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SAVE TIME, NO MORE RETYPING!

Congratulations on acquiring Readiris. This software package will undoubt-
edly be of great help in recapturing your texts and tables.

As efficient as computers are, you have to key in your information first. If you
have ever retyped a 15 page report or a large table of figures, you know how
tedious and time-consuming it can be. Use this state-of-the-art OCR package to
automatically enter text in your applications and you'll acquire an unprecedented
level of efficiency and comfort!

Scan a printed or typed document, indicate the zones of interest - or have the
system detect them for you - and execute the character recognition. Documents
composed of many pages are processed from start to finish in a single effort. A
few mouse clicks beat long hours of work as Readiris converts your paper docu-
ments into editable computer files: it's 10 to 25 times faster than manual retyping.

With the automatic mode of operation, the user's effort is reduced to a single
click: he initiates the scanning and saves the text result, all intermediate steps are
taken care of by Readiris. The wizard guides you through the OCR process
comfortably: answer a few simple questions and you'll obtain quick and easy
results with Readiris. Not only can you send the reading results directly to your
wordprocessor and spreadsheet, thanks to the “Connect” capability, you can even
access the OCR function from within your favourite Windows applications! To
recognize faxes, you can drag the fax files from the Windows Explorer to the
Readiris application window.

Readiris recognizes tabular data and recreates them as worksheets or as table
objects inside your wordprocessor; your numeric data are immediately ready for
further processing.

Based on the Connectionist technology from I.R.I.S., Readiris represents the
best OCR has to offer. Font-independant feature extraction is complemented by
self-learning techniques derived from a proprietary neural network. The system
can learn new characters through context analysis: linguistic knowledge about
syllables and words improves the OCR performance.
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Readiris supports up to 55 languages: all American and European languages
are supported, including the Central-European languages, Greek and the Cyrillic
(“Russian”) languages. (Optionally, you can read Japanese and Simplified Chi-
nese.) Readiris even copes with mixed alphabets: the software detects “West-
ern” words that pop up in Greek, Cyrillic and Asian documents - many untranscrible
proper names, brand names etc. are written using the Western symbols.

Readiris uses linguistics during the recognition phase, not after it. As a direct
result, Readiris recognizes documents of all kinds with top accuracy, including
low-quality documents, faxes and dot matrix printouts. It copes beautifully with
badly scanned and copied documents containing too light or dark font shapes.
Joined characters (“ligatures”) are resolved and fragmented forms, such as dot
matrix symbols, are recomposed.

User verification in pop-up style not only flags doubtful characters but also
increases the system's precision. All solutions confirmed by the user are memo-
rized, increasing speed and confidence as you go along. Using Readiris means
rendering it more intelligent each time! This powerful learning tool allows you to
train Readiris on special characters such as mathematic symbols and dingbats
but also to handle distorted fonts as you will find in real documents.

To increase your productivity further, Readiris not only recognizes your texts,
but can format them for you as well! Make use of “autoformatting” and Readiris
recreates a facsimile copy of the scanned document: the word, paragraph and
page formatting of the original document are retained. Similar typefaces are used,
the point sizes and typestyles as used in the source document are maintained
across the recognition. The placement of columns, text blocks and graphics fol-
lows your original documents. When a document contains tables, Readiris reor-
ganizes them in real cells and recreates the cell borders of the original tables.

In other words, Readiris allows you to archive a true copy of your documents,
be it editable and compact text files instead of scanned images! Various levels of
formatting are available, the choice is up to the user.

Readiris supports a wide range of popular scanners: numerous flatbed scan-
ners, sheetfed scanners, hand-held scanners and “all-in-one” multifunctional pe-
ripherals (“MFPs”) can be used. Readiris also supports the Twain scanning stan-
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dard and some scanning platforms such as Visioneer PaperPort or HP Docu-
ment Assistant.
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Chapter 1
I N S T A L L A T I O N

This chapter discusses the system requirements and installation of the Readiris
software.

SYSTEM REQUIREMENTS

This is the minimal system configuration required to use Readiris:
q a 486 based Intel PC or compatible. A Pentium based PC is recom-

mended.
q 16 MB RAM. 32 MB RAM is recommended under Windows NT and

to make use of the “Connect” capability.
q 30 MB free disk space. 25 MB of disk space suffices when you leave

the electronic manual on the CD-ROM.
q the Windows 98, Windows 95 or Windows NT 4.0 operating system.

Note that some scanner drivers may not work under Windows NT! Refer to
the documentation supplied with your scanner to see which platforms are sup-
ported.

INSTALLING THE READIRIS SOFTWARE

The Readiris software is delivered exclusively on an autorunning CD-ROM.
To install, simply insert the CD-ROM in your CD-ROM drive and wait for the
installation program to start running. Follow the on-screen instructions.

Should the installation not begin to run when the CD-ROM is inserted in your
CD-ROM drive, run the setup program menu.exe to install the software.



1 - 2

Users of Windows NT must ensure that they have the necessary access
rights - contact the system administrator if necessary.

Some installation options are offered. Be sure to install the linguistic data-
bases of all languages you intend to read. By default, all lexicons are installed.
You are recommended to install the sample images which are used in the tuto-
rials of this manual.

Similarly, the electronic manual is by default copied to your hard disk. You
can also leave it on the CD-ROM. It is supplied in the Adobe Acrobat PDF
format. Be sure to install the Acrobat Reader software required to access the
software documentation, should this be necessary.
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The submenu "I.R.I.S. Applications - Readiris" under the "Programs" menu is
created automatically by the installation program.

COMFORT ISN'T LAZINESS!

Some additional steps can be completed for maximal ease of use of Readiris.

It may be useful to create a shortcut. The Windows documentation and on-
line help discuss several methods of creating shortcuts. One easy way of pro-
ceeding is by dragging the Readiris application from the Windows Explorer to
your desktop.
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As a result, you'll be able to start the Readiris software directly from your
desktop.
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INSTALLING THE “CONNECT” CAPABILITY

Installing the “Connect” capability implies some manual steps which no in-
stallation program can take care of.

The information needed to install the “Connect” capability can be found in the
Readiris on-line help system and in the file CONNREAD.DOC.



1 - 6

For optimal comfort, the “Read Me” file on the “Connect” capability is dis-
played automatically at the end of the installation program, otherwise it is avail-
able under the Readiris folder.
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UNINSTALLING THE READIRIS SOFTWARE

There are only two correct ways of uninstalling Readiris: using the Readiris
“uninstall” program and using the Windows (un)install wizard. You are strongly
recommended not to uninstall Readiris or its software modules by manually eras-
ing the program files.

Readiris “uninstall” program
Select "Uninstall Readiris" under the submenu "I.R.I.S. Applications - Readiris"

to start the Readiris “uninstall” program and follow the on-screen instructions.

Windows (un)install wizard
Execute the following steps to make use of the Windows (un)install wizard.
q Click "Settings" under the "Start" menu of Windows and go to the "Con-

trol Panel".
q Click the icon "Add/Remove Programs" under the control panel.
q Readiris is listed under the "Install/Uninstall" tab.



1 - 8

q Select Readiris and click the "Add/Remove" button to remove the
Readiris software.

q Follow the on-screen instructions.
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INSTALLING SOFTWARE OPTIONS

There's a single software option available for the Readiris software: the Asian
OCR “add-on”. It allows you to read Japanese and Simplified Chinese. This
software is again delivered on an autorunning CD-ROM.
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INSTALLING RELATED PRODUCTS

Depending on the software bundle you acquired, Readiris may be supplied
with an evaluation version of the related product Cardiris, a card organizer.

If this free software package is included on your Readiris CD-ROM, it is also
installed using the autorunning CD-ROM and following the on-screen instruc-
tions.
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Contact I.R.I.S. to learn more about complementary software; the command
"Contact I.R.I.S." under the "Help" menu of Readiris details in which ways you
can get in touch with I.R.I.S.
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INSTALLED FILES

The installation program has created a folder where the Readiris files are
located. Never try to uninstall Readiris or some of its modules by manually eras-
ing the program files, use the Readiris “uninstall” program or the Windows
(un)install wizard instead. See above.

Read Me files and documentation
README.DOC General “Read Me” file

CONNREAD.DOC “Read Me” file on “Connect” capability
Depending on the software bundle you acquired, the Readiris CD-ROM may

contain some additional “Read Me” and Acrobat PDF files - these files are not
installed on your hard disk!

They discuss how to set up the multilanguage support of Windows - this Win-
dows “service pack” is mandatory to recognize “exotic” languages such as Greek
and the Cyrillic languages - and the “Twunk” (“Twain thunk”) software utility to
solve some problems with Twain drivers.

You may also find specialized manuals concerning the scanning platforms
Visioneer PaperPort and Microtek PageSuite on the CD-ROM.

Scanner drivers
Finally, you may find some scanner drivers on the Readiris CD-ROM under

the folder “Drivers”.

I.R.I.S. offers no guarantee that drivers are supplied for your scanner model
or that the drivers supplied on the Readiris CD-ROM will work (well) with your
scanner model.

Don’t hesitate to contact your scanner manufacturer or its representative should
problems with scanner drivers continue. Most manufacturers allow you to down-
load the latest versions of the scanners drivers from their web site.
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User files
The user can create font dictionaries, zoning layouts and settings files.

*.DUS Font dictionaries

*.WDW Windowing templates

*.IBT Readiris settings

REGISTER TO VOTE!

Don’t forget to register your Readiris licence! Doing so will allow us to keep
you informed of future product developments and related I.R.I.S. products. The
registration benefits, including free product support and special offers, are strictly
limited to registered users.

You can register in many ways: by sending in your registration card or faxing
its electronic counterpart, by calling I.R.I.S. during working hours and by filling
out a registration form on the I.R.I.S. home page!
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The Readiris registration wizard as you'll find under the menu "Register" of
the Readiris software can guide you through the registration process comfort-
ably.

Depending on the software version you acquired, you'll receive the softkey in
return as may be needed to continue using the Readiris software after one month.

GETTING PRODUCT SUPPORT

The command "Product Support" under the "Help" menu of Readiris details
how you can get technical support. Please describe the phenomenon you experi-
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ence clearly and include all relevant data concerning Readiris, your scanner and
your computer system.
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Chapter 2
GUIDED TOUR

Readiris is a state-of-the-art OCR package equipped with numerous advanced
features. We will discuss all major features in this chapter and add many tips and
hints concerning the use of Readiris.

STARTING THE SOFTWARE UP

Click on the Readiris application in the submenu "I.R.I.S. Applications -
Readiris", or click on the shortcut to the Readiris application on your desktop.

The Readiris startup screen and application window are displayed. The startup
screen displays the version and copyrights of the Readiris software. Clicking the
mouse anywhere makes this screen disappear.
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The next window concerns the OCR wizard; click Cancel for the time being.

THE FIRST-TIME STARTUP

Depending on the software bundle you acquired, the first startup may be spe-
cial: you may be prompted to register your licence.

If this is the case, the use of Readiris is limited to 30 days, and by registering,
you receive a free softkey from I.R.I.S. to continue using the software after the
first month.

It takes your identification number to generate the softkey; be sure that this
number is available or mentioned when you register your licence.
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DISCOVERING THE READIRIS INTERFACE

The Readiris application window not only contains command menus but also
two button bars that give quick access to all frequent commands. Initially, some
command menus are dimmed: they concern the preview. As long as no image is
opened, they are unavailable.
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The same goes for the image toolbar on the right side of the application
window: it contains all commands you need during the image preview. The main
toolbar on the left gives quick access to all frequent general commands.

To learn which command corresponds to a certain button, hold your mouse
pointer over it for a while: a tooltip will tell you what the button does.
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The window pane or image zone is where the scanned images are displayed.
You can drop image files onto the image zone to recognize them.

When multipage documents are processed, an additional toolbar, the page
toolbar, is added below the image zone: it represents the various pages of the
document and gives access to the page commands using the right-click (the "Con-
text" menu).

GETTING STARTED WITH A FIRST TUTORIAL

The best way to become familiar with the operation of Readiris is undoubtedly
by using it. A number of prescanned images is provided with the software;
they allow you to get started even when there is no scanner connected to your
computer. Let’s turn to these now.

The "Source" button on the main toolbar determines whether you are going to
use a scanner or a prescanned image as image source. Readiris allows you to
open TIFF images (uncompressed, packbits, Group 3 and Group 4 compressed),
multipage TIFF images, Paintbrush (PCX) images and Windows bitmaps (BMP).
Only black-and-white images are supported. This capability is particularly useful
to convert your faxes into editable text files.

As you are going to open a prescanned image, you should select the disk, and
not the scanner, as image source with the "Source" button.

      

Next, click the "Open" button. (When you select the disk as image source, the
"Scan" button is replaced by the "Open" button and the corresponding "Scan"
command under the "Process" menu is replaced by the "Open" command.)
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You could also select the command "Open" from the "File" menu and open a
prescanned image directly - this works even if your scanner operates as current
image source.

You are invited to select an image file. Select the file ENGLISH.TIF in the
Readiris folder. The image is read from disk and displayed in the image zone
progressively.
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A third way of opening prescanned images is the use of “drag and drop”:
drag an image from the Windows Explorer onto the Readiris image zone and it is
opened promptly.

The image toolbar on the right side of the Readiris application window con-
tains all commands you need during the image preview: tools to indicate the zones
of interest, to rotate the image, zoom in and out etc.

ZOOMING IN ON IMAGES

Readiris has several commands that allow you to zoom in on the scanned
image, for instance to verify the scanning quality.

The image toolbar contains buttons that allow you to zoom in at real size, to fit
the image to the page width and to fit the entire image in the preview window.
The "View" menu contains the same commands and adds two extra zoom levels:
you can display the image at 50% and 200% of its actual size. At actual size, a
screen pixel corresponds to an image pixel. (Shortcuts are available for all zoom
levels!)

                

Finally, you can right-click the mouse button over a region of the scanned
image to zoom in at real size immediately. Right-click a second time to zoom out
again.
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ONE, DECOMPOSING A SCANNED IMAGE

Now that the image is scanned, you have to indicate which parts you want to
convert into editable text by drawing frames, so-called “windows”, around the
zones of interest.

Actually, Readiris will do this for you automatically when the option "Page
Analysis" is enabled on the main toolbar.
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Automatic page decomposition is particularly useful when columnized texts
and documents with a complex page layout, possibly including graphics and tables,
are recognized.

Page decomposition uses three window types: text, graphic and table win-
dows. Readiris discriminates text blocks, tables and graphic zones containing
photos, illustrations etc. on the page. (Saving graphics and recognizing tables will
be discussed at great length below.)

A color code indicates the window type: text zones are yellow, graphics are
blue and tables are purple.
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The number of windows is indicated at all times in the tooltips of the "Text
Window", "Graphic Window" and "Table Window" tools.

                  

Page analyisis is fast, skew-tolerant and highly accurate: it traces complex,
“irregular” shapes.

The page analysis will even detect zones where you get white text on a
black background. Recognizing such inserts is no problem: while the preview
displays the scanned document correctly on-screen, Readiris “inverts” the image
when the need arises to recognize such text blocks! (You can have your scanner
generate fully inverted images to process pages with white text on a black back-
ground. See below.)

ONE AND A HALF, SORTING WINDOWS

Readiris not only detects the various blocks, but also sorts them: the zones are
sorted top-down, left to right by default to cope with columnized documents.

Evidently, you can modify the sort order. To do so, click the "Sort" button on
the main toolbar. The mouse cursor becomes a pointing hand as soon as the “sort
mode” is enabled.

Click on the windows you want to include. Windows you do not click on are
simply ignored, excluded from recognition. It's easy to see which windows are
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selected and which aren't: the selected windows have their full color, non-se-
lected windows have a lighter color tone.

Page analysis is enabled by default. To force Readiris to decompose the cur-
rent page - because you disabled page analysis by accident, because you erased
some windows erroneously and want to redo the page analysis etc. -, you can
simply click the button "Analyze Page" in the image toolbar.

(Select the document language before executing the page analysis when you
are dealing with Asian documents. Specific routines are used for these languages:
the interline spacing of Asian documents is in most cases bigger than in Western
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documents, the text is made up of small icons (“ideograms”) that could easily be
seen as graphic zones in Western documents and the text may run from top to
bottom, from right to left.)

TWO, WINDOWING A SCANNED IMAGE MANUALLY

Page analysis is the automatic way of windowing a scanned page. Alterna-
tively, you can zone an image manually with the windowing tools of Readiris.

To create a rectangle around a zone of interest, select the corresponding tool
in the image toolbar, click the cursor in the upper left corner of the window,
stretch the window by moving the mouse to the lower right corner and click
again. (Sides smaller than 1 mm are not allowed, they wouldn't even contain a
single character anyway.)

The windows are automatically sorted in the order of creation: arrows indi-
cate the sort order.

You can also frame “irregular” text blocks by drawing polygonal windows
around them. Non-rectangular windows are created by merging rectangular zones:
as soon as two rectangles (of the same type) intersect, they become a single
window automatically! In a way, you're building a house by adding one room
after the other... (Creating polygonal table windows doesn't make any sense.)
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Furthermore, manual windowing can be combined with window sorting: you
can draw new windows even when the “sort mode” is enabled. You then use
sorting to include a number of detected windows and manually create some other
windows where the page analysis didn't yield the appropriate results. As soon as
you start creating windows in the “sort mode”, all windows you didn't select are
promptly erased!

To modify, move and delete windows, you need to select them first. To do so,
select the "Window Selection" or “arrow” tool in the image toolbar and click
inside a window. Rectangular markers now appear at each corner and in the
middle of the window sides.
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To unselect windows, click the mouse button elsewhere. To select addi-
tional windows, hold down the Shift key while clicking on these extra windows.
To select a window and the included windows (of another type), hold down the
Ctrl key while clicking on the main window.

You can display the type, pixel coordinates and sort order of a window by
pressing the Alt key while you select it!

So much for selecting windows. To modify a window, select it, put your mouse
cursor over a marker and drag the side to change the window size.

To move a window, simply select it and drag it to another location.
To delete windows, select the window(s) and choose the "Cut" or "Clear"

command from the "Edit" menu. The "Cut" command cuts the window(s) to an
internal buffer, "Clear" erases the window(s) irretrievably. When you paste win-
dows, they are inserted in their original position, and you have to drag them to
their new location.

In fact, all familiar commands from the "Edit" menu apply to the windows:
you can delete, cut, copy and paste them! The "Undo" command also applies: if
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you have unfortunately deleted, moved, resized etc. some windows, "Undo" will
cancel the last operation.

Also note that shortcuts are available for all commands! Let's give an ex-
ample: to erase all existing windows, you can choose the command "Select All"
or its shortcut Ctrl+A and click the command "Clear" or its shortcut Delete. You
are now ready to recreate the necessary layout. To restore the previous layout,
you can choose "Undo" or the shortcut Alt+Backspace.

THREE, SAVING WINDOWING TEMPLATES

The resulting windowing layouts can be saved as zoning templates for fu-
ture use with the command "Save Layout" under the "File" menu and loaded into
memory with the command "Load Layout".

If you have to recognize documents with a similar layout, for instance a 50
page report where the header and footer should be excluded for obvious reasons,
a single template can be applied to zone all 50 pages.

When you load a template into memory, page analysis is disabled automati-
cally. The zoning template remains active until you re-enable page analysis on the
main toolbar.
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READIRIS TAKES YOU AROUND THE WORLD

Assuming that the windows are correctly defined, you are now almost ready
to execute the character recognition. We say “almost”, because we haven’t veri-
fied the language and document settings yet.

The language setting can be found on the main toolbar.

Click the "Language" button to modify the document language.

You can press a letter key to move to it directly: if English is currently se-
lected, and you want to select Hungarian, you can click the "H" key on your
keyboard to go directly to the Hungarian language. When several languages have
the same initial, press the letter several times to go through the options. Let's give
an example: Readiris reads Polish and Portuguese. By pressing "P" once, you
select Polish, by pressing "P" a second time, you select Portuguese, and by press-
ing "P" a third time, you're back on Polish. (To go to another letter, say T, press
BackSpace before you enter the "T" character.)
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Readiris is far from limited to English: up to 55 languages are supported! All
American and European languages are supported, including the Central-Euro-
pean languages, Greek, Turkish, the Cyrillic (“Russian”) and the Baltic languages.

Optionally, you can read Asian documents: the extra module “Asian OCR
add-on” offers recognition of Japanese and Simplified Chinese. Traditional Chi-
nese is not supported. (Simplified Chinese is used on China’s mainland, where
Traditional Chinese is used by the “Big 5” communities - Hong Kong, Taiwan,
Singapore etc.)

Also note that the British and American - or should we say “international”? -
variants of the English language are distinguished.

It takes the appropriate Windows configuration to display Central-European,
Greek, Turkish, Cyrillic and Baltic characters. You may have to install the Win-
dows “service pack” "Multilanguage Support" before your Windows system is
able to cope with these languages. Select the icon "Add/Remove Programs" un-
der the "Control Panel" to find out if this Windows module is installed  on your
PC. Depending on the software bundle you acquired, the Readiris CD-ROM
may contain detailled information on how to install this Windows module.
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To view and edit Asian documents, you can install an Asian, Japanese or
Chinese version of the Windows operating system or run specialized “emulating”
software (such as UnionWay AsianSuite or TwinBridge AsianBridge) on a West-
ern version of Windows to correctly represent the ideograms of these Asian
languages.

Selecting the proper document language is imperative. Based on the selection
of a language, the software knows which symbol set to recognize. Multi-linguis-
tic support ensures that “exotic” characters such as ç, ß, ñ, γ and ø are recog-
nized correctly.
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Secondly, the software extensively uses linguistic databases to validate its
results. Suppose that you have to read the word "president" where an ink stain
makes the "r" look like an "f". Looking things up in the English lexicon, Readiris
will detect autonomously that the word "president" is being read and that it doesn't
make any sense to recognize the symbol "f". This “self-learning” technique is
of course highly dependant on the linguistic context.

Linguistics offer useful help to solve ambiguous cases such as an "O" which
might be mistaken for a '0'. Another typical example is the letter "l" and number
'1' which have an identical form in many fonts - think of texts produced on old
typewriters! The linguistic context helps to determine whether you are dealing
with "l" or '1'.

The illustration below shows various shapes of '1' and "l". The shapes on the
first line are unambiguous, the shapes on the second line are ambiguous, but
linguistics can solve them. When the context does not suffice, the user inter-
venes.

READIRIS CHANGES LANGUAGES AS NEEDED

But the buck doesn't stop here: Readiris can switch languages in the middle of
a sentence without any help from the user! When Western words pop up in
Greek, Cyrillic or Asian documents - many untranscrible proper names, brand
names etc. are written using the familiar Western symbols -, Readiris can switch
to the correct alphabet automatically. In other words, you can activate a mixed
alphabet of Greek, Cyrillic or Asian and Western characters.

Be sure to select "Greek-English" or the appropriate Cyrillic language setting
- for instance "Byelorussian-English". In other words: don’t try to just select
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"Greek" or "Byelorussian" as document language and hope that the Western sym-
bols will come out fine!

        

Here’s an example where a Russian text contains some English words - open
the image file ALPHABET.TIF if you want to try it for yourself!

The end result looks like this when opened with the wordprocessor - you may
have to select a Cyrillic font to display the Russian text correctly.
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To mix other languages, simply select the language with the most extended
character set. If you have a document where the, say, French translation is placed
alongside an English text, you have to select French as language to ensure that
the accentuated characters such as ç, é and ù get recognized correctly.

DEFINING THE DOCUMENT CHARACTERISTICS

Now that the language is set, we’ll turn to the other document characteristics.
You can fine-tune the recognition by specifying some document features: the font
type and character pitch. (These commands do not apply to Asian documents.)
Let’s clarify what this means.

First of all, indicate whether you are recognizing “normal” or dot matrix
printed documents with the command "Font Type" under the "Settings" menu.
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Setting this parameter correctly is mandatory: “draft” or “9 pin” dot matrix
symbols are made up of isolated, separate dots, and highly specialized recognition
routines are required to recognize them.

“Letter quality” dot matrix printing, also called “25 pin” or “NLQ” dot matrix,
requires the normal setting, as do the printing qualities typeset, typewritten,
laser printed and inkjet printed. Obviously, "Normal" is the default value.

The font type is indicated in the tooltip of the "Recognize" button: when no
message is added to the tooltip, the “normal” printing quality applies, when the
message "Dot Matrix" shows up in the tooltip, the dot matrix reading mode is
enabled.

The character pitch can be set with the command "Character Pitch" under
the "Settings" menu.

With fixed or “monospaced” fonts, all symbols of the font have the same
width. An "i" takes up as much horizontal space on a line as a
"w", as is the case in this sentence. Think of documents produced
using a typewriter, where the carriage moves a fixed distance for each typed
symbol.

A proportional pitch means that the width of a character depends on its
shape. Symbols like “m” and “w” are wider, take more horizontal space on a line
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than the “thin” characters “l” or “j”. Virtually all books, magazines and newspa-
pers are printed in proportional pitch.

The simplest solution is to leave this option at all times on the default value
"Auto", which means that Readiris will detect the character pitch automatically.

READIRIS GETS MORE INTELLIGENT EACH TIME!

When the document language is selected and document characteristics are
set, you can click the "Recognize" button.

The OCR progress is indicated on-screen. You can click the "Stop" button to
abort the text recognition.
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At the end of the recognition, Readiris enters the interactive learning phase
when the learning is enabled with the "Learn" button on the main toolbar. Interac-
tive learning is enabled by default.

(Interactive learning does not apply to Asian documents: learning does not
make sense for these languages which use thousands of different symbols - and
you’d have to be able to enter the ideograms, not an easy task when using a
Western keyboard!)

      

Font training can substantially enhance the accuracy of the recognition sys-
tem. When the user tries to read distorted, defaced forms as are found in real
documents or stylized font shapes which Readiris does not recognize optimally,
training can overcome this temporary “failure”.

User learning is also used to train the system on special symbols which
Readiris is unable to recognize, such as mathematical and scientific symbols and
dingbats. Some examples: Readiris can be trained to recognize the "π" symbol as
"pi" or the dingbat "(" as "Tel". (However, the list of recognized symbols cannot
be extended with the symbols "π"and "("!)

The recognized text is displayed progressively and the system stops on doubt-
ful characters, or - if you are dealing with touching characters (“ligatures”) - on
doubtful character strings. They are always presented in their context, the doubt-
ful characters are highlighted. Unrecognized characters are represented by a
tilde (the "~" symbol).
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First thing you should do is verify if you activated the correct font dictionary
and dictionary mode - these are always indicated in the title of the learning win-
dow. If that is not the case, click the "Abort" button - the document image is
redisplayed with the zoning as was created - enable the right font dictionary or
dictionary mode and run the OCR again. (The operation of font dictionaries will
be discussed shortly.)

If necessary, enter a character (or character string) for the incorrect or un-
known shape and click one of the following buttons.

Learn
You agree with the proposed solution or correct it. The program saves this

doubtful character in the font dictionary as “sure”, final. Future recognition will
no longer require your intervention, the shape is considered learnt once and for
all.

In the example above, the system stops on a soiled character, and we click
"Learn" to accept a shape which cannot be confused with other characters.
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Don't Learn
You agree with the proposed solution or correct it. The difference with the

"Learn" button is that the learnt symbol gets the status “unsure” in the dictionary.
For future recognition, the system will propose the learnt solution but still require
a confirmation.

This button is used for symbols which might be confused with others: a de-
faced "e" which might be mistaken for a "c", a damaged "t" which closely re-
sembles an "r" etc.

The "s" above is seriously damaged - in fact it is close to the "£" symbol -, and
you should click "Don't Learn" so as not to confuse it with the pound symbol.

Delete
The displayed form is eliminated from the output. This button is used to ignore

“noise” on the documents - spots, coffee stains etc. - which might get recognized
as points, comma’s and what have you -, and to erase any other unwanted sym-
bol.



2 - 27

USER'S GUIDE

Undo
You go back to correct mistakes. You can undo the nine last decisions.

Finish
The learning process is aborted but the OCR continues in automatic mode. All

decisions by the system thereafter are accepted without user validation.

Click this button when you see that the recognition is highly accurate and does
not require detailled proofreading.

Don't confuse "Finish" with the "Abort" button: with "Abort", no output is gen-
erated and you start all over, with "Finish", the text is created, it just isn't proof-
read in detail!

THE ROLE OF FONT DICTIONARIES

The results of each training session are temporarily held in the computer’s
memory but can and should be stored in files called “dictionaries” for future use.

These font dictionaries should be loaded into memory when you want to rec-
ognize similar documents in order to make use of the extra intelligence they con-
tain; in this way, Readiris takes into account the intelligence stored in these font
libraries. You could say that Readiris gets more intelligence each time you use it!

How does this work? The operation of font dictionaries is controlled by the
"Learn" menu: you have to select a dictionary with the command "Font Dictio-
nary" and determine its mode of operation.
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Font dictionaries are limited to 500 shapes, and you are recommended to
create separate dictionaries for specific applications, for instance per type of
document. For clarity, you are recommended to give meaningful names to the
font dictionaries, for instance REPORT.DUS, PALATINO.DUS etc. Dictionar-
ies have the default extension *.DUS. Training no longer has effect when the
dictionary is full: the results of the learning are no longer held in memory or
written to a dictionary.

You can set the dictionary mode inside the command "Font Dictionary" or
directly under the "Learn" menu. Three dictionary modes are available: new,
append and read.
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By selecting "New Font Dictionary", you indicate that the training results will
be saved in a new dictionary. (If you select an existing dictionary, its contents will
be erased.)

The append mode indicates that the training results will be saved in an exist-
ing dictionary: the recognition makes use of the extra intelligence already con-
tained in the dictionary, and you add new font shapes to it. In simple terms, this
option allows you to build up a font dictionary in several steps.

(When you enter a filename for a new dictionary and activate the “append”
mode, an empty font dictionary is created and you complete it.)

With the last option, "Read Font Dictionary", the dictionary functions in read-
only mode: you make use of the dictionary without adding new font shapes to it.

Select the new mode when a single page is recognized. To recognize many
pages of the same type - pages with the same fonts and printing quality - select
the new mode for the first page, the append mode for a few pages more and the
read mode for the rest of the document(s). When multipage documents are rec-
ognized, scanning a next page automatically puts the user dictionary in the ap-
pend mode.

Know that the tooltip of the "Learn" button indicates at all times which font
dictionary is currently active and in which mode that dictionary operates.
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When you enter the interactive learning, the dictionary and its operating mode
are indicated in the window title; you should click the "Abort" button and start
over in case they are wrong.

SENDING THE RESULT DIRECTLY TO YOUR APPLICATION

The interactive training concludes the character recognition. As Microsoft
Word 97 operates as output target by default, your wordprocessor is started up
automatically at the end of the recognition (if necessary) and the recognized text
is inserted.

The scanned image is displayed again with the zoning as created to be avail-
able for further processing, it stays there until you scan another page.

You have indeed converted a paper document into an editable computer file,
be it 10 to 25 times faster than manual retyping! Go ahead and compare it with
the image you have inside your Readiris window.

Actually, Readiris offers three different methods when it comes to saving the
OCR result: sending the recognized document directly to a target application,
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saving the result in an external file and copying the result to the Windows clip-
board.

The output target is selected using the "Format" button on the main toolbar
(or the command "Text Format" under the "Settings" menu).

The "Send to" feature offers a direct OCR link between your scanner and
your Windows applications: you send the scanned documents directly to your
wordprocessor or spreadsheet! Readiris exports recognized documents directly
to Microsoft Word 97, to Microsoft Excel and the Windows accessory WordPad.



2 - 32

At the end of the recognition, the target application is started up and the rec-
ognized document is opened inside a new text file or worksheet.

Don't forget that the option "Send to" also allows you to copy the recognized
text to the Windows clipboard, so there is no strict need to export the result... or
save it to an external file!

SAVING THE RESULTS IN A TEXT FILE

You can indeed write the OCR result to an “external” file. Readiris supports a
wide range of file formats incorporating all popular wordprocessors and spread-
sheets - Microsoft Word (DOC), RTF and HTML etc.
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When you select the option "External File", you are prompted to save the
recognized text at the end of the recognition phase.
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You can create a new file and append an existing text file - that's why you
have an "Append" option. You could for instance add two scanned pages of text
to a study which you wrote yourself. If you append an existing file, be sure it isn't
currently open, because that will prevent you from writing to it!
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RECOGNIZING MULTIPLE PAGES

When you click "Save" to save the text, the system prompts you to read an-
other page or not. (If you send the recognized text to a target application or the
clipboard, you obviously won't be prompted to save the text.)

At this stage, some brief statistics are given on the number of characters
you've just read.

You can now open the recognized text with your wordprocessor or text editor,
import it into your desktop publishing software or any other text-based applica-
tion.

But how do you save the text of the additional pages? Or in other words: how
do you process documents consisting of multiple pages? It's actually very simple:
click "Next Page" when you are prompted to read another page. When you do so,
another page will be scanned promptly if your scanner functions as image source.
Secondly, the output file and font dictionary are put in the append mode automati-
cally so that you can append the text and continue the font training comfortably.

You can go on recognizing other pages: the new text is appended to the text
file each time you save after the recognition.

But there's a more efficient way of recognizing several pages than scanning
and OCRing them one after the other: processing multipage documents di-
rectly!
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To scan a document composed of several pages in one operation, enable the
document feeder of your scanner with the option "ADF" under the "Scanner"
button.

       

Place the pages of your document in the automatic document feeder and start
the scanning: all pages are scanned until the document feeder is empty.

You can also open multiple prescanned images. To load several images, se-
lect the first image and hold down the Ctrl key as you select additional images. To
load a continuous range of images, select the first image and hold down the Shift
key as you select the last image.

     

You can even drag several prescanned images from the Windows Explorer
onto the Readiris window!
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As soon as a multipage document is loaded into memory, an additional toolbar,
the page toolbar, is added below the image: it represents the various pages of
the document and gives access to the page commands (using the right-click).
The current page is highlighted in the page toolbar and mentioned in the Readiris
title bar.

When you start the recognition, the various pages are displayed one after the
other; the Readiris title bar and the OCR progress bar indicate the page number.
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If the interactive learning is enabled, you go through the recognition and learn-
ing phases page by page. The dictionary mode "New" is used for the first page
and the mode "Append" for the successive pages.

(When you click the "Finish" button, all decisions by the system thereafter are
accepted without user validation. In other words, the interactive learning is aborted
for all pages; the OCR for this document continues in automatic mode.)

The recognition result of multipage documents is saved in a single output file.
When the recognition result is sent to a target application, multiple pages get
created inside a single document.

EDITING MULTIPAGE DOCUMENTS

The user can edit multipage documents, mainly to correct scanning errors: he
can delete pages from the document and move pages to other locations in the
document.

The navigation first. To go to a page, click on its icon in the page toolbar or
hold your cursor over its icon, invoke the "Context" menu by right-clicking and
use the command "Select Page".

Let's edit the document now. To delete a page from the document, hold your
cursor over its icon, right-click it and use the command "Delete Page". To move
a page up in the document, use the command "Move Page Up", and to move a
page down, use the command "Move Page Up".

Note above all that the commands from "Context" menu apply to the page
under your mouse cursor, not to the selected, highlighted page!
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ORGANIZING THE TEXT OUTPUT

Saving or exporting the text means more than selecting an output method or
defining a filename for the output file. You also select a file format and determine
the appearance of the recognized text. In short, you have to decide where you
want to take the text before you launch the execution.

Some options of the "Format" button allow you to influence the look of the text
output.

The text flow of the output document is directly influenced by the option
"Merge Lines into Paragraphs" as you'll find under the "Format" button.

Keep this option enabled to have Readiris detect the paragraphs: Readiris will
then apply the normal wordwrap typical of wordprocessors, otherwise, a car-
riage return is added after each line and hyphenated words remain so! Paragraph
detection is enabled by default.

Let’s give an example to clear things up. When the first three lines of a col-
umn are "The new presi-", "dent waved from the balcony." and "His wife had
joined him.", the paragraph detection gives you the following result: "The new
president waved from the balcony. His wife had joined him." The hyphenated
parts of the word "president" were “reglued” and a space was added at the end
of the first sentence, thus creating naturally flowing text.

Had paragraph detection not been enabled, the original layout would have
been retained, with a carriage return added at the end of each line.

(The "Format" button contains some formatting options we haven't discussed
yet - this will be done shortly.)



2 - 40

SETTING UP YOUR SCANNER

Let's set our scanner up now. It is assumed that the scanner hardware and
necessary drivers are installed correctly.

If your Readiris software licence was bundled with a scanner model, this step
probably is unnecessary as your scanner may already be set up under Readiris.

Click the "Scanner" button on the main toolbar.

Click the button "Scanner Model" to determine your scanner model.

When you select the option "<Image>" as “scanner”, prescanned images func-
tion as image source at all times - you won't have even to select the disk as image
source with the "Source" button on the main toolbar.

The "Config." button is only available when you scanner allows it. It gives
access to some advanced scanning parameters; with Twain scanners, clicking
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the "Config." button allows you to select the Twain source. (You can also use the
command "Select Source" under the "File" menu.)

Your scanner may also come with a scanning platform such as Visioneer
PaperPort or HP Document Assistant. Depending on the software bundle you
acquired, you may find specialized manuals concerning the scanning platforms on
the Readiris CD-ROM.

Once the scanner is selected, the same window may allow you to set the
scanning resolution, the page format and orientation, brightness and contrast and
may allow you to indicate whether you are going to use the scanner's document
feeder. With Twain compliant scanners, all scanning parameters are often set
within the Twain interface.

Select a resolution of 300 dpi for normal applications, use a higher resolution
of 400 dpi for small print (below 10 point) and when the document is very de-
graded.

Readiris reads point sizes of 6 to 72 point (0.08 to 1" or 0.21 to 2.54 cm).
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Readiris also recognizes “drop letters”, large caps that cover several lines.
(These can of course be no bigger than 72 point!)

By enabling the option "Landscape", you indicate that the selected page orien-
tation is wide (“landscape”) instead of tall (“portrait”). The page orientation actu-
ally applies to reduced page formats: on an A4 flatbed scanner, you can scan, say,
A5 pages (half that big) in portrait or landscape format, but you can obviously
only scan the full A4 surface in one direction!

Whenever you need to adjust the page orientation, you can use the rotation
tools on the image toolbar. (Corresponding commands are found under the "View"
menu.)
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Three rotation directions are available: to the left, to the right and upside down.
Rotation takes a few seconds as the image itself is updated, not just the display
on-screen.

Set the brightness, and, if available, the contrast. The contrast setting is
only available on some scanners. Drag the trackbar to darken or brighten the
document; the selected values are represented numerically.

Finally, the option "Invert" allows you to generate “inverted” images - acti-
vate this option to process full pages with white text on a black background.

SAVING DEFAULT SETTINGS

Set all scanning parameters correctly and click the command "Save Default
Settings" under the "File" menu to save the current settings as default settings for
future use.

Settings files contain more than the scanner settings: they also determine
whether you are going to use interactive learning, which font dictionary is used
(and its mode), which language and font type - for instance a normal, proportional
font - the documents have, which output mode and layout options are used - for
instance body text sent to WordPad - etc. In short, all operational settings of
Readiris are stored in the settings files.
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SAVING SPECIFIC SETTINGS

The default settings will obviously be used at each startup, but you can save
specific settings as well to avoid having to redefine the operational parameters.
The commands "Save Settings" and "Load Settings" under the "File" menu take
care of this.

Let’s give an example: if you regularly have to OCR English documents with
a specific layout, you are recommended to create a settings file for this type of
document. You would then select "English" as the document language, load a
specific zoning template to avoid having to reapply the same windowing each
time, disable learning but activate a font dictionary in the “read” mode because
the same typefaces are used systematically etc.

If you are unsure what the current settings are, you don’t have to “plunge”
into every menu and command to discover what they are. You can use the com-
mand "Info" from the "File" menu to get an overview.
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LETTING THE OCR WIZARD WORK FOR YOU

Now that our scanner is set up, we want to get started capturing documents.
Instead of going through all the parameters, we'll use the OCR wizard, a very
comfortable way of recognizing pages.

Click the "OCR Wizard" button on the main toolbar (or select the command
"OCR Wizard" under the "Process" menu).

      

The wizard guides you through the OCR process comfortably: answer a few
simple questions and you'll obtain quick and easy results with Readiris.
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Note that the OCR wizard starts running each time you start up Readiris; you
can avoid this by disabling the option "Enable Wizard on Startup" in the first
screen of the wizard (and with the equivalent option under the "Settings" menu).

RECOGNIZING PAGES AUTOMATICALLY

The OCR wizard is a semi-automatic way of recognizing pages. Readiris also
allows fully automatic recognition: instead of being taken through the parameters
step by step, we will now recognize a page immediately, without any interruption.

To replace the "OCR Wizard" button on the main toolbar by the "Auto" button,
disable the option "Enable Wizard on Toolbar" under the "Settings" menu.
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Select the scanner as image source with the "Source" button and click on the
"Auto" button (or select the command "Automatic OCR" under the "Process"
menu).

Automatic OCR means that a page is successively scanned, windowed by
page analysis or a zoning template and recognized without interactive learning.
All you have to do is initiate the scanning and save the recognized text, the inter-
mediate steps are handled by Readiris.

READIRIS RECREATES YOUR DOCUMENT LAYOUT

Automatic recognition, which renders the recognition process automatic, should
not be confused with autoformatting! “Autoformatting” means that Readiris rec-
reates a facsimile copy of the scanned document: the word, paragraph and page
formatting of your original document are applied.

Similar typefaces (serif and sans serif, proportional and fixed, normal and
condensed) are used as in the source document, the point sizes and typestyles
(bold, italic and underlined) are maintained across the recognition. The tabs and
the alignment (left, centered, right and justified) of each text block are recreated.
The placement of columns, text blocks and graphics follows your original docu-
ment.

In other words, Readiris allows you to archive a true copy of your documents,
be it a editable and compact text file instead of a scanned image!

All this implies that the sorting of windows only partially applies when
“autoformatting” is used: you can include and exclude zones, but any re-ordering
of zones is simply ignored!

Here’s an example of how it works. To get acquainted with this feature, open
the image AUTOFORM.TIF which is found in your Readiris folder.
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Click the "Format" button on the main toolbar and choose to send the OCR
result to Microsoft Word or select the RTF (Rich Text Format) or Word (DOC)
format. Secondly, select "Recreate Source Document" as layout option. (The
option "Merge Lines into Paragraphs" is enabled by default to apply wordwrap
within the paragraphs.)
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Note that layout reconstruction is limited to the Word (DOC) and RTF format,
and to documents sent directly to Microsoft Word 97. On the plus side, the Word
(DOC) and RTF formats are widely used text formats that can be opened by any
popular wordprocessor.

Other, “poor” formats generating “plain” text such as ASCII, ANSI etc. do
not support advanced formatting codes and therefore cannot offer autoformat-
ting. Similarly, the target application WordPad is a “reduced” text editor, not a
fully featured wordprocessor; WordPad may open RTF files but ignores most
formatting codes such as text frames, alignment etc.

When the recognized text is opened using a wordprocessor, the text looks like
this without any intervention by the user.
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To see the effect correctly, you need to enable the “WYSIWIG” mode of
your wordprocessor, mostly called “page layout” mode. However, if you send the
recognized document directly to Microsoft Word, the “page layout” view is acti-
vated automatically!
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In short, Readiris not only recognizes your texts, but can format them for you
as well. OCR isn't just text recognition anymore, it is becoming more and more
page or document recognition as well!

TEXT FORMATTING, PART 2

The other layout options are "Create Body Text" and "Retain Word and Para-
graph Formatting".

As the icon on the right side illustrates, creating body text means you create
a non-formatted, “running” text. The text will be captured, but its formatting is
entirely ignored. Use this option when you just need to recapture a text but not its
layout.

(Generating Asian text implies creating body text - you cannot apply
“autoformatting” or retain the word and paragraph formatting. Secondly, the num-
ber of file formats is reduced.)

The option "Retain Word and Paragraph Formatting" represents the middle
road: the word formatting - font type (serif - sans serif, proportional - fixed,
normal - condensed), point size and typestyle (bold, italic and underlined) - is
retained across the recognition, and so is the paragraph formatting - the tabs
and the alignment (left, centered, right and justified).
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Don't confuse this formatting option with “full” autoformatting: this option just
puts one paragraph after the other, it does not recreate columns or copy the
relative position of the various zones. Nor will it include the graphics as full
autoformatting can do.

SAVING GRAPHICS SEPARATELY

In our example, the graphic was included in the recognized text; whether this
is the case depends on the formatting option "Include Graphics". Saving graphics
inside the text is only possible with “full” autoformatting -, not with “poor” text
formats such as ASCII, ANSI etc.

Still, with Readiris, you can save graphics without performing text recognition.
As the OCR software Readiris generates black-and-white images, no greyscale
or color images, it doesn’t make any sense to scan photographs with Readiris, but
you can capture lineart graphics effortlessly.

How? Draw a graphic zone around the illustrations, cartoons etc. you need.
Creating graphic windows manually is done in the same way as drawing text and
table windows, simply select the "Graphic Window" tool now.
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(Similar to the other window types, the tooltip of the graphic window tool tells
you how many graphic windows there are. And you can press the Alt key while
you select a window to display its type and its coordinates.)

Next, choose the command "Save Graphics" under the "File" menu.

You are prompted to specify a filename.

Determine which graphic file format you will use. Select a format that's sup-
ported by your paint or photo retouching software. The TIFF and Paintbrush
(PCX) formats are available. (Paintbrush files can always be opened with the
Windows accessory Paint.)
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The graphics are saved in a single file. You don't have to limit yourself to a
single graphic, but if you draw several graphic windows, they will be collected,
“stacked” in a single file. (You can use the "Crop" command of your paint or
photo retouching program to separate them.)

Sides smaller than 1 mm are not allowed - bitmaps of that size hardly contain
any information. “Irregular”, non-rectangular windows are invisibly converted
into rectangles: Readiris covers the maximal surface based on the largest coordi-
nates. In the example below, the graphic window with the black border is com-
pleted by the shaded area.
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READING FAXES AND DEFERRED RECOGNITION

Saving images as image files opens another possibility: you can save the full
page and perform deferred OCR on it later on. That's what we did with the
prescanned images of our tutorials.

Simply scan the document and select the command "Save Full Page as Im-
age" under the "File" menu. You'll again be prompted to save the entire page as
TIFF or Paintbrush (PCX) file.

You can now select the disk as image source and open the image file with the
"Open" button (or with the corresponding command under the "Process" menu).
(If you use the "Open" command under the "File" menu, you don't even have to
update the image source.)

Readiris opens black-and-white TIFF images (uncompressed, packbits, Group
3 and Group 4 compressed), multipage TIFF images, Paintbrush (PCX) images
and Windows bitmaps (BMP). This capability is particularly useful to convert
your faxes into editable text files!
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If you have any influence over your correspondents, ask them to send faxes
with the “fine” quality - those faxes have the higher resolution of 200 dpi and will
yield better OCR results.

Don't forget that you can use “drag and drop” to open images: drop image
files from the Windows Explorer onto the image zone of Readiris and they are
promptly opened!

RECOGNIZING TABLES

So far, we've recognized texts and faxes and we've saved graphics. Let's
process a table now. Take a table of figures and scan it, or open the sample image
TABLE.TIF in your Readiris folder.

Actually, the image TABLE.TIF contains two tables, and that's no coinci-
dence! The page analysis zones them as table windows, and Readiris will recon-
struct them for you by recreating the tables cell by cell in your spreadsheet or by
inserting a table object inside your wordprocessor files.

Let's explore the different solutions, starting with the “gridded” or “framed”
table - it has borders around the cells.
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Run the recognition with the layout option "Retain Word and Paragraph For-
matting" or "Recreate Source Document" enabled and the table gets recreated.
Open your wordprocessor to have a look at the result. (You could obviously have
included the text paragraphs in the text file as well.)
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Now the “ungridded” example - it has no borders around the cells. Note that
the page analysis nevertheless detects the table!
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For optimal OCR accuracy, you should limit recognition to the numeric sym-
bols with the "Language" button. (The numeric mode is not strictly numeric, it
includes the symbols 0 to 9, +, *, /, %, , (comma), . (dot), (, ), -, =, $ and £.)

As you can only do this when the table doesn't contain any alphabetic symbols
- otherwise the text portions won't be recognized correctly - we can activate the
numeric mode now but couldn't do it for the first table.

This time, we will send the OCR result directly to the spreadsheet Microsoft
Excel, so we select Excel as target application under the "Format" button.
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The spreadsheet is started up automatically and the result looks like this: the
typical table structure with rows and columns is recreated, and you are immedi-
ately ready to process the data.

Also note that you can also send tables to the clipboard - hence the option
"Send to Clipboard Excel" - and save them in an external file - hence the file
format Excel (CSV stands for “comma delimited” data).

You may come across “ungridded” tables the page analysis does not detect as
table zones because the columns are too widely spaced - Readiris tries to avoid
confusion with columnized text blocks. To create a table window manually, click
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on the "Table Window" tool in the image toolbar and proceed as usual; the button's
tooltip again indicates the number of table windows.

THE “CONNECT” FEATURE, ANOTHER DIRECT LINK

Actually, there's yet another way of recognizing tables of figures: you can do
it from within your spreadsheet!

Similar to the "Send to" feature, which exports the reading result automati-
cally, the “Connect” feature offers a direct OCR link between your scanner and
your Windows applications. The only difference is the “inverse” way of proceed-
ing: you don't recognize your documents inside Readiris to export the result to a
“target” application, Readiris is called up from within your application!

As there are some manual steps no installation procedure can take care of
for you, you need to check the on-line help system or the file CONNREAD.DOC
in your Readiris folder to learn how to install it - it takes a macro to use the
“Connect” capability from within Word, Excel and WordPerfect. (That “Read
Me” file is displayed automatically at the end of the installation program.)
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When correctly installed, the “Connect” feature adds a new command to the
menus of your application. In the examples below, the command "Scan Text" is
added to the "File" menu of Word, and the menu "Scan Table" is added to the
menu bar of Excel.
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Here's how it works: Readiris may not run in the background when you launch
the “Connect” macro. Click on the new command in your application menu to run
Readiris. The “Connect” interface may ask you some questions before Readiris
will start running. Proceed as usual and quit the “Connect” interface when you
are through. The recognition results are inserted at the current cursor position.



2 - 64

GETTING ON-LINE HELP

This concludes our overview of Readiris. Some last-minute information may
not be included in this manual. We thus recommend you to consult the on-line
help system for additional information on Readiris.

Go to the "Help" menu to do so. The command "Help Topics" and its shortcut
key F1 allow you to navigate through the many help topics.
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Chapter 3
COMMAND REFERENCE

This chapter provides an extensive reference guide to the Readiris commands.
Note that buttons and shortcuts are available for all frequently used functions!

MAIN TOOLBAR

The main toolbar provides immediate access to the frequently used general
commands. Tooltips are available for all buttons.

  OCR Wizard button

Starts the OCR wizard.

The OCR wizard is a semi-automatic way of recognizing pages. It guides the
user through the OCR process comfortably: he answers a few simple questions
to obtain quick and easy results with Readiris.
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The OCR wizard starts running each time Readiris is started up; this can be
avoided by disabling the option "Enable Wizard on Startup" in the first screen of
the wizard. (Whether the OCR wizard is run at the program startup or not is
stored in the default settings.)

Related Commands

The option "Enable Wizard on Toolbar" under the "Settings" menu “installs”
the OCR wizard on the main toolbar: when this option is enabled, the "OCR
Wizard" button is placed on the toolbar, when it is disabled, the "Auto" button that
triggers automatic recognition is placed on the toolbar.

The option "Enable Wizard on Startup" under the "Settings" menu sees to it
that the OCR wizard starts running each time Readiris is started up. The option
"Enable Wizard on Startup" in the first screen of the wizard has the same effect.
This option is enabled by default.
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  Auto button

Executes automatic recognition.

The user intervention is limited to a mimimum: he initiates the scanning pro-
cess and saves the recognition result.

Depending on the image source selected with the "Source" or "Scanner" but-
ton on the main toolbar, the scanner scans a page automatically or the user is
prompted to open an image file. To zone the document, page analysis is executed
on the scanned image or the active windowing layout as loaded into memory with
the command "Open Layout" under the "File" menu is applied. Next, the charac-
ter recognition is executed without interactive learning and the user is invited to
save the text result or the text result is placed on the clipboard.

Related Commands

The successive use of the buttons "Scan" (or "Open"), "Sort" and "Recognize"
on the main toolbar executes step-by-step text recognition. The "Source" and
"Scanner" button on the main toolbar determine whether the scanner or prescanned
images function as image source.

The "Auto" button is equivalent to the command "Automatic OCR" under the
"Process" menu.

The option "Enable Wizard on Toolbar" under the "Settings" menu “installs”
the automatic mode on the main toolbar: when this option is disabled, the "Auto"
button is placed on the toolbar, when it is enabled, the "OCR Wizard" button that
guides the user through the OCR process is placed on the toolbar.

  Scan button

Scans a document.
The scanned images appear in the image zone progressively.

To scan multipage documents efficiently, the user enables the document feeder
of his scanner with the option "ADF" under the "Scanner" button on the main
toolbar and starts the scanning. All pages are scanned until the document feeder
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is empty. (As soon as multipage documents are loaded into memory, the page
toolbar is added below the image zone.)

This button alternates with the "Open" button. It is available exclusively when
the scanner option is selected as image source with the "Source" button on the
main toolbar and when the option "<Image>" is not selected as “scanner” with
the "Scanner" button on the main toolbar.

Related Commands

The "Scanner" button on the main toolbar determines all scanning parameters
such as resolution, page format, brightness and contrast etc.

The rotation buttons on the image toolbar allow the user to rotate images with
an incorrect orientation.

The button "Auto" on the main toolbar executes scanning, page analysis and
recognition simultaneously.

The "Scan" button is equivalent to the "Acquire" command under the "File"
menu and the "Scan" command under the "Process" menu.

  Open button

Opens an image file.

The user is prompted to open prescanned image files, the scanned images
appear in the image zone progressively.

Readiris supports black-and-white TIFF images (uncompressed, packbits, Group
3 and Group 4 compressed), Paintbrush (PCX) images and Windows bitmaps
(BMP). Multipage TIFF files are also supported.

Opening prescanned images is particularly useful to convert faxes into editable
text files. Should the user have any influence over his correspondents, he can ask
them to send faxes with the “fine” quality - those faxes have the higher resolution
of 200 dpi and will yield better OCR results.

The user can open multiple images by loading multipage (TIFF) files and by
loading several prescanned images. To load several images, he selects the first
image and holds down the Ctrl key as he selects additional images. To load a
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continuous range of images, he selects the first image and holds down the Shift
key as he selects the last image. (As soon as multipage documents are loaded
into memory, the page toolbar is added below the image zone.)

The user can also use “drag and drop” to open prescanned images. When
image files are dragged from the Windows Explorer onto the Readiris image
zone, they are opened promptly.

This button alternates with the "Scan" button. It is available exclusively when
the disk option is selected as image source with the "Source" button on the main
toolbar or when the option "<Image>" is selected as “scanner” with the "Scan-
ner" button on the main toolbar.

Related Commands

The rotation buttons on the image toolbar allow the user to rotate images with
an incorrect orientation.

The button "Auto" on the main toolbar executes scanning, page analysis and
recognition simultaneously.

The command "Save Full Page as Image" under the "File" menu allows to
save entire scanned pages in image files which can be opened and recognized
later on.

The "Open" button is equivalent to the "Open" command under the "File" menu
and the "Open" command under the "Process" menu.

  Sort button

Allows to modify the sort order of the text windows.
Sorting is very useful to edit the results of the page analysis.

The mouse cursor shows that the “sort mode” is enabled: the mouse cursor
changes to a hand with a pointing finger and the color of the windows becomes
softer, weaker. (With white-on-black text blocks, the difference is less notice-
able.)
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The user clicks inside the windows to define their sequence: for selected win-
dows, the “full” color is restored. The windows the user doesn't click on won’t be
recognized. Arrows indicate the sort order.

Sorting can be combined with manual windowing: the user applies page analy-
sis to detect the windows and sorts the ones he want to include. As soon as he
starts drawing a window manually, all windows that were not selected up to that
point are simply erased.

Sorting applies only partially when “autoformatting” is used - this involves
the enabling of the Word (DOC) or RTF file format or sending the OCR result
directly to Microsoft Word, and the layout option "Recreate Source Document"
with the "Format" button on the main toolbar. The user can include and exclude
specific zones, but any re-ordering of zones is simply ignored. “Autoformatting”
recreates a facsimile copy of the original document and therefore implies that the
placement of columns, text blocks, graphics and tables is true to the source docu-
ment.

Related Commands

The "Page Analysis" button on the main toolbar enables the automatic page
analysis, the "Analyze Page" button on the image toolbar forces the system to
(re-)execute page decomposition.

The button "Auto" on the main toolbar executes scanning, page analysis and
recognition simultaneously.

The "Sort" button is equivalent to the "Sort" command under the "Process"
menu.

  Recognize button

Executes character recognition.

The image file is converted into editable text.
When “autoformatting” is used, Readiris allows to archive a true copy of the

user's documents, be it a editable and compact text file instead of a scanned
image.
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The tooltip of the "Recognize" button indicates the font type: when no mes-
sage is added to the tooltip, the “normal” font quality applies, when the message
"Dot Matrix" is added, the dot matrix reading mode is enabled.

Related Commands

The button "Auto" on the main toolbar executes scanning, page analysis and
recognition simultaneously.

The command "Font Type" under the "Settings" menu determines whether the
“normal” or dot matrix reading mode applies.

The "Recognize" button is equivalent to the command "Recognize" under the
"Process" menu.

  Language button

Determines the document language.

Indicating the language of the document to be recognized is imperative, as the
set of recognized characters varies according to the selected language. Secondly,
recognition is assisted by linguistic databases: Readiris extensively uses linguistic
information to validate good solutions and mark suspicious ones.

Readiris recognizes all American and European languages, including the Cen-
tral-European languages, Greek, Turkish, the Cyrillic (“Russian”) and Baltic lan-
guages. Multi-linguistic support ensures that “exotic” characters such as ç, ß, ñ,
γ and ø are recognized correctly.

Optionally, the user can read Asian documents: the extra module “Asian OCR
add-on” offers recognition of Japanese and Simplified Chinese. Traditional Chi-
nese is not supported. (Simplified Chinese is used on China’s mainland, where
Traditional Chinese is used by the “Big 5” communities - Hong Kong, Taiwan,
Singapore etc.)

It takes the appropriate Windows configuration to display Central-European,
Greek, Turkish, Cyrillic and Baltic characters. The user may have to install the
Windows “service pack” "Multilanguage Support" before his Windows system is
able to cope with these languages. Depending on the software package, the
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Readiris CD-ROM may contain detailled information on how to install this Win-
dows module.

To view and edit Asian documents, the user can install an Asian, Japanese or
Chinese version of the Windows operating system or run specialized “emulating”
software (such as UnionWay AsianSuite or TwinBridge AsianBridge) on a West-
ern version of Windows to correctly represent the ideograms of these Asian
languages.

The user can press a letter key to move to it directly: if English is currently
selected, and he wants to select Hungarian, he can click the "H" key on his
keyboard to go to the Hungarian language directly. When several languages have
the same initial, he simply presses that letter several times to go through the
options. An example: by pressing "P" once, the user selects Polish, by pressing
"P" a second time, he selects Portuguese, and by pressing "P" a third time, he's
back on Polish. To go to another letter, say T, the user presses BackSpace
before he enters the "T" character.

The British and American - or should we say “international”? - variants of the
English language are distinguished.

When the user selects Greek-English, a mixed Cyrillic language setting - for
instance "Byelorussian-English" instead of just "Byelorussian" -, Japanese or Sim-
plified Chinese, a mixed character set is used. Readiris copes beautifully with
“Western” words (proper names, brand names etc.) as occur in Greek, Cyrillic
and Asian documents.

To mix other languages on a page, the user selects the language with the most
extended character set. To read documents where English and French occur
alongside, French is selected as language to ensure that the accentuated charac-
ters such as ç, é and ù are recognized correctly.

To optimally recognize tables of figures, the recognition can be limited to a
numeric character set. The symbols 0 to 9, +, *, /, %, , (comma), . (dot), (, ), -, =,
$ and £ will then be recognized. This option should not be selected when the
tables contain alphabetic text.
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Related Commands

The language selection can also be enabled by loading a Readiris configura-
tion with the command "Load Settings" under the "File" menu.

The "Language" button is equivalent to the "Language" command under the
"Settings" menu.

  Source button

Determines the image source.

The user can capture images using a scanner, or open prescanned images to
execute deferred OCR. The latter procedure is useful to recognize faxes.

Alternatively, the user can select the option "<Image>" as his “scanner” with
the button "Scanner" on the main toolbar to use prescanned images as image
source. The scanner option is then no longer available.

Selecting the scanner as image source puts the "Scan" button on the main
toolbar (and enables the command "Scan" under the "Process" menu), selecting
prescanned images as image source puts the "Open" button on the main toolbar
(and enables the command "Open" under the "Process" menu).

The scanner is the default image source.

Related Commands

The "Scan" button on the main toolbar scans a document, the "Open" button
on the main toolbar opens an image file.

The source selection can also be enabled by loading a Readiris configuration
with the command "Load Settings" under the "File" menu.

  Page Analysis button

Enables the automatic page analysis.

The user avoids windowing the zones manually as Readiris decomposes the
page automatically. Page analysis is particularly useful when columnized texts
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and documents with a complex page layout - possibly including graphics and
tables - are OCRed.

Page decomposition uses three window types: it discriminates the text blocks
from the tables and graphic zones containing photos, illustrations etc. on the page.
A color code indicates the window type: text windows are yellow, graphics are
blue and table windows are purple.

Page analysis is fast, skew-tolerant and highly accurate: it traces complex,
“irregular” shapes.

Readiris detects “gridded” and “non-gridded” tables: “gridded” or “framed”
tables have borders around the cells, “non-gridded” tables are not surrounded by
cell borders. When the space between the columns of “non-gridded” tables is too
big, Readiris may avoid windowing it as a table to avoid confusion with text
columns.

The windows are sorted top-down, left to right to account for columnized
documents. Arrows indicate the sort order. The user can change the sort order of
windows with the "Sort" button on the main toolbar and combine window sorting
with manual zoning.

When “autoformatting” is applied, sorting only partially applies: the user can
include and exclude specific zones, but any re-ordering of zones is simply ig-
nored. “Autoformatting” recreates a facsimile copy of the original document,
which implies that the placement of columns, text blocks, graphics and tables is
true to the source document.

The user should select the document language before executing the page
analysis when he is dealing with Asian documents. Specific routines are used for
these languages: the interline spacing of Asian documents is in most cases bigger
than in Western documents, the text is made up of small icons (“ideograms”) that
could easily be seen as graphic zones in Western documents and the text may run
from top to bottom, from right to left.

Page analysis is automatically disabled when a windowing template is loaded
into memory with the command "Load Layout" under the "File" menu. (The zon-
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ing layout remains active until page analysis is re-enabled with the "Page Analy-
sis" button on the main toolbar.)

Related Commands

The command "Analyze Page" on the image toolbar makes Readiris (re-)ex-
ecute page analysis, the "Sort" button on the main toolbar resorts the text win-
dows.

The page analysis can also be enabled by loading a Readiris configuration
with the command "Load Settings" under the "File" menu.

The "Page Analysis" button is equivalent to the option "Page Analysis" under
the "Settings" menu.

  Learn button

Enables the learning phase, where Readiris acquires new font information.

Font training can substantially enhance the accuracy of the recognition sys-
tem. When the user tries to read distorted, defaced forms as can be found in real
documents or stylized font shapes which Readiris does not recognize optimally,
training can overcome this temporary “failure”.

User learning is also used to train the system on special symbols which Readiris
is unable to recognize, such as mathematical and scientific symbols and dingbats.
Readiris can for instance be trained to recognize the "π" symbol as "pi" or the
dingbat "(" as "Tel". (However, the list of recognized symbols cannot be ex-
tended with the symbols "π"and "("!)

Learning can be disabled when the recognition rate is excellent and the text
result requires no detailled proofreading.

Learning is enabled by default. Learning is always disabled with automatic
OCR and when Asian documents are read: learning does not make sense for
these languages which use thousands of different symbols - assuming that the
user is able to enter the ideograms, not an easy task when using a Western
keyboard.
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The button's tooltip indicates the font dictionary and its mode: the user can
hold the mouse cursor over the "Learn" button to learn which user dictionary and
dictionary mode are enabled.

Related Commands

The command "Font Dictionary" under the "Learn" menu selects or defines a
font dictionary and its mode, the options "New Dictionary", "Append Dictionary"
and "Read Dictionary" under the "Learn" menu also set the dictionary mode.

Interactive learning can also be enabled by loading a Readiris configuration
with the command "Load Settings" under the "File" menu.

The "Learn" button is equivalent to the option "Interactive Learning" under the
"Learn" menu.

  Format button

Determines the text file format and the degree of formatting of the recognition
result.
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The user can select a document format supported by his text applications,
copy the output to the Windows clipboard and output the OCR result directly to
his wordprocessor and spreadsheet.

Readiris can export the recognized document automatically to the
wordprocessor Microsoft Word 97, the spreadsheet Microsoft Excel and the Win-
dows accesory WordPad. If necessary, Readiris will start up the target applica-
tion. When “autoformatting” is applied, Readiris will enable the “page layout”
view of Microsoft Word 97 to give a “WYSIWIG” view of the reading result.

The recognition result of multipage documents is saved in a single output file.
When the recognition result is sent to a target application, various pages get
created inside a single document.
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This command also determines the level of formatting given to the text output.
The availability of formatting options depends on the selected file format: layout
reconstruction is limited to documents sent to Microsoft Word and to the Word
(DOC) and RTF format. Microsoft Word (DOC) and RTF are widely used text
formats that can be opened by any popular wordprocessor.

Other, “poor” formats generating “plain” text such as ASCII, ANSI etc. do
not support advanced formatting codes and therefore cannot offer word, para-
graph or page formatting. The target application WordPad is a “reduced” text
editor, not a fully featured wordprocessor: WordPad opens Word (DOC) and
RTF files but ignores most formatting elements such as text frames, alignment
etc.

To apply “autoformatting”, the user selects Word (DOC) or RTF (Rich Text
Format) as output format or sends the OCR result directly to Microsoft Word and
enables the layout option "Recreate Source Document". Full “autoformatting”
means that Readiris recreates a facsimile copy of the scanned document: the
word, paragraph and page formatting of the original document are applied. The
graphics and tables are included in the text file.

Similar typefaces (serif - sans serif, proportional - fixed, normal - condensed)
are used as in the source document, the point sizes and typestyles (bold, italic and
underlined) are maintained across the recognition. The tabs and the alignment
(left, centered, right and justified) of each text block are recreated. The place-
ment of columns, text blocks, graphics and tables follow the source documents.
In other words, Readiris allows to archive a true copy of your documents, be it a
editable and compact text files instead of scanned images!

To see the recognized text correctly, the user may have to enable the
“WYSIWIG” mode of his wordprocessor, mostly called “page layout” mode.

When “autoformatting” is applied, sorting applies only partially: the user can
include and exclude specific zones, but any re-ordering of zones is simply ig-
nored.

The graphics are included in the OCR results when the option "Include Graph-
ics" is enabled. The availability of this option depends on performing full
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“autoformatting”. (Alternatively, graphics can be saved separately with the com-
mand "Save Graphics" under the "File" menu.)

The layout option "Create Body Text" creates a non-formatted, “running” text.
The text will be captured, but its formatting is entirely ignored. This option is used
when a text needs to be recaptured but not its layout. Documents sent to WordPad
yield “body text”.

The option "Retain Word and Paragraph Formatting" represents the middle
road: the word formatting - font type, point size and typestyle - is retained across
the recognition, and so is the paragraph formatting - the tabs and the alignment.
No page formatting is applied: this option just puts one paragraph after the other,
it does not recreate columns or copy the relative position of the various blocks,
nor will it include the graphics. The tables are however recaptured correctly.

The option "Merge Lines into Paragraphs" sets the text flow within the para-
graphs. Enabling this option makes Readiris apply the normal wordwrap typical
of wordprocessors until a new paragraph starts, otherwise, a carriage return (CR
or EOL code) is added after each line and hyphenated words remain so. Para-
graph detection is enabled by default.

Here's an example to clear things up. When the first three lines of a column
are "The new presi-", "dent waved from the balcony." and "His wife had joined
him.", the paragraph detection yields the following result: "The new president
waved from the balcony. His wife had joined him." The hyphenated parts of the
word "president" were “reglued” and a space was added at the end of the first
sentence, thus creating naturally flowing text. Had paragraph detection not been
enabled, the original layout would have been retained, with a carriage return
added at the end of each line.

Readiris outputs tabular data to spreadsheets and wordprocessors: tables gets
reconstructed cell by cell in worksheets and inserted as table objects in
wordprocessor files. Recognizing tables can be done in many ways: they can be
sent to the target applications Microsoft Excel and Word 97, sent to the clipboard
in an “Excel” format, saved inside a Microsoft Word (DOC) and RTF file, or
saved using a table format such as Excel (CSV stands for “comma delimited”
data).
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Generating Asian text implies creating body text - the user cannot apply
“autoformatting” or retain the word and paragraph formatting. Secondly, the num-
ber of file formats is reduced in these languages.

Related Commands

The output mode and layout formatting options can also be enabled by loading
a Readiris configuration with the command "Load Settings" under the "File" menu.

The "Format" button is equivalent to the "Text Format" command under the
"Settings" menu.

  Scanner button

Allows the user to select his scanner model and determine its settings.

The user clicks the button "Scanner Model" to determine his scanner model. If
the user's Readiris software licence was bundled with a scanner model, this step
is probably unnecessary as his scanner may already be set up under Readiris.

Readiris supports a wide range of popular scanners; it also supports the scan-
ning standard Twain and the scanning platforms Visioneer PaperPort, HP Docu-
ment Assistant, HP JetSuite, Microtek PageSuite and Primax PaperEase. (De-
pending on the software bundle, the user may also find specialized manuals con-
cerning the scanning platforms on the Readiris CD-ROM.)

When the user selects the option "<Image>" as his “scanner”, prescanned
images function as image source: the button "Scan" on the main toolbar is re-
placed by the "Open" button and the scanner option is no longer availabe under
the "Source" button on the main toolbar.
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Once the scanner is selected, this command allows the user to set the scan-
ning resolution, the page format and orientation, brightness and contrast and al-
lows him to indicate whether he is going to use the scanner's document feeder.
With Twain compliant scanners, the scanning parameters are often set within the
Twain interface.

A resolution of 300 dpi is selected for normal applications, a higher resolution
of 400 dpi is recommended for small print (below 10 point) and when the docu-
ment is very degraded.

The user enables the scanner's document feeder to scan multipage docu-
ments efficiently. By starting the scanning with the "Scan" button on the main
toolbar, all pages will be scanned until the document feeder is empty.

By enabling the option "Landscape", the user indicates that the selected page
orientation is wide (“landscape”) rather than tall (“portrait”). The page orienta-
tion actually applies to reduced page formats: on an A4 flatbed scanner, the user
can scan A5 pages (half that big) in portrait or landscape format, but he can only
scan the full A4 surface in one direction.
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The user sets the brightness, and, if available, the contrast. The contrast set-
ting is only available on some scanners. The trackbar is dragged to modify the
brightness and contrast; the selected values are represented numerically.

The option "Invert" allows the user to generate “inverted” images - this option
is enabled to process full pages with white text on a black background.

The "Config." button is only available when the scanner allows it. It gives
access to some advanced scanning parameters; with Twain scanners, clicking
the "Config." button allows to select the Twain source. Alternatively, the user can
use the command "Select Source" under the "File" menu.

Related Commands

The scanner selection and scanner setup can also be enabled by loading a
Readiris configuration with the command "Load Settings" under the "File" menu.

The command "Select Source" under the "File" menu allows to select the
Twain source.

The "Scanner" button is equivalent to the "Scanner" command under the "Set-
tings" menu.

IMAGE TOOLBAR

The image toolbar contains the tools needed to zone the images comfortably
and provides quick access to all frequently used commands required to handle
scanned images.

This toolbar is only activated in the “preview” mode, when an image is dis-
played on-screen. Tooltips are available for all buttons.

  Select Window button

Activates the window selection or “arrow” tool.

To modify, move and delete windows, the user has to select them first.
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The window selection tool is the default image tool: when an image is dis-
played on-screen, this tool is enabled automatically.

The user selects the "Select Windows" button on the image toolbar and clicks
inside a window. Rectangular markers now appear at each corner and in the
middle of the window sides.

To select additional windows, the user holds down the Shift key while clicking
on these extra windows.

To select a window and the included windows (of the other type), he holds
down the Ctrl key while clicking on the main window.

To unselect windows, he clicks the mouse button elsewhere.

Related Commands

The user can display the sort order, type and coordinates of a window by
pressing the Alt key while he selects it.

Windows can be cut, copied and deleted with the corresponding commands of
the "Edit" menu. Windows can also be modified and moved with mouse cursor
movements.

  Text Window button

Creates a text window.

To window a text zone of interest, the user selects the "Text Window" tool and
clicks the cursor in a corner of the window, stretches the window by moving the
mouse to the opposite corner and clicks again.

Text windows are yellow, graphics are blue and table windows are purple.

Sides smaller than 1 mm are not allowed - windows of that size wouldn't
contain any characters.

The user can frame “irregular” text blocks by drawing polygonal windows
around them. Non-rectangular windows are created by “merging” rectangular
zones: as soon as two rectangles (of the same window type) intersect, they be-
come a single window automatically.
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The windows are sorted in the order of creation: arrows indicate the sort
order. The user can modify the sort order - to include the relevant zones and
exclude the zones of no interest, or to modify their order in the output file - with
the "Sort" button on the main toolbar.

He can also combine sorting with manual windowing: the user applies page
analysis to detect the windows and sorts the ones he want to include. As soon as
he starts drawing a other window manually, all windows that were not selected
up to that point are simply erased.

The sort order is ignored when “autoformatting” is used - this involves the use
of the Word (DOC) or RTF file format or sending the OCR result to Microsoft
Word and the enabling of the layout option "Recreate Source Document" with the
"Format" button on the main toolbar. “Autoformatting” recreates a facsimile copy
of the original document and therefore implies that the placement of columns,
text blocks, graphics and tables is true to the source document.

The user can display the sort order, type and coordinates of a text window by
pressing the Alt key while he selects it. The tooltip of the "Text Window" button
indicates the number of text windows.

Related Commands

Windows can be cut, copied and deleted with the corresponding commands of
the "Edit" menu. Windows can also be modified and moved with mouse cursor
movements.

The "Graphic Window" button on the image toolbar allows to create graphic
windows, the "Table Window" button on the image toolbar allows to create table
windows.

  Graphic Window button

Creates a graphic window.

As the OCR software Readiris generates black-and-white images, no greyscale
or color images, it doesn’t make sense to scan photographs with Readiris, but the
user can capture lineart graphics effortlessly.
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To create a rectangle around a illustration, cartoon etc., the user selects the
"Graphic Window" tool and clicks the cursor in the upper left corner of the win-
dow, stretches the window by moving the mouse to the lower right corner and
clicks again.

Graphic windows are blue, text windows are yellow and table windows are
purple.

Sides smaller than 1 mm are not allowed - bitmaps of that size hardly contain
any information.

“Irregular”, non-rectangular windows are invisibly converted into rectangles:
Readiris covers the maximal surface based on the largest coordinates.

The user can create several graphic windows per operation, but these will be
collected, “stacked” in a single file when the command "Save Graphics" under
the "File" menu is used.

Graphics can be included directly in the text file when “autoformatting” is
applied - this involves the use of the Word (DOC) or RTF file format or sending
the OCR result to Microsoft Word and the enabling of the layout option "Recre-
ate Source Document" with the "Format" button on the main toolbar -, and saved
separately with the command "Save Graphics" under the "File" menu.

The user can display the type and coordinates of a graphic window by press-
ing the Alt key while he selects it. The tooltip of the "Graphic Window" button
indicates the number of graphic windows.

Related Commands

Windows can be cut, copied and deleted with the corresponding commands of
the "Edit" menu. Windows can also be modified and moved with mouse cursor
movements.

The "Text Window" button on the image toolbar allows to create text win-
dows, the "Table Window" button on the image toolbar allows to create table
windows.
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  Table Window button

Creates a table window.

Readiris detects “gridded” and “non-gridded” tables of figures - “gridded” (or
“framed”) tables have borders around the cells and “non-gridded” tables don't -
and outputs them to spreadsheets and wordprocessors. Tables get reconstructed
by creating cells in Microsoft Excel worksheets or by inserting table objects in
Word (DOC) and RTF files - the user must then select the layout option "Retain
Word and Paragraph Formatting" or "Recreate Source Document".

To create a rectangle around a table, the user selects the "Table Window" tool
and clicks the cursor in the upper left corner of the window, stretches the window
by moving the mouse to the lower right corner and clicks again.

Table windows are purple, text windows are yellow and graphics are blue.

Sides smaller than 1 mm are not allowed - bitmaps of that size can't even
contain a single table cell. It does not make any sense to create “irregular”,
polygonal table windows.

The windows are sorted in the order of creation: arrows indicate the sort
order. The user can modify the sort order - to include the relevant zones and
exclude the zones of no interest, or to modify their order in the output file - with
the "Sort" button on the main toolbar.

He can also combine sorting with manual windowing: the user applies page
analysis to detect the windows and sorts the ones he want to include. As soon as
he starts drawing a other window manually, all windows that were not selected
up to that point are simply erased.

The sort order is ignored when “autoformatting” is used - this involves the use
of the Word (DOC) or RTF file format or sending the OCR result to Microsoft
Word and the enabling of the layout option "Recreate Source Document" with the
"Format" button on the main toolbar. “Autoformatting” recreates a facsimile copy
of the original document and therefore implies that the placement of tables, col-
umns, text blocks and graphics is true to the source document.
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The user can display the sort order, type and coordinates of a table window by
pressing the Alt key while he selects it. The tooltip of the "Table Window" button
indicates the number of table windows.

Related Commands

Windows can be cut, copied and deleted with the corresponding commands of
the "Edit" menu. Windows can also be modified and moved with mouse cursor
movements.

The "Text Window" button on the image toolbar allows to create text win-
dows, the "Graphic Window" button on the image toolbar allows to create graphic
windows.

  Analyze Page button

(Re-)executes page analysis on the current image.
The user avoids windowing the zones manually as Readiris decomposes the

page automatically. Page analysis is particularly useful when columnized texts
and documents with a complex page layout - possibly including graphics and
tables - are OCRed.

Page decomposition uses three window types: it discriminates the text blocks
from the tables and graphic zones containing photos, illustrations etc. on the page.
A color code indicates the window type: text windows are yellow, graphics are
blue and table windows are purple.

Page analysis is fast, skew-tolerant and highly accurate: it traces complex,
“irregular” shapes.

Readiris detects “gridded” and “non-gridded” tables: “gridded” or “framed”
tables have borders around the cells, “non-gridded” tables are not surrounded by
cell borders. When the space between the columns of “non-gridded” tables is too
big, Readiris may avoid windowing it as a table to avoid confusion with text
columns.

The windows are sorted top-down, left to right to account for columnized
documents. Arrows indicate the sort order. The user can change the sort order of
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windows with the "Sort" button on the main toolbar and combine window sorting
with manual windowing.

When “autoformatting” is applied, sorting applies only partially: the user can
include and exclude specific zones, but any re-ordering of zones is simply ig-
nored. “Autoformatting” recreates a facsimile copy of the original document,
which implies that the placement of columns, text blocks, graphics and tables is
true to the source document.

The user should select the document language before executing the page
analysis when he is dealing with Asian documents. Specific routines are used for
these languages: the interline spacing of Asian documents is in most cases bigger
than in Western documents, the text is made up of small icons (“ideograms”) that
could easily be seen as graphic zones in Western documents and the text may run
from top to bottom, from right to left.

Related Commands

The button "Page Analysis" on the image toolbar enables automatic page de-
composition, the "Sort" button on the main toolbar resorts the text windows.

The "Analyze Page" button is equivalent to the "Analyze Page" command
under the "Process" menu.

  Fit to Window button

Displays the entire page.

This zoom level is convenient for seeing the various text and graphic zones in
relation to each other.

The user can toggle between "Fit to Window" and "Actual Size" by clicking
the right mouse button.

Related Commands

The "Fit to Width" button displays the entire width of the document, the "Ac-
tual Size" button on the image toolbar and the commands "50% Actual Size" and
"200% Actual Size" under the "View" menu display the document at its real size,
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at half size and at double that size. At actual size, a screen pixel corresponds to
an image pixel.

The "Fit to Window" button is equivalent to the "Fit to Window" command
under the "View" menu.

  Fit to Width button

Displays the entire width of a document.

Related Commands

The "Fit to Window" button on the image toolbar displays the entire document,
the "Actual Size" button on the image toolbar and the commands "50% Actual
Size" and "200% Actual Size" under the "View" menu display the document at its
real size, at half size and at double that size. At actual size, a screen pixel corre-
sponds to an image pixel.

The "Fit to Width" button is equivalent to the "Fit to Width" command under the
"View" menu.

  Actual Size button

Displays the document at its real size. A screen pixel corresponds to an image
pixel.

The user can toggle between "Fit to Window" and "Actual Size" by clicking
the right mouse button.

Related Commands

The "Fit to Window" button on the image toolbar displays the entire document,
the "Fit to Width" button on the image toolbar displays the entire width of a docu-
ment. The commands "50% Actual Size" and "200% Actual Size" under the "View"
menu display the document at half and at double its real size.

The "Actual Size" button is equivalent to the "Actual Size" command under the
"View" menu.
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  Rotate Left button

Rotates the scanned image 90° to the left.

The rotation takes a few seconds, as the image itself is updated, not just the
display on-screen. If necessary, the page analysis is re-executed.

Related Commands

The "Rotate Right" button on the image toolbar rotates the scanned image 90°
to the right, the "Turn Upside Down" button on the image toolbar rotates the
scanned image 180°.

The "Rotate Left" button is equivalent to the "Rotate Left" command under
the "View" menu.

  Rotate Right button

Rotates the scanned image 90° to the right.

The rotation takes a few seconds, as the image itself is updated, not just the
display on-screen. If necessary, the page analysis is re-executed.

Related Commands

The "Rotate Left" button on the image toolbar rotates the scanned image 90°
to the left, the "Turn Upside Down" button on the image toolbar rotates the scanned
image 180°.

The "Rotate Right" button is equivalent to the "Rotate Right" command under
the "View" menu.

  Turn Upside Down button

Rotates the scanned image 180°.

This command is used to correct the orientation of a page which was scanned
upside down without having to rescan.
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The rotation takes a few seconds, as the image itself is updated, not just the
display on-screen. If necessary, the page analysis is re-executed.

Related Commands

The "Rotate Left" button on the image toolbar rotates the scanned image 90°
to the left, the "Rotate Right" button on the image toolbar rotates the scanned
image 90° to the right.

The "Turn Upside Down" button is equivalent to the "Turn Upside Down"
command under the "View" menu.

PAGE TOOLBAR

The page toolbar allows to navigate through multipage documents and gives
access to the page commands using the right-click ("Context" menu).

This toolbar is context-sensitive: it is displayed below the image zone only
when multipage documents, not single pages, are processed.

The image toolbar higlights the current page.

Related Commands

The command "Select Page" from the "Context" menu brings the user to the
page under his mouse cursor, the command "Delete Page" from the "Context"
menu deletes the page under the user's mouse cursor from the multipage docu-
ment, the command "Move Page Up" from the "Context" menu moves the page
under the user's mouse cursor one page up in the document. and the command
"Move Page Down" from the "Context" menu moves the page under the user's
mouse cursor one page down in the document.

FILE MENU

The "File" menu contains all commands relating to file management: the man-
agement of windowing templates and Readiris configurations. It also allows the
user to open prescanned images and select a Twain source.



3 - 28

Open
Opens image files to execute deferred OCR, regardless of the image source

selected with the "Source" or "Scanner" buttons on the main toolbar.

The user is prompted to open prescanned image files, the scanned images
appear in the image zone progressively.

Readiris supports black-and-white TIFF images (uncompressed, packbits, Group
3 and Group 4 compressed), Paintbrush (PCX) images and Windows bitmaps
(BMP). Multipage TIFF files are also supported.

Opening prescanned images is particularly useful to convert faxes into editable
text files. Should the user have any influence over his correspondents, he can ask
them to send faxes with the “fine” quality - those faxes have the higher resolution
of 200 dpi and will yield better OCR results.

The user can open multiple images by loading multipage (TIFF) files and by
loading several prescanned images. To load several images, he selects the first
image and holds down the Ctrl key as he selects additional images. To load a
continuous range of images, he selects the first image and holds down the Shift
key as he selects the last image. (As soon as multipage documents are loaded
into memory, the page toolbar is added below the image zone.)

The user can also use “drag and drop” to open prescanned images. When
image files are dragged from the Windows Explorer onto the Readiris image
zone, they are opened promptly.

Finally, the user can select the disk as input source with the "Source" button on
the main toolbar and click the "Open" button, and he can select the option "<Im-
age>" as “scanner” with the button "Scanner" on the main toolbar and click the
"Open" button to open prescanned images.

Related Command

The command "Save Full Page as Image" under the "File" menu allows to
save images which can be opened and recognized later on.
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Save Graphics
Saves the graphic windows.

This command saves all graphics (illustrations, cartoons etc.) zoned with the
"Graphic Window" tool in a graphic file (without text recognition).

The user can create several graphic windows per operation, but these will be
collected, “stacked” in a single file. (He can use the "Crop" command of his paint
or photo retouching program to separate them.)

This command also determines the graphics format in which the graphics will
be saved. The user should select a graphic format supported by his paint or photo
retouching software. The file formats TIFF (uncompressed, packbits and Group
4 compressed) and Paintbrush (PCX) are available.

Graphics can be included directly in the text file when “autoformatting” is
applied - this involves the use of the Word (DOC) or RTF file format or sending
the OCR result to Microsoft Word and the enabling of the layout option "Recre-
ate Source Document" with the "Format" button on the main toolbar.
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Related Command

The command "Save Full Page as Image" under the "File" menu saves the
entire page in an image file for deferred OCR.

Save Full Page as Image
Saves the entire page as an image file.

Saving scanned pages in image files leads to an interesting capability: the user
can run deferred OCR on prescanned images. He can scan a document, save the
entire page in a graphic file and recognize the image later on.

Related Commands

The button "Open" on the main toolbar opens prescanned images.

The command "Save Graphics" under the "File" menu saves graphic windows
in image files.

Info
Displays the current Readiris configuration.
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Related Commands

The command "Save Default Settings" under the "File" menu saves the cur-
rent settings as default settings to avoid having to redefine them each time. Set-
tings are loaded into memory with the command "Load Settings" under the "File"
menu and saved with the command "Save Settings" under the "File" menu.

Select Source
Allows to select a Twain source.

This command strictly applies to Twain compliant scanners. Refer to the but-
ton "Scanner" on the main toolbar for more information on scanner setup.

Related Command

This command is equivalent to the button "Configure" under the "Scanner"
button on the main toolbar.

Acquire
Refer to the "Scan" button on the main toolbar.

Load Layout
Loads a windowing layout into memory.
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Layout files contain predefined windowing structures. Zoning templates are
particularly useful when documents with a similar page layout are OCRed, as the
user avoids having to redraw the same layout.

Loading a windowing template into memory automatically disables page analysis.
The zoning layout remains active until page analysis is re-enabled with the "Page
Analysis" button on the main toolbar.

The active layout is applied when documents are automatically recognized
with the "Auto" button on the main toolbar.

Related Commands

Zoning layouts can also be enabled by loading a Readiris configuration with
the command "Load Settings" under the "File" menu.

The command "Save Layout" under the "File" menu saves the current layout
as defined on a scanned document in a windowing template for future use.

Layouts can also be loaded into memory by loading a Readiris configuration
with the command "Load Settings" under the "File" menu.

Save Layout
Saves the current zoning layout as drawn on the image in a windowing tem-

plate.

Layout files contain predefined windowing structures. Zoning templates are
particularly useful when documents with a similar page layout are OCRed, as the
user avoids having to redraw the same layout again.

Related Command

The command "Load Layout" under the "File" menu loads a layout into memory.

Load Settings
Loads a Readiris configuration into memory.
Settings files determine which scanner model is being used and its settings, the

output mode for the recognized document, the language and characteristics of
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the document to be recognized etc. All operational parameters of Readiris are
saved in the settings files.

Related Commands

Settings are saved with the command "Save Settings" under the "File" menu.
As the basic settings rarely need to be changed, the command "Save Default
Settings" under the "File" menu saves the current settings as default settings to
avoid having to redefine them each time.

Save Settings
Saves the current Readiris configuration in a settings file for later use.

Settings files determine which scanner model is being used and its settings, the
output mode for the recognized document, the language and characteristics of
the document to be recognized etc. All operational parameters of Readiris are
saved in the settings files.

Related Commands

As the basic settings rarely need to be changed, the command "Save Default
Settings" under the "File" menu saves the current settings as default settings to
avoid having to redefine them. Settings are loaded into memory with the com-
mand "Load Settings" under the "File" menu.

Save Default Settings
Saves the current Readiris configuration as default settings.

Settings files determine which scanner model is being used and its settings, the
output mode for the recognized document, the language and characteristics of
the document to be recognized etc. All operational parameters of Readiris are
saved in the settings files.

The default settings are loaded into memory automatically at each startup. As
these settings rarely change, the user avoids having to redefine them.
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Related Commands

Settings are saved with the command "Save Settings" under the "File" menu
and loaded into memory with the command "Load Settings" under the "File" menu.

Exit
Quits the Readiris software.

Related Command

The default settings saved with the command "Save Default Settings" under
the "File" menu will be loaded into memory automatically at the next startup.

EDIT MENU

The commands under the "Edit" menu are limited to the “preview” mode: they
are available only when an image is displayed in Readiris' image zone.

They concern the windows: the user can delete, cut, copy and paste them.
Shortcuts are available for all commands.

Undo
Cancels the last operation.

This command undoes cut, copy and paste operations of text, graphic and
table windows. If the user erroneously deleted, moved, resized etc. windows,
"Undo" will cancel the last operation. This button does not “undo” window selec-
tion operations.

Cut
Transfers the selected window(s) to an internal buffer.

Choosing the "Window Selection or “arrow” tool on the image toolbar and
clicking inside a window suffices to select it. Rectangular markers appear at
each corner and in the middle of the window sides. To select additional windows,
the user holds down the Shift key while he clicks on these extra windows. To
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select a window and the included windows (of another type), he holds down the
Ctrl key while clicking on the main window.

Related Commands

The command "Paste" under the "Edit" menu allows to insert the selected
window(s) stored in an internal buffer. The command "Clear" under the "Edit"
menu deletes the selected window(s) irretrievably. The command "Undo" under
the "Edit" menu undoes delete operations.

Copy
Copies the selected window(s) to an internal buffer.

Choosing the "Select Windows" or “arrow” tool on the image toolbar and
clicking inside a window suffices to select it. Rectangular markers appear at
each corner and in the middle of the window sides. To select additional windows,
the user holds down the Shift key while he clicks on these extra windows. To
select a window and the included windows (of another type), he holds down the
Ctrl key while clicking on the main window.

Related Commands

The command "Paste" under the "Edit" menu allows to insert the selected
window(s) stored in an internal buffer. The command "Cut" under the "Edit"
menu cuts the selected window(s) to an internal buffer, the command "Clear"
under the "Edit" menu deletes the selected window(s) irretrievably.

Paste
Pastes the window(s) stored in an internal buffer.

Windows are pasted in their original position, and the user has to drag them to
their new location.

Related Commands

The command "Copy" under the "Edit" menu copies the selected window(s) to
an internal buffer. The command "Undo" under the "Edit" menu undoes delete
operations.
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Clear
Deletes the selected window(s) irretrievably.

Choosing the "Select Windows" or “arrow” tool on the image toolbar and
clicking inside a window suffices to select it. Rectangular markers appear at
each corner and in the middle of the window sides. To select additional windows,
the user holds down the Shift key while he clicks on these extra windows. To
select a window and the included windows (of another type), he holds down the
Ctrl key while clicking on the main window.

Related Commands

The command "Cut" under the "Edit" menu transfers the selected window(s)
to an internal buffer. The command "Undo" under the "Edit" menu undoes delete
operations.

Select All
Selects all windows of both window types simultaneously.

Related Commands

The command "Cut" under the "Edit" menu transfers the selected window(s)
to an internal buffer. The command "Copy" under the "Edit" menu copies the
selected window(s) to an internal buffer. The command "Paste" under the "Edit"
menu allows to insert the selected window(s) stored in an internal buffer. The
command "Clear" under the "Edit" menu deletes the selected window(s) irre-
trievably. The command "Undo" under the "Edit" menu does not “undo”  selection
operations.

SETTINGS MENU

The "Settings" menu allows to specify the document characteristics and OCR
options. It also allows to configure the scanner.
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Scanner
Refer to the "Scanner" button on the main toolbar.

Language
Refer to the "Language" button on the main toolbar.

Font Type
Determines the font type of the document to be recognized.

The setting "Normal" is used for the printing qualities typeset, typewritten,
laser printed, inkjet printed and “letter quality” dot matrix printing (also called “25
pin” or “NLQ” dot matrix), the setting "Dot matrix" is strictly reserved for draft
dot matrix printing (also called “9 pin” dot matrix); such texts require highly spe-
cialized recognition techniques.

The font type is indicated in the tooltip of the "Recognize" button: when no
message is added to the tooltip, the “normal” font quality applies, when the mes-
sage "Dot Matrix" is added, the dot matrix reading mode is enabled.

This command does not apply to Asian documents.

Related Command

The font type can also be enabled by loading a Readiris configuration with the
command "Load Settings" under the "File" menu.

Character Pitch
Determines the character pitch of the document to be recognized.
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The setting "Fixed" is selected when the document is composed of a fixed
font. With fixed or “monospaced” typefaces, each character of the typeface has
the same width. An "i" takes up as much horizontal space on a
line as a "w", as is the case in this sentence. Such typefaces
are typically found in documents produced by typewriters.

The setting "Proportional" is selected when the document is composed of a
proportional font. With proportional fonts, the width of the letters depends on their
shape. A "w" takes up more horizontal space on a line than an "i", as is the case in
this sentence. Virtually all fonts found in newspapers, magazines and books are
proportional.

The setting "Auto" is selected to have Readiris detect the character pitch
automatically. It is enabled by default and can be left untouched at all times.

This command does not apply to Asian documents.

Related Command

The character pitch can also be enabled by loading a Readiris configuration
with the command "Load Settings" under the "File" menu.

Text Format
Refer to the "Format" button on the main toolbar.

View after Scan
Enables the “preview” mode, where the scanned documents are displayed

on-screen in the image zone.

All commands concerning the image preview - the buttons on the image toolbar
and the commands under the "Edit" menu - are available only when an image is
opened in the image zone.

This minor option is enabled by default, and is best left untouched.

Page Analysis
Refer to the "Page Analysis" button on the main toolbar.
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Enable Wizard on Toolbar
“Installs” the OCR wizard or the automatic mode on the main toolbar: when

this option is enabled, the "OCR Wizard" button that guides the user through the
OCR process is placed on the toolbar, when it is disabled, the "Auto" button that
triggers automatic recognition is placed on the toolbar.

Related Commands

The "OCR Wizard" button on the main toolbar and the command "OCR Wiz-
ard" under the "Process" menu start the OCR wizard.

The option "Enable Wizard on Startup" under the "Settings" menu sees to it
that the OCR wizard starts running each time Readiris is started up. The option
"Enable Wizard on Startup" in the first screen of the wizard has the same effect.

Enable Wizard on Startup
Sees to it that the OCR wizard starts running each time Readiris is started up.

The option "Enable Wizard on Startup" in the first screen of the wizard has the
same effect.

This option is enabled by default.

Related Commands

The "OCR Wizard" button on the main toolbar and the command "OCR Wiz-
ard" under the "Process" menu start the OCR wizard.

The option "Enable Wizard on Toolbar" under the "Settings" menu “installs”
the OCR wizard or the automatic mode on the main toolbar: when this option is
enabled, the "OCR Wizard" button that guides the user through the OCR process
is placed on the toolbar, when it is disabled, the "Auto" button that triggers auto-
matic recognition is placed on the toolbar.
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VIEW MENU

The "View" menu contains the zoom levels and rotation commands. A minor
diagnostic command is added. Buttons on the image toolbar provide quick access
to all frequently used commands.

Fit to Window
Refer to the "Fit to Window" button on the image toolbar.

Fit to Width
Refer to the "Fit to Width" button on the image toolbar.

50% Actual Size
Displays the document at half its real size. (At actual size, a screen pixel

corresponds to an image pixel.)

Related Commands

The "Fit to Window" button on the image toolbar displays the entire document,
the "Fit to Width" button on the image toolbar displays the entire width of a docu-
ment. The commands "Actual Size" and "200% Actual Size" under the "View"
menu display the document at actual size and at double its real size.

Actual Size
Refer to the "Actual Size" button on the image toolbar.

200% Actual Size
Displays the document at twice its real size. (At actual size, a screen pixel

corresponds to an image pixel.)

Related Commands

The "Fit to Window" button on the image toolbar displays the entire document,
the "Fit to Width" button on the image toolbar displays the entire width of a docu-
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ment. The commands "50% Actual Size" and "Actual Size" under the "View"
menu display the document at half its actual size and at double its real size.

Rotate Left
Refer to the "Rotate Left" button on the image toolbar.

Rotate Right
Refer to the "Rotate Right" button on the image toolbar.

Turn Upside Down
Refer to the "Turn Upside Down" button on the image toolbar.

Coordinates
This minor diagnostic option displays the coordinates of the mouse cursor in

document pixels.

Related Command

The user can display the type, coordinates and sort order of a window by
pressing the Alt key while he selects it.

PROCESS MENU

The "Process" menu contains the commands needed to scan, decompose, sort
and recognize documents.

OCR Wizard
Refer to the "OCR Wizard" button on the main toolbar.
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Automatic OCR
Refer to the "Auto" button on the main toolbar.

Scan
Refer to the "Scan" button on the main toolbar.

Open
Refer to the "Open" button on the main toolbar.

Sort
Refer to the "Sort" button on the main toolbar.

Recognize
Refer to the "Recognize" button on the main toolbar.

Analyze Page
Refer to the "Analyze Page" button on the image toolbar.

LEARN MENU

The "Learn" menu contains all commands relating to the interactive learning.

Font training can substantially enhance the accuracy of the recognition sys-
tem. When the user tries to read defaced and stylized font shapes which Readiris
does not recognize optimally, training can overcome this temporary “failure”.

Linguistics offer useful help to solve ambiguous cases such as an "O" which
might be mistaken for a '0'. Another typical example is the letter "l" and number
'1' which have an identical form in many fonts - think of texts produced on old
typewriters! The linguistic context helps to determine whether you are dealing
with "l" or '1'.
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User learning is also used to train the system on special symbols which Readiris
is unable to recognize, such as mathematical and scientific symbols and dingbats.
Readiris can for instance be trained to recognize the "π" symbol as "pi" or the
dingbat "(" as "Tel". (However, the list of recognized symbols cannot be ex-
tended with the symbols "π"and "(".)

Learning does not apply when Asian documents are read: learning does not
make sense for these languages which use thousands of different symbols - as-
suming that the user is able to enter the ideograms, not an easy task when using
a Western keyboard.

Readiris enters the interactive learning phase at the end of the recognition.
When multipage documents are read, the users goes through the recognition and
learning phases page by page.

The recognized text is displayed progressively and the system stops on doubt-
ful characters, or - in the case of touching characters (“ligatures”) - on doubtful
character strings. They are always presented in their context, the doubtful char-
acters are highlighted. Unrecognized characters are represented by a tilde (the
"~" symbol).
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First of all, the user should verify if he has activated the correct font dictionary
and dictionary mode - these are always indicated in the title of the learning win-
dow (as in the tooltip of the "Learn" button on the main toolbar). If that is not the
case, he should click the "Abort" button - the last image is redisplayed with the
zoning as was created -, enable the right font dictionary or dictionary mode and
run the OCR again.

If necessary, a character (or character string) is entered for the incorrect or
unknown shape and one of the following buttons is clicked.

Learn

The user agrees with the proposed solution or corrects it. The program saves
this doubtful character in the font dictionary as “sure”, final. Future recognition
will no longer require his intervention, the shape is considered learnt once and for
all.

In the example above, the system stops on six joined characters, and "Learn"
is to accept a shape which cannot be confused with other characters.

Don't Learn

The user agrees with the proposed solution or corrects it. The difference with
the "Learn" button is that the learnt symbol gets the status “unsure” in the font
dictionary. For future recognition, the system will propose the learnt solution but
still require a confirmation.

This button is used for symbols which might be confused with others: a de-
faced "e" which might be mistaken for a "c", a damaged "t" which closely re-
sembles an "r" etc.
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The "t" above is close to the "r" symbol -, and the user clicks "Don't Learn" so
as not to confuse the two symbols further on.

Delete

The displayed form is eliminated from the output. This button is used to ignore
“noise” on the documents - spots, coffee stains etc. - which might get recognized
as points, comma’s etc. -, and to erase any other unwanted symbol.

Undo

The user goes back to correct mistakes. He can undo the nine last decisions.
Finish

The learning process is aborted but the OCR continues in automatic mode. All
decisions by the system thereafter are accepted without user validation.

This button is clicked when the recognition is highly accurate and does not
require detailled proofreading. (When the "Finish" button is clicked in a multipage
document, the interactive learning is aborted for all pages; the OCR for that
document continues in automatic mode.)



3 - 46

The "Finish" button should not be confused with the "Abort" button: with the
"Abort" button, no output is generated and the OCR must be run again, with the
"Finish" button, the text is created, it just isn't proofread in detail.

The results of a training session are stored in files called “font dictionaries” for
future use. These font dictionaries can be loaded to make good use of previous
training, so that Readiris will recognize the learnt character shapes automatically.

Font Dictionary
Selects or defines a font dictionary and its mode of operation.

User dictionaries contain font information the system learns during the inter-
active learning. When many documents of the same type are recognized, the
user can avoid having to go through the same learning process every time. The
learnt characters can be stored in a font dictionary and that information can be
used when documents of the same type are recognized.
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The user also sets the dictionary mode: "New Dictionary" creates a new dic-
tionary, the user starts without any previous knowledge. The option "Append
Dictionary" uses the previously learnt font information and completes it, the op-
tion "Read Dictionary" uses the previously learnt font information but does not
complete it further.

The new mode is selected when a single page is recognized. To recognize
many pages of the same type - pages with the same fonts and printing quality -
the new mode is selected for the first page, the append mode for a few pages
more and the read mode for the rest of the document(s). When multipage docu-
ments are recognized, scanning a next page automatically puts the font dictionary
in the append mode.

As font dictionaries are limited to 500 learnt shapes, the user is recommended
to create specific dictionaries for specific applications, for instance per type of
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document. For clarity, it is recommend to give meaningful names to the font
dictionaries, for instance REPORT.DUS, PALATINO.DUS dus etc. Dictionar-
ies have the default extension *.DUS.

When the user enters a filename for a new dictionary and activates the “ap-
pend“ mode, an empty font dictionary is created to be completed.

When a dictionary is full, the learning has no further effect: the results of the
learning are no longer held in memory or written to a dictionary.

Related Commands

The dictionary mode can also be set with the options "New Font Dictionary",
"Append Font Dictionary" and "Read Font Dictionary" under the "Learn" menu.

The tooltip of the "Learn" button on the main toolbar indicates the font dictio-
nary and its mode.

The "Learn" button on the main toolbar enables the interactive learning.
A font dictionary and its mode can also be enabled by loading a Readiris

configuration with the command "Load Settings" under the "File" menu.

New, Append, Read Font Dictionary
Sets the mode of the font dictionary.
"New Font Dictionary" creates a new dictionary, the user starts without any

previous knowledge. The option "Append Font Dictionary" uses the previously
learnt font information and completes it, the option "Read Font Dictionary" uses
the previously learnt font information but does not complete it further.

The new mode is selected when a single page is recognized. To recognize
many pages of the same type - pages with the same fonts and printing quality -
the new mode is selected for the first page, the append mode for a few more
pages and the read mode for the rest of the document(s). When multipage docu-
ments are recognized, scanning a next page automatically puts the font dictionary
in the append mode.

When a dictionary is full, the learning has no further effect: the results of the
learning are no longer held in memory or written to a dictionary.
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The tooltip of the "Learn" button indicates the font dictionary and its mode.

Related Commands

The mode can also be set with the options "New Dictionary", "Append Dictio-
nary" and "Read Dictionary" of the "Font Dictionary" command under the "Learn"
menu, and can be enabled by loading a Readiris configuration with the command
"Load Settings" under the "File" menu.

The "Learn" button on the main toolbar enables the interactive learning, the
command "Font Dictionary" under the "Learn" menu selects a font dictionary and
sets its mode.

Interactive Learning
Refer to the "Learn" button on the main toolbar.

REGISTER MENU

The "Register" menu allows the user to register his software licence.

Registration Wizard
Starts the registration wizard.
The registration wizard guides the user through the licence registration pro-

cess comfortably. The user can register in many ways: by sending in the registra-
tion card or faxing its electronic counterpart, by calling I.R.I.S. during working
hours and by filling out a registration form on the I.R.I.S. web site.

Depending on the software bundle, he'll receive the softkey in return as may
be needed to continue using the Readiris software after one month.
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Registering the Readiris licence will allow I.R.I.S. to keep the user informed
of future product developments and related I.R.I.S. products. The registration
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benefits, including free product support and special offers, are strictly limited to
registered users.

HELP MENU

The "Help" menu contains the on-line help system.
Some last-minute information may not be included in this manual. The user is

recommended to consult the on-line help system for additional information on
Readiris' capabilities.

Help Topics
Allows to navigate through the on-line help system.
The available information cannot only be consulted on-screen but also printed

out.
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Product Support
Informs the user how to get Readiris product support.
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Contact I.R.I.S.
Gives the coordinates of the I.R.I.S. offices.
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About Readiris
Displays the startup screen where the software version and copyrights are

displayed.
The user clicks anywhere to return to the Readiris software.
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CONTEXT MENU

The "Context" menu gives access to the page commands of multipage docu-
ments. These commands allow to edit multipage documents, mainly to correct
scanning errors. The user can delete pages from the document and move pages
to other locations in the document.

This menu is invoked by right-clicking over a page icon in the page toolbar -
this toolbar is displayed below the image zone only when multipage documents,
not single pages, are processed.

The commands from this menu apply to the page under the user's mouse
cursor, not to the current page.

Select Page
The user goes to the page under his mouse cursor.
The current page is higlighted in the image toolbar and mentioned in the Readiris

title bar.

Alternatively, the user can double-click on a page's icon in the page toolbar to
select a page.

Related Commands

The command "Delete Page" from the "Context" menu deletes the page under
the user's mouse cursor from the multipage document, the command "Move Page
Up" from the "Context" menu moves the page under the user's mouse cursor one
page up in the document and the command "Move Page Down" from the "Con-
text" menu moves the page under the user's mouse cursor one page down in the
document.

Delete Page
The user erases the page under his mouse cursor from the multipage docu-

ment.
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Related Commands

The command "Select Page" from the "Context" menu brings the user to the
page under his mouse cursor, the command "Move Page Up" from the "Context"
menu moves the page under the user's mouse cursor one page up in the docu-
ment and the command "Move Page Down" from the "Context" menu moves the
page under the user's mouse cursor one page down in the document.

Move Page Up
The user moves the page under his mouse cursor one page up in the multipage

document.

Related Commands

The command "Select Page" from the "Context" menu brings the user to the
page under his mouse cursor, the command "Delete Page" from the "Context"
menu deletes the page under the user's mouse cursor from the multipage docu-
ment and the command "Move Page Down" from the "Context" menu moves the
page under the user's mouse cursor one page down in the document.

Move Page Down
The user moves the page under his mouse cursor one page down in the multipage

document.

Related Commands

The command "Select Page" from the "Context" menu brings the user to the
page under his mouse cursor, the command "Delete Page" from the "Context"
menu deletes the page under the user's mouse cursor from the multipage docu-
ment and the command "Move Page Up" from the "Context" menu moves the
page under the user's mouse cursor one page up in the document.
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Appendix
PRODUCT DESCRIPTION

This appendix gives a detailled product description of Readiris.

Recognition Connectionist technology

omnifont feature extraction

self-learning routines derived from a proprietary neu-
ral network technique

contextual and linguistic analysis

powerful learning module

Linguistic support 55 languages (American English, British English, Afri-
kaans, Albanian, Basque, Brazilian, Breton, Bulgarian,
Byelorussian, Catalan, Corsican, Croatian, Czech, Dan-
ish, Dutch, Estonian, Finnish, French, Frisian, German,
Greek, Hungarian, Icelandic, Indonesian, Irish (Gaelic),
Italian, Lithuanian, Luxemburgh, Macedonian, Malay,
Norwegian, Nynorsk, Polish, Portuguese, Romanian,
Russian, Scottish (Gaelic), Serbian, Slovak, Slovenian,
Spanish, Swahili, Swedish, Tagalog, Turkish and
Ukranian)

7 mixed language modes (Bulgarian-English,
Byelorussian-English, Greek-English, Macedonian-En-
glish, Russian-English, Serbian-English and Ukranian-
English)
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linguistic modules using knowledge about syllables and
a 100,000 word lexicon per language

software option “Asian OCR add-on” provides OCR
of Japanese and Simplified Chinese

to view and edit Asian documents, an Asian, Japanese
or Chinese version of the Windows operating system is
installed or specialized “emulating” software (such as
UnionWay AsianSuite or TwinBridge AsianBridge) is
on a Western version of Windows

Character sets all American and European character sets, including
the Central-European, Cyrilic (“Russian”), Greek, Bal-
tic, Japanese and Simplified Chinese alphabets

use of mixed characters sets for recognition of “West-
ern” words (proper names, brand names etc.) in Cyrillic
(“Russian”), Greek and Asian documents

numeric mode for recognition of tables of figures
trainable on any special symbol: mathematic and sci-
entific symbols, dingbats etc.

Printing quality typeset, typed, laser printed, inkjet printed, letter qual-
ity dot matrix (“25 pin” or “NLQ”) and draft dot matrix
(“9 pin”) printed documents

lineskew tolerance 7 degrees

Fonts virtually any proportional and fixed (“monospaced”)
typeface

normal, bold, italic and underlined typestyles

detection and recreation of font type (serif-sans serif,
proportional-fixed, normal-condensed), typestyle (bold,
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italic and underlined) and point size of original docu-
ment in “autoformatting” mode

character sizes 6 to 72 point (0.08 to 1" or 0.21 to 2.54
cm)

drop letter (“drop caps”) recognition

User interface toolbar based operation

OCR wizard guides user through the recognition pro-
cess

automatic mode allows “one-click” OCR
recognition of single pages and multipage documents

pop-up style user verification

stand-alone operation or call from within Windows ap-
plications through “Connect” capability

DDE command set available to integrate OCR func-
tion

Preview image preview with 5 zoom levels and 3 rotate com-
mands

highly accurate, skew-tolerant automatic page analy-
sis discriminates text zones, tables and graphics

detection of white text on a black background with
automatic inversion at recognition time and image in-
version of all scanned pages
adjustable manual windowing of relevant zones using
rectangular and polygonal windows

storage of zoning templates for future use
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Text output all leading wordprocessors and text formats including
Microsoft Word (DOC), RTF and HTML

output to Windows clipboard

direct, automatic export of OCR result to
wordprocessor Microsoft Word, spreadsheet Microsoft
Excel and Windows accesory WordPad

paragraph detection ensures wordwrap

“autoformatting” feature recreates facsimile copy of
original document through word formatting - font type
(serif-sans serif, proportional-fixed, normal-condensed),
typestyle (bold, italic and underlined) and point size -,
paragraph formatting - alignment (left, centered, right
and justified) and indentation - and page formatting -
placement of text blocks, columns, graphics and tables

Table output detection of “gridded” and “non-gridded” tables by page
analysis
recreation of tables cell by cell in spreadsheets and
wordprocessors (table objects in Microsoft Word
(DOC) and RTF files)

direct, automatic export of tables to spreadsheet
Microsoft Excel and wordprocessor Microsoft Word

Graphic output black-and-white graphics in (compressed) TIFF and
Paintbrush (PCX) format

graphics included in RTF file when “autoformatting” is
applied
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Scanner support supports wide range of flatbed, sheetfed and hand-held
scanners and “all-in-one” MFPs (“multifunctional pe-
ripherals”)
compliant with Twain scanner standard and HP SCL
software

supports scanning platforms Visioneer PaperPort, HP
Document Assistant, HP JetSuite, Microtek PageSuite
and Primax PaperEase

Graphic input black-and-white images in TIFF (uncompressed,
packbits, Group 3 and Group 4 compressed), multipage
TIFF, Paintbrush (PCX) and Windows bitmap (BMP)
format

allows direct recognition of fax files

“drag and drop” of images onto the Readiris image zone

System requirements a 486 based Intel PC with 16 MB RAM and 30 MB
free disk space. A Pentium based PC with 32 MB RAM
is recommended under Windows NT 4.0 and to use
the “Connect” capability
the Windows 98, 95 or Windows NT 4.0 operating sys-
tem

to view and edit Asian documents, an Asian, Japanese
or Chinese version of the Windows operating system is
installed or specialized “emulating” software (such as
UnionWay AsianSuite or TwinBridge AsianBridge) is
on a Western version of Windows

MacOS version available

Linguistic versions English, Dutch, French, German, Italian and Spanish
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consult the I.R.I.S. web site for the availability of addi-
tional localized versions
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