Glide64 Readme

Glide64

International Emulation Project

Version: "Napalm" Public Release 1

Author: Sergey 'Gonetz' Lipski (Russia)

Disclaimer:

Neither I, nor anyone who is working with me, will take ANY responsibility for your actions or if this program causes harm to anything, including you and your computer, in any way, physically or mentally.

Table of Contents:

  1. What is Glide64?
  2. The Very Quick Start
  3. Utility settings
  4. Rendering settings
  5. Frame buffer emulation settings
  6. About hardware frame buffer emulation
  7. Depth buffer emulation
  8. Special game settings/fixes
  9. Texture enhancement and hi-resolution textures

1. What is Glide64?

Glide64 is a graphics plugin for Nintendo 64 emulators. It can run natively on 3dfx cards, or via a OpenGL-based wrapper for modern video cards. The project started on 29 December 2001 by David 'Dave2001' Forrester (USA). Gugaman (Brazil) and Sergey 'Gonetz' Lipski (that is me) joined him at February 2002. We worked together until the autumn of 2002. Then, Dave2001 and Gugaman left the project. Since that time I'm the only developer of the plugin. However, I'm not the only one, who works on this project. The Glide64 project includes two additional libraries beside the plugin itself. The first one is the library known as the 'Glitch64' wrapper, previously known as "Hacktarux's glide wrapper", named after its original author, Hacktarux (France). It then was heavily modified & improved by Vincent 'ziggy' Penne (France) and Brad 'mudlord' Miller (Australia). The second library is a texture enhancement module named 'GlideHQ', created by Hiroshi 'KoolSmoky' Morii (Japan). Beside that, lots of people from around the world helped me to test the plugin and gave me valuable advices on how to improve it. The main tester of this version is Olivieryuyu (France); and additional testing, advices and friendly support was provided by Wesley 'Legend' Mcdaniel (USA).

2. The Very Quick Start

To install Glide64:

  1. Unpack the distribution somewhere (as you read this text, you probably already did it)
  2. Copy everything from the 'Plugin' folder, into the folder, where all your N64 plugins are stored. This is usually the 'Plugin' sub-folder in your emulator's folder, e.g. Project64\Plugin
  3. For OpenGL rendering, copy glide3x.dll from the 'Wrapper' folder, into your emulator's folder.

To setup Glide64:

  1. Launch your emulator.
  2. Select Glide64 as your graphics plugin.
  3. Select 'Configure graphics plugin'
  4. In Glide64 configuration dialog, on the 'Config' tab, select your desired resolution. It will be fullscreen resolution for 3dfx cards, or windowed resolution for other cards.
  5. If 'Wrapper settings' button is not grayed, push it and select your desired fullscreen resolution.

Glide64 is now ready to use. If you're a novice in N64 emulation, you may skip the rest of this document, start your favorite games and enjoy. If you are an experienced emu fan, or a curious person, read further for explanation for other options and various tips and tricks.

3. Utility settings

Utility settings are placed on the 'On screen info' tab. You may select them with no worries - these settings do not impact the emulation process.

Select any or all options in the 'Speed' option group to see, how fast the plugin executes. 'FPS counter' will show you the actual frames per second (FPS) for the current game. This number depends on the running game. The 'VI/s counter' will show you the number of visual interrupts per second received by the plugin. This number must be 50 for PAL games and 60 for NTSC games. '% speed' will show you, how fast your game is emulated; 100% means that the currently emulated game runs at perfect speed. 'FPS transparent' option makes background of the counter(s) transparent. All speed information displayed in the lower left corner of the screen.

Select 'Clock enabled' in the 'Time' group to see current the time. Select 'Clock is 24-hour' to see the time in 24-hour format. Time information will be displayed in the lower right corner of the screen.

4. Rendering settings

By default, you may only change the screen resolution and set Vertical Sync on/off. Other settings are defined in the Glide64 ini file, and usually must not be changed. However, if you need to change these options, uncheck 'Custom ini settings' in the 'Other' group of the plugin's settings.

'Filtering mode' - you may set 'Force bilinear', 'Automatic' or 'Force point-sampled' mode. You also may easily switch between filtering modes during game play by pressing the backspace button.

'Buffer swapping modes' - it's hard to explain the difference between these modes. Just select any available option. If a game will flicker, select another buffer swapping mode.

'Fog' - sets fog emulation on/off.

'Buffer clear on every frame' - force frame buffer clear. Usually frame buffer clear is controlled by the game. However, in some cases it is not well emulated, and some garbage may left on the screen. In such cases, this option must be set on.

'Anisotropic filtering' - to set it, push the 'Wrapper settings' button, and set the 'Anisotropic filtering' option on. This may noticeably improve image quality in some games.

5. Frame buffer emulation settings

N64 games often use auxiliary frame buffers to implement special game effects like motion blur or for optimization purposes. The console can allocate as many auxiliary frame buffers as needed and then use them as usual textures. PC video cards usually use only one buffer per frame, thus emulation of frame buffer effects is always a hard problem. Glide64 implements lot of methods of frame buffer emulation, to support as many effects as possible. Most games will work fine with pre-defined settings, but some effects require additional options to be set. Known cases are described in the Compatibility List and in the Game Tips. You may set the following options:

'Enable frame buffer emulation' - when this option is on, the plugin will try to detect frame buffer effects usage and emulate them. This option is grayed when 'Custom ini settings' is on. This means, that the ini file controls this option.

'Hardware frame buffer emulation' - enables hardware frame buffer emulation. Usually, this must be set on, except some rare cases, mentioned in the Compatibility List. Read next chapter for explanation of hardware frame buffer emulation.

'Motion blur' - enable motion blur emulation. Motion blur works slow without hardware frame buffer emulation, so it is made optional. This option usually must be on, because most of cards support hardware frame buffer emulation. You may also switch it on/off during game play by pressing ALT-B.

'Read every frame' - in some cases, Glide64 cannot detect frame buffer usage by the game. In this case the only way to emulate frame buffer effects, is to read every rendered frame from video memory and put it into the emulated RDRAM. Reading from video memory is usually slow, so this method of frame buffer emulation is optional. You may also switch it on/off during game play by pressing ALT-V.

'Get frame buffer info' - this is another way to emulate frame buffer effects, which the plugin cannot detect. This option allows the plugin to get notification about frame buffer usage from the emulator and thus emulate frame buffer effects without slowdown. Currently it works only with Mupen64. Do not enable this option with 1964, otherwise the emulator will crash.

6. About hardware frame buffer emulation

The usual method of frame buffer emulation, which theoretically should always work, is to render auxiliary frame buffers into the main video buffer and then read it from video memory into main memory, and put into the structure representing N64 memory (RDRAM). This approach has 2 main disadvantages:

1) auxiliary frame buffers may be visible when they should not.

2) reading from video memory is a very slow operation, thus many frame buffer effects will be slow.

Besides, image taken from video memory must be scaled down to N64 native resolution (usually 320x240), thus quality lost is inevitable. To avoid these problems, Glide64 uses the Glide3x extension, which allows it to create auxiliary frame buffers right into video memory, like the N64 does. This allows the plugin to run frame buffer effects without speed hits or quality loss. Hardware frame buffer emulation (HWFBE) greatly improves many games, but it has some restrictions:

1) HWFBE is in fact a hack - auxiliary frame buffers are not put into N64 memory. When a game uses a texture located in RDRAM corresponding to an auxiliary frame buffer, the plugin uses the texture located in video memory instead. The game may use this area in RDRAM for different textures later, but the plugin will use it's auxiliary buffer anyway, which leads to serious glitches. I have tried to reduce the probability of this situation, but it is still possible. If you encounter it, switch to windowed mode, and then back to full screen again.

2) The Glide extension used for HWFBE is fully supported by Voodoo 4/5 only. Banshee and Voodoo3 cards also support it, but only for small auxiliary frame buffers (e.g. shadows). Other Voodoo cards do not support it at all!

3) HWFBE may not work for Voodoo4/5 if the anti-aliasing option is set to "fastest performance". Use any other option there.

4) Anti-aliasing is not applicable to auxiliary frame buffers.

5) The wrapper support HWFBE almost fully, but it has its peculiarities. Two ways of hardware frame buffer emulation are implemented in the wrapper - with, and without usage of the OpenGL Frame Buffer Objects (FBO) extension. The method with FBO's works fast on any card, which supports FBO's, but it may cause depth issues, since framebuffer objects use their own depth buffer. The method without FBO's works on almost any card, has no problems with depth buffer usage, but it may work slowly on ATI cards. To switch between these methods, press the 'Wrapper settings' button and set the 'Use Framebuffer Objects' option on/off.

7. Depth buffer emulation

Sometimes N64 games use values in the depth buffer to decide, when to render some particular object or not. This is often used for coronas, which must be rendered only if they are not covered by other objects in the 3D scene. To emulate it properly, the N64 depth buffer must be filled with correct values. Glide64 uses software rendering to fill the N64 depth buffer. It is enabled by default. If you experience performance issues, set the 'Software depth buffer rendering' option off.

8. Special game settings/fixes

'LOD calculation'. The N64 uses a very special way to implement mip-mapping, which has no direct analogues on PC hardware. Glide64 implements a rough approximation of N64 mip-mapping, which can be enabled by setting 'LOD calculation' option to 'fast' or 'precise'. The result is not always good though.

'Texture wrap hack' - force texture wrapping. This hack is useful for 3D levels in Mischief Makers. It may help for other games with similar texture issues.

'Render N64 frame buffer as texture'. The N64 architecture allows the CPU to write directly into the frame buffer. Sometimes N64 games uses this ability, which may lead to graphics lost during emulation, since graphics plugin does not know, that some graphics are already written in the N64 frame buffer by by the CPU. Some examples of this are: falling pills in Dr.Mario and rain in Jet Force Gemini. When this option is enabled, content of each N64 frame buffer is rendered as a texture over the current rendered frame. This prevents graphics loss, but may cause slowdowns and various glitches in some games.

'Detect CPU write to N64 frame buffer'- this option works as the previous options, but the plugin is trying to detect, when a game uses CPU writes to the N64 frame buffer. The N64 frame buffer is rendered only when CPU writes is detected. Use this option for those games, in which you see still image or no image at all for some time with no reason.

9. Texture enhancement and hi-resolution textures

Texture enhancement is done via GlideHQ - a real-time texture enhancer library with hi-resolution texture pack support. GlideHQ is an independent DLL, which dynamically loaded by Glide64, when it is needed. GlideHQ itself has no user interface; all its settings are placed on the 'Texture enhancement' tab.

The following are details for some of the GlideHQ options. Others are hopefully self-explanatory.

'Texture enhancement' - 'Texture cache':
Enhanced and filtered textures are cached for later use. This helps boost performance if there are subsequent requests for the same texture, which is the case for most games. Normally, 128MB should be more than enough but there is a sweet spot for each game. 32MB will be enough for Super Mario, but Conker's BFD streams a lot of textures so setting 256MB or more will boost performance.

'Compress memory used for texture cache':
Memory will be compressed so that more textures can be held in the texture cache. The compression ratio varies with each texture, but 1/5 of the original size would be a modest approximation. They will be decompressed on-the-fly, before being downloaded to the gfx hardware. This option will still help save memory space even when using texture compressions such as FXT1 and S3TC.

'Apply texture compression':
Textures will be compressed using the FXT1 or S3TC format. The overall compression ratio is about 1/6 for FXT1 and 1/4 for S3TC. In addition to saving space on the texture cache, the space occupied on the GFX hardware's texture RAM, by the enhanced textures, will be greatly reduced. This minimizes texture RAM usage, decreasing the number of texture swaps to the GFX hardware leading to performance gains.

'Hi-resolution textures - Force 16bpp textures':
The color of the textures will be reduced to 16bpp. This is another space saver and performance enhancer. This halves the space used on the texture cache and the GFX hardware's texture RAM. Color reduction is done so that the original quality is preserved as much as possible. The rendered result will be indistinguishable from the results of 32bpp textures, unless examined carefully.


Glide64 Readme

Glide64

Международный Эмуляционный Проект

Версия: "Napalm" Public Release 1

Автор: Сергей 'Gonetz' Липский (Россия)

Disclaimer:

Ни я, и никто другой работающий со мной, не несет никакой отвественности за любые события в вашей жизни, связанные и не связанные с использованием этой программы.

Содержание:

  1. Что такое Glide64?
  2. Очень быстрый старт
  3. Вспомогательные настройки
  4. Видео настройки
  5. Настройки эмуляции буфера кадра
  6. О аппаратной эмуляции буфера кадра
  7. Эмуляция буфера глубины
  8. Специальные настройки игр
  9. Улучшение текстур и текстуры высокого разрешения

1. Что такое Glide64?

Glide64 является графическим плагином для эмуляторов Nintendo 64. Он работает напрямую на видео картах 3dfx, или через OpenGL враппер* на современных видео картах. Проект основал David 'Dave2001' Forrester (США) 29 декабря 2001. Gugaman (Бразилия) и Сергей 'Gonetz' Липский (то есть я) присоединились к нему в феврале 2002. Вместе мы работали до осени 2002. Затем Dave2001 и Gugaman покинули проект. С тех пор я единственный разработчик плагина. Однако, я не единственный, кто работает над этим проектом. Проект Glide64 помимо собственно плагина включает две дополнительных библиотеки. Первой библиотекой является враппер 'Glitch64', ранее известный как Hacktarux's glide wrapper, по имени его первого автора, Hacktarux (Франция). Затем он был серьезно изменен и улучшен силами Vincent 'ziggy' Penne (Франция) и Brad 'mudlord' Miller(Австралия). Второй библиотекой является модуль улучшения текстур 'GlideHQ', созданный Hiroshi 'KoolSmoky' Morii (Япония). Кроме того, множество людей со всего света помогали мне тестировать плагин и предлагали ценные советы по его улучшению. Основной тестер данной версии Olivieryuyu (Франция); дополнительное тестирование, советы и дружеская поддержка Wesley 'Legend' Mcdaniel (США).

*враппер - от английского wrapper: программа - оболочка, выполняющая замену вызов одного программного интерфейса, в данном случае Glide3x API, в вызовы другого интерфейса, в данном случае OpenGL API.

2. Очень быстрый старт

Для установки Glide64:

  1. Распакуйте куда-нибудь дистрибутив (раз вы читаете этот текст, это наверное уже сделано)
  2. Скопируйте все из папки 'Plugin' в папку, где хранятся все ваши N64 плагины. Обычно это подпапка 'Plugin' в основной папке вашего эмулятора, например Project64\Plugin
  3. Для использования OpenGL, скопируйте glide3x.dll из папки 'Wrapper' в основную папку вашего эмулятора.

Для настройки Glide64:

  1. Запустите эмулятор.
  2. Выберите Glide64 в качестве вашего графического плагина.
  3. Выберите 'Configure graphics plugin'
  4. В открывшемся окне настроек Glide64, на закладке 'Config', выберите нужное разрешение. Для 3dfx видео карт это будет полноэкранное разрешение, для остальных карт это оконное разрешение.
  5. Если кнопка 'Wrapper settings' не отключена, нажмите ее и выберите в открывшемся окне нужное полноэкранное разрешение.

Теперь Glide64 готов к использованию. Если вы новичок в эмуляции N64, то можете пропустить остаток документа, запустить любимые игры и наслаждаться. Если вы опытный эмуляторщик, или просто любопытны, читайте дальше пояснения к остальным настрокам и различные советы по использованию плагина.

3. Вспомогательные настройки

Вспомогательные настройки расположены на закладке 'On screen info'. Эти настройки можно использовать без опасений - они не влияют на процесс эмуляции.

Выберите любую опцию, или все сразу, в группе 'Speed' для отображения счетчиков скорости работы плагина. 'FPS counter' показывает количество кадров в секунду. Это число может быть разным в зависимости от запускаемой игры. 'VI/s counter' показывает количество видео прерываний в секунду, полученных плагином. Это число должно быть равным 50 для PAL и 60 для NTSC игр. '% speed' показывает, насколько быстро эмулируется игра; 100% означает, что игра эмулируется с правильной скоростью. 'FPS transparent' - эта опция делает фон счетчиков прозрачным. Все счетчики скорости отображаются в левом нижнем углу экрана.

Выберите 'Clock enabled' в группе 'Time' для отображения текущего времени. Выберите 'Clock is 24-hour' для отображения времени в 24х часовом формате. Время отображается в правом нижнем углу экрана.

4. Видео настройки

По умолчанию, все настройки видео, кроме разрешения экрана и Vertical Sync, не доступны. Видео настройки задаются в файле инициализации Glide64, и обычно не должны меняться. Если вам все же нужно изменить эти настройки, отключите 'Custom ini settings' в группе 'Other'.

'Filtering mode' - режим фильтрации текстур. Можно выбрать режимы 'Force bilinear', 'Automatic' или 'Force point-sampled'. Также между режимами можно переключаться во время игры, нажимая backspace.

'Buffer swapping modes' - режим смены буффера кадра. Объяснить разницу между имеющимися режимами сложно. Просто выберите одну из опций. Если изображение в игре начнет моргать, выберите другой режим.

'Fog' - туман. Включение/выключение эмуляции тумана.

'Buffer clear on every frame' - принудительная очистка буфера кадра. Обычно очистка буфера кадра контролируется игрой. Иногда это плохо эмулируется, и на экране остается мусор. В таких случаях эта опция должна быть включена.

'Anisotropy filtering' - Анизотропная фильтрация. Для ее включения нажмите кнопку 'Wrapper settings' и включите опцию 'Anisotropy filtering'. Это позволяет заметно улучшить качество изображения в некоторых играх.

5. Настройки эмуляции буфера кадра

Игры для N64 часто используют вспомогательный буфер кадра для реализации спец-эффектов вроде эффекта размытия движения, или в целях оптимизации. Сама приставка может использовать произвольное количество вспомогательных буферов кадра, и использовать любой буфер кадра как обычную текстуру. Видео карты для PC обычно используют только один буффер для отрисовки текущего кадра, который к тому-же нельзя напрямую использовать как текстуру. Соотвественно, эмуляция приставочных эффектов на PC всегда является сложной проблемой. Glide64 реализует множество методов эмуляции эффектов буфера кадра, чтобы поддержать как можно больше эффектов. Большинство игр нормально работает с предустановленными настройками, но для некоторых эффектов нужно установить дополнительные настройки. Известные случаи описаны в Compatibility List и в Game Tips. Пользователям доступны следующие опции:

'Enable frame buffer emulation' - включить эмуляцию буфера кадра. Когда эта опция включена, плагин пытается заранее определить использование спецэффектов и применить нужный метод эмуляции. Эта опция не доступна, когда включена опция 'Custom ini settings', то есть когда эмуляция буфера кадра контролируется настройками в файле инициализации.

'Hardware frame buffer emulation' - включить аппаратную эмуляцию буфера кадра. Обычно должно быть включено, кроме некоторых редких случаев, описанных в Compatibility List. Описание аппаратной эмуляции буфера кадра дано в следующей главе.

'Motion blur' - включить эмуляцию эффекта размытия движения. Этот эффект работает медленно без аппаратной эмуляции буфера кадра, поэтому он сделан опциональным. Эта опция обычно должна быть включена, так как большинство карт поддерживают аппаратную эмуляцию буфера кадра. Эффукт также можно включить/выключить во время игры, нажав ALT-B.

'Read every frame' - считывать каждый кадр. В некоторых случаях плагин не может определить использование буфера кадра. Тогда единственным способом эмулировать эффект является считывание каждого кадра из памяти видео карты и запись его в соответствующую область RDRAM. Так как чтение из памяти видеокарты обычно выполняется медленно, этот метод эмуляции является опциональным. Его также можно включить/выключить во время игры, нажав ALT-V.

'Get frame buffer info' - получить информацию об использовании буфера кадра. Это альтернативный способ эмулировать те эффекты буфера кадра, которые плагин не способен определить. Если эта настройка включена, плагин получает информацию от эмулятора, что буфер кадра будет использоваться для спецэффекта. Это позволяет эмулировать такие эффекты без замедления работы. В данный момент этот способ работает только с Mupen64. Не включайте эту настройку с 1964, иначе эмулятор может поломаться.

6. О аппаратной эмуляции буфера кадра

Обычным способом эмуляции буфера кадра, который теоретически должен работать во всех случаях, является отрисовка вспомогательных буферов кадра внутри основного с последующим чтением их из памяти видео карты в основную память и записью в структуру, представляющую память N64 (RDRAM). У этого подхода два основных недостатка:

1) вспомогательный буфер кадра может быть виден на экране.

2) чтение из памяти видео карты является медленной операцией. Поэтому многие эффекты эмулируются медленно.

Кроме того, кадр, считанный из видео памяти, должен быть масштабирован в родное разрешение N64 (обычно 320x240), что влечет неизбежные потери качества. Чтобы избежать этих недостатков, Glide64 использует расширения Glide3x API, позволяющие создавать вспомогательные буферы кадра прямо в видео памяти, подобно тому, как действует N64. Это позволяет эмулировать спецэффекты без потери скорости и качества. Аппаратная эмуляция буфера кадра (HWFBE - Hardware frame buffer emulation) значительно улучшает работу многих игр, но она имеет некоторые ограничения:

1) HWFBE фактически является хаком - буфер кадра не копируется в память N64. Когда игра использует текстуру, расположенную в области памяти RDRAM, соответствующей буферу кадра, то плагин использует вместо нее вспомогательный буфер кадра, расположенный в видео памяти, как тектстуру высокого разрешения. Позже игра может пере использовать эту область в RDRAM для другой текстуры, но плагин об этом не узнает и будет по прежнему использовать в качестве текстуры вспомогательный буфер кадра. Я постарался сократить вероятность этой ситуации, но она все еще возможна. Если вы наткнулись на подобную проблему, переключитесь в оконный режим и обратно.

2) Расширения Glide3x API, используемые для HWFBE полностью поддерживаются только Voodoo 4/5. Banshee и Voodoo3 также поддерживают эти расширения, но только для маленьких вспомогательных буферов (например, для теней). Остальные 3dfx карты не поддерживают эти расширения вовсе!

3) HWFBE может не работать для Voodoo4/5, когда anti-aliasing установлен в "fastest performance". Используйте любую другую опцию.

4) Anti-aliasing не применяется к вспомогательным буферам кадра.

5) Враппер поддерживает HWFBE почти полностью, но со своими особенностями. Аппаратная эмуляция буфера кадра реализована во враппере двумя методами - с использованием OpenGL расширения Frame Buffer Objects (FBO) и без него. Метод с FBO работает быстро на всех картах, которые поддерживают это расширение, но он может вызывать проблемы с буфером глубины, так как FBO используют свой собственный буфер глубины. Метод без FBO работает почти на всех картах, не имеет проблем с буфером кадра, но на картах ATI он может работать медленно. Для переключения между этими методами, нажмите кнопку 'Wrapper settings' и включите/выключите опцию 'Use Framebuffer Objects'.

7. Эмуляция буфера глубины

Иногда игры для N64 используют значения в буфере глубины, чтобы определить, когда отрисовывать некоторые объекты. Это часто используется для короны вокруг ламп или факелов, которая должна отрисовываться только если она не закрывается другими объектами сцены. Для правильной эмуляции буфер глубины должен быть заполнен корректными значениями. Glide64 использует программную отрисовку для заполнения буфера глубины N64. По умолчанию она включена. Если у вас возникнут проблемы с производительностью, отключите опцию 'Software depth buffer rendering'.

8. Специальные настройки игр

'LOD calculation'. N64 использует весьма специфичный способ реализации мип-маппинга, не имеющего прямого аналога на видео картах для PC. В Glide64 реализовано грубое приближение мип-маппинга N64, которое включается установлением значения опции 'LOD calculation' в 'fast' (быстрый) или 'precise' (точный). Результат не всегда удовлетворительный.

'Texture wrap hack' - принудительный враппинг текстур. Этот хак полезен на 3х-мерных уровнях в MischiefMakers. Возможно это поможет в других играх со схожими текстурными проблемами.

'Render N64 frame buffer as texture'. Архитектура N64 позволяет CPU писать напрямую в буфер кадра. Некоторые игры используют эту возможность, что может привести к потери части или всей графики, так как графический плагин не знает, что CPU уже записал что-то в буфер кадра N64, и это нужно отобразить. Примеры: падающие пилюли в Dr.Mario, дождь в Jet Force Gemini. При включении этой опции, содержимое каждого буфера кадра N64 отрисовывается как текстура поверх готового кадра. Это предотвращает потерю графики, но может вызвать замедление работы и графические аномалии в некоторых играх.

'Detect CPU write to N64 frame buffer'- работает как предыдущая опция, только в этом случае плагин пытается определить, когда игра использует прямую запись в буфер кадра N64. Буфер кадра N64 выводится на экран только тогда, когда есть подозрение на прямую запись CPU в буфер. Используйте эту опцию для тех игр, в которых случаются застывание или пропадание картинки без видимой причины.

9. Улучшение текстур и текстуры высокого разрешения

Улучшение текстур производится через GlideHQ - библиотеку улучшения текстур в реальном времени с поддержкой наборов текстур высокого разрешения. GlideHQ является независимой dll, которую Glide64 по необходимости автоматически подгружает. GlideHQ не имеет своего пользовательского интерфейса; все ее настройки расположены на закладке 'Texture enhancement'.

Описание некоторых опций GlideHQ даны ниже. Остальные опции и так понятны.

'Texture enhancement' - 'Texture cache':
Кэшировать улучшенные и отфильтрованные текстуры для дальнейшего использования. Сильно помогает улучшить производительность при повторных обращениях к текстуре. Оптимальный размер кэша разный для разных игр, обычно 128мб более чем достаточно. Для SuperMario достаточно 32мб, а вот ConkerBFD использует множество текстур, так что 256мб и больше может потребоваться для улучшения производительности.

'Compress memory used for texture cache':
Применить сжатие памяти, чтобы больше текстур уместилось в каше. Степень сжатия разная для каждой текстуры, в среднем сжатая текстура в пять раз меньше оригинальной. Текстуры разжимаются на лету перед загрузкой в видео карту. Эта опция позволяет сэкономить память даже в случае применения компрессии текстур, такой как FXT1 и S3TC.

'Apply texture compression':
Текстуры будут сжаты с использованием компресии в формате FXT1 или S3TC. Средняя степень сжатия 1/6 для FXT1 и 1/4 для S3TC. Использование компресии текстур не только экономит место в текстурном кэше, но и, что более важно, серьезно экономит место в текстурной памяти видеокарты. Это помогает от переполнения текстурной памяти, уменьшает количество замен текстур в видеопамяти, что ведет к увеличению производительности.

'Hi-resolution textures - Force 16bpp textures':
Преобразовывать 32бит текстуры в 16бит. Место в текстурной памяти экономится вдвое, производительность увеличивается. Преобразование сделано таким образом, что качество оригинальной текстуры сохраняется максимальным образом. Готовый кадр почти не отличим от результата с 32бит текстурами.


Glide64 Games Tips and Tricks

  • Banjo-Kazooie
  • Beetle Adventure Racing / HSV Adventure Racing
  • Bio Hazard 2 / Resident Evil 2
  • Conker's Bad Fur Day
  • Fushigi no Dungeon - Furai no Shiren 2 (J)
  • Legend of Zelda, The - Majora's Mask
  • Mario Story / Paper Mario
  • Mischief Makers / Yuke Yuke!! Trouble Makers
  • Perfect Dark

Banjo-Kazooie

The puzzle effect is not emulated by default. To see it, either set 'Read every frame' option on or set 'Get frame buffer info' and run this game with Mupen64.

Beetle Adventure Racing / HSV Adventure Racing

Fog. The fog in this game is implemented in a very specific way. When rendering of the current frame is finished, the depth buffer, filled during rendering of this frame, is used as a texture and blended with the color buffer. As the result, the frame becomes fogged, and the fog is thicker where depth values are higher. Glide64 implements two ways to emulate this effect, software and hardware ones.

Software emulation uses software depth buffer rendering. It works on all cards, but has two disadvantages:

- Alpha testing is not used during software depth buffer rendering. As the result, the pixels, which would normally be rejected by alpha testing, are stored in the depth buffer. This causes artifacts in the produced fog.

- The software depth buffer has original (that is low) N64 resolution output. When it is used as a texture, blended with the high-resolution frame buffer, aliasing is visible.

Hardware emulation produces perfect fog, but currently it works only on 3dfx Voodoo 4/5's. These cards use the same depth buffer format, as the N64, and they can allocate the depth buffer right in the texture memory, so it can be easily used as a texture, as on N64 hardware. In both cases, the 'Software depth buffer rendering' option must be on.
On car reflection. Your car (the car you drive) should reflect the environment in this game. That is, various objects, which you roll by, should be reflected on your car. This is implemented via the usage of frame buffer content. Emulation of this effect implies frame buffer emulation. Unfortunately, this can't be done in hardware, because the texture, which is used as a reflection, is not a part of the frame buffer - it is the result of frame buffer post processing, made on the N64 CPU. Thus, the only way to emulate this effect is to use the 'Read every frame' option. If your hardware allows you to use this option without slowdown, you are lucky.

Bio Hazard 2 / Resident Evil 2

This game uses pre-rendered depth buffers, which are stored in the game's ROM, and are loaded into the depth buffer memory area each frame before rendering is started. This is hard to emulate, and especially hard to emulate efficiently. The following options must be set:

'Hardware frame buffer emulation' - on

'Software depth buffer rendering' - on

in the 'Wrapper settings' - 'Use Framebuffer Objects' - off

To get good sound in this game, use Mupen64 with Azimer's HLE sound plugin v.056. However, the game may flicker in some places with Mupen64.

Conker's Bad Fur Day

The game is well emulated with default settings. However, there are two special effects in this game, which require special settings: the black-and-white "It's war" cut-scene, and the Uga-Buga pixilated effect. To see these effects, set the following options:
'Read every frame' - on
'Special game settings' tab, 'Render N64 frame buffer as texture' - on
The game is not playable with these settings, so use them only to see these particular effects.

Note for ATI users: you must set 'Use Framebuffer Objects' option on ('Wrapper settings'), otherwise the game will work very slow.

Fushigi no Dungeon - Furai no Shiren 2 (J)

To see correct background in menus, either set 'Read every frame' option on or set 'Get frame buffer info' and run this game with Mupen64.

Legend of Zelda, The - Majora's Mask

Lens of Truth may not work, if 'Use Framebuffer Objects' option set off ('Wrapper settings').
Also, when Lens of Truth is used, some objects outside of the lens can be cut. This is not a bug - depth buffer copy must be emulated to fully emulate Lens of Truth. It is currently supported only by 3dfx Voodoo 4/5 cards.

Mario Story / Paper Mario

To see correct background in the menu subscreen, either set the 'Read every frame' option on or set 'Get frame buffer info' and run this game with Mupen64.

Mischief Makers / Yuke Yuke!! Trouble Makers

To see correct textures on 3D levels, select 'Special game settings' tab and set the 'Texture wrap hack' option on. This option causes some minor glitches, so it should be off for 2D levels.

Perfect Dark

Frame buffer emulation must be disabled in multiplayer mode to avoid flickering. Most of the special effects used will not work without frame buffer emulation, but it's not that important for multiplayer.


Glide64 Known Issues

Current Version: 8.04 (year: 2008, month: 04) |  |
Known issues |  |
Game | Description | Correct with
 |  | following plugin:
64 de Hakken!! Tamagotchi Minna de Tamagotchi World | Missing or wrong textures everywhere | Ziggy LLE
All-Star Baseball '99 | Missing gfx in menu | Rice, Jabo
Blast Corps | missing 2d gfx in menu and game | Jabo software
Command & Conquer | Briefing menu error. Intro texture errors. | (Intro only )Ziggy LLE
Cruis'n World | The N logo is wrong | Rice
custom robo | Rolling square during logo display at intro is cut | Rice, Jabo, Ziggy LLE
Derby Stallion 64 | textures problem during demo | Rice
Donkey kong 64 | Wide screen doesn t work |
Eikou no Saint Andrew | The gfx are reversed | Rice
Excitebike 64 | sky textures sliced in multiplayer | to check
Extreme-G | Wrong title: the blue square must not appear (checked on real N64) | NONE
Flying Dragon | shaking ground | Rice, Jabo
FX-Zero: | Wrong or missing (fb ?) effects in menu | Jabo Software
Gauntlet Legends 64 | Missing status bar, flickering (fb+core issue ?) | NONE
Gex 3, Deep Cover Gecko | Bad water | NONE
Glover | strange blue line in sky sometimes | Ziggy LLE
Harvest Moon 64 (Bokujo Monogatari 2) | Problem with shadows | Ziggy LLE
Hey You, Pikachu | Missing gfx | Rice
Jeremy McGrath Supercross 2000 | Missing jauge in menu, selection in pause menu in game | Ziggy LLE
Jet force gemini | Coronas behave slighly incorrectly | Wonder++
Kuiki-Uhabi-Suigo | Missing jigsaw (microcode issue ? ) | Ziggy LLE
Madden NFL 2000/2001/2002 | Missing sky / texture correction disabled | Better with Direct64
Mahjong Master | Pictures of the character are wrong. Menu doesn't show the japanese letters | Rice/SP8
Major League Baseball Featuring Ken Griffey Jr | Wrong textures in game | Jabo soft/Rice
Mario Tennis | Gfx errors | to check
Midway's Greatest Arcade Hits Volume 1 | gfx errors in lot of mini games | to check
Mission Impossible | missing dithering color alpha effect in menu | NONE
Monster Truck Madness 64 | Letters have some very small gfx issue | to check
Morita Shogi 64 | Missing logo at boot | Rice
Nascar 2000 | Split screen in multiplayer doesn't work correctly. | to check
Nushi Zuri 64 - Shiokaze ni Notte | Missing gfx in game (blender ?) | Direct64, LLE
Operation WinBack | A gray square sometimes appear on the screen; missing sky | Ziggy LLE
OgreBattle 64 | the shadows in menu are wrong | NONE
Pachinko 365 Nichi | Gfx is reversed | Rice
Paper Mario | The candle lights in the haunted castle are wrong, title screen is also wrong. | to check
Parlor! Pro 64 Pachinko Jikki Simulation Game | small texture issue in game | Rice
PGA European Tour | No sky / colors seems wrong / jauge doesn t work | Jabo
Pikachu Genki Dech | Missing and stretched textures | Rice
Power League Baseball 64 | Missing polygons | Jabo
Space Silicon Valley | Missing on TV dithering color alpha (noise) | NONE
Starfox 64 | Missing dithering color alpha (noise) at logo | NONE
Super Bowling 64 | In game, the two part of the screen is mixed | Rice
Super Speed Race 64 | Sliced textures in menu | Rice
Top Gear Hyper-Bike | Problem of resolution, wrong texture, problem of framebuffer effect | NONE
Top Gear Overdrive | Resolution change causes gfx glitches in menu | NONE
Turok 2 | Flashlight doesn't work | Ziggy LLE
Twine | title screen during demo is wrong | Jabo
Twisted Edge Extreme Snowboarding | wrong background in game | to check
Vigilante 8 | No menus, missing textures and many gfx errors | Jabo software
Vigilante 8 - 2nd Offense | No menus, depth problem, missing textures and many gfx errors | Jabo software
Wipeout 64 | wrong sky in some particular places, ok with jabo | Jabo
Yoshi's Story | cut textures | Jabo
Framebuffer issues |  |
NOTE: HWFBE or fb notification with Mupen is correct solution in terms of speed and quality. Only when REFB is needed or when the fb effect |  |
is not emulated that it is considered as an issue. |  |
Game | Description |
Akumajou Dracula Makushiroku: Real Action Adventure | REFB needed to get motion blur in intro and correct gfx in menu | Jabo
All-Star Baseball 2000, 2001 | Monitors requires REFB. | NONE
Bakushou Jinsei 64 - Mezase | Needs REFB to be playable (or background will be missing) (Mupen doesn t handle fb effect correctly=disabled) | NONE
Beetle Adventure Racing | Unemulated fb effects in menu (scrolling effect); shadows on cars needs REFB | Ziggy LLE
Blast Corps | wrong depth with shadows with HWFBE | to check
Bottom of the 9th | needs REFB for correct intro; With HWFBE only half of the player heads are displayed in game | NONE
Castlevania - Legacy of Darkness | REFB needed to get motion blur in intro and correct gfx in menu | Jabo
Dobutsu no Mori (Animal Forest) | The character menu is uncorrect due to an unhandeld fb effect | Direct64
Donkey Kong 64 | The zipper screen issue is a framebuffer effects (needs REFB) (Mupen doesn t support this game) | NONE
Extreme-G | Missing transfer effects in after select the car | Direct64
iss98/2000/Jikkyou World Cup France '98/J. League Perfect Striker | Missing fb effect when a goal is scored | GLN64 0.41
Knockout Kings 2000 | Missing heads at screen before doing matches and missing shadows during intro due to unhandled fb effect. | NONE
The New tetris | Missing fb effect in menu (partially working with HWBFE) | Direct64
Micromachines 64 | Missing shadows for some elements of the environment | Jabo software
Ogre Battle 64 - Person of Lordly Caliber | Screen transition effects requires REFB. | to check
Tonic Trouble | texts for the screen just before going in game needs REFB (side effect of cpu gfx effect ?) | NONE
WWF WrestleMania 2000 /Virtual Pro Wrestling 2 | REFB is needed to get motion blur in intro | Ziggy LLE
Yoshi's Story | Transition "page" level needs REFB | to check
Pending investigation |  |
Game | Description |
Super Robot Spirit | In menu, just before beginning a new game there is a problem in this screen: it's seems that there is only half of the screen for the flames (to check on real system) |
Heiwa Pachinko World 64 | Gfx errors ? How should it be ? |
F1 Pole position 64 | Wrong use of dithering alpha for texts ? |
Non-working games |  |
Game | Description |
Indiana Jones and the Infernal Machine | Unimplemented microcode | Jabo/ Ziggy LLE
Last Legion U | Unimplemented microcode | Jabo/ Ziggy LLE
Mia Hamm Soccer | Unimplemented microcode | Jabo/ Ziggy LLE
Michael Owens WLS 2000 | Unimplemented microcode | Jabo/ Ziggy LLE
RTL World League Soccer 2000 | Unimplemented microcode | Jabo/ Ziggy LLE
Star Wars - Rogue Squadron | Unimplemented microcode | Jabo/ Ziggy LLE
Star Wars Episode I - Battle for Naboo | Unimplemented microcode | Jabo/ Ziggy LLE
Telefoot Soccer 2000 | Unimplemented microcode | Jabo/ Ziggy LLE
Toukon Road - Brave Spirits | Unimplemented microcode | Jabo/ Ziggy LLE
Toukon Roads - The Next Generation | Unimplemented microcode | Jabo/ Ziggy LLE
Emu issues |  |
Game | Description |
Ai Shougi 3 | Textures are completely distorted (use 1964!) |
Banjo Tooie | Random crashes |
Dobutsu no Mori | NES games crash emulation |
Hoshi no Kirby 64 | Minor gfx errors with the status bar (use Mupen!) |
Kirby 64 - The Crystal Shards | Minor gfx errors with the status bar (use Mupen!) |
Mario No Photopie | Special card issues |
NBA Courtside 2 - Featuring Kobe Bryant | CPU gfx effect issue >> Missing intro. (TIP: set "Frame Buffer R/W: Yes" with 1964 : got some gfx but broken) |
Yakouchuu II - Satsujun Kouru: | CPU gfx effect issue >> Missing movies |
Wrapper issues |  |
Game | Description |
Depth issue when using HWFBE, mostly with fbo:International Track and Field Summer Games, NFL98 TV screen (?), others |  |
Unknown issues |  |
Game | Description |
Stunt Racer 64 | Microcode issue and core issues ? |
World Driver Championship | Microcode issue and core issues ? |
Credits :) Current list's maintainer: GAB (Previous: The Player of Doom Thks for hosting it!) |  |
A BIG thanks to: |
Raziel64, Olivieryuyu (* Special Mention :) ), MasterPhW, Noxious Ninja, TRS, Straight, Knuckles, Flash, Milen, Jelta, Federelli, Clements, Doomulation, etc. |  |
They are issues' hunters :D (so am i, hehe) |
And a Very special thanks to: |
Dave2001 for starting, Gugaman and Gonetz (^_^ He is tha man! ^_^ Thks a lot pal :) ) for enhancing and fixing |  |
the best video plugin and showing the true power of 3DFX and Glide. And to the N64 emulators' authors & betatesters! |  |
Hacktarux, Mudlord and Ziggy for making the best Glide Wrapper out there. |  |


.::Glide64 compatibility list::.

Compatibility List
for Glide64 0.9
Game Name: | RSP Microcode | Playability Level | Relative speed | Comments
007 - The World is Not Enough | F3DEX2.XX | 5 | Normal | Compatible
1080 Snowboarding | F3DEX1.XX | 5 | Normal | Compatible. Use "Read every frame" option to see correct TV monitors (slow)
40 Winks | F3DEX2.XX | 5 | Normal | Compatible
64 Oozumou | F3DEX1.XX | 5 | Normal | Compatible
64 Oozumou 2 | F3DEX1.XX | 5 | Normal | Compatible
64 Trump Collection - Alice no Wakuwaku Trump World | F3DEX1.XX | 5 | Normal | Compatible
64 de Hakken!! Tamagotchi Minna de Tamagotchi World | F3DEX1.XX | 3 | Slow | Major gfx errors
AI Shogi 3 | F3DEX1.XX | 5 | Fast | Compatible. Use 1964
Aerofighter's Assault | RSP SW 2.0X | 5 | Normal | Compatible
AeroGauge | F3DEX1.XX | 5 | Fast | Compatible
Aidyn Chronicles - The First Mage | F3DEX2.XX | 5 | Normal | Compatible
Airboarder 64 | F3DEX1.XX | 5 | Fast | Compatible
Akumajou Dracula Makushiroku - Real Action Adventure | F3DEX2.XX | 5 | Normal | Compatible. Use "Read every frame" option to see correct menu (slow)
Akumajou Dracula Makushiroku-Legend of Cornell | F3DEX2.XX | 5 | Normal | Compatible. Enable hi-res mode for correct menus
All Star Tennis '99 | F3DEX1.XX | 5 | Fast | Compatible
All-Star Baseball 99 | F3DEX1.XX | 5 | Normal | Compatible. Use "Get frame buffer info" option with Mupen or use "Read every frame" option to see correct TV monitors (slow). Minor gfx errors
All-Star Baseball 2000 | F3DEX2.XX | 5 | Normal | Compatible. Use Nemu 0.8. Use "Read every frame" option to see correct TV monitors (slow)
All-Star Baseball 2001 | F3DEX1.XX | 5 | Normal | Compatible. Use Nemu 0.8. Use "Read every frame" option to see correct TV monitors (slow)
Armorines - Project S.W.A.R.M. | F3DEX2.XX | 5 | Normal | Compatible
Army Men - Air Combat | F3DEX2.XX | 5 | Normal | Compatible
Army Men - Sarge's Heroes | F3DEX2.XX | 5 | Normal | Compatible
Army Men - Sarge's Heroes 2 | F3DEX2.XX | 5 | Normal | Compatible
Asteroids Hyper 64 | F3DEX2.XX | 5 | Fast | Compatible
Automobili Lamborghini | F3DEX1.XX | 5 | Normal | Compatible. Minor gfx errors
Baku Bomberman | F3DEX1.XX | 5 | Normal | Compatible. Use "Get frame buffer info" option with Mupen or use "Read every frame" option to see intro correctly (slow)
Baku Bomberman 2 | F3DEX2.XX | 5 | Normal | Compatible
Bakuretsu Muteki Bangaioh | F3DEX1.XX | 5 | Slow | Compatible
Bakushou Jinsei 64 - Mezase! (Game of Life) | RSP SW 2.0X | 5 | Slow | Compatible. Use "Read every frame" option to have correct gfx in game
Banjo to Kazooie no Dai Bouken | F3DEX1.XX | 5 | Normal | Compatible. Use "Read every frame" option (slow) or "Get frame buffer info" option with Mupen to see puzzle effect
Banjo to Kazooie no Dai Bouken 2 | F3DEX2.XX | 5 | Normal | Compatible
Banjo-Kazooie | F3DEX1.XX | 5 | Normal | Compatible. Use "Read every frame" option (slow) or "Get frame buffer info" option to see puzzle effect with Mupen
Banjo-Tooie | F3DEX2.XX | 5 | Normal | Compatible
Bass Hunter 64 | F3DEX2.XX | 5 | Normal | Compatible
Bass Rush - ECOGEAR PowerWorm Championship | F3DEX2.XX | 5 | Normal | Compatible
Bass Tsuri No.1 - Shigesato Itoi's Bass Fishing | F3DEX2.XX | 5 | Normal | Compatible
Bassmasters 2000 | F3DEX2.XX | 5 | Normal | Compatible
Batman Beyond - Return of the Joker | F3DEX2.XX | 5 | Normal | Compatible
BattleTanx | F3DEX1.XX | 5 | Fast | Compatible
BattleTanx - Global Assault | F3DEX2.XX | 5 | Fast | Compatible
Battlezone - Rise of the Black Dogs | F3DEX2.XX | 5 | Normal | Compatible
Beetle Adventure Racing | F3DEX2.XX | 5 | Normal | Compatible
Big Mountain 2000 | F3DEX2.XX | 5 | Fast | Compatible
Bio F.R.E.A.K.S. | F3DEX1.XX | 5 | Normal | Compatible
Bio Hazard 2 | F3DEX1.XX | 5 | Normal | Compatible
Blast Corps | RSP SW 2.0X | 5 | Normal | Compatible. Use PJ64. Minor gfx errors
Blast Dozer | RSP SW 2.0X | 5 | Normal | Compatible. Use PJ64. Minor gfx errors
Blues Brothers 2000 | F3DEX2.XX | 5 | Normal | Compatible
Body Harvest | F3DEX1.XX | 5 | Normal | Compatible. Use "Read every frame" option (slow) or "Get frame buffer info" with Mupen to have correct menu
Bokujo Monogatari 2 | F3DEX2.XX | 5 | Normal | Compatible
Bomberman 64 | F3DEX1.XX | 5 | Normal | Compatible. Use "Get frame buffer info" option with Mupen or use "Read every frame" option to see intro correctly (slow)
Bomberman64 - The Second Attack | F3DEX2.XX | 5 | Normal | Compatible
Bomberman Hero | F3DEX1.XX | 5 | Fast | Compatible.
Bottom of the 9th | F3DEX2.XX | 5 | Fast | Compatible. Use "Read every frame" option (slow) to see correct intro
Brunswick Circuit Pro Bowling | F3DEX1.XX | 5 | Fast | Compatible
Buck Bumble | F3DEX2.XX | 5 | Normal | Compatible
Bug's Life, A | F3DEX1.XX | 5 | Normal | Compatible
Bust-A-Move '99 | F3DEX1.XX | 5 | Fast | Compatible
Bust-A-Move 2 - Arcade Edition | F3DEX1.XX | 5 | Fast | Compatible
Bust-A-Move 3 DX | F3DEX1.XX | 5 | Fast | Compatible
California Speed | F3DEX2.XX | 5 | Normal | Compatible
Carmageddon 64 | F3DEX2.XX | 5 | Fast | Compatible
Castlevania | F3DEX2.XX | 5 | Normal | Compatible. Use "Read every frame" option to see correct menu (slow)
Castlevania - Legacy of Darkness | F3DEX2.XX | 5 | Normal | Compatible. Enable hi-res mode for correct menus
Centre Court Tennis | F3DEX1.XX | 5 | Fast | Compatible
Chameleon Twist | F3DEX1.XX | 5 | Fast | Compatible
Chameleon Twist 2 | F3DEX2.XX | 5 | Normal | Compatible
Charlie Blast's Territory | F3DEX1.XX | 5 | Fast | Compatible
Chopper Attack | RSP SW 2.0X | 5 | Fast | Compatible
Choro Q 64 | F3DEX1.XX | 5 | Fast | Compatible
Choro Q 64 II | F3DEX2.XX | 5 | Fast | Compatible. Use "Read every frame" option (slow) or "Get frame buffer info" option with Mupen to see correct menu
Chou Kuukan Night Pro Yakyuu King | F3DEX1.XX | 5 | Normal | Compatible
Chou Kuukan Night Pro Yakyuu King 2 | F3DEX1.XX | 5 | Normal | Compatible
Chou Snobow Kids | F3DEX2.XX | 5 | Fast | Compatible
City-Tour GP - Zennihon GT Senshuken | F3DEX1.XX | 5 | Normal | Compatible
Clay Fighter - Sculptor's Cut | F3DEX1.XX | 5 | Slow | Compatible
Clay Fighter 63 1-3 | F3DEX1.XX | 5 | Slow | Compatible
Command & Conquer | F3DEX2.XX | 3 | Fast | Not playable
Conker's Bad Fur Day | F3DEXGB2.08 | 5 | Normal | Compatible. Use "Read every frame" option (slow) to get black and white effect during “It’s war” cut scene and Buga pixellisation effect
Cruis'n Exotica | F3DEX2.XX | 5 | Fast | Compatible
Cruis'n USA | RSP SW 2.0X | 5 | Fast | Compatible
Cruis'n World | F3DEX2.XX | 5 | Fast | Compatible
Custom Robo | F3DEX2.XX | 5 | Normal | Compatible
Custom Robo V2 | F3DEX2.XX | 5 | Normal | Compatible
CyberTiger | F3DEX2.XX | 5 | Normal | Compatible
Dance Dance Revolution - Disney Dancing Museum | F3DEX2.XX | 5 | Normal | Compatible
Dark Rift | TURBO3D | 5 | Normal | Compatible
Deadly Arts | F3DEX1.XX | 5 | Slow | Compatible
Défi au Tetris Magique | S2DEX.XX | 5 | Normal | Compatible
Densha de GO! 64 | F3DEX2.XX | 5 | Normal | Compatible. Use 1964
Derby Stallion | F3DEX2.XX | 5 | Normal | Compatible. Use Nemu 0.8
Destruction Derby 64 | F3DEX1.XX | 5 | Slow | Compatible
Dezaemon 3D | F3DEX1.XX | 5 | Fast | Compatible
Diddy Kong Racing | RSP SW DKR | 5 | Fast | Compatible
Disney's Donald Duck - Goin' Quackers | F3DEX1.XX | 5 | Normal | Compatible. Use "Read every frame" option to see correct transition effects in menu
Disney's Tarzan | F3DEX2.XX | 5 | Normal | Compatible. Use PJ64
Donald Duck - Quack Attack | F3DEX1.XX | 5 | Normal | Compatible. Use "Read every frame" option to see correct transition effect in menu
Donkey Kong 64 | F3DEX2.XX | 5 | Normal | Compatible. Use PJ64
Doom 64 | F3DEX1.XX | 5 | Fast | Compatible
Doraemon - Mittsu no Seireiseki | F3DEX2.XX | 5 | Fast | Compatible
Doraemon 2 - Hikari no Shinden | F3DEX1.XX | 5 | Fast | Compatible
Doraemon 3 - Nobi Dai no Machi SOS! | F3DEX1.XX | 5 | Fast | Compatible. Use 1964
Doubutsu no Mori | F3DEX2.XX | 5 | Normal | Compatible
Dr. Mario 64 | F3DEX2.XX | 5 | Normal | Compatible
Dual Heroes | F3DEX1.XX | 5 | Normal | Compatible
Duck Dodgers Starring Daffy Duck | F3DEX2.XX | 5 | Slow | Compatible
Duke Nukem - ZER0 H0UR | F3DEX2.XX | 5 | Fast | Compatible
Duke Nukem 64 | RSPSW 2.0X | 5 | Normal | Compatible. Minor gfx errors
ECW Hardcore Revolution | F3DEX2.XX | 5 | Fast | Compatible
Earthworm Jim 3D | F3DEX1.XX | 5 | Normal | Compatible
Eikou no Saint Andrew | RSP SW 2.0X | 2 | Normal | Major gfx errors
Elmo's Letter Adventure | F3DEX1.XX | 5 | Normal | Compatible
Elmo's Number Journey | F3DEX1.XX | 5 | Normal | Compatible
Eltale Monsters | F3DEX1.XX | 5 | Fast | Compatible
Excitebike 64 | F3DEX2.XX | 5 | Normal | Compatible
Extreme-G | F3DEX1.XX | 5 | Normal | Compatible. Minor gfx errors
Extreme-G XG2 | F3DEX2.XX | 5 | Normal | Compatible
F-1 Pole Position 64 | F3DEX1.XX | 5 | Fast | Compatible. Use "Read every frame" option (slow) or "Get frame buffer info" with Mupen to have correct menu
F-1 World Grand Prix | F3DEX1.XX | 5 | Normal | Compatible
F-1 World Grand Prix II | F3DEX2.XX | 5 | Normal | Compatible
F-Zero X | F3DEX2.XX | 5 | Normal | Compatible
F1 Racing Championship | F3DEX2.XX | 5 | Normal | Compatible. Use Mupen
FIFA - Road to World Cup 98 | RSP SW 2.0X | 5 | Slow | Compatible
FIFA 99 | F3DEX1.XX | 5 | Normal | Compatible
FIFA Soccer 64 | RSP SW 2.0X | 5 | Normal | Compatible. Use 1964
Famista 64 | F3DEX2.XX | 5 | Normal | Compatible. Use "Read every frame" option (slow) or "Get frame buffer info" with Mupen to have ground in game
Fighter Destiny 2 | F3DEX2.XX | 5 | Fast | Compatible
Fighter's Destiny | F3DEX1.XX | 5 | Fast | Compatible
Fighting Cup | F3DEX1.XX | 5 | Fast | Compatible
Fighting Force 64 | F3DEX1.XX | 5 | Normal | Compatible
Fire Electric Pen | F3DEX1.XX | 5 | Normal | Compatible
Flying Dragon | F3DEX1.XX | 5 | Normal | Compatible. Minor gfx errors
Forsaken 64 | F3DEX1.XX | 5 | Fast | Compatible
Frogger 2 (Alpha) | F3DEX2.XX | 5 | Fast | Compatible
FoxSportsCollege Hoops ‘99 | F3DEX2.XX | 5 | Normal | Compatible
Fushigi no Dungeon - Fuurai no Shiren 2 | F3DEX2.XX | 5 | Normal | Compatible. Use "Read every frame" option (slow) or "Get frame buffer info" with Mupen to have backgrounds in menus
G.A.S.P! Fighter's NEXTream | F3DEX2.XX | 5 | Normal | Compatible. Use (J) version or use Mupen
GT 64 - Championship Edition | F3DEX1.XX | 5 | Normal | Compatible
Ganbare Goemon - Derudero Douchuu Obake Tenkomori | F3DEX2.XX | 5 | Fast | Compatible
Ganbare Goemon - Mononoke Sugoroku | F3DEX2.XX | 5 | Normal | Compatible
Ganbare Goemon - Neo Momoyama Bakufu no Odori | F3DEX1.XX | 5 | Normal | Compatible
Ganbare Nippon Olympics 2000 | F3DEX2.XX | 5 | Fast | Compatible
Gauntlet Legends | F3DEX2.XX | 2 | Normal | Missing gfx. Flickerings. Use PJ64
Getter Love !! Cho Renai Party Game | F3DEX2.XX | 5 | Fast | Compatible
Gex 3 - Deep Cover Gecko | F3DEX2.XX | 5 | Fast | Compatible
Gex 64 - Enter the Gecko | F3DEX1.XX | 5 | Fast | Compatible
Glover | F3DEX1.XX | 5 | Normal | Compatible (For (E) version use Mupen)
Goemon's Great Adventure | F3DEX2.XX | 5 | Fast | Compatible
Golden Nugget 64 | RSP SW 2.0X | 5 | Fast | Compatible. Use 1964 or Mupen
GoldenEye 007 | RSP SW 2.0G | 5 | Slow | Compatible
HVS Adventure Racing | F3DEX2.XX | 5 | Normal | Compatible. Use PJ64 Audio Fix Edition
Hamster Monogatari 64 | S2DEX.XX | 5 | Normal | Compatible
Hanafuda 64 - Tenshi no Yakusoku | F3DEX2.XX | 5 | Normal | Compatible. Use 1964
Harukanaru Augusta Masters 98 | F3DEX1.XX | 5 | Normal | Compatible
Harvest Moon 64 | F3DEX2.XX | 5 | Fast | Compatible
Heiwa Pachinko World 64 | F3DEX2.XX | 3 | Normal | Gfx errors
Hercules - The Legendary Journeys | F3DEX2.XX | 5 | Normal | Compatible. Minor gfx errors
Hexen | F3DEX1.XX | 5 | Normal | Compatible. Use "Read every frame" option (slow) to see texts at objectives screen
Hey You, Pikachu! | F3DEX2.XX | 3 | Normal | Gfx errors (needs voice pak)
Hiryuu no Ken Twin | F3DEX1.XX | 5 | Normal | Compatible. Minor gfx errors
Holy Magic Century | F3DEX1.XX | 5 | Fast | Compatible
Hoshi no Kirby 64 | F3DEX2.XX | 5 | Normal | Compatible. Use Mupen for correct status bar
Hot Wheels Turbo Racing | F3DEX2.XX | 5 | Slow | Compatible
Human Grand Prix - New Generation | F3DEX1.XX | 5 | Normal | Compatible. Use "Read every frame" option (slow) or "Get frame buffer info" with Mupen to have correct menu
Hybrid Heaven | F3DEX2.XX | 5 | Normal | Compatible
Hydro Thunder | F3DEX2.XX | 5 | Normal | Compatible. Use PJ64
Ide Yosuke no Mahjong Juku | F3DEX1.XX | 5 | Normal | Compatible. Use Nemu 0.8 (disable audio HLE)
Iggy's Reckin' Balls | F3DEX1.XX | 5 | Normal | Compatible
Iggy-kun no Bura Bura Poyon | F3DEX1.XX | 5 | Normal | Compatible
In-Fisherman Bass Hunter 64 | F3DEX2.XX | 5 | Normal | Compatible
Indiana Jones and the Infernal Machine | ? | 0 | ? | Unsupported. Microcode not implemented
Indy Racing 2000 | F3DEX2.XX | 5 | Normal | Compatible
International Superstar Soccer '98 | F3DEX1.XX | 5 | Normal | Compatible. Use “Read every frame” option to see correct effects after scoring a goal
International Superstar Soccer 2000 | F3DEX2.XX | 5 | Normal | Compatible. Use “Read every frame” option to see correct effects after scoring a goal
International Superstar Soccer 64 | F3DEX1.XX | 5 | Normal | Compatible. Minor gfx errors
International Track & Field 2000 | F3DEX2.XX | 5 | Normal | Compatible
International Track & Field Summer Games | F3DEX2.XX | 5 | Normal | Compatible
J. League Dynamite Soccer 64 | F3DEX1.XX | 5 | Normal | Compatible
J. League Eleven Beat 1997 | F3DEX1.XX | 5 | Normal | Compatible
J. League Live 64 | F3DEX1.XX | 5 | Normal | Compatible
J. League Tactics Soccer | F3DEX2.XX | 5 | Normal | Compatible
Jangou Simulation Mahjong Do 64 | F3DEX1.XX | 5 | Normal | Compatible
Jeopardy! | RSP SW 2.0X | 5 | Normal | Compatible
Jeremy McGrath Supercross 2000 | F3DEX2.XX | 5 | Fast | Compatible
Jet Force Gemini | RSP SW RARE4 | 5 | Normal | Compatible
Jikkyou G1 Stable | F3DEX2.XX | 5 | Normal | Compatible
Jikkyou J. League 1999 - Perfect Striker 2 | F3DEX2.XX | 5 | Normal | Compatible. Use “Read every frame” option to see correct effects after scoring a goal
Jikkyou J. League Perfect Striker | RSP SW 2.0X | 5 | Normal | Compatible. Use “Read every frame” option to see correct effects after scoring a goal
Jikkyou Powerful Pro Yakyuu - Basic Han 2001 | F3DEX2.XX | 5 | Normal | Compatible
Jikkyou Powerful Pro Yakyuu 2000 | F3DEX2.XX | 5 | Normal | Compatible
Jikkyou Powerful Pro Yakyuu 4 | F3DEX1.XX | 5 | Normal | Compatible
Jikkyou Powerful Pro Yakyuu 5 | F3DEX1.XX | 5 | Normal | Compatible
Jikkyou Powerful Pro Yakyuu 6 | F3DEX2.XX | 5 | Normal | Compatible
Jikkyou World Cup France '98 | RSP SW 2.0X | 5 | Normal | Compatible. Use “Read every frame” option to see correct effects after scoring a goal
Jikkyou World Soccer 3 | RSP SW 2.0X | 5 | Normal | Compatible
Jinsei Game 64 | F3DEX2.XX | 5 | Normal | Compatible
John Romero's Daikatana | F3DEX2.XX | 5 | Normal | Compatible
Kakutou Denshou - F-Cup Maniax | F3DEX2.XX | 5 | Normal | Compatible
Ken Griffey Jr.'s Slugfest | F3DEX2.XX | 5 | Normal | Compatible
Killer Instinct Gold | RSP SW 2.0X | 5 | Fast | Compatible
King Hill 64 - Extreme Snowboarding | F3DEX2.XX | 5 | Normal | Compatible. Minor gfx errors.
Kiratto Kaiketsu! 64 Tanteidan | F3DEX1.XX | 5 | Normal | Compatible
Kirby 64 - The Crystal Shards | F3DEX2.XX | 5 | Fast | Compatible. Use Mupen for correct status bar
Knife Edge - Nose Gunner | F3DEX2.XX | 5 | Fast | Compatible
Knockout Kings 2000 | F3DEX2.XX | 5 | Fast | Compatible. Use 1964. Minor gfx errors
Kobe Bryant NBA Courtside | F3DEX1.XX | 5 | Fast | Compatible
Kuiki-Uhabi-Suigo | RSP SW 2.0X | 2 | Normal | Gfx errors
LEGO Racers | F3DEX2.XX | 5 | Depends | Compatible
Last Legion UX | ? | 0 | ? | Unsupported. Microcode not implemented
Legend of Zelda, The - Ocarina of Time | F3DEX 2.06H | 5 | *Mostly* Fast | Compatible
Legend of Zelda 2, The - Majora's Mask | F3DEX2.XX | 5 | Normal | Compatible
Legend of Zelda, The - Ocarina of Time - Master Quest | F3DEX 2.06H | 5 | *Mostly* Fast | Compatible
Les Razmoket - La Chasse aux Trésors | F3DEX2.XX | 5 | Normal | Compatible
Let's Smash Tennis | F3DEX1.XX | 5 | Normal | Compatible
Lode Runner 3-D | F3DEX2.XX | 5 | Normal | Compatible
Looney Tunes - Duck Dodgers | F3DEX2.XX | 5 | Slow | Compatible
Lylat Wars | F3DEX1.XX | 5 | Fast | Compatible
MRC - Multi Racing Championship | F3DEX1.XX | 5 | Fast | Compatible
Mace - The Dark Age | F3DEX1.XX | 5 | Normal | Compatible.
Madden Football 64 | F3DEX1.XX | 5 | Slow | Compatible
Madden NFL 2000 | F3DEX1.XX | 5 | Slow | Compatible
Madden NFL 2001 | F3DEX1.XX | 5 | Slow | Compatible
Madden NFL 2002 | F3DEX1.XX | 5 | Normal | Compatible
Madden NFL 99 | F3DEX1.XX | 5 | Normal | Compatible
Magical Tetris Challenge | F3DEX1.XX | 5 | Normal | Compatible
Mahjong 64 | RSP SW 2.0X | 5 | Normal | Compatible
Mahjong Hourouki Classic | RSP SW 2.0X | 5 | Normal | Compatible
Mahjong Master | RSP SW 2.0X | 5 | Normal | Compatible. Minors gfx errors
Major League Baseball Featuring Ken Griffey Jr. | F3DEX1.XX | 3 | Normal | Gfx errors
Mario Golf | F3DEX2.XX | 5 | Normal | Compatible
Mario Kart 64 | F3DEX1.XX | 5 | Fast | Compatible. Use “Read every frame” option (slow) or use "Get frame buffer info" with Mupen to see correct billboards
Mario Party | F3DEX2.XX | 5 | Fast | Compatible
Mario Party 2 | F3DEX2.XX | 5 | Fast | Compatible
Mario Party 3 | F3DEX2.XX | 5 | Fast | Compatible
Mario Story | F3DEX2.XX | 5 | Normal | Compatible
Mario Tennis | F3DEX2.XX | 4 | Unstable | Various gfx errors.
Mario No Photopie | ? | 0 | ? | Unsupported
Mega Man 64 | F3DEX2.XX | 5 | Fast | Compatible
Mia Hamm Soccer | ZSortp 0.33 | 0 | ? | Unsupported. Microcode not implemented
Michael Owens WLS 2000 | ZSortp 0.33 | 0 | ? | Unsupported. Microcode not implemented
Mickey no Racing Challenge USA | RSP SW RARE4 | 5 | Fast | Compatible
Mickey's Speedway USA | RSP SW RARE4 | 5 | Fast | Compatible
Micro Machines 64 Turbo | F3DEX1.XX | 5 | Fast | Compatible
Midway's Greatest Arcade Hits Volume 1 | RSP SW 2.0X | 3 | Normal | Only few games are fully playable
Mike Piazza's Strike Zone | F3DEX1.XX | 5 | Fast | Compatible
Milo's Astro Lanes | F3DEX1.XX | 5 | Normal | Compatible
Mischief Makers | RSP SW 2.0X | 5 | Normal | Compatible
Mission Impossible | F3DEX1.XX | 5 | Normal | Compatible
Monaco Grand Prix | F3DEX2.XX | 5 | Normal | Compatible. Use Mupen64
Monaco Grand Prix - Racing Simulation 2 | F3DEX2.XX | 5 | Normal | Compatible. Use 1964
Monopoly | F3DEX2.XX | 5 | Fast | Compatible
Monster Truck Madness 64 | F3DEX2.XX | 5 | Normal | Compatible
Morita Shougi 64 | RSP SW 2.0X | 5 | Normal | Compatible
Mortal Kombat 4 | F3DEX1.XX | 5 | Scene dependent | Compatible
Mortal Kombat Mythologies - Sub-Zero | F3DEX1.XX | 5 | Fast | Compatible
Mortal Kombat Trilogy | RSP SW 0.2X | 5 | Fast | Compatible
Ms. Pac-Man - Maze Madness | F3DEX2.XX | 5 | Normal | Compatible
Mystical Ninja 2 - Starring Goemon | F3DEX1.XX | 5 | Normal | Compatible
Mystical Ninja - Starring Goemon | F3DEX1.XX | 5 | Normal | Compatible
NASCAR 99 | F3DEX2.XX | 5 | Normal | Compatible
NASCAR 2000 | F3DEX2.XX | 5 | Normal | Compatible
NBA Courtside 2 - Featuring Kobe Bryant | F3DEX2.XX | 5 | Normal | Compatible
NBA Hangtime | RSP SW 2.0X | 5 | Slow | Compatible
NBA In the Zone '98 | F3DEX1.XX | 5 | Fast | Compatible
NBA In the Zone '99 | F3DEX2.XX | 5 | Fast | Compatible
NBA In the Zone 2 | F3DEX2.XX | 5 | Normal | Compatible
NBA In the Zone 2000 | F3DEX2.XX | 5 | Normal | Compatible
NBA Jam 2000 | F3DEX2.XX | 5 | Slow | Compatible
NBA Jam 99 | F3DEX2.XX | 5 | Normal | Compatible
NBA Live 2000 | F3DEX2.XX | 5 | Normal | Compatible
NBA Live 99 | F3DEX2.XX | 5 | Normal | Compatible
NBA Showtime - NBA on NBC | F3DEX2.XX | 5 | Slow | Compatible. Use PJ64
NFL Blitz | F3DEX2.XX | 5 | Fast | Compatible
NFL Blitz - Special Edition | F3DEX2.XX | 5 | Fast | Compatible
NFL Blitz 2000 | F3DEX2.XX | 5 | Fast | Compatible
NFL Blitz 2001 | F3DEX2.XX | 5 | Fast | Compatible
NFL Quarterback Club 2000 | F3DEX2.XX | 5 | Normal | Compatible. Use Nemu 0.8
NFL Quarterback Club 2001 | F3DEX2.XX | 5 | Normal | Compatible. Use Nemu 0.8
NFL Quarterback Club 98 | F3DEX1.XX | 5 | Normal | Compatible. Use Mupen
NFL Quarterback Club 99 | F3DEX2.XX | 5 | Normal | Compatible. Use Nemu 0.8
NHL 99 | F3DEX2.XX | 5 | Normal | Compatible
NHL Blades of Steel '99 | F3DEX2.XX | 5 | Normal | Compatible
NHL Breakaway 98 | F3DEX1.XX | 5 | Normal | Compatible
NHL Breakaway 99 | F3DEX2.XX | 5 | Normal | Compatible
NHL Pro 99 | F3DEX2.XX | 5 | Normal | Compatible
Nagano Winter Olympics '98 | F3DEX1.XX | 5 | Normal | Compatible
Namco Museum 64 | F3DEX1.XX | 5 | Normal | Compatible
Neon Genesis Evangelion | F3DEX2.XX | 5 | Normal | Compatible
New Tetris, The | F3DEX2.XX | 5 | Normal | Compatible. Use Mupen
Nightmare Creatures | F3DEX2.XX | 5 | Normal | Compatible. Use PJ64
Nintama Rantarou Gallery 64 | S2DEX.XX | 5 | Slow | Compatible
Nintendo All-Star! Dairantou Smash Brothers | F3DEX2.XX | 5 | Normal | Compatible
Nuclear Strike 64 | F3DEX2.XX | 5 | Normal | Compatible
Nushi Zuri 64 | F3DEX1.XX | 5 | Normal | Compatible. Use “Read every frame” option (slow) or use "Get frame buffer info" with Mupen to have backgrounds in game
Nushi Zuri 64 - Shiokaze ni Notte | F3DEX2.XX | 2 | Normal | Missing gfx in game
O.D.T | F3DEX2.XX | 5 | Normal | Compatible
Off Road Challenge | F3DEX1.XX | 5 | Normal | Compatible
Ogre Battle 64 - Person of Lordly Caliber | F3DEX2.XX | 5 | Normal | Compatible. Use PJ64 or 1964 0.8.5 (Win9X users must use 1964 0.8.5 or Nemu 0.8, to get backgrounds). Use "Read every frame" option to see screen transition effects (slow)
Olympic Hockey Nagano '98 | F3DEX1.XX | 5 | Normal | Compatible
Onegai Monster | F3DEX2.XX | 5 | Normal | Compatible
Operation WinBack | F3DEX2.XX | 5 | Fast | Compatible, but a gray square sometimes appear on the screen. Missing sky
PD Ultraman Battle Collection 64 | F3DEX2.XX | 5 | Normal | Compatible
PGA European Tour | F3DEX2.XX | 5 | Normal | Compatible. Minor gfx errors
Pachinko 365 Nichi | RSP SW 2.0X | 2 | Normal | Major Gfx errors
Paper Mario | F3DEX2.XX | 5 | Fast | Compatible. Minor gfx errors
Paperboy | F3DEX2.XX | 5 | Normal | Compatible
Parlor! Pro 64 Pachinko Jikki Simulation Game | S2DEX.XX | 5 | Normal | Compatible
Penny Racers | F3DEX1.XX | 5 | Fast | Compatible
Perfect Dark | RSP SW PD | 5 | Slow | Compatible. Use "Read every frame" (slow) or "Get frame buffer info" with Mupen to get correct pause menu in game
Pikachu Genki Dechu | F3DEX2.XX | 3 | Normal | Gfx errors (needs voice pak)
Pilot Wings | F3DEX1.XX | 5 | Fast | Compatible
Pocket Monsters Snap | F3DEX2.XX | 5 | Normal | Compatible. Use "Read every frame" option when selecting shots for professor Oak
Pokemon Puzzle League | S2DEX.XX | 5 | Normal | Compatible
Pokemon Snap | F3DEX2.XX | 5 | Normal | Compatible. Use "Read every frame" option when selecting shots for professor Oak
Pokemon Stadium | F3DEX2.XX | 5 | Fast | Compatible
Pokemon Stadium 2 | F3DEX2.XX | 5 | Normal | Compatible
Polaris SnoCross | F3DEX2.XX | 5 | Normal | Compatible
Power League Baseball 64 | F3DEX2.XX | 4 | Normal | Gfx errors
Power Rangers - Lightspeed Rescue | F3DEX2.XX | 5 | Normal | Compatible
Powerpuff Girls, The - Chemical X-traction | F3DEX1.XX | 5 | Normal | Compatible
Premier Manager 64 | F3DEX2.XX | 5 | Fast | Compatible
Pro Mahjong Kiwame 64 | RSP SW 2.0X | 5 | Normal | Compatible
Pro Majhong Tsuwamono 64 | S2DEX.XX | 5 | Slow | Compatible
Puyo Puyo 4 - Puyo Puyo Party | S2DEX.XX | 5 | Normal | Compatible
Puyo Puyo Sun 64 | RSP SW 2.0X | 5 | Normal | Compatible
Puzzle Bobble 64 | F3DEX1.XX | 5 | Normal | Compatible
Quake 64 | F3DEX1.XX | 5 | Fast | Compatible
Quake II | F3DEX1.XX | 5 | Normal | Compatible
Quest 64 | F3DEX1.XX | 5 | Fast | Compatible
RR64 - Ridge Racer 64 | F3DEX2.XX | 5 | Fast | Compatible. Pause menu doesn't work correctly with Voodoo 1-3
RTL World League Soccer 2000 | ZSortp 0.33 | 0 | ? | Unsupported. Microcode not implemented
Racing Simulation 2 | F3DEX2.XX | 5 | Normal | Compatible. Use 1964. Minor gfx errors
Rakuga Kids | F3DEX2.XX | 5 | Normal | Compatible
Rally '99 | F3DEX2.XX | 5 | Normal | Compatible
Rally Challenge 2000 | F3DEX2.XX | 5 | Normal | Compatible
Rampage - World Tour | F3DEX1.XX | 5 | Fast | Compatible
Rampage 2 - Universal Tour | F3DEX1.XX | 5 | Normal | Compatible
Rat Attack | F3DEX1.XX | 5 | Fast | Compatible
Rayman 2 - The Great Escape | F3DEX1.XX | 5 | Normal | Compatible. Use "Read every frame" option to see correct transition effects in game
Razor Freestyle Scooter | F3DEX2.XX | 5 | Normal | Compatible
Re-Volt | F3DEX2.XX | 5 | Fast | Compatible. Use PJ64
Ready 2 Rumble Boxing | F3DEX1.XX | 5 | Fast | Compatible
Ready 2 Rumble Boxing Round 2 | F3DEX1.XX | 5 | Fast | Compatible
Resident Evil 2 | F3DEX2.XX | 5 | Normal | Compatible
Road Rash 64 | F3DEX2.XX | 5 | Normal | Compatible
Roadsters | F3DEX2.XX | 5 | Normal | Compatible
Robotech - Crystal Dreams (Beta) | F3DEX2.XX | 5 | Normal | Compatible
Robot Ponkottsu 64 - Caramel of the 7 Seas | F3DEX2.XX | 5 | Normal | Compatible
Robotron 64 | F3DEX1.XX | 5 | Fast | Compatible
Rocket - Robot on Wheels | F3DEX2.XX | 5 | Fast | Compatible
Rockman Dash | F3DEX2.XX | 5 | Fast | Compatible
Rugrats - Scavenger Hunt | F3DEX2.XX | 5 | Fast | Compatible
Rugrats - Treasure Hunt | F3DEX2.XX | 5 | Fast | Compatible
Rugrats in Paris - The Movie | F3DEX2.XX | 5 | Fast | Compatible
Rush 2 - Extreme Racing USA | F3DEX2.XX | 5 | Normal | Compatible
S.C.A.R.S. | F3DEX2.XX | 5 | Fast | Compatible
SD Hiryuu no Ken Densetsu | F3DEX1.XX | 5 | Normal | Compatible. Minor gfx errors
San Francisco Rush - Extreme Racing | F3DEX1.XX | 5 | Normal | Compatible
San Francisco Rush 2049 | F3DEX2.XX | 5 | Normal | Compatible
Scooby-Doo - Classic Creep Capers | F3DEX2.XX | 5 | Normal | Compatible. Sky in game doesn't work correctly with Voodoo 1-3
Shadow Man | F3DEX2.XX | 5 | Normal | Compatible. Use "Read every frame" option (slow) or "Get frame buffer info" with Mupen to have correct pause menu in game
Shadowgate 64 - Trials of the Four Towers | F3DEX2.XX | 5 | Fast | Compatible
Sim City 2000 | S2DEX.XX | 5 | Normal | Compatible
Snow Speeders | F3DEX2.XX | 5 | Normal | Compatible
Snowboard Kids | F3DEX1.XX | 5 | Normal | Compatible
Snowboard Kids 2 | F3DEX2.XX | 5 | Normal | Compatible
Sonic Wings Assault | RSP SW 2.0X | 5 | Slow | Compatible
South Park | F3DEX2.XX | 5 | Fast | Compatible
SouthPark - Chef's Luv Shack | F3DEX2.XX | 5 | Fast | Compatible
South Park Rally | F3DEX2.XX | 5 | Fast | Compatible
Space Dynamites | TURBO3D | 5 | Normal | Compatible
Space Invaders | F3DEX2.XX | 5 | Fast | Compatible
Space Station Silicon Valley | F3DEX1.XX | 5 | Normal | Compatible
Spider-Man | F3DEX2.XX | 5 | Fast | Compatible
Star Fox 64 | F3DEX1.XX | 5 | Fast | Compatible
Star Soldier - Vanishing Earth | F3DEX1.XX | 5 | Fast | Compatible
Star Twins | RSP SW RARE4 | 5 | Normal | Compatible. Use "Get frame buffer info" option with Mupen or use “Read every frame” option (slow) to see correct TV
Star Wars - Rogue Squadron | ? | 0 | ? | Unsupported. Microcode not implemented
Star Wars - Shadows of the Empire | RSP SW 2.0D EXT | 5 | Normal | Compatible
Star Wars Episode I - Battle for Naboo | ? | 0 | ? | Unsupported. Microcode not implemented
Star Wars Episode I - Racer | F3DEX2.XX | 5 | Normal | Compatible
StarCraft 64 | F3DEX2.XX | 5 | Normal | Compatible
Starshot - Space Circus Fever | F3DEX2.XX | 5 | Normal | Compatible
Stunt Racer 64 | ? | 0 | ? | Unsupported
Super B-Daman - Battle Phoenix 64 | F3DEX1.XX | 5 | Fast | Compatible
Super Bowling 64 | F3DEX2.XX | 3 | Fast | Gfx errors
Super Mario 64 | RSP SW 2.0X | 5 | Fast | Compatible
Super Robot Spirits | F3DEX1.XX | 5 | Normal | Compatible
Super Robot Taisen 64 | RSP SW 2.0X | 5 | Normal | Compatible
Super Smash Bros. | F3DEX2.XX | 5 | Normal | Compatible
Super Speed Race 64 | F3DEX1.XX | 5 | Fast | Compatible
Supercross 2000 | F3DEX2.XX | 5 | Normal | Compatible
Superman | F3DEX1.XX | 5 | Normal | Compatible
Susume! taisen puzzle dama toukon ! Marumata Chou | S2DEX.XX | 5 | Normal | Compatible
Taz Express | RSP SW 2.0X | 5 | Normal | Compatible. Use Mupen 0.4
Telefoot Soccer 2000 | ZSortp 0.33 | 0 | ? | Unsupported. Microcode not implemented
Tetris 64 | RSP SW 2.0X | 5 | Normal | Compatible
Tetrisphere | RSP SW 2.0X | 5 | Fast | Compatible
Tigger's Honey Hunt | F3DEX2.XX | 5 | Normal | Compatible
Tom Clancy's Rainbow Six | F3DEX2.XX | 5 | Normal | Compatible
Tom and Jerry in Fists of Furry | F3DEX1.XX | 5 | Normal | Compatible
Tonic Trouble | F3DEX1.XX | 5 | Normal | Compatible. Use "Read every frame" option to see correct transition effects for pause menu in game
Tony Hawk's Pro Skater | F3DEX2.XX | 5 | Fast | Compatible. Use PJ64
Tony Hawk's Pro Skater 2 | F3DEX2.XX | 5 | Fast | Compatible
Tony Hawk's Pro Skater 3 | F3DEX2.XX | 5 | Fast | Compatible
Top Gear Hyper-Bike | F3DEX2.XX | 2 | Normal | Major gfx errors. Use Mupen
Top Gear Overdrive | F3DEX2.XX | 4 | Normal | Gfx errors. Use Mupen
Top Gear Rally | F3DEX1.XX | 5 | Normal | Compatible
Top Gear Rally 2 | F3DEX2.XX | 5 | Normal | Compatible
Toukon Roads | ? | 0 | ? | Unsupported. Microcode not implemented
Toukon Roads 2 | ? | 0 | ? | Unsupported. Microcode not implemented
Toy Story 2 | F3DEX1.XX | 5 | Normal | Compatible
Transformers - Beast Wars Metals 64 | F3DEX2.XX | 5 | Fast | Compatible
Transformers - Beast Wars Transmetal | F3DEX2.XX | 5 | Fast | Compatible
Triple Play 2000 | F3DEX2.XX | 5 | Normal | Compatible. Use "Get frame buffer info" option with Mupen or use "Read every frame" option to see correct TV monitors (slow)
Tsumi to Batsu - Chikyuu no Keishousha | F3DEX2.XX | 5 | Normal | Compatible
Turok - Dinosaur Hunter | F3DEX1.XX | 5 | Fast | Compatible
Turok - Rage Wars | F3DEX2.XX | 5 | Normal | Compatible
Turok 2 - Seeds of Evil | F3DEX2.XX | 5 | Slow | Compatible
Turok 3 - Shadow of Oblivion | F3DEX2.XX | 5 | Slow | Compatible
Twisted Edge Extreme Snowboarding | F3DEX2.XX | 5 | Slow | Compatible. Minor gfx errors
V-Rally Edition 99 | F3DEX2.XX | 5 | Slow | Compatible. Minor gfx errors
Vigilante 8 | F3DEX2.XX | 2 | Slow | Many gfx errors
Vigilante 8 - 2nd Offense | F3DEX2.XX | 2 | Slow | Many gfx errors
Virtual Chess 64 | F3DEX1.XX | 5 | Slow | Compatible
Virtual Pool 64 | F3DEX1.XX | 5 | Fast | Compatible
Virtual Pro Wrestling 2 - Oudou Keishou | F3DEX2.XX | 5 | Normal | Compatible. Use "Read every frame" option to see motion blur effects during intro
Virtual Pro Wrestling 64 | F3DEX1.XX | 5 | Normal | Compatible
WCW Backstage Assault | F3DEX2.XX | 5 | Normal | Compatible
WCW Mayhem | F3DEX2.XX | 5 | Normal | Compatible
WCW Nitro | F3DEX1.XX | 5 | Normal | Compatible
WCW vs. nWo - World Tour | F3DEX1.XX | 5 | Normal | Compatible
WCW-nWo Revenge | F3DEX2.XX | 5 | Normal | Compatible
WWF - War Zone | F3DEX2.XX | 5 | Fast | Compatible. Use "Get frame buffer info" option with Mupen or use "Read every frame" option to see correct TV monitors (slow)
WWF Attitude | F3DEX2.XX | 5 | Fast | Compatible
WWF No Mercy | F3DEX2.XX | 5 | Fast | Compatible
WWF WrestleMania 2000 | F3DEX2.XX | 5 | Normal | Compatible. Use "Read every frame" option to see motion blur effects during intro
Waialae Country Club - True Golf Classics | F3DEX1.XX | 5 | Normal | Compatible. Minor gfx errors
War Gods | RSP SW 2.0X | 5 | Fast | Compatible
Wave Race 64 | RSP SW 2.0D EXT | 5 | Fast | Compatible
Wave Race 64 Shindou Edition | F3DEX1.XX | 5 | Normal | Compatible
Wayne Gretzky's 3D Hockey '98 | F3DEX1.XX | 5 | Fast | Compatible
Wetrix | F3DEX1.XX | 5 | Normal | Compatible
Wheel of Fortune | RSP SW 2.0X | 5 | Slow | Compatible
Wild Choppers | RSP SW 2.0X | 5 | Normal | Compatible
WinBack - Covert Operations | F3DEX2.XX | 5 | Fast | Compatible, but a gray square sometimes appear on the screen. Missing sky
Wipeout 64 | F3DEX1.XX | 5 | Fast | Compatible
Wonder Project J2 | RSP SW 2.0X | 5 | Normal | Compatible
World Cup 98 | F3DEX1.XX | 5 | Normal | Compatible
World Driver Championship | ? | 0 | ? | Unsupported
Worms - Armageddon | F3DEX2.XX | 5 | Normal | Compatible
Xena Warrior Princess - Talisman of Fate | F3DEX2.XX | 5 | Fast | Compatible
Yakouchuu II - Satsujun Kouru | F3DEX2.XX | 4 | Normal | Use Nemu 0.8 (disable audio HLE). No movies
Yoshi's Story | S2DEX.XX | 5 | Normal | Compatible. Minor texture errors. Use "Read every frame" option to see transition effects
Yuke Yuke!! Trouble Makers | RSP SW 2.0X | 5 | Normal | Compatible
Zelda no Densetsu 2 - Mujura no Kamen | F3DEX2.XX | 5 | Normal | Compatible
Zelda no Densetsu - Toki no Ocarina | F3DEX 2.06H | 5 | *Mostly* Fast | Compatible
Zool - Majou Tsukai Densetsu | F3DEX1.XX | 5 | Normal | Compatible