Bienvenue dans Adobe LiveCycle Designer

Bienvenue dans Adobe LiveCycle Designer

Bienvenue dans Adobe® LiveCycle® Designer


Apprentissage des principes clés

Apprentissage des principes clés

Présentation de LiveCycle Designer
Espace de travail
Introduction aux formulaires


Présentation de LiveCycle Designer

A propos d’ LiveCycle Designer
Nouveautés
Documentation supplémentaire, exemples et didacticiels
LiveCycle Designer et Adobe document services


A propos d’ LiveCycle Designer

Adobe® LiveCycle® Designer offre une interface graphique conviviale de conception de formulaires, qui simplifie la création de conceptions de formulaire pour leur distribution au format Adobe PDF. Les destinataires du formulaire peuvent remplir celui-ci en ligne, envoyer les données, les imprimer ou imprimer et remplir le formulaire manuellement à l'aide d'Adobe Reader®.
A l'aide de LiveCycle Designer, les auteurs de formulaires peuvent faire glisser et déposer des images et d'autres objets sur leurs formulaires, par exemple des zones de liste, des listes déroulantes et des boutons de commande. Ils peuvent concevoir un formulaire, en définir la logique, y apporter des modifications pour le faire correspondre à un exemplaire papier ou répondre à des exigences législatives rigoureuses, puis le visualiser et le tester dans Designer avant sa distribution.
Cependant, les fonctions de LiveCycle Designer ne se limitent pas à la simple création de formulaires. Les auteurs de formulaires sont en mesure de créer des solutions simples de capture de données électroniques et d'utiliser Adobe Acrobat® Professional pour consolider les données collectées. De plus, les développeurs de formulaires peuvent tirer parti de LiveCycle Designer pour créer et mettre à jour des solutions de capture des données qui accèdent aux sources de données de l'entreprise afin de lire, valider ou ajouter des enregistrements. LiveCycle Designer permet d'intégrer des documents PDF à des flux de production existants en liant les formulaires à des schémas XML, à des fichiers d'exemples XML, à des bases de données et à des services Web. LiveCycle Forms vous permet de créer des formulaires au format HTML et PDF.
Voir aussi
Nouveautés


Nouveautés

La liste ci-dessous présente les nouveautés intégrées à LiveCycle Designer 8.0 :
Importation des documents PDF
Diffusion du formulaire
Vérification de l'orthographe
Signatures numériques
Importation de modèles
Personnalisation de modèles
Copie des cellules d'une feuille de calcul
Editeur de champs
Génération de données test
Connexion aux données avec des schémas XML non-locaux
Champs peigne
Styles des cases à cocher et des boutons
Importation des documents PDF
Vous pouvez importer un document PDF sous forme d'illustration d'arrière-plan afin de préserver la disposition et l'aspect originaux, ou l'importer sous forme de contenu modifiable. Si vous importez un document PDF créé dans Acrobat sous forme d'illustration d'arrière-plan et s'il contient des champs de formulaire, LiveCycle Designer convertir ces champs en objets de bibliothèque correspondants. Vous pouvez ainsi modifier tout objet interactif et placer de nouveaux objets de bibliothèque au-dessus de l'illustration. Pour importer un document PDF sous forme d'illustration d'arrière-plan, sélectionnez l'option Créer un formulaire interactif avec des pages fixes dans l'assistant de création de formulaires. Si vous souhaitez importer un document PDF sous forme de contenu éditable dans LiveCycle Designer, sélectionnez l'option Créer un formulaire interactif avec une disposition souple.
Diffusion du formulaire
Après avoir terminé une conception de formulaire dans LiveCycle Designer, vous pouvez utiliser la fonction de diffusion d'Acrobat pour envoyer votre formulaire aux destinataires de votre choix afin qu'ils le remplissent. Cette fonction permet de transmettre le formulaire accompagné d'instructions précises sur la façon de le compléter. Une fois que les destinataires ont rempli le formulaire, il leur suffit alors de cliquer sur le bouton Envoyer pour vous retourner leur formulaire.
Vérification de l'orthographe
Le nouveau vérificateur orthographique permet de corriger les fautes en cours de frappe ou d'effectuer une vérification globale une fois la conception de formulaire terminée. Les options proposées permettent de sélectionner les éléments à prendre en compte lors de la vérification de l'orthographe et le dictionnaire à utiliser.
Signatures numériques
Vous pouvez désormais appliquer deux types de signatures numériques dans LiveCycle Designer : des signatures de document et des signatures de données. Les signatures de document protègent les champs et leurs valeurs. Vous pouvez appliquer des signatures de document à l'intégralité du formulaire ou à une collection de champs. Ces signatures s'appliquent aux boutons, cases à cocher, champs de date/heure, champs décimaux, listes déroulantes, champs d'image, zones de liste, champs numériques, codes à barres de formulaires pour support papier, champs de mot de passe, boutons radio, autres champs de signature du document et champs de texte. La signature de données protège les données du formulaire tout en assurant leur intégrité lors de la transmission. Les signatures de données peuvent s'appliquer uniquement aux données ou à la totalité de l'envoi. Vous pouvez les appliquer uniquement aux données ou à la totalité de l'envoi.
Importation de modèles
Vous pouvez désormais importer des fichiers modèle (TDS) dans le Gestionnaire de modèles. Lors de cette opération, une copie du modèle est automatiquement ajoutée au dossier des modèles indiqué dans le code source XML du formulaire ou dans le dossier Imported, si aucun emplacement n'est spécifié. Vous pouvez ensuite vous baser sur le modèle importé pour définir une nouvelle conception de formulaire ou apporter les modifications voulues au modèle.
Personnalisation de modèles
Les modèles installés avec LiveCycle Designer contiennent du texte et des images que vous êtes libre de remplacer par le nom, l'adresse, le numéro de téléphone ou le logo de votre entreprise. Lorsque vous créez un formulaire basé sur un modèle contenant des champs avec du texte ou des images personnalisables, l'assistant de création de formulaires vous invite à changer les informations affichées dans chaque champ en fonction de vos besoins.
Vous pouvez également vous servir de l'assistant de création de formulaires pour produire un formulaire basé sur les colonnes d'une feuille de calcul. LiveCycle Designer crée un champ de texte pour chaque colonne sélectionnée dans la feuille de calcul. Le nom de chaque en-tête de colonne devient le nom des légendes des champs de texte.
Copie des cellules d'une feuille de calcul
Il est possible de copier/coller ou de faire glisser des cellules d'une feuille de calcul directement dans LiveCycle Designer. LiveCycle Designer crée alors un objet de tableau correspondant aux cellules sélectionnées dans la feuille de calcul, en préservant les dimensions et le contenu. La mise en forme est également conservée dans la mesure du possible et les cellules vides du tableau contiennent des champs de texte. Si la section d'origine contient des en-têtes de colonne, ils sont convertis sous forme de rangée d'en-tête.
Editeur de champs
Vous pouvez à présent éditer des objets qui se trouvent dans la conception de formulaire à l'aide de l'éditeur de champs. L'éditeur de champ permet d'accéder facilement aux propriétés les plus fréquemment utilisées. Activez l'éditeur de champs dans le menu Affichage.
Génération de données test
Il est possible de générer des échantillons de données afin de prévisualiser et tester vos formulaires au lieu de créer des fichiers de données d'exemple. Si un formulaire contient des sous-formulaires qui se répètent ou des jeux de sous-formulaires, indiquez le nombre de répétitions voulu au moment de prévisualiser le formulaire. Pour définir des données test, cliquez sur l'onglet Valeurs par défaut dans la boîte de dialogue Propriétés du formulaire.
Connexion aux données avec des schémas XML non-locaux
Vous pouvez à présent établir une connexion à un schéma XML à l'aide d'un schéma ne se trouvant pas sur votre système local. Lorsque vous établissez une nouvelle connexion aux données, entrez l'URL du fichier de schéma XML. Lorsque vous chargez le schéma, il fonctionne de la même manière que sur votre système local.
Champs peigne
Vous pouvez à présent utiliser le format de peigne lorsque vous souhaitez séparer des caractères et des nombres ajoutés aux champs décimaux et numériques. Dans un champ peigne, chaque lettre du champ est séparé par une ligne verticale noire tendue entre les bords supérieur et inférieur du champ.
Styles des cases à cocher et des boutons
Vous pouvez à présent sélectionner de nouveaux styles pour les cases à cocher et les boutons. Lorsque vous sélectionnez une case à cocher, le panneau Champ de la palette Objet affiche plusieurs options de formatage. Vous pouvez définir la marque de sélection de la case à cocher par une coche, un cercle, une croix, un losange, un carré ou une étoile. Lorsque vous créez des boutons, vous pouvez les mettre en surbrillance, leur donner l'impression d'être enfoncés, ou ajouter un contour autour du bouton lorsque l'utilisateur clique dessus. D'autres effets pouvant être appliqués aux boutons sont les légendes enfoncé et survol. Pour définir le style des boutons, cliquez sur l'onglet Champ de la palette Objet.


Documentation supplémentaire, exemples et didacticiels

Plusieurs ressources ont été prévues pour vous aider à créer des formulaires avec LiveCycle Designer.

Ressource

Lieu
Didacticiels de mise en route conçus spécialement pour vous aider à faire vos premiers pas avec LiveCycle Designer.
Aide de LiveCycle Designer
Exemples de formulaires illustrant les différentes techniques de conception de formulaire, des plus simples aux plus compliquées. LiveCycle Designer propose une sélection d'échantillons, chacun d'entre eux étant accompagné par une conception de formulaire, des données d'exemple et/ou un schéma, ainsi que de la version finale du formulaire.
Installés avec LiveCycle Designer dans le répertoire d'installation par défaut sous \...\EN\Samples
Exemples de scripts s'appuyant sur des exemples de formulaires pour illustrer des solutions simples et rapides. Vous pouvez vous exercer avec les exemples de formulaires pour mettre en pratique les techniques apprises.
Centre des développeurs Adobe LiveCycle
Référence sur les objets de script. Le document Adobe XML Form Object Model Reference décrit les objets, les propriétés et les méthodes dont vous disposez pour écrire des scripts dans l'environnement LiveCycle Designer.
Centre des développeurs Adobe LiveCycle
Informations au sujet de FormCalc, langage de calcul (semblable à celui utilisé pour les tableurs) intégré dans LiveCycle Designer.
Aide LiveCycle Designer installée au format PDF dans le répertoire d'installation par défaut sous \...\Documentation\EN.
Le fichier LisezMoi de LiveCycle Designer contient des renseignements importants qui n'étaient pas disponibles au moment de la rédaction de la documentation du produit.
Installé avec LiveCycle Designer dans le répertoire d'installation par défaut sous \....\Documentation\EN.


LiveCycle Designer et Adobe document services

A propos de Adobe document services
LiveCycle Designer et Adobe document services
Choix du format de fichier approprié pour vos formulaires
Comportement des formulaires PDF dans Adobe Reader
Comportement des formulaires PDF dans Acrobat
Gestion des formulaires par LiveCycle Forms
Gestion des formulaires par LiveCycle Form Manager


A propos de Adobe document services

Adobe document services optimise la valeur des systèmes d'entreprise de base pour accroître la sécurité, la fiabilité et l'utilisation efficace de l'information vitale dans l'ensemble de l'entreprise élargie. En utilisant Adobe document services et ses propres systèmes de gestion, une entreprise peut :
      •
      automatiser les processus documentaires ;
      •
      échanger des documents transactionnels ;
      •
      conserver le caractère familier des processus ;
      •
      accéder à des processus automatisés hors connexion ;
      •
      partager de l'information sécurisée ;
      •
      échanger des données avec des gens et des systèmes ;
      •
      gérer l'accès aux documents ;
      •
      gérer des documents sécurisés et la sécurité ;
      •
      utiliser des signatures numériques et le chiffrement.


LiveCycle Designer et Adobe document services

Les produits intégrés à Adobe document services offrent aux entreprises des fonctions de création de documents, de collaboration, de contrôle, de sécurité, de gestion des processus et de gestion des accès.
La première étape dans Adobe document services consiste à concevoir et à créer des formulaires en utilisant LiveCycle Designer. La distribution d'un formulaire dans l'environnement d'exécution permet aux utilisateurs et aux entreprises d'accéder à une variété d'applications commerciales ou propriétaires pour ouvrir le formulaire et manipuler les données qui y sont associées. Par exemple, l'environnement d'exécution pourrait inclure les produits Adobe suivants :

Produit

Ce que fait le produit
Adobe Reader
Permet aux utilisateurs de visualiser, de remplir, de soumettre et d'imprimer des formulaires PDF de base.
Acrobat
Permet aux utilisateurs de visualiser, remplir, imprimer, enregistrer et soumettre des données et des formulaires PDF interactifs. Les utilisateurs peuvent consolider les informations obtenues dans un tableur tel que Microsoft Excel à l'aide d'Acrobat Professional.
LiveCycle Reader Extensions
Ajoute des droits d'utilisation aux formulaires PDF et offre des fonctions additionnelles dans Adobe Reader.
LiveCycle Forms
Présente les formulaires au format PDF ou HTML avec ou sans données.
Extrait des données XML à partir d'un formulaire PDF/HTML.
Exécute la logique applicative sur le serveur, y compris l'interaction avec les applications de base de l'entreprise.
LiveCycle Form Manager
Permet aux utilisateurs de stocker et d'extraire des formulaires et des données contenus dans un référentiel central.
Voir aussi
Comportement des formulaires PDF dans Adobe Reader
Comportement des formulaires PDF dans Acrobat


Choix du format de fichier approprié pour vos formulaires

Lorsque vous enregistrez un formulaire, son format doit être compatible avec la méthode de travail des utilisateurs. Vous pouvez enregistrer le formulaire sous forme de fichier PDF ou XDP. LiveCycle Designer vous offre ces deux choix pour répondre aux besoins des deux scénarios d'exécution de base suivants :
      •
      Le fichier PDF est ouvert dans Adobe Reader ou Acrobat.
      •
      Le fichier XDP est généré par LiveCycle Forms.
Si vous créez un formulaire que les utilisateurs ouvriront avec Acrobat version 6.0.2 et ultérieures ou Adobe Reader (avec ou sans droits d'accès), enregistrez-le sous forme de fichier PDF. Si vous créez un formulaire qui sera transmis par LiveCycle Forms, enregistrez-le sous forme de fichier XDP.
Voir aussi
A propos de Adobe document services
Comportement des formulaires PDF dans Adobe Reader
Comportement des formulaires PDF dans Acrobat


Comportement des formulaires PDF dans Adobe Reader

Lorsque les utilisateurs disposent d'Adobe Reader, ils peuvent ouvrir un formulaire au format PDF à partir du système de fichiers réseau, le remplir en ligne, soumettre les données et lancer l'impression, ou encore imprimer le formulaire puis le remplir à la main. Adobe Reader ne peut pas enregistrer les modifications apportées aux fichiers PDF. Même lorsque Adobe Reader est utilisé pour visualiser un formulaire PDF interactif, les utilisateurs peuvent interagir avec les objets et entrer des données, mais ils ne peuvent pas les enregistrer.
LiveCycle Reader Extensions vous permet d'accroître l'utilité d'Adobe Reader en offrant des fonctions interactives auparavant réservées aux utilisateurs qui ouvraient des documents PDF à l'aide de la version complète d'Acrobat.
Acrobat et Adobe Reader prennent en charge le traitement d'échange de données côté client pour les formulaires PDF interactifs.
Voir aussi
Comportement des formulaires PDF dans Acrobat


Comportement des formulaires PDF dans Acrobat

Lorsque les utilisateurs disposent d'Acrobat, ils ont accès à l'ensemble des fonctionnalités des formulaires interactifs, notamment le remplissage de formulaire, l'enregistrement local, les signatures numériques, la révision et les annotations, les opérations de bases de données et de services Web, ainsi que l'impression. Les utilisateurs peuvent ouvrir le formulaire PDF à partir d'un système de fichiers réseau, d'un courrier électronique ou d'un site Web, le remplir en ligne et enregistrer les données localement.
Acrobat et Adobe Reader prennent en charge le traitement d'échange de données côté client pour les formulaires PDF interactifs.
Voir aussi
Comportement des formulaires PDF dans Adobe Reader


Gestion des formulaires par LiveCycle Forms

LiveCycle Forms permet aux entreprises de publier des formulaires sur le Web. LiveCycle Forms permet de créer des formulaires PDF ou Web pour les acheminer vers un navigateur sans téléchargement ni module externe.
A mesure que les utilisateurs remplissent un formulaire, LiveCycle Forms peut vérifier l'exactitude des données, les valider et les calculer, envoyer une confirmation et soumettre les données aux principaux processus de l'entreprise.
Vous créez des formulaires à l'aide de LiveCycle Designer et vous les publiez dans LiveCycle Forms. LiveCycle Designer constitue la plate-forme centralisée requise pour déployer les formulaires dans l'entreprise, quel que soit l'environnement bureautique des utilisateurs. Il offre également les outils nécessaires pour élaborer et déployer facilement des formulaires, ainsi qu'un agent SNMP (Simple Network Management Protocol) pour surveiller les performances et gérer les formulaires à distance.
Voir aussi
A propos de Adobe document services
Comportement des formulaires PDF dans Adobe Reader
Comportement des formulaires PDF dans Acrobat


Gestion des formulaires par LiveCycle Form Manager

Les auteurs de formulaires et les autres utilisateurs autorisés stockent les formulaires et les fichiers dans le référentiel pour les mettre à la disposition des utilisateurs et d'autres applications, comme LiveCycle Designer. L'administrateur de LiveCycle Form Manager organise les formulaires et les fichiers dans le référentiel et accorde les droits d'accès qui y sont associés.
Vous utilisez LiveCycle Designer pour créer un formulaire et le publier avec tous les fichiers graphiques connexes à l'emplacement voulu dans LiveCycle Form Manager.
L'administrateur récupère ensuite le formulaire et en définit les droits d'accès ainsi que les métadonnées (comme une description et un nom de fichier plus significatifs, ainsi que du texte pour le formulaire). Il ajoute ensuite le formulaire à une ou à plusieurs catégories et le met à la disposition des utilisateurs finals. Ceux-ci peuvent ensuite faire une recherche sur le formulaire ou naviguer pour y accéder. Ils peuvent ouvrir le formulaire et le remplir, puis enregistrer le résultat dans LiveCycle Form Manager et interagir avec d'autres produits serveur tels que LiveCycle Forms ou Reader Extension Server.
Voir aussi
A propos de Adobe document services


Espace de travail

Présentation de l'espace de travail
Personnalisation de l'espace de travail
Gestion de la palette Bibliothèque


Présentation de l'espace de travail

A propos de l'espace de travail
Editeur de disposition
Editeur de script
Palettes


A propos de l'espace de travail

Par défaut, l'espace de travail LiveCycle Designer se compose d'une zone appelée Editeur de disposition (dans laquelle vous créez et présentez votre conception de formulaire), d'un éditeur de script (prévu pour créer des scripts dans le but d'étendre les fonctionnalités de la conception de formulaire), de palettes (qui vous aident à modifier la conception de formulaire) et de menus et commandes pour effectuer toutes les tâches nécessaires.
Quand vous serez plus à l'aise avec les conceptions de formulaire, vous pourrez personnaliser l'espace de travail en fonction de vos besoins spécifiques.
Voir aussi
Editeur de disposition
Editeur de script
Palettes


Editeur de disposition

L'éditeur de disposition sert à créer et à gérer les conceptions de formulaires. Il contient les quatre panneaux suivants :
Vue de conception, panneau
Affiche les pages constituant votre conception de formulaire.
Gabarit, panneau
Affiche les gabarits applicables aux pages en mode Vue de conception.
Source XML, panneau
Affiche le code source XML qui décrit la structure de la conception de formulaire et de ses objets. Evitez de modifier directement le code source XML.
Aperçu PDF, panneau
Affiche un formulaire PDF basé sur la conception de formulaire actuelle.
Par défaut, tous les onglets ne s’affichent pas. Vous avez accès à l'onglet Vue de conception, mais pas aux onglets Gabarit et Source XML. L'onglet Aperçu PDF s'affiche uniquement si Acrobat ou Adobe Reader est installé.
Des palettes munies d'onglets, disposées autour de l'éditeur de disposition, donnent accès aux outils sans encombrer l'espace de travail.
Vue de conception, panneau
Les pages de la vue de conception présentent le contenu de la conception de formulaire. La première fois que vous lancez LiveCycle Designer ou créez une conception de formulaire, le panneau Vue de conception affiche une page prête à recevoir des objets.
Les objets du gabarit qui apparaissent dans la page sont impossibles à sélectionner.
Gabarit, panneau
Les gabarits définissent la disposition et l'arrière-plan de la conception de formulaire. Ils contiennent des objets qui figureront au même endroit dans toute la conception de formulaire. Le panneau Gabarit est masqué par défaut.
Les objets figurant sur la page Vue de conception ne s'affichent pas dans le gabarit.
Aperçu PDF, panneau
Pendant la création d'un formulaire, si vous avez installé Acrobat ou Adobe Reader, vous pouvez le prévisualiser dans le panneau Aperçu PDF. Ce panneau permet d'afficher et de tester le fonctionnement d'un formulaire ou d'un modèle comme s'il s'agissait d'un fichier PDF. Vous pouvez configurer des options relatives à l'aperçu des formulaires interactifs ou des formulaires imprimables au format PDF, à partir de la boîte de dialogue Propriétés du formulaire (onglet Valeurs par défaut).
pour afficher l'aperçu d’un formulaire dans le panneau Aperçu PDF, dans Acrobat, assurez-vous que l'option Edition > Préférences > Internet > Afficher PDF dans le navigateur est sélectionnée.
Voir aussi
Pour personnaliser l’éditeur de disposition


Editeur de script

Servez-vous de l'éditeur de script pour créer des scripts dans le but d'étendre les fonctionnalités de la conception de formulaire. Par défaut, l'éditeur de script est affiché dans la partie supérieure de l'espace de travail de LiveCycle Designer. Vous pouvez toutefois l’ancrer à l'emplacement de votre choix.
L'éditeur de script propose à la fois une vue uniligne et une vue multiligne, entre lesquelles vous pouvez basculer librement en fonction de vos besoins. La vue uniligne permet d'augmenter l'espace réservé à l'affichage de l'éditeur de disposition et des autres palettes. La vue multiligne permet, quant à elle, d'augmenter l'espace réservé à la rédaction des scripts.
Vous pouvez, par exemple, faire appel à l'éditeur de script pour écrire un calcul simple dans le but d'additionner les valeurs de deux champs numériques ou un script complexe qui modifie la présentation du formulaire selon les actions de l'utilisateur final. LiveCycle Designer prend en charge les scripts écrits dans son propre langage (FormCalc) ou en langage JavaScript.
Voir aussi
A propos des calculs et des scripts
A propos de l’éditeur de script


Palettes

A propos des palettes
Palette Hiérarchie
Palette Vue des données
Palette Structure PDF
Palette Bibliothèque
Palette Disposition
Palette Bordure
Palette Objet
Palette Accessibilité
Palette Police
Palette Paragraphe
Palette Accessoires de dessin
Palette Info
Palette Rapport
Palette Procédures


A propos des palettes

Les palettes permettent d'accéder facilement aux outils sans encombrer l'espace de travail. Elles peuvent comporter un ou plusieurs onglets contenant chacun des propriétés communes. La palette Objet peut, par exemple, contenir un ou plusieurs onglets.
Vous pouvez disposer les palettes comme il vous plaît dans l'espace de travail. Par exemple, vous pouvez masquer les palettes rarement utilisées et intégrer dans une même fenêtre de palettes celles dont vous vous servez le plus souvent.
Quand vous travaillez dans l'éditeur de disposition, les informations qui s'affichent dans les palettes varient en fonction de l'objet sélectionné. Par exemple, si vous sélectionnez un objet, les informations de la palette Disposition sont mises à jour pour indiquer la taille et la position de l'objet.


Palette Hiérarchie

La palette Hiérarchie est une représentation graphique du contenu des panneaux Vue de conception et Gabarit.
Tout ce que vous sélectionnez dans la palette Hiérarchie est également sélectionné dans le corps ou le gabarit auxquels la sélection est associée.
Voir aussi
Menu de la palette Hiérarchie


Palette Vue des données

S'il existe une connexion aux données, la palette Vue des données affiche la hiérarchie qui en résulte. Les noeuds supérieurs de la hiérarchie représentent chaque connexion aux données et affichent leurs noms. Une connexion aux données établit un lien entre le formulaire et la source de données.
Lorsque vous concevez un formulaire basé sur une connexion aux données, LiveCycle Designer définit une structure de données pour votre formulaire en fonction de cette source de données. Vous pouvez alors créer rapidement un formulaire en exploitant une partie ou l'intégralité de la source de données. Il suffit ensuite d'établir une liaison pour associer un noeud d'une source de données à un objet du formulaire.
Voir aussi
Menu de la palette Vue des données


Palette Structure PDF

La palette Structure PDF présente une vue de la structure hiérarchique des documents PDF balisés, ce qui permet aux technologies d’assistance (telles que l'accès au clavier et les lecteurs d'écran) de disposer d'options d'accessibilité et d'un ordre de tabulation et de lecture défini.
Voir aussi
Menu de la palette Structure PDF
Importation de documents PDF en tant qu'illustrations


Palette Bibliothèque

La palette Bibliothèque contient tous les objets susceptibles d'être ajoutés à une conception de formulaire. Les objets sont classés par catégories :
Favoris
Contient les objets que vous utilisez fréquemment.
Standard
Regroupe les objets de formulaire régulièrement employés, tels que les cases à cocher et les champs de texte.
Codes à barres
Contient une liste des objets de type code à barres.
Personnalisés
Contient des objets prédéfinis, tels que des blocs d'adresse et des champs de numéros de téléphone.
Vous être libre d'ajouter des catégories, de renommer des catégories existantes, de déplacer des objets d'une catégorie à une autre ou de retirer des catégories de cette palette. Vous pouvez également créer et ajouter vos propres objets dans les catégories. Chaque catégorie correspond à un dossier dans le système de fichiers.
Voir aussi
Qu'est-ce-qu'un objet ?
Gestion de la palette Bibliothèque
Menu de la palette Bibliothèque


Palette Disposition

Servez-vous de la palette Disposition pour définir les propriétés suivantes pour l'objet sélectionné :
      •
      Taille et position de l'objet.
      •
      Développement de l'objet pour afficher tout son contenu, indépendamment de la hauteur et de la largeur définies.
      •
      Position du point d'ancrage (insertion). Il est possible de faire pivoter l'objet autour de son point d'ancrage par incrément de 90°, de 180° ou de 270°.
      •
      Marges autour de l'objet.
      •
      Position et largeur de la légende. Vous pouvez également la masquer.
Lorsque vous sélectionnez un objet, la palette Disposition affiche automatiquement les paramètres de l'objet sélectionné. Vous pouvez modifier la plupart des paramètres de disposition d'un objet directement dans l'éditeur de disposition. Par exemple, pour changer la position d'un objet, vous pouvez le faire glisser vers son nouvel emplacement dans la page.
Voir aussi
Formatage des objets
Propriétés de la palette Disposition
Menu de la palette Disposition


Palette Bordure

La palette Bordure permet de modifier les propriétés de la bordure des objets qui se trouvent dans la conception de formulaire. Vous pouvez redéfinir les bordures individuellement (gauche, droite, supérieure et inférieure) ou globalement. Vous pouvez également indiquer le type de coin de la bordure et la couleur de l'arrière-plan.
Voir aussi
Menu de la palette Bordure
Propriétés de la palette Bordure
Pour ajouter une bordure autour d'un objet
Pour ajouter une bordure autour de la zone remplissable


Palette Objet

La palette Objet permet de modifier les propriétés propres à l'objet sélectionné. Les onglets de la palette varient selon l'objet sélectionné dans l'éditeur de disposition.
Voir aussi
Menu de la palette Objet


Palette Accessibilité

Utilisez la palette Accessibilité pour associer un texte personnalisé à un objet, qui peut ensuite être lu par un lecteur d'écran doté de la technologie Microsoft Active Accessibility (MSAA). Si l'objet comporte un texte personnalisé destiné au lecteur d'écran, ce dispositif lit le texte personnalisé et non l'info-bulle.
Vous pouvez également modifier, objet par objet, l'ordre par défaut selon lequel le lecteur d'écran recherche le texte à lire ; en outre, vous pouvez désactiver, pour tout objet, le texte destiné au lecteur d'écran.
Voir aussi
Menu de la palette Accessibilité
Propriétés de la palette Accessibilité
Définition d’objets accessibles


Palette Police

La palette Police permet de modifier la famille de polices, la taille et le style du texte de l'objet sélectionné. Vous pouvez également changer la police de la légende et de la valeur.
Voir aussi
A propos de la mise en forme du texte
Menu de la palette Police
Propriétés de la palette Police


Palette Paragraphe

La palette Paragraphe permet de modifier l'alignement, les retraits et l'interligne du texte sélectionné. Vous pouvez également y définir l'alignement de la base dans le cas d'un objet de champ numérique. Les options de la palette Paragraphe varient selon l'élément sélectionné. Vous pouvez également changer la police de la légende et de la valeur.
Voir aussi
A propos de la mise en forme des paragraphes
Menu de la palette Paragraphe


Palette Accessoires de dessin

La palette Accessoires de dessin permet de définir les paramètres de grille et de règle ainsi que les unités de dessin. Vous pouvez aussi afficher ou masquer les limites d'un objet et définir les styles de bordures des contours.
Les règles horizontale et verticale, la grille et le viseur plein écran vous aident à positionner avec précision les objets sur une page. Lorsqu'elles sont visibles, les règles figurent dans la partie supérieure et du côté gauche de la page ou du gabarit actifs. Sur la règle, les marqueurs indiquent la position du pointeur lorsque vous le déplacez. En changeant l'origine de la règle (la marque (0, 0) sur les règles supérieure et de gauche), vous pouvez mesurer la position à partir d'un point spécifique de la conception de formulaire.
Vous pouvez également afficher ou masquer les limites d'un objet sur la conception de formulaire. Cette fonction est particulièrement utile pour afficher les objets dont les bordures n'apparaissent pas sur le formulaire final. Il est possible, en outre, de définir les styles de bordures des champs, des sous-formulaires, des zones de contenu, des groupes et de divers autres objets.
Voir aussi
Pour utiliser les accessoires de dessin
Alignement et redimensionnement d'objets
Menu de la palette Accessoires de dessin


Palette Info

La palette Info affiche les métadonnées associées aux objets sélectionnés. Les métadonnées sont stockées dans la source XML sous forme d'enfants spécifiques à un élément <desc>. Vous pouvez modifier certaines des métadonnées de la conception de formulaire à l'aide de la boîte de dialogue Propriétés du formulaire (onglet Info).
Voir aussi
Menu de la palette Info
Panneau Infos (boîte de dialogue Propriétés du formulaire)


Palette Rapport

La palette Rapport fournit des renseignements sur la conception de formulaire. Le panneau Avertissements contient la liste des messages et des erreurs signalés pendant que vous travaillez sur la conception de formulaire. Pour effacer le contenu du panneau Avertissements, cliquez dans le menu de la palette et choisissez Effacer les avertissements.
Voir aussi
Menu de la palette Rapport
Pour afficher la liste des champs liés


Palette Procédures

La palette Procédures répertorie les rubriques d'aide relatives aux procédures couramment effectuées dans LiveCycle Designer. Faites défiler la liste pour afficher la rubrique qui vous intéresse, puis cliquez sur Informations supplémentaires pour afficher le détail de la procédure correspondante.


Personnalisation de l'espace de travail

Pour personnaliser l’éditeur de disposition
Pour personnaliser l’éditeur de script
Pour personnaliser des palettes
Pour utiliser les accessoires de dessin
Pour personnaliser les barres d’outils
Pour personnaliser les info-bulles


Pour personnaliser l’éditeur de disposition

Vous pouvez personnaliser l'éditeur de disposition afin d'afficher ou de masquer des onglets, de redimensionner des pages et d'effectuer des zooms avant et arrière.
Pour afficher ou masquer des onglets
      •
      Pour afficher ou masquer l'onglet Vue de conception, choisissez Affichage > Vue de conception.
      •
      Pour afficher ou masquer l'onglet Gabarit, choisissez Affichage > Gabarit.
      •
      Pour afficher ou masquer l'onglet Source XML, choisissez Affichage > Source XML.
      •
      Pour afficher ou masquer l'onglet Aperçu PDF, choisissez Affichage > Aperçu PDF.
Pour faire un zoom avant ou arrière
      •
      Pour afficher la page en grandeur nature (100 %), choisissez Affichage > Taille réelle.
      •
      Pour adapter la page aux dimensions de l'éditeur de disposition, choisissez Affichage > Taille réelle.
      •
      Pour adapter la page à la largeur de l'éditeur de disposition, choisissez Affichage > Taille réelle.
      •
      Pour effectuer un zoom avant ou arrière dans l'éditeur de disposition, choisissez Affichage > Zoom, entrez une valeur comprise entre 25% et 500% dans la zone Facteur de zoom, puis cliquez sur OK. Vous pouvez également utiliser la zone Facteur de zoom [image] dans la barre d'outils.
      •
      Pour agrandir une zone, choisissez Affichage > Zoom ciblé. Le pointeur se change en loupe. A l’aide de la loupe, cliquez sur la zone que vous voulez agrandir et faites-la glisser pour obtenir le grossissement voulu.
      •
      Pour afficher une page spécifique, effectuez un zoom arrière afin d'afficher la page entière, puis faites défiler les pages jusqu'à celle qui vous intéresse.
Voir aussi
Editeur de disposition


Pour personnaliser l’éditeur de script

      •
      Pour afficher ou masquer l'éditeur de script, choisissez Fenêtre > Editeur de script.
      •
      Pour passer de la vue uniligne à la vue multiligne, faites glisser le bouton Développer sur la bordure de la palette Éditeur de script jusqu'à ce que vous obteniez la taille de palette requise.
Voir aussi
Editeur de script
A propos des calculs et des scripts


Pour personnaliser des palettes

Il est possible de personnaliser les palettes de façon à les afficher, les masquer, les ancrer, les déplacer, les redimensionner ou les réinitialiser.
Pour afficher ou masquer des palettes
      •
      Pour afficher une palette, choisissez Fenêtre > [nom de la palette].
      •
      Pour masquer une palette, sélectionnez le menu de la palette > Masquer la palette.
      •
      Pour afficher ou masquer toutes les palettes d'un seul côté de l'éditeur de disposition, cliquez sur Développer [image] sur la bordure de la palette. Cliquez de nouveau pour réduire les palettes.
      •
      Pour afficher ou masquer toutes les palettes à l'emplacement sélectionné, choisissez Fenêtre > Espace de travail, puis choisissez l'une des commandes proposées.
Pour ancrer ou déplacer les palettes
      •
      Pour ancrer une palette sur le côté de la fenêtre, faites glisser la barre de la palette vers le bord de la fenêtre LiveCycle Designer.
      •
      Pour ancrer deux palettes entre-elles, faites glisser la barre de la palette jusqu'au dessous d'une autre palette. Cette procédure concerne uniquement les palettes ancrées à la fenêtre LiveCycle Designer. Elle ne s'applique pas aux palettes flottantes.
      •
      Pour déplacer et ancrer une palette, faites glisser la barre de la palette.
      •
      Pour déplacer une palette sans l'ancrer, faites glisser la barre de la palette tout en maintenant la touche Ctrl enfoncée.
      •
      Pour déplacer une palette dans une autre fenêtre de palette, faites glisser l'onglet de la palette vers la palette de destination. Vous ne pouvez pas déplacer un sous-onglet.
Pour redimensionner ou réinitialiser des palettes
      •
      Pour changer la taille d'une palette, faites glisser l'un des côtés de la palette.
      •
      Pour rétablir l'emplacement des palettes, choisissez Fenêtre > Réinitialiser la position des palettes.
Voir aussi
Palettes


Pour utiliser les accessoires de dessin

Vous pouvez tirer parti des accessoires de dessin pour afficher ou masquer les règles et les limites d'objets, configurer la grille et définir d'autres préférences.
Pour afficher ou masquer les accessoires de dessin
      •
      Pour afficher rapidement la palette Accessoires de dessin, cliquez deux fois sur les règles.
      •
      Pour afficher ou masquer les limites des objets, choisissez Affichage > Limites de l'objet.
      •
      Pour afficher ou masquer les règles, les lignes guides ou la grille, choisissez Affichage > Règles, Affichage > Lignes guides ou Affichage > Grille.
      •
      Pour afficher ou masquer le viseur, choisissez Viseur plein écran.
Pour utiliser la grille
      •
      Pour activer la fonction d'accrochage à la grille, choisissez Affichage > Accrocher à la grille.
      •
      Pour définir l'origine de la grille, entrez les nouvelles coordonnées de l'origine dans les zones X et Y prévues à cet effet.
      •
      Pour redéfinir l'intervalle de la grille, saisissez les nouvelles valeurs dans les zones Intervalle X et Intervalle Y. Si le pas de la grille correspond à 1 centimètre et que vous spécifiez un intervalle de 10, 10 points de grille sont affichés par centimètre.
Pour définir d'autres accessoires de dessin
      •
      Pour ajouter une ligne guide, depuis le coin supérieur gauche de l'éditeur de disposition, faites glisser le pointeur sur la page. Pour supprimer une ligne guide, sélectionnez le triangle correspondant dans la règle, puis faites-le glisser hors de la page.
      •
      Pour définir l'unité de mesure des règles, faites votre choix dans la liste Unités.
      •
      Pour définir la couleur des bordures des contours de l'objet, cliquez sur Styles, cliquez sur la zone Couleur, choisissez Autres couleurs, puis sélectionnez une couleur prédéfinie dans une palette ou créez votre propre couleur en cliquant sur Définir les couleurs personnalisées.
      •
      Pour définir le style des bordures des contours de l'objet, cliquez sur Styles et sélectionnez le style de bordure voulu pour l'objet.
      •
      Pour définir la couleur des grilles ou des lignes guides, cliquez sur la zone Couleur, choisissez Autres couleurs, puis sélectionnez une couleur prédéfinie dans une palette ou créez votre propre couleur en cliquant sur Définir les couleurs personnalisées.
Voir aussi
Palette Accessoires de dessin
Menu de la palette Accessoires de dessin
Alignement et redimensionnement d'objets


Pour personnaliser les barres d’outils

Vous pouvez personnaliser les barres d'outils de façon à afficher, masquer, ancrer, déplacer, créer ou supprimer des barres d'outils, ajouter des boutons fréquemment employés ou retirer les boutons inutiles, ou bien rétablir les barres d'outils par défaut.
Pour afficher, masquer, ancrer ou déplacer une barre d'outils
      •
      Pour afficher ou masquer une barre d'outils, cliquez dessus avec le bouton droit de la souris, puis sélectionnez ou désélectionnez la barre d'outils à afficher ou masquer.
      •
      Pour ancrer une barre d'outils, faites-la glisser jusqu'en haut de la fenêtre LiveCycle Designer.
      •
      Pour déplacer une barre d'outils, faites-la glisser jusqu'à son nouvel emplacement.
Pour créer une barre d'outils
1.
Choisissez Outils > Personnaliser les barres d'outils.
2.
Dans l'onglet Barres d'outils, cliquez sur Nouveau.
3.
Donnez un nom à la barre d'outils, puis cliquez sur OK.
4.
Ajoutez des boutons et des menus à la barre d'outils, puis cliquez sur OK.
Pour supprimer une barre d'outils
1.
Choisissez Outils > Personnaliser les barres d'outils.
2.
Dans le panneau Barres d'outils, sélectionnez la barre d'outils dont vous n'avez plus besoin et cliquez sur Supprimer.
vous ne pouvez supprimer que les barres d'outils que vous avez créées.
Pour ajouter ou supprimer un bouton dans une barre d'outils
1.
Assurez-vous que la barre d'outils que vous voulez modifier n'est pas masquée.
2.
Choisissez Outils > Personnaliser les barres d'outils.
3.
Ajoutez ou supprimez un bouton.
      •
      Pour ajouter un bouton dans une barre d'outils, sélectionnez la catégorie dans le panneau Commandes, puis cliquez sur le bouton à ajouter. Faites glisser ensuite le bouton vers la barre d'outils.
      •
      Pour supprimer un bouton dans une barre d'outils, faites-le simplement glisser hors de la barre d'outils.
4.
Cliquez sur OK.
Pour restaurer l'aspect par défaut d'une barre d'outils
1.
Assurez-vous que la barre d'outils que vous voulez restaurer n'est pas masquée.
2.
Choisissez Outils > Personnaliser les barres d'outils.
3.
Sélectionnez la barre d'outils, cliquez sur Réinitialiser, puis cliquez sur OK.


Pour personnaliser les info-bulles

      •
      Pour afficher ou masquer les info-bulles de position, choisissez Outils > Options > Espace de travail, activez ou désactivez l'option Afficher les info-bulles de taille et de position lors de la modification, puis cliquez sur OK.
      •
      Pour afficher ou masquer les info-bulles d'objet, choisissez Outils > Options > Espace de travail, activez ou désactivez l'option Afficher les info-bulles de nom d'objet au pointage du curseur, puis cliquez sur OK.


Gestion de la palette Bibliothèque

Pour ajouter une catégorie à la palette Bibliothèque
Pour supprimer une catégorie dans la palette Bibliothèque
Pour déplacer un objet dans une autre catégorie de la palette Bibliothèque
Pour personnaliser l'affichage dans la palette Bibliothèque
Pour définir les droits pour une catégorie de la palette Bibliothèque
Pour ajouter un objet à la palette Bibliothèque
Pour supprimer un objet à partir de la palette Bibliothèque
Pour renommer un objet de la palette Bibliothèque
Pour restaurer les objets par défaut dans la palette Bibliothèque
Pour partager une catégorie de la palette Bibliothèque avec d'autres auteurs ou développeurs de formulaires
Pour partager une bibliothèque avec d'autres auteurs ou développeurs de formulaires


Pour ajouter une catégorie à la palette Bibliothèque

1.
Dans le menu de la palette Bibliothèque, choisissez Ajouter un groupe.
2.
Saisissez le nom de la catégorie, puis cliquez sur OK. L'ajout d'une catégorie à la palette Bibliothèque a pour effet de créer un dossier dans le système de fichiers.
pour afficher l'emplacement du nouveau dossier, cliquez sur la catégorie dans la palette Bibliothèque, puis choisissez Propriétés du groupe dans le menu de la palette. L'information voulue apparaît dans la zone Emplacement.


Pour supprimer une catégorie dans la palette Bibliothèque

1.
Dans le menu de la palette Bibliothèque, choisissez Supprimer le groupe.
2.
Effectuez l'une des opérations suivantes :
      •
      Pour supprimer une catégorie, choisissez Supprimer le groupe et tous ses objets.
      •
      Pour supprimer une catégorie et transférer les objets vers une autre catégorie, choisissez Supprimer le groupe et déplacer les objets vers [nom de la catégorie].
3.
Cliquez sur OK.


Pour déplacer un objet dans une autre catégorie de la palette Bibliothèque

      *
      Dans la palette Bibliothèque, sélectionnez l'objet à déplacer et choisissez Déplacer l’objet vers > [nom de la catégorie].
Seules les catégories permettant l'ajout ou la suppression d'objets sont répertoriées.


Pour personnaliser l'affichage dans la palette Bibliothèque

      *
      Effectuez une ou les deux opérations suivantes :
      •
      Pour modifier la taille des icônes, dans le menu de la catégorie, choisissez Affichage > [taille de l'icône].
      •
      Pour classer les icônes, dans le menu de la catégorie, choisissez Affichage > Liste triée.


Pour définir les droits pour une catégorie de la palette Bibliothèque

1.
Dans le menu de la catégorie, choisissez Propriétés du groupe.
2.
Effectuez l'une des opérations suivantes :
      •
      Pour autoriser l'ajout d'objets dans une catégorie, assurez-vous que la case Permettre l'ajout d'objets est cochée.
      •
      Pour autoriser la suppression d'objets dans une catégorie, assurez-vous que la case Permettre le retrait d'objets est cochée.
      •
      Pour autoriser le changement des objets dans une catégorie, assurez-vous que la case Permettre la modification d'objets est cochée.


Pour ajouter un objet à la palette Bibliothèque

1.
Dans la palette Bibliothèque, sélectionnez la catégorie dans laquelle vous souhaitez stocker l'objet.
2.
Faites glisser l’objet dans la palette Bibliothèque.
3.
Dans la boîte de dialogue Ajouter un objet de bibliothèque, saisissez le nom de l'objet.
4.
(Facultatif) Entrez la description de l'objet.
5.
Cliquez sur OK.
S'il existe déjà un objet portant le même nom dans cette catégorie, LiveCycle Designer vous demande si vous souhaitez le remplacer.
Dans la boîte de dialogue Propriétés du groupe, il est possible que certaines catégories aient été configurées afin d'empêcher l'ajout, la suppression ou la modification des objets. Si une catégorie empêche l'ajout des nouveaux objets, les objets sont placés dans la première catégorie qui les accepte.


Pour supprimer un objet à partir de la palette Bibliothèque

1.
Dans la palette Bibliothèque, sélectionnez la catégorie où l'objet est stocké.
2.
Cliquez sur l'objet à l'aide du bouton droit de la souris, puis choisissez Retirer l'objet de la bibliothèque.
Dans la boîte de dialogue Propriétés du groupe, il est possible que certaines catégories aient été configurées afin d'empêcher l'ajout, la suppression ou la modification des objets. Vous ne pouvez pas modifier un objet si la catégorie est configurée pour empêcher cette opération.
3.
Lorsque vous êtes invité à supprimer l'objet, cliquez sur Oui. L'objet est alors supprimé du système de fichiers.


Pour renommer un objet de la palette Bibliothèque

1.
Dans la palette Bibliothèque, sélectionnez la catégorie où l'objet est stocké.
2.
Cliquez sur l'objet à l'aide du bouton droit de la souris, puis choisissez Propriété de l'objet.
Dans la boîte de dialogue Propriétés du groupe, il est possible que certaines catégories aient été configurées afin d'empêcher l'ajout, la suppression ou la modification des objets. Vous ne pouvez pas modifier un objet si la catégorie est configurée pour empêcher cette opération.
3.
Dans la zone Nom, tapez un nouveau nom.
4.
(Facultatif) Dans la zone Description, entrez une description.
5.
Cliquez sur OK.
S'il existe déjà un objet portant le même nom dans cette catégorie, LiveCycle Designer vous demande si vous souhaitez le remplacer.


Pour restaurer les objets par défaut dans la palette Bibliothèque

Il est possible de restaurer les objets par défaut des catégories Favoris, Standard, Codes à barres et Personnalisés dans LiveCycle Designer.
la procédure de restauration a pour effet de rétablir tous les objets fournis avec LiveCycle Designer. LiveCycle Designer remplace les objets manquants et écrase tous ceux dont les noms sont identiques aux objets d'origine.
1.
Dans la palette Bibliothèque, sélectionnez l'une des catégories suivantes : Favorites, Standard, Codes à barres ou Personnalisés.
2.
Dans le menu de la palette, choisissez Restaurer les objets standard.


Pour partager une catégorie de la palette Bibliothèque avec d'autres auteurs ou développeurs de formulaires

Vous pouvez placer les objets de la palette Bibliothèque dans un dossier partagé ou un dossier Web accessible aux autres auteurs ou développeurs de formulaires.
1.
Créez un dossier partagé ou un dossier Web accessible aux autres auteurs ou développeurs de formulaires.
2.
Créez des sous-dossiers pour chacune des catégories de la palette Bibliothèque que vous souhaitez partager.
3.
Copiez les objets et collez-les au nouvel emplacement.
pour afficher l'emplacement du nouveau dossier, cliquez sur la catégorie dans la palette Bibliothèque, puis choisissez Propriétés du groupe dans le menu de la palette. L'information voulue apparaît dans la zone Emplacement.
4.
Dans LiveCycle Designer, sélectionnez la catégorie qui vous intéresse dans la palette Bibliothèque.
5.
Dans le menu de la palette Bibliothèque, choisissez Propriétés du groupe.
6.
Dans la zone Emplacement, entrez ou recherchez l'emplacement des objets que vous souhaitez placer dans cette catégorie.
7.
Cliquez sur OK.
8.
Répétez les étapes 4 à 7 pour chacune des catégories.


Pour partager une bibliothèque avec d'autres auteurs ou développeurs de formulaires

Vous pouvez placer votre bibliothèque de catégories et d'objets dans un dossier partagé ou un dossier Web accessible aux autres auteurs ou développeurs de formulaires.
Pour créer une bibliothèque partagée à l'aide d'une bibliothèque existante
1.
Ajoutez et supprimez des catégories et des objets de votre bibliothèque jusqu'à ce que vous créiez la structure désirée de la bibliothèque partagée.
2.
Pour chaque catégorie, sélectionnez Propriétés du groupe dans le menu de la palette Bibliothèque, puis définissez les droits d'accès utilisateur.
3.
Localisez le dossier Objets situé dans le répertoire où vous avez installé LiveCycle Designer, puis copiez-le (ainsi que tous ses sous-dossiers) sur un dossier partagé ou un dossier Web accessible aux auteurs ou développeurs de formulaires.
4.
Renommez le fichier LocalLibrary.xml situé dans le dossier Objets afin d'éviter toute confusion. Par exemple, renommez le fichier comme suit : SharedLibrary.xml.
5.
Ajoutez la bibliothèque partagée à LiveCycle Designer en suivant la procédure Pour ajouter une bibliothèque partagée.
Pour créer une bibliothèque partagée sans avoir recours à une bibliothèque existante
1.
Créez un dossier partagé ou un dossier Web accessible aux auteurs ou développeurs de formulaires.
2.
Créez des sous-dossiers au sein du dossier partagé pour chacune des catégories de la bibliothèque que vous souhaitez partager.
3.
Copiez les objets de la bibliothèque et collez-les au nouvel emplacement partagé.
pour afficher l'emplacement actuel des objets ou des catégories de la bibliothèque, cliquez sur la catégorie de la palette Bibliothèque, puis choisissez Propriétés du groupe dans le menu de la palette. L'information voulue apparaît dans la zone Emplacement.
4.
A l'aide du formulaire, créez un nouveau fichier de bibliothèque d'objets pour lequel nom_de_la_catégorie est le nom devant apparaître comme titre de la catégorie dans la palette Bibliothèque, et dossier est l'emplacement ou le chemin d'accès relatif au dossier contenant les objets de la catégorie.

    <?xml version="1.0" encoding="UTF-8"?>
    <objectLibraryTabSet>
        <tab name="Category_name" directory="folder" permission="adm"/>
        <tab name="Category_name" directory="folder" permission="adm"/>
        .
        .
        .
    </objectLibraryTabSet>
5.
Enregistrez le nouveau fichier de bibliothèque d'objets dans le répertoire racine de votre dossier partagé avec l'extension de nom de fichier .xml.
6.
Ajoutez la bibliothèque partagée à LiveCycle Designer en suivant la procédure Pour ajouter une bibliothèque partagée.
Pour ajouter une bibliothèque partagée
1.
Dans le menu de la palette Bibliothèque, sélectionnez Emplacement de la bibliothèque partagée.
2.
Dans la zone Emplacement, entrez le nom du dossier ou cliquez sur Parcourir pour localiser le dossier partagé contenant le fichier de bibliothèque d'objets de la bibliothèque partagée que vous souhaitez ajouter.
3.
Cliquez sur OK.


Introduction aux formulaires

Concepts de base
Composants d’une conception de formulaire
Formulaires interactifs
Planification des conceptions de formulaire


Concepts de base

A propos des formulaires et des conceptions de formulaire
Mode de capture ou de présentation des informations
Méthodes de création de conceptions de formulaire
Qui crée les formulaires ?


A propos des formulaires et des conceptions de formulaire

Les formulaires ont généralement pour but de collecter ou de présenter des données structurées et font l'interface avec un processus d'entreprise. Un formulaire est le document affiché par l'utilisateur final ou avec lequel il interagit.
Un formulaire est créé à partir d’une conception de formulaire élaborée à l’aide de LiveCycle Designer. La conception de formulaire est le terme qui décrit le formulaire pendant le processus de création ou de conception. La conception de formulaire précise les règles de disposition, de saisie de données et de présentation relatives au formulaire. Les règles s'appliquent chaque fois que des données sont saisies dans un formulaire. Le mode de saisie des données dans le formulaire dépend de l'utilisation prévue du formulaire, qui à son tour influence le type de formulaire que vous créez.
Voir aussi
Mode de capture ou de présentation des informations
Méthodes de création de conceptions de formulaire
Que contient une conception de formulaire ?


Mode de capture ou de présentation des informations

Un formulaire sert avant tout à capturer ou afficher des informations. Il existe trois façons de collecter et de présenter des données et autant de formulaires.
Formulaires interactifs
Les formulaires peuvent être conçus pour capturer directement les données des utilisateurs. Les utilisateurs renseignent le formulaire et sélectionnent des options en ligne, puis ils le renvoient en suivant une procédure prédéfinie. Ce type de formulaire est un formulaire interactif. Dans le scénario le plus simple, les utilisateurs requièrent uniquement Adobe Reader® pour compléter le formulaire et le renvoyer à son auteur sous forme électronique ou pour l'imprimer et envoyer une copie du formulaire à l'auteur. Si vous avez acheté LiveCycle Forms, le formulaire interactif peut être enregistré au format PDF ou HTML. Dans ce cas, les utilisateurs ouvrent et remplissent le formulaire à partir d'un navigateur Web.
Les formulaires interactifs peuvent comprendre des boutons de commande permettant aux utilisateurs d'enregistrer les données dans un fichier ou une base de données, ou de les envoyer par messagerie électronique à une adresse spécifique. En outre, vous pouvez ajouter des validations destinées à garantir la précision des données saisies par l'utilisateur.
Formulaires non interactifs
Les formulaires peuvent être conçus pour présenter des informations aux utilisateurs. Les données peuvent provenir d'une variété de sources de données, telles que des bases de données, services Web ou systèmes de gestion de contenu d'entreprise. L'utilisateur final se contente de consulter le formulaire pré-rempli. Il ne peut ni modifier les données du formulaire, ni ajouter des informations. Ce type de formulaire est considéré comme un formulaire non interactif. Un scénario type de ce formulaire intègre LiveCycle Forms dans la solution. LiveCycle Forms fusionne la conception du formulaire avec les données et présente le formulaire, préalablement complété, à l'utilisateur. Un exemple classique de formulaire non interactif est un relevé de carte de crédit ou une facture de téléphone.
Dans un autre scénario, un formulaire peut être conçu pour fournir des informations à l'utilisateur et lui donner la possibilité de spécifier d'autres informations et de les renvoyer à l'auteur ou au serveur pour être traitées.
Formulaires d'impression et de saisie
Le dernier type de formulaire correspond au formulaire d'impression et de saisie. L'auteur du formulaire crée la conception du formulaire dans LiveCycle Designer et l'enregistre généralement au format PDF. L'utilisateur final ouvre le formulaire dans Acrobat ou Adobe Reader, l'imprime et le complète manuellement. Le formulaire est ensuite renvoyé à son auteur par télécopie ou par courrier.
Voir aussi
Méthodes de création de conceptions de formulaire
A propos des modèles et du Gestionnaire de modèles
Que contient une conception de formulaire ?


Méthodes de création de conceptions de formulaire

Avant de vous lancer dans la conception d'un formulaire avec LiveCycle Designer, il est important de faire le point sur le mode d'utilisation envisagé, les informations qu'il permettra de capturer et, dans de nombreux cas, sur la disposition du formulaire.
Dans LiveCycle Designer, vous ajoutez des fonctionnalités à votre formulaire en incorporant, par exemple, un champ de saisie de texte ou un bouton pour l'envoi du formulaire par messagerie électronique. Les objets statiques ont pour intérêt de présenter du texte fixe ou des informations graphiques. Il s'agit des cercles, des lignes, des rectangles, des images et du texte.
Les formulaires les plus courants ont généralement une disposition fixe : ils comportent un nombre constant de pages et leur disposition reste la même, quelle que soit la quantité de données à insérer. C'est le cas des formulaires d'inscription à des cours que l'utilisateur imprime ou remplit à la main ou complète dans Acrobat ou Adobe Reader. Une fois renseigné, le formulaire conserve sa disposition d'origine et le même nombre de pages, quelle que soit la quantité de données disponibles pour le compléter. Les champs non remplis restent vides dans le formulaire. De même, si la quantité des données est supérieure à la capacité de contenance du formulaire, celui-ci n'est pas agrandi pour contenir le surplus de données. Si le formulaire d'inscription à un cours comporte, par exemple, 5 rangées dans lesquelles l'utilisateur final fait ses choix, alors qu'il y a suffisamment de données pour remplir 10 rangées, seules les 5 rangées sont complétées. De la même manière, si l'utilisateur choisit seulement 2 cours, 2 des 5 rangées sont remplies et les 3 autres sont vides.
Ce formulaire peut être interactif (l'utilisateur peut le renseigner dans Acrobat ou Adobe Reader) ou non interactif, auquel cas un processus de serveur fusionne le formulaire avec les données d'une source de données. LiveCycle Forms génère le plus souvent des formulaires non interactifs avec une disposition fixe dans le but de présenter des informations provenant d’une source de données.
Outre le fait de disposer de formulaires avec une disposition fixe, vous avez la possibilité de définir des sections qui auront la faculté de s'agrandir ou de se réduire en fonction de la quantité de données à fusionner dans le formulaire rendu. Pour ce faire, il est nécessaire d'agencer les différentes sections (groupes de sous-formulaires) dans les sous-formulaires qui enchaînent le contenu. Ensuite, lors de l'exécution, seuls les sous-formulaires nécessaires pour l'affichage de la quantité exacte de données sont appelés.
Ce type de formulaire possède une disposition souple avec un nombre variable de pages. Les sous-formulaires s'adaptent à la quantité de données fusionnées avec le formulaire lors de sa génération ou leur taille augmente lorsque les utilisateurs souhaitent ajouter des données. Vous pouvez, par exemple, décider de laisser aux utilisateurs le soin d'ajouter au formulaire le nombre de rangées voulu, de supprimer des rangées du formulaire ou de renvoyer les données du formulaire par voie électronique. Selon le nombre de rangées ajoutées, le formulaire peut se prolonger sur plusieurs pages.
Les formulaires interactifs à disposition souple sont parfois appelés des formulaires côté client. Acrobat et Adobe Reader 7.0 et les versions ultérieures prennent en charge ce type de formulaire interactif.
LiveCycle Designer permet également de créer des formulaires avec une disposition souple pour LiveCycle Forms. Dans ce scénario, la conception de formulaire est fusionnée avec les données de LiveCycle Forms. Les relevés de carte de crédit ou les factures de téléphone sont des exemples classiques de formulaires non interactifs conçus pour fournir aux utilisateurs des informations d'une source de données. Les utilisateurs peuvent imprimer ces formulaires ou les enregistrer au format électronique. Ces formulaires sont parfois considérés comme des formulaires côté serveur, car la fusion de la conception du formulaire et des données a lieu sur le serveur.
Voir aussi
A propos des formulaires et des conceptions de formulaire
A propos de la création de conceptions de formulaire prévues pour s'adapter aux données
A propos de la création de formulaires interactifs prévus pour s'adapter aux données
Que contient une conception de formulaire ?


Qui crée les formulaires ?

Dans certaines entreprises, une personne est chargée de créer les conceptions de formulaire tandis qu'une autre prépare les fonctions intelligentes pouvant être intégrées au formulaire. Vous devez identifier les personnes qui travailleront à la création du formulaire et à sa mise en oeuvre.
Demandez-vous si des analystes doivent participer à la procédure. Identifiez aussi les développeurs de formulaires et les experts en gestion de données qui devront rédiger des scripts et offrir un support technique pour mettre en oeuvre le formulaire.
Si vous êtes l’auteur des formulaires, vous devez travailler en étroite collaboration avec le développeur et d'autres spécialistes afin de vous assurer que vos formulaires fonctionnent comme prévu lors de leur distribution.
Les auteurs de formulaires sont généralement chargés des tâches suivantes :
      •
      Sélection des formats de fichiers ou des conversions LiveCycle Forms à utiliser en fonction des différentes applications client dont les utilisateurs sont susceptibles de se servir pour visualiser les formulaires (par exemple, Acrobat, Adobe Reader, un navigateur Web ou un lecteur d'écran)
      •
      Création d'une disposition adaptée à une conception de formulaire
      •
      Mise à disposition des formulaires sur les serveurs appropriés ou directement, par messagerie électronique, aux personnes devant les remplir
Les développeurs de formulaires sont généralement chargés des tâches suivantes :
      •
      Etablissement des connexions et préparation des données test pour les auteurs de formulaires si des données sont à fusionner dans les formulaires
      •
      Rédaction de scripts à joindre aux objets
Voir aussi
Définition de normes de conception communes


Composants d’une conception de formulaire

Que contient une conception de formulaire ?
Gabarit
Pages
Zones de contenu
Sous-formulaires
Tableaux
Objets de champ
Objets standard


Que contient une conception de formulaire ?

Vous créez une conception de formulaire en faisant glisser des objets de la palette Bibliothèque sur une ou plusieurs pages de l'éditeur de disposition et en travaillant ensuite dans la palette Objet pour modifier les propriétés de l'objet sélectionné. L'objet sélectionné détermine les onglets disponibles dans la palette Objet. Il existe bien d'autres palettes contenant des propriétés particulières que vous pouvez modifier. Par exemple, la palette Police permet de modifier la famille de polices, la taille et le style du texte de l'objet sélectionné.
Vous placez les objets de votre choix dans les pages de la conception de formulaire. Si vous souhaitez qu'un objet apparaisse sur toute les pages de la conception de formulaire, placez-le sur un gabarit. Par exemple, vous pouvez incorporer un logo, un filigrane ou des informations de présentation qui apparaîtront toujours au même emplacement sur toutes les pages de la conception de formulaire.
Une conception de formulaire se compose des éléments essentiels suivants :
      •
      Gabarit
      •
      Pages
      •
      Zones de contenu
      •
      Sous-formulaires
      •
      Champs
      •
      Objets standard
Ces éléments sont affichés dans la palette Hiérarchie de LiveCycle Designer.
LiveCycle Designer génère automatiquement du code source XML pour chaque objet à mesure que vous élaborez la conception de formulaire. Comme LiveCycle Designer génère automatiquement le code source XML, vous pouvez élaborer des conceptions de formulaire sans avoir aucune connaissance du langage XML.
Voir aussi
A propos des formulaires et des conceptions de formulaire
Gabarit
Pages
Zones de contenu
Sous-formulaires
Tableaux
Objets de champ
Objets standard


Gabarit

Chaque conception de formulaire contient au moins un gabarit créé automatiquement par LiveCycle Designer. Le principal intérêt d'un gabarit est de formater les pages et de maintenir l'homogénéité de la conception, en fournissant par exemple un format d'arrière-plan et de disposition pour plusieurs pages d'une conception de formulaire.
Le cas échéant, vous pouvez utiliser le gabarit fourni pour formater les pages, modifier les paramètres de gabarit ou ajouter des gabarits supplémentaires. Pour créer un formulaire interactif simple, vous utiliserez probablement le gabarit proposé sans modifier ses paramètres.
Enfin, les gabarits définissent l'orientation et les dimensions des pages. Vous pouvez utiliser des gabarits pour définir les aspects suivants d'une conception de formulaire :
      •
      Format et orientation des pages
      •
      En-têtes et pieds de page
      •
      Filigranes et logos d'entreprise
Chaque gabarit est créé avec une zone de contenu par défaut qui couvre toute la page. Vous pouvez ajouter des textes statiques, des images et d'autres objets standard à un gabarit. Ces objets apparaissent sur toutes les pages auxquelles le gabarit est appliqué.
les champs de texte, numériques et d'heure/date des gabarits ne sont pas interactifs sur les formulaires compatibles avec Acrobat 6. Par conséquent, les utilisateurs ne peuvent pas modifier les données insérées dans ces champs.
Les gabarits peuvent être manipulés à partir du panneau Gabarit.
Voir aussi
A propos des formulaires et des conceptions de formulaire
A propos des gabarits
Zones de contenu


Pages

Il s'agit des pages du formulaire. Pour chaque page, le format et l'orientation sont déterminées par le gabarit et, par défaut, chaque page est associée au gabarit par défaut créée par LiveCycle Designer. Chaque page est créée avec un sous-formulaire par défaut qui couvre toute la page.
Si votre conception de formulaire contient plusieurs gabarits et pages, vous pouvez choisir le gabarit à appliquer à une page.
Vous manipulez les pages à partir du panneau Vue de conception.
Voir aussi
A propos des formulaires et des conceptions de formulaire
A propos des pages
Sous-formulaires


Zones de contenu

Les zones de contenu définissent les emplacements possibles des objets sur les pages. Lorsque vous concevez un formulaire, vous ne pouvez pas placer d'objet sur une page à moins qu'il ne se trouve à l’intérieur d’une zone délimitée par une zone de contenu. Vous ne pouvez ajouter des zones de contenu qu'aux gabarits.
Lorsque vous définissez un nouveau gabarit, LiveCycle Designer crée une zone de contenu par défaut sur le gabarit.
Une conception de formulaire avec une disposition fixe comporte, en principe, une zone de contenu. Une conception de formulaire comprenant des sections qui s'ajustent à la taille des données peut comporter une ou plusieurs zones de contenu. Vous pouvez spécifier si les objets de chaque zone de contenu doivent être intégrés de haut en bas ou de gauche à droite et de haut en bas.
Voir aussi
Aperçu des zones de contenu


Sous-formulaires

Les sous-formulaires sont des objets conteneur pouvant être utilisés pour regrouper des objets de conception de formulaire, tels que des champs, des objets standard et d'autres sous-formulaires. Après avoir effectué le regroupement, vous pouvez vérifier si le sous-formulaire et les objets regroupés apparaissent dans le formulaire en fonction des liaisons de données configurées dans le formulaire. Il est possible également de configurer des objets de sous-formulaire pour qu'ils se répètent. Vous pouvez ainsi avoir plusieurs instances d'un seul sous-formulaire dont les objets regroupés apparaissent sur le formulaire. Cela permet de créer des conceptions de formulaire plus souples et plus adaptables.
Les sous-formulaires sont essentiels lors de la création de formulaires avec des sections prévues pour s'ajuster à la taille des données. En effet, ils permettent aux fonctions dynamiques d'être visibles, de rester cachées et d'augmenter, en fonction des données et des actions de l'utilisateur lors de l'exécution.
Voir aussi
Aperçu des zones de contenu


Tableaux

Les tableaux sont des objets conteneur structurés par nature, permettant d'organiser le contenu de la conception de formulaire de manière logique et significative. Chaque cellule d'un tableau est un conteneur distinct, capable de stocker des objets de la conception de formulaire.
Les tableaux ressemblent beaucoup aux sous-formulaires en termes de fonctionnalité et de comportement. Comme les sous-formulaires, les tableaux ont la faculté d'être dynamiques. Ils peuvent ainsi se répéter et s'agrandir en fonction des données et des actions de l'utilisateur lors de l'exécution.
Voir aussi
A propos des tableaux
Sous-formulaires


Objets de champ

LiveCycle Designer fournit de nombreux objets de champ capables de capturer, de fusionner et d'afficher des données. Un objet de champ constitue une région de saisie de données et les utilisateurs peuvent interagir avec les objets de champ en tapant ou en sélectionnant une valeur.
Les objets suivants sont des objets de champ :
      •
      Bouton
      •
      Case à cocher
      •
      Champ Date/Heure
      •
      Champ décimal
      •
      Champ de signature du document
      •
      Liste déroulante
      •
      Bouton Envoyer par messagerie
      •
      Bouton Envoyer via HTTP
      •
      Champ d'image
      •
      Zone de liste
      •
      Champ numérique
      •
      Code à barres de formulaires pour support papier
      •
      Champ Mot de passe
      •
      Bouton Imprimer
      •
      Bouton radio
      •
      Champ de texte
Voir aussi
Qu'est-ce-qu'un objet ?
Objets standard


Objets standard

Les objets standard sont des objets en lecture seule qui améliorent l'aspect esthétique d’un formulaire et peuvent offrir un contexte ou des informations pratiques aux utilisateurs. Ils peuvent être insérés dans les pages et dans les gabarits.
Les objets suivants sont des objets standard :
      •
      Cercle
      •
      Image
      •
      Droite
      •
      Rectangle
      •
      Texte
Voir aussi
Qu'est-ce-qu'un objet ?
Objets de champ


Formulaires interactifs

A propos des formulaires interactifs
Avantages des formulaires interactifs
Utilisation des objets d'un formulaire interactif
A propos des calculs et des scripts dans les formulaires interactifs
Différences entre le remplissage de formulaires dans Acrobat et Adobe Reader


A propos des formulaires interactifs

Un formulaire interactif est un formulaire électronique qu'un utilisateur ouvre et remplit en ligne. Vous pouvez concevoir des formulaires interactifs à remplir dans Acrobat Professional, Acrobat Standard ou Adobe Reader, ou des formulaires pour LiveCycle Forms que l'utilisateur doit remplir à partir d'un navigateur Web.
L'utilisateur introduit les données directement dans les champs du formulaire en ligne. Le formulaire peut analyser les données saisies et fournir des renseignements sous forme de messages instantanés pour certains types de données. En outre, il peut intégrer des fonctions intelligentes qui envoient les données saisies directement à un système d'entrée de données spécifique d'entreprise, notamment une base de données.
Les formulaires interactifs comprennent généralement des fonctions d'entrée de données comme des listes d'éléments, des listes déroulantes, des cases à cocher, des calculs automatiques, des messages de validation, des signatures numériques, ainsi que des boutons Envoyer et Exécuter. Les concepteurs de formulaires peuvent utiliser des fonctions FormCalc intégrées et des scripts personnalisés en langage JavaScript pour étendre les fonctionnalités des champs interactifs.
Si vous concevez des formulaires interactifs pour LiveCycle Forms, reportez-vous également à la rubrique d'aide A propos de la conception de formulaires pour LiveCycle Forms. Il existe cinq différences de conception et fonctionnalités améliorées que vous pouvez appliquer aux formulaires déployés dans LiveCycle Forms.
Voir aussi
A propos des formulaires et des conceptions de formulaire
A propos de la conception de formulaires pour LiveCycle Forms
A propos des sources de données
Procédure générale de conception d'un formulaire
Pour créer un objet personnalisé
A propos de l'aperçu et des tests de formulaires


Avantages des formulaires interactifs

Bien que les formulaires interactifs ressemblent aux formulaires papier traditionnels, ils éliminent les tâches fastidieuses et chronophages associées au traitement des formulaires papier. L'utilisation de formulaires interactifs en guise de solutions commerciales est le choix tout indiqué pour les entreprises fondées sur Internet et entièrement informatisées.
Vous pouvez offrir des formulaires interactifs par le biais d'Internet, d'un intranet ou du courrier électronique. Vous pouvez automatiser le processus d'échange de documents et stocker des formulaires dans un format fiable tout en protégeant le contenu et l'intégrité des documents.
Les formulaires interactifs vous permettent de simplifier votre processus de collecte de données. Un formulaire interactif peut recueillir les données et les intégrer à vos systèmes de collecte de données de base existants, augmentant par le fait même leur valeur. Le formulaire peut intégrer directement les données à votre système de collecte ou utiliser un programme sur le serveur, comme un script CGI, une page ASP, une page JSP ou un servlet.
Au moyen de formulaires interactifs, vous pouvez également établir des processus de flux de tâches fondés sur des formulaires en ligne en utilisant une logique intégrée pour acheminer le formulaire par voie électronique d'un utilisateur à l'autre. Les formulaires électroniques sont compatibles avec les technologies d'aide, notamment les lecteurs d'écran, de façon à les rendre accessibles aux utilisateurs ayant des déficiences.
Voir aussi
A propos des formulaires et des conceptions de formulaire


Utilisation des objets d'un formulaire interactif

LiveCycle Designer comprend plusieurs objets standard ou personnalisés qui assurent des fonctions de saisie de données et d'accessibilité. Ils prennent aussi en charge les calculs et les scripts pour lancer des actions, ainsi que la saisie de données et leur manipulation. Vous pouvez utiliser n'importe lequel de ces objets sur un formulaire, y compris les objets tels que les champs de texte et les objets de dessin.
De plus, vous pouvez créer des objets personnalisés auxquels sont attribuées les propriétés et caractéristiques souvent utilisées dans vos formulaires. Pour créer des objets personnalisés, vous devez définir les propriétés des objets LiveCycle Designer standard et leur ajouter la fonctionnalité voulue sous la forme d'un script ou d'une fonction de calcul. Vous enregistrez les objets personnalisés dans la palette Bibliothèque, en utilisant la catégorie Personnalisés ou une catégorie que vous avez créée.
Avant de choisir des objets, vous devez en connaître les fonctions. Tenez compte des points suivants :
      •
      Déterminez le type d'information que doit contenir le formulaire et familiarisez-vous avec les caractéristiques des objets.
      •
      N'oubliez pas que les champs ont différentes exigences et options quant à leur longueur et à leur format, ainsi que des restrictions et exigences quant à la saisie de données.
      •
      Analysez les types de données qui seront affichés et capturés, et déterminez les objets qui les prennent en charge.
      •
      Certains objets permettent d'ajouter des calculs et de rédiger des scripts pour lancer des actions à partir du champ. Il vous faut déterminer les types de scripts que vous pouvez utiliser avec certains objets.
Voir aussi
Qu'est-ce-qu'un objet ?
Pour créer un objet personnalisé


A propos des calculs et des scripts dans les formulaires interactifs

Vous pouvez utiliser le langage de calculs intégré FormCalc ou le langage JavaScript pour rédiger des scripts personnalisés qui calculent et valident des données, ou qui lancent des commandes et des actions dans le cas où un événement spécifique se produit sur un champ. Pour lancer l'exécution d'un script, il suffit que l'utilisateur remplisse le formulaire et déclenche un événement particulier (comme le fait de cliquer sur un bouton).
LiveCycle Designer prend en charge une multitude d'options de calculs généralement utilisées dans les formulaires interactifs. Les fonctions intégrées FormCalc comprennent les fonctions mathématiques, les dates et heures, les chaînes, ainsi que les fonctions financières et logiques. Vous pouvez également rédiger des scripts personnalisés qui exécutent au besoin des calculs.
Vous pouvez utiliser une fonction de calcul ou un script dans les cas suivants :
      •
      Ajout d’un script à une liste déroulante pour remplir un autre champ selon le choix de l’utilisateur dans cette liste.
      •
      Association d'un script de calcul à un champ numérique pour calculer un total ou une augmentation ou diminution en pourcentage d'une colonne formée de champs et afficher le résultat dans le champ Total.
      •
      Création d'un script pour lancer une requête ou une consultation de base de données, soit pour remplir une liste déroulante, soit pour en afficher les descriptions des articles.
Lorsque vous voulez associer un script à un objet, vous devez spécifier son événement déclencheur. Il peut s'agir d'un événement Change, notamment lorsque l'utilisateur sélectionne un nouvel élément dans une zone de liste ou une liste déroulante. Un événement Click, quant à lui, peut déclencher un script lorsqu'un utilisateur clique sur un objet.
Pour plus de détails sur la création de calculs et de scripts, voir A propos des calculs et des scripts.
Voir aussi
Pour insérer un bouton standard afin d'exécuter un calcul ou un script
Pour associer un script de base de données à un bouton
Utilisation d'un bouton pour remplir les champs à partir d'une base de données


Différences entre le remplissage de formulaires dans Acrobat et Adobe Reader

Les concepteurs de formulaires doivent tenir compte des observations suivantes lorsqu’ils créent des formulaires interactifs :
      •
      Les utilisateurs peuvent remplir des formulaires PDF par l'intermédiaire d'Acrobat ou Adobe Reader.
      •
      Tenez compte des versions d’Acrobat et d'Adobe Reader utilisées par les personnes qui remplissent le formulaire : Les formulaires PDF enregistrés pour Acrobat 7.0 doivent être ouverts à l'aide d'Acrobat ou Adobe Reader 7.0 (ou version ultérieure). Les formulaires PDF enregistrés pour Acrobat 6.0 doivent être ouverts à l'aide d'Acrobat ou Adobe Reader 6.0.2 (ou version ultérieure).
      •
      Le tableau suivant répertorie les fonctions disponibles de LiveCycle Designer 7.1 dans les formulaires PDF enregistrés au format PDF compatible avec Acrobat 6.0, PDF statique et PDF dynamique dans LiveCycle Designer 7.1.

Fonction de LiveCycle Designer 7.1

Disponible dans un formulaire PDF compatible Acrobat 6.0

Disponible dans un formulaire PDF statique

Disponible dans un formulaire PDF dynamique
Code à barres de formulaires pour support papier*
N
O
O
Codes à barres interactifs
N
O
O
Images interactives
N
N
O
Formulaires avec une disposition souple
N
N
O
Formulaires accessibles
O
O
O
Prise en charge des images EXIF
O**
O
O
Visibilité des boutons à l'impression
N
O
O
Points dans les noms d'élément
N
O
O
Prise en charge <xs:import>
O
O
O
* Les symbologies Code QR et Grille de données requièrent Acrobat ou Adobe Reader 7.0.5 pour le remplissage. Si vous utilisez un code à barres de formulaires pour support papier avec la symbologie Code ou Grille de données, enregistrez le formulaire sous Acrobat 7.0.5.
** Le format EXIF est pris en charge dans Acrobat 7.0 ; cependant, les images sont au format JPEG dans Acrobat 6.0.2.
      •
      Si la conception de formulaire inclut des scripts qui modifient l'aspect des objets inclus dans le formulaire PDF à l'exécution, enregistrez-le en tant que formulaire PDF dynamique.
      •
      Acrobat prend en charge une multitude de fonctionnalités interactives, y compris le remplissage de formulaire, l'enregistrement local, les signatures numériques, la vérification et les étiquettes, les bases de données et les opérations de services Web, ainsi que l'impression. Le tableau suivant indique si les objets conservent leur interactivité en fonction du type de PDF enregistré.

Fonction

Acrobat 6.0.2

Formulaire PDF statique

Formulaire PDF dynamique
Objets de champ et de bouton sur un gabarit
N
O
O
Objets de champ et de bouton dans des sous-formulaire de début/fin de débordement
N
O
O
Champs extensibles
N
O
O
Champs flottants
N
N
N
Champs pour lesquels l’événement ready::$layout est spécifié
N
O
O
Possibilité de modifier la disposition du formulaire
N
N
O
      •
      Adobe Reader prend en charge un nombre inférieur de fonctionnalités et permet aux utilisateurs de remplir et d'imprimer des formulaires et, dans certains cas, de les envoyer. Pour étendre les fonctionnalités d'Adobe Reader par rapport à celles d'Acrobat, vous devez configurer les droits d'utilisation pour le formulaire à l'aide de LiveCycle Reader Extensions. Pour plus de détails, voir A propos des options de protection PDF.
      •
      Acrobat et Adobe Reader prennent en charge le traitement d'échange de données côté client pour les formulaires PDF interactifs.
      •
      LiveCycle Forms assure le traitement de données côté serveur, notamment le rendu et le réaffichage dynamiques des formulaires au moment de l'exécution.
Voir aussi
Pour enregistrer votre conception de formulaire


Planification des conceptions de formulaire

Définition des besoins de l'entreprise en matière de formulaires
Définition des besoins des utilisateurs
Choix des objets les mieux adaptés au formulaire
Définition de normes de conception communes
Observations relatives au côté pratique du formulaire
Procédure générale de conception d'un formulaire
Liste de vérification de la conception de formulaire


Définition des besoins de l'entreprise en matière de formulaires

Vous devez identifier les besoins fonctionnels auxquels doit répondre le formulaire. Pour ce faire, il suffit parfois d'obtenir une directive de vos supérieurs, mais il arrive également qu'il soit nécessaire d'effectuer des recherches pour identifier la conception qui convient le mieux. Au moment de déterminer les objectifs que doit atteindre le formulaire, tenez compte des points suivants :
      •
      Le rôle que devra jouer le formulaire au sein d’une solution de gestion globale.
      •
      Disposez-vous d’un schéma ou d'exemples de données pour modéliser le formulaire ?
      •
      Les conditions de saisie des données. Quelles sont les données que vous comptez collecter ou distribuer et comment les recueillir et les traiter ? Les utilisateurs saisiront-ils manuellement toutes les données ou certaines d'entre elles seront-elles fusionnées ? Si les données sont destinées à être collectées auprès des utilisateurs, seront-elles enregistrées localement à l’aide d'Acrobat ou d'Adobe Reader, ou soumises à LiveCycle Forms ?
      •
      Calculs ou scripts à associer aux données et emplacement où ils seront exécutés (client, serveur, ou client et serveur). Un script ne s’exécute que sur un serveur si vous déployez les formulaires via LiveCycle Forms.
      •
      La complexité du formulaire. Il doit être simple et ne contenir aucune dépendance ou, au contraire, être plus complexe et intégrer des dépendances, par exemple.
      •
      La distribution du formulaire comme partie intégrante d'un processus de gestion et le nombre de personnes qui participeront à sa conception.
      •
      Conditions de sécurité. Les utilisateurs auront-ils besoin d'un mot de passe pour ouvrir, imprimer, copier du texte ou appliquer des signatures, etc. ?
      •
      Les besoins en traduction.
Voir aussi
Choix des objets les mieux adaptés au formulaire
A propos des formulaires sécurisés
Aperçu des champs de signature de document
Aperçu des champs de mot de passe


Définition des besoins des utilisateurs

Votre premier objectif de conception devrait être de répondre aux besoins des personnes qui se serviront de vos formulaires. Vous devez tenir compte des exigences professionnelles des utilisateurs et établir une série de buts à atteindre. De cette manière, vous définirez vos formulaires en conséquence et éviterez d'insérer des éléments superflus qui ne correspondent pas au but du formulaire. Plus vos objectifs sont clairs, plus la conception de votre formulaire sera satisfaisante. Ne perdez jamais de vue la fonction principale du formulaire par rapport aux besoins des utilisateurs :
      •
      En quoi le formulaire sera-t-il utile aux personnes qui le rempliront et pourquoi ?
      •
      Le formulaire servira-t-il à collecter des informations auprès des utilisateurs, à fournir des informations aux utilisateurs, ou les deux ?
      •
      Les utilisateurs auront-ils besoin d'instructions concernant une procédure et, si tel est le cas, les informations seront-elles contenues dans le formulaire proprement dit ou dans un document annexe ?
      •
      Les utilisateurs souhaiteront-ils lire le formulaire d'une page à l'autre ? Dans le cas contraire, comment s'attendent-ils à parcourir ou à explorer le formulaire ?
      •
      Les utilisateurs interagiront-ils avec le formulaire (par exemple, en parcourant une sélection d'éléments par nom ou par prix, en choisissant des options, en commandant des articles spécifiques ou en saisissant des données) ?
En règle générale, les utilisateurs exploitent les formulaires des manières suivantes :
      •
      Ils ouvrent un formulaire vierge en ligne, l'impriment et le remplissent à la main.
      •
      Ils ouvrent un formulaire vierge en ligne, le remplissent hors connexion ou non et soumettent les informations en ligne.
      •
      Ils affichent un formulaire électronique qui contient des données fusionnées (la fusion est effectuée par une application ou en ligne par un tiers) et en impriment un exemplaire.
      •
      Ils affichent un formulaire électronique qui contient des données fusionnées, modifient au besoin les informations et les soumettent en ligne.
      •
      Ils remplissent partiellement un formulaire en ligne et le soumettent à un cycle de production automatisé ou à un autre utilisateur à des fins de traitement ultérieur.
Voir aussi
Définition des besoins de l'entreprise en matière de formulaires
Choix des objets les mieux adaptés au formulaire
Observations relatives au côté pratique du formulaire
A propos des formulaires accessibles


Choix des objets les mieux adaptés au formulaire

Afin de choisir les objets qui répondront le mieux à vos besoins, tenez compte des points suivants :
      •
      Le formulaire doit-il être interactif ou non ?
      •
      C'est le type d'information et de données à inclure dans le formulaire qui dicte le choix des objets requis pour la saisie et l'affichage des données.
      •
      La cohérence de la disposition et des mécanismes fonctionnels de la conception facilite l'utilisation du formulaire.
      •
      La définition des objectifs de disposition et la planification de la structure générale du document (pages, sections et sous-sections) facilitent l'organisation des informations associées et permet de déterminer le nombre de gabarits et de pages nécessaires.
      •
      Dans le cas d'un formulaire contenant des sous-formulaires prévus pour s'adapter aux données, pour combiner différents types de structures de données ou présenter un contenu considérable de manière sophistiquée, dressez un plan spécifique de l'ordre dans lequel les zones de contenu et les sous-formulaires doivent être intégrés.
Voir aussi
Qu'est-ce-qu'un objet ?
Définition des besoins des utilisateurs
Définition de normes de conception communes
Observations relatives au côté pratique du formulaire


Définition de normes de conception communes

Définissez des normes de conception à respecter au sein de votre équipe afin de garantir une cohérence entre vous :
      •
      Configurez les options courantes de LiveCycle Designer et les propriétés des formulaires.
      •
      Choisissez la langue adaptée aux formulaires.
      •
      Définissez le mode de configuration des lignes guides, des grilles et des intervalles de règles.
      •
      Déterminez comment et quand vous utiliserez les marges, les bordures, les polices, l'alignement du texte et les légendes.
      •
      Choisissez les objets que vous utiliserez, à quel moment et à quel endroit.
      •
      Envisagez la création d'objets communs que pourront partager les concepteurs (en-têtes, blocs d'adresse, pieds de page, etc.).
      •
      Elaborez une bibliothèque d'objets personnalisés comme des logos, des images ou des filigranes, afin de maintenir la cohérence et augmenter la productivité.
      •
      Recherchez les éléments communs aux différentes sections du formulaire, notamment lorsque le formulaire compte plus d'une page. De cette manière, vous avez la possibilité d'utiliser la commande Multiplier afin d'accroître la productivité, de déterminer clairement les objets personnalisés à ajouter à la bibliothèque d'objets en vue d'une utilisation répétée et de calculer le nombre exact de gabarits dont vous aurez besoin.
      •
      Choisissez le langage de programmation par script à utiliser : FormCalc ou JavaScript.
      •
      Examinez les options de protection à appliquer au formulaire.
      •
      Le cas échéant, établissez des normes d'accessibilité.
Voir aussi
A propos de l'espace de travail
Pour créer un objet personnalisé


Observations relatives au côté pratique du formulaire

Pensez à la facilité d’utilisation d'un formulaire lors de la phase de planification. Voici quelques points à prendre en considération :
      •
      Le formulaire doit présenter une structure logique, une disposition simple et nette, et des légendes significatives facilitant la compréhension du formulaire. Essayez d'imaginer comment séparer et regrouper les informations disparates et connexes. Vérifiez la taille des sections et efforcez-vous de définir des sections ni trop longues ni trop courtes.
      •
      Un formulaire doit être facile à parcourir. LiveCycle Designer permet de choisir l'ordre de tabulation entre les objets. Pensez à la meilleure manière de passer d'une section à l'autre et déterminez s'il vous faut plusieurs pages ou plus d'un formulaire. La présentation des données peut être hiérarchique ou linéaire (séquentielle). Vous pouvez également proposer des alternatives à partir d'un point central.
      •
      Un formulaire doit être simple d'emploi. Une disposition simple, avec des légendes claires et éloquentes, facilite la compréhension du formulaire. Des formulaires peuvent valider les entrées utilisateur et proposer des messages destinés à aider les utilisateurs lors de la saisie des données. Si LiveCycle Forms est disponible, certaines zones peuvent être pré-remplies par fusion de données. En outre, des scripts joints aux objets permettent de calculer automatiquement des valeurs numériques au moment de l'exécution. Si vous êtes un adepte de la programmation par script, vous pouvez également développer des scripts pour automatiser le traitement ou l'acheminement des données et des formulaires à partir de boutons de commande.
      •
      Un formulaire doit être accessible aux utilisateurs souffrant de déficiences.
Voir aussi
A propos des formulaires accessibles
A propos de l'ordre de tabulation


Procédure générale de conception d'un formulaire

La création de formulaires exige une approche pas à pas de la planification des besoins, du contenu, de la conception et de la disposition de la conception de formulaire tout en gardant à l'esprit les conditions et facteurs propres au type de formulaire que vous créez. Lors de l'élaboration d'un formulaire, suivez les étapes générales décrites ci-après.
1.
Décidez de ce que vous souhaitez accomplir avec le formulaire et rassemblez les informations et outils dont vous aurez besoin.
2.
Ouvrez un ou plusieurs exemples de formulaires ou modèles fournis pour vous familiariser avec LiveCycle Designer et les objets disponibles.
3.
Choisissez l'une des méthodes suivantes :
      •
      Si l'un des exemples ou des modèles est adapté à vos besoins, utilisez-le comme point de départ.
      •
      Créez une conception de formulaire de A à Z.
4.
Si nécessaire, ajustez le format et l'orientation du papier et configurez les espaces blancs, les en-têtes et les pieds de page, ainsi que les objets standard sur les gabarits.
5.
Effectuez la mise en page.
6.
Créez les calculs ou les scripts appropriés et joignez-les aux objets.
7.
Assurez-vous que votre formulaire est prêt.
8.
Testez le formulaire localement.
Acrobat et Adobe Reader prennent en charge diverses fonctions. Si votre environnement utilisateur comprend les deux applications, il est recommandé de tester tous les formulaires dans les deux applications.
9.
Si vous travaillez sur une solution d'entreprise, soumettez vos fichiers de conception de formulaire au serveur et testez-les comme si vous deviez remplir le formulaire.
10.
Revoyez l'ensemble de la solution.
Voir aussi
Méthodes de création de conceptions de formulaire
Qui crée les formulaires ?
Liste de vérification de la conception de formulaire


Liste de vérification de la conception de formulaire

Vous pouvez utiliser une liste de vérification pour consigner certains points tels que des détails spécifiques au projet, des préférences utilisateur et des règles générales de conception d'éléments compatibles dans des formulaires multipage. Une liste de vérification peut également vous aider à respecter la ligne arrêtée et à livrer la solution dans les délais prescrits. Par exemple, vous pouvez créer une liste de vérification semblable à l'exemple suivant afin de tenir compte des spécifications relatives à votre organisation.

Elément

Spécifications
Format et orientation des pages
(pour le gabarit)
Format de page (Lettre, par exemple)
Orientation (Portrait, par exemple)
Logos et images
Format de fichier requis (TIF, par exemple)
Propriétés du formulaire
Enregistrer le titre du formulaire avec les propriétés de formulaire (Oui ou Non)
Paramètre régional par défaut (langue du système de visualisation, par exemple)
Langage de script par défaut (JavaScript, par exemple)
Accessibilité
Info-bulles requises pour les objets (indiquez les objets nécessitant des info-bulles)
Ordre de priorité du lecteur d’écran (info-bulle, par exemple)
Ordre de tabulation
Paramètre (Occidental, par exemple)
Polices et propriétés de dessin communes
Epaisseur de trait (même épaisseur pour toutes les lignes, par exemple)
Toutes les légendes (même police et même taille)
Toutes les valeurs de données (même police et même taille)
Propriétés d'objet
Bordures des champs et couleur d'arrière-plan (Oui ou Non)
Couleur d'arrière-plan des zones remplissables (valeur RVB, par exemple)
Noms des champs (voir la liste Nom de champ, par exemple)
Intelligence du formulaire
Les champs à remplir obligatoirement (identifiez-les)
Invitation à spécifier les champs requis (indiquez les messages obligatoires)
Voir aussi
Procédure générale de conception d'un formulaire


Didacticiels de mise en route

Didacticiels de mise en route

A propos des didacticiels de mise en route
Création d’un formulaire d’enquête d'entreprise
Création d'un formulaire de bon de commande
Création d'un bon de commande dont les sections s'adaptent à la taille des données


A propos des didacticiels de mise en route

Cette section présente les didacticiels conçus pour vous aider à faire vos premiers pas avec LiveCycle Designer.
Création d’un formulaire d’enquête d'entreprise
Ce didacticiel montre comment procéder pour créer un formulaire d'enquête sur la sortie annuelle de l’entreprise comprenant un bouton d’envoi par messagerie. Il suffit à l'utilisateur de cliquer sur ce bouton pour vous renvoyer les informations complétées par courrier électronique.
Création d'un formulaire de bon de commande
Ce didacticiel décrit la procédure de création d'un formulaire de bon de commande interactif comprenant un bouton d’impression. L'utilisateur n'aura plus qu'à cliquer sur ce bouton pour imprimer le formulaire. Il vous renverra ensuite l'exemplaire imprimé du formulaire. Vous apprendrez à ajouter des objets et à incorporer des opérations mathématiques simples dans les formulaires.
Création d'un bon de commande avec des sous-formulaires prévus pour s'adapter à la taille des données
Ce didacticiel explique comment passer d'une disposition fixe à une présentation qui évolue en fonction du volume de données, en utilisant des sous-formulaires afin d'afficher tous les articles commandés par un de vos clients. Vous aurez également l'occasion d'apprendre à fusionner un formulaire avec des données.
Cliquez sur ce lien pour continuer :
Création d’un formulaire d’enquête d'entreprise
Création d'un formulaire de bon de commande
Création d'un bon de commande dont les sections s'adaptent à la taille des données


Création d’un formulaire d’enquête d'entreprise

Création d’un formulaire d’enquête d'entreprise
Conception de formulaire à l’aide de l’assistant de création de formulaires
Placement du bouton Envoyer par messagerie
Ajout du titre Enquête sur le pique-nique d'entreprise
Ajout d'un objet de champ de texte pour le nom
Ajout d'un objet de liste déroulante pour le nombre de participants
Ajout d’un objet de texte pour les instructions
Ajout d'un objet de bouton radio pour les choix de dates
Ajout d'un objet de case à cocher pour les activités préférées
Enregistrement de votre conception de formulaire
Aperçu de votre travail
Finition de la conception du formulaire
Collecte des données dans une feuille de calcul
En quoi consiste l’étape suivante ?


Création d’un formulaire d’enquête d'entreprise

Vous revoilà à ce moment précis de l’année : outre toutes les autres tâches qui remplissent votre journée de travail, vous devez reprendre l’enquête de l’an dernier et sonder vos collègues à propos de la sortie annuelle de l’entreprise. Une fois de plus, il vous incombe de mettre à jour et de distribuer le questionnaire, de collecter les exemplaires remplis et imprimés, d’envoyer d’innombrables rappels de commentaires et, enfin, de compiler et de saisir manuellement les réponses dans une feuille de calcul.
Ne serait-il pas formidable de créer une copie électronique de l’enquête que vous pourriez ensuite distribuer à vos collègues ? Chacun d’entre eux pourrait ensuite directement remplir le questionnaire et vous renvoyer les informations par messagerie électronique en cliquant simplement sur un bouton inclus dans le formulaire. Grâce au présent didacticiel, c’est ce que vous allez faire.
Ce didacticiel vous guide dans la procédure de création d’une enquête sur la sortie annuelle de l’entreprise comprenant un bouton d’envoi par messagerie qui, lorsque l’utilisateur clique dessus après avoir rempli le formulaire, vous transmet les informations recueillies.
Après avoir suivi ce didacticiel dans son intégralité, vous obtiendrez un formulaire similaire au suivant :
Grâce à LiveCycle Designer, vous allez élaborer une conception de formulaire. Vous y définirez la disposition et les règles de saisie des données du formulaire final. Ceci fait, vous enregistrerez la conception de formulaire au format PDF. Il s’agira du formulaire à distribuer aux personnes qui le rempliront.
Cliquez sur ce lien pour continuer : Conception de formulaire à l’aide de l’assistant de création de formulaires


Conception de formulaire à l’aide de l’assistant de création de formulaires

LiveCycle Designer offre plusieurs méthodes pour commencer une conception de formulaire. Pour les besoins de ce didacticiel, nous utiliserons l’assistant de création de formulaires afin de créer un questionnaire sur la sortie annuelle de l’entreprise. L’assistant de création de formulaires enlève toute approximation. Il vous guide tout au long du processus de conception, du choix du type de formulaire à créer au mode de renvoi des informations en passant par le mode de remplissage du formulaire.
La condition requise pour le formulaire de notre didacticiel est qu’il tienne sur une page au format PDF que les utilisateurs rempliront à l’aide d’Adobe Reader. Il doit par ailleurs contenir un bouton dont l’utilisateur se servira après avoir rempli tous les champs afin de vous renvoyer les informations fournies.
1.
Choisissez Fichier > Nouveau. La boîte de dialogue de l’assistant de création de formulaires s’affiche.
l’assistant est également accessible par un clic sur l’option Créer un formulaire dans l’écran de bienvenue de l’application.
2.
L’option Utiliser un formulaire vierge est déjà sélectionnée. Cliquez sur Suivant.
3.
Sélectionnez le format Lettre dans la liste Format de page et cliquez sur Suivant.
4.
Sélectionnez Ajouter un bouton Envoyer par messagerie et saisissez l'adresse électronique de renvoi. LiveCycle Designer insère automatiquement un bouton Envoyer par messagerie dans la conception du formulaire. Lorsque la personne qui a rempli le formulaire clique sur ce bouton, un message électronique contenant les informations sous forme de pièce jointe vous est adressé.
5.
Cliquez sur Terminer.
La nouvelle conception de formulaire s’ouvre. Vous constaterez que le bouton Envoyer par messagerie y figure.
Passons à présent au placement du bouton Envoyer par messagerie dans la conception de formulaire.
Cliquez sur ce lien pour continuer : Placement du bouton Envoyer par messagerie


Placement du bouton Envoyer par messagerie

L’assistant de création de formulaires ajoute automatiquement le bouton Envoyer par messagerie à la conception de formulaire vide lorsque vous sélectionnez l’option Remplir et envoyer. Une fois que vos collègues auront rempli le questionnaire, il leur suffira de cliquer sur ce bouton pour vous envoyer immédiatement les informations au format XML. Vous pourrez ensuite exploiter les fichiers XML reçus de bien des manières ; vous pouvez, par exemple, consolider les informations obtenues dans un tableur tel que Microsoft Excel à l’aide d’Acrobat Professional.
Pour les besoins de ce didacticiel, nous verrons comment centrer le bouton Envoyer par messagerie au bas du formulaire.
1.
Faites glisser le bouton vers le milieu en bas du formulaire.
Pour sélectionner le bouton (et pas simplement le texte du bouton) lors du déplacement, sélectionnez la bordure du bouton.
2.
Pour centrer horizontalement le bouton sur le formulaire, sélectionnez-le, puis choisissez Disposition > Centrer sur la page > Horizontalement.
Cliquez sur ce lien pour continuer : Ajout du titre Enquête sur le pique-nique d'entreprise


Ajout du titre Enquête sur le pique-nique d'entreprise

Dans cette section, nous verrons comment insérer un titre dans le questionnaire.
1.
Dans la palette Bibliothèque, cliquez sur la catégorie Standard, puis sur l’objet de texte [image].
si la palette voulue n’est pas visible, choisissez Fenêtre > [nom de la palette].
2.
Cliquez sur le haut du formulaire, à l’emplacement où vous souhaitez afficher le titre.
L’objet s’affiche, prêt à être ajusté en fonction de vos besoins. Par exemple, pour le centrer horizontalement sur le formulaire, choisissez Disposition > Centrer sur la page > Horizontalement.
vous observerez les lignes délimitant le contour de l’objet. Il s’agit de la bordure de l’objet ; elle est uniquement visible dans la conception de formulaire afin de vous donner une idée de la taille et de la forme de l’objet. L’utilisateur du formulaire ne la verra pas.
3.
Pour dimensionner l’objet, faites glisser les lignes de la bordure.
4.
Effectuez les opérations suivantes :
      •
      Sélectionnez le texte contenu dans l’objet de texte et tapez Questionnaire sur la sortie annuelle de l’entreprise.
      •
      Appuyez sur Entrée.
      •
      Tapez Aidez-nous à en faire un événement réussi !
si un signe plus blanc s’affiche dans un carré rouge dans le coin inférieur droit de l’objet, cela signifie que vous devez ajuster la hauteur de l’objet pour tenir compte de la taille de la police.
5.
Sélectionnez le texte Questionnaire sur la sortie annuelle de l’entreprise.
6.
Sur la barre d’outils Formatage de texte, sélectionnez 22 dans la liste Taille, cliquez sur l’icône Gras [image] et choisissez Centrer [image].
vous pouvez contrôler la façon dont vous sélectionnez les objets et les légendes dans une conception de formulaire. Choisissez Edition > Verrouiller le texte si vous souhaitez sélectionner un objet à l’aide d’un clic de souris et modifier les légendes à l’aide d’un double-clic. Dans ce guide, l’option Verrouiller le texte est désactivée pour que vous puissiez utiliser un clic pour activer un objet et sélectionner la légende directement. Ce didacticiel utilise un simple clic pour sélectionner un objet.
7.
Sélectionnez le texte Aidez-nous à en faire un événement réussi !.
8.
Sur la barre d’outils Formatage de texte, sélectionnez 16 dans la liste Taille et choisissez Centrer [image].
Cliquez sur ce lien pour continuer : Ajout d'un objet de champ de texte pour le nom


Ajout d'un objet de champ de texte pour le nom

Vous venez de voir comme il est facile d’insérer un titre à la conception de formulaire. Voyons à présent comment créer le corps du questionnaire.
Pour ce faire, vous ajouterez plusieurs objets à partir de la catégorie Standard de la palette Bibliothèque. Ainsi, pour insérer une zone dans laquelle les utilisateurs indiqueront leur nom, vous ajouterez un objet de champ de texte.
Lorsque vous voulez offrir aux utilisateurs la possibilité de saisir du texte, utilisez l’objet de champ de texte afin d’ajouter des champs dans un formulaire. Dans ce didacticiel, vous apprendrez à ajouter des zones dans lesquelles les personnes qui rempliront le formulaire saisiront leur nom et leurs commentaires ou suggestions.
Il existe plusieurs méthodes pour insérer des objets dans une conception de formulaire. Cela dépend de la manière dont vous préférez travailler. Vous pouvez ajouter des objets en commençant par le haut du formulaire et en poursuivant jusqu’en bas ou procéder de manière aléatoire.
Voyons maintenant comment ajouter les champs Nom et Commentaires/Suggestions à l’aide de l’objet de champ de texte.
Pour ajouter le champ Nom à l’aide de l’objet de champ de texte
1.
Dans la palette Bibliothèque, activez la catégorie Standard, puis cliquez sur l’objet de champ de texte [image].
2.
Dans le formulaire, cliquez à l’emplacement où vous souhaitez voir figurer le champ Nom.
L’objet s’affiche, prêt à être ajusté en fonction de vos besoins.
Cet objet se divise en deux parties : la légende (ou l’intitulé) et l’endroit où les informations seront saisies (également appelé la valeur).
3.
Sélectionnez le texte Champ de texte et tapez Nom :.
Ce texte est appelé la légende.
4.
Choisissez Fenêtre > Objet.
La palette Objet s’affiche dans la partie droite de l’éditeur de disposition.
5.
Dans la palette Objet, cliquez sur l’onglet Liaison, puis tapez Nom dans le champ Nom.
Il est recommandé d’attribuer un nom à chaque objet d’une conception de formulaire. Vous verrez par la suite comment les noms d’objet s’avèrent pratiques lorsque vous recevez les informations au format XML.
6.
Pour réduire l’espace entre la légende et le champ de saisie du nom, faites glisser la ligne de la bordure comprise entre la légende et la valeur de gauche.
Pour ajouter le champ Commentaires/Suggestions à l’aide de l’objet de champ de texte
1.
Dans la palette Bibliothèque, cliquez sur la catégorie Standard, puis sur l’objet de champ de texte [image].
2.
Cliquez au bas du formulaire, à l’emplacement prévu pour afficher le champ Commentaires/Suggestions. L’objet s’affiche, prêt à être ajusté en fonction de vos besoins.
3.
Choisissez Fenêtre > Disposition.
La palette Disposition s’affiche dans la partie droite de l’éditeur de disposition.
toutes les palettes ne sont pas affichées dans l’espace de travail. Si vous ne voyez pas la palette souhaitée, choisissez son nom dans le menu Fenêtre afin de l’activer.
4.
Dans le champ Légende de la palette Disposition, sélectionnez Haut dans la liste Position. La légende se place dans la partie supérieure du champ.
5.
Faites glisser les contours de la bordure afin d’ajuster la taille du champ.
6.
Sélectionnez la légende Champ de texte et tapez Commentaires/Suggestions.
7.
Sélectionnez le champ Commentaires/Suggestions.
8.
Dans la palette Objet, activez l’onglet Champ et cochez la case Permettre des lignes multiples afin que la personne qui remplit le formulaire puisse saisir plus d’une ligne de texte.
9.
Dans la palette Objet, cliquez sur l’onglet Liaison, puis tapez Commentairesdans le champ Nom.
Cliquez sur ce lien pour continuer : Ajout d'un objet de liste déroulante pour le nombre de participants


Ajout d'un objet de liste déroulante pour le nombre de participants

Les listes déroulantes offrent aux personnes qui remplissent un formulaire un moyen de sélectionner un seul élément dans une liste (le nombre de personnes qui participeront à la sortie, par exemple).
1.
Dans la palette Bibliothèque, activez la catégorie Standard, puis cliquez sur l’objet de liste déroulante [image].
2.
Dans le formulaire, cliquez à droite du champ Nom, à l’emplacement où devra figurer la liste déroulante.
3.
Pour aligner la liste déroulante par rapport au champ Nom, sélectionnez à la fois l’objet de liste déroulante et le champ Nom, puis choisissez Disposition > Aligner > Haut.
4.
Agrandissez l’objet de liste déroulante afin de pouvoir taper la légende.
5.
Sélectionnez la légende Liste déroulante et tapez Combien de personnes seront présentes ?
6.
Sélectionnez l’objet de liste déroulante.
7.
Cliquez sur l'onglet Champ de la palette Objet. Dans la zone Articles de liste, saisissez les valeurs de la façon suivante :
      •
      Cliquez sur Ajouter [image].
      •
      Tapez 1 et appuyez sur Entrée.
      •
      Tapez 2 et appuyez sur Entrée.
      •
      Recommencez cette procédure jusqu’à ce que vous ayez atteint le chiffre 9.
8.
Dans la palette Objet, cliquez sur l’onglet Liaison, puis tapez Nombre de participants dans le champ Nom.
Cliquez sur ce lien pour continuer : Ajout d’un objet de texte pour les instructions


Ajout d’un objet de texte pour les instructions

Vous avez déjà utilisé l’objet de texte pour créer le titre de la conception de formulaire. Voyons à présent comment l’utiliser pour ajouter des instructions destinées à la personne qui remplira le formulaire.
1.
Dans la palette Bibliothèque, cliquez sur la catégorie Standard, puis sur l’objet de texte [image].
2.
Cliquez sous le champ Nom, à l’emplacement où doivent figurer les instructions associées.
3.
Dimensionnez l’objet en fonction de la longueur des instructions.
4.
Sélectionnez le texte Texte et tapez Le parc nous propose les dates suivantes. Veuillez choisir celle qui vous convient le mieux :
5.
Recommencez les étapes 1 à 3 pour ajouter un autre objet de texte à mi-chemin entre le texte que vous venez d’insérer et le champ Commentaires/Suggestions.
6.
Sélectionnez le texte Texte et tapez Veuillez sélectionner les activités que vous aimeriez faire durant le pique-nique :
Cliquez sur ce lien pour continuer : Ajout d'un objet de bouton radio pour les choix de dates


Ajout d'un objet de bouton radio pour les choix de dates

Les boutons radio constituent un moyen pratique d’offrir divers choix qui s’excluent mutuellement. Par exemple, dans notre cas, nous souhaitons connaître la date la plus favorable. Vous dressez la liste des dates sur le formulaire à côté d’un bouton radio. La personne qui remplira le formulaire ne pourra choisir qu’une seule date.
1.
Dans la palette Bibliothèque, activez la catégorie Standard, puis cliquez sur l’objet de bouton radio [image].
2.
Cliquez sous le premier jeu d’instructions. L’objet s’affiche.
3.
Sélectionnez le texte Bouton radio et tapez 26 juin.
4.
Recommencez les étapes 1 à 3 pour les deux autres dates et procédez comme suit.
      •
      Placez les objets sous le premier.
      •
      Sélectionnez la légende du deuxième objet et tapez 10 juillet.
      •
      Sélectionnez le libellé du troisième objet et tapez 17 juillet.
5.
Dans la palette Objet, cliquez sur l’onglet Liaison, puis tapez DateVoulue dans le champ Nom.
Cliquez sur ce lien pour continuer : Ajout d'un objet de case à cocher pour les activités préférées


Ajout d'un objet de case à cocher pour les activités préférées

Les cases à cocher s’avèrent pratiques lorsque vous souhaitez que l’utilisateur puisse sélectionner une ou plusieurs options. Dans notre exemple, vous souhaitez connaître les activités qui intéressent les participants à la sortie. Vous dressez la liste des activités sur le formulaire à côté d’une case à cocher. La personne qui remplit le formulaire peut choisir une ou plusieurs activités.
1.
Dans la palette Bibliothèque, activez la catégorie Standard, puis cliquez sur l’objet de case à cocher [image].
2.
Cliquez sous le deuxième jeu d’instructions.
L’objet s’affiche, prêt à être ajusté en fonction de vos besoins.
3.
Sélectionnez le texte Case à cocher et tapez Football.
4.
Dans la palette Objet, cliquez sur l’onglet Liaison, puis tapez Football dans le champ Nom.
5.
Recommencez les étapes 1 à 4 pour les activités suivantes.
      •
      Volley-ball (Tapez Volley-ball dans le champ Nom de l’onglet Liaison.)
      •
      Peinture de portrait (Tapez Peinture de portrait dans le champ Nom de l’onglet Liaison.)
      •
      Course en sac (Tapez Course en sac dans le champ Nom de l’onglet Liaison.)
Cliquez sur ce lien pour continuer : Enregistrement de votre conception de formulaire


Enregistrement de votre conception de formulaire

Il est conseillé d’enregistrer votre travail à intervalle régulier. Vous réduirez ainsi le risque d’en perdre une grande partie.
1.
Choisissez Fichier > Enregistrer.
2.
Dans le champ Nom de fichier, saisissez le nom du fichier.
3.
Cliquez sur Enregistrer.
Cliquez sur ce lien pour continuer : Aperçu de votre travail


Aperçu de votre travail

A mesure que vous travaillez, vous pouvez prévisualiser et tester la conception du formulaire pour savoir comment il se présente à la personne qui devra le renseigner.
1.
Cliquez sur l’onglet Aperçu PDF dans l’éditeur de disposition.
Ce mode d’affichage vous permet de vérifier la disposition et de tester les champs qui demandent une saisie de la part de l’utilisateur.
2.
Tapez des données dans les champs, puis cliquez sur le bouton Envoyer par messagerie afin de transmettre les informations.
Dans le présent didacticiel, ces données vous sont adressées, car vous aviez indiqué votre adresse électronique comme adresse de renvoi lors de la création du formulaire à l’aide de l’assistant de création de formulaires.
Si vous ouvrez le fichier XML dans votre navigateur, voici ce que vous pourrez voir :
<?xml version="1.0" encoding="UTF-16"?>
<form1>
<Name>Susan White</Name>
<PreferredDate>1</PreferredDate>
<Number>3</Number>
<Football>1</Football>
<Volleyball>0</Volleyball>
<FacePainting>0</FacePainting>
<SackRaces>1</SackRaces>
<Comments>Is there a rain date? </Comments>
</form1>
Observez comment les noms que vous avez attribués aux objets dans la conception de formulaire sont des éléments dans le code XML. Le fichier XML vous offre de nombreuses possibilités de gestion des informations.
Cliquez sur ce lien pour continuer : Finition de la conception du formulaire


Finition de la conception du formulaire

Conservez en lieu sûr le fichier de conception du formulaire. Vous procéderez aux mises à jour ou modifications du formulaire directement dans cette conception.
1.
Choisissez Fichier > Enregistrer.
2.
Sélectionnez l’emplacement de la conception du formulaire, puis indiquez son nom dans le champ Nom du fichier.
Avant de distribuer le formulaire, il est recommandé de le tester à l’extérieur de LiveCycle Designer. Vous pouvez commencer par le tester vous-même, puis le distribuer à quelques personnes choisies qui vous feront part de leurs commentaires après l’avoir testé.
Cliquez sur ce lien pour continuer : Collecte des données dans une feuille de calcul


Collecte des données dans une feuille de calcul

Utilisez Acrobat Professional pour rassembler des informations des fichiers reçus dans une feuille de calcul (notamment Microsoft Excel).
1.
Lancez Acrobat Professional et ouvrez le formulaire enregistré lors de l’étape précédente.
2.
Choisissez Fichier > Données de formulaire > Créer des feuilles de calcul à partir des fichiers de données.
3.
Cliquez sur Ajouter des fichiers et recherchez le fichier XML envoyé par messagerie.
4.
Recommencez l’étape 3 si vous souhaitez ajouter d’autres fichiers à la liste.
5.
Cliquez sur Exporter.
6.
Sélectionnez un emplacement sur votre ordinateur pour l'enregistrement de la feuille de calcul, puis cliquez sur Enregistrer.
La boîte de dialogue Créer des feuilles de calcul indique que l'opération est terminée une fois qu’Acrobat a créé la feuille de calcul.
7.
Cliquez sur Afficher le fichier maintenant pour ouvrir la feuille de calcul dans l’application par défaut.
Ci-dessous vous trouverez un exemple de l’aspect des données dans la feuille de calcul :
Les noms saisis dans le champ Nom de l’onglet Liaison s’affichent. La feuille de calcul est donc plus facile à lire.
8.
Fermez la feuille de calcul.
9.
Cliquez sur Fermer.
10.
Quitter Acrobat Professional.
Cliquez sur ce lien pour continuer : En quoi consiste l’étape suivante ?


En quoi consiste l’étape suivante ?

Vous venez de créer votre tout premier formulaire. Ce type de formulaire n’est qu’un des nombreux types que vous pouvez créer en utilisant LiveCycle Designer. L’aide en ligne décrit d’autres concepts et techniques permettant d’élaborer des formulaires.
Voir aussi
Création d'un formulaire de bon de commande


Création d'un formulaire de bon de commande

Création d'un formulaire de bon de commande
Démarrage de la conception de formulaire
Ajout d'un logo
Ajout du titre du bon de commande
Ajout d'un champ de texte pour le numéro de bon de commande
Ajout d'un champ de date pour la date du bon de commande
Aperçu de votre travail
Enregistrement de la conception de formulaire
Ajout d'un bloc d'adresse
Ajout des détails du bon de commande
Déplacement du tableau du bon de commande
Dimensionnement du tableau du bon de commande
Saisie de libellés sur la rangée d'en-tête
Définition des cellules N° d'article et Description sous forme de champs de texte
Transformation des cellules en champs numériques
Attribution de noms aux champs
Exécution d'un calcul dans la colonne Montant
Ajout de rangées au tableau du bon de commande
Changement du nom du contenu de votre formulaire
Insertion du sous-total au bas du tableau
Insertion de champs Taxe
Insertion du champ Frais de livraison
Insertion du champ Total global
Ajout de la section Conditions générales
Ajout de l'objet de champ Autorisé par
En quoi consiste l’étape suivante ?


Création d'un formulaire de bon de commande

Au cours d'une journée de travail, vous êtes amené à utiliser différents types de formulaires, tels que des formulaires de commande, factures, prêts et feuilles de présence. Il existe différents types de formulaires :
      •
      Dans certains cas, vous remplissez les formulaires directement, soit à la main soit électroniquement.
      •
      Dans d'autres cas, le remplissage s'effectue parallèlement à un processus faisant appel à un serveur, qui fusionne les données dans le formulaire.
      •
      Enfin, les formulaires peuvent être une combinaison de ces deux types.
Ce didacticiel explique comment créer un bon de commande que les utilisateurs vont remplir électroniquement et imprimer. Il décrit les concepts et les procédures essentielles qui s'appliquent à tous les types de formulaires. Ce didacticiel constitue une introduction de grande utilité, quel que soit le type de formulaire que vous souhaitiez créer par la suite.
Après avoir suivi ce didacticiel dans son intégralité, vous créerez un formulaire identique au bon de commande suivant.
Cliquez sur ce lien pour continuer : Démarrage de la conception de formulaire


Démarrage de la conception de formulaire

LiveCycle Designer offre plusieurs méthodes pour commencer rapidement une conception de formulaire. Pour les besoins de ce didacticiel, nous utiliserons l’assistant de création de formulaires afin de créer le bon de commande. L'assistant de création de formulaires simplifie la procédure de création d'une conception de formulaire en vous guidant dans une série d'étapes, du choix du type de formulaire à créer au mode de renvoi des informations en passant par le mode de remplissage du formulaire.
La seule condition requise concernant le bon de commande est qu’il tienne sur une page au format PDF. Les utilisateurs rempliront le formulaire par voie électronique à l’aide d’Adobe Reader, l’imprimeront à l’aide du bouton prévu à cet effet dans le formulaire, puis vous le renverront manuellement.
1.
Choisissez Fichier > Nouveau.
2.
Cliquez sur Suivant.
3.
Dans la liste Format de page, sélectionnez Lettre.
4.
Cliquez sur Suivant.
5.
Sélectionnez Remplir et imprimer, puis cliquez sur Suivant.
Lorsque vous sélectionnez l’option Remplir et imprimer comme mode de renvoi, LiveCycle Designer insère automatiquement un bouton Imprimer dans la conception. Une fois le formulaire dûment rempli, les utilisateurs cliquent sur le bouton Imprimer afin d’en imprimer un exemplaire.
6.
Cliquez sur Terminer.
La nouvelle conception de formulaire apparaît dans l'éditeur de disposition.
Cliquez sur ce lien pour continuer : Ajout d'un logo


Ajout d'un logo

Dans cette section, vous apprendrez à ajouter un logo au bon de commande.
1.
Dans la palette Bibliothèque, activez la catégorie Standard et faites glisser l'objet d'image [image] vers le coin supérieur gauche de la conception de formulaire.
2.
Double-cliquez sur la balise d'emplacement réservé et localisez le fichier d'image.
Par exemple, si vous (ou votre administrateur) avez installé les échantillons fournis avec LiveCycle Designer, localisez et ouvrez le fichier d’image suivant :
\Samples\Purchase Order\Interactive\Images\Purchase Order.tif.
3.
Dans la palette Objet, choisissez Utiliser la taille d'origine dans la liste Taille.
Cliquez sur ce lien pour continuer : Ajout du titre du bon de commande


Ajout du titre du bon de commande

Dans cette section, vous apprendrez à ajouter un titre au bon de commande.
1.
Dans la palette Bibliothèque, cliquez sur l'onglet Standard, puis faites glisser l'objet de texte [image] en dessous du logo.
2.
Sélectionnez le texte dans l'objet de texte et tapez Bon de commande.
3.
Sélectionnez le texte dans l'objet de texte, puis dans la palette Police, sélectionnez 20 dans la liste Taille et Gras dans la liste Style.
vous pouvez définir la police par défaut pour les objets. Par exemple, si vous souhaitez définir la police par défaut pour tous les objets de texte sur Arial, insérez un objet de texte dans le formulaire, choisissez la police Arial, puis faites glisser l'objet de texte dans la catégorie Standard de la palette Bibliothèque. Dans la boîte de dialogue Ajouter un objet de bibliothèque, saisissez Texte, puis cliquez sur OK. LiveCycle Designer vous demande de confirmer que vous souhaitez remplacer l'objet de texte existant. Cliquez sur Oui.
Cliquez sur ce lien pour continuer : Ajout d'un champ de texte pour le numéro de bon de commande


Ajout d'un champ de texte pour le numéro de bon de commande

Ensuite, vous devez utiliser un champ de texte pour le numéro du bon de commande. Dans ce formulaire, il comporte 10 chiffres.
1.
Dans la palette Bibliothèque, activez la catégorie Standard et faites glisser l'objet de champ de texte [image] vers le coin supérieur droit du formulaire.
2.
Sélectionnez le texte dans l'objet de champ de texte et tapez N° de bon de commande.
après avoir sélectionné Champ de texte, vous pouvez modifier la police, la taille et le style de la légende et de la valeur. La légende (intitulé du champ) est placée à côté de la valeur (zone dans laquelle l'utilisateur saisit les données). Dans la palette Police, utilisez le menu pour modifier les polices de la légende et de la valeur.
Ensuite, vous devez définir la longueur du champ de texte, 10 caractères au maximum.
3.
Dans la palette Objet, cliquez sur l'onglet Champ, puis sélectionnez l'option Limiter la taille. Saisissez 10 dans la zone Nombre max. de caractères.
Cliquez sur ce lien pour continuer : Ajout d'un champ de date pour la date du bon de commande


Ajout d'un champ de date pour la date du bon de commande

Vous pouvez utiliser l'objet de date/heure pour aider les utilisateurs à sélectionner une date. Il s'agit de ce que les utilisateurs voient lorsqu'ils cliquent sur la liste déroulante pour la date du bon de commande lors de l'affichage du formulaire dans Acrobat.
1.
Dans la palette Bibliothèque, activez la catégorie Standard et faites glisser l'objet de date/heure [image] sous le numéro du bon de commande dans le formulaire.
2.
Sélectionnez le texte dans l'objet de date/heure et tapez Date.
Cliquez sur ce lien pour continuer : Aperçu de votre travail


Aperçu de votre travail

A mesure que vous travaillez, vous pouvez prévisualiser la conception du formulaire pour savoir comment il se présente à la personne qui devra le renseigner. Par exemple, voici comment il va se présenter.
1.
Cliquez sur l'onglet Aperçu PDF.
vous devez disposer d'Adobe Reader version 6.0.2 ou d'une version supérieure pour utiliser le panneau Aperçu PDF.
2.
Cliquez sur l'onglet Vue de conception pour continuer à modifier la conception de formulaire.
Cliquez sur ce lien pour continuer : Enregistrement de la conception de formulaire


Enregistrement de la conception de formulaire

Il est conseillé d’enregistrer le formulaire maintenant. Vous devez enregistrer la conception de formulaire dans un fichier PDF que les personnes pourront remplir électroniquement, puis imprimer à l’aide du bouton Imprimer le formulaire.
1.
Cliquez sur Fichier > Enregistrer sous.
2.
Sélectionnez l’emplacement de la conception du formulaire, puis indiquez son nom dans le champ Nom du fichier.
3.
Dans la liste Type de la boîte de dialogue Enregistrer sous, sélectionnez Formulaire PDF statique Acrobat 7.0.5 (*.pdf).
Cliquez sur ce lien pour continuer : Ajout d'un bloc d'adresse


Ajout d'un bloc d'adresse

LiveCycle Designer contient des objets personnalisés prédéfinis que vous pouvez utiliser pour créer rapidement des formulaires. Par exemple, dans ce didacticiel, vous utiliserez l'objet de bibliothèque personnalisé Bloc d'adresse pour insérer plusieurs champs à la fois.
1.
Dans la palette Bibliothèque, cliquez sur la catégorie Personnalisés et faites glisser l'objet de bloc d'adresse [image] sous le titre Bon de commande.
2.
Renommez le champ de texte Nom en Commandé par.
3.
Dans la palette Bibliothèque, activez la catégorie Standard, puis faites glisser l'objet de champ de texte [image] sous le champ Pays.
4.
Nommez l'objet de champ de texte Téléphone.
5.
Ajoutez un autre objet de champ de texte pour Télécopieur.
6.
Ajoutez un autre objet de champ de texte dans le formulaire sous le numéro de télécopie.
7.
Nommez l'objet de champ de texte Contact.
8.
Pour insérer un second bloc d'adresse à côté de celui-là, faites glisser le pointeur pour sélectionner tous les champs créés aux étapes 1 à 7 et réduisez leur largeur d'environ un centimètre à l'aide de la poignée de droite.
9.
Copiez et collez les champs sélectionnés à côté du bloc d'adresse Commandé par.
10.
Renommez le second champ Commandé par en Livré à.
Normalement, voici à quoi ressemble maintenant le formulaire.
Vous pouvez afficher un aperçu du formulaire dans le panneau Aperçu PDF.
pour améliorer la présentation du formulaire, vous pouvez modifier l'aspect des champs de texte enfoncés. Pour ce faire, dans la palette Objet, sélectionnez l'objet, cliquez sur l'onglet Champ et choisissez Souligné dans la liste Aspect.
Cliquez sur ce lien pour continuer : Ajout des détails du bon de commande


Ajout des détails du bon de commande

Maintenant, vous devez ajouter un tableau destiné à contenir les numéros d'articles, la description des articles, les quantités, les prix unitaires et les volumes de chaque article. Les tableaux permettent de construire cette section rapidement. Le tableau va comporter cinq colonnes.
1.
Choisissez Tableau > Insérer un tableau.
2.
Sélectionnez l'option Créer un tableau à l'aide de l'assistant, puis cliquez sur OK.
Cet assistant permet de créer facilement un tableau si vous avez peu d'expérience en matière de création de tableaux dans LiveCycle Designer.
3.
Sous Contenu aux dimensions fixes, saisissez 5 pour le nombre de colonnes et 1 pour le nombre de rangées de contenu, puis cliquez sur Suivant.
4.
Sélectionnez l'option Avec rangée de pied de page et cliquez sur Suivant.
5.
Vérifiez si l'option Aucune rangée de pied de page est sélectionnée et cliquez sur Suivant.
6.
Sélectionnez l'option Avec rangées de contenu et sans section, puis cliquez sur Suivant.
7.
Désactivez l'option Alternance des couleurs de rangées, puis cliquez sur Terminer.
Cliquez sur ce lien pour continuer : Déplacement du tableau du bon de commande


Déplacement du tableau du bon de commande

Voici le tableau que vous venez d'insérer.
Maintenant, vous devez positionner le tableau sous les blocs d'adresse.
1.
Si le tableau n'est pas sélectionné, déplacez le curseur vers le coin supérieur gauche jusqu'à ce que le curseur suivant apparaisse :
2.
Cliquez pour sélectionner le tableau.
il existe un autre moyen de sélectionner le tableau qui consiste à sélectionner une cellule, choisir Tableau > Sélectionner, puis Tableau. Vous pouvez également cliquer et faire glisser le curseur pour sélectionner le tableau.
3.
Déplacez le curseur vers le coin supérieur gauche du tableau jusqu'à ce que le curseur de déplacement [image] apparaisse.
4.
Faites glisser le tableau vers son nouvel emplacement.
Cliquez sur ce lien pour continuer : Dimensionnement du tableau du bon de commande


Dimensionnement du tableau du bon de commande

Vous pouvez dimensionner le tableau de sorte qu'il occupe la largeur de la page. Par défaut, il est centré sur la page.
1.
Sélectionnez le tableau.
2.
Déplacez le curseur vers la poignée centrale située à droite pour que le curseur de déplacement apparaisse (représenté dans l'étape suivante).
3.
Faites glisser le curseur de sorte que le tableau remplisse la largeur de la page.
pour définir la même largeur pour toutes les colonnes, choisissez Tableau > Répartir proportionnellement les colonnes.
Cliquez sur ce lien pour continuer : Saisie de libellés sur la rangée d'en-tête


Saisie de libellés sur la rangée d'en-tête

1.
Double-cliquez sur la première cellule du tableau et saisissez N° d'article
2.
Répétez l'étape 1 pour les autres cellules de la rangée d'en-tête afin d'obtenir le résultat suivant.
vous pouvez appliquer une couleur de remplissage à cette rangée pour la faire ressortir. Pour cela, sélectionnez la rangée en déplaçant le curseur vers la gauche de la rangée jusqu'à ce que ce curseur apparaisse [image].
Puis, dans la palette Bordure, sélectionnez Plein dans la liste Style de remplissage de l'arrière-plan. Enfin, choisissez une couleur dans le sélecteur de couleurs [image].
Normalement, voici à quoi ressemble maintenant le formulaire.
Cliquez sur ce lien pour continuer : Définition des cellules N° d'article et Description sous forme de champs de texte


Définition des cellules N° d'article et Description sous forme de champs de texte

Par défaut, les cellules des tableaux sont des objets de texte. Maintenant, vous devez définir les cellules de la colonne Description sous forme de champs de texte. Les champs de texte permettent aux utilisateurs de saisir, sélectionner, modifier, couper, copier, coller et supprimer n'importe quelle portion du texte qui se trouve dans le champ. (Les objets de texte affichent un texte en lecture seule que l'utilisateur ne peut pas modifier.)
1.
Sélectionnez la cellule située sous N° d'article.
2.
Dans la palette Objet, activez l'onglet Cellule et choisissez Champ de texte dans la liste Type.
3.
Dans la liste Aspect, sélectionnez Aucun.
4.
Sélectionnez l'option Permettre des lignes multiples.
5.
Recommencez les étapes 1 à 4 pour les cellules Description.
Cliquez sur ce lien pour continuer : Transformation des cellules en champs numériques


Transformation des cellules en champs numériques

Maintenant, vous devez définir Quantité, Prix unitaire et Montant comme champs numériques.
1.
Sélectionnez la première cellule située sous Quantité.
2.
Dans la palette Objet, activez l'onglet Cellule et choisissez Champ numérique dans la liste Type.
3.
Dans le panneau Cellule, sélectionnez Aucun dans la liste Aspect.
4.
Recommencez les étapes 1 à 3 pour Prix unitaire et Montant :
les champs Prix unitaire et Montant contiennent des devises. Pour formater les données afin d'afficher les chiffres sous forme de devise, faites glisser le curseur afin de sélectionner les cellules des colonnes Prix unitaire et Montant. Dans la palette Objet, cliquez sur l'onglet Cellule et choisissez z,zz9.99 euro dans la liste Format d'affichage.
Cliquez sur ce lien pour continuer : Attribution de noms aux champs


Attribution de noms aux champs

Pour faciliter la lecture et l'utilisation de votre formulaire et exécuter des calculs, il est préférable de renommer les champs. Pour effectuer des calculs, vous devez connaître le nom exact du champ.
LiveCycle Designer tient compte des minuscules et des majuscules.
1.
Sélectionnez la cellule située sous N° d'article.
2.
Dans la palette Objet, cliquez sur l'onglet Liaison, puis tapez référence dans le champ Nom.
3.
Répétez les étapes 1 et 2 pour les autres colonnes et nommez-les comme suit :
      •
      description
      •
      quantité
      •
      prixUnitaire
      •
      montant
Cliquez sur ce lien pour continuer : Exécution d'un calcul dans la colonne Montant


Exécution d'un calcul dans la colonne Montant

La colonne Montant doit contenir le nombre d'articles commandés multiplié par le prix unitaire. Pour effectuer les calculs dans LiveCycle Designer, vous devez utiliser FormCalc ou JavaScript. Pour ce calcul, vous allez utiliser FormCalc. FormCalc est un langage de calcul simple mais puissant, basé sur les tableurs traditionnels. Il permet de créer des formulaires, rapidement et efficacement, sans exiger la maîtrise des techniques ou des langages de script traditionnels. L'éditeur de script permet d'entrer des calculs pour les différents objets du formulaire.
1.
Si l'éditeur de script n'est pas affiché à l'écran, choisissez Fenêtre > Editeur de script.
2.
Si besoin est, faites glisser la barre de la palette Editeur de script jusqu'à la taille de palette requise.
3.
Sélectionnez la cellule située sous Montant.
4.
Sélectionnez calculate dans la liste Afficher.
5.
Sélectionnez FormCalc dans la liste Langage, et Client dans la liste Exécuter sur.
6.
Dans le champ Source du script, saisissez le calcul suivant :

quantity * unitPrice
7.
Cliquez sur Insérer les changements dans la source du script [image] pour ajouter le script à votre formulaire.
8.
Pour définir cette colonne en lecture seule, dans la palette Objet, cliquez sur l'onglet Valeur et sélectionnez Calculé - Lecture seule dans la liste Type.
Cliquez sur ce lien pour continuer : Ajout de rangées au tableau du bon de commande


Ajout de rangées au tableau du bon de commande

Pour ce formulaire, vous avez besoin de sept rangées pour que les utilisateurs puissent y entrer les articles qu'ils souhaitent acheter. La commande Multiplier permet d'ajouter rapidement plusieurs rangées à la fois.
1.
Faites glisser le curseur pour sélectionner la rangée de contenu.
2.
Choisissez Edition > Multiplier.
3.
Dans le champ Nombre de copies, entrez 6.
4.
Sélectionnez l'option En dessous.
5.
Vérifiez si l'option Aucun est sélectionnée dans la zone Espacement vertical.
Normalement, voici à quoi ressemble maintenant le formulaire :
Cliquez sur ce lien pour continuer : Changement du nom du contenu de votre formulaire


Changement du nom du contenu de votre formulaire

Il est judicieux de renommer les objets d'un formulaire afin de l'organiser et d'identifier ses différentes zones. Pour ce faire, le meilleur moyen est d'utiliser la palette Hiérarchie. Il s'agit en fait d'une représentation graphique du contenu de votre formulaire.
1.
Choisissez Fenêtre> Hiérarchie.
2.
Sélectionnez le premier objet de la hiérarchie, form1.
3.
Appuyez sur F2 ou cliquez avec le bouton droit et choisissez Renommer l'objet.
4.
Saisissez le nouveau nom, PurchaseOrderForm.
5.
Renommez (Sous-formulaire sans titre) (page 1) en PurchaseOrder.
Vous pouvez renommer le reste du contenu de votre formulaire, si besoin est, mais il n'est pas nécessaire de terminer ce didacticiel.
vous pouvez également déplacer des objets dans la Hiérarchie en les sélectionnant et en les faisant glisser vers le haut ou vers le bas.
Cliquez sur ce lien pour continuer : Insertion du sous-total au bas du tableau


Insertion du sous-total au bas du tableau

Pour exécuter des calculs, FormCalc doit savoir quel objet utiliser dans le calcul. Dans cette étape, nous souhaitons générer le total de toutes les données de la colonne Montant. Si vous sélectionnez une cellule dans la colonne Montant, le nom interne apparaît dans l'éditeur de script (si vous agrandissez l'éditeur de script).
Le nom interne correspond à celui qui apparaît dans la hiérarchie. PurchaseOrderForm se trouve en haut de la hiérarchie, suivi de PurchaseOrder, etc.
Toutes les rangées du tableau s'appellent Rangée1 suivi d'un numéro d'instance par défaut. Pour que les données puissent être ajoutées à une colonne, toutes les rangées doivent porter le même nom.
Maintenant, vous allez ajouter le calcul du sous-total au bas du tableau.
1.
Dans la palette Bibliothèque, activez la catégorie Standard, puis faites glisser l’objet de champ numérique [image] sur le formulaire en dessous du tableau sous la colonne Montant.
2.
Sélectionnez le texte de l'objet de champ numérique et tapez Total.
3.
Dans la palette Objet, activez l'onglet Champ et choisissez Case pleine dans la liste Aspect.
4.
Dans l'éditeur de script, sélectionnez calculate dans la liste Afficher.
5.
Sélectionnez FormCalc dans la liste Langage, et Client dans la liste Exécuter sur.
6.
Dans le champ Source du script, saisissez le calcul suivant :

sum(Table1.Row1[*].amount[*])
Le caractère générique (*) indique à LiveCycle Designer de collecter toutes les données dans les rangées intitulées Rangée1 et toutes les données de la colonne Montant.
7.
Cliquez sur Insérer les changements dans la source du script [image] pour ajouter le script à votre formulaire.
8.
Dans la palette Objet, cliquez sur l'onglet Liaison, puis tapez Total dans le champ Nom.
9.
Dans la palette Objet, cliquez sur l'onglet Champ et choisissez z,zz9.99 euros dans la liste Format d'affichage.
10.
Dans la palette Objet, cliquez sur l'onglet Valeur et, dans la liste Type, choisissez Calculé - Lecture seule.
Cliquez sur ce lien pour continuer : Insertion de champs Taxe


Insertion de champs Taxe

Le bon de commande doit calculer les taxes fédérales et locales. Pour cela, créez un champ contenant le taux d'imposition et un champ calculé contenant le montant de la taxe.
Pour insérer le champ % Taxe locale
1.
Dans la palette Bibliothèque, activez la catégorie Standard, puis faites glisser l'objet de champ numérique [image] sur le formulaire en dessous du champ Total.
2.
Sélectionnez le texte dans l'objet de champ numérique et tapez % Taxe locale.
Vous pouvez redimensionner le champ pour le réduire.
3.
Dans la palette Objet, activez l'onglet Champ et choisissez Case pleine dans la liste Aspect.
4.
Dans la palette Objet, cliquez sur l'onglet Liaison, puis tapez %TauxImposition dans le champ Nom.
5.
Dans la palette Objet, cliquez sur l'onglet Champ et tapez z9.99'%' dans la liste Format d'affichage.
6.
Dans la palette Objet, cliquez sur l'onglet Valeur et tapez 6 dans le champ Valeur par défaut.
Pour insérer le champ Taxe locale
1.
Copiez le champ % Taxe locale et positionnez le nouveau champ à côté du champ % Taxe locale.
2.
Sélectionnez le texte et saisissez Taxe locale.
3.
Dans l'éditeur de script, sélectionnez calculate dans la liste Afficher.
4.
Dans le champ Source du script, saisissez le calcul suivant :

(total * stateTaxPercent / 100)
5.
Cliquez sur Insérer les changements dans la source du script [image] pour ajouter le script à votre formulaire.
6.
Dans la palette Objet, cliquez sur l'onglet Liaison, puis tapez taxeLocale dans le champ Nom.
7.
Dans la palette Objet, cliquez sur l'onglet Champ et choisissez z,zz9.99 euros dans la liste Format d'affichage.
8.
Dans la palette Objet, cliquez sur l'onglet Valeur et, dans la liste Type, choisissez Calculé - Lecture seule.
Pour insérer les champs % Taxe fédérale et Taxe fédérale
1.
Recommencez la procédure d'insertion du champ % Taxe locale.
2.
Recommencez la procédure d'insertion du champ Taxe locale.
3.
Effectuez les modifications suivantes pour que les champs soient applicables à la taxe fédérale :
      •
      Remplacez toutes les instances du mot Locale par Fédérale.
      •
      Définissez la valeur par défaut du taux d'imposition de la taxe fédérale sur 8.
      •
      Définissez le calcul de taxeFédérale sur :

(total * federalTaxPercent / 100)
Cliquez sur ce lien pour continuer : Insertion du champ Frais de livraison


Insertion du champ Frais de livraison

Par défaut, des frais de livraison de 50 õ sont appliqués. Cependant, ce formulaire permet aux utilisateurs de saisir un autre montant de frais de livraison, si besoin est.
1.
Dans la palette Bibliothèque, activez la catégorie Standard, puis faites glisser l'objet de champ numérique [image] sur le formulaire en dessous du champ Taxe fédérale.
2.
Sélectionnez le texte de l'objet de champ numérique et tapez Frais de livraison.
3.
Dans la palette Objet, cliquez sur l'onglet Liaison, puis tapez fraisLivraison dans le champ Nom.
4.
Dans la palette Objet, activez l'onglet Champ et choisissez Case pleine dans la liste Aspect.
5.
Dans la palette Objet, cliquez sur l'onglet Champ et choisissez z,zz9.99 euros dans la liste Format d'affichage.
6.
Dans la palette Objet, cliquez sur l'onglet Valeur et tapez 50 dans le champ Valeur par défaut.
Cliquez sur ce lien pour continuer : Insertion du champ Total global


Insertion du champ Total global

Vous devez ajouter un champ Total global contenant le total des articles, taxes et frais de livraison.
1.
Dans la palette Bibliothèque, activez la catégorie Standard, puis faites glisser l'objet de champ numérique [image] sur le formulaire en dessous du tableau.
2.
Sélectionnez le texte de l'objet de champ numérique et tapez Total global.
3.
Dans la palette Objet, cliquez sur l’onglet Liaison, puis tapez totalGlobal dans le champ Nom.
4.
Dans la palette Objet, activez l'onglet Champ et choisissez Case pleine dans la liste Aspect.
5.
Dans la palette Objet, cliquez sur l'onglet Champ et choisissez z,zz9.99 euros dans la liste Format d'affichage.
6.
Dans la palette Objet, cliquez sur l'onglet Valeur et, dans la liste Type, choisissez Calculé - Lecture seule.
7.
Dans l'éditeur de script, sélectionnez calculate dans la liste Afficher.
8.
Dans le champ Source du script, saisissez le calcul suivant :

sum (total, stateTax, federalTax, shippingCharge)
9.
Cliquez sur Insérer les changements dans la source du script [image] pour ajouter le script à votre formulaire.
Cliquez sur ce lien pour continuer : Ajout de la section Conditions générales


Ajout de la section Conditions générales

Vous allez maintenant ajouter la section Conditions générales définissant les conditions de paiement des articles.
1.
Dans la palette Bibliothèque, activez la catégorie Standard, puis faites glisser l’objet de champ de texte [image] sur le formulaire sous le tableau situé à côté des calculs.
2.
Nommez-le Conditions générales.
Vous devrez peut-être redimensionner le champ en fonction de la légende. Pour ce faire, déplacez le curseur vers la bordure gauche du champ. Cliquez et faites glisser le curseur pour redimensionner le champ.
3.
Dans la palette Objet, cliquez sur l'onglet Champ, puis sélectionnez l'option Permettre des lignes multiples.
4.
Dans la palette Objet, activez l'onglet Champ et choisissez Case pleine dans la liste Aspect.
5.
Dans la palette Disposition, sélectionnez Haut dans la liste Position.
6.
Faites glisser le curseur pour redimensionner le champ et l'agrandir.
Cliquez sur ce lien pour continuer : Ajout de l'objet de champ Autorisé par


Ajout de l'objet de champ Autorisé par

Si vous voulez que la personne remplissant le formulaire utilise la fonction de signature d’Adobe Acrobat pour signer le document, ajoutez un objet de champ de signature du document à la conception de formulaire. Pour plus d'informations sur les signatures, voir Aperçu des champs de signature de document.
1.
Dans la palette Bibliothèque, activez la catégorie Standard, puis faites glisser l'objet de champ de signature du document [image] sur le formulaire en dessous de la section Conditions générales.
2.
Sélectionnez le texte de l'objet de champ de signature du document et tapez Autorisé par :.
3.
Dans la palette Objet, sélectionnez Souligné dans la liste Aspect.
4.
Faites glisser le curseur pour redimensionner le champ et l'agrandir.
Normalement, voici à quoi ressemble maintenant le formulaire.
Cliquez sur ce lien pour continuer : En quoi consiste l’étape suivante ?


En quoi consiste l’étape suivante ?

Ce type de formulaire n’est qu’un des nombreux types que vous pouvez créer en utilisant LiveCycle Designer. L’aide en ligne décrit d’autres concepts et techniques permettant d’élaborer des formulaires.
Voir aussi
Création d'un bon de commande dont les sections s'adaptent à la taille des données


Création d'un bon de commande dont les sections s'adaptent à la taille des données

Création d'un bon de commande dont les sections s'adaptent à la taille des données
Ouverture du formulaire de bon de commande
Amélioration du format du formulaire
Organisation du formulaire
Mise en forme du pied de page
Configuration de l'agrandissement dynamique du tableau
Calcul du champ Total
Paramétrage de champs en lecture seule
Connexion à une source de données
Liaison de données aux champs et aux cellules de tableau
Spécification d'un fichier de données
En quoi consiste l’étape suivante ?


Création d'un bon de commande dont les sections s'adaptent à la taille des données

Dans le didacticiel précédent, vous avez créé un formulaire de bon de commande avec une disposition fixe que les utilisateurs vont remplir électroniquement et imprimer. Vous allez maintenant rendre le formulaire plus souple afin d'afficher tous les articles commandés par un de vos clients.
Dans ce didacticiel, la conception de formulaire contient des informations issues d'une source de données. Il s'agit d'un formulaire non interactif que vous pouvez imprimer et enregistrer de façon électronique.
A l'issue de ce didacticiel, vous obtiendrez un formulaire identique au bon de commande suivant dans lequel les données seront fusionnées.
Pour terminer ce didacticiel, vous devez disposer d'un schéma et d'un fichier de données. Vous pouvez utiliser ceux de LiveCycle Designer si les exemples ont été installés par l'administrateur système ou vous-même. Par défaut, le schéma et le fichier de données se trouvent à l'emplacement suivant :
      •
      \FR\Samples\Purchase Order\Schema\Schema\Purchase Order.xsd
      •
      \FR\Samples\Purchase Order\Schema\Data\Purchase Order.xml
Cliquez sur ce lien pour continuer : Ouverture du formulaire de bon de commande


Ouverture du formulaire de bon de commande

Pour commencer, vous allez ouvrir le formulaire de bon de commande que vous avez enregistré dans le didacticiel précédent.
1.
Choisissez Fichier > Ouvrir.
2.
Localisez le formulaire que vous avez enregistré dans le didacticiel précédent et cliquez sur Ouvrir.
3.
Sélectionnez Fichier > Enregistrer sous et choisissez Acrobat 7.0 Formulaire XML dynamique (*.pdf) dans la liste Type.
4.
Modifiez le nom du fichier.
5.
Cliquez sur Enregistrer.
si vous envisagez de créer plus de formulaires avec une disposition souple que de formulaires avec une disposition statique, vous pouvez définir le type de fichier par défaut Formulaire PDF Dynamique pour les nouveaux formulaires dans la boîte de dialogue Outils > Options (onglet Gestion du document).
Cliquez sur ce lien pour continuer : Amélioration du format du formulaire


Amélioration du format du formulaire

Pour améliorer le format du formulaire pour l'impression, vous pouvez définir les objets de champ situés au-dessus du tableau pour qu'ils affichent un trait de soulignement et non un champ enfoncé.
1.
Sélectionnez le champ N° de bon de commande.
2.
Dans la palette Objet, cliquez sur l'onglet Champ et, dans la liste Aspect, sélectionnez Souligné.
3.
Répétez cette procédure pour les autres objets de champ situés au-dessus du tableau.
vous pouvez modifier en même temps tous les objets sélectionnés du même type.
4.
Sélectionnez tous les objets de champ situés au-dessus du tableau, excepté le titre Bouton Imprimer, Logo et Bon de commande.
5.
Dans la palette Paragraphe, cliquez sur Aligner en bas.
6.
Affichez le formulaire dans le panneau Aperçu PDF.
7.
Cliquez sur l'onglet Vue de conception pour continuer à modifier la conception de formulaire.
Cliquez sur ce lien pour continuer : Organisation du formulaire


Organisation du formulaire

Pour créer un formulaire prévu pour s'adapter à la taille des données, vous devez organiser les sections en sous-formulaires pour la fusion avec les données. Les sous-formulaires sont des objets qui agissent en tant que conteneurs pour d'autres objets, y compris les champs, objets standard et autres sous-formulaires. Ils permettent de positionner des objets les uns par rapport aux autres et offrent une structure dans les conceptions de formulaire avec une disposition souple.
1.
Dans la palette Hiérarchie, sélectionnez tous les éléments figurant au-dessus du tableau.
2.
Choisissez Insertion > Placer dans un sous-formulaire.
3.
Sélectionnez (Sous-formulaire sans titre), cliquez avec le bouton droit et choisissez Renommer l'objet.
4.
Tapez En-tête et appuyez sur Entrée.
5.
Pour prévoir suffisamment d'espace au-dessus du sous-formulaire En-tête, assurez-vous que la palette Disposition est affichée puis, dans la zone Hauteur, sous Taille et position, tapez 4.5 po.
6.
Réduisez tous les éléments de la hiérarchie.
7.
Répétez les étapes 1 et 2 pour tous les éléments situés sous le tableau (total to SignatureField1) et renommez ce nouveau (Sous-formulaire sans titre) Pied de page.
8.
Pour prévoir suffisamment d'espace avant le sous-formulaire Pied de page, assurez-vous que la palette Disposition est affichée puis, dans la zone Haut, sous Marges, tapez 0.25 po.
Voici ce que vous devez voir dans la palette Hiérarchie si vous réduisez tout ce qui se trouve sous PurchaseOrder.
Cliquez sur ce lien pour continuer : Mise en forme du pied de page


Mise en forme du pied de page

Pour améliorer le format du pied de page, vous pouvez définir les champs situées en dessous du tableau pour qu'elles affichent un trait de soulignement et non une zone enfoncée. Vous pouvez également définir les légendes et les valeurs de sorte qu'elles soient alignées en bas et définir les valeurs des champs pour qu'elles soient centrées.
1.
Faites glisser le curseur pour sélectionner les champs du pied de page (excepté les champs Conditions générales et Autorisé par).
si vous essayez de sélectionner les champs et que vous disposez du pointeur de déplacement [image], cliquez le long du bord de la conception du formulaire pour transformer le pointeur en pointe de flèche.
2.
Dans la palette Objet, cliquez sur l'onglet Champ et, dans la liste Aspect, sélectionnez Souligné.
3.
Dans la palette Paragraphe, cliquez sur Aligner en bas.
4.
Dans la palette Modification de la légende, sélectionnez Modifier la valeur pour changer l'alignement du paragraphe relatif à la valeur uniquement.
5.
Cliquez sur Aligner au centre.
Cliquez sur ce lien pour continuer : Configuration de l'agrandissement dynamique du tableau


Configuration de l'agrandissement dynamique du tableau

Dans un formulaire prévu pour s'adapter en fonction des données fusionnées, il est probable que vous ignoriez la quantité de données de la source de données. Par conséquent, vous ne pouvez pas spécifier le nombre de rangées du tableau. Vous devez définir un tableau dynamique. Pour ce faire, il suffit d'inclure une rangée de contenu définie pour être répétée en fonction du volume de données de la source de données.
1.
Faites glisser le pointeur pour sélectionner les rangées situées en dessous de la première rangée.
2.
Choisissez Tableau > Supprimer > Rangée.
3.
Dans la palette Hiérarchie, sélectionnez Tableau1.
4.
Choisissez Insertion > Placer dans un sous-formulaire.
Une section contenant le tableau est créée dans le formulaire. Vous devez séparer cette section du reste du formulaire pour que sa taille augmente de façon dynamique pour contenir les données.
5.
Le (Sous-formulaire sans titre) est sélectionné dans la palette Hiérarchie. Dans la palette Objet, cliquez sur l'onglet Sous-formulaire, puis sélectionnez Enchaînement dans la liste Contenu.
6.
Renommez le (Sous-formulaire sans titre) Tableau.
7.
Dans la palette Hiérarchie, sélectionnez Rangée1.
8.
Dans la palette Objet, cliquez sur l'onglet Liaison et sélectionnez l'option Rangée pour chaque élément.
Maintenant, vous devez définir la distribution du formulaire.
9.
Dans la palette Hiérarchie, choisissez le sous-formulaire PurchaseOrder.
10.
Dans la palette Objet, cliquez sur l'onglet Sous-formulaire et sélectionnez Enchaînement dans la liste Contenu.
Le fait d'appliquer la fonction d'enchaînement à l'intégralité du formulaire permet de mettre en forme chaque sous-formulaire du formulaire à tour à de rôle, sans laisser d'espace entre eux.
Cliquez sur ce lien pour continuer : Calcul du champ Total


Calcul du champ Total

Maintenant que vous avez réorganisé le contenu de votre formulaire, le calcul du total doit faire référence au nouveau sous-formulaire Tableau.
1.
Sélectionnez le champ Total.
2.
Faites glisser la barre de la palette Éditeur de script jusqu'à la taille de palette requise pour afficher plusieurs lignes.
3.
Dans le champ Source du script, révisez le script pour afficher le calcul suivant :

sum(Table.Table1.Row1[*].amount[*])
4.
Cliquez sur Insérer les changements dans la source du script [image] pour ajouter le script à votre formulaire.
Cliquez sur ce lien pour continuer : Paramétrage de champs en lecture seule


Paramétrage de champs en lecture seule

Vous ne souhaitez pas que les utilisateurs modifient les champs d'un formulaire imprimable. Par conséquent, vous devez définir ces champs en lecture seule.
1.
Dans la palette Hiérarchie, ouvrez le sous-formulaire En-tête et sélectionnez tous les champs de texte (PONumber, OrderedBy, OrderedByAddress).
2.
Dans la palette Objet, cliquez sur l’onglet Valeur et, dans la liste Type, choisissez Lecture seule.
3.
Dans la palette Hiérarchie, ouvrez le sous-formulaire Tableau et sélectionnez les champs de texte (référence et description).
4.
Dans la palette Objet, cliquez sur l’onglet Valeur et, dans la liste Type, choisissez Lecture seule.
5.
Répétez cette procédure pour quantité, prixUnitaire et montant.
6.
Répétez cette procédure pour les éléments du sous-formulaire Pied de page (excepté SignatureField).
Cliquez sur ce lien pour continuer : Connexion à une source de données


Connexion à une source de données

Pour fusionner des données avec votre formulaire, vous devez vous connecter à une source de données. Il convient ensuite de lier les données à un champ de votre conception de formulaire.
Lorsque vous liez les champs d'une conception de formulaire à une source de données, vous établissez un lien entre ces deux éléments qui vous permet de saisir, présenter, déplacer, traiter, afficher et imprimer les informations associées à la conception de formulaire.
1.
Choisissez Fichier > Nouvelle connexion aux données.
2.
Sélectionnez Schéma XML et cliquez sur Suivant.
3.
Par exemple, si vous (ou l'administrateur) avez installé les exemples fournis avec LiveCycle Designer, localisez le schéma appelé Purchase Order.xsd et cliquez sur Ouvrir.
Ce fichier se trouve dans \FR\Samples\Purchase Order\Schema\Schema.
4.
Cliquez sur Terminer.
Les données s'affichent dans la palette Vue des données.
Celle-ci s'affiche sous forme d'une vue hiérarchique de chaque source de données. Le nœud supérieur de la hiérarchie représente la connexion de données et affiche le nom que vous avez attribué à la connexion lors de sa création.
Cliquez sur ce lien pour continuer : Liaison de données aux champs et aux cellules de tableau


Liaison de données aux champs et aux cellules de tableau

Une fois connecté à une source de données, vous devez indiquer la position des données dans la conception de formulaire :
      •
      Pour lier des champs uniques, tels que N° de bon de commande et Date, vous pouvez utiliser la méthode glisser-déposer.
      •
      Pour lier des objets répétitifs, tels que la rangée du tableau du bon de commande, en éléments répétitifs dans le schéma, utilisez la case Par défaut de l'onglet Liaison de la palette Objet. Lorsque la rangée est liée, vous pouvez lier des cellules de cette rangée aux noeuds du schéma. Ces liaisons sont alors relatives par rapport à la liaison de la rangée.
Pour lier des données aux champs de la conception du formulaire
1.
Sélectionnez poNum dans la palette Vue des données, et faites-le glisser vers le champ N° de bon de commande.
2.
Dans la boîte de dialogue Propriétés de liaison, sélectionnez l'option Ne pas mettre à jour les propriétés connexes, puis cliquez sur OK.
L'opération de liaison associe un champ de formulaire existant à un élément de la source de données. Etant donné que vous avez choisi de ne pas mettre à jour les propriétés associées, LiveCycle Designer conserve la mise en forme que vous avez appliquée à l'objet de champ.
3.
Répétez la procédure pour les autres éléments de la palette Vue des données (excepté pour référence, description, quantité et prixUnitaire).
Par exemple, companyName doit être lié au champ Commandé par.
Pour lier des données aux cellules du tableau du formulaire
1.
Dans la palette Hiérarchie, sélectionnez Rangée1.
2.
Dans la palette Objet, cliquez sur l'onglet Liaison.
3.
Cliquez sur le triangle situé à côté de la zone Par défaut (Ouvrir, Enregistrer, Envoyer) et sélectionnez une liaison. Par exemple, sélectionnez DataConnection > item > item.
La chaîne suivante apparaît dans le champ Par défaut (Ouvrir, Enregistrer, Envoyer) : $record.item.item[*].
vous pouvez taper cette chaîne dans le champ Par défaut (Ouvrir, Enregistrer, Envoyer) au lieu de la sélectionner.
4.
Ouvrez la palette Vue des données.
5.
Pour vous assurer que la liaison correspond à ce que vous attendiez, liez chaque noeud à une cellule à l'aide de la méthode glisser-déposer. Par exemple, dans la palette Vue des données, sélectionnez référence et faites le glisser dans la cellule située sous l'en-tête N° d'article
6.
Dans la boîte de dialogue Propriétés de liaison qui s'affiche, sélectionnez l'option Ne pas mettre à jour les propriétés connexes, puis cliquez sur OK.
7.
Répétez la procédure pour les autres éléments de la palette Vue des données (description, quantité et prixUnitaire).
Cliquez sur ce lien pour continuer : Spécification d'un fichier de données


Spécification d'un fichier de données

La dernière étape consiste à pointer sur le fichier de données à fusionner avec le formulaire.
1.
Choisissez Fichier > Propriétés du formulaire, puis cliquez sur l’onglet Valeurs par défaut.
2.
Dans la zone Aperçu, accédez à l'emplacement du fichier de données à utiliser.
Si l'administrateur système ou vous-même avez installé les exemples fournis avec LiveCycle Designer, recherchez le fichier de données appelé Purchase Order.xml (il figure dans \FR\Samples\Purchase Order\Schema\Data).
3.
Cliquez sur Ouvrir, puis sur OK.
4.
Affichez le formulaire dans le panneau Aperçu PDF.
Normalement, voici à quoi ressemble maintenant le formulaire.
le fichier de données Purchase Order.xml fourni avec LiveCycle Designer contient quatre enregistrements. Vous pouvez modifier ce fichier XML pour pouvoir tester la disposition du formulaire et vérifier s'il s'adapte à la taille des données en utilisant un fichier contenant un nombre plus important de données.
(Facultatif) Pour vérifier si le formulaire Bon de commande s'adapte à la taille des données :
1.
Ouvrez le fichier XML et recherchez les lignes suivantes :

<item>
   <partNum>00300-896</partNum>
   <description>Address book</description>
   <quantity>2</quantity>
   <unitPrice>15.00</unitPrice>
</item>
2.
En dessous de ces lignes, il est possible d'ajouter d'autres éléments. Par exemple, vous pourriez ajouter les lignes suivantes :

<item>
   <partNum>00300-300</partNum>
   <description>Clipboard</description>
   <quantity>3</quantity>
   <unitPrice>5.00</unitPrice>
</item>
<item>
   <partNum>00300-325</partNum>
   <description>Paper Punch</description>
   <quantity>1</quantity>
   <unitPrice>8.00</unitPrice>
</item>
<item>
   <partNum>00300-350</partNum>
   <description>Ruler</description>
   <quantity>5</quantity>
   <unitPrice>1.00</unitPrice>
</item>
<item>
   <partNum>00300-400</partNum>
   <description>Scissors</description>
   <quantity>2</quantity>
   <unitPrice>2.00</unitPrice>
</item>
<item>
   <partNum>00300-425</partNum>
   <description>Tape</description>
   <quantity>2</quantity>
   <unitPrice>2.50</unitPrice>
</item>
<item>
   <partNum>00300-450</partNum>
   <description>Glue Stick</description>
   <quantity>2</quantity>
   <unitPrice>1.00</unitPrice>
</item>
<item>
   <partNum>00300-475</partNum>
   <description>Stapler</description>
   <quantity>2</quantity>
   <unitPrice>4.00</unitPrice>
</item>
<item>
   <partNum>00300-500</partNum>
   <description>Highlighters</description>
   <quantity>1</quantity>
   <unitPrice>5.00</unitPrice>
</item>
<item>
   <partNum>00300-550</partNum>
   <description>Selfstick Notes</description>
   <quantity>4</quantity>
   <unitPrice>5.00</unitPrice>
</item>
<item>
   <partNum>00300-575</partNum>
   <description>Composition Notebook</description>
   <quantity>5</quantity>
   <unitPrice>8.00</unitPrice>
</item>
3.
Enregistrez le fichier de données modifié sous un nouveau nom.
4.
Dans la boîte de dialogue Propriétés du formulaire, cliquez sur l'onglet Valeurs par défaut et localisez le fichier de données modifié.
5.
Cliquez sur OK et affichez de nouveau le formulaire dans le panneau Aperçu PDF.
Cliquez sur ce lien pour continuer : En quoi consiste l’étape suivante ?


En quoi consiste l’étape suivante ?

Si vous avez suivi les didacticiels, vous connaissez les principes de base de la création d'un formulaire. Maintenant, vous pouvez ajouter la rangée d'en-tête dans les pages suivantes du tableau. Vous pouvez également procéder à la numérotation des pages. N'hésitez pas à consulter l'aide en ligne pour en savoir plus sur la personnalisation de vos formulaires.


Utilisation de LiveCycle Designer

Utilisation de LiveCycle Designer

Utilisation des conceptions de formulaire
Utilisation des objets
Propriétés de l'objet
Utilisation de sources de données
Création de formulaires accessibles
Configuration de la protection
Création de formulaires en vue d'optimiser les performances
Création de formulaires destinés à LiveCycle Forms
Création de formulaires pour LiveCycle Workflow
Utilisation du clavier


Utilisation des conceptions de formulaire

Création, ouverture et enregistrement
Définition des pages, des gabarits et des jeux de pages
Définition de l'ordre de tabulation
Vérification orthographique dans les formulaires
Aperçu et tests de formulaires
Utilisation de formulaires dont la disposition s'adapte à la taille des données
Importation de documents
Utilisation des tableaux
Utilisation des sous-formulaires
Création et gestion des modèles


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Création, ouverture et enregistrement

Création, ouverture et enregistrement

Création de formulaires
Ouverture et enregistrement de formulaires


Création de formulaires

A propos de la création des formulaires
Pour concevoir un formulaire à l’aide de l’assistant de création de formulaires
Pour concevoir un formulaire sans l’assistant de création de formulaires
Pour créer une conception de formulaire basée sur un modèle, un exemple ou un formulaire existant
Pour créer une conception de formulaire en important un document PDF
Pour commencer avec un formulaire vierge
Pour ajouter des détails au sujet du formulaire
Pour définir des droits d’accès utilisateur à un formulaire PDF


A propos de la création des formulaires

Lorsque vous lancez LiveCycle Designer, vous êtes invité à créer un nouveau formulaire, créer un nouveau formulaire à partir d'un modèle ou ouvrir un formulaire. Vous pouvez également explorer les exemples de formulaires. Lorsque vous sélectionnez l'option Créer un formulaire vierge ou Utiliser un modèle, l'assistant de création de formulaires apparaît.
Il vous guide tout au long des étapes qui vous permettent de choisir le type de conception ou de modèle de formulaire à créer, le mode de remplissage et le mode de renvoi des données.
Si vous le souhaitez, vous avez la possibilité de désactiver l'assistant de création de formulaires.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Création, ouverture et enregistrement > Création de formulaires > Pour concevoir un formulaire à l’aide de l’assistant de création de formulaires

Pour concevoir un formulaire à l’aide de l’assistant de création de formulaires

1.
Choisissez Fichier > Nouveau. L'assistant de création de formulaires apparaît.
2.
Dans le panneau Mise en route, sélectionnez une méthode de création et cliquez sur Suivant.
3.
Suivez les instructions qui s'affichent à l'écran pour créer un formulaire.
4.
Donnez un nom au formulaire, puis enregistrez-le.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Création, ouverture et enregistrement > Création de formulaires > Pour concevoir un formulaire sans l’assistant de création de formulaires

Pour concevoir un formulaire sans l’assistant de création de formulaires

1.
Choisissez Fichier > Nouveau. L'assistant de création de formulaires apparaît.
2.
Cliquez sur Ne pas utiliser l’assistant. La boîte de dialogue Options de l’assistant s’affiche.
3.
Définissez les options d’utilisation de l’assistant de création de formulaires, puis cliquez sur OK. La boîte de dialogue Nouveau s’affiche.
4.
Dans le panneau Standard, cliquez sur une icône pour sélectionner un format de page, puis cliquez sur OK. Une conception de formulaire sans titre est créée.
pour afficher la page entière, la taille réelle de la page ou une zone équivalant à la largeur de la page, cliquez sur Taille réelle [image], Page entière [image] ou Pleine largeur [image] sur la barre d’outils. L’option de zoom actuelle [image] s’affiche aussi dans la barre d’outils.
Voir aussi
Pour enregistrer votre conception de formulaire


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Création, ouverture et enregistrement > Création de formulaires > Pour créer une conception de formulaire basée sur un modèle, un exemple ou un formulaire existant

Pour créer une conception de formulaire basée sur un modèle, un exemple ou un formulaire existant

1.
Ouvrez le modèle, l'exemple ou le formulaire à partir duquel vous voulez créer la conception de formulaire.
2.
Choisissez Fichier > Enregistrer sous.
3.
Naviguez jusqu’à l’emplacement où vous souhaitez enregistrer la conception de formulaire.
4.
Dans le champ Nom du fichier, tapez un nom de fichier pour la conception de formulaire.
si vous créez un formulaire en utilisant un modèle généré dans une version antérieure de LiveCycle Designer, vous pouvez utiliser l'onglet Compatibilité de la boîte de dialogue Propriétés du formulaire pour le mettre à jour en fonction de la version 7.
Voir aussi
Ouverture et enregistrement de formulaires


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Création, ouverture et enregistrement > Création de formulaires > Pour créer une conception de formulaire en important un document PDF

Pour créer une conception de formulaire en important un document PDF

Vous pouvez importer un document PDF afin de l'utiliser comme modèle pour définir une nouvelle conception de formulaire. Pour plus de détails, voir Pour importer des fichiers PDF.
Voir aussi
A propos de l'importation
A propos de l'importation de documents PDF en tant qu'illustrations
Boîte de dialogue Options d'importation


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Création, ouverture et enregistrement > Création de formulaires > Pour commencer avec un formulaire vierge

Pour commencer avec un formulaire vierge

      *
      Cliquez sur le bouton Nouveau [image] de la barre d’outils.


Pour ajouter des détails au sujet du formulaire

Vous pouvez enregistrer des informations descriptives relatives à une conception ou à un modèle de formulaire (par exemple, une description de fichier, le nom de l’auteur et les informations de création de fichier) avec la conception ou le modèle de formulaire.
Vous avez également la possibilité d’activer des fonctions de protection pour les formulaires PDF et d’intégrer les informations de sorte qu’elles soient disponibles pour les autres applications Adobe. Par exemple, si vous enregistrez la conception de formulaire en tant que fichier PDF, les informations de création de fichier peuvent être mises à disposition d’Acrobat.
1.
Choisissez Fichier > Propriétés du formulaire.
2.
Dans le panneau Info, entrez les informations voulues. Pour obtenir la liste complète et la description des éléments figurant dans ce panneau, voir Panneau Infos (boîte de dialogue Propriétés du formulaire).
3.
Pour incorporer des informations destinées à des applications tierces, cliquez sur l’onglet Sécurité PDF et dans la zone Droits d’accès, activez l'option Utiliser un mot de passe pour restreindre l’impression et la modification du document et de ses paramètres de protection, puis sélectionnez les options de protection nécessaires.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Création, ouverture et enregistrement > Création de formulaires > Pour définir des droits d’accès utilisateur à un formulaire PDF

Pour définir des droits d’accès utilisateur à un formulaire PDF

Vous pouvez définir les droits d’accès utilisateur permettant d’accéder, d’imprimer et de modifier des formulaires PDF à l’aide de LiveCycle Designer.
1.
Choisissez Fichier > Propriétés du formulaire.
2.
Dans le panneau Sécurité PDF, activez l'option Utiliser un mot de passe pour restreindre l’impression et la modification du document et de ses paramètres de protection, puis sélectionnez les options de protection nécessaires.
Voir aussi
Utilisation des options de protection PDF


Ouverture et enregistrement de formulaires

Pour ouvrir des conceptions de formulaires et d'autres fichiers
A propos des types de fichier
Pour enregistrer votre conception de formulaire
Pour enregistrer une copie d'une conception de formulaire
Pour enregistrer des formulaires au format Acrobat ou Adobe Reader
Pour publier un formulaire dans un référentiel


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Création, ouverture et enregistrement > Ouverture et enregistrement de formulaires > Pour ouvrir des conceptions de formulaires et d'autres fichiers

Pour ouvrir des conceptions de formulaires et d'autres fichiers

Outre les conceptions (XDP), les modèles (TDS) de formulaire ou les formulaires PDF créés et modifiés uniquement à l'aide de LiveCycle Designer, vous pouvez ouvrir d'autres types de fichier. Ces formats sont décrits en détails dans Formats des formulaires importés dans LiveCycle Designer.
les formulaires PDF créés avec un autre programme que LiveCycle Designer doivent être importés.
Lorsque vous ouvrez un fichier, une conception de formulaire, un modèle de formulaire ou un fichier d'un autre format, LiveCycle Designer recherche les polices du fichier parmi celles disponibles sur l'ordinateur. Si le fichier contient une police non disponible, LiveCycle Designer affiche une boîte de dialogue signalant la police manquante et une police de substitution. Vous pouvez accepter cette police de substitution ou en choisir une autre. Lorsque vous enregistrez le fichier par la suite, vous pouvez indiquer si vous souhaitez enregistrer les polices de substitution dans le fichier.
Si vous ouvrez un formulaire généré dans une version antérieure de LiveCycle Designer, vous pouvez utiliser l'onglet Compatibilité de la boîte de dialogue Propriétés du formulaire pour le mettre à jour en fonction de la version 7.
1.
Choisissez Fichier > Ouvrir.
2.
Naviguez jusqu’à l’emplacement où la conception de formulaire est enregistrée, sélectionnez le fichier et cliquez sur Ouvrir. Si le fichier contient des polices non disponibles sur l’ordinateur, la boîte de dialogue Polices manquantes s’affiche.
3.
Si besoin est, sélectionnez une méthode de substitution de police :
      •
      Pour accepter les polices de substitution suggérées, cliquez sur OK.
      •
      Pour changer de police de substitution, cliquez sur Changer de police de substitution. Choisissez une police et un style de police, puis cliquez sur OK. Dans la boîte de dialogue Polices manquantes, cliquez sur OK.
cette substitution de police n'est pas permanente. LiveCycle Designer doit mapper les polices manquantes chaque fois que le formulaire s'ouvre. Pour rendre la substitution permanente, choisissez Fichier > Enregistrer sous, puis cochez la case Remplacer définitivement les polices non disponibles avant d’enregistrer le fichier.
Voir aussi
Formats des formulaires importés dans LiveCycle Designer
Pour enregistrer votre conception de formulaire
A propos des types de fichier


A propos des types de fichier

Chaque type de fichier est prévu pour divers usages :
Formulaire PDF statique Acrobat 8 (*.pdf)
Enregistre les formulaires au format statique compatible Acrobat 8,0. La conception de formulaire ne peut contenir que des éléments statiques. Par exemple, si votre formulaire comporte 10 rangées de données, et que la quantité de données est suffisante pour renseigner 25 rangées, seules 10 rangées peuvent être complétées. De même, si la quantité de données est suffisante pour compléter 2 rangées, vous obtiendrez 10 rangées. Dans ce cas, 2 rangées seront complétées et les 8 autres seront vides.
Formulaire XML (dynamique) Acrobat 8 (*.pdf)
Enregistre les formulaires au format dynamique compatible Acrobat 8,0. La conception de formulaire peut contenir des éléments dynamiques. Par exemple, la conception de formulaire peut être un formulaire interactif dynamique qui permet aux utilisateurs d'ajouter ou de supprimer des rangées d'éléments.
Formulaire PDF statique Acrobat 7 (*.pdf)
Enregistre les formulaires au format statique compatible Acrobat 7.0. La conception de formulaire ne peut contenir que des éléments statiques. Par exemple, si votre formulaire comporte 10 rangées de données, et que la quantité de données est suffisante pour renseigner 25 rangées, seules 10 rangées peuvent être complétées. De même, si la quantité de données est suffisante pour compléter 2 rangées, vous obtiendrez 10 rangées. Dans ce cas, 2 rangées seront complétées et les 8 autres seront vides.
Formulaire XML (dynamique) Acrobat 7 (*.pdf)
Enregistre les formulaires au format dynamique compatible Acrobat 7.0. La conception de formulaire peut contenir des éléments dynamiques. Par exemple, la conception de formulaire peut être un formulaire interactif dynamique qui permet aux utilisateurs d'ajouter ou de supprimer des rangées d'éléments.
Formulaire PDF statique Acrobat 6 (*.pdf)
Ce format permet d’enregistrer une conception de formulaire lorsque les utilisateurs doivent remplir un formulaire avec Acrobat 6.0 ou Adobe Reader 6.0. Les utilisateurs ne peuvent pas ouvrir les formulaires LiveCycle Designer enregistrés dans les versions antérieures d'Acrobat ou d'Adobe Reader.
Formulaire XML Adobe (*.xdp)
Enregistre les formulaires au format XML natif créés par LiveCycle Designer. Préférez cette option si vous utilisez LiveCycle Forms. La conception de formulaire peut contenir des éléments dynamiques.
Adobe Modèle LiveCycle Designer (*.tds)
Enregistre la structure de base d'un formulaire sous la forme d'un modèle. Il peut contenir des composants et des paramètres, tels que polices, mise en page, mise en forme et scripts. Utilisez-le comme point de départ d'un nouveau formulaire.
Voir aussi
Différences entre le remplissage de formulaires dans Acrobat et Adobe Reader


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Création, ouverture et enregistrement > Ouverture et enregistrement de formulaires > Pour enregistrer votre conception de formulaire

Pour enregistrer votre conception de formulaire

Vous pouvez enregistrer des conceptions et des modèles de formulaire sous le nom et à l’emplacement actuels, ou enregistrer une copie sous un nom et à un emplacement différents. Vous avez le choix entre plusieurs formats pour enregistrer un document.
les formulaires PDF enregistrés dans LiveCycle Designer doivent uniquement être modifiés dans LiveCycle Designer.
      *
      Effectuez l'une des opérations suivantes :
      •
      Choisissez Fichier > Enregistrer.
      •
      Dans la barre d’outils, cliquez sur Enregistrer [image].
Voir aussi
Pour ajouter des détails au sujet du formulaire
A propos des modèles et du Gestionnaire de modèles


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Création, ouverture et enregistrement > Ouverture et enregistrement de formulaires > Pour enregistrer une copie d'une conception de formulaire

Pour enregistrer une copie d'une conception de formulaire

1.
Choisissez Fichier > Enregistrer sous.
2.
Pour enregistrer une conception de formulaire sous un nom différent, naviguez jusqu’à l’emplacement où la conception de formulaire doit être enregistrée et, dans la zone Nom du fichier, tapez un nom de fichier différent.
3.
Pour changer le type de fichier, choisissez l’une des options proposées dans la liste Type.
4.
Définissez les options d’enregistrement :
      •
      Pour incorporer des informations d’accessibilité dans le formulaire PDF, cochez la case Générer les données d’accessibilité (balises) pour Acrobat.
      •
      Pour créer un fichier journal du formulaire PDF enregistré, cochez la case Générer un fichier journal à l’enregistrement. Ce fichier journal est placé dans le même répertoire que le formulaire enregistré.
      •
      Pour remplacer les polices non disponibles par d’autres polices dans le fichier enregistré, cochez la case Remplacer définitivement les polices non disponibles. Cette option est disponible pour tous les formats de fichier.
      •
      Pour incorporer les polices du formulaire dans le formulaire PDF enregistré, cochez la case Incorporer les polices.
5.
Cliquez sur Enregistrer.
des exemples de conceptions et de modèles de formulaire sont fournis. Pour les utiliser, reportez-vous aux fichiers Lisezmoi correspondants. Les exemples de conceptions de formulaire sont installés dans le dossier Samples du dossier d’installation de LiveCycle Designer et les exemples de modèles sont installés dans le dossier Templates du dossier d’installation de LiveCycle Designer. Les modèles peuvent être visualisés et gérés à l’aide du Gestionnaire de modèles.
Voir aussi
Formats des formulaires importés dans LiveCycle Designer
Pour enregistrer votre conception de formulaire
A propos des types de fichier


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Création, ouverture et enregistrement > Ouverture et enregistrement de formulaires > Pour enregistrer des formulaires au format Acrobat ou Adobe Reader

Pour enregistrer des formulaires au format Acrobat ou Adobe Reader

Lorsque vous créez des formulaires pour Acrobat et Adobe Reader, vous devez les enregistrer sous forme de fichiers PDF.
Lorsque vous cliquez deux fois sur un fichier PDF, il s'ouvre dans Acrobat ou Adobe Reader. Pour ouvrir le fichier PDF dans LiveCycle Designer, choisissez Fichier > Ouvrir dans LiveCycle Designer ou démarrez LiveCycle Designer à partir du menu Options avancées d’Acrobat.
les fichiers PDF enregistrés dans LiveCycle Designer doivent uniquement être modifiés à l'aide de LiveCycle Designer.
1.
Choisissez Fichier > Enregistrer.
2.
Dans la zone Nom du fichier, entrez le nom du fichier.
3.
Dans la zone Type, sélectionnez le type voulu.
4.
Cliquez sur OK.
assurez-vous que la version d'Acrobat installée correspond à celle qui est enregistrée. Sinon vous risquez d'obtenir un message d'erreur ou d'avertissement en cliquant sur l'onglet Aperçu PDF. Par exemple, si vous enregistrez le format sous forme de formulaire PDF dynamique Acrobat 7.0, vérifiez si Acrobat 7.0 est installé.
Voir aussi
A propos des types de fichier


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Création, ouverture et enregistrement > Ouverture et enregistrement de formulaires > Pour publier un formulaire dans un référentiel

Pour publier un formulaire dans un référentiel

Vous pouvez placer une copie d'un formulaire et les fichiers associés dans un dossier partagé ou un dossier Web. Elle sera ainsi accessible à de nombreux utilisateurs ou à d'autres applications. Lorsque vous publiez un formulaire dans un référentiel, les modifications apportées au nom du fichier, au type du fichier et les références à des fichiers externes (images) ne sont appliquées que dans la copie publiée. Si le formulaire comporte un lien vers un fichier externe au moment où vous publiez le formulaire et ses fichiers associés, le système modifie la liste incluse dans le formulaire de façon à refléter le nouvel emplacement du fichier.
Vous pouvez publier le formulaire au format PDF ou XDP.
      •
      Lorsque vous publiez le formulaire au format PDF, les informations d'images et de schémas sont incorporées dans le formulaire et aucun fichier externe n'est copié dans le dossier de publication.
      •
      Quand vous publiez le formulaire au format XDP, les liens renvoyant à des fichiers externes référencés deviennent des chemins relatifs. Un chemin relatif permet de stocker les images référencées par plusieurs formulaires dans un même dossier sans devoir copier plusieurs fois ces images.
S'ils ne sont pas inclus dans un sous-dossier du dossier partagé ou du dossier Web, les fichiers liés sont copiés dans le dossier de publication et les liens du fichier XDP sont modifiés pour refléter le nouveau chemin absolu des fichiers.
1.
Choisissez Fichier > Publier dans le référentiel.
2.
Pour changer le type de fichier, choisissez l’une des options proposées dans la liste Type.
3.
Définissez les options d’enregistrement :
      •
      Pour incorporer des informations d’accessibilité dans un formulaire PDF, cochez la case Générer les données d’accessibilité (balises) pour Acrobat.
      •
      Pour créer un fichier journal du formulaire PDF enregistré, cochez la case Générer un fichier journal à l’enregistrement. Ce fichier journal est placé dans le même répertoire que le formulaire enregistré.
      •
      Pour remplacer les polices non disponibles par d’autres polices dans le fichier enregistré, cochez la case Remplacer définitivement les polices non disponibles. Cette option est disponible pour tous les formats de fichier.
      •
      Pour incorporer les polices du formulaire dans le formulaire PDF enregistré, cochez la case Incorporer les polices.
4.
Cliquez sur Enregistrer. Une boîte de dialogue affiche les résultats.
Voir aussi
A propos des types de fichier


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Définition des pages, des gabarits et des jeux de pages

Définition des pages, des gabarits et des jeux de pages

Définition des pages
Définition des gabarits
Définition des jeux de pages


Définition des pages

A propos des pages
Pour afficher ou masquer une page
Pour ajouter une page
Pour supprimer une page
Pour passer d’une page à une autre
Pour réorganiser les pages
Pour renommer une page


A propos des pages

Les pages représentent la trame sur laquelle vous construisez votre conception de formulaire. Pour mettre en page une conception de formulaire, il suffit de faire glisser les objets, tels que les champs de texte, depuis la palette Bibliothèque sur la page. Servez-vous du panneau Vue de conception pour afficher, ajouter, supprimer et modifier des pages.
Voir aussi
A propos des gabarits


Pour afficher ou masquer une page

Vous disposez de plusieurs méthodes pour afficher ou masquer les pages dans une conception de formulaire :
      •
      Pour afficher le panneau Vue de conception lorsqu'un autre panneau est actif, cliquez sur l'onglet Vue de conception dans l’éditeur de disposition.
      •
      Pour afficher ou masquer le panneau Vue de conception, choisissez Affichage > Vue de conception.


Pour ajouter une page

Vous pouvez ajouter une page par le biais du menu Insertion ou de la palette Hiérarchie.
si la palette Hiérarchie n’est pas visible, choisissez Fenêtre > Hiérarchie.
      •
      Pour ajouter une page, cliquez sur l'onglet Vue de conception et choisissez Insertion > Nouvelle page.
      •
      Pour ajouter une page, dans la palette Hiérarchie, cliquez à l'aide du bouton droit sur un sous-formulaire de niveau page et choisissez Nouvelle page.


Pour supprimer une page

Vous pouvez supprimer une page par le biais du menu Insertion ou de la palette Hiérarchie.
si la palette Hiérarchie n’est pas visible, choisissez Fenêtre > Hiérarchie.
      •
      Pour supprimer une page, cliquez sur la page et choisissez Insertion > Supprimer la page.
      •
      Pour supprimer une page, dans la palette Hiérarchie, cliquez avec le bouton droit de la souris sur le sous-formulaire de niveau page qui correspond à la page et choisissez Supprimer.


Pour passer d’une page à une autre

Si votre conception de formulaire comprend plusieurs pages, vous pouvez facilement vous déplacer d'une page à l'autre à l'aide de la palette Hiérarchie ou de l'éditeur de disposition.
si la palette Hiérarchie n’est pas visible, choisissez Fenêtre > Hiérarchie.
      •
      Faites défiler le panneau Vue de conception vers le haut ou vers le bas jusqu’à la page qui vous intéresse.
      •
      Dans la palette Hiérarchie, cliquez sur la page voulue.


Pour réorganiser les pages

Si vous avez besoin de changer l'ordre des pages, vous pouvez le faire à partir de la palette Hiérarchie.
si la palette Hiérarchie n’est pas visible, choisissez Fenêtre > Hiérarchie.
1.
Dans la palette Hiérarchie, choisissez le sous-formulaire qui correspond à la page que vous voulez déplacer.
2.
Faites glisser le sous-formulaire jusqu'à une nouvelle position située sous le noeud form1.
3.
Recommencez les étapes 1 et 2 jusqu'à ce que toutes les pages soient dans l'ordre voulu.


Pour renommer une page

Il est possible de renommer une page par le biais de la palette Hiérarchie ou du panneau Page de la palette Objet. Par défaut, le nom d'un noeud de page dans la palette Hiérarchie est (Sous-formulaire sans titre) (page 1), (Sous-formulaire sans titre) (page 2), etc.
si la palette Hiérarchie n’est pas visible, choisissez Fenêtre > Hiérarchie.
      •
      Dans la palette Hiérarchie, cliquez sur le noeud de page avec le bouton droit de la souris et choisissez Renommer l'objet. Tapez un nouveau nom pour la page.
      •
      Le panneau Vue de conception étant sélectionné, cliquez à un endroit quelconque de la page, puis cliquez sur la palette Objet et tapez le nouveau nom de la page dans le panneau Liaison.


Définition des gabarits

A propos des gabarits
A quel moment faut-il ajouter un gabarit ?
Pour afficher ou masquer un gabarit
Pour ajouter un gabarit
Pour supprimer un gabarit
Pour passer d’un gabarit à un autre
Pour réorganiser les gabarits
Pour renommer un gabarit
Pour préciser la taille d'un gabarit
Pour préciser l'orientation du gabarit
Pour spécifier l'espace blanc autour des bords d'un formulaire
En-têtes, pieds de page et autres éléments d'arrière-plan
Affectation de gabarits supplémentaires aux conceptions de formulaire complexes
Pour attribuer un gabarit à une page spécifique
Exemple d'attribution d'un deuxième gabarit à une conception de formulaire
Application de gabarits à des formulaires dont le nombre de pages varie
Utilisation de gabarits avec des sous-formulaires qui se répètent
Pour utiliser une seule fois le gabarit


A propos des gabarits

Les gabarits définissent la disposition et l'arrière-plan de la conception de formulaire. Ils contiennent des objets qui figureront au même endroit dans toute la conception de formulaire. Le panneau Gabarit est masqué par défaut.
Une conception de formulaire interactif standard qui contient deux pages de dimensions différentes inclut au moins deux gabarits, un pour chaque page. Si une conception de formulaire dispose de plusieurs pages qui présentent les mêmes dimensions et la même orientation, la conception de formulaire requiert seulement un gabarit.
Vous pouvez immédiatement commencer à concevoir les pages à l'aide du gabarit par défaut. Si votre conception est plus complexe (par exemple, si vous avez besoin de créer des composants de conception tels que des en-têtes et des pieds de page), il est préférable de manipuler les composants directement sur le gabarit.
Vous pouvez placer des objets n'importe où sur un gabarit. Chaque gabarit peut avoir une conception unique que vous pouvez appliquer à une ou plusieurs pages. Les gabarits vous facilitent la tâche, car vous n'avez pas à créer une mise en page identique pour chaque page. Si plusieurs pages qui ont la même mise en page doivent aussi comporter la même série d'objets (par exemple, un pied de page standard), il est plus efficace de placer et de gérer la série d'objets sur un gabarit que de dupliquer les objets sur chacune des pages. Si les objets sont placés sur un gabarit, toutes les pages associées affichent ces objets à l'arrière-plan. La modification ultérieure du gabarit entraîne une mise à jour automatique de toutes les pages associées.
Si vous choisissez de placer des objets sur les gabarits, vous pouvez aussi ajuster les tailles et positions des zones de contenu et prévoir des fonctions simples et doubles (telles que des en-têtes et des pieds de page) à afficher sur toutes les pages.
Servez-vous du panneau Gabarit pour afficher, ajouter et supprimer des gabarits. Vous pouvez aussi renommer des gabarits et les réorganiser.
Voir aussi
Propriétés des gabarits dans le panneau Gabarit
Propriétés des gabarits dans le panneau Pagination


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Définition des pages, des gabarits et des jeux de pages > Définition des gabarits > A quel moment faut-il ajouter un gabarit ?

A quel moment faut-il ajouter un gabarit ?

En principe, il est conseillé d'ajouter des gabarits supplémentaires lorsque vous avez besoin d'insérer des pages de plusieurs tailles ou avec des orientations ou des paramètres d'impression différents.
Si le formulaire possède une disposition fixe, il suffit d'ajouter autant de pages que le formulaire doit en contenir. Si le formulaire contient des sous-formulaires prévus pour s'adapter à la taille des données fusionnées, LiveCycle Forms ajoute automatiquement des pages supplémentaires lorsque le volume de données à fusionner ne tient pas complètement sur une seule page.
lorsque vous créez une conception de formulaire pour un formulaire avec une disposition fixe qui prend en charge les données fusionnées, vous devez vous assurer que les objets ne s'étendent pas au point de dépasser la zone de contenu. En effet, des pages indésirables pourraient être ajoutées automatiquement au formulaire lors de la génération.
Une conception de formulaire peut contenir plusieurs zones de contenu. Par exemple, un gabarit peut présenter deux zones de contenu pour une mise en page sur deux colonnes. Deux gabarits de ce genre (impair et pair) sont peut-être nécessaires pour prendre en charge des pages recto-verso.
Voir aussi
Sous-formulaires par défaut
Propriétés des gabarits dans le panneau Gabarit
Propriétés des gabarits dans le panneau Pagination


Pour afficher ou masquer un gabarit

Vous disposez de plusieurs méthodes pour afficher ou masquer un gabarit.
      •
      Pour afficher le panneau Gabarit lorsqu'un autre panneau est actif, cliquez sur l'onglet Gabarit dans l’éditeur de disposition.
      •
      Pour afficher ou masquer le panneau Gabarit, choisissez Affichage > Gabarit.


Pour ajouter un gabarit

Vous pouvez ajouter un gabarit par le biais du menu Insertion ou de la palette Hiérarchie.
si la palette Hiérarchie n’est pas visible, choisissez Fenêtre > Hiérarchie.
      •
      Pour ajouter un gabarit, cliquez sur l'onglet Gabarit et choisissez Insertion > Nouveau gabarit.
      •
      Pour ajouter un gabarit, dans la palette Hiérarchie, cliquez sur le noeud Gabarit avec le bouton droit de la souris et choisissez Nouveau gabarit.


Pour supprimer un gabarit

Vous pouvez supprimer un gabarit par le biais du menu Insertion ou de la palette Hiérarchie.
si la palette Hiérarchie n’est pas visible, choisissez Fenêtre > Hiérarchie.
      •
      Pour supprimer un gabarit, cliquez sur l'onglet Gabarit, sélectionnez la zone de contenu correspondant au gabarit et choisissez Insertion > Supprimer un gabarit.
      •
      Pour supprimer un gabarit, dans la palette Hiérarchie, cliquez sur le gabarit avec le bouton droit de la souris et choisissez Supprimer.


Pour passer d’un gabarit à un autre

Si votre conception de formulaire comprend plusieurs gabarits, vous pouvez facilement vous déplacer d'un gabarit à l'autre à l'aide de la palette Hiérarchie ou de l'éditeur de disposition.
si la palette Hiérarchie n’est pas visible, choisissez Fenêtre > Hiérarchie.
      •
      Faites défiler le panneau Gabarit vers le haut ou vers le bas jusqu’à la page qui vous intéresse.
      •
      Dans la palette Hiérarchie, cliquez sur le gabarit voulu.


Pour réorganiser les gabarits

Si vous avez besoin de changer l'ordre des gabarits d'une conception de formulaire, utilisez la palette Hiérarchie.
si la palette Hiérarchie n’est pas visible, choisissez Fenêtre > Hiérarchie.
1.
Dans la palette Hiérarchie, faites glisser le gabarit vers la nouvelle position située sous le noeud Gabarits.
2.
Recommencez l'étape 1 jusqu'à ce que tous les gabarits soient dans l'ordre souhaité.


Pour renommer un gabarit

Il est possible de renommer un gabarit par le biais de la palette Hiérarchie ou du panneau Page de la palette Objet.
si la palette Hiérarchie n’est pas visible, choisissez Fenêtre > Hiérarchie.
      •
      Dans la palette Hiérarchie, cliquez sur le gabarit avec le bouton droit de la souris, choisissez Renommer l'objet, puis tapez un nouveau nom pour le gabarit.
      •
      Le panneau Gabarit étant sélectionné, cliquez à un endroit quelconque du gabarit, puis cliquez sur la palette Objet et tapez le nouveau nom du gabarit dans le panneau Gabarit.


Pour préciser la taille d'un gabarit

Dans le panneau Gabarit, vous pouvez afficher les modifications apportées à la mise en page de base d’un formulaire, y compris à la taille de page. Lorsque vous choisissez un gabarit dans la palette Hiérarchie, vous pouvez changer ses propriétés de mise en page de base dans le panneau Page de la palette Objet.
la zone de contenu définit la section dans laquelle les objets peuvent être placés sur les pages d'un formulaire. Si vous créez un formulaire contenant des sous-formulaires permettant d'enchaîner le contenu, il est préférable de définir la taille et la position de toutes les zones de contenu avant d'ajouter d'autres objets au gabarit.
1.
Dans la palette Hiérarchie, sous le noeud Gabarit, choisissez le gabarit à redimensionner.
2.
Dans la palette Objet, choisissez une taille dans la liste correspondante.
3.
Si vous sélectionnez une taille personnalisée, tapez les dimensions de page dans les zones Hauteur et Largeur.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Définition des pages, des gabarits et des jeux de pages > Définition des gabarits > Pour préciser l'orientation du gabarit

Pour préciser l'orientation du gabarit

Dans le panneau Gabarit, vous pouvez afficher les modifications apportées à la mise en page de base d’un formulaire, y compris à l'orientation de page. Lorsque vous choisissez un gabarit dans la palette Hiérarchie, vous pouvez changer ses propriétés de mise en page de base dans le panneau Page de la palette Objet.
1.
Dans la palette Hiérarchie, sous le noeud Gabarit, choisissez le gabarit dont vous souhaitez définir l'orientation.
2.
Dans la palette Objet, sélectionnez Portrait ou Paysage.
Voir aussi
Pour copier, déplacer et redimensionner une zone de contenu


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Définition des pages, des gabarits et des jeux de pages > Définition des gabarits > Pour spécifier l'espace blanc autour des bords d'un formulaire

Pour spécifier l'espace blanc autour des bords d'un formulaire

Dans un document imprimé traditionnel, une marge constitue une zone autour des bords de la page dans laquelle rien n'est imprimé. Dans des formulaires interactifs, le terme marge correspond uniquement à la zone d’espace blanc située autour de la limite intérieure des bords d’un objet.
Pour augmenter l'espace blanc autour des bords extérieurs d'un formulaire, vous devez réduire la taille de la zone de contenu sur le gabarit. Par défaut, le bord de la zone de contenu est de 0,25 pouces (0,635 cm) à partir des bords du formulaire. Pour augmenter l'espace blanc afin de placer un en-tête ou un pied de page, ou en vue d'ajustements aux limitations de d'impression, vous devez réduire la zone de contenu par défaut.
La zone délimitée par la zone de contenu détermine l'emplacement où les objets peuvent être placés sur les pages d'un formulaire. Le sous-formulaire par défaut sur une page est de la même taille que la zone de contenu par défaut sur un gabarit, et les marges du sous-formulaire par défaut sont réglées sur 0 po/cm. La modification des marges du sous-formulaire par défaut sur une page a une incidence sur l'emplacement des objets. Si vous augmentez les marges du sous-formulaire, la zone de rendu des objets du sous-formulaire diminue.
Tous les objets que vous insérez sur un gabarit s'affichent sur chacune des pages associées, que vous ayez placé ces objets à l'intérieur ou à l'extérieur de la zone de contenu. Si vous ajoutez un filigrane, vous devez placer les objets constituant le filigrane à l'intérieur de la zone de contenu.
Si vous concevez un formulaire contenant des sous-formulaires permettant d'enchaîner le contenu et que vous ne voulez pas que les objets du gabarit interfèrent avec les objets placés sur les pages, vous devez positionner les objets à l'extérieur de la zone de contenu, c'est-à-dire dans l'espace blanc que vous créez sur le gabarit. Si vous placez des objets à l'intérieur de la zone de contenu, d'autres objets peuvent être superposés aux objets du gabarit lors de la génération du formulaire.
Voir aussi
Aperçu des zones de contenu
Pour copier, déplacer et redimensionner une zone de contenu
Sous-formulaires par défaut


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Définition des pages, des gabarits et des jeux de pages > Définition des gabarits > En-têtes, pieds de page et autres éléments d'arrière-plan

En-têtes, pieds de page et autres éléments d'arrière-plan

La plupart des pages dans votre conception de formulaire requièrent un certain nombre de contenus normalisés et fixes que vous pouvez placer sur les gabarits pour homogénéiser l'arrière-plan et faciliter les modifications. Par exemple, vous pouvez disposer du texte, des images et des formes géométriques sur un gabarit de sorte qu'ils apparaissent au même emplacement sur plusieurs pages.
Si vous créez des en-têtes et des pieds de page et que vous disposez les autres éléments d'arrière-plan sur le gabarit, suivez les règles générales suivantes :
      •
      Si vous créez un formulaire contenant des sous-formulaires permettant d'enchaîner le contenu, il est préférable de définir la taille et la position de toutes les zones de contenu avant d'ajouter d'autres objets au gabarit.
      •
      Les objets peuvent être placés n'importe où sur un gabarit, à l'intérieur ou à l'extérieur de la zone de contenu. En règle générale, ne placez pas d'objets à l'intérieur d'une zone de contenu à moins que votre intention ne soit de superposer d'autres objets aux objets du gabarit lors de la génération du formulaire. Si vous définissez un filigrane, placez-le à l'intérieur d'une zone de contenu.
      •
      Vous aurez besoin d'objets de texte pour contenir du texte en lecture seule, des objets d'image ou de champ d'image afin de positionner des images (un logo, par exemple). Vous pouvez également envisager d'ajouter des objets géométriques tels que des cercles, des lignes ou des rectangles afin d'améliorer l'aspect de la conception de formulaire.
      •
      Tous les objets du gabarit s'affichent comme des objets d'arrière-plan sur les pages lors du rendu du formulaire.
Voir aussi
Pour copier, déplacer et redimensionner une zone de contenu


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Définition des pages, des gabarits et des jeux de pages > Définition des gabarits > Affectation de gabarits supplémentaires aux conceptions de formulaire complexes

Affectation de gabarits supplémentaires aux conceptions de formulaire complexes

Les gabarits définissent le format sous-jacent et l'arrière-plan des pages. Toutes les nouvelles conceptions de formulaire sont créées avec un gabarit par défaut, qui s'applique à la première page. Les pages supplémentaires sont formatées selon la disposition du gabarit par défaut, à moins que vous n'ayez prévu un gabarit différent.
Une conception de formulaire peut contenir autant de gabarits que nécessaire, chacun ayant une disposition unique. Si certaines pages requièrent des mises en forme ou des objets standard différents, vous pouvez créer un gabarit pour chaque disposition.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Définition des pages, des gabarits et des jeux de pages > Définition des gabarits > Pour attribuer un gabarit à une page spécifique

Pour attribuer un gabarit à une page spécifique

1.
Sélectionnez le sous-formulaire à l'aide de l'une des méthodes suivantes :
      •
      Dans le panneau Vue de conception, sélectionnez le sous-formulaire par défaut sur la page.
      •
      Dans la palette Hiérarchie, sélectionnez le sous-formulaire qui correspond à la page.
2.
Cliquez sur l'onglet Pagination dans la palette Objet et, dans la liste des positions, choisissez À la page > [ page ], où [ page ] désigne le nom du gabarit que vous voulez utiliser.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Définition des pages, des gabarits et des jeux de pages > Définition des gabarits > Exemple d'attribution d'un deuxième gabarit à une conception de formulaire

Exemple d'attribution d'un deuxième gabarit à une conception de formulaire

L'exemple suivant décrit étape par étape la procédure à suivre pour attribuer un second gabarit à une page dans une conception de formulaire interactif ou avec une disposition fixe.
Cette conception de formulaire contient deux pages et deux gabarits. Le premier gabarit a une orientation Portrait, tandis que le second a une orientation Paysage.
1.
Cliquez sur l'onglet Vue de conception.
2.
Sélectionnez le sous-formulaire sur la page 2.
3.
Cliquez sur l'onglet Sous-formulaire dans la palette Objet et, dans la liste des positions, choisissez À la page > [ page ], où [ page ] désigne le nom du gabarit 2.
Ainsi, la mise en page du gabarit 2 est attribuée à la page 2 qui a maintenant une mise en page de type Paysage.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Définition des pages, des gabarits et des jeux de pages > Définition des gabarits > Application de gabarits à des formulaires dont le nombre de pages varie

Application de gabarits à des formulaires dont le nombre de pages varie

Les formulaires contenant des sous-formulaires permettant d'enchaîner le contenu ont un nombre de pages variable. Lors du rendu du formulaire, les objets sont placés à l'intérieur des zones de contenu et, si les données remplissent la zone de contenu, un saut de page a lieu automatiquement. Par défaut, le format du gabarit par défaut est attribué à toutes les pages.
Si plusieurs gabarits sont disponibles, chaque gabarit peut influer sur le formatage des pages. Dans ce cas, la mise en page d'un gabarit est appliquée lors du rendu du sous-formulaire qui lui est associé. Ceci signifie que si le sous-formulaire est généré en page 2 du formulaire, le format du gabarit attribué est appliqué à la page 2.
Vous pouvez limiter le nombre d'applications d'un gabarit. Par exemple, vous pouvez limiter un gabarit à la première page sur laquelle un sous-formulaire est rendu. Toute page supplémentaire est formatée à condition que la mise en page du gabarit suivant soit autorisée un nombre de fois illimité. La nature du type de formulaire doit indiquer l'option à utiliser.
Par exemple, un ordre de paiement peut comporter des informations relatives à la société et aux employés sur la première page. Les pages suivantes comportent très peu d'informations relatives à la société et aux employés, et de nombreuses informations relatives aux cartes de pointage. Vous pourriez définir deux gabarits. Le premier gabarit commencerait par le logo et les coordonnées de la société, à l'extérieur de la zone de contenu. Viendrait ensuite une petite zone de contenu, destinée à recevoir les informations sur les employés. Le second gabarit présenterait une zone de contenu plus grande, couvrant éventuellement toute la page, destinée à recevoir les informations relatives aux cartes de pointage.
Dans ce cas, pour que l'attribution des gabarits s'effectue correctement, le premier gabarit requiert une seule occurrence de page au minimum et au maximum, car il ne se produit jamais plus d'une fois. Pour les gabarits, la valeur par défaut de Min. de répétitions est 0, alors que celle de Max. de répétitions est -1. Pour le deuxième gabarit, la mise en page peut être générée sur une page un nombre de fois illimité.
Voir aussi
A propos des pages


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Définition des pages, des gabarits et des jeux de pages > Définition des gabarits > Utilisation de gabarits avec des sous-formulaires qui se répètent

Utilisation de gabarits avec des sous-formulaires qui se répètent

Si vous disposez d'un sous-formulaire qui se répète dont la taille requiert l'utilisation de plusieurs pages consécutives, vous pouvez affecter un gabarit différent à n'importe quelle page apparaissant après la première page du formulaire. Par exemple, le sous-formulaire peut commencer au milieu de la première page du formulaire. Pour le faire commencer en haut des pages suivant la première page, vous devez créer un autre gabarit.
Lorsque vous indiquez 1 comme nombre maximal, le premier gabarit ne s'imprime qu'une fois. Lorsque la première page est remplie de données, LiveCycle Designer utilise automatiquement le deuxième gabarit à la suite et continue de placer les données en débordement.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Définition des pages, des gabarits et des jeux de pages > Définition des gabarits > Pour utiliser une seule fois le gabarit

Pour utiliser une seule fois le gabarit

1.
Dans la palette Hiérarchie, cliquez sur le premier gabarit, Page1.
2.
Cliquez sur la palette Objet et procédez comme suit :
      •
      Cochez la case Restreindre les occurrences de page.
      •
      Cochez la case Max., puis tapez 1 dans la zone correspondante.
3.
Enregistrez la conception de formulaire.
Voir aussi
A quel moment faut-il ajouter un gabarit ?
A propos des pages


Définition des jeux de pages

A propos des jeux de pages
Pour passer d'un jeu de pages à un autre
Pour ajouter ou supprimer un jeu de pages
Pour réorganiser les jeux de pages
Pour renommer un jeu de pages


A propos des jeux de pages

Les jeux de pages contrôlent l'ordre, les paramètres d'impression, les occurrences et la visibilité des pages dans la conception de formulaire. Toutes les conceptions de formulaire contiennent au moins un jeu de pages.
Les jeux de pages sont le plus souvent utilisés pour créer des formulaires contenant des sous-formulaires permettant d'enchaîner le contenu, car ils permettent d'indiquer l'ordre de génération des pages dans le formulaire, ainsi que leur occurrence. Par exemple, vous souhaitez créer une conception de formulaire pour générer un formulaire brut et de pré-impression. Un formulaire de pré-impression est un formulaire imprimé sur une feuille de papier qui a déjà été utilisée pour des impressions. Un formulaire brut est un formulaire imprimé sur du papier blanc.
Pour cet exemple, vous créez cinq gabarits combinés en jeux de pages :
Gabarit1
Le titre de la page qui apparaît une seule fois.
Gabarit2
Le papier sur lequel le formulaire de pré-impression est imprimé contient le logo de la société et ses coordonnées. Ce gabarit laisse de l'espace aux informations situées hors de la zone de contenu. Vient ensuite une petite zone de contenu, destinée à recevoir les informations sur les employés. Il n'apparaît qu'une seule fois sur le formulaire de pré-impression.
Gabarit3
Il dispose d'une zone de contenu plus grande, s'étendant éventuellement sur la page entière, afin d'accueillir plus d'informations. Il est utilisé pour la deuxième page et les pages suivantes du formulaire de pré-impression. Il apparaît de 0 à un nombre de fois illimité.
Gabarit4
Il contient le logo de la société et ses coordonnées en premier lieu, hors de la zone de contenu. Vient ensuite une petite zone de contenu, destinée à recevoir les informations sur les employés. Il n'apparaît qu'une seule fois sur le formulaire brut.
Gabarit5
Il dispose d'une zone de contenu plus grande, s'étendant éventuellement sur la page entière, afin d'accueillir plus d'informations. Il est utilisé pour la deuxième page et les pages suivantes du formulaire brut. Il apparaît de 0 à un nombre de fois illimité.
Les gabarits sont rassemblés en groupes de pages comme le montre cette illustration :
Le formulaire est généré en fonction de l'ordre des jeux de pages dans la hiérarchie :
      •
      Le premier sous-formulaire est toujours placé sur le Gabarit1.
      •
      Le sous-formulaire suivant est placé sur le Gabarit2 et sur le Gabarit3 si le formulaire est une pré-impression, ou sur le Gabarit4 et le Gabarit5 s'il s'agit d'un formulaire brut.
Voir aussi
A propos des pages
A propos de l'aperçu et des tests de formulaires
Propriétés des jeux de pages dans le panneau Jeu de pages


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Définition des pages, des gabarits et des jeux de pages > Définition des jeux de pages > Pour passer d'un jeu de pages à un autre

Pour passer d'un jeu de pages à un autre

      *
      Dans la palette Hiérarchie, cliquez sur le jeu de pages.
si la palette Hiérarchie n’est pas visible, choisissez Fenêtre > Hiérarchie.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Définition des pages, des gabarits et des jeux de pages > Définition des jeux de pages > Pour ajouter ou supprimer un jeu de pages

Pour ajouter ou supprimer un jeu de pages

      •
      Pour ajouter un jeu de pages, dans la palette Hiérarchie, cliquez sur le noeud Gabarit avec le bouton droit de la souris et choisissez Insérer un jeu de pages.
      •
      Pour supprimer un jeu de pages, dans la palette Hiérarchie, cliquez sur le jeu de pages avec le bouton droit de la souris et choisissez Supprimer.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Définition des pages, des gabarits et des jeux de pages > Définition des jeux de pages > Pour réorganiser les jeux de pages

Pour réorganiser les jeux de pages

1.
Dans la palette Hiérarchie, faites glisser le jeu de pages vers la nouvelle position située sous le noeud Gabarit.
2.
Recommencez l'étape 1 jusqu'à ce que tous les jeux de pages soient dans l'ordre souhaité.


Pour renommer un jeu de pages

1.
Dans la palette Hiérarchie, cliquez sur le jeu de pages avec le bouton droit de la souris et choisissez Renommer l'objet.
2.
Indiquez le nouveau nom du jeu de pages.
vous pouvez aussi renommer le jeu sélectionné via le panneau correspondant dans la palette Objet.


Définition de l'ordre de tabulation

A propos de l'ordre de tabulation
Fonctionnement de l'ordre de tabulation
Pour définir l'ordre de tabulation
Pour changer l'ordre de tabulation à l'aide de la souris
Pour changer l'ordre de tabulation à l'aide des raccourcis clavier


A propos de l'ordre de tabulation

Les utilisateurs se servent généralement de la touche de tabulation pour se déplacer d'un champ et d'un bouton à un autre au lieu d'utiliser la souris. LiveCycle Designer permet de définir l'ordre de tabulation entre les objets d'un formulaire.
L'ordre de tabulation est important aussi bien pour les formulaires interactifs que pour les formulaires avec une disposition fixe. Dans le cas de formulaires interactifs, l’ordre de tabulation varie en fonction de l’expérience de l’utilisateur qui remplit le formulaire.
Qu'il s'agisse de formulaires interactifs ou non interactifs, l'ordre de tabulation est essentiel si vos formulaires doivent être accessibles aux utilisateurs ayant une mobilité réduite ou une déficience visuelle. Ces utilisateurs n'utilisent généralement pas la souris pour naviguer dans un formulaire. Ils dépendent donc des touches du clavier, et seule une séquence d'ordre de tabulation correcte peut leur garantir un accès à tous les champs du formulaire.
Les formulaires accessibles requièrent un ordre de tabulation spécifique, que le formulaire soit interactif ou destiné à être imprimé. En outre, un lecteur d'écran lit le formulaire de manière géographique. LiveCycle Designer peut être configuré pour cela lorsque vous utilisez l'ordre de tabulation par défaut.
Voir aussi
Fonctionnement de l'ordre de tabulation
Ordre de tabulation dans les formulaires accessibles


Fonctionnement de l'ordre de tabulation

Dans un formulaire, l'ordre de tabulation par défaut lit les objets de gauche à droite et de haut en bas, à partir du coin supérieur gauche. L'ordre de tabulation tient compte de l'existence de sous-formulaires, de boutons radio et de zones de contenu. Par exemple, si deux sous-formulaires sont placés côte à côte et que chaque sous-formulaire contient un certain nombre d'objets de champ, la séquence de tabulation passe par les champs du premier sous-formulaire avant de passer à ceux du second.
LiveCycle Designer n'inclut pas les objets tels que les cercles, les lignes ou les rectangles dans l'ordre de tabulation.
L'ordre de tabulation est également déterminé par la position verticale des objets sur une page et son gabarit.
L'ordre de tabulation commence par l'objet doté de la plus petite coordonnée verticale et se termine par l'objet dont la coordonnée verticale est la plus grande, que l'objet se trouve sur la page ou sur le gabarit.
Dans le cas d'objets imbriqués dans d'autres objets, tels que les zones de contenu, l'ordre de tabulation passe par tous les objets enfant avant d'atteindre l'objet de niveau supérieur.
La liste suivante présente un exemple d'ordre de tabulation d'objets situés sur des pages et des gabarits :
      •
      Objet d'image sur le gabarit doté d'une coordonnée verticale de 1.
      •
      Objet de zone de contenu sur la page doté d'une coordonnée verticale de 4. La tabulation passe par tous les objets de la zone de contenu avant d'atteindre l'objet de sous-formulaire du gabarit.
      •
      Objet de sous-formulaire sur le gabarit doté d'une coordonnée verticale de 10. La tabulation passe par tous les objets de la zone de contenu avant d'atteindre l'objet de texte du gabarit.
      •
      Objet de texte sur le gabarit doté d'une coordonnée verticale de 12.
Etant donné que l'ordre de tabulation est important, veillez à positionner les objets avec précision sur le formulaire, les uns par rapport aux autres. Par exemple, vous pouvez positionner et redimensionner un objet en utilisant ses coordonnées et aligner des objets sur des points d'une grille.
Vous pouvez changer l'ordre de tabulation par défaut si vous avez besoin d'une séquence différente pour votre formulaire. Par exemple, rien ne vous empêche de changer l'ordre de tabulation pour passer d'un objet à l'autre dans une colonne, de haut en bas, puis de gauche à droite.
dans Acrobat 6.0, l'accès à un groupe de boutons radio au moyen de la touche de tabulation active systématiquement le bouton radio situé dans le coin supérieur gauche. Utilisez cette même touche pour vous déplacer parmi les boutons radio. Dans Acrobat 7.0, le bouton radio sélectionné est activé. Utilisez alors les touches de direction fléchées pour vous déplacer parmi les boutons radio d'un groupe et la touche de tabulation pour sortir du groupe.
Voir aussi
Pour définir l'ordre de tabulation
Pour définir la position des objets
Pour utiliser les accessoires de dessin


Pour définir l'ordre de tabulation

L'une des dernières tâches à effectuer une fois que vous avez créé un formulaire consiste à définir l'ordre de tabulation. Tant que vous n'avez pas terminé de définir la disposition de la conception de formulaire, les objets sont susceptibles de bouger. Il est donc préférable d'attendre qu'elle soit terminée pour définir l'ordre de tabulation.
si vous définissez l'ordre de tabulation d'un formulaire utilisé comme modèle, tout formulaire créé à partir de ce dernier fera appel au même ordre de tabulation.
1.
Choisissez Affichage >Ordre de tabulation. La page montre l'ordre de tabulation actuel.
Dans l'exemple du bon de commande, modifiez l'ordre de tabulation de sorte que les informations Commandé par arrivent avant les informations Livré à dans la séquence de tabulation.
2.
Cliquez sur l'image de société Finance pour la désigner comme premier objet dans l'ordre de tabulation. Le chiffre 1 apparaît sur l'objet.
3.
Cliquez sur le titre Bon de commande pour le désigner comme second objet dans l'ordre de tabulation. Le chiffre 2 apparaît sur l'objet.
4.
Cliquez sur le reste des champs dans l'ordre suivant : N° du bon de commande, Date, Commandé par, Téléphone, Télécopie, Contact, Livré à, Téléphone, Télécopie, Contact.
5.
Pour revenir au mode de conception normal et désactiver l'affichage de l'ordre de tabulation, choisissez Affichage > Ordre de tabulation.
6.
Enregistrez la conception de formulaire.


Pour changer l'ordre de tabulation à l'aide de la souris

1.
Choisissez l'une des méthodes suivantes :
      •
      Si la conception de formulaire n'indique pas d'ordre de tabulation, choisissez Affichage >Ordre de tabulation.
      •
      Si l'ordre de tabulation s'affiche actuellement à l'écran, choisissez Affichage > Ordre de tabulation pour le désélectionner. Choisissez de nouveau Ordre de tabulation.
2.
Cliquez sur le champ qui doit porter le numéro 1. L'ordre de tabulation est modifié de sorte que le champ actuel devient l'objet numéro 1. Les champs restants sont numérotés à partir du champ auquel le numéro 1 était affecté jusqu'à présent.
3.
Pour continuer à modifier l'ordre de tabulation, cliquez sur le reste des champs pour établir la séquence voulue.
4.
Pour revenir au mode de conception normal et désactiver l'affichage de l'ordre de tabulation, choisissez Affichage > Ordre de tabulation.


Pour changer l'ordre de tabulation à l'aide des raccourcis clavier

      •
      Pour spécifier l'emplacement où l'ordre de tabulation doit être modifié, cliquez sur le champ voulu dans la conception de formulaire en maintenant la touche Ctrl enfoncée.
      •
      Pour préciser un nouveau numéro 1 dans l'ordre de tabulation, cliquez sur le champ voulu en maintenant la touche Maj enfoncée.
      •
      Pour abandonner ce champ dans l'ordre de tabulation, cliquez sur le champ tout en maintenant la touche Maj enfoncée. Cela permet de revenir à l'ordre géographique et de partager la séquence en deux si le champ figurait au milieu de la séquence.
      •
      Pour enregistrer les changements et quitter le mode Ordre de tabulation, appuyez sur la touche Entrée.
      •
      Pour ignorer les changements effectués au cours de la session actuelle du mode Ordre de tabulation, appuyez sur la touche Echap. Cela permet aussi de quitter le mode Ordre de tabulation.
Voir aussi
Utilisation du clavier


Vérification orthographique dans les formulaires

Pour sélectionner le paramètre régional par défaut
Pour vérifier l'orthographe en cours de frappe
Pour vérifier l'orthographe dans un formulaire
Pour ajouter un mot à toutes les version linguistiques du dictionnaire personnel
Pour ajouter un mot aux langues sélectionnées du dictionnaire personnel
Pour modifier le dictionnaire personnel
Ajout d'un mot à la liste de mots ignorés
Pour ajouter un dictionnaire
Pour supprimer un dictionnaire


Pour sélectionner le paramètre régional par défaut

Avant de procéder à la vérification orthographique d'un formulaire, vous devez vous assurer que le paramètre régional approprié est sélectionné. L'option sélectionnée dans la liste Paramètre régional par défaut du formulaire de la boîte de dialogue Propriétés du formulaire indique la langue par défaut qu'utilise LiveCycle Designer pour la vérification orthographique. Pour référence, la langue actuellement prise en compte s'affiche dans le coin supérieur droit de la boîte de dialogue Vérifier l'orthographe, juste sous la barre de titre.
Si vous appliquez différents paramètres régionaux à des objets du formulaire à l'aide de la liste Paramètre régional dans la palette Objet, ces paramètres remplacent le paramètre régional défini par défaut pour le formulaire. Par conséquent, si le paramètre régional concernant un objet est différent du paramètre régional défini pour le formulaire, LiveCycle Designer identifie les termes (texte) associés à ces objets comme étant mal orthographiés.
Si vous appliquez des paramètres régionaux différents à des objets, rappelez-vous que les objets figurant dans les tableaux et les sous-formulaires dépendent automatiquement du même paramètre régional que celui défini pour l'objet de tableau et de sous-formulaire.
si vous sélectionnez un paramètre régional (langue) que la fonction de vérification orthographique ne prend pas en charge, un message s'affiche vous indiquant que l'orthographe des objets associés à ce paramètre régional ne pourra pas être examinée.
1.
Choisissez Fichier > Propriétés du formulaire.
2.
Cliquez sur l'onglet Valeurs par défaut et sélectionnez la langue de la vérification orthographique dans la liste Paramètre régional par défaut du formulaire.
3.
Cliquez sur OK.
Voir aussi
Pour vérifier l'orthographe en cours de frappe
Pour vérifier l'orthographe dans un formulaire
Boîte de dialogue Propriétés du formulaire


Pour vérifier l'orthographe en cours de frappe

Vous pouvez configurer LiveCycle Designer de manière à ce qu'il identifie les fautes d'orthographe en cours de saisie, en choisissant l'option Vérifier l'orthographe en cours de frappe dans le panneau Orthographe de la boîte de dialogue Options.
Si l'option Vérifier l'orthographe en cours de frappe est sélectionnée, une ligne rouge ondulée s'affiche sous les mots mal orthographiés dans les objets de texte statique, les champs de légende ou les différents champs des palettes Objet et Accessibilité, quelles que soient les options sélectionnées. Utilisez les options de la liste Orthographe pour spécifier le type de texte à examiner lorsque vous procédez à partir de la boîte de dialogue Vérifier l'orthographe.
Lorsque vous vérifiez l'orthographe dans un formulaire, LiveCycle Designer se réfère toujours à un dictionnaire interne ainsi qu'à votre dictionnaire personnalisé (Mon dictionnaire personnel). Vous pouvez également ajouter d'autres fichiers de dictionnaires personnalisés (*.clam) pour étoffer la liste des mots corrects à laquelle LiveCycle Designer se reporte. Pour plus de détails, voir Ajout d'un mot à la liste de mots ignorés.
pour consulter la liste des dictionnaires actuellement disponibles, choisissez Outils > Options, puis cliquez sur Orthographe. Le panneau Orthographe affiche la liste des dictionnaires installés. Notez que Mon dictionnaire personnel est sélectionné en permanence et ne peut pas être supprimé.
Tenez compte des éléments suivants lorsque vous vérifiez l'orthographe en cours de frappe :
      •
      Une ligne rouge ondulée s'affiche sous les mots mal orthographiés dans les objets de texte statique et les champs de légendes à condition que le point d'insertion (barre clignotante verticale utilisée pour saisir le texte) ne soit pas à l'intérieur du mot ou directement à côté.
      •
      Vous pouvez changer la couleur de la ligne ondulée en choisissant Outils > Options > Orthographe > Couleur du soulignement en ondulé.
      •
      LiveCycle Designer propose, au maximum, quatre corrections dans le menu contextuel pour chaque mot mal orthographié. Pour afficher davantage de propositions, utilisez la boîte de dialogue Vérifier l'orthographe.
1.
Pour configurer LiveCycle Designer de manière à ce qu'il identifie les erreurs en cours de frappe, choisissez Outils > Options et, dans le panneau Orthographe, sélectionnez Vérifier l'orthographe en cours de frappe.
2.
Pour corriger une faute d'orthographe en cours de frappe, placez le point d'insertion à l'intérieur du mot souligné ou directement à côté, cliquez avec le bouton droit de la souris et procédez de l'une des manières suivantes :
      •
      Pour corriger le mot mal orthographié, sélectionnez un des mots suggérés dans le menu contextuel. Si aucun terme n'est proposé, (aucune suggestion de correction) s'affiche à la place.
      •
      Pour ajouter le mot au dictionnaire personnel, sélectionnez Ajouter au dictionnaire. Le mot souligné est alors ajouté à toutes les versions linguistiques du dictionnaire. LiveCycle Designer ne considérera plus ce mot comme étant mal orthographié.
      •
      Pour ignorer toutes les occurrences d'un mot prétendument mal orthographié, sélectionnez Ignorer tout. Cette sélection permet d'ajouter le mot en question à la liste des mots ignorés. LiveCycle Designer ne considère pas, pour le moment, que le mot est erroné. Toutes les opérations de vérification orthographique ignorent ce mot tant que vous ne redémarrez pas LiveCycle Designer. La liste des mots ignorés est vidée à chaque exécution de LiveCycle Designer.
Voir aussi
Pour sélectionner le paramètre régional par défaut
Pour vérifier l'orthographe dans un formulaire
Pour modifier le dictionnaire personnel
Boîte de dialogue Options


Pour vérifier l'orthographe dans un formulaire

Vous pouvez rechercher les fautes d'orthographe dans le texte des objets sélectionnés ou dans l'ensemble du formulaire à l'aide de la boîte de dialogue Vérifier l'orthographe.
Par défaut, LiveCycle Designer vérifie l'orthographe de l'ensemble du texte associé aux différents objets figurant dans le formulaire, c'est-à-dire le texte statique, les légendes, les info-bulles, le texte de lecteur d'écran personnalisé et les entrées de liste déroulante. Cependant, vous pouvez définir le type de texte examiné par LiveCycle Designer en sélectionnant des options dans la liste Othographe proposée dans le panneau Orthographe de la boîte de dialogue Options. Si vous activez les options Texte statique et Légendes, vous pouvez également sélectionner un texte statique ou une légende spécifique à vérifier dans le formulaire. Si ces deux options ne sont pas activées, LiveCycle Designer ne vérifie par l'orthographe de tout objet de texte statique ou de tout champ de légende sélectionné.
Lorsque vous vérifiez l'orthographe dans un formulaire, LiveCycle Designer se réfère toujours à un dictionnaire interne ainsi qu'à votre dictionnaire personnalisé (Mon dictionnaire personnel). Vous pouvez également ajouter d'autres fichiers de dictionnaires personnalisés (*.clam) pour étoffer la liste des mots corrects à laquelle LiveCycle Designer se reporte. Pour plus de détails, voir Ajout d'un mot à la liste de mots ignorés.
pour consulter la liste des dictionnaires actuellement disponibles, choisissez Outils > Options, puis cliquez sur Orthographe. Le panneau Orthographe affiche la liste des dictionnaires installés. Notez que Mon dictionnaire personnel est sélectionné en permanence et ne peut pas être supprimé.
1.
(Facultatif) Si vous voulez vérifier l'orthographe des objets de texte ou des champs de légende spécifiques, appuyez sur la touche Ctrl et sélectionnez les objets appropriés.
2.
Choisissez Outils > Vérifier l'orthographe. La boîte de dialogue Vérifier l'orthographe apparaît et indique le premier mot dont l'orthographe est incorrecte en rouge sous Pas dans le dictionnaire.
3.
Pour corriger les fautes d'orthographe, effectuez l'une des opérations suivantes :
      •
      Pour corriger le mot incorrect, sélectionnez un des mots répertoriés dans la liste Suggestions, puis cliquez sur Remplacer pour remplacer cette occurrence du mot ou sur Remplacer tout pour rectifier toutes les occurrences du mot mal orthographié. Si le mot correct souhaité ne se trouve pas dans la liste des propositions, saisissez l'orthographe appropriée dans la boîte de dialogue Vérifier l'orthographe, puis cliquez sur Remplacer ou sur Remplacer tout, selon le cas.
      •
      Pour ignorer une occurrence particulière d'un mot mal orthographié, cliquez sur Ignorer cette fois.
      •
      Pour ignorer toutes les occurrences d'un mot signalé comme étant incorrect, cliquez sur Ignorer tout. Cette sélection permet d'ajouter le mot en question à la liste des mots ignorés. LiveCycle Designer ne considère pas, pour le moment, que le mot est erroné. Toutes les opérations de vérification orthographique ignorent ce mot tant que vous ne redémarrez pas LiveCycle Designer. La liste des mots ignorés est vidée à chaque exécution de LiveCycle Designer.
      •
      Pour ajouter le mot au dictionnaire personnel, cliquez sur Ajouter au dictionnaire. Le mot en surbrillance est alors ajouté à toutes les versions linguistiques de Mon dictionnaire personnel. LiveCycle Designer ne considérera plus ce mot comme étant mal orthographié.
Après avoir corrigé une faute d'orthographe, la boîte de dialogue Vérifier l'orthographe passe automatiquement au mot erroné suivant. Un message s'affiche dès que LiveCycle Designer a terminé la vérification orthographique.
Voir aussi
Pour modifier le dictionnaire personnel
Boîte de dialogue Vérifier l'orthographe
Boîte de dialogue Options


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Vérification orthographique dans les formulaires > Pour ajouter un mot à toutes les version linguistiques du dictionnaire personnel

Pour ajouter un mot à toutes les version linguistiques du dictionnaire personnel

Lorsque vous vérifiez l'orthographe d'un formulaire, LiveCycle Designer peut identifier un mot comme étant mal orthographié alors qu'il ne l'est pas en réalité. Par exemple, LiveCycle Designer ne reconnaît généralement pas les noms de produit et les acronymes propres à un secteur d'activité ou à une société. LiveCycle Designer fournit à chaque utilisateur un dictionnaire personnalisé (Mon dictionnaire personnel) dans lequel il est possible d'établir une liste personnalisée de mots correctement orthographiés. Mon dictionnaire personnel se trouve sous Dictionnaires installés dans le panneau Orthographe de la boîte de dialogue Options et est toujours sélectionné par défaut. LiveCycle Designer se réfère à Mon dictionnaire personnel dès que vous vérifiez l'orthographe d'un formulaire, par conséquent vous ne pouvez pas le supprimer.
Les mots que vous ajoutez au dictionnaire personnel sont automatiquement ajoutés à toutes les langues (paramètres régionaux). LiveCycle Designer considère que l'orthographe du mot est correcte, quelle que soit la langue actuellement appliquée au formulaire ou à un objet sélectionné. Toutefois, si le mot à insérer dans le dictionnaire personnel n'est pas compréhensible dans toutes les langues, vous pouvez utiliser la boîte de dialogue Modifier le dictionnaire afin d'ajouter le mot aux langues voulues. Après avoir ajouté un mot dans le dictionnaire personnel, LiveCycle Designer reconnaît l'orthographe du mot comme étant correcte et enlève la ligne rouge ondulée sous le mot.
      *
      Cliquez avec le bouton droit de la souris sur le mot non reconnu et sélectionnez Ajouter au dictionnaire.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Vérification orthographique dans les formulaires > Pour ajouter un mot aux langues sélectionnées du dictionnaire personnel

Pour ajouter un mot aux langues sélectionnées du dictionnaire personnel

Si le mot à inclure dans le dictionnaire personnalisé (Mon dictionnaire personnel) n'est pas compréhensible dans toutes les langues, vous pouvez utiliser la boîte de dialogue Modifier le dictionnaire afin d'ajouter le mot aux langues voulues. Après avoir ajouté un mot dans Mon dictionnaire personnel, LiveCycle Designer reconnaît l'orthographe du mot comme étant correcte pour la langue déterminée et enlève la ligne rouge ondulée sous le mot.
1.
Choisissez Outils > Modifier le dictionnaire.
2.
Dans la liste Langue, sélectionnez la langue de votre choix.
3.
Dans la zone Mot, tapez l'orthographe correcte du mot à ajouter.
4.
Cliquez sur Ajouter.
5.
Recommencez ces étapes pour ajouter le mot dans une autre langue, si nécessaire.
Voir aussi
Pour ajouter un mot à toutes les version linguistiques du dictionnaire personnel
Pour modifier le dictionnaire personnel
Boîte de dialogue Modifier le dictionnaire


Pour modifier le dictionnaire personnel

De temps à autre, vous pouvez être amené à apporter des modifications au dictionnaire personnalisé (Mon dictionnaire personnel) ou à examiner son contenu. Dans la boîte de dialogue Modifier le dictionnaire, vous pouvez sélectionner des options dans la liste Langue afin de passer en revue les mots associés à l'ensemble des langues ou à des langues particulières. Vous avez également la possibilité de rectifier l'orthographe de tout mot répertorié, d'ajouter des mots pour des langues sélectionnées ou toutes les langues et de supprimer les mots pour toutes les langues ou certaines d'entre-elles.
      *
      Pour ouvrir la boîte de dialogue Modifier le dictionnaire, choisissez Outils > Modifier le dictionnaire.
Voir aussi
Pour ajouter un mot à toutes les version linguistiques du dictionnaire personnel
Pour ajouter un mot aux langues sélectionnées du dictionnaire personnel
Boîte de dialogue Options
Boîte de dialogue Modifier le dictionnaire


Ajout d'un mot à la liste de mots ignorés

Parfois, LiveCycle Designer peut identifier un mot comme étant mal orthographié alors qu'il ne l'est pas en réalité. Cependant, en pareil cas, il se peut que vous ne vouliez pas inclure le mot en question dans votre dictionnaire personnel. Vous pouvez ainsi établir une liste de mots que LiveCycle Designer ignore lors de la vérification orthographique d'un document. LiveCycle Designer considère alors que l'orthographe des mots ignorés n'est ni correcte, ni incorrecte et ne les examine pas au cours de la vérification orthographique.
Vous ne pouvez pas afficher ou modifier la liste des mots ignorés. Par conséquent, il vaut mieux se souvenir des mots ajoutés. La liste des mots ignorés reste en vigueur tant que vous ne quittez pas LiveCycle Designer. A chaque initialisation de LiveCycle Designer, cette liste est vidée.
Vous pouvez insérer rapidement un mot à la liste des mots ignorés tout en saisissant du texte dans un champ d'un formulaire ou dans les palettes Objet ou Hiérarchie à l'aide des commandes du menu contextuel (accès par le bouton droit de la souris). Les boutons de la boîte de dialogue Vérifier l'orthographe vous permettent également d'inclure un mot à la liste lors de la vérification orthographique d'un formulaire.
Pour ajouter un mot à la liste des mots ignorés en cours de frappe
      •
      Cliquez avec le bouton droit de la souris sur le mot mal orthographié d'un champ dans un formulaire ou dans la palette Objet ou Hiérarchie et sélectionnez Ignorer tout. LiveCycle Designer ignore temporairement toutes les occurrences du mot, c'est-à-dire jusqu'au prochain redémarrage de LiveCycle Designer.
Pour ajouter un mot à la liste des mots ignorés lors de la vérification orthographique d'un formulaire
1.
Choisissez Outils > Vérifier l'orthographe. La boîte de dialogue Vérifier l'orthographe apparaît et indique le premier mot dont l'orthographe est incorrecte en rouge sous Pas dans le dictionnaire.
2.
Effectuez l'une des opérations suivantes :
      •
      Pour ignorer uniquement l'occurrence actuelle du mot comportant une faute, cliquez sur Ignorer cette fois. LiveCycle Designer n'examine pas le mot et recherche la faute d'orthographe suivante.
      •
      Pour ignorer toutes les occurrences du mot mal orthographié, cliquez sur Ignorer tout. LiveCycle Designer ignore toutes les instances du mot incriminé et affiche la faute d'orthographe suivante. Les vérifications orthographiques suivantes ne tiennent pas compte du mot incorrect tant que vous ne relancez pas LiveCycle Designer. La liste des mots ignorés est vidée à chaque exécution de LiveCycle Designer.
Voir aussi
Pour ajouter un mot aux langues sélectionnées du dictionnaire personnel
Pour modifier le dictionnaire personnel
Boîte de dialogue Vérifier l'orthographe
Boîte de dialogue Modifier le dictionnaire


Pour ajouter un dictionnaire

Si vous voulez augmenter la liste des mots correctement orthographiés utilisée par LiveCycle Designer au cours de la vérification orthographique d'un formulaire, vous pouvez ajouter un ou plusieurs fichiers dictionnaires personnalisés (*.clam) pour une langue donnée ou pour toutes les langues prises en charge. Vous pouvez ainsi ajouter un dictionnaire personnalisé rassemblant des termes propres à des domaines spécialisés tels que la médecine, le droit, l'ingénierie, les assurances ou la finance.
Si vous voulez insérer des termes dans un fichier dictionnaire personnalisé pour une langue donnée et non pour toutes les langues, vous devez inclure l'extension de la langue appropriée dans le nom du fichier de dictionnaire personnalisé. Ainsi, si vous voulez ajouter un fichier dictionnaire personnalisé en français canadien exclusivement, vous devez faire suivre le nom du fichier de l'extension fr_CA : [nom du fichier]-fr_CA.clam. Si vous n'insérez pas d'extension de langue dans le nom de fichier, les mots seront considérés comme corrects, quelle que soit la langue utilisée.
Vous pouvez utiliser les options du panneau Orthographe de la boîte de dialogue Options pour ajouter des dictionnaires et sélectionner ceux qui serviront de référence au cours des vérifications orthographiques.
1.
Choisissez Outils > Options.
2.
Sélectionnez Orthographe dans la liste située à gauche, puis cliquez sur Ajouter un dictionnaire. La boîte de dialogue Fichier de dictionnaire personnalisé s'affiche.
3.
Recherchez le fichier de dictionnaire à ajouter à LiveCycle Designer, puis cliquez sur Ouvrir. Le dictionnaire est inclus à la liste des dictionnaires installés.
Voir aussi
Pour supprimer un dictionnaire
Pour modifier le dictionnaire personnel
Boîte de dialogue Options
Boîte de dialogue Modifier le dictionnaire


Pour supprimer un dictionnaire

La liste des dictionnaires installés du panneau Orthographe de la boîte de dialogue Options présente les dictionnaires actuellement disponibles pour la vérification orthographique d'un formulaire. Vous pouvez supprimer un ou plusieurs dictionnaires personnalisés que vous jugez inutiles. Lorsque vous supprimez un dictionnaire personnalisé, il est retiré de la liste des dictionnaires installés. Le fichier de dictionnaire (*.clam) n'est pas physiquement supprimé du système de fichiers de l'ordinateur.
vous ne pouvez pas supprimer Mon dictionnaire personnel, car LiveCycle Designer utilise toujours ce dictionnaire lorsqu'il contrôle l'orthographe d'un formulaire.
1.
Choisissez Outils > Options.
2.
Dans le panneau Orthographe, sélectionnez le dictionnaire à retirer de la liste Dictionnaires installés.
3.
Cliquez sur Supprimer un dictionnaire.
Voir aussi
Ajout d'un mot à la liste de mots ignorés
Pour modifier le dictionnaire personnel
Boîte de dialogue Options


Aperçu et tests de formulaires

A propos de l'aperçu et des tests de formulaires
Pour prévisualiser et tester les formulaires dans le panneau Aperçu PDF
Pour définir les options d'aperçu d'un formulaire interactif
Pour définir les options d'aperçu d'un formulaire non interactif
Pour tester un formulaire avec des exemples de données
Pour créer des exemples de données pour afficher l'aperçu d'un formulaire
Pour générer automatiquement des échantillons de données pour afficher l'aperçu d'un formulaire
Pour tester le niveau d’accessibilité


A propos de l'aperçu et des tests de formulaires

Le panneau Aperçu PDF permet de vérifier et de tester un modèle ou une conception de formulaire comme s'il s'agissait d'un formulaire PDF à l'aide d'Acrobat ou d'Adobe Reader.
Le panneau Aperçu PDF s'affiche uniquement si Acrobat ou Adobe Reader est installé. Par défaut, si les deux sont installés (Acrobat et Adobe Reader), LiveCycle Designer lance automatiquement Acrobat pour afficher un aperçu du formulaire. Pour prévisualiser le formulaire à l'aide de Adobe Reader, vous devez lancer Adobe Reader avant de cliquer sur l'onglet Aperçu PDF.
L'aperçu applique le même format que celui utilisé pour réaliser l'enregistrement. Par défaut, LiveCycle Designer affiche un nouveau formulaire (non enregistré) comme formulaire PDF statique. Pour afficher un formulaire non enregistré comme formulaire PDF statique, choisissez Fichier > Propriétés du formulaire> Valeurs par défaut, puis modifiez le paramètre Format d'aperçu XDP en définissant une des options de formulaire dynamique.
Si vous concevez un formulaire interactif ou imprimable, vous devez tout d'abord préciser le type de formulaire pour configurer correctement l'aperçu au format PDF, en définissant les options d'aperçu dans la boîte de dialogue Propriétés du formulaire.
Si vous concevez des formulaires destinés à être utilisées avec LiveCycle Forms, la même conception de formulaire peut être utilisée en vue de générer des formulaires PDF ou HTML. Bien que vous puissiez prévisualiser la conception de formulaire dans le panneau Aperçu PDF, un formulaire HTML risque de ne pas avoir le même aspect que lorsqu'il est généré avec LiveCycle Forms. Si vous créez un formulaire HTML, vous devez le générer à l'aide de LiveCycle Forms et l’afficher dans un navigateur Web.
Voir aussi
Observations générales sur la conception de formulaires accessibles


Pour prévisualiser et tester les formulaires dans le panneau Aperçu PDF

Utilisez le panneau Aperçu PDF pour prévisualiser la conception de formulaire telle qu'elle apparaît dans Adobe Reader. Avant de demander un aperçu de la conception de formulaire, assurez-vous que vous avez choisi les options d'affichage appropriées en fonction du type de formulaire dans la boîte de dialogue Propriétés du formulaire.
pour afficher l'aperçu d'un formulaire dans le panneau Aperçu PDF, assurez-vous que l'option Afficher PDF dans le navigateur d'Acrobat est sélectionnée. Vérifiez si la version d'Acrobat installée correspond à celle qui est enregistrée. Sinon vous risquez d'obtenir un message d'erreur ou d'avertissement en cliquant sur l'onglet Aperçu PDF. Par exemple, si vous enregistrez le formulaire au format de fichier PDF dynamique Acrobat 7.0.5, assurez-vous d'avoir installé Acrobat 7.0.5.
1.
Choisissez l'un des modes d'affichage suivants dans le panneau PDF :
      •
      Choisissez Affichage > Aperçu PDF.
      •
      Dans l'éditeur de mise en page, cliquez sur l'onglet Aperçu PDF.
2.
Si le formulaire est interactif, testez les objets qui s'y trouvent pour vérifier s'ils se comportent comme prévu.
3.
(Facultatif) S'il s'agit d'un formulaire non interactif destiné à être fusionné avec des données, il peut être utile de le tester avec un échantillon de fichier de données pour s'assurer que tous les champs correspondent bien aux données source.
vous devez utiliser Acrobat pour tester les fonctions de services Web et de connectivité de base de données. Pour ce faire, vous avez besoin d'un formulaire PDF dont les droits ont été activés pour ces fonctions. Cependant, vous ne pouvez pas définir de droits d'utilisation pour un formulaire PDF et afficher son aperçu dans LiveCycle Designer.


Pour définir les options d'aperçu d'un formulaire interactif

Pour afficher un aperçu d'un formulaire interactif, vous devez définir les options correspondantes dans la boîte de dialogue Propriétés du formulaire.
1.
Choisissez Fichier > Propriétés du formulaire.
2.
Cliquez sur l'onglet Valeurs par défaut et, dans la zone de liste Type d'aperçu, sélectionnez Formulaire interactif.
3.
(Facultatif) Pour tester le formulaire que vous êtes en train de prévisualiser à l'aide d'une source de données, indiquez le chemin d'accès complet au fichier des données de test dans la zone appropriée. Vous pouvez également vous servir du bouton Parcourir pour naviguer jusqu'au fichier.
4.
(Facultatif) Pour tester le formulaire que vous êtes en train de prévisualiser à l'aide d'une source de données générée automatiquement, cliquez sur Générer les données d'aperçu. Si le formulaire contient des sous-formulaires qui se répètent ou des jeux de sous-formulaires, indiquez le nombre de répétitions pour chaque sous-formulaire ou jeu de sous-formulaires dans le fichier de données. Vous pouvez vous servir du bouton Parcourir pour accéder à l'emplacement où vous souhaitez enregistrer le fichier. Saisissez le nom du fichier et cliquez sur Générer.
5.
Dans la liste Format d'aperçu XDP, sélectionnez le format d'aperçu PDF pour les fichiers XDP et TDS. Le format d'aperçu XDP n'est pas pris en compte pour les fichiers PDF.


Pour définir les options d'aperçu d'un formulaire non interactif

Pour afficher un aperçu d'un formulaire non interactif, vous devez définir les options correspondantes dans la boîte de dialogue Propriétés du formulaire.
1.
Choisissez Fichier > Propriétés du formulaire.
2.
(Facultatif) Pour tester le formulaire que vous êtes en train de prévisualiser à l'aide d'une source de données, indiquez le chemin d'accès complet au fichier des données de test dans la zone appropriée. Vous pouvez également vous servir du bouton Parcourir pour naviguer jusqu'au fichier.
3.
(Facultatif) Pour tester le formulaire que vous êtes en train de prévisualiser à l'aide d'une source de données générée automatiquement, cliquez sur Générer les données d'aperçu. Si le formulaire contient des sous-formulaires qui se répètent ou des jeux de sous-formulaires, indiquez le nombre de répétitions pour chaque sous-formulaire ou jeu de sous-formulaires dans le fichier de données. Vous pouvez vous servir du bouton Parcourir pour accéder à l'emplacement où vous souhaitez enregistrer le fichier. Saisissez le nom du fichier et cliquez sur Générer.
4.
Dans la liste Format d'aperçu XDP, sélectionnez le format d'aperçu PDF pour les fichiers XDP et TDS. Le format d'aperçu XDP n'est pas pris en compte pour les fichiers PDF.
lorsque vous sélectionnez Formulaire pour impression, les objets ne sont pas interactifs. Il est en de même lorsque vous sélectionnez l’option Remplir et envoyer/imprimer ou Remplir et imprimer dans l’assistant de création de formulaires lors de la création de la conception de formulaire.


Pour tester un formulaire avec des exemples de données

LiveCycle Designer vous permet de tester votre formulaire avec des échantillons de données XML.
L'utilisation d'une source de données d'exemple pour tester votre formulaire est un bon moyen de s'assurer que les données et les champs correspondent et que les sous-formulaires se répètent comme prévu. Vous pouvez créer un formulaire à la disposition équilibrée, où chaque objet a la place nécessaire pour afficher les données fusionnées.
1.
Choisissez Fichier > Propriétés du formulaire.
2.
Cliquez sur l'onglet Valeurs par défaut et, dans la zone Fichier de données, spécifiez le chemin complet de votre fichier de données test. Vous pouvez également vous servir du bouton Parcourir pour naviguer jusqu'au fichier.
3.
Cliquez sur OK. La prochaine fois que vous prévisualiserez le formulaire dans le panneau Aperçu PDF, les valeurs des données provenant de l'échantillon de fichier XML figureront dans les objets correspondants.
Pour obtenir des informations détaillées sur chaque option du panneau Valeurs par défaut, voir Panneau Valeurs par défaut (boîte de dialogue Propriétés du formulaire).
Voir aussi
Pour établir une connexion à un schéma XML et à un fichier de données XML


Pour créer des exemples de données pour afficher l'aperçu d'un formulaire

Il est recommandé de tester fréquemment le formulaire avec des exemples de données pour vous assurer qu'il est généré correctement. Vous pouvez créer des exemples de données si vous n'en avez pas.
Après avoir créé l'échantillon de fichier de données, vous pouvez préciser le fichier de données à utiliser pour afficher l'aperçu du formulaire. La prochaine fois que afficherez l'aperçu du formulaire dans LiveCycle Designer, les échantillons de données figureront dans les objets correspondants.
1.
Enregistrez la conception de formulaire au format PDF.
2.
Ouvrez le fichier PDF, puis entrez des valeurs dans les champs que vous voulez tester.
3.
Dans Acrobat, choisissez Options avancées > Formulaires > Exporter des données à partir d'un formulaire.
4.
Dans la boîte de dialogue Exporter les données du formulaire, nommez et enregistrez le fichier sous forme de paquets de données XML (*.xdp).
5.
Dans LiveCycle Designer, choisissez Fichier > Propriétés du formulaire > onglet Valeurs par défaut.
6.
Cliquez sur le bouton de dossier en regard de la case Fichier de données, puis naviguez jusqu'au fichier XDP.
7.
Sélectionnez le fichier XDP et cliquez sur OK.
Voir aussi
Pour tester un formulaire avec des exemples de données


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Aperçu et tests de formulaires > Pour générer automatiquement des échantillons de données pour afficher l'aperçu d'un formulaire

Pour générer automatiquement des échantillons de données pour afficher l'aperçu d'un formulaire

Il est possible de générer des échantillons de données afin de prévisualiser et tester votre formulaire au lieu de créer un fichier de données d'exemple. Si votre formulaire contient des sous-formulaires qui se répètent ou des jeux de sous-formulaires, indiquez le nombre de répétitions voulu au moment de prévisualiser le formulaire.
LiveCycle Designer génère des données d'exemple valides pour les objets correspondants dans le formulaire, à quelques exceptions près :
      •
      Les données d'exemple ne sont pas générées en fonction des scripts de validation éventuellement prévus pour un objet.
      •
      La valeur d'occurrence minimale et maximale d'un sous-formulaire limite le nombre de sous-formulaires répétitifs que vous spécifiez pour le fichier de données d'exemple généré.
      •
      La valeur par défaut sélectionnée pour un code à barres 2D est conservée dans le fichier de données d'exemple généré.
Après avoir généré le fichier de données d'exemple, vous avez la possibilité de le modifier, si besoin est.
Vous désignez le fichier de données à utiliser lors de l'aperçu du formulaire. La prochaine fois que afficherez l'aperçu du formulaire dans LiveCycle Designer, les échantillons de données figureront dans les objets correspondants.
1.
Dans LiveCycle Designer, choisissez Fichier > Propriétés du formulaire > onglet Valeurs par défaut.
2.
Cliquez sur l'onglet Valeurs par défaut et, dans la zone de liste Type d'aperçu, sélectionnez Formulaire interactif.
3.
Cliquez sur Générer les données d'aperçu.
4.
Dans la boîte de dialogue Générer les données d'aperçu, indiquez le chemin complet y compris le nom du fichier de données de test. Vous pouvez également vous servir du bouton Parcourir pour naviguer jusqu'à l'emplacement dans la zone Fichier de données.
5.
Dans la liste Répétition des éléments, sélectionnez le nombre à gauche d'un sous-formulaire et tapez le nombre de fois où il se répète dans le fichier de données.
6.
Cliquez sur Générer.
Voir aussi
Pour tester un formulaire avec des exemples de données


Pour tester le niveau d’accessibilité

Il est recommandé de tester les formulaires avec divers dispositifs d'assistance afin d'en garantir l'accessibilité.
Téléchargez des versions de démonstration de logiciels de lecteur d'écran. En tant que concepteur du formulaire, votre grande connaissance de ce dernier peut faire en sorte qu'il vous soit difficile de déterminer si l'information lue par le lecteur d'écran est suffisante et compréhensible. Par conséquent, si cela est possible, demandez à quelqu'un d'autre de tester votre formulaire de cette façon. Pour tester les résultats des lecteurs d'écran, éteignez votre moniteur et remplissez un formulaire en ne vous servant que du lecteur d'écran.
Recherchez sur Internet des versions de démonstration de logiciels de grossissement d'écran.
Assurez-vous de pouvoir remplir le formulaire en vous servant seulement du clavier et gardez à l'esprit les points suivants :
      •
      Existe-t-il des opérations qui ne peuvent pas être effectuées ?
      •
      Existe-t-il des opérations qui semblent bizarres ou difficiles à effectuer ?
      •
      Est-ce que les séquences de touches sont bien documentées ?
      •
      Est-ce qu'un raccourci clavier a été défini pour chacune des commandes et des touches ?
Lorsque vous remplissez le formulaire, gardez à l'esprit les éléments suivants :
      •
      Toute partie du formulaire devenant invisible, impossible à reconnaître ou difficile à utiliser
      •
      Zones s’affichant en noir sur un fond blanc
      •
      Objets du formulaire mal dimensionnés ou tronqués
Voir aussi
Observations générales sur la conception de formulaires accessibles


Utilisation de formulaires dont la disposition s'adapte à la taille des données

Création de formulaires interactifs prévus pour s'adapter aux données
Création de formulaires non interactifs prévus pour s'adapter aux données
Placement des objets dans un formulaire prévu pour s'adapter à la taille des données
Création de conceptions de formulaire prévues pour s'adapter aux données


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de formulaires interactifs prévus pour s'adapter aux données

Création de formulaires interactifs prévus pour s'adapter aux données

A propos de la création de formulaires interactifs prévus pour s'adapter aux données
Considérations sur la création de formulaires interactifs prévus pour s'adapter aux données
Positionnement de l'en-tête et du pied de page sur les gabarits
Placement d'objets de formulaire dans un sous-formulaire et configuration des valeurs d'occurrence
Modification des marges pour l'adaptation aux sous-formulaires
Utilisation de sous-formulaires de début et de fin de débordement
Création de sous-formulaires adaptables
Création d'un bouton pour ajouter et supprimer une section
Création de boutons d'ajout et de suppression
Pour ajouter et supprimer des instances de sous-formulaire à l'aide de scripts
Pour ajouter et supprimer des tableaux et des rangées de tableau à l'aide de scripts


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de formulaires interactifs prévus pour s'adapter aux données > A propos de la création de formulaires interactifs prévus pour s'adapter aux données

A propos de la création de formulaires interactifs prévus pour s'adapter aux données

Grâce à LiveCycle Designer, il est possible de créer des formulaires interactifs (contenant des sous-formulaires adaptables en fonction de la quantité de données fusionnées lors du rendu du formulaire) que les utilisateurs peuvent ouvrir et remplir dans Acrobat ou Adobe Reader. Ce type de formulaire combine les fonctionnalités propres aux formulaires dynamique et interactif. Il permet aux utilisateurs de saisir des données directement dans des champs extensibles, d'ajouter ou de supprimer des sections, et de renvoyer les données du formulaire au format électronique. Vous pouvez créer, par exemple, un formulaire interactif dans lequel les utilisateurs peuvent ajouter ou supprimer des rangées d'article et insérer des commentaires.
Pour ajouter une fonctionnalité dynamique aux formulaires interactifs, vous utilisez également des gabarits, des zones de contenu et des sous-formulaires. Ces éléments contrôlent la manière dont LiveCycle Designer place les objets dans le formulaire lorsque celui-ci s'adapte afin d'afficher différentes quantités de données.
les utilisateurs n'ont pas accès aux fonctions de saisie de commentaires d'Acrobat lorsqu'ils remplissent des formulaires interactifs contenant des sous-formulaires adaptables en fonction de la quantité de données fusionnées.
Différences à la conception et à l’exécution
Lorsque vous ajoutez des fonctionnalités dynamiques à un formulaire, souvenez-vous que ce que vous voyez lors de la conception ne correspond pas à ce que voient les utilisateurs lorsque le formulaire est généré dans Acrobat ou Adobe Reader.
Lorsque vous ouvrez le formulaire dans LiveCycle Designer, par exemple, la conception de formulaire contient peut-être une seule rangée d'articles pour la saisie des données. Toutefois, le formulaire peut contenir plusieurs rangées d'articles lors de sa génération dans Acrobat ou Adobe Reader. Ce cas peut se produire si vous avez placé les objets de la rangée d'articles dans un sous-formulaire utilisant les options Min. de répétitions et Max. de répétitions pour contrôler le nombre de rangées initialement disponibles dans le formulaire (à remplir par les utilisateurs) et le nombre de rangées supplémentaires qui peuvent être ajoutées.
Etant donné que la disposition des formulaires interactifs s'adapte automatiquement à la saisie utilisateur, vous n'avez plus besoin de déterminer à l'avance la taille exacte des objets tels que les champs de texte, ni le nombre précis des rangées d'article nécessaires dans le formulaire.
Par exemple, sélectionnez des options telles que Permettre des lignes multiples, Autoriser des sauts de page et Ajuster pour concevoir des formulaires interactifs à disposition souple qui afficheront correctement une quantité indéterminée de données.
Vous ajoutez une fonctionnalité dynamique à un formulaire interactif comme vous le feriez pour un formulaire à utiliser avec LiveCycle Forms. Pour plus d'informations sur la création de formulaires avec une disposition souple pour LiveCycle Forms, voir A propos de la création de conceptions de formulaire prévues pour s'adapter aux données.
pour remplir des formulaires interactifs avec une disposition souple, les utilisateurs ont besoin d'Acrobat 7.0 ou d'Adobe Reader 7.0.
Voir aussi
Considérations sur la création de formulaires interactifs prévus pour s'adapter aux données
A propos des formulaires et des conceptions de formulaire
A propos de la création de conceptions de formulaire prévues pour s'adapter aux données


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de formulaires interactifs prévus pour s'adapter aux données > Considérations sur la création de formulaires interactifs prévus pour s'adapter aux données

Considérations sur la création de formulaires interactifs prévus pour s'adapter aux données

De nombreux auteurs préfèrent commencer par la disposition d'une conception de formulaire interactif avec une disposition fixe. Ils obtiennent ainsi une disposition finale qui inclut tous les éléments nécessaires aux utilisateurs. Lorsque la conception de formulaire correspond à vos exigences, vous pouvez la diviser en sous-formulaires et indiquer combien d'entre eux seront extensibles en fonction du volume de données fusionnées.
L'ajout de fonctions dynamiques à un formulaire interactif implique habituellement les techniques suivantes :
      •
      Positionnement de l'en-tête et du pied de page sur les gabarits
      •
      Placement d'objets de formulaire dans un sous-formulaire et configuration des valeurs d'occurrence
      •
      Modification des marges pour l'adaptation aux sous-formulaires
      •
      Utilisation de sous-formulaires de début et de fin de débordement
      •
      Création de sous-formulaires adaptables
      •
      Création d'un bouton pour ajouter et supprimer une section
      •
      Création de boutons d'ajout et de suppression


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de formulaires interactifs prévus pour s'adapter aux données > Positionnement de l'en-tête et du pied de page sur les gabarits

Positionnement de l'en-tête et du pied de page sur les gabarits

Dans un formulaire interactif avec une disposition fixe, le texte d'en-tête et de pied de page est généralement placé sur la page. Lorsque vous ajoutez des sous-formulaires permettant d'enchaîner le contenu dans le formulaire, vous voulez généralement que le texte d’en-tête et de pied de page apparaisse sur le gabarit.
Etant donné que la longueur d'un formulaire interactif (composé de sous-formulaires permettant d'enchaîner le contenu) peut s'étendre en fonction de la quantité de données figurant dans le formulaire, des pages supplémentaires peuvent être ajoutées au fur et à mesure que l'utilisateur final entre des données. En plaçant l'en-tête et le pied de page sur les gabarits, vous garantissez que ces éléments apparaissent sur chaque page et pas uniquement sur la première page.
Voir aussi
Définition des gabarits


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de formulaires interactifs prévus pour s'adapter aux données > Placement d'objets de formulaire dans un sous-formulaire et configuration des valeurs d'occurrence

Placement d'objets de formulaire dans un sous-formulaire et configuration des valeurs d'occurrence

Lorsque vous concevez un formulaire interactif avec une disposition fixe, vous devez fournir un nombre suffisant de rangées d'article à remplir par les utilisateurs. Cependant, si vous placez les rangées d'articles dans des sous-formulaires permettant d'enchaîner le contenu, les utilisateurs peuvent ajouter autant de rangées que nécessaire.
Du fait des fonctions dynamiques des sous-formulaires, vous pouvez intégrer une ou deux rangées d'articles au formulaire, ainsi que des boutons Ajouter et Supprimer. En plaçant les objets dans un sous-formulaire, vous pouvez déterminer quand, où et combien de fois les sous-formulaires sont répétés en utilisant les options des panneaux Sous-formulaire et Liaison de la palette Objet.
Le placement de groupes d'objets dans des sous-formulaires est une étape clé de la création d'un formulaire doté de fonctionnalités dynamiques.
Les sous-formulaires contiennent et contrôlent les objets organisés en sections dans le formulaire pour conserver la disposition du formulaire lorsqu'il adapte sa longueur à la quantité de données saisies. Les sous-formulaires conservent les coordonnées x et y de chaque objet afin de garantir que les objets sont déplacés en un seul bloc et sont placés ensemble.
Lorsque vous placez des groupes d'objets dans des sous-formulaires, vous garantissez que, quelle que soit la quantité de données contenues dans le formulaire, le format de chaque section et la disposition de tout le formulaire restent cohérents et prévisibles.
Souvenez-vous que les utilisateurs finals doivent voir au moins une rangée d'articles lorsqu'ils ouvrent le formulaire. Autrement dit, vous devez affecter au moins la valeur 1 à l'option Min. de répétitions du sous-formulaire. Selon le formulaire considéré, l'affichage initial de plusieurs rangées dans le formulaire PDF peut lui donner un aspect plus agréable et équilibré, et rendre son utilisation plus intuitive et fonctionnelle.
Les sous-formulaires offrent également des fonctions dynamiques qui permettent aux utilisateurs d'ajouter ou de supprimer des rangées et des sections au formulaire. Par exemple, vous pouvez ajouter divers boutons pour permettre aux utilisateurs d'ajouter et supprimer des rangées d'articles ou de soumettre des commentaires.
Prévoyez la manière dont vous allez placer des objets dans les sous-formulaires pour créer des sections dans la conception de formulaire, puis testez celle-ci pour vous assurer que les sous-formulaires se déplacent et se répètent correctement et ne sont pas fractionnés sur plusieurs pages d'une manière indésirable.
Voir aussi
Aperçu des sous-formulaires
Création et configuration des sous-formulaires
Création d'un bouton pour ajouter et supprimer une section


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de formulaires interactifs prévus pour s'adapter aux données > Modification des marges pour l'adaptation aux sous-formulaires

Modification des marges pour l'adaptation aux sous-formulaires

Lorsque vous appliquez une fonctionnalité dynamique à un formulaire interactif avec une disposition fixe, un reformatage est généralement nécessaire. A l'aide des options de la palette Disposition, configurez la taille, la position, les marges et les légendes des objets. Par exemple, vous pouvez définir des marges autour des objets de sous-formulaire pour ajuster l'alignement et l'espacement (espace blanc) entre les sections du formulaire.
Voir aussi
Propriétés de la palette Disposition


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de formulaires interactifs prévus pour s'adapter aux données > Utilisation de sous-formulaires de début et de fin de débordement

Utilisation de sous-formulaires de début et de fin de débordement

Etant donné que la longueur d'un formulaire interactif (composé de sous-formulaires permettant d'enchaîner le contenu) peut varier en fonction de la quantité de données affichées dans le formulaire, le formulaire comprend souvent plusieurs pages. Par conséquent, vous pouvez souhaiter que certains sous-formulaires (sections) du formulaire se prolongent sur les pages suivantes.
Les sous-formulaires de début et de fin de débordement permettent de spécifier différents sous-formulaires à insérer avant et après les sous-formulaires répétés ou extensibles qui risquent de s'étendre sur des pages supplémentaires. Les débuts et les fins de débordement sont des types particuliers de sous-formulaires que vous utilisez dans les conceptions de formulaire avec une disposition souple. Après avoir défini un sous-formulaire en tant que sous-formulaire de début de débordement dans le panneau Liaison de la palette Objet, il apparaît en haut de chaque nouvelle page.
Par exemple, vous pouvez utiliser la rangée de titre en haut d'un tableau comme sous-formulaire de début de débordement. De cette manière, la rangée de titre est répétée en haut de chaque nouvelle page. Les informations contenues dans les rangées du tableau sont ainsi plus faciles à lire et à suivre d’une page à l’autre.
De même, vous pouvez affecter un sous-formulaire de fin de débordement qui suit la dernière occurrence sur une page d'un sous-formulaire répété ou extensible qui peut s'étendre sur plusieurs pages.
Voir aussi
Aperçu des sous-formulaires
Création et configuration des sous-formulaires


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de formulaires interactifs prévus pour s'adapter aux données > Création de sous-formulaires adaptables

Création de sous-formulaires adaptables

Selon l'objectif de la conception du formulaire, vous pouvez ajouter une section adaptable où les utilisateurs peuvent saisir des informations comme des requêtes spéciales ou des commentaires. LiveCycle Designer vous permet d'appliquer différentes options aux champs de texte et aux sous-formulaires. Ces options permettent d'ajuster la taille des sections du formulaire en fonction de la quantité de données saisies par l'utilisateur.
Par exemple, le formulaire interactif peut contenir une section de commentaires, que les utilisateurs peuvent afficher ou masquer en cliquant sur un bouton. Cette section peut être créée à l'aide d'un champ de texte placé dans un sous-formulaire, les options suivantes étant sélectionnées pour activer la saisie dynamique de données :
Champ de texte Permettre des lignes multiples et Permettre du texte brut seulement (onglet Champ), Entré par l'utilisateur - Facultatif (onglet Valeur), Hauteur - Ajuster (palette Disposition)
Permet aux utilisateurs de saisir le texte de leur choix dans la section Commentaires en étant certains que le champ de texte est automatiquement modifié en hauteur pour afficher correctement les valeurs.
Sous-formulaire Autoriser des sauts de page (onglet Sous-formulaire), Max. (de répétitions) avec la valeur 1 (onglet Liaison), Ajustement automatique (palette Disposition)
Permet de poursuivre sur les pages suivantes le sous-formulaire de commentaires, si nécessaire, tout en l'affichant une seule fois dans le formulaire et en s'assurant que le sous-formulaire est automatiquement élargi pour afficher correctement toutes les données à l'écran.
Voir aussi
Aperçu des sous-formulaires
Création et configuration des sous-formulaires
Création d'un bouton pour ajouter et supprimer une section


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de formulaires interactifs prévus pour s'adapter aux données > Création d'un bouton pour ajouter et supprimer une section

Création d'un bouton pour ajouter et supprimer une section

Dans une conception de formulaire interactive, il est fréquent qu'une ou plusieurs sections du formulaire ne soient pas affichées tant que l'utilisateur ne sélectionne pas l'option permettant de les inclure. Dans LiveCycle Designer, vous pouvez ajouter un bouton avec un script qui ajoute ou supprime de manière dynamique une section (sous-formulaire) donnée dans le formulaire lorsque l'utilisateur clique sur un bouton.
Ainsi, dans l'exemple de bon de commande interactif, l'utilisateur peut cliquer sur le bouton d'ajout de commentaires pour afficher la section de commentaires (sous-formulaire de commentaires). Ce bouton permet d'ajouter des commentaires ou de les supprimer, selon l'état actif du sous-formulaire. Chaque fois que l'utilisateur clique sur le bouton, le script vérifie si le sous-formulaire de commentaires est affiché, puis met à jour la légende du bouton en conséquence.
Le bouton déclenche un script qui utilise instanceManager, l'objet Modèle d'objet de formulaire XML qui gère la création, la suppression et le déplacement des occurrences d'objets de formulaire. Lorsque l'utilisateur final supprime le sous-formulaire Comment, l'objet instanceManager supprime le sous-formulaire du modèle d'objet de document (DOM) des données de formulaires, ainsi que du DOM de données.
Remarquez qu'instanceManager utilise quatre méthodes : addInstance, removeInstance, moveInstance et setInstances. Par convention, un objet instanceManager est appelé avec le nom du sous-formulaire, précédé d'un trait de soulignement (_subformname). La syntaxe de instanceManager est _subformname.methodname().
Dans l'exemple de formulaire interactif du bon de commande, l'auteur a saisi le script suivant dans l'éditeur de script en utilisant la méthode setInstances afin d'ajouter et de supprimer le sous-formulaire de commentaires et de changer la légende du bouton. Observez que l'instruction _comments.count == 0 property renvoie le nombre d'instances de sous-formulaire appelées.
// Invoke the Instance Manager to add and remove the comments subform.

if (_comments.count == 0) {// The count property specifies the current number
                                            // d'instances appelées.
    _comments.setInstances(1);												// Add the comments subform.
    this.resolveNode("caption.value.#text").value = "Clear Comments";																											// Change the button's caption.
}

else {
    _comments.setInstances(0);												// Remove the comments subform.
    this.resolveNode("caption.value.#text").value = "Add Comments";																											// Change the button's caption.
}


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de formulaires interactifs prévus pour s'adapter aux données > Création de boutons d'ajout et de suppression

Création de boutons d'ajout et de suppression

L'ajout de boutons à un formulaire interactif permet aux utilisateurs finals de lancer des actions, telles que l'ajout et la suppression d'instances de sous-formulaires définissant des sections (par exemple, des rangées d'articles dans un formulaire de commande).
Vous pouvez aussi ajouter une info-bulle au bouton de suppression pour afficher l'information Supprimer l'article lorsque l'utilisateur place le curseur sur le bouton. L'utilisation de boutons de suppression distincts permet aux utilisateurs de supprimer des rangées précises du formulaire.
Ainsi, l'exemple de bon de commande interactif comporte un bouton d'ajout d'élément et un bouton de suppression représenté par un X sur chaque rangée d'articles. Lorsque l'utilisateur clique sur le bouton d'ajout d'éléments, un script ajoute une rangée d'articles. Lorsque l'utilisateur clique sur l'un des boutons de suppression, un script supprime la rangée d'articles associée.
Bouton d'ajout d'élément
Le script JavaScript suivant associé à l'événement click du bouton d'ajout d'élément permet aux utilisateurs d'ajouter une ligne d'article au modèle de formulaire interactif de bon de commande. Le script effectue de nouveau les calculs dans le formulaire pour que le champ Total prenne en compte la nouvelle rangée.
Etant donné que les utilisateurs ajoutent uniquement des rangées d'articles avec le bouton d'ajout d'élément, le script n'a pas besoin de vérifier le nombre minimal d'occurrences.
// Invoke the Instance Manager to add one instance of the detail subform.
_detail.addInstance(1);

//Invoke the recalculate method to include the field values from the added subform in calculations.
xfa.form.recalculate(1);
Bouton de suppression
Le script JavaScript suivant associé à l’événement click du bouton de suppression permet aux utilisateurs de supprimer une instance du sous-formulaire detail dans le modèle de formulaire interactif de bon de commande. Le script effectue de nouveau les calculs dans le formulaire pour que le champ Total prenne en compte la suppression de la rangée.
// Invoke the Instance Manager to remove the current instance of the detail subform.
_detail.removeInstance(this.parent.index);

// Invoke the recalculate method to update the form calculations.
xfa.form.recalculate(1);
La valeur d'occurrence minimale de départ du sous-formulaire detail étant égale à 2, le script doit réduire cette valeur pour permettre à la personne remplissant le formulaire de supprimer les deux rangées d'articles qui apparaissent automatiquement lorsque le formulaire est généré. Ce script a été ajouté à l'événement initialize du sous-formulaire detail.
// Reset the minimum occurrence value of the detail subform.
this.occur.min = "0";
Comme le formulaire permet aux utilisateurs de supprimer toutes les instances du sous-formulaire detail, le script de l'événement calculate du champ Total (numTotal) doit vérifier qu'il existe au moins une instance du champ numAmount dans le sous-formulaire detail. En effet, si le calcul ne trouve aucune occurrence du champ numAmount, une erreur se produit. Ce script a été ajouté à l'événement Calculate du champ numTotal.
// Verify at least one instance of the numAmount field exists.
if (exists(detail[0].numAmount) == 1) then
    Sum(detail[*].numAmount)
endif


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de formulaires interactifs prévus pour s'adapter aux données > Pour ajouter et supprimer des instances de sous-formulaire à l'aide de scripts

Pour ajouter et supprimer des instances de sous-formulaire à l'aide de scripts

Vous pouvez ajouter ou supprimer des instances de sous-formulaire en ajoutant des calculs ou des scripts aux objets de votre formulaire à l'aide de l'éditeur de script.
Avant de commencer, assurez-vous que les paramètres suivants sont appliqués :
      •
      Si l'éditeur de script n'est pas déjà ouvert, ouvrez-le en choisissant Fenêtre > Editeur de script. Agrandissez l'éditeur de script pour afficher une vue multiligne.
      •
      Vérifiez si le sous-formulaire auquel vous voulez ajouter des instances se trouve dans un sous-formulaire permettant d'enchaîner le contenu.
      •
      Si besoin est, définissez les valeurs d'occurrence maximale, minimale et initiale à partir du panneau Liaison correspondant au sous-formulaire ou en utilisant les scripts suivants (integer représente la valeur d'occurrence maximale et Subform1 le nom de l'objet de sous-formulaire) :
FormCalc
// Include the quotation marks (" ") surrounding the integer values
Subform1.occur.max = "integer"
Subform1.occur.min = "integer"
Subform1.occur.initial = "integer"
JavaScript
// Include the quotation marks (" ") surrounding the integer values
Subform1.occur.max = "integer";
Subform1.occur.min = "integer";
Subform1.occur.initial = "integer";
Pour ajouter une instance de sous-formulaire à un formulaire à l'aide de scripts
1.
Sélectionnez l'objet de votre conception de formulaire auquel vous souhaitez ajouter le script et sélectionnez un événement dans la liste Afficher de l'éditeur de script. Choisissez, par exemple, l'événement click d'un bouton ou d'un autre objet de formulaire interactif.
2.
Entrez l'un des scripts suivants dans l'éditeur de script, où Subform1 représente le nom du sous-formulaire dans lequel ajouter des instances et la valeur true indique que la nouvelle instance de sous-formulaire doit être fusionnée avec les données du formulaire :
FormCalc
Subform1.instanceManager.addInstance(true) // Default instance manager syntax
xfa.form.recalculate(true) // Invoke the recalculate method to include the field values from the added subform in the form calculations.
ou
_Subform1.addInstance(true) // Short form of the instance manager syntax
xfa.form.recalculate(true) // Invoke the recalculate method to include the field values from the added subform in the form calculations.
JavaScript
Subform1.instanceManager.addInstance(true); // Default instance manager syntax
xfa.form.recalculate(true) // Invoke the recalculate method to include the field values from the added subform in the form calculations.
ou
_Subform1.addInstance(true); // Short form of the instance manager syntax
xfa.form.recalculate(true) // Invoke the recalculate method to include the field values from the added subform in the form calculations.
Pour supprimer une instance de sous-formulaire d'un formulaire
1.
Sélectionnez l'objet de votre conception de formulaire auquel vous souhaitez ajouter le script et sélectionnez un événement dans la liste Afficher de l'éditeur de script.
2.
Entrez l'un des scripts suivants dans l'éditeur de script, où Subform1 est le nom du sous-formulaire dans lequel une instance va être supprimée, et integer est le numéro d'index à base zéro de l'instance à supprimer :
FormCalc
Subform1.instanceManager.removeInstance(integer) // Default instance manager syntax
ou
_Subform1.removeInstance(integer) // Short form of the instance manager syntax
JavaScript
Subform1.instanceManager.removeInstance(integer); // Default instance manager syntax
ou
_Subform1.removeInstance(integer); // Short form of the instance manager syntax
Voir aussi
A propos de l’éditeur de script
Propriétés des sous-formulaires dans le panneau Liaison
addInstance
removeInstance
Pour ajouter et supprimer des tableaux et des rangées de tableau à l'aide de scripts


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de formulaires interactifs prévus pour s'adapter aux données > Pour ajouter et supprimer des tableaux et des rangées de tableau à l'aide de scripts

Pour ajouter et supprimer des tableaux et des rangées de tableau à l'aide de scripts

Vous pouvez ajouter ou supprimer des tableaux, des rangées de contenu, des rangées d'en-têtes et des rangées de pieds de page en ajoutant des expressions de script du gestionnaire d'instances aux objets de votre formulaire à l'aide de l'éditeur de script.
Avant de commencer, assurez-vous que les paramètres suivants sont appliqués :
      •
      Si l'éditeur de script n'est pas déjà ouvert, ouvrez-le en choisissant Fenêtre > Editeur de script. Agrandissez l'éditeur de script pour afficher une vue multiligne.
      •
      Assurez-vous que le tableau de destination fait partie d'un sous-formulaire permettant d'enchaîner le contenu de façon à pouvoir ajouter de nouvelles instances du tableau ou des rangées au sein du tableau.
      •
      Si besoin est, définissez les valeurs d'occurrence maximale, minimale et initiale à partir du panneau Liaison correspondant au tableau ou aux rangées de tableau ou en utilisant les scripts suivants (integer représente la valeur d'occurrence maximale et Table1 et Row1 les noms des objets de tableau et de rangée de tableau) :
FormCalc
// Include the quotation marks (" ") surrounding the integer values
Table1.occur.max = "integer"
Table1.occur.min = "integer"
Table1.occur.initial = "integer"
Table1.Row1.occur.max = "integer"
Table1.Row1.occur.min = "integer"
Table1.Row1.occur.initial = "integer"
JavaScript
// Include the quotation marks (" ") surrounding the integer values
Table1.occur.max = "integer";
Table1.occur.min = "integer";
Table1.occur.initial = "integer";
Table1.Row1.occur.max = "integer";
Table1.Row1.occur.min = "integer";
Table1.Row1.occur.initial = "integer";
Pour ajouter une instance de tableau ou de rangée de tableau à un formulaire
1.
Sélectionnez l'objet de votre conception de formulaire auquel vous souhaitez ajouter le script et sélectionnez un événement dans la liste Afficher de l'éditeur de script.
2.
Entrez l’un des scripts suivants dans l’éditeur de script, où Table1 et Row1 sont les noms du tableau et de la rangée de tableau auxquels des instances doivent être ajoutées :
FormCalc
Table1.instanceManager.addInstance(true) // Default instance manager syntax
Table1.Row1.instanceManager.addInstance(true) // Default instance manager syntax
xfa.form.recalculate(true) // Invoke the recalculate method to include the field values from the added table or row in the form calculations.
ou
Table1.addInstance(true) // Short form of the instance manager syntax
Table1._Row1.addInstance(true) // Short form of the instance manager syntax
xfa.form.recalculate(true) // Invoke the recalculate method to include the field values from the added table or row in the form calculations.
JavaScript
Table1.instanceManager.addInstance(true); // Default instance manager syntax
Table1.Row1.instanceManager.addInstance(true); // Default instance manager syntax
xfa.form.recalculate(true); // Invoke the recalculate method to include the field values from the added table or row in the form calculations.
ou
Table1.addInstance(true); // Short form of the instance manager syntax
Table1._Row1.addInstance(true); // Short form of the instance manager syntax
xfa.form.recalculate(true); // Invoke the recalculate method to include the field values from the added table or row in the form calculations.
Pour supprimer une instance de tableau ou de rangée de tableau de votre formulaire
1.
Sélectionnez l'objet de votre conception de formulaire auquel vous souhaitez ajouter le script et sélectionnez un événement dans la liste Afficher de l'éditeur de script.
2.
Entrez l'un des scripts suivants dans l'éditeur de script, où Table1 et Row1 représentent les noms du tableau et de la rangée de tableau dans lequel/laquelle des instances doivent être supprimées, et où integer représente le numéro d'index à base zéro de l'instance à supprimer :
FormCalc
Table1.instanceManager.removeInstance(true) // Default instance manager syntax
Table1.Row1.instanceManager.removeInstance(true) // Default instance manager syntax
ou
Table1.removeInstance(true) // Short form of the instance manager syntax
Table1._Row1.removeInstance(true) // Short form of the instance manager syntax
JavaScript
Table1.instanceManager.removeInstance(true); // Default instance manager syntax
Table1.Row1.instanceManager.removeInstance(true); // Default instance manager syntax
ou
Table1.removeInstance(true); // Short form of the instance manager syntax
Table1._Row1.removeInstance(true); // Short form of the instance manager syntax
Voir aussi
A propos de l’éditeur de script
Propriétés des tableaux dans le panneau Liaison
Propriétés des rangées de contenu dans le panneau Liaison
Propriétés des rangées d'en-tête et de pied de page sous l'onglet Liaison
addInstance
removeInstance
Pour ajouter et supprimer des instances de sous-formulaire à l'aide de scripts


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de formulaires non interactifs prévus pour s'adapter aux données

Création de formulaires non interactifs prévus pour s'adapter aux données

A propos de la création de formulaires non interactifs prévus pour s'adapter aux données
Fonctionnement des formulaires non interactifs prévus pour s'adapter aux données


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de formulaires non interactifs prévus pour s'adapter aux données > A propos de la création de formulaires non interactifs prévus pour s'adapter aux données

A propos de la création de formulaires non interactifs prévus pour s'adapter aux données

Les formulaires non interactifs (contenant des sous-formulaires permettant d'enchaîner le contenu) s'avèrent pratiques lorsque vous souhaitez présenter une quantité de données indéterminée aux utilisateurs ou capturer diverses informations provenant des utilisateurs. Du fait que la disposition d'un formulaire de ce type s'ajuste automatiquement à la quantité de données fusionnées, vous n'avez pas besoin de déterminer à l'avance une disposition ou un nombre de pages fixe pour le formulaire, comme il faut le faire avec un formulaire dotée d'une mise en forme statique.
Grâce à LiveCycle Designer, il est possible de créer des formulaires avec des sections s'ajustant automatiquement au volume des données, en vue de les utiliser dans LiveCycle Forms. Dans ce scénario, la conception de formulaire est fusionnée avec les données de LiveCycle Forms. En général, ce sont des formulaires non interactifs conçus pour fournir aux utilisateurs des informations d'une source de données. Les utilisateurs peuvent imprimer le formulaire ou l'enregistrer au format électronique. Voir A propos de la conception de formulaires pour LiveCycle Forms.
Voir aussi
Fonctionnement des formulaires non interactifs prévus pour s'adapter aux données
A propos des sous-formulaires


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de formulaires non interactifs prévus pour s'adapter aux données > Fonctionnement des formulaires non interactifs prévus pour s'adapter aux données

Fonctionnement des formulaires non interactifs prévus pour s'adapter aux données

Dans une conception de formulaire avec une mise en forme statique, vous n'utilisez généralement qu'un seul sous-formulaire (le sous-formulaire par défaut de la page) que LiveCycle Designer configure par défaut pour positionner le contenu. Lorsque LiveCycle Designer positionne le contenu dans un sous-formulaire, aucun des objets qui s'y trouvent n'est déplacé par rapport à sa position d'ancrage, quelles qu'en soient les caractéristiques et les quantités de données.
Cependant si vous souhaitez que les sections du formulaire s'étendent afin d'accueillir les données, vous utilisez généralement plusieurs sous-formulaires : le sous-formulaire par défaut de la page que vous définissez pour enchaîner le contenu, ainsi que plusieurs sous-formulaires supplémentaires que vous pouvez configurer pour la répétition de chaque élément de données, l'ajustement automatique, ou les deux. Lorsque vous reconfigurez un sous-formulaire pour enchaîner le contenu, les objets du sous-formulaire, y compris les autres sous-formulaires, changent de position pour tenir compte des données fusionnées dans les sous-formulaires de répétition et d'extension.
LiveCycle Designer vous permet de lier les objets d'un formulaire aux éléments d'un fichier de données et de configurer les objets de champ de texte et de sous-formulaire du formulaire de façon qu'ils s'affichent, se répètent ou s'étendent selon les caractéristiques et la quantité de données fusionnées avec l'objet. Comme les objets du formulaire sont liés aux données source, la mise en forme d'un formulaire est liée aux données.
Lors de la création d'une conception de formulaire (avec des sections ajustables automatiquement au volume des données), il est important de comprendre quels sous-formulaires apparaîtront une seule fois dans le formulaire (comme les blocs d'adresse, par exemple) et lesquels seront reproduits plusieurs fois en fonction de la quantité de données (comme une rangée de données). Dans le cas des sous-formulaires qui se répètent, vous incluez une seule instance du sous-formulaire et les composants associés dans la conception de formulaire. Par conséquent, ce que vous voyez au stade de la conception ne correspond pas à ce que les utilisateurs verront une fois le formulaire généré.
Par exemple, les illustrations suivantes de la version non interactive de l'exemple Bon de commande montrent la conception de formulaire préalablement à la fusion avec les données ainsi que le formulaire résultant présenté à un utilisateur, une fois la conception fusionnée avec les données. Remarquez la ligne de détail (sous-formulaire de détail), répétée quatre fois pour tenir compte de la liste des pièces (données disponibles).
Formulaire avec une disposition souple et sans données fusionnées
Formulaire avec une disposition souple et avec des données fusionnées
Voir aussi
A propos des sous-formulaires
Considérations générales au sujet des conceptions de formulaire avec une disposition adaptable


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Placement des objets dans un formulaire prévu pour s'adapter à la taille des données

Placement des objets dans un formulaire prévu pour s'adapter à la taille des données

A propos des sous-formulaires et des zones de contenu
Gestion des zones de contenu dans les formulaires prévus pour s'adapter aux données
Utilisation de sous-formulaires dans une conception de formulaire s'adaptant aux données fusionnées


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Placement des objets dans un formulaire prévu pour s'adapter à la taille des données > A propos des sous-formulaires et des zones de contenu

A propos des sous-formulaires et des zones de contenu

LiveCycle Designer vous donne le choix entre deux modes de placement possibles des objets dans un formulaire, dans des zones de contenu et dans des sous-formulaires :
      •
      Les zones de contenu dans les gabarits déterminent les zones et la direction de l'enchaînement qu'utilise LiveCycle Designer pour disposer les objets sur les pages.

      Chaque gabarit possède une zone de contenu par défaut, c'est-à-dire un conteneur qui détermine à quel endroit LiveCycle Designer place les objets comme les sous-formulaires dans les pages.
      •
      Les sous-formulaires définissent la façon dont LiveCycle Designer place les objets dans le formulaire. En plaçant des objets dans un sous-formulaire, vous pouvez utiliser les différentes options des panneaux Sous-formulaire et Liaison dans la palette Objet, pour déterminer le nombre de répétitions des objets et leur emplacement sur la page.

      Dans un formulaire composé de sections s'adaptant automatiquement au volume des données, les sous-formulaires contiennent les objets de chaque section du formulaire et gèrent la disposition du formulaire à mesure qu'ils ajustent la longueur d'après la quantité de données qui y sont fusionnées. Les sous-formulaires s'assurent que les objets se déplacent ensemble et qu'ils sont disposés de façon cohérente les uns par rapport aux autres. Lorsque vous placez des objets dans un sous-formulaire, vous avez l'assurance que, quelle que soit la quantité de données fusionnées avec le formulaire, le format de chaque section demeure cohérent, et que la disposition du formulaire dans son ensemble sera prévisible d'un rendu à l'autre. C'est pourquoi la planification de l'utilisation des sous-formulaires compte pour beaucoup dans la conception de ce type de formulaire.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Placement des objets dans un formulaire prévu pour s'adapter à la taille des données > Gestion des zones de contenu dans les formulaires prévus pour s'adapter aux données

Gestion des zones de contenu dans les formulaires prévus pour s'adapter aux données

Servez-vous des zones de contenu dans les gabarits pour déterminer les zones et la direction de l'enchaînement qu'utilise LiveCycle Designer pour disposer les objets sur les pages. Rappelez-vous que vous ne pouvez pas manipuler les zones de contenu dans les pages.
Chaque gabarit possède une zone de contenu qui s'affiche dans les pages correspondantes et délimite la zone dans laquelle vous pouvez placer des objets dans les pages, un peu comme les marges dans un document de texte. Autrement dit, dans une page, vous ne pouvez pas placer d'objets en dehors de la zone de contenu définie.
chaque formulaire doit comporter au moins une zone de contenu.
Cependant, la zone de contenu ne limite en rien la zone dans laquelle vous pouvez positionner des objets dans les gabarits. En fait, vous pouvez placer des objets standard n'importe où dans un gabarit, à l'intérieur ou à l'extérieur de la zone de contenu. Si vous placez des objets à l'extérieur de la zone de contenu, comme du texte d'en-tête ou de pied de page, la date et l'heure, ou la pagination, n'hésitez pas à tester le formulaire pour vous assurer que les objets s'affichent comme prévu. Assurez-vous, en outre, que les objets des pages ne chevauchent pas et ne cachent pas les objets des gabarits lorsque le formulaire est généré.
Avec les formulaires contenant des sections s'adaptant aux données, n'oubliez pas que la mise en forme du formulaire est, en définitive, liée aux données. Si le formulaire est généré via LiveCycle Forms, des pages sont ajoutées jusqu'à ce que toutes les données disponibles soient fusionnées. A mesure que LiveCycle Forms insère de nouvelles pages, les données s'enchaînent de page en page dans la section définie par la zone de contenu des gabarits.
Si vous voulez que chaque page du formulaire ait la même disposition de base, la zone de contenu par défaut est peut-être la seule dont vous avez besoin. Cependant, si vous souhaitez une disposition plus complexe, vous pouvez ajouter des zones de contenu supplémentaires au gabarit par défaut. N'oubliez pas que si vous souhaitez une direction d'enchaînement ou une orientation de page différente, ou des pages recto verso, vous pouvez insérer des gabarits supplémentaires et configurer les autres gabarits et zones de contenu en fonction de vos besoins.
Voir aussi
Aperçu des zones de contenu


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Placement des objets dans un formulaire prévu pour s'adapter à la taille des données > Utilisation de sous-formulaires dans une conception de formulaire s'adaptant aux données fusionnées

Utilisation de sous-formulaires dans une conception de formulaire s'adaptant aux données fusionnées

Pour ajouter des sections dont la taille diminue ou augmente en fonction des données fusionnées, créez des sous-formulaires et imbriquez-les dans une hiérarchie comparable à la structure des données. Vous pouvez imbriquer des sous-formulaires à n'importe quel niveau. L'imbrication de sous-formulaires vous permet de faire correspondre la conception de formulaire au fichier de données XML avec lequel elle va être fusionnée. Si, par exemple, le fichier de données XML comporte deux niveaux, vous pouvez créer la hiérarchie des sous-formulaires en faisant correspondre les noms des sous-formulaires aux noms des balises du fichier de données XML, de façon à ce que LiveCycle Designer puisse mapper les données sans transformer le fichier de données.
Un formulaire avec une disposition souple, comme l'exemple Bon de commande, comprend normalement plusieurs sous-formulaires imbriqués, chaque sous-formulaire comportant un ou plusieurs objets. Par exemple, vous pouvez voir, dans l'exemple Bon de commande, la façon dont les différents objets sont placés dans les sous-formulaires nommés header, detailHeader, detail et total. Comme vous le constatez, vous pouvez aligner des objets de texte et de champ de texte en rangées et en colonnes et les placer dans un sous-formulaire. L'utilisation de sous-formulaires pour regrouper des objets comme les différents champs de texte du sous-formulaire detail vous permet non seulement de gérer la disposition des objets, mais aussi de déterminer le nombre de répétitions du sous-formulaire.
Vous pouvez configurer chaque sous-formulaire de façon à ce que, dans le formulaire rendu, seuls les sous-formulaires contenant les objets nécessaires à la représentation du contenu des données soient insérés. Par exemple, il peut être intéressant d'établir des bons de commande différents pour chaque client. Dans un formulaire de bon de commande, le sous-formulaire est inséré douze fois pour indiquer les articles achetés ; dans un autre formulaire de bon de commande, le même sous-formulaire est disposé cinquante fois et s'étend sur plusieurs pages.
Le formulaire d'exemple Bon de commande prévu pour s'adapter à la taille des données illustre bien comment on peut utiliser les sous-formulaires pour obtenir cette configuration. Ouvrez le formulaire dans LiveCycle Designer et examinez la palette Hiérarchie pour connaître la structure du sous-formulaire, puis la palette Objet pour vérifier la configuration des sous-formulaires. Prêtez une attention particulière aux sous-formulaires purchaseOrder, detailHeader et detail, et à la façon dont ils sont configurés. N'oubliez pas que le sous-formulaire parent, purchaseOrder, détermine l'enchaînement du contenu dans le formulaire et s'étend pour s'ajuster aux données disponibles. Le sous-formulaire detailHeader est configuré avec une valeur d'occurrence minimale de 1, ce qui signifie que LiveCycle Forms insérera le sous-formulaire une seule fois. Le sous-formulaire detail est configuré pour être répété avec chaque élément de données.
En outre, vous pouvez utiliser un sous-formulaire pour dessiner une bordure autour d'un jeu de sous-formulaires. Par exemple, vous pouvez créer un ou plusieurs sous-formulaires dynamiques, les imbriquer dans un sous-formulaire wrapper, pour lequel vous pouvez configurer une bordure. Après génération du formulaire, une bordure apparaît autour de tous les sous-formulaires internes.
Voir aussi
Aperçu des sous-formulaires
A propos des sous-formulaires


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de conceptions de formulaire prévues pour s'adapter aux données

Création de conceptions de formulaire prévues pour s'adapter aux données

A propos de la création de conceptions de formulaire prévues pour s'adapter aux données
Pour créer une conception de formulaire dans un contexte positionné
Pour créer une conception de formulaire dans un contexte enchaîné
Considérations générales au sujet des conceptions de formulaire avec une disposition adaptable


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de conceptions de formulaire prévues pour s'adapter aux données > A propos de la création de conceptions de formulaire prévues pour s'adapter aux données

A propos de la création de conceptions de formulaire prévues pour s'adapter aux données

Il existe deux approches possibles pour créer une conception de formulaire contenant des sous-formulaires dont la taille varie en fonction des données :
      •
      Création d'une conception de formulaire dans un contexte positionné
      •
      Création d'une conception de formulaire dans un contexte enchaîné
Les deux méthodes produisent les mêmes résultats. Vous pouvez avoir une préférence pour une méthode, qui correspond davantage à votre façon de concevoir les formulaires. Quand vous vous serez familiarisé avec la création ce type de conception de formulaire, vous adopterez la méthode qui vous convient le mieux.
Quel que soit votre choix, il vaut mieux commencer par créer une conception de formulaire avec une disposition fixe. Vous pouvez planifier la présentation du formulaire, ainsi que tous les objets et renseignements que vous voulez voir y figurer. Après avoir créé une conception de formulaire répondant à vos besoins, vous pouvez commencer à agencer les différents groupes d'objets dans les sous-formulaires et configurer chaque sous-formulaire pour rendre le formulaire plus souple. Par exemple, vous devez déterminer quels sous-formulaires positionneront ou enchaîneront le contenu, quelle direction d'enchaînement convient le mieux à chaque sous-formulaire, quels sous-formulaires auront besoin d'un sous-formulaire de début ou de fin de débordement, et lesquels se répéteront, lesquels s'étendront pour s'ajuster au contenu, et lesquels scinderont leur contenu.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de conceptions de formulaire prévues pour s'adapter aux données > Pour créer une conception de formulaire dans un contexte positionné

Pour créer une conception de formulaire dans un contexte positionné

Dans un contexte positionné, vous créez le modèle de formulaire en utilisant autant de gabarits et de pages que nécessaire. Une fois la disposition et le formatage des objets terminés, les propriétés dynamiques sont appliquées aux sous-formulaires appropriés de la conception de formulaire.
Si vous savez déjà créer des formulaires avec une disposition fixe, vous éprouverez sans doute un sentiment de familiarité avec la méthode du contexte positionné. Cette méthode constitue, en outre, la façon la plus facile et la plus simple de convertir un formulaire avec une disposition fixe en une conception de formulaire avec une disposition souple.
Les étapes suivantes indiquent, de façon générale, comment créer un modèle de formulaire dans un contexte positionné. Pour être en mesure de les suivre, la phase de planification doit être terminée.
1.
Créez les gabarits nécessaires.
2.
Dans la page, créez le contenu du formulaire. Si vous procédez à la conversion d'un formulaire avec une disposition fixe, commencez simplement à placer les objets du formulaire dans des sous-formulaires. Si vous partez d'un formulaire vierge, procédez comme suit :
      •
      Ajoutez des objets au formulaire et placez-les dans les sous-formulaires appropriés.
      •
      Appliquez le formatage nécessaire aux objets.
      •
      Finalisez la disposition des objets dans les sous-formulaires, et des sous-formulaires dans la page.
      •
      Au besoin, ajoutez un script.
3.
Implémentez les propriétés dynamiques :
      •
      Placez les sous-formulaires par défaut hors de chacune des pages. Les sous-formulaires deviendront alors les enfants du sous-formulaire racine, formulaire1, dont le contenu est enchaîné. La conception se fait maintenant dans un contexte enchaîné. Vous remarquerez que les sous-formulaires sont positionnés l'un sous l'autre, puisque la direction de l'enchaînement est de haut en bas.
      •
      Appliquez le formatage nécessaire aux sous-formulaires, comme le type de liaison des sous-formulaires et les bordures.
      •
      Définissez l'enchaînement. Il faut notamment paramétrer les valeurs d'occurrence, autoriser les sauts de page, définir les sous-formulaires de début et de fin de débordement, indiquer les sous-formulaires à conserver ensemble, associer les sous-formulaires aux gabarits et configurer les marges.
4.
Testez le formulaire en utilisant les données d'exemple.
les exemples de formulaires livrés avec LiveCycle Designer suivent cette procédure. Pour des raisons pratiques, les sous-formulaires qui contiennent le contenu en tant que tel sont placés dans un sous-formulaire dont le type de liaison est défini sur Aucun. Cette façon de configurer les sous-formulaires permet d'appréhender rapidement la structure globale d'un formulaire quand on la visualise pour la première fois dans la vue Hiérarchie.
Observations relatives à la création d'une conception de formulaire avec une disposition adaptable en contexte positionné
Lorsque vous créez des formulaires ayant une disposition souple dans un contexte positionné, tenez compte des recommandations suivantes :
      •
      Ne définissez le contenu du formulaire sur Enchaîné que lorsque vous êtes satisfait de la disposition. Après avoir défini le contenu d'un formulaire sur Enchaîné, il est possible de revenir à une disposition positionnée, mais cela risque d'altérer la disposition du formulaire. Si, par exemple, vous décidez de placer les sous-formulaires à l'intérieur d'un seul conteneur positionné, les sous-formulaires seront positionnés exactement à l'endroit où ils se trouvaient dans leurs pages respectives et risquent de se chevaucher. Pour éviter ce problème, placez les sous-formulaires comme indiqué ci-dessus, en regroupant les pages.
      •
      Les valeurs d'occurrence min. et max. du sous-formulaire sont définies sur 1 et doivent être ajustées pour réagir dynamiquement.
      •
      Le placement des objets dans un sous-formulaire élimine l'espace en trop défini au-delà des objets. Vous pouvez ajouter des marges gauche et droite pour réaligner le sous-formulaire horizontalement. Vous pouvez également redimensionner le sous-formulaire, mais les objets seront alors repositionnés, puisqu'ils sont positionnés relativement au parent.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de conceptions de formulaire prévues pour s'adapter aux données > Pour créer une conception de formulaire dans un contexte enchaîné

Pour créer une conception de formulaire dans un contexte enchaîné

Dans un contexte enchaîné, créez la conception de formulaire en utilisant autant de gabarits et de sous-formulaires que nécessaire. La notion de pages n'a pas sa place ici. La création de pages a lieu pendant le traitement, quand le modèle de formulaire est fusionné aux données et que la quantité de données déborde sur une autre page. Les propriétés dynamiques sont appliquées une fois la disposition et le formatage terminés.
La création d'un formulaire dans un contexte enchaîné est souvent la meilleure façon de procéder lorsque vous partez d'un schéma XML. En outre, les utilisateurs expérimentés privilégient souvent cette méthode car elle montre mieux le comportement dynamique du formulaire au moment de la conception. Il faut toutefois un peu de temps pour se sentir à l'aise avec la création d'un formulaire dans un contexte enchaîné. Cette difficulté provient du comportement inattendu qui peut se produire quand on crée des objets à l'intérieur d'un conteneur enchaîné.
Les étapes suivantes indiquent, de façon générale, comment créer un formulaire dans un contexte enchaîné. Pour être en mesure de les suivre, la phase de planification doit être terminée.
1.
Créez les gabarits nécessaires.
2.
Créez le contenu du formulaire de la façon suivante.
      •
      Créez les sous-formulaires et leur contenu. Le sous-formulaire par défaut de page devient le premier sous-formulaire du formulaire. Redimensionnez-le pour tenir compte du contenu.
      •
      D'autres pages ne sont pas nécessaires. Continuez à ajouter autant de sous-formulaires que nécessaire pour compléter la conception de formulaire. A mesure que vous concevez le formulaire, des pages supplémentaires sont insérées lorsque les sous-formulaires créés ne tiennent plus dans la page actuelle. Cela n'est pas toujours évident puisque cette fonction est automatique et que la palette Hiérarchie ne montre pas ces pages supplémentaires.
      •
      Appliquez le formatage nécessaire aux objets.
      •
      Finalisez la disposition des objets dans les sous-formulaires, et des sous-formulaires dans la page.
      •
      Au besoin, ajoutez un script.
3.
Implémentez les propriétés dynamiques.
      •
      Appliquez le formatage nécessaire aux sous-formulaires, comme le type de liaison des sous-formulaires et les bordures.
      •
      Définissez l'enchaînement. Il faut notamment paramétrer les valeurs d'occurrence, autoriser les sauts de page, définir les sous-formulaires de début et de fin de débordement, indiquer les sous-formulaires à conserver ensemble, associer les sous-formulaires aux gabarits et configurer les marges.
4.
Testez le formulaire en utilisant les données d'exemple.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation de formulaires dont la disposition s'adapte à la taille des données > Création de conceptions de formulaire prévues pour s'adapter aux données > Considérations générales au sujet des conceptions de formulaire avec une disposition adaptable

Considérations générales au sujet des conceptions de formulaire avec une disposition adaptable

Que vous conceviez un formulaire dans un contexte enchaîné ou positionné, voici quelques observations générales sur la conception dont vous devez tenir compte :
      •
      Définir les marges d'un sous-formulaire risque de produire des résultats inattendus. Puisque la majorité des sous-formulaires auront un contenu positionné, et donc une hauteur fixe, l'ajout de marges décalera d'autant le contenu du sous-formulaire, risquant de faire se chevaucher les objets dans celles-ci.
      •
      Pour placer précisément le contenu d'un sous-formulaire, sans utiliser l'option Ajuster, redimensionnez le sous-formulaire à l'aide des propriétés de la palette Disposition. Les exemples de formulaires fournis avec LiveCycle Designer suivent les deux méthodes.
      •
      Définissez les gabarits dans l'ordre où vous souhaitez les placer. Cela empêche la première page de demeurer vierge, car la disposition commence au sous-formulaire racine, formulaire1, de la première zone de page.
Les auteurs de conceptions de formulaire avec une disposition souple peuvent ne pas tenir compte des options de la liste déroulante Type dans le panneau Valeur de la palette Objet. Ces options ne s'appliquent pas aux conceptions de formulaire prévues pour s'adapter aux données.


Importation de documents

A propos de l'importation
Importation de fichiers PDF
Importation de documents PDF en tant qu'illustrations
Importation de fichiers Word
Importation de données de feuilles de calcul à partir de Microsoft Excel
Importation de fichiers InfoPath


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Importation de documents > A propos de l'importation

A propos de l'importation

Formats des formulaires importés dans LiveCycle Designer


Formats des formulaires importés dans LiveCycle Designer

LiveCycle Designer permet d'importer des formulaires conçus dans une autre application de création de formulaires. Vous pouvez également importer des formulaires existants comme point de départ pour définir de nouveaux formulaires LiveCycle Designer. LiveCycle Designer peut importer des fichiers créés dans les applications suivantes.

Application

Type de fichier
Adobe Acrobat
PDF
Adobe Form Designer 5.0 ou version ultérieure
XFT
Adobe Output Designer
IFD
LiveCycle Designer peut importer des fichiers IFD seulement si le programme Output Designer est également installé. Pour en savoir plus à ce sujet, adressez-vous au support clientèle.
Microsoft InfoPath
XSN
Microsoft Word
DOC, DOT, RTF
LiveCycle Designer offre un certain nombre d'options de traitement des fichiers importés et de rendu du meilleur résultat. LiveCycle Designer conserve la disposition du formulaire importé et convertit les éléments en objets LiveCycle Designer. Lorsque vous importez un formulaire, LiveCycle Designer le convertit automatiquement au format de fichier XDP.
Voir aussi
Pour importer des fichiers PDF
Pour importer un fichier Microsoft Word
Pour importer un fichier Microsoft InfoPath


Importation de fichiers PDF

Pour importer des fichiers PDF
Contrôle des résultats d'une importation de fichier PDF
Conversion des objets PDF dans LiveCycle Designer
Limitation des problèmes de conversion des fichiers PDF
A propos des fichiers PDF accessibles et de leur importation
A propos des polices et de l'importation de PDF
Pour définir la substitution des polices de manière permanente
Ajout d'un nouveau mappage dans la table de mappage des polices dans Designer
Table de mappage des polices dans ConvertPDF_FontMap.txt
Table de mappage des caractères dans ConvertPDF_CharMap.txt


Pour importer des fichiers PDF

Les fichiers PDF proviennent de plusieurs sources, chaque outil de développement pouvant en définir le contenu de façon unique.
Avant d'importer un fichier PDF dans LiveCycle Designer, il est important de bien comprendre les différentes options disponibles qui visent à améliorer les résultats de l'importation.
les fichiers PDF créés à l'aide de LiveCycle Designer ne passent pas par la procédure d'importation. Ils s'ouvrent directement dans LiveCycle Designer et doivent apparaître comme étant créés sans modifications.
Pour importer un fichier PDF, vous avez le choix entre l'assistant de création de formulaires ou la boîte de dialogue Options d'importation. L'assistant de création de formulaires simplifie la procédure de création en vous guidant au cours des différentes étapes. Celles-ci vous permettent de déterminer le fichier PDF à importer, la manière d'utiliser le contenu PDF importé ainsi que la manière dont le formulaire sera diffusé et renvoyé. La boîte de dialogue Options d'importation permet de mieux contrôler la façon dont LiveCycle Designer importe le contenu du fichier PDF lorsque vous créez un formulaire interactif dont la disposition est susceptible d'être enchaînée. Ainsi, vous pouvez sélectionner des options personnalisées visant à contrôler la manière dont LiveCycle Designer traite le texte, les paragraphes et les images dans le document.
Si vous préférez utiliser l'assistant de création de formulaires en vue de l'importation des fichiers PDF, vous pouvez désactiver l'assistant selon l'une des méthodes suivantes :
      •
      Cliquez sur le lien Ne pas utiliser l'assistant dans l'assistant de création de formulaires afin d'ouvrir la boîte de dialogue Options de l'assistant ; sélectionnez ensuite l'option la mieux adaptée à vos besoins.
      •
      Choisissez Outils > Options pour ouvrir la boîte de dialogue Options, sélectionnez Assistants et conseils, puis sous Assistant de création de formulaires, désactivez Afficher à l'importation de documents. Pour plus de détails, voir Assistants et conseils (boîte de dialogue Options).
Avant d'importer un PDF, examinez les cas de figure suivants :
      •
      Si vous possédez un document PDF créé dans Adobe Acrobat ou dans une application autre que LiveCycle Designer et si vous souhaitez importer son contenu en tant qu'illustration d'arrière-plan tout en conservant la disposition et l'aspect du document d'origine, sélectionnez Créer un formulaire interactif avec des pages fixes. Vous pouvez modifier tout objet interactif et placer des objets de bibliothèque supplémentaires au-dessus de l'illustration.
      •
      Si vous souhaitez modifier le contenu du document PDF dans LiveCycle Designer, sélectionnez Créer un formulaire interactif avec une disposition souple. Le retour à la ligne et les sauts de ligne risquent de ne pas être préservés.
Si la conversion initiale ne vous convient pas, vous pouvez tester différentes combinaisons d'options afin d'améliorer les résultats.
lors de l'importation d'un fichier PDF doté de droits de protection, LiveCycle Designer vous invite à saisir le mot de passe correspondant afin d'éviter l'accès à des personnes non autorisées.
Pour importer un fichier PDF à l'aide de l'assistant de création de formulaires
1.
Choisissez Fichier > Nouveau.
2.
Dans le panneau Mise en route de l'assistant de création de formulaires, sélectionnez Importer un document PDF et cliquez sur Suivant.
3.
Dans la fenêtre Configuration : Dans le panneau Importer un PDF, recherchez et sélectionnez le fichier PDF à importer, cliquez sur Ouvrir, puis sur Suivant.
4.
Dans la fenêtre Configuration du document : Dans le panneau Options d'importation, sélectionnez l'option d'importation de votre choix :
      •
      Pour importer le fichier PDF en tant qu'illustration d'arrière-plan de manière à ce que LiveCycle Designer conserve l'aspect du document initial ainsi que les champs interactifs existants, sélectionnez Créer un formulaire interactif avec des pages fixes.
      •
      Pour importer le fichier PDF afin de pouvoir le modifier dans LiveCycle Designer, sélectionnez Créer un formulaire interactif avec une disposition souple.
5.
Cliquez sur Suivant.
6.
(Facultatif) Dans Configuration du renvoi du formulaire : Dans le panneau Ajout de boutons, sélectionnez la manière dont sera distribué le formulaire et la manière dont les données de formulaires devront être renvoyées.
7.
Cliquez sur Terminer.
Pour importer un fichier PDF sans recourir à l'assistant de création de formulaires
1.
Choisissez Fichier > Ouvrir.
2.
Recherchez le fichier PDF à importer, sélectionnez-le et cliquez sur Ouvrir. La boîte de dialogue Options d'importation s'affiche. Cependant, si vous n'avez pas désactivé l'assistant de création de formulaires en désélectionnant l'option Afficher à l'importation de documents dans la boîte de dialogue Options (panneau Assistants et conseils), l'assistant de création de formulaires apparaît. Si nécessaire, cliquez sur Ne pas utiliser l'assistant pour ouvrir la boîte de dialogue Options d'importation.
3.
Dans cette boîte de dialogue, sélectionnez l'option qui correspond le mieux à l'utilisation que vous souhaitez faire du contenu PDF importé :
      •
      Pour conserver la disposition et l'aspect du contenu PDF, sélectionnez Créer un formulaire interactif avec des pages fixes.
      •
      Pour modifier le contenu du document PDF dans LiveCycle Designer, sélectionnez Créer un formulaire interactif avec une disposition souple, puis sélectionnez les options personnalisées en vue d'importer le PDF de la manière désirée.
4.
Cliquez sur OK. Si vous avez sélectionné l'option Afficher un rapport sommaire, une boîte de dialogue dresse la liste des problèmes de conversion potentiels tels que les polices non disponibles et les objets non pris en charge avant l’ouverture du formulaire.
le dossier temporaire est votre répertoire temporaire configuré par Windows (en général \Documents and Settings\[nomutilisateur]\Local Settings\Temp). Le fichier journal porte le même nom que le fichier PDF mais est suivi de l'extension de nom de fichier .log. S'il existe un fichier de même nom dans le dossier temporaire, il est remplacé.
Voir aussi
Ouverture et enregistrement de formulaires
Boîte de dialogue Options d'importation


Contrôle des résultats d'une importation de fichier PDF

La conception de formulaire obtenue suite à l'importation d'un fichier PDF varie en fonction des différentes combinaisons d'options effectuées lors de l'importation. Si la conversion initiale ne vous convient pas, vous pouvez tester différentes combinaisons d'options afin d'améliorer les résultats ou modifier les objets dans la conception de formulaire en utilisant la fonction Superposition de l'éditeur de champs.
La superposition de l'éditeur de champs s'affiche lorsque vous sélectionnez un objet. Elle offre un accès rapide aux commandes les plus couramment utilisées lors de l'édition des objets.
Au départ, les limites d'objet sont visibles dans la conception de formulaire de sorte que vous pouvez visualiser le mode de groupement en objets des éléments du fichier PDF (en particulier le texte). Cela peut rendre difficile et complexe la lecture de la conception du formulaire. A l'aide de la commande Limites de l'objet dans le menu Affichage, vous pouvez masquer les limites d'objet pendant que vous examinez la conception de formulaire. Les limites des objets sont utiles pour apporter des modifications aux objets dans la conception du formulaire. Par exemple, elles vous servent de référence lorsque vous redimensionnez ou déplacez des objets sans bordure. De même, les limites des objets vous permettent de voir si un texte est divisé en plusieurs objets dans la conception du formulaire. Vous pouvez facilement fusionner ces objets en un seul objet de texte à l'aide de la commande Fusionner les objets de texte sélectionnés du menu Disposition.
Le texte dans les titres et les instructions risque d'être divisé en plusieurs objets de texte et de champ. Vous pouvez créer une légende pour un objet de champ n'en comportant pas en le fusionnant avec un objet de texte à l'aide de la commande Fusionner comme légende du menu Disposition.
Les commandes de verrouillage disponibles dans le menu Edition se révèlent également très pratiques. Le verrouillage des objets empêche leur sélection et leur modification dans l'éditeur de disposition. Par exemple, vous pouvez verrouiller le texte de sorte qu'il soit nécessaire de cliquer deux fois sur la légende ou le texte pour le modifier. Le verrouillage rend plus difficile la modification du texte. Vous pouvez également verrouiller les objets statiques tels que le texte, les lignes, les images et les formes ainsi que les objets de champ.
Voir aussi
Conversion des objets PDF dans LiveCycle Designer
Limitation des problèmes de conversion des fichiers PDF
Pour utiliser les accessoires de dessin
Pour fusionner les objets de texte
Pour créer une légende en fusionnant un objet de texte et un objet de champ


Conversion des objets PDF dans LiveCycle Designer

La conversion du contenu PDF au format XDP est tributaire de la source du fichier PDF en question. Les normes PDF offrent un large éventail de styles et de présentations en matière de disposition structurelle, qui peuvent être bien convertis. Le format PDF est souvent utilisé pour générer la mise en page finale du formulaire, ce qui signifie que l'accent est mis sur la présentation du contenu, et non sur le contenu proprement dit.
La plupart du temps, Distiller® ou PDFMaker génèrent bien le fichier PDF, mais ils ne peuvent traiter que les éléments qui leur sont fournis dans l'ordre reçu.
Le tableau ci-dessous identifie les éléments clés d'un fichier PDF et indique comment LiveCycle Designer les traite au cours de l'importation.

Elément

Converti(s)

Ne sont pas convertis
Actions (d'un formulaire Acrobat)
LiveCycle Designer convertit uniquement les actions suivantes associées à un formulaire créé dans Acrobat :
•
Importation de données de formulaire
•
Lancer un URL
•
Réinitialiser un formulaire (listes de champs partielle et complète)
•
Afficher/Masquer un champ
•
Soumettre un formulaire contenant une liste de champs complète
Toutes les autres actions
Calculs
Moyenne
Maximum
Minimum
Somme
Plage
Commentaires/Annotations
Ne sont pas convertis
Document
Les scripts JavaScript situés au niveau du document sont convertis en scripts d'événement et mis en commentaire. Vous devez les vérifier et les mettre à jour afin qu'ils correspondent au modèle de LiveCycle Designer.
Pages et noms
Evénements autres que les scripts JavaScript
Paramètres de protection
Métadonnées des documents, comprenant la version PDF, le titre, l'auteur, le sujet, les mots-clé, le créateur, le producteur et les dates de création et de modification
Les informations d'accessibilité des PDF avec balises sont conservées.
Ordre de tabulation
Champs
Types de champs : dates, texte, champs numériques, cases à cocher, boutons radio, groupes de boutons radio, boutons, zones de liste, signature (identifiée uniquement) et listes déroulantes.
Texte par défaut
Dimensions
Evénements
Nom, taille et style (gras, italique) de police
Les scripts JavaScript sont convertis en scripts d'événement et mis en commentaire. Vous devez les vérifier et les mettre à jour afin qu'ils correspondent au modèle de LiveCycle Designer.
Nom
Formatage des images
Positionnement, orientation, alignement et visibilité
Valeur imprimable
Attributs Lecture seule, Requis, Nombre maximal de caractères et Multiligne
Définitions RVB et niveaux de gris pour l'arrière-plan, les bordures et la couleur. D'autres spécifications de couleurs sont mappées aux valeurs RVB.
L'info-bulle est conservée
Toutes les polices utilisées dans un fichier PDF doivent se trouver sur le système. A défaut, vous devez définir des règles de substitution dans la table de mappage des polices.
LiveCycle Designer utilise un x pour indiquer qu'une case est cochée. Si, dans le fichier PDF, la coche est représentée par un autre caractère, le système le convertit en croix (x). Il se peut que cette dernière ne s'aligne pas parfaitement dans la zone remplissable.
Images
Toutes les images à1 bit, 4 bits, 8 bits et 24 bits
Dimensions
Poste
Images vectorielles
6 bits
32 bits
Certains formats TIFF
Lignes
Couleur (bordure et fond)
Dimensions
Poste
Largeur
Certains styles de pointillés et de tirets
Style
Rectangles
Couleur (bordure et fond)
Dimensions
Poste
Largeur
Certains styles de lignes en pointillé et de tirets
Les rectangles aux coins arrondis sont convertis lorsque le système les détecte. Cela dépend de la manière dont le fichier PDF a été généré.
Style
Scripts
Les scripts JavaScript situés au niveau du document, de la page et du champ sont convertis en scripts d'événement et mis en commentaire. Vous devez les vérifier et les mettre à jour afin qu'ils correspondent au modèle de LiveCycle Designer.
Texte
Contenu
Dimensions
Nom, taille et style (gras, italique) de police
Formatage mixte (texte enrichi)
Poste
Définitions RVB et niveaux de gris pour l'arrière-plan, les bordures et la couleur. D'autres spécifications de couleurs sont mappées aux valeurs RVB.
Toutes les polices utilisées dans un fichier PDF doivent se trouver sur le système. A défaut, vous devez définir des règles de substitution dans la table de mappage des polices.
Les symboles ne s'affichent pas toujours correctement. Vous pouvez définir des règles de mappage des caractères dans la table correspondante.
LiveCycle Designer ne prend pas en charge le crénage des caractères. Lorsqu'il détecte un crénage PDF, le système diminue la taille de la police de façon à ce que le texte occupe le même espace horizontal.
Voir aussi
Pour importer des fichiers PDF
Limitation des problèmes de conversion des fichiers PDF
Ajout d'un nouveau mappage dans la table de mappage des polices dans Designer
Table de mappage des caractères dans ConvertPDF_CharMap.txt


Limitation des problèmes de conversion des fichiers PDF

Vous pouvez éprouver des difficultés lors de l'importation de certains formulaires dans LiveCycle Designer. Les problèmes de conversion peuvent provenir aussi bien de l'application utilisée pour générer le fichier PDF que des choix effectués lors de l'élaboration du document source. Par exemple, les fichiers PDF générés à partir des sources suivantes sont difficiles à importer dans LiveCycle Designer :
      •
      Fichiers Digipath, convertis en une grande image non modifiable
      •
      Fichiers Microsoft Word, lorsque le document n'a pas été spécialement conçu comme un formulaire
Vous pouvez réduire les éventuels problèmes de conversion en tenant compte des points suivants :
      •
      Lors de l'importation, les polices du formulaire qui ne sont pas installées sur votre ordinateur sont automatiquement remplacées. Lorsqu'une police est remplacée, le texte concerné n'est plus affiché tel qu'il a été défini dans le formulaire d'origine.
      •
      Si vous créez des fichiers PDF à l'aide d'Acrobat, n'élaborez pas le formulaire exclusivement à partir d'annotations de dessin.
      •
      Lorsqu'une des images d'un formulaire PDF comprend un grand nombre de lignes, par exemple une image vectorielle, LiveCycle Designer a besoin de plus de temps pour traiter les lignes pendant le processus d'importation. Pour un traitement plus rapide, supprimez l'image du fichier source qui sert à créer le fichier PDF. Vous pourrez toujours la réinsérer une fois que vous aurez enregistré le formulaire dans LiveCycle Designer. Si le fichier source n'est pas disponible, supprimez l'image du formulaire dans LiveCycle Designer pour améliorer les performances du formulaire.
      •
      Si vous rencontrez des problèmes de conversion et que vous avez accès aux fichiers source du formulaire d'origine, essayez de recréer le formulaire PDF à l'aide d'Acrobat Distiller. Si le formulaire PDF d’origine n'a pas été créé correctement, il suffit parfois de le régénérer pour résoudre le problème.
Voir aussi
Pour importer des fichiers PDF


A propos des fichiers PDF accessibles et de leur importation

Lors de l'importation d’un fichier PDF avec balises (PDF accessible), les informations d'accessibilité des contenus de page sont conservées. En outre, l'organisation du formulaire suite à l'ajout ou à la modification de sous-formulaires risque de modifier les informations d'accessibilité.
Pour vous assurer que le formulaire fonctionne toujours de manière acceptable pour les utilisateurs, testez-le de manière approfondie. Faites très attention aux zones suivantes et ajustez-les si elles ne fonctionnent pas comme prévu :
      •
      Info-bulles
      •
      Texte du lecteur d'écran personnalisé
      •
      Ordre de lecture du lecteur d'écran
Voir aussi
Pour importer des fichiers PDF
A propos des formulaires accessibles


A propos des polices et de l'importation de PDF

Au cours de l'importation, LiveCycle Designer tente de faire correspondre les polices du fichier PDF à celles qui sont installées sur l'ordinateur. Si le fichier contient une police non disponible, LiveCycle Designer affiche la boîte de dialogue Polices manquantes signalant la police manquante et une police de substitution. Vous pouvez accepter cette police de substitution ou en choisir une autre. cette substitution de police n'est pas permanente. LiveCycle Designer doit mapper les polices manquantes chaque fois que le formulaire s'ouvre.
Une fois le PDF importé, le panneau Avertissements de la palette Rapport dresse la liste des polices manquantes et explique comment elles ont été converties. Si la table de mappage des polices comprend la police manquante, le panneau Avertissements indique que la police a été remplacée par la nouvelle. Si la police ne se trouve pas dans la table, LiveCycle Designer tente de sélectionner une substitution appropriée. Dans ce cas, le panneau Avertissements indique que la police manquante a été remplacée par la nouvelle. Vous pouvez alors décider de substituer la police de façon permanente ou d'ajouter un nouveau mappage dans la table.


Pour définir la substitution des polices de manière permanente

      •
      Après l'importation, choisissez Fichier > Enregistrer sous, puis cochez la case Remplacer définitivement les polices non disponibles avant d'enregistrer le fichier.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Importation de documents > Importation de fichiers PDF > Ajout d'un nouveau mappage dans la table de mappage des polices dans Designer

Ajout d'un nouveau mappage dans la table de mappage des polices dans Designer

Grâce à cette table stockée dans le fichier Designer.xci, LiveCycle Designer accélère le processus de substitution d'une police manquante par une des polices de l'ordinateur. Elle contient plusieurs entrées par défaut pour le mappage des polices.
Le fichier Designer.xci est situé dans le répertoire d'installation. Cependant, au démarrage de LiveCycle Designer, le fichier XCI est copié dans le répertoire utilisateur.
Vous pouvez modifier les entrées par défaut de la table de mappage des polices dans le fichier Designer.xci.
Syntaxe
<equate from='input_font_*_*' to='LiveCycle Designer_font_*_*' force="0"/>
Paramètres
input_font
Nom de la police utilisée dans le fichier PDF d'entrée.
LiveCycle Designer_font
Nom de la police installée sur l'ordinateur.
Astérisque (*)
Caractère générique. Par exemple, la chaîne *Cour* fait référence à tous les noms de police comportant la chaîne Cour.
Point d'interrogation (?)
Caractère générique unique.
_*_*
Attributs bold (gras) et italic (italique). Les valeurs admises après le premier trait de soulignement sont les suivantes : *, normal et bold. Les valeurs admises après le deuxième trait de soulignement sont les suivantes :*, normal et italic.
Instruction force=« 0 »
Indique à LiveCycle Designer de rechercher la police sur le système et d'utiliser le mappage correspondant uniquement s'il ne trouve pas la police.
Instruction force=« 1 »
Indique à LiveCycle Designer de forcer le mappage de la police qu'elle soit installée ou non.
Exemple
La ligne suivante indique à LiveCycle Designer de mapper la police Courier à Courier New lorsque Courier n'est pas disponible :
<equate from='Courier_*_*' to='Courier New_*_*' force="0"/>
Voir aussi
Pour importer des fichiers PDF
Conversion des objets PDF dans LiveCycle Designer
Table de mappage des polices dans ConvertPDF_FontMap.txt
Table de mappage des caractères dans ConvertPDF_CharMap.txt


Table de mappage des polices dans ConvertPDF_FontMap.txt

Vous pouvez définir une table de mappage des polices dans le fichier ConvertPDF_FontMap.txt.
Si vous ajoutez une règle de mappage à ce fichier, toutes les occurrences de la police substituée sont remplacées par la nouvelle police lorsque vous importez un fichier PDF, sans tenir compte de la table de mappage des polices figurant dans le fichier Designer.xci et même si la police substituée est installée sur le système.
Le fichier ConvertPDF_FontMap.txt se trouve dans le répertoire d'installation et est vide par défaut.
Syntaxe
input_font=LiveCycle Designer_font
input_font
Nom de la police utilisée dans le fichier PDF d'entrée.
LiveCycle Designer_font
Nom de la police installée sur l'ordinateur.
Astérisque (*)
Caractère générique. Par exemple, la chaîne *Cour* fait référence à tous les noms de police comportant la chaîne Cour. L'ajout de caractères génériques avant ou après le nom de la input_font permet de représenter les variations légères du nom de la police dans le formulaire.
Point d'interrogation (?)
Caractère générique unique.
Exemple
*Arial*=Arial
*Helv*=Arial
*Cour*=Courier New
*=Times New Roman
Le traitement s'effectue dans le même ordre que celui du fichier. Dans cet exemple, la dernière ligne convertit toutes les polices restantes en police Times New Roman.
Voir aussi
Pour importer des fichiers PDF
Conversion des objets PDF dans LiveCycle Designer
Ajout d'un nouveau mappage dans la table de mappage des polices dans Designer
Table de mappage des caractères dans ConvertPDF_CharMap.txt


Table de mappage des caractères dans ConvertPDF_CharMap.txt

Les fichiers PDF peuvent contenir des caractères qui sont mappés différemment dans LiveCycle Designer. Pour résoudre ce problème, vous pouvez définir des règles de mappage des caractères dans la table correspondante, c'est-à-dire dans le fichier ConvertPDF_CharMap.txt.
LiveCycle Designer se sert de cette table pour afficher correctement les symboles PDF d'entrée à l'aide de son jeu de caractères natif. La table comprend plusieurs entrées par défaut.
Si une ligne du fichier ConvertPDF_CharMap.txt ne reflète pas votre configuration, vous pouvez la supprimer. Vous pouvez ajouter des lignes supplémentaires, le cas échéant.
Le fichier ConvertPDF_CharMap.txt se trouve dans le répertoire d'installation.
Syntaxe
input_char,input_font=LiveCycle Designer_char,LiveCycle Designer_font
input_char
Valeur décimale du symbole PDF d'entrée.
input_font
Police à laquelle le caractère doit être associé dans le fichier PDF. Un astérisque (*) indique qu'il peut s'agir de n'importe quelle police.
LiveCycle Designer_char
Valeur décimale UTF-8 associée au caractère.
LiveCycle Designer_font
Police désirée qui comprend le caractère. Un astérisque (*) indique que le système doit laisser le nom de la police d'origine tel quel.
Exemple
La ligne suivante convertit les guillemets anglais doubles (« ) PDF de n'importe quelle police en caractère UTF-8 équivalent de la même police.
0144,*=0039,*
Voir aussi
Pour importer des fichiers PDF
Conversion des objets PDF dans LiveCycle Designer
Ajout d'un nouveau mappage dans la table de mappage des polices dans Designer
Table de mappage des polices dans ConvertPDF_FontMap.txt


Importation de documents PDF en tant qu'illustrations

A propos de l'importation de documents PDF en tant qu'illustrations
Pour importer un document PDF en tant qu'illustration
Pour remplacer une illustration PDF
A propos de l'importation de documents PDF structurés en tant qu'illustrations
Pour ajouter une balise de champ à la structure du document
Pour enlever une balise de champ de la structure du document
Pour déplacer une balise de champ vers le haut ou le bas de la structure du document
Pour rechercher des champs non balisés dans la structure du document
Pour afficher les balises de contenu dans la structure du document


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Importation de documents > Importation de documents PDF en tant qu'illustrations > A propos de l'importation de documents PDF en tant qu'illustrations

A propos de l'importation de documents PDF en tant qu'illustrations

Si vous disposez d'un document PDF créé dans Adobe Acrobat ou dans une autre application et souhaitez l'utiliser comme modèle pour la création d'un formulaire PDF dans LiveCycle Designer, vous pouvez vous servir de l'option Créer un formulaire interactif avec des pages fixes dans l'assistant de création de formulaires afin d'importer le contenu du document PDF en tant qu'illustration d'arrière-plan du nouveau formulaire.
Si le document PDF a été créé dans Acrobat et contient des champs de formulaire, LiveCycle Designer convertit ces champs en objets de bibliothèque correspondants. Après avoir importé un PDF en tant qu'illustration, il est possible de placer des objets de bibliothèque supplémentaires sur l'illustration afin d'enrichir la conception de formulaire.
Si vous voulez modifier l'illustration d'arrière-plan, utilisez la commande Remplacer l'illustration du menu Edition afin d'importer un autre document PDF. Pour plus de détails, voir Pour remplacer une illustration PDF.
Rappelez-vous des points suivants au moment de l'importation d'un document PDF en tant qu'illustration :
      •
      Il est possible d'importer des documents en tant qu'illustrations seulement si ces derniers ont été créés dans Acrobat ou dans une application similaire capable de générer des documents PDF. Si le document PDF a été créé à l'aide de LiveCycle Designer, vous ne pouvez pas importer le contenu en tant qu'illustration ; vous pouvez seulement importer le contenu sous forme d'objets de formulaire modifiables.
      •
      Après l'importation d'un document PDF en tant qu'illustration, vous devez enregistrer le formulaire obtenu sous forme d'un formulaire Acrobat PDF (statique). Vous ne pouvez pas enregistrer le formulaire sous forme d'un formulaire Acrobat PDF (dynamique) ou d'un formulaire XML Adobe. Formulaire PDF (statique) Acrobat 7 (*.pdf) correspond au type de fichier par défaut des nouveaux formulaires contenant des illustrations PDF. Vous pouvez modifier le type de fichier défini par défaut dans la boîte de dialogue Options à partir du panneau Gestion du document.
      •
      Il est possible d'importer des documents PDF structurés ou non qui contiennent des balises et dont l'ordre de tabulation et de lecture est défini pour l'accès clavier et les lecteurs d'écran. Pour plus de détails, voir A propos de l'importation de documents PDF structurés en tant qu'illustrations.
      •
      Les objets de bibliothèque suivants ne sont pas disponibles dans les groupes Standard et Personnalisés à l'importation d'un document PDF sous forme d'illustration : Cercle, Zone de contenu, Image, Ligne, Rectangle, Sous-formulaire, Tableau, Texte, Masque de saisie, Masque de saisie partiel, Page n sur m, Feuille n sur m, Signature (imprimer et signer) et Questionnaire.
      •
      Les boutons associés à des icônes dans le document PDF importé ne sont pas pris en charge.
      •
      Si vous ouvrez un document PDF contenant des images en arrière-plan issues d'une version de LiveCycle Designer antérieure à la version utilisée pour créer le document, les données image risquent de ne pas s'afficher correctement dans le document.
      •
      Le script JavaScript au niveau du document, de la page et du champ (dans le document PDF importé en tant qu'illustration) est converti en scripts d'événement mis en commentaire. Vous devez les vérifier et les mettre à jour afin qu'ils correspondent au modèle de LiveCycle Designer. Vous n'êtes plus en mesure de modifier ce script dans Acrobat.
Après l'importation d'un document PDF sous forme d'illustration, vous utilisez le document résultant comme n'importe quel formulaire PDF statique.
Voir aussi
Pour importer un document PDF en tant qu'illustration


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Importation de documents > Importation de documents PDF en tant qu'illustrations > Pour importer un document PDF en tant qu'illustration

Pour importer un document PDF en tant qu'illustration

Vous pouvez importer le contenu d'un document PDF créé dans Adobe Acrobat ou dans d'autres applications disponibles dans la boîte de dialogue Ouvrir, comme l'illustration d'arrière-plan d'un nouveau formulaire PDF.
Pour plus de détails sur les points à considérer lors de l'importation d'un document PDF en tant qu'illustration dans LiveCycle Designer, voir Importation de documents PDF en tant qu'illustrations.
1.
Choisissez Fichier > Ouvrir.
2.
Dans la boîte de dialogue Ouvrir, sélectionner le fichier à importer et cliquez sur Ouvrir. L'assistant de création de formulaires apparaît.
3.
Dans la fenêtre Configuration du document : Dans le panneau Options d'importation, sélectionnez Créer un formulaire interactif avec des pages fixes, puis cliquez sur Suivant.
4.
(Facultatif) Dans Configuration du renvoi du formulaire : Dans le panneau Ajout de boutons, sélectionnez les options correspondant à vos besoins, puis cliquez sur Terminer.
5.
Choisissez Fichier > Enregistrer et enregistrez le formulaire en choisissant un des formats de fichier dans la liste Type.
Voir aussi
Importation de documents PDF en tant qu'illustrations
Pour remplacer une illustration PDF


Pour remplacer une illustration PDF

Vous pouvez remplacer l'illustration d'arrière-plan d'un formulaire PDF à l'aide de la commande Remplacer l'illustration du menu Edition. LiveCycle Designer substitue alors l'illustration d'arrière-plan tout en préservant les objets de champ placés au-dessus de l'illustration d'arrière-plan. Tout champ de formulaire Adobe Acrobat dans l'illustration PDF de remplacement est ignoré et supprimé.
Rappelez-vous que le remplacement de l'illustration PDF influence la structure du PDF. Pour plus de détails, voir A propos de l'importation de documents PDF structurés en tant qu'illustrations.
le remplacement de l'illustration est irréversible. Par conséquent, il est recommandé d'enregistrer votre formulaire PDF avant de remplacer l'illustration.
1.
Choisissez Edition > Remplacer l'illustration.
2.
Choisissez Fichier > Enregistrer et enregistrez le formulaire en choisissant un des formats de fichier dans la liste Type.
Voir aussi
Importation de documents PDF en tant qu'illustrations
Pour importer un document PDF en tant qu'illustration


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Importation de documents > Importation de documents PDF en tant qu'illustrations > A propos de l'importation de documents PDF structurés en tant qu'illustrations

A propos de l'importation de documents PDF structurés en tant qu'illustrations

Vous avez la possibilité d'importer des documents PDF structurés en tant qu'illustrations qui contiennent des balises et des informations structurelles afin de définir un ordre de tabulation et de lecture pour les technologies d'assistance telles que l'accès au clavier et les lecteurs d'écran.
La palette Structure PDF dans LiveCycle Designer présente une vue de la structure hiérarchique des documents PDF balisés et fournit trois types de balises structurelles :
    • <content>
Les balises de contenu s'appliquent au contenu du document. Ces balises sont similaires aux balises HTML et s'affichent en tant que <P>, <H1>, <Sect>, <Figure>, etc. Le contenu du document s'affiche en dessous de ces balises. Les balises de contenu sont fournies à titre de référence seulement et ne sont pas modifiables dans LiveCycle Designer.
    • <formulaire>
Les balises de formulaire font office de conteneurs pour les balises de champ. L'intégralité de la structure des objets de bibliothèque figure sous ce type de balise.
    • <champ>
Les balises de champs correspondent aux objets réels dans le document. Les balises de champ n'existent que sous les balises de formulaire. Chaque balise de champ ne peut être liée qu'à un seul objet. Lorsqu'une balise de champ est liée à un objet, celle-ci indique le nom de l'objet et l'icône qui l'accompagne spécifie le type d'objet dans le document. Si une balise de champ est dissociée d'un objet, elle affiche le texte unlinked field.
Lorsque vous importez un document PDF structuré en tant qu'illustration, LiveCycle Designer conserve la structure et associe automatiquement tout champ de formulaire Adobe Acrobat balisé converti en objet de bibliothèque à la balise de formulaire appropriée dans la structure du document. Cependant, vous pouvez être amené à ajouter manuellement des balises de champ sous les balises de formulaire qui conviennent en présence de champs non balisés restants dans le formulaire. Vous pouvez également insérer des objets de bibliothèque supplémentaires au premier plan de l'illustration PDF et ajouter des balises de champ à la structure du document pour chaque objet.
A l'aide de la palette Structure PDF, vous pouvez examiner les objets associés aux balises de structure dans le formulaire. Lorsque vous cliquez sur une balise de contenu dans la palette Structure PDF, l'objet correspondant dans le formulaire est mis en surbrillance dans le panneau Vue de conception. Si, par exemple, vous cliquez sur une balise de contenu de paragraphe <P> affichée dans la palette Structure PDF, le contenu correspondant, en général du texte, apparaît en surbrillance dans le formulaire.
Après avoir importé un document PDF structuré en tant qu'illustration, vous pouvez utiliser les commandes du menu (et du menu contextuel) de la palette Structure PDF pour ajouter des balises de champ à la structure du document ou les retirer, parcourir la structure, déplacer des champs vers le haut ou le bas de la structure et afficher les balises de contenu au sein de la structure.
n'oubliez pas que vous pouvez seulement modifier la structure des champs dans LiveCycle Designer. Si vous voulez modifier les balises de structure et la structure du contenu dans un formulaire, vous devez utiliser Acrobat.
Le remplacement de l'illustration PDF influence la structure du document.
Lorsque vous changez l'illustration en arrière-plan d'un document PDF structuré, sachez que la structure actuelle est remplacée par la structure de la nouvelle illustration en arrière-plan. Toutes les balises de contenu de l'ancienne illustration sont remplacées par celles de la nouvelle illustration. Les balises de formulaire et de champ sont conservées et fusionnées aux nouvelles balises de contenu. Le contenu des objets de champ est préservé et fusionné à la nouvelle structure de contenu. Vous devrez peut-être déplacer certaines balises de formulaire et de champ si les balises fusionnées ne sont pas placées aux endroits prévus.
Notez que les champs de formulaire qui ont été ajoutés à l'illustration PDF de remplacement dans Acrobat ne sont pas convertis en objets de bibliothèque modifiables correspondants dans LiveCycle Designer.
Si l'illustration PDF de remplacement n'est pas structurée, la structure de l'illustration PDF actuelle est supprimée et le formulaire PDF obtenu est dépourvu de structure.
Voir aussi
Pour importer un document PDF en tant qu'illustration
Pour remplacer une illustration PDF
Palette Structure PDF


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Importation de documents > Importation de documents PDF en tant qu'illustrations > Pour ajouter une balise de champ à la structure du document

Pour ajouter une balise de champ à la structure du document

Vous pouvez sélectionner un objet de champ dans un formulaire, puis ajouter une balise de champ sous la balise de formulaire sélectionnée dans la structure de document. Il est possible d'ajouter une balise de champ sous chaque balise de formulaire.
Vous pouvez également créer une balise de champ en faisant glisser un champ du formulaire sur une balise de structure dans la palette Structure PDF.
1.
Dans le panneau Vue de conception, sélectionnez le champ du formulaire à intégrer à la structure du document.
2.
Dans la palette Structure PDF, cliquez avec le bouton droit de la souris sur la balise de formulaire sous laquelle vous voulez ajouter la balise de champ et choisissez Ajouter une structure de champ.
Voir aussi
Menu de la palette Structure PDF
A propos de l'importation de documents PDF structurés en tant qu'illustrations
Pour remplacer une illustration PDF


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Importation de documents > Importation de documents PDF en tant qu'illustrations > Pour enlever une balise de champ de la structure du document

Pour enlever une balise de champ de la structure du document

      *
      Dans la palette Structure PDF, cliquez avec le bouton droit de la souris sur la balise de champ à supprimer et choisissez Supprimer la structure de champ.
Voir aussi
Menu de la palette Structure PDF
A propos de l'importation de documents PDF structurés en tant qu'illustrations
Pour remplacer une illustration PDF


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Importation de documents > Importation de documents PDF en tant qu'illustrations > Pour déplacer une balise de champ vers le haut ou le bas de la structure du document

Pour déplacer une balise de champ vers le haut ou le bas de la structure du document

      *
      Dans la palette Structure PDF, cliquez avec le bouton droit de la souris sur la balise de champ à déplacer et choisissez Déplacer le champ vers le haut ou Déplacer le champ vers le bas, selon le cas.
Voir aussi
Menu de la palette Structure PDF
A propos de l'importation de documents PDF structurés en tant qu'illustrations
Pour remplacer une illustration PDF


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Importation de documents > Importation de documents PDF en tant qu'illustrations > Pour rechercher des champs non balisés dans la structure du document

Pour rechercher des champs non balisés dans la structure du document

      *
      Dans la palette Structure PDF, cliquez avec le bouton droit de la souris et choisissez Rechercher les champs non balisés.
Voir aussi
Menu de la palette Structure PDF
A propos de l'importation de documents PDF structurés en tant qu'illustrations
Pour remplacer une illustration PDF


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Importation de documents > Importation de documents PDF en tant qu'illustrations > Pour afficher les balises de contenu dans la structure du document

Pour afficher les balises de contenu dans la structure du document

      *
      Dans la palette Structure PDF, cliquez avec le bouton droit de la souris et choisissez Afficher les balises de contenu.
Voir aussi
Menu de la palette Structure PDF
A propos de l'importation de documents PDF structurés en tant qu'illustrations
Pour remplacer une illustration PDF


Importation de fichiers Word

Pour importer un fichier Microsoft Word
Conversion des paramètres et des objets Word dans LiveCycle Designer
Limitation des problèmes de conversion des fichiers Word


Pour importer un fichier Microsoft Word

Vous pouvez importer un fichier Microsoft Word XP ou Microsoft Word 2003 dans LiveCycle Designer. Il peut s'agir d'un document (DOC), d'un modèle (DOT) ou d'un fichier texte enrichi (RTF).
Les objets Word, y compris les paragraphes, les tableaux, les images, les dessins au trait, les champs de formulaire, les en-têtes et les pieds de page sont convertis en objets XML dans LiveCycle Designer et le formatage de texte enrichi est conservé.
si le fichier Word contient des caractères de tabulation soulignés et adjacents (dans le cas où le trait de soulignement est défini comme caractère de tabulation), LiveCycle Designer tente de convertir les informations en champs de texte.
LiveCycle Designer affiche les options d'importation de fichier chaque fois que vous importez un fichier Word.
1.
Choisissez Fichier > Ouvrir.
2.
Dans la liste déroulante Type, sélectionnez Documents Microsoft Word (*.doc, *.dot, *.rtf).
3.
Recherchez le fichier à ouvrir, sélectionnez-le et cliquez sur Ouvrir.
4.
Dans la boîte de dialogue Options d'importation de fichier, indiquez éventuellement un mot de passe pour ouvrir le fichier ou en ôter la protection.
5.
Pour remplacer les polices manquantes et supprimer les messages d'erreur s'y rapportant, sélectionnez l'option Ignorer les polices manquantes.
6.
Pour convertir et incorporer les images dans le modèle de formulaire, sélectionnez l'option Convertir les images.
7.
Sélectionnez une option de consignation dans la liste Générer le fichier journal.
8.
Cliquez sur OK.
comme LiveCycle Designer accède au Presse-Papiers de Windows pour convertir les données, ce dernier n'est pas accessible aux autres applications pendant que LiveCycle Designer importe un fichier Word.
Voir aussi
Boîte de dialogue Options d'importation de fichier (Microsoft InfoPath et Word)
Conversion des paramètres et des objets Word dans LiveCycle Designer
Limitation des problèmes de conversion des fichiers Word


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Importation de documents > Importation de fichiers Word > Conversion des paramètres et des objets Word dans LiveCycle Designer

Conversion des paramètres et des objets Word dans LiveCycle Designer

Lorsque LiveCycle Designer convertit un fichier Word, il conserve sa disposition. Cependant, il se peut que par la suite vous ayez à repositionner des objets manuellement pour parfaire la présentation du formulaire.
Le tableau ci-dessous identifie les objets clés d'un fichier Word et indique comment LiveCycle Designer les traite au cours de l'importation.

Elément

Converti(s)

Non converti(s)
Propriétés de fichier
Les propriétés intégrées et personnalisées sont converties en propriétés de formulaire.
Paragraphes
Contenu (texte, par exemple), y compris le formatage de texte enrichi
Effets de police, tels que Souligné, Barré, Exposant et Indice
Bordures et ombrage appliqués aux paragraphes
Hyperliens
Un soulignement en couleur est converti en trait de soulignement noir.
Effet de police Tout en majuscules
Couleur de la police des numéros de liste si elle est différente de celle du texte
Ombrage des paragraphes vides
Bordures appliquées au texte
Tableaux
Les tableaux sont convertis en sous-formulaires dont le contenu est positionné, et les cellules en sous-formulaires enfant.
Certains styles de bordures ne sont pas pris en charge.
Formes
Zones de texte
Images
Les lignes, les rectangles et les cercles sont pixellisés.
Formes automatiques
Objets OLE
Cadres
Les contrôles ActiveX® sont convertis en images.
Les pointes de flèche sont converties en lignes droites.
Les objets dessinés sont convertis en images.
Pente de ligne
La rotation des formes de dessin n'est pas prise en charge sauf si elle représente un multiple de 90.
Lignes vides à l'intérieur des cadres
Fonctionnalité des contrôles ActiveX
Formes intégrées
Les images et les objets OLE sont considérés comme des caractères. Ils sont positionnés comme s'il s'agissait de caractères dans une ligne de texte.
Les contrôles ActiveX sont convertis en images.
Fonctionnalité des contrôles ActiveX
Champs de formulaire
Les champs de case à cocher sont simplement reproduites. L'état par défaut est maintenu.
Les zones de liste déroulante sont simplement reproduites en listes déroulantes. Tous les éléments des listes sont maintenus.
Les champs de saisie de texte sont simplement reproduits et leur valeur par défaut est conservée.
Le contenu des propriétés HelpText et StatusText est converti en info-bulles.
Formatage des valeurs de la zone Textinput
Objets créés à l'aide d'outils Web
En-têtes et pieds de page
Si tous les en-têtes ou les pieds de page sont identiques, ils sont créés dans le gabarit et positionnés selon les paramètres de formatage des en-têtes et des pieds de page définis dans le document Word.
Dans le cas contraire, ils sont créés sur les pages.
Codes de champ incorporés (date et heure, par exemple)
Paramètres de mise en page
Les paramètres de marge permettent de spécifier la mise en page du sous-formulaire par défaut dans la page.
Les pages multiples sont converties en plusieurs pages distinctes.
Les paramètres Format de papier et Orientation déterminent les propriétés de base de mise en page.
Paramètres de marge intérieure
Scripts
Tous les scripts associés à un champ de formulaire sont convertis en commentaires dans le code source XML de LiveCycle Designer.
Bordures de page
S'il est spécifié, cet attribut est converti en bordure dans le gabarit.
Numéros de ligne
Ne sont pas convertis
Commentaires
Ne sont pas convertis
Attributs de page Web
Ne sont pas convertis
Voir aussi
Pour importer un fichier Microsoft Word
Limitation des problèmes de conversion des fichiers Word


Limitation des problèmes de conversion des fichiers Word

Microsoft Word XP ou Microsoft Word 2003 doivent être installés sur le même ordinateur que LiveCycle Designer.
Si vous importez un fichier Word XP configuré pour l'envoi par messagerie électronique, assurez-vous d'avoir installé Word XP Service Pack 1, sans quoi Word XP se bloquera après l'importation.
Pour optimiser les résultats, assurez-vous que le fichier d'entrée ne comprend pas plus de dix pages.
Voir aussi
Pour importer un fichier Microsoft Word


Importation de données de feuilles de calcul à partir de Microsoft Excel

Pour copier les cellules à partir d'une feuille de calcul Microsoft Excel
Pour créer un formulaire à partir du contenu d'une feuille de calcul Microsoft Excel


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Importation de documents > Importation de données de feuilles de calcul à partir de Microsoft Excel > Pour copier les cellules à partir d'une feuille de calcul Microsoft Excel

Pour copier les cellules à partir d'une feuille de calcul Microsoft Excel

Vous avez la possibilité de copier les cellules d'une feuille de calcul Microsoft Excel pour les coller dans votre formulaire. LiveCycle Designer crée un objet de tableau dans le formulaire avec les mêmes dimensions, le même nombre de cellules et le même contenu que la sélection dans la feuille de calcul.
LiveCycle Designer retient une partie de la mise en forme d'origine des cellules de la feuille de calcul : texte, polices, couleurs, couleurs de l'arrière-plan, alignement et bordures. Si les cellules sélectionnées contiennent des en-têtes de colonne, LiveCycle Designer conserve leur mise en forme dans une rangée d'en-têtes en haut du tableau.
Sachez, cependant, que LiveCycle Designer ne préserve pas les calculs, les scripts, les images et les objets incorporés tels que les graphiques qui figuraient dans la feuille de calcul.
1.
Dans Excel, copiez les cellules de la feuille de calcul qui vous intéressent. Lorsque vous avez terminé, quittez Excel.
2.
Dans LiveCycle Designer, collez les cellules à l'intérieur de votre formulaire.
Voir aussi
Pour créer un formulaire à partir du contenu d'une feuille de calcul Microsoft Excel


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Importation de documents > Importation de données de feuilles de calcul à partir de Microsoft Excel > Pour créer un formulaire à partir du contenu d'une feuille de calcul Microsoft Excel

Pour créer un formulaire à partir du contenu d'une feuille de calcul Microsoft Excel

Vous pouvez vous servir d'une feuille de calcul Microsoft Excel comme modèle pour définir un nouveau formulaire PDF que vous diffuserez aux destinataires par messagerie électronique afin de recueillir le même type de données que dans la feuille de calcul.
A l’aide de l’assistant de création de formulaires, vous pouvez produire un formulaire PDF avec des champs de texte interactifs basés sur les en-têtes de colonne de la feuille de calcul Excel. Cet assistant crée un objet de champ de texte pour chaque colonne de la feuille de calcul. Ces objets sont positionnés dans le formulaire de gauche à droite et placés sur des lignes supplémentaires si besoin est. La légende et le nom de liaison de chaque objet de champ de texte correspond au texte de l'en-tête de colonne dans la feuille de calcul.
Si vous prévoyez un bouton Envoyer par messagerie dans le formulaire, vous pouvez distribuer le formulaire aux destinataires de votre choix pour qu'ils le remplissent et vous le renvoient. Le fait de choisir la commande Diffuser le formulaire dans le menu Fichier a pour effet de fermer le formulaire dans LiveCycle Designer et d'afficher l'assistant de distribution Acrobat. Lorsque vous aurez reçu les formulaires remplis par les destinataires, vous pourrez classer les données recueillies par jeu dans Acrobat. Après réception de plusieurs jeux de données relatifs à un formulaire, vous pouvez réorganiser les informations dans une feuille de calcul.
Sachez, cependant, que LiveCycle Designer ne préserve pas les calculs, les scripts, les images et les objets incorporés tels que les graphiques qui figuraient dans la feuille de calcul.
1.
Choisissez Outils > Créer un formulaire à partir d'une feuille de calcul.
2.
Suivez les instructions affichées à l'écran par l'assistant de création de formulaires. Excel doit être en cours d'exécution pour terminer la procédure dans l'assistant de création de formulaires.
Voir aussi
Pour copier les cellules à partir d'une feuille de calcul Microsoft Excel


Importation de fichiers InfoPath

Pour importer un fichier Microsoft InfoPath
Conversion des objets Microsoft InfoPath dans LiveCycle Designer
Différences entre les objets LiveCycle Designer et les objets InfoPath


Pour importer un fichier Microsoft InfoPath

Vous pouvez importer des fichiers Microsoft InfoPath (XSN) dans LiveCycle Designer. Au cours de l'importation, LiveCycle Designer extrait les composants suivants du fichier d'entrée afin de les utiliser pour créer des éléments XML LiveCycle Designer :
      •
      Un fichier XML décrivant le contenu du paquet
      •
      Un fichier XML décrivant le formulaire InfoPath
      •
      Des fichiers XSL décrivant chacune des vues
      •
      Un fichier de schéma relatif au formulaire InfoPath
      •
      Un fichier script, enregistré comme série de commentaires dans le code source XML de LiveCycle Designer
LiveCycle Designer affiche les options d'importation de fichier chaque fois que vous importez un fichier InfoPath.
1.
Choisissez Fichier > Ouvrir.
2.
Dans la liste Type, sélectionnez Fichiers Microsoft InfoPath (.xsn).
3.
Recherchez le fichier à ouvrir, sélectionnez-le et cliquez sur Ouvrir.
4.
Effectuez l'une des opérations suivantes :
      •
      Si vous souhaitez obtenir une vue, sélectionnez l'option Choisir la vue pendant la conversion. Si le fichier InfoPath dispose uniquement d'une vue, le message ne s'affiche pas, même si vous sélectionnez cette option.
      •
      Si vous connaissez le nom de la vue à importer, indiquez son nom dans la zone Affichage. Pour convertir la vue par défaut, laissez la zone vide.
5.
Effectuez l'une des opérations suivantes :
      •
      Sélectionnez l'option Importer les paramètres d'impression pour importer les en-têtes et les pieds de page, l'orientation de la page et les marges de la page du formulaire InfoPath.
      •
      Si vous connaissez le format de papier du formulaire InfoPath, sélectionnez-le dans la liste ou choisissez le format par défaut.
      •
      Si vous connaissez l'orientation de la page du formulaire InfoPath, sélectionnez-la dans la liste.
si vous sélectionnez l'option Importer les paramètres d'impression, la taille et l'orientation de la page proviennent du formulaire InfoPath. Dans ce cas, vous n'avez pas besoin de les sélectionner.
6.
(Facultatif) Sélectionnez une option dans la liste Générer le fichier journal.
7.
(Facultatif) Pour convertir et incorporer les images dans la conception de formulaire, sélectionnez l'option Intégrer les images dans le XPD.
8.
Cliquez sur OK.
au cours de l'importation d'un fichier InfoPath, LiveCycle Designer transfère les données à l'aide de Microsoft Internet Explorer 5.0 (ou une version ultérieure). Si Internet Explorer n'est pas installé sur votre ordinateur, vous ne pouvez pas importer de fichier InfoPath dans LiveCycle Designer.
Voir aussi
Microsoft InfoPath


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Importation de documents > Importation de fichiers InfoPath > Conversion des objets Microsoft InfoPath dans LiveCycle Designer

Conversion des objets Microsoft InfoPath dans LiveCycle Designer

LiveCycle Designer conserve la disposition des fichiers Microsoft InfoPath lors de la conversion. Cependant, il se peut que par la suite vous ayez à repositionner des objets manuellement pour parfaire la présentation du formulaire.
Le tableau ci-dessous identifie les objets clés d'un fichier InfoPath et indique comment LiveCycle Designer les traite au cours de l'importation.

Elément

Converti(s)

Non converti(s)
Contrôles
Les champs de texte, y compris les champs de texte enrichi, sont reproduits en l'état.
Les zones de liste déroulante sont reproduites en l'état. Les valeurs sont incluses uniquement si l'option est remplie manuellement.
Les zones de liste sont reproduites en l'état.
Les options de sélection de date sont converties en champs de date/heure sauf si le type de données de ces options dans InfoPath est défini sur « Texte (Chaîne) ». Dans ce cas, il est converti en un champ de texte.
Les cases à cocher sont reproduites en l'état.
Les boutons radio sont convertis en boutons radio.
Les boutons sont reproduits en l'état.
Règles de validation
Défilement
Images intégrées aux champs de texte enrichi
Il se peut qu'un groupe de boutons radio ne soit pas converti en un seul groupe de boutons radio.
Les actions d'envoi affectées aux boutons ne sont pas prises en charge.
Propriétés de remplissage des cases à cocher et des boutons radio
Pièces jointes
Commandes personnalisées
Champs d'expression
Ne sont pas convertis
Listes
Les listes numérotées sont converties en texte.
S'il s'agit de listes à puces, seul le texte est reporté tel quel.
Symboles de puces
Images
Les images sont reproduites en l'état.
Images tracées
Schéma
Si le formulaire InfoPath a été conçu à partir d'un schéma, celui-ci est importé et la liaison des données est créée automatiquement dans LiveCycle Designer.
Scripts
Ne sont pas convertis
Zones de défilement
Les zones de défilement sont converties en sous-formulaires.
Sections
Les sections sont converties en sous-formulaires.
Les sections répétitives sont converties en sous-formulaires répétitifs dans un formulaire. Les boutons d'ajout et de suppression sont fournis pour ajouter ou supprimer l'occurrence de la section lors du remplissage du formulaire.
Propriétés Inclure/Exclure
Instructions
Seule une occurrence de section facultative ou répétitive est convertie
Tableaux
Les tables sont converties en tableaux.
Les tableaux répétitifs sont convertis en tableaux répétitifs dans un formulaire. Les boutons d'ajout et de suppression sont fournis pour ajouter ou supprimer l'occurrence de la section lors du remplissage du formulaire.
Certains styles de bordures ne sont pas pris en charge.
Seules les lignes visibles d'un tableau répétitif sont converties.
Les lignes fusionnées verticalement sont converties en sous-formulaires dans une disposition positionnée.
Texte
Le texte est simplement reporté. Les couleurs de surbrillance sont converties en couleurs d'arrière-plan.
Hyperliens


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Importation de documents > Importation de fichiers InfoPath > Différences entre les objets LiveCycle Designer et les objets InfoPath

Différences entre les objets LiveCycle Designer et les objets InfoPath

LiveCycle Designer et InfoPath prennent en charge des fonctions et des propriétés d'objet différentes. Les différences les plus évidentes sont les suivantes :
      •
      Il n'est pas possible de placer des images dans les champs de texte de LiveCycle Designer.
      •
      LiveCycle Designer ne prend pas en charge les listes numérotées par ordre séquentiel modifiable, ni les listes à puces.
Voir aussi
Pour importer un fichier Microsoft InfoPath


Utilisation des tableaux

A propos des tableaux
Création de tableaux
Sélection, copie, déplacement et navigation
Insertion et suppression
Formatage d'un tableau
Alignement, redimensionnement et réorganisation des tableaux
Manipulation des données dans les tableaux
Création de tableaux extensibles
Pagination et utilisation de rangées d'en-tête et de pied de page dans les tableaux
Manipulation des cellules et du contenu des cellules
Utilisation des sections de tableau
Manipulation des sections de choix dans les tableaux


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > A propos des tableaux

A propos des tableaux

Parties d'un tableau
Types de tableaux


Parties d'un tableau

Un tableau est constitué de rangées et de colonnes de cellules qui peuvent contenir des champs de formulaire ou dans lesquelles vous pouvez fusionner des données. Cet exemple montre les différentes parties qui constituent un tableau.
Voir aussi
Types de tableaux
A propos de la création des tableaux


Types de tableaux

Vous pouvez créer deux types de tableaux dans les conceptions de formulaire de LiveCycle Designer :
      •
      Les tableaux statiques comportent un nombre fixe de colonnes et de rangées. Cet exemple représente un tableau comportant quatre colonnes et quatre rangées, avec une rangée d'en-têtes et une rangée de pieds de page.
      •
      Les tableaux comportent un nombre fixe de colonnes, mais le nombre de rangées change selon le volume d'informations de la source de données.
Un tableau interactif peut également s'agrandir ou rétrécir lorsqu'un utilisateur ajoute une rangée ou en supprime en cliquant sur le bouton correspondant.
Voir aussi
Parties d'un tableau
A propos de la création des tableaux


Création de tableaux

A propos de la création des tableaux
Pour créer un tableau à l'aide de l'assistant
Pour créer un tableau simple
Pour créer un tableau à partir d'objets existants
Pour créer un tableau à l'intérieur d'un autre
Pour importer un tableau à partir de Microsoft Word
Pour créer un tableau à partir de sous-formulaires
Pour créer un tableau imbriqué à partir de sous-formulaires


A propos de la création des tableaux

Cette rubrique présente les différentes méthodes de création d'un tableau.

Tâche

Méthode
A un endroit précis de la conception de formulaire, créez un tableau vide possédant un nombre fixe de rangées et de colonnes.
Faites glisser l'objet de tableau de la palette Bibliothèque vers l'emplacement souhaité sur votre conception de formulaire. Dans la boîte de dialogue Insérer un tableau, indiquez le nombre de colonnes et de rangées. Voir Pour créer un tableau simple.
A la fin de la conception de formulaire actuelle, créez un tableau vide possédant un nombre fixe de rangées et de colonnes.
Choisissez Tableau > Insérer un tableau, sélectionnez Créer un tableau simple, puis spécifiez le nombre de colonnes et de rangées de contenu. Voir Pour créer un tableau simple.
A un endroit précis de la conception de formulaire, créez un tableau avec un nombre de rangées variable en fonction de la quantité de données à afficher.
Si vous êtes connecté à une source de données, faites glisser un élément identifié comme groupe de données qui se répètent (affichées avec une icône de tableau) à partir de la palette Vue des données. Occupez-vous du format du tableau. Voir Pour créer un tableau à partir d'une source de données.
A la fin de la conception de formulaire actuelle, créez un tableau vide avec un nombre de rangées variable en fonction de la quantité de données à afficher.
Choisissez Tableau > Insérer un tableau, puis sélectionnez Créer un tableau à l'aide de l'assistant. Sélectionnez l'option Rangée de contenu varie selon données et suivez les instructions de l'assistant. Voir Pour créer un tableau à l'aide de l'assistant.
Créez un tableau à partir d'objets existants.
Sélectionnez les objets, puis choisissez Tableau > Convertir en tableau. Voir Pour créer un tableau à partir d'objets existants.
Créez un tableau à l'intérieur d'un autre.
Créez le tableau principal, puis créez le tableau que vous souhaitez insérer dans celui-ci Sélectionnez le second tableau, puis faites-le glisser dans la cellule dans laquelle il doit s'insérer. Vous pouvez également sélectionner la cellule du tableau principal, puis choisir Tableau > Insérer un tableau. Voir Pour créer un tableau à l'intérieur d'un autre.
Importez un tableau à partir d'une autre application.
Choisissez Fichier > Ouvrir et localisez le fichier (document Microsoft Word, par exemple) contenant le tableau. Voir Pour importer un tableau à partir de Microsoft Word.
Voir aussi
A propos des tableaux


Pour créer un tableau à l'aide de l'assistant

L'assistant de création de tableaux simplifie et rationalise le processus de création d'un tableau en permettant de définir facilement certains éléments de base d'un tableau avant de le placer dans un formulaire. Par exemple, la boîte de dialogue Assistant de création de tableaux offre des options permettant d'ajouter des colonnes et des rangées de contenu, d'ajouter des rangées d'en-tête et de pied de page et d'ombrer les rangées.
Vous pouvez faire appel à cet assistant pour créer des tableaux avec un nombre fixe de rangées et de colonnes, ou avec un nombre fixe de colonnes et un nombre de rangées qui varie en fonction de la quantité d'informations provenant de la source de données.
Au fur et à mesure que vous sélectionnez les options, vous voyez le tableau prendre forme dans la zone Aperçu de l'assistant. Après avoir créé un tableau avec l'assistant, vous pouvez le modifier à l'aide des commandes du menu Tableau et des diverses options des palettes Disposition, Bordure, Objet et Accessibilité.
par défaut, la boîte de dialogue Insérer un tableau s'affiche lorsque vous choisissez Insertion > Standard > Tableau ou lorsque vous faites glisser l'objet de tableau dans l'éditeur de disposition. En revanche, si vous avez sélectionné au préalable l'option Ne plus afficher dans la boîte de dialogue Insérer un tableau, vous pouvez toujours revenir au comportement par défaut en choisissant Outils > Options > Assistants et conseils, puis en sélectionnant l'option Afficher à la création de tableaux.
1.
Choisissez Tableau > Insérer un tableau, puis sélectionnez Créer un tableau à l'aide de l'assistant.
2.
Dans l'assistant de création de tableaux, spécifiez la disposition du contenu, puis cliquez sur Suivant :
      •
      Pour ajouter un nombre précis de rangées et de colonnes, choisissez l'option Contenu aux dimensions fixes, puis sélectionnez les valeurs correspondantes dans les listes Nombre de colonnes et Nombre de rangées de contenu.
      •
      Pour créer un tableau dont le nombre de rangées de contenu correspond au nombre de rangées de données, choisissez l'option Rangées de contenu varient selon données, puis sélectionnez une valeur dans la liste Nombre de colonnes.
3.
Indiquez si vous souhaitez ajouter une rangée d'en-tête, puis cliquez sur Suivant :
      •
      Si vous ne souhaitez pas ajouter de rangée d'en-tête, sélectionnez l'option Aucune rangée d'en-tête.
      •
      Si vous souhaitez en ajouter une, sélectionnez l'option Avec rangée d'en-tête, puis sélectionnez l'option Rangée à chaque page, le cas échéant. Cette dernière option n'est disponible que si vous sélectionnez l'option Rangées de contenu varient selon données sur la page Disposition du contenu.
4.
Précisez si vous souhaitez ajouter une rangée de pied de page, puis cliquez sur Suivant :
      •
      Si vous ne souhaitez pas ajouter de rangée de pied de page, sélectionnez l'option Aucune rangée de pied de page.
      •
      Si vous souhaitez en ajouter une, sélectionnez l'option Avec rangée de pied de page, puis sélectionnez l'option Rangée pied de page ttes pg, le cas échéant. Cette dernière option n'est disponible que si vous sélectionnez l'option Rangées de contenu varient selon données sur la page Disposition du contenu.
5.
Indiquez les sections à ajouter, puis cliquez sur Suivant.
      •
      Pour ajouter des rangées de contenu sans section, sélectionnez l'option Avec rangées de contenu et sans section.
      •
      Pour ajouter des rangées de contenu groupées dans des sections, sélectionnez l'option Avec sections de rangées de contenu, puis procédez de la façon suivante :
      •
      Utilisez les boutons d'ajout et de suppression situés au-dessus de la liste Sections pour respectivement ajouter et supprimer des sections, ou les flèches vers le haut et le bas pour organiser les sections en fonction de vos besoins.
      •
      Pour renommer une section de la liste Sections, cliquez deux fois sur la section concernée, puis changez son nom dans la boîte de dialogue Section du tableau.
      •
      Pour appliquer des options à une section, sélectionnez-la dans la liste Sections, puis faites vos choix sous la zone Options de la section. Si vous sélectionnez l'option Section facultative, le nombre minimum d'occurrence de la section est fixé à 0. Autrement dit, si la section ne contient aucune donnée, elle ne s'affiche pas.
6.
Spécifiez l'ombrage de la rangée, puis cliquez sur Terminer :
      •
      Sélectionnez l'option Alternance des couleurs de rangées.
      •
      Dans la liste Premier, sélectionnez le nombre de rangées initiales auxquelles l'ombrage doit être appliqué, puis sélectionnez une couleur.
      •
      Dans la liste Suivant, sélectionnez le nombre de rangées suivantes auxquelles l'ombrage doit être appliqué, puis sélectionnez une couleur.
Voir aussi
Pour répéter une rangée d'en-tête ou de pied de page sur plusieurs pages


Pour créer un tableau simple

Vous pouvez créer un tableau simple, avec ou sans rangées d'en-tête et de pied de page, comprenant un certain nombre de colonnes et de rangées. Cet exemple représente un tableau comportant quatre colonnes et quatre rangées, avec une rangée d'en-tête et une rangée de pied de page.
1.
Dans la palette Bibliothèque, cliquez sur la catégorie Standard, puis sélectionnez l'objet de tableau [image].
2.
Cliquez à l'endroit où le tableau doit apparaître.
lorsque vous sélectionnez l'objet de tableau dans la palette Bibliothèque, si vous avez auparavant choisi l'option Ne plus afficher dans la boîte de dialogue Insérer un tableau, LiveCycle Designer insère automatiquement un tableau avec le même nombre de rangées et de colonnes que le dernier tableau inséré.
3.
Dans la boîte de dialogue Insérer un tableau, indiquez le nombre de colonnes et de rangées.
Vous pouvez demander un maximum de 20 colonnes et 50 rangées. Une fois le tableau créé, vous pouvez continuer à ajouter des rangées et des colonnes par l'intermédiaire des commandes Insérer du menu Tableau.
4.
(Facultatif) Pour ajouter une rangée d'en-tête, sélectionnez l'option Inclure la rangée d'en-tête dans le tableau.
5.
(Facultatif) Pour ajouter une rangée de pied de page, sélectionnez l'option Inclure la rangée de pied de page dans le tableau.
6.
Cliquez sur OK.
Voir aussi
Pour répéter une rangée d'en-tête ou de pied de page sur plusieurs pages


Pour créer un tableau à partir d'objets existants

Si vous disposez d'un formulaire contenant des objets de champ présentés sous forme tabulaire, vous pouvez facilement les convertir en tableau. Le modèle de note de chargement, par exemple, livré avec LiveCycle Designer contient des champs au format tabulaire.
1.
Ouvrez un formulaire contenant des champs en format tabulaire.
Par exemple, créez un formulaire basé sur le modèle de note de chargement. Pour ce faire, choisissez Fichier > Nouveau, puis sélectionnez l'option Utiliser un modèle. Cliquez sur Suivant, puis sélectionnez le modèle Note de chargement. Cliquez sur Suivant et complétez l'assistant de création de formulaires.
2.
Faites glisser les objets à convertir en tableau.
Sélectionnez, par exemple, la rangée d'en-tête et les rangées de contenu, mais arrêtez au-dessus de la section des conditions de livraison et d'assurance.
3.
Sélectionnez Tableau > Convertir en tableau.
tous les groupes de champs peuvent être convertis en tableau. Dans ce même modèle, par exemple, vous pouvez convertir les champs Expédier à et Expéditeur en un tableau.


Pour créer un tableau à l'intérieur d'un autre

Vous pouvez créer un tableau à l'intérieur d'un autre tableau, qui soit indépendant du tableau principal. Le tableau imbriqué peut, par exemple, posséder un nombre de colonnes et de rangées différent du tableau principal. Le nombre de niveaux d'imbrication des tableaux n'est pas limité.
1.
Créez un tableau. Voir Pour créer un tableau simple.
2.
Dans la palette Bibliothèque, cliquez sur la catégorie Standard, puis faites glisser l'objet de tableau dans une cellule du tableau principal.
lorsque vous sélectionnez l'objet de tableau dans la palette Bibliothèque, si vous avez auparavant choisi l'option Ne plus afficher dans la boîte de dialogue Insérer un tableau, LiveCycle Designer insère automatiquement un tableau avec le même nombre de rangées et de colonnes que le dernier tableau inséré.
3.
Dans la boîte de dialogue Insérer un tableau, indiquez le nombre de colonnes et de rangées.
Vous pouvez demander un maximum de 20 colonnes et 50 rangées. Une fois le tableau créé, vous pouvez continuer à ajouter des rangées et des colonnes par l'intermédiaire des commandes Insérer du menu Tableau.
4.
(Facultatif) Pour ajouter une rangée d'en-tête, sélectionnez l'option Inclure la rangée d'en-tête dans le tableau.
5.
(Facultatif) Pour ajouter une rangée de pied de page, sélectionnez l'option Inclure la rangée de pied de page dans le tableau.
6.
Cliquez sur OK.
si le tableau existe déjà, vous pouvez le sélectionner et le faire glisser dans la cellule où il doit apparaître.


Pour importer un tableau à partir de Microsoft Word

Vous pouvez importer un tableau provenant de Microsoft Word dans LiveCycle Designer.
1.
Dans LiveCycle Designer, choisissez Fichier > Ouvrir.
2.
Dans la liste Type, sélectionnez Document Microsoft Word.
3.
Sélectionnez le document Microsoft Word contenant le tableau et cliquez sur Ouvrir.
LiveCycle Designer affiche l'assistant de création de formulaires et l'option Importer un document Word est automatiquement sélectionnée.
4.
Cliquez sur Suivant et répondez aux questions de l'assistant de création de formulaires.
5.
Entrez les informations requises dans la boîte de dialogue Options d'importation de fichier et cliquez sur OK.
LiveCycle Designer importe le contenu du document, y compris le tableau.
Voir aussi
Pour transformer une cellule en un autre type d'objet


Pour créer un tableau à partir de sous-formulaires

Vous pouvez créer un tableau à l’aide de sous-formulaires. Les sous-formulaires peuvent contenir différents objets, comme des boutons, des champs de texte et d'autres sous-formulaire. L'option d'enchaînement du sous-formulaire indique le mode d'agencement des objets qu'il contient. En général, pour créer des tableaux, vous devez utiliser l'objet Tableau de la palette Bibliothèque. Si vous avez besoin de créer un tableau complexe, avec des colonnes non alignées, utilisez des sous-formulaires.
1.
Esquissez le tableau :
      •
      Cliquez sur la catégorie Standard de la palette Bibliothèque, puis faites glisser un objet de sous-formulaire sur le formulaire.
      •
      Redimensionnez le sous-formulaire pour qu'il corresponde à la largeur de tableau voulue.
      •
      Augmentez la hauteur du sous-formulaire pour pouvoir y ajouter un ou plusieurs sous-formulaires enfant.
      •
      Donnez un nom au sous-formulaire dans la zone Nom située sous l'onglet Liaison de la palette Objet. Par exemple, saisissez TableParent.
      •
      Dans la palette Accessibilité, sélectionnez Tableau dans la liste Rôle du sous-formulaire.
2.
Créez un en-tête de tableau :
      •
      Faites glisser un autre objet de sous-formulaire dans le formulaire TableauParent.
      •
      Faites en sorte que la largeur du sous-formulaire d'en-tête corresponde à celle du sous-formulaire parent et que la hauteur du sous-formulaire corresponde à la hauteur requise pour la rangée d'en-tête.
      •
      Donnez un nom au sous-formulaire dans la zone Nom située sous l'onglet Liaison de la palette Objet. Par exemple, saisissez TableHeader.
      •
      Dans la palette Accessibilité, sélectionnez En-tête dans la liste Rôle du sous-formulaire.
3.
Ajoutez du texte dans les en-têtes de colonne :
      •
      Faites glisser un objet de texte dans le sous-formulaire TableauEn-tête.
      •
      Cliquez deux fois sur le texte de l'objet de texte et tapez le nom de la colonne.
      •
      Répétez l'opération autant de fois que nécessaire pour ajouter d'autres en-têtes au tableau.
4.
Créez une rangée de contenu représentant la rangée du tableau destinée à se répéter.
      •
      Faites glisser un autre objet de sous-formulaire dans le formulaire TableauParent.
      •
      Faites en sorte que la largeur du sous-formulaire de rangée de contenu corresponde à celle du sous-formulaire parent et que la hauteur du sous-formulaire corresponde à la hauteur requise pour la rangée de contenu.
      •
      Donnez un nom au sous-formulaire dans la zone Nom située sous l'onglet Liaison de la palette Objet. Par exemple, saisissez TableBodyRow.
      •
      Ajoutez le même nombre de champs sous les en-têtes que celui indiqué à l'étape 3, de façon à afficher les valeurs des données dans le tableau. Définissez la taille des champs.
      •
      Dans la liste Position de la palette Disposition, sélectionnez Aucune.
      •
      Dans la palette Accessibilité, sélectionnez Rangée d'en-tête dans la liste Rôle du sous-formulaire.
      •
      Dans la palette Objet, cliquez sur l'onglet Liaison et sélectionnez l'option Sous-formulaire pour chaque élément.
5.
Sélectionnez le sous-formulaire TableauParent, cliquez sur l'onglet Sous-formulaire de la palette Objet, puis sélectionnez Distribué dans la liste Type.
6.
(Facultatif) Essayez d'améliorer le tableau en suivant la procédure ci-dessous :
      •
      Ajoutez des bordures et des remplissages à l'aide de la palette Bordure.
      •
      Indiquez des débuts et des fins de débordement pour les rangées du tableau.
Pour créer un tableau contenant des cellules de largeur variable
1.
Créez plusieurs tableaux. Chaque tableau doit contenir une rangée de contenu. Le premier tableau doit contenir une rangée d'en-tête et les autres tableaux une seule rangée de contenu.
2.
Placez les tableaux l'un au-dessous de l'autre.
3.
Placez tous ces tableaux dans un sous-formulaire parent.
4.
Ajustez la largeur de chaque cellule comme il convient.
5.
Sélectionnez l'option Distribué pour le sous-formulaire parent.
Voir aussi
Aperçu des sous-formulaires
A propos des débuts et fins de débordement
Propriétés de la palette Bordure
Propriétés de la palette Accessibilité


Pour créer un tableau imbriqué à partir de sous-formulaires

Après avoir créé un tableau à partir de sous-formulaires, vous pouvez insérer un tableau dans une cellule. Par exemple, pour afficher deux tableaux indépendants l'un à côté de l'autre (dans des cellules distinctes) ou imbriquer des données tabulaires.
Avant d'insérer un tableau dans une cellule, vous devez placer la cellule dans un sous-formulaire.
1.
Commencez le tableau imbriqué :
      •
      Sélectionnez la cellule (dans le tableau créé à l'aide de sous-formulaires) de destination du sous-formulaire imbriqué.
      •
      Choisissez Insertion > Placer dans un sous-formulaire.
      •
      Donnez un nom au sous-formulaire dans la zone Nom située sous l'onglet Liaison de la palette Objet. Par exemple, saisissez Wrapper.
2.
Créez le tableau imbriqué.
      •
      Cliquez de nouveau sur la cellule avec le bouton droit de la souris et choisissez Placer dans un sous-formulaire ou faites glisser l'objet de sous-formulaire de la palette Bibliothèque vers la cellule.
      •
      Donnez un nom au sous-formulaire dans la zone Nom située sous l'onglet Liaison de la palette Objet. Par exemple, saisissez NestedTable.
      •
      Dans la palette Accessibilité, sélectionnez Tableau dans la liste Rôle du sous-formulaire.
3.
Cliquez sur la cellule avec le bouton droit de la souris (Texte1, dans l'exemple) et choisissez Supprimer.
4.
Créez une rangée d'en-tête pour le tableau imbriqué :
      •
      Faites glisser un autre objet de sous-formulaire dans le sous-formulaire TableauImbriqué.
      •
      Fixez la largeur et la hauteur de la rangée d'en-tête.
      •
      Donnez un nom au sous-formulaire dans la zone Nom située sous l'onglet Liaison de la palette Objet. Par exemple, saisissez NestedRow1.
      •
      Dans la palette Accessibilité, sélectionnez En-tête du tableau dans la liste Rôle du sous-formulaire.
il est possible qu'un sous-formulaire inséré dans un sous-formulaire parent pour lequel l'option Distribué a été sélectionnée n'apparaisse pas à la bonne place dans la palette Hiérarchie.
5.
Ajoutez du texte dans les en-têtes de colonne :
      •
      Dans la palette Bibliothèque, cliquez sur la catégorie Standard et faites glisser deux objets de texte dans RangéeImbriquée1.
      •
      Sélectionnez un des objets de texte et affectez-lui un nom. Par exemple, saisissez Description.
      •
      Sélectionnez le second objet de texte et affectez-lui un nom. Par exemple, saisissez Cost.
      •
      Sélectionnez les deux objets de texte de RangéeImbriquée1, puis choisissez Disposition > Groupe.
6.
Créez une rangée de contenu pour le tableau imbriqué :
      •
      Faites glisser un autre objet de sous-formulaire dans le sous-formulaire TableauImbriqué.
      •
      Définissez la largeur et la hauteur de la rangée de contenu.
      •
      Donnez un nom au sous-formulaire dans la zone Nom située sous l'onglet Liaison de la palette Objet. Par exemple, saisissez NestedRow2.
      •
      Dans la palette Accessibilité, sélectionnez Rangée d'en-tête dans la liste Rôle du sous-formulaire.
      •
      Dans la palette Bibliothèque, cliquez sur la catégorie Standard et faites glisser trois objets de champ dans RangéeImbriquée2 (tels que des champs de texte).
7.
Sélectionnez l'option Distribué pour les parties du tableau :
      •
      Sélectionnez le sous-formulaire TableauImbriqué, cliquez sur l'onglet Sous-formulaire de la palette Objet, puis sélectionnez Distribué dans la liste Type.
      •
      Sélectionnez le sous-formulaire contenant le sous-formulaire TableauImbriqué appelé (sous-formulaire sans titre) (page 1), cliquez sur l'onglet Sous-formulaire de la palette Objet, puis sélectionnez Distribué dans la liste Type.
La palette Hiérarchie pourrait ressembler à l'illustration ci-dessous.
Voici à quoi pourrait ressembler le formulaire dans l'onglet Aperçu PDF.
Voir aussi
Aperçu des sous-formulaires
A propos des débuts et fins de débordement
Propriétés de la palette Bordure
Propriétés de la palette Accessibilité


Sélection, copie, déplacement et navigation

Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section
Pour copier un tableau, une rangée, une colonne, une cellule ou une section
Pour déplacer un tableau
Pour atteindre une rangée spécifique
A propos de la navigation dans les tableaux des formulaires accessibles


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Sélection, copie, déplacement et navigation > Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section

Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section

Plusieurs méthodes permettent de sélectionner des rangées, des colonnes, des cellules, des sections ou un tableau entier.
      •
      Cliquez dans le tableau, puis utilisez les commandes Sélectionner du menu Tableau.
      •
      Faites glisser le pointeur de la souris pour sélectionner différentes parties du tableau.
      •
      Sélectionnez des objets dans la palette Hiérarchie.
Vous pouvez également recourir à l'une des méthodes suivantes.
Pour sélectionner le tableau entier
      *
      Cliquez dans la zone située en haut à gauche du tableau, ou sélectionnez tout le tableau par cliquer-glisser.
Pour sélectionner les cellules d'une rangée
      *
      Cliquez dans la zone située à gauche de la rangée jusqu'à ce que la flèche suivante s'affiche.
Pour sélectionner une rangée
      *
      Cliquez dans la zone située à gauche de la rangée jusqu'à ce que la flèche suivante s'affiche.
Pour sélectionner les cellules d'une colonne
      *
      Cliquez au-dessus de la colonne.
Pour sélectionner une cellule
      *
      Cliquez sur le bord inférieur droit de la cellule.
après avoir sélectionné une cellule, vous pouvez en sélectionner d'autres en utilisant les touches fléchées pour vous déplacer dans le tableau. Pour sélectionner plusieurs cellules adjacentes, appuyez simultanément sur la touche Maj et sur la touche fléchée.
Pour sélectionner plusieurs rangées, colonnes, cellules ou sections
      *
      Faites glisser le pointeur de la souris pour sélectionner des rangées, colonnes, cellules ou sections.
Pour sélectionner plusieurs éléments qui ne sont pas attenants, cliquez sur la première rangée, colonne, cellule ou section souhaitée et appuyez sur Ctrl tout en cliquant sur les rangées, colonnes, cellules ou sections suivantes à prendre en compte.
Pour sélectionner des cellules adjacentes, cliquez dans la première cellule, puis appuyez simultanément sur Maj et sur les touches fléchées pour sélectionner d'autres cellules du tableau.
les rangées, colonnes, cellules ou sections doivent se trouver dans le même tableau. Un tableau imbriqué est considéré comme un tableau distinct.
Pour sélectionner une section
      *
      Cliquez sur le crochet droit qui marque un début de section.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Sélection, copie, déplacement et navigation > Pour copier un tableau, une rangée, une colonne, une cellule ou une section

Pour copier un tableau, une rangée, une colonne, une cellule ou une section

1.
Sélectionnez le tableau, la rangée, la colonne ou la section à copier. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Effectuez l'une des opérations suivantes :
      •
      Appuyez sur Ctrl et faites glisser la copie vers un nouvel emplacement.
      •
      Sélectionnez Edition > Copier, cliquez à l'endroit où vous souhaitez placer l'objet, puis choisissez Edition > Coller.
      •
      Choisissez Edition > Dupliquer. Cette commande ne fonctionne pas pour des cellules seules ou des cellules de rangées.
pour obtenir plusieurs copies qui sont positionnées et alignées, utilisez la commande Multiplier du menu Edition. Cette commande ne fonctionne pas pour des cellules seules ou des cellules de rangées.


Pour déplacer un tableau

1.
Sélectionnez le tableau. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Cliquez en haut ou à gauche du tableau jusqu'à ce qu'il se transforme en curseur de déplacement [image], puis faites-le glisser vers son nouvel emplacement.


Pour atteindre une rangée spécifique

Si le tableau est long, vous pouvez atteindre une rangée particulière, qu'il s'agisse d'une rangée d'en-tête, de contenu ou de pied de page.
1.
Sélectionnez une partie du tableau, puis choisissez Tableau > Atteindre la rangée.
2.
Sélectionnez Rangée d'en-tête, Rangée de contenu ou Rangée de pied de page.
Vous pouvez également accéder à une rangée d'en-tête ou de pied de page particulière à l'intérieur d'une section.
3.
Tapez le numéro de la rangée à laquelle vous souhaitez accéder, puis cliquez sur OK.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Sélection, copie, déplacement et navigation > A propos de la navigation dans les tableaux des formulaires accessibles

A propos de la navigation dans les tableaux des formulaires accessibles

Dans les formulaires accessibles, les lecteurs d’écran lisent les informations présentes à l’emplacement du curseur dans le tableau. Dès qu’un utilisateur accède une cellule du tableau dans le formulaire, le lecteur d’écran en lit le contenu. S’il accède à une cellule contenant un tableau imbriqué, le lecteur d’écran lit le contenu de la cellule et du tableau imbriqué.
Les champs modifiables d’un tableau imbriqué font partie de l’ordre de tabulation du formulaire. Par conséquent, les utilisateurs peuvent se déplacer entre les champs modifiables d’un tableau imbriqué à l’aide des touches de direction fléchées. Dès que l’utilisateur accède à un tableau imbriqué et en ressort, les informations du début et de la fin du tableau sont lues.
avec JAWS, ces informations ne sont pas lues en mode curseur virtuel.

Résultat

Action
Le lecteur d’écran lit la cellule de tableau active.
Ctrl+Alt+5 (pavé numérique)
Déplacement horizontal entre les cellules.
Ctrl+Alt+Flèche Droite ou Gauche
Déplacement vertical entre les cellules.
Ctrl+Alt+Flèche Haut ou Bas
Voir aussi
Personnalisation des raccourcis clavier
A propos des formulaires accessibles
Observations générales sur la conception de formulaires accessibles
Lecteurs d'écran pris en charge
Conseils sur la conception de formulaires pour lecteurs d'écran


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Insertion et suppression

Insertion et suppression

Pour insérer une rangée, une colonne ou une section
Pour supprimer un tableau, une rangée, une colonne ou une section


Pour insérer une rangée, une colonne ou une section

1.
Sélectionnez une partie du tableau.
2.
Choisissez Tableau > Insérer, puis sélectionnez une option.
lorsque vous insérez une section, LiveCycle Designer y ajoute par défaut une rangée d'en-tête.


Pour supprimer un tableau, une rangée, une colonne ou une section

Pour supprimer un tableau
1.
Sélectionnez le tableau. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Choisissez Tableau > Supprimer, puis cliquez sur Tableau.
pour supprimer un tableau qui n'est pas imbriqué, choisissez Tableau > Supprimer.
Pour supprimer une rangée, une colonne ou une section
1.
Sélectionnez les rangées, les colonnes ou les sections. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Choisissez Tableau > Supprimer, puis cliquez sur Rangée, Colonne ou Section.


Formatage d'un tableau

Pour ajouter un titre à un tableau
Pour ajouter de l'espace autour d'un tableau
Pour ajouter de l'espace autour des cellules
Pour ajouter de l'espace autour des rangées
Pour appliquer des bordures et un ombrage à un tableau
Pour répartir uniformément les rangées et les colonnes
Pour formater des coins d'un tableau ou de cellules
Pour créer un style de tableau pour la bibliothèque personnalisée
Pour afficher des légendes dans les rangées
Pour créer un calendrier à l'aide d'un tableau


Pour ajouter un titre à un tableau

1.
Dans la palette Bibliothèque, cliquez sur la catégorie Standard, puis faites glisser l'objet de texte [image] au-dessus du tableau.
2.
Cliquez deux fois sur le texte par défaut, puis saisissez le titre.
3.
Définissez les propriétés de la police.
vous pouvez également fusionner les cellules de la première rangée du tableau et y saisir le titre.


Pour ajouter de l'espace autour d'un tableau

Vous pouvez ajouter de l'espace autour des contours d'un tableau en utilisant des marges.
1.
Sélectionnez le tableau. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Définissez les marges (supérieure, inférieure, de droite et de gauche) dans la palette Disposition.


Pour ajouter de l'espace autour des cellules

Vous pouvez ajouter de l'espace autour des cellules en utilisant des marges.
1.
Sélectionnez la cellule. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Définissez les marges (supérieure, inférieure, de droite et de gauche) dans la palette Disposition.


Pour ajouter de l'espace autour des rangées

Vous pouvez ajouter de l'espace autour des rangées en utilisant des marges. Par exemple, les marges du tableau suivant sont de 0,25 pouce autour de la rangée.
1.
Sélectionnez la rangée. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Définissez les marges (supérieure, inférieure, de droite et de gauche) dans la palette Disposition.


Pour appliquer des bordures et un ombrage à un tableau

Il est possible de rendre un tableau plus attractif en lui ajoutant des bordures et un effet d'ombre. Les bordures peuvent s'appliquer à un tableau ou à une rangée, colonne ou cellule individuelle. Les ombres sont quant à elles utilisées en arrière-plan du tableau.
Le remplissage des rangées peut s'effectuer une rangée sur deux ou par bandes. Vous pouvez sélectionner le nombre de rangées ou de colonnes à inclure dans un motif à bandes, ainsi que la couleur à appliquer.
Pour appliquer une bordure et un ombrage à un tableau
1.
Sélectionnez le tableau. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Effectuez l'une des opérations suivantes :
      •
      Pour placer des bordures uniquement sur certains côtés, dans la palette Bordure, sélectionnez l'option Modifier individuellement de la liste Contours. Vous pouvez à présent définir la bordure de chaque côté.
      •
      Pour placer la même bordure sur tous les côtés, sélectionnez l'option Modifier ensemble de la liste Contours.
3.
Sélectionnez une option dans la liste de types de lignes, puis choisissez une couleur dans le sélecteur de couleur.
4.
Pour appliquer un remplissage, sélectionnez un style dans la liste correspondante, puis choisissez une couleur dans le sélecteur de couleur.
Pour supprimer la bordure ou l'ombrage d'un tableau
1.
Sélectionnez le tableau. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Dans la liste Contours de la palette Bordure, sélectionnez Modifier ensemble.
3.
Sélectionnez Aucune dans la liste des types de lignes.
Pour appliquer un ombrage une rangée sur deux ou par bandes
1.
Sélectionnez le tableau. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Dans la palette Objet, cliquez sur l'onglet Ombrage de la rangée, puis sélectionnez l'option Appliquer l'ombrage une rangée sur deux.
3.
Sélectionnez la couleur d'ombrage de la première rangée ou de la première série de rangées.
4.
Sélectionnez la couleur d'ombrage de la rangée suivante ou de la série de rangées suivante.
si vous utilisez la palette Bordure pour définir un remplissage de la cellule, celui-ci prévaut sur l'ombrage défini pour le tableau.
Pour supprimer l'ombrage une rangée sur deux ou par bandes
      *
      Dans la palette Objet, cliquez sur l'onglet Ombrage de la rangée, puis désactivez l'option Appliquer l'ombrage une rangée sur deux.


Pour répartir uniformément les rangées et les colonnes

Vous pouvez faire en sorte que les rangées et les colonnes fassent la même taille. Toutes les rangées s'adaptent à la hauteur de la rangée la plus haute sélectionnée. Toutes les colonnes s'ajustent selon des distances égales proportionnellement à la largeur du tableau. Le tableau ne s'étend pas.
1.
Sélectionnez les rangées ou les colonnes à mettre à la même taille. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Sélectionnez Tableau > Répartir proportionnellement les rangées ou Répartir proportionnellement les colonnes.
si vous avez utilisé la commande Fusionner les cellules, les colonnes d'origine sont toujours présentes, mais elles sont masquées (vous pouvez toujours diviser les cellules, en cas de besoin). Pour faire en sorte que les colonnes fassent la même taille après avoir fusionné les cellules, commencez par supprimer les colonnes cachées par l'intermédiaire de la commande Tableau > Supprimer > Colonne.


Pour formater des coins d'un tableau ou de cellules

Vous pouvez faire en sorte que les coins d'un tableau ou de cellules soient arrondis ou rentrés.
Pour formater les coins d'un tableau ou de cellules
1.
Sélectionnez le tableau ou les cellules. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Dans la palette Bordure, sélectionnez une des options relatives aux coins suivantes.
3.
Entrez un nombre dans la zone Rayon. L'exemple précédent utilise un rayon de 1 pouce.
Pour supprimer la bordure tout autour du tableau
      *
      Sélectionnez le tableau, puis dans la palette Bordure, sélectionnez Aucune dans la liste des types de lignes.


Pour créer un style de tableau pour la bibliothèque personnalisée

Vous pouvez créer votre propre style de tableau pour harmoniser l'aspect des bordures, de l'ombrage, de l'alignement et des polices. Inspirez-vous, par exemple, du tableau ci-dessous et enregistrez-le dans la bibliothèque personnalisée afin de pouvoir le réutiliser dans un autre formulaire.
1.
Créez un tableau.
2.
Définissez les bordures; l'ombrage, le type et l'alignement des cellules, les polices.
3.
Assurez-vous que la catégorie Personnalisés de la palette Bibliothèque est affichée.
4.
Sélectionnez le tableau et faites-le glisser vers la catégorie Personnalisés de la palette Bibliothèque.
5.
Dans la boîte de dialogue Ajouter un objet de bibliothèque, saisissez le nom du style de tableau et cliquez sur OK.
Vous pouvez saisir une description et sélectionner l'onglet de la bibliothèque sous lequel l'objet doit apparaître.


Pour afficher des légendes dans les rangées

Par défaut, la légende d'un champ n'est pas affichée lorsque le champ se trouve dans une cellule. Les objets suivants, par exemple, possèdent des légendes, mais elles sont masquées lorsque le champ se trouve dans une cellule.
      •
      Case à cocher
      •
      Date/Heure
      •
      Champ décimal
      •
      Champ de signature du document
      •
      Liste déroulante
      •
      Champ d'image
      •
      Zone de liste
      •
      Champ numérique
      •
      Champ du mot de passe
      •
      Champ de texte
Vous pouvez afficher la légende dans certains tableaux. Dans le formulaire suivant, par exemple, un tableau permet de présenter les informations. Chaque rangée sous la rangée d'en-tête est constituée d'une cellule.
1.
Sélectionnez la cellule. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Dans la palette Disposition, sélectionnez la position de la légende dans la liste Ancrage.


Pour créer un calendrier à l'aide d'un tableau

Il est possible de créer un calendrier à partir d'un tableau.
1.
Choisissez Affichage > Gabarit.
2.
Dans la palette Objet, cliquez sur l'onglet Gabarit et sélectionnez Paysage.
3.
Cliquez sur l'onglet Vue de conception.
4.
Dans la palette Bibliothèque, choisissez Tableau > Insérer un tableau.
5.
Dans la boîte de dialogue Insérer un tableau, tapez 7 pour les colonnes et 6 pour les rangées.
6.
Sélectionnez l'option Inclure la rangée d'en-tête dans le tableau et cliquez sur OK.
7.
Déplacez le tableau en haut de la page.
8.
Redimensionnez les colonnes afin que le tableau s'adapte à la largeur de la page.
9.
Choisissez Tableau > Répartir proportionnellement les colonnes.
10.
Sélectionnez la dernière rangée du tableau. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
11.
Dans la palette Disposition, tapez 1.1in dans la zone Hauteur.
12.
Sélectionnez le tableau. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
13.
Choisissez Tableau > Répartir proportionnellement les rangées.
14.
Sélectionnez la première rangée du tableau. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
15.
Choisissez Tableau > Fusionner les cellules.
16.
Saisissez le mois et définissez les propriétés de la police.
17.
Dans la seconde rangée, tapez les jours de la semaine et définissez les propriétés de la police.
18.
Dans les cellules restantes, tapez les numéros des jours de la semaine et définissez les propriétés de la police.


Alignement, redimensionnement et réorganisation des tableaux

Pour aligner un tableau avec d'autres objets
Pour aligner le contenu d'une cellule
Pour affecter à un autre objet la même taille qu'un tableau
Pour redimensionner un tableau entier
Pour redimensionner des rangées et des colonnes
Pour centrer un tableau
Pour organiser un tableau en fonction d'autres objets


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Alignement, redimensionnement et réorganisation des tableaux > Pour aligner un tableau avec d'autres objets

Pour aligner un tableau avec d'autres objets

1.
Sélectionnez le tableau. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Tout en appuyant sur la touche Ctrl, cliquez sur l'autre objet avec lequel aligner le tableau.
3.
Sélectionnez l'une des options suivantes.

Tâche

Sélection
Aligner les bords gauches des objets
Disposition > Aligner > Gauche
Aligner les bords droits des objets
Disposition > Aligner > Droite
Aligner les bords supérieurs des objets
Disposition > Aligner > Haut
Aligner les bords inférieurs des objets
Disposition > Aligner > Bas
Aligner les centres des objets sur la verticale
Disposition > Aligner > Centrer verticalement.
Aligner les centres des objets sur l'horizontale
Disposition > Aligner > Centrer horizontalement


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Alignement, redimensionnement et réorganisation des tableaux > Pour aligner le contenu d'une cellule

Pour aligner le contenu d'une cellule

Vous pouvez modifier l'alignement horizontal et vertical du contenu d'une cellule.
1.
Sélectionnez la cellule. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Dans la palette Paragraphe, sélectionnez une des options d'alignement suivantes.

Tâche

Sélection
Aligner à gauche le contenu d'une cellule
Aligner à gauche
Centrer le contenu d'une cellule
Centrer
Aligner à droite le contenu d'une cellule
Aligner à droite
Justifier le contenu d'une cellule
les lignes sont alignées à gauche et à droite à l'exception de la dernière ligne d'une cellule qui en compte plusieurs (les paragraphes à une seule ligne ne peuvent pas être justifiés).
Justifier
Aligner en haut d'une cellule
Aligner en haut
Aligner au milieu d'une cellule
Aligner au milieu
Aligner en bas d'une cellule
Aligner en bas


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Alignement, redimensionnement et réorganisation des tableaux > Pour affecter à un autre objet la même taille qu'un tableau

Pour affecter à un autre objet la même taille qu'un tableau

Vous pouvez donner à un objet la même taille qu'un tableau du formulaire. Vous pouvez, par exemple affecter à un rectangle la même taille qu'un tableau, afin de pouvoir insérer un élément de séparation ou une bordure autour d'une section du formulaire. Il est possible d'affecter à d'autres objets la même taille qu'un tableau, mais pas l'inverse.
1.
Sélectionnez l'objet à mettre à la même taille que le tableau.
2.
Cliquez tout en appuyant sur la touche Ctrl ou Maj pour sélectionner le tableau. Celui-ci doit être sélectionné en dernier.
3.
Sélectionnez Disposition > Donner une même taille, puis Largeur, Hauteur ou Les deux.
L'objet sélectionné en dernier sert à définir la taille des deux objets.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Alignement, redimensionnement et réorganisation des tableaux > Pour redimensionner un tableau entier

Pour redimensionner un tableau entier

Vous pouvez redimensionner un tableau entier. Seuls le bord inférieur et le bord de droite permettent de redimensionner le tableau. Pour redimensionner le tableau ou la dernière colonne hors de la zone de contenu, modifiez la largeur dans la palette Disposition.
1.
Sélectionnez le tableau. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Approchez le pointeur du bord du tableau, jusqu'à ce qu'il se transforme en flèche bidirectionnelle.
3.
Faites glisser les bords du tableau jusqu'à ce qu'il atteigne la taille souhaitée.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Alignement, redimensionnement et réorganisation des tableaux > Pour redimensionner des rangées et des colonnes

Pour redimensionner des rangées et des colonnes

Vous pouvez changer la taille des rangées et des colonnes. Seuls le bord inférieur, le bord de droite et le bord de gauche permettent de redimensionner une rangée ou une colonne. Pour redimensionner la dernière colonne hors de la zone de contenu, modifiez la largeur dans la palette Disposition.
1.
Approchez le pointeur du bord de la rangée ou de la colonne, jusqu'à ce qu'il se transforme en flèche bidirectionnelle.
2.
Faites glisser le bord jusqu'à ce que la rangée ou la colonne atteigne la taille souhaitée.


Pour centrer un tableau

1.
Sélectionnez le tableau. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Choisissez Disposition > Centrer sur la page, puis Horizontalement ou Verticalement.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Alignement, redimensionnement et réorganisation des tableaux > Pour organiser un tableau en fonction d'autres objets

Pour organiser un tableau en fonction d'autres objets

Vous pouvez définir comment des objets se chevauchent en les plaçant en avant ou à l'arrière d'autres objets. Par exemple, vous pouvez placer une image en filigrane.
1.
Sélectionnez le tableau. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Sélectionnez une des options suivantes :
      •
      Pour rapprocher le tableau, choisissez Disposition > En avant.
      •
      Pour placer le tableau au premier plan, choisissez Disposition > Premier plan.
      •
      Pour éloigner le tableau, choisissez Disposition > En arrière.
      •
      Pour placer le tableau en arrière-plan, choisissez Disposition > Arrière-plan.


Manipulation des données dans les tableaux

Pour créer un tableau à partir d'une source de données
Pour configurer les rangées d'un tableau en vue de les adapter aux données
Pour créer un tableau regroupant des données
Pour créer un tableau facultatif
Pour effectuer des calculs dans un tableau


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Manipulation des données dans les tableaux > Pour créer un tableau à partir d'une source de données

Pour créer un tableau à partir d'une source de données

Il est possible d'afficher dans un tableau des informations provenant d'une source de données. Lorsque vous vous connectez à une source de données, la palette Vues des données identifie tous les éléments qui peuvent être des tableaux. LiveCycle Designer affiche également les éléments susceptibles de devenir des rangées du tableau s'il détecte un groupe de données qui se répète.
Après vous être connecté à la source de données, vous pouvez faire glisser des éléments de la palette Vue des données vers la conception de formulaire pour créer rapidement des champs associés à la source de données. Si vous faites glisser un élément de tableau de la palette Vue des données vers la conception de formulaire, LiveCycle Designer crée un tableau et, lorsque vous sélectionnez un fichier de données, vous obtenez un tableau comme celui-ci lorsque le formulaire est généré. Le groupe de données qui se répètent dans le fichier possède quatre enregistrements.
1.
Vérifiez que vous êtes connecté à une source de données. Voir A propos de la connexion à une source de données.
Par exemple, si vous (ou votre administrateur) avez installé les échantillons fournis avec LiveCycle Designer, localisez et ouvrez le schéma suivant : Purchase Order.xsd dans la boîte de dialogue Connexion aux données.
2.
Dans la palette Vue des données, repérez un noeud susceptible d'être un tableau. Par exemple, trouvez le noeud item.
3.
Sélectionnez le noeud et faites-le glisser sur la conception de formulaire. Après cette opération, par exemple, voici ce que vous obtenez.
La palette Vue des données montre que le noeud est associé à un objet.
4.
Pour sélectionnez un fichier de données, choisissez Fichier > Propriétés du formulaire et cliquez sur l'onglet Valeurs par défaut. Accédez à l'emplacement du fichier de données à utiliser.
Par exemple, si vous (ou votre administrateur) avez installé les modèles fournis avec LiveCycle Designer, localisez et ouvrez le fichier de données Purchase Order.xml.
5.
Affichez le formulaire dans le panneau Aperçu PDF.
LiveCycle Designer crée automatiquement un tableau qui s'adapte à la quantité d'informations présentes dans la source de données.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Manipulation des données dans les tableaux > Pour configurer les rangées d'un tableau en vue de les adapter aux données

Pour configurer les rangées d'un tableau en vue de les adapter aux données

Si vous avez déjà créé un tableau possédant un nombre fixe de colonnes et de rangées, vous pouvez le convertir en tableau dynamique (qui s'adapte en fonction des informations provenant d'une source de données). Pour ce faire, il faut sélectionner l'option Distribué pour le sous-formulaire dans lequel se trouve le tableau et faire en sorte que les rangées de contenu se répètent.
1.
Créez un tableau. Voir Pour créer un tableau simple.
2.
Sélectionnez les rangées qui se trouvent sous la première.
Dans un tableau comportant un nombre fixe de colonnes, mais dont le nombre de rangées change selon le volume d'informations de la source de données, seule une rangée est nécessaire. Par conséquent, vous devez supprimer toutes les rangées du tableau, à l'exception de la première. Vous pouvez conserver la rangée de pied de page.
3.
Choisissez Tableau > Supprimer > Rangée.
4.
Enregistrez le formulaire au format Formulaire XML (dynamique) Acrobat 7.0 (*.pdf).
5.
Dans la palette Hiérarchie, sélectionnez le sous-formulaire contenant le tableau.
6.
Dans la palette Objet, cliquez sur l'onglet Sous-formulaire et sélectionnez Distribué dans la liste Contenu.
7.
Dans la palette Hiérarchie, sélectionnez la rangée de contenu (Rangée1, par exemple).
8.
Dans la palette Objet, cliquez sur l'onglet Liaison et sélectionnez l'option Rangée pour chaque élément.
9.
Connectez-vous à une source de données. Voir A propos de la connexion à une source de données.
Vous devez vous connecter à une source de données, telle qu'un schéma XML, pour que des données s'affichent dans le tableau.
10.
Sélectionnez un fichier de données. Voir Pour tester un formulaire avec des exemples de données.
Vous devez sélectionner un fichier pour visualiser et tester le formulaire avec les données.
11.
Affichez le formulaire dans le panneau Aperçu PDF.


Pour créer un tableau regroupant des données

Vous pouvez afficher les données de manière groupée au sein d'un tableau. L'association permet d'organiser et de disposer les données en rapports, comme le pays (Country) ou la région (Région). Vous pouvez imbriquer des groupes afin d'identifier rapidement les rapports et de visualiser les tendances. L'association permet aussi de présenter des résumés, tels que des sommes totales et des décomptes.
Si, par exemple, vous fournissez des produits, tels que des moniteurs d'ordinateur, des lampes de bureau et des téléphones, il peut s'avérer pratique de voir le pays et la région qui vendent le mieux ces produits. Vous pouvez créer ce tableau, qui comprend un tableau imbriqué au sein d'un autre tableau imbriqué, lui-même imbriqué dans le tableau principal :
      •
      Le pays (Country) correspond à l'en-tête du tableau principal.
      •
      La région (Region) correspond à l'en-tête du premier tableau imbriqué.
      •
      Le produit et les bénéfices correspondent à l'en-tête du tableau imbriqué au sein du premier tableau imbriqué.
Ainsi, l'exemple de fichier XML auquel vous vous connectez peut suivre la syntaxe ci-dessous :
<form1>
 <Sales>
  <SalesData>
     <country>United States</country>
     <CountryData>
          <RegionRow>
          <region>Western</region>
     <RegionData>
     <Item>
          <product>Monitor</product>
          <profit>10</profit>
     </Item>
     <Item>
          <product>Desk Lamp</product>
          <profit>20</profit>
     </Item>
     </RegionData>
          </RegionRow>
          <RegionRow>
          <region>Central</region>
     <RegionData>
     <Item>
          <product>Monitor</product>
          <profit>30</profit>
     </Item>
     <Item>
          <product>Desk Lamp</product>
          <profit>25</profit>
     </Item>
     <Item>
          <product>Telephone</product>
          <profit>28</profit>
     </Item>
     </RegionData>
          </RegionRow>
          <RegionRow>
     <region>Atlantic</region>
     <RegionData>
     <Item>
          <product>Monitor</product>
          <profit>31</profit>
     </Item>
     <Item>
          <product>Desk Lamp</product>
          <profit>17</profit>
     </Item>
     <Item>
          <product>Telephone</product>
          <profit>22</profit>
</Item>
          </RegionData>
          </RegionRow>
     </CountryData>
  </SalesData>
 </Sales>
</form1>
Avant d'effectuer cette tâche, assurez-vous que les paramètres suivants sont appliqués :
      •
      Vérifiez que vous êtes connecté à une source de données. Voir A propos de la connexion à une source de données.
      •
      Pour tester le formulaire à l'aide de données d'essai, assurez-vous de pointer vers un fichier de données. Voir Pour tester un formulaire avec des exemples de données.
Pour créer le tableau principal
1.
Choisissez Fichier > Enregistrer sous, saisissez le nom du fichier et choisissez Formulaire XML (dynamique) Acrobat 7.0 (*.pdf). Cliquez sur OK.
2.
Choisissez Tableau > Insérer un tableau.
3.
Dans la boîte de dialogue Insérer un tableau, indiquez le nombre de colonnes et de rangées. Par exemple, tapez 2 pour le nombre de colonnes et 1 pour le nombre de rangées.
Vous pouvez demander un maximum de 20 colonnes et 50 rangées. Une fois le tableau créé, vous pouvez continuer à ajouter des rangées et des colonnes par l'intermédiaire des commandes Insérer du menu Tableau.
4.
(Facultatif) Pour inclure une rangée d'en-tête, sélectionnez l'option Inclure la rangée d'en-tête dans le tableau.
5.
(Facultatif) Pour inclure une rangée de pied de page, sélectionnez l'option Inclure la rangée de pied de page dans le tableau.
6.
Cliquez sur OK.
7.
Renommez la rangée d'en-tête. Par exemple, renommez le premier en-tête Country et supprimez le texte de l'en-tête de la deuxième colonne.
8.
Redimensionnez le tableau.
Pour créer le premier tableau imbriqué
1.
Faites glisser l'objet de tableau de la palette Bibliothèque vers une cellule du tableau.
2.
Renommez le texte de la rangée d'en-tête. Par exemple, renommez le premier en-tête Region et supprimez le texte de l'en-tête de la deuxième colonne.
Pour créer le dernier tableau imbriqué au sein du premier tableau imbriqué
1.
Faites glisser l'objet de tableau de la palette Bibliothèque vers une cellule du tableau afin de créer un autre tableau imbriqué. Par exemple, faites-le glisser vers la deuxième cellule de la rangée de contenu du premier tableau imbriqué.
2.
Dans la boîte de dialogue Insérer un tableau, indiquez le nombre de colonnes et de rangées.
3.
(Facultatif) Pour inclure une rangée d'en-tête, sélectionnez l'option Inclure la rangée d'en-tête dans le tableau.
4.
(Facultatif) Pour inclure une rangée de pied de page, sélectionnez l'option Inclure la rangée de pied de page dans le tableau.
5.
Cliquez sur OK.
6.
Renommez la rangée d'en-tête. Par exemple, modifiez le premier en-tête en Product et le deuxième en Profit.
Le formulaire devrait être similaire à l'illustration ci-dessous.
Pour afficher les données dans les cellules
1.
Dans la palette Vue des données, faites glisser un noeud vers la cellule placée sous le premier en-tête. Par exemple, faites glisser le noeud du pays vers la cellule située sous l'en-tête Country.
2.
Recommencez cette étape pour les cellules restantes.
Par exemple, faites glisser le noeud de la région vers la cellule située sous l'en-tête Region. Faites glisser le noeud du produit vers la cellule située sous l'en-tête Product. Faites glisser le noeud du bénéfice vers la cellule située sous l'en-tête Profit.
3.
Dans la palette Hiérarchie, sélectionnez chaque rangée intitulée Rangée1 et activez l'option Rangée pour chaque élément dans l'onglet Liaison de la palette Objet.
4.
Harmonisez les noms du tableau, des rangées et des champs avec ceux de l'exemple de fichier XML.
Par exemple, sélectionnez Tableau1 dans la palette Hiérarchie. Puis, dans la palette Objet, cliquez sur l'onglet Liaison et saisissez $record.Sales dans la zone Par défaut (Ouvrir, Enregistrer, Envoyer).
Par exemple, définissez la liaison par défaut comme indiqué dans ce tableau.

Sélectionnez les éléments suivants dans la palette Hiérarchie

Définissez la liaison par défaut à la chaîne correspondante
Rangée1
SalesData
country
country
Tableau2
CountryData
Rangée1
RegionRow[*]
region
region
Tableau3
RegionData
Rangée1
Elément[*]
product
product
profit
profit
5.
Sélectionnez le sous-formulaire contenant le tableau principal et, dans le panneau Sous-formulaire de la palette Objet, sélectionnez l'option Distribué dans la liste Contenu.
6.
Occupez-vous du format du tableau. Par exemple, ajoutez des bordures et un ombrage.
7.
Affichez le formulaire dans le panneau Aperçu PDF.


Pour créer un tableau facultatif

Il peut être intéressant de créer un tableau facultatif lorsque vous ne souhaitez pas afficher les informations du tableau ou que le tableau ne contient pas de données à afficher.
1.
Connectez-vous à une source de données. Voir A propos de la connexion à une source de données.
Vous devez vous connecter à une source de données, telle qu'un schéma XML, pour que des données s'affichent dans le tableau.
2.
Sélectionnez un fichier de données. Voir Pour tester un formulaire avec des exemples de données.
Vous devez sélectionner un fichier pour visualiser et tester le formulaire avec les données.
3.
Vérifiez que le tableau se trouve dans un sous-formulaire pour lequel l'option Distribué a été sélectionnée.
4.
Sélectionnez le tableau dont le nombre de rangées varie en fonction du volume d'informations provenant de la source de données. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
Si vous sélectionnez un tableau avec un nombre fixe de rangées et de colonnes et le rendez facultatif, la rangée d'en-tête se répète pour chaque élément de données. Pour transformer ce tableau en un tableau dont le nombre de rangées s'adapte au volume des données, désactivez l'option Rangée pour chaque élément pour la rangée d'en-tête, mais activez-la pour la rangée de contenu.
5.
Dans la palette Objet, cliquez sur l'onglet Liaison, puis sélectionnez l'option Tableau pour chaque élément.
6.
Désactivez la case Min. de répétitions.
7.
Affichez le formulaire dans le panneau Aperçu PDF.
Le tableau ne doit pas apparaître si vous n'êtes pas connecté à une source de données. En revanche, si vous avez lié les cellules d'un tableau à une source de données, et si des données existent, le tableau apparaît.


Pour effectuer des calculs dans un tableau

Utilisez la fonction sum de FormCalc pour totaliser les valeurs d'une colonne. Vous devez ajouter le calcul à la rangée de pied de page du tableau.
1.
Sélectionnez la cellule de la rangée de pied de page où doit apparaître le calcul. Par exemple, sélectionnez la cellule correspondant au total du premier trimestre.
2.
Dans l'éditeur de script, sélectionnez calculate dans la liste Afficher.
3.
Dans la liste Langage, sélectionnez FormCalc.
4.
Dans la liste Exécuter sur le, sélectionnez Client.
5.
Dans le champ Source du script, insérez le calcul FormCalc.
Pour calculer, par exemple, la somme des données du premier trimestre, tapez l'expression suivante.
6.
Cliquez sur Insérer les changements dans la source du script pour ajouter le script à votre formulaire.
7.
Répétez l'opération pour les second et troisième trimestre.
8.
Pour calculer les cumuls par pays, tapez l'expression suivante :

sum(Q1 + Q2 + Q3)
9.
Répétez l'opération pour les cumuls des rangées restantes.
10.
Pour obtenir le total cumulé, tapez l'expression suivante :

sum(TotalQ1 + TotalQ2 + TotalQ3)
pour afficher les données sous la forme 10K, tapez z9'K' dans la zone Format d'affichage de l'onglet Cellule de la palette Objet. Sous l'onglet Valeur, sélectionnez Calculé - Lecture seule dans la liste Type.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Création de tableaux extensibles

Création de tableaux extensibles

Pour créer un tableau extensible à l'aide de l'objet de bouton


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Création de tableaux extensibles > Pour créer un tableau extensible à l'aide de l'objet de bouton

Pour créer un tableau extensible à l'aide de l'objet de bouton

Vous pouvez créer un tableau permettant d'ajouter une rangée lorsqu'un utilisateur clique sur un bouton d'ajout de rangée. Vous pouvez également inclure un bouton de suppression de rangée. Vous devez créer le tableau, ajouter les boutons, puis définir les propriétés permettant l'agrandissement du tableau.
Pour créer un tableau extensible à l'aide de l'objet de bouton
1.
Dans la palette Bibliothèque, choisissez Tableau > Insérer un tableau.
2.
Dans la boîte de dialogue Insérer un tableau, sélectionnez Créer un tableau à l'aide de l'assistant, puis cliquez sur OK.
3.
Dans la section Disposition du contenu de l'assistant de création de tableaux, sélectionnez l'option Rangées de contenu varient selon données.
Cela a pour effet de créer un tableau dans lequel des rangées sont ajoutées ou supprimées en fonction des données transférées dans ce tableau.
4.
Indiquez le nombre de colonnes et cliquez sur Suivant.
5.
(Facultatif) Sélectionnez l'option Avec rangée d'en-tête, puis cliquez sur Suivant.
6.
(Facultatif) Sélectionnez l'option Avec rangée de pied de page, puis cliquez sur Suivant.
7.
(Facultatif) Sélectionnez l'option Avec rangées de contenu et sans section, puis cliquez sur Suivant.
8.
(Facultatif) Sélectionnez l'option Alternance des couleurs de rangées, puis cliquez sur Terminer.
9.
Enregistrez le formulaire au format Formulaire XML (dynamique) Acrobat 7.0 (*.pdf)
Maintenant, vous devez insérer les boutons destinés à ajouter et supprimer des rangées.
Pour ajouter les boutons
1.
Sélectionnez la première cellule de la rangée de contenu. Dans la palette Objet, cliquez sur l'onglet Cellule et sélectionnez Sous-formulaire dans la liste Type.
Cette cellule doit être un sous-formulaire pour contenir les deux boutons.
vous pouvez également faire glisser l'objet de sous-formulaire de la palette Bibliothèque vers une cellule du tableau.
2.
Dans la palette Bibliothèque, cliquez sur la catégorie Standard, puis faites glisser l'objet Bouton dans une cellule de la rangée de contenu. Placez-le, par exemple, dans la première cellule de la rangée de contenu.
3.
Dans la palette Objet, cliquez sur l'onglet Champ et tapez Add Row dans la zone Légende.
4.
Répétez les étapes 2 et 3 pour créer un bouton Supprimer la rangée.
5.
Sélectionnez le bouton Ajouter une rangée puis, dans l'éditeur de script, sélectionnez click dans la liste Afficher.
6.
Dans l'éditeur de script, sélectionnez JavaScript dans la liste Langage.
7.
Entrez le script suivant :

Table.Row1.instanceManager.addInstance(1);
Pour adapter le script à votre propre formulaire, vous devez comprendre comment il intervient dans la hiérarchie. Par exemple, dans la hiérarchie du formulaire actif, les deux boutons se trouvent à l'intérieur du même formulaire. Vous n'avez donc pas besoin de spécifier les objets au-delà du niveau Tableau.
8.
Cliquez sur Insérer les changements dans la source du script pour ajouter le script à votre formulaire.
9.
Sélectionnez le bouton Supprimer la rangée puis, dans l'éditeur de script, sélectionnez click dans la liste Afficher.
10.
Dans l'éditeur de script, sélectionnez JavaScript dans la liste Langage.
11.
Entrez le script suivant :

Table.Row1.instanceManager.removeInstance(1);
pour réutiliser ces boutons dans un autre formulaire, vous pouvez les ajouter à la catégorie Personnalisés (ou à votre propre catégorie) dans la palette Bibliothèque. Si vous utilisez le bouton dans un autre formulaire, il se peut qu'il faille modifier le script.
12.
Cliquez sur Insérer les changements dans la source du script pour ajouter le script à votre formulaire.
13.
Affichez le formulaire dans le panneau Aperçu PDF.
L'exemple ci-dessous montre ce que vous obtenez si vous avez modifié le tableau des articles du modèle de bon de commande.


Pagination et utilisation de rangées d'en-tête et de pied de page dans les tableaux

Pour configurer un tableau s'étendant sur plusieurs pages
Pour répéter une rangée d'en-tête ou de pied de page sur plusieurs pages
Pour transformer une rangée en rangée d'en-tête, de contenu ou de pied de page
Pour contrôler les sauts de section, de rangée de pied de page, de rangée de contenu, de rangée d'en-tête et de tableau à l'aide d'instructions conditionnelles


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Pagination et utilisation de rangées d'en-tête et de pied de page dans les tableaux > Pour configurer un tableau s'étendant sur plusieurs pages

Pour configurer un tableau s'étendant sur plusieurs pages

Pour autoriser un tableau à s'étendre automatiquement sur la page suivante, vous devez vérifier les conditions suivantes :
      •
      Le tableau doit se trouver dans un sous-formulaire pour lequel l'option Distribué a été sélectionnée sous l'onglet Sous-formulaire de la palette Objet.
      •
      L'option Autoriser des sauts de page est sélectionnée sous l'onglet Tableau.
      •
      Le tableau ne fait pas partie d'un groupe.
Vous pouvez alors procéder à des ajustements sur le tableau pour vérifier que les informations apparaissent où vous le souhaitez lorsque le tableau s'étend sur plusieurs pages. Vous pouvez inclure une balise de continuité de tableau en haut de la page suivante si le tableau s'étend sur plusieurs pages.
Si vous voulez que la rangée d'en-tête soit reprise sur la page suivante, voir Pour répéter une rangée d'en-tête ou de pied de page sur plusieurs pages.
Pour définir un gabarit contenant la balise de continuité de tableau :
1.
Créez un tableau qui évolue en fonction du volume d'informations provenant de la source de données. Voir Pour configurer les rangées d'un tableau en vue de les adapter aux données.
2.
Sélectionnez la rangée d'en-tête.
3.
Dans la palette Objet, cliquez sur l'onglet Pagination, puis sélectionnez l'option Rangée d'en-tête sur pages suivantes.
4.
Si le panneau Pages types n'est pas affiché, choisissez Affichage > Pages types.
5.
Cliquez sur l'onglet Page type, puis choisissez Insertion > Nouvelle page type.
6.
Redimensionnez la zone de contenu afin qu'elle soit plus petite sur le nouveau gabarit.
7.
Dans la palette Bibliothèque, cliquez sur la catégorie Standard, puis faites glisser l'objet de texte [image] au-dessus de la zone de contenu.
8.
Cliquez deux fois sur le texte par défaut, puis saisissez Table continued ...
9.
Sélectionnez le texte, puis, dans la palette Police, mettez-le en gras et en italique.
10.
Dans la palette Hiérarchie, renommez (Zone de contenu sans titre) à la page 2 en ZoneContenuPage2.
Pour définir la pagination du tableau
1.
Sélectionnez le tableau dans le panneau Vue de conception de l'éditeur de disposition. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Dans la palette Objet, cliquez sur l'onglet Tableau et vérifiez que l'option Autoriser des sauts de page est sélectionnée.
3.
Dans la palette Objet, cliquez sur l'onglet Pagination ; cliquez alors sur la flèche située à droite de la liste Débordement, puis sélectionnez Atteindre la zone de contenu > ZoneContenuPage2.
Pour se connecter à une source de données
1.
Vérifiez que vous êtes connecté à une source de données. Voir A propos de la connexion à une source de données.
Par exemple, si vous (ou votre administrateur) avez installé les échantillons fournis avec LiveCycle Designer, localisez et ouvrez le schéma suivant : Purchase Order.xsd dans la boîte de dialogue Connexion aux données.
2.
Dans la palette Vue des données, cherchez le noeud partNum.
3.
Faites glisser le noeud dans la première cellule sous le titre Nº d'article.
4.
Répétez les étapes 2 et 3 pour les noeuds description, quantity et unitPrice.
Pour sélectionner un fichier de données
1.
Choisissez Fichier > Propriétés du formulaire, puis cliquez sur l’onglet Valeurs par défaut.
vous devez sélectionner un fichier contenant suffisamment de données pour remplir un tableau s'étendant sur plusieurs pages.
2.
Affichez le formulaire dans le panneau Aperçu PDF.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Pagination et utilisation de rangées d'en-tête et de pied de page dans les tableaux > Pour répéter une rangée d'en-tête ou de pied de page sur plusieurs pages

Pour répéter une rangée d'en-tête ou de pied de page sur plusieurs pages

1.
Cliquez et faites glisser le curseur pour sélectionner l'en-tête ou le pied de page du tableau.
2.
Dans la palette Objet, cliquez sur l'onglet Pagination et effectuez l'une des opérations suivantes :
      •
      Sélectionnez Rangée d'en-tête sur pages suivantes.
      •
      Sélectionnez Rangée de pied de page sur pages suiv.
le tableau doit être inséré dans un sous-formulaire pour lequel l'option Distribué a été sélectionnée.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Pagination et utilisation de rangées d'en-tête et de pied de page dans les tableaux > Pour transformer une rangée en rangée d'en-tête, de contenu ou de pied de page

Pour transformer une rangée en rangée d'en-tête, de contenu ou de pied de page

Dès qu'un tableau est inséré, vous pouvez transformer une rangée en une rangée d'un autre type. Par exemple, vous pouvez changer une rangée de contenu en rangée d'en-tête pour créer un tableau à l'intérieur d'un autre. Vous pouvez également transformer une rangée de contenu en rangée de pied de page pour afficher des récapitulatifs dans la dernière rangée de chaque page du formulaire.
1.
Sélectionnez une rangée. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Dans la palette Objet, cliquez sur l'onglet Rangée, puis sélectionnez un élément de la liste Type.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Pagination et utilisation de rangées d'en-tête et de pied de page dans les tableaux > Pour contrôler les sauts de section, de rangée de pied de page, de rangée de contenu, de rangée d'en-tête et de tableau à l'aide d'instructions conditionnelles

Pour contrôler les sauts de section, de rangée de pied de page, de rangée de contenu, de rangée d'en-tête et de tableau à l'aide d'instructions conditionnelles

LiveCycle Designer permet de créer des sauts conditionnels personnalisés pour les tableaux, les rangées d'en-tête, les rangées de contenu, les rangées de pied de page et les sections. Au lieu de laisser les ruptures s'effectuer automatiquement dans ces objets en fonction du flux de données, vous pouvez spécifier des sauts conditionnels afin de déterminer la manière dont ils sont coupés sur un formulaire à l'aide d'instructions dites conditionnelles.
Ces instructions permettent de comparer les données d'un champ d'un tableau (ou d'une rangée d'en-tête, d'une rangée de contenu, d'une rangée de pied de page ou d'une section) par rapport à des occurrences précédentes de ce champ. Le tableau (ou la rangée d'en-tête, la rangée de contenu, la rangée de pied de page ou la section) peut alors être coupé en réponse à un changement des données contenues dans le champ.
Sur une facture téléphonique, par exemple, vous pouvez couper un objet de tableau en réponse à un changement du champ contenant la date de chaque entrée de facturation. Ainsi, une rupture peut s'opérer à chaque changement de date, ce qui rend la facture téléphonique plus facile à lire pour le client.
Outre la condition de saut, vous pouvez également spécifier des sous-formulaires de début et de fin et indiquer l'endroit où placer l'occurrence suivante du sous-formulaire qui se répète sur le formulaire.
Avant d'effectuer cette tâche, assurez-vous que le tableau se trouve dans un sous-formulaire défini sur le paramètre Distribué.
1.
Sélectionnez un tableau (ou une rangée d'en-tête, une rangée de contenu, une rangée de pied de page ou une section). Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Cliquez sur l'onglet Pagination de la palette Objet.
3.
Cliquez sur le bouton Modifier, puis sur le bouton Ajouter [image] pour insérer un nouvel élément de la liste de sauts conditionnels.
4.
Sélectionnez un langage de script dans la liste Langage. L'instruction de saut conditionnelle est créée à l'aide du langage de script sélectionné.
5.
Dans la liste Exécuter sur, sélectionnez l'endroit où doit s'exécuter le saut conditionnel.
6.
Cliquez sur Insérer une expression exemple [image] et sélectionnez l'objet de la conception de formulaire à l'intérieur du tableau (ou de la rangée d'en-tête, de la rangée de contenu, de la rangée de pied de page ou de la section) à utiliser comme champ de comparaison pour le saut conditionnel. Vous pouvez également saisir votre propre expression dans le champ. Toutefois, les instructions conditionnelles définies par l'utilisateur doivent retourner la valeur vrai ou faux pour pouvoir correctement évaluer un saut conditionnel.
7.
Sélectionnez Avant ou Après, pour déterminer quand le tableau (ou la rangée d'en-tête, la rangée de contenu, la rangée de pied de page ou la section) doit être coupé. Si vous sélectionnez Avant, un saut est inséré juste avant l'occurrence actuelle du tableau (ou de la rangée d'en-tête, de la rangée de contenu, de la rangée de pied de page, de la section) . Il est inséré juste après si vous sélectionnez Après.
8.
Dans le champ A, sélectionnez l'emplacement des occurrences restantes du tableau (ou de la rangée d'en-tête, de la rangée de contenu, de la rangée de pied de page ou de la section).
9.
Si besoin est, sélectionnez les sous-formulaires de fin et de début à utiliser pour le saut conditionnel, respectivement dans les listes Caractère de fin et Caractère de début.
10.
Répétez les étapes 2 à 9 pour chaque saut conditionnel que vous souhaitez ajouter à l'objet sélectionné, puis cliquez sur OK une fois l'ajout d'entrées à la liste terminé.
Après avoir créé toutes les entrées de saut conditionnel, vérifiez l'ordre dans lequel elles apparaissent dans la boîte de dialogue Modifier les sauts conditionnels. LiveCycle Designer traite les sauts conditionnels énumérés dans cette boîte de dialogue dans l'ordre où ils apparaissent, de haut en bas. Chaque saut conditionnel dont l'instruction conditionnelle se vérifie est exécuté.
Utilisez les boutons fléchés Haut [image] et Bas [image] pour déplacer les entrées de la liste des sauts conditionnels et les placer dans l'ordre de votre choix.
Voir aussi
Boîte de dialogue Modifier les sauts conditionnels
Propriétés des tableaux dans le panneau Pagination
Propriétés des rangées d'en-tête et de pied de page dans le panneau Pagination
Propriétés des rangées de contenu dans le panneau Liaison
Propriétés des sections dans le panneau Pagination


Manipulation des cellules et du contenu des cellules

Pour effacer le contenu d’une cellule
Pour fusionner et scinder des cellules
Pour orienter verticalement du texte dans les cellules
Pour transformer une cellule en un autre type d'objet


Pour effacer le contenu d’une cellule

Il est impossible de supprimer une cellule. En revanche, vous pouvez effacer son contenu. Cette action modifie la cellule qui devient un objet de texte vide.
1.
Sélectionnez la cellule. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Choisissez Edition > Effacer le contenu.


Pour fusionner et scinder des cellules

Vous pouvez réunir au moins deux cellules attenantes de la même rangée en une seule cellule. Vous pouvez, par exemple, fusionner plusieurs cellules horizontalement pour créer un titre de tableau s'étendant sur plusieurs colonnes. Seules les cellules d'une même rangée peuvent être fusionnées.
Voici un exemple de tableau avant et après fusion des informations de la seconde rangée.
Il n'est pas possible de fusionner dans une cellule les données provenant de deux cellules. Vous pouvez fusionner le texte uniquement. Si la rangée d'en-tête est fusionnée, par exemple, le texte est fusionné car il s'agit de deux objets de texte. En revanche, si la rangée de contenu est fusionnée et si les cellules sont associées aux éléments de la source de données, seule la cellule la plus à gauche est conservée.
il vaut mieux fusionner les cellules à la fin du processus de conception d'un tableau, car l'ajout ou la suppression de colonnes ne donne pas les mêmes résultats en présence de cellules fusionnées dans le tableau.
Pour fusionner des cellules
1.
Sélectionnez les cellules à fusionner. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Choisissez Tableau > Fusionner les cellules.
Si les cellules contiennent des objets de texte, LiveCycle Designer fusionne le texte. Si les cellules contiennent d'autres objets, ceux-ci sont supprimés.
pour affecter aux colonnes la même taille en utilisant la commande Répartir proportionnellement les colonnes après avoir fusionné les cellules, commencez par supprimer les colonnes cachées avec la commande > Supprimer > Colonne.
Pour séparer une cellule fusionnée
1.
Sélectionnez une cellule fusionnée. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Choisissez Tableau > Scinder la cellule horizontalement.
Les cellules séparées sont converties en objet de texte vide ou, si les cellules d'origine étaient des sous-formulaires, elles sont converties en sous-formulaires vides. Si la cellule fusionnée était un champ numérique, par exemple, toutes les cellules scindées sont des champs numériques.
Notez que vous pouvez utiliser ces deux boutons sous l'onglet Cellule de la palette Objet.

Icône

Commande
Fusionner les cellules
Scinder la cellule horizontalement


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Manipulation des cellules et du contenu des cellules > Pour orienter verticalement du texte dans les cellules

Pour orienter verticalement du texte dans les cellules

Vous pouvez changer l'orientation du contenu des cellules, afin qu'il soit affiché verticalement et non horizontalement.
Seules les cellules peuvent subir une rotation, et non les colonnes, rangées, sections, ni les tableaux entiers.
1.
Sélectionnez la cellule. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Dans la palette Disposition, sélectionnez un des boutons de rotation.
3.
Cliquez sur l'orientation souhaitée. Dans l'exemple précédent, le texte vertical a subi une rotation de 90°.
4.
Dans la palette Paragraphe, sélectionnez l'option d'alignement qui convient le mieux à la cellule. Dans l'exemple précédent, le texte vertical est aligné en haut à droite.
si vous faites pivoter un champ qui doit être rempli par les utilisateurs, ces derniers doivent saisir les données en suivant l'angle de rotation.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Manipulation des cellules et du contenu des cellules > Pour transformer une cellule en un autre type d'objet

Pour transformer une cellule en un autre type d'objet

Par défaut, toutes les cellules sont des objets de texte. Ces objets contiennent du texte en lecture seule, que l'utilisateur ne peut pas modifier. Vous pouvez vous en servir pour effectuer les opérations suivantes :
      •
      Libeller une zone du formulaire (en-têtes de tableau, par exemple)
      •
      Fournir des instructions sur la façon de remplir le formulaire
      •
      Rendre le formulaire plus attractif
La cellule peut devenir tout autre type d'objet, comme un champ numérique ou un champ de texte. Ainsi, vous pouvez utiliser un tableau pour présenter tout un formulaire.
Une cellule peut également accueillir un bouton qui valide des données, exécute une opération de service Web ou une requête de base de données ou envoie des données par courrier électronique à quelqu'un.
Une cellule peut même être un sous-formulaire. Les sous-formulaires jouent le rôle de conteneur pour d'autres objets, y compris des champs, des objets standard et d'autres sous-formulaires. Ils facilitent également le positionnement des objets les uns par rapport aux autres et fournissent une structure. Si une cellule est un sous-formulaire, elle peut contenir plusieurs objets. Elle peut accueillir, par exemple, deux boutons.
Lorsqu'une cellule devient un objet autre qu'un objet de texte, elle se comporte différemment dans une cellule. Un objet de champ de texte dans une cellule, par exemple, a pour légende Aucun.
Il existe plusieurs façons de changer une cellule en un autre type d'objet (mais les résultats sont différents en fonction de ce qui se trouve dans la cellule et du type d'objet cible) :
      •
      Utilisez la liste Type sous l'onglet Cellule de la palette Objet.
      •
      Faites glisser un objet de la palette Bibliothèque dans une cellule.
En fonction de ce que vous sélectionnez dans la liste Type ou la palette Bibliothèque et de ce qui se trouve dans la cellule, le nouvel objet remplace l'objet existant. Si vous changez une cellule en sous-formulaire, les objets présents dans la cellule sont placés dans le sous-formulaire. Si un champ de texte existe déjà dans la cellule, par exemple, et si vous sélectionnez Sous-formulaire dans la liste Type, le champ de texte est placé dans le sous-formulaire. Si un champ de texte existe déjà dans la cellule et si vous sélectionnez Champ numérique dans la liste Type, le champ numérique remplace le champ de texte.
      •
      Faites glisser dans une cellule un objet de la conception de formulaire qui se trouve à l'extérieur du tableau. Cette procédure permet de préserver l'aspect de l'objet. Si vous faites glisser, par exemple, un champ de numéro de téléphone formaté dans une cellule, la légende est conservée, ainsi que la taille du champ.
Si vous faites glisser dans une cellule un objet sous-formulaire se trouvant à l'extérieur du tableau, il remplace le contenu de la cellule.
si vous changez une cellule en champ de texte, vous pouvez sélectionner l'option Permettre des lignes multiples de la palette Objet afin afficher plusieurs lignes de texte.
Pour changer une cellule en un autre type d'objet par l'intermédiaire de la liste Type de l'onglet Cellule de la palette Objet
1.
Sélectionnez la cellule. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Dans la palette Objet, cliquez sur l'onglet Cellule et choisissez un autre type d'objet dans la liste Type.
Pour changer une cellule en un autre type d'objet en faisant glisser un objet de la palette Bibliothèque
      *
      Faites glisser l'objet à partir de la palette Bibliothèque vers la cellule dans laquelle il doit apparaître.
Pour changer une cellule en un autre type d'objet en faisant glisser un objet de la conception de formulaire
      *
      Dans la conception de formulaire, faites glisser l'objet existant qui se trouve hors du tableau vers la cellule dans laquelle il doit apparaître.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Utilisation des sections de tableau

Utilisation des sections de tableau

Pour insérer une section de tableau
Pour regrouper des rangées en section
Pour créer une section de tableau facultative


Pour insérer une section de tableau

Une section de tableau est un ensemble de rangées qui constituent une unité. L'utilisation des sections permet d'organiser le tableau. Une section peut avoir ses propres en-tête et pied de page, afin que vous puissiez afficher des informations détaillées regroupées par types de valeurs. Chaque section apparaît dans le formulaire selon un ordre précis. Par défaut, LiveCycle Designer insère une rangée d'en-tête par section.
1.
Sélectionnez une cellule ou une rangée. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Choisissez Tableau > Insérer, puis Section au-dessus ou Section en dessous.
LiveCycle Designer insère une rangée d'en-tête et une rangée de contenu pour la section.


Pour regrouper des rangées en section

Une fois le tableau créé, vous pouvez regrouper les rangées en sections. Vous pouvez également ombrer les sections avec des couleurs différentes. Le tableau suivant, par exemple, contient quatre sections.
Pour regrouper des rangées en section
1.
Sélectionnez les rangées à grouper. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Choisissez Tableau> Regrouper comme section.
LiveCycle Designer affiche un crochet à droite du tableau pour marquer la section.
Pour dissocier une section et rétablir les rangées
      *
      Sélectionnez la section et choisissez Tableau > Dissocier la section.
Voir aussi
Pour insérer une section de tableau
Pour créer une section de tableau facultative


Pour créer une section de tableau facultative

Il peut être intéressant de créer une section facultative lorsque vous ne souhaitez pas afficher les informations de la section. L'exemple suivant montre un tableau où les sections 1 et 3 sont masquées.
1.
Sélectionnez la section. Voir Pour sélectionner un tableau, une rangée, une colonne, une cellule ou une section.
2.
Dans la palette Objet, cliquez sur l'onglet Liaison, puis désactivez l'option Section pour chaque élément.
pour afficher une section de tableau qui a été masquée, sélectionnez la section, l'option Section pour chaque élément, puis l'option Min. de répétitions et enfin tapez 1 dans la zone.


Manipulation des sections de choix dans les tableaux

A propos des sections de choix dans les tableaux
Pour créer des sections de choix dans les tableaux
Pour ajouter et supprimer des rangées dans les sections de choix
Pour créer des liaisons de données et des instructions conditionnelles pour les sections de choix


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Manipulation des sections de choix dans les tableaux > A propos des sections de choix dans les tableaux

A propos des sections de choix dans les tableaux

Une section de choix correspond à une section d'un tableau qui peut être personnalisée pour afficher des rangées spécifiques de la section.
Cette personnalisation s'applique aux diverses rangées de la section grâce à des instructions conditionnelles. Vous pouvez faire en sorte, par exemple, qu'une section de choix affiche les occurrences d'une rangée spécifique en utilisant des couleurs particulières pour le texte selon la valeur d'un champ spécifique de cette rangée.
Voir aussi
Boîte de dialogue Modifier les sous-formulaires désignés par les données


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Manipulation des sections de choix dans les tableaux > Pour créer des sections de choix dans les tableaux

Pour créer des sections de choix dans les tableaux

Vous pouvez créer une section de choix à partir d'une section ou d'une rangée d'un tableau.
Pour créer une section de choix à partir d'une section existante
1.
Sélectionnez une section de tableau.
2.
Dans la palette Objet, cliquez sur l'onglet Section, puis sélectionnez l'option Choisir sous-formulaire de remplacement dans la liste Type.
Pour créer une section de choix à partir d'une rangée
      *
      Sélectionnez une rangée du tableau, puis choisissez Tableau > Regrouper comme section de choix.
Voir aussi
Boîte de dialogue Modifier les sous-formulaires désignés par les données


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Manipulation des sections de choix dans les tableaux > Pour ajouter et supprimer des rangées dans les sections de choix

Pour ajouter et supprimer des rangées dans les sections de choix

Vous pouvez ajouter et supprimer des rangées d'en-tête, de contenu et de pied de page à une section de choix à l'aide de la boîte de dialogue Modifier les sous-formulaires désignés par les données.
Vous pouvez ajouter des rangées d'en-tête, de contenu et de pied de page à une section de choix, ou bien supprimer ces éléments d'un jeu de sous-formulaires de choix, en sélectionnant une des options suivantes :
      •
      Utilisation de la boîte de dialogue Modifier les sous-formulaires désignés par les données
      •
      Modification manuelle du contenu en faisant glisser les objets de sous-formulaire vers ou à l'extérieur de la section de choix en utilisant la palette Hiérarchie
Pour ajouter une rangée d'en-tête, de contenu ou de pied de page à une section de choix
1.
Sélectionnez une section de choix.
2.
Dans la palette Objet, cliquez sur l'onglet Section et assurez-vous que l'option Choisir sous-formulaire de remplacement est activée dans la liste Type.
3.
Cliquez sur le bouton Modifier les variantes.
4.
Cliquez sur le bouton Ajouter [image] pour ajouter un nouvel élément à la liste Sous-formulaires de remplacement. Vous pouvez également faire glisser des rangées dans le jeu de sous-formulaires de choix en utilisant la palette Hiérarchie.
L'ajout d'une nouvelle rangée copie la rangée sélectionnée. Si aucune rangée n'est sélectionnée, une nouvelle rangée sans nom est ajoutée à la section de choix.
5.
Utilisez les flèches vers le haut [image] et le bas [image] pour déplacer la nouvelle rangée à l'endroit souhaité. Il est important d'organiser les entrées dans la liste Sous-formulaires de remplacement, car elles sont traitées de manière séquentielle au moment de l'exécution et la première dont l'expression s'avère vraie apparaît sur le formulaire.
cette procédure indique comment ajouter de nouvelles rangées à une section de choix existante. Lorsque vous ajoutez des rangées de cette manière, LiveCycle Designer commence par créer un nouvel objet de rangée, puis l'ajoute au tableau et à la section de choix. Pour ajouter des rangées de tableau existantes à une section de choix, utilisez la palette Hiérarchie pour faire glisser les objets dans la section de choix.
Pour supprimer une rangée d'en-tête, de contenu ou de pied de page d'une section de choix
1.
Sélectionnez une section de choix.
2.
Dans la palette Objet, cliquez sur l'onglet Section, puis sur Modifier les variantes.
3.
Sélectionnez une entrée dans la liste Sous-formulaires de remplacement et cliquez sur Supprimer [image].
la suppression d'une rangée par l'intermédiaire de la boîte de dialogue Modifier les sous-formulaires désignés par les données supprime définitivement l'objet de la conception de formulaire. Si vous souhaitez conserver la rangée, tout en la supprimant de la section de choix, vous devez faire glisser manuellement la rangée en dehors de la section de choix en utilisant la palette Hiérarchie.
Voir aussi
Boîte de dialogue Modifier les sous-formulaires désignés par les données


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des tableaux > Manipulation des sections de choix dans les tableaux > Pour créer des liaisons de données et des instructions conditionnelles pour les sections de choix

Pour créer des liaisons de données et des instructions conditionnelles pour les sections de choix

Après avoir créé une section de choix, vous pouvez créer des liaisons de données avec ou sans instructions conditionnelles pour les diverses rangées de la section. Par rapport à la simple liaison de données, l'utilisation d'instructions conditionnelles permet de mieux contrôler le moment où les rangées sont affichées dans la section de choix sur le formulaire.
Pour chaque rangée mentionnée dans la liste Sous-formulaires de remplacement de la boîte de dialogue Modifier les sous-formulaires désignés par les données, vous pouvez spécifier un noeud de données à partir de la connexion aux données. Vous pouvez utiliser une instruction conditionnelle qui s'avèrera vraie ou fausse au moment de l'exécution. Seule la première entrée de la liste Sous-formulaires de remplacement qui s'avère vraie apparaît sur le formulaire.
1.
Sélectionnez un objet de jeu de sous-formulaires.
2.
Dans la palette Objet, cliquez sur l'onglet Section et assurez-vous que l'option Choisir sous-formulaire de remplacement est activée dans la liste Type.
3.
Cliquez sur Modifier les variantes.
4.
Choisissez comment spécifier une liaison de données à partir de la section de choix en effectuant l'une des actions suivantes :
      •
      Cliquez sur Choisir le sous-formulaire dont le nom correspond à l'élément ou attribut de données pour lier les noeuds de données aux rangées par nom. Dans ce cas, les noms des noeuds de données associés doivent correspondre à ceux des rangées sur la conception de formulaire.
      •
      Cliquez sur Choisir le sous-formulaire à l'aide de l'expression pour lier manuellement les rangées de la conception de formulaire aux noeuds de données.
5.
Dans la liste Connexion aux données, sélectionnez la source de données à partir de laquelle vous souhaitez lier les données.
6.
Cliquez sur le bouton d'ajout [image] pour insérer une rangée dans le tableau ou sélectionnez un article de liste existant. L'ajout d'une nouvelle rangée copie la rangée sélectionnée. Si aucune rangée n'est sélectionnée, une nouvelle rangée sans nom est ajoutée à la section de choix.
7.
Insérez un nouveau sous-formulaire dans le jeu de sous-formulaires de choix ou sélectionnez un article de liste existant. L'ajout d'un nouveau sous-formulaire copie le sous-formulaire sélectionné. Si aucun sous-formulaire n'est sélectionné, un nouveau sous-formulaire sans nom est ajouté au jeu de sous-formulaires de choix.
8.
Dans le champ Nom, saisissez un nom pour le nouvel objet de rangée, si nécessaire. Si vous liez la rangée par élément de données ou nom d'attribut, vérifiez que le nom du champ correspond exactement à celui du noeud de données associé.
Si vous avez sélectionné l'option Choisir le sous-formulaire dont le nom correspond à l'élément ou attribut de données à l'étape 4, vous pouvez passer directement à l'étape 12. Sinon, passez à l'étape 9.
9.
Cliquez sur la flèche située à droite du champ Liaison, puis sélectionnez un noeud de données à l'aide du menu déroulant. LiveCycle Designer remplit automatiquement le champ Liaison avec un script faisant référence au noeud de données sélectionné. Vous pouvez également taper manuellement une référence dans le champ.
10.
Sélectionnez un langage de script dans la liste Langage.
11.
Dans le champ Expression, saisissez le script permettant d'effectuer les actions désirées ou le traitement à appliquer à la rangée et au noeud de données spécifiés.
12.
Répétez les étapes 6 à 10 pour toutes les autres rangées de la section de choix, puis cliquez sur OK.
Voir aussi
Boîte de dialogue Modifier les sous-formulaires désignés par les données


Utilisation des sous-formulaires

A propos des sous-formulaires
Création et configuration des sous-formulaires
Utilisation des jeux de sous-formulaires
Création de formulaires multipages qui se répètent
Utilisation des jeux de sous-formulaires de choix


A propos des sous-formulaires

Aperçu des sous-formulaires
Sous-formulaires par défaut
Sous-formulaires qui positionnent le contenu
Sous-formulaires qui enchaînent le contenu
Sous-formulaires s'étendant sur plusieurs pages
Sous-formulaires de début et de fin de débordement


Aperçu des sous-formulaires

Un sous-formulaire est une section d'une conception de formulaire qui permet de gérer l'ancrage, la disposition et la géométrie des objets. Les objets contenus dans un sous-formulaire peuvent être organisés en rangées, en colonnes ou selon un autre agencement équilibré.
Une conception de formulaire peut contenir plusieurs sous-formulaires. Les sous-formulaires peuvent eux-mêmes être imbriqués dans d'autres sous-formulaires. Cette relation s'affiche dans la palette Hiérarchie.
Les sous-formulaires servent à organiser un formulaire en plusieurs sections. Ils sont également pratiques pour créer un formulaire avec des sections ajustables automatiquement au volume des données. Si le sous-formulaire est configuré pour s'étendre, sa disposition change en fonction de la quantité de données à fusionner dans le formulaire rendu. Au moment de la fusion de données, les sous-formulaires s'assurent que les objets et les données correspondantes sont disposés de façon cohérente. Les sous-formulaires peuvent servir à faire correspondre la hiérarchie des données dans les données XML.
Si vous concevez un formulaire ayant une disposition fixe, il est peu probable que vous ayez besoin de plusieurs sous-formulaires, car le sous-formulaire par défaut positionne les objets automatiquement.
Vous pouvez définir les propriétés d’un sous-formulaire dans les panneaux Sous-formulaire et Liaison de la palette Objet. Vous pouvez définir les propriétés suivantes :
      •
      Attribuer un nom évocateur au sous-formulaire (recommandé)
      •
      Permettre au sous-formulaire de s'étendre au-delà du saut de page ou le forcer à commencer sur la page suivante lorsque les données sont fusionnées
      •
      Indiquer s'il faut placer le sous-formulaire après le sous-formulaire précédent, dans la zone de contenu spécifiée, ou plutôt sur une page formatée selon le gabarit spécifié
      •
      Indiquer s'il faut placer le sous-formulaire dans la même zone de contenu que le sous-formulaire précédent ou suivant
      •
      Indiquer l'enchaînement des données fusionnées une fois que le sous-formulaire est en place
      •
      Définir si le sous-formulaire est visible, invisible ou masqué
      •
      Définir le paramètre régional associé au sous-formulaire
      •
      Indiquer si le sous-formulaire répète ses objets chaque fois qu'un élément de données unique est fourni pour un de ses objets
      •
      Au besoin, définir le début de débordement ou la fin de débordement d'un sous-formulaire pouvant répéter le rendu de ses objets
      •
      Spécifier la méthode de liaison pour contrôler la façon dont les objets du sous-formulaire sont associés aux données
Voir aussi
Sous-formulaires par défaut
Pour ajouter un sous-formulaire
Pour placer des objets à l'intérieur ou hors d'un sous-formulaire
Propriétés de l'objet Sous-formulaire dans l’onglet Sous-formulaire
Propriétés du sous-formulaire dans le panneau Pagination
Propriétés des sous-formulaires dans le panneau Liaison


Sous-formulaires par défaut

Tous les formulaires contiennent un sous-formulaire racine (parent). Dans la palette Hiérarchie, le sous-formulaire racine (formulaire1) figure comme noeud supérieur, le sous-formulaire de page par défaut (sous-formulaire sans titre) apparaissant comme noeud enfant sous le sous-formulaire racine.
LiveCycle Designer ajoute automatiquement à chaque page un sous-formulaire par défaut qui couvre toute la page et qui correspond en taille et en position à la zone de contenu par défaut du gabarit. Tout sous-formulaire ajouté par la suite aux pages sera imbriqué et figurera sous le sous-formulaire de page par défaut dans la palette Hiérarchie.
Dans la palette Hiérarchie, chaque sous-formulaire est représenté par un noeud et les objets compris dans un sous-formulaire s'affichent sous le noeud correspondant. Les enfants du sous-formulaire n'héritent pas des modifications effectuées au niveau du sous-formulaire. Vous devez définir les propriétés de votre choix pour chacun des objets.
Dans l'exemple Bon de commande, le sous-formulaire racine, formulaire1, figure comme noeud supérieur, alors que le sous-formulaire de page par défaut, purchaseOrder, apparaît dessous en tant qu'enfant du sous-formulaire racine. Les autres sous-formulaires utilisés pour placer des objets dans la page (header, detailHeader, detail et total) sont imbriqués sous le sous-formulaire de page. Dans la palette Hiérarchie, chaque sous-formulaire est représenté par un noeud, et les objets placés dans un sous-formulaire sont affichés sous chaque noeud.
Voir aussi
Aperçu des sous-formulaires
Propriétés de l'objet Sous-formulaire dans l’onglet Sous-formulaire
Propriétés du sous-formulaire dans le panneau Pagination
Propriétés des sous-formulaires dans le panneau Liaison
A propos de la création de conceptions de formulaire prévues pour s'adapter aux données


Sous-formulaires qui positionnent le contenu

Les objets du sous-formulaire sont positionnés en fonction de leurs coordonnées X et Y. Lors du rendu du formulaire, les sous-formulaires avec enchaînement sont placés dans un ordre déterminé par leur position dans la palette Hiérarchie.
Par défaut, tous les sous-formulaires sauf le sous-formulaire racine (formulaire1) sont configurés pour positionner le contenu. Lorsqu'un sous-formulaire est configuré pour positionner le contenu, il peut quand même s'étendre pour tenir compte de la quantité de données fusionnées, mais aucun des objets du sous-formulaire ne peut bouger de son point d'ancrage. En conséquence, si un sous-formulaire est configuré pour positionner le contenu, vous devez fréquemment tester la conception de formulaire pour vous assurer qu'aucun objet du sous-formulaire susceptible de s'étendre après fusion des données, ne recouvre d'autres objets dans la conception de formulaire. Rappelez-vous que tout objet prévu pour s'étendre, comme un objet de champ de texte, risque de chevaucher un autre objet lorsque LiveCycle Forms génère le formulaire. Pour éviter ce souci lié à la conception, vous pouvez configurer le sous-formulaire pour qu'il s'étende et s'ajuste au contenu. (Voir Sous-formulaires qui enchaînent le contenu.)
LiveCycle Designer définit automatiquement le sous-formulaire de page par défaut pour qu'il positionne le contenu, afin de faciliter la création de formulaires interactifs avec une disposition fixe. Pour plus de détails, voir Sous-formulaires par défaut.
Toutefois, lorsque vous créez un formulaire prévu pour s'adapter à la taille des données, après avoir terminé la conception, vous devez configurer le sous-formulaire de page par défaut pour qu'il enchaîne le contenu. Il vaut mieux faire cela en dernier lieu, pour que le sous-formulaire reste visible et que les objets que vous placez dans le sous-formulaire demeurent à la position souhaitée dans la page.
Utilisez l'option Contenu positionné, dans la liste Type du panneau Sous-formulaire, pour positionner le contenu dans un sous-formulaire. Lorsque vous choisissez l'option Contenu positionné, les coordonnées X et Y de chaque objet, dans le sous-formulaire, sont maintenues. Les objets sont placés à leurs coordonnées X et Y relativement à la position du sous-formulaire.


Sous-formulaires qui enchaînent le contenu

Les objets du sous-formulaire sont positionnés pendant le processus de fusion des données de façon à éviter toute superposition d’objets. Les sous-formulaires qui enchaînent du contenu sont disposés par ordre croissant. Vous pouvez utiliser des sous-formulaires permettant l'enchaînement du contenu lorsque vous avez besoin de formulaires dont la taille varie en fonction des données.
Par défaut, le sous-formulaire racine (formulaire1) est configuré pour enchaîner le contenu. Le sous-formulaire racine enchaîne toujours le contenu d'après l'option de direction de l'enchaînement que vous appliquez à la zone de contenu par défaut correspondante. Puisque le sous-formulaire racine est configuré pour enchaîner le contenu, tous les sous-formulaires imbriqués sous lui s'enchaînent automatiquement, d'une page de formulaire à l'autre (zone de contenu), au besoin, lorsque les données sont fusionnées. Dans le rendu du formulaire, les sous-formulaires situés sous le sous-formulaire racine sont disposés en ordre décroissant selon leur position dans la hiérarchie des objets.
Vous pouvez aussi configurer n'importe quel autre sous-formulaire pour qu'il enchaîne le contenu. Chaque sous-formulaire configuré pour l'enchaînement du contenu peut contenir des quantités variables de données. Les objets contenus dans le sous-formulaire se déplacent ensemble lors de la fusion des données, de façon à ce qu'aucun de ces objets n'entre en conflit avec les autres.
Utilisez l'option Contenu avec enchaînement, dans la liste Type du panneau Sous-formulaire, pour enchaîner le contenu dans un sous-formulaire. Lorsque vous choisissez l'option Contenu avec enchaînement, les objets sont disposés d'après l'option Direction de l'enchaînement que vous avez sélectionnée. La liste Direction de l'enchaînement et l'option Autoriser des sauts de page ne sont activées qu'après avoir sélectionné Contenu avec enchaînement dans la liste Type.
Voir aussi
Aperçu des sous-formulaires


Sous-formulaires s'étendant sur plusieurs pages

Même si vous pouvez placer un sous-formulaire n'importe où dans une page, lorsqu'une grande quantité de données est fusionnée avec le formulaire, le sous-formulaire risque de dépasser la bordure inférieure de la page générée. Pour résoudre ce problème, vous pouvez soit sélectionner l'option Autoriser des sauts de page pour demander à LiveCycle Forms de scinder en deux le sous-formulaire, soit désélectionner cette option pour forcer le renvoi de tout le sous-formulaire au début de la page rendue suivante. Le renvoi forcé d'un sous-formulaire à la page suivante permet de garantir que tous les sous-formulaires imbriqués s'affichent sur la même page. Si vous ne sélectionnez pas l'option Autoriser des sauts de page, vous voudrez sans doute créer un sous-formulaire de début et de fin de débordement. (Voir Sous-formulaires de début et de fin de débordement.)
Lorsque les données sont fusionnées, LiveCycle Forms positionne le contenu d'un sous-formulaire uniquement dans les limites des zones de contenu. S'il faut fusionner une grande quantité de données avec l'un des objets d'un sous-formulaire, celui-ci peut s'étendre sur plusieurs pages de formulaire. Lorsqu'une page de formulaire est remplie, LiveCycle Forms génère automatiquement une autre page identique et continue à mettre en forme le sous-formulaire sur la nouvelle page à moins que vous ne dirigiez explicitement l'enchaînement vers une zone de contenu ou un gabarit différent. Lorsqu'il existe plusieurs zones de contenu ou gabarits dans un même formulaire, vous pouvez indiquer si le sous-formulaire doit être placé dans une zone de contenu particulière ou disposé selon le gabarit.


Sous-formulaires de début et de fin de débordement

Du fait que la longueur d'un formulaire avec une disposition souple varie selon la quantité de données qui y sont fusionnées, les formulaires de ce type comptent souvent plus d'une page. L'utilisation de sous-formulaires de début et de fin de débordement est une façon efficace de commencer et de terminer les sous-formulaires qui se répètent sur plusieurs pages. Comme sous-formulaire de début ou de fin de débordement, vous pouvez utiliser n'importe quel sous-formulaire configuré pour positionner le contenu. Par exemple, dans le formulaire d'exemple Bon de commande, le sous-formulaire detail est configuré pour positionner le contenu et pour se répéter avec chaque élément de données. Lorsque des données sont fusionnées avec le formulaire, s'il y a suffisamment d'espace sur la première page pour afficher toutes les occurrences du sous-formulaire detail, une nouvelle page est ajoutée et les données continuent à s'enchaîner vers la zone de contenu suivante.
Lorsque les données s'enchaînent de cette façon sur plusieurs pages, il est parfois souhaitable d'afficher sur chaque nouvelle page une mention du genre « Suite de la page précédente » ou des éléments de formatage spécifiques, tels qu'une rangée d'en-tête de colonne contenant le libellé descriptif de chaque colonne de données. L'utilisation de rangées d'en-tête de colonne sur chaque page suivante rend le formulaire bien plus facile à lire pour les utilisateurs. Pour ce faire, vous pouvez créer un sous-formulaire de début de débordement qui fera office de rangée d'en-tête de colonne pour chaque page supplémentaire. Dans le formulaire d'exemple Bon de commande, le sous-formulaire detailHeader est sélectionné comme sous-formulaire de début de débordement. En conséquence, LiveCycle Forms génèrera une copie du sous-formulaire detailHeader au début de chaque nouvelle page avant la première occurrence du sous-formulaire detail.
De même, il se peut que vous vouliez inclure certaines informations à la suite de la dernière occurrence du sous-formulaire répété, au bas de toutes les pages à l'exception de la dernière. Par exemple, vous pouvez inclure la mention « Suite à la page suivante » au bas des pages. Pour ce faire, vous pouvez créer un sous-formulaire de fin de débordement pour le sous-formulaire répété, de la même façon que vous avez créé le sous-formulaire de début de débordement.
Lorsqu'un sous-formulaire déborde sur la nouvelle page, LiveCycle Forms effectue les opérations suivantes :
      •
      Il place le sous-formulaire de début de débordement sur la page actuelle
      •
      Il dispose le sous-formulaire de fin de débordement sur la page suivante
      •
      Il enchaîne le sous-formulaire et le reste de ses objets répétés sur la nouvelle page


Création et configuration des sous-formulaires

Pour ajouter un sous-formulaire
Pour attribuer un nom à un sous-formulaire
Pour rendre un sous-formulaire visible ou invisible, ou pour le masquer
Pour définir un paramètre régional (langue et pays) pour un sous-formulaire
Pour placer des objets à l'intérieur ou hors d'un sous-formulaire
Pour définir le mode de gestion du contenu par un sous-formulaire
Pour définir la position des sous-formulaires
Pour définir le mode de fusion des données entre sous-formulaires
Pour définir les propriétés de liaison personnalisée d'un sous-formulaire


Pour ajouter un sous-formulaire

Vous pouvez insérer un sous-formulaire à partir du menu ou de la palette Bibliothèque.
Pour ajouter un sous-formulaire à partir de la barre de menus
      *
      A la page du formulaire, choisissez Insertion > Standard > Sous-formulaire.
Pour ajouter un sous-formulaire à partir de la palette Bibliothèque
      *
      Effectuez l'une des opérations suivantes :
Cliquez sur l'onglet Standard de la palette Bibliothèque, sélectionnez l'objet Sous-formulaire et dessinez l'objet sur la page du formulaire.
      •
      A partir du panneau Standard de la palette Bibliothèque, faites glisser l'objet Sous-formulaire sur la page du formulaire.
      •
      Dans la palette Bibliothèque, cliquez sur l'onglet Standard, puis cliquez deux fois sur l'objet Sous-formulaire.
Voir aussi
Aperçu des sous-formulaires
Pour attribuer un nom à un sous-formulaire
Sous-formulaires par défaut
Pour placer des objets à l'intérieur ou hors d'un sous-formulaire
Pour définir un sous-formulaire qui s'étend sur plusieurs pages


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des sous-formulaires > Création et configuration des sous-formulaires > Pour attribuer un nom à un sous-formulaire

Pour attribuer un nom à un sous-formulaire

Pour nommer ou renommer un sous-formulaire, vous devez d'abord le sélectionner.
Pour nommer ou renommer un sous-formulaire à l'aide la palette Hiérarchie
1.
Dans la palette Hiérarchie, cliquez sur le sous-formulaire avec le bouton droit de la souris et choisissez Renommer l'objet.
2.
Tapez le nouveau nom et appuyez sur Entrée.
Pour nommer ou renommer un sous-formulaire à partir du panneau Liaison de la palette Objet
1.
Sélectionnez le sous-formulaire.
2.
Dans l'onglet Liaison, tapez le nouveau nom du sous-formulaire dans la zone Nom et appuyez sur Entrée. LiveCycle Designer gère automatiquement le nombre d’occurrences.
Voir aussi
Aperçu des sous-formulaires
Propriétés des sous-formulaires dans le panneau Liaison
Pour définir les propriétés de liaison personnalisée d'un sous-formulaire


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des sous-formulaires > Création et configuration des sous-formulaires > Pour rendre un sous-formulaire visible ou invisible, ou pour le masquer

Pour rendre un sous-formulaire visible ou invisible, ou pour le masquer

1.
Sélectionnez le sous-formulaire.
2.
Dans la palette Objet, cliquez sur l'onglet Sous-formulaire.
3.
Dans la liste Visibilité, sélectionnez l'option qui correspond à vos besoins :
      •
      Pour rendre l'objet visible à l'écran et sur le formulaire imprimé et le prendre en compte dans la disposition du formulaire, sélectionnez Visible.
      •
      Pour rendre l'objet visible à l'écran, invisible sur le formulaire imprimé et le prendre en compte dans la disposition du formulaire, sélectionnez Visible (Ecran seulement).
      •
      Pour rendre l'objet invisible à l'écran, visible sur le formulaire imprimé et le prendre en compte dans la disposition du formulaire, sélectionnez Visible (Impression seulement).
      •
      Pour rendre l'objet invisible à l'écran et sur le formulaire imprimé et le prendre en compte dans la disposition du formulaire, sélectionnez Invisible.
      •
      Pour rendre l'objet invisible à l'écran et sur le formulaire imprimé sans le prendre en compte dans la disposition du formulaire, sélectionnez Masqué (pas affiché).
Voir aussi
A propos des méthodes pour rendre des objets visibles ou invisibles ou les masquer
Pour rendre un objet visible ou invisible ou le masquer


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des sous-formulaires > Création et configuration des sous-formulaires > Pour définir un paramètre régional (langue et pays) pour un sous-formulaire

Pour définir un paramètre régional (langue et pays) pour un sous-formulaire

1.
Sélectionnez le sous-formulaire.
2.
Cliquez sur l'onglet Champ de la palette Objet.
3.
Dans la zone Paramètre régional, sélectionnez l'une des options suivantes ou l'un des paramètres régionaux suggérés :
      •
      Pour appliquer le paramètre régional par défaut défini dans le panneau Valeurs par défaut de la boîte de dialogue Propriétés du formulaire, sélectionnez Paramètre régional par défaut.
      •
      Pour utiliser le paramètre régional système de l'ordinateur de l'utilisateur, choisissez Paramètre régional du système de visualisation.
lors de la conception et de l'exécution, les valeurs formatées dans le champ sont tributaires du format du paramètre régional.
Voir aussi
Propriétés de la palette Disposition
Propriétés de la palette Bordure
Aperçu des sous-formulaires
Propriétés de l'objet Sous-formulaire dans l’onglet Sous-formulaire


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des sous-formulaires > Création et configuration des sous-formulaires > Pour placer des objets à l'intérieur ou hors d'un sous-formulaire

Pour placer des objets à l'intérieur ou hors d'un sous-formulaire

Un objet est placé dans un sous-formulaire lorsqu'il est contenu dans celui-ci.
Pour ajouter des objets à un sous-formulaire existant
      *
      Sélectionnez les objets à inclure dans le sous-formulaire, puis choisissez Insertion > Placer dans un sous-formulaire.
Pour placer des objets hors d'un sous-formulaire
      *
      Sélectionnez le sous-formulaire qui comporte les objets à exclure, puis choisissez Insertion > Placer hors du sous-formulaire.
Voir aussi
Propriétés de l'objet Sous-formulaire dans l’onglet Sous-formulaire
Pour ajouter un sous-formulaire


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des sous-formulaires > Création et configuration des sous-formulaires > Pour définir le mode de gestion du contenu par un sous-formulaire

Pour définir le mode de gestion du contenu par un sous-formulaire

Par défaut, tous les sous-formulaires, excepté le sous-formulaire racine, sont définis de façon à positionner le contenu. Le sous-formulaire racine enchaîne toujours le contenu selon la direction indiquée par l'option Enchaînement définie pour la zone de contenu associée. Etant donné que le sous-formulaire racine enchaîne le contenu, tous les sous-formulaires imbriqués dans le sous-formulaire racine peuvent déborder automatiquement d'une page ou d'une zone de contenu à la suivante, si cela s'avère nécessaire à la suite de la fusion de données.
En revanche, lorsque le sous-formulaire positionne son contenu, l'espace délimité par le sous-formulaire peut s'agrandir pour recevoir les données fusionnées, mais aucun des objets du sous-formulaire ne peut bouger par rapport à ses points d'ancrage. Par conséquent, si un sous-formulaire comporte des objets qui risquent de fusionner des données de tailles diverses, vous devez vous assurer que ces objets n'atteignent jamais une taille telle qu'ils pourraient chevaucher l'espace occupé par un autre objet. Tout objet qui s'agrandit par suite de la fusion de données, comme un champ de texte, présente le risque de superposer d'autres objets.
Pour éviter ce problème, vous pouvez définir le sous-formulaire pour qu'il enchaîne le contenu. Un sous-formulaire qui enchaîne le contenu place les objets correctement pendant le processus de fusion des données de sorte qu'aucun des objets ne soit rendu par-dessus un autre.
Le sous-formulaire par défaut associé à la page positionne le contenu de manière à prendre en charge la création des formulaires interactifs et de formulaires avec une disposition fixe. Si vous concevez un formulaire contenant des sous-formulaires prévus pour s'adapter aux données, vous devez vous familiariser aussi bien aux sous-formulaires destinés à positionner le contenu qu'à ceux permettant d'enchaîner le contenu. Vous pouvez recourir à différentes techniques lorsque vous travaillez avec des sous-formulaires dans ce type de conception de formulaire. L'approche que vous choisirez dépendra de votre expérience en matière de création de formulaires adaptables au contenu. Pour plus de détails, voir A propos de la création de conceptions de formulaire prévues pour s'adapter aux données.
Pour indiquer comment un sous-formulaire positionne son contenu
      *
      Dans le panneau Sous-formulaire de la palette Objet, sélectionnez l'une des options suivantes dans la liste Contenu :
      •
      Positionné
      •
      Distribué
Pour indiquer la direction de l'enchaînement des objets dans un sous-formulaire dont le contenu est enchaîné
      *
      Dans la palette Objet, cliquez sur l’onglet Sous-formulaire. Dans la liste Enchaînement, sélectionnez une des options suivantes (les objets sont toujours placés à partir du haut du sous-formulaire) :
      •
      Haut vers le bas
      •
      Texte occidental
l'option Enchaînement n'est disponible que si vous avez sélectionné l'option Distribué dans la liste Contenu.
Pour changer un sous-formulaire à contenu positionné en sous-formulaire à contenu avec enchaînement :
1.
Sélectionnez le sous-formulaire dans lequel vous voulez que le contenu soit enchaîné.
2.
Dans la palette Objet, cliquez sur l'onglet Sous-formulaire et sélectionnez Enchaînement dans la liste Contenu.
3.
Dans la liste Enchaînement, sélectionnez une des options suivantes (les objets sont toujours placés à partir du haut du sous-formulaire) :
      •
      Haut vers le bas
      •
      Texte occidental
Voir aussi
Propriétés de l'objet Sous-formulaire dans l’onglet Sous-formulaire
Pour définir la position des sous-formulaires
Pour définir le mode de fusion des données entre sous-formulaires


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des sous-formulaires > Création et configuration des sous-formulaires > Pour définir la position des sous-formulaires

Pour définir la position des sous-formulaires

Pour indiquer l'emplacement d'un sous-formulaire
      *
      Dans le panneau Pagination de la palette Objet, cliquez sur la flèche à droite de la zone Placer et sélectionnez une des options de présentation suivantes :
      •
      Suivant le précédent
      •
      Dans la zone de contenu > [nom_de_la_zone_de_contenu]
      •
      Haut de la zone de contenu suivante
      •
      Haut de la zone de contenu > [nom_de_la_zone_de_contenu]
      •
      A la page > [nom_de_la_page]
      •
      Haut de la page suivante
      •
      Haut de la page > [nom_de_la_page]
Pour conserver le sous-formulaire dans la même zone de contenu ou page que le sous-formulaire précédent ou suivant
      *
      Dans la palette Objet, cliquez sur l'onglet Pagination, puis sélectionnez l'option Conserver avec le précédent ou Conserver avec le suivant.
Voir aussi
Propriétés de l'objet Sous-formulaire dans l’onglet Sous-formulaire
Pour définir le mode de gestion du contenu par un sous-formulaire
Pour définir le mode de fusion des données entre sous-formulaires


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des sous-formulaires > Création et configuration des sous-formulaires > Pour définir le mode de fusion des données entre sous-formulaires

Pour définir le mode de fusion des données entre sous-formulaires

      *
      Dans le panneau Pagination de la palette Objet, cliquez sur la flèche à droite de la zone Après et sélectionnez une des options suivantes :
      •
      Continuer à remplir le parent
      •
      Aller à la zone de contenu suivante
      •
      Aller à la zone de contenu > [nom_de_la_zone_de_contenu]
      •
      Aller à la page suivante
      •
      Aller à la page > [nom_de_la_page]
Voir aussi
Propriétés du sous-formulaire dans le panneau Pagination
Pour définir le mode de gestion du contenu par un sous-formulaire
Pour définir la position des sous-formulaires


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des sous-formulaires > Création et configuration des sous-formulaires > Pour définir les propriétés de liaison personnalisée d'un sous-formulaire

Pour définir les propriétés de liaison personnalisée d'un sous-formulaire

Les options de liaison permettent de concevoir un formulaire qui capture les données pour les infrastructures de l'entreprise ou d'utiliser une source de données externe pour remplir le formulaire à l'exécution. Définissez les propriétés de liaison de données dans le panneau Liaison de la palette Objet.
Les sous-formulaires proprement dits n'affichent pas et ne capturent pas des données, mais les objets inclus dans un sous-formulaire peuvent le faire. Les paramètres de liaison d'un sous-formulaire ont des répercussions directes sur la façon dont les objets imbriqués sont mappés aux données.
Un sous-formulaire peut être lié à un groupe de données et les objets du sous-formulaire peuvent être liés à des valeurs de données contenues dans ce groupe de données. Par défaut, les liaisons des objets inclus dans un sous-formulaire sont tributaires des liaisons du sous-formulaire.
1.
Sélectionnez le sous-formulaire.
2.
Activez le formulaire pour établir la connexion à la source de données lorsque le formulaire est ouvert.
3.
Liez le sous-formulaire et ses objets aux noeuds de données correspondants. Pour plus d'informations sur la liaison des objets à une source de données, voir A propos de la liaison de champs à une source de données.
Voir aussi
Aperçu des sous-formulaires
Propriétés des sous-formulaires dans le panneau Liaison
Pour attribuer un nom à un sous-formulaire
Pour créer un sous-formulaire qui se répète


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des sous-formulaires > Utilisation des jeux de sous-formulaires

Utilisation des jeux de sous-formulaires

Aperçu des jeux de sous-formulaires
Pour insérer un jeu de sous-formulaires


Aperçu des jeux de sous-formulaires

Un jeu de sous-formulaires est un ensemble de plusieurs sous-formulaires qui se répètent ou de sous-formulaires multipages.
Utilisez le jeu de sous-formulaires pour contrôler l'ordre dans lequel LiveCycle Forms génère les sous-formulaires du jeu, en fonction de l'ordre selon lequel ils apparaissent dans le jeu.
Ainsi, dans le formulaire d'exemple Bon de commande, les sous-formulaires detailHeader et detail forment un jeu de sous-formulaires. Le jeu de sous-formulaires maintient ensemble les deux sous-formulaires de sorte que LiveCycle Forms génère les deux sous-formulaires pour chaque élément de données, ou ne génère ni l'un ni l'autre, si aucune donnée n'existe pour le sous-formulaire detail.
En regroupant des sous-formulaires dans un jeu, vous vous assurez qu'LiveCycle Forms ne génère pas les sous-formulaires du jeu à moins que des données existent pour les générer.
Pour contrôler l'ordre selon lequel LiveCycle Forms génère les sous-formulaires d'un jeu, sélectionnez l'une des options suivantes dans la liste Type de l'onglet Jeu de sous-formulaires de la palette Objet :
      •
      Utiliser tous les sous-formulaires dans l'ordre
      Tous les sous-formulaires du jeu de sous-formulaires s'afficheront dans le document final, dans l'ordre selon lequel ils figurent dans la palette Hiérarchie.
      •
      Sélectionner un sous-formulaire parmi les sous-formulaires de remplacement
      Un sous-formulaire du jeu apparaît dans le document final. Pour plus de détails, voir A propos des jeux de sous-formulaires de choix.
Lorsque vous choisissez comment générer des sous-formulaires, tenez compte des points suivants :
      •
      Si vous configurez un sous-formulaire avec une valeur d'occurrence minimale de zéro, LiveCycle Forms ne génère pas le sous-formulaire si aucune donnée n'existe pour ce sous-formulaire.
      •
      Si vous configurez un sous-formulaire avec une valeur d'occurrence minimale inférieure au nombre réel d'occurrences dans les données, les valeurs qui restent ne seront pas affichées. De même, si vous configurez un sous-formulaire avec une valeur d'occurrence maximale supérieure au nombre réel d'occurrences dans les données, LiveCycle Forms génère le nombre indiqué de sous-formulaires, ce qui signifie que certains objets du sous-formulaire sont générés sans données et apparaissent vides.
      •
      Si vous le souhaitez, vous pouvez imbriquer des jeux de sous-formulaires dans d'autres jeux de sous-formulaires, à autant de niveaux que vous le voulez. Toutefois, vous ne pouvez pas placer, à l'intérieur d'un jeu de sous-formulaires, des objets individuels comme des lignes, des cercles ou des objets de champ de texte.
Voir aussi
Pour insérer un jeu de sous-formulaires
A propos des jeux de sous-formulaires de choix
Propriétés d'un jeu de sous-formulaires dans l’onglet Jeu de sous-formulaires
Propriétés du jeu de sous-formulaires sous l'onglet Pagination
Propriétés du jeu de sous-formulaires dans le panneau Liaison


Pour insérer un jeu de sous-formulaires

Un jeu de sous-formulaires compte deux sous-formulaires ou plus à garder ensemble. Vous pouvez utiliser ces jeux pour combiner des sous-formulaires et déterminer l’ordre selon lequel LiveCycle Forms les génère.
Avant de créer un jeu de sous-formulaires, il est recommandé de considérer l'ordre selon lequel vous voulez que LiveCycle Forms génère le formulaire, de façon à vous permettre de choisir l'option adéquate dans la liste Type de l'onglet Sous-formulaire.
1.
A l'aide du bouton droit de la souris, cliquez dans la palette Hiérarchie, puis choisissez Insérer un jeu de sous-formulaires. Un jeu de sous-formulaires sans titre est ajouté à la palette Hiérarchie.
2.
Dans la palette Hiérarchie, faites glisser les sous-formulaires souhaités dans le jeu de sous-formulaires.
3.
Une fois le jeu de sous-formulaires sélectionné dans la palette Hiérarchie, cliquez sur l'onglet Jeu de sous-formulaires de la palette Objet, puis sélectionnez l'option de votre choix dans la liste Type.
4.
Cliquez sur l'onglet Liaison. Si vous le souhaitez, indiquez le nom du jeu de sous-formulaires dans la zone Nom.
5.
Si vous voulez que le jeu de sous-formulaires se répète selon les données fournies, activez l'option Répéter le sous-formulaire pour chacun des éléments de données, puis, au besoin, indiquez un nombre minimal et maximal.
6.
Visualisez la conception de formulaire pour tester le jeu de sous-formulaires.
Voir aussi
Aperçu des jeux de sous-formulaires
A propos des jeux de sous-formulaires de choix


Création de formulaires multipages qui se répètent

Pour créer un sous-formulaire qui se répète
Pour définir un sous-formulaire qui s'étend sur plusieurs pages
A propos des débuts et fins de débordement
Pour créer et affecter des débuts de débordement et des fins de débordement
Pour gérer des sauts de sous-formulaires et de jeux de sous-formulaires à l'aide d'instructions conditionnelles


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des sous-formulaires > Création de formulaires multipages qui se répètent > Pour créer un sous-formulaire qui se répète

Pour créer un sous-formulaire qui se répète

1.
Sélectionnez le sous-formulaire.
2.
Dans la palette Objet, cliquez sur l'onglet Sous-formulaire et sélectionnez Enchaînement dans la liste Contenu.
3.
Cliquez sur l'onglet Liaison et sélectionnez Sous-formulaire pour chaque élément.
l'option Sous-formulaire pour chaque élément n'est disponible que lorsque le sous-formulaire parent (tel qu'il s'affiche dans la palette Hiérarchie) est du type contenu avec enchaînement.
4.
Pour indiquer un nombre minimal de répétitions, tapez le nombre voulu dans la zone Min. de répétitions. Si cette option est réglée sur 0 et qu'aucune donnée n'est fournie pour les objets du sous-formulaire au moment de la fusion, le sous-formulaire n'est pas placé au cours du processus de génération du formulaire.
5.
Pour limiter le nombre de répétitions, sélectionnez l’option Max et tapez le nombre approprié dans la zone correspondante. Si vous n'indiquez rien dans la zone Max, le nombre de répétitions est illimité.
6.
Pour spécifier un nombre précis de répétitions, quelle que soit la quantité de données, sélectionnez l'option Quantité initiale et tapez le nombre de répétitions souhaité dans la zone associée. Si cette option est sélectionnée et s'il n'y a pas de données disponibles, ou si les données existantes sont inférieures à la valeur Quantité initiale, les occurrences vides du sous-formulaire apparaissent quand même sur le formulaire.
la valeur de la zone Quantité initiale doit être comprise entre les valeurs Min. de répétitions et Max. de répétitions. Si aucune valeur n'est indiquée dans la zone Min. de répétitions ou si elle est égale à 0, la valeur Quantité initiale est 0 par défaut.
Voir aussi
Aperçu des sous-formulaires
Propriétés de l'objet Sous-formulaire dans l’onglet Sous-formulaire
Propriétés du sous-formulaire dans le panneau Pagination
Propriétés des sous-formulaires dans le panneau Liaison
A propos des débuts et fins de débordement
Pour créer et affecter des débuts de débordement et des fins de débordement


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des sous-formulaires > Création de formulaires multipages qui se répètent > Pour définir un sous-formulaire qui s'étend sur plusieurs pages

Pour définir un sous-formulaire qui s'étend sur plusieurs pages

Les sous-formulaires peuvent être placés n'importe où dans une conception de formulaire. Toutefois, lorsqu'il y a fusion d'une grande quantité de données, le sous-formulaire peut dépasser le bord inférieur de la page rendue.
Pour régler ce problème, vous pouvez soit activer un saut de page au milieu du sous-formulaire, soit faire en sorte que le rendu de tout le sous-formulaire commence en haut de la page suivante. Le renvoi forcé d'un sous-formulaire à la page suivante permet de garantir que tous les sous-formulaires imbriqués s'affichent sur la même page.
Lorsqu'il y a fusion de données, le contenu d'un sous-formulaire est placé dans les limites des zones de contenu. S'il faut fusionner des quantités relativement importantes de données avec l'un ou l'autre des objets d'un sous-formulaire, il arrive qu'un sous-formulaire déborde sur plusieurs pages.
Lorsqu'une page est remplie, une page supplémentaire identique est générée automatiquement. Le sous-formulaire continue sur la nouvelle page, à moins que vous choisissiez explicitement de diriger l'enchaînement dans une zone de contenu ou un gabarit différent. Lorsqu'il existe plusieurs zones de contenu ou gabarits dans un même formulaire, vous pouvez indiquer si le sous-formulaire doit être placé dans une zone de contenu particulière ou disposé selon le gabarit.
      *
      Dans la palette Objet, cliquez sur l'onglet Sous-formulaire et sélectionnez l'option Autoriser des sauts de page .
Lorsque cette option est désélectionnée, les objets du sous-formulaire sont conservés ensemble sur la même page.
Voir aussi
Aperçu des sous-formulaires
Propriétés de l'objet Sous-formulaire dans l’onglet Sous-formulaire
Propriétés du sous-formulaire dans le panneau Pagination
Propriétés des sous-formulaires dans le panneau Liaison
A propos de la création de conceptions de formulaire prévues pour s'adapter aux données


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des sous-formulaires > Création de formulaires multipages qui se répètent > A propos des débuts et fins de débordement

A propos des débuts et fins de débordement

Un début de débordement est un type spécial de sous-formulaire positionné qui apparaît en haut de la page suivante dès qu'un débordement de page se produit.
Les débuts de débordement ressemblent à la rangée d'en-tête d'un tableau standard. La rangée d'en-tête s'affiche au haut du tableau et comporte un libellé qui décrit chaque colonne de celui-ci. Vous pouvez formater le tableau de telle sorte que, s'il dépasse une page, la rangée d'en-tête se répète en haut de chaque nouvelle page. Grâce à ce procédé, il est plus facile pour le lecteur de comprendre les informations du tableau lorsqu'il passe d'une page à l'autre.
Un sous-formulaire de début de débordement fonctionne sur ce principe. Lorsque vous indiquez qu'un sous-formulaire donné servira de début de débordement d'un sous-formulaire qui se répète, le sous-formulaire de début de débordement s'affichera une fois, avant que le sous-formulaire se répète, en haut de la page active et sur chaque page par la suite.
Le sous-formulaire qui se répète est ajouté aussi souvent que nécessaire au moment de la fusion de données. Lorsqu'il n'y a plus de place sur la première page, une nouvelle page est insérée et les données continuent de s'enchaîner sur la page suivante jusqu'à ce qu'elles soient épuisées. Le sous-formulaire de début de débordement s’affiche une fois en haut de chaque page.
Vous pouvez voir un cas de sous-formulaire de début de débordement utilisé dans une conception de formulaire prévue pour s'adapter à la taille des données, en consultant l’exemple inclus dans LiveCycle Designer. Cet exemple, Purchase Order.xdp, se trouve dans le dossier Samples dans lequel LiveCycle Designer est installé. Dans cet exemple, le sous-formulaire nommé detailHeader agit comme sous-formulaire de début de débordement du sous-formulaire qui se répète detail.
Les débuts de page de garde sont des sous-formulaires qui apparaissent avant un sous-formulaire qui se répète. Si vous définissez un nom apparenté de sous-formulaire au-dessus d'un sous-formulaire qui se répète , vous le spécifiez comme début de page de garde et comme début de débordement.
Une fin de débordement apparaît au bas de la page suivante dès qu'un débordement de page se produit. Utilisez une fin de débordement pour inclure des informations qui ne s'affichent qu'une fois, lorsque toutes les données ont été placées.
Les fins de page de garde sont des sous-formulaires qui apparaissent immédiatement après un sous-formulaire qui se répète. Si vous définissez un sous-formulaire immédiatement au-dessous d'un sous-formulaire qui se répète et que vous le spécifiez comme fin de débordement, vous l'avez défini comme fin de page de garde et comme fin de débordement.
Voir aussi
Aperçu des sous-formulaires
Pour créer et affecter des débuts de débordement et des fins de débordement
A propos de la création de conceptions de formulaire prévues pour s'adapter aux données
Utilisation de sous-formulaires de début et de fin de débordement


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des sous-formulaires > Création de formulaires multipages qui se répètent > Pour créer et affecter des débuts de débordement et des fins de débordement

Pour créer et affecter des débuts de débordement et des fins de débordement

Un début ou une fin de débordement est un sous-formulaire à contenu positionné qui peut être affecté à tout sous-formulaire qui se répète. Habituellement, vous créez d'abord les sous-formulaires qui serviront de début ou de fin de débordement. Ensuite, vous les affectez à un sous-formulaire qui se répète et leur attribuez des propriétés de débordement.
Si le début de débordement est également traité comme début de page de garde, il est placé dans la palette Hiérarchie, immédiatement au-dessus du sous-formulaire. De même, si la fin de débordement est également traitée comme fin de page de garde, elle est placée dans la palette Hiérarchie, immédiatement au-dessous du sous-formulaire.
Pour créer un sous-formulaire de début de débordement ou de fin de débordement
1.
Créez une conception de formulaire qui comporte tous les sous-formulaires nécessaires.
2.
Sur le modèle de formulaire, repérez le sous-formulaire que vous voulez utiliser comme début ou fin de débordement, sélectionnez le sous-formulaire et procédez comme suit :
      •
      Passez au panneau Sous-formulaire de la palette Objet. Assurez-vous que l'option Positionné est affichée dans la liste Contenu. Dans la palette Objet, cliquez sur l'onglet Sous-formulaire et assurez-vous que l'option Positionné est sélectionnée dans la liste Contenu.
      •
      Accédez au panneau Liaison de la palette Objet. Dans la palette Objet, cliquez sur l'onglet Liaison et sélectionnez l'option Sous-formulaire pour chaque élément pour afficher les débuts et les fins de débordement pour plusieurs débordements. Les débuts et fins de page de garde ne sont pas décomptés dans ce nombre.
Pour appliquer un début de débordement ou une fin de débordement à un sous-formulaire
1.
Sélectionnez les sous-formulaires à répéter.
2.
Dans la palette Objet, cliquez sur l'onglet Liaison et sélectionnez l'option Sous-formulaire pour chaque élément.
3.
Dans le panneau Pagination de la palette Objet, dans la zone Débordement, indiquez soit la zone de contenu, soit la page dans laquelle le formulaire doit placer les sous-formulaires de débordement.
4.
Pour spécifier un début de débordement, dans la liste Début de débordement, sélectionnez le sous-formulaire à utiliser pour le sous-formulaire qui se répète. Vous pouvez également sélectionner Nouveau dans la liste Début de débordement pour créer et affecter un nouveau sous-formulaire de début de débordement.
5.
Pour spécifier une fin de débordement, dans la liste Fin de débordement, sélectionnez le sous-formulaire à utiliser pour le sous-formulaire qui se répète. Vous pouvez également sélectionner Nouveau dans la liste Fin de débordement pour créer et affecter un nouveau sous-formulaire de fin de débordement.
vous n'avez pas besoin d'avoir à la fois un début de débordement et une fin de débordement. C'est vous, selon vos besoins, qui décidez si le sous-formulaire doit comporter un de ces éléments, les deux ou aucun.
Voir aussi
Aperçu des sous-formulaires
Pour créer un sous-formulaire qui se répète
A propos des débuts et fins de débordement


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des sous-formulaires > Création de formulaires multipages qui se répètent > Pour gérer des sauts de sous-formulaires et de jeux de sous-formulaires à l'aide d'instructions conditionnelles

Pour gérer des sauts de sous-formulaires et de jeux de sous-formulaires à l'aide d'instructions conditionnelles

LiveCycle Designer permet de créer des sauts conditionnels personnalisés pour les objets de sous-formulaire qui se répètent. Au lieu de laisser les ruptures s'effectuer automatiquement en fonction du flux de données, vous pouvez spécifier des sauts conditionnels afin de gérer la manière dont les sous-formulaires sont coupés sur un formulaire à l'aide d'instructions dites conditionnelles.
Ces instructions permettent de comparer les données d'un champ par rapport à des occurrences précédentes de ce champ. Le sous-formulaire qui se répète peut alors être coupé lors d'un changement des données du champ.
Sur une facture téléphonique, par exemple, vous pouvez couper un sous-formulaire en réponse à un changement du champ contenant la date de chaque entrée de facturation. Ainsi, une rupture peut s'opérer à chaque changement de date, ce qui rend la facture téléphonique plus facile à lire pour le client.
Outre la condition de saut, vous pouvez également spécifier un sous-formulaire de début ou de fin et indiquer l'endroit où placer l'occurrence suivante du sous-formulaire qui se répète sur le formulaire.
1.
Sélectionnez un sous-formulaire ou jeu de sous-formulaires.
2.
Cliquez sur l'onglet Pagination de la palette Objet.
3.
Cliquez sur Modifier, puis sur le bouton d'ajout [image] pour insérer un nouvel élément de la liste de sauts conditionnels.
4.
Sélectionnez un langage de script dans la liste Langage. L'instruction de saut conditionnelle est créée à l'aide du langage de script sélectionné.
5.
Dans la liste Exécuter sur, sélectionnez l'endroit où doit s'exécuter le saut conditionnel.
6.
Cliquez sur Insérer une expression exemple [image] et sélectionnez dans le sous-formulaire l'objet de conception de formulaire à utiliser comme champ de comparaison pour le saut conditionnel. Vous pouvez également saisir votre propre expression dans le champ. Toutefois, les instructions conditionnelles définies par l'utilisateur doivent retourner la valeur true ou false pour pouvoir correctement évaluer un saut conditionnel. Les expressions conditionnelles dont la valeur est true sont exécutées.
7.
Utilisez l'une des options suivantes pour indiquer à quel moment le saut doit se produire :
      •
      Sélectionnez Avant pour insérer un saut juste avant l'instance actuelle du sous-formulaire insérée dans le formulaire.
      •
      Sélectionnez Après pour insérer un saut juste après l'instance actuelle du sous-formulaire insérée dans le formulaire.
8.
Dans le champ A, sélectionnez à quel endroit placer les occurrences restantes du sous-formulaire.
9.
Si besoin est, sélectionnez les sous-formulaires de fin et de début à utiliser pour le saut conditionnel, respectivement dans les listes Caractère de fin et Caractère de début.
10.
Répétez les étapes 2 à 8 pour chaque saut conditionnel à inclure pour le sous-formulaire sélectionné.
11.
Cliquez sur OK lorsque toutes les entrées ont été intégrées à la liste.
Après avoir créé toutes les entrées de saut conditionnel, vérifiez l'ordre dans lequel elles apparaissent dans la boîte de dialogue Modifier les sauts conditionnels. LiveCycle Designer traite les sauts conditionnels énumérés dans cette boîte de dialogue dans l'ordre où ils apparaissent, de haut en bas. Chaque saut conditionnel dont l'instruction conditionnelle se vérifie (true) est exécuté.
Utilisez les boutons fléchés Haut [image] et Bas [image] pour déplacer les entrées de la liste des sauts conditionnels et les placer dans le bon ordre.
Voir aussi
Boîte de dialogue Modifier les sauts conditionnels
Propriétés du sous-formulaire dans le panneau Pagination
A propos des calculs et des scripts


Utilisation des jeux de sous-formulaires de choix

A propos des jeux de sous-formulaires de choix
Pour créer des jeux de sous-formulaires de choix
Pour ajouter et supprimer des sous-formulaires dans les jeux de sous-formulaires de choix
Pour créer des liaisons de données et des instructions conditionnelles pour les jeux de sous-formulaires de choix


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des sous-formulaires > Utilisation des jeux de sous-formulaires de choix > A propos des jeux de sous-formulaires de choix

A propos des jeux de sous-formulaires de choix

Un jeu de sous-formulaires de choix est une sorte de jeu de sous-formulaires permettant de personnaliser l'affichage de certains sous-formulaires par l'intermédiaire d'instructions conditionnelles. A l'instar des jeux de sous-formulaires standard, ils sont liés aux données au travers d'une connexion, mais ils permettent un niveau de contrôle supérieur sur la manière dont les sous-formulaires du jeu sont affichés lors de l'exécution. Vous pouvez faire en sorte, par exemple, qu'un jeu de sous-formulaires de choix affiche les occurrences d'un sous-formulaire qui se répète en utilisant des couleurs particulières pour le texte selon la valeur d'un champ spécifique de ce sous-formulaire.
Voir aussi
Pour créer des jeux de sous-formulaires de choix
Pour ajouter et supprimer des sous-formulaires dans les jeux de sous-formulaires de choix
Pour créer des liaisons de données et des instructions conditionnelles pour les jeux de sous-formulaires de choix
Aperçu des jeux de sous-formulaires


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des sous-formulaires > Utilisation des jeux de sous-formulaires de choix > Pour créer des jeux de sous-formulaires de choix

Pour créer des jeux de sous-formulaires de choix

Vous pouvez créer un sous-formulaire de choix, soit à partir d'un jeu existant, soit à partir d'un objet de sous-formulaire existant.
Pour créer un jeu de sous-formulaires de choix à partir d'un jeu de sous-formulaires existant
1.
Sélectionnez un objet de jeu de sous-formulaires.
2.
Dans la palette Objet, cliquez sur l'onglet Jeu de sous-formulaires et sélectionnez l'option Sélectionner un sous-formulaire parmi les sous-formulaires de remplacement dans la liste Type.
Pour créer un jeu de sous-formulaires de choix à partir d'un objet de sous-formulaire existant
      *
      Sélectionnez un objet de sous-formulaire et choisissez Insertion > Placer dans le jeu de sous-formulaires choisi.
Voir aussi
A propos des jeux de sous-formulaires de choix
Pour ajouter et supprimer des sous-formulaires dans les jeux de sous-formulaires de choix
Pour créer des liaisons de données et des instructions conditionnelles pour les jeux de sous-formulaires de choix
Boîte de dialogue Modifier les sous-formulaires désignés par les données
Aperçu des jeux de sous-formulaires


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des sous-formulaires > Utilisation des jeux de sous-formulaires de choix > Pour ajouter et supprimer des sous-formulaires dans les jeux de sous-formulaires de choix

Pour ajouter et supprimer des sous-formulaires dans les jeux de sous-formulaires de choix

Vous pouvez ajouter des sous-formulaires à un jeu de sous-formulaires de choix, ou en supprimer, en effectuant une des opérations suivantes :
      •
      Utilisation de la boîte de dialogue Modifier les sous-formulaires désignés par les données
      •
      Modification manuelle du contenu en faisant glisser les objets de sous-formulaire vers ou à l'extérieur du jeu de sous-formulaires de choix à l'aide de la palette Hiérarchie.
la suppression d'un sous-formulaire par l'intermédiaire de la boîte de dialogue Modifier les sous-formulaires désignés par les données supprime définitivement le sous-formulaire de la conception de formulaire. Si vous souhaitez conserver le sous-formulaire, tout en le supprimant du jeu de sous-formulaires de choix, vous devez le faire glisser manuellement en dehors du jeu de sous-formulaires de choix par l'intermédiaire de la palette Hiérarchie.
Pour ajouter un sous-formulaire à un jeu de sous-formulaires de choix
1.
Sélectionnez un objet de jeu de sous-formulaires.
2.
Dans la palette Objet, cliquez sur l'onglet Jeu de sous-formulaires, puis sur Modifier les variantes.
3.
Cliquez sur le bouton Ajouter [image] pour ajouter un nouvel élément à la liste Sous-formulaires de remplacement. Vous pouvez également faire glisser et déposer des sous-formulaires dans le jeu de sous-formulaires de choix en utilisant la palette Hiérarchie.
L'ajout d'un nouveau sous-formulaire copie le sous-formulaire sélectionné. Si aucun sous-formulaire n'est sélectionné, un nouveau sous-formulaire sans nom est ajouté au jeu de sous-formulaires de choix.
4.
Utilisez les boutons fléchés Haut [image] et Bas [image] pour déplacer le nouveau sous-formulaire à l'endroit souhaité. Il est important d'organiser les entrées dans la liste Sous-formulaires de remplacement, car elles sont traitées de manière séquentielle au moment de l'exécution et la première dont l'expression s'avère vraie (true) apparaît sur le formulaire.
Pour supprimer un sous-formulaire d'un jeu de sous-formulaires de choix
1.
Sélectionnez un objet de jeu de sous-formulaires.
2.
Dans la palette Objet, cliquez sur l'onglet Jeu de sous-formulaires, puis sur Modifier les variantes.
3.
Sélectionnez une entrée dans la liste Sous-formulaires de remplacement et cliquez sur le bouton de suppression [image].
Voir aussi
A propos des jeux de sous-formulaires de choix
Pour créer des liaisons de données et des instructions conditionnelles pour les jeux de sous-formulaires de choix
Boîte de dialogue Modifier les sous-formulaires désignés par les données
Aperçu des jeux de sous-formulaires


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des conceptions de formulaire > Utilisation des sous-formulaires > Utilisation des jeux de sous-formulaires de choix > Pour créer des liaisons de données et des instructions conditionnelles pour les jeux de sous-formulaires de choix

Pour créer des liaisons de données et des instructions conditionnelles pour les jeux de sous-formulaires de choix

Après avoir créé un jeu de sous-formulaires de choix, vous pouvez créer des liaisons de données avec ou sans instructions conditionnelles pour les divers sous-formulaires du jeu. Par rapport à la simple liaison de données, l'utilisation d'instructions conditionnelles permet de mieux contrôler le moment où les sous-formulaires sont affichés dans le jeu de sous-formulaires de choix sur le formulaire.
Pour chaque sous-formulaire mentionné dans la liste Sous-formulaires de remplacement de la boîte de dialogue Modifier les sous-formulaires désignés par les données, vous pouvez spécifier un noeud de données à partir de la connexion aux données. Vous pouvez utiliser une instruction conditionnelle qui s'avèrera vraie (true) ou fausse (false) au moment de l'exécution. Seule la première entrée de la liste Sous-formulaires de remplacement qui s'avère true apparaît sur le formulaire.
en l'absence d'expression conditionnelle pour une entrée de la liste Sous-formulaires de remplacement, cette expression est considérée comme true.
1.
Sélectionnez un objet de jeu de sous-formulaires.
2.
Dans la palette Objet, cliquez sur l'onglet Jeu de sous-formulaires et assurez-vous que l'option Sélectionner un sous-formulaire parmi les sous-formulaires de remplacement est activée dans la liste Type.
3.
Cliquez sur Modifier les variantes.
4.
Choisissez comment spécifier une liaison de données à partir du jeu de sous-formulaires en effectuant l'une des actions suivantes :
      •
      Sélectionnez l'option Choisir le sous-formulaire dont le nom correspond à l'élément ou attribut de données pour lier les noeuds de données aux sous-formulaires par nom. Dans ce cas, les noms des noeuds de données associés doivent correspondre à ceux des sous-formulaires sur la conception de formulaire.
      •
      Sélectionnez l'option Choisir le sous-formulaire à l'aide de l'expression pour lier manuellement les sous-formulaires de la conception de formulaire aux noeuds de données.
5.
Dans la liste Connexion aux données, indiquez la source de données à partir de laquelle vous souhaitez lier les données.
6.
Cliquez sur le bouton Ajouter [image] pour insérer un nouveau sous-formulaire dans le jeu de sous-formulaires de choix ou sélectionnez un article de liste existant. L'ajout d'un nouveau sous-formulaire copie le sous-formulaire sélectionné. Si aucun sous-formulaire n'est sélectionné, un nouveau sous-formulaire sans nom est ajouté au jeu de sous-formulaires de choix.
7.
Dans le champ Nom, saisissez un nom pour le nouvel objet de sous-formulaire, si nécessaire. Si vous liez le sous-formulaire par élément de données ou nom d'attribut, assurez-vous que le nom du champ correspond exactement à celui du noeud de données associé.
Si vous avez sélectionné l'option Choisir le sous-formulaire dont le nom correspond à l'élément ou attribut de données à l'étape 4, vous pouvez passer directement à l'étape 11. Sinon, passez à l'étape 8.
8.
Cliquez sur le triangle à droite du champ Liaison et sélectionnez un noeud de données à l'aide du menu. LiveCycle Designer remplit automatiquement le champ Liaison avec un script faisant référence au noeud de données sélectionné. Vous pouvez également taper manuellement une référence dans le champ.
9.
Sélectionnez un langage de script dans la liste Langage.
10.
Dans le champ Expression, entrez le script permettant d'effectuer les actions désirées ou le traitement à appliquer au sous-formulaire et au noeud de données spécifiés.
11.
Répétez les étapes 6 à 10 pour les autres sous-formulaires, le cas échéant.
12.
Cliquez sur OK lorsque toutes les entrées ont été intégrées à la liste.
Voir aussi
A propos des jeux de sous-formulaires de choix
Référence aux propriétés et aux valeurs d'objet
Pour créer des jeux de sous-formulaires de choix
Boîte de dialogue Modifier les sous-formulaires désignés par les données


Création et gestion des modèles

A propos des modèles et du Gestionnaire de modèles
Pour créer un modèle
Pour ajouter un modèle au Gestionnaire de modèles
Pour importer un modèle
Pour créer et personnaliser un formulaire à partir d’un modèle
Pour supprimer un modèle dans le Gestionnaire de modèles
Pour renommer un modèle dans le Gestionnaire de modèles
Pour définir un modèle par défaut dans le Gestionnaire de modèles
Pour restaurer les modèles par défaut dans le Gestionnaire de modèles
Pour ajouter un panneau au Gestionnaire de modèles
Pour supprimer un panneau du Gestionnaire de modèles
Pour déplacer un modèle dans un autre panneau du Gestionnaire de modèles
Pour déterminer l'emplacement de stockage des fichiers
Pour personnaliser la vue dans le Gestionnaire de modèles


A propos des modèles et du Gestionnaire de modèles

Un modèle fournit la structure de base de la conception de formulaire et contient des informations de création de fichier prédéfinies que LiveCycle Designer applique à la conception de formulaire. Les modèles contiennent les définitions des objets utilisés dans une conception de formulaire ainsi que les attributs de mise en page. Un modèle permet de stocker les propriétés destinées à plusieurs conceptions de formulaire, notamment :
      •
      les mises en forme de gabarits, qui ont un impact sur le format des pages ;
      •
      les objets standard, y compris les en-têtes et les pieds de page formatés ;
      •
      les images ou objets incorporés qui assurent la liaison avec les objets graphiques courants tels que les logos ou les filigranes ;
      •
      les variables de texte ou champs flottants utilisés comme balises d'emplacement pour les données ;
      •
      les équations de formule prédéfinies et fragments de script ;
      •
      les propriétés de fichier et informations sur la création du fichier ;
      •
      d'autres propriétés visant à faciliter ou à automatiser votre travail.
La création d'un modèle s'apparente à celle d'une conception de formulaire. Cependant, dans un modèle, vous définissez la disposition et sélectionnez les paramètres et préférences de fichier dont vous avez, en principe, besoin dans plus d'une conception de formulaire. Vous pouvez également, si vous le souhaitez, inclure et définir des objets que vous appliquerez à plusieurs conceptions de formulaire. L'intégration des mises en forme et des propriétés communes à de nombreuses conceptions de formulaire permet de gagner du temps, car la préparation des conceptions créées à partir de ce modèle nécessite moins de travail.
Le Gestionnaire de modèles propose une grande variété d'exemples de modèles fournis avec LiveCycle Designer. Il peut également contenir les modèles que vous créez et utilisez avec LiveCycle Designer.
Servez-vous du Gestionnaire de modèles pour effectuer les tâches suivantes :
      •
      Obtenir un aperçu des modèles
      •
      Sélectionner un modèle par défaut pour créer des conceptions de formulaire
      •
      Ajouter, supprimer et renommer des modèles, mais aussi ajouter et supprimer des groupes
Le Gestionnaire de modèles permet également d'ajouter ou de supprimer des onglets, de déplacer des modèles entre les panneaux et de déterminer l'emplacement des modèles enregistrés dans le système de fichiers parLiveCycle Designer. Chaque panneau correspond à un dossier dans le système de fichiers. Par défaut, les fichiers modèle sont enregistrés dans le dossier Templates de LiveCycle Designer.
Voir aussi
A propos des formulaires et des conceptions de formulaire
Pour créer une conception de formulaire basée sur un modèle, un exemple ou un formulaire existant


Pour créer un modèle

L'un des moyens les plus faciles de créer un fichier modèle (TDS) est de procéder à partir de l'assistant de création de formulaires. Il vous guide tout au long des étapes qui vous permettent de prévisualiser et de sélectionner le modèle à utiliser, de saisir les coordonnées d'un contact et d'ajouter des boutons Envoyer par messagerie et Imprimer, par exemple. Si vous préférez ne pas utiliser l'assistant de création de formulaires, choisissez Outils > Gestionnaire de modèles pour ouvrir la boîte de dialogue à partir de laquelle vous pouvez sélectionner directement le modèle voulu.
1.
Ouvrez l'assistant de création de formulaires à l'aide de l'une des méthodes suivantes :
      •
      Choisissez Fichier > Nouveau.
      •
      Dans la barre d'outils, cliquez sur la flèche vers le bas au regard du bouton Nouveau et choisissez Nouveau.
2.
Dans l'assistant de création de formulaires, sélectionnez Utiliser un modèle et cliquez sur Suivant.
3.
Suivez les instructions à l'écran pour personnaliser le modèle en fonction de vos besoins.
4.
Choisissez Fichier > Enregistrer sous.
5.
Dans la liste Type, sélectionnez Modèle Adobe LiveCycle Designer (*.tds).
6.
Cliquez sur Enregistrer.
Voir aussi
Pour créer une conception de formulaire basée sur un modèle, un exemple ou un formulaire existant


Pour ajouter un modèle au Gestionnaire de modèles

1.
Choisissez Outils > Gestionnaire de modèles.
2.
Cliquez sur l'onglet dans lequel vous souhaitez ajouter un modèle.
3.
Dans le menu de la palette, choisissez Ajouter un modèle.
4.
Accédez au dossier qui vous intéresse, sélectionnez le fichier modèle (TDS) à ajouter et cliquez sur Ouvrir. Une copie du modèle est ajoutée au Gestionnaire de modèles.


Pour importer un modèle

Vous pouvez importer n'importe quel fichier modèle (TDS) dans LiveCycle Designer et copier le modèle dans le Gestionnaire de modèles, définir une nouvelle conception de formulaire basée sur ce modèle ou apporter les modifications voulues au modèle.
Lors de l'importation, une copie du modèle est automatiquement ajoutée au dossier des modèles indiqué dans le code source XML du formulaire ou dans le dossier Other, si aucun emplacement n'est spécifié. Le modèle importé est désormais répertorié dans le panneau correspondant du Gestionnaire de modèles. S'il existe déjà un modèle portant le même nom dans le panneau, LiveCycle Designer vous invite à remplacer le fichier existant.
1.
Ouvrez le fichier modèle à importer à l'aide de l'une des méthodes suivantes :
      •
      Choisissez Fichier > Ouvrir, accédez au dossier voulu, sélectionnez le fichier modèle (TDS) et cliquez sur Ouvrir.
      •
      Dans l'Explorateur Windows, cliquez deux fois sur le fichier modèle (TDS).
      •
      Faites glisser le fichier modèle (TDS) de l'Explorateur Windows vers l'espace de travail de LiveCycle Designer.
2.
Dans la boîte de dialogue Options de modèle, sélectionnez l'une des options suivantes :
      •
      Pour ajouter le modèle au Gestionnaire de modèles, sélectionnez Copier ce modèle dans le Gestionnaire de modèles.
      •
      Pour créer un formulaire PDF basé sur le modèle, sélectionnez Créer un formulaire basé sur ce modèle.
      •
      Pour ouvrir le modèle dans LiveCycle Designer en vue de le modifier, sélectionnez Modifier ce modèle.
3.
Cliquez sur OK.


Pour créer et personnaliser un formulaire à partir d’un modèle

Les fichiers modèle (TDS) contiennent quelquefois du texte ou des images personnalisables au sein des légendes de champs, des objets de texte statiques et des images statiques. Lorsque vous créez un formulaire basé sur un modèle contenant des champs avec du texte ou des images personnalisables, l'assistant de création de formulaires vous invite à changer les informations affichées dans chaque champ en fonction de vos besoins. Les exemples de modèles proposés dans le Gestionnaire de modèles contiennent, par exemple, du texte ou des images personnalisables que vous pouvez remplacer par le nom, l'adresse, le numéro de téléphone ou le logo de votre entreprise.
Les informations que vous définissez pour chaque champ seront enregistrées et réutilisées pour compléter les mêmes champs dans l'assistant de création de formulaires la prochaine fois que vous ouvrirez le modèle.
1.
Ouvrez l'assistant de création de formulaires à l'aide de l'une des méthodes suivantes :
      •
      Choisissez Fichier > Nouveau.
      •
      Dans la barre d'outils, cliquez sur la flèche vers le bas au regard du bouton Nouveau et choisissez Nouveau.
2.
Dans l'assistant de création de formulaires, sélectionnez Utiliser un modèle et cliquez sur Suivant.
3.
Suivez les instructions à l'écran pour personnaliser le nouveau modèle en fonction de vos besoins.
4.
Donnez un nom au fichier et enregistrez-le.


Pour supprimer un modèle dans le Gestionnaire de modèles

1.
Choisissez Outils > Gestionnaire de modèles.
2.
Cliquez sur l'onglet où figure le modèle.
3.
Cliquez sur le modèle avec le bouton droit de la souris et choisissez Supprimer le modèle.
4.
Lorsque vous êtes invité à supprimer le modèle, cliquez sur Oui. Le fichier est alors supprimé du système de fichiers de votre ordinateur.


Pour renommer un modèle dans le Gestionnaire de modèles

1.
Choisissez Outils > Gestionnaire de modèles.
2.
Cliquez sur l'onglet où figure le modèle.
3.
Cliquez sur le modèle avec le bouton droit de la souris et choisissez Renommer le modèle.
4.
Tapez un nom différent pour le modèle, puis appuyez sur Entrée.


Pour définir un modèle par défaut dans le Gestionnaire de modèles

1.
Choisissez Outils > Gestionnaire de modèles.
2.
Cliquez sur l'onglet où figure le modèle.
3.
Sélectionner le modèle.
4.
Cliquez sur le bouton Définir par défaut.


Pour restaurer les modèles par défaut dans le Gestionnaire de modèles

Vous avez la possibilité de rétablir les modèles par défaut disponibles dans le panneau des formulaires vides et dans le panneau des formulaires courants de la boîte de dialogue Gestionnaire de modèles.
lorsque vous restaurez les modèles, tous ceux qui sont fournis par LiveCycle Designer dans le panneau des formulaires vides et des formulaires courants sont restaurés. LiveCycle Designer remplace les modèles manquants et écrase tous ceux dont les noms sont identiques aux modèles d'origine.
1.
Choisissez Outils > Gestionnaire de modèles.
2.
Cliquez sur l'onglet qui vous intéresse.
3.
Dans le menu de la palette, choisissez Restaurer les modèles par défaut.


Pour ajouter un panneau au Gestionnaire de modèles

Lorsque vous ajoutez un panneau au Gestionnaire de modèles, un sous-formulaire portant le même nom est créé dans le dossier des modèles de LiveCycle Designer.
1.
Choisissez Outils > Gestionnaire de modèles.
2.
Dans le menu de la palette, choisissez Ajouter une catégorie.
3.
Saisissez le nom du panneau, puis cliquez sur OK.


Pour supprimer un panneau du Gestionnaire de modèles

Lorsque vous supprimez un panneau dans le Gestionnaire de modèles, le dossier correspondant est automatiquement supprimé du dossier des modèles de LiveCycle Designer.
1.
Choisissez Outils > Gestionnaire de modèles.
2.
Sélectionnez le panneau à supprimer.
3.
Dans le menu de la palette, choisissez Retirer la catégorie de modèles.
4.
Lorsque vous êtes invité à supprimer le panneau, effectuez l'une des actions suivantes :
      •
      Pour supprimer le panneau sélectionné et le dossier de catégorie et les modèles correspondants, sélectionnez Retirer la catégorie et supprimer tous les modèles qu'elle contient.
      •
      Pour transférer les modèles dans un autre panneau avant de supprimer le panneau sélectionné et le dossier de catégorie correspondant, sélectionnez Retirer la catégorie et déplacer les modèles qu'elle contient dans la catégorie suivante : [nom du panneau], puis cliquez sur l'onglet de destination.
5.
Cliquez sur OK.


Pour déplacer un modèle dans un autre panneau du Gestionnaire de modèles

1.
Choisissez Outils > Gestionnaire de modèles.
2.
Cliquez sur l'onglet qui vous intéresse, cliquez sur le modèle à déplacer avec le bouton droit de la souris et choisissez Déplacer le modèle vers > [nom du panneau].


Pour déterminer l'emplacement de stockage des fichiers

1.
Choisissez Outils > Gestionnaire de modèles.
2.
Cliquez sur l'onglet voulu.
3.
Dans le menu de la palette, choisissez Propriétés de la catégorie. La boîte de dialogue Propriétés de la catégorie de modèles affiche l'emplacement des modèles actuellement répertoriés dans le panneau sélectionné.


Pour personnaliser la vue dans le Gestionnaire de modèles

1.
Choisissez Outils > Gestionnaire de modèles.
2.
Cliquez sur l'onglet voulu.
3.
Dans le menu de la palette, choisissez Afficher et effectuez l'une des actions suivantes :
      •
      Pour afficher les noms des modèles sous forme d'icônes, sélectionnez Grandes icônes.
      •
      Pour afficher les noms des modèles dans une liste, sélectionnez Liste.


Utilisation des objets

A propos des objets
Utilisation d'objets
Ajout, copie et suppression d'objets
Sélection, regroupement et déplacement d'objets
Alignement et redimensionnement d'objets
Formatage des objets
Utilisation de collections d'objets de formulaire
Méthodes pour rendre des objets visibles ou invisibles ou les masquer
Formatage des légendes
Formatage des valeurs de champ
Configuration d'un objet pour d'autres langues
Utilisation d'objets spéciaux


A propos des objets

Qu'est-ce-qu'un objet ?
Catégories d'objets
Pour changer un type d'objet
Pour donner un nom aux objets ou changer leur nom
Pour définir le style de la bordure
Pour définir un paramètre régional (langue et pays) pour un objet
Objets prenant en charge des fonctions de script et de calcul


Qu'est-ce-qu'un objet ?

Les objets constituent les blocs fonctionnels d'un formulaire. Chaque objet représente un élément fonctionnel du formulaire, comme une zone de saisie de texte ou un bouton pour l'envoi du formulaire par messagerie électronique. A mesure que votre formulaire prend forme, les objets s sélectionnés viennent s'ajouter aux pages et au gabarit de la conception de formulaire. Vous trouverez tous les objets disponibles dans la palette Bibliothèque.
Les objets de la palette Bibliothèque sont regroupés en catégorie. La catégorie Favoris contient les objets que vous utilisez le plus souvent. Les catégories Standard et Codes à barres contiennent les objets de base, tandis qu'un certain nombre d'objets personnalisés prédéfinis sont disponibles dans la catégorie Personnalisés.


Catégories d'objets

La plupart des objets appartiennent à deux catégories principales :
Objets standard ou statiques
Les objets statiques ne capturent pas ou n'affichent pas de données. Ils présentent du texte fixe ou des informations graphiques. Il s'agit des cercles, des lignes, des rectangles, des images et du texte. Les objets statiques peuvent être insérés dans tous les types de formulaire.
Objets de champ
Les objets de champ capturent et affichent des données. Il s'agit des codes à barres, des boutons, des cases à cocher, des champs de date/heure, des listes déroulantes, des champs d'image, des zones de liste, des champs de mot de passe et de signature du document, des boutons radio et des champs de texte. Certains objets de champ, tels que les champs de texte, conviennent à tous les types de formulaire (interactif, à faire remplir par l'utilisateur ou à compléter par fusion d'une source de données). D'autres objets, notamment les listes déroulantes, sont réservés aux formulaires interactifs.
Les objets suivants sont disponibles dans les catégories Standard et Codes à barres de la palette Bibliothèque.

Objet

Description

Catégorie

Utilisation

Pour plus de détails
Bouton
Bouton permettant l'exécution d'une commande ou d'une requête client.
Champ
Conçu pour les formulaires interactifs.
Aperçu des boutons
Bouton Envoyer par messagerie
Bouton qui permet aux utilisateurs d'un formulaire de transmettre des données de formulaire à une adresse électronique spécifique.
Champ
Conçu pour les formulaires interactifs.
Aperçu du bouton Envoyer par messagerie
Bouton Envoyer via HTTP
Bouton qui permet aux utilisateurs d'un formulaire de transmettre des données de formulaire via le protocole HTTP à une URL spécifique.
Champ
Conçu pour les formulaires interactifs.
Aperçu du bouton Envoyer via HTTP
Bouton Imprimer
Bouton configuré pour permettre aux utilisateurs d'un formulaire de l'imprimer.
Champ
Conçu pour les formulaires interactifs.
Aperçu du bouton Imprimer
Bouton radio
Objet représentant un choix unique parmi une liste d'options mutuellement exclusives.
Champ
Adapté à tous les types de formulaire.
Aperçu des boutons radio
Bouton Réinitialiser
Bouton qui permet aux utilisateurs d'un formulaire de rétablir les valeurs par défaut du contenu de ses champs.
Champ
Conçu pour les formulaires interactifs.
Aperçu du bouton Réinitialiser
Case à cocher
Objet pouvant être activé (état actif) ou désactivé (état inactif).
Champ
Adapté à tous les types de formulaire.
A propos des cases à cocher
Cercle
Cercle, ellipse ou arc.
Static
Adapté à tous les types de formulaire.
Aperçu des cercles, des lignes et des rectangles
Champ de signature du document
Contrôle permettant aux utilisateurs de joindre une signature électronique à un formulaire.
Champ
Adapté à tous les types de formulaire.
Aperçu des champs de signature de document
Champ de texte
Champ qui valide et affiche des données texte dont il reconnaît le format.
Champ
Adapté à tous les types de formulaire.
Aperçu des champs de texte
Champ décimal
Champ qui valide et affiche des données décimales dont il reconnaît le format.
Champ
Adapté à tous les types de formulaire.
Aperçu des champs de valeurs décimales et numériques
Champ d'image
Balise d'emplacement permettant le chargement dynamique d'une image dans un formulaire.
Champ
Adapté à tous les types de formulaire.
Aperçu des champs d'image
Champ du mot de passe
Champ qui valide et masque l'affichage des mots de passe alphanumériques.
Champ
Adapté à tous les types de formulaire.
Aperçu des champs de mot de passe
Champ numérique
Champ qui valide et affiche des données numériques dont il reconnaît le format.
Champ
Adapté à tous les types de formulaire.
Aperçu des champs numériques
Code à barres
Symbole d'identification d'un code à barres.
Static
Adapté à tous les types de formulaire.
Aperçu des codes à barres
Code à barres de formulaires pour support papier
Code à barres bidimensionnel qui code les données saisies par l'utilisateur dans un formulaire interactif. Pour utiliser l'objet de code à barres de formulaires pour support papier, votre entreprise doit avoir mis en place la solution LiveCycle Barcoded Forms.
Champ
Conçu pour les formulaires interactifs.
Aperçu des codes à barres de formulaires pour support papier
Date/Heure
Champ qui valide et affiche des données de date et d'heure dont il reconnaît le format.
Champ
Adapté à tous les types de formulaire.
Aperçu des champs de date et d'heure
Image
Objet représentant une image, telle qu'un logo ou une icône.
Static
Adapté à tous les types de formulaire.
Aperçu des images
Lignes
Ligne pleine, à tirets ou en pointillés.
Static
Adapté à tous les types de formulaire.
Aperçu des cercles, des lignes et des rectangles
Liste déroulante
Liste d'options permettant de sélectionner une seule option. Une seule option s'affiche à la fois.
Champ
Conçu pour les formulaires interactifs.
Aperçu des listes déroulantes et des zones de liste
Rectangle
Rectangle à coins réguliers, inversés ou arrondis.
Static
Adapté à tous les types de formulaire.
Aperçu des cercles, des lignes et des rectangles
Sous-formulaire
Conteneur qui gère le positionnement des objets. Chaque page constitue un sous-formulaire et peut être composée de plusieurs sous-formulaires.
Static
Adapté à tous les types de formulaire.
Aperçu des sous-formulaires
Tableau
Conteneur constitué de rangées et de colonnes de cellules qui peuvent contenir des champs de formulaire ou dans lesquelles vous pouvez fusionner des données.
Il peut s'agir d'un objet statique ou d'un objet de champ
Adapté à tous les types de formulaire.
A propos des tableaux
Texte
Texte en lecture seule.
Static
Adapté à tous les types de formulaire.
Aperçu du texte
Zone de contenu
Conteneur représentant l'objet principal d'une hiérarchie d'objets et définissant la zone d'un formulaire susceptible de comporter des objets.
Static
Chaque gabarit définit au moins une zone de contenu.
Aperçu des zones de contenu
Zone de liste
Liste d'options permettant de sélectionner une seule option. Plusieurs options s'affichent à la fois.
Champ
Conçu pour les formulaires interactifs.
Aperçu des listes déroulantes et des zones de liste
Voir aussi
A propos des objets personnalisés
Pour créer un objet personnalisé


Pour changer un type d'objet

Il y a plusieurs façons de changer le type d'objet :
      •
      Supprimez l'objet sur votre conception de formulaire, puis faites glisser l'objet requis à partir de la palette Bibliothèque
      •
      Servez-vous de la liste Type dans le panneau Champ de la palette Objet (pour les objets de champ tels que les champs de texte, les champs numériques et les boutons)
      •
      Utilisez la liste de l'éditeur de champs (pour les objets de champ tels que les champs de texte, les champs numériques et les boutons)
      •
      Servez-vous de la liste Type dans le panneau Dessin de la palette Objet (pour les objets statiques tels que les cercles, les lignes et le texte)
Pour changer de type d'objet à partir de la liste Type dans les panneaux de la palette Objet
1.
Sélectionnez l'objet dont vous avez l'intention de changer.
2.
Dans la palette Objet, cliquez sur l'onglet Champ ou Dessin et choisissez un autre type d'objet dans la liste Type.
Pour changer de type d'objet à partir de la liste Type dans l'éditeur de champs
1.
Sélectionnez l'objet dont vous avez l'intention de changer. Si l'éditeur de champs n'apparaît pas autour de l'objet, choisissez Affichage > Editeur de champs.
2.
Sélectionnez un autre type d'objet dans la liste Type.


Pour donner un nom aux objets ou changer leur nom

Lorsque vous faites glisser un objet de la palette Objet dans votre conception de formulaire, son nom par défaut est celui de l'objet, suivi d’un numéro qui représente le nombre de copies de cet objet dans la conception. Par exemple, si votre conception de formulaire comporte deux objets de zone de liste, les noms par défaut sont Liste1 et Liste2. Ce type d'appellation correspond au numéro d'occurrence.
Lors de la création de la conception de formulaire, vous pouvez voir le nom de l'objet aux endroits suivants :
      •
      Hiérarchie, palette
      •
      Panneau Liaison de la palette Objet
      •
      Editeur de champs
      •
      Info-bulle sur la conception de formulaire lorsque vous maintenez le pointeur au-dessus de l'objet
Il est possible de nommer ou de renommer un objet par le biais de la palette Hiérarchie, du panneau Liaison de la palette Objet ou de l'éditeur de champs.
si vous prévoyez de créer des calculs ou des scripts pour améliorer votre formulaire, évitez d'utiliser les noms correspondant à des propriétés de script, à des méthodes et à des objets. Sinon, les calculs et les scripts risquent de ne pas s'exécuter correctement.
Pour nommer ou renommer un objet par le biais de la palette Hiérarchie
1.
Dans la palette Hiérarchie, cliquez avec le bouton droit de la souris sur l'objet et choisissez Renommer l'objet.
2.
Tapez le nouveau nom et appuyez sur Entrée.
Pour nommer ou renommer un objet par le biais du panneau Liaison de la palette Objet
1.
Sélectionnez l'objet.
2.
Dans la palette Objet, cliquez sur l'onglet Liaison.
3.
Dans la zone Nom, entrez le nouveau nom de l'objet et appuyez sur Entrée.
Pour nommer ou renommer un objet par le biais de l'éditeur de champs
1.
Sélectionnez l'objet. Si l'éditeur de champs n'apparaît pas, choisissez Affichage > Editeur de champs.
2.
Dans la zone Nom, entrez le nouveau nom de l'objet et appuyez sur Entrée.


Pour définir le style de la bordure

      •
      Pour définir le style de la bordure d'un objet, cliquez sur l'onglet Champ dans la palette Objet et sélectionnez un style de bordure dans la liste Aspect.
      •
      Pour personnaliser l'aspect d'un objet, sélectionnez Personnaliser dans la liste Aspect.
      •
      Pour définir une bordure pour tout l'objet, utilisez la palette Bordure
Voir aussi
Propriétés de la palette Bordure


Pour définir un paramètre régional (langue et pays) pour un objet

1.
Cliquez sur l'onglet Champ de la palette Objet.
2.
Dans la zone de liste Paramètre régional, sélectionnez l'une des options suivantes ou l'un des paramètres régionaux suggérés :
      •
      Pour appliquer le paramètre régional par défaut défini dans le panneau Valeurs par défaut de la boîte de dialogue Propriétés du formulaire, sélectionnez Paramètre régional par défaut.
      •
      Pour utiliser le paramètre régional système de l'ordinateur de l'utilisateur, choisissez Paramètre régional du système de visualisation.
lors de la conception et de l'exécution, les valeurs formatées dans le champ sont tributaires du format du paramètre régional.


Objets prenant en charge des fonctions de script et de calcul

Les objets qui valident les données peuvent être associés à des expressions FormCalc ou JavaScript. Par exemple, vous pouvez utiliser un script pour calculer une valeur ou valider les données entrées par l'utilisateur. Dans la plupart des cas, les attributs d'un objet permettent de contrôler la validité des données. S'il s'agit d'objets nécessitant un format de saisie (édition) complexe, la validité est contrôlée par les paramètres définis dans le panneau Valeur de la palette Objet.
Certains objets permettent de lancer des requêtes client. Par exemple, vous pouvez définir un bouton afin d'interroger une source de données au moment de l'exécution. Dans un tel cas, vous devez également écrire un script pour consigner la valeur recherchée dans un champ spécifique du formulaire.
Vous pouvez écrire des scripts qui exécutent des commandes et des fonctions ou effectuent des calculs lorsque des événements relatifs à un objet surviennent à l'exécution. Par exemple, un événement se produit pendant l'exécution lorsque l'utilisateur effectue l'action spécifiée par cet événement. Vous pouvez appeler n'importe quelle méthode prise en charge par un objet, puis définir un script afin d'afficher ou de configurer les propriétés.
Certains objets, tels que les cercles et les zones de contenu, ne prennent pas en charge les événements. Les objets qui prennent en charge les fonctions de script et de calcul ou qui déclenchent des événements sont les codes à barres, les boutons, les cases à cocher, les champs de date/heure, les listes déroulantes, les champs d'image, les zones de liste, les champs numériques, les champs de mot de passe, les boutons radio, les champs de signature du document, les sous-formulaires et les champs de texte. Les événements gérés sont propres à un objet et varient d'un objet à l'autre.
Voir aussi
Aperçu de la création de calculs et de scripts


Utilisation d'objets

Utilisation des codes à barres
Utilisation des boutons
Utilisation des cases à cocher
Utilisation de cercles, de lignes et de rectangles
Utilisation de zones de contenu
Utilisation des champs de date et d'heure
Utilisation de champs de valeurs décimales et numériques
Utilisation des listes déroulantes et des zones de liste
Utilisation des champs d'image
Utilisation d'images
Utilisation des codes à barres de formulaires pour support papier
Utilisation des champs de mot de passe
Utilisation de boutons radio
Utilisation de champs de signature de document
Utilisation de texte
Utilisation des champs de texte
Utilisation d'objets personnalisés


Utilisation des codes à barres

Aperçu des codes à barres
Pour définir les propriétés d'un champ de code à barres
Pour définir la valeur par défaut d'un code à barres
Pour définir le mode de fonctionnement d'un code à barres
Pour définir les propriétés de liaison personnalisée d'un code à barres


Aperçu des codes à barres

L'utilisation des codes à barres est largement répandue dans les entreprises, notamment pour assurer le contrôle des stocks. Les codes à barres servent à identifier les formulaires, mais ils sont souvent imprimés sur du papier adhésif pour créer des étiquettes utilisées à des fins d'inventaire.
LiveCycle Designer prend en charge deux types de codes à barres :
    • Codes à barres matériels
Ils s'utilisent uniquement lorsque le formulaire est imprimé directement à partir du serveur. Du fait qu'une imprimante est requise pour les imprimer, LiveCycle Designer utilise une balise d'emplacement pour représenter les codes à barres matériels dans le formulaire.
    • Codes à barres logiciels
Ils peuvent être créés dans LiveCycle Designer et sont visibles dans Acrobat et Adobe Reader. Vous pouvez les reproduire sur tout type d'imprimante générique.
LiveCycle Designer propose un large éventail de formats de codes à barres. La catégorie Codes à barres de la palette Bibliothèque dresse la liste de tous les formats de codes à barres pris en charge. Si vous utilisez un code à barres qui exige l'utilisation d'un type précis d'imprimante, LiveCycle Designer représente ce code à barres par un rectangle avec un effet d'ombrage dans le formulaire.
LiveCycle Designer reconnaît également les codes à barres bidimensionnels de formulaires pour support papier. Pour plus de détails, voir Aperçu des codes à barres de formulaires pour support papier.
Après avoir inséré un code à barres dans votre formulaire, définissez ses propriétés à partir des panneaux Champ, Valeur et Liaison de la palette Objet. Vous pouvez définir les propriétés suivantes :
      •
      Position du texte
      •
      Longueur des données
      •
      Toute autre propriété prise en charge par le code à barres (par exemple, des fonctions facultatives telles que la somme de contrôle, le positionnement et l'incorporation de texte)
      •
      Etat visible, invisible ou masqué du code à barres
      •
      Méthode de liaison utilisée pour le stockage et la récupération des données liées
les codes à barres interactifs qui acceptent la saisie de données sont pris en charge uniquement par les formulaires PDF remplis dans Acrobat 7.0 ou Adobe Reader 7.0.
Voir aussi
Formats de codes à barres pris en charge
Propriétés des codes à barres dans le panneau Champ
Propriétés des codes à barres dans le panneau Valeur
Propriétés des codes à barres dans le panneau Liaison


Pour définir les propriétés d'un champ de code à barres

Pour définir les propriétés d'un code à barres, vous devez d'abord sélectionner le code à barres. Définissez les caractéristiques de base dans le panneau Champ de la palette Objet. Le nombre et les types de propriétés varient d'un code à barres à l'autre.
1.
Sélectionnez le code à barres voulu.
2.
Cliquez sur l'onglet Valeur de la palette Objet. Dans la zone Valeur par défaut, tapez le texte du code à barres.
3.
Cliquez sur l'onglet Champ. Dans la zone Emplacement, sélectionnez la position du texte.
Le format PDF 417 ne prend pas en charge le positionnement de texte et les formats EAN8, EAN13 et CUP-A n'acceptent que l'option En dessous intégré.
4.
Dans la colonne Valeur, effectuez une ou plusieurs des actions suivantes :
      •
      Dans la zone Longueur des données, entrez la longueur des données. Si vous définissez un code à barres MSI, la longueur doit être comprise entre 1 et 14. Les formats de code à barres MSI, CUP-E, CUP EAN2, CUP EAN5, US Postal Zip-5, US Postal DPBC et US Postal Standard ont des longueurs de données fixes qui ne peuvent pas être modifiées.
      •
      Si l'option Somme de contrôle s'affiche, activez ou désactivez cette fonction. Si vous définissez un code à barres MSI, sélectionnez l'une des méthodes de somme de contrôle proposées.
      •
      Si l'option Caractère de fin ou Caractère de début s'affiche, tapez le caractère de fin, le caractère de début ou les deux. Si vous définissez un code à barres Codabar, les caractères de début et de fin corrects sont A, B, C, D, a, b, c, d, *, N, T, E, n, t et e. Si vous définissez un code à barres Code 49, les caractères de début corrects sont A, 1, 2, 3, 4 et 5.
      •
      Si l'option Rapport Large/étroit s'affiche, entrez une valeur de rapport large/étroit. Pour les codes à barres Codabar, Code 2 parmi 5 (industriel, entrelacé et matriciel) et Code 3 parmi 9, la valeur du rapport large/étroit doit être comprise entre 2,2 et 3. Pour les codes à barres Code 11, Logmars, MSI et Plessey, cette valeur doit être comprise entre 2 et 3.
Voir aussi
Propriétés des codes à barres dans le panneau Champ
Caractères de texte de code à barres corrects


Pour définir la valeur par défaut d'un code à barres

      *
      Cliquez sur l'onglet Valeur de la palette Objet. Saisissez une valeur par défaut dans la zone Valeur par défaut.
Voir aussi
Propriétés des codes à barres dans le panneau Champ
Caractères de texte de code à barres corrects


Pour définir le mode de fonctionnement d'un code à barres

Pour définir les propriétés d'un code à barres, vous devez d'abord sélectionner le code à barres. Configurez les propriétés qui contrôlent la façon dont le code à barres reçoit les données. Vous trouverez ces propriétés dans le panneau Valeur de la palette Objet.
vous pouvez remplir un modèle de validation ou un message de script de manière dynamique à l'aide d'une valeur issue d'une source de données. Vous serez ainsi assuré que les utilisateurs saisissent la valeur correcte dans le champ.
1.
Cliquez sur l'onglet Valeur de la palette Objet. Dans la zone Type, sélectionnez l'une des options suivantes :
      •
      Pour laisser aux utilisateurs le choix de saisir des données, choisissez Entré par l'utilisateur - Facultatif.
      •
      Pour inviter les utiliser à saisir des données et indiquer qu'il est recommandé de compléter le champ, choisissez Entré par l'utilisateur - Recommandé et entrez un message personnalisé dans la zone Message d'état vide.
      •
      Pour demander aux utilisateurs de saisir des données et indiquer qu'il est obligatoire de compléter le champ, choisissez Entré par l'utilisateur - Obligatoire et entrez un message personnalisé dans la zone Message d'état vide.
      •
      Pour configurer le champ en lecture seule et calculer et afficher la valeur de donnée par le biais d'un script joint , choisissez Calculé - Lecture seule. L'utilisateur n'est pas autorisé à modifier la valeur calculée.
      •
      Pour autoriser la modification du champ et calculer et afficher une valeur de donnée par le biais d'un script joint , choisissez Calculé - L’utilisateur peut remplacer. L'utilisateur peut changer la valeur si le script de calcul accepte les saisies. Si l'utilisateur change la valeur, le message personnalisé que vous avez défini dans la zone Message de remplacement s'affiche.
      •
      Pour configurer le champ en lecture seule et afficher une valeur de donnée résultant d'une fusion ou d'un calcul au moment de l'exécution, choisissez Lecture seule. L'utilisateur n'est pas autorisé à modifier la valeur.
2.
Si la valeur est recommandée ou obligatoire, tapez un message dans la zone Message d'état vide.
3.
Si la valeur doit être calculée, joignez le script de calcul à l'objet à l'aide de l'éditeur de script.
4.
(Facultatif) Si la valeur calculée peut être remplacée, saisissez un message dans la zone Message de remplacement.
Voir aussi
Pour remplir de façon dynamique un message de modèle de validation
Pour remplir de façon dynamique un message de script de validation
Propriétés des codes à barres dans le panneau Valeur


Pour définir les propriétés de liaison personnalisée d'un code à barres

Les options de liaison permettent de développer un formulaire qui capture les données pour les infrastructures de l'entreprise ou d'utiliser une source de données externe pour remplir le formulaire à l'exécution. Définissez les propriétés de liaison de données dans le panneau Liaison de la palette Objet.
1.
Sélectionnez le code à barres voulu.
2.
Activez le formulaire pour établir la connexion à la source de données lorsque le formulaire est ouvert.
3.
Liez le code à barres au noeud de données correspondant. Pour plus d'informations sur la liaison des objets à une source de données, voir A propos de la liaison de champs à une source de données.
Voir aussi
Propriétés des codes à barres dans le panneau Liaison


Utilisation des boutons

Aperçu des boutons
Aperçu du bouton Envoyer par messagerie
Aperçu du bouton Envoyer via HTTP
Aperçu du bouton Imprimer
Aperçu du bouton Réinitialiser
A propos de l'envoi de données au moyen d'un bouton
A propos des options de traitement d'un bouton
Pour insérer un bouton standard afin d'exécuter un calcul ou un script
Pour insérer un bouton d'envoi permettant d'envoyer des informations à un serveur
Pour insérer un bouton d'envoi qui incorpore un PDF
Pour insérer un bouton d'envoi qui transmet un flux de données XML
Pour insérer un bouton d'envoi permettant d'envoyer un flux de texte par la méthode POST
Pour insérer un bouton afin de transmettre un courrier électronique contenant des données XML
Pour exécuter une opération de service Web ou une requête dans une base de données à l'aide d'un bouton
Pour associer un script de base de données à un bouton
Utilisation d'un bouton pour remplir les champs à partir d'une base de données
Pour personnaliser le bouton Envoyer par messagerie
Pour personnaliser le bouton Envoyer via HTTP


Aperçu des boutons

Si vous voulez permettre aux utilisateurs de lancer des actions telles que l'envoi de données, l'exécution d'une opération de service Web ou l'envoi d'une requête à une base de données, vous pouvez ajouter un bouton dans le formulaire. Grâce aux fonctions intégrées de script et de communication client-serveur de LiveCycle Designer, les formulaires sont en mesure de prendre en charge les actions ci-dessous en les lançant grâce à un bouton :
      •
      Exécuter un calcul
      •
      Traiter et manipuler des données par le biais d'un script
      •
      Soumettre des données (y compris des pièces jointes) au serveur
      •
      Signer des données envoyées
      •
      Ouvrir une connexion hôte
      •
      Envoyer des requêtes client au serveur
      •
      Appeler une opération de service Web
      •
      Envoyer une requête à une source de données
L'action qui est associée au bouton est lancée dès que l'utilisateur clique sur le bouton.
Après avoir inséré un objet de bouton dans votre formulaire, vous pouvez définir le texte de sa légende et manipuler ses propriétés dans les panneaux Champ, Envoyer et Exécuter de la palette Objet. Vous pouvez définir les propriétés suivantes :
      •
      Changer la légende du bouton
      •
      Définir le style de la bordure du bouton
      •
      Définir le style de mise en surbrillance du bouton
      •
      Rendre le bouton visible ou invisible, ou le masquer
      •
      Définir le paramètre régional associé au bouton
      •
      Spécifier le comportement d'exécution
LiveCycle Designer inclut également quatre boutons préconfigurés proposant des fonctions spécifiques. Il s'agit des boutons Envoyer par messagerie, Envoyer via HTTP, Imprimer et Réinitialiser.
Voir aussi
A propos des options de traitement d'un bouton
Formatage des légendes
A propos des signatures numériques
Propriétés de la palette Disposition
Propriétés de la palette Bordure
Propriétés de la palette Police
Propriétés de la palette Paragraphe
Propriétés de l'objet Bouton dans l'onglet Champ
Propriétés des boutons dans le panneau Envoyer
Propriétés des boutons dans le panneau Exécuter


Aperçu du bouton Envoyer par messagerie

Le bouton d'envoi par messagerie est un bouton standard doté de certaines propriétés pré-configurées et d'une palette Objet particulière. Cet objet facilite la création de boutons sur lesquels l'utilisateur doit cliquer pour envoyer les données de formulaire par messagerie. Etant donné qu'Adobe Reader n'enregistre pas les modifications apportées aux fichiers PDF, y compris les données de formulaire, il est préférable d'inclure un bouton Envoyer par messagerie dans les formulaires à remplir dans Adobe Reader.
Ce type de bouton fonctionne comme un objet de bouton standard si les paramètres sont configurés de la manière suivante :
      •
      L'option Type de contrôle est définie sur Envoyer.
      •
      L'option Format d’envoi est définie sur Données XML (XML).
      •
      L'option Envoyer à l'URL est définie sur le protocole mailto, par exemple : name@adobe.com
      •
      L'option Codage est définie sur UTF-8
Si vous utilisez l'assistant de création de formulaires pour créer un formulaire et si vous sélectionnez l'un des modes de renvoi, un bouton Envoyer par messagerie est inclus automatiquement dans le formulaire.
Après avoir inséré un bouton dans votre formulaire, vous pouvez définir le texte de sa légende et manipuler ses propriétés dans le panneau Champ de la palette Objet. Vous pouvez définir les propriétés suivantes :
      •
      Changer la légende du bouton
      •
      Définir le style de la bordure du bouton
      •
      Définir le style de mise en surbrillance du bouton
      •
      Définir l'adresse dans le champ Adresse électronique et l'objet dans le champ Objet du message
      •
      Ajouter une signature de données
      •
      Rendre le bouton visible ou invisible, ou le masquer
      •
      Définir le paramètre régional associé au bouton
Vous pouvez également modifier le nom du bouton dans la palette Hiérarchie et définir le style de la légende dans les palettes Police et Paragraphe.
Voir aussi
A propos des signatures numériques
Pour ajouter une signature de données à un bouton d'envoi
Propriétés de la palette Disposition
Propriétés de la palette Bordure
Propriétés de la palette Police
Propriétés de la palette Paragraphe
Propriétés des boutons Envoyer par messagerie dans le panneau Champ


Aperçu du bouton Envoyer via HTTP

Le bouton d'envoi via HTTP est un bouton standard doté de certaines propriétés pré-configurées et d'une palette Objet particulière. Cet objet facilite la création de boutons sur lesquels l'utilisateur doit cliquer pour envoyer les données de formulaire via HTTP.
Ce type de bouton fonctionne comme un objet de bouton standard s'il est défini sur les paramètres suivants :
      •
      L'option Type de contrôle est définie sur Envoyer.
      •
      L'option Format d’envoi est définie sur Données codées dans URL (HTTP Post).
      •
      L'option Envoyer à l'URL est définie sur le protocole mailto:.
Si les données doivent être renvoyées par protocole https: sécurisé, utilisez plutôt un bouton standard.
Après avoir inséré un bouton dans votre formulaire, vous pouvez définir le texte de sa légende et manipuler ses propriétés dans le panneau Champ de la palette Objet. Vous pouvez définir les propriétés suivantes :
      •
      Changer la légende du bouton
      •
      Définir le style de la bordure du bouton
      •
      Définir le style de mise en surbrillance du bouton
      •
      Indiquer l'URL auquel les données doivent être envoyées
      •
      Ajouter une signature de données
      •
      Rendre le bouton visible ou invisible, ou le masquer
      •
      Définir le paramètre régional associé au bouton
Vous pouvez également modifier le nom du bouton dans la palette Hiérarchie et définir le style de la légende dans les palettes Police et Paragraphe.
Voir aussi
A propos des signatures numériques
Pour ajouter une signature de données à un bouton d'envoi
Propriétés de la palette Disposition
Propriétés de la palette Bordure
Propriétés de la palette Police
Propriétés de la palette Paragraphe
Propriétés des boutons Envoyer via HTTP dans le panneau Champ


Aperçu du bouton Imprimer

Le bouton Imprimer ouvre la boîte de dialogue d'impression afin que l'utilisateur puisse imprimer le formulaire. Un bouton Imprimer fonctionne quasiment comme un bouton standard : l’option Type de commande est définie sur Normal et un script est inclus dans l’événement click afin que le formulaire soit imprimé lorsque l’utilisateur clique sur le bouton.
Si vous utilisez l'assistant de création de formulaires pour créer un formulaire et si vous sélectionnez l'une des méthodes d'impression, un bouton Imprimer est inclus automatiquement dans le formulaire.
Voir aussi
Propriétés de la palette Disposition
Propriétés de la palette Bordure
Propriétés de la palette Police
Propriétés de la palette Paragraphe
Propriétés de l'objet Bouton dans l'onglet Champ


Aperçu du bouton Réinitialiser

Le bouton Réinitialiser a pour effet de rétablir les valeurs par défaut de tous les champs d'un formulaire. Le bouton Réinitialiser fonctionne comme un bouton standard : l’option Type de contrôle est définie sur Normal et un script est inclus dans l’événement click afin que les valeurs des champs soient réinitialisées lorsque l’utilisateur clique sur le bouton.
Voir aussi
Propriétés de la palette Disposition
Propriétés de la palette Bordure
Propriétés de la palette Police
Propriétés de la palette Paragraphe
Propriétés de l'objet Bouton dans l'onglet Champ


A propos de l'envoi de données au moyen d'un bouton

Pour définir les propriétés d'un bouton, vous devez d'abord sélectionner le bouton. Configurez les propriétés d'envoi de données dans le panneau Envoyer de la palette Objet. Pour afficher le panneau Envoyer, vous devez sélectionner l'option Envoyer dans la zone Type de contrôle du panneau Champ.
Vous pouvez spécifier le format, le type et le codage des données à soumettre. Si le bouton envoie des données codées URL, vous pouvez indiquer l'URL vers lequel soumettre les données. Si le bouton envoie un fichier XDP, vous pouvez inclure des pièces jointes, telles qu'annotations, documents PDF ou signatures de document. Vous pouvez également appliquer une signature numérique aux données envoyées.
Voir aussi
Propriétés des boutons dans le panneau Envoyer
A propos des signatures numériques
Pour ajouter une signature de données à un bouton d'envoi


A propos des options de traitement d'un bouton

Le panneau Exécuter de la palette Objet vous permet de sélectionner la connexion aux données du bouton et de spécifier si le traitement a lieu sur l'ordinateur client, sur le serveur ou sur les deux. La connexion aux données doit donner accès à l'interface de service Web ou au serveur de base de données OLE qui renverra les données au formulaire au moment de l'exécution ou qui effectuera une autre action.
Après avoir spécifié la source de données (voir A propos des sources de données), vous pouvez spécifier l'opération ou la requête à exécuter. A l'exécution, lorsque l'utilisateur clique sur le bouton, le système procède au traitement comme le définit l'opération ou la requête.
Les données renvoyées peuvent être fusionnées dans le formulaire de sorte que seules les données associées à des objets existants sont écrasées, sans actualisation de la structure du formulaire. Vous pouvez également choisir de mettre la structure du formulaire à jour en fonction des données XML renvoyées. Dans ce cas, la structure du formulaire est mise à jour et les données renvoyées sont fusionnées une fois le traitement terminé.
Pour définir les propriétés de traitement d'un bouton, vous devez d'abord sélectionner l'objet. Les options de traitement sont définies dans le panneau Exécuter de la palette Objet. Pour afficher le panneau Exécuter, vous devez sélectionner l'option Exécuter dans la zone Type de contrôle du panneau Champ.
Voir aussi
Propriétés des boutons dans le panneau Exécuter


Pour insérer un bouton standard afin d'exécuter un calcul ou un script

1.
Ajoutez le bouton dans une conception de formulaire. Voir Pour ajouter des objets à une conception de formulaire.
2.
Cliquez sur l'onglet Champ de la palette Objet.
3.
Sélectionnez un événement dans la zone Afficher. Si vous souhaitez que le bouton effectue un calcul, par exemple, sélectionnez Click.
4.
Dans l'éditeur de script, sélectionnez un langage dans la liste Langage.
5.
Tapez le calcul ou le script dans l'éditeur de script.
6.
Cliquez sur le bouton Insérer les changements dans la source du script [image] pour ajouter le script.
Voir aussi
Propriétés de l'objet Bouton dans l'onglet Champ


Pour insérer un bouton d'envoi permettant d'envoyer des informations à un serveur

1.
Ajoutez le bouton dans une conception de formulaire. Voir Pour ajouter des objets à une conception de formulaire.
2.
Cliquez sur l'onglet Champ de la palette Objet.
3.
Dans la zone Type de contrôle, sélectionnez Envoyer. Les données sont envoyées conformément aux paramètres définis dans le panneau Envoyer.
4.
Cliquez sur l'onglet Envoyer, puis entrez le protocole URL dans la zone Envoyer à l'URL.

A

Utiliser ce protocole URL

Exemple
Envoyer le paquet vers un site FTP
ftp
ftp://ftp.gnu.org/gnu/GPL
Envoyer le paquet vers un serveur Web
http
http://myserver/cgi-bin/
Envoyer le paquet vers un serveur Web sécurisé
https
https://myserver/cgi-bin/
lorsque vous soumettez des données à un URL, il est recommandé de spécifier une cible absolue. Les cibles relatives sont interprétées par rapport à l'environnement des utilisateurs, qui peut varier d'un utilisateur à l'autre.
5.
Sélectionnez un format de fichier dans la liste Envoyer comme.
Ces formats déclenchent le traitement côté serveur. L'option Paquet de données XML (XDP) soumet la conception de formulaire et peut inclure d'autres informations, telles que la conception de formulaire, les annotations et les signatures de document, requises par LiveCycle Forms pour afficher le formulaire au moment de l'exécution. Les pièces jointes ne peuvent être incluses que dans des fichiers XDP.
6.
(Facultatif) Pour appliquer une signature de données aux données envoyées, sélectionnez l'option Signature de l'envoi dans l'onglet Champ, puis cliquez sur Paramètres pour configurer les autres paramètres de signature.
7.
Dans la zone Inclure, sélectionnez les types de pièces jointes à inclure :
      •
      Pour inclure des commentaires de révision, des info-bulles et toute autre balise particulière nécessaire à la capture du texte du lecteur d'écran, sélectionnez Annotations.
      •
      Pour inclure la signature électronique d'un document signé, sélectionnez Signatures de document.
      •
      Pour inclure la version PDF du formulaire lorsque vous l'envoyez sous forme de pièce jointe, sélectionnez PDF. Si vous omettez de sélectionner cette option, c'est une référence au fichier PDF incorporé qui est incluse.
      •
      Pour inclure une copie de la conception de formulaire, sélectionnez Modèle.
      •
      Pour inclure un ou plusieurs éléments <xdp> dans le fichier source XDP, sélectionnez Autre. Les éléments spécifiés doivent être séparés par une virgule. L'espace après la virgule est facultatif ; par exemple : xci, xslt, sourceset.
8.
Dans la liste Codage des données, sélectionnez un type de codage de données :
      •
      UTF-8
      •
      UTF-16
      •
      Shift_JIS
      •
      Big5
      •
      GBK
      •
      KSC_5601
Voir aussi
Propriétés de l'objet Bouton dans l'onglet Champ
Propriétés des boutons dans le panneau Envoyer


Pour insérer un bouton d'envoi qui incorpore un PDF

1.
Ajoutez le bouton dans une conception de formulaire. Voir Pour ajouter des objets à une conception de formulaire.
2.
Cliquez sur l'onglet Champ de la palette Objet.
3.
Dans la zone Type de contrôle, sélectionnez Envoyer. Les données sont envoyées conformément aux paramètres définis dans le panneau Envoyer.
4.
Cliquez sur l'onglet Envoyer, puis entrez le protocole URL dans la zone Envoyer à l'URL.

A

Utiliser ce protocole URL

Exemple
Envoyer le paquet vers un site FTP
ftp
ftp://ftp.gnu.org/gnu/GPL
Envoyer le paquet vers un serveur Web
http
http://myserver/cgi-bin/
Envoyer le paquet vers un serveur Web sécurisé
https
https://myserver/cgi-bin/
Envoyer le paquet vers une adresse électronique
mailto
mailto:username@domain.com
lorsque vous soumettez des données à un URL, il est recommandé de spécifier une cible absolue. Les cibles relatives sont interprétées par rapport à l'environnement des utilisateurs, qui peut varier d'un utilisateur à l'autre.
5.
Sélectionnez PDF dans la liste Envoyer comme.
6.
Ce format soumet un paquet qui contient un fichier PDF incorporé. Sélectionnez ce format si le formulaire contient un champ de signature du document ou si une copie du formulaire et des données doit être enregistrée par LiveCycle Forms ou soumise à un autre type de serveur. Ne choisissez pas cette option si le formulaire lance un traitement sur le serveur, si LiveCycle Forms est utilisé pour générer des formulaires HTML ou dynamiques au moment de l'exécution, ou s'il s'agit d'un formulaire PDF rempli dans Adobe Reader sans LiveCycle Reader Extensions. (Facultatif) Pour appliquer une signature de données aux données envoyées, sélectionnez l'option Signature de l'envoi dans l'onglet Champ, puis cliquez sur Paramètres pour configurer les autres paramètres de signature.
Voir aussi
Propriétés de l'objet Bouton dans l'onglet Champ
Propriétés des boutons dans le panneau Envoyer


Pour insérer un bouton d'envoi qui transmet un flux de données XML

1.
Ajoutez le bouton dans une conception de formulaire. Voir Pour ajouter des objets à une conception de formulaire.
2.
Cliquez sur l'onglet Champ de la palette Objet.
3.
Dans la zone Type de contrôle, sélectionnez Envoyer. Les données sont envoyées conformément aux paramètres définis dans le panneau Envoyer.
4.
Cliquez sur l'onglet Envoyer, puis entrez le protocole URL dans la zone Envoyer à l'URL.

A

Utiliser ce protocole URL

Exemple
Envoyer le paquet vers un site FTP
ftp
ftp://ftp.gnu.org/gnu/GPL
Envoyer le paquet vers un serveur Web
http
http://myserver/cgi-bin/
Envoyer le paquet vers un serveur Web sécurisé
https
https://myserver/cgi-bin/
Envoyer le paquet vers une adresse électronique
mailto
mailto:username@domain.com
lorsque vous soumettez des données à une URL, il est recommandé de spécifier une cible absolue. Les cibles relatives sont interprétées par rapport à l'environnement des utilisateurs, qui peut varier d'un utilisateur à l'autre.
5.
Sélectionnez Données XML (XML) dans la liste Envoyer comme.
Ce format soumet un flux de données XML pour permettre une représentation hiérarchique des données pouvant être analysées par un analyseur syntaxique XML. Sélectionnez ce format si le serveur qui communique avec le programme d'application doit recevoir un flux de données XML.
6.
(Facultatif) Pour appliquer une signature de données aux données envoyées, sélectionnez l'option Signature de l'envoi dans l'onglet Champ, puis cliquez sur Paramètres pour configurer les autres paramètres de signature.
7.
Dans la liste Codage, sélectionnez un type de codage de données :
      •
      UTF-8
      •
      UTF-16
      •
      Shift_JIS
      •
      Big5
      •
      GBK
      •
      KSC_5601
Voir aussi
Propriétés de l'objet Bouton dans l'onglet Champ
Propriétés des boutons dans le panneau Envoyer


Pour insérer un bouton d'envoi permettant d'envoyer un flux de texte par la méthode POST

1.
Ajoutez le bouton dans une conception de formulaire. Voir Pour ajouter des objets à une conception de formulaire.
2.
Cliquez sur l'onglet Champ de la palette Objet.
3.
Dans la zone Type de contrôle, sélectionnez Envoyer. Les données sont envoyées conformément aux paramètres définis dans le panneau Envoyer.
4.
Cliquez sur l'onglet Envoyer, puis entrez le protocole URL dans la zone Envoyer à l'URL.

A

Utiliser ce protocole URL

Exemple
Envoyer le paquet vers un site FTP
ftp
ftp://ftp.gnu.org/gnu/GPL
Envoyer le paquet vers un serveur Web
http
http://myserver/cgi-bin/
Envoyer le paquet vers un serveur Web sécurisé
https
https://myserver/cgi-bin/
Envoyer le paquet vers une adresse électronique
mailto
mailto:username@domain.com
lorsque vous soumettez des données à un URL, il est recommandé de spécifier une cible absolue. Les cibles relatives sont interprétées par rapport à l'environnement des utilisateurs, qui peut varier d'un utilisateur à l'autre.
5.
Sélectionnez Données codées dans URL (HTTP Post) dans la liste Envoyer comme.
Ce format soumet un flux de texte à l'URL spécifiée par le biais de la méthode POST. Le flux de texte peut être analysé par un serveur FTP, un serveur de messagerie, un serveur Web ou un script CGI qui traite des formulaires HTML. Pour tirer parti de cette méthode, les utilisateurs doivent ouvrir le formulaire dans Adobe Reader 6.0 (ou version ultérieure) ou dans un navigateur Web à moins que l'URL n'indique un protocole mailto.
6.
(Facultatif) Pour appliquer une signature de données aux données envoyées, sélectionnez l'option Signature de l'envoi dans l'onglet Champ, puis cliquez sur Paramètres pour configurer les autres paramètres de signature.
7.
Dans la liste Codage, sélectionnez un type de codage de données :
      •
      UTF-8
      •
      UTF-16
      •
      Shift_JIS
      •
      Big5
      •
      GBK
      •
      KSC_5601
Voir aussi
Propriétés de l'objet Bouton dans l'onglet Champ
Propriétés des boutons dans le panneau Envoyer


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des boutons > Pour insérer un bouton afin de transmettre un courrier électronique contenant des données XML

Pour insérer un bouton afin de transmettre un courrier électronique contenant des données XML

Vous pouvez créer votre propre bouton Envoyer par messagerie ou utiliser celui de la palette Bibliothèque.
1.
Ajoutez le bouton dans une conception de formulaire. Voir Pour ajouter des objets à une conception de formulaire.
2.
Cliquez sur l'onglet Champ de la palette Objet.
3.
Dans la zone Type de contrôle, sélectionnez Envoyer. Les données sont envoyées conformément aux paramètres définis dans le panneau Envoyer.
4.
Cliquez sur l'onglet Envoyer, puis, dans la zone Envoyer à l'URL, spécifiez le protocole mailto comme indiqué dans l'exemple suivant :

mailto:username@domain.com
5.
Sélectionnez Données XML (XML) dans la liste Envoyer comme.
Ce format envoie un flux de données XML pour permettre une représentation hiérarchique des données pouvant être analysées par un analyseur syntaxique XML. Sélectionnez ce format si le serveur qui communique avec le programme d'application doit recevoir un flux de données XML.
6.
(Facultatif) Pour appliquer une signature de données aux données envoyées, sélectionnez l'option Signature de l'envoi dans l'onglet Champ, puis cliquez sur Paramètres pour configurer les autres paramètres de signature.
7.
Dans la liste Codage, sélectionnez un type de codage de données :
      •
      UTF-8
      •
      UTF-16
      •
      Shift_JIS
      •
      Big5
      •
      GBK
      •
      KSC_5601
Voir aussi
Propriétés des boutons dans le panneau Envoyer


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des boutons > Pour exécuter une opération de service Web ou une requête dans une base de données à l'aide d'un bouton

Pour exécuter une opération de service Web ou une requête dans une base de données à l'aide d'un bouton

Le type de bouton Exécuter permet d'envoyer une requête de traitement à un service Web. Un service Web traite les opérations qu'il reçoit pour définir les données d'entrée et de sortie de votre formulaire.
Vous devez ajouter une connexion à un service Web, puis créer des champs ou les lier à la requête et aux services de réponse. Le champ associé peut transmettre un message d'entrée au service ou recevoir un message transmis par ce dernier. Pour exécuter l'opération, vous pouvez vous servir du bouton Exécuter ou rédiger un script. Vous pourriez, par exemple, utiliser un service Web pour vérifier un taux d'intérêt, un taux de change ou le cours d'une action.
1.
Ajoutez le bouton dans une conception de formulaire. Voir Pour ajouter des objets à une conception de formulaire.
2.
Cliquez sur l'onglet Champ de la palette Objet.
3.
Dans la zone Type de contrôle, sélectionnez Exécuter. Une opération de service Web ou une requête dans une base de données est exécutée conformément aux paramètres définis dans le panneau Exécuter.
4.
Cliquez sur l'onglet Exécuter et sélectionnez Nouvelle connexion aux données dans la liste Connexion.
5.
Sélectionnez Fichier WSDL et cliquez sur Suivant.
6.
Si le fichier se trouve sur votre ordinateur, cliquez sur Parcourir pour rechercher et sélectionner le fichier voulu. Dans le cas contraire, saisissez l’URL menant au fichier WSDL dans la zone Fichier WSDL.
7.
Cliquez sur Suivant et sélectionnez l’opération que vous voulez appeler.
Le panneau de droite affiche des renseignements sur l’opération sélectionnée. Si l’opération n’est pas codée pour SOAP ou n’est pas un document ou un littéral, le système affiche un avertissement et vous ne pouvez pas continuer votre travail.
8.
Cliquez sur Terminer.
9.
Dans la liste Exécuter sur, sélectionnez l'emplacement d'exécution du traitement.
      •
      Pour traiter la requête sur l’ordinateur client, sélectionnez Client.
      •
      Pour traiter la requête sur le serveur, sélectionnez Serveur.
      •
      Pour traiter la requête sur l’ordinateur client et sur le serveur, sélectionnez Client et serveur.
10.
Pour mettre à jour la structure du formulaire et fusionner les données renvoyées une fois le traitement terminé, sélectionnez l'option Fusionner à nouveau les données de formulaire.
Voir aussi
A propos des options de traitement d'un bouton
Propriétés des boutons dans le panneau Exécuter


Pour associer un script de base de données à un bouton

Vous pouvez également utiliser des scripts pour effectuer une manipulation de données plus complexe sur le système d'une entreprise. L'exemple suivant montre comment associer des scripts simples à des champs de bouton pour exécuter des opérations élémentaires de base de données (déplacement au premier ou au dernier enregistrement et à l'enregistrement précédent ou suivant, ajout de nouveaux enregistrements, mise à jour d'enregistrements existants et suppression d'enregistrements).
cet exemple utilise une configuration et une base de données en particulier. Il ne fait pas partie des exemples de LiveCycle Designer. Il constitue une référence en vue de la création de vos propres scripts de consultation de base de données.
1.
Cliquez sur la catégorie Standard de la palette Bibliothèque, puis faites glisser huit objets de bouton sur la conception de formulaire. Lorsque vous ajoutez un objet de bouton, son type de contrôle par défaut est Normal. Validez l'option par défaut.
2.
Nommez les boutons comme suit : Premier, Précédent, Suivant, Dernier, Ajouter, Mettre à jour, Supprimer et Annuler.
3.
Sélectionnez le bouton nommé Premier.
4.
Dans l'éditeur de script, sélectionnez click dans la zone Afficher, JavaScript dans la liste Langage et Client dans la liste Exécuter sur.
5.
Dans l'éditeur de script, rédigez le script JavaScript suivant :

xfa.sourceSet.DataConnection.first();
6.
Répétez l'étape 5 pour chacun des boutons en utilisant respectivement les scripts suivants :
      •
      Précédent : xfa.sourceSet.DataConnection.previous();
      •
      Suivant : xfa.sourceSet.DataConnection.next();
      •
      Dernier : xfa.sourceSet.DataConnection.last();
      •
      Ajouter : xfa.sourceSet.DataConnection.addNew();
      •
      Mettre à jour : xfa.sourceSet.DataConnection.update();
      •
      Supprimer : xfa.sourceSet.DataConnection.delete();
      •
      Annuler : xfa.sourceSet.DataConnection.cancel();
7.
Enregistrez la conception de formulaire.
8.
Testez le formulaire à partir du panneau Aperçu PDF. Avant qu'un tel formulaire ne soit rempli dans Adobe Reader, vous devez définir les droits d'utilisation du formulaire au moyen de LiveCycle Reader Extensions, afin qu'Adobe Reader puisse accéder à la base de données.
9.
Cliquez sur les différents boutons pour afficher les données associées à chacun des enregistrements. L'exemple montre qu'en cliquant sur le bouton Dernier, l'ID, le numéro de pièce, la description et le prix unitaire du dernier enregistrement apparaissent dans leurs champs respectifs.
Voir aussi
A propos de l'aperçu et des tests de formulaires
A propos des sources de données
A propos des calculs et des scripts dans les formulaires interactifs


Utilisation d'un bouton pour remplir les champs à partir d'une base de données

Vous pouvez utiliser une base de données en vue de transmettre les données à des champs du formulaire, y compris des champs de texte et des champs numériques.
Dans l'exemple ci-dessous, le bouton Récupérer l'enregistrement et la zone de liste sont liés à la base de données (appelée DataConnection) dans la palette Vue des données située à gauche. Un script FormCalc est également associé au bouton pour récupérer les données propres au numéro de pièce sélectionné dans la zone de liste. Les données propres à l'enregistrement récupéré s'affichent dans les champs d'identifiant, de numéro de pièce, de prix unitaire et de description.
1.
Etablissez une connexion à la base de données.
2.
A partir de la palette Vue des données, faites glisser les éléments UNIT_PRICE, DESCRIPTION, PART_NO et ID situés sous DataConnection pour les déposer sur la conception de formulaire. Chaque noeud que vous faites glisser vers la conception de formulaire crée automatiquement un champ associé.
3.
Cliquez sur la catégorie Standard de la palette Objet et faites glisser l'objet de bouton pour le déposer sur la conception de formulaire.
4.
Saisissez le nouveau nom du bouton. L'exemple utilise RETRIEVE RECORD.
5.
Sélectionnez le bouton et, dans l'éditeur de script, choisissez click dans la zone Afficher, FormCalc dans la liste Langage et Client dans la liste Exécuter sur.
6.
Entrez un script FormCalc en vous basant sur l'exemple ci-dessous. Lorsqu'un utilisateur clique sur le bouton, le script récupère les données propres aux enregistrements spécifiés, puis les affiche dans les champs correspondants.

//Change the commandType from TABLE to TEXT. TEXT
//is the equivalent of SQL Property
$sourceSet.DataConnection.#command.query.commandType = “text”

//Set the Select Node. Select in this case will be
//whatever SQL Property you want
$sourceSet.DataConnection.#command.query.select.nodes.item(0).value = Concat(“Select*from OfficeSupplies Where ID = “, DataListBox1.rawValue,””)

//Reopen the Data connection
$sourceSet.DataConnection.open()
7.
Enregistrez la conception de formulaire au format PDF.
8.
Testez le formulaire au moyen du panneau Aperçu PDF pour vérifier si le script fonctionne comme prévu.
Voir aussi
A propos de l'aperçu et des tests de formulaires
A propos des sources de données
A propos des calculs et des scripts dans les formulaires interactifs
Pour créer un champ ou un sous-formulaire lié
Aperçu des boutons


Pour personnaliser le bouton Envoyer par messagerie

Vous pouvez spécifier l'adresse électronique à laquelle les données du formulaire seront envoyées et indiquer l'objet du message.
1.
Ajoutez un bouton Envoyer par messagerie à la conception de formulaire. Voir Pour ajouter des objets à une conception de formulaire.
2.
Cliquez sur l'onglet Champ de la palette Objet.
3.
Saisissez l'adresse dans la zone Adresse électronique.
4.
Saisissez l'objet dans la zone Objet du message.
5.
(Facultatif) Pour appliquer une signature de données aux données envoyées, sélectionnez l'option Signature de l'envoi, puis cliquez sur Paramètres pour configurer les autres paramètres de signature.
Voir aussi
Propriétés des boutons Envoyer par messagerie dans le panneau Champ
A propos des signatures numériques
Pour ajouter une signature de données à un bouton d'envoi


Pour personnaliser le bouton Envoyer via HTTP

1.
Ajoutez un bouton Envoyer via HTTP à la conception de formulaire. Voir Pour ajouter des objets à une conception de formulaire.
2.
Dans la palette Objet, cliquez sur l'onglet Champ et spécifiez l'URL dans la zone URL.

A

Utiliser ce protocole URL

Exemple
Envoyer le paquet vers un site FTP
ftp
ftp://ftp.gnu.org/gnu/GPL
Envoyer le paquet vers un serveur Web
http
http://myserver/cgi-bin/
Envoyer le paquet vers un serveur Web sécurisé
https
https://myserver/cgi-bin/
Envoyer le paquet vers une adresse électronique
mailto
mailto:username@domain.com
lorsque vous soumettez des données à un URL, il est recommandé de spécifier une cible absolue. Les cibles relatives sont interprétées par rapport à l'environnement des utilisateurs, qui peut varier d'un utilisateur à l'autre.
3.
(Facultatif) Pour appliquer une signature de données aux données envoyées, sélectionnez l'option Signature de l'envoi, puis cliquez sur Paramètres pour configurer les autres paramètres de signature.
Voir aussi
Propriétés des boutons Envoyer via HTTP dans le panneau Champ
A propos des signatures numériques
Pour ajouter une signature de données à un bouton d'envoi


Utilisation des cases à cocher

A propos des cases à cocher
Pour définir la taille de la case à cocher
Pour définir le type de marque
Pour définir l'état de la case à cocher
Pour définir le comportement de la case à cocher
Pour spécifier l'état par défaut de la case à cocher
Pour modifier les valeurs attribuées aux états d'une case à cocher
Pour définir des propriétés de liaison personnalisée d'une case à cocher


A propos des cases à cocher

Si vous souhaitez offrir aux utilisateurs la possibilité d'activer ou de désactiver des éléments individuels, insérez des cases à cocher dans vos formulaires. L'utilisateur peut changer à sa guise l'état d'une case à cocher. Lorsqu'une case est cochée, elle est activée. Lorsqu'une case n'est pas cochée, cela signifie qu'elle est désactivée. Les cases à cocher d'un formulaire peuvent être activées ou désactivées séparément, et utilisées pour définir les propriétés d'une sélection.
Après avoir inséré une case à cocher dans votre formulaire, vous pouvez définir le texte de sa légende et manipuler ses propriétés dans les panneaux Champ, Valeur et Liaison de la palette Objet. Vous pouvez définir les propriétés suivantes :
      •
      Changer la légende de la case à cocher. Voir Pour renommer une légende.
      •
      Sélectionner le style de la bordure de la case à cocher. Voir Pour définir le style de la bordure.
      •
      Définir l'objet comme visible, invisible ou masqué. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Définir le paramètre régional associé à la case à cocher. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Définir la taille de la case à cocher.
      •
      Définir le type de marque.
      •
      Définir l'état de la case à cocher.
      •
      Sélectionner l'état par défaut de la case à cocher.
      •
      Définir les valeurs des états Activé, Désactivé et Neutre de la case à cocher.
      •
      Spécifier la méthode de liaison pour le stockage et la restauration des données liées.
Il est possible d'associer des scripts et des calculs aux cases à cocher. Si l'utilisateur est appelé à entrer des données, vous pouvez déterminer si la saisie d'informations est facultative ou obligatoire et définir le texte d'invite approprié. Toutes les données entrées par l'utilisateur peuvent être validées par un script.
Vous pouvez lier les objets de case à cocher aux éléments de données d’un fichier de données source afin que les valeurs Activé et Désactivé soient dérivées du fichier source dans le formulaire.
Voir aussi
Pour ajouter des objets à une conception de formulaire
Pour donner un nom aux objets ou changer leur nom
Propriétés des cases à cocher dans le panneau Champ
Propriétés des cases à cocher dans le panneau Valeur
Propriétés de case à cocher dans le panneau Liaison
Propriétés de la palette Disposition
Propriétés de la palette Bordure


Pour définir la taille de la case à cocher

1.
Pour spécifier les dimensions d'une case à cocher, cliquez sur l'onglet Champ dans la palette Objet.
2.
Tapez une valeur différente (en points) dans la zone Taille et appuyez sur Entrée.
Selon la taille spécifiée, vous devrez peut-être redimensionner la case à cocher.
Voir aussi
Propriétés des cases à cocher dans le panneau Champ


Pour définir le type de marque

1.
Cliquez sur l'onglet Champ de la palette Objet.
2.
Sélectionnez une option dans la liste Type de marque :
      •
      Pour attribuer le style par défaut (X), sélectionnez Valeur par défaut.
      •
      Pour utiliser une coche, sélectionnez Coche.
      •
      Pour utiliser un cercle, sélectionnez Cercle.
      •
      Pour utiliser une croix, sélectionnez Croix.
      •
      Pour utiliser un losange, sélectionnez Losange.
      •
      Pour utiliser un carré, sélectionnez Carré.
      •
      Pour utiliser une étoile, sélectionnez Etoile.
Voir aussi
Propriétés des cases à cocher dans le panneau Champ


Pour définir l'état de la case à cocher

1.
Cliquez sur l'onglet Champ de la palette Objet.
2.
Sélectionnez l'option voulue sous Etats :
      •
      Pour indiquer que la case à cocher peut prendre l'état Activé (case sélectionnée) ou Désactivé (case vide), sélectionnez Activé/Désactivé.
      •
      Pour indiquer que la case à cocher peut prendre l'état Activé (case sélectionnée), Désactivé (case vide) ou Neutre (case ni sélectionnée ni vide), sélectionnez Activé/Désactivé/Neutre.
Les valeurs correspondant à chacun des états doivent être définies dans le panneau Liaison de la palette Objet. Voir Pour modifier les valeurs attribuées aux états d'une case à cocher.
Voir aussi
Propriétés des cases à cocher dans le panneau Champ
Propriétés de case à cocher dans le panneau Liaison


Pour définir le comportement de la case à cocher

1.
Dans le panneau Valeur de la palette Objet, sélectionnez l'une des options suivantes :
      •
      Pour laisser aux utilisateurs le choix de saisir des données, choisissez Entré par l'utilisateur - Facultatif.
      •
      Pour configurer le champ en lecture seule et calculer et afficher la valeur de donnée par le biais d'un script joint , choisissez Calculé - Lecture seule. L'utilisateur n'est pas autorisé à modifier la valeur calculée.
      •
      Pour autoriser la modification du champ et calculer et afficher une valeur de donnée par le biais d'un script joint , choisissez Calculé - L’utilisateur peut remplacer. L'utilisateur peut changer la valeur si le script de calcul accepte les saisies. Si l'utilisateur change la valeur, le message personnalisé que vous avez défini dans la zone Message de remplacement s'affiche.
      •
      Pour configurer le champ en lecture seule et afficher une valeur de donnée résultant d'une fusion ou d'un calcul au moment de l'exécution, choisissez Lecture seule. L'utilisateur n'est pas autorisé à modifier la valeur.
2.
Si la valeur doit être calculée, joignez le script de calcul à l'objet à l'aide de l'éditeur de script.
3.
(Facultatif) Si la valeur calculée peut être remplacée, saisissez un message dans la zone Message de remplacement.
vous pouvez remplir un modèle de validation ou un message de script de manière dynamique à l'aide d'une valeur issue d'une source de données. Vous serez ainsi assuré que les utilisateurs saisissent la valeur correcte dans le champ.
Voir aussi
Pour remplir de façon dynamique un message de modèle de validation
Pour remplir de façon dynamique un message de script de validation
Propriétés des cases à cocher dans le panneau Valeur


Pour spécifier l'état par défaut de la case à cocher

1.
Cliquez sur l'onglet Valeur de la palette Objet.
2.
Sélectionnez un état dans la liste Valeur par défaut :
      •
      Pour appliquer l'état Activé par défaut, sélectionnez Activé. La case est initialement cochée.
      •
      Pour appliquer l'état Désactivé par défaut, sélectionnez Désactivé. La case est initialement désélectionnée.
      •
      Pour appliquer l'état Neutre par défaut, sélectionnez Neutre. La case est initialement grisée.
la liste Valeur par défaut est disponible uniquement si l'option Type est définie sur Entré par l'utilisateur ou sur Lecture seule. L'option Neutre est disponible dans la liste Valeur par défaut seulement lorsque l'option Etats du panneau Champ est définie sur Activé/Désactivé/Neutre.
Voir aussi
Propriétés des cases à cocher dans le panneau Valeur


Pour modifier les valeurs attribuées aux états d'une case à cocher

Par défaut, les cases à cocher utilisent des nombres pour représenter les valeurs de données de formulaire. Les valeurs par défaut sont 1 (activé), 0 (désactivé) et 2 (neutre). Vous pouvez modifier ces valeurs pour qu'elles correspondent à des valeurs existantes dans la source des données ou fournir des termes significatifs concernant le rôle de la case à cocher dans le fichier de données.
1.
Dans la palette Objet, cliquez sur l'onglet Liaison.
2.
Dans la zone Valeur - zone sélectionnée, indiquez la valeur de l’état Activé de la case à cocher à la source de données.
3.
Dans la zone Valeur - zone non sélectionnée, indiquez la valeur de l’état Désactivé de la case à cocher à la source de données.
4.
Si l'option Activé/Désactivé/Neutre a été sélectionnée dans le panneau Champ, dans la zone Valeur – zone en grisé, indiquez la valeur de l'état Neutre de la case à cocher à la source de données.
Voir aussi
A propos des sources de données
Propriétés de case à cocher dans le panneau Liaison


Pour définir des propriétés de liaison personnalisée d'une case à cocher

Les options de liaison permettent de développer un formulaire qui capture les données pour les infrastructures de l'entreprise ou d'utiliser une source de données externe pour remplir le formulaire à l'exécution. Définissez les propriétés de liaison de données dans le panneau Liaison de la palette Objet.
1.
Sélectionnez la case à cocher.
2.
Activez le formulaire pour établir la connexion à la source de données lorsque le formulaire est ouvert.
3.
Liez la case à cocher au noeud de données correspondant. Pour plus d'informations sur la liaison des objets à une source de données, voir A propos de la liaison de champs à une source de données.
Voir aussi
Pour modifier les valeurs attribuées aux états d'une case à cocher
A propos des sources de données
Propriétés de case à cocher dans le panneau Liaison


Utilisation de cercles, de lignes et de rectangles

Aperçu des cercles, des lignes et des rectangles
Pour changer le style de ligne
Pour changer l'épaisseur de la ligne
Pour sélectionner la couleur de la ligne
Pour définir la forme du cercle
Pour indiquer les points de départ et d'arrivée d'un arc
Pour appliquer une couleur ou un motif de fond au cercle ou au rectangle
Pour changer la pente de la ligne
Pour modifier les coins du rectangle


Aperçu des cercles, des lignes et des rectangles

Les objets de dessin de la palette Bibliothèque permettent d'améliorer l'aspect des formulaires.
      •
      En utilisant l'objet de cercle, vous pouvez dessiner des formes circulaires, elliptiques ainsi que des arcs sur la page.
      •
      À l'aide de l'objet de ligne, vous pouvez tracer des lignes pleines, avec des tirets ou en pointillés, n'importe où sur la page.
      •
      L'objet de rectangle permet de dessiner des rectangles dont les coins sont à 90° ou arrondis. Utilisez des rectangles pour encadrer une portion du formulaire ou définir une zone rectangulaire servant d'arrière-plan à d'autres objets.
Après avoir inséré un objet de dessin dans votre formulaire, définissez ses propriétés à partir du panneau Dessin de la palette Objet. Vous pouvez définir les propriétés suivantes :
      •
      Changer le style de ligne.
      •
      Changer l'épaisseur de la ligne.
      •
      Sélectionner la couleur de la ligne.
      •
      Définir la forme du cercle.
      •
      Indiquer les points de départ et de fin d'un arc.
      •
      Appliquer une couleur ou un motif de fond au cercle ou au rectangle.
      •
      Changer la pente de la ligne.
      •
      Modifier les coins du rectangle.
      •
      Rendre l'objet visible ou invisible, ou le masquer.
      •
      Définir l'objet comme visible, invisible ou masqué. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
Voir aussi
Propriétés des cercles dans le panneau Dessin
Propriétés des lignes dans le panneau Dessin
Propriétés des rectangles dans le panneau Dessin
Propriétés de la palette Disposition


Pour changer le style de ligne

1.
Sélectionnez le cercle, la ligne ou le rectangle.
2.
Dans la palette Objet, sélectionnez un style dans la liste Trait.
Vous devrez éventuellement faire un zoom ou augmenter l'épaisseur du trait pour voir le style.
Voir aussi
Propriétés des cercles dans le panneau Dessin
Propriétés des lignes dans le panneau Dessin
Propriétés des rectangles dans le panneau Dessin


Pour changer l'épaisseur de la ligne

1.
Sélectionnez le cercle, la ligne ou le rectangle.
2.
Spécifiez une nouvelle épaisseur dans la zone à droite de l'option Style de trait dans la palette Objet.
Si le nombre entré génère un trait trop épais (2,5 cm, par exemple ), la ligne sera difficile à sélectionner. Servez-vous de la palette Hiérarchie pour sélectionner la ligne.
Voir aussi
Propriétés des cercles dans le panneau Dessin
Propriétés des lignes dans le panneau Dessin
Propriétés des rectangles dans le panneau Dessin


Pour sélectionner la couleur de la ligne

1.
Sélectionnez le cercle, la ligne ou le rectangle.
2.
Dans la palette Objet, cliquez sur le bouton de sélection de couleurs et choisissez une couleur.
Voir aussi
Propriétés des cercles dans le panneau Dessin
Propriétés des lignes dans le panneau Dessin
Propriétés des rectangles dans le panneau Dessin


Pour définir la forme du cercle

1.
Sélectionnez le cercle.
2.
Dans la palette Objet, sélectionnez la forme de l'objet dans la liste Aspect.
      •
      Pour dessiner une forme elliptique, sélectionnez Ellipse.
      •
      Pour dessiner une forme circulaire, sélectionnez Cercle.
      •
      Pour dessiner un arc, sélectionnez Arc.
Voir aussi
Propriétés des cercles dans le panneau Dessin


Pour indiquer les points de départ et d'arrivée d'un arc

1.
Sélectionnez l'arc.
2.
Dans la palette Objets, entrez les points de départ et d'arrivée (en degrés) dans les zones Début et Balayage respectivement.
Voir aussi
Propriétés des cercles dans le panneau Dessin


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation de cercles, de lignes et de rectangles > Pour appliquer une couleur ou un motif de fond au cercle ou au rectangle

Pour appliquer une couleur ou un motif de fond au cercle ou au rectangle

1.
Sélectionnez le cercle ou le rectangle.
2.
Dans la palette Objet, sélectionnez une option dans la liste Fond.
3.
Servez-vous des boutons de sélection de couleurs pour choisir les couleurs de fond appropriées.
Voir aussi
Propriétés des cercles dans le panneau Dessin
Propriétés des rectangles dans le panneau Dessin


Pour changer la pente de la ligne

Vous avez la possibilité de modifier l'inclinaison de la ligne Cela est très pratique lorsque votre ligne n'est pas tout à fait droite. Vous pouvez la redresser à l'aide de cette option.
1.
Sélectionnez la ligne.
2.
Dans la palette Objet, cliquez sur un des boutons d'aspect [image].
Voir aussi
Propriétés des lignes dans le panneau Dessin


Pour modifier les coins du rectangle

1.
Sélectionnez le rectangle.
2.
Dans la palette Objet, cliquez sur un des boutons de définition des coins.
3.
Entrez le rayon du coin dans la zone prévue à cet effet.
Voir aussi
Propriétés des rectangles dans le panneau Dessin


Utilisation de zones de contenu

Aperçu des zones de contenu
Flux des données entre les zones de contenu
Pour sélectionner une zone de contenu
Pour renommer une zone de contenu
Pour définir l'ordre de tabulation et l'ordre de remplissage des sous-formulaires de la zone de contenu
Pour copier, déplacer et redimensionner une zone de contenu
Pour ajouter une zone de contenu


Aperçu des zones de contenu

Les zones de contenu permettent de gérer l’ancrage et la disposition de tous les objets du formulaire, y compris les sous-formulaires.
Il n'est généralement pas nécessaire de modifier les propriétés d'une zone de contenu. Toutefois, si vous concevez un formulaire comportant des sous-formulaires configurés pour enchaîner le contenu, familiarisez-vous avec les propriétés des zones de contenu pour mieux comprendre le fonctionnement des sous-formulaires.
Les zones de contenu ne peuvent pas être sélectionnées ou manipulées dans le panneau Vue de conception de l'éditeur de disposition. Au besoin, vous pouvez sélectionner, couper, copier, coller, déplacer, supprimer ou redimensionner une zone de contenu dans le panneau Gabarit de l'éditeur de disposition. Un rectangle sur le gabarit délimite la zone de contenu.
Les nouveaux formulaires incluent une zone de contenu par défaut. Si cela s'avère nécessaire (par exemple, lors de la conception d'un formulaire comportant des sous-formulaires configurés pour enchaîner le contenu), vous pouvez ajouter des zones de contenu supplémentaires dans le formulaire. Toutes les zones de contenu s'affichent dans la palette Hiérarchie.
Voir aussi
Pour donner un nom aux objets ou changer leur nom
Propriétés de la palette Disposition
Propriétés des zones de contenu dans le panneau Zone de contenu


Flux des données entre les zones de contenu

Lorsque plusieurs zones de contenu ont été définies, les objets peuvent être enchaînés d'une zone de contenu à l'autre lors du rendu du formulaire. Vous pouvez définir la direction de l'enchaînement pour les objets et leurs données. Cette direction détermine l'objet qui devient actif par rapport aux autres objets du formulaire dans une séquence de tabulation. Elle détermine également le moment auquel un objet reçoit les données fusionnées. En définissant l'enchaînement d'une zone de contenu, vous définissez automatiquement celui de toutes les autres zones de contenu du formulaire.
Lors du rendu du formulaire, si un objet qui fusionne des données reçoit plus de données qu'il ne peut en contenir, les données peuvent s'étendre dans les zones de contenu suivantes. De la même manière, lorsque vous concevez un formulaire, vous ne pouvez pas insérer un nombre d'objets supérieur à celui qu'elle peut contenir. Dès que la zone est pleine, les objets restants sont insérés dans la prochaine zone de contenu disponible. Si aucune autre zone de contenu ne peut accueillir le débordement, les données ne sont pas rendues correctement.
Voir aussi
Pour ajouter une zone de contenu


Pour sélectionner une zone de contenu

Il est possible de sélectionner une zone de contenu par le biais de la palette Hiérarchie ou dans le panneau Gabarit de l'éditeur de disposition.
      *
      Sélectionnez une zone de contenu en utilisant l'une des méthodes suivantes :
      •
      Cliquez sur le panneau Gabarit de l'éditeur de disposition. Cliquez ensuite sur le rectangle qui délimite la zone de contenu.
      •
      Dans la palette Hiérarchie, cliquez sur la zone de contenu.
Voir aussi
Propriétés des zones de contenu dans le panneau Zone de contenu


Pour renommer une zone de contenu

      •
      Pour renommer une zone de contenu à partir de la palette Hiérarchie, cliquez avec le bouton droit de la souris sur l’objet et choisissez Renommer l’objet. Tapez le nouveau nom et appuyez sur Entrée.
      •
      Pour renommer une zone de contenu par le biais de la palette Objet, sélectionnez la zone de contenu. Dans la palette Objet, tapez le nouveau nom de la zone de contenu dans la zone prévue à cet effet et appuyez sur Entrée. LiveCycle Designer gère automatiquement le nombre d'occurrences.
Voir aussi
Propriétés des zones de contenu dans le panneau Zone de contenu


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation de zones de contenu > Pour définir l'ordre de tabulation et l'ordre de remplissage des sous-formulaires de la zone de contenu

Pour définir l'ordre de tabulation et l'ordre de remplissage des sous-formulaires de la zone de contenu

      *
      Dans la palette Objet, sélectionnez l'une des options proposées dans la liste Enchaînement :
      •
      Pour définir l’ordre de tabulation et l’ordre de remplissage par défaut du haut vers le bas de la page, sélectionnez Haut vers le bas.
      •
      Pour définir l’ordre de tabulation et l’ordre de remplissage par défaut du haut de la page vers la droite jusqu’à ce l’objet le plus à droite ait été atteint, sélectionnez Texte occidental. Une fois le bord droit de la page atteint, l'enchaînement se poursuit au prochain objet en dessous et du côté gauche de la page.
Voir aussi
Propriétés des zones de contenu dans le panneau Zone de contenu


Pour copier, déplacer et redimensionner une zone de contenu

Vous pouvez couper, copier, coller, supprimer, redimensionner ou repositionner une zone de contenu dans le panneau Gabarit de l'éditeur de disposition. Vous ne pouvez couper et supprimer que les zones de contenu ajoutées à un gabarit. Chaque formulaire doit comporter au moins une zone de contenu. La zone de contenu par défaut ne peut pas être supprimée.
Pour couper, copier, coller ou supprimer une zone de contenu
      *
      Cliquez sur l'onglet Gabarit dans l'éditeur de disposition. Cliquez avec le bouton droit de la souris sur la zone de contenu et sélectionnez la commande désirée.
Pour redimensionner une zone de contenu
      *
      Redimensionnez la zone de contenu le panneau Pages types de l'éditeur de disposition à l'aide de l'une des méthodes suivantes :
      •
      Cliquez sur le bord de la zone de contenu et faites glisser l'une des poignées de l'objet pour obtenir la taille voulue.
      •
      Sélectionnez la zone de contenu et modifiez les options de taille dans la palette Disposition.
Pour déplacer une zone de contenu
1.
Dans le panneau Gabarit de l'éditeur de disposition, sélectionnez la zone de contenu.
2.
Déplacez la zone de contenu à l'aide de l'une des méthodes suivantes :
      •
      Faites glisser la zone de contenu vers son nouvel emplacement.
      •
      Modifiez les coordonnées x et y de l'objet dans la palette Disposition.
      •
      Utilisez une touche fléchée pour déplacer légèrement la zone de contenu dans une direction.
Voir aussi
Propriétés des gabarits dans le panneau Gabarit


Pour ajouter une zone de contenu

Vous pouvez ajouter une zone de contenu par le biais de la palette Bibliothèque ou de la barre de menus. Les zones de contenu ne peuvent être ajoutées que dans les gabarits.
Pour ajouter une zone de contenu par le biais de la barre de menus
      *
      Une fois que le gabarit s'affiche, choisissez Insertion > Standard > Zone de contenu.
Pour ajouter une zone de contenu par le biais de la palette Bibliothèque
      *
      Effectuez l'une des opérations suivantes :
      •
      Cliquez sur la catégorie Standard de la palette Bibliothèque. Cliquez sur l'objet de zone de contenu et dessinez l'objet sur le gabarit du formulaire.
      •
      Dans la catégorie Standard de la palette Bibliothèque, faites glissez l'objet de zone de contenu sur le gabarit du formulaire.
      •
      Cliquez sur la catégorie Standard de la palette Bibliothèque. Cliquez deux fois sur l'objet de zone de contenu.
Voir aussi
Flux des données entre les zones de contenu


Utilisation des champs de date et d'heure

Aperçu des champs de date et d'heure
Pour ajouter le champ de la date actuelle
Pour définir le comportement du champ date/heure
Pour définir les propriétés de liaison personnalisée d’un champ de date/heure
Pour spécifier les données à afficher dans le champ de date/heure
Pour spécifier le format de peigne du champ de date/heure
Pour limiter les nombres saisis dans les champs de date/heure


Aperçu des champs de date et d'heure

Si vous souhaitez offrir la possibilité d'enregistrer la date, l'heure ou les deux dans un formulaire, insérez-y un champ Date/Heure. Vous pouvez formater la valeur du champ Date/Heure et l'afficher selon des formats prédéfinis et selon le paramètre régional défini pour le champ.
Vous pouvez ajouter, par exemple, un champ de date/heure à votre conception de formulaire pour permettre à l'utilisateur de saisir directement une date ou de la choisir dans une fenêtre de calendrier.
Après avoir inséré un champ Date/Heure dans votre conception de formulaire, vous pouvez définir le texte de sa légende et manipuler ses propriétés dans les panneaux Champ, Valeur et Liaison de la palette Objet. Vous pouvez définir les propriétés suivantes :
      •
      Changer la légende du champ. Voir Pour renommer une légende.
      •
      Définir le style de la bordure du champ. Voir Pour définir le style de la bordure.
      •
      Rendre le champ visible ou invisible, ou le masquer. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Définir le paramètre régional associé au champ. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Spécifier le format de peigne du champ. Voir Pour spécifier le format de peigne du champ de date/heure.
      •
      Demander à LiveCycle Designer de se baser sur la longueur horizontale du champ de texte pour déterminer le nombre de caractères et de chiffres admis.
      •
      Définir le format d'affichage.
      •
      Définir le format de saisie de la date.
      •
      Spécifier la valeur initiale par défaut à afficher.
      •
      Définir une propriété d'exécution (par exemple, insérer la date et l'heure auxquelles le formulaire est rendu).
      •
      Définir le modèle de validation.
      •
      Choisir d'afficher la date, l'heure ou les deux.
      •
      Définir un modèle de liaison des données.
      •
      Spécifier la méthode de liaison pour le stockage et la restauration des données liées.
Le champ Date/Heure prend en charge les scripts et les calculs. Si l'utilisateur est appelé à entrer des données, vous pouvez déterminer si la saisie d'informations est facultative ou obligatoire et définir le texte d'invite approprié. Toutes les données entrées par l'utilisateur peuvent être validées par un script.
Voir aussi
A propos des formats et des valeurs de format
Propriétés de la palette Disposition
Propriétés de la palette Bordure
Champs de date/heure
Propriétés des champs de date/heuredans le panneau Champ
Propriétés des champs de date/heure dans le panneau Valeur
Propriétés des champs de date/heure dans le panneau Liaison


Pour ajouter le champ de la date actuelle

Vous pouvez utiliser un champ date/heure pour afficher automatiquement la date actuelle grâce à l'option Propriété d'exécution du panneau Valeur dans la palette Objet.
lorsque vous utilisez un champ de date actuelle, la date est mise à jour en fonction de la date courante du système chaque fois qu’un utilisateur ouvre le formulaire.
1.
Dans la palette Bibliothèque, cliquez sur la catégorie Standard et faites glisser un objet de champ de date/heure sur la conception de formulaire.
2.
Dans la palette Objet, cliquez sur l'onglet Valeur et, dans la liste Type, choisissez Calculé - Lecture seule.
3.
Sélectionnez l'option Propriété d'exécution.
4.
Affichez le formulaire dans le panneau Aperçu PDF.
Voir aussi
Aperçu des champs de date et d'heure
Propriétés des champs de date/heure dans le panneau Valeur


Pour définir le comportement du champ date/heure

1.
Cliquez sur l'onglet Valeur de la palette Objet. Sélectionnez l'une des options suivantes :
      •
      Pour laisser aux utilisateurs le choix de saisir des données, choisissez Entré par l'utilisateur - Facultatif.
      •
      Pour inviter les utiliser à saisir des données et indiquer qu'il est recommandé de compléter le champ, choisissez Entré par l'utilisateur - Recommandé et entrez un message personnalisé dans la zone Message d'état vide.
      •
      Pour demander aux utilisateurs de saisir des données et indiquer qu'il est obligatoire de compléter le champ, choisissez Entré par l'utilisateur - Obligatoire et entrez un message personnalisé dans la zone Message d'état vide.
      •
      Pour configurer le champ en lecture seule et calculer et afficher la valeur de donnée par le biais d'un script joint , choisissez Calculé - Lecture seule. L'utilisateur n'a pas la possibilité de modifier la valeur calculée.
      •
      Pour autoriser la modification du champ et calculer et afficher une valeur de donnée par le biais d'un script joint , choisissez Calculé - L’utilisateur peut remplacer. L'utilisateur peut changer la valeur si le script de calcul accepte les saisies. Si l'utilisateur change la valeur, le message personnalisé que vous avez défini dans la zone Message de remplacement s'affiche.
      •
      Pour configurer le champ en lecture seule et afficher une valeur de donnée résultant d'une fusion ou d'un calcul au moment de l'exécution, choisissez Lecture seule. Les utilisateurs ne peuvent pas modifier la valeur.
2.
Si la valeur est recommandée ou obligatoire, tapez un message dans la zone Message d'état vide.
3.
Si la valeur doit être calculée, joignez le script de calcul à l'objet à l'aide de l'éditeur de script.
4.
(Facultatif) Si la valeur calculée peut être remplacée, saisissez un message dans la zone Message de remplacement.
vous pouvez remplir un modèle de validation ou un message de script de manière dynamique à l'aide d'une valeur issue d'une source de données. Vous serez ainsi assuré que les utilisateurs saisissent la valeur correcte dans le champ.
Voir aussi
Aperçu des champs de date et d'heure
Pour définir une valeur par défaut
Pour remplir de façon dynamique un message de modèle de validation
Pour remplir de façon dynamique un message de script de validation
Propriétés des champs de date/heure dans le panneau Valeur


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des champs de date et d'heure > Pour définir les propriétés de liaison personnalisée d’un champ de date/heure

Pour définir les propriétés de liaison personnalisée d’un champ de date/heure

Les options de liaison permettent de développer un formulaire qui capture les données pour les infrastructures de l'entreprise ou d'utiliser une source de données externe pour remplir le formulaire à l'exécution. Définissez les propriétés de liaison de données dans le panneau Liaison de la palette Objet.
1.
Sélectionnez le champ de date/heure.
2.
Activez le formulaire pour établir la connexion à la source de données lorsque le formulaire est ouvert.
3.
Liez le champ au noeud de données correspondant. Pour plus d'informations sur la liaison des objets à une source de données, voir A propos de la liaison de champs à une source de données.
Voir aussi
Aperçu des champs de date et d'heure
Propriétés des champs de date/heure dans le panneau Liaison


Pour spécifier les données à afficher dans le champ de date/heure

Vous pouvez choisir d'afficher la date, l'heure ou les deux.
1.
Dans la palette Objet, cliquez sur l'onglet Liaison.
2.
Dans la zone Format des données, spécifiez les éléments à afficher dans le champ :
    • Date
Indique l'objet sous forme d'une date.
    • Heure
Indique l'objet sous forme d'une heure.
    • Date et heure
Indique l'objet sous forme d'une date et d'une heure.
Voir aussi
Aperçu des champs de date et d'heure
Propriétés des champs de date/heure dans le panneau Liaison


Pour spécifier le format de peigne du champ de date/heure

Utilisez ce format pour séparer les nombres ajoutés aux champs de date/heure par des lignes.
1.
Cliquez sur l'onglet Champ de la palette Objet.
2.
Sélectionnez Bande de caractères pour insérer des lignes de séparation entre chaque nombre dans le champ de date/heure.
3.
Précisez combien de nombres vous souhaitez séparer par des lignes dans le champ de date/heure.
Voir aussi
Aperçu des champs de date et d'heure
Propriétés des champs de date/heuredans le panneau Champ


Pour limiter les nombres saisis dans les champs de date/heure

Vous pouvez limiter le nombre de chiffres figurant dans le champ de date/heure en demandant à LiveCycle Designer de se baser sur la longueur horizontale du champ de date/heure pour déterminer le nombre de chiffres admis.
      *
      Dans la palette Objet, cliquez sur l'onglet Champ, puis sélectionnez l'option Limiter la longueur à la zone visible.
Voir aussi
Aperçu des champs de date et d'heure
Propriétés des champs de date/heuredans le panneau Champ


Utilisation de champs de valeurs décimales et numériques

Aperçu des champs de valeurs décimales et numériques
Aperçu des champs numériques
Pour définir l'alignement (point décimal) de la base des valeurs numériques
Pour définir le comportement du champ de valeur décimale ou numérique
Pour définir les propriétés de liaison personnalisée d’un champ décimal ou numérique
Pour spécifier le format des données pour les champs numériques
Pour limiter le nombre de chiffres saisis dans les champs de valeurs décimales et numériques
Pour exécuter un calcul sur des champs décimaux à l'aide de JavaScript
Pour spécifier le format de peigne pour les champs décimaux et numériques


Aperçu des champs de valeurs décimales et numériques

Les champs de valeurs décimales s'apparentent beaucoup aux champs de valeurs numériques. Le tableau ci-dessous décrit les différences qui existent entre ces champs.

Champ

Description
Champ décimal
Contient des nombres au format décimal.
Vous pouvez définir le nombre maximum de chiffres de début et de fin.
Vous pouvez définir un modèle d'affichage afin de limiter la valeur formatée aux chiffres de début et de fin.
Il est impossible de spécifier un format de données pour un champ décimal ; il est toujours enregistré au format décimal.
Par défaut, la valeur formatée contient deux chiffres suivis de la base décimale.
Champs numériques
Affiche des nombres à virgule flottante ou entiers.
Vous ne pouvez pas définir le nombre maximum de chiffres de début et de fin.
Vous pouvez définir un modèle de données et un format de données (à virgule flottante ou entiers).
La valeur formatée ne contient que deux chiffres après la base.
Utilisez le champ de valeur décimale dans les cas suivants :
      •
      Pour définir le nombre de chiffres de début ou de fin.
      •
      Pour conserver précisément la valeur des nombres entiers ou décimaux saisis antérieurement (en s'assurant que l'option Limiter les chiffres de fin est désélectionnée) sans arrondi.
Par exemple, un champ, appelé Qté, est placé dans un sous-formulaire qui se répète. A la première occurrence du sous-formulaire, le champ Qté peut avoir la valeur 3 alors qu'à la deuxième occurrence, il peut avoir la valeur 3,123 :
      •
      Si l'option Limiter les chiffres de fin a la valeur 2, le premier chiffre est enregistré sous 3 (les 0 de fin sont supprimés) et le second chiffre est enregistré sous 3,12 (le chiffre est arrondi).
      •
      Si l'option Limiter les chiffres de fin est désélectionnée, les deux chiffres sont enregistrés tels qu'ils ont été entrés (le premier chiffre est enregistré sous 3 et le deuxième chiffre sous 3,123).
Pour en savoir plus sur les champs de valeurs décimales, voir la rubrique relative aux champs numériques. En effet, de nombreuses options sont identiques.
pour utiliser un objet de champ décimal dans un formulaire interactif, vous devez disposer d'Adobe Reader 6.0.3 (ou version ultérieure).
Voir aussi
Aperçu des champs numériques
Pour exécuter un calcul sur des champs décimaux à l'aide de JavaScript
Formats numériques


Aperçu des champs numériques

Si vous souhaitez que votre formulaire accepte et affiche des nombres entiers ou en virgule flottante, y compris des valeurs monétaires, prévoyez un champ numérique dans le formulaire. Vous pouvez formater la valeur d'un champ numérique et l'afficher selon des formats prédéfinis et selon le paramètre régional défini pour le champ.
Après avoir inséré un champ numérique dans votre formulaire, vous pouvez définir le texte de sa légende et manipuler ses propriétés dans les panneaux Champ, Valeur et Liaison de la palette Objet. Vous pouvez définir les propriétés suivantes :
      •
      Changer la légende du champ. Voir Pour renommer une légende.
      •
      Définir le style de la bordure du champ. Voir Pour définir le style de la bordure.
      •
      Rendre le champ visible ou invisible, ou le masquer. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Définir le paramètre régional associé au champ. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Spécifier le format de peigne du champ. Voir Pour spécifier le format de peigne pour les champs décimaux et numériques.
      •
      Demander à LiveCycle Designer de se baser sur la longueur horizontale du champ pour déterminer le nombre de caractères admis.
      •
      Définir le format d'affichage.
      •
      Définir le format de saisie.
      •
      Spécifier la valeur initiale à afficher.
      •
      Définir une propriété d'exécution (par exemple, l'insertion du numéro de la page rendue).
      •
      Définir le modèle de validation.
      •
      Déterminer si le champ accepte la virgule flottante ou les valeurs entières.
      •
      Définir un modèle de liaison des données.
      •
      Spécifier la méthode de liaison pour le stockage et la restauration des données liées.
Il est possible d'associer des scripts et des calculs aux champs numériques. Si l'utilisateur est appelé à entrer des données, vous pouvez déterminer si la saisie d'informations est facultative ou obligatoire et définir le texte d'invite approprié. Toutes les données entrées par l'utilisateur peuvent être validées par un script.
la valeur maximale d'un champ numérique est de 2 147 483 647 (qu'elle soit saisie par l'utilisateur ou qu'elle résulte d'un calcul). Sur un ordinateur, il s'agit de la plus grande valeur possible pour un entier signé sur 32 bits.
Voir aussi
Formatage des légendes
A propos des formats et des valeurs de format
Formats numériques
Propriétés de la palette Disposition
Propriétés de la palette Bordure
Propriétés des champs numériques dans le panneau Champ
Propriétés des champs numériques dans le panneau Valeur
Propriétés des champs numériques dans le panneau Liaison


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation de champs de valeurs décimales et numériques > Pour définir l'alignement (point décimal) de la base des valeurs numériques

Pour définir l'alignement (point décimal) de la base des valeurs numériques

1.
Dans le menu de la palette Paragraphe, choisissez Modifier la valeur.
2.
Cliquez sur Alignement de la base [image].
3.
Dans la zone adjacente, indiquez la quantité d'espace à créer entre l'emplacement de la base et le bord droit de la zone remplissable.
4.
Appuyez sur Entrée.
Acrobat 6.0 et Adobe Reader 6.0 ne prennent pas en charge l'alignement de la base. Si vous envisagez d'enregistrer le formulaire en tant que formulaire PDF compatible avec Acrobat 6.0, n'utilisez pas l'alignement de la base. Si vous le faites, les utilisateurs ne peuvent pas modifier les valeurs.
Voir aussi
Propriétés de la palette Paragraphe


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation de champs de valeurs décimales et numériques > Pour définir le comportement du champ de valeur décimale ou numérique

Pour définir le comportement du champ de valeur décimale ou numérique

1.
Dans le panneau Valeur de la palette Objet, sélectionnez l'une des options suivantes dans la liste Type :
      •
      Pour laisser aux utilisateurs le choix de saisir des données, choisissez Entré par l'utilisateur - Facultatif.
      •
      Pour inviter les utiliser à saisir des données et indiquer qu'il est recommandé de compléter le champ, choisissez Entré par l'utilisateur - Recommandé et entrez un message personnalisé dans la zone Message d'état vide.
      •
      Pour demander aux utilisateurs de saisir des données et indiquer qu'il est obligatoire de compléter le champ, choisissez Entré par l'utilisateur - Obligatoire et entrez un message personnalisé dans la zone Message d'état vide.
      •
      Pour configurer le champ en lecture seule et calculer et afficher la valeur de donnée par le biais d'un script joint , choisissez Calculé - Lecture seule. L'utilisateur n'a pas la possibilité de modifier la valeur calculée.
      •
      Pour autoriser la modification du champ et calculer et afficher une valeur de donnée par le biais d'un script joint , choisissez Calculé - L’utilisateur peut remplacer. L'utilisateur peut changer la valeur si le script de calcul accepte les saisies. Si l'utilisateur change la valeur, le message personnalisé que vous avez défini dans la zone Message de remplacement s'affiche.
      •
      Pour configurer le champ en lecture seule et afficher une valeur de donnée résultant d'une fusion ou d'un calcul au moment de l'exécution, choisissez Lecture seule. Les utilisateurs ne peuvent pas modifier la valeur.
2.
Si la valeur est recommandée ou obligatoire, tapez un message dans la zone Message d'état vide.
3.
Si la valeur doit être calculée, joignez le script de calcul à l'objet à l'aide de l'éditeur de script.
4.
(Facultatif) Si la valeur calculée peut être remplacée, saisissez un message dans la zone Message de remplacement.
Voir aussi
Pour définir une valeur par défaut
Pour remplir de façon dynamique un message de modèle de validation
Pour remplir de façon dynamique un message de script de validation
Propriétés des champs numériques dans le panneau Valeur


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation de champs de valeurs décimales et numériques > Pour définir les propriétés de liaison personnalisée d’un champ décimal ou numérique

Pour définir les propriétés de liaison personnalisée d’un champ décimal ou numérique

Les options de liaison permettent de développer un formulaire qui capture les données pour les infrastructures de l'entreprise ou d'utiliser une source de données externe pour remplir le formulaire à l'exécution. Définissez les propriétés de liaison de données dans le panneau Liaison de la palette Objet.
1.
Sélectionnez le champ.
2.
Activez le formulaire pour établir la connexion à la source de données lorsque le formulaire est ouvert.
3.
Liez le champ au noeud de données correspondant. Pour plus d'informations sur la liaison des objets à une source de données, voir A propos de la liaison de champs à une source de données.
Voir aussi
Propriétés des champs numériques dans le panneau Liaison


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation de champs de valeurs décimales et numériques > Pour spécifier le format des données pour les champs numériques

Pour spécifier le format des données pour les champs numériques

Les champs numériques peuvent enregistrer des données à virgule flottante ou des entiers. Par défaut, le format d'enregistrement est la virgule flottante.
Par défaut, les données numériques d'un champ décimal sont uniquement enregistrées avec un maximum de deux chiffres après la décimale. Les données après la deuxième valeur décimale sont arrondies.
1.
Dans la palette Objet, cliquez sur l'onglet Liaison.
2.
Sélectionnez le format voulu dans la liste Format des données :
      •
      Pour définir le format des nombres sous forme d'une représentation en trois parties d'un nombre contenant une base, sélectionnez Flottant.
      •
      Pour définir le nombre comme une séquence de chiffres de 0 à 9 précédés d'un signe moins, sélectionnez Entier.
Voir aussi
Pour définir les propriétés de liaison personnalisée d’un champ décimal ou numérique
Pour spécifier un modèle de données
Propriétés des champs numériques dans le panneau Liaison
Formats numériques


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation de champs de valeurs décimales et numériques > Pour limiter le nombre de chiffres saisis dans les champs de valeurs décimales et numériques

Pour limiter le nombre de chiffres saisis dans les champs de valeurs décimales et numériques

Vous pouvez limiter le nombre de chiffres figurant dans les champs de valeurs décimales et numériques en demandant à LiveCycle Designer de se baser sur la longueur horizontale du champ pour déterminer le nombre de chiffres admis.
      *
      Dans la palette Objet, cliquez sur l'onglet Champ, puis sélectionnez l'option Limiter la longueur à la zone visible.
Voir aussi
Aperçu des champs de valeurs décimales et numériques
Aperçu des champs numériques
Propriétés des champs numériques dans le panneau Champ
Propriétés des champs décimaux dans le panneau Champ


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation de champs de valeurs décimales et numériques > Pour exécuter un calcul sur des champs décimaux à l'aide de JavaScript

Pour exécuter un calcul sur des champs décimaux à l'aide de JavaScript

Vous pouvez effectuer des calculs sur des champs de valeurs décimales à l'aide de FormCalc. Cependant, si l'option Limiter les chiffres de fin est désélectionnée et que vous souhaitez utiliser JavaScript pour le calcul sur des champs de valeurs décimales, vous devez utiliser un script. Pour obtenir un niveau élevé de précision, LiveCycle Designer enregistre la valeur des champs décimaux sous forme d'une chaîne. Le script indique que le champ décimal est un nombre.
Par exemple, votre conception de formulaire contient trois champs décimaux. Le premier s'appelle a, le deuxième b et le troisième Total. Vous souhaitez effectuer un calcul qui additionne a et b.
1.
Si l'éditeur de script n'est pas affiché à l'écran, choisissez Fenêtre > Editeur de script.
2.
(Facultatif) Faites glisser la barre de la palette Editeur de script jusqu'à la taille de palette requise.
3.
Sélectionnez le champ décimale à utiliser pour le calcul.
4.
Sélectionnez calculate dans la liste Afficher, JavaScript dans la liste Langage et Client dans la liste Exécuter sur.
5.
Dans le champ Source du script, saisissez le script suivant :

Total.rawValue = Number(a.rawValue) + Number (b.rawValue)
      •
      Total est le nom du champ décimal à utiliser pour le calcul.
      •
      a est le premier champ décimal.
      •
      b est le deuxième champ décimal.
6.
Cliquez sur Insérer les changements dans la source du script pour ajouter le script à votre formulaire.
7.
Affichez le formulaire dans le panneau Aperçu PDF.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation de champs de valeurs décimales et numériques > Pour spécifier le format de peigne pour les champs décimaux et numériques

Pour spécifier le format de peigne pour les champs décimaux et numériques

Utilisez ce format pour séparer les caractères et les nombres ajoutés aux champs décimaux et numériques par des lignes.
1.
Cliquez sur l'onglet Champ de la palette Objet.
2.
Sélectionnez Bande de caractères pour insérer des lignes de séparation entre chaque nombre dans le champ décimal ou numérique.
3.
Précisez combien de nombres vous souhaitez séparer par des lignes dans le champ décimal ou numérique.
Voir aussi
Aperçu des champs de valeurs décimales et numériques
Aperçu des champs numériques
Propriétés des champs numériques dans le panneau Champ
Propriétés des champs décimaux dans le panneau Champ


Utilisation des listes déroulantes et des zones de liste

Aperçu des listes déroulantes et des zones de liste
Pour spécifier la liste des options d'une liste déroulante ou d'une zone de liste
Pour définir le comportement d'une liste déroulante ou d'une zone de liste
Pour afficher une sélection par défaut dans la liste déroulante ou la zone de liste
Pour définir des propriétés de liaison personnalisée d'une liste déroulante ou d'une zone de liste
Pour spécifier les valeurs des éléments d'une liste déroulante ou d'une zone de liste


Aperçu des listes déroulantes et des zones de liste

Les listes déroulantes et les zones de liste offrent aux utilisateurs la possibilité de sélectionner une option parmi celles qui sont proposées. Les choix sont représentés par du texte. Vous définissez les options par défaut.

Liste déroulante

Zone de liste
L'utilisateur doit ouvrir la liste pour voir tous les choix.
Le nombre d'éléments dans une liste n'est pas limité. Lorsque la taille d'une zone de liste ne permet pas de voir tous les éléments qu'elle contient, le système affiche une barre de défilement verticale.
Autorise l'utilisateur à entrer des valeurs.
Interdit la saisie de valeurs par l'utilisateur.
Contrairement aux cases à cocher et aux boutons radio, les listes déroulantes et les zones de liste permettent d'insérer des données de taille variable et différents types d'options. En cliquant sur la flèche de la liste déroulante, vous affichez l'ensemble complet des options et, en cliquant sur l'une des options, vous ne sélectionnez que cette option. Lorsque l'aspect d'un formulaire ne permet pas l'utilisation de cases à cocher ou de boutons radio, utilisez une zone de liste.
Après avoir inséré une liste déroulante ou une zone de liste dans votre formulaire, vous pouvez définir le texte de sa légende et manipuler ses propriétés dans les panneaux Champ, Valeur et Liaison de la palette Objet. Vous pouvez définir les propriétés suivantes :
      •
      Changer la légende de la liste. Voir Pour renommer une légende.
      •
      Définir le style de la bordure de la liste. Voir Pour définir le style de la bordure.
      •
      Rendre la liste visible ou invisible, ou la masquer. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Définir le paramètre régional associé au champ. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Définir les éléments de la liste et identifier la sélection par défaut.
      •
      Trier les éléments par ordre croissant ou décroissant.
      •
      Permettre ou non la saisie de données (listes déroulantes uniquement).
      •
      Rendre la liste visible ou invisible, ou la masquer.
      •
      Définir le paramètre régional associé au champ.
      •
      Spécifier les valeurs de données personnalisées pour chaque élément de la liste.
      •
      Spécifier la méthode de liaison pour le stockage et la restauration des données liées.
vous pouvez remplir une liste déroulante ou une zone de liste de manière dynamique à l'aide de valeurs issues d'une source de données.
Voir aussi
A propos des objets
Pou remplir de façon dynamique une liste déroulante ou une zone de liste
Propriétés de la palette Disposition
Propriétés de la palette Bordure
Propriétés des listes déroulantes dans le panneau Champ
Propriétés des listes déroulantes dans le panneau Valeur
Propriétés des listes déroulantes dans le panneau Liaison
Propriétés des zones de liste dans le panneau Champ
Propriétés des zones de liste dans le panneau Valeur
Propriétés des zones de liste dans le panneau Liaison


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des listes déroulantes et des zones de liste > Pour spécifier la liste des options d'une liste déroulante ou d'une zone de liste

Pour spécifier la liste des options d'une liste déroulante ou d'une zone de liste

Vous pouvez compléter la liste déroulante ou la zone de liste à partir du panneau Champ de la palette Objet.
vous pouvez remplir une liste déroulante de manière dynamique à l'aide de valeurs issues d'une source de données.
1.
Dans la palette Objet, cliquez sur l'onglet Champ et effectuez l'une des opérations suivantes :
      •
      Cliquez deux fois dans la zone située en dessous de l'en-tête de colonne Texte de la zone Articles de liste.
      •
      Cliquez sur le bouton Ajouter [image].
2.
Tapez le texte correspondant à la première option et appuyez sur Entrée.
3.
Tapez le texte correspondant à l'option suivante et appuyez sur Entrée.
4.
Recommencez l'étape 3 pour chacune des options que vous voulez ajouter à la liste.
5.
Pour modifier l'ordre des éléments dans la liste, sélectionnez la valeur à déplacer et cliquez sur les boutons Monter [image] ou Descendre [image].
6.
Pour supprimer un élément de la liste, sélectionnez-le et cliquez sur le bouton Supprimer [image].
7.
Pour trier la liste par ordre croissant, sélectionnez Tri croissant [image].
8.
Pour trier la liste par ordre décroissant, sélectionnez Tri décroissant [image].
9.
Pour autoriser les utilisateurs à spécifier un élément qui ne se trouve pas dans la liste (uniquement dans le cas d'une liste déroulante), sélectionnez l'option Permettre la saisie de texte personnalisé.
Voir aussi
Pou remplir de façon dynamique une liste déroulante ou une zone de liste
Propriétés des listes déroulantes dans le panneau Champ
Propriétés des zones de liste dans le panneau Champ


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des listes déroulantes et des zones de liste > Pour définir le comportement d'une liste déroulante ou d'une zone de liste

Pour définir le comportement d'une liste déroulante ou d'une zone de liste

1.
Cliquez sur l'onglet Valeur de la palette Objet. Dans la zone Type, sélectionnez l'une des options suivantes :
      •
      Pour laisser aux utilisateurs le choix de saisir des données, choisissez Entré par l'utilisateur - Facultatif.
      •
      Pour inviter les utiliser à saisir des données et indiquer qu'il est recommandé de compléter le champ, choisissez Entré par l'utilisateur - Recommandé et entrez un message personnalisé dans la zone Message d'état vide.
      •
      Pour demander aux utilisateurs de saisir des données et indiquer qu'il est obligatoire de compléter le champ, choisissez Entré par l'utilisateur - Obligatoire et entrez un message personnalisé dans la zone Message d'état vide.
      •
      Pour configurer le champ en lecture seule et calculer et afficher la valeur de donnée par le biais d'un script joint , choisissez Calculé - Lecture seule. L'utilisateur n'est pas autorisé à modifier la valeur calculée.
      •
      Pour autoriser la modification du champ et calculer et afficher une valeur de donnée par le biais d'un script joint , choisissez Calculé - L’utilisateur peut remplacer. L'utilisateur peut changer la valeur si le script de calcul accepte les saisies. Si l'utilisateur change la valeur, le message personnalisé que vous avez défini dans la zone Message de remplacement s'affiche.
      •
      Pour configurer le champ en lecture seule et afficher une valeur de donnée résultant d'une fusion ou d'un calcul au moment de l'exécution, choisissez Lecture seule. L'utilisateur n'est pas autorisé à modifier la valeur.
2.
Si la valeur est recommandée ou obligatoire, tapez un message dans la zone Message d'état vide.
3.
Si la valeur doit être calculée, joignez le script de calcul à l'objet à l'aide de l'éditeur de script.
4.
(Facultatif) Si la valeur calculée peut être remplacée, saisissez un message dans la zone Message de remplacement.
Voir aussi
Pour remplir de façon dynamique un message de modèle de validation
Pour remplir de façon dynamique un message de script de validation
Propriétés des listes déroulantes dans le panneau Valeur
Propriétés des zones de liste dans le panneau Valeur


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des listes déroulantes et des zones de liste > Pour afficher une sélection par défaut dans la liste déroulante ou la zone de liste

Pour afficher une sélection par défaut dans la liste déroulante ou la zone de liste

Il est possible de définir une sélection par défaut dans la liste déroulante ou la zone de liste Vous devez d'abord spécifier la liste des options.
1.
Cliquez sur l'onglet Valeur de la palette Objet.
2.
Sélectionnez l'option par défaut dans la liste Valeur par défaut.
la liste Valeur par défaut n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Calculé - L'utilisateur peut remplacer.
Les options de la liste Valeur par défaut correspondent aux articles de liste définis dans le panneau Champ de la palette Objet.
Voir aussi
Pour spécifier la liste des options d'une liste déroulante ou d'une zone de liste
Propriétés des listes déroulantes dans le panneau Valeur
Propriétés des zones de liste dans le panneau Valeur


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des listes déroulantes et des zones de liste > Pour définir des propriétés de liaison personnalisée d'une liste déroulante ou d'une zone de liste

Pour définir des propriétés de liaison personnalisée d'une liste déroulante ou d'une zone de liste

Les options de liaison permettent de concevoir un formulaire qui capture les données pour les infrastructures de l'entreprise ou d'utiliser une source de données externe pour remplir le formulaire à l'exécution. Définissez les propriétés de liaison de données dans le panneau Liaison de la palette Objet.
1.
Sélectionnez la liste déroulante ou la zone de liste.
2.
Activez le formulaire pour établir la connexion à la source de données lorsque le formulaire est ouvert.
3.
Liez la liste au noeud de données correspondant. Pour plus d'informations sur la liaison des objets à une source de données, voir A propos de la liaison de champs à une source de données.
Voir aussi
Pour spécifier les valeurs des éléments d'une liste déroulante ou d'une zone de liste
Propriétés des listes déroulantes dans le panneau Liaison
Propriétés des zones de liste dans le panneau Liaison


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des listes déroulantes et des zones de liste > Pour spécifier les valeurs des éléments d'une liste déroulante ou d'une zone de liste

Pour spécifier les valeurs des éléments d'une liste déroulante ou d'une zone de liste

Chaque élément d’une liste est associé à une valeur de données qui représente cet élément. Par défaut, cette valeur correspond au texte de l'article de liste. Vous pouvez modifier cette valeur pour qu'elle corresponde, par exemple, à des valeurs existantes de la source des données.
Lorsque vous spécifiez des valeurs d'élément pour la première fois, ces valeurs deviennent des entiers, le premier élément étant l'élément 0. Si vous désélectionnez l'option Spécifier les valeurs, les valeurs correspondent à nouveau au texte des éléments de la liste.
vous pouvez remplir une zone de liste de manière dynamique à l'aide de valeurs issues d'une source de données.
1.
Sélectionnez l'objet de liste déroulante ou de zone de liste.
2.
Dans la palette Objet, cliquez sur l'onglet Liaison.
3.
Cochez la case Spécifier les valeurs.
4.
Cliquez deux fois sur la première valeur à modifier.
5.
Saisissez la nouvelle valeur.
6.
Appuyez sur Entrée pour modifier la valeur suivante ou cliquez deux fois sur une autre valeur afin de la modifier.
Voir aussi
A propos des sources de données
Pour définir des propriétés de liaison personnalisée d'une liste déroulante ou d'une zone de liste
Pou remplir de façon dynamique une liste déroulante ou une zone de liste


Utilisation des champs d'image

Aperçu des champs d'image
Pour spécifier une image initiale (par défaut) à lier
Pour incorporer des données image au moment de la création du formulaire
Pour redimensionner une image
Pour définir les propriétés de liaison personnalisée d'un champ d'image


Aperçu des champs d'image

LiveCycle Designer propose deux types d'objets d'image.
      •
      Les objets d'image vous permettent d'ajouter des images en lecture seule que les utilisateurs ne peuvent modifier dans le formulaire. Ce type d'objet s'avère utile pour améliorer l'aspect d'un formulaire. Pour plus d'informations, voir Utilisation d'images.
      •
      Les objets de champ d'image permettent d'ajouter une image modifiable dans un formulaire interactif.
Les champs d'image peuvent être liés à une source de données externes ou faire l'objet d'un script. Ils prennent en charge la fusion de données image externes par le biais d'une liaison. Lorsque la source de données contient une valeur pour un champ d'image, l'image est rendue dans le formulaire. Grâce à cette fonction, il est possible de sélectionner et de charger des images de façon dynamique. Par exemple, un formulaire peut permettre aux utilisateurs de choisir un article dans un catalogue et, par le biais d'un script, d'afficher une image de chacun des articles choisis. Si le formulaire comporte un champ d'image vide, un chemin d'accès identifie l'image à afficher dans le formulaire.
les images interactives d'objets de champ d'image peuvent être mises à jour lorsque le formulaire est ouvert dans Acrobat ou Adobe Reader 7.0. Les images interactives deviennent en lecture seule et ne peuvent plus être mises à jour lorsque le formulaire est ouvert dans Acrobat 6.0 ou Adobe Reader 6.0. Toutefois, grâce à un script dans un formulaire PDF ou HTML interactif créé par LiveCycle Forms, un utilisateur a la possibilité de rappeler le même formulaire avec une image différente.
Les objets de champ d'image acceptent les formats de fichier suivants :
      •
      BMP (Windows Bitmap)
      •
      JPG (Joint Photographic Experts Group, variantes)
      LiveCycle Designer prend en charge les images JPG qui incluent des données de fichiers d'appareils numériques (format EXIF).
      •
      GIF (Graphics Interchange Format)
      Bien que LiveCycle Designer prenne en charge les images GIF, ce n'est pas le cas pour les fichiers GIF animés. LiveCycle Designer prend également en charge la transparence dans les fichiers GIF pour la superposition d'images sur des formulaires.
      •
      PNG (Portable Network Graphics)
      LiveCycle Designer prend en charge la transparence dans les fichiers PNG pour la superposition d'images sur des formulaires.
      •
      TIF (Tagged Image Format)
      LiveCycle Designer prend en charge les images TIF monochromes (1 composante de couleur, profondeur de 1 bit), à niveaux de gris (1 composante de couleur, profondeur de 8 bits), RVB (3 composantes de couleur, profondeur de 8 bits) et Palette (1 composante de couleur, profondeur de 1, 2, 4 et 8 bits).
Il est possible de spécifier une image initiale (par défaut) qui doit être insérée à l'exécution, soit par un nom de fichier, soit par un URL. Au départ, l'image est liée. Cela signifie qu'elle est stockée séparément du formulaire et qu'elle s'affiche à l'ouverture du formulaire. Il est toutefois possible d'incorporer l'image dans le formulaire au moment de la création de celui-ci.
la liaison d'une image ne constitue pas une protection sécurisée des données sensibles. Si les données image sont considérées comme sensibles, vous devez les incorporer au formulaire. En outre, vous avez la possibilité d'utiliser une connexion HTTPS sécurisée conjointement avec l'URL. Cependant, cette connexion protège la transmission des données image tant que les données sont transmises ; elle ne protège pas l'accès à l'image (c'est-à-dire qu'elle n'effectue aucune authentification).
Après avoir inséré un champ d’image dans votre formulaire, définissez ses propriétés dans la palette Objet. Vous pouvez notamment :
      •
      Changer la légende du champ. Voir Pour renommer une légende.
      •
      Définir le style de la bordure du champ. Voir Pour définir le style de la bordure.
      •
      Rendre la liste visible ou invisible, ou la masquer. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Définir le paramètre régional associé au champ. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Incorporer l'image dans le formulaire.
      •
      Mettre l'image à l'échelle.
      •
      Vous pouvez spécifier le chemin d'accès à l'image initiale par défaut et/ou une méthode de liaison pour le stockage et la récupération des données de l'image liée.
N’oubliez pas que si le fichier image ou le lien vers le fichier image se trouve dans le fichier de données, l’image ne s’affiche que dans le rendu du formulaire. Elle n’est pas visible pendant que vous êtes en train de concevoir le formulaire. De même, si vous songez à utiliser le formulaire hors ligne, choisissez l’option Incorporer les données image dans l'onglet Champ de la palette Objet, afin que toutes les composantes du formulaire soient disponibles.
Voir aussi
Propriétés des champs d’image dans le panneau Champ
Propriétés des champs d’image dans le panneau Liaison


Pour spécifier une image initiale (par défaut) à lier

1.
Cliquez sur l'onglet Champ de la palette Objet.
2.
Effectuez l'une des opérations suivantes :
      •
      Si vous connaissez l'emplacement du fichier image, dans la zone URL, indiquez l'URL du fichier image et appuyez sur Entrée.
      •
      Pour désigner l'emplacement du fichier image, cliquez sur le bouton Parcourir [image] à droite de la zone URL, naviguez jusqu'au fichier image que vous voulez insérer et cliquez sur Ouvrir.
pour utiliser des chemins d'accès relatifs en vue de récupérer des images liées à l'ouverture du formulaire, les fichiers image doivent être stockés dans un dossier accessible aux utilisateurs. Si LiveCycle Forms est disponible, le chemin d'accès doit être relatif à LiveCycle Forms.
Voir aussi
Propriétés des champs d’image dans le panneau Champ


Pour incorporer des données image au moment de la création du formulaire

      *
      Cliquez sur l'onglet Champ de la palette Objet, puis sélectionnez Incorporer les données image.
Lorsque vous incorporez une image dans le formulaire, une copie de ses données est stockée dans le formulaire. Si le champ d'image est utilisé pour charger dynamiquement des images lors du rendu du formulaire, ne sélectionnez pas l'option Incorporer les données image.
si vous utilisez l'objet de code à barres de formulaires pour support papier, ne sélectionnez pas l'option Incorporer les données image à moins d'avoir attribué au code à barres une collection excluant les champs d'image. L'objet de code à barres de formulaires pour support papier ne peut pas contenir toutes les données d'image imbriquée.
Voir aussi
Propriétés des champs d’image dans le panneau Champ
Pour créer une collection d'objets de formulaire


Pour redimensionner une image

1.
Cliquez sur l'onglet Champ de la palette Objet.
2.
Dans la zone Taille, sélectionnez l'une des options proposées pour le traitement de l'image lorsque celle-ci est chargée :
      •
      Pour redimensionner l'image dans l'objet, veillez tout d'abord à en conserver les proportions, puis sélectionnez Ajuster l'image proportionnellement.
      •
      Pour adapter l'image aux dimensions de l'objet, sélectionnez Ajuster l'image à l'échelle du rectangle. Les proportions de l'image ne sont pas conservées.
      •
      Pour conserver la taille réelle de l'image, sélectionnez Utiliser la taille d'origine. L'image n'est pas redimensionnée.
Voir aussi
Propriétés des champs d’image dans le panneau Champ


Pour définir les propriétés de liaison personnalisée d'un champ d'image

Vous pouvez utiliser les options de liaison pour développer un formulaire qui capture les données pour les infrastructures de l'entreprise et/ou utiliser une source de données externe pour remplir le formulaire à l'exécution.
1.
Sélectionnez le champ d'image.
2.
Activez le formulaire pour établir la connexion à la source de données lorsque le formulaire est ouvert.
3.
Liez le champ au noeud de données correspondant. Pour plus d'informations sur la liaison des objets à une source de données, voir A propos de la liaison de champs à une source de données.
Voir aussi
Aperçu des champs d'image
Propriétés des champs d’image dans le panneau Liaison


Utilisation d'images

Aperçu des images
Pour spécifier l'image à lier
Pour incorporer une image dans un formulaire
Pour redimensionner l'image


Aperçu des images

Si vous souhaitez améliorer l'aspect d'un formulaire, vous pouvez lui ajouter des images. Utilisez les objets d’image pour afficher des images comme des logos, des icônes, des illustrations et des photos. Un objet d'image constitue un élément graphique que les utilisateurs ne peuvent pas modifier. Les objets d'image acceptent les formats de fichier suivants :
      •
      BMP (Windows Bitmap)
      •
      Encapsulated Postscript (EPS)
      •
      JPG (Joint Photographic Experts Group, variantes)
      LiveCycle Designer prend en charge les images JPG qui incluent des données de fichiers d'appareils numériques (format EXIF).
      •
      GIF (Graphics Interchange Format)
      Bien que LiveCycle Designer prenne en charge les images GIF, ce n'est pas le cas pour les fichiers GIF animés. LiveCycle Designer prend également en charge la transparence dans les fichiers GIF pour la superposition d'images sur des formulaires.
      •
      PNG (Portable Network Graphics)
      LiveCycle Designer prend en charge la transparence dans les fichiers PNG pour la superposition d'images sur des formulaires.
      •
      TIF (Tagged Image Format)
      LiveCycle Designer prend en charge les images TIF monochromes (1 composante de couleur, profondeur de 1 bit), à niveaux de gris (1 composante de couleur, profondeur de 8 bits), RVB (3 composantes de couleur, profondeur de 8 bits) et Palette (1 composante de couleur, profondeur de 1, 2, 4 et 8 bits).
Il est possible de spécifier l'image à insérer à l'aide d'un nom de fichier ou d'un URL. Par défaut, l'image est liée, ce qui signifie qu'elle est stockée séparément du formulaire et qu'elle s'affiche à l'ouverture du formulaire. Vous pouvez également incorporer l'image dans le formulaire.
la liaison d'une image ne constitue pas une protection sécurisée des données sensibles. Si l'image est considérée comme sensible, il est préférable de l'incorporer au formulaire. En outre, vous avez la possibilité d'utiliser une connexion HTTPS sécurisée conjointement avec l'URL. Cependant, cette connexion protège la transmission des données image tant que les données sont transmises ; elle ne protège pas l'accès à l'image (c'est-à-dire qu'elle n'effectue aucune authentification).
Après avoir inséré un objet d'image dans votre formulaire, définissez ses propriétés dans la palette Objet. Vous pouvez notamment :
      •
      Incorporer l'image dans le formulaire.
      •
      Mettre l'image à l'échelle.
      •
      Rendre la liste visible ou invisible, ou la masquer. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
Voir aussi
Propriétés des images dans le panneau Dessin


Pour spécifier l'image à lier

      *
      Dans la palette Objet, utilisez l'une des méthodes suivantes :
      •
      Si vous connaissez l'emplacement du fichier image, dans la zone URL, indiquez l'URL du fichier image et appuyez sur Entrée.
      •
      Pour désigner l'emplacement du fichier image, cliquez sur le bouton Parcourir [image] à droite de la zone URL, naviguez jusqu'au fichier image que vous voulez insérer et cliquez sur Ouvrir.
pour utiliser des chemins d'accès relatifs en vue de récupérer des images liées à l'ouverture du formulaire, les fichiers image doivent être stockés dans un dossier accessible aux utilisateurs. Si LiveCycle Forms est disponible, le chemin d'accès doit être relatif à LiveCycle Forms.
Voir aussi
Propriétés des images dans le panneau Dessin


Pour incorporer une image dans un formulaire

      *
      Dans la palette Objet, sélectionnez l'option Incorporer les données image.
lorsque vous incorporez l'image dans le formulaire, une copie de ses données est stockée dans le formulaire.
Voir aussi
Propriétés des images dans le panneau Dessin


Pour redimensionner l'image

1.
Cliquez sur l'onglet Champ de la palette Objet.
2.
Dans la zone Taille, sélectionnez l'une des options proposées pour le traitement de l'image lorsque celle-ci est chargée :
      •
      Pour redimensionner l'image dans l'objet, veillez tout d'abord à en conserver les proportions, puis sélectionnez Ajuster l'image proportionnellement.
      •
      Pour adapter l'image aux dimensions de l'objet, sélectionnez Ajuster l'image à l'échelle du rectangle. Les proportions de l'image ne sont pas conservées.
      •
      Pour conserver la taille réelle de l'image, sélectionnez Utiliser la taille d'origine. L'image n'est pas redimensionnée.
Voir aussi
Propriétés des images dans le panneau Dessin


Utilisation des codes à barres de formulaires pour support papier

Aperçu des codes à barres de formulaires pour support papier
Principe des codes à barres de formulaires pour support papier
Pour spécifier un libellé unique pour le code à barres de formulaires pour support papier
Pour générer un libellé pour le code à barres de formulaires pour support papier
Pour spécifier la symbologie pour le code à barres de formulaires pour support papier
Pour spécifier la méthode de numérisation du code à barres de formulaires pour support papier
Pour personnaliser les paramètres de décodage d'un code à barres de formulaires pour support papier
Pour contrôler le codage des données par un code à barres de formulaires pour support papier
Pour créer un script personnalisé pour le codage des données pour un code à barres
Conseils de conception sur l’utilisation d’un code à barres de formulaires pour support papier


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des codes à barres de formulaires pour support papier > Aperçu des codes à barres de formulaires pour support papier

Aperçu des codes à barres de formulaires pour support papier

Un code à barres de formulaires pour support papier permet de capturer électroniquement des données fournies par les utilisateurs dans un formulaire PDF interactif. Lorsqu'un utilisateur final remplit le formulaire à l'aide d'Adobe Reader ou Acrobat, le code à barres est mis à jour automatiquement de manière à coder les données fournies par l'utilisateur. Celui-ci peut alors renvoyer le formulaire rempli en l'imprimant et en vous le remettant manuellement ou en le renvoyant par télécopie ou courrier électronique. Lorsque vous recevez les données fournies par l'utilisateur, vous pouvez les décoder à l'aide d'un périphérique de numérisation.
Pour utiliser l'objet de code à barres de formulaires pour support papier, votre entreprise doit avoir mis en place LiveCycle Barcoded Forms. Pour plus de détails sur LiveCycle Barcoded Forms et sur la manière de diffuser ou de traiter les formulaires contenant un code à barres de formulaires pour support papier, reportez-vous au guide Création et traitement des formulaires à codes à barres 2D.
Voici un exemple de cycle de production impliquant la solution LiveCycle Barcoded Forms. Au fur et à mesure que l'utilisateur remplit le formulaire, les données sont codées automatiquement dans le code à barres. Lorsque le formulaire est imprimé et que vous en recevez une copie papier, vous pouvez l'extraire à l’aide d’un scanner de codes à barres. Cette manipulation donne des résultats d’une grande précision et aucune saisie supplémentaire n’est nécessaire.
L'utilisation d'un code à barres de formulaires pour support papier élimine la nécessité de saisir manuellement des données ou de traiter les formulaires à l'aide de la méthode de reconnaissance optique des caractères (OCR). Il est possible de réinsérer avec rapidité et précision les données saisies à partir de formulaires à remplir et à imprimer dans le cycle de production électronique, sans craindre de subir des pertes de données dues à des erreurs de numérisation ou de saisie manuelle. Vous pouvez en outre conserver un exemplaire numérique de la transaction, comprenant même les signatures à l’encre.
Une entreprise peut très bien, par exemple, disposer d'un formulaire PDF prêt à être rempli par voie électronique. Cependant, ce formulaire nécessite la signature de l'utilisateur ; il doit donc être imprimé, signé et renvoyé par télécopie ou par messagerie après avoir été rempli. En prévoyant un code à barres de formulaires pour support papier sur le formulaire, vous êtes assuré que les données saisies électroniquement sont codées dans le code à barres. Lorsque le formulaire imprimé est renvoyé, un lecteur de codes à barres analyse toutes les données saisies dans un fichier de données structuré. Seule la signature doit être vérifiée.
vous ne pouvez pas utiliser d'objets code à barres de formulaires pour support papier dans un formulaire enregistré comme formulaire PDF compatible avec Acrobat 6.0. Les utilisateurs qui remplissent un formulaire contenant un code à barres de formulaires pour support papier doivent posséder Acrobat 7.0 ou version ultérieure, ou Adobe Reader 7.0 ou version ultérieure (s'il s'agit de codes à barres PDF 417), ou Acrobat 7.0.5 ou version ultérieure, ou Adobe Reader 7.0.5 ou version ultérieure (s'il s'agit de codes à barres QR Code et DataMatrix) pour permettre au code à barres de coder les données saisies.
Voir aussi
Propriétés des codes à barres de formulaires pour support papier dans le panneau Champ
Propriétés des codes à barres de formulaires pour support papier dans le panneau Valeur
Propriétés de la palette Disposition
Propriétés de la palette Bordure
Propriétés de la palette Accessibilité


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des codes à barres de formulaires pour support papier > Principe des codes à barres de formulaires pour support papier

Principe des codes à barres de formulaires pour support papier

L'objet de code à barres de formulaires pour support papier est un code à barres bidimensionnel (2D), codé par une symbologie standard PDF417, QR Code (Version 2) ou DataMatrix (modèle ECC200). Ce code à barres comprend un script de calcul intelligent permettant d'encoder les données saisies dans les champs d'un formulaire.
Vous devez sélectionner les champs du formulaires à coder avec le code à barres de formulaires pour support papier. Cependant, étant donné que la capacité de stockage des codes à barres est restreinte, ne sélectionnez que les champs requis.
Une fois que vous avez inséré un code à barres de formulaires pour support papier dans votre conception de formulaire, configurez ses propriétés de sorte qu'il fonctionne selon vos attentes et besoins. La palette Objet vous permet de définir les propriétés suivantes du code à barres :
      •
      Libellé du code à barres
      •
      Symbologie codée dans le code à barres
      •
      Méthode de numérisation utilisée pour décoder le code à barres
      •
      Niveau de correction d'erreurs et dimensions (hauteur et largeur) du module du code à barres (lorsque vous choisissez une méthode de numérisation personnalisée)
      •
      Visibilité de l’objet sur le formulaire
      •
      Options de compression des données
      •
      Données du formulaire à inclure dans le code à barres
      •
      Format de données utilisé par le code à barres pour coder les données et les champs inclus
Lorsque vous distribuez votre formulaire fini, les utilisateurs remplissent le formulaire, l'impriment et le renvoient. A leur réception, les données fournies par l'utilisateur sont décodées à l'aide d'un périphérique de numérisation. Pour les codes à barres PDF 417, les formulaires peuvent être remplis avec Acrobat 7.0 ou version ultérieure, ou Adobe Reader 7.0 ou version ultérieure. Les codes à barres QR Code et DataMatrix nécessitent Acrobat 7.0.5 ou version ultérieure, ou Adobe Reader 7.0.5 ou version ultérieure.
pour que vous puissiez utiliser le code à barres de formulaires pour support papier, votre entreprise doit avoir mis en place LiveCycle Barcoded Forms.
Voir aussi
Pour ajouter des objets à une conception de formulaire
Pour contrôler le codage des données par un code à barres de formulaires pour support papier
Propriétés des codes à barres de formulaires pour support papier dans le panneau Champ
Propriétés des codes à barres de formulaires pour support papier dans le panneau Valeur
Propriétés de la palette Disposition
Propriétés de la palette Bordure
Propriétés de la palette Accessibilité


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des codes à barres de formulaires pour support papier > Pour spécifier un libellé unique pour le code à barres de formulaires pour support papier

Pour spécifier un libellé unique pour le code à barres de formulaires pour support papier

1.
Sur la conception de formulaire, sélectionnez le code à barres de formulaires pour support papier.
2.
Dans la palette Objet, cliquez sur l'onglet Champ, désactivez l'option Générer le libellé automatiquement, puis entrez un libellé dans la zone Libellé.
Voir aussi
Propriétés des codes à barres de formulaires pour support papier dans le panneau Champ


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des codes à barres de formulaires pour support papier > Pour générer un libellé pour le code à barres de formulaires pour support papier

Pour générer un libellé pour le code à barres de formulaires pour support papier

1.
Sur la conception de formulaire, sélectionnez le code à barres de formulaires pour support papier.
2.
Dans la palette Objet, cliquez sur l'onglet Champ, puis sélectionnez l'option Générer le libellé automatiquement.
Voir aussi
Propriétés des codes à barres de formulaires pour support papier dans le panneau Champ
Aperçu des codes à barres de formulaires pour support papier
Conseils de conception sur l’utilisation d’un code à barres de formulaires pour support papier


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des codes à barres de formulaires pour support papier > Pour spécifier la symbologie pour le code à barres de formulaires pour support papier

Pour spécifier la symbologie pour le code à barres de formulaires pour support papier

1.
Sur la conception de formulaire, sélectionnez le code à barres de formulaires pour support papier.
2.
Dans l'onglet Champ de la palette Objet, sélectionnez l'une des options suivantes dans la liste Symbologie :
      •
      PDF417
      •
      Code QR
      •
      Grille de données
les utilisateurs finaux qui remplissent un formulaire contenant un code à barres QR Code ou DataMatrix doivent posséder Acrobat 7.0.5 ou version ultérieure, ou Adobe Reader 7.0.5 ou version ultérieure. Le décodage des codes à barres QR Code et DataMatrix est pris en charge par Adobe LiveCycle Barcoded Forms 7.0, mais ne l'est pas par Adobe LiveCycle Barcoded Forms 7.0 Standalone (ST).
Voir aussi
Propriétés des codes à barres de formulaires pour support papier dans le panneau Champ
Aperçu des codes à barres de formulaires pour support papier
Conseils de conception sur l’utilisation d’un code à barres de formulaires pour support papier


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des codes à barres de formulaires pour support papier > Pour spécifier la méthode de numérisation du code à barres de formulaires pour support papier

Pour spécifier la méthode de numérisation du code à barres de formulaires pour support papier

1.
Sur la conception de formulaire, sélectionnez le code à barres de formulaires pour support papier.
2.
Dans l'onglet Champ de la palette Objet, sélectionnez l'une des options suivantes dans la liste Méthode de numérisation :
      •
      Scanner à main
      •
      Serveur de télécopies
      •
      Scanner de document
      •
      Personnaliser
3.
Si vous sélectionnez Personnaliser, vous avez la possibilité en outre de définir des paramètres de décodage personnalisés.
Voir aussi
Propriétés des codes à barres de formulaires pour support papier dans le panneau Champ
Aperçu des codes à barres de formulaires pour support papier
Conseils de conception sur l’utilisation d’un code à barres de formulaires pour support papier


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des codes à barres de formulaires pour support papier > Pour personnaliser les paramètres de décodage d'un code à barres de formulaires pour support papier

Pour personnaliser les paramètres de décodage d'un code à barres de formulaires pour support papier

1.
Sur la conception de formulaire, sélectionnez le code à barres de formulaires pour support papier.
2.
Dans l'onglet Champ de la palette Objet, sélectionnez Personnaliser dans la liste Méthode de numérisation.
3.
Pour modifier les propriétés de décodage, sélectionnez la valeur voulue dans la liste Valeur en regard de la propriété adéquate.
si vous projetez de décoder le code à barres à l'aide d'un scanner à main, évitez de créer des codes à barres dont la largeur est supérieure à quatre pouces. Les codes à barres longs et étroits sont généralement plus indiqués pour les scanners à main.
Voir aussi
Propriétés des codes à barres de formulaires pour support papier dans le panneau Champ
Aperçu des codes à barres de formulaires pour support papier
Conseils de conception sur l’utilisation d’un code à barres de formulaires pour support papier


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des codes à barres de formulaires pour support papier > Pour contrôler le codage des données par un code à barres de formulaires pour support papier

Pour contrôler le codage des données par un code à barres de formulaires pour support papier

Lorsque vous utilisez un objet de code à barres de formulaires pour support papier dans une conception de formulaire, vous devez spécifier le format que le code à barres applique lors de l'encodage des données, ainsi que les données à encoder. Vous pouvez spécifier les types de formats de données suivants :
      •
      XML
      •
      Délimité par tabulation
Chaque option fournit un script pour l'objet de code à barres de formulaires pour support papier qui indique à ce dernier d'appliquer un type de données particulier pour le codage. Le code à barres peut coder tous les champs d'un formulaire, uniquement les données provenant des champs du sous-formulaire parent de l'objet de code à barres ou uniquement les champs que vous spécifiez et que vous enregistrez dans une collection.
Vous pouvez utiliser votre propre script pour coder les données. Pour plus de détails, voir Pour créer un script personnalisé pour le codage des données pour un code à barres.
Pour définir le mode d'acquisition des données par le code à barres de formulaires pour support papier, utilisez les options du panneau Valeur de la palette Objet. Vous pouvez également spécifier si vous souhaitez compresser les données avant le codage.
Pour générer automatiquement un script destiné à coder les données
1.
Sur la conception de formulaire, sélectionnez le code à barres de formulaires pour support papier.
2.
Dans la palette Objet, cliquez sur l'onglet Valeur, puis cochez la case Ecriture de script automatique.
3.
Dans la zone Format, sélectionnez l'une des options suivantes :
      •
      XML
      •
      Délimité par tabulation. (Facultatif) Sélectionnez Inclure les noms des champs et Inclure le libellé.
4.
Dans la zone Application, sélectionnez l'une des options suivantes :
      •
      Intégralité des données du formulaire
      •
      Données de sous-formulaire
      •
      Données de collection. Sélectionnez la collection dans le menu Collection.
Pour compresser les données avant leur codage
1.
Sur la conception de formulaire, sélectionnez le code à barres de formulaires pour support papier.
2.
Dans la palette Objet, cliquez sur l'onglet Valeur, puis cochez la case Compresser les données avant le codage.
Voir aussi
Pour créer un script personnalisé pour le codage des données pour un code à barres
Conseils de conception sur l’utilisation d’un code à barres de formulaires pour support papier
A propos des collections d'objets de formulaire
Propriétés des codes à barres de formulaires pour support papier dans le panneau Valeur
Aperçu des sous-formulaires
A propos des calculs et des scripts


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des codes à barres de formulaires pour support papier > Pour créer un script personnalisé pour le codage des données pour un code à barres

Pour créer un script personnalisé pour le codage des données pour un code à barres

Si vous devez respecter des spécifications gouvernementales ou autres pour le codage des données, il se peut que les options de codage des données prédéfinies dans l'application ne soient pas conformes à vos exigences. L'option Personnaliser permet d'utiliser un script spécifique pour le codage des données. Le script peut être extrêmement simple, tel que le montre l'exemple suivant :
this.rawValue=NumericField1.rawValue
Cela ne signifie pas pour autant qu'il est impossible de rédiger de script plus complexe. En effet, vous pouvez très bien écrire un script qui définit les champs à coder en fonction de conditions spécifiques.
1.
Sur la conception de formulaire, sélectionnez l'objet de code à barres de formulaires pour support papier.
2.
Dans la palette Objet, cliquez sur l'onglet Valeur et désactivez la case Ecriture de script automatique.
3.
Dans l'éditeur de script, vous pouvez modifier l'exemple de script personnalisé ou rédiger votre propre script.
L'exemple de code suivant illustre le script JavaScript permettant de récupérer les valeurs de champs d'un formulaire, de formater une chaîne représentant une occurrence CSV (valeurs séparées par des virgules) contenant les champs de formulaire, et de mettre à jour un code à barres de formulaires pour support papier conçu pour un formulaire PDF interactif. La formulaire contient des champs nommés accountNum, formerFirstName, formerMiddleInitial, formerLastName, newFirstName, newMiddleInitial et newLastName.
// This function ensures that the barcode will update
// when a change is made to any field on the form.
function depends(node)
{
for (var i = 0; i < node.nodes.length; ++i)
{
var child = node.nodes.item(i);
if (child.isContainer)
depends(child);
}
}
// Return a field surrounded by quotes and followed with a separator
function fmtField(fieldName, separator)
{
   var str = "\"" + fieldName.rawValue + "\"" + separator;
   return str;
}
// Force all fields in the form to be updated in the dataset
depends(xfa.form);
// Generate the CSV string that will be encoded in the barcode
var comma = ",";
var newLine = "\n";
var s = fmtField(accountNum, comma);
s += fmtField(formerFirstName, comma)
s += fmtField(formerMiddleInitial, comma);
s += fmtField(formerLastName, comma);
s += fmtField(newFirstName, comma)
s += fmtField(newMiddleInitial, comma);
s += fmtField(newLastName, newLine);
// Assign the string to the barcode for encoding
this.rawValue = s;
Voir aussi
Pour contrôler le codage des données par un code à barres de formulaires pour support papier
Propriétés des codes à barres de formulaires pour support papier dans le panneau Valeur
A propos des calculs et des scripts.


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des codes à barres de formulaires pour support papier > Conseils de conception sur l’utilisation d’un code à barres de formulaires pour support papier

Conseils de conception sur l’utilisation d’un code à barres de formulaires pour support papier

La création d'un code à barres de formulaires pour support papier performant implique la conception d'un code à barres dans lequel les informations sont codées de manière pratique et facilement décodable en informations compréhensibles. Gardez à l'esprit les points suivants lors de la conception d'un code à barres décodable.

Conseil de conception sur les codes à barres

Détails
Concevez un code à barres adapté à sa future utilisation.
Pensez au mode que les utilisateurs finaux choisiront pour vous renvoyer les données personnellement ou à votre centre de traitement. Assurez-vous que le code à barres est conçu pour « survivre » aux opérations d'impression, d'envoi postal, de télécopie et de numérisation.
Choisissez soigneusement l'emplacement du code à barres sur la conception de formulaire.
Vous pouvez placer le code à barres n'importe où dans la conception. Placez toujours le code à barres à un endroit facilement identifiable et numérisable. Conservez un espacement d'au moins un centimètre entre le code à barres et le bord de la feuille afin de vous assurer que le code sera visible sur l'imprimé.
Dimensionnez le code à barres en fonction de la quantité de données à saisir.
La quantité de données pouvant être codée dans un code à barres de formulaires pour support papier est limitée. La taille du code à barres affecte également la quantité de données susceptible d'être codée. Si le code est trop petit pour contenir les données fournies par l'utilisateur, un marqueur rouge s'affiche dans l'angle supérieur droit du code, vous signalant que les données à coder sont trop importantes pour tenir dans le code à barres. Dans ce cas, effectuez l'une des opérations suivantes :
•
Redimensionnez le code à barres en l'agrandissant en fonction de la quantité de données qu'il devra contenir.
•
Pour ce faire, modifiez la taille par défaut des données de certains objets de formulaire tels que les champs de texte. Par exemple, la longueur maximale par défaut de chaque champ de texte est définie sur 255. Cependant, si un champ de texte ne doit contenir que les prénom et nom de famille de la personne, vous pouvez réduire cette limite à 20 ou 50 caractères, ce qui peut éventuellement résoudre le problème de taille du code à barres.
•
L'utilisation simultanée de majuscules et de minuscules et l'utilisation de caractères étendus augmentent la taille des données. Ecrivez un script pour limiter les données aux caractères alphanumériques et aux majuscules.
•
Si des noms de champs sont inclus dans les données, utilisez des noms d'objet plus courts.
•
Divisez le formulaire en sous-formulaires et attribuez certains champs à un sous-formulaire et d'autres à un autre sous-formulaire. Pour chaque sous-formulaire, ajoutez un code à barres de formulaires pour support papier. Cette stratégie vous permet de diviser de grandes quantités de données en plusieurs codes à barres, ce qui vous laisse le champ libre pour coder davantage de données.
N'incorporez pas de données aux champs d'image.
Les codes à barres de formulaires pour support papier ne peuvent pas contenir assez de données pour les incorporer aux images. Si un formulaire contient un objet de champ d'image, ne sélectionnez pas l'option Incorporer les données image, ou excluez l'objet des données des codes à barres. Si le champ d'image est inclus dans les données des codes à barres, le code à barre vous avertit qu'il est impossible de calculer la longueur des données.
Testez le formulaire avant de le distribuer
Il est essentiel de tester le formulaire terminé dans Adobe Reader ainsi que dans Acrobat. La plupart des utilisateurs de ces types de formulaires ne disposent que d'Adobe Reader sur leur ordinateur.
Assurez-vous que les utilisateurs remplissent le formulaire par voie électronique.
Soyez très clair auprès des utilisateurs quant au mode de remplissage du formulaire. En effet, s'ils impriment le formulaire avant de le remplir à la main, le code à barres de formulaires pour support papier ne pourra pas coder les données fournies par l'utilisateur.
Voir aussi
Aperçu des codes à barres de formulaires pour support papier
Principe des codes à barres de formulaires pour support papier
A propos des collections d'objets de formulaire


Utilisation des champs de mot de passe

Aperçu des champs de mot de passe
Pour définir le caractère d'affichage du mot de passe
Pour définir le comportement du champ
Pour définir les propriétés de liaison personnalisée d’un champ de mot de passe
Pour limiter le nombre de caractères dans les champs de mot de passe


Aperçu des champs de mot de passe

Si vous souhaitez contrôler l'accès à un formulaire au moyen d'un mot de passe, ajoutez un champ de mot de passe dans le formulaire. Lorsque l'utilisateur tape une valeur dans le champ de mot de passe, les caractères sont masqués par le caractère d'affichage que vous avez choisi. Au besoin, vous pouvez définir un format de saisie que l'utilisateur doit respecter pour avoir accès au formulaire.
Après avoir inséré un champ de mot de passe dans votre formulaire, vous pouvez définir le texte de sa légende et manipuler ses propriétés dans les panneaux Champ, Valeur et Liaison de la palette Objet. Vous pouvez définir les propriétés suivantes :
      •
      Changer la légende du champ. Voir Pour renommer une légende.
      •
      Définir le style de la bordure du champ. Voir Pour définir le style de la bordure.
      •
      Rendre le champ visible ou invisible, ou le masquer. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Définir le paramètre régional associé au champ. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Demander à LiveCycle Designer de se baser sur la longueur horizontale du champ de texte pour déterminer le nombre de caractères admis.
      •
      Définir le caractère d'affichage du mot de passe.
      •
      Définir le format de saisie.
      •
      Définir le modèle de validation.
      •
      Définir un modèle de liaison des données.
      •
      Spécifier la méthode de liaison pour le stockage et la restauration des données liées.
Le formulaire peut comprendre un champ de mot de passe sans que les utilisateurs aient à entrer obligatoirement un mot de passe. Vous pouvez indiquer si le mot de passe est facultatif, recommandé ou obligatoire, et définir des messages qui guideront les utilisateurs de façon appropriée. Toutes les données entrées par l'utilisateur peuvent être validées par un script.
Voir aussi
Formatage des légendes
Formatage des valeurs de champ
Propriétés de la palette Disposition
Propriétés de la palette Bordure
Formats de mot de passe
Propriétés des champs de mot de passe dans le panneau Champ
Propriétés des champs de mot de passe dans le panneau Valeur
Propriétés des champs de mot de passe dans le panneau Liaison


Pour définir le caractère d'affichage du mot de passe

1.
Cliquez sur l'onglet Champ de la palette Objet.
2.
Dans la zone Caractère d'affichage du mot de passe, entrez le caractère qui sert à masquer le mot de passe lorsqu'il s'affiche au moment de l'exécution.


Pour définir le comportement du champ

1.
Dans le panneau Valeur de la palette Objet, sélectionnez l'une des options suivantes dans la liste Type :
      •
      Pour laisser aux utilisateurs le choix de saisir des données, choisissez Entré par l'utilisateur - Facultatif.
      •
      Pour inviter les utiliser à saisir des données et indiquer qu'il est recommandé de compléter le champ, choisissez Entré par l'utilisateur - Recommandé et entrez un message personnalisé dans la zone Message d'état vide.
      •
      Pour demander aux utilisateurs de saisir des données et indiquer qu'il est obligatoire de compléter le champ, choisissez Entré par l'utilisateur - Obligatoire et entrez un message personnalisé dans la zone Message d'état vide.
2.
Si la valeur est recommandée ou obligatoire, tapez un message dans la zone Message d'état vide.
Voir aussi
Propriétés des champs de mot de passe dans le panneau Valeur
Pour remplir de façon dynamique un message de modèle de validation
Pour remplir de façon dynamique un message de script de validation


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation des champs de mot de passe > Pour définir les propriétés de liaison personnalisée d’un champ de mot de passe

Pour définir les propriétés de liaison personnalisée d’un champ de mot de passe

Les options de liaison permettent de développer un formulaire qui capture les données pour les infrastructures de l'entreprise ou d'utiliser une source de données externe pour remplir le formulaire à l'exécution. Définissez les propriétés de liaison de données dans le panneau Liaison de la palette Objet.
1.
Sélectionnez le champ de mot de passe.
2.
Activez le formulaire pour établir la connexion à la source de données lorsque le formulaire est ouvert.
3.
Liez le champ au noeud de données correspondant. Pour plus d'informations sur la liaison des objets à une source de données, voir A propos de la liaison de champs à une source de données.
Voir aussi
Propriétés des champs de mot de passe dans le panneau Liaison


Pour limiter le nombre de caractères dans les champs de mot de passe

Il est possible de limiter le nombre de caractères entrés dans les champs de mot de passe en demandant à LiveCycle Designer de se baser sur la longueur horizontale du champ décimal ou numérique pour déterminer le nombre de caractères admis..
      *
      Dans la palette Objet, cliquez sur l'onglet Champ, puis sélectionnez l'option Limiter la longueur à la zone visible.
Voir aussi
Aperçu des champs de mot de passe
Propriétés des champs de mot de passe dans le panneau Champ


Utilisation de boutons radio

Aperçu des boutons radio
Pour définir la taille d'un bouton radio
Pour définir le style du bouton radio
Pour attribuer des valeurs à l'état Activé aux boutons radio
Pour définir les propriétés de liaison personnalisée d'un bouton radio
Pour créer un groupe d'exclusion
Pour déplacer un bouton radio vers un autre groupe d'exclusion
Pour déplacer un groupe d’exclusion
Pour fusionner des groupes d’exclusion
Pour définir le comportement du groupe d'exclusion
Pour définir la sélection par défaut du groupe d'exclusion


Aperçu des boutons radio

Les boutons radio constituent un moyen pratique d'offrir divers choix qui s'excluent mutuellement. Les utilisateurs peuvent activer ou désactiver l'état de n'importe quel bouton radio. Lorsqu'un bouton radio est sélectionné, son état est Activé et sa valeur est enregistrée. Lorsqu'il n'est pas sélectionné, son état est Désactivé et sa valeur n'est pas enregistrée. L'utilisateur n'a la possibilité de sélectionner qu'un seul bouton radio à la fois dans un groupe.
l'aspect d'un bouton radio peut être semblable à celui d'une case à cocher. Pour ce faire, vous devez en définir les caractéristiques dans le panneau Champ de la palette Objet. Toutefois, vous devez avant tout tenir compte des attentes des utilisateurs à l'égard du comportement des cases à cocher. S'attendent-ils à des choix multiples ? Dans l'affirmative, vous devriez conserver l'aspect standard du bouton radio et ne pas appliquer ses fonctions à des cases à cocher.
Après avoir inséré un bouton radio dans votre formulaire, vous pouvez définir le texte de sa légende et manipuler ses propriétés dans les panneaux Champ, Valeur et Liaison de la palette Objet. Vous pouvez définir les propriétés suivantes :
      •
      Changer la légende du bouton radio. Voir Pour renommer une légende.
      •
      Définir le style de la bordure du bouton radio. Voir Pour définir le style de la bordure.
      •
      Rendre le bouton radio visible ou invisible, ou le masquer. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Définir le paramètre régional associé au bouton radio. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Attribuer une valeur à l'état Activé de chaque bouton radio du groupe d'exclusion.
      •
      Définir le style du bouton radio.
      •
      Définir la sélection par défaut du groupe.
      •
      Spécifier la méthode de liaison pour le stockage et la restauration des données liées.
Il est possible d'associer des scripts et des calculs aux boutons radio. Si l'utilisateur est appelé à entrer des données, vous pouvez déterminer si la saisie d'informations est facultative ou obligatoire et définir le texte d'invite approprié. Les données entrées par l'utilisateur peuvent être validées par un script.
Un groupe d'exclusion est un groupe de boutons radio. L'utilisateur n'a la possibilité de sélectionner qu'un seul bouton radio à la fois dans un groupe d'exclusion.
Un groupe d'exclusion peut être manipulé comme un seul objet. Certaines options de la palette Objet s'appliquent à tous les boutons radio d'un même groupe d'exclusion. Vous pouvez déplacer des boutons radio d'un groupe à un autre et créer des groupes d'exclusion. Lorsque plusieurs boutons radio font partie d'un même groupe, vous pouvez facilement en retirer certains pour les placer dans un autre groupe.
Lorsque vous ajoutez un nouveau bouton radio à un formulaire et que le dernier objet inséré était un bouton radio, le nouveau bouton radio est intégré dans le même groupe d'exclusion. Si le dernier objet ajouté n'était pas un bouton radio, le nouveau bouton radio est placé dans un nouveau groupe d'exclusion.
Les groupes d'exclusion sont automatiquement redimensionnés pour contenir tous leurs boutons radio. Si vous faites glisser un bouton radio d'une zone de page vide, le groupe d'exclusion s'agrandit pour inclure ce bouton radio. Si vous redimensionnez un groupe d'exclusion manuellement, tous les boutons radio qu'il contient sont redimensionnés en conséquence.
Voir aussi
Formatage des légendes
Pour rendre accessible les boutons radio
Propriétés de la palette Disposition
Propriétés de la palette Bordure
Propriétés des boutons radio dans le panneau Champ
Propriétés des boutons radio dans le panneau Valeur
Propriétés des boutons radio dans le panneau Liaison


Pour définir la taille d'un bouton radio

1.
Cliquez sur l'onglet Champ de la palette Objet.
2.
Tapez une valeur différente (en points) dans la zone Taille et appuyez sur Entrée.
Selon la taille spécifiée, vous devrez peut-être redimensionner le bouton radio.
Voir aussi
Propriétés des boutons radio dans le panneau Champ


Pour définir le style du bouton radio

1.
Cliquez sur l'onglet Champ de la palette Objet.
2.
Sélectionnez une option dans la liste Style de bouton :
      •
      Pour attribuer le style par défaut (cercle plein), sélectionnez Valeur par défaut.
      •
      Pour utiliser une coche, sélectionnez Coche.
      •
      Pour utiliser un cercle, sélectionnez Cercle.
      •
      Pour utiliser une croix, sélectionnez Croix.
      •
      Pour utiliser un losange, sélectionnez Losange.
      •
      Pour utiliser un carré, sélectionnez Carré.
      •
      Pour utiliser une étoile, sélectionnez Etoile.
Voir aussi
Propriétés des boutons radio dans le panneau Champ


Pour attribuer des valeurs à l'état Activé aux boutons radio

Chaque bouton radio d'un groupe d'exclusion est associé à une valeur Activé qui le représente dans les données de formulaire. Vous pouvez modifier cette valeur pour qu'elle corresponde, par exemple, à des valeurs existantes de la source des données.
Lorsque vous spécifiez des valeurs pour l'état Activé, les valeurs par défaut constituent des entiers qui commencent à 1 pour le premier bouton radio du groupe d'exclusion ajouté au formulaire. Si vous désélectionnez l'option Spécifier les valeurs, les valeurs de l'état Activé correspondent à la légende du bouton radio.
1.
Sélectionnez le groupe d'exclusion ou l'un des boutons radio du groupe.
2.
Dans la palette Objet, cliquez sur l'onglet Liaison et sélectionnez Spécifier les valeurs.
3.
Cliquez deux fois sur la première valeur d'état Activé à modifier.
4.
Saisissez la nouvelle valeur.
5.
Appuyez sur Entrée pour modifier la valeur suivante ou cliquez deux fois sur une autre valeur afin de la modifier.
Voir aussi
A propos des sources de données
Pour définir les propriétés de liaison personnalisée d'un bouton radio
Propriétés des boutons radio dans le panneau Liaison


Pour définir les propriétés de liaison personnalisée d'un bouton radio

Les options de liaison permettent de développer un formulaire qui capture les données pour les infrastructures de l'entreprise ou d'utiliser une source de données externe pour remplir le formulaire à l'exécution. Définissez les propriétés de liaison de données du bouton radio dans le panneau Liaison de la palette Objet.
1.
Sélectionnez le groupe désiré.
2.
Activez le formulaire pour établir la connexion à la source de données lorsque le formulaire est ouvert.
3.
Liez le groupe d'exclusion au noeud de données correspondant. Pour plus d'informations sur la liaison des objets à une source de données, voir A propos de la liaison de champs à une source de données.
Voir aussi
Propriétés des boutons radio dans le panneau Liaison
Pour attribuer des valeurs à l'état Activé aux boutons radio


Pour créer un groupe d'exclusion

1.
Sélectionnez les boutons radio à placer dans un autre groupe d'exclusion dans l'éditeur de disposition ou dans la palette Hiérarchie.
2.
Effectuez l'une des opérations suivantes :
      •
      Cliquez sur l'un des objets sélectionnés avec le bouton droit de la souris dans l'éditeur de disposition, puis choisissez Placer dans un nouveau groupe de boutons radio.
      •
      Cliquez sur l'un des objets sélectionnés avec le bouton droit de la souris dans la palette Hiérarchie, puis choisissez Placer dans un nouveau groupe de boutons radio.
après avoir ajouté un groupe de boutons radio, insérez un autre objet sur la page. Par exemple, ajoutez un objet de texte. L'ajout de tout nouveau bouton radio sur la conception de formulaire a pour effet de créer un groupe d'exclusion.


Pour déplacer un bouton radio vers un autre groupe d'exclusion

1.
Sélectionnez le bouton radio à placer dans un autre groupe d'exclusion dans l'éditeur de disposition ou dans la palette Hiérarchie.
2.
Effectuez l'une des opérations suivantes :
      •
      Pour déplacer un bouton radio sur le formulaire, faites glisser l'objet dans l'éditeur de disposition pour le placer au sein d'un autre groupe d'exclusion.
      •
      Pour modifier les groupes d'exclusion sans déplacer le bouton sur la page, faites glisser le bouton radio vers un autre groupe d'exclusion dans la palette Hiérarchie.


Pour déplacer un groupe d’exclusion

1.
Cliquez sur le bord du groupe d'exclusion pour le sélectionner.
2.
Faites glisser le groupe vers son nouvel emplacement sur la page. Tous les boutons radio du groupe se déplacent en même temps.


Pour fusionner des groupes d’exclusion

1.
Cliquez sur le bord des groupes d'exclusion pour les sélectionner.
2.
Choisissez Mise en page > Fusionner les groupes de boutons radio.
Voir aussi
Aperçu des boutons radio


Pour définir le comportement du groupe d'exclusion

1.
Dans le panneau Valeur de la palette Objet, sélectionnez l'une des options suivantes dans la liste Type :
      •
      Pour laisser aux utilisateurs le choix de saisir des données, choisissez Entré par l'utilisateur - Facultatif.
      •
      Pour inviter les utiliser à saisir des données et indiquer qu'il est recommandé de compléter le champ, choisissez Entré par l'utilisateur - Recommandé et entrez un message personnalisé dans la zone Message d'état vide.
      •
      Pour demander aux utilisateurs de saisir des données et indiquer qu'il est obligatoire de compléter le champ, choisissez Entré par l'utilisateur - Obligatoire et entrez un message personnalisé dans la zone Message d'état vide.
      •
      Pour configurer le champ en lecture seule et calculer et afficher la valeur de donnée par le biais d'un script joint , choisissez Calculé - Lecture seule. L'utilisateur n'a pas la possibilité de modifier la valeur calculée.
      •
      Pour autoriser la modification du champ et calculer et afficher une valeur de donnée par le biais d'un script joint , choisissez Calculé - L’utilisateur peut remplacer. L'utilisateur peut changer la valeur si le script de calcul accepte les saisies. Si l'utilisateur change la valeur, le message personnalisé que vous avez défini dans la zone Message de remplacement s'affiche.
      •
      Pour configurer le champ en lecture seule et afficher une valeur de donnée résultant d'une fusion ou d'un calcul au moment de l'exécution, choisissez Lecture seule. Les utilisateurs ne peuvent pas modifier la valeur.
2.
Si la valeur est recommandée ou obligatoire, tapez un message dans la zone Message d'état vide.
3.
Si la valeur doit être calculée, joignez le script de calcul à l'objet à l'aide de l'éditeur de script.
4.
(Facultatif) Si la valeur calculée peut être remplacée, saisissez un message dans la zone Message de remplacement.
Voir aussi
Propriétés des boutons radio dans le panneau Valeur


Pour définir la sélection par défaut du groupe d'exclusion

1.
Cliquez sur l'onglet Valeur de la palette Objet.
2.
Dans la liste Valeur par défaut, sélectionnez la valeur qui identifie le bouton radio dont vous voulez activer l'état.
la liste Valeur par défaut est disponible uniquement si l'option Type est définie sur Entré par l'utilisateur ou sur Lecture seule. La valeur attribuée à l'état Activé du bouton radio peut être changée dans l'onglet Liaison.
Voir aussi
Propriétés des boutons radio dans le panneau Valeur


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation de champs de signature de document

Utilisation de champs de signature de document

Aperçu des champs de signature de document


Aperçu des champs de signature de document

Si vous souhaitez authentifier l'identité d'un utilisateur, ainsi que le contenu du document, ajoutez un champ de signature de document au formulaire. Une signature numérique permet d'enregistrer les informations concernant l'utilisateur et l'état du document lorsque celui-ci est signé. Les signatures du document Adobe prennent en charge la norme de cryptographie à clé publique (PKCS) nº 7, par le biais de l'algorithme de hachage RSA MD5, RSA SHA-1 ou DSA SHA-1.
Vous pouvez indiquer si la signature s'applique à l'intégralité du formulaire ou à une collection d'objets bien précis. Si vous souhaitez que la signature s'applique à une collection d'objets, l'utilisateur doit utiliser Acrobat ou Adobe Reader 8.0 ou une version ultérieure.
Si la signature s'applique à une collection d'objets, les champs sont verrouillés et ne peuvent pas être modifiés une fois le document signé. Le verrouillage est hérité. Ainsi, si un sous-formulaire est verrouillé, tous les objets qui le composent sont également verrouillés.
Pour signer le formulaire, l'utilisateur clique dans le champ de signature de document. Pour plus de détails sur la signature de formulaires PDF dans Acrobat, voir l'aide d'Acrobat.
Le champ de signature de document ne génère pas directement une signature numérique. Il fait appel à un gestionnaire de signatures tiers au moyen d'un script. Le gestionnaire de signatures offre les fonctions de signature numérique requises. Les utilisateurs ne peuvent pas signer des formulaires sans avoir un gestionnaire de signatures approprié.
Au besoin, vous pouvez modifier le nom du champ de signature de document dans la palette Hiérarchie une fois que vous avez ajouté l'objet à la conception de formulaire.
Après avoir ajouté un champ de signature de document à la conception de formulaire, vous pouvez définir les propriétés de la signature dans l'onglet Signature du document de la palette Objet. Vous pouvez définir si vous souhaitez que la signature s'applique à l'intégralité du formulaire ou à une collection d'objets de champ, puis spécifier les propriétés de la signature par défaut.
Vous pouvez modifier le texte du libellé, ainsi que les propriétés de l’objet dans l’onglet Champ de la palette Objet. Vous pouvez définir les propriétés suivantes :
      •
      Changer la légende du champ. Voir Pour renommer une légende.
      •
      Définir le style de la bordure du champ. Voir Pour définir le style de la bordure.
      •
      Rendre le champ visible ou invisible, ou le masquer. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Définir le paramètre régional associé au champ. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
Voir aussi
Formatage des légendes
Propriétés de la palette Disposition
Propriétés de la palette Bordure
Champs de signature du document
A propos des signatures numériques


Utilisation de texte

Aperçu du texte
Pour entrer des caractères dans un objet de texte
Pour insérer un champ de texte flottant dans un objet de texte
Pour insérer la valeur d'une propriété d'exécution dans l'objet de texte
Pour fusionner les objets de texte
Pour créer une légende en fusionnant un objet de texte et un objet de champ
Pour insérer des numéros propres à la langue dans du texte ou des légendes


Aperçu du texte

Ces objets de texte contiennent du texte en lecture seule, que l'utilisateur ne peut pas modifier. Vous pouvez vous en servir pour effectuer les opérations suivantes :
      •
      Etiqueter une zone du formulaire
      •
      Fournir des instructions sur la façon de remplir le formulaire
      •
      Inclure un en-tête et un pied de page
Une fois que vous avez ajouté un objet de texte à la conception de formulaire, vous pouvez notamment :
      •
      Rendre le texte visible ou invisible, ou le masquer. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Définir le paramètre régional associé au texte. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Saisir le texte et définir son style.
      •
      Appliquer des propriétés de police à tout le texte ou à des portions de celui-ci.
En outre, vous pouvez insérer des balises d'emplacement, telles que des champs de texte flottants et des valeurs de propriétés d'exécution (page active, nombre de pages, date et heure actuelles) dans les objets de texte.
Dans l'objet de texte, les deux options d'ajustement sont sélectionnées par défaut : l'objet sera automatiquement redimensionné au moment de la conception de façon à tenir compte du texte que vous saisissez et des options des propriétés que vous modifiez comme les marges, les bordures et le type et la taille de police.
Voir aussi
Propriétés de la palette Disposition
Propriétés de la palette Bordure
Propriétés de la palette Police
Propriétés de la palette Paragraphe
Propriétés du texte dans le panneau Dessin


Pour entrer des caractères dans un objet de texte

Vous pouvez taper des caractères dans l'objet une fois que vous l'avez ajouté dans le formulaire.
Par défaut, l'option Ajuster les objets de texte de taille fixe lors de la modification (située dans le panneau Espace de travail de la boîte de dialogue Options du menu Outils) est sélectionnée. Cette option vous permet d'ajuster la largeur et la hauteur des objets de texte en cours de frappe. Pour ajuster uniquement la largeur ou la hauteur d'un objet de texte, désactivez l'option Ajuster les objets de texte de taille fixe lors de la modification, puis sélectionnez l'option d'ajustement appropriée dans la palette Disposition.
1.
Sélectionnez Edition, et assurez-vous que les commandes Verrouiller le texte et Verrouiller les objets statiques ne sont pas sélectionnées.
2.
Cliquez deux fois sur l'objet de texte et saisissez le texte voulu.
Voir aussi
Pour ajuster les objets au contenu
Propriétés de la palette Disposition


Pour insérer un champ de texte flottant dans un objet de texte

Vous pouvez incorporer un champ de texte flottant dans un objet de texte. Ce type de champ permet de fusionner différentes valeurs de texte dans l'objet de texte. Par exemple, vous pouvez incorporer un champ de texte flottant qui génère le nom du client dans la formule de politesse d'une lettre type.
Un champ de texte flottant ne dispose pas d'une légende et peut être modifié de la même manière qu'un caractère de texte. Les propriétés du champ de texte flottant doivent être définies séparément des propriétés de l'objet de texte.
1.
Dans l'objet de texte, placez le curseur à l'endroit où vous voulez insérer le champ de texte flottant.
2.
Choisissez Insertion > Champ flottant.
3.
Sélectionnez le champ de texte flottant et modifiez ses propriétés.
Voir aussi
Aperçu des champs de texte


Pour insérer la valeur d'une propriété d'exécution dans l'objet de texte

Il est possible d'ajouter des valeurs de propriétés d'exécution dans un objet de texte. Lorsque le formulaire est consulté, la valeur réelle est insérée automatiquement.
La police, la taille et le style de police de la valeur insérée peuvent être différents de ceux de l'objet de texte.
1.
Dans l'objet de texte, placez le curseur à l'endroit où vous voulez insérer la valeur de la propriété d'exécution.
2.
Choisissez Insertion > [valeur de la propriété d'exécution].
      •
      Pour insérer le numéro de la page en cours du formulaire final, sélectionnez Numéro de la page active.
      •
      Pour insérer le nombre total de pages dont le formulaire final est constitué, sélectionnez Nombre de pages.
      •
      Pour insérer la date et l'heure actuelles, sélectionnez Date/Heure courante.
      •
      Pour insérer la valeur du paramètre régional de l'application qui traite le formulaire, sélectionnez Paramètres régionaux du programme de visualisation.
      •
      Pour insérer le nom de l'application qui traite le formulaire, sélectionnez Nom du programme de visualisation.
      •
      Pour insérer le numéro de version de l'application qui traite le formulaire, sélectionnez Version du programme de visualisation.
3.
Sélectionnez la valeur de la propriété d'exécution et modifiez ses attributs.
Voir aussi
Aperçu des champs de date et d'heure
Aperçu des champs numériques
Aperçu des champs de texte
Propriétés de la palette Police
Propriétés de la palette Paragraphe


Pour fusionner les objets de texte

Lors de l'importation d'un fichier PDF dans LiveCycle Designer, le texte des titres et des instructions risque d'être divisé en plusieurs objets de texte, en fonction des options d'importation choisies. Ceci rend le texte difficile à modifier, car les mots et les lettres risquent d'être divisés en objets de texte distincts. Si vous devez modifier le texte, vous pouvez fusionner les objets de texte afin de rendre la mise à jour du texte plus aisée.
1.
Sélectionnez les objets de texte à fusionner.
Si vous sélectionnez également un autre type d'objet, celui-ci ne sera pas inclus dans l'objet résultant de la fusion.
2.
Choisissez Disposition > Fusionner les objets de texte sélectionnés.
Tous les objets de texte sélectionnés sont combinés de façon à former un seul objet.
Voir aussi
Pour créer une légende en fusionnant un objet de texte et un objet de champ


Pour créer une légende en fusionnant un objet de texte et un objet de champ

Vous pouvez créer une légende pour un objet de champ sans légende en le fusionnant avec un objet de texte.
Si, par exemple, vous disposez d'un objet de texte situé au-dessus d'un champ de texte dont la légende est défini sur Aucune, vous pouvez fusionner les deux objets afin de créer un seul champ. Le texte de l'objet de texte devient la légende du champ de texte.
Avant d'effectuer cette tâche, assurez-vous que les paramètres suivants sont appliqués :
      •
      Assurez-vous de disposer d'un objet de texte.
      •
      Assurez-vous de disposer d'un objet de champ dont la légende est définie sur Aucune dans la palette Disposition ou est vide.
L'objet de champ peut correspondre à l'un des objets suivants :
      •
      Case à cocher
      •
      Date/Heure
      •
      Champ décimal
      •
      Champ de signature du document
      •
      Liste déroulante
      •
      Champ d'image
      •
      Zone de liste
      •
      Champ numérique
      •
      Champ du mot de passe
      •
      Bouton radio
      •
      Champ de texte
Vous pouvez uniquement fusionner un objet de texte et un objet de champ.
1.
Sélectionnez l'objet de texte devant devenir la légende de l'objet de champ.
2.
Maintenez la touche Ctrl ou Maj enfoncée et cliquez pour sélectionner l'objet de champ à fusionner avec l'objet de texte.
L'objet de champ doit disposer d'une légende définie sur Aucune dans la palette Disposition ou d'une légende vide.
3.
Choisissez Disposition > Fusionner comme légende.
La légende du nouvel objet devient le texte de l'objet de texte. La taille et la position du nouvel objet correspondent au contour global des objets fusionnés.
Vous devrez peut-être modifier la police de la légende et la valeur après la fusion des objets.
Voir aussi
Pour fusionner les objets de texte
Formatage des légendes
Pour positionner une légende


Pour insérer des numéros propres à la langue dans du texte ou des légendes

La plupart des régions du monde utilisent le système de numérotation romain, appelé également système européen (1, 2, 3, etc.). Toutefois, le système de numérotation arabe, qui est issu des chiffres indiens, est différent.
Bien que les lettres arabes s'écrivent de droite à gauche, les chiffres s'écrivent de gauche à droite. Il s'agit du système de numérotation arabe.
Vous pouvez insérer des chiffres propres à la langue dans du texte ou des légendes si vos paramètres régionaux (Arabe d'Egypte, par exemple), prennent en charge cette possibilité. Les paramètres régionaux suivants sont compatibles avec cette fonction :
      •
      Arabe (tous sauf Algérie, Maroc et Tunisie)
      •
      Thaïlandais (traditionnel)
Les options décrites dans cette rubrique d'aide ne sont disponibles que si la langue adéquate est activée par l'intermédiaire des paramètres de langue de Microsoft Office.
1.
Sélectionnez le texte.
2.
Cliquez avec le bouton droit de la souris et assurez-vous que l'option Utiliser les chiffres est activée.
Si cette option de menu n'est pas proposée, vérifiez si les paramètres régionaux définis pour cet objet prennent en charge cette fonction.
3.
Tapez les chiffres.
Voici un exemple de légende montrant trois types de chiffres propres à la langue.
LiveCycle Forms 7.1 ne prend pas en charge les conceptions de formulaire contenant des polices relatives à l'arabe, l'hébreu, le thaï et le vietnamien.


Utilisation des champs de texte

Aperçu des champs de texte
Pour autoriser plusieurs lignes de texte dans les champs de texte
Pour limiter le nombre de caractères dans les champs de texte
Pour autoriser le remplissage du champ avec du texte enrichi
Pour définir le comportement du champ
Pour définir les propriétés de liaison personnalisée d'un champ de texte
Pour spécifier le format des données pour les champs de texte
Pour spécifier le format de peigne pour les champs de texte


Aperçu des champs de texte

Si vous souhaitez offrir aux utilisateurs la possibilité d'entrer des données de texte, prévoyez des champs de texte dans le formulaire. Les champs de texte permettent aux utilisateurs de saisir, sélectionner, modifier, couper, copier, coller et supprimer n'importe quelle portion du texte qui se trouve dans le champ.
Ils peuvent accueillir une ou plusieurs lignes de texte avec retour à la ligne et prennent en charge différentes fonctions de formatage améliorées. Par exemple, les champs de texte peuvent afficher des blocs de texte ayant différents styles et couleurs de polices. Le texte peut être enregistré ou récupéré en tant que texte brut ou XHTML. Au besoin, les données d'un champ de texte peuvent être formatées et affichées selon des formats prédéfinis.
Après avoir inséré un champ de texte dans votre formulaire, vous pouvez définir le texte de sa légende et manipuler ses propriétés dans les panneaux Champ, Valeur et Liaison de la palette Objet. Vous pouvez définir les propriétés suivantes :
      •
      Changer la légende du champ. Voir Pour renommer une légende.
      •
      Définir le style de la bordure du champ. Voir Pour définir le style de la bordure.
      •
      Rendre le champ visible ou invisible, ou le masquer. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Définir le paramètre régional associé au champ. Voir Pour définir un paramètre régional (langue et pays) pour un objet.
      •
      Spécifier le format de peigne du champ. Voir Pour spécifier le format de peigne pour les champs de texte.
      •
      Activer ou désactiver le texte à lignes multiples.
      •
      Autoriser ou non le remplissage du champ avec du texte enrichi.
      •
      Limiter le nombre de caractères dans le champ.
      •
      Définir le format d'affichage.
      •
      Définir le format de saisie.
      •
      Spécifier la valeur initiale à afficher.
      •
      Définir une propriété d'exécution (par exemple, l'insertion du numéro de page).
      •
      Définir le modèle de validation.
      •
      Déterminer si le champ prend en charge le texte brut ou XHTML.
      •
      Définir un modèle de liaison des données.
      •
      Spécifier la méthode de liaison pour le stockage et la restauration des données liées.
Il est possible d'associer des scripts et des calculs aux champs de texte. Si l'utilisateur est appelé à entrer des données, vous pouvez déterminer si la saisie d'informations est facultative ou obligatoire et définir le texte d'invite approprié. Toutes les données entrées par l'utilisateur peuvent être validées par un script.
Voir aussi
Formatage des légendes
Pour verrouiller des objets
A propos des formats et des valeurs de format
Propriétés de la palette Disposition
Propriétés de la palette Bordure
Formats des champs de texte
Propriétés des champs de texte dans le panneau Champ
Propriétés des champs de texte dans le panneau Valeur
Propriétés des champs de texte dans le panneau Liaison


Pour autoriser plusieurs lignes de texte dans les champs de texte

      *
      Dans la palette Objet, cliquez sur l'onglet Champ, puis sélectionnez Permettre des lignes multiples.
Voir aussi
Propriétés des champs de texte dans le panneau Champ


Pour limiter le nombre de caractères dans les champs de texte

Vous pouvez limiter le nombre de caractères dans les champs de texte de l'une ou l'autre des façons suivantes :
      •
      Vous pouvez indiquer le nombre maximum de caractères autorisés.
      •
      Vous pouvez demander à LiveCycle Designer de se baser sur la longueur horizontale du champ de texte pour déterminer le nombre de caractères admis.
Pour spécifier le nombre de caractères dans les champs de texte
1.
Cliquez sur l'onglet Champ de la palette Objet.
2.
Sélectionnez l'option Limiter la taille et dans la zone Nombre max. de caractères, tapez le nombre maximal de caractères que l'utilisateur est autorisé à entrer dans le champ de texte.
Pour limiter le nombre de caractères en fonction de la largeur des champs de texte
      *
      Dans la palette Objet, cliquez sur l'onglet Champ, puis sélectionnez l'option Limiter la longueur à la zone visible.
Voir aussi
Propriétés des champs de texte dans le panneau Champ


Pour autoriser le remplissage du champ avec du texte enrichi

Par défaut, un champ de texte est configuré pour afficher et capturer du texte brut. Dans ce cas, si la valeur associée au champ de texte comporte des informations de formatage, celles-ci ne sont pas prises en compte et la valeur est affichée en texte brut. Il est possible de le configurer de façon à préserver le formatage en texte enrichi des données.
1.
Dans la palette Objet, activez l’onglet Champ et sélectionnez Texte enrichi dans la liste Format du champ.
2.
Dans le panneau Liaison, sélectionnez XHTML dans la liste Format des données.
Voir aussi
Propriétés des champs de texte dans le panneau Champ


Pour définir le comportement du champ

1.
Dans le panneau Valeur de la palette Objet, sélectionnez l'une des options suivantes dans la liste Type :
      •
      Pour laisser aux utilisateurs le choix de saisir des données, choisissez Entré par l'utilisateur - Facultatif.
      •
      Pour inviter les utiliser à saisir des données et indiquer qu'il est recommandé de compléter le champ, choisissez Entré par l'utilisateur - Recommandé et entrez un message personnalisé dans la zone Message d'état vide.
      •
      Pour demander aux utilisateurs de saisir des données et indiquer qu'il est obligatoire de compléter le champ, choisissez Entré par l'utilisateur - Obligatoire et entrez un message personnalisé dans la zone Message d'état vide.
      •
      Pour configurer le champ en lecture seule et calculer et afficher la valeur de donnée par le biais d'un script joint , choisissez Calculé - Lecture seule. L'utilisateur n'a pas la possibilité de modifier la valeur calculée.
      •
      Pour autoriser la modification du champ et calculer et afficher une valeur de donnée par le biais d'un script joint , choisissez Calculé - L’utilisateur peut remplacer. L'utilisateur peut changer la valeur si le script de calcul accepte les saisies. Si l'utilisateur change la valeur, le message personnalisé que vous avez défini dans la zone Message de remplacement s'affiche.
      •
      Pour configurer le champ en lecture seule et afficher une valeur de donnée résultant d'une fusion ou d'un calcul au moment de l'exécution, choisissez Lecture seule. Les utilisateurs ne peuvent pas modifier la valeur.
2.
Si la valeur est recommandée ou obligatoire, tapez un message dans la zone Message d'état vide.
3.
Si la valeur doit être calculée, joignez le script de calcul à l'objet à l'aide de l'éditeur de script.
4.
(Facultatif) Si la valeur calculée peut être remplacée, saisissez un message dans la zone Message de remplacement.
Voir aussi
Pour définir une valeur par défaut
Pour remplir de façon dynamique un message de modèle de validation
Pour remplir de façon dynamique un message de script de validation
Propriétés des champs de texte dans le panneau Valeur


Pour définir les propriétés de liaison personnalisée d'un champ de texte

Les options de liaison permettent de développer un formulaire qui capture les données pour les infrastructures de l'entreprise ou d'utiliser une source de données externe pour remplir le formulaire à l'exécution. Définissez les propriétés de liaison de données dans le panneau Liaison de la palette Objet.
1.
Sélectionnez le champ de texte.
2.
Activez le formulaire pour établir la connexion à la source de données lorsque le formulaire est ouvert.
3.
Liez le champ au noeud de données correspondant. Pour plus d'informations sur la liaison des objets à une source de données, voir A propos de la liaison de champs à une source de données.
Voir aussi
Propriétés des champs de texte dans le panneau Liaison


Pour spécifier le format des données pour les champs de texte

Les champs de texte peuvent enregistrer des données en texte brut uniquement ou contenir des informations de formatage de texte XHTML dans la valeur. La valeur par défaut est Texte brut. Si vous adoptez le format de données XHTML, l'option Texte enrichi de la liste Format du champ disponible via l’onglet Champ de la palette Objet est automatiquement sélectionnée.
1.
Sélectionnez l'objet de champ de texte.
2.
Dans la palette Objet, cliquez sur l'onglet Liaison.
3.
Sélectionnez le format voulu dans la liste Formats des données.
Voir aussi
Pour définir les propriétés de liaison personnalisée d'un champ de texte
Propriétés des champs de texte dans le panneau Liaison


Pour spécifier le format de peigne pour les champs de texte

Utilisez ce format pour séparer les caractères et les nombres ajoutés aux champs de texte par des lignes.
1.
Cliquez sur l'onglet Champ de la palette Objet.
2.
Sélectionnez Bande de caractères pour insérer des lignes de séparation entre chaque caractère dans le champ de texte.
3.
Précisez combien de caractères vous souhaitez séparer par des lignes dans le champ de texte.
Voir aussi
Aperçu des champs de texte
Propriétés des champs de texte dans le panneau Champ


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation d'objets > Utilisation d'objets personnalisés

Utilisation d'objets personnalisés

A propos des objets personnalisés
Pour créer un objet personnalisé


A propos des objets personnalisés

Outre les objets regroupés dans la catégorie Standard de la palette Bibliothèque, LiveCycle Designer propose des objets personnalisés prédéfinis conçus pour offrir des fonctionnalités très recherchées par les auteurs de formulaires dans une solution de formulaire. Vous pouvez modifier les propriétés et les scripts relatifs aux objets personnalisés en fonction de vos besoins.
Les objets personnalisés prédéfinis suivants sont situés dans la catégorie Personnalisés de la palette Bibliothèque.

Objet

Description
Adresse électronique
Un champ de texte qui capture et valide une adresse électronique.
Conçu pour les formulaires interactifs.
Bloc d'adresse
Accepte et affiche les adresses au format postal United States. Le bloc d'adresse est un groupe de champs de texte qui permet aux utilisateurs d'entrer leurs nom, adresse, ville, code postal et pays.
Adapté à tous les types de formulaire.
Champs Adobe Workflow Server
Un bloc d'objets conçu pour les formulaires Workflow Server. Il inclut un bouton Envoyer, une liste déroulante d'action et d’autres champs masqués, utilisés pour acheminer les données nécessaires à Workflow Server afin de transférer correctement les données de formulaire.
Date courante
Un champ de date/heure avec un script affichant la date courante selon les paramètres locaux du système de visualisation.
Adapté à tous les types de formulaire.
Feuille n sur m
Affiche un objet de texte indiquant la valeur de la feuille de papier actuelle (feuille) dans la plage des feuilles requise pour un formulaire.
Exemple : Feuille 1 de 5
Pour tous les types de formulaire.
Liste déroulante Données
Une liste déroulante avec un script remplissant la liste d'une source de données OLE.
Conçu pour les formulaires interactifs.
Navigation
Un groupe de boutons avec des scripts pour naviguer jusqu’à la première ou dernière page, ou jusqu’à la page précédente ou suivante.
Conçu pour les formulaires interactifs.
Nom
Un groupe d'objets de texte acceptant et affichant les informations de nom. Les utilisateurs finaux peuvent entrer leurs nom, prénom et initiales.
Pour tous les types de formulaire.
Numéro de sécurité sociale U.S.
Un champ de texte qui permet à un utilisateur d’entrer un numéro de sécurité sociale des Etats-Unis.
Conçu pour les formulaires interactifs.
Numéro de téléphone – Amérique du Nord
Un champ de texte qui formate la sortie de texte en numéro de téléphone d’Amérique du Nord.
Conçu pour les formulaires interactifs.
Numéro de téléphone - International
Un champ de texte qui formate la sortie de texte en numéro de téléphone international.
Conçu pour les formulaires interactifs.
Page n sur m
Un champ de texte avec un script affichant la page courante et le nombre total de pages du formulaire au moment de l'exécution.
Exemple : Page 1 sur 30
Pour tous les types de formulaire.
Pays
Affiche une liste déroulante remplie de noms de pays. Vous pouvez ajouter, déplacer et supprimer tout pays de la liste.
Conçu pour les formulaires interactifs.
Question de sondage
Un objet de texte statique pour une question de sondage et un groupe de boutons radio pour sélectionner la réponse.
Conçu pour les formulaires interactifs.
Signature – Imprimer et Signer
Affiche un espace sur une impression de formulaire, où un utilisateur peut apposer sa signature.
Conçue pour les formulaires à imprimer.
U.S.A.
Affiche une liste déroulante remplie de noms d’Etats des U.S.A. Vous pouvez ajouter, déplacer et supprimer tout Etat de la liste.
Conçu pour les formulaires interactifs.
Zone de liste déroulante Données
Une zone de liste déroulante avec un script remplissant la liste de la source de données OLE.
Conçu pour les formulaires interactifs.
La plupart des objets personnalisés sont prêts à l'emploi et ne nécessitent que des modifications secondaires, telles que l'édition des légendes, la mise en forme des nombres ou le changement du type de police, à votre convenance. Il vous suffit de faire glisser ces objets sur la conception de formulaire puis d'effectuer les modifications. Notez qu'un objet personnalisé placé sur une conception de formulaire apparaît également dans la palette Hiérarchie. Dans le cas d'objets personnalisés formés de plusieurs objets standard, regroupés et mis en forme de manière particulière, notamment les objets de blocs d'adresse, les objets de champs de texte individuels (Nom, Adresse, Ville, Région, Code postal, Pays) apparaissent également dans la palette Hiérarchie.
Deux types d'objets personnalisés, la liste déroulante de données et la zone de liste de données, se composent d'un seul objet associé à un script personnalisé, lequel permet d'insérer deux colonnes de données provenant d'une connexion à une base de données OLE. Le script s'affiche dans l'éditeur de script lorsque vous placez l'objet sur une conception de formulaire. Les commentaires inclus dans le script permettent d'expliquer les modifications nécessaires pour rendre le script compatible à un environnement d'exécution en particulier. Pour plus de détails, voir Pour remplir de façon dynamique une liste déroulante ou une zone de liste à partir d'une connexion aux données OLE.
L'objet de champ d'Adobe Workflow Server est conçu spécialement pour une utilisation avec Workflow Server.
Voir aussi
Pour créer un objet personnalisé
Pour ajouter des objets à une conception de formulaire


Pour créer un objet personnalisé

LiveCycle Designer vous permet de créer des objets personnalisés que vous pouvez enregistrer et réutiliser. La création d'un objet personnalisé consiste à ajouter un ou plusieurs objets du panneau Standard dans la conception de formulaire, puis à définir leurs propriétés en fonction de vos besoins.
Vous pouvez enregistrer l'objet dans la catégorie Personnalisés de la palette Bibliothèque ou dans la catégorie que vous y avez créée. La création de vos propres catégories de palette Bibliothèque est un bon moyen d'organiser les objets personnalisés de votre composition et de les séparer de ceux proposés avec LiveCycle Designer. Pour obtenir plus de renseignements sur la création de vos propres catégories, voir Pour ajouter une catégorie à la palette Bibliothèque.
1.
Dans la palette Bibliothèque, faites glisser l'objet que vous souhaitez personnaliser dans la conception de formulaire.
2.
Définissez ses propriétés.
3.
Dans la palette Bibliothèque, cliquez sur la catégorie Personnalisés.
4.
Faites glisser l'objet vers la catégorie Personnalisés.
5.
Dans la boîte de dialogue Ajouter un objet de bibliothèque, entrez le nom et la description de l'objet personnalisé, puis cliquez sur OK.
il est possible d'enregistrer plusieurs objets comme s'il s'agissait d'un seul objet. Lorsque vous faites glisser un groupe d'objets vers l'onglet Personnaliser, le système crée un seul objet dans le panneau.
Voir aussi
Palette Bibliothèque
Gestion de la palette Bibliothèque
Objets prenant en charge des fonctions de script et de calcul
Propriétés de la palette Disposition
Propriétés de la palette Bordure
Propriétés de la palette Police
Propriétés de la palette Paragraphe


Ajout, copie et suppression d'objets

Pour ajouter des objets à une conception de formulaire
Pour couper, copier et coller des objets
Pour dupliquer un objet
Pour supprimer un objet


Pour ajouter des objets à une conception de formulaire

Vous pouvez ajouter des objets à une conception de formulaire de plusieurs façons. Après avoir ajouté un objet, vous pouvez en définir les propriétés.
Pour ajouter un objet à partir du menu Insertion
      *
      Effectuez l'une des opérations suivantes :
      •
      Choisissez Insertion > Favoris > [objet].
      •
      Choisissez Insertion > Standard > [objet].
      •
      Choisissez Insertion > Codes à barres > [objet].
      •
      Choisissez Insertion > Personnaliser > [objet].
Pour ajouter un objet à partir de la palette Bibliothèque
      *
      Effectuez l'une des opérations suivantes :
      •
      Faites-le glisser sur la conception de formulaire.
      •
      Cliquer deux fois sur l’objet.
      •
      Cliquez sur l'objet et faites glisser le curseur sur la conception de formulaire pour dessiner l'objet.
Pour ajouter plusieurs objets du même type
      *
      Effectuez l'une des opérations suivantes :
      •
      Dans la palette Bibliothèque, cliquez sur l'objet et choisissez Affichage > Conserver l'outil de dessin. Vous pouvez utiliser la commande Conserver l'outil de dessin pour tout type d'objet. Pour désactiver cette fonction, choisissez à nouveau Affichage > Conserver l'outil de dessin ou appuyez sur la touche Echap.
      •
      Cliquez sur le bouton de création des champs dans la barre d'outils Outils et sélectionnez l'objet qui vous intéresse dans la liste déroulante. Ce bouton s'applique uniquement aux objets répertoriés dans la liste déroulante. Pour désactiver cette fonction, cliquez sur l'outil Sélectionner ou sur l'outil Main dans la barre d'outils Outils.
Après avoir activé ces commandes, vous pouvez insérer autant de copies d'un objet que vous le souhaitez, sans devoir le sélectionner chaque fois dans la palette Bibliothèque.


Pour couper, copier et coller des objets

Vous pouvez couper, copier et coller des objets à partir du menu Edition ou à l'aide des raccourcis clavier.
Pour couper ou copier et coller un objet
1.
Sélectionner un ou plusieurs objets
2.
Effectuez l'une des opérations suivantes :
      •
      Pour couper un objet, choisissez Edition > Couper.
      •
      Pour copier un objet, choisissez Edition > Copier.
3.
Choisissez Edition > Coller.
Si le pointeur se trouve sur la page, l'objet est collé sous ce dernier. Sinon, il est collé dans le coin supérieur gauche de la zone de contenu active.
Pour copier un groupe d’objets
1.
Dans la palette Hiérarchie, cliquez sur le noeud de groupe.
2.
Choisissez Edition > Copier.
Pour réaliser plusieurs copies d'objets
1.
Dans la conception de formulaire ou la palette Hiérarchie, sélectionnez un ou plusieurs objets.
2.
Choisissez Edition > Multiplier.
3.
Entrer le nombre de copies approprié. Vous pouvez faire autant de copies que la zone de contenu active peut en contenir.
4.
Sélectionnez les options relatives aux positions verticale et horizontale.
5.
Pour augmenter l'espacement vertical entre les objets copiés et les objets d'origine, cochez la case Décalage de la zone de groupe Espacement vertical, et entrez la nouvelle distance dans la zone adjacente.
6.
Pour augmenter l'espacement horizontal entre les objets copiés et les objets d'origine, cochez la case Décalage de la zone de groupe Espacement horizontal, et entrez la nouvelle distance dans la zone adjacente.
7.
Cliquez sur OK. Les copies sont ajoutées à la page, et tous les objets d'origine ou copiés sont sélectionnés.
Voir aussi
Pour dupliquer un objet
Pour supprimer un objet


Pour dupliquer un objet

La fonction de duplication d'objets est équivalente à la fonction de copier/coller. Par défaut, l'objet dupliqué est placé juste au-dessous et à droite de l'original. Si vous faites glisser l'objet dupliqué vers un nouvel emplacement puis le dupliquez de nouveau, le prochain objet dupliqué, y compris les objets suivants, sont placés à la même distance et dans la même direction par rapport au dernier objet dupliqué. Vous pouvez dupliquer un objet autant de fois que la zone de contenu active peut en contenir.
Pour dupliquer un objet
1.
Sélectionner un ou plusieurs objets
2.
Choisissez Edition > Dupliquer.
Pour dupliquer un objet en le faisant glisser
1.
Faites glisser l'objet à l’emplacement où vous souhaitez le dupliquer.
2.
Appuyez sur la touche Ctrl et relâchez le bouton de la souris.
Voir aussi
Pour couper, copier et coller des objets
Pour supprimer un objet


Pour supprimer un objet

Vous pouvez supprimer n'importe quel objet sélectionné.
1.
Sélectionner un ou plusieurs objets
2.
Effectuez l'une des opérations suivantes :
      •
      Choisissez Edition > Supprimer.
      •
      Appuyez sur la touche Suppr.
Voir aussi
Pour couper, copier et coller des objets


Sélection, regroupement et déplacement d'objets

Pour sélectionner des objets
Pour sélectionner des objets par le biais de la palette Hiérarchie
Pour regrouper et dissocier des objets
Pour déplacer des objets
Pour empiler des objets
Pour verrouiller des objets


Pour sélectionner des objets

La sélection d'un objet s'effectue par le biais de la souris ou du clavier selon des méthodes connues.
      •
      Pour sélectionner un seul objet, cliquez sur le bouton Sélectionner l'outil [image] dans la barre d'outils et cliquez sur l'objet.
      •
      Pour sélectionner plusieurs objets, maintenez la touche Ctrl enfoncée et cliquez sur chacun des objets à sélectionner ou encerclez-les (en faisant glisseur le curseur).
      •
      Pour sélectionner l'intégralité des objets, choisissez Edition > Sélectionner tout.
      •
      Pour sélectionner l'intégralité des objets statiques, choisissez Edition > Sélectionner tous les objets statiques.
      •
      Pour sélectionner l'intégralité des champs, choisissez Edition > Sélectionner tous les champs.
Voir aussi
Raccourcis clavier affectés à la sélection de texte


Pour sélectionner des objets par le biais de la palette Hiérarchie

La palette Hiérarchie vous aide à sélectionner et à manipuler les objets.
Lorsque vous sélectionnez un objet dans la palette Hiérarchie, l'objet est simultanément sélectionné dans le formulaire. Cependant, lorsque vous faites une sélection dans la palette Hiérarchie, toutes les touches (F2 ou Maj+clic, par exemple) sont activées dans la palette Hiérarchie jusqu'à ce que vous travailliez de nouveau dans le formulaire.
      •
      Pour afficher la palette Hiérarchie, choisissez Fenêtre > Hiérarchie.
      •
      Pour sélectionner un seul objet dans la palette Hiérarchie, cliquez sur l'objet.
      •
      Pour sélectionner plusieurs objets adjacents dans la palette Hiérarchie, cliquez sur le premier objet puis, en appuyant sur la touche Maj, cliquez sur le dernier objet.
      •
      Pour sélectionner plusieurs objets non adjacents dans la palette Hiérarchie, cliquez sur chacun des objets en maintenant la touche Ctrl enfoncée.
      •
      Pour sélectionner un groupe d'objets dans la palette Hiérarchie, cliquez sur le noeud de groupe.


Pour regrouper et dissocier des objets

Vous pouvez regrouper et dissocier des objets à partir du menu Disposition, de la palette Hiérarchie ou de la barre d'outils Disposition :
      •
      Pour regrouper des objets, sélectionnez les objets à associer dans la conception de formulaire ou la palette Hiérarchie, puis choisissez Disposition > Associer ou cliquez sur Associer [image].
      •
      Pour dissocier des objets, sélectionnez les objets à dissocier dans la conception de formulaire ou la palette Hiérarchie, puis choisissez Disposition > Dissocier ou cliquez sur Dissocier [image].
      •
      Pour ajouter un nouvel objet à un groupe à l'aide de la souris, dans la conception de formulaire, faites glisser l'objet vers le groupe.
      •
      Pour ajouter un nouvel objet à un groupe à l'aide de la palette Hiérarchie, faites glisser l'objet vers un noeud de groupe existant.
Voir aussi
Raccourcis clavier pour manipuler les objets


Pour déplacer des objets

Vous pouvez déplacer les objets en les faisant glisser à l'aide de la souris, en vous servant des touches fléchées du clavier ou en entrant des valeurs précises dans la palette Disposition.
Pour déplacer ou dupliquer des objets en les collant
1.
Sélectionner un ou plusieurs objets
2.
Choisissez Edition > Couper pour déplacer la sélection ou Edition > Copier pour la dupliquer.
3.
(Facultatif) Pour coller un objet dans un autre fichier, ouvrez le fichier.
4.
Choisissez Edition > Coller pour insérer l'objet dans la fenêtre active.
Pour déplacer un objet en le faisant glisser
1.
Sélectionner un ou plusieurs objets
2.
Faites glisser l'objet vers le nouvel emplacement.
Pour déplacer un objet à l'aide des touches fléchées
1.
Sélectionner un ou plusieurs objets
2.
Appuyez sur la touche fléchée correspondant au sens de déplacement voulu. La distance par défaut est de 1 point (1/72ème de pouce ou 0,3528 millimètre).
3.
Pour déplacer l'objet de 10 points à la fois, appuyez sur Maj+touche fléchée.
Pour déplacer les objets en indiquant les coordonnées x et y dans la palette Disposition
1.
Sélectionner un ou plusieurs objets
2.
Dans la palette Disposition, saisissez les nouvelles valeurs dans l'une ou les deux zones X ou Y.


Pour empiler des objets

LiveCycle Designer empile successivement les objets dessinés, en commençant par le premier objet dessiné. Le mode d'empilement des objets détermine la façon dont ils sont affichés lorsqu'ils se chevauchent. Vous pouvez changer à tout moment l'ordre dans lequel les objets sont empilés sur votre conception de formulaire en vous servant des commandes de réorganisation du menu Disposition.
1.
Sélectionnez l'objet.
2.
Utilisez l'une des méthodes suivantes :
      •
      Pour rapprocher l'objet, choisissez Disposition > En avant ou cliquez sur l'icône éponyme [image].
      •
      Pour amener l'objet au premier plan, choisissez Disposition > Premier plan ou cliquez sur l'icône éponyme [image].
      •
      Pour éloigner un objet, choisissez Disposition > En arrière ou cliquez sur l'icône éponyme [image].
      •
      Pour envoyer un objet à l'arrière-plan, choisissez Disposition > Arrière-plan ou cliquez sur l'icône éponyme [image].
Voir aussi
Propriétés de la palette Disposition


Pour verrouiller des objets

Le verrouillage des objets empêche leur sélection et leur modification dans l'éditeur de disposition. Voici les différents éléments qu'il est possible de verrouiller sur votre conception de formulaire :
    • Texte
Il s'agit du texte statique et du texte des légendes des objets. Lorsque vous sélectionnez la commande Verrouiller le texte, vous devez cliquer deux fois sur le texte ou la légende à modifier. Cela complique la modification de texte. Si la commande Verrouiller le texte est activée, cliquez sur l’objet légende ou texte pour modifier le texte. Cette commande est particulièrement intéressante pour sélectionner et déplacer des objets sans modifier le texte. Vous pouvez cliquer sur l'objet pour le sélectionner, mais vous devez cliquer deux fois sur la légende ou le texte pour effectuer les modifications
    • Objets statiques
Il s'agit du texte statique, des cercles, des lignes et des rectangles.
    • Objets de champ
Il s'agit des boutons, des cases à cocher, des champs de date/heure, des champs décimaux, des champs de signature du document, des listes déroulantes, des champs d'image, des zones de liste, des champs numériques, des codes à barres de formulaires pour support papier, des champs de mot de passe, des boutons radio et des champs de texte.
vous pouvez sélectionner les objets dans la palette Hiérarchie et redéfinir leurs propriétés.
Après avoir verrouillé des objets statiques et des objets de champ, vous devez les déverrouiller pour en ajouter de nouveaux.
Les commandes de verrouillage sont appréciables lorsque la mise en forme d'un type d'objet spécifique est terminée dans la conception de formulaire et que vous souhaitez continuer à manipuler les autres types d'objet. Prenons l'exemple de votre formulaire qui comprend un grand nombre d'objets de champ de texte ainsi que des objets contenant les instructions nécessaires pour le remplir. Vous avez disposé et mis en forme tous les objets texte statique, mais il vous reste à appliquer une autre police aux objets champ de texte. Il vous suffit pour cela de verrouiller les objets de texte, de choisir la commande Edition > Sélectionner tous les champs pour sélectionner tous les objets de texte simultanément, puis de changer de police.
      •
      Pour verrouiller du texte, choisissez Edition > Verrouiller le texte. Pour déverrouiller du texte, choisissez Edition > Verrouiller le texte.
      •
      Pour verrouiller des objets statiques, choisissez Edition > Verrouiller les objets statiques. Pour déverrouiller des objets statiques, choisissez Edition > Verrouiller les objets statiques.
      •
      Pour verrouiller des champs, choisissez Edition > Verrouiller les champs. Pour déverrouiller des champs, choisissez Edition > Verrouiller les champs.


Alignement et redimensionnement d'objets

Pour aligner des objets les uns par rapport aux autres
Pour aligner des objets sur une grille
Pour centrer des objets sur la page
Pour faire pivoter les objets
Pour répartir des objets
Pour redimensionner les objets
Pour donner la même taille aux objets
Pour ajuster les objets au contenu
Pour définir la position des objets


Pour aligner des objets les uns par rapport aux autres

Lorsque vous alignez des objets les uns par rapport aux autres, le dernier objet sélectionné détermine le point d'alignement. Par exemple, si vous cliquez sur plusieurs objets en maintenant la touche Maj enfoncée pour les aligner à gauche, ils sont alignés en fonction du bord gauche de l'objet que vous avez sélectionné en dernier. Dans un groupe d'objets sélectionnés, le dernier objet sélectionné est reconnaissable aux poignées pleines.
Pour aligner les bords des objets
1.
Sélectionnez les objets à aligner.
2.
Effectuez l'une des opérations suivantes :
      •
      Pour aligner les bords gauches des objets, choisissez Disposition > Aligner > Gauche ou cliquez sur l'icône Aligner à gauche [image].
      •
      Pour aligner les bords droits des objets, choisissez Disposition > Aligner > Droite ou cliquez sur l'icône Aligner à droite [image].
      •
      Pour aligner les bords supérieurs des objets, choisissez Disposition > Aligner > Haut ou cliquez sur l'icône Aligner en haut [image].
      •
      Pour aligner les bords inférieurs des objets, choisissez Disposition > Aligner > Bas ou cliquez sur l'icône Aligner en bas [image].
Pour aligner les centres des objets sur la verticale
1.
Sélectionnez les objets à aligner.
2.
Choisissez Disposition > Aligner > Centrer verticalement ou cliquez sur l'icône Aligner le centre sur la verticale [image].
Pour aligner les centres des objets sur l'horizontale
1.
Sélectionnez les objets à aligner.
2.
Choisissez Disposition > Aligner > Centrer horizontalement ou cliquez sur l'icône Aligner le centre sur l'horizontale [image].
Voir aussi
Pour aligner des objets sur une grille
Pour centrer des objets sur la page
Pour répartir des objets
Raccourcis clavier pour manipuler les objets


Pour aligner des objets sur une grille

Vous pouvez aligner des objets sur les points de repère de la grille les plus proches. Il est possible d'ajuster les paramètres de la grille dans la palette Accessoires de dessin.
1.
Sélectionnez les objets à aligner.
2.
Choisissez Disposition > Aligner > Sur la grille.
Voir aussi
Pour aligner des objets les uns par rapport aux autres
Pour centrer des objets sur la page
Pour répartir des objets
Raccourcis clavier pour manipuler les objets
Palette Accessoires de dessin


Pour centrer des objets sur la page

Vous pouvez positionner un objet sur le centre horizontal ou vertical de la page. Ce dernier varie selon le format de page qui a été défini.
1.
Sélectionnez les objets à centrer.
2.
Choisissez Disposition > Centrer sur la page > Horizontalement ou Disposition > Centrer sur la page > Verticalement.
Voir aussi
Pour aligner des objets les uns par rapport aux autres
Pour aligner des objets sur une grille
Pour répartir des objets


Pour faire pivoter les objets

Il est possible de faire pivoter l'objet autour de son point d'ancrage par incrément de 90°, de 180° ou de 270°. Le point d'ancrage, défini par les coordonnées X et Y d'un objet, constitue le point de départ de la rotation.
1.
Sélectionnez l'objet.
2.
Dans la palette Disposition, sélectionnez la position du point d'ancrage par rapport au périmètre de l'objet dans la liste Position.
3.
Cliquez sur l'un des boutons de rotation [image].
Voir aussi
Propriétés de la palette Disposition


Pour répartir des objets

La fonction de répartition d'objets permet d'espacer les objets proportionnellement à l'intérieur de la zone définie par la sélection active. Les objets sélectionnés sont espacés proportionnellement sur l'horizontale ou la verticale, ou répartis en rangées et colonnes. Lorsque vous répartissez des objets dans la zone de sélection active, ils sont espacés proportionnellement entre le bord de l'objet le plus à gauche et le bord de l'objet le plus à droite.
Lorsque vous répartissez des objets en rangées et colonnes, les objets situés le plus près des bords extérieurs de la zone de sélection déterminent la position de la colonne la plus à gauche, de la colonne la plus à droite et des rangées du haut et du bas.
s'il s'agit d'une mise en forme complexe, il est plus facile de contrôler la répartition rangée par rangée ou colonne par colonne plutôt que de répartir tous les objets à la fois sur les rangées et les colonnes. Pour obtenir de meilleurs résultats, répartissez d'abord les objets sur la colonne la plus à gauche, puis sur la rangée la plus en haut. Sélectionnez ensuite chacune des rangées, puis alignez-les à gauche par rapport à la colonne la plus à gauche.
1.
Sélectionnez les objets à répartir.
2.
Effectuez l'une des opérations suivantes :
      •
      Pour répartir les objets proportionnellement sur l'horizontale dans la zone de sélection active, choisissez Disposition > Répartir > Horizontalement ou cliquez sur l'icône Répartir proportionnellement sur l'horizontale [image].
      •
      Pour espacer les objets proportionnellement sur la verticale dans la zone de sélection active, choisissez Disposition > Répartir > Verticalement ou cliquez sur l'icône Répartir proportionnellement sur la verticale [image].
      •
      Pour répartir les objets sur les rangées et les colonnes, choisissez Disposition > Répartir > En rangées et colonnes ou cliquez sur l'icône Répartir proportionnellement en rangées et colonnes [image].
Voir aussi
Pour aligner des objets les uns par rapport aux autres
Pour aligner des objets sur une grille
Pour centrer des objets sur la page
Raccourcis clavier pour manipuler les objets


Pour redimensionner les objets

Vous pouvez modifier la taille d'un objet ou d'un groupe d'objets à l'aide de la souris. Lorsque vous redimensionnez plusieurs objets à la fois, les objets sont redimensionnés proportionnellement. Pour modifier plusieurs objets et leur donner une taille différente, sélectionnez un objet à la fois et modifiez sa taille.
Vous pouvez également modifier la taille d'un objet à l'aide des paramètres de la palette Disposition.
vous pouvez redimensionner un champ d'image à condition que l'option Utiliser la taille de l'image ne soit pas activée dans la zone de liste Taille (située dans le panneau Champ de la palette Objet).
1.
Sélectionnez les objets à redimensionner.
2.
Placez le pointeur sur l'une des poignées de sélection. Lorsque le pointeur prend la forme d'une flèche bidirectionnelle, effectuez l'une des opérations suivantes :
      •
      Pour agrandir l'objet sélectionné, faites glisser la poignée de manière à l'éloigner de l'objet.
      •
      Pour réduire l'objet sélectionné, faites glisser la poignée vers l'intérieur de l'objet.
Au fur et à mesure que vous faites glisser la poignée, la barre d'état affiche la taille de l'objet.
Voir aussi
Pour donner la même taille aux objets
Propriétés de la palette Disposition


Pour donner la même taille aux objets

Vous pouvez appliquer la même taille (largeur, hauteur ou les deux) à deux objets ou plus. Les dimensions du dernier objet que vous avez sélectionné déterminent la largeur et la hauteur utilisées. Par exemple, si vous cliquez sur plusieurs objets en maintenant la touche Maj enfoncée pour leur donner la même largeur, ils sont redimensionnés en fonction de la largeur de l'objet sélectionné en dernier. Dans un groupe d'objets sélectionnés, le dernier objet est reconnaissable aux poignées pleines.
vous pouvez redimensionner un champ d'image à condition que l'option Utiliser la taille de l'image ne soit pas activée dans la zone de liste Taille (située dans le panneau Champ de la palette Objet).
1.
Sélectionnez les objets à mettre à la même taille.
2.
Choisissez Disposition > Donner une même taille > [dimension].
Voir aussi
Pour aligner des objets les uns par rapport aux autres
Pour redimensionner les objets


Pour ajuster les objets au contenu

Lorsque des données sont insérées dans un objet, l'objet peut s'étendre en hauteur et en largeur par rapport à son point d'ancrage. Puisque l'agrandissement d'un objet se fait toujours dans la direction opposée au point d'ancrage, ce dernier peut restreindre la direction dans laquelle l'objet peut s'étendre. Par exemple, si vous avez sélectionné la position Haut milieu, l'objet ne peut s'étendre que vers la gauche, la droite et le bas.
évitez de sélectionner l’option Ajuster pour les formulaires compatibles avec Acrobat 6. Sinon, les utilisateurs ne seront pas en mesure de modifier les données des champs extensibles dans les formulaires compatibles avec Acrobat 6. Définissez plutôt la position et la taille des champs de manière à pouvoir saisir la plus grande valeur possible.
1.
Sélectionnez l'objet.
2.
Dans la palette Disposition, sélectionnez l'option Ajuster de la zone Hauteur ou de la zone Largeur, ou des deux.
Voir aussi
Propriétés de la palette Disposition


Pour définir la position des objets

Vous pouvez positionner un objet avec précision en entrant ses coordonnées X et Y dans la palette Disposition. La coordonnée X définit la position horizontale de l'objet par rapport au côté gauche de la page. La coordonnée Y définit la position verticale de l'objet par rapport au haut de la page. La taille totale d'un objet comprend la légende (le cas échéant) et la zone de saisie associée.
1.
Sélectionnez l'objet.
2.
Dans le menu contextuel de la palette Disposition, sélectionnez l'une ou l'autre de ces options :
      •
      Coordonnées absolues
      •
      Coordonnées relatives
3.
Dans la palette Disposition, spécifiez les coordonnées X et Y de l'objet.
Voir aussi
Propriétés de la palette Disposition


Formatage des objets

Pour ajouter de l'espace autour d'un objet
Pour ajouter une bordure autour d'un objet
Pour ajouter une bordure autour de la zone remplissable
Pour changer le formatage par défaut des nouveaux objets
Mise en forme du texte et des paragraphes


Pour ajouter de l'espace autour d'un objet

Un espace blanc (marge) doit être réservé autour de chacun des objets.
1.
Sélectionnez l'objet.
2.
Définissez les marges (supérieure, inférieure, de droite et de gauche) dans la palette Disposition.
Voir aussi
Propriétés de la palette Disposition


Pour ajouter une bordure autour d'un objet

Pour définir les propriétés de bordure d'un objet qui prend en charge les bordures, vous devez d'abord sélectionner l'objet. Les propriétés que vous définissez dans la palette Bordure affectent l'objet en entier.
1.
Sélectionnez l'objet.
2.
Dans la palette Bordure, sélectionnez une option de modification dans la liste Contours.
      •
      Pour appliquer la bordure séparément à chacun des bords, choisissez Modifier individuellement. Cette option ne s'applique pas aux bordures tridimensionnelles.
      •
      Pour appliquer la même bordure à tous les bords, choisissez Modifier ensemble.
3.
Sous la zone Contours, sélectionnez le style, la largeur et la couleur des bordures.
4.
Si vous voulez que les coins du rectangle soient inversés, cliquez sur l'un des boutons de la zone Coins et dans la zone Rayon, définissez le rayon des coins (en pouces, en centimètres ou en points).
5.
Pour colorer l'objet ou y appliquer un motif, sélectionnez une option dans la liste Style et choisissez la couleur appropriée en utilisant les boutons de remplissage.
Voir aussi
Propriétés de la palette Bordure
Pour ajouter une bordure autour de la zone remplissable


Pour ajouter une bordure autour de la zone remplissable

Il est également possible de définir des propriétés de bordure pour les zones remplissables d'un objet. Par exemple, pour un champ de texte, vous pouvez définir un type de bordure et de fond pour l'ensemble de l'objet et un autre type de bordure et de fond pour la zone qui affiche les données. Les objets ci-dessous comportent des zones remplissables :
      •
      Boutons
      •
      Cases à cocher
      •
      Champs de signature du document
      •
      Listes déroulantes
      •
      Zones de liste
      •
      Champs numériques
      •
      Champs de mot de passe
      •
      Boutons radio
      •
      Champs de texte
1.
Sélectionnez l'objet.
2.
Cliquez sur l'onglet Champ de la palette Objet. Dans la liste Aspect, sélectionnez Personnalisé.
3.
Sélectionnez le style de la bordure de la zone remplissable. Les options sont les mêmes que celles de la palette Bordure.
4.
Le cas échéant, entrez une largeur et sélectionnez une couleur de bordure pour l'objet.
5.
Si vous voulez que les coins du rectangle soient inversés, cliquez sur l'un des boutons de la zone Coins et dans la zone Rayon, définissez le rayon des coins (en pouces, en centimètres ou en points).
6.
Pour colorer la zone remplissable ou y appliquer un motif, sélectionnez une option dans la liste Style et choisissez la couleur appropriée en utilisant les boutons de remplissage.
Voir aussi
Pour ajouter une bordure autour d'un objet
Propriétés de la palette Bordure


Pour changer le formatage par défaut des nouveaux objets

Il est possible de redéfinir le mode de formatage par défaut des nouveaux objets et d'enregistrer vos paramètres dans la bibliothèque. Rien ne vous empêche, par exemple, de remplacer la police par défaut de tous les nouveaux objets de texte par la police Times New Roman.
1.
Insérez un objet.
2.
Apportez les modifications voulues à l'objet. Ajoutez une bordure, appliquez une autre police ou changez la taille du texte, par exemple.
3.
Faites glisser l’objet dans une catégorie de la palette Bibliothèque.
4.
Dans la boîte de dialogue Ajouter un objet de bibliothèque, saisissez le nom de l'objet et cliquez sur OK.
S'il existe déjà un objet portant le même nom dans ce panneau, LiveCycle Designer vous demande si vous souhaitez le remplacer.
Voir aussi
Propriétés de la palette Police
Propriétés de la palette Paragraphe
Propriétés de la palette Bordure


Mise en forme du texte et des paragraphes

A propos de la mise en forme du texte
Pour appliquer une autre police
Pour changer la taille du texte
Pour décaler le texte vers le haut ou vers le bas
Pour appliquer le style italique, gras, soulignement ou barré
Pour changer la couleur du texte
A propos de la mise en forme des paragraphes
Pour aligner les paragraphes
Pour changer la mise en retrait des paragraphes
Pour changer l'espacement des paragraphes


A propos de la mise en forme du texte

Vous pouvez définir les propriétés de police des objets de texte, des légendes des objets ainsi que des valeurs des données.
La palette Police contient toutes les propriétés de police disponibles. Voici les propriétés qu'il est possible de définir dans cette palette :
      •
      Type de police
      •
      Taille et style de police
      •
      Décalage par rapport à la ligne de base ou quantité d'espace pour déplacer les caractères vers le haut ou vers le bas.
Vous pouvez utiliser la barre d'outils Polices pour définir rapidement les propriétés de mise en forme des polices notamment le type de police, la taille et le style.
si vous créez des objets susceptibles d'afficher du texte utilisant des caractères non latins, assurez-vous de choisir une police pour l'objet prenant en charge l'ensemble du jeu de caractères de la langue et le paramètre régional approprié dans le panneau Champ de la palette Objet.
Voir aussi
Propriétés de la palette Police


Pour appliquer une autre police

1.
Sélectionnez le texte que vous avez l'intention de modifier ou sélectionnez l'objet.
Si l'option Edition > Verrouiller le texte est activée, cliquez deux fois sur le texte.
2.
Effectuez l'une des opérations suivantes :
      •
      Pour changer la légende et la valeur de données, dans la palette Police, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la légende et la valeur.
      •
      Pour changer uniquement la légende, dans la palette Police, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la légende.
      •
      Pour changer uniquement la valeur de données, dans la palette Police, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la valeur.
3.
Sélectionnez un nom de police dans la liste correspondante de la palette Police.
Voir aussi
Propriétés de la palette Police


Pour changer la taille du texte

1.
Sélectionnez le texte que vous avez l'intention de modifier ou sélectionnez l'objet.
Si l'option Edition > Verrouiller le texte est activée, cliquez deux fois sur le texte.
2.
Effectuez l'une des opérations suivantes :
      •
      Pour changer la légende et la valeur de données, dans la palette Police, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la légende et la valeur.
      •
      Pour changer uniquement la légende, dans la palette Police, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la légende.
      •
      Pour changer uniquement la valeur de données, dans la palette Police, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la valeur.
3.
Entrez ou sélectionnez une taille en point dans la zone correspondante de la palette Police.
Voir aussi
Propriétés de la palette Police


Pour décaler le texte vers le haut ou vers le bas

1.
Sélectionnez le texte que vous avez l'intention de modifier ou sélectionnez l'objet.
Si l'option Edition > Verrouiller le texte est activée, cliquez deux fois sur le texte.
2.
Effectuez l'une des opérations suivantes :
      •
      Pour changer la légende et la valeur de données, dans la palette Police, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la légende et la valeur.
      •
      Pour changer uniquement la légende, dans la palette Police, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la légende.
      •
      Pour changer uniquement la valeur de données, dans la palette Police, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la valeur.
3.
Entrez la valeur de décalage souhaitée dans la zone Décalage sur la ligne de base de la palette Police.
Voir aussi
Propriétés de la palette Police


Pour appliquer le style italique, gras, soulignement ou barré

1.
Sélectionnez le texte que vous avez l'intention de modifier ou sélectionnez l'objet.
Si l'option Edition > Verrouiller le texte est activée, cliquez deux fois sur le texte.
2.
Effectuez l'une des opérations suivantes :
      •
      Pour changer la légende et la valeur de données, dans la palette Police, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la légende et la valeur.
      •
      Pour changer uniquement la légende, dans la palette Police, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la légende.
      •
      Pour changer uniquement la valeur de données, dans la palette Police, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la valeur.
3.
Dans la palette Police, effectuez l'une des actions suivantes :
      •
      Pour mettre l'élément en caractères gras, cliquez sur l'icône Gras.
      •
      Pour mettre l'élément en italiques, cliquez sur l'icône Italique.
      •
      Pour souligner l'élément, cliquez sur l'icône Soulignement.
      •
      Pour barrer l'élément, cliquez sur l'icône Barré.
Voir aussi
Propriétés de la palette Police


Pour changer la couleur du texte

1.
Sélectionnez le texte que vous avez l'intention de modifier ou sélectionnez l'objet.
Si l'option Edition > Verrouiller le texte est activée, cliquez deux fois sur le texte.
2.
Effectuez l'une des opérations suivantes :
      •
      Pour changer la légende et la valeur de données, dans la palette Police, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la légende et la valeur.
      •
      Pour changer uniquement la légende, dans la palette Police, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la légende.
      •
      Pour changer uniquement la valeur de données, dans la palette Police, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la valeur.
3.
Dans la palette Police, cliquez sur le sélecteur de couleur et choisissez la couleur voulue.
Voir aussi
Propriétés de la palette Police


A propos de la mise en forme des paragraphes

Vous pouvez définir les propriétés de paragraphes des objets de texte, des légendes d'objets ainsi que des valeurs des données. Pour définir ces propriétés, vous devez d'abord sélectionner l'objet.
La palette Paragraphe contient toutes les propriétés de paragraphe disponibles dans LiveCycle Designer. Les propriétés de paragraphe suivantes peuvent être définies dans la palette Paragraphe :
      •
      Alignement horizontal et vertical
      •
      Retrait
      •
      Espacement et interligne
Vous pouvez utiliser la barre d'outils Paragraphe pour accéder rapidement à la plupart des commandes de mise en forme courantes des paragraphes.
Voir aussi
Propriétés de la palette Paragraphe


Pour aligner les paragraphes

1.
Sélectionnez le texte que vous avez l'intention de modifier ou sélectionnez l'objet.
Si l'option Edition > Verrouiller le texte est activée, cliquez deux fois sur le texte.
2.
Effectuez l'une des opérations suivantes :
      •
      Pour changer la légende et la valeur de données, dans la palette Paragraphe, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la légende et la valeur.
      •
      Pour changer uniquement la légende, dans la palette Paragraphe, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la légende.
      •
      Pour changer uniquement la valeur de données, dans la palette Paragraphe, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la valeur.
3.
Effectuez l'une des opérations suivantes :
      •
      Pour aligner le texte à gauche ou à droite, cliquez sur Aligner à gauche ou Aligner à droite dans la palette Paragraphe.
      •
      Pour centrer le texte, cliquez sur Aligner au centre dans la palette Paragraphe.
      •
      Pour justifier le texte, cliquez sur Justifier dans la palette Paragraphe.
      •
      Pour aligner le texte sur le haut de la zone réservée à la légende et à la valeur, cliquez sur Aligner en haut dans la palette Paragraphe.
      •
      Pour aligner le texte avec le milieu de la zone réservée à la légende et à la valeur, cliquez sur Aligner au milieu dans la palette Paragraphe.
      •
      Pour aligner le texte sur le bas de la zone réservée à la légende et à la valeur, cliquez sur Aligner en bas dans la palette Paragraphe.
Voir aussi
Propriétés de la palette Paragraphe


Pour changer la mise en retrait des paragraphes

1.
Sélectionnez le texte que vous avez l'intention de modifier ou sélectionnez l'objet.
Si l'option Edition > Verrouiller le texte est activée, cliquez deux fois sur le texte.
2.
Effectuez l'une des opérations suivantes :
      •
      Pour changer la légende et la valeur de données, dans la palette Paragraphe, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la légende et la valeur.
      •
      Pour changer uniquement la légende, dans la palette Paragraphe, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la légende.
      •
      Pour changer uniquement la valeur de données, dans la palette Paragraphe, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la valeur.
3.
Effectuez l'une des opérations suivantes :
      •
      Pour augmenter ou réduire le retrait du texte à gauche, entrez la valeur de retrait désirée dans la zone prévue à cet effet sous Retraits dans la palette Paragraphe.
      •
      Pour augmenter ou réduire le retrait du texte à droite, entrez la valeur de retrait désirée dans la zone prévue à cet effet sous Retraits dans la palette Paragraphe.
      •
      Pour créer un retrait de première ligne (alinéa), sélectionnez Première ligne dans la zone correspondante de la palette Paragraphe. Tapez la valeur du retrait dans la zone De.
      •
      Pour créer un retrait négatif, sélectionnez Négatif dans la zone correspondante de la palette Paragraphe. Tapez la valeur du retrait dans la zone De.
Voir aussi
Propriétés de la palette Paragraphe


Pour changer l'espacement des paragraphes

1.
Sélectionnez le texte que vous avez l'intention de modifier ou sélectionnez l'objet.
Si l'option Edition > Verrouiller le texte est activée, cliquez deux fois sur le texte.
2.
Effectuez l'une des opérations suivantes :
      •
      Pour changer la légende et la valeur de données, dans la palette Paragraphe, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la légende et la valeur.
      •
      Pour changer uniquement la légende, dans la palette Paragraphe, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la légende.
      •
      Pour changer uniquement la valeur de données, dans la palette Paragraphe, cliquez sur le menu Modification de la légende et de la valeur et sélectionnez Modifier la valeur.
3.
Effectuez l'une des opérations suivantes :
      •
      Pour changer l'espacement avant ou après le texte, entrez l'espacement voulu dans la zone Dessus ou Dessous sous Espacement dans la palette Paragraphe.
      •
      Pour espacer les lignes, sélectionnez une option dans la zone Interligne de la palette Paragraphe.
Voir aussi
Propriétés de la palette Paragraphe


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation de collections d'objets de formulaire

Utilisation de collections d'objets de formulaire

A propos des collections d'objets de formulaire


A propos des collections d'objets de formulaire

Pour créer une collection d'objets de formulaire
Pour copier une collection d'objets de formulaire
Pour renommer une collection d'objets de formulaire
Pour modifier une collection d'objets de formulaire
Pour supprimer une collection d'objets de formulaire
Vous pouvez restreindre la sélection aux objets devant comporter un champ de signature du document ou devant être encodés dans un code à barres de formulaires pour support papier et les enregistrer en tant que collection.
Une collection s'applique soit aux champs de signature du document, soit aux codes à barres de formulaires pour support papier, mais jamais au deux, car les objets sont représentés de manière différente. Les collections disponibles pour les champs de signature du document se trouvent dans l'onglet Signature du document de la palette Objet. Les collections disponibles pour les codes à barres de formulaires pour support papier se trouvent dans l'onglet Valeur de la palette Objet.
Voir aussi
A propos des signatures numériques
Aperçu des codes à barres de formulaires pour support papier


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation de collections d'objets de formulaire > A propos des collections d'objets de formulaire > Pour créer une collection d'objets de formulaire

Pour créer une collection d'objets de formulaire

Vous pouvez créer une collection pour les champs de signature du document ou pour les codes à barres de formulaires pour support papier. Vous avez la possibilité de créer une ou plusieurs collections, puis d'en sélectionner une pour un champ de signature du document ou un code à barres de formulaire pour support papier particulier.
1.
Choisissez Fichier > Collections d'objets de formulaire.
2.
Cliquez sur Créer, puis saisissez le nom de la collection dans la zone prévue à cet effet.
3.
Cliquez sur Modifier, puis sélectionnez l'option requise dans la liste Type de collection. La liste affiche les objets disponibles du type de collection sélectionné.
4.
Sélectionnez les objets à inclure dans la collection. Pour masquer les objets du type de collection non pris en charge, sélectionnez Masquer les nœuds non pris en charge.
5.
Cliquez sur OK.
Voir aussi
Pour ajouter un champ de signature du document
Propriétés des champs de signature du document dans le panneau Champ
Conseils de conception sur l’utilisation d’un code à barres de formulaires pour support papier
Propriétés des codes à barres de formulaires pour support papier dans le panneau Valeur
Boîte de dialogue Editeur de collections
Boîte de dialogue Liste des collections


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation de collections d'objets de formulaire > A propos des collections d'objets de formulaire > Pour copier une collection d'objets de formulaire

Pour copier une collection d'objets de formulaire

1.
Choisissez Fichier > Collections d'objets de formulaire.
2.
Sélectionnez une collection dans la liste, puis cliquez sur Dupliquer.
3.
Cliquez deux fois sur la collection et tapez un nom.
4.
Pour définir la position de la collection, cliquez sur Monter ou Descendre.
Voir aussi
Pour ajouter un champ de signature du document
Propriétés des champs de signature du document dans le panneau Champ
Conseils de conception sur l’utilisation d’un code à barres de formulaires pour support papier
Propriétés des codes à barres de formulaires pour support papier dans le panneau Valeur
Boîte de dialogue Editeur de collections
Boîte de dialogue Liste des collections


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation de collections d'objets de formulaire > A propos des collections d'objets de formulaire > Pour renommer une collection d'objets de formulaire

Pour renommer une collection d'objets de formulaire

1.
Choisissez Fichier > Collections d'objets de formulaire.
2.
Cliquez deux fois sur la collection dans la liste et tapez le nouveau nom.
Voir aussi
Pour ajouter un champ de signature du document
Propriétés des champs de signature du document dans le panneau Champ
Conseils de conception sur l’utilisation d’un code à barres de formulaires pour support papier
Propriétés des codes à barres de formulaires pour support papier dans le panneau Valeur
Boîte de dialogue Editeur de collections
Boîte de dialogue Liste des collections


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation de collections d'objets de formulaire > A propos des collections d'objets de formulaire > Pour modifier une collection d'objets de formulaire

Pour modifier une collection d'objets de formulaire

1.
Suivez l'une des méthodes suivantes :
      •
      Sélectionnez Fichier > Collections d'objets de formulaire, puis passez à l'étape 3.
      •
      Sélectionnez sur la page un champ de signature du document ou un code à barres de formulaires pour support papier.
2.
Effectuez l'une des opérations suivantes :
      •
      Pour modifier une collection pour un code à barres de formulaires pour support papier, cliquez sur l'onglet Valeur de la palette Objet.
      •
      Pour modifier une collection pour un champ de signature du document, cliquez sur l'onglet Signature du document de la palette Objet.
3.
Dans la liste Collection, sélectionnez Créer/Gérer une collection.
4.
Sélectionnez la collection que vous souhaitez modifier, puis cliquez sur Modifier.
5.
Sélectionnez l'option désirée dans la liste Type de collection.
6.
Sélectionnez les objets à supprimer ou à inclure dans la collection. Pour masquer les objets du type de collection non pris en charge, sélectionnez Masquer les nœuds non pris en charge.
7.
Cliquez sur OK.
8.
Pour définir la position de la collection, cliquez sur Monter ou Descendre.
Voir aussi
Pour ajouter un champ de signature du document
Propriétés des champs de signature du document dans le panneau Champ
Conseils de conception sur l’utilisation d’un code à barres de formulaires pour support papier
Propriétés des codes à barres de formulaires pour support papier dans le panneau Valeur
Boîte de dialogue Editeur de collections
Boîte de dialogue Liste des collections


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Utilisation de collections d'objets de formulaire > A propos des collections d'objets de formulaire > Pour supprimer une collection d'objets de formulaire

Pour supprimer une collection d'objets de formulaire

1.
Choisissez Fichier > Collections d'objets de formulaire.
2.
Sélectionnez une collection dans la liste, cliquez sur Supprimer, puis sur Oui.
Voir aussi
Pour ajouter un champ de signature du document
Propriétés des champs de signature du document dans le panneau Champ
Conseils de conception sur l’utilisation d’un code à barres de formulaires pour support papier
Propriétés des codes à barres de formulaires pour support papier dans le panneau Valeur
Boîte de dialogue Editeur de collections
Boîte de dialogue Liste des collections


Méthodes pour rendre des objets visibles ou invisibles ou les masquer

A propos des méthodes pour rendre des objets visibles ou invisibles ou les masquer
Pour rendre un objet visible ou invisible ou le masquer


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation des objets > Méthodes pour rendre des objets visibles ou invisibles ou les masquer > A propos des méthodes pour rendre des objets visibles ou invisibles ou les masquer

A propos des méthodes pour rendre des objets visibles ou invisibles ou les masquer

Selon l'objectif du formulaire, il est possible de choisir les objets visibles dans un formulaire PDF lorsque les utilisateurs l'affichent dans Acrobat ou Adobe Reader ou lorsqu'ils l'impriment. Grâce aux différentes options proposées dans la zone Visibilité de la palette Objet, vous pouvez rendre différents objets d'un formulaire PDF visibles, invisibles ou les masquer lorsque le formulaire est affiché à l'écran ou imprimé.
Tenez compte des points suivants lorsque vous appliquez les options de visibilité aux objets :
      •
      Les options Invisible et Masqué ne concernent pas les groupes, les zones de contenu, les gabarits, les jeux de pages et les jeux de sous-formulaires.
      •
      L'option de visibilité que vous appliquez aux objets conteneur (tels que les zones de contenu et les sous-formulaires) a priorité sur celle que vous appliquez à chaque objet contenu. Si vous appliquez, par exemple, l'option Visible (Impression seulement) à un jeu de sous-formulaires, le sous-formulaire et les objets collectés n'apparaissent pas à l'écran, mais sont visibles sur le formulaire imprimé, quel que soit le paramètre de visibilité défini pour les objets individuels.
      •
      Si vous avez l'intention d'imprimer un formulaire, n'appliquez pas l'option Visible (Ecran seulement) aux objets de zone de contenu dans le formulaire. Dans le cas contraire, la zone de contenu sera visible à l'écran, mais pas sur le formulaire imprimé. De plus, le formulaire ne sera pas imprimé correctement. Un marqueur d’avertissement s'affiche dans le coin supérieur droit du gabarit lorsqu'aucune zone de contenu ou aucun gabarit n'est visible à l'écran et sur le formulaire imprimé.
      •
      Si vous appliquez l'option Visible (Impression seulement) à un objet, l'objet apparaît dans les panneaux Vue de conception et Gabarit, mais pas dans le panneau Aperçu PDF.
La section suivante décrit plusieurs modes d'utilisation possibles des options de visibilité :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Si vous souhaitez, par exemple, que l'aspect du formulaire soit le même à l'écran et à l'impression, il suffit d'appliquer l'option Visible à l'ensemble des objets du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire. Si vous disposez, par exemple, d'un formulaire que les utilisateurs remplissent, soumettent en ligne, puis impriment, vous pouvez appliquer l'option Visible (Ecran seulement) aux boutons Imprimer et Envoyer afin qu'ils soient visibles à l'écran, mais pas sur le formulaire imprimé.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire. Si vous avez besoin, par exemple, d'inclure sur le formulaire imprimé un texte d'instruction qu'il est inutile d'afficher à l'écran (comme dans le cas d'informations au sujet du renvoi du formulaire par la poste), vous pouvez appliquer l'option Visible (Impression seulement) aux objets de champ de texte contenant les instructions, de façon à ce que le texte soit visible à l'impression, mais pas à l'écran.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire. Si vous souhaitez qu'une partie d'un formulaire reste invisible tant que l'utilisateur n'a pas sélectionné une option spécifique, comme par exemple la section relative aux conditions de paiement sur un formulaire de facturation, vous pouvez appliquer l'option Invisible aux objets de champ de texte utilisés pour collecter les données de la carte de crédit, de façon à ce qu'ils apparaissent uniquement lorsque l'utilisateur sélectionne un bouton radio correspondant au type de carte de crédit.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire. Si vous souhaitez, par exemple, qu'une section d'un formulaire reste masquée tant que l'utilisateur n'a pas sélectionné une option spécifique et qu'elle n'occupe pas d'espace particulier dans la conception de formulaire, vous pouvez appliquer l'option Masqué (pas affiché) au sous-formulaire contenant les différents objets de la section, de façon à ajuster la disposition du formulaire aux conditions d'utilisation.


Pour rendre un objet visible ou invisible ou le masquer

La zone Visibilité s'affiche dans différents panneaux en fonction de l'objet sélectionné.
1.
Sélectionnez l'objet.
2.
Cliquez sur l'onglet approprié de la palette Objet.
3.
Dans la liste Visibilité, sélectionnez une des options suivantes :
      •
      Pour rendre l'objet visible à l'écran et sur le formulaire imprimé et le prendre en compte dans la disposition du formulaire, sélectionnez Visible.
      •
      Pour rendre l'objet visible à l'écran, invisible sur le formulaire imprimé et le prendre en compte dans la disposition du formulaire, sélectionnez Visible (Ecran seulement).
      •
      Pour rendre l'objet invisible à l'écran, visible sur le formulaire imprimé et le prendre en compte dans la disposition du formulaire, sélectionnez Visible (Impression seulement).
      •
      Pour rendre l'objet invisible à l'écran et sur le formulaire imprimé et le prendre en compte dans la disposition du formulaire, sélectionnez Invisible.
      •
      Pour rendre l'objet invisible à l'écran et sur le formulaire imprimé sans le prendre en compte dans la disposition du formulaire, sélectionnez Masqué (pas affiché).


Formatage des légendes

A propos des légendes
Pour renommer une légende
Pour positionner une légende
Pour définir l'espace à réserver pour la légende
Pour ajuster automatiquement l'espace réservé à la légende
Pour masquer une légende


A propos des légendes

Plusieurs objets de champs standard de la palette Bibliothèque prennent en charge les légendes. Celles-ci fournissent des informations textuelles aux programmes de visualisation du formulaire final.
Lorsque vous ajoutez un objet qui prend en charge les légendes, LiveCycle Designer attribue un nom par défaut à la légende. Le nom par défaut est celui de l'objet. Par exemple, si vous ajoutez un objet de zone de liste à la conception du formulaire, la légende par défaut est Zone de liste.
Lors de la création de la conception de formulaire, vous pouvez voir la légende de l'objet à deux endroits : dans la conception du formulaire, au-dessus de l'objet (position par défaut) ou dans le panneau Champ de la palette Objet.
Vous pouvez modifier la légende en cliquant sur l'onglet Champ de la palette Objet ou en changeant le texte de la légende directement sur la page. Si le texte est renvoyé à la ligne suivante au fur et à mesure que vous tapez, augmentez la taille de l'objet pour afficher le texte correctement. Si une croix blanche s'affiche dans une zone rouge [image], vous devez redimensionner l'objet ou ajuster l'espace réservé à la légende. Si la propriété reserve a la valeur 0, l'ajustement automatique est défini pour la légende. La légende est protégée et ne peut pas être modifiée par les utilisateurs qui remplissent le formulaire.
Si vous devez réorganiser des objets de champ, sans risquer de modifier leurs légendes, vous pouvez utiliser la commande Verrouiller le texte. Cette commande permet de déplacer facilement les objets de champ, mais complique leur modification.
vous ne pouvez pas sélectionner ou modifier des légendes si un objet de champ est verrouillé. Voir Pour verrouiller des objets.
Voir aussi
Mise en forme du texte et des paragraphes
Pour créer une légende en fusionnant un objet de texte et un objet de champ
Pour insérer des numéros propres à la langue dans du texte ou des légendes
Propriétés de la palette Police
Propriétés de la palette Paragraphe
Propriétés de la palette Disposition


Pour renommer une légende

1.
Sélectionnez l'objet.
2.
Effectuez l'une des opérations suivantes :
      •
      Pour changer la légende dans l'éditeur de disposition, sélectionnez le texte et saisissez une nouvelle légende. Si l'option Edition > Verrouiller le texte est activée, cliquez deux fois sur le texte.
      •
      Pour changer la légende à l'aide de la palette Objet, cliquez sur l'onglet Champ et entrez une nouvelle légende dans la zone prévue à cet effet.
vous pouvez remplir une légende de manière dynamique à l'aide d'une valeur issue d'une source de données.
Voir aussi
Pour verrouiller des objets
Pour remplir de façon dynamique une légende


Pour positionner une légende

L'emplacement des légendes est défini par rapport à la zone remplissable de l'objet.
1.
Sélectionner un ou plusieurs objets
2.
Dans la palette Disposition, sélectionnez la position de la légende dans la liste Ancrage.


Pour définir l'espace à réserver pour la légende

Vous pouvez ajuster l'espace situé entre la légende et la zone remplissable.
1.
Sélectionner un ou plusieurs objets
2.
Dans la palette Disposition, tapez une nouvelle valeur dans la zone Réserver.
si vous définissez un espace réservé avant de sélectionner la position du libellé, LiveCycle Designer ajuste automatiquement cet espace.


Pour ajuster automatiquement l'espace réservé à la légende

1.
Sélectionnez un ou plusieurs objets.
2.
Dans la palette Disposition, tapez 0 dans la zone Réserver. Cette valeur permet d'ajuster automatiquement la zone réservée à la légende.
Voir aussi
Propriétés de la palette Disposition


Pour masquer une légende

1.
Sélectionnez un ou plusieurs objets.
2.
Dans la liste Position de la palette Disposition, sélectionnez Aucune.
Voir aussi
Propriétés de la palette Disposition


Formatage des valeurs de champ

A propos des formats et des valeurs de format
Utilisation des formats
Valeurs de mise en forme par défaut
Pour définir une valeur par défaut
Pour définir un format d'affichage
Pour inviter les utilisateurs à entrer des données
Pour définir un format de saisie
Pour valider les données utilisateur
Pour spécifier un modèle de données
Formats simples
Paramètres régionaux
Epoque
Formats de date
Formats d’heure
Formats de date et heure
Formats de champ complexes


A propos des formats et des valeurs de format

En fonction de la situation, vous pouvez indiquer un ou plusieurs formats pour contrôler la mise en forme des valeurs de champs (champs de texte, champs numériques et champs de date et d'heure) au moment de l'exécution :
      •
      Un format d'affichage qui décrit comment les données s'affichent dans le formulaire. Si vous définissez une valeur par défaut initiale, elle respecte le format d'affichage. Le format d'affichage gère également le formatage des valeurs entrées par l'utilisateur et de toutes les valeurs liées qui sont récupérées au moment de l'exécution.
      •
      Un format de saisie qui décrit la syntaxe des valeurs à entrer à l'exécution dans un champ de date/heure, un champ numérique, un champ de texte ou un champ de mot de passe.
      •
      Un modèle de validation qui sert à vérifier la valeur entrée par l'utilisateur à l'exécution.
      •
      Un modèle de données qui décrit la syntaxe des données liées ou enregistrées.
Les options de formatage que vous choisissez dépendent de l'utilisation que vous comptez faire de votre formulaire. Par exemple, si vous concevez un formulaire interactif, vous devriez définir pour chaque champ un format de saisie pour traiter les données entrées par l'utilisateur et un modèle de validation pour les vérifier. Vous ne devriez avoir besoin de définir un modèle de données que si les champs sont liés à une source de données.
Voir aussi
Utilisation des formats
Pour définir une valeur par défaut
Pour définir un format d'affichage
Pour inviter les utilisateurs à entrer des données
Pour définir un format de saisie
Pour valider les données utilisateur
Pour spécifier un modèle de données


Utilisation des formats

Utilisez les formats pour contrôler le traitement des valeurs de champ à l'exécution. Par exemple, les utilisateurs peuvent entrer des lettres et des chiffres dans un champ de texte où la ponctuation et les espaces sont automatiquement appliqués conformément au format prédéfini avant que le champ ne s'affiche.
Capture et affichage des données utilisateur
Si vous créez un formulaire qui capture des données, vous pouvez définir le format de ces données et le format d'affichage des données. Si vous n'indiquez pas de format d'affichage, les données respectent le format par défaut de LiveCycle Designer.
Si les utilisateurs risquent d’entrer des données qui ne correspondent pas aux valeurs par défaut de LiveCycle Designer, vous devez indiquer un format de saisie. Le format de saisie décrit la syntaxe des valeurs que doit entrer l'utilisateur. En fonction du format, l'application d'exécution convertit les valeurs entrées par l'utilisateur en données brutes, puis les formate conformément au format d'affichage.
Si vous concevez un formulaire interactif, vous devez assurer une validation adéquate des valeurs entrées par l'utilisateur. Vous pouvez choisir d'afficher un message personnalisé qui invite les utilisateurs à entrer les valeurs au format approprié au moment de l'exécution. Si vous ne spécifiez pas de message, le système en génère un automatiquement.
il est possible d'utiliser des formules FormCalc et des scripts JavaScript pour traiter les valeurs entrées par l'utilisateur (par exemple, un script peut demander la valeur brute d'un champ). Comme les formules et les scripts utilisent des valeurs brutes et formatées, il est important de valider toutes les entrées.
Récupération et affichage des données liées
Si des champs liés sont fusionnés dans le formulaire, vous pouvez indiquer le format d'affichage selon lequel les données doivent être formatées. Si vous n’indiquez pas de format d’affichage, les données respectent le format par défaut de LiveCycle Designer.
Si les données liées ne respectent pas le format par défaut de LiveCycle Designer, vous devez indiquer un modèle de données. Le modèle de données décrit la syntaxe des données liées. En fonction du modèle, l'application d'exécution convertit les données récupérées en données brutes, puis les formate en vue de les afficher.
Voir aussi
A propos des formats et des valeurs de format
Valeurs de mise en forme par défaut


Valeurs de mise en forme par défaut

Les valeurs par défaut doivent être conformes aux règles suivantes, selon le type de champ.

Champ

Règle
Date/Heure
Une valeur date/heure par défaut doit se conformer au format court du paramètre régional spécifié pour le champ de date/heure. Cependant, par défaut, LiveCycle Designer affiche la valeur par défaut dans le format de paramètre régional moyen lors de la conception et de l'exécution.
Prenons l'exemple d'un formulaire dans lequel le champ de date/heure est configuré pour utiliser le paramètre régional allemand (Allemagne). Vous saisissez la valeur par défaut d'une date dans le format court DD.MM.YY. Après avoir placé la sélection sur un autre champ, la valeur spécifiée dans le champ de la page est affichée dans le format moyen DD.MM.YYYY. La valeur mise en forme apparaît également dans le format moyen si vous affichez le formulaire dans le panneau Aperçu PDF.
au moment de l'exécution, par défaut, les utilisateurs qui remplissent les formulaires doivent modifier la valeur des champs de date/heure en utilisant le format court du paramètre régional spécifié pour le champ. Si vous spécifiez un Format de saisie dans le panneau Champ, ce format remplace le format court et les utilisateurs doivent saisir les données conformes à ce format.
Champ numérique ou champ décimal
Une valeur numérique par défaut peut être un nombre entier ou un nombre décimal qui ne contient qu'une seule séparation fractionnaire. Le caractère fractionnaire peut être un point (.) ou une virgule (,) selon le paramètre régional sélectionné. Les séparateurs des milliers (ou symboles de regroupement) et les symboles monétaires ne sont pas valides en tant que valeur par défaut.
Par exemple, si un champ numérique est défini en fonction du paramètre régional Anglais (Etats-Unis) et que vous spécifiez la valeur par défaut $1,234.56, le symbole monétaire du dollar ($) et le séparateur des milliers de la virgule (,) ne sont pas valides.
Champ de texte
Une valeur de texte par défaut (y compris un mot de passe) peut être n'importe quelle chaîne alphanumérique pouvant contenir des espaces.
seuls les champs répertoriés dans le tableau comportent des valeurs par défaut devant être conformes à la mise en forme inhérente aux paramètres régionaux.
Voir aussi
A propos des formats et des valeurs de format
Formats simples
Formats de champ complexes
Formats de date
Formats d’heure


Pour définir une valeur par défaut

Les champs de date/heure, les champs numériques et les champs de texte peuvent afficher une valeur initiale (par défaut) à l'ouverture du formulaire. Cette valeur peut provenir d’une propriété d’exécution ou être une valeur que vous spécifiez explicitement dans LiveCycle Designer. Elle peut également provenir d'une source de données externe par le biais d'une liaison. Au moment de l'exécution, LiveCycle Designer définit la mise en forme des valeurs par défaut en fonction du paramètre régional spécifié pour chaque champ.
1.
Sélectionnez un champ de date/heure, un champ décimal, un champ numérique ou un champ de texte.
2.
Cliquez sur l'onglet Champ de la palette Objet. Sélectionnez un paramètre régional dans la liste correspondante.
3.
Cliquez sur l'onglet Valeur de la palette Objet. Tapez la valeur dans la zone Valeur par défaut.
La valeur par défaut doit être définie dans un format de paramètre régional.
si les données sont liées et qu'un modèle a été spécifié, la valeur doit correspondre au modèle de données défini dans le panneau Liaison.
Voir aussi
A propos des formats et des valeurs de format
Valeurs de mise en forme par défaut
Pour spécifier un modèle de données
Formats simples


Pour définir un format d'affichage

Lors de l'exécution, LiveCycle Designer affiche les valeurs des champs de date/heure et des champs numériques dans le format des paramètres régionaux. Si vous souhaitez afficher une valeur de champ dans un format autre que celui par défaut, vous pouvez spécifier le modèle personnalisé dans le panneau Champ.
les listes déroulantes prennent en charge les valeurs entrées par les utilisateurs, mais il n'est pas possible de définir un format d'affichage pour ces valeurs. Vous pouvez écrire un script pour formater, au besoin, la valeur entrée par l'utilisateur.
Puisque le format d'affichage détermine l'affichage des données dans le formulaire, toutes les valeurs par défaut, les valeurs entrées par les utilisateurs et les valeurs récupérées d'une base de données sont converties au format d'affichage défini.
les dates antérieures au 1 janvier 1900 ne sont pas affectées par le format d'affichage.
1.
Sélectionnez un champ de date/heure, un champ numérique ou un champ de texte.
2.
Cliquez sur l'onglet Champ de la palette Objet. Dans la zone Format d'affichage, sélectionnez un des formats prédéfinis ou entrez un format personnalisé.
Voir aussi
A propos des formats et des valeurs de format
Valeurs de mise en forme par défaut
Formats simples


Pour inviter les utilisateurs à entrer des données

Les invites sont utiles dans les cas où les utilisateurs doivent entrer des données ou effectuer une sélection. Vous pouvez rédiger un message pour inviter les utilisateurs à saisir une valeur dans un champ de date/heure, numérique, de texte, de mot de passe ou une liste déroulante, ou encore pour les inviter à sélectionner une option dans une liste déroulante, une zone de liste ou un groupe de boutons radio.
Si vous définissez un message pour un objet, il s'affiche dans les cas suivants :
      •
      L'utilisateur sort, à l'aide de la touche de tabulation, d'un champ de date/heure, numérique, de texte, de mot de passe ou d'une liste déroulante sans y avoir entré de données à l'exécution.
      •
      Aucune valeur n'a été spécifiée lorsque l'utilisateur tente de soumettre des données par l'intermédiaire d'un bouton d'envoi.
les utilisateurs ne peuvent pas soumettre un formulaire PDF qui contient des valeurs nulles alors que la saisie de ces valeurs est obligatoire. Toutefois, les utilisateurs peuvent enregistrer et fermer un formulaire PDF sans entrer les valeurs recommandées ou obligatoires. Dans un tel cas, aucun message n'invite les utilisateurs à entrer des valeurs.
1.
Sélectionnez le champ, la liste déroulante, la zone de liste ou le groupe de boutons radio.
2.
Cliquez sur l'onglet Valeur de la palette Objet. Dans la zone Type, sélectionnez l'une des options suivantes :
      •
      Entré par l'utilisateur - Recommandé
      •
      Entré par l'utilisateur - Obligatoire
3.
Dans la zone Message d'état vide, tapez le texte de l'invite. Le cas échéant, l'invite doit indiquer le format de saisie requis. Par exemple, si vous définissez un format de saisie, la valeur entrée par l'utilisateur doit respecter ce format.
Voir aussi
Pour définir un format de saisie
Pour valider les données utilisateur


Pour définir un format de saisie

Lors de l'exécution, LiveCycle Designer affiche les valeurs des champs de date/heure et des champs numériques dans le format des paramètres régionaux. Si vous souhaitez autoriser les utilisateurs à modifier des valeurs de champ dans un format autre que la valeur par défaut propre au paramètre régional, vous pouvez spécifier le format de saisie dans le panneau Champ. Si l'entrée de l'utilisateur n'est pas conforme au format de saisie, les données sont refusées et la mise en forme des valeurs de champ n'est pas effectuée.
Le format de saisie peut différer du format d'affichage. Par exemple, puisqu’il est plus facile pour les utilisateurs d’entrer des dates au format court et de lire des dates au format long, vous pouvez indiquer une date au format court dans le format de saisie d’un champ de date/heure et une date au format long dans son format d’affichage. Lorsque ces deux formats sont différents, les valeurs brutes sont formatées pour l'affichage dès que l'utilisateur quitte le champ.
1.
Sélectionnez un champ de date/heure, un champ numérique, un champ de texte ou un champ de mot de passe.
2.
Cliquez sur l'onglet Champ de la palette Objet. Dans la liste Format de saisie, saisissez un format personnalisé ou sélectionnez l'un des formats prédéfinis dans la liste.
Voir aussi
A propos des formats et des valeurs de format
Valeurs de mise en forme par défaut
Pour définir un format d'affichage
Formats simples


Pour valider les données utilisateur

Trois méthodes de validation sont possibles pour chaque champ. L'ordre d'exécution de ces validations est le suivant :
      •
      Test du champ pour s'assurer que son contenu n'est pas nul.
      •
      Comparaison du format de la valeur du champ par rapport à un format spécifique. Pour plus de détails sur les formats des champs, voir Formats simples.
      •
      Exécution d'un script de validation.
Vous pouvez définir un modèle de validation qui vérifie les valeurs entrées par les utilisateurs dans les champs de date/heure, les champs numériques, les champs de texte et les champs de mot de passe. Par défaut, les valeurs nulles ne sont pas acceptées lorsque la saisie de valeurs est obligatoire. Les valeurs brutes sont directement comparées au modèle de validation et, si elles correspondent, elles sont formatées pour l'affichage.
Si elles ne correspondent pas au modèle de validation, une erreur de programmation ou un avertissement s'affiche. L'erreur/avertissement est identifié(e) par Acrobat, Adobe Reader ou LiveCycle Forms, qui renvoie automatiquement un message à l'utilisateur. Si aucun format de saisie n'est défini et que la valeur entrée par l'utilisateur ne respecte pas le format par défaut de LiveCycle Designer, la validation échoue.
Un message de validation s'affiche si les objets nécessitant des valeurs contiennent des valeurs nulles et si l'utilisateur tente de soumettre des données à LiveCycle Forms.
les utilisateurs peuvent enregistrer et fermer un formulaire PDF sans entrer les valeurs obligatoires. Dans un tel cas, aucune validation n'est effectuée.
Si vous le désirez, vous pouvez taper un message de modèle de validation personnalisé qui remplace le message d'erreur ou d'avertissement par défaut.
Vous pouvez valider les données utilisateur à l'aide d'un modèle de validation et/ou, dans les cas où le modèle de validation n'est pas pris en charge (par exemple, pour les groupes de boutons radio et les cases à cocher), grâce à un script de validation. La validation des données par le biais d'un script permet de vous assurer qu'elles sont correctes pour votre application. Dans un tel cas, un message personnalisé et un avertissement ou une erreur d'exécution sont également pris en charge.
vous pouvez remplir de manière dynamique un message de modèle de validation à l'aide d'une valeur issue d'une source de données. Vous serez ainsi assuré que les utilisateurs saisissent la valeur correcte dans le champ.
Pour définir un modèle de validation et un message personnalisé
1.
Sélectionnez un champ de date/heure, un champ numérique, un champ de texte, un champ de mot de passe, une liste déroulante ou une zone de liste.
2.
Cliquez sur l'onglet Valeur de la palette Objet. Dans la zone Modèle de validation, sélectionnez un des formats prédéfinis ou entrez un format personnalisé.
Pour les champs de date/heure, les champs numériques, les champs de texte et les champs de mot de passe, le modèle de validation doit correspondre à la syntaxe des valeurs entrées par les utilisateurs. Par exemple, si un format de saisie a été spécifié, le modèle de validation doit correspondre à ce format.
3.
Dans la zone Message du modèle de validation, tapez le message qui invitera les utilisateurs à entrer une valeur correcte. Le message doit indiquer le format de saisie obligatoire. Pour commencer une nouvelle ligne de texte, appuyez sur Ctrl+Entrée.
4.
Si vous souhaitez afficher une erreur de programmation plutôt qu'un avertissement, cochez la case Erreur.
Pour afficher un message lorsqu'un script détecte une valeur incorrecte
1.
Sélectionnez un champ de date/heure, un champ numérique, un champ de texte, un champ de mot de passe, une liste déroulante, une zone de liste, une case à cocher ou un groupe de boutons radio.
2.
Cliquez sur l'onglet Valeur de la palette Objet. Dans la zone Message du script de validation, tapez le message.
3.
Si vous souhaitez afficher une erreur de programmation plutôt qu'un avertissement, cochez la case Erreur.
Voir aussi
A propos des formats et des valeurs de format
Valeurs de mise en forme par défaut
Pour définir un format de saisie
A propos des calculs et des scripts
Pour remplir de façon dynamique un message de modèle de validation


Pour spécifier un modèle de données

Les options de liaison de données permettent de développer un formulaire qui capture les données pour les infrastructures de l'entreprise et/ou d'utiliser une source de données externe pour remplir le formulaire à l'exécution. Par exemple, si les données de liaison appropriées (voir A propos de la liaison de champs à une source de données) et un accès à la source de données (voir A propos des sources de données) sont définis, Acrobat et Adobe Reader peuvent importer et afficher des données provenant d'une base de données OLE à l'ouverture du formulaire. Les objets peuvent également être liés à un schéma XML, à un fichier XML ou à une source de données WSDL.
Acrobat, Adobe Reader et LiveCycle Forms interprètent les propriétés de liaison des données pour enregistrer les données saisies et analyser les données récupérées. Par défaut, les données d'un objet sont enregistrées et fusionnées conformément aux règles de fusion d'Adobe. Lorsqu'un formulaire est ouvert dans Acrobat ou Adobe Reader ou qu'il est généré par LiveCycle Forms, la source de données remplit les champs. Toute modification de la valeur d'un champ par un utilisateur est répercutée dans la source de données appropriée lorsque le formulaire est enregistré dans Acrobat ou Adobe Reader, ou que les données sont soumises à LiveCycle Forms.
Si les données ne sont pas liées à une source de données (si par exemple les données du formulaire vont être renvoyées par messagerie), le modèle de données indique le format à utiliser pour les enregistrer. Si vous ne créez pas de modèle de données, celles-ci sont enregistrées dans un format canonique. Si un formulaire est susceptible d'être renseigné par des utilisateurs impliquant des paramètre régionaux différents, ou si les données doivent être retournées dans plusieurs paramètres régionaux, l'utilisation d'un format de données canonique permet de s'assurer que tous les utilisateurs interpréteront les données de la même manière.
Il est possible de définir un modèle de données pour les champs de date/heure, les champs numériques, les champs de texte et les champs de mot de passe. Si le modèle de données empêche Acrobat, Adobe Reader ou LiveCycle Forms d'analyser une valeur récupérée, cette dernière s'affiche telle quelle dans le formulaire (elle n'est pas formatée pour l'affichage).
1.
Sélectionnez un champ de date/heure, un champ numérique, un champ de texte ou un champ de mot de passe.
2.
Dans la palette Objet, cliquez sur l'onglet Liaison. Dans la zone Modèle de données, sélectionnez un des formats de liaison de données prédéfinis ou entrez un format personnalisé.
Voir aussi
A propos des formats et des valeurs de format
Valeurs de mise en forme par défaut


Formats simples

Il est possible d'utiliser des formats simples pour formater les valeurs des champs de date/heure, des champs numériques, des champs de texte et des champs de mot de passe. Chacun de ces objets possède ses propres règles quant à la création de formats corrects. Le jeu de caractères qui peut être utilisé dans un format est limité et la syntaxe d'un format valable varie pour les champs de date/heures, les champs numériques, les champs de texte et les champs de mot de passe.
Pour plus de détails sur les caractères que vous pouvez utiliser dans un modèle et pour obtenir des exemples de syntaxe correcte, voir l'une des sections ci-dessous. Pour plus de détails sur les formats complexes de champ de date/heure, champ numérique ou champ de texte, voir Formats de champ complexes.
Voir aussi
Valeurs de mise en forme par défaut
Formats de date et heure
Formats numériques
Formats des champs de texte
Formats de mot de passe


Paramètres régionaux

Un paramètre régional est un terme standard utilisé, dans le développement de normes internationales, pour identifier une nation (une langue, un pays ou les deux). En ce qui concerne FormCalc, un paramètre régional définit le format de date et d’heure ainsi que le format numérique et monétaire d’une nation ou d’une région, pour permettre aux utilisateurs de se servir des formats auxquels ils sont habitués.
Chaque paramètre régional comprend une chaîne de caractères unique appelée identificateur de paramètre régional. La composition de ces chaînes est gérée par le groupe IETF (Internet Engineering Task Force) de l’Organisation mondiale de normalisation (ISO), organe de la Société Internet (www.isoc.org).
Les identificateurs de paramètre régional se composent d’une partie langue, d’une partie pays ou des deux. Le tableau suivant présente la liste des paramètres régionaux valides avec la présente version de LiveCycle Designer.

Langage

Pays

Code ISO
Arabe
Emirats arabes unis
ar_AE
Arabe
Bahreïn
ar_BH
Arabe
Algérie
ar_DZ
Arabe
Egypte
ar_EG
Arabe
Iraq
ar_IQ
Arabe
Jordanie
ar_JO
Arabe
Koweït
ar_KW
Arabe
Liban
ar_LB
Arabe
Libye
ar_LY
Arabe
Maroc
ar_MA
Arabe
Oman
ar_OM
Arabe
Qatar
ar_QA
Arabe
Arabie Saoudite
ar_SA
Arabe
Soudan
ar_SD
Arabe
Syrie
ar_SY
Arabe
Tunisie
ar_TN
Arabe
Yémen
ar_YE
Bulgare
Bulgarie
bg_BG
Chinois
Hong Kong
zh_HK
Chinois
Chinois simplifié (République populaire de Chine)
zh_CN
Chinois
Chinois traditionnel
zh_TW
Croate
Croatie
hr_HR
Tchèque
République tchèque
cs_CAZ
Danois
Danemark
da_DK
Néerlandais
Belgique
nl_BE
Néerlandais
Pays-Bas
nl_NL
Français
Australie
en_AU
Français
Canada
en_CA
Français
Inde
en_IN
Français
Irlande
en_IE
Français
Nouvelle-Zélande
en_NZ
Français
Afrique du Sud
en_ZA
Français
Royaume-Uni
en_GB
Français
Royaume-Uni (Europe)
en_GB_EURO
Français
Anglais (Etats-Unis)
en_US
Estonien
Estonie
et_EE
Finnois
Finlande
fi_FI
Français
Belgique
fr_BE
Français
Canada
fr_CA
Français
France
fr_FR
Français
Luxembourg
fr_LU
Français
Suisse
fr_CH
Allemand
Autriche
de_AT
Allemand
Allemagne
de_DE
Allemand
Luxembourg
de_LU
Allemand
Suisse
de_CH
Grec
Grèce
el_GR
Hébreu
Israël
he_IL
Hongrois
Hongrie
hu_HU
Indonésien
Indonésie
id_ID
Italien
Italie
it_IT
Italien
Suisse
it_CH
Japonais
Japon
ja_JP
Coréen
République de Corée
ko_KR
Coréen
Corée (caractères Hanja)
ko_KR_HANI
Letton
Lettonie
lv_LV
Lituanien
Lituanie
lt_LT
Malais
Malaisie
ms_MY
Norvégien (Bokmal)
Norvège
nb_NO
Norvégien (Nynorsk)
Norvège
nn_NO
Polonais
Pologne
pl_PL
Portugais
Brésil
pt_BR
Portugais
Portugal
pt_PT
Roumain
Roumanie
ro_RO
Russe
Russie
ru_RU
Serbo-croate
Bosnie-Herzégovine
sh_BA
Serbo-croate
Croatie
sh_HR
Serbo-croate
Serbie-et-Monténégro
sh_CS
Slovaque
Slovaquie
sk_SK
Slovène
Slovénie
sl_SI
Espagnol
Equateur
es_EC
Espagnol
El Salvador
es_SV
Espagnol
Guatemala
es_GT
Espagnol
Honduras
es_HN
Espagnol
Nicaragua
es_NI
Espagnol
Panama
es_PA
Espagnol
Paraguay
es_PY
Espagnol
Porto Rico
es_PR
Espagnol
Uruguay
es_UY
Espagnol
Argentine
es_AR
Espagnol
Bolivie
es_BO
Espagnol
Chili
es_CL
Espagnol
Colombie
es_CO
Espagnol
Costa Rica
es_CR
Espagnol
République dominicaine
es_DO
Espagnol
Mexique
es_MX
Espagnol
Pérou
es_PE
Espagnol
Espagne
es_ES
Espagnol
Venezuela
es_VE
Suédois
Suède
sv_SE
Thaï
Thaïlande
th_TH
Thaï
Royaume de Thaïlande
th_TH_TH
Turc
Turquie
tr_TR
Ukrainien
Ukraine
uk_UA
Vietnamien
Vietnam
vi_VN
Habituellement, les deux éléments d’un paramètre régional sont importants. Par exemple, le nom des jours de la semaine et des mois en anglais pour le Canada et en anglais pour la Grande-Bretagne ont le même format, mais les dates sont formatées différemment. Ainsi, l’indication de la langue anglaise comme paramètre régional n’est pas suffisante. De même, l’indication du seul pays comme paramètre régional n’est pas suffisante. Par exemple, le Canada possède deux formats de date, l’un pour l’anglais et l’autre pour le français.
En général, chaque application fonctionne dans un environnement où se trouve un paramètre régional. Ce paramètre régional est ambiant. Dans certaines circonstances, une application peut fonctionner sur un système, ou dans un environnement, dans lequel ne se trouve aucun paramètre régional. Dans ces rares cas, le paramètre régional ambiant par défaut est l’anglais des Etats-Unis (en-US). Ce paramètre régional est celui par défaut.
Voir aussi
Epoque
Formats de date
Formats d’heure
Formats de date et heure


Epoque

On associe aux valeurs de date et d’heure une origine, dite époque, qui sert de point de départ chronologique. Toute valeur de date ou d’heure située avant cette époque n’est pas valide.
L’unité de valeur pour toutes les fonctions de date est le nombre de jours calculé depuis l’époque. L’unité de valeur pour toutes les fonctions d’heure est le nombre de millisecondes calculé depuis l’époque.
LiveCycle Designer définit le jour 1 de l’époque pour toutes les fonctions de date comme étant le 1er janvier 1900, et la milliseconde 1 de l’époque pour toutes les fonctions d’heure comme étant minuit, 00:00:00, en temps universel coordonné (UTC), aussi connu sous le nom de « temps moyen de Greenwich » (GMT). Cette définition signifie que les utilisateurs des fuseaux horaires situés à l’Est de l’UTC peuvent recevoir des valeurs d’heure négatives.
Voir aussi
Paramètres régionaux
Formats de date
Formats d’heure
Formats de date et heure


Formats de date

Un format de date est une notation abrégée déterminant la façon dont la date s'affiche. Elle comprend différents signes de ponctuation et symboles représentant le formatage utilisé par la date. Le tableau suivant fournit des exemples de formats de date :

Format de date

Exemple
MM/DD/YY
11/11/78
DD/MM/YY
25/07/85
MMMM DD, YYYY
Mars 10, 1964
Le format de date est géré par une norme ISO. Chaque pays ou région spécifie ses propres formats de date. Les quatre catégories générales de formats de date correspondent aux formats court, moyen, long et complet. Le tableau ci-dessous indique quelques exemples de formats de date, dans différents paramètres régionaux, pour chacune des quatre catégories.

Identificateur de paramètre régional et description

Format de date (catégorie)

Exemple
en_GB
Anglais (Royaume-Uni)
DD/MM/YY (Court)
08/18/92
08/04/05
fr_CA
Français (Canada)
YY-MM-DD (Moyen)
92-08-18
de_DE
Allemand (Allemagne)
D. MMMM YYYY (Long)
17. Juni 1989
fr_FR
Français (France)
EEEE, ' le ' D MMMM YYYY (Complet)
Lundi, le 29 Octobre, 1990
Voir aussi
Paramètres régionaux
Epoque
Formats d’heure
Formats de date et heure


Formats d’heure

Un format d’heure est une notation abrégée déterminant la façon dont l’heure s’affichera. Elle comprend des signes de ponctuation, des littéraux et des symboles. Le tableau suivant propose des exemples de formats d’heure.

Format d’heure

Exemple
h:MM A
7:15 PM
HH:MM:SS
21:35:26
HH:MM:SS 'o''clock' A Z
14:20:10 o’clock PM EDT
Le format d’heure est géré par une norme ISO. Chaque nation définit ses formats d’heure par défaut, court, moyen, long, et complet. Le paramètre régional identifie le format d’heure conforme aux normes de cette nation.
Le tableau ci-dessous indique quelques exemples de formats d'heure, dans différents paramètres régionaux, pour chacune des quatre catégories.

Identificateur de paramètre régional et description

Format d'heure (Catégorie)

Exemple
en_GB
Anglais (Royaume-Uni)
HH:MM (Court)
14:13
fr_CA
Français (Canada)
HH:MM:SS (Moyen)
12:15:50
de_DE
Allemand (Allemagne)
HH:MM:SS z (Long)
14:13:13 -0400
fr_FR
Français (France)
HH ' h ' MM Z (Complet)
14 h 13 GMT-04:00
Voir aussi
Paramètres régionaux
Epoque
Formats de date
Formats de date et heure


Formats de date et heure

Vous devez utiliser les symboles suivants pour créer des formats de date et heure pour les champs de date/heure. Certains symboles de dates sont uniquement utilisés dans les paramètres régionaux correspondant aux langues chinoise, japonaise et coréenne. Ces symboles sont également indiqués ci-dessous.
la virgule (,), le tiret (-), le deux-points (:), la barre oblique (/), le point (.) et l'espace ( ) sont considérés comme des valeurs littérales qui peuvent être incluses n'importe où dans le format. Pour inclure du texte dans un format, délimitez la chaîne de texte par des guillemets simples ('). Par exemple, 'Your payment is due no later than' MM-DD-YY peut être spécifié comme format d'affichage.

Symboles de date

Description

Valeur formatée pour un paramètre régional Anglais (Etats-Unis) dont la valeur d'entrée tributaire du format du paramètre régional est 1/1/08 (Janvier 1, 2008)

D
Jour du mois à 1 ou 2 chiffres (1-31)
1

DD
Jour du mois à 2 chiffres avec zéro de remplissage (01-31)
01

J
Jour de l'année à 1, 2 ou 3 chiffres (1-366)
1

JJJ
Jour de l'année à 3 chiffres avec zéros de remplissage (001-366)
001

M
Mois de l'année à 1 ou 2 chiffres (1-12)
1

MM
Mois de l'année à 2 chiffres avec zéro de remplissage (01-12)
01

MMM
Nom abrégé du mois
Jan

MMMM
Nom complet du mois
Janvier

E
Jour de la semaine à 1 chiffre (1-7), où 1=Dimanche
3 (le 1er janvier 2008 correspond à un mardi)

EEE
Nom abrégé du jour de la semaine
Mar (le 1er janvier 2008 correspond à un mardi)

EEEE
Nom complet du jour de la semaine
Mardi (le 1er janvier 2008 correspond à un mardi)

YY
Année à 2 chiffres, où les nombres inférieurs à 30 se situent après l'an 2000 et où les nombres égaux et supérieurs à 30 se situent avant l'an 2000. Par exemple, 00=2000, 29=2029, 30=1930 et 99=1999.
08

YYYY
Année à 4 chiffres
2008

G
Nom de l'ère (av. J.-C. ou ap. J.-C.)
ap. J.-C.

w
Semaine du mois à 1 chiffre (0-5), où la semaine 1 est le premier groupe de 4 jours qui se termine un samedi
1

WW
Semaine de l'année à 2 chiffres (01-53) ISO-8601, où la semaine 1 représente la semaine qui contient le 4 janvier
01
Vous disposez de plusieurs autres modèles de dates correspondant aux paramètres régionaux chinois, japonais et coréen.
Les ères japonaises sont représentables à l'aide de plusieurs symboles différents. Les quatre derniers symboles d'ère constituent d'autres symboles possibles pour représenter les ères japonaises.

Symbole de date CJK

Description

DDD
Jour du mois du paramètre régional, exprimé en valeur numérique idéographique

DDDD
Jour du mois du paramètre régional, exprimé en valeur numérique idéographique (règle des dixièmes)

YYY
Année du paramètre régional, exprimée en valeur numérique idéographique

YYYYY
Année du paramètre régional, exprimée en valeur numérique idéographique (règle des dixièmes)

g
Autre nom possible désignant l'ère du paramètre régional. Pour l'ère actuelle japonaise, Heisei, ce modèle affiche la lettre H ASCII (U+48)

gg
Autre nom possible désignant l'ère du paramètre régional. Pour l'ère actuelle japonaise, ce modèle affiche l'idéogramme représenté par le symbole Unicode (U+5E73)

ggg
Autre nom possible désignant l'ère du paramètre régional. Pour l'ère actuelle japonaise, ce modèle affiche les idéogrammes représentés par les symboles Unicode (U+5E73 U+6210)

 g
Autre nom possible désignant l'ère du paramètre régional. Pour l'ère actuelle japonaise, ce modèle affiche la lettre H à pleine largeur (U+FF28)

 g g
Autre nom possible désignant l'ère du paramètre régional. Pour l'ère actuelle japonaise, ce modèle affiche l'idéogramme représenté par le symbole Unicode (U+337B)

Symbole de l'heure

Description

Valeur d'entrée tributaire du format du paramètre régional

Valeur formatée du paramètre régional Anglais (Etats-Unis)

h
Heure au format du jour (AM/PM) à 1 ou à 2 chiffres (1-12)
12:08 AM ou 2:08 PM
12 ou 2

hh
Heure au format du jour (AM/PM) à 2 chiffres avec zéro de remplissage (01-12)
12:08 AM ou 2:08 PM
12 ou 02

k
Heure au format du jour (AM/PM) à 0 ou à 2 chiffres (1-11)
12:08 AM ou 2:08 PM
0 ou 2

kk
Heure au format du jour (AM/PM) à 2 chiffres (00-11)
12:08 AM ou 2:08 PM
00 ou 02

H
Heure du jour à 1 ou 2 chiffres (0-23)
12:08 AM ou 2:08 PM
0 ou 14

HH
Heure du jour à 2 chiffres avec zéro de remplissage (00-23)
12:08 AM ou 2:08 PM
00 ou 14

K
Heure du jour à 1 ou 2 chiffres (1-24)
12:08 AM ou 2:08 PM
24 ou 14

KK
Heure du jour à 2 chiffres avec zéro de remplissage (01-24)
12:08 AM ou 2:08 PM
24 ou 14

M
Minute de l'heure à 1 ou 2 chiffres (0-59)
vous devez utiliser ce symbole dans un symbole d'heure.
2:08 PM
8

MM
Minute de l'heure à 2 chiffres avec zéro de remplissage (00-59)
vous devez utiliser ce symbole dans un symbole d'heure.
2:08 PM
08

S
Seconde de la minute à 1 ou 2 chiffres (0-59)
vous devez utiliser ce symbole dans un symbole d'heure et de minutes.
2:08:09 PM
9

SS
Seconde de la minute à 2 chiffres avec zéro de remplissage (00-59)
vous devez utiliser ce symbole dans un symbole d'heure et de minutes.
2:08:09 PM
09

FFF
Millième de la seconde à 3 chiffres (000-999)
vous devez utiliser ce symbole dans un symbole d'heure, de minute et de seconde.
2:08:09 PM
09

A
Partie de la journée comprise entre minuit et midi (AM) ou midi et minuit (PM)
2:08:09 PM
PM

z
Format de fuseau horaire ISO-8601 (par exemple, Z, +0500, -0030, -01, +0100)
vous devez utiliser ce symbole dans un symbole d'heure.
2:08:09 PM
-0400

zz
Format de fuseau horaire ISO-8601 secondaire (par exemple, Z, +05:00, -00:30, -01, +01:00)
vous devez utiliser ce symbole dans un symbole d'heure.
2:08:09 PM
-04:00

Z
Nom abrégé de fuseau horaire, par exemple, TMG, TMG+05:00, TMG-00:30, HNE, HAP
vous devez utiliser ce symbole dans un symbole d'heure.
2:08:09 PM
EDT
Symboles réservés
Les symboles qui suivent ont une signification particulière et ne peuvent pas être utilisés comme texte littéral.
?
Lorsqu'il est utilisé, ce symbole représente n'importe quel caractère. Lorsqu'il est fusionné pour l'affichage, il devient un espace.

*
Lorsqu'il est utilisé, ce symbole représente 0 ou le caractère d'espace Unicode. Lorsqu'il est fusionné pour l'affichage, il devient un espace.

+
Lorsqu'il est utilisé, ce symbole représente un ou plusieurs caractères d'espace Unicode. Lorsqu'il est fusionné pour l'affichage, il devient un espace.
Voir aussi
A propos des formats et des valeurs de format
Formats de champ complexes
Formats de date
Formats d’heure
Exemples de formats de date et heure


Formats de champ complexes

Outre la définition de formats simples pour les champs de date/heure, les champs numériques et les champs de texte, vous pouvez définir des formats propres au paramètre régional de la langue ou traiter des formats variables.
Formats propres aux paramètres régionaux
Si vous voulez forcer l'utilisation d'un paramètre régional dans un format, quelle que soit le paramètre régional affecté à un objet, vous avez la possibilité de spécifier un format propre à un tel paramètre. La syntaxe d'un tel format est définie de la façon suivante :
category_name(locale_name){pattern}
où
      •
      category_name peut être date, time, num ou text.
      •
      locale_name est identifié par une langue et/ou un code de pays, tel que défini dans le document RFC 1766 (Tags for the Identification of Languages, 1995).
      •
      pattern est le format simple utilisé pour le traitement des valeurs.
Par exemple, pour forcer un champ de date/heure à traduire une date en français selon le code de pays de la France, vous pouvez définir le format de la façon suivante :
date(fr_FR){DD MMMM, YYYY}
Formats variables
Dans les cas où les valeurs entrées par l'utilisateur ou les données liées sont disponibles en plusieurs formats (par exemple, les numéros de téléphone peuvent avoir ou non un indicatif régional de trois chiffres), vous pouvez définir un format qui tient compte de ces différences. La syntaxe utilisée pour la définition des différents formats corrects est la suivante :
category_name{pattern}|category_name{pattern}|category_name{pattern}
où chacun des formats est séparé par une barre verticale (|). Vous pouvez définir un nombre illimité de formats. Par exemple, la syntaxe suivante traite deux formats de texte différents :
text{999*9999}|text{999*999*9999}
Voir aussi
Formats simples


Configuration d'un objet pour d'autres langues

Pour configurer un objet pour l'arabe et l'hébreu
Pour configurer un objet pour le thaï et le vietnamien
Pour configurer un champ de date pour d'autres langues


Pour configurer un objet pour l'arabe et l'hébreu

Les objets, qui sont les éléments constitutifs des formulaires, peuvent prendre diverses formes en fonction de la langue de conception du formulaire.
La légende d'une liste déroulante en français, par exemple, se trouve généralement à gauche et la flèche déroulante à droite. En revanche, en arabe et en hébreu, la légende de la liste déroulante se trouve à droite et la flèche déroulante à gauche, car ces langues se lisent de droite à gauche.
Pour configurer un objet afin de l'utiliser en arabe et en hébreu, suivez la procédure ci-dessous :
      •
      Choisissez la langue (arabe ou hébreu).
      •
      Placez la légende à droite (sauf pour les cases à cocher et les boutons radio, qui doivent être positionnés à gauche).
      •
      Alignez à droite la légende et sa valeur.
      •
      Choisissez une police compatible avec la langue.
Les objets suivants peuvent être configurés pour l'arabe et l'hébreu :
      •
      Cases à cocher
      •
      Champs de date et heure
      •
      Champs décimaux
      •
      Champs de signature du document
      •
      Listes déroulantes
      •
      Zones de liste
      •
      Champs numériques
      •
      Champs de mot de passe
      •
      Boutons radio
      •
      Champs de texte
les options décrites dans cette rubrique d'aide ne sont disponibles que si la langue adéquate est activée par l'intermédiaire des paramètres de langue de Microsoft Office.
LiveCycle Forms 7.1 ne prend pas en charge les conceptions de formulaire contenant des polices relatives à l'arabe, l'hébreu, le thaï et le vietnamien.
1.
Ajoutez l'objet.
A partir de la palette Bibliothèque, par exemple, faites glisser l'objet de liste déroulante sur la conception de formulaire.
2.
Cliquez sur l'onglet Champ de la palette Objet.
3.
Dans la zone Paramètre régional, sélectionnez la langue et le pays.
Par exemple, sélectionnez l'arabe (Bahreïn).
4.
Sélectionnez l'objet.
5.
Dans la palette Police, sélectionnez une police compatible avec les paramètres régionaux que vous avez choisis.
Par exemple, Adobe Arabic prend en charge l'arabe et Adobe Hebrew l'hébreu. Si la langue choisie ne se trouve pas sur votre système, vous pouvez la rechercher sur Internet.
6.
Sélectionnez l'objet.
7.
Dans la palette Paragraphe, cliquez sur l'icône correspondante pour aligner à droite la légende et la valeur.
8.
Dans la palette Disposition, sélectionnez l'option appropriée de la légende dans la liste Ancrage.

Objet

Poste
Cases à cocher
Gauche
Champs de date et heure
Droite
Champs décimaux
Droite
Champs de signature du document
Droite
Listes déroulantes
Droite
Zones de liste
Droite
Champs numériques
Droite
Champs de mot de passe
Droite
Boutons radio
Gauche
Champs de texte
Droite
9.
Affichez l'objet dans le panneau Aperçu PDF pour vérifier s'il apparaît correctement.


Pour configurer un objet pour le thaï et le vietnamien

Pour configurer un objet afin de l'utiliser en thaï et en vietnamien, suivez la procédure ci-dessous :
      •
      Définissez le thaï ou le vietnamien comme langue.
      •
      Choisissez une police compatible avec la langue.
les options décrites dans cette rubrique d'aide ne sont disponibles que si la langue adéquate est activée par l'intermédiaire des paramètres de langue de Microsoft Office.
LiveCycle Forms 7.1 ne prend pas en charge les conceptions de formulaire contenant des polices relatives à l'arabe, l'hébreu, le thaï et le vietnamien.
1.
Ajoutez l'objet.
A partir de la palette Bibliothèque, par exemple, faites glisser l'objet de liste déroulante sur la conception de formulaire.
2.
Cliquez sur l'onglet Champ de la palette Objet.
3.
Dans la zone Paramètre régional, sélectionnez la langue et le pays.
Par exemple, sélectionnez le thaï (traditionnel).
4.
Sélectionnez l'objet.
5.
Dans la palette Police, sélectionnez une police compatible avec les paramètres régionaux que vous avez choisis.
Par exemple, Adobe Thai prend en charge le thaï et Myriad® Pro (ainsi que Minion® Pro) le vietnamien. Si la langue choisie ne se trouve pas sur votre système, vous pouvez la rechercher sur Internet.
6.
Affichez l'objet dans le panneau Aperçu PDF pour vérifier s'il apparaît correctement.


Pour configurer un champ de date pour d'autres langues

1.
Dans le Panneau de configuration de Microsoft Windows®, assurez-vous que les paramètres régionaux et linguistiques sont configurés pour la langue appropriée.
2.
Dans LiveCycle Designer, faites glisser l'objet de champ de date/heure sur la conception de formulaire à partir de la palette Bibliothèque.
3.
Dans la palette Objet, cliquez sur l'onglet Champ et tapez DD/MM/gYY dans la zone Format d'affichage.
Pour les dates en thaï, utilisez par exemple les formats suivants :
      •
      g affiche B.E (Buddish era)
      •
      gg affiche l'abréviation de l'ère boudhiste en thaï
      •
      ggg affiche le nom complet de B.E. en thaï
4.
Dans le panneau Aperçu PDF, le champ Date/Heure et le calendrier ont l'aspect suivant :
Ci-dessous figurent d'autres calendriers, tels qu'ils apparaissent lorsque les paramètres régionaux utilisent ces langues.


Utilisation d'objets spéciaux

A propos des objets spéciaux
Pour définir un champ global
Pour insérer un champ flottant
Pour insérer des propriétés d'exécution
Pour ajouter des variables dans un formulaire


A propos des objets spéciaux

Outre les objets standard et personnalisés de la palette Bibliothèque, LiveCycle Designer propose des objets et/ou des propriétés conçus pour assurer des fonctionnalités spéciales dans un formulaire au moment de l'exécution. Ces objets et ces propriétés sont les suivants :
      •
      Champs globaux
      •
      Champs flottants
      •
      Propriétés d'exécution
      •
      Variables
Voir aussi
Pour définir un champ global
Pour insérer un champ flottant
Pour insérer des propriétés d'exécution
Pour ajouter des variables dans un formulaire


Pour définir un champ global

Un champ global contient des données qui s'affichent à plusieurs emplacements dans votre formulaire. Par exemple, une facture doit comporter un numéro qui s'affiche à différents endroits sur le formulaire. Dans la conception de formulaire, vous pouvez définir le numéro de facture en tant que champ global et le réutiliser au besoin.
Les champs globaux sont particulièrement utiles lorsque certaines données doivent être répétées à plusieurs endroits. L'utilisation des champs globaux ne réduit pas seulement la quantité de données à envoyer, mais permet aussi de s'assurer que les données sont exactement les mêmes aux différents emplacements du formulaire où elles doivent s'afficher.
A l'aide de la propriété de liaison globale, vous pouvez appliquer la même valeur à tous les objets du formulaire qui portent le même nom.
Lorsque vous appliquez le paramètre global à un objet, tous les objets portant le même nom sont liés aux mêmes données au moment de l’exécution. Puisque les objets globaux portant le même nom sont liés à la même valeur de données, les données affichées dans un objet global sont automatiquement affichées dans tous les autres objets globaux portant le même nom. Vous ne pouvez pas avoir plus d’un objet portant le même nom dans un formulaire dans lequel certains objets, mais pas tous, sont définis sur Globale.
Vous pouvez appliquer le paramètre de liaison globale aux types d’objet suivants :
      •
      Cases à cocher
      •
      Champs de date et heure
      •
      Listes déroulantes
      •
      Champs d'image
      •
      Zones de liste
      •
      Champs numériques
      •
      Champs de mot de passe
      •
      Boutons radio
      •
      Champs de texte
Lorsque vous appliquez ce paramètre à un objet, LiveCycle Designer attribue automatiquement la valeur globale à tous les autres objets qui portent le même nom dans le formulaire. De même, lorsque vous retirez le paramètre Global d’un objet, LiveCycle Designer retire la valeur de tous les autres objets qui portent le même nom et qui sont définis sur le même paramètre.
lorsque vous appliquez une liaison globale à un objet, vous ne pouvez pas ajouter à cet objet des propriétés d’exécution comme la page active, le nombre de pages et la date et l’heure actuelles.
1.
Insérez les objets désirés dans la conception de formulaire.
2.
Attribuez le même nom à tous ces objets.
3.
Sélectionnez un des objets.
4.
Dans la palette Objet, cliquez sur l'onglet Liaison et sélectionnez Globale dans la liste Liaison par défaut. LiveCycle Designer affiche un message qui confirme que la liaison globale s’appliquera à tous les objets portant le même nom que l’objet sélectionné.
Voir aussi
A propos des sources de données
Pour donner un nom aux objets ou changer leur nom


Pour insérer un champ flottant

Vous pouvez insérer un champ flottant dans un objet de texte pour afficher différents types de renseignements.
Les champs flottants sont des objets qui prennent en charge la fusion de texte, les valeurs numériques, les propriétés d’exécution et les scripts dans un objet de texte au moment du rendu du formulaire. Vous pouvez insérer des champs flottants uniquement dans des objets de texte.
Les champs flottants sont par défaut des objets de champ de texte, mais vous pouvez changer de type d’objet depuis la liste Type dans le panneau Champ de la palette Objet.
Vous pouvez lier les champs flottants à une source de données pour afficher un texte ou des valeurs numériques spécifiques. Il est possible, par exemple, d'insérer un champ flottant pour générer le nom du client dans l’introduction d’une lettre de formulaire. Le champ flottant apparaît sous la forme d’un objet de champ de texte, comme indiqué dans l'exemple ci-dessous.
(M./Mme {ChampTexte})
Vous devez configurer les propriétés de l'objet de champ flottant indépendamment des propriétés de l'objet de texte. Par défaut, les objets de champ flottant sont définis sur Masqué (pas affiché) dans la liste Visibilité.
1.
Cliquez dans l’objet de texte où vous voulez placer l’objet de champ de texte flottant.
2.
Placez le curseur sur la ligne où vous voulez que LiveCycle Designer insère l’objet de champ de texte flottant.
3.
Choisissez Insertion > Champ flottant.
4.
Pour définir les propriétés du champ flottant, cliquez sur le marqueur Champ flottant, à l’intérieur de l’objet de texte, puis sélectionnez les options voulues. Il est recommandé de renommer l’objet de champ de texte flottant et d’indiquer la liaison nécessaire.
Voir aussi
Pour insérer des propriétés d'exécution
Aperçu du texte
Aperçu des champs de texte


Pour insérer des propriétés d'exécution

Dans un formulaire, vous pouvez afficher certains types d'information au moment de l'exécution à l'aide des propriétés d'exécution. Vous pouvez afficher, par exemple, la page actuelle, le nombre de pages, la date et l'heure actuelles, les paramètres régionaux du programme de visualisation, le nom et la version du programme de visualisation.
Vous pouvez insérer des propriétés d'exécution dans les objets suivants :
      •
      Champ numérique
      •
      Texte
      •
      Champ de texte
Pour ajouter des propriétés d’exécution à un objet de texte, utilisez les commandes du menu Insertion. Pour ajouter des propriétés d’exécution à un objet de champ de texte ou de champ numérique, servez-vous de la liste Type.
Dans tous les cas, LiveCycle Designer ajoute un champ flottant à l’objet sélectionné, ainsi qu’un script de calcul qui génère la valeur voulue et une valeur par défaut fondée sur la propriété. LiveCycle Designer nomme également le champ flottant d’après la propriété d’exécution que vous choisissez.
lorsque vous ajoutez à un objet la propriété d’exécution de page active, n'appliquez pas non plus l'option de liaison globale. En effet, LiveCycle Designer appliquerait à chaque page le même numéro de page plutôt que des valeurs différentes.
Pour ajouter une propriété d’exécution à un objet de texte
1.
Cliquez sur le champ de texte.
2.
Choisissez Insertion, puis la propriété d’exécution à insérer.
Pour ajouter une propriété d’exécution à un objet de champ de texte ou de champ numérique
1.
Cliquez sur le champ de texte ou le champ numérique.
2.
Dans la palette Objet, cliquez sur l'onglet Valeur et, dans la liste Type, choisissez Calculé - Lecture seule. L’option Propriétés de l’exécution s’affiche.
3.
Choisissez Propriétés de l’exécution, puis, dans la liste, sélectionnez la propriété de l’exécution à insérer.
Voir aussi
Aperçu des champs numériques
Aperçu du texte
Aperçu des champs de texte


Pour ajouter des variables dans un formulaire

Les variables servent à insérer du texte ou des valeurs qui varient. Une variable est un segment de texte ou des valeurs que LiveCycle Designer peut automatiquement mettre à jour ou modifier (sur demande) au moyen d’un script.
Une variable peut contenir n’importe quel nombre ou n’importe quel type d’élément de données. Comme chaque élément de données possède un nom unique avec son propre attribut de nom, les scripts peuvent les désigner individuellement par leur identité.
Vous pouvez définir des variables de texte, puis les insérer dans des légendes ou d’autres textes. Par exemple, vous pouvez utiliser des variables pour appliquer une terminologie qui risque de changer. Pour changer la variable (le terme), il suffit alors d’ouvrir le formulaire concerné et de modifier la valeur de la variable. LiveCycle Designer met automatiquement à jour toutes les occurrences du terme par la suite.
Pour créer une variable, vous devez nommer la variable et indiquer la valeur qu’utilisera LiveCycle Designer. Vous pouvez, par exemple, créer une variable appelée NomProduit, qui contiendra le nom actuel d’un produit que vous serez libre de changer, si besoin est.
Les valeurs des variables sont enregistrées avec le formulaire.
Voir aussi
Variables
Panneau Variables (boîte de dialogue Propriétés du formulaire)


Propriétés de l'objet

Propriétés de la palette Disposition
Propriétés de la palette Bordure
Propriétés de la palette Police
Propriétés de la palette Paragraphe
Propriétés de la palette Accessibilité
Propriétés des gabarits dans le panneau Gabarit
Propriétés des gabarits dans le panneau Pagination
Propriétés des jeux de pages dans le panneau Jeu de pages
Propriétés de la palette Objet


Propriétés de la palette Disposition

Grâce à la palette Disposition, vous pouvez définir certaines caractéristiques de l'objet sélectionné, y compris sa taille et sa position, ses marges et l'emplacement de ses légendes. Il est possible de définir les propriétés de disposition de chacun des objets sur la page.
X et Y
Définit la position horizontale et verticale du point d'ancrage de l'objet. Si la liste Position n'est pas définie sur Haut gauche, les options X et Y sont remplacées par AncrageX et AncrageY. Voir Pour définir la position des objets.
Largeur, Hauteur et Ajuster/Ajustement automatique
Définissent la hauteur et la largeur minimales de l'objet et permettent un agrandissement dans cette direction, le cas échéant. Voir Pour définir la position des objets et Pour ajuster les objets au contenu.
Les options d'ajustement automatique ne sont disponibles que pour les objets de texte et de sous-formulaire. Lorsque vous sélectionnez un objet, sa taille est modifiée dans LiveCycle Designer afin de s’adapter au contenu.
Position
Définit le point d'ancrage de l'objet. Voir Pour faire pivoter les objets.
Rotation
Font pivoter l'objet autour de son point d'ancrage. Voir Pour faire pivoter les objets.
Marges
Définit la quantité d'espace blanc qu'il doit y avoir à gauche, à droite, en haut et en bas de l'objet. Voir Pour ajouter de l'espace autour d'un objet.
Légende
Définit la position d'une légende. Voir Pour positionner une légende.
Réserver
Définit l'espace à réserver pour une légende. Voir Pour positionner une légende.
Si la propriété de réservation a la valeur 0, l'ajustement automatique est défini pour la légende. La taille de l'objet est ajustée en fonction de la légende.
Voir aussi
Alignement et redimensionnement d'objets


Propriétés de la palette Bordure

Grâce à la palette Bordure, vous pouvez modifier les propriétés de bordure des objets. Il est possible de modifier les bordures individuellement ou globalement.
Contour
Définit les propriétés de bordure de chacun des contours de l'objet :
    • Modifier individuellement
Applique la bordure séparément à chacun des contours. Cette option ne s'applique pas aux bordures tridimensionnelles.
    • Modifier ensemble
Applique la même bordure à tous les contours.
    • Face
Définit le style et la largeur des bordures.
    • Sélecteur de couleurs
Définit la couleur de la ligne.
Coins
Applique un style aux coins de la bordure.
Rayon
Définit le rayon des coins rentrés.
Style
Définit la couleur ou le motif du fond :
    • Sélecteur de couleurs
Définit les couleurs de l'arrière-plan.
Voir aussi
Pour ajouter une bordure autour d'un objet


Propriétés de la palette Police

Grâce à la palette Police, vous pouvez modifier la famille, la taille et le style des polices du texte de l'objet sélectionné.
Police
Définit le type de police.
Format
Définit la taille de la police.
Décalage sur la ligne de base
Définit le décalage des caractères par rapport à la ligne de base.
Style
Définit le style de la police.
Voir aussi
A propos de la mise en forme du texte


Propriétés de la palette Paragraphe

Grâce à la palette Paragraphe, vous pouvez modifier l’alignement, le retrait et l’espacement du texte sélectionné.
Aligner
Définit les options d'alignement horizontal :
    • Aligner à gauche
Aligne la légende ou la valeur à gauche.
    • Centrer
Centre la légende ou la valeur.
    • Aligner à droite
Aligne la légende ou la valeur à droite.
    • Justifier
Justifie la légende ou la valeur. Les lignes sont justifiées à gauche et à droite à l'exception de la dernière ligne d'une légende ou d'une valeur multiligne (les paragraphes à une seule ligne ne peuvent pas être justifiés).
Alignement de la base
Définit l'alignement des champs numériques en fonction de l'alignement de la base (point décimal). Cette option est disponible dans la palette Paragraphe uniquement lorsqu'un objet de champ numérique est sélectionné.
les champs numériques pour lesquels un alignement de la base a été défini ne sont pas pris en charge dans les formulaires PDF destinés à Acrobat 6.0 ou à Adobe Reader 6.0.
Alignement vertical
Définit les options d'alignement vertical :
    • Aligner en haut
Aligne sur le haut de la zone réservée à la légende ou à la valeur.
    • Aligner au milieu
Aligne avec le milieu de la zone réservée à la légende ou à la valeur.
    • Aligner en bas
Aligne sur le bas de la zone réservée à la légende ou à la valeur.
Retraits
Définit les retraits à gauche et à droite.
Prem.
Définit le retrait de la première ligne :
    • Non
Applique la même valeur de retrait à toutes les lignes.
    • Première ligne
Met seulement la première ligne en retrait.
    • Négatif
Met toutes les lignes en retrait sauf la première.
De
Définit le retrait de la première ligne ou le retrait négatif.
Espacement
Définit l'espacement au-dessus et en dessous du paragraphe.
    • Dessus
Définit l'espace vertical au-dessus du paragraphe. Cette valeur est ajoutée à la valeur indiquée dans la zone Dessous.
    • Dessous
Définit l'espace vertical en dessous du paragraphe. Cette valeur est ajoutée à la valeur indiquée dans la zone Dessus.
Interligne
Définit l'espace entre les lignes.
    • Simple
Donne à la ligne la même hauteur que celle du plus grand caractère de la ligne.
    • 1,5 lignes
Donne à la ligne une hauteur équivalente à une fois et demie celle du plus grand caractère de la ligne.
    • Double
Donne à la ligne le double de la hauteur de celle du plus grand caractère de la ligne.
    • Exactement
Donne à la ligne une hauteur équivalente à la valeur définie dans la zone A.
Voir aussi
A propos de la mise en forme des paragraphes


Propriétés de la palette Accessibilité

LiveCycle Designer propose un certain nombre d'options qui reconnaissent les lecteurs d'écran. Pour chaque objet de champ contenu dans un formulaire, vous pouvez définir une option de texte de lecteur d'écran :
      •
      texte personnalisé défini dans la palette Accessibilité ;
      •
      info-bulles définies dans la palette Accessibilité ;
      •
      légendes des champs ;
      •
      noms des objets, tels qu'ils sont indiqués par l'option Nom de l'onglet Liaison.
Les informations lues par les lecteurs d'écran pour les objets des formulaires PDF dépendent des paramètres sélectionnés. Une seule option vocale est lue à voix haute pour chaque objet.
Lorsque le formulaire est enregistré en format PDF balisé, LiveCycle Designer recherche ces paramètres dans le formulaire. L’ordre de recherche par défaut est Texte personnalisé, Info-bulle, Légende et Nom. Vous pouvez changer cet ordre par défaut à l’aide de l’option Précédence du lecteur d’écran de la palette Accessibilité.
vous pouvez remplir une info-bulle et le texte personnalisé d'un lecteur d'écran de manière dynamique à l'aide de valeurs issues d'une source de données.
les info-bulles apparaissent au moment de l'exécution lorsque l'utilisateur passe le pointeur sur l'objet. Les paramètres de la palette Accessibilité n'ont aucun effet sur les objets lorsque le formulaire est généré au format PDF.
Rôle du sous-formulaire
Détermine la façon dont les lecteurs d'écran interprètent le sous-formulaire, le tableau ou la ligne sélectionnée d'un tableau :
    • Tableau
Attribue le rôle d'un tableau au sous-formulaire sélectionné. Lorsque l'utilisateur parcourt le formulaire à la recherche de ce sous-formulaire, la plupart des lecteurs d'écran interprètent ce dernier comme un tableau et indiquent les nombres de rangées et de colonnes correspondants.
    • Rangée d'en-tête
Attribue le rôle de rangée d'en-tête au sous-formulaire ou à la rangée de tableau sélectionné. Lors de la lecture du contenu d'une cellule de rangée de contenu, la plupart de ces lecteurs d'écran identifient d'abord le contenu de la cellule correspondante dans la rangée d'en-tête.
    • Rangée de contenu
Attribue le rôle de rangée de contenu au sous-formulaire ou à la rangée de tableau sélectionné. Si une cellule contient un sous-formulaire, les lecteurs d'écran lisent généralement le contenu de la cellule correspondante dans la rangée d'en-tête, puis les champs du sous-formulaire.
    • Rangée de pied de page
Attribue le rôle de rangée de pied de page au sous-formulaire ou à la rangée de tableau sélectionné.
    • Liste
Attribue le rôle d'une liste au sous-formulaire sélectionné.
    • Article de liste
Attribue le rôle d'un article de liste au sous-formulaire sélectionné. Ce rôle peut être attribué uniquement à un sous-formulaire contenu dans un sous-formulaire possédant le rôle Liste. Vous ne pouvez pas définir un tableau ou une rangée de tableau en tant que liste ou article de liste. Un article de liste peut, cependant, contenir un tableau.
    • Titre
Attribue le rôle de titre à l'objet de texte statique sélectionné.
    • (Aucun)
Précise une rangée qui contient des informations sur le tableau ou sur son contenu. Bien que la rangée ne soit pas considérée comme faisant partie du tableau, le lecteur d'écran lit son contenu.
Info-bulle
Définit l'info-bulle de l'objet. Les info-bulles apparaissent au moment de l'exécution lorsque l'utilisateur passe le pointeur sur l'objet. Un lecteur d'écran peut lire le texte inscrit dans cette zone à voix haute.
Un texte d'info-bulle personnalisée unique et un texte de lecteur d'écran personnalisé unique ne peuvent pas être associés à un seul objet. Vous devez choisir l'un ou l'autre. Si vous souhaitez utiliser une info-bulle personnalisée, saisissez le texte personnalisé et sélectionnez Info-bulle dans la liste Précédence du lecteur d'écran ou n'incluez pas de texte de lecteur d'écran personnalisé.
info-bulle est une propriété dynamique pour la plupart des objets. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet.
Précédence du lecteur d'écran
Indique l'option que le lecteur d'écran doit lire. Une seule option vocale est lue à voix haute pour chaque objet :
    • Texte personnalisé
Lit le texte indiqué dans la zone Texte du lecteur d'écran personnalisé. Il s'agit de la valeur par défaut.
    • Info-bulle
Lit le texte indiqué dans la zone Info-bulle.
    • Légende
Lit la légende indiquée pour l'objet. La position de la légende par rapport à l'objet ne modifie pas l'ordre dans lequel le lecteur d'écran lit la légende. Par défaut, le lecteur d'écran lit la légende si rien n'est spécifié dans la zone Info-bulle ou Texte du lecteur d'écran personnalisé.
    • Nom
Lit le nom de l'objet, tel qu'il est indiqué dans la zone Nom sous l'onglet Liaison de la palette Objet.
    • Non
Désactive l'info-bulle personnalisée ou le texte du lecteur d'écran personnalisé pour le champ.
Texte du lecteur d'écran personnalisé
Définit le texte personnalisé associé à l'objet sélectionné. Le lecteur d'écran lit le texte inscrit dans cette zone.
Un texte d'info-bulle personnalisée unique et un texte de lecteur d'écran personnalisé unique ne peuvent pas être associés à un seul objet. Vous devez choisir l'un ou l'autre. Si vous souhaitez utiliser le texte de lecteur d'écran personnalisé pour l'info-bulle et le texte de lecteur d'écran, saisissez le texte personnalisé et sélectionnez Texte personnalisé dans la liste Précédence du lecteur d'écran.
texte du lecteur d'écran personnalisé est une propriété dynamique pour la plupart des objets. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet.
Voir aussi
A propos des formulaires accessibles
Pour remplir de façon dynamique une info-bulle
Pour remplir de façon dynamique du texte d'un lecteur d'écran


Propriétés des gabarits dans le panneau Gabarit

Le panneau Gabarit de la palette Objet permet de définir le nom des pages et différentes options de disposition pour chaque gabarit. Pour afficher le panneau Gabarit, choisissez le gabarit qui vous intéresse dans la palette Hiérarchie.
Nom
Définit le nom du gabarit.
Type de papier, Hauteur et Largeur
Définissent la taille du gabarit. Les dimensions réelles s'affichent dans les zones Hauteur et Largeur, et peuvent être modifiées si l'option Type de papier est définie sur Personnaliser.
Orientation
Définit l'orientation du gabarit :
    • Portrait
La hauteur de la page est supérieure ou égale à sa largeur.
    • Paysage
La largeur de la page est supérieure ou égale à sa hauteur.
Restreindre les occurrences de page, Min. de répétitions et Max
Sélectionnez cette option uniquement si vous avez l'intention de créer des formulaires prévus pour s'adapter aux données. L'option Restreindre les occurrences de page permet d'activer ou de désactiver le rendu répétitif des pages qui ont été créées à partir du gabarit sélectionné. Si cette option est activée, vous pouvez entrer un nombre minimum de répétitions dans la zone Min. de répétitions et un nombre maximum de répétitions dans la zone Max.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
Voir aussi
Propriétés des gabarits dans le panneau Pagination
Définition des gabarits


Propriétés des gabarits dans le panneau Pagination

Lorsque vous sélectionnez un gabarit, l'onglet Pagination de la palette Objet affiche diverses options de pagination.
Inclure la page dans la numérotation
Indique s'il faut tenir compte des pages qui ont été rendues conformément au gabarit sélectionné, dans le nombre de pages total. Par défaut, l'option est sélectionnée et toutes les pages sont prises en compte.
Si la première page du document
Définit la numérotation des pages générées en fonction du gabarit sélectionné :
    • Continuer la numérotation à partir du document précédent dans le lot
La numérotation se poursuit à partir du dernier document traité par LiveCycle Forms.
    • Commencer à
La numérotation commence à cette valeur spécifique.
Voir aussi
Propriétés des gabarits dans le panneau Gabarit
Définition des gabarits


Propriétés des jeux de pages dans le panneau Jeu de pages

Utilisez le panneau de jeu de pages de la palette Objet pour définir le nom et l'occurrence des pages ainsi que les options propres à chaque groupe de pages. Pour afficher le panneau, choisissez le jeu de pages qui vous intéresse dans la palette Hiérarchie.
Vous pouvez définir les options suivantes pour chaque jeu de pages.
Nom
Définit le nom du jeu de pages.
Restreindre les occurrences de page, Min. de répétitions et Max
Sélectionnez cette option uniquement pour créer des formulaires interactifs. L'option Restreindre les occurrences de page permet d'activer ou de désactiver le rendu répétitif des pages créées à partir des gabarits du jeu de pages sélectionné. Si cette option est activée, vous pouvez entrer un nombre minimum de répétitions dans la zone Min. de répétitions et un nombre maximum de répétitions dans la zone Max.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
Voir aussi
Définition des jeux de pages


Propriétés de la palette Objet

Codes à barres
Boutons
Cases à cocher
Cercles
Zones de contenu
Champs de date/heure
Champs décimaux
Champs de signature du document
Listes déroulantes
Bouton Envoyer par messagerie
Bouton Envoyer via HTTP
Champs d'image
Images
Lignes
Zones de liste
Champs numériques
Codes à barres de formulaires pour support papier
Champs de mot de passe
Boutons radio
Rectangles
Sous-formulaires
Jeux de sous-formulaires
Tableaux
Texte
Champs de texte


Codes à barres

Propriétés des codes à barres dans le panneau Champ
Propriétés des codes à barres dans le panneau Valeur
Propriétés des codes à barres dans le panneau Liaison
Formats de codes à barres pris en charge
Caractères de texte de code à barres corrects


Propriétés des codes à barres dans le panneau Champ

Lorsque vous sélectionnez un code à barres, le panneau Champ de la palette Objet affiche les options propres au formatage de l'objet.
Lieu
Détermine l'emplacement du texte du code à barres.
Propriété/Valeur
Définissent les propriétés propres au code à barres.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Voir aussi
Aperçu des codes à barres


Propriétés des codes à barres dans le panneau Valeur

Lorsque vous créez un code à barres, le panneau Valeur propose différentes options que vous pouvez appliquer à l'objet.
Type
Permet les calculs à l'exécution et l'affichage d'invites :
    • Entré par l'utilisateur - Facultatif
L'utilisateur peut choisir d'entrer des données ou non.
    • Entré par l'utilisateur - Recommandé
Si l'utilisateur n'entre pas de données, un message personnalisé (s'il est défini dans la zone Message d'état vide) s'affiche.
    • Entré par l'utilisateur - Obligatoire
Si l'utilisateur n'entre pas de données, un message personnalisé (s'il est défini dans la zone Message d'état vide) s'affiche.
    • Calculé - Lecture seule
Une valeur sera calculée et affichée par le biais d'un script. L'utilisateur n'a pas la possibilité de modifier la valeur calculée.
    • Calculé - L'utilisateur peut remplacer
Une valeur sera calculée et affichée par le biais d'un script. L'utilisateur peut changer la valeur si le script de calcul accepte les saisies. Si l'utilisateur change la valeur, le message personnalisé que vous avez défini dans la zone Message de remplacement s'affiche.
    • Lecture seule
Une valeur sera fusionnée ou calculée et affichée à l'exécution. Les utilisateurs ne peuvent pas modifier la valeur.
Valeur par défaut
Définit la valeur initiale du code à barres. La longueur de la valeur par défaut peut affecter la largeur de l'affichage de certains codes à barres.
cette option s'affiche uniquement lorsque l'option Type est définie sur Entré par l'utilisateur - Obligatoire, Entré par l'utilisateur - Recommandé ou Lecture seule.
Message d'état vide
Définit le message demandant aux utilisateurs d'entrer une valeur recommandée ou obligatoire. Voir Pour inviter les utilisateurs à entrer des données.
Cette option est disponible seulement lorsque l'option Type est définie sur Entré par l'utilisateur - Recommandé ou Entré par l'utilisateur - Obligatoire.
Modèle de validation
Définit le modèle qui valide la valeur entrée par l'utilisateur. Le modèle doit correspondre à la syntaxe de la valeur saisie par l'utilisateur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule.
Message du modèle de validation et Erreur
Définit un message personnalisé qui s'affiche lorsque la valeur brute ne correspond pas au modèle de validation. Par défaut, cette situation génère une erreur de programmation à l'exécution. Pour afficher plutôt un message d'avertissement, désélectionnez l'option Erreur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule. La propriété Message du modèle de validation est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique un message de modèle de validation.
Message du script de validation et Erreur
Définit un message personnalisé qui s'affiche lorsque le script de validation détecte une valeur inacceptable. Par défaut, cette situation génère une erreur de programmation à l'exécution. Pour afficher plutôt un message d'avertissement, désélectionnez l'option Erreur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule. La propriété Message du script de validation est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique un message de script de validation.
Message de remplacement
Définit un message personnalisé pour informer l'utilisateur qu'il change la valeur d'un champ calculé. Le message s'affiche lorsqu'un utilisateur modifie la valeur calculée.
cette option est disponible uniquement lorsque l'option Type est définie sur Calculé - L'utilisateur peut remplacer.
Voir aussi
Aperçu des codes à barres
Pour définir le mode de fonctionnement d'un code à barres
Pour remplir de façon dynamique un message de modèle de validation
Pour remplir de façon dynamique un message de script de validation


Propriétés des codes à barres dans le panneau Liaison

Le panneau Liaison propose différentes options pour la liaison des codes à barres. Les options qui ne sont pas directement liées à la création d'une connexion de données s'appliquent aux données liées à une source de données et aux données enregistrées dans un fichier lorsque l'objet est lié à la source de données.
Nom
Définit le nom du code à barres. Voir Pour donner un nom aux objets ou changer leur nom.
Liaison par défaut
Définit la méthode de liaison de données par défaut :
    • Normale
Active les options de fusion et d'enregistrement. Les données sont fusionnées et enregistrées implicitement conformément aux règles de fusion d'Adobe.
    • Globale
Associe une valeur unique à tous les objets qui portent le même nom (voir Pour définir un champ global).
    • Nouvelle connexion aux données
Démarre l'assistant Nouvelle connexion aux données. Pour définir une connexion à l'aide de l'assistant, voir Pour établir une connexion à un schéma XML et à un fichier de données XML ou Pour établir une connexion à une base de données OLE.
    • Non
Désactive la liaison de données. Puisque l'objet ne recueille et n'affiche aucune donnée fusionnée, aucune information associée ne s'affiche dans la sortie lorsque le formulaire est enregistré/envoyé.
Importation/exportation
Définit une liaison d'importation/exportation pour une connexion de données WSDL. Voir Pour établir une connexion à un fichier WSDL.
Voir aussi
A propos des sources de données
Aperçu des codes à barres
Pour définir les propriétés de liaison personnalisée d'un code à barres


Formats de codes à barres pris en charge

Voici la liste des formats de codes à barres pris en charge :
AUS Post Custom2
Format AUSPOST Custom 2
AUS Post Custom3
Format AUSPOST Custom 3
AUS Post Reply Paid
Format AUSPOST Reply Paid
AUS Post Standard
Format AUSPOST Standard
Codabar
Format Codabar qui offre une compatibilité avec USD-4, NW-7 et Code 2 parmi 7
Code 11
Format Code 11 (de type matériel)
Code 128SSCC
Format UCC/EAN 128 SSCC (Serial Shipping Container Code)
Code 128
Format Code 128
Code 128A
Format Code 128, jeu A
Code 128B
Format Code 128, jeu B
Code 128C
Format Code 128, jeu C
Code 2 parmi 5 industriel
Format 2 parmi 5 industriel
Code 2 parmi 5 entrelacé
Format 2 parmi 5 entrelacé, qui offre une compatibilité avec Code 25, I2of5, ITF et I25
Code 2 parmi 5 matriciel
Format 2 parmi 5 matriciel
Code 3 parmi 9 - 3
Format 3 parmi 9
Code 93
Format Code 93 (de type matériel)
Code 49
Format Code 49 (de type matériel)
Code QR
Format de code 2D QR (Quick Response) (de type matériel)
EAN13
Format EAN13
EAN8
Format EAN8
Logmars
Format Logmars (de type matériel)
MSI
Format MSI (de type matériel)
PDF 417
Format bidimensionnel qui accepte jusqu'à 1 800 caractères ASCII
Plessey
Format Plessey (de type matériel)
UK Post RM4SCC
Format RM4SCC de la Poste royale du Royaume-Uni
CUP-A
Format CUP-A
CUP-E
Format CUP-E (de type matériel)
CUP EAN2
Format CUP EAN2 (de type matériel)
CUP EAN5
Format CUP EAN5 (de type matériel)
US Postal Zip-5
Format à 5 chiffres de la poste américaine
US Postal DPBC
Format du ZIP de livraison +6
US Postal Standard
Format standard de la poste américaine
il est possible d'ajouter d'autres formats de code à barres de type matériel à l'ensemble par défaut de formats pris en charge.
Voir aussi
Aperçu des codes à barres


Caractères de texte de code à barres corrects

Le tableau ci-dessous identifie les caractères que vous pouvez utiliser dans le texte des codes à barres.

Code à barres

Caractères corrects
AUS Post Custom2
AUS Post Custom3
AUS Post Reply Paid
AUS Post Standard
Code 2 parmi 5 industriel
Code 2 parmi 5 entrelacé
Code 2 parmi 5 matriciel
EAN13
EAN8
MSI
CUP-A
CUP-E
CUP-EAN2
CUP-EAN5
US Postal Zip-5
US Postal DPBC
US Postal Standard
0 1 2 3 4 5 6 7 8 9
Codabar
0 1 2 3 4 5 6 7 8 9
- $ : / . +
Code 11
0 1 2 3 4 5 6 7 8 9
-
Code 128SSCC
Code 128
Code 128A
Code 128B
Code 128C
0 1 2 3 4 5 6 7 8 9
! # & ' < > `
$ % ( ) * + , - . / : ; ? @ # = [ ] \ ^ _ { } | ~ ESPACE
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
a b c d e f g h i j k l m n o p q r s t u v w x y z
Code 3 parmi 9
0 1 2 3 4 5 6 7 8 9
- . $ / + % * ESPACE
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Code 49
0 1 2 3 4 5 6 7 8 9
< > - . $ / + % : ; ? =
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Code 93
0 1 2 3 4 5 6 7 8 9
& ' - . $ ( ) / + % , ESPACE
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Logmars
0 1 2 3 4 5 6 7 8 9
- . $ / + % ESPACE
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
PDF 417
Aucune restriction
Plessey
0 1 2 3 4 5 6 7 8 9
A B C D E F
UK Post RM4SCC
0 1 2 3 4 5 6 7 8 9
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Voir aussi
Aperçu des codes à barres


Boutons

Propriétés de l'objet Bouton dans l'onglet Champ
Propriétés des boutons d'impression dans le panneau Champ
Propriétés des boutons de réinitialisation dans l'onglet Champ
Propriétés des boutons dans le panneau Envoyer
Propriétés des boutons dans le panneau Exécuter


Propriétés de l'objet Bouton dans l'onglet Champ

Lorsque vous sélectionnez un bouton, le panneau Champ de la palette Objet affiche les options propres au formatage de l'objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Légende
Définit la légende de l'objet.
La propriété Légende est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique une légende.
Aspect
Définit le style de la bordure :
    • Aucune bordure
Supprime la ligne entourant le bouton.
    • Bordure pleine
Crée une ligne épaisse autour du bouton.
    • Bordure surélevée
Crée une ombre autour du bouton pour lui donner un aspect tridimensionnel.
    • Personnaliser
Ouvre la boîte de dialogue Aspect personnalisé. Sélectionnez cette option pour personnaliser l'aspect du bouton.
Mise en surbrillance
Définit la façon dont le bouton est mis en évidence lorsque vous cliquez dessus :
    • Non
Supprime la mise en surbrillance du bouton.
    • Inversée
Inverse la mise en surbrillance du bouton lorsque vous cliquez dessus.
    • Enfoncé
Crée une ombre autour du bouton pour donner l'impression qu'il est enfoncé.
    • Contour
Crée une ligne autour du bouton lorsque vous cliquez dessus.
Légende au survol
Définit une légende au survol lorsque le type de mise en surbrillance du bouton est Enfoncé. Cette légende apparaît dès que vous placez le curseur au-dessus du bouton.
Légende à l'activation
Définit une légende lorsque le type de mise en surbrillance du bouton est Enfoncé. Cette légende apparaît dès que vous cliquez sur le bouton.
Type de contrôle
Détermine l'action exécutée lorsque l'utilisateur clique sur le bouton. Les options suivantes ne s'affichent pas pour les boutons Imprimer et Réinitialiser :
    • Normal
Exécute le script ou le calcul qui est joint. Le script ou le calcul est fournit par l'utilisateur.
    • Envoyer
Les données sont envoyées conformément aux paramètres définis dans le panneau Envoyer. Voir Propriétés des boutons dans le panneau Envoyer.
    • Exécuter
Une opération de service Web ou une requête dans une base de données est exécutée conformément aux paramètres définis dans le panneau Exécuter. Voir Propriétés des boutons dans le panneau Exécuter.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
Aperçu des boutons


Propriétés des boutons d'impression dans le panneau Champ

Lorsque vous sélectionnez un bouton, le panneau Champ de la palette Objet affiche les options propres au formatage de l'objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Légende
Définit la légende de l'objet.
La propriété Légende est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique une légende.
Aspect
Définit le style de la bordure :
    • Aucune bordure
Supprime la ligne entourant le bouton.
    • Bordure pleine
Crée une ligne épaisse autour du bouton.
    • Bordure surélevée
Crée une ombre autour du bouton pour lui donner un aspect tridimensionnel.
    • Personnaliser
Ouvre la boîte de dialogue Aspect personnalisé. Sélectionnez cette option pour personnaliser l'aspect du bouton.
Mise en surbrillance
Définit la façon dont le bouton est mis en évidence lorsque vous cliquez dessus :
    • Non
Supprime la mise en surbrillance du bouton.
    • Inversée
Inverse la mise en surbrillance du bouton lorsque vous cliquez dessus.
    • Enfoncé
Crée une ombre autour du bouton pour donner l'impression qu'il est enfoncé.
    • Contour
Crée une ligne autour du bouton lorsque vous cliquez dessus.
Légende au survol
Définit une légende au survol lorsque le type de mise en surbrillance du bouton est Enfoncé. Cette légende apparaît dès que vous placez le curseur au-dessus du bouton.
Légende à l'activation
Définit une légende lorsque le type de mise en surbrillance du bouton est Enfoncé. Cette légende apparaît dès que vous cliquez sur le bouton.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
Aperçu des boutons


Propriétés des boutons de réinitialisation dans l'onglet Champ

Lorsque vous sélectionnez un bouton, le panneau Champ de la palette Objet affiche les options propres au formatage de l'objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Légende
Définit la légende de l'objet.
La propriété Légende est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique une légende.
Aspect
Définit le style de la bordure :
    • Aucune bordure
Supprime la ligne entourant le bouton.
    • Bordure pleine
Crée une ligne épaisse autour du bouton.
    • Bordure surélevée
Crée une ombre autour du bouton pour lui donner un aspect tridimensionnel.
    • Personnaliser
Ouvre la boîte de dialogue Aspect personnalisé. Sélectionnez cette option pour personnaliser l'aspect du bouton.
Mise en surbrillance
Définit la façon dont le bouton est mis en évidence lorsque vous cliquez dessus :
    • Non
Supprime la mise en surbrillance du bouton.
    • Inversée
Inverse la mise en surbrillance du bouton lorsque vous cliquez dessus.
    • Enfoncé
Crée une ombre autour du bouton pour donner l'impression qu'il est enfoncé.
    • Contour
Crée une ligne autour du bouton lorsque vous cliquez dessus.
Légende au survol
Définit une légende au survol lorsque le type de mise en surbrillance du bouton est Enfoncé. Cette légende apparaît dès que vous placez le curseur au-dessus du bouton.
Légende à l'activation
Définit une légende lorsque le type de mise en surbrillance du bouton est Enfoncé. Cette légende apparaît dès que vous cliquez sur le bouton.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
Aperçu des boutons


Propriétés des boutons dans le panneau Envoyer

Lorsque vous créez un bouton et que vous définissez son type de contrôle sur Envoyer, le panneau Envoyer s'affiche dans la palette Objet. Ce panneau présente différentes options de formatage des boutons prévus pour soumettre des données.
Envoyer à l'URL
Définit l'emplacement du serveur Web hôte. Vous pouvez spécifier les protocoles suivants : ftp, http, https ou mailto.
Envoyer comme
Définit le format des données à soumettre.
    • Paquet de données XML (XDP)
Soumet un paquet au format de fichier créé par LiveCycle Designer. Sélectionnez ce format si le formulaire effectue un traitement serveur ou pour soumettre la conception de formulaire, les données du formulaire, les annotations et toute autre donnée requise par LiveCycle Forms pour le rendu du formulaire au moment de l'exécution.
    • PDF
Soumet un paquet qui contient un fichier PDF incorporé. Sélectionnez ce format si le formulaire contient un champ de signature du document ou si une copie du formulaire et des données doit être enregistrée par LiveCycle Forms ou soumise à un autre type de serveur. Ne choisissez pas cette option si le formulaire lance un traitement sur le serveur, si LiveCycle Forms est utilisé pour générer des formulaires HTML ou avec une disposition souple au moment de l'exécution, ou s'il s'agit d'un formulaire PDF rempli dans Adobe Reader sans LiveCycle Reader Extensions.
    • Données XML (XML)
Soumet un flux de données XML pour permettre une représentation hiérarchique des données pouvant être analysée par un analyseur syntaxique XML. Sélectionnez ce format si le serveur qui communique avec le programme d'application doit recevoir un flux de données XML.
    • Données codées dans URL (HTTP Post)
Soumet un flux de texte à l'URL spécifiée par le biais de la méthode POST. Le flux de texte peut être analysé par un serveur FTP, un serveur de messagerie, un serveur Web ou un script CGI qui traite des formulaires HTML. Pour tirer parti de cette méthode, les utilisateurs doivent ouvrir le formulaire dans Adobe Reader 6.0 (ou version ultérieure) ou dans un navigateur Web à moins que l'URL n'indique un protocole mailto.
Signature de l'envoi
Applique une signature de données aux données envoyées. Lorsqu'un utilisateur clique sur ce bouton, une signature numérique est créée pour protéger les données envoyées, ainsi que les pièces jointes. La signature de données protège les données signées tout en assurant leur intégrité lors de la transmission. La signature de données peut s'appliquer aux données du formulaire ou à la totalité de l'envoi, y compris aux pièces jointes. Vous pouvez cliquer sur le bouton Paramètres pour définir les propriétés des options de sécurité facultatives de la signature de données, telles qu'un gestionnaire de signatures, des certificats de signatures ou des émetteurs de certificat.
Inclure
Détermine les éléments à inclure en tant que pièces jointes. Les pièces jointes ne peuvent être incluses que dans des fichiers XDP.
    • Annotations
Comprend des commentaires de révision, des info-bulles et toute autre balise particulière nécessaire à la capture du texte du lecteur d'écran.
    • Signature numérique
Inclut les signatures numériques à un document signé.
    • PDF
Si cette option est activée, incorpore une version PDF du formulaire envoyé en tant que pièce jointe ; sinon, une référence à un fichier PDF incorporé est incluse.
    • Modèle
Inclut une copie de la conception de formulaire sans données fusionnées.
    • Autre
Intègre un ou plusieurs éléments <xdp> dans le fichier source XDP. Les éléments spécifiés doivent être séparés par une virgule. L'espace après la virgule est facultatif. Par exemple : xci, xslt, sourceset.
Options de données
Définit le format de codage pour le transfert des données.
    • UTF-8
Unicode Transformation Format 8.
    • UTF-16
Unicode Transformation Format 16.
    • Shift_JIS
Codage de la norme industrielle japonaise.
    • Big5
Norme commune de codage des caractères en chinois traditionnel.
    • GBK
Codage des caractères en chinois simplifié (GB 13000.1-93) (une extension de GB 2312-80).
    • KSC_5601
Encodage en coréen.
Voir aussi
Aperçu des boutons
A propos de l'envoi de données au moyen d'un bouton


Propriétés des boutons dans le panneau Exécuter

Lorsque vous créez un bouton et que vous définissez l'option Type de contrôle sur Exécuter, le panneau Exécuter s'affiche dans la palette Objet. Ce panneau présente différentes options de formatage des boutons prévus pour établir une connexion aux données.
Connexion
Définit la connexion. Voir Pour établir une connexion à un fichier WSDL.
Info sur la connexion
Fournit des renseignements sur la connexion et le nom de l'opération ou de la requête à exécuter.
Exécuter sur
Définit l'emplacement de l'exécution.
    • Client
Traite la requête sur l'ordinateur client.
    • Serveur
Traite la requête sur le serveur.
    • Client et serveur
Traite la requête sur l'ordinateur client et sur le serveur.
Fusionner à nouveau les données de formulaire
Autorise ou non la mise à jour de la structure du formulaire une fois que le traitement est terminé.
Voir aussi
Aperçu des boutons
A propos des options de traitement d'un bouton
Détermination de l'emplacement d'exécution de votre calcul ou script


Cases à cocher

Propriétés des cases à cocher dans le panneau Champ
Propriétés des cases à cocher dans le panneau Valeur
Propriétés de case à cocher dans le panneau Liaison


Propriétés des cases à cocher dans le panneau Champ

Lorsque vous sélectionnez une case à cocher, le panneau Champ de la palette Objet affiche les options propres au formatage de l'objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Légende
Définit la légende de l'objet.
La propriété Légende est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique une légende.
Aspect
Définit le style de la bordure de la case à cocher.
    • Non
N'affiche pas de bordure autour de la case.
    • Carré 2D
Utilise un carré plein pour représenter la case.
    • Carré enfoncé
La case est un carré formé de lignes ombrées qui lui donnent un aspect tridimensionnel.
    • Cercle 2D
Utilise un cercle plein pour représenter la case.
    • Cercle enfoncé
La case est un cercle formé de lignes ombrées qui lui donnent un aspect tridimensionnel.
    • Personnaliser
Ouvre la boîte de dialogue Aspect personnalisé. Sélectionnez cette option si vous voulez personnaliser la zone remplissable de l'objet.
Etats
Définit le nombre d'états possibles :
    • Activé/Désactivé
L'état de la case à cocher pourra être soit Activé (case sélectionnée) ou Désactivé (case vide).
    • Activé/Désactivé/Neutre
L'état de la case à cocher pourra être Activé (case sélectionnée), Désactivé (case vide) ou Neutre (case ni sélectionnée ni vide).
Les valeurs correspondant à chacun des états doivent être définies dans le panneau Liaison de la palette Objet.
Format
Définit la taille de l'objet.
Type de marque
Définit le style de l'objet :
    • Valeur par défaut
Représente la marque de sélection par un X.
    • Coche
Représente la marque de sélection par une coche.
    • Cercle
Représente la marque de sélection par un cercle.
    • Croix
Représente la marque de sélection par une croix.
    • Losange
Représente la marque de sélection par un losange.
    • Carré
Représente la marque de sélection par un rectangle.
    • Etoile
Représente la marque de sélection par une étoile.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
A propos des cases à cocher


Propriétés des cases à cocher dans le panneau Valeur

Lorsque vous créez une case à cocher, le panneau Valeur propose différentes options que vous pouvez appliquer à l'objet.
Type
Permet des calculs à l'exécution et l'affichage d'invites.
    • Entré par l'utilisateur
L'utilisateur peut choisir d'entrer des données ou non.
    • Calculé - Lecture seule
Une valeur sera calculée et affichée à l'exécution par le biais d'un script. L'utilisateur n'est pas autorisé à modifier la valeur calculée.
    • Calculé - L'utilisateur peut remplacer
Une valeur sera calculée et affichée par le biais d'un script. L'utilisateur peut changer la valeur si le script de calcul accepte les saisies. Si l'utilisateur change la valeur, le message personnalisé que vous avez défini dans la zone Message de remplacement s'affiche.
    • Lecture seule
Une valeur sera fusionnée ou calculée et affichée à l'exécution. L'utilisateur n'est pas autorisé à modifier la valeur.
Valeur par défaut
Définit l'état initial de la case à cocher.
    • Activé
L'état par défaut est Activé. La case est initialement cochée.
    • Désactivé
L'état par défaut est Désactivé. La case est initialement désélectionnée.
    • Neutre
L'état par défaut est Neutre. La case est initialement grisée.
la liste Valeur par défaut est disponible uniquement si l'option Type est définie sur Entré par l'utilisateur ou sur Lecture seule. L'option Neutre est disponible dans la liste Valeur par défaut seulement lorsque l'option Etats du panneau Champ est définie sur Activé/Désactivé/Neutre.
Message du script de validation et Erreur
Définit un message personnalisé qui s'affiche lorsque le script de validation détecte une valeur inacceptable. Par défaut, cette situation génère une erreur de programmation à l'exécution. Pour afficher plutôt un message d'avertissement, désélectionnez l'option Erreur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule. La propriété Message du script de validation est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique un message de script de validation.
Message de remplacement
Définit un message personnalisé pour informer l'utilisateur qu'il change la valeur d'un champ calculé. Le message s'affiche lorsqu'un utilisateur modifie la valeur calculée.
cette option est disponible uniquement lorsque l'option Type est définie sur Calculé - L'utilisateur peut remplacer.
Voir aussi
A propos des cases à cocher


Propriétés de case à cocher dans le panneau Liaison

Lorsque vous créez une case à cocher, le panneau Liaison propose différentes options que vous pouvez appliquer à l'objet. Les options qui ne sont pas directement liées à la création d'une connexion de données s'appliquent aux données liées à une source de données et aux données enregistrées dans un fichier lorsque l'objet est lié à la source de données.
Nom
Définit le nom de la case à cocher. Voir Pour donner un nom aux objets ou changer leur nom.
Liaison par défaut
Définit la méthode de liaison de données par défaut :
    • Normale
Active les options de fusion et d'enregistrement. Les données sont fusionnées et enregistrées implicitement conformément aux règles de fusion d'Adobe.
    • Globale
Associe une valeur unique à tous les objets qui portent le même nom (voir Pour définir un champ global).
    • Nouvelle connexion aux données
Démarre l'assistant Nouvelle connexion aux données. Pour définir une connexion à l'aide de l'assistant, voir Pour établir une connexion à un schéma XML et à un fichier de données XML ou Pour établir une connexion à une base de données OLE.
    • Non
Désactive la liaison de données. Puisque l'objet ne recueille et n'affiche aucune donnée fusionnée, aucune information associée ne s'affiche dans la sortie lorsque le formulaire est enregistré/envoyé.
Valeur - zone sélectionnée
Indique la valeur de l'état Activé de la case à cocher dans la source de données. Voir Pour modifier les valeurs attribuées aux états d'une case à cocher.
Valeur - zone non sélectionnée
Indique la valeur de l'état Désactivé de la case à cocher dans la source de données.
Valeur - zone en grisé
Indique la valeur de l'état Neutre de la case à cocher dans la source de données.
Importation/exportation
Définit une liaison d'importation/exportation pour une connexion de données WSDL. Voir Pour établir une connexion à un fichier WSDL.
Voir aussi
A propos des sources de données
A propos des cases à cocher


Précédent Suivant

Utilisation de LiveCycle Designer > Propriétés de l'objet > Propriétés de la palette Objet > Cercles

Cercles

Propriétés des cercles dans le panneau Dessin


Propriétés des cercles dans le panneau Dessin

Lorsque vous créez un cercle, le panneau Dessin de la palette Objet affiche les options propres au formatage de l'objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Aspect
Définit la forme de l'objet.
    • Ellipse
Trace une forme elliptique.
    • Cercle
Trace une forme circulaire.
    • Arc
Trace un arc.
Début
Définit le point de départ d'un arc.
Balayage
Définit le point d'arrivée d'un arc.
Style de trait
Définit le style et l'épaisseur de la ligne.
Sélecteur de couleurs
Définit la couleur de la ligne.
Fond
Définit le style du fond.
Sélecteur de couleurs
Définit les couleurs du fond.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Voir aussi
Aperçu des cercles, des lignes et des rectangles


Précédent Suivant

Utilisation de LiveCycle Designer > Propriétés de l'objet > Propriétés de la palette Objet > Zones de contenu

Zones de contenu

Propriétés des zones de contenu dans le panneau Zone de contenu


Propriétés des zones de contenu dans le panneau Zone de contenu

Le panneau Zone de contenu présente deux options.
Nom
Définit le nom de la zone de contenu.
Enchaînement
Définit la direction de l'enchaînement des sous-formulaires de la zone de contenu.
    • Haut vers le bas
Définit l'ordre de tabulation et l'ordre de remplissage par défaut du haut vers le bas de la page.
    • Texte occidental
Définit l'ordre de tabulation et l'ordre de remplissage par défaut du haut de la page vers la droite jusqu'à ce l'objet le plus à droite ait été atteint. Une fois le bord droit de la page atteint, l'enchaînement se poursuit au prochain objet en dessous et du côté gauche de la page.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
Voir aussi
Aperçu des zones de contenu
Flux des données entre les zones de contenu


Champs de date/heure

Propriétés des champs de date/heuredans le panneau Champ
Propriétés des champs de date/heure dans le panneau Valeur
Propriétés des champs de date/heure dans le panneau Liaison
Exemples de formats de date et heure


Propriétés des champs de date/heuredans le panneau Champ

Lorsque vous sélectionnez un champ de date/heure, le panneau Champ présente différentes options propres au formatage de cet objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Légende
Définit la légende de l'objet.
La propriété Légende est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique une légende.
Aspect
Définit le style de la bordure du champ :
    • Non
N'affiche pas de bordure autour du champ.
    • Souligné
Souligne le champ.
    • Case pleine
Affiche une bordure pleine autour du champ
    • Case enfoncée
Crée une ombre autour du champ pour lui donner un aspect tridimensionnel.
    • Personnaliser
Ouvre la boîte de dialogue Aspect personnalisé. Sélectionnez cette option si vous voulez personnaliser la zone remplissable de l'objet.
Limiter la longueur à la zone visible
Définit le nombre maximal de caractères et de chiffres autorisés dans le champ en fonction de la longueur horizontale du champ de date/heure.
Utiliser les cellules
Active le format de peigne.
Format d'affichage
Définit le format d'affichage des valeurs formatées dans le formulaire. Le format doit être compatible avec celui des données sélectionné dans le panneau Liaison. Par exemple, si le format des données est défini sur Date, le format doit correspondre à un format de date.
lors de la conception et de l'exécution, les valeurs formatées dans la zone d'affichage sont tributaires du format du paramètre régional.
Format de saisie
Définit le format de syntaxe des valeurs entrées par l'utilisateur. Le format doit être compatible avec celui des données sélectionné dans le panneau Liaison. Par exemple, si le format des données est défini sur Date, le format doit correspondre à un format de date. Si l'entrée de l'utilisateur n'est pas conforme au format de saisie, les données sont refusées et la mise en forme des valeurs de champ n'est pas effectuée.
lors de la conception et de l'exécution, les valeurs formatées dans la zone d'affichage sont tributaires du format du paramètre régional.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
Aperçu des champs de date et d'heure
Pour définir un format d'affichage
Pour définir un format de saisie
Formats de date et heure


Propriétés des champs de date/heure dans le panneau Valeur

Lorsque vous créez un champ de date/heure, le panneau Valeur propose différentes options que vous pouvez appliquer à l'objet.
Type
Permet les calculs à l'exécution et l'affichage d'invites :
    • Entré par l'utilisateur - Facultatif
L'utilisateur peut choisir d'entrer des données ou non.
    • Entré par l'utilisateur - Recommandé
Si l'utilisateur n'entre pas de données, un message personnalisé (s'il est défini dans la zone Message d'état vide) s'affiche.
    • Entré par l'utilisateur - Obligatoire
Si l'utilisateur n'entre pas de données, un message personnalisé (s'il est défini dans la zone Message d'état vide) s'affiche.
    • Calculé - Lecture seule
Une valeur sera calculée et affichée par le biais d'un script. L'utilisateur n'a pas la possibilité de modifier la valeur calculée.
    • Calculé - L'utilisateur peut remplacer
Une valeur sera calculée et affichée par le biais d'un script. L'utilisateur peut changer la valeur si le script de calcul accepte les saisies. Si l'utilisateur change la valeur, le message personnalisé que vous avez défini dans la zone Message de remplacement s'affiche.
    • Lecture seule
Une valeur sera fusionnée ou calculée et affichée à l'exécution. Les utilisateurs ne peuvent pas modifier la valeur.
Valeur par défaut
Définit la valeur initiale du champ. La valeur est mise en forme selon le paramètre de l'option Format d'affichage du panneau Champ, mais elle doit se conformer à la valeur du format court de date ou d'heure propre au paramètre régional choisi pour le champ. Voir Formats de date et Formats d’heure pour obtenir plus de renseignements sur les formats courts de date et d'heure. si les données sont liées et qu'un modèle a été spécifié, la valeur doit correspondre au modèle de données défini dans le panneau Liaison. Voir Pour définir une valeur par défaut.
cette option s'affiche uniquement lorsque l'option Type est définie sur Entré par l'utilisateur - Obligatoire, Entré par l'utilisateur - Recommandé ou Lecture seule.
Message d'état vide
Définit le message demandant aux utilisateurs d'entrer une valeur recommandée ou obligatoire. Voir Pour inviter les utilisateurs à entrer des données.
Cette option est disponible seulement lorsque l'option Type est définie sur Entré par l'utilisateur - Recommandé ou Entré par l'utilisateur - Obligatoire.
Modèle de validation
Définit le modèle qui valide la valeur entrée par l'utilisateur. Le format doit être compatible avec le format des données sélectionné dans le panneau Liaison et correspondre à la syntaxe de la valeur saisie par l'utilisateur. Par exemple, si le format des données est défini sur Date, le format doit correspondre à un format de date. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule.
Message du modèle de validation et Erreur
Définit un message personnalisé qui s'affiche lorsque la valeur brute ne correspond pas au modèle de validation. Par défaut, cette situation génère une erreur de programmation à l'exécution. Pour afficher plutôt un message d'avertissement, désélectionnez l'option Erreur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule. La propriété Message du modèle de validation est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique un message de modèle de validation.
Message du script de validation et Erreur
Définit un message personnalisé qui s'affiche lorsque le script de validation détecte une valeur inacceptable. Par défaut, cette situation génère une erreur de programmation à l'exécution. Pour afficher plutôt un message d'avertissement, désélectionnez l'option Erreur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule. La propriété Message du script de validation est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique un message de script de validation.
Script de calcul
La valeur est calculée par le script écrit pour l’événement calculate de l’objet.
cette option est disponible uniquement lorsque l'option Type est définie sur Calculé - Lecture seule.
Propriété de l'exécution
Définit la propriété d'exécution choisie pour l'objet. Lorsque vous sélectionnez une propriété d'exécution, la valeur réelle correspondant à l'option est insérée dynamiquement dans le rendu du formulaire.
    • date/heure courante
Affiche la date et l'heure actuelles dans le champ de date/heure.
cette option est disponible uniquement lorsque l'option Type est définie sur Calculé - Lecture seule.
Message de remplacement
Définit un message personnalisé pour informer l'utilisateur qu'il change la valeur d'un champ calculé. Le message s'affiche lorsqu'un utilisateur modifie la valeur calculée.
cette option est disponible uniquement lorsque l'option Type est définie sur Calculé - L'utilisateur peut remplacer.
Voir aussi
Aperçu des champs de date et d'heure


Propriétés des champs de date/heure dans le panneau Liaison

Lorsque vous créez un champ de date/heure, le panneau Liaison propose différentes options que vous pouvez appliquer à l'objet. Les options qui ne sont pas directement liées à la création d'une connexion de données s'appliquent aux données liées à une source de données et aux données enregistrées dans un fichier lorsque l'objet est lié à la source de données.
Nom
Définit le nom du champ de date/heure. Voir Pour donner un nom aux objets ou changer leur nom.
Liaison par défaut
Définit la méthode de liaison de données par défaut :
    • Normale
Active les options de fusion et d'enregistrement. Les données sont fusionnées et enregistrées implicitement conformément aux règles de fusion d'Adobe.
    • Globale
Associe une valeur unique à tous les objets qui portent le même nom (voir Pour définir un champ global).
    • Nouvelle connexion aux données
Démarre l'assistant Nouvelle connexion aux données. Pour définir une connexion à l'aide de l'assistant, voir Pour établir une connexion à un schéma XML et à un fichier de données XML ou Pour établir une connexion à une base de données OLE.
    • Non
Désactive la liaison de données. Puisque l'objet ne recueille et n'affiche aucune donnée fusionnée, aucune information associée ne s'affiche dans la sortie lorsque le formulaire est enregistré/envoyé.
Modèle de données
Définit un modèle pour le stockage et l'extraction des données liées ou pour enregistrer les données lorsque le formulaire n'est pas lié à une source de données. Voir Pour spécifier un modèle de données.
Format des données
Définit le contenu du champ.
    • Date
Indique l'objet sous forme d'une date.
    • Heure
Indique l'objet sous forme d'une heure.
    • Date et heure
Indique l'objet sous forme d'une date et d'une heure.
Importation/exportation
Définit une liaison d'importation/exportation pour une connexion de données WSDL. Voir Pour établir une connexion à un fichier WSDL.
Voir aussi
A propos des sources de données
Aperçu des champs de date et d'heure
Pour spécifier les données à afficher dans le champ de date/heure
Formats de date et heure


Exemples de formats de date et heure

Une valeur formatée peut être affichée ou traitée. Une valeur brute respecte le format par défaut de LiveCycle Designer.
Formats prédéfinis
Le tableau ci-dessous illustre les formats de date et heure prédéfinis que vous pouvez sélectionner dans la liste Format d'affichage du panneau Champ de la palette Objet. Il montre également des exemples de valeurs par défaut entrées en fonction du paramètre régional spécifié. Dans ces exemples, le paramètre régional est Anglais (Etats-Unis).

Format prédéfini

Valeur d'entrée (format court, qui est M/D/YY pour la date et h:MM A pour l'heure)

Valeur formatée
YYYY-MM-DD
8/23/08
2008-08-23
EEEE, MMMM D, YYYY
8/23/08
Samedi, août 23, 2008
HH:MM:SS
5:02 PM
17:02:00
date{YYYY-MM-DD} time{HH:MM:SS}
8/23/08 5:02 PM
2008-08-23 17:02:00
pour obtenir le format court par défaut de la date et de l'heure, choisissez Affichage > Source XML et recherchez les lignes suivantes :
<datePatterns>
   <datePattern name="full">EEEE, MMMM D, YYYY</datePattern>
   <datePattern name="long">MMMM D, YYYY</datePattern>
   <datePattern name="med">MMM D, YYYY</datePattern>
   <datePattern name="short">M/D/YY</datePattern>
</datePatterns>
<timePatterns>
   <timePattern name="full">h:MM:SS A Z</timePattern>
   <timePattern name="long">h:MM:SS A Z</timePattern>
   <timePattern name="med">h:MM:SS A</timePattern>
   <timePattern name="short">h:MM A</timePattern>
</timePatterns>
Formats personnalisés
Le tableau ci-dessous illustre des formats d'affichage personnalisés que vous pouvez définir pour formater les valeurs par défaut d'entrée en fonction du paramètre régional spécifié. Dans ces exemples, le paramètre régional est Anglais (Etats-Unis).

Format personnalisé

Valeur d'entrée (format court, qui est M/D/YY pour la date et h:MM A pour l'heure)

Valeur formatée
MMMM DD, YYYY
8/23/08
Août 23, 2008
EEEE, 'le' D 'de' MMMM, YYYY
8/23/08
Samedi, le 23 août, 2008
HH:MM
5:02 PM
17:02
h:MM:SS 'o''clock' A Z
5:02 PM
5:02:00 o'clock PM EDT
HH:MM:SS Z
5:02 PM
17:02:00 EDT


Précédent Suivant

Utilisation de LiveCycle Designer > Propriétés de l'objet > Propriétés de la palette Objet > Champs décimaux

Champs décimaux

Propriétés des champs décimaux dans le panneau Champ


Propriétés des champs décimaux dans le panneau Champ

Lorsque vous sélectionnez un champ décimal, le panneau Champ de la palette Objet affiche les options propres à cet objet. A l'exception de deux options, toutes les options sont identiques à celles des champs numériques.
Limiter les chiffres de début et Max
Définit le nombre maximum de chiffres pouvant figurer avant le séparateur décimal. Un zéro s'affiche en cas de dépassement de la valeur maximale.
Valeur par défaut : Illimité
Maximum : 15 (y compris les chiffres de fin)
Limiter les chiffres de fin et Max
Définit le nombre maximum de chiffres pouvant figurer après le séparateur décimal. Le chiffre est arrondi en cas de dépassement de la valeur maximale. Si vous désélectionnez l'option Limiter les chiffres de fin, la précision des données décimales est celle des données entrées.
Valeur par défaut : 2
Maximum : 15 (y compris les chiffres de début)
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Voir aussi
Aperçu des champs de valeurs décimales et numériques
Aperçu des champs numériques
Propriétés des champs numériques dans le panneau Champ
Propriétés des champs numériques dans le panneau Valeur
Propriétés des champs numériques dans le panneau Liaison


Champs de signature du document

Propriétés des champs de signature du document dans le panneau Champ
Propriétés des champs de signature du document dans le panneau Champ


Propriétés des champs de signature du document dans le panneau Champ

Lorsque vous sélectionnez un champ de signature du document, le panneau Champ de la palette Objet affiche les options propres au formatage de l'objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Légende
Définit la légende de l'objet.
La propriété Légende est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique une légende.
Aspect
Définit le style de la bordure du champ :
    • Non
N'affiche pas de bordure autour du champ.
    • Souligné
Souligne le champ.
    • Case pleine
Affiche une bordure pleine autour du champ
    • Case enfoncée
Crée une ombre autour du champ pour lui donner un aspect tridimensionnel.
    • Personnaliser
Ouvre la boîte de dialogue Aspect personnalisé. Sélectionnez cette option si vous voulez personnaliser la zone remplissable de l'objet.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
Aperçu des champs de signature de document
A propos des signatures numériques


Propriétés des champs de signature du document dans le panneau Champ

Lorsque vous sélectionnez un champ de signature du document, le panneau Champ de signature de la palette Objet affiche plusieurs options de configuration pour la signature du document. Si la signature du document s'applique à une collection d'objets, les types d'objet valides sont les suivants : boutons, cases à cocher, champs de date/heure, champs décimaux, listes déroulantes, champs d'image, zones de liste, champs numériques, codes à barres de formulaires pour support papier, champs de mot de passe, boutons radio, autres champs de signature du document et champs de texte.
Vous pouvez cliquer sur le bouton Paramètres pour définir les propriétés des options de sécurité facultatives de la signature du document, telles qu'un gestionnaire de signatures, des certificats de signatures ou des émetteurs de certificat.
Verrouiller les champs après la signature
Indique à quels objets de formulaire s'applique la signature du document. Le champ de signature du document peut s'appliquer à l'intégralité du formulaire ou à une collection d'objets bien précis. Si vous ne sélectionnez pas cette option, la signature du document s'applique par défaut à l'intégralité du formulaire. Si vous sélectionnez cette option, la signature s'applique aux objets sélectionnés. Une fois que l'utilisateur a signé le formulaire, les champs signés sont verrouillés. Vous pouvez sélectionner la collection d'objet à signer dans la liste déroulante.
    • Tous les champs du document
Verrouille tous les champs du document.
    • Tous les champs de la collection
Verrouille tous les champs de la collection sélectionnée.
    • Tous les champs hors de la collection
Verrouille tous les champs non inclus dans la collection.
    • Créer/Gérer une collection
Ouvre la boîte de dialogue Liste des collections vous permettant de créer ou de modifier une collection de champs pour la signature du document.
Voir aussi
Aperçu des champs de signature de document
A propos des signatures numériques
A propos des collections d'objets de formulaire


Listes déroulantes

Propriétés des listes déroulantes dans le panneau Champ
Propriétés des listes déroulantes dans le panneau Valeur
Propriétés des listes déroulantes dans le panneau Liaison


Propriétés des listes déroulantes dans le panneau Champ

Lorsque vous sélectionnez une liste déroulante, le panneau Champ présente différentes options propres au formatage de l'objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Légende
Définit la légende de l'objet.
La propriété Légende est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique une légende.
Aspect
Définit le style de la bordure du champ :
    • Non
N'affiche pas de bordure autour du champ.
    • Souligné
Souligne le champ.
    • Case pleine
Affiche une bordure pleine autour du champ
    • Case enfoncée
Crée une ombre autour du champ pour lui donner un aspect tridimensionnel.
    • Personnaliser
Ouvre la boîte de dialogue Aspect personnalisé. Sélectionnez cette option si vous voulez personnaliser la zone remplissable de l'objet.
Articles de liste
Définit les valeurs proposées dans la liste et leur position. Vous pouvez ajouter ou supprimer des éléments dans la liste, les faire monter ou descendre, ou encore les trier par ordre croissant ou décroissant à l'aide des boutons disponibles à côté du libellé.
Articles de liste est une propriété dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet.
Permettre la saisie de texte personnalisé
Autorise ou non l'utilisateur à entrer des valeurs. Ces valeurs doivent toutefois correspondre aux valeurs par défaut de LiveCycle Designer. Voir Valeurs de mise en forme par défaut.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
Aperçu des listes déroulantes et des zones de liste


Propriétés des listes déroulantes dans le panneau Valeur

Lorsque vous créez une liste déroulante, le panneau Valeur propose différentes options que vous pouvez appliquer à l'objet.
Type
Permet les calculs à l'exécution et l'affichage d'invites :
    • Entré par l'utilisateur - Facultatif
L'utilisateur peut choisir d'entrer des données ou non.
    • Entré par l'utilisateur - Recommandé
Si l'utilisateur n'entre pas de données, un message personnalisé (s'il est défini dans la zone Message d'état vide) s'affiche.
    • Entré par l'utilisateur - Obligatoire
Si l'utilisateur n'entre pas de données, un message personnalisé (s'il est défini dans la zone Message d'état vide) s'affiche.
    • Calculé - Lecture seule
Une valeur sera calculée et affichée par le biais d'un script. L'utilisateur n'a pas la possibilité de modifier la valeur calculée.
    • Calculé - L'utilisateur peut remplacer
Une valeur sera calculée et affichée par le biais d'un script. L'utilisateur peut changer la valeur si le script de calcul accepte les saisies. Si l'utilisateur change la valeur, le message personnalisé que vous avez défini dans la zone Message de remplacement s'affiche.
    • Lecture seule
Une valeur sera fusionnée ou calculée et affichée à l'exécution. Les utilisateurs ne peuvent pas modifier la valeur.
Valeur par défaut
Définit la valeur par défaut. Si la case Permettre la saisie de texte personnalisé est cochée dans le panneau Champ, vous pouvez entrer une valeur par défaut qui ne figure pas dans la liste.
cette option s'affiche uniquement lorsque l'option Type est définie sur Entré par l'utilisateur - Obligatoire, Entré par l'utilisateur - Recommandé ou Lecture seule.
Message d'état vide
Définit le message demandant aux utilisateurs d'entrer une valeur recommandée ou obligatoire. Voir Pour inviter les utilisateurs à entrer des données.
cette option est disponible seulement lorsque l'option Type est définie sur Entré par l'utilisateur - Recommandé ou Entré par l'utilisateur - Obligatoire.
Modèle de validation
Définit le modèle qui valide la valeur entrée par l'utilisateur. Le modèle doit correspondre à la syntaxe de la valeur saisie par l'utilisateur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule.
Message du modèle de validation et Erreur
Définit un message personnalisé qui s'affiche lorsque la valeur brute ne correspond pas au modèle de validation. Par défaut, cette situation génère une erreur de programmation à l'exécution. Pour afficher plutôt un message d'avertissement, désélectionnez l'option Erreur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule. La propriété Message du modèle de validation est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique un message de modèle de validation.
Message du script de validation et Erreur
Définit un message personnalisé qui s'affiche lorsque le script de validation détecte une valeur inacceptable. Par défaut, cette situation génère une erreur de programmation à l'exécution. Pour afficher plutôt un message d'avertissement, désélectionnez l'option Erreur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule. La propriété Message du script de validation est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique un message de script de validation.
Message de remplacement
Définit un message personnalisé pour informer l'utilisateur qu'il change la valeur d'un champ calculé. Le message s'affiche lorsqu'un utilisateur modifie la valeur calculée.
cette option est disponible uniquement lorsque l'option Type est définie sur Calculé - L'utilisateur peut remplacer.
Voir aussi
Aperçu des listes déroulantes et des zones de liste


Propriétés des listes déroulantes dans le panneau Liaison

Lorsque vous créez une liste déroulante, le panneau Liaison propose différentes options que vous pouvez appliquer à l'objet. Les options qui ne sont pas directement liées à la création d'une connexion de données s'appliquent aux données liées à une source de données et aux données enregistrées dans un fichier lorsque l'objet est lié à la source de données.
Nom
Définit le nom de la liste. Voir Pour donner un nom aux objets ou changer leur nom.
Liaison par défaut
Définit la méthode de liaison de données par défaut :
    • Normale
Active les options de fusion et d'enregistrement. Les données sont fusionnées et enregistrées implicitement conformément aux règles de fusion d'Adobe.
    • Globale
Associe une valeur unique à tous les objets qui portent le même nom (voir Pour définir un champ global).
    • Nouvelle connexion aux données
Démarre l'assistant Nouvelle connexion aux données. Pour définir une connexion à l'aide de l'assistant, voir Pour établir une connexion à un schéma XML et à un fichier de données XML ou Pour établir une connexion à une base de données OLE.
    • Non
Désactive la liaison de données. Puisque l'objet ne recueille et n'affiche aucune donnée fusionnée, aucune information associée ne s'affiche dans la sortie lorsque le formulaire est enregistré/envoyé.
Spécifier les valeurs
Permet de spécifier les valeurs de données personnalisées pour chaque élément de la liste. Si cette option n'est pas sélectionnée, les valeurs des données correspondent au texte des éléments de la liste. Si elle est sélectionnée, les valeurs par défaut consistent en des entiers qui se suivent et commencent à 0 pour le premier élément de la liste. Voir Pour spécifier les valeurs des éléments d'une liste déroulante ou d'une zone de liste.
la propriété Spécifier les valeurs est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet.
Monter, Descendre, Tri croissant, Tri décroissant
Réorganise les éléments dans la liste (par exemple, lorsque les données doivent être stockées dans un ordre différent de l'ordre d'affichage des options de la liste déroulante). Vous pouvez faire monter ou descendre des éléments dans la liste, ou les trier par ordre croissant ou décroissant à l'aide des boutons disponibles à côté du libellé.
Importation/exportation
Définit une liaison d'importation/exportation pour une connexion de données WSDL. Voir Pour établir une connexion à un fichier WSDL.
Voir aussi
A propos des sources de données
Aperçu des listes déroulantes et des zones de liste


Précédent Suivant

Utilisation de LiveCycle Designer > Propriétés de l'objet > Propriétés de la palette Objet > Bouton Envoyer par messagerie

Bouton Envoyer par messagerie

Propriétés des boutons Envoyer par messagerie dans le panneau Champ


Propriétés des boutons Envoyer par messagerie dans le panneau Champ

Lorsque vous sélectionnez un bouton Envoyer par messagerie, le panneau Champ de la palette Objet affiche les options propres au formatage de l'objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Légende
Définit la légende de l'objet.
La propriété Légende est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique une légende.
Aspect
Définit le style de la bordure :
    • Aucune bordure
Supprime la ligne entourant le bouton.
    • Bordure pleine
Crée une ligne épaisse autour du bouton.
    • Bordure surélevée
Crée une ombre autour du bouton pour lui donner un aspect tridimensionnel.
    • Personnaliser
Ouvre la boîte de dialogue Aspect personnalisé. Sélectionnez cette option pour personnaliser l'aspect du bouton.
Mise en surbrillance
Définit la façon dont le bouton est mis en évidence lorsque vous cliquez dessus :
    • Non
Supprime la mise en surbrillance du bouton.
    • Inversée
Inverse la mise en surbrillance du bouton lorsque vous cliquez dessus.
    • Enfoncé
Crée une ombre autour du bouton pour donner l'impression qu'il est enfoncé.
    • Contour
Crée une ligne autour du bouton lorsque vous cliquez dessus.
Légende au survol
Définit une légende au survol lorsque le type de mise en surbrillance du bouton est Enfoncé. Cette légende apparaît dès que vous placez le curseur au-dessus du bouton.
Légende à l'activation
Définit une légende lorsque le type de mise en surbrillance du bouton est Enfoncé. Cette légende apparaît dès que vous cliquez sur le bouton.
Adresse électronique
Indique le destinataire du message électronique et des données de formulaire jointes.
Objet du message
Définit l'objet du message électronique.
Signature de l'envoi
Applique une signature de données aux données envoyées. Lorsqu'un utilisateur clique sur ce bouton, une signature numérique est créée pour protéger les données envoyées, ainsi que les pièces jointes. La signature de données protège les données signées tout en assurant leur intégrité lors de la transmission. La signature de données peut s'appliquer aux données du formulaire ou à la totalité de l'envoi, y compris aux pièces jointes. Vous pouvez cliquer sur le bouton Paramètres pour définir les propriétés des options de sécurité facultatives de la signature de données, telles qu'un gestionnaire de signatures, des certificats de signatures ou des émetteurs de certificat.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
Aperçu du bouton Envoyer par messagerie


Précédent Suivant

Utilisation de LiveCycle Designer > Propriétés de l'objet > Propriétés de la palette Objet > Bouton Envoyer via HTTP

Bouton Envoyer via HTTP

Propriétés des boutons Envoyer via HTTP dans le panneau Champ


Propriétés des boutons Envoyer via HTTP dans le panneau Champ

Lorsque vous sélectionnez un bouton Envoyer via HTTP, le panneau Champ de la palette Objet affiche les options propres au formatage de l'objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Légende
Définit la légende de l'objet.
La propriété Légende est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique une légende.
Aspect
Définit le style de la bordure :
    • Aucune bordure
Supprime la ligne entourant le bouton.
    • Bordure pleine
Crée une ligne épaisse autour du bouton.
    • Bordure surélevée
Crée une ombre autour du bouton pour lui donner un aspect tridimensionnel.
    • Personnaliser
Ouvre la boîte de dialogue Aspect personnalisé. Sélectionnez cette option pour personnaliser l'aspect du bouton.
Mise en surbrillance
Définit la façon dont le bouton est mis en évidence lorsque vous cliquez dessus :
    • Non
Supprime la mise en surbrillance du bouton.
    • Inversée
Inverse la mise en surbrillance du bouton lorsque vous cliquez dessus.
    • Enfoncé
Crée une ombre autour du bouton pour donner l'impression qu'il est enfoncé.
    • Contour
Crée une ligne autour du bouton lorsque vous cliquez dessus.
Légende au survol
Définit une légende au survol lorsque le type de mise en surbrillance du bouton est Enfoncé. Cette légende apparaît dès que vous placez le curseur au-dessus du bouton.
Légende à l'activation
Définit une légende lorsque le type de mise en surbrillance du bouton est Enfoncé. Cette légende apparaît dès que vous cliquez sur le bouton.
URL
Indique l'URL à laquelle les données de formulaire doivent être envoyées.
Signature de l'envoi
Applique une signature de données aux données envoyées. Lorsqu'un utilisateur clique sur ce bouton, une signature numérique est créée pour protéger les données envoyées, ainsi que les pièces jointes. La signature de données protège les données signées tout en assurant leur intégrité lors de la transmission. La signature de données peut s'appliquer aux données du formulaire ou à la totalité de l'envoi, y compris aux pièces jointes. Vous pouvez cliquer sur le bouton Paramètres pour définir les propriétés des options de sécurité facultatives de la signature de données, telles qu'un gestionnaire de signatures, des certificats de signatures ou des émetteurs de certificat.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
Aperçu du bouton Envoyer via HTTP


Précédent Suivant

Utilisation de LiveCycle Designer > Propriétés de l'objet > Propriétés de la palette Objet > Champs d'image

Champs d'image

Propriétés des champs d’image dans le panneau Champ
Propriétés des champs d’image dans le panneau Liaison


Propriétés des champs d’image dans le panneau Champ

Lorsque vous sélectionnez un champ d'image, le panneau Champ présente différentes options propres au formatage de l'objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Légende
Définit la légende de l'objet.
La propriété Légende est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique une légende.
URL
Détermine l'emplacement du fichier image source. Pour utiliser des chemins d'accès relatifs en vue de récupérer des images liées à l'ouverture du formulaire, les fichiers image doivent être stockés dans un dossier accessible aux utilisateurs. Si LiveCycle Forms est disponible, le chemin d'accès doit être relatif à LiveCycle Forms.
Incorporer les données image
Lorsque cette option est sélectionnée, une copie des données image est stockée dans le formulaire. Si cette option n'est pas sélectionnée, les données image sont stockées séparément et l'image est résolue à l'ouverture du formulaire.
Si le champ d'image est utilisé pour charger dynamiquement des images lors du rendu du formulaire, ne sélectionnez pas l'option Incorporer les données image.
Taille
Active ou désactive le redimensionnement lors du chargement de l'image.
    • Ajuster l'image proportionnellement
Redimensionne l'image dans l'objet tout en conservant les proportions.
    • Ajuster l'image à l'échelle du rectangle
Redimensionne l'image pour qu'elle corresponde aux dimensions de l'objet. Les proportions de l'image ne sont pas conservées.
    • Utiliser la taille d'origine
Ne redimensionne pas l'image. L'objet conserve la taille réelle de l'image.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
Aperçu des champs d'image


Propriétés des champs d’image dans le panneau Liaison

Lorsque vous créez un champ d'image, le panneau Liaison propose différentes options que vous pouvez appliquer à l'objet. Les options qui ne sont pas directement liées à la création d'une connexion de données s'appliquent aux données liées à une source de données et aux données enregistrées dans un fichier lorsque l'objet est lié à la source de données.
Nom
Définit le nom du champ d'image. Voir Pour donner un nom aux objets ou changer leur nom.
Liaison par défaut
Définit la méthode de liaison de données par défaut :
    • Normale
Active les options de fusion et d'enregistrement. Les données sont fusionnées et enregistrées implicitement conformément aux règles de fusion d'Adobe.
    • Globale
Associe une valeur unique à tous les objets qui portent le même nom (voir Pour définir un champ global).
    • Nouvelle connexion aux données
Démarre l'assistant Nouvelle connexion aux données. Pour définir une connexion à l'aide de l'assistant, voir Pour établir une connexion à un schéma XML et à un fichier de données XML ou Pour établir une connexion à une base de données OLE.
    • Non
Désactive la liaison de données. Puisque l'objet ne recueille et n'affiche aucune donnée fusionnée, aucune information associée ne s'affiche dans la sortie lorsque le formulaire est enregistré/envoyé.
Importation/exportation
Définit une liaison d'importation/exportation pour une connexion de données WSDL. Voir Pour établir une connexion à un fichier WSDL.
Voir aussi
A propos des sources de données
Aperçu des champs d'image


Précédent Suivant

Utilisation de LiveCycle Designer > Propriétés de l'objet > Propriétés de la palette Objet > Images

Images

Propriétés des images dans le panneau Dessin


Propriétés des images dans le panneau Dessin

Lorsque vous créez une image, le panneau Dessin de la palette Objet affiche les options propres au formatage de l'objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
URL
Détermine l'emplacement du fichier image source. Pour utiliser des chemins d'accès relatifs en vue de récupérer des images liées à l'ouverture du formulaire, les fichiers image doivent être stockés dans un dossier accessible aux utilisateurs. Si LiveCycle Forms est disponible, le chemin d'accès doit être relatif à LiveCycle Forms.
Incorporer les données image
Lorsque cette option est sélectionnée, une copie des données image est stockée dans le formulaire. Si cette option n'est pas sélectionnée, les données image sont stockées séparément et l'image est résolue à l'ouverture du formulaire.
Taille
Active ou désactive le redimensionnement lors du chargement de l'image :
    • Ajuster l'image proportionnellement
Redimensionne l'image dans l'objet tout en conservant les proportions.
    • Ajuster l'image à l'échelle du rectangle
Redimensionne l'image pour qu'elle corresponde aux dimensions de l'objet. Les proportions de l'image ne sont pas conservées.
    • Utiliser la taille d'origine
Ne redimensionne pas l'image. L'objet conserve la taille réelle de l'image.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Voir aussi
Aperçu des images


Précédent Suivant

Utilisation de LiveCycle Designer > Propriétés de l'objet > Propriétés de la palette Objet > Lignes

Lignes

Propriétés des lignes dans le panneau Dessin


Propriétés des lignes dans le panneau Dessin

Lorsque vous tracez une ligne, le panneau Dessin de la palette Objet affiche les options propres au formatage des lignes.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Aspect
Définit la pente de la ligne.
Style de trait
Définit le style et l'épaisseur de la ligne.
Sélecteur de couleurs
Définit la couleur de la ligne.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Voir aussi
Aperçu des cercles, des lignes et des rectangles


Zones de liste

Propriétés des zones de liste dans le panneau Champ
Propriétés des zones de liste dans le panneau Valeur
Propriétés des zones de liste dans le panneau Liaison


Propriétés des zones de liste dans le panneau Champ

Lorsque vous sélectionnez une zone de liste, le panneau Champ présente différentes options propres au formatage de l'objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Légende
Définit la légende de l'objet.
La propriété Légende est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique une légende.
Aspect
Définit le style de la bordure du champ :
    • Non
N'affiche pas de bordure autour du champ.
    • Souligné
Souligne le champ.
    • Case pleine
Affiche une bordure pleine autour du champ
    • Case enfoncée
Crée une ombre autour du champ pour lui donner un aspect tridimensionnel.
    • Personnaliser
Ouvre la boîte de dialogue Aspect personnalisé. Sélectionnez cette option si vous voulez personnaliser la zone remplissable de l'objet.
Articles de liste
Définit les valeurs proposées dans la liste et leur position. Vous pouvez ajouter ou supprimer des éléments dans la liste, les faire monter ou descendre, ou encore les trier par ordre croissant ou décroissant à l'aide des boutons disponibles à côté du libellé.
Articles de liste est une propriété dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
Aperçu des listes déroulantes et des zones de liste


Propriétés des zones de liste dans le panneau Valeur

Lorsque vous créez une zone de liste, le panneau Valeur propose différentes options que vous pouvez appliquer à l'objet.
Type
Permet les calculs à l'exécution et l'affichage d'invites :
    • Entré par l'utilisateur - Facultatif
L'utilisateur peut choisir d'entrer des données ou non.
    • Entré par l'utilisateur - Recommandé
Si l'utilisateur n'entre pas de données, un message personnalisé (s'il est défini dans la zone Message d'état vide) s'affiche.
    • Entré par l'utilisateur - Obligatoire
Si l'utilisateur n'entre pas de données, un message personnalisé (s'il est défini dans la zone Message d'état vide) s'affiche.
    • Calculé - Lecture seule
Une valeur sera calculée et affichée par le biais d'un script. L'utilisateur n'a pas la possibilité de modifier la valeur calculée.
    • Calculé - L'utilisateur peut remplacer
Une valeur sera calculée et affichée par le biais d'un script. L'utilisateur peut changer la valeur si le script de calcul accepte les saisies. Si l'utilisateur change la valeur, le message personnalisé que vous avez défini dans la zone Message de remplacement s'affiche.
    • Lecture seule
Une valeur sera fusionnée ou calculée et affichée à l'exécution. Les utilisateurs ne peuvent pas modifier la valeur.
Valeur par défaut
Définit une valeur par défaut.
cette option s'affiche uniquement lorsque l'option Type est définie sur Entré par l'utilisateur - Obligatoire, Entré par l'utilisateur - Recommandé ou Lecture seule.
Message d'état vide
Définit le message demandant aux utilisateurs d'entrer une valeur recommandée ou obligatoire. Voir Pour inviter les utilisateurs à entrer des données.
Cette option est disponible seulement lorsque l'option Type est définie sur Entré par l'utilisateur - Recommandé ou Entré par l'utilisateur - Obligatoire.
Modèle de validation
Définit le modèle qui valide la valeur entrée par l'utilisateur. Le modèle doit correspondre à la syntaxe de la valeur saisie par l'utilisateur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule.
Message du modèle de validation et Erreur
Définit un message personnalisé qui s'affiche lorsque la valeur brute ne correspond pas au modèle de validation. Par défaut, cette situation génère une erreur de programmation à l'exécution. Pour afficher plutôt un message d'avertissement, désélectionnez l'option Erreur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule. La propriété Message du modèle de validation est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique un message de modèle de validation.
Message du script de validation et Erreur
Définit un message personnalisé qui s'affiche lorsque le script de validation détecte une valeur inacceptable. Par défaut, cette situation génère une erreur de programmation à l'exécution. Pour afficher plutôt un message d'avertissement, désélectionnez l'option Erreur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule. La propriété Message du script de validation est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique un message de script de validation.
Message de remplacement
Définit un message personnalisé pour informer l'utilisateur qu'il change la valeur d'un champ calculé. Le message s'affiche lorsqu'un utilisateur modifie la valeur calculée.
cette option est disponible uniquement lorsque l'option Type est définie sur Calculé - L'utilisateur peut remplacer.
Voir aussi
Aperçu des listes déroulantes et des zones de liste


Propriétés des zones de liste dans le panneau Liaison

Lorsque vous créez une zone de liste, le panneau Liaison propose différentes options que vous pouvez appliquer à l'objet. Les options qui ne sont pas directement liées à la création d'une connexion de données s'appliquent aux données liées à une source de données et aux données enregistrées dans un fichier lorsque l'objet est lié à la source de données.
Nom
Définit le nom de la liste. Voir Pour donner un nom aux objets ou changer leur nom.
Liaison par défaut
Définit la méthode de liaison de données par défaut :
    • Normale
Active les options de fusion et d'enregistrement. Les données sont fusionnées et enregistrées implicitement conformément aux règles de fusion d'Adobe.
    • Globale
Associe une valeur unique à tous les objets qui portent le même nom (voir Pour définir un champ global).
    • Nouvelle connexion aux données
Démarre l'assistant Nouvelle connexion aux données. Pour définir une connexion à l'aide de l'assistant, voir Pour établir une connexion à un schéma XML et à un fichier de données XML ou Pour établir une connexion à une base de données OLE.
    • Non
Désactive la liaison de données. Puisque l'objet ne recueille et n'affiche aucune donnée fusionnée, aucune information associée ne s'affiche dans la sortie lorsque le formulaire est enregistré/envoyé.
Spécifier les valeurs
Permet de spécifier les valeurs de données personnalisées pour chaque élément de la liste. Si cette option n'est pas sélectionnée, les valeurs des données correspondent au texte des éléments de la liste. Si elle est sélectionnée, les valeurs par défaut consistent en des entiers qui se suivent et commencent à 0 pour le premier élément de la liste. Voir Pour spécifier les valeurs des éléments d'une liste déroulante ou d'une zone de liste.
La propriété Spécifier les valeurs est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet.
Monter, Descendre, Tri croissant, Tri décroissant
Réorganise les éléments dans la liste (par exemple, lorsque les données doivent être stockées dans un ordre différent de l'ordre d'affichage des options de la liste déroulante). Vous pouvez faire monter ou descendre des éléments dans la liste, ou les trier par ordre croissant ou décroissant à l'aide des boutons disponibles à côté du libellé.
Importation/exportation
Définit une liaison d'importation/exportation pour une connexion de données WSDL. Voir Pour établir une connexion à un fichier WSDL.
Voir aussi
A propos des sources de données
Aperçu des listes déroulantes et des zones de liste


Champs numériques

Propriétés des champs numériques dans le panneau Champ
Propriétés des champs numériques dans le panneau Valeur
Propriétés des champs numériques dans le panneau Liaison
Formats numériques
Exemples de formats numériques


Propriétés des champs numériques dans le panneau Champ

Lorsque vous sélectionnez un champ numérique, le panneau Champ de la palette Objet affiche les options propres au formatage de l'objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Légende
Définit la légende de l'objet.
La propriété Légende est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique une légende.
Aspect
Définit le style de la bordure du champ :
    • Non
N'affiche pas de bordure autour du champ.
    • Souligné
Souligne le champ.
    • Case pleine
Affiche une bordure pleine autour du champ
    • Case enfoncée
Crée une ombre autour du champ pour lui donner un aspect tridimensionnel.
    • Personnaliser
Ouvre la boîte de dialogue Aspect personnalisé. Sélectionnez cette option si vous voulez personnaliser la zone remplissable de l'objet.
Limiter la longueur à la zone visible
Définit le nombre maximal de chiffres autorisés dans le champ en fonction de la longueur horizontale du champ de texte.
Utiliser les cellules
Active le format de peigne.
Format d'affichage
Définit le format d'affichage des valeurs formatées dans le formulaire. Voir Pour définir un format d'affichage.
lors de la conception et de l'exécution, les valeurs formatées dans le champ sont tributaires du format du paramètre régional.
Format de saisie
Définit le format de syntaxe des valeurs entrées par l'utilisateur. Si l'entrée de l'utilisateur n'est pas conforme au format de saisie, les données sont refusées et la mise en forme des valeurs de champ n'est pas effectuée. Voir Pour définir un format de saisie.
Lors de la conception et de l'exécution, les valeurs formatées dans la zone d'affichage sont tributaires du format du paramètre régional.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
Aperçu des champs numériques
Aperçu des champs de valeurs décimales et numériques


Propriétés des champs numériques dans le panneau Valeur

Lorsque vous créez un champ numérique, le panneau Valeur propose différentes options que vous pouvez appliquer à l'objet.
Type
Permet les calculs à l'exécution et l'affichage d'invites :
    • Entré par l'utilisateur - Facultatif
L'utilisateur peut choisir d'entrer des données ou non.
    • Entré par l'utilisateur - Recommandé
Si l'utilisateur n'entre pas de données, un message personnalisé (s'il est défini dans la zone Message d'état vide) s'affiche.
    • Entré par l'utilisateur - Obligatoire
Si l'utilisateur n'entre pas de données, un message personnalisé (s'il est défini dans la zone Message d'état vide) s'affiche.
    • Calculé - Lecture seule
Une valeur sera calculée et affichée par le biais d'un script. L'utilisateur n'a pas la possibilité de modifier la valeur calculée.
    • Calculé - L'utilisateur peut remplacer
Une valeur sera calculée et affichée par le biais d'un script. L'utilisateur peut changer la valeur si le script de calcul accepte les saisies. Si l'utilisateur change la valeur, le message personnalisé que vous avez défini dans la zone Message de remplacement s'affiche.
    • Lecture seule
Une valeur sera fusionnée ou calculée et affichée à l'exécution. Les utilisateurs ne peuvent pas modifier la valeur.
Valeur par défaut
Définit la valeur initiale du champ. La valeur est mise en forme selon le paramètre de l'option Format d'affichage du panneau Champ, mais elle doit se conformer à la valeur en fonction du paramètre régional spécifié dans le champ. si les données sont liées et qu'un modèle a été spécifié, la valeur doit correspondre au modèle de données défini dans le panneau Liaison. Voir Pour définir une valeur par défaut.
cette option s'affiche uniquement lorsque l'option Type est définie sur Entré par l'utilisateur - Obligatoire, Entré par l'utilisateur - Recommandé ou Lecture seule.
Message d'état vide
Définit le message demandant aux utilisateurs d'entrer une valeur recommandée ou obligatoire. Voir Pour inviter les utilisateurs à entrer des données.
Cette option est disponible seulement lorsque l'option Type est définie sur Entré par l'utilisateur - Recommandé ou Entré par l'utilisateur - Obligatoire.
Modèle de validation
Définit le modèle qui valide la valeur entrée par l'utilisateur. Le modèle doit correspondre à la syntaxe de la valeur saisie par l'utilisateur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule.
Message du modèle de validation et Erreur
Définit un message personnalisé qui s'affiche lorsque la valeur brute ne correspond pas au modèle de validation. Par défaut, cette situation génère une erreur de programmation à l'exécution. Pour afficher plutôt un message d'avertissement, désélectionnez l'option Erreur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule. La propriété Message du modèle de validation est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique un message de modèle de validation.
Message du script de validation et Erreur
Définit un message personnalisé qui s'affiche lorsque le script de validation détecte une valeur inacceptable. Par défaut, cette situation génère une erreur de programmation à l'exécution. Pour afficher plutôt un message d'avertissement, désélectionnez l'option Erreur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule. La propriété Message du script de validation est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique un message de script de validation.
Script de calcul
La valeur est calculée par le script écrit pour l’événement calculate de l’objet.
cette option est disponible uniquement lorsque l'option Type est définie sur Calculé - Lecture seule.
Propriété de l'exécution
Définit l'une des propriétés d'exécution ci-dessous pour l'objet. Lorsque vous sélectionnez une propriété d'exécution, la valeur réelle correspondant à l'option est insérée dynamiquement dans le rendu du formulaire.
    • numéro de la page active
Affiche le numéro de la page active dans le champ numérique.
    • nombre de pages
Insère le nombre total de pages dont le formulaire est constitué.
    • Numéro de feuille actuel
Insère le numéro de la feuille de papier actuelle dans le champ numérique.
    • Nombre de feuilles
Insère le nombre de feuilles de papier qui constituent le formulaire.
cette option est disponible uniquement lorsque l'option Type est définie sur Calculé - Lecture seule.
Message de remplacement
Définit un message personnalisé pour informer l'utilisateur qu'il change la valeur d'un champ calculé. Le message s'affiche lorsqu'un utilisateur modifie la valeur calculée.
cette option est disponible uniquement lorsque l'option Type est définie sur Calculé - L'utilisateur peut remplacer.
Voir aussi
Aperçu des champs numériques
Aperçu des champs de valeurs décimales et numériques


Propriétés des champs numériques dans le panneau Liaison

Lorsque vous créez un champ numérique, le panneau Liaison propose différentes options que vous pouvez appliquer à l'objet. Les options qui ne sont pas directement liées à la création d'une connexion de données s'appliquent aux données liées à une source de données et aux données enregistrées dans un fichier lorsque l'objet est lié à la source de données.
Nom
Définit le nom du champ numérique. Voir Pour donner un nom aux objets ou changer leur nom.
Liaison par défaut
Définit la méthode de liaison de données par défaut :
    • Normale
Active les options de fusion et d'enregistrement. Les données sont fusionnées et enregistrées implicitement conformément aux règles de fusion d'Adobe.
    • Globale
Associe une valeur unique à tous les objets qui portent le même nom (voir Pour définir un champ global).
    • Nouvelle connexion aux données
Démarre l'assistant Nouvelle connexion aux données. Pour définir une connexion à l'aide de l'assistant, voir Pour établir une connexion à un schéma XML et à un fichier de données XML ou Pour établir une connexion à une base de données OLE.
    • Non
Désactive la liaison de données. Puisque l'objet ne recueille et n'affiche aucune donnée fusionnée, aucune information associée ne s'affiche dans la sortie lorsque le formulaire est enregistré/envoyé.
Modèle de données
Définit un modèle pour le stockage et l'extraction des données liées ou pour enregistrer les données lorsque le formulaire n'est pas lié à une source de données. Voir Pour spécifier un modèle de données.
Format des données
Définit le format des données. Voir Pour spécifier un modèle de données:
    • Flottant
Représentation en trois parties d'un nombre contenant une base. Le nombre comporte les parties suivantes : un signe, un nombre et une base. Exemples de nombres en virgule flottante : 4,23423412, 1234,1234234 ou 4,00. Notez que dans certaines langues, la base n'est pas une virgule décimale. Par exemple, la base est une virgule (1234,1234) en allemand (Allemagne).
    • Entier
Toute séquence de chiffres de 0 à 9 précédés d'un signe moins. Par exemple, le nombre peut être positif (par exemple 1, 2 ou 3), un zéro ou un nombre entier négatif (-1, -2 ou -3).
Importation/exportation
Définit une liaison d'importation/exportation pour une connexion de données WSDL. Voir Pour établir une connexion à un fichier WSDL.
Voir aussi
A propos des sources de données
Aperçu des champs numériques
Aperçu des champs de valeurs décimales et numériques


Formats numériques

Des symboles précis doivent être utilisés pour créer les formats des champs numériques. Vous pouvez également utiliser ces symboles afin de créer des formats numériques pour les champs décimaux.
Le tiret (-), le deux-points (:), la barre oblique (/) et l'espace ( ) sont considérés comme des valeurs littérales qui peuvent être incluses n'importe où dans le format. Pour inclure du texte dans un format, délimitez la chaîne de texte par des guillemets simples ('). Par exemple, 'Your balance is' z,zz9.99 peut être spécifié comme format d'affichage.
Utilisez ces symboles pour créer des formats. Le format détermine le format utilisé pour entrer des données ou les mettre en forme. Les résultats formatés dans la colonne Exemple sont délimités par des guillemets doubles de sorte que vous puissiez voir où se trouvent les espaces. Les guillemets ne font pas partie du résultat. Dans ces exemples, le paramètre régional est Anglais (Etats-Unis).

Symbole numérique

Description

Exemple

8
Single digit or the zero digit if the input is a zero digit or empty. When following the decimal radix, indicates the same number of digits as contained in the data value, up to the maximum number of digits indicated by the pattern.
The 8 symbol is used in decimal fields.
Display Pattern: zzz,zz9.888
Input Value: 123456.1236 or 1234
Formatted Value: “123,456.124” or “1,234”

9
Chiffre unique ou zéro si aucune information n'est saisie. Placé après la base décimale, il contient le même nombre de chiffres que la valeur.
Format d'affichage : zzz,zz9.999
Valeur d'entrée : 123456,1236 ou 1234
Valeur formatée : « 123 456,124 » ou « 1 234,000 »

z
Chiffre unique ou aucun résultat si l'information saisie est un zéro de début, ou aucun résultat si aucune information n'est saisie
Format d'affichage : $zzz9
Valeur d'entrée : 123
Valeur formatée : « $123 »

Z
Chiffre unique ou espace si l'information saisie est un zéro de début, ou un espace si aucune information n'est saisie
Format d'affichage : $ZZZ9
Valeur d'entrée : 123
Valeur formatée : « $ 123 »

s
Signe moins (-) lorsque le nombre est négatif (si le nombre est positif, aucun symbole n'est nécessaire).
Format d'affichage : $szzz9
Valeur d'entrée : 123 ou -123
Valeur formatée : « $123 » ou « $-123 »

S
Signe moins (-) lorsque le nombre est négatif ou espace lorsque le nombre est positif.
Format d'affichage : $Szzz9
Valeur d'entrée : 123 ou -123
Valeur formatée : « $ 123 » ou « $-123 »

E
Symbole de l'exposant (E+3 signifie que l'exposant est 3 et E-2 signifie que l'exposant est -2).
Le symbole de l’exposant (E) ne peut être utilisé qu’après les chiffres 9, z ou Z.
Format d'affichage : 99.999E
Valeur d'entrée : 12345 ou 0,12345
Valeur formatée : « 12,345E+3 » ou « 12,345E-2 »

$
Le symbole monétaire, c'est-à-dire celui qui correspond au paramètre actuel de la locale de l'objet.
Format d'affichage : $zzz9
Valeur d'entrée : 123
Valeur formatée : « $123 »
cr
Symbole du crédit (CR) lorsque le nombre est négatif (si le nombre est positif, aucun symbole n'est nécessaire).
Format d'affichage : cr$zzz9
Valeur d'entrée : 123 ou -123
Valeur formatée : « $123 » ou « CR$123 »

CR
Symbole du crédit (CR) lorsque le nombre est négatif ou espaces lorsque le nombre est positif.
Format d'affichage : CR$zzz9
Valeur d'entrée : 123 ou -123
Valeur formatée : « $123 » ou « CR$123 »

db
Symbole du débit (DB) lorsque le nombre est négatif (si le nombre est positif, aucun symbole n'est nécessaire).
Format d'affichage : db$zzz9
Valeur d'entrée : 123 ou -123
Valeur formatée : « $123 » ou « DB$123 »

DB
Symbole du débit (DB) lorsque le nombre est négatif ou espaces lorsque le nombre est positif.
Format d'affichage : DB$zzz9
Valeur d'entrée : 123 ou -123
Valeur formatée : « $123 » ou « DB$123 »

( )
Parenthèses gauche et droite indiquant un nombre négatif. Si le nombre est positif, les parenthèses sont remplacées par des espaces.
les parenthèses gauche et droite peuvent délimiter un chiffre 8, 9, z ou Z seulement.
Format d'affichage : ($zzz9)
Valeur d'entrée : 123 ou -123
Valeur formatée : « $123 « ou « ($123) »

.
La base décimale, c'est-à-dire celle qui correspond au paramètre actuel de la locale de l'objet.
Format d'affichage : zzz9.99
Valeur d'entrée : 123.45
Valeur formatée pour un paramètre régional Allemand (Allemagne) : « 123,45 »

v
La base décimale implicite, c'est-à-dire celle qui correspond au paramètre actuel de la locale de l'objet (la base décimale est retirée avant l'affichage de la sortie).
Format d'affichage : zzz9v99
Valeur d'entrée : 123.45
Valeur formatée : « 12345 »

,
Le symbole de regroupement des chiffres, c'est-à-dire celui qui correspond au paramètre actuel de la locale de l'objet.
Format d'affichage : z,zz9.99
Valeur d'entrée : 1234.56
Valeur formatée pour un paramètre régional Allemand (Allemagne) : « 1.234,56 »

%
Symbole de pourcentage, c'est-à-dire celui qui correspond au paramètre actuel du paramètre régional de l'objet.
Format d'affichage : z9.99%
Valeur d'entrée : 0.123
Valeur formatée : « 12.30% »
Symboles réservés
Les symboles qui suivent ont une signification particulière et ne peuvent pas être utilisés comme texte littéral.
?
Lorsqu'il est utilisé, ce symbole représente n'importe quel caractère. Lorsqu'il est fusionné pour l'affichage, il devient un espace.

*
Lorsqu'il est utilisé, ce symbole représente 0 ou le caractère d'espace Unicode. Lorsqu'il est fusionné pour l'affichage, il devient un espace.

+
Lorsqu'il est utilisé, ce symbole représente un ou plusieurs caractères d'espace Unicode. Lorsqu'il est fusionné pour l'affichage, il devient un espace.
Voir aussi
A propos des formats et des valeurs de format
Pour spécifier un modèle de données
Pour définir un format de saisie
Exemples de formats numériques


Exemples de formats numériques

Le tableau suivant présente des exemples de formats d'affichage ainsi que les résultats obtenus lorsque vous les appliquez à des valeurs (saisies par l'utilisateur ou données liées). Les résultats formatés sont délimités par des guillemets doubles de sorte que vous puissiez voir où se trouvent les espaces. Les guillemets ne font pas partie du résultat. Dans ces exemples, le paramètre régional est Anglais (Etats-Unis).
.

Format

Valeur d'entrée

Valeur formatée
zzz,zz9.888
The 8 symbol is used in decimal fields.
123456.1236
12345.6
1234
“123,456.124”
“12,345.6”
“1234”
zzz,zz9.99
123456.1236
123456.4
123456
« 123,456.12 »
« 123,456.40 »
« 123,456.00 »
$Z,ZZ9.99
123.4
« 123.40 »
$z,zz9.99CR
1234
-1234
« $1,234.00 »
« $1,234.00CR »
$Z,ZZ9.99DB
123
-123
« $ 123.00 »
« $ 123.00DB »
($z,zz9.99)
1234
-1234
« $1,234.56 «
« ($1,234.00) »
zzz9
12.0
« 12 »
Szzz,zz9.99
1234.56
-1234.56
« 1,234.56 »
« -1,234.56 »
$9,999.99
123.4
« $0,123.40 »
$Z,999.99
123.4
« $ 123.40 »
99999
1234
« 01234 »
S999V99
-1.23
« -00123 »
S999V99
-1.23
123
« -001.23 »
« 123.00 »
SZZ9.99
12.3
-12.3
« 12.30 »
« - 12.30 »
szz9.99
12.3
-12.3
« 12.3 »
« -12.3 »
99.999E
12345
0.12345
« 12.345E+3 »
« 12.345E-2 »
Le tableau qui suit illustre le résultat de la conversion de certaines valeurs (saisies par un utilisateur ou provenant de données liées) en valeurs brutes au moyen d'un format de saisie ou d'un modèle de données.

Format personnalisé

Valeur d'entrée

Valeur brute
99V99
1050
3125
10.50
31.25
99.999E
12.345E3
12.345E-2
12345
0.12345
z999
150
0150
150
150
z,zz9.99
10.50
3,125.00
10.50
3125.00
$z,zz9.99DB
$1,234.00
$1,234.00DB
1234.00
-1234.00


Codes à barres de formulaires pour support papier

Propriétés des codes à barres de formulaires pour support papier dans le panneau Champ
Propriétés des codes à barres de formulaires pour support papier dans le panneau Valeur


Précédent Suivant

Utilisation de LiveCycle Designer > Propriétés de l'objet > Propriétés de la palette Objet > Codes à barres de formulaires pour support papier > Propriétés des codes à barres de formulaires pour support papier dans le panneau Champ

Propriétés des codes à barres de formulaires pour support papier dans le panneau Champ

Lorsque vous sélectionnez un objet de code à barres de formulaires pour support papier sur la conception de formulaire, le panneau Champ de la palette Objet affiche les options spécifiques au formatage de cet objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Libellé
Libellé personnalisé ou généré automatiquement qui apparaît sous le code à barres. Utile pour distinguer les codes à barres dans des versions distinctes des formulaires à codes à barres.
Générer le libellé automatiquement
Lorsque cette option est sélectionnée, le libellé du code à barres est généré automatiquement. Ne la sélectionnez pas pour préciser un libellé personnalisé.
Symbologie
Détermine la symbologie du code à barres :
      •
      PDF417
      •
      Code QR
      •
      Grille de données
les utilisateurs finaux qui remplissent un formulaire contenant un code à barres QR Code ou DataMatrix doivent posséder Acrobat 7.0.5 ou version ultérieure, ou Adobe Reader 7.0.5 ou version ultérieure. Le décodage des codes à barres QR Code et DataMatrix est pris en charge par Adobe LiveCycle Barcoded Forms 7.0, mais ne l'est pas par Adobe LiveCycle Barcoded Forms 7.0 Standalone (ST).
Méthode de numérisation
Indique les conditions de décodage des informations contenues dans le code à barres de formulaires pour support papier une fois le code imprimé sur un formulaire. La condition de décodage détermine la taille des cellules de données horizontales et verticales ainsi que le niveau de correction des erreurs du code à barres. LiveCycle Designer contient les options prédéfinies et personnalisées suivantes :
    • Scanner de document (par défaut)
Cette option définit automatiquement les propriétés Niveau de correction de l'erreur, Largeur/hauteur du module et Largeur du module sur des valeurs appropriées lors de la numérisation d'un code à barres de formulaires pour support papier à l'aide d'un scanner de 300 ppp.
LiveCycle Designer spécifie les valeurs suivantes :
      •
      Niveau de correction de l'erreur : 5
      •
      Largeur/hauteur du module : 2 (PDF417), 1 (Code QR et Grille de données)
      •
      Largeur du module : 0,3378 mm
    • Scanner à main
Cette option définit automatiquement les propriétés Niveau de correction de l'erreur, Largeur/hauteur du module et Largeur du module sur des valeurs appropriées lors de la numérisation d'un code à barres de formulaires pour support papier à l'aide d'un scanner à main.
LiveCycle Designer spécifie les valeurs suivantes :
      •
      Niveau de correction de l'erreur : 5
      •
      Largeur/hauteur du module : 3 (PDF417), 1 (Code QR et Grille de données)
      •
      Largeur du module : 0,3378 mm
    • Serveur de télécopies
Cette option définit automatiquement les propriétés Niveau de correction de l'erreur, Largeur/hauteur du module et Largeur du module sur des valeurs appropriées lors de la numérisation d'un code à barres de formulaires pour support papier qui a été imprimé sur un formulaire reçu par télécopie.
LiveCycle Designer spécifie les valeurs suivantes :
      •
      Niveau de correction de l'erreur : 6
      •
      Largeur/hauteur du module : 2 (PDF417), 1 (Code QR et Grille de données)
      •
      Largeur du module : 0,3378 mm
    • Personnaliser
Cette option active la liste Propriété/Valeur et vous permet de configurer les propriétés des paramètres Niveau de correction de l'erreur, Largeur/hauteur du module et Largeur du module sur des valeurs comprises dans les plages suivantes :
      •
      Niveau de correction de l'erreur : 1 - 8
      •
      Largeur/hauteur du module : 1 - 4 (nombres entiers pour PDF417), 1 (Code QR et Grille de données)
      •
      Largeur du module : 0,0133 à 0,04 pouce
Si vous sélectionnez Personnaliser, la liste Propriété reste activée, quelles que soient les valeurs définies pour les propriétés Niveau de correction de l'erreur, Largeur/hauteur du module et Largeur du module et ce, même si elles sont identiques à celles d'une condition prédéfinie.
le paramètre Niveau de correction de l'erreur est désactivé pour les codes à barres Grille de données.
Propriété/Valeur
Lorsque l'option Personnaliser est sélectionnée, vous devez définir les valeurs des propriétés de niveau de correction de l'erreur, du rapport hauteur/largeur du module et de la largeur du module :
    • Niveau de correction de l'erreur
Indique le niveau de redondance des données ajouté au code à barres afin de faciliter la correction des éventuelles erreurs de numérisation. La plage des niveaux acceptables correspond aux valeurs comprises entre 1 et 8. Un niveau élevé admet davantage de redondance et un code à barres plus puissant. Il implique également un code à barres plus grand. Un code à barres plus puissant permet de récupérer des données en cas d'erreurs, notamment des indications au stylo ou des plis dans le document, en incluant des informations redondantes dans le code. LiveCycle Designer définit automatiquement un niveau de correction de l'erreur d'après le type de périphérique de numérisation choisi.
Un niveau de correction de l'erreur de 5 permet généralement d'obtenir des performances satisfaisantes tout en laissant au code à barres une taille raisonnable. Il est recommandé de conserver un niveau de correction de l'erreur supérieur à 5, à moins que vous ne maîtrisiez parfaitement la technologie de décodage des codes à barres.
le paramètre Niveau de correction de l'erreur est désactivé pour les codes à barres Grille de données.
    • Largeur/hauteur du module
Définit la hauteur du code à barres comme le rapport de la hauteur du module sur la largeur. La plage des niveaux acceptables correspond aux nombres entiers compris entre 1 et 4 (PDF417), 1 (Code QR et Grille de données).
    • Largeur du module
Définit la largeur de la plus petite barre du code. Une barre sur deux du code à barres sera un multiple de cette valeur. La plage de niveaux acceptables correspond aux valeurs comprises entre 0,133 et 0,04 pouce.
La valeur de la largeur du module est arrondie au 1/300 de pouce le plus proche lorsque le code à barres est généré dans Acrobat ou Adobe Reader. Vous devez maîtriser la technologie de décodage des codes à barres pour sélectionner correctement la valeur de largeur du module.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Voir aussi
Aperçu des codes à barres de formulaires pour support papier


Précédent Suivant

Utilisation de LiveCycle Designer > Propriétés de l'objet > Propriétés de la palette Objet > Codes à barres de formulaires pour support papier > Propriétés des codes à barres de formulaires pour support papier dans le panneau Valeur

Propriétés des codes à barres de formulaires pour support papier dans le panneau Valeur

Lorsque vous sélectionnez un code à barres de formulaires pour support papier sur la conception de formulaire, le panneau Valeur de la palette Objet présente les options propres au formatage de cet objet.
Compresser les données avant le codage
Indique si les données sont compressées avant leur codage par l'objet de code à barres de formulaires pour support papier. Par défaut, ce paramètre de compression est désactivé.
La compression de données fait appel à la méthode Flate. Lorsque cette case est cochée, la compression est appliquée dans Acrobat ou Adobe Reader au moment du traçage du code à barres.
Les données compressées nécessitent moins d'espace de stockage dans le code à barres, augmentant ainsi la quantité de données de formulaire pouvant être placée dans le code à barres.
en général, les données sont compressées jusqu'à leur décodage à l'aide d'un scanner à main ou de votre propre solution de décodage ne comprenant pas de logiciel de décompression. Pour plus de détails sur la compression de données, consultez l'aide d'Acrobat.
Ecriture de script automatique
Indique si les données du code à barres sont obtenues automatiquement ou au moyen d'un script personnalisé.
Format
Précise le format des données de code à barres écrites automatiquement. Une fois l'option sélectionnée, le script associé s'affiche dans l'éditeur de script. Si nécessaire, vous pouvez modifier les scripts prédéfinis. Sélectionnez un format parmi les suivants :
    • XML
La valeur du code à barres est calculée par un script conçu pour coder au format XML les données provenant de tous les champs de formulaire.
    • Délimité par tabulation
La valeur du code à barres est calculée par un script conçu pour coder les données de tous les champs de formulaire au format délimité par tabulation (autrement dit, une représentation ASCII plate des valeurs de champ séparées par un caractère de tabulation). Les options suivantes sont disponibles :
Inclure le nom des champs
Les noms de champs sont séparés par des tabulations et codés sous la forme de la première ligne du contenu du code à barres. Les valeurs sont codées en dessous.
Inclure le libellé
Le libellé est codé (affiché sous le panneau Champ) et constitue le premier champ délimité par une tabulation du contenu du code à barres.
Application
Précise à quoi s'applique le format sélectionné. Faites votre sélection parmi les choix suivants :
    • Intégralité des données du formulaire
Code les données de tous les champs du formulaire selon le format sélectionné.
    • Données de sous-formulaire
Code les données de tous les champs du sous-formulaire dont l'objet de code à barres de formulaires pour support papier est un enfant, selon le format sélectionné.
    • Données de collection
Code les données de tous les champs indiqués dans la collection sélectionnée.
Collection
Précise la collection à utiliser pour coder les données. Faites votre sélection parmi les choix suivants :
    • nom de collection
Nom de la collection que vous avez créée.
    • Créer/Gérer une collection
Crée, supprime, duplique, renomme et modifie des collections dans la liste Collection.
Modifier
Affiche les champs sélectionnés de la collection active. Cette fenêtre vous permet également de modifier les champs de la collection ou de renommer cette dernière.
Voir aussi
Aperçu des codes à barres de formulaires pour support papier
Pour contrôler le codage des données par un code à barres de formulaires pour support papier
Conseils de conception sur l’utilisation d’un code à barres de formulaires pour support papier


Champs de mot de passe

Propriétés des champs de mot de passe dans le panneau Champ
Propriétés des champs de mot de passe dans le panneau Valeur
Propriétés des champs de mot de passe dans le panneau Liaison
Formats de mot de passe
Exemples de formats de mot de passe


Propriétés des champs de mot de passe dans le panneau Champ

Lorsque vous sélectionnez un champ de mot de passe, le panneau Champ de la palette Objet affiche les options propres au formatage de l'objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Légende
Définit la légende de l'objet.
La propriété Légende est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique une légende.
Aspect
Définit le style de la bordure du champ :
    • Non
N'affiche pas de bordure autour du champ.
    • Souligné
Souligne le champ.
    • Case pleine
Affiche une bordure pleine autour du champ
    • Case enfoncée
Crée une ombre autour du champ pour lui donner un aspect tridimensionnel.
    • Personnaliser
Ouvre la boîte de dialogue Aspect personnalisé. Sélectionnez cette option si vous voulez personnaliser la zone remplissable de l'objet.
Caractère d'affichage du mot de passe
Définit le caractère à utiliser pour masquer le mot de passe.
Limiter la longueur à la zone visible
Définit le nombre maximal de caractères autorisés dans le champ en fonction de la longueur horizontale du champ de mot de passe.
Format de saisie
Si la valeur entrée par l'utilisateur risque de ne pas correspondre au format par défaut de LiveCycle Designer, spécifiez la syntaxe que doit respecter la valeur saisie par l'utilisateur. Voir Pour définir un format de saisie.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
Aperçu des champs de mot de passe


Propriétés des champs de mot de passe dans le panneau Valeur

Lorsque vous créez un champ de mot de passe, le panneau Valeur propose différentes options que vous pouvez appliquer à l'objet.
Type
Définit les exigences relatives à la saisie.
    • Entré par l'utilisateur - Facultatif
L'utilisateur peut choisir d'entrer un mot de passe ou non.
    • Entré par l'utilisateur - Recommandé
Si l'utilisateur n'entre pas un mot de passe, un message personnalisé (s'il est défini dans la zone Message d'état vide) est affiché.
    • Entré par l'utilisateur - Obligatoire
Si l'utilisateur n'entre pas un mot de passe, un message personnalisé (s'il est défini dans la zone Message d'état vide) est affiché.
Message d'état vide
Définit le message demandant aux utilisateurs d'entrer une valeur recommandée ou obligatoire. Voir Pour inviter les utilisateurs à entrer des données.
Cette option est disponible seulement lorsque l'option Type est définie sur Entré par l'utilisateur - Recommandé ou Entré par l'utilisateur - Obligatoire.
Modèle de validation
Définit le modèle qui valide la valeur entrée par l'utilisateur. Le modèle doit correspondre à la syntaxe de la valeur saisie par l'utilisateur. Voir Pour valider les données utilisateur.
Message du modèle de validation et Erreur
Définit un message personnalisé qui s'affiche lorsque la valeur brute ne correspond pas au modèle de validation. Par défaut, cette situation génère une erreur de programmation à l'exécution. Pour afficher plutôt un message d'avertissement, désélectionnez l'option Erreur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule. La propriété Message du modèle de validation est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique un message de modèle de validation.
Message du script de validation et Erreur
Définit un message personnalisé qui s'affiche lorsque le script de validation détecte une valeur inacceptable. Par défaut, cette situation génère une erreur de programmation à l'exécution. Pour afficher plutôt un message d'avertissement, désélectionnez l'option Erreur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule. La propriété Message du script de validation est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique un message de script de validation.
Voir aussi
Aperçu des champs de mot de passe


Propriétés des champs de mot de passe dans le panneau Liaison

Lorsque vous créez un champ de mot de passe, le panneau Liaison propose différentes options que vous pouvez appliquer à l'objet. Les options qui ne sont pas directement liées à la création d'une connexion de données s'appliquent aux données liées à une source de données et aux données enregistrées dans un fichier lorsque l'objet est lié à la source de données.
Nom
Définit le nom du champ. Voir Pour donner un nom aux objets ou changer leur nom.
Liaison par défaut
Définit la méthode de liaison de données par défaut :
    • Normale
Active les options de fusion et d'enregistrement. Les données sont fusionnées et enregistrées implicitement conformément aux règles de fusion d'Adobe.
    • Globale
Associe une valeur unique à tous les objets qui portent le même nom (voir Pour définir un champ global).
    • Nouvelle connexion aux données
Démarre l'assistant Nouvelle connexion aux données. Pour définir une connexion à l'aide de l'assistant, voir Pour établir une connexion à un schéma XML et à un fichier de données XML ou Pour établir une connexion à une base de données OLE.
    • Non
Désactive la liaison de données. Puisque l'objet ne recueille et n'affiche aucune donnée fusionnée, aucune information associée ne s'affiche dans la sortie lorsque le formulaire est enregistré/envoyé.
Modèle de données
Définit un modèle pour le stockage et l'extraction des données liées ou pour enregistrer les données lorsque le formulaire n'est pas lié à une source de données. Voir Pour spécifier un modèle de données.
Importation/exportation
Définit une liaison d'importation/exportation pour une connexion de données WSDL. Voir Pour établir une connexion à un fichier WSDL.
Voir aussi
A propos des sources de données
Aperçu des champs de mot de passe


Formats de mot de passe

Si vous le souhaitez, vous pouvez définir des formats de mot de passe. Toutefois, si vous spécifiez un format de mot de passe particulier, les mots de passe risquent d'être plus vulnérables, car les possibilités de combinaison de caractères sont moindres. Pour définir un format de mot de passe, utilisez les symboles suivants.
la virgule (,), le tiret (-), le deux-points (:), la barre oblique (/), le point (.) et l'espace ( ) sont considérés comme des valeurs littérales qui peuvent être incluses n'importe où dans le format.

Symboles de mot de passe

Description

A
Caractère alphabétique simple

X
Caractère simple

O
Caractère alphanumérique simple

0
Caractère alphanumérique simple

9
Chiffre simple
les symboles O (o majuscule) et 0 (zéro) ont été intentionnellement définis comme des synonymes, car ils sont souvent confondus sur le clavier ou à la lecture.
Symboles réservés
Les symboles qui suivent ont une signification particulière et ne peuvent pas être utilisés dans un mot de passe.
?
Lorsqu'il est utilisé, ce symbole représente n'importe quel caractère. Lorsqu'il est fusionné pour l'affichage, il devient un espace.

*
Lorsqu'il est utilisé, ce symbole représente 0 ou le caractère d'espace Unicode. Lorsqu'il est fusionné pour l'affichage, il devient un espace.

+
Lorsqu'il est utilisé, ce symbole représente un ou plusieurs caractères d'espace Unicode. Lorsqu'il est fusionné pour l'affichage, il devient un espace.
Voir aussi
A propos des formats et des valeurs de format
Exemples de formats de mot de passe


Exemples de formats de mot de passe

Le tableau ci-dessous donne des exemples de formats de saisie que vous pouvez définir pour le traitement des mots de passe entrés par les utilisateurs.

Format personnalisé

Valeur d'entrée
AAA999
MAB123
XXX-9
MA2-4
99999
12345
9009AA9
1M23BE4
1m23be4
1MA3BE4


Boutons radio

Propriétés des boutons radio dans le panneau Champ
Propriétés des boutons radio dans le panneau Valeur
Propriétés des boutons radio dans le panneau Liaison


Propriétés des boutons radio dans le panneau Champ

Lorsque vous sélectionnez un bouton radio ou un groupe d'exclusion, le panneau Champ de la palette Objet affiche les options propres au formatage de l'objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Aspect
Définit le style de la bordure du bouton.
Lorsqu'un seul bouton radio est sélectionné, les options disponibles sont les suivantes :
    • Non
N'affiche pas de bordure autour du bouton.
    • Carré 2D
Utilise un carré plein pour représenter le bouton.
    • Carré enfoncé
Crée un carré formé de lignes ombrées autour du bouton pour lui donner un aspect tridimensionnel.
    • Cercle 2D
Utilise un cercle plein pour représenter le bouton.
    • Cercle enfoncé
Crée un cercle formé de lignes ombrées autour du bouton pour lui donner un aspect tridimensionnel.
    • Personnaliser
Ouvre la boîte de dialogue Aspect personnalisé. Sélectionnez cette option si vous voulez personnaliser la zone remplissable de l'objet.
Lorsque le groupe d'exclusion est sélectionné, les options disponibles sont les suivantes :
    • Aucune bordure
N'affiche pas de bordure autour du groupe.
    • Bordure pleine
Crée une ligne épaisse autour du groupe.
    • Bordure surélevée
Crée une ombre autour du groupe pour lui donner un aspect tridimensionnel.
    • Personnaliser
Ouvre la boîte de dialogue Aspect personnalisé. Sélectionnez cette option pour personnaliser l'aspect du groupe.
Format
Définit la taille du bouton radio.
Type de marque
Définit le style du bouton radio :
    • Valeur par défaut
Représente la marque de sélection par un cercle plein.
    • Coche
Représente la marque de sélection par une coche.
    • Cercle
Représente la marque de sélection par un cercle.
    • Croix
Représente la marque de sélection par une croix.
    • Losange
Représente la marque de sélection par un losange.
    • Carré
Représente la marque de sélection par un carré.
    • Etoile
Représente la marque de sélection par une étoile.
Elément
Répertorie tous les boutons radio du groupe d'exclusion actuel. Vous pouvez cliquer deux fois sur le nom d'un bouton radio pour modifier sa légende.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
Aperçu des boutons radio


Propriétés des boutons radio dans le panneau Valeur

Lorsque vous créez un groupe d'exclusion de boutons radio, le champ Valeur propose différentes options que vous pouvez appliquer au groupe.
Type
Permet les calculs à l'exécution et l'affichage d'invites :
    • Entré par l'utilisateur - Facultatif
L'utilisateur peut choisir d'entrer des données ou non.
    • Entré par l'utilisateur - Recommandé
Si l'utilisateur n'entre pas de données, un message personnalisé (s'il est défini dans la zone Message d'état vide) s'affiche.
    • Entré par l'utilisateur - Obligatoire
Si l'utilisateur n'entre pas de données, un message personnalisé (s'il est défini dans la zone Message d'état vide) s'affiche.
    • Calculé - Lecture seule
Une valeur sera calculée et affichée par le biais d'un script. L'utilisateur n'a pas la possibilité de modifier la valeur calculée.
    • Calculé - L'utilisateur peut remplacer
Une valeur sera calculée et affichée par le biais d'un script. L'utilisateur peut changer la valeur si le script de calcul accepte les saisies. Si l'utilisateur change la valeur, le message personnalisé que vous avez défini dans la zone Message de remplacement s'affiche.
    • Lecture seule
Une valeur sera fusionnée ou calculée et affichée à l'exécution. Les utilisateurs ne peuvent pas modifier la valeur.
Valeur par défaut
Définit une valeur par défaut.
cette option s'affiche uniquement lorsque l'option Type est définie sur Entré par l'utilisateur - Obligatoire, Entré par l'utilisateur - Recommandé ou Lecture seule.
Message d'état vide
Définit le message demandant aux utilisateurs d'entrer une valeur recommandée ou obligatoire. Voir Pour inviter les utilisateurs à entrer des données.
Cette option est disponible seulement lorsque l'option Type est définie sur Entré par l'utilisateur - Recommandé ou Entré par l'utilisateur - Obligatoire.
Message du script de validation et Erreur
Définit un message personnalisé qui s'affiche lorsque le script de validation détecte une valeur inacceptable. Par défaut, cette situation génère une erreur de programmation à l'exécution. Pour afficher plutôt un message d'avertissement, désélectionnez l'option Erreur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule. La propriété Message du script de validation est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique un message de script de validation.
Message de remplacement
Définit un message personnalisé pour informer l'utilisateur qu'il change la valeur d'un champ calculé. Le message s'affiche lorsqu'un utilisateur modifie la valeur calculée.
cette option est disponible uniquement lorsque l'option Type est définie sur Calculé - L'utilisateur peut remplacer.
Voir aussi
Aperçu des boutons radio


Propriétés des boutons radio dans le panneau Liaison

Lorsque vous créez un groupe d'exclusion de boutons radio, le panneau Liaison propose différentes options que vous pouvez appliquer au groupe. Les options qui ne sont pas directement liées à la création d'une connexion de données s'appliquent aux données liées à une source de données et aux données enregistrées dans un fichier lorsque l'objet est lié à la source de données.
Nom
Définit le nom du groupe d'exclusion.
Liaison par défaut
Définit la méthode de liaison de données par défaut :
    • Normale
Active les options de fusion et d'enregistrement. Les données sont fusionnées et enregistrées implicitement conformément aux règles de fusion d'Adobe.
    • Globale
Associe une valeur unique à tous les objets qui portent le même nom (voir Pour définir un champ global).
    • Nouvelle connexion aux données
Démarre l'assistant Nouvelle connexion aux données. Pour définir une connexion à l'aide de l'assistant, voir Pour établir une connexion à un schéma XML et à un fichier de données XML ou Pour établir une connexion à une base de données OLE.
    • Non
Désactive la liaison de données. Puisque l'objet ne recueille et n'affiche aucune donnée fusionnée, aucune information associée ne s'affiche dans la sortie lorsque le formulaire est enregistré/envoyé.
Spécifier les valeurs
Permet de spécifier les valeurs personnalisées de l'état Activé de chaque bouton radio du groupe d'exclusion. La valeur de chacun des boutons radio du groupe doit être unique par rapport aux valeurs des autres boutons du groupe.
Si l'option Spécifier les valeurs n'est pas sélectionnée, les valeurs de l'état Activé correspondent à la légende du bouton radio. Si cette option est sélectionnée, les valeurs par défaut consistent en des entiers qui se suivent et commencent à 1 pour le premier bouton radio du groupe. Voir Pour attribuer des valeurs à l'état Activé aux boutons radio.
Importation/exportation
Définit une liaison d'importation/exportation pour une connexion de données WSDL. Voir Pour établir une connexion à un fichier WSDL.
Voir aussi
A propos des sources de données
Aperçu des boutons radio


Précédent Suivant

Utilisation de LiveCycle Designer > Propriétés de l'objet > Propriétés de la palette Objet > Rectangles

Rectangles

Propriétés des rectangles dans le panneau Dessin


Propriétés des rectangles dans le panneau Dessin

Lorsque vous créez un rectangle, le panneau Dessin de la palette Objet affiche les options propres au formatage de cet objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Style de trait
Définit le style et l'épaisseur de la ligne.
Sélecteur de couleurs
Définit la couleur de la ligne.
Coins
Définit le style de coin.
Rayon
Définit le rayon des coins rentrés.
Fond
Définit le style du fond.
Sélecteur de couleurs
Définit les couleurs du fond.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Voir aussi
Aperçu des cercles, des lignes et des rectangles


Sous-formulaires

Propriétés de l'objet Sous-formulaire dans l’onglet Sous-formulaire
Propriétés du sous-formulaire dans le panneau Pagination
Propriétés des sous-formulaires dans le panneau Liaison


Propriétés de l'objet Sous-formulaire dans l’onglet Sous-formulaire

Lorsque vous sélectionnez un sous-formulaire, le panneau Sous-formulaire de la palette Objet affiche diverses options de formatage.
Contenu
Définit le contenu (positionné ou avec enchaînement) du sous-formulaire.
    • Positionné
Positionne les objets dans le sous-formulaire selon leurs coordonnées X et Y.
    • Distribué
Place les objets dans le sous-formulaire pendant le processus de fusion des données de façon à éviter toute superposition d'objets.
Enchaînement
Définit la direction de l'enchaînement des objets :
    • Haut vers le bas
Dispose les objets les uns au-dessous des autres.
    • Texte occidental
Dispose les objets de gauche à droite et, lorsqu'ils atteignent l'extrémité droite du sous-formulaire, continue de les disposer les uns au-dessous des autres, de gauche à droite.
Cette option est affichée en grisé sauf si vous avez sélectionné l'option Distribué dans la liste Contenu.
Autoriser des sauts de page
Active ou désactive les sauts de page au milieu d'un sous-formulaire.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
Aperçu des sous-formulaires
Pour définir un sous-formulaire qui s'étend sur plusieurs pages


Propriétés du sous-formulaire dans le panneau Pagination

Lorsque vous sélectionnez un sous-formulaire, le panneau Pagination de la palette Objet affiche diverses options de pagination.
Placer
Détermine l'emplacement du sous-formulaire.
    • Suivant le précédent
Place le sous-formulaire après l'objet précédent du sous-formulaire parent.
    • Dans Zone de contenu > [nom_de_la_zone_de_contenu]
Place le sous-formulaire dans la zone de contenu indiquée.
    • Haut de la zone de contenu suivante
Place le sous-formulaire en haut de la zone de contenu suivante.
    • Haut de la zone de contenu > [nom_de_la_zone_de_contenu]
Place le sous-formulaire en haut de la zone de contenu indiquée.
    • A la page > [nom_de_la_page]
Place le sous-formulaire sur la page indiquée (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Haut de la page suivante
Place le sous-formulaire en haut de la page suivante (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Haut de la page > [nom_de_la_page]
Place le sous-formulaire en haut de la page chaque fois que la page indiquée est générée (inclut un saut de page s'il n'est pas inséré automatiquement).
Conserver avec - Précédent
Maintient le sous-formulaire dans la même zone de contenu que le sous-formulaire précédent.
Conserver avec - Suivant
Maintient le sous-formulaire dans la même zone de contenu que le sous-formulaire suivant.
Après
Détermine la zone à remplir une fois le sous-formulaire placé.
    • Continuer à remplir le parent
Continue de fusionner les données de tous les objets qu'il reste à remplir dans le //sous-formulaire parent.
    • Aller à la zone de contenu suivante
Commence à remplir la zone de contenu suivante.
    • Aller à la zone de contenu > [nom_de_la_zone_de_contenu]
Commence à remplir la zone de contenu indiquée.
    • Aller à la page suivante
Commence à remplir la page suivante.
    • Aller à la page > [nom_de_la_page]
Commence à remplir la page indiquée.
Sauts conditionnels
Indique le nombre de sauts de page conditionnels définis pour le sous-formulaire.
Débordement
Détermine le mode de débordement si le sous-formulaire s'étend sur plusieurs pages.
    • Non
Commence à remplir la page suivante (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Aller à la zone de contenu > [nom_de_la_zone_de_contenu]
Commence à remplir la zone de contenu indiquée.
    • Aller à la page > [nom_de_la_page]
Commence à remplir la page indiquée.
Début de débordement
Spécifie un début de débordement pour un sous-formulaire qui doit être paginé.
    • [nom_du_sous-formulaire]
Utilise ce sous-formulaire existant comme début de débordement.
    • Non
N'utilise pas de début de débordement lors de la pagination du sous-formulaire.
    • Nouveau
Crée dans LiveCycle Designer un nouveau sous-formulaire et le désigne comme début de débordement lors de la pagination du sous-formulaire.
Fin de débordement
Spécifie une fin de débordement pour un sous-formulaire qui doit être paginé.
    • [nom_du_sous-formulaire]
Utilise ce sous-formulaire existant comme fin de débordement.
    • Non
N'utilise pas de fin de débordement lors de la pagination du sous-formulaire.
    • Nouveau
Crée dans LiveCycle Designer un nouveau sous-formulaire et le désigne comme fin de débordement lors de la pagination du sous-formulaire.
Voir aussi
Aperçu des sous-formulaires
Propriétés de l'objet Sous-formulaire dans l’onglet Sous-formulaire
Propriétés des sous-formulaires dans le panneau Liaison


Propriétés des sous-formulaires dans le panneau Liaison

Lorsque vous sélectionnez un sous-formulaire, le panneau Liaison de la palette Objet affiche diverses options de liaison. Les options qui ne sont pas directement liées à la création d'une connexion de données s'appliquent aux données liées à une source de données et aux données enregistrées dans un fichier lorsque l'objet est lié à la source de données.
Nom
Définit le nom du sous-formulaire. Par défaut, les sous-formulaires ne portent pas de nom. Voir Pour attribuer un nom à un sous-formulaire.
Par défaut
Définit la méthode de liaison de données par défaut.
    • Normale
Active les options de fusion et d'enregistrement. Les données sont fusionnées et enregistrées implicitement conformément aux règles de fusion d'Adobe.
    • Nouvelle connexion aux données
Démarre l'assistant Nouvelle connexion aux données. Pour définir une connexion à l'aide de l'assistant, voir Pour établir une connexion à un schéma XML et à un fichier de données XML ou Pour établir une connexion à une base de données OLE.
    • Non
Désactive la liaison de données. Le sous-formulaire ne sera pas considéré dans les opérations de fusion de données, bien que ses objets (y compris les sous-formulaires imbriqués) puissent tout de même capturer ou afficher des données.
Quantité initiale
Définit le nombre d'occurrences de l'objet actuellement sélectionné à afficher initialement sur le formulaire, indépendamment de la quantité de données de toutes les connexions. La valeur indiquée doit être supérieure ou égale à la valeur Min. de répétitions et inférieure ou égale à la valeur Max.
Voir aussi
A propos des sources de données
Aperçu des sous-formulaires


Jeux de sous-formulaires

Propriétés d'un jeu de sous-formulaires dans l’onglet Jeu de sous-formulaires
Propriétés du jeu de sous-formulaires sous l'onglet Pagination
Propriétés du jeu de sous-formulaires dans le panneau Liaison


Propriétés d'un jeu de sous-formulaires dans l’onglet Jeu de sous-formulaires

Lorsque vous sélectionnez un jeu de sous-formulaires, le panneau Sous-formulaire de la palette Objet affiche diverses options de formatage.
l'option Modifier les variantes est affichée en grisé, à moins que l'option Sélectionner un sous-formulaire parmi les sous-formulaires de remplacement soit sélectionnée dans la liste Type.
Type
Détermine l'ordre de génération des sous-formulaires d'un jeu sur un formulaire.
    • Utiliser tous les sous-formulaires dans l'ordre
Tous les sous-formulaires du jeu sont générés dans l'ordre dans lequel ils apparaissent sur la conception de formulaire.
    • Sélectionner un sous-formulaire parmi les sous-formulaires de remplacement
Un seul des sous-formulaires du jeu est généré, selon des critères spécifiés par l'auteur du formulaire.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
Voir aussi
Aperçu des jeux de sous-formulaires
Propriétés du jeu de sous-formulaires sous l'onglet Pagination
Propriétés du jeu de sous-formulaires dans le panneau Liaison
Boîte de dialogue Modifier les sous-formulaires désignés par les données


Propriétés du jeu de sous-formulaires sous l'onglet Pagination

Lorsque vous sélectionnez un jeu de sous-formulaires, le panneau Pagination de la palette Objet affiche diverses options de pagination.
Placer
Détermine l'emplacement du sous-formulaire.
    • Suivant le précédent
Place le jeu de sous-formulaires après l'objet précédent du sous-formulaire parent.
    • Dans Zone de contenu > [nom_de_la_zone_de_contenu]
Place le jeu de sous-formulaires dans la zone de contenu indiquée.
    • Haut de la zone de contenu suivante
Place le jeu de sous-formulaires en haut de la zone de contenu suivante.
    • Haut de la zone de contenu > [nom_de_la_zone_de_contenu]
Place le jeu de sous-formulaires en haut de la zone de contenu indiquée.
    • A la page > [nom_de_la_page]
Place le jeu de sous-formulaires sur la page indiquée (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Haut de la page suivante
Place le jeu de sous-formulaires en haut de la page suivante (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Haut de la page > [nom_de_la_page]
Place le jeu de sous-formulaires en haut de la page chaque fois que la page indiquée est générée (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Sur page impaire
Place le jeu de sous-formulaires sur les pages destinées à être imprimées sur des pages impaires.
    • Haut de la page impaire suivante
Place le jeu de sous-formulaires en haut de la page impaire chaque fois que la page indiquée est générée (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Sur page paire
Place le jeu de sous-formulaires sur les pages destinées à être imprimées sur des pages paires.
    • Haut de la page paire suivante
Place le jeu de sous-formulaires en haut de la page paire chaque fois que la page indiquée est générée (inclut un saut de page s'il n'est pas inséré automatiquement).
Après
Détermine la zone à remplir une fois le jeu de sous-formulaires placé.
    • Continuer à remplir le parent
Continue de fusionner les données de tous les objets qu'il reste à remplir dans le //sous-formulaire parent.
    • Aller à la zone de contenu suivante
Commence à remplir la zone de contenu suivante.
    • Aller à la zone de contenu > [nom_de_la_zone_de_contenu]
Commence à remplir la zone de contenu indiquée.
    • Aller à la page suivante
Commence à remplir la page suivante.
    • Aller à la page > [nom_de_la_page]
Commence à remplir la page indiquée.
Sauts conditionnels
Indique le nombre de sauts de page conditionnels définis pour le jeu de sous-formulaires.
Débordement
Détermine le mode de débordement si le jeu de sous-formulaires s'étend sur plusieurs pages.
    • Non
Commence à remplir la page suivante (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Aller à la zone de contenu > [nom_de_la_zone_de_contenu]
Commence à remplir la zone de contenu indiquée.
    • Aller à la page > [nom_de_la_page]
Commence à remplir la page indiquée.
Début de débordement
Spécifie un début de débordement pour un jeu de sous-formulaires à paginer.
    • Non
N'utilise pas de début de débordement lors de la pagination du jeu de sous-formulaires.
    • [nom_du_sous-formulaire]
Utilise ce jeu de sous-formulaires existant comme début de débordement.
    • Nouveau
Crée un nouveau jeu de sous-formulaires et le désigne comme début de débordement lors de la pagination du sous-formulaire.
Fin de débordement
Spécifie une fin de débordement pour un jeu de sous-formulaires à paginer.
    • Non
N'utilise pas de fin de débordement lors de la pagination du jeu de sous-formulaires.
    • [nom_du_sous-formulaire]
Utilise ce jeu de sous-formulaires existant comme fin de débordement.
    • Nouveau
Crée un nouveau jeu de sous-formulaires et le désigne comme fin de débordement lors de la pagination de ce sous-formulaire.
Voir aussi
Aperçu des jeux de sous-formulaires
Propriétés d'un jeu de sous-formulaires dans l’onglet Jeu de sous-formulaires
Propriétés du jeu de sous-formulaires dans le panneau Liaison


Propriétés du jeu de sous-formulaires dans le panneau Liaison

Lorsque vous sélectionnez un jeu de sous-formulaires, le panneau Liaison de la palette Objet affiche diverses options de liaison.
Nom
Définit le nom du jeu de sous-formulaires. Par défaut, les groupes de sous-formulaires ne portent pas de nom.
Sous-formulaire pour chaque élément
Active ou désactive la répétition des sous-formulaires.
Min. de répétitions
Définit le nombre minimum d'occurrences de l'objet actuellement sélectionné à afficher sur le formulaire.
Max
Définit le nombre maximum d'occurrences de l'objet actuellement sélectionné à afficher sur le formulaire.
Quantité initiale
Définit le nombre d'occurrences de l'objet actuellement sélectionné à afficher initialement sur le formulaire, indépendamment de la quantité de données de toutes les connexions. La valeur indiquée doit être supérieure ou égale à la valeur Min. de répétitions et inférieure ou égale à la valeur Max.
Voir aussi
Aperçu des jeux de sous-formulaires


Tableaux

Propriétés des tableaux dans le panneau Tableau
Propriétés des tableaux dans le panneau Ombrage de la rangée
Propriétés des tableaux dans le panneau Pagination
Propriétés des tableaux dans le panneau Liaison
Propriétés des rangées d'en-tête et de pied de page sous l'onglet Rangée
Propriétés de la rangée de pied de page dans le panneau Rangée
Propriétés des rangées d'en-tête et de pied de page dans le panneau Pagination
Propriétés des rangées d'en-tête et de pied de page sous l'onglet Liaison
Propriétés des rangées de pied de page dans l’onglet Liaison
Propriétés des rangées de contenu dans le panneau Rangée
Propriétés des rangées de contenu dans le panneau Pagination
Propriétés des rangées de contenu dans le panneau Liaison
Propriétés des sections dans le panneau Section
Propriétés des sections dans le panneau Ombrage de la rangée
Propriétés des sections dans le panneau Pagination
Propriétés des sections dans le panneau Liaison
Propriétés des cellules dans le panneau Cellule
Propriétés des cellules dans le panneau Valeur
Propriétés des cellules dans le panneau Liaison


Propriétés des tableaux dans le panneau Tableau

Lorsque vous sélectionnez un tableau, le panneau Tableau de la palette Objet affiche diverses options de formatage.
Rangées de contenu
Affiche le nombre de rangées de contenu.
Rangées d'en-tête
Affiche le nombre de rangées d'en-tête.
Colonnes
Affiche le nombre de colonnes.
Rangées de pied de page
Affiche le nombre de rangées de pied de page.
Autoriser des sauts de page
Active ou désactive les sauts de page au milieu d'un tableau.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
A propos des tableaux
Propriétés des tableaux dans le panneau Ombrage de la rangée
Propriétés des tableaux dans le panneau Pagination
Propriétés des tableaux dans le panneau Liaison


Propriétés des tableaux dans le panneau Ombrage de la rangée

Lorsque vous sélectionnez un tableau, le panneau Ombrage de la rangée de la palette Objet affiche des options permettant d'utiliser des couleurs pour ombrer des rangées en alternance.
Appliquer l'ombrage une rangée sur deux
Active ou désactive l'ombrage des rangées de contenu d'un tableau.
Dans le cas d'un tableau dans lequel les données sont fusionnées au moment de la génération du formulaire, l'ombrage s'applique uniquement aux rangées de contenu dans lesquelles des données fusionnées apparaissent. L'ombrage ne s'applique pas aux rangées de contenu qui ne font pas partie du processus de fusion. Toutes les rangées auxquelles s'applique l'ombrage doivent avoir un nom. Voir Propriétés des rangées de contenu dans le panneau Liaison.
Détermine le nombre de rangées de contenu auxquelles s'applique la première couleur d'ombrage, en partant de la première rangée.
Sélecteur de couleurs
Définit la première couleur de remplissage utilisée pour l'ombrage.
Suivant
Détermine le nombre de rangées de contenu auxquelles s'applique la seconde couleur d'ombrage, après les rangées associées à la première couleur d'ombrage.
Sélecteur de couleurs
Définit la seconde couleur de remplissage utilisée pour l'ombrage.
Voir aussi
A propos des tableaux
Pour appliquer des bordures et un ombrage à un tableau
Propriétés des tableaux dans le panneau Tableau
Propriétés des tableaux dans le panneau Pagination
Propriétés des tableaux dans le panneau Liaison


Propriétés des tableaux dans le panneau Pagination

Lorsque vous sélectionnez un tableau, le panneau Pagination de la palette Objet affiche diverses options de pagination.
Placer
Détermine l'emplacement du tableau.
    • Suivant le précédent
Place le tableau après l'objet précédent du sous-formulaire parent.
    • Dans Zone de contenu > [nom_de_la_zone_de_contenu]
Place le tableau dans la zone de contenu indiquée.
    • Haut de la zone de contenu suivante
Place le tableau en haut de la zone de contenu suivante.
    • Haut de la zone de contenu > [nom_de_la_zone_de_contenu]
Place le tableau en haut de la zone de contenu indiquée.
    • A la page > [nom_de_la_page]
Place le tableau sur la page indiquée (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Haut de la page suivante
Place le tableau en haut de la page suivante (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Haut de la page > [nom_de_la_page]
Place le tableau en haut de la page chaque fois que la page indiquée est générée (inclut un saut de page s'il n'est pas inséré automatiquement).
Conserver avec - Précédent
Maintient le tableau dans la même zone de contenu que le tableau précédent.
Conserver avec - Suivant
Maintient le tableau dans la même zone de contenu que le tableau suivant.
Après
Détermine la zone à remplir une fois le tableau placé.
    • Continuer à remplir le parent
Continue de fusionner les données de tous les objets qu'il reste à remplir dans le //sous-formulaire parent.
    • Aller à la zone de contenu suivante
Commence à remplir la zone de contenu suivante.
    • Aller à la zone de contenu > [nom_de_la_zone_de_contenu]
Commence à remplir la zone de contenu indiquée.
    • Aller à la page suivante
Commence à remplir la page suivante.
    • Aller à la page > [nom_de_la_page]
Commence à remplir la page indiquée.
Sauts conditionnels
Indique le nombre de sauts de page conditionnels définis pour le tableau. Voir Pour contrôler les sauts de section, de rangée de pied de page, de rangée de contenu, de rangée d'en-tête et de tableau à l'aide d'instructions conditionnelles.
Débordement
Détermine le mode de débordement si le tableau s'étend sur plusieurs pages. Voir Pour configurer un tableau s'étendant sur plusieurs pages.
    • Non
Commence à remplir la page suivante (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Aller à la zone de contenu > [nom_de_la_zone_de_contenu]
Commence à remplir la zone de contenu indiquée.
    • Aller à la page > [nom_de_la_page]
Commence à remplir la page indiquée.
Voir aussi
A propos des tableaux
Pour configurer un tableau s'étendant sur plusieurs pages
Propriétés des tableaux dans le panneau Tableau
Propriétés des tableaux dans le panneau Ombrage de la rangée
Propriétés des tableaux dans le panneau Liaison


Propriétés des tableaux dans le panneau Liaison

Lorsque vous sélectionnez un tableau, le panneau Liaison de la palette Objet affiche diverses options de liaison. Les options qui ne sont pas directement liées à la création d'une connexion de données s'appliquent aux données liées à une source de données et aux données enregistrées dans un fichier lorsque l'objet est lié à la source de données.
Nom
Définit le nom du tableau. Si d'autres tableaux du formulaire portent le même nom, le numéro à côté du nom distingue chaque instance de tableau. Voir Pour donner un nom aux objets ou changer leur nom.
Liaison par défaut
Définit la méthode de liaison de données par défaut :
    • Normale
Active les options de fusion et d'enregistrement. Les données sont fusionnées et enregistrées implicitement conformément aux règles de fusion d'Adobe.
    • Globale
Associe une valeur unique à tous les objets qui portent le même nom (voir Pour définir un champ global).
    • Nouvelle connexion aux données
Démarre l'assistant Nouvelle connexion aux données. Pour définir une connexion à l'aide de l'assistant, voir Pour établir une connexion à un schéma XML et à un fichier de données XML ou Pour établir une connexion à une base de données OLE.
    • Non
Désactive la liaison de données. Puisque l'objet ne recueille et n'affiche aucune donnée fusionnée, aucune information associée ne s'affiche dans la sortie lorsque le formulaire est enregistré/envoyé.
Importation/exportation
Définit une liaison d'importation/exportation pour une connexion de données WSDL. Voir Pour établir une connexion à un fichier WSDL.
Répéter le tableau pour chacun des éléments de données
Active ou désactive la répétition des tableaux.
Min. de répétitions
Définit le nombre minimum d'occurrences de l'objet actuellement sélectionné à afficher sur le formulaire.
Max
Définit le nombre maximum d'occurrences de l'objet actuellement sélectionné à afficher sur le formulaire.
Quantité initiale
Définit le nombre d'occurrences de l'objet actuellement sélectionné à afficher initialement sur le formulaire, indépendamment de la quantité de données de toutes les connexions. La valeur indiquée doit être supérieure ou égale à la valeur Min. de répétitions et inférieure ou égale à la valeur Max.
Voir aussi
A propos des tableaux
Propriétés des tableaux dans le panneau Tableau
Propriétés des tableaux dans le panneau Ombrage de la rangée
Propriétés des tableaux dans le panneau Pagination


Propriétés des rangées d'en-tête et de pied de page sous l'onglet Rangée

Lorsque vous sélectionnez une rangée d'en-tête ou de pied de page d'un tableau, le panneau Rangée de la palette Objet affiche diverses options de formatage.
Type
Détermine le type de contenu de la rangée :
    • Rangée de contenu
Rangée destinée au contenu du tableau.
    • Rangée d'en-tête
La rangée contient des informations d'en-tête. Il s'agit généralement de la première rangée du tableau. Une rangée d'en-tête peut, par exemple, servir à identifier les informations de chaque colonne de tableau.
    • Rangée de pied de page
La rangée contient des informations de pied de page. Il s'agit généralement de la dernière rangée du tableau. Dans le cas d'un tableau contenant des données numériques, par exemple, une rangée de pied de page peut fournir la valeur cumulée de chaque colonne.
Autoriser des sauts de page
Active ou désactive les sauts de page au milieu d’une rangée.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
A propos des tableaux
Pour transformer une rangée en rangée d'en-tête, de contenu ou de pied de page
Propriétés des rangées d'en-tête et de pied de page dans le panneau Pagination
Propriétés des rangées d'en-tête et de pied de page sous l'onglet Liaison


Propriétés de la rangée de pied de page dans le panneau Rangée

Lorsque vous sélectionnez une rangée d'en-tête ou de pied de page d'un tableau, le panneau Rangée de la palette Objet affiche diverses options de formatage.
Type
Détermine le type de contenu de la rangée :
    • Rangée de contenu
Rangée destinée au contenu du tableau.
    • Rangée d'en-tête
La rangée contient des informations d'en-tête. Il s'agit généralement de la première rangée du tableau. Une rangée d'en-tête peut, par exemple, servir à identifier les informations de chaque colonne de tableau.
    • Rangée de pied de page
La rangée contient des informations de pied de page. Il s'agit généralement de la dernière rangée du tableau. Dans le cas d'un tableau contenant des données numériques, par exemple, une rangée de pied de page peut fournir la valeur cumulée de chaque colonne.
Autoriser des sauts de page
Active ou désactive les sauts de page au milieu d’une rangée.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
A propos des tableaux
Pour transformer une rangée en rangée d'en-tête, de contenu ou de pied de page
Propriétés des rangées d'en-tête et de pied de page dans le panneau Pagination
Propriétés des rangées d'en-tête et de pied de page sous l'onglet Liaison


Propriétés des rangées d'en-tête et de pied de page dans le panneau Pagination

Lorsque vous sélectionnez une rangée d'en-tête ou de pied de page d'un tableau, le panneau Pagination de la palette Objet affiche diverses options de pagination.
Placer
Détermine l'emplacement de la rangée d'en-tête ou de pied de page.
    • Suivant le précédent
Place la rangée après la rangée précédente.
    • Dans Zone de contenu > [nom_de_la_zone_de_contenu]
Place la rangée dans la zone de contenu indiquée.
    • Haut de la zone de contenu suivante
Place la rangée en haut de la zone de contenu suivante.
    • Haut de la zone de contenu > [nom_de_la_zone_de_contenu]
Place la rangée en haut de la zone de contenu indiquée.
    • A la page > [nom_de_la_page]
Place la rangée sur la page indiquée (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Haut de la page suivante
Place la rangée en haut de la page suivante (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Haut de la page > [nom_de_la_page]
Place la rangée en haut de la page chaque fois que la page indiquée est générée (inclut un saut de page s'il n'est pas inséré automatiquement).
Conserver avec - Précédent
Maintient la rangée dans la même zone de contenu que la rangée précédente.
Conserver avec - Suivant
Maintient la rangée dans la même zone de contenu que la rangée suivante.
Après
Détermine la zone à remplir une fois la rangée placée.
    • Continuer à remplir le parent
Continue de fusionner les données de tous les objets qu'il reste à remplir dans le tableau parent.
    • Aller à la zone de contenu suivante
Commence à remplir la zone de contenu suivante.
    • Aller à la zone de contenu > [nom_de_la_zone_de_contenu]
Commence à remplir la zone de contenu indiquée.
    • Aller à la page suivante
Commence à remplir la page suivante.
    • Aller à la page > [nom_de_la_page]
Commence à remplir la page indiquée.
Sauts conditionnels
Indique le nombre de sauts de page conditionnels définis pour la rangée d'en-tête ou de pied de page. Voir Pour contrôler les sauts de section, de rangée de pied de page, de rangée de contenu, de rangée d'en-tête et de tableau à l'aide d'instructions conditionnelles.
Rangée d’en-tête sur première page
La rangée d'en-tête apparaît à sa position actuelle dans le tableau.
Rangée d'en-tête sur pages suivantes
Dans le cas d'un tableau qui s'étend sur plusieurs pages, la rangée d'en-tête se répète sur la première ligne de toutes les pages du tableau.
Rangée de pied de page sur pages suiv.
Dans le cas d'un tableau qui s'étend sur plusieurs pages, la rangée de pied de page se répète sur la dernière ligne de toutes les pages du tableau.
Rangée de pied de page sur dernière page
La rangée de pied de page apparaît à sa position actuelle dans le tableau.
Voir aussi
A propos des tableaux
Pour répéter une rangée d'en-tête ou de pied de page sur plusieurs pages
Propriétés des rangées d'en-tête et de pied de page sous l'onglet Rangée
Propriétés des rangées d'en-tête et de pied de page sous l'onglet Liaison
Propriétés des rangées de contenu dans le panneau Pagination


Propriétés des rangées d'en-tête et de pied de page sous l'onglet Liaison

Lorsque vous sélectionnez une rangée d'en-tête ou de pied de page d'un tableau, le panneau Liaison de la palette Objet affiche diverses options de liaison. Les options qui ne sont pas directement liées à la création d'une connexion de données s'appliquent aux données liées à une source de données et aux données enregistrées dans un fichier lorsque l'objet est lié à la source de données.
Nom
Définit le nom de la rangée. Si d'autres rangées du tableau portent le même nom, le numéro à côté du nom distingue chaque instance de rangée. Voir Pour donner un nom aux objets ou changer leur nom.
Liaison par défaut
Définit la méthode de liaison de données par défaut :
    • Normale
Active les options de fusion et d'enregistrement. Les données sont fusionnées et enregistrées implicitement conformément aux règles de fusion d'Adobe.
    • Globale
Associe une valeur unique à tous les objets qui portent le même nom (voir Pour définir un champ global).
    • Nouvelle connexion aux données
Démarre l'assistant Nouvelle connexion aux données. Pour définir une connexion à l'aide de l'assistant, voir Pour établir une connexion à un schéma XML et à un fichier de données XML ou Pour établir une connexion à une base de données OLE.
    • Non
Désactive la liaison de données. Puisque l'objet ne recueille et n'affiche aucune donnée fusionnée, aucune information associée ne s'affiche dans la sortie lorsque le formulaire est enregistré/envoyé.
Importation/exportation
Définit une liaison d'importation/exportation pour une connexion de données WSDL. Voir Pour établir une connexion à un fichier WSDL.
Rangée pour chaque élément, Min. de répétitions, Max. et Quantité initiale.
Active ou désactive la répétition des rangées. Voir Pour configurer les rangées d'un tableau en vue de les adapter aux données.
Voir aussi
A propos des tableaux
Propriétés des rangées d'en-tête et de pied de page sous l'onglet Rangée
Propriétés des rangées d'en-tête et de pied de page dans le panneau Pagination
Propriétés des rangées de contenu dans le panneau Liaison


Propriétés des rangées de pied de page dans l’onglet Liaison

Lorsque vous sélectionnez une rangée d'en-tête ou de pied de page d'un tableau, le panneau Liaison de la palette Objet affiche diverses options de liaison. Les options qui ne sont pas directement liées à la création d'une connexion de données s'appliquent aux données liées à une source de données et aux données enregistrées dans un fichier lorsque l'objet est lié à la source de données.
Nom
Définit le nom de la rangée. Si d'autres rangées du tableau portent le même nom, le numéro à côté du nom distingue chaque instance de rangée. Voir Pour donner un nom aux objets ou changer leur nom.
Liaison par défaut
Définit la méthode de liaison de données par défaut :
    • Normale
Active les options de fusion et d'enregistrement. Les données sont fusionnées et enregistrées implicitement conformément aux règles de fusion d'Adobe.
    • Globale
Associe une valeur unique à tous les objets qui portent le même nom (voir Pour définir un champ global).
    • Nouvelle connexion aux données
Démarre l'assistant Nouvelle connexion aux données. Pour définir une connexion à l'aide de l'assistant, voir Pour établir une connexion à un schéma XML et à un fichier de données XML ou Pour établir une connexion à une base de données OLE.
    • Non
Désactive la liaison de données. Puisque l'objet ne recueille et n'affiche aucune donnée fusionnée, aucune information associée ne s'affiche dans la sortie lorsque le formulaire est enregistré/envoyé.
Importation/exportation
Définit une liaison d'importation/exportation pour une connexion de données WSDL. Voir Pour établir une connexion à un fichier WSDL.
Rangée pour chaque élément, Min. de répétitions, Max. et Quantité initiale.
Active ou désactive la répétition des rangées. Voir Pour configurer les rangées d'un tableau en vue de les adapter aux données.
Voir aussi
A propos des tableaux
Propriétés des rangées d'en-tête et de pied de page sous l'onglet Rangée
Propriétés des rangées d'en-tête et de pied de page dans le panneau Pagination
Propriétés des rangées de contenu dans le panneau Liaison


Propriétés des rangées de contenu dans le panneau Rangée

Lorsque vous sélectionnez une rangée de contenu, le panneau Rangée de la palette Objet affiche diverses options de formatage.
Type
Détermine le type de contenu de la rangée :
    • Rangée de contenu
Rangée destinée au contenu du tableau.
    • Rangée d'en-tête
La rangée contient des informations d'en-tête. Il s'agit généralement de la première rangée du tableau. Une rangée d'en-tête peut, par exemple, servir à identifier les informations de chaque colonne de tableau.
    • Rangée de pied de page
La rangée contient des informations de pied de page. Il s'agit généralement de la dernière rangée du tableau. Dans le cas d'un tableau contenant des données numériques, par exemple, une rangée de pied de page peut fournir la valeur cumulée de chaque colonne.
Voir Propriétés des rangées d'en-tête et de pied de page sous l'onglet Rangée.
Autoriser des sauts de page
Active ou désactive les sauts de page au milieu d’une rangée.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
A propos des tableaux
Pour transformer une rangée en rangée d'en-tête, de contenu ou de pied de page
Propriétés des rangées de contenu dans le panneau Pagination
Propriétés des rangées de contenu dans le panneau Liaison


Propriétés des rangées de contenu dans le panneau Pagination

Lorsque vous sélectionnez une rangée de contenu, le panneau Pagination de la palette Objet affiche diverses options de pagination.
les options Inclure sont disponibles uniquement lorsqu'une rangée d'en-tête ou de pied de page est sélectionnée. Voir Propriétés des rangées d'en-tête et de pied de page dans le panneau Pagination.
Placer
Détermine l'emplacement de la rangée.
    • Suivant le précédent
Place la rangée après la rangée précédente.
    • Dans Zone de contenu > [nom_de_la_zone_de_contenu]
Place la rangée dans la zone de contenu indiquée.
    • Haut de la zone de contenu suivante
Place la rangée en haut de la zone de contenu suivante.
    • Haut de la zone de contenu > [nom_de_la_zone_de_contenu]
Place la rangée en haut de la zone de contenu indiquée.
    • A la page > [nom_de_la_page]
Place la rangée sur la page indiquée (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Haut de la page suivante
Place la rangée en haut de la page suivante (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Haut de la page > [nom_de_la_page]
Place la rangée en haut de la page chaque fois que la page indiquée est générée (inclut un saut de page s'il n'est pas inséré automatiquement).
Conserver avec - Précédent
Maintient la rangée dans la même zone de contenu que la rangée précédente.
Conserver avec - Suivant
Maintient la rangée dans la même zone de contenu que la rangée suivante.
Après
Détermine la zone à remplir une fois la rangée placée.
    • Continuer à remplir le parent
Continue de fusionner les données de tous les objets qu'il reste à remplir dans le tableau parent.
    • Aller à la zone de contenu suivante
Commence à remplir la zone de contenu suivante.
    • Aller à la zone de contenu > [nom_de_la_zone_de_contenu]
Commence à remplir la zone de contenu indiquée.
    • Aller à la page suivante
Commence à remplir la page suivante.
    • Aller à la page > [nom_de_la_page]
Commence à remplir la page indiquée.
Sauts conditionnels
Indique le nombre de sauts de page conditionnels définis pour la rangée. Voir Pour contrôler les sauts de section, de rangée de pied de page, de rangée de contenu, de rangée d'en-tête et de tableau à l'aide d'instructions conditionnelles.
Voir aussi
A propos des tableaux
Propriétés des rangées de contenu dans le panneau Rangée
Propriétés des rangées de contenu dans le panneau Liaison


Propriétés des rangées de contenu dans le panneau Liaison

Lorsque vous sélectionnez une rangée de contenu, le panneau Liaison de la palette Objet affiche diverses options de liaison. Les options qui ne sont pas directement liées à la création d'une connexion de données s'appliquent aux données liées à une source de données et aux données enregistrées dans un fichier lorsque l'objet est lié à la source de données.
Nom
Définit le nom de la rangée. Par défaut, les rangées de contenu ne portent pas de nom. Si d'autres rangées du formulaire portent le même nom, le numéro à côté du nom distingue chaque instance de rangée. Voir Pour donner un nom aux objets ou changer leur nom.
Liaison par défaut
Définit la méthode de liaison de données par défaut :
    • Normale
Active les options de fusion et d'enregistrement. Les données sont fusionnées et enregistrées implicitement conformément aux règles de fusion d'Adobe.
    • Globale
Associe une valeur unique à tous les objets qui portent le même nom (voir Pour définir un champ global).
    • Nouvelle connexion aux données
Démarre l'assistant Nouvelle connexion aux données. Pour définir une connexion à l'aide de l'assistant, voir Pour établir une connexion à un schéma XML et à un fichier de données XML ou Pour établir une connexion à une base de données OLE.
    • Non
Désactive la liaison de données. Puisque l'objet ne recueille et n'affiche aucune donnée fusionnée, aucune information associée ne s'affiche dans la sortie lorsque le formulaire est enregistré/envoyé.
Importation/exportation
Définit une liaison d'importation/exportation pour une connexion de données WSDL. Voir Pour établir une connexion à un fichier WSDL.
Rangée pour chaque élément, Min. de répétitions, Max. et Quantité initiale.
Active ou désactive la répétition des rangées. Voir Pour configurer les rangées d'un tableau en vue de les adapter aux données.
Voir aussi
A propos des tableaux
Propriétés des rangées de contenu dans le panneau Rangée
Propriétés des rangées de contenu dans le panneau Pagination
Propriétés des rangées d'en-tête et de pied de page sous l'onglet Liaison


Propriétés des sections dans le panneau Section

Lorsque vous sélectionnez une section, le panneau Section de la palette Objet affiche diverses options de formatage.
Type
Définit les sections à afficher au moment de la génération du formulaire, en fonction du contenu de la section.
    • Utiliser tous les sous-formulaires dans l'ordre
Toutes les rangées de la section sont intégrées lorsque le formulaire est généré.
    • Sélectionner un sous-formulaire parmi les sous-formulaires de remplacement
Une rangée parmi deux rangées possibles est intégrée lorsque le formulaire est généré. La rangée à inclure dépend des données fusionnées. Pour les rangées dont une cellule affiche une valeur calculée, par exemple, vous pouvez décider qu'une rangée est affichée si la valeur est supérieure ou égale à zéro et une autre rangée si la valeur est inférieure à zéro.
Voir aussi
A propos des tableaux
Pour regrouper des rangées en section
Pour créer des sections de choix dans les tableaux
Propriétés des sections dans le panneau Ombrage de la rangée
Propriétés des sections dans le panneau Pagination
Propriétés des sections dans le panneau Liaison


Propriétés des sections dans le panneau Ombrage de la rangée

Lorsque vous sélectionnez une section, le panneau Ombrage de la rangée de la palette Objet affiche des options permettant d'utiliser des couleurs pour ombrer des rangées de la section en alternance.
Appliquer l'ombrage une rangée sur deux
Active ou désactive l'ombrage des rangées de contenu d'une section.
Dans le cas d'une section dans laquelle les données sont fusionnées au moment de la génération du formulaire, l'ombrage s'applique uniquement aux rangées de contenu dans lesquelles des données fusionnées apparaissent. L'ombrage ne s'applique pas aux rangées de contenu qui ne font pas partie du processus de fusion. Toutes les rangées auxquelles s'applique l'ombrage doivent avoir un nom. Voir Propriétés des rangées de contenu dans le panneau Liaison.
Prem.
Détermine le nombre de rangées de contenu auxquelles s'applique la première couleur d'ombrage, en partant de la première rangée de la section.
Sélecteur de couleurs
Définit la première couleur de remplissage utilisée pour l'ombrage.
Suivant
Détermine le nombre de rangées de contenu de la section auxquelles s'applique la seconde couleur d'ombrage, après les rangées associées à la première couleur d'ombrage.
Sélecteur de couleurs
Définit la seconde couleur de remplissage utilisée pour l'ombrage.
Voir aussi
A propos des tableaux
Propriétés des sections dans le panneau Section
Propriétés des sections dans le panneau Pagination
Propriétés des sections dans le panneau Liaison


Propriétés des sections dans le panneau Pagination

Lorsque vous sélectionnez une section, le panneau Pagination de la palette Objet affiche diverses options de pagination.
Placer
Détermine l'emplacement de la section.
    • Suivant le précédent
Place la section après la section précédente.
    • Dans Zone de contenu > [nom_de_la_zone_de_contenu]
Place la section dans la zone de contenu indiquée.
    • Haut de la zone de contenu suivante
Place la section en haut de la zone de contenu suivante.
    • Haut de la zone de contenu > [nom_de_la_zone_de_contenu]
Place la section en haut de la zone de contenu indiquée.
    • A la page > [nom_de_la_page]
Place la section sur la page indiquée (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Haut de la page suivante
Place la section en haut de la page suivante (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Haut de la page > [nom_de_la_page]
Place la section en haut de la page chaque fois que la page indiquée est générée (inclut un saut de page s'il n'est pas inséré automatiquement).
Après
Détermine la zone à remplir une fois la section placée.
    • Continuer à remplir le parent
Continue de fusionner les données de tous les objets qu'il reste à remplir dans le tableau parent.
    • Aller à la zone de contenu suivante
Commence à remplir la zone de contenu suivante.
    • Aller à la zone de contenu > [nom_de_la_zone_de_contenu]
Commence à remplir la zone de contenu indiquée.
    • Aller à la page suivante
Commence à remplir la page suivante.
    • Aller à la page > [nom_de_la_page]
Commence à remplir la page indiquée.
Sauts conditionnels
Indique le nombre de sauts de page conditionnels définis pour la section. Voir Pour contrôler les sauts de section, de rangée de pied de page, de rangée de contenu, de rangée d'en-tête et de tableau à l'aide d'instructions conditionnelles.
Débordement
Détermine le mode de débordement si la section s'étend sur plusieurs pages. Voir Pour configurer un tableau s'étendant sur plusieurs pages.
    • Non
Commence à remplir la page suivante (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Aller à la zone de contenu > [nom_de_la_zone_de_contenu]
Commence à remplir la zone de contenu indiquée.
    • Aller à la page > [nom_de_la_page]
Commence à remplir la page indiquée.
Voir aussi
A propos des tableaux
Propriétés des sections dans le panneau Section
Propriétés des sections dans le panneau Ombrage de la rangée
Propriétés des sections dans le panneau Liaison


Propriétés des sections dans le panneau Liaison

Lorsque vous sélectionnez une section, le panneau Liaison de la palette Objet affiche diverses options de liaison. Les options qui ne sont pas directement liées à la création d'une connexion de données s'appliquent aux données liées à une source de données et aux données enregistrées dans un fichier lorsque l'objet est lié à la source de données.
Nom
Définit le nom de la section. Si d'autres sections du tableau portent le même nom, le numéro à côté du nom distingue chaque instance de section. Par défaut, les sections ne portent pas de nom. Voir Pour donner un nom aux objets ou changer leur nom.
Rangée pour chaque élément, Min. et Max. de répétitions et Quantité initiale.
Active ou désactive la répétition des sections. Voir Pour créer une section de tableau facultative.
Voir aussi
A propos des tableaux
Propriétés des sections dans le panneau Section
Propriétés des sections dans le panneau Ombrage de la rangée
Propriétés des sections dans le panneau Pagination


Propriétés des cellules dans le panneau Cellule

Lorsque vous sélectionnez une cellule, le panneau Cellule de la palette Objet affiche des options de formatage.
Par défaut, les cellules contiennent du texte statique et le panneau Cellule propose des options de formatage relatives à l'objet de texte. Si vous modifiez le contenu d'une cellule, le panneau Cellule affiche les options de formatage correspondant au type d'objet. Ainsi, si vous changez le contenu d'une cellule en champ de texte, le panneau Cellule affiche les options de formatage correspondant à un objet de champ de texte.
Tous les types d'objet par défaut peuvent être utilisés pour définir le type de cellule. Les options de formatage qui apparaissent dans le panneau Cellule sont identiques à celles disponibles lorsque vous ajoutez l'objet directement au formulaire. Par exemple, les options disponibles dans le panneau Cellule pour un type de cellule Champ de texte sont identiques à celles du panneau Champ pour un objet de champ de texte. De même, si le type de cellule est un cercle, le panneau Cellule affiche les mêmes options que le panneau Dessin pour un objet de cercle.
Outre les options de formatage relatives au type d'objet, le panneau Cellule affiche les options suivantes :
    • Fusionner les cellules
Fusionne plusieurs cellules adjacentes sélectionnées.
    • Scinder la cellule horizontalement
Lorsqu'une cellule fusionnée est sélectionnée, sépare les cellules en fonction de leur position d'origine.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
Invisible
      •
      L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
Voir aussi
A propos des tableaux
Pour transformer une cellule en un autre type d'objet
Pour fusionner et scinder des cellules
Propriétés des cellules dans le panneau Valeur
Propriétés des cellules dans le panneau Liaison


Propriétés des cellules dans le panneau Valeur

Lorsque vous sélectionnez une cellule dont le type d'objet accepte des options de valeur (ex : objets de champ numérique ou de champ de texte), le panneau Valeur de la palette Objet affiche diverses options. Celles-ci dépendent du type de cellule sélectionné. Si vous sélectionnez une cellule de type Champ de texte, par exemple, le panneau Valeur affiche les options relatives à ce type d'objet.
Les options qui apparaissent dans le panneau Valeur sont identiques à celles disponibles dans ce panneau lorsque vous ajoutez l'objet directement au formulaire.
Voir aussi
A propos des tableaux
Propriétés des cellules dans le panneau Cellule
Propriétés des cellules dans le panneau Liaison


Propriétés des cellules dans le panneau Liaison

Lorsque vous sélectionnez une cellule contenant un objet auquel s'appliquent des options de liaison (objets de sous-formulaire ou de champ de texte, par exemple), le panneau Liaison de la palette Objet affiche diverses options de liaison. Celles-ci dépendent du type de cellule sélectionné.
Si vous sélectionnez une cellule de champ de texte, par exemple, le panneau Liaison affiche les options relatives à ce type d'objet. Les options qui ne sont pas directement liées à la création d'une connexion de données s'appliquent aux données liées à une source de données et aux données enregistrées dans un fichier lorsque l'objet est lié à la source de données.
Les options qui apparaissent dans le panneau Liaison sont identiques à celles disponibles dans ce panneau lorsque vous ajoutez l'objet directement au formulaire.
Voir aussi
A propos des tableaux
Propriétés des cellules dans le panneau Cellule
Propriétés des cellules dans le panneau Valeur


Précédent Suivant

Utilisation de LiveCycle Designer > Propriétés de l'objet > Propriétés de la palette Objet > Texte

Texte

Propriétés du texte dans le panneau Dessin


Propriétés du texte dans le panneau Dessin

Lorsque vous créez un texte, le panneau Dessin de la palette Objet affiche les options propres au formatage de l'objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
Aperçu du texte


Champs de texte

Propriétés des champs de texte dans le panneau Champ
Propriétés des champs de texte dans le panneau Valeur
Propriétés des champs de texte dans le panneau Liaison
Formats des champs de texte
Exemples de formats de texte


Propriétés des champs de texte dans le panneau Champ

Lorsque vous sélectionnez un champ de texte, le panneau Champ de la palette Objet affiche les options propres au formatage de l'objet.
Type
Définit le type de l'objet. Les objets constituent les blocs fonctionnels d'un formulaire.
Légende
Définit la légende de l'objet.
La propriété Légende est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique une légende.
Aspect
Définit le style de la bordure du champ :
    • Non
N'affiche pas de bordure autour du champ.
    • Souligné
Souligne le champ.
    • Case pleine
Affiche une bordure pleine autour du champ
    • Case enfoncée
Crée une ombre autour du champ pour lui donner un aspect tridimensionnel.
    • Personnaliser
Ouvre la boîte de dialogue Aspect personnalisé. Sélectionnez cette option si vous voulez personnaliser la zone remplissable de l'objet.
Permettre des lignes multiples
Active ou désactive les lignes multiples.
Format du champ
Active la mise en forme en texte simple ou enrichi de la valeur du champ dans le formulaire :
    • Texte simple seulement
Autorise un formatage en texte brut.
    • Texte enrichi
Autorise un formatage en texte enrichi. Si vous définissez le champ de façon à ce qu'il affiche des valeurs au format texte enrichi et que vous souhaitez enregistrer les données sous ce format, vous devez également configurer l'option Format de données du panneau Liaison sur XHTML.
Limiter la taille et Nombre max. de caractères
Définit la longueur du champ en fonction du nombre maximal de caractères indiqué.
Limiter la longueur à la zone visible
Définit le nombre maximal de caractères autorisés dans le champ en fonction de la longueur horizontale du champ de texte.
Utiliser les cellules
Active le format de peigne.
Format d'affichage
Définit le format d'affichage des valeurs formatées dans le formulaire. Voir Pour définir un format d'affichage.
lors de la conception et de l'exécution, les valeurs formatées dans le champ sont tributaires du format du paramètre régional.
Format de saisie
Définit le format de syntaxe des valeurs entrées par l'utilisateur. Si l'entrée de l'utilisateur n'est pas conforme au format de saisie, les données sont refusées et la mise en forme des valeurs de champ n'est pas effectuée. Voir Pour définir un format de saisie.
lors de la conception et de l'exécution, les valeurs formatées dans le champ sont tributaires du format du paramètre régional.
Visibilité
Détermine si un objet est affiché dans un formulaire PDF lorsque les utilisateurs ouvrent le formulaire dans Acrobat ou Adobe Reader, ou lorsqu'ils impriment le formulaire :
    • Visible
L'objet est visible à l'écran et sur le formulaire imprimé et est également pris en compte dans la disposition du formulaire. Il s'agit du paramètre de visibilité par défaut pour tous les objets.
    • Visible (Ecran seulement)
L'objet est visible à l'écran, mais pas sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Visible (Impression seulement)
L'objet n'est pas visible à l'écran, mais est présent sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Invisible
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il est pris en compte dans la disposition du formulaire.
    • Masqué (pas affiché)
L'objet n'est ni visible à l'écran, ni visible sur le formulaire imprimé. Il n'est pas non plus pris en compte dans la disposition du formulaire.
Paramètre régional
Affiche les données en fonction des paramètres régionaux spécifiés pour la langue et le pays. Vous pouvez choisir une langue et un pays dans la liste ou sélectionner l'une des options suivantes :
    • Paramètre régional par défaut
Applique le paramètre régional par défaut défini dans l'onglet Valeurs par défaut de la boîte de dialogue Propriétés du formulaire.
    • Paramètre régional du système de visualisation
Utilise le paramètre régional système de l'ordinateur de l'utilisateur.
Les paramètres régionaux de la liste sont d'abord organisés par langue, puis par pays.
Voir aussi
Aperçu des champs de texte


Propriétés des champs de texte dans le panneau Valeur

Lorsque vous créez un champ de texte, le panneau Valeur propose différentes options que vous pouvez appliquer à l'objet.
Type
Permet les calculs à l'exécution et l'affichage d'invites :
    • Entré par l'utilisateur - Facultatif
L'utilisateur peut choisir d'entrer des données ou non.
    • Entré par l'utilisateur - Recommandé
Si l'utilisateur n'entre pas de données, un message personnalisé (s'il est défini dans la zone Message d'état vide) s'affiche.
    • Entré par l'utilisateur - Obligatoire
Si l'utilisateur n'entre pas de données, un message personnalisé (s'il est défini dans la zone Message d'état vide) s'affiche.
    • Calculé - Lecture seule
Une valeur sera calculée et affichée par le biais d'un script. L'utilisateur n'a pas la possibilité de modifier la valeur calculée.
    • Calculé - L'utilisateur peut remplacer
Une valeur sera calculée et affichée par le biais d'un script. L'utilisateur peut changer la valeur si le script de calcul accepte les saisies. Si l'utilisateur change la valeur, le message personnalisé que vous avez défini dans la zone Message de remplacement s'affiche.
    • Lecture seule
Une valeur sera fusionnée ou calculée et affichée à l'exécution. Les utilisateurs ne peuvent pas modifier la valeur.
Valeur par défaut
Définit la valeur initiale du champ. La valeur est mise en forme selon le paramètre de l'option Format d'affichage du panneau Champ, mais elle doit se conformer à la valeur en fonction du paramètre régional spécifié dans le champ. si les données sont liées et qu'un modèle a été spécifié, la valeur doit correspondre au modèle de données défini dans le panneau Liaison. Voir Pour définir une valeur par défaut.
cette option s'affiche uniquement lorsque l'option Type est définie sur Entré par l'utilisateur - Obligatoire, Entré par l'utilisateur - Recommandé ou Lecture seule.
Message d'état vide
Définit le message demandant aux utilisateurs d'entrer une valeur recommandée ou obligatoire. Voir Pour inviter les utilisateurs à entrer des données.
Cette option est disponible seulement lorsque l'option Type est définie sur Entré par l'utilisateur - Recommandé ou Entré par l'utilisateur - Obligatoire.
Modèle de validation
Définit le modèle qui valide la valeur entrée par l'utilisateur. Le modèle doit correspondre à la syntaxe de la valeur saisie par l'utilisateur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule.
Message du modèle de validation et Erreur
Définit un message personnalisé qui s'affiche lorsque la valeur brute ne correspond pas au modèle de validation. Par défaut, cette situation génère une erreur de programmation à l'exécution. Pour afficher plutôt un message d'avertissement, désélectionnez l'option Erreur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule. La propriété Message du modèle de validation est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique un message de modèle de validation.
Message du script de validation et Erreur
Définit un message personnalisé qui s'affiche lorsque le script de validation détecte une valeur inacceptable. Par défaut, cette situation génère une erreur de programmation à l'exécution. Pour afficher plutôt un message d'avertissement, désélectionnez l'option Erreur. Voir Pour valider les données utilisateur.
cette option n'est pas disponible lorsque l'option Type est définie sur Calculé - Lecture seule ou Lecture seule. La propriété Message du script de validation est dynamique. Les propriétés dynamiques sont identifiées par des libellés actifs soulignés en vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à la source de données. Pour activer et désactiver des libellés, choisissez la commande Afficher les propriétés dynamiques dans le menu de la palette Objet. Voir Pour remplir de façon dynamique un message de script de validation.
Script de calcul
La valeur est calculée par le script écrit pour l’événement calculate de l’objet.
cette option est disponible uniquement lorsque l'option Type est définie sur Calculé - Lecture seule.
Propriété de l'exécution
Définit l'une des propriétés d'exécution ci-dessous pour l'objet. Lorsque vous sélectionnez une propriété d’exécution, la valeur réelle de l’option correspondante est insérée dynamiquement lorsque le formulaire est consulté.
    • numéro de la page active
Insère le numéro de la page actuelle dans le formulaire final.
    • nombre de pages
Insère le nombre total de pages dont le formulaire est constitué.
    • paramètres régionaux du programme de visualisation
Insère l'identificateur de paramètre régional du paramètre régional spécifié pour l'application qui traite le formulaire. Par exemple, l'identificateur du paramètre régional Anglais (Etats-Unis) est en_US, où en est la langue et US le pays.
    • nom du programme de visualisation
Insère le nom de l'application qui traite le formulaire.
    • version du programme de visualisation
Insère le numéro de version de l'application qui traite le formulaire.
    • Numéro de feuille actuel
Insère le numéro de la feuille de papier actuelle dans le champ numérique.
    • Nombre de feuilles
Insère le nombre de feuilles de papier qui constituent le formulaire.
cette option est disponible uniquement lorsque l'option Type est définie sur Calculé - Lecture seule.
Message de remplacement
Définit un message personnalisé pour informer l'utilisateur qu'il change la valeur d'un champ calculé. Le message s'affiche lorsqu'un utilisateur modifie la valeur calculée.
cette option est disponible uniquement lorsque l'option Type est définie sur Calculé - L'utilisateur peut remplacer.
Voir aussi
Aperçu des champs de texte


Propriétés des champs de texte dans le panneau Liaison

Lorsque vous créez un champ de texte, le panneau Liaison propose différentes options que vous pouvez appliquer à l'objet. Les options qui ne sont pas directement liées à la création d'une connexion de données s'appliquent aux données liées à une source de données et aux données enregistrées dans un fichier lorsque l'objet est lié à la source de données.
Nom
Définit le nom du champ de texte. Voir Pour donner un nom aux objets ou changer leur nom.
Liaison par défaut
Définit la méthode de liaison de données par défaut :
    • Normale
Active les options de fusion et d'enregistrement. Les données sont fusionnées et enregistrées implicitement conformément aux règles de fusion d'Adobe.
    • Globale
Associe une valeur unique à tous les objets qui portent le même nom (voir Pour définir un champ global).
    • Nouvelle connexion aux données
Démarre l'assistant Nouvelle connexion aux données. Pour définir une connexion à l'aide de l'assistant, voir Pour établir une connexion à un schéma XML et à un fichier de données XML ou Pour établir une connexion à une base de données OLE.
    • Non
Désactive la liaison de données. Puisque l'objet ne recueille et n'affiche aucune donnée fusionnée, aucune information associée ne s'affiche dans la sortie lorsque le formulaire est enregistré/envoyé.
Modèle de données
Définit un modèle pour le stockage et l'extraction des données liées ou pour enregistrer les données lorsque le formulaire n'est pas lié à une source de données. Voir Pour spécifier un modèle de données.
Format des données
Définit le format des données enregistrées. Voir Pour spécifier le format des données pour les champs de texte.
    • Texte brut
Texte codé en UTF-8 qui prend en charge le jeu de caractères étendus. La valeur du champ ne contient que des données.
    • XHTML
Langage XMTML (Extensible HyperText Markup Language), version 1.0. La valeur du champ enregistrée dans la source des données ou le fichier de données inclut des informations de formatage XHTML du texte.
Importation/exportation
Définit une liaison d'importation/exportation pour une connexion de données WSDL. Voir Pour établir une connexion à un fichier WSDL.
Voir aussi
A propos des sources de données
Aperçu des champs de texte
Formats des champs de texte


Formats des champs de texte

Vous devez utiliser les symboles suivants pour définir les formats des champs de texte.
la virgule (,), le tiret (-), le deux-points (:), la barre oblique (/), le point (.) et l'espace ( ) sont considérés comme des valeurs littérales qui peuvent être incluses n'importe où dans le format. Pour inclure du texte dans un format, délimitez la chaîne de texte par des guillemets simples ('). Par exemple, 'Your phone number is ('999')' 999-9999peut être spécifié comme format d'affichage.

Symbole de texte

Description

Exemple

A
Caractère alphabétique simple
Format d'affichage : A9A 9A9
Valeur d'entrée : K1S5K2
Valeur formatée : K1S 5K2

X
Caractère simple
Format d'affichage : XXX XXX
Valeur d'entrée : !1$5&2
Valeur formatée : !1$ 5&2

O
Caractère alphanumérique simple
Format d'affichage : OO OO OO
Valeur d'entrée : 123ABC
Valeur formatée : 12 3A BC

0
Caractère alphanumérique simple
Format d'affichage : 00 00 00
Valeur d'entrée : 123ABC
Valeur formatée : 12 3A BC

9
Chiffre simple
Format d'affichage : 999-9999
Valeur d'entrée : 9407000
Valeur formatée : 940-7000
les symboles O (o majuscule) et 0 (zéro) ont été intentionnellement définis comme des synonymes, car ils sont souvent confondus sur le clavier ou à la lecture.
Symboles réservés
Les symboles qui suivent ont une signification particulière et ne peuvent pas être utilisés comme texte littéral.
?
Lorsqu'il est utilisé, ce symbole représente n'importe quel caractère. Lorsqu'il est fusionné pour l'affichage, il devient un espace.

*
Lorsqu'il est utilisé, ce symbole représente 0 ou le caractère d'espace Unicode. Lorsqu'il est fusionné pour l'affichage, il devient un espace.

+
Lorsqu'il est utilisé, ce symbole représente un ou plusieurs caractères d'espace Unicode. Lorsqu'il est fusionné pour l'affichage, il devient un espace.
Voir aussi
A propos des formats et des valeurs de format
Formats de champ complexes
Exemples de formats de texte


Exemples de formats de texte

Formats prédéfinis
Le tableau ci-dessous illustre les formats de texte prédéfinis que vous pouvez sélectionner dans la liste Format d'affichage du panneau Champ de la palette Objet. Il montre également des exemples de valeurs entrées par un utilisateur ou provenant de données liées, une fois qu'elles sont formatées selon le format d'affichage.

Format prédéfini

Valeur d'entrée

Valeur formatée
A9A 9A9
K1S5K2
K1S 5K2
AA9A 9A9
KB1C3R2
KB1C 3R2
99999
12345
12345
'('999')' 999-9999
6135551212
(613) 555-1212
999-9999
5551212
555-1212
text{999-9999}|text{999-999-9999}
5551212
6135551212
555-1212
613-555-1212
Formats personnalisés
Le tableau suivant indique des formats personnalisés que vous pouvez définir pour les valeurs saisies par un utilisateur ou provenant de données liées, au moyen d'un format d'affichage.

Format personnalisé

Valeur d'entrée

Valeur formatée
'+1 ('999') '999-9999
6135551212
+1 (613) 555-1212
999.999.9999
6135551212
613.555.1212
L'exemple qui suit illustre un numéro de série qui exige le format suivant : trois caractères alphabétiques, suivis de quatre chiffres puis d'un seul caractère de n'importe quel type. Un format approprié serait :
AAA-9999-X
Le tableau qui suit illustre le résultat de la conversion de certaines valeurs (saisies par un utilisateur ou provenant de données liées) en valeurs brutes au moyen d'un format de saisie ou d'un modèle de données.

Format personnalisé

Valeur d'entrée

Valeur brute
AAA-9999-X
ABC-1234-5
ABC-1234-D
123-4567-8
ABC12345
ABC1234D
« «
Dans le dernier exemple, la valeur brute résultante est une chaîne vide, puisque la valeur entrée 123-4567-8 ne respecte pas le format.


Utilisation de sources de données

A propos des sources de données
Connexion à une source de données
Liaison de champs à une source de données
Types de fichiers
Remplissage dynamique des propriétés d'objets de formulaire à partir d'une source de données


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation de sources de données > A propos des sources de données

A propos des sources de données

Utilisation de sources de données
Utilisation de connexion aux données


Utilisation de sources de données

Vous pouvez créer des conceptions de formulaire qui permettent plus que la simple capture de données. LiveCycle Designer vous permet d'intégrer vos conceptions de formulaire à des bases de données d'entreprise ou à des services Web afin d'élaborer et de tenir à jour des solutions de capture qui lisent des sources de données d'entreprise, valident des données par rapport à ces sources et ajoutent des données aux sources de données. Pour ce faire, vous connectez votre conception de formulaire à une ou à plusieurs sources de données et liez les données à un ou à plusieurs champs de la conception de formulaire.
Vous pouvez connecter et lier des champs aux sources de données suivantes :
Schémas XML
Des schémas XML spécifient comment décrire formellement les éléments d'un document XML. En établissant une connexion à un schéma XML, vous pouvez lier les éléments et les attributs définis dans le schéma aux champs de la conception de formulaire. Vous pouvez également sélectionner l'élément racine de données XML à utiliser pour la connexion.
Bases de données OLE
Base de données OLE est une norme d'intégration Microsoft, qui propose une interface de programme d'application (API) de base pour utiliser les données dans toute une entreprise. En vous connectant à une base de données OLE, vous pouvez créer des conceptions de formulaire qui servent d'outils de saisie ou de capture de données pour les serveurs de base de données de l'entreprise. Vous pouvez également tirer parti d'une base de données pour fournir du contenu à des sections d'un formulaire au moment de l'exécution.
Données XML d'exemple
En établissant une connexion à un fichier XML, vous pouvez lier des champs aux éléments et aux attributs définis dans le fichier XML. Cette méthode est utile lorsque vous ne disposez pas de schéma XML, mais que vous avez un fichier XML qui peut servir d'échantillon.
Fichiers WSDL (Web Service Definition Language)
Les fichiers WSDL décrivent les services Web en utilisant le langage XML. En établissant une connexion à un fichier WSDL, vous pouvez lier des champs d'une conception de formulaire à un ou à plusieurs services Web.
Voir aussi
Palette Vue des données
A propos de la connexion à une source de données
A propos de la liaison de champs à une source de données
A propos des propriétés dynamiques


Utilisation de connexion aux données

Pour créer des conceptions de formulaire interactives, vous pouvez utiliser des sources de données externes (bases de données, fichiers de données XML, schémas XML et services Web) afin de définir les valeurs des champs, remplir des champs sur un formulaire ou recueillir des données saisies dans un formulaire. LiveCycle Designer offre un outil spécialement conçu pour définir les connexions aux sources de données. Vous pouvez ensuite associer les champs qui acceptent ces types de données aux sources de données. Vous pouvez rédiger en langage FormCalc ou JavaScript les scripts pris en charge par un champ pour indiquer une logique d'entreprise et créer des calculs et des validations. De plus, vous pouvez tirer profit de deux objets personnalisés, la Liste déroulante de données et la Liste de données, pour assurer la connexion à une base de données et remplir les zones de liste. Ces deux objets sont disponibles dans la catégorie Personnalisés de la palette Bibliothèque.
Vous choisissez les types de données en fonction de votre formulaire et de la façon dont vous comptez le distribuer. Vous pouvez lier le formulaire à au moins une source de données et associer les données à au moins un champ de votre conception de formulaire.

Type

Description
Bases de données OLEDB
Vous pouvez lier un formulaire à au moins une base de données pour assurer l'échange des données. Vous pouvez remplir les champs avec les données provenant d'une base de données ou intégrer à la base de données les données introduites dans le formulaire. Acrobat prend en charge l'échange de données au moyen de liaisons côté client pour les formulaires interactifs. Pour plus de détails, voir Pour établir une connexion à une base de données OLE.
Schémas XML
Un schéma XML spécifie la façon formelle de décrire les éléments d'un document XML. Vous pouvez lier un schéma XML à un formulaire et associer aux champs de ce dernier des éléments et attributs spécifiques et définis dans le schéma. Vous pouvez utiliser cette méthode pour mapper des données vers ou depuis les champs du formulaire dans un format compatible avec le schéma. Pour plus de détails, voir Pour établir une connexion à un schéma XML et à un fichier de données XML.
Fichiers de données XML
Si vous n'utilisez aucun schéma XML, vous pouvez lier un fichier de données XML à un formulaire et associer aux champs de ce dernier les éléments et attributs du fichier. Les données introduites dans le formulaire seront compatibles avec le fichier de données XML. Vous pouvez utiliser le fichier de données pour assurer le mappage des données vers ou depuis les champs du formulaire dans le format nécessaire. Pour plus de détails, voir Pour établir une connexion à un schéma XML et à un fichier de données XML.
Services Web (WSDL)
Les services Web proposent des fonctions et des données à d'autres applications par le biais d'Internet en utilisant des normes telles que SOAP plutôt que HTTP. Le service Web peut recevoir et exécuter une commande et retourner les résultats au formulaire. Vous pouvez lier un ou plusieurs services Web à un formulaire. Pour plus de détails, voir Pour établir une connexion à un fichier WSDL.
LiveCycle Designer propose des outils intégrés vous permettant de créer des sources de données, de les lier et de les importer ou de les exporter. Toutefois, les concepteurs de formulaires qui ne savent pas comment utiliser des sources de données doivent faire appel aux administrateurs de base de données et autres techniciens pour établir les connexions aux données.
Veuillez tenir compte des points suivants au moment de configurer et d'exécuter l'échange de données requis par votre formulaire :
      •
      Identifiez les sources de données qui seront utilisées pour recueillir les données entrées par l'utilisateur et pour les importer vers les champs du formulaire.
      •
      Pour définir la structure des données, vous aurez à choisir entre l'association de champs à un schéma XML ou à un fichier de données.
      •
      Obtenez des informations sur le mappage de données, y compris les types et structures de données utilisés par la source de données existante.
dans Acrobat, pour des raisons de sécurité, vous ne pouvez pas utiliser la syntaxe Driver=; pour spécifier une chaîne de connexion ODBC. Il faut donc s'assurer de définir un DSN pour la connexion ODBC du système client. De même, pour utiliser des sources de données externes dans un formulaire que vous souhaitez rendre disponible avec Adobe Reader, vous devez configurer les droits d'accès au formulaire à l'aide de LiveCycle Reader Extensions.
Voir aussi
A propos des sources de données
A propos de la connexion à une source de données


Connexion à une source de données

A propos de la connexion à une source de données
Pour travailler à partir de la palette Vue des données
Pour établir une connexion à un schéma XML et à un fichier de données XML
Pour établir une connexion à un fichier de données XML
Pour établir une connexion à une base de données OLE
Pour établir une connexion à un fichier WSDL
Pour exécuter la connexion au service Web
Pour supprimer une connexion aux données
Pour modifier une connexion aux données


A propos de la connexion à une source de données

La connexion d'une conception de formulaire à une source de données constitue la première étape de la liaison des données aux champs de la conception de formulaire. Une fois que vous avez défini une ou plusieurs sources de données dans une conception de formulaire, la palette Vue des données affiche leur hiérarchie. Les noeuds supérieurs de la hiérarchie représentent chacune des connexions et affichent le nom que vous avez attribué aux connexions lors de leur création.
Après avoir créé une connexion aux données, vous devez lier les données aux champs de la conception de formulaire.
Voir aussi
Liaison de champs à une source de données


Pour travailler à partir de la palette Vue des données

      •
      Pour afficher les détails des noeuds, choisissez Afficher info dans le menu de la palette.
      •
      Pour développer un noeud, cliquez sur le signe plus (+).
      •
      Pour réduire un noeud, cliquez sur le signe moins (-).
      •
      Pour afficher la description de données du noeud (à raison de 25 caractères au maximum), choisissez Afficher les descriptions de données dans le menu de la palette. En l'absence de légende pour le noeud, le nom de données est affiché. Vous devez être connecté à une source de données décrivant les données.
      •
      Pour afficher simultanément le nom de données et la description du noeud, choisissez Afficher les deux dans le menu de la palette. Vous devez être connecté à une source de données décrivant les données.
Voir aussi
Menu de la palette Vue des données
A propos de la liaison de champs à une source de données


Pour établir une connexion à un schéma XML et à un fichier de données XML

Vous pouvez importer une définition de schéma XML dans une conception de formulaire et lier les objets de cette conception de formulaire aux éléments et aux attributs de la définition de schéma XML.
si vous importez un schéma XML qui contient un élément de schéma <xs:include> ou <xs:import>, l’attribut schemaLocation de l’élément doit être paramétré sur une référence de fichier figurant sur le système de fichiers local.
1.
Effectuez l'une des opérations suivantes :
      •
      Choisissez Fichier > Nouvelle connexion aux données.
      •
      Sélectionnez un objet dans la page, puis cliquez sur l'onglet Liaison de la palette Objet et sélectionnez Nouvelle connexion aux données dans le menu Par défaut.
2.
Dans la zone Nommer la nouvelle connexion, saisissez le nom de la connexion.
Le nom doit être formé d’un seul mot et ne doit pas dépasser 127 caractères. Le premier caractère du nom doit être une lettre ou un trait de soulignement (_). Les autres caractères peuvent être des lettres, des chiffres, des tirets (-), des traits de soulignement (_) ou des points (.).
3.
Sélectionnez Schéma XML et cliquez sur Suivant.
4.
Effectuez l'une des opérations suivantes :
      •
      Cliquez sur Parcourir [image] pour rechercher et sélectionner le fichier de schéma XML voulu.
      •
      Saisissez ou collez l'emplacement URL du fichier de schéma XML dans le champ Sélectionner un fichier de schéma XML.
5.
Choisissez une ou plusieurs des options suivantes :
      •
      Dans la zone Utiliser le nom d'élément racine de données XML, sélectionnez l'élément racine qui servira à nommer le sous-formulaire racine de la conception de formulaire. La liste déroulante propose toutes les déclarations d'éléments contenues dans le schéma XML.
      •
      (Facultatif) Sélectionnez l'option Incorporer le schéma XML pour incorporer le schéma en tant que paquet dans le fichier XPD.
      •
      (Facultatif) Sélectionnez l’option Transformer les données d’entrée, puis cliquez sur Parcourir [image] pour rechercher et sélectionner le fichier XSLT qui servira à transformer les données d’entrée de la conception de formulaire.
      •
      (Facultatif) Sélectionnez l'option Transformer les données de sortie, puis cliquez sur Parcourir [image] pour rechercher et sélectionner le fichier XSLT qui servira à transformer les données de sortie de la conception de formulaire.
6.
Cliquez sur Terminer. Les données s'affichent dans la palette Vue des données.
le symbole @ placé devant un nom dans la palette Vue des données indique que ce noeud est un attribut d'un noeud d'option et #data indique la valeur réelle du noeud d’ option.
Voir aussi
A propos de la liaison de champs à une source de données
Pour créer un champ ou un sous-formulaire lié


Pour établir une connexion à un fichier de données XML

Si vous ne disposez pas d’un schéma XML, vous pouvez établir une connexion à un fichier XML qui servira d’exemple de données.
1.
Effectuez l'une des opérations suivantes :
      •
      Choisissez Fichier > Nouvelle connexion aux données.
      •
      Sélectionnez un objet de la page. Dans la palette Objet, cliquez sur l'onglet Liaison et sélectionnez Connexion aux données dans la zone de liste Liaison par défaut.
2.
Dans la zone Nommer la nouvelle connexion, saisissez le nom de la connexion.
Le nom doit être formé d’un seul mot et ne doit pas dépasser 127 caractères. Le premier caractère du nom doit être une lettre ou un trait de soulignement (_). Les autres caractères peuvent être des lettres, des chiffres, des tirets (-), des traits de soulignement (_) ou des points (.).
3.
Sélectionnez Exemple de données XML et cliquez sur Suivant.
4.
Cliquez sur Parcourir [image] pour rechercher et sélectionner le fichier XML voulu.
5.
Sélectionnez une ou les deux options suivantes :
      •
      (Facultatif) Sélectionnez l’option Transformer les données d’entrée, puis cliquez sur Parcourir [image] pour rechercher et sélectionner le fichier XSLT qui servira à transformer les données d’entrée de la conception de formulaire.
      •
      (Facultatif) Sélectionnez l'option Transformer les données de sortie, puis cliquez sur Parcourir [image] pour rechercher et sélectionner le fichier XSLT qui servira à transformer les données de sortie de la conception de formulaire.
6.
Cliquez sur Terminer. Les données s'affichent dans la palette Vue des données.
Voir aussi
A propos de la liaison de champs à une source de données
Pour créer un champ ou un sous-formulaire lié


Pour établir une connexion à une base de données OLE

Vous pouvez faire en sorte que votre formulaire ait accès aux informations d'une base de données. Par exemple, il peut être intéressant d'extraire des données pour remplir un formulaire d'après une valeur, comme l’ID d'employé, que l’utilisateur entre lorsqu'il remplit le formulaire. Lorsque l'utilisateur saisit son numéro d'identification, cela déclenche une recherche dans la base de données afin d’extraire l'enregistrement correspondant et de l'afficher dans le formulaire.
Pour afficher, insérer, mettre à jour ou supprimer des données dans une base de données, vous établissez une connexion à la base de données, puis liez les champs du formulaire aux colonnes correspondantes d'une table de la base de données.
Vous pouvez aussi utiliser des scripts pour effectuer l'insertion, la mise à jour ou la suppression d'enregistrements, ainsi que pour naviguer parmi les enregistrements d'une base de données.
Le développeur d'application détermine à quel moment utiliser une base de données plutôt que, par exemple, un fichier de données XML. Vous pouvez configurer plusieurs connexions pour un formulaire (une connexion à une base de données et une à un fichier XML) et lier individuellement les champs à l'une ou l'autre des connexions.
La base de données OLE est la seule à laquelle vous pouvez établir une connexion à partir de LiveCycle Designer. Grâce au fournisseur de la base de données OLE de Microsoft pour les pilotes ODBC, vous pouvez accéder aux bases de données qui sont identifiées par un nom de source de données ODBC (DSN). Vous pouvez utiliser des pilotes OLE autres que ce fournisseur. Cependant, le formulaire doit être certifié dans Acrobat pour fonctionner à l'exécution.
Dans Acrobat, pour des raisons de sécurité, vous ne pouvez pas spécifier une chaîne de connexion à une base de données OLE en utilisant la syntaxe Driver=; . Par conséquent, l'ordinateur client doit avoir un DSN configuré en fonction de connexions à une base de données OLE.
Si vous utilisez des sources de données externes dans une conception de formulaire qui doit être remplie par des utilisateurs dans Adobe Reader, vous devez définir les droits d'accès au formulaire par le biais de LiveCycle Reader Extensions.
1.
Effectuez l'une des opérations suivantes :
      •
      Choisissez Fichier > Nouvelle connexion aux données.
      •
      Sélectionnez un objet de la page. Dans la palette Objet, cliquez sur l'onglet Liaison et sélectionnez Connexion aux données dans la zone de liste Liaison par défaut.
2.
Dans la zone Nommer la nouvelle connexion, saisissez le nom de la connexion.
Le nom doit être formé d’un seul mot et ne doit pas dépasser 127 caractères. Le premier caractère du nom doit être une lettre ou un trait de soulignement (_). Les autres caractères peuvent être des lettres, des chiffres, des tirets (-), des traits de soulignement (_) ou des points (.).
3.
Sélectionnez Base de données OLE et cliquez sur Suivant.
4.
Dans la boîte de dialogue Connexion à la base de données OLE, saisissez la chaîne de connexion à la base de données. Pour obtenir de l'aide pour cette étape, voir la documentation du fournisseur de la base de données.
5.
Sélectionnez l'une des options suivantes, puis cliquez sur Suivant :
      •
      Activez l'option Table et sélectionnez la table qui servira de source de données. Les tables proposées dans la liste proviennent de la base de données correspondant à la chaîne de connexion.
      •
      Activez l'option Procédure enregistrée et sélectionnez la source d'enregistrement voulue dans la liste. Les procédures proposées dans la liste sont celles qui sont disponibles dans la base de données.
      •
      Activez l'option Requête SQL et saisissez la chaîne de la requête SQL.
6.
Saisissez vos nom utilisateur et mot de passe dans les zones correspondantes et définissez les options ADO recordset appropriées.
7.
Cliquez sur Suivant. LiveCycle Designer vérifie si la connexion à la base de données a été établie et vous demande de vous identifier, le cas échéant.
8.
Cliquez sur Terminer. Les données s'affichent dans la palette Vue des données.
Voir aussi
Comment LiveCycle Designer détermine le type de champ au moment de lier les données


Pour établir une connexion à un fichier WSDL

Un service Web, tel qu’il est défini par un document de langage de description de service Web (WSDL), présente un certain nombre d'opérations. Pour chacune des opérations, le fichier WSDL peut définir un message d’entrée, un message de sortie, ou les deux. Les messages d'entrée sont envoyés à un serveur. Ce dernier peut ainsi répondre par un message de sortie. Vous pouvez créer des champs dans une conception de formulaire et les lier à un ou à plusieurs services Web.
La connexion WSDL diffère des autres types de connexions aux données. Une opération de service Web ressemble à un appel de fonction comportant des paramètres d'entrée ou de sortie, ou les deux. Un ou plusieurs champs peuvent être la source du message d'entrée et la destination du message de sortie.
En utilisant LiveCycle Designer et une connexion WSDL, vous pouvez effectuer les tâches suivantes :
      •
      Lier une ou plusieurs opérations à l’intérieur d'un ou de plusieurs services Web.
      •
      Relier des champs, des sous-formulaires et des groupes d’exclusion à l'événement Click d’un bouton qui exécute une opération de service Web.
      •
      Exécuter une opération de service Web à partir de n'importe quel script d'événement.
      •
      Permettre à tous les éléments retournés par un service Web d’accéder à un script, qu’ils soient ou non liés à des champs.
      •
      Utiliser le style de communication du service SOAP 1.1 (liaisons SOAP et transport HTTP).
      •
      Echanger des données avec un service Web par le biais du format d’échange de données/littéraux.
      •
      Ecrire des scripts côté client au moyen de l’objet JavaScript SOAP d’Acrobat (qui prend en charge les données codées RPC).
Voici les fonctions qui ne sont pas prises en charge :
      •
      Certaines fonctions de schéma XML
      •
      Certains protocoles tels que SMTP, FTP, etc. comme moyen de transport sous-jacent du service SOAP
      •
      Les éléments de type extensible
      •
      La recherche de services Web à l’aide de l’annuaire UDDI
      •
      Les messages SOAP codés RPC (Remote Procedure Call)
      •
      L’utilisation des liaisons HTTP POST et GET WSDL
1.
Choisissez Fichier > Nouvelle connexion aux données.
2.
Dans la zone Nommer la nouvelle connexion, saisissez le nom de la connexion.
Le nom doit être formé d’un seul mot et ne doit pas dépasser 127 caractères. Le premier caractère du nom doit être une lettre ou un trait de soulignement (_). Les autres caractères peuvent être des lettres, des chiffres, des tirets (-), des traits de soulignement (_) ou des points (.).
3.
Sélectionnez Fichier WSDL et cliquez sur Suivant.
4.
Si le fichier se trouve sur votre ordinateur, cliquez sur Parcourir [image] pour rechercher et sélectionner le fichier voulu. Dans le cas contraire, saisissez l’URL menant au fichier WSDL dans la zone Fichier WSDL.
5.
Cliquez sur Suivant et sélectionnez l’opération que vous voulez appeler.
Le panneau de droite affiche des renseignements sur l’opération sélectionnée. Si l’opération n’est pas codée pour SOAP ou n’est pas un document ou un littéral, le système affiche un avertissement et vous ne pouvez pas continuer votre travail.
6.
Cliquez sur Terminer.
Voir aussi
Pour exécuter la connexion au service Web


Pour exécuter la connexion au service Web

Vous pouvez exécuter la connexion au service Web de différentes façons.
Pour exécuter la connexion au service Web à l'aide d'un bouton
Lorsqu’il s’agit d’une connexion WSDL, la palette Vue des données comporte un noeud qui représente un bouton.
      *
      Faites glisser le noeud représentant un bouton sur la conception de formulaire. Ce bouton a pour effet d'exécuter l'opération de cette connexion.
Pour exécuter la connexion au service Web à partir d'un autre événement
Vous pouvez exécuter la connexion à un service Web à partir d’un autre événement plutôt que d’un bouton. Par exemple, si vous voulez transmettre une valeur choisie dans une liste.
      *
      Entrez le script suivant pour l'événement permettant de déclencher le service Web :
En langage JavaScript : xfa.connectionSet.MyWSDLDataConnection.execute(0);
En langage FormCalc : $connectionSet.MyWSDLDataConnection.execute(0)
Dans les deux cas, le paramètre transmis est une valeur booléenne. Lorsque le service Web retourne les résultats, cette valeur indique si l’objet DOM de données entier doit être fusionné avec le formulaire ou si les valeurs retournées remplacent celles qui se trouvent dans l’occurrence active du formulaire. La valeur zéro (0) indique que les données ne seront pas fusionnées à nouveau : aucun nouveau champ ou aucun nouveau sous-formulaire ne sera ajouté ou supprimé à la suite de cette opération d’exécution. La valeur un (1) indique que toutes les données de l’objet DOM seront à nouveau fusionnées.
Pour afficher les informations de connexion associées à un bouton
1.
Sélectionnez un bouton sur la page.
2.
Dans la palette Objet, cliquez sur l’onglet Exécuter et consultez les renseignements affichés sous Info sur la connexion.


Pour supprimer une connexion aux données

Vous pouvez supprimer une connexion aux données qui a été définie dans la conception de formulaire.
1.
Dans la palette Vue des données, sélectionnez la connexion aux données que vous voulez supprimer.
2.
Dans le menu de la palette, choisissez Supprimer la connexion aux données.
3.
Sélectionnez une des options suivantes :
      •
      Pour supprimer les liaisons en plus de la connexion à la base de données, cochez la case Rompre les liaisons des connexions de données supprimées.
      •
      Pour supprimer la connexion aux données tout en conservant les liaisons aux données, désactivez la case Rompre les liaisons des connexions de données supprimées. Les liaisons sont des références aux données de la conception de formulaire et sont toujours valables, même en l’absence d’une connexion aux données, pourvu que les données ne changent pas.
4.
Cliquez sur Supprimer.


Pour modifier une connexion aux données

Vous pouvez modifier la plupart des propriétés d’une connexion aux données, à l’exception du type de description de données.
1.
Dans la palette Vue des données, sélectionnez la connexion aux données que vous voulez modifier.
2.
Dans le menu de la palette, choisissez Propriétés de la connexion.
3.
Apportez les changements nécessaires. Cliquez sur Suivant pour passer aux autres boîtes de dialogue.
4.
Cliquez sur Terminer.


Liaison de champs à une source de données

A propos de la liaison de champs à une source de données
Pour créer un champ ou un sous-formulaire lié
Pour lier un noeud à un champ existant
Pour générer des champs liés dans un sous-formulaire
Méthodes pour afficher les mêmes données à différents endroits
Pour lier des champs multiples à un noeud unique
Pour utiliser un script pour afficher dans un champ les données saisies dans un autre champ
Pour définir les options de génération de champs
Pour supprimer une liaison
Pour actualiser les connexions aux données
Pour afficher la liste des champs liés


A propos de la liaison de champs à une source de données

Lorsque vous liez les champs d'une conception de formulaire à une source de données, vous établissez un lien entre ces deux éléments qui vous permet de saisir, présenter, déplacer, traiter, afficher et imprimer les informations associées à la conception de formulaire.
Si des champs d'un formulaire sont liés à une source de données, les données qui ne sont pas liées sont perdues si le formulaire est enregistré dans Acrobat. Si vous souhaitez lier des champs à une source de données, tous les champs dont vous voulez enregistrer les données doivent être liés.
LiveCycle Designer permet d'établir des liaisons côté client ou côté serveur. Les liaisons côté client permettent d'apporter immédiatement des modifications aux données. Les liaisons côté serveur exigent que vous envoyiez à nouveau au serveur les modifications apportées aux données.
Pour être en mesure d’établir des liaisons côté client, vous devez avoir installé Acrobat ou Adobe Reader (et disposer d’un formulaire avec les droits nécessaires). Pour établir des liaisons côté serveur, LiveCycle Forms doit être installé sur un serveur Microsoft.
Pour créer un champ ou un sous-formulaire lié, utilisez l'une des méthodes suivantes :
Créer de nouveaux objets de formulaire à partir de la palette Vue des données
Vous pouvez faire glisser, sur la page, un noeud (avec ou sans son arborescence) à partir de la palette Vue des données pour créer automatiquement un champ lié ou plusieurs champs ou sous-formulaires liés. Le champ de formulaire ou le sous-formulaire, et ses descendants, sont alors liés à la source de données. En outre, les propriétés du champ de formulaire sont automatiquement définies pour correspondre à celles de la liaison des données. Par exemple, le type, le nom et la légende du type d’objet de formulaire sont identiques à ceux de l’objet de liaison.
Associer un noeud de la palette Vue des données à un champ de formulaire existant
Vous pouvez faire glisser un noeud de la palette Vue des données vers un champ de formulaire de la page pour les lier. Vous avez aussi la possibilité de mettre à jour les propriétés du champ de formulaire pour les faire correspondre avec celles de l’objet de liaison. Les propriétés disponibles pour la mise à jour varient en fonction des types de l'objet de formulaire et de l'objet de liaison. Pour plus d'informations sur la mise à jour de ces propriétés, voir Boîte de dialogue Propriétés de liaison.
Sélectionner le noeud de liaison à l'aide de l'onglet Liaison de la palette Objet
Sélectionnez un objet de la page, puis sélectionnez le noeud auquel vous souhaitez le lier dans l'onglet Liaison de la palette Objet. La mise à jour des propriétés des champs de formulaire se présente de la même façon que lorsque vous faites glisser un noeud de la palette Vue des données vers un champ de formulaire existant. Pour plus d'informations sur la mise à jour de ces propriétés, voir Boîte de dialogue Propriétés de liaison.
Laisser à LiveCycle Designer le soin de générer automatiquement les champs liés dans un sous-formulaire
Vous pouvez générer de nouveaux champs liés dans un sous-formulaire à l'aide de la palette Vue des données.
Voir aussi
Pour établir une connexion à une base de données OLE
Pour établir une connexion à un fichier WSDL


Pour créer un champ ou un sous-formulaire lié

1.
Optez pour l'une des méthodes suivantes :
      •
      Pour créer des champs liés à partir de tous les noeuds de la palette Vue de données, faites glisser le noeud supérieur d’une connexion aux données vers la page. LiveCycle Designer crée des sous-formulaires et des objets liés à chaque noeud de la hiérarchie.
      •
      Pour créer un champ lié, faites glisser un noeud sur la page.
      •
      Pour créer un sous-formulaire lié, faites glisser le noeud et ses descendants sur la page.
2.
Positionnez les objets et les sous-formulaires sur la page selon vos besoins.
Voir aussi
Pour établir une connexion à une base de données OLE
Pour établir une connexion à un fichier WSDL


Pour lier un noeud à un champ existant

Vous pouvez lier un noeud à un champ existant à l'aide de la palette Vue des données ou Objet.
Pour lier un noeud à un champ existant à l'aide de la palette Vue des données
1.
Dans la palette Vue des données, sélectionnez le noeud de votre choix et faites-le glisser vers le champ de la page.
2.
Dans la boîte de dialogue Propriétés de la liaison, sélectionnez l'une des options suivantes :
      •
      Mettre à jour toutes les propriétés connexes
      •
      Mettre à jour uniquement les propriétés suivantes
      •
      Ne pas mettre à jour les propriétés connexes
3.
Cliquez sur OK. Que vous mettiez à jour ses propriétés ou non, l’objet de formulaire est à présent lié à la source de données.
Pour lier un noeud à un champ existant à l'aide de la palette Objet :
1.
Sur la page, sélectionnez l'objet que vous voulez lier à un noeud.
2.
Dans la palette Objet, cliquez sur l'onglet Liaison et sélectionnez le noeud dans la liste Par défaut.
3.
Dans la boîte de dialogue Propriétés de la liaison, sélectionnez l'une des options suivantes :
      •
      Mettre à jour toutes les propriétés connexes
      •
      Mettre à jour uniquement les propriétés suivantes
      •
      Ne pas mettre à jour les propriétés connexes
4.
Cliquez sur OK. Que vous mettiez à jour ses propriétés ou non, l’objet de formulaire est maintenant lié à la source de données.
Voir aussi
Pour établir une connexion à une base de données OLE
Pour établir une connexion à un fichier WSDL


Pour générer des champs liés dans un sous-formulaire

1.
Sélectionnez le sous-formulaire dans lequel vous voulez générer les champs liés.
2.
Dans la palette Vue des données, sélectionnez le noeud pour lequel vous voulez créer les noeuds feuille dans le sous-formulaire.
3.
Dans le menu de la palette, sélectionnez Générer les champs. Les nouveaux champs correspondant au noeud sont créés dans le sous-formulaire.
Voir aussi
Pour établir une connexion à une base de données OLE
Pour établir une connexion à un fichier WSDL


Méthodes pour afficher les mêmes données à différents endroits

Vous pouvez afficher les mêmes données à plusieurs endroits via diverses méthodes :
      •
      Définir plusieurs champs en tant que champs globaux pour afficher les mêmes données saisies interactivement.
      •
      Lier plusieurs champs à un noeud pour afficher les mêmes données d'une source de données dans les champs.
      •
      Utiliser un script pour afficher dans un champ les données saisies dans un autre champ.
Le tableau compare les champs globaux, la liaison de champs multiples à un noeud unique et l'utilisation d'un script pour l'affichage dans un champ des données saisies dans un autre champ.

Comparaison...

Champs globaux

Liaison

Script
Ce qui se produit
LiveCycle Designer affiche la même valeur dans tous les champs portant le même nom.
LiveCycle Designer affiche la même valeur dans tous les champs dotés de la même liaison.
LiveCycle Designer affiche dans un champ les données saisies dans un autre champ.
Noms des champs
Les noms doivent être identiques.
Les noms peuvent être différents.
Les noms peuvent être différents.
Propriétés d'exécution (notamment la page active, le nombre de pages et la date/l'heure actuelle)
Il n'est pas possible d'ajouter des propriétés d'exécution au champ.
Il n'est pas possible d'ajouter des propriétés d'exécution au champ.
Il est possible d'ajouter des propriétés d'exécution au champ.
En cas de suppression...
Si vous supprimez le paramètre global d'un champ, LiveCycle Designer supprime le paramètre de tous les autres champs portant le même nom.
Si vous supprimez la liaison d'un champ, les autres champs la conservent.
Sans objet
Référence aux noeuds
Les champs globaux peuvent se référer aux noeuds hors de l'enregistrement actif.
Les données de liaison explicites font référence aux noeuds dans l'enregistrement actif.
Sans objet
Exemple d'utilisation
A utiliser en cas de répétition d'informations dans le formulaire, notamment le nom ou l'adresse du client. L'utilisateur saisit les informations une fois et les données sont automatiquement saisies dans les autres champs définis en tant que champs globaux.
A utiliser si vous voulez une instance unique de données à partir d'une source de données affichée dans plusieurs champs.
A utiliser pour copier les données saisies à partir d'un nom de contact à la page 1 et les afficher dans une lettre à la page 2.
Le diagramme affiche ce qui se produit lorsque vous définissez plusieurs champs en tant que champs globaux. Le nom et l'adresse s'affichent sur la page 2 une fois que l'utilisateur a saisi le nom et l'adresse à la page 1.
Le diagramme affiche ce qui se produit lorsque vous liez plusieurs champs à un noeud. Le nom et l'adresse sont saisis à partir de la source de données.
Le diagramme affiche ce qui se produit lorsque vous utilisez un script pour afficher dans un champ les données saisies dans un autre champ. Le Nom de contact dans la lettre est identique au nom saisi dans le champ Nom à la page 1.
Voir aussi
Pour définir un champ global
Pour lier des champs multiples à un noeud unique
Pour utiliser un script pour afficher dans un champ les données saisies dans un autre champ


Pour lier des champs multiples à un noeud unique

Vous pouvez lier plusieurs champs à un noeud en effectuant l'une des actions suivantes :
      •
      Associer un noeud de la palette Vue des données à des champs de formulaire existants à l'aide de la méthode glisser-déposer.
      •
      Spécifier explicitement le noeud de liaison en utilisant l'onglet Liaison de la palette Objet pour les champs de formulaire existants.
Ne liez qu'une seule instance de données à plusieurs champs. Ne liez pas de données qui se répètent à plusieurs champs.
1.
Dans la palette Vue des données, sélectionnez le noeud de votre choix et faites-le glisser vers le champ de la page.
2.
Dans la boîte de dialogue Propriétés de la liaison, sélectionnez l'une des options suivantes :
      •
      Mettre à jour toutes les propriétés connexes
      •
      Mettre à jour uniquement les propriétés suivantes et sélectionner les options voulues
      •
      Ne pas mettre à jour les propriétés connexes
3.
Cliquez sur OK. Que vous mettiez à jour ses propriétés ou non, l’objet de formulaire est maintenant lié à la source de données.
4.
Sélectionnez le même noeud à l'étape 1 et répétez les étapes 2 et 3 pour les autres champs que vous voulez lier au même noeud.
Voir aussi
Pour définir un champ global
Pour utiliser un script pour afficher dans un champ les données saisies dans un autre champ


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation de sources de données > Liaison de champs à une source de données > Pour utiliser un script pour afficher dans un champ les données saisies dans un autre champ

Pour utiliser un script pour afficher dans un champ les données saisies dans un autre champ

Vous pouvez utiliser un script pour afficher dans un champ les données saisies dans un autre champ. Vous pouvez exécuter ce script sur des événements spécifiques orientés champ qui se déclenchent en réponse à des actions utilisateur.
Par exemple, un formulaire interactif peut inviter un utilisateur à saisir le nom d'un service. Ce nom peut s'afficher sur les pages suivantes du formulaire (s'il s'agit d'un formulaire interactif contenant plusieurs pages). Le champ pour le nom du service est lié à un champ de données et c'est dans ce dernier que le nom est enregistré. Pour afficher le nom du service sur les autres pages, le contenu du champ de saisie doit également s'afficher sur les autres pages. Les autres instances ne doivent pas nécessairement être modifiables et peuvent faire partie d'un autre champ (notamment un champ flottant). Dans ce cas, vous utilisez un script pour copier le nom du service dans d'autres champs.
1.
Sélectionnez le premier champ.
2.
Si l'éditeur de script n'est pas affiché à l'écran, choisissez Fenêtre > Editeur de script.
3.
(Facultatif) Cliquez sur le bouton permettant de développer la palette (situé en bordure de la palette).
4.
Dans la zone de liste Afficher, sélectionnez un événement orienté champ.
Par exemple, sélectionnez Quitter dans la liste Afficher.
5.
Dans la liste Langage, sélectionnez JavaScript, puis choisissez Client dans la liste Exécuter sur.
6.
Dans le champ Source du script, saisissez le script.
Par exemple, rédigez le script suivant :
ContactName.rawValue = this.rawValue;
Le nom de contact est le nom du deuxième champ dans le panneau Liaison de la palette Objet.
7.
Cliquez sur Insérer les changements dans la source du script pour ajouter le script à votre formulaire.
8.
Sélectionnez le deuxième champ.
9.
Dans la palette Objet, cliquez sur l’onglet Valeur et, dans la liste Type, choisissez Calculé - Lecture seule.
Voir aussi
Pour lier des champs multiples à un noeud unique
Pour définir un champ global
A propos des calculs et des scripts


Pour définir les options de génération de champs

Vous pouvez spécifier les options suivantes qui sont appliquées lorsque vous générez un champ ou un groupe de champs :
      •
      Générer les scripts de validation pour les nouveaux champs. Les scripts de validation qui sont générés sont de type JavaScript. Par exemple, un script de validation peut vérifier si la valeur spécifiée dans un champ se trouve dans la liste des valeurs acceptées.
      •
      Générer des descriptions.
      •
      Autoriser la génération de tableaux. Il est possible d'afficher dans un tableau des informations provenant d'une source de données. Lorsque vous vous connectez à une source de données, la palette Vues des données identifie tous les éléments qui peuvent être des tableaux. LiveCycle Designer affiche également les éléments susceptibles de devenir des rangées du tableau s'il détecte un groupe de données qui se répète.
1.
Dans le menu de la palette Vue des données, choisissez Options.
2.
Désactivez l'une des options suivantes :
      •
      Générer les scripts de validation, pour désactiver cette fonction.
      •
      Générer des descriptions, pour désactiver cette fonction.
      •
      Autoriser la génération de tableaux
3.
Cliquez sur OK.
Voir aussi
Comment LiveCycle Designer détermine le type de champ au moment de lier les données


Pour supprimer une liaison

Vous pouvez supprimer une liaison à des champs ou à des sous-formulaires.
1.
Sélectionnez les objets dont vous voulez supprimer la liaison.
2.
Dans la palette Objet, cliquez sur l'onglet Liaison et sélectionnez l'option Aucune dans la liste Par défaut. Puisque l'objet ne recueille pas et n'affiche pas de données, toute information qui lui est associée n'est pas affichée dans la sortie au moment de l'enregistrement des données du formulaire.
si vous supprimez des liaisons d'un sous-formulaire, celui-ci n'est pas pris en compte lors des opérations de fusion de données bien que ses objets (y compris les sous-formulaires imbriqués) puissent tout de même saisir et afficher des données.
Voir aussi
Pour établir une connexion à une base de données OLE
Pour établir une connexion à un fichier WSDL


Pour actualiser les connexions aux données

Vous pouvez actualiser toutes les connexions aux données définies dans la conception de formulaire. Cette commande est utile lorsque vous avez modifié des fichiers ou des bases de données et que vous voulez mettre la conception de formulaire à jour.
      *
      Dans le menu de la palette Vue des données, choisissez Actualiser la vue des données.
Voir aussi
Pour établir une connexion à une base de données OLE
Pour établir une connexion à un fichier WSDL


Pour afficher la liste des champs liés

Vous pouvez générer une liste pour les types de champs suivants :
      •
      Champs présentant une liaison normale
      •
      Champs liés à une référence de données
      •
      Champs présentant une liaison globale
      •
      Champs sans liaison
      •
      Noeuds de connexion aux données non liés
1.
Dans la palette Rapport, cliquez sur l'onglet Associations.
2.
Dans la zone de liste du panneau Associations, sélectionnez l'option appropriée et exécutez une commande de menu :
      •
      Pour afficher la liste des champs qui ont une liaison normale, sélectionnez Champs avec liaison de données normale.
      •
      Pour afficher la liste des champs qui ont une liaison de données par référence, sélectionnez Champs avec liaison de données par référence.
      •
      Pour afficher la liste des champs qui ont une liaison globale, sélectionnez Champs avec liaisons de données globales.
      •
      Pour afficher la liste des champs qui n'ont pas de liaison, sélectionnez Champs sans liaison de données.
      •
      Pour afficher la liste des champs non liés, sélectionnez Noeuds de connexion de données non liées.
Voir aussi
Comment LiveCycle Designer détermine le type de champ au moment de lier les données


Types de fichiers

Comment LiveCycle Designer détermine le type de champ au moment de lier les données
Types simples
Types complexes
Objets de texte enrichi
Images
Valeurs fixes/par défaut
Informations sur l'annotation
Espaces de nommage
Validation


Comment LiveCycle Designer détermine le type de champ au moment de lier les données

Une fois que vous avez créé une connexion aux données, vous pouvez générer des sous-formulaires et des champs qui correspondent à toutes ces données ou à une partie d'entre elles. Ces éléments contiennent souvent des données superflues. Pour les éviter, vous pouvez créer des sous-formulaires de façon sélective au lieu de choisir l'option permettant de tous les générer automatiquement. Une autre approche consiste à concevoir d'abord la conception de formulaire, puis à utiliser la palette Vue des données pour lier des champs spécifiques figurant dans la conception de formulaire à des noeuds de données spécifiques dans la hiérarchie.
LiveCycle Designer détermine quel champ créer lorsque vous liez des champs spécifiques d’un schéma XML, d’un fichier XML ou d’un fichier WSDL, ou encore lorsque vous générez des champs de la palette Vue des données en fonction des types d’éléments et d’attributs. Par exemple, une image sera associée à l'objet d'image statique dans la conception de formulaire.
Lorsque vous faites glisser sur la page un noeud de la palette Vue des données pour créer un champ ou un sous-formulaire, le système utilise le nom d'un élément ou d’un attribut de schéma XML comme nom du champ ou du sous-formulaire généré. Ce nom est également utilisé dans la légende du champ généré. La valeur de liaison du champ est utilisée pour lier le champ au noeud de données décrit dans la déclaration d'élément ou d'attribut du schéma.
La liste des sections « Voir aussi » fournie ci-dessous propose des informations supplémentaires sur la façon dont LiveCycle Designer détermine les champs à créer lorsque vous liez les champs d'un schéma XML, d'un fichier XML ou d'un fichier WSDL.
Voir aussi
Pour créer un champ ou un sous-formulaire lié
Pour établir une connexion à une base de données OLE
Pour établir une connexion à un fichier WSDL


Types simples

Les déclarations d'élément de schéma XML peuvent être de types simples ou complexes. Les éléments qui ne contiennent pas d'autres éléments ou attributs sont déclarés de type simple dans le schéma XML. Les déclarations d'attribut peuvent être de types simples. En règle générale, les éléments de types et d'attributs simples sont associés à des champs dans LiveCycle Designer. Le type du champ dépend de la valeur du type simple.
Types simples intégrés
Un schéma XML définit un certain nombre de types simples intégrés.
Les types suivants sont associés à un objet de champ de texte qui est un objet contenant du texte brut :
chaîne | normalizedString
token | Nom
NCName | QName
langue |
Les types suivants sont associés à un objet de champ numérique :
float | double
decimal | integer
long | int
short | byte
positiveInteger | nonPositiveInteger
negativeInteger | nonNegativeInteger
unsignedLong | unsignedInt
unsignedShort | unsignedByte
Les types suivants sont associés à des dates et des heures :

Date et heure

Type d'objet
duration
Champ de texte modifiable
dateTime
Champ de date et d'heure. Le type de contrôle est Date et Heure.
date
Champ de date et d'heure. Le type de contrôle est Date.
time
Champ de date et d'heure. Le type de contrôle est Time.
gYear
Champ de texte avec une clause d'image.
gYearMonth
Champ de texte avec une clause d'image.
gMonth
Champ de texte avec une clause d'image.
gMonthDay
Champ de texte avec une clause d'image.
gDay
Champ de texte avec une clause d'image.
Les types patrimoniaux suivants sont associés à un objet de champ de texte :
ID | IDREF
IDREFS | ENTITY
ENTITIES | NMTOKEN
NMTOKENS | NOTATION
Le tableau ci-dessous décrit à quoi correspondent les autres types :

Autre

Type d'objet
booléen
Case à cocher
hexBinary
Image statique
base64Binary
Image statique
anyURI
Champ de texte
Types simples restreints
Grâce aux restrictions de schéma XML, il est possible d'obtenir de nouveaux types simples à partir des types simples. La présente rubrique décrit comment ces restrictions peuvent être associées à des conceptions de formulaire.
Facettes d'énumération
Une déclaration d’élément ou d’attribut de schéma XML de n’importe quel type, qui déclare une ou plusieurs valeurs énumérées, génère un objet de liste déroulante plutôt que le champ par défaut associé au type de base de la déclaration, comme l’illustre l’exemple suivant :
<xsd:element name=”Colors”>
    <xsd:complexType>
        <xsd:simpleContent>
            <xsd:extension base=”xsd:string”>
                <xsd:enumeration value=”red”/>
                <xsd:enumeration value=”green”/>
                <xsd:enumeration value=”blue”/>
            </xsd:extension>
        </xsd:simpleContent>
    </xsd:complexType>
<xsd:element>
Les valeurs énumérées sont stockées en tant qu'éléments de la liste déroulante.
Facettes de borne, de taille et de précision
Lorsque cela est possible, les facettes de restriction qui gèrent les bornes (minInclusive, minExclusive, maxInclusive et maxExclusive), les tailles (length, minLength et maxLength) et la précision (totalDigits et fractionDigits) sont associées à des propriétés d'objets générés. Autrement, elles servent à générer des scripts de validation. Voici deux exemples :
      •
      La facette maxLength sert à définir les propriétés maxCars de la valeur de texte :

<field><value><text maxChars=”100”/></value></field>
      •
      La facette fractionDigits sert à définir la propriété fracDigits de la valeur décimale :

<field><value><decimal fracDigits=”3”/></value></field>
Types de liste et d'union
Les types de liste permettent de définir des types composés de listes de valeurs simples séparées par des blancs. Les éléments et les attributs de type liste sont associés à des objets de champ de texte.
Les types d'union sont des types dont les diverses valeurs permises proviennent de l’union de plusieurs ensembles de valeurs. Les différents ensembles ne sont pas nécessairement du même type de base. En règle générale, les types d'union sont associés à des objets de champ de texte. Cependant, lorsque tous les ensembles de l'union sont du même type, l'association est la même que celle des types qui utilisent un de ces ensembles (c’est-à-dire l'union de deux ensembles de valeurs énumérées génère une liste déroulante comportant toutes les valeurs de l'union).


Types complexes

Les déclarations d'élément de schéma XML peuvent être de types simples ou complexes. Les déclarations d'attribut peuvent être de types simples. En règle générale, les éléments de types et d'attributs simples sont associés à des champs dans LiveCycle Designer. Les éléments de types complexes contiennent d'autres éléments ou attributs et sont généralement associés à des sous-formulaires.
Les types complexes servent à définir tous les autres éléments. Ils peuvent définir un contenu d'élément, un contenu simple, un contenu mixte et un contenu vide.
Tout élément de type complexe peut déclarer ou non des attributs.
Génération d'un sous-formulaire à partir d’un élément d’une source de données
Un élément qui ne comporte que du contenu d'élément et, facultativement, des attributs, génère un sous-formulaire lorsqu'on le glisse dans un modèle de formulaire.
Ce sous-formulaire contient des objets pour chacun des attributs déclarés dans l'élément et des objets ou des sous-formulaires pour chacun des éléments enfant.
Contenu simple
Un contenu est simple lorsqu'un élément est déclaré comme ayant un contenu simple (données texte) et qu'il peut aussi déclarer des attributs. Si l'élément ne déclare aucun attribut, l'association est la même que celle des éléments simples.
Lorsque des attributs sont déclarés, les éléments sont associés à un sous-formulaire portant le même nom que celui de l'élément. Ce sous-formulaire contient un champ lié à l'élément et des champs supplémentaires pour chacun des attributs. Le champ lié porte le même nom que l’élément auquel il est lié, avec la chaîne “_data” en suffixe. Par exemple, l'élément <phone>a un contenu numérique et un attribut nommé type :
<phone type=”work”>5554567</phone>
Cela génèrera un sous-formulaire nommé phone qui contient les objets nommés type et phone_data. L'objet type est lié à $data...phone.type, le champ phone_data est lié à $data...phone.
Contenu mixte
Un contenu est considéré comme mixte lorsque la déclaration d'un élément indique qu’il contient un mélange d'éléments enfants et de contenu de texte brut.
Contenu vide
Les types complexes qui ont un contenu vide sont traités comme s'ils avaient un contenu simple. Ainsi, l’objet qui est créé et lié à l'élément ne peut pas avoir de contenu.
Occurrence
Les attributs d'occurrence d'un schéma XML (minOccurs et maxOccurs) pour les déclarations d'élément, qui génèrent des sous-formulaires, sont associés aux propriétés de répétition du sous-formulaire.
Modèles de contenu
Lorsque le modèle de contenu d’un élément enfant n'est pas une séquence, les associations tentent de modéliser le choix et tous les groupes à l'aide d’ensembles de sous-formulaires.


Objets de texte enrichi

Une déclaration d'élément qui définit le contenu à partir d'un schéma XHTML est associée à un objet de champ de texte enrichi plutôt qu'à un objet de champ de texte ordinaire. En d'autres termes, l'objet <field> créé dans la conception de formulaire contient <value><exData contentType=”text/html”/></value>.
Il existe trois cas dans lesquels un élément est identifié comme ayant un contenu de texte enrichi :
      •
      Le schéma importe le schéma XHTML et déclare un élément contenant un seul enfant, soit l'élément XHTML <body> , tel qu'il est illustré dans l'exemple ci-dessous :

    <xsd:schema xmlns:xsd=”http://www.w3.ord/2001/XMLSchema”
            xmlns:xhtml=”http://www.w3.ord/1999/xhtml”>
    <xsd:import namespace=”http://www.w3.org/1999/xhtml”/>
    <xsd:element name=”RichTextField”>
        <xsd:complexType>
            <xsd:sequence>
                <xsd:element ref=”xhtml:body”/>
            </xsd:sequence>
        </xsd:complexType>
    </xsd:element>
      •
      Un document schéma déclare un élément de type chaîne avec une valeur par défaut ou une valeur fixe qui commence par le contenu suivant :

<body xmlns=”http://www.w3.org/1999/xhtml” ...
Dans un tel cas, l'objet de texte enrichi est créé avec une valeur définie sur la valeur fixe ou sur la valeur par défaut.
      •
      Une déclaration d'élément comprend un attribut xfa:contentType avec une valeur fixe text/html, comme l'illustre l'exemple ci-dessous :

    <xsd:schema xmlns:xsd=”http://www.w3.ord/2001/XMLSchema”
                    xmlns:xfa=”http://www.adobe.com/2003/xfa”>
    <xsd:import namespace=”http://www.adobe.com/2003/xfa”/>
    <xsd:element name=”RichTextField”>
        <xsd:complexType>
            <xsd:simpleContent>
                <xsd:extension base=”xsd:string”>
                    <xsd:attribute ref=”xfa:contentType" fixed="text/html”/>
                </xsd:extension>
            </xsd:simpleContent>
        </xsd:complexType>
    </xsd:element>
Dans cet exemple, l'attribut xfa:contentType n’est pas utilisé pour générer un champ comme dans le cas d’un attribut général. Il est plutôt interprété comme une directive indiquant que le champ généré doit être un champ de texte enrichi. En ce qui concerne l'identificateur de l'espace de nommage, la conception de formulaire contient xmlns=”http://www.xfa.org/schema/xfa-template/2.1/ et le fichier XDP contient xmlns:xdp=”http://ns.adobe.com/xdp/.


Images

Une image est associée à l'objet de champ d’image statique dans la conception de formulaire. Les attributs sont les suivants :
xfa:contentType
xfa:href
xfa:transferEncoding
Voici un exemple de déclaration de ce type :
<xsd:schema xmlns:xsd=”http://www.w3.org/2001/XMLSchema”
        xmlns:xfa=”http://www.adobe.com/2003/xfa”>
<xsd:import namespace=”http//www.adobe.com/2003/xfa”>
<xsd:element name=”ImageField”>
    <xsd:complexType>
        <xsd:extension base=”xsd:hexBinary”>
            <xsd:attribute ref=”xfa:contentType” fixed=”image/jpg”/>
            <xsd:attribute ref=”xfa:transferEncoding” fixed=”base64”/>
        </xsd:extension>
    </xsd:simpleContent>
    </xsd:complexType>
</xsd:element>
Dans le cas présent, les attributs ne sont pas utilisés pour générer les champs de la conception de formulaire. Ils servent à reconnaître la correspondance de l'élément avec un champ d'image. Toutes les valeurs fixes ou par défaut des attributs sont définies dans l'élément <image> qui a été généré.


Valeurs fixes/par défaut

Les déclarations d'attribut et d'élément qui ont un type simple ou complexe, avec un contenu simple, peuvent définir une valeur fixe ou par défaut pour l'élément ou l'attribut.
Toute déclaration d'élément ou d'attribut qui définit une valeur fixe ou une valeur par défaut génère un champ où la valeur initiale est définie sur la valeur fixe ou sur la valeur par défaut spécifiée dans la déclaration.


Informations sur l'annotation

Toute information sur l'annotation qui survient en tant qu'enfant d'un <xsd:element> ou <xsd:attribute> dans le schéma XML est associée à un champ généré à partir de cette déclaration d'élément ou d'attribut en tant que contenu <desc> .


Espaces de nommage

Si l'entrée targetNamespace est définie dans le schéma XML, cette information est conservée et sert à identifier les éléments de données. Les informations de préfixe de namespace et namespace n'apparaissent pas dans la palette Vue des données ou dans les objets ou les sous-formulaires générés à partir de la connexion aux données. Toutefois, les informations de namespace sont préservées au moyen du dataDescription généré à partir du schéma utilisé pour mettre en correspondance la conception de formulaire et les données décrites dans le schéma XML.


Validation

Lorsque le schéma XML fournit des renseignements à propos des valeurs permises d'un élément ou d'un attribut (et, en conséquence, du champ correspondant dans le modèle), le champ généré inclut un script de validation JavaScript qui vérifie que la valeur fait partie des valeurs permises par la déclaration de schéma. De telles données peuvent être fournies par le type de données d'un élément ou d'un attribut de même que par les facettes de restriction appliquées au type de base. Observez l'exemple suivant :
<xsd:element name=”Number”>
    <xsd:simpleType>
        <xsd:restriction base=”xsd:integer”>
            <xsd:minInclusive value=”4”/>
            <xsd:maxInclusive value=”9”/>
        </xsd:restriction>
    </xsd:simpleType>
</xsd:element>
La mise en correspondance génère un champ numérique nommé « Number », lequel comporte un script de validation qui s'assure que la valeur est un nombre entier compris entre 4 et 9.
De nombreuses facettes de restriction fournies par le schéma XML fournissent des renseignements qui peuvent servir à générer un script de validation. Ces renseignements ne peuvent être utilisés que pour générer des scripts de validation dans les cas où les informations ne peuvent pas être associées directement à une propriété ; l'association de la facette maxLength de type chaîne à <text maxChars=« « > en est un exemple.
Scripts de type numérique
Tous les types numériques d'un schéma XML sont associés à une seul champ numérique. Cependant, les autres restrictions imposées par le type numérique d'un schéma XML sont conservées en générant des scripts de validation. Ces scripts vérifient que la valeur numérique définit la limite permise pour le type de schéma XML original. Un type « unsigned byte » (octet non signé) dans un schéma XML génère un champ numérique assorti d'un script qui vérifie que la valeur est bel et bien une valeur d'octet non signé ; voici le script généré :
this.rawValue >= 0 && this.rawValue <= 255;
Des scripts de vérification du respect de la plage sont générés pour les valeurs suivantes :
integer | positive integer
negative integer | non-positive integer
non-negative integer | long, int
short | byte
unsigned long | unsigned int
unsigned short | unsigned byte datatypes
Scripts d'inclusion et d'exclusion
Lorsqu'un type numérique indique des valeurs d'inclusion ou d'exclusion min ou max, un script est généré pour vérifier si la valeur entrée se trouve dans la plage définie par ces facettes de restriction. Dans le cas d'un champ déjà assorti d'un script de plage numérique, tel qu'il est défini à la rubrique Scripts de type numérique, le script vérifie la plage en fonction des paramètres les plus stricts : la plage datatype ou la plage d'inclusion/d'exclusion.
Scripts length, minLength et maxLength
Un type de chaîne schéma XML peut indiquer une facette de restriction de longueur ou une facette de longueur minimale (minLength) et/ou de longueur maximale (maxLength). Lorsque le noeud de schéma est associé à un champ de texte, les valeurs indiquées pour les facettes de restriction de longueur et de longueur minimale servent à générer un script de validation pour vérifier si la longueur du champ de texte a une valeur qui respecte la longueur ou la longueur minimale indiquée.
Remarquez que toute valeur de la facette maxLength est associée à la facette maxChars pour le champ de texte.
Lorsqu'un type chaîne est associé à une liste déroulante (à cause des valeurs énumérées) et aux facettes length ou min/maxLength, les valeurs déclencheront un script de validation qui vérifiera si la longueur de la valeur sélectionnée dans la liste est correcte, selon les facettes de longueur (length, minLength et maxLength).
Scripts totalDigits/fractionDigits
La facette totalDigits définit le nombre maximal de chiffres pouvant être utilisés comme décimales ou pour tout type de nombre entier (types de données : decimal, integer, positive integer, negative integer, non-positive integer, non-negative integer, long, int, short, byte, unsigned long, unsigned int, unsigned short et unsigned byte). La facette fractionDigits, qui ne s'applique qu'aux données décimales, définit le nombre maximal de décimales pouvant être utilisées.
Lorsque vous utilisez les facettes totalDigits ou fractionDigits pour un élément ou un attribut qui est associé à un champ numérique, un script de validation est généré pour vérifier si le nombre total de chiffres ou de décimales est permis par les facettes de restriction.


Remplissage dynamique des propriétés d'objets de formulaire à partir d'une source de données

A propos des propriétés dynamiques
Pour configurer les propriétés dynamiques
Pou remplir de façon dynamique une liste déroulante ou une zone de liste
Pour remplir de façon dynamique une liste déroulante ou une zone de liste à partir d'une connexion aux données OLE
Pour remplir de façon dynamique une légende
Pour remplir de façon dynamique un message de modèle de validation
Pour remplir de façon dynamique un message de script de validation
Pour remplir de façon dynamique une info-bulle
Pour remplir de façon dynamique du texte d'un lecteur d'écran
Pour remplir de façon dynamique un second champ après remplissage du premier
Pour modifier la liaison de données dynamique
Pour remplir de façon dynamique des propriétés d'objet de formulaire à l'aide de la méthode glisser-déposer
Pour supprimer la liaison de données dynamique


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation de sources de données > Remplissage dynamique des propriétés d'objets de formulaire à partir d'une source de données > A propos des propriétés dynamiques

A propos des propriétés dynamiques

Les propriétés dynamiques sont des propriétés d'objet de formulaire auxquelles des valeurs sont attribuées à partir d'une source de données et qui sont mises à jour au moment de l'exécution. Par exemple, les options d'une liste déroulante peuvent être complétées par une liste de pays stockée dans une source de données.
Les propriétés suivantes d'objets de formulaire sont dynamiques et peuvent être liées aux valeurs d'une source de données :
      •
      options d'une liste déroulante ou d'une zone de liste ;
      •
      légende ;
      •
      message de modèle de validation ;
      •
      message de script de validation ;
      •
      info-bulle ;
      •
      texte d'un lecteur d'écran.
Les propriétés dynamiques permettent de modifier des propriétés d'objets de formulaire en dehors de la conception de formulaire et de prendre en compte une source de données. Cela peut être utile dans les scénarios de déploiement et de maintenance.
En outre, la même source de données peut fournir des données à différentes conceptions de formulaire. Par exemple, une longue liste de pays peut être enregistrée dans un seul fichier de données et utilisée dans plusieurs formulaires. Vous pouvez utiliser une grande variété de sources de données, aussi bien des bases de données complexes que des fichiers XML simples.
Pour identifier les propriétés d'objets de formulaire pour lesquelles vous pouvez définir des propriétés dynamiques, LiveCycle Designer utilise des libellés actifs. Les libellés actifs peuvent être activés et désactivés en ouvrant la boîte de dialogue Outils > Options > Liaison de données et en sélectionnant l'option Afficher les propriétés dynamiques. Prenons l'exemple d'un libellé actif pour la légende d'une liste déroulante avant et après sa liaison dynamique à une source de données.
Dans la palette Vue des données, cette icône [image] indique que le noeud est lié dynamiquement à un objet.
si un noeud est lié à une propriété dynamique et à un champ, l'icône par défaut [image] s'affiche.
Pour remplir de façon dynamique les propriétés d'objet de formulaire à partir d'une source de données, vous devez d'abord lier ces propriétés à un fichier de données et pointer ensuite sur un fichier contenant les données à utiliser pour remplir les propriétés.
vous pouvez lier manuellement les propriétés d'objet de formulaire à un fichier de données si vous connaissez la structure du fichier de données attendue. Dans ce cas, vous n’avez pas besoin d'établir une connexion aux données.
Le tableau ci-dessous répertorie la liste des objets et leurs libellés actifs.

Libellé actif/Objet

Articles de liste

Valeurs élément

Légende

Message du modèle de validation

Message du script de validation

Info-bulle

Texte du lecteur d'écran personnalisé
Codes à barres
O
O
O
O
Bouton
O
O
O
Case à cocher
O
O
O
O
Date/Heure
O
O
O
O
O
Champ décimal
O
O
O
O
O
Champ de signature du document
O
O
O
Zone de liste déroulante
O
O
O
O
O
O
O
Bouton Envoyer par messagerie
O
O
O
Bouton Envoyer via HTTP
O
O
O
Image
O
O
Champ d'image
O
O
O
Zone de liste
O
O
O
O
O
O
O
Champ numérique
O
O
O
O
O
Champ du mot de passe
O
O
O
O
O
Bouton Imprimer
O
O
O
Bouton radio
O
O
O
Texte
O
O
Champ de texte
O
O
O
O
O
Voir aussi
Pour configurer les propriétés dynamiques


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation de sources de données > Remplissage dynamique des propriétés d'objets de formulaire à partir d'une source de données > Pour configurer les propriétés dynamiques

Pour configurer les propriétés dynamiques

Pour identifier les propriétés d'objets de formulaire dynamiques, vous devez d'abord activer les libellés.
Les libellés actifs identifient les propriétés qui peuvent être dynamiques. Les libellés actifs sont identifiés par un soulignement vert que vous pouvez activer par un clic de souris afin de lier dynamiquement la propriété à une source de données. Vous pouvez définir la couleur par défaut des libellés actifs.
Par exemple, voici le libellé actif de la légende d’une liste déroulante.
Par défaut, les propriétés dynamiques sont désactivées.
Pour activer et désactiver les libellés actifs
      *
      Effectuez l'une des opérations suivantes :
      •
      Dans le menu de la palette Objet, choisissez Afficher les propriétés dynamiques.
      •
      Choisissez Outils > Options, puis Liaison de données dans la liste de gauche. Sélectionnez ensuite l'option Afficher les propriétés dynamiques, puis cliquez sur OK.
si vous désactivez les libellés actifs, les propriétés d'objet de formulaire qui sont déjà liées de façon dynamique à une source de données restent liées et actives.
Pour définir la couleur par défaut des libellés actifs
1.
Choisissez Outils > Options, puis Liaison de données dans la liste de gauche.
2.
Sélectionnez l'option Utiliser une couleur de libellé personnalisée.
3.
Cliquez sur le sélecteur de couleurs et choisissez une couleur.
4.
Cliquez sur OK.
Voir aussi
A propos des propriétés dynamiques


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation de sources de données > Remplissage dynamique des propriétés d'objets de formulaire à partir d'une source de données > Pou remplir de façon dynamique une liste déroulante ou une zone de liste

Pou remplir de façon dynamique une liste déroulante ou une zone de liste

Vous pouvez remplir une liste déroulante ou une zone de liste de manière dynamique à l'aide de valeurs issues d'une source de données.
Si vous disposez d'un ensemble de valeurs prédéterminé et immuable, vous pouvez remplir une liste déroulante ou une zone de liste lors de la conception du formulaire. Voir Pour spécifier la liste des options d'une liste déroulante ou d'une zone de liste. Si vous disposez d'un ensemble de valeurs pouvant être modifié, vous pouvez remplir de façon dynamique une liste déroulante ou une zone de liste à partir d'une source de données au moment de l'exécution. Si vous disposez d'un ensemble de valeurs important, il est préférable de l'enregistrer dans une source de données afin d'attribuer plus de souplesse au formulaire.
Vous pouvez par exemple remplir une liste déroulante à l'aide d’une liste de pays issue d'une source de données. Autre exemple : vous pouvez remplir une zone de liste de noms de produits français en soumettant des valeurs de données anglaises à la source de données.
Par exemple, les éléments suivants peuvent être définis pour une liste pour le schéma auquel vous vous connectez :
<form>
   <lists>
      <item uiname="item1" token="value1"/>
      <item uiname="item2" token="value2"/>
   </lists>
</form>
Et les éléments suivants peuvent être définis pour une liste pour le fichier de données sur lequel vous pointez :
<form>
   <lists>
      <item uiname="MasterCard" token="MC"/>
      <item uiname="Visa" token="VS"/>
      <item uiname="Eurocard" token="EC"/>
      <item uiname="Special Card" token="SC"/>
   </lists>
</form>
Lorsque vous fusionnez le fichier de données avec la conception de formulaire, MasterCard devrait apparaître parmi les options de la liste, mais lorsque le formulaire est transmis, le jeton MC est envoyé à la source de données.
si vous disposez d'une connexion aux données OLE, vous pouvez utiliser l'objet de liste déroulante Données de la catégorie Personnalisés de la palette Bibliothèque pour remplir une liste déroulante ou une zone de liste à l'aide des données d'une colonne d'un tableau. Voir Pour remplir de façon dynamique une liste déroulante ou une zone de liste à partir d'une connexion aux données OLE.
Avant d'effectuer cette tâche, assurez-vous que les paramètres suivants sont appliqués :
      •
      Vérifiez si les libellés sont activés. Voir Pour configurer les propriétés dynamiques.
      •
      Assurez-vous que vous êtes connecté à une source de données décrivant les données auxquelles les propriétés d'objet de formulaire vont être liées. Voir A propos de la connexion à une source de données.
      •
      Pour tester le formulaire à l'aide des données d'exemple, vérifiez si vous pointez sur un fichier contenant des données définies pour la propriété d'objet de formulaire. Voir Pour tester un formulaire avec des exemples de données.
1.
Dans la palette Bibliothèque, cliquez sur la catégorie Standard et faites glisser un objet de liste déroulante ou de zone de liste sur la conception de formulaire.
Par exemple, insérez une liste déroulante.
2.
(Facultatif) Dans la palette Objet, cliquez sur l'onglet Champ et tapez une légende pour l'objet de la zone Légende.
Par exemple, saisissez Credit Card.
3.
Effectuez l'une des opérations suivantes :
      •
      Cliquez sur le libellé actif Articles de liste dans le panneau Champ de la palette Objet.
      •
      Cliquez sur le libellé actif Spécifier les valeurs dans le panneau Liaison de la palette Objet.
les libellés actifs Articles de liste et Spécifier les valeurs affichent la même boîte de dialogue Propriétés dynamiques.
4.
Sélectionnez la connexion aux données.
si vous n'êtes pas connecté à une source de données, Liaison des données par défaut est la seule sélection possible dans la liste Connexion aux données.
5.
Cliquez sur le triangle situé à côté de la liste Eléments et sélectionnez une liaison.
La liaison que vous sélectionnez doit être une valeur ou un groupe de données qui se répète pour que la liste déroulante ou la zone de liste contienne plusieurs éléments.
Par exemple, sélectionnez l'élément > Listes.
La chaîne suivante apparaît dans la zone Eléments :
$record.lists.item[*]
vous pouvez taper cette chaîne dans la zone Eléments au lieu de la sélectionner.
dans le cas des connexions de données OLE, la zone Eléments n'est pas disponible. Les zones Texte de l'élément et Valeur de l'élément vous permettent de sélectionner les colonnes de la base de données destinées à remplir la liste.
6.
Pour afficher un nom d'élément convivial au moment de l'exécution, cliquez sur le triangle situé à côté de la zone Texte de l'élément et sélectionnez une liaison.
Par exemple, sélectionnez @uiname pour afficher MasterCard.
Le fichier de données sur lequel vous pointez peut contenir une valeur de données qui se répète :
<form>
   <pymt>
      <cc type="MC">MasterCard</cc>
      <cc type="VS">Visa</cc>
   </pymt>
</form>
si vous sélectionnez #data, la liste déroulante contient MasterCard.
7.
(Facultatif) Pour enregistrer une autre valeur que le libellé Texte de l'élément dans la source de données, cliquez sur le triangle situé à côté de la zone Valeur de l’élément et sélectionnez une liaison.
Par exemple, sélectionnez @token pour enregistrer MC dans le fichier de données.
Le fichier de données sur lequel vous pointez peut contenir une valeur de données qui se répète :
<form>
   <pymt>
      <cc type="MC">MasterCard</cc>
      <cc type="VS">Visa</cc>
   </pymt>
</form>
si vous sélectionnez #data, la liste déroulante contient MC.
8.
Cliquez sur OK.
Lorsqu'une liaison est définie, une petite icône représentant un lien apparaît avec le libellé actif.
9.
Affichez le formulaire dans le panneau Aperçu PDF.
Voir aussi
A propos des propriétés dynamiques
Pour configurer les propriétés dynamiques


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation de sources de données > Remplissage dynamique des propriétés d'objets de formulaire à partir d'une source de données > Pour remplir de façon dynamique une liste déroulante ou une zone de liste à partir d'une connexion aux données OLE

Pour remplir de façon dynamique une liste déroulante ou une zone de liste à partir d'une connexion aux données OLE

La catégorie Personnalisés de la palette Bibliothèque propose deux objets personnalisés que vous pouvez utiliser pour insérer des données dans deux colonnes provenant d’une connexion à une base de données OLE. Il s'agit des objets de liste déroulante de données et de zone de liste de données.
il s’agit d'une solution basée sur un script. Vous pouvez utiliser des propriétés dynamiques pour effectuer la même opération. Voir Pou remplir de façon dynamique une liste déroulante ou une zone de liste.
1.
Dans la palette Bibliothèque, cliquez sur la catégorie Personnalisés et faites glisser sur la page l'objet de zone de liste approprié.
      •
      Pour créer une liste déroulante, faites glisser l'objet correspondant.
      •
      Pour créer une zone de liste, faites glisser l'objet correspondant.
2.
Sélectionnez l'objet.
3.
Choisissez Fenêtre > Editeur de script.
4.
Dans sDataConnectionName = “<value>”, remplacez value par le nom de la connexion aux données.
5.
Dans sColHiddenValue = “<value>”, remplacez value par le nom de la valeur cachée.
6.
Dans sColDisplayText = “<value>”, remplacez value par le nom de la colonne de texte.
Voir aussi
A propos des propriétés dynamiques
Pour configurer les propriétés dynamiques
Pour créer un champ ou un sous-formulaire lié
Pour établir une connexion à une base de données OLE
Pour établir une connexion à un fichier WSDL


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation de sources de données > Remplissage dynamique des propriétés d'objets de formulaire à partir d'une source de données > Pour remplir de façon dynamique une légende

Pour remplir de façon dynamique une légende

Vous pouvez remplir une légende de manière dynamique à l'aide de valeurs issues d'une source de données.
Par exemple, vous pouvez remplir une légende à l'aide d'un nom de produit en français. Les éléments suivants peuvent être définis pour une légende pour le schéma auquel vous vous connectez :
<form>
   <caption product=”ProductName1”></caption>
</form>
Et les éléments suivants peuvent être définis pour une légende pour le fichier de données sur lequel vous pointez :
<form>
   <caption product=”Desk Lamp”></caption>
</form>
Lorsque vous fusionnez le fichier de données avec la conception de formulaire, la légende Desk Lamp est affichée comme produit.
Un autre exemple peut consister à indiquer le nom de produit dans une autre langue. Et les éléments suivants peuvent être définis pour la légende pour le fichier de données sur lequel vous pointez :
<form>
   <caption product=”Lampe de Bureau”></caption>
</form>
Lorsque vous fusionnez le fichier de données avec la conception de formulaire, la légende Lampes de bureau est affichée comme produit.
pour utiliser un texte non ASCII (tels que les accents) dans votre fichier de données, assurez-vous qu'il est correctement codé et que le codage est correctement identifié dans l'instruction de traitement XML. Par exemple :
<?xml version="1.0" encoding="UTF-8"?>
Avant d'effectuer cette tâche, assurez-vous que les paramètres suivants sont appliqués :
      •
      Vérifiez si les libellés sont activés. Voir Pour configurer les propriétés dynamiques.
      •
      Assurez-vous que vous êtes connecté à une source de données décrivant les données auxquelles les propriétés d'objet de formulaire vont être liées. Voir A propos de la connexion à une source de données.
      •
      Pour tester le formulaire à l'aide des données d'exemple, vérifiez si vous pointez sur un fichier contenant des données définies pour la propriété d'objet de formulaire. Voir Pour tester un formulaire avec des exemples de données.
1.
Cliquez sur la catégorie Standard de la palette Bibliothèque, puis faites glisser un objet sur la conception de formulaire.
Par exemple, insérez un objet de champ de texte.
2.
(Facultatif) Dans la palette Objet, cliquez sur l'onglet Champ et tapez une légende pour l'objet de la zone Légende.
Par exemple, saisissez Product.
3.
Cliquez sur le libellé actif Légende.
4.
Sélectionnez la connexion aux données.
si vous n'êtes pas connecté à une source de données, Liaison des données par défaut est la seule sélection possible dans la liste Connexion aux données.
5.
Cliquez sur le triangle situé à côté de la zone Liaison et sélectionnez une liaison.
Par exemple, légende >@product.
6.
Cliquez sur OK.
7.
Affichez le formulaire dans le panneau Aperçu PDF.
Voir aussi
A propos des propriétés dynamiques
Pour configurer les propriétés dynamiques


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation de sources de données > Remplissage dynamique des propriétés d'objets de formulaire à partir d'une source de données > Pour remplir de façon dynamique un message de modèle de validation

Pour remplir de façon dynamique un message de modèle de validation

Vous pouvez remplir de manière dynamique un message de modèle de validation à l'aide d'une valeur issue d'une source de données. Vous serez ainsi assuré que les utilisateurs saisissent la valeur correcte dans le champ.
Par exemple, vous pouvez afficher un message d'erreur personnalisé lorsque les utilisateurs saisissent un modèle non valide dans un champ.
Les éléments suivants peuvent être définis pour un modèle de validation pour le schéma auquel vous vous connectez :
<form>
   <validationPattern dp_patternMessage="message1"/>
</form>
Et les éléments suivants peuvent être définis pour un modèle de validation pour le fichier de données sur lequel vous pointez :
<form>
   <validationPattern dp_patternMessage="DP Pattern Message - The order number pattern is: A9A9A9"/>
</form>
Lorsque vous fusionnez le fichier de données avec la conception de formulaire et que vous saisissez un numéro dans le champ N° de bon de commande qui ne correspond pas au modèle attendu, un message d'erreur s'affiche.
Autre exemple : vous pourriez afficher des messages d'erreur personnalisés pour les modèles dans une autre langue. Les éléments suivants peuvent être définis pour la validation du modèle pour le fichier de données sur lequel vous pointez :
<form>
   <validationPattern dp_patternMessage="Le numéro de commande doit suivre le modèle suivant : A9A9A9"/>
</form>
Lorsque vous fusionnez le fichier de données avec la conception de formulaire et que vous saisissez un numéro dans le champ N° de bon de commande qui ne correspond pas au modèle attendu, un message d'erreur en français s'affiche.
pour utiliser un texte non ASCII (tels que les accents) dans votre fichier de données, assurez-vous qu'il est correctement codé et que le codage est correctement identifié dans l'instruction de traitement XML. Par exemple :
<?xml version="1.0" encoding="UTF-8"?>
Avant d'effectuer cette tâche, assurez-vous que les paramètres suivants sont appliqués :
      •
      Vérifiez si les libellés sont activés. Voir Pour configurer les propriétés dynamiques.
      •
      Assurez-vous que vous êtes connecté à une source de données décrivant les données auxquelles les propriétés d'objet de formulaire vont être liées. Voir A propos de la connexion à une source de données.
      •
      Pour tester le formulaire à l'aide des données d'exemple, vérifiez si vous pointez sur un fichier contenant des données définies pour la propriété d'objet de formulaire. Voir Pour tester un formulaire avec des exemples de données.
1.
Cliquez sur la catégorie Standard de la palette Bibliothèque, puis faites glisser un objet sur la conception de formulaire.
Par exemple, insérez un objet de champ de texte.
2.
(Facultatif) Dans la palette Objet, cliquez sur l'onglet Champ et tapez une légende pour l'objet de la zone Légende.
Par exemple, saisissez Order Number.
3.
Cliquez sur l'onglet Valeur et saisissez un modèle dans la zone Modèle de validation.
Par exemple, saisissez A9A9A9.
4.
Cliquez sur le libellé actif Message de modèle de validation.
5.
Sélectionnez la connexion aux données.
si vous n'êtes pas connecté à une source de données, Liaison des données par défaut est la seule sélection possible dans la liste Connexion aux données.
6.
Cliquez sur le triangle situé à côté de la zone Liaison et sélectionnez une liaison.
Par exemple, sélectionnez validation > @dp_patternMessage.
La chaîne suivante apparaît dans la zone Liaison :
$record.validation.dp_patternMessage
vous pouvez taper cette chaîne dans la zone Eléments au lieu de la sélectionner.
7.
Cliquez sur OK.
8.
Affichez le message d'erreur à partir du panneau Aperçu PDF.
Par exemple, dans le panneau Aperçu PDF, saisissez un numéro de bon de commande ne correspondant pas au modèle.
Voir aussi
A propos des propriétés dynamiques
Pour configurer les propriétés dynamiques


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation de sources de données > Remplissage dynamique des propriétés d'objets de formulaire à partir d'une source de données > Pour remplir de façon dynamique un message de script de validation

Pour remplir de façon dynamique un message de script de validation

Vous pouvez remplir de manière dynamique un message de script de validation à l'aide d'une valeur issue d'une source de données. Vous serez ainsi assuré que les utilisateurs saisissent la valeur correcte dans le champ.
Par exemple, vous pouvez afficher un message d'erreur personnalisé lorsque les utilisateurs saisissent des données dans un champ qui ne correspondent pas à ce que le script attend. Par exemple, un script peut être associé à un champ numérique, tel que Quantité, pour indiquer que le nombre spécifié dans ce champ ne peut pas être supérieur à 100. Si l'utilisateur saisit un nombre supérieur à 100, un message d'erreur personnalisé s'affiche.
Les éléments suivants peuvent être définis pour un script de validation pour le schéma auquel vous vous connectez :
<form>
   <validationScript dp_scriptMessage="message1"/>
</form>
Les éléments suivants peuvent être définis pour le script de validation pour le fichier de données sur lequel vous pointez :
<form>
   <validationScript dp_scriptMessage="DP Script Message - The quantity must be less than or equal to 100."/>
</form>
Lorsque vous fusionnez le fichier de données avec la conception de formulaire et que vous saisissez un nombre supérieur à 100 dans le champ Quantité, un message d'erreur s'affiche.
Autre exemple : vous pourriez afficher des messages d'erreur personnalisés associés à un script dans une autre langue. Les éléments suivants peuvent être définis pour le script de validation pour le fichier de données sur lequel vous pointez :
<form>
   <validationScript dp_scriptMessage="Entrez un nombre inférieur ou égal à 100."/>
</form>
Lorsque vous fusionnez le fichier de données avec la conception de formulaire et que vous saisissez un nombre supérieur à 100 dans le champ Quantité, un message d'erreur en français s'affiche.
pour utiliser un texte non ASCII (tels que les accents) dans votre fichier de données, assurez-vous qu'il est correctement codé et que le codage est correctement identifié dans l'instruction de traitement XML. Par exemple :
<?xml version="1.0" encoding="UTF-8"?>
Avant d'effectuer cette tâche, assurez-vous que les paramètres suivants sont appliqués :
      •
      Vérifiez si les libellés sont activés. Voir Pour configurer les propriétés dynamiques.
      •
      Assurez-vous que vous êtes connecté à une source de données décrivant les données auxquelles les propriétés d'objet de formulaire vont être liées. Voir A propos de la connexion à une source de données.
      •
      Pour tester le formulaire à l'aide des données d'exemple, vérifiez si vous pointez sur un fichier contenant des données définies pour la propriété d'objet de formulaire. Voir Pour tester un formulaire avec des exemples de données.
1.
Cliquez sur la catégorie Standard de la palette Bibliothèque, puis faites glisser un objet sur la conception de formulaire.
Par exemple, insérez un objet de champ numérique.
2.
(Facultatif) Dans la palette Objet, cliquez sur l'onglet Champ et tapez une légende pour l'objet de la zone Légende.
Par exemple, saisissez Quantity.
3.
Dans l'éditeur de script, sélectionnez Valider dans la liste Afficher.
4.
Dans l'éditeur de script, sélectionnez un langage dans la liste Langage.
Par exemple, sélectionnez JavaScript dans la liste Langage.
5.
Saisissez un script pour l'objet.
Par exemple, saisissez ce script pour le champ Quantité :
this.rawValue <= 100
6.
Dans la palette Objet, cliquez sur l'onglet Valeur, puis cliquez sur le libellé actif Message de script de validation.
7.
Sélectionnez la connexion aux données.
si vous n'êtes pas connecté à une source de données, Liaison des données par défaut est la seule sélection possible dans la liste Connexion aux données.
8.
Cliquez sur le triangle situé à côté de la zone Liaison et sélectionnez une liaison.
Par exemple, sélectionnez validation > @dp_scriptMessage.
La chaîne suivante apparaît dans la zone Liaison :
$record.validation.dp_scriptMessage
vous pouvez taper cette chaîne dans la zone Eléments au lieu de la sélectionner.
9.
Cliquez sur OK.
10.
Affichez le message d'erreur à partir du panneau Aperçu PDF.
Par exemple, dans le panneau Aperçu PDF, saisissez une quantité supérieure à 100.
Voir aussi
A propos des propriétés dynamiques
Pour configurer les propriétés dynamiques


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation de sources de données > Remplissage dynamique des propriétés d'objets de formulaire à partir d'une source de données > Pour remplir de façon dynamique une info-bulle

Pour remplir de façon dynamique une info-bulle

Vous pouvez remplir une info-bulle de manière dynamique à l'aide d'une valeur issue d'une source de données. Par exemple, vous pouvez afficher une info-bulle personnalisée en français pour un objet.
Les éléments suivants peuvent être définis pour une info-bulle pour le schéma auquel vous vous connectez :
<form>
   <tooltip dp_tt="tooltip1"/>
</form>
Et les éléments suivants peuvent être définis pour une info-bulle pour le fichier de données sur lequel vous pointez :
<form>
   <tooltip dp_tt="Quantité - Entrez un nombre inférieur ou égal à 100."/>
</form>
Lorsque vous fusionnez le fichier de données avec la conception de formulaire, et que vous positionnez le pointeur sur le champ Quantité, l'info-bulle s'affiche :
Avant d'effectuer cette tâche, assurez-vous que les paramètres suivants sont appliqués :
      •
      Vérifiez si les libellés sont activés. Voir Pour configurer les propriétés dynamiques.
      •
      Assurez-vous que vous êtes connecté à une source de données décrivant les données auxquelles les propriétés d'objet de formulaire vont être liées. Voir A propos de la connexion à une source de données.
      •
      Pour tester le formulaire à l'aide des données d'exemple, vérifiez si vous pointez sur un fichier contenant des données définies pour la propriété d'objet de formulaire. Voir Pour tester un formulaire avec des exemples de données.
1.
Cliquez sur la catégorie Standard de la palette Bibliothèque, puis faites glisser un objet sur la conception de formulaire.
Par exemple, insérez un objet de champ de texte.
2.
(Facultatif) Dans la palette Objet, cliquez sur l'onglet Champ et tapez une légende pour l'objet de la zone Légende.
Par exemple, saisissez Quantité.
3.
Dans la palette Accessibilité, cliquez sur le libellé actif Info-bulle.
4.
Sélectionnez la connexion aux données.
si vous n'êtes pas connecté à une source de données, Liaison des données par défaut est la seule sélection possible dans la liste Connexion aux données.
5.
Cliquez sur le triangle situé à côté de la zone Liaison et sélectionnez une liaison.
Par exemple, sélectionnez info-bulle > @dp_tt.
La chaîne suivante apparaît dans la zone Liaison :
$record.tooltip.dp_tt
vous pouvez taper cette chaîne dans la zone Eléments au lieu de la sélectionner.
6.
Cliquez sur OK.
7.
Affichez le formulaire dans le panneau Aperçu PDF.
Par exemple, dans le panneau Aperçu PDF, essayez de positionner le pointeur sur le champ Quantité pour afficher l'info-bulle personnalisée.
Voir aussi
A propos des propriétés dynamiques
Pour configurer les propriétés dynamiques


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation de sources de données > Remplissage dynamique des propriétés d'objets de formulaire à partir d'une source de données > Pour remplir de façon dynamique du texte d'un lecteur d'écran

Pour remplir de façon dynamique du texte d'un lecteur d'écran

Vous pouvez remplir un texte d'un lecteur d'écran de manière dynamique à l'aide de valeurs issues d'une source de données. Par exemple, vous pouvez afficher un texte d'un lecteur d'écran personnalisé en français pour un objet.
Les éléments suivants peuvent être définis pour le texte d'un lecteur d'écran personnalisé pour le schéma auquel vous vous connectez :
<form>
   <csr dp_csr="csr1"/>
</form>
Les éléments suivants peuvent être définis pour le texte d'un lecteur d'écran personnalisé pour le fichier de données sur lequel vous pointez :
<form>
   <csr dp_csr="The 7-digit customer identification field."/>
</form>
Lorsque vous fusionnez le fichier de données avec la conception de formulaire, et que vous lancez le lecteur d'écran, il lit le type de champ, puis le champ d'identification client à 7 chiffres.
Avant d'effectuer cette tâche, assurez-vous que les paramètres suivants sont appliqués :
      •
      Vérifiez si les libellés sont activés. Voir Pour configurer les propriétés dynamiques.
      •
      Assurez-vous que vous êtes connecté à une source de données décrivant les données auxquelles les propriétés d'objet de formulaire vont être liées. Voir A propos de la connexion à une source de données.
      •
      Pour tester le formulaire à l'aide des données d'exemple, vérifiez si vous pointez sur un fichier contenant des données définies pour la propriété d'objet de formulaire. Voir Pour tester un formulaire avec des exemples de données.
      •
      Assurez-vous que l’option Lire les champs de formulaire d'Adobe Acrobat est configurée dans le menu Edition de la boîte de dialogue Préférences (catégorie Lecture).
1.
Cliquez sur la catégorie Standard de la palette Bibliothèque, puis faites glisser un objet sur la conception de formulaire.
Par exemple, insérez un objet de champ numérique.
2.
(Facultatif) Dans la palette Objet, cliquez sur l'onglet Champ et tapez une légende pour l'objet de la zone Légende.
Par exemple, saisissez Customer ID.
3.
Dans la palette Accessibilité, cliquez sur le libellé actif Texte d'un lecteur d'écran personnalisé.
4.
Sélectionnez la connexion aux données.
si vous n'êtes pas connecté à une source de données, Liaison des données par défaut est la seule sélection possible dans la liste Connexion aux données.
5.
Cliquez sur le triangle situé à côté de la zone Liaison et sélectionnez une liaison.
Par exemple, sélectionnez csr> @dp_csr.
La chaîne suivante apparaît dans la zone Liaison :
$record.csr.dp_csr
vous pouvez taper cette chaîne dans la zone Eléments au lieu de la sélectionner.
6.
Cliquez sur OK.
7.
Affichez le formulaire dans le panneau Aperçu PDF.
Par exemple, dans le panneau Aperçu PDF, essayez de saisir des données dans le champ ID client pour entendre le texte du lecteur d'écran personnalisé.
Voir aussi
A propos des propriétés dynamiques
Pour configurer les propriétés dynamiques


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation de sources de données > Remplissage dynamique des propriétés d'objets de formulaire à partir d'une source de données > Pour remplir de façon dynamique un second champ après remplissage du premier

Pour remplir de façon dynamique un second champ après remplissage du premier

Vous pouvez remplir de façon dynamique un seconde champ après avoir rempli le premier en utilisant un script. Par exemple, vous pouvez disposer d'une liste déroulante contenant une liste de pays destinée aux utilisateurs. Lorsqu'un utilisateur sélectionne un pays, la seconde liste affiche les états ou provinces de ce pays.
Ainsi, les éléments suivants peuvent être définis pour l'exemple de fichier XML auquel vous vous connectez :
<MyData>
   <country/>
   <countries>
      <item uiname="United States" token="US"/>
      <item uiname="Vietnam" token="SRV"/>
   </countries>
   <state/>
   <US>
      <item>California</item>
      <item>New York</item>
      <item>Texas</item>
   </US>
   <SRV>
      <item>An Giang</item>
      <item>Bac Giang</item>
      <item>Bac Kan</item>
   </SRV>
</MyData>
Par exemple, après avoir sélectionné Vietnam dans la première liste déroulante, les éléments affichés dans la liste Etats/Provinces n'indiquent alors que ceux qui s'appliquent au Vietnam.
Avant d'effectuer cette tâche, assurez-vous que les paramètres suivants sont appliqués :
      •
      Vérifiez si les libellés sont activés. Voir Pour configurer les propriétés dynamiques.
      •
      Assurez-vous que vous êtes connecté à une source de données décrivant les données auxquelles les propriétés d'objet de formulaire vont être liées. Voir A propos de la connexion à une source de données.
      •
      Pour tester le formulaire à l'aide des données d'exemple, vérifiez si vous pointez sur un fichier contenant des données définies pour la propriété d'objet de formulaire. Voir Pour tester un formulaire avec des exemples de données.
Pour définir le premier champ :
1.
Dans la palette Bibliothèque, cliquez sur la catégorie Standard et faites glisser un objet de liste déroulante ou de zone de liste sur la conception de formulaire.
Par exemple, insérez une liste déroulante.
2.
(Facultatif) Dans la palette Objet, cliquez sur l'onglet Champ et tapez une légende pour l'objet de la zone Légende.
Par exemple, saisissez Country.
3.
Effectuez l'une des opérations suivantes :
      •
      Cliquez sur le libellé actif Articles de liste dans le panneau Champ de la palette Objet.
      •
      Cliquez sur le libellé actif Spécifier les valeurs dans le panneau Liaison de la palette Objet.
4.
Sélectionnez la connexion aux données.
si vous n'êtes pas connecté à une source de données, Liaison des données par défaut est la seule sélection possible dans la liste Connexion aux données.
5.
Cliquez sur le triangle situé à côté de la liste Eléments et sélectionnez une liaison.
La liaison que vous sélectionnez doit être une valeur ou un groupe de données qui se répète pour que la liste déroulante ou la zone de liste contienne plusieurs éléments.
Par exemple, sélectionnez l'élément > pays.
La chaîne suivante apparaît dans la zone Eléments :
$record.countries.item[*]
vous pouvez taper cette chaîne dans la zone Eléments au lieu de la sélectionner.
dans le cas des connexions de données OLE, la zone Eléments n'est pas disponible. Les zones Texte de l'élément et Valeur de l'élément vous permettent de sélectionner les colonnes de la base de données destinées à remplir la liste.
6.
Pour afficher un nom d'élément convivial au moment de l'exécution, cliquez sur le triangle situé à côté de la zone Texte de l'élément et sélectionnez une liaison.
Par exemple, sélectionnez @uiname pour afficher Etats-Unis.
7.
(Facultatif) Pour enregistrer une autre valeur que le libellé Texte de l'élément dans la source de données, cliquez sur le triangle situé à côté de la zone Valeur de l’élément et sélectionnez une liaison.
Par exemple, sélectionnez @token pour enregistrer US dans le fichier de données.
8.
Cliquez sur OK.
Lorsqu'une liaison est définie, une petite icône représentant un lien apparaît avec le libellé actif.
Pour définir le script pour qu’il remplisse de façon dynamique un second champ après remplissage du premier
1.
Après avoir sélectionné la première liste déroulante dans l'éditeur de script, choisissez Modifier dans la liste Afficher.
2.
Sélectionnez JavaScript dans la liste Langage.
3.
Entrez le script suivant :

var tempString = "xfa.record." + this.boundItem(xfa.event.newText);
var oItems = xfa.resolveNode(tempString);
var nItemsLength = oItems.nodes.length;

DropDownList2.clearItems();

for (var nItemCount = 0; nItemCount < nItemsLength; nItemCount++) {
   DropDownList2.addItem(oItems.nodes.item(nItemCount).value);
}

Script

Description

tempString
Spécifie une chaîne pour xfa.record. Par exemple, si Etats-Unis est sélectionné, xfa.record est remplacé par xfa.record.US.

this.boundItem
Une méthode d'objet de liste qui convertit le nom convivial en une chaîne de valeur ou de jeton. Par exemple, si Etats-Unis est sélectionné, US est transmis.

xfa.event.newText
Renvoie le nouveau contenu de texte de l'événement Modification de liste. Par exemple, si Etats-Unis est sélectionné, Etats-Unis est transmis.

var nItemsLength = oItems.nodes.length;
Demande le nombre d'éléments enfant de <US> (ou <SRV>), qui est le nombre d'enfants <item>.

DropDownList2.clearItems();
Supprime les éléments existants dans la seconde liste déroulante.

for (var nItemCount = 0; nItemCount < nItemsLength; nItemCount++)
Demande chaque enfant <item> de <US> (ou <SRV>).

DropDownList2.addItem(oItems.nodes.item(nItemCount).value);
Obtient la valeur texte de l'enfant <item> indiquée par l'index nItemCount et ajoute cette valeur en tant que nouvel élément à la seconde liste déroulante
4.
Cliquez sur Insérer les changements dans la source du script pour ajouter le script à votre formulaire.
Pour définir le second champ :
1.
Dans la palette Bibliothèque, cliquez sur la catégorie Standard et faites glisser un objet de liste déroulante ou de zone de liste sur la conception de formulaire.
Par exemple, insérez une liste déroulante.
2.
(Facultatif) Dans la palette Objet, cliquez sur l'onglet Champ et tapez une légende pour l'objet de la zone Légende.
Par exemple, saisissez States/Provinces.
3.
Liez le champ à la source de données.
Par exemple, liez le noeud Etat à la liste déroulante Etats/Provinces.
4.
Affichez le formulaire dans le panneau Aperçu PDF.
Voir aussi
A propos des propriétés dynamiques
Pour configurer les propriétés dynamiques


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation de sources de données > Remplissage dynamique des propriétés d'objets de formulaire à partir d'une source de données > Pour modifier la liaison de données dynamique

Pour modifier la liaison de données dynamique

1.
Sélectionnez l'objet auquel une liaison de données dynamique est associée.
Une petite icône de liaison apparaît avec le libellé actif pour les propriétés dynamiques liées. Par exemple :
2.
Localisez le libellé actif de la propriété dynamique pour laquelle vous souhaitez modifier la liaison de données.
3.
Effectuez l'une des opérations suivantes :
      •
      Cliquez sur le libellé actif.
      •
      Cliquez avec le bouton droit de la souris sur le libellé actif et choisissez Modifier les liaisons [propriété].
4.
Effectuez les modifications et cliquez sur OK.
Voir aussi
A propos des propriétés dynamiques
Pour configurer les propriétés dynamiques


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation de sources de données > Remplissage dynamique des propriétés d'objets de formulaire à partir d'une source de données > Pour remplir de façon dynamique des propriétés d'objet de formulaire à l'aide de la méthode glisser-déposer

Pour remplir de façon dynamique des propriétés d'objet de formulaire à l'aide de la méthode glisser-déposer

Vous pouvez définir rapidement la liaison de données dynamique pour les propriétés d'objets de formulaire à l'aide de la méthode glisser-déposer.
vous ne pouvez pas utiliser cette méthode pour répertorier les éléments dans une liste déroulante ou une zone de liste.
Avant d'effectuer cette tâche, assurez-vous que les paramètres suivants sont appliqués :
      •
      Vérifiez si les libellés sont activés. Voir Pour configurer les propriétés dynamiques.
      •
      Assurez-vous que vous êtes connecté à une source de données décrivant les données auxquelles les propriétés d'objet de formulaire vont être liées. Voir A propos de la connexion à une source de données.
      •
      Pour tester le formulaire à l'aide des données d'exemple, vérifiez si vous pointez sur un fichier contenant des données définies pour la propriété d'objet de formulaire. Voir Pour tester un formulaire avec des exemples de données.
1.
Localisez le libellé actif pour lequel vous voulez définir la liaison de données dynamique.
2.
Dans la palette Vue des données, sélectionnez le noeud que vous souhaitez lier.
3.
Cliquez sur le noeud et faites-le glisser vers le libellé actif.
Une petite icône de liaison apparaît avec le libellé actif pour les propriétés dynamiques liées. Par exemple :
Si une liaison de données est déjà définie pour la propriété pour la même connexion aux données, elle est remplacée.
Voir aussi
A propos des propriétés dynamiques
Pour configurer les propriétés dynamiques


Précédent Suivant

Utilisation de LiveCycle Designer > Utilisation de sources de données > Remplissage dynamique des propriétés d'objets de formulaire à partir d'une source de données > Pour supprimer la liaison de données dynamique

Pour supprimer la liaison de données dynamique

1.
Sélectionnez l'objet auquel une liaison de données dynamique est associée.
Une petite icône de liaison apparaît avec le libellé actif pour les propriétés dynamiques liées. Par exemple :
2.
Localisez le libellé actif pour lequel vous voulez supprimer la liaison de données dynamique.
3.
Cliquez avec le bouton droit de la souris sur le libellé actif et sélectionnez Effacer les liaisons [propriété].
il existe un autre moyen pour supprimer la liaison de données dynamique qui consiste à sélectionner <Aucune> dans la liste de la boîte de dialogue Propriétés dynamiques. En outre, si vous supprimez une connexion aux données, les liaisons de données par défaut et les liaisons de données dynamiques sont supprimées si vous sélectionnez l'option Rompre les liaisons des connexions de données supprimées.
Voir aussi
A propos des propriétés dynamiques
Pour configurer les propriétés dynamiques


Création de formulaires accessibles

A propos des formulaires accessibles
Conception de formulaires accessibles
Définition d’objets accessibles


A propos des formulaires accessibles

Un formulaire accessible est conçu être utilisé par un public large et divers, comprenant notamment les personnes souffrant d'une déficience pouvant gêner leur interaction avec le formulaire affiché à l'écran. Par exemple, l'utilisateur du formulaire peut avoir une mobilité ou une vision réduite.
LiveCycle Designer comporte de nombreuses fonctions et possibilités qui simplifient l'utilisation des formulaires pour les utilisateurs ayant diverses déficiences et aident les développeurs à créer des formulaires PDF plus facilement accessibles par ce public.
LiveCycle Designer prend en charge la création de fichiers HTML (AHTML) accessibles à l’aide de LiveCycle Forms et de formulaires balisés Adobe PDF. Les formulaires PDF balisés renferment une structure logique complète et d’autres renseignements sur le contenu du document qui augmentent considérablement leur accessibilité.
Avant de créer des formulaires accessibles, vous devez déterminer leur finalité et adapter leur conception en conséquence : sont-ils conçus pour être renseignés de façon interactive par les utilisateurs ou uniquement pour être affichés et imprimés ?
Pour vous aider dans votre tâche, vous avez la possibilité d'importer des fichiers PDF accessibles et les utiliser comme point de départ. Pour plus de détails, voir A propos des fichiers PDF accessibles et de leur importation.
Voir aussi
Observations générales sur la conception de formulaires accessibles
Propriétés de la palette Accessibilité


Conception de formulaires accessibles

Observations générales sur la conception de formulaires accessibles
Formulaires destinés à des utilisateurs ayant une déficience visuelle
Formulaires destinés à des utilisateurs ayant une mobilité réduite
Ordre de tabulation dans les formulaires accessibles
Formulaires en couleur accessibles
Lecteurs d'écran pris en charge
Conseils sur la conception de formulaires pour lecteurs d'écran
Pour créer un formulaire PDF assorti de balises d'accessibilité
Conseils pour la création de formulaires PDF accessibles
Techniques de vérification de l'accessibilité d'un formulaire


Observations générales sur la conception de formulaires accessibles

Lorsque vous concevez des formulaires destinés à un large public, vous devez tenir compte du fait que certains utilisateurs peuvent avoir des déficiences qui gênent leur interaction avec le formulaire. Certains utilisateurs du formulaire peuvent avoir une déficience visuelle, une mobilité réduite ou d’autres déficiences. Pour tenir compte des besoins de tous les utilisateurs, il s’avère utile d’inclure certaines fonctions de conception pratiques dans les formulaires et de tester les formulaires à l’aide de différents dispositifs d’assistance.
Voici quelques conseils sur la conception de formulaires accessibles :
      •
      Si un formulaire ne propose par une utilisation simple, il n'est pas considéré accessible. Vous devez vous efforcer de concevoir des formulaires simples à utiliser. Disposez les commandes et les champs de façon simple et associez-leur des légendes et des info-bulles explicites. Votre formulaire n'en sera que plus facile à remplir par tous les utilisateurs.
      •
      La conception de formulaires aérés et organisés de façon logique, qui donnent des instructions simples et claires, aident tous les utilisateurs à remplir les formulaires le plus facilement possible. Les fonctions de navigation, telles que l'ordre de tabulation et les raccourcis clavier, doivent prendre en charge l'ordre logique des objets dans le formulaire. La légende associée à un champ doit se trouver sur la même ligne que le champ devant être rempli par l’utilisateur. Placez toujours les légendes du même côté des champs.
      •
      Les utilisateurs renseignent plus facilement les formulaires dans lesquels le risque d'erreur est faible. Des messages d'erreur courts et clairs aident les utilisateurs à corriger les erreurs qu'ils commettent en renseignant le formulaire.
      •
      Choisissez des objets qui facilitent l'utilisation des formulaires. Par exemple, lorsqu'ils sont utilisés correctement, les tableaux constituent un moyen efficace pour organiser et présenter des informations. Evitez tout chevauchement de tableaux complexes, dans lesquels des tableaux et des sections sont imbriqués.
      •
      Les utilisateurs devraient être en mesure de remplir le formulaire en utilisant seulement le clavier ou un dispositif de saisie équivalent. Certains utilisateurs ayant une mobilité réduite ou une déficience visuelle sont parfois contraints à n'utiliser que le clavier. De plus, de nombreux utilisateurs préfèrent saisir leurs données au moyen du clavier plutôt que de la souris. En proposant différents modes de saisie des données, vous créez également des formulaires qui répondent aux préférences de l'ensemble des utilisateurs.
      •
      Concevez votre formulaire de manière qu'il interagisse naturellement avec les normes des autres applications et des autres systèmes. Par exemple, votre formulaire peut prendre en charge les options du Panneau de configuration relatives aux couleurs et reprendre les fonctions standard du clavier.
      •
      Un formulaire bien conçu sera compatible avec différents types de dispositifs d'assistance. Nous vous conseillons de vous familiariser avec ces dispositifs pour comprendre leur fonctionnement et d'utiliser des techniques de conception, ainsi que des éléments d'interface, compatibles avec une large gamme de dispositifs d'assistance.
      •
      Utilisées de façon judicieuse, les couleurs peuvent améliorer considérablement la convivialité des formulaires. Employez-les, par exemple, pour faire ressortir certaines parties d'un formulaire, mais évitez de reposer sur leur seule utilisation pour véhiculer des informations. L'utilisation intensive de couleurs peut réduire le confort visuel et obscurcir le texte au premier plan. Les couleurs à contrasté élevé, comme le paramètre par défaut (noir sur fond blanc), sont recommandés.
      •
      Les images peuvent faciliter la compréhension des utilisateurs souffrant de déficiences. Mais, de nombreux lecteurs d'écran ne lisent pas les graphiques, ce qui peut réduire l'accessibilité des utilisateurs présentant une déficience visuelle à votre formulaire. Si vous choisissez d'utiliser des images, fournissez les descriptions textuelles qui décrivent l'objet et son rôle dans le formulaire.
      •
      Gardez à l'esprit que les scripts client peuvent entrer en conflit avec des lecteurs d'écran et des claviers s'ils ont pour effet de modifier la cible d'action de l'application client. Par exemple, les événements change et mouseEnter, lorsqu'ils sont associés à une zone de liste ou une zone de liste déroulante, peuvent déclencher des actions inadéquates. Les scripts client doivent être rédigés de manière à éviter les problèmes qui risquent d'affecter les lecteurs d'écran et les claviers. De même, évitez les événements de script produisant des effets visuels, tels qu'un texte clignotant, qui peut accroître les problèmes de lisibilité des utilisateurs.
      •
      Les boutons radio sont souvent mal interprétés par les utilisateurs ayant des déficiences ou sont difficiles d’accès sur les formulaires HTML, car les navigateurs Web et les lecteurs d’écran ne les traitent pas toujours de façon cohérente. Evitez d’utiliser des boutons radio si vous pouvez recourir à une zone de liste.
Voir aussi
Conseils sur la conception de formulaires pour lecteurs d'écran
Conseils pour la création de formulaires PDF accessibles
Création de tableaux simples accessibles
Création de tableaux complexes accessibles
Création d’images accessibles
Création de scripts accessibles


Formulaires destinés à des utilisateurs ayant une déficience visuelle

Les utilisateurs ayant une déficience visuelle ou autre utilisent généralement un outil d'aide appelé lecteur d'écran, qui émet des sons à l'intention de l'utilisateur. Le lecteur d'écran transmet à l'utilisateur des informations sur l'emplacement du curseur à l'écran. Ce type de lecteur peut également lire les info-bulles : insistons sur le fait qu'il est très important d'inclure des info-bulles lorsque vous concevez vos formulaires.
Outre les info-bulles, vous avez la possibilité de vous servir de légendes, de noms d’objet ou de texte du lecteur d'écran personnalisé pour délimiter nettement chaque champ. Vous pouvez également utiliser des objets de texte pour indiquer le type d'information requis. Soyez explicite lorsque vous indiquez les champs devant être complétés. Par exemple, le texte de l'info-bulle peut comporter le message « saisie obligatoire ».
Pour vous assurer qu'un lecteur d'écran fonctionne avec un formulaire PDF, chaque objet doit fournir des informations vocales et vous devez générer un formulaire PDF balisé. Si vous créez un formulaire HTML à partir de la même conception de formulaire, les lecteurs d’écran peuvent lire les info-bulles à voix haute grâce à des conversions AHTML.
Lors de la conception de vos formulaires, gardez à l'esprit les observations suivantes pour aider les personnes ayant une déficience visuelle ou autre :
      •
      Les utilisateurs ayant une déficience visuelle ou autre ne peuvent pas utiliser une souris pour interagir avec l'ordinateur. Chaque fonction doit être accessible à partir du clavier. Dans la plupart des formulaires, les touches Tab et Maj+Tab ont généralement pour effet de déplacer le curseur vers l'avant et vers l'arrière parmi les champs du formulaire. Assurez-vous de définir un ordre de tabulation logique qui inclut l'ensemble des champs et des boutons.
      •
      Plusieurs formulaires comprennent des renseignements administratifs qui fournissent à l'utilisateur des instructions supplémentaires sur la façon de remplir le formulaire. Utilisez les info-bulles pour vous assurer que tous les renseignements importants sont lus à l'utilisateur au moment approprié. Par exemple, si l'utilisateur doit appuyer sur certaines touches pour effectuer une action (comme appuyer sur la barre d'espacement pour sélectionner un bouton ou sur la touche fléchée Bas pour sélectionner un élément dans une liste déroulante), il doit en être informé.
      •
      Ajoutez suffisamment de renseignements vocaux pour que les utilisateurs sachent ce qu'ils doivent entrer et comment ils doivent remplir le champ, mais évitez les renseignements superflus.
      •
      Ajoutez des boutons de navigation en haut et en bas du formulaire. Par exemple, dans la partie supérieure du formulaire, vous pouvez inclure les boutons « Ouvrir fichier de données », « Page précédente » et « Page suivante ». De même, dans la partie inférieure du formulaire, vous pouvez inclure les boutons « Enregistrer données », « Envoyer par messagerie », « Haut de la page » et « Imprimer ».
      •
      L'utilisation de champs « intelligents » peut être une manière efficace de faciliter le remplissage de certains formulaires. Par exemple, un formulaire de remboursement de frais de déplacement peut contenir plusieurs rangées et colonnes. Le dernier champ de chaque rangée peut servir à vérifier si des données ont été entrées dans la rangée. Si la rangée est vide, la touche Tab peut faire avancer le curseur à la section suivante du formulaire plutôt que de continuer à naviguer dans des champs devant rester vides.
      •
      Un utilisateur daltonien ou souffrant d'une autre déficience visuelle peut avoir des difficultés à repérer la position du curseur. Utilisez des couleurs appropriées pour afficher les objets en recourant à un code de couleurs sélectionné par l'utilisateur.
      •
      Les utilisateurs ayant une déficience visuelle utilisent généralement un dispositif d'assistance comme un agrandisseur d'écran. Comme son nom l'indique, ce produit agrandit le curseur. Testez vos formulaires avec plusieurs agrandisseurs d'écran connus pour vous assurer qu'ils sont accessibles.


Formulaires destinés à des utilisateurs ayant une mobilité réduite

Les utilisateurs ayant une mobilité ou une dextérité réduite éprouvent souvent de grandes difficultés à renseigner un formulaire. Si un utilisateur est dans l'impossibilité d'utiliser une souris, chacune des fonctions d'un formulaire doit être disponible à partir du clavier.
Les utilisateurs ayant une mobilité ou une dextérité réduite peuvent utiliser divers dispositifs d'assistance, notamment des claviers adaptés et des logiciels pilotés par la voix (ces derniers permettent de remplir un formulaire à l'aide d'un microphone). Des technologies plus sophistiquées permettent aussi d'utiliser un ordinateur au moyen de la respiration ou du mouvement de l'oeil.
Testez vos formulaires avec plusieurs de ces dispositifs d'assistance pour vous assurer qu'ils sont accessibles.


Ordre de tabulation dans les formulaires accessibles

Si votre formulaire utilise l'ordre de tabulation par défaut, l'ordre de lecture sera géographique, de gauche à droite, puis de haut en bas. L'ordre de tabulation tient compte de l'existence de sous-formulaires, de boutons radio et de zones de contenu. L'ordre de tabulation est également déterminé par la position verticale des objets sur une page et son gabarit.
Lors de la conception des formulaires, vous devez définir un ordre de tabulation utile pour les rendre accessibles aux utilisateurs ayant des déficiences ou des troubles visuels. Ces utilisateurs ne se servent généralement pas d'une souris pour naviguer à l'intérieur du formulaire, mais sont contraints d'utiliser le clavier. Un ordre de tabulation logique leur garantit un accès complet, rationnel et efficace à tous les champs du formulaire.
L'ordre de tabulation détermine également l'ordre de lecture dans lequel le lecteur d'écran lit les objets du formulaire. L’ordre de lecture est basé sur la structure logique du document PDF créé lors de l’enregistrement du formulaire au format balisé PDF.
LiveCycle Designer inclut tous les objets statiques et les objets de champ de la structure logique. Assurez-vous de placer l'ensemble des objets de texte et d'image de façon logique dans l'ordre de tabulation. Ainsi, le texte des objets de texte et des info-bulles, ou le texte personnalisé de l'image pour le lecteur d'écran, doit être lu au moment approprié.
Etant donné que l'ordre de tabulation est important, veillez à positionner les objets avec précision sur le formulaire, les uns par rapport aux autres. Par exemple, vous pouvez positionner et redimensionner un objet en utilisant ses coordonnées et aligner des objets sur des points d'une grille.
si vous créez un formulaire PDF interactif volumineux sans structure, l'utilisateur final risque de constater une baisse des performances lorsqu'il passe d'un champ à l'autre. Vous pouvez remédier à ce problème en enregistrant le formulaire sans ordre de tabulation. Cependant, si votre formulaire doit être accessible aux utilisateurs ayant des déficiences visuelles ou autres, vous devez l'enregistrer comme fichier PDF balisé. Pour contourner ce problème, vous pouvez regrouper des sections du formulaire dans des sous-formulaires sans nom. Ceci permet d'ajouter la structure requise au formulaire.
Voir aussi
A propos de l'ordre de tabulation
Fonctionnement de l'ordre de tabulation
Pour définir l'ordre de tabulation
Pour définir la position des objets
Pour utiliser les accessoires de dessin


Formulaires en couleur accessibles

Utilisées de façon judicieuse, les couleurs peuvent améliorer considérablement la convivialité des formulaires. L'utilisation intensive de couleurs peut réduire le confort visuel et obscurcir le texte au premier plan.
La conception de formulaires pour l'accessibilité implique la prise en compte d'instructions supplémentaires pour l'utilisation de la couleur. Employez-les, par exemple, pour faire ressortir certaines parties d'un formulaire, mais évitez de reposer sur leur seule utilisation pour véhiculer des informations.
Par exemple, un astérisque rouge indique souvent qu'un champ de texte requiert une saisie de l'utilisateur. Etant donné que les utilisateurs présentant une déficience visuelle risquent d'avoir des difficultés à voir la couleur rouge, la meilleure solution est de choisir le type de champ de texte Saisie utilisateur - Obligatoire pour les formulaires accessibles et de définir un message indiquant que le champ requiert la saisie utilisateur.
De nombreux utilisateurs ayant une déficience visuelle s'appuient sur le contraste prononcé entre le texte et l'arrière-plan pour lire le formulaire. Nous vous recommandons vivement d'utiliser la police et les couleurs d'arrière-plan par défaut, le noir sur fond blanc fournit un contraste élevé qui améliore la lisibilité du formulaire. Si vous devez modifier ces couleurs par défaut, veillez à choisir une combinaison appropriée de couleurs à contraste élevé.
Concevez votre formulaire de manière qu'il interagisse naturellement avec les normes des autres applications et systèmes, notamment la prise en charge des paramètres du Panneau de configuration de Windows pour les couleurs. Un utilisateur daltonien ou souffrant d'une autre déficience visuelle peut avoir des difficultés à repérer la position du curseur. Ce problème peut être éliminé en utilisant les paramètres standard des couleurs.
Lors de la conception de votre formulaire, testez-le souvent à l'aide d’un modèle de couleurs semblable à celui dont se servent les utilisateurs ayant une déficience visuelle pour remplir ce formulaire. Cela permet de détecter et de corriger les problèmes dès le début de la conception.
Voir aussi
Propriétés de la palette Police
Propriétés de la palette Paragraphe
Propriétés de la palette Bordure
Techniques de vérification de l'accessibilité d'un formulaire


Lecteurs d'écran pris en charge

Pour accéder à des informations vocales associées à un formulaire, les utilisateurs ayant une déficience visuelle doivent utiliser un lecteur d'écran. Les lecteurs d'écran transmettent à l'utilisateur des informations sur l'emplacement du curseur à l'écran. En tant qu'auteur du formulaire, vous devez préciser le texte que doit transmettre le lecteur d'écran. Si le formulaire est enregistré au format PDF, il vous faut également générer un formulaire PDF balisé.
LiveCycle Designer prend en charge les lecteurs d'écran compatibles MSAA (Microsoft Active Accessibility) et JAWS pour Windows de la société Freedom Scientific.
Voir aussi
Conseils sur la conception de formulaires pour lecteurs d'écran
Propriétés de la palette Accessibilité


Conseils sur la conception de formulaires pour lecteurs d'écran

Pour produire un formulaire accessible, vous devez comprendre le fonctionnement des lecteurs d'écran. Vous devez également savoir comment utiliser la palette Accessibilité de LiveCycle Designer pour définir les informations que le lecteur d'écran transmet au sujet des objets apparaissant sur les formulaires. Ayez à l'esprit les points suivants lorsque vous créez des formulaires accessibles compatibles avec des lecteurs d'écran :
      •
      Le formulaire doit indiquer aux utilisateurs son titre et la méthode de remplissage. Lorsqu'un formulaire s'ouvre, le lecteur d'écran lit généralement toute la page, y compris les objets d'image et de texte. Lorsque l'utilisateur passe d'un champ à l'autre au moyen de la touche de tabulation, le lecteur d'écran lit le texte associé à chacun des objets au moment où il devient actif.
      •
      Définissez un ordre de tabulation logique comprenant la totalité du texte, des boutons, des champs et des images pour faciliter la navigation des utilisateurs ayant des déficiences visuelles. La définition de l'ordre de tabulation est un facteur important, car les balises PDF de lecteur d'écran sont organisées par défaut de haut en bas et de gauche à droite.
      •
      Annoncez aux utilisateurs toute combinaison de touches spéciale qu'ils doivent actionner pour exécuter une fonction. Par exemple, appuyer sur la barre d'espacement pour sélectionner un bouton ou sur la touche fléchée Bas pour sélectionner un élément dans une liste déroulante.
      •
      Annoncez le nom des boutons et des champs, ainsi que leur rôle, lorsque l'utilisateur y arrive par tabulation. Envisagez de recourir à ces techniques :
      •
      Annoncez l'état des cases à cocher et des boutons radio.
      •
      Dans les zones de liste ou les zones de liste déroulante, annoncez l'élément sélectionné par défaut dans la liste. Assurez-vous que l'utilisateur sait qu'il doit utiliser les touches fléchées Haut et Bas pour se déplacer dans les éléments de la liste. La touche de tabulation ou la touche Entrée ont pour effet de sélectionner l'élément activé dans la liste. A l'aide de scripts, vous pouvez définir l'événement change de l'objet de sorte qu'il annonce l'élément sélectionné dans la liste.
Voir aussi
Propriétés de la palette Accessibilité
Pour associer un texte de lecteur d'écran personnalisé à un objet
Pour définir une info-bulle personnalisée à associer à un objet
Pour indiquer un autre ordre de recherche de texte de lecteur d'écran
Pour désactiver le texte de lecteur d’écran associé à un objet


Pour créer un formulaire PDF assorti de balises d'accessibilité

Outre l'ajout de texte destiné aux lecteurs d'écran, vous devez créer un formulaire PDF balisé pour que le lecteur puisse lire le texte. Pour ce faire, vous générez des balises d'accessibilité lorsque vous enregistrez la conception du formulaire comme fichier PDF.
Dans LiveCycle Designer, l'action par défaut consiste à créer des formulaires PDF balisés.
1.
Choisissez Fichier > Enregistrer.
2.
Dans la liste Type de la boîte de dialogue Enregistrer sous, sélectionnez l'une des options Fichiers de formulaire PDF (*.pdf).d'Acrobat.
3.
Dans la zone Options d’enregistrement, cochez la case Générer les données d’accessibilité (balises) pour Acrobat.
Voir aussi
Ordre de tabulation dans les formulaires accessibles
Conseils pour la création de formulaires PDF accessibles


Conseils pour la création de formulaires PDF accessibles

Ces conseils vous aident à créer des formulaires accessibles destinés à Acrobat et Adobe Reader :
      •
      Les objets Cercle, Ligne et Rectangle ne sont pas balisés dans les formulaires PDF. Ces objets n’ajoutent pas d’informations utiles pour les utilisateurs ayant une déficience visuelle ou autre. Les lecteurs d'écran ne lisent pas les informations contenues dans ces objets.
      •
      Ne définissez pas l'option Précédence du lecteur d'écran sur Aucun pour les objets de champ. Si vous le faites, Acrobat génère une erreur dans le lecteur d'écran (invite de données MSAA non disponible) lorsque l'utilisateur accède au champ, même si ce dernier est en lecture seule.
      •
      Les sous-formulaires sont utiles pour organiser les objets associés et fournir une structure logique. Par défaut, l'ordre de tabulation va de gauche à droite et de haut en bas. Si deux sous-formulaires sont placés l'un à côté de l'autre, et que chaque sous-formulaire contient un certain nombre d'objets de champ, la séquence de tabulation passe par les champs du premier sous-formulaire avant de passer à ceux du second.
      •
      Quand il arrive sur un bouton radio, le lecteur d'écran lit d'abord le texte de l'objet de groupe, puis la valeur du bouton radio. Vous devez définir un texte de lecteur d'écran personnalisé pour chaque groupe d'exclusion de boutons radio et vous assurer que la valeur des boutons radio est significative ou qu'elle correspond à la légende.
      •
      Les images peuvent faciliter la compréhension des utilisateurs souffrant de déficiences. Mais, de nombreux lecteurs d'écran ne lisent pas les graphiques, ce qui peut réduire l'accessibilité des utilisateurs présentant une déficience visuelle à votre formulaire. Si vous choisissez d'utiliser des images, fournissez les descriptions textuelles qui décrivent l'objet et son rôle dans le formulaire.
      •
      L'ordre de tabulation des objets dans les pages et leurs gabarits est déterminé par les coordonnées verticales des objets. Testez vos formulaires afin de vérifier que le lecteur d'écran lit les objets dans l'ordre que vous avez choisi.
      •
      Gardez à l'esprit que les scripts client peuvent entrer en conflit avec des lecteurs d'écran et des claviers s'ils ont pour effet de modifier la cible d'action de l'application client. Par exemple, les événements change et mouseEnter, lorsqu'ils sont associés à une zone de liste ou une zone de liste déroulante, peuvent déclencher des actions inadéquates. Les scripts client doivent être rédigés de manière à éviter les problèmes qui risquent d'affecter les lecteurs d'écran et les claviers. De même, évitez les événements de script produisant des effets visuels, tels qu'un texte clignotant, qui peut accroître les problèmes de lisibilité des utilisateurs.
      •
      Si le formulaire contient un nombre élevé d'objets, la tabulation dans Acrobat 6.0 risque d'être lente. Si vous créez un formulaire compatible avec Acrobat 6.0, ajoutez des sous-formulaires sans nom autour de petits groupes d'objets de formulaire afin d'ajouter des niveaux à la structure logique et de résoudre le problème.
      •
      Les auteurs et les utilisateurs de formulaires doivent être conscients de certains problèmes connus concernant Acrobat et les lecteurs d'écran :
      •
      Lorsque les utilisateurs saisissent des données dans un champ, y compris un champ de mot de passe, les lecteurs d'écran lisent chaque caractère dans l'ordre inverse de la frappe.
      •
      Chaque fois qu'un message s'affiche, pour signaler une erreur de validation par exemple, le formulaire n'est plus actif. Appuyez de nouveau sur la touche de tabulation pour revenir au premier champ indiqué dans l'ordre de tabulation.
      •
      Le lecteur d'écran lit tous les textes comme s'ils étaient écrits dans la langue défini par le paramètre régional par défaut du formulaire.
Voir aussi
Conseils sur la conception de formulaires pour lecteurs d'écran
Pour créer un formulaire PDF assorti de balises d'accessibilité
Propriétés de la palette Accessibilité
Pour désactiver le texte de lecteur d’écran associé à un objet


Techniques de vérification de l'accessibilité d'un formulaire

Pour vous assurer que les formulaires sont accessibles à un grand nombre d'utilisateurs, vous devez les tester à l'aide de différents dispositifs d'assistance. Vous pouvez tester vos formulaires simplement et rapidement à l'aide des techniques suivantes :
      •
      Assurez-vous qu'il est possible de remplir le formulaire en utilisant seulement le clavier. Prenez soin de remplir le formulaire en entier et de tester tous les champs et tous les boutons. A mesure que vous remplissez le formulaire, déterminez les améliorations à apporter. Pour cela, posez-vous les questions suivantes :
      •
      Existe-t-il des opérations qui ne peuvent pas être effectuées ?
      •
      Existe-t-il des opérations qui semblent bizarres ou difficiles à effectuer ?
      •
      Est-ce que les séquences de touches sont bien documentées ?
      •
      Est-ce qu'un raccourci clavier a été défini pour chacune des commandes et des touches ?
      •
      Des versions de démonstration des lecteurs d'écran sont disponibles gratuitement sur Internet. Pour tester les résultats des lecteurs d'écran, éteignez votre moniteur et remplissez un formulaire en ne vous servant que du lecteur d'écran. Comme vous avez conçu formulaire et que vous en maîtriser les moindres caractéristiques, vous aurez peut-être du mal à déterminer si l'information lue par le lecteur d'écran est suffisante et a du sens. Par conséquent, si cela est possible, demandez à quelqu'un d'autre de tester votre formulaire de cette façon.
      •
      Des versions de démonstration d'agrandisseurs d'écran sont également disponibles sur Internet.
      •
      Vous pouvez vous procurer des logiciels pilotés par la voix à peu de frais chez des détaillants locaux. Testez vos formulaires en utilisant uniquement des données vocales.
      •
      De nombreux utilisateurs ayant une déficience visuelle s'appuient sur le contraste prononcé entre le texte et l'arrière-plan pour lire le formulaire. Microsoft Windows propose un modèle de couleurs pour contraste élevé qui permet d'afficher des écrans semblables à ceux dont se servent les utilisateurs ayant une déficience visuelle pour remplir leurs formulaires. Pour régler votre écran en mode contraste élevé, activez cette fonction dans les Options d'accessibilité du Panneau de configuration de Windows. A mesure que vous remplissez le formulaire en utilisant ce mode, déterminez les améliorations à apporter. Répondez pour cela aux questions suivantes :
      •
      Existe-t-il des parties du formulaire qui deviennent invisibles, indéchiffrables ou difficiles à utiliser ?
      •
      Est-ce que certaines parties du formulaire demeurent noires sur un fond blanc ?
      •
      Est-ce que la taille de certains éléments est incorrecte ou tronquée ?


Définition d’objets accessibles

Pour associer un texte de lecteur d'écran personnalisé à un objet
Pour définir une info-bulle personnalisée à associer à un objet
Pour indiquer un autre ordre de recherche de texte de lecteur d'écran
Pour désactiver le texte de lecteur d’écran associé à un objet
Création de tableaux simples accessibles
Création de tableaux complexes accessibles
Pour rendre accessible les boutons radio
Définition de listes accessibles
Création d’images accessibles
Création de scripts accessibles
Saut de sections dans des formulaires


Pour associer un texte de lecteur d'écran personnalisé à un objet

Utilisez la palette Accessibilité pour définir le texte de lecteur d'écran personnalisé à associer à un objet donné.
Pour tester votre formulaire, assurez-vous que l'option Lire les champs de formulaire d'Acrobat est configurée dans le menu Edition de la boîte de dialogue Préférences (catégorie Lecture).
1.
Sélectionnez l'objet sur le modèle de formulaire.
2.
Cliquez sur la palette Accessibilité et, dans le champ Texte du lecteur d'écran personnalisé, tapez le texte personnalisé.
Voir aussi
Propriétés de la palette Accessibilité
Pour définir une info-bulle personnalisée à associer à un objet


Pour définir une info-bulle personnalisée à associer à un objet

Utilisez la palette Accessibilité pour définir une info-bulle personnalisée à associer à un objet donné. Pour la plupart des objets, les info-bulles apparaissent au moment de l'exécution lorsque l'utilisateur passe le pointeur sur l'objet. Les info-bulles apparaissent pour certains objets en lecture seule, tels qu'un objet de code à barres de formulaire papier, seulement lorsqu’un lecteur d'écran est utilisé.
Un texte d'info-bulle personnalisée unique et un texte de lecteur d'écran personnalisé unique ne peuvent pas être associés à un seul objet. Vous devez choisir l'un ou l'autre. Si vous souhaitez utiliser une info-bulle personnalisée, saisissez le texte personnalisé et sélectionnez Info-bulle dans la liste Précédence du lecteur d'écran ou n'incluez pas de texte de lecteur d'écran personnalisé. Si vous souhaitez utiliser le texte de lecteur d'écran personnalisé pour l'info-bulle et le texte de lecteur d'écran, saisissez le texte personnalisé et sélectionnez Texte personnalisé dans la liste Précédence du lecteur d'écran.
Si rien n'est spécifié dans la zone Info-bulle ou Texte du lecteur d'écran personnalisé, le lecteur d'écran utilisera la légende pour l'info-bulle et la lecture.
1.
Sélectionnez l'objet sur le modèle de formulaire.
2.
Cliquez sur la palette Accessibilité et, dans la zone Info-bulle, tapez le texte voulu.
3.
S'il existe aussi un texte de lecteur d'écran personnalisé associé à cet objet et que vous voulez que le lecteur d'écran lise l'info-bulle et non le texte personnalisé, dans la liste Précédence du lecteur d'écran, sélectionnez Info-bulle.
Voir aussi
Propriétés de la palette Accessibilité
Pour associer un texte de lecteur d'écran personnalisé à un objet
Pour indiquer un autre ordre de recherche de texte de lecteur d'écran


Pour indiquer un autre ordre de recherche de texte de lecteur d'écran

Par défaut, le lecteur d'écran recherche les options de formulaire dans l'ordre suivant : Texte personnalisé, Info-bulle, Légende et Nom. Vous pouvez modifier cet ordre par défaut à l'aide de l'option Précédence du lecteur d'écran.
1.
Sélectionnez l'objet sur le modèle de formulaire.
2.
Cliquez sur la palette Accessibilité.
3.
Dans la liste Précédence du lecteur d'écran, sélectionnez l'option voulue.
Par exemple, si vous voulez que le lecteur d'écran lise le nom plutôt que la légende, sélectionnez Nom. L'ordre de recherche devient Nom, Texte personnalisé, Info-bulle et Légende.
Voir aussi
Propriétés de la palette Accessibilité
Pour définir une info-bulle personnalisée à associer à un objet
Pour désactiver le texte de lecteur d’écran associé à un objet


Pour désactiver le texte de lecteur d’écran associé à un objet

Dans certaines situations, il est préférable qu'aucun texte ne soit lu pour un objet donné, y compris le type de l'objet. A l'aide de la palette Accessibilité, vous pouvez désactiver le texte du lecteur d'écran pour certains objets et l'activer pour d'autres.
Pour tester votre formulaire, assurez-vous que l'option Lire les champs de formulaire d'Acrobat est configurée dans le menu Edition de la boîte de dialogue Préférences (catégorie Lecture).
1.
Sélectionnez l'objet sur le modèle de formulaire.
2.
Cliquez sur la palette Accessibilité.
3.
Dans la liste Précédence du lecteur d'écran, sélectionnez Aucun.
Voir aussi
Propriétés de la palette Accessibilité
Pour indiquer un autre ordre de recherche de texte de lecteur d'écran


Création de tableaux simples accessibles

Les tableaux constituent un moyen efficace pour organiser et présenter le contenu dans des formulaires accessibles. Utilisées correctement, les rangées et les colonnes d'un tableau offrent une structure prévisible et cohérente du contenu des formulaires.
Par exemple, lorsqu'un utilisateur navigue dans une cellule d'une rangée, le lecteur d'écran indique l'emplacement de la cellule et lit son contenu. Le lecteur d'écran indique l'emplacement de la cellule en utilisant une combinaison d'en-tête de rangée et de colonne ou des numéros de rangée et de colonne.
Outre l'emplacement d'une cellule, les lecteurs d'écran peuvent également spécifier des informations d'en-tête, comme le contenu de la cellule en haut de la colonne. Comme les lecteurs d'écran fournissent des informations qui orientent l'utilisateur vers l'emplacement du contenu du tableau, la disposition affecte directement l'accessibilité du tableau.
Il est recommandé d'utiliser des tableaux dont la disposition est simple. Les tableaux simples commencent par une rangée d'en-tête unique suivie des rangées de contenu.
Lors de la conception de tableaux simples pour l'accessibilité, tenez compte des conseils suivants :
      •
      L'ordre de tabulation d'un tableau est l'ordre géographique, identique à celui du formulaire lui-même. Assurez-vous que le contenu du tableau est organisé de manière logique, de gauche à droite et de haut en bas.
      •
      La plupart des lecteurs d'écran interprètent la première rangée d'un tableau comme rangée d'en-tête. Lors de la lecture du contenu d'une cellule de rangée de contenu, ces lecteurs d'écran lisent d'abord le contenu de la cellule de rangée d'en-tête associée. Assurez-vous que le contenu de chaque rangée d'en-tête décrit le contenu de la colonne de manière significative.
      •
      Evitez les cellules qui s'étendent sur deux ou plusieurs colonnes, des tableaux imbriqués ou des sections de tableau. Les lecteurs d'écran ont des difficultés à interpréter correctement ces fonctions. D'ailleurs, ils peuvent ne pas les utiliser. Par exemple, si une cellule d'une rangée de contenu s'étend sur deux colonnes, les lecteurs d'écran risquent de ne pas référencer le contenu de cellule approprié dans la rangée d'en-tête lors de la lecture de la cellule suivante de la rangée.
Voir aussi
Création de tableaux complexes accessibles
Propriétés de la palette Accessibilité


Création de tableaux complexes accessibles

Lors de la conception de tableaux pour l'accessibilité, nous vous recommandons d'adopter une disposition simple, avec une rangée d'en-tête suivie des rangées de contenu. Cependant, dans certains cas, au lieu d'utiliser les opérations de présentation standard, il peut être préférable de présenter le contenu dans un tableau nécessitant une disposition plus complexe. Par exemple, vous pouvez avoir besoin d'utiliser l'étendue des cellules ou plusieurs en-têtes pour faire ressortir le contenu.
Vous pouvez créer des tableaux complexes en utilisant l'objet de tableau ou en combinant des objets de sous-formulaire. L'objet de tableau permet d'utiliser les fonctions destinées à faciliter la conception, comme les options d'insertion et de redimensionnement des colonnes et des rangées.
Selon votre expérience et vos préférences de conception, vous pouvez choisir de créer des tableaux complexes en combinant des objets de sous-formulaire. Par exemple, vous pouvez créer un sous-formulaire incluant deux rangées et le définir comme en-tête du tableau et spécifier un autre sous-formulaire pour les rangées de contenu du tableau.
Lors de l'utilisation d'objets de sous-formulaire à la place d'objets de tableau pour créer des tableaux, les étapes supplémentaires suivantes doivent être réalisées :
      •
      Définissez le type de chaque sous-formulaire sur Positionné. Voir Propriétés de l'objet Sous-formulaire dans l’onglet Sous-formulaire.
      •
      Dans la palette Accessibilité, définissez le rôle approprié de chaque sous-formulaire constituant le tableau. Par exemple, attribuez le rôle Rangée d'en-tête au sous-formulaire utilisé comme en-tête de tableau. Voir Propriétés de la palette Accessibilité.
      •
      Pour les rangées contenant des informations sur le tableau ou son contenu, mais qui ne sont pas considérées comme faisant partie du tableau, attribuez le rôle de sous-formulaire Aucune. Le lecteur d'écran lit le contenu des rangées.
Les fonctions prises en charge par le lecteur d'écran déterminent les informations lues pour un tableau complexe. Par exemple, supposons qu'un tableau comporte une rangée d'en-têtes et une section contenant une rangée d'en-têtes. Lorsque l'utilisateur navigue dans une cellule de rangée de contenu dans la section du tableau, le lecteur d'écran doit lire ce qui suit, dans cet ordre :
      •
      Contenu de la cellule concernée dans la rangée d'en-têtes du tableau
      •
      Contenu de la cellule concernée dans la rangée d'en-têtes de la section
      •
      Contenu de la cellule sélectionnée
Certains lecteurs d'écran ne peuvent pas lire les cellules des deux rangées d'en-têtes.
Voir aussi
Création de tableaux simples accessibles


Pour rendre accessible les boutons radio

Lorsque vous parcourez un groupe d'exclusion à l'aide la touche de tabulation, le lecteur d'écran lit d'abord le texte du groupe d'exclusion et ensuite la légende du bouton radio actif.
Lorsqu'un utilisateur présentant des troubles visuels accède à un bouton radio à l'aide de la touche de tabulation, le lecteur d'écran doit lire deux éléments :
      •
      Une description générale portant sur la fonction du groupe de boutons
      •
      Une description significative portant sur la fonction de chaque bouton radio
Par exemple, un formulaire contient un groupe de boutons radio relatif aux paiements. Le texte lu décrivant le groupe d'exclusion doit être : « Sélectionnez un mode de paiement ». La valeur des boutons doit être respectivement « Espèces », « Carte de crédit » et « Chèque ». Lorsque l'utilisateur parcourt le groupe d'exclusion et que le premier bouton radio, Espèces, est activé, le lecteur d'écran doit indiquer le type d'objet et afficher « Sélectionnez le mode de paiement. Espèces ». Il doit également indiquer l'état (activé ou désactivé).
LiveCycle Designer inclut des options prenant en charge les lecteurs d'écran pour la définition de texte vocal. Vous pouvez utiliser la palette Accessibilité pour définir le texte de lecteur d'écran personnalisé et les info-bulles. Vous pouvez également utiliser des noms d'objet, comme indiqué dans l’option Nom de l'onglet Liaison, ainsi que des légendes. Autant que possible, les légendes des boutons radio doivent fournir un texte significatif au lecteur d'écran.
Pour rendre les boutons radio accessibles à l’aide de légendes de bouton
1.
Dans la palette Hiérarchie, cliquez sur le groupe d'exclusion.
2.
Cliquez sur la palette Accessibilité et, dans la zone Texte du lecteur d'écran personnalisé, indiquez le texte lu du groupe. Par exemple, saisissez Select a method of payment.
3.
Si les légendes de chaque bouton radio fournissent un texte lu significatif, sélectionnez l’onglet Liaison de la palette Objet, puis désélectionnez Spécifier la valeur.
Pour rendre des boutons radio accessibles à l’aide d’une valeur spécifiée
1.
Dans la palette Hiérarchie, cliquez sur le groupe d'exclusion.
2.
Cliquez sur la palette Accessibilité et, dans la zone Texte du lecteur d'écran personnalisé, indiquez le texte lu du groupe. Par exemple, saisissez Select a method of payment.
3.
Dans la palette Hiérarchie, sélectionnez le premier bouton radio du groupe.
4.
Cliquez sur l'onglet Champ de la palette Objet. Dans la zone Élément, cliquez deux fois sur l'élément et indiquez une valeur significative pour le bouton radio sélectionné. Par exemple, saisissez Cash.
5.
Appliquez les étapes 3 et 4 à chaque bouton du groupe d'exclusion.
Voir aussi
Aperçu des boutons radio
Propriétés de la palette Accessibilité
Pour associer un texte de lecteur d'écran personnalisé à un objet


Définition de listes accessibles

Si la conception de formulaire contient des listes créées en imbriquant des sous-formulaires dans la conception, vous pouvez vous servir de la palette Accessibilité pour définir le rôle approprié de chaque sous-formulaire constituant la liste de façon à ce que le lecteur d'écran annonce la liste, le nombre d'éléments dans la liste, le niveau d'imbrication et la fin de la liste.
Attribuez, par exemple, le rôle Liste au sous-formulaire de niveau supérieur et le rôle Article de liste aux sous-formulaires imbriqués correspondant aux articles de liste.
Voir aussi
Propriétés de la palette Accessibilité
Pour associer un texte de lecteur d'écran personnalisé à un objet


Création d’images accessibles

Les images peuvent faciliter la compréhension des utilisateurs souffrant de déficiences, mais de nombreux lecteurs d'écran ne lisent pas les éléments graphiques. Les images peuvent réduire l'accessibilité à votre formulaire pour les utilisateurs souffrant d'une déficience visuelle.
Si vous choisissez d'utiliser des images, fournissez des descriptions pour l'ensemble des images et objets de champ d’image. Lorsque les utilisateurs accèdent à l'objet, le lecteur d'écran lit le texte. Assurez-vous que le texte décrit l'objet et son rôle dans le formulaire.
Vous fournissez des descriptions textuelles en utilisant des info-bulles ou un texte de lecteur d'écran personnalisé dans la palette Accessibilité ou des champs de texte, légendes et noms d'objet comme indiqué dans l’option Nom de l'onglet Liaison.
Outre le texte descriptif des images, considérez les instructions générales suivantes dans le but d'améliorer l’accessibilité des images de vos formulaires :
      •
      Assurez-vous que les images améliorent le contenu du formulaire sans fournir des détails inutiles.
      •
      Pour les images contenant de la couleur, choisissez des couleurs à contraste élevé pour optimiser la lisibilité.
      •
      Assurez-vous la taille des images n’est pas trop petite pour une lecture normale.
Voir aussi
Aperçu des images
Aperçu des champs d'image
Propriétés de la palette Accessibilité
Formulaires en couleur accessibles


Création de scripts accessibles

Dans le processus de conception des formulaires, un développeur de formulaires peut utiliser des scripts afin d'apporter à l'utilisateur un confort d'utilisation amélioré. Vous pouvez ajouter des scripts à la plupart des champs et objets. Par exemple, vous pouvez créer des scripts simples pour mettre à jour dynamiquement des valeurs sur un formulaire interactif en réponse à une entrée d'utilisateur.
Lors de la conception de scripts pour l'accessibilité, tenez compte des instructions générales suivantes :
      •
      Le contenu du formulaire ne doit faire l'objet d’interruptions visuelles. Par exemple, évitez les fonctions qui entraînent le tremblement, le clignotement ou le déplacement du contenu.
      •
      Assurez-vous que les fenêtres contextuelles ne s'affichent qu'à l’issue d’actions exécutées par l'utilisateur. De même, n’autorisez pas le changement de la sélection dans le formulaire ou le réaffichage du contenu, sauf s'il est exécuté par l'utilisateur. La sélection dans le formulaire fait référence à la vue actuelle de l'utilisateur. Par exemple, si l’utilisateur complète des champs dans la moitié inférieure du formulaire, n'autorisez pas le changement de sélection vers le coin supérieur gauche du formulaire, sauf si l'utilisateur choisit de naviguer vers cet emplacement.
      •
      Les utilisateurs souffrant de déficiences peuvent avoir besoin de plus de temps pour remplir les champs. Ne prévoyez pas des réponses en temps limité pour le remplissage des champs.
      •
      Gardez à l'esprit que les scripts client peuvent entrer en conflit avec des lecteurs d'écran et des claviers s'ils ont pour effet de modifier la cible d'action de l'application client. Par exemple, les événements change et mouseEnter, lorsqu'ils sont associés à une zone de liste ou une zone de liste déroulante, peuvent déclencher des actions inadéquates. Les scripts client doivent être rédigés de manière à éviter les problèmes qui risquent d'affecter les lecteurs d'écran et les claviers.
Voir aussi
A propos des calculs et des scripts


Saut de sections dans des formulaires

Vous pouvez donner aux utilisateurs de lecteurs d'écran la possibilité d'ignorer certaines sections du formulaire. Pour ce faire, il suffit de placer des objets de texte statiques au début des différentes sections d'un formulaire et d'utiliser la palette Accessibilité pour attribuer le rôle de sous-formulaire Titre à chaque objet de texte statique.
Lorsque l'utilisateur appuiera sur la touche H dans le lecteur d'écran JAWS, celui-ci passera de l'objet actif au prochain objet de texte statique ayant le rôle Titre dans le formulaire.
Voir aussi
Propriétés de la palette Accessibilité
Pour associer un texte de lecteur d'écran personnalisé à un objet


Configuration de la protection

A propos des formulaires sécurisés
Utilisation de signatures numériques
Utilisation des champs de mot de passe
Utilisation des options de protection PDF


A propos des formulaires sécurisés

Lorsque vous concevez des formulaires PDF interactifs, il est très important de vous assurer qu'ils sont sécurisés, ainsi que les données qu'ils contiennent. Les fonctions et options suivantes de LiveCycle Designer servent à sécuriser vos formulaires :
      •
      Les options de protection PDF servent à définir les droits d’accès des utilisateurs aux formulaires PDF. Dans la boîte de dialogue Propriétés du formulaire, vous pouvez spécifier un mot de passe que les utilisateurs doivent introduire pour ouvrir et remplir le formulaire. Vous pouvez aussi restreindre divers niveaux d’accès au formulaire. Vous pouvez par exemple autoriser les utilisateurs à remplir des champs et à entrer des signatures, mais pas à ajouter des commentaires ni des pages au formulaire.
      •
      Les signatures numériques vous permettent d'authentifier la signature d'un utilisateur et d'éviter que le formulaire soit modifié après la signature. Pour ajouter un champ de signature numérique à une conception de formulaire, vous pouvez utiliser le champ de signature du document ou une signature de données associée à un bouton d'envoi. Le champ de signature du document permet de protéger l'aspect des objets du formulaire et les données qu'ils contiennent. Une signature de données permet quant à elle de protéger l'intégrité des données du formulaire.
      •
      Les champs de mot de passe servent à contrôler l'accès au formulaire. Vous pouvez sélectionner l'option de caractère de masquage de champ afin que les données ne s'affichent pas à l'écran. Vous pouvez indiquer si le mot de passe est facultatif, recommandé ou obligatoire, et définir des messages qui guideront les utilisateurs de façon appropriée. Toutes les données entrées par l'utilisateur peuvent être validées par un script. Vous pouvez aussi lier des champs de mot de passe à des sources de données.
Voir aussi
Utilisation des options de protection PDF
Aperçu des champs de signature de document
Aperçu des boutons
Aperçu des champs de mot de passe


Utilisation de signatures numériques

A propos des signatures numériques
Pour ajouter un champ de signature du document
Pour tester un champ de signature du document
Pour ajouter une signature de données à un bouton d'envoi


A propos des signatures numériques

Vous pouvez protéger l'intégrité des formulaires en permettant aux utilisateurs de les signer numériquement à l'aide de certificats. Dès qu'un formulaire a été signé, la partie signée ne peut plus être modifiée sans que la signature soit invalidée. La signature numérique implique l'intervention d'un gestionnaire de signatures tiers qui offre les fonctions de signature numérique requises.
La vérification de la signature vous certifie que personne n’a altéré les données une fois qu’elles ont été soumises. Lorsqu'une personne signe un formulaire, un condensé de message des données à être signées est créé et un calcul mathématique combine la clé privée de cette personne avec les données du formulaire spécifiées, puis les chiffre ensemble. Ce calcul résulte en une signature numérique. La signature numérique contient les données signées et les informations de certificat associées à la personne ayant signé le formulaire.
Une fois la signature vérifiée, la clé publique de la personne en question est utilisée pour déchiffrer les données signées et pour obtenir la valeur digest. La nouvelle valeur digest est calculée selon les valeurs contenues dans le document reçu avec le même algorithme que celui du processus de signature. Si les deux valeurs digest ne correspondent pas, cela signifie qu'elles ont été modifiées après la signature du formulaire, et l'authentification échoue.
Les signatures numériques lient également les certificats aux données signées. Le certificat inclus dans la signature peut être authentifié afin de valider l'identité de la personne qui a signé les données.
Pour pouvoir signer le formulaire, la personne doit disposer d'un certificat numérique provenant d'un émetteur de certificats attitré. Les signatures Adobe prennent en charge la norme de cryptographie à clé publique n°7, par le biais de l'algorithme de hachage RSA MD5, RSA SHA-1 ou DSA SHA-1.
LiveCycle Designer propose les deux types de signatures numériques suivants.
Signatures du document
Les signatures du document permettent de protéger l'aspect des objets de formulaire et les valeurs qu'ils contiennent. Pour créer une signature du document, ajoutez un champ de signature du document à la conception de formulaire. Vous pouvez indiquer si la signature numérique s'applique à l'intégralité du formulaire ou à une collection d'objets bien précis. Par défaut, elle s'applique à l'intégralité du formulaire. Si vous souhaitez que la signature numérique s'applique à une collection d'objets de formulaire, l'utilisateur qui appose sa signature doit utiliser Acrobat ou Adobe Reader 8.0 ou une version ultérieure.
Si la signature s'applique à une collection d'objets, celle-ci ne prend pas en compte les objets statiques, tels que cercles et rectangles. Elle s'applique uniquement aux boutons, cases à cocher, champs de date/heure, champs décimaux, listes déroulantes, champs d'image, zones de liste, champs numériques, codes à barres de formulaires pour support papier, champs de mot de passe, boutons radio, autres champs de signature du document et champs de texte.
Pour signer le formulaire, l'utilisateur clique dans le champ de signature du document. Si la signature du document s'applique à une collection d'objets de formulaire, les objets spécifiés dans la signature sont verrouillées et ne sont disponibles qu'en lecture seule. Le verrouillage des objets empêche les destinataires du formulaire de modifier les valeurs de l'objet après que le document ait été signé.
Signatures de données
La signature de données protège les données du formulaire tout en assurant leur intégrité lors de la transmission. Pour créer une signature de données, ajoutez un bouton d'envoi, un bouton d'envoi par messagerie ou un bouton d'envoi via HTTP, puis sélectionnez l'option Signature de l'envoi dans la palette Objet. Pour signer les données, l'utilisateur qui appose sa signature doit utiliser Acrobat ou Adobe Reader 8.0 ou une version ultérieure.
Les signatures de données peuvent s'appliquer uniquement aux données du formulaire ou à la totalité de l'envoi, y compris aux pièces jointes (annotations, signatures du document ou documents PDF).
Pour signer les données du formulaire, l'utilisateur doit cliquer sur le bouton d'envoi. Lorsqu'un utilisateur clique sur ce bouton, il doit fournir son certificat de signature afin que sa signature numérique s'applique aux données du formulaire avant d'être envoyée.
Voir aussi
Aperçu des champs de signature de document
Aperçu des boutons
A propos de l'envoi de données au moyen d'un bouton


Pour ajouter un champ de signature du document

LiveCycle Designer offre un champ de signature du document incorporé que vous pouvez ajouter à un formulaire, grâce auquel les utilisateurs peuvent signer les données qu'ils introduisent. Par défaut, la signature du document s'applique à tous les objets constituant le formulaire. Si vous souhaitez que la signature du document s'applique à un ensemble d'objets de formulaire, vous devez créer cet ensemble et le spécifier dans l'onglet Signature du document de la palette Objet.
Si la signature s'applique à une collection d'objets, la signature du document verrouille également les champs de cette collection. Si vous ajoutez plusieurs champs de signature du document dans le but de couvrir diverses parties du formulaire, la première collection d'objets est verrouillée une fois le premier champ de signature signé, et seuls les champs restants du formulaire peuvent être remplis.
Lorsqu'une signature du document s'applique à une collection d'objets, elle protège également la valeur contenue dans ces objets. La signature du document permet également de protéger l'aspect des objets de la collection afin que celui-ci soit conservé lors de l'ouverture du formulaire. La fonction de protection de l'aspect des objets dépend de l'option Préserver les changements de script dans le formulaire à l'enregistrement située dans la boîte de dialogue Propriétés du formulaire. Si cette option est définie sur la valeur par défaut (Automatiquement), l'aspect des objets est automatiquement protégé. Néanmoins, si cette option est définie sur Manuellement, vous devrez écrire un script pour restaurer l'aspect des objets.
Vous devez éviter de répéter un champ de signature du document et ne pas l'insérer dans un objet de sous-formulaire pouvant être répété. Un formulaire avec des champs de signature du document répétés n'est pas valable et peut provoquer des erreurs dans Acrobat ; en outre, le champ de signature risque de ne pas s'afficher.
Si la signature du document s'applique à une collection d'objets, les objets de cette collection ne doivent pas se répéter, car le nombre d'objets peut changer et invalider la signature. Vous pouvez supprimer les objets d'une collection se répétant ou utiliser une signature de données.
Pour signer le formulaire, l'utilisateur clique dans le champ de signature du document. Pour signer une collection d'objets de formulaire, l'utilisateur doit utiliser Acrobat ou Adobe Reader 8.0 ou une version ultérieure.
1.
Dans la palette Bibliothèque, cliquez sur la catégorie Standard, puis faites glisser le champ de signature du document sur la conception de formulaire.
2.
(Facultatif) Pour appliquer la signature du document à une collection de champs dans le formulaire, cliquez sur l'onglet Signature du document de la palette Objet, puis sélectionnez Verrouiller les champs après la signature.
3.
(Facultatif) Créez et sélectionnez une collection :
      •
      Sélectionnez Créer/Gérer une collection.
      •
      Dans la boîte de dialogue Liste des collections, cliquez sur Créer, tapez le nom d'une collection, appuyez sur la touche Entrée, puis cliquez sur Modifier.
      •
      Dans la boîte de dialogue Editeur de collections, sélectionnez les objets que vous souhaitez inclure à la collection, puis cliquez sur OK.
      •
      Cliquez alors sur Fermer dans la boîte de dialogue Liste des collections.
      •
      Sélectionnez la collection dans la liste.
4.
(Facultatif) Appliquez une signature aux champs de la collection ou aux champs se trouvant hors de la collection :
      •
      Pour appliquer la signature aux champs de la collection, sélectionnez Tous les champs de la collection.
      •
      Pour appliquer la signature aux champs se trouvant hors de la collection, sélectionnez Tous les champs hors de la collection.
5.
(Facultatif) Cliquez sur Paramètres pour définir les options de sécurité facultatives, telles qu'un gestionnaire de signatures ou une liste de révocation des certificats.
6.
Utilisez les palettes pour changer l'aspect du champ de signature du document.
7.
Enregistrez la conception de formulaire.
Voir aussi
Aperçu des champs de signature de document
Propriétés des champs de signature du document dans le panneau Champ
A propos des collections d'objets de formulaire
Boîte de dialogue Editeur de collections
Boîte de dialogue Liste des collections


Pour tester un champ de signature du document

Utilisez le panneau Aperçu PDF pour vous assurer que le champ de signature du document se comporte de la façon prévue. Avant de tester la conception de formulaire, assurez-vous que vous avez choisi les options par défaut d'affichage de formulaire interactif dans la boîte de dialogue Propriétés du formulaire.
Pour signer une collection d'objets de formulaire, l'utilisateur doit utiliser Acrobat ou Adobe Reader 8.0 ou une version ultérieure.
1.
Cliquez sur l'onglet Aperçu PDF pour afficher la conception de formulaire en tant que formulaire interactif PDF.
2.
Cliquez dans le champ de signature du document.
3.
Dans la boîte de dialogue Alerte, sélectionnez Poursuivre la signature.
4.
Dans la boîte de dialogue Fichier d'échange de données, sélectionnez une signature numérique ou cliquez sur Ajouter un ID numérique pour créer un ID.
Voir aussi
Aperçu des champs de signature de document
A propos de l'aperçu et des tests de formulaires


Pour ajouter une signature de données à un bouton d'envoi

Vous pouvez configurer un bouton d'envoi pour créer une signature de données avant l'envoi de celles-ci, afin que les utilisateurs puissent signer les données lorsqu'ils envoient le formulaire. Les signatures de données permettent de protéger l'intégrité des données et d'authentifier l'utilisateur lors de la transmission. Vous pouvez par exemple utiliser des signatures de données pour protéger les données du formulaire lors de transactions automatisées.
Pour signer les données, l'utilisateur qui appose sa signature doit utiliser Acrobat ou Adobe Reader 8.0 ou une version ultérieure.
1.
Dans la palette Bibliothèque, cliquez sur la catégorie Standard, puis faites glisser l'un des boutons suivants sur la conception de formulaire : Bouton, Envoyer par messagerie ou Envoyer via HTTP .
2.
Dans la palette Objet, associez une signature de données au bouton :
      •
      Si vous utilisez un bouton standard, sélectionnez Envoyer dans la zone Type de contrôle de l'onglet Champ, puis sélectionnez Signature de l'envoi dans l'onglet Envoyer.
      •
      Si vous utilisez un bouton d'envoi par messagerie ou via HTTP, sélectionnez Signature de l'envoi dans l'onglet Champ.
3.
(Facultatif) Cliquez sur Paramètres pour définir les options de sécurité facultatives, telles que l'application de la signature aux données uniquement ou à la totalité de l'envoi.
4.
Utilisez les palettes pour modifier l'aspect du bouton d'envoi.
5.
Enregistrez la conception de formulaire.
Voir aussi
Aperçu du bouton Envoyer par messagerie
Aperçu du bouton Envoyer via HTTP
A propos de l'envoi de données au moyen d'un bouton


Utilisation des champs de mot de passe

A propos des champs de mot de passe des formulaires interactifs
Pour ajouter un champ de mot de passe dans un formulaire interactif
Pour modifier le caractère d'affichage du mot de passe
Pour spécifier un format de saisie et un message de validation


A propos des champs de mot de passe des formulaires interactifs

Vous pouvez contrôler l'accès à un formulaire en utilisant un champ de mot de passe et un script. Plusieurs options sont associées au champ de mot de passe :
      •
      Une option de caractère de masquage vous permettant de spécifier un caractère qui masque les données introduites par l'utilisateur. En outre, le mot de passe ne s'affiche pas dans le champ de mot de passe.
      •
      Un format de saisie pour s'assurer que l'utilisateur saisit le mot de passe au format correct.
      •
      Un modèle et un message de validation demandant à l'utilisateur de saisir à nouveau le mot de passe si le format n'est pas correct.
      •
      Une option pour spécifier que le mot de passe est obligatoire, recommandé ou facultatif, avec un message invitant l'utilisateur à saisir une valeur recommandée ou obligatoire.
le seul but de l'affichage des caractères dans le champ durant la saisie est que l'utilisateur puisse les voir. Aucune tentative n'est effectuée pour masquer la valeur du champ des interfaces de programmation ou lors de l'envoi des données. Si vous souhaitez sécuriser vos données, vous devez vous servir d'une liaison sécurisée (protocole SSL, par exemple) pour les chiffrer lors de la transmission.
Voir aussi
Aperçu des champs de mot de passe


Pour ajouter un champ de mot de passe dans un formulaire interactif

Vous pouvez ajouter des champs de mot de passe aux formulaires interactifs.
1.
Dans la palette Bibliothèque, cliquez sur la catégorie Standard et faites glisser un objet de champ de mot de passe sur la conception de formulaire.
2.
A l'aide des palettes Disposition, Police, Paragraphe et Bordure, définissez les propriétés du champ de mot de passe.
3.
Ajoutez un format de saisie si vous voulez vous assurer que l'utilisateur introduit le mot de passe dans un format particulier.
4.
Ajoutez un modèle de validation avec message si vous voulez valider les données introduites par l'utilisateur et afficher un message lorsqu'elles ne sont pas correctes. Le modèle de validation doit être identique au format de saisie.
5.
(Facultatif) Modifiez le caractère de masquage par défaut.
6.
Ajoutez toute donnée de liaison nécessaire.
7.
Enregistrez la conception de formulaire et testez-la.
Voir aussi
Aperçu des champs de mot de passe


Pour modifier le caractère d'affichage du mot de passe

Le caractère d'affichage de mot de passe qui s'affiche par défaut lorsqu'un utilisateur entre un mot de passe est l'astérisque (*). Vous pouvez modifier ce caractère à l'aide de l'option Caractère d'affichage du mot de passe dans l'onglet Champ de la palette Objet.
      *
      Dans la palette Objet, cliquez sur l'onglet Champ, sélectionnez le caractère par défaut (*) dans Caractère d'affichage du mot de passe, puis saisissez le nouveau caractère, par exemple #.
Voir aussi
Aperçu des champs de mot de passe


Pour spécifier un format de saisie et un message de validation

Vous pouvez spécifier un format de saisie pour vous assurer que l'utilisateur introduit le mot de passe selon un format correct. Vous pouvez aussi inclure un modèle et un message de validation demandant à l'utilisateur de saisir à nouveau le mot de passe si le format n'est pas correct. Le format de saisie et le modèle de validation que vous spécifiez doivent être identiques. Chaque fois que l'utilisateur introduit un nouveau mot de passe, celui-ci est comparé au modèle de validation. S'il n'y a pas correspondance, la modification n'est pas acceptée.
vous pouvez remplir de manière dynamique un modèle de validation à l'aide d'une valeur issue d'une source de données. Vous serez ainsi assuré que les utilisateurs saisissent la valeur correcte dans le champ.
1.
Dans la palette Objet, cliquez sur l'onglet Champ, puis saisissez un format de saisie dans la zone Format de saisie.
Ce format décrit la façon dont l'utilisateur doit introduire le mot de passe. Le formulaire ne fournit aucune représentation visuelle de ce format. Le formulaire n'acceptera les données que si l'utilisateur les introduit dans ce format.
Pour définir les propriétés de valeur d'un champ de mot de passe, vous devez d'abord sélectionner ce champ dans la conception de formulaire. Les propriétés de valeur peuvent être modifiées dans l’onglet Valeur de la palette Objet.
Si une valeur est recommandée, le message s'affiche une fois. Si une valeur est obligatoire, le message s'affiche continuellement jusqu'à ce que l'utilisateur introduise des données.
2.
Dans la palette Objet, cliquez sur l’onglet Valeur et procédez de l'une des façons suivantes :
      •
      Dans la liste Modèle de validation, sélectionnez un modèle de validation ou saisissez un modèle personnalisé. Les options du modèle de validation doivent être identiques à celles qui ont été définies dans l'option Format de saisie de l’onglet Champ.
      •
      Dans la zone Message du modèle de validation, saisissez un message demandant à l'utilisateur d'entrer la valeur correcte.
3.
Pour générer une erreur à l'exécution, sélectionnez Erreur.
Voir aussi
Formats de mot de passe
Aperçu des champs de mot de passe
Pour remplir de façon dynamique un message de modèle de validation


Utilisation des options de protection PDF

A propos des options de protection PDF
Pour spécifier un mot de passe afin d’ouvrir un formulaire PDF
Pour restreindre l’impression d’un formulaire PDF
Pour restreindre la modification d’un formulaire PDF
Pour activer l’accès au texte des formulaires sécurisés par les lecteurs d’écran


A propos des options de protection PDF

Lorsque vous distribuez des formulaires PDF interactifs, vous pouvez limiter l’accès à certaines fonctionnalités normalement disponibles. Par exemple, dans un formulaire PDF, vous pouvez habituellement ajouter des commentaires, insérer et supprimer des pages, signer, copier du texte et enregistrer des copies du formulaire.
Dans le menu Fichier, vous pouvez sélectionner la boîte de dialogue Propriétés du formulaire et configurer les options de sécurité PDF dans le panneau Sécurité PDF pour restreindre l’accès à certaines fonctions. Vous pouvez désactiver les options suivantes :
      •
      Impression d’un formulaire
      •
      Ouverture d’un formulaire sans mot de passe
      •
      Insertion, extraction ou rotation des pages
      •
      Ajout de commentaires
      •
      Ajout de signatures
      •
      Copie de texte et d’images
      •
      Métadonnées en texte brut
Si vous décidez de limiter l’accès à certaines des fonctions du formulaire PDF, vous devez savoir que les lecteurs d’écran risquent de ne pas être capables de lire les éléments PDF balisés de votre formulaire. Un lecteur d'écran est une technologie qui permet aux utilisateurs ayant une déficience visuelle ou autre d'interagir avec l'ordinateur. Afin que ces utilisateurs puissent accéder sans problème au formulaire, vous devez activer l'accès au texte sur les lecteurs d'écran.
Voir aussi
Utilisation des options de protection PDF


Pour spécifier un mot de passe afin d’ouvrir un formulaire PDF

Vous pouvez spécifier un mot de passe que l’utilisateur doit saisir pour ouvrir un formulaire PDF. Ce processus comporte deux étapes. Vous devez tout d'abord indiquer qu'un mot de passe est requis, puis spécifier le mot de passe que l'utilisateur doit saisir lors de l'ouverture du formulaire.
1.
Choisissez Fichier > Propriétés du formulaire.
2.
Cliquez sur l’onglet Sécurité PDF.
3.
Sélectionnez Exiger un mot de passe pour l'ouverture du document, puis cliquez sur OK.
4.
Enregistrez le formulaire comme formulaire PDF Adobe (*.pdf).
5.
Dans la boîte de dialogue Définir le mot de passe d’ouverture du document, procédez de la façon suivante :
      •
      Dans la boîte de dialogue Mot de passe d’ouverture de document, saisissez un mot de passe.
      •
      Dans la zone Confirmer le mot de passe, saisissez de nouveau le mot de passe.
      •
      Cliquez sur OK.
6.
Fermez la conception de formulaire.
Voir aussi
Utilisation des options de protection PDF


Pour restreindre l’impression d’un formulaire PDF

Vous pouvez empêcher les utilisateurs d'imprimer un formulaire PDF. Vous pouvez spécifier si le formulaire peut être imprimé, imprimé avec une résolution minimale ou imprimé avec une résolution élevée.
1.
Choisissez Fichier > Propriétés du formulaire.
2.
Cliquez sur l’onglet Sécurité PDF.
3.
Dans la zone Droits d’accès, cochez la case Utiliser un mot de passe pour restreindre l’impression et la modification du document et de ses paramètres de protection.
4.
Dans la liste Impression permise, sélectionnez l’une des options suivantes :
      •
      Non
      •
      Basse résolution (150 dpi)
      •
      Haute résolution
Voir aussi
Utilisation des options de protection PDF


Pour restreindre la modification d’un formulaire PDF

Vous pouvez désactiver certaines des fonctionnalités de modification des formulaires PDF :
      •
      Insertion, suppression et rotation des pages
      •
      Ajout de commentaires
      •
      Ajout de signatures
      •
      Copie de texte et d’images
      •
      Autorisation d’utiliser des métadonnées en texte brut
1.
Choisissez Fichier > Propriétés du formulaire.
2.
Cliquez sur l’onglet Sécurité PDF.
3.
Dans la zone Droits d’accès, cochez la case Utiliser un mot de passe pour restreindre l’impression et la modification du document et de ses paramètres de protection.
4.
Dans la liste Modifications permises, sélectionnez l’une des options suivantes :
      •
      Insérer, supprimer et faire pivoter des pages
      •
      Remplir et signer un formulaire
      •
      Commenter, remplir et signer un formulaire
      •
      Tout sauf extraire des pages
5.
Sélectionnez l'une ou les deux options suivantes :
      •
      Activer la copie de texte, d'images et d'autres contenus
      •
      Autoriser les métadonnées en texte brut
Voir aussi
Utilisation des options de protection PDF


Pour activer l’accès au texte des formulaires sécurisés par les lecteurs d’écran

Si vous décidez de sélectionner des options qui limitent l’accès aux fonctions PDF, vous devez savoir que les lecteurs d’écran risquent de ne pas être capables de lire les textes PDF balisés de votre formulaire.
Pour vous assurer que les formulaires sont accessibles aux lecteurs d’écran, vous devez vous assurer d'avoir sélectionné l’option d'accès au texte par lecteurs d’écran.
1.
Choisissez Fichier > Propriétés du formulaire.
2.
Cliquez sur l'onglet Sécurité PDF, puis dans la zone Droits d'accès, sélectionnez les options suivantes :
      •
      Sélectionnez Utiliser un mot de passe pour restreindre l’impression et la modification du document et de ses paramètres de protection.
      •
      Sélectionnez Activer l’accès au texte pour les lecteurs d’écran destinés aux malvoyants.
Voir aussi
Utilisation des options de protection PDF


Création de formulaires en vue d'optimiser les performances

A propos des performances
Observations générales sur la conception en tenant compte des performances
Utilisation d'objets
Structuration des données en vue d'optimiser les performances
Choix des polices en fonction des performances
Performances et importation de formulaires
Performances et formulaires accessibles
Performances et scripts
Performances et expressions de modèles d'objet de formulaire XML
Résolution des messages d'erreur et d'avertissement en vue d'optimiser les performances


A propos des performances

De nombreux facteurs affectent les performances lors de la génération et de l'utilisation de formulaires, notamment le type du formulaire. Il est plus rapide de générer des formulaires non interactifs que des formulaires interactifs.
Parmi les autres facteurs influant sur les performances, citons les polices utilisées dans le formulaire ainsi que le nombre, le type et la complexité des objets. Dans le cas des formulaires liés à des sources de données, la structure même des données a également une incidence sur les performances.
LiveCycle Designer offre diverses options de conception de formulaires. Vous obtiendrez souvent les mêmes résultats sur un formulaire en employant différentes options de conception. Lors de la prise de décision en matière de conception, tenez compte de l'impact des options choisies sur les performances.
Voir aussi
Observations générales sur la conception en tenant compte des performances


Observations générales sur la conception en tenant compte des performances

Bien que de nombreux facteurs affectent les performances, l'une des principales méthodes d'optimisation des performances consiste à maintenir la taille des fichiers de formulaire aussi petite que possible.
La taille de fichier des formulaires influe sur les performances à divers stades : lors de la génération des formulaires par le serveur, lors du transfert des formulaires via des canaux de communication à faible débit ou encore lors du stockage ou de la récupération de formulaires à partir d'un système de stockage de proximité.
Tenez compte des conseils généraux suivants afin de réduire au minimum la taille des fichiers de formulaires :
      •
      Evitez d'utiliser des polices devant être incorporées, notamment pour les objets de champs. Il est impossible en effet de créer des jeux partiels de polices dans le cas de polices incorporées.
      •
      Recourez aux images incorporées plutôt qu'aux images liées. Sachez que, par défaut, les images sont liées.
      •
      Utilisez des images monochromes ou de la palette pour définir les couleurs. Evitez d'utiliser des formats de couleur 24 bits.
      •
      Sachez que la génération de formulaires accessibles limite les performances.
      •
      Utilisez le moins d'objets possible dans les formulaires et simplifiez ces objets au maximum.
Tenez compte de ces conseils généraux en vue d'améliorer les performances des formulaires interactifs :
      •
      Dans le cas de formulaires envoyant des données à LiveCycle Forms, choisissez le format de données XML. Les autres formats (PDF, par exemple) nécessitent davantage de bande passante et de temps de traitement. Voir A propos de l'envoi de données au moyen d'un bouton.
      •
      Activez la mise en mémoire cache des formulaires afin d'accroître les performances de génération de formulaires. Lorsqu'un formulaire est mis en cache, les données sont placées dans une présentation générée au préalable. Pour que LiveCycle Forms puisse mettre en cache des formulaires avec une disposition fixe, sélectionnez l'option de mise en cache de formulaires de LiveCycle Designer pour chacun des formulaires que vous créez. Voir Mise en cache des formulaires.
Tenez compte de ces conseils généraux en vue d'améliorer les performances des formulaires non interactifs :
      •
      Evitez les schémas de validation et autres fonctions de formulaire interactives telles que les validations de saisie de données et la modification de masques.
Ces fonctions impliquent la génération de formulaires interactifs par LiveCycle Forms. En règle générale, les formulaires non interactifs ont une taille de fichier inférieure à celle des formulaires interactifs et sont générés plus rapidement.
Si le formulaire est destiné à être imprimé, les fonctions interactives n'offrent aucun avantage supplémentaire. Par exemple, LiveCycle Designer permet de générer des scripts de validation pour des objets particuliers de formulaire liés à des schémas XML. Dans le cas de formulaires interactifs, ces scripts de validation garantissent que les données saisies par l'utilisateur sont conformes au schéma spécifié. Ainsi, un script de validation peut s'assurer qu'une valeur fournie pour un objet numérique correspond à un entier compris entre 4 et 9. Les formulaires non interactifs n'acceptent pas de valeurs saisies par l'utilisateur et, de ce fait, ne contiennent pas de scripts de validation. La désactivation de la génération de ces scripts permet d'améliorer les performances en éliminant le traitement nécessaire à leur exécution. Voir Pour définir les options de génération de champs.
      •
      Traitez les formulaires par lots.
Lors de la génération de plusieurs instances d'un même formulaire, dans le cas de factures destinées à différents clients, regroupez les données de toutes les instances dans un seul fichier de données et générez des formulaires individuels à partir de ce fichier. Cette approche se révèle plus efficace que le traitement individuel de formulaires. Toutefois, lors du traitement par lots de différents formulaires, regroupez ces derniers avant de les générer. Si, par exemple, vous exécutez des factures et des listings simultanément, regroupez et exécutez toutes les factures, puis tous les listings.
Voir aussi
A propos des performances
Optimisation des performances des images
Aperçu des images
Performances et formulaires accessibles
Conseils relatifs à la réduction du nombre d'objets
Conseils relatifs à la simplification des objets


Utilisation d'objets

Optimisation des performances des images
Optimisation des performances pour des choix d'option discrets
Optimisation des performances des sous-formulaires
Optimisation des performances des champs de texte
Performances des objets sur les gabarits par rapport à ceux situés sur les pages
Conseils relatifs à la réduction du nombre d'objets
Conseils relatifs à la simplification des objets


Optimisation des performances des images

Les images nécessitent un temps de traitement supplémentaire lors de la génération d'un formulaire. Si vous choisissez d'utiliser des images, adoptez des formats de fichier compacts et des dimensions d'image aussi réduites que possible afin de minimiser la taille des fichiers. Dimensionnez les images selon la taille voulue avant leur insertion dans le formulaire. Evitez de redimensionner les images après leur insertion dans le formulaire.
Assurez-vous que les coins sont carrés et que les lignes sont parfaitement horizontales et verticales en vue d'optimiser les performances lors de la génération du formulaire. Les lignes qui semblent être verticales ou horizontales peuvent se révéler légèrement inclinées.
Vous pouvez vérifier l'inclinaison de telles lignes via la palette Disposition. L'option Hauteur représente l'inclinaison d'une ligne horizontale et l'option Largeur, celle d'une ligne verticale. Dans l'exemple suivant, une ligne verticale présente une légère inclinaison d'environ un demi millimètre. Une largeur de 0 mm rendra la ligne parfaitement verticale.
Voir aussi
Observations générales sur la conception en tenant compte des performances
Optimisation des performances pour des choix d'option discrets


Optimisation des performances pour des choix d'option discrets

Plusieurs objets offrent des choix d'option discrets : les cases à cocher, les zones de liste et les boutons radio. Les zones de liste et les cases à cocher sont générées plus rapidement que les boutons radio.
Voir aussi
Optimisation des performances des images
Optimisation des performances des sous-formulaires


Optimisation des performances des sous-formulaires

LiveCycle Designer distingue les objets standard ou statiques (tels que le texte, les lignes et les images) des objets dotés d'un contenu variable, comme les champs de texte et d'image.
Par exemple, les formulaires interactifs peuvent comprendre des libellés de texte statiques fournissant des informations à l'utilisateur et des objets de champ de texte capturant les informations provenant de l'utilisateur.
Un sous-formulaire désigne un type d'objet avec contenu. Les sous-formulaires sont souvent regroupés en fonction de la structure des données liées aux différents sous-formulaires. La possibilité de lier des groupes de données répétitifs, facultatifs et conditionnels à des sous-formulaires permet de réduire les risques d'erreurs de conception susceptibles de survenir si vous utilisez des scripts pour parvenir aux mêmes résultats.
Par exemple, vous pouvez créer un sous-formulaire comprenant des objets permettant de répéter des groupes de données. Lors de la génération du formulaire, LiveCycle Forms crée autant d'instances du sous-formulaire que nécessaire en vue de représenter tous les groupes de données.
Lors de l'utilisation de sous-formulaires, gardez à l'esprit les considérations suivantes relatives à l'optimisation des performances :
      •
      Les sous-formulaires répétitifs et imbriqués nécessitent un temps de traitement supplémentaire pour générer le formulaire. Evitez de vous en servir à moins qu'ils n'offrent des performances supérieures aux autres méthodes. Ainsi, un sous-formulaire répétitif peut vous éviter d'intégrer un nombre d'objets répétés.
      •
      L'autorisation des sauts de page dans les sous-formulaires rallonge le traitement du formulaire, même si LiveCycle Forms n'applique pas ces sauts de page. Par exemple, l'emplacement, la taille ou le contenu d'un sous-formulaire peuvent empêcher un saut de page. Afin d'optimiser les performances, désactivez les sauts de page dans les sous-formulaires. Sachez qu'ils sont autorisés par défaut.
En outre, les sous-formulaires s'avèrent pratiques pour regrouper et organiser les objets sans lier le sous-formulaire à un élément de données. Afin d'empêcher LiveCycle Forms de rechercher un élément de données pour le sous-formulaire lors de la fusion des données, modifiez le type de liaison des données du sous-formulaire. Remplacez la valeur par défaut Normale par la valeur Aucune.
Voir aussi
Propriétés de l'objet Sous-formulaire dans l’onglet Sous-formulaire
Optimisation des performances pour des choix d'option discrets
Optimisation des performances des champs de texte


Optimisation des performances des champs de texte

Par défaut, les données saisies dans les objets Champs de texte sont mises en forme au format texte simple. Vous pouvez modifier cette option afin d'utiliser le format Texte enrichi.
Toutefois, dans le cas des champs de texte simple, la police, le style et le corps de police utilisés lors de la conception sont appliqués aux données saisies par l'utilisateur. Vous pouvez rendre la génération du formulaire plus efficace en utilisant les propriétés de texte employées dans la conception de formulaire.
Pour les saisies en texte enrichi, les utilisateurs peuvent personnaliser le style et la taille des polices du texte tapé dans l'objet. Bien que les saisies en texte enrichi sont utiles dans certaines situations, notamment à des fins narratives, les attributs supplémentaires ont une incidence négative sur les performances.
Voir aussi
Propriétés des champs de texte dans le panneau Champ
Optimisation des performances des sous-formulaires
Performances des objets sur les gabarits par rapport à ceux situés sur les pages


Précédent Suivant

Utilisation de LiveCycle Designer > Création de formulaires en vue d'optimiser les performances > Utilisation d'objets > Performances des objets sur les gabarits par rapport à ceux situés sur les pages

Performances des objets sur les gabarits par rapport à ceux situés sur les pages

Les objets situés sur des gabarits nécessitent un traitement supplémentaire lorsque LiveCycle Forms génère le formulaire. Dans la mesure du possible, placez les objets sur les pages.
Voir aussi
Optimisation des performances des champs de texte
Conseils relatifs à la réduction du nombre d'objets


Conseils relatifs à la réduction du nombre d'objets

La taille de fichier d'un formulaire est affectée par le nombre d'objets situés sur le formulaire. Tenez compte de ces conseils généraux en vue de réduire le nombre d'objets des formulaires :
      •
      Lors de la création d'une zone, utilisez un seul objet rectangle au lieu de joindre quatre lignes distinctes.
      •
      Lors de la création d'une bordure de champ ou d'objet de sous-formulaire, appliquez les attributs de bordure de l'objet plutôt que de créer une zone distincte.
      •
      Lors de la création d'arrière-plans d'objets, utilisez un arrière-plan au lieu de définir un nouvel objet de zone ombrée.
      •
      Pour les légendes, faites appel à la propriété de légende d'un objet au lieu d'utiliser un objet de texte statique distinct.
      •
      Combinez plusieurs objets de texte statiques en un seul objet de texte. Cette stratégie s'avère particulièrement utile après l'importation de formulaires dans LiveCycle Designer.
Voir aussi
Performances et importation de formulaires
Performances des objets sur les gabarits par rapport à ceux situés sur les pages
Conseils relatifs à la simplification des objets
A propos des légendes
Pour fusionner les objets de texte
Propriétés de la palette Bordure


Conseils relatifs à la simplification des objets

La taille de fichier d'un formulaire est affectée par la complexité des objets situés sur le formulaire. Le traitement des objets simples est plus efficace que celui des objets complexes. Tenez compte de ces conseils généraux en vue de réduire la complexité des objets :
      •
      Utilisez un nombre minimum de polices, styles et tailles afin d'exploiter au mieux les informations sur les polices mises en cache.
      •
      Dans la mesure du possible, choisissez des objets fixes plutôt que des objets dynamiques qui voient leur taille diminuer et augmenter.
      •
      Evitez d'empiler des objets les uns sur les autres, surtout au-delà de trois niveaux.
Voir aussi
Optimisation des performances des champs de texte
Choix des polices en fonction des performances
Conseils relatifs à la réduction du nombre d'objets
Options de liaison des données par rapport aux performances


Structuration des données en vue d'optimiser les performances

Options de liaison des données par rapport aux performances
Evaluation de la structure des données par rapport aux performances


Précédent Suivant

Utilisation de LiveCycle Designer > Création de formulaires en vue d'optimiser les performances > Structuration des données en vue d'optimiser les performances > Options de liaison des données par rapport aux performances

Options de liaison des données par rapport aux performances

Dans le cas de formulaires liés à des sources de données, vous pouvez associer un élément de données à un objet de formulaire, tel qu'un champ ou un sous-formulaire. Cette association s'appelle la liaison de données. Vous pouvez choisir des objets dont la taille augmente ou diminue selon la quantité de données à afficher.
De nombreuses définitions de liaison de données peuvent aboutir à des résultats identiques lors de la génération du formulaire. Toutefois, plus le rapport établi entre l'objet de formulaire et son élément de données est clair, plus le traitement de la liaison de données par LiveCycle Forms est efficace.
Le diagramme qui suit illustre un exemple de liaison de données pour lequel deux objets de champ du formulaire sont liés à des éléments de données. La liaison est ambiguë, car plusieurs instances des objets de champ et de leurs données existent. Un traitement plus poussé est nécessaire pour faire correspondre la nième occurrence de chaque objet avec la nième occurrence des données correspondantes lors de la génération du formulaire.
Le diagramme qui suit illustre l'utilisation de la liaison de sous-formulaires en vue de grouper des objets et ainsi de simplifier le traitement pour la génération du formulaire. Le sous-formulaire est lié au groupe qui se répète dans les données, ce qui élimine la liaison ambiguë. La liaison est renvoyée pour le premier groupe et n'a pas besoin d'être renvoyée à nouveau pour les répétitions ultérieures.
vous pouvez utiliser des sous-formulaires afin de regrouper et d'organiser des objets sans lier le sous-formulaire à un élément de données. Afin d'empêcher LiveCycle Forms de rechercher un élément de données pour le sous-formulaire lors de la fusion des données, modifiez le type de liaison des données du sous-formulaire. Remplacez la valeur par défaut Normale par la valeur Aucune.
Voir aussi
A propos des sources de données
Propriétés des sous-formulaires dans le panneau Liaison
Conseils relatifs à la simplification des objets
Evaluation de la structure des données par rapport aux performances


Précédent Suivant

Utilisation de LiveCycle Designer > Création de formulaires en vue d'optimiser les performances > Structuration des données en vue d'optimiser les performances > Evaluation de la structure des données par rapport aux performances

Evaluation de la structure des données par rapport aux performances

L'affichage sélectif de champs constitue l'un des moyens de démontrer l'incidence de la structure des données sur les performances.
Supposons que nous souhaitions afficher un message uniquement dans les cas où la valeur de l'élément de données amountOwned est supérieure à zéro. Une approche consiste à utiliser un script permettant d'examiner la valeur de amountOwed et de modifier la propriété d'affichage/de masquage du champ du message selon la valeur de l'élément de données.
Une autre solution consiste à lier les données à un sous-formulaire. Cette méthode s'avère plus efficace que la précédente, bien que les deux aboutissent au même résultat. Avec cette méthode, nous ajoutons l'élément d'état à la structure des données et le lions à un sous-formulaire. Ce dernier comprend le champ de message et le champ amountOwed . Avec le nombre minimal d'occurrences du sous-formulaire défini sur zéro, le message s'affiche uniquement lorsque l'élément d'état existe.
Dans le contexte des données, la décision d'ajouter le noeud d'état au fichier de données doit s'effectuer au moment de la génération, uniquement lorsque la valeur est supérieure à 0. Cette technique modifie la logique afin de déterminer si un sous-formulaire est nécessaire dans la conception du contexte des données.
Voir aussi
Options de liaison des données par rapport aux performances
Choix des polices en fonction des performances


Choix des polices en fonction des performances

Les fichiers de formulaire de petite taille sont générés plus rapidement que les fichiers volumineux. Pour réduire au minimum la taille d'un fichier, utilisez un nombre restreint de polices et évitez de choisir des polices devant être incorporées dans le document.
Les polices suivantes sont toujours disponibles dans Adobe Reader et ne sont jamais incorporées :
      •
      Adobe Pi Std, Adobe Sans MM, Adobe Serif MM
      •
      Courier Std, Courier Std Bold, Courier Std Bold Oblique, Courier Std Oblique
      •
      Minion Pro Bold, Minion Pro Bold It, Minion Pro It, Minion Pro Regular
      •
      Myriad Pro Bold, Myriad Pro Bold It, Myriad Pro It, Myriad Pro Regular
      •
      Symbol (Type 1)
Palette Police
Evaluation de la structure des données par rapport aux performances
Performances et importation de formulaires


Performances et importation de formulaires

Vous pouvez importer des formulaires existants dans LiveCycle Designer. Lors de l'importation, il se peut que des objets superflus soient créés.
Par exemple, lors de l'importation d'un formulaire PDF, il se peut qu'un objet de texte statique soit créé pour chaque ligne ou mot contenus dans le formulaire d'origine. Le nombre et la complexité des objets augmentent la taille de fichier du formulaire et réduisent les performances de rendu du formulaire.
LiveCycle Designer propose des options visant à diminuer le nombre d'objets superflus créés lors de la génération du rendu. Lors de l'importation du formulaire, vous pouvez choisir l'option Conserver l'autorisation de modification ou l'option Conserver l'aspect.
Ces deux options aboutissent à des résultats différents sur le plan du nombre et de la complexité des objets contenus dans le formulaire obtenu. Il peut s'avérer pratique d'importer le formulaire une fois à l'aide de l'option Conserver l'autorisation de modification et une autre fois à l'aide de l'option Conserver l'aspect. Vous pouvez générer le formulaire final en combinant les éléments les plus adaptés provenant de chacun des formulaires.
Une fois le formulaire importé, vous avez la possibilité de réduire le nombre d'objets du document en combinant les objets de texte apparentés. Par exemple, vous pouvez sélectionner individuellement les différents objets de texte constituant des phrases puis les combiner en un seul objet de texte.
Voir aussi
Pour importer des fichiers PDF
Pour fusionner les objets de texte
Conseils relatifs à la réduction du nombre d'objets
Conseils relatifs à la simplification des objets
Choix des polices en fonction des performances
Performances et formulaires accessibles


Performances et formulaires accessibles

Lors de la conception de formulaires accessibles, vous pouvez définir le texte lu par les lecteurs d'écran. Créez un formulaire PDF balisé afin que le lecteur d'écran puisse lire le texte. Pour ce faire, vous générez des balises d'accessibilité lorsque vous enregistrez la conception du formulaire comme fichier PDF.
Dans LiveCycle Designer, l'action par défaut consiste à créer des formulaires PDF balisés.
Le balisage appliqué à des fins d'accessibilité augmente la taille du fichier, ce qui amoindrit les performances. Afin d'atténuer l'impact sur les performances pour les formulaires accessibles, choisissez soigneusement les éléments de conception.
Par exemple, dans le cas des choix d'options discrets, utilisez de préférence des zones de liste ou des cases à cocher. En effet, ces objets sont générés plus rapidement que les boutons radio.
Voir aussi
Pour créer un formulaire PDF assorti de balises d'accessibilité
Performances et importation de formulaires
Performances et scripts


Performances et scripts

En général, les scripts augmentent le traitement nécessaire à la génération des formulaires. Avant d'en utiliser, voyez s'il n'existe pas d'alternative plus intéressante au niveau des performances. Par exemple, les masques de caractère offrent de meilleures performances que les scripts en aboutissant aux mêmes résultats.
Les langages JavaScript et FormCalc sont tous deux disponibles pour effectuer les calculs et les validations dans les formulaires. Dans la mesure du possible, évitez d'utiliser des scripts de validation. Ils diminuent les performances en raison du temps que leur traitement nécessite.
Si vous choisissez d'utiliser des scripts, FormCalc offre généralement de meilleures performances que le langage JavaScript pour les raisons suivantes :
      •
      FormCalc exécute plus rapidement des calculs et des validations simples.
      •
      FormCalc interprète directement la syntaxe de modèle d'objet de formulaire XML. Autrement dit, il peut renvoyer les expressions de syntaxe de référence plus efficacement.
Vous sélectionnez le langage de script à l'aide de l'éditeur de script.
Voir aussi
A propos des calculs et des scripts
A propos de l'utilisation de FormCalc
A propos de l’utilisation de JavaScript
A propos des références aux objets dans les calculs et les scripts
Performances et formulaires accessibles
Performances et expressions de modèles d'objet de formulaire XML


Performances et expressions de modèles d'objet de formulaire XML

Le modèle d'objet de formulaire Adobe XML adopte une approche de création de formulaires qui différencie la mise en forme, la conception et les données du formulaire.
Dans une conception de formulaire, les expressions de syntaxe de référence associent les objets à des valeurs, des objets et des propriétés au sein de la hiérarchie arborescente d'un modèle d'objet de document (DOM, Document Object Model). Les expressions de syntaxe de référence sont généralement rédigées sous forme de logique de formulaire, de validations, de calculs ou d'autres règles d'entreprise.
Tenez compte des conseils suivants en vue de réduire la durée de traitement nécessaire à la résolution des expressions de syntaxe de référence :
      •
      Veillez à ce que les expressions restent le plus simple possible.
      •
      Evitez d'utiliser « .. » (deux points) dans les expressions.
De plus, après avoir évalué une expression de syntaxe de référence dans un script, stockez le résultat dans une variable d'objet. Vous pourrez récupérer ce résultat si l'expression de syntaxe de référence est à nouveau utilisée. Il est plus efficace de réutiliser un résultat que de réévaluer l'expression.
Dans l'exemple suivant, la méthode resolveNode est utilisée une seule fois et la référence d'objet obtenue est enregistrée et réutilisée en vue de manipuler divers objets apparentés. Le traitement de ce script sera plus efficace que celui d'un script faisant appel à une expression de syntaxe de référence pour chaque objet et appliquant la méthode resolveNode à chacun d'entre eux.
var oSubform = xfa.resolveNode("xfa.form.form1.Subform1");

if (oSubform.all.length< 3) {

   Subform.SubformUpButton1.presence = « invisible »;
   Subform.SubformLabel1.presence = « invisible »;

   Subform.SubformUpButton2.presence = « invisible »;
   Subform.SubformLabel2.presence = « invisible »;

}
Voir aussi
A propos des calculs et des scripts
A propos de l’utilisation de JavaScript
A propos des références aux objets dans les calculs et les scripts
Performances et scripts
Résolution des messages d'erreur et d'avertissement en vue d'optimiser les performances


Résolution des messages d'erreur et d'avertissement en vue d'optimiser les performances

La génération de messages d'avertissement ou d'erreur réduit les performances. Efforcez-vous de résoudre autant de messages de ce type que possible.
Par exemple, vous pourrez résoudre des messages relatifs à des substitutions de polices en vous assurant que les polices nécessaires sont disponibles. Certains messages sont générés même lorsque les formulaires fonctionnent parfaitement. Il se peut que vous ne parveniez pas à les résoudre.
Les messages générés par LiveCycle Designer figurent sous l'onglet Avertissements de la palette Rapport.
Vous pouvez examiner les messages dans la palette Rapport de LiveCycle Designer. Ces messages sont consignés également dans les fichiers journaux de LiveCycle Forms.
Il est vivement conseillé de toujours vérifier les deux types de messages générés. Même si LiveCycle Designer ne génère pas de messages, l'environnement LiveCycle Forms peut se révéler considérablement différent de votre propre environnement de bureau.
La liste suivante présente des exemples de messages communs générés lorsque LiveCycle Forms génère le formulaire :
      •
      « La police ZaDb est introuvable. Elle a été simplifiée et remplacée par Myriad Pro. »
Le formulaire utilise une police non disponible pour LiveCycle Forms et une police disponible lui a été substituée. Si le formulaire s'affiche correctement à l'aide de la police de substitution, vous pouvez éliminer cette erreur en modifiant les objets du formulaire de sorte qu'ils utilisent la police de substitution. Une autre manière de résoudre cette erreur consiste à installer la police manquante pour LiveCycle Forms.
      •
      « Le script a échoué (le langage est JavaScript ; le contexte est ...) »
Impossible d'exécuter le script en raison d'erreurs de langage. Si le script n'entraîne pas de résultats dans le formulaire, cette erreur risque de passer inaperçue lors du test du formulaire. Cependant, la génération de l'erreur affectera les performances.
L'exemple suivant illustre une erreur de script :
script = function testFractionDigits(maxDigits)
{
   index = this.rawValue.lastIndexOf(".");
   if (index >= 0)
   return (((this.rawValue.length1)index) <= maxDigits);
   return true;
}
Dans cet exemple, index désigne une variable non définie. Pour résoudre cette erreur, ajoutez var devant la première instance de index.
      •
      « Les polices utilisées dans les champs ne peuvent pas être des jeux partiels. La police ArialMT n'est pas un jeu partiel. Elle sera incorporée. »
Il est impossible de créer des jeux partiels de polices. Pour résoudre cette erreur, utilisez une police standard afin d'éliminer la création de jeux partiels de polices. Cette modification permet par ailleurs de réduire la taille du fichier résultant.
      •
      « L'attribut 'access' Champ_image devrait être explicitement défini à 'nonInteractive'. Le champ sera dessiné comme un objet standard. »
Un objet de champ d'image est généré comme objet non interactif dans les formulaires Acrobat Professional 6.0 et Acrobat Standard 6.0 et Adobe Reader 6.0. Pour résoudre ce message, convertissez l'objet en objet d'image statique.
      •
      « Attribut de disposition non valide dans le sous-formulaire AccountDetails. Utilisation de la valeur par défaut. »
Un sous-formulaire dispose d'un type de disposition des rangées devant être incorporé dans un parent tableau. Or, il n'est pas inséré dans un tableau. Pour résoudre cette erreur, déplacez ce sous-formulaire dans un tableau ou changez le type du sous-formulaire et choisissez Contenu positionné ou Contenu avec enchaînement.
Voir aussi
Performances et expressions de modèles d'objet de formulaire XML


Création de formulaires destinés à LiveCycle Forms

A propos de LiveCycle Forms
Conception de formulaires pour LiveCycle Forms
Déploiement de formulaires vers LiveCycle Forms
Optimisation des conceptions de formulaire HTML
Traitement des formulaires intelligents


A propos de LiveCycle Forms

A quoi sert LiveCycle Forms ?
Rôle de LiveCycle Forms
Mode de traitement des données saisies par LiveCycle Forms
Mode de génération des formulaires par LiveCycle Forms
Mode de préremplissage automatique des formulaires par LiveCycle Forms


A quoi sert LiveCycle Forms ?

LiveCycle Forms est une solution intelligente de saisie et de fusion de données qui permet aux entreprises et autres organismes de publier des formulaires sur le Web. Grâce à LiveCycle Forms, vous pouvez automatiser la saisie de données, pré-remplir des formulaires et distribuer ces derniers au sein comme à l'extérieur de votre organisme.
LiveCycle Forms offre ces services de base :
      •
      Fournit des formulaires HTML aux navigateurs Web sur les bureaux des utilisateurs, sans nécessiter de téléchargements ou de modules externes.
      •
      Propose des formulaires PDF à remplir en ligne comme hors connexion, à imprimer et à enregistrer sur l'ordinateur local.
      •
      Procède à l'exécution des opérations intelligentes des formulaires côté serveur et traite les scripts configurés pour s'exécuter sur l'ordinateur de l'utilisateur lorsque l'application client ne parvient pas à lancer le script.
      •
      Applique, le cas échéant, les règles de l’entreprise aux champs de données.
Voir aussi
Rôle de LiveCycle Forms


Rôle de LiveCycle Forms

Lorsque LiveCycle Forms fait partie de l'environnement d'exécution, les développeurs de logiciels sont généralement chargés de créer une application personnalisée et de l'intégrer à LiveCycle Forms et à l'infrastructure de l'entreprise. LiveCycle Forms ne représente qu'une partie de l'environnement d'exécution.
L'application personnalisée comporte généralement une interface utilisateur et fournit un accès à LiveCycle Forms. L’infrastructure de l’entreprise peut comprendre un référentiel centralisé des données de l’entreprise à partir duquel LiveCycle Forms accède aux données.
Voici quelques exemples des fonctions proposées par LiveCycle Forms :
      •
      Les formulaires permettent de créer des factures à des fins de distribution multiples. Les utilisateurs accèdent aux formulaires et mettent à jour les informations via LiveCycle Forms.
      •
      Il est possible de fusionner les formulaires avec des données provenant d’une base de données en vue de créer des factures de téléphone spécifiques aux clients. LiveCycle Forms demande les données à la base de données afin de fusionner les informations de manière dynamique.
      •
      Les utilisateurs peuvent afficher et éventuellement remplir en ligne un formulaire prérempli avant de le soumettre à un fournisseur à des fins de saisie ultérieure. Une fois le formulaire actualisé enregistré et les données saisies, LiveCycle Forms lie les données en veillant à ce qu'elles soient compatibles avec le schéma XML propriétaire propre au fournisseur.
LiveCycle Forms prend en charge les options évoluées de saisie, de soumission et de liaison des données. Il se charge également de la fusion des données destinées aux formulaires. Lorsque les données sont saisies, LiveCycle Forms accepte les données et les valide. Lorsqu’un formulaire est demandé,LiveCycle Forms fusionne la conception de formulaire avec les données et rend le formulaire fusionné accessible au format PDFou HTML. Dans le cas de formulaires contenant des sous-formulaires permettant d'enchaîner le contenu, LiveCycle Forms gère la mise en forme des objets qui acceptent des quantités de données variables d’une génération à l’autre.
LiveCycle Forms est compatible avec LiveCycle Reader Extensions. Une fois qu’un fichier XDP LiveCycle Designer est stocké par LiveCycle Forms, vous pouvez appliquer des droits d’utilisation aux formulaires PDF générés de manière dynamique au lieu de recourir à l’interface utilisateur de LiveCycle Reader Extensions.
Lorsqu'un utilisateur demande un formulaire viaAdobe Reader,LiveCycle Forms vérifie les droits d'utilisation de la personne pour déterminer si elle est habilitée à télécharger le formulaire demandé. Si tel est le cas, un fichier de droits d’utilisation XML est créé et téléchargé avec le formulaire destiné à LiveCycle Reader Extensions.
LiveCycle Reader Extensions se réfère à un certificat Adobepour authentifier les informations d’identification de l’utilisateur avant d’activer dans les documents PDF des fonctions qui, dans le cas contraire, seraient inaccessibles via Adobe Reader.
Pour plus de détails sur LiveCycle Forms, consultez la documentation appropriée répertoriée dans le tableau ci-dessous.

Informations recherchées

Voir
Fonctions, environnements de travail et intégration avec d’autres produits Adobe.
Aperçu
Nouveautés pour la dernière version de LiveCycle Forms.
Quoi de neuf ?
Documentation de LiveCycle Forms.
Guide documentaire
Installation, configuration et administration de LiveCycle Forms dans un environnement de développement et d’exécution.
Installation et de configuration de LiveCycle Forms
Utilisation des exemples fournis avec l’installation de LiveCycle Forms.
Fichier LisezMoi des exemples
L’architecture de LiveCycle Forms et l’utilisation des API pour la création des applications LiveCycle Forms.
Développement d’applications personnalisées
API de LiveCycle Forms, notamment une description et une explication pour chaque API
Référence pour les API des modules de formulaires XML et Adobe LiveCycle Forms Référence pour les API.
Propriétés LiveCycle Designer prises en charge par différents navigateurs Web lors du rendu de formulaires au format HTML.
Référence sur les conversions
Voir aussi
Mode de traitement des données saisies par LiveCycle Forms
Mode de génération des formulaires par LiveCycle Forms
Mode de préremplissage automatique des formulaires par LiveCycle Forms


Mode de traitement des données saisies par LiveCycle Forms

Vous pouvez utiliser des formulaires interactifs pour recueillir des données fournies par les utilisateurs. Lorsque les utilisateurs possèdent Acrobat ou Adobe Reader, ils peuvent enregistrer les données directement dans le formulaire PDF. De même, lorsque vous insérez un bouton d'envoi dans un formulaire, vous pouvez configurer le formulaire de sorte que les données saisies par les utilisateurs soient directement téléchargées sur LiveCycle Forms.
Lorsqu'un utilisateur clique sur un bouton d'envoi au moment de l'exécution, les données sont soumises à LiveCycle Forms. Si la configuration le permet et qu'aucune erreur ne se produit au moment de la validation, LiveCycle Forms peut à nouveau fusionner les données avec le formulaire et les renvoyer à l'utilisateur. De même, vous pouvez configurer LiveCycle Forms pour qu'il transmette les données à une application personnalisée en vue d'un traitement ultérieur.
Il est important de comprendre le mode de configuration des propriétés d’un bouton d’envoi afin de répondre aux exigences de l’application personnalisée, car il est possible d’envoyer les données à LiveCycle Forms selon bien des formats.
Voir aussi
Aperçu des boutons
A propos de l'envoi de données au moyen d'un bouton
Pour valider les données utilisateur


Mode de génération des formulaires par LiveCycle Forms

LiveCycle Designer vous permet de créer des conceptions de formulaire interactives, statiques ou dynamiques que LiveCycle Forms génère au format PDF ou HTML.
Vous pouvez enregistrer les formulaires PDF directement dans LiveCycle Designer puis les distribuer aux utilisateurs par messagerie électronique ou par le biais d'un serveur réseau standard. Cependant, si vous possédez LiveCycle Forms, il est très probable que vous enregistrerez vos conceptions de formulaire au format XDP et que vous les mettrez à la disposition de LiveCycle Forms.
Lorsque vous déployez des conceptions de formulaire sur LiveCycle Forms, vous pouvez distribuer directement les formulaires générés aux utilisateurs par le biais d'une interface utilisateur Web. Lorsqu’un utilisateur demande un formulaire, LiveCycle Forms applique la conversion adaptée à la conception de formulaire afin de générer le formulaire.
Si, par exemple, l’utilisateur demande un formulaire PDF interactif, LiveCycle Forms fait appel à la conversion PDFForm pour générer le formulaire.
Voir aussi
Conversion de formulaires
Conceptions de formulaire prises en charge par LiveCycle Forms
Enregistrement d’une conception de formulaire : XDP ou PDF ?


Mode de préremplissage automatique des formulaires par LiveCycle Forms

Au moment de la génération d'un formulaire, LiveCycle Forms peut préremplir automatiquement le formulaire avec des données provenant d'une source externe.
Pour des applications peu complexes, vous pouvez créer des formulaires qui font appel à des données externes sans avoir à rédiger des scripts. Il suffit de définir des liaisons de données dans LiveCycle Designer. La fonction de liaison permet généralement d'obtenir des données à partir d'une source WSDL ou d'une base de données OLEDB.
LiveCycle Forms prend en charge les liaisons de données simples. Ce type de liaison vous permet d'associer une valeur unique à un champ.
Voir aussi
A propos de la liaison de champs à une source de données
Pour tester la fusion de données
Insertion automatique de données dans les champs de formulaire


Conception de formulaires pour LiveCycle Forms

A propos de la conception de formulaires pour LiveCycle Forms
Conceptions de formulaire prises en charge par LiveCycle Forms
Pour préparer des conceptions de formulaire adaptées à LiveCycle Forms
Définition du format d'envoi des données
Conversion de formulaires
Pour tester la fusion de données
Optimisation et amélioration des performances pour LiveCycle Forms


A propos de la conception de formulaires pour LiveCycle Forms

La procédure de création d’un formulaire destiné à LiveCycle Forms est exactement la même que celle utilisée pour concevoir tout autre type de formulaire. Il existe cependant une différence : un formulaire destiné à LiveCycle Forms peut être réutilisé en vue de générer des formulaires PDF ou HTML.
LiveCycle Forms vous permet de publier des formulaires PDF et HTML sur Internet ou sur un intranet. Lorsque LiveCycle Forms génère le formulaire HTML, il s’ouvre dans un navigateur Web. Lorsque LiveCycle Forms génère un formulaire PDF, celui-ci s’ouvre directement dans Acrobat ou Adobe Reader, selon la configuration d'Acrobat ou d'Adobe Reader sur l’ordinateur de l’utilisateur.
Lorsque vous distribuez des formulaires au sein d’un environnement Web, tenez compte des limitations de votre cadre de travail. Il se peut, par exemple, que certaines des fonctions que vous attribuez à des conceptions de formulaire à l’aide de LiveCycle Designer ne soient pas prises en charge dans un environnement Web. D’autre part, tous les navigateurs Web n’affichent pas les mêmes objets de manière identique.
Enfin, certaines fonctionnalités de formulaire ne sont pas directement prises en charge par les navigateurs Web ou la technologie HTML. L’éventail complet des fonctionnalités de formulaire est uniquement disponible lorsque le formulaire PDF est ouvert à l’aide d’Acrobat ou d'Adobe Reader.
LiveCycle Forms 7,1 ne prend pas en charge les tableaux dans les conceptions de formulaires générées au format HTML. LiveCycle Forms 7.1 ne prend pas non plus en charge les conceptions de formulaire contenant des polices relatives à l'arabe, l'hébreu, le thaï et le vietnamien.
Voir aussi
A quoi sert LiveCycle Forms ?
Conceptions de formulaire prises en charge par LiveCycle Forms
Pour préparer des conceptions de formulaire adaptées à LiveCycle Forms


Conceptions de formulaire prises en charge par LiveCycle Forms

Quatre types de formulaires de base de rendus par LiveCycle Forms :
      •
      Formulaires interactifs avec une disposition fixe
      •
      Formulaires non interactifs avec une disposition fixe
      •
      Formulaires interactifs prévus pour s'adapter aux données
      •
      Formulaires non interactifs prévus pour s'adapter aux données
Lorsque vous soumettez une conception de formulaire à LiveCycle Forms, LiveCycle Forms peut générer le formulaire sous forme de document PDF ou HTML , avec ou sans données fusionnées.
Le tableau suivant donne une brève description des types de formulaires que vous pouvez créer avec LiveCycle Designer. Pour obtenir plus d'information sur les types de formulaires, voir Méthodes de création de conceptions de formulaire.

Interactif

Non interactif
Disposition fixe
Un formulaire interactif avec une disposition fixe contient au moins des champs devant être remplis manuellement. La disposition et la pagination du formulaire ne changent pas, quel que soit le volume des données insérées dans les champs.
Un formulaire non interactif avec une disposition fixe ne contient pas de champs à compléter. Vous pouvez pré-remplir des formulaires non interactifs à l'aide de données, mais leur disposition et leur pagination ne changent pas.
Disposition souple
Un formulaire interactif sont la disposition s'adapte au volume de données peut ou ne pas être prérempli. Cependant, il doit comporter au moins des champs devant être complétés ou d'autres fonctions devant être exécutées.
Un formulaire non interactif dont la disposition s'adapte au volume de données peut ou ne pas être prérempli. Il ne contient pas de champs devant être complétés ou d'autres fonctions devant être exécutées.
tous les types de formulaires autorisent les utilisateurs à importer des données de formulaire au moment de l'exécution.
Voir aussi
A propos de la création de conceptions de formulaire prévues pour s'adapter aux données
Méthodes de création de conceptions de formulaire
A propos des formulaires HTML


Précédent Suivant

Utilisation de LiveCycle Designer > Création de formulaires destinés à LiveCycle Forms > Conception de formulaires pour LiveCycle Forms > Pour préparer des conceptions de formulaire adaptées à LiveCycle Forms

Pour préparer des conceptions de formulaire adaptées à LiveCycle Forms

Il est important de comprendre qu’il existe des différences de comportement entre les formulaires PDF et HTML générés à partir d’une même conception de formulaire.
Etant donné que les formulaires PDF s’ouvrent dans Acrobat ou Adobe Reader, ils prennent en charge toutes les propriétés d’objet que vous définissez dans la conception. Malheureusement, si vous distribuez des formulaires HTML reposant sur la même conception, certaines applications client (les navigateurs Web, par exemple) ne reconnaîtront pas l’ensemble des propriétés des objets.
Sachez également que les formulaires HTML ne reconnaissent pas les propriétés relatives aux formats de page (nécessaires à la pagination des formulaires PDF). Un formulaire avec une disposition souple peut s'étendre sur une page HTML démesurément longue. Vous devez donc éviter de configurer un pied de page sur le gabarit. Si vous insérez un pied de page en dessous de la zone de contenu d’un gabarit, vous risquez d’écraser le contenu HTML qui suit et qui correspond sinon (dans un formulaire PDF) à la limite de la page.
LiveCycle Forms 7,1 ne prend pas en charge les tableaux dans les conceptions de formulaires générées au format HTML. LiveCycle Forms 7.1 ne prend pas non plus en charge les conceptions de formulaire contenant des polices relatives à l'arabe, l'hébreu, le thaï et le vietnamien.
Pour créer une conception de formulaire unique qui tient compte de ces restrictions, procédez comme suit :
1.
Consultez le manuel de référence sur les conversions pour déterminer le comportement des objets dans une application client particulière.
2.
Si vous concevez un formulaire avec une disposition fixe et que vous souhaitez générer le formulaire au format HTML, vous devrez activer la fonction de mise en cache des conversions.
3.
Lorsque vous concevez le formulaire, essayez de contourner les limites des applications client en cherchant des solutions qui ne reposent pas sur les propriétés d’objets non prises en charge.
4.
Assurez-vous que la disposition convient autant aux formulaires PDF qu’aux formulaires HTML.
5.
Lisez la section sur la création de formulaires accessibles et suivez les conseils visant à optimiser l’accessibilité de votre conception de formulaire.
6.
Demandez au développeur de formulaires de votre organisation où les scripts doivent être exécutés normalement. Par défaut, les scripts s'exécutent sur le client. Si les scripts que vous incorporez à un formulaire doivent être exécutés sur le serveur ou sur le client et le serveur, il se peut que vous ayez à modifier ou à remplacer la configuration définie par défaut.
7.
Affichez régulièrement un aperçu de votre formulaire dans LiveCycle Designer (s’il s’agit d’un formulaire PDF) ou dans l’application client cible (dans le cas d’un formulaire HTML) afin de corriger les problèmes dès les premières étapes de la conception.
8.
Si LiveCycle Forms fusionne des formulaires contenant des données, utilisez des données test pour tester vos conceptions de formulaire de manière approfondie avant de mettre les versions finales à la disposition de LiveCycle Forms.
Voir aussi
Conversion de formulaires
Mise en cache des formulaires
Procédure générale de conception d'un formulaire
A propos des formulaires accessibles
Traitement client et serveur
Pour prévisualiser et tester les formulaires dans le panneau Aperçu PDF
Aperçu d’un formulaire HTML
Définition du format d'envoi des données
Pour tester la fusion de données
Enregistrement d’une conception de formulaire : XDP ou PDF ?
Copie de conceptions de formulaires sur le réseau


Définition du format d'envoi des données

Lorsque vous créez un formulaire, vous pouvez déterminer le format à utiliser pour envoyer les données. Vous pouvez définir le format d'envoi des données dans LiveCycle Designer. Il existe deux méthodes :
      •
      En plaçant l'objet de bouton dans le formulaire, en le définissant comme un bouton d'envoi et en choisissant le format d'envoi des données.
      •
      En plaçant un bouton Envoyer via HTTP ou Envoyer par messagerie dans le formulaire.
Après avoir ajouté un objet de bouton dans la conception du formulaire, vous pouvez définir un format d'envoi des données dans le panneau Envoyer de la palette Objet. Les boutons Envoyer par HTTP et Envoyer par messagerie sont préconfigurés pour utiliser des formats d'envoi spécifiques. Pour plus d'informations sur les formats d'envoi de données, voir A propos de l'envoi de données au moyen d'un bouton.
Fonctions prises en charge
LiveCycle Designer prend en charge quatre formats d'envoi :
    • Paquet de données XML (XDP)
Données XML et fichiers PDF extraits et enregistrés sous forme de contenu séparé. Lorsque les utilisateurs demandent le formulaire, ils reçoivent le fichier PDF.
    • PDF
Données XML extraites du fichier PDF et enregistrées séparément.
    • Données XML (XML)
Données enregistrées dans un fichier XML séparé. Les données sont fusionnées avec le formulaire à la demande.
    • Données codées dans URL (HTTP Post)
Les données sont gérées de la même manière que les données XML. Ce format est le seul format d'envoi de données pour les formulaires HTML.
Le tableau ci-dessous récapitule les fonctions prises en charge par les formats d'envoi de données du panneau Envoyer de la palette Objet.

Caractéristique
fonctionnalité

Paquet de données XML (XDP)

PDF

Données XML

Données codées dans URL
(HTTP Post)
Annotations
Prises en charge
Pour inclure des annotations dans le paquet de données XML, vous devez cocher la case PDF du panneau Envoyer de l'objet de bouton Envoyer.
Non prises en charge
Non prises en charge
Non prises en charge
Signatures numériques
Prises en charge
Pour inclure des signatures numériques dans le paquet de données XML, vous devez cocher la case PDF du panneau Envoyer de l'objet de bouton Envoyer.
Non prises en charge
Non prises en charge
Non prises en charge
PDF
Prises en charge
Non prises en charge
Non prises en charge
Non prises en charge
Modèle
Prises en charge
Non prises en charge
Non prises en charge
Non prises en charge
Voir aussi
A propos de l'envoi de données au moyen d'un bouton
Propriétés des boutons dans le panneau Envoyer
Pour tester la fusion de données
A propos de l'optimisation et de l'amélioration des performances


Conversion de formulaires

LiveCycle Forms effectue des conversions pour générer des formulaires dans différents formats adaptés aux applications client telles qu'Acrobat, Adobe Reader, les navigateurs Web et les logiciels de lecture d'écran.
LiveCycle Forms prend en charge tous les clients HTML conformes aux spécifications techniques CSS2. Compte tenu que la prise en charge des spécifications CSS2 varie énormément d’un navigateur à l’autre (cette norme n’est d’ailleurs pas reconnue par les navigateurs plus anciens), de nombreux navigateurs et agents utilisateur génériques nécessitent des conversions particulières. Les conversions effectuées par LiveCycle Forms pour les applications client sont décrites dans le tableau.

Conversion

Application client cible
HTML4
Netscape Navigator 4.7.x.
PDF
Crée des formulaires PDF non interactifs avec une disposition fixe qui peuvent être imprimés et enregistrés à l’aide d'Acrobat or d'Adobe Reader.
PDFForm
Crée des formulaires PDF interactifs et accessibles destinés à Acrobat ou Adobe Reader.
PDFMerge
Fusionne (préremplit) des données dans une conception de formulaire enregistrée à partir de LiveCycle Designer dans un formulaire au format PDF. Si aucun calcul côté serveur n'est requis, il s'agit-là de la conversion la plus rapide.
AHTML
Lecteurs d’écran et Microsoft Internet Explorer 5.x (ou version ultérieure).
MSDHTML
Microsoft Internet Explorer 5.x (ou version ultérieure). Utilise VML pour les images vectorielles.
CSS2HTML
Netscape Navigator 6.2 (ou version ultérieure), Opera 7 et Internet Explorer 5.x (ou version ultérieure). A l’exception des rectangles et des lignes, les images vectorielles ne sont pas prises en charge.
Les formulaires HTML acceptent tous les types d’objet à l’exception des champs de signature de document. Toutefois, certaines propriétés d’objet ne sont pas prises en charge par les applications client offrant des possibilités limitées.
Pour obtenir une liste exhaustive des objets et des propriétés gérés par chaque type de conversion, voir la page de référence sur les conversions disponible sur le site Web de support de LiveCycle Designer.
si vous effectuez une conversion HTML4 pour assurer la prise en charge sur Netscape 4.7.x, sachez que les scripts JavaScript conçus pour être exécutés sur le client seront exécutés automatiquement sur le serveur.
Voir aussi
Pour préparer des conceptions de formulaire adaptées à LiveCycle Forms


Pour tester la fusion de données

Lorsque vous configurez des formulaires pour prendre en charge des données fusionnées, analysez les exigences relatives à la fusion des données du formulaire par rapport aux données d'entrée. Vous devez concevoir le formulaire d'après la structure des données d'entrée.
Il est recommandé de revoir les données d'entrée et de préparer un fichier d'exemple de données ou de demander à LiveCycle Designer de générer automatiquement ce fichier à des fins de test. Le fichier peut être remis à l'auteur du formulaire.
Vous pouvez utiliser des données d'exemple pour vérifier le comportement d'un formulaire, mais il demeure important de faire des tests approfondis. Pour optimiser les résultats, testez la conception de formulaire avec les données générées par le système. Vous pouvez générer les données d'exemple comme suggéré dans la liste suivante afin de déterminer si la disposition, le formatage, le contenu et le comportement d'un formulaire répondent aux exigences :
      •
      Pour vérifier si le formatage des données (par exemple, le type de police, la taille de la police et l'alignement des paragraphes) est correct, générez des données pour chaque champ du formulaire. Les données vous permettront également de vérifier toutes les valeurs des champs calculés.
      •
      Pour vérifier si la taille des objets de champ est suffisante pour accueillir toutes les valeurs des données, générez des données permettant d'atteindre le nombre maximum de caractères autorisé par champ.
      •
      Pour vérifier le fonctionnement des options de lignes multiples et de zones agrandissables automatiquement, générez plusieurs lignes de données.
      •
      Si votre conception de formulaire comporte des sous-formulaires qui se répètent, générez des groupes de données répétitifs pour tester l'affichage de ces sous-formulaires dans le fichier de données d'exemple que vous créez. Si vous utilisez un fichier de données d'exemple généré automatiquement, vous pouvez spécifier le nombre de fois où le groupe de données se répète.
      •
      Si votre conception de formulaire comporte des débuts/fins de débordement, générez les données requises pour tester chaque début ou fin de débordement et les paramètres d'occurrence associés. Vous devez générer suffisamment de groupes de données qui se répètent afin qu'ils débordent sur trois pages, ce qui vous permettra également de vérifier la numérotation des pages. Utilisez les données d'exemple (ajoutez les groupes de données qui se répètent un par un) pour vérifier l'aspect d'un sous-formulaire qui se répète lorsqu'il s'étend sur une nouvelle page.
      •
      Pour tester le paramètre de modèle de données s'appliquant aux données liées, assurez-vous que toutes les valeurs de données suivent le même format généré par le système, en particulier si la syntaxe des données source ne correspond pas aux valeurs par défaut de LiveCycle Designer.
      •
      Générez suffisamment de données pour utiliser la disposition de chaque gabarit du formulaire résultant.
Les consignes suivantes visent à faciliter la création d'un fichier test simple qui comporte des données d'entrée représentatives :
      •
      Le fichier des données d'entrée doit être un fichier XML valide. Par exemple, un fichier plat comporte des éléments au format suivant :

        <root_node>
            <first_node>value</first_node>
            <second_node>value</second_node>
            ...
            <last_node>value</last_node>
        </root_node>
      •
      Comparez le flux des données d'entrée à la disposition du formulaire. Si vous utilisez une liaison implicite, les noms des noeuds de données doivent correspondre aux champs et aux conteneurs correspondants du formulaire et suivre l'ordre de remplissage du formulaire.
      •
      Si le fichier des données d'entrée comprend davantage de niveaux d'imbrication que les éléments de la palette Hiérarchie, vous devez définir les liaisons de données de tous les objets imbriqués de manière explicite via le panneau Liaison de la palette Objet.
      •
      Dans le fichier des données d'entrée, recherchez les données qui sont répétées, mais qui ne figurent pas dans tous les enregistrements. Ces données pourraient peut-être être traitées en tant qu'objets standard dans les gabarits ou dans des sous-formulaires qui répètent les données pour des enregistrements spécifiques.
Pour commencer le test, vous pouvez définir le fichier de données d'entrée à charger dans une fenêtre d'aperçu de LiveCycle Designer (voir le panneau Valeurs par défaut de la boîte de dialogue Propriétés du formulaire). Le cas échéant, vous pouvez réorganiser les objets dans la conception de formulaire en fonction de l'ordre et de l'imbrication des noeuds de données du fichier des données d'entrée.
Pour affiner davantage une conception de formulaire d'après les données d'entrée, songez à fractionner les informations dans les différents composants énoncés ci-dessous et à les organiser en conséquence :
      •
      Il est recommandé de placer les objets constituant un en-tête de formulaire sur un gabarit.
      •
      Il est recommandé de placer le contenu du formulaire (y compris les débuts de débordement, les lignes qui se répètent (sous-formulaires) et les fins de débordement) sur des pages.
      •
      Pour les formulaires PDF interactifs et statiques, les objets constituant un pied de page de formulaire peuvent être placés sur un gabarit. Il est préférable d’éviter d’insérer des pieds de page dans les formulaires HTML.
assurez-vous que les données du formulaire ne contiennent pas de valeurs hexadécimales comprises entre 0x00 et 0x20, à l'exception du retour chariot, du changement de ligne et de la tabulation horizontale. Ces valeurs ne sont pas des caractères XML valides reconnus par LiveCycle Forms.
Voir aussi
A propos des sources de données
A propos des formulaires interactifs
Méthodes de création de conceptions de formulaire
A propos de la création de conceptions de formulaire prévues pour s'adapter aux données
Pour prévisualiser et tester les formulaires dans le panneau Aperçu PDF
Aperçu d’un formulaire HTML


Précédent Suivant

Utilisation de LiveCycle Designer > Création de formulaires destinés à LiveCycle Forms > Conception de formulaires pour LiveCycle Forms > Optimisation et amélioration des performances pour LiveCycle Forms

Optimisation et amélioration des performances pour LiveCycle Forms

A propos de l'optimisation et de l'amélioration des performances
Mise en cache des formulaires
Pour spécifier la mise en cache pour un formulaire avec une disposition fixe
Génération sur le client d'une conception de formulaire avec une disposition souple
Insertion automatique de données dans les champs de formulaire


Précédent Suivant

Utilisation de LiveCycle Designer > Création de formulaires destinés à LiveCycle Forms > Conception de formulaires pour LiveCycle Forms > Optimisation et amélioration des performances pour LiveCycle Forms > A propos de l'optimisation et de l'amélioration des performances

A propos de l'optimisation et de l'amélioration des performances

LiveCycle Designer offre plusieurs méthodes d'optimisation et d'amélioration des performances des formulaires lors de l'utilisation d'LiveCycle Forms. Grâce à ces améliorations, vous pouvez configurer des fonctions de gain de temps telles que le rendu plus rapide des formulaires, le rendu des formulaires sur le client afin de réduire la charge du serveur et le pré-remplissage des formulaires à l'aide de données connues afin de réduire la charge des personnes qui remplissent les formulaires.
Voir aussi
Mise en cache des formulaires
Génération sur le client d'une conception de formulaire avec une disposition souple
Insertion automatique de données dans les champs de formulaire


Précédent Suivant

Utilisation de LiveCycle Designer > Création de formulaires destinés à LiveCycle Forms > Conception de formulaires pour LiveCycle Forms > Optimisation et amélioration des performances pour LiveCycle Forms > Mise en cache des formulaires

Mise en cache des formulaires

La mise en cache d'un formulaire est un moyen efficace d'accroître les performances au moment de la génération du formulaire. Lorsqu'un formulaire est mis en cache, les données sont placées dans une présentation générée au préalable. A l'aide d’LiveCycle Forms, vous pouvez mettre en cache vos formulaires afin d'améliorer les performances de l'affichage.
Notez que les restrictions suivantes s'appliquent lorsque la mise en cache est activée :
      •
      Si le formulaire peut être complété à l'aide d’Acrobat ou d'Adobe Reader 6.0.2, la mise en cache ne concerne que les formulaires avec une disposition fixe. La mise en cache des formulaires avec une disposition souple n'est possible qu'avec Acrobat et Adobe Reader 7.0 et les versions ultérieures.
      •
      Aucun script côté serveur associé à la disposition du formulaire n'est pris en considération. Ainsi, il n'est pas possible d'utiliser un script pour définir la couleur de remplissage, la couleur de la police, ou encore la largeur et la couleur d'une bordure.
      •
      Les scripts côté serveur qui modifient le contenu de la page, le nombre ou la position des champs ou l'aspect du formulaire ne sont pas pris en considération.
      •
      Lorsque vous faites appel à la conversion PDF ou PDFForm, vous ne pouvez pas modifier la disposition du formulaire par le biais de scripts côté client. Cependant, lorsque vous choisissez la conversion HTML, il est possible d'utiliser des scripts côté client pour modifier la disposition d'un formulaire, et cela, même si la fonction de mise en cache est activée.
      •
      Les droits d'utilisation sont appliqués au formulaire avant la mise en cache afin d'améliorer davantage la performance de l'affichage.
      •
      Pour être mis en cache, chaque formulaire doit avoir une identification unique. LiveCycle DesignerSi vous souhaitez créer un formulaire à partir d'un formulaire existant, n'utilisez pas la commande Copier du système d'exploitation pour copier le formulaire. Utilisez plutôt la commande de LiveCycle Designer, Fichier > Enregistrer sous, pour créer le formulaire et l'identifier de manière unique pour permettre sa mise en cache.
      •
      Si vous ouvrez un formulaire existant dans LiveCycle Designer et que vous y enregistrez des modifications, le cache sera automatiquement mis à jour.
Pour que LiveCycle Forms puisse mettre en cache des formulaires avec une disposition fixe, sélectionnez l'option de mise en cache de formulaires de LiveCycle Designer pour chacun des formulaires que vous créez.


Précédent Suivant

Utilisation de LiveCycle Designer > Création de formulaires destinés à LiveCycle Forms > Conception de formulaires pour LiveCycle Forms > Optimisation et amélioration des performances pour LiveCycle Forms > Pour spécifier la mise en cache pour un formulaire avec une disposition fixe

Pour spécifier la mise en cache pour un formulaire avec une disposition fixe

1.
Choisissez Fichier > Propriétés du formulaire.
2.
Cliquez sur l’onglet Valeurs par défaut et choisissez Autoriser la mise en cache du rendu sur le serveur.
3.
Cliquez sur OK.
Voir aussi
Pour tester la fusion de données
Conversion de formulaires


Précédent Suivant

Utilisation de LiveCycle Designer > Création de formulaires destinés à LiveCycle Forms > Conception de formulaires pour LiveCycle Forms > Optimisation et amélioration des performances pour LiveCycle Forms > Génération sur le client d'une conception de formulaire avec une disposition souple

Génération sur le client d'une conception de formulaire avec une disposition souple

Si vos formulaires sont remplis à l'aide d'Acrobat 7.0 ou une version ultérieure, ou d'Adobe Reader 7.0 ou une version ultérieure, vous pouvez opter pour le rendu des formulaires côté client et non côté serveur.
La génération de formulaires interactifs ou non interactifs avec une disposition souple, via Acrobat ou Adobe Reader côté client, est plus performante que du côté serveur Cela s'explique par le fait que les applications client Acrobat et Adobe Reader exécutent l'opération de rendu, par opposition au serveur. Même les formulaires avec une disposition souple impliquant la fusion de données peuvent être générés sur le client.
De plus, via le rendu côté client, vous optimisez la distribution du contenu PDF et vous améliorez la capacité de LiveCycle Forms à traiter la charge du réseau.
Pour rendre un formulaire côté client, LiveCycle Forms doit être configuré pour afficher les formulaires sur le client et générer un PDF de base.
Le fichier PDF de base est un conteneur qui permet de distribuer un fichier XDP (avec le flux de données) au client Acrobat ou Adobe Reader. Il sert de base à partir de laquelle le fichier PDF rendu dynamiquement est affiché et peut contenir des polices imbriquées, requises par le fichier XDP. Grâce au fichier PDF de base, Acrobat et Adobe Reader peuvent ouvrir le fichier XDP et générer le PDF sur le client.
Pour plus d’informations sur LiveCycle Forms et la génération de formulaires sur le client, reportez-vous au guide Développement d’applications personnalisées fourni avec LiveCycle Forms.
Voir aussi
A propos de la création de conceptions de formulaire prévues pour s'adapter aux données
Méthodes de création de conceptions de formulaire


Précédent Suivant

Utilisation de LiveCycle Designer > Création de formulaires destinés à LiveCycle Forms > Conception de formulaires pour LiveCycle Forms > Optimisation et amélioration des performances pour LiveCycle Forms > Insertion automatique de données dans les champs de formulaire

Insertion automatique de données dans les champs de formulaire

Des données peuvent être insérées automatiquement dans tous les types de formulaire à l'aide de l'API Module de LiveCycle Forms. Vous pouvez préremplir un formulaire à l'aide de données avant de le générer, ou remplir la conception de formulaire enregistrée par LiveCycle Designer comme formulaire PDF. Les données proviennent d'une variété de sources, telles qu'une base de données, un autre formulaire ou une autre application.
L'insertion automatique de données dans un formulaire présente plusieurs avantages :
      •
      Elle permet à l'utilisateur d'afficher des données personnalisées dans un formulaire
      •
      Elle permet de réduire le volume de saisie de l'utilisateur pour remplir un formulaire
      •
      Elle assure l'intégrité des données grâce au contrôle du placement des données
L'insertion automatique de données dans les formulaires est plus rapide et plus sécurisée lorsqu'elle a lieu pendant le rendu des formulaires sur le serveur, et non sur le client.
Vérification de la source de données XML en vue de la fusion des données
Lors de l'insertion automatique de données dans des formulaires, il est important de s'assurer que la structure des données est compatible avec celle de la conception de formulaire, ou que celle-ci est compatible avec la structure des données.
En d'autres termes, un élément XML doit exister dans votre source de données pour chaque champ de formulaire dans lequel les données doivent être insérées automatiquement. Toute incompatibilité entre les structures du formulaire et de la source de données peut être source de problèmes de sortie. Le nom de l'élément XML doit correspondre à celui du champ du formulaire, et les éléments XML qui ne correspondent pas aux champs de formulaire sont ignorés.
Les deux types suivants de source de données peuvent être utilisés pour insérer automatiquement des données dans un formulaire LiveCycle Designer :
      •
      Une source de données XDP au format XML, compatible avec la syntaxe de l'architecture de formulaires XML
      •
      Une source de données arbitraire XML qui contient des paires nom/valeur correspondant aux noms de champs de formulaires
Une source de données XML est utilisée pour insérer automatiquement des données dans des formulaires. Cependant, une source de données XML prévue pour préremplir un formulaire avec une disposition souple contient des éléments XML répétitifs, qui sont utilisés pour compléter automatiquement des formulaires répétés dans le formulaire lui-même.
Pour plus d'informations sur le préremplissage, reportez-vous au guide Développement d’applications personnalisées fourni avec LiveCycle Forms.
Voir aussi
A propos de la liaison de champs à une source de données
Pour tester la fusion de données
A propos de la création de conceptions de formulaire prévues pour s'adapter aux données
Aperçu des sous-formulaires


Déploiement de formulaires vers LiveCycle Forms

Conditions préalables au déploiement des conceptions de formulaires vers LiveCycle Forms
Enregistrement d’une conception de formulaire : XDP ou PDF ?
Copie de conceptions de formulaires sur le réseau


Précédent Suivant

Utilisation de LiveCycle Designer > Création de formulaires destinés à LiveCycle Forms > Déploiement de formulaires vers LiveCycle Forms > Conditions préalables au déploiement des conceptions de formulaires vers LiveCycle Forms

Conditions préalables au déploiement des conceptions de formulaires vers LiveCycle Forms

Pour déployer une conception de formulaire, vous devez d’abord rendre la conception disponible pour LiveCycle Forms. Des étapes préalables supplémentaires sont indispensables au déploiement de conceptions de formulaires vers LiveCycle Forms :
      •
      Le développeur de l’application personnalisée doit définir la configuration requise de l’application. Le format de fichier de votre conception de formulaire (XDP ou PDF) dépendra de cette configuration.
      •
      Vous devez définir les options de conversion dans l’API de LiveCycle Forms pour que les conversions requises soient effectuées. Le développeur de l’application personnalisée définira les options en fonction des renseignements que vous lui fournirez.
      •
      Si vous utilisez un objet de signature dans une conception de formulaire PDF, le développeur de l’application personnalisée doit intégrer une solution tierce pour prendre en charge les signatures numériques.
Voir aussi
Enregistrement d’une conception de formulaire : XDP ou PDF ?
Copie de conceptions de formulaires sur le réseau


Enregistrement d’une conception de formulaire : XDP ou PDF ?

LiveCycle Forms accepte les formats suivants pour les conceptions de formulaires :
      •
      XDP
      •
      PDF
XDP est le format de fichier créé par LiveCycle Designer. Choisissez ce format pour soumettre le modèle de formulaire, n'importe quelle donnée de formulaire, les annotations, les balises d'accessibilité et toute autre information pertinente requise par LiveCycle Forms pour afficher le formulaire au moment de l'exécution. Vous devez choisir ce format si vous souhaitez que le formulaire déclenche le traitement côté serveur.
Enregistrez le formulaire au format PDF s'il doit toujours être ouvert dans Acrobat ou Adobe Reader.
Choisissez le format PDF si le formulaire comporte un champ de signature de document ou s'il est prévu que les utilisateurs enregistrent les données directement dans le formulaire PDF. Lorsque le formulaire généré a une disposition fixe et que vous prévoyez qu'il sera fréquemment utilisé, le fait de prévoir une conception de formulaire destinée à LiveCycle Forms au format PDF permet d'accroître les performances de LiveCycle Forms à l'exécution.
Ne choisissez pas le format PDF dans les cas suivants :
      •
      Le formulaire doit déclencher un traitement côté serveur.
      •
      LiveCycle Forms est utilisé pour afficher des formulaires HTML ou des formulaires à disposition souple.
Voir aussi
Conditions préalables au déploiement des conceptions de formulaires vers LiveCycle Forms
Copie de conceptions de formulaires sur le réseau


Copie de conceptions de formulaires sur le réseau

Pour fournir des conceptions de formulaires destinées à LiveCycle Forms, vous devez disposer des droits d'écriture à l'emplacement à partir duquel LiveCycle Forms extrait les fichiers lors de l'exécution. Le développeur de l’application personnalisée connaît l’emplacement auquel vous devez accéder et l’administrateur réseau peut définir pour vous les droits d’accès appropriés.
Les conceptions de formulaire achevées sont placées dans le système de fichiers local afin que le développeur de l’application personnalisée puisse y accéder. Vous devez inclure tous les autres fichiers indispensables à la prise en charge de la conception du formulaire (les images, par exemple).
Une fois que vos droits d’accès sont définis, vous pouvez publier les conceptions de formulaire à cet emplacement en utilisant la commande Publier dans le référentiel de LiveCycle Designer (choisissez Fichier > Publier dans le référentiel).
Voir aussi
Conditions préalables au déploiement des conceptions de formulaires vers LiveCycle Forms
Enregistrement d’une conception de formulaire : XDP ou PDF ?


Optimisation des conceptions de formulaire HTML

A propos des formulaires HTML
Utilisation de sous-formulaires pour créer des pages HTML
Observations sur la disposition des formulaires HTML
Recommandations relatives aux images utilisées dans les formulaires HTML
Contournement des restrictions des navigateurs Web
Pour activer la fonction de mise en cache des conversions pour les formulaires avec une disposition fixe
Aperçu d’un formulaire HTML


A propos des formulaires HTML

LiveCycle Forms permet de générer à la fois des formulaires HTML et des formulaires PDF. Pour distribuer les formulaires HTML, vous devez enregistrer vos conceptions de formulaire dans des fichiers XDP que vous déployez (avec les éventuels fichiers de support tels que des images) sur LiveCycle Forms.
Vous pouvez créer des formulaires interactifs au format HTML. Compte tenu du fait que les formulaires HTML sont affichés dans une application client (un navigateur Web, par exemple), ils sont soumis aux contraintes liées à l’environnement de l’application client.
Vous pouvez, par exemple, inclure des scripts JavaScript dans vos conceptions de formulaire et configurer le téléchargement des scripts vers l’application client en tant que partie intégrante du formulaire HTML lors de l’exécution. Assurez-vous au préalable que le langage JavaScript est activé pour exécuter le script dans le navigateur.
LiveCycle Forms 7.2 ne prend pas en charge les tableaux dans les conceptions de formulaires générées au format HTML.
Voir aussi
A propos des formulaires interactifs
Conceptions de formulaire prises en charge par LiveCycle Forms
A propos de la création de conceptions de formulaire prévues pour s'adapter aux données


Utilisation de sous-formulaires pour créer des pages HTML

Lorsqu’une conception de formulaire comprend des sous-formulaires qui se développent, il est difficile de connaître le nombre exact de pages que le formulaire final comportera lors de l’exécution. Le paramètre des formats de page permet de paginer les formulaires PDF, mais il n’est pas pris en compte lorsqu’il s’agit d’un formulaire HTML, car les pages HTML n’ont pas de longueur définie.
Pour mettre en oeuvre le concept d’un formulaire HTML multipage, vous pouvez inclure dans votre conception de formulaire un sous-formulaire de niveau page. L'un de ces sous-formulaires vous sera utile pour chaque page à générer dans le formulaire. Pour les formulaires prévus pour s'adapter à la taille des données, chaque sous-formulaire dont le contenu déborde doit être imbriqué au sein de l’un des sous-formulaires de niveau page. Par la suite, lorsque le formulaire est généré, le contenu faisant partie d’un même sous-formulaire de niveau page s’affiche sur la même page HTML.
pour mettre en oeuvre le concept d’un formulaire HTML multipage, vous devez inclure un ou plusieurs boutons dans chaque sous-formulaire de niveau page afin de permettre aux utilisateurs de se déplacer d’une page à l’autre. Le développeur de formulaires doit écrire un script permettant de gérer le traitement chaque fois qu’un utilisateur clique sur l’un de ces boutons.
Observez, par exemple, la conception de formulaire dans l’illustration suivante. La conception de formulaire comprend trois sous-formulaires de niveau page : Subform_Page0, Subform_Page1 et Subform_LastPage. Si LiveCycle Forms devait générer un formulaire HTML reposant sur cette conception, une page HTML serait créée automatiquement à partir de chaque sous-formulaire comportant des niveaux page.
Lorsque LiveCycle Forms génère le formulaire HTML lors de l’exécution, le premier sous-formulaire de niveau page est affiché sur la première page. Dans cet exemple, la première page ressemblerait à la page illustrée ici. Vous remarquerez la présence indispensable du bouton Page suivante qui permet aux utilisateurs de passer à la page suivante du formulaire.
En supposant qu’au moins un enregistrement soit disponible pour fusionner avec Expanding_subform lors de l’exécution, la seconde page pourrait ressembler à la page suivante fournie à titre d’exemple. Il convient ici aussi de prévoir un bouton Page suivante pour que les utilisateurs puissent accéder à la page suivante du formulaire. Vous pouvez également inclure un bouton Page précédente dans votre formulaire.
Le troisième sous-formulaire de niveau page, Subform_LastPage, est affiché sur la dernière page du formulaire généré. Dans cet exemple, la dernière page permet de remercier les utilisateurs d’avoir rempli le formulaire et propose un bouton d’envoi pour soumettre les données saisies àLiveCycle Forms.
Pour plus de détails sur l’élaboration d’un script permettant aux utilisateurs de parcourir des pages HTML, voir Rédaction d’un script destiné à traiter les pages HTML.
Voir aussi
Observations sur la disposition des formulaires HTML
Recommandations relatives aux images utilisées dans les formulaires HTML
Contournement des restrictions des navigateurs Web


Observations sur la disposition des formulaires HTML

Les informations ci-dessous vous aideront à concevoir des formulaires HTML destinés au Web qui sont agréables à l'oeil et faciles à lire.
      •
      N’utilisez pas les propriétés de bordure d’un objet pour tracer des lignes, des zones ou des grilles dans un formulaire. Certains navigateurs n’alignent pas les bordures exactement telles qu’elles sont présentées dans un aperçu de LiveCycle Designer. Les objets risquent de se chevaucher ou de déplacer d’autres objets de manière imprévue.
      •
      Pour les utilisateurs qui font appel à Microsoft Internet Explorer, vous pouvez utiliser des lignes, des rectangles et des cercles pour définir l’arrière-plan. Tous les autres navigateurs Web ne prennent en charge que les lignes verticales et horizontales. Par conséquent, les rectangles et les cercles de la conception du formulaire ne s'afficheront pas lors de l'exécution.
      •
      Si les utilisateurs disposent de navigateurs Opera, concevez des champs légèrement plus grands. Dans Opera, les champs comportent toujours une bordure intérieure enfoncée. Tout style appliqué à la bordure sera placé sur le contour extérieur de la bordure. La surface du champ à remplir se trouve réduite suite à l’espace occupé par la bordure enfoncée dans la zone.
      •
      Créez des objets de texte statique un peu plus grands que nécessaire pour accueillir le texte. LiveCycle Designer et Acrobat peuvent utiliser un crénage différent de celui du navigateur Web utilisé, et le texte risque ne pas s'afficher correctement.
      •
      LiveCycle Forms 7.2 ne prend pas en charge les tableaux dans les conceptions de formulaires générées au format HTML.
      •
      LiveCycle Forms 7.2 ne prend pas en charge les conceptions de formulaires contenant des polices relatives à l'arabe, l'hébreu, le thaï et le vietnamien.
Voir aussi
Recommandations relatives aux images utilisées dans les formulaires HTML
Contournement des restrictions des navigateurs Web


Précédent Suivant

Utilisation de LiveCycle Designer > Création de formulaires destinés à LiveCycle Forms > Optimisation des conceptions de formulaire HTML > Recommandations relatives aux images utilisées dans les formulaires HTML

Recommandations relatives aux images utilisées dans les formulaires HTML

Lorsque vous sélectionnez des images à insérer dans des conceptions de formulaires, vous pouvez inclure n'importe quel fichier image (à l’exception des fichiers GIF animés). Sachez, toutefois, que certains utilisateurs disposent de navigateurs Web imposant des restrictions au niveau des images.
N'incorporez pas d'images dans le formulaire. LiveCycle Forms ne prend pas en charge les images imbriquées. Insérez les fichiers image en spécifiant des noms de chemins d’accès relatifs.
Un chemin d’accès peut, par exemple, être défini par rapport au répertoire racine des formulaires LiveCycle Forms qui, par défaut, correspond au dossier configuré comme référentiel des formulaires. Le dossier des images défini dans le chemin d’accès suivant se trouve au même niveau que le dossier des formulaires :
../images/graphic.jpg
Voir aussi
Observations sur la disposition des formulaires HTML
Contournement des restrictions des navigateurs Web


Contournement des restrictions des navigateurs Web

Si vous pensez que certains utilisateurs se serviront de navigateurs dotés de fonctionnalités restreintes, vous devez tenir compte des restrictions du dénominateur commun le moins évolué et concevoir vos formulaires en conséquence. Si votre entreprise utilise au contraire des navigateurs qui prennent en charge XHTML, vous bénéficiez d’un plus large éventail de possibilités pour définir votre conception de formulaire.
Tenez compte des points suivants lorsque vous concevez des formulaires qui seront affichés dans divers navigateurs :
      •
      Définissez un format de page afin de vous assurer que la conversion HTML4 (pour Netscape Navigator 4.7.x) affichera correctement tous les objets statiques. A défaut, le système réservera seulement l’espace nécessaire aux champs du formulaire généré.
      •
      Prévoyez une marge d’au moins 1/4 po (0,635 cm) en haut et à gauche du formulaire. Les éléments de formulaire situés au-dessus et à gauche de cette limite ne seront pas visibles.
      •
      Les objets ou les parties d’objets comportant des coordonnées négatives ne sont pas affichés. Par exemple, si vous tracez un objet en commençant à la coordonnée verticale -1,270, la partie de l’objet comprise entre -1,270 et la marge de 0,635 cm ne sera pas visible.
      •
      Réservez suffisamment d’espace autour des champs afin de compenser la dégradation visuelle engendrée par les navigateur bas de gamme. Par exemple, dans certains navigateurs, l’affichage des cases à cocher et des boutons radio est plus large que la taille à laquelle ils ont été définis à la conception.
      •
      Il se peut que l’alignement à gauche des données ne soit pas conservé lorsqu’un navigateur bas de gamme est utilisé pour afficher le formulaire, notamment si les utilisateurs modifient les polices par défaut associées à leurs navigateurs.
Voir aussi
Observations sur la disposition des formulaires HTML
Recommandations relatives aux images utilisées dans les formulaires HTML


Précédent Suivant

Utilisation de LiveCycle Designer > Création de formulaires destinés à LiveCycle Forms > Optimisation des conceptions de formulaire HTML > Pour activer la fonction de mise en cache des conversions pour les formulaires avec une disposition fixe

Pour activer la fonction de mise en cache des conversions pour les formulaires avec une disposition fixe

LiveCycle Forms met en cache les conversions afin d’optimiser leurs performances. Afin que LiveCycle Forms effectue cette opération correctement lors de l’exécution, vous devez activer la fonction de mise en cache des formulaires lorsque vous créez un formulaire.
1.
Choisissez Fichier > Propriétés du formulaire.
2.
Cliquez sur l’onglet Valeurs par défaut et choisissez Autoriser la mise en cache du rendu sur le serveur.
3.
Cliquez sur OK.
Voir aussi
Conversion de formulaires


Aperçu d’un formulaire HTML

Pour tester le fonctionnement de votre conception de formulaire avec LiveCycle Forms et configurer avec précision les boutons de commande dans une conception de formulaire, vous devez connaître l’URL qui sera associé aux requêtes envoyées à LiveCycle Forms. Le développeur de l’application personnalisée connaît cet URL.
Pour afficher un aperçu du formulaire HTML, vous devez donner accès à LiveCycle Forms à la conception de formulaire afin que LiveCycle Forms puisse la stocker. Par la suite, vous pouvez demander le formulaire par le biais de l’URL associé à LiveCycle Forms. Utilisez un navigateur Web ou l’une des applications client cibles (telle qu’un lecteur d’écran) pour ouvrir le formulaire.
LiveCycle Forms 7.2 ne prend pas en charge les tableaux dans les conceptions de formulaires générées au format HTML. Il ne gère pas non plus les conceptions de formulaires contenant des polices relatives à l'arabe, l'hébreu, le thaï et le vietnamien.
Voir aussi
Conditions préalables au déploiement des conceptions de formulaires vers LiveCycle Forms
Copie de conceptions de formulaires sur le réseau


Traitement des formulaires intelligents

Emplacement d'exécution des calculs et des scripts
Traitement client et serveur
Evénements à référencer dans un script ou un calcul
Récapitulatif des propriétés, méthodes et événements pris en charge
Expressions prises en charge par les clients HTML
Rédaction d’un script destiné à traiter les pages HTML


Emplacement d'exécution des calculs et des scripts

Dans une conception de formulaire, vous pouvez incorporer des calculs et des scripts visant à exécuter des calculs, des méthodes ou des opérations lorsque l'un des événements relatifs à un objet survient au moment de l'exécution. Par exemple, un événement se produit pendant l'exécution lorsque l'utilisateur effectue l'action spécifiée par cet événement. Vous pouvez appeler n'importe quelle méthode prise en charge par un objet, puis définir un script afin d'afficher ou de configurer les propriétés.
Dans LiveCycle Designer, les scripts et les calculs sont conçus, par défaut, pour fonctionner sur le périphérique client. L’emplacement de traitement par défaut est défini dans le panneau Valeurs par défaut de la boîte de dialogue Propriétés du formulaire (disponible via Fichier > Propriétés du formulaire). Pour changer d'emplacement de traitement par défaut, vous pouvez indiquer explicitement un autre dossier à l'aide de l'option Exécuter sur, disponible dans l'éditeur de script lorsque vous joignez un script ou un calcul à un objet.
Si LiveCycle Forms est installé sur votre système, vous pouvez effectuer le traitement sur le client, sur le serveur ou sur les deux à la fois. Lorsque vous configurez l’exécution d’un script/calcul sur le client et le serveur à la fois, il se peut que les deux ordinateurs tentent de lancer l’opération. LiveCycle Forms s’efforce systématiquement de traiter le script/calcul lorsque le client n’est pas en mesure de le faire. Si les scripts/calculs sont conçus pour être exécutés sur le serveur, LiveCycle Forms lance les scripts et/ou les calculs, fusionne à nouveau les résultats dans le formulaire avant de les renvoyer au client.
Les scripts et les calculs client sont exécutés sur le périphérique client. Lors de la création de formulaires PDF destinés à Acrobat ou Adobe Reader, le traitement complet doit être effectué sur le client. Cependant, si le client ne peut pas exécuter le script ou le calcul, LiveCycle Forms tentera d'effectuer l'opération.
Pour exécuter un script client dans un formulaire HTML, assurez-vous que les conditions suivantes sont remplies :
      •
      L’application client doit être Microsoft Internet Explorer 5.x, Netscape 6.0 (ou version ultérieure) ou Opera 5 (ou version ultérieure).
      •
      Il est possible d’utiliser le langage JavaScript uniquement pour l’écriture des scripts (vous ne pouvez pas inclure de calculs FormCalc dans la conception de formulaire).
      •
      La fonction JavaScript doit être activée dans l’application client.
LiveCycle Forms 7,1 ne prend pas en charge les tableaux dans les conceptions de formulaires générées au format HTML.
Voir aussi
Traitement client et serveur
Evénements à référencer dans un script ou un calcul
Expressions prises en charge par les clients HTML
Rédaction d’un script destiné à traiter les pages HTML
A propos de FormCalc


Traitement client et serveur

Le traitement peut être exécuté sur le client, sur le serveur ou sur les deux. Les scripts et les calculs se comportent différemment selon leur emplacement d'exécution.
Traitement client
Lors de l'exécution, si le traitement est configuré pour s'effectuer sur le client, tous les scripts/calculs sont lancés en temps réel sur l'ordinateur de l'utilisateur. Le code et les variables déclarés sont alors disponibles quasiment dès l'ouverture du formulaire. Ces informations restent disponibles et l'état des données est conservé jusqu'à ce que l'une des situations suivantes se présentent :
      •
      Un autre script est exécuté.
      •
      Un autre script supprime l'objet associé.
      •
      Le formulaire est fermé.
Traitement serveur
LiveCycle Forms peut gérer tout type de script/calcul que l'application client n'est pas en mesure de traiter. Si, par exemple, vous souhaitez préremplir un formulaire, il se peut que vous deviez utiliser un script afin de vous connecter à une base de données ou un service Web non disponible à partir du client. Lorsque LiveCycle Forms exécute un script ou un calcul, cette opération se produit pendant la génération du formulaire. Une fois le traitement terminé, plus aucun code ni variable n'est disponible. Autrement dit, si vous ajoutez des variables à un script ou un calcul, elles demeurent valides uniquement pendant la durée du traitement.
si vous choisissez la conversion HTML4 pour prendre en charge Netscape Navigator 4.7.x, tout script JavaScript conçu pour fonctionner sur le client est automatiquement lancé sur le serveur.
LiveCycle Forms 7,1 ne prend pas en charge les tableaux dans les conceptions de formulaires générées au format HTML.
Voir aussi
Emplacement d'exécution des calculs et des scripts
A propos de FormCalc


Evénements à référencer dans un script ou un calcul

Scripts serveur
Acrobat et Adobe Reader reconnaissent tous les événements pris en charge par LiveCycle Designer. L'application client envoie les événements déclenchés par l'utilisateur à LiveCycle Forms pour le traitement sur le serveur. Aucun autre type d’événement ne déclenche le traitement sur le serveur. LiveCycle Forms exécute le traitement sur le serveur chaque fois qu'il génère un formulaire, qu’il exécute des événements serveur lancés à partir du client ou qu’il traite les données envoyées.
Lorsque vous configurez l'exécution d'un script ou d'un calcul sur le serveur, les événements suivants déclenchés par l'utilisateur obligent Acrobat ou Adobe Reader à envoyer l'événement à LiveCycle Forms à des fins de traitement :
      •
      exit
      •
      mouseEnter
      •
      mouseExit
      •
      change
      •
      mouseUp
      •
      mouseDown
      •
      click
Lors du traitement des événements, LiveCycle Forms exécute tous les scripts et calculs conçus pour être lancés sur le serveur et fusionne à nouveau les résultats dans le formulaire avant de renvoyer celui-ci à l’application client.
Si l'un des événements suivants est référencé dans un script ou calcul serveur, Acrobat ou Adobe Reader n'en tient pas compte :
      •
      initialize
      •
      calculate
      •
      validate
      •
      docReady
      •
      docClose
Le tableau suivant identifie les événements que vous pouvez référencer dans des scripts ou calculs serveur uniquement. Ces événements ne sont pas reconnus par les applications client HTML.

Evénement

Pour plus de détails, voir
form:ready
Evénement form:ready
layout:ready
Evénement layout:ready
Lorsqu’un script a été conçu pour fonctionner sur le serveur, l’événement click (d’un bouton de souris normal) est le seul événement qui oblige un client HTML à déclencher le traitement sur le serveur. Lors du traitement, LiveCycle Forms fusionne à nouveau les résultats dans le formulaire HTML avant de renvoyer ce dernier à l’application client. Tous les autres événements sont ignorés par le client HTML et exécutés uniquement lorsque LiveCycle Forms effectue le traitement sur le serveur.
Scripts client
Pour les scripts et les calculs client, Acrobat et Adobe Reader prennent en charge la liste complète des événements que vous pouvez définir dans LiveCycle Designer.
Cependant, ces événements ne sont pas tous reconnus par les clients HTML. Si vous utilisez une seule conception de formulaire pour créer à la fois des formulaires PDF et des formulaires HTML, assurez-vous que les scripts client référencent uniquement un sous-ensemble des événements pris en charge.
Si un script client référence un événement que le client HTML ne reconnaît pas, le script arrêtera l’exécution au point où l’événement non reconnu est référencé.
Vous pouvez utiliser les événements suivants pour exécuter des scripts client à partir de formulaires HTML.
]

Evénement

Pour plus de détails, voir
initialize
Evénement initialize
enter
Evénement enter
exit
Evénement exit
calculate
Evénement calculate
seuls les formulaires HTML permettent d’exécuter des activités déclenchées par les événements calculate lorsque le curseur quitte une zone. Le traitement ne démarre pas lorsqu’un utilisateur modifie la valeur d’une zone, mais vous pouvez appeler le traitement explicitement à ce stade (si nécessaire) à l’aide de la méthode execCalculate().
validate
Evénement validate
change
Evénement change
dans les formulaires PDF et HTML , cet événement est pris en charge par les listes déroulantes et les zones de liste uniquement.
mouseUp
Evénement mouseUp
mouseDown
Evénement mouseDown
click
Evénement click
il est impossible d’utiliser l’événement click pour les boutons d’envoi des formulaires PDF ou HTML. Utilisez à la place l’événement preSubmit.
preSubmit
Evénement preSubmit
dans les formulaires PDF et HTML, cet événement est pris en charge pour les boutons Envoyer uniquement. Lorsque vous utilisez l’événement preSubmit pour exécuter un script client, le traitement a lieu avant la soumission des données. Si l’événement exécute un script sur le serveur, le traitement a lieu pendant l’envoi des données.
Voir aussi
Récapitulatif des propriétés, méthodes et événements pris en charge
Emplacement d'exécution des calculs et des scripts
A propos des calculs et des scripts


Récapitulatif des propriétés, méthodes et événements pris en charge

A l'exception de quelques méthodes d'objets hôtes, Acrobat et Adobe Reader prennent en charge l'ensemble des propriétés, méthodes et événements. Les clients HTML reconnaissent un nombre limité de ces propriétés, méthodes et événements.
Si vous utilisez un modèle de formulaire simple pour créer à la fois des formulaires PDF et des formulaires HTML, vos scripts peuvent référencer un sous-ensemble des propriétés, méthodes et événements pris en charge.
LiveCycle Forms 7,1 ne prend pas en charge les tableaux dans les conceptions de formulaires générées au format HTML.
Les tableaux suivants indiquent les applications client qui reconnaissent les divers événements, propriétés et méthodes que vous pouvez référencer dans les scripts client et/ou serveur.

Objet hôte

Acrobat / Adobe Reader

Client HTML

Propriétés
currentPage (lecture seule)
Oui
Oui
numPages (lecture seule)
Oui
Oui
name (lecture seule)
Oui
Oui
validationsEnabled
Oui
Oui
calculationsEnabled
Oui
Oui

Méthodes
pageUp
Oui
Client et serveur uniquement
pageDown
Oui
Client et serveur uniquement
exportData
Oui
Non
importData
Oui
Non
gotoURL
Client uniquement
Client uniquement
messageBox
Client uniquement
Client uniquement
resetData
Oui
Oui
setFocus
Client uniquement
Client uniquement

Evénements
docReady
Oui
Serveur uniquement
docClose
Oui
Serveur uniquement
postPrint
Oui
Non
postSave
Oui
Non
prePrint
Oui
Non
preSave
Oui
Non

Objet de formulaire

Acrobat / Adobe Reader

Client HTML

Méthodes
resolveNodes
Oui
Oui
resolveNode
Oui
Oui
execCalculate
Oui
Oui
execValidate
Oui
Oui
execInitialize
Oui
Oui

Objet de sous-formulaire

Acrobat / Adobe Reader

Client HTML

Propriétés
name (lecture seule)
Oui
Oui
index (lecture seule)
Oui
Oui
x
Oui
Oui
y
Oui
Oui
w
Oui
Oui
h
Oui
Oui
validationMessage
Oui
Oui

Méthodes
resolveNodes
Oui
Oui
resolveNode
Oui
Oui
execCalculate
Oui
Oui
execValidate
Oui
Oui
execInitialize
Oui
Oui

Evénements
enter
Oui
Oui
exit
Oui
Oui
initialize
Oui
Oui
validate
Oui
Oui
calculate
Oui
Oui

Objets de champ

Acrobat / Adobe Reader

Client HTML

Propriétés
name (lecture seule)
Oui
Oui
index (lecture seule)
Oui
Oui
rawValue
Oui
Oui
formattedValue
Voir la remarque 1.
Oui
x
Oui
Oui
y
Oui
Oui
w
Oui
Oui
h
Oui
Oui
visibilité
Oui
Oui
mandatory
Oui
Oui
fontColor
Oui
Oui
fillColor
Oui
Oui
borderColor
Oui
Oui
borderWidth
Oui
Oui
validationMessage
Oui
Oui

Méthodes
execCalculate
Oui
Oui
execInitialize
Oui
Oui
execValidate
Oui
Oui
addItem
Oui, par les listes déroulantes et les zones de liste uniquement
Oui, par les listes déroulantes et les zones de liste uniquement
clearItems
Oui, par les listes déroulantes et les zones de liste uniquement
Oui, par les listes déroulantes et les zones de liste uniquement
resolveNodes
Oui
Oui
resolveNode
Oui
Oui

Evénements
exit
Oui
Oui
enter
Oui
Oui
calculate
Oui
Oui
validate
Oui
Oui
initialize
Oui
Oui
click
Oui, mais pas pour les boutons d'envoi. Voir la remarque 2.
Oui, mais pas pour les boutons d'envoi. Voir la remarque 2.
change
Oui
Oui, par les listes déroulantes et les zones de liste uniquement
mouseUp
Oui
Oui
mouseDown
Oui
Oui
preSubmit
Oui
Oui, pour les boutons d’envoi uniquement
Remarque 1 : Pour les zones de liste, formattedValue ne renvoie pas le texte d'affichage.
Remarque 2 : L’événement click n’est pas pris en charge par les boutons d’envoi des formulaires PDF ou HTML. Utilisez preSubmit à la place.

Objet ScriptObject

Acrobat / Adobe Reader

Client HTML
Voir la remarque 3.
Oui
Oui
Remarque 3 : L'objet ScriptObject peut être créé et utilisé avec n'importe quel autre script. Voir Pour créer un objet de script.

Objet événement

Acrobat / Adobe Reader

Client HTML

Propriétés
prevText
Oui
Non
prevContentType
Oui
Non
newText
Oui
Non
newContentType
Oui
Non
fullText
Oui
Non
commitKey
Oui
Non
keyDown
Oui
Non
modifier
Oui
Non
name
Oui
Non
selEnd
Oui
Non
selStart
Oui
Non
shift
Oui
Non
target
Oui
Non
change
Oui
Non


Expressions prises en charge par les clients HTML

Un sous-ensemble simplifié d’expressions de syntaxe de référence est pris en charge par les clients HTML :
      •
      Les raccourcis de symboles ($form, $data et $host, par exemple) ne sont pas pris en charge.
      •
      Les points de suspension (...) ne sont pas pris en charge.
      •
      Lorsque vous rédigez un script client pour des formulaires HTML, vous devez utiliser l’expression resolveNode JavaScript afin d’identifier les noeuds dans la hiérarchie. Le script ne peut pas traiter la hiérarchie à l’aide de la notation des objets. L’expression suivante n’est pas prise en charge, par exemple :

xfa.form.subform1.TextEdit1
L’expression suivante est prise en charge :
xfa.form.resolveNode("subform1.TextEdit1")
Il est possible d’utiliser des références à des zones non qualifiées pour repérer des zones voisines dans la hiérarchie.
si vous choisissez la conversion HTML4 pour prendre en charge Netscape Navigator 4.7.x, tout script JavaScript conçu pour fonctionner sur le client est automatiquement exécuté sur le serveur.
LiveCycle Forms 7,1 ne prend pas en charge les tableaux dans les conceptions de formulaires générées au format HTML.


Rédaction d’un script destiné à traiter les pages HTML

Lorsque la même conception de formulaire est utilisée pour générer des formulaires PDF et HTML, la configuration des formats de page permet de paginer les formulaires PDF, mais elle n’est pas prise en compte dans le cas des formulaires HTML. Pour gérer les différences entre les deux types de formulaires (PDF et HTML), les auteurs peuvent éventuellement recourir à des sous-formulaires de niveau page afin de définir des pages HTML artificielles. Si les pages HTML sont configurées de cette manière, il est alors indispensable de prévoir un script JavaScript pour permettre aux utilisateurs de passer d’une page HTML à l’autre lors de l’exécution.
LiveCycle Forms 7,1 ne prend pas en charge les tableaux dans les conceptions de formulaires générées au format HTML.
Vous pouvez utiliser les méthodes pageUp() et pageDown() pour permettre aux utilisateurs de se déplacer au sein des pages HTML en utilisant un bouton de commande normal qui déclenche le traitement lorsque l'événement click du bouton se produit. Pour les formulaires PDF et HTML, assurez-vous que le traitement est exécuté sur le client et le serveur.
Les méthodes pageUp() et pageDown() s’appliquent aux sous-formulaires de niveau page. Supposons par exemple que l’auteur d’un formulaire configure la structure suivante dans la conception de son formulaire :
Si l’utilisateur visualise la page HTML qui correspond à Subform_Page0, l’appel de xfa.host.pageDown() entraîne l’affichage de Subform_Page1 dans le navigateur. De la même manière, l’appel de xfa.host.pageUp() alors que Subform_Page1 est déjà affiché entraîne l’affichage de Subform_Page0 dans le navigateur. Les numéros de page sont alors assignés aux propriétés suivantes afin de manipuler ces pages HTML :
xfa.host.currentPage = 0 	//moves to the first page
xfa.host.currentPage = 1 	//moves to the second page
xfa.host.currentPage = 2 	//moves to the third page
xfa.host.currentPage = xfa.host.numPages -1 	//moves to the last page
A mesure que les utilisateurs parcourent les pages HTML, l’état des données est conservé, mais l’état de présentation d’un objet (par exemple, la couleur d’arrière-plan d’un champ) peut varier d’une page à l'autre. Vous pouvez conserver la configuration de présentation entre les pages en utilisant des champs masqués qui comportent les valeurs d’état des différents paramètres et des boutons de commande permettant aux utilisateurs de parcourir les pages du formulaire dans un sens comme dans l’autre. Le script met à jour les états de présentation des champs reposant sur les valeurs des champs masqués. Lorsqu’un utilisateur clique sur l’un des boutons de commande, l’événement calculate associé au bouton pourrait être prévu pour exécuter le script.
Par exemple, le script JavaScript suivant conserve la couleur de remplissage d’un champ en fonction de la valeur d’un champ intitulé hiddenField. Le script est déclenché lorsque l’événement calculate se produit.
If (hiddenField.rawValue == 1)
this.fillColor = “255,0,0”
else
this.fillColor = “0,255,0”
lorsque les scripts d’un formulaire HTML sont exécutés sur le périphérique client, le script peut uniquement s’appliquer à la page de sous-formulaire/HTML active.
Voir aussi
pageDown
pageUp
currentPage


Création de formulaires pour LiveCycle Workflow

A propos de LiveCycle Workflow
Pour créer un formulaire destiné à LiveCycle Workflow
Objets requis pour LiveCycle Workflow


A propos de LiveCycle Workflow

Adobe® LiveCycle™ Workflow permet de concevoir, de déployer et de gérer des processus automatisés de gestion qui connectent des systèmes et des personnes. LiveCycle Workflow fournit de nombreux outils d'implémentation de votre plan d'automatisation de processus de gestion :
LiveCycle Workflow Designer
Application bureautique pour la création de définitions électroniques de processus de gestion et leur déploiement sur le serveur.
LiveCycle Workflow Server
Application de serveur qui exécute les définitions électroniques des processus de gestion et coordonne l'activité de ces processus.
Administration de LiveCycle
Application basée sur Web pour la configuration de l'authentification et de l'autorisation des utilisateurs pour tous les produits LiveCycle, la configuration des propriétés d'exécution de LiveCycle Workflow Server et la gestion de la progression de l'exécution des processus.
LiveCycle Workflow Business Activity Monitor
Ensemble d'applications basées sur le Web pour la création et l'affichage des tableaux de bord basés sur des données en temps réel provenant de processus de gestion automatisés.
Pour plus d'informations sur ces outils, voir Aperçu de LiveCycle Workflow.
Voir aussi
Pour créer un formulaire destiné à LiveCycle Workflow
Objets requis pour LiveCycle Workflow


Pour créer un formulaire destiné à LiveCycle Workflow

Adobe LiveCycle Designer peut créer des formulaires pour LiveCycle Workflow. Les formulaires conçus pour LiveCycle Workflow doivent comporter certains objets. Pour faciliter votre travail, nous avons créé un objet personnalisé qui permet de traiter le formulaire dans LiveCycle Workflow Server. Vous pouvez utiliser l'objet de champ d'Adobe LiveCycle Workflow pour insérer rapidement les objets dans votre formulaire. Cet objet se trouve dans la catégorie Personnalisés de la palette Bibliothèque.
L'objet personnalisé ajoute les objets nécessaires, par exemple le bouton Envoyer, un menu contextuel des actions, ainsi que d'autres champs cachés, qui permettent de transférer les données dont LiveCycle Workflow Server a besoin pour acheminer le formulaire correctement. Grâce à l'objet personnalisé, vous n'avez pas besoin de créer tous ces objets et vous êtes sûr qu'ils sont créés correctement chaque fois.
Il est possible d'utiliser les formulaires LiveCycle Designer dans un environnement de courrier électronique et dans un environnement Web. Les formulaires peuvent être conçus pour fonctionner dans un de ces environnements ou dans les deux de façon simultanée.
Pour permettre la prise en charge du formulaire par messagerie électronique, intégrez le formulaire dans une page Web, puis activez-le au moyen d'un navigateur Web.
1.
Créez le formulaire.
2.
Ajoutez-y l'objet de champ d'Adobe LiveCycle Workflow
Si votre formulaire comprend plus d'une page, vous devez insérer l'objet de champ d'Adobe LiveCycle Workflow sur la première page.
3.
Choisissez Fichier > Enregistrer.
Voir aussi
A propos de LiveCycle Workflow
Objets requis pour LiveCycle Workflow


Objets requis pour LiveCycle Workflow

Les objets qui suivent sont requis dans les formulaires destinés à être utilisés dans LiveCycle Workflow. L'objet de bibliothèque personnalisée appelé objet de champ d'Adobe LiveCycle Workflow comporte les objets nécessaires à Form Manager, ceux nécessaires au courrier électronique et ceux qui sont nécessaires aux deux.
le menu contextuel AWS_ACTION et le bouton Envoyer sont visibles lorsque l'utilisateur remplit le formulaire. Tous les autres objets sont invisibles.

Nom de champ

Type

Description
AWS_SUBMIT
Bouton
Envoie le formulaire à LiveCycle Workflow Server.
Pour convertir des formulaires et des données de formulaire en un document PDF et enregistrer la référence dans une variable de document, vous devez configurer le bouton Envoyer pour utiliser un format d'envoi PDF.
Dans la palette Objet, cliquez sur l’onglet Champ, puis sur Envoyer. Cliquez sur l'onglet Envoyer et sélectionnez PDF dans le menu Format d’envoi.
AWS_ACTION
Menu déroulant
Contient la liste des choix possibles pour terminer l'élément de travail. Si vous ne souhaitez pas offrir plusieurs possibilités, il n'est pas nécessaire d'inclure ce champ.
AWS_ASSIGNED_ID
Champ Texte (invisible)
Champ de texte masqué qui contient le nom du participant qui envoie le formulaire.
AWS_STATUS
Champ Texte (invisible)
Champ de texte masqué dans lequel les données du flux de production sont insérées automatiquement.
AWS_TASKID
Champ Texte (invisible)
Champ de texte masqué dans lequel les données du flux de production sont insérées automatiquement.
Ce champ contient l'identité de la tâche associée au formulaire.
AWS_MAILTO
Champ Texte (invisible)
Champ de texte masqué qui contient l'adresse électronique utilisée par LiveCycle Workflow Server.
Vous devez entrer une valeur dans ce champ si vous souhaitez que les utilisateurs lancent des processus en envoyant le formulaire par messagerie à LiveCycle Workflow Server.
AWS_CHOICE
Champ Texte (invisible)
Champ de texte masqué dans lequel les données du flux de production sont insérées automatiquement.
AWS_PROCESSTYPE
Champ Texte (invisible)
Champ de texte masqué qui contient le type de processus auquel le formulaire est associé.
Vous ne devez entrer une valeur dans ce champ que si vous souhaitez que les utilisateurs lancent des processus en envoyant le formulaire par messagerie à LiveCycle Workflow Server.
Si le champ AWS_TASKID est vide, LiveCycle Workflow Server appelle le type de processus défini dans le champ AWS_PROCESSTYPE.
FSSUBMIT_
Champ Texte (invisible)
Bouton masqué dans lequel les informations sont entrées automatiquement pour l'envoi du formulaire à LiveCycle Forms.
vous ne devez pas regrouper les champ de flux de production. Si vous le faites, le formulaire ne sera pas reconnu par LiveCycle Workflow.
Pour plus de détails, voir le guide Création de flux de production de LiveCycle Workflow.
Voir aussi
A propos de LiveCycle Workflow
Pour créer un formulaire destiné à LiveCycle Workflow


Utilisation du clavier

Raccourcis clavier par défaut
Personnalisation des raccourcis clavier


Raccourcis clavier par défaut

Raccourcis clavier usuels
Raccourcis clavier pour annuler ou rétablir une action
Raccourcis pour supprimer du texte
Raccourcis clavier affectés à la sélection de texte
Raccourcis pour copier et déplacer du texte
Raccourcis pour formater le texte sélectionné
Raccourcis clavier pour définir l'interligne
Raccourcis clavier pour aligner les paragraphes
Raccourcis clavier associés aux fenêtres
Raccourcis clavier pour naviguer dans une conception de formulaire
Raccourcis clavier associés aux menus
Raccourcis clavier associés à l'éditeur de script ou au panneau Source XML
Raccourcis clavier pour manipuler les objets
Raccourcis clavier pour modifier l'ordre de tabulation
Raccourcis clavier pour sélectionner et naviguer dans un tableau
Raccourcis clavier pour naviguer dans l'aide de LiveCycle Designer


Raccourcis clavier usuels

Résultat

Action
Active ou désactive le mode Barre de menus.
Alt ou F10
Annule la tâche en cours ou ferme la boîte de dialogue ou le menu qui est ouvert.
Echap
Affiche le menu contextuel de l'élément sélectionné.
Maj + F10
Amène le curseur au début du texte de la ligne en cours
Accueil
Amène le curseur à la fin du texte de la ligne en cours
Fin
Amène le curseur à la fin du texte.
Ctrl+Fin
Amène le curseur au début du texte.
Ctrl+Origine
Ouvre la fenêtre d'aide de LiveCycle Designer.
F1
Effectue une sélection (même fonction que le bouton principal de la souris).
Barre d’espace
Ouvre l'assistant de création de formulaires, par défaut. Ouvre la boîte de dialogue Créer (si vous avez désactivé l'option Afficher à la création de nouveaux documents, sous Assistant de création de formulaires, dans le panneau Assistants et conseils de la boîte de dialogue Options).
Ctrl + N


Raccourcis clavier pour annuler ou rétablir une action

Résultat

Action
Rétablit la dernière action annulée.
Ctrl+Maj+Z ou Ctrl+Y
Annule la dernière action.
Ctrl+Z ou Alt+Retour arrière


Raccourcis pour supprimer du texte

Résultat

Action
Coupe le texte sélectionné et le copie dans le Presse-papiers.
Ctrl+X ou Maj+Suppr
Supprime un caractère vers la gauche.
Retour arrière
Supprime un caractère à droite ou supprime le texte sélectionné sans en placer de copie dans le Presse-papiers.
Supprimer
Supprime un mot vers la gauche.
Ctrl+Retour arrière
Supprime un mot vers la droite.
Ctrl+Suppr


Raccourcis clavier affectés à la sélection de texte

Résultat

Action
Conserve le mode édition.
F2
Sélectionne à partir du caractère où se trouve le curseur jusqu'au début du paragraphe.
Ctrl+Maj+Flèche Haut
Sélectionne à partir du caractère où se trouve le curseur jusqu'à la fin du paragraphe.
Ctrl+Maj+Flèche Bas
Sélectionne ou désélectionne à partir du caractère où se trouve le curseur jusqu'à la fin du mot.
Ctrl+Maj+Flèche Droite
Sélectionne ou désélectionne à partir du caractère où se trouve le curseur jusqu'au début de la ligne en cours.
Maj+Origine
Sélectionne ou désélectionne à partir du caractère où se trouve le curseur jusqu'au début du mot.
Ctrl+Maj+Flèche Gauche
Sélectionne ou désélectionne à partir du caractère où se trouve le curseur jusqu'à la fin de la ligne en cours.
Maj+Fin
Sélectionne ou désélectionne à partir du caractère où se trouve le curseur jusqu'à la même position sur la ligne suivante. Si le curseur est sur la dernière ligne, la sélection se termine à la fin de la ligne en cours.
Maj+Flèche Bas
Sélectionne ou désélectionne à partir du caractère où se trouve le curseur jusqu'à la même position sur la ligne précédente. Si le curseur est sur la première ligne, la sélection se termine au début de la ligne en cours.
Maj+Flèche Haut
Sélectionne ou désélectionne un caractère vers la gauche.
Maj+Flèche Gauche
Sélectionne ou désélectionne un caractère vers la droite.
Maj+Flèche Droite
Sélectionne ou désélectionne le contenu de l'écran à la même position sur l’écran suivant.
Maj+Page bas
Sélectionne ou désélectionne le contenu de l'écran à la même position sur l’écran précédent.
Maj+Page haut
Sélectionne ou désélectionne à partir du curseur jusqu'au début du texte de l'objet (caractère en haut et à gauche dans le texte de l'objet).
Ctrl+Maj+Origine
Sélectionne ou désélectionne à partir du curseur jusqu'à la fin du texte de l'objet (caractère en bas et à droite dans le texte de l'objet).
Ctrl+Maj+Fin
Sélectionne tout le texte d'un champ de texte ou de l'éditeur de script.
Sélectionne tous les objets d'une page.
Ctrl + A


Raccourcis pour copier et déplacer du texte

Résultat

Action
Copie le texte sélectionné dans le Presse-papiers.
Ctrl+C ou Ctrl+Inser
Coupe le texte sélectionné et le met dans le Presse-papiers.
Ctrl+X
Supprime un caractère à droite ou supprime le texte sélectionné sans en placer de copie dans le Presse-papiers.
Supprimer
Supprime un mot vers la droite.
Ctrl+Suppr
Colle le contenu du Presse-papiers au point d'insertion.
Ctrl+V ou Maj+Inser


Raccourcis pour formater le texte sélectionné

Résultat

Action
Applique l'attribut Gras (la police doit prendre en charge cet attribut).
Ctrl+B
Applique l'attribut Italique (la police doit prendre en charge cet attribut).
Ctrl+I
Applique l'attribut Soulignement.
Ctrl+U


Raccourcis clavier pour définir l'interligne

Résultat

Action
Applique l’interligne 1,5.
Ctrl+Maj+5
Applique l’interligne double.
Ctrl+Maj+2
Applique l’interligne simple.
Ctrl+Maj+1


Raccourcis clavier pour aligner les paragraphes

Résultat

Action
Centre un paragraphe.
Ctrl + E
Réduit un retrait négatif.
Ctrl+Maj+T
Augmente un retrait négatif.
Ctrl+T
Augmente un retrait à gauche dans le paragraphe.
Ctrl+M
Justifie un paragraphe.
Ctrl+J
Aligne un paragraphe à gauche.
Ctrl+L
Enlève le retrait à gauche du paragraphe.
Ctrl+Maj+M
Rétablit les paramètres de formatage des paragraphes par défaut antérieurs aux modifications.
Ctrl+Q
Aligne un paragraphe à droite.
Ctrl+R


Raccourcis clavier associés aux fenêtres

Résultat

Action
Affiche le menu de la palette active.
F6
Affiche l'onglet Aperçu PDF.
F5
Accède au document ouvert suivant.
Ctrl + F6
Accède à la fenêtre ou à la palette suivante.
Ctrl + Tab
Accède à l’onglet suivant de la palette active
Crtl+,
Accède au document ouvert précédent.
Ctrl +Maj + F6
Accède à la fenêtre ou à la palette précédente.
Ctrl+Maj+Tab
Accède à l’onglet précédent de la palette active
Crtl+.
Crée une nouvelle conception de formulaire.
Ctrl+N
Ouvre la boîte de dialogue Ouvrir fichier.
Ctrl+O
Ouvre la boîte de dialogue Impression.
Ctrl+P
Quitte LiveCycle Designer.
Alt+F4
Enregistre une copie du contenu de la conception de formulaire active dans un nouveau fichier.
Ctrl+Maj+S
Enregistre la conception de formulaire qui est actuellement la cible d'action.
Ctrl+S
Affiche ou masque la grille.
Ctrl+’
Active ou désactive la fonction d'accrochage à la grille.
Ctrl+Maj+’


Raccourcis clavier pour naviguer dans une conception de formulaire

Résultat

Action
Se rend à la première page.
Ctrl+Origine
Se rend à la dernière page.
Ctrl+Fin
Se rend à la page suivante.
Page suivante
Se rend à la page précédente.
Page précédente
Alterne entre la conception de formulaire et la première palette active.
F6
Accède à la page de propriétés suivante dans la palette.
Ctrl+.
Accède à la page de propriétés précédente dans la palette.
Ctrl+,
Effectue un zoom avant.
Ctrl+=
Effectue un zoom arrière.
Ctrl+-
Règle le zoom en fonction de la taille réelle.
Ctrl+1
Règle le zoom en fonction de la largeur de la page.
Ctrl+2
Règle le zoom en fonction de la page.
Ctrl+0


Raccourcis clavier associés aux menus

Résultat

Action
Active la barre de menus et passe au mode Menu.
F10 ou Alt
Active la barre de menus et ouvre le menu correspondant à la touche d'accès rapide.
Alt+(touches d'accès rapide du menu ou de la boîte de dialogue sélectionnée)
Affiche le menu de raccourcis (ou menu contextuel) de l'élément sélectionné.
Maj + F10
Affiche le menu contextuel de la fenêtre enfant active.
Alt+tiret (-)
Affiche le menu contextuel de la fenêtre active.
Alt+Barre d'espacement
Lorsque le mode Menu est sélectionné (Alt+), effectue la commande correspondante.
Touche d'accès rapide
Lorsque le mode Menu est sélectionné (Alt+), sélectionne la commande précédente ou accède au bas du menu si la commande sélectionnée était la première du menu.
Flèche Haut
Lorsque le mode Menu est sélectionné (Alt+), ouvre le menu, sélectionne la commande suivante ou accède au haut du menu si la commande sélectionnée était la dernière du menu.
Flèche Bas
Lorsque le mode Menu est sélectionné (Alt+), ouvre le menu suivant placé à gauche ou ferme un sous-menu.
Flèche Gauche
Lorsque le mode Menu est sélectionné (Alt+), ouvre le menu suivant placé à droite ou ouvre un sous-menu.
Flèche Droite


Raccourcis clavier associés à l'éditeur de script ou au panneau Source XML

Résultat

Action
Recherche l'occurrence suivante.
F3
Recherche l'occurrence précédente.
Maj+F3
Insère une syntaxe de référence abrégée pour un objet sur le formulaire.
Ctrl+clic sur l'objet à référencer (l'éditeur de script étant la cible d'action).
Ouvre la boîte de dialogue Rechercher.
Ctrl+F
Ouvre la liste des fonctions FormCalc dans le champ Source du script de l'éditeur de script.
F10
Ouvre la boîte de dialogue Atteindre la ligne.
Ctrl+G
Ouvre la boîte de dialogue Remplacer.
Ctrl+H
Affiche ou masque l’éditeur de script.
Ctrl+Maj+F5


Raccourcis clavier pour manipuler les objets

Résultat

Action
Aligne en bas.
Ctrl+Flèche Bas
Aligne le centre sur l'horizontale.
Alt+Ctrl+Flèche Droite
Aligne à gauche.
Ctrl+Flèche Gauche
Aligne à droite.
Ctrl+Flèche Droite
Aligne sur la grille.
Alt+Ctrl+Flèche Gauche
Aligne en haut.
Ctrl+Flèche Haut
Aligne le centre sur la verticale.
Alt+Ctrl+Flèche Haut
Duplique l'objet sélectionné.
Ctrl+D
Insérez un objet.
Alt+I, sélection d'un objet, puis activation de la touche Entrée
Conserve l'outil de dessin.
Ctrl+K
Déplace l'objet de 10 unités vers le bas.
Maj+Flèche Bas
Déplace l'objet d'une unité vers le bas.
Flèche Bas
Déplace l'objet de 10 unités vers la gauche.
Maj+Flèche Gauche
Déplace l'objet d'une unité vers la gauche.
Flèche Gauche
Déplace l'objet de 10 unités vers la droite.
Maj+Flèche Droite
Déplace l'objet d'une unité vers la droite.
Flèche Droite
Déplace l'objet de 10 unités vers le haut.
Maj+Flèche Haut
Déplace l'objet d'une unité vers le haut.
Flèche Haut
Renomme un objet par le biais de la palette Hiérarchie.
Ctrl+F2
Renomme l'objet sélectionné.
F2
Sélectionne un objet par le biais de la palette Hiérarchie.
Flèche Haut ou Bas
Sélectionne plusieurs objets adjacents dans la palette Hiérarchie.
Maj+Flèche Haut ou Maj+Flèche Bas
Sélectionne plusieurs objets non adjacents dans la palette Hiérarchie.
Ctrl+Flèche Haut ou Ctrl+Flèche Bas, puis Barre d'espacement
Affiche ou masque la palette Accessibilité.
Maj + F6
Affiche ou masque la palette Bordure.
Maj + F8
Affiche ou masque la palette Police.
Maj + F4
Affiche ou masque la palette Hiérarchie.
Maj+F11
Affiche ou masque la palette Disposition.
Maj+F9
Affiche ou masque la palette Bibliothèque.
Maj+F12
Affiche ou masque la palette Objet.
Maj+F7
Affiche ou masque la palette Paragraphe.
Maj + F5
Affiche ou masque l’éditeur de script.
Ctrl+Maj+F5


Raccourcis clavier pour modifier l'ordre de tabulation

pour définir l’ordre de tabulation à l’aide du clavier, vous devez utiliser un dispositif de pointage et le clavier.

Résultat

Action
Ne tient pas compte des modifications apportées pendant la session en cours et quitte le mode Ordre de tabulation.
Echap
Enregistre les modifications et quitte le mode Ordre de tabulation.
Entrée
Indique un nouveau numéro 1 dans l'ordre de tabulation.
Maj+ clic sur le champ


Raccourcis clavier pour sélectionner et naviguer dans un tableau

Résultat

Action
Etend la sélection au début de la rangée.
Maj+Origine
Etend la sélection au début du tableau.
Ctrl+Maj+Origine
Etend la sélection à la fin de la rangée.
Maj+Fin
Etend la sélection à la fin du tableau.
Ctrl+Maj+Fin
Etend la sélection.
Maj+Flèche gauche, Flèche droite, Flèche Haut ou Flèche Bas
Passe d'une cellule à une autre.
Flèche gauche, Flèche droite, Flèche Haut ou Flèche Bas
Sélectionne toutes les cellules d'une colonne.
Ctrl + Barre d’espacement
Sélectionne toutes les cellules d'une rangée.
Maj+Barre d'espacement
Sélectionne toutes les cellules du tableau.
Ctrl+Maj+Barre d’espacement
Sélectionne uniquement la cellule active, lorsque plusieurs cellules sont sélectionnées.
Maj+Retour arrière
Sélectionne la première cellule de la rangée.
Accueil
Sélectionne la première cellule du tableau.
Ctrl+Origine
Sélectionne la dernière cellule de la rangée.
Fin
Sélectionne la dernière cellule du tableau.
Ctrl+Fin
Active et désactive le mode Edition de texte dans la cellule active.
F2


Raccourcis clavier pour naviguer dans l'aide de LiveCycle Designer

Résultat

Action
Ferme le système de visualisation de l’aide.
Alt+F4
Affiche l'aide de LiveCycle Designer.
F1
Affiche le Sommaire.
Alt+C
Affiche le panneau Index.
Alt+N
Affiche le menu Options. Les commandes correspondant à l'ensemble des boutons de la barre d'outils du système de visualisation de l'aide sont disponibles dans le menu Options.
Alt+O
Affiche le panneau Rechercher.
Alt+S
Affiche la rubrique sélectionnée.
Entrée ou Alt+D
Ouvre et ferme un livre.
Touches Signe plus et Signe moins ou touches fléchées Gauche et Droite
Sélectionne un mot-clé dans la liste.
Touches fléchées Haut et Bas
Sélectionne une rubrique dans la liste des résultats de la recherche.
Alt+T, puis touches fléchées Haut et Bas
Sélectionne une rubrique.
Touches fléchées Bas et Haut
Lance une recherche.
Alt+L


Personnalisation des raccourcis clavier

Pour créer un jeu de raccourcis clavier personnalisé
Pour attribuer un raccourci clavier à une commande
Pour supprimer un raccourci clavier attribué à une commande
Pour vérifier les raccourcis clavier actuels d'une commande


Pour créer un jeu de raccourcis clavier personnalisé

Un jeu de raccourcis clavier personnalisé est une collection nommée de raccourcis. Vous pouvez créer un ou plusieurs jeux de raccourcis clavier personnalisés selon vos besoins ou les besoins de plusieurs utilisateurs.
Par exemple, si plusieurs personnes travaillent sur la même copie de LiveCycle Designer à différentes heures, chacune peut créer son propre jeu de raccourcis clavier. L'utilisation de plusieurs jeux facilite la gestion des différents raccourcis clavier sans modifier le jeu par défaut que les autres personnes connaissent mieux et préfèrent utiliser.
vous ne pouvez pas modifier, remplacer ou supprimer directement le jeu de raccourcis clavier par défaut. Après avoir modifié le jeu par défaut (ou un jeu personnalisé existant), LiveCycle Designer ajoute, par conséquent, une autre instance de ce jeu à la liste Jeu avec le mot (Modifié) annexé au nom du jeu. Vous pouvez ensuite renommer le jeu modifié.
1.
Choisissez Outils > Raccourcis clavier.
2.
Dans la liste Jeu, sélectionnez le jeu de raccourcis clavier à modifier. Utilisez le jeu (Par défaut) ou un jeu personnalisé existant.
3.
Cliquez sur Enregistrer sous.
4.
(Facultatif) Dans la zone Nom, entrez le nom du jeu. Si vous n'entrez pas un nouveau nom pour le jeu, le mot (Modifié) reste ajouté au nom de jeu existant.
5.
Cliquez sur OK.


Pour attribuer un raccourci clavier à une commande

Il est possible d'attribuer un raccourci clavier à une commande. Vous pouvez affecter un ou plusieurs raccourcis clavier à la même commande. Toutefois, pour éviter des doublons inutiles, il est recommandé d'attribuer un seul raccourci clavier à une commande.
Si le raccourci clavier que vous souhaitez utiliser est déjà attribué à une autre commande, LiveCycle Designer vous invite à le supprimer et à l'affecter à la commande que vous venez de sélectionner.
Après avoir affecté un raccourci clavier à une commande qui n'en avait pas encore, ou un raccourci clavier supplémentaire à une commande à laquelle un raccourci clavier par défaut était affecté, un astérisque (*) apparaît devant le nom de la commande affiché dans la liste Commande pour indiquer que les raccourcis clavier associés à la commande ont été modifiés.
lorsque vous attribuez un raccourci clavier à une commande, vous modifiez le jeu de raccourcis auquel appartient la commande, soit le jeu (Par défaut), soit un jeu personnalisé. LiveCycle Designer ajoute alors une autre instance du jeu de raccourcis clavier à la liste Jeu avec le mot (Modifié) annexé au nom du jeu pour indiquer qu'il a été modifié. Pour enregistrer les raccourcis clavier que vous affectez aux commandes, vous devez enregistrer le jeu de raccourcis clavier associé.
Si vous n'enregistrez pas les modifications que vous apportez à un jeu de raccourcis clavier, LiveCycle Designer les conserve jusqu'à ce que vous sélectionniez un autre jeu dans la liste Jeu. Lorsque vous sélectionnez un autre jeu de raccourcis clavier, LiveCycle Designer vous invite à enregistrer les modifications apportées au jeu (Par défaut) ou personnalisé.
1.
Choisissez Outils > Raccourcis clavier.
2.
Dans la liste Jeu, sélectionnez le jeu dans lequel vous souhaitez enregistrer le raccourci clavier.
3.
Dans la liste Zone du produit, sélectionnez (Toutes les commandes) ou le menu qui contient la commande à laquelle vous voulez accéder.
4.
Dans la liste Commandes, sélectionnez la commande de votre choix. Les raccourcis clavier existants sont répertoriés dans la liste Raccourcis actuels.
5.
(Facultatif) Dans la liste Raccourcis actuels, sélectionnez d'autres raccourcis attribués à la commande que vous voulez supprimer, puis cliquez sur Supprimer.
6.
Dans la zone Nouveau, saisissez le raccourci que vous voulez attribuer à la commande, puis cliquez sur Attribuer.
7.
Cliquez sur Enregistrer sous pour sauvegarder les modifications apportées au jeu de raccourcis clavier.
8.
(Facultatif) Dans la zone Nom, entrez le nom du nouveau jeu, si besoin est. Si vous n'entrez pas un nouveau nom pour le jeu, le mot (Modifié) reste ajouté au nom de jeu existant.
9.
Cliquez sur OK.


Pour supprimer un raccourci clavier attribué à une commande

Vous pouvez supprimer un raccourci clavier, y compris les raccourcis clavier par défaut, de n'importe quelle commande.
Par exemple, vous pouvez supprimer les raccourcis clavier que vous n'utilisez plus, ou un raccourci clavier afin de le remplacer par un autre raccourci de votre choix.
Si vous supprimez un raccourci clavier par défaut d'une commande, un astérisque (*) apparaît devant le nom de la commande figurant dans la liste Commande pour indiquer que le raccourci clavier associé à cette commande a été modifié.
lorsque vous supprimez un raccourci clavier d'une commande, vous modifiez le jeu de raccourcis auquel appartient la commande, soit le jeu (Par défaut), soit un jeu personnalisé. LiveCycle Designer ajoute une autre instance du jeu de raccourcis clavier à la liste Jeu avec le mot (Modifié) annexé au nom du jeu pour indiquer qu'il a été modifié. Pour enregistrer vos modifications, vous devez sauvegarder le jeu de raccourcis clavier associé.
Si vous n'enregistrez pas les modifications que vous apportez à un jeu de raccourcis clavier, LiveCycle Designer les conserve jusqu'à ce que vous sélectionniez un autre jeu dans la liste Jeu. Lorsque vous sélectionnez un autre jeu de raccourcis clavier, LiveCycle Designer vous invite à enregistrer les modifications apportées au jeu (Par défaut) ou personnalisé.
1.
Choisissez Outils > Raccourcis clavier.
2.
Dans la liste Jeu, sélectionnez le jeu qui contient le raccourci clavier à supprimer.
3.
Dans la liste Zone du produit, sélectionnez (Toutes les commandes) ou le menu qui contient la commande à laquelle vous voulez accéder.
4.
Dans la liste Commandes, sélectionnez la commande de votre choix. Les raccourcis clavier existants sont répertoriés dans la liste Raccourcis actuels.
5.
Dans la liste Raccourcis actuels, sélectionnez le raccourci clavier à supprimer, puis cliquez sur Supprimer.
6.
(Facultatif) Pour renommer le jeu de raccourcis clavier, cliquez sur Enregistrer sous, puis dans la zone Nom, tapez le nom du jeu qui convient.
7.
Cliquez sur OK.


Pour vérifier les raccourcis clavier actuels d'une commande

1.
Choisissez Outils > Raccourcis clavier.
2.
Dans la liste Jeu, sélectionnez le jeu de raccourcis clavier qui contient les raccourcis clavier à vérifier.
3.
Dans la liste Zone du produit, sélectionnez (Toutes les commandes) ou le menu qui contient la commande à laquelle vous voulez accéder.
4.
Dans la liste Commandes, sélectionnez la commande de votre choix. Les raccourcis clavier attribués à la commande sont répertoriés dans la liste Raccourcis actuels.


Script

Script

Scripts utilisant LiveCycle Designer
Référence sur les objets de script
Guide de référence FormCalc


Scripts utilisant LiveCycle Designer

A propos des calculs et des scripts
Objets prenant en charge les calculs et les scripts
Configuration de l’espace de travail LiveCycle Designer pour les scripts
Création de calculs et de scripts
Evénements
Langages de script
Référence aux objets dans les calculs et les scripts
Variables
Débogage des calculs et des scripts
Utilisation d'une application hôte
Utilisation du modèle d'événement
Création et réutilisation des fonctions JavaScript
Conversion des scripts Acrobat en scripts LiveCycle Designer
Exemples de tâches de script courantes


A propos des calculs et des scripts

Dans le processus de conception des formulaires, un développeur de formulaires peut utiliser des fonctions de calcul et de script afin d'apporter à l'utilisateur un confort d'utilisation amélioré. Vous pouvez ajouter des calculs et des scripts à la plupart des champs et objets. Par exemple, vous pouvez créer des calculs simples pour mettre à jour dynamiquement des valeurs sur un formulaire interactif en réponse à une entrée d'utilisateur. A un niveau plus avancé, vous pourriez créer vos propres fonctions personnalisées répondant au mieux à vos besoins de traitement des formulaires.
LiveCycle Designer reconnaît deux langages de script, chacun d'eux étant défini selon les besoins d'un type particulier de développeur de formulaire. FormCalc est un langage immédiat, d'utilisation aisée, adapté aux fonctionnalités communes de tableaux. Il comprend diverses fonctions intégrées conçues pour réduire le temps nécessaire au développement de votre modèle de formulaire. JavaScript, langage de script puissant, offre une flexibilité optimale pour la création de scripts et vous permet de bénéficier des connaissances actuelles du langage.
Soyez conscient que l'ajout de scripts à un formulaire est une opération facultative. Vous pouvez choisir d'utiliser des scripts pour améliorer le confort d'utilisation, mais LiveCycle Designer vous propose de nombreuses fonctions, parmi les plus puissantes, pour créer un formulaire sans avoir à recourir aux scripts. Cependant, les scripts vous permettent de manipuler et de commander quasiment tous les aspects de votre modèle de formulaire.
Voir aussi
A propos de l'utilisation de FormCalc
A propos de l’utilisation de JavaScript
A propos de la référence sur les objets de script


Objets prenant en charge les calculs et les scripts

Vous pouvez créer des calculs et des scripts ayant un impact sur tous les objets de la conception de formulaire. Cependant, vous pouvez seulement ajouter des calculs et des scripts aux événements de formulaire d'un objet particulier. Les objets de conception de formulaire ne reconnaissant pas tous les événements, vous devez, pour les modifier, ajouter la fonction de calcul ou de script à un événement reconnu d'un autre objet de conception de formulaire. Le tableau suivant donne un rapide aperçu des scripts reconnus pour les objets disponibles dans la catégorie Standard de la palette Bibliothèque.

Objets prenant en charge les calculs et les scripts

Objets ne prenant pas en charge les calculs et les scripts
Bouton
Zone de contenu
Bouton Envoyer par messagerie
Bouton Envoyer via HTTP
Bouton Imprimer
Bouton radio
Bouton Réinitialiser
Case à cocher
Droite
Champ de signature du document
Tableau (sections uniquement)
Champ de texte
Champ décimal
Image
Champ d'image
Champ du mot de passe
Champ numérique
Code à barres de formulaires pour support papier
Codes à barres
Cercle
Date/Heure
Rectangle
Sous-formulaire
Tableau (y compris les rangées de contenu, les rangées d'en-tête et les rangées de pied de page)
Zone de liste
Zone de liste déroulante
Texte
Voir aussi
A propos de la référence sur les objets de script


Configuration de l’espace de travail LiveCycle Designer pour les scripts

A propos de l’éditeur de script
Pour afficher l’éditeur de script
Pour passer de la vue uniligne à la vue multiligne
Pour définir le langage de script par défaut
Pour définir l'application de traitement par défaut
Pour afficher des caractères en arabe, hébreu, thaï et vietnamien
Utilisation de l'espace de travail pour le débogage des calculs et des scripts


A propos de l’éditeur de script

Dans LiveCycle Designer, l'éditeur de script est l'endroit où vous créez, modifiez et visualisez les calculs et les scripts d'un formulaire donné.
L'éditeur de script proprement dit possède à la fois une vue uniligne et une vue multiligne, entre lesquelles vous pouvez basculer librement en fonction de vos besoins. La vue uniligne permet d'augmenter l'espace réservé à l'affichage de l'éditeur de disposition et des autres palettes, tandis que la vue multiligne permet d'augmenter l'espace réservé à la rédaction des scripts.
Afficher
Répertorie tous les événements de conception de formulaire qui permettent à l'utilisateur de rédiger des scripts. Tous les événements qui ne s'appliquent pas à un objet en particulier apparaissent en grisé. Les événements qui contiennent un calcul ou un script sont affichés avec un * (astérisque) à côté du nom de l'événement.
Afficher les événements pour les objets enfant
Affiche l'événement actuellement sélectionné dans la liste Afficher pour l'objet actif et tous ses objets enfant.
Fonctions
Affiche une liste des fonctions intégrées disponibles.
Pour insérer une fonction sur votre champ d'édition de script, choisissez une fonction dans la liste et appuyez sur Entrée.
Insérer les changements dans la source du script
Enregistre votre script pour votre conception de formulaire. Cliquez sur ce bouton dès que vous avez terminé d'écrire votre script. Si vous n'enregistrez pas votre script de cette manière, il risque de ne pas s'exécuter correctement ou d'être perdu.
Annuler les changements à la source du script
Annule toutes les modifications que vous avez apportées à un calcul ou à un script donné. Ce bouton s'applique uniquement à la session d'édition en cours et n'agit pas comme une fonction d'annulation multiple.
Langage
Spécifie le langage de script à utiliser pour le calcul ou le script actuel. Deux options sont disponibles :
      •
      FormCalc est un langage machine Adobe natif, idéal pour des scripts courts.
      •
      JavaScript est un langage de script puissant et flexible, idéal pour les scripts plus complexes.
Exécuter sur
Indique l'emplacement où le calcul ou le script doit être exécuté. Trois options sont disponibles :
    • Client
Les calculs et scripts sont exécutés pendant que l'application client (par exemple, Acrobat, Adobe Reader ou un navigateur Web) traite le formulaire.
    • Serveur
      •
      Les calculs et scripts sont exécutés pendant que l'application serveur (par exemple, LiveCycle Forms) traite le formulaire.
    • Client et serveur
      •
      Les calculs et scripts sont exécutés pendant que l'application serveur (par exemple, LiveCycle Forms) traite le formulaire, sauf dans les cas où l'application client HTML prend en charge les scripts côté client.


Précédent Suivant

Script > Scripts utilisant LiveCycle Designer > Configuration de l’espace de travail LiveCycle Designer pour les scripts > Pour afficher l’éditeur de script

Pour afficher l’éditeur de script

      *
      Choisissez Fenêtre > Editeur de script.


Pour passer de la vue uniligne à la vue multiligne

      *
      Faites glisser la barre de la palette Editeur de script jusqu'à la taille de palette requise.
la vue multiligne ajoute les options Tous les événements et Evénements avec scripts à la liste Afficher. L'option Tous les événements affiche tous les événements d'un objet de conception de formulaire donné, même si l'événement ne contient ni calculs ni scripts. L'option Evénements avec scripts affiche uniquement les événements d'un objet particulier qui contient des calculs ou des scripts.


Pour définir le langage de script par défaut

1.
Choisissez Fichier > Propriétés du formulaire.
2.
Cliquez sur l'onglet Valeurs par défaut.
3.
Choisissez votre langage de script par défaut dans la liste Langage par défaut.


Pour définir l'application de traitement par défaut

1.
Choisissez Fichier > Propriétés du formulaire.
2.
Cliquez sur l'onglet Valeurs par défaut.
3.
Choisissez votre application de traitement par défaut dans la liste Exécution par défaut sur le.
Voir aussi
Aperçu de la création de calculs et de scripts
Détermination de l'emplacement d'exécution de votre calcul ou script
A propos des événements


Pour afficher des caractères en arabe, hébreu, thaï et vietnamien

Pour afficher les caractères arabes, hébreux, thaïs et vietnamiens dans le panneau Source XML/Editeur de script, vous devez modifier les paramètres de police utilisés par LiveCycle Designer dans ces panneaux. Sinon, LiveCycle Designer affiche des rectangles à l'emplacement des caractères concernés.
LiveCycle Forms 7.1 ne prend pas en charge les conceptions de formulaire contenant des polices relatives à l'arabe, l'hébreu, le thaï et le vietnamien.
1.
Choisissez Outils > Options, puis Espace de travail dans la liste de gauche.
2.
Sélectionnez l'une des options suivantes :
      •
      Formatage de la syntaxe FormCalc pour définir la police dans l'éditeur de script lors de l'utilisation de FormCalc
      •
      Formatage de la syntaxe JavaScript pour définir la police dans l'éditeur de script lors de l'utilisation de JavaScript
      •
      Formatage de la syntaxe de la source XML pour définir la police dans le panneau Source XML
3.
Dans la zone Options de polices, sélectionnez une police prenant en charge votre langue. Par exemple, Adobe Arabic prend en charge l'arabe, Adobe Hebrew prend en charge l'hébreu, Adobe Thai prend en charge le thaï et Myriad Pro et Minion Pro prennent en charge le vietnamien. Si la langue choisie ne se trouve pas sur votre système, vous pouvez la rechercher sur Internet.
4.
Cliquez sur OK.
5.
Cliquez sur OK pour refermer la boîte de dialogue.


Précédent Suivant

Script > Scripts utilisant LiveCycle Designer > Configuration de l’espace de travail LiveCycle Designer pour les scripts > Utilisation de l'espace de travail pour le débogage des calculs et des scripts

Utilisation de l'espace de travail pour le débogage des calculs et des scripts

L'espace de travail LiveCycle Designer offre plusieurs solutions pour déboguer les calculs et les scripts.
Le tableau ci-dessous indique l'emplacement et le rôle des informations de débogage proposées dans les palettes et panneaux de LiveCycle Designer.

Emplacement dans l'espace de travail

Fonction
Panneau Avertissements de la palette Rapport
Le panneau Avertissement est l'endroit qu'un développeur de formulaire doit vérifier en premier lorsqu'il rencontre des erreurs de script ou toute erreur inattendue du système. C'est dans ce panneau que sont consignées les actions signalées par LiveCycle Designer. Il est mis à jour lorsque vous affichez un aperçu de la conception de formulaire dans le panneau Aperçu PDF.
Panneau Liaisons de la palette Rapport
Si vous prévoyez des champs dans votre conception de formulaire qui sont liés à une source de données, le panneau Liaisons peut vous aider en affichant des listes de champs en fonction de la définition des liaisons de données que vous avez effectuée. Par exemple, vous pouvez afficher la liste des champs avec liaisons de données globales uniquement ou seulement ceux pour lesquels aucune liaison de données n'est définie. Cette fonction est particulièrement utile dans les formulaires comportant un grand nombre de liaisons de données.
Palette Hiérarchie
Vous pouvez vous servir de la palette Hiérarchie pour déterminer l'emplacement d'un objet de formulaire pour une syntaxe de référence. La palette Hiérarchie donne une représentation graphique de la structure de votre formulaire. Elle présente le contenu des panneaux Gabarit et Vue de conception.
La palette Hiérarchie affiche également les objets référencés sous le noeud Objets référencés. Un objet est référencé lorsqu'il est ajouté à un formulaire uniquement en cas de besoin. Les sous-formulaires de début et fin de débordement sont des exemples d'objets référencés. Dès que des données sont enchaînées sur plusieurs pages ou zones de contenu, des sous-formulaire de début et de fin de débordement sont insérés dans le formulaire aux endroits appropriés.
Panneau Liaison de la palette Objet
Chaque objet LiveCycle Designer pouvant être lié à une source de données possède un onglet Liaison dans la palette Objet. Si vous liez un objet de votre conception de formulaire à un noeud de données particulier à partir de votre connexion de données, la liste Liaison par défaut (Ouvrir, Enregistrer, Envoyer) affiche une syntaxe de référence FormCalc valide pour l’accès à ce noeud de données. Vous pouvez utiliser la syntaxe de référence FormCalc dans d'autres calculs ou scripts lors des tests.
Panneau Source XML
Le panneau Source XML contient le code XML de la conception de formulaire. Le code source XML définit tous les aspects du formulaire. Vous pouvez vous servir du panneau Source XML pour vérifier la structure du modèle d'objet de formulaire XML pour une conception de formulaire et pour comprendre la relation entre les objets et les propriétés. Dans la source XML, les noms d'éléments XML sont équivalents aux noms d'objets dans le modèle d'objet de formulaire XML et les attributs sont équivalents aux propriétés.
Lorsque vous sélectionnez un objet dans la palette Hiérarchie, puis cliquez sur l'onglet Source XML, la première ligne de l'élément correspondant est mise en surbrillance. Le nom de l'objet dans LiveCycle Designer, tel qu'il est indiqué dans la palette Hiérarchie, devient la valeur de l'attribut name dans la source XML.
Vous pouvez configurer les options dans la boîte de dialogue Outils > Options afin de visualiser la source dans le panneau Source XML de manière à afficher ou masquer les numéros de ligne et à définir la couleur de la syntaxe, par exemple.
évitez de modifier directement le code source XML.
Il peut être utile de modifier les options par défaut de l'éditeur de script afin de faciliter le débogage de vos calculs et scripts. Ces options figurent dans le panneau Espace de travail de la boîte de dialogue Options. Pour y accéder, choisissez Outils > Options, puis sélectionnez Espace de travail dans la liste à gauche.
Voir aussi
Test et débogage des calculs et des scripts
A propos du débogage des calculs et des scripts
A propos de l'espace de travail
Palette Hiérarchie
Palette Rapport
Palette Objet


Création de calculs et de scripts

Aperçu de la création de calculs et de scripts
Conventions de dénomination des objets et des variables dans une conception de formulaire
Choix du langage de script
Pour créer un calcul ou un script
Pour rechercher du texte ou d'autres éléments
Pour remplacer du texte ou d'autres éléments
Pour utiliser des options de fin d'instructions pour créer des calculs et des scripts
Pour insérer automatiquement la syntaxe de référence d'objet
Détermination du moment de l'exécution de votre calcul ou script
Pour afficher les événements de script et les scripts
Détermination de l'emplacement d'exécution de votre calcul ou script
Test et débogage des calculs et des scripts


Aperçu de la création de calculs et de scripts

LiveCycle Designer offre une grande variété de fonctions de calcul et de script prévues pour réaliser une multitude d'opérations. Vous pouvez, par exemple, créer de simples scripts pour changer l'aspect d'un objet de formulaire (couleur de la bordure de l'objet ou taille de la police, par exemple) en réponse aux interactions de l'utilisateur final au moment de l'exécution. Il peut être intéressant d'élaborer des formulaires plus complexes pour tirer parti des fonctions de script dans le but d'établir une connexion à la source de données et de manipuler les données au moment de l'exécution.
La création de calculs et de scripts dans LiveCycle Designer fait appel à une procédure générale que vous devez exécuter chaque fois que vous attachez un calcul ou un script à un objet. Bien que toutes les étapes de la procédure ne soient pas nécessaires lors de la création d'un calcul ou d'un script, il est conseillé de suivre le déroulement normal de la procédure pour éviter de générer des erreurs et d'obtenir des résultats inattendus.
En règle générale, chaque fois que vous créez un calcul ou un script, voici les différentes tâches qu'il convient d'effectuer :
      •
      Sélectionnez l'objet auquel vous voulez attacher un calcul ou un script. Bien que vous puissiez créez des calculs ou des scripts qui manipulent la plupart des objets de la conception de formulaire, seuls les objets de champ prennent en charge les événements de formulaire. Cela signifie que si vous souhaitez manipuler un objet comportant un calcul ou un script, vous devez placer le calcul ou le script dans un objet de champ de la conception de formulaire.
      •
      Vous devez attribuer chaque calcul ou script que vous créez dans LiveCycle Designer à un événement de formulaire spécifique. Le calcul ou le script associé à l'événement est exécuté chaque fois que l'événement de formulaire se produit. Les calculs ou les scripts associés à l'événement click d'un bouton sont, par exemple, exécutés chaque fois que la personne remplissant le formulaire clique sur le bouton.
      •
      Sélectionnez le langage de script à utiliser. En fonction du formulaire que vous créez, vous pouvez opter pour le langage FormCalc, le langage JavaScript ou une combinaison des deux.
      •
      Choisissez l'emplacement où le calcul ou le script doit être exécuté, soit au niveau de l'application client (Acrobat ou Adobe Reader, par exemple), soit au niveau du serveur utilisant LiveCycle Forms.
      •
      Testez le calcul ou le script à partir du panneau Aperçu PDF ou de votre environnement de production.
Voir aussi
Pour créer un calcul ou un script
Pour rechercher du texte ou d'autres éléments
Pour remplacer du texte ou d'autres éléments
Pour utiliser des options de fin d'instructions pour créer des calculs et des scripts
Détermination du moment de l'exécution de votre calcul ou script
Pour afficher les événements de script et les scripts
Détermination de l'emplacement d'exécution de votre calcul ou script
Test et débogage des calculs et des scripts
Objets prenant en charge les calculs et les scripts


Conventions de dénomination des objets et des variables dans une conception de formulaire

Lorsque vous définissez des calculs ou des scripts pour améliorer votre formulaire, prêtez une attention particulière aux noms que vous donnez aux objets et aux variables dans une conception de formulaire. Evitez d'utiliser des noms de propriétés, de méthodes et d'objets de modèle d'objet de formulaire XML pour désigner les objets et les variables dans la conception de formulaire. Les calculs et les scripts risqueraient sinon de ne pas s'exécuter correctement.
Pour plus d'informations sur les objets de modèle d'objet de formulaire XML et leurs propriétés, méthode et noms d'objet, voir Référence sur les objets de script.
Voir aussi
Attribution de noms aux variables
Aperçu de la création de calculs et de scripts
Objets prenant en charge les calculs et les scripts


Choix du langage de script

LiveCycle Designer prend en charge les scripts créés avec FormCalc et JavaScript. Avant d'écrire un script dans un formulaire, vous devez connaître les avantages que présentent chacun des langages de script.
FormCalc est un langage de calcul qui inclut une grande variété de fonctions intégrées destinées à simplifier les fonctionnalités de formulaire les plus courantes. Vous pouvez, par exemple, profiter des fonctions financières de FormCalc pour évaluer le montant du versement d'un prêt, compte tenu du montant du prêt, du taux d'intérêt et du nombre de versements.
JavaScript est un langage de script plus puissant et varié. Outre une plus grande flexibilité, il vous permet de mettre à profit vos connaissances en matière de script. Vous pouvez, par exemple, réutiliser les fonctions JavaScript existantes dans LiveCycle Designer pour limiter le nombre de lignes de code à écrire.
LiveCycle Designer prend en charge les versions JavaScript 1.6 et antérieures.
Le tableau suivant souligne quelques différences essentielles entre FormCalc et JavaScript.

FormCalc

JavaScript
Langage de calcul natif Adobe valable dans LiveCycle Designer et LiveCycle Forms
Langage de script standard utilisé dans de nombreuses applications logicielles courantes
Scripts plus courts (généralement une ligne seulement)
Possibilité de scripts plus longs si nécessaire avec la possibilité d'utiliser des boucles
Contient une variété de fonctions intégrées utiles qui réduisent le nombre de scripts requis pour accomplir les tâches courantes sur les conceptions de formulaire
Fournit l'accès aux fonctions de modèle d'objet Acrobat et aux fonctions JavaScript d'Acrobat
Reconnaît les formats de date, d'heure, de devise et de nombre
Débogage possible en utilisant JavaScript Debugger dans Acrobat
Les fonctions URL intégrées Post, Put et Get permettent des interactions Web.
Possibilité de créer des fonctions adaptées à vos besoins
Compatible sur toutes les plates-formes LiveCycle Designer et LiveCycle Forms prises en charge
Compatible sur toutes les plates-formes LiveCycle Designer et LiveCycle Forms prises en charge
Voir aussi
A propos de l'utilisation de FormCalc
A propos de l’utilisation de JavaScript
Différences entre les fonctions FormCalc et JavaScript
Création et réutilisation des fonctions JavaScript


Pour créer un calcul ou un script

1.
Sélectionnez un objet de la conception de formulaire qui prend en charge les événements.
2.
Dans la liste Afficher de l'éditeur de script, choisissez un des événements qui s'applique à l'objet. L'événement que vous sélectionnez détermine le moment d'exécution du script. Si vous écrivez un calcul ou un script ayant un impact sur un objet qui ne reconnaît pas les événements de formulaire, vous devez ajouter votre calcul ou script à un objet de conception de formulaire qui prend en charge les événements.
3.
Choisissez le langage de script dans la liste Langage.
4.
Dans la liste Exécuter sur, choisissez l'emplacement où le script doit être exécuté.
Vous pouvez choisir d'exécuter des calculs ou des scripts sur l'application client (par exemple, Acrobat ou un navigateur Web) ou l'application serveur (par exemple, LiveCycle Forms). Dans le cas de l'application client, le traitement des calculs et des scripts s'effectue après la génération du formulaire. Dans le cas de l'application serveur, les calculs et des scripts sont exécutés au moment de la génération du formulaire.
si vous choisissez Client et serveur dans la liste Exécuter sur, le script est exécuté soit sur l'application client, soit sur l'application serveur, selon l'application qui traite le formulaire.
5.
Dans le champ Source du script, insérez le calcul FormCalc ou script JavaScript. Vous pouvez tirer profit de la fonctionnalité de fin d'instructions de LiveCycle Designer pour créer les syntaxes de référence dans le cadre de calculs ou de scripts.
6.
Cliquez sur Insérer les changements dans la source du script [image] pour ajouter le script à votre formulaire.
7.
Une fois que vous avez terminé votre conception de formulaire, testez et déboguez vos calculs et scripts avant de les mettre en production.
Voir aussi
A propos de l'utilisation de FormCalc
A propos de l’utilisation de JavaScript
A propos des événements
Pour utiliser des options de fin d'instructions pour créer des calculs et des scripts
Détermination du moment de l'exécution de votre calcul ou script
Pour afficher les événements de script et les scripts
Détermination de l'emplacement d'exécution de votre calcul ou script
Test et débogage des calculs et des scripts


Pour rechercher du texte ou d'autres éléments

Vous pouvez rechercher rapidement dans le panneau Source XML ou dans l'éditeur de script toutes les occurrences d'une expression ou d'un mot précis.
1.
Dans le panneau Source XML ou dans l'éditeur de script, choisissez Edition > Rechercher ou cliquez avec le bouton droit pour afficher le menu contextuel.
2.
Dans la zone Rechercher, entrez le texte à rechercher.
3.
Sélectionnez les autres options de votre choix.
4.
Cliquez sur Rechercher suivant.
Pour annuler une recherche en cours, appuyez sur Echap ou cliquez sur le bouton Annuler.
Voir aussi
Aperçu de la création de calculs et de scripts
Pour créer un calcul ou un script
Pour remplacer du texte ou d'autres éléments
Pour utiliser des options de fin d'instructions pour créer des calculs et des scripts
Détermination du moment de l'exécution de votre calcul ou script
Pour afficher les événements de script et les scripts
Détermination de l'emplacement d'exécution de votre calcul ou script
Test et débogage des calculs et des scripts


Pour remplacer du texte ou d'autres éléments

1.
Vous pouvez remplacer automatiquement du texte. Par exemple, vous pouvez remplacer Cie par Compagnie.
2.
Dans le panneau Source XML de l'éditeur de script, choisissez Edition > Remplacer.
3.
Dans la zone Rechercher, entrez le texte à rechercher.
4.
Dans la zone Remplacer par, entrez le texte de substitution.
5.
Sélectionnez les autres options de votre choix.
6.
Cliquez sur Suivant, Remplacer ou Remplacer tout.
Pour annuler une recherche en cours, appuyez sur Echap ou cliquez sur le bouton Annuler.
il est recommandé de ne pas modifier le code de la source XML directement dans le panneau Source XML, à moins que vous ne soyez familiarisé avec l'architecture de formulaires XML Adobe. Pour obtenir de plus amples informations sur l'architecture de formulaires XML, voir www.adobe.com/devnet/livecycle/.
Voir aussi
Aperçu de la création de calculs et de scripts
Pour rechercher du texte ou d'autres éléments


Pour utiliser des options de fin d'instructions pour créer des calculs et des scripts

La fonctionnalité de fin d’instructions de l’éditeur de script permet de créer des calculs et des scripts de manière interactive.
Durant la création d’un calcul ou d’un script, lorsque vous saisissez un point (« . ») immédiatement après un objet de formulaire ou un nom de propriété, la fonctionnalité de fin d'instructions affiche une liste des méthodes et des propriétés disponibles. Si la liste de fin d’instructions n'apparaît pas, assurez-vous d'avoir saisi correctement le nom de la propriété ou de l'objet.
1.
Tapez le nom d'un objet de conception de formulaire, d'une propriété ou d'un raccourci FormCalc valide suivi d'un point (« . »).
2.
Choisissez la méthode ou la propriété que vous souhaitez appliquer à l'objet de modèle de formulaire et poursuivez l'écriture du script. Pour fermer la liste de fin d'instructions sans sélectionner de fonction, appuyez sur la touche Echap.
La liste des propriétés disponibles du modèle d'objet de formulaire XML varie en fonction de l'objet de modèle de formulaire ou de la propriété qui apparaît avant le point (« . »).
Voir aussi
A propos de la référence sur les objets de script
Référence aux propriétés et aux valeurs d'objet


Pour insérer automatiquement la syntaxe de référence d'objet

Au lieu d'utiliser la liste de fin d’instructions pour créer une syntaxe de référence d'objet, vous pouvez tirer parti de la fonction d'insertion de syntaxe de référence d'objet pour intégrer automatiquement la syntaxe de référence à votre calcul ou à votre script. Cette fonction insère la syntaxe de référence abrégée pour l'objet sélectionné dans le champ Source du script de l'éditeur de script. Vous perdrez ainsi beaucoup moins de temps lors de la création des calculs et des scripts et aurez l'assurance que la syntaxe est correcte.
1.
Assurez-vous que le champ Source du script de l'éditeur de script est activé.
2.
Dans votre formulaire, cliquez sur l'objet à référencer tout en maintenant la touche Ctrl enfoncée. Le curseur change de forme ( [image]) pour vous aider lors de la sélection d'un objet.
Voir aussi
A propos des références aux objets dans les calculs et les scripts
A propos de l’éditeur de script


Détermination du moment de l'exécution de votre calcul ou script

Chaque fois que vous créez des calculs et des scripts, vous êtes tenu d'associer chaque entrée à un événement de formulaire spécifique. Chaque événement correspond à un changement dans l'état du formulaire qui se produit à un moment précis. Ce changement peut survenir lors de la génération du formulaire sur le serveur par LiveCycle Forms, sur le client par Acrobat ou par Adobe Reader lorsque l'utilisateur final remplit le formulaire. Lorsque le changement d'état se produit, tous les calculs ou scripts associés à l'événement sont traités automatiquement.
L'événement utilisé lors de la création d'un calcul ou d'un script détermine, dans une certaine mesure, les éléments à prendre en compte dans le calcul ou le script. La quantité et le type d'informations disponibles dans un formulaire peut varier en fonction du moment choisi pour le déclenchement de l'événement. Ainsi, un calcul ou un script ayant pour fonction de récupérer une valeur peut donner des résultats différents selon qu'il est exécuté avant ou après les actions effectuées par la personne remplissant le formulaire.
Selon le type de formulaire que vous créez, il est possible que certains événements n'aient jamais lieu. Si vous concevez, par exemple, un formulaire avec une disposition fixe et sans objet interactif, les événements interactifs associés aux actions de la personne chargée de remplir le formulaire risquent de ne jamais se produire. Les scripts correspondant à ces événements ne seront donc pas exécutés.
Bien que LiveCycle Designer prenne en charge une grande variété d'événements de formulaire, il est possible de réaliser de très nombreuses tâches de calcul et de script en ayant recours simplement à quelques événements se produisant lors de changements majeurs dans l'état du formulaire, comme dans le cas des événements suivants :
    • change
      •
      Se produit lorsque la personne remplissant le formulaire modifie la valeur d'un champ
    • click
      •
      Se produit lorsque la personne remplissant le formulaire clique sur un champ ou un bouton
    • docReady
      •
      Se produit juste après l'ouverture du formulaire dans Acrobat ou Adobe Reader et juste avant que la personne remplissant le formulaire commence à interagir avec les objets du formulaire
    • enter
      •
      Se produit lorsque la personne remplissant le formulaire active un autre champ ou bouton particulier
    • exit
      •
      Se produit lorsque la personne remplissant le formulaire active un autre objet à la place d'un champ ou bouton particulier
Voir aussi
Pour afficher les événements de script et les scripts
A propos de l’éditeur de script
A propos des événements
Détermination de l'emplacement d'exécution de votre calcul ou script


Pour afficher les événements de script et les scripts

L'éditeur de script offre différents moyens de visualiser des événements de script pour les objets de votre formulaire, selon le type d'objet que vous sélectionnez et le nombre d'événements que vous avez l'intention d'afficher.
Avant de commencer, assurez-vous que les paramètres suivants sont appliqués :
      •
      Pour afficher l’éditeur de script, choisissez Fenêtre > Editeur de script.
      •
      Si la fenêtre de l'éditeur de script n'est pas assez grande pour afficher au moins deux lignes de script à la fois, agrandissez-la en faisant glisser vers le bas sa bordure inférieure.
Pour afficher un événement de script pour un simple objet dans l'éditeur de script
1.
Sélectionnez un objet dans votre formulaire.
2.
Dans la zone Afficher, sélectionnez un événement de script valide.
L'événement apparaît dans le champ de modification du script de l'éditeur de script. Certains événements s'appliquent uniquement à des objets spécifiques. Lorsque vous sélectionnez un événement de script, le champ de modification du script de l'éditeur de script présente seulement les instances valides de l'événement. Si vous sélectionnez, par exemple, un sous-formulaire contenant une liste déroulante et choisissez l'événement preOpen, l'éditeur de script affiche une seule entrée représentant la liste déroulante. En effet, l'événement preOpen s'applique exclusivement aux listes déroulantes. A l'inverse, la sélection de l'événement enter a pour effet d'afficher deux entrées, une pour la liste déroulante et une pour le sous-formulaire.
pour identifier les événements contenant des scripts, la zone Afficher insère un astérisque (*) à la suite du nom de l'événement. Si un événement contient un script, dès que vous le sélectionnez dans la zone Afficher, la source est indiquée dans le champ de modification du script de l'éditeur de script.
Pour afficher un événement de script pour un objet conteneur et ses enfants dans l'éditeur de script
1.
S'il n'est pas déjà en mode multiligne, agrandissez l’éditeur de script afin d'afficher plusieurs lignes de script et assurez-vous que l'option Afficher les événements pour les objets enfant [image] est activée.
2.
Sélectionnez un objet conteneur, tel qu'un sous-formulaire.
3.
Dans la zone Afficher, sélectionnez un événement de script valide.
Les événements sont présentés dans le champ de modification du script de l'éditeur de script, séparés par la syntaxe de référence pour chaque événement. Certains événements s'appliquent uniquement à des types d'objet spécifiques. Lorsque vous sélectionnez un événement de script, le champ de modification du script de l'éditeur de script présente seulement les instances valides de l'événement. Si vous sélectionnez, par exemple, un sous-formulaire contenant une liste déroulante et choisissez l'événement preOpen, l'éditeur de script affiche une seule entrée représentant la liste déroulante. En effet, l'événement preOpen s'applique exclusivement aux listes déroulantes. A l'inverse, la sélection de l'événement enter a pour effet d'afficher deux entrées, une pour la liste déroulante et une pour le sous-formulaire.
pour identifier les événements contenant des scripts, la zone Afficher insère un astérisque (*) à la suite du nom de l'événement. Si un événement contient un script, dès que vous le sélectionnez dans la zone Afficher, la source est indiquée dans le champ de modification du script de l'éditeur de script.
Pour afficher tous les événements de script pour un simple objet dans l'éditeur de script
1.
Sélectionnez un objet dans votre formulaire.
2.
Dans la liste Afficher, sélectionnez Tous les événements.
Les événements sont présentés dans le champ de modification du script de l'éditeur de script, séparés par la syntaxe de référence pour chaque événement.
Pour afficher tous les événements de script pour un objet conteneur et ses enfants dans l'éditeur de script
1.
S'il n'est pas déjà en mode multiligne, agrandissez l’éditeur de script afin d'afficher plusieurs lignes de script et assurez-vous que l'option Afficher les événements pour les objets enfant [image] est activée.
2.
Sélectionnez un objet conteneur, tel qu'un sous-formulaire.
3.
Dans la liste Afficher, sélectionnez Tous les événements.
Les événements sont présentés dans le champ de modification du script de l'éditeur de script, séparés par la syntaxe de référence pour chaque événement.
Pour afficher tous les scripts pour un simple objet dans l'éditeur de script
1.
Sélectionnez un objet auquel est associé un script.
2.
Dans la zone Afficher, sélectionnez Evénements avec scripts.
Les scripts sont présentés dans le champ de modification du script de l'éditeur de script, séparés par la syntaxe de référence pour chaque événement.
Pour afficher tous les scripts pour un objet conteneur et ses enfants dans l'éditeur de script
1.
S'il n'est pas déjà en mode multiligne, agrandissez l’éditeur de script afin d'afficher plusieurs lignes de script et assurez-vous que l'option Afficher les événements pour les objets enfant [image] est activée.
2.
Sélectionnez un objet conteneur, tel qu'un sous-formulaire. Tous les événements correspondant à l'objet conteneur et ses objets enfant apparaissent dans l'éditeur de script.
3.
Dans la liste Afficher, sélectionnez Tous les événements.
Les scripts sont présentés dans le champ de modification du script de l'éditeur de script, séparés par la syntaxe de référence pour chaque événement.
Voir aussi
A propos de l'aperçu et des tests de formulaires


Détermination de l'emplacement d'exécution de votre calcul ou script

Pour chaque calcul ou script créé dans LiveCycle Designer, vous devez préciser l'emplacement où le calcul ou le script doit être exécuté.
A moins que vous n'utilisiez un traitement sur serveur tel que LiveCycle Forms, assurez-vous que tous vos calculs et scripts sont exécutés sur l'application client (par exemple, sur Acrobat ou un navigateur Web).
Si vous utilisez un traitement sur serveur, vous avez le choix entre exécuter les calculs sur l'application client ou sur le serveur. Dans le deuxième cas, vous choisissez d'exécuter les scripts à un certain point durant le processus de rendu de formulaires.
Si vous choisissez Client et serveur dans la liste Exécuter sur, votre calcul ou script est disponible à la fois pour les applications de type client et serveur. Cette option peut s'avérer particulièrement utile, par exemple, si vous ne savez pas si vos utilisateurs souhaitent utiliser leurs formulaires sur des applications client ou serveur. Cette option est également pratique lorsque vous voulez que certains objets de formulaire se comportent différemment sur les applications client et sur les applications serveur.
Voir aussi
A propos de l’éditeur de script
A propos des événements
Détermination du moment de l'exécution de votre calcul ou script
Pour afficher les événements de script et les scripts


Test et débogage des calculs et des scripts

Après avoir créé votre calcul ou script et testé votre formulaire, vous pouvez détecter des erreurs de script ou autres valeurs de champ inattendues résultant des erreurs de script.
LiveCycle Designer propose trois méthodes principales pour tester et déboguer vos calculs et scripts :
      •
      Utilisation des palettes Espace de travail de LiveCycle Designer. Pour plus de détails, voir Utilisation de l'espace de travail pour le débogage des calculs et des scripts.
      •
      Pour JavaScript uniquement, JavaScript Debugger vous aide à tester vos scripts. Pour plus de détails sur l’utilisation du débogueur, voir Pour activer JavaScript Debugger pour LiveCycle Designer.
      •
      Résolution des erreurs de votre formulaire à l'aide des propriétés et méthodes du modèle d'événement et du modèle d'hôte.
Le modèle d'événement et le modèle d'hôte offrent les fonctionnalités nécessaires pour interagir avec l'application hôte ou les différents événements liés au formulaire. Ces modèles renvoient des informations utiles pour le débogage des calculs et des scripts.
Par exemple, le script suivant renvoie un message au moment de l'exécution, indiquant le nom de l'événement contenant le script. Cela indique qu'un événement particulier a été déclenché.
    xfa.host.messageBox(xfa.event.name)  // FormCalc
    xfa.host.messageBox(xfa.event.name); // JavaScript
Un autre exemple consisterait à obtenir la valeur d'un champ d'un formulaire interactif avant que l'utilisateur ne le modifie manuellement. Cela est utile pour déterminer comment les objets de votre conception de formulaire répondent aux données saisies par l'utilisateur.
    xfa.host.messageBox(xfa.event.prevText)  // FormCalc
    xfa.host.messageBox(xfa.event.prevText); // JavaScript
Voir aussi
Utilisation de l'espace de travail pour le débogage des calculs et des scripts
A propos de l'utilisation d'une application hôte
A propos du modèle d'événement


Evénements

A propos des événements
Types d'événements
Evénements de traitement
Evénements interactifs
Evénements d'application
Liste d'événements


A propos des événements

Chaque calcul ou script que vous associez à un objet de formulaire correspond à un événement spécifique. Un événement est défini comme une occurrence ou une action donnée permettant de modifier l'état d'un formulaire et, lorsque le changement d'état se produit, d'appeler automatiquement le script ou le calcul associé à l'événement. Les événements se produisent à différents stades, du début de la génération du formulaire lorsque les données sont fusionnées avec la conception de formulaire et tout au long de la procédure menant au remplissage du formulaire par l'utilisateur utilisant les objets contenus par le formulaire dans une application client. Grâce à l'application de calculs et de scripts à des événements spécifiques, vous pouvez contrôler chaque aspect de la présentation des objets du formulaire, ainsi que les données et la manière dont les objets et les données répondent à l'interaction de l'utilisateur.
Un simple changement d'état ou une action de l'utilisateur peut déclencher plusieurs événements. Il suffit, par exemple, de déplacer le curseur du champ actif au champ suivant pour déclencher à la fois l'événement exit pour le champ actif et l'événement enter pour le champ suivant. Si les champs actif et suivant se trouvent dans des sous-formulaires différents, quatre événements au total sont déclenchés : les événements exit pour le champ actif et le sous-formulaire et les événements enter pour le champ et le sous-formulaire suivants. En général, chacune des différentes catégories d'événements de formulaire suit un ordre précis.
Voir aussi
Types d'événements
Evénements de traitement
Evénements interactifs
Evénements d'application


Types d'événements

Les événements liés au formulaire appartiennent aux catégories suivantes :
Evénements de traitement
Ce type d'événement démarre automatiquement suite à un processus interne ou à une action liée aux objets d'un formulaire. Si, par exemple, l'utilisateur d'un formulaire clique sur un bouton qui permet d'insérer une page dans le formulaire, les événements de traitement initialize, calculate, validate et layout:ready lancent automatiquement la création de la page.
Evénements interactifs
Ce type d'événement est déclenché comme le résultat direct d'actions de l'utilisateur. Si, par exemple, un utilisateur place le pointeur au-dessus d'un champ d'un formulaire, l'événement mouseEnter est initialisé suite à cette action.
Evénements d'application
Ce type d'événement est exécuté comme le résultat des actions qu'une application client ou une application serveur effectue. Ainsi, vous pouvez créer un calcul ou un script afin d'effectuer une tâche juste avant que l'utilisateur du formulaire imprime une copie du formulaire à l'aide de l'événement prePrint.
Voir aussi
A propos des événements
Evénements de traitement
Evénements interactifs
Evénements d'application


Evénements de traitement

Les événements de traitement démarrent automatiquement suite à un processus interne ou à une action liée à un formulaire ou aux objets d'un formulaire. Ces événements sont déclenchés suite à des modifications importantes du formulaire, par exemple après la fusion de la conception d'un formulaire avec les données ou après le processus de pagination du formulaire. Les événements de traitement sont déclenchés immédiatement après le démarrage des événements interactifs. Ainsi, tout de suite après le déclenchement d'un événement interactif, l'événement calculate se produit suivi par l'événement validate.
La liste suivante inclut les événements de traitement disponibles dans la liste Afficher de l'éditeur de script :
      •
      calculate
      •
      form:ready
      •
      indexChange
      •
      initialize
      •
      layout:ready
      •
      validate
Les événements de traitement peuvent être déclenchés de nombreuses fois en fonction de leurs dépendances, c'est-à-dire des actions associées à un événement unique lançant par la suite un ou plusieurs événements. Considérons l'exemple d'un utilisateur d'un formulaire cliquant sur un bouton afin d'afficher une partie jusque-là masquée du formulaire. Dès que l'utilisateur a cliqué sur le bouton, cela déclenche une série d'événements interactifs et de traitement liés à la seule activation du bouton mais également un certain nombre d'événements de traitement liés au nouveau sous-formulaire.
L'illustration suivante représente l'enchaînement général des événements aboutissant à l'ouverture d'un formulaire PDF dans Acrobat ou dans Adobe Reader.
Lorsque le formulaire est ouvert dans Acrobat ou Adobe Reader, ces événements de traitement peuvent encore être déclenchés à la suite des modifications apportées au formulaire. Par exemple, les événements calculate, validate et layout:ready associés à un objet se produisent immédiatement après le déclenchement de certains événements interactifs. Par conséquent, les calculs et les scripts liés à ces événements de traitement seront exécutés à plusieurs reprises.
Voir aussi
A propos des événements
Evénements interactifs
Evénements d'application
Evénement calculate
Evénement docReady
Evénement form:ready
Evénement indexChange
Evénement initialize
Evénement layout:ready
Evénement validate
Détermination du moment de l'exécution de votre calcul ou script


Evénements interactifs

Les événements interactifs sont le résultat direct des actions de l'utilisateur du formulaire ce qui rend ces événements particulièrement utiles pour un grand nombre de calculs et d'opérations liés aux scripts. Par exemple, vous pouvez ajouter un script à l'événement mouseEnter de sorte que la couleur de bordure d'un champ de texte vire au bleu et un script à l'événement mouseExit pour que la bordure revienne à sa couleur initiale. Cette action crée un effet de mise en surbrillance lorsque l'utilisateur place le pointeur au-dessus du champ lui procurant ainsi une aide visuelle pour le remplissage du formulaire. Les événements interactifs sont également utiles pour la modification des données du formulaire suite à une sélection de l'utilisateur. Ainsi, vous pouvez ajouter un script à l'événement change pour une liste déroulante mettant à jour les valeurs des données dans plusieurs champs en fonction de la valeur que l'utilisateur a choisie dans la liste déroulante.
La liste suivante inclut les événements interactifs disponibles dans la liste Afficher de l'éditeur de script :
      •
      change
      •
      click
      •
      enter
      •
      exit
      •
      mouseDown
      •
      mouseEnter
      •
      mouseExit
      •
      mouseUp
      •
      preOpen
L'illustration suivante représente l'enchaînement général des événements lorsqu'un utilisateur sélectionne un objet et modifie sa valeur à l'aide de la souris.
alors que cette image produit un enchaînement général des événements, certaines actions utilisateur et objets de formulaire peuvent provoquer un ordre d'événement différent. Par exemple, si un utilisateur sélectionne une valeur dans une liste déroulante, l'événement mouseExit se produit après l'événement click mais avant les événements change ou full. De la même manière, si un utilisateur sélectionne un champ, appuie sur le bouton de la souris et quitte le champ tout en maintenant le bouton de la souris enfoncé, l'événement mouseUp se produira dans un ordre différent de celui décrit dans cette image.
L'illustration suivante représente l'enchaînement général des événements lorsqu'un utilisateur sélectionne un objet et modifie sa valeur à l'aide du clavier.
Voir aussi
Evénement change
Evénement click
Evénement enter
Evénement exit
Evénement full
Evénement mouseDown
Evénement mouseEnter
Evénement mouseExit
Evénement mouseUp
Evénement preOpen


Evénements d'application

Les événements d'application sont le résultat des actions qu'une application client ou une application serveur effectue, soit en réponse à une action de l'utilisateur, soit suite à un processus automatisé. Si, par exemple, un utilisateur enregistre le formulaire dans Acrobat ou dans Adobe Reader, l'événement preSave est immédiatement déclenché avant l'opération d'enregistrement ; il est suivi, dans l'ordre, par les événements calculate, validate et layout:ready associés à tous les objets du formulaire. La même séquence d'événements démarre si le formulaire contient un script enregistrant le formulaire par programme.
La liste suivante inclut les événements d'application disponibles dans la liste Afficher de l'éditeur de script :
      •
      docClose
      •
      docReady
      •
      postPrint
      •
      postSave
      •
      prePrint
      •
      preSave
      •
      preSubmit
Les événements d'application ne font pas partie de l'enchaînement général des événements. Il s'agit d'événements uniques correspondant aux actions que l'application client ou serveur réalise.
Voir aussi
Evénement docClose
Evénement postPrint
Evénement postSave
Evénement prePrint
Evénement preSave
Evénement preSubmit


Liste d'événements

Evénement calculate
Evénement change
Evénement click
Evénement docClose
Evénement docReady
Evénement enter
Evénement exit
Evénement form:ready
Evénement full
Evénement indexChange
Evénement initialize
Evénement layout:ready
Evénement mouseDown
Evénement mouseEnter
Evénement mouseExit
Evénement mouseUp
Evénement postPrint
Evénement postSave
Evénement preOpen
Evénement prePrint
Evénement preSave
Evénement preSubmit
Evénement validate


Evénement calculate

Description
Déclenché dans les conditions suivantes :
      •
      Au moment de la fusion de votre conception de formulaire et des données en un formulaire finalisé.
      •
      Lorsqu'une modification est apportée à une valeur dont dépend le calcul, telle la valeur d'un champ spécifique, à moins que l'utilisateur ait corrigé manuellement la valeur calculée. L'objet affiche alors la valeur de retour de l'événement. Les propriétés des champs remplacés manuellement se trouvent dans le panneau Valeur de la palette Objet.
      •
      Lorsque le champ n'est plus actif. Par exemple, dès qu'un utilisateur clique ou utilise la touche de tabulation pour quitter un champ.
Lorsque vous faites appel à l'événement calculate pour effectuer des calculs ou exécuter des scripts, prenez en compte les problèmes potentiels suivants :
      •
      Les calculs et les scripts associés à l'événement calculate ne doivent pas modifier la structure du formulaire, excepté en ce qui concerne les valeurs des données et de champs du formulaire.
      •
      Le contenu inséré par l'événement calculate doit se conformer aux validations associées à l'objet ; sinon des erreurs de validation se produiront.
      •
      Les calculs et les scripts ne doivent pas inclure une boucle infinie, car cela entraînerait la mise à jour permanente de la valeur par le formulaire. Par exemple, un script qui incrémente la valeur d'un champ dans le cadre d'une expression en boucle comme une boucle while ou for peut générer une boucle infinie.
Type
Evénement de traitement
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
4
Exemple
Servez-vous de l'événement calculate pour mettre à jour les valeurs numériques des champs, car cet événement démarre immédiatement après la plupart des autres événements. Ainsi, sur un formulaire de bon de commande, vous pouvez utiliser l'événement calculate pour un champ afin de déterminer le pourcentage de la taxe sur les ventes d'après le total de la commande. Le calcul s'effectue chaque fois qu'une modification est apportée aux valeurs des champs du formulaire. Ceci garantit que le montant de la taxe affichée est toujours correct.
Cependant, étant donné que l'événement calculate peut être exécuté à plusieurs reprises, vous devez vous assurer que le calcul ou le script que vous associez à l'événement ne provoquera pas une incrémentation inutile des valeurs de données. Si, par exemple, le calcul de la taxe sur les ventes additionne la valeur de la taxe au montant total à chaque exécution de l'événement calculate, le total obtenu sur le formulaire risque d'être trop élevé.
Voir aussi
A propos des événements
Evénements de traitement


Evénement change

Description
Déclenché lorsqu'un utilisateur modifie le contenu d'un champ par l'exécution de l'une des actions suivantes :
      •
      il effectue une saisie au clavier lorsque le champ est contrôlé par la cible d'action du clavier ;
      •
      il colle des données dans le champ ;
      •
      il effectue une sélection à partir d'une zone de liste ou d'une liste déroulante ;
      •
      il active ou désactive une case à cocher ;
      •
      il change le paramètre d'un groupe de boutons radio.
Cet événement ne se déclenche pas lorsque les valeurs des objets sont modifiées suite à l'application de calculs ou de scripts ou encore à l'issue de la fusion de la conception du formulaire avec les données.
Type
Evénement interactif
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
4
(seulement pour les listes déroulantes)
Exemple
Servez-vous de cet événement pour tout calcul ou tout script qui doit se déclencher en réponse à la modification de la valeur d'un champ par un utilisateur du formulaire. Vous pouvez ainsi utiliser l'événement change pour une liste déroulante afin de mettre en surbrillance certaines rangées du tableau. Cette technique permet, chaque fois que l'utilisateur sélectionne une valeur dans la liste déroulante, d'afficher en surbrillance la rangée correspondante du tableau.
Voir aussi
A propos des événements
Evénements interactifs


Evénement click

Description
Cet événement se déclenche par un clic de souris dans la région. Si un événement click se produit pour un champ de texte ou un champ numérique, les calculs ou les scripts sont automatiquement exécutés. Cependant, la valeur du champ ne change pas suite aux calculs et aux scripts tant que le champ n'est pas désélectionné.
vous ne pouvez pas placer un calcul ou un script sur l'événement click d'un bouton Envoyer, car le calcul ou le script prévaudrait sur l'action de soumission. En revanche, placez le calcul ou le script sur l'événement preSubmit associé au bouton Envoyer.
Type
Evénement interactif
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
4
Exemple
Utilisez cet événement pour déclencher une action en réponse immédiate à l'action d'un utilisateur consistant à cliquer sur un bouton, à sélectionner un bouton radio ou encore à activer une case à cocher du formulaire. Vous pouvez, par exemple, associer l'événement click à une case à cocher afin d'afficher ou de masquer un champ du formulaire.
Voir aussi
A propos des événements
Evénements interactifs
Evénement preSubmit


Evénement docClose

Description
Cet événement est exécuté à chaque fin de formulaire, seulement si toutes les validations de formulaire se sont terminées sans erreur.
Type
Evénement d'application
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
8
Exemple
Lorsque cet événement se déclenche, vous ne pouvez plus modifier un formulaire enregistré. En effet, il vise à donner la possibilité de générer un état quitter ou un message indiquant que le remplissage du formulaire est achevé. Par exemple, ayez recours à l'événement docClose pour afficher un message à l'utilisateur lui indiquant que le formulaire est dûment rempli.
Voir aussi
A propos des événements
Evénements d'application
Evénements de traitement


Evénement docReady

Description
Se déclenche immédiatement après l'ouverture du formulaire dans Acrobat ou dans Adobe Reader.
Type
Evénement d'application
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
8
Exemple
Cet événement est le premier qui s'exécute à l'ouverture du formulaire dans Acrobat ou Adobe Reader. Toute tâche de calcul ou de script impliquant le remplissage du formulaire ou ne devant être exécutée qu'une fois à la première ouverture du formulaire doit faire appel à cet événement. Par exemple, faites appel à l'événement docReady pour vérifier la version d'Acrobat ou d'Adobe Reader et renvoyer un message à l'utilisateur dans le cas où il est tenu de mettre à niveau son application avant de compléter le formulaire.
Voir aussi
A propos des événements
Evénements d'application


Evénement enter

Description
Cet événement se déclenche lorsqu'un champ ou un sous-formulaire atteint la cible d'action du clavier, que ce soit provoqué par une action utilisateur (déplacement du curseur dans le champ ou clic dans le champ) ou par un script qui définit la cible d'action par programme.
Type
Evénement interactif
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
4
Exemple
Vous pouvez recourir à cet événement pour fournir un texte d'info-bulle ou tout autre message à l'utilisateur du formulaire lorsque ce dernier place le pointeur dans le champ actif ou le sous-formulaire. Si, par exemple, un champ requiert une valeur dans un format donné ou si le remplissage d'un champ est régi par des instructions spéciales, cet événement permet d'afficher un message spécifiant les consignes particulières que doit respecter l'utilisateur.
Voir aussi
A propos des événements
Evénements interactifs


Evénement exit

Description
Cet événement se déclenche lorsqu'un champ ou un sous-formulaire n'est plus contrôlé par la cible d'action du clavier, en raison d'une action utilisateur (déplacement du curseur dans un autre champ ou clic hors du champ) ou de l'exécution d'un script qui supprime la cible.
Type
Evénement interactif
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
4
Exemple
Appliquez cet événement pour exécuter la vérification de données de champ lorsqu'un utilisateur quitte un champ. Si, par exemple, un champ exige une valeur, utilisez cet événement pour afficher un message à l'utilisateur afin de lui signaler que le remplissage de ce champ conditionne la soumission du formulaire.
Voir aussi
A propos des événements
Evénements interactifs


Evénement form:ready

Description
Cet événement se déclenche lorsque la fusion de votre conception de formulaire et des données est terminée, que le formulaire terminé existe et que les événements initialize, calculate et validate sont terminés.
Type
Evénement de traitement
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
8
Exemple
Pensez à faire appel à cet événement pour effectuer des tâches après la fusion de la conception de formulaire et des données et avant l'application de la disposition. Cet événement est utile, par exemple, pour personnaliser l'ordre ou l'emplacement des sous-formulaires sur votre formulaire avant que le formulaire soit paginé et rendu.
Voir aussi
A propos des événements
Evénements de traitement


Evénement full

Description
Cet événement se déclenche lorsque l'utilisateur tente d'entrer le contenu maximum autorisé dans un champ. Si, par exemple, la propriété Limiter la taille d'un champ est définie sur 5 et si un utilisateur tente de saisir la chaîne abcdef, l'événement full s'exécute lorsque l'utilisateur tape la lettre f.
la propriété Limiter la taille d'un champ se trouve dans le panneau Champ de la palette Objet.
Type
Evénement interactif
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
8
Exemple
Grâce à cet événement, il est possible d'indiquer à l'utilisateur qu'un champ a atteint sa capacité maximale. Par exemple, vous pouvez générer un message indiquant à l'utilisateur que la longueur maximale du champ est atteinte et lui indiquer les étapes supplémentaires en vue de remédier à ce problème.
Voir aussi
A propos des événements
Evénements interactifs
Propriétés des champs de texte dans le panneau Champ


Evénement indexChange

Description
L'événement est exécuté suite à l'insertion, au déplacement ou à la sa suppression d'un sous-formulaire, que ce soit par la fusion de nouvelles données avec le formulaire ou par l'utilisation d'un script.
cet événement n'est reçu que par les instances de sous-formulaire contrôlées par le gestionnaire d'instances ; il n'est pas pris en compte dans le cadre de jeux de sous-formulaires.
Type
Evénement de traitement
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
8
Exemple
Cet événement s'avère particulièrement utile pour définir des propriétés basées sur la valeur de l'occurrence d'un objet donné. Ainsi, vous pouvez utiliser cet événement pour coordonner l'ombrage de rangées alternées dans un tableau.
Voir aussi
A propos des événements
Evénements de traitement


Evénement initialize

Description
L'événement s'applique à tous les objets dès la fusion de la conception du formulaire avec les données.
Type
Evénement de traitement
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
4
Exemple
Vous pouvez utiliser cet événement pour réaliser des actions lorsqu'un objet est crée en raison d'une action de l'utilisateur ou au cours du processus de création du formulaire. Utilisez cet événement, par exemple, pour contrôler les paramètres des nouvelles instances d'un objet de sous-formulaire qu'un utilisateur ajoute au formulaire en cliquant sur un bouton.
Voir aussi
A propos des événements
Evénements de traitement


Evénement layout:ready

Description
Cet événement s'exécute après la fusion de la conception du formulaire et des donnée, le formulaire existe et la disposition est appliquée. A ce stade, le rendu du formulaire finalisé n'a pas été effectué. Un calcul ou un script exécuté sur cet événement peut donc modifier la disposition du formulaire avant sa génération. Cet événement peut également se produire après la restitution du formulaire si un calcul ou un script rectifie les données ou entraîne une modification du formulaire dans Acrobat ou Adobe Reader.
Type
Evénement de traitement
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
8
Exemple
Vous pouvez utiliser cet événement pour réaliser des tâches immédiatement après l'application de la disposition. Par exemple, cet événement vous permet de déterminer le nombre de pages que le formulaire contient.
Voir aussi
A propos des événements
Evénements de traitement


Evénement mouseDown

Description
L'événement survient lorsque l'utilisateur appuie sur le bouton de la souris alors que le pointeur se trouve dans le champ.
si un événement mouseDown se produit pour un champ de texte ou un champ numérique, les calculs ou les scripts sont automatiquement exécutés. Cependant, la valeur du champ ne change pas suite aux calculs et aux scripts tant que le champ n'est pas désélectionné. Lorsqu'un événement mouseDown intervient dans un champ de signature, l'événement se déclenche avant le début du processus de signature.
Type
Evénement interactif
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
4
Exemple
Vous pouvez faire appel à cet événement pour déclencher une action en réponse immédiate à l'action d'un utilisateur consistant à cliquer sur un bouton, à sélectionner un bouton radio ou encore à activer une case à cocher du formulaire. Vous pouvez, par exemple, associer l'événement mouseDown à une case à cocher afin d'afficher ou de masquer un champ du formulaire. Cet événement est similaire, du point de vue de la conception, à l'événement click et est utilisé dans le même but.
Voir aussi
A propos des événements
Evénements interactifs
Evénement click


Evénement mouseEnter

Description
Cet événement se déclenche lorsque l'utilisateur déplace le pointeur de la souris à l'intérieur du champ, sans nécessairement appuyer sur le bouton de la souris. Il n'est pas déclenché si le pointeur de la souris est placé dans le champ pour une toute autre raison, par exemple parce qu'une fenêtre superposée se ferme.
Type
Evénement interactif
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
8
Exemple
Vous pouvez utiliser cet événement pour procurer un retour d'informations visuel à un utilisateur pour l'événement mouseExit. Cet événement permet de modifier la couleur de la bordure ou la couleur d'arrière-plan d'un objet afin de signaler de manière visuelle à l'utilisateur qu'il utilise un champ donné.
Voir aussi
A propos des événements
Evénements interactifs


Evénement mouseExit

Description
Cet événement se déclenche lorsque l'utilisateur déplace le pointeur de la souris hors du champ, même si l'utilisateur appuie sur le bouton de la souris. Il n'est pas déclenché si le pointeur de la souris est placé dans le champ pour une toute autre raison, par exemple parce qu'une fenêtre superposée s'ouvre.
Type
Evénement interactif
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
8
Exemple
Vous pouvez utiliser cet événement pour procurer un retour d'informations visuel à un utilisateur pour l'événement mouseEnter. Cet événement permet de rétablir la couleur d'origine de la bordure ou d'arrière-plan d'un objet afin de signaler de manière visuelle à l'utilisateur qu'il ne travaille plus dans un champ donné.
Voir aussi
A propos des événements
Evénements interactifs


Evénement mouseUp

Description
L'événement se produit lorsque l'utilisateur relâche le bouton de la souris alors que le pointeur se trouve dans le champ.
si un événement mouseUp se produit pour un champ de texte ou un champ numérique, les calculs ou les scripts sont automatiquement exécutés. Cependant, la valeur du champ ne change pas suite aux calculs et aux scripts tant que le champ n'est pas désélectionné.
Type
Evénement interactif
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
4
Exemple
Vous pouvez faire appel à cet événement pour déclencher des actions afin de répondre immédiatement à l'action d'un utilisateur consistant à cliquer sur un bouton, à sélectionner un bouton radio ou encore à activer une case à cocher du formulaire. Vous pouvez, par exemple, associer l'événement mouseUp à une case à cocher afin d'afficher ou de masquer un champ du formulaire. Cet événement est similaire, du point de vue de la conception, à l'événement click et est utilisé dans le même but.
Voir aussi
A propos des événements
Evénements interactifs


Evénement postPrint

Description
Cet événement est automatiquement exécuté une fois que le formulaire rendu est envoyé à l'imprimante, au programme d'impression différée ou à la destination de sortie.
Type
Evénement d'application
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
8
Exemple
Utilisez cet événement pour afficher des messages d'information à l'intention de l'utilisateur lorsque le formulaire est imprimé. Ainsi, il est possible de créer un script sur l'événement postPrint pour rappeler à l'utilisateur les étapes qu'il doit encore entreprendre pour soumettre manuellement le formulaire.
Voir aussi
A propos des événements
Evénements d'application


Evénement postSave

Description
Cet événement s'exécute automatiquement lorsqu'un utilisateur enregistre un formulaire au format PDF ou XDP. Il ne se produit pas si vous exportez un sous-ensemble du formulaire (par exemple, uniquement les données de formulaire) au format XDP.
Type
Evénement d'application
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
8
Exemple
Utilisez cet événement pour afficher des messages d'information à l'intention de l'utilisateur lorsque les données du formulaire sont enregistrées. Créez ainsi un script sur l'événement postSave pour rappeler aux utilisateurs le temps qu'il leur reste pour remplir et soumettre le formulaire.
Voir aussi
A propos des événements
Evénements d'application


Evénement preOpen

Description
Cet événement est exécuté lorsqu'un utilisateur effectue une action ayant pour effet d'afficher la liste déroulante, notamment cliquer sur la flèche de la liste déroulante ou activer la liste déroulante avec la touche Tabulation et utiliser la flèche Bas. Cet événement se produit avant l'affichage du contenu de la liste déroulante.
cet événement s'applique uniquement à l'objet de liste déroulante.
Type
Evénement interactif
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
8
Exemple
Cet événement permet de contrôler le chargement d'un grand nombre d'articles de liste. Par exemple, vous pouvez utiliser cet événement pour charger un nombre fixe d'enregistrements provenant d'une source de données dans une liste déroulante. Cette opération contribue à améliorer les performances du formulaire au moment de son exécution par l'utilisateur.
Voir aussi
A propos des événements
Evénements interactifs


Evénement prePrint

Description
Cet événement est automatiquement exécuté avant qu'un formulaire ne soit rendu à des fins d'impression.
Type
Evénement d'application
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
4
Exemple
Cet événement permet de masquer un objet que vous ne souhaitez pas imprimer. Ainsi, il est possible de masquer un texte ou des instructions destinés à l'utilisateur lorsqu'il remplit le formulaire en ligne.
Voir aussi
A propos des événements
Evénements d'application


Evénement preSave

Description
Se produit automatiquement avant l'enregistrement des données du formulaire au format PDF ou XDP. Ce événement n'est pas exécuté si les données ou tout autre sous-ensemble du formulaire sont exportés au format XDP.
Type
Evénement d'application
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
4
Exemple
Grâce à cet événement, vous pouvez modifier les données du formulaire juste avant l'enregistrement des données. Par exemple, il est possible de créer un script sur l'événement preSave afin d'analyser les données et d'afficher un message de rappel à l'utilisateur si certains champs obligatoires sont vides.
Voir aussi
A propos des événements
Evénements d'application


Evénement preSubmit

Description
Se déclenche dès qu'un formulaire transmet des données à l'hôte via le protocole HTTP. A ce stade, les données sont organisées dans un ensemble de données, mais n'ont pas encore été envoyées à l'hôte. Les calculs et les scripts associés à l'événement peuvent examiner et corriger les données avant la soumission du formulaire. Si le calcul ou le script est défini de manière à être exécuté sur le serveur, le formulaire envoie les données au serveur en lui indiquant d'exécuter le calcul ou le script avant tout traitement supplémentaire.
l'événement preSubmit ne fait pas la distinction entre les soumissions initiées par l'activation de différents boutons ou par différents URL. Tout script devant faire cette distinction doit inclure un code lui permettant de déterminer le bouton ayant été activé. En général, preSubmit est analogue à preSave et est utilisé dans le même but.
Type
Evénement d'application
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
4
(Pour les boutons d'envoi uniquement)
Exemple
Grâce à cet événement, vous pouvez modifier les données du formulaire juste avant la soumission des données. Vous avez la possibilité, par exemple, de générer un script sur l'événement preSubmit consistant à analyser la quantité de données et à afficher par la suite un message à l'utilisateur l'informant du temps nécessaire à l'envoi des données.
Voir aussi
A propos des événements
Evénements d'application
Evénement preSave


Evénement validate

Description
S'exécute lorsque la conception de formulaire et les données sont fusionnées pour créer le formulaire et lorsqu'un champ est désélectionné ; par exemple, lorsqu'un utilisateur clique ou utilise la touche Tabulation pour quitter un champ. Cet événement se produit à nouveau chaque fois que la valeur d'un champ change. Les calculs et les scripts placés sur l'événement validate offrent des méthodes de validation plus spécifiques que celles disponibles dans le panneau Valeur de la palette Objet.
Les calculs et les scripts associés à l'événement validate sont nécessaires pour le renvoi des valeurs true ou false (exprimées selon le format approprié du script) correspondant à une validation correcte ou à un échec de la validation et ne doivent pas influer sur la structure globale des valeurs du formulaire. De plus, ils ne doivent pas tenter de retourner des informations à un utilisateur de formulaire, puisque cet utilisateur n'utilise pas forcément le formulaire sur une application client telle qu'Acrobat.
étant donné que les validations portent sur le contenu d'un formulaire, elles ne peuvent pas être utilisées pour vérifier la mise en forme déterminée par les formats des champs.
Type
Evénement de traitement
Prise en charge

Application client

Disponibilité
Acrobat et Adobe Reader
4
Navigateur HTML
4
Exemple
Vous pouvez utiliser cet événement pour vérifier les valeurs des objets, tout particulièrement lorsque les données doivent respecter des règles spécifiques. Par exemple, vous pouvez créer un script sur l'événement validate afin de vous assurer que le champ indiquant le montant total sur un formulaire de bon de commande ne contient pas une valeur négative.
Voir aussi
A propos des événements
Evénements de traitement


Langages de script

Différences entre les fonctions FormCalc et JavaScript
Utilisation de FormCalc
Utilisation de JavaScript


Différences entre les fonctions FormCalc et JavaScript

Bien que FormCalc et JavaScript s'adressent à deux types d'utilisateurs différents, il y a certaines similitudes entre les types de fonctions intégrées respectivement proposés. Le tableau suivant fournit une liste des fonctions FormCalc disponibles et indique s'il existe une fonction JavaScript comparable.

Fonction FormCalc

Description

Equivalent JavaScript

Abs(n1)
Retourne la valeur absolue d’une valeur ou d’une expression numérique.
Oui

Apr(n1, n2, n3)
Renvoie le taux annuel d’un prêt.
Non

At(s1, s2)
Repère la position du premier caractère d’une chaîne dans une autre chaîne.
Oui

Avg(n1 [, n2... ] )
Evalue un ensemble de valeurs et/ou d’expressions numériques et renvoie la moyenne des éléments non nuls de cet ensemble.
Non

Ceil(n1)
Renvoie le nombre entier supérieur ou égal au nombre fourni.
Oui

Choose(n1, s1 [, s2... ] )
Sélectionne une valeur dans un ensemble de paramètres donné.
Non

Concat(s1 [, s2... ] )
Renvoie la concaténation des chaînes indiquées.
Oui

Count(n1 [, n2...])
Evalue un ensemble de valeurs et/ou d'expressions et renvoie le nombre d'éléments non nuls contenus dans cet ensemble.
Non

CTerm(n1, n2, n3)
Renvoie le nombre de périodes nécessaires pour qu’un investissement, dont le taux d’intérêt est fixe mais composé, atteigne une valeur capitalisée.
Non

Date()
Retourne la date active du système représentée sous forme du nombre de jours écoulés depuis la date considérée.
Oui

Date2Num(d1 [, f1 [, k1 ] ] )
Retourne le nombre de jours écoulés depuis la date considérée, à partir d'une chaîne de date.
Non

DateFmt([ n1 [, k1 ] ] )
Renvoie une chaîne de format de date, à partir d'un style de format de date.
Non

Decode(s1 [, s2 ] )
Renvoie la version décodée d'une chaîne donnée.
Prise en charge limitée
JavaScript reconnaît uniquement les valeurs codées URL qui ne contiennent pas de caractère d'échappement.

Encode(s1 [, s2 ] )
Renvoie la version codée d'une chaîne donnée.
Prise en charge limitée
JavaScript reconnaît uniquement les valeurs codées URL qui ne contiennent pas de caractère d'échappement.

Eval()
Renvoie la valeur d'un calcul de formulaire donné.
Oui

Exists(v1)
Détermine si le paramètre donné est une syntaxe de référence valide à un objet existant.
Non

Floor(n1)
Renvoie le plus grand nombre entier inférieur ou égal à la valeur donnée.
Oui

Format(s1, s2)
Formate les données fournies selon la chaîne de format d'image indiquée.
Non

FV(n1, n2, n3)
Renvoie la valeur capitalisée de paiements fixes effectués à intervalles réguliers, compte tenu d'un taux d’intérêt fixe.
Non

Get(s1)
Télécharge le contenu de l'adresse URL indiquée.
Non

HasValue(v1)
Détermine si le paramètre indiqué est une syntaxe de référence valide dont la valeur n'est ni nulle, ni vide, ni un blanc.
Non

IPmt(n1, n2, n3, n4, n5)
Renvoie le montant de l'intérêt payé pour un prêt au cours d'une période donnée.
Non

IsoDate2Num(d1)
Retourne le nombre de jours écoulés depuis l'époque considérée, à partir d'une chaîne de date valide.
Non

IsoTime2Num(d1)
Retourne le nombre de millisecondes écoulées depuis l'époque considérée, à partir d'une chaîne d'heure valide.
Non

Left(s1, n1)
Extrait un nombre spécifique de caractères d'une chaîne, en commençant par le premier caractère à gauche.
Oui

Len(s1)
Renvoie le nombre de caractères d'une chaîne donnée.
Oui

LocalDateFmt( [ n1 [, k1 ] ] )
Renvoie une chaîne de format de date localisée, à partir d'un style de format de date.
Non

LocalTimeFmt( [ n1 [, k1 ] ] )
Renvoie une chaîne de format d'heure localisée, à partir d'un style de format d'heure.
Non

Lower(s1 [, k1 ] )
Convertit en minuscules toutes les majuscules d'une chaîne donnée.
Non

Ltrim(s1)
Renvoie une chaîne sans aucun caractère d'espace blanc à gauche.
Non

Max(n1 [, n2... ] )
Renvoie la valeur maximale des éléments non nuls d'un ensemble donné de nombres.
Non

Min(n1 [, n2... ] )
Renvoie la valeur minimale des éléments non nuls d'un ensemble donné de nombres.
Non

Mod(n1, n2)
Renvoie le reste d'un nombre divisé par un autre.
Non

NPV(n1, n2 [, ... ] )
Renvoie la valeur nette actualisée d'un investissement, compte tenu d'une série de mouvements futurs de l'encaisse et d'un taux d'actualisation.
Non

Num2Date(n1[, f1 [, k1 ] ] )
Retourne une chaîne de date, déterminant un nombre de jours écoulés depuis l'époque considérée.
Non

Num2GMTime(n1 [,f1 [, k1 ] ] )
Retourne une chaîne d'heure UT, à partir du nombre de millisecondes écoulées depuis l'époque considérée.
Non

Num2Time(n1 [,f1 [, k1 ] ] )
Retourne une chaîne d'heure, à partir du nombre de millisecondes écoulées depuis l'époque considérée.
Non

Oneof(s1, s2 [, s3... ] )
Retourne vrai (1) si une valeur se trouve dans un ensemble donné, et faux (0) dans le cas contraire.
Oui

Parse(s1, s2)
Analyse les données fournies selon le format d'image donné.
Non

Pmt(n1, n2, n3)
Renvoie le remboursement d'un prêt basé sur des versements fixes et sur un taux d'intérêt fixe.
Non

Post(s1, s2 [, s3 [, s4 [, s5 ] ] ] )
Place à l'adresse URL indiquée les données fournies.
Non

PPmt(n1, n2, n3, n4, n5)
Renvoie le montant du principal payé pour un prêt au cours d'une période.
Non

Put(s1, s2 [, s3 ] )
Télécharge les données fournies vers l'adresse URL indiquée.
Non

PV(n1, n2, n3)
Renvoie la valeur actualisée d'un investissement réalisé par versements fixes périodiques avec un taux d'intérêt fixe.
Non

Rate(n1, n2, n3)
Renvoie le taux d'intérêt composé par période nécessaire pour qu'un investissement d'une valeur actualisée atteigne une valeur capitalisée au cours d'une période donnée.
Non

Ref()
Renvoie une référence à un objet existant.
Oui

Replace(s1, s2 [, s3 ] )
Remplace toutes les occurrences d'une chaîne par une autre, dans la chaîne indiquée.
Oui

Right(s1, n1)
Extrait un nombre spécifique de caractères dans une chaîne donnée, en commençant par le dernier caractère à droite.
Oui

Round(n1 [, n2 ] )
Evalue une valeur ou expression numérique donnée et renvoie un nombre arrondi comportant le nombre de décimales défini.
Oui

Rtrim(s1)
Renvoie une chaîne sans aucun caractère d'espace blanc à droite.
Non

Space(n1)
Renvoie une chaîne composée d'un nombre donné d'espaces blancs.
Non

Str(n1 [, n2 [, n3 ] ] )
Convertit un nombre en une chaîne de caractères. FormCalc formate le résultat selon la largeur indiquée et l'arrondit au nombre de décimales défini.
Non

Stuff(s1, n1, n2 [, s2 ] )
Insère une chaîne dans une autre chaîne.
Non

Substr(s1, n1, n2)
Extrait une partie d'une chaîne donnée.
Oui

Sum(n1 [, n2... ] )
Renvoie la somme des éléments non nuls d'un ensemble donné de nombres.
Non

Term(n1, n2, n3)
Renvoie le nombre de périodes nécessaires pour atteindre la valeur capitalisée donnée, compte tenu de paiements fixes périodiques versés sur un compte portant intérêt.
Non

Time()
Retourne l'heure courante du système représentée sous forme du nombre de millisecondes écoulées depuis l'époque considérée.
Oui

Time2Num(d1 [, f1 [, k1 ] ] )
Retourne le nombre de millisecondes écoulées depuis l'époque considérée, à partir d'une chaîne d'heure.
Non

TimeFmt([n1 [, k1 ] ] )
Renvoie un format d'heure, à partir d'un style de format d'heure.
Non

UnitType(s1)
Renvoie les unités d'une étendue d'unité. Une étendue d'unité est une chaîne composée d'un nombre suivi d'un nom d'unité.
Non

UnitValue(s1 [, s2 ] )
Retourne la valeur numérique d’une mesure avec l'étendue d'unité qui lui est associée, après une conversion d’unité facultative.
Non

Upper(s1 [, k1 ] )
Convertit en majuscules toutes les minuscules d'une chaîne.
Non

Uuid(n1)
Renvoie une chaîne UUID qui sert de méthode d'identification.

Within(s1, s2, s3)
Retourne vrai (1) si une valeur de contrôle se trouve dans une plage donnée, et faux (0) dans le cas contraire.
Oui

WordNum(n1 [, n2 [, k1 ] ] )
Renvoie le texte équivalent à un nombre donné.
Non
Voir aussi
A propos de l'utilisation de FormCalc
Introduction à FormCalc


Utilisation de FormCalc

A propos de l'utilisation de FormCalc
Utilisation de fonctions intégrées
Pour attacher une fonction FormCalc à un objet
Syntaxe de fonction intégrée
Création de calculs de base


A propos de l'utilisation de FormCalc

FormCalc est un langage de calcul simple mais puissant, fondé sur les tableurs traditionnels. Il permet de créer des formulaires, rapidement et efficacement, sans exiger la maîtrise des techniques ou des langages de script traditionnels. Les nouveaux utilisateurs de FormCalc peuvent ainsi créer rapidement, au moyen de quelques fonctions intégrées, des formulaires visant à épargner les tâches fastidieuses (calculs, validations, vérifications) aux utilisateurs finals. Vous pouvez ainsi créer un ensemble de règles de base pour le modèle de formulaire qui permet au formulaire résultant de réagir en fonction des données qu'il rencontre.
Dans LiveCycle Designer, FormCalc est le langage de script par défaut dans tous les emplacements de script. Le langage JavaScript constitue l'autre choix possible. Pour plus d'informations sur la configuration du langage de script par défaut, reportez-vous à la section A propos de l’éditeur de script.
si vous développez des formulaires destinés à être utilisés avec un processus serveur (par exemple, à l'aide de LiveCycle Forms), avec l'intention de générer vos formulaires au format HTML, il est préférable de développer vos calculs et scripts avec JavaScript. Les calculs FormCalc ne sont pas reconnus par les navigateurs HTML, et sont supprimés avant que les formulaires ne soient générés au format HTML.
FormCalc traite chaque nouvelle ligne dans l'éditeur de script comme une nouvelle expression à évaluer.
Voir aussi
A propos de l'utilisation de FormCalc
A propos de l’utilisation de JavaScript


Utilisation de fonctions intégrées

FormCalc propose de nombreuses fonctions portant sur des domaines variés, tels que les mathématiques, les dates et heures, les chaînes, la finance, la logique et le Web. Ces domaines représentent les types de fonctionnalités habituellement rencontrés dans les formulaires ; les fonctions permettent de manipuler rapidement et simplement les données des formulaire à des fins utiles.
Au niveau le plus élémentaire, un calcul peut consister en une fonction FormCalc simple seulement. Cependant, une fonction FormCalc simple peut utiliser d'autres fonctions FormCalc comme paramètres.
Voir aussi
Introduction à FormCalc


Pour attacher une fonction FormCalc à un objet

Vous pouvez ajouter une fonction FormCalc à n'importe quel objet de conception de formulaire afin de permettre l'exécution de calculs ou de scripts, à l'exception des objets de script.
1.
Assurez-vous de disposer d'une version multiligne de l'éditeur de script dans l'espace de travail LiveCycle Designer.
2.
Choisissez un champ du formulaire.
3.
Dans la zone Afficher, sélectionnez l'événement calculate.
4.
Cliquez sur Fonctions [image] ou sur la touche F10 pour afficher une liste des fonctions FormCalc.
5.
Choisissez la fonction souhaitée et appuyez sur Entrée.
6.
Remplacez la notation de syntaxe de la fonction par défaut par votre propre série de valeurs.
7.
Cliquez sur Insérer les changements dans la source du script [image] pour ajouter le calcul FormCalc à votre formulaire.


Syntaxe de fonction intégrée

Chaque fonction FormCalc utilise une notation de syntaxe spécifique que vous devez respecter pour que les fonctions soient correctement exécutées. Le tableau ci-dessous décrit, d'une manière très générale, les éléments de notation de syntaxe.

Notation de syntaxe

Valeurs de remplacement

d
Chaîne de date valide (par exemple, 03/15/1996)

f
Chaîne de format de date valide (par exemple, MM/DD/YYYY)

k
Identifiant local valide (par exemple, fr_FR)

n
Valeur numérique valide. Notez que la plage de valeurs correctes varie selon les fonctions.

s
Unité de mesure valide (par exemple, « cm » pour centimètres)

v
Syntaxe de référence valide.

n1, n2, n3
Toutes les valeurs sont requises.

[ [ n [, k ] ] ]
Aucune valeur n'est requise, mais vous pouvez choisir de ne préciser que n, ou à la fois n et k.

n1 [, n2 ... ]
n1 est requis, mais vous pouvez choisir de préciser un nombre illimité de valeurs supplémentaires.

d [, f [, k ] ]
d est requis, mais vous pouvez également choisir de préciser f, ou à la fois f et k.


Création de calculs de base

A propos des calculs de base
Les expressions simples sont les instances les plus élémentaires des scripts. Ces expressions n'impliquent pas l'utilisation de fonctions intégrées FormCalc et ne dépassent jamais une ligne. Vous devez ajouter des expressions simples pour l'événement calculate d'un champ ou d'un objet donné afin que la valeur de l'expression apparaisse sur votre formulaire.
Exemples de calculs de base
Voici quelques exemples d'expressions simples :
2
"abc"
2 - 3 * 10 / 2 + 7
Chaque expression simple donne une seule valeur, après exécution des opérations dans l'ordre traditionnel, même si cet ordre n'est pas toujours évident à déterminer à partir de la syntaxe de l'expression. Par exemple, la série d'expressions suivante produit des résultats équivalents :

Expression

Equivalent à

Résultat

"abc"

"abc"

abc

2 - 3 * 10 / 2 + 7

2 - (3 * 10 / 2) + 7

-6

(10 + 2) * (5 + 4)

(10 + 2) * (5 + 4)

108

0 and 1 or 2 > 1

(0 and 1) or (2 >1)
1 (vrai)

2 < 3 not 1 == 1

(2 < 3) not (1 == 1)
0 (faux)
Tous les exemples ci-dessus sont des expressions simples valides que vous pouvez ajouter à un champ ou un objet de formulaire, qui acceptent des calculs et des scripts. Par exemple, si vous créez un formulaire dans LiveCycle Designer avec un champ numérique simple, et que vous ajoutez le calcul suivant à l'événement calculate dans l'éditeur de script :
Lorsque vous choisissez ensuite le panneau Aperçu PDF pour afficher le formulaire complet, la valeur de l'expression simple apparaît dans le champ de texte.
Si la valeur n'apparaît pas dans l'aperçu, assurez-vous que votre expression simple apparaît dans l'événement calculate de l'objet de conception de formulaire. Vérifiez également si vous avez correctement installé LiveCycle Designer et Acrobat.


Utilisation de JavaScript

A propos de l’utilisation de JavaScript
Création de scripts à l'aide de JavaScript
Pour attacher un script JavaScript à un objet


A propos de l’utilisation de JavaScript

LiveCycle Designer reconnaît l'utilisation de JavaScript 1,6 dans toutes les situations compatibles avec les fonctions de script pour offrir des possibilités accrues et plus de flexibilité en matière de conception de formulaires.
Les développeurs qui maîtrisent le langage JavaScript peuvent appliquer directement leurs propres connaissances dans LiveCycle Designer. LiveCycle Designer offre de nombreuses propriétés et méthodes permettant d'améliorer JavaScript pour que vous puissiez accéder aux valeurs de champ et d'objet. Ces propriétés et méthodes sont combinées avec la syntaxe de référence de LiveCycle Designer pour une manipulation plus aisée des valeurs et des données de formulaire.
l'éditeur de script ne permet pas la vérification des erreurs de syntaxe des scripts créés à l'aide de JavaScript.
Voir aussi
Création de scripts à l'aide de JavaScript


Création de scripts à l'aide de JavaScript

La création de scripts dans LiveCycle Designer à l'aide de JavaScript est très similaire à la création de JavaScript dans d’autres applications. Vous pouvez vous baser sur vos connaissances des concepts JavaScript, réutiliser les fonctions JavaScript à l'aide de l'objet de script de LiveCycle Designer et tirer parti des fonctionnalités du langage JavaScript.
Cependant, il est important de noter que si les connaissances de JavaScript sont transférables, vous devez comprendre comment créer une syntaxe de référence LiveCycle Designer pour utiliser efficacement JavaScript dans votre conception de formulaire. Plus particulièrement, vous devez être en mesure d'utiliser correctement la syntaxe de référence pour accéder aux objets de votre conception de formulaire.
Le tableau ci-dessous décrit les concepts de base du développement de scripts dans JavaScript pour LiveCycle Designer et indique l'emplacement où vous pouvez trouver des informations complémentaires sur chaque concept de <Italic>Aide de LiveCycle Designer.

Concept de base

Pour plus d’informations, voir ...
Création de références à des propriétés et valeurs d'objets, y compris l'utilisation de la méthode resolveNode.
Référence aux propriétés et aux valeurs d'objet
resolveNode
Pour utiliser des options de fin d'instructions pour créer des calculs et des scripts
Test et débogage de votre formulaire à l’aide des modèles d'événement et d'hôte.
Test et débogage des calculs et des scripts
Référence aux propriétés et aux valeurs d'objet
Utilisation de l'objet de script pour réutiliser les fonctions JavaScript existantes.
A propos de l'objet de script
Outre les ressources disponibles dans l'<Italic>Aide de LiveCycle Designer, LiveCycle Developer Center contient des ressources étendues de création de scripts et de la documentation. Developer Center se trouve sur le site Web www.adobe.com/devnet/livecycle/.
Voir aussi
A propos de l’utilisation de JavaScript


Pour attacher un script JavaScript à un objet

Vous pouvez ajouter un script JavaScript à n'importe quel objet de conception de formulaire afin de permettre l'exécution de calculs ou de scripts, y compris des objets de script.
1.
Assurez-vous de disposer d'une version multiligne de l'éditeur de script dans l'espace de travail LiveCycle Designer.
2.
Choisissez un champ du formulaire.
3.
Dans la zone Afficher, sélectionnez un événement valide.
4.
Cliquez sur Fonctions [image] ou sur la touche F10 pour afficher une liste des fonctions JavaScript, sélectionnez la fonction voulue et appuyez sur la touche Entrée. Remplacez la notation de syntaxe de la fonction par défaut par votre propre série de valeurs. Vous pouvez également créer votre propre script manuellement dans le champ Source du script de l'éditeur de script.
5.
Cliquez sur Insérer les changements dans la source du script [image] pour ajouter le script JavaScript à votre formulaire.
Voir aussi
A propos de l’utilisation de JavaScript


Référence aux objets dans les calculs et les scripts

A propos des références aux objets dans les calculs et les scripts
Référence aux propriétés et aux valeurs d'objet
Référence aux objets sans nom et aux objets répétés
Référence à l'objet actif
Raccourcis de la syntaxe de référence FormCalc


A propos des références aux objets dans les calculs et les scripts

Bien que les calculs FormCalc et les scripts JavaScript possèdent leurs propres règles en vue de créer la structure du code, ces deux fonctionnalités font appel à la même syntaxe de référence lors de l'accès aux propriétés et valeurs des objets de formulaires. Le modèle d'objet de formulaire XML permet d'accéder de manière structurée aux propriétés et aux valeurs des objets grâce à la convention de dénomination composée ; chaque propriété, méthode et objet étant séparé par des points (.).
En général, chaque syntaxe de référence possède une structure analogue divisée en trois parties :
      •
      La première partie contient les noms des objets dans la hiérarchie de formulaire et sert à accéder à un champ ou à un objet spécifique. Vous pouvez utiliser la palette Hiérarchie et la palette Vue des données pour déterminer l'emplacement d'un objet par rapport à d'autres objets dans le formulaire et dans les données associées.
      •
      La seconde partie désigne le nom de l'objet auquel vous voulez faire référence.
      •
      La troisième partie représente le nom de la propriété ou de la méthode à laquelle vous voulez accéder. Cette partie peut inclure des objets du modèle d'objet de formulaire XML précédant la propriété ou la méthode dans la structure, mais qui ne s'affichent pas en tant qu'objets dans la palette Hiérarchie.
L'exemple suivant illustre une syntaxe de référence permettant d'accéder à la valeur d'un champ de texte qui utilise les conventions de dénomination d'objet par défaut :
par défaut, l'objet de sous-formulaire représentant la première page d'un nouveau formulaire n'a pas de nom. Dans la syntaxe de référence précédente, le sous-formulaire sans nom est représenté par #subform.
La structure de notation de la syntaxe de référence varie légèrement selon le cas. Par exemple, une syntaxe de référence complète est toujours applicable, mais, dans certains cas, vous pouvez être amené à faire appel à une syntaxe de référence abrégée ou à un raccourci de la syntaxe de référence afin de limiter la taille de la syntaxe.
Voir aussi
Référence aux propriétés et aux valeurs d'objet
Référence aux objets sans nom et aux objets répétés
Référence à l'objet actif
Raccourcis de la syntaxe de référence FormCalc


Référence aux propriétés et aux valeurs d'objet

La syntaxe de référence servant à examiner ou à modifier les propriétés et les valeurs d'objet peut prendre l'une des formes suivantes :
Complète
La syntaxe de référence contient la hiérarchie d'objet complète commençant par le nœud racine xfa. La syntaxe de référence complète permet d'accéder précisément à la propriété ou la valeur d'un objet, quel que soit l'emplacement du calcul ou du script contenant la syntaxe.
Abrégée
La syntaxe de référence est abrégée en raison du positionnement relatif du calcul ou du script qui contient la syntaxe de référence et les références aux objets de syntaxe ou en raison de l'utilisation de raccourcis. Bien qu'il soit généralement plus rapide de créer une syntaxe de référence abrégée, cette méthode présente l'inconvénient de ne plus être exploitable dès que les objets changent de position les uns par rapport aux autres.
La figure suivante illustre la hiérarchie d'un formulaire de bon de commande.
Cette illustration présente la syntaxe de référence complète, pour FormCalc et JavaScript, indiquant l'accès à la valeur du champ txtCondition. Cette syntaxe de référence peut être utilisée au sein d'un calcul ou d'un script ou encore avec tout objet du formulaire.
même si la syntaxe de référence est commune à FormCalc et à JavaScript, vous devez respecter les conventions de chaque langage de script. Ainsi, dans l'exemple précédent, la syntaxe de référence est compréhensible par FormCalc, mais vous devrez inclure un caractère point-virgule à la fin (;) pour JavaScript.
Si deux objets existent dans le même conteneur, tel qu'un sous-formulaire, leur référence indique qu'ils partagent le même contexte. Lorsque des objets existent dans le même contexte, vous pouvez utiliser une syntaxe de référence abrégée comprenant uniquement le nom de l'objet suivi de la propriété ou de la méthode à accéder. Par exemple, dans le cadre de l'exemple précédent, la syntaxe de référence abrégée suivante accède à la valeur du champ txtCondition à partir de n'importe quel champ situé dans le sous-formulaire total :
    txtCondition.rawValue
Si deux objets existent dans des conteneurs différents, ils ne partagent pas le même contexte. Dans ce cas, vous pouvez utiliser une syntaxe de référence abrégée. Cependant, elle doit commencer par le nom de l'objet conteneur situé au niveau supérieur non commun aux deux objets. Ainsi, dans le cadre de la hiérarchie ci-dessus, la syntaxe de référence abrégée suivante indique la valeur du champ address du champ txtCondition :
    header.address.rawValue
En raison de la manière dont le modèle d'objet de formulaire XML est structuré, certaines propriétés et méthodes d'objet existent pour les objets enfant sur le formulaire. Ces objets enfant existent seulement en tant que parties du modèle d'objet de formulaire XML et n'apparaissent pas dans les palettes Hiérarchie et Vue des données. Pour accéder à ces propriétés et méthodes, vous devez inclure les objets enfant dans la syntaxe de référence. La syntaxe de référence suivante définit le texte d'info-bulle pour le champ txtCondition :
    txtCondition.assist.toolTip.value = "Conditions of purchase."  // FormCalc
    txtCondition.assist.toolTip.value = "Conditions of purchase."; // JavaScript
Pour plus d'informations sur les objets de modèle d'objet de formulaire XML et leur structure, voir Référence sur les objets de script.
Voir aussi
A propos des références aux objets dans les calculs et les scripts
Référence aux objets sans nom et aux objets répétés
Référence à l'objet actif
Raccourcis de la syntaxe de référence FormCalc


Référence aux objets sans nom et aux objets répétés

LiveCycle Designer prend en charge la fonctionnalité permettant de créer à la fois des objets sans nom et plusieurs objets portant le même nom. Vous pouvez établir des calculs et des scripts en vue d'accéder ou de remplacer les propriétés et les valeurs des objets sans nom à l'aide de la notation comportant une dièse (#), ainsi que les valeurs d'occurrence d'objet à l'aide de la notation comportant des crochets ([ ]). FormCalc interprète correctement la dièse (#) et les crochets ([ ]), mais pas JavaScript. Pour accéder à la valeur d'un champ de texte impliquant une dièse (#) ou des crochets ([ ]) avec JavaScript, vous devez utiliser la méthode resolveNode, ainsi qu'une syntaxe de référence complète ou abrégée.
Lorsque vous générez un formulaire vide, le nom du sous-formulaire représentant la page du formulaire correspond, par défaut, à un sous-formulaire sans nom doté de la valeur d'occurrence 0. L'illustration suivante présente la hiérarchie de formulaire sur un nouveau formulaire utilisant les conventions de dénomination d'objet par défaut.
Le sous-formulaire sans titre représentant la première page du formulaire porte le numéro d'occurrence 0. En pareil cas, les deux syntaxes de référence suivantes ont accès à la valeur du champ de texte dans la hiérarchie de formulaire ci-dessus sur un nouveau formulaire utilisant les conditions de dénomination par défaut :
    xfa.form.form1.#subform.TextField1.rawValue
    xfa.form.form1.#subform[0].TextField1.rawValue
par défaut, si vous ne précisez pas la valeur d'occurrence pour un objet, la syntaxe de référence accède à la première occurrence de l'objet.
FormCalc reconnaît la syntaxe de référence complète ci-dessus et l'interprète directement. Pour accéder à la même valeur à l'aide de JavaScript, vous devez utiliser un des formulaires de la méthode de script resolveNode :
    xfa.resolveNode("xfa.form.form1.#subform.TextField1").rawValue;
    xfa.resolveNode("xfa.form.form1.#subform[0].TextField1").rawValue;
Si vous ajoutez une nouvelle page au formulaire, le nom du sous-formulaire correspondant à la nouvelle page est, par défaut, sans nom. Toutefois, la valeur d'occurrence du nouveau sous-formulaire est 1. Vous pouvez désigner le nouveau sous-formulaire sans nom par une syntaxe de référence similaire :
    xfa.form.form1.#subform[1].TextField1.rawValue // FormCalc
    xfa.resolveNode("xfa.form.form1.#subform[1].TextField1").rawValue; // JavaScript
les options d'exécution d'instructions de l'éditeur de script incluent des objets sans nom au début de la liste. Les objets possédant plusieurs valeurs d'occurrence n'apparaissent qu'une fois dans la liste, la première occurrence seule étant indiquée. Si vous voulez accéder à une valeur d'occurrence différente de la première, vous devez ajouter manuellement cette valeur à la syntaxe de référence.
Utilisez la méthode resolveNode pour faire référence aux objets au sein des autres instructions de la syntaxe de référence. Ceci contribue à réduire le nombre total de scripts nécessaires pour faire référence à un objet, une propriété ou une méthode spécifique. Ainsi, vous pouvez simplifier la syntaxe menant à un champ de texte de la deuxième page de votre formulaire de la manière suivante :
    xfa.form.form1.resolveNode("#subform[1].TextField1").rawValue; // JavaScript
Pour plus de détails sur la méthode resolveNode, voir resolveNode.
Voir aussi
A propos des références aux objets dans les calculs et les scripts
Référence aux propriétés et aux valeurs d'objet
Référence à l'objet actif
Raccourcis de la syntaxe de référence FormCalc


Référence à l'objet actif

Si vous souhaitez modifier les propriétés ou les valeurs de l'objet actif à l'aide des calculs ou des scripts associés à l'objet lui-même, FormCalc et JavaScript recourent à des raccourcis uniques pour limiter la taille de la syntaxe de référence. FormCalc remplace l'objet actif par le symbole dollar ($) tandis que JavaScript utilise le mot-clé this.
L'exemple de syntaxe de référence suivante renvoie la valeur de l'objet actif :
    $ // FormCalc
    this.rawValue // JavaScript
De la même façon, vous pouvez utiliser le raccourci comportant le symbole dollar ($) et le mot-clé this à la place du nom de l'objet actif afin d'accéder aux propriétés et valeurs des objets de formulaires. L'exemple de syntaxe de référence suivant change le texte d'info-bulle associé à l'objet actif :
    $.assist.toolTip.value = "This is some tool tip text."     // FormCalc
    this.assist.toolTip.value = "This is some tool tip text."; // JavaScript
Voir aussi
A propos des références aux objets dans les calculs et les scripts
Référence aux propriétés et aux valeurs d'objet
Référence aux objets sans nom et aux objets répétés
Raccourcis de la syntaxe de référence FormCalc


Raccourcis de la syntaxe de référence FormCalc

Pour faciliter l'accès aux propriétés et aux valeurs et limiter votre travail, FormCalc offre des raccourcis pratiques pour créer des références. Le tableau suivant décrit les raccourcis de la syntaxe de référence pour FormCalc.

Notation

Description
$
Fait référence au champ ou à l'objet actuel, comme l'illustre cet exemple :
    $ = "Tony Blue"
L'exemple ci-dessus définit la valeur du champ ou de l'objet actuel sur Tony Blue.
$data
Représente la racine du modèle de données xfa.datasets.data. Par exemple :
    $data.purchaseOrder.total
est équivalent à
    xfa.datasets.data.purchaseOrder.total
$event
Représente l'événement d'objet de formulaire actif. Par exemple :
    $event.name
est équivalent à
    xfa.event.name
Pour plus de détails, voir A propos du modèle d'événement.
$form
Représente la racine du modèle de formulaire xfa.form. Par exemple :
    $form.purchaseOrder.tax
est équivalent à
    xfa.form.purchaseOrder.tax
$host
Représente l'objet hôte. Par exemple :
    $host.messageBox("Hello world")
est équivalent à
    xfa.host.messageBox("Hello world")
Pour plus de détails, voir A propos de l'utilisation d'une application hôte.
$layout
Représente la racine du modèle de disposition xfa.layout. Par exemple :
    $layout.ready
est équivalent à
    xfa.layout.ready
$record
Représente l'enregistrement actuel d'une collection de données, provenant d'un fichier XML par exemple. Par exemple :
    $record.header.txtOrderedByCity
référence le noeud txtOrderedByCity dans le noeud header des données XML actuelles.
$template
Représente la racine de la conception de modèle xfa.template. Par exemple :
    $template.purchaseOrder.item
est équivalent à
    xfa.template.purchaseOrder.item
!
Représente la racine du modèle de données xfa.datasets. Par exemple :
    !data
est équivalent à
    xfa.datasets.data
*
Sélectionne tous les objets de formulaire dans un conteneur donné (tel qu'un sous-formulaire), quel que soit le nom, ou sélectionne tous les objets ayant un nom similaire.
Par exemple, l'expression suivante sélectionne tous les objets nommés item sur un formulaire :
    xfa.form.form1.item[*]
..
Vous pouvez utiliser deux points à un endroit quelconque de votre syntaxe de référence pour rechercher des objets faisant partie de n'importe quel sous-conteneur du conteneur actuel (tel qu'un sous-formulaire). Par exemple, l'expression Subform_Page..Subform2 signifie rechercher le nœud Subform_Page (comme d'habitude) et trouver un descendant de Subform_Page appelé Subform2.
En se fondant sur l'arborescence ci-dessus,
    Subform_Page..TextField2
est équivalent à
    Subform_Page.Subform1[0].Subform3.TextField2[0]
puisque TextField2[0] est le premier nœud Subform1 que FormCalc rencontre lors de sa recherche. Deuxième exemple :
    Subform_Page..Subform3[*]
retourne les quatre instances de l'objet TextField2.
#
La notation # (signe dièse) est utilisée pour représenter l'un des éléments suivants dans une syntaxe de référence :
      •
      Un objet sans nom. Ainsi, la syntaxe de référence suivante accède à un sous-formulaire sans nom :

        xfa.form.form1.#subform
      •
      Une propriété dans une syntaxe de référence si une propriété et un objet possèdent le même nom. La syntaxe de référence suivante accède, par exemple, à la propriété name d'un sous-formulaire si ce dernier contient également un champ appelé name :

        xfa.form.form1.#subform.#name
[ ]
Le crochet ([ ]) représente la valeur d'occurrence d'un objet. Pour créer une référence à une valeur d'occurrence, placez des crochets ([ ]) après un nom d'objet et insérez entre les crochets l'une des valeurs suivantes :
      •
      [ n ], où n est un numéro d'index d'occurrence absolu commençant à 0. Un numéro d'occurrence hors limite renvoie une erreur. Par exemple :

        xfa.form.form1.#subform.Quantity[3]
        refers to the fourth occurrence of the Quantity object.
      •
      [ +/- n ], où n indique une occurrence relative à l'occurrence de l'objet porteur de la référence. Les valeurs positives retournent des nombres d'occurrences plus élevés alors que les valeurs négatives retournent des nombres d'occurrences plus bas. Par exemple :

         xfa.form.form1.#subform.Quantity[+2]

      Cette référence retourne l'occurrence de Quantity dont le nombre d'occurrences est deux de plus que le nombre d'occurrences du conteneur qui constitue la référence. Si, par exemple, cette référence était jointe à l'objet Quantity[2], la référence serait la même que :

         xfa.template.Quantity[4]

      Si le numéro d'index calculé est hors limite, la référence renvoie une erreur.

      Cette syntaxe sert surtout à localiser l'occurrence précédente ou suivante d'un objet en particulier. Par exemple, chaque occurrence de l'objet Quantity (sauf la première) peut utiliser Quantity[-1] pour obtenir la valeur de l'objet Quantity précédent.
      •
      [*] indique plusieurs occurrences d'un objet. Le premier objet nommé est trouvé, et les objets portant le même nom et ayant le même parent immédiat sont retournés. Le résultat de cette notation est une collection d'objets. Par exemple :

         xfa.form.form1.#subform.Quantity[*]

      Cette expression fait référence à tous les objets portant le nom Quantity et ayant le même parent immédiat que la première occurrence Quantity trouvée par la référence.
dans les formulaires en arabe, hébreu, thaï et vietnamien, la syntaxe de référence se trouve toujours à droite (même pour les langues s'écrivant de droite à gauche).
LiveCycle Forms 7.1 ne prend pas en charge les conceptions de formulaire contenant des polices relatives à l'arabe, l'hébreu, le thaï et le vietnamien.
[ ]
(suite)
L'arborescence servant de référence, les expressions suivantes retournent les résultats indiqués :
      •
      Subform_Page.Subform1[*] renvoie les deux objets Subform1.
      •
      Subform_Page.Subform1.Subform3.TextField2[*] renvoie les deux objets TextField2. Subform_Page.Subform1 a pour résultat le premier objet Subform1 à gauche et TextField2[*] est évalué relativement à l'objet Subform3.
      •
      Subform_Page.Subform1[*].TextField1 renvoie les deux instances TextField1. Subform_Page.Subform1[*] a pour résultat les deux objets Subform1 et TextField1 est évalué relativement aux objets Subform1.
      •
      Subform_Page.Subform1[*].Subform3.TextField2[1] renvoie le deuxième et le quatrième objet TextField2 à partir de la gauche. Subform_Page.Subform1[*] a pour résultat les deux objets Subform1 et TextField2[1] est évalué relativement aux objets Subform3.
      •
      Subform_Page.Subform1[*].Subform3[*] retourne les deux instances de l'objet Subform3.
      •
      Subform_Page.* retourne les deux objets Subform1 et l'objet Subform2.
      •
      Subform_Page.Subform2.* retourne les deux instances de l'objet NumericField2.
A propos des références aux objets dans les calculs et les scripts
Référence aux propriétés et aux valeurs d'objet
Référence aux objets sans nom et aux objets répétés
Référence à l'objet actif


Variables

A propos des variables
Attribution de noms aux variables
Pour définir une variable de texte
Pour visualiser une définition de variable de texte
Pour supprimer une variable de texte
Utilisation des variables dans les calculs et les scripts


A propos des variables

Vous pouvez définir des variables de texte dans LiveCycle Designer pour enregistrer des informations spécifiques à un emplacement central et accessible. Une variable agit généralement comme une balise d'emplacement pour un texte susceptible d'être modifié par la suite. Elle sert, par exemple, à stocker le titre d'une zone de message. Lorsque ce texte doit être modifié, il vous suffit alors d'ouvrir le formulaire ou le modèle concerné, et de mettre à jour le texte une seule fois à l'aide de la définition de variable. LiveCycle Designer propage automatiquement le nouveau texte dans toutes les instances de la variable insérée.
Vous pouvez créer, visualiser et supprimer des variables sans avoir recours aux scripts. Cependant, vous devez utiliser des scripts pour accéder aux valeurs enregistrées par des variables et les manipuler, ou pour appliquer les valeurs aux objets du formulaire.
les valeurs des variables de formulaire sont restaurées chaque fois que vous ouvrez un formulaire.
Avant de créer une variable, choisissez le nom de la variable et du texte qu'elle doit contenir. Les définitions de variables sont enregistrées en même temps que le formulaire ou le modèle.
Voir aussi
Attribution de noms aux variables
Pour définir une variable de texte
Pour visualiser une définition de variable de texte
Pour supprimer une variable de texte
Utilisation des variables dans les calculs et les scripts


Attribution de noms aux variables

Lors de l'exécution, des conflits de noms se produisent si les noms des variables sont identiques à ceux utilisés pour les méthodes et les propriétés du modèle d'objet XML ou à ceux des champs de la conception de formulaire. Ces conflits peuvent être à l'origine du renvoi de valeurs inattendues par les scripts. Il est donc important d'attribuer des noms uniques aux variables. Voici quelques exemples pratiques :
      •
      Utilisez le nom de la variable fieldWidth et fieldHeight plutôt que x et y.
      •
      Utilisez le nom d'objet de modèle de formulaire clientName plutôt que name.
les noms de variable distinguent les majuscules des minuscules et ne doivent contenir aucun espace.
Voir aussi
A propos des variables
Pour définir une variable de texte
Pour visualiser une définition de variable de texte
Pour supprimer une variable de texte
Utilisation des variables dans les calculs et les scripts


Pour définir une variable de texte

1.
Choisissez Fichier > Propriétés du formulaire.
2.
Dans le panneau Variables, cliquez sur Nouveau (Insérer) [image].
3.
Dans la liste Variables, tapez un seul nom pour la variable et appuyez sur Entrée. Les noms de variable distinguent les majuscules des minuscules et ne doivent contenir aucun espace.
4.
Cliquez une fois sur la zone à droite et tapez le texte que vous voulez associer à cette variable.
La variable apparaît dans la palette Hiérarchie au niveau formulaire.
Voir aussi
A propos des variables
Attribution de noms aux variables
Pour visualiser une définition de variable de texte
Pour supprimer une variable de texte
Utilisation des variables dans les calculs et les scripts


Pour visualiser une définition de variable de texte

1.
Choisissez Fichier > Propriétés du formulaire.
2.
Cliquez sur l'onglet Variables et sélectionnez la variable dans la liste Variables. Le texte associé est affiché dans la zone à droite.
Voir aussi
A propos des variables
Attribution de noms aux variables
Pour définir une variable de texte
Pour supprimer une variable de texte
Utilisation des variables dans les calculs et les scripts


Pour supprimer une variable de texte

1.
Choisissez Fichier > Propriétés du formulaire.
2.
Sélectionnez la variable dans le panneau Variables et cliquez sur Supprimer [image].
Voir aussi
A propos des variables
Attribution de noms aux variables
Pour définir une variable de texte
Pour visualiser une définition de variable de texte
Utilisation des variables dans les calculs et les scripts


Utilisation des variables dans les calculs et les scripts

Une fois que vous avez créé des variables de formulaire, il vous suffit de vous référer au nom de variable dans vos calculs et scripts pour obtenir la valeur de la variable.
lorsque vous nommez des variables, évitez d'utiliser des noms identiques aux noms des propriétés de modèle d'objet de formulaire XML, de méthodes ou de noms d'objet. Pour plus d'informations au sujet des propriétés de modèle d'objet de formulaire XML, des méthodes et des objets, voir Référence sur les objets de script.
Créons, par exemple, les définitions de variable de formulaire suivantes.

Nom de variable

Valeur
firstName
Tony
lastName
Bleu
age
32
Dans FormCalc, vous pouvez accéder aux valeurs de variable de la même manière que vous accédez aux valeurs de champ et d'objet. Dans cet exemple, les valeurs sont attribuées à trois champs différents.
TextField1 = firstName
TextField2 = lastName
NumericField1 = age
De même, vous pouvez aussi utiliser des variables dans des fonctions FormCalc, comme le montre cet exemple :
Concat( "Dear ", firstName, lastName )
Dans JavaScript, vous référencez des valeurs de variable à l'aide de la propriété .value au lieu de la propriété .rawValue utilisée pour les valeurs de champ et d'objet, comme l'illustre cet exemple.
TextField1.rawValue = firstName.value;
Voir aussi
A propos des variables
Attribution de noms aux variables
Pour définir une variable de texte
Pour visualiser une définition de variable de texte
Pour supprimer une variable de texte


Débogage des calculs et des scripts

A propos du débogage des calculs et des scripts
Affichage d'informations de débogage à l'aide de la méthode messageBox
Pour activer JavaScript Debugger pour LiveCycle Designer
Pour maintenir ouvert JavaScript Debugger dans LiveCycle Designer
Exécution de scripts dans JavaScript Console


A propos du débogage des calculs et des scripts

LiveCycle Designer propose différentes fonctions et stratégies pour le débogage des calculs et des scripts, en fonction du langage de script choisi.
Quel que soit le langage (FormCalc ou JavaScript), vous pouvez tirer parti de certaines fonctions LiveCycle Designer pour déboguer et tester vos scripts.
      •
      Le panneau Avertissements de la palette Rapport permet de vérifier les erreurs ou les messages générés par LiveCycle Designer. C'est dans ce panneau que sont consignées les actions signalées par LiveCycle Designer. Il est mis à jour lorsque vous affichez un aperçu de la conception de formulaire dans le panneau Aperçu PDF. Pour plus d'informations sur l'utilisation du panneau Avertissements et de l'espace de travail LiveCycle Designer lors du débogage de vos scripts, voir Utilisation de l'espace de travail pour le débogage des calculs et des scripts.
      •
      La méthode messageBox du modèle d'objet de formulaire XML permet d'extraire des informations d'un formulaire interactif dans une boîte de dialogue au moment de l'exécution. Pour plus d'informations sur l'utilisation de la méthode messageBox, voir messageBox.
      •
      Pour certains types de débogage, il peut être intéressant de produire des informations (valeurs de champs ou messages, par exemple) dans un champ de texte de votre conception de formulaire. Pourquoi, par exemple, ajouter de nouveaux messages ou de nouvelles valeurs dans un champ de texte pour créer un journal auquel vous pourrez vous référer lors de la résolution des problèmes.
Si vous disposez d’Acrobat Professional, vous pouvez utiliser l’outil JavaScript Debugger depuis Acrobat pour tester vos scripts de formulaires. JavaScript Debugger inclut la console JavaScript Console qui permet de vérifier des parties du code JavaScript dans le panneau Aperçu PDF. Cette console fournit une interface interactive et pratique pour contrôler des parties de code JavaScript et travailler sur les propriétés et méthodes d'objets. La console JavaScript Console est interactive : elle se comporte donc comme un éditeur permettant l'exécution de lignes uniques ou de blocs de code.
Pour plus d’informations sur JavaScript Console et JavaScript Debugger, voir le document Developing Acrobat Applications Using JavaScript à l’adresse partners.adobe.com/public/developer/acrobat/devcenter.html (en anglais uniquement).
Voir aussi
Affichage d'informations de débogage à l'aide de la méthode messageBox
Pour activer JavaScript Debugger pour LiveCycle Designer
Pour maintenir ouvert JavaScript Debugger dans LiveCycle Designer
Exécution de scripts dans JavaScript Console
Palette Rapport
Guide de référence FormCalc
Référence sur les objets de script


Affichage d'informations de débogage à l'aide de la méthode messageBox

Quel que soit le type de formulaire créé, la méthode messageBox du modèle d'objet de formulaire XML est très pratique pour afficher des messages ou des valeurs de champs au moment de l'exécution. Une fois lancée, la méthode messageBox se charge d'afficher une valeur de chaîne dans une nouvelle boîte de dialogue de l'application client. Il peut s'agit, en l'occurrence, d'un message de texte que vous rédigez à des fins de débogage ou de la valeur de chaîne de champs ou d'expressions.
Prenons un scénario dans lequel une simple conception de formulaire contient un seul champ numérique (NumericField1) et un bouton (Button1). Dans ce cas, le calcul FormCalc et le script JavaScript génèrent chacun un message présentant du texte et la valeur actuellement affichée dans le champ numérique. En ajoutant le calcul ou le script à l'événement click de l'objet de bouton, il est possible de présenter de façon interactive la valeur du champ numérique dans une nouvelle boîte de dialogue en cliquant sur le bouton.
FormCalc
    xfa.host.messageBox(Concat("The value of NumericField1 is: ",
        NumericField1), « Debugging », 3)
JavaScript
    xfa.host.messageBox("The value of NumericField1 is: " +
        NumericField1.rawValue, « Debugging », 3);
la méthode messageBox renvoie un nombre entier représentant le bouton que la personne remplissant le formulaire sélectionne dans la boîte de dialogue du message. Si vous associez la méthode messageBox à l'événement calculate d'un objet de champ et que la méthode messagebox est la dernière ligne du script, le champ affiche la valeur renvoyée par la méthode messageBox au moment de l'exécution.
Dans certains cas (si vous souhaitez renvoyer une zone de message lors d'un événement calculate, par exemple), vous pouvez tirer parti de la méthode alert du modèle d'objet JavaScript à partir d'Acrobat. Le script suivant renvoie, par exemple, la valeur d'un champ de texte :
    var oField = xfa.resolveNode("TextField1").rawValue;
    app.alert(oField);
Pour plus d’informations au sujet de la méthode alert et du modèle d'objet JavaScript de Acrobat, voir le document Developing Acrobat Applications Using JavaScript à l’adresse partners.adobe.com/public/developer/acrobat/devcenter.html (en anglais uniquement).
Voir aussi
A propos du débogage des calculs et des scripts
Pour activer JavaScript Debugger pour LiveCycle Designer
Pour maintenir ouvert JavaScript Debugger dans LiveCycle Designer
Exécution de scripts dans JavaScript Console
Utilisation de l'espace de travail pour le débogage des calculs et des scripts


Pour activer JavaScript Debugger pour LiveCycle Designer

Pour activer JavaScript Debugger pour LiveCycle Designer et exécuter du code depuis la console JavaScript, vous devez activer JavaScript et JavaScript Debugger dansAcrobat Professional. Vous devez activer JavaScript Debugger pour accéder à la console JavaScript, car la fenêtre de console est un composant de l'interface JavaScript Debugger.
vous pouvez activer JavaScript Debugger dans Adobe Reader si vous avez installé LiveCycle Reader Extensions. Pour activer JavaScript Debugger dans Adobe Reader, vous devez ouvrir le fichier debugger.js et modifier le registre Microsoft Windows. Pour plus d’informations sur l'activation de JavaScript Debugger dans Adobe Reader, voir le document Developing Acrobat Applications Using JavaScript à l’adresse partners.adobe.com/public/developer/acrobat/devcenter.html (en anglais uniquement).
1.
Lancez LiveCycle Designer.
2.
Lancez Acrobat Professional.
3.
Dans Acrobat Professional, choisissez Edition > Préférences.
4.
Sélectionnez JavaScript dans la liste située à gauche.
5.
Sélectionnez l’option d’activation d’Acrobat JavaScript si besoin est.
6.
Dans JavaScript Debugger, sélectionnez l’option indiquant qu’il faut activer JavaScript Debugger après le redémarrage d’Acrobat.
7.
Sélectionnez l'option d'activation de la console interactive. Cette option vous permet d'évaluer le code que vous écrivez dans la console JavaScript Console.
8.
Sélectionnez l'option d'affichage de la console lors d'erreurs et de messages. Cette option vous assure que la console affichera des informations utiles dès que vous ferez des erreurs.
9.
Cliquez sur OK pour fermer la boîte de dialogue Préférences.
10.
Quitte Acrobat Professional.
11.
Dans LiveCycle Designer, cliquez sur l'onglet Aperçu PDF.
12.
Appuyez sur Ctrl+J pour ouvrir JavaScript Debugger.
Voir aussi
A propos du débogage des calculs et des scripts
Affichage d'informations de débogage à l'aide de la méthode messageBox
Pour maintenir ouvert JavaScript Debugger dans LiveCycle Designer
Exécution de scripts dans JavaScript Console
Utilisation de l'espace de travail pour le débogage des calculs et des scripts


Pour maintenir ouvert JavaScript Debugger dans LiveCycle Designer

Si l'outil JavaScript Debugger était actif dans Acrobat et qu'il disparaît dès que vous cliquez sur des composants dans l'interface LiveCycle Designer, vous devez arrêter le processus Acrobat.exe dans le Gestionnaire des tâches de Microsoft Windows. Le processus Acrobat.exe continue de s'exécuter après la fermeture d'Acrobat de manière à ce qu’Acrobat puisse s'ouvrir plus vite en cas de redémarrage. L'interruption d'Acrobat.exe arrête l'association entre JavaScript Debugger et la session Acrobat Professional, ce qui permet d'utiliser JavaScript Debugger dans LiveCycle Designer.
1.
Dans le Gestionnaire des tâches de Windows, cliquez sur l'onglet Processus.
2.
Dans la colonne Nom de l'image, cliquez avec le bouton droit de la souris sur Acrobat.exe et choisissez Terminer le processus.
Voir aussi
A propos du débogage des calculs et des scripts
Affichage d'informations de débogage à l'aide de la méthode messageBox
Pour activer JavaScript Debugger pour LiveCycle Designer
Exécution de scripts dans JavaScript Console
Utilisation de l'espace de travail pour le débogage des calculs et des scripts


Exécution de scripts dans JavaScript Console

La console JavaScript d'Acrobat permet d'évaluer une ou plusieurs lignes de code.
Il existe trois moyens d'évaluer du code JavaScript au moyen de la console interactive JavaScript :
      •
      Pour évaluer une partie d'une ligne de code, mettez en évidence la partie souhaitée dans la fenêtre de la console, puis appuyez sur la touche Entrée du pavé numérique ou sur Ctrl+Entrée du clavier standard.
      •
      Pour évaluer une ligne de code, assurez-vous que le curseur est bien positionné sur la ligne souhaitée dans la fenêtre de la console, puis appuyez sur la touche Entrée du pavé numérique ou sur Ctrl+Entrée du clavier standard.
      •
      Pour évaluer plusieurs lignes de code, mettez en évidence les lignes souhaitées dans la fenêtre de la console, puis appuyez sur la touche Entrée du pavé numérique ou sur Ctrl+Entrée du clavier standard.
Dans tous les cas, le résultat de la dernière instruction JavaScript évaluée s'affiche dans la fenêtre de la console.
Après l'évaluation de chaque script JavaScript, la fenêtre de console imprime undefined, c'est-à-dire la valeur renvoyée de l'instruction. Notez que le résultat d'une instruction est différent de la valeur d'une expression dans l'instruction. La valeur renvoyée undefined ne signifie pas que la valeur du script est indéterminée : elle indique que la valeur retournée de l'instruction JavaScript est indéterminée.
Cliquez sur l'icône de la corbeille en bas à droite de la console pour supprimer le contenu apparaissant dans la fenêtre de la console.
Voir aussi
A propos du débogage des calculs et des scripts
Affichage d'informations de débogage à l'aide de la méthode messageBox
Pour activer JavaScript Debugger pour LiveCycle Designer
Pour maintenir ouvert JavaScript Debugger dans LiveCycle Designer
Utilisation de l'espace de travail pour le débogage des calculs et des scripts


Utilisation d'une application hôte

A propos de l'utilisation d'une application hôte
Comparaison des fonctionnalités du modèle de script hôte


A propos de l'utilisation d'une application hôte

L'application hôte est l'application qui héberge le formulaire à un moment donné. Si vous utilisez, par exemple, LiveCycle Forms pour générer un formulaire au format HTML, lors du stage de pré-rendu, l'application hôte sera LiveCycle Forms. Après avoir généré le formulaire, si vous le visualisez dans une application client telle que Acrobat, Adobe Reader ou un navigateur HTML, c'est l'application client qui fait office d'application hôte.
LiveCycle Designer inclut un modèle de script offrant des propriétés et des méthodes de création de script prévues pour interagir directement avec une application hôte. Vous pouvez, par exemple, vous servir des propriétés et des méthodes du modèle de script hôte pour assurer des actions de navigation dans les pages PDF dans Acrobat ou Adobe Reader, ou utiliser la méthode importData pour charger des données dans votre formulaire.
Il est possible de faire référence à la syntaxe du modèle de script hôte dans tout événement de scripting valide pour les objets de conception de formulaire utilisant la syntaxe suivante en langage FormCalc et JavaScript :
    xfa.host.property_or_method
Propriétés et méthodes du modèle de script hôte
A l'aide des propriétés et des méthodes du modèle de script hôte, vous pouvez rechercher des informations et exécuter des actions qui ne sont pas accessibles autrement par le biais de calculs et de scripts. Par exemple, vous pouvez rechercher le nom de l'application hôte (telle que Acrobat), ou avancer la page actuelle sur un formulaire interactif. Le tableau suivant présente les propriétés et les méthodes disponibles pour le modèle de script hôte.
Pour plus d'informations au sujet des propriétés et des méthodes du modèle de script hôte, reportez-vous au LiveCycle Developer Center accessible à l'adresse www.adobe.com/devnet/livecycle/.

Propriétés

Méthodes
appType
calculationsEnabled
currentPage
language
name
numPages
platform
title
validationsEnabled
variation
version
beep
exportData
gotoURL
importData
messageBox
pageDown
pageUp
print
resetData
response
setFocus
Voir aussi
Comparaison des fonctionnalités du modèle de script hôte
A propos des références aux objets dans les calculs et les scripts


Comparaison des fonctionnalités du modèle de script hôte

Le tableau suivant récapitule les propriétés et les méthodes du modèle de script hôte de LiveCycle Designer et les compare aux expressions équivalentes dans le modèle d'objet JavaScript de Acrobat.

Propriétés et méthodes du modèle de script hôte

Equivalent du modèle d'objet JavaScript

xfa.host.appType
app.viewerType
xfa.host.beep( [ INTEGER param ] )
app.beep([ nType ])
xfa.host.currentPage
doc.pageNum
xfa.host.exportData([ STRING param1 [,
    BOOLEAN param2 ] ])
doc.exportXFAData(cPath [, bXDP ])
xfa.host.gotoURL( STRING param1 [,
    BOOLEAN param2 ] )
doc.getURL(cURL, [ bAppend ])
xfa.host.importData( [ STRING param ] )
doc.importXFAData(cPath)
xfa.host.language
app.language
xfa.host.messageBox(STRING param1 [,
    STRING param2 [, INTEGER param3 [,
    INTEGER param4 ] ] ])
doc.alert(cMsg [, nIcon [, nType [,
    cTitle ] ] ])
xfa.host.name
none
xfa.host.numPages
doc.numPages
xfa.host.pageDown()
doc.pageNum++
xfa.host.pageUp()
doc.pageNum--
xfa.host.platform
app.platform
xfa.host.print(BOOLEAN param1, INTEGER
    param2, INTEGER param3, BOOLEAN
    param4, BOOLEAN param5, BOOLEAN
    param6, BOOLEAN param7, BOOLEAN
    param8)
doc.print([ bUI [, nStart [, nEnd [,
    bSilent [, bShrinkToFit [,
    bPrintAsImage [, bReverse [,
    bAnnotations ] ] ] ] ] ] ] ])
xfa.host.resetData( [ STRING param ] )
doc.resetForm([ aFields ])
xfa.host.response( STRING param1 [,
    STRING param2 [, STRING param3 [,
    BOOLEAN param4] ] ])
app.response(cQuestion [, cTitle [,
    cDefault [, bPassword ] ] ])
xfa.host.setFocus( STRING param )
field.setFocus()
xfa.host.title
doc.title
xfa.host.variation
app.viewerVariation
xfa.host.version
app.viewerVersion
Voir aussi
A propos de l'utilisation d'une application hôte


Utilisation du modèle d'événement

A propos du modèle d'événement
Propriétés et méthodes du modèle d'événement


A propos du modèle d'événement

Le modèle d'événement sert à stocker les propriétés d'événement objet. Ces propriétés s'avèrent utiles pour accéder aux valeurs qui sortiraient du cadre des événements présentés dans la liste Afficher de l'éditeur de script.
Le modèle d'événement contrôle les modifications dans un formulaire qui se produisent avant, pendant et après les actions, qu'il s'agisse d'événements de formulaire dynamique (stade auquel les données et la conception de formulaire sont fusionnées et avant la pagination) ou d'événements de formulaire interactif (moment auquel un utilisateur met à jour la valeur d'un champ).
Voir aussi
Propriétés et méthodes du modèle d'événement


Propriétés et méthodes du modèle d'événement

A l'aide des propriétés et des méthodes d'événement objet, vous pouvez rechercher des informations et exécuter des actions qui ne sont pas accessibles autrement par le biais de calculs et de scripts. Par exemple, vous pouvez rechercher la valeur complète d'un champ qui ferait partie des données retirées parce qu'elles sont trop longues ou invalides. L'extraction d'une valeur complète d'un champ est pratique lorsque vous devez procéder à des vérifications extensives d'erreurs.

Propriétés

Méthodes
change
className
commitKey
fullText
keyDown
modifier
name
newContentType
newText
prevContentType
prevText
reenter
selEnd
selStart
shift
soapFaultCode
soapFaultString
target
emit
reset
Voir aussi
A propos du modèle d'événement


Création et réutilisation des fonctions JavaScript

A propos de l'objet de script
Pour créer un objet de script
Pour ajouter un script à un objet de script
Pour référencer les fonctions JavaScript stockées dans un objet de script


A propos de l'objet de script

Un objet de script est un objet que vous pouvez utiliser pour stocker des fonctions JavaScript et des valeurs séparément de l'objet de formulaire proprement dit. En général, on utilise un objet de script pour créer des fonctions et des méthodes personnalisées que l'on veut utiliser sous forme de script JavaScript en différents endroits du formulaire. Cette technique réduit le nombre total de scripts requis pour réaliser des actions répétitives.
L'objet de script reconnaît uniquement les scripts écrits en langage JavaScript, mais il n'y a aucune restriction quant au lieu d'exécution des scripts (à condition d'avoir configuré le langage de script JavaScript pour l'événement faisant appel à l'objet de script). Acrobat et LiveCycle Forms traitent les scripts à partir d'un objet de script de la même manière, mais des différences demeurent. Seuls les scripts destinés à être exécutés sur le client peuvent utiliser des objets de script destinés à être exécutés sur le client, et réciproquement.
Voir aussi
Pour créer un objet de script
Pour ajouter un script à un objet de script
Pour référencer les fonctions JavaScript stockées dans un objet de script


Pour créer un objet de script

La création d'un objet de script se fait en deux temps. La première étape consiste à ajouter l'objet proprement dit à la conception de formulaire, et la seconde étape consiste à écrire le script que vous souhaitez enregistrer dans l'objet de script.
1.
Créez un nouveau formulaire ou ouvrez un formulaire existant.
2.
Dans la palette Hiérarchie, cliquez à l'aide du bouton droit sur un objet de niveau formulaire ou un objet de niveau sous-formulaire et choisissez Insérer un objet de script.
3.
(Facultatif) Cliquez à l'aide du bouton droit sur l'objet de script, et choisissez Renommer l'objet.
Voir aussi
A propos de l'objet de script
Pour ajouter un script à un objet de script
Pour référencer les fonctions JavaScript stockées dans un objet de script


Pour ajouter un script à un objet de script

Une fois que vous avez un objet de script dans votre formulaire, vous pouvez ajouter des scripts à l'aide de l'éditeur de script.
1.
Choisissez l'objet de script dans la palette Hiérarchie.
L'éditeur de script affiche à la fois une valeur de l'objet de script dans la liste Afficher, et la valeur JavaScript dans la liste Langage. Vous ne pouvez modifier aucune de ces valeurs.
2.
Entrez votre script dans le champ Source du script.
3.
Lorsque vous avez terminé, cliquez sur Insérer les changements dans la source du script [image] pour ajouter le script à votre formulaire.
Exemple
Créez, par exemple, un objet de script appelé feedback contenant la fonction suivante :
function emptyCheck(oField) {

    if ((oField.rawValue == null) || (oField.rawValue == "")) {
        xfa.host.messageBox("You must input a value for this field.", "Error Message", 3);
    }
}
Voir aussi
A propos de l'objet de script
Pour créer un objet de script
Pour référencer les fonctions JavaScript stockées dans un objet de script


Pour référencer les fonctions JavaScript stockées dans un objet de script

Après avoir ajouté des scripts à un objet de script, vous pouvez référencer l'objet de script à partir de tout événement compatible avec les scripts JavaScript.
1.
Sélectionnez un objet de votre formulaire et choisissez un événement dans la liste Afficher.
2.
Créez une référence à l'objet de script et aux fonctions voulues dans l'objet de script. La syntaxe générique suivante suppose que l'objet dans lequel vous référencez l'objet de script est au même niveau que l'objet de script dans la hiérarchie du formulaire ou que l'objet de script figure au niveau supérieur de la hiérarchie.

        script_object.function_name(parameter1, ...);
3.
Appliquez le nouveau script à l'objet de formulaire et testez-le en prévisualisant le formulaire à partir du panneau Aperçu PDF.
Comme lors du référencement d'autres objets dans un formulaire, vous devez spécifier une syntaxe valide lorsque vous référencez l'objet de script en indiquant son emplacement au sein de la hiérarchie. Pour plus d'informations au sujet du référencement des objets dans un script, voir Référence aux propriétés et aux valeurs d'objet.
Exemple
En vous basant sur l'exemple d'objet de script de la section Pour ajouter un script à un objet de script, appliquez le script JavaScript suivant à l'événement exit pour un champ de texte. Testez le formulaire à partir du panneau Aperçu PDF.
    feedback.emptyCheck(this);
Voir aussi
A propos de l'objet de script
Pour créer un objet de script
Pour ajouter un script à un objet de script


Conversion des scripts Acrobat en scripts LiveCycle Designer

A propos de la conversion des scripts Acrobat en scripts LiveCycle Designer
Conversion de formulaires Acrobat contenant des scripts
Utilisation d'objets JavaScript d'Acrobat dans LiveCycle Designer
Objets JavaScript d'Acrobat pris en charge dans LiveCycle Designer


A propos de la conversion des scripts Acrobat en scripts LiveCycle Designer

LiveCycle Designer offre des fonctions de script étendues et prend même en charge les objets JavaScript les plus courants provenant d'Acrobat. Lorsque vous convertissez un formulaire Acrobat au format LiveCycle Designer, la plupart des scripts JavaScript continuent de fonctionner normalement sans aucune modification. Il convient, cependant, de convertir manuellement certains scripts JavaScript provenant d'Acrobat pour qu'ils se comportent de la même manière dans votre formulaire Acrobat.
Lors de la conversion de scripts sur votre formulaire Acrobat, notez les différences suivantes en matière de création de scripts dans LiveCycle Designer et dans Acrobat :
    • Espace de travail LiveCycle Designer
Dans l'espace de travail LiveCycle Designer, il est possible de changer les propriétés et les comportements des objets sur votre formulaire sans qu'il soit nécessaire de créer des scripts.
    • Langages de script
LiveCycle Designer gère aussi bien le langage JavaScript que le langage FormCalc (langage de calcul simple). FormCalc offre des fonctions intégrées permettant d'effectuer diverses opérations correspondant à des scripts complexes.
    • Référence aux objets, propriétés et méthodes
Compte tenu de la nature très structurée des formulaires LiveCycle Designer, il est nécessaire d'inclure la syntaxe de référence appropriée dans votre script pour faire référence à des objets, propriétés ou méthodes spécifiques. Pour vous faciliter la tâche, vous pouvez tirer parti des options d'exécution d'instructions dans l'éditeur de script.
Vous pouvez continuer à utiliser dans LiveCycle Designer les objets, propriétés et méthodes JavaScript provenant d'Acrobat. Utilisez de préférence JavaScript depuis Acrobat uniquement pour gérer les tâches liées à l'application où figure le formulaire et que vous ne pouvez pas reproduire dans LiveCycle Designer. Servez-vous par exemple de JavaScript depuis Acrobat pour ajouter des pièces jointes, des signets et des annotations, effectuer des recherches ou une vérification orthographique dans le formulaire, créer des rapports ou accéder à des métadonnées et les manipuler. JavaScript dans Acrobat ne permet pas, en revanche, de définir des valeurs de champ, d'ajouter de nouveaux champs dans un formulaire ou de supprimer des pages d'un formulaire.
vous ne pouvez pas utiliser Acrobat pour ajouter des scripts JavaScript à un formulaire LiveCycle Designer, y compris les formulaires Acrobat que vous avez convertis à l'aide de LiveCycle Designer. Lorsque vous affichez un formulaire LiveCycle Designer dans Acrobat, vous avez accès à aucun des outils JavaScript.
Pour plus d'informations au sujet de la conversion de scripts Acrobat sous LiveCycle Designer, lisez l'article Converting Acrobat JavaScript for Use in LiveCycle Designer Forms figurant sur le Developer Center LiveCycle à l'adresse suivante : www.adobe.com/devnet/livecycle/.
Voir aussi
Conversion de formulaires Acrobat contenant des scripts


Conversion de formulaires Acrobat contenant des scripts

L'une des premières choses à faire lorsque vous décidez de convertir un formulaire Acrobat sous LiveCycle Designer est de déterminer la proportion des scripts Acrobat pris en charge par LiveCycle Designer et à évaluer le nombre de scripts à convertir.
En règle générale, il est conseillé de convertir tous les scripts Acrobat sous leur forme équivalente dans LiveCycle Designer. Les scripts LiveCycle Designer tirent pleinement parti de la nature hautement structurée des formulaires LiveCycle Designer, ainsi que des caractéristiques propres aux formulaires. La conception et la mise en oeuvre de votre solution de formulaire n'en est que plus aisée et rapide.
Les scripts Acrobat à préserver sont ceux qui ont trait à l'environnement du formulaire et aux opérations périphériques (telles que l'ajout de pièces jointes ou de contenu multimédia, l'exécution de recherches ou la création de rapports et le traitement des métadonnées).
Pour plus d'informations au sujet de la conversion de scripts Acrobat sous LiveCycle Designer, lisez l'article Converting Acrobat JavaScript for Use in LiveCycle Designer Forms figurant sur le Developer Center LiveCycle Designer à l'adresse suivante : www.adobe.com/devnet/livecycle/.
Voir aussi
A propos de la conversion des scripts Acrobat en scripts LiveCycle Designer
Utilisation d'objets JavaScript d'Acrobat dans LiveCycle Designer
Objets JavaScript d'Acrobat pris en charge dans LiveCycle Designer


Utilisation d'objets JavaScript d'Acrobat dans LiveCycle Designer

Dans LiveCycle Designer, vous pouvez appliquer des scripts à certains objets JavaScript dans Acrobat en faisant appel à la syntaxe de script d'Acrobat. Il est donc possible d'utiliser les propriétés et les méthodes de ces objets sur votre formulaire. Par exemple, si vous voulez afficher un message à l'intention de l'utilisateur, vous pouvez ajouter le script suivant à l'événement d'un objet de conception de formulaire dans LiveCycle Designer :
app.alert("This is an Acrobat alert message.");
Vous pouvez également demander la transmission du formulaire par messagerie en ajoutant le script suivant à l'événement click d'un bouton :
var myDoc = event.target;
myDoc.mailDoc(true);
dans LiveCycle Designer, vous devez vous assurer de choisir le langage JavaScript pour l'événement afin que le script soit exécuté correctement.
Vous pouvez utiliser également des références dans les objets JavaScript d'Acrobat dans votre syntaxe de référence. Par exemple, le script suivant extrait l’état signé d’un champ de signature de document, puis exécute une action en fonction de l’état récupéré :
        // Proceed if the current field is not signed.
        var oState = event.target.getField("form1[0].#subform[0].SignatureField1[0]").signatureValidate(); //Get the field's signed state.

if (oState == 0) {
...
}
cet exemple utilise une syntaxe de référence complète pour référencer le texte. Pour plus d'informations sur le référencement des objets de conception de formulaire, voir Référence aux propriétés et aux valeurs d'objet.
Lorsque vous travaillez avec JavaScript à partir d'Acrobat dans LiveCycle Designer, tenez compte des points suivants :
      •
      Dans LiveCycle Designer, utilisez event.target pour accéder à l'objet JavaScript Doc à partir d'Acrobat. Dans Acrobat, l'objet this sert à référencer l'objet Doc. Cependant, dans LiveCycle Designer, l'objet this fait référence à l'objet de conception de formulaire auquel le script est attaché.
      •
      L'éditeur de script ne comporte pas de fin d’exécution des instructions pour les objets JavaScript à partir d'Acrobat. Reportez-vous au document de référence JavaScript pour Acrobat API dans le Family Developer Center Acrobat à l'adresse suivante : partners.adobe.com/public/developer/acrobat/devcenter.html.
Pour plus d'informations au sujet de la conversion de scripts Acrobat sous LiveCycle Designer, lisez l'article Converting Acrobat JavaScript for Use in LiveCycle Designer Forms figurant sur le Developer Center LiveCycle à l'adresse suivante : www.adobe.com/devnet/livecycle/.
Voir aussi
A propos de la conversion des scripts Acrobat en scripts LiveCycle Designer
Conversion de formulaires Acrobat contenant des scripts


Objets JavaScript d'Acrobat pris en charge dans LiveCycle Designer

Le tableau suivant répertorie les objets, les propriétés et les méthodes Acrobat les plus fréquemment utilisés dans LiveCycle Designer et décrit les fonctions équivalentes dans LiveCycle Designer. Bien que le tableau présente la plupart des objets, propriétés et méthodes Acrobat, ceux qui sont rarement utilisés dans les formulaires (comme les objets multimédia) ont été volontairement omis.
Lorsqu'aucune fonctionnalité LiveCycle Designer équivalente n'est citée, cela signifie qu'il n'existe pas de propriété ou méthode LiveCycle Designer directe pour reproduire le comportement d'Acrobat. Il est toujours possible, cependant, de créer des fonctions ou des scripts personnalisés pour obtenir le résultat de la fonction Acrobat.

JavaScript dans Acrobat

LiveCycle
LiceCycle
Designer

Equivalent JavaScript dans LiveCycle Designer

Commentaires
Propriétés et méthodes d'objet Annot
Toutes les propriétés et les méthodes
Oui
Non
Seuls les formulaires avec une disposition fixe prennent en charge le calque des annotations.
app propriétés de l’objet

calculate
Non
Non
LiveCycle Designer inclut la méthode execCalculate qui déclenche l'événement calculate.

language
Oui

xfa.host.language
Voir la propriété language.

monitors
Oui
Non

platform
Oui

xfa.host.platform
Voir la propriété platform.

plugins
Oui
Non

toolbar
Oui
Non

viewerType
Oui

xfa.host.appType
Voir la propriété appType.

viewerVariation
Oui

xfa.host.variation
Voir la propriété variation.

viewerVersion
Oui

xfa.host.version
Voir la propriété version.
app méthodes d'objet

addMenuItem
Oui
Non

addSubMenu
Oui
Non

addToolButton
Oui
Non

alert
Oui

xfa.host.messageBox()
Voir la méthode messageBox.

beep
Oui

xfa.host.beep()
Voir la méthode beep.

browseForDoc
Oui
Non

clearInterval
Oui
Non

clearTimeOut
Oui
Non

execDialog
Oui
Non

execMenuItem
Oui
Non
Exécute la commande de menu spécifiée. Utilisez cette méthode dans LiveCycle Designer pour les commandes du menu Fichier.

getNthPluginName
Oui
Non

getPath
Oui
Non

goBack
Oui
Non

goForward
Oui
Non

hideMenuItem
Oui
Non

hideToolbarButton
Oui
Non

launchURL
Oui
Non
LiveCycle Designer inclut la méthode gotoURL qui charge un URL spécifique dans l'application client, telle qu'Acrobat ou Adobe Reader.

listMenuItems
Oui
Non

listToolbarButtons
Oui
Non

mailGetAddrs
Oui
Non

mailMsg
Oui
Non

newDoc
Oui
Non
Cette méthode ne peut être exécutée que lors des événements de traitement par lot, de console ou de menu.

newFDF
Non
Non

openDoc
Oui
Non

openFDF
Non
Non

popUpMenuEx
Oui
Non

popUpMenu
Oui
Non

removeToolButton
Oui
Non

response
Oui

xfa.host.response()
Voir la méthode response.

setInterval
Oui
Non

setTimeOut
Oui
Non

trustedFunction
Oui
Non

trustPropagatorFunction
Oui
Non
Cette méthode est disponible uniquement lors de l'initialisation du traitement par lot, de la console et de l'application.
Propriétés et méthodes d'objet de signet
Toutes les propriétés et les méthodes
Oui
Non
doc propriétés de l’objet

author
Oui
Non

baseURL
Oui
Non

bookmarkRoot
Oui
Non

calculate
Non
Non

dataObjects
Oui
Non

delay
Non
Non

dirty
Oui
Non
Ce script Javascript LiveCycle Designer a pour effet d'enregistrer une copie d'un formulaire et de vérifier si le formulaire a changé :
var sOrigXML = xfa.data.saveXML;
if (sOrigXML != xfa.data.saveXML)
{...}

disclosed
Oui
Non

documentFileName
Oui
Non

dynamicXFAForm
Oui
Non

external
Oui
Non

filesize
Oui
Non

hidden
Oui
Non

icons
Oui
Non

keywords
Oui
Non

layout
Oui
Non

media
Oui
Non

metadata
Oui

xfa.form.desc
Voir l'objet desc.

modDate
Oui
Non

mouseX
mouseY
Oui
Non

noautocomplete
Oui
Non

nocache
Oui
Non

numFields
Oui

xfa.layout.pageContent()
La méthode pageContent renvoie une liste de tous les objets d'un type particulier. Cependant, vous devez exécuter la méthode pour les pages de contenu et les pages type afin de numériser la totalité du formulaire.

numPages
Oui

xfa.host.numPages
ou
xfa.layout.absPageCount()
xfa.layout.pageCount()
La propriété numPages renvoie le nombre de pages du formulaire fini dans le client. Voir aussi les méthodes absPageCount et pageCount.

pageNum
Oui

xfa.host.currentPage
Voir la propriété currentPage.

pageNum--
Oui

xfa.host.currentPage--
ou
xfa.host.pageUp()
Voir la propriété currentPage ou la méthode pageUp.

pageNum++
Oui

xfa.host.currentPage++
ou
xfa.host.pageDown()
Voir la propriété currentPage ou la méthode pageDown.

path
Oui
Non

securityHandler
Oui
Non

templates
Non
Non
Utilisez les objets de sous-formulaire dans LiveCycle Designer et servez-vous des propriétés et des méthodes pour ajouter, supprimer, déplacer et configurer les instances de sous-formulaire.
Pour plus de détails, voir Pour ajouter et supprimer des instances de sous-formulaire à l'aide de scripts.

title
Oui

xfa.host.title
Voir la propriété title.
doc méthodes d'objet

addAnnot
Oui
Non

addField
Non
Non
Vous devez utiliser impérativement des formulaires avec une disposition souple dans LiveCycle Designer, puis masquer et afficher les champs à l'aide de la propriété presence.

addIcon
Oui
Non

addLink
Non
Non

addRecipientListCryptFilter
Oui
Non

addScript
Oui
Non

addThumbnails
Non
Non

addWatermarkFromFile
Oui
Non

addWatermarkFromText
Oui
Non

addWeblinks
Oui
Non

appRightsSign
Oui
Non

appRightsValidate
Oui
Non

bringToFront
Oui
Non

calculateNow
Non

xfa.form.recalculate(1);
ou
execCalculate()
La méthode recalculate force l'exécution d'un jeu spécifique de scripts sur des événements calculate à lancer. La valeur booléenne indique si la condition est vraie (True (par défaut) - tous les scripts de calcul sont exécutés) ou fausse (False - seuls les scripts de calcul en attente sont exécutés).
LiveCycle Designer L'objet calculate contrôle si la personne remplissant le formulaire peut écraser ou non la valeur calculée d'un champ.
Vous pouvez également utiliser la méthode execCalculate pour chaque objet pour lequel vous souhaitez forcer la répétition des calculs.

closeDoc
Oui
Non

createDataObject
Oui
Non

createTemplate
Non
Non
Les formulaires LiveCycle Designer n'ont pas d'équivalent en ce qui concerne le concept de modèle Acrobat. Vous devez utiliser des objets de sous-formulaire dans LiveCycle Designer.

deletePages
Non
Non
Dans LiveCycle Designer vous pouvez utiliser l'objet instanceManager pour supprimer l'objet de sous-formulaire représentant une page de votre formulaire.
Pour plus de détails, voir Pour ajouter et supprimer des instances de sous-formulaire à l'aide de scripts.

embedDocAsDataObject
Oui
Non

encryptForRecipients
Oui
Non

encryptUsingPolicy
Oui
Non

exportAsText
Oui
Non
Cette méthode est uniquement disponible dans la console JavaScript de l'outil JavaScript Debugger dans Acrobat ou au cours d'un traitement par lot.

exportAsFDF
Non

xfa.host.exportData()
La méthode exportData exporte un fichier XML ou XDP au lieu d'un fichier FDF.

exportAsXFDF
Non

xfa.host.exportData()
La méthode exportData exporte un fichier XML ou XDP au lieu d'un fichier FDF.

exportDataObject
Oui
Non

exportXFAData
Non

xfa.host.exportData()
La méthode exportData exporte un fichier XML ou XDP au lieu d'un fichier FDF.

extractPages
Non
Non

flattenPages
Oui
Non

getAnnot
Oui
Non

getAnnots
Oui
Non

getDataObjectContents
Oui
Non

getField("FieldName")
Oui

xfa.resolveNode
(« FieldName« )
La méthode resolveNode accède à l'objet spécifié dans le fichier XML source du formulaire.

getLegalWarnings
Oui
Non

getLinks
Non
Non

getNthFieldName
Oui
Vous devez effectuer une boucle à travers tous les objets ayant un nom de classe similaire jusqu'à ce que vous atteigniez la nth occurrence.
Voir la propriété className.

getNthTemplate
Non
Non

getOCGs
Oui
Non

getOCGOrder
Oui
Non

getPageBox
Oui
Non

getPageLabel
Oui
Non

getPageNthWord
Oui
Non

getPageNthWordQuads
Oui
Non

getPageNumWords
Oui
Non

getPageRotation
Oui
Non

getPrintParams
Oui
Non

getTemplate
Non
Non

getURL
Oui

xfa.host.gotoURL(
« http://www.adobe.com »);
Voir la méthode gotoURL.

gotoNamedDest
Non
Non

importAnFDF
Non
Non

importAnXFDF
Oui
Non

importDataObject
Oui
Non

importIcon
Oui
Non

importTextData
Oui
Non

importXFAData
Non

xfa.host.importData
(« filename.xdp »);
Voir la méthode importData.

insertPages
Non
Non

mailDoc
Oui
Non

mailForm
Non
Non

movePage
Non
Non

newPage
Non
Non

openDataObject
Oui
Non

print
Oui

xfa.host.print();
Voir la méthode print.

removeDataObject
Oui
Non

removeField
Non
Non

removeIcon
Oui
Non

removeLinks
Non
Non

removeScript
Oui
Non

removeTemplate
Non
Non

removeThumbnails
Non
Non

removeWeblinks
Oui
Non

replacePages
Non
Non
resetForm
Non

xfa.host.resetData()
ou
xfa.event.reset()
La méthode resetData rétablie toutes la valeurs des champs d'un formulaire à leurs valeurs par défaut. La méthode reset rétablie toutes les propriétés au sein d'un modèle d'événement.
saveAs
Oui
Non
Dans LiveCycle Designer, le fichier doit être enregistré au niveau de l'application. Ces scripts sont des exemples d'enregistrement au niveau de application :
app.executeMenuItem
("SaveAs");
ou
var myDoc = event.target; myDoc.saveAs();

spawnPageFromTemplate
Non
Non

setAction
Non
Non

setPageLabel
Oui
Non

setPageRotation
Non
Non

setPageTabOrder
Non
Non
Dans LiveCycle Designer, choisissez Edition > Ordre de tabulation pour définir l'ordre de tabulation.

setScript
Non
Non

submitForm
Oui
Utilisez l'un des objets de bouton d'envoi dans LiveCycle Designer.
event propriétés de l’objet

change
Oui

xfa.event.change
Voir la propriété change.

targetName
Oui

xfa.event.target
Voir la propriété target.
field propriétés de l’objet

comb
Non
Non

charLimit
Non

this.value.#text.maxChars
Dans les formulaires avec une disposition fixe, le nombre limite de caractères peut être défini dans l'espace de travail LiveCycle Designer. Vous pouvez configurer des champs sur les formulaires prévus pour évoluer en fonction du volume de données.
Pour plus de détails, voir maxChars.

display = display.noView
Non
In the prePrint event:
this.presence =
"visible"
In the postPrint event:
this.presence =
invisible"
Vous pouvez également définir la propriété presence dans l'espace de travail LiveCycle Designer.

display = display.noPrint
Non
In the prePrint event:
this.presence = "invisible"
In the postPrint event:
this.presence =
"visible"
Vous pouvez également définir la propriété presence dans l'espace de travail LiveCycle Designer.

defaultValue
Non
Non
Définissez la valeur de champ par défaut dans l'espace de travail LiveCycle Designer.

exportValues
Non
Non
Définissez la valeur d'exportation dans l'espace de travail LiveCycle Designer.

fillColor
Non

xfa.form.Form1.
NumericField1.fillColor
Voir la propriété fillColor.

hidden
Non

this.presence = "invisible" this.
presence = « visible »
Vous pouvez également définir la propriété presence dans l'espace de travail LiveCycle Designer.

multiline
Non

this.ui.textEdit.multiLine
= « 1 »;
Voir la propriété multiLine.

password
Non
Non
LiveCycle Designer contient un champ de mot de passe utilisable sur un formulaire.

page
Non
Non
Ne s'applique pas aux formulaires LiveCycle Designer.

print
Non

this.relevant = "-print";
Voir la propriété relevant.

radiosInUnison
Non
Non
Les boutons radio en groupes dans LiveCycle Designer sont mutuellement exclusifs par défaut.

rect
Oui
Vous pouvez obtenir la hauteur et la largeur d'un champ de formulaire LiveCycle Designer à l'aide de la syntaxe de référence suivante :
this.h;
this.w;
Vous pouvez également obtenir les coordonnées x et y d'un objet à l'aide de la syntaxe de référence suivante :
this.x;
this.y;
Voir les propriétés h, w, x et y.

required
Non

this.mandatory = "error";
ou
this.validate.nullTest = "error";
Voir les propriétés mandatory et nullTest.

textColor
Non

this.fontColor
Voir la propriété fontColor.

textSize
Non

this.font.size
Voir la propriété size.

textFont
Non

this.font.typeface
Voir la propriété typeface.

value
Non

this.rawValue
Voir la propriété rawValue.
les champs LiveCycle Designer ont une propriété value ; celle-ci n'est pas équivalente à la propriété Acrobat value.
field méthodes d'objet

clearItems
Non

DropDownList1.clearItems();
La méthode clearItems s'applique uniquement aux objets de liste déroulante et aux objets de zones de liste dans LiveCycle Designer.

deleteItemAt
Non
Non

getItemAt
Non
Non

insertItemAt
Non

DropDownList1.addItem(
.....)
Voir la méthode addItem.

isBoxChecked
Non

if(CheckBox1.rawValue
== 1)....
Voir la propriété rawValue.

isDefaultChecked
Non
Non

setAction
Non
Non
Ne s'applique pas aux formulaires LiveCycle Designer.

setFocus
Oui

xfa.host.setFocus
("TextField1")
La méthode setFocus exige que l'objet spécifié ait un nom unique par rapport aux autres objets sur votre formulaire.

setItems
Non
Non

setLock
Oui
Non

signatureGetModifications
Oui
Non

signatureGetSeedValue
Oui
Non

signatureInfo
Oui
Non

signatureSetSeedValue
Oui
Non

signatureSign
Oui
Non

signatureValidate
Oui
Non
search méthode d'objet

search.query("<your text>");
Oui
Non
La syntaxe FormCalc abrégée vous permet de rechercher des objets au sein du modèle d'objet de formulaire XML.
Pour plus de détails, voir Raccourcis de la syntaxe de référence FormCalc.
SOAP méthode d'objet
Toutes les propriétés et les méthodes
Oui
Non
Voir aussi
A propos du modèle d'événement


Exemples de tâches de script courantes

A propos des exemples de script
Modification des couleurs d'arrière-plan des champs, des zones remplissables et des sous-formulaires
Masquage et affichage d'objets
Modification des propriétés visuelles d'un objet sur le client
Obtention de la valeur actuelle ou de la valeur précédente d'une liste déroulante
Ajustement de la hauteur d'un champ au moment de l'exécution
Définition d'une valeur de champ obligatoire au moment de l'exécution
Calcul des sommes d'un champ
Mise en surbrillance des champs en réponse aux interactions de l'utilisateur final
Réinitialisation des valeurs du sous-formulaire actif
Modification de la visibilité d'un objet de conception de formulaire
Utilisation des propriétés du gestionnaire d'instances pour contrôler les sous-formulaires
Utilisation des méthodes du gestionnaire d'instances pour contrôler les sous-formulaires
Utilisation du gestionnaire d'instances pour contrôler les sous-formulaires au moment de l'exécution


A propos des exemples de script

Les exemples de script vous proposent des techniques rapides et simples que vous pouvez appliquer à vos travaux personnels.
Pour obtenir davantage d'exemples et d'idées, visitez le site Web de LiveCycle Developer Center à l'adresse suivante : www.adobe.com/devnet/livecycle.


Modification des couleurs d'arrière-plan des champs, des zones remplissables et des sous-formulaires

Cet exemple vous montre comment modifier la couleur d'arrière-plan des sous-formulaires, des champs et des zones remplissables en réponse aux interactions de l'utilisateur final au moment de l'exécution.
Dans cet exemple, un simple clic sur un bouton permet de modifier la couleur d'arrière-plan de l'objet associé.
pour pouvoir modifier la couleur d'arrière-plan des objets au moment de l'exécution, vous devez enregistrer votre formulaire comme formulaire XML dynamique Acrobat.
Pour visualiser cet exemple de script et en obtenir d'autres, visitez le site Web de LiveCycle Developer Center à l'adresse suivante : www.adobe.com/devnet/livecycle.
Script pour les couleurs d'arrière-plan des sous-formulaires et des champs de texte
Pour définir les couleurs d'arrière-plan des sous-formulaires et des champs de texte, utilisez la méthode fillColor. Par exemple, la ligne suivante constitue le script pour les sous-formulaires :
    Subform1.fillColor = "17,136,255";
Les lignes suivantes constituent le script pour la couleur d'arrière-plan des champs de texte :
    Subform1.Name.fillColor = "102,179,255";
    Subform1.Address.fillColor = "102,179,255";
    Subform1.City.fillColor = "102,179,255";
    Subform1.State.fillColor = "102,179,255";
    Subform1.ZipCode.fillColor = "102,179,255";
    Subform1.Country.fillColor = "102,179,255";
Script pour la couleur d'arrière-plan des zones remplissables
Lorsque vous définissez la couleur d'arrière-plan ou la zone remplissable de chaque champ de texte, vos scripts doivent accéder à des propriétés nécessitant une expression de syntaxe de référence et incluant le symbole (#). Etant donné que JavaScript n'interprète pas correctement le symbole (#) dans les expressions de syntaxe de référence, le script utilise la méthode resolveNode pour résoudre l'expression.
    xfa.resolveNode("Subform1.Name.ui.#textEdit.border.fill.color").value = "153,204,255";
    xfa.resolveNode("Subform1.Address.ui.#textEdit.border.fill.color").value = "153,204,255";
    xfa.resolveNode("Subform1.City.ui.#textEdit.border.fill.color").value = "153,204,255";
    xfa.resolveNode("Subform1.State.ui.#textEdit.border.fill.color").value = "153,204,255";
    xfa.resolveNode("Subform1.ZipCode.ui.#textEdit.border.fill.color").value = "153,204,255";
    xfa.resolveNode("Subform1.Country.ui.#textEdit.border.fill.color").value = "153,204,255";
Script pour le bouton Effacer tout
Le script pour le bouton Effacer tout utilise la méthode remerge pour fusionner à nouveau la conception de formulaire et les données de formulaire. Dans le cas présent, la méthode rétablie efficacement les champs, les zones remplissables et les sous-formulaires à leur état d'origine.
    xfa.form.remerge();


Masquage et affichage d'objets

Cet exemple vous explique comment masquer les boutons lors de l'impression d'un formulaire ; il vous explique également comment masquer et afficher des objets en modifiant les valeurs de visibilité au moment de l'exécution.
Dans cet exemple, tous les objets de formulaire sont affichés dans le formulaire.
Grâce aux listes déroulantes de la zone Valeurs de visibilité, l'utilisateur peut afficher ou masquer les objets. Dans le diagramme suivant, le champ d'adresse est masqué et la disposition du formulaire est ajustée en conséquence. Le bouton Formulaire pour impression est également visible.
pour afficher et masquer les objets au moment de l'exécution, vous devez enregistrer votre formulaire comme formulaire PDF dynamique Acrobat.
Pour visualiser cet exemple de script et en obtenir d'autres, visitez le site Web de LiveCycle Developer Center à l'adresse suivante : www.adobe.com/devnet/livecycle.
Script pour les valeurs de visibilité des sous-formulaires
Le script pour les valeurs de visibilité des sous-formulaires utilise une instruction de commutation pour gérer les trois options de visibilité qu'un utilisateur peut appliquer à l'objet de sous-formulaire :
switch(xfa.event.newText) {
    case 'Invisible':
        Subform1.presence = "invisible";
        break;
    case 'Hidden (Exclude from Layout)':
        Subform1.presence = "hidden";
        break;
    default:
        Subform1.presence = "visible";
        break;
}
Script pour les valeurs de visibilité des champs de texte
Le script pour les valeurs de visibilité des champs de texte nécessite deux variables. La première variable enregistre le nombre d'objets contenus dans le Sous-formulaire1 :
    var nSubLength = Subform1.nodes.length;
La deuxième variable enregistre le nom du champ de texte que l'utilisateur sélectionne dans la liste déroulante Champs de texte :
    var sSelectField = fieldList.rawValue;
Le script suivant utilise la méthode replace pour supprimer tous les espaces contenus dans le nom du champ enregistré dans la variable sSelectField afin que la valeur de la liste déroulante corresponde au nom de l'objet dans la palette Hiérarchie :
    sSelectField = sSelectField.replace(' ', '');
Ce script utilise une boucle For pour passer en revue tous les objets contenus dans le Sous-formulaire1 :
    for (var nCount = 0; nCount < nSubLength; nCount++) {
Si l'objet actif dans le Sous-formulaire1 est de type field et l'objet actif a le même nom que celui sélectionné par l'utilisateur, les cas de commutation suivants sont exécutés :
if ((Subform1.nodes.item(nCount).className == "field") & (Subform1.nodes.item(nCount).name == sSelectField)) {
Le script suivant utilise une instruction de commutation pour gérer les trois valeurs de visibilité qu'un utilisateur peut appliquer aux objets de champs de texte :
        switch(xfa.event.newText) {
            case 'Invisible':
                Subform1.nodes.item(nCount).presence = "invisible";
                break;
            case 'Hidden (Exclude from Layout)':
                Subform1.nodes.item(nCount).presence = "hidden";
                break;
            default:
                Subform1.nodes.item(nCount).presence = "visible";
                break;
        }
    }
}
Script pour les valeurs de visibilité des boutons
Le script pour les valeurs de visibilité des boutons nécessite deux variables. Cette variable enregistre le nombre d'objets contenus dans le Sous-formulaire1 :
    var nSubLength = Subform1.nodes.length;
Cette variable enregistre le nom du bouton sélectionné par l'utilisateur dans la liste déroulante Boutons :
    var sSelectButton = buttonList.rawValue;
Le script suivant utilise la méthode replace pour supprimer tous les espaces contenus dans le nom du bouton enregistré dans la variable sSelectField afin que la valeur de la liste déroulante corresponde au nom de l'objet dans la palette Hiérarchie :
    sSelectButton = sSelecButton.replace(/\s/g, '');
Ce script utilise une boucle For pour passer en revue tous les objets contenus dans le Sous-formulaire1 :
    for (var nCount = 0; nCount < nSubLength; nCount++) {
Si l'objet actif dans le Sous-formulaire1 est de type field et l'objet actif a le même nom que celui sélectionné par l'utilisateur, exécutez les cas de commutation suivants :
    if ((Subform1.nodes.item(nCount).className == "field") &
    Subform1.nodes.item(nCount).name == sSelectButton)) {
Ce script utilise une instruction switch pour gérer les cinq valeurs de visibilité qu'un utilisateur peut appliquer aux objets de bouton.
la propriété relevant indique si un objet doit s'afficher lors de l'impression du formulaire.
        switch(xfa.event.newText) {
            case 'Invisible':
                Subform1.nodes.item(nCount).presence = "invisible";
                break;
            case 'Hidden (Exclude from Layout)':
                Subform1.nodes.item(nCount).presence = "hidden";
                break;
            case 'Visible (but Don\'t Print)':
                Subform1.nodes.item(nCount).presence = "visible";
                Subform1.nodes.item(nCount).relevant = "-print";
                break;
            case 'Invisible (but Print Anyway)':
                Subform1.nodes.item(nCount).presence = "invisible";
                Subform1.nodes.item(nCount).relevant = "+print";
                break;
            default:
                Subform1.nodes.item(nCount).presence = "visible";
                break;
        }
    }
}
Script pour la réinitialisation des listes déroulantes
Utilisez la méthode resetData pour rétablir toutes les valeurs par défaut des listes déroulantes :
    xfa.host.resetData();
Utilisez la méthode remerge pour fusionner à nouveau la conception de formulaire et les données du formulaire. Dans le cas présent, la méthode rétablie de manière efficace les objets de la zone Objets de formulaire à leur état d'origine :
    xfa.form.remerge();


Modification des propriétés visuelles d'un objet sur le client

Cet exemple vous montre comment modifier les propriétés visuelles d'un objet ; il s'agit ici d'un champ de texte. Par exemple, si vous activez l'option d'agrandissement du champ, la zone remplissable du champ de texte augmente de quatre pouces.
pour modifier les propriétés visuelles des objets sur le client, vous devez enregistrer votre formulaire comme formulaire PDF dynamique Acrobat.
Dans cet exemple, les cases à cocher comportent plusieurs noms d'objet ; par conséquent, LiveCycle Designer assigne une valeur d'instance pour référencer l'objet. Le script de la case à cocher utilise une instruction if-else pour donner l'effet d'une sélection ou d'une désélection.
Pour visualiser cet exemple de script et en obtenir d'autres, visitez le site Web de LiveCycle Developer Center à l'adresse suivante : www.adobe.com/devnet/livecycle.
Script pour l'option de déplacement du champ
Si cette case est activée, le champ se déplace selon les paramètres x et y. Si elle n'est pas activée, le champ revient à sa position d'origine.
if (CheckBox1.rawValue == true) {
    TextField.x = "3.0in";
    TextField.y = "3.5in";
}
else {
    TextField.x = "1in";
    TextField.y = "3in";
}
Script pour l'option d'agrandissement du champ
Si cette case est activée, la largeur du champ passe à 4 pouces. Si elle est désactivée, la largeur du champ passe à 2,5 pouces.
if (CheckBox2.rawValue == true)
    TextField.w = "4in";
else
    TextField.w = "2.5in";
Script pour l'option de réduction du champ
Si cette case est activée, la hauteur du champ passe à 1,5 pouces. Si elle est désactivée, la hauteur du champ passe à 0,5 pouce.
if (CheckBox3.rawValue == true)
    TextField.h = "1.5in";
else
    TextField.h = "0.5in";
Script pour l'option de modification de la couleur de l'objet
Si cette case est activée, la bordure du champ devient rouge. Si elle est désactivée, la bordure du champ devient blanche.
if (CheckBox4.rawValue == true)
    TextField.border.edge.color.value = "255,0,0";
else
    TextField.border.edge.color.value = "255,255,255";
Script pour l'option de modification de la couleur de remplissage de la zone remplissable
Si cette case est activée, la zone remplissable du champ de texte devient verte. Si elle est désactivée, la zone remplissable du champ de texte devient blanche.
if (CheckBox5.rawValue == true) {
    xfa.resolveNode("TextField.ui.#textEdit.border.fill.color").value = "0,255,0";
}
else {
    xfa.resolveNode("TextField.ui.#textEdit.border.fill.color").value = "255,255,255";
}
Script pour l'option d'ajustement de la largeur de la valeur
Si cette case est activée, la zone remplissable du champ de texte s'adapte pour héberger la valeur. Si elle est désactivée, la zone remplissable du champ de texte ne s'adapte pas.
if (CheckBox6.rawValue == true)
    TextField.minW = "0.25in";
else
    TextField.maxW = "2.5in";
Script pour l'option de masquage du champ
Si cette case est activée, le champ est masqué. Si elle est désactivée, le champ est visible.
if (CheckBox7.rawValue == true)
    TextField.presence = "hidden";
else
    TextField.presence = "visible";
Script pour l'option de changement de police de la valeur
Si cette case est activée, la police de la valeur est Courier New. Si elle est désactivée, la police de la valeur est Myriad Pro.
if (CheckBox8.rawValue == true)
    TextField.font.typeface = "Courier New";
else
    TextField.font.typeface = "Myriad Pro";
Script pour l'option de modification de la taille de la police
Si cette case est activée, la taille de la police est de 14 points. Si elle est désactivée, la taille de la police est de 10 points.
if (CheckBox9.rawValue == true)
    TextField.font.size = "14pt";
else
    TextField.font.size = "10pt";
Script pour l'option d'alignement vertical de la valeur du champ de texte
Si cette case est activée, la valeur du champ de texte est alignée en haut. Si elle est désactivée, la valeur du champ de texte est alignée au centre.
if (CheckBox10.rawValue == true)
    TextField.para.vAlign = "top";
else
    TextField.para.vAlign = "middle";
Script pour l'option d'alignement horizontal de la valeur du champ de texte
Si cette case est activée, la valeur du champ de texte est alignée au centre. Si elle est désactivée, la valeur du champ de texte est alignée à gauche.
if (CheckBox11.rawValue == true)
    TextField.para.hAlign = "center";
else
    TextField.para.hAlign = "left";
Script pour l'option d'affichage d'une valeur définie
Si cette case est activée, la valeur définie à l'aide d'un script s'affiche dans le champ de texte. Si elle est désactivée, la valeur par défaut (également définie à l'aide d'un script) s'affiche dans le champ de texte.
if (CheckBox12.rawValue == true)
    TextField.rawValue = "This is a value set using a script.";
else
    TextField.rawValue = "This is a default value.";
Script pour l'option de modification du texte de la légende
Si cette case est activée, le texte de la légende défini à l'aide d'un script s'affiche comme légende. Si elle est désactivée, la légende par défaut (également définie à l'aide d'un script) s'affiche dans le champ de texte.
if (CheckBox13.rawValue == true)
    xfa.resolveNode("TextField.caption.value.#text").value = "Alternate Caption:";
else
    xfa.resolveNode("TextField.caption.value.#text").value = "Caption:";
Script pour l'option de modification de la bordure du champ de 3D à case pleine
Si cette case est activée, la bordure du champ devient une case pleine. Si elle est désactivée, la bordure du champ devient une bordure 3D.
if (CheckBox14.rawValue == true)
    xfa.resolveNode("TextField.ui.#textEdit.border.edge").stroke = "solid";
else
    xfa.resolveNode("TextField.ui.#textEdit.border.edge").stroke = "lowered";
Script pour le bouton de désactivation de toutes les cases à cocher
Utilisez la méthode resetData pour rétablir toutes les valeurs par défaut des cases à cocher (désactivées) :
    xfa.host.resetData();
Utilisez la méthode remerge pour fusionner à nouveau la conception de formulaire et les données du formulaire. Dans le cas présent, la méthode rétablie de manière efficace le champ de texte à son état d'origine.
    xfa.form.remerge();


Obtention de la valeur actuelle ou de la valeur précédente d'une liste déroulante

Cet exemple vous montre comment obtenir la valeur actuelle d'une liste déroulante et vous explique les différentes méthodes d'accès à la valeur précédente d'une liste déroulante sur un formulaire. Outre les scripts actuels qui définissent les valeurs actuelle et précédente, il est important de noter que les scripts sont situés sur l'événement change de la liste déroulante.
Dans l'exemple suivant, lorsqu'un utilisateur sélectionne une valeur dans la liste déroulante, celle-ci s'affiche dans le champ Valeur actuelle. Ainsi, lorsque l'utilisateur sélectionne une autre valeur dans la liste déroulante, la nouvelle valeur s'affiche dans la liste Valeur actuelle et la valeur précédente s'affiche dans le champ Valeur précédente 1.
chacune de ces méthodes d'obtention de la valeur précédente d'une liste déroulante utilise un script différent. Le champ de texte Valeur précédente 1 est rempli par une référence directe à la propriété rawValue de la liste déroulante, tandis que le champ de texte Valeur précédente 2 est rempli à l'aide de la propriété prevText. Pour obtenir des résultats homogènes, il est recommandé d'accéder à la valeur précédente en utilisant la propriété prevText.
Pour visualiser cet exemple de script et en obtenir d'autres, visitez le site Web de LiveCycle Developer Center à l'adresse suivante : www.adobe.com/devnet/livecycle.
Script pour le remplissage du champ de texte Valeur actuelle
Remplissez la valeur du champ de texte Valeur actuelle à l'aide de la propriété newText :
    CurrentValue.rawValue = xfa.event.newText;
Script pour le remplissage du champ de texte Valeur précédente 1
Remplissez la valeur du champ de texte Valeur précédente 1 en référençant la valeur rawValue de la liste déroulante :
    PreviousValue1.rawValue = DropDownList.rawValue;
Script pour le remplissage du champ de texte Valeur précédente 2
Remplissez la valeur du champ de texte Valeur précédente 2 à l'aide de la propriété prevText :
    PreviousValue2.rawValue = xfa.event.prevText;


Ajustement de la hauteur d'un champ au moment de l'exécution

Cet exemple vous montre comment adapter un champ à la hauteur du contenu d'un autre champ.
Dans cet exemple, lorsque l'utilisateur saisit plusieurs lignes dans le champ de texte1, puis clique sur le bouton d'ajustement, la hauteur du Champ de texte2 augmente pour qu'elle corresponde à celle du Champ de texte1.
Pour visualiser cet exemple de script et en obtenir d'autres, visitez le site Web de LiveCycle Developer Center à l'adresse suivante : www.adobe.com/devnet/livecycle.
Script pour le bouton d'ajustement
Le script suivant correspond au bouton d'ajustement :
    var newHeight = xfa.layout.h(TextField1, "in");
    TextField2.h = newHeight + "in";


Définition d'une valeur de champ obligatoire au moment de l'exécution

Cet exemple vous montre comment rendre un champ obligatoire au moment de l'exécution.
Dans cet exemple, lorsque vous cliquez sur le bouton de valeur obligatoire, si l'utilisateur tente d'envoyer un formulaire sans saisir de texte dans le champ de texte 1, un message d'erreur s'affiche.
Pour visualiser cet exemple de script et en obtenir d'autres, visitez le site Web de LiveCycle Developer Center à l'adresse suivante : www.adobe.com/devnet/livecycle.
Script pour le bouton de valeur obligatoire
Le script suivant correspond au bouton de valeur obligatoire :
    TextField1.validate.nullTest = "error";
Vous pouvez également utiliser l'un des scripts suivants :
TextField1.mandatory = "error"
TextField1.mandatoryMessage = "this field is mandatory!"


Calcul des sommes d'un champ

Cet exemple vous montre comment calculer les sommes des champs situés à différents niveaux de la hiérarchie lorsque l'utilisateur ouvre un formulaire dans une application client, telle que Acrobat Professional, Adobe Reader, ou une application client HTML.
Pour visualiser cet exemple de script et en obtenir d'autres, visitez le site Web de LiveCycle Developer Center à l'adresse suivante : www.adobe.com/devnet/livecycle.
Script pour le calcul de la somme des champs répétés dans un formulaire
Pour calculer la somme des champs répétés dans un formulaire, vous ajoutez un événement calculate au champ de somme :
var fields = xfa.resolveNodes("NumericField1[*]");

var total = 0;
for (var i=0; i <= fields.length-1; i++) {
    total = total + fields.item(i).rawValue;
}

this.rawValue = total;
Script pour le calcul de la somme des champs répétés
De la même manière, pour calculer la somme des champs répétés, vous ajoutez un événement calculate au champ de somme :
var fields = xfa.resolveNodes("detail[*].NumericField1");

var total = 0;
for (var i=0; i <= fields.length-1; i++) {
    total = total + fields.item(i).rawValue;
}

this.rawValue = total;
Script pour le calcul de la somme des champs dans une page
Pour calculer la somme des champs dans une page, vous ajoutez un événement calculate au champ de somme :
var fields = xfa.layout.pageContent(0 , "field", 0);

var total = 0;
for (var i=0; i <= fields.length-1; i++) {
    if (fields.item(i).name == "NumericField1") {
           total = total + fields.item(i).rawValue;
       }
}

this.rawValue = total;


Mise en surbrillance des champs en réponse aux interactions de l'utilisateur final

Cet exemple vous montre comment mettre en surbrillance le champ actif avec lequel travaille un utilisateur, comment mettre en surbrillance les champs que doit remplir un utilisateur, et comment utiliser les zones de message pour envoyer des commentaires à l'utilisateur.
Dans cet exemple, un astérisque (*) apparaît à droite des champs obligatoires. Lorsqu'un champ est sélectionné, la bordure du champ devient bleue. Si l'utilisateur clique sur le bouton de vérification des données sans avoir rempli les champs obligatoires, un message s'affiche et le champ devient rouge. Si tous les champs obligatoires sont remplis, un message de confirmation s'affiche lorsque l'utilisateur clique sur le bouton de vérification des données.
Pour visualiser cet exemple de script et en obtenir d'autres, visitez le site Web de LiveCycle Developer Center à l'adresse suivante : www.adobe.com/devnet/livecycle.
Script pour l'ajout d'une bordure bleue autour d'un champ sélectionné
Pour ajouter une bordure bleue au champ sélectionné, ajoutez les scripts suivants à chaque champ de texte :
Par exemple, ajoutez un événement enter au champ Nom :
    Name.border.edge.color.value = "0,0,255";
Par exemple, ajoutez un événement exit au champ Nom :
    Name.border.edge.color.value = "255,255,255";
Par exemple, ajoutez un événement mouseEnter au champ Nom :
    Name.border.edge.color.value = "0,0,255";
Par exemple, ajoutez un événement mouseExit au champ Nom :
    Name.border.edge.color.value = "255,255,255";
Script pour le bouton de vérification des données :
Le script suivant, créé pour le bouton de vérification des données, exécute une série de vérifications afin de confirmer que les champs obligatoires contiennent des données. Dans le cas présent, chaque champ est vérifié un à un afin de confirmer que la valeur du champ est non-nulle ou est une chaîne vide. Si la valeur du champ est nulle ou une chaîne vide, un message d'alerte s'affiche indiquant que des données doivent être entrées dans le champ et que la couleur d'arrière-plan de la zone remplissable est passée au rouge.
Utilisez cette variable pour indiquer si le champs ne contient aucune donnée :
var iVar = 0;

if ((Name.rawValue == null) || (Name.rawValue == "")) {
    app.alert("Please enter a value in the Name field.");
Ce script modifie la couleur de la zone remplissable du champ de texte :
    xfa.resolveNode("Name.ui.#textEdit.border.edge").stroke = "solid";
    xfa.resolveNode("Name.ui.#textEdit.border.fill.color").value = "255,100,50";

    // Set the variable to indicate that this field does not contain data.
    iVar = 1;
}
else {
    // Reset the fillable area of the text field.
    xfa.resolveNode("Name.ui.#textEdit.border.edge").stroke = "lowered";
    xfa.resolveNode("Name.ui.#textEdit.border.fill.color").value = "255,255,255";
}

if ((Address.rawValue == null) || (Address.rawValue == "")) {
    app.alert("Please enter a value in the Address field.");
Ce script modifie la couleur de la zone remplissable du champ de texte :
    xfa.resolveNode("Address.ui.#textEdit.border.edge").stroke = "solid";
    xfa.resolveNode("Address.ui.#textEdit.border.fill.color").value = "255,100,50";
Ce script définie la variable pour indiquer que ce champ ne contient aucune donnée :
    iVar = 1;
}
else {
Ce script réinitialise la zone remplissable du champ de texte :
    xfa.resolveNode("Address.ui.#textEdit.border.edge").stroke = "lowered";
    xfa.resolveNode("Address.ui.#textEdit.border.fill.color").value = "255,255,255";
}

if ((City.rawValue == null) || (City.rawValue == "")) {
    app.alert("Please enter a value in the City field.");

Ce script modifie la couleur de la zone remplissable du champ de texte :
    xfa.resolveNode("City.ui.#textEdit.border.edge").stroke = "solid";
    xfa.resolveNode("City.ui.#textEdit.border.fill.color").value = "255,100,50";
Ce script définie la variable pour indiquer que ce champ ne contient aucune donnée :
    iVar = 1;
}
else {
Ce script réinitialise la zone remplissable du champ de texte :
    xfa.resolveNode("City.ui.#textEdit.border.edge").stroke = "lowered";
    xfa.resolveNode("City.ui.#textEdit.border.fill.color").value = "255,255,255";
}

if ((State.rawValue == null) || (State.rawValue == "")) {
    app.alert("Please enter a value in the State field.");
Ce script modifie la couleur de la zone remplissable du champ de texte :
    xfa.resolveNode("State.ui.#textEdit.border.edge").stroke = "solid";
    xfa.resolveNode("State.ui.#textEdit.border.fill.color").value = "255,100,50";
Ce script définie la variable pour indiquer que ce champ ne contient aucune donnée :
    iVar = 1;
}
else {
Ce script réinitialise la zone remplissable du champ de texte :
    xfa.resolveNode("State.ui.#textEdit.border.edge").stroke = "lowered";
    xfa.resolveNode("State.ui.#textEdit.border.fill.color").value = "255,255,255";
}

if ((ZipCode.rawValue == null) || (ZipCode.rawValue == "")) {
    app.alert("Please enter a value in the Zip Code field.");

Ce script modifie la couleur de la zone remplissable du champ de texte :
    xfa.resolveNode("ZipCode.ui.#textEdit.border.edge").stroke = "solid";
    xfa.resolveNode("ZipCode.ui.#textEdit.border.fill.color").value = "255,100,50";
Ce script définie la variable pour indiquer que ce champ ne contient aucune donnée :
    iVar = 1;
}
else {
Ce script réinitialise la zone remplissable du champ de texte :
    xfa.resolveNode("ZipCode.ui.#textEdit.border.edge").stroke = "lowered";
    xfa.resolveNode("ZipCode.ui.#textEdit.border.fill.color").value = "255,255,255";
}

if ((Country.rawValue == null) || (Country.rawValue == "")) {
    app.alert("Please enter a value in the Country field.");
Ce script modifie la couleur de la zone remplissable du champ de texte :
    xfa.resolveNode("Country.ui.#textEdit.border.edge").stroke = "solid";
    xfa.resolveNode("Country.ui.#textEdit.border.fill.color").value = "255,100,50";

Ce script définie la variable pour indiquer que ce champ ne contient aucune donnée.
    iVar = 1;
}
else {
Ce script réinitialise la zone remplissable du champ de texte.
    xfa.resolveNode("Country.ui.#textEdit.border.edge").stroke = "lowered";
    xfa.resolveNode("Country.ui.#textEdit.border.fill.color").value = "255,255,255";
}
Si tous les champs obligatoires contiennent des données, la variable iVar est définie à zéro et un message de confirmation s'affiche :
    if (iVar == 0) {
        app.alert("Thank you for inputting your information.");
    }


Réinitialisation des valeurs du sous-formulaire actif

Cet exemple vous montre comment réinitialiser les valeurs d'un jeu de champs spécifique (et non de l'intégralité du formulaire). Pour ce faire, réinitialisez uniquement les champs dans l'objet de sous-formulaire requis.
Dans cet exemple, l'utilisateur peut cliquer sur le bouton d'effacement pour réinitialiser les valeurs du champ.
Pour visualiser cet exemple de script et en obtenir d'autres, visitez le site Web de LiveCycle Developer Center à l'adresse suivante : www.adobe.com/devnet/livecycle.
Script pour les valeurs qui s'affichent dans la colonne de gauche
Ecrivez le script suivant pour les valeurs qui s'affichent dans la colonne de gauche :
    this.rawValue = this.parent.index + 1;
Pour réinitialiser les valeurs par défaut, ajoutez un événement click au bouton d'effacement. Vous avez besoin d'une expression de syntaxe de référence, car le détail est un sous-formulaire répété qui doit se refléter dans l'expression de syntaxe de référence. Par conséquent, il est facile de développer les paramètres resetData séparément.
    var f1 = this.parent.somExpression + ".TextField2" + ",";
    var f2 = f1 + this.parent.somExpression + ".DropDownList1" + ",";
    var f3 = f2 + this.parent.somExpression + ".NumericField1";

    // ...and pass the variable as a parameter.
    xfa.host.resetData(f3);


Modification de la visibilité d'un objet de conception de formulaire

LiveCycle Designer offre les paramètres de visibilité suivants pour les différents objets d'un formulaire via les onglets de la palette Objet. Les paramètres Invisible et Masqué (pas affiché) ne s'appliquent pas aux groupes, aux zones de contenu, aux gabarits, aux jeux de pages et aux objets des jeux de sous-formulaires.
pour modifier le paramètre de visibilité d'un objet à l'aide de scripts, vous devez modifier la valeur de deux propriétés sous-jacentes du modèle d’objet de formulaire XML : presence et relevant.
Le tableau ci-dessous présente les paramètres de visibilité et la syntaxe de référence correspondante.

Paramètre de visibilité

Syntaxe de référence
Visible
FormCalc
ObjectName.presence = "visible"
JavaScript
ObjectName.presence = "visible";
Visible (Ecran seulement)
FormCalc
ObjectName.presence = "visible"
ObjectName.relevant = « -print »
JavaScript
ObjectName.presence = "visible";
ObjectName.relevant = « -print »;
Visible (Impression seulement)
FormCalc
ObjectName.presence = "visible"
ObjectName.relevant = « +print »
JavaScript
ObjectName.presence = "visible";
ObjectName.relevant = « +print »;
Invisible
FormCalc
ObjectName.presence = "invisible"
JavaScript
ObjectName.presence = "invisible";
Masqué (pas affiché)
FormCalc
ObjectName.presence = "hidden"
JavaScript
ObjectName.presence = "hidden";
Voir aussi
Pour changer le formatage par défaut des nouveaux objets


Utilisation des propriétés du gestionnaire d'instances pour contrôler les sous-formulaires

Cet exemple vous montre comment utiliser les propriétés du gestionnaire d'instances (qui fait partie du modèle d'objet de formulaire XML) pour récupérer les informations sur les sous-formulaires au moment de l'exécution.
Dans le formulaire suivant, les quatre boutons donnent des informations sur le Sous-formulaire 1 grâce aux propriétés de script du gestionnaire d'instances. Par exemple, lorsque l'utilisateur clique sur le bouton Max., un message décrivant le nombre maximal d'instances du Sous-formulaire 1 prises en charge s'affiche.
Script pour la zone de message pour la génération de la valeur de la propriété Count
Le script suivant utilise la méthode messageBox pour générer la valeur de la propriété count :
    xfa.host.messageBox("The current number of Subform1 instances on the
    formulaire est : » + properties.Subform1.instanceManager.count, « Instance Manager
    Properties »,3);
Vous pouvez également écrire ce script en utilisant du trait de soulignement (_) pour référencer la propriété count du gestionnaire d'instances, comme indiqué ci-après :
    xfa.host.messageBox("The current number of Subform1 instances on the form
    est : «  + properties._Subform1.count, « Instance Manager Properties », 3);
Le trait de soulignement (_) est particulièrement important s'il n'existe aucune instance de sous-formulaire sur le formulaire.
Script pour la zone de message pour la génération de la valeur de la propriété Max
Le script suivant utilise la méthode messageBox pour générer la valeur de la propriété max :
    xfa.host.messageBox("The maximum number of instances allowed for Subform1
    est : «  + properties.Subform1.instanceManager.max, « Instance Manager
    Properties », 3);
Vous pouvez également écrire ce script en utilisant du trait de soulignement (_) pour référencer la propriété max du gestionnaire d'instances, comme indiqué ci-après :
    xfa.host.messageBox("The maximum number of instances allowed for Subform1
    est : «  + properties._Subform1.max, « Instance Manager Properties », 3);
Script pour la zone de message pour la génération de la valeur de la propriété Min
Le script suivant utilise la méthode messageBox pour générer la valeur de la propriété min :
    xfa.host.messageBox("The minimum number of instances allowed for Subform1
    est : «  + properties.Subform1.instanceManager.min, « Instance Manager
    Properties », 3);
Vous pouvez également écrire ce script en utilisant du trait de soulignement (_) pour référencer la propriété min du gestionnaire d'instances, comme indiqué ci-après :
    xfa.host.messageBox("The minimum number of instances allowed for Subform1
    est : «  + properties._Subform1.min, « Instance Manager Properties », 3);
Script pour la zone de message pour la génération de la valeur de la propriété Subform
Le script suivant utilise la méthode messageBox pour générer le nom de la propriété subform :
    xfa.host.messageBox("The name of the subform using the instance manager name
    property is: «  + properties.Subform1.instanceManager.name +
    ".\n\nNote: This value is different than the value returned by the name
    de la propriété de l'objet Sous-formulaire 1. » , « Instance Manager Properties », 3);
Vous pouvez également écrire ce script en utilisant du trait de soulignement (_) pour référencer le nom de la propriété du gestionnaire d'instances, comme indiqué ci-après :
    xfa.host.messageBox("The name of the subform using the instance manager name
    property is: «  + properties._Subform1.name +
    « .\n\nRemarque : cette valeur est différente de celle renvoyée par le nom
    de la propriété de l'objet Sous-formulaire 1. » , « Instance Manager Properties », 3);


Utilisation des méthodes du gestionnaire d'instances pour contrôler les sous-formulaires

Cet exemple vous montre comment utiliser les méthodes du gestionnaire d'instances (qui fait partie du modèle d'objet de formulaire XML) pour effectuer des opérations sur les objets de sous-formulaire au moment de l'exécution. Par exemple, vous pouvez ajouter les instances supprimées d'un sous-formulaire particulier ou une rangée de tableau.
Dans le formulaire suivant, l'utilisateur se sert des quatre boutons pour utiliser les différentes méthodes de script du gestionnaire d'instances. Par exemple, lorsque l'utilisateur clique sur le bouton Ajouter, une nouvelle instance Sous-formulaire2 est ajoutée au formulaire.
le bouton de déplacement réorganise les deux premières instances Sous-formulaire2, et le bouton de définition affiche le nombre maximal d'instances Sous-formulaire2. Dans les deux cas, vous devez ajouter ou supprimer des sous-formulaires ou effectuer des modifications au niveau des données dans les champs de texte pour que les modifications soient appliquées aux instances Sous-formulaire2.
Script pour déterminer si vous avez ajouté le nombre maximal d'instances de sous-formulaire à un formulaire
Le script suivant détermine si le nombre maximal d'instances de Sous-formulaire2 pris en charge se trouve sur le formulaire. Si c'est le cas, le script affiche un message. Dans le cas contraire, la nouvelle instance de Sous-formulaire2 est ajoutée au formulaire.
    if (methods.Subform2.instanceManager.count ==
    methods.Subform2.instanceManager.max) {
    xfa.host.messageBox("You have reached the maximum number of items allowed.",
    « Instance Manager Methods », 1);
}
    else {
    methods.Subform2.instanceManager.addInstance(1);
    xfa.form.recalculate(1);
}
Vous pouvez également écrire ce script en utilisant du trait de soulignement (_) pour référencer les propriétés et les méthodes du gestionnaire d'instances, comme indiqué ci-après :
    if (methods._Subform2.count == methods._Subform1.max) {
         xfa.host.messageBox("You have reached the maximum number of items
        allowed. », « Instance Manager Methods », 1);
}
    else {
        methods._Subform2.addInstance(1);
        xfa.form.recalculate(1);
}
Script pour déterminer s'il existe encore des sous-formulaires à supprimer dans le formulaire
Le script suivant détermine s'il existe une instance Sous-formulaire2 sur le formulaire. S'il n'en existe pas, le script affiche un message indiquant qu'aucune instance n'existe. S'il existe des instances, le script supprime la première instance du formulaire.
    if (methods.Subform2.instanceManager.count == 0) {
        xfa.host.messageBox("There are no subform instances to remove.",
        « Instance Manager Methods », 1);
    }
    else {
        methods.Subform2.instanceManager.removeInstance(0);
        xfa.form.recalculate(1);
    }
Vous pouvez également écrire ce script en utilisant du trait de soulignement (_) pour référencer les propriétés et les méthodes du gestionnaire d'instances, comme indiqué ci-après :
    if (methods._Subform2.count == 0) {
        xfa.host.messageBox("There are no subform instances to remove.",
        « Instance Manager Methods », 1);
    }
    else {
        methods._Subform2.removeInstance(0);
        xfa.form.recalculate(1);
    }
Script pour obliger à quatre instances de sous-formulaire de s'afficher sur le formulaire
Le script suivant oblige quatre instances de Sous-formulaire2 de s'afficher sur le formulaire, indépendamment du nombre d'instances existantes :
    methods.Subform2.instanceManager.setInstances(4);
Vous pouvez également écrire ce script en utilisant du trait de soulignement (_) pour référencer les propriétés et les méthodes du gestionnaire d'instances, comme indiqué ci-après :
    methods._Subform2.setInstances(4);
Script pour obliger la première et la deuxième instance de sous-formulaire à changer d'emplacement sur le formulaire
Le script suivant oblige la première et la deuxième instance de Sous-formulaire2 de changer d'emplacement sur le formulaire.
    methods.Subform2.instanceManager.moveInstance(0,1);
Vous pouvez également écrire ce script en utilisant du trait de soulignement (_) pour référencer les propriétés et les méthodes du gestionnaire d'instances, comme indiqué ci-après.
    methods._Subform2.moveInstance(0,1);


Utilisation du gestionnaire d'instances pour contrôler les sous-formulaires au moment de l'exécution

Cet exemple vous montre comment utiliser les propriétés et les méthodes du gestionnaire d'instances pour récupérer les informations concernant les sous-formulaires et effectuer des opérations sur les objets de sous-formulaire au moment de l'exécution.
Dans cet exemple, l'utilisateur utilise les boutons pour exécuter diverses actions à l'aide des instances de Sous-formulaire3. Par exemple, lorsque l'utilisateur clique sur le bouton d'ajout d'une rangée au-dessous, une nouvelle instance Sous-formulaire3 est ajoutée sous l'instance actuelle.
vous devez ajouter ou supprimer des sous-formulaires ou effectuer des modifications au niveau des données dans les champs de texte pour que les modifications soient appliquées aux instances Sous-formulaire3.
Script pour le bouton d'ajout d'un nouveau sous-formulaire
Le script suivant détermine si le nombre maximal d'instances de Sous-formulaire3 pris en charge se trouve sur le formulaire. Si c'est le cas, le script affiche un message. Dans le cas contraire, la nouvelle instance de Sous-formulaire3 est ajoutée au formulaire.
    if (advanced.Subform3.instanceManager.count ==
        advanced.Subform3.instanceManager.max) {
        xfa.host.messageBox("You have reached the maximum number of items
        allowed. », »Combining Instance Manager Concepts », 1);
}
    else {
        advanced.Subform3.instanceManager.addInstance(1);
        xfa.form.recalculate(1);
}
Vous pouvez également écrire ce script en utilisant du trait de soulignement (_) pour référencer les propriétés et les méthodes du gestionnaire d'instances, comme indiqué ci-après :
    if (advanced._Subform3.count == advanced._Subform3.max) {
        xfa.host.messageBox(« You have reached the maximum number of items
        allowed. », « Combining Instance Manager Concepts », 1);
    }
    else {
        advanced._Subform3.addInstance(1);
        xfa.form.recalculate(1);
    }
Script pour le bouton de suppression d'un sous-formulaire
Le script suivant détermine s'il existe une instance Sous-formulaire3 sur le formulaire. S'il n'en existe pas, le script affiche un message indiquant qu'aucune instance n'existe. S'il existe des instances, le script supprime la première instance du formulaire.
    if (advanced.Subform3.instanceManager.count == 0) {
        xfa.host.messageBox("There are no subform instances to remove.",
        « Combining Instance Manager Concepts », 1);
    }
    else {
        advanced.Subform3.instanceManager.removeInstance(0);
    }
Vous pouvez également écrire ce script en utilisant du trait de soulignement (_) pour référencer les propriétés et les méthodes du gestionnaire d'instances, comme indiqué ci-après :
    if (advanced._Subform3.count == 0) {
        xfa.host.messageBox("There are no subform instances to remove.",
        « Combining Instance Manager Concepts », 1);
    }
    else {
        advanced._Subform3.removeInstance(0);
    }
Script pour le bouton d'ajout d'une instance au-dessous
L'instruction if-else suivante évite que le script soit traité si le formulaire contient actuellement le nombre maximal d'instances Subform3 :
    if (Subform3.instanceManager.count < Subform3.instanceManager.occur.max) {
//oNewInstance stores an instance of Subform3 created by the addInstance() method.
    var oNewInstance = Subform3.instanceManager.addInstance(1);
//nIndexFrom and nIndexTo store the before and after index values to use with the moveInstance() method.
    var nIndexFrom = oNewInstance.index;
    var nIndexTo = Subform3.index + 1;
Dans ce cas, lorsque le script référence la valeur de nIndexFrom, la nouvelle instance de Subform3 est ajoutée au formulaire à l'emplacement spécifié dans la méthode moveInstance :
        Subform3.instanceManager.moveInstance(nIndexFrom, nIndexTo);
    }
    else {
        xfa.host.messageBox("You have reached the maximum number of items
        allowed. », « Combining Instance Manager Concepts », 1);
    }
Vous pouvez également écrire ce script en utilisant du trait de soulignement (_) pour référencer les propriétés et les méthodes du gestionnaire d'instances, comme indiqué ci-après :
    if (_Subform3.count < _Subform3.occur.max) {
    var oNewInstance = _Subform3.addInstance(1);
    var nIndexFrom = oNewInstance.index;
    var nIndexTo = Subform3.index + 1;
    _Subform3.moveInstance(nIndexFrom, nIndexTo);
    }
    else {
    xfa.host.messageBox("You have reached the maximum number of items allowed.", 		"Combining Instance Manager Concepts", 1);
    }
Script pour le bouton de suppression de l'instance active
L'instruction if-else suivante évite que le script soit traité si le formulaire contient actuellement le nombre minimal d'instances Subform3 :
    if (Subform3.instanceManager.count > Subform3.instanceManager.occur.min) {
Ce script utilise la méthode removeInstance pour supprimer une instance de Sous-formulaire3.
ce script utilise la valeur parent.parent.index pour indiquer l'instance de Sous-formulaire3 à supprimer. La référence parent indique le conteneur de l'objet qui utilise la référence. Dans ce cas, l'utilisation de la référence parent.index indique le sous-formulaire sans titre qui contient les boutons d'ajout d'une instance au-dessous, de suppression de l'instance active, de déplacement des rangées vers le haut et de déplacement de rangées vers le bas.
        Subform3.instanceManager.removeInstance(parent.parent.index);
    }
    else {
        xfa.host.messageBox("You have reached the minimum number of items
        allowed. », « Combining Instance Manager Concepts », 1);
    }
Vous pouvez également écrire ce script en utilisant du trait de soulignement (_) pour référencer les propriétés et les méthodes du gestionnaire d'instances, comme indiqué ci-après :
    if (_Subform3.count > _Subform3.occur.min) {
    Subform3.removeInstance(Subform3.index);
    }
    else {
    xfa.host.messageBox("You have reached the minimum number of items allowed.",
    « Combining Instance Manager Concepts », 1);
    }
Script pour le bouton de déplacement des rangées vers le haut
L'instruction if-else suivante évite que le script soit traité si l'instance de Sous-formulaire3 s'affiche comme la première instance dans la liste :
    if (Subform3.index != 0) {
//nIndexFrom and nIndexTo store the before and after index values to use with the moveInstance method.
        var nIndexFrom = Subform3.index;
        var nIndexTo = Subform3.index - 1;
        Subform3.instanceManager.moveInstance(nIndexFrom, nIndexTo);
    }
    else {
        xfa.host.messageBox("The current item cannot be moved because it is the
        first instance in the list. », « Combining Instance Manager Concepts », 1);
    }
Vous pouvez également écrire ce script en utilisant du trait de soulignement (_) pour référencer les propriétés et les méthodes du gestionnaire d'instances, comme indiqué ci-après :
    if (Subform3.index != 0) {
        var nIndexFrom = Subform3.index;
    var nIndexTo = Subform3.index - 1;
    Subform3.moveInstance(nIndexFrom, nIndexTo);
    }
    else {
    xfa.host.messageBox("The current item can't be moved since it already is the 	first instance in the list.", "Combining Instance Manager Concepts", 1);
    }
Script pour le bouton de déplacement des rangées vers le bas
Cette variable stocke la valeur de l'index de l'instance de Sous-formulaire3 :
var nIndex = Subform3.index;
L'instruction if-else suivante évite que le script soit traité si l'instance de Sous-formulaire3 s'affiche comme la dernière instance dans la liste :
if ((nIndex + 1) < Subform3.instanceManager.count) {
// nIndexFrom and nIndexTo store the before and after index values to use with the moveInstance() method.
    var nIndexFrom = nIndex;
    var nIndexTo = nIndex + 1;

    Subform3.instanceManager.moveInstance(nIndexFrom, nIndexTo);
    }
    else {
    xfa.host.messageBox("The current item cannot be moved because it is the last
    instance in the list. », « Combining Instance Manager Concepts », 1);
    }
Vous pouvez également écrire ce script en utilisant du trait de soulignement (_) pour référencer les propriétés et les méthodes du gestionnaire d'instances, comme indiqué ci-après :
    var nIndex = Subform3.index;
    if ((nIndex + 1) < Subform3.instanceManager.count) {
    var nIndexFrom = nIndex;
    var nIndexTo = nIndex + 1;
    _Subform3.moveInstance(nIndexFrom, nIndexTo);
    }
    else {
    xfa.host.messageBox("The current item can't be moved since it already is the
    last instance in the list. », « Combining Instance Manager Concepts », 1);
    }


Référence sur les objets de script

A propos de la référence sur les objets de script
Hiérarchie des classes de modèles d'objets de formulaires XML
Objets
Propriétés de script
Méthodes de script


A propos de la référence sur les objets de script

Cette section décrit les objets, les propriétés et les méthodes que vous pouvez utiliser dans l'environnement de script LiveCycle Designer.
Chaque hôte (Acrobat ou Adobe Reader, par exemple) est chargé de mettre en oeuvre les méthodes disponibles. Certaines méthodes, comme la méthode beep, ne présentent aucun intérêt sur un serveur. Le serveur n'implémente pas ces méthodes et peut même produire un message d'erreur si l'utilisateur essaie d'appeler la méthode.
Pour plus d'informations au sujet de l'environnement de script LiveCycle Designer, reportez-vous au document Adobe XML Form Object Model Reference proposé sur le site Web Adobe LiveCycle Designer Developer Center : http://partners.adobe.com/public/developer/livecycle/designer/devcenter.html.


Hiérarchie des classes de modèles d'objets de formulaires XML

classe objet
classe treeList
classe tree
classe node
classe content
classe model
classe textNode
Le modèle d'objet de formulaire XML se compose de neuf modèles contenant chacun un jeu d'objets. Chaque objet est dérivé de l'un des jeux de classes qui définissent les propriétés et méthodes communes. Un objet hérite à son tour de ces propriétés et méthodes communes mais peut aussi ajouter des propriétés et des méthodes qui soient particuliers à cet objet, ou relatives à d'autres objets dérivés de la même classe.
La hiérarchie de classes dont sont issus les objets des modèles d'objets de formulaire XML est structurée comme suit :
object |  |  |
 | treeList |  |
 | tree |  |
 |  | node |
 |  |  | content
 |  |  | model
 |  |  | textNode
A l'instar des structures de classes traditionnelles, chaque classe hérite des propriétés et méthodes de sa classe parent. Les objets à leur tour héritent de la classe parent dont ils sont issus.
chaque modèle utilise une hiérarchie d'objets. Les objets n'héritent pas des propriétés et méthodes d'autres objets, mais héritent directement de la hiérarchie de classes. La hiérarchie des objets dans un modèle représente la structure XML de ce modèle.


classe objet

La classe object constitue la classe de base dont sont issus, directement ou indirectement, les autres classes, objets et modèles.
Hiérarchie de classes

Classe parent

Classe en cours

Classe enfant
Non

object
tree
treeList
Propriétés

Nom

Description

Type

Accès
className
Spécifie le nom de la classe de cet objet.
Chaîne
Get
Méthodes
Non


classe treeList

La classe treeList représente une liste d'arborescence.
Hiérarchie de classes

Classe parent

Classe en cours

Classe enfant
object
treeList
Non
Propriétés

Nom

Description

Type

Accès
length
Indique le nombre d'objets dans la liste.
Entier
Lecture
Méthodes

Nom

Description

Renvoie
append
Ajoute un nœud à la fin de la liste de nœuds.
Vide
insert
Insère un nœud avant un nœud spécifique dans la liste des nœuds.
Vide
item
Décrit un index à base zéro dans la collection.
Objet
namedItem
Récupère le premier enfant du nœud portant le nom donné.
Objet
remove
Supprime un nœud de la liste.
Vide


classe tree

La classe tree représente la structure dont est issue la classe node.
Hiérarchie de classes

Classe parent

Classe en cours

Classe enfant
object
tree
node
Propriétés

Nom

Description

Type

Accès
all
Renvoie une collection de nœuds de même nom et compris dans la plage indiquée.
Objet
Lecture
classAll
Renvoie une collection de nœuds de même classe et compris dans la plage indiquée.
Objet
Lecture
classIndex
Renvoie la position de l'objet dans sa collection d'objets de même classe et compris dans la plage indiquée.
Entier
Lecture
index
Renvoie la position du nœud dans sa collection de nœuds de même nom et compris dans la plage indiquée.
Entier
Lecture
name
Identificateur qui permet de désigner un objet ou un événement dans les expressions de script.
Chaîne
Lecture/écriture
nodes
Renvoie une liste de tous les objets enfant de l'objet actuel.
Objet
Lecture
parent
Renvoie l'objet parent de l'objet en cours.
Objet
Lecture
somExpression
Récupère l'expression de syntaxe de référence pour ce nœud.
Chaîne
Lecture
Méthodes

Nom

Description

Renvoie
resolveNode
Evalue l'expression de syntaxe de référence spécifiée, en commençant par l'objet modèle de l'objet de formulaire XML actif et renvoie la valeur de l'objet spécifié dans l'expression de syntaxe de référence.
Objet
resolveNodes
Evalue l'expression de syntaxe de référence spécifiée, en commençant par l'objet modèle de l'objet de formulaire XML actif et renvoie la valeur de l'objet ou des objets spécifiés dans l'expression de syntaxe de référence.
Objet


classe node

La classe node représente le type de données primaire pour les objets de modèle d'objet de formulaire XML.
Hiérarchie de classes

Classe parent

Classe en cours

Classes enfant
tree

node
content
model
textNode
Propriétés

Nom

Description

Type

Accès
id
Spécifie un type d'ID XML générique défini par l'utilisateur.
Chaîne
Lecture/écriture
isContainer
Indique si l'objet est un objet conteneur.
Booléen
Lecture
isNull
Indique si la valeur de données actuelle est la valeur nulle.
Booléen
Lecture
model
Indique le modèle de l'objet actuel.
Objet
Lecture
ns
Renvoie l'espace de nommage pour l'objet.
Chaîne
Lecture
oneOfChild
Récupère ou définit l'objet enfant dans le cas où un objet parent peut disposer uniquement d'un objet enfant particulier.
Objet
Lecture/écriture
Méthodes

Nom

Description

Renvoie
applyXSL
Applique une transformation XLS à une représentation XML du nœud actif. Vous pouvez également appeler saveXML et transformer le résultat à l'aide du document XLS spécifié.
Chaîne
assignNode
Evalue l'expression de syntaxe de référence dans le contexte actif et définit la valeur du nœud détecté. Si le nœud n'existe pas, il peut être créé.
Objet
clone
Effectue la copie d'un objet.
Objet
getAttribute
Récupère une valeur de propriété spécifiée.
Chaîne
getElement
Renvoie une propriété d'objet spécifiée.
Objet
isPropertySpecified
Vérifie si une propriété spécifique a été définie pour ce nœud.
Booléen
loadXML
Charge et ajoute un document XML spécifié à l'objet actif.
Vide
saveFilteredXML
Enregistre le nœud actif dans une chaîne, mais inclut uniquement un jeu partiel des nœuds enfant.
Chaîne
saveXML
Enregistre le nœud actif dans une chaîne.
Chaîne
setAttribute
Définit la valeur d'une propriété spécifiée.
Vide
setElement
Définit un objet spécifié sur l'objet actif.
Vide


classe content

La classe content fournit des objets de contenu aux modèles de formulaire et aux conceptions de modèle. Les conceptions de formulaires et les formulaires terminés sont composés d'objets visuels représentant du contenu, tels que des images et du texte.
Hiérarchie de classes

Classe parent

Classe en cours

Classe enfant
node

content
Non
Propriétés
Non
Méthodes
Non


classe model

La classe model constitue la classe de base pour les objets racine de chaque modèle.
Hiérarchie de classes

Classe parent

Classe en cours

Classe enfant
node

model
Non
Propriétés

Nom

Description

Type

Accès
aliasNode
Indique l'objet représenté par le pseudonyme pour ce modèle.
Objet
Lecture/écriture
context
Indique l'objet actif, qui est l'objet de départ lors de l'utilisation des méthodes resolveNode et resolveNodes.
Objet
Lecture/écriture
Méthodes

Nom

Description

Renvoie
clearErrorList
Supprime tous les éléments du journal d'erreurs actuel.
Vide
createNode
Crée un nouveau nœud en fonction d'un nom de classe correct.
Objet
isCompatibleNS
Détermine si un espace de noms spécifié fonctionne, c'est-à-dire est compatible avec l'espace de noms de ce modèle. Détermine si les deux espaces de noms sont équivalents, même si les chaînes qui les représentent ne le sont pas.
Booléen


classe textNode

La classe textNode représente des objets qui stockent des données textuelles directement au lieu d'utiliser l'objet #text dérivé de la classe node.
Hiérarchie de classes

Classe parent

Classe en cours

Classe enfant
node

textNode
Non
Propriétés

Nom

Description

Type

Accès
{par défaut}
Représente la valeur réelle stockée par un objet.
Chaîne
Lecture/écriture
value
Indique la valeur de l'objet actuel.
Chaîne
Lecture/écriture
Méthodes
Non


Objets

arc
zone
assist
barcode
bind
bindItems
bookend
boolean
border
break
breakAfter
breakBefore
button
calculate
caption
certificate
certificates
checkButton
choiceList
Couleur
comb
command
connect
connectionSet
connectString
contentArea
corner
dataGroup
dataModel
dataValue
dataWindow
date
dateTime
dateTimeEdit
decimal
defaultUi
delete
desc
digestMethod
digestMethods
draw
dSigData
edge
encoding
encodings
event
eventPseudoModel
exclGroup
exData
execute
exObject
extras
field
fill
filter
float
font
formulaire
format
handler
hostPseudoModel
image
imageEdit
insert
instanceManager
integer
issuers
items
keep
keyUsage
layoutPseudoModel
line
linear
manifest
map
margin
mdp
medium
message
numericEdit
occur
oid
oids
operation
overflow
packet
pageArea
pageSet
para
password
passwordEdit
pattern
picture
proto
query
radial
reason
reasons
recordSet
rectangle
ref
rootElement
script
select
setProperty
signature
signatureProperties
signaturePseudoModel
signData
signedState
signing
soapAction
soapAddress
solid
source
sourceSet
speak
stipple
subform
subformSet
subjectDN
subjectDNs
submit
template
Texte
textEdit
time
timeStamp
toolTip
traversal
traverse
ui
update
uri
user
validate
value
variable
wsdlAddress
wsdlConnection
xfa
xmlConnection
xsdConnection


arc

L'objet arc décrit un arc ou une ellipse.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
value

arc
edge
fill
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
circular
Permet de convertir un arc en cercle.
Chaîne
Lecture/écriture
hand
Décrit la justification d'une ligne ou d'un bord.
Chaîne
Lecture/écriture
startAngle
Indique l’angle à l’origine d’un arc.
Chaîne
Lecture/écriture
sweepAngle
Indique la longueur d’un arc, exprimée comme un angle.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


zone

L'objet area représente le regroupement d'autres objets de conteneur sur un formulaire.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
zone
pageArea
proto
subform

area
desc
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
colSpan
Spécifie le nombre de colonnes étendues par cet objet lorsqu'il est incorporé dans un sous-formulaire doté d'un type de disposition des rangées particulier.
Chaîne
Lecture/écriture
relevant
Contrôle si un objet de formulaire est inclus dans l'opération d'impression.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
x
Indique l’abscisse (coordonnée X) du point d'ancrage d'un conteneur par rapport au coin supérieur gauche du conteneur parent lors d'un placement avec disposition positionnée.
Chaîne
Lecture/écriture
y
Indique l'ordonnée (coordonnée X) du point d'ancrage d'un conteneur par rapport au coin supérieur gauche du conteneur parent lors d'un placement avec disposition positionnée.
Chaîne
Lecture/écriture
Méthodes
Non


assist

L'objet assist fournit des informations supplémentaires sur un conteneur pour les utilisateurs des applications de formulaires interactifs.
Il permet de spécifier l'info-bulle et le comportement pour une invite spoken.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
draw
exclGroup
field
proto

assist
speak
toolTip
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
role
Indique le rôle joué par le conteneur parent.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


barcode

L'objet barcode fournit les informations nécessaires à l'affichage d'un code à barres. Ces informations comprennent le type de code à barres et un ensemble d'options différentes selon les types de codes à barres.
LiveCycle Designer peut prendre en charge deux types de codes à barres : logiciel et matériel. Toutefois, une application XFA n'est pas nécessaire pour prendre en charge un ensemble de codes à barres particulier. Les codes à barres matériels sont affichés pour des imprimantes particulières. L'ensemble de codes à barres pris en charge peut être différent selon le périphérique d'affichage, car certaines imprimantes sont équipées d'un système intégré de prise en charge de codes à barres particuliers. Les codes à barres logiciels sont dessinés contour par contour par l'application XFA elle-même. A l'écran, indéchiffrable par les lecteurs de codes à barres, une application XFA peut remplacer un code à barres précis par une balise d'emplacement.
Pour chaque type de code à barres, il y a généralement deux spécifications, une pour le code à barres lui-même et une pour sa position par rapport à la page physique et les caractères imprimés environnants. L'auteur de la conception de formulaire doit s'assurer que le code à barres est correctement placé sur la page. L'application XFA est responsable de la génération correcte du code à barres à l'aide des données utilisateur. Les données utilisateur doivent être compatibles avec le code à barres, c'est-à-dire qu'elles doivent se conformer au jeu et à la longueur de caractères autorisés.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
ui

barcode
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
charEncoding
Spécifie l'encodage de caractères de la valeur encodée dans un code à barres.
Chaîne
Lecture/écriture
checksum
Indique un algorithme de la somme de contrôle à insérer dans un code à barres.
Chaîne
Lecture/écriture
dataColumnCount
Spécifie un nombre facultatif de colonnes de données à encoder pour les codes à barres pris en charge. Cette propriété s'applique uniquement aux codes à barres bidimensionnels (2D).
Chaîne
Lecture/écriture
dataLength
Indique le nombre maximal de caractères de l’occurrence d’un code à barres. Cette propriété s'applique uniquement aux codes à barres unidimensionnels.
Chaîne
Lecture/écriture
dataPrep
Définit le prétraitement appliqué aux données consignées dans le code à barres.
Chaîne
Lecture/écriture
dataRowCount
Spécifie un nombre facultatif de rangées de données à encoder pour les codes à barres pris en charge. Cette propriété s'applique uniquement aux codes à barres bidimensionnels (2D).
Chaîne
Lecture/écriture
endChar
Indique un caractère de commande de fin facultatif à ajouter aux données du code à barres.
Chaîne
Lecture/écriture
errorCorrectionLevel
Indique un niveau de correction d'erreur facultatif à appliquer aux codes à barres pris en charge. Cette propriété s'applique uniquement aux codes à barres bidimensionnels (2D).
Chaîne
Lecture/écriture
moduleHeight
Détermine la hauteur d'une série de barres utilisées pour encoder un caractère de texte fourni.
Chaîne
Lecture/écriture
moduleWidth
Spécifie différents aspects d'un code à barres en fonction de la classe de codes à barres utilisée.
Chaîne
Lecture/écriture
printCheckDigit
Spécifie si les chiffres de contrôle doivent être imprimés dans le texte affichable.
Chaîne
Lecture/écriture
rowColumnRatio
Un rapport facultatif rangées/colonnes pour les codes à barres 2D pris en charge.
Chaîne
Lecture/écriture
startChar
Indique le caractère de commande de départ facultatif à ajouter au début des données du code à barres.
Chaîne
Lecture/écriture
textLocation
Indique l'emplacement de tout texte associé au code à barres.
Chaîne
Lecture/écriture
truncate
Tronque le bord droit du code à barres pour les formats pris en charge.
Chaîne
Lecture/écriture
type
Spécifie le modèle utilisé par un objet.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
wideNarrowRatio
Spécifie un rapport barre large/barre étroite dans les codes à barres pris en charge.
Chaîne
Lecture/écriture
Méthodes
Non


bind

L'objet bind contrôle le comportement de son objet parent au cours des opérations de fusion.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
command
exclGroup
field
proto
subform

bind
picture
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
contentType
Spécifie le type de contenu présent dans le document référencé, à savoir MIME.
Chaîne
Lecture/écriture
match
Contrôle le rôle de l'objet encadré lors d'une opération de liaison de données (fusion).
Chaîne
Lecture/écriture
ref
Spécifie une expression de syntaxe de référence définissant le noeud dans le modèle de données auquel le conteneur englobant est associé.
Chaîne
Lecture/écriture
transferEncoding
Indique l'encodage du contenu binaire dans le document référencé.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


bindItems

L'objet bindItems identifie une série de noeuds de données à lier.
L'application de l'objet bindItems est une opération de liaison. Les liens entre les éléments de liste et les données référencées sont actifs. Toute modification apportée aux données provoque la mise à jour immédiate des éléments de la liste.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
field
proto

bindItems
ref
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
connection
Spécifie le nom du contrôle de connexion associé dans l'ensemble de connexions.
Chaîne
Lecture/écriture
labelRef
Renvoie une valeur de données pour chaque noeud de données dans le jeu identifié par l'objet ref .
Chaîne
Lecture/écriture
valueRef
Renvoie une valeur de données pour chaque noeud de données dans le jeu identifié par l'objet ref .
Chaîne
Lecture/écriture
Méthodes
Non


bookend

L'objet bookend stocke des propriétés identifiant des sous-formulaires facultatifs encadrant le contenu du sous-formulaire parent.
La propriété leader identifie un sous-formulaire facultatif subform ou subformSet disposé en premier, avant le contenu du conteneur parent. La propriété trailer identifie un sous-formulaire facultatif subform ou subformSet disposé en dernier, après le contenu du conteneur parent. Ainsi, ces propriétés encadrent le contenu du conteneur parent et ce, quel que soit le nombre d'objets contentArea ou pageArea englobés par le conteneur parent.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
subform
subformSet

bookend
Sans
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
leader
Indique l'objet subform ou subformSet devant être placé en haut d'une zone de contenu ou d'une zone de page.
Chaîne
Lecture/écriture
trailer
Indique l'objet subform ou subformSet devant être placé en bas d'une zone de contenu ou d'une zone de page.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


boolean

L'objet boolean décrit une unité de contenu unique représentant une valeur logique booléenne.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
desc
exObject
extras
items
proto
value
variable
boolean
Non
Classe parent
Classe de content
Propriétés

Nom

Description

Type

Accès
{par défaut}
Représente la valeur réelle stockée par un objet.
Booléen
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
value
Indique la valeur de l'objet actuel.
Booléen
Lecture/écriture
Méthodes
Non


border

L'objet border décrit la bordure entourant un objet.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
checkButton
choiceList
dateTimeEdit
draw
exclGroup
field
imageEdit
numericEdit
passwordEdit
proto
signature
subform
textEdit

border
corner
edge
extras
fill
margin
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
break
Indique les contraintes de déplacement vers une nouvelle page ou zone de contenu après la génération d'un objet.
Chaîne
Lecture/écriture
hand
Décrit la justification d'une ligne ou d'un bord.
Chaîne
Lecture/écriture
presence
Indique si un objet est visible ou non.
Chaîne
Lecture/écriture
relevant
Contrôle si un objet de formulaire est inclus dans l'opération d'impression.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


break

L'objet break décrit les contraintes liées au déplacement vers une nouvelle page ou zone de contenu avant ou après la génération d'un objet.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
subform
subformSet
break
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
after
Indique les contraintes de déplacement vers une nouvelle page ou zone de contenu après la génération du sous-formulaire.
Chaîne
Lecture/écriture
afterTarget
Spécifie la page de destination ou la zone de contenu explicites pour la propriété after.
Chaîne
Lecture/écriture
before
Indique les contraintes de déplacement vers une nouvelle page ou zone de contenu avant la génération du sous-formulaire.
Chaîne
Lecture/écriture
beforeTarget
Spécifie la page de destination ou la zone de contenu explicites pour la propriété before.
Chaîne
Lecture/écriture
bookendLeader
Indique le sous-formulaire à placer dans la zone de contenu ou la page active avant tout autre contenu.
Chaîne
Lecture/écriture
bookendTrailer
Indique le sous-formulaire à placer dans la zone de contenu ou la page active après tout autre contenu.
Chaîne
Lecture/écriture
overflowLeader
Indique le sous-formulaire à placer en haut de la zone de contenu ou de la page lorsqu'il est activé suite à un débordement.
Chaîne
Lecture/écriture
overflowTarget
Indique la zone de contenu explicite qui servira de cible de transition lorsque la zone de contenu ou la page actuelle sera dépassée.
Chaîne
Lecture/écriture
overflowTrailer
Indique le sous-formulaire à placer au bas de la zone de contenu ou de la page en cas de débordement.
Chaîne
Lecture/écriture
startNew
Indique s'il est nécessaire de commencer une nouvelle zone de contenu ou une page même lorsque la zone de contenu ou de page actuelle est dotée du nom requis.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


breakAfter

L'objet breakAfter décrit les contraintes conditionnelles liées au déplacement vers une nouvelle page ou zone de contenu après le placement du conteneur parent. L'objet breakAfter est invoqué après la disposition du sous-formulaire parent. Les débuts ou fins sont mis en forme avant et après les sauts imposés par l'objet breakAfter.
Un objet script facultatif associé à l'objet breakAfter détermine s'il est respecté ou pas. Cet objet script est associé à la condition vraie par défaut, ce qui signifie que les objets breakAfter dépourvus d'objet script sont toujours appelés.
L'objet breakAfter fonctionne de la même façon que la syntaxe désapprouvée de break.after et afterTarget.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
subform
subformSet

breakAfter
script
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
leader
Indique l'objet subform ou subformSet devant être placé en haut d'une zone de contenu ou d'une zone de page.
Chaîne
Lecture/écriture
startNew
Indique s'il est nécessaire de commencer une nouvelle zone de contenu ou une page même lorsque la zone de contenu ou de page actuelle est dotée du nom requis.
Chaîne
Lecture/écriture
target
Indique l'objet sur lequel l'événement a une influence.
Chaîne
Lecture/écriture
targetType
Indique les contraintes de déplacement vers une nouvelle page ou zone de contenu avant la disposition du sous-formulaire parent.
Chaîne
Lecture/écriture
trailer
Indique l'objet subform ou subformSet devant être placé en bas d'une zone de contenu ou d'une zone de page.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


breakBefore

L'objet breakBefore décrit les contraintes conditionnelles liées au déplacement vers une nouvelle page ou zone de contenu avant le placement du conteneur parent. L'objet breakBefore est invoqué avant la disposition du sous-formulaire parent. Les débuts et fins sont mis en forme avant et après les sauts imposés par l'objet breakBefore.
Un objet script facultatif associé à l'objet breakBefore détermine s'il est respecté ou pas. Cet objet script est associé à la condition vraie par défaut, ce qui signifie que les objets breakBefore dépourvus d'objet script sont toujours appelés.
L'objet breakBefore fonctionne de la même façon que la syntaxe désapprouvée de break.before et beforeTarget.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
subform
subformSet

breakBefore
script
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
leader
Indique l'objet subform ou subformSet devant être placé en haut d'une zone de contenu ou d'une zone de page.
Chaîne
Lecture/écriture
startNew
Indique s'il est nécessaire de commencer une nouvelle zone de contenu ou une page même lorsque la zone de contenu ou de page actuelle est dotée du nom requis.
Chaîne
Lecture/écriture
target
Indique l'objet sur lequel l'événement a une influence.
Chaîne
Lecture/écriture
targetType
Indique les contraintes de déplacement vers une nouvelle page ou zone de contenu avant la disposition du sous-formulaire parent.
Chaîne
Lecture/écriture
trailer
Indique l'objet subform ou subformSet devant être placé en bas d'une zone de contenu ou d'une zone de page.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


button

L'objet button décrit un bouton de commande.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
ui

button
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
highlight
Indique l'aspect visuel d'un bouton lorsque celui-ci est activé par un utilisateur. Toutes les valeurs prennent en charge deux états (relâché et enfoncé) à l'exception de push qui prend en charge trois états (relâché, enfoncé et effleuré).
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


calculate

L'objet calculate contrôle le calcul de la valeur d'un champ.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
exclGroup
field
proto
subform

calculate
extras
message
script
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
override
Détermine si la valeur calculée peut être remplacée interactivement par l'utilisateur, ou si elle est désactivée quel que soit le contexte.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


caption

L'objet caption décrit un libellé descriptif associé à un objet de conception de formulaire.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
draw
exclGroup
field
proto
caption
extras
font
margin
para
value
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
placement
Indique l’emplacement d’un libellé.
Chaîne
Lecture/écriture
presence
Indique si un objet est visible ou non.
Chaîne
Lecture/écriture
reserve
Mesure qui indique la hauteur ou la largeur d’une légende.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


certificate

L'objet certificate détient un certificat.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
issuers
proto
signing

certificate
Sans
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


certificates

L'objet certificates détient une collection de filtres de certificat.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
filter
proto

certificates
issuers
keyUsage
oids
signing
subjectDNs
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
credentialServerPolicy
Indique si la vérification de l'état du certificat est nécessaire lorsqu'une signature numérique est signée. L'état du certificat peut être vérifié à l'aide d'une liste de révocation des certificats ou d'une réponse OCSP (Online Certificate Status Protocol).
Chaîne
Lecture/écriture
url
Spécifie l'URL pour cet objet.
Chaîne
Lecture/écriture
urlPolicy
(urlPolicy)Spécifie le type d'URL représenté par l'objet de certificat.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


checkButton

L'objet checkButton décrit une case à cocher ou un bouton radio.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
ui

checkButton
border
extras
margin
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
allowNeutral
Indique si la case à cocher ou le bouton radio prend en charge un troisième état représentant une valeur neutre.
Chaîne
Lecture/écriture
mark
Indique la forme à utiliser lors du remplissage d'un objet de case à cocher.
Chaîne
Lecture/écriture
shape
Indique si le contour de la case à cocher ou du bouton radio est carré ou rond.
Chaîne
Lecture/écriture
size
Mesure indiquant la taille du contour de la case à cocher ou du bouton radio, soit la hauteur et la largeur s'il s'agit d'une case à cocher, soit le diamètre s'il s'agit d'un bouton radio.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


choiceList

L'objet choiceList décrit une liste d'options. La liste d'options est spécifiée par un ou plusieurs objets apparentés.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
ui

choiceList
border
extras
margin
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
commitOn
Indique lorsque les sélections de l'utilisateur sont transmises au modèle de données.
Chaîne
Lecture/écriture
open
Détermine le moment où la liste à choix multiples est présentée par les applications interactives.
Chaîne
Lecture/écriture
textEntry
Détermine si un utilisateur peut saisir une valeur dans une liste déroulante.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


Couleur

L'objet color décrit une couleur unique sur un formulaire.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
corner
edge
fill
linear
pattern
proto
radial
stipple
color
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
cSpace
Spécifie l'espace colorimétrique.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
value
Indique la valeur de l'objet actuel.
Chaîne
Lecture/écriture
Méthodes
Non


comb

L'objet comb décrit un champ peigne, où chaque lettre du champ est séparé par une ligne verticale noire tendue entre les bords supérieur et inférieur du champ.
Seuls les champs peigne d'une seule ligne peuvent être créés. Si un objet textEdit est un champ à plusieurs lignes ou un champ de texte enrichi, la présence d'un objet peigne sera considérée comme une erreur et générera un message d'erreur. La propriété maxChars sur l'objet textEdit détermine le nombre de peignes à créer.
L'objet comb n'est disponible que pour les formulaires PDF interactifs ou dynamiques. Les formulaires PDF statiques, et tous les autres formats de sortie, ignoreront cet objet.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
textEdit (textEdit.comb est réservé pour une utilisation ultérieure)

comb
Sans
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
numberOfCells
Indique le nombre de cellules dessinées pour un champ peigne. Ceci n'est pas affecté par le nombre de caractères dans la valeur du champ.
Entier
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


command

L'objet command spécifie une seule commande à exécuter sur la source de données.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
source

command
delete
insert
query
update
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
timeout
Spécifie le nombre de secondes autorisé pour la tentative d'exécution de la requête.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


connect

L'objet connect décrit la relation entre son objet conteneur et une connexion à un service Web, un schéma ou une description de données. Les connexions sont définies hors de la conception de formulaire dans un paquet séparé doté de son propre schéma.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
exclGroup
field
proto
source
subform

connect
connectString
password
picture
user
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
connection
Spécifie le nom du contrôle de connexion associé dans l'ensemble de connexions.
Chaîne
Lecture/écriture
delayedOpen
Spécifie la durée, en secondes, du délai d'ouverture de la source de données une fois la connexion établie.
Chaîne
Lecture/écriture
ref
Spécifie une expression de syntaxe de référence définissant le noeud dans le modèle de données auquel le conteneur englobant est associé.
Chaîne
Lecture/écriture
timeout
Spécifie le nombre de secondes autorisé pour la tentative d'exécution de la requête.
Chaîne
Lecture/écriture
usage
Spécifie les contextes d'utilisation de la connexion.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


connectionSet

L'objet connectionSet constitue l'objet racine du modèle connectionSet.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
Sans

connectionSet
wsdlConnection
xsdConnection
Classe parent
Classe de model
Propriétés
Non
Méthodes
Non


connectString

L'objet connectString spécifie la chaîne de connexion à utiliser pour se connecter à la base de données.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
connect

connectString
Non
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


contentArea

L'objet contentArea décrit une zone à l'intérieur d'une page pouvant recevoir du contenu.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
pageArea
proto

contentArea
desc
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
h
Mesure de la hauteur pour la disposition.
Chaîne
Lecture/écriture
relevant
Contrôle si un objet de formulaire est inclus dans l'opération d'impression.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
w
Mesure indiquant la largeur pour la disposition.
Chaîne
Lecture/écriture
x
Indique l’abscisse (coordonnée X) du point d'ancrage d'un conteneur par rapport au coin supérieur gauche du conteneur parent lors d'un placement avec disposition positionnée.
Chaîne
Lecture/écriture
y
Indique l'ordonnée (coordonnée X) du point d'ancrage d'un conteneur par rapport au coin supérieur gauche du conteneur parent lors d'un placement avec disposition positionnée.
Chaîne
Lecture/écriture
Méthodes
Non


corner

L'objet corner décrit l'aspect d'un sommet entre deux bords.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
border
proto
rectangle

corner
Couleur
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
inverted
Indique si un coin est convexe (les bords sont joints selon la tangente) ou s'il est inversé et prend une forme concave (les bords sont joints à angle droit).
Chaîne
Lecture/écriture
join
Indique la forme d’un coin.
Chaîne
Lecture/écriture
presence
Indique si un objet est visible ou non.
Chaîne
Lecture/écriture
radius
Indique le rayon d’un coin.
Chaîne
Lecture/écriture
stroke
Indique l'aspect d'une ligne.
Chaîne
Lecture/écriture
thickness
Indique l'épaisseur ou le poids de la ligne.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


dataGroup

L'objet dataGroup est le parent d'une liste de noeuds de données XML au sein d'un fichier de données XML. Les noeuds délimités par l'objet dataGroup sont soit des valeurs de données réelles, soit d'autres objets de données XML (comme des objets dataGroup). Les sous-formulaires, tels qu'ils apparaissent dans les fichiers de données XML, sont un exemple de groupes de données.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
dataGroup

dataGroup
dataGroup
dataValue
Classe parent
Classe de node
Propriétés
Non
Méthodes
Non


dataModel

L'objet dataModel constitue l'objet racine du modèle dataModel.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
Non

dataModel
dataWindow
Classe parent
Classe de model
Propriétés
Non
Méthodes
Non


dataValue

L'objet dataValue représente un objet conteneur prévu pour stocker une ou plusieurs valeurs. Un objet dataValue correspond, par exemple, à un champ sur un formulaire.
un objet dataValue peut posséder des objets enfant dataValue supplémentaires stockant des données complémentaires. Ce n'est généralement pas le cas.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
dataGroup

dataValue
dataValue
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
{par défaut}
Représente la valeur réelle stockée par un objet.
Variable
Lecture/écriture
contains
Spécifie si une valeur de données doit être incluse dans la valeur de l'objet parent ou en tant que propriété du parent.
Chaîne
Lecture/écriture
contentType
Spécifie le type de contenu présent dans le document référencé, à savoir MIME.
Chaîne
Lecture/écriture
isNull
Indique si la valeur de données actuelle est la valeur nulle.
Booléen
Lecture/écriture
value
Indique la valeur de l'objet actuel.
Chaîne
Lecture/écriture
Méthodes
Non


dataWindow

L'objet dataWindow représente la plage d'enregistrements de la source de données actuellement chargée dans le modèle de données.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
dataModel

dataWindow
dataGroup
dataValue
Classe parent
Classe de object
Propriétés

Nom

Description

Type

Accès
currentRecordNumber
Renvoie le numéro d’enregistrement actif dans la plage d’enregistrements contenus dans l’objet dataWindow actif.
Entier
Lecture
isDefined
Indique si une fenêtre de données valide est actuellement définie.
Booléen
Lecture
recordsAfter
Renvoie le nombre d'enregistrements dans la fenêtre de données après l'enregistrement en cours.
Entier
Lecture
recordsBefore
Renvoie le nombre d'enregistrements dans la fenêtre de données avant l'enregistrement en cours.
Entier
Lecture
Méthodes

Nom

Description

Renvoie
gotoRecord
Déplace l'enregistrement actif de la fenêtre de données vers un enregistrement particulier dans la plage d'enregistrements des données.
Vide
isRecordGroup
Indique si un objet dataGroup particulier est également un enregistrement unique.
Booléen
moveCurrentRecord
Place l'enregistrement actif dans un autre emplacement dans la plage des enregistrements.
Vide
record
Renvoie un enregistrement dans une position relative à l'enregistrement actif.
Objet


date

L'objet date décrit une date de calendrier.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
desc
exObject
extras
items
proto
value
variable
date
Non
Classe parent
Classe de content
Propriétés

Nom

Description

Type

Accès
{par défaut}
Représente la valeur réelle stockée par un objet.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
value
Indique la valeur de l'objet actuel.
Chaîne
Lecture/écriture
Méthodes
Non


dateTime

L'objet dateTime représente une date et une heure.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
desc
exObject
extras
items
proto
value
variable
dateTime
Non
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
{par défaut}
Représente la valeur réelle stockée par un objet.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
value
Indique la valeur de l'objet actuel.
Chaîne
Lecture/écriture
Méthodes
Non


dateTimeEdit

L'objet dateTimeEdit décrit une commande destinée à faciliter la sélection de la date et de l'heure.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
ui

dateTimeEdit
border
comb
extras
margin
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
hScrollPolicy
Indique si un champ peut défiler horizontalement.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


decimal

L'objet decimal représente un nombre doté d'un nombre de chiffres fixe après la virgule.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
desc
exObject
extras
items
proto
value
variable
decimal
Non
Classe parent
Classe de content
Propriétés

Nom

Description

Type

Accès
{par défaut}
Représente la valeur réelle stockée par un objet.
Double
Lecture/écriture
fracDigits
Indique le nombre maximum de chiffres (inclusifs) suivant la décimale à capturer et à stocker.
Chaîne
Lecture/écriture
leadDigits
Indique le nombre maximum de chiffres (inclusifs) précédant la décimale à capturer et à stocker.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
value
Indique la valeur de l'objet actuel.
Chaîne
Lecture/écriture
Méthodes
Non


defaultUi

L'objet defaultUi contrôle la représentation des objets dont l'aspect est délégué à l'application.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
ui

defaultUi
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


delete

L'objet delete spécifie l'opération de suppression de l'enregistrement en cours de la source de données.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
command

delete
Non
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


desc

L'objet desc décrit des métadonnées affichables.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
zone
contentArea
draw
exclGroup
field
pageArea
proto
subform
subformSet
desc
boolean
date
dateTime
decimal
exData
float
image
integer
Texte
time
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


digestMethod

L'objet digestMethod répertorie des algorithmes digest pouvant être utilisés lors de la signature. Les valeurs valides pour PDF 1.7 sont SHA1, SHA256, SHA384, SHA512 et RIPEMD160.
Cet objet s'applique uniquement si les informations d'identification numériques qu'utilise un utilisateur contiennent des clés RSA publiques ou privées. Si elles contiennent des clés DSA publiques ou privées, l'algorithme digest est toujours SHA1 et cet objet n'est pas pris en compte. La valeur par défaut, si elle n'est pas spécifiée, dépend de l'implémentation.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
digestMethods

digestMethod
Non
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


digestMethods

L'objet digestMethods contient une liste de valeurs d'objet digestMethod admises. Si les informations d'identification contiennent des clés RSA publiques ou privées, les valeurs valides sont SHA1, SHA256, SHA384, SHA512, RIPEMD160. Si les informations d'identification contiennent des clés DSA publiques ou privées, la seule valeur valide est SHA1.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
filter

digestMethods
digestMethod
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
type
Spécifie le modèle utilisé par un objet.
Chaîne
Read \Write
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


draw

L'objet draw contient le contenu non interactif de la conception de formulaire. Par exemple, dans LiveCycle Designer, l'objet draw décrit le texte statique et les objets statiques Image, Cercle, Ligne et Rectangle.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
zone
pageArea
proto
subform
draw
assist
border
caption
desc
extras
font
margin
para
setProperty
traversal
ui
value
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
{par défaut}
Représente la valeur réelle stockée par un objet.
Chaîne
Lecture/écriture
anchorType
Indique l'emplacement du point d'ancrage du conteneur lorsque la stratégie de disposition positionnée est utilisée.
Chaîne
Lecture/écriture
colSpan
Spécifie le nombre de colonnes étendues par cet objet lorsqu'il est incorporé dans un sous-formulaire doté d'un type de disposition des rangées particulier.
Chaîne
Lecture/écriture
h
Mesure de la hauteur pour la disposition.
Chaîne
Lecture/écriture
hAlign
Indique l'alignement de texte horizontal.
Chaîne
Lecture/écriture
locale
Indique la langue, la monnaie et le format des date/heure à utiliser pour le contenu de l'objet.
Chaîne
Lecture/écriture
maxH
Indique la hauteur maximale à des fins de disposition.
Chaîne
Lecture/écriture
maxW
Indique la largeur maximale à des fins de disposition.
Chaîne
Lecture/écriture
minH
Indique la hauteur maximale à des fins de disposition.
Chaîne
Lecture/écriture
minW
Indique la largeur maximale à des fins de disposition.
Chaîne
Lecture/écriture
presence
Indique si un objet est visible ou non.
Chaîne
Lecture/écriture
rawValue
Indique la valeur non mise en forme de l'objet actuel.
Chaîne
Lecture/écriture
relevant
Contrôle si un objet de formulaire est inclus dans l'opération d'impression.
Chaîne
Lecture/écriture
rotate
Fait pivoter l'objet autour de son point d'ancrage selon l'angle indiqué.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
vAlign
Indique l'alignement de texte vertical.
Chaîne
Lecture/écriture
w
Mesure indiquant la largeur pour la disposition.
Chaîne
Lecture/écriture
x
Indique l’abscisse (coordonnée X) du point d'ancrage d'un conteneur par rapport au coin supérieur gauche du conteneur parent lors d'un placement avec disposition positionnée.
Chaîne
Lecture/écriture
y
Indique l'ordonnée (coordonnée X) du point d'ancrage d'un conteneur par rapport au coin supérieur gauche du conteneur parent lors d'un placement avec disposition positionnée.
Chaîne
Lecture/écriture
Méthodes
Non


dSigData

L'objet dSigData décrit une unité de donnée de signature numérique XML.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
A déterminer

dSigData
Non
Classe parent
Classe de node
Propriétés
Non
Méthodes
Non


edge

L'objet edge décrit un arc, une ligne, ou le côté d'une bordure ou d'un rectangle.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
arc
border
line
proto
rectangle
edge
Couleur
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
cap
Spécifie le rendu d'extrémité du contour.
Chaîne
Lecture/écriture
presence
Indique si un objet est visible ou non.
Chaîne
Lecture/écriture
stroke
Indique l'aspect d'une ligne.
Chaîne
Lecture/écriture
thickness
Indique l'épaisseur ou le poids de la ligne.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


encoding

L'objet encoding correspond à l'élément PDFL subFilters. Les valeurs valides pour Adobe sont adbe.x509.rsa_sha1, adbe.pkcs7.detached et adbe.pkcs7.sha1, mais d'autres gestionnaires de protection peuvent définir leurs propres valeurs.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
encodings

encoding
Non
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


encodings

L'objet encodings contient une liste de valeurs d'objet encoding admises.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
filter
submit

encodings
encoding
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
type
Spécifie le modèle utilisé par un objet.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


event

L'objet event provoque l'exécution d'un script ou l'envoi de données lors d'un événement particulier.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
exclGroup
field
proto
subform
event
extras
execute
script
submit
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
activity
Indique le nom de l'événement.
Chaîne
Lecture/écriture
ref
Spécifie une expression de syntaxe de référence définissant le noeud dans le modèle de données auquel le conteneur englobant est associé.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


eventPseudoModel

L'objet eventPseudoModel constitue l'objet racine du modèle d'événement.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
Non

eventPseudoModel
Non
Classe parent
Classe de object
Propriétés

Nom

Description

Type

Accès
change
Indique la valeur saisie ou collée par un utilisateur dans un champ immédiatement après avoir effectué une opération.
Chaîne
Lecture/écriture
commitKey
Indique comment l'utilisateur a défini la valeur actuelle d'un champ de formulaire.
Entier
Lecture/écriture
fullText
Représente la valeur pleine (non tronquée) que l'utilisateur colle dans un champ de formulaire.
Chaîne
Lecture/écriture
keyDown
Détermine si un utilisateur appuie sur une touche fléchée pour effectuer une sélection. Cette propriété est uniquement disponible pour les zones de liste et les listes déroulantes.
Booléen
Lecture/écriture
modifier
Détermine l'utilisation de la touche de modification (par exemple, Ctrl sous Windows) lors de l'exécution d'un événement particulier.
Booléen
Lecture/écriture
newContentType
Indique le type de contenu de la propriété newText.
Chaîne
Lecture/écriture
newText
Indique le contenu du champ une fois qu'il a été modifié suite aux actions de l'utilisateur.
Chaîne
Lecture/écriture
prevContentType
Indique le type de contenu de la valeur spécifiée pour la propriété prevText.
Chaîne
Lecture/écriture
prevText
Indique le contenu du champ avant qu'il soit modifié suite aux actions de l'utilisateur.
Chaîne
Lecture/écriture
reenter
Indique si l’événement enter se produit pour la première fois. L’événement enter se produit chaque fois qu’un utilisateur clique sur un champ.
Booléen
Lecture/écriture
selEnd
Indique la position de l'index pour le dernier caractère de la sélection de texte stockée dans la propriété prevText lors d'un événement de modification.
Entier
Lecture/écriture
selStart
Indique la position de l'index pour le premier caractère de la sélection de texte stockée dans la propriété prevText lors d'un événement de modification.
Entier
Lecture/écriture
shift
Indique si la touche Maj est enfoncée lors d'un événement donné.
Booléen
Lecture/écriture
soapFaultCode
Indique tout code incorrect survenant lors de la tentative d'exécution par l'utilisateur d'une connexion au service Web.
Chaîne
Lecture/écriture
soapFaultString
Indique le message descriptif correspondant à un code incorrect lors de la connexion à un service Web particulier.
Chaîne
Lecture/écriture
target
Indique l'objet sur lequel l'événement a une influence.
Chaîne
Lecture/écriture
Méthodes

Nom

Description

Renvoie
emit
Indique au gestionnaire d'événements de formulaire qu'un événement est survenu.
Vide
reset
Réinitialise toutes les propriétés dans le modèle d'événements du formulaire XML.
Vide


exclGroup

L'objet exclGroup décrit une relation d'exclusion mutuelle entre conteneurs.
Un groupe d'exclusion est utilisé pour provoquer l'exclusion mutuelle de boutons radio. Lorsqu'un utilisateur active un membre de la série, les autres membres sont automatiquement désactivés. Par exemple, si le jeu se compose de boutons radio, l'activation d'un bouton particulier provoque la désactivation des autres boutons.
Chaque membre du groupe d'exclusion est associé à une valeur on et à une valeur off. Lorsqu'un membre est activé, la valeur on est prise en compte par défaut. Lorsqu'il est désactivé, la valeur off est prise en compte par défaut. La valeur on pour chaque membre d'un groupe d'exclusion particulier doit être unique.
Lorsque un membre est sélectionné dans le groupe d'exclusion du formulaire, la valeur de chaque membre est réglée sur on ou off, selon le cas. De même, lorsque la valeur on est affectée au membre du groupe d'exclusion, les autres membres sont désactivés.
Une valeur peut également être associée au groupe d'exclusion lui-même. Dans ce cas, chaque membre n'est activé que si la valeur correspond à la valeur on de ce membre.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
zone
pageArea
proto
subform
exclGroup
assist
bind
border
calculate
caption
connect
desc
event
extras
field
margin
para
setProperty
traversal
validate
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
{par défaut}
Représente la valeur réelle stockée par un objet.
Chaîne
Lecture/écriture
access
Définit l'accès de l'utilisateur au contenu d'un conteneur.
Chaîne
Lecture/écriture
accessKey
Spécifie une touche d'accès rapide utilisée par une application interactive pour déplacer la cible d'action vers un élément de champ particulier.
Chaîne
Lecture/écriture
anchorType
Indique l'emplacement du point d'ancrage du conteneur lorsque la stratégie de disposition positionnée est utilisée.
Chaîne
Lecture/écriture
borderColor
Indique la valeur de la couleur de la bordure pour ce champ.
Chaîne
Lecture/écriture
borderWidth
Indique la largeur de la bordure pour ce champ.
Chaîne
Lecture/écriture
colSpan
Spécifie le nombre de colonnes étendues par cet objet lorsqu'il est incorporé dans un sous-formulaire doté d'un type de disposition des rangées particulier.
Chaîne
Lecture/écriture
fillColor
La valeur de la couleur de fond pour ce champ.
Chaîne
Lecture/écriture
h
Mesure de la hauteur pour la disposition.
Chaîne
Lecture/écriture
hAlign
Indique l'alignement de texte horizontal.
Chaîne
Lecture/écriture
layout
Indique la stratégie de disposition utilisée par cet objet.
Chaîne
Lecture/écriture
mandatory
Indique la valeur nullTest pour le champ.
Chaîne
Lecture/écriture
mandatoryMessage
Indique la chaîne de message obligatoire pour ce champ.
Chaîne
Lecture/écriture
maxH
Indique la hauteur maximale à des fins de disposition.
Chaîne
Lecture/écriture
maxW
Indique la largeur maximale à des fins de disposition.
Chaîne
Lecture/écriture
minH
Indique la hauteur maximale à des fins de disposition.
Chaîne
Lecture/écriture
minW
Indique la largeur maximale à des fins de disposition.
Chaîne
Lecture/écriture
presence
Indique si un objet est visible ou non.
Chaîne
Lecture/écriture
rawValue
Indique la valeur non mise en forme de l'objet actuel.
Chaîne
Lecture/écriture
relevant
Contrôle si un objet de formulaire est inclus dans l'opération d'impression.
Chaîne
Lecture/écriture
transient
Spécifie si l'application de traitement doit enregistrer la valeur du groupe d'exclusion lors de l'envoi du formulaire ou d'une opération de sauvegarde.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
validationMessage
Indique la chaîne de message de validation pour ce champ.
Chaîne
Lecture/écriture
vAlign
Indique l'alignement de texte vertical.
Chaîne
Lecture/écriture
w
Mesure indiquant la largeur pour la disposition.
Chaîne
Lecture/écriture
x
Indique l’abscisse (coordonnée X) du point d'ancrage d'un conteneur par rapport au coin supérieur gauche du conteneur parent lors d'un placement avec disposition positionnée.
Chaîne
Lecture/écriture
y
Indique l'ordonnée (coordonnée X) du point d'ancrage d'un conteneur par rapport au coin supérieur gauche du conteneur parent lors d'un placement avec disposition positionnée.
Chaîne
Lecture/écriture
Méthodes

Nom

Description

Renvoie
execCalculate
Exécute le script de calcul du champ.
Vide
execEvent
Exécute le script d'événement de l'objet.
Vide
execInitialize
Exécute le script d'initialisation du champ.
Vide
execValidate
Exécute le script de validation du champ.
Vide
selectedMember
Renvoie le membre sélectionné d'un groupe d'exclusion.
Objet


exData

L'objet exData décrit un type de données étranger.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
desc
exObject
extras
items
proto
value
variable
exData
Non
Classe parent
Classe de content
Propriétés

Nom

Description

Type

Accès
{par défaut}
Représente la valeur réelle stockée par un objet.
Chaîne
Lecture/écriture
contentType
Spécifie le type de contenu présent dans le document référencé, à savoir MIME.
Chaîne
Lecture/écriture
href
Indique une référence à un fichier ou à une ressource externe.
Chaîne
Lecture/écriture
maxLength
Spécifie la longueur de contenu maximale autorisée (incluse) ou -1 pour indiquer qu'aucune longueur maximale n'est imposée.
Chaîne
Lecture/écriture
transferEncoding
Indique l'encodage du contenu binaire dans le document référencé.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


execute

L'objet execute contrôle à quel endroit un événement est géré.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
event
proto

execute
Non
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
connection
Spécifie le nom du contrôle de connexion associé dans l'ensemble de connexions.
Chaîne
Lecture/écriture
executeType
Indique s'il faut importer les nouvelles données dans le formulaire existant ou les fusionner dans la conception de formulaire initiale en vue d'obtenir un nouveau formulaire.
Chaîne
Lecture/écriture
runAt
Indique quelle application peut exécuter le script.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


exObject

L'objet exObject décrit un programme unique ou un objet étranger particulier à un type d'implémentation.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
zone
exObject
proto
subform
ui
exObject
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
archive
Spécifie l'emplacement URI d'un fichier d'archive pouvant contenir un code de programmation associé à l'objet exObject .
Chaîne
Lecture/écriture
classId
Spécifie un nom ou un emplacement URI pour le code de programmation représenté par l'objet.
Chaîne
Lecture/écriture
codeBase
Spécifie un emplacement URI pouvant être utilisé pour faciliter la résolution d'une propriété classId relative.
Chaîne
Lecture/écriture
codeType
Spécifie un identifiant de type MIME capable d'identifier le code de programmation représenté par l'objet.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


extras

L'objet extras joue le rôle d'enceinte autour d'un ou de plusieurs jeux de propriétés personnalisées. Le contenu de cet objet peut être utilisé par des applications personnalisées.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
zone
barcode
border
break
button
calculate
caption
checkButton
choiceList
Couleur
contentArea
corner
dateTimeEdit
defaultUi
draw
edge
event
exclGroup
exObject
extras
field
fill
font
format
imageEdit
keep
linear
margin
numericEdit
occur
pageArea
pageSet
passwordEdit
pattern
proto
radial
signature
solid
stipple
subform
subformSet
template
textEdit
traversal
traverse
ui
validate

extras
boolean
date
dateTime
decimal
exData
extras
float
image
integer
Texte
time
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
type
Spécifie le modèle utilisé par un objet.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


field

L'objet field décrit un conteneur interactif unique pouvant récupérer et présenter un contenu de données.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
zone
exclGroup
pageArea
proto
subform
field
assist
bind
bindItems
border
calculate
caption
connect
desc
event
extras
font
format
items
margin
para
setProperty
traversal
ui
validate
value
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
{par défaut}
Représente la valeur réelle stockée par un objet.
Variable
Lecture/écriture
access
Définit l'accès de l'utilisateur au contenu d'un conteneur.
Chaîne
Lecture/écriture
accessKey
Spécifie une touche d'accès rapide utilisée par une application interactive pour déplacer la cible d'action vers un élément de champ particulier.
Chaîne
Lecture/écriture
anchorType
Indique l'emplacement du point d'ancrage du conteneur lorsque la stratégie de disposition positionnée est utilisée.
Chaîne
Lecture/écriture
borderColor
Indique la valeur de la couleur de la bordure pour ce champ.
Chaîne
Lecture/écriture
borderWidth
Indique la largeur de la bordure pour ce champ.
Chaîne
Lecture/écriture
colSpan
Spécifie le nombre de colonnes étendues par cet objet lorsqu'il est incorporé dans un sous-formulaire doté d'un type de disposition des rangées particulier.
Chaîne
Lecture/écriture
fillColor
La valeur de la couleur de fond pour ce champ.
Chaîne
Lecture/écriture
fontColor
La valeur de la couleur de premier plan pour ce champ.
Chaîne
Lecture/écriture
formatMessage
Indique la chaîne de message pour la validation du format pour ce champ.
Chaîne
Lecture/écriture
formattedValue
Indique la valeur formatée pour le champ.
Chaîne
Lecture/écriture
h
Mesure de la hauteur pour la disposition.
Chaîne
Lecture/écriture
hAlign
Indique l'alignement de texte horizontal.
Chaîne
Lecture/écriture
locale
Indique la langue, la monnaie et le format des date/heure à utiliser pour le contenu de l'objet.
Chaîne
Lecture/écriture
mandatory
Indique la valeur nullTest pour le champ.
Chaîne
Lecture/écriture
mandatoryMessage
Indique la chaîne de message obligatoire pour ce champ.
Chaîne
Lecture/écriture
maxH
Indique la hauteur maximale à des fins de disposition.
Chaîne
Lecture/écriture
maxW
Indique la largeur maximale à des fins de disposition.
Chaîne
Lecture/écriture
minH
Indique la hauteur maximale à des fins de disposition.
Chaîne
Lecture/écriture
minW
Indique la largeur maximale à des fins de disposition.
Chaîne
Lecture/écriture
parentSubform
Indique le sous-formulaire (page) parent du champ.
Objet
Lecture
presence
Indique si un objet est visible ou non.
Chaîne
Lecture/écriture
rawValue
Indique la valeur non mise en forme de l'objet actuel.
Variable
Lecture/écriture
relevant
Contrôle si un objet de formulaire est inclus dans l'opération d'impression.
Chaîne
Lecture/écriture
rotate
Fait pivoter l'objet autour de son point d'ancrage selon l'angle indiqué.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
validationMessage
Indique la chaîne de message de validation pour ce champ.
Chaîne
Lecture/écriture
vAlign
Indique l'alignement de texte vertical.
Chaîne
Lecture/écriture
w
Mesure indiquant la largeur pour la disposition.
Chaîne
Lecture/écriture
x
Indique l’abscisse (coordonnée X) du point d'ancrage d'un conteneur par rapport au coin supérieur gauche du conteneur parent lors d'un placement avec disposition positionnée.
Chaîne
Lecture/écriture
y
Indique l'ordonnée (coordonnée X) du point d'ancrage d'un conteneur par rapport au coin supérieur gauche du conteneur parent lors d'un placement avec disposition positionnée.
Chaîne
Lecture/écriture
Méthodes

Nom

Description

Renvoie
addItem
Ajoute de nouveaux éléments au champ de formulaire actuel. Par exemple, cette méthode permet d'ajouter des éléments à une liste déroulante.
Vide
boundItem
Récupère la valeur liée d'un élément d'affichage spécifique dans une liste déroulante ou une zone de liste.
Chaîne
clearItems
Supprime tous les éléments du champ. Cette méthode supprime par exemple tous les éléments contenus dans une zone de liste ou une liste déroulante.
Vide
execCalculate
Exécute le script de calcul du champ.
Vide
execEvent
Exécute le script d'événement de l'objet.
Vide
execInitialize
Exécute le script d'initialisation du champ.
Vide
execValidate
Exécute le script de validation du champ.
Vide


fill

L'objet fill applique une couleur et des rendus facultatifs à la zone délimitée par un objet.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
arc
border
font
proto
rectangle
fill
Couleur
extras
linear
pattern
radial
solid
stipple
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
presence
Indique si un objet est visible ou non.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


filter

L'objet filter décrit les critères de filtrage des certificats signés. Les certificats signés sont utilisés pour générer des signatures de données conformément aux normes W3C XML.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
signature
signData
filtrer
certificates
digestMethods
encodings
handler
mdp
reasons
timeStamp
Les objets enfant mdp, reasons et timestamp ne sont valides que si l'objet parent est signature. Si l'objet parente est signData, LiveCycle Designer ne prend pas en compte ces objets enfant et ne les génère pas.
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
addRevocationInfo
Indique si l'état du certificat est vérifié lorsqu'une signature numérique est signée. L'état du certificat peut être vérifié à l'aide d'une liste de révocation des certificats ou d'une réponse OCSP (Online Certificate Status Protocol).
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


float

L'objet float décrit une valeur en virgule flottante.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
desc
exObject
extras
items
proto
value
variable
float
Non
Classe parent
Classe de content
Propriétés

Nom

Description

Type

Accès
{par défaut}
Représente la valeur réelle stockée par un objet.
Double
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
value
Indique la valeur de l'objet actuel.
Double
Lecture/écriture
Méthodes
Non


font

L'objet font décrit une police utilisée sur un formulaire.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
caption
draw
field
proto
font
extras
fill
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
baselineShift
Indique une mesure positive permettant de décaler une police vers le haut par rapport à la ligne de base ou indique une mesure négative décalant une police vers le bas par rapport à la ligne de base.
Chaîne
Lecture/écriture
lineThrough
Indique l'activation d'une ligne simple ou double traversant le texte (propriété également connue sous le nom de texte barré).
Chaîne
Lecture/écriture
lineThroughPeriod
Contrôle l'aspect de la ligne sur le texte (propriété également connue sous le nom de Barré).
Chaîne
Lecture/écriture
overline
Indique l’activation et le type de ligne de séparation supérieure.
Chaîne
Lecture/écriture
overlinePeriod
Contrôle l'aspect de la ligne de séparation supérieure.
Chaîne
Lecture/écriture
posture
Indique le style d’une police.
Chaîne
Lecture/écriture
size
Mesure indiquant la taille du contour de la case à cocher ou du bouton radio, soit la hauteur et la largeur s'il s'agit d'une case à cocher, soit le diamètre s'il s'agit d'un bouton radio.
Chaîne
Lecture/écriture
typeface
Indique le nom d’une police de caractères.
Chaîne
Lecture/écriture
underline
Indique l’activation et le type de soulignement.
Chaîne
Lecture/écriture
underlinePeriod
Contrôle l'aspect du soulignement.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
weight
Définit l’épaisseur du style d’une police de caractères.
Chaîne
Lecture/écriture
Méthodes
Non


formulaire

L'objet form constitue l'objet racine du modèle de formulaire.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
Non

form
desc
extras
Classe parent
Classe de model
Propriétés
Non
Méthodes

Nom

Description

Renvoie
execCalculate
Exécute le script de calcul du champ.
Vide
execInitialize
Exécute le script d'initialisation du champ.
Vide
execValidate
Exécute le script de validation du champ.
Vide
formNodes
Renvoie la liste de tous les objets de modèle du formulaire liés à un objet de données spécifié.
Objet
recalculate
Force l'exécution d'un jeu spécifique de scripts sur des événements de calculs. Les événements spécifiques peuvent être des événements de calculs en attente ou l'intégralité des événements de calculs.
Vide
remerge
Force la fusion des modèles de données et la conception de modèle pour recréer un modèle de formulaire. Une fois la fusion effectuée, tout traitement de modèle de disposition doit être à nouveau effectué pour déterminer le formulaire.
Vide


format

L'objet format renferme des informations relatives au formatage des valeurs d'entrée ou de sortie, telles que la clause d'image.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
field
proto

format
extras
picture
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


handler

L'objet handler contrôle le gestionnaire de signatures utilisé pour les opérations de signature de données, conformément aux normes W3C XML.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
filter
proto
handler
Non
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
type
Spécifie le modèle utilisé par un objet.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
version
Indique le numéro de version de l'application active.
Chaîne
Lecture
Méthodes
Non


hostPseudoModel

L'objet hostPseudoModel constitue l'objet racine du modèle d'hôte. Utilisez les propriétés et méthodes de l'hôte au moment de l'exécution.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
Non

hostPseudoModel
Non
Classe parent
Classe de object
Propriétés

Nom

Description

Type

Accès
appType
Indique le nom de l'application client contenant un formulaire existant.
Chaîne
Lecture/écriture
calculationsEnabled
Indique si les scripts de calcul seront exécutés ou non.
Booléen
Lecture/écriture
currentPage
Définit la page active d'un document lors de l'exécution.
Entier
Lecture/écriture
language
Renvoie la langue de l'application hôte en cours d'exécution.
Chaîne
Lecture
numPages
Renvoie le nombre de pages que compte le document actif.
Entier
Lecture
platform
Renvoie la plate-forme de l'ordinateur qui exécute le script.
Chaîne
Lecture
title
Définit et obtient le titre du document. Cette méthode est uniquement disponible pour les applications client.
Chaîne
Lecture/écriture
validationsEnabled
Indique si les scripts de validation seront exécutés ou non.
Booléen
Lecture
variation
Indique le conditionnement de l'application exécutant le script.
Chaîne
Lecture
version
Indique le numéro de version de l'application active.
Chaîne
Lecture
Méthodes

Nom

Description

Renvoie
beep
Entraîne l'émission d'un son par le système. Cette méthode est uniquement disponible pour les applications client.
Vide
exportData
Exporte dans un fichier les données contenues dans le formulaire actif au format XDP ou XML.
Vide
gotoURL
Récupère l'URL spécifié. Cette méthode est uniquement disponible pour les applications client.
Vide
importData
Importe les données d'un fichier spécifié dans le formulaire actif.
Vide
messageBox
Affiche à l'écran une boîte de dialogue. Cette méthode est uniquement disponible pour les applications client.
Entier
openList
Ouvre une liste déroulante spécifiée par l'expression de syntaxe de référence. Cette méthode est uniquement disponible pour les applications client.
Vide
pageDown
Atteint la page suivante d'un formulaire. Utilise la méthode pageDown lors de l'exécution.
Vide
pageUp
Atteint la page précédente d'un formulaire. Utilise la méthode pageUp lors de l'exécution.
Vide
print
Imprime un nombre de pages spécifique à partir d'un document. Cette méthode est uniquement disponible pour les applications client.
Vide
resetData
Rétablit les valeurs par défaut des champs dans un document.
Vide
response
Affiche une boîte de dialogue contenant une question et un champ d'entrée permettant à l'utilisateur de répondre à la question. La valeur renvoyée est une chaîne contenant la réponse de l'utilisateur. Si l'utilisateur clique sur le bouton Annuler dans la boîte de dialogue, la réponse est nulle.
Chaîne
setFocus
Définit la sélection au clavier sur le champ défini par l'expression de syntaxe de référence. Cette méthode est uniquement disponible pour les applications client.
Vide


image

L'objet image décrit une image unique sur un formulaire.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
desc
exObject
extras
items
proto
value
variable
image
Non
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
{par défaut}
Représente la valeur réelle stockée par un objet.
Chaîne
Lecture
aspect
Indique le mode de mappage de l'image à la zone de contenu nominale du conteneur de l'image.
Chaîne
Lecture/écriture
contentType
Spécifie le type de contenu présent dans le document référencé, à savoir MIME.
Chaîne
Lecture/écriture
href
Indique une référence à un fichier ou à une ressource externe.
Chaîne
Lecture/écriture
transferEncoding
Indique l'encodage du contenu binaire dans le document référencé.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
value
Indique la valeur de l'objet actuel.
Chaîne
Lecture
Méthodes
Non


imageEdit

L'objet imageEdit renferme des commandes destinées à faciliter la manipulation des contenus d'image.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
ui

imageEdit
border
extras
margin
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
data
Indique si l'image fournie au widget doit être désignée comme référence ou incorporée.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


insert

L'objet insert spécifie l'opération d'insertion de l'enregistrement en cours de la source de données.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
command

insert
Non
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


instanceManager

L'objet instanceManager gère la création, la suppression et le déplacement de l'instance des objets de modèle de formulaire.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
subform

instanceManager
occur
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
count
Indique le nombre actuel d'instances de sous-formulaire sur un formulaire.
Chaîne
Lecture/écriture
max
Indique le nombre maximal d'occurrences pour le conteneur qui englobe ou -1 pour ne définir aucune limite supérieure pour les occurrences.
Chaîne
Lecture/écriture
min
Indique le nombre minimal d'occurrences du conteneur qui englobe.
Chaîne
Lecture/écriture
Méthodes

Nom

Description

Renvoie
addInstance
Ajoute une instance d'un sous-formulaire ou d'un jeu de sous-formulaires au modèle de formulaire.
Objet
insertInstance
Insère une nouvelle instance d'un sous-formulaire ou d'un jeu de sous-formulaires à un formulaire.
Objet
moveInstance
Déplace un objet de subform au sein d'un jeu d'instances de sous-formulaire.
Vide
removeInstance
Supprime un sous-formulaire ou un jeu de sous-formulaires spécifique du modèle de formulaire.
Vide
setInstance
Ajoute ou supprime les sous-formulaires ou jeux de sous-formulaires spécifiés du modèle de formulaire.
Vide


integer

L'objet integer décrit une valeur sous forme d'entier.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
desc
exObject
extras
items
proto
value
variable
integer
Non
Classe parent
Classe de content
Propriétés

Nom

Description

Type

Accès
{par défaut}
Représente la valeur réelle stockée par un objet.
Entier
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
value
Indique la valeur de l'objet actuel.
Entier
Lecture/écriture
Méthodes
Non


issuers

L'objet issuers décrit une collection de certificats émis compatibles avec la signature de données, conformément aux normes W3C XML.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
certificates
proto
issuers
Sans
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
type
Spécifie le modèle utilisé par un objet.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


items

L'objet items fournit une sélection d'options dans une colonne pour une zone de liste ou une case à cocher.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
field
proto

items
boolean
date
dateTime
decimal
exData
float
image
integer
Texte
time
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
presence
Indique si un objet est visible ou non.
Chaîne
Lecture/écriture
ref
Spécifie une expression de syntaxe de référence définissant le noeud dans le modèle de données auquel le conteneur englobant est associé.
Chaîne
Lecture/écriture
save
Détermine si les valeurs d'une colonne particulière désignent à la fois les valeurs d'affichage et liées, ou si les données de la colonne désignent les valeurs liées uniquement.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


keep

L'objet keep décrit les contraintes liées au maintien des sous-formulaires dans une page ou une zone de contenu.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
subform

keep
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
intact
Spécifie les contraintes liées au maintien d'un sous-formulaire dans un état intact dans une zone de contenu ou une page.
Chaîne
Lecture/écriture
next
Indique les contraintes relatives au maintien d'un sous-formulaire avec le sous-formulaire suivant au sein d'une zone de contenu ou d'une page.
Chaîne
Lecture/écriture
previous
Indique les contraintes relatives au maintien d'un sous-formulaire avec le sous-formulaire précédent au sein d'une zone de contenu ou d'une page.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


keyUsage

L'objet keyUsage décrit les paramètres d'utilisation des clés devant être définis pour le certificat de signature. Il est créé avec un caractère utilisé pour représenter chaque type d'utilisation des clés. Les neuf premiers caractères, de gauche à droite, représentent la valeur requise pour ces propriétés : digitalSignature, nonRepudiation, keyEncipherment, dataEncipherment, keyAgreement, keyCertSign, crlSign, encipherOnly, decipherOnly. Tout caractère supplémentaire est ignoré.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
certificates

keyUsage
Non
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
crlSign
Indique une extension d'utilisation acceptable devant être présente dans le certificat de signature.
Chaîne
Lecture/écriture
dataEncipherment
Indique une extension d'utilisation acceptable devant être présente dans le certificat de signature.
Chaîne
Lecture/écriture
decipherOnly
Indique une extension d'utilisation acceptable devant être présente dans le certificat de signature.
Chaîne
Lecture/écriture
digitalSignature
Indique une extension d'utilisation acceptable devant être présente dans le certificat de signature.
Chaîne
Lecture/écriture
encipherOnly
Indique une extension d'utilisation acceptable devant être présente dans le certificat de signature.
Chaîne
Lecture/écriture
keyAgreement
Indique une extension d'utilisation des clés acceptable devant être présente dans le certificat de signature.
Chaîne
Lecture/écriture
keyCertSign
Indique une extension d'utilisation des clés acceptable devant être présente dans le certificat de signature.
Chaîne
Lecture/écriture
keyEncipherment
Indique une extension d'utilisation des clés acceptable devant être présente dans le certificat de signature.
Chaîne
Lecture/écriture
nonRepudiation
Indique une extension d'utilisation des clés acceptable devant être présente dans le certificat de signature.
Chaîne
Lecture/écriture
type
Spécifie le modèle utilisé par un objet.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


layoutPseudoModel

L'objet layoutPseudoModel sert à identifier au moyen de requêtes des paramètres connus seulement au stade de la disposition du formulaire (afin de connaître, par exemple, la page sur laquelle réside un objet de conception de formulaire, le nombre total de pages, le nombre de pages sur lesquelles s'étend un objet ou encore l'orientation d'un objet de conception de formulaire).
Hiérarchie des objets

Objets parent

This object

Objets enfant
Non

layoutPseudoModel
Non
Classe parent
Classe de object
Propriétés

Nom

Description

Type

Accès
ready
Indique si le processus de disposition du formulaire est terminé et si les tâches de script peuvent commencer.
Booléen
Lecture
Méthodes

Nom

Description

Renvoie
absPage
Détermine la première page du formulaire sur laquelle s'affiche un objet de conception de formulaire donné.
Entier
absPageCount
Détermine la quantité de pages du formulaire actuel.
Entier
absPageSpan
Détermine le nombre de pages du formulaire utilisé par un objet de conception de formulaire donné.
Entier
h
Détermine la hauteur d'un objet de conception de formulaire donné.
Double
page
Détermine le numéro de page où figure l'objet de conception de formulaire donné. Dans le cas d'un objet occupant plusieurs pages, cette méthode renvoie la première page.
Entier
pageContent
Récupère les types d'objet de conception de formulaire à partir d'une page donnée d'un formulaire.
Objet
pageCount
Détermine le nombre de pages du formulaire actuel.
Entier
pageSpan
Détermine le nombre de pages logiques utilisé par un objet de conception de formulaire donné.
Entier
relayout
Applique à nouveau les options de disposition au formulaire actif.
Vide
relayoutPageArea
Remplace la disposition du contenu de l'objet pageArea par une nouvelle disposition.
Vide
w
Détermine la largeur d'un objet de conception de formulaire donné.
Double
x
Détermine l'abscisse (coordonnée x) d'un objet de conception de formulaire donné.
Double
y
Détermine l'ordonnée (coordonnée y) d'un objet de conception de formulaire donné.
Double


line

L'objet line décrit une ligne unique générée sur un formulaire.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
value

line
edge
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
hand
Décrit la justification d'une ligne ou d'un bord.
Chaîne
Lecture/écriture
slope
Indique l'orientation de la ligne.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


linear

L'objet linear décrit un remplissage dégradé linéaire sur un formulaire.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
fill
proto

linear
Couleur
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
type
Spécifie le modèle utilisé par un objet.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


manifest

L'objet manifest contient une liste de références à l'ensemble des noeuds inclus dans une signature de document.
Lorsque les objets manifest sont un enfant de l'objet signature, la signature du document protège une collection de nœuds et non l'intégralité du formulaire.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
signature
signData
manifest
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
{par défaut}
Représente la valeur réelle stockée par un objet.
Booléen
Lecture/écriture
action
Identifie les noeuds de formulaire protégés par une signature de document.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes

Nom

Description

Renvoie
evaluate
Récupère la liste des objets référencée dans l'élément Manifest.
Objet


map

L'objet map spécifie les mappages de données à partir des noms de colonnes d'une source de données.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
query

map
Non
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
bind
Spécifie le nom d'un ID de liaison unique selon lequel les colonnes de la source de données spécifiées par la propriété from sont liées.
Chaîne
Lecture/écriture
from
Spécifie le nom original de la colonne dans la source de données.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


margin

L'objet margin spécifie des valeurs de marge pour un objet de conception de formulaire.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
border
caption
checkButton
choiceList
dateTimeEdit
draw
exclGroup
field
imageEdit
numericEdit
passwordEdit
proto
signature
subform
textEdit
margin
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
bottomInset
Indique la taille d’une insertion en bas.
Chaîne
Lecture/écriture
leftInset
Indique la taille d’une insertion à gauche.
Chaîne
Lecture/écriture
rightInset
Indique la taille d’une insertion à droite.
Chaîne
Lecture/écriture
topInset
Mesure représentant la taille d’une insertion en haut.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


mdp

L'objet mdp prend en charge les signatures numériques MDP+ (Modify Detection Prevention Plus). Acrobat 8.0 et les versions ultérieures prennent en charge les signatures numériques MDP+ pour les formulaires XFA.
Dans LiveCycle Designer, les signatures MDP+ sont implémentées avec un champ de signature du document. Les champs de signature du document vous permettent de spécifier une collection d'objets de formulaire protégés par une signature de document. L'utilisation de signatures de document empêche toute modification du formulaire ou d'une partie de celui-ci.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
filter

mpd
Non
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
permissions
Spécifie les droits d'accès accordés pour un formulaire qui inclut la signature de l'auteur.
Chaîne
Lecture/écriture
signatureType
Indique le mode d'enregistrement d'un formulaire comportant une signature du document comme document PDF certifié.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


medium

L'objet medium décrit un support physique sur lequel effectuer des rendus.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
pageArea
medium
Non
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
imagingBBox
Spécifie une région sur le support où le rendu peut être effectué à l'aide de quatre mesures séparées par des virgules correspondant aux axes x et y, à la largeur et à la hauteur.
Chaîne
Lecture/écriture
long
Spécifie la longueur du bord long du support. La longueur spécifiée par la propriété long doit être supérieure à celle spécifiée par la propriété short.
Chaîne
Lecture/écriture
orientation
Indique l'orientation du support.
Chaîne
Lecture/écriture
short
Spécifie la longueur du bord court de l'objet medium .
Chaîne
Lecture/écriture
stock
Spécifie le nom d'un format de papier standard.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


message

L'objet message contient un ou plusieurs sous-objets générant des messages d'échec de validation.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
calculate
proto
validate

message
Texte
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


numericEdit

L'objet numericEdit décrit une commande destinée à faciliter la manipulation des contenus numériques.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
ui

numericEdit
border
comb
extras
margin
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
hScrollPolicy
Indique si un champ peut défiler horizontalement.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


occur

L'objet occur décrit les contraintes liées au nombre d'instances autorisé pour son conteneur englobant.
Modifiez l'objet occur à l'événement template:ready. Cependant, l'événement template:ready n'est pas accessible dans l'interface utilisateur. Vous ne pouvez pas modifier l'objet occur à l'événement form:ready, car ce dernier survient trop tard dans le traitement du formulaire.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
pageArea
pageSet
proto
subform
subformSet

occur
extras
script (occur.script est réservé pour une utilisation ultérieure)
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
initial
Indique le nombre initial d'occurrences du conteneur qui englobe.
Chaîne
Lecture/écriture
max
Indique le nombre maximal d'occurrences pour le conteneur qui englobe ou -1 pour ne définir aucune limite supérieure pour les occurrences.
Chaîne
Lecture/écriture
min
Indique le nombre minimal d'occurrences du conteneur qui englobe.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


oid

L'objet oid décrit un identifiant d'objet (OID) des stratégies de certificats devant apparaître dans la signature du certificat.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
oids
proto
oid
Sans
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


oids

L'objet oids décrit une collection d'identifiants d'objets (OID) qui s'appliquent à la signature de données, conformément aux normes W3C XML.
Cet objet n'est valide que si un objet issuers apparenté est n'est pas vide.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
certificates
proto
oid s
Sans
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
type
Spécifie le modèle utilisé par un objet.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


operation

L'objet operation représente une opération spécifique fournie par une adresse WSDL spécifique. Chaque opération correspond à une connexion de données unique.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
wsdlConnection

operation
Non
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
input
Spécifie un message d'entrée associé à une opération de connexion WSDL particulière.
Chaîne
Lecture/écriture
output
Spécifie le message de sortie associé à une opération de connexion WSDL particulière.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


overflow

L'objet overflow enregistre des propriétés utilisées lorsqu'un subform parent déborde sur la contentArea en cours.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
subform
subformSet

overflow
Sans
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
leader
Indique l'objet subform ou subformSet devant être placé en haut d'une zone de contenu ou d'une zone de page.
Chaîne
Lecture/écriture
target
Indique l'objet sur lequel l'événement a une influence.
Chaîne
Lecture/écriture
trailer
Indique l'objet subform ou subformSet devant être placé en bas d'une zone de contenu ou d'une zone de page.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


packet

L'objet packet stocke des objets non reconnus, c'est-à-dire ceux qui ne se conforment à aucun des autres modèles d'objet de formulaire XML. Cet objet permet de copier, déplacer ou récupérer les informations dans ces objets non reconnus.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
dataGroup

packet
Non
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
content
Indique le contenu de l'objet.
Chaîne
Lecture/écriture
Méthodes

Nom

Description

Renvoie
getAttribute
Récupère une valeur de propriété spécifiée.
Chaîne
removeAttribute
Supprime la propriété spécifiée.
Vide
setAttribute
Définit la valeur d'une propriété spécifiée.
Vide


pageArea

L'objet pageArea décrit une surface de rendu.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
pageSet
proto

pageArea
zone
contentArea
desc
draw
exclGroup
extras
field
medium
occur
subform
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
blank (désapprouvée)
Spécifie si la zone de page doit être vierge et par conséquent faire l'objet d'un traitement particulier par le périphérique de sortie.
Chaîne
Lecture/écriture
blankOrNotBlank
Spécifie si la zone de page doit être vierge et par conséquent faire l'objet d'un traitement particulier par le périphérique de sortie.
Chaîne
Lecture/écriture
initialNumber
Fournit le numéro de page d'origine à la première occurrence consécutive de la page, s'il s'agit d'une zone de page numérotée.
Chaîne
Lecture/écriture
numbered
Spécifie si la zone de page est assimilée à une zone de page numérotée.
Chaîne
Lecture/écriture
oddOrEven
Indique si une page est paire ou impaire pour la pagination d'un jeu de pages.
Chaîne
Lecture/écriture
pagePosition
Indique une position de la page dans un jeu de pages.
Chaîne
Lecture/écriture
relevant
Contrôle si un objet de formulaire est inclus dans l'opération d'impression.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


pageSet

L'objet pageSet décrit un jeu d'objets de zones de pages associés.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
pageSet
proto
subform

pageSet
extras
occur
pageArea
pageSet
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
relation
Indique les rapports qu'entretiennent les membres du jeu.
Chaîne
Lecture/écriture
relevant
Contrôle si un objet de formulaire est inclus dans l'opération d'impression.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


para

L'objet para spécifie les propriétés de paragraphe et d'alignement par défaut à appliquer au contenu d'un conteneur englobant.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
caption
draw
exclGroup
field
proto
subform
para
Non
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
hAlign
Indique l'alignement de texte horizontal.
Chaîne
Lecture/écriture
lineHeight
Indique la hauteur de ligne à appliquer au contenu d’un paragraphe.
Chaîne
Lecture/écriture
marginLeft
Indique la taille du retrait d’un paragraphe à gauche.
Chaîne
Lecture/écriture
marginRight
Indique la taille du retrait d’un paragraphe à droite.
Chaîne
Lecture/écriture
preserve
Spécifie les contraintes veuve/orphelin associées au comportement de débordement du contenu au sein du conteneur qui englobe.
Chaîne
Lecture/écriture
radixOffset
Spécifie une valeur de décalage pour le point d'ancrage du paragraphe.
Chaîne
Lecture/écriture
spaceAbove
Indique la quantité d’espacement vertical et la taille maximale de police sur la première ligne d’un paragraphe.
Chaîne
Lecture/écriture
spaceBelow
Indique la quantité d’espacement vertical et la taille maximale de police sur la première ligne d’un paragraphe.
Chaîne
Lecture/écriture
tabDefault
Spécifie la distance entre les taquets de tabulation par défaut.
Chaîne
Lecture/écriture
tabStops
Spécifie une liste d'emplacements de taquets de tabulation séparés par des espaces.
Chaîne
Lecture/écriture
textIndent
Indique la position horizontale de la première ligne par rapport au reste d'un paragraphe.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
vAlign
Indique l'alignement de texte vertical.
Chaîne
Lecture/écriture
Méthodes
Non


password

L'objet password spécifie le mot de passe pour la source de données (si la connexion l'exige).
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
connect

password
Non
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


passwordEdit

L'objet passwordEdit décrit une commande destinée à faciliter la manipulation des contenus de mots de passe. L'interface utilisateur masque toute représentation visuelle du contenu.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
ui

passwordEdit
border
extras
margin
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
hScrollPolicy
Indique si un champ peut défiler horizontalement.
Chaîne
Lecture/écriture
passwordChar
Indique le caractère visible à l'écran lorsqu'un utilisateur saisit un mot de passe dans le formulaire.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


pattern

L'objet pattern décrit un motif de remplissage pour un objet de conception de formulaire.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
fill
proto

pattern
Couleur
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
type
Spécifie le modèle utilisé par un objet.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


picture

L'objet picture présente des informations relatives aux masques de saisie et au formatage des valeurs de sortie.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
bind
connect
format
proto
ui
validate
picture
Non
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
{par défaut}
Représente la valeur réelle stockée par un objet.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
value
Indique la valeur de l'objet actuel.
Chaîne
Lecture/écriture
Méthodes
Non


proto

L'objet proto décrit un jeu de définitions d'objets réutilisables.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
subform

proto
arc
zone
assist
barcode
bind
bindItems
boolean
border
break
breakAfter
breakBefore
button
calculate
caption
checkButton
choiceList
Couleur
connect
contentArea
corner
date
dateTime
dateTimeEdit
decimal
defaultUi
desc
draw
edge
event
exclGroup
exData
execute
exObject
extras
field
fill
float
font
format
image
imageEdit
integer
items
keep
line
linear
margin
medium
message
numericEdit
occur
pageArea
pageSet
para
passwordEdit
pattern
picture
radial
rectangle
script
setProperty
signature
signedState
solid
speak
stipple
subform
subformSet
submit
template
Texte
textEdit
time
toolTip
traversal
traverse
ui
validate
value
variable
Classe parent
Classe de node
Propriétés
Non
Méthodes
Non


query

L'objet query représente une requête effectuée sur une source de données particulière.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
command

query
recordSet
select
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
commandType
Spécifie le type de commande utilisé par une requête de données.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


radial

L'objet radial décrit un remplissage dégradé radial.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
fill
proto

radial
Couleur
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
type
Spécifie le modèle utilisé par un objet.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


reason

L'objet reason contient une raison justifiant la signature de données, conformément aux normes W3C XML.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
reasons
reason
Sans
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


reasons

L'objet reasons contient des raisons justifiant la signature de données, conformément aux normes W3C XML.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
filter
proto
reasons
Sans
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
type
Spécifie le modèle utilisé par un objet.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


recordSet

L'objet recordSet contient plusieurs enregistrements basés sur une requête particulière de la source de données. Ces enregistrements peuvent être affichés, réorganisés, ajoutés et supprimés.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
query

recordSet
Non
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
bofAction
Spécifie l'opération à effectuer si l'enregistrement actif est le premier du jeu d'enregistrements.
Chaîne
Lecture/écriture
cursorLocation
Indique l'emplacement de la bibliothèque de curseurs à utiliser avec le jeu d'enregistrements.
Chaîne
Lecture/écriture
cursorType
Spécifie le type de curseur à utiliser à l'ouverture du jeu d'enregistrements.
Chaîne
Lecture/écriture
eofAction
Spécifie l'opération à effectuer si l'enregistrement actif est le dernier du jeu d'enregistrements.
Chaîne
Lecture/écriture
lockType
Indique le type de fonction de verrouillage à utiliser avec la source de données.
Chaîne
Lecture/écriture
max
Indique le nombre maximal d'occurrences pour le conteneur qui englobe ou -1 pour ne définir aucune limite supérieure pour les occurrences.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


rectangle

L'objet rectangle décrit un rectangle unique généré.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
value

rectangle
corner
edge
fill
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
hand
Décrit la justification d'une ligne ou d'un bord.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


ref

L'objet ref contient une expression de syntaxe de référence qui identifie un noeud à inclure dans une signature numérique XML.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
bindItems
manifest
proto
setProperty
ref
Sans
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


rootElement

L'objet rootElement spécifie l'élément XML au sein d'une connexion aux données du schéma XML à utiliser comme racine d'un fichier de données à l'intérieur du formulaire.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
xsdConnection

rootElement
Non
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


script

L'objet script contient un script écrit en FormCalc ou en JavaScript.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
breakAfter
breakBefore
calculate
event
occur (occur.script est réservé pour une utilisation ultérieure)
proto
traverse
validate
variable
script
Non
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
{par défaut}
Représente la valeur réelle stockée par un objet.
Chaîne
Lecture/écriture
binding
Identifie le type d'application auquel s'adresse le script.
Chaîne
Lecture/écriture
contentType
Spécifie le type de contenu présent dans le document référencé, à savoir MIME.
Chaîne
Lecture/écriture
runAt
Indique quelle application peut exécuter le script.
Chaîne
Lecture/écriture
stateless
Détermine si les variables d'un script sont conservées d'une invocation à l'autre.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
value
Indique la valeur de l'objet actuel.
Chaîne
Lecture/écriture
Méthodes
Non


select

L'objet select renferme les informations de sélection de requête d'instruction à utiliser avec la source de données en cours.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
query

select
Non
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


setProperty

L'objet setProperty modifie une propriété de son objet parent. Un objet parent peut contenir un nombre illimité d'objets setProperty .
La propriété target est une expression de syntaxe de référence qui décrit une propriété unique de l'objet parent. Cette propriété identifie le noeud dont la valeur doit être identique à celle identifiée par l'objet ref et la propriété connection. Par exemple, la cible spécifiée pour définir la propriété toolTip d'un champ serait access.toolTip.
Dans le conteneur parent, il n'existe pas de restrictions sur le type de propriétés pouvant être ciblées par l'objet setProperty . Toutefois, l'objet setProperty ne peut pas cibler les propriétés de conteneurs imbriqués.
L'application de l'objet setProperty est une opération de modèle. La référence est résolue et la valeur est appliquée à la propriété target lors de la création du formulaire suite à une fusion. Il n'existe pas de liaison permanente entre le noeud de données et la propriété. Tous les changements ultérieurs effectués sur les données ne sont pas propagés à la propriété target sauf en cas de nouvelle fusion.
il est inutile d'utiliser l'objet setProperty pour cibler des propriétés de liaison telles que l'objet bind ou #name, car l'application setProperty survient après le processus de fusion.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
draw
exclGroup
field
proto
subform
setProperty
ref
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
connection
Spécifie le nom du contrôle de connexion associé dans l'ensemble de connexions.
Chaîne
Lecture/écriture
target
Indique l'objet sur lequel l'événement a une influence.
Chaîne
Lecture/écriture
Méthodes
Non


signature

L'objet signature détermine quels autres objets sont signés par une signature.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
ui

signature
border
extras
filter
manifest
margin
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
type (signature.type is reserved for future use)
(type)Specifies the pattern used by an object.
String
Read /Write
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


signatureProperties

L'objet signatureProperties détient les propriétés d'une signature de données XML. Les objets insérés dans cet objet sont insérés dans la signature XML en tant que données XMP.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
signData

signtureProperties
signedState
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


signaturePseudoModel

L'objet signaturePseudoModel constitue l'objet racine du modèle de signature.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
Non

signaturePseudoModel
Non
Classe parent
Classe de object
Méthodes

Nom

Description

Renvoie
clear
Supprime une signature donnée.
Booléen
enumerate
Enumère toutes les signatures XML trouvées dans le document.
Objet
sign
Appose une signature à une liste de nœuds donnée et place la signature à l'emplacement cible.
Booléen
verify
Authentifie la signature.
Entier


signData

L'objet signData contrôle la création d'une signature de données conformément aux normes W3C XML.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
event
proto
submit

signData
filter
manifest
ref
signatureProperties
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
operation
Détermine à quel moment un lien a été utilisé.
Chaîne
Lecture/écriture
ref
Spécifie une expression de syntaxe de référence définissant le noeud dans le modèle de données auquel le conteneur englobant est associé.
Chaîne
Lecture/écriture
target
Indique l'objet sur lequel l'événement a une influence.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


Précédent Suivant

Script > Référence sur les objets de script > Objets > signedState

signedState

Réservé en vue d'une utilisation ultérieure.


signing

L'objet signing décrit une collection de certificats de signature compatibles avec la signature de données, conformément aux normes W3C XML.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
certificates
proto
signing
Sans
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
type
Spécifie le modèle utilisé par un objet.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


soapAction

L'objet soapAction contient une action SOAP complète.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
wsdlConnection

soapAction
Non
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


soapAddress

L'objet soapAddress stocke l'emplacement complet du point final SOAP. Cet emplacement doit être défini au format standard RFC 2396.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
wsdlConnection

soapAddress
Non
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


solid

L'objet solid décrit un style de remplissage plein attribué à un objet de formulaire.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
fill
proto

solid
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


source

L'objet source représente une source de données externe.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
sourceSet

source
connect
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
db
Spécifie le nom d'une base de données disponible auprès du fournisseur.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes

Nom

Description

Renvoie
addNew
Ajoute un nouvel enregistrement au jeu d'enregistrements.
Vide
cancel
Annule toutes modifications apportées à la rangée active ou à une nouvelle rangée de l'objet de jeu d'enregistrements ou à la collection de champs d'un objet d'enregistrement, avant l'appel de la méthode update.
Vide
cancelBatch
Annule une mise à jour par lots en attente
Vide
close
Ferme une connexion d'une source de données.
Vide
delete
Supprime l'enregistrement actuel du jeu d'enregistrements.
Vide
first
Accède au premier enregistrement dans le jeu d'enregistrements et remplit le modèle de données avec les données d'enregistrement.
Vide
hasDataChanged
Détermine si les données de l'enregistrement actuel ont été modifiées. Il s'agit d'un test de pré-validation de l'enregistrement actif. Il compare les données de l'enregistrement actuel avec les données d'enregistrement de la source de données active. Si les données ont changé, cette méthode renvoie la valeur true .
Booléen
isBOF
Détermine si l'emplacement actuel se trouve au début du jeu d'enregistrements.
Booléen
isEOF
Détermine si l'emplacement actuel se trouve à la fin du jeu d'enregistrements.
Booléen
last
Accède au dernier enregistrement dans le jeu d'enregistrements et remplit le modèle de données avec les données d'enregistrement.
Vide
next
Accède à l'enregistrement suivant dans le jeu d'enregistrements et remplit le modèle de données avec les données d'enregistrement.
Vide
open
Etablit la connexion à la source de données et remplit le modèle de données avec les résultats de l'enregistrement actuel.
Vide
previous
Accède à l'enregistrement précédent dans le jeu d'enregistrements et remplit le modèle de données avec les données d'enregistrement.
Vide
requery
Met à jour la liaison active des données en exécutant à nouveau la requête sur laquelle reposent les données d'objet. L'appel de cette méthode équivaut à appeler les méthodes close et open l'une après l'autre.
Vide
resync
Actualise le jeu d'enregistrements ou la connexion aux données actif.
Vide
update
Met à jour l'enregistrement actif dans le jeu d'enregistrements.
Vide
updateBatch
Ecrit toutes les mises à jour du lot en attente dans la source de données.
Vide


sourceSet

L'objet sourceSet constitue l'objet racine du modèle sourceSet.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
Non

sourceSet
source
Classe parent
Classe de model
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


speak

La propriété speak joue une invite sonore décrivant le contenu d'un objet de conteneur, tel qu'un champ ou un sous-formulaire. Cet objet n'est pas pris en compte par les applications de formulaire non interactives.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
assist
proto

speak
Non
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
disable
Désactive l'invite audible.
Chaîne
Lecture/écriture
priority
Modifie le chemin de recherche du texte lu. L'objet spécifié dans cette propriété passe au début du chemin de recherche. Les autres objets conservent leur ordre relatif.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


stipple

L'objet stipple décrit un effet grisé appliqué à un objet de formulaire.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
fill
proto

stipple
Couleur
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
rate
Spécifie le pourcentage de motif grisé sur un arrière-plan plein.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


subform

L'objet subform décrit un sous-formulaire unique pouvant englober d'autres conteneurs.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant

zone
proto
subform
subformSet
subform
assist
bind
bookend
border
break
breakAfter
breakBefore
calculate
desc
extras
instanceManager
keep
margin
occur
overflow
pageSet
para
setProperty
subform
subformSet
traversal
validate
variable
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
allowMacro
Spécifie si l'application de traitement est autorisée ou non à optimiser les résultats en créant une macro d'imprimante pour tout le contenu de dessin du sous-formulaire.
Chaîne
Lecture/écriture
anchorType
Indique l'emplacement du point d'ancrage du conteneur lorsque la stratégie de disposition positionnée est utilisée.
Chaîne
Lecture/écriture
colSpan
Spécifie le nombre de colonnes étendues par cet objet lorsqu'il est incorporé dans un sous-formulaire doté d'un type de disposition des rangées particulier.
Chaîne
Lecture/écriture
columnWidths
Spécifie la largeur des colonnes d'un tableau.
Chaîne
Lecture/écriture
h
Mesure de la hauteur pour la disposition.
Chaîne
Lecture/écriture
hAlign
Indique l'alignement de texte horizontal.
Chaîne
Lecture/écriture
layout
Indique la stratégie de disposition utilisée par cet objet.
Chaîne
Lecture/écriture
locale
Indique la langue, la monnaie et le format des date/heure à utiliser pour le contenu de l'objet.
Chaîne
Lecture/écriture
maxH
Indique la hauteur maximale à des fins de disposition.
Chaîne
Lecture/écriture
maxW
Indique la largeur maximale à des fins de disposition.
Chaîne
Lecture/écriture
minH
Indique la hauteur maximale à des fins de disposition.
Chaîne
Lecture/écriture
minW
Indique la largeur maximale à des fins de disposition.
Chaîne
Lecture/écriture
presence
Indique si un objet est visible ou non.
Chaîne
Lecture/écriture
relevant
Contrôle si un objet de formulaire est inclus dans l'opération d'impression.
Chaîne
Lecture/écriture
restoreState
Rétablie les noeuds de formulaire d'un formulaire à leur état d'origine, tout en réinitialisant les propriétés visuelles des champs, telles que les modifications apportées aux couleurs des bordures.
Chaîne
Lecture/écriture
scope
Contrôle l'intervention du sous-formulaire dans la liaison de données et les expressions de syntaxe de référence.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
validationMessage
Indique la chaîne de message de validation pour ce champ.
Chaîne
Lecture/écriture
vAlign
Indique l'alignement de texte vertical.
Chaîne
Lecture/écriture
w
Mesure indiquant la largeur pour la disposition.
Chaîne
Lecture/écriture
x
Indique l’abscisse (coordonnée X) du point d'ancrage d'un conteneur par rapport au coin supérieur gauche du conteneur parent lors d'un placement avec disposition positionnée.
Chaîne
Lecture/écriture
y
Indique l'ordonnée (coordonnée X) du point d'ancrage d'un conteneur par rapport au coin supérieur gauche du conteneur parent lors d'un placement avec disposition positionnée.
Chaîne
Lecture/écriture
Méthodes

Nom

Description

Renvoie
execCalculate
Exécute le script de calcul du champ.
Vide
execEvent
Exécute le script d'événement de l'objet.
Vide
execInitialize
Exécute le script d'initialisation du champ.
Vide
execValidate
Exécute le script de validation du champ.
Vide


subformSet

L'objet subformSet décrit un jeu d'objets de sous-formulaires associés.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
zone
proto
subform
subformSet
subformSet
bookend
break
breakAfter
breakBefore
desc
extras
instanceManager
occur
overflow
subform
subformSet
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
relation
Indique les rapports qu'entretiennent les membres du jeu.
Chaîne
Lecture/écriture
relevant
Contrôle si un objet de formulaire est inclus dans l'opération d'impression.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


subjectDN

L'objet subnectDN décrit les attributs pour un pseudo du sujet (PS) qui doit être présent au sein du certificat de signature afin qu'il soit compatible avec la signature. Il s'agit d'un réseau de dictionnaires, où chaque dictionnaire contient des paires identifiant-valeur qui spécifient le pseudo sujet (PS). Le certificat doit contenir tous les attributs spécifiés dans le dictionnaire, mais il peut contenir des attributs supplémentaires. La clé peut être n'importe quel identifiant d'attribut légal.
Pour obtenir de plus amples informations sur les attributs Pseudo et leurs types, reportez-vous au document RFC 3280.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
subjectDNs

subjectDN
Non
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
delimiter
Sépare les attributs dans la chaîne Pseudo PS.
Chaîne
Lecture/écriture
Méthodes
Non


subjectDNs

L'objet subjectDNs décrit la collection de paires identifiant-valeur utilisées pour spécifier le pseudo sujet (PS).
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
certificates

subjectDNs
subjectDN
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
type
Spécifie le modèle utilisé par un objet.
Chaîne
Lecture/écriture
Méthodes
Non


submit

L'objet submit décrit comment envoyer des données à un hôte.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
event
proto

submit
signData
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
embedPDF
Détermine si le fichier PDF doit être inclus aux données.
Chaîne
Lecture/écriture
format
Détermine le format à utiliser pour envoyer les données.
Chaîne
Lecture/écriture
target
Indique l'objet sur lequel l'événement a une influence.
Chaîne
Lecture/écriture
textEncoding
Indique l'encodage du contenu de texte dans un document.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
xdpContent
Définit le sous-ensemble de données qui est envoyé. Cette propriété s'utilise uniquement lorsque la propriété format est définie sur xdp .
Chaîne
Lecture/écriture
Méthodes
Non


template

L'objet template décrit un modèle. Un objet de ce type existe pour chaque modèle et tous les autres objets qui sont des descendants de l'objet de modèle.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto

template
extras
Classe parent
Classe de model
Propriétés

Nom

Description

Type

Accès
baseProfile
Chaîne
Lecture/écriture
Méthodes

Nom

Description

Renvoie
createNode
Crée un nouveau nœud en fonction d'un nom de classe correct.
Objet
execCalculate
Exécute le script de calcul du champ.
Vide
execInitialize
Exécute le script d'initialisation du champ.
Vide
execValidate
Exécute le script de validation du champ.
Vide
formNodes
Renvoie la liste de tous les objets de modèle du formulaire liés à un objet de données spécifié.
Objet
recalculate
Force l'exécution d'un jeu spécifique de scripts sur des événements de calculs. Les événements spécifiques peuvent être des événements de calculs en attente ou l'intégralité des événements de calculs.
Vide
remerge
Force la fusion des modèles de données et la conception de modèle pour recréer un modèle de formulaire. Une fois la fusion effectuée, tout traitement de modèle de disposition doit être à nouveau effectué pour déterminer le formulaire.
Vide


Texte

L'objet text décrit une unité de contenu unique représentant une valeur de texte brut.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
desc
exObject
extras
items
message
proto
value
variable
text
Non
Classe parent
Classe de content
Propriétés

Nom

Description

Type

Accès
{par défaut}
Représente la valeur réelle stockée par un objet.
Chaîne
Lecture/écriture
maxChars
Indique le nombre maximal de caractères que cette valeur de texte peut englober.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
value
Indique la valeur de l'objet actuel.
Chaîne
Lecture/écriture
Méthodes
Non


textEdit

L'objet textEdit renferme des commandes destinées à faciliter la manipulation des contenus de texte.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
ui

textEdit
border
comb (textEdit.comb est réservé pour une utilisation ultérieure)
extras
margin
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
allowRichText
Indique si le texte est compatible avec les styles (ce qu'on appelle également du texte enrichi).
Chaîne
Lecture/écriture
hScrollPolicy
Indique si un champ peut défiler horizontalement.
Chaîne
Lecture/écriture
multiLine
Indique si le texte peut couvrir plusieurs lignes.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
vScollPolicy
Indique si un champ peut défiler verticalement.
Chaîne
Lecture/écriture
Méthodes
Non


time

L'objet time décrit une unité de données représentant une valeur temporelle.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
desc
exObject
extras
items
proto
value
variable
time
Non
Classe parent
Classe de content
Propriétés

Nom

Description

Type

Accès
{par défaut}
Représente la valeur réelle stockée par un objet.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
value
Indique la valeur de l'objet actuel.
Chaîne
Lecture/écriture
Méthodes
Non


timeStamp

L'objet timeStamp ajoute un tampon temporel à une signature de document. Un tampon temporel spécifie la date et l'heure de signature d'un document, ce qui permet de savoir avec certitude à quel moment le document a été signé.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
filter

timestamp
Non
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
server
Indique l'URL pour un serveur de tampons temporels.
Chaîne
Lecture/écriture
type
Spécifie le modèle utilisé par un objet.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


toolTip

L'objet toolTip fournit du texte pour une info-bulle sur un formulaire. Cet objet n'est pas pris en compte par les applications de formulaire non interactives.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
assist
proto

tooltip
Non
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


traversal

L'objet traversal lie son conteneur à d'autres objets dans une séquence.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
draw
exclGroup
field
proto
subform
traversal
extras
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


traverse

L'objet traverse déclare un lien unique entre son conteneur et un autre objet dans une chaîne de liens unidirectionnelle.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
traversal

traverse
extras
script
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
operation
Détermine à quel moment un lien a été utilisé.
Chaîne
Lecture/écriture
ref
Spécifie une expression de syntaxe de référence définissant le noeud dans le modèle de données auquel le conteneur englobant est associé.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


ui

L'objet ui renferme la description d'interface utilisateur d'un objet de formulaire.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
draw
field
proto

ui
extras
imageEdit
picture
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


update

L'objet update spécifie l'opération de mise à jour de l'enregistrement en cours de la source de données.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
command
source

update
Non
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


uri

L'objet uri stocke un URI complet pour un objet xmlConnection ou xsdConnection spécifique.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
xmlConnection
xsdConnection

uri
Non
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


user

L'objet user spécifie l'ID utilisateur pour la source de données (si la connexion l'exige).
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
connect

user
Non
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


validate

L'objet validate contrôle la validation de données fournies par l'utilisateur sur un formulaire.
L'objet validate peut être activé plusieurs fois pendant la durée de vie d'un formulaire.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
exclGroup
field
proto
subform
validate
extras
message
picture
script
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
formatTest
Définit la validation d’une clause d’image.
Chaîne
Lecture/écriture
nullTest
Détermine si un champ est obligatoire dans un formulaire ou s'il peut être laissé vide.
Chaîne
Lecture/écriture
scriptTest
Contrôle la validation effectuée par le script inclus.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


value

L'objet value renferme une unité de contenu unique.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
caption
draw
field
proto

value
Non
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
override
Détermine si la valeur calculée peut être remplacée interactivement par l'utilisateur, ou si elle est désactivée quel que soit le contexte.
Chaîne
Lecture/écriture
relevant
Contrôle si un objet de formulaire est inclus dans l'opération d'impression.
Chaîne
Lecture/écriture
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


variable

L'objet variables est utilisé pour stocker des variables de document.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
proto
subform

variables
Non
Classe parent
Classe de node
Propriétés
(

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


wsdlAddress

L'objet wsdlAddress contient l'URL original du fichier WSDL référencé dans l'objet wsdlConnection.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
wsdlConnection

wsdlAddress
Non
Classe parent
Classe de textNode
Propriétés

Nom

Description

Type

Accès
use
Invoque un prototype.
Chaîne
Lecture/écriture
usehref
Invoque un prototype externe.
Chaîne
Lecture/écriture
Méthodes
Non


wsdlConnection

L'objet wsdlConnection identifie une connexion unique aux services Web WSDL.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
connectionSet

wsdlConnection
operation
soapAction
soapAddress
wsdlAddress
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
dataDescription
Spécifie le nom de la description d'une connexion aux données à utiliser avec un type particulier de connexion aux services Web.
Chaîne
Lecture/écriture
Méthodes

Nom

Description

Renvoie
execute
Exécute une connexion.
Booléen


xfa

L'objet xfa constitue le noeud racine pour le modèle xfa.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
Non

xfa
packet
Classe parent
Classe de model
Propriétés
Non
Méthodes
Non


xmlConnection

L'objet xmlConnection sert à stocker un exemple de connexion aux données XML.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
connectionSet

xmlConnection
uri
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
dataDescription
Spécifie le nom de la description d'une connexion aux données à utiliser avec un type particulier de connexion aux services Web.
Chaîne
Lecture/écriture
Méthodes
Non


xsdConnection

L'objet xsdConnection stocke une entrée de connexion aux données du schéma XML.
Hiérarchie des objets

Objets parent

Objet actif

Objets enfant
connectionSet

xsdConnection
rootElement
uri
Classe parent
Classe de node
Propriétés

Nom

Description

Type

Accès
dataDescription
Spécifie le nom de la description d'une connexion aux données à utiliser avec un type particulier de connexion aux services Web.
Chaîne
Lecture/écriture
Méthodes
Non


Propriétés de script

#text
{par défaut}
access
accessKey
action
activity
addRevocationInfo
after
afterTarget
aliasNode
all
allowMacro
allowNeutral
allowRichText
anchorType
appType
archive
aspect
baselineShift
before
beforeTarget
bind
binding
blank (désapprouvée)
blankOrNotBlank
bofAction
bookendLeader
bookendTrailer
borderColor
borderWidth
bottomInset
break
calculationsEnabled
cap
change
charEncoding
checksum
circular
classAll
classId
classIndex
className
codeBase
codeType
colSpan
columnWidths
commandType
commitKey
commitOn
connection
contains
content
contentType
context
count
credentialServerPolicy
crlSign
cSpace
currentPage
currentRecordNumber
cursorLocation
cursorType
data
dataColumnCount
dataDescription
dataEncipherment
dataLength
dataPrep
dataRowCount
db
decipherOnly
delayedOpen
delimiter
digitalSignature
disable
embedPDF
encipherOnly
endChar
eofAction
errorCorrectionLevel
executeType
fillColor
fontColor
format
formatMessage
formattedValue
formatTest
fracDigits
from
fullText
h
hAlign
hand
highlight
href
hScrollPolicy
id
imagingBBox
index
initial
initialNumber
input
intact
inverted
isContainer
isDefined
isNull
join
keyAgreement
keyCertSign
keyDown
keyEncipherment
labelRef
language
layout
leadDigits
leader
leftInset
length
lineHeight
lineThrough
lineThroughPeriod
locale
lockType
long
mandatory
mandatoryMessage
marginLeft
marginRight
mark
match
max
maxChars
maxH
maxLength
maxW
min
minH
minW
model
modifier
moduleHeight
moduleWidth
multiLine
name
newContentType
newText
next
nodes
nonRepudiation
ns
nullTest
numbered
numberOfCells
numPages
oddOrEven
oneOfChild
open
operation
orientation
output
overflowLeader
overflowTarget
overflowTrailer
overline
overlinePeriod
override
pagePosition
parent
parentSubform
passwordChar
permissions
picture
placement
platform
posture
presence
preserve
prevContentType
previous
prevText
printCheckDigit
priority
radius
radixOffset
rate
rawValue
ready
recordsAfter
recordsBefore
reenter
ref
relation
relevant
reserve
restoreState
rightInset
role
rotate
rowColumnRatio
runAt
save
scope
scriptTest
selEnd
selStart
server
shape
shift
short
signatureType
size
slope
soapFaultCode
soapFaultString
somExpression
spaceAbove
spaceBelow
startAngle
startChar
startNew
stateless
stock
stroke
sweepAngle
tabDefault
tabStops
target
targetType
textEncoding
textEntry
textIndent
textLocation
thickness
this
timeout
timeStamp
title
topInset
trailer
transferEncoding
transient
truncate
type
typeface
underline
underlinePeriod
url
urlPolicy
usage
use
usehref
uuid
validationMessage
validationsEnabled
vAlign
value
valueRef
variation
version
vScollPolicy
w
weight
wideNarrowRatio
x
xdpContent
y
Cette section fournit une liste alphabétique de toutes les propriétés prises en charge dans cet environnement de script.
toutes les propriétés disposent d'un accès en lecture et écriture, à moins que vous ne spécifiiez autrement.


#text

Chaîne de texte.
Syntaxe
Reference_Syntax.#text.value = "text"
Valeurs

Type

Valeurs
Chaîne
      •
      Toute chaîne valide.
Exemples
JavaScript
TextField1.caption.value.#text = "This is a caption.";
FormCalc
TextField1.caption.value.#text = "This is a caption."


{par défaut}

Représente la valeur réelle stockée par un objet.
Le type et les valeurs possibles varient selon l'objet.
Syntaxe
Reference_Syntax = "value"
Valeurs

Type

Valeurs
Variable
Les valeurs varient selon les objets.
Application

Modèle

Objet
Modèle de données
dataValue
Modèle de formulaire
boolean
date
dateTime
decimal
draw
exclGroup
exData
field
float
image
integer
picture
Texte
time
Modèle sourceSet
boolean
integer
Texte
S'applique également aux objets provenant de la classe textNode.


access

Définit l'accès de l'utilisateur au contenu d'un conteneur.
Syntaxe
Reference_Syntax.access = "open | protected | readOnly"
Valeurs

Type

Valeurs
Chaîne
      •
      open (par défaut)
Permet de mettre à jour le contenu d’un conteneur et d’y accéder sans restriction. Dans les formulaires interactifs, vous pouvez modifier le contenu et l'onglet du conteneur ou encore le parcourir. Le conteneur génère des événements.
      •
      protected
L'application de traitement empêche l'utilisateur d'apporter des modifications directes au contenu du conteneur. Il est possible d'apporter des modifications indirectes, telles que des calculs. Le conteneur n'est pas inclus dans l'ordre de tabulation bien que l'application permette de sélectionner du texte pour le copier dans le Presse-papiers. Un conteneur protégé ne génère pas d'événement.
      •
      readOnly
L'application empêche l'utilisateur d'apporter des modifications directes au contenu du conteneur, mais l'autorise à apporter des modifications indirectes, telles que des calculs. Le conteneur est inclus dans l'ordre de tabulation et permet à l'utilisateur d'afficher le contenu. L'utilisateur peut sélectionner le contenu du conteneur pour le copier dans le Presse-papiers. Le conteneur génère également un sous-ensemble d’événements, lesquels ne sont pas associés aux modifications directes du contenu.
Application

Modèle

Objet
Modèle de formulaire
exclGroup
field
Exemples
JavaScript
TextField1.access = "readOnly";
FormCalc
TextField1.access = "readOnly"


accessKey

Spécifie une touche d'accès rapide utilisée par une application interactive pour déplacer la cible d'action vers un élément de champ particulier.
Syntaxe
Reference_Syntax.accessKey = "character"
Valeurs

Type

Valeurs
Chaîne
La valeur de cet attribut est un caractère unique. Lorsque l'utilisateur appuie sur la touche de modification particulière à sa plate-forme et le caractère unique, la sélection du formulaire se déplace sur ce champ. Sur les systèmes Windows, la touche de modification est la touche ALT ; sur les systèmes Mac OS, il s'agit de la touche OPTION.
Par exemple, si l'auteur du formulaire définit la propriété accessKey d'un champ à f et un utilisateur Windows appuie sur Alt+f, la sélection se déplace sur ce champ.
Lorsqu'ils créent des formulaires contenant des touches d'accès rapide, les concepteurs doivent informer les utilisateurs de la disponibilité de ces touches.
Application

Modèle

Objet
Modèle de formulaire
exclGroup
field
Exemples
JavaScript
TextField1.accessKey = "f";
FormCalc
TextField1.accessKey = « f »


action

Identifie les noeuds de formulaire protégés par une signature de document.
Syntaxe
Reference_Syntax.action = "include | exclude | all"
Valeurs

Type

Valeurs
Chaîne
•
include (par défaut)
La signature de document protège tous les noeuds de formulaire à remplir dans la collection spécifiée. Cette option nécessite au moins un objet enfant ref valide dont la valeur de texte est une expression de syntaxe de référence identifiant des nœuds protégés par la signature de document.
      •
      exclude
La signature de document protège tous les noeuds de formulaire à remplir ne se trouvant pas dans la collection spécifiée. Cette option nécessite au moins un objet enfant ref valide dont la valeur de texte est une expression de syntaxe de référence identifiant des nœuds protégés par la signature de document.
      •
      all
La signature de document protège tous les noeuds de formulaire à remplir.
Application

Modèle

Objet
Modèle de formulaire
manifest


activity

Indique le nom de l'événement.
La propriété ref associée doit spécifier un objet pouvant générer l'événement nommé.
Syntaxe
Reference_Syntax.activity = "change | click | docClose | docReady | enter | exit | full | initialize | mouseDown | mouseEnter | mouseExit | mouseUp | postExecute | postPrint | postSave | preExecute | prePrint | preSave | preSubmit | ready"
Valeurs

Type

Valeur
Chaîne
      •
      change
Se produit lorsque l'utilisateur modifie la valeur du champ. Voici quelques exemples :
      •
      Lors de chaque frappe de touche
      •
      Lorsque le texte est collé
      •
      Lorsqu'une nouvelle sélection est effectuée
      •
      Lorsqu'une case à cocher est activée
      •
      click (par défaut)
Se produit lorsque l'utilisateur clique dans le champ. Sur la plupart des systèmes, un clic est l'action d'appuyer sur le bouton de la souris et de le relâcher tout en déplaçant le pointeur le moins possible.
      •
      docClose
Cet événement est exécuté à chaque fin de formulaire, si et seulement si toutes les validations de formulaire se sont terminées sans erreur. Lorsque cet événement se déclenche, vous ne pouvez plus modifier un document enregistré, l'objectif étant de donner la possibilité de générer un état quitter ou un message d'accomplissement.
      •
      docReady
Cet événement est exécuté avant que le document ne soit rendu, mais après la liaison de données.
      •
      enter
Pour un champ, cet événement se déclenche lorsque le champ atteint la cible d'action du clavier. Pour un sous-formulaire ou un groupe d'exclusion, cet événement se déclenche lorsqu'un champ du sous-formulaire ou du groupe d'exclusion atteint la cible d'action du clavier, c'est-à-dire lorsque la cible d'action du clavier se déplace de l'extérieur vers l'intérieur de l'objet.
      •
      enter
Pour un champ, cet événement se déclenche lorsque le champ atteint la cible d'action du clavier. Pour un sous-formulaire ou un groupe d'exclusion, cet événement se déclenche lorsqu'un champ du sous-formulaire ou du groupe d'exclusion atteint la cible d'action du clavier, c'est-à-dire lorsque la cible d'action du clavier se déplace de l'extérieur vers l'intérieur de l'objet.
      •
      exit
Pour un champ, cet événement se déclenche lorsque le champ n'est plus contrôlé par la cible d'action du clavier. Pour un sous-formulaire ou un groupe d'exclusion, cet événement se déclenche lorsque l'ensemble des champs du sous-formulaire ou du groupe d'exclusion n'est plus contrôlé par la cible d'action du clavier, c'est-à-dire lorsque la cible d'action se déplace de l'intérieur vers l'extérieur de l'objet.
      •
      full
Cet événement se déclenche lorsque l'utilisateur tente d'entrer le contenu maximum autorisé dans un champ.
      •
      initialize
Cet événement est exécuté une fois la liaison de données terminée. Un événement séparé est généré pour chaque instance du sous-formulaire dans le modèle de formulaire.
      •
      mouseDown
Se produit lorsque l'utilisateur appuie sur le bouton de la souris dans le champ, mais avant que ce dernier ne soit relâché.
      •
      mouseEnter
Se produit lorsque l'utilisateur fait glisser le pointeur sur le champ sans nécessairement appuyer sur le bouton.
      •
      mouseExit
Se produit lorsque l'utilisateur fait glisser le pointeur hors du champ sans nécessairement appuyer sur le bouton.
      •
      mouseUp
Se produit lorsque l'utilisateur relâche le bouton de la souris dans le champ.
      •
      postExecute
Se produit lorsque des données sont envoyées vers un service Web via WSDL, juste après réception de la réponse à la requête et après que les données reçues ont été classées dans un objet connectionData sous $datasets. Un script déclenché par cet événement peut consulter et traiter les données reçues. Une fois cet événement exécuté, les données reçues sont effacées.
      •
      postPrint
Cet événement se produit juste après que le formulaire rendu a été envoyé à l'imprimante, au programme d'impression différée ou à la destination de sortie.
      •
      postSave
Cet événement se produit juste après que le formulaire été enregistré au format PDF ou XDP. Cet événement ne se produit pas si le modèle de données ou un autre sous-ensemble du formulaire est exporté au format XDP.
      •
      preExecute
Se produit lorsqu'une requête est envoyée à un service Web via WSDL. Un script déclenché par cet événement peut consulter et modifier les données avant l'envoi de la requête. Si le script est défini de sorte à être exécuté uniquement sur le serveur, les données sont envoyées au serveur avec instruction d'exécuter le script associé avant tout autre traitement.
      •
      preSave
Se produit juste après que les données du formulaire ont été enregistrées au format PDF ou XDP. Cet événement ne se produit pas si le modèle de données ou un autre sous-ensemble du formulaire est exporté au format XDP. Le post-traitement XSLT, s'il est activé, a lieu après cet événement.
      •
      preSubmit
Se produit lorsque des données sont envoyées à l'hôte via le protocole HTTP. Un script déclenché par cet événement peut consulter et modifier les données avant leur envoi. Si le script est défini de sorte à être exécuté sur le serveur, les données sont envoyées au serveur avec instruction d'exécuter le script associé avant tout autre traitement.
      •
      ready
Se produit lorsque le chargement du modèle est terminé.
Application

Modèle

Objet
Modèle de formulaire
event
Exemples
JavaScript
TextField1.event.activity = "mouseEnter";
FormCalc
TextField1.event.activity = « mouseEnter »


addRevocationInfo

Indique si l'état du certificat est vérifié lorsqu'une signature numérique est signée. L'état du certificat peut être vérifié à l'aide d'une liste de révocation des certificats ou d'une réponse OCSP (Online Certificate Status Protocol).
La personne qui appose la signature doit avoir accès à Internet pour récupérer la liste de révocation des certificats ou la réponse OCSP du serveur approprié.
La propriété addRevocationInfo n'a pas de valeur par défaut afin qu'Acrobat puisse la remplacer au cas où la valeur ne soit pas spécifiée.
Syntaxe
Reference_Syntax.addRevocationInfo = "required | optional | none"
Valeurs

Type

Valeurs
Chaîne
•
Required
La vérification de l'état du certificat est obligatoire.
•
Optional
La vérification de l'état du certificat est facultative.
•
None
Une liste de révocation des certificats ou une réponse OCSP n'est pas incluse dans la signature numérique.
Application

Modèle

Objet
Modèle de formulaire
filter


after

Indique les contraintes de déplacement vers une nouvelle page ou zone de contenu après la génération du sous-formulaire.
Syntaxe
Reference_Syntax.after = "auto | contentArea | pageArea | pageEven | pageFront | pageOdd"
Valeurs

Type

Valeurs
Chaîne
Les comportements décrits ci-dessous peuvent être affinés par la sélection facultative d'une page de destination ou d'une zone de contenu via la propriété afterTarget.
      •
      auto (par défaut)
La détermination d'une transition vers une nouvelle page ou zone de contenu sera déléguée à l'application de traitement. Aucune transition vers une nouvelle page ou zone de contenu ne sera imposée.
      •
      contentArea
La transition de rendu sera effectuée vers la prochaine zone de contenu disponible.
      •
      pageArea
La transition de rendu vers une nouvelle page sera effectuée.
      •
      pageBack
Lors d'une impression recto-verso, la transition du rendu est effectuée vers la prochaine surface arrière disponible, ce qui peut entraîner l'impression d'une surface de page intercalée. Lorsque l'option recto-verso est désactivée, la transition du rendu est effectuée vers une nouvelle page.
      •
      pageEven
La transition du rendu est effectuée vers la prochaine page à numérotation paire disponible, ce qui peut entraîner l'impression de pages numérotées ou non numérotées intercalées. Ce comportement ne nécessite pas de configuration recto-verso.
      •
      pageFront
Lors d'une impression recto-verso, la transition du rendu est effectuée vers la prochaine surface avant disponible, ce qui peut entraîner l'impression d'une surface de page intercalée. Lorsque l'option recto-verso est désactivée, la transition du rendu est effectuée vers une nouvelle page.
      •
      pageOdd
La transition du rendu est effectuée vers la prochaine page à numérotation impaire disponible, ce qui peut entraîner l'impression de pages numérotées ou non numérotées intercalées. Ce comportement ne nécessite pas de configuration recto-verso.
Application

Modèle

Objet
Modèle de formulaire
break
Exemples
JavaScript
Subform1.break.after = "pageOdd";
FormCalc
Subform1.break.after = « pageOdd »


afterTarget

Spécifie la page de destination ou la zone de contenu explicites pour la propriété after.
Syntaxe
Reference_Syntax.afterTarget = "auto | contentArea | pageArea | pageEven | pageFront | pageOdd"
Valeurs

Type

Valeurs
Chaîne
La valeur de cette propriété doit être compatible avec la valeur de la propriété after. Par exemple, il serait considéré comme une erreur que la propriété after identifie une zone de page et que la propriété afterTarget identifie une zone de contenu, ou vice versa.
Application

Modèle

Objet
Modèle de formulaire
break
Exemples
JavaScript
Subform1.break.afterTarget = "pageEven";
FormCalc
Subform1.break.afterTarget = « pageEven »


aliasNode

Indique l'objet représenté par le pseudonyme pour ce modèle.
Syntaxe
Reference_Syntax.aliasNode = "object"
Valeurs

Type

Valeurs
Objet
L'objet dans le modèle identifié par la syntaxe de référence de ce modèle. Dans le cas du modèle de formulaire, le nœud d'alias serait l'objet formulaire.
Pour plus de détails sur l’utilisation des expressions de syntaxe de référence, voir A propos des références aux objets dans les calculs et les scripts.
Application
Classe de model
Exemples
JavaScript
xfa.aliasNode = "form";
FormCalc
xfa.aliasNode = « form »


all

Renvoie une collection de nœuds de même nom et compris dans la plage indiquée.
Si le nœud est dépourvu de nom, une collection de même classe est renvoyée.
Syntaxe
Reference_Syntax.all = "object(s)"
Valeurs

Type

Valeurs
Objet
Un objet ou une collection d'objets.
Application
Classe de tree
Exemples
JavaScript
Subform1.all;
FormCalc
Subform1.all


allowMacro

Spécifie si l'application de traitement est autorisée ou non à optimiser les résultats en créant une macro d'imprimante pour tout le contenu de dessin du sous-formulaire.
Syntaxe
Reference_Syntax.allowMacro = "1 | 0"
Valeurs

Type

Valeurs
Chaîne
      •
      1 (par défaut)
L'application de traitement est autorisée à utiliser une macro d'imprimante pour ce sous-formulaire.
      •
      0
L'application de traitement ne peut pas utiliser de macro d'imprimante pour ce sous-formulaire.
Application

Modèle

Objet
Modèle de formulaire
subform
Exemples
JavaScript
Subform1.allowMacro = "0";
FormCalc
Subform1.allowMacro = "0"


allowNeutral

Indique si la case à cocher ou le bouton radio prend en charge un troisième état représentant une valeur neutre.
Syntaxe
Reference_Syntax.allowNeutral = "0 | 1"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
La case à cocher ou le bouton radio prend en charge deux états, représentant la valeur vrai ou faux.
      •
      1
La case à cocher ou le bouton radio prend en charge trois états : vrai, faux ou neutre.
Application

Modèle

Objet
Modèle de formulaire
checkButton
Exemples
JavaScript
CheckBox1.resolveNode(« ui.#checkButton »).allowNeutral = « 1 »;
FormCalc
CheckBox1.ui.#checkButton.allowNeutral = "1"


allowRichText

Indique si le texte est compatible avec les styles (ce qu'on appelle également du texte enrichi).
la propriété allowRichText ne fait que transmettre les paramètres de style à l’interface de l’application. Quelle que soit sa valeur, elle n'empêche en aucun cas un utilisateur de saisir une annotation de texte normal, assortie d'attributs de style. Par exemple, quel que soit le paramètre défini pour cette propriété, un utilisateur peut taper :
        <b>hello</b>
Syntaxe
Reference_Syntax.allowRichText = "0 | 1"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
Les styles de texte ne sont pas pris en charge. Il s'agit du paramètre défini par défaut lorsque l'objet textEdit ne contient pas d'objet exData.
      •
      1
Les styles de texte sont pris en charge. Il s'agit du paramètre défini par défaut lorsque l'objet textEdit ne contient pas d'objet exData.
Application

Modèle

Objet
Modèle de formulaire
textEdit
Exemples
JavaScript
TextField1.resolveNode(« ui.#textEdit »).allowRichText = « 1 »;
FormCalc
TextField1.ui.#textEdit.allowRichText = "1"


anchorType

Indique l'emplacement du point d'ancrage du conteneur lorsque la stratégie de disposition positionnée est utilisée.
Syntaxe
Reference_Syntax.anchorType = "topLeft | topCenter | topRight | middleLeft | middleCenter | middleRight | bottomLeft | bottomCenter | bottomRight"
Valeurs

Type

Valeurs
Chaîne
      •
      topLeft (par défaut)
Coin supérieur gauche du conteneur.
      •
      topCenter
Centre du bord supérieur du conteneur.
      •
      topRight
Coin supérieur droit du conteneur.
      •
      middleLeft
Milieu du bord gauche du conteneur.
      •
      middleCenter
Milieu du conteneur.
      •
      middleRight
Milieu du bord droit du conteneur.
      •
      bottomLeft
Coin inférieur gauche du conteneur.
      •
      bottomCenter
Centre du bord inférieur du conteneur.
      •
      bottomRight
Coin inférieur droit du conteneur.
Application

Modèle

Objet
Modèle de formulaire
draw
exclGroup
field
subform
Exemples
JavaScript
TextField1.anchorType = « bottomRight »;
FormCalc
TextField1.anchorType = "bottomRight"


appType

Indique le nom de l'application client contenant un formulaire existant.
La propriété appType appelle la propriété viewerType à partir du modèle d'objet JavaScript Acrobat et renvoie la valeur correspondante pour l'application client contenant le formulaire. Par exemple, dans le contexte d'un formulaire PDF visualisé dans Adobe Reader, cette propriété retourne Reader.
Pour plus de détails sur la propriété viewerType et les valeurs qu'elle renvoie, voir le document Acrobat JavaScript Scripting Reference disponible sur le site Web d'Acrobat Family Developer Center à l'adresse : www.adobe.com/devnet/livecycle.
Syntaxe
Reference_Syntax.appType
Valeurs

Type

Valeurs
Chaîne
Chaîne valable représentant le nom de l'application client hôte actuelle.
Application

Modèle

Objet
Modèle de formulaire
draw
exclGroup
field
subform
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.appType;
FormCalc
xfa.host.appType


archive

Spécifie l'emplacement URI d'un fichier d'archive pouvant contenir un code de programmation associé à l'objet exObject.
Syntaxe
Reference_Syntax.archive = "URI"
Valeurs

Type

Valeurs
Chaîne
Valeur URI complètement qualifiée.
Application

Modèle

Objet
Modèle de formulaire
exObject


aspect

Indique le mode de mappage de l'image à la zone de contenu nominale du conteneur de l'image.
Syntaxe
Reference_Syntax.aspect = "fit | none | actual | width | height"
Valeurs

Type

Valeurs
Chaîne
      •
      fit (par défaut)
L’application ajuste l’image à l’échelle proportionnellement à la taille maximale de la zone de contenu du conteneur.
      •
      none
L’application ajuste l’image à l’échelle selon la taille de toute la zone de contenu du conteneur. Conséquence : des valeurs d'échelle différentes peuvent être appliquées aux coordonnées (X, Y) de l'image.
      •
      actual
Le rendu de l'image est généré à partir des dimensions stockées dans le contenu. La taille de la zone du conteneur n'a aucun impact sur les dimensions de l'image.
      •
      width
L'application met l'image à l'échelle proportionnellement à la largeur de la zone de contenu du conteneur. L'image peut se révéler plus longue ou plus courte que la zone de contenu.
      •
      height
L'application met l'image à l'échelle proportionnellement à la hauteur de la zone de contenu du conteneur. L'image peut se révéler plus large ou plus étroite que la zone de contenu.
Application

Modèle

Objet
Modèle de formulaire
image
Exemples
JavaScript
ImageField1.resolveNode("value.#image").aspect = "actual";
FormCalc
ImageField1.value.#image.aspect = "actual"


baselineShift

Indique une mesure positive permettant de décaler une police vers le haut par rapport à la ligne de base ou indique une mesure négative décalant une police vers le bas par rapport à la ligne de base.
Syntaxe
Reference_Syntax.baselineShift = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
font
Exemples
JavaScript
TextField1.font.baselineShift = "-5pt";
FormCalc
TextField1.font.baselineShift = "-5pt"


before

Indique les contraintes de déplacement vers une nouvelle page ou zone de contenu avant la génération du sous-formulaire.
Syntaxe
Reference_Syntax.before = "auto | contentArea | pageArea | pageBack | pageEven | pageFront | pageOdd"
Valeurs

Type

Valeurs
Chaîne
Les comportements décrits ci-dessous peuvent être affinés par la sélection facultative d'une page de destination ou d'une zone de contenu à l'aide de la propriété beforeTarget. La propriété startNew modifie aussi certains des ces comportements :
      •
      auto (par défaut)
La détermination d'une transition vers une nouvelle page ou zone de contenu est déléguée à l'application de traitement. Aucune transition vers une nouvelle page ou zone de contenu n'est imposée.
      •
      contentArea
Transitions de rendu vers la prochaine zone de contenu disponible. Voir aussi la propriété startNew.
      •
      pageArea
Transitions de rendu vers une nouvelle page. Voir aussi la propriété startNew.
      •
      pageBack
Lors d'une impression recto-verso, transitions de rendu vers la prochaine surface arrière disponible, ce qui peut entraîner l'impression d'une surface de page intercalée. Lorsque l'option recto-verso est désactivée, transitions de rendu vers une nouvelle page. Notez que pageBack, à l'inverse de pageEven, n'est pas affectée par la numérotation de pages.
      •
      pageEven
Transitions de rendu effectuées vers la prochaine page à numérotation paire disponible, ce qui peut entraîner l'impression de pages numérotées ou non numérotées intercalées. Ce comportement ne nécessite pas de configuration recto-verso.
      •
      pageFront
Lors d'une impression recto-verso, transitions de rendu effectuées vers la prochaine surface avant disponible, ce qui peut entraîner l'impression d'une surface de page intercalée. Lorsque l'option recto-verso est désactivée, la transition du rendu est effectuée vers une nouvelle page. Notez que pageFront, à l'inverse de pageOdd, n'est pas affectée par la numérotation de pages.
      •
      pageOdd
Transitions de rendu effectuées vers la prochaine page à numérotation impaire disponible, ce qui peut entraîner l'impression de pages numérotées ou non numérotées intercalées. Ce comportement ne nécessite pas de configuration recto-verso.
Application

Modèle

Objet
Modèle de formulaire
break
Exemples
JavaScript
Subform1.break.before = "contentArea";
FormCalc
Subform1.break.before = "contentArea"


beforeTarget

Spécifie la page de destination ou la zone de contenu explicites pour la propriété before.
Syntaxe
Reference_Syntax.beforeTarget = "auto | contentArea | pageArea | pageEven | pageFront | pageOdd"
Valeurs

Type

Valeurs
Chaîne
La valeur de beforeTarget doit être compatible avec la valeur de la propriété before. Par exemple, il serait considéré comme une erreur que la propriété before soit affectée de la valeur pageArea et que la propriété beforeTarget identifie une zone de contenu, ou vice versa.
Application

Modèle

Objet
Modèle de formulaire
break
Exemples
JavaScript
Subform1.break.beforeTarget = "#contentArea_ID";
FormCalc
Subform1.break.beforeTarget = "#contentArea_ID"


bind

Spécifie le nom d'un ID de liaison unique selon lequel les colonnes de la source de données spécifiées par la propriété from sont liées.
Syntaxe
Reference_Syntax.bind = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valable représentant un ID de liaison.
Application

Modèle

Objet
Modèle sourceSet
map


binding

Identifie le type d'application auquel s'adresse le script.
Syntaxe
Reference_Syntax.binding = "XFA | Application_type"
Valeurs

Type

Valeurs
Chaîne
      •
      XFA (par défaut)
Le script doit être appliqué par une application standard.
      •
      Tout autre type d'application valide
Une valeur différente de XFA signifie que le script peut être ignoré par les applications standard.
Application

Modèle

Objet
Modèle de formulaire
script
Exemples
JavaScript
TextField1.resolveNode("#event.#script").binding = "XFA";
FormCalc
TextField1.#event.#script.binding = "XFA"


blank (désapprouvée)

Spécifie si la zone de page doit être vierge et par conséquent faire l'objet d'un traitement particulier par le périphérique de sortie.
Syntaxe
Reference_Syntax.blank = "0 | 1"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
La zone de page ne doit pas être vierge, et tous les contenus sont rendus.
      •
      1
La zone de page doit être vierge et peut faire l'objet d'un traitement particulier par le périphérique de sortie.
Par exemple, une imprimante peut facturer l'utilisateur à la page imprimée. L'utilisateur ne souhaite pas se voir facturer les versos vierges des pages imprimées recto-verso. Grâce à cette propriété, les versos vierges du document sont signalés comme tel, ce qui interdit à l'application de traitement de rendre de contenu sur le verso et signale éventuellement à l'imprimante de vérifier que ce verso vierge n'est pas facturé à l'utilisateur.
Application

Modèle

Objet
Modèle de formulaire
pageArea
Exemples
L'expression de syntaxe de référence varie selon l'objet à partir duquel elle est appelée.
JavaScript
xfa.form.form1.pageSet.Page1.blank;
FormCalc
xfa.form.form1.pageSet.Page1.blank


blankOrNotBlank

Spécifie si la zone de page doit être vierge et par conséquent faire l'objet d'un traitement particulier par le périphérique de sortie.
Syntaxe
Reference_Syntax.blankOrNotBlank = "any | blank | notBlank"
Valeurs

Type

Valeurs
Chaîne
      •
      any (par défaut)
Représente n'importe quelle page vierge ou non vierge.
      •
      blank
Représente une page insérée par un saut vers une page paire lorsqu'il s'agit d'une page paire, ou par un saut vers une page impaire lorsqu'il s'agit d'une page impaire.
      •
      notBlank
Représente n'importe quelle page insérée pour héberger du contenu ou respecter les règles d'occurrence minimale.
Application

Modèle

Objet
Modèle de formulaire
pageArea
Exemples
L'expression de syntaxe de référence varie selon l'objet à partir duquel elle est appelée.
JavaScript
xfa.form.form1.pageSet.Page1.blankOrNotBlank = "notBlank";
FormCalc
xfa.form.form1.pageSet.Page1.blankOrNotBlank = "notBlank"


bofAction

Spécifie l'opération à effectuer si l'enregistrement actif est le premier du jeu d'enregistrements.
Syntaxe
Reference_Syntax.bofAction = "moveLast | stayEOF"
Valeurs

Type

Valeurs
Chaîne
      •
      moveLast (par défaut)
Déplace l'enregistrement actif vers un emplacement situé après le dernier enregistrement.
      •
      stayEOF
L'enregistrement actif sera toujours le dernier enregistrement du jeu d'enregistrements.
Application

Modèle

Objet
Modèle sourceSet
recordSet


bookendLeader

Indique le sous-formulaire à placer dans la zone de contenu ou la page active avant tout autre contenu.
Si les propriétés bookendLeader et bookendTrailer sont fournies, les deux sous-formulaires encadrent le contenu comme des pages de garde.
Syntaxe
Reference_Syntax.bookendLeader = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant le nom ou l'expression de syntaxe de référence complète d'un sous-formulaire.
Application

Modèle

Objet
Modèle de formulaire
break
Exemples
JavaScript
Subform1.break.bookendLeader = "xfa.form.form1.Subform2";
FormCalc
Subform1.break.bookendLeader = "xfa.form.form1.Subform2"


bookendTrailer

Indique le sous-formulaire à placer dans la zone de contenu ou la page active après tout autre contenu.
Si les propriétés bookendLeader et bookendTrailer sont fournies, les deux sous-formulaires encadrent le contenu comme des pages de garde.
Syntaxe
Reference_Syntax.bookendTrailer = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant le nom ou l'expression de syntaxe de référence complète d'un sous-formulaire.
Application

Modèle

Objet
Modèle de formulaire
break
Exemples
JavaScript
Subform1.break.bookendTrailer = « xfa.form.form1.Subform2 »;
FormCalc
Subform1.break.bookendTrailer = "xfa.form.form1.Subform2"


borderColor

Indique la valeur de la couleur de la bordure pour ce champ.
Vous devez définir une bordure avant de modifier la couleur au moyen d'un script.
Syntaxe
Reference_Syntax.borderColor = " [0-255], [0-255], [0-255]"
Valeurs

Type

Valeurs
Chaîne
Pour l’espace de couleurs sRVB, les valeurs des composantes doivent suivre le format r,v,b, où r est la valeur de la composante rouge, v celle de la composante verte et b celle de la composante bleue. Chaque valeur doit être comprise entre 0 et 255 (inclus). La valeur 255 représente l'intensité d'affichage maximale. Par exemple, 255,0,0 correspond à la couleur rouge.
La couleur par défaut varie selon le contexte dans lequel une couleur est utilisée. Elle est déterminée par l'objet qui englobe l'objet de couleur.
Application

Modèle

Objet
Modèle de formulaire
exclGroup
field
Exemples
JavaScript
TextField1.borderColor = "125,154,125";
FormCalc
TextField1.borderColor = "125,154,125"


borderWidth

Indique la largeur de la bordure pour ce champ.
Syntaxe
Reference_Syntax.borderWidth = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
exclGroup
field
Exemples
JavaScript
TextField1.borderWidth = "0.05in";
FormCalc
TextField1.borderWidth = "0.05in"


bottomInset

Indique la taille d’une insertion en bas.
Syntaxe
Reference_Syntax.bottomInset = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
margin
Exemples
JavaScript
Subform1.margin.bottomInset = "1in";
FormCalc
Subform1.margin.bottomInset ="1in"


break

Indique les contraintes de déplacement vers une nouvelle page ou zone de contenu après la génération d'un objet.
Syntaxe
Reference_Syntax.break = "close | open"
Valeurs

Type

Valeurs
Chaîne
      •
      close (par défaut)
      •
      open
Application

Modèle

Objet
Modèle de formulaire
border
Exemples
JavaScript
Subform1.border.break = "open";
FormCalc
Subform1.border.break = "open"


calculationsEnabled

Indique si les scripts de calcul seront exécutés ou non.
Syntaxe
Reference_Syntax.calculationsEnabled= "0 | 1"
Valeurs

Type

Valeurs
Booléen
      •
      1 (par défaut)
Les scripts de calcul seront exécutés.
      •
      0
Les scripts de calcul ne seront pas exécutés.
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.calculationsEnabled = "1";
FormCalc
xfa.host.calculationsEnabled = "1"


cap

Spécifie le rendu d'extrémité du contour.
Les contours formant une zone fermée n'ont pas de rendu d'extrémité. En particulier, les limites des rectangles et bordures, ainsi que les arêtes des arcs à 360 degrés, ne sont pas considérés comme ayant une extrémité. Les arcs dotés d'angles de flèche de moins de 360 degrés et de lignes ont quant à eux deux points d'extrémité.
Syntaxe
Reference_Syntax.cap = "square | butt | round"
Valeurs

Type

Valeurs
Chaîne
      •
      square (par défaut)
Une fois le contour achevé, le rendu erroné présente un report des bords au-delà de leurs points d'extrémité à une distance correspondant à la moitié de l'épaisseur de la bordure.
      •
      butt
Une fois le contour achevé, le rendu erroné présente l'extrémité des bords chevauchant les points d'extrémité.
      •
      round
Une fois le contour achevé, le rendu erroné présente un demi-cercle sur le point d'extrémité de la bordure, dont le rayon correspond à la moitié de l'épaisseur de la bordure.
Application

Modèle

Objet
Modèle de formulaire
edge
Exemples
JavaScript
Line1.resolveNode("value.#line.edge").cap = "round";
FormCalc
Line1.value.#line.edge.cap = "round"


change

Indique la valeur saisie ou collée par un utilisateur dans un champ immédiatement après avoir effectué une opération.
Syntaxe
Reference_Syntax.change
Valeurs

Type

Valeurs
Chaîne
Toute valeur de chaîne valable adaptée à un champ de formulaire spécifique
Application

Modèle

Objet
Modèle d'événement
eventPseudoModel
Exemples
JavaScript
xfa.event.change;
FormCalc
xfa.event.change


charEncoding

Spécifie l'encodage de caractères de la valeur encodée dans un code à barres.
La valeur du champ de code à barres est numérotée dans une séquence d'octets en fonction de l'encodage de caractères spécifié. Elle est ensuite compressée si la propriété dataPrep l'exige et chiffrée si l'objet encrypt est présent. Enfin, elle est encodée en fonction de la symbologie.
la valeur de cette propriété ne respecte pas la casse des caractères et doit correspondre à l'une des valeurs suivantes.
Syntaxe
Reference_Syntax.charEncoding = "UTF-8 | none | ISO-8859-1 | ISO-8859-2 | SO-8859-7 | SHift-JIS | KSC-5601 | Big-Five | GB-2312 | UTF-16 | UCS-2 | fontSpecific"
Valeurs

Type

Valeurs
Chaîne
      •
      UTF-8 (par défaut)
Les caractères sont encodés à l'aide de points de code Unicode selon les normes Unicode et de la numérotation consécutive UTF-8 (selon la norme ISO/IEC 10646).
      •
      none
Aucun encodage spécifique n'est indiqué. Les caractères sont encodés à l'aide de l'encodage disponible sur le système d'exploitation.
      •
      ISO-8859-1
Les caractères sont encodés selon la norme ISO-8859-1, également connue sous l'appellation Latin-1.
      •
      ISO-8859-2
Les caractères sont encodés selon la norme ISO-8859-2.
      •
      SO-8859-7
Les caractères sont encodés selon la norme ISO-8859-7.
      •
      Shift-JIS
Les caractères sont encodés selon la norme JIS X 0208, plus connue sous le nom de Shift-JIS.
      •
      KSC-5601
Les caractères sont encodés selon le code CII (Code for Information Interchange, Hangul et Hanja.
      •
      Big-Five
Les caractères sont encodés en chinois traditionnel (Big-5). Il n'existe pas de norme officielle relative à l'encodage Big-5. Aussi, plusieurs variantes sont disponibles. Le modèle d'objet de formulaire d'Adobe utilise la variante mise en oeuvre par Microsoft sous la forme de code.
      •
      GB-2312
Les caractères sont encodés en chinois simplifié.
      •
      UTF-16
Les caractères sont encodés à l'aide de points de code Unicode selon les normes Unicode et de la numérotation consécutive UTF-16 (selon la norme ISO/IEC 10646).
      •
      UCS-2
Les caractères sont encodés à l'aide de points de code Unicode (selon les normes Unicode) et de la numérotation consécutive UCS-2 (selon la norme ISO/IEC 10646).
      •
      fontSpecific
Les caractères sont encodés d'après la police. Chaque caractère est représenté par un octet de 8 bits.
Application

Modèle

Objet
Modèle de formulaire
barcode
Exemples
JavaScript
Code11BarCode1.resolveNode(« ui.#barcode »).charEncoding = « UCS-2 »;
FormCalc
Code11BarCode1.ui.#barcode.charEncoding = "UCS-2"


checksum

Indique un algorithme de la somme de contrôle à insérer dans un code à barres.
Le calcul des sommes de contrôle repose sur les données du code à barres.
La conception de modèle autorise l'un quelconque des choix présentés ci-dessous. Toutefois, certains formats de codes à barres exigent une somme de contrôle spécifique ou rejettent les sommes de contrôle. Dans ce cas, la propriété checksum n'est pas prise en compte. Parmi les formats de codes à barres restants, certains prennent en charge un jeu partiel limité des choix ci-dessous. Pour ce type de code à barres, la conception de modèle n'indique pas de choix non pris en charge.
Syntaxe
Reference_Syntax.checksum = "none | auto | 1mod10 | 2mod10 | 1mod10_1mod11"
Valeurs

Type

Valeurs
Chaîne
      •
      none (par défaut)
N'insère pas de somme de contrôle.
      •
      auto
Insère la somme de contrôle par défaut définie pour le format de code à barres.
      •
      1mod10
Insère une somme de contrôle 1 modulo 10.
      •
      2mod10
Insère une somme de contrôle 2 modulo 10.
      •
      1mod10_1mod11
Insère une somme de contrôle 1 modulo 10 suivie d'une somme de contrôle 1 modulo 11.
1 modulo 10, 2 modulo 10 et 1 modulo 11 sont des normes de codes à barres. Référez-vous à la documentation relative à ces normes pour en savoir plus sur ce type de code à barres.
Application

Modèle

Objet
Modèle de formulaire
barcode
Exemples
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").checksum  = "2mod10";
FormCalc
Code11BarCode1.ui.#barcode.checksum  = "2mod10"


circular

Permet de convertir un arc en cercle.
Syntaxe
Reference_Syntax.circular = "0 | 1"
Valeurs

Type

Valeurs
Booléen
      •
      0 (par défaut)
Ne transforme pas l'arc en tracé circulaire.
      •
      1
Transforme l'arc en tracé circulaire.
vous pouvez convertir un arc en cercle même si la zone de contenu de l'arc n'est pas carrée. Au besoin, la taille du cercle est ajustée à celle de la zone de contenu.
Application

Modèle

Objet
Modèle de formulaire
arc
Exemples
JavaScript
Circle1.resolveNode("value.#arc").circular = "1";
FormCalc
Circle1.value.#arc.circular = 1


classAll

Renvoie une collection de nœuds de même classe et compris dans la plage indiquée.
cette propriété est en lecture seule.
Syntaxe
Reference_Syntax.classAll = "objects"
Valeurs

Type

Valeurs
Objet
Une série d'objets provenant de la même classe que l'objet actif et issu de la même plage.
Application
Classe de tree
Exemples
JavaScript
Subform1.classAll;
FormCalc
Subform1.classAll


classId

Spécifie un nom ou un emplacement URI pour le code de programmation représenté par l'objet.
Syntaxe
Reference_Syntax.classId = "URI"
Valeurs

Type

Valeurs
Chaîne
Toute valeur URI complètement qualifiée.
Application

Modèle

Objet
Modèle de formulaire
exObject


classIndex

Renvoie la position de l'objet dans sa collection d'objets de même classe et compris dans la plage indiquée.
cette propriété est en lecture seule.
Syntaxe
Reference_Syntax.classIndex = "integer"
Valeurs

Type

Valeurs
Entier
Un entier représentant la position de l'index sur la base de 0 pour l'objet actif par rapport à l'ensemble d'objets compris dans une même plage et provenant de la même classe.
Application
Classe de tree
Exemples
JavaScript
Subform1.classIndex;
FormCalc
Subform1.classIndex


className

Spécifie le nom de la classe de cet objet.
cette propriété est en lecture seule.
Syntaxe
Reference_Syntax.className = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valable représentant le nom de classe de l'objet spécifique.
Application
Classe de object
Exemples
JavaScript
Subform1.className;
FormCalc
Subform1.className


codeBase

Spécifie un emplacement URI pouvant être utilisé pour faciliter la résolution d'une propriété classId relative.
Syntaxe
Reference_Syntax.codeBase = "URI"
Valeurs

Type

Valeurs
Chaîne
Valeur URI complètement qualifiée.
Application

Modèle

Objet
Modèle de formulaire
exObject


codeType

Spécifie un identifiant de type MIME capable d'identifier le code de programmation représenté par l'objet.
Syntaxe
Reference_Syntax.codeType = "MIME-type"
Valeurs

Type

Valeurs
Chaîne
Un identifiant de type MIME valide. Par exemple : application/java.
Application

Modèle

Objet
Modèle de formulaire
exObject


colSpan

Spécifie le nombre de colonnes étendues par cet objet lorsqu'il est incorporé dans un sous-formulaire doté d'un type de disposition des rangées particulier.
Syntaxe
Reference_Syntax.colSpan = "1 | integer"
Valeurs

Type

Valeurs
Chaîne
      •
      1 (par défaut)
      •
      Tout nombre entier valide.
Application

Modèle

Objet
Modèle de formulaire
zone
draw
exclGroup
field
subform
Exemples
JavaScript
StaticText1.colSpan = "1";
FormCalc
StaticText1.colSpan = "1"


columnWidths

Spécifie la largeur des colonnes d'un tableau.
La propriété columnWidth n'est pas prise en compte à moins que la propriété layout ne soit définie à table.
Syntaxe
Reference_Syntax.columnWidth = "measurement | -1 [, [, measurement | -1 ] ]"
Valeurs

Type

Valeurs
Chaîne
La valeur de cette propriété est un ensemble de jetons séparés par des espaces. Chaque jeton doit être une mesure valide ou -1. Si une mesure existe, la largeur de la colonne correspondante doit être définie sur cette valeur. Si -1 existe, la colonne correspondante prend la largeur la plus importante affichée dans l'une des rangées du tableau.
Application

Modèle

Objet
Modèle de formulaire
subform
Exemples
JavaScript
Subform1.columnWidths = ".5in 1.5in";
FormCalc
Subform1.columnWidths = ".5in 1.5in"


commandType

Spécifie le type de commande utilisé par une requête de données.
Syntaxe
Reference_Syntax.commandType = "unknown | text | table | storedProc"
Valeurs

Type

Valeurs
Chaîne
      •
      unknown (par défaut)
      •
      text
Une chaîne de requête SQL explicite stockée dans la base de données sans nom particulier.
      •
      table
Un tableau stocké dans la base de données.
      •
      storedProc
Une requête, SQL par exemple, créée pour interroger un ou plusieurs tableaux de la base de données, puis enregistrée dans la base de données sous un nom particulier.
Application

Modèle

Objet
Modèle sourceSet
query
Exemples
Dans ces exemples, Titles désigne le nom de la connexion aux données.
JavaScript
xfa.sourceSet.Titles.nodes.item(1).query.setAttribute("text", "commandType");
FormCalc
xfa.sourceSet.Titles.nodes.item(1).query.setAttribute("text", "commandType")


commitKey

Indique comment l'utilisateur a défini la valeur actuelle d'un champ de formulaire.
Syntaxe
Reference_Syntax.commitKey = "0 | 1 | 2 | 3"
Valeurs

Type

Valeurs
Entier
      •
      0 (par défaut)
La valeur n'a pas été définie (lorsque, par exemple, l'utilisateur appuie sur la touche Echap avant que le champ de formulaire ne perde la cible d'action).
      •
      1
La valeur est définie lorsqu'un utilisateur clique en dehors du champ avec le bouton gauche de la souris.
      •
      2
La valeur est définie lorsqu'un utilisateur appuie sur la touche Entrée.
      •
      3
La valeur est définie lorsqu'un utilisateur passe à un nouveau champ à l'aide de la touche Tab.
Application

Modèle

Objet
Modèle d'événement
eventPseudoModel
Exemples
JavaScript
xfa.event.commitKey = "2";
FormCalc
xfa.event.commitKey = "2"


commitOn

Indique lorsque les sélections de l'utilisateur sont transmises au modèle de données.
Syntaxe
Reference_Syntax.commitOn = "select | exit"
Valeurs

Type

Valeurs
Chaîne
      •
      select
Les données sélectionnées sont consignées dans le modèle lorsqu'un utilisateur sélectionne à l'aide du clavier ou de la souris une entrée dans la liste de choix.
l'utilisation de données de validation disponibles dès l'étape de la sélection pour une liste à choix multiples peut s'avérer importante dans les formulaires contenant des fonctions interactives non XFA telles que les liens hypertexte ou les annotations Acrobat. Les personnes remplissant de tels formulaires peuvent comprendre à tort que la sélection d'un élément dans une liste à choix multiples suivie d'un clic sur une fonction interactive non XFA revient à quitter la liste. En réalité, la liste est toujours sélectionnée.
      •
      exit
Les données sélectionnées ne sont pas consignées dans le modèle de données tant que le champ n'est pas désélectionné. Il s'agit du paramètre recommandé pour les listes à choix multiples prenant en charge plusieurs sélections (open=« multiSelect »).
Application

Modèle

Objet
Modèle de formulaire
choiceList
Exemples
JavaScript
DropDownList1.resolveNode("ui.#choiceList").commitOn = "exit";
FormCalc
DropDownList1.ui.#choiceList.commitOn = "exit"


connection

Spécifie le nom du contrôle de connexion associé dans l'ensemble de connexions.
La connexion désignée par cette propriété doit pointer vers un service Web.
Syntaxe
Reference_Syntax.connection = "string"
Valeurs

Type

Valeurs
Chaîne
Une chaîne valide représentant le nom de l'objet de connexion associé dans l'ensemble de connexions. Si cette propriété est absente ou vide, la connexion prend par défaut le nom du sous-formulaire recevant les données.
Application

Modèle

Objet
Modèle de formulaire
bindItems
connect
execute
setProperty
Modèle sourceSet
connect
Exemples
JavaScript
TextField1.resolveNode("#connect").connection = "DataConnection";
FormCalc
TextField1.#connect.connection = "DataConnection"


contains

Spécifie si une valeur de données doit être incluse dans la valeur de l'objet parent ou en tant que propriété du parent.
Syntaxe
Reference_Syntax.contains = "data | metaData"
Valeurs

Type

Valeurs
Chaîne
      •
      data (par défaut)
La valeur est incluse dans la valeur de l'objet parent
      •
      metaData
La valeur est une propriété de l'objet parent.
Application

Modèle

Objet
Modèle de données
dataValue


content

Indique le contenu de l'objet.
Syntaxe
Reference_Syntax.content = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valable représentant le contenu de l'objet. Les paquets contenant des données XML doivent renvoyer une chaîne vide.
Application

Modèle

Objet
modèle XFA
packet
Exemples
JavaScript
xfa.packet.content = "";
FormCalc
xfa.packet.content = ""


contentType

Spécifie le type de contenu présent dans le document référencé, à savoir MIME.
Syntaxe
Reference_Syntax.contentType = "text/plain | application/x-formcalc | Mime-type"
Valeurs

Type

Valeurs
Chaîne
Les valeurs suivantes sont autorisées pour les documents contenant du texte :
      •
      text/plain (par défaut)
Texte sans ornementation. L'application peut accepter du contenu ne se conformant pas strictement aux conditions du type MIME.
      •
      application/x-formcalc
Un script FormCalc.
      •
      Tout identifiant de type MIME valide.
La prise en charge d'autres types de texte, tels que text/html et de types de script, tels que application/x-ecmascript, est définie par l'implémentation.
Lorsque le document référencé est une image, un identifiant de type MIME doit être fourni pour cette propriété pour signaler à l'application que le contenu est une image. Après avoir analysé les données image, l'application peut toutefois remplacer la valeur fournie si elle estime que ces données sont de type différent. Les types d'images pris en charge sont déterminés par l'implémentation.
Application

Modèle

Objet
Modèle de données
dataValue
Modèle de formulaire
exData
image
script
Modèle sourceSet
bind
Exemples
JavaScript
ImageField1.resolveNode("value.#image").contentType = "application/x-formcalc";
FormCalc
ImageField1.value.#image.contentType = "application/x-formcalc"


context

Indique l'objet actif, qui est l'objet de départ lors de l'utilisation des méthodes resolveNode et resolveNodes.
Syntaxe
Reference_Syntax.content = "object"
Valeurs

Type

Valeurs
Objet
L'objet actif.
Application
Classe de model


count

Indique le nombre actuel d'instances de sous-formulaire sur un formulaire.
Syntaxe
Reference_Syntax.count = "integer"
Valeurs

Type

Valeurs
Entier
      •
      integer
Entier supérieur ou égal à 0 indiquant le nombre d'instances de sous-formulaire sur un formulaire.
Application

Modèle

Objet
Modèle de formulaire
instanceManager
Exemples
JavaScript
Subform1.instanceManager.count;
FormCalc
Subform1.instanceManager.count


credentialServerPolicy

Indique si la vérification de l'état du certificat est nécessaire lorsqu'une signature numérique est signée. L'état du certificat peut être vérifié à l'aide d'une liste de révocation des certificats ou d'une réponse OCSP (Online Certificate Status Protocol).
Syntaxe
Reference_Syntax.credentialServerPolicy = "Optional | Required"
Valeurs

Type

Valeurs
Chaîne
•
Optional (par défaut)
L'inclusion de la liste de révocation des certificats ou de la réponse OCSP est facultative.
•
Required
L'inclusion de la liste de révocation des certificats ou de la réponse OCSP est obligatoire.
Application

Modèle

Objet
Modèle de formulaire
certificates


crlSign

Indique une extension d'utilisation acceptable devant être présente dans le certificat de signature.
Syntaxe
Reference_Syntax.crlSign = "Yes | No | empty_string"
Valeurs

Type

Valeurs
Chaîne
•
Yes (par défaut)
La valeur doit être définie dans le certificat pour pouvoir être acceptée.
•
No
La valeur ne doit pas être définie dans le certificat pour pouvoir être acceptée.
•
""
S'il est spécifié ou non spécifié comme chaîne vide, l'attribut du certificat n'est pas pris en compte.
Application

Modèle

Objet
Modèle de formulaire
keyUsage


cSpace

Spécifie l'espace colorimétrique.
L'espace colorimétrique par défaut, qui s'avère être l'unique espace autorisé, est SRGB.
Syntaxe
Reference_Syntax.cSpace = "SRGB"
Valeurs

Type

Valeurs
Chaîne
SRBG (par défaut)
il s'agit de l'unique valeur prise en charge.
Application

Modèle

Objet
Modèle de formulaire
Couleur
Exemples
JavaScript
TextField1.border.edge.color.cSpace = "SRGB";
FormCalc
TextField1.border.edge.color.cSpace = "SRGB"


currentPage

Définit la page active d'un document lors de l'exécution.
Les valeurs de page sont à base 0, de sorte que la première page d'un document retourne la valeur 0.
La propriété currentPage est disponible lorsque l'événement layout:ready est exécuté sur un client. En revanche, elle n'est pas disponible lorsque l'événement layout:ready est exécuté sur le serveur, car l'exécution de la propriété doit être précédée par celle de la disposition du formulaire.
Syntaxe
Reference_Syntax.currentPage = "integer"
Valeurs

Type

Valeurs
Entier
Entier valable représentant une page spécifique du document.
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.currentPage = "2";
FormCalc
xfa.host.currentPage = "2"


currentRecordNumber

Renvoie le numéro d’enregistrement actif dans la plage d’enregistrements contenus dans l’objet dataWindow actif.
Syntaxe
Reference_Syntax.currentRecordNumber = "integer"
Valeurs

Type

Valeurs
Entier
Tout nombre entier valide.
Application

Modèle

Objet
Modèle de données
dataWindow
Exemples
JavaScript
xfa.dataWindow.currentRecordNumber = "2"; // The third record
FormCalc
xfa.dataWindow.currentRecordNumber = "2" // The third record


cursorLocation

Indique l'emplacement de la bibliothèque de curseurs à utiliser avec le jeu d'enregistrements.
Syntaxe
Reference_Syntax.cursorLocation = "client | server"
Valeurs

Type

Valeurs
Chaîne
      •
      client (par défaut)
La bibliothèque de curseurs est située sur l'ordinateur client.
      •
      server
La bibliothèque de curseurs est située sur le serveur.
Application

Modèle

Objet
Modèle sourceSet
recordSet


cursorType

Spécifie le type de curseur à utiliser à l'ouverture du jeu d'enregistrements.
Syntaxe
Reference_Syntax.cursorType = "forwardOnly | keyset | dynamic | static | unspecified"
Valeurs

Type

Valeurs
Chaîne
      •
      forwardOnly (par défaut)
Identique à un curseur statique, mais le défilement ne se fait que vers l'avant. Les performances s'en trouvent améliorées lorsque vous ne devez parcourir un jeu d'enregistrements qu'une seule fois.
      •
      keyset
Semblable à un curseur dynamique, mais les enregistrements ajoutés par d'autres utilisateurs ne sont pas visibles. Les modifications de données effectuées par d'autres utilisateurs sont visibles.
      •
      dynamic
Les ajouts, modifications et suppressions effectués par d'autres utilisateurs sont visibles, et toutes les opérations effectuées dans le jeu d'enregistrements sont autorisées, à l'exception des signets, si le fournisseur ne les prend pas en charge.
      •
      static
Copie statique d'un ensemble d'enregistrements pouvant être utilisée pour rechercher des données ou pour générer des rapports. Les ajouts, les modifications et les suppressions effectués par d'autres utilisateurs ne sont pas visibles.
      •
      unspecified
Le type de curseur n'est pas spécifié.
Application

Modèle

Objet
Modèle sourceSet
recordSet


data

Indique si l'image fournie au widget doit être désignée comme référence ou incorporée.
La propriété data modifie le comportement de l'objet lorsque le formulaire est rempli.
Syntaxe
Reference_Syntax.data = "link | embed"
Valeurs

Type

Valeurs
Chaîne
      •
      link
L'image est désignée comme référence URI. Si l'utilisateur fournit le widget avec un URI, l'attribut href de l'objet Image du conteneur est mis à jour pour prendre en compte le nouveau URI. Si l'objet Image précédemment chargé incorporait une image, cette dernière est supprimée de l'objet.
      •
      embed
L'image est incorporée dans l'objet Image du conteneur. Si l'utilisateur fournit le widget avec un URI, l'image référencée par l'URI est incorporée comme contenu de l'objet Image.
Application

Modèle

Objet
Modèle de formulaire
imageEdit
Exemples
JavaScript
TextField1.resolveNode("ui.#imageEdit").data = "embed";
FormCalc
TextField1.ui.#textEdit.data = "embed"


dataColumnCount

Spécifie un nombre facultatif de colonnes de données à encoder pour les codes à barres pris en charge. Cette propriété s'applique uniquement aux codes à barres bidimensionnels (2D).
Le modèle de formulaire doit associer cette propriété à la propriété dataRowCount pour spécifier un code à barres correspondant à un nombre fixe de rangées et de colonnes ; dans le cas contraire, l'analyseur doit utiliser la propriété rowColumnRatio pour déterminer le nombre de rangées et de colonnes. Le modèle ne doit pas fournir la propriété dataColumnCount à moins que la propriété dataRowCount ne soit également fournie. Lorsque ces propriétés sont utilisées, la taille du code à barres est fixe. Si les données fournies ne remplissent pas le code à barres, ce dernier est complété par des caractères de remplissage.
Syntaxe
Reference_Syntax.dataColumnCount = "string"
Valeurs

Type

Valeurs
Chaîne
Une chaîne valide représentant le nombre de colonnes de données à encoder.
Application

Modèle

Objet
Modèle de formulaire
barcode
Exemples
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").dataColumnCount = "3";
FormCalc
Code11BarCode1.ui.#barcode.dataColumnCount = "3"


dataDescription

Spécifie le nom de la description d'une connexion aux données à utiliser avec un type particulier de connexion aux services Web.
Syntaxe
Reference_Syntax.dataDescription = "string"
Valeurs

Type

Valeurs
Chaîne
Une chaîne valide représentant le nom d'une description de données à utiliser lors de l'exportation de données.
Application

Modèle

Objet
Modèle connectionSet


dataEncipherment

Indique une extension d'utilisation acceptable devant être présente dans le certificat de signature.
Syntaxe
Reference_Syntax.dataEncipherment = "Yes | No | empty_string"
Valeurs

Type

Valeurs
Chaîne
•
Yes (par défaut)
La valeur doit être définie dans le certificat pour pouvoir être acceptée.
•
No
La valeur ne doit pas être définie dans le certificat pour pouvoir être acceptée.
•
""
S'il est spécifié ou non spécifié comme chaîne vide, l'attribut du certificat n'est pas pris en compte.
Application

Modèle

Objet
Modèle de formulaire
keyUsage


dataLength

Indique le nombre maximal de caractères de l’occurrence d’un code à barres. Cette propriété s'applique uniquement aux codes à barres unidimensionnels.
Pour les codes à barres logiciels, lorsque la propriété moduleWidth n'est pas spécifiée, la propriété dataLength doit être fournie par la conception de formulaire. Pour les codes à barres logiciels, cette propriété n'est pas prise en compte.
Les données affichées ne sont pas validées. Dans le cas des codes à barres logiciels, l'application permet aux données de dépasser la section du champ affecté. Quant aux codes à barres matériels, le résultat d'un débordement dépend de l'imprimante.
il n'existe pas de longueur minimale correspondante. Certains formats de codes à barres disposent d'un nombre fixe de symboles et doivent être complétés au besoin à l'aide de caractères de remplissage. D'autres formats, au contraire, admettent un nombre variable de symboles et doivent se terminer après le dernier symbole.
Syntaxe
Reference_Syntax.dataLength = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valable représentant le nombre maximum de caractères pour cette instance de code à barres. Chaque type de code à barres a une longueur par défaut qui lui est propre.
Application

Modèle

Objet
Modèle de formulaire
barcode
Exemples
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").dataLength = "10";
FormCalc
Code11BarCode1.ui.#barcode.dataLength = "10"


dataPrep

Définit le prétraitement appliqué aux données consignées dans le code à barres.
Ce prétraitement n'a aucun impact sur les données contenues dans les modèles d'objet ni sur ce que voit l'utilisateur lorsque le champ est sélectionné dans les contextes interactifs.
propriété recommandée pour les codes à barres bidimensionnels (2D) uniquement.
Syntaxe
Reference_Syntax.dataPrep = "none | flateCompress"
Valeurs

Type

Valeurs
Chaîne
      •
      none (par défaut)
Utilise les données telles qu'elles sont fournies.
      •
      flateCompress
Ecrit un en-tête composé d'un octet avec une valeur décimale de 257, suivi d'un autre octet dont la valeur décimale est 1. Consigne ensuite les données compressées à l'aide de l'algorithme Flate, comme défini par le groupe IETF (Internet Engineering Task Force) dans le document RFC1951. N'utilise pas d'algorithme de prévision.
Ne configurez pas cette option avec un type ne pouvant pas encoder de données binaires arbitraires.
Application

Modèle

Objet
Modèle de formulaire
barcode
Exemples
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").dataPrep = "flateCompress";
FormCalc
Code11BarCode1.ui.#barcode.dataPrep = "flateCompress"


dataRowCount

Spécifie un nombre facultatif de rangées de données à encoder pour les codes à barres pris en charge. Cette propriété s'applique uniquement aux codes à barres bidimensionnels (2D).
Le modèle de formulaire peut associer cette propriété à la propriété dataColumnCount pour spécifier un code à barres correspondant à un nombre fixe de rangées et de colonnes. Sinon, la propriété rowColumnRatio ainsi que la longueur réelle des données insérées déterminent le nombre de rangées et de colonnes. La propriété dataRowCount n'existe pas si la propriété dataColumnCount n'est pas disponible. Lorsque ces propriétés sont utilisées, la taille du code à barres est fixe. Si les données fournies ne remplissent pas le code à barres, les cellules restantes sont complétées par des caractères de remplissage.
Syntaxe
Reference_Syntax.dataRowCount = "string"
Valeurs

Type

Valeurs
Chaîne
Une chaîne valide représentant le nombre de rangées de données à encoder.
Application

Modèle

Objet
Modèle de formulaire
barcode
Exemples
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").dataRowCount = "2";
FormCalc
Code11BarCode1.ui.#barcode.dataRowCount = "2"


db

Spécifie le nom d'une base de données disponible auprès du fournisseur.
Syntaxe
Reference_Syntax.db = "string"
Valeurs

Type

Valeurs
Chaîne
Une chaîne valide représentant le nom de la base de données.
Application

Modèle

Objet
Modèle sourceSet
source


decipherOnly

Indique une extension d'utilisation acceptable devant être présente dans le certificat de signature.
Syntaxe
Reference_Syntax.decipherOnly = "Yes | No | empty_string"
Valeurs

Type

Valeurs
Chaîne
•
Yes (par défaut)
La valeur doit être définie dans le certificat pour pouvoir être acceptée.
•
No
La valeur ne doit pas être définie dans le certificat pour pouvoir être acceptée.
•
""
S'il est spécifié ou non spécifié comme chaîne vide, l'attribut du certificat n'est pas pris en compte.
Application

Modèle

Objet
Modèle de formulaire
keyUsage


delayedOpen

Spécifie la durée, en secondes, du délai d'ouverture de la source de données une fois la connexion établie.
Syntaxe
Reference_Syntax.delayedOpen = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant le nombre de secondes.
Application

Modèle

Objet
Modèle sourceSet
command
Exemples
Dans ces exemples, Titles désigne le nom de la connexion aux données.
JavaScript
xfa.sourceSet.Titles.connect.delayedOpen = "5";
FormCalc
xfa.sourceSet.Titles.connect.delayedOpen = "5"


delimiter

Sépare les attributs dans la chaîne Pseudo PS.
Syntaxe
Reference_Syntax.delimiter = ", | string"
Valeurs

Type

Valeurs
Chaîne
•
, (par défaut)
•
Une chaîne valide qui sépare les attributs dans la chaîne Pseudo PS.


digitalSignature

Indique une extension d'utilisation acceptable devant être présente dans le certificat de signature.
Syntaxe
Reference_Syntax.digitalSignature = "Yes | No | empty_string"
Valeurs

Type

Valeurs
Chaîne
•
Yes (par défaut)
La valeur doit être définie dans le certificat pour pouvoir être acceptée.
•
No
La valeur ne doit pas être définie dans le certificat pour pouvoir être acceptée.
•
""
S'il est spécifié ou non spécifié comme chaîne vide, l'attribut du certificat n'est pas pris en compte.
Application

Modèle

Objet
Modèle de formulaire
keyUsage


disable

Désactive l'invite audible.
Syntaxe
Reference_Syntax.disable = "1 | 0"
Valeurs

Type

Valeurs
Chaîne
      •
      1 (par défaut)
Une invite audible est générée si le champ n'est pas masqué ou invisible.
      •
      0
Aucune invite audible n'existe.
Application

Modèle

Objet
Modèle de formulaire
speak
Exemples
JavaScript
TextField1.assist.speak.disable = "0";
FormCalc
TextField1.assist.speak.disable = "0"


embedPDF

Détermine si le fichier PDF doit être inclus aux données.
Syntaxe
Reference_Syntax.embedPDF = "0 | 1"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
Le fichier PDF est incorporé aux données envoyées.
      •
      1
Le fichier PDF n'est pas incorporé aux données envoyées. Un URI est envoyé à la place.
Application

Modèle

Objet
Modèle de formulaire
submit
Exemples
JavaScript
Button1.resolveNode("#event.#submit").embedPDF = "1";
FormCalc
Button1.#event.#submit.embedPDF = "1"


encipherOnly

Indique une extension d'utilisation acceptable devant être présente dans le certificat de signature.
Syntaxe
Reference_Syntax.encipherOnly = "Yes | No | empty_string"
Valeurs

Type

Valeurs
Chaîne
•
Yes (par défaut)
La valeur doit être définie dans le certificat pour pouvoir être acceptée.
•
No
La valeur ne doit pas être définie dans le certificat pour pouvoir être acceptée.
•
""
S'il est spécifié ou non spécifié comme chaîne vide, l'attribut du certificat n'est pas pris en compte.
Application

Modèle

Objet
Modèle de formulaire
keyUsage


endChar

Indique un caractère de commande de fin facultatif à ajouter aux données du code à barres.
La propriété endChar n'est pas prise en compte par l'analyseur si le format du code à barres ne prend pas en charge le caractère de commande spécifié.
Syntaxe
Reference_Syntax.endChar = "character"
Valeurs

Type

Valeurs
Chaîne
Caractère de commande valable.
Application

Modèle

Objet
Modèle de formulaire
barcode
Exemples
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").endChar = "*";
FormCalc
Code11BarCode1.ui.#barcode.endChar = "*"


eofAction

Spécifie l'opération à effectuer si l'enregistrement actif est le dernier du jeu d'enregistrements.
Syntaxe
Reference_Syntax.eofAction = "moveLast | stayEOF | addNew"
Valeurs

Type

Valeurs
Chaîne
      •
      moveLast (par défaut)
Déplace l'enregistrement actif vers un emplacement situé après le dernier enregistrement.
      •
      stayEOF
L'enregistrement actif sera toujours le dernier enregistrement du jeu d'enregistrements.
      •
      addNew
Ajoute un nouvel enregistrement au jeu d'enregistrements.
Application

Modèle

Objet
Modèle sourceSet
recordSet


errorCorrectionLevel

Indique un niveau de correction d'erreur facultatif à appliquer aux codes à barres pris en charge. Cette propriété s'applique uniquement aux codes à barres bidimensionnels (2D).
dans le cas des types de codes à barres acceptant cette propriété, l'analyseur ne tient pas compte de la checksum.
Syntaxe
Reference_Syntax.errorCorrectionLevel = "0 | integer"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
      •
      Pour les codes à barres PDF417, les valeurs admises sont des entiers compris entre 0 et 8 (inclus).
Application

Modèle

Objet
Modèle de formulaire
barcode
Exemples
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").errorCorrectionLevel = "5";
FormCalc
Code11BarCode1.ui.#barcode.errorCorrectionLevel = "5"


executeType

Indique s'il faut importer les nouvelles données dans le formulaire existant ou les fusionner dans la conception de formulaire initiale en vue d'obtenir un nouveau formulaire.
Syntaxe
Reference_Syntax.executeType = "import | remerge"
Valeurs

Type

Valeurs
Chaîne
      •
      import (par défaut)
Importe les données dans le formulaire actif sans les fusionner dans la conception de formulaire.
      •
      remerge
Fusionne les données du jeu connectionData dans la conception de formulaire. Le processus de fusion crée des sous-formulaires dynamiques (si nécessaire) selon les données renvoyées par le service Web.
Application

Modèle

Objet
Modèle de formulaire
execute
Exemples
JavaScript
Button1.resolveNode("#event.#execute").executeType = "remerge";
FormCalc
Button1.#event.#execute.executeType = "remerge"


fillColor

La valeur de la couleur de fond pour ce champ.
Vous devez définir une couleur de remplissage avant de modifier la couleur.
Syntaxe
Reference_Syntax.fillColor = "[0-255], [0-255], [0-255]"
Valeurs

Type

Valeurs
Chaîne
Pour l’espace de couleurs sRVB, les valeurs des composantes doivent suivre le format r,v,b, où r est la valeur de la composante rouge, v celle de la composante verte et b celle de la composante bleue. Chaque valeur doit être comprise entre 0 et 255 (inclus). La valeur 255 représente l'intensité d'affichage maximale. Par exemple, 255,0,0 correspond à la couleur rouge.
La couleur par défaut varie selon le contexte dans lequel une couleur est utilisée. Elle est déterminée par l'objet qui englobe l'objet de couleur.
Application

Modèle

Objet
Modèle de formulaire
exclGroup
field
Exemples
JavaScript
TextField1.fillColor = "150,130,33";
FormCalc
TextField1.fillColor = "150,130,33"


fontColor

La valeur de la couleur de premier plan pour ce champ.
Syntaxe
Reference_Syntax.fontColor = "string"
Valeurs

Type

Valeurs
Chaîne
Une chaîne valide représentant la couleur de la police.
Application

Modèle

Objet
Modèle de formulaire
field
Exemples
JavaScript
TextField1.fontColor = "150,130,33";
FormCalc
TextField1.fontColor = "150,130,33"


format

Détermine le format à utiliser pour envoyer les données.
Syntaxe
Reference_Syntax.format = "xdp | formdata | pdf | xml"
Valeurs

Type

Valeurs
Chaîne
      •
      xdp (par défaut)
Les données sont conditionnées au format XDP.
      •
      formdata
Les données sont conditionnées et encodées au format URL selon les spécifications URL (Uniform Resource Locators).
      •
      pdf
Les données sont conditionnées au format PDF selon les spécifications Adobe PDF.
Application

Modèle

Objet
Modèle de formulaire
submit
Exemples
JavaScript
Button1.resolveNode("#event.#submit").format = "pdf"
FormCalc
Button1.#event.#submit.format = "pdf"


formatMessage

Indique la chaîne de message pour la validation du format pour ce champ.
Syntaxe
Reference_Syntax.formatMessage = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant le message de validation du format.
Application

Modèle

Objet
Modèle de formulaire
field
Exemples
JavaScript
TextField1.formatMessage = "Please use the format: LASTNAME, FIRSTNAME";
FormCalc
TextField1.formatMessage = "Please use the format: LASTNAME, FIRSTNAME"


formattedValue

Indique la valeur formatée pour le champ.
Syntaxe
Reference_Syntax.formattedValue = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant la valeur affichée dans le champ avec formatage, notamment les formats et symboles graphiques.
Application

Modèle

Objet
Modèle de formulaire
field
Exemples
JavaScript
TextField2.rawValue = TextField1.formattedValue;
FormCalc
TextField2 = TextField1.formattedValue


formatTest

Définit la validation d’une clause d’image.
La propriété formatTest peut être utilisée pour les validations.
Syntaxe
Reference_Syntax.formatTest = "warning | disabled | error"
Valeurs

Type

Valeurs
Chaîne
      •
      disabled
N'effectue aucun test. L'objet de formulaire peut avoir une valeur non conforme à la clause d'image. Il est possible de laisser le champ sans valeur non conforme, sans que cela invalide le formulaire.
      •
      error
Emet un message et refuse les données qui ne tiennent pas dans la clause d'image. L'objet de formulaire doit se conformer à une clause d'image.
      •
      warning (par défaut)
Emet un message si les données ne tiennent pas dans la clause d'image tout en laissant l'utilisateur passer au champ suivant. Le message doit informer l'utilisateur que l'objet de formulaire doit comporter une valeur conforme à la clause d'image. Il doit proposer deux choix :
      •
      dismiss: l'utilisateur comprend le message et souhaite revenir au formulaire afin de satisfaire à cette contrainte.
      •
      override: l'utilisateur comprend le message, mais choisit de ne pas respecter cette contrainte.
Application

Modèle

Objet
Modèle de formulaire
validate
Exemples
Définissez le modèle de validation si cela n'est pas déjà fait.
JavaScript
TextField1.validate.picture.value = "A9A 9A9";
TextField1.validate.formatTest = "error";
FormCalc
TextField1.validate.picture = "A9A 9A9"
TextField1.validate.formatTest = "error"


fracDigits

Indique le nombre maximum de chiffres (inclusifs) suivant la décimale à capturer et à stocker.
Syntaxe
Reference_Syntax.fracDigits = "2 | integer"
Valeurs

Type

Valeurs
Chaîne
      •
      2 (par défaut)
      •
      Chaîne représentant toute valeur entière valable.
Exemples
Le type des données du champ numérique devrait être décimal.
JavaScript
NumericField1.resolveNode("value.#decimal").fracDigits = "3";
FormCalc
NumericField1.value.#decimal.fracDigits = "3"


from

Spécifie le nom original de la colonne dans la source de données.
Syntaxe
Reference_Syntax.from = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant le nom de la colonne dans la source à partir de laquelle les données seront associées.
Application

Modèle

Objet
Modèle sourceSet
map


fullText

Représente la valeur pleine (non tronquée) que l'utilisateur colle dans un champ de formulaire.
Il se peut que le texte inséré dans les zones soit tronqué s'il dépasse la zone de contenu autorisée. La propriété fullText stocke en mémoire la valeur non tronquée afin de l'utiliser dans des opérations de script.
La valeur de la newContentType détermine le type de contenu de cette propriété.
Syntaxe
Reference_Syntax.fullText = "string"
Valeurs

Type

Valeurs
Chaîne
Toute valeur de chaîne valable.
Application

Modèle

Objet
Modèle d'événement
eventPseudoModel
Exemples
JavaScript
xfa.event.fullText;
FormCalc
xfa.event.fullText


h

Mesure de la hauteur pour la disposition.
Lorsqu'elle est spécifiée sous forme de mesure, cette valeur remplace toute plage d'accroissement autorisée par la propriété minH et la propriété maxH. Si cette propriété est omise ou définie comme chaîne vide, la plage d'accroissement est définie par la propriété minH et la propriété maxH.
Syntaxe
Reference_Syntax.h = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
contentArea
draw
exclGroup
field
subform
Exemples
JavaScript
TextField1.h = "2in";
FormCalc
TextField1.h = "2in"


hAlign

Indique l'alignement de texte horizontal.
Syntaxe
Reference_Syntax.hAlign = "left | center | right | justifyAll | justify | radix"
Valeurs

Type

Valeurs
Chaîne
      •
      left (par défaut)
Aligne sur le bord gauche de la zone disponible.
      •
      center
Centre horizontalement dans la zone disponible.
      •
      right
Aligne sur le bord droit de la zone disponible.
      •
      justifyAll
Justifie toutes les lignes à gauche et à droite afin de remplir la zone disponible.
      •
      justify
Aligne la dernière ligne à gauche et justifie le reste du texte à gauche et à droite.
Application

Modèle

Objet
Modèle de formulaire
draw
exclGroup
field
para
subform
Exemples
JavaScript
TextField1.para.hAlign = "right";
FormCalc
TextField1.para.hAlign = "right"


hand

Décrit la justification d'une ligne ou d'un bord.
Syntaxe
Reference_Syntax.hand = "even | left | right"
Valeurs

Type

Valeurs
Chaîne
      •
      even (par défaut)
Centre la ligne affichée sur le vecteur ou l'arc sous-jacent.
      •
      left
Positionne la ligne affichée juste à gauche du vecteur ou de l'arc sous-jacent, lorsque la trajectoire de la ligne est suivie du début à la fin.
      •
      right
Positionne la ligne affichée juste à droite du vecteur ou de l'arc sous-jacent, lorsque la trajectoire de la ligne est suivie du début à la fin.
Application

Modèle

Objet
Modèle de formulaire
arc
border
line
rectangle
Exemples
JavaScript
Line1.resolveNode("value.#line").hand = "left";
FormCalc
Line1.value.#line.hand = "left"


highlight

Indique l'aspect visuel d'un bouton lorsque celui-ci est activé par un utilisateur. Toutes les valeurs prennent en charge deux états (relâché et enfoncé) à l'exception de push qui prend en charge trois états (relâché, enfoncé et effleuré).
Syntaxe
Reference_Syntax.highlight="none | inverted | push | outline"
Valeurs

Type

Valeurs
Chaîne
      •
      push (par défaut)
      •
      none
      •
      inverted
      •
      outline
pour les boutons définis sur le mode de mise en surbrillance « enfoncée », il est possible d'attribuer différentes légendes aux autres états de bouton (enfoncé et survol).
Application

Modèle

Objet
Modèle de formulaire
button
Exemples
JavaScript
Button1.resolveNode("ui.#button").highlight = "push";
FormCalc
Button1.ui.#button.highlight = "push"


href

Indique une référence à un fichier ou à une ressource externe.
La propriété transferEncoding ne s'applique pas aux images externes.
Syntaxe
Reference_Syntax.href = "URL"
Valeurs

Type

Valeurs
Chaîne
Référence HTML valable. Par exemple :
      •
      http://www.adobe.com/data
      •
      ftp://255.255.0.0/dataFiles
Application

Modèle

Objet
Modèle de formulaire
exData
image
Exemples
JavaScript
ImageField1.resolveNode("value.#image").href = "E:\dev\Logos\adobe.jpg";
FormCalc
ImageField1.value.#image.href = "E:\dev\Logos\adobe.jpg"


hScrollPolicy

Indique si un champ peut défiler horizontalement.
cette propriété ne s'applique pas aux champs de texte pouvant être ajustés pour contenir des données ou du texte.
Syntaxe
Reference_Syntax.hScrollPolicy = "auto | on | off"
Valeurs

Type

Valeurs
Chaîne
      •
      auto (par défaut)
Les champs ne contenant qu'une seule ligne défilent horizontalement et les champs à plusieurs lignes défilent verticalement (une barre de défilement verticale s'affiche si besoin est).
      •
      on
Les barres de défilement verticales et/ou horizontales s'affichent, même si le texte ou les données dépassent la limite de débordement du champ.
      •
      off
Empêche l'utilisateur de saisir des caractères lorsque la capacité physique du champ est atteinte (délimitée par la largeur de champ). Notez que cette restriction ne s'applique pas aux données de champ.
Application

Modèle

Objet
Modèle de formulaire
dateTimeEdit
Exemples
JavaScript
TextField1.resolveNode("ui.#textEdit").hScrollPolicy = "off";
FormCalc
TextField1.ui.#textEdit.hScrollPolicy = "off"


id

Spécifie un type d'ID XML générique défini par l'utilisateur.
Syntaxe
Reference_Syntax.id = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant une identification XML définie par l'utilisateur.
Application
Classe de node
Exemples
Dans ces exemples, CurrentPageNumber est un champ flottant. Il s'agit d'un type d'objet doté d'une identification.


imagingBBox

Spécifie une région sur le support où le rendu peut être effectué à l'aide de quatre mesures séparées par des virgules correspondant aux axes x et y, à la largeur et à la hauteur.
Syntaxe
Reference_Syntax.bind = "none | x, y, width, height"
Valeurs

Type

Valeurs
Chaîne
      •
      none (par défaut)
Un rendu peut être effectué sur toute la surface du papier.
      •
      x, y, width, height
Le contenu du sous-formulaire ne peut pas être modifié par l'utilisateur. Un agent utilisateur doit comprendre que le sous-formulaire n'est qu'un conteneur temporaire lors des opérations de séquencement ; vous ne devez pas être autorisé à modifier le contenu de ce sous-formulaire. Le contenu du sous-formulaire peut toutefois être modifié indirectement, par exemple à l'aide d'opérations et de calculs de script.
Application

Modèle

Objet
Modèle de formulaire
medium
Exemples
JavaScript
xfa.form.form1.pageSet.Page1.medium = "100, 100, 50, 50";
FormCalc
xfa.form.form1.pageSet.Page1.medium = "100, 100, 50, 50"


index

Renvoie la position du nœud dans sa collection de nœuds de même nom et compris dans la plage indiquée.
Si le nœud est dépourvu de nom, la position dans sa collection de même classe est renvoyée.
Syntaxe
Reference_Syntax.index = "integer"
Valeurs

Type

Valeurs
Entier
Un entier représentant la position de l'index sur la base de 0 de l'objet actif par rapport aux objets du même nom compris dans une même plage.
Application
Classe de tree
Exemples
JavaScript
Subform1.parent.index;
FormCalc
Subform1.parent.index


initial

Indique le nombre initial d'occurrences du conteneur qui englobe.
Syntaxe
Reference_Syntax.initial = "1 | string"
Valeurs

Type

Valeurs
Chaîne
      •
      1 (par défaut)
      •
      Chaîne valable représentant n'importe quel entier correct.
Application

Modèle

Objet
Modèle de formulaire
occur
Exemples
La modification de l'objet occur lors de l'événement form:ready survient trop tard dans le cycle de vie du formulaire. Cet objet doit être modifié au niveau de l'événement template:ready. Cependant, l'événement template:ready n'est pas accessible dans l'interface utilisateur.
JavaScript
Subform1.occur.initial = "3";
FormCalc
Subform1.occur.initial = "3"


initialNumber

Fournit le numéro de page d'origine à la première occurrence consécutive de la page, s'il s'agit d'une zone de page numérotée.
Syntaxe
Reference_Syntax.initialNumber = "1 | string"
Valeurs

Type

Valeurs
Chaîne
      •
      1 (par défaut)
      •
      Chaîne valable représentant n'importe quelle entier.
Application

Modèle

Objet
Modèle de formulaire
pageArea
Exemples
JavaScript
xfa.form.form1.pageSet.Page1.initialNumber = "4";
FormCalc
xfa.form.form1.pageSet.Page1.initialNumber = "4"


input

Spécifie un message d'entrée associé à une opération de connexion WSDL particulière.
Syntaxe
Reference_Syntax.input = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant un message d'entrée.
Application

Modèle

Objet
Modèle connectionSet
operation


intact

Spécifie les contraintes liées au maintien d'un sous-formulaire dans un état intact dans une zone de contenu ou une page.
Syntaxe
Reference_Syntax.intact = "none | contentArea | pageArea"
Valeurs

Type

Valeurs
Chaîne
      •
      none (par défaut)
C'est l'application de traitement qui détermine si un sous-formulaire sera rendu intact dans une zone de contenu ou une page. Le sous-formulaire peut être divisé dans une zone de contenu ou une page. Il s'agit de la valeur par défaut lorsque la disposition du conteneur parent est tb, lr-tb ou table.
      •
      contentArea
Le sous-formulaire doit obligatoirement être rendu intact au sein d'une zone de contenu. Il s'agit de la valeur par défaut lorsque la disposition du conteneur parent est position ou row.
      •
      pageArea
Le sous-formulaire doit obligatoirement être rendu intact au sein d'une page.
il n’existe pas de valeur unique par défaut pour cette propriété. Elle est de type contextuel. Lorsque la disposition du conteneur parent est tb, lr-tb ou table, la valeur par défaut est none. Lorsque la disposition du conteneur parent est position ou row, la valeur par défaut est contentArea. La valeur par défaut est calculée lorsque l'appel de l'interface API est effectué pour obtenir la valeur, ou lorsque l'opération de disposition est appelée.
Application

Modèle

Objet
Modèle de formulaire
keep
Exemples
JavaScript
Subform1.keep.intact = "pageArea";
FormCalc
Subform1.keep.intact = "pageArea"


inverted

Indique si un coin est convexe (les bords sont joints selon la tangente) ou s'il est inversé et prend une forme concave (les bords sont joints à angle droit).
Syntaxe
Reference_Syntax.inverted = "0 | 1"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
Le coin est convexe.
      •
      1
Le coin est concave.
Application

Modèle

Objet
Modèle de formulaire
corner
Exemples
JavaScript
TextField1.border.corner.inverted = "1";
FormCalc
TextField1.border.corner.inverted = "1"


isContainer

Indique si l'objet est un objet conteneur.
cette propriété est en lecture seule.
Syntaxe
Reference_Syntax.isContainer = "True | False"
Valeurs

Type

Valeurs
Booléen
      •
      True (par défaut)
L'objet est un type d'objet conteneur.
      •
      False
L'objet n'est pas un type d'objet conteneur.
Application
Classe de node
Exemples
JavaScript
TextField1.isContainer;
FormCalc
TextField1.isContainer


isDefined

Indique si une fenêtre de données valide est actuellement définie.
Une fenêtre de données peut être considérée comme valide si l'index d'enregistrement actif indique un enregistrement dans les données. Une fenêtre de données n'est pas définie s'il n'existe aucun enregistrement ou si l'index d'enregistrement actif s'étend au-delà de la limite de la plage des enregistrements.
cette propriété est en lecture seule.
Syntaxe
Reference_Syntax.isDefined = "True | False"
Valeurs

Type

Valeurs
Booléen
      •
      True (par défaut)
La fenêtre de données actuelle est définie.
      •
      False
La fenêtre de données actuelle n'est pas définie.
Application

Modèle

Objet
Modèle de données
dataWindow
Exemples
JavaScript
xfa.dataWindow.isDefined;
FormCalc
$dataWindow.isDefined


isNull

Indique si la valeur de données actuelle est la valeur nulle.
Syntaxe
Reference_Syntax.isNull = "True | False"
Valeurs

Type

Valeurs
Booléen
      •
      True (par défaut)
La valeur de données actuelle est la valeur nulle.
      •
      False
La fenêtre de données actuelle n'est pas la valeur nulle.
Application
Classe de node

Modèle

Objet
Modèle de données
dataValue
Exemples
JavaScript
TextField1.isNull = "False";
FormCalc
TextField1.isNull = "False"


join

Indique la forme d’un coin.
Syntaxe
Reference_Syntax.join = "square | round"
Valeurs

Type

Valeurs
Chaîne
      •
      square (par défaut)
Le coin joignant les bords a la forme d'un angle droit.
      •
      round
Le coin joignant les bords a la forme d'une courbe arrondie.
Application

Modèle

Objet
Modèle de formulaire
corner
Exemples
JavaScript
TextField1.border.corner.join = "round";
FormCalc
TextField1.border.corner.join = "round"


keyAgreement

Indique une extension d'utilisation des clés acceptable devant être présente dans le certificat de signature.
Syntaxe
Reference_Syntax.keyAgreement = "Yes | No | empty_string"
Valeurs

Type

Valeurs
Chaîne
•
Yes (par défaut)
La valeur doit être définie dans le certificat pour pouvoir être acceptée.
•
No
La valeur ne doit pas être définie dans le certificat pour pouvoir être acceptée.
•
""
S'il est spécifié ou non spécifié comme chaîne vide, l'attribut du certificat n'est pas pris en compte.
Application

Modèle

Objet
Modèle de formulaire
keyUsage


keyCertSign

Indique une extension d'utilisation des clés acceptable devant être présente dans le certificat de signature.
Syntaxe
Reference_Syntax.keyCertSign = "Yes | No | empty_string"
Valeurs

Type

Valeurs
Chaîne
•
Yes (par défaut)
La valeur doit être définie dans le certificat pour pouvoir être acceptée.
•
No
La valeur ne doit pas être définie dans le certificat pour pouvoir être acceptée.
•
""
S'il est spécifié ou non spécifié comme chaîne vide, l'attribut du certificat n'est pas pris en compte.
Application

Modèle

Objet
Modèle de formulaire
keyUsage


keyDown

Détermine si un utilisateur appuie sur une touche fléchée pour effectuer une sélection. Cette propriété est uniquement disponible pour les zones de liste et les listes déroulantes.
Syntaxe
Reference_Syntax.keyDown = "True | False"
Valeurs

Type

Valeurs
Chaîne
      •
      True (par défaut)
Sélection effectuée à l'aide d'une touche fléchée
      •
      False
Sélection effectuée sans utiliser de touche fléchée
Application

Modèle

Objet
Modèle d'événement
eventPseudoModel
Exemples
JavaScript
xfa.event.keyDown;
FormCalc
xfa.event.keyDown


keyEncipherment

Indique une extension d'utilisation des clés acceptable devant être présente dans le certificat de signature.
Syntaxe
Reference_Syntax.keyEnciphement = "Yes | No | empty_string"
Valeurs

Type

Valeurs
Chaîne
•
Yes (par défaut)
La valeur doit être définie dans le certificat pour pouvoir être acceptée.
•
No
La valeur ne doit pas être définie dans le certificat pour pouvoir être acceptée.
•
""
S'il est spécifié ou non spécifié comme chaîne vide, l'attribut du certificat n'est pas pris en compte.
Application

Modèle

Objet
Modèle de formulaire
keyUsage


labelRef

Renvoie une valeur de données pour chaque noeud de données dans le jeu identifié par l'objet ref.
Les valeurs de données sont ensuite utilisées pour remplir les éléments de libellé, tels que <items save='0'>.
La propriété labelRef est une expression de syntaxe de référence relative.
La propriété labelRef est facultative. Vous pouvez définir une liste en n'utilisant qu'un jeu de valeurs sans libellé. Le cas échéant, l'objet rendu utilise des libellés qui prennent par défaut les valeurs actuelles.
Syntaxe
Reference_Syntax.labelRef = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne représentant une valeur de données pour chaque noeud du jeu.
Application

Modèle

Objet
Modèle de formulaire
bindItems


language

Renvoie la langue de l'application hôte en cours d'exécution.
Syntaxe
Reference_Syntax.language
Valeurs

Type

Valeurs
Chaîne
Chaîne valable représentant la langue de la version de l'ordinateur hôte.
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.language;
FormCalc
xfa.host.language


layout

Indique la stratégie de disposition utilisée par cet objet.
Syntaxe
Reference_Syntax.layout = "position | lr-tb | rl-tb | row | table | tb"
Valeurs

Type

Valeurs
Chaîne
      •
      position (par défaut)
Le contenu de la commande est positionné en fonction des informations sur l'emplacement exprimées sur les objets de contenu.
      •
      lr-tb
Le contenu de l'objet est réparti de gauche à droite et de haut en bas.
      •
      rl-tb
Réservé en vue d'une utilisation ultérieure. Le contenu de l'objet est réparti de droite à gauche et de haut en bas.
      •
      row
Il s'agit de l'objet intérieur d'un tableau qui représente une ou plusieurs rangées. Les objets contenus dans cet objet sont les cellules du tableau, et leurs hauteur et largeur ne sont pas prises en compte (le cas échéant). Les cellules sont disposées de droite à gauche et chacune d'elles est ajustée à la hauteur de la rangée et à la largeur d'une ou de plusieurs colonnes consécutives.
      •
      table
Il s'agit de l'objet extérieur d'un tableau. Les propriétés de disposition de chacun de ses sous-formulaires enfant ou groupes d'exclusion doivent être définies sur la rangée. Les rangées du tableau sont disposées de haut en bas.
      •
      tb
Le contenu de l'objet est réparti de haut en bas.
Application

Modèle

Objet
Modèle de formulaire
exclGroup
subform
Exemples
JavaScript
Subform1.layout = "tb";
FormCalc
Subform1.layout = "tb"


leadDigits

Indique le nombre maximum de chiffres (inclusifs) précédant la décimale à capturer et à stocker.
Syntaxe
Reference_Syntax.leadDigits = "0 | integer"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
      •
      Chaîne valable représentant n'importe quelle valeur entière.
Application

Modèle

Objet
Modèle de formulaire
decimal
Exemples
Pour ces exemples, le type des données du champ numérique devrait être décimal.
JavaScript
NumericField1.resolveNode("value.#decimal").leadDigits = "2";
FormCalc
NumericField1.value.#decimal.leadDigits = "2"


leader

Indique l'objet subform ou subformSet devant être placé en haut d'une zone de contenu ou d'une zone de page.
La propriété leader remplace les propriétés overflowLeader et bookendLeader désapprouvées.
Syntaxe
Reference_Syntax.leader = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant l'ID ou l'expression de syntaxe de référence complète d'un sous-formulaire ou d'un jeu de sous-formulaires. La valeur par défaut est une chaîne vide.
Application

Modèle

Objet
Modèle de formulaire
bookend
breakAfter
breakBefore
overflow
Exemples
JavaScript
Subform1.leader = "xfa.form.form1.Subform2";
FormCalc
Subform1.leader = "xfa.form.form1.Subform2"


leftInset

Indique la taille d’une insertion à gauche.
Syntaxe
Reference_Syntax.leftInset = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
margin
Exemples
JavaScript
Subform1.margin.leftInset = "0.25in";
FormCalc
Subform1.margin.leftInset = "0.25in"


length

Indique le nombre d'objets dans la liste.
cette propriété est en lecture seule.
Syntaxe
Reference_Syntax.length
Valeurs

Type

Valeurs
Entier
Entier valide représentant le nombre d'objets.
Application
Classe de treeList
Exemples
JavaScript
// Display the number of child nodes under root node.
xfa.host.messageBox("Number of nodes under rootNode after appending clone: " + xfa.record.nodes.length);
FormCalc
// Display the number of child nodes under root node.
xfa.host.messageBox("Number of nodes under rootNode after appending clone: " + xfa.record.nodes.length)


lineHeight

Indique la hauteur de ligne à appliquer au contenu d’un paragraphe.
Lorsque cette propriété est omise ou configurée comme chaîne vide, la taille de la police détermine la hauteur de la ligne.
Syntaxe
Reference_Syntax.lineHeight = "0pt | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0pt (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
para
Exemples
JavaScript
TextField1.para.lineHeight = "20pt";
FormCalc
TextField1.para.lineHeight = "20pt"


lineThrough

Indique l'activation d'une ligne simple ou double traversant le texte (propriété également connue sous le nom de texte barré).
Syntaxe
Reference_Syntax.lineThrough = "0 | 1 | 2"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
La police est générée sans que le texte ne soit barré.
      •
      1
La police est générée et le texte est barré d'une ligne simple.
      •
      2
La police est générée et le texte est barré d'une ligne double.
Application

Modèle

Objet
Modèle de formulaire
font
Exemples
JavaScript
TextField1.font.lineThrough = "2";
FormCalc
TextField1.font.lineThrough = "2"


lineThroughPeriod

Contrôle l'aspect de la ligne sur le texte (propriété également connue sous le nom de Barré).
Syntaxe
Reference_Syntax.lineThroughPeriod = "all | word"
Valeurs

Type

Valeurs
Chaîne
      •
      all (par défaut)
La ligne rendue doit s'étendre aux sauts de mots.
      •
      word
La ligne rendue doit être interrompue aux sauts de mots.
Application

Modèle

Objet
Modèle de formulaire
font
Exemples
JavaScript
TextField1.font.lineThroughPeriod = "word";
FormCalc
TextField1.font.lineThroughPeriod = "word"


locale

Indique la langue, la monnaie et le format des date/heure à utiliser pour le contenu de l'objet.
Les paramètres régionaux affectent la représentation des données mises en forme, validées ou normalisées par des clauses d'image. Lorsque cette propriété est absente ou vide, le comportement par défaut est d'hériter des paramètres régionaux de l'objet parent. Si le sous-formulaire extérieur ne spécifie pas de paramètres régionaux, le comportement par défaut est déduit des paramètres régionaux du système d'exploitation. La valeur en_US est utilisée si aucun paramètre local n'est fourni par le système d'exploitation.
Syntaxe
Reference_Syntax.locale = "ambient | locale"
Valeurs

Type

Valeurs
Chaîne
      •
      ambient (par défaut)
L'application utilise les paramètres régionaux propres à l'environnement.
      •
      Nom de paramètres régionaux valable, par exemple en_US. Pour obtenir la liste complète des valeurs de paramètres régionaux valables, référez-vous aux spécifications IETF RFC 1766 et ISO 639/ISO 3166.
Application

Modèle

Objet
Modèle de formulaire
draw
field
subform
Exemples
JavaScript
TextField1.locale = "en_US";
FormCalc
TextField1.locale = "en_US"


lockType

Indique le type de fonction de verrouillage à utiliser avec la source de données.
Syntaxe
Reference_Syntax.lockType = "unspecified | readOnly | pessimistic | optimistic | batchOptimistic"
Valeurs

Type

Valeurs
Chaîne
      •
      unspecified (par défaut)
Aucun type de verrouillage n’est précisé.
      •
      readOnly
Indique que les enregistrements sont en lecture seule. Les données ne peuvent pas être modifiées.
      •
      pessimistic
Les enregistrements sont verrouillés à la source de données immédiatement après la modification.
      •
      optimistic
Les enregistrements sont verrouillées uniquement lorsqu'une mise à jour des données sollicitée par l'utilisateur se produit.
      •
      batchOptimistic
Indique des mises à jour optimistes par lots. Ceci est obligatoire pour le mode de mise à jour par lots.
Application

Modèle

Objet
Modèle sourceSet
recordSet
Exemples
Dans ces exemples, Titles désigne le nom de la connexion aux données.
JavaScript
xfa.sourceSet.Titles.nodes.item(1).query.recordSet.lockType = "optimistic";
FormCalc
xfa.sourceSet.Titles.nodes.item(1).query.recordSet.lockType = "optimistic"


long

Spécifie la longueur du bord long du support. La longueur spécifiée par la propriété long doit être supérieure à celle spécifiée par la propriété short.
Syntaxe
Reference_Syntax.long = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
medium
Exemples
JavaScript
xfa.form.form1.pageSet.Page1.medium.long = "4in";
FormCalc
xfa.form.form1.pageSet.Page1.medium.long = "4in"


mandatory

Indique la valeur nullTest pour le champ.
Syntaxe
Reference_Syntax.mandatory = "string"
Valeurs

Type

Valeurs
Chaîne
Une chaîne qui représente la valeur nullTest.
Application

Modèle

Objet
Modèle de formulaire
exclGroup
field
Exemples
JavaScript
Textfield1.mandatory = "error";
FormCalc
TextField1.mandatory = "error"


mandatoryMessage

Indique la chaîne de message obligatoire pour ce champ.
Syntaxe
Reference_Syntax.mandatoryMessage = "string"
Valeurs

Type

Valeurs
Chaîne
Une chaîne qui représente un message obligatoire.
Application

Modèle

Objet
Modèle de formulaire
exclGroup
field
Exemples
JavaScript
Textfield1.mandatoryMessage = "This field is required.";
FormCalc
TextField1.mandatoryMessage = "This field is required."


marginLeft

Indique la taille du retrait d’un paragraphe à gauche.
Syntaxe
Reference_Syntax.marginLeft = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
para
Exemples
JavaScript
TextField1.para.marginLeft = "0.5in";
FormCalc
TextField1.para.marginLeft = "0.5in"


marginRight

Indique la taille du retrait d’un paragraphe à droite.
Syntaxe
Reference_Syntax.marginRight = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
para
Exemples
JavaScript
TextField1.para.marginRight = "0.5in";
FormCalc
TextField1.para.marginRight = "0.5in"


mark

Indique la forme à utiliser lors du remplissage d'un objet de case à cocher.
Syntaxe
Reference_Syntax.mark = "default | check | circle | cross | diamond | square | star"
Valeurs

Type

Valeurs
Chaîne
      •
      default (par défaut)
Les repères par défaut varient selon la forme de l'objet de case à cocher. Une diagonale pour le carré et un cercle plein pour le cercle. Les nouveaux repères sont des symboles basés sur des polices.
      •
      check
      •
      circle
      •
      cross
      •
      diamond
      •
      square
      •
      star
Application

Modèle

Objet
Modèle de formulaire
checkButton
Exemples
JavaScript
CheckBox1.resolveNode("ui.#checkButton").mark = "diamond";
FormCalc
CheckBox1.ui.#checkButton.mark = "diamond"


match

Contrôle le rôle de l'objet encadré lors d'une opération de liaison de données (fusion).
Syntaxe
Reference_Syntax.mark = "once | none | global | dataref"
Valeurs

Type

Valeurs
Chaîne
      •
      once (par défaut)
Le noeud représentant l'objet encadré est lié à l'un des noeuds du modèle de données conformément aux règles de correspondance standard.
      •
      none
Le noeud représentant l'objet encadré est transitoire. Il ne sera pas lié à un noeud du modèle de données.
      •
      global
Le champ compris est global. Si les règles de correspondance normales ne permettent pas de trouver de correspondance, le processus de liaison de données recherche les données à lier au champ en dehors de l'enregistrement actif.
      •
      dataRef
Le champ compris se lie au noeud du modèle de données spécifié par la propriété ref connexe.
Application

Modèle

Objet
Modèle de formulaire
bind
Modèle sourceSet
bind
Exemples
Il est recommandé de définir la propriété globale d'un champ avant de procéder à la fusion.
JavaScript
TextField1.bind.match = "global";
FormCalc
TextField1.bind.match = "global"


max

Indique le nombre maximal d'occurrences pour le conteneur qui englobe ou -1 pour ne définir aucune limite supérieure pour les occurrences.
La propriété max prend par défaut la valeur de la propriété min. Si la min n'est pas définie, la valeur par défaut correspond à 1.
Syntaxe
Reference_Syntax.max = "1 | -1 | integer"
Valeurs

Type

Valeurs
Chaîne
      •
      1 (par défaut)
      •
      -1
Aucune limite supérieure n'est définie.
      •
      Tout entier valable.
Application

Modèle

Objet
Modèle de formulaire
instanceManager
occur
Modèle sourceSet
recordSet
Exemples
JavaScript
Subform1.occur.max = "3";
FormCalc
Subform1.occur.max = "3"


maxChars

Indique le nombre maximal de caractères que cette valeur de texte peut englober.
Syntaxe
Reference_Syntax.maxChars = "0 | integer"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
      •
      Tout nombre entier valide.
si aucune valeur n’est définie ou si la propriété est configurée comme une chaîne vide, il n’y a pas de limite.


maxH

Indique la hauteur maximale à des fins de disposition.
Si aucune valeur n'est définie pour cette propriété, cela signifie qu'aucune limite supérieure n'est définie. Dans le cas où la valeur de la propriété h est définie, la taille du conteneur ne peut pas augmenter verticalement et cette propriété n'est pas prise en compte.
Syntaxe
Reference_Syntax.maxH = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Exemples
JavaScript
TextField1.maxH = "3in";
FormCalc
TextField1.maxH = "3in"


maxLength

Spécifie la longueur de contenu maximale autorisée (incluse) ou -1 pour indiquer qu'aucune longueur maximale n'est imposée.
L'interprétation de cette propriété dépend du type de contenu. Dans ce cas, cette propriété spécifie la longueur de contenu maximale autorisée (incluse) dans les caractères. Par exemple, si le type de contenu est text/plain, cette propriété représente le nombre maximal de caractères contenus dans le texte brut. De la même manière, si le type de contenu est text/html, cette propriété représente le nombre maximal de caractères du contenu, à l'exception des annotations et des espaces blancs insignifiants.
Syntaxe
Reference_Syntax.maxLength = "-1 | integer"
Valeurs

Type

Valeurs
Chaîne
      •
      -1 (par défaut)
      •
      Tout nombre entier valide.
Application

Modèle

Objet
Modèle de formulaire
exData


maxW

Indique la largeur maximale à des fins de disposition.
Si aucune valeur n'est définie pour cette propriété, cela signifie qu'aucune valeur maximale n'existe. Dans le cas où la valeur de la propriété w est définie, la taille du conteneur ne peut pas augmenter horizontalement et cette propriété n'est pas prise en compte.
Syntaxe
Reference_Syntax.maxW = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
draw
exclGroup
field
subform
Exemples
JavaScript
TextField1.maxW = "3in";
FormCalc
TextField1.maxW = "3in"


min

Indique le nombre minimal d'occurrences du conteneur qui englobe.
Syntaxe
Reference_Syntax.min = "1 | integer"
Valeurs

Type

Valeurs
Chaîne
      •
      1 (par défaut)
      •
      Tout entier valable.
Application

Modèle

Objet
Modèle de formulaire
instanceManager
occur
Exemples
JavaScript
Subform1.occur.min = "0";
FormCalc
Subform1.occur.min = "0"


minH

Indique la hauteur maximale à des fins de disposition.
Dans le cas où la valeur de la propriété h est fournie, la taille du conteneur ne peut pas augmenter verticalement et cette propriété n'est pas prise en compte.
Syntaxe
Reference_Syntax.minH = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
draw
exclGroup
field
subform
Exemples
JavaScript
TextField1.minH = "0.5in";
FormCalc
TextField1.minH = "0.5in"


minW

Indique la largeur maximale à des fins de disposition.
Dans le cas où la valeur de la propriété w est fournie, la taille du conteneur ne peut pas augmenter horizontalement et cette propriété n'est pas prise en compte.
Syntaxe
Reference_Syntax.minW = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Exemples
JavaScript
TextField1.minW = "0.5in";
FormCalc
TextField1.minW = "0.5in"


model

Indique le modèle de l'objet actuel.
cette propriété est en lecture seule.
Syntaxe
Reference_Syntax.model
Valeurs

Type

Valeurs
Objet
L'objet racine pour le modèle d'objets du formulaire XML, tel que connectionSet ou dataModel.
Application
Classe de node
Exemples
JavaScript
xfa.model.name;
FormCalc
xfa.model.name


modifier

Détermine l'utilisation de la touche de modification (par exemple, Ctrl sous Windows) lors de l'exécution d'un événement particulier.
Syntaxe
Reference_Syntax.modifier
Valeurs

Type

Valeurs
Booléen
      •
      True (par défaut)
Touche de modification enfoncée pendant l'exécution d'un événement.
      •
      False
Touche de modification relâchée pendant l'exécution d'un événement.
Application

Modèle

Objet
Modèle d'événement
eventPseudoModel
Exemples
JavaScript
xfa.event.modifier;
FormCalc
xfa.event.modifier


moduleHeight

Détermine la hauteur d'une série de barres utilisées pour encoder un caractère de texte fourni.
La gamme de hauteurs autorisée dépend des formats de codes à barres. Le modèle de formulaire ne doit pas spécifier de hauteur dépassant la plage autorisée.
Syntaxe
Reference_Syntax.moduleHeight = "5mm | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      5mm (valeur par défaut pour les codes à barres 2D)
      •
      Toute mesure valable.
Lorsque cette propriété n'est pas fournie, le comportement par défaut dépend du type de code à barres. Les codes à barres unidimensionnels atteignent la hauteur d'un champ englobant, limitée par la plage de hauteur autorisée. Les codes à barres 2D prennent par défaut une hauteur de module égale à 5mm.
Application

Modèle

Objet
Modèle de formulaire
barcode
Exemples
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").moduleHeight = "5mm";
FormCalc
Code11BarCode1.ui.#barcode.moduleHeight = "5mm"


moduleWidth

Spécifie différents aspects d'un code à barres en fonction de la classe de codes à barres utilisée.
Pour les codes à barres unidimensionnels, l'analyseur utilise la valeur de cette propriété pour définir la largeur des barres les plus étroites. La largeur des barres les plus larges est calculée en fonction de celle des barres les plus étroites. La gamme de largeurs autorisée dépend des formats de codes à barres. Le modèle de formulaire ne doit pas spécifier de valeur dépassant la plage autorisée. Si la propriété moduleWidth est fournie, la propriété dataLength n'est pas prise en compte. A l'inverse, la propriété moduleWidth n'a pas de valeur par défaut. Ainsi, si la propriété dataLength n'est pas fournie, moduleWidth doit être fournie.
Pour les codes à barres matériels 2D, la propriété moduleWidth n'a aucun effet ou produit le même effet que les codes à barres logiciels, en fonction du type d'imprimante et de code à barres. La plage de valeurs autorisée dépend des imprimantes et des codes à barres.
Pour les codes à barres 2D, la valeur de cette propriété détermine la largeur de module. Un module est une série de barres encodant un symbole. En général, un symbole correspond à un caractère de données fournies. La gamme de largeurs autorisée dépend des formats de codes à barres. Le modèle de formulaire ne doit pas spécifier de valeur dépassant la plage autorisée.
Syntaxe
Reference_Syntax.moduleWidth = "0.25mm | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0.25mm (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
barcode
Exemples
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").moduleWidth = "25mm";
FormCalc
Code11BarCode1.ui.#barcode.moduleHeight = "25mm"


multiLine

Indique si le texte peut couvrir plusieurs lignes.
La propriété multiLine s'avère utile si les clients, tels que les navigateurs HTML, possèdent deux types d'interfaces pour modifier le texte.
Syntaxe
Reference_Syntax.multiLine = "1 | 0"
Valeurs

Type

Valeurs
Chaîne
      •
      1 (par défaut)
Le texte peut couvrir plusieurs lignes.
      •
      0
Le texte est limité à une seule ligne.
Exemples
JavaScript
TextField1.resolveNode("ui.#textEdit").multiLine = "0";
FormCalc
TextField1.ui.#textEdit.multiLine = "0"


name

Identificateur qui permet de désigner un objet ou un événement dans les expressions de script.
Par exemple, cette propriété définit le nom de l'application hôte et, sur un formulaire PDF interactif, elle renvoie Acrobat.
Syntaxe
Reference_Syntax.name
Valeurs

Type

Valeurs
Chaîne
Chaîne pouvant comprendre jusqu'à 255 caractères.
Application
Classe de tree
Exemples
JavaScript
xfa.host.name;
FormCalc
xfa.host.name


newContentType

Indique le type de contenu de la propriété newText.
Par exemple, si newContentType='text/html', newText contiendra un fragment XHTML.
Syntaxe
Reference_Syntax.newContentType = "allowRichText | plainTextOnly"
Valeurs

Type

Valeurs
Chaîne
      •
      allowRichText (par défaut)
Le champ prend en charge le texte enrichi.
      •
      plainTextOnly
Le champ ne prend pas en charge le texte enrichi. Même en présence d'annotations, il vaut mieux transmettre les données que les interpréter. Il n'est toutefois pas garanti que le traitement en aval répondra aux annotations.
Application

Modèle

Objet
Modèle d'événement
eventPseudoModel
Exemples
JavaScript
xfa.event.newContentType = "plainTextOnly";
FormCalc
xfa.event.newContentType = "plainTextOnly"


newText

Indique le contenu du champ une fois qu'il a été modifié suite aux actions de l'utilisateur.
Syntaxe
Reference_Syntax.newtext = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne pouvant comprendre jusqu'à 255 caractères.
Application

Modèle

Objet
Modèle d'événement
eventPseudoModel
Exemples
JavaScript
TextField2.rawValue = xfa.event.newTextl;
FormCalc
TextField2 = xfa.event.newText


next

Indique les contraintes relatives au maintien d'un sous-formulaire avec le sous-formulaire suivant au sein d'une zone de contenu ou d'une page.
Syntaxe
Reference_Syntax.next = "none | contentArea | pageArea"
Valeurs

Type

Valeurs
Chaîne
      •
      none (par défaut)
Il incombe à l'application de traitement de déterminer si un sous-formulaire est généré dans la même zone de contenu ou sur la même page que le sous-formulaire suivant. Aucune contrainte de maintien particulière ne sera imposée.
      •
      contentArea
Le sous-formulaire doit obligatoirement être généré dans la même zone de contenu que celui qui le suit.
      •
      pageArea
Le sous-formulaire doit obligatoirement être généré sur la même page que celui qui le suit.
Application

Modèle

Objet
Modèle de formulaire
keep
Exemples
JavaScript
Subform1.keep.next = "contentArea";
FormCalc
Subform1.keep.next = "contentArea"


nodes

Renvoie une liste de tous les objets enfant de l'objet actuel.
cette propriété est en lecture seule.
Syntaxe
Reference_Syntax.nodes
Valeurs

Type

Valeurs
Objet
Une liste de tous les objets Modèle d'objet de formulaire XML.
Application
Classe de tree
Exemples
JavaScript
Subform1.nodes; // Single line example

// This example displays the names of the children of Subform1
var oNodes = this.nodes;
var nodesLength = oNodes.length;

for (var i = 0; i < nodesLength; i++) {
    xfa.host.messageBox(oNodes.item(i).name)
}
FormCalc
Subform1.nodes // Single line example

// This example displays the names of the children of Subform1
var oNodes = Subform1.nodes
var nodesLength = oNodes.length;

for (var i = 0; i < nodesLength; i++) {
    xfa.host.messageBox(oNodes.item(i).name)
}


nonRepudiation

Indique une extension d'utilisation des clés acceptable devant être présente dans le certificat de signature.
Syntaxe
Reference_Syntax.nonRepudiation = "Yes | No | empty_string"
Valeurs

Type

Valeurs
Chaîne
•
Yes (par défaut)
La valeur doit être définie dans le certificat pour pouvoir être acceptée.
•
No
La valeur ne doit pas être définie dans le certificat pour pouvoir être acceptée.
•
""
S'il est spécifié ou non spécifié comme chaîne vide, l'attribut du certificat n'est pas pris en compte.
Application

Modèle

Objet
Modèle de formulaire
keyUsage


ns

Renvoie l'espace de nommage pour l'objet.
Si l'objet en question est la racine d'un modèle, cette propriété renvoie l'espace de nommage pour le modèle.
cette propriété est en lecture seule.
Syntaxe
Reference_Syntax.ns
Valeurs

Type

Valeurs
Objet
Une chaîne valide représentant l'espace de nommage de l'objet actuel, ou l'espace de nommage du modèle actuel si l'objet racine est l'objet sélectionné.
Application
Classe de node


nullTest

Détermine si un champ est obligatoire dans un formulaire ou s'il peut être laissé vide.
La propriété nullTest peut être utilisée pour les validations.
Syntaxe
Reference_Syntax.nullTest = "disabled | error | warning"
Valeurs

Type

Valeurs
Chaîne
      •
      disabled (par défaut)
N'effectue pas ce test (par défaut). L'objet de formulaire peut être affecté d'une valeur nulle. Il est possible de laisser le champ sans valeur sans que cela n'affecte la validité du formulaire. Cette valeur désactive le test de validation.
      •
      error
Génère un message d'erreur et refuse de valider un champ vide. L'objet de formulaire doit être affecté d'une valeur non nulle.
      •
      warning
Génère un message d'avertissement lorsque le champ est vide, mais autorise l'utilisateur à passer au champ suivant. Le message doit informer l'utilisateur que l'objet de formulaire doit de préférence être affecté d'une valeur, et propose deux options :
      •
      dismiss: L'utilisateur comprend la recommandation et souhaite revenir au formulaire afin de satisfaire à cette contrainte.
      •
      override: L'utilisateur comprend la recommandation mais choisit de ne pas respecter cette contrainte.
Application

Modèle

Objet
Modèle de formulaire
validate
Exemples
JavaScript
TextField1.validate.nullTest = "error";
FormCalc
TextField1.validate.nullTest = "error"


numbered

Spécifie si la zone de page est assimilée à une zone de page numérotée.
Les zones de pages numérotées contribuent à l'incrémentation normale des numéros de pages, alors que cette dernière est absente des pages sans numéros.
Syntaxe
Reference_Syntax.numbered = "auto | none"
Valeurs

Type

Valeurs
Chaîne
      •
      auto (par défaut)
La zone de page représente une zone de page numérotée. Par conséquent, l'instanciation de la zone de page contribue à l'incrémentation des numéros de la zone de page en cours.
      •
      none
La zone de page ne contribue pas à incrémenter la numérotation de la zone de page en cours.
Application

Modèle

Objet
Modèle de formulaire
pageArea
Exemples
JavaScript
xfa.form.form1.pageSet.Page1.numbered = "none";
FormCalc
xfa.form.form1.pageSet.Page1.numbered = "none"


numberOfCells

Indique le nombre de cellules dessinées pour un champ peigne. Ceci n'est pas affecté par le nombre de caractères dans la valeur du champ.
Syntaxe
Reference_Syntax.numberOfCells = "0 | integer"
Valeurs

Type

Valeurs
Entier
      •
      0 (par défaut)
Une seule cellule est dessinée pour la champ peigne, ou si la propriété maxChars est définie, le nombre de cellules correspond à la valeur de maxChars.
      •
      integer
Entier valide qui représente le nombre total de cellules dessinées pour le champ peigne.
Application

Modèle

Objet
Modèle de formulaire
comb
Exemples
JavaScript
TextField1.resolveNode("ui.#textEdit.comb").numberOfCells = "6";
FormCalc
TextField1.ui.#textEdit.comb.numberOfCells = "6"


numPages

Renvoie le nombre de pages que compte le document actif.
Syntaxe
Reference_Syntax.numPages
Valeurs

Type

Valeurs
Entier
Entier valable représentant le nombre total de pages.
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.numPages;
FormCalc
xfa.host.numPages


oddOrEven

Indique si une page est paire ou impaire pour la pagination d'un jeu de pages.
Syntaxe
Reference_Syntax.oddOrEven = "any | odd | even"
Valeurs

Type

Valeurs
Chaîne
      •
      any (par défaut)
Représente n'importe quelle page dans un document.
      •
      odd
Représente la première page dans un document et toutes les pages consécutives, indépendamment du numérotation de pages.
      •
      even
Représente la deuxième page dans un document et toutes les pages consécutives, indépendamment du numérotation de pages.
Application

Modèle

Objet
Modèle de formulaire
pageArea
Exemples
L'expression de syntaxe de référence varie selon l'objet à partir duquel elle est appelée.
JavaScript
xfa.form.form1.pageSet.Page1.oddOrEven = "even";
FormCalc
xfa.form.form1.pageSet.Page1.oddOrEven = "even"


oneOfChild

Récupère ou définit l'objet enfant dans le cas où un objet parent peut disposer uniquement d'un objet enfant particulier.
Syntaxe
Reference_Syntax.oneOfChild = "object"
Valeurs

Type

Valeurs
Objet
L'objet enfant.
Application
Classe de node
Exemples
JavaScript
TextField1.value.oneOfChild;
FormCalc
TextField1.value.oneOfChild


open

Détermine le moment où la liste à choix multiples est présentée par les applications interactives.
Syntaxe
Reference_Syntax.open = "userControl | onEntry | always | multiSelect"
Valeurs

Type

Valeurs
Chaîne
      •
      userControl (par défaut)
La liste se déroule lorsque l'utilisateur clique sur un bouton ou effectue le mouvement de souris approprié. Elle disparaît lorsque le curseur la quitte ou qu'un événement d'interface approprié survient.
      •
      onEntry
La liste se déroule pour la saisie dans le champ. Elle disparaît lorsque le curseur quitte le champ.
      •
      always
La liste s'affiche lorsque le champ est visible.
      •
      multiSelect
L'utilisateur peut sélectionner plusieurs entrées dans la liste en appuyant sur la touche Maj lorsqu'il effectue sa sélection. La liste de choix multiples s'affiche lorsque le champ est visible.
Application

Modèle

Objet
Modèle de formulaire
choiceList
Exemples
JavaScript
DropDownList1.resolveNode("ui.#choiceList").open = "always";
FormCalc
DropDownList1.ui.#choiceList.open = "always"


operation

Détermine à quel moment un lien a été utilisé.
Syntaxe
Reference_Syntax.operation = "next | back | down | first | left | right | up"
Valeurs

Type

Valeurs
Chaîne
      •
      next (par défaut)
Activée lorsque l'utilisateur appuie sur la touche de tabulation ou saisit le dernier caractère dans un champ à largeur fixe. Toutefois, la même chaîne de liens est également parcourue par le lecteur d'écran pendant la lecture du formulaire. Par défaut, lit de gauche à droite et de haut en bas
pour faciliter la lecture de l'écran, la chaîne de liens suivants peut inclure des objets standard. De tels objets ne peuvent pas accepte de cible d'action. C'est pourquoi, lorsque la cible se déplace vers l'objet de formulaire suivant, la tabulation se poursuit jusqu'au premier objet n'acceptant pas la cible d'action. Il incombe au créateur du formulaire de s'assurer que, par sa conception, le formulaire ne génère pas de boucle sans fin.
      •
      back
Activé lorsque l'utilisateur appuie sur Maj+Tab. Par défaut, lit de droite à gauche et de bas en haut.
      •
      down
Destination lorsque l'utilisateur appuie sur la touche fléchée Bas. Par défaut, lit de haut en bas.
      •
      first
Cette propriété n'est utilisée que lorsque le conteneur est un sous-formulaire ou un jeu de sous-formulaires. Le lien pointe vers l'objet atteignant la cible d'action lorsque le conteneur est entré. Le conteneur délègue la cible d'action via ce lien. Par défaut, le premier conteneur qui se trouve être un enfant de ce conteneur, de haut en bas et de gauche à droite.
      •
      left
Destination lorsque l'utilisateur appuie sur la touche fléchée Gauche. Par défaut, de droite à gauche.
      •
      right
Destination lorsque l'utilisateur appuie sur la touche fléchée Droite. Par défaut, de gauche à droite.
      •
      up
Destination lorsque l'utilisateur appuie sur la touche fléchée Haut. Par défaut, lit de bas en haut.
Application

Modèle

Objet
Modèle connectionset
wsdlConnection
Modèle de formulaire


orientation

Indique l'orientation du support.
Syntaxe
Reference_Syntax.orientation = "portrait | landscape"
Valeurs

Type

Valeurs
Chaîne
      •
      portrait (par défaut)
L'orientation du support place le bord court en haut.
      •
      landscape
L'orientation du support place le bord long en haut.
Application

Modèle

Objet
Modèle de formulaire
medium
Exemples
JavaScript
xfa.form.form1.pageSet.Page1.medium.orientation = "landscape";
FormCalc
xfa.form.form1.pageSet.Page1.medium.orientation = "landscape"


output

Spécifie le message de sortie associé à une opération de connexion WSDL particulière.
Syntaxe
Reference_Syntax.output = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant le message de sortie.
Application

Modèle

Objet
Modèle connectionSet
operation
Exemples
JavaScript
xfa.connectionSet.DataConnection.operation.output = "Connection successful.";
FormCalc
xfa.connectionSet.DataConnection.operation.output = "Connection successful."


overflowLeader

Indique le sous-formulaire à placer en haut de la zone de contenu ou de la page lorsqu'il est activé suite à un débordement.
Syntaxe
Reference_Syntax.overflowLeader = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant le nom ou l'expression de syntaxe de référence complète d'un sous-formulaire.
Application

Modèle

Objet
Modèle de formulaire
break
Exemples
JavaScript
Subform1.break.overflowLeader = "Subform2";
FormCalc
Subform1.break.overflowLeader = "Subform2"


overflowTarget

Indique la zone de contenu explicite qui servira de cible de transition lorsque la zone de contenu ou la page actuelle sera dépassée.
Syntaxe
Reference_Syntax.overflowTarget = "string"
Valeurs

Type

Valeurs
Chaîne
Nom ou expression de syntaxe de référence complète d'une zone de contenu.
Application

Modèle

Objet
Modèle de formulaire
break
Exemples
JavaScript
Subform1.break.overflowTarget = "xfa.form.form1.pageSet.Page1.Content_Main";
FormCalc
Subform1.break.overflowTarget = "xfa.form.form1.pageSet.Page1.Content_Main"


overflowTrailer

Indique le sous-formulaire à placer au bas de la zone de contenu ou de la page en cas de débordement.
L'espace vertical requis par la fin de débordement doit être réservé.
Syntaxe
Reference_Syntax.overflowTrailer = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant le nom ou l'expression de syntaxe de référence complète d'un sous-formulaire.
Application

Modèle

Objet
Modèle de formulaire
break
Exemples
JavaScript
Subform1.break.overflowTrailer = "Subform2";
FormCalc
Subform1.break.overflowTrailer = "Subform2"


overline

Indique l’activation et le type de ligne de séparation supérieure.
Syntaxe
Reference_Syntax.overline = "0 | 1 | 2"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
La police est générée sans ligne de séparation supérieure.
      •
      1
La police est générée avec une ligne de séparation supérieure simple.
      •
      2
La police est générée avec une ligne de séparation supérieure double.
Application

Modèle

Objet
Modèle de formulaire
font
Exemples
JavaScript
TextField1.font.overline = "0";
FormCalc
TextField1.font.overline = "0"


overlinePeriod

Contrôle l'aspect de la ligne de séparation supérieure.
Syntaxe
Reference_Syntax.overlinePeriod = "all | word"
Valeurs

Type

Valeurs
Chaîne
      •
      all (par défaut)
La ligne rendue s'étend aux sauts de mots.
      •
      word
La ligne rendue est interrompue aux sauts de mots.
Application

Modèle

Objet
Modèle de formulaire
font
Exemples
JavaScript
TextField1.font.overlinePeriod = "all";
FormCalc
TextField1.font.overlinePeriod = "all"


override

Détermine si la valeur calculée peut être remplacée interactivement par l'utilisateur, ou si elle est désactivée quel que soit le contexte.
Lorsqu'aucun objet calculate n'est associé, cette propriété n'a pas d'effet et l'utilisateur peut saisir une valeur dans ce champ.
Syntaxe
Reference_Syntax.override = "error | ignore | disabled | warning"
Valeurs

Type

Valeurs
Chaîne
      •
      error
Le calcul est activé et l'utilisateur ne peut pas remplacer la valeur calculée. Si l'utilisateur tente de remplacer la valeur calculée, l'application de traitement affiche un message d'erreur. Pour ne pas avoir à créer de messages d'erreur, les concepteurs de formulaires peuvent définir ces champs en lecture seule.
Il s'agit de la valeur de remplacement par défaut lorsque l'objet calculate est inclus dans l'objet de conteneur.
      •
      ignore
La valeur calculée est celle fournie par défaut. Si l'utilisateur choisit de remplacer la valeur, l'application de traitement autorise l'opération sans afficher de message d'erreur.
Il s'agit de la valeur de remplacement par défaut lorsque l'objet calculate est omis dans le conteneur.
      •
      disabled
Le calcul est désactivé. Dans un contexte interactif, l'utilisateur peut saisir des informations dans le champ. Cette valeur de remplacement n'a pas d'incidence sur l'opération effectuée par l'utilisateur. La valeur disabled permet à un script d'événement d'activer ou de désactiver dynamiquement un objet calculate.
      •
      warning
Le calcul est activé et la valeur calculée est préférée aux valeurs saisies par l'utilisateur. Si l'utilisateur remplace la valeur calculée, l'application de traitement affiche un message d'erreur. Le message informe l'utilisateur que l'objet de formulaire doit utiliser une valeur calculée. Deux options sont proposées :
      •
      Dismiss indique que l'utilisateur souhaite utiliser la valeur calculée.
      •
      Override indique que l'utilisateur a pris connaissance du message, mais a choisi de remplacer la valeur calculée.
L'application ne génère pas de message d'avertissement ou d'invites concernant des cibles d'action atteintes par le même objet.
Application

Modèle

Objet
Modèle de formulaire
calculate
value
Exemples
JavaScript
TextField1.calculate.override = "disabled";
FormCalc
TextField1.calculate.override = "disabled"


pagePosition

Indique une position de la page dans un jeu de pages.
Syntaxe
Reference_Syntax.pagePosition = "any | first | last | rest | only"
Valeurs

Type

Valeurs
Chaîne
      •
      any (par défaut)
Représente n'importe quelle page dans un jeu de pages consécutif.
      •
      first
Représente la première page dans une séquence de pages consécutive.
      •
      last
Représente la dernière page dans une séquence de pages consécutive.
      •
      rest
Représente n'importe quelle page à l'exception de la première et de la dernière page dans une séquence de pages.
      •
      only
Représente une séquence de page unique.
Application

Modèle

Objet
Modèle de formulaire
pageArea
Exemples
L'expression de syntaxe de référence varie selon l'objet à partir duquel elle est appelée.
JavaScript
xfa.form.form1.pageSet.Page1.pagePosition = "only";
FormCalc
xfa.form.form1.pageSet.Page1.pagePosition = "only"


parent

Renvoie l'objet parent de l'objet en cours.
cette propriété est en lecture seule.
Syntaxe
Reference_Syntax.parent
Valeurs

Type

Valeurs
Objet
Un modèle d'objet de formulaire XML.
Application
Classe de tree
Exemples
JavaScript
TextField1.parent;
FormCalc
TextField1.parent


parentSubform

Indique le sous-formulaire (page) parent du champ.
Syntaxe
Reference_Syntax.parentSubform = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valable représentant le nom ou l'expression de syntaxe de référence complète de l'objet de sous-formulaire parent.
Application

Modèle

Objet
Modèle de formulaire
field
Exemples
JavaScript
TextField1.parentSubform;
FormCalc
TextField1.parentSubform


passwordChar

Indique le caractère visible à l'écran lorsqu'un utilisateur saisit un mot de passe dans le formulaire.
Syntaxe
Reference_Syntax.passwordChar = "* | character"
Valeurs

Type

Valeurs
Chaîne
      •
      « *« (astérisque) (valeur par défaut)
      •
      Tout caractère valable.
Application

Modèle

Objet
Modèle de formulaire
passwordEdit
Exemples
JavaScript
PasswordField1.resolveNode("ui.#passwordEdit").passwordChar = "*";
FormCalc
PasswordField1.ui.#passwordEdit.passwordChar = "*"


permissions

Spécifie les droits d'accès accordés pour un formulaire qui inclut la signature de l'auteur.
Pour plus d'informations sur les signatures d'auteur, voir signatureType.
Syntaxe
Reference_Syntax.permissions = "1 | 2 | 3"
Valeurs

Type

Valeurs
Chaîne
•
1
Aucune modification au document n'est autorisée. Toute modification apportée au document invalide la signature.
•
2 (par défaut)
Les modifications autorisées sont le remplissage de formulaires, la génération d'instances de modèles de page et la signature. Toute autre modification invalide la signature.
•
3
Les modifications autorisées sont celles permises par 2, ainsi que la création d'annotations, la suppression et la modification. Toute autre modification invalide la signature.
Application

Modèle

Objet
Modèle de formulaire
mdp


picture

Rendu d'un élément qui décrit les données de mise en forme d'entrée et de sortie.
Syntaxe
Reference_Syntax.picture = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne représentant un format de données d'image valable.
Voir aussi
Formats de date et heure


placement

Indique l’emplacement d’un libellé.
Syntaxe
Reference_Syntax.placement = "left | right | top | bottom | inline"
Valeurs

Type

Valeurs
Chaîne
      •
      left (par défaut)
Localise la légende à gauche du contenu.
      •
      right
Localise la légende à droite du contenu.
      •
      top
Localise la légende au-dessus du contenu.
      •
      bottom
Localise la légende en dessous du contenu.
      •
      inline
Localise la légende dans le contenu, en le précédant.
Application

Modèle

Objet
Modèle de formulaire
caption
Exemples
JavaScript
TextField1.caption.placement = "left";
FormCalc
TextField1.caption.placement = "left"


platform

Renvoie la plate-forme de l'ordinateur qui exécute le script.
cette propriété est en lecture seule.
Syntaxe
Reference_Syntax.platform
Valeurs

Type

Valeurs
Chaîne
Chaîne valable représentant le système d'exploitation. Par exemple, dans le cas d'un formulaire PDF ouvert dans Acrobat, cette propriété renvoie l'une des valeurs suivantes : WIN, MAC ou UNIX.
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.platform;
FormCalc
xfa.host.platform


posture

Indique le style d’une police.
Syntaxe
Reference_Syntax.posture = "normal | italic"
Valeurs

Type

Valeurs
Chaîne
      •
      normal (par défaut)
La police présente un style normal.
      •
      italic
La police est mise en italique.
Application

Modèle

Objet
Modèle de formulaire
font
Exemples
JavaScript
TextField1.font.posture = "italic";
FormCalc
TextField1.font.posture = "italic"


presence

Indique si un objet est visible ou non.
Syntaxe
Reference_Syntax.presence = "visible | invisible | hidden"
Valeurs

Type

Valeurs
Chaîne
      •
      visible (par défaut)
L'objet est visible.
      •
      invisible
L'objet est transparent. Bien qu'invisible, il occupe un espace physique.
      •
      hidden
L'objet est masqué. Le formulaire n'affiche pas l'objet. Ce dernier n'entre pas en compte pour la disposition du formulaire.
Application

Modèle

Objet
Modèle de formulaire
border
caption
corner
draw
edge
exclGroup
field
fill
items
subform
Exemples
JavaScript
TextField1.presence = "hidden";
FormCalc
TextField1.presence = "hidden"


preserve

Spécifie les contraintes veuve/orphelin associées au comportement de débordement du contenu au sein du conteneur qui englobe.
Syntaxe
Reference_Syntax.preserve = "0 | integer | all"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
Le contenu dépasse la limite de débordement.
      •
      integer
Une valeur sous forme d'entier supérieure à zéro spécifie la quantité minimale de contenu devant franchir la limite de débordement. Par exemple, la valeur 2 empêche la création d'une ligne de contenu creuse hors de la limite de débordement ; deux lignes de contenu sont renvoyées hors de ces limites.
      •
      all
Chaque paragraphe de contenu doit être conservé intact et ne peut donc pas dépasser la limite de débordement.
Application

Modèle

Objet
Modèle de formulaire
para
Exemples
JavaScript
TextField1.para.preserve = "all";
FormCalc
TextField1.para.preserve = "all"


prevContentType

Indique le type de contenu de la valeur spécifiée pour la propriété prevText.
Par exemple, si prevContentType='text/html', prevText contient un fragment de code XHTML.
Syntaxe
Reference_Syntax.prevContentType = "allowRichText | plainTextOnly"
Valeurs

Type

Valeurs
Chaîne
      •
      allowRichText (par défaut)
Le champ prend en charge le texte enrichi.
      •
      plainTextOnly
Le champ ne prend pas en charge le texte enrichi.
Application

Modèle

Objet
Modèle d'événement
eventPseudoModel
Exemples
JavaScript
xfa.event.prevContentType = "plainTextOnly";
FormCalc
xfa.event.prevContentType = "plainTextOnly"


previous

Indique les contraintes relatives au maintien d'un sous-formulaire avec le sous-formulaire précédent au sein d'une zone de contenu ou d'une page.
Syntaxe
Reference_Syntax.previous = "none | contentArea | pageArea"
Valeurs

Type

Valeurs
Chaîne
      •
      none (par défaut)
Il incombe à l'application de traitement de déterminer si un sous-formulaire est généré dans la même zone de contenu ou sur la même page que le sous-formulaire précédent. Aucune contrainte particulière n'est imposée.
      •
      contentArea
Le sous-formulaire doit obligatoirement être généré dans la même zone de contenu que celui qui le précède.
      •
      pageArea
Le sous-formulaire doit obligatoirement être généré sur la même page que celui qui le précède.
Application

Modèle

Objet
Modèle de formulaire
keep
Exemples
JavaScript
Subform1.keep.previous = "contentArea";
FormCalc
Subform1.keep.previous = "contentArea"


prevText

Indique le contenu du champ avant qu'il soit modifié suite aux actions de l'utilisateur.
Il est possible de rappeler la valeur prevText de manière similaire à une fonction d'annulation.
Syntaxe
Reference_Syntax.prevText
Valeurs

Type

Valeurs
Chaîne
Chaîne pouvant comprendre jusqu'à 255 caractères.
Application

Modèle

Objet
Modèle d'événement
eventPseudoModel
Exemples
JavaScript
xfa.event.prevText;
FormCalc
xfa.event.prevText


printCheckDigit

Spécifie si les chiffres de contrôle doivent être imprimés dans le texte affichable.
L'analyseur ignore cette propriété si la propriété checksum est affectée de la valeur 0, ou si la propriété checksum est affectée de la valeur 1 et le comportement standard du type de code à barres est de ne pas inclure de somme de contrôle.
Syntaxe
Reference_Syntax.printCheckDigit = "0 | 1"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
N'imprime pas le chiffre de contrôle dans le texte affichable, mais seulement dans le code à barres lui-même.
      •
      1
Ajoute le chiffre de contrôle à la fin du texte affichable.
Application

Modèle

Objet
Modèle de formulaire
barcode
Exemples
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").printCheckDigit = "1";
FormCalc
Code11BarCode1.ui.#barcode.printCheckDigit = "1"


priority

Modifie le chemin de recherche du texte lu. L'objet spécifié dans cette propriété passe au début du chemin de recherche. Les autres objets conservent leur ordre relatif.
Syntaxe
Reference_Syntax.priority = "custom | caption | name | tooltip"
Valeurs

Type

Valeurs
Chaîne
      •
      custom (par défaut)
L'ordre de recherche est le suivant : speak, tooltip, caption, nom du conteneur.
      •
      caption
L'ordre de recherche est le suivant : caption, speak, tooltip, nom du conteneur.
      •
      name
L'ordre de recherche est le suivant : speak, tooltip, caption.
      •
      tooltip
L'ordre de recherche est le suivant : tooltip, speak, caption, nom du conteneur.
Application

Modèle

Objet
Modèle de formulaire
speak
Exemples
JavaScript
TextField1.assist.speak.priority = "tooltip";
FormCalc
TextField1.assist.speak.priority = "tooltip"


radius

Indique le rayon d’un coin.
La propriété radius a toujours un impact sur l'aspect des coins arrondis, mais elle détermine également la profondeur des coins carrés inversés. Chaque bord est ajusté à partir de ses extrémités selon le rayon du coin, quelles que soient les valeurs des propriétés inverted et join. En général, cela n'a aucune conséquence, car le coin apparaît joint aux bords ajustés. Cependant, si le coin est affecté de la valeur invisible relativement à la propriété presence, l'ajustement des bords est alors visible même s'il s’agit d’un coin carré non inversé.
Syntaxe
Reference_Syntax.radius = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
corner
Exemples
JavaScript
TextField1.border.corner.radius = "0.5in";
FormCalc
TextField1.border.corner.radius = "0.5in"


radixOffset

Spécifie une valeur de décalage pour le point d'ancrage du paragraphe.
Syntaxe
Reference_Syntax.radixOffset = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
para
Exemples
JavaScript
NumericField1.para.radixOffset = "0in";
FormCalc
NumericField1.para.radixOffset = "0in"


rate

Spécifie le pourcentage de motif grisé sur un arrière-plan plein.
La couleur de l'arrière-plan n'est pas spécifié par l'objet grisé.
Syntaxe
Reference_Syntax.rate = "50 | integer"
Valeurs

Type

Valeurs
Chaîne
      •
      50 (par défaut)
      •
      Toute valeur (entier) valide comprise entre 0 et 100, où 0 indique l'absence de grisé visible sur la couleur d'arrière-plan et 100 indique le masquage complet de la couleur d'arrière-plan par une couleur grisée.
Une valeur comprise entre 0 et 100 indique un mélange variable de couleur d'arrière-plan et de grisé superposé. Par exemple, un taux de grisé de 50 signale une proportion égale de couleur d'arrière-plan et de grisé.
Application

Modèle

Objet
Modèle de formulaire
stipple
Exemples
JavaScript
TextField1.border.fill.stipple.rate = "75";
FormCalc
TextField1.border.fill.stipple.rate = "75"


rawValue

Indique la valeur non mise en forme de l'objet actuel.
Par exemple, cette propriété renverrait ou définirait la valeur d'un champ.
Syntaxe
Reference_Syntax.rawValue = "value"
Valeurs

Type

Valeurs
Variable
Les valeurs diffèrent selon l'objet de référencement. Ainsi, dans le cas des objets demandant une valeur de couleur, cette propriété indique une liste de valeurs séparées par des virgules pour chaque composante couleur de l'espace colorimétrique sous la forme r,g,b (RVB).
Autre possibilité, la propriété rawValue d'un objet field est une chaîne représentant la valeur réelle affichée dans le champ ou la valeur liée du champ.
Exemples
JavaScript
TextField1.rawValue = "Hello";
FormCalc
TextField1.rawValue = "Hello"


ready

Indique si le processus de disposition du formulaire est terminé et si les tâches de script peuvent commencer.
cette propriété est en lecture seule.
Syntaxe
Reference_Syntax.ready = "True | False"
Valeurs

Type

Valeurs
Booléen
      •
      True (par défaut)
Le processus de disposition est terminé.
      •
      False
Le processus de disposition n'est pas terminé.
Application

Modèle

Objet
Modèle de disposition
layoutPseudoModel
Exemples
JavaScript
xfa.layout.ready;
FormCalc
xfa.layout.ready


recordsAfter

Renvoie le nombre d'enregistrements dans la fenêtre de données après l'enregistrement en cours.
cette propriété est en lecture seule.
Syntaxe
Reference_Syntax.recordsAfter
Valeurs

Type

Valeurs
Entier
Une valeur sous forme d'entier valide comprise entre 0 et la valeur d'index du dernier enregistrement dans les données source.
Application

Modèle

Objet
Modèle de données
dataWindow
Exemples
JavaScript
xfa.dataWindow.recordsAfter;
FormCalc
xfa.dataWindow.recordsAfter


recordsBefore

Renvoie le nombre d'enregistrements dans la fenêtre de données avant l'enregistrement en cours.
cette propriété est en lecture seule.
Syntaxe
Reference_Syntax.recordsBefore
Valeurs

Type

Valeurs
Entier
Une valeur sous forme d'entier valide comprise entre 0 et la valeur d'index du premier enregistrement dans les données source.
Application

Modèle

Objet
Modèle de données
dataWindow
Exemples
JavaScript
xfa.dataWindow.recordsBefore;
FormCalc
xfa.dataWindow.recordsBefore


reenter

Indique si l’événement enter se produit pour la première fois. L’événement enter se produit chaque fois qu’un utilisateur clique sur un champ.
La première fois qu’un utilisateur clique sur un champ, un événement enter est envoyé lorsque la propriété reenter est définie sur false. Si l'utilisateur clique de nouveau sur le champ ou appuie sur la touche Entrée, un autre événement enter est envoyé avec la propriété reenter définie sur true.
Syntaxe
Reference_Syntax.reenter = "0 | 1"
Valeurs

Type

Valeurs
Booléen
      •
      True
L'événement d'entrée est déjà survenu.
      •
      False
L'événement d'entrée est survenu pour la première fois.
Application

Modèle

Objet
Modèle d'événement
eventPseudoModel
Exemples
JavaScript
xfa.event.reenter = "False";
FormCalc
xfa.event.reenter = "False"


ref

Spécifie une expression de syntaxe de référence définissant le noeud dans le modèle de données auquel le conteneur englobant est associé.
Syntaxe
Reference_Syntax.ref = "string"
Valeurs

Type

Valeurs
Chaîne
Syntaxe de référence valide.
Application

Modèle

Objet
Modèle de formulaire
bind
bindItems
connect
event
items
signData
traverse
Modèle sourceSet


relation

Indique les rapports qu'entretiennent les membres du jeu.
Syntaxe
Reference_Syntax.relation = "ordered | unordered | choice"
Valeurs

Type

Valeurs
Chaîne
      •
      ordered (par défaut)
Génère une instance des membres selon l'ordre dans lequel ils ont été déclarés dans la conception de formulaire. Par conséquent, il se peut que le contenu soit à nouveau trié de manière à respecter l'ordre des documents de la conception de formulaire.
      •
      unordered
Génère une instance des membres dans l'ordre des données, quel que soit celui dans lequel ils ont été déclarés. Par conséquent, il se peut que le jeu soit à nouveau trié de manière à respecter l'ordre du contenu.
      •
      choice
Les membres s'excluent mutuellement et un seul d'entre eux peut être instancié. Ce sont les données qui déterminent le membre pour lequel une instance doit être générée.
Application

Modèle

Objet
Modèle de formulaire
subformSet
Exemples
JavaScript
xfa.form.form1.resolveNode("#subformSet").relation = "unordered";
FormCalc
xfa.form.form1.#subformSet.relation = "unordered"


relevant

Contrôle si un objet de formulaire est inclus dans l'opération d'impression.
Syntaxe
Reference_Syntax.relevant = "+print | -print"
Valeurs

Type

Valeurs
Chaîne
      •
      +print | print (valeur par défaut des objets visibles)
Impose l’affichage d’un objet précis à l’impression du formulaire, quelle que soit la valeur de la propriétépresence de l’objet.
      •
      -print (valeur par défaut des objets invisibles ou masqués)
Impose le masquage d'un objet lors de l'impression du formulaire, quel que soit le paramètre de la propriété presence de l'objet.
Application

Modèle

Objet
Modèle de formulaire
zone
border
contentArea
draw
exclGroup
field
pageArea
pageSet
subform
subformSet
value
Exemples
JavaScript
Button1.relevant = "-print";
FormCalc
Button1.relevant = "-print"


reserve

Mesure qui indique la hauteur ou la largeur d’une légende.
L'effet de cette propriété est déterminé par la propriété placement. Lorsque la légende est placée à gauche ou à droite, la propriété reserve indique la hauteur de la zone de la légende. Lorsque la légende est placée au-dessus ou en dessous, la propriété reserve indique la largeur. Lorsque la légende est placée sur la même ligne, elle est ignorée.
Si la propriété de réservation a la valeur 0, l'ajustement automatique est défini pour la légende. La taille de l'objet est ajustée en fonction de la légende.
Syntaxe
Reference_Syntax.reserve = "measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
caption
Exemples
JavaScript
TextField1.caption.reserve = "1.5in";
FormCalc
TextField1.caption.reserve = "1.5in"


restoreState

Rétablie les noeuds de formulaire d'un formulaire à leur état d'origine, tout en réinitialisant les propriétés visuelles des champs, telles que les modifications apportées aux couleurs des bordures.
Syntaxe
Reference_Syntax.restoreState = "none | manual | auto"
Valeurs

Type

Valeurs
Chaîne
      •
      none (par défaut)
Les informations sur l'état et la restauration ne sont pas enregistrées.
      •
      manual
Les propriétés spécifiques sont enregistrées et restaurées à l'aide des objets de script.
      •
      auto
Enregistrent automatiquement le formulaire et le restaurent à son état d'origine.
le paramètre automatique ne peut pas être utilisé pour les documents certifiés.
Application

Modèle

Objet
Modèle de formulaire
subform
Exemples
JavaScript
Subform1.restoreState = "auto";
FormCalc
Subform1.restoreState = "auto"


rightInset

Indique la taille d’une insertion à droite.
Syntaxe
Reference_Syntax.rightInset = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
margin
Exemples
JavaScript
Subform1.margin.rightInset = "0.25in";
FormCalc
Subform1.margin.rightInset = "0.25in"


role

Indique le rôle joué par le conteneur parent.
Syntaxe
Reference_Syntax.role = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valable indiquant le rôle du conteneur parent. Elle peut être employée dans les applications de traitement XFA dont la fonction vocale est activée en vue de fournir des informations. Par exemple, il peut s'agir de valeurs attribuées empruntées au code HTML, telles que TH (en-têtes de tableau) et TR (lignes de tableau).
Application

Modèle

Objet
Modèle de formulaire
assist
Exemples
JavaScript
TextField1.assist.role = "TH";
FormCalc
TextField1.assist.role = "TH"


rotate

Fait pivoter l'objet autour de son point d'ancrage selon l'angle indiqué.
L'angle est exprimé en degrés par rapport à la position par défaut, dans le sens inverse des aiguilles d'une montre. La valeur doit être un multiple non négatif de 90.
le sens de la rotation est identique à celui des angles positifs aux formats PostScript, PDF et PCL, mais inverse pour le format SVG.
Syntaxe
Reference_Syntax.rotate = "0 | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
      •
      Toute mesure d'angle valable.
Application

Modèle

Objet
Modèle de formulaire
draw
field
Exemples
JavaScript
TextField1.rotate = "90";
FormCalc
TextField1.rotate = "90"


rowColumnRatio

Un rapport facultatif rangées/colonnes pour les codes à barres 2D pris en charge.
L'analyseur ignore cette propriété si les propriétés dataRowCount et dataColumnCount sont spécifiées.
Lorsque la propriété rowColumnRatio est fournie, la taille du code à barres évolue pour prendre en compte le nombre de rangées nécessaire à l'affichage des données fournies. Si la dernière rangée n'est pas remplie par les données fournies, elle est complétée par des caractères de remplissage.
Syntaxe
Reference_Syntax.rowColumnRatio = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant le rapport rangées/colonnes.
Application

Modèle

Objet
Modèle de formulaire
barcode


runAt

Indique quelle application peut exécuter le script.
Ce paramètre est appliqué même si le script est appelé par un autre script.
Syntaxe
Reference_Syntax.runAt = "client | server | both"
Valeurs

Type

Valeurs
Chaîne
      •
      client (par défaut)
Le script est exécuté sur le client uniquement.
      •
      server
Le script est exécuté sur le serveur uniquement.
      •
      both
Le script est exécuté sur le client et le serveur.
Application

Modèle

Objet
Modèle de formulaire
execute
script
Exemples
JavaScript
NumericField1.calculate.script.runAt = "both";
FormCalc
NumericField1.calculate.script.runAt = "both"


save

Détermine si les valeurs d'une colonne particulière désignent à la fois les valeurs d'affichage et liées, ou si les données de la colonne désignent les valeurs liées uniquement.
Syntaxe
Reference_Syntax.save = "0 | 1"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
Les valeurs fournies par cet objet sont celles d'affichage uniquement.
      •
      1
Les valeurs fournies par cet objet peuvent être saisies dans ce champ.
Une colonne au moins doit être affectée de la valeur 1. Si plusieurs d'entre elles sont affectées de cette valeur, l'analyseur enregistre la première colonne affichant la valeur 1 qu'il détecte.
Application

Modèle

Objet
Modèle de formulaire
items
Exemples
JavaScript
DropDownList1.resolveNode("#items").save = "1";
FormCalc
DropDownList1.#items.save = "1"


scope

Contrôle l'intervention du sous-formulaire dans la liaison de données et les expressions de syntaxe de référence.
Par défaut, un sous-formulaire nommé prend part à la liaison de données et peut être référencé à l'aide d'une expression de syntaxe de référence. Cette propriété permet d'attribuer un nom à un sous-formulaire mais ne joue aucun rôle dans la liaison de données et les expressions de syntaxe de référence.
Syntaxe
Reference_Syntax.scope = "name | none"
Valeurs

Type

Valeurs
Chaîne
      •
      name (par défaut)
Si le sous-formulaire porte un nom, il prend part à la liaison de données et aux expressions de syntaxe de référence. Dans le cas contraire, il ne joue aucun rôle.
      •
      none
Le sous-formulaire ne prend pas part à la liaison de données ni aux expressions de syntaxe de référence, même s'il porte un nom.
Application

Modèle

Objet
Modèle de formulaire
subform
Exemples
JavaScript
Subform1.scope = "none";
FormCalc
Subform1.scope = "none"


scriptTest

Contrôle la validation effectuée par le script inclus.
Il est préférable que les scripts indiqués comme faisant partie de la validation n'établissent aucune supposition sur l'utilisation des résultats de la validation par l'application de traitement ou du moment où l'objet validate est appelé. En particulier, il est vivement déconseillé de définir un script tentant de répondre à un utilisateur ou tentant de modifier l'état du formulaire de quelque façon que ce soit.
Syntaxe
Reference_Syntax.scriptTest = "error | disabled | warning"
Valeurs
Application

Type

Valeurs
Chaîne
      •
      disabled
N'effectue pas ce test. L'objet de formulaire peut avoir une valeur non conforme au script. Il est possible de laisser le champ doté d'une valeur non conforme sans que cela affecte la validité du formulaire. Cette valeur désactive le test de validation.
      •
      error (par défaut)
Envoie un message et refuse les données signalées par le script comme étant erronées. L'objet de formulaire doit avoir une valeur conforme au script.
      •
      warning
Emet un message si le script signale des données erronées tout en permettant à l'utilisateur de passer au champ suivant. Le message doit informer l'utilisateur qu'il est recommandé pour un objet de formulaire de disposer d'une valeur conforme aux contraintes du script et offrir deux choix :
      •
      dismiss: l'utilisateur comprend la recommandation et souhaite revenir au formulaire afin de satisfaire à cette contrainte.
      •
      override: l'utilisateur comprend la recommandation mais choisit de ne pas respecter cette contrainte.

Modèle

Objet
Modèle de formulaire
validate
Exemples
JavaScript
NumericField1.validate.scriptTest = "disabled";
FormCalc
NumericField1.validate.scriptTest = "disabled"


selEnd

Indique la position de l'index pour le dernier caractère de la sélection de texte stockée dans la propriété prevText lors d'un événement de modification.
Syntaxe
Reference_Syntax.selEnd
Valeurs

Type

Valeurs
Entier
Entier valable représentant la valeur d'index calculée sur une base de 0 du dernier caractère de la sélection de texte.
Si aucun texte n'est sélectionné, cette propriété désigne la position du curseur de saisie de texte au moment du changement. La modification de la valeur de cette propriété a pour effet de modifier les caractères à remplacer par la valeur de changement et repositionne le curseur de saisie de texte.
Application

Modèle

Objet
Modèle d'événement
eventPseudoModel
Exemples
JavaScript
xfa.event.selEnd;
FormCalc
xfa.event.selEnd


selStart

Indique la position de l'index pour le premier caractère de la sélection de texte stockée dans la propriété prevText lors d'un événement de modification.
Syntaxe
Reference_Syntax.selStart
Valeurs

Type

Valeurs
Entier
Entier valable représentant la valeur d'index calculée sur une base de 0 du premier caractère de la sélection de texte.
Si aucun texte n'est sélectionné, cette propriété désigne la position du curseur de saisie de texte au moment du changement. La modification de la valeur de cette propriété a pour effet de modifier les caractères à remplacer par la valeur de changement et repositionne le curseur de saisie de texte.
Application

Modèle

Objet
Modèle d'événement
eventPseudoModel
Exemples
JavaScript
xfa.event.selStart;
FormCalc
xfa.event.selStart


server

Indique l'URL pour un serveur de tampons temporels.
Syntaxe
Reference_Syntax.server = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide qui représente l'URL pour un serveur de tampons temporels.
Application

Modèle

Objet
Modèle de formulaire
timeStamp


shape

Indique si le contour de la case à cocher ou du bouton radio est carré ou rond.
Syntaxe
Reference_Syntax.shape = "square | round"
Valeurs

Type

Valeurs
Chaîne
      •
      square (par défaut)
Le bouton s'affiche avec un contour carré.
      •
      round
Le bouton s'affiche avec un contour rond.
Application

Modèle

Objet
Modèle de formulaire
checkButton
Exemples
JavaScript
CheckButton1.resolveNode("ui.#checkButton").shape = "square";
FormCalc
CheckButton.ui.#checkButton.shape = "square"


shift

Indique si la touche Maj est enfoncée lors d'un événement donné.
Syntaxe
Reference_Syntax.shift
Valeurs

Type

Valeurs
Booléen
      •
      True (par défaut)
La touche Maj est enfoncée lors de l'exécution d'un événement.
      •
      False
La touche Maj n'est pas enfoncée lors de l'exécution d'un événement.
Application

Modèle

Objet
Modèle d'événement
eventPseudoModel
Exemples
JavaScript
xfa.event.shift;
FormCalc
xfa.event.shift


short

Spécifie la longueur du bord court de l'objet medium.
La longueur spécifiée par la propriété short doit être inférieure à celle spécifiée par la propriété long.
Syntaxe
Reference_Syntax.short = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
medium
Exemples
JavaScript
xfa.form.form1.pageSet.Page1.medium.short;
FormCalc
xfa.form.form1.pageSet.Page1.medium.short


signatureType

Indique le mode d'enregistrement d'un formulaire comportant une signature du document comme document PDF certifié.
Syntaxe
Reference_Syntax.signatureType = "filler | author"
Valeurs

Type

Valeurs
Chaîne
      •
      filler (par défaut)
Enregistre le formulaire comme document PDF certifié.
      •
      author
Les documents comportant des signatures d'auteur sont considérés comme documents certifiés. Après avoir enregistré le formulaire comme document PDF et l'avoir ouvert dans Acrobat, l'utilisateur peut cliquer sur le champ de signature du document pour certifier l'intégralité du document.
Application

Modèle

Objet
Modèle de formulaire
mdp


size

Mesure indiquant la taille du contour de la case à cocher ou du bouton radio, soit la hauteur et la largeur s'il s'agit d'une case à cocher, soit le diamètre s'il s'agit d'un bouton radio.
Syntaxe
Reference_Syntax.size = "10pt | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      10pt (par défaut)
      •
      Toute mesure valable.
Les valeurs de cette propriété varient en fonction de l'objet de référencement :
      •
      Pour l'objet font, cette propriété indique la taille de la police.
      •
      Pour l'objet checkButton, cette propriété indique soit la hauteur ou la largeur d'une case à cocher, soit le diamètre d'un bouton radio.
Application

Modèle

Objet
Modèle de formulaire
checkButton
font
Exemples
JavaScript
CheckBox1.resolveNode("ui.#checkButton").size = "20pt";
FormCalc
CheckBox1.ui.#checkButton.size = "20pt"


slope

Indique l'orientation de la ligne.
Syntaxe
Reference_Syntax.slope = "\ | /"
Valeurs

Type

Valeurs
Chaîne
      •
      \ (barre oblique inversée) (par défaut)
La ligne s'étend du coin supérieur gauche au coin inférieur droit.
      •
      / (barre oblique)
La ligne s'étend du coin inférieur gauche au coin supérieur droit.
Application

Modèle

Objet
Modèle de formulaire
line
Exemples
JavaScript
Line1.resolveNode("value.#line").slope = "/";
FormCalc
Line1.value.#line.slope = "/"


soapFaultCode

Indique tout code incorrect survenant lors de la tentative d'exécution par l'utilisateur d'une connexion au service Web.
Syntaxe
Reference_Syntax.soapFaultCode = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valable représentant le code de défaillance SOAP.
Application

Modèle

Objet
Modèle d'événement
eventPseudoModel


soapFaultString

Indique le message descriptif correspondant à un code incorrect lors de la connexion à un service Web particulier.
Syntaxe
Reference_Syntax.size = "10pt | measurement"
Valeurs

Type

Valeurs
Chaîne
Chaîne valable représentant le message du code de défaillance SOAP.
Application

Modèle

Objet
Modèle d'événement
eventPseudoModel


somExpression

Récupère l'expression de syntaxe de référence pour ce nœud.
Syntaxe
Reference_Syntax.somExpression
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant une expression de syntaxe de référence complète.
Application
Classe de tree
Exemples
JavaScript
TextField1.somExpression;
FormCalc
TextField1.somExpression


spaceAbove

Indique la quantité d’espacement vertical et la taille maximale de police sur la première ligne d’un paragraphe.
Syntaxe
Reference_Syntax.spaceAbove = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
para
Exemples
JavaScript
TextField1.para.spaceAbove = "2pt";
FormCalc
TextField1.para.spaceAbove = "2pt"


spaceBelow

Indique la quantité d’espacement vertical et la taille maximale de police sur la première ligne d’un paragraphe.
Syntaxe
Reference_Syntax.spaceAbove = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
para
Exemples
JavaScript
TextField1.para.spaceBelow = "2pt";
FormCalc
TextField1.para.spaceBelow = "2pt"


startAngle

Indique l’angle à l’origine d’un arc.
Syntaxe
Reference_Syntax.startAngle = "0 | angle"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
      •
      Valeur supérieure à 0 et inférieure ou égale à 360.
Application

Modèle

Objet
Modèle de formulaire
arc
Exemples
JavaScript
Circle1.resolveNode("value.#arc").startAngle = "12";
FormCalc
Circle1.value.#arc.startAngle = "12"


startChar

Indique le caractère de commande de départ facultatif à ajouter au début des données du code à barres.
La propriété starChar n'est pas prise en compte par l'analyseur si le format du code à barres ne prend pas en charge le caractère de commande de départ spécifié.
Syntaxe
Reference_Syntax.startChar = "character"
Valeurs

Type

Valeurs
Chaîne
Chaîne valable représentant un caractère de commande.
Application

Modèle

Objet
Modèle de formulaire
barcode
Exemples
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").startChar = "*";
FormCalc
Code11BarCode1.ui.#barcode.startChar = "*"


startNew

Indique s'il est nécessaire de commencer une nouvelle zone de contenu ou une page même lorsque la zone de contenu ou de page actuelle est dotée du nom requis.
Cette propriété est sans effet, à moins que la propriété before ne soit doté de la valeur contentArea ou pageArea.
Syntaxe
Reference_Syntax.startNew = "0 | 1"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
Ne commence pas de nouvelle zone de contenu ou de page si la zone actuelle est dotée du nom indiqué.
      •
      1
Commence une nouvelle zone de contenu ou page.
Le nom de la zone de contenu ou de la page est fourni par la propriété beforeTarget associée.
Application

Modèle

Objet
Modèle de formulaire
break
breakAfter
breakBefore
Exemples
JavaScript
Subform1.break.startNew = "1";
FormCalc
Subform1.break.startNew = "1"


stateless

Détermine si les variables d'un script sont conservées d'une invocation à l'autre.
Syntaxe
Reference_Syntax.stateless = "0 | 1"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
Les variables du script sont conservées (si la propriété stateful est activée).
      •
      1
Les variables du script ne sont pas conservées (si la propriété stateless est activée).
Application

Modèle

Objet
Modèle de formulaire
script
Exemples
JavaScript
TextField1.resolveNode("#event.#script").stateless = "1";
FormCalc
TextField1.#event.#script.stateless = "1"


stock

Spécifie le nom d'un format de papier standard.
Syntaxe
Reference_Syntax.stock = "letter | paper_size"
Valeurs

Type

Valeurs
Chaîne
      •
      letter (par défaut)
      •
      Toute valeur de format de papier valide.
Application

Modèle

Objet
Modèle de formulaire
medium
Exemples
JavaScript
xfa.form.form1.pageSet.Page1.medium.stock = "A4";
FormCalc
xfa.form.form1.pageSet.Page1.medium.stock = "A4"


stroke

Indique l'aspect d'une ligne.
Syntaxe
Reference_Syntax.stroke = "solid | dashed | dotted | dashDot | dashDotDot | lowered | raised | etched | embossed"
Valeurs

Type

Valeurs
Chaîne
      •
      solid (par défaut)
Pleine.
      •
      dashed
Succession de tirets rectangulaires.
      •
      dotted
Succession de points ronds.
      •
      dashDot
Alternance de tirets et de points.
      •
      dashDotDot
Succession de tirets suivis de deux points.
      •
      lowered
Ligne encadrant une zone enfoncée.
      •
      raised
Ligne encadrant une zone surélevée.
      •
      etched
Ligne gravée sur la surface de dessin.
      •
      embossed
Ligne en relief sur la surface de dessin.
Application

Modèle

Objet
Modèle de formulaire
corner
edge
Exemples
JavaScript
Line1.resolveNode("value.#line.edge").stroke = "etched";
FormCalc
Line1.value.#line.edge.stroke = "etched"


sweepAngle

Indique la longueur d’un arc, exprimée comme un angle.
Syntaxe
Reference_Syntax.sweepAngle = "360 |angle"
Valeurs

Type

Valeurs
Chaîne
      •
      360 (par défaut)
      •
      Valeur inférieure à 360 et supérieure ou égale à 0.
Application

Modèle

Objet
Modèle de formulaire
arc
Exemples
JavaScript
Circle1.resolveNode("value.#arc").sweepAngle = "45";
FormCalc
Circle1.value.#arc.sweepAngle = "45"


tabDefault

Spécifie la distance entre les taquets de tabulation par défaut.
Par défaut, aucun taquet de tabulation par défaut n'est défini.
Syntaxe
Reference_Syntax.tabDefault = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant la distance entre les taquets de tabulation par défaut.
Application

Modèle

Objet
Modèle de formulaire
para
Exemples
JavaScript
TextField1.para.tabDefault = "3in";
FormCalc
TextField1.para.tabDefault = "3in"


tabStops

Spécifie une liste d'emplacements de taquets de tabulation séparés par des espaces.
Entre la marge de gauche et le taquet de tabulation le plus à droite dans la liste, ces emplacements de taquets de tabulation remplacent les taquets de tabulation par défaut spécifiés par la propriété tabDefault. Les taquets de tabulation par défaut reprennent à droite de cette zone.
Chaque entrée de la liste de taquets de tabulation se compose d'un mot-clé qui définit l'alignement au taquet de tabulation, suivi par un espace, et par la distance comprise entre la marge de gauche et le taquet de tabulation.
Syntaxe
Reference_Syntax.tabStops = "center | left | rigth | decimal"
Valeurs

Type

Valeurs
Chaîne
L'alignement du taquet de tabulation est défini par l'une des valeurs suivantes :
      •
      center
Spécifie un taquet de tabulation centré.
      •
      left
Spécifie un taquet de tabulation aligné à gauche.
      •
      right
Spécifie un taquet de tabulation aligné à droite.
      •
      decimal
Spécifie un taquet de tabulation qui aligne le contenu le long de la base.
Application

Modèle

Objet
Modèle de formulaire
para
Exemples
JavaScript
TextField1.para.tabStops = "decimal";
FormCalc
TextField1.para.tabStops = "decimal"


target

Indique l'objet sur lequel l'événement a une influence.
Syntaxe
Reference_Syntax.target = "URL"
Valeurs

Type

Valeurs
Chaîne
Chaîne valable représentant le nom d'un objet de modèle de formulaire, d'une expression de syntaxe de référence ou d'un URL auquel les données sont envoyées.
Application

Modèle

Objet
Modèle d'événement
eventPseudoModel
Modèle de formulaire
breakAfter
breakBefore
overflow
setProperty
signData
submit
Exemples
JavaScript
xfa.event.target;
FormCalc
xfa.event.target


targetType

Indique les contraintes de déplacement vers une nouvelle page ou zone de contenu avant la disposition du sous-formulaire parent.
La propriété targetType remplace la propriété break.before désapprouvée.
Syntaxe
Reference_Syntax.targetType = "auto | contentArea | pageArea"
Valeurs

Type

Valeurs
Chaîne
La propriété startNew modifie aussi certains des ces comportements.
      •
      auto (par défaut)
La détermination d'une transition vers une nouvelle page ou zone de contenu est déléguée à l'application de traitement. Aucune transition vers une nouvelle page ou zone de contenu n'est imposée.
      •
      contentArea
Transitions de rendu vers la prochaine zone de contenu disponible. Voir aussi la propriété startNew.
      •
      pageArea
Transitions de rendu vers une nouvelle page. Voir aussi la propriété startNew.
Application

Modèle

Objet
Modèle de formulaire
breakAfter
breakBefore
Exemples
JavaScript
Subform1.breakBefore.targetType = "pageArea";
FormCalc
Subform1.breakBefore.targetType = "pageArea"


textEncoding

Indique l'encodage du contenu de texte dans un document.
Syntaxe
Reference_Syntax.textEncoding = "UTF-8 | UTF-16 | Shift-JIS | Big-Five | GB-2312"
Valeurs
la valeur de cette propriété ne respecte pas la casse des caractères et doit correspondre à l'une des valeurs suivantes.

Type

Valeurs
Chaîne
      •
      none (par défaut)
Aucun encodage spécifique n'est indiqué. Les caractères sont encodés à l'aide de l'encodage disponible sur le système d'exploitation.
      •
      ISO-8859-1
Les caractères sont encodés selon la norme ISO-8859-1, également connue sous l'appellation Latin-1.
      •
      ISO-8859-2
Les caractères sont encodés selon la norme ISO-8859-2.
      •
      SO-8859-7
Les caractères sont encodés selon la norme ISO-8859-7.
      •
      Shift-JIS
Les caractères sont encodés selon la norme JIS X 0208, plus connue sous le nom de Shift-JIS.
      •
      KSC-5601
Les caractères sont encodés selon le code CII (Code for Information Interchange, Hangul et Hanja.
      •
      Big-Five
Les caractères sont encodés en chinois traditionnel (Big-5). Il n'existe pas de norme officielle relative à l'encodage Big-5. Aussi, plusieurs variantes sont disponibles. Le modèle d'objet de formulaire d'Adobe utilise la variante mise en oeuvre par Microsoft sous la forme de code.
      •
      GB-2312
Les caractères sont encodés en chinois simplifié.
      •
      UTF-8
Les caractères sont encodés à l'aide de points de code Unicode selon les normes Unicode et de la numérotation consécutive UTF-8 (selon la norme ISO/IEC 10646).
      •
      UTF-16
Les caractères sont encodés à l'aide de points de code Unicode selon les normes Unicode et de la numérotation consécutive UTF-16 (selon la norme ISO/IEC 10646).
      •
      UCS-2
Les caractères sont encodés à l'aide de points de code Unicode (selon les normes Unicode) et de la numérotation consécutive UCS-2 (selon la norme ISO/IEC 10646).
      •
      fontSpecific
Les caractères sont encodés d'après la police. Chaque caractère est représenté par un octet de 8 bits.
Application

Modèle

Objet
Modèle de formulaire
submit
Exemples
JavaScript
Button1.event.submit.textEncoding = "UCS-2";
FormCalc
Button1.event.submit.textEncoding = "UCS-2"


textEntry

Détermine si un utilisateur peut saisir une valeur dans une liste déroulante.
Syntaxe
Reference_Syntax.textEntry = "0 | 1"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
Empêche l'utilisateur de saisir une valeur dans le champ actif. Il doit obligatoirement effectuer sa sélection dans la liste déroulante.
      •
      1
Permet à l'utilisateur de saisir ou de sélectionner une valeur dans la liste déroulante. L'utilisateur dispose ainsi d'un champ dont les valeurs admises ne sont pas restrictives. Si la propriété open est définie sur multiSelect, l'utilisateur n'est pas autorisé à saisir des valeurs dans le champ.
Application

Modèle

Objet
Modèle de formulaire
choiceList
Exemples
JavaScript
DropDownList1.resolveNode("ui.#choiceList").textEntry = "1";
FormCalc
DropDownList1.ui.#choiceList.textEntry = "1"


textIndent

Indique la position horizontale de la première ligne par rapport au reste d'un paragraphe.
Une valeur négative indique un retrait à gauche alors qu'une valeur positive indique la mise en retrait de la première ligne.
Syntaxe
Reference_Syntax.textIndent = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
para
Exemples
JavaScript
TextField1.para.textIndent = "3in";
FormCalc
TextField1.para.textIndent = "3in"


textLocation

Indique l'emplacement de tout texte associé au code à barres.
La zone disponible pour le texte incorporé, le cas échéant, est définie par le format du code à barres. Pour la plupart des formats de codes à barres, il s'agit d'une zone unique contiguë. Cependant, dans le cas des codes à barres EAN, cette zone est divisée en quatre plus petites qui héritent des propriétés typeface et size à partir de la zone englobante. La conception de formulaire doit indiquer les propriétés typeface et size pour le champ qui s'adaptera à l'espace fourni sans chevaucher de barres. Il est déconseillé de définir la propriété typeface sur une valeur proportionnelle.
Syntaxe
Reference_Syntax.textLocation = "below | none | above | aboveEmbedded | belowEmbedded"
Valeurs

Type

Valeurs
Chaîne
      •
      below (par défaut)
Place le texte en dessous du code à barres.
      •
      above
Place le texte au-dessus du code à barres.
      •
      belowEmbedded
Incorpore partiellement le texte à la partie inférieure du code à barres en l'alignant sur le bas des barres.
      •
      aboveEmbedded
Incorpore partiellement le texte à la partie supérieure du code à barres en l’alignant avec le haut des barres.
      •
      none
N'affiche pas de texte.
Application

Modèle

Objet
Modèle de formulaire
barcode
Exemples
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").textLocation = "aboveEmbedded";
FormCalc
Code11BarCode1.ui.#barcode.textLocation = "aboveEmbedded"


thickness

Indique l'épaisseur ou le poids de la ligne.
Syntaxe
Reference_Syntax.thickness = "0.5pt | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0.5pt (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
corner
edge
Exemples
JavaScript
TextField1.border.edge.thickness = "0.2in";
FormCalc
TextField1.border.edge.thickness = "0.2in"


this

Récupère le nœud actif, qui est le nœud de départ lors de l'utilisation des méthodes resolveNode et resolveNodes.
cette propriété est en lecture seule.
Syntaxe
this
Valeurs

Type

Valeurs
Objet
L'objet actif.
Application

Modèle

Objet
Modèle XFA
xfa
Exemples
JavaScript
this
FormCalc
this


timeout

Spécifie le nombre de secondes autorisé pour la tentative d'exécution de la requête.
Syntaxe
Reference_Syntax.timeout = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant le nombre de secondes avant l'expiration de la requête.
Application

Modèle

Objet
Modèle sourceSet
command
connect
Exemples
Dans ces exemples, Titles désigne le nom de la connexion aux données.
JavaScript
xfa.sourceSet.Titles.connect.timeout = "10";
FormCalc
xfa.sourceSet.Titles.connect.timeout = "10"


timeStamp

Indique le tampon de date et d'heure pour ce nœud.
Syntaxe
Reference_Syntax.timeStamp = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant une date et une heure.
Application

Modèle

Objet
Modèle XFA
xfa


title

Définit et obtient le titre du document. Cette méthode est uniquement disponible pour les applications client.
Syntaxe
Reference_Syntax.title
Valeurs

Type

Valeurs
Chaîne
Chaîne valable représentant le titre du formulaire actif.
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.title;
FormCalc
xfa.host.title


topInset

Mesure représentant la taille d’une insertion en haut.
Syntaxe
Reference_Syntax.topInset = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
margin
Exemples
JavaScript
Subform1.margin.topInset "1in";
FormCalc
Subform1.margin.topInset "1in"


trailer

Indique l'objet subform ou subformSet devant être placé en bas d'une zone de contenu ou d'une zone de page.
La propriété trailer remplace les propriétés overflowTrailer et bookendTrailer désapprouvées.
Syntaxe
Reference_Syntax.trailer = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant l'ID ou l'expression de syntaxe de référence complète d'un sous-formulaire ou d'un jeu de sous-formulaires. La valeur par défaut est une chaîne vide.
Application

Modèle

Objet
Modèle de formulaire
bookend
breakAfter
breakBefore
overflow
Exemples
JavaScript
Subform1.breakBefore.trailer = "Subform2";
FormCalc
Subform1.breakBefore.trailer = "Subform2"


transferEncoding

Indique l'encodage du contenu binaire dans le document référencé.
Syntaxe
Reference_Syntax.transferEncoding = "none | base64"
Valeurs

Type

Valeurs
Chaîne
      •
      none (par défaut)
Le document référencé n'est pas encodé. Si le document référencé est spécifié via une URI, il sera transféré sous forme de flux d'octets. Si le document référencé est intégré, il doit se conformer aux restrictions relatives au type de données PCDATA.
      •
      base64
Le contenu binaire est encodé conformément aux normes d'encodage des transferts base64.
Application

Modèle

Objet
Modèle de formulaire
exData
image
Modèle sourceSet
bind


transient

Spécifie si l'application de traitement doit enregistrer la valeur du groupe d'exclusion lors de l'envoi du formulaire ou d'une opération de sauvegarde.
Syntaxe
Reference_Syntax.transient = "0 | 1"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
La valeur du groupe d'exclusion doit être sauvegardée.
      •
      1
Le groupe d'exclusion ne doit pas être sauvegardé.
Application

Modèle

Objet
Modèle de formulaire
exclGroup


truncate

Tronque le bord droit du code à barres pour les formats pris en charge.
La troncature s'applique seulement au code à barres PDF417. L'analyseur ignore cette propriété pour les formats de codes à barres auxquels elle ne s'applique pas.
Syntaxe
Reference_Syntax.truncate = "0 | 1"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
Inclut la marque de synchronisation du système droitier.
      •
      1
Omet la marque de synchronisation du système droitier.
Application

Modèle

Objet
Modèle de formulaire
barcode
Exemples
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").truncate = "1";
FormCalc
Code11BarCode1.ui.#barcode.truncate = "1"


type

Spécifie le modèle utilisé par un objet.
Indique le sens du flux d'un dégradé de couleurs.
Syntaxe
Reference_Syntax.type = "toRight | toLeft | toTop | toBottom"
Valeurs

Type

Valeurs
Chaîne
Les valeurs de cette propriété varient en fonction de l'objet de référencement.
Pour l'objet barcode :
Chaîne identifiant le modèle de code à barres.
Cette propriété doit être fournie. L'ensemble de valeurs prises en charge pour cette propriété dépend du périphérique d'affichage.
Cette propriété signale plusieurs types de codes à barres, comme indiqué par les valeurs ci-dessous :
•
codabar
Codabar, comme défini dans ANSI/AIM BC3-1995, USS Codabar.
•
code2Of5Industrial
Code 2 parmi 5 (industriel) ; pas de norme officielle.
•
code2Of5Interleaved
Code 2 parmi 5 (entrelacé), comme défini dans ANSI/AIM BC2-1995, USS Interleaved 2-of-5.
•
code2Of5Matrix
Code 2 parmi 5 (matriciel) ; pas de norme officielle.
•
code2Of5Standard
Code 2 parmi 5 ; pas de norme officielle.
•
code3Of9
Code 39 (appelé également code 3 parmi 9), comme défini dans ANSI/AIM BC1-1995, USS Code 39.
•
code3Of9extended
Code 39 étendu ; pas de norme officielle.
•
code11
Code 11 (USD-8) ; pas de norme officielle.
•
code49
Code 49, comme défini dans ANSI/AIM BC6-1995, USS Code 49.
•
code93
Code 93, comme défini dans ANSI/AIM BC5-1995, USS Code 93.
•
code128
Code 128, comme défini dans ANSI/AIM BC4-1995, Code 128.
•
code128A
Code 128 A, comme défini dans ANSI/AIM BC4-1995, ISS Code 128.
•
code128B
Code 128 B, comme défini dans ANSI/AIM BC4-1995, ISS Code 128.
•
code128C
Code 128 C, comme défini dans ANSI/AIM BC4-1995, ISS Code 128.
•
code128SSCC
Code 128 (serial shipping container code), comme défini dans ANSI/AIM BC4-1995, ISS Code 128.
•
ean8
EAN-8, comme défini dans ISO/EEC 15420.
•
ean8add2
EAN-8 avec addendum de deux chiffres, comme défini dans ISO/EEC 15420.
•
ean8add5
EAN-8 avec addendum de cinq chiffres, comme défini dans ISO/EEC 15420.
•
ean13
EAN-13, comme défini dans ISO/EEC 15420.
•
postAUSStandard
Australian Postal Standard (format standard de la poste australienne), comme défini dans Customer Barcoding Technical Specifications (Spécifications techniques des codes à barres clients).
•
postUKRM4SCC
United Kingdom RM4SCC (Royal Mail 4-State Customer Code), comme défini dans le How to Use Mailsort Guide (guide d'instructions sur le tri du courrier).
•
postUSDPBC
Code à barres United States Postal Service Delivery Point, comme défini dans le DMM C840 Barcoding Standards for Letters and Flats.
•
postUSStandard
Code à barres United States Postal Service POSTNET (code postal à 4 chiffres), comme défini dans le DMM C840 Barcoding Standards for Letters and Flats.
•
postUSZip
Code à barres United States Postal Service POSTNET (code postal américain à 5 chiffres), comme défini dans le DMM C840 Barcoding Standards for Letters and Flats.
•
qr
QR Code, comme défini dans ISS - QR Code.
•
telepen
Telepen, comme défini dans USS Telepen.
•
ucc128
UCC/EAN 128, comme défini dans International Symbology Specification (Spécifications internationales de la symbologie) - Code 128 (1999).
•
ucc128random
UCC/EAN 128 Random Weight, comme défini dans International Symbology Specification (Spécifications internationales de la symbologie) - Code 128 (1999).
•
ucc128sscc
UCC/EAN 128 (serial shipping container code - SSCC), comme défini dans International Symbology Specification (Spécifications internationales de la symbologie) - Code 128 (1999).
•
upcA
UPC-A, comme défini dans ISO/EEC 15420.
•
upcAadd2
UPC-A avec addendum de deux chiffres, comme défini dans ISO/EEC 15420.
•
upcAadd5
UPC-A avec addendum de cinq chiffres, comme défini dans ISO/EEC 15420.
•
upcApwcd
UPC-A avec données client prix/poids, comme défini dans ISO/EEC 15420.
•
upcE
UPC-E, comme défini dans ISO/EEC 15420.
•
upcEadd2
UPC-E avec addendum de deux chiffres, comme défini dans ISO/EEC 15420.
•
upcEadd5
UPC-E avec addendum de cinq chiffres, comme défini dans ISO/EEC 15420.
•
upcean2
UPC/EAN avec addendum de deux chiffres, comme défini dans ISO/EEC 15420.
•
upcean5
UPC/EAN avec addendum de cinq chiffres, comme défini dans ISO/EEC 15420.
Pour les objets digestMethods, encodings, subjectDNs et timeStamp :
Indique si les options de signature sont restreintes aux options de filtrage.
•
optional (par défaut)
Les options de signature ne sont pas restreintes aux options de filtrage.
•
required
Les options de signature sont restreintes aux options de filtrage.
Pour l'objet linear :
Indique le sens du flux d'un dégradé de couleurs.
•
toRight (par défaut)
La couleur de départ s'affiche à l'extrémité gauche de l'objet et évolue vers la couleur d'arrivée située à l'extrémité droite.
•
toLeft
La couleur de départ s'affiche à l'extrémité droite de l'objet et évolue vers la couleur d'arrivée située à l'extrémité gauche.
•
toTop
La couleur de départ s'affiche à l'extrémité inférieure de l'objet et évolue vers la couleur d'arrivée située à l'extrémité supérieure.
•
toBottom
La couleur de départ s’affiche à l’extrémité supérieure de l’objet et évolue vers la couleur d’arrivée à l’extrémité inférieure.
Pour l'objet radial :
Indique la direction d'un dégradé de couleurs.
•
toEdge (par défaut)
La couleur de départ s'affiche au centre de l'objet et évolue vers la couleur d'arrivée située à l'extérieur.
•
toCenter
La couleur de départ s'affiche à l'extérieur de l'objet et évolue vers la couleur d'arrivée située au centre.
Application

Modèle

Objet
Modèle de formulaire
barcode
handler
issuers
linear
oids
pattern
radial
reasons
signing
timeStamp
Modèle sourceSet
extras


typeface

Indique le nom d’une police de caractères.
Syntaxe
Reference_Syntax.typeface = "Courier | typeface"
Valeurs

Type

Valeurs
Chaîne
      •
      Courier (par défaut)
      •
      Tout identificateur de police valable.
Application

Modèle

Objet
Modèle de formulaire
font
Exemples
JavaScript
TextField1.font.typeface = "Myriad Pro";
FormCalc
TextField1.font.typeface = "Myriad Pro"


underline

Indique l’activation et le type de soulignement.
Syntaxe
Reference_Syntax.underline = "0 | 1 | 2"
Valeurs

Type

Valeurs
Chaîne
      •
      0 (par défaut)
La police est générée sans soulignement.
      •
      1
La police est générée avec un soulignement simple.
      •
      2
La police est générée avec soulignement double.
Application

Modèle

Objet
Modèle de formulaire
font
Exemples
JavaScript
TextField1.font.underline = "2";
FormCalc
TextField1.font.underline = "2"


underlinePeriod

Contrôle l'aspect du soulignement.
Syntaxe
Reference_Syntax.underlinePeriod = "all | word"
Valeurs

Type

Valeurs
Chaîne
      •
      all (par défaut)
La ligne rendue doit s'étendre aux sauts de mots.
      •
      word
La ligne rendue doit être interrompue aux sauts de mots.
Application

Modèle

Objet
Modèle de formulaire
font
Exemples
JavaScript
TextField1.font.underlinePeriod = "word";
FormCalc
TextField1.font.underlinePeriod = "word"


url

Spécifie l'URL pour cet objet.
Syntaxe
Reference_Syntax.url = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant une URL pour ce noeud individuel.
Application

Modèle

Objet
Modèle de formulaire
certificates


urlPolicy

(urlPolicy)Spécifie le type d'URL représenté par l'objet de certificat.
Il équivaut à l'attribut urlType des documents PDF, et ses valeurs sont codées comme Navigateur, ASSP ou la chaîne saisie par l'utilisateur pour la clé urlType.
Syntaxe
Reference_Syntax.urlPolicy = "enrollmentServer | roamingCredentialServer | string"
Valeurs

Type

Valeurs
Chaîne
•
enrollmentServer
L'URL référence un serveur Web auquel l'utilisateur peut s'adresser pour demander un certificat numérique.
•
roamingCredentialServer
L'URL référence un service Web qui contient les informations d'identification numériques qu'un utilisateur utilise pour signer un document ou des données.
•
Chaîne valide qui prolonge l'utilisation de cette propriété avec des valeurs uniques.
Application

Modèle

Objet
Modèle de formulaire
certificates


usage

Spécifie les contextes d'utilisation de la connexion.
Syntaxe
Reference_Syntax.usage = "exportAndImport | exportOnly | importOnly"
Valeurs

Type

Valeurs
Chaîne
      •
      exportAndImport (par défaut)
Utilisée pour l'importation et l'exportation.
      •
      exportOnly
Utilisée pendant l'exportation, ignorée pendant l'importation.
      •
      importOnly
Utilisée pendant l'importation, ignorée pendant l'exportation.
Application

Modèle

Objet
Modèle de formulaire
connect
Exemples
JavaScript
TextField1.connect.usage = "importOnly";
FormCalc
TextField1.connect.usage = "importOnly"


use

Invoque un prototype.
Syntaxe
Reference_Syntax.use = "string"
Valeurs

Type

Valeurs
Chaîne
La valeur de cette propriété est un caractère ‘#’ suivi par l'identificateur du prototype.
Application

Modèle

Objet
Modèle connectionSet
operation
rootElement
soapAction
soapAddress
uri
wsdlAddress
Modèle de formulaire
arc
zone
assist
barcode
bookend
boolean
border
break
breakAfter
breakBefore
button
calculate
caption
certificate
certificates
checkButton
choiceList
Couleur
comb
connect
contentArea
corner
date
dateTime
dateTimeEdit
decimal
defaultUi
desc
draw
edge
event
exclGroup
exData
execute
exObject
extras
field
fill
filter
float
font
format
handler
image
integer
issuers
items
keep
line
linear
manifest
margin
medium
message
numericEdit
occur
oid
oids
overflow
pageArea
pageSet
para
passwordEdit
pattern
picture
radial
reason
reasons
rectangle
ref
script
signature
signatureProperties
signData
signing
solid
stipple
subform
subformSet
submit
Texte
textEdit
time
traversal
traverse
ui
validate
value
variable
Modèle sourceSet
boolean
command
connect
connectString
delete
extras
insert
integer
map
password
query
recordSet
select
source
sourceSet
Texte
update
user


usehref

Invoque un prototype externe.
la propriété usehref ne peut pas cibler de fichiers PDF, même si ceux-ci contiennent des objets de modèle d'objet de formulaire XML.
Si un objet contient les propriétés use et usehref , la propriété usehref a préséance sur la propriété use . Ce niveau de priorité permet l'utilisation d'un prototype différent lors de la génération du rendu des conceptions de formulaire sur des systèmes existants. Les systèmes existants ne tiendront pas compte de la propriété usehref .
Pour contrôler les questions de sécurité, indiquez HTTPS pour l'URI usehref ou assurez-vous que toutes les références de prototypes surviennent derrière un pare-feu.
Syntaxe
Reference_Syntax.usehref = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant un prototype externe. La valeur de cette propriété inclut un caractère ‘#’ et l'identificateur du prototype :
    usehref="URL#XML_ID"
    usehref="URL#ref(reference_syntax)"
Application

Modèle

Objet

Modèle connectionSet
operation
rootElement
soapAction
soapAddress
uri
wsdlAddress
Modèle de formulaire
arc
zone
assist
barcode
bookend
boolean
border
break
breakAfter
breakBefore
button
calculate
caption
certificate
certificates
checkButton
choiceList
Couleur
comb
connect
contentArea
corner
date
dateTime
dateTimeEdit
decimal
defaultUi
desc
draw
edge
event
exclGroup
exData
execute
exObject
extras
field
fill
filter
float
font
format
handler
image
imageEdit
instanceManager
integer
issuers
items
keep
line
linear
manifest
margin
medium
message
numericEdit
occur
oid
oids
overflow
pageArea
pageSet
para
passwordEdit
pattern
picture
radial
reason
reasons
rectangle
ref
script
signature
signatureProperties
signData
signedState
signing
solid
stipple
subform
subformSet
submit
Texte
textEdit
time
traversal
traverse
ui
validate
value
variable
Modèle sourceSet
bind
boolean
command
connect
connectString
delete
extras
insert
integer
map
password
query
recordSet
select
source
sourceSet
Texte
update
user


uuid

Indique l'identificateur unique universel (UUID) pour cet objet.
Syntaxe
Reference_Syntax.uuid = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant un identificateur unique universel pour ce noeud individuel.
Application

Modèle

Objet
Modèle XFA
xfa


validationMessage

Indique la chaîne de message de validation pour ce champ.
Syntaxe
Reference_Syntax.validationMessage = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant un message de validation à l'attention de l'utilisateur.
Application

Modèle

Objet
Modèle de formulaire
exclGroup
field
Exemples
JavaScript
NumericField1.validationMessage = "This is the validation message."
FormCalc
NumericField1.validationMessage = "This is the validation message."


validationsEnabled

Indique si les scripts de validation seront exécutés ou non.
Syntaxe
Reference_Syntax.validationsEnabled = "0 | 1"
Valeurs

Type

Valeurs
Booléen
      •
      0 (par défaut)
Les scripts de validation sont désactivés.
      •
      1
Les scripts de validation sont activés.
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.validationsEnabled = "1";
FormCalc
xfa.host.validationsEnabled = "1"


vAlign

Indique l'alignement de texte vertical.
Syntaxe
Reference_Syntax.vAlign = "top | middle | bottom"
Valeurs

Type

Valeurs
Chaîne
      •
      top (par défaut)
Aligne le texte sur le bord supérieur de la zone disponible.
      •
      middle
Centre le texte verticalement sur la zone disponible.
      •
      bottom
Aligne le texte sur le bord inférieur de la zone disponible.
Application

Modèle

Objet
Modèle de formulaire
draw
exclGroup
field
para
subform
Exemples
JavaScript
TextField1.vAlign = "top";
FormCalc
TextField1.vAlign = "top"


value

Indique la valeur de l'objet actuel.
Indique une liste de valeurs séparées par des virgules pour chacune des composantes de l’espace de couleurs.
Syntaxe
Reference_Syntax.value = "various"
Valeurs

Type

Valeurs
Variable
Les valeurs diffèrent selon l'objet de référencement.
Par exemple, la propriété value d'un objet field est une chaîne représentant la valeur réelle affichée dans le champ ou la valeur liée du champ.
Pour les objets nécessitant une valeur de couleur, cette propriété spécifie une liste de valeurs séparée par des virgules pour chacun des composants de l'espace de couleurs. Pour l’espace de couleurs sRVB, les valeurs des composantes doivent suivre le format r,v,b, où r est la valeur de la composante rouge, v celle de la composante verte et b celle de la composante bleue. Chaque valeur doit être comprise entre 0 et 255 (inclus). La valeur 255 représente l'intensité d'affichage maximale. Par exemple, 255,0,0 correspond à la couleur rouge.
La couleur par défaut varie selon le contexte dans lequel une couleur est utilisée. Elle est déterminée par l'objet qui englobe l'objet de couleur.
Application

Modèle

Objet
Modèle de données
dataValue
Modèle de formulaire
boolean
Couleur
date
dateTime
decimal
float
image
integer
picture
script
Texte
time
Modèle sourceSet
boolean
integer
Texte
S'applique également aux objets provenant de la classe textNode.
Exemples
JavaScript
// Use the value property to set and get the document variable’s value.
TextField1.rawValue = docVar.value;
FormCalc
// Use the value property to set and get the document variable’s value.
TextField1 = docVar.value


valueRef

Renvoie une valeur de données pour chaque noeud de données dans le jeu identifié par l'objet ref.
Les valeurs de données sont ensuite utilisées pour remplir les éléments de valeur, tels que <items save='1'>.
La propriété valueRef est une expression de syntaxe de référence relative.
cette propriété est en lecture seule.
Syntaxe
Reference_Syntax.valueRef = "string"
Valeurs

Type

Valeurs
Chaîne
Chaîne valide représentant une valeur de données pour chaque noeud du jeu.
Application

Modèle

Objet
Modèle de formulaire
bindItems


variation

Indique le conditionnement de l'application exécutant le script.
Cette méthode est uniquement disponible pour les applications client.
cette propriété est en lecture seule.
Syntaxe
Reference_Syntax.variation
Valeurs

Type

Valeurs
Chaîne
Chaîne valable représentant le conditionnement de l'application. Par exemple, dans le cas d'un formulaire PDF ouvert dans Acrobat, cette propriété renvoie l'une des valeurs suivantes : Reader, Fill-in, Business Tools ou Full.
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.variation;
FormCalc
xfa.host.variation


version

Indique le numéro de version de l'application active.
cette propriété est en lecture seule.
Syntaxe
Reference_Syntax.version
Valeurs

Type

Valeurs
Chaîne
Chaîne valable représentant le conditionnement de l'application. Par exemple, dans Acrobat 6.0.1, cette propriété renvoie 6.0.1.
Application

Modèle

Objet
Modèle de formulaire
handler
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.version;
FormCalc
xfa.host.version


vScollPolicy

Indique si un champ peut défiler verticalement.
cette propriété ne s'applique pas aux champs de texte pouvant être ajustés pour contenir des données ou du texte.
Syntaxe
Reference_Syntax.hScrollPolicy = "auto | on | off"
Valeurs

Type

Valeurs
Chaîne
      •
      auto (par défaut)
Les champs ne contenant qu'une seule ligne défilent horizontalement et les champs à plusieurs lignes défilent verticalement (une barre de défilement verticale s'affiche si besoin est).
      •
      on
Les barres de défilement verticales et/ou horizontales s'affichent, même si le texte ou les données dépassent la limite de débordement du champ.
      •
      off
Empêche l'utilisateur de saisir des caractères lorsque la capacité physique du champ est atteinte (délimitée par la largeur de champ). Notez que cette restriction ne s'applique pas aux données de champ.
Application

Modèle

Objet
Modèle de formulaire
textEdit
Exemples
JavaScript
TextField1.resolveNode("ui.#textEdit").vScrollPolicy = "off";
FormCalc
TextField1.ui.#textEdit.vScrollPolicy = "off"


w

Mesure indiquant la largeur pour la disposition.
Lorsque vous spécifiez la largeur, la valeur remplace la plage d'accroissement définie par la propriété minW et la propriété maxW. Si la propriété w est omise ou configurée comme chaîne vide, ce sont la propriété minW et la propriété maxW qui définissent la largeur de l'objet.
Syntaxe
Reference_Syntax.w = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
contentArea
draw
exclGroup
field
subform
Exemples
JavaScript
TextField1.w = "3in";
FormCalc
TextField1.w = "3in"


weight

Définit l’épaisseur du style d’une police de caractères.
Syntaxe
Reference_Syntax.weight = "bold | normal"
Valeurs

Type

Valeurs
Chaîne
      •
      bold (par défaut)
La police est générée en gras.
      •
      normal
La police est générée selon l'épaisseur par défaut.
Application

Modèle

Objet
Modèle de formulaire
font
Exemples
JavaScript
TextField1.font.weight = "normal";
FormCalc
TextField1.font.weight = "normal"


wideNarrowRatio

Spécifie un rapport barre large/barre étroite dans les codes à barres pris en charge.
L'éventail de rapports autorisé varie selon les formats de codes à barres. Pour les codes à barres matériel, c'est le périphérique de sortie qui diffère. Le modèle ne doit pas spécifier de valeur dépassant la plage autorisée. L'analyseur ignore cette propriété pour les formats de codes à barres qui n'autorisent pas de rapport variable entre les différentes largeurs de barres.
Syntaxe
Reference_Syntax.wideNarrowRatio = "3:1 | wide[:narrow]"
Valeurs

Type

Valeurs
Chaîne
      •
      3:1 (par défaut)
Tout rapport valide utilisant la syntaxe suivante :
      •
      wide[:narrow]
où wide est un nombre positif représentant le numérateur du rapport, et narrow est un nombre positif facultatif représentant le dénominateur du rapport.
Si la valeur narrow n'est pas fournie, elle affiche 1.
Application

Modèle

Objet
Modèle de formulaire
barcode
Exemples
JavaScript
Barcode1.resolveNode("ui.#barcode").wideNarrowRatio = "5:1";
FormCalc
Barcode1.ui.#barcode.wideNarrowRatio = "5:1"


x

Indique l’abscisse (coordonnée X) du point d'ancrage d'un conteneur par rapport au coin supérieur gauche du conteneur parent lors d'un placement avec disposition positionnée.
Les conteneurs dont le contenu est distribué n'utilisent pas les coordonnées x.
Syntaxe
Reference_Syntax.x = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
zone
contentArea
draw
exclGroup
field
subform
Exemples
JavaScript
TextField1.x = "5in";
FormCalc
TextField.x = "5in"


xdpContent

Définit le sous-ensemble de données qui est envoyé. Cette propriété s'utilise uniquement lorsque la propriété format est définie sur xdp.
Syntaxe
Reference_Syntax.xdpContent = "string"
Valeurs

Type

Valeurs
Chaîne
      •
      datasets pdf xfdf (par défaut)
Envoie les objets comprenant les sous-ensembles de balises et le formulaire xfdf à l'hôte.
      •
      tag1 tag2 ... tagN
Envoie les objets contenant des balises correspondant à l'une des balises spécifiées.
      •
      * (astérisque)
Envoie tous les objets de données à l'hôte.
Application

Modèle

Objet
Modèle de formulaire
submit
Exemples
JavaScript
Button1.resolveNode("#event.#submit").xdpContent = "*"
FormCalc
Button1.#event.#submit.xdpContent = "*"


y

Indique l'ordonnée (coordonnée X) du point d'ancrage d'un conteneur par rapport au coin supérieur gauche du conteneur parent lors d'un placement avec disposition positionnée.
Les conteneurs dont le contenu est distribué n'utilisent pas les coordonnées y.
Syntaxe
Reference_Syntax.y = "0in | measurement"
Valeurs

Type

Valeurs
Chaîne
      •
      0in (par défaut)
      •
      Toute mesure valable.
Application

Modèle

Objet
Modèle de formulaire
zone
contentArea
draw
exclGroup
field
subform
Exemples
JavaScript
TextField1.y = "5in";
FormCalc
TextField.y = "5in"


Méthodes de script

absPage
absPageCount
absPageSpan
addInstance
addItem
addNew
append
applyXSL
assignNode
beep
boundItem
cancel
cancelBatch
clear
clearErrorList
clearItems
clone
close
createNode
delete
emit
enumerate
evaluate
execCalculate
execEvent
execInitialize
execute
execValidate
exportData
first
formNodes
getAttribute
getElement
gotoRecord
gotoURL
h
hasDataChanged
importData
insert
insertInstance
isBOF
isCompatibleNS
isEOF
isPropertySpecified
isRecordGroup
item
last
loadXML
messageBox
moveCurrentRecord
moveInstance
namedItem
next
open
openList
page
pageContent
pageCount
pageDown
pageSpan
pageUp
previous
print
recalculate
record
relayout
relayoutPageArea
remerge
remove
removeAttribute
removeInstance
requery
reset
resetData
resolveNode
resolveNodes
response
resync
saveFilteredXML
saveXML
selectedMember
setAttribute
setElement
setFocus
setInstance
sign
update
updateBatch
verify
w
x
y
Cette section fournit une liste alphabétique de toutes les méthodes prises en charge dans cet environnement de script.
Chaque hôte (Acrobat ou Adobe Reader, par exemple) est chargé de mettre en oeuvre les méthodes disponibles. Certaines méthodes, comme la méthode beep, ne présentent aucun intérêt sur un serveur. Le serveur n'implémente pas ces méthodes et peut même produire un message d'erreur si l'utilisateur essaie d'appeler la méthode.


absPage

Détermine la première page du formulaire sur laquelle s'affiche un objet de conception de formulaire donné.
Syntaxe
Reference_Syntax.absPage( OBJECT param )
Paramètres
param
Expression de syntaxe de référence complète de l'un des objets de conception de formulaire suivants : champ, dessin, sous-formulaire, zone, zone de page, zone de contenu.
Renvoie
Entier représentant la page du formulaire (base 0). Cette méthode renvoie la valeur -1 si l'objet spécifié dans param est introuvable sur le formulaire.
Application

Modèle

Objet
Modèle de disposition
layoutPseudoModel
Exemples
JavaScript
TextField2.rawValue = xfa.layout.absPage(this);
FormCalc
TextField2 = xfa.layout.absPage($)


absPageCount

Détermine la quantité de pages du formulaire actuel.
Syntaxe
Reference_Syntax.absPageCount()
Paramètres
Non
Renvoie
Entier représentant le nombre de pages dans le formulaire actuel.
Application

Modèle

Objet
Modèle de disposition
layoutPseudoModel
Exemples
JavaScript
TextField2.rawValue = xfa.layout.absPageCount();
FormCalc
TextField2 = xfa.layout.absPageCount()


absPageSpan

Détermine le nombre de pages du formulaire utilisé par un objet de conception de formulaire donné.
Syntaxe
Reference_Syntax.absPageSpan( OBJECT param )
Paramètres
param
Expression de syntaxe de référence complète de l'un des objets de conception de formulaire suivants : champ, dessin, sous-formulaire, zone, zone de page, zone de contenu.
Renvoie
Entier représentant le nombre de pages qu'occupe l'objet de conception de formulaire spécifié. Cette méthode renvoie la valeur -1 si l'objet spécifié dans param est introuvable sur le formulaire.
Application

Modèle

Objet
Modèle de disposition
layoutPseudoModel
Exemples
JavaScript
xfa.layout.absPageSpan(Subform1);
FormCalc
xfa.layout.absPageSpan(Subform1)


addInstance

Ajoute une instance d'un sous-formulaire ou d'un jeu de sous-formulaires au modèle de formulaire.
Syntaxe
Reference_Syntax.addInstance( BOOLEAN param )
Paramètres
param (facultatif)
Indique si le nouveau sous-formulaire ou jeu de sous-formulaires dispose d'une valeur de données correspondante dans le modèle de données.
      •
      True (par défaut)
Fusionne le nouveau sous-formulaire ou jeu de sous-formulaires avec le modèle de données.
      •
      False
N'effectue pas d'opération de fusion.
Renvoie
Nouvel objet de formulaire ou rien si aucun objet n'a été ajouté.
Application

Modèle

Objet
Modèle de formulaire
instanceManager
Exemples
JavaScript
Subform1.instanceManager.addInstance(1);
FormCalc
Subform1.instanceManager.addInstance(1)


addItem

Ajoute de nouveaux éléments au champ de formulaire actuel. Par exemple, cette méthode permet d'ajouter des éléments à une liste déroulante.
Syntaxe
Reference_Syntax.addItem( STRING param1 [, STRING param2 ] )
Paramètres
param1 | Chaîne valide représentant la valeur à afficher dans le champ.
param2 (facultatif) | Chaîne valide représentant la valeur liée du nouvel élément. Lorsqu'elle est vide, la valeur par défaut correspond à une chaîne vide.
Renvoie
Vide
Application

Modèle

Objet
Modèle de formulaire
field
Exemples
JavaScript
DropDownList1.addItem("Human Resources");
FormCalc
DropDownList1.addItem("Human Resources")


addNew

Ajoute un nouvel enregistrement au jeu d'enregistrements.
Syntaxe
Reference_Syntax.addNew()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle sourceSet
source
Exemples
JavaScript
xfa.sourceSet.dataConnectionName.addNew();
FormCalc
xfa.sourceSet.dataConnectionName.addNew();


append

Ajoute un nœud à la fin de la liste de nœuds.
Syntaxe
Reference_Syntax.append( OBJECT param )
Paramètres
param
Expression de syntaxe de référence valide représentant le nœud à ajouter.
Renvoie
Vide
Application
Classe de treeList
Exemples
JavaScript
// Append a data group node to another data model node.
xfa.record.nodes.append(oGroupNode);
FormCalc
// Append a data group node to another data model node.
xfa.record.nodes.append(oGroupNode)


applyXSL

Applique une transformation XLS à une représentation XML du nœud actif. Vous pouvez également appeler saveXML et transformer le résultat à l'aide du document XLS spécifié.
Syntaxe
Reference_Syntax.applyXSL( STRING param )
Paramètres
param
Chaîne valide représentant les données de transformation XLS à appliquer.
Renvoie
Chaîne valide représentant le résultat de la transformation XLS.
Application
Classe de node


assignNode

Evalue l'expression de syntaxe de référence dans le contexte actif et définit la valeur du nœud détecté. Si le nœud n'existe pas, il peut être créé.
Syntaxe
Reference_Syntax.assignNode( STRING param1 [, STRING param2 [, INTEGER param3 ] ] )
Paramètres
param1
Chaîne valide représentant une expression de syntaxe de référence pointant vers un nœud particulier.
param2 (facultatif)
Chaîne valide représentant la valeur à attribuer au nœud.
param3 (facultatif)
Valeur entière représentant l'action à effectuer à la création de nœuds. Les valeurs suivantes désignent les valeurs admises :
      •
      0
Si le nœud existe, la valeur est mise à jour. Si le nœud n'existe pas, il est créé.
      •
      1
Si le nœud existe, une erreur sera émise. Si le nœud n'existe pas, il est créé.
      •
      2
Si le nœud existe, aucune action n'est réalisée. Si le nœud n'existe pas, il est créé.
      •
      3
Un nouveau nœud est toujours généré.
Renvoie
Objet correspondant au nœud spécifié.
Application
Classe de node


beep

Entraîne l'émission d'un son par le système. Cette méthode est uniquement disponible pour les applications client.
Syntaxe
Reference_Syntax.beep( [ INTEGER param ] )
Paramètres
param (facultatif)
Correspond au code système du son approprié.
      •
      0 (Erreur)
      •
      1 (Avertissement)
      •
      2 (Question)
      •
      3 (Etat)
      •
      4 (Par défaut - chaîne représentant la valeur d'affichage)
Renvoie
Vide
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.beep("2");
FormCalc
xfa.host.beep("2")


boundItem

Récupère la valeur liée d'un élément d'affichage spécifique dans une liste déroulante ou une zone de liste.
Syntaxe
Reference_Syntax.boundItem( STRING param )
Paramètres
param
Chaîne valide représentant la valeur d'affichage figurant dans la zone de liste ou la liste déroulante.
Renvoie
Chaîne valide représentant la valeur liée d'une valeur d'affichage spécifiée.
Application

Modèle

Objet
Modèle de formulaire
field
Exemples
JavaScript
DropDownList1.boundItem("Text");
FormCalc
DropDownList1.boundItem("Text")


cancel

Annule toutes modifications apportées à la rangée active ou à une nouvelle rangée de l'objet de jeu d'enregistrements ou à la collection de champs d'un objet d'enregistrement, avant l'appel de la méthode update.
Syntaxe
Reference_Syntax.cancel()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle sourceSet
source
Exemples
JavaScript
xfa.sourceSet.dataConnectionName.cancel();
FormCalc
xfa.sourceSet.dataConnectionName.cancel()


cancelBatch

Annule une mise à jour par lots en attente
Syntaxe
Reference_Syntax.cancelBatch()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle sourceSet
source


clear

Supprime une signature donnée.
Syntaxe
Reference_Syntax.clear( OBJECT param1 [, BOOLEAN param2 ] )
Paramètres
param1
entrée
Nœud de signature XML valable.
param2 (facultatif)
entrée (facultatif)
      •
      True (par défaut)
Indique qu'une boîte de dialogue sert à la réalisation de l'opération.
      •
      False
Indique qu'une boîte de dialogue n'est pas utilisée pour la réalisation de l'opération.
Renvoie
True lorsque la signature est supprimée et False dans le cas contraire.
Application

Modèle

Objet
Modèle de signature
signaturePseudoModel


clearErrorList

Supprime tous les éléments du journal d'erreurs actuel.
Syntaxe
Reference_Syntax.clearErrorList()
Paramètres
Non
Renvoie
Vide
Application
Classe de model


clearItems

Supprime tous les éléments du champ. Cette méthode supprime par exemple tous les éléments contenus dans une zone de liste ou une liste déroulante.
Syntaxe
Reference_Syntax.clearItems()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle de formulaire
field
Exemples
JavaScript
DropDownList1.clearItems();
FormCalc
DropDownList1.clearItems()


clone

Effectue la copie d'un objet.
Syntaxe
Reference_Syntax.clone( BOOLEAN param )
Paramètres
param
Valeur booléenne indiquant si le clonage se produit de manière récursive.
      •
      True(Par défaut)
Clone l'objet de manière récursive.
      •
      False
Ne clone pas l'objet de manière récursive.
Renvoie
Une copie de l'objet.
Application
Classe de node
Exemples
JavaScript
xfa.record.NewGroupNode.clone(1);
FormCalc
xfa.record.NewGroupNode.clone(1)


close

Ferme une connexion d'une source de données.
Syntaxe
Reference_Syntax.close()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle sourceSet
source
Exemples
JavaScript
xfa.sourceSet.nodes.item(nIndex).close();
FormCalc
xfa.sourceSet.nodes.item(nIndex).close()


createNode

Crée un nouveau nœud en fonction d'un nom de classe correct.
Syntaxe
Reference_Syntax.createNode( STRING param1 [, STRING param2 [, STRING param3 ] ] )
Paramètres
param1 | Chaîne valide représentant le nom de classe de l'objet à créer.
param2 (facultatif) | Chaîne valide représentant le nom à attribuer au nœud. S'il est vide, la valeur de ce paramètre correspond par défaut à une chaîne vide.
param3 (facultatif) | Chaîne valide représentant l'espace de nommage XML dans lequel le nœud créé existe. S'il est vide, la valeur de ce paramètre correspond par défaut à une chaîne vide.
Renvoie
Un objet représentant un nœud valide.
Application
Classe de model.
Exemples
JavaScript
// Create a node of type dataGroup.
var oGroupNode = xfa.datasets.createNode("dataGroup", "NewGroupNode");
FormCalc
// Create a node of type dataGroup.
var oGroupNode = xfa.datasets.createNode("dataGroup", "NewGroupNode")


delete

Supprime l'enregistrement actuel du jeu d'enregistrements.
Syntaxe
Reference_Syntax.delete()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle sourceSet
source
Exemples
JavaScript
xfa.sourceSet.dataConnectionName.delete();
FormCalc
xfa.sourceSet.dataConnectionName.delete()


emit

Indique au gestionnaire d'événements de formulaire qu'un événement est survenu.
Syntaxe
Reference_Syntax.emit()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle d'événement
eventPseudoModel
Exemples
JavaScript
xfa.event.emit();
FormCalc
xfa.event.emit()


enumerate

Enumère toutes les signatures XML trouvées dans le document.
Syntaxe
Reference_Syntax.enumerate()
Paramètres
Non
Renvoie
Un objet représentant une liste de nœuds XFA de tous les nœuds de signature XML.
Application

Modèle

Objet
Modèle de signature
signaturePseudoModel


evaluate

Récupère la liste des objets référencée dans l'élément Manifest.
Syntaxe
Reference_Syntax.evaluate()
Paramètres
Non
Renvoie
Un objet représentant la liste des objets.
Application

Modèle

Objet
Modèle de formulaire
manifest


execCalculate

Exécute le script de calcul du champ.
Syntaxe
Reference_Syntax.execCalculate()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle de formulaire
exclGroup
field
formulaire
subform
Exemples
JavaScript
TextField1.execCalculate();
FormCalc
TextField1.execCalculate()


execEvent

Exécute le script d'événement de l'objet.
Syntaxe
Reference_Syntax.execEvent( STRING param )
Paramètres
param
Chaîne valide représentant le nom de l'événement à exécuter.
Renvoie
Vide
Application

Modèle

Objet
Modèle de formulaire
exclGroup
field
subform
Exemples
JavaScript
Button1.execEvent("click");
FormCalc
Button1.execEvent("click")


execInitialize

Exécute le script d'initialisation du champ.
Syntaxe
Reference_Syntax.execInitialize()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle de formulaire
exclGroup
field
formulaire
subform
Exemples
JavaScript
Subform1.execInitialize();
FormCalc
Subform1.execInitialize()


execute

Exécute une connexion.
Syntaxe
Reference_Syntax.execute( BOOLEAN param )
Paramètres
param
      •
      True(Par défaut)
Impose une nouvelle fusion de la conception de formulaire et des données WSDL importées.
      •
      False
Importe les données WSDL dans le formulaire actif sans le fusionner à la conception de formulaire.
Renvoie
True si la connexion a été établie et false dans le cas contraire.
Application

Modèle

Objet
Modèle connectionSet
wsdlConnection


execValidate

Exécute le script de validation du champ.
Syntaxe
Reference_Syntax.execValidate()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle de formulaire
field
formulaire
subform
Exemples
JavaScript
NumericField1.execValidate();
FormCalc
NumericField1.execValidate()


exportData

Exporte dans un fichier les données contenues dans le formulaire actif au format XDP ou XML.
Pour des raisons de sécurité, si vous fournissez le premier paramètre, la méthode exportData s'exécute uniquement sur des documents certifiés. Si vous n'indiquez pas le premier paramètre, le document ne doit pas nécessairement être certifié, et l'utilisateur est invité à fournir un emplacement et un nom de fichier.
Syntaxe
Reference_Syntax.exportData( [ STRING param1 [, BOOLEAN param2 ] ])
Paramètres
param1 (facultatif)
Indique l'emplacement et le nom du fichier vers lequel les données seront exportées. Si vous omettez ce paramètre, une boîte de dialogue invite l'utilisateur à sélectionner le fichier manuellement.
ce paramètre s'applique uniquement à des documents certifiés pour lesquels l'utilisateur dispose des autorisations adéquates.
param2 (facultatif)
Indique le format d'exportation des données.
      •
      True (Par défaut)
Exporte au format XDP.
      •
      False
Exporte des données XML standard.
pour changer de type d'exportation sans préciser de nom de fichier, vous devez fournir une chaîne vide comme premier paramètre. Par exemple :
xfa.host.exportData("",0)
Renvoie
Vide
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.exportData("filename.xdp");
FormCalc
xfa.host.exportData("filename.xdp")


first

Accède au premier enregistrement dans le jeu d'enregistrements et remplit le modèle de données avec les données d'enregistrement.
la méthode de connexion aux données xfa.sourceSet.DataConnection.first recherche un tableau et le met à jour en cas de modification des données. Elle utilise la méthode hasDataChanged afin de déterminer si les données ont changé.
Syntaxe
Reference_Syntax.first()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle sourceSet
source
Exemples
JavaScript
xfa.sourceSet.dataConnectionName.first();
FormCalc
xfa.sourceSet.dataConnectionName.first()


formNodes

Renvoie la liste de tous les objets de modèle du formulaire liés à un objet de données spécifié.
Syntaxe
Reference_Syntax.formNodes( OBJECT param )
Paramètres
param
Expression de syntaxe de référence valide représentant un objet de modèle de données.
Renvoie
Un objet représentant la liste des objets de modèle du formulaire partageant une relation avec l'objet de données spécifié.
Application

Modèle

Objet
Modèle de formulaire
formulaire


getAttribute

Récupère une valeur de propriété spécifiée.
Syntaxe
Reference_Syntax.getAttribute( STRING param )
Paramètres
param
Chaîne valide représentant le nom de la propriété à récupérer.
Renvoie
Chaîne valide représentant la valeur de la propriété.
Application

Modèle

Objet
Modèle XFA
packet
S'applique également à la classe de node.
Exemples
JavaScript
var sBOFBackup = oDB.nodes.item(nIndex).query.recordSet.getAttribute("bofAction");
FormCalc
var sBOFBackup = oDB.nodes.item(nIndex).query.recordSet.getAttribute("bofAction")


getElement

Renvoie une propriété d'objet spécifiée.
Syntaxe
Reference_Syntax.getElement( STRING param1 [, INTEGER param2 ] )
Paramètres
param1 | Chaîne valide représentant le nom de l'objet à récupérer.
param2 (facultatif) | Valeur entière représentant l'instance de l'objet à récupérer.
Renvoie
L'objet spécifié.
Application
Classe de node


gotoRecord

Déplace l'enregistrement actif de la fenêtre de données vers un enregistrement particulier dans la plage d'enregistrements des données.
Syntaxe
Reference_Syntax.gotoRecord( INTEGER param )
Paramètres
param
Valeur entière représentant l'enregistrement spécifié dans la plage des enregistrements.
Renvoie
Vide
Application

Modèle

Objet
Modèle de données
dataWindow
Exemples
JavaScript
xfa.dataWindow.gotoRecord(2);
FormCalc
xfa.dataWindow.gotoRecord(2)


gotoURL

Récupère l'URL spécifié. Cette méthode est uniquement disponible pour les applications client.
Syntaxe
Reference_Syntax.gotoURL( STRING param1 [, BOOLEAN param2 ] )
Paramètres
param1
Chaîne valide représentant un URL complet ou relatif. Il est possible d'inclure une chaîne de requête à la fin de l'URL.
Si le formulaire est affiché par le biais d'un navigateur ou si Acrobat Capture® n'est pas disponible, le module externe Weblink récupère l'URL demandé. Si le formulaire est exécuté depuis Acrobat, l'URL du document actif est alors obtenu à partir de l'URL de base du document, de l'URL de la page 0 (dans le cas d'un document capturé à l'aide de Web Capture) ou à partir du système de fichiers.
param2 (facultatif)
      •
      True (par défaut)
Ajoute les pages obtenues au document actif.
      •
      False
Cet indicateur est faux si le document est ouvert à partir d'un navigateur Web, si le module externe Acrobat Capture n'est pas disponible ou encore si l'URL est de type « file: ».
Renvoie
Vide
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.gotoURL("http://www.adobe.com");
FormCalc
xfa.host.gotoURL("http://www.adobe.com")


h

Détermine la hauteur d'un objet de conception de formulaire donné.
Syntaxe
Reference_Syntax.h( OBJECT param1 [, STRING param2 [, INTEGER param3 ] ] )
Paramètres
param1 | Expression de syntaxe de référence complète de l'un des objets conteneur de conception de formulaire suivants : champ, dessin, sous-formulaire, zone, zone de page, zone de contenu.
param2 (facultatif) | Chaîne représentant le type d'unité de la valeur renvoyée. Si le paramètre est vide, le type d'unité par défaut est points.
param3 (facultatif) | Entier représentant la valeur de décalage appliquée à la hauteur d'un objet de conception de formulaire en commençant par la première page sur laquelle apparaît l'objet. Si aucune valeur n'est définie, la valeur par défaut est 0.
Renvoie
Hauteur de l'objet de conception de formulaire
Application

Modèle

Objet
Modèle de disposition
layoutPseudoModel
Exemples
JavaScript
xfa.layout.h(TextField1,"in");
FormCalc
xfa.layout.h(TextField1,"in")


hasDataChanged

Détermine si les données de l'enregistrement actuel ont été modifiées. Il s'agit d'un test de pré-validation de l'enregistrement actif. Il compare les données de l'enregistrement actuel avec les données d'enregistrement de la source de données active. Si les données ont changé, cette méthode renvoie la valeur true.
la méthode de connexion aux données xfa.sourceSet.DataConnection.first, xfa.sourceSet.DataConnection.next, xfa.sourceSet.DataConnection.previous, et xfa.sourceSet.DataConnection.last réalise une mise à jour implicite en cas de modification des données.
Syntaxe
Reference_Syntax.hasDataChanged()
Paramètres
Non
Renvoie
True si les données ont été modifiées et false dans le cas contraire.
Application

Modèle

Objet
Modèle sourceSet
source


importData

Importe les données d'un fichier spécifié dans le formulaire actif.
Pour des raisons de sécurité, si vous fournissez le paramètre, la méthode importData s'exécute uniquement sur des documents certifiés. Si vous n'indiquez pas le paramètre, le document ne doit pas nécessairement être certifié, et l'utilisateur est invité à fournir un emplacement et un nom de fichier.
Syntaxe
Reference_Syntax.importData( [ STRING param ] )
Paramètres
param (facultatif)
Chaîne valable représentant l'emplacement et le nom du fichier à partir duquel les données seront importées. Si vous omettez ce paramètre, une boîte de dialogue invite l'utilisateur à sélectionner le fichier manuellement.
ce paramètre s'applique uniquement à des documents certifiés, pour lesquels l'utilisateur dispose des autorisations adéquates.
Renvoie
Vide
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.importData("filename.xdp");
FormCalc
xfa.host.importData("filename.xdp")


insert

Insère un nœud avant un nœud spécifique dans la liste des nœuds.
Syntaxe
Reference_Syntax.insert( OBJECT param1, OBJECT param2 )
Paramètres
param1 | Expression de syntaxe de référence valide représentant le nœud à insérer.
param2 | Expression de syntaxe de référence valide représentant le nœud précédant le nœud à insérer.
Renvoie
Vide
Application
Classe de treeList
Exemples
JavaScript
xfa.datasets.connectionData.DataConnection.nodes.insert(oHeader,oFirst);
FormCalc
xfa.datasets.connectionData.DataConnection.nodes.insert(oHeader,oFirst)


insertInstance

Insère une nouvelle instance d'un sous-formulaire ou d'un jeu de sous-formulaires à un formulaire.
Syntaxe
Reference_Syntax.insertInstance( INTEGER param1 [, BOOLEAN param2 ] )
Paramètres
param1
Entier spécifiant la position de l'index à base zéro pour insérer l'instance au sein d'un jeu d'instances.
param2
(facultatif)
Valeur booléenne indiquant si les données doivent être fusionnées avec la nouvelle instance de sous-formulaire.
      •
      True
Fusionne la nouvelle instance de sous-formulaire avec les données disponibles.
      •
      False
La nouvelle instance de sous-formulaire n'est pas fusionnée avec les données.
Renvoie
Objet représentant la nouvelle instance du sous-formulaire ou du jeu de sous-formulaires.
Application

Modèle

Objet
Modèle sourceSet
source
Exemples
JavaScript
Subform1.instanceManager.insertInstance(3, false);
FormCalc
Subform1.instanceManager.insertInstance(3, false)


isBOF

Détermine si l'emplacement actuel se trouve au début du jeu d'enregistrements.
la propriété bofAction doit être définie sur stayBOF.
Syntaxe
Reference_Syntax.isBOF()
Paramètres
Non
Renvoie
True si l'emplacement actuel se trouve au début du jeu d'enregistrements et False dans le cas contraire.
Application

Modèle

Objet
Modèle sourceSet
source
Exemples
JavaScript
xfa.sourceSet.nodes.item(nIndex).isBOF();
FormCalc
xfa.sourceSet.nodes.item(nIndex).isBOF()


isCompatibleNS

Détermine si un espace de noms spécifié fonctionne, c'est-à-dire est compatible avec l'espace de noms de ce modèle. Détermine si les deux espaces de noms sont équivalents, même si les chaînes qui les représentent ne le sont pas.
Syntaxe
Reference_Syntax.isCompatibleNS( STRING param )
Paramètres
param
Chaîne valide représentant l'espace de nom à comparer
Renvoie
True si les deux espaces de noms sont équivalents et False s'ils ne sont pas compatibles.
Application
Classe de model


isEOF

Détermine si l'emplacement actuel se trouve à la fin du jeu d'enregistrements.
la propriété eofAction doit être définie sur stayEOF.
Syntaxe
Reference_Syntax.isEOF()
Paramètres
Non
Renvoie
True si l'emplacement actuel se trouve à la fin du jeu d'enregistrements et False dans le cas contraire.
Application

Modèle

Objet
Modèle sourceSet
source
Exemples
JavaScript
xfa.sourceSet.nodes.item(nIndex).isEOF();
FormCalc
xfa.sourceSet.nodes.item(nIndex).isEOF()


isPropertySpecified

Vérifie si une propriété spécifique a été définie pour ce nœud.
Syntaxe
Reference_Syntax.isPropertySpecified( STRING param1 [, BOOLEAN param2 [, INTEGER param3 ] ] )
Paramètres
param1
Chaîne valide représentant le nom de la propriété de l'objet à rechercher.
param2 (facultatif)
Valeur booléenne indiquant si l'héritage des classes parent doit être pris en compte.
      •
      True (par défaut)
Détermine si cette propriété est hérité d'une classe parent.
      •
      False
Détermine si cette propriété est définie pour l'objet actif, quel que soit l'héritage éventuel.
param3 (facultatif)
Valeur entière spécifiant l'occurrence de la propriété à examiner. Ce paramètre est seulement valide pour les propriétés possédant plusieurs occurrences.
Renvoie
True si la propriété est spécifiée et false dans le cas contraire.
Application
Classe de node
Exemples
JavaScript
TextField1.isPropertySpecified("ui");
FormCalc
TextField1.isPropertySpecified("ui")


isRecordGroup

Indique si un objet dataGroup particulier est également un enregistrement unique.
Syntaxe
Reference_Syntax.isRecordGroup( OBJECT param )
Paramètres
param
Objet dataGroup valide issu de la source de données actuelles.
Renvoie
True si le groupe de données spécifié est également un enregistrement unique et false dans le cas contraire.
Application

Modèle

Objet
Modèle de données
dataWindow
Exemples
JavaScript
xfa.dataWindow.isRecordGroup(xfa.datasets.data.dataNodeName);
FormCalc
xfa.dataWindow.isRecordGroup(xfa.datasets.data.dataNodeName)


item

Décrit un index à base zéro dans la collection.
Syntaxe
Reference_Syntax.item( INTEGER param )
Paramètres
param
Index à base zéro dans la collection.
Renvoie
Un objet représentant une arborescence XFA.
Application
Classe de treeList


last

Accède au dernier enregistrement dans le jeu d'enregistrements et remplit le modèle de données avec les données d'enregistrement.
la méthode de connexion aux données xfa.sourceSet.DataConnection.last recherche un tableau et le met à jour en cas de modification des données. Elle utilise la méthode hasDataChanged afin de déterminer si les données ont changé.
Syntaxe
Reference_Syntax.last()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle sourceSet
source
Exemples
JavaScript
xfa.sourceSet.dataConnectionName.last();
FormCalc
xfa.sourceSet.dataConnectionName.last()


loadXML

Charge et ajoute un document XML spécifié à l'objet actif.
Syntaxe
Reference_Syntax.EMPTY loadXML( STRING param1 [, BOOLEAN param2 [, BOOLEAN param3 ] ] )
Paramètres
param1
Chaîne valide représentant le nom du document XML.
param2 (facultatif)
Valeur booléenne indiquant si le nœud racine au sein du document XML doit être ignoré.
      •
      True (par défaut)
Ignore le nœud racine du document XML et ajoute les autres nœuds XML directement dans l'objet Modèle d'objet de formulaire XML.
      •
      False
Ajoute le nœud racine du document XML directement à l'objet Modèle d'objet de formulaire XML actif.
param3 (facultatif)
Valeur booléenne indiquant si les données issues du document XML doivent remplacer les informations de l'objet Modèle d'objet de formulaire XML actif.
      •
      True
Remplace le contenu de l'objet Modèle d'objet de formulaire XML actif par les données du document XML.
      •
      False (par défaut)
Ajoute les données du document XML à l'objet Modèle d'objet de formulaire XML actif.
Renvoie
Vide
Application
Classe de node
Exemples
JavaScript
xfa.datasets.data.loadXML(xmlData,0,1);
FormCalc
xfa.datasets.data.loadXML(xmlData,0,1)


messageBox

Affiche à l'écran une boîte de dialogue. Cette méthode est uniquement disponible pour les applications client.
Syntaxe
Reference_Syntax.messageBox( STRING param1 [, STRING param2 [, INTEGER param3 [, INTEGER param4 ] ] ] )
Paramètres
param1
Chaîne valable représentant le message à afficher.
param2 (facultatif)
Chaîne valable représentant le titre à afficher sur la barre de titre de la boîte de dialogue.
param3 (facultatif)
Entier représentant l'icône à afficher dans la boîte de dialogue.
      •
      0 (Erreur) - Il s'agit de la valeur par défaut.
      •
      1 (Avertissement)
      •
      2 (Question)
      •
      3 (Etat)
param4 (facultatif)
Entier représentant les boutons à afficher.
      •
      0 (OK) - Il s'agit de la valeur par défaut.
      •
      1 (OK, Annuler)
      •
      2 (Oui, Non)
      •
      3 (Oui, Non, Annuler)
Renvoie
Entier valide représentant la valeur du bouton activé par l'utilisateur :
      •
      1 (OK)
      •
      2(Annuler)
      •
      3(Non)
      •
      4(Oui)
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.messageBox("This is a message", 3, 1);
FormCalc
xfa.host.messageBox("This is a message", 3, 1)


moveCurrentRecord

Place l'enregistrement actif dans un autre emplacement dans la plage des enregistrements.
Syntaxe
Reference_Syntax.moveCurrentRecord( INTEGER param )
Paramètres
param
Entier valide représentant le nombre d'enregistrements séparant l'enregistrement actif de l'enregistrement cible voulu. Une valeur positive indique un enregistrement situé entre l'enregistrement actif et la fin de la plage des enregistrements, une valeur négative indique un enregistrement entre l'enregistrement actif et le début de la plage.
Renvoie
Vide
Application

Modèle

Objet
Modèle de données
dataWindow
Exemples
JavaScript
xfa.dataWindow.moveCurrentRecord(1);
FormCalc
xfa.dataWindow.moveCurrentRecord(1)


moveInstance

Déplace un objet de subform au sein d'un jeu d'instances de sous-formulaire.
Les informations du modèle de données correspondantes sont également déplacées dans le modèle de données.
Syntaxe
Reference_Syntax.moveInstance( INTEGER param1, INTEGER param2 )
Paramètres
param1 | Entier valide représentant la position de l'index à base 0 de l'objet de modèle de formulaire à déplacer.
param2 | Entier valide représentant la position à base 0 de l'objet enfant au sein du jeu des instances.
Renvoie
Vide
Application

Modèle

Objet
Modèle de formulaire
instanceManager
Exemples
JavaScript
Subform1.instanceManager.moveInstance(0,6);
FormCalc
Subform1.instanceManager.moveInstance(0,6)


namedItem

Récupère le premier enfant du nœud portant le nom donné.
Syntaxe
Reference_Syntax.namedItem( STRING param )
Paramètres
param
Chaîne valide représentant le nom de ce nœud.
Renvoie
Objet représentant le premier enfant de ce nœud portant le nom donné.
Application
Classe de treeList


next

Accède à l'enregistrement suivant dans le jeu d'enregistrements et remplit le modèle de données avec les données d'enregistrement.
la méthode de connexion aux données xfa.sourceSet.DataConnection.next recherche un tableau et le met à jour en cas de modification des données. Elle utilise la méthode hasDataChanged afin de déterminer si les données ont changé.
Syntaxe
Reference_Syntax.next()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle sourceSet
source
Exemples
JavaScript
xfa.sourceSet.dataConnectionName.next();
FormCalc
xfa.sourceSet.dataConnectionName.next()


open

Etablit la connexion à la source de données et remplit le modèle de données avec les résultats de l'enregistrement actuel.
Syntaxe
Reference_Syntax.open()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle sourceSet
source
Exemples
JavaScript
xfa.sourceSet.nodes.item(nIndex).open();
FormCalc
xfa.sourceSet.nodes.item(nIndex).open()


openList

Ouvre une liste déroulante spécifiée par l'expression de syntaxe de référence. Cette méthode est uniquement disponible pour les applications client.
Syntaxe
Reference_Syntax.openList( STRING param )
Paramètres
param
Expression de syntaxe de référence complète spécifiant une liste déroulante.
Renvoie
Vide
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel


page

Détermine le numéro de page où figure l'objet de conception de formulaire donné. Dans le cas d'un objet occupant plusieurs pages, cette méthode renvoie la première page.
Syntaxe
Reference_Syntax.page( OBJECT param )
Paramètres
param
Expression de syntaxe de référence complète de l'un des objets conteneur de conception de formulaire suivants : champ, dessin, sous-formulaire, zone, zone de page, zone de contenu.
Renvoie
Entier représentant le nombre de pages contenant l'objet de conception de formulaire spécifié. Cette méthode renvoie la valeur 0 si l'objet spécifié dans param est introuvable sur le formulaire.
Application

Modèle

Objet
Modèle de disposition
layoutPseudoModel
Exemples
JavaScript
xfa.layout.page(this);
FormCalc
xfa.layout.page($)


pageContent

Récupère les types d'objet de conception de formulaire à partir d'une page donnée d'un formulaire.
Syntaxe
Reference_Syntax.pageContent( INTEGER param1 [, STRING param2 [, BOOLEAN param3 ] ] )
Paramètres
param1
Entier représentant le nombre de pages souhaité. Il s'agit d'une valeur à base 0.
param2 (facultatif)
Renvoie les types suivants de conteneur :
      •
      field
Renvoie tous les objets de conception de formulaire suivants : bouton, case à cocher, champ date et heure, liste déroulante, champ de signature du document, champ d'image, zone de liste, champ numérique, champ de mot de passe, bouton radio et champ de texte.
      •
      draw
Renvoie tous les objets de conception de formulaire suivants : cercle, ligne et rectangle, image statique et texte statique.
      •
      subform
Renvoie tous les objets de conception de sous-formulaire.
      •
      area
Renvoie tous les objets de conception de formulaire associés à une zone.
      •
      pageArea
Renvoie tous les objets de conception de sous-formulaire associés à la zone de page.
      •
      contentArea
Renvoie tous les objets de conception de formulaire associés à la zone de contenu.
      •
      empty (par défaut)
Renvoie tous les conteneurs.
param3 (facultatif)
      •
      True (par défaut)
Renvoie seulement les nœuds de contenu de zone de page.
      •
      False
Renvoie tous les nœuds de contenu hormis les nœuds de contenu de zone de page.
Renvoie
Collection d'objets de conception de formulaire à partir du numéro de page spécifié.
Application

Modèle

Objet
Modèle de disposition
layoutPseudoModel
Exemples
JavaScript
// Get the fields in a document
var oFields = xfa.layout.pageContent(i, "field");
FormCalc
// Get the fields in a document
var oFields = xfa.layout.pageContent(i, "field")


pageCount

Détermine le nombre de pages du formulaire actuel.
Syntaxe
Reference_Syntax.pageCount()
Paramètres
Non
Renvoie
Entier représentant le nombre total de pages du formulaire.
Application

Modèle

Objet
Modèle de disposition
layoutPseudoModel
Exemples
JavaScript
xfa.layout.pageCount();
FormCalc
xfa.layout.pageCount()


pageDown

Atteint la page suivante d'un formulaire. Utilise la méthode pageDown lors de l'exécution.
Syntaxe
Reference_Syntax.pageDown()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.pageDown();
FormCalc
xfa.host.pageDown()


pageSpan

Détermine le nombre de pages logiques utilisé par un objet de conception de formulaire donné.
Syntaxe
Reference_Syntax.pageSpan( OBJECT param )
Paramètres
param
Expression de syntaxe de référence complète de l'un des objets conteneur de conception de formulaire suivants : champ, dessin, sous-formulaire, zone, zone de page, zone de contenu.
Renvoie
Entier représentant le nombre total de pages du formulaire.
Application

Modèle

Objet
Modèle de disposition
layoutPseudoModel
Exemples
JavaScript
xfa.layout.pageSpan(this);
FormCalc
xfa.layout.pageSpan($)


pageUp

Atteint la page précédente d'un formulaire. Utilise la méthode pageUp lors de l'exécution.
Syntaxe
Reference_Syntax.pageUp()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.pageUp();
FormCalc
xfa.host.pageUp()


previous

Accède à l'enregistrement précédent dans le jeu d'enregistrements et remplit le modèle de données avec les données d'enregistrement.
la méthode de connexion aux données xfa.sourceSet.DataConnection.previous recherche un tableau et le met à jour en cas de modification des données. Elle utilise la méthode hasDataChanged afin de déterminer si les données ont changé.
Syntaxe
Reference_Syntax.previous()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle sourceSet
source
Exemples
JavaScript
xfa.sourceSet.dataConnectionName.previous();
FormCalc
xfa.sourceSet.dataConnectionName.previous()


print

Imprime un nombre de pages spécifique à partir d'un document. Cette méthode est uniquement disponible pour les applications client.
Syntaxe
Reference_Syntax.print( BOOLEAN param1, INTEGER param2, INTEGER param3, BOOLEAN param4, BOOLEAN param5, BOOLEAN param6, BOOLEAN param7, BOOLEAN param8 )
Paramètres
param1
      •
      True (par défaut)
Affiche une boîte de dialogue d'impression et invite l'utilisateur à préciser les informations de configuration de l'impression et à confirmer l'opération.
      •
      False
N'affiche pas de boîte de dialogue d'impression. L'impression démarre sans que l'utilisateur n'ait à fournir d'informations ni à confirmer l'opération.
param2
Chaîne valide représentant le numéro de la première page de la série à imprimer. Les valeurs de page étant calculées sur la base 0, vous devez représenter la page 1 par la valeur 0.
La page de début est incluse dans la série à imprimer.
param3
Chaîne valide représentant le numéro de la dernière page de la série à imprimer. Les valeurs de page étant calculées sur la base 0, vous devez représenter la page 1 par la valeur 0.
La page de fin est incluse dans la série à imprimer.
param4
      •
      True (par défaut)
N'affiche pas de boîte de dialogue permettant d'annuler l'impression en cours.
      •
      False
Affiche une boîte de dialogue permettant d'annuler l'impression en cours.
param5
      •
      True (par défaut)
Réduit la page (si nécessaire) afin de l'ajuster à la zone visible de la page imprimée.
      •
      False
Ne réduit pas la page afin de l'ajuster à la zone visible de la page imprimée.
param6
      •
      True (par défaut)
Imprime chaque page sous forme d'image.
      •
      False
Imprime chaque page comme une page de texte.
param7
      •
      True (par défaut)
Imprime les pages en ordre inverse.
      •
      False
Imprime les pages dans l'ordre.
param8
      •
      True (par défaut)
Imprime toutes les annotations.
      •
      False
N'imprime pas les annotations.
Renvoie
Vide
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.print(1, "0", "0", 0, 1, 0, 0, 0);
FormCalc
xfa.host.print(1, "0", "0", 0, 1, 0, 0, 0)


recalculate

Force l'exécution d'un jeu spécifique de scripts sur des événements de calculs. Les événements spécifiques peuvent être des événements de calculs en attente ou l'intégralité des événements de calculs.
Syntaxe
Reference_Syntax.recalculate( BOOLEAN param )
Paramètres
param
Une valeur booléenne indique les scripts de calcul à exécuter.
      •
      True (par défaut)
Tous les scripts de calcul sont réexécutés.
      •
      False
Seuls les scripts de calcul en attente sont à exécuter.
Renvoie
Vide
Application

Modèle

Objet
Modèle de formulaire
formulaire
template
Exemples
JavaScript
xfa.form.recalculate(1);
FormCalc
xfa.form.recalculate(1)


record

Renvoie un enregistrement dans une position relative à l'enregistrement actif.
Syntaxe
Reference_Syntax.record( INTEGER param )
Paramètres
param
Entier valide représentant le nombre d'enregistrements séparant l'enregistrement actif de l'enregistrement cible voulu. Une valeur positive indique un enregistrement situé entre l'enregistrement actif et la fin de la plage des enregistrements, une valeur négative indique un enregistrement entre l'enregistrement actif et le début de la plage.
Renvoie
Objet
Application

Modèle

Objet
Modèle de données
dataWindow
Exemples
JavaScript
xfa.dataWindow.record(0).dataNodeName.value;
FormCalc
xfa.dataWindow.record(0).dataNodeName.value


relayout

Applique à nouveau les options de disposition au formulaire actif.
Syntaxe
Reference_Syntax.relayout()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle de disposition
layoutPseudoModel
Exemples
JavaScript
xfa.layout.relayout();
FormCalc
xfa.layout.relayout()


relayoutPageArea

Remplace la disposition du contenu de l'objet pageArea par une nouvelle disposition.
Syntaxe
Reference_Syntax.relayoutPageArea( [ INTEGER param ] )
Paramètres
param (facultatif)
Numéro de la page à substituer. Les valeurs de numéro de page sont à base 0.
Renvoie
Vide
Application

Modèle

Objet
Modèle de disposition
layoutPseudoModel
Exemples
JavaScript
xfa.layout.relayoutPageArea(0);
FormCalc
xfa.layout.relayoutPageArea(0)


remerge

Force la fusion des modèles de données et la conception de modèle pour recréer un modèle de formulaire. Une fois la fusion effectuée, tout traitement de modèle de disposition doit être à nouveau effectué pour déterminer le formulaire.
Syntaxe
Reference_Syntax.remerge()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle de formulaire
formulaire
Exemples
JavaScript
xfa.form.remerge();
FormCalc
xfa.form.remerge()


remove

Supprime un nœud de la liste.
Syntaxe
Reference_Syntax.remove( OBJECT param )
Paramètres
param
Expression de syntaxe de référence valide représentant le nœud à supprimer.
Renvoie
Vide
Application
Classe de treeList
Exemples
JavaScript
xfa.record.nodes.remove(oNode);
FormCalc
xfa.record.nodes.remove(oNode)


removeAttribute

Supprime la propriété spécifiée.
Syntaxe
Reference_Syntax.removeAttribute( STRING param )
Paramètres
param
Chaîne valide représentant le nom de la propriété à supprimer.
Renvoie
Vide
Application

Modèle

Objet
Modèle XFA
packet


removeInstance

Supprime un sous-formulaire ou un jeu de sous-formulaires spécifique du modèle de formulaire.
Lors de la suppression d'une instance de sous-formulaire, évitez les violations d'occurrences de sous-formulaire. En effet, vous ne pouvez pas supprimer d'instance de sous-formulaire lorsque le nombre minimum d'instances a été atteint. Lorsque cette valeur minimale est atteinte pour un sous-formulaire, le débogueur JavaScript affiche un message d'erreur :
The element [min] has violated its allowable number of occurrences.
Si l'utilisateur final est autorisé à supprimer toutes les instances d'un sous-formulaire, réinitialisez le nombre minimum d'instances sur la valeur 0 avant de tenter de supprimer une instance. A défaut, le script empêchera toute tentative de suppression d'instances de sous-formulaire en deçà du nombre minimum.
Syntaxe
Reference_Syntax.removeInstance( INTEGER param )
Paramètres
param
Entier valide représentant la position de l'index sur la base de 0 au sein d'un modèle de formulaire pour le sous-formulaire ou jeu de sous-formulaires à supprimer.
Renvoie
Vide
Application

Modèle

Objet
Modèle de formulaire
instanceManager
Exemples
JavaScript
Subform2.instanceManager.removeInstance(3);
FormCalc
Subform2.instanceManager.removeInstance(3)


requery

Met à jour la liaison active des données en exécutant à nouveau la requête sur laquelle reposent les données d'objet. L'appel de cette méthode équivaut à appeler les méthodes close et open l'une après l'autre.
Syntaxe
Reference_Syntax.requery()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle sourceSet
source


reset

Réinitialise toutes les propriétés dans le modèle d'événements du formulaire XML.
Syntaxe
Reference_Syntax.reset()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle d'événement
eventPseudoModel
Exemples
JavaScript
xfa.event.reset();
FormCalc
xfa.event.reset()


resetData

Rétablit les valeurs par défaut des champs dans un document.
Syntaxe
Reference_Syntax.resetData([ STRING param ])
Paramètres
param
(Facultatif)
Chaîne valide répertoriant soit les noms soit les expressions de syntaxe de référence équivalentes des champs à réinitialiser. Les entrées de liste sont délimitées par le caractère , (virgule). Si la chaîne est absente ou vide, tous les champs du formulaire sont réinitialisés selon leur valeur par défaut.
Renvoie
Vide
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.resetData("xfa.form.form1.TextField1,xfa.form.form1.TextField2");
FormCalc
xfa.host.resetData("xfa.form.form1.TextField1,xfa.form.form1.TextField2")


resolveNode

Evalue l'expression de syntaxe de référence spécifiée, en commençant par l'objet modèle de l'objet de formulaire XML actif et renvoie la valeur de l'objet spécifié dans l'expression de syntaxe de référence.
La recherche d'un objet commence à un point différent dans la hiérarchie de formulaires, selon le mode utilisé pour accéder à la propriété resolveNode :
      •
      this.resolveNode() La recherche commence à partir de l'objet actif et remonte la hiérarchie de formulaires.
      •
      xfa.resolveNode() La recherche commence en haut de la hiérarchie de formulaires et progresse vers le bas.
la recherche peut renvoyer des résultats inattendus si le formulaire contient plusieurs objets utilisant le même nom. Elle renvoie la valeur du premier objet trouvé.
Syntaxe
Reference_Syntax.resolveNode( STRING param )
Paramètres
param
Chaîne valide représentant une expression de syntaxe de référence renvoyant un objet de modèle d'objet de formulaire XML spécifique.
Renvoie
Objet unique correspondant à l'expression de syntaxe de référence (s'il existe). En l'absence d'un tel objet, cette méthode renvoie la chaîne null.
Application
Classe de tree
Exemples
JavaScript
xfa.resolveNode("#subform").x = "2in";

TextField1.resolveNode("ui.#textEdit").border.edge.stroke = "lowered";


resolveNodes

Evalue l'expression de syntaxe de référence spécifiée, en commençant par l'objet modèle de l'objet de formulaire XML actif et renvoie la valeur de l'objet ou des objets spécifiés dans l'expression de syntaxe de référence.
La recherche d'un objet commence à un point différent dans la hiérarchie de formulaires, selon le mode utilisé pour accéder à la propriété resolveNode :
      •
      this.resolveNodes() La recherche commence à partir de l'objet actif et remonte la hiérarchie de formulaires.
      •
      xfa.resolveNodes() La recherche commence en haut de la hiérarchie de formulaires et progresse vers le bas.
la recherche peut renvoyer des résultats inattendus si le formulaire contient plusieurs objets utilisant le même nom. Elle renvoie la valeur du premier objet trouvé.
Syntaxe
Reference_Syntax.resolveNodes( STRING param )
Paramètres
param
Chaîne valide représentant une expression de syntaxe de référence renvoyant à un ou plusieurs objets de modèle d'objet de formulaire XML spécifiques.
Renvoie
Un ou plusieurs objets correspondants à l'expression de syntaxe de référence, si de tels objets existent. En l'absence de tels objets, cette méthode renvoie la chaîne null.
Application
Classe de tree
Exemples
JavaScript
xfa.resolveNodes("Subform1[*]");
FormCalc
xfa.resolveNodes("Subform1[*]")


response

Affiche une boîte de dialogue contenant une question et un champ d'entrée permettant à l'utilisateur de répondre à la question. La valeur renvoyée est une chaîne contenant la réponse de l'utilisateur. Si l'utilisateur clique sur le bouton Annuler dans la boîte de dialogue, la réponse est nulle.
Syntaxe
Reference_Syntax.response(STRING param1 [, STRING param2 [, STRING param3 [, BOOLEAN param4 ] ] ])
Paramètres
param1
Chaîne valide représentant une question adressée à l'utilisateur.
param2 (facultatif)
Chaîne valide représentant le titre figurant sur la barre de titre de la boîte de dialogue.
param3 (facultatif)
Chaîne valide représentant la valeur par défaut de la réponse à la question.
param4 (facultatif)
      •
      True (par défaut)
Masque la réponse de l'utilisateur par un * (astérisque).
      •
      False
Ne masque pas la réponse de l'utilisateur.
Renvoie
Chaîne représentant la réponse de l'utilisateur. Si l'utilisateur clique sur le bouton Annuler dans la boîte de dialogue, la réponse correspond à l'objet nul.
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.response("Question", "Title", "Default Value");
FormCalc
xfa.host.response("Question", "Title", "Default Value")


resync

Actualise le jeu d'enregistrements ou la connexion aux données actif.
Syntaxe
Reference_Syntax.resync()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle sourceSet
source


saveFilteredXML

Enregistre le nœud actif dans une chaîne, mais inclut uniquement un jeu partiel des nœuds enfant.
Syntaxe
Reference_Syntax.saveFilteredXML( OBJECT param1 [, STRING param2 ] )
Paramètres
param1 | Objet Manifest décrivant le sous-jeu de nœuds à inclure dans la chaîne.
param2 (Facultatif) | Chaîne valide représentant la méthode d'impression de la chaîne XML obtenue. Par exemple, utilisez pretty pour imprimer la chaîne XML résultante en mode pretty-print (enjolivement).
Renvoie
Chaîne valide représentant le fragment XML incluant uniquement le jeu partiel spécifié du nœud actif.
Application
classe node


saveXML

Enregistre le nœud actif dans une chaîne.
Syntaxe
Reference_Syntax.saveXML()
Paramètres
Non
Renvoie
Une chaîne valable représentant le fragment XML de l'objet actif.
Application
Classe de node
Exemples
JavaScript
xfa.data.saveXML();
FormCalc
xfa.data.saveXML()


selectedMember

Renvoie le membre sélectionné d'un groupe d'exclusion.
Syntaxe
Reference_Syntax.selectedMember( [ STRING param ] )
Paramètres
param (facultatif)
Chaîne valide représentant le nom du membre du groupe d'exclusion à condition que celui-ci soit dans la même plage que l'objet de référence. Sinon, chaîne représentant l'expression de syntaxe de référence du membre du groupe d'exclusion à sélectionner.
Renvoie
Objet représentant le membre sélectionné du groupe d'exclusion. Dans LiveCycle Designer, par exemple, cette méthode renverra le bouton radio sélectionné.
Application

Modèle

Objet
Modèle de formulaire
exclGroup


setAttribute

Définit la valeur d'une propriété spécifiée.
Syntaxe
Reference_Syntax.setAttribute( STRING param1, STRING param2 )
Paramètres
param1 | Chaîne valide représentant la nouvelle valeur de la propriété.
param2 | Chaîne valide représentant le nom de la propriété.
Renvoie
Vide
Application

Modèle

Objet
Modèle XFA
packet
S'applique également à la classe de node.


setElement

Définit un objet spécifié sur l'objet actif.
Syntaxe
Reference_Syntax.setElement( OBJECT param1 [, STRING param2 ] )
Paramètres
param1 | Objet représentant le nouvel objet.
param2 (facultatif) | Chaîne valide représentant le nom de l'objet à remplacer.
Renvoie
Vide
Application
Classe de node


setFocus

Définit la sélection au clavier sur le champ défini par l'expression de syntaxe de référence. Cette méthode est uniquement disponible pour les applications client.
Vous ne pouvez pas utiliser setFocus avec le form:ready, layout:ready ou les événements initialize.
Syntaxe
Reference_Syntax.setFocus( STRING param )
Paramètres
param
Chaîne valide représentant une expression de syntaxe de référence complète pour le champ défini comme sélection.
Renvoie
Vide
Application

Modèle

Objet
Modèle d'hôte
hostPseudoModel
Exemples
JavaScript
xfa.host.setFocus("xfa.form.form1.TextField1");
FormCalc
xfa.host.setFocus("xfa.form.form1.TextField1")


setInstance

Ajoute ou supprime les sous-formulaires ou jeux de sous-formulaires spécifiés du modèle de formulaire.
Syntaxe
Reference_Syntax.setInstance( INTEGER param )
Paramètres
param
Entier valide représentant le nombre d'instances voulu d'un sous-formulaire ou d'un jeu de sous-formulaires dans le modèle de formulaire.
Renvoie
Vide
Application

Modèle

Objet
Modèle de formulaire
instanceManager
Exemples
JavaScript
Subform1.instanceManager.setInstances(5);
FormCalc
Subform1.instanceManager.setInstances(5)


sign

Appose une signature à une liste de nœuds donnée et place la signature à l'emplacement cible.
Syntaxe
Reference_Syntax.sign( OBJECT param1, STRING param2, STRING param3 [, STRING param4 [, BOOLEAN param5 [, OBJECT param6 [, OBJECT param7 ] ] ] ] )
Paramètres
param1
entrée
Liste valide des nœuds XFA pour tous les nœuds à signer.
param2
entrée
Chaîne valide représentant une expression de syntaxe de référence du parent du nœud de signature.
param3
entrée
Chaîne valide représentant une valeur d'identification XML de la signature.
param4 (facultatif)
entrée (facultatif)
Chaîne valide indiquant le fonctionnement des nœuds de données signées.
Les valeurs possibles sont :
      •
      open (par défaut)
Les nœuds de données sont ouverts pour modification et peuvent donc être manipulés lorsqu'ils sont exécutés.
      •
      locked
Le nœud de données est verrouillé et ne peut donc pas être manipulé lorsqu'il est exécuté.
param5 (facultatif)
entrée (facultatif)
      •
      True (par défaut)
Indique qu'une boîte de dialogue sert à la réalisation de l'opération.
      •
      False
Indique qu'une boîte de dialogue n'est pas utilisée pour la réalisation de l'opération.
param6 (facultatif)
entrée (facultatif)
Représente l'objet SecurityHandler utilisé pour les opérations de signature. Les objets de sécurité doivent en général être initialisés avant d'être utilisés pour des opérations de signature.
param7 (facultatif)
sortie (facultatif)
Représente l'objet SignatureInfo de sortie contenant les propriétés en écriture de la signature.
Renvoie
True lorsque la signature est apposée et False quand la signature est annulée. Une exception est renvoyée si l'opération de signature échoue.
Application

Modèle

Objet
Modèle de signature
signaturePseudoModel


update

Met à jour l'enregistrement actif dans le jeu d'enregistrements.
Syntaxe
Reference_Syntax.update()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle sourceSet
source
Exemples
JavaScript
xfa.sourceSet.dataConnectionName.update();
FormCalc
xfa.sourceSet.dataConnectionName.update()


updateBatch

Ecrit toutes les mises à jour du lot en attente dans la source de données.
Syntaxe
Reference_Syntax.updateBatch()
Paramètres
Non
Renvoie
Vide
Application

Modèle

Objet
Modèle sourceSet
source


verify

Authentifie la signature.
Syntaxe
Reference_Syntax.verify( OBJECT param1 [, BOOLEAN param2 [, OBJECT param3 [, OBJECT param4 ] ] ] )
Paramètres
param1
entrée
Nœud de signature XML valable.
param2 (facultatif)
entrée (facultatif)
      •
      True (par défaut)
Indique qu'une boîte de dialogue sert à la réalisation de l'opération.
      •
      False
Indique qu'une boîte de dialogue n'est pas utilisée pour la réalisation de l'opération.
param3 (facultatif)
entrée (facultatif)
Objet SecurityHandler utilisé pour les opérations de signature. Les objets de sécurité doivent en général être initialisés avant d'être utilisés pour des opérations de signature.
param4 (facultatif)
sortie (facultatif)
Objet SignatureInfo de sortie contenant les propriétés en écriture de la signature.
Renvoie
Entier représentant la validité de la signature. Le tableau suivant décrit les valeurs valides :

Valeur

Description
-1
Ce nœud n'est pas affecté à une signature.
0
Signature vide.
1
Etat inconnu.
2
Signature non valable.
3
Signature valide, mais l'identité du signataire n'a pas pu être vérifiée.
4
La signature du document et l'identité du signataire sont valides.
Application

Modèle

Objet
Modèle de signature
signaturePseudoModel


w

Détermine la largeur d'un objet de conception de formulaire donné.
Syntaxe
Reference_Syntax.w( OBJECT param1 [, STRING param2 [, INTEGER param3 ] ] )
Paramètres
param1 | Expression de syntaxe de référence complète de l'un des objets conteneur de conception de formulaire suivants : champ, dessin, sous-formulaire, zone, zone de page, zone de contenu.
param2 (facultatif) | Chaîne représentant le type d'unité de la valeur renvoyée. Si le paramètre est vide, le type d'unité par défaut est points.
param3 (facultatif) | Entier représentant le nombre permettant d'ajuster la largeur de l'objet en commençant par la première page sur laquelle l'objet apparaît. Si aucune valeur n'est définie, la valeur par défaut est 0.
Renvoie
Largeur de l'objet de conception de formulaire sous la forme d'un double.
Application

Modèle

Objet
Modèle de disposition
layoutPseudoModel
Exemples
JavaScript
xfa.layout.w(TextField1,"in");
FormCalc
xfa.layout.w(TextField1,"in")


x

Détermine l'abscisse (coordonnée x) d'un objet de conception de formulaire donné.
Syntaxe
Reference_Syntax.x( OBJECT param1 [, STRING param2 [, INTEGER param3 ] ] )
Paramètres
param1 | Expression de syntaxe de référence complète de l'un des objets conteneur de conception de formulaire suivants : champ, dessin, sous-formulaire, zone, zone de page, zone de contenu.
param2 (facultatif) | Chaîne représentant le type d'unité de la valeur renvoyée. Si le paramètre est vide, le type d'unité par défaut est points.
param3 (facultatif) | Entier représentant le nombre de pages de décalage de l'abscisse (coordonnée x) de l'objet en commençant par la première page sur laquelle apparaît l'objet. Si aucune valeur n'est définie, la valeur par défaut est 0.
Renvoie
Abscisse (coordonnée x) de l'objet de conception de formulaire sous la forme d'un double.
Application

Modèle

Objet
Modèle de disposition
layoutPseudoModel
Exemples
JavaScript
xfa.layout.x(TextField1,"in");
FormCalc
xfa.layout.x(TextField1,"in")


y

Détermine l'ordonnée (coordonnée y) d'un objet de conception de formulaire donné.
Syntaxe
Reference_Syntax.y( OBJECT param1 [, STRING param2 [, INTEGER param3 ] ] )
Paramètres
param1 | Expression de syntaxe de référence complète de l'un des objets conteneur de conception de formulaire suivants : champ, dessin, sous-formulaire, zone, zone de page, zone de contenu.
param2 (facultatif) | Chaîne représentant le type d'unité de la valeur renvoyée. Si le paramètre est vide, le type d'unité par défaut est points.
param3 (facultatif) | Entier représentant le nombre de pages de décalage de l'ordonnée (coordonnée y) de l'objet en commençant par la première page sur laquelle apparaît l'objet. Si aucune valeur n'est définie, la valeur par défaut est 0.
Renvoie
Ordonnée (coordonnée y) de l'objet de conception de formulaire sous la forme d'un double.
Application

Modèle

Objet
Modèle de disposition
layoutPseudoModel
Exemples
JavaScript
xfa.layout.y(TextField1,"in");
FormCalc
xfa.layout.y(TextField1,"in")


Guide de référence FormCalc

Introduction à FormCalc
Section de référence sur le langage
Fonctions arithmétiques
Fonctions de date et d’heure
Fonctions financières
Fonctions logiques
Fonctions diverses
Fonctions de chaîne
Fonctions URL


Introduction à FormCalc

A propos de FormCalc
A propos des scripts dans LiveCycle Designer
Liste alphabétique des fonctions


A propos de FormCalc

FormCalc est un langage de calcul simple mais puissant, fondé sur les tableurs traditionnels. Il permet de créer des formulaires, rapidement et efficacement, sans exiger la maîtrise des techniques ou des langages de script traditionnels. A l’aide de quelques fonctions intégrées, les nouveaux utilisateurs de FormCalc peuvent ainsi créer rapidement des formulaires pour éviter aux utilisateurs finaux d’effectuer certaines tâches fastidieuses, telles que les calculs, les validations et autres vérifications. De cette façon, un développeur de formulaires est capable d’intégrer une certaine intelligence à un formulaire au moment de la conception, de façon à ce que le formulaire interactif créé réagisse selon les données entrées.
FormCalc proposent de nombreuses fonctions portant sur des domaines variés, tels que les mathématiques, les dates et heures, les chaînes, la finance, la logique et le Web. Ces catégories représentent les types de données habituellement rencontrées dans les formulaires ; les fonctions permettent de manipuler rapidement et facilement les données à des fins utiles.


A propos des scripts dans LiveCycle Designer

Dans LiveCycle Designer, FormCalc est le langage de script par défaut à tous les emplacements de script ; le langage JavaScript™ constitue l’autre choix possible. Les scripts s’appliquent aux différents événements qui accompagnent chaque objet d’un formulaire. Vous pouvez combiner les langages FormCalc et JavaScript dans vos formulaires interactifs. Toutefois, si vous utilisez un processus serveur, tel que LiveCycle Forms, pour créer des formulaires qui seront affichés dans un navigateur Web, les scripts FormCalc de certains événements rattachés aux objets des formulaires ne sont pas reflétés dans les formulaires HTML. Cette fonctionnalité permet d’éviter des erreurs de navigateur Internet lorsque les utilisateurs manipulent les formulaires remplis.


Liste alphabétique des fonctions

Le tableau suivant contient toutes les fonctions FormCalc, la description de chaque fonction et la catégorie à laquelle elle appartient.

Fonction

Description

Type
Abs
Retourne la valeur absolue d’une valeur ou d’une expression numérique.
Arithmétique
Apr
Renvoie le taux annuel d’un prêt.
Financière
At
Repère la position du premier caractère d’une chaîne dans une autre chaîne.
Chaîne
Avg
Evalue un ensemble de valeurs et/ou d’expressions numériques et renvoie la moyenne des éléments non nuls de cet ensemble.
Arithmétique
Ceil
Renvoie le nombre entier supérieur ou égal au nombre fourni.
Arithmétique
Choose
Sélectionne une valeur dans un ensemble de paramètres donné.
Logique
Concat
Renvoie la concaténation des chaînes indiquées.
Chaîne
Count
Evalue un ensemble de valeurs et/ou d'expressions et renvoie le nombre d'éléments non nuls contenus dans cet ensemble.
Arithmétique
CTerm
Renvoie le nombre de périodes nécessaires pour qu’un investissement, dont le taux d’intérêt est fixe mais composé, atteigne une valeur capitalisée.
Financière
Date
Renvoie la date active du système sous la forme du nombre de jours écoulés depuis l’époque.
Date et heure
Date2Num
Renvoie le nombre de jours écoulés depuis l’époque, à partir d’une chaîne de date.
Date et heure
DateFmt
Renvoie une chaîne de format de date, à partir d'un style de format de date.
Date et heure
Decode
Renvoie la version décodée d'une chaîne donnée.
Chaîne
Encode
Renvoie la version codée d'une chaîne donnée.
Chaîne
Eval
Renvoie la valeur d'un calcul de formulaire donné.
Divers
Exists
Détermine si le paramètre donné est un mécanisme d'accès à un objet existant.
Logique
Floor
Renvoie le plus grand nombre entier inférieur ou égal à la valeur donnée.
Arithmétique
Format
Formate les données fournies selon la chaîne de format d'image indiquée.
Chaîne
FV
Renvoie la valeur capitalisée de paiements fixes effectués à intervalles réguliers, compte tenu d'un taux d’intérêt fixe.
Financière
Get
Télécharge le contenu de l'adresse URL indiquée.
URL
HasValue
Détermine si le paramètre indiqué est un mécanisme d’accès dont la valeur n’est ni nulle, ni vide, ni un blanc.
Logique
IPmt
Renvoie le montant de l'intérêt payé pour un prêt au cours d'une période donnée.
Financière
IsoDate2Num
Renvoie le nombre de jours écoulés depuis l’époque, à partir d’une chaîne de date valide.
Date et heure
IsoTime2Num
Renvoie le nombre de millisecondes écoulées depuis l’époque, à partir d’une chaîne d’heure valide.
Date et heure
Left
Extrait un nombre spécifique de caractères d'une chaîne, en commençant par le premier caractère à gauche.
Chaîne
Len
Renvoie le nombre de caractères d'une chaîne donnée.
Chaîne
LocalDateFmt
Renvoie une chaîne de format de date localisée, à partir d'un style de format de date.
Date et heure
LocalTimeFmt
Renvoie une chaîne de format d'heure localisée, à partir d'un style de format d'heure.
Date et heure
Lower
Convertit en minuscules toutes les majuscules d'une chaîne donnée.
Chaîne
Ltrim
Renvoie une chaîne sans aucun caractère d'espace blanc à gauche.
Chaîne
Max
Renvoie la valeur maximale des éléments non nuls d'un ensemble donné de nombres.
Arithmétique
Min
Renvoie la valeur minimale des éléments non nuls d'un ensemble donné de nombres.
Arithmétique
Mod
Renvoie le reste d'un nombre divisé par un autre.
Arithmétique
NPV
Renvoie la valeur nette actualisée d’un investissement compte tenu d’une série de mouvements futurs de l’encaisse et d’un taux d’actualisation.
Financière
Null
Renvoie la valeur nulle. La valeur nulle signifie aucune valeur.
Divers
Num2Date
Renvoie une chaîne de date, à partir du nombre de jours écoulés depuis l’époque.
Date et heure
Num2GMTime
Renvoie une chaîne d’heure UT, à partir du nombre de millisecondes écoulées depuis l’époque.
Date et heure
Num2Time
Renvoie une chaîne d’heure, à partir du nombre de millisecondes écoulées depuis l’époque.
Date et heure
Oneof
Renvoie « vrai » (1) si une valeur se trouve dans un ensemble donné, et « faux » (0) dans le cas contraire.
Logique
Parse
Analyse les données fournies selon le format d'image donné.
Chaîne
Pmt
Renvoie le remboursement d'un prêt basé sur des versements fixes et sur un taux d'intérêt fixe.
Financière
Post
Place à l'adresse URL indiquée les données fournies.
URL
PPmt
Renvoie le montant du principal payé pour un prêt au cours d'une période.
Financière
Put
Télécharge les données fournies vers l'adresse URL indiquée.
URL
PV
Renvoie la valeur actualisée d'un investissement réalisé par versements fixes périodiques avec un taux d'intérêt fixe.
Financière
Rate
Renvoie le taux d'intérêt composé par période nécessaire pour qu'un investissement d'une valeur actualisée atteigne une valeur capitalisée au cours d'une période donnée.
Financière
Ref
Renvoie une référence à un objet existant.
Divers
Replace
Remplace toutes les occurrences d'une chaîne par une autre, dans la chaîne indiquée.
Chaîne
Right
Extrait un nombre spécifique de caractères dans une chaîne donnée, en commençant par le dernier caractère à droite.
Chaîne
Round
Evalue une valeur ou expression numérique donnée et renvoie un nombre arrondi comportant le nombre de décimales défini.
Arithmétique
Rtrim
Renvoie une chaîne sans aucun caractère d'espace blanc à droite.
Chaîne
Space
Renvoie une chaîne composée d'un nombre donné d'espaces blancs.
Chaîne
Str
Convertit un nombre en une chaîne de caractères. FormCalc formate le résultat selon la largeur indiquée et l'arrondit au nombre de décimales défini.
Chaîne
Stuff
Insère une chaîne dans une autre chaîne.
Chaîne
Substr
Extrait une partie d'une chaîne donnée.
Chaîne
Sum
Renvoie la somme des éléments non nuls d'un ensemble donné de nombres.
Arithmétique
Term
Renvoie le nombre de périodes nécessaires pour atteindre la valeur capitalisée donnée, compte tenu de paiements fixes périodiques versés sur un compte portant intérêt.
Financière
Time
Renvoie l’heure actuelle du système sous la forme du nombre de millisecondes écoulées depuis l’époque.
Date et heure
Time2Num
Renvoie le nombre de millisecondes écoulées depuis l’époque, à partir d’une chaîne d’heure.
Date et heure
TimeFmt
Renvoie un format d'heure, à partir d'un style de format d'heure.
Date et heure
UnitType
Renvoie les unités d'une étendue d'unité. Une étendue d'unité est une chaîne composée d'un nombre suivi d'un nom d'unité.
Divers
UnitValue
Retourne la valeur numérique d’une mesure avec l'étendue d'unité qui lui est associée, après une conversion d’unité facultative.
Divers
Upper
Convertit en majuscules toutes les minuscules d'une chaîne.
Chaîne
Uuid
Renvoie une chaîne UUID qui sert de méthode d'identification.
Chaîne
Within
Renvoie « vrai » (1) si une valeur de contrôle se trouve dans la plage indiquée, et « faux » (0) dans le cas contraire.
Logique
WordNum
Renvoie le texte équivalent à un nombre donné.
Chaîne


Précédent Suivant

Script > Guide de référence FormCalc > Section de référence sur le langage

Section de référence sur le langage

Blocs fonctionnels
Expressions


Blocs fonctionnels

A propos des blocs fonctionnels
Littéraux
Opérateurs
Commentaires
Mots-clés
Identificateurs
Terminateurs de ligne
Espace blanc


A propos des blocs fonctionnels

Le langage FormCalc consiste en un certain nombre de blocs fonctionnels qui composent les expressions FormCalc. Chaque expression FormCalc est une séquence composée d’une combinaison de blocs fonctionnels.
      •
      Littéraux
      •
      Opérateurs
      •
      Commentaires
      •
      Mots-clés
      •
      Identificateurs
      •
      Terminateurs de ligne
      •
      Espace blanc


Littéraux

A propos des littéraux
Les littéraux sont des valeurs constantes qui forment la base de toutes les valeurs transmises à FormCalc pour traitement. Il existe deux grands types de littéraux : les nombres et les chaînes.
Littéraux numériques
Un littéral numérique est une séquence composée surtout de chiffres ; elle comprend un ou plusieurs des caractères suivants : un entier, un point décimal, une fraction, un indicateur d’exposant (« e » ou « E ») et une valeur d’exposant avec signe facultatif. Voici quelques exemples de littéraux numériques :
      •
      -12
      •
      1.5362
      •
      0.875
      •
      5.56e-2
      •
      1.234E10
Dans un littéral numérique, il est possible d’omettre la partie de l’entier ou de la fraction, mais non les deux. En outre, dans la partie de la fraction, on peut aussi omettre le point décimal ou la valeur de l’exposant, mais non les deux.
Tous les littéraux numériques sont convertis en interne en valeurs binaires 64 bits IEEE. Cependant, puisque les valeurs IEEE ne peuvent représenter qu’une quantité finie de nombres, certaines valeurs n’ont pas de représentation en fraction binaire. Cette situation est comparable au fait que certaines valeurs, comme 1/3, n’ont pas de représentation précise en fraction décimale (la valeur décimale aurait besoin d’un nombre infini de décimales pour être tout à fait exacte).
Ces valeurs qui ne possèdent pas d’équivalent en fraction binaire sont généralement les littéraux numériques comptant plus de 16 chiffres significatifs avant l’exposant. FormCalc arrondit ces valeurs à la valeur 64 bits IEEE représentable la plus proche selon les normes de l’IEEE. Par exemple, la valeur :
    123456789.012345678
est arrondi à la valeur (la plus près) :
    123456789.01234567
Autre exemple, le littéral numérique :
    99999999999999999
est arrondi à la valeur (la plus près) :
    100000000000000000
Cette façon de faire entraîne parfois des résultats surprenants. FormCalc possède une fonction, Round, qui renvoie le nombre indiqué arrondi au nombre indiqué de décimales. Lorsque le nombre indiqué est exactement à mi-chemin entre deux nombres représentables, il est arrondi au plus loin de zéro. Autrement dit, le nombre est arrondi à la hausse s’il est positif et à la baisse s’il est négatif. Considérez l’exemple suivant :
    Round(0.124, 2)
renvoie 0.12,
et
    Round(.125, 2)
renvoie 0.13.
D’après cette convention, vous pourriez penser que :
    Round(0.045, 2)
renvoie 0.05.
Cependant, la norme IEEE 754 stipule que le littéral numérique 0.045 reçoit la valeur approximative 0.0449999999999999. Cette approximation est plus près de 0.04 que de 0.05. C’est pourquoi :
    Round(0.045, 2)
renvoie 0.04.
Cette façon de faire est conforme à la norme IEEE 754.
Les valeurs 64 bits IEEE reconnaissent les représentations comme NaN (« not a number », n’est pas un nombre), +Inf (infini positif) et -Inf (infini négatif). FormCalc ne les gère pas ; toute expression dont l’évaluation a pour résultat NaN, +Inf ou -Inf entraîne une exception d’erreur, transmise au reste de l’expression.
Littéraux chaînes
Un littéral chaîne est une séquence constituée de tout caractère Unicode, précédée et suivie de guillemets. Par exemple :
    "The cat jumped over the fence."
    "Number 15, Main street, California, U.S.A"
Le littéral chaîne "" définit une séquence vide (sans caractères) appelée chaîne vide.
Pour mettre un élément entre guillemets au sein d’un littéral chaîne, vous devez faire précéder le guillemet d’une barre oblique inverse (\). Par exemple :
    "The message reads: ""Warning: Insufficient Memory"""
Tous les caractères Unicode ont une séquence d’échappement de 6 caractères équivalente, composée de \u suivie de quatre chiffres hexadécimaux. Dans tout littéral chaîne, il est possible d’exprimer n’importe quel caractère, y compris les caractères de commande, au moyen de la séquence d’échappement Unicode équivalente. Par exemple :
    "\u0047\u006f\u0066\u0069\u0073\u0068\u0021"
    "\u000d" (carriage return)
    "\u000a" (newline character)


Opérateurs

FormCalc inclut un certain nombre d’opérateurs : unaires, multiplicatifs, additifs, relationnels, logiques, d’égalité et d’affectation.
Plusieurs opérateurs FormCalc ont un mot-clé mnémonique équivalent. Ces mots-clés sont utiles lorsque des expressions FormCalc sont incorporées dans du texte source HTML et XML, où les symboles « inférieur à » (<), « supérieur à » (>), et « et commercial » (&) ont des significations prédéfinies, et doivent donc être obtenus par des séquences d’échappement. Le tableau suivant dresse la liste de tous les opérateurs FormCalc accompagnés des formes symboliques et, le cas échéant, mnémoniques.

Type d’opérateur

Représentations
Addition
+
Division
/
Egalité
== eq
<> ne
ET logique
& and
OU logique
| or
Multiplication
*
Expression relationnelle
< lt (« less than », inférieur à)
> gt (« greater than », supérieur à)
<= le (« less than or equal to », inférieur ou égal à)
>= ge (« greater than or equal to », supérieur ou égal à)
Soustraction
-
Unaire
-
+
not


Commentaires

Les commentaires sont des sections de code que FormCalc n’exécute pas. Les commentaires contiennent normalement des renseignements ou des directives qui expliquent l’utilité d’un certain fragment de code. Au moment de l’exécution, FormCalc ne tient pas compte des informations stockées en commentaires.
Vous pouvez indiquer un commentaire en entrant soit un point-virgule (;), soit une paire de barres obliques (//). Dans FormCalc, un commentaire s’étend depuis son début jusqu’au prochain terminateur de ligne.

Nom du caractère

Représentations
Commentaire
;
//
Par exemple :
    // This is a type of comment
    First_Name="Tony"
    Initial="C" ;This is another type of comment
    Last_Name="Blue"
Commentaires de tous les calculs FormCalc pour un événement
L’ajout de commentaires à tous les calculs FormCalc pour un événement particulier entraîne une erreur lors de l’affichage de votre formulaire dans le panneau Aperçu PDF ou lors de l’affichage du PDF final. Chaque calcul FormCalc doit renvoyer une valeur, et FormCalc ne considère pas les commentaires comme étant des valeurs.
Pour empêcher que le code des commentaires FormCalc ne renvoie une erreur, effectuez l’une des opérations suivantes :
      •
      Supprimez le code de commentaires de l’événement.
      •
      Ajoutez une expression qui renvoie une valeur au code de FormCalc pour l’événement.
Pour empêcher que la valeur de l’expression n’entraîne des résultats indésirables sur votre formulaire, utilisez l’un des types d’expressions suivants :
      •
      Une simple expression faite d’un caractère unique, comme suit :

        // First_Name="Tony"
        // Initial="C"
        // Last_Name="Blue"
        //
        // The simple expression below sets the value of the event to zero.
        0
      •
      Une expression d’affectation conservant la valeur de l’objet. Utilisez ce type d’expression si le code de commentaire de FormCalc se trouve dans l’événement de calcul afin d’empêcher que la valeur réelle de l’objet ne soit modifiée, comme suit :

        // First_Name="Tony"
        // Initial="C"
        // Last_Name="Blue"
        //
        // The assignment expression below sets the value of the current
        // field equal to itself.
        $.rawValue = $.rawValue


Mots-clés

Les mots de passe FormCalc sont réservés et ne font pas la distinction entre majuscules et minuscules. Ces mots-clés sont réservés aux parties d’expressions, aux littéraux numériques spéciaux et aux opérateurs.
Le tableau suivant dresse la liste des mots-clés FormCalc. N’utilisez aucun de ces mots lorsque vous nommez un objet de votre conception de formulaire.
and | endif | in | step
break | endwhile | infinity | then
continue | eq | le | this
do | exit | lt | throw
downto | for | nan | upto
else | foreach | ne | var
elseif | func | not | while
end | ge | null |
endfor | gt | or |
endfunc | if | return |


Identificateurs

Un identificateur est une séquence de caractères de longueur illimitée qui représente le nom d’une fonction ou d’une méthode. Un identificateur commence toujours par l’un des caractères suivants :
      •
      N’importe quel caractère alphabétique (d’après le classement des lettres Unicode)
      •
      Trait de soulignement (_)
      •
      Signe du dollar ($)
      •
      Point d’exclamation (!)
Les identificateurs FormCalc distinguent les lettres majuscules et les lettres minuscules. Autrement dit, les identificateurs dont les caractères ne diffèrent que par les majuscules ou les minuscules sont considérés comme distincts.

Nom du caractère

Représentations
Identificateur
A..Z,a..z
$
!
_
Voici quelques exemples d’identificateurs valides :
    GetAddr
    $primary
    _item
    !dbresult


Terminateurs de ligne

Les terminateurs de ligne sont utilisés pour séparer des lignes et améliorer la lisibilité.
Le tableau suivant dresse la liste des terminateurs de ligne valides FormCalc :

Nom du caractère

Caractères Unicode
Retour chariot
#xD
U+000D
Changement de ligne
#xA
&#x000D;
&#D;


Espace blanc

Les caractères d’espace blanc sont ceux qui séparent les objets et les opérations mathématiques. Ces caractères servent strictement à améliorer la lisibilité et n’ont aucune importance au moment du traitement dans FormCalc.

Nom du caractère

Caractère Unicode
Saut de page
#xC
Tabulation horizontale
#x9
Barre espace
#x20
Tabulation verticale
#xB


Expressions

A propos des expressions
Simple
Affectation
OU logique
ET logique
Unaire
Egalité et inégalité
Expression relationnelle
Expressions if
Expressions while
Expressions for
Expressions foreach
Expressions break
Expressions continue


A propos des expressions

Les littéraux, opérateurs, commentaires, mots-clés, identificateurs, terminateurs de ligne et espaces blancs constituent ensemble une liste d’expressions, même lorsque la liste ne contient qu’une seule expression. En général, chaque expression de la liste renvoie une valeur ; la valeur de la liste dans son ensemble est celle de la dernière expression de la liste.
Considérez, par exemple, les deux champs suivants d’une conception de formulaire :

Nom de champ

Calculs

Renvoie

Field1

5 + Abs(Price)
« Hello World »
10 * 3 + 5 * 4

50

Field2

10 * 3 + 5 * 4

50
La valeur de Field1 et de Field2 après l’évaluation de l’expression de chaque champ est 50.
FormCalc classe comme suit les différents types d’expressions qui forment une liste d’expressions :
      •
      Simple
      •
      Affectation
      •
      OU logique
      •
      ET logique
      •
      Unaire
      •
      Egalité et inégalité
      •
      Expression relationnelle
      •
      Expressions if
      •
      Expressions while
      •
      Expressions for
      •
      Expressions foreach
      •
      Expressions break
      •
      Expressions continue


Simple

A propos des expressions simples
Dans leur forme leur plus simple, les expressions FormCalc sont des groupes d’opérateurs, mots-clés et littéraux assemblés de façon logique. Voici des exemples d’expressions simples :
    2
    "abc"
    2 - 3 * 10 / 2 + 7
Chaque expression FormCalc renvoie une seule valeur, après exécution des opérations dans l’ordre traditionnel, même si cet ordre n’est pas toujours évident à déterminer d’après la syntaxe de l’expression. Ainsi, les ensembles d’expressions suivants, lorsqu’on les applique à des objets de conception de formulaire, produisent les mêmes résultats :

Expression

Equivalent à

Renvoie

"abc"

"abc"

abc

2 - 3 * 10 / 2 + 7

2 - (3 * (10 / 2)) + 7

-6

10 * 3 + 5 * 4

(10 * 3) + (5 * 4)

50

0 and 1 or 2 > 1

(0 and 1) or (2 >1)
1 (true)

2 < 3 not 1 == 1

(2 < 3) not (1 == 1)
0 (false)
Comme le suggère le tableau précédent, tous les opérateurs FormCalc possèdent un certain niveau de priorité lorsqu’ils apparaissent dans des expressions. Le tableau suivant illustre la hiérarchie des opérateurs :

Priorité

Opérateur
La plus élevée
=
(Unaire) - , + , not
* , /
+ , -
< , <= , > , >= , lt , le , gt , ge
== , <> , eq , ne
& , and
La plus basse
| , or
Promotion d’opérandes
Dans le cas où une ou plusieurs opérandes d’une opération ne correspondent pas au type prévu pour cette opération, FormCalc promeut les opérandes pour qu’elles correspondent au type requis. La façon dont se fait cette promotion dépend du type d’opérande exigé par l’opération.
Opérations numériques
Lorsque des opérandes non numériques se retrouvent dans des opérations numériques, elles sont d’abord promues à leur équivalent numérique. Si l’opérande non numérique n’est pas convertie correctement en valeur numérique, sa valeur devient zéro (0). La promotion d’opérandes dont la valeur est nulle en nombres donne toujours la valeur zéro.
Le tableau suivant donne quelques exemples de promotion d’opérandes non numériques.

Expression

Equivalent à

Renvoie

(5 - "abc") * 3

(5 - 0) * 3

15

"100" / 10e1

100 / 10e1

1

5 + null + 3

5 + 0 + 3

8
Opération booléenne
Lorsque des opérandes non booléennes se retrouvent dans des opérations booléennes, elles sont d’abord promues à leur équivalent booléen. Si l’opérande non booléenne n’est pas convertie correctement en une valeur différente de zéro, sa valeur est Vrai (1) ; sinon, sa valeur est Faux (0). La promotion d’opérandes dont la valeur est nulle en valeur booléenne donne toujours la valeur Faux (0). Par exemple, l’expression :
    "abc" | 2
renvoie 1. Autrement dit, Faux | Vrai = Vrai, alors que
    if ("abc") then
    10
    else
    20
    endif
renvoie 20.
Opérations de chaîne
Lorsque des opérandes non chaînes se retrouvent dans des opérations de chaîne, elles sont d’abord promues en chaînes tirées de leur valeur. La promotion d’opérandes dont la valeur est nulle en chaînes donne toujours la chaîne vide. Par exemple, l’expression :
    concat("The total is ", 2, " dollars and ", 57, " cents.")
renvoie "The total is 2 dollars and 57 cents."
si durant l’évaluation d’une expression, une étape intermédiaire génère NaN, +Inf ou -Inf, FormCalc génère une exception d’erreur et propage cette erreur dans le reste de l’expression. La valeur de l’expression est alors toujours 0. Par exemple :
3 / 0 + 1
renvoie 0.


Affectation

Une expression d’affectation attribue la valeur d’une expression simple à la propriété identifiée par une syntaxe de référence donnée. Par exemple :
    $template.purchase_order.name.first = "Tony"
Cette expression définit la valeur de la conception de formulaire « first » sur Tony.
Pour plus de détails sur l’utilisation de la syntaxe de référence, voir A propos des références aux objets dans les calculs et les scripts.


OU logique

Une expression OU logique renvoie soit Vrai (1) si au moins l’une de ses opérandes est Vrai (1), soit Faux (0) si les deux opérandes sont Faux (0). Si les deux opérandes sont nulles, l’expression renvoie Nul.

Expression

Représentation par des caractères
OU logique
|
or
Voici quelques exemples d’utilisation de l’expression OU logique :

Expression

Renvoie

1 or 0
1 (true)

0 | 0
0 (false)

0 or 1 | 0 or 0
1 (true)


ET logique

Une expression ET logique renvoie soit Vrai (1) si les deux opérandes sont Vrai (1), soit Faux (0) si au moins l’une de ses opérandes est Faux (0). Si les deux opérandes sont nulles, l’expression renvoie Nul.

Expression

Représentation par des caractères
ET logique
&
and
Voici quelques exemples d’utilisation de l’expression ET logique :

Expression

Renvoie

1 and 0
0 (false)

0 & 0
1 (true)

0 and 1 & 0 and 0
0 (false)


Unaire

Une expression unaire renvoie des résultats différents selon l’opérateur unaire utilisé.

Expression

Représentation par des caractères

Renvoie
Unaire
-
La négation arithmétique de l’opérande, ou nul si l’opérande est nulle.
+
La valeur arithmétique de l’opérande (inchangée), ou nul si l’opérande est nulle.
not
La négation logique de l’opérande.
la négation arithmétique d’une opérande nulle donne le résultat nul, alors que la négation logique d’une opérande nulle renvoie le résultat booléen Vrai. Pour comprendre ces résultats, suivez le raisonnement suivant : Si « nul » signifie « rien », alors « pas rien » signifie « quelque chose ».
Voici quelques exemples d’utilisation de l’expression unaire :

Expression

Renvoie

-(17)

-17

-(-17)

17

+(17)

17

+(-17)

-17

not("true")
1 (true)

not(1)
0 (false)


Egalité et inégalité

Les expressions d’égalité et d’inégalité renvoient le résultat d’une comparaison d’égalité de ses opérandes.

Expression

Représentation par des caractères

Renvoie
Egalité
== eq
Vrai (1) lorsque les deux opérandes comparées sont identiques, et Faux (0) si elles sont différentes.
Inégalité
<> ne
Vrai (1) lorsque les deux opérandes comparées sont différentes, et Faux (0) si elles sont identiques.
Les cas spéciaux suivants s’appliquent aussi à l’utilisation des opérateurs d’égalité :
      •
      Si l’une des opérande est nulle, une comparaison de valeur nulle est exécutée. Si les deux opérandes sont nulles, le résultat est « identique » ; si l’une des opérandes n’est pas nulle, le résultat est « différent ».
      •
      Si les deux opérandes sont des références, elles sont considérées identiques si elles se rapportent toutes deux au même objet, et différentes si elles ne se rapportent pas au même objet.
      •
      Si les deux opérandes ont pour valeur une chaîne, une comparaison lexicale des chaînes, prenant en compte le paramètre régional, est exécutée sur les opérandes. Sinon, si elles ne sont pas nulles, les opérandes sont promues en valeurs numériques et une comparaison numérique a lieu.
Voici quelques exemples d’utilisation des expressions d’égalité et d’inégalité :

Expression

Renvoie

3 == 3
1 (true)

3 <> 4
1 (true)

"abc" eq "def"
0 (false)

"def" ne "abc"
1 (true)

5 + 5 == 10
1 (true)

5 + 5 <> "10"
0 (false)


Expression relationnelle

Une expression relationnelle renvoie le résultat booléen de la comparaison relationnelle des opérandes.

Expression

Représentation par des caractères

Renvoie
Expression relationnelle
< lt
Vrai (1) lorsque la première opérande est inférieure à la seconde ; faux (0) lorsque la première opérande est supérieure à la seconde.
> gt
Vrai (1) lorsque la première opérande est supérieure à la seconde ; faux (0) lorsque la première opérande est inférieure à la seconde.
<= le
Vrai (1) lorsque la première opérande est inférieure ou égale à la seconde ; faux (0) lorsque la première opérande est supérieure à la seconde.
>= ge
Vrai (1) lorsque la première opérande est supérieure ou égale à la seconde ; faux (0) lorsque la première opérande est inférieure à la seconde.
Les cas spéciaux suivants s’appliquent aussi à l’utilisation des opérateurs relationnels :
      •
      Si l’une des opérandes est nulle, une comparaison de valeur nulle est exécutée. Les opérandes dont la valeur est nulle sont considérées identiques si les deux opérandes sont nulles et que l’opérateur relationnel est « inférieur ou égal à » ou « supérieur ou égal à » ; sinon, elles sont considérées différentes.
      •
      Si les deux opérandes ont pour valeur une chaîne, une comparaison lexicale des chaînes, prenant en compte le paramètre régional, est exécutée sur les opérandes. Sinon, si elles ne sont pas nulles, les opérandes sont promues en valeurs numériques et une comparaison numérique a lieu.
Voici quelques exemples d’utilisation de l’expression relationnelle :

Expression

Renvoie

3 < 3
0 (false)

3 > 4
0 (false)

"abc" <= "def"
1 (true)

"def" > "abc"
1 (true)

12 >= 12
1 (true)

"true" < "false"
0 (false)


Expressions if

Une expression (ou instruction) if évalue si une expression simple est vraie ; le résultat renvoyé est une liste d’expressions correspondant à la valeur Vrai. Si l’expression simple initiale est fausse (0), FormCalc vérifie les conditions elseif ou else et renvoie, le cas échéant, les résultats de leurs listes d’expressions.

Expression

Syntaxe

Renvoie
If

if ( simple expression ) then
    list of expressions
elseif ( simple expression ) then
    list of expressions
else
    list of expressions
endif
Résultat de la liste d’expressions associée à toute condition correcte énoncée dans l’expression if.
vous n’êtes pas tenu d’insérer des instructions elseif(...) ou else dans l’expression if. Cependant, vous devez signifier la fin de l’expression par endif.
Voici quelques exemples d’utilisation de l’expression if :

Expression

Renvoie

if ( 1 < 2 ) then
 1
endif

1

if ( "abc" > "def") then
 1 and 0
else
 0
endif

0

if ( Field1 < Field2 ) then
 Field3 = 0
elseif ( Field1 > Field2 ) then
 Field3 = 40
elseif ( Field1 = Field2 ) then
 Field3 = 10
endif
Varie avec les valeurs de Field1 et de Field2. Par exemple, si Field1 est 20 et Field2 est 10, cette expression définit Field3 à 40.


Expressions while

Une expression while est une instruction itérative, aussi appelée instruction de boucle, qui évalue une expression simple donnée. Si le résultat de l’évaluation est Vrai (1), FormCalc examine continuellement la condition do et renvoie les résultats des listes d’expressions. Si le résultat est Faux (0), le contrôle passe alors à l’instruction suivante.
Une expression while est particulièrement adaptée aux situations où une répétition conditionnelle est nécessaire. En revanche, les situations demandant l’utilisation d’une répétition non conditionnelle sont souvent traitées plus efficacement avec une expression for.

Expression

Syntaxe

Renvoie
While

while ( simple expression ) do
    expression list
endwhile
Le résultat de la liste d’expressions associée à la condition do.
Dans l’exemple suivant, les valeurs des éléments sont ajoutées à une liste déroulante à partir d’un fichier XML. La méthode addItem est utilisée pour l’ensemble des éléments XML répertoriés sous list1 qui ne sont pas égaux à 3 :
    var List = ref(xfa.record.lists.list1)
    var i = 0
    while ( List.nodes.item(i+1).value ne "3")do
    $.addItem (List.nodes.item(i).value,List.nodes.item(i+1).value)
    i = i + 2
    endwhile


Expressions for

Une expression for est une boucle ou une instruction itérative conditionnelle.
Une expression for est particulièrement adaptée aux situations de boucles où une répétition non conditionnelle est nécessaire. En revanche, les situations demandant l’utilisation d’une répétition conditionnelle sont souvent traitées plus efficacement avec une expression while.
La valeur de l’expression for correspond à la valeur de la dernière liste d’évaluation évaluée ou à Faux (0).
La condition for initialise une variable FormCalc qui contrôle l’action de boucle.
Dans la variante upto, la valeur de la variable de boucle effectue une itération de l’expression start à l’expression end, en utilisant pour cela des incréments de l’expression step. Si vous n’indiquez aucune valeur pour l’expression step, l’incrément step prend la valeur 1 par défaut.
Dans la variante downto, la valeur de la variable de boucle effectue une itération de l’expression start à l’expression end, en utilisant pour cela des décréments de l’expression step. Si vous n’indiquez aucun valeur pour l’expression step, les décréments step prennent la valeur -1 par défaut.
Les itérations de la boucle sont contrôlées par la valeur de l’expression end. Avant chaque itération, l’expression end est évaluée et comparée à la variable de boucle. Si le résultat est Vrai (1), la liste d’expressions est évaluée. Après chaque évaluation, l’expression step est évaluée et ajoutée à la variable de boucle.
Avant chaque itération, l’expression end est évaluée et comparée à la variable de boucle. De plus, après chaque évaluation de la condition do, l’expression step est évaluée et ajoutée à la variable de boucle.
Une boucle for se termine lorsque l’expression start a dépassé l’expression end. L’expression start peut dépasser l’expression end vers le haut, si vous utilisez la variante upto, ou vers le bas, si vous utilisez la variante downto.

Expression

Syntaxe

Renvoie
For

for variable = start expression
    (upto | downto ) end expression
        (step step expression ) do
    expression list
endfor
les expressions start, end et step doivent toutes être des expressions simples.
Le résultat de la liste d’expressions associée à la condition do.
Dans l’exemple suivant, les valeurs des éléments sont ajoutées à une liste déroulante à partir d’un fichier XML. La méthode addItem est utilisée pour l’ensemble des éléments XML répertoriés sous list1 :
    var List = ref(xfa.record.lists.list1)
    for i=0 upto List.nodes.length - 1 step 2 do
    $.addItem (List.nodes.item(i).value,"")
    endfor


Expressions foreach

Une expression foreach effectue une itération sur la liste d’expressions pour chaque valeur de sa liste d’arguments.
La valeur de l’expression foreach correspond à la valeur de la dernière liste d’expressions évaluée, ou à zéro (0) si aucune boucle n’a été indiquée.
La condition in, exécutée une seule fois (après déclaration de la variable de boucle), contrôle l’itération de la boucle. Avant chaque itération, des valeurs consécutives issues de la liste d’arguments sont affectées à la variable de boucle. La liste d’arguments ne peut pas être vide.

Expression

Syntaxe

Renvoie
Foreach

foreach variable in( argument list )do
    expression list
endfor
utilisez une virgule (,) pour séparer les expressions simples de la liste d’arguments.
La valeur de la dernière liste d’expressions évaluée ou zéro (0) si aucune boucle n’a été indiquée.
Dans l’exemple suivant, seules les valeurs des éléments XML « display » sont ajoutées à la liste déroulante foreach.
    foreach Item in (xfa.record.lists.list1.display[*]) do
    $.addItem(Item,"")
    endfor


Expressions break

Une expression break provoque une sortie immédiate à partir de la boucle d’expression while, for ou foreach la plus centrale. Le contrôle est alors transmis à l’expression suivant la boucle terminée.
La valeur de l’expression break est toujours égale à zéro (0).

Expression

Syntaxe

Renvoie
Saut

break
Transmet le contrôle à l’expression suivant la boucle terminée.
Dans l’exemple suivant, une condition if est placée dans la boucle while pour vérifier si la valeur actuelle est égale à « Display data for 2 ». Si l’expression if est Vrai, l’expression break est exécutée et interrompt la boucle.
    var List = ref(xfa.record.lists.list1)
    var i=0
    while (List.nodes.item(i+1).value ne "3") do
    $.addItem(List.nodes.item(i).value,List.nodes.item(i+1).value)
    i = i + 2
    if (List.nodes.item(i) eq "Display data for 2" then
    break
    endif
    endwhile


Expressions continue

Une expression continue déclenche l’itération suivante de la boucle while, for ou foreach la plus centrale.
La valeur de l’expression continue est toujours égale à zéro (0).

Expression

Syntaxe

Renvoie
Continue

continue
Lorsqu’elle est utilisée dans une expression while, le contrôle est transmis à la condition while. Lorsqu’elle est utilisée dans une expression for, le contrôle est transmis à l’expression step.
L’objectif de l’exemple suivant est de remplir la liste déroulante à l’aide des valeurs d’un fichier XML. Si la valeur de l’élément XML actuel est « Display data for 3 », l’expression break entraîne la sortie de la boucle while. Si la valeur de l’élément XML actuel est « Display data for 2 », le script ajoute 2 à la variable i (le compteur) et la boucle passe immédiatement à son cycle suivant. Les deux dernières lignes ne sont pas prises en compte lorsque la valeur de l’élément XML actuel est « Display data for 2 ».
    var List = ref(xfa.record.lists.list1)
    var i = 0
    while (List.nodes.item(i+1).value ne "5") do
    if (List.nodes.item(i) eq "Display data for 3") then
    break
    endif
    if (List.nodes.item(i) eq "Display data for 2" then
    i=i+2
    continue
    endif
    $.addItem(List.nodes.item(i).value,List.nodes.item(i+1).value)
    i=i+2
    endwhile
Pour faciliter l'accès aux propriétés et aux valeurs et limiter votre travail, FormCalc offre des raccourcis pratiques pour créer des références. Le tableau suivant décrit les raccourcis de la syntaxe de référence pour FormCalc.

Notation

Description
$
Fait référence au champ ou à l'objet actuel, comme l'illustre cet exemple :
    $ = "Tony Blue"
L'exemple ci-dessus définit la valeur du champ ou de l'objet actuel sur Tony Blue.
$data
Représente la racine du modèle de données xfa.datasets.data. Par exemple :
    $data.purchaseOrder.total
est équivalent à
    xfa.datasets.data.purchaseOrder.total
$event
Représente l'événement d'objet de formulaire actif. Par exemple :
    $event.name
est équivalent à
    xfa.event.name
Pour plus de détails, voir A propos du modèle d'événement.
$form
Représente la racine du modèle de formulaire xfa.form. Par exemple :
    $form.purchaseOrder.tax
est équivalent à
    xfa.form.purchaseOrder.tax
$host
Représente l'objet hôte. Par exemple :
    $host.messageBox("Hello world")
est équivalent à
    xfa.host.messageBox("Hello world")
Pour plus de détails, voir A propos de l'utilisation d'une application hôte.
$layout
Représente la racine du modèle de disposition xfa.layout. Par exemple :
    $layout.ready
est équivalent à
    xfa.layout.ready
$record
Représente l'enregistrement actuel d'une collection de données, provenant d'un fichier XML par exemple. Par exemple :
    $record.header.txtOrderedByCity
référence le noeud txtOrderedByCity dans le noeud header des données XML actuelles.
$template
Représente la racine de la conception de modèle xfa.template. Par exemple :
    $template.purchaseOrder.item
est équivalent à
    xfa.template.purchaseOrder.item
!
Représente la racine du modèle de données xfa.datasets. Par exemple :
    !data
est équivalent à
    xfa.datasets.data
*
Sélectionne tous les objets de formulaire dans un conteneur donné (tel qu'un sous-formulaire), quel que soit le nom, ou sélectionne tous les objets ayant un nom similaire.
Par exemple, l'expression suivante sélectionne tous les objets nommés item sur un formulaire :
    xfa.form.form1.item[*]
..
Vous pouvez utiliser deux points à un endroit quelconque de votre syntaxe de référence pour rechercher des objets faisant partie de n'importe quel sous-conteneur du conteneur actuel (tel qu'un sous-formulaire). Par exemple, l'expression Subform_Page..Subform2 signifie rechercher le nœud Subform_Page (comme d'habitude) et trouver un descendant de Subform_Page appelé Subform2.
En se fondant sur l'arborescence ci-dessus,
    Subform_Page..TextField2
est équivalent à
    Subform_Page.Subform1[0].Subform3.TextField2[0]
puisque TextField2[0] est le premier nœud Subform1 que FormCalc rencontre lors de sa recherche. Deuxième exemple :
    Subform_Page..Subform3[*]
retourne les quatre instances de l'objet TextField2.
#
La notation # (signe dièse) est utilisée pour représenter l'un des éléments suivants dans une syntaxe de référence :
      •
      Un objet sans nom. Ainsi, la syntaxe de référence suivante accède à un sous-formulaire sans nom :

        xfa.form.form1.#subform
      •
      Une propriété dans une syntaxe de référence si une propriété et un objet possèdent le même nom. La syntaxe de référence suivante accède, par exemple, à la propriété name d'un sous-formulaire si ce dernier contient également un champ appelé name :

        xfa.form.form1.#subform.#name
[ ]
Le crochet ([ ]) représente la valeur d'occurrence d'un objet. Pour créer une référence à une valeur d'occurrence, placez des crochets ([ ]) après un nom d'objet et insérez entre les crochets l'une des valeurs suivantes :
      •
      [ n ], où n est un numéro d'index d'occurrence absolu commençant à 0. Un numéro d'occurrence hors limite renvoie une erreur. Par exemple :

        xfa.form.form1.#subform.Quantity[3]
        refers to the fourth occurrence of the Quantity object.
      •
      [ +/- n ], où n indique une occurrence relative à l'occurrence de l'objet porteur de la référence. Les valeurs positives retournent des nombres d'occurrences plus élevés alors que les valeurs négatives retournent des nombres d'occurrences plus bas. Par exemple :

         xfa.form.form1.#subform.Quantity[+2]

      Cette référence retourne l'occurrence de Quantity dont le nombre d'occurrences est deux de plus que le nombre d'occurrences du conteneur qui constitue la référence. Si, par exemple, cette référence était jointe à l'objet Quantity[2], la référence serait la même que :

         xfa.template.Quantity[4]

      Si le numéro d'index calculé est hors limite, la référence renvoie une erreur.

      Cette syntaxe sert surtout à localiser l'occurrence précédente ou suivante d'un objet en particulier. Par exemple, chaque occurrence de l'objet Quantity (sauf la première) peut utiliser Quantity[-1] pour obtenir la valeur de l'objet Quantity précédent.
      •
      [*] indique plusieurs occurrences d'un objet. Le premier objet nommé est trouvé, et les objets portant le même nom et ayant le même parent immédiat sont retournés. Le résultat de cette notation est une collection d'objets. Par exemple :

         xfa.form.form1.#subform.Quantity[*]

      Cette expression fait référence à tous les objets portant le nom Quantity et ayant le même parent immédiat que la première occurrence Quantity trouvée par la référence.
dans les formulaires en arabe, hébreu, thaï et vietnamien, la syntaxe de référence se trouve toujours à droite (même pour les langues s'écrivant de droite à gauche).
LiveCycle Forms 7.1 ne prend pas en charge les conceptions de formulaire contenant des polices relatives à l'arabe, l'hébreu, le thaï et le vietnamien.
[ ]
(suite)
L'arborescence servant de référence, les expressions suivantes retournent les résultats indiqués :
      •
      Subform_Page.Subform1[*] renvoie les deux objets Subform1.
      •
      Subform_Page.Subform1.Subform3.TextField2[*] renvoie les deux objets TextField2. Subform_Page.Subform1 a pour résultat le premier objet Subform1 à gauche et TextField2[*] est évalué relativement à l'objet Subform3.
      •
      Subform_Page.Subform1[*].TextField1 renvoie les deux instances TextField1. Subform_Page.Subform1[*] a pour résultat les deux objets Subform1 et TextField1 est évalué relativement aux objets Subform1.
      •
      Subform_Page.Subform1[*].Subform3.TextField2[1] renvoie le deuxième et le quatrième objet TextField2 à partir de la gauche. Subform_Page.Subform1[*] a pour résultat les deux objets Subform1 et TextField2[1] est évalué relativement aux objets Subform3.
      •
      Subform_Page.Subform1[*].Subform3[*] retourne les deux instances de l'objet Subform3.
      •
      Subform_Page.* retourne les deux objets Subform1 et l'objet Subform2.
      •
      Subform_Page.Subform2.* retourne les deux instances de l'objet NumericField2.


Fonctions arithmétiques

A propos des fonctions arithmétiques
Abs
Avg
Ceil
Count
Floor
Max
Min
Mod
Round
Sum


A propos des fonctions arithmétiques

Ces fonctions exécutent différentes opérations mathématiques.
Fonctions
      •
      Abs
      •
      Avg
      •
      Ceil
      •
      Count
      •
      Floor
      •
      Max
      •
      Min
      •
      Mod
      •
      Round
      •
      Sum


Abs

Renvoie la valeur absolue d’une valeur ou expression numérique, ou renvoie « nul » si la valeur ou expression est nulle.
Syntaxe
Abs(n1)
Paramètres

Paramètre

Description

n1
Valeur ou expression numérique à évaluer.
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Abs :

Expression

Renvoie

Abs(1.03)

1.03

Abs(-1.03)

1.03

Abs(0)

0


Avg

Evalue un ensemble de valeurs et/ou d’expressions numériques et renvoie la moyenne des éléments non nuls de cet ensemble.
Syntaxe
Avg(n1 [, n2 ...])
Paramètres

Paramètre

Description

n1
Première valeur ou expression numérique de l’ensemble.
n2 (facultatif)
Autres valeurs ou expressions numériques.
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Avg :

Expression

Renvoie

Avg(0, 32, 16)

16

Avg(2.5, 17, null)

9.75

Avg(Price[0], Price[1], Price[2], Price[3])
Moyenne des quatre premières occurrences non nulles de Price.

Avg(Quantity[*])
Moyenne de toutes les occurrences non nulles de Quantity.


Ceil

Renvoie le nombre entier supérieur ou égal au nombre fourni, ou renvoie « nul » si le paramètre est nul.
Syntaxe
Ceil(n)
Paramètres

Paramètre

Description

n
N’importe quelle valeur ou expression numérique.
La fonction renvoie la valeur 0 si n n’est pas une valeur ou expression numérique.
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Ceil :

Expression

Renvoie

Ceil(2.5875)

3

Ceil(-5.9)

-5

Ceil("abc")

0

Ceil(A)
100 si la valeur de A est égale à 99,999.


Count

Evalue un ensemble de valeurs et/ou expressions, et renvoie le nombre d’éléments non nuls contenus dans cet ensemble.
Syntaxe
Count(n1 [, n2 ...])
Paramètres

Paramètre

Description

n1
Valeur ou expression numérique.
n2 (facultatif)
Autres valeurs et/ou expressions numériques.
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Count :

Expression

Renvoie

Count("Tony", "Blue", 41)

3

Count(Customers[*])
Nombre d’occurrences non nulles de Customers.

Count(Coverage[2], "Home", "Auto")
3, à condition que la troisième occurrence de Coverage ne soit pas nulle.


Floor

Renvoie le plus grand nombre entier inférieur ou égal à la valeur donnée.
Syntaxe
Floor(n)
Paramètres

Paramètre

Description

n
N’importe quelle valeur ou expression numérique.
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Floor :

Expression

Renvoie

Floor(21.3409873)

21

Floor(5.999965342)

5

Floor(3.2 * 15)

48


Max

Renvoie la valeur maximale des éléments non nuls d’un ensemble donné de nombres.
Syntaxe
Max(n1 [, n2 ...])
Paramètres

Paramètre

Description

n1
Valeur ou expression numérique.
n2 (facultatif)
Autres valeurs et/ou expressions numériques.
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Max :

Expression

Renvoie

Max(234, 15, 107)

234

Max("abc", 15, "Tony Blue")

15

Max("abc")

0

Max(Field1[*], Field2[0])
Évalue les occurrences non nulles de Field1, ainsi que la première occurrence de Field2, et retourne la valeur la plus élevée.

Max(Min(Field1[*], Field2[0]), Field3, Field4)
La première expression évalue les occurrences non nulles de Field1, ainsi que la première occurrence de Field2, et renvoie la valeur la plus basse. Le résultat final est le maximum de cette valeur comparativement aux valeurs de Field3 et de Field4.
Voir aussi Min.


Min

Renvoie la valeur minimale des éléments non nuls d’un ensemble donné de nombres.
Syntaxe
Min(n1 [, n2 ...])
Paramètres

Paramètre

Description

n1
Valeur ou expression numérique.
n2 (facultatif)
Autres valeurs et/ou expressions numériques.
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Min :

Expression

Renvoie

Min(234, 15, 107)

15

Min("abc", 15, "Tony Blue")

15

Min("abc")

0

Min(Field1[*], Field2[0])
Évalue les occurrences non nulles de Sales_July, ainsi que la première occurrence de Sales_August, et retourne la valeur la plus basse.

Min(Max(Field1[*], Field2[0]), Field3, Field4)
La première expression évalue les occurrences non nulles de Field1, ainsi que la première occurrence de Field2, et renvoie la valeur la plus élevée. Le résultat final est le minimum de cette valeur comparativement aux valeurs de Field3 et de Field4.
Voir aussi Max.


Mod

Renvoie le reste d’un nombre divisé par un autre. Il s’agit du reste de la division du dividende par le diviseur. Le signe du reste est toujours le même que celui du dividende.
Syntaxe
Mod(n1, n2)
Paramètres

Paramètre

Description

n1
Le dividende : valeur ou expression numérique.

n2
Le diviseur : valeur ou expression numérique.
Si n1 et/ou n2 ne sont pas des valeurs ou des expressions numériques, la fonction renvoie 0.
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Mod :

Expression

Renvoie

Mod(64, -3)

1

Mod(-13,3)

-1

Mod("abc", 2)

0

Mod(X[0], Y[9])
La première occurrence de X sert de dividende et la dixième occurrence de Y est utilisée comme diviseur.

Mod(Round(Value[4], 2), Max(Value[*]))
La cinquième occurrence de Value arrondie à deux décimales sert de dividende et la valeur la plus élevée parmi toutes les occurrences non nulles de Value est utilisée comme diviseur.
Voir aussi Max et Round.


Round

Evalue une valeur ou expression numérique donnée et renvoie un nombre arrondi comportant un nombre de décimales défini.
Syntaxe
Round(n1 [, n2])
Paramètres

Paramètre

Description

n1
Valeur ou expression numérique à évaluer.
n2 (facultatif)
Nombre de décimales avec lesquelles n1 est évalué (maximum de 12).
Si vous omettez la valeur n2, ou si n2 n’est pas valide, la fonction ne retournera aucune décimale.
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Round :

Expression

Renvoie

Round(12.389764537, 4)

12.3898

Round(20/3, 2)

6.67

Round(8.9897, "abc")

9

Round(FV(400, 0.10/12, 30*12), 2)
904195.17. Cette fonction prend la valeur obtenue par la fonction FV et l’arrondit à deux décimales.
Voir aussi FV.

Round(Total_Price, 2)
Arrondit la valeur de Total_Price à deux décimales.


Sum

Renvoie la somme des éléments non nuls d’un ensemble donné de nombres.
Syntaxe
Sum(n1 [, n2 ...])
Paramètres

Paramètre

Description

n1
Valeur ou expression numérique.
n2 (facultatif)
Autres valeurs et/ou expressions numériques.
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Sum :

Expression

Renvoie

Sum(2, 4, 6, 8)

20

Sum(-2, 4, -6, 8)

4

Sum(4, 16, "abc", 19)

39

Sum(Amount[2], Amount[5])
Totaux des troisième et sixième occurrences de Amount.

Sum(Round(20/3, 2), Max(Amount[*]), Min(Amount[*]))
Effectue le total de la valeur de 20/3 arrondie à deux décimales, et des occurrences non nulles les plus et moins élevées de Amount.
Voir aussi Max, Min et Round.


Fonctions de date et d’heure

A propos des fonctions de date et d’heure
Date
Date2Num
DateFmt
IsoDate2Num
IsoTime2Num
LocalDateFmt
LocalTimeFmt
Num2Date
Num2GMTime
Num2Time
Time
Time2Num
TimeFmt


A propos des fonctions de date et d’heure

Les fonctions décrites dans la présente section portent spécifiquement sur la création et la gestion des valeurs de date et d’heure.
Fonctions
      •
      Date
      •
      Date2Num
      •
      DateFmt
      •
      IsoDate2Num
      •
      IsoTime2Num
      •
      LocalDateFmt
      •
      LocalTimeFmt
      •
      Num2Date
      •
      Num2GMTime
      •
      Num2Time
      •
      Time
      •
      Time2Num
      •
      TimeFmt
Un paramètre régional est un terme standard utilisé, dans le développement de normes internationales, pour identifier une nation (une langue, un pays ou les deux). En ce qui concerne FormCalc, un paramètre régional définit le format de date et d’heure ainsi que le format numérique et monétaire d’une nation ou d’une région, pour permettre aux utilisateurs de se servir des formats auxquels ils sont habitués.
Chaque paramètre régional comprend une chaîne de caractères unique appelée identificateur de paramètre régional. La composition de ces chaînes est gérée par le groupe IETF (Internet Engineering Task Force) de l’Organisation mondiale de normalisation (ISO), organe de la Société Internet (www.isoc.org).
Les identificateurs de paramètre régional se composent d’une partie langue, d’une partie pays ou des deux. Le tableau suivant présente la liste des paramètres régionaux valides avec la présente version de LiveCycle Designer.

Langage

Pays

Code ISO
Allemand
Autriche
de_AT
Allemand
Allemagne
de_DE
Allemand
Luxembourg
de_LU
Allemand
Suisse
de_CH
Anglais
Australie
en_AU
Anglais
Canada
en_CA
Anglais
Inde
en_IN
Anglais
Irlande
en_IE
Anglais
Nouvelle-Zélande
en_NZ
Anglais
Afrique du Sud
en_ZA
Anglais
Royaume-Uni
en_GB
Anglais
Royaume-Uni (Europe)
en_GB_EURO
Anglais
Etats-Unis
en_US
Arabe
Emirats arabes unis
ar_AE
Arabe
Bahreïn
ar_BH
Arabe
Algérie
ar_DZ
Arabe
Egypte
ar_EG
Arabe
Iraq
ar_IQ
Arabe
Jordanie
ar_JO
Arabe
Koweït
ar_KW
Arabe
Liban
ar_LB
Arabe
Libye
ar_LY
Arabe
Maroc
ar_MA
Arabe
Oman
ar_OM
Arabe
Qatar
ar_QA
Arabe
Arabie Saoudite
ar_SA
Arabe
Soudan
ar_SD
Arabe
Syrie
ar_SY
Arabe
Tunisie
ar_TN
Arabe
Yémen
ar_YE
Bulgare
Bulgarie
bg_BG
Chinois
Hong Kong
zh_HK
Chinois
Chinois simplifié (République populaire de Chine)
zh_CN
Chinois
Chinois traditionnel
zh_TW
Coréen
République de Corée
ko_KR
Coréen
Corée (caractères Hanja)
ko_KR_HANI
Croate
Croatie
hr_HR
Danois
Danemark
da_DK
Espagnol
Equateur
es_EC
Espagnol
El Salvador
es_SV
Espagnol
Guatemala
es_GT
Espagnol
Honduras
es_HN
Espagnol
Nicaragua
es_NI
Espagnol
Panama
es_PA
Espagnol
Paraguay
es_PY
Espagnol
Porto Rico
es_PR
Espagnol
Uruguay
es_UY
Espagnol
Argentine
es_AR
Espagnol
Bolivie
es_BO
Espagnol
Chili
es_CL
Espagnol
Colombie
es_CO
Espagnol
Costa Rica
es_CR
Espagnol
République dominicaine
es_DO
Espagnol
Mexique
es_MX
Espagnol
Pérou
es_PE
Espagnol
Espagne
es_ES
Espagnol
Venezuela
es_VE
Estonien
Estonie
et_EE
Finnois
Finlande
fi_FI
Français
Belgique
fr_BE
Français
Canada
fr_CA
Français
France
fr_FR
Français
Luxembourg
fr_LU
Français
Suisse
fr_CH
Grec
Grèce
el_GR
Hébreu
Israël
he_IL
Hongrois
Hongrie
hu_HU
Indonésien
Indonésie
id_ID
Italien
Italie
it_IT
Italien
Suisse
it_CH
Japonais
Japon
ja_JP
Letton
Lettonie
lv_LV
Lituanien
Lituanie
lt_LT
Malais
Malaisie
ms_MY
Néerlandais
Belgique
nl_BE
Néerlandais
Pays-Bas
nl_NL
Norvégien (Bokmal)
Norvège
nb_NO
Norvégien (Nynorsk)
Norvège
nn_NO
Polonais
Pologne
pl_PL
Portugais
Brésil
pt_BR
Portugais
Portugal
pt_PT
Roumain
Roumanie
ro_RO
Russe
Russie
ru_RU
Serbo-croate
Bosnie-Herzégovine
sh_BA
Serbo-croate
Croatie
sh_HR
Serbo-croate
Serbie-et-Monténégro
sh_CS
Slovaque
Slovaquie
sk_SK
Slovène
Slovénie
sl_SI
Suédois
Suède
sv_SE
Tchèque
République tchèque
cs_CAZ
Thaï
Thaïlande
th_TH
Thaï
Royaume de Thaïlande
th_TH_TH
Turc
Turquie
tr_TR
Ukrainien
Ukraine
uk_UA
Vietnamien
Vietnam
vi_VN
Habituellement, les deux éléments d’un paramètre régional sont importants. Par exemple, le nom des jours de la semaine et des mois en anglais pour le Canada et en anglais pour la Grande-Bretagne ont le même format, mais les dates sont formatées différemment. Ainsi, l’indication de la langue anglaise comme paramètre régional n’est pas suffisante. De même, l’indication du seul pays comme paramètre régional n’est pas suffisante. Par exemple, le Canada possède deux formats de date, l’un pour l’anglais et l’autre pour le français.
En général, chaque application fonctionne dans un environnement où se trouve un paramètre régional. Ce paramètre régional est ambiant. Dans certaines circonstances, une application peut fonctionner sur un système, ou dans un environnement, dans lequel ne se trouve aucun paramètre régional. Dans ces rares cas, le paramètre régional ambiant par défaut est l’anglais des Etats-Unis (en-US). Ce paramètre régional est celui par défaut.
On associe aux valeurs de date et d’heure une origine, dite époque, qui sert de point de départ chronologique. Toute valeur de date ou d’heure située avant cette époque n’est pas valide.
L’unité de valeur pour toutes les fonctions de date est le nombre de jours calculé depuis l’époque. L’unité de valeur pour toutes les fonctions d’heure est le nombre de millisecondes calculé depuis l’époque.
LiveCycle Designer définit le jour 1 de l’époque pour toutes les fonctions de date comme étant le 1er janvier 1900, et la milliseconde 1 de l’époque pour toutes les fonctions d’heure comme étant minuit, 00:00:00, en temps universel coordonné (UTC), aussi connu sous le nom de « temps moyen de Greenwich » (GMT). Cette définition signifie que les utilisateurs des fuseaux horaires situés à l’Est de l’UTC peuvent recevoir des valeurs d’heure négatives.
Un format de date est une notation abrégée déterminant la façon dont la date s'affiche. Elle comprend différents signes de ponctuation et symboles représentant le formatage utilisé par la date. Le tableau suivant fournit des exemples de formats de date :

Format de date

Exemple
MM/DD/YY
11/11/78
DD/MM/YY
25/07/85
MMMM DD, YYYY
Mars 10, 1964
Le format de date est géré par une norme ISO. Chaque pays ou région spécifie ses propres formats de date. Les quatre catégories générales de formats de date correspondent aux formats court, moyen, long et complet. Le tableau ci-dessous indique quelques exemples de formats de date, dans différents paramètres régionaux, pour chacune des quatre catégories.

Identificateur de paramètre régional et description

Format de date (catégorie)

Exemple
en_GB
Anglais (Royaume-Uni)
DD/MM/YY (Court)
08/18/92
08/04/05
fr_CA
Français (Canada)
YY-MM-DD (Moyen)
92-08-18
de_DE
Allemand (Allemagne)
D. MMMM YYYY (Long)
17. Juni 1989
fr_FR
Français (France)
EEEE, ' le ' D MMMM YYYY (Complet)
Lundi, le 29 Octobre, 1990
Un format d’heure est une notation abrégée déterminant la façon dont l’heure s’affichera. Elle comprend des signes de ponctuation, des littéraux et des symboles. Le tableau suivant propose des exemples de formats d’heure.

Format d’heure

Exemple
h:MM A
7:15 PM
HH:MM:SS
21:35:26
HH:MM:SS 'o''clock' A Z
14:20:10 o’clock PM EDT
Le format d’heure est géré par une norme ISO. Chaque nation définit ses formats d’heure par défaut, court, moyen, long, et complet. Le paramètre régional identifie le format d’heure conforme aux normes de cette nation.
Le tableau ci-dessous indique quelques exemples de formats d'heure, dans différents paramètres régionaux, pour chacune des quatre catégories.

Identificateur de paramètre régional et description

Format d'heure (Catégorie)

Exemple
en_GB
Anglais (Royaume-Uni)
HH:MM (Court)
14:13
fr_CA
Français (Canada)
HH:MM:SS (Moyen)
12:15:50
de_DE
Allemand (Allemagne)
HH:MM:SS z (Long)
14:13:13 -0400
fr_FR
Français (France)
HH ' h ' MM Z (Complet)
14 h 13 GMT-04:00
Vous devez utiliser les symboles suivants pour créer des formats de date et heure pour les champs de date/heure. Certains symboles de dates sont uniquement utilisés dans les paramètres régionaux correspondant aux langues chinoise, japonaise et coréenne. Ces symboles sont également indiqués ci-dessous.
la virgule (,), le tiret (-), le deux-points (:), la barre oblique (/), le point (.) et l'espace ( ) sont considérés comme des valeurs littérales qui peuvent être incluses n'importe où dans le format. Pour inclure du texte dans un format, délimitez la chaîne de texte par des guillemets simples ('). Par exemple, 'Your payment is due no later than' MM-DD-YY peut être spécifié comme format d'affichage.

Symboles de date

Description

Valeur formatée pour un paramètre régional Anglais (Etats-Unis) dont la valeur d'entrée tributaire du format du paramètre régional est 1/1/08 (Janvier 1, 2008)

D
Jour du mois à 1 ou 2 chiffres (1-31)
1

DD
Jour du mois à 2 chiffres avec zéro de remplissage (01-31)
01

J
Jour de l'année à 1, 2 ou 3 chiffres (1-366)
1

JJJ
Jour de l'année à 3 chiffres avec zéros de remplissage (001-366)
001

M
Mois de l'année à 1 ou 2 chiffres (1-12)
1

MM
Mois de l'année à 2 chiffres avec zéro de remplissage (01-12)
01

MMM
Nom abrégé du mois
Jan

MMMM
Nom complet du mois
Janvier

E
Jour de la semaine à 1 chiffre (1-7), où 1=Dimanche
3 (le 1er janvier 2008 correspond à un mardi)

EEE
Nom abrégé du jour de la semaine
Mar (le 1er janvier 2008 correspond à un mardi)

EEEE
Nom complet du jour de la semaine
Mardi (le 1er janvier 2008 correspond à un mardi)

YY
Année à 2 chiffres, où les nombres inférieurs à 30 se situent après l'an 2000 et où les nombres égaux et supérieurs à 30 se situent avant l'an 2000. Par exemple, 00=2000, 29=2029, 30=1930 et 99=1999.
08

YYYY
Année à 4 chiffres
2008

G
Nom de l'ère (av. J.-C. ou ap. J.-C.)
ap. J.-C.

w
Semaine du mois à 1 chiffre (0-5), où la semaine 1 est le premier groupe de 4 jours qui se termine un samedi
1

WW
Semaine de l'année à 2 chiffres (01-53) ISO-8601, où la semaine 1 représente la semaine qui contient le 4 janvier
01
Vous disposez de plusieurs autres modèles de dates correspondant aux paramètres régionaux chinois, japonais et coréen.
Les ères japonaises sont représentables à l'aide de plusieurs symboles différents. Les quatre derniers symboles d'ère constituent d'autres symboles possibles pour représenter les ères japonaises.

Symbole de date CJK

Description

DDD
Jour du mois du paramètre régional, exprimé en valeur numérique idéographique

DDDD
Jour du mois du paramètre régional, exprimé en valeur numérique idéographique (règle des dixièmes)

YYY
Année du paramètre régional, exprimée en valeur numérique idéographique

YYYYY
Année du paramètre régional, exprimée en valeur numérique idéographique (règle des dixièmes)

g
Autre nom possible désignant l'ère du paramètre régional. Pour l'ère actuelle japonaise, Heisei, ce modèle affiche la lettre H ASCII (U+48)

gg
Autre nom possible désignant l'ère du paramètre régional. Pour l'ère actuelle japonaise, ce modèle affiche l'idéogramme représenté par le symbole Unicode (U+5E73)

ggg
Autre nom possible désignant l'ère du paramètre régional. Pour l'ère actuelle japonaise, ce modèle affiche les idéogrammes représentés par les symboles Unicode (U+5E73 U+6210)

 g
Autre nom possible désignant l'ère du paramètre régional. Pour l'ère actuelle japonaise, ce modèle affiche la lettre H à pleine largeur (U+FF28)

 g g
Autre nom possible désignant l'ère du paramètre régional. Pour l'ère actuelle japonaise, ce modèle affiche l'idéogramme représenté par le symbole Unicode (U+337B)

Symbole de l'heure

Description

Valeur d'entrée tributaire du format du paramètre régional

Valeur formatée du paramètre régional Anglais (Etats-Unis)

h
Heure au format du jour (AM/PM) à 1 ou à 2 chiffres (1-12)
12:08 AM ou 2:08 PM
12 ou 2

hh
Heure au format du jour (AM/PM) à 2 chiffres avec zéro de remplissage (01-12)
12:08 AM ou 2:08 PM
12 ou 02

k
Heure au format du jour (AM/PM) à 0 ou à 2 chiffres (1-11)
12:08 AM ou 2:08 PM
0 ou 2

kk
Heure au format du jour (AM/PM) à 2 chiffres (00-11)
12:08 AM ou 2:08 PM
00 ou 02

H
Heure du jour à 1 ou 2 chiffres (0-23)
12:08 AM ou 2:08 PM
0 ou 14

HH
Heure du jour à 2 chiffres avec zéro de remplissage (00-23)
12:08 AM ou 2:08 PM
00 ou 14

K
Heure du jour à 1 ou 2 chiffres (1-24)
12:08 AM ou 2:08 PM
24 ou 14

KK
Heure du jour à 2 chiffres avec zéro de remplissage (01-24)
12:08 AM ou 2:08 PM
24 ou 14

M
Minute de l'heure à 1 ou 2 chiffres (0-59)
vous devez utiliser ce symbole dans un symbole d'heure.
2:08 PM
8

MM
Minute de l'heure à 2 chiffres avec zéro de remplissage (00-59)
vous devez utiliser ce symbole dans un symbole d'heure.
2:08 PM
08

S
Seconde de la minute à 1 ou 2 chiffres (0-59)
vous devez utiliser ce symbole dans un symbole d'heure et de minutes.
2:08:09 PM
9

SS
Seconde de la minute à 2 chiffres avec zéro de remplissage (00-59)
vous devez utiliser ce symbole dans un symbole d'heure et de minutes.
2:08:09 PM
09

FFF
Millième de la seconde à 3 chiffres (000-999)
vous devez utiliser ce symbole dans un symbole d'heure, de minute et de seconde.
2:08:09 PM
09

A
Partie de la journée comprise entre minuit et midi (AM) ou midi et minuit (PM)
2:08:09 PM
PM

z
Format de fuseau horaire ISO-8601 (par exemple, Z, +0500, -0030, -01, +0100)
vous devez utiliser ce symbole dans un symbole d'heure.
2:08:09 PM
-0400

zz
Format de fuseau horaire ISO-8601 secondaire (par exemple, Z, +05:00, -00:30, -01, +01:00)
vous devez utiliser ce symbole dans un symbole d'heure.
2:08:09 PM
-04:00

Z
Nom abrégé de fuseau horaire, par exemple, TMG, TMG+05:00, TMG-00:30, HNE, HAP
vous devez utiliser ce symbole dans un symbole d'heure.
2:08:09 PM
EDT
Symboles réservés
Les symboles qui suivent ont une signification particulière et ne peuvent pas être utilisés comme texte littéral.
?
Lorsqu'il est utilisé, ce symbole représente n'importe quel caractère. Lorsqu'il est fusionné pour l'affichage, il devient un espace.

*
Lorsqu'il est utilisé, ce symbole représente 0 ou le caractère d'espace Unicode. Lorsqu'il est fusionné pour l'affichage, il devient un espace.

+
Lorsqu'il est utilisé, ce symbole représente un ou plusieurs caractères d'espace Unicode. Lorsqu'il est fusionné pour l'affichage, il devient un espace.


Date

Renvoie la date active du système sous la forme du nombre de jours écoulés depuis l’époque.
Syntaxe
Date()
Paramètres
Non
Exemples
L’expression suivante constitue un exemple d’utilisation de la fonction Date :

Expression

Renvoie

Date()
37875 (le nombre de jours depuis l’époque jusqu’au 12 septembre 2003)


Date2Num

Renvoie le nombre de jours écoulés depuis l’époque, à partir d’une chaîne de date.
Syntaxe
Date2Num(d [, f [, k ]])
Paramètres

Paramètre

Description

d
Chaîne de date respectant le format indiqué par f qui par ailleurs se conforme au paramètre régional indiqué par k.
f (facultatif)
Chaîne de format de date. Si f est omis, le format de date par défaut MMM D, YYYY est utilisé.
k (facultatif)
Chaîne d’identification du paramètre régional qui se conforme aux normes de dénomination de ce dernier. Si k est omis (ou n’est pas valide), le paramètre régional ambiant est utilisé.
La fonction renvoie la valeur 0 si l’une des conditions suivantes est vraie :
      •
      Le format de la date fournie ne correspond pas au format indiqué dans la fonction.
      •
      Le paramètre régional ou le format de date fourni dans la fonction n’est pas valide.
Les informations fournies sont insuffisantes pour déterminer un jour unique calculé depuis l’époque (autrement dit, une information relative à la date est manquante ou incomplète).
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Date2Num :

Expression

Renvoie

Date2Num("Mar 15, 1996")

35138

Date2Num("1/1/1900", "D/M/YYYY")

1

Date2Num("03/15/96", "MM/DD/YY")

35138

Date2Num("Aug 1,1996", "MMM D, YYYY")

35277

Date2Num("96-08-20", "YY-MM-DD", "fr_FR")

35296

Date2Num("1/3/00", "D/M/YY") - Date2Num("1/2/00", "D/M/YY")

29


DateFmt

Renvoie une chaîne de format de date, à partir d’un style de format de date.
Syntaxe
DateFmt([n [, k ]])
Paramètres

Paramètre

Description
n (facultatif)
Entier qui identifie le style de format d’heure propre au paramètre régional, de la façon suivante :
      •
      1 (style court)
      •
      2 (style moyen)
      •
      3 (style long)
      •
      4 (style complet)
Si n est omis (ou n’est pas valide), la valeur de style par défaut est 0.
k (facultatif)
Chaîne d’identification du paramètre régional qui se conforme aux normes de dénomination de ce dernier. Si k est omis (ou n’est pas valide), le paramètre régional ambiant est utilisé.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction DateFmt :

Expression

Renvoie

DateFmt(1)
M/D/YY (si le paramètre régional en_US est défini)

DateFmt(2, "fr_CA")

YY-MM-DD

DateFmt(3, "de_DE")

D. MMMM YYYY

DateFmt(4, "fr_FR")

EEEE D' MMMM YYYY


IsoDate2Num

Renvoie le nombre de jours écoulés depuis l’époque, à partir d’une chaîne de date valide.
Syntaxe
IsoDate2Num(d)
Paramètres

Paramètre

Description

d
Chaîne de date valide.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction IsoDate2Num :

Expression

Renvoie

IsoDate2Num("1900")

1

IsoDate2Num("1900-01")

1

IsoDate2Num("1900-01-01")

1

IsoDate2Num("19960315T20:20:20")

35138

IsoDate2Num("2000-03-01") - IsoDate2Num("20000201")

29


IsoTime2Num

Renvoie le nombre de millisecondes écoulées depuis l’époque, à partir d’une chaîne d’heure valide.
Syntaxe
IsoTime2Num(d)
Paramètres

Paramètre

Description

d
Chaîne d’heure valide.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction IsoTime2Num :

Expression

Renvoie

IsoTime2Num("00:00:00Z")
1, pour un utilisateur situé dans le fuseau horaire de l’heure normale de l’Est.

IsoTime2Num("13")
64800001, pour un utilisateur situé à Boston, aux États-Unis.

IsoTime2Num("13:13:13")
76393001, pour un utilisateur situé en Californie.

IsoTime2Num("19111111T131313+01")
43993001, pour un utilisateur situé dans le fuseau horaire de l’heure normale de l’Est.


LocalDateFmt

Renvoie une chaîne de format de date localisée, à partir d’un style de format de date.
Syntaxe
LocalDateFmt([n [, k ]])
Paramètres

Paramètre

Description
n (facultatif)
Entier qui identifie le style de format de date propre au paramètre régional, de la façon suivante :
      •
      1 (style court)
      •
      2 (style moyen)
      •
      3 (style long)
      •
      4 (style complet)
Si n est omis (ou n’est pas valide), la valeur de style par défaut est 0.
k (facultatif)
Chaîne d’identification du paramètre régional qui se conforme aux normes de dénomination de ce dernier. Si k est omis (ou n’est pas valide), le paramètre régional ambiant est utilisé.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction LocalDateFmt :

Expression

Renvoie

LocalDateFmt(1, "de_DE")

tt.MM.uu

LocalDateFmt(2, "fr_CA")

aa-MM-jj

LocalDateFmt(3, "de_CH")

t. MMMM jjjj

LocalDateFmt(4, "fr_FR")

EEEE j MMMM aaaa


LocalTimeFmt

Renvoie une chaîne de format d’heure localisée, à partir d’un style de format d’heure.
Syntaxe
LocalTimeFmt([n [, k ]])
Paramètres

Paramètre

Description
n (Facultatif)
Entier qui identifie le style de format d’heure propre au paramètre régional, de la façon suivante :
      •
      1 (style court)
      •
      2 (style moyen)
      •
      3 (style long)
      •
      4 (style complet)
Si n est omis (ou n’est pas valide), la valeur de style par défaut est 0.
k (Facultatif)
Chaîne d’identification du paramètre régional qui se conforme aux normes de dénomination de ce dernier. Si k est omis (ou n’est pas valide), le paramètre régional ambiant est utilisé.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction LocalTimeFmt :

Expression

Renvoie

LocalTimeFmt(1, "de_DE")

HH:mm

LocalTimeFmt(2, "fr_CA")

HH:mm:ss

LocalTimeFmt(3, "de_CH")

HH:mm:ss z

LocalTimeFmt(4, "fr_FR")

HH' h 'mm z


Num2Date

Renvoie une chaîne de date, à partir du nombre de jours écoulés depuis l’époque.
Syntaxe
Num2Date(n [,f [, k ]])
Paramètres

Paramètre

Description

n
Entier représentant le nombre de jours.
Si n n’est pas valide, la fonction renvoie une erreur.
f (Facultatif)
Chaîne de format de date. Si vous omettez la valeur f, la fonction utilise le format de date par défaut MMM D, YYYY.
k (Facultatif)
Chaîne d’identification du paramètre régional qui se conforme aux normes de dénomination de ce dernier. Si vous omettez la valeur k, ou si k n’est pas valide, la fonction utilise le paramètre régional ambiant.
La fonction renvoie la valeur 0 si l’une des conditions suivantes est vraie :
      •
      Le format de la date fournie ne correspond pas au format indiqué dans la fonction.
      •
      Le paramètre régional ou le format de date fourni dans la fonction n’est pas valide.
Les informations fournies sont insuffisantes pour déterminer un jour unique calculé depuis l’époque (autrement dit, une information relative à la date est manquante ou incomplète).
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Num2Date :

Expression

Renvoie

Num2Date(1, "DD/MM/YYYY")

01/01/1900

Num2Date(35139, "DD-MMM-YYYY", "de_DE")

16-Mrz-1996

Num2Date(Date2Num("Mar 15, 2000") - Date2Num("98-03-15", "YY-MM-DD", "fr_CA"))

Jan 1, 1902


Num2GMTime

Renvoie une chaîne d’heure UT, à partir du nombre de millisecondes écoulées depuis l’époque.
Syntaxe
Num2GMTime(n [,f [, k ]])
Paramètres

Paramètre

Description

n
Entier représentant le nombre de millisecondes.
Si n n’est pas valide, la fonction renvoie une erreur.
f (Facultatif)
Chaîne de format d’heure. Si vous omettez la valeur f, la fonction utilise le format d’heure par défaut H:MM:SS A.
k (Facultatif)
Chaîne d’identification du paramètre régional qui se conforme aux normes de dénomination de ce dernier. Si vous omettez la valeur k, ou si k n’est pas valide, la fonction utilise le paramètre régional ambiant.
La fonction renvoie la valeur 0 si l’une des conditions suivantes est vraie :
      •
      Le format de l’heure fournie ne correspond pas au format indiqué dans la fonction.
      •
      Le paramètre régional ou le format d’heure fourni dans la fonction n’est pas valide.
Les informations fournies sont insuffisantes pour déterminer une heure unique calculée depuis l’époque (autrement dit, une information relative à l’heure est manquante ou incomplète).
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Num2GMTime :

Expression

Renvoie

Num2GMTime(1, "HH:MM:SS")

00:00:00

Num2GMTime(65593001, "HH:MM:SS Z")

18:13:13 GMT

Num2GMTime(43993001, TimeFmt(4, "de_DE"), "de_DE")

12.13 Uhr GMT


Num2Time

Renvoie une chaîne d’heure, à partir du nombre de millisecondes écoulées depuis l’époque.
Syntaxe
Num2Time(n [,f [, k ]])
Paramètres

Paramètre

Description

n
Entier représentant le nombre de millisecondes.
Sinn’est pas valide, la fonction renvoie une erreur.
f (Facultatif)
Chaîne de format d’heure. Si vous omettez la valeur f, la fonction utilise le format d’heure par défaut H:MM:SS A.
k (Facultatif)
Chaîne d’identification du paramètre régional qui se conforme aux normes de dénomination de ce dernier. Si vous omettez la valeur k, ou si k n’est pas valide, la fonction utilise le paramètre régional ambiant.
La fonction renvoie la valeur 0 si l’une des conditions suivantes est vraie :
      •
      Le format de l’heure fournie ne correspond pas au format indiqué dans la fonction.
      •
      Le paramètre régional ou le format d’heure fourni dans la fonction n’est pas valide.
Les informations fournies sont insuffisantes pour déterminer une heure unique calculée depuis l’époque (autrement dit, une information relative à l’heure est manquante ou incomplète).
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Num2Time :

Expression

Renvoie

Num2Time(1, "HH:MM:SS")
00:00:00 à Greenwich, en Angleterre, et 09:00:00 à Tokyo.

Num2Time(65593001, "HH:MM:SS Z")
13:13:13 EST à Boston, aux États-Unis.

Num2Time(65593001, "HH:MM:SS Z", "de_DE")
13:13:13 GMT-05:00 pour un utilisateur suisse allemand à Boston, aux Etats-Unis.

Num2Time(43993001, TimeFmt(4, "de_DE"), "de_DE")
13.13 Uhr GMT+01:00 pour un utilisateur situé à Zurich, en Suisse.

Num2Time(43993001, "HH:MM:SSzz")
13:13+01:00 pour un utilisateur situé à Zurich, en Suisse.


Time

Renvoie l’heure actuelle du système sous la forme du nombre de millisecondes écoulées depuis l’époque.
Syntaxe
Time()
Paramètres
Non
Exemples
L’expression suivante constitue un exemple d’utilisation de la fonction Time :

Expression

Renvoie

Time()
71533235 à précisément 15:52:15 le 15 septembre 2003 pour un utilisateur situé dans le fuseau horaire de l’heure normale de l’Est (HNE).


Time2Num

Renvoie le nombre de millisecondes écoulées depuis l’époque, à partir d’une chaîne d’heure.
Syntaxe
Time2Num(d [, f [, k ]])
Paramètres

Paramètre

Description

d
Chaîne d’heure respectant le format indiqué par f qui par ailleurs se conforme au paramètre régional indiqué par k.
f (Facultatif)
Chaîne de format d’heure. Si vous omettez la valeur f, la fonction utilise le format d’heure par défaut H:MM:SS A.
k (Facultatif)
Chaîne d’identification du paramètre régional qui se conforme aux normes de dénomination de ce dernier. Si vous omettez la valeur k, ou si k n’est pas valide, la fonction utilise le paramètre régional ambiant.
La fonction renvoie la valeur 0 si l’une des conditions suivantes est vraie :
      •
      Le format de l’heure fournie ne correspond pas au format indiqué dans la fonction.
      •
      Le paramètre régional ou le format d’heure fourni dans la fonction n’est pas valide.
Les informations fournies sont insuffisantes pour déterminer une heure unique calculée depuis l’époque (autrement dit, une information relative à l’heure est manquante ou incomplète).
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Time2Num :

Expression

Renvoie

Time2Num("00:00:00 GMT", "HH:MM:SS Z")

1

Time2Num("1:13:13 PM")
76393001 pour un utilisateur situé en Californie qui suit l’heure normale du Pacifique, et 76033001 lorsque le même utilisateur suit l’heure avancée du Pacifique.

Time2Num("13:13:13", "HH:MM:SS") - Time2Num("13:13:13 GMT", "HH:MM:SS Z")) / (60 * 60 * 1000)
8 pour un utilisateur situé à Vancouver et 5 pour un utilisateur situé à Ottawa, à l’heure normale. A l’heure avancée, les valeurs renvoyées sont 7 et 4, respectivement.

Time2Num("13:13:13 GMT", "HH:MM:SS Z", "fr_FR")

47593001


TimeFmt

Renvoie un format d’heure, à partir d’un style de format d’heure.
Syntaxe
TimeFmt([n [, k ]])
Paramètres

Paramètre

Description
n (Facultatif)
Entier qui identifie le style de format d’heure propre au paramètre régional, de la façon suivante :
      •
      1 (style court)
      •
      2 (style moyen)
      •
      3 (style long)
      •
      4 (style complet)
Si vous omettez la valeur n, ou si n n’est pas valide, la fonction utilise la valeur de style par défaut.
k (Facultatif)
Chaîne d’identification du paramètre régional qui se conforme aux normes de dénomination de ce dernier. Si k est omis (ou n’est pas valide), le paramètre régional ambiant est utilisé.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction TimeFmt :

Expression

Renvoie

TimeFmt(1)

h:MM A (if en_US locale is set)

TimeFmt(2, "fr_CA")

HH:MM:SS

TimeFmt(3, "fr_FR")

HH:MM:SS Z

TimeFmt(4, "de_DE")

H.MM' Uhr 'Z


Fonctions financières

A propos des fonctions financières
Apr
CTerm
FV
IPmt
NPV
Pmt
PPmt
PV
Rate
Term


A propos des fonctions financières

Ces fonctions effectuent différents calculs d’intérêt, de principal et d’évaluation liés au secteur financier.
Fonctions
      •
      Apr
      •
      CTerm
      •
      FV
      •
      IPmt
      •
      NPV
      •
      Pmt
      •
      PPmt
      •
      PV
      •
      Rate
      •
      Term


Apr

Renvoie le taux annuel d’un prêt.
les méthodes de calcul du taux d’intérêt varient d’un pays à l’autre. Cette fonction calcule le taux d’intérêt d’après les normes américaines.
Syntaxe
Apr(n1, n2, n3)
Paramètres

Paramètre

Description

n1
Valeur ou expression numérique représentant le montant du principal du prêt.

n2
Valeur ou expression numérique représentant le montant du versement envers le remboursement du prêt.

n3
Valeur ou expression numérique représentant le nombre de périodes correspondant à la durée du prêt.
Si un paramètre est nul, la fonction renvoie null. Si un paramètre est négatif ou équivalent à 0, la fonction renvoie une erreur.
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Apr :

Expression

Renvoie

Apr(35000, 269.50, 360)
0.08515404566pour un prêt de 35 000 $ remboursé à raison de 269.50 $ par mois pendant 30 ans.

Apr(210000 * 0.75, 850 + 110, 25 * 26)

0.07161332404

Apr(-20000, 250, 120)
Erreur

Apr(P_Value, Payment, Time)
Cet exemple utilise des variables au lieu de valeurs ou expressions numériques.


CTerm

Renvoie le nombre de périodes nécessaires pour qu’un investissement, dont le taux d’intérêt est fixe mais composé, atteigne une valeur capitalisée.
les méthodes de calcul du taux d’intérêt varient d’un pays à l’autre. Cette fonction calcule le taux d’intérêt d’après les normes américaines.
Syntaxe
CTerm(n1, n2, n3)
Paramètres

Paramètre

Description

n1
Valeur ou expression numérique représentant le taux d’intérêt par période.

n2
Valeur ou expression numérique représentant la valeur capitalisée de l’investissement.

n3
Valeur ou expression numérique représentant le montant de l’investissement de départ.
Si un paramètre est nul, la fonction renvoie null. Si un paramètre est négatif ou équivalent à 0, la fonction renvoie une erreur.
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction CTerm :

Expression

Renvoie

CTerm(0.02, 1000, 100)

116.2767474515

CTerm(0.10, 500000, 12000)

39.13224648502

CTerm(0.0275 + 0.0025, 1000000, 55000 * 0.10)

176.02226044975

CTerm(Int_Rate, Target_Amount, P_Value)
Cet exemple utilise des variables au lieu de valeurs ou expressions numériques.


FV

Renvoie la valeur capitalisée de paiements fixes effectués à intervalles réguliers, compte tenu d’un taux d’intérêt fixe.
les méthodes de calcul du taux d’intérêt varient d’un pays à l’autre. Cette fonction calcule le taux d’intérêt d’après les normes américaines.
Syntaxe
FV(n1, n2, n3)
Paramètres

Paramètre

Description

n1
Valeur ou expression numérique représentant le montant du versement.

n2
Valeur ou expression numérique représentant l’intérêt par période de l’investissement.

n3
Valeur ou expression numérique représentant le nombre total de périodes de versement.
La fonction renvoie une erreur si l’une des conditions suivantes est vraie :
      •
      n1 ou n3 est négatif ou équivalent à 0.
      •
      n2 est négatif.
Si un paramètre est nul, la fonction renvoie nul.
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction FV :

Expression

Renvoie

FV(400, 0.10 / 12, 30 * 12)
904195.16991842445. Valeur, après 30 ans, d’un investissement de 400 $ par mois rapportant 10 % annuellement.

FV(1000, 0.075 / 4, 10 * 4)
58791.96145535981. Valeur, après 10 ans, d’un investissement de 1 000 $ par mois rapportant 7,5 % par trimestre.

FV(Payment[0], Int_Rate / 4, Time)
Cet exemple utilise des variables au lieu de valeurs ou expressions numériques.


IPmt

Renvoie le montant de l’intérêt payé pour un prêt au cours d’une période donnée.
les méthodes de calcul du taux d’intérêt varient d’un pays à l’autre. Cette fonction calcule le taux d’intérêt d’après les normes américaines.
Syntaxe
IPmt(n1, n2, n3, n4, n5)
Paramètres

Paramètre

Description

n1
Valeur ou expression numérique représentant le montant du principal du prêt.

n2
Valeur ou expression numérique représentant le taux d’intérêt annuel de l’investissement.

n3
Valeur ou expression numérique représentant le montant du versement mensuel.

n4
Valeur ou expression numérique représentant le premier mois où un paiement est effectué.

n5
Valeur ou expression numérique représentant le nombre de mois à prendre en compte dans le calcul.
La fonction renvoie une erreur si l’une des conditions suivantes est vraie :
      •
      n1, n2 ou n3 est négatif ou équivalent à 0.
      •
      n4 ou n5 est négatif.
Si un paramètre est nul, la fonction renvoie null. Si le montant du versement (n3) est inférieur aux intérêts mensuels, la fonction renvoie 0.
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction IPmt :

Expression

Renvoie

IPmt(30000, 0.085, 295.50, 7, 3)
624.8839283142. Montant des intérêts versés sur un prêt de 30 000 $ contracté à 8,5 %, pour les trois mois situés entre les septième et dixième mois du terme du prêt.

IPmt(160000, 0.0475, 980, 24, 12)
7103.80833569485. Montant du principal remboursé pendant la troisième année du prêt.

IPmt(15000, 0.065, 65.50, 15, 1)
0, puisque le versement mensuel est inférieur aux intérêts courus chaque mois.


NPV

Renvoie la valeur nette actualisée d’un investissement, compte tenu d’une série de mouvements futurs de l’encaisse et d’un taux d’actualisation.
les méthodes de calcul du taux d’intérêt varient d’un pays à l’autre. Cette fonction calcule le taux d’intérêt d’après les normes américaines.
Syntaxe
NPV(n1, n2 [, ...])
Paramètres

Paramètre

Description

n1
Valeur ou expression numérique représentant le taux d’actualisation au cours d’une période.

n2
Valeur ou expression numérique représentant une valeur de mouvement d’encaisse, qui doit survenir à la fin de la période. Il est important que les valeurs indiquées dans n2 et au-delà soient dans l’ordre adéquat.
La fonction renvoie une erreur si la valeur de n1 est négative ou égale à 0. Si l’un des paramètres est nul, la fonction renvoie « null ».
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction NPV :

Expression

Renvoie

NPV(0.065, 5000)
4694.83568075117, qui est la valeur nette actualisée d’un investissement rapportant 6,5 % par an et qui générera 5 000 $.

NPV(0.10, 500, 1500, 4000, 10000)
11529.60863329007, qui est la valeur nette actualisée d’un investissement rapportant 10 % par année et qui générera 500 $, 1 500 $, 4 000 $ et 10 000 $ pour chacune des quatre prochaines années.

NPV(0.0275 / 12, 50, 60, 40, 100, 25)
273.14193838457, qui est la valeur nette actualisée d’un investissement rapportant 2,75 % par an et qui générera 50 $, 60 $, 40 $, 100 $ et 25 $ pour chacun des cinq prochains mois.


Pmt

Renvoie le remboursement d’un prêt basé sur des versements fixes et sur un taux d’intérêt fixe.
les méthodes de calcul du taux d’intérêt varient d’un pays à l’autre. Cette fonction calcule le taux d’intérêt d’après les normes américaines.
Syntaxe
Pmt(n1, n2, n3)
Paramètres

Paramètre

Description

n1
Valeur ou expression numérique représentant le montant du principal du prêt.

n2
Valeur ou expression numérique représentant le taux d’intérêt par période de l’investissement.

n3
Valeur ou expression numérique représentant le nombre total de périodes de versement.
La fonction renvoie une erreur si l’un des paramètres est négatif ou égal à 0. Si l’un des paramètres est nul, la fonction renvoie « null ».
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Pmt :

Expression

Renvoie

Pmt(150000, 0.0475 / 12, 25 * 12)
855.17604207164, qui est le versement mensuel d’un prêt de 150 000 $ assorti d’un taux d’intérêt annuel de 4,75 %, remboursable en 25 ans.

Pmt(25000, 0.085, 12)
3403.82145169876, qui est le versement annuel d’un prêt de 25 000 $ assorti d’un taux d’intérêt annuel de 8,5 %, remboursable en 12 ans.


PPmt

Renvoie le montant du principal payé pour un prêt au cours d’une période.
les méthodes de calcul du taux d’intérêt varient d’un pays à l’autre. Cette fonction calcule le taux d’intérêt d’après les normes américaines.
Syntaxe
PPmt(n1, n2, n3, n4, n5)
Paramètres

Paramètre

Description

n1
Valeur ou expression numérique représentant le montant du principal du prêt.

n2
Valeur ou expression numérique représentant le taux d’intérêt annuel.

n3
Valeur ou expression numérique représentant le montant du versement mensuel.

n4
Valeur ou expression numérique représentant le premier mois où un paiement est effectué.

n5
Valeur ou expression numérique représentant le nombre de mois à prendre en compte dans le calcul.
La fonction renvoie une erreur si l’une des conditions suivantes est vraie :
      •
      n1, n2 ou n3 est négatif ou équivalent à 0.
      •
      n4 ou n5 est négatif.
Si un paramètre est nul, la fonction renvoie null. Si le montant du versement (n3) est inférieur aux intérêts mensuels, la fonction renvoie 0.
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction PPmt :

Expression

Renvoie

PPmt(30000, 0.085, 295.50, 7, 3)
261.6160716858, qui est le montant du principal remboursé sur un prêt de 30 000 $ contracté à 8,5 %, pour les trois mois situés entre les septième et dixième mois du terme du prêt.

PPmt(160000, 0.0475, 980, 24, 12)
4656.19166430515, qui est le montant du principal remboursé pendant la troisième année du prêt.

PPmt(15000, 0.065, 65.50, 15, 1)
0, car dans le cas présent, le versement mensuel est inférieur aux intérêts courus chaque mois et aucune partie du principal n’a été remboursée.


PV

Renvoie la valeur actualisée d’un investissement réalisé par versements fixes périodiques avec un taux d’intérêt fixe.
les méthodes de calcul du taux d’intérêt varient d’un pays à l’autre. Cette fonction calcule le taux d’intérêt d’après les normes américaines.
Syntaxe
PV(n1, n2, n3)
Paramètres

Paramètre

Description

n1
Valeur ou expression numérique représentant le montant du versement.

n2
Valeur ou expression numérique représentant l’intérêt par période de l’investissement.

n3
Valeur ou expression numérique représentant le nombre total de périodes de versement.
La fonction renvoie une erreur si la valeur de n1 ou de n3 est négative ou égale à 0. Si l’un des paramètres est nul, la fonction renvoie « null ».
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction PV :

Expression

Renvoie

PV(400, 0.10 / 12, 30 * 12)
45580.32799074439. Valeur, après 30 ans, d’un investissement de 400 $ par mois rapportant 10 % annuellement.

PV(1000, 0.075 / 4, 10 * 4)
58791.96145535981. Valeur, après dix ans, d’un investissement de 1 000 $ par mois rapportant 7,5 % par trimestre.

PV(Payment[0], Int_Rate / 4, Time)
Cet exemple utilise des variables au lieu de valeurs ou expressions numériques.


Rate

Renvoie le taux d’intérêt composé par période nécessaire pour qu’un investissement d’une valeur actualisée atteigne une valeur capitalisée au cours d’une période donnée.
les méthodes de calcul du taux d’intérêt varient d’un pays à l’autre. Cette fonction calcule le taux d’intérêt d’après les normes américaines.
Syntaxe
Rate(n1, n2, n3)
Paramètres

Paramètre

Description

n1
Valeur ou expression numérique représentant la valeur capitalisée de l’investissement.

n2
Valeur ou expression numérique représentant la valeur actualisée de l’investissement.

n3
Valeur ou expression numérique représentant le nombre total de périodes de versement.
La fonction renvoie une erreur si l’un des paramètres est négatif ou égal à 0. Si l’un des paramètres est nul, la fonction renvoie « null ».
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Rate :

Expression

Renvoie

Rate(12000, 8000, 5)
0.0844717712 (ou 8,45 %), qui est le taux d’intérêt par période nécessaire pour que la valeur actuelle de 8 000 $ atteigne 12 000 $ en cinq périodes.

Rate(10000, 0.25 * 5000, 4 * 12)
0.04427378243 (ou 4,43 %), qui est le taux d’intérêt mensuel nécessaire pour que la valeur actuelle atteigne 10 000 $ en quatre ans.

Rate(Target_Value, Pres_Value[*], Term * 12)
Cet exemple utilise des variables au lieu de valeurs ou expressions numériques.


Term

Renvoie le nombre de périodes nécessaires pour atteindre la valeur capitalisée donnée, compte tenu de paiements fixes périodiques versés sur un compte portant intérêt.
les méthodes de calcul du taux d’intérêt varient d’un pays à l’autre. Cette fonction calcule le taux d’intérêt d’après les normes américaines.
Syntaxe
Term(n1, n2, n3)
Paramètres

Paramètre

Description

n1
Valeur ou expression numérique représentant le montant du versement effectué à la fin de chaque période.

n2
Valeur ou expression numérique représentant le taux d’intérêt par période de l’investissement.

n3
Valeur ou expression numérique représentant la valeur capitalisée de l’investissement.
La fonction renvoie une erreur si l’un des paramètres est négatif ou égal à 0. Si l’un des paramètres est nul, la fonction renvoie « null ».
FormCalc respecte la norme internationale IEEE-754 en matière de gestion des valeurs numériques à virgule flottante. Pour plus de détails, voir Littéraux numériques.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Term :

Expression

Renvoie

Term(475, .05, 1500)
3.00477517728 (soit environ 3), qui est le nombre de périodes nécessaires pour qu’un versement de 475 $ atteigne 1 500 $, avec un taux d’intérêt de 5 % par période.

Term(2500, 0.0275 + 0.0025, 5000)
1.97128786369, qui est le nombre de périodes nécessaires pour que des versements de 2 500 $ atteignent 5 000 $, avec un taux d’intérêt de 3 % par période.

Rate(Inv_Value[0], Int_Rate + 0.0050, Target_Value)
Cet exemple utilise des variables au lieu de valeurs ou expressions numériques. Dans le présent cas, la première occurrence de la variable Inv_Value sert de montant de versement, un demi point de pourcentage est ajouté à la variable Int_Rate qui représente le taux d’intérêt, et la variable Target_Value correspond à la valeur capitalisée de l’investissement.


Fonctions logiques

A propos des fonctions logiques
Choose
Exists
HasValue
Oneof
Within


A propos des fonctions logiques

Ces fonctions sont utiles pour tester et analyser des informations dans le but d’obtenir un résultat vrai ou faux.
Fonctions
      •
      Choose
      •
      Exists
      •
      HasValue
      •
      Oneof
      •
      Within


Choose

Sélectionne une valeur dans un ensemble de paramètres donné.
Syntaxe
Choose(n, s1 [, s2 ...])
Paramètres

Paramètre

Description

n
Position de la valeur que vous souhaitez sélectionner dans l’ensemble. Si cette valeur n’est pas un nombre entier, la fonction arrondit n en faisant fi des décimales.
Cette fonction renvoie une chaîne vide si l’une ou l’autre des conditions suivantes est vraie :
      •
      n est inférieur à 1.
      •
      n est supérieur au nombre d’éléments contenus dans la liste.
Si n est nul, la fonction renvoie « null ».

s1
Première valeur de l’ensemble de valeurs.
s2 (Facultatif)
Autres valeurs de l’ensemble.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Choose :

Expression

Renvoie

Choose(3, "Taxes", "Price", "Person", "Teller")

Person

Choose(2, 10, 9, 8, 7, 6, 5, 4, 3, 2, 1)

9

Choose(Item_Num[0], Items[*])
Renvoie la valeur de l’ensemble Items qui correspond à la position définie par la première occurrence de Item_Num.

Choose(20/3, "A", "B", "C", "D", "E", "F", "G", "H")

F


Exists

Détermine si le paramètre donné est une syntaxe de référence à un objet existant.
Syntaxe
Exists(v)
Paramètres

Paramètre

Description

v
Expression de syntaxe de référence valide.
Si v n’est pas une syntaxe de référence, la fonction renvoie « false » (0).
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Exists :

Expression

Renvoie

Exists(Item)
True (1) si l’objet Item existe et false (0) dans le cas contraire.

Exists("hello world")
False (0). La chaîne n’est pas une syntaxe de référence.

Exists(Invoice.Border.Edge[1].Color)
True (1) si l’objet Invoice existe et possède la propriété Border, laquelle est définie au moins par une propriété Edge, qui dispose quant à elle de la propriété Color. Sinon, la fonction renvoie false (0).


HasValue

Détermine si le paramètre indiqué est une syntaxe de référence dont la valeur n’est ni nulle, ni vide, ni un blanc.
Syntaxe
HasValue(v)
Paramètres

Paramètre

Description

v
Expression de syntaxe de référence valide.
Si v n’est pas une syntaxe de référence, la fonction renvoie « false » (0).
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction HasValue.

Expression

Renvoie

HasValue(2)
True (1)

HasValue(" ")
False (0)

HasValue(Amount[*])
Erreur

HasValue(Amount[0])
Evalue la première occurrence de Amount et renvoie true (1) si sa valeur n’est ni nulle, ni vide, ni un blanc.


Oneof

Détermine si la valeur fournie fait partie d’un ensemble.
Syntaxe
Oneof(s1, s2 [, s3 ...])
Paramètres

Paramètre

Description

s1
Position de la valeur que vous souhaitez sélectionner dans l’ensemble. Si cette valeur n’est pas un nombre entier, la fonction arrondit s1 en faisant fi des décimales.

s2
Première valeur de l’ensemble de valeurs.
s3 (Facultatif)
Autres valeurs de l’ensemble.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Oneof :

Expression

Renvoie

Oneof(3, 10, 9, 8, 7, 6, 5, 4, 3, 2, 1)
True (1)

Oneof("John", "Bill", "Gary", "Joan", "John", "Lisa")
True (1)

Oneof(3, 1, 25)
False (0)

Oneof("loan", Fields[*])
Détermine si une occurrence de Fields a la valeur de loan.


Within

Détermine si la valeur fournie est dans une plage donnée.
Syntaxe
Within(s1, s2, s3)
Paramètres

Paramètre

Description

s1
Valeur à tester.
Si s1 est un nombre, la comparaison d’ordonnancement est numérique.
Si s1 n’est pas un nombre, la comparaison d’ordonnancement utilise la séquence de classement du paramètre régional actuel. Pour plus de détails, voir Paramètres régionaux.
Si s1 est nul, la fonction renvoie « null ».

s2
Limite inférieure de la plage de test.

s3
Limite supérieure de la plage de test.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Within :

Expression

Renvoie

Within("C", "A", "D")
True (1)

Within(1.5, 0, 2)
True (1)

Within(-1, 0, 2)
False (0)

Within($, 1, 10)
True (1) si la valeur actuelle se situe entre 1 et 10.


Fonctions diverses

A propos des fonctions diverses
Eval
Null
Ref
UnitType
UnitValue


A propos des fonctions diverses

Les fonctions décrites dans la présente section ne font partie d’aucune catégorie de fonctions particulière, et sont utiles dans de multiples applications.
Fonctions
      •
      Eval
      •
      Null
      •
      Ref
      •
      UnitType
      •
      UnitValue


Eval

Renvoie la valeur d’un calcul de formulaire donné.
Syntaxe
Eval(s)
Paramètres

Paramètre

Description

s
Chaîne valide représentant une expression ou une liste d’expressions.
la fonction Eval ne peut pas faire référence à des variables ou à des fonctions définies par l’utilisateur. Par exemple :
var s = "var t = concat(s, ""hello"")"
eval(s)
Dans ce cas, la fonction Eval ne reconnaît pas s et renvoie une erreur. Toutes les fonctions suivantes faisant référence à la variable s échouent également.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Eval :

Expression

Renvoie

eval("10*3+5*4")

50

eval("hello")

error


Null

Renvoie la valeur nulle. La valeur nulle signifie aucune valeur.
Définition
Null()
Paramètres
Non
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Null :

Expression

Renvoie

Null()

null
Null() + 5

5

Quantity = Null()
Assigne la valeur null à l’objet Quantity.

Concat("ABC", Null(), "DEF")

ABCDEF
Voir aussi Concat.


Ref

Renvoie une référence à un objet existant.
Définition
Ref(v)
Paramètres

Paramètres

Description

v
Chaîne valide représentant une syntaxe de référence, une propriété, une méthode ou une fonction.
si un paramètre est nul, la fonction renvoie null. Pour tous les autres paramètres, la fonction génère une erreur.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Ref :

Expressions

Renvoie

Ref("10*3+5*4")

10*3+5*4

Ref("hello")

hello


UnitType

Renvoie les unités d’une étendue d’unité. Une étendue d’unité est une chaîne composée d’un nombre suivi d’un nom d’unité.
Syntaxe
UnitType(s)
Paramètres

Paramètre

Description

s
Chaîne valide contenant une valeur numérique et une unité de mesure valide (unitspan). Unités de mesure reconnues :
      •
      in, inches (pouces)
      •
      mm, millimètres
      •
      cm, centimètres
      •
      pt, picas, points
      •
      mp, millipoints
Si s n’est pas valide, la fonction renvoie in.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction UnitType :

Expression

Résultats

UnitType("36 in")

in

UnitType("2.54centimeters")

cm

UnitType("picas")

pt

UnitType("2.cm")

cm

UnitType("2.zero cm")

in

UnitType("kilometers")

in

UnitType(Size[0])
Renvoie la valeur de la mesure de la première occurrence de Size.


UnitValue

Renvoie la valeur numérique d’une mesure avec l’étendue d’unité qui lui est associée, après une conversion d’unité facultative. Une étendue d’unité est une chaîne composée d’un nombre suivi d’une unité de mesure valide.
Syntaxe
UnitValue(s1 [, s2 ])
Paramètres

Paramètres

Description

s1
Chaîne valide contenant une valeur numérique et une unité de mesure valide (unitspan). Unités de mesure reconnues :
      •
      in, inches (pouces)
      •
      mm, millimètres
      •
      cm, centimètres
      •
      pt, picas, points
      •
      mp, millipoints
s2 (facultatif)
Chaîne contenant une unité de mesure valide. La fonction convertit l’unitspan indiquée dans s1 en cette nouvelle unité de mesure.
Si vous n’incluez pas une valeur pour s2, la fonction utilise l’unité de mesure indiquée dans s1. Si s2 n’est pas valide, la fonction convertit s1 en pouces.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction UnitValue :

Expression

Renvoie

UnitValue("2in")

2

UnitValue("2in", "cm")

5.08

UnitValue("6", "pt")

432

UnitValue("A", "cm")

0

UnitValue(Size[2], "mp")
Renvoie la valeur de la mesure de la troisième occurrence de Size convertie en millipoints.

UnitValue("5.08cm", "kilograms")

2


Fonctions de chaîne

A propos des fonctions de chaîne
At
Concat
Decode
Encode
Format
Left
Len
Lower
Ltrim
Parse
Replace
Right
Rtrim
Space
Str
Stuff
Substr
Upper
Uuid
WordNum


A propos des fonctions de chaîne

Les fonctions décrites dans la présente section portent sur la manipulation, l’évaluation et la création de valeurs de chaîne.
Fonctions
      •
      At
      •
      Concat
      •
      Decode
      •
      Encode
      •
      Format
      •
      Left
      •
      Len
      •
      Lower
      •
      Ltrim
      •
      Parse
      •
      Replace
      •
      Right
      •
      Rtrim
      •
      Space
      •
      Str
      •
      Stuff
      •
      Substr
      •
      Upper
      •
      Uuid
      •
      WordNum


At

Repère la position du premier caractère d’une chaîne dans une autre chaîne.
Syntaxe
At(s1, s2)
Paramètres

Paramètre

Description

s1
Chaîne source.

s2
Chaîne de recherche.
Si s2 n’est pas une partie de s1, la fonction renvoie 0.
Si s2 est vide, la fonction renvoie 1.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction At :

Expression

Renvoie

At("ABCDEFGH", "AB")

1

At("ABCDEFGH", "F")

6

At(23412931298471, 29)
5, position du premier caractère de la première occurrence de 29 à l’intérieur de la chaîne source.

At(Ltrim(Cust_Info[0]), "555")
Emplacement de la chaîne 555 à l’intérieur de la première occurrence de Cust_Info.
Voir aussi Ltrim.


Concat

Renvoie la concaténation des chaînes indiquées.
Syntaxe
Concat(s1 [, s2 ...])
Paramètres

Paramètre

Description

s1
Première chaîne de l’ensemble.
s2 (Facultatif)
Autres chaînes à ajouter à l’ensemble.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Concat :

Expression

Renvoie

Concat("ABC", "DEF")

ABCDEF

Concat("Tony", Space(1), "Blue")

Tony Blue
Voir aussi Space.
Concat("You owe ", WordNum(1154.67, 2), ".")

You owe One Thousand One Hundred Fifty-four Dollars And Sixty-seven Cents.
Voir aussi WordNum.


Decode

Renvoie la version décodée d’une chaîne donnée.
Syntaxe
Decode(s1 [, s2 ])
Paramètres

Paramètre

Description

s1
Chaîne à décoder.
s2 (Facultatif)
Chaîne identifiant le type de décodage à effectuer. Chaînes de décodage valides :
      •
      url (décodage URL)
      •
      html (décodage HTML)
      •
      xml (décodage XML)
Si vous omettez la valeur s2, la fonction utilise le décodage URL.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Decode :

Expression

Renvoie

Decode("&AElig;&Aacute;&Acirc;&Aacute;
&Acirc;", "html")

ÆÁÂÁÂ

Decode("~!@#$%^&amp;*()_+|`{&quot;}[]
&lt;&gt;?,./;&apos;:", "xml")

~!@#$%^&*()_+|`{""}[]<>?,./;':


Encode

Renvoie la version codée d’une chaîne donnée.
Syntaxe
Encode(s1 [, s2 ])
Paramètres

Paramètre

Description

s1
Chaîne à coder.
s2 (Facultatif)
Chaîne identifiant le type de codage à effectuer. Chaînes de codage valides :
      •
      url (codage URL)
      •
      html (codage HTML)
      •
      xml (codage XML)
Si vous omettez la valeur s2, la fonction utilise le codage URL.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Encode :

Expression

Renvoie

Encode("""hello, world!""", "url")

%22hello,%20world!%22

Encode("ÁÂÃÄÅÆ", "html")

&#xc1;&#Xc2;&#Xc3;&#xc4;&#xc5;&#xc6;


Format

Formate les données fournies selon la chaîne de format d’image indiquée.
Syntaxe
Format(s1, s2 [, s3 ...])
Paramètres

Paramètre

Description

s1
Chaîne de format d’image, qui peut être un format de date ou d’heure prenant en compte le paramètre régional. Voir Paramètres régionaux.
s2
Données source à formater.
Pour les formats d’image de date, les données source doivent être soit une chaîne de date/heure ISO, soit une chaîne de date ISO dans l’un ou l’autre des formats suivants :
      •
      YYYY[MM[DD]]
      •
      YYYY[-MM[-DD]]
Pour les formats d’image de date, les données source doivent être soit une chaîne de date/heure ISO, soit une chaîne de date ISO dans l’un ou l’autre des formats suivants :
      •
      HH[MM[SS[.FFF][z]]]
      •
      HH[MM[SS[.FFF][+HH[MM]]]]
      •
      HH[MM[SS[.FFF][-HH[MM]]]]
      •
      HH[:MM[:SS[.FFF][z]
      •
      HH[:MM[:SS[.FFF][-HH[:MM]]]]
      •
      HH[:MM[:SS[.FFF][+HH[:MM]]]]
Pour les formats d’image de date-heure, les données source doivent être une chaîne de date-heure ISO.
Pour les formats d’image numériques, les données source doivent être numériques.
Pour les formats d’image textuels, les données source doivent être textuelles.
Pour les formats d’image composés, le nombre d’arguments des données source doit correspondre au nombre de sous-éléments de l’image.
s3 (Facultatif)
Autres données source à formater.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Format :

Expression

Renvoie

Format("MMM D, YYYY", "20020901")

Sep 1, 2002

Format("$9,999,999.99", 1234567.89)
$1,234,567.89 aux États-Unis et 1 234 567,89 euros en France.


Left

Extrait un nombre spécifique de caractères d’une chaîne, en commençant par le premier caractère à gauche.
Syntaxe
Left(s, n)
Paramètres

Paramètre

Description

s
Chaîne dans laquelle l’extraction est effectuée.

n
Nombre de caractères à extraire.
Si le nombre de caractères à extraire est supérieur à la taille de la chaîne, la fonction renvoie toute la chaîne.
Si le nombre de caractères à extraire est 0 ou moins, la fonction renvoie une chaîne vide.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Left :

Expression

Renvoie

Left("ABCDEFGH", 3)

ABC

Left("Tony Blue", 5)

"Tony "

Left(Telephone[0], 3)
Les trois premiers caractères de la première occurrence de Telephone.

Left(Rtrim(Last_Name), 3)
Les trois premiers caractères de Last_Name.
Voir aussi Rtrim.


Len

Renvoie le nombre de caractères d’une chaîne donnée.
Syntaxe
Len(s)
Paramètres

Paramètre

Description

s
Chaîne à évaluer.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Len :

Expression

Renvoie

Len("ABDCEFGH")

8

Len(4)

1

Len(Str(4.532, 6, 4))

6
Voir aussi Str.

Len(Amount[*])
Nombre de caractères de la première occurrence de Amount.


Lower

Convertit en minuscules toutes les majuscules d’une chaîne donnée.
Syntaxe
Lower(s, [, k ])
Paramètres

Paramètre

Description

s
Chaîne à convertir.
k (Facultatif)
Chaîne représentant un paramètre régional valide. Si vous omettez la valeur k, la fonction utilise le paramètre régional ambiant.
Voir aussi Paramètres régionaux.
cette fonction convertit uniquement les caractères Unicode U+41 à U+5A (du jeu de caractères ASCII), ainsi que les caractères U+FF21 à U+FF3A (du jeu de caractères pleine largeur).
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Lower :

Expression

Renvoie

Lower("ABC")

abc

Lower("21 Main St.")

21 main st.

Lower(15)

15

Lower(Address[0])
Cet exemple convertit en minuscules la première occurrence de Address.


Ltrim

Renvoie une chaîne sans aucun caractère d’espace blanc à gauche.
Les caractères d’espace incluent l’espace ASCII, la tabulation horizontale, le changement de ligne, la tabulation verticale, le changement de page, le retour chariot et les caractères d’espace Unicode (catégorie Unicode Zs).
Syntaxe
Ltrim(s)
Paramètres

Paramètre

Description

s
Chaîne à dégrossir.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Ltrim :

Expression

Renvoie

Ltrim("          ABCD")

"ABCD"

Ltrim(Rtrim("          Tony Blue          "))

"Tony Blue"
Voir aussi Rtrim.

Ltrim(Address[0])
Supprime tous les espaces situés à gauche de la première occurrence de Address.


Parse

Analyse les données fournies selon le format d’image donné.
Une analyse réussie des données génère l’un des résultats suivants :
      •
      Format d’image de date : Chaîne de date ISO au format YYYY-MM-DD.
      •
      Formats d’image d’heure : Chaîne d’heure ISO au format HH:MM:SS.
      •
      Format d’image de date-heure : Chaîne de date-heure ISO au format YYYY-MM-DDTHH:MM:SS.
      •
      Format d’image numérique : Un nombre.
      •
      Images de texte : Du texte.
Syntaxe
Parse(s1, s2 )
Paramètres

Paramètre

Description

s1
Chaîne de format d’image de date ou d’heure valide.
Pour plus de détails sur les formats de date et d'heure, voir A propos des fonctions de date et d’heure.

s2
Données de la chaîne à analyser.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Parse :

Expression

Renvoie

Parse("MMM D, YYYY", "Sep 1, 2002")

2002-09-01

Parse("$9,999,999.99", "$1,234,567.89")
1234567.89aux États-Unis.


Replace

Remplace toutes les occurrences d’une chaîne par une autre, dans la chaîne indiquée.
Syntaxe
Replace(s1, s2 [, s3 ])
Paramètres

Paramètre

Description

s1
Chaîne source.

s2
Chaîne à remplacer.
s3 (Facultatif)
Chaîne à utiliser pour le remplacement.
Si vous omettez la valeur s3, ou si s3 est nul, la fonction utilise une chaîne vide.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Replace :

Expression

Renvoie

Replace("Tony Blue", "Tony", "Chris")

Chris Blue

Replace("ABCDEFGH", "D")

ABCEFGH

Replace("ABCDEFGH", "d")

ABCDEFGH

Replace(Comments[0], "recieve", "receive")
Corrige les utilisations mal orthographiées du mot receive dans la première occurrence de Comments.


Right

Extrait un nombre spécifique de caractères dans une chaîne donnée, en commençant par le dernier caractère à droite.
Syntaxe
Right(s, n )
Paramètres

Paramètre

Description

s
Chaîne à extraire.

n
Nombre de caractères à extraire.
Si n est supérieur à la taille de la chaîne, la fonction renvoie toute la chaîne.
Si n est 0 ou moins, la fonction renvoie une chaîne vide.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Right :

Expression

Renvoie

Right("ABCDEFGH", 3)

FGH

Right("Tony Blue", 5)

" Blue"

Right(Telephone[0], 7)
Les sept derniers caractères de la première occurrence de Telephone.

Right(Rtrim(CreditCard_Num), 4)
Les quatre derniers caractères de CreditCard_Num.
Voir aussi Rtrim.


Rtrim

Renvoie une chaîne sans aucun caractère d’espace blanc à droite.
Les caractères d’espace incluent l’espace ASCII, la tabulation horizontale, le changement de ligne, la tabulation verticale, le changement de page, le retour chariot et les caractères d’espace Unicode (catégorie Unicode Zs).
Syntaxe
Rtrim(s )
Paramètres

Paramètre

Description

s
Chaîne à dégrossir.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Rtrim :

Expression

Renvoie

Rtrim("ABCD          ")

"ABCD"

Rtrim("Tony Blue           ")

"Tony Blue"

Rtrim(Address[0])
Supprime tous les espaces situés à droite de la première occurrence de Address.


Space

Renvoie une chaîne composée d’un nombre donné d’espaces blancs.
Syntaxe
Space(n )
Paramètres

Paramètre

Description

n
Nombre d’espaces.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Space :

Expression

Renvoie

Space(5)

"     "

Space(Max(Amount[*]))
Chaîne vide contenant autant de caractères que la valeur de l’occurrence la plus élevée de Amount.
Voir aussi Max.

Concat("Tony", Space(1), "Blue")

Tony Blue


Str

Convertit un nombre en une chaîne de caractères. FormCalc formate le résultat selon la largeur indiquée et l’arrondit au nombre de décimales défini.
Syntaxe
Str(n1 [, n2 [, n3 ]])
Paramètres

Paramètre

Description

n1
Nombre à convertir.
n2 (Facultatif)
Largeur maximale de la chaîne. Si vous omettez la valeur n2, la fonction utilise la valeur 10 comme largeur par défaut.
Si la chaîne obtenue est plus longue que n2, la fonction renvoie une chaîne d’astérisques (*) de la largeur indiquée par n2.
n3 (Facultatif)
Nombre de chiffres après le point décimal. Si vous omettez la valeur n3, la fonction utilise 0 par défaut.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Str :

Expression

Renvoie

Str(2.456)

"         2"

Str(4.532, 6, 4)

4.5320

Str(234.458, 4)

" 234"

Str(31.2345, 4, 2)

****

Str(Max(Amount[*]), 6, 2)
Convertit l’occurrence la plus élevée de Amount en une chaîne de six caractères comprenant deux décimales.
Voir aussi Max.


Stuff

Insère une chaîne dans une autre chaîne.
Syntaxe
Stuff(s1, n1, n2 [, s2 ])
Paramètres

Paramètre

Description

s1
Chaîne source.

n1
Position, dans s1, où la nouvelle chaîne s2 doit être insérée.
Si n1 est inférieur à un, la fonction utilise la position du premier caractère. Si n1 est supérieur à la longueur de s1, la fonction utilise la position du dernier caractère.

n2
Nombre de caractères à supprimer de la chaîne s1, en commençant à la position du caractère n1.
Si n2 est inférieur ou égal à 0, la fonction ne supprime aucun caractère.
s2 (Facultatif)
Chaîne à insérer dans s1.
Si vous omettez la valeur s2, la fonction utilise une chaîne vide.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Stuff :

Expression

Renvoie

Stuff("TonyBlue", 5, 0, " ")

Tony Blue

Stuff("ABCDEFGH", 4, 2)

ABCFGH

Stuff(Address[0], Len(Address[0]), 0, "Street")
Le mot Street est ajouté à la fin de la première occurrence de Address.
Voir aussi Len.

Stuff("members-list@myweb.com", 0, 0, "cc:"

cc:members-list@myweb.com


Substr

Extrait une partie d’une chaîne donnée.
Syntaxe
Substr(s1, n1, n2 )
Paramètres

Paramètre

Description

s1
Chaîne source.

n1
Position, dans la chaîne s1, marquant le début de l’extraction.
Si n1 est inférieur à un, la fonction utilise la position du premier caractère. Si n1 est supérieur à la longueur de s1, la fonction utilise la position du dernier caractère.

n2
Nombre de caractères à extraire.
Si n2 est inférieur ou égal à 0, la fonction renvoie une chaîne vide. Si n1 + n2 est supérieur à la longueur de s1, la fonction renvoie la sous-chaîne à partir de n1 et à la fin de s1.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Substr :

Expression

Renvoie

Substr("ABCDEFG", 3, 4)

CDEF

Substr(3214, 2, 1)

2

Substr(Last_Name[0], 1, 3)
Les trois premiers caractères de la première occurrence de Last_Name.

Substr("ABCDEFG", 5, 0)

""

Substr("21 Waterloo St.", 4, 5)

Water


Upper

Convertit en majuscules toutes les minuscules d’une chaîne.
Syntaxe
Upper(s [, k ])
Paramètres

Paramètre

Description

s
Chaîne à convertir.
k (Facultatif)
Chaîne représentant un paramètre régional valide. Si vous omettez la valeur k, la fonction utilise le paramètre régional ambiant.
Voir aussi Paramètres régionaux.
cette fonction convertit uniquement les caractères Unicode U+61 à U+7A (du jeu de caractères ASCII), ainsi que les caractères U+FF41 à U+FF5A (du jeu de caractères pleine largeur).
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Upper :

Expression

Renvoie

Upper("abc")

ABC

Upper("21 Main St.")

21 MAIN ST.

Upper(15)

15

Upper(Address[0])
Cet exemple convertit en majuscules la première occurrence de Address.


Uuid

Renvoie une chaîne UUID qui sert de méthode d’identification.
Syntaxe
Uuid([n ])
Paramètres

Paramètre

Description

n
Numéro identifiant le format de la chaîne UUID. Numéros valides :
      •
      0 (valeur par défaut) : la chaîne UUID contient uniquement des valeurs hexadécimales.
      •
      1: la chaîne UUID contient des tirets séparant les séquences de valeurs hexadécimales à des positions fixes.
Si vous omettez la valeur n, la fonction utilise la valeur par défaut.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Uuid :

Expression

Renvoie

Uuid()
Une valeur telle que 3c3400001037be8996c400a0c9c86dd5
Uuid(0)
Une valeur telle que 3c3400001037be8996c400a0c9c86dd5
Uuid(1)
Une valeur telle que 1a3ac000-3dde-f352-96c4-00a0c9c86dd5
Uuid(7)
Une valeur telle que 1a3ac000-3dde-f352-96c4-00a0c9c86dd5


WordNum

Renvoie le texte équivalent à un nombre donné.
Syntaxe
WordNum(n1 [, n2 [, k ]])
Paramètres

Paramètre

Description

n1
Nombre à convertir.
Si l’un des énoncés suivants est vrai, la fonction renvoie des astérisques (*) pour indiquer une erreur :
      •
      n1 n’est pas un nombre.
      •
      La valeur entière de n1 est négative.
      •
      La valeur entière de n1 est supérieure à 922 337 203 685 477 550.
n2 (Facultatif)
Numéro identifiant l’option de formatage. Numéros valides :
      •
      0 (valeur par défaut) : le nombre est converti en texte représentant la partie entière du nombre.
      •
      1: le nombre est converti en texte représentant la valeur monétaire, sans décimales.
      •
      2: le nombre est converti en texte représentant la valeur monétaire, avec les décimales.
Si vous omettez la valeur n2, la fonction utilise la valeur par défaut (0).
k (Facultatif)
Chaîne représentant un paramètre régional valide. Si vous omettez la valeur k, la fonction utilise le paramètre régional ambiant.
Voir aussi Paramètres régionaux.
à compter de la présente version, vous ne pouvez plus indiquer un identificateur de paramètre régional autre que l’anglais pour cette fonction.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction WordNum.

Expression

Renvoie

WordNum(123.45)

One Hundred and Twenty-three Dollars

WordNum(123.45, 1)

One Hundred and Twenty-three Dollars

WordNum(1154.67, 2)

One Thousand One Hundred Fifty-four Dollars And Sixty-seven Cents

WordNum(43, 2)

Forty-three Dollars And Zero Cents

WordNum(Amount[0], 2)
Cet exemple utilise la première occurrence de Amount comme nombre à convertir.


Précédent Suivant

Script > Guide de référence FormCalc > Fonctions URL

Fonctions URL

A propos des fonctions URL
Get
Post
Put


A propos des fonctions URL

Ces fonctions portent sur l’envoi et la réception d’informations (type de contenu et codage des données compris) à destination ou en provenance de n’importe quel emplacement URL accessible.
Fonctions
      •
      Get
      •
      Post
      •
      Put


Get

Télécharge le contenu de l’adresse URL indiquée.
la fonction Get ne s’applique qu’aux formulaires certifiés. Adobe Acrobat® et Adobe Reader® ne sont pas capables d’identifier les formulaires certifiés tant que l’événement initialize n’a pas été lancé. Pour tirer parti de la fonction Get sur les formulaires certifiés avant de procéder au rendu du formulaire, utilisez l’événement docReady.
Syntaxe
Get(s)
Paramètres

Paramètre

Description

s
Adresse URL à télécharger.
Si la fonction ne parvient pas à télécharger le contenu de l’adresse URL, elle renvoie une erreur.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Get.

Expression

Renvoie

Get("http://www.myweb.com/data/mydata.xml")
Données XML extraites du fichier indiqué.

Get("ftp://ftp.gnu.org/gnu/GPL")
Contenu de la Licence Publique Générale GNU.

Get("http://intranet?sql=SELECT+*+FROM+
projects+FOR+XML+AUTO,+ELEMENTS")
Résultats d’une requête SQL adressée au site Web indiqué.


Post

Place à l’adresse URL indiquée les données fournies.
la fonction Post ne s’applique qu’aux formulaires certifiés. Acrobat et Adobe Reader ne sont pas capables d’identifier les formulaires certifiés tant que l’événement initialize n’a pas été lancé. Pour tirer parti de la fonction Post sur les formulaires certifiés avant de procéder au rendu du formulaire, utilisez l’événement docReady.
Syntaxe
Post(s1, s2 [, s3 [, s4 [, s5 ]]])
Paramètres

Paramètre

Description

s1
Adresse URL à laquelle les données sont inscrites.

s2
Données à publier.
Si la fonction ne parvient pas à publier les données, elle renvoie une erreur.
s3 (Facultatif)
Chaîne contenant le type de contenu des données à publier. Types de contenu valides :
      •
      application/flux d’octets (valeur par défaut)
      •
      texte/html
      •
      texte/xml
      •
      texte/en clair
      •
      texte en plusieurs parties/données de formulaire
      •
      application/formulaire x-www codé url
      •
      tout autre type MIME valide
Si vous ne donnez pas de valeur à s3, la fonction affecte au type de contenu la valeur par défaut. L’application doit s’assurer que les données à publier utilisent le format adéquat en fonction du type de contenu indiqué.
s4 (Facultatif)
Chaîne contenant le nom de la page de codes utilisée pour coder les données. Noms de pages de codes valides :
      •
      UTF-8 (valeur par défaut)
      •
      UTF-16
      •
      ISO-8859-1
      •
      Tout codage de caractères reconnu par l’IANA (Internet Assigned Numbers Authority)
Si vous ne donnez pas de valeur à s4, la fonction affecte à la page de codes la valeur par défaut. L’application doit s’assurer que le codage des données à publier correspond à la page de codes indiquée.
s5 (Facultatif)
Chaîne contenant tout en-tête HTTP supplémentaire à inclure à la publication des données.
Si vous ne donnez pas de valeur à s5, la fonction n’ajoute pas d’en-tête HTTP supplémentaire à la publication.
Pour effectuer une publication sur un serveur SOAP, vous devez généralement utiliser un en-tête SOAPAction.
Exemples
Les expressions suivantes constituent des exemples d’utilisation de la fonction Post :

Expression

Renvoie

Post("http://tools_build/scripts/jfecho.cgi",
"user=joe&passwd=xxxxx&date=27/08/2002",
"application/x-www-form-urlencoded")
Publie des données de connexion codées URL sur le serveur et renvoie l’accusé de réception de ce serveur.

Post("http://www.nanonull.com/TimeService/
TimeService.asmx/getLocalTime", "<?xml version='1.0'
encoding='UTF-8'?><soap:Envelope><soap:Body>
<getLocalTime/></soap:Body>
</soap:Envelope>", "text/xml", "utf-8",
"http://www.Nanonull.com/TimeService/getLocalTime")
Publie une requête SOAP pour l’heure locale sur un serveur et attend une réponse XML.


Put

Télécharge les données fournies vers l’adresse URL indiquée.
la fonction Put ne s’applique qu’aux formulaires certifiés. Acrobat et Adobe Reader ne sont pas capables d’identifier les formulaires certifiés tant que l’événement initialize n’a pas été lancé. Pour tirer parti de la fonction Put sur les formulaires certifiés avant de procéder au rendu du formulaire, utilisez l’événement docReady.
Syntaxe
Put(s1, s2 [, s3 ])
Paramètres

Paramètre

Description

s1
Adresse URL de destination du téléchargement.

s2
Données à télécharger.
Si la fonction ne parvient pas à télécharger les données, elle renvoie une erreur.
s3 (Facultatif)
Chaîne contenant le nom de la page de codes utilisée pour coder les données. Noms de pages de codes valides :
      •
      UTF-8 (valeur par défaut)
      •
      UTF-16
      •
      ISO8859-1
      •
      Tout codage de caractères reconnu par l’IANA (Internet Assigned Numbers Authority)
Si vous ne donnez pas de valeur à s3, la fonction affecte à la page de codes la valeur par défaut. L’application doit s’assurer que le codage des données à télécharger correspond à la page de codes indiquée.
Exemples
Les expressions suivantes constituent un exemple d’utilisation de la fonction Put :

Expression

Renvoie

Put("ftp://www.example.com/pub/fubu.xml",
"<?xml version='1.0'
encoding='UTF-8'?><msg>hello world!</msg>")
Rien si le serveur FTP a autorisé l’utilisateur à télécharger certaines données XML vers le fichier pub/fubu.xml sur le serveur. Sinon, cette fonction renvoie une erreur.


Référence aux menus, commandes, boîtes à outils et boîtes de dialogue

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue

Menus et commandes
Barres d'outils
Présentation des boîtes de dialogue


Menus et commandes

A propos des menus et des commandes
Pour ouvrir un menu à l'aide du clavier
Pour afficher un menu contextuel
Menu Fichier
Menu Edition
Menu Affichage
Menu Insertion
Menu Tableau
Menu Disposition
Menu Outils
Menu Fenêtre
Menu Aide
Menu Gestionnaire de modèles
Menu Editeur de champs
Menu de la palette Hiérarchie
Menu de la palette Vue des données
Menu de la palette Structure PDF
Menu de la palette Bibliothèque
Menu Favoris
Menu Standard
Menu Personnalisés
Menu Code à barres
Menu de la palette Disposition
Menu de la palette Bordure
Menu de la palette Objet
Menu de la palette Accessibilité
Menu de la palette Police
Menu de la palette Paragraphe
Menu de la palette Accessoires de dessin
Menu de la palette Info
Menu de la palette Rapport
Menu de la palette Procédures


A propos des menus et des commandes

Un menu propose une liste de commandes. Certaines d'entre elles sont assorties d'une icône de façon à ce que vous puissiez facilement associer la commande au bouton correspondant dans la barre d'outils. D'autres sont associées à des touches d'accès rapide, identifiées par un trait de soulignement, et à des raccourcis clavier qui permettent d'exécuter rapidement les tâches les plus courantes.
Outre les menus affichés en haut de la fenêtre de LiveCycle Designer et de plusieurs palettes, il existe des menus contextuels qui sont composés des commandes pertinentes pour la palette ou la page active.


Pour ouvrir un menu à l'aide du clavier

      *
      Pour ouvrir un menu à l'aide du clavier, appuyez sur Alt + [touche d'accès rapide], puis sélectionnez une commande de menu en appuyant sur la touche d'accès rapide correspondant à cette commande. Par exemple, pour ouvrir le menu Edition et choisir la commande Couper, appuyez sur Alt+D C. Vous pouvez également utiliser le raccourci clavier Ctrl+X pour sélectionner la commande Couper.


Pour afficher un menu contextuel

1.
Placez le pointeur de la souris sur la palette ou la page.
2.
Cliquez avec le bouton droit de la souris. Le menu contextuel s'affiche à l'endroit où vous avez cliqué.


Menu Fichier

Le menu Fichier comprend les commandes qui permettent d’effectuer des opérations de base dans LiveCycle Designer.
Nouveau
Crée une form design. Cliquez sur l’icône de liste du bouton Nouveau [image] pour sélectionner rapidement le modèle sur lequel vous voulez baser la nouvelle conception de formulaire.
Ouvrir
Ouvre une form design existante.
Fermer
Ferme la form design active. Le système vous invite à enregistrer les modifications.
Enregistrer
Enregistre le contenu de la form design active.
Enregistrer sous
Enregistre le contenu de la form design active sous l’un des formats suivants : Formulaire PDF (statique) Acrobat 8.0 (.pdf), Formulaire XML (dynamique) Acrobat 8.0 (.pdf), Formulaire PDF (statique) Acrobat 7.0 (.pdf), Formulaire XML (dynamique) Acrobat 7.0 (.pdf), Formulaire PDF (statique) Acrobat 6.0 (.pdf), Formulaire XML Adobe (.xdp) ou Modèle Adobe LiveCycle Designer (.tds).
Publier dans le référentiel
Enregistre la conception de formulaire et les fichiers qui y sont liés dans un dossier partagé ou un dossier Web, où elle sera accessible par de nombreux utilisateurs ou d’autres applications.
Diffuser le formulaire
Ferme le formulaire dans LiveCycle Designer et ouvre l'assistant de diffusion d'Acrobat qui vous guide tout au long de la procédure de diffusion.
Nouvelle connexion aux données
Etablit une connexion aux données. Cette boîte de dialogue fournit une description de la connexion entre la source de données et la conception de formulaire.
Collections d'objets de formulaire
Crée, supprime, duplique, renomme et modifie des collections pour les champs de signature du document et les codes à barres de formulaires pour support papier.
Propriétés du formulaire
Affiche les propriétés de la form design active.
Imprimer
Imprime le contenu des panneaux Vue de conception et Gabarit actifs dans l’éditeur de disposition.
Liste des derniers fichiers
Affiche la liste des form designs récemment ouvertes.
Quitter
Ferme LiveCycle Designer. Le système vous invite à enregistrer les modifications.


Menu Edition

Le menu Edition contient les commandes qui permettent de modifier une form design.
Annuler
Annule les dernières actions réalisées (10 au maximum).
Rétablir
Applique à nouveau une action qui a été annulée (10 au maximum).
Couper
Supprime la sélection active et la copie dans le Presse-papiers.
Copier
Ajoute une copie de la sélection active dans le Presse-papiers.
Coller
Copie le contenu du Presse-papiers sur la page.
Supprimer
Supprime la sélection active sans en placer une copie dans le Presse-papiers.
Dupliquer
Crée un duplicata de la sélection active sans en placer une copie dans le Presse-papiers.
Copies multiples
Crée un nombre défini de copies de l'objet sélectionné.
Sélectionner tout
Sélectionne tous les objets, groupes et sous-formulaires de niveau supérieur qui se trouvent dans le panneau actif de l'éditeur de disposition. Le contenu de l'éditeur de script est également sélectionné.
Sélectionner tous les objets statiques
Sélectionne tous les objets statiques, y compris le texte statique, les cercles, les lignes et les rectangles.
Sélectionner tous les champs
Sélectionne l'ensemble des champs, boutons, cases à cocher, champs de date/heure, champs décimaux, champs de signature du document, listes déroulantes, champs d'image, zones de liste, champs numériques, codes à barres de formulaires pour support papier, champs de mot de passe, boutons radio et champs de texte.
Rechercher
Recherche dans le panneau Source XML ou dans l'éditeur de script toutes les occurrences d'une expression ou d'un mot précis.
Rechercher suivant
Recherche dans le panneau Source XML ou dans l'éditeur de script l'occurrence suivante de l'expression ou du mot spécifié.
Rechercher précédent
Recherche dans le panneau Source XML ou dans l'éditeur de script l'occurrence précédente de l'expression ou du mot spécifié.
Remplacer
Recherche et remplace le texte dans le panneau Source XML ou dans l'éditeur de script.
Atteindre la ligne
Permet d'accéder au numéro de ligne indiqué dans le panneau Source XML ou dans l'éditeur de script.
Verrouiller le texte
Lorsque cette option est activée, cliquez une seule fois sur un objet pour le sélectionner et deux fois pour modifier sa légende. Lorsqu'elle est désactivée, cliquez une seule fois sur un objet pour le sélectionner, puis sélectionnez directement sa légende.
Verrouiller les objets statiques
Lorsque cette commande est activée, les objets statiques comme le texte, les lignes, les images et les formes ne peuvent pas être sélectionnés ou modifiés.
Verrouiller les champs
Lorsque cette commande est activée, les objets de champ ne peuvent pas être sélectionnés ou modifiés.
Remplacer l'illustration
Remplace l'illustration d'arrière-plan d'un document PDF par un autre document PDF que vous sélectionnez. Cette commande ne s'applique aux documents PDF ne contenant pas d'illustration d'arrière-plan.


Menu Affichage

Le menu Affichage comprend des commandes permettant de changer votre espace de travail.
Règles
Affiche ou masque les règles.
Lignes guides
Affiche ou masque les lignes guides.
Grille
Affiche ou masque la grille.
Accrocher à la grille
Accroche les objets au point de la grille le plus proche.
Conserver l'outil de dessin
Une fois la commande choisie, vous pouvez dessiner autant de copies d'un objet que vous le souhaitez, sans devoir le sélectionner chaque fois dans la palette Bibliothèque. Pour désactiver cette fonction, cliquez de nouveau sur le bouton Conserver l'outil de dessin.
Limites de l'objet
Affiche ou masque les limites de l'objet sur la page.
Editeur de champs
Affiche ou masque l'éditeur de champs sur la page qui s'affiche autour de l'objet sélectionné sur la page. L'éditeur de champ permet d'accéder facilement aux propriétés les plus fréquemment utilisées.
Vue de conception
Affiche le panneau Vue de conception.
Gabarit
Affiche le panneau Gabarit.
Source XML
Affiche le panneau Source XML.
Aperçu PDF
Affiche le panneau Aperçu PDF.
Zoom
Applique un zoom avant pour afficher les détails ou un zoom arrière pour afficher une plus grande zone.
Taille réelle
Définit le facteur de zoom sur 100 %.
Page entière
Redimensionne la page de sorte qu'elle s'ajuste à l'éditeur de disposition.
Pleine largeur
Redimensionne la page de sorte que sa largeur s'ajuste à l'éditeur de disposition.
Zoom ciblé
Fait un zoom avant sur la zone sélectionnée sur la page.
Ordre de tabulation
Permet de choisir l'ordre dans lequel vous passez d'un objet à l'autre dans la conception de formulaire en appuyant sur la touche Tab.


Menu Insertion

Le menu Insertion comprend les commandes qui permettent d'ajouter des objets à une form design.
Champ flottant
Insère un champ flottant dans la form design.
Numéro de la page courante
Insère le numéro de la page actuelle dans le formulaire final.
Nombre de pages
Insère le nombre total de pages dont le formulaire final est constitué.
Date/Heure courante
Insère la date et l'heure actuelles.
Paramètres régionaux du programme de visualisation
Insère la valeur définie dans les paramètres régionaux de l'application qui traite le formulaire.
Nom du programme de visualisation
Insère le nom de l'application qui traite le formulaire.
Version du programme de visualisation
Insère le numéro de version de l'application qui traite le formulaire.
Favoris > [objet]
Répertorie les objets de dessin que vous pouvez ajouter au formulaire. Ces objets correspondent aux objets affichés dans la catégorie Favoris de la palette Bibliothèque.
Standard > [objet]
Répertorie les objets de dessin que vous pouvez ajouter au formulaire. Ces objets correspondent aux objets affichés dans la catégorie Standard de la palette Bibliothèque.
Codes à barres > [objet]
Répertorie les objets de code à barres que vous pouvez ajouter au formulaire. Ces objets correspondent aux objets affichés dans la catégorie Codes à barres de la palette Bibliothèque.
Personnalisés > [objet]
Répertorie les objets personnalisés que vous pouvez ajouter au formulaire. Ces objets correspondent aux objets affichés dans la catégorie Personnalisés de la palette Bibliothèque.
[Palette Bibliothèque] > [objet]
Répertorie les catégories supplémentaires que vous pouvez ajouter à la palette Bibliothèque. Ces objets correspondent aux objets affichés dans les catégories supplémentaires de la palette Bibliothèque.
Placer dans un sous-formulaire
Crée un sous-formulaire qui contient les objets sélectionnés.
Placer hors du sous-formulaire
Supprime le sous-formulaire, mais laisse les objets dans la form design.
Placer dans un jeu de sous-formulaires
Crée un sous-formulaire regroupant au moins deux sous-formulaires afin qu'ils restent associés.
Placer dans le jeu de sous-formulaires choisi
Crée un nouveau sous-formulaire regroupant au moins deux sous-formulaires afin qu'ils restent associés, mais un seul d'entre eux figurera sur le formulaire final selon les conditions définies par l'utilisateur.
Placer hors du jeu de sous-formulaires
Supprime le regroupement de deux ou plusieurs formulaires qui les conservait ensemble.
Nouvelle page
Ajoute une nouvelle page à la suite de la dernière page de la form design. Cette commande apparaît à condition que le panneau Vue de conception soit actif.
Supprimer la page
Supprime la page active. Cette commande apparaît à condition que le panneau Vue de conception soit actif.
Nouveau gabarit
Ajoute un nouveau gabarit à la suite de la dernière page de la form design. Cette commande apparaît à condition que le panneau Gabarit soit actif.
Supprimer le gabarit
Supprime le gabarit actif. Cette commande apparaît à condition que le panneau Gabarit soit actif.


Menu Tableau

Le menu Tableau propose des commandes de manipulation des tableaux.
Insérer un tableau
Ouvre la boîte de dialogue Insérer un tableau.
Insérer > Colonne à gauche
Insère une ou plusieurs colonnes à gauche des colonnes sélectionnées. Le nombre de colonnes insérées correspond au nombre de colonnes sélectionnées.
Insérer > Colonne à droite
Insère une ou plusieurs colonnes à droite des colonnes sélectionnées. Le nombre de colonnes insérées correspond au nombre de colonnes sélectionnées.
Insérer > Rangée au-dessus
Insère une ou plusieurs rangées au-dessus des cellules ou rangées sélectionnées. Le nombre de rangées insérées correspond au nombre de rangées sélectionnées.
Insérer > Rangée au-dessous
Insère une ou plusieurs rangées au-dessous des cellules ou rangées sélectionnées. Le nombre de rangées insérées correspond au nombre de rangées sélectionnées.
Insérer > Section au-dessus
Insère une section au-dessus des cellules, rangées ou sections sélectionnées.
Insérer > Section au-dessous
Insère une section au-dessous des cellules, rangées ou sections sélectionnées.
Supprimer > Rangée
Supprime toutes les rangées contenant une ou plusieurs cellules sélectionnées.
Supprimer > Colonne
Supprime toutes les colonnes contenant une ou plusieurs cellules sélectionnées.
Supprimer > Section
Supprime toutes les sections contenant une ou plusieurs cellules sélectionnées.
Supprimer > Tableau
Supprime tous les tableaux contenant une ou plusieurs cellules sélectionnées.
Sélectionner > Cellule
Sélectionne la cellule sur laquelle se trouve le curseur en mode Edition de texte.
Sélectionner > Cellules de rangée
Sélectionne toutes les cellules de toutes les rangées contenant une ou plusieurs cellules sélectionnées. Sélectionne uniquement les cellules de rangée (objets de texte) et non la rangée elle-même.
Sélectionner > Cellules de colonne
Sélectionne toutes les cellules de toutes les colonnes contenant une ou plusieurs cellules sélectionnées.
Sélectionner > Rangée
Sélectionne toutes les rangées contenant une ou plusieurs cellules sélectionnées.
Sélectionner > Section
Sélectionne toutes les sections contenant une ou plusieurs cellules ou rangées sélectionnées.
Sélectionner > Tableau
Sélectionne tous les tableaux contenant une ou plusieurs cellules, rangées ou sections sélectionnées.
Fusionner les cellules
Réunit au moins deux cellules attenantes de la même rangée en une seule cellule.
Scinder la cellule horizontalement
Sépare au moins deux cellules fusionnées d'une rangée en cellules distinctes.
Répartir proportionnellement les rangées
Répartit proportionnellement les rangées sélectionnées sur une ou plusieurs sections ou sur un ou plusieurs tableaux. Toutes les rangées s'adaptent à la hauteur de la rangée la plus haute sélectionnée.
Répartir proportionnellement les colonnes
Répartit proportionnellement les colonnes sélectionnées sur une ou plusieurs sections ou sur un ou plusieurs tableaux. La largeur totale des colonnes sélectionnées est proportionnellement répartie entre toutes les colonnes sélectionnées, afin qu'elles aient toutes la même largeur. La largeur du tableau ne change pas.
Regrouper comme section
Rassemble une ou plusieurs rangées ou sections sélectionnés en une section.
Regrouper comme section de choix
Facilite la création d'une section de choix à partir d'une rangée. LiveCycle Designer place la rangée dans une section, définit comme condition de rangée Sélectionner un formulaire parmi les sous-formulaires de remplacement, applique les restrictions d'occurrence de rangée à la section du tableau et définit les valeurs d'occurrence minimale et maximale de la rangée sur 1. Cette commande est disponible à condition qu'une seule rangée de tableau soit sélectionnée.
Dissocier la section
Sépare une ou plusieurs rangées ou sections sélectionnées en éléments distincts.
Convertir en tableau
Convertit un ou plusieurs objets sélectionnés en tableau.
Atteindre la rangée
Ouvre la boîte de dialogue Atteindre la rangée.


Menu Disposition

Le menu Disposition comprend les commandes qui permettent d'organiser les objets dans une form design.
Aligner > Gauche
Aligne le bord gauche des objets sélectionnés sur la position du dernier objet actif dans la sélection.
Aligner > Droite
Aligne le bord droit des objets sélectionnés sur la position du dernier objet actif dans la sélection.
Aligner > Haut
Aligne le bord supérieur des objets sélectionnés sur la position du dernier objet actif dans la sélection.
Aligner > Bas
Aligne le bord inférieur des objets sélectionnés sur la position du dernier objet actif dans la sélection.
Aligner > Centrer verticalement
Aligne sur la verticale le point central des objets sélectionnés.
Aligner > Centrer horizontalement
Aligne sur l'horizontale le point central des objets sélectionnés.
Aligner > Sur la grille
Aligne les objets sélectionnés sur le point de la grille le plus proche.
Répartir > Horizontalement
Répartit uniformément les objets sélectionnés sur l'horizontale.
Répartir > Verticalement
Distribue uniformément les objets sélectionnés sur la verticale.
Répartir > En rangées et colonnes
Aligne et répartit uniformément les objets sélectionnés sur les rangées et les colonnes.
Centrer sur la page > Horizontalement
Centre les objets sélectionnés horizontalement dans la form design.
Centrer sur la page > Verticalement
Centre les objets sélectionnés verticalement dans la form design.
Donner une même taille > Largeur
Change la taille des objets sélectionnés pour que leur largeur soit identique à celle du dernier objet sélectionné.
Donner une même taille > Hauteur
Change la taille des objets sélectionnés pour que leur hauteur soit identique à celle du dernier objet sélectionné.
Donner une même taille > Les deux
Change la taille des objets sélectionnés pour que leur largeur et leur hauteur correspondent à celles du dernier objet sélectionné.
Associer
Combine les objets sélectionnés de façon à ce qu'ils soient traités comme un seul et même objet. Il n'y a pas de limite quant au nombre d'objets contenus dans un groupe ou au nombre d'imbrications.
Dissocier
Dissocie le groupe d'objets en unités distinctes.
Fusionner les objets de texte sélectionnés
Fusionne le contenu de plusieurs objets de texte en un seul objet. La taille et la position du nouvel objet correspondent au contour global des objets fusionnés.
Fusionner comme légende
Fusionne en un objet unique le contenu d'un objet de texte et un objet de champ dont la légende est définie sur Aucune. La légende du nouvel objet devient le texte de l'objet de texte. La taille et la position du nouvel objet correspondent au contour global des objets fusionnés.
Placer dans un nouveau groupe de boutons radio
Place les objets de bouton radio sélectionnés dans un seul objet.
Fusionner les groupes de boutons radio
Fusionne les groupes de boutons radio sélectionnés (ou au moins un groupe de boutons radio sélectionné et un ou plusieurs boutons radio sélectionnés) en un seul groupe de boutons radio.
Premier plan
Amène les objets sélectionnés au premier plan.
En avant
Déplace les objets sélectionnés vers l'avant par rapport aux autres objets.
En arrière
Déplace les objets sélectionnés vers l'arrière par rapport aux autres objets.
Arrière-plan
Envoie les objets sélectionnés à l'arrière-plan.


Menu Outils

Le menu Outils comprend des commandes qui permettent de spécifier des options.
Vérifier l'orthographe
Ouvre la boîte de dialogue Vérifier l'orthographe qui permet d'effectuer les opérations suivantes : corriger une occurrence particulière ou l'ensemble des occurrences d'un mot mal orthographié dans les objets sélectionnés ou dans le formulaire entier, ajouter des mots à Mon dictionnaire personnel, créer une liste de mots à ignorer et afficher le panneau Orthographe dans la boîte de dialogue Options.
Modifier un dictionnaire
Ouvre la boîte de dialogue Modifier un dictionnaire qui permet d'effectuer les opérations suivantes : consulter la liste des mots disponible dans Mon dictionnaire personnel dans une langue particulière ou dans toutes les langues, changer l'orthographe des mots répertoriés et ajouter ou supprimer des mots dans une langue particulière ou dans toutes les langues.
Gestionnaire de modèles
Ouvre la boîte de dialogue Gestionnaire de modèles qui permet de gérer les modèles et de définir le modèle par défaut.
Raccourcis clavier
Ouvre la boîte de dialogue Raccourcis clavier permettant de personnaliser les raccourcis clavier.
Personnaliser les barres d'outils
Personnalise l'aspect des barres d'outils.
Options
Ouvre la boîte de dialogue Options qui permet de définir les options relatives au traitement des documents, à l'espace de travail, à la vérification de l'orthographe, aux assistants et conseils, au texte bidirectionnel, à la liaison des données et aux paramètres linguistiques et de mesures internationaux.
Créer un formulaire à partir d'une feuille de calcul
Ouvre l’assistant de création de formulaires dans lequel vous pouvez produire un formulaire PDF avec des champs interactifs basés sur les en-têtes de colonne d'une feuille de calcul Microsoft Excel.


Menu Fenêtre

Le menu Fenêtre comprend des commandes qui permettent d’afficher ou de masquer les form designs et les palettes dans LiveCycle Designer.
Réorganiser > Nouvelle fenêtre
Ouvre une nouvelle fenêtre de la form design active.
Réorganiser > Cascade
Affiche une série de form designs en cascade.
Réorganiser > Mosaïque
Affiche toutes les fenêtres de form design ouvertes.
Réorganiser > Réorganiser les icônes
Organise les fenêtres réduites en icônes au bas de la fenêtre de LiveCycle Designer.
Espace de travail > Palettes en haut
Affiche ou masque les palettes ancrées en haut de la fenêtre de LiveCycle Designer.
Espace de travail > Palettes en bas
Affiche ou masque les palettes ancrées en bas de la fenêtre de LiveCycle Designer.
Espace de travail > Palettes à gauche
Affiche ou masque les palettes ancrées à gauche de la fenêtre de LiveCycle Designer.
Espace de travail > Palettes à droite
Affiche ou masque les palettes ancrées à droite de la fenêtre de LiveCycle Designer.
Espace de travail > Palettes flottantes
Affiche ou masque les palettes flottantes.
Espace de travail > Réinitialiser la position des palettes
Ramène les palettes à leur emplacement par défaut.
Barres d'outils
Affiche ou masque la barre d'outils.
Editeur de script
Affiche ou masque l’éditeur de script.
Barre d'état
Affiche ou masque la barre d’état.
Hiérarchie
Affiche ou masque la palette Hiérarchie.
Structure PDF
Affiche ou masque la palette Structure PDF.
Vue des données
Affiche ou masque la palette Vue des données.
Bibliothèque
Affiche ou masque la palette Bibliothèque.
Disposition
Affiche ou masque la palette Disposition.
Bordure
Affiche ou masque la palette Bordure.
Objet
Affiche ou masque la palette Objet.
Accessibilité
Affiche ou masque la palette Accessibilité.
Police
Affiche ou masque la palette Police.
Paragraphe
Affiche ou masque la palette Paragraphe.
Accessoires de dessin
Affiche ou masque la palette Accessoires de dessin.
Info
Affiche ou masque la palette Info.
Rapport
Affiche ou masque la palette Rapport.
Procédures
Affiche ou masque la palette Procédures.


Menu Aide

Le menu Aide comprend les commandes qui permettent d'obtenir de l'aide sur LiveCycle Designer et d'identifier la version.
Adobe LiveCycle DesignerAide
Affiche les rubriques d'aide de LiveCycle Designer.
Procédures
Affiche ou masque la palette Procédures.
Mise en route
Affiche les didacticiels conçus pour vous guider tout au long de la création de formulaires de base.
Référence sur les objets de script
Affiche les références sur les objets de script. La référence sur les objets de script décrit les objets, les propriétés et les méthodes que vous pouvez utiliser dans l'environnement de script LiveCycle Designer.
Bienvenue
Affiche ou masque l’écran de bienvenue.
A propos de LiveCycle Designer 8,0
Affiche la version de LiveCycle Designer et les informations relatives au copyright.


Menu Gestionnaire de modèles

Le menu qui s'affiche dans les boîtes de dialogue Nouveau et Gestionnaire de modèles propose différentes commandes permettant de gérer les modèles de formulaire.
Aide
Ouvre l'aide de LiveCycle Designer et affiche une description de la boîte de dialogue.
Afficher > Grandes icônes
Affiche les objets en tant que grandes icônes.
Afficher > Liste
Affiche les objets selon leur nom, par ordre alphabétique.
Ajouter un modèle
Ouvre la boîte de dialogue Ajouter un fichier modèle dans laquelle vous pouvez rechercher le modèle à ajouter à la boîte de dialogue.
Supprimer le modèle
Supprime le modèle sélectionné de la boîte de dialogue.
Renommer le modèle
Renomme le modèle dans la boîte de dialogue.
Déplacer le modèle vers >[panneau]
Déplace le modèle vers un autre panneau de la boîte de dialogue.
Ajouter une catégorie
Ajoute un panneau à la boîte de dialogue.
Supprimer la catégorie
Supprime le panneau actif de la boîte de dialogue. Tous les panneaux ne peuvent pas être supprimés.
Propriétés de la catégorie
Affiche les propriétés du panneau. Ces propriétés peuvent être modifiées.
Restaurer les modèles par défaut
Restaure les paramètres d'origine des modèles par défaut.


Menu Editeur de champs

Le menu Editeur de champs figurant dans l'éditeur de champs donne accès aux commandes de gestion des propriétés d'objet sélectionnées.
Couper
Supprime la sélection active et la copie dans le Presse-papiers.
Copier
Ajoute une copie de la sélection active dans le Presse-papiers.
Coller
Copie le contenu du Presse-papiers sur la page.
Supprimer
Supprime la sélection active sans en placer une copie dans le Presse-papiers.
Renommer l'objet Renomme l'objet sélectionné.
Remplacer le type d'objet > Champ de texte
Définit le type d'objet en tant que champ de texte.
Remplacer le type d'objet > Champ numérique
Définit le type d'objet en tant que champ numérique.
Remplacer le type d'objet > Bouton
Définit le type d'objet en tant que bouton.
Remplacer le type d'objet > Zone de liste
Définit le type d'objet en tant que zone de liste.
Remplacer le type d'objet > Liste déroulante
Définit le type d'objet en tant que liste déroulante.
Remplacer le type d'objet > Bouton radio
Définit le type d'objet en tant que bouton radio.
Remplacer le type d'objet > Champ d'image
Définit le type d'objet en tant que champ d'image.
Remplacer le type d'objet > Rectangle
Définit le type d'objet en tant que Rectangle.
Remplacer le type d'objet > Cercle
Définit le type d'objet en tant que Cercle.
Remplacer le type d'objet > Ligne
Définit le type d'objet en tant que Ligne.
Remplacer le type d'objet > Image
Définit le type d'objet en tant qu'image.
Remplacer le type d'objet > Texte
Définit le type d'objet en tant que texte.
Placer dans un sous-formulaire
Crée un sous-formulaire qui contient les objets sélectionnés.
Placer hors du sous-formulaire
Supprime le sous-formulaire, mais laisse les objets dans la form design.
Fusionner
Fusionne le contenu de plusieurs objets de texte en un seul objet. La taille et la position du nouvel objet correspondent au contour global des objets fusionnés.
Premier plan
Amène les objets sélectionnés au premier plan.
En avant
Déplace les objets sélectionnés vers l'avant par rapport aux autres objets.
En arrière
Déplace les objets sélectionnés vers l'arrière par rapport aux autres objets.
Arrière-plan
Envoie les objets sélectionnés à l'arrière-plan.
Palettes > Disposition
Affiche ou masque la palette Disposition.
Palettes > Bordure
Affiche ou masque la palette Bordure.
Palettes > Objet
Affiche ou masque la palette Objet.
Palettes > Police
Affiche ou masque la palette Police.
Palettes > Paragraphe
Affiche ou masque la palette Paragraphe.
Palettes > Accessibilité
Affiche ou masque la palette Accessibilité.
Ajouter à la bibliothèque
Ajoute l'objet à la palette bibliothèque.
Modifier le texte
Applique les changements apportés à la légende de l'objet.


Menu de la palette Hiérarchie

Le menu de la palette Hiérarchie affiche les commandes qui permettent de manipuler les éléments correspondants. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette. Vous pouvez également accéder au menu contextuel de la palette Hiérarchie en cliquant sur le bouton droit de la souris.
Aide
Ouvre l'aide de LiveCycle Designer et affiche une description de la palette Hiérarchie.
Masquer la palette
Masque la palette.
Renommer l'objet
Renomme l'objet sélectionné dans la palette Hiérarchie.
Supprimer
Supprime la sélection active sans en placer une copie dans le Presse-papiers.
Placer dans un sous-formulaire
Crée un sous-formulaire qui contient les objets sélectionnés.
Placer hors du sous-formulaire
Supprime le sous-formulaire, mais laisse les objets dans la form design.
Insérer un sous-formulaire
Ajoute un sous-formulaire à la form design.
Placer dans un jeu de sous-formulaires
Crée un sous-formulaire regroupant au moins deux sous-formulaires afin qu'ils restent associés.
Placer dans le jeu de sous-formulaires choisi
Crée un nouveau sous-formulaire regroupant au moins deux sous-formulaires afin qu'ils restent associés, mais un seul d'entre eux figurera sur le formulaire final selon les conditions définies par l'utilisateur.
Placer hors du jeu de sous-formulaires
Supprime l'association de deux ou plusieurs formulaires qui les conservait ensemble.
Insérer un jeu de sous-formulaires
Ajoute un jeu de sous-formulaires à la form design.
Fusionner les objets de texte sélectionnés
Fusionne le contenu de plusieurs objets de texte en un seul objet. La taille et la position du nouvel objet correspondent au contour global des objets fusionnés.
Fusionner comme légende
Fusionne en un objet unique le contenu d'un objet de texte et d'un objet de champ dont la légende est définie sur Aucune. La légende du nouvel objet devient le texte de l'objet de texte. La taille et la position du nouvel objet correspondent au contour global des objets fusionnés.
Placer dans un nouveau groupe de boutons radio
Place les objets de bouton radio sélectionnés dans un seul objet.
Fusionner les groupes de boutons radio
Fusionne les groupes de boutons radio sélectionnés (ou au moins un groupe de boutons radio sélectionné et un ou plusieurs boutons radio sélectionnés) en un seul groupe de boutons radio.
Insérer un objet de script
Ajoute un script qui devient un enfant de l'objet sélectionné. L'objet de script est un objet que vous pouvez utiliser pour stocker le code et les valeurs du script à l'extérieur de l'objet de formulaire proprement dit. En général, un objet de script permet de créer des fonctions et des méthodes personnalisées à utiliser dans des scripts à plusieurs emplacements d'un formulaire.
Nouvelle page
Ajoute une nouvelle page à la suite de la dernière page de la form design. Cette commande apparaît à condition d'avoir sélectionné une page dans la palette Hiérarchie.
Nouveau gabarit
Ajoute un nouveau gabarit à la suite du dernier gabarit de la form design. Cette commande apparaît à condition d'avoir sélectionné un gabarit dans la palette Hiérarchie.
Insérer un jeu de pages
Ajoute un groupe de pages pour contrôler l'ordre et l'occurrence des pages dans une form design.
Afficher les noms
Affiche le nom de l'objet. Il s'agit de la valeur par défaut.
Afficher les légendes
Affiche la légende de l'objet, à raison de 25 caractères au maximum. En l'absence de légende pour l'objet, (aucune légende) est affiché.
Afficher les deux
Affiche le nom de l'objet et la légende de l'objet.


Menu de la palette Vue des données

Le menu de la palette Vue des données affiche les commandes permettant de manipuler les éléments correspondants. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette. Vous pouvez également accéder au menu contextuel de la palette Vue des données en cliquant sur le bouton droit de la souris.
Aide
Ouvre l’aide de LiveCycle Designer et affiche une description de la palette Vue des données.
Masquer la palette
Masque la palette.
Nouvelle connexion aux données
Etablit une connexion aux données. Cette boîte de dialogue fournit une description de la connexion entre la source de données et la conception de formulaire.
Supprimer la connexion aux données
Supprime la connexion aux données sélectionnée à partir de la form design.
Propriétés de la connexion
Affiche les propriétés de la connexion aux données active. Certaines propriétés sont modifiables.
Générer les champs
Crée des champs, des sous-formulaires et des jeux de sous-formulaire dans la form design correspondant à la hiérarchie des données représentée par la connexion aux données.
Options
Affiche les options qui sont appliquées lorsque vous générez un champ ou un groupe de champs en utilisant la commande Générer les champs.
Afficher les noms de données
Affiche le nom de données de l'objet. Il s'agit de la valeur par défaut.
Afficher les descriptions de données
Affiche la description de données de l'objet, à raison de 25 caractères au maximum. En l'absence de description pour l'objet, le nom de données est affiché.
Afficher les deux
Affiche le nom de données et la description de l'objet.
Afficher les infos
Affiche ou masque les propriétés du noeud sélectionné dans la palette Vue des données.
Actualiser la vue des données
Actualise toutes les connexions aux données dans le modèle actif.


Menu de la palette Structure PDF

Le menu de la palette Structure PDF affiche les commandes permettant de manipuler les éléments correspondants. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette. Vous pouvez également accéder au menu contextuel de la palette Structure PDF en cliquant sur le bouton droit de la souris.
Aide
Ouvre l'aide de LiveCycle Designer et affiche une description de la palette Structure PDF.
Masquer la palette
Masque la palette (vous pouvez la réafficher à partir du menu Fenêtre).
Ajouter un champ à la structure
Crée un élément de structure de champ à partir de l'objet de champ sélectionné dans le panneau Vue de conception. A chaque champ correspond un seul élément de structure dans la vue de structure.
Supprimer le champ de la structure
Supprime l'élément de structure de champ sélectionné.
Balise précédente
Passe de la balise de structure sélectionnée à la balise de structure précédente.
Balise suivante
Passe de la balise de structure sélectionnée à la balise de structure suivante.
Déplacer le champ vers le haut
Déplace le champ sélectionné d'un rang vers le haut sous la balise de structure active. Si le champ sélectionné est le premier champ sous la balise, il passe sous la balise de structure précédente.
Déplacer le champ vers le bas
Déplace le champ sélectionné d'un rang vers le bas sous la balise de structure active. Si le champ sélectionné est le dernier champ sous la balise, il passe sous la balise de structure suivante.
Rechercher les champs non balisés
Localise et identifie les champs n'ayant pas de structure.
Afficher les balises de contenu
Active ou désactive l'affichage des balises de contenu.


Menu de la palette Bibliothèque

Le menu de la palette Bibliothèque affiche les commandes qui permettent de manipuler les éléments correspondants. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette.
Aide
Ouvre l'aide d'LiveCycle Designer et affiche une description de la palette Bibliothèque.
Masquer la palette
Masque la palette.
Réduire tout
Masque les objets dans les listes de la palette Bibliothèque.
Développer tout
Affiche les objets dans les listes de la palette Bibliothèque.
Afficher l'aperçu de l'objet
Affiche ou masque le panneau d’aperçu de l’objet sélectionné.
Zoom de l'aperçu > [%]
Affiche le facteur de zoom du panneau d'aperçu.
Ajouter un groupe
Ajoute une nouvelle catégorie à la palette Bibliothèque dans laquelle vous pouvez créer et stocker des objets.
Emplacement de la bibliothèque partagée
Affiche l'emplacement de la bibliothèque partagée.
Restaurer les objets par défaut pour tous les groupes
Lorsque cela est permis, rétablit tous les objets qui figuraient dans la palette Bibliothèque au moment de l'installation.


Menu Favoris

Le menu Favoris affiche les commandes permettant de manipuler les objets correspondants dans la palette Bibliothèque. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette.
Afficher > Grandes icônes
Affiche les objets en tant que grandes icônes.
Afficher > Petites icônes
Affiche les objets en tant que petites icônes.
Afficher > Liste triée
Affiche les objets selon leur nom, par ordre alphabétique.
Déplacer l’objet vers > [tab]
Déplace l'objet sélectionné vers la liste indiquée dans la palette Bibliothèque.
Retirer l'objet de la bibliothèque
Supprime l'objet sélectionné de la palette Bibliothèque.
Propriété de l'objet
Affiche des informations sur l'objet. Si la modification de l'objet est permise, vous pouvez modifier ces informations à l'aide de cette commande.
Supprimer le groupe
Supprime la catégorie sélectionnée et les objets correspondants de la palette Bibliothèque.
Propriétés du groupe
Affiche les propriétés de la catégorie sélectionnée dans la palette Bibliothèque. Il n'est pas permis de modifier les propriétés d'une bibliothèque partagée.
Restaurer les objets par défaut
Lorsque cela est autorisé, restaure les objets qui se trouvaient dans la catégorie Favoris au moment de l'installation et les ajoute à la liste active.


Menu Standard

Le menu Standard affiche les commandes permettant de manipuler les objets correspondants dans la palette Bibliothèque. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette.
Afficher > Grandes icônes
Affiche les objets en tant que grandes icônes.
Afficher > Petites icônes
Affiche les objets en tant que petites icônes.
Afficher > Liste triée
Affiche les objets selon leur nom, par ordre alphabétique.
Déplacer l’objet vers > [tab]
Déplace l'objet sélectionné vers la liste indiquée dans la palette Bibliothèque.
Retirer l'objet de la bibliothèque
Supprime l'objet sélectionné de la palette Bibliothèque.
Propriété de l'objet
Affiche des informations sur l'objet. Si la modification de l'objet est permise, vous pouvez modifier ces informations à l'aide de cette commande.
Supprimer le groupe
Supprime la catégorie sélectionnée et les objets correspondants de la palette Bibliothèque.
Propriétés du groupe
Affiche les propriétés de la catégorie sélectionnée dans la palette Bibliothèque. Il n'est pas permis de modifier les propriétés d'une bibliothèque partagée.
Restaurer les objets par défaut
Lorsque cela est autorisé, restaure les objets qui se trouvaient dans la catégorie Standard au moment de l'installation et les ajoute à la liste active.


Menu Personnalisés

Le menu ///Personnalisés affiche les commandes permettant de manipuler les objets correspondants dans la palette Bibliothèque. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette.
Afficher > Grandes icônes
Affiche les objets en tant que grandes icônes.
Afficher > Petites icônes
Affiche les objets en tant que petites icônes.
Afficher > Liste triée
Affiche les objets selon leur nom, par ordre alphabétique.
Déplacer l’objet vers > [tab]
Déplace l'objet sélectionné vers la liste indiquée dans la palette Bibliothèque.
Retirer l'objet de la bibliothèque
Supprime l'objet sélectionné de la palette Bibliothèque.
Propriété de l'objet
Affiche des informations sur l'objet. Si la modification de l'objet est permise, vous pouvez modifier ces informations à l'aide de cette commande.
Supprimer le groupe
Supprime la catégorie sélectionnée et les objets correspondants de la palette Bibliothèque.
Propriétés du groupe
Affiche les propriétés de la catégorie sélectionnée dans la palette Bibliothèque. Il n'est pas permis de modifier les propriétés d'une bibliothèque partagée.
Restaurer les objets par défaut
Lorsque cela est autorisé, restaure les objets qui se trouvaient dans la catégorie Personnalisés au moment de l'installation et les ajoute à la liste active.


Menu Code à barres

Le menu Code à barres affiche les commandes permettant de manipuler les objets correspondants dans la palette Bibliothèque. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette.
Afficher > Grandes icônes
Affiche les objets en tant que grandes icônes.
Afficher > Petites icônes
Affiche les objets en tant que petites icônes.
Afficher > Liste triée
Affiche les objets selon leur nom, par ordre alphabétique.
Déplacer l’objet vers > [tab]
Déplace l'objet sélectionné vers la liste indiquée dans la palette Bibliothèque.
Retirer l'objet de la bibliothèque
Supprime l'objet sélectionné de la palette Bibliothèque.
Propriété de l'objet
Affiche des informations sur l'objet. Si la modification de l'objet est permise, vous pouvez modifier ces informations à l'aide de cette commande.
Supprimer le groupe
Supprime la catégorie sélectionnée et les objets correspondants de la palette Bibliothèque.
Propriétés du groupe
Affiche les propriétés de la catégorie sélectionnée dans la palette Bibliothèque. Il n'est pas permis de modifier les propriétés d'une bibliothèque partagée.
Restaurer les objets par défaut
Lorsque cela est autorisé, restaure les objets qui se trouvaient dans la catégorie Code à barres au moment de l'installation et les ajoute à la liste active.


Menu de la palette Disposition

Le menu de la palette Disposition affiche les commandes qui permettent de manipuler les éléments correspondants. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette.
Aide
Ouvre l'aide de LiveCycle Designer et affiche une description de la palette Disposition.
Masquer la palette
Masque la palette.
Coordonnées absolues
Affiche les coordonnées X et Y calculées par rapport au coin supérieur gauche de la page. Les coordonnées absolues sont surtout pratiques pour les formulaires avec une disposition fixe.
Coordonnées relatives
Affiche les coordonnées X et Y relatives aux objets parent. Les coordonnées absolues sont surtout pratiques pour les formulaires prévus pour s'adapter à la taille des données.


Menu de la palette Bordure

Le menu de la palette Bordure affiche les commandes qui permettent de manipuler les éléments correspondants. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette.
Aide
Ouvre l'aide de LiveCycle Designer et affiche une description de la palette Bordure.
Masquer la palette
Masque la palette.


Menu de la palette Objet

Le menu de la palette Objet affiche les commandes qui permettent de manipuler les éléments correspondants. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette.
Aide
Ouvre l'aide de LiveCycle Designer et affiche une description de la palette Objet.
Masquer la palette
Masque la palette.
Afficher les propriétés dynamiques
Active ou désactive les libellés actifs des propriétés dynamiques. Les libellés actifs indiquent les propriétés pouvant devenir dynamiques. Ils sont identifiables par un trait de soulignement vert sur lequel vous pouvez cliquer afin de lier de manière dynamique la propriété à une source de données.


Menu de la palette Accessibilité

Le menu de la palette Accessibilité affiche les commandes qui permettent de manipuler les éléments correspondants. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette.
Aide
Ouvre l'aide de LiveCycle Designer et affiche une description de la palette Accessibilité.
Masquer la palette
Masque la palette.
Afficher les propriétés dynamiques
Active ou désactive les libellés actifs des propriétés dynamiques. Les libellés actifs indiquent les propriétés pouvant devenir dynamiques. Ils sont identifiables par un trait de soulignement vert sur lequel vous pouvez cliquer afin de lier de manière dynamique la propriété à une source de données.


Menu de la palette Police

Le menu de la palette Police affiche les commandes qui permettent de manipuler les éléments correspondants. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette.
Aide
Ouvre l'aide de LiveCycle Designer et affiche une description de la palette Police.
Masquer la palette
Masque la palette.
Répertorier les noms de police en utilisant leur police
Affiche les noms des polices en utilisant ces polices.
Menu de la palette Modification de la légende
Le menu de la palette Modification de la légende affiche les commandes permettant d'utiliser la palette Police. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette.
le menu de la palette Modification de la légende est uniquement disponible lorsque la totalité de l'objet est sélectionnée et que la commande Edition > Verrouiller le texte n'est pas activée.
Modifier la légende et la valeur
Applique les changements apportés à la fois à la légende et à la valeur de l'objet, dans la palette Paragraphe.
Modifier la légende
Applique les changements apportés à la légende de l'objet, dans la palette Paragraphe.
Modifier la valeur
Applique les changements apportés à la valeur de l'objet, dans la palette Paragraphe.


Menu de la palette Paragraphe

Le menu de la palette Paragraphe affiche les commandes qui permettent de manipuler les éléments correspondants. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette.
Aide
Ouvre l'aide de LiveCycle Designer et affiche une description de la palette Paragraphe.
Masquer la palette
Masque la palette.
Menu de la palette Modification de la légende
[Le menu de la palette Modification de la légende affiche les commandes permettant d'utiliser la palette Paragraphe. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette.
le menu de la palette Modification de la légende est uniquement disponible lorsque la totalité de l'objet est sélectionnée et que la commande Edition > Verrouiller le texte n'est pas activée.
Modifier la légende et la valeur
Applique les changements apportés à la fois à la légende et à la valeur de l'objet, dans la palette Paragraphe.
Modifier la légende
Applique les changements apportés à la légende de l'objet, dans la palette Paragraphe.
Modifier la valeur
Applique les changements apportés à la valeur de l'objet, dans la palette Paragraphe.


Menu de la palette Accessoires de dessin

Le menu de la palette Accessoires de dessin affiche les commandes permettant de manipuler les éléments correspondants. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette.
Aide
Ouvre l'aide de LiveCycle Designer et affiche une description de la palette Accessoires de dessin.
Masquer la palette
Masque la palette.
Pouces/Centimètres/Millimètres décimaux/Points
Affiche une valeur au format n po ou n cm.
Lignes par pouce/centimètres/pica
Affiche une valeur au format n/po ou n/cm.
Jeux de lignes guides >[ligne guide]
Ajoute des lignes guides horizontales et verticales.


Menu de la palette Info

Le menu de la palette Info affiche les commandes qui permettent de manipuler les éléments correspondants. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette.
Aide
Ouvre l'aide de LiveCycle Designer et affiche une description de la palette Info.
Masquer la palette
Masque la palette.


Menu de la palette Rapport

Le menu de la palette Rapport affiche les commandes qui permettent de manipuler les éléments correspondants. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette.
Aide
Ouvre l'aide de LiveCycle Designer et affiche une description de la palette Rapport.
Masquer la palette
Masque la palette.
Effacer les avertissements
Efface le contenu du panneau Avertissements.


Menu de la palette Procédures

Le menu de la palette Procédures affiche les commandes qui permettent de manipuler les éléments correspondants. Pour accéder à ce menu, cliquez sur le bouton Plus de la palette.
Aide
Ouvre l'aide de LiveCycle Designer et affiche une description de la palette Procédures.
Masquer la palette
Masque la palette.


Barres d'outils

A propos des barres d’outils
Barre d’outils Standard
Barre d'outils Formatage de texte
Barre d’outils Disposition
Barre d'outils Tableau
Barre d'outils Outils


A propos des barres d’outils

Les barres d'outils regroupent les boutons correspondant aux commandes les plus fréquemment utilisées. Les barres d’outils suivantes sont installées avec LiveCycle Designer :
      •
      Standard
      •
      Formatage de texte
      •
      Disposition
      •
      Tableau
      •
      Outils
Vous pouvez modifier les barres d'outils ou en créer de nouvelles pour répondre à vos besoins.
Voir aussi
Pour personnaliser les barres d’outils
Barre d’outils Standard
Barre d'outils Formatage de texte
Barre d’outils Disposition
Barre d'outils Tableau
Barre d'outils Outils


Barre d’outils Standard

La barre d’outils Standard offre un accès rapide aux commandes les plus courantes de LiveCycle Designer.
Nouveau
Ouvre une nouvelle form design.
Ouvrir
Ouvre une form design existante.
Enregistrer
Enregistre le contenu de la form design active.
Imprimer
Imprime le contenu des panneaux Vue de conception et Gabarit actifs dans l’éditeur de disposition.
Annuler
Annule les dernières actions réalisées (10 au maximum).
Rétablir
Applique à nouveau une action qui a été annulée (10 au maximum).
Rechercher
Recherche dans le panneau Source XML ou dans l'éditeur de script toutes les occurrences d'une expression ou d'un mot précis.
Afficher la grille
Affiche ou masque la grille.
Accrocher à la grille
Active ou désactive la fonction d'accrochage à la grille. Lorsque cette fonction est activée, accroche l'objet sélectionné au point de la grille le plus proche.
Conserver l'outil de dessin
Lorsque cette fonction est activée, vous pouvez dessiner autant de copies d'un objet que vous le souhaitez, sans devoir le sélectionner chaque fois dans la palette Bibliothèque. Pour désactiver cette fonction, cliquez de nouveau sur le bouton Conserver l'outil de dessin.
Taille réelle
Définit le facteur de zoom sur 100 %.
Page entière
Redimensionne la page de sorte qu'elle s'ajuste à l'éditeur de mise en forme.
Pleine largeur
Redimensionne la page de sorte que sa largeur s'ajuste à l'éditeur de mise en forme.
Zoom arrière
Applique un zoom arrière afin d'afficher davantage d'éléments.
Zoom
Applique un zoom avant pour afficher les détails ou un zoom arrière pour afficher une plus grande zone.
Zoom avant
Applique un zoom avant afin d'afficher des détails.
Palette Procédures
Affiche ou masque la palette Procédures.
Vérifier l'orthographe
Vérifie l'orthographe d'une partie ou de l'intégralité du document actif.


Barre d'outils Formatage de texte

La barre d'outils Formatage de texte offre un accès rapide aux commandes de formatage de texte et de paragraphe les plus courantes.
Police (de caractère)
Affiche le nom de la police du texte sélectionné.
Corps
Affiche la taille de la police du texte sélectionné.
Gras
Applique l'attribut Gras au texte sélectionné ou l'annule.
Italique
Applique l'attribut Italique au texte sélectionné ou l'annule.
Souligné
Applique l'attribut Souligné au texte sélectionné ou l'annule.
Aligner à gauche
Aligne le texte à gauche.
Centrer
Centre le texte.
Aligner à droite
Aligne le texte à droite.
Justifier
Justifie le texte.


Barre d’outils Disposition

La barre d'outils Disposition offre un accès rapide aux commandes de mise en forme les plus courantes.
Aligner à gauche
Aligne les bords gauches des objets sélectionnés.
Aligner à droite
Aligne les bords droits des objets sélectionnés.
Aligner en haut
Aligne les bords supérieurs des objets sélectionnés.
Aligner en bas
Aligne les bords inférieurs des objets sélectionnés.
Aligner le centre sur la verticale
Aligne sur la verticale le point central des objets sélectionnés.
Aligner le centre sur l'horizontale
Aligne sur l'horizontale le point central des objets sélectionnés.
Répartir proportionnellement sur l'horizontale
Répartit uniformément les objets sélectionnés sur l'horizontale.
Distribuer proportionnellement sur la verticale
Distribue uniformément les objets sélectionnés sur la verticale.
Répartir proportionnellement en rangées et colonnes
Aligne et répartit uniformément les objets sélectionnés sur les rangées et les colonnes.
Premier plan
Amène les objets sélectionnés au premier plan.
Arrière-plan
Envoie les objets sélectionnés à l'arrière-plan.
En avant
Déplace les objets sélectionnés vers l'avant par rapport aux autres objets.
En arrière
Déplace les objets sélectionnés vers l'arrière par rapport aux autres objets.
Associer
Combine les objets sélectionnés de façon qu'ils soient traités comme s'il s'agissait d'un seul objet. Il n'y a pas de limite quant au nombre d'objets contenus dans un groupe ou au nombre d'imbrications.
Dissocier
Dissocie le groupe d'objets en unités distinctes.
Fusionner
Si plusieurs objets de texte sont sélectionnés, les fusionne en un seul objet. Si plusieurs boutons radio sont sélectionnés, crée un groupe d'exclusion contenant les boutons radio sélectionnés.


Barre d'outils Tableau

La barre d’outils Tableau offre un accès rapide aux commandes les plus couramment utilisées pour les tableaux.
Insérer un tableau
Ouvre la boîte de dialogue Insérer un tableau.
Insérer - Rangée au-dessous
Insère une ou plusieurs rangées au-dessous des cellules ou rangées sélectionnées. Le nombre de rangées insérées correspond au nombre de rangées sélectionnées.
Insérer Colonne à droite
Insère une ou plusieurs colonnes à droite des colonnes sélectionnées. Le nombre de colonnes insérées correspond au nombre de colonnes sélectionnées.
Fusionner les cellules
Réunit au moins deux cellules attenantes de la même rangée en une seule cellule.
Scinder la cellule horizontalement
Sépare au moins deux cellules fusionnées d'une rangée en cellules distinctes.
Supprimer Rangée
Supprime toutes les rangées contenant une ou plusieurs cellules sélectionnées.
Supprimer - Colonne
Supprime toutes les colonnes contenant une ou plusieurs cellules sélectionnées.
Convertir en tableau
Convertit un ou plusieurs objets sélectionnés en tableau.


Barre d'outils Outils

La barre d'outils Outils offre un accès rapide aux outils les plus courants.
Outil Sélectionner
Sélectionne l'objet.
Outil Main
Déplace la page de façon à ce que vous puissiez voir toutes les zones de la page. Déplacer une page LiveCycle Designer avec l’outil Main équivaut à déplacer une feuille de papier sur un bureau.
Dessiner des champs
Change le type d'objet.
Outil Zoom
Applique un zoom avant afin d'afficher des détails.
Ordre de tabulation
Affiche l'ordre de tabulation actuel.


Présentation des boîtes de dialogue

Boîte de dialogue Propriétés de liaison
Boîte de dialogue Vérifier l'orthographe
Boîte de dialogue Editeur de collections
Boîte de dialogue Liste des collections
Boîte de dialogue Propriétés de la connexion
Boîte de dialogue Personnalisation
Boîte de dialogue Options d'affichage des données
Boîte de dialogue Paramètres de signature du document
Boîte de dialogue Propriétés dynamiques
Boîte de dialogue Modifier les sauts conditionnels
Boîte de dialogue Modifier les sous-formulaires désignés par les données
Boîte de dialogue Modifier le dictionnaire
Boîte de dialogue Options d'importation de fichier (Microsoft InfoPath et Word)
Boîte de dialogue Propriétés du formulaire
Boîte de dialogue Options d'importation
Boîte de dialogue Insérer un tableau
Boîte de dialogue Raccourcis clavier
Boîte de dialogue Polices manquantes
Boîte de dialogue Modifier les substitutions de polices
Boîte de dialogue Nouvelle connexion aux données
Boîte de dialogue Créer
Boîte de dialogue Ouvrir
Boîte de dialogue Options
Boîte de dialogue Impression
Boîte de dialogue Publier dans le référentiel
Boîte de dialogue Enregistrer sous
Signature des données et paramètres d'envoi, boîte de dialogue
Boîte de dialogue Spécifier une police de substitution
Boîte de dialogue Formatage de la syntaxe
Boîte de dialogue Assistant de création de tableaux
Boîte de dialogue Gestionnaire de modèles
Boîte de dialogue Options de modèle


Boîte de dialogue Propriétés de liaison

Utilisez cette boîte de dialogue pour modifier les propriétés d’un objet de formulaire lorsque vous associez une liaison de données à un champ existant de la conception de formulaire. Pour associer une liaison de données à un objet de formulaire, faites glisser un noeud de la palette Vue des données vers l'objet. Vous pouvez aussi utiliser l’onglet Liaison de la palette Objet. Voir Pour créer un champ ou un sous-formulaire lié.
Cette boîte de dialogue est uniquement affichée pour les objets de formulaire qui prennent en charge la liaison. Remarquez qu'elle n'est pas affichée lorsque vous configurez la liaison des objets de bouton radio.
Pour afficher cette boîte de dialogue, faites glisser un noeud de la palette Vue des données sur un champ existant de la conception de formulaire ou sélectionnez un noeud de liaison à partir du panneau Liaison de la palette Objet.
Mettre à jour toutes les propriétés connexes
Met à jour toutes les propriétés applicables à l'objet du formulaire pour les faire correspondre avec celles de l'objet de liaison.
Si vous sélectionnez Mettre à jour toutes les propriétés connexes et que le type d'objet du formulaire est différent du type de liaison, le type de l'objet est modifié pour le faire correspondre avec celui de la liaison. Par exemple, si l'objet du formulaire est un champ de texte et que l'objet de liaison est un champ numérique, l'objet du formulaire est converti en champ numérique lorsque vous sélectionnez l'option Mettre à jour toutes les propriétés connexes. Pour contrôler la conversion des types d'objet, utilisez l'option Mettre à jour uniquement les propriétés suivantes.
Mettre à jour uniquement les propriétés suivantes
Affiche la liste de toutes les propriétés applicables à l'objet du formulaire qui peuvent être mises à jour en fonction des propriétés de l'objet de liaison. Vous pouvez sélectionner précisément les propriétés à mettre à jour. Si vous validez toutes les options, le résultat est identique à celui obtenu à l'aide de l'option Mettre à jour toutes les propriétés connexes.
La liste des propriétés affichées varie en fonction de la combinaison entre le type d'objet du formulaire et la liaison. Si l'objet du formulaire et l'objet de liaison sont identiques, la liste des options dont vous pouvez mettre à jour les propriétés est la suivante :
      •
      Nom
      •
      Légende
      •
      Description
      •
      Occurrence
      •
      Scripts de validation
Les propriétés Nom et Légende sont toujours affichées. En revanche, les autres propriétés affichées varient en fonction de l'objet du formulaire et de la liaison. Par exemple, si la liaison contient des informations relatives à un script de validation, l'option Scripts de validation est affichée.
En fonction de la combinaison entre l'objet du formulaire et la liaison, LiveCycle Designer affiche également les options qui sont associées exclusivement au type de l'objet. La liste suivante répertorie les options de ce type dont vous pouvez modifier les propriétés :
      •
      Modèle de données (champs de texte et champ de date/heure uniquement)
      •
      Valeurs par défaut (tous les champs, excepté les champs d'image)
      •
      URL de l'image (champs d'image uniquement)
      •
      conception de formulaire Articles de liste (listes déroulantes uniquement)
      •
      Nombre max. de caractères (champs de texte uniquement)
Si le type d’objet du formulaire est identique à celui de l’objet de liaison, LiveCycle Designer affiche les propriétés associées exclusivement aux types d’objets avec les autres propriétés mentionnées au-dessus. Cependant, si le type d’objet du formulaire est différent de celui de l’objet de liaison, LiveCycle Designer affiche l’option Type suivie de l’ensemble des propriétés associées exclusivement aux types d’objets. Dans ce cas, vous devez sélectionner l'option Type afin de mettre à jour l'ensemble des propriétés associées aux types d'objets. Si vous ne sélectionnez pas l'option Type, aucune de ces propriétés n'est mise à jour.
Si vous ne souhaitez pas que le type d'objet du formulaire soit modifié, désélectionnez l'option Type.
Ne pas mettre à jour les propriétés connexes
Spécifie que les propriétés supplémentaires de l’objet, autres que celles liées à la liaison elle-même, ne sont pas modifiées.
Ne plus afficher
Arrête l'affichage de la boîte de dialogue Propriétés de liaison lorsque vous faites glisser un noeud de la palette Vue des données dans l'éditeur de disposition.
Aucune des propriétés de l'objet n'est mise à jour afin de correspondre aux propriétés de l'élément de données dans la source.
Pour que la boîte de dialogue Propriétés de liaison s'affiche à nouveau, cliquez sur la palette Vue des données avec le bouton droit de la souris et sélectionnez l'option Afficher les propriétés de liaison.
Voir aussi
A propos de la liaison de champs à une source de données


Boîte de dialogue Vérifier l'orthographe

Utilisez cette boîte de dialogue pour effectuer les opérations suivantes : corriger une occurrence particulière ou l'ensemble des occurrences d'un mot mal orthographié dans les objets sélectionnés ou dans le formulaire entier, ajouter des mots au dictionnaire personnel, créer une liste de mots à ignorer et afficher le panneau Orthographe dans la boîte de dialogue Options.
par défaut, LiveCycle Designer vérifie l'orthographe de l'ensemble du texte associé aux différents objets figurant dans le formulaire, c'est-à-dire le texte statique, les légendes, les info-bulles, le texte de lecteur d'écran personnalisé et les entrées de liste déroulante. Pour définir le type de texte examiné par LiveCycle Designer, sélectionnez les options dans la liste Orthographe disponible dans le panneau Orthographe de la boîte de dialogue Options. Pour plus de détails, voir Orthographe (boîte de dialogue Options).
Pour afficher cette boîte de dialogue, choisissez Outils> Vérifier l'orthographe.
Pas dans le dictionnaire
Affiche les mots mal orthographiés en contexte. Si, par exemple, le texte d'une info-bulle contient une faute d'orthographe, l'ensemble du texte de l'info-bulle s'affiche en surbrillance à la manière des mots mal orthographiés (rouge gras). Vous pouvez saisir directement vos corrections dans la zone. Lorsque vous corrigez une partie du texte dans la zone, la mise en surbrillance de couleur rouge et en gras est supprimée du mot erroné et les boutons Ignorer cette fois, Ignorer tout, Ajouter au dictionnaire, Remplacer tout et Annuler ne sont plus disponibles.
Trouvé dans
Affiche la syntaxe de référence décrivant l'objet dont vous vérifiez l'orthographe.
Suggestions
Liste de propositions de corrections orthographiques pour le mot mis en surbrillance.
Ignorer cette fois
Ignore cette occurrence du mot mal orthographié. LiveCycle Designer mettra en surbrillance les éventuelles occurrences suivantes.
Ignorer tout
Ignore toutes les occurrences du mot mal orthographié. Cette option permet d'ajouter le mot en question à la liste des mots ignorés de sorte que LiveCycle Designer n'assimile pas, pour la session actuelle, le mot à un mot mal orthographié. Toutes les opérations de vérification orthographique ignorent ce mot tant que vous ne redémarrez pas LiveCycle Designer. La liste des mots ignorés est vidée à chaque exécution de LiveCycle Designer.
Ajouter au dictionnaire
Le mot mis en surbrillance est ajouté aux langues du dictionnaire personnel. LiveCycle Designer ne considère plus ce mot comme étant mal orthographié.
Remplacer
Remplace le mot erroné (mis en surbrillance) dans le texte par le mot sélectionné dans la zone Suggestions ou par le mot indiqué dans la zone Pas dans le dictionnaire.
Remplacer tout
Remplace toutes les occurrences du mot erroné (mis en surbrillance) dans le texte par le mot sélectionné dans la zone Suggestions.
Annuler
Annule la modification précédente.
Options
Ouvre le panneau Orthographe dans la boîte de dialogue Options. Tout changement effectué dans le panneau Orthographe prend effet immédiatement et s'applique à la procédure de vérification en cours. Si, par exemple, vous désactivez la case Info-bulle de la liste Vérifier l'orthographe, LiveCycle Designer n'examinera pas le texte inclus dans les info-bulles.
Fermer
Ferme la boîte de dialogue Vérifier l'orthographe.


Boîte de dialogue Editeur de collections

Cette boîte de dialogue permet de sélectionner les objets à inclure dans la collection de champs de signature du document ou de codes à barres de formulaires pour support papier.
Pour l'afficher, cliquez sur Modifier dans le panneau Valeur de la palette Objet (lorsque l'objet code à barres de formulaires pour support papier est sélectionné).
Nom
Affiche le nom de la collection sélectionnée.
Type de collection
Spécifie le type de collection que vous êtes en train de modifier. Les deux types de collection sont les suivants : Signature du document et Code à barres de formulaires pour support papier.
La liste affiche les objets sous forme hiérarchique afin que vous puissiez sélectionner ou non les objets à inclure dans la collection.
Masquer les nœuds non pris en charge
Masque les objets non pris en charge de la collection sélectionnée. Cette opération facilite la localisation des objets que vous souhaitez inclure dans la collection.
Voir aussi
Pour ajouter un champ de signature du document
Propriétés des champs de signature du document dans le panneau Champ
Propriétés des codes à barres dans le panneau Champ
Pour définir le mode de fonctionnement d'un code à barres
A propos des collections d'objets de formulaire


Boîte de dialogue Liste des collections

Cette boîte de dialogue permet de créer, dupliquer, supprimer, organiser et modifier les collections d'objets pour les champs de signature du document et les codes à barres de formulaires pour support papier.
Pour afficher cette boîte de dialogue, cliquez sur Fichier > Collections d'objets de formulaire.
collection
Répertorie les collections de champs de signature du document et de codes à barres de formulaires pour support papier. Une collection s'applique soit aux champs de signature du document, soit aux codes à barres de formulaires pour support papier, mais jamais au deux, car ils utilisent différents types d'objets. Les collections disponibles pour les champs de signature du document se trouvent dans l'onglet Signature du document de la palette Objet. Les collections disponibles pour les codes à barres de formulaires pour support papier se trouvent dans l'onglet Valeur de la palette Objet.
Nouveau
Crée une nouvelle collection à la fin de la liste Collections.
Dupliquer
Crée une copie de la collection sélectionnée dans la liste Collections.
Monter
Déplace la collection sélectionnée vers le haut de la liste Collections.
Descendre
Déplace la collection sélectionnée vers le bas de la liste Collections.
Modifier
Ouvre la boîte de dialogue Editeur de collection afin que vous puissiez modifier la liste des objets inclus dans la collection.
Voir aussi
Pour ajouter un champ de signature du document
Propriétés des champs de signature du document dans le panneau Champ
Propriétés des codes à barres dans le panneau Champ
Pour définir le mode de fonctionnement d'un code à barres
A propos des collections d'objets de formulaire


Boîte de dialogue Propriétés de la connexion

Utilisez cette boîte de dialogue pour modifier le nom de la connexion aux données sélectionnée.
Pour afficher cette boîte de dialogue, sélectionnez une connexion aux données, puis choisissez Propriétés de la connexion dans le menu de la palette Vue des données.
Nom de la connexion
Affiche le nom de la connexion à la source de données. C'est dans cette zone que vous changez le nom de la connexion à la source de données.
Voir aussi
A propos des sources de données
Pour établir une connexion à un schéma XML et à un fichier de données XML
Pour établir une connexion à une base de données OLE
Pour établir une connexion à un fichier WSDL


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Personnalisation

Boîte de dialogue Personnalisation

Onglet Commandes (boîte de dialogue Personnalisation)
Onglet Barres d'outils (boîte de dialogue Personnalisation)


Onglet Commandes (boîte de dialogue Personnalisation)

Utilisez cette boîte de dialogue pour ajouter un menu ou un bouton à une barre d’outils.
Pour afficher cette boîte de dialogue, choisissez Outils> Personnaliser les barres d'outils, puis cliquez sur Commandes.
Catégories
Affiche la liste des catégories parmi lesquelles vous pouvez sélectionner des boutons pour les ajouter à une barre d'outils.
Boutons
Affiche les boutons que vous pouvez sélectionner en vue de les ajouter à une barre d'outils. Vous pouvez faire glisser ces boutons vers les barres d'outils existantes.
Voir aussi
Pour personnaliser les barres d’outils


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Personnalisation > Onglet Barres d'outils (boîte de dialogue Personnalisation)

Onglet Barres d'outils (boîte de dialogue Personnalisation)

Utilisez cette boîte de dialogue pour personnaliser les barres d’outils affichées dans LiveCycle Designer.
Pour afficher cette boîte de dialogue, choisissez Outils> Personnaliser les barres d’outils, puis cliquez sur Barres d’outils.
Barres d’outils
Répertorie les barres d’outils disponibles dans LiveCycle Designer.
Afficher les info-bulles
Affiche les info-bulles lorsque vous pointez sur une icône d’une barre d’outils.
Nouveau style
Change l'aspect des barres d'outils.
Grandes icônes
Affiche de grandes icônes sur la barre d'outils.
Nouveau
Crée une barre d'outils personnalisée.
Réinitialiser
Rétablit l'état par défaut des barres d'outils.
Voir aussi
Pour personnaliser les barres d’outils


Boîte de dialogue Options d'affichage des données

Utilisez cette boîte de dialogue pour définir les options appliquées lors de la génération d'un champ ou d'un groupe de champs à l'aide de la commande Générer les champs.
Pour afficher cette boîte de dialogue, choisissez Options dans le menu de la palette Vue des données.
Générer les scripts de validation
Génère les scripts de validation des nouveaux champs. Les scripts de validation qui sont générés sont de type JavaScript. Par exemple, un script de validation peut vérifier si la valeur spécifiée dans un champ se trouve dans la liste des valeurs acceptées.
Générer des descriptions
Génère des informations descriptives.
Autoriser la génération de tableaux
Crée un tableau lorsque vous faites glisser un noeud de tableau de la palette Vue des données vers l'éditeur de disposition. Si vous désactivez cette option, LiveCycle Designer crée des sous-formulaires positionnés ou distribués imbriqués.
Créer une rangée d'en-tête pour tout tableau
Crée une rangée d'en-tête pour chaque tableau défini.
Afficher les propriétés de liaison
Affiche la boîte de dialogue Propriétés de liaison lorsque vous faites glisser un noeud de la palette Vue des données vers l'éditeur de disposition.
Si vous désactivez cette option, aucune des propriétés de l'objet ne sera mise à jour afin de correspondre aux propriétés de l'élément de données dans la source de données lorsque vous faites glisser un noeud de la palette Vue des données vers l'éditeur de disposition.
Voir aussi
Pour définir les options de génération de champs


Boîte de dialogue Paramètres de signature du document

Panneau Emetteurs et stratégies (boîte de dialogue Paramètres de signature du document/Signature des données et paramètres d'envoi)
Panneau ID itinérant (boîte de dialogue Paramètres de signature du document/Signature des données et paramètres d'envoi)
Panneau Gestionnaire de signatures (boîte de dialogue Paramètres de signature du document/Signature des données et paramètres d'envoi)
Panneau Infos sur la signature (boîte de dialogue Paramètres de signature du document/Signature des données et paramètres d'envoi)
Panneau Signature des certificats (boîte de dialogue Paramètres de signature du document/Signature des données et paramètres d'envoi)
Panneau Motifs de la signature (boîte de dialogue Paramètres de signature du document)


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Paramètres de signature du document > Panneau Emetteurs et stratégies (boîte de dialogue Paramètres de signature du document/Signature des données et paramètres d'envoi)

Panneau Emetteurs et stratégies (boîte de dialogue Paramètres de signature du document/Signature des données et paramètres d'envoi)

Utilisez ce panneau pour spécifier les émetteurs de certificat, un serveur pour inscription au certificat et des stratégies relatives aux certificats.
Pour afficher ce panneau, effectuez une des actions suivantes :
      •
      Sélectionnez un champ de signature du document, cliquez sur le panneau Signature du document de la palette Objet, cliquez sur Paramètres, puis sur l'onglet Emetteurs et stratégies.
      •
      Sélectionnez un bouton d'envoi, cliquez sur l'onglet Envoyer de la palette Objet, assurez-vous que l'option Signature de l'envoi est activée, cliquez sur Paramètres, puis sur Emetteurs et stratégies.
      •
      Sélectionnez un bouton d'envoi par messagerie pou via HTTP, puis dans la palette Objet, assurez-vous que l'option Signature de l'envoi est activée, cliquez sur Paramètres, puis sur Emetteurs et stratégies.
Emetteurs de certificat
Répertorie les certificats qui identifient les émetteurs pouvant fournir aux utilisateurs des certificats de signature :
    • Ajouter
Ouvre la boîte de dialogue Sélectionner le certificat de l'émetteur vous permettant de rechercher et d'ajouter les certificats de l'émetteur. Un fichier de certificat peut être doté des extensions de nom de fichier suivants : .p7c, .p7b ou .cer.
    • Supprimer
Supprime les certificats sélectionnés de la liste.
    • Détail
Ouvre le programme de visualisation des certificats vous permettant de visualiser les informations concernant le certificat sélectionné. Les informations affichées dépendent du système d'exploitation et des certificats installés et délivrés par une autorité de certification.
    • Restreindre la signature aux certificats des émetteurs spécifiés
Acrobat rejette la signature si l'utilisateur ne dispose pas d'un certificat délivré par un émetteur spécifié.
URL du serveur d'enregistrement des certificats
Spécifie l'URL d'une page Web où les utilisateurs peuvent demander un certificat. Cette page Web s'affiche si un utilisateur ne dispose pas d'un certificat de signature valide.
Restreindre l'enregistrement des certificats au serveur d'URL spécifié
Oblige l'utilisateur à obtenir une certificat de signature d'un serveur d'adhésion spécifié.
Identifiants d'objet
Répertorie les identifiants d'objets (OID) associés aux stratégies de certificat permettant de limiter l'utilisation des certificats pour la signature du document ou des données.
Ajouter
Ajoute un identifiant d'objets.
Supprimer
Supprimer l'identifiant d'objets sélectionné.
Restreindre la signature aux certificats conformes aux stratégies spécifiées
Acrobat rejette la signature si le certificat de signature n'est pas conforme aux stratégies spécifiées.
Voir aussi
Utilisation de champs de signature de document
Aperçu du bouton Envoyer par messagerie
Aperçu du bouton Envoyer via HTTP
A propos de l'envoi de données au moyen d'un bouton
Pour ajouter un champ de signature du document
Pour ajouter une signature de données à un bouton d'envoi


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Paramètres de signature du document > Panneau ID itinérant (boîte de dialogue Paramètres de signature du document/Signature des données et paramètres d'envoi)

Panneau ID itinérant (boîte de dialogue Paramètres de signature du document/Signature des données et paramètres d'envoi)

Utilisez ce panneau pour spécifier un serveur qui contient les informations d'identification numériques utilisées pour signer le document ou les données.
Pour afficher ce panneau, effectuez une des actions suivantes :
      •
      Sélectionnez un champ de signature du document, cliquez sur le panneau Signature du document de la palette Objet, cliquez sur Paramètres, puis sur l'onglet ID itinérant.
      •
      Sélectionnez un bouton d'envoi, cliquez sur l'onglet Envoyer de la palette Objet, assurez-vous que l'option Signature de l'envoi est activée, cliquez sur Paramètres, puis sur ID itinérant.
      •
      Sélectionnez un bouton d'envoi par messagerie pou via HTTP, puis dans la palette Objet, assurez-vous que l'option Signature de l'envoi est activée, cliquez sur Paramètres, puis sur ID itinérant.
URL du serveur de signatures
Indique un service Web qui contient les informations d'identification numériques qu'un utilisateur utilise pour signer un document ou des données.
Restreindre la signature au serveur d'URL spécifié
Oblige Acrobat à rechercher les informations d'identification sur le serveur spécifié. Si cette option n'est pas sélectionnée, le serveur est uniquement suggéré ; par conséquent, Acrobat peut rechercher les informations d'identification sur d'autres services Web.
Voir aussi
Utilisation de champs de signature de document
Aperçu du bouton Envoyer par messagerie
Aperçu du bouton Envoyer via HTTP
A propos de l'envoi de données au moyen d'un bouton
Pour ajouter un champ de signature du document
Pour ajouter une signature de données à un bouton d'envoi


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Paramètres de signature du document > Panneau Gestionnaire de signatures (boîte de dialogue Paramètres de signature du document/Signature des données et paramètres d'envoi)

Panneau Gestionnaire de signatures (boîte de dialogue Paramètres de signature du document/Signature des données et paramètres d'envoi)

Utilisez ce panneau pour définir un gestionnaire de signatures facultatif pour une signature de document ou une signature de données associée à un bouton d'envoi. Un gestionnaire de signatures est module logiciel qui implémente le processus de chiffrement à clé publique et contrôle l'accès au document et aux données cryptés. Voici quelques exemples de gestionnaires de protection qui prennent en charge le chiffrement à clé publique : Adobe.PPKLite, Adobe.PubSec et Entrust.PPKEF.
Pour afficher ce panneau, effectuez une des actions suivantes :
      •
      Sélectionnez un champ de signature du document, cliquez sur le panneau Signature du document de la palette Objet, cliquez sur Paramètres, puis sur l'onglet Gestionnaire de signatures.
      •
      Sélectionnez un bouton d'envoi, cliquez sur l'onglet Envoyer de la palette Objet, assurez-vous que l'option Signature de l'envoi est activée, cliquez sur Paramètres, puis sur le panneau Gestionnaire de signatures.
      •
      Sélectionnez un bouton d'envoi par messagerie pou via HTTP, puis dans la palette Objet, assurez-vous que l'option Signature de l'envoi est activée, cliquez sur Paramètres, puis sur le panneau Gestionnaire de signatures.
Nom
Répertorie les noms des gestionnaires de protection. Vous pouvez entrer un nom dans la zone si le gestionnaire de protection que vous souhaitez utiliser ne se trouve pas dans la liste.
Version
Spécifie le numéro de version minimal du gestionnaire de protection. Vous pouvez entrer un numéro dans la zone plutôt que d'en sélectionner un. Si vous sélectionnez AdobePPKLite comme votre gestionnaire de protection, la version est limitée à 0, 1 et 2, en fonction de la version d'Acrobat ou d'Adobe Reader utilisée pour signer le document.

Version d'Acrobat et d'Adobe Reader.

AdobePPKLite version
4.x et 5.x
0
6.x et 7.x
1
8.x
2
Demander au signataire d'utiliser le gestionnaire de signatures spécifié
Oblige Acrobat à utiliser le gestionnaire de protection spécifié pour créer et valider la signature numérique. Si cette option n'est pas sélectionnée, le gestionnaire de protection est uniquement suggéré ; par conséquent, Acrobat peut utiliser le gestionnaire de protection de son choix.
Voir aussi
Utilisation de champs de signature de document
Aperçu du bouton Envoyer par messagerie
Aperçu du bouton Envoyer via HTTP
A propos de l'envoi de données au moyen d'un bouton
Pour ajouter un champ de signature du document
Pour ajouter une signature de données à un bouton d'envoi


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Paramètres de signature du document > Panneau Infos sur la signature (boîte de dialogue Paramètres de signature du document/Signature des données et paramètres d'envoi)

Panneau Infos sur la signature (boîte de dialogue Paramètres de signature du document/Signature des données et paramètres d'envoi)

Utilisez ce panneau pour spécifier une liste de révocation des certificats ou une réponse OCSP (Online Certificate Status Protocol), ainsi que pour spécifier un serveur de tampons temporels.
Pour afficher ce panneau, effectuez une des actions suivantes :
      •
      Sélectionnez un champ de signature du document, cliquez sur le panneau Signature du document de la palette Objet, cliquez sur Paramètres, puis sur l'onglet Infos sur la signature.
      •
      Sélectionnez un bouton d'envoi, cliquez sur l'onglet Envoyer de la palette Objet, assurez-vous que l'option Signature de l'envoi est activée, cliquez sur Paramètres, puis sur le panneau Infos sur la signature.
      •
      Sélectionnez un bouton d'envoi par messagerie pou via HTTP, puis dans la palette Objet, assurez-vous que l'option Signature de l'envoi est activée, cliquez sur Paramètres, puis sur le panneau Infos sur la signature.
Inclure la liste CRL ou la réponse OCSP lors de la signature
Inclut la liste CRL ou la réponse OCSP dans la signature lorsque le document et les données sont signés. La personne qui appose la signature doit avoir accès à Internet pour récupérer la liste de révocation des certificats ou la réponse OCSP du serveur approprié.
    • Obligatoire
L'inclusion de la liste de révocation des certificats ou de la réponse OCSP est obligatoire.
    • Facultatif
L'inclusion de la liste de révocation des certificats ou de la réponse OCSP est facultative.
URL du serveur de tampons temporels
Cette option s'affiche uniquement pour les champs de signature du document. Indique l'URL pour le serveur de tampons temporels. Les tampons temporels indiquent la date et l'heure auxquelles un document a été signé. L'utilisation d'un serveur externe pour ajouter un tampon temporel à une signature numérique permet de savoir avec certitude à quel moment le document et les données ont été signés.
Demander au signataire d'utiliser le serveur de tampons temporels spécifié
Cette option s'affiche uniquement pour les champs de signature du document. Oblige Acrobat à ajouter un tampon temporel à une signature numérique lorsque le document ou les données sont signés.
Voir aussi
Utilisation de champs de signature de document
Aperçu du bouton Envoyer par messagerie
Aperçu du bouton Envoyer via HTTP
A propos de l'envoi de données au moyen d'un bouton
Pour ajouter un champ de signature du document
Pour ajouter une signature de données à un bouton d'envoi


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Paramètres de signature du document > Panneau Signature des certificats (boîte de dialogue Paramètres de signature du document/Signature des données et paramètres d'envoi)

Panneau Signature des certificats (boîte de dialogue Paramètres de signature du document/Signature des données et paramètres d'envoi)

Utilisez ce panneau pour spécifier les certificats qui identifient les utilisateurs pouvant signer le document ou les données.
Pour afficher ce panneau, effectuez une des actions suivantes :
      •
      Sélectionnez un champ de signature du document, cliquez sur le panneau Signature du document de la palette Objet, cliquez sur Paramètres, puis sur l'onglet Signature des certificats.
      •
      Sélectionnez un bouton d'envoi, cliquez sur l'onglet Envoyer de la palette Objet, assurez-vous que l'option Signature de l'envoi est activée, cliquez sur Paramètres, puis sur le panneau Signature des certificats.
      •
      Sélectionnez un bouton d'envoi par messagerie pou via HTTP, puis dans la palette Objet, assurez-vous que l'option Signature de l'envoi est activée, cliquez sur Paramètres, puis sur le panneau Signature des certificats.
Ajouter
Ouvre la boîte de dialogue Sélectionner le certificat utilisateur vous permettant de rechercher et d'ajouter des certificats de signature. Un fichier de certificat peut être doté des extensions de nom de fichier suivants : .p7C, .p7b ou .cer.
Supprimer
Supprime les certificats sélectionnés de la liste.
Détail
Ouvre le programme de visualisation des certificats vous permettant de visualiser les informations concernant le certificat sélectionné. Les informations affichées dépendent du système d'exploitation et des certificats installés et délivrés par une autorité de certification.
Restreindre la signature aux personnes associées aux certificats spécifiés
Autorise uniquement les utilisateurs identifiés par les certificats répertoriés de signer le document ou les données.
Voir aussi
Utilisation de champs de signature de document
Aperçu du bouton Envoyer par messagerie
Aperçu du bouton Envoyer via HTTP
A propos de l'envoi de données au moyen d'un bouton
Pour ajouter un champ de signature du document
Pour ajouter une signature de données à un bouton d'envoi


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Paramètres de signature du document > Panneau Motifs de la signature (boîte de dialogue Paramètres de signature du document)

Panneau Motifs de la signature (boîte de dialogue Paramètres de signature du document)

Utilisez ce panneau pour spécifier les motifs des signatures du document.
Sélectionnez un champ de signature du document, cliquez sur le panneau Signature du document de la palette Objet, cliquez sur Paramètres, puis sur le panneau Motifs de la signature.
Motifs de signature
Les motifs invoqués remplacent les motifs par défaut dans Acrobat. L'utilisateur peut sélectionner un des motifs suivants lorsqu'il signe un formulaire.
    • Ajouter
Ajoute un motif de signature à la liste.
    • Supprimer
Supprime les motifs de signature sélectionnés de la liste.
    • Monter
Déplace le motif sélectionné vers le haut de la liste.
    • Descendre
Déplace le motif sélectionné vers le bas de la liste.
    • Tri croissant
Classe la liste dans l'ordre alphabétique, de haut en bas.
    • Tri décroissant
Classe la liste dans l'ordre alphabétique, de bas en haut.
Demander au signataire de sélectionner un motif dans cette liste
Oblige l'utilisateur à sélectionner un motif de la liste lorsqu'il signe le formulaire. Lorsque vous créez une liste de motifs non obligatoires, il est possible que l'utilisateur ne puisse pas afficher les motifs s'il utilise la version 8.0 d'Acrobat ou d'Adobe Reader ou une version ultérieure.
Voir aussi
Utilisation de champs de signature de document
Pour ajouter un champ de signature du document


Boîte de dialogue Propriétés dynamiques

Utilisez cette boîte de dialogue pour lier de manière dynamique les propriétés d'objets de formulaire à des valeurs provenant d'une source de données. De cette manière, vous pouvez remplir de manière dynamique les propriétés d'objets de formulaire (tels que les éléments d'une liste déroulante ou d'une zone de liste) à l'aide de valeurs issues d'une source de données.
Pour afficher cette boîte de dialogue, assurez-vous que les libellés actifs sont activés, sélectionnez la propriété d'objet de formulaire disposant d'une liaison de données dynamique associée, puis cliquez sur l'un des libellés actifs suivants :
      •
      Articles de liste et Spécifier les valeurs dans le cas d'une liste déroulante ou d'une zone de liste
      •
      Légende
      •
      Message du modèle de validation
      •
      Message du script de validation
      •
      Info-bulle
      •
      Texte du lecteur d'écran personnalisé
Connexion aux données
Indique la connexion aux données à utiliser pour la liaison de données dynamique. si vous n'êtes pas connecté à une source de données, Liaison des données par défaut est la seule sélection possible dans la liste Connexion aux données.
A l'instar d'une liaison normale, vous pouvez définir une ou plusieurs liaisons de connexions aux données WSDL.
Eléments
Indique le jeu de noeuds qui servira à remplir les éléments des listes déroulantes ou des zones de liste.
Vous pouvez sélectionner <Aucune> pour effacer la liaison associée à la propriété sélectionnée. Vous avez également la possibilité de saisir directement une chaîne dans la zone au lieu d'en sélectionner une.
Cette option est disponible lorsque vous cliquez sur le libellé actif des options Articles de liste et Spécifier les valeurs des listes déroulantes et des zones de liste. De plus, dans le cas des connexions de données OLE, la zone Eléments n'est pas disponible. Les zones Texte de l'élément et Valeur de l'élément vous permettent de sélectionner les colonnes de la base de données destinées à remplir la liste.
Texte de l'élément
Indique le libellé convivial affiché lors de l'exécution. Les liaisons disponibles dépendent du jeu de noeuds sélectionné dans la zone Eléments.
Vous pouvez sélectionner <Aucune> pour effacer la liaison associée à la propriété sélectionnée. Vous avez également la possibilité de saisir directement une chaîne dans la zone au lieu d'en sélectionner une.
Cette option est disponible lorsque vous cliquez sur le libellé actif des options Articles de liste et Spécifier les valeurs des listes déroulantes et des zones de liste.
Valeur de l'élément
Indique la valeur des données envoyée à la source des données. Les liaisons disponibles dépendent du jeu de noeuds sélectionné dans la zone Eléments. Cette zone est facultative. Si vous la laissez vide, le contenu de l'option Texte de l'élément est transmis à la source des données.
Vous pouvez sélectionner <Aucune> pour effacer la liaison associée à la propriété sélectionnée. Vous avez également la possibilité de saisir directement une chaîne dans la zone au lieu d'en sélectionner une.
Cette option est disponible lorsque vous cliquez sur le libellé actif des options Articles de liste et Spécifier les valeurs des listes déroulantes et des zones de liste.
Liaison
Définit la liaison associée à la propriété sélectionnée. Les liaisons disponibles sont les mêmes que pour la connexion aux données choisie.
Vous pouvez sélectionner <Aucune> pour effacer la liaison associée à la propriété sélectionnée. Vous avez également la possibilité de saisir directement une chaîne dans la zone au lieu d'en sélectionner une.
Cette option est disponible lorsque vous cliquez sur le libellé actif des options Légende, Message du modèle de validation, Message du script de validation, Info-bulles et Texte du lecteur d'écran personnalisé.
Voir aussi
A propos des propriétés dynamiques


Boîte de dialogue Modifier les sauts conditionnels

Utilisez cette boîte de dialogue pour créer des règles de rupture conditionnelle pour les sous-formulaires, les groupes de sous-formulaire, les tableaux, les rangées d'en-tête, les rangées de contenu et les sections. Les sauts conditionnels sont plus souples que les sauts de page traditionnels et permettent de multiples ruptures d'un seul objet.
Pour afficher cette boîte de dialogue, effectuez une des actions suivantes :
      •
      Sélectionnez un objet de sous-formulaire et cliquez sur Modifier dans le panneau Pagination de la palette Objet. Notez que l'objet de sous-formulaire sélectionné doit exister sur la conception du formulaire à l'intérieur d'un objet de sous-formulaire avec enchaînement.
      •
      Sélectionnez un objet de jeu de sous-formulaires et cliquez sur Modifier dans le panneau Pagination de la palette Objet.
      •
      Sélectionnez un objet de tableau et cliquez sur Modifier dans le panneau Pagination de la palette Objet. Notez que l'objet de tableau sélectionné doit exister sur la conception du formulaire à l'intérieur d'un objet de sous-formulaire avec enchaînement.
      •
      Sélectionnez une rangée d'en-tête de tableau et cliquez sur Modifier dans le panneau Pagination de la palette Objet. Notez que le tableau associé à la rangée d'en-tête doit exister sur la conception du formulaire à l'intérieur d'un objet de sous-formulaire avec enchaînement.
      •
      Sélectionnez une rangée de contenu de tableau et cliquez sur Modifier dans le panneau Pagination de la palette Objet. Notez que le tableau associé à la rangée de contenu doit exister sur la conception du formulaire à l'intérieur d'un objet de sous-formulaire avec enchaînement.
      •
      Sélectionnez une rangée de pied de page de tableau et cliquez sur Modifier dans le panneau Pagination de la palette Objet. Notez que le tableau associé à la rangée de pied de page doit exister sur la conception du formulaire à l'intérieur d'un objet de sous-formulaire avec enchaînement.
      •
      Sélectionnez une section de tableau et cliquez sur Modifier dans le panneau Pagination de la palette Objet. Notez que la section de tableau sélectionnée doit exister sur la conception du formulaire à l'intérieur d'un objet de sous-formulaire avec enchaînement.
Ajouter
Ajoute une nouvelle condition de saut pour l'objet actif. Au cas où un saut conditionnel est déjà sélectionné, une nouvelle entrée est créée avant l'entrée sélectionnée.
Supprimer
Supprime la condition de saut actuellement sélectionnée pour l'objet.
Monter
Déplace vers le haut de la liste le saut conditionnel sélectionné.
Descendre
Déplace vers le bas de la liste le saut conditionnel sélectionné.
Moment
Spécifie une expression stipulant à quel moment un saut conditionnel doit se produire.
Cliquez sur le bouton Insérer une expression exemple [image] pour sélectionner un objet valide à utiliser comme condition de saut. LiveCycle Designer insère une expression exemple qui force un saut de page conditionnel si elle s'avère vraie.
Le bouton Insérer une expression exemple s'affiche en grisé si aucun objet valide n'est présent sur la conception de formulaire.
Langage
Spécifie le langage de script à utiliser pour le calcul ou le script actuel. Vous disposez de deux options :
    • FormCalc
Langage machine Adobe natif, idéal pour des scripts courts.
    • JavaScript
Langage de script puissant et flexible, idéal pour les scripts plus complexes.
Exécuter sur
Indique l'emplacement où le calcul ou le script doit être exécuté. Vous disposez de trois options :
    • Client
Les calculs et scripts sont exécutés pendant que l'application client (par exemple, Acrobat ou un navigateur Web) traite le formulaire.
    • Serveur
Les calculs et scripts sont exécutés pendant que l'application serveur (par exemple, LiveCycle Forms) traite le formulaire.
    • Client et serveur
Les calculs et scripts sont exécutés lors du traitement par l'application client ou serveur, selon l'application qui traite le formulaire.
Saut
Indique où le saut conditionnel doit se produire :
    • Avant
Immédiatement avant le sous-formulaire, jeu de sous-formulaires, tableau, rangée d'en-tête, rangée de pied de page ou section en cours.
    • Après
Immédiatement après le sous-formulaire, jeu de sous-formulaires, tableau, rangée d'en-tête, rangée de pied de page ou section en cours.
A
Détermine où placer les champs et données restants du sous-formulaire après le saut conditionnel :
    • Zone de contenu > [nom_de_la_zone_de_contenu]
Reprend dans la zone de contenu indiquée.
    • Haut de la zone de contenu suivante
Reprend en haut de la zone de contenu suivante.
    • Haut de la zone de contenu > [nom_de_la_zone_de_contenu]
Reprend en haut de la zone de contenu indiquée.
    • Page > [nom_de_la_page]
Reprend à la page spécifiée (insère un saut de page si la page spécifiée n'est pas la page active).
    • Haut de la page suivante
Reprend en haut de la page suivante (insère un saut de page).
    • Haut de la page > [nom_de_la_page]
Reprend en haut de la page chaque fois que la page indiquée est générée (inclut un saut de page s'il n'est pas inséré automatiquement).
    • Sans saut, avec caractère de début et de fin
Place l'objet après le sous-formulaire, jeu de sous-formulaires, tableau, rangée d'en-tête, rangée de contenu ou rangée de pied de page précédent. Bascule vers une nouvelle zone de contenu uniquement si le sous-formulaire, le jeu de sous-formulaires, le tableau, la rangée d'en-tête, la rangée de contenu, la rangée de pied de page ou la section ne tient pas dans la zone de contenu actuelle.
Caractère de fin
Indique le sous-formulaire de fin à utiliser pour le saut conditionnel.
    • [nom_du_sous-formulaire/tableau]
Utilise le sous-formulaire, le jeu de sous-formulaires, le tableau, la rangée d'en-tête ou la rangée de contenu comme fin de débordement.
    • Non
Aucune fin de débordement n'est utilisée.
Caractère de début
Indique le sous-formulaire de début à utiliser pour le saut conditionnel.
    • [nom_du_sous-formulaire/tableau]
Utilise le sous-formulaire, le jeu de sous-formulaires, le tableau, la rangée d'en-tête ou la rangée de contenu comme début de débordement.
    • Non
Aucun début de débordement n'est utilisé.
Voir aussi
Aperçu des sous-formulaires
Aperçu des jeux de sous-formulaires
A propos des tableaux
Pour créer un sous-formulaire qui se répète
Pour gérer des sauts de sous-formulaires et de jeux de sous-formulaires à l'aide d'instructions conditionnelles
Pour contrôler les sauts de section, de rangée de pied de page, de rangée de contenu, de rangée d'en-tête et de tableau à l'aide d'instructions conditionnelles


Boîte de dialogue Modifier les sous-formulaires désignés par les données

Utilisez cette boîte de dialogue pour gérer l'affichage des sous-formulaires à partir d'un jeu de sous-formulaires de choix ou l'affichage des rangées à partir d'une section de choix.
Pour afficher cette boîte de dialogue, effectuez une des actions suivantes :
      •
      Sélectionnez un jeu de sous-formulaires de choix et cliquez sur Modifier les variantes dans le panneau Jeu de sous-formulaires de la palette Objet.
      •
      Sélectionnez une section de choix et cliquez sur Modifier les variantes dans le panneau Section de la palette Objet.
Choisir le sous-formulaire dont le nom correspond à l'élément ou attribut de données
Fait correspondre un seul sous-formulaire du jeu de sous-formulaires de choix, ou une seule rangée de la section de choix, à un noeud de données de même nom provenant de la connexion de données. Seul le sous-formulaire ou la rangée dont le nom correspond à un des noeuds de données apparaît dans le formulaire.
Choisir le sous-formulaire à l'aide de l'expression
Associe un seul sous-formulaire du jeu de sous-formulaires de choix, ou une seule rangée de la section de choix, à un noeud de données défini par l'utilisateur provenant de la connexion de données. Vous pouvez alors utiliser des expressions de script relationnelles, telles que des expressions d'égalité ou d'inégalité dans le champ Expression pour préciser les conditions à remplir pour que le sous-formulaire ou la rangée désigné apparaisse dans le formulaire. La première entrée de la liste Sous-formulaires de remplacement dont l'expression s'avère vraie est affichée dans le formulaire.
Connexion aux données
Indique le nom de la connexion de données active :
    • Liaison des données par défaut
Aucune connexion aux données n'est actuellement spécifiée dans la conception de formulaire.
    • [nom_de_connexion_aux_données]
Nom de la connexion aux données actuellement définie dans la conception de formulaire.
Ajouter
Ajoute un objet de sous-formulaire au jeu de sous-formulaires de choix ou une rangée à la section de choix. Cette opération duplique l'objet de sous-formulaire sélectionné dans la liste Sous-formulaires de remplacement. Si aucun sous-formulaire ou rangée n'est sélectionné, un sous-formulaire sans nom est ajouté au jeu de sous-formulaires de choix ou à la section de choix.
Supprimer
Retire l'objet de sous-formulaire ou l'objet de rangée sélectionné du sous-formulaire de choix actuel ou de la section de choix actuelle.
Monter
Déplace vers le haut l'entrée de la liste Sous-formulaires de remplacement sélectionnée.
Descendre
Déplace vers le bas l'entrée de la liste Sous-formulaires de remplacement sélectionnée.
Nom
Indique le nom d'un objet de sous-formulaire dans le jeu de sous-formulaires de choix ou le nom d'une rangée dans la section de choix.
Liaison
Affiche toutes les options de liaison de données disponibles pour la connexion de données active :
    • [nom_du_noeud_de_données]
Associe le sous-formulaire ou la rangée à cette entrée de noeud de données à partir de la connexion aux données.
    • <Non>
Désactive la liaison des données en utilisant un noeud de données défini par l'utilisateur de la connexion aux données. Le sous-formulaire ou la rangée est toujours associé à un noeud de données de même nom à partir de la connexion aux données, s'il existe.
vous pouvez également saisir directement dans le champ Liaison une liaison définie par l'utilisateur.
Expression
Spécifie une expression de script relationnelle, telle qu'une expression d'égalité ou d'inégalité, pour indiquer les conditions à remplir pour que le sous-formulaire ou la rangée désigné apparaisse dans le formulaire.
En l'absence d'expression, le saut conditionnel est supposé correspondre à la valeur Vrai.
Langage
Spécifie le langage de script à utiliser pour le calcul ou le script actuel. Vous disposez de deux options :
    • FormCalc
Langage machine Adobe natif, idéal pour des scripts courts.
    • JavaScript
Langage de script puissant et flexible, idéal pour les scripts plus complexes.
Voir aussi
Aperçu des sous-formulaires
Aperçu des jeux de sous-formulaires
A propos des tableaux
Propriétés des sections dans le panneau Section


Boîte de dialogue Modifier le dictionnaire

Cette boîte de dialogue permet de passer en revue la liste des mots inclus dans votre dictionnaire personnalisé (Mon dictionnaire personnel) associé à une langue ou à toutes les langues, de modifier l'orthographe des mots répertoriés ainsi que d'ajouter et de supprimer les mots dans une langue donnée ou de toutes les langues.
Pour afficher cette boîte de dialogue, choisissez Outils> Modifier le dictionnaire.
Langage
Dresse la liste de toutes les langues disponibles. La liste des mots associés à chaque langue s'affiche une fois la langue sélectionnée.
Mot
Le mot sélectionné dans la liste des mots s'affiche dans cette zone prévue pour corriger l'orthographe. Vous pouvez également saisir de nouveaux mots à ajouter à Mon dictionnaire personnel.
Ajouter
Insère le nouveau mot saisi dans la zone Mot dans Mon dictionnaire personnel.
Supprimer
Retire le mot sélectionné de la liste des mots associée à la langue désignée.
Terminer
Ferme la boîte de dialogue Modifier le dictionnaire.


Boîte de dialogue Options d'importation de fichier (Microsoft InfoPath et Word)

Utilisez cette boîte de dialogue pour importer des fichiers Microsoft InfoPath et Document Microsoft Word.
Microsoft InfoPath
Utilisez cette boîte de dialogue pour définir les options d'importation des fichiers Microsoft® InfoPath.
Pour afficher cette boîte de dialogue, choisissez Fichier > Ouvrir, puis sélectionnez un fichier InfoPath à ouvrir.
Choisir la vue pendant la conversion
Vous invite à choisir la vue. Si le fichier InfoPath dispose uniquement d'une vue, le message ne s'affiche pas, même si vous sélectionnez cette option.
Affichage
Indique le nom de la vue à convertir. Pour convertir la vue par défaut, laissez la zone vide. Cette option est ignorée si l'option Choisir la vue pendant la conversion est sélectionnée.
Importer les paramètres d'impression
Importe les en-têtes et pieds de page, l'orientation de la page et les marges du formulaire InfoPath. si vous sélectionnez l'option Importer les paramètres d'impression, la taille et l'orientation de la page proviennent du formulaire InfoPath. Dans ce cas, vous n'avez pas besoin de les sélectionner.
Format de page
Détermine la taille de page du formulaire converti. Pour convertir la taille de page par défaut, sélectionnez Par défaut.
Orientation
Détermine l'orientation de page du formulaire converti.
Générer un fichier journal
A moins que l’option Ne pas consigner soit sélectionnée, LiveCycle Designer crée un fichier journal (*.log) portant le nom que vous sélectionnez, à l’emplacement spécifié. Le fichier journal consigne les informations relatives aux processus de conversion et peut être lu à l'aide de n'importe quel éditeur de texte ASCII.
Intégrer les images dans le XPD
Lorsque cette case est cochée, le système convertit les images du fichier InfoPath et les incorpore dans le fichier converti. Sinon, LiveCycle Designer ne convertit pas les images, mais insère à la place des balises d’emplacement.
Voir aussi
Pour importer un fichier Microsoft InfoPath
Conversion des objets Microsoft InfoPath dans LiveCycle Designer
Document Microsoft Word
Utilisez cette boîte de dialogue pour définir les options d'importation des fichiers de document Microsoft Word.
Pour afficher cette boîte de dialogue, choisissez Fichier > Ouvrir, puis sélectionnez un fichier Word à ouvrir.
Mot de passe d'ouverture du fichier
Si le fichier Word est défini de sorte que vous devez entrer un mot de passe pour l'ouvrir, entrez le mot de passe dans cette zone.
Mot de passe de déprotection du fichier
Si le fichier Word est protégé (les utilisateurs peuvent entrer des données uniquement dans des zones désignées) et configuré de sorte que vous devez entrer un mot de passe pour en désactiver la protection, entrez le mot de passe dans cette zone.
Ignorer les polices manquantes
LiveCycle Designer détecte si le fichier Word contient des polices qui ne sont pas installées sur l’ordinateur. Pour résoudre ce problème, vous pouvez soit installer les polices manquantes, soit définir des règles appropriées de substitution des polices dans Word. Lorsque cette option est sélectionnée, LiveCycle Designer remplace les polices manquantes par des polices disponibles et tous les messages relatifs à la substitution des polices sont supprimés.
Convertir les images
Lorsqu'elle est sélectionnée, cette option convertit les images et les incorpore dans le formulaire converti. Sinon, LiveCycle Designer ne convertit pas les images, mais insère à la place des balises d’emplacement.
Conserver la disposition fluide (distribution des objets et du texte plutôt que leur positionnement)
Lorsque cette option est sélectionnée, LiveCycle Designer vérifie que la disposition est fluide.
Générer le fichier journal
A moins que l’option Ne pas consigner soit sélectionnée, LiveCycle Designer crée un fichier journal (*.log) à l’emplacement spécifié. Le fichier journal consigne les informations relatives aux processus de conversion et peut être lu à l'aide de n'importe quel éditeur de texte ASCII. Son nom est basé sur le nom du fichier de formulaire.
Voir aussi
Pour importer un fichier Microsoft Word
Conversion des paramètres et des objets Word dans LiveCycle Designer
Limitation des problèmes de conversion des fichiers Word


Boîte de dialogue Propriétés du formulaire

Panneau Compatibilité (boîte de dialogue Propriétés du formulaire)
Panneau Valeurs par défaut (boîte de dialogue Propriétés du formulaire)
Panneau Infos (boîte de dialogue Propriétés du formulaire)
Panneau Sécurité PDF (boîte de dialogue Propriétés du formulaire)
Panneau Performances (boîte de dialogue Propriétés du formulaire)
Panneau Variables (boîte de dialogue Propriétés du formulaire)


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Propriétés du formulaire > Panneau Compatibilité (boîte de dialogue Propriétés du formulaire)

Panneau Compatibilité (boîte de dialogue Propriétés du formulaire)

Utilisez cette boîte de dialogue pour mettre à jour les formulaires créés dans les versions 6 à 7 de LiveCycle Designer. La mise à jour de formulaires plus anciens va entraîner le déplacement du texte. Vous allez peut-être devoir ensuite l'ajuster manuellement. En outre, cela a une incidence sur le traitement des événements enter et exit des listes déroulantes à l'aide de scripts. Si le formulaire le plus ancien doit être visualisé à l'aide d'Acrobat 7.0 ou de la version 7.0 ou ultérieure d'Adobe Reader, utilisez ce panneau Compatibilité pour mettre à jour le formulaire en fonction de la version 7.
Pour afficher cette boîte de dialogue, choisissez Fichier > Propriétés du formulaire, puis cliquez sur Compatibilité. Si le formulaire a été créé avec la version 6, vous obtiendrez les boutons à utiliser pour la mise à jour en fonction de la version 7.
Annuler le formatage de texte ou mettre à jour le formatage de texte
Si vous ouvrez un formulaire dont la version est antérieure à celle de LiveCycle Designer, les règles de formatage du texte sont différentes.
Pour utiliser les règles de formatage de texte actuelles, cliquez sur Mettre à jour le formatage de texte. La mise à jour de formulaires plus anciens va entraîner le déplacement du texte. Vous allez peut-être devoir ensuite l'ajuster manuellement.
Pour utiliser les règles de formatage de texte de la version 6, cliquez sur Annuler le formatage de texte.
Version précédente du modèle d'événement ou Mettre à jour le modèle d'événement
Si vous ouvrez un formulaire en utilisant une version antérieure de LiveCycle Designer, les événements enter n'auront pas le même effet dans le formulaire. Dans la version 7, lorsqu'un utilisateur clique pour la première fois sur une liste déroulante, un événement enter est envoyé avec la propriété reenter définie sur false (faux). Si l'utilisateur clique de nouveau sur le champ ou appuie sur la touche Entrée, un autre événement enter est envoyé avec la propriété reenter définie sur true (vrai).
Pour utiliser les règles de traitement des événements actuelles, cliquez sur Mettre à jour le modèle d'événement. Si vous souhaitez que l'événement enter se produise chaque fois qu'un utilisateur clique sur une liste déroulante, mettez à jour le modèle d'événement.
Pour utiliser la version 6 des règles de traitement des événements, cliquez sur Version précédente du modèle d'événement. Par exemple, si votre formulaire a été créé avec la version 6 de LiveCycle Designer et que vous voulez télécharger des données du serveur une seule fois à l'aide du premier événement enter, vous pouvez conserver l'ancien modèle d'événement ou revenir à la version précédente du modèle.


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Propriétés du formulaire > Panneau Valeurs par défaut (boîte de dialogue Propriétés du formulaire)

Panneau Valeurs par défaut (boîte de dialogue Propriétés du formulaire)

Utilisez cette boîte de dialogue pour définir les paramètres standard qui sont ensuite appliqués par LiveCycle Designer pour chaque conception de formulaire. Au besoin, vous pouvez ensuite remplacer ces paramètres à l’ouverture d’une conception de formulaire particulière.
Pour afficher cette boîte de dialogue, choisissez Fichier > Propriétés du formulaire, puis cliquez sur Valeurs par défaut.
Paramètre régional par défaut du formulaire
Détermine la langue par défaut de la conception de formulaire ainsi que le format de la date, de l'heure, des nombres et de la devise d'un pays donné. Il définit également la langue utilisée pour la fonction de vérification orthographique.
Langage par défaut
Spécifie le langage de script par défaut à utiliser lors de la création d’une conception de formulaire. Vous pouvez choisir entre JavaScript et FormCalc.
Exécution par défaut sur le
Indique l’emplacement par défaut d’exécution des scripts associés au modèle. Les options disponibles sont les suivantes :
    • Client
Indique que les scripts doivent être exécutés sur le client. Il s'agit de l'option par défaut.
    • Serveur
Indique que les scripts doivent être exécutés sur le serveur. Les résultats sont ensuite retournés au navigateur.
    • Client et serveur
Indique que les scripts peuvent être exécutés sur le client et sur le serveur.
Type d'aperçu
Indique le type de formulaire à prévisualiser lorsque vous utilisez le panneau Aperçu PDF :
    • Formulaire interactif
Sélectionnez cette option pour afficher un formulaire qui comporte des champs de saisie de données interactives. Lorsque vous affichez l'aperçu d'une conception de formulaire, le formulaire résultant s'ouvre comme un PDF interactif.
Générer les données d'aperçu
Sélectionnez cette option pour générer des données d'exemple. Lorsque vous prévisualiserez la conception de formulaire, elle sera alors fusionnée avec les données d'exemple. Vous pouvez également indiquer le nombre de répétitions voulu pour un sous-formulaire qui se répète dans la conception de formulaire prévisualisée.
Fichier de données
Indique le fichier de données à utiliser pour afficher l’aperçu d’une conception de formulaire après fusion des données. Le fichier de données doit être au format XML standard. Vous pouvez saisir le chemin d'accès dans la zone Fichier de données ou rechercher le fichier qui vous intéresse.
Format d'aperçu XDP
Indique le format d'aperçu PDF pour les fichiers XDP et TDS. Le format d'aperçu XDP spécifié est également utilisé pour prévisualiser les fichiers non enregistrés lorsque l'option Type de fichier par défaut des nouveaux formulaires (Outils > Options) a pour valeur Formulaire XML Adobe (XDP). Le format d'aperçu XDP n'est pas pris en compte pour les fichiers PDF. Vous pouvez sélectionner l'une des options suivantes :
    • Formulaire PDF (statique) Acrobat 8.0
Définit le format Acrobat 8.0 statique comme format d'aperçu par défaut. La conception de formulaire ne peut contenir que des éléments statiques. Si votre formulaire contient des éléments dynamiques, ceux-ci ne sont pas disponibles. Ainsi, dans un formulaire comportant un tableau avec un nombre fixe de colonnes, mais dont le nombre de rangées varie en fonction du volume d'informations de la source de données, une seule rangée est affichée dans le panneau Aperçu PDF.
    • Formulaire XML (dynamique) Acrobat 8.0
Définit le format Acrobat 8.0 dynamique comme format d'aperçu par défaut. La conception de formulaire peut contenir des éléments dynamiques. Ainsi, dans un formulaire comportant un tableau avec un nombre fixe de colonnes, mais dont le nombre de rangées varie en fonction du volume d'informations de la source de données, toutes les rangées de données sont affichées dans le panneau Aperçu PDF.
    • Formulaire PDF (statique) Acrobat 7.0
Définit le format compatible Acrobat 7.0 statique comme format d'aperçu par défaut. La conception de formulaire ne peut contenir que des éléments statiques. Par exemple, si votre formulaire comporte 10 rangées de données, et que la quantité de données est suffisante pour renseigner 25 rangées, seules 10 rangées peuvent être complétées. De même, si la quantité de données est suffisante pour compléter 2 rangées, vous obtiendrez 10 rangées. Dans ce cas, 2 rangées seront complétées et les 8 autres seront vides.
    • Formulaire XML (dynamique) Acrobat 7
Définit le format compatible Acrobat 7.0 dynamique comme format d'aperçu par défaut. La conception de formulaire peut contenir des éléments dynamiques. Par exemple, la conception de formulaire peut être un formulaire interactif qui permet aux utilisateurs d'ajouter ou de supprimer des rangées d'éléments.
    • PDF (statique) compatible Acrobat 6.0
Définit le format compatible Acrobat 6 statique comme format d'aperçu par défaut. Utilisez cette option si les utilisateurs ne disposent que de la version 6.0 d'Acrobat. La conception de formulaire ne peut contenir que des éléments statiques. Elle ne peut pas contenir des codes à barres de formulaires pour support papier.
Remplacer le rendu par défaut
Sélectionnez cette option pour indiquer à LiveCycle Forms comment un formulaire XDP doit être généré.
Format de rendu PDF
Si l'option Remplacer le rendu par défaut est sélectionnée, indique le format PDF que LiveCycle Forms 7.1 doit utiliser pour générer un formulaire XDP si le comportement par défaut est défini pour LiveCycle Forms 7.1. Pour plus de détails, voir le document LiveCycle Forms intitulé Développement d’applications personnalisées. Vous pouvez sélectionner l'une des options suivantes : Formulaire PDF (statique) Acrobat 8.0, Formulaire PDF (dynamique) Acrobat 8.0, Formulaire PDF (statique) Acrobat 7.0,Formulaire XML (dynamique) Acrobat 7.0 ou Formulaire PDF (statique) Acrobat 6.0.
Voir aussi
Pour prévisualiser et tester les formulaires dans le panneau Aperçu PDF
Pour définir les options d'aperçu d'un formulaire interactif


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Propriétés du formulaire > Panneau Infos (boîte de dialogue Propriétés du formulaire)

Panneau Infos (boîte de dialogue Propriétés du formulaire)

Utilisez cette boîte de dialogue pour obtenir des informations générales sur la conception de formulaire et les afficher. L'option Fichier, par exemple, affiche le nom du fichier et le chemin d'accès à la conception du formulaire.
Si vous travaillez sur un document PDF contenant une illustration PDF, le contenu du panneau Infos est affiché en lecture seule et ne peut être modifié qu'avec Adobe Acrobat.
Pour afficher cette boîte de dialogue, choisissez Fichier > Propriétés du formulaire, puis cliquez sur Infos.
Fichier
Indique le nom du fichier, y compris le chemin d'accès. Le système crée le nom au moment de l'enregistrement de la conception de formulaire.
Titre
Indique le nom de la conception de formulaire.
Description
Donne une description de la conception de formulaire.
Auteur
Indique le créateur de la conception de formulaire.
Contact
Mentionne un autre contact.
Department
Indique le service qui, dans votre entreprise, est propriétaire de la conception de formulaire.
Date de création
Indique la date à laquelle la conception de formulaire a été créée.
Version
Indique la version actuelle de la conception de formulaire.
Date de la version
Indique la date de la version actuelle de la conception de formulaire.
Voir aussi
Pour ajouter des détails au sujet du formulaire


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Propriétés du formulaire > Panneau Sécurité PDF (boîte de dialogue Propriétés du formulaire)

Panneau Sécurité PDF (boîte de dialogue Propriétés du formulaire)

Utilisez cette boîte de dialogue pour limiter l'accès au formulaire PDF. Pour cela, il suffit de spécifier des mots de passe et de restreindre certaines fonctions comme l’impression et la modification du formulaire PDF.
Pour afficher cette boîte de dialogue, choisissez Fichier > Propriétés du formulaire, puis cliquez sur Sécurité PDF.
Exiger un mot de passe pour l'ouverture du document
Indique que le formulaire PDF invite l’utilisateur à fournir un mot de passe avant d’autoriser son ouverture. Le système vous invite à définir le mot de passe lorsque vous enregistrez la conception du formulaire au format PDF.
Effacer les mots de passe
Supprime les mots de passe obligatoires pour l’ouverture du formulaire PDF, ainsi que pour l’impression et la modification du document. Le système vous invite à définir le mot de passe lorsque vous enregistrez la conception du formulaire au format PDF.
Utiliser un mot de passe pour restreindre l’impression et la modification du document et de ses paramètres de protection
Indique que l’utilisateur final doit fournir le bon mot de passe pour imprimer et modifier le formulaire PDF. Le système vous invite à définir le mot de passe lorsque vous enregistrez la conception du formulaire au format PDF.
Impression autorisée
Indique si l’utilisateur peut imprimer le formulaire. Si vous voulez autoriser l’impression, sélectionnez la résolution d’impression dans la liste. Voici les options :
      •
      Basse résolution (150 dpi)
      •
      Haute résolution
Modifications autorisées
Indique si l’utilisateur peut apporter des changements au formulaire PDF. Si vous voulez autoriser les changements, sélectionnez le type de changement que l’utilisateur sera autorisé à faire. Voici les options :
      •
      Insérer, supprimer et faire pivoter des pages
      •
      Remplir et signer un formulaire
      •
      Commenter, remplir et signer un formulaire
      •
      Tout sauf extraire des pages
Autoriser la copie de texte, d’images et d’autre contenu
Indique que l’utilisateur peut copier du texte, des images et d’autres types de contenus.
Activer l'accès au texte pour les lecteurs d'écran destinés aux malvoyants
Indique que l’utilisateur peut accéder au document à l’aide d’un lecteur d’écran.
Autoriser les métadonnées en texte brut
Indique que les informations saisies dans le panneau Infos seront enregistrées avec le formulaire PDF.
Voir aussi
A propos des formulaires sécurisés
A propos des options de protection PDF


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Propriétés du formulaire > Panneau Performances (boîte de dialogue Propriétés du formulaire)

Panneau Performances (boîte de dialogue Propriétés du formulaire)

Utilisez cette boîte de dialogue pour définir les propriétés du serveur et de mise en cache d'impression pour une conception de formulaire. Les options de mise en cache d'impression améliorent les performances et le traitement côté serveur de l'impression spécifiée. Toutefois, la sélection de ces options peut augmenter la taille de fichier des conceptions de formulaire et nuire aux performances côté client. La sélection de plusieurs options d'impression augmente considérablement la taille de fichier d'une conception de formulaire.
Pour afficher cette boîte de dialogue, choisissez Fichier > Propriétés du formulaire, puis cliquez sur Performances.
Autoriser la mise en cache du rendu sur le serveur
Met en cache un formulaire PDF statique entier sur le serveur et le réutilise pour les rendus de formulaire ultérieurs. Sélectionnez cette option uniquement pour les formulaires avec une disposition fixe.
Le formulaire requiert la liaison des données et/ou l'écriture de script sur le serveur
Donne l'instruction au serveur de fusionner la conception de formulaire avec les données. Sélectionnez cette option uniquement lorsque la conception de formulaire inclut une liaison de base de données, une liaison de service Web ou un script côté serveur.
Ne la sélectionnez pas si un formulaire n'a pas de liaison de données ou de script côté serveur, car les performances seraient amoindries.
Mettre en cache la sortie PostScript dans le formulaire
Intègre une copie de la conception de formulaire au format PostScript® à l'intérieur de la conception de formulaire. La copie est incorporée lors de l'enregistrement de la conception de formulaire.
Mettre en cache la sortie noir et blanc PCL dans le formulaire
Intègre une copie de la conception de formulaire au format noir et blanc PCL à l'intérieur de la conception de formulaire. La copie est incorporée lors de l'enregistrement de la conception de formulaire.
Mettre en cache la sortie PCL couleur dans le formulaire
Intègre une copie de la conception de formulaire au format couleur PCL à l'intérieur de la conception de formulaire. La copie est incorporée lors de l'enregistrement de la conception de formulaire.
Mettre en cache la sortie sur l'imprimante Zebra Label à 200 ppp dans le formulaire
Intègre une copie de la conception de formulaire en Zebra à 200 ppp à l'intérieur de la conception de formulaire. La copie est incorporée lors de l'enregistrement de la conception de formulaire.
Mettre en cache la sortie sur l'imprimante Zebra Label à 300 ppp dans le formulaire
Intègre une copie de la conception de formulaire en Zebra à 300 ppp à l'intérieur de la conception de formulaire. La copie est incorporée lors de l'enregistrement de la conception de formulaire.


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Propriétés du formulaire > Panneau Variables (boîte de dialogue Propriétés du formulaire)

Panneau Variables (boîte de dialogue Propriétés du formulaire)

Utilisez cette boîte de dialogue pour spécifier des variables basées sur la conception de formulaire. Les variables sont enregistrées avec la conception de formulaire active.
Pour afficher cette boîte de dialogue, choisissez Fichier > Propriétés du formulaire, puis cliquez sur Variables.
Variables
Affiche toutes les variables contenues dans la conception de formulaire active.
Ajouter
Cliquez sur ce bouton pour définir une nouvelle variable. Vous devez indiquer un nom dans la liste Variables et la valeur correspondante dans la grande zone de texte, du côté droit.
Chaque variable d'une conception de formulaire doit porter un nom unique. Dans les noms de variable, le système fait la distinction entre les lettres majuscules et les lettres minuscules.
Un nom de variable ne doit pas contenir d'espace. Dès que vous appuyez sur la barre d’espacement, LiveCycle Designer place automatiquement le curseur dans la grande zone de texte, du côté droit.
Si une variable est dépourvue de valeur, LiveCycle Designer ne l'enregistre pas avec la conception de formulaire à la fermeture de la session en cours.
Supprimer
Cliquez sur ce bouton pour supprimer la variable sélectionnée parmi la liste des variables.
Voir aussi
Variables


Boîte de dialogue Options d'importation

Utilisez cette boîte de dialogue pour définir les options d’importation des fichiers PDF qui n’ont pas été créés dans LiveCycle Designer.
Pour afficher cette boîte de dialogue, choisissez Fichier > Ouvrir, sélectionnez un fichier PDF et cliquez sur Ouvrir. Si l'assistant de création de formulaires apparaît, cliquez sur le lien Ne pas utiliser l'assistant.
Créer un formulaire interactif avec des pages fixes
Préserve l’aspect des documents PDF créés dans Acrobat et dans d'autres applications disponibles dans la boîte de dialogue Ouvrir. Convertit les champs de formulaire Acrobat en objets de bibliothèque LiveCycle Designer correspondants. Après avoir importé le contenu d'un document PDF en tant qu'illustration, vous pouvez placer des objets de bibliothèque supplémentaires au-dessus de l'illustration, si nécessaire. Servez-vous de cette option si vous possédez un document PDF généré dans Acrobat ou dans une autre application à utiliser comme base (arrière-plan) du formulaire interactif avec pages fixes que vous voulez créer avec LiveCycle Designer.
Créer un formulaire interactif avec une disposition souple
Importe des documents PDF de sorte que le contenu puisse être modifié dans LiveCycle Designer. Toute pièce jointe ou annotation est supprimée. Conserver du texte ensemble dans moins d'objets Servez-vous de cette option pour créer un formulaire interactif dont la disposition est susceptible d'être enchaînée, apporter des modifications importantes au texte du formulaire PDF ou utiliser LiveCycle Designer afin d'effectuer des mises à jour régulières du formulaire. Cette option est compatible avec la fonction de retour à la ligne, mais les sauts de ligne risquent de ne pas être préservés. Quelques retouches seront sans doute nécessaires pour rétablir l'aspect du document d'origine.
Options d'autorisation de modification
Propose diverses options pour l'importation du texte :
    • Placer le contenu dans
Indique l’emplacement du contenu dans la conception de formulaire, une page ou un gabarit.
    • Joindre le texte au format
Indique la façon dont le texte est converti en objets.
    • Tolérance pour la jonction de texte
Une valeur de tolérance élevée est plus souple et permettra de joindre davantage d'éléments de texte en un objet. Une valeur élevée risque également de combiner des fragments de texte censés devenir des objets distincts. Une valeur faible conservera plus d'éléments de texte en tant qu'objets distincts.
    • Tolérance pour la jonction de lignes
Une valeur de tolérance élevée est plus souple et permettra de joindre davantage de lignes de texte en un objet. Une valeur élevée risque également de combiner des lignes de texte censées devenir des objets distincts. Une valeur faible conservera plus de texte en tant que lignes distinctes.
    • Tolérance pour la jonction de paragraphes
Une valeur de tolérance élevée est plus souple et permettra de réunir davantage de paragraphes. Une valeur élevée risque également de combiner des paragraphes qui devaient rester distincts. Une valeur faible conservera plus de paragraphes en tant qu'objets distincts, mais elle risque également de ne pas combiner des sections de texte qui devraient être réunies en un seul paragraphe.
Incorporer les images
Convertit les images du fichier PDF et les intègre au formulaire converti. Vous pouvez choisir l'un des formats compatibles. Sinon, LiveCycle Designer ne convertit pas les images, mais insère à la place des balises d’emplacement.
Format
Répertorie les formats de fichier image que vous pouvez sélectionner.
Générer un fichier journal dans le dossier temporaire
Crée un fichier journal (*.log) portant le nom du fichier PDF, auquel s'ajoute l'extension .log. Le fichier journal est conservé dans votre répertoire temporaire configuré par Windows (il s'agit en général de Documents and Settings\[nom_utilisateur]\Local Settings\Temp). S'il existe un fichier de même nom dans le dossier temporaire, il est remplacé. Le fichier journal consigne les informations relatives aux processus de conversion et peut être lu à l'aide de n'importe quel éditeur de texte ASCII.
Afficher un rapport récapitulant les problèmes de conversion rencontrés
En cas de problèmes de conversion, le système en fait état dans une boîte de dialogue avant que le processus de conversion ne se termine. Vous pouvez annuler le processus, le cas échéant.
Options d'étendue
Fournit les options permettant d'indiquer le nombre de pages à importer.
Tout
Importe toutes les pages dans le fichier PDF.
Pages
Importe une page en particulier ou une série de pages. Par exemple, entrez 2,3,6 pour des pages spécifiques ou 2-5 pour un groupe de pages consécutives. Vous pouvez associer des pages distinctes et des séries de pages : 1,3,6-9.
Voir aussi
Pour importer des fichiers PDF
Conversion des objets PDF dans LiveCycle Designer
Limitation des problèmes de conversion des fichiers PDF
Importation de documents PDF en tant qu'illustrations


Boîte de dialogue Insérer un tableau

Utilisez cette boîte de dialogue pour créer un tableau simple ou créer un tableau à l'aide de l'assistant de création de tableaux.
Pour afficher cette boîte de dialogue, choisissez Insertion > Standard > Tableau, ou faites glisser l'objet Tableau standard de la catégorie Standard de la palette Bibliothèque vers l'éditeur de disposition. Vous pouvez également ouvrir la boîte de dialogue Insérer un tableau en choisissant Tableau > Insérer un tableau.
Créer un tableau simple
Crée un tableau simple en utilisant les options sélectionnées.
Colonnes
Ajoute le nombre de colonnes spécifié au tableau simple.
Rangées de contenu
Ajoute le nombre de rangées de contenu spécifié au tableau simple.
Inclure la rangée d'en-tête dans le tableau
Ajoute une rangée d'en-tête au tableau simple.
Inclure la rangée de pied de page dans le tableau
Ajoute une rangée de pied de page au tableau simple.
Créer un tableau à l'aide de l'assistant
Démarre l'assistant de création de tableaux, qui permet de créer un tableau simple ou un tableau prévu pour s'adapter au nombre de rangées de données.
Ne plus afficher
Empêche l'affichage de la boîte de dialogue Insérer un tableau lorsque vous choisissez Insertion > Standard > Tableau ou lorsque vous faites glisser un objet de tableau sur l'éditeur de disposition. Pour afficher à nouveau cette boîte de dialogue, choisissez Outils > Options > Assistants et conseils > Afficher à la création de tableaux.
Voir aussi
Disposition du contenu (boîte de dialogue Assistant de création de tableaux)
Pour créer un tableau à l'aide de l'assistant
Pour créer un tableau simple


Boîte de dialogue Raccourcis clavier

Utilisez cette boîte de dialogue pour créer et gérer des raccourcis clavier pour les commandes de LiveCycle Designer.
Pour afficher cette boîte de dialogue, choisissez Outils> Raccourcis clavier.
Définir
Répertorie les jeux de raccourcis clavier définis par l'utilisateur et le jeu par défaut. Vous pouvez utiliser, modifier, enregistrer ou supprimer ces jeux. Dès que des changements sont apportés au jeu sélectionné, la mention (Modifié) est ajoutée au nom du jeu.
Enregistrer sous
Ouvre la boîte de dialogue Enregistrer sous, qui permet de nommer et d'enregistrer le jeu de raccourcis clavier sélectionné. En cas de besoin, vous pouvez renommer un jeu modifié. En revanche, vous ne pouvez pas remplacer le jeu de raccourcis clavier par défaut.
Supprimer
Supprime le jeu de raccourcis clavier sélectionné. Vous ne pouvez pas supprimer le jeu de raccourcis clavier par défaut.
Zone du produit
Répertorie les zones du produit (y compris les menus et les palettes) pour lesquelles vous pouvez créer un ou plusieurs raccourcis clavier personnalisés.
Commandes
Affiche toutes les commandes disponibles lorsque l'option Toutes les commandes est sélectionnée dans la liste Zone du produit, mais uniquement les commandes concernées lorsqu'un menu ou une palette spécifique est sélectionné. Les commandes sont classées par zone du produit (Fichier, Edition, Affichage et Palettes).
Raccourcis actuels
Répertorie les raccourcis clavier affectés à la commande sélectionnée dans la liste Commandes.
Supprimer
Retire le raccourci clavier de la liste Raccourcis actuels. Cette option n'est pas disponible lorsque la commande sélectionnée dans la liste Commandes n'est pas associée à un raccourci clavier.
Nouveau raccourci
Zone dans laquelle vous tapez le nouveau raccourci clavier à associer à la commande sélectionnée.
Attribuer
Affecte le nouveau raccourci clavier à la commande sélectionnée.
Description
Propose une brève description de la commande sélectionnée.
Voir aussi
Personnalisation des raccourcis clavier


Boîte de dialogue Polices manquantes

Utilisez cette boîte de dialogue pour sélectionner une police de substitution pour les polices non disponibles sur l'ordinateur. Une fois que vous avez sélectionné les polices de substitution ou accepté la valeur par défaut, le document s’affiche avec ces polices.
Cette boîte de dialogue s’affiche lorsque vous ouvrez un formulaire contenant des polices qui ne sont pas installées sur votre ordinateur.
Substitution de polices
Toutes les polices manquantes sont répertoriées.
Changer de police de substitution
Si vous ne souhaitez pas utiliser la police proposée par défaut, cliquez sur ce bouton pour en sélectionner une autre.


Boîte de dialogue Modifier les substitutions de polices

Utilisez cette boîte de dialogue pour confirmer les substitutions proposées ou les modifier. Elle affiche les polices manquantes et les polices de substitution proposées.
Pour afficher cette boîte de dialogue, cliquez sur Outils> Options. Sélectionnez Gestion du document dans la liste située sur la gauche, puis cliquez sur Modifier les substitutions de polices.
Substitution de polices
Chaque police manquante est affichée avec la police de substitution proposée.
Changer de police de substitution
Si la police de substitution proposée ne vous convient pas, cliquez sur ce bouton pour en sélectionner une autre.


Boîte de dialogue Nouvelle connexion aux données

Nouvelle connexion aux données
Boîte de dialogue Propriétés ADO (Nouvelle connexion aux données)
Connexion OLEDB (boîte de dialogue Nouvelle connexion aux données/Propriétés de la connexion)
Exemple de données XML (Nouvelle connexion aux données/Propriétés de la connexion)
WSDL (boîte de dialogue Nouvelle connexion aux données)
WSDL Sélectionner une opération (boîte de dialogue Nouvelle connexion aux données)
Schéma XML (Nouvelle connexion aux données/Propriétés de la connexion)


Nouvelle connexion aux données

Utilisez cette boîte de dialogue pour définir une connexion entre une source de données et une conception de formulaire.
Pour afficher cette boîte de dialogue, sélectionnez Fichier > Nouvelle connexion aux données.
Nommer la nouvelle connexion
Précise le nom que vous affectez à la connexion aux données.
Récupérer la description des données de
Affiche la liste des sources de données disponibles.
Voir aussi
A propos des sources de données
Pour établir une connexion à un schéma XML et à un fichier de données XML
Pour établir une connexion à une base de données OLE
Pour établir une connexion à un fichier WSDL


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Nouvelle connexion aux données > Boîte de dialogue Propriétés ADO (Nouvelle connexion aux données)

Boîte de dialogue Propriétés ADO (Nouvelle connexion aux données)

Utilisez cette boîte de dialogue pour spécifier les propriétés de la connexion à la base de données et en déterminer les caractéristiques.
Utilisateur
Spécifie l'utilisateur à authentifier lors de la connexion à la base de données.
Mot de passe
Spécifie le mot de passe à authentifier lors de la connexion à la base de données.
Délai de la connexion
Indique le délai maximal pour l'établissement d'une connexion avant de mettre fin à la tentative et de générer une erreur.
Délai de la requête
Indique le délai d'attente maximum pour que la base de données renvoie les résultats d'une requête SQL avant d'interrompre la tentative et de générer une erreur.
Ouverture retardée
Lorsque cette option est sélectionnée, LiveCycle Designer ne se connecte pas automatiquement à la source de données lorsqu’il charge le formulaire. Sélectionnez cette option lorsque le formulaire nécessite une intervention de l'utilisateur avant la tentative de connexion, par exemple lorsque qu'un ID et un mot de passe utilisateur sont obligatoires.
Type de curseur
Indique le type de curseur utilisé à l'ouverture d'un objet Recordset.
Emplacement du curseur
Indique l'emplacement du curseur. Vous pouvez sélectionner un emplacement client ou côté serveur.
Type de verrouillage
Indique le type de verrouillage à utiliser lorsque le formulaire est ouvert.
Action - début de fichier
Indique l'action qui sera exécutée lors de l'activation d'un enregistrement déplacé au-delà du premier enregistrement de début de fichier de la source de données. Par exemple, restez sur l'enregistrement incorrect, retournez au dernier enregistrement correct ou reprenez au début.
Action - fin de fichier
Indique l'action qui sera exécutée lors de l'activation d'un enregistrement déplacé au-delà du dernier enregistrement de fin de fichier de la source de données. Par exemple, restez sur l'enregistrement incorrect, retournez au dernier enregistrement correct ou reprenez au début.
Voir aussi
A propos des sources de données
Pour établir une connexion à une base de données OLE


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Nouvelle connexion aux données > Connexion OLEDB (boîte de dialogue Nouvelle connexion aux données/Propriétés de la connexion)

Connexion OLEDB (boîte de dialogue Nouvelle connexion aux données/Propriétés de la connexion)

Utilisez cette boîte de dialogue pour fournir une description de la connexion de données entre les bases de données OLE et une conception de formulaire.
Pour afficher cette boîte de dialogue, sélectionnez Fichier > Nouvelle connexion aux données. Sélectionnez Base de données OLE, puis cliquez sur Suivant.
Chaîne de la connexion
Indique le nom de la chaîne de la connexion.
Tableau
Précise la table.
Procédure enregistrée
Précise la procédure enregistrée.
Requête SQL
Spécifie la requête SQL.
Voir aussi
A propos des sources de données
Pour établir une connexion à une base de données OLE


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Nouvelle connexion aux données > Exemple de données XML (Nouvelle connexion aux données/Propriétés de la connexion)

Exemple de données XML (Nouvelle connexion aux données/Propriétés de la connexion)

Utilisez cette boîte de dialogue pour fournir une description de la connexion de données entre des données XML d'exemple et une conception de formulaire.
Pour afficher cette boîte de dialogue, sélectionnez Fichier > Nouvelle connexion aux données. Sélectionnez Exemple de données XML et cliquez sur Suivant.
Sélectionner un fichier de données XML d’exemple
Indique l'emplacement et le nom du fichier XML.
Transformer les données d'entrée
Transforme les données d'entrée à l'aide du fichier XSLT que vous avez indiqué.
Fichier XSLT
Indique le fichier XSLT utilisé pour transformer les données d’entrée.
Transformer les données de sortie
Transforme les données de sortie à l'aide du fichier XSLT que vous avez indiqué.
Fichier XSLT
Indique le fichier XSLT utilisé pour transformer les données de sortie.
Voir aussi
A propos des sources de données
Pour établir une connexion à un schéma XML et à un fichier de données XML


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Nouvelle connexion aux données > WSDL (boîte de dialogue Nouvelle connexion aux données)

WSDL (boîte de dialogue Nouvelle connexion aux données)

Utilisez cette boîte de dialogue pour fournir une description de la connexion de données entre WSDL (Web Service Description Language) et une conception de formulaire.
Pour afficher cette boîte de dialogue, sélectionnez Fichier > Nouvelle connexion aux données. Sélectionnez Fichier WSDL et cliquez sur Suivant.
Fichier WSDL
Indique l'emplacement et le nom du fichier WSDL.
Voir aussi
A propos des sources de données
Pour établir une connexion à un fichier WSDL


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Nouvelle connexion aux données > WSDL Sélectionner une opération (boîte de dialogue Nouvelle connexion aux données)

WSDL Sélectionner une opération (boîte de dialogue Nouvelle connexion aux données)

Utilisez cette boîte de dialogue pour sélectionner l'opération WSDL.
Sélectionner une opération
Sélectionnez l'opération que vous voulez utiliser dans le form design.
Voir aussi
A propos des sources de données
Pour établir une connexion à un fichier WSDL


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Nouvelle connexion aux données > Schéma XML (Nouvelle connexion aux données/Propriétés de la connexion)

Schéma XML (Nouvelle connexion aux données/Propriétés de la connexion)

Utilisez cette boîte de dialogue pour fournir une description de la connexion de données entre un schéma XML et une conception de formulaire.
Pour afficher cette boîte de dialogue, sélectionnez Fichier > Nouvelle connexion aux données.
Sélectionner un fichier de schéma XML
Indiquez l'emplacement et le nom du fichier de schéma XML.
Utiliser le nom d'élément racine de données XML
Indique l'élément racine que vous voulez afficher dans la palette Vue des données.
Incorporer le schéma XML
Incorpore le schéma XML dans la form design.
Transformer les données d'entrée
Transforme les données d'entrée à l'aide du fichier XSLT que vous avez indiqué.
Fichier XSLT
Indique le fichier XSLT utilisé pour transformer les données d’entrée.
Transformer les données de sortie
Transforme les données de sortie à l'aide du fichier XSLT que vous avez indiqué.
Fichier XSLT
Indique le fichier XSLT utilisé pour transformer les données de sortie.
Voir aussi
A propos des sources de données
Pour établir une connexion à un schéma XML et à un fichier de données XML


Boîte de dialogue Créer

Utilisez cette boîte de dialogue pour créer un formulaire, créer un formulaire à partir d’un modèle ou ouvrir un formulaire d’exemple existant. Vous pouvez également explorer les modèles de formulaire d’exemple.
Pour afficher cette boîte de dialogue, l'assistant de création de formulaires étant désactivé, sélectionnez Fichier > Nouveau ou cliquez Nouveau formulaire dans l'écran de bienvenue.
Onglet Standard
Affiche les formats de papier offerts pour le nouveau formulaire.
Onglet Exemples
Affiche les conceptions de modèles de formulaire disponibles.
Onglet Personnaliser
Affiche les conceptions de formulaire personnalisées disponibles.
Définir par défaut
Définit la taille par défaut des nouvelles conceptions de formulaire.
Créer
Précise si vous créez un formulaire ou un modèle.
Voir aussi
Pour concevoir un formulaire sans l’assistant de création de formulaires


Boîte de dialogue Ouvrir

Utilisez cette boîte de dialogue pour ouvrir une conception de formulaire existante. Vous pouvez ouvrir des documents de différents formats. Une fois ouverts dans LiveCycle Designer, les documents sont convertis au format de fichier XDP.
Pour afficher cette boîte de dialogue, sélectionnez Fichier > Ouvrir.
Regarder dans
Indiquez l’emplacement dans lequel vous voulez enregistrer un fichier ou un dossier.
Nom du fichier
Affiche le nom du fichier. Le système crée le nom au moment de l’enregistrement du modèle.
Fichiers de type
Dresse la liste des types de fichiers que vous pouvez ouvrir.
Voir aussi
Pour ouvrir des conceptions de formulaires et d'autres fichiers


Boîte de dialogue Options

Texte bidirectionnel (boîte de dialogue Options)
Liaison des données (boîte de dialogue Options)
Gestion du document (boîte de dialogue Options)
Assistants et conseils (boîte de dialogue Options)
Espace de travail (boîte de dialogue Options)
Orthographe (boîte de dialogue Options)
International (boîte de dialogue Options)


Texte bidirectionnel (boîte de dialogue Options)

Cette boîte de dialogue permet de définir un mouvement logique ou visuel pour le curseur au moment de la conception. La valeur par défaut est Logique. Pour afficher cette boîte de dialogue, sélectionnez Outils > Options, puis Texte bidirectionnel dans la liste située à gauche.
Logique
Déplace le point d'insertion dans le texte bidirectionnel en fonction de la direction du texte rencontré. Lorsque, par exemple, vous utilisez les touches fléchées pour déplacer le curseur parmi un texte en arabe et des nombres anglais dans un même libellé, la flèche de droite déplace le curseur de droite à gauche dans le texte en arabe, puis progresse dans les nombres anglais de gauche à droite, en commençant par le caractère le plus à gauche. L'option Logique s'applique aux boîte de dialogue, aux palettes, à l'éditeur de script et à la source XML.
Visuel
Déplace le point d'insertion dans du texte bidirectionnel d'un caractère au caractère visuellement adjacent suivant. Si vous utilisez les touches fléchées, par exemple, pour déplacer le curseur de droite à gauche dans un texte arabe et des nombres anglais qui se trouvent dans le même libellé, la flèche de gauche déplace le curseur de droite à gauche, quel que soit le sens du texte. L'option Visuel change uniquement le mouvement du curseur dans Vue de conception et Pages types. Elle ne s'applique pas aux boîte de dialogue, aux palettes, à l'éditeur de script et à la source XML.
Voir aussi
Pour configurer un objet pour l'arabe et l'hébreu
Pour configurer un objet pour le thaï et le vietnamien


Liaison des données (boîte de dialogue Options)

Cette boîte de dialogue permet d'activer et de désactiver les libellés, de définir la couleur par défaut des libellés actifs ainsi que la liaison par défaut des nouveaux sous-formulaires.
Pour afficher cette boîte de dialogue, sélectionnez Outils > Options, puis sélectionnez Liaison des données dans la liste de gauche.
Afficher les propriétés dynamiques
Active ou désactive les libellés actifs des propriétés dynamiques. Les libellés actifs indiquent les propriétés pouvant devenir dynamiques. Ils sont identifiables par un trait de soulignement vert sur lequel vous pouvez cliquer afin de lier de manière dynamique la propriété à une source de données.
Utiliser une couleur de libellé personnalisée
Définit la couleur par défaut des libellés actifs.
Couleur de libellé personnalisée
Ouvre la palette de couleurs dans laquelle vous choisissez la couleur des libellés actifs.
Liaison par défaut pour les nouveaux sous-formulaires
Définit la liaison par défaut des nouveaux sous-formulaires.
    • Normale
Définit les options de fusion et d'enregistrement. Les données sont fusionnées et enregistrées implicitement conformément aux règles de fusion d'Adobe.
    • Non
Efface les options de fusion et d'enregistrement des données pour les nouveaux sous-formulaires. Un nouveau sous-formulaire ne sera pas impliqué dans une quelconque opération de fusion des données par défaut.
Voir aussi
Pour configurer les propriétés dynamiques


Gestion du document (boîte de dialogue Options)

Servez-vous de cette boîte de dialogue pour modifier le type de fichier par défaut des nouveaux formulaires; la liste des fichiers récemment utilisés, les options de sauvegarde et de compression, les options de l'explorateur de fichiers image et les options de substitution de polices.
Pour afficher cette boîte de dialogue, sélectionnez Outils > Options, puis sélectionnez Gestion du document dans la liste située à gauche.
Type de fichier par défaut des nouveaux formulaires
Indique le type de fichier par défaut des nouveaux formulaires. Cette option a un impact sur la valeur par défaut de la boîte de dialogue Enregistrer sous et sur le format de fichier utilisé dans l'onglet Aperçu PDF si le formulaire n'a jamais été enregistré.
    • Formulaire PDF (statique) Acrobat 8
Définit le type de fichier par défaut des nouveaux formulaires sur Formulaire PDF statique compatible avec Acrobat 8,0. La conception de formulaire ne peut contenir que des éléments statiques. Par exemple, si votre formulaire comporte 10 rangées de données, et que la quantité de données est suffisante pour renseigner 25 rangées, seules 10 rangées peuvent être complétées. De même, si la quantité de données est suffisante pour compléter 2 rangées, vous obtiendrez 10 rangées. Dans ce cas, 2 rangées seront complétées et les 8 autres seront vides.
    • Formulaire XML (dynamique) Acrobat 8.0
Définit le type de fichier par défaut des nouveaux formulaires sur Formulaire PDF dynamique compatible avec Acrobat 8,0. La conception de formulaire peut contenir des éléments dynamiques. Par exemple, la conception de formulaire peut être un formulaire interactif qui permet aux utilisateurs d'ajouter ou de supprimer des rangées d'éléments.
    • Formulaire PDF (statique) Acrobat 7
Définit le type de fichier par défaut des nouveaux formulaires sur Formulaire PDF statique compatible avec Acrobat 7.0. La conception de formulaire ne peut contenir que des éléments statiques. Par exemple, si votre formulaire comporte 10 rangées de données, et que la quantité de données est suffisante pour renseigner 25 rangées, seules 10 rangées peuvent être complétées. De même, si la quantité de données est suffisante pour compléter 2 rangées, vous obtiendrez 10 rangées. Dans ce cas, 2 rangées seront complétées et les 8 autres seront vides.
    • Formulaire XML (dynamique) Acrobat 7
Définit le type de fichier par défaut des nouveaux formulaires sur Formulaire PDF dynamique compatible avec Acrobat 7.0. La conception de formulaire peut contenir des éléments dynamiques. Par exemple, la conception de formulaire peut être un formulaire interactif qui permet aux utilisateurs d'ajouter ou de supprimer des rangées d'éléments.
    • Formulaire PDF (statique) Acrobat 6
Définit le type de fichier par défaut des nouveaux formulaires sur Formulaire PDF (statique) compatible avec Acrobat 6. Utilisez cette option si les utilisateurs ne disposent que de la version 6.0 d'Acrobat. La conception de formulaire ne peut contenir que des éléments statiques. Elle ne peut pas contenir des codes à barres de formulaires pour support papier.
    • Formulaire XML Adobe (XDP)
Définit le type de fichier par défaut des nouveaux formulaires sur le format XML natif créé par LiveCycle Designer. Préférez cette option si vous utilisez LiveCycle Forms. La conception de formulaire peut contenir des éléments dynamiques. Le paramètre Format d'aperçu XDP de l'onglet Valeurs par défaut (boîte de dialogue Propriétés du formulaire) contrôle le format PDF utilisé pour l'aperçu PDF pour ce type de fichier.
Liste des derniers fichiers utilisés
Contrôle le nombre de fichiers affichés dans la Liste des derniers fichiers utilisés. Saisissez le nombre de noms de fichier à afficher. La valeur maximale est 10.
Enregistrer les fichiers PDF compressés
Compresse les fichiers PDF lorsqu’ils sont enregistrés.
Créer une copie de sauvegarde à l'enregistrement
Crée un fichier de sauvegarde lorsque vous enregistrez un form design. La copie de sauvegarde est enregistrée au même endroit que la conception de formulaire. La mention _BAK est ajoutée au nom de fichier, avant l'extension. La copie de sauvegarde préserve la version précédente du fichier lorsque vous procédez à l'enregistrement, au cas où vous auriez besoin de revenir à la version antérieure.
Afficher l'explorateur de fichiers par défaut
Indique l'explorateur de fichiers à utiliser par défaut. Vous pouvez charger un composant COM externe (tel qu'un composant d'explorateur de fichiers) pour effectuer des recherches dans un référentiel particulier. Si de tels composants sont enregistrés sur votre ordinateur, LiveCycle Designer les détecte et les affiche dans la liste.
Modifier les substitutions de polices
Définit les polices de substitution des documents concernés.
B. de dialogue Polices manquantes si aucune police de remplacement n'est définie
Affiche la boîte de dialogue Polices manquantes si aucune substitution n'est définie pour une ou plusieurs polices.
Voir aussi
Méthodes de création de conceptions de formulaire


Assistants et conseils (boîte de dialogue Options)

Servez-vous de cette boîte de dialogue pour modifier les options d'affichage des conseils dans les boîtes de dialogue, les avertissements et la boîte de dialogue de bienvenue.
Pour afficher cette boîte de dialogue, sélectionnez Outils > Options, puis Assistants et conseils dans la liste située à gauche.
Réinitialiser les boîtes de dialogues de conseil
Affiche les boîtes de dialogue de conseil. Ces boîtes de dialogue proposent des conseils sur ce que vous venez de faire dans LiveCycle Designer. Si vous avez sélectionné Ne plus afficher ce conseil, et si vous souhaitez à nouveau obtenir cette boîte de dialogue, cliquez sur Réinitialiser les boîtes de dialogue de conseil.
Réinitialiser tous les messages d'avertissement
Affiche les boîtes de dialogue d'avertissement lorsqu'une erreur survient.
Afficher la boîte de dialogue de bienvenue
Affiche la fenêtre d’accueil au démarrage de LiveCycle Designer.
Afficher les marqueurs d'avertissement
Affiche les marqueurs d'avertissement, par exemple un triangle jaune ou une croix blanche dans un cercle rouge, qui apparaissent à l'endroit où un problème est survenu dans un objet.
Lorsque la zone de valeur est insuffisante
Affiche un marqueur d'avertissement [image] lorsque la zone de valeur est trop petite pour afficher la valeur réelle. Admettons que vous créiez une zone de 3 pouces de large et de 0,5 pouce de haut, par exemple, et que vous limitiez sa longueur à un maximum de 50 caractères. Lors de l'exécution, il peut arriver que la zone de valeur soit trop petite pour afficher tous les caractères. Vous devez ajuster la largeur de la zone de valeur en fonction de son contenu.
LiveCycle Designer vérifie la zone pour s'assurer que, lors de l'exécution, elle sera suffisamment grande pour afficher la valeur correspondante. LiveCycle Designer affiche le marqueur d'avertissement dans les cas suivants :
      •
      La police utilisée dans la zone est une police à espacement fixe ou non proportionnelle (Courier ou LetterGothic, par exemple*). Si vous utilisez une police proportionnelle (Times New Roman, par exemple), LiveCycle Designer n'est pas en mesure d'évaluer la capacité de la zone, car plusieurs caractères i, par exemple, peuvent tenir dans l'espace d'un caractère W. L'utilisation d'une police à espacement fixe facilite la tâche de LiveCycle Designer pour évaluer la capacité de la zone.
vérifiez que LiveCycle Designer reconnaît la police en tant que police à espacement fixe ou non proportionnelle en effectuant le test sur un champ trop petit, et observez que le marqueur d'avertissement apparaît.
      •
      La taille du champ (largeur/hauteur) a été fixée par l'intermédiaire de la palette Disposition.
      •
      La longueur du champ est limitée à un certain nombre de caractères ou de chiffres. Le nombre limite de caractères peut être défini sous l'onglet Champ de la palette Objet.
      •
      Aucun modèle de données ou modèle d'affichage n'est défini pour le champ.
si le champ correspond à une cellule d'un tableau, le marqueur d'avertissement ne s'affiche pas.
Afficher à la création de nouveaux documents
Affiche l'assistant de création de formulaire lors de la conception d'un formulaire.
Afficher à l'importation de documents
Affiche l’assistant de création de formulaire à l'importation d’un fichier.
Afficher à l'importation de documents PDF d'Adobe
Affiche l'assistant de création de formulaire à l'ouverture d'un fichier PDF dans Acrobat. Cette option ne s'applique pas lorsque vous ouvrez un fichier PDF directement dans LiveCycle Designer.
Afficher à la création de tableaux
Affiche la boîte de dialogue Insérer un tableau lorsque vous créez un tableau en utilisant l'objet tableau de la palette Bibliothèque. Vous pouvez utiliser l'assistant de création de tableau à partir de cette boîte de dialogue.


Espace de travail (boîte de dialogue Options)

Servez-vous de cette boîte de dialogue pour afficher ou masquer des info-bulles associées aux objets, définir des options de l'éditeur de script et des options d'affichage de la source.
Pour afficher cette boîte de dialogue, sélectionnez Outils > Options, puis sélectionnez Espace de travail dans la liste située à gauche.
Afficher les info-bulles de taille et de position lors de la modification
Affiche les info-bulles de taille et de position.
Afficher les info-bulles de nom d'objet au pointage du curseur
Affiche l'info-bulle d'un objet lorsque vous placez le pointeur dessus.
Ajuster les objets de texte de taille fixe lors de la modification
Ajuste les objets de texte avec une hauteur et une largeur spécifiques, et les options d'ajustement se désactivent pour s'adapter à la quantité de texte.
Formatage de la syntaxe FormCalc
Affiche les options de police et de couleur de la syntaxe FormCalc dans l'éditeur de script.
Formatage de la syntaxe JavaScript
Affiche les options de police et de couleur de la syntaxe JavaScript dans l'éditeur de script.
Afficher les options d'exécution d'instructions
Affiche les options d'exécution d'instructions dans l'éditeur de script.
Afficher les numéros de ligne
Affiche les numéros de ligne dans l'éditeur de script.
Formatage de la syntaxe de la source XML
Affiche les options de police et de couleur de la syntaxe XML sur la page de la source XML.
Afficher les numéros de ligne
Affiche le numéro de ligne sur la page de la source XML.
Utiliser LiveCycle Designer 8.0 par défaut
Utilise LiveCycle Designer 8.0 comme version par défaut. La version par défaut est la version enregistrée de LiveCycle Designer. Si vous avez installé une version antérieure sur votre système et la démarrez, la version précédente s'enregistre automatiquement et devient la version par défaut.
LiveCycle Designer doit vérifier s'il est activé par défaut au démarrage.
Vérifie si LiveCycle Designer 8.0 est la version par défaut lorsque vous lancez le logiciel. Si ce n'est pas le cas, vous pouvez la configurer comme version par défaut.
Voir aussi
A propos de l’éditeur de script
Pour personnaliser les info-bulles
Boîte de dialogue Formatage de la syntaxe


Orthographe (boîte de dialogue Options)

Servez-vous de cette boîte de dialogue pour sélectionner les options de la vérification orthographique en cours de frappe, contrôler le type de texte que LiveCycle Designer vérifie, ajouter et supprimer des dictionnaires personnalisés et ouvrir la boîte de dialogue Modifier le dictionnaire d'éditer le dictionnaire personnel.
Pour afficher cette boîte de dialogue, sélectionnez Outils > Options, puis sélectionnez Orthographe dans la liste située à gauche.
Vérifier l'orthographe en cours de frappe
Permet de vérifier l'orthographe au fur et à mesure que vous saisissez du texte. Si cette option est sélectionnée, une ligne rouge ondulée s'affiche sous les mots mal orthographiés dans LiveCycle Designer.
Couleur du soulignement en ondulé
Ouvre une palette de couleurs dans laquelle les utilisateurs sélectionnent une autre couleur à appliquer à la ligne ondulée figurant sous les mots mal orthographiés. Par défaut, la couleur est le rouge.
Orthographe
Répertorie les types de texte dans un formulaire dont LiveCycle Designer peut vérifier l'orthographe lorsque vous ouvrez la boîte de dialogue Vérifier l'orthographe. Toutes les options sont sélectionnées par défaut.
Dictionnaires installés
Dresse la liste des dictionnaires disponibles pour la vérification de l'orthographe. LiveCycle Designer utilise les dictionnaires sélectionnés pour valider un formulaire. Le premier dictionnaire indiqué correspond toujours à votre (utilisateur actif) dictionnaire personnel (Mon dictionnaire personnel). Ce dictionnaire est toujours sélectionné et ne peut être supprimé de la liste.
Ajouter un dictionnaire
Ouvre la boîte de dialogue Fichier de dictionnaire personnalisé dans laquelle vous recherchez et ouvrez les fichiers dictionnaires personnalisés (*.clam) à ajouter à la liste des dictionnaires.
Supprimer un dictionnaire
Retire le dictionnaire sélectionné de la liste des dictionnaires installés. Le fichier dictionnaire (*.clam) n'est pas physiquement supprimé du système de fichiers de l'ordinateur.
Modifier le dictionnaire personnalisé
Ouvre la boîte de dialogue Modifier un dictionnaire qui permet d'effectuer les opérations suivantes : consulter la liste des mots disponible dans Mon dictionnaire personnel dans une langue particulière ou dans toutes les langues, changer l'orthographe des mots répertoriés et ajouter ou supprimer des mots dans une langue particulière ou dans toutes les langues. Vous ne pouvez pas modifier le contenu des autres dictionnaires installés.


International (boîte de dialogue Options)

Servez-vous de cette boîte de dialogue pour sélectionner la langue de l'application. Vous devez redémarrer LiveCycle Designer pour appliquer les modifications de langue.
Pour afficher cette boîte de dialogue, sélectionnez Outils > Options, puis sélectionnez International dans la liste située à gauche.
Langue
Répertorie les langues disponibles.
Afficher les unités de mesure selon les paramètres régionaux par défaut de l'application
Affiche les unités de mesure conformes aux paramètres régionaux de l'application.


Boîte de dialogue Impression

Utilisez la boîte de dialogue Impression pour définir les options de votre imprimante.
Les options affichées dans la boîte de dialogue Impression dépendent de l'imprimante à laquelle l'ordinateur est relié. Pour plus de détails sur les options de l’imprimante, reportez-vous à la documentation correspondante.


Boîte de dialogue Publier dans le référentiel

Utilisez cette boîte de dialogue pour placer une conception de formulaire et les fichiers qui y sont liés dans un dossier partagé ou un dossier Web, où elle sera accessible par de nombreux utilisateurs ou d’autres applications. Si le formulaire comporte un lien vers un fichier externe au moment où vous publiez la conception de formulaire et ses fichiers, le système modifie la liste incluse dans la conception de formulaire de façon à refléter le nouvel emplacement du fichier.
Pour afficher cette boîte de dialogue, sélectionnez Fichier > Publier dans le référentiel.
Enregistrer sous
Indique l’emplacement où vous voulez publier le formulaire.
Nom du fichier
Affiche le nom du fichier.
Type
Dresse la liste des types de fichiers que vous pouvez publier.
    • Formulaire PDF statique Acrobat 8 (*.pdf)
Publie les formulaires au format statique compatible Acrobat 8,0. La conception de formulaire ne peut contenir que des éléments statiques. Par exemple, si votre formulaire comporte 10 rangées de données, et que la quantité de données est suffisante pour renseigner 25 rangées, seules 10 rangées peuvent être complétées. De même, si la quantité de données est suffisante pour compléter 2 rangées, vous obtiendrez 10 rangées. Dans ce cas, 2 rangées seront complétées et les 8 autres seront vides.
    • Formulaire XML (dynamique) Acrobat 8 (*.pdf)
Publie les formulaires au format dynamique compatible Acrobat 8,0. La conception de formulaire peut contenir des éléments dynamiques. Par exemple, la conception de formulaire peut être un formulaire interactif qui permet aux utilisateurs d'ajouter ou de supprimer des rangées d'éléments.
    • Formulaire PDF statique Acrobat 7 (*.pdf)
Publie les formulaires au format statique compatible Acrobat 7.0. La conception de formulaire ne peut contenir que des éléments statiques. Par exemple, si votre formulaire comporte 10 rangées de données, et que la quantité de données est suffisante pour renseigner 25 rangées, seules 10 rangées peuvent être complétées. De même, si la quantité de données est suffisante pour compléter 2 rangées, vous obtiendrez 10 rangées. Dans ce cas, 2 rangées seront complétées et les 8 autres seront vides.
    • Formulaire XML (dynamique) Acrobat 7 (*.pdf)
Publie les formulaires au format dynamique compatible Acrobat 7.0. La conception de formulaire peut contenir des éléments dynamiques. Par exemple, la conception de formulaire peut être un formulaire interactif qui permet aux utilisateurs d'ajouter ou de supprimer des rangées d'éléments.
    • Formulaire PDF statique Acrobat 6 (*.pdf)
Publie les formulaires au format statique compatible avec Acrobat 6. Utilisez cette option si les utilisateurs ne disposent que de la version 6.0 d'Acrobat. La conception de formulaire ne peut contenir que des éléments statiques. Elle ne peut pas contenir des codes à barres de formulaires pour support papier.
    • Formulaire XML Adobe (*.xdp)
Publie les formulaires au format XML natif créés par LiveCycle Designer. Préférez cette option si vous utilisez LiveCycle Forms. La conception de formulaire peut contenir des éléments dynamiques.
Générer les informations d'accessibilité (balises)
pour Acrobat Incorpore les balises de données d’accessibilité dans le fichier PDF.
Générer un fichier journal à l'enregistrement
Crée un fichier journal dans le même dossier que le fichier PDF. Cette option est disponible seulement pour la publication au format PDF.
Remplacer définitivement les polices non disponibles
Remplace les polices non disponibles par des polices disponibles. Cette option est disponible seulement pour la publication au format PDF.
Incorporer les polices
Incorpore les polices du formulaire dans la conception de formulaire à enregistrer. Cette option est disponible seulement pour la publication au format PDF.
Voir aussi
Pour publier un formulaire dans un référentiel


Boîte de dialogue Enregistrer sous

Utilisez cette boîte de dialogue pour enregistrer les conceptions et les modèles de formulaire sous leur nom et emplacement actifs, ou pour en enregistrer une copie sous un nom et un emplacement différents.
Pour afficher cette boîte de dialogue, sélectionnez Fichier > Enregistrer sous.
Enregistrer sous
Indiquez l’emplacement dans lequel vous voulez enregistrer un fichier ou un dossier.
Nom du fichier
Affiche le nom du fichier. Le système crée le nom au moment de l'enregistrement de la conception de formulaire.
Type
Dresse la liste des types de fichiers que vous pouvez enregistrer.
    • Formulaire PDF statique Acrobat 8 (*.pdf)
Enregistre les formulaires au format statique compatible Acrobat 8,0. La conception de formulaire ne peut contenir que des éléments statiques. Par exemple, si votre formulaire comporte 10 rangées de données, et que la quantité de données est suffisante pour renseigner 25 rangées, seules 10 rangées peuvent être complétées. De même, si la quantité de données est suffisante pour compléter 2 rangées, vous obtiendrez 10 rangées. Dans ce cas, 2 rangées seront complétées et les 8 autres seront vides.
    • Formulaire XML (dynamique) Acrobat 8 (*.pdf)
Enregistre les formulaires au format dynamique compatible Acrobat 8,0. La conception de formulaire peut contenir des éléments dynamiques. Par exemple, la conception de formulaire peut être un formulaire interactif qui permet aux utilisateurs d'ajouter ou de supprimer des rangées d'éléments.
    • Formulaire PDF statique Acrobat 7 (*.pdf)
Enregistre les formulaires au format statique compatible Acrobat 7.0. La conception de formulaire ne peut contenir que des éléments statiques. Par exemple, si votre formulaire comporte 10 rangées de données, et que la quantité de données est suffisante pour renseigner 25 rangées, seules 10 rangées peuvent être complétées. De même, si la quantité de données est suffisante pour compléter 2 rangées, vous obtiendrez 10 rangées. Dans ce cas, 2 rangées seront complétées et les 8 autres seront vides.
    • Formulaire XML (dynamique) Acrobat 7 (*.pdf)
Enregistre les formulaires au format dynamique compatible Acrobat 7.0. La conception de formulaire peut contenir des éléments dynamiques. Par exemple, la conception de formulaire peut être un formulaire interactif qui permet aux utilisateurs d'ajouter ou de supprimer des rangées d'éléments.
    • Formulaire PDF statique Acrobat 6 (*.pdf)
Enregistre les formulaires au format statique compatible avec Acrobat 6. Utilisez cette option si les utilisateurs ne disposent que de la version 6.0 d'Acrobat. La conception de formulaire ne peut contenir que des éléments statiques. Elle ne peut pas contenir des codes à barres de formulaires pour support papier.
    • Formulaire XML Adobe (*.xdp)
Enregistre les formulaires au format XML natif créés par LiveCycle Designer. Préférez cette option si vous utilisez LiveCycle Forms. La conception de formulaire peut contenir des éléments dynamiques.
    • Adobe Modèle LiveCycle Designer (*.tds)
Enregistre la structure de base d'un formulaire sous la forme d'un modèle. Il peut contenir des composants et des paramètres, tels que polices, mise en page, mise en forme et scripts. Utilisez-le comme point de départ d'un nouveau formulaire.
Générer les informations d'accessibilité (balises) pour Acrobat
Incorpore les données d’accessibilité dans le fichier PDF à enregistrer. Cette option est disponible seulement pour la publication au format PDF.
Générer un fichier journal à l'enregistrement
Crée un fichier journal associé au fichier à enregistrer. Ce fichier journal est placé dans le même répertoire que le formulaire enregistré. Cette option est disponible seulement pour la publication au format PDF.
Remplacer définitivement les polices non disponibles
Remplace les polices non disponibles par des polices disponibles.
Incorporer les polices
Incorpore les polices du formulaire dans la conception de formulaire à enregistrer. Cette option est disponible seulement pour la publication au format PDF.
Voir aussi
Pour enregistrer votre conception de formulaire
Pour enregistrer une copie d'une conception de formulaire


Signature des données et paramètres d'envoi, boîte de dialogue

Panneau Signature des données (boîte de dialogue Signature des données et paramètres d'envoi)
Cette boîte de dialogue contient les mêmes panneaux que la boîte de dialogue Paramètres de signature du document, sauf qu'elle dispose du panneau Signature des données au lieu du panneau Motifs de la signature.
Pour plus d'informations sur les panneaux de cette boîte de dialogue, voir Boîte de dialogue Paramètres de signature du document.


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Signature des données et paramètres d'envoi, boîte de dialogue > Panneau Signature des données (boîte de dialogue Signature des données et paramètres d'envoi)

Panneau Signature des données (boîte de dialogue Signature des données et paramètres d'envoi)

Utilisez ce panneau pour sélectionner les données incluses dans une signature de données associée à un bouton d'envoi. La signature peut inclure les données par défaut ou toutes les données.
Pour afficher ce panneau, effectuez une des actions suivantes :
      •
      Sélectionnez un bouton d'envoi, cliquez sur l'onglet Envoyer de la palette Objet, assurez-vous que l'option Signature de l'envoi est activée, cliquez sur Paramètres, puis sur le panneau Signature des données.
      •
      Sélectionnez un bouton d'envoi par messagerie pou via HTTP, puis dans la palette Objet, assurez-vous que l'option Signature de l'envoi est activée, cliquez sur Paramètres, puis sur le panneau Signature des données.
Signature des données uniquement
Créé une signature qui s'applique uniquement aux données du formulaire d'envoi. Il s'agit de l'option par défaut.
Signature de l'envoi entier
Créé une signature qui s'applique aux données du formulaire et aux pièces jointes, telles que conception de formulaire, signature du document ou annotations.
Voir aussi
Aperçu du bouton Envoyer par messagerie
Aperçu du bouton Envoyer via HTTP
A propos de l'envoi de données au moyen d'un bouton
Pour ajouter une signature de données à un bouton d'envoi


Boîte de dialogue Spécifier une police de substitution

Utilisez cette boîte de dialogue pour sélectionner une police de substitution pour la police manquante.
Pour afficher cette boîte de dialogue, cliquez sur Outils> Options. Sélectionnez Gestion du document dans la liste située sur la gauche, puis cliquez sur Modifier les substitutions de polices. Cliquez sur Changer la police de substitution
Police manquante
Indique le nom de la police manquante sur l’ordinateur.
Polices disponibles
Répertorie les polices que vous pouvez choisir en substitution des polices manquantes.
Style de police
Répertorie les styles de police pour la police disponible sélectionnée.


Boîte de dialogue Formatage de la syntaxe

Les boîtes de dialogue Formatage de la syntaxe de la source XML, FormCalc et JavaScript permettent de définir les options de police et de couleur des syntaxes FormCalc et JavaScript et de la syntaxe de source XML.
Pour afficher les caractères arabes, hébreux, thaïs et vietnamiens dans la zone Source XML ou Editeur de script, vous devez modifier les paramètres de police utilisés par LiveCycle Designer dans cette zone. Sinon, LiveCycle Designer affiche des rectangles à l'emplacement des caractères concernés. Par exemple, pour l'arabe, choisissez la police Adobe Arabic, pour l'hébreu Adobe Hebrew, pour le thaï Adobe Thai et pour le vietnamien Myriad Pro ou Minion Pro.
Pour afficher cette boîte de dialogue, cliquez sur Outils> Options. Sélectionnez Espace de travail dans la liste située à gauche, puis cliquez sur l'un des boutons Formatage de la syntaxe.
Police
Définit la police.
Format
Définit la taille de la police.
Couleurs
Définit la catégorie à modifier.
Utiliser une couleur de texte personnalisée
Définit la couleur des caractères.
Utiliser une couleur de fond personnalisée
Spécifie la couleur du fond.
Echantillon
Affiche un exemple des paramètres actuels.
Rétablir les valeurs par défaut
Réinitialise les valeurs par défaut des options de police et de couleur.
Voir aussi
A propos de l’éditeur de script
Pour afficher des caractères en arabe, hébreu, thaï et vietnamien


Boîte de dialogue Assistant de création de tableaux

Disposition du contenu (boîte de dialogue Assistant de création de tableaux)
Rangée de pied de page (boîte de dialogue Assistant de création de tableaux)
Rangée d'en-tête (boîte de dialogue Assistant de création de tableaux)
Ombrage de la rangée (boîte de dialogue Assistant de création de tableaux)
Sections (boîte de dialogue Assistant de création de tableaux)


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Assistant de création de tableaux > Disposition du contenu (boîte de dialogue Assistant de création de tableaux)

Disposition du contenu (boîte de dialogue Assistant de création de tableaux)

Cette boîte de dialogue permet de créer un tableau contenant un nombre fixe de rangées et de colonnes de contenu ou un tableau avec un nombre variable de rangées de contenu et un nombre fixe de colonnes.
Pour afficher cette boîte de dialogue, sélectionnez Insertion > Standard > Tableau > Créer un tableau à l'aide de l'assistant de création de tableaux > OK.
Contenu aux dimensions fixes
Crée un tableau dont le nombre de colonnes et de rangées de contenu correspond aux nombres (fixes) sélectionnés.
Nombre de colonnes
Ajoute le nombre de colonnes spécifié (20 au maximum).
Nombre de rangées de contenu
Ajoute le nombre de rangées de contenu spécifié (50 au maximum).
Rangées de contenu varient selon données
Crée un tableau dans lequel le nombre de rangées varie en fonction de la quantité nécessaire aux données.
Voir aussi
Pour créer un tableau à l'aide de l'assistant


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Assistant de création de tableaux > Rangée de pied de page (boîte de dialogue Assistant de création de tableaux)

Rangée de pied de page (boîte de dialogue Assistant de création de tableaux)

Utilisez cette boîte de dialogue pour exclure ou inclure une rangée de pied de page du tableau et pour faire en sorte que la rangée de pied de page se répète sur toutes les pages.
Pour afficher cette boîte de dialogue, sélectionnez Insertion > Standard > Tableau > Créer un tableau à l'aide de l'assistant de création de tableaux > OK > Rangée de pied de page.
Aucune rangée de pied de page
Aucune rangée de pied de page ne figure dans le tableau.
Avec rangée de pied de page
Inclut une rangée de pied de page dans le tableau.
Rangée pied de page ttes pg
Reprend la rangée de pied de page sur toutes les pages. Cette option est disponible uniquement si le sous-formulaire parent est défini comme Distribué sous l'onglet Sous-formulaire de la palette Objet.
Voir aussi
Pour créer un tableau à l'aide de l'assistant


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Assistant de création de tableaux > Rangée d'en-tête (boîte de dialogue Assistant de création de tableaux)

Rangée d'en-tête (boîte de dialogue Assistant de création de tableaux)

Utilisez cette boîte de dialogue pour exclure ou inclure une rangée d'en-tête du tableau et pour faire en sorte que la rangée d'en-tête se répète sur toutes les pages.
Pour afficher cette boîte de dialogue, sélectionnez Insertion > Standard > Tableau > Créer un tableau à l'aide de l'assistant de création de tableaux > OK > Rangée d'en-tête.
Aucune rangée d'en-tête
Aucune rangée d'en-tête ne figure dans le tableau.
Avec rangée d'en-tête
Inclut une rangée d'en-tête dans le tableau.
Rangée en-tête à chaque page
Reprend la rangée d'en-tête sur toutes les pages. Cette option est disponible uniquement si le sous-formulaire parent est défini comme Distribué sous l'onglet Sous-formulaire de la palette Objet.
Voir aussi
Pour créer un tableau à l'aide de l'assistant


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Assistant de création de tableaux > Ombrage de la rangée (boîte de dialogue Assistant de création de tableaux)

Ombrage de la rangée (boîte de dialogue Assistant de création de tableaux)

Utilisez cette boîte de dialogue pour ajouter des rangées de couleur en alternance.
Pour afficher cette boîte de dialogue, sélectionnez Insertion > Standard > Tableau > Créer un tableau à l'aide de l'assistant de création de tableaux > OK > Ombrage de la rangée.
Alternance des couleurs de rangées
Alterne les couleurs de rangées de contenu en se basant sur le nombre de rangées spécifié et les couleurs sélectionnées.
Prem.
Indique le nombre de rangées auxquelles appliquer la première couleur.
Sélecteur de couleurs
Ouvre la palette de couleurs dans laquelle vous pouvez sélectionner la couleur de la première rangée ou du premier ensemble de rangées.
Suivant
Indique le nombre de rangées auxquelles appliquer la seconde couleur.
Sélecteur de couleurs
Ouvre la palette de couleurs dans laquelle vous pouvez sélectionner la couleur de la seconde rangée ou du second ensemble de rangées.
Voir aussi
Pour créer un tableau à l'aide de l'assistant


Précédent Suivant

Référence aux menus, commandes, boîtes à outils et boîtes de dialogue > Présentation des boîtes de dialogue > Boîte de dialogue Assistant de création de tableaux > Sections (boîte de dialogue Assistant de création de tableaux)

Sections (boîte de dialogue Assistant de création de tableaux)

Utilisez cette boîte de dialogue pour ajouter, supprimer, renommer et organiser des sections (ensemble de rangées considéré comme une unité) dans le tableau.
Pour afficher cette boîte de dialogue, sélectionnez Insertion > Standard > Tableau > Créer un tableau à l'aide de l'assistant de création de tableaux > OK > Sections.
Avec rangées de contenu et sans section
Crée un tableau sans section contenant le nombre de rangées de contenu indiqué dans la boîte de dialogue Disposition du contenu.
Avec sections de rangées de contenu
Crée un tableau contenant le nombre de rangées de contenu indiqué dans la boîte de dialogue Disposition du contenu et les sections spécifiées dans la liste Sections.
Sections
Répertorie les sections ajoutées à la disposition du tableau. Le nom de section Section1 correspond à une balise d'emplacement. Il suffit de cliquer deux fois sur ce nom pour le changer.
Ajouter
Ajoute une section et ouvre la boîte de dialogue Section du tableau, afin de donner un nom à la section.
Supprimer
Supprime la section sélectionnée.
Flèche Haut
Déplace la section sélectionnée vers le haut.
Flèche Bas
Déplace la section sélectionnée vers le bas.
Section avec rangée d'en-tête
Ajoute une rangée d'en-tête à la section sélectionnée.
Section avec rangée de pied de page
Ajoute une rangée de pied de page à la section sélectionnée.
Section facultative
Empêche l'affichage de la section sélectionnée s'il n'y a aucune donnée disponible pour cette section.
Voir aussi
Pour créer un tableau à l'aide de l'assistant


Boîte de dialogue Gestionnaire de modèles

Utilisez le Gestionnaire de modèles pour afficher un aperçu des modèles et sélectionner un modèle par défaut pour créer vos modèles de formulaire. Le modèle par défaut apparaît à l'ouverture du Gestionnaire de modèles.
Pour afficher cette boîte de dialogue, sélectionnez Outils> Gestionnaire de modèles.
Onglet Standard
Affiche les formats de papier proposés pour le nouveau modèle de formulaire.
Onglet Exemples
Affiche les modèles de formulaire d'exemple disponibles.
Onglet Personnaliser
Affiche les conceptions de formulaire personnalisées disponibles.
Définir par défaut
Définit le modèle par défaut proposé lorsque de la création d'un modèle de formulaire.
Voir aussi
A propos des modèles et du Gestionnaire de modèles
Pour ajouter un modèle au Gestionnaire de modèles
Pour ajouter un panneau au Gestionnaire de modèles


Boîte de dialogue Options de modèle

Utilisez cette boîte de dialogue pour spécifier comment LiveCycle Designer traite le modèle que vous importez.
Pour afficher cette boîte de dialogue, ouvrez un fichier de modèle (TDS) qui n'a pas été ajouté au Gestionnaire de modèles.
Copier ce modèle dans le Gestionnaire de modèles
Ajoute le fichier de modèle au Gestionnaire de modèles
Créer un formulaire basé sur ce modèle
Crée un formulaire PDF sans titre basé sur le modèle ; vous pouvez le nommer et l'enregistrer. Si le modèle contient des balises d'emplacement, l'assistant de création de formulaires s'ouvre et vous permet de modifier les informations correspondantes dans les différents champs.
Modifier ce modèle
Ouvre le fichier de modèle afin de le modifier.


Modèles de formulaire

Modèles de formulaire

A propos des modèles de formulaire
Modèle de rappel de paiement
Modèle de billet électronique
Modèle de demande de subvention
Modèles de bons de commande
Modèle de script
Modèle de jeu de sous-formulaires
Modèle de reçu pour déclaration fiscale


A propos des modèles de formulaire

LiveCycle Designer propose une sélection de modèles de formulaire. Chacun d'eux comprend une conception de formulaire, des modèles de données et/ou un schéma, ainsi que la version finale du formulaire. Ils illustrent les différentes techniques de conception de formulaires simples et complexes. Ces formulaires se trouvent dans le dossier FR\Samples sous le dossier d'installation de LiveCycle Designer.
Le tableau ci-dessous répertorie les modèles et leur emplacement dans le dossier d'installation de LiveCycle Designer.

Modèle de formulaire

Lieu

Rappel de paiement

Le modèle de rappel de paiement illustre le fonctionnement d'un formulaire PDF dynamique.
\FR\Samples\Dunning Notice

Billet électronique

Le modèle de billet électronique illustre le fonctionnement d'un formulaire PDF dynamique. Le fichier d'aide donne une explication sur chacune des notes numérotées qui se trouvent dans le fichier de modèle E-Ticket.pdf.
\FR\Samples\E-Ticket

Demande de subvention

Le modèle de demande de subvention illustre le fonctionnement d'un formulaire PDF interactif.
\FR\Samples\Grant Application

Bon de commande

Les quatre modèles de bons de commande illustrent le fonctionnement de formulaires PDF dynamiques, interactifs et les deux à la fois.
\FR\Samples\Purchase Order

Script

Le modèle de script vous aide à rédiger un script en utilisant les langages FormCalc et JavaScript. Vous pouvez écrire un script dans un champ de saisie, puis l'exécuter en cliquant sur un bouton.
\FR\Samples\Scripting

Jeu de sous-formulaires

Le modèle de jeu de sous-formulaires illustre le fonctionnement d'un formulaire PDF dynamique. Il est composé de quatre sous-modèles qui démontrent le fonctionnement de l'appel de l'objet de jeu de sous-formulaires lorsque le type de relation et les valeurs d'occurrence de ce dernier sont variables.
\FR\Samples\SubformSet

Reçu pour déclaration fiscale

Le modèle de reçu pour déclaration fiscale illustre le fonctionnement d'un formulaire PDF dynamique.
\FR\Samples\Tax Receipt


Modèle de rappel de paiement

A propos du modèle de rappel de paiement
Pour ouvrir le modèle de rappel de paiement
A propos du formulaire de rappel de paiement


A propos du modèle de rappel de paiement

Le modèle de rappel de paiement illustre le fonctionnement d'un formulaire PDF dynamique.
Ce modèle dispose de trois niveaux de paiement. Les renseignements propres à chacun des niveaux doivent être imprimés avec la liste des documents impayés.
Le modèle inclut les fichiers suivants :
Formulaire | Dunning Notice.xdp | Fichier de formulaire LiveCycle Designer situé dans le dossier Forms.
Données | Dunning Notice Level1.xml Dunning Notice Level2.xml Dunning Notice Level3.xml | Fichiers de données XML situés dans le dossier Data. Le troisième fichier de données du rappel de paiement comporte suffisamment de factures pour entraîner un débordement sur une deuxième page.
Image | Dunning Notice.tif | Fichier image situé dans le dossier Images.
Sortie | Dunning Notice Level1.pdf Dunning Notice Level2.pdf Dunning Notice Level3.pdf | Formulaires générés avec données situés dans le dossier Outputs.


Pour ouvrir le modèle de rappel de paiement

1.
Choisissez Fichier\Ouvrir \FR\Samples\Dunning Notice\Forms\Dunning Notice.xdp dansLiveCycle Designer.
2.
Pour définir les options d'aperçu, choisissez Fichier > Propriétés du formulaire. Cliquez sur l'onglet Valeurs par défaut et effectuez les opérations suivantes :
      •
      Dans la liste Type d'aperçu, sélectionnez Imprimer le formulaire.
      •
      Dans la zone Fichier de données, parcourez l'arborescence des fichiers jusqu'au dossier Data et sélectionnez l'un des modèles de fichiers de données comme par exemple, le fichier Dunning Notice Level1.xml.
      •
      Cliquez sur OK.
3.
Pour afficher un aperçu du formulaire, cliquez sur l'onglet Aperçu PDF.
Les fichiers PDF situés dans le dossier Outputs illustrent le résultat obtenu après la fusion des différents jeux de données dans le formulaire. Servez-vous de ces fichiers pour comparer le résultat final avec celui de l'aperçu du formulaire.


A propos du formulaire de rappel de paiement

Le formulaire dispose de plusieurs fonctions.
Structure hiérarchique du formulaire
Le formulaire de rappel de paiement est fondé sur la structure de données, permettant ainsi de tirer profit du processus implicite de liaison de données.
Page type
Deux pages types sont nécessaires. La première comprend le logo de l'entreprise, le titre du formulaire et le texte statique. Cette page est la première page à imprimer et possède une valeur Max. de 1. L'option Max. est située dans l'onglet Liaison de la palette Objet ; la deuxième page type s'utilise pour les pages suivantes. Le même texte statique y est affiché ainsi que le numéro de page.
Numérotation de pages
Les numéros de page sont des valeurs calculées que l'on obtient en insérant une propriété d'exécution dans un objet de texte.
Contenu avec enchaînement
Lorsque les données sont fusionnées dans le formulaire, les sous-formulaires sont placés les uns sous les autres lorsque l'option Contenu du parent des sous-formulaires (dunningNotice) est défini à Distribué. Cette option est située dans l'onglet Sous-formulaire de la palette Objet. L'option Enchaînement, également située dans l'onglet Sous-formulaire de la palette Objet, est définie à Haut vers le bas. Les marges du sous-formulaire, spécifiées dans la palette Disposition, ajoutent l'espace nécessaire entre deux sous-formulaires.
Les sous-formulaires header, level1, level2, level3 et closing ont également un contenu avec enchaînement. Les marges des champs ajoutent l'espace nécessaire entre deux objets.
Occurrences du sous-formulaire
Le formulaire comporte différents sous-formulaires qui fonctionnent ensemble de manière à bien rendre les données. Ces sous-formulaires sont eux-mêmes composés de sous-formulaires qui se répètent ou non. La valeur Min. de répétitions de tous les sous-formulaires (à l'exception des sous-formulaires detailHeader et closing) est définie à 0. Cela signifie que seul le sous-formulaire requis sera imprimé. La valeur Max. du sous-formulaire qui ne se répète pas est définie à 1. Cette valeur n'est pas définie pour les sous-formulaires qui se répètent car le nombre varie pour chacun des ensembles de données. La valeur Min. de répétitions du sous-formulaire closing est définie à 1, car il n'existe aucune donnée pour appeler le sous-formulaire.
En-tête de détail
L'en-tête de détail affiche les en-têtes de colonne et doit être imprimé avant la première ligne de détail. Cet en-tête devrait se répéter en haut de la page suivante lorsque les lignes de détail ne peuvent plus tenir sur la page courante. En définissant la valeur Min. de répétitions du sous-formulaire detailHeader à 1, vous vous assurez que l'en-tête est toujours imprimé au moins une fois.
Début de débordement
Le sous-formulaire detailHeader est associé au sous-formulaire document en tant que sous-formulaire de début de débordement. Cette fonction force l'impression du sous-formulaire de début de débordement chaque fois que le sous-formulaire document déborde sur une nouvelle page. Etant donné qu'il n'existe aucun champ dans le sous-formulaire detailHeader, l'option de liaison par défaut, située dans l'onglet Liaison de la palette Objet, est définie à Aucune.
Champs globaux
La valeur de la devise est indiquée une seule fois dans le fichier de données. En définissant la liaison par défaut du champ de la devise en tant que valeur globale et en utilisant ce champ à divers endroits, la valeur est reproduite dans chacune des occurrences du champ.
Champ d'image
Étant donné que le logo de l'entreprise peut changer, il a été incorporé au fichier de données. Un objet de champ d'image est utilisé pour afficher l'image.
Nombre maximal de caractères pour chaque champ
Le nombre maximal de caractères pour chacun des champs est conforme aux spécifications définies. Cette option est située dans l'onglet Champ de la palette Objet.
Champs extensibles et position de l'ancre
Pour tenir compte des valeurs de taille variable, l'option Ajuster, située dans la palette Disposition, a été désactivée pour les champs d'adresse de facturation, de salutations et de fin. La position de l'ancre de ces champs est définie de manière à permettre une extension du champ dans la direction appropriée.
Variables
Chaque paragraphe se termine de la même manière. Pour en faciliter la gestion, ce contenu a été défini en tant que variable et un script est utilisé pour faire référence à cette valeur et l'afficher. Puisque la valeur du champ est calculée, la liaison par défaut est définie à Aucune.
Script
Les valeurs d'adresses doivent être affichées en bloc. Un script JavaScript est utilisé pour concaténer les données. Puisque la valeur du champ d'adresse de facturation est calculée, la liaison par défaut est définie à Aucune.
Champ multiligne
La propriété Permettre des lignes multiples du champ d'adresse de facturation, située dans l'onglet Champ de la palette Objet, est activée afin que la valeur calculée puisse imprimer plusieurs lignes.
Champs flottants
Le sous-formulaire level3 comporte du texte et des champs. L'utilisation de champs flottants résulte en un flux naturel de l'information. Il est possible de définir directement le format d'affichage du champ qui sera rendu dans le paragraphe. Cette option est située dans l'onglet Champ de la palette Objet. Le champ flottant est un champ masqué inséré dans l'objet de texte. La référence au champ flottant est représentée par le nom du champ entre accolades, par exemple : {fieldName}.
Modèles d'image
Certaines valeurs se lisent mieux lorsqu'on leur applique un format d'affichage. Par exemple, la valeur d'échéance du sous-formulaire niveau3 est affichée selon le format moyen. Un exemple de données est également nécessaire parce que la valeur n'est pas fournie en format canonique. Définissez la valeur du modèle de données dans l'onglet Liaison de la palette Objet.


Modèle de billet électronique

A propos du modèle de billet électronique
Pour ouvrir le modèle de billet électronique
A propos de l'impression du billet électronique


A propos du modèle de billet électronique

Le modèle de billet électronique illustre et explique le fonctionnement d'un formulaire PDF dynamique. Le modèle de formulaire contient des notes numérotées, représentées par des cercles noirs avec un nombre blanc. Pour obtenir de plus amples informations sur ces notes, reportez-vous à la section A propos de l'impression du billet électronique.
Ce formulaire imprime le dossier de voyage qui comprend l'itinéraire des vols, le formulaire des douanes, le formulaire de rapport médical, les bordereaux de transfert de vols, les renseignements sur l'hébergement et les cartes d'embarquement. Différentes orientations de papier sont utilisées pour l'impression des éléments du dossier.
Le modèle inclut les fichiers suivants :
Formulaire | E-Ticket.xdp | Fichier de formulaire LiveCycle Designer situé dans le dossier Forms.
Données | E-Ticket.xml | Fichier de données XML situé dans le dossier Data.
Image | E-Ticket.tif | Fichier image situé dans le dossier Images.
Sortie | E-Ticket.pdf | Formulaire généré avec données situé dans le dossier Outputs.


Pour ouvrir le modèle de billet électronique

1.
Choisissez Fichier \Ouvrir \FR\Samples\E-Ticket\Forms\E-Ticket.xdp dans LiveCycle Designer.
2.
Pour définir les options d'aperçu, choisissez Fichier > Propriétés du formulaire. Cliquez sur l'onglet Valeurs par défaut et effectuez les opérations suivantes :
      •
      Dans la liste Type d'aperçu, sélectionnez Formulaire pour impression.
      •
      Dans la zone Fichier de données, repérez le dossier Data et sélectionnez le modèle de fichier de données (E-Ticket.xml).
      •
      Cliquez sur OK.
3.
Pour afficher un aperçu du formulaire, cliquez sur l'onglet Aperçu PDF.
Le modèle de fichier PDF situé dans le dossier Outputs illustre le formulaire généré avec des données. Servez-vous de ce fichier pour comparer le résultat final avec celui de l'aperçu du formulaire.


A propos de l'impression du billet électronique

Les notes numérotées ci-dessous correspondent aux numéros indiqués dans les cercles noirs qui se trouvent dans le modèle de formulaire.
1.
La page de couverture du dossier doit être imprimée une seule fois, selon une orientation portrait.
      •
      Le sous-formulaire coverPage est appelé dès que des données se trouvent dans le groupe de données coverPage.
      •
      Il est placé dans la page type ayant une orientation portrait puisqu'il s'agit de la première zone de page définie dans le groupe de pages.
      •
      Les valeurs Min. de répétitions et Max du sous-formulaire coverPage sont respectivement de 0 et 1. Ces options se trouvent dans l'onglet Liaison de la palette Objet.
      •
      Le fichier d'image est lié au formulaire. Le lien constitue l'URL de l'objet d'image.
      •
      Un script JavaScript est utilisé dans la section Éléments compris dans ce dossier de voyage pour insérer le pluriel dans le texte des libellés de champ, lorsque cela est nécessaire.
les données qui doivent être imprimées à différents endroits dans le dossier de voyage sont définies en tant que champs globaux, notamment les champs Nom, Prénom et Initiale.
2.
Les données d'en-tête de l'itinéraire des vols doivent être imprimées avant les itinéraires de vol, selon une orientation paysage.
      •
      Pour appeler le sous-formulaire flightHeader la combinaison sous-formulaire, occurrence du sous-formulaire et type de relation du sous-formulaire est requise.
      •
      Le groupe de sous-formulaires itinéraire n'est appelé que si le sous-formulaire flight est lui-même appelé. Cela est possible en définissant la valeur Min. de répétitions du groupe de sous-formulaires à 0. Une fois le groupe de sous-formulaires appelé, le sous-formulaire flightHeader est également appelé, car une valeur Min. de répétitions de 1 lui a été affectée. C'est ce qui se produit lorsqu'on définit la valeur Type, située dans l'onglet Sous-formulaire de la palette Objet, à Utiliser tous les sous-formulaires dans l'ordre.
      •
      Le sous-formulaire flightHeader est associé à la page type paysage. Le sous-formulaire flightHeader prendra la position À la page « paysage ».
      •
      Le sous-formulaire flightHeader est associé au sous-formulaire flight en tant de sous-formulaire de début de débordement. Il doit être imprimé en haut de chacune des pages de la section Itinéraire des vols. Le champ Liaison par défaut, situé dans l'onglet Liaison de la palette Objet, a pour valeur Globale, car l'information doit se répéter.
3.
Ces vols sont propres au dossier de voyage et peuvent varier d'un itinéraire à l'autre.
      •
      Le sous-formulaire flight est appelé dès que des données se trouvent dans le groupe de données flight. Ce sous-formulaire a une valeur Min. de répétitions de 0 et une valeur d'occurrence maximale illimitée. Cela signifie qu'il ne sera appelé que si des données de vol sont présentes et qu'il se répétera autant de fois que cela est nécessaire pour imprimer toutes les données. La valeur maximale est illimitée lorsque l'option Sous-formulaire pour chaque élément est activée et lorsque l'option Max. est désactivée. L'option Sous-formulaire pour chaque élément figure dans l'onglet Liaison de la palette Objet.
      •
      Le sous-formulaire flight prendra la position Suivant le précédent sous-formulaire.
4.
Une seule déclaration douanière est requise pour chaque famille. Elle doit être imprimée selon une orientation portrait.
      •
      Le sous-formulaire customs est appelé dès que des données se trouvent dans le groupe de données customs.
      •
      Les valeurs Min. de répétitions et Max. du sous-formulaire customs sont respectivement de 0 et 1.
      •
      Le sous-formulaire customs est associé à la page type portrait. Il prendra la position Haut de la page « portrait », forçant ainsi une nouvelle page.
5.
Un seul rapport médical doit être imprimé sur une page et il doit l'être selon une orientation portrait.
      •
      Le sous-formulaire medical est appelé dès que des données se trouvent dans le groupe de données medical.
      •
      Ce sous-formulaire a une valeur Min. de répétitions de 0 et une valeur d'occurrence maximale illimitée.
      •
      Le sous-formulaire medical est associé à la page type portrait et prend la position Haut de la page « portrait », forçant ainsi une nouvelle page.
      •
      Un script Javascript concaténera les renseignements sur l'adresse du passager. L'option Permettre des lignes multiples du champ d'adresse du passager est active pour que tout le bloc d'information puisse être imprimé. Cette option est située dans l'onglet Champ de la palette Objet.
6.
Les données d'en-tête d'hébergement doivent être imprimées avant la liste des hôtels, selon une orientation paysage.
      •
      Pour appeler le sous-formulaire hotelHeader, la combinaison sous-formulaire, occurrence du sous-formulaire et type de relation du sous-formulaire est requise.
      •
      Le groupe de sous-formulaires accomodation n'est appelé que si le sous-formulaire hotel est lui-même appelé. Cela est possible en définissant la valeur Min. de répétitions du groupe de sous-formulaires à 0. Une fois le groupe de sous-formulaires appelé, le sous-formulaire hotelHeader est également appelé, car une valeur Min. de répétitions de 1 lui a été affectée. C'est ce qui se produit lorsqu'on définit le type de relation à Utiliser tous les sous-formulaires dans l'ordre.
      •
      Le sous-formulaire hotelHeader est associé à la page type paysage. Il prendra la position À la page « paysage ».
      •
      Le sous-formulaire hotelHeader est associé au sous-formulaire hotel en tant de sous-formulaire de début de débordement. Il doit s'imprimer en haut de chacune des pages de la section Hébergement. Les champs sont définis en tant que champs globaux, car l'information doit se répéter.
      •
      Un script JavaScript est utilisé pour concaténer les données Nom et Prénom.
      •
      Les valeurs d'adresse de passager doivent être affichées en bloc. Un script JavaScript est utilisé pour concaténer les données.
7.
La liste d'hôtels est propre au dossier de voyage et peut varier d'un itinéraire à l'autre.
      •
      Le sous-formulaire hotel est appelé dès que des données se trouvent dans le groupe de données hotel. Ce sous-formulaire a une valeur Min. de répétitions de 0 et une valeur d'occurrence maximale illimitée. Il ne sera appelé que si des données sont présentes, et il se répétera autant de fois que cela est nécessaire pour imprimer toutes les données.
      •
      Le sous-formulaire hotel prendra la position Suivant le précédent sous-formulaire.
      •
      Les valeurs de catégorie de chambre doivent être affichées en bloc. Un script JavaScript est utilisé pour concaténer les données. Puisque la valeur du champ de catégorie de chambre est calculée, la liaison par défaut est définie à Aucune.
8.
Une seule carte d'embarquement doit être imprimée sur une page et elle doit l'être selon une orientation paysage.
      •
      Le sous-formulaire boarding est appelé dès que des données se trouvent dans le groupe de données boarding.
      •
      Ce sous-formulaire a une valeur Min. de répétitions de 0 et une valeur d'occurrence maximale illimitée. Cela signifie qu'il ne sera appelé que si des données sont présentes et qu'il se répétera autant de fois que cela est nécessaire pour imprimer toutes les données.
      •
      Le sous-formulaire boarding est associé à la page type paysage. Il prendra la position Haut de la page « paysage », forçant ainsi une nouvelle page.


Modèle de demande de subvention

A propos du modèle de demande de subvention
Pour ouvrir le modèle de demande de subvention
A propos du formulaire de demande de subvention


A propos du modèle de demande de subvention

Le modèle de demande de subvention illustre le fonctionnement d'un formulaire PDF interactif. Pour obtenir plus de renseignements sur la création et l'utilisation de formulaires interactifs, reportez-vous à l'aide de LiveCycle Designer.
Remplissez la demande de subvention de l'institution ou de la fondation qui a émis le formulaire.
Le modèle inclut le fichier suivant :
Formulaire
Grant Application.pdf
La conception de formulaire et le formulaire avec lesquels l'utilisateur interagit sont tous deux situés dans le dossier Forms.


Pour ouvrir le modèle de demande de subvention

1.
Ouvrez le formulaire dans Fichier\Ouvrir\FR\Samples\Grant Application\Forms\Grant Application.pdf dans Acrobat ou Adobe Reader.
2.
Cliquez dans le champ Titre du projet, puis commencez à remplir le formulaire.


A propos du formulaire de demande de subvention

Le formulaire dispose de plusieurs fonctions.
Numérotation de pages
Les numéros de page sont des valeurs calculées que l'on obtient en insérant une propriété d'exécution dans un objet de texte.
Nombre maximal de caractères pour chaque champ
L'option Nombre max. de caractères (située dans l'onglet Champ de la palette Objet) pour chaque champ est conforme aux spécifications définies.
Champ multiligne
L'option Permettre des lignes multiples du champ de description, située dans l'onglet Champ de la palette Objet, est activée afin que les utilisateurs puissent entrer plusieurs lignes de description.
Modèles d'image
L'utilisateur doit entrer certaines valeurs dans un format précis. Un message de validation, défini dans l'onglet Valeur de la palette Objet, invitera l'utilisateur à entrer les valeurs dans le format approprié s'il ne l'a pas fait. Par exemple, un script validera la valeur entrée par l'utilisateur dans le champ des coûts budgétaires directs.
Objets de bibliothèque personnalisés
Un objet de bibliothèque personnalisé a été utilisé pour créer les listes déroulantes des provinces (adresse postale et organisme demandeur).
Ordre de tabulation
L'ordre de tabulation a été modifié de manière à permettre un enchaînement logique des colonnes. Pour afficher l'ordre de tabulation, sélectionnez l'option Ordre de tabulation du menu Affichage.


Modèles de bons de commande

A propos des modèles de bons de commande
Pour ouvrir les modèles de bons de commande


A propos des modèles de bons de commande

Les quatre modèles de bons de commande illustrent le fonctionnement de formulaires PDF dynamiques, interactifs et les deux à la fois.
Les modèles incluent les fichiers suivants :
Bon de commande dynamique
Formulaire | Purchase Order.xdp | Fichier de formulaire LiveCycle Designer situé dans le dossier Forms.
Données | Purchase Order.xml | Fichier de données XML situé dans le dossier Data.
Image | Purchase Order.tif | Fichier image situé dans le dossier Images.
Sortie | Purchase Order.pdf | Formulaire généré avec données situé dans le dossier Outputs.
Bon de commande interactif dynamique
Formulaire | Purchase Order.pdf | La conception de formulaire et le formulaire avec lesquels l'utilisateur interagit, tous deux situés dans le dossier Forms.
Image | Purchase Order.tif | Fichier image situé dans le dossier Images.
Bon de commande interactif
Formulaire | Purchase Order.pdf | La conception de formulaire et le formulaire avec lesquels l'utilisateur interagit, tous deux situés dans le dossier Forms.
Image | Purchase Order.tif | Le fichier image situé dans le dossier Images.
Bon de commande schématique
r
Formulaire | Purchase Order.xdp | Fichier de formulaire LiveCycle Designer situé dans le dossier Forms.
Données | Purchase Order.xml | Fichier de données XML situé dans le dossier Data.
Schéma | Purchase Order.xsd | Fichier schéma situé dans le dossier Schema.
Image | Purchase Order.tif | Fichier image situé dans le dossier Images.
Sortie | Purchase Order.pdf | Formulaire généré avec données situé dans le dossier Outputs.


Pour ouvrir les modèles de bons de commande

Bon de commande dynamique et schématique
1.
Dans LiveCycle Designer, ouvrez le formulaire désiré :
      •
      \FR\Samples\Purchase Order\Dynamic\Forms\Purchase Order.xdp
      •
      \FR\Samples\Purchase Order\Schema\Forms\Purchase Order.xdp
2.
Pour définir les options d'aperçu, choisissez Fichier > Propriétés du formulaire. Cliquez sur l'onglet Valeurs par défaut et effectuez les opérations suivantes :
      •
      Dans la liste Type d'aperçu, sélectionnez Formulaire pour impression.
      •
      Dans la zone Fichier de données, parcourez l'arborescence des fichiers jusqu'au dossier Data et sélectionnez le modèle de fichier de données Purchase Order.xml.
      •
      Cliquez sur OK.
3.
Pour afficher un aperçu du formulaire, cliquez sur l'onglet Aperçu PDF.
Le modèle de fichier PDF situé dans le dossier Outputs illustre le formulaire généré avec des données. Servez-vous de ce fichier pour comparer le résultat final avec celui de l'aperçu du formulaire.
Bon de commande interactif ou interactif et dynamique
1.
Dans Acrobat ou Adobe Reader, ouvrez le formulaire désiré :
      •
      \FR\Samples\Purchase Order\Interactive\Forms\Purchase Order.xdp
      •
      \FR\Samples\Purchase Order\Dynamic Interactive\Forms\Purchase Order.xdp
2.
Cliquez dans le champ N° de bon de commande, puis commencez à remplir le formulaire.
L'exemple de fichier PDF situé dans le dossier Outputs illustre le formulaire généré avec des données. Servez-vous de ce fichier pour comparer le résultat final avec celui de l'aperçu du formulaire.


Modèle de script

A propos du modèle de script
Pour ouvrir le modèle de script


A propos du modèle de script

Le modèle de script vous aide à rédiger un script en utilisant les langages FormCalc et JavaScript. Vous pouvez écrire un script dans un champ de saisie, puis l'exécuter en cliquant sur un bouton. Ce modèle comprend différents types de champ pouvant être utilisés par le script.
Le modèle inclut le fichier suivant :
Formulaire
Scripting.pdf
La conception de formulaire et le formulaire avec lesquels l'utilisateur interagit, tous deux situés dans le dossier Forms.


Pour ouvrir le modèle de script

1.
Ouvrez le formulaire \FR\Samples\Scripting\Forms\Scripting.pdf dans Acrobat ou Adobe Reader.
2.
Tapez un script dans le champ Entrez votre script ici.
3.
Entrez les valeurs attendues par le script.
4.
Cliquez sur le bouton approprié pour lancer l'exécution du script. Les résultats s'affichent dans le champ Résultat. Vous pouvez si vous le souhaitez afficher les résultats dans un autre champ.
5.
Après avoir exécuté le script, cliquez sur le bouton Effacer les champs de saisie pour modifier le script ou en réécrire un autre.
Pour tester un script simple, utilisez l'un des exemples proposés.
JavaScript
if (NF1.rawValue < NF2.rawValue)
    NF3.rawValue = 0
else
    NF3.rawValue = NF1.rawValue - NF2.rawValue
FormCalc
if (NF1 < NF2) then
    NF3 = 0
else
    NF3 = NF1 - NF2
endif
Ces deux scripts font appel aux champs numériques NF1, NF2 et NF3. L'utilisateur peut entrer des nombres dans les champs NF1 et NF2 ; à l'exécution, le script soustrait un nombre de l'autre (NF1-NF2) et affiche la différence dans le champ NF3. Si le résultat est négatif, la valeur du champ NF3 est définie à 0.


Modèle de jeu de sous-formulaires

A propos du modèle de jeu de sous-formulaires
Pour ouvrir le modèle de jeu de sous-formulaires
A propos de l'impression du jeu de sous-formulaires


A propos du modèle de jeu de sous-formulaires

Le modèle de jeu de sous-formulaires illustre le fonctionnement d'un formulaire PDF dynamique. Il est composé de quatre sous-modèles qui démontrent le fonctionnement de l'appel de l'objet de jeu de sous-formulaires lorsque le type de relation et les valeurs d'occurrence de ce dernier sont variables. Le modèle de formulaire contient des notes numérotées, représentées par des cercles noirs avec un nombre blanc. Pour obtenir de plus amples informations sur ces notes, reportez-vous à la section A propos de l'impression du jeu de sous-formulaires.
Le modèle inclut les fichiers suivants :
Formulaire | SubformSet1.xdp SubformSet2.xdp SubformSet3.xdp SubformSet4.xdp | Fichier de formulaire LiveCycle Designer situé dans le dossier Forms.
Données | DataA.xml DataB.xml | Fichiers de données XML situés dans le dossier Data.
Sortie | SubformSet1 DataA.pdf SubformSet1 DataB.pdf SubformSet2 DataA.pdf SubformSet2 DataB.pdf SubformSet3 DataA.pdf SubformSet3 DataB.pdf SubformSet4 DataA.pdf SubformSet4 DataB.pdf | Formulaires générés avec données situés dans le dossier Outputs.


Pour ouvrir le modèle de jeu de sous-formulaires

1.
Ouvrez l'un des formulaires dans le dossier \FR\Samples\SubformSet\Forms de LiveCycle Designer.
2.
Pour définir les options d'aperçu, choisissez Fichier > Propriétés du formulaire. Cliquez sur l'onglet Valeurs par défaut et effectuez les opérations suivantes :
      •
      Dans la liste Type d'aperçu, sélectionnez Formulaire pour impression.
      •
      Dans la zone Fichier de données, parcourez l'arborescence des fichiers jusqu'au dossier Data et sélectionnez l'un des modèles de fichiers de données tel que DataA.xml.
      •
      Cliquez sur OK.
3.
Pour afficher un aperçu du formulaire, cliquez sur l'onglet Aperçu PDF.
Les modèles de fichiers PDF situés dans le dossier Outputs illustrent le résultat obtenu après la fusion des deux jeux de données dans le formulaire. Servez-vous de ces fichiers pour comparer le résultat final avec celui de l'aperçu du formulaire.


A propos de l'impression du jeu de sous-formulaires

Les numéros des commentaires suivants correspondent à ceux des cercles noirs que vous trouverez dans le modèle de formulaire de jeu de sous-formulaires.
Données
Deux fichiers de données sont utilisés avec ce modèle de formulaire. La présente section donne le nom du fichier dont les données sont fusionnées dans le formulaire et décrit son contenu. Cette information est particulièrement utile pour comparer les données affichées dans la section 3, « Relation ».
Occurrences du sous-formulaire
Chaque formulaire comporte trois sous-formulaires. Cette section donne la valeur d'occurrence et les valeurs Min. de répétitions et Max. des sous-formulaires. Les valeurs d'occurrence sont spécifiées dans l'onglet Liaison de la palette Objet.
Spécification des sous-formulaires pour chacun des formulaires

Sous-formulaire A

Sous-formulaire B

Sous-formulaire C
SubformSet1.xdp
Min. de répétitions = 0 Max. =−1*
Min. de répétitions = 0 Max. =−1*
Min. de répétitions = 0 Max. =−1*
SubformSet2.xdp
Min. de répétitions = 0 Max. = 1
Min. de répétitions = 0 Max. = 1
Min. de répétitions = 0 Max. = 1
SubformSet3.xdp
Min. de répétitions = 1 Max. = 1
Min. de répétitions = 1 Max. = 1
Min. de répétitions = 1 Max. = 1
SubformSet4.xdp
Min. de répétitions = 2 Max. = 2
Min. de répétitions = 1 Max. = 1
Min. de répétitions = 3 Max. = 3
* La valeur Max. est illimitée si l'option Sous-formulaire pour chaque élément (située dans l'onglet Liaison de la palette Objet) est activée et si l'option Max. est désactivée.
Relation
La troisième section affiche trois colonnes qui sont utilisées pour comparer la disposition des sous-formulaires par rapport à différents types de relation :

Colonne

Type

Commentaires
1
Utiliser tous les sous-formulaires dans l'ordre
Les sous-formulaires sont appelés dans l'ordre selon lequel ils ont été énoncés dans le formulaire. Il peut donc se produire un réordonnancement du contenu pour respecter l'ordre des éléments du formulaire.
2
Sélectionner un sous-formulaire parmi les sous-formulaires de remplacement
Les sous-formulaires sont mutuellement exclusifs. Un seul sous-formulaire peut donc être appelé. Ce sont les données qui déterminent le sous-formulaire à appeler.


Modèle de reçu pour déclaration fiscale

A propos du modèle de reçu pour déclaration fiscale
Pour ouvrir le modèle de reçu pour déclaration fiscale
A propos du formulaire de reçu pour déclaration fiscale


A propos du modèle de reçu pour déclaration fiscale

Le modèle de reçu pour déclaration fiscale illustre le fonctionnement d'un formulaire PDF dynamique.
Ce formulaire imprime trois copies du reçu sur une même page : la copie de la fondation, la copie de l'émetteur du reçu et la copie pour déclaration fiscale.
Le modèle inclut les fichiers suivants :
Formulaire | Tax Receipt.xdp | Fichier de formulaire LiveCycle Designer situé dans le dossier Forms.
Données | Tax Receipt.xml | Fichier de données XML situé dans le dossier Data.
Image | Signature.tif Tax Receipt.tif | Fichiers image situés dans le dossier Images.
Sortie | Tax Receipt.pdf | Formulaire généré avec données situé dans le dossier Outputs.


Pour ouvrir le modèle de reçu pour déclaration fiscale

1.
Ouvrez le formulaire intitulé Tax Receipt.xdp dans LiveCycle Designer.
2.
Pour définir les options d'aperçu, choisissez Fichier > Propriétés du formulaire. Cliquez sur l'onglet Valeurs par défaut et effectuez les opérations suivantes :
      •
      Dans la liste Type d'aperçu, sélectionnez Formulaire pour impression.
      •
      Dans la zone Fichier de données, parcourez l'arborescence des fichiers jusqu'au dossier Data et sélectionnez le modèle de fichier de données Tax Receipt.xml.
      •
      Cliquez sur OK.
3.
Pour afficher un aperçu du formulaire, cliquez sur l'onglet Aperçu PDF.
Le modèle de fichier PDF situé dans le dossier Outputs illustre le formulaire généré avec des données. Servez-vous de ce fichier pour comparer le résultat final avec celui de l'aperçu du formulaire.


A propos du formulaire de reçu pour déclaration fiscale

Le formulaire dispose de plusieurs fonctions.
Structure hiérarchique du formulaire
Le formulaire de reçu pour déclaration fiscale est fondé sur la structure de données, permettant ainsi de tirer profit du processus implicite de liaison de données.
Page type
Puisque le texte du bas de page doit être affiché dans la portion inférieure de chacune des pages, il doit être défini dans la page type.
Contenu avec enchaînement
Les occurrences du sous-formulaire receipt sont placées les unes en dessous des autres lorsque le contenu du sous-formulaire taxReceipt est défini à Distribué. Cette option est située dans l'onglet Sous-formulaire de la palette Objet. L'option Enchaînement, également située dans l'onglet Sous-formulaire, est définie à Haut vers le bas. Les marges du sous-formulaire sont définies dans la palette Disposition et ajoutent l'espace nécessaire entre deux sous-formulaires.
Occurrences du sous-formulaire
Le sous-formulaire receipt contient les données du reçu pour déclaration fiscale, y compris les champs et les éléments statiques. Puisque le reçu est censé s'imprimer trois fois sur une même page, la valeur Max. du sous-formulaire de reçu est définie à 3. Cette valeur est définie dans l'onglet Liaison de la palette Objet.
Champs globaux
Les renseignements sur le donateur sont indiqués une seule fois dans le fichier de données. En définissant ces champs comme étant globaux, les valeurs qu'ils contiennent sont imprimées sur chacune des copies du reçu pour déclaration fiscale.
Champ d'image
Étant donné que la signature du trésorier peut varier, le lien vers l'image de signature est fourni dans le fichier de données. Un champ d'image est utilisé pour afficher l'image de signature.
Nombre maximal de caractères pour chaque champ
Le nombre maximal de caractères pour chaque champ est défini dans l'onglet Champ de la palette Objet et est conforme aux spécifications définies.
Champs extensibles et position de l'ancre
Pour tenir compte des valeurs de taille variable, l'option Ajuster, située dans la palette Disposition, a été désactivée pour les champs du numéro et du destinataire du reçu. La position de l'ancre de ces champs est définie de manière à permettre une extension du champ dans la direction appropriée.
Script
Les valeurs d'adresses doivent être affichées en bloc. Un script JavaScript est utilisé pour concaténer les données. Puisque la valeur du champ d'adresse du donateur est calculée, la liaison par défaut est définie à Aucune. La liaison par défaut est définie dans l'onglet Liaison de la palette Objet.
Champ multiligne
L'option Permettre des lignes multiples du champ d'adresse du donateur, située dans l'onglet Champ de la palette Objet, est activée afin d'imprimer sur plusieurs lignes.
Modèles d'image
Afin de faciliter la lecture de certaines valeurs, il est possible d'appliquer un format d'affichage ; cette option est située dans l'onglet Champ de la palette Objet. Par exemple, la valeur de date est présentée dans un format long.


Glossaire

Glossaire

Ce glossaire comprend des définitions terminologiques qui sont propres à la documentation d'Adobe document services. Ces termes ont une signification qui est bien précise dans cette documentation mais qui peut être différente dans d'autres contextes.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
A
Adobe document services
Adobe document services élargit la portée des systèmes stratégiques d'une entreprise afin que l'information vitale soit saisie et accessible à toute l'entreprise. La solution Adobe document services inclut LiveCycle Designer, LiveCycle Forms, LiveCycle Reader Extensions, LiveCycle Form Manager et Document Security Server.
Application
Ensemble de fichiers connexes et généralement indépendants qui constituent une application autonome pouvant être exécutée par LiveCycle Forms. Cette application peut contenir des fichiers tels que des conceptions de formulaire, des pages JavaServer, des pages HTML, des servlets et des images.
Architecture de formulaires XML
Technologie sur laquelle repose la solution de formulaires XML d'Adobe. Elle permet de développer des applications de formulaire robustes et flexibles destinées au client ou au serveur.
Auteur de formulaire
Utilisateur de LiveCycle Designer habilité à créer des formulaires remplissables à utiliser dans Acrobat ou Adobe Reader et des formulaires non interactifs simples à déployer dans LiveCycle Forms. Voir aussi Développeur de formulaire.
Haut
C
Certificat
Clé publique associée à des informations d'identification (clé privée) qui permet d'effectuer des opérations de chiffrement et de signature. Voir aussi Document certifié Adobe.
Client
Personne ou programme demandant dans une relation client-serveur. Un navigateur Web est un exemple d'application client.
Conception de formulaire
Version d'un formulaire au moment de sa conception dans LiveCycle Designer.
Haut
D
Développeur de formulaire
Utilisateur de LiveCycle Designer capable de créer des applications de formulaire complexes destinées à différents environnements. Voir aussi Auteur de formulaire.
Disposition fixe
Formulaire dont la disposition reste identique à celle d'origine, une fois que le formulaire est rempli. La disposition ne varie pas en fonction de la quantité de données d'entrée.
Document accessible selon les droits
Document PDF comprenant des extensions de sécurité permettant aux utilisateurs d'Adobe Reader d'enregistrer le formulaire avec son contenu, d'y insérer des commentaires et de signer des documents.
Document Adobe certifié
Document signé à l'aide d'un certificat racine propre à Adobe. Le certificat racine d'Adobe est distribué par le biais d'un dispositif de sécurité électronique. Un document certifié Adobe fournit une forte garantie quant à son authenticité et son immutabilité. Voir aussi Certificat.
Document protégé
Document PDF protégé par un mot de passe qui empêche l'ouverture, l'impression, l'enregistrement ou la modification du document.
Droits d’utilisation
Droits qui augmentent la fonctionnalité d'Adobe Reader et permettent aux utilisateurs d'enregistrer des formulaires avec des données, d'ajouter des commentaires et de signer des documents.
Droits d'accès
Paramètres de sécurité permettant de contrôler l'ouverture, la modification et l'impression d'un document PDF. Il n'est pas possible de modifier les droits d'accès à moins de connaître le mot de passe correspondant. Vous pouvez définir les droits d'accès dans LiveCycle Designer, Acrobat ou LiveCycle Forms.
Haut
F
Flux de production
Processus qui concerne l'acheminement automatique des données d'un formulaire, entre les services, les personnes et les systèmes, dans une séquence prédéfinie.
Format canonique
Méthode standard d'écriture d'une formule. Par exemple, les deux formules, telles que 9 + x et x + 9, sont considérées comme équivalentes car elles ont la même signification, mais la seconde est au format canonique, car elle est écrite de façon standard, avec la puissance la plus élevée de x en premier. En général, vous pouvez utiliser des règles fixes afin de déterminer si le format canonique est appliqué ou non. Il est plus facile de comparer des éléments au format canonique.
Le tableau ci-dessous décrit les différents types de champs et leur format canonique. Notez que les valeurs entre crochets sont facultatives. Les symboles de regroupement et les symboles monétaires ne sont pas valides au format canonique.

Type de champ

Description

Format canonique

Exemple
Champs de date
Chaîne de date ISO-8601/XFA
YYYY[-MM[-DD]]
YYYY[MM[DD]]
2005-07-04
20050704
Champs de date et heure
Date/heure ISO-8601/XFA, qui est la concaténation d'une chaîne de date ISO-8601/XFA valide et d'une chaîne d'heure ISO-8601/XFA valide avec la lettre 'T' comme séparateur entre ces deux chaînes
2004-07-04T10:11:12+05:00
20040704T101112
Champs numériques
Séquence de chiffres ASCII constituée d'un entier, d'un point décimal, d'une fraction et éventuellement, d'un e (ou E) et d'un exposant avec signe
12
1.234
.12
1e-2
1.2E3
Champs de texte
Séquence constituée de caractères Unicode sans espaces
A1B2C3
Format d'affichage : A9A 9A9
Valeur formatée : A1B 2C3
Champs d'heure
Chaîne d'heure ISO-8601/XFA
HH[:MM[:SS[.FFF][Z]]]
HH[:MM[:SS[.FFF][+HH[:MM]]]]
HH[:MM[:SS[.FFF][-HH[:MM]]]]
HH[MM[SS[.FFF][Z]]]
HH[MM[SS[.FFF][+HH[MM]]]]
HH[MM[SS[.FFF][-HH[MM]]]]
10:11:12.123+05:00
101112+0500
10:11:12Z
10:11
10
FormCalc
Langage de calcul similaire à celui utilisé par les tableurs courants. Il facilite la conception de formulaires sans nécessiter de connaissances sur les techniques et les langages de script.
Formulaire
Document électronique permettant de saisir et de fournir des données. Une personne ajoute des données à un formulaire interactif ou un serveur fusionne une conception de formulaire avec les données afin de produire un formulaire.
Formulaire accessible
Formulaire que les utilisateurs ayant des incapacités ou une déficience visuelle peuvent remplir à l'aide d'un lecteur d'écran ou d'un autre dispositif d'assistance.
Formulaire Acrobat
Document PDF créé dans Acrobat contenant un ou plusieurs champs de formulaire. Les formulaires Acrobat peuvent également comprendre des zones qui ne sont pas propres aux formulaires.
Formulaire interactif
Formulaire qu'un utilisateur peut remplir électroniquement et avec lequel il peut interagir.
Formulaire PDF
Formulaire accessible à l'aide d'Acrobat et d'Adobe Reader. Un formulaire PDF peut être interactif ou non.
Formulaire PDF balisé
Formulaire qui comprend une structure logique et un ensemble d'éléments reliés les uns aux autres par des relations et des dépendances. Des données supplémentaires permettent également le réacheminement de l'information.
Formulaire pré-rempli
Formulaire dont les valeurs de certains ou de tous les champs sont automatiquement définies lorsque l'utilisateur final l'affiche.
Formulaire statique
Voir Disposition fixe.
Formulaire XML
Formulaire articulé autour de l'architecture de formulaires XML. LiveCycle Designer permet de créer des fichiers de formulaire XML qui portent l'extension .xdp ou .pdf.
Haut
G
Gestionnaire de protection
Module logiciel ayant pour fonction de mettre en oeuvre différents aspects du processus de chiffrement et de contrôler l'accès au contenu du document chiffré. Il intègre toute la logique de sécurité nécessaire et définit notamment les méthodes de signature et le mode de validation des signatures.
Haut
I
Identité approuvée
Identité reconnue par le certificat associé. Seules les identités approuvées spécifiées ont le droit de signer un formulaire.
Informations d'identification
Clé privée permettant d'établir l'identité d'un utilisateur lors des opérations de déchiffrement et de signature.
Haut
L
Liaison de données
Action de lier un objet au champ approprié dans un fichier de données ou une base de données.
Haut
O
Objet de formulaire
Elément, tel qu'un bouton ou un champ de texte, que vous placez sur un formulaire. L'objet comporte son propre ensemble de propriétés et d'événements.
Objet standard
Objet statique d'un formulaire tel que du texte, une ligne, un cercle ou un rectangle.
Haut
R
Référentiel LiveCycle Form Manager
Référentiel accessible aux utilisateurs et aux applications qui disposent des droits appropriés, pour stocker et extraire des formulaires et des fichiers d'application connexes.
Rendu
Opération exécutée par LiveCycle Forms pour extraire une conception de formulaire, la fusionner avec des données (le cas échéant), puis l’afficher au format PDF ou HTML dans un navigateur.
Haut
S
Sous-formulaire
Section d'une conception de formulaire qui permet de créer un formulaire avec une disposition souple. Le sous-formulaire peut contenir du texte, des images ou des champs.
Standard
Objet statique ou fixe, y compris du texte ou une image, qui représente une des composantes visuelles d'une conception de formulaire. A la différence d'un champ de données, l'information relative à un élément standard ne change jamais.
Haut
T
Temps d'exécution
Moment où une application ou un serveur récupère une conception de formulaire, la fusionne éventuellement avec des données et la présente à un utilisateur pour affichage ou remplissage.
Haut


Avis de copyright et de marques de commerce

Avis de copyright et de marques de commerce

© 2006 Adobe Systems Incorporated. Tous droits réservés.
Adobe® LiveCycle® Designer 8.0 - Aide pour Microsoft® Windows®
Octobre 2006
Lorsque le présent guide est distribué avec un logiciel assujetti à un contrat de licence, le guide et le logiciel qu'il décrit sont régis par la licence et ne peuvent être utilisés ou copiés qu'en conformité avec les conditions de ladite licence. A moins d’une autorisation expresse accordée par cette licence, aucune partie de ce guide ne peut être reproduite, stockée dans un système d’interrogation ou transmise, sous quelque forme ou par quelque moyen que ce soit (électronique, mécanique, par enregistrement ou autre) sans l’autorisation écrite préalable d’Adobe Systems Incorporated. Veuillez noter que le contenu du présent guide est protégé par la loi sur les droits d’auteur, même s’il n’est pas distribué avec un logiciel régi par un contrat de licence utilisateur.
Les informations contenues dans ce guide sont fournies à titre purement informatif ; elles sont susceptibles d’être modifiées sans préavis et ne doivent pas être interprétées comme étant un engagement de la part d'Adobe Systems Incorporated. Adobe Systems Incorporated n’accepte aucune responsabilité quant aux erreurs ou inexactitudes pouvant être contenues dans le présent guide.
Veuillez noter que les illustrations et images existantes que vous souhaiterez éventuellement inclure dans votre projet sont susceptibles d’être protégées par les lois sur les droits d’auteur. L’inclusion non autorisée de tels éléments dans vos nouveaux travaux peut constituer une violation des droits du propriétaire. Veuillez vous assurer de détenir toute autorisation nécessaire auprès du détenteur des droits.
Toute référence à des noms et à des logos de société dans le matériel ou les formulaires d’exemple inclus dans le présent logiciel n’est faite qu’à titre de démonstration et ne vise aucun organisme réel.
Adobe, le logo Adobe, Acrobat, Distiller, LiveCycle, Minion, Myriad, PostScript et Reader sont des marques ou des marques déposées d'Adobe Systems Incorporated aux Etats-Unis et/ou dans d'autres pays.
Microsoft, Windows et ActiveX sont des marques ou marques déposées de Microsoft Corporation aux Etats-Unis et/ou dans certains autres pays.
SVG est une marque de World Wide Web Consortium ; les marques du W3C sont déposées et détenues par ses institutions hôte MIT, INRIA et Keio.
Toutes les autres marques citées sont la propriété de leurs détenteurs respectifs.
Ce produit contient des éléments logiciels développé par Apache Software Foundation (http://www.apache.org/).
Adobe Systems Incorporated, 345 Park Avenue, San Jose, California 95110, USA.
Avis aux utilisateurs du gouvernement des Etats-Unis. Le logiciel et la documentation sont des « articles commerciaux », conformément à la définition du terme « Commercial Items » dans l'article 48 C.F.R. §2.101 du Code de la réglementation fédérale (Code Of Federal Regulations), qui consistent en du « logiciel informatique commercial » et de la « documentation logicielle commerciale », tel qu'il est mentionné dans les articles 48 C.F.R. §12.212 et 48 C.F.R. §227.7202. Conformément aux articles 48 C.F.R. §12.212 et 48 C.F.R. §§227.7202-1 à 227.7202-4, le logiciel commercial et la documentation logicielle commerciale sont fournis sous licence aux utilisateurs du gouvernement des Etats-Unis (a) uniquement à titre d’articles commerciaux (b) et leur confèrent seulement les droits octroyés à tous les autres utilisateurs selon les conditions mentionnées aux présentes. Droits non publiés réservés dans le cadre des lois sur les droits d’auteur en vigueur aux Etats-Unis. Adobe Systems Incorporated, 345 Park Avenue, San Jose, CA 95110, USA. Pour les utilisateurs du gouvernement des Etats-Unis, Adobe s’engage à respecter la législation relative à l’égalité des chances y compris, le cas échéant, les dispositions du décret 11246, tel qu’amendé, à la section 402 de la loi sur l’assistance aux vétérans du Vietnam (Vietnam Era Veterans Readjustment Assistance Act) de 1974 (38 USC 4212), et à la section 503 de la loi sur la réadaptation (Rehabilitation Act) de 1973, telle qu’amendée, et la réglementation des articles 41 CFR, alinéas 60-1 à 60-60, 60-250 et 60-741. La clause d’action positive et la réglementation décrites dans la phrase précédente sont incluses par référence.