Willkommen bei Adobe LiveCycle Designer

Willkommen bei Adobe LiveCycle Designer

Willkommen bei Adobe® LiveCycle® Designer


Grundlegende Kenntnisse erwerben

Grundlegende Kenntnisse erwerben

Grundlagen zu LiveCycle Designer
Arbeitsbereich
Grundlagen zu Formularen


Grundlagen zu LiveCycle Designer

Info über LiveCycle Designer
Neuheiten
Zusätzliche Dokumentation, Beispiele und Übungen
LiveCycle Designer und Adobe Document Services


Info über LiveCycle Designer

Adobe® LiveCycle® Designer ist ein grafisches Formularentwurfsprogramm mit Point-und-Klick-Funktion. Es vereinfacht die Erstellung von Formularentwürfen, die dann als Adobe-PDFs weitergegeben werden können. Die Empfänger können ein Formular online ausfüllen, die Daten senden und anschließend das Formular drucken. Alternativ können sie das Formular auch ausdrucken und mit Adobe Reader® von Hand ausfüllen.
In LiveCycle Designer können Formularverfasser Bilder und andere Objekte wie Listenfelder, Dropdown-Listen und Befehlsschaltflächen auf ihre Formulare ziehen und dort ablegen. Sie können ein Formular entwerfen, die zugehörige Logik definieren, es exakt an das in Papierform vorliegende Original sowie an gesetzliche Vorgaben anpassen und dann eine Vorschau des Formulars anzeigen, bevor es weitergegeben wird.
LiveCycle Designer bietet jedoch noch weitere Möglichkeiten, die über die bloße Formularerstellung hinausgehen. Formularverfasser können einfache Lösungen zur elektronischen Datenerfassung erstellen und die Daten, die sie den ausgefüllten Formularen entnehmen, mit Adobe Acrobat® Professional konsolidieren. Darüber hinaus haben Formularentwickler mit LiveCycle Designer die Möglichkeit, Datenerfassungslösungen zu erstellen und zu verwalten, die Daten aus Unternehmensquellen lesen, auf ihrer Grundlage Gültigkeitsprüfungen durchführen und diesen Quellen neue Daten hinzufügen. Mit LiveCycle Designer lassen sich PDF-Dokumente durch Bindung von Formularen an XML-Schemas, XML-Beispieldateien, Datenbanken und Webdienste in bestehende Arbeitsabläufe integrieren. Mit LiveCycle Forms können Sie sowohl HTML-Formulare als auch PDF-Formulare wiedergeben.
Verwandte Themen
Neuheiten


Neuheiten

Es folgt eine Auflistung der Neuheiten in Adobe LiveCycle Designer 8.0:
PDF-Dokumente importieren
Formulare verteilen
Rechtschreibprüfung
Digitale Unterschriften
Vorlagen importieren
Vorlagen anpassen
Zellen aus einer Tabelle kopieren
Feldeditor
Testdaten erstellen
Datenverbindungen mit nicht lokalen XML-Schemas
Kombinationsfelder
Kontrollkästchen- und Schaltflächenstile
PDF-Dokumente importieren
Sie können ein PDF-Dokument als Hintergrundgrafik importieren, um das Original-Layout und -Erscheinungsbild des Dokuments beizubehalten oder um die Datei als bearbeitbaren Inhalt importieren. Wenn Sie ein PDF-Dokument importieren, das in Acrobat als Hintergrundgrafik erstellt wurde und Formularfelder enthält, konvertiert LiveCycle Designer diese Felder in die entsprechenden Bibliotheksobjekte. Anschließend können Sie alle interaktiven Objekte bearbeiten und neue Bibliotheksobjekte über den Grafiken platzieren. Wenn Sie ein PDF-Dokument als Hintergrundgrafik importieren möchten, wählen Sie im Assistenten für neue Formulare die Option „Interaktives Formular mit fixierten Seiten erstellen“ aus. Wenn Sie ein PDF-Dokument in LiveCycle Designer als bearbeitbaren Inhalt importieren möchten, wählen Sie die Option „Interaktives Formular mit flexiblem Layout erstellen“ aus.
Formulare verteilen
Wenn Sie einen Formularentwurf in LiveCycle Designer fertiggestellt haben, können Sie die Funktion zum Verteilen in Adobe Acrobat verwenden, um das Formular zum Ausfüllen an eine Gruppe von Empfängern zu senden. Mit Hilfe der Funktion zum Verteilen können Sie Anweisungen zum Ausfüllen des Formulars mit dem Formular versenden. Wenn die Empfänger das Formular ausgefüllt haben, klicken sie auf die Schaltfläche „Senden“ auf dem Formular. Das Formular wird dann mit den Informationen an Sie zurück gesendet.
Rechtschreibprüfung
Die neue Rechtschreibprüfung überprüft den Text bei der Eingabe oder führt eine globale Rechtschreibprüfung durch, wenn Sie einen Formularentwurf fertiggestellt haben. Zusätzlich sind Optionen verfügbar, mit denen Sie die zu verwendenden Wörterbucher und die Elemente, die Sie in die Rechtschreibprüfung einschließen möchten, auswählen können.
Digitale Unterschriften
Sie können jetzt zwei Arten von digitalen Unterschriften in LiveCycle Designer verwenden: Dokumentunterschriften und Datenunterschriften. Dokumentunterschriften schützen Felder und die zugehörigen Werte. Sie können Dokumentunterschriften auf ein gesamtes Formular oder auf eine Sammlung von Feldern anwenden. Dokumentunterschriften gelten für Schaltflächen, Kontrollkästchen, Datums-/Uhrzeitfelder, Dezimalfelder, Dropdown-Listen, Bildfelder, Listenfelder, numerische Felder, Papierformular-Barcodes, Kennwortfelder, Optionsfelder, andere Dokumentunterschriftsfelder und Textfelder. Datenunterschriften schützen die Formulardaten und gewährleisten die Datenintegrität während der Übertragung. Sie können nur für die Daten oder für die gesamte Übertragung gelten. Sie können Datenunterschriften nur für die gesamte Übertragung auf die Daten anwenden.
Vorlagen importieren
Sie können jetzt Vorlagendateien (TDS) in den Vorlagen-Manager importieren. Wenn Sie eine Vorlage importieren, wird eine Kopie automatisch entweder im Vorlagenordner, der im XML-Quellcode des Formulars angegeben ist, oder im Importordner (wenn keine Position angegeben ist) hinzugefügt. Wenn Sie die Vorlage importiert haben, können Sie basierend auf der Vorlage ein neues Formular erstellen oder die Vorlage bearbeiten.
Vorlagen anpassen
Die mit LiveCycle Designer installierten Vorlagen enthalten Texte und Bilder, die Sie durch den Namen, die Adresse, die Telefonnummer und das Logo Ihres Unternehmens ersetzen können. Wenn Sie ein Formular anhand einer Vorlage erstellen, die Felder mit anpassbarem Text oder anpassbaren Bildern enthält, wird der Assistent für neue Formulare angezeigt, um Ihnen die Gelegenheit zu geben, die in den Feldern angezeigten Informationen an Ihre Anforderungen anzupassen.
Sie können jetzt den Assistenten für neue Formulare verwenden, um auf den Tabellenspalten basierend ein neues Formular zu erstellen. LiveCycle Designer erstellt aus jeder Spalte, die Sie in der Tabelle auswählen, ein Textfeld. Der Name der einzelnen Kopfzeilen in den Spalten wird als Name für die Textfeldbeschreibungen übernommen.
Zellen aus einer Tabelle kopieren
Sie können Zellen direkt aus einer Tabelle in LiveCycle Designer kopieren oder ziehen. Aus den in der Tabelle ausgewählten Zellen erstellt LiveCycle Designer ein Tabellenobjekt mit denselben Abmessungen und demselben Inhalt. Die Formatierung wird bestmöglich erhalten. Die leeren Zellen in der Tabelle enthalten Textfelder. Wenn der Originalabschnitt Kopfzeilen in den Spalten enthält, werden diese als Kopfzeile erhalten.
Feldeditor
Sie können jetzt im Formularentwurf enthaltene Objekte mit Hilfe des Feldeditors bearbeiten. Der Feldeditor vereinfacht den Zugriff auf allgemeine Eigenschaften. Sie können den Feldeditor im Menü „Ansicht“ aktivieren.
Testdaten erstellen
Statt Musterdatendateien zu erstellen, können Sie jetzt Musterdaten generieren, um Ihre Formulare in der Vorschau anzuzeigen und zu testen. Wenn ein Formular sich wiederholende Teilformulare oder Teilformularsätze enthält, können Sie bei der Formularvorschau angeben, wie oft die Daten wiederholt werden. Die Testdaten werden im Dialogfeld „Formulareigenschaften“ auf der Registerkarte „Standard“ eingerichtet.
Datenverbindungen mit nicht lokalen XML-Schemas
Sie können jetzt eine XML-Schema-Datenverbindung erstellen, indem Sie ein Schema verwenden, das sich nicht auf Ihrem lokalen System befindet. Wenn Sie eine neue Datenverbindung erstellen, geben Sie die URL zur XML-Schemadatei ein. Das Laden des Schemas funktioniert genauso wie auf dem lokalen System.
Kombinationsfelder
Sie können jetzt das Zeichenformat verwenden, wenn Sie Zeichen und Zahlen voneinander trennen möchten, die zu Dezimalfeldern und numerischen Feldern hinzugefügt werden. In einem Kombinationsfeld werden die einzelnen Buchstaben des Feldes durch eine schwarze vertikale Linie voneinander getrennt, die von der oberen bis zur unteren Kante des Feldes reicht.
Kontrollkästchen- und Schaltflächenstile
Sie können jetzt unterschiedliche Stile für Kontollkästchen und Schaltflächen wählen. Wenn Sie ein Kontrollkästchen aktivieren, werden in der Palette „Objekt“ auf der Registerkarte „Feld“ mehrere Formatierungsoptionen angezeigt. Sie können den Kontrollkästchenstil auf ein Häkchen, einen Kreis, ein Kreuz, ein Karo, ein Quadrat oder einen Stern festlegen. Wenn Sie Schaltflächen erstellen, können Sie eine Markierung darauf anwenden, die Schaltfläche vertieft darstellen oder nach dem Klicken eine Umrisslinie um eine Schaltfläche anzeigen. Ein weiterer Effekt, den Sie auf Schaltflächen anwenden können, ist das Bewegen des Mauszeigers über Beschriftungen. Schaltflächenstile werden in der Palette „Objekt“ auf der Registerkarte „Feld“ festgelegt.


Zusätzliche Dokumentation, Beispiele und Übungen

Verschiedene Ressourcen sind verfügbar, um Sie beim Erstellen von Formularen mit LiveCycle Designer zu unterstützen.

Ressource

Ort:
Lernprogramme zum Erstellen von Formularen mit LiveCycle Designer.
LiveCycle Designer-Hilfe
Formularmuster, die leichte bis schwere Techniken zum Formularentwurf veranschaulichen. LiveCycle Designer enthält eine Auswahl vollständiger Muster mit einem Formularentwurf, Musterdaten, einer Endversion des Formulars und/oder des Schemas.
Mit LiveCycle Designer im Standardinstallationsverzeichnis unter „\...\DE\Samples“ installiert.
Beispielskripten, die Beispielformulare zum Anzeigen schneller und einfacher Lösungen verwenden. Sie können mit den Beispielformularen experimentieren und die Techniken auf Ihre eigene Arbeit anwenden.
Adobe LiveCycle Developer Center
Skriptreferenzmaterial Adobe XML Form Object Model Reference beschreibt die Objekte, Eigenschaften und Methoden, die für das Erstellen von Skripten in der LiveCycle Designer-Umgebung verfügbar sind.
Adobe LiveCycle Developer Center
Informationen zu FormCalc, einer tabellenartigen Berechnungssprache, die in LiveCycle Designer integriert ist.
LiveCycle Designer-Hilfe ist als PDF-Dokument im Standardinstallationsverzeichnis unter „\...\Documentation\DE“ installiert.
Die Datei LiveCycle Designer Readme enthält wichtige Informationen, die noch nicht verfügbar waren, als die Produktdokumentation geschrieben wurde.
Mit LiveCycle Designer im Standardverzeichnis unter „\....\Documentation\EN“ installiert.


LiveCycle Designer und Adobe Document Services

Grundlagen zu Adobe Document Services
LiveCycle Designer und Adobe Document Services
Auswählen des richtigen Dateiformats für Ihre Formulare
Umgang mit PDF-Formularen in Adobe Reader
Umgang mit PDF-Formularen in Acrobat
Formularverwaltung bei LiveCycle Forms
Formularverwaltung bei LiveCycle Form Manager


Grundlagen zu Adobe Document Services

Adobe Document Services erweitern die Leistungsfähigkeit der Kernsysteme eines Unternehmens und gewährleisten so eine sicherere, zuverlässigere und effizientere Nutzung geschäftskritischer Informationen im gesamten Unternehmen. Der kombinierte Einsatz von Adobe Document Services und bestehenden Geschäftssystemen eröffnet einem Unternehmen die folgenden Möglichkeiten:
      •
      Automatisieren dokumentbasierter Prozesse
      •
      Austausch von Transaktionsdokumenten
      •
      Aufrechterhaltung der Prozessvertrautheit
      •
      Offline-Zugriff auf automatisierte Prozesse
      •
      Gemeinsame Nutzung sicherer Informationen
      •
      Austausch von Daten mit Personen und Systemen
      •
      Verwaltung des Zugriffs auf Dokumente
      •
      Verwaltung sicherer Dokumente und der Sicherheit
      •
      Bereitstellung digitaler Unterschriften und Verschlüsselungsfunktionen


LiveCycle Designer und Adobe Document Services

Die im Rahmen der Adobe Document Services zur Verfügung stehenden Produkte ermöglichen einem Unternehmen unter anderem die Dokumenterzeugung, -kollaboration, -steuerung und -sicherheit sowie ein Prozess- und Zugriffsmanagement.
Der erste Schritt bei der Arbeit mit Adobe Document Services besteht im Entwerfen und Erstellen der Formulare mit LiveCycle Designer. Wenn Sie ein Formular in der Laufzeitumgebung verteilen, können Benutzer und Unternehmen das Formular mit einer Reihe handelsüblicher oder proprietärer Anwendungen öffnen und die zugehörigen Daten bearbeiten. Die Laufzeitumgebung kann beispielsweise die folgenden Adobe-Produkte umfassen:

Produkt

Produktfunktionen
Adobe Reader
Ermöglicht Benutzern das Anzeigen, Ausfüllen, Senden von Daten und Drucken einfacher PDF-Formulare.
Acrobat
Ermöglicht Benutzern das Anzeigen, Ausfüllen, Drucken, Speichern und Senden interaktiver PDF-Formulare und Daten. Mit Acrobat Professional können Benutzer zurückgegebene Formulardaten in einer Tabellenkalkulationsanwendung wie Microsoft Excel konsolidieren.
LiveCycle Reader Extensions
Fügt PDF-Formularen Verwendungsrechte hinzu und aktiviert weitere Features und Funktionen in Adobe Reader.
LiveCycle Forms
Liefert Formulare im PDF- oder HTML-Format mit oder ohne Daten.
Extrahiert XML-Daten aus einem PDF-/HTML-Formular.
Führt Unternehmenslogik auf dem Server aus, einschließlich einer Interaktion mit den Kernanwendungen im Unternehmen.
LiveCycle Form Manager
Ermöglicht Benutzern, Formulare und Daten in einem zentralen Repository zu speichern und sie von dort abzurufen.
Verwandte Themen
Umgang mit PDF-Formularen in Adobe Reader
Umgang mit PDF-Formularen in Acrobat


Auswählen des richtigen Dateiformats für Ihre Formulare

Das Dateiformat, in dem ein Formular gespeichert wird, muss für die im Zielbenutzerkreis vorgesehene Verwendungsweise geeignet sein. Sie können ein Formular als PDF- oder XDP-Datei speichern. LiveCycle Designer stellt diese zwei Möglichkeiten zur Unterstützung der folgenden beiden grundlegenden Laufzeitszenarios zur Verfügung:
      •
      Die PDF-Ausgabe wird in Adobe Reader oder Acrobat geöffnet.
      •
      Die XDP-Ausgabe wird von LiveCycle Forms wiedergegeben.
Wenn Sie ein Formular erstellen, das der Benutzer in Acrobat 6.0.2 und höher oder Adobe Reader (mit oder ohne Verwendungsrechte) öffnen wird, speichern Sie das Formular als PDF-Datei. Wenn Sie ein Formular erstellen, das über LiveCycle Forms bereitgestellt werden soll, speichern Sie das Formular als XDP-Datei.
Verwandte Themen
Grundlagen zu Adobe Document Services
Umgang mit PDF-Formularen in Adobe Reader
Umgang mit PDF-Formularen in Acrobat


Umgang mit PDF-Formularen in Adobe Reader

Wenn ein Benutzer über Adobe Reader verfügt, kann er ein PDF-Formular über das Netzwerkdateisystem öffnen, das Formular online ausfüllen, die Daten senden und anschließend das Formular drucken. Alternativ kann er auch das Formular ausdrucken und von Hand ausfüllen. Adobe Reader kann Änderungen an PDF-Dateien nicht speichern. Selbst wenn ein interaktives PDF-Formular in Adobe Reader angezeigt wird, kann ein Benutzer lediglich mit den Objekten arbeiten und Daten eingeben, nicht aber die Daten speichern.
Mit LiveCycle Reader Extensions können Sie den Leistungsumfang von Adobe Reader durch interaktive Funktionen erweitern, die dem Endbenutzer bisher nur zur Verfügung standen, wenn PDF-Dokumente in der Vollversion von Acrobat geöffnet wurden.
Acrobat und Adobe Reader unterstützen den clientseitigen Datenaustausch für interaktive PDF-Formulare.
Verwandte Themen
Umgang mit PDF-Formularen in Acrobat


Umgang mit PDF-Formularen in Acrobat

Wenn ein Benutzer über Acrobat verfügt, kann er die gesamte Funktionalität nutzen, die interaktive Formulare bieten. Dazu gehören das Ausfüllen von Formularen, die lokale Speicherung, digitale Unterschriften, die Überprüfung und Markierung, das Abrufen von Datenbank- und Webdiensten sowie das Drucken der Dokumente. Der Benutzer hat die Möglichkeit, das PDF-Formular entweder über das Dateisystem des Netzwerks, über eine E-Mail-Nachricht oder über eine Webseite zu öffnen, es online auszufüllen und die Daten lokal zu speichern.
Acrobat und Adobe Reader unterstützen den clientseitigen Datenaustausch für interaktive PDF-Formulare.
Verwandte Themen
Umgang mit PDF-Formularen in Adobe Reader


Formularverwaltung bei LiveCycle Forms

Mit LiveCycle Forms können Organisationen Formulare im World Wide Web bereitstellen. LiveCycle Forms gibt PDF- oder webbasierte Formulare direkt und ohne Downloads oder spezielle Plug-ins in einem Browser wieder.
Sobald ein Anwender ein Formular ausgefüllt hat, kann LiveCycle Forms die Daten auf Korrektheit überprüfen, validieren und berechnen, eine Bestätigung zurücksenden und die Daten anschließend an die Kerngeschäftsprozesse weiterleiten.
Sie können mit Hilfe von LiveCycle Designer Formulare erstellen und diese anschließend in LiveCycle Forms veröffentlichen. LiveCycle Designer bietet die zentrale Plattform, die Sie benötigen, um Ihre Formulare den Endbenutzern unabhängig von ihrer Desktop-Umgebung zur Verfügung zu stellen. Darüber hinaus enthält Form Server die erforderlichen Werkzeuge, mit denen Formulare auf einfache Weise eingerichtet und verteilt werden können, sowie einen SNMP-Agenten (Simple Network Management Protocol) zur Leistungsüberwachung und Remote-Verwaltung von Formularen.
Verwandte Themen
Grundlagen zu Adobe Document Services
Umgang mit PDF-Formularen in Adobe Reader
Umgang mit PDF-Formularen in Acrobat


Formularverwaltung bei LiveCycle Form Manager

Formularverfasser und andere autorisierte Benutzer speichern Formulare und Dateien im Repository, um sie Benutzern und anderen Anwendungen wie z. B. LiveCycle Designer zur Verfügung zu stellen. Der LiveCycle Form Manager-Administrator organisiert die Formulare und Dateien im Repository und vergibt die Zugriffsberechtigungen für die Formulare und Dateien.
Sie erstellen ein Formular mit LiveCycle Designer und veröffentlichen das Formular und zugehörige Bilddateien anschließend an einem Speicherort in LiveCycle Form Manager.
Der Administrator legt dann die Zugriffsberechtigungen für das Formular fest und definiert Metadaten (beispielsweise einen aussagekräftigeren Dateinamen, eine Beschreibung und einen Hilfetext für das Formular). Der Administrator fügt das Formular anschließend einer oder mehreren Kategorien hinzu und macht das Formular für die Endbenutzer sichtbar. Die Endbenutzer können nun nach dem Formular suchen oder einen Speicherort danach durchsuchen. Sie können das Formular öffnen und ausfüllen und das Ergebnis in LiveCycle Form Manager speichern. Außerdem können sie mit den anderen Serverprodukten arbeiten, wie z. B. LiveCycle Forms oder Reader Extension Server.
Verwandte Themen
Grundlagen zu Adobe Document Services


Arbeitsbereich

Beschreibung des Arbeitsbereichs
Arbeitsbereich anpassen
Palette „Bibliothek“ verwalten


Zurück Weiter

Grundlegende Kenntnisse erwerben > Arbeitsbereich > Beschreibung des Arbeitsbereichs

Beschreibung des Arbeitsbereichs

Der Arbeitsbereich
Layout-Editor
Skript-Editor
Paletten


Der Arbeitsbereich

Der Arbeitsbereich von LiveCycle Designer besteht standardmäßig aus mehreren Teilbereichen. Im Layout-Editor können Sie den Formularentwurf erstellen und das Layout des Formulars festlegen. Im Skript-Editor können Sie Skripten erstellen, mit deren Hilfe sich die Funktionalität des Formularentwurfs erweitern lässt. Außerdem stehen im Arbeitsbereich Paletten zum Bearbeiten des Formularentwurfs sowie Menüs und Befehle für die Ausführung von Aufgaben zur Verfügung.
Nachdem Sie nach einiger Zeit mit Formularentwürfen vertrauter geworden sind, können Sie den Arbeitsbereich an Ihre Bedürfnisse anpassen.
Verwandte Themen
Layout-Editor
Skript-Editor
Paletten


Layout-Editor

Formularentwürfe werden primär im Layout-Editor erstellt und bearbeitet. Der Layout-Editor umfasst standardmäßig vier Registerkarten:
Registerkarte „Designansicht“
Zeigt die zum Formularentwurf gehörigen Seiten an.
Registerkarte „Masterseiten“
Zeigt die Masterseiten an, die auf die Seiten in der Designansicht angewendet werden können.
Registerkarte „XML-Quelle“
Zeigt den XML-Quellcode an, der die Struktur des Formularentwurfs und seine Objekte beschreibt. Es ist nicht empfehlenswert, den XML-Quellcode direkt zu bearbeiten.
Registerkarte „PDF-Vorschau“
Zeigt ein PDF-Formular auf der Basis des aktuellen Formularentwurfs an.
Standardmäßig werden nicht alle Registerkarten angezeigt. Die Registerkarte „Designansicht“ wird angezeigt. Die Registerkarten „Masterseiten“ und „XML-Quelle“ sind ausgeblendet. Die Registerkarte „PDF-Vorschau“ wird nur angezeigt, wenn Acrobat oder Adobe Reader installiert sind.
Um den Layout-Editor sind Paletten mit Registerkarten angeordnet, die einen einfachen Zugriff auf die Werkzeuge ermöglichen, ohne den Arbeitsbereich zu überladen.
Registerkarte „Designansicht“
Die Seiten der Designansicht zeigen den Inhalt des Formularentwurfs an. Wenn Sie LiveCycle Designer zum ersten Mal starten oder einen neuen Formularentwurf erstellen, enthält die Registerkarte „Designansicht“ bereits eine Seite, der Sie Objekte hinzufügen können.
Objekte, die sich auf der Masterseite befinden, werden auf der Seite angezeigt, können aber nicht ausgewählt werden.
Registerkarte „Masterseiten“
Masterseiten definieren das Layout und den Hintergrund des Formularentwurfs. Die Objekte, die Sie auf einer Masterseite einfügen, werden im gesamten Formularentwurf an derselben Stelle angezeigt. Die Registerkarte „Masterseiten“ ist standardmäßig ausgeblendet.
Objekte, die sich auf der Registerkarte „Designansicht“ befinden, werden nicht auf der Masterseite angezeigt.
Registerkarte „PDF-Vorschau“
Während Sie an dem Formular arbeiten, können Sie sich auf der Registerkarte „PDF-Vorschau“ eine Vorschau des Formulars anzeigen lassen, sofern Acrobat oder Adobe Reader installiert ist. Auf der Registerkarte „PDF-Vorschau“ können Sie Formulare oder Vorlagen anzeigen und deren Bedienung genau wie in einer richtigen PDF-Datei testen. Im Dialogfeld „Formulareigenschaften“ (Registerkarte „Standard“) können Sie Optionen für die Vorschau von interaktiven oder druckbaren Formularen im PDF-Format festlegen.
Um ein Formular auf der Registerkarte „PDF-Vorschau“ anzuzeigen, stellen Sie sicher, dass in Acrobat die Option „Bearbeiten“ > „Grundeinstellungen“ > „Internet“ > „PDF in Browser anzeigen“ ausgewählt ist.
Verwandte Themen
Layout-Editor anpassen


Skript-Editor

Mit dem Skript-Editor können Sie Skripten erstellen, um die Funktionalität des Formularentwurfs zu erweitern. Der Skript-Editor wird standardmäßig oben im LiveCycle Designer-Arbeitsbereich angezeigt, kann aber auch an jeder beliebigen anderen Stelle angedockt werden.
Der Skript-Editor verfügt sowohl über eine einzeilige als auch über eine mehrzeilige Ansicht. Sie können je nach Anforderung jederzeit zwischen diesen Ansichten wechseln. Die einzeilige Ansicht soll dafür sorgen, dass möglichst viel Platz für den Layout-Editor und andere Paletten zur Verfügung steht, wogegen die mehrzeilige Ansicht möglichst viel Platz für die Skripterstellung bereitstellen soll.
Sie können mit dem Skript-Editor beispielsweise eine einfache Berechnung schreiben, die die Summe der Werte zweier numerischer Felder berechnet, oder auch komplexere Skripten erstellen, die die Darstellung des Formulars in Abhängigkeit von den Aktionen des Endbenutzers anpasst. LiveCycle Designer unterstützt das Schreiben von Skripten in einer eigenen Skriptsprache namens FormCalc sowie in JavaScript.
Verwandte Themen
Berechnungen und Skripten
Der Skript-Editor


Paletten

Info über Paletten
Palette „Hierarchie“
Palette „Datenansicht“
Palette „PDF-Struktur“
Palette „Bibliothek“
Palette „Layout“
Palette „Rand“
Palette „Objekt“
Palette „Ein-/Ausgabehilfen“
Palette „Schrift“
Palette „Absatz“
Palette „Zeichenhilfen“
Palette „Info“
Palette „Bericht“
Palette „Verfahren“


Info über Paletten

Paletten bieten einen einfachen Zugang zu den Werkzeugen, ohne den Arbeitsbereich zu überladen. Eine Palette kann eine oder mehrere Registerkarten umfassen, die jeweils einen bestimmten Typ von Eigenschaften enthalten. Die Palette „Objekt“ kann beispielsweise eine oder mehrere Registerkarten enthalten.
Sie können die Paletten im Arbeitsbereich so anordnen, wie es Ihren Arbeitsgewohnheiten entspricht. Beispielsweise können Sie die selten benutzten Paletten ausblenden und die häufig verwendeten Paletten zusammen in ein Palettenfenster verschieben.
Während Sie im Layout-Editor arbeiten, ändern sich die in bestimmten Paletten angezeigten Informationen je nach ausgewähltem Objekt. Wenn Sie beispielsweise ein Objekt auswählen, werden in der Palette „Layout“ Informationen über die Größe und Position des Objekts angezeigt.


Palette „Hierarchie“

Die Palette „Hierarchie“ ist eine grafische Darstellung des Inhalts der Registerkarten „Designansicht“ und „Masterseiten“.
Jede Auswahl, die Sie in der Palette „Hierarchie“ vornehmen, wird auch auf der entsprechenden Textseite oder Masterseite vorgenommen.
Verwandte Themen
Palettenmenü „Hierarchie“


Palette „Datenansicht“

Wenn eine Datenverbindung existiert, zeigt die Palette „Datenansicht“ die Hierarchie an, die aus der Datenverbindung entnommen wurde. Die oberen Nodes der Hierachie stellen die einzelnen Datenverbindungen dar und zeigen den Namen der jeweiligen Datenverbindung an. Eine Datenverbindung stellt eine Verknüpfung zwischen dem Formular und der Datenquelle her.
Wenn Sie einen auf einer Datenverbindung basierenden Formularentwurf erstellen, erzeugtLiveCycle Designer für das Formular eine Datenstruktur auf der Basis dieser Datenquelle. Formulare lassen sich schnell erstellen, indem Sie die Datenquelle ganz oder teilweise verwenden. Mit Hilfe einer Bindung verknüpfen Sie anschließend die Node einer Datenquelle mit einem Objekt im Formular.
Verwandte Themen
Palettenmenü „Datenansicht“


Palette „PDF-Struktur“

Die Palette „PDF Struktur“ zeigt die hierarchische Struktur von mit Tags versehenen PDF-Dokumenten an, damit Sie die Barrierefreiheit, eine definierte Tab-Reihenfolge und Leserichtung für Hilfstechnologien wie den Tastenzugriff und Bildschirmlesehilfen gewährleisten können.
Verwandte Themen
Palettenmenü „PDF-Struktur“
PDF-Dokumente als Grafik importieren


Palette „Bibliothek“

Die Palette „Bibliothek“ enthält alle Objekte, die Sie einem Formularentwurf hinzufügen können. Die Objekte sind in Kategorien zusammengefasst:
Favoriten
Enthält häufig verwendete Objekte.
Standard
Enthält die am häufigsten verwendeten Formularobjekte wie Kontrollkästchen und Textfelder.
Barcodes
Enthält eine Liste der Barcode-Objekte.
Eigene
Enthält vorformatierte Objekte wie Adressblöcke und Telefonnummernfelder.
Sie können Kategorien zu dieser Palette hinzufügen, vorhandene Kategorien umbenennen, Objekte zwischen den Kategorien verschieben und Kategorien aus dieser Palette entfernen. Darüber hinaus haben Sie die Möglichkeit, eigene Objekte zu erstellen und diese den Kategorien hinzuzufügen. Jede Kategorie entspricht einem Ordner im Dateisystem.
Verwandte Themen
Was ist ein Objekt?
Palette „Bibliothek“ verwalten
Palettenmenü „Bibliothek“


Palette „Layout“

In der Palette „Layout“ können Sie die folgenden Eigenschaften für das ausgewählte Objekt festlegen:
      •
      Größe und Position des Objekts.
      •
      Ob das Objekt die definierte Höhe und Breite ignorieren und so erweitert werden sollte, dass der gesamte Objektinhalt sichtbar ist
      •
      Position des Verankerungspunktes (Einfügepunkt). Sie können das Objekt in Schritten von 90°, 180° oder 270° um seinen Verankerungspunkt drehen.
      •
      Ränder um das Objekt
      •
      Position und Breite der Beschriftung. Die Beschriftung lässt sich auch ausblenden.
Wenn Sie ein Objekt auswählen, zeigt die Palette „Layout“ automatisch die Einstellungen dieses Objekts an. Die meisten Layout-Einstellungen eines Objekts können Sie direkt im Layout-Editor bearbeiten. Um beispielsweise die Position eines Objekts zu ändern, können Sie das Objekt einfach an die neue Position auf der Seite ziehen.
Verwandte Themen
Objekte formatieren
Layout-Eigenschaften in der Palette „Layout“
Palettenmenü „Layout“


Palette „Rand“

Über die Palette „Rand“ können Sie die Randeigenschaften der Objekte im Formularentwurf bearbeiten. Die Ränder lassen sich einzeln (links, rechts, oben und unten) oder gemeinsam bearbeiten. Sie können auch die Art der Ecken und die Hintergrundfarbe angeben.
Verwandte Themen
Palettenmenü „Rand“
Randeigenschaften in der Palette „Rand“
So legen Sie einen Rand um ein Objekt herum fest
So legen Sie einen Rand um den Füllbereich herum fest


Palette „Objekt“

Über die Palette „Objekt“ können Sie die spezifischen Eigenschaften des ausgewählten Objekts ändern. Welche Registerkarten in dieser Palette zur Verfügung stehen, hängt von dem im Layout-Editor ausgewählten Objekt ab.
Verwandte Themen
Palettenmenü „Objekt“


Palette „Ein-/Ausgabehilfen“

Verwenden Sie die Palette „Ein-/Ausgabehilfen“, um individuell angepassten Text für ein Objekt festzulegen, das in dem Formular von einer MSAA-kompatiblen (Microsoft Active Accessibility) Bildschirmlesehilfe gelesen wird. Wenn das Objekt einen angepassten Text für die Bildschirmlesehilfe aufweist, liest die Bildschirmlesehilfe diesen Text anstelle der QuickInfo.
Sie können außerdem die Standardreihenfolge ändern, in der eine Bildschirmlesehilfe die einzelnen Objekte nach zu lesendem Text durchsucht, und für beliebige Objekte den Text für Bildschirmlesehilfen deaktivieren.
Verwandte Themen
Palettenmenü „Ein-/Ausgabehilfe“
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“
Objekte barrierefrei machen


Palette „Schrift“

Über die Palette „Schrift“ können Sie die Schriftfamilie, die Größe und den Stil des Textes im ausgewählten Objekt ändern. Sie können die Schrift für Beschriftung und Wert ändern.
Verwandte Themen
Info über das Formatieren von Texten
Palettenmenü „Schrift“
Schrift-Eigenschaften in der Palette „Schrift“


Palette „Absatz“

Über die Palette „Absatz“ können Sie die Ausrichtung, die Einzüge und den Zeilenabstand des ausgewählten Textes ändern. Darüber hinaus können Sie für ein Objekt des Typs „Numerisches Feld“ die Radix-Ausrichtung festlegen. Welche Optionen in der Palette „Absatz“ angezeigt werden, hängt davon ab, was ausgewählt wurde. Sie können die Schrift für Beschriftung und Wert ändern.
Verwandte Themen
Info über das Formatieren von Abschnitten
Palettenmenü „Absatz“


Palette „Zeichenhilfen“

Mit der Palette „Zeichenhilfen“ können Sie die Raster- und Linealeinstellungen sowie die Zeicheneinheiten angeben. Sie können auch Objektgrenzen anzeigen oder ausblenden und Begrenzungsstile auswählen.
Das horizontale und vertikale Lineal, das Raster und die langen Fadenkreuze vereinfachen die exakte Positionierung von Objekten auf einer Seite in horizontaler oder vertikaler Richtung. Wenn die Lineale eingeblendet sind, werden sie entlang dem oberen und linken Rand der aktiven Textseite oder Masterseite dargestellt. Markierungen im Lineal zeigen die Position des Zeigers an, wenn dieser bewegt wird. Durch Ändern des Linealursprungs (der Markierung (0, 0) auf den oben und links angeordneten Linealen) ist es möglich, eine Messung von einem bestimmten Punkt des Formularentwurfs aus durchzuführen.
Sie können auch die Objektgrenzen im Formularentwurf ein- oder ausblenden. Das Einblenden der Grenzen ist vor allem bei Objekten hilfreich, die im Formular keine Umrandung aufweisen. Sie können auch spezielle Randeigenschaften für Felder, Teilformulare, Inhaltsbereiche, Gruppen und andere Objekte angeben.
Verwandte Themen
Die Zeichenhilfen
Objekte ausrichten und in der Größe ändern
Palettenmenü „Zeichenhilfen“


Palette „Info“

In der Palette „Info“ werden die den ausgewählten Objekten zugeordneten Metadaten angezeigt. Diese Metadaten werden in der XML-Quelle als benannte untergeordnete Elemente eines <desc>-Elements abgelegt. In Dialogfeld „Formulareigenschaften“ (Registerkarte „Info“) können Sie einige Metadaten für den Formularentwurf bearbeiten.
Verwandte Themen
Palettenmenü „Info“
Registerkarte „Info“ (Dialogfeld „Formulareigenschaften“)


Palette „Bericht“

Die Palette „Bericht“ stellt Informationen über den Formularentwurf zur Verfügung. Die Registerkarte „Warnungen“ enthält eine Liste der Fehler und Meldungen, die während der Ausarbeitung des Formularentwurfs gemeldet werden. Um die Registerkarte „Warnungen“ zu leeren, klicken Sie im Palettenmenü auf „Warnungen löschen“.
Verwandte Themen
Palettenmenü „Bericht“
So zeigen Sie eine Liste gebundener Felder an


Palette „Verfahren“

Die Palette „Verfahren“ enthält eine Reihe von Hilfethemen zu gängigen Verfahren in LiveCycle Designer. Führen Sie einen Bildlauf durch, um ein bestimmtes Thema zu suchen. Klicken Sie dann auf die Verknüpfung „Weitere Infos“, um die Verfahrensdetails anzuzeigen.


Arbeitsbereich anpassen

Layout-Editor anpassen
Skript-Editor anpassen
Paletten anpassen
Die Zeichenhilfen
Werkzeugleisten anpassen
QuickInfo anpassen


Layout-Editor anpassen

Sie können den Layout-Editor individuell anpassen, indem Sie Registerkarten ein- oder ausblenden, die Seitengröße ändern und die Ansicht vergrößern und verkleinern.
Registerkarten ein- und ausblenden
      •
      Um die Registerkarte „Designansicht“ ein- oder auszublenden, wählen Sie „Ansicht“ > „Designansicht“.
      •
      Um die Registerkarte „Masterseiten“ ein- oder auszublenden, wählen Sie „Ansicht“ > „Masterseiten“.
      •
      Um die Registerkarte „XML-Quelle“ ein- oder auszublenden, wählen Sie „Ansicht“ > „XML-Quelle“.
      •
      Um die Registerkarte „PDF-Vorschau“ ein- oder auszublenden, wählen Sie „Ansicht“ > „PDF-Vorschau“.
Ansicht vergrößern oder verkleinern
      •
      Um die Seite auf 100 % zu vergrößern, wählen Sie „Ansicht“ > „Tatsächliche Größe“.
      •
      Um die Größe der Seite an die Größe des Fensters „Layout-Editor“ anzupassen, wählen Sie „Ansicht“ > „An Seite anpassen“.
      •
      Um die Größe der Seite an die Breite des Fensters „Layout-Editor“ anzupassen, wählen Sie „Ansicht“ > „Fensterbreite“.
      •
      Um die Seite im Fenster „Layout-Editor“ zu vergrößern oder zu verkleinern, wählen Sie „Ansicht“ > „Zoom“, geben Sie im Feld „Zoomen auf“ einen Wert zwischen 25 % und 500 % ein und klicken Sie anschließend auf „OK“. Sie können auch das Feld „Zoomen auf“ [image] in der Werkzeugleiste verwenden.
      •
      Um einen Bereich zu vergrößern, wählen Sie „Ansicht“ > „Zoom-Bereich“. Der Zeiger verwandelt sich in ein Vergrößerungsglas. Ziehen Sie mit dem Vergrößerungsglas über den Bereich, der vergrößert werden soll.
      •
      Um eine bestimmte Seite anzuzeigen, verkleinern Sie den Bereich, um ihn vollständig anzuzeigen. Führen Sie anschließend einen Bildlauf nach unten durch, um zur gewünschten Seite zu gelangen.
Verwandte Themen
Layout-Editor


Skript-Editor anpassen

      •
      Um den Skript-Editor ein- oder auszublenden, wählen Sie „Fenster“ > „Skript-Editor“.
      •
      Um von der einzeiligen zur mehrzeiligen Ansicht zu wechseln, ziehen Sie die Erweitern-Schaltfläche am Rand der Palette „Skript-Editor“, bis die Palette die gewünschte Größe besitzt.
Verwandte Themen
Skript-Editor
Berechnungen und Skripten


Paletten anpassen

Sie können die Paletten ein- und ausblenden, andocken und verschieben oder deren Größe anpassen und Paletten zurücksetzen.
Paletten ein- und ausblenden
      •
      Um eine Palette einzublenden, wählen Sie „Fenster“ > [Name der Palette].
      •
      Um eine Palette auszublenden, wählen Sie im Palettenmenü die Option „Palette ausblenden“.
      •
      Um alle Paletten auf einer Seite des Layout-Editors ein- bzw. auszublenden, klicken Sie am Palettenrand auf die Erweitern-Schaltfläche [image]. Klicken Sie erneut auf die Schaltfläche, um die Paletten zu reduzieren.
      •
      Um alle Paletten an der ausgewählten Position aus- bzw. einzublenden, wählen Sie „Fenster“ > „Arbeitsbereich“ und wählen Sie anschließend eine der Optionen aus.
Paletten andocken oder verschieben
      •
      Um eine Palette am Rand des Fensters anzudocken, ziehen Sie die Palettenleiste an den Rand des LiveCycle Designer-Fensters.
      •
      Um die Paletten aneinander anzudocken, ziehen Sie die Palettenleiste auf den unteren Rand einer anderen Palette. Dies funktioniert nur bei Paletten, die im LiveCycle Designer-Fenster angedockt sind, und nicht bei schwebenden Paletten.
      •
      Um eine Palette zu verschieben und anzudocken, ziehen Sie die Palettenleiste.
      •
      Um eine Palette zu verschieben, ohne die Palette anzudocken, drücken Sie die Taste [STRG], halten Sie sie gedrückt und ziehen Sie die Palettenleiste.
      •
      Um eine Palette in ein anderes Palettenfenster zu verschieben, ziehen Sie die Registerkarte der Palette auf die Zielpalette. Eine untergeordnete Registerkarte kann nicht verschoben werden.
Palettengröße anpassen bzw. Paletten zurücksetzen
      •
      Um die Größe einer Palette anzupassen, ziehen Sie einen beliebigen Rand der Palette.
      •
      Um die Palettenpositionen zurückzusetzen, wählen Sie „Fenster“ > „Palettenpositionen zurücksetzen“.
Verwandte Themen
Paletten


Die Zeichenhilfen

Über die Palette „Zeichenhilfen“ können Sie Lineale und Objektgrenzen aus- und einblenden sowie das Raster und weitere Voreinstellungen festlegen.
Zeichnungshilfen ein- bzw. ausblenden
      •
      Um die Palette „Zeichenhilfen“ schnell einzublenden, doppelklicken Sie auf ein Lineal.
      •
      Um Objektgrenzen ein- bzw. auszublenden, wählen Sie „Ansicht“ > „Objektgrenzen“.
      •
      Um Lineale, Führungslinien oder das Raster ein- bzw. auszublenden, wählen Sie „Ansicht“ > „Lineale“, „Ansicht“ > „Führungslinien“ oder „Ansicht“ > „Raster“.
      •
      Um die Fadenkreuze ein- bzw. auszublenden, wählen Sie „Lange Fadenkreuze“.
Raster verwenden
      •
      Um die Objekte am Raster auszurichten, wählen Sie „Ansicht“ > „Am Raster ausrichten“.
      •
      Um den Rasterursprung festzulegen, geben Sie neue Koordinaten in den Feldern „X“ und „Y“ für den Rasterursprung ein.
      •
      Um das Rasterintervall festzulegen, geben Sie neue Werte in den Feldern „X“ und „Y“ für das Intervall des Rasters ein. Beispiel: Wenn Sie das Raster in Einheiten zu 1 Zoll einteilen und ein Intervall von 10 angeben, werden 10 Rasterpunkte pro Zoll angezeigt.
Weitere Zeichenhilfen festlegen
      •
      Um eine Führungslinie beginnend von links oben im Layout-Editor hinzuzufügen, ziehen Sie den Zeiger auf die Seite. Um eine Führungslinie zu entfernen, wählen Sie das dazugehörige Dreieck im Lineal aus und ziehen Sie es von der Seite.
      •
      Um die Maßeinheit der Lineale festzulegen, wählen Sie eine Einheit im Listenfeld „Einheit“ aus.
      •
      Um die Farbe der Objektgrenzen festzulegen, klicken Sie auf „Stile“ und auf „Farbe“, klicken Sie auf „Weitere Farben“, und wählen Sie entweder eine vordefinierte Farbe in der Palette aus, oder erstellen Sie eine benutzerdefinierte Farbe, indem Sie auf „Farben definieren“ klicken.
      •
      Um den Begrenzungsstil festzulegen, klicken Sie auf „Stile“ und wählen Sie den Begrenzungsstil für das gewünschte Objekt aus.
      •
      Um die Farbe des Rasters bzw. der Führungslinien festzulegen, klicken Sie auf das Feld „Farbe“, klicken Sie auf „Weitere Farben“ und wählen Sie entweder eine vordefinierte Farbe in der Palette aus, oder erstellen Sie eine benutzerdefinierte Farbe, indem Sie auf „Farben definieren“ klicken.
Verwandte Themen
Palette „Zeichenhilfen“
Palettenmenü „Zeichenhilfen“
Objekte ausrichten und in der Größe ändern


Werkzeugleisten anpassen

Sie können die Werkzeugleisten ein- und ausblenden, andocken oder verschieben, nicht benötigte Werkzeugleisten entfernen, häufig verwendete Schaltflächen hinzufügen oder nicht verwendete Schaltflächen aus einer Werkzeugleiste entfernen, die Standardwerkzeugleisten zurücksetzen oder neue Werkzeugleisten erstellen.
Werkzeugleiste ein- bzw. ausblenden, andocken oder verschieben
      •
      Um eine Werkzeugleiste ein- bzw. auszublenden, klicken Sie mit der rechten Maustaste auf eine Werkzeugleiste und aktivieren oder deaktivieren Sie die Werkzeugleiste, die Sie ein- bzw. ausblenden möchten.
      •
      Um eine Werkzeugleiste anzudocken, ziehen Sie die Werkzeugleiste an den oberen Rand des LiveCycle Designer-Fensters.
      •
      Um eine Werkzeugleiste zu verschieben, ziehen Sie die Werkzeugleiste an einen neuen Standort.
Werkzeugleiste erstellen
1.
Wählen Sie „Extras“ > „Werkzeugleisten anpassen“.
2.
Klicken Sie auf der Registerkarte „Werkzeugleisten“ auf „Neu“.
3.
Geben Sie einen Namen für die Werkzeugleiste ein und klicken Sie auf „OK“.
4.
Fügen Sie Schaltflächen und Menüs zur Werkzeugleiste und klicken Sie dann auf „OK“.
Werkzeugleiste entfernen
1.
Wählen Sie „Extras“ > „Werkzeugleisten anpassen“.
2.
Wählen Sie auf der Registerkarte „Werkueugleisten“ die Werkzeugleiste aus, die Sie entfernen möchten, und klicken Sie auf „Löschen“.
Sie können nur Werkzeugleisten löschen, die Sie selbst erstellt haben.
Schaltfläche zu einer Werkzeugleiste hinzufügen oder entfernen
1.
Achten Sie darauf, dass die Werkzeugleiste, die Sie ändern möchten, eingeblendet ist.
2.
Wählen Sie „Extras“ > „Anpassen“.
3.
So fügen Sie eine Schaltfläche hinzu oder entfernen diese:
      •
      Um eine Schaltfläche zur Werkzeugleiste hinzuzufügen, wählen Sie auf der Registerkarte „Befehle“ eine Kategorie und wählen Sie anschließend die Schaltfläche, die Sie hinzufügen möchten.
      •
      Um eine Schaltfläche aus einer Werkzeugleiste zu entfernen, ziehen Sie die Schaltfläche von der Werkzeugleiste.
4.
Klicken Sie auf „OK“.
Werkzeugleiste auf die Standarddarstellung zurücksetzen
1.
Achten Sie darauf, dass die Werkzeugleiste, die Sie zurücksetzen möchten, eingeblendet ist.
2.
Wählen Sie „Extras“ > „Werkzeugleisten anpassen“.
3.
Wählen Sie die Werkzeugleiste aus, klicken Sie auf „Zurück“ und klicken Sie anschließend auf „OK“.


QuickInfo anpassen

      •
      Um die QuickInfos zur Position ein- bzw. auszublenden, wählen Sie „Extras“ > „Optionen“> „Arbeitsbereich“, aktivieren oder deaktivieren Sie das Kontrollkästchen „QuickInfos zu Position und Größe beim Bearbeiten anzeigen“ und klicken Sie auf „OK“.
      •
      Um die QuickInfos für Objekte ein- bzw. auszublenden, wählen Sie „Extras“ > „Optionen“> „Arbeitsbereich“, aktivieren oder deaktivieren Sie das Kontrollkästchen „QuickInfos zu Objektnamen beim Zeigen einblenden“ und klicken Sie auf „OK“.


Palette „Bibliothek“ verwalten

So fügen Sie der Palette „Bibliothek“ eine Kategorie hinzu
So löschen Sie eine Kategorie aus der Palette „Bibliothek“
So verschieben Sie ein Objekt in eine andere Kategorie in der Palette „Bibliothek“
So passen Sie die Ansicht in der Palette „Bibliothek“ an
So legen Sie Berechtigungen für eine Kategorie in der Palette „Bibliothek“ fest
So fügen Sie der Palette „Bibliothek“ ein Objekt hinzu
So löschen Sie ein Objekt aus der Palette „Bibliothek“
So benennen Sie ein Objekt in der Palette „Bibliothek“ um
So stellen Sie Standardobjekte in der Palette „Bibliothek“ wieder her
So können Sie eine Kategorie in der Palette „Bibliothek“ mit anderen Formularverfassern oder Formularentwicklern gemeinsam verwenden
So können Sie eine Bibliothek mit anderen Formularverfassern oder Formularentwicklern gemeinsam verwenden


So fügen Sie der Palette „Bibliothek“ eine Kategorie hinzu

1.
Wählen Sie im Menü der Palette „Bibliothek“ die Option „Gruppe hinzufügen“.
2.
Geben Sie einen Namen für die Kategorie ein und klicken Sie auf „OK“. Wenn Sie der Palette „Bibliothek“ eine Kategorie hinzufügen, wird ein Ordner im Dateisystem erstellt.
Wenn Sie den Speicherort des neuen Ordners anzeigen möchten, klicken Sie in der Palette „Bibliothek“ auf die gewünschte Kategorie und wählen Sie im Menü der Palette „Bibliothek“ die Option „Gruppeneigenschaften“. Der Speicherort des Ordners wird im Feld „Speicherort“ angezeigt.


So löschen Sie eine Kategorie aus der Palette „Bibliothek“

1.
Wählen Sie im Menü der Palette „Bibliothek“ die Option „Gruppe entfernen“.
2.
Führen Sie eine der folgenden Aufgaben aus:
      •
      Wenn Sie eine Kategorie löschen möchten, wählen Sie „Gruppe und zugehörige Objekte entfernen“ aus.
      •
      Wenn Sie eine Kategorie löschen und die zugehörigen Objekte in eine andere Kategorie verschieben möchten, wählen Sie „Gruppe entfernen und Objekte verschieben nach: [Name der Kategorie]„ aus.
3.
Klicken Sie auf „OK“.


So verschieben Sie ein Objekt in eine andere Kategorie in der Palette „Bibliothek“

      *
      Klicken Sie in der Palette „Bibliothek“ mit der rechten Maustaste auf das zu verschiebende Objekt und wählen Sie „Objekt verschieben nach > [Name der Kategorie]„ aus.
Es werden nur Kategorien angezeigt, bei denen das Hinzufügen oder Entfernen von Objekten möglich ist.


So passen Sie die Ansicht in der Palette „Bibliothek“ an

      *
      Führen Sie mindestens eine der folgenden Aufgaben aus:
      •
      Wenn Sie die Größe der Symbole ändern möchten, wählen Sie im Menü der jeweiligen Kategorie „Ansicht“ > [Symbolgröße].
      •
      Wenn Sie die Symbole sortieren möchten, wählen Sie im Menü der jeweiligen Kategorie „Ansicht“ > „Sortierte Liste“.


So legen Sie Berechtigungen für eine Kategorie in der Palette „Bibliothek“ fest

1.
Wählen Sie im Menü der jeweiligen Kategorie die Option „Gruppeneigenschaften“.
2.
Führen Sie eine der folgenden Aufgaben aus:
      •
      Wenn Sie das Hinzufügen von Objekten zu einer Kategorie zulassen möchten, muss die Option „Objekte hinzufügen zulassen“ aktiviert sein.
      •
      Wenn Sie das Löschen von Objekten aus einer Kategorie zulassen möchten, muss die Option „Objekte entfernen zulassen“ aktiviert sein.
      •
      Wenn Sie das Ändern von Objekten in einer Kategorie zulassen möchten, muss die Option „Objekte ändern zulassen“ aktiviert sein.


So fügen Sie der Palette „Bibliothek“ ein Objekt hinzu

1.
Wählen Sie in der Palette „Bibliothek“ die Kategorie aus, in der Sie das Objekt speichern möchten.
2.
Ziehen Sie das Objekt in die Palette „Bibliothek“.
3.
Geben Sie im Dialogfeld „Bibliotheksobjekt hinzufügen“ einen Namen für das Objekt ein.
4.
(Optional) Geben Sie eine Beschreibung für das Objekt ein.
5.
Klicken Sie auf „OK“.
Falls in dieser Kategorie bereits ein Objekt mit diesem Namen vorhanden ist, müssen Sie in LiveCycle Designer bestätigen, dass Sie das vorhandene Objekt ersetzen möchten.
Im Dialogfeld „Gruppeneigenschaften“ wurden einige Kategorien möglicherweise so eingerichtet, dass keine Objekte hinzugefügt, entfernt oder geändert werden können. Wenn zu einer Kategorie keine neuen Objekte hinzugefügt werden können, werden die Objekte zur ersten Kategorie hinzugefügt, die dies zulässt.


So löschen Sie ein Objekt aus der Palette „Bibliothek“

1.
Wählen Sie in der Palette „Bibliothek“ die Kategorie aus, in der das Objekt gespeichert ist.
2.
Klicken Sie mit der rechten Maustaste auf das Objekt und wählen Sie „Objekt aus Bibliothek entfernen“ aus.
Im Dialogfeld „Gruppeneigenschaften“ wurden einige Kategorien möglicherweise so eingerichtet, dass keine Objekte hinzugefügt, entfernt oder geändert werden können. Sie können ein Objekt nicht löschen, wenn dies in der jeweiligen Kategorie nicht zulässig ist.
3.
Wenn Sie gefragt werden, ob Sie das Objekt löschen möchten, klicken Sie auf „Ja“. Das Objekt wird aus dem Dateisystem entfernt.


So benennen Sie ein Objekt in der Palette „Bibliothek“ um

1.
Wählen Sie in der Palette „Bibliothek“ die Kategorie aus, in der das Objekt gespeichert ist.
2.
Klicken Sie mit der rechten Maustaste auf das Objekt und wählen Sie „Objektinfo“ aus.
Im Dialogfeld „Gruppeneigenschaften“ wurden einige Kategorien möglicherweise so eingerichtet, dass keine Objekte hinzugefügt, entfernt oder geändert werden können. Sie können ein Objekt nicht löschen, wenn dies in der jeweiligen Kategorie nicht zulässig ist.
3.
Geben Sie im Feld „Name“ einen neuen Namen ein.
4.
(Optional) Geben Sie im Feld „Beschreibung“ eine Beschreibung ein.
5.
Klicken Sie auf „OK“.
Falls in dieser Kategorie bereits ein Objekt mit diesem Namen vorhanden ist, müssen Sie in LiveCycle Designer bestätigen, dass Sie das vorhandene Objekt ersetzen möchten.


So stellen Sie Standardobjekte in der Palette „Bibliothek“ wieder her

Sie können die Standardobjekte in LiveCycle Designer in den Kategorien „Favoriten“, „Standard“, „Barcodes“ und „Eigene“ wiederherstellen.
Beim Wiederherstellen werden alle Objekte wiederhergestellt, die im Lieferumfang von LiveCycle Designer enthalten sind. In LiveCycle Designer werden alle fehlenden Objekte ersetzt und alle Objekte überschrieben, deren Namen mit den Namen der Originale übereinstimmen.
1.
Wählen Sie in der Palette „Bibliothek“ eine der folgenden Kategorien aus: „Favoriten“, „Standard“, „Barcodes“ oder „Eigene“.
2.
Wählen Sie im Palettenmenü die Option „Standardobjekte wiederherstellen“ aus.


Zurück Weiter

Grundlegende Kenntnisse erwerben > Arbeitsbereich > Palette „Bibliothek“ verwalten > So können Sie eine Kategorie in der Palette „Bibliothek“ mit anderen Formularverfassern oder Formularentwicklern gemeinsam verwenden

So können Sie eine Kategorie in der Palette „Bibliothek“ mit anderen Formularverfassern oder Formularentwicklern gemeinsam verwenden

Sie können die Objekte in der Palette „Bibliothek“ in einem gemeinsamen Ordner oder in einem Webordner platzieren, wo auch andere Formularverfasser oder Formularentwickler darauf zugreifen können.
1.
Erstellen Sie einen gemeinsamen Ordner oder einen Webordner, auf den andere Formularverfasser oder Formularentwickler Zugriff haben.
2.
Erstellen Sie in der Palette „Bibliothek“ Unterordner für die einzelnen Kategorien, die Sie gemeinsam verwenden möchten.
3.
Kopieren Sie die Objekte vom bisherigen Speicherort an den neuen Speicherort.
Wenn Sie den Speicherort des neuen Ordners anzeigen möchten, klicken Sie in der Palette „Bibliothek“ auf die gewünschte Kategorie und wählen Sie im Menü der Palette „Bibliothek“ die Option „Gruppeneigenschaften“. Der Speicherort des Ordners wird im Feld „Speicherort“ angezeigt.
4.
Wählen Sie in LiveCycle Designer die gewünschte Kategorie in der Palette „Bibliothek“ aus.
5.
Wählen Sie im Menü der Palette „Bibliothek“ die Option „Gruppeneigenschaften“.
6.
Sie können den Speicherort der Objekte, die in dieser Kategorie enthalten sein sollen, im Feld „Speicherort“ eingeben oder den Speicherort der Objekte suchen.
7.
Klicken Sie auf „OK“.
8.
Wiederholen Sie die Schritte 4 bis 7 für die einzelnen Kategorien.


So können Sie eine Bibliothek mit anderen Formularverfassern oder Formularentwicklern gemeinsam verwenden

Sie können die Bibliothek mit Kategorien und Objekten in einem gemeinsamen Ordner oder in einem Webordner platzieren, wo auch andere Formularverfasser oder Formularentwickler darauf zugreifen können.
So erstellen Sie eine gemeinsame Bibliothek mithilfe einer vorhandenen Bibliothek
1.
Fügen Sie aus der vorhandenen Bibliothek Kategorien und Objekte hinzu und entfernen Sie diese, bis Sie die Struktur erstellt haben, die Sie für die gemeinsame Bibliothek verwenden möchten.
2.
Wählen Sie im Menü der Palette „Bibliothek“ für jede Kategorie die Option „Gruppeneigenschaften“ aus und legen Sie die gewünschten Benutzerberechtigungen fest.
3.
Suchen Sie den Ordner „Objekte“ in dem Verzeichnis, in dem LiveCycle Designer installiert ist, und kopieren Sie den Ordner „Objekte“ sowie alle zugehörigen Unterordner in einen gemeinsamen Ordner oder in einen Webordner, auf den andere Formularverfasser oder Formularentwickler Zugriff haben.
4.
Benennen Sie die Datei „LocalLibrary.xml“ um, die sich im Ordner „Objekte“ befindet, um Verwechslungen zu vermeiden. Nennen Sie die Datei beispielsweise „SharedLibrary.xml“.
5.
Fügen Sie die gemeinsame Bibliothek zu LiveCycle Designer hinzu, indem Sie die unter So fügen Sie eine gemeinsame Bibliothek hinzu beschriebenen Schritte befolgen.
So erstellen Sie eine gemeinsame Bibliothek ohne vorhandene Bibliothek
1.
Erstellen Sie einen gemeinsamen Ordner oder einen Webordner, auf den Formularverfasser oder Formularentwickler Zugriff haben.
2.
Erstellen Sie in der Palette „Bibliothek“ im gemeinsamen Ordner Unterordner für die einzelnen Kategorien, die Sie gemeinsam verwenden möchten.
3.
Kopieren Sie die Bibliotheksobjekte vom bisherigen Speicherort an den neuen gemeinsamen Speicherort.
Um den aktuellen Speicherort von Objekten oder Kategorien in der Bibliothek anzuziegen, klicken Sie in der Palette „Bibliothek“ auf die Kategorie und wählen Sie im Menü der Palette „Bibliothek“ die Option „Gruppeneigenschaften“ aus. Der Speicherort des Ordners wird im Feld „Speicherort“ angezeigt.
4.
Erstellen Sie mithilfe des Formulars eine neue Objektbibliotheksdatei, wobei Category_name der Name ist, der in der Palette „Bibliothek“ als Kategorietitel angezeigt wird, und folder der Speicherort oder der relative Pfad zu dem Ordner ist, der die Objekte für die Kategorie enthält.

    <?xml version="1.0" encoding="UTF-8"?>
    <objectLibraryTabSet>
        <tab name="Category_name" directory="folder" permission="adm"/>
        <tab name="Category_name" directory="folder" permission="adm"/>
        .
        .
        .
    </objectLibraryTabSet>
5.
Speichern Sie die neue Objektbibliotheksdatei im Stammverzeichnis des gemeinsamen Ordners mit der Dateinamenerweiterung „.xml“.
6.
Fügen Sie die gemeinsame Bibliothek zu LiveCycle Designer hinzu, indem Sie die unter So fügen Sie eine gemeinsame Bibliothek hinzu beschriebenen Schritte befolgen.
So fügen Sie eine gemeinsame Bibliothek hinzu
1.
Wählen Sie im Menü der Palette „Bibliothek“ die Option „Gemeinsame Bibliotheksposition“ aus.
2.
Geben Sie im Feld „Speicherort“ den Namen des gemeinsamen Ordners ein oder wechseln Sie zum gemeinsamen Ordner, der die Objektbibliotheksdatei für die gemeinsame Bibliothek enthält, die Sie hinzufügen möchten.
3.
Klicken Sie auf „OK“.


Grundlagen zu Formularen

Grundlegende Konzepte
Bestandteile eines Formularentwurfs
Interaktive Formulare
Formularentwürfe planen


Grundlegende Konzepte

Formulare und Formularentwürfe
Wie Formulare Informationen erfassen bzw. darstellen
Ansätze zum Erstellen von Formularentwürfen
Wer erstellt Formulare?


Formulare und Formularentwürfe

Formulare werden in der Regel verwendet, um strukturierte Daten zu erfassen oder darzustellen. Sie stellen das Front-End eines Geschäftsprozesses dar. Ein Formular ist das Dokument, das ein Endbenutzer anzeigt und bearbeitet.
Ein Formular beruht auf einem Formularentwurf, den Sie mit Hilfe von LiveCycle Designer erstellen. Der Ausdruck Formularentwurf beschreibt das Formular während der Erstellung oder des Entwurfsprozesses. Im Formularentwurf werden Regeln für das Layout, die Datenerfassung und die endgültige Darstellung des Formulars definiert. Die Regeln werden angewendet, wenn ein Formular mit Daten gefüllt wird. Wie das Formular mit Daten gefüllt wird, hängt vom Zweck des Formulars ab, der wiederum den zu erstellenden Formulartyp bestimmt.
Verwandte Themen
Wie Formulare Informationen erfassen bzw. darstellen
Ansätze zum Erstellen von Formularentwürfen
Woraus besteht ein Formularentwurf?


Wie Formulare Informationen erfassen bzw. darstellen

Der Hauptzweck eines Formulars ist die Informationserfassung oder -anzeige. Diese kann auf drei verschiedene Arten erfolgen.
Interaktive Formulare
Formulare können so konzipiert sein, dass Daten direkt vom Endbenutzer erfasst werden. Benutzer füllen das Formular online aus, wählen Optionen und geben die Formulardaten mit Hilfe eines vorgeschriebenen Prozesses zurück. Diese Formulare bezeichnet man als interaktive Formulare. Im einfachsten Fall benötigt der Endbenutzer nur Adobe Reader®, um das Formular elektronisch auszufüllen und die Formulardaten an den Formularverfasser zurückzuschicken oder das Formular auszudrucken und in Papierform an den Verfasser zurückzusenden. Wenn Sie LiveCycle Forms erworben haben, kann das interaktive Formular im PDF- oder HTML-Format vorliegen. In diesem Fall wird das Formular von den Benutzern in einem Webbrowser geöffnet und ausgefüllt.
Interaktive Formulare können Befehlsschaltflächen enthalten, mit deren Hilfe Benutzer die Daten in einer Datei oder Datenbank speichern oder per E-Mail an eine angegebene Adresse senden können. Darüber hinaus können Überprüfungsmechanismen hinzugefügt werden, um die Richtigkeit der von Benutzern eingegebenen Daten sicherzustellen.
Nicht interaktive Formulare
Formulare können auch zur Darstellung von Informationen für Endbenutzer konzipiert sein. Die Daten können aus verschiedenen Datenquellen stammen, z. B. aus Datenbanken, Webdiensten oder unternehmensinternen Inhaltsmanagementsystemen. Der Endbenutzer zeigt das mit Daten vorausgefüllte Formular einfach an. Er kann die Daten im Formular weder bearbeiten noch neue Daten hinzufügen. Dieser Formulartyp wird als nicht interaktives Formular bezeichnet. Normalerweise spielen bei diesen Formulartypen LiveCycle Forms eine Rolle. LiveCycle Forms führen den Formularentwurf mit Daten zusammen und geben das bereits mit Daten gefüllte Formular für den Endbenutzer wieder. Ein klassisches Beispiel für ein nicht interaktives Formular wäre eine Kreditkartenabrechnung oder eine Telefonrechnung.
Ein Formular könnte aber auch zunächst zur Darstellung von Informationen für den Endbenutzer dienen und dann dem Benutzer die Möglichkeit geben, zusätzliche Informationen einzufügen und das Formular an den Verfasser oder Server zur weiteren Verarbeitung zurückzugeben.
Formulare drucken und ausfüllen
Darüber hinaus gibt es noch den Formulartyp zum Ausdrucken und Ausfüllen. Der Formularautor erstellt den Formularentwurf in LiveCycle Designer und speichert ihn normalerweise als PDF. Der Endbenutzer öffnet das Formular in Acrobat oder Adobe Reader, druckt es und füllt es per Hand aus. Das Formular wird dann per Fax oder Post an den Verfasser zurückgeschickt.
Verwandte Themen
Ansätze zum Erstellen von Formularentwürfen
Vorlagen und der Vorlagen-Manager
Woraus besteht ein Formularentwurf?


Ansätze zum Erstellen von Formularentwürfen

Bevor Sie damit beginnen, mit Hilfe von LiveCycle Designer einen Formularentwurf zu erstellen, sollten Sie sich überlegen, wie das Formular verwendet wird, welche Informationen darin erfasst werden und wie das Formular aussehen soll.
In LiveCycle Designer fügen Sie Funktionen zu Ihrem Formular hinzu, indem Sie Objekte hinzufügen, etwa eine Stelle für die Eingabe von Text oder eine Schaltfläche zum Senden des Formulars per E-Mail. Statische Objekte stellen dabei festen Text oder Grafikinformationen dar. Zu diesen Objekten gehören Kreise, Linien, Rechtecke, Bilder und Text.
Der am häufigsten verwendete Formulartyp sind Formulare mit festem, d. h. vordefiniertem Layout. Diese Formulare besitzen immer eine feste Anzahl von Seiten, unabhängig von der Datenmenge, die in das Formular eingegeben wird. Ein Beispiel hierfür ist ein Registrierungsformular für einen Kurs, den der Benutzer entweder drucken und per Hand oder mit Acrobat bzw. Adobe Reader ausfüllen kann. Das Formular behält beim Ausfüllen sein ursprüngliches Layout und die Anzahl der Seiten bei, unabhängig von der Datenmenge, die in das Formular eingegeben wird. Nicht ausgefüllte Felder bleiben leer. Wenn es umgekehrt mehr Daten gibt, als Platz im Formular verfügbar ist, kann das Formular nicht entsprechend erweitert werden. Wenn ein Kursregistrierungsformular beispielsweise 5 Zeilen für die Eingabe der ausgewählten Kurse durch den Endbenutzer besitzt, jedoch 10 Zeilen für die gewünschte Datenmenge erforderlich wären, sind trotzdem nur 5 Zeilen für die Eingabe verfügbar. Trägt der Endbenutzer nur 2 Kurse ein, bleiben die übrigen 3 Zeilen leer, werden jedoch weiterhin angezeigt.
Ein Formular kann interaktiv sein, wobei ein Endbenutzer das Formular normalerweise in Acrobat oder Adobe Reader ausfüllt, oder nicht interaktiv, wobei das Formular durch einen Serverprozess mit Daten aus einer Datenquelle gefüllt wird. Analog dazu gibt LiveCycle Forms im Allgemeinen nicht interaktive Formulare mit festem Layout wieder, die Informationen von einer Datenquelle darstellen.
Neben Formularen mit festem Layout können Sie Abschnitte in Formularen definieren. Diese werden entsprechend der Menge der Daten erweitert und verkleinert, die bei der Wiedergabe des Formulars zusammengeführt wird. Dies erfolgt, indem Sie verschiedene Abschnitte (Gruppen von Teilformularen) in Teilformulare umbrechen, die auf Textfluss eingestellt sind. Zur Laufzeit werden dann nur die Teilformulare instanziiert, die zur Anzeige der exakten Datenmenge benötigt werden.
Dieser Formulartyp besitzt ein flexibles (fließendes) Layout mit einer variablen Anzahl von Seiten. Die Teilformulare werden entsprechend der Menge der Daten angepasst, die bei der Anzeige des Formulars mit diesem zusammengeführt werden, oder sie werden erweitert, wenn noch mehr Daten vom Endbenutzer hinzugefügt werden müssen. Beispielsweise können Sie es den Endbenutzern überlassen, die für ihre Auswahl benötigte Zeilenanzahl hinzuzufügen, Zeilen aus dem Formular zu löschen und die Formulardaten anschließend elektronisch zurückzusenden. Je nachdem, wie viele Zeilen die Endbenutzer hinzufügen, kann sich das Formular über zwei oder mehr Seiten erstrecken.
Interaktive Formulare mit flexiblem Layout werden manchmal auch als Client-seitige Formulare bezeichnet. Acrobat und Adobe Reader 7.0 oder höher unterstützen diesen Typ von interaktiven Formularen.
Mit LiveCycle Designer können Sie auch Formulare mit flexiblem Layout für die Verwendung mit LiveCycle Forms erstellen. In diesem Fall wird der Formularentwurf über LiveCycle Forms mit Daten zusammengeführt. Telefon- oder Kreditkartenabrechnungen sind normalerweise nicht interaktive Formulare, in denen den Benutzern Informationen aus einer Datenquelle dargestellt werden. Benutzer drucken diese Formulare anschließend aus oder speichern sie elektronisch. Diese Formulartypen werden auch als Server-seitige Formulare bezeichnet, da das Zusammenführen des Formularentwurfs mit Daten über einen Server erfolgt.
Verwandte Themen
Formulare und Formularentwürfe
Info über das Erstellen von Formularentwürfen mit Layoutanpassungen an die Datenmenge
Info über interaktive Formulare mit Layoutanpassungen an die Datenmenge
Woraus besteht ein Formularentwurf?


Wer erstellt Formulare?

In manchen Organisationen übernimmt eine Person die Verantwortung für die Ausarbeitung des Formularentwurfs, und eine andere Person bereitet die Intelligenz vor, die in das Formular integriert werden kann. Sie müssen wissen, wer an der Ausarbeitung und Implementierung des Formulars arbeiten wird.
Bestimmen Sie, ob Geschäftsanalysten Input und Orientierung bereitstellen. Identifizieren Sie die Formularentwickler und Datenverwaltungsexperten, die die Skripten und weitere für die Implementierung des Formulars erforderliche technische Unterstützung liefern werden.
Wenn Sie als Formularverfasser tätig sind, müssen Sie mit dem Formularentwickler und anderen Personen eng zusammenarbeiten, damit Ihre Formulare nach der Bereitstellung ordnungsgemäß funktionieren.
Formularverfasser sind typischerweise für folgende Aufgaben verantwortlich:
      •
      Auswahl der zu verwendenden Dateiformate oder LiveCycle Forms-Konvertierungen anhand der verschiedenen Client-Anwendungen, die möglicherweise zur Anzeige von Formularen verwendet werden (beispielsweise Acrobat, Adobe Reader, ein Webbrowser oder eine Bildschirmlesehilfe).
      •
      Erstellen eines geeigneten Layouts für einen Formularentwurf
      •
      Bereitstellung der Formulare auf einem Server bzw. per E-Mail für die Zielgruppe
Formularentwickler sind gewöhnlich für folgende Aufgaben verantwortlich:
      •
      Herstellen von Datenverbindungen und Vorbereitung von Testdaten für die Formularverfasser, falls Daten mit Formularen zusammengeführt werden sollen
      •
      Verfassen von Skripten, die an Objekte angehängt werden
Verwandte Themen
Allgemeine Verfasserstandards festlegen


Bestandteile eines Formularentwurfs

Woraus besteht ein Formularentwurf?
Masterseiten
Seiten
Inhaltsbereiche
Teilformulare
Tabellen
Feldobjekte
Bausteinobjekte


Woraus besteht ein Formularentwurf?

Ein Formularentwurf wird durch Ziehen von Objekten aus der Palette „Bibliothek“ auf eine oder mehrere Seiten im Layout-Editor erstellt. Mit Hilfe der Palette „Objekt“ bearbeiten Sie die Eigenschaften abhängig vom ausgewählten Objekt. Welche Registerkarten in der Palette „Objekt“ verfügbar sind, hängt vom ausgewählten Objekt ab. Darüber hinaus sind noch viele andere Paletten verfügbar. Diese enthalten spezielle Eigenschaften, die Sie ändern können. Über die Palette „Schrift“ können Sie beispielsweise die Schriftfamilie, die Größe und den Stil des Textes im ausgewählten Objekt ändern.
Sie platzieren die gewünschten Objekte im Formularentwurf auf Seiten. Wenn ein Objekt auf jeder Seite des Formularentwurfs angezeigt werden soll, platzieren Sie es auf einer Masterseite. Sie können beispielsweise ein Logo, ein Wasserzeichen oder einleitende Informationen einschließen, die auf jeder Seite des Formularentwurfs immer an derselben Stelle angezeigt werden sollen.
Ein Formularentwurf besteht aus folgenden Hauptkomponenten:
      •
      Masterseiten
      •
      Seiten
      •
      Inhaltsbereiche
      •
      Teilformulare
      •
      Felder
      •
      Bausteinobjekte
Formularentwurfselemente werden in LiveCycle Designer in der Palette „Hierarchie“ angezeigt.
LiveCycle Designer generiert automatisch XML-Quellcode für jedes Objekt, während Sie den Formularentwurf ausarbeiten. Da LiveCycle Designer den XML-Quellcode für Sie automatisch generiert, können Sie Formularentwürfe erstellen, ohne etwas von XML verstehen zu müssen.
Verwandte Themen
Formulare und Formularentwürfe
Masterseiten
Seiten
Inhaltsbereiche
Teilformulare
Tabellen
Feldobjekte
Bausteinobjekte


Masterseiten

Jeder Formularentwurf enthält mindestens eine Masterseite, die automatisch von LiveCycle Designer erstellt wird. Masterseiten dienen zur Formatierung von Seiten. Sie tragen zur Konsistenz des Formularentwurfs bei, da sie ein Hintergrund- und Layoutformat für mehrere Seiten in einem Formularentwurf bereitstellen können.
Sie können anhand der bereitgestellten Masterseite die Seiten formatieren, die Einstellungen der Masterseite bearbeiten oder bei Bedarf zusätzliche Masterseiten hinzufügen. Wenn Sie ein einfaches interaktives Formular erstellen, werden Sie wahrscheinlich die bereitgestellte Masterseite verwenden, ohne ihre Einstellungen zu ändern.
Masterseiten definieren zumindest die Ausrichtung und die Maße der Seiten. Mit Hilfe von Masterseiten können Sie folgende Aspekte eines Formularentwurfs definieren:
      •
      Seitengröße und -ausrichtung
      •
      Kopf- und Fußzeilen
      •
      Wasserzeichen und Firmenlogos
Beim Erstellen einer Masterseite wird gleichzeitig ein Standard-Inhaltsbereich erstellt, der die ganze Seite umfasst. Sie können einer Masterseite Text, statische Bilder und andere Bausteinobjekte hinzufügen. Diese Objekte werden auf allen Seiten angezeigt, die die Masterseite formatiert.
Textfelder, numerische Felder und Datums-/Uhrzeit-Felder auf Masterseiten sind in Formularen, die mit Acrobat 6 kompatibel sind, nicht interaktiv. Benutzer können die Daten in diesen Feldern nicht verändern.
Masterseiten werden auf der Registerkarte „Masterseiten“ bearbeitet.
Verwandte Themen
Formulare und Formularentwürfe
Info über Masterseiten
Inhaltsbereiche


Seiten

Seiten stellen die Seiten eines Formulars dar. Die Seitengröße und -ausrichtung einer Seite wird von der zugehörigen Masterseite bestimmt. Standardmäßig ist jede Seite mit der Standard-Masterseite verknüpft, die LiveCycle Designer erstellt. Beim Erstellen einer Seite wird gleichzeitig ein Standard-Teilformular erstellt, das die gesamte Seite umfasst.
Wenn Ihr Formularentwurf mehr als eine Masterseite und Seite umfasst, können Sie auswählen, welche Masterseite Sie einer Seite zuordnen möchten.
Seiten werden auf der Registerkarte „Designansicht“ bearbeitet.
Verwandte Themen
Formulare und Formularentwürfe
Info über Seiten
Teilformulare


Inhaltsbereiche

Inhaltsbereiche definieren, wo Objekte auf Seiten platziert werden können. Wenn Sie ein Formular entwerfen, können Sie Objekte ausschließlich innerhalb des Inhaltsbereichs einer Seite platzieren. Sie können Inhaltsbereiche nur Masterseiten zuordnen.
Immer wenn Sie eine neue Masterseite erstellen, erstellt LiveCycle Designer einen Standard-Inhaltsbereich auf der Masterseite.
Ein Formularentwurf mit festem Layout enthält normalerweise einen Inhaltsbereich. Enthält der Formularentwurf Abschnitte, die für die entsprechende Datenmenge angepasst werden, kann der Formularentwurf einen oder mehrere Inhaltsbereiche umfassen. Sie können festlegen, ob die Objekte in jedem Inhaltsbereich von oben nach unten bzw. von links nach rechts und von oben nach unten positioniert werden sollen.
Verwandte Themen
Inhaltsbereiche – Übersicht


Teilformulare

Teilformulare sind Container-Objekte, mit denen Sie Formularentwurfsobjekte gruppieren können, einschließlich Feldern, Bausteinobjekten und anderen Teilformularen. Nach der Gruppierung können Sie steuern, ob das Teilformular und die gruppierten Objekte basierend auf von Ihnen für das Formular konfigurierten Datenbindungen im Formular angezeigt werden. Sie können Teilformularobjekte aber auch als wiederholbare Objekte konfigurieren, so dass in Ihrem Formular mehrere Exemplare eines Teilformulars und seiner gruppierten Objekte auftreten können. Auf diese Weise lassen sich flexiblere und anpassbarere Formularentwürfe erstellen.
Teilformulare sind wesentliche Komponenten bei der Erstellung von Formularen mit Abschnitten, die sich der entsprechenden Datenmenge anpassen, denn sie enthalten die dynamischen Funktionen für die Sichtbarkeit, zum Ausblenden und Ausdehnen, abhängig von den Daten und der Benutzerinteraktion zur Laufzeit.
Verwandte Themen
Inhaltsbereiche – Übersicht


Tabellen

Tabellen sind im Grunde strukturierte Container-Objekte, mit denen Sie den Inhalt Ihres Formularentwurfs auf sinnvolle und logische Weise gliedern können. Jede Tabellenzelle ist ein separater Container, der Formularentwurfsobjekte speichern kann.
Tabellen sind Teilformularen in Bezug auf Funktionalität und Verhalten sehr ähnlich. Wie Teilformulare können Tabellen dynamisch sein, so dass sie je nach Daten und Benutzerinteraktion zur Laufzeit Wiederholungen durchführen und sich ausdehnen können.
Verwandte Themen
Info über Tabellen
Teilformulare


Feldobjekte

LiveCycle Designer stellt eine Reihe von Feldobjekten bereit, die Daten erfassen, zusammenführen und anzeigen können. Ein Feldobjekt bietet einen Dateneingabebereich, und Benutzer können Feldobjekte nutzen, indem sie einen entsprechenden Datenwert eingeben oder auswählen.
Bei den folgenden Objekten handelt es sich um Feldobjekte:
      •
      Schaltfläche
      •
      Kontrollkästchen
      •
      Datum-/Uhrzeitfeld
      •
      Dezimalfeld
      •
      Dokumentunterschriftsfeld
      •
      Dropdown-Liste
      •
      E-Mail-Senden-Schaltfläche
      •
      HTTP-Senden-Schaltfläche
      •
      Bildfeld
      •
      Listenfeld
      •
      Numerisches Feld
      •
      Papierformular-Barcode
      •
      Kennwortfeld
      •
      Drucken-Schaltfläche
      •
      Optionsfeld
      •
      Textfeld
Verwandte Themen
Was ist ein Objekt?
Bausteinobjekte


Bausteinobjekte

Bausteinobjekte oder statische Objekte sind schreibgeschützte Objekte, die das Erscheinungsbild eines Formulars verbessern und gleichzeitig den Benutzern zusätzliche Informationen bieten oder Hilfestellung geben. Sie können Seiten oder Masterseiten hinzugefügt werden.
Bei den folgenden Objekten handelt es sich um Bausteinobjekte:
      •
      Kreis
      •
      Bild
      •
      Linie
      •
      Rechteck
      •
      Text
Verwandte Themen
Was ist ein Objekt?
Feldobjekte


Interaktive Formulare

Info über interaktive Formulare
Vorteile interaktiver Formulare
Objekte in interaktiven Formularen verwenden
Berechnungen und Skripten in interaktiven Formularen
Unterschiede beim Ausfüllen von Formularen in Acrobat und Adobe Reader


Info über interaktive Formulare

Ein interaktives Formular ist ein elektronisches Formular, das von den Benutzern geöffnet und online ausgefüllt wird. Sie können interaktive Formulare erstellen, die von den Benutzern in Acrobat Professional, Acrobat Standard oder Adobe Reader ausgefüllt werden. Außerdem haben Sie die Möglichkeit, Formulare für LiveCycle Forms zu verfassen, die in einem Webbrowser ausgefüllt werden.
Der Benutzer gibt Daten direkt in die Felder des Online-Formulars ein. Das Formular kann die von dem Benutzer eingegebenen Daten erfassen und ein Feedback geben, wie z. B. Meldungen, um zur Eingabe spezieller Arten von Daten aufzufordern. Das Formular kann integrierte Intelligenz enthalten, die die vom Benutzer eingegebenen Daten direkt in einem angegebenen Datenerfassungssystem eines Unternehmens, wie z. B. einer Datenbank, verarbeitet.
Interaktive Formulare enthalten typischerweise Dateneingabefunktionen, wie z. B. Auswahllisten, Dropdown-Listen, Kontrollkästchen, automatisch generierte Berechnungen, Überprüfungsmeldungen, digitale Unterschriften und die Schaltflächen „Senden“ und „Ausführen“. Formularverfasser können integrierte FormCalc-Funktionen und benutzerdefinierte Skripten mit JavaScript verwenden, um die Funktionalität interaktiver Felder zu erweitern.
Wenn Sie interaktive Formulare für LiveCycle Forms entwickeln, sollten Sie auch das Hilfethema Formulare für LiveCycle Forms entwerfen lesen. Es gibt einige Entwurfsunterschiede und erweiterte Funktionen, die Sie bei Formularen anwenden können, die an LiveCycle Forms weitergegeben werden.
Verwandte Themen
Formulare und Formularentwürfe
Formulare für LiveCycle Forms entwerfen
Datenquellen
Schritte zum Verfassen eines Formularentwurfs
So erstellen Sie ein benutzerdefiniertes Objekt
Info über die Vorschau und das Testen von Formularen


Vorteile interaktiver Formulare

Obwohl interaktive Formulare wie traditionelle Formulare in Papierform aussehen, beseitigen sie den mit Papierformularen verbundenen lästigen und zeitraubenden Verarbeitungsaufwand. Die Verwendung interaktiver Formulare zur Bereitstellung von Geschäftslösungen ist in einer Welt von Internet und unternehmensweiter Datenverarbeitung sinnvoll.
Sie können interaktive Formulare über das Internet, Intranet oder E-Mail verteilen. Sie können den Prozess des Dokumentaustauschs automatisieren, Formulare in zuverlässigen Formaten speichern und Dokumentinhalte sowie die Dokumentintegrität schützen.
Interaktive Formulare ermöglichen es Ihnen, den Datenerfassungsprozess zu rationalisieren. Ein interaktives Formular kann Daten sammeln und in Ihre existierenden Kerndatenerfassungssysteme integrieren und gleichzeitig deren Wert steigern. Das Formular kann Daten direkt in Ihr Datenerfassungssystem integrieren oder ein Programm auf dem Server verwenden, beispielsweise ein CGI-Skript, eine ASP-Seite, JSP oder ein Servlet.
Mit interaktiven Formularen können Sie auch Arbeitsablaufprozesse aufbauen, die auf Online-Formularen basieren, indem Sie Formulare mit Hilfe integrierter Logik von einem Benutzer zum nächsten elektronisch weiterleiten. Interaktive Formulare können auch Hilfstechnologien unterstützen, wie z. B. Bildschirmlesehilfen, so dass die Formulare auch von behinderten Benutzern verwendet werden können.
Verwandte Themen
Formulare und Formularentwürfe


Objekte in interaktiven Formularen verwenden

LiveCycle Designer enthält mehrere Standardobjekte und benutzerspezifische Objekte, die Funktionen zur Dateneingabe und zum Zugriff bieten und Berechnungen und Skripten unterstützen, mit denen Aktionen initiiert und Daten erfasst und verarbeitet werden können. Sie können alle interaktiven Objekte, aber auch statische Objekte wie Textfelder und Zeichenobjekte in einem Formular verwenden.
Zusätzlich haben Sie die Möglichkeit, eigene interaktive Objekte zu erstellen, deren Eigenschaften und Merkmale Sie häufig in Ihren Formularen verwenden möchten. Sie erstellen eigene Objekte, indem Sie Eigenschaften definieren und die erforderlichen Funktionen wie z. B. Skripten oder Berechnungen zu Standard-LiveCycle Designer-Objekten hinzufügen. Benutzerdefinierte Objekte in der Palette „Bibliothek“ speichern Sie entweder in der Kategorie „Eigene“ oder in einer selbst erstellten Kategorie.
Beim Auswählen von Objekten sollten Sie wissen, welche Funktionen und Möglichkeiten diese Objekte bieten. Beachten Sie dabei die folgenden Punkte:
      •
      Bestimmen Sie die Art der Informationen, die im Formular enthalten sein müssen, und machen Sie sich mit den Merkmalen der Objekte vertraut.
      •
      Beachten Sie, dass Felder unterschiedliche Längen, Erscheinungsbildanforderungen und -optionen sowie Dateneingabebeschränkungen und -anforderungen haben.
      •
      Analysieren Sie die Datentypen, die Sie anzeigen und erfassen möchten, und bestimmen Sie, welche Objekte diese Datentypen unterstützen.
      •
      Bestimmte Objekte ermöglichen es Ihnen, Berechnungen hinzuzufügen und Skripten zu schreiben, um Aktionen im Feld auszulösen. Bestimmen Sie, welche Skriptarten Sie mit bestimmten Objekten verwenden können.
Verwandte Themen
Was ist ein Objekt?
So erstellen Sie ein benutzerdefiniertes Objekt


Berechnungen und Skripten in interaktiven Formularen

Sie können die integrierten Berechnungssprachen FormCalc oder JavaScript verwenden, um benutzerdefinierte Skripten zum Berechnen und Überprüfen von Daten oder zum Initiieren von Befehlen und Aktionen als Folge eines bestimmten Ereignisses in einem Feld zu schreiben. Wenn ein Benutzer das Formular ausfüllt und ein bezeichnetes Ereignis initiiert (z. B. das Klicken auf eine Schaltfläche), wird das Skript ausgeführt.
LiveCycle Designer unterstützt eine ganze Reihe von Optionen für Berechnungen, die häufig in interaktiven Formularen anzutreffen sind. Die integrierten FormCalc-Funktionen umfassen mathematische, Datum- und Uhrzeit-, Zeichenfolge-, Finanz- und Logikfunktionen. Sie können auch benutzerdefinierte Skripten schreiben, um Berechnungen nach Bedarf durchzuführen.
Diese Beispiele zeigen, wann Sie eine Berechnung oder ein Skript einfügen können:
      •
      Fügen Sie ein Skript zu einer Dropdown-Liste hinzu, um ein anderes Feld mit Daten zu füllen, je nach Auswahl des Benutzers in der Dropdown-Liste.
      •
      Fügen Sie eine Berechnung in ein numerisches Feld ein, um eine Summe oder die Erhöhung oder Verringerung eines Prozentsatzes einer Reihe von Feldern zu berechnen und das Ergebnis im Feld „Summe“ anzuzeigen.
      •
      Erstellen Sie ein Skript, um eine Datenbankabfrage zu initiieren, z. B. um eine Dropdown-Liste zu füllen oder um Beschreibungen von Elementen in einer Dropdown-Liste anzuzeigen.
Wenn Sie ein Skript an ein Objekt anhängen möchten, müssen Sie das Ereignis angeben, durch das das Skript ausgelöst wird. Ein Ereignis kann beispielsweise ein Änderungsereignis sein, z. B. wenn ein Benutzer ein neues Element in einem Listenfeld oder einer Dropdown-Liste auswählt. Das Ereignis kann auch ein click-Ereignis sein, das ein Skript auslöst, wenn der Benutzer auf ein Objekt klickt.
Weitere Informationen zum Erstellen von Berechnungen und Skripten finden Sie unter Berechnungen und Skripten.
Verwandte Themen
So fügen Sie eine Standardschaltfläche zum Ausführen einer Berechnung oder eines Skripts ein
So hängen Sie ein Datenbankskript an eine Schaltfläche an
Mit einer Schaltfläche Felder aus einer Datenbank ausfüllen


Unterschiede beim Ausfüllen von Formularen in Acrobat und Adobe Reader

Formularverfasser sollten sich bei der Erstellung interaktiver Formulare über folgende Aspekte bewusst sein:
      •
      Benutzer können PDF-Formulare in Acrobat oder Adobe Reader ausfüllen.
      •
      Beachten Sie, welche Version von Acrobat und Adobe Reader die Benutzer zum Ausfüllen des Formulars verwenden: Für Acrobat 7.0 gespeicherte PDF-Formulare müssen in einer Version von Acrobat oder Adobe Reader ab Version 7.0 geöffnet werden. Für Acrobat 6.0 gespeicherte PDF-Formulare müssen in einer Version von Acrobat oder Adobe Reader ab Version 6.0.2 geöffnet werden.
      •
      Die folgende Tabelle zeigt die Verfügbarkeit der Funktionen von LiveCycle Designer 7.1 in Formularen, die als Acrobat 6.0-kompatible, statische oder dynamische PDF-Formulare in LiveCycle Designer 7.1 gespeichert wurden.

LiveCycle Designer 7.1-Funktion

Verfügbar in einem Acrobat 6.0-kompatiblen PDF-Formular

Verfügbar in einem statischen PDF-Formular

Verfügbar in einem dynamischen PDF-Formular
Papierformular-Barcode*
N
J
J
Interaktive Barcodes
N
J
J
Interaktive Bilder
N
N
J
Formulare mit flexiblen Layout-Funktionen
N
N
J
Barrierefreie Formulare
J
J
J
EXIF-Grafikunterstützung
J**
J
J
Darstellung der Schaltflächen beim Drucken
N
J
J
Punkte in Elementnamen
N
J
J
<xs:import>-Unterstützung
J
J
J
* Bei Symbolen für QR-Code und Datenmatrix sind Acrobat oder Adobe Reader 7.0.5 zum Ausfüllen erforderlich. Speichern Sie bei Verwendung von Formular-Barcodes mit Symbolen für QR-Code und Datenmatrix das Formular im Format für Acrobat 7.0.5.
** EXIF wird von Acrobat 7.0 unterstützt. In Acrobat 6.0.2 erfolgt eine Umwandlung in JPEG.
      •
      Wenn der Formularentwurf Skripten enthält, die das Erscheinungsbild von Objekten im PDF-Formular zur Laufzeit verändern, sollten Sie den Formularentwurf als dynamisches PDF-Formular speichern.
      •
      Acrobat unterstützt alle interaktiven Funktionen wie das Ausfüllen von Formularen, lokales Speichern, digitale Unterschriften, Überprüfung und Markup, Datenbank- und Webdienstabrufe und Drucken. Die folgende Tabelle zeigt, welche Objekte abhängig vom gespeicherten PDF-Typ interaktiv sind.

Funktion

Acrobat 6.0.2

Statisches PDF-Formular

Dynamisches PDF-Formular
Feld- und Schaltflächenobjekte auf einer Masterseite
N
J
J
Feld- und Schaltflächenobjekte in Überlaufkopfbereich/-fußbereich-Teilformularen
N
J
J
Erweiterbare Felder
N
J
J
Schwebende Felder
N
N
N
Felder, für die das ready::$layout -Ereignis festgelegt wurde.
N
J
J
Formularlayout kann geändert werden
N
N
J
      •
      Adobe Reader unterstützt einen geringeren Funktionsumfang und bietet Benutzern die Möglichkeit zum Ausfüllen und Drucken von Formularen und in einigen Fällen auch zum Senden der Formulare. Um die Funktionalität von Adobe Reader auf die von Acrobat zu erweitern, müssen Sie Verwendungsrechte für das Formular mit LiveCycle Reader Extensions festlegen. Weitere Informationen finden Sie unter PDF-Sicherheitsoptionen.
      •
      Acrobat und Adobe Reader unterstützen den Client-seitigen Datenaustausch für interaktive PDF-Formulare.
      •
      Eine Server-seitige Datenverarbeitung wie die dynamische Wiedergabe und Wiederanzeige von Formularen zur Laufzeit ist durch LiveCycle Forms verfügbar.
Verwandte Themen
So speichern Sie Formularentwürfe


Formularentwürfe planen

Die geschäftlichen Grundlagen eines Formulars ermitteln
Die Benutzeranforderungen ermitteln
Geeignete Objekte für ein Formular auswählen
Allgemeine Verfasserstandards festlegen
Bedienfreundlichkeit des Formulars
Schritte zum Verfassen eines Formularentwurfs
Checkliste für den Formularentwurf


Die geschäftlichen Grundlagen eines Formulars ermitteln

Zunächst müssen Sie feststellen, welchen geschäftlichen Anforderungen das Formular genügen soll. Möglicherweise erhalten Sie Vorgaben von Ihrer Geschäftsleitung oder Sie müssen intensivere Untersuchungen anstellen, um das am besten geeignete Design zu ermitteln. Wenn Sie die Zielsetzung des Formulars ermitteln, berücksichtigen Sie folgende Aspekte:
      •
      Die Rolle des Formulars in einer umfassenderen Geschäftslösung.
      •
      Ist ein Schema oder eine Vorlage als Modell für das Formular verfügbar?
      •
      Anforderungen an die Datenerfassung: Die Daten, die Sie erfassen oder weiterleiten möchten, und wie diese Daten erfasst und verarbeitet werden sollen. Geben Benutzer alle Daten manuell ein oder können auch Daten zusammengeführt werden? Falls Daten von Benutzern gesammelt werden, werden die Daten mit Hilfe von Acrobat oder Adobe Reader lokal gespeichert oder an LiveCycle Forms übergeben?
      •
      Berechnungen oder Skripten, die mit den Daten verknüpft sind, und die Frage, an welcher Stelle sie ausgeführt werden (Client, Server oder Client und Server). Skripten werden nur auf einem Server ausgeführt, wenn Formulare über LiveCycle Forms bereitgestellt werden.
      •
      Die Komplexität des Formulars. Ist es nötig, dass das Formular einfach und frei von Abhängigkeiten ist, oder sollte es ein anspruchsvolleres Ausfüllerlebnis bieten, vielleicht mit mehreren Abhängigkeiten?
      •
      Die Verteilung des Formulars als Teil eines Geschäftsprozesses und die Anzahl der Personen, die möglicherweise Einfluss auf die Formulargestaltung haben.
      •
      Anforderungen an die Sicherheit: Ist zum Öffnen, Drucken oder Kopieren von Text oder zum Anbringen einer Unterschrift ein Kennwort erforderlich?
      •
      Die Übersetzungsanforderungen.
Verwandte Themen
Geeignete Objekte für ein Formular auswählen
Sichere Formulare


Die Benutzeranforderungen ermitteln

Beim Entwurf eines Formulars sollten die Bedürfnisse der Personen, die Ihre Formulare verwenden, stets im Vordergrund stehen. Sie müssen die geschäftlichen Anforderungen Ihrer Benutzer verstehen und eine Reihe von Zielen identifizieren, an denen sich das Design Ihrer Formulare orientiert. So gewährleisten Sie auch, dass Ihre Formulare ausschließlich zweckdienliche Inhalte enthalten. Je klarer Ihre Ziele, desto besser der Formularentwurf. Behalten Sie immer die Hauptfunktion Ihres Formulars in Hinblick auf die Benutzeranforderungen im Auge:
      •
      Wobei ist das Formular den Benutzern behilflich und warum?
      •
      Muss das Formular Informationen von Benutzern sammeln, den Benutzern Informationen liefern oder beides?
      •
      Benötigen Benutzer Anweisungen und wenn ja, befinden diese Informationen sich im Formular selbst oder in einem zugehörigen Dokument?
      •
      Möchten Benutzer die Seiten nacheinander durchlesen? Falls nicht, welche Erwartungen haben Benutzer in Hinblick auf die Navigation durch das Formular?
      •
      Werden Benutzer mit dem Formular interaktiv arbeiten (z. B. Durchsuchen einer Auswahl von Elementen nach Name oder Preis, Auswahl von Optionen, Bestellen spezieller Artikel oder Eingabe von Daten)?
In der Regel werden Formulare von Benutzern folgendermaßen genutzt:
      •
      Sie öffnen ein leeres Formular online, drucken es und füllen es von Hand aus.
      •
      Sie öffnen ein leeres Formular online, füllen es online oder offline aus und senden die Informationen online.
      •
      Sie zeigen ein Online-Formular an, das zusammengeführte Daten enthält (die Zusammenführung erfolgt durch eine Anwendung oder online durch einen anderen Benutzer) und drucken es auf Papier aus.
      •
      Sie zeigen ein Online-Formular an, das zusammengeführte Daten enthält, bearbeiten die Informationen nach Wunsch online und senden die geänderten Informationen online.
      •
      Sie füllen einen Teil eines Formulars online aus und übergeben es an einen automatisierten Arbeitsablauf oder einen anderen Benutzer zur Weiterverarbeitung.
Verwandte Themen
Die geschäftlichen Grundlagen eines Formulars ermitteln
Geeignete Objekte für ein Formular auswählen
Bedienfreundlichkeit des Formulars
Barrierefreie Formulare


Geeignete Objekte für ein Formular auswählen

Damit Sie für Ihr Formular die am besten geeigneten Objekte auswählen können, berücksichtigen Sie folgende Punkte:
      •
      Handelt es sich um ein interaktives oder ein nicht interaktives Formular?
      •
      Die Art der Informationen und Daten, die in Ihr Formular aufgenommen werden müssen, sollte bei der Entscheidung, welche Objekte für die Erfassung und Anzeige der Daten erforderlich sind, ausschlaggebend sein.
      •
      Visuelle und funktionale Konsistenz in der Darstellung im gesamten Design verbessert die Nutzbarkeit des Formulars.
      •
      Eine klare Zielsetzung für die Darstellung und Entwicklung einer allgemeinen Struktur für die Seiten, Abschnitte und Unterabschnitte erleichtert die Anordnung verbundener Informationen in den Abschnitten und die Ermittlung der für das Design benötigten Anzahl von Masterseiten und Seiten.
      •
      Wenn Sie ein Formular mit Teilformularen entwerfen, die sich der entsprechenden Datenmenge anpassen, und verschiedene Arten von Datenstrukturen kombinieren oder eine große Menge Inhalt auf anspruchsvolle Weise präsentieren möchten, stellen Sie einen speziellen Plan für die Reihenfolge auf, in der die Inhaltsbereiche und Teilformulare platziert werden müssen.
Verwandte Themen
Was ist ein Objekt?
Die Benutzeranforderungen ermitteln
Allgemeine Verfasserstandards festlegen
Bedienfreundlichkeit des Formulars


Allgemeine Verfasserstandards festlegen

Legen Sie Entwurfsrichtlinien fest, damit Sie und Ihre Mitarbeiter einen konsistenten Formularentwurf erarbeiten können:
      •
      Legen Sie allgemein gültige LiveCycle Designer-Optionen und Einstellungen für die Formulareigenschaften fest.
      •
      Legen Sie das geeignete Gebietsschema für das Formular fest.
      •
      Entscheiden Sie, wie Sie Hilfslinien, Raster und Linealintervalle einstellen.
      •
      Bestimmen Sie, wie und wann Sie Ränder, Begrenzungen, Schriften, Textausrichtung und Objektbeschreibungen verwenden.
      •
      Erörtern Sie, welche Objekte Sie verwenden möchten, wann diese verwendet werden und wohin sie platziert werden.
      •
      Erwägen Sie die Erstellung von Objekten, die von den Formularverfassern gemeinsam verwendet werden können; dazu gehören etwa Kopfzeilen, Adressblöcke und Fußzeilen.
      •
      Bauen Sie eine Bibliothek mit benutzerdefinierten Objekten auf, z. B. Logos, Bilder oder Wasserzeichen, um die Konsistenz zu wahren und Produktionszeit zu sparen.
      •
      Identifizieren Sie Designelemente, die verschiedenen Abschnitten des Formulars gemeinsam sind, insbesondere wenn das Formular länger als eine einzige Seite ist. Dies gibt Ihnen die Möglichkeit, den Befehl „Mehrere kopieren“ zu verwenden und so die Produktionszeit zu verringern. Ferner können Sie schnell feststellen, welche benutzerdefinierten Objekte der Objektbibliothek zur wiederholten Verwendung hinzugefügt werden sollten, und Sie können die Anzahl der erforderlichen Masterseiten genau berechnen.
      •
      Entscheiden Sie, welche Skriptsprache verwendet werden soll: FormCalc oder JavaScript.
      •
      Überlegen Sie, welche Sicherheitsoptionen auf das Formular angewendet werden sollen.
      •
      Legen Sie gegebenenfalls Zugriffsstandards fest:
Verwandte Themen
Der Arbeitsbereich
So erstellen Sie ein benutzerdefiniertes Objekt


Bedienfreundlichkeit des Formulars

Berücksichtigen Sie bei der Planung eines Formulars auch seine Bedienfreundlichkeit. Beachten Sie dabei Folgendes:
      •
      Ein Formular sollte logisch aufgebaut sein und ein einfaches Layout mit klaren, leicht verständlichen Beschriftungen aufweisen. Überlegen Sie, wie Sie zusammengehörige und nicht zusammengehörige Informationen voneinander trennen und gruppieren können. Betrachten Sie die Größe der Abschnitte und versuchen Sie, Abschnitte zu erstellen, die weder zu klein noch zu groß sind.
      •
      Ein Formular sollte eine einfache Navigation erlauben. In LiveCycle Designer können Sie die Tab-Reihenfolge zwischen Objekten festlegen. Überlegen Sie, wie man am besten von einem Abschnitt eines Formulars zum nächsten gelangt, und bestimmen Sie, ob ein Satz Seiten reicht oder ob mehrere Formulare benötigt werden. Material kann hierarchisch oder linear (nacheinander) präsentiert werden, oder Sie können Alternativen bereitstellen, die sich von einem einzelnen Punkt aus verzweigen.
      •
      Ein Formular sollte bedienfreundlich sein. Ein einfaches Layout mit klaren, sinnvollen Beschriftungen erleichtert das Verständnis. Formulare können Benutzereingaben überprüfen und Eingabeaufforderungen anzeigen, die den Benutzern bei der Dateneingabe behilflich sind. Wenn LiveCycle Forms verfügbar ist, können einige Details mit Hilfe von zusammengeführten Daten bereits vorher ausgefüllt werden. Zusätzlich können Skripten, die an Objekte angehängt werden, zur Laufzeit numerische Werte automatisch berechnen. Wenn Sie das Schreiben von Skripten beherrschen, können Sie auch Skripten entwickeln, die Daten und Formulare nach dem Klicken auf Schaltflächen automatisch verarbeiten oder weiterleiten.
      •
      Ein Formular sollte für Benutzer mit Behinderungen zugänglich sein.
Verwandte Themen
Barrierefreie Formulare
Info über die Tab-Reihenfolge


Schritte zum Verfassen eines Formularentwurfs

Die Erstellung von Formularen setzt eine gründliche Auseinandersetzung mit den Anforderungen an das Design sowie eine sorgfältige Planung des Inhalts, des Designs und des Layouts voraus. Dabei müssen auch die speziellen Anforderungen des gewünschten Formulartyps berücksichtigt werden. Wenn Sie ein Formular erstellen, gehen Sie wie im Folgenden beschrieben vor.
1.
Entscheiden Sie, welchen Zweck Sie mit dem Formular verfolgen, und beschaffen Sie sich dann die dazu benötigten Informationen und Werkzeuge.
2.
Öffnen Sie einige der mitgelieferten Musterformulare oder Vorlagen, um sich mit LiveCycle Designer und den verfügbaren Objekten vertraut zu machen.
3.
Führen Sie einen der folgenden Schritte aus:
      •
      Wenn eines der Musterformulare bzw. eine der Vorlagen Ihren Anforderungen entspricht, verwenden Sie dieses Formular bzw. diese Vorlage als Ausgangspunkt.
      •
      Erstellen Sie einen völlig neuen Formularentwurf.
4.
Ändern Sie gegebenenfalls die Papiergröße und -ausrichtung und richten Sie Leerraum, Kopf- und Fußzeilen sowie Bausteinobjekte auf Masterseiten ein.
5.
Richten Sie die Seiten ein.
6.
Erstellen Sie die erforderlichen Berechnungen oder Skripten und binden Sie diese in die Objekte ein.
7.
Vergewissern Sie sich, dass Ihr Formular fertig ist.
8.
Testen Sie das Formular lokal.
In Acrobat und Adobe Reader werden verschiedene Funktionen unterstützt. Wenn in Ihrer Benutzerumgebung beide Anwendungen vorhanden sind, sollten alle Formulare in beiden Anwendungen getestet werden.
9.
Wenn Sie an einer unternehmensweiten Lösung arbeiten, übergeben Sie Ihre Formularentwurfsdateien an den Server und testen Sie die Datei aus der Sicht und in der Rolle eines Benutzers.
10.
Stellen Sie die fertige Lösung bereit.
Verwandte Themen
Ansätze zum Erstellen von Formularentwürfen
Wer erstellt Formulare?
Checkliste für den Formularentwurf


Checkliste für den Formularentwurf

In einer Checkliste können Sie Dinge wie projektspezifische Details, Benutzereinstellungen und allgemeine Regeln erfassen, um zu gewährleisten, dass die für mehrseitige Formulare entworfenen Elemente miteinander kompatibel sind. Eine Checkliste kann auch dazu beitragen, dass Sie bei der Ausarbeitung einer Lösung das Wesentliche nicht aus den Augen verlieren. Beispielsweise können Sie eine Checkliste wie die unten stehende zusammenstellen und Spezifikationen für Ihre Organisation einfügen.

Element

Spezifikationen
Seitengröße und -ausrichtung
(für Masterseite)
Seitengröße (z. B. Letter)
Ausrichtung (z. B. Hochformat)
Logos und Grafiken
Erforderliches Dateiformat (z. B. TIF)
Formulareigenschaften
Formulartitel mit Formulareigenschaften speichern (Ja oder Nein)
Gebietsschema (z. B. des Anzeigeprogramms)
Standard-Skript-Sprache (z. B. JavaScript)
Ein-/Ausgabehilfe
Für Objekte erforderliche QuickInfos (Objekte angeben, für die QuickInfos erforderlich sind)
Rangfolge der Bildschirmlesehilfen (z. B. QuickInfos)
Tab-Reihenfolge
Einstellung (z. B. Links nach rechts)
Allgemein gültige Einstellungen für Schriften und Zeichnungen
Linienstärke (z. B. gleiche Stärke für alle Linien)
Alle Beschriftungen(gleiches Schriftbild und gleiche Schriftgröße)
Alle Datenwerte (gleiches Schriftbild und gleiche Schriftgröße)
Objekteigenschaften
Feldbegrenzungen und Hintergrundfarbe (Ja oder Nein)
Hintergrundfarbe von füllbaren Bereichen (z. B. ein RGB-Wert)
Feldnamen (z. B. siehe Liste „Feldname“)
Formularintelligenz
Auszufüllende Felder (Felder angeben)
Für erforderliche Felder festzulegende Eingabeaufforderungen (Erforderliche Eingabeaufforderungen festlegen)
Verwandte Themen
Schritte zum Verfassen eines Formularentwurfs


Quick Start-Lernprogramme

Quick Start-Lernprogramme

Info über die Quick Start-Lernprogramme
Umfrageformular für einen Betriebsausflug erstellen
Bestellformular erstellen
Bestellformular mit Abschnitten erstellen, die an die entsprechende Datenmenge angepasst werden


Info über die Quick Start-Lernprogramme

Dieser Abschnitt enthält Lernprogramme zur Einführung in LiveCycle Designer.
Umfrageformular für einen Betriebsausflug erstellen
In diesem Lernprogramm erfahren Sie, wie Sie ein Umfrageformular für ein Firmenpicknick erstellen, das die Schaltfläche „Per E-Mail senden“ enthält. Wenn eine Person nach dem Ausfüllen des Formulars auf diese Schaltfläche klickt, werden die eingegebenen Informationen per E-Mail an Sie gesendet.
Bestellformular erstellen
Dieses Lernprogramm führt Sie durch die Erstellung eines interaktiven Bestellformulars, das die Schaltfläche „Formular drucken“ enthält. Wenn die Person, die das Formular ausfüllt, auf diese Schaltfläche klickt, wird das Formular gedruckt. Diese Person stellt Ihnen das gedruckte Formular dann zu. In diesem Lernprogramm erfahren Sie, wie man Objekte und einfache Berechnungen hinzufügt.
Bestellformular mit Teilformularen erstellen, das an die entsprechende Datenmenge angepasst wird
In diesem Lernprogramm erfahren Sie, wie Sie das feste Layout eines Formulars mit Hilfe von Teilformularen in ein Layout ändern, das sich der entsprechenden Datenmenge anpasst, so dass das Formular alle Bestellungen des jeweiligen Kunden anzeigt. Außerdem lernen Sie hier, wie Sie ein Formular mit Daten zusammenführen.
Um fortzufahren, klicken Sie auf:
Umfrageformular für einen Betriebsausflug erstellen
Bestellformular erstellen
Bestellformular mit Abschnitten erstellen, die an die entsprechende Datenmenge angepasst werden


Umfrageformular für einen Betriebsausflug erstellen

Umfrageformular für einen Betriebsausflug erstellen
Formularentwurf mit dem Assistenten für neue Formulare erstellen
Schaltfläche „Per E-Mail senden“ positionieren
Titel „Firmenpicknick – Umfrage“ hinzufügen
Textfeld für den Namen hinzufügen
Dropdown-Liste für die Teilnehmerzahl hinzufügen
Textobjekt für Anleitungen hinzufügen
Optionsfeldobjekt für Termine hinzufügen
Kontrollkästchenobjekt für Aktivitäten hinzufügen
Eigenen Formularentwurf speichern
Vorschau Ihrer Arbeit anzeigen
Formularentwurf abschließen
Daten in einer Tabellenkalkulation sammeln
Wie geht es weiter?


Umfrageformular für einen Betriebsausflug erstellen

Es ist mal wieder soweit. Trotz Ihres prall gefüllten Terminkalenders hat man Sie darum gebeten, den Fragebogen vom letzten Jahr herauszusuchen und unter Ihren Mitarbeitern eine Umfrage zum alljährlichen Picknick zu machen. Wieder stehen Sie vor der Aufgabe, die Umfrage zu aktualisieren und zu verteilen, die ausgefüllten und gedruckten Fragebögen einzusammeln, zahllose Mahnungen an Ihre Kollegen zu senden und schließlich sämtliche Antworten auszuwerten und manuell auf eine Tabelle zu übertragen.
Wäre es nicht schön, wenn Sie eine elektronische Version der Umfrage erstellen und diese dann einfach an Ihre Kollegen senden könnten? Jeder Mitarbeiter könnte dann den Fragebogen direkt ausfüllen und seine Antworten einfach durch Klicken auf eine in das Formular integrierte Schaltfläche per E-Mail an Sie zurücksenden. Hier erfahren Sie, wie man das macht.
In diesem Lehrgang lernen Sie, wie Sie ein Umfrageformular für ein Firmenpicknick erstellen, das die Schaltfläche „Per E-Mail senden“ enthält. Wenn eine Person nach dem Ausfüllen des Formulars auf diese Schaltfläche klickt, werden die eingegebenen Informationen per E-Mail an Sie gesendet.
Im Rahmen dieses Lehrgangs erstellen Sie ein Formular, das ungefähr so aussieht:
Sie erstellen in LiveCycle Designer einen Formularentwurf. In diesem Formularentwurf definieren Sie das Layout und legen fest, nach welchen Regeln die Datenerfassung in dem fertigen Formular erfolgt. Wenn Sie fertig sind, speichern Sie den Formatentwurf im PDF-Format. Dies ist das Formular, das Sie an den gewünschten Personenkreis verteilen.
Um fortzufahren, klicken Sie auf: Formularentwurf mit dem Assistenten für neue Formulare erstellen


Formularentwurf mit dem Assistenten für neue Formulare erstellen

In LiveCycle Designer gibt es verschiedene Möglichkeiten, einen neuen Formularentwurf zu beginnen. Im Rahmen dieses Lehrgangs verwenden Sie den Assistenten für neue Formulare, um ein Umfrageformular für ein Picknick zu erstellen. Dieser Assistent nimmt Ihnen jede Unsicherheit. Er führt Sie Schritt für Schritt durch eine Reihe von Bildschirmen, in denen Sie angeben, welche Art von Formular Sie erstellen möchten, wie das Formular von den Anwendern ausgefüllt wird und wie es an Sie zurückgesendet werden soll.
Bei dem Umfrageformular für das Picknick lautet die Aufgabe, eine einseitige PDF-Datei zu erstellen, die in Adobe Reader ausgefüllt werden kann. Das Formular soll ferner eine Schaltfläche enthalten, auf die der Benutzer nach dem Ausfüllen klickt, um das Formular an Sie zurückzusenden.
1.
Wählen Sie „Datei“ > „Neu“. Das Dialogfeld „Assistent für neue Formulare“ wird angezeigt.
Der Assistent für neue Formulare wird auch angezeigt, wenn Sie auf dem Begrüßungsbildschirm auf „Neues Formular“ klicken.
2.
Die Option „Leeres Formular verwenden“ ist bereits aktiviert. Klicken Sie auf „Weiter“.
3.
Wählen Sie unter „Seitenformat“ die Option „US-Letter“ aus. Klicken Sie dann auf „Weiter“.
4.
Wählen Sie die Option „E-Mail-Schaltfläche hizufügen“ und geben Sie die E-Mail-Adresse für die Rücklieferung an. LiveCycle Designer fügt automatisch eine „Per E-Mail senden“-Schaltfläche zum neuen Formularentwurf hinzu. Wenn ein Anwender nach dem Ausfüllen des Formulars auf diese Schaltfläche klickt, wird eine E-Mail-Nachricht mit einer Anlage angezeigt.
5.
Klicken Sie auf „Fertig stellen“.
Der neue Formularentwurf wird geöffnet. Wie Sie sehen, hat der Assistent in diesem Entwurf die Schaltfläche „Per E-Mail senden“ eingefügt.
Im nächsten Schritt positionieren Sie die Schaltfläche „Per E-Mail senden“ im Formularentwurf.
Um fortzufahren, klicken Sie auf: Schaltfläche „Per E-Mail senden“ positionieren


Schaltfläche „Per E-Mail senden“ positionieren

Die Schaltfläche „Per E-Mail senden“ wird vom Assistenten für neue Formulare automatisch dem leeren Formularentwurf hinzugefügt, wenn Sie die Option „Ausfüllen und Senden“ aktiviert haben. Mit Hilfe dieser Schaltfläche können die Anwender nach dem Ausfüllen des Picknick-Umfrageformulars ihre Daten schnell im XML-Format an Sie zurücksenden. Die XML-Dateien, die Sie erhalten, können Sie auf vielfältige Weise verarbeiten. Beispielsweise können Sie die Daten mit Acrobat Professional in einer Tabellenkalkulationsanwendung wie Microsoft Excel konsolidieren.
In diesem Lehrgang positionieren Sie die Schaltfläche „Per E-Mail senden“ in der Mitte des unteren Formularbereichs.
1.
Ziehen Sie die Schaltfläche in den mittleren, unteren Bereich des Formulars.
Um nicht nur den Schaltflächentext, sondern die ganze Schaltfläche auszuwählen und zu ziehen, klicken Sie auf die Schaltflächenumrandung.
2.
Um die Schaltfläche horizontal auf dem Formular zu zentrieren, wählen Sie die Schaltfläche aus und dann „Layout“ > „Auf Seite zentrieren“ > „Horizontal“.
Um fortzufahren, klicken Sie auf: Titel „Firmenpicknick – Umfrage“ hinzufügen


Titel „Firmenpicknick – Umfrage“ hinzufügen

In diesem Abschnitt fügen Sie der Umfrage einen Titel hinzu.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und dann auf das Objekt „Text“ [image].
Wenn die gewünschte Palette nicht geöffnet ist, wählen Sie „Fenster“ > [Palettenname].
2.
Klicken Sie im oberen Bereich des Formulars auf die Stelle, an der der Titel stehen soll.
Das Objekt wird angezeigt, und Sie können es an Ihre Anforderungen anpassen. Um das Objekt beispielsweise horizontal auf dem Formular zu zentrieren, wählen Sie „Layout“ > „Auf Seite zentrieren“ > „Horizontal“.
Wie Sie sehen, werden um das Objekt Begrenzungslinien angezeigt. Diese Linien kennzeichnen die Objektbegrenzung und werden nur im Formularentwurf angezeigt, um Ihnen eine bessere Vorstellung von der Objektgröße und -form zu geben. Wenn die Anwender später das Formular ausfüllen, sind diese Linien nicht sichtbar.
3.
Um die Objektgröße zu ändern, ziehen Sie die Objektbegrenzungslinien.
4.
Führen Sie die folgenden Schritte aus:
      •
      Wählen Sie im Objekt „Text“ den Text aus, und geben Sie Firmenpicknick – Umfrage ein.
      •
      Drücken Sie die Eingabetaste.
      •
      Geben Sie Wir brauchen Ihre Hilfe! ein.
Wenn rechts unten im Objekt ein weißes Pluszeichen in einem roten Quadrat erscheint, müssen Sie die Höhe des Objekts an die Größe der Schrift anpassen.
5.
Wählen Sie den Text Firmenpicknick – Umfrage aus.
6.
Wählen Sie in der Werkzeugleiste „Textformatierung“ in der Liste „Größe“ den Wert 22, klicken Sie dann auf Fett [image] und wählen Sie „Zentrieren“ [image].
Sie können steuern, wie Objekte und Beschriftungen in einem Formularentwurf ausgewählt werden. Wählen Sie „Bearbeiten“ > „Text sperren“, wenn Sie mit einem einzelnen Mausklick ein Objekt auswählen und mit einem Doppelklick Beschriftungen bearbeiten möchten. Im Rahmen dieses Lehrgangs ist die Option „Text sperren“ deaktiviert, das heißt durch einen einzelnen Mausklick wird ein Objekt markiert, und die Beschriftung wird direkt ausgewählt. In diesem Lehrgang wird ein Objekt durch einen einzelnen Mausklick ausgewählt.
7.
Markieren Sie Wir brauchen Ihre Hilfe!.
8.
Wählen Sie in der Werkzeugleiste „Textformatierung“ in der Liste „Größe“ den Wert 16 und klicken Sie dann auf „Zentrieren“ [image].
Um fortzufahren, klicken Sie auf: Textfeld für den Namen hinzufügen


Textfeld für den Namen hinzufügen

Nachdem Sie gelernt haben, wie einfach es ist, dem Formularentwurf einen Titel hinzuzufügen, werden Sie im nächsten Schritt den Hauptteil der Picknick-Umfrage erstellen.
Dazu müssen Sie dem Formular verschiedene Objekte aus der Kategorie „Standard“ in der Palette „Bibliothek“ hinzufügen. Um beispielsweise ein Feld hinzuzufügen, in das die Anwender ihre Namen eingeben sollen, müssen Sie ein Objekt des Typs „Textfeld“ einfügen.
Fügen Sie einem Formular Objekte des Typs „Textfeld“ hinzu, wenn Sie es den Anwendern ermöglichen möchten, Text in Felder einzugeben. In diesem Lehrgang fügen Sie Felder hinzu, in die die Anwender ihre Namen und ihre Kommentare oder Vorschläge eingeben können.
In welcher Reihenfolge Sie einem Formulardesign Objekte hinzufügen, hängt ganz von Ihrer Arbeitsweise ab. Sie können Objekte systematisch von oben nach unten oder aber willkürlich hinzufügen.
Im nächsten Schritt fügen Sie auf dem Formular die beiden Felder „Name“ und „Kommentare/Vorschläge“ anhand des Objekts „Textfeld“ ein.
So fügen Sie das Feld „Name“ mit Hilfe des Objekts „Textfeld“ hinzu
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und dann auf das Objekt „Textfeld“ [image].
2.
Klicken Sie im Formular auf die Stelle, an der das Feld „Name“ stehen soll.
Das Objekt wird angezeigt, und Sie können es an Ihre Anforderungen anpassen.
Dieses Objekt setzt sich aus der Beschriftung und dem Ort zusammen, an dem die Anwender Informationen eingeben. Diesen Ort bezeichnet man auch als den Wert.
3.
Wählen Sie den Text Textfeld aus und geben Sie Name: ein.
Diesen Text bezeichnet man als Beschriftung.
4.
Wählen Sie „Fenster“ > „Objekt“.
Die Palette „Objekt“ wird rechts neben dem Layout-Editor angezeigt.
5.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und geben Sie Name im Feld „Name“ ein.
Es ist empfehlenswert, jedem Objekt im Formularentwurf einen Namen zuzuweisen. Später werden Sie sehen, wie nützlich die Objektnamen sind, wenn die Daten im XML-Format an Sie zurückgesendet werden.
6.
Um den Abstand zwischen der Beschriftung und dem Feld zu verringern, in das die Anwender ihren Namen eingeben, ziehen Sie die Begrenzungslinie zwischen der Beschriftung und dem Wert nach links.
So fügen Sie das Feld „Kommentare/Vorschläge“ mit Hilfe des Objekts „Textfeld“ hinzu
1.
Klicken Sie in der Palette „Bibliothek“ auf die Registerkarte „Standard“ und dann auf das Objekt „Textfeld“ [image].
2.
Klicken Sie in dem Formular an der Stelle, an der das Feld „Kommentare/Vorschläge“ stehen soll. Das Objekt wird angezeigt und Sie können es an Ihre Anforderungen anpassen.
3.
Wählen Sie „Fenster“ > „Layout“.
Die Palette „Layout“ wird rechts neben dem Layout-Editor angezeigt.
Nicht alle Paletten sind im Arbeitsbereich geöffnet. Wenn die gewünschte Palette nicht angezeigt wird, wählen Sie die Palette im Menü „Fenster“ aus, um sie zu öffnen.
4.
Wählen Sie in der Palette „Layout“ im Bereich „Beschriftung“ unter „Position“ die Option „Oben“ aus. Die Beschriftung wird nun über dem Feld angezeigt.
5.
Ziehen Sie die Begrenzungslinien, um die Feldgröße zu ändern.
6.
Wählen Sie die Beschriftung Textfeld aus, und geben Sie Kommentare/Vorschläge: ein.
7.
Wählen Sie das Feld „Kommentare/Vorschläge“ aus.
8.
Klicken Sie auf der Palette „Objekt“ auf die Registerkarte „Feld“, und aktivieren Sie die Option „Mehrere Zeilen zulassen“, damit die Anwender mehr als eine Textzeile eingeben können.
9.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“, und geben Sie Kommentare im Feld „Name“ ein.
Um fortzufahren, klicken Sie auf: Dropdown-Liste für die Teilnehmerzahl hinzufügen


Dropdown-Liste für die Teilnehmerzahl hinzufügen

Dropdown-Listen geben einem Anwender beim Ausfüllen eines Formulars die Möglichkeit, eine Option wie etwa die Anzahl der Teilnehmer in einer Liste auszuwählen.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und dann auf das Objekt „Dropdown-Liste“ [image].
2.
Klicken Sie im Formular rechts neben dem Feld „Name“ auf die Stelle, an der die Dropdown-Liste angezeigt werden soll.
3.
Um die Dropdown-Liste mit dem Feld „Name“ auszurichten, wählen Sie das Objekt „Dropdown-Liste“ und das Feld „Name“ aus, und wählen Sie dann „Layout“ > „Ausrichten“ > „Oben“.
4.
Verbreitern Sie das Objekt „Dropdown-Liste“, damit Sie genügend Platz für die Beschriftung haben.
5.
Wählen Sie die Beschriftung Dropdown-Liste aus und geben Sie Anzahl Teilnehmer ein.
6.
Wählen Sie das Dropdown-Listen-Objekt aus.
7.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“. Geben Sie im Feld „Listenelemente“ die Teilnehmerzahlen folgendermaßen ein:
      •
      Klicken Sie auf „Neues Element hinzufügen“ [image].
      •
      Geben Sie 1 ein und drücken Sie die Eingabetaste.
      •
      Geben Sie 2 ein und drücken Sie die Eingabetaste.
      •
      Wiederholen Sie diesen Vorgang, bis Sie bei9 angelangt sind.
8.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und geben Sie Teilnehmer im Feld „Name“ ein.
Um fortzufahren, klicken Sie auf: Textobjekt für Anleitungen hinzufügen


Textobjekt für Anleitungen hinzufügen

Im Lauf dieses Lehrgangs haben Sie bereits das Objekt „Text“ kennen gelernt, als Sie für den Formularentwurf einen Titel erstellten. Sie werden nun dem Formular mit Hilfe dieses Objekts Anleitungen für die Anwender hinzufügen.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und dann auf das Objekt „Text“ [image].
2.
Klicken Sie unterhalb des Feldes „Name“ auf die Stelle, an der die Anleitungen angezeigt werden sollen.
3.
Ändern Sie die Objektgröße, damit Sie genügend Platz für die Anleitungen haben.
4.
Wählen Sie den Text Text aus, und geben Sie Folgendes ein: Die folgenden Termine stehen zur Auswahl. Geben Sie an, welcher Termin Ihnen zusagt:
5.
Wiederholen Sie die Schritte 1 bis 3, um ein weiteres Textobjekt hinzuzufügen. Platzieren Sie dieses Objekt zwischen dem Text, den Sie gerade hinzugefügt haben, und dem Feld „Kommentare/Vorschläge“.
6.
Wählen Sie den Text Text aus und geben Sie Wählen Sie die Aktivitäten aus, an denen Sie interessiert sind:
Um fortzufahren, klicken Sie auf: Optionsfeldobjekt für Termine hinzufügen


Optionsfeldobjekt für Termine hinzufügen

Optionsfelder sind nützlich, wenn Sie einem Anwender mehrere einander ausschließende Möglichkeiten zur Auswahl stellen möchten. Beispielsweise möchten Sie herausfinden, welchen Termin die einzelnen Befragten bevorzugen. Sie führen die einzelnen Daten auf dem Formular jeweils neben einem Optionsfeld auf. Die Anwender, die das Formular ausfüllen, können nur jeweils einen Termin auswählen.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und dann auf das Objekt „Optionsfeld“ [image].
2.
Klicken Sie auf eine Stelle unterhalb des ersten Anleitungssatzes. Das Objekt wird angezeigt.
3.
Wählen Sie den Text Optionsfeld aus und geben Sie 26. Juni ein.
4.
Wiederholen Sie die Schritte 1 bis 3 für die beiden anderen Termine und gehen Sie folgendermaßen vor:
      •
      Platzieren Sie diese Objekte unter dem ersten Objekt.
      •
      Wählen Sie die Beschriftung im zweiten Objekt aus und geben Sie 10. Juli ein.
      •
      Wählen Sie die Beschriftung im dritten Objekt aus und geben Sie 17. Juli ein.
5.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“, und geben Sie BevorzugterTermin im Feld „Name“ ein.
Um fortzufahren, klicken Sie auf: Kontrollkästchenobjekt für Aktivitäten hinzufügen


Kontrollkästchenobjekt für Aktivitäten hinzufügen

Kontrollkästchen sind nützlich, wenn Sie den Anwendern die Möglichkeit geben möchten, eine oder mehrere Optionen auszuwählen. Beispielsweise möchten Sie herausfinden, an welchen Aktivitäten die Befragten teilnehmen möchten. Sie führen die einzelnen Aktivitäten auf dem Formular jeweils neben einem Kontrollkästchen auf. Die Anwender, die das Formular ausfüllen, können eine oder mehrere Aktivitäten auswählen.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und dann auf das Objekt „Kontrollkästchen“ [image].
2.
Klicken Sie auf eine Stelle unterhalb des zweiten Anleitungssatzes.
Das Objekt wird angezeigt und Sie können es an Ihre Anforderungen anpassen.
3.
Wählen Sie den Text Kontrollkästchen aus und geben Sie Fußball: ein.
4.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und geben Sie Fußball im Feld „Name“ ein.
5.
Wiederholen Sie die Schritte 1 bis 4 für die restlichen Aktivitäten:
      •
      Volleyball (Geben Sie auf der Registerkarte „Bindung“ Volleyball im Feld „Name“ ein.)
      •
      Kinderschminken (Geben Sie auf der Registerkarte „Bindung“ Kinderschminken im Feld „Name“ ein.)
      •
      Sackhüpfen (Geben Sie auf der Registerkarte „Bindung“ Sackhüpfen im Feld „Name“ ein.)
Um fortzufahren, klicken Sie auf: Eigenen Formularentwurf speichern


Eigenen Formularentwurf speichern

Sie sollten Ihre Arbeit regelmäßig speichern. Häufiges Speichern verhindert, dass ein großer Teil Ihrer Arbeit versehentlich verloren geht.
1.
Wählen Sie „Datei“ > „Speichern“.
2.
Geben Sie im Feld „Dateiname“ einen Namen für die Datei ein.
3.
Klicken Sie auf „Speichern“.
Um fortzufahren, klicken Sie auf: Vorschau Ihrer Arbeit anzeigen


Vorschau Ihrer Arbeit anzeigen

Während der Arbeit an einem Formularentwurf können Sie eine Vorschau des Entwurfs anzeigen und testen, um zu prüfen, wie dieses aus der Sicht des Endbenutzers aussieht.
1.
Klicken Sie im Layout-Editor auf die Registerkarte „PDF-Vorschau“.
In dieser Ansicht können Sie das Layout überprüfen und die Felder testen, in denen eine Eingabe erforderlich ist.
2.
Geben Sie Daten in die Felder ein und klicken Sie dann auf die Schaltfläche „Per E-Mail senden“, um die Daten zu senden.
In diesem Lehrgang werden die Daten an Sie gesendet, weil Sie beim Erstellen des Formulars mit dem Assistenten für neue Formulare Ihre eigene E-Mail-Adresse angegeben haben.
Wenn Sie die XML-Datei in Ihrem Browser öffnen, sehen Sie Folgendes:
<?xml version="1.0" encoding="UTF-16"?>
<form1>
<Name>Susan White</Name>
<PreferredDate>1</PreferredDate>
<Number>3</Number>
<Football>1</Football>
<Volleyball>0</Volleyball>
<FacePainting>0</FacePainting>
<SackRaces>1</SackRaces>
<Comments>Is there a rain date? </Comments>
</form1>
Wie Sie sehen, tauchen die Namen, die Sie den Objekten im Formularentwurf zugewiesen haben, im XML-Code auf. Die XML-Datei gibt Ihnen verschiedene Möglichkeiten, die gesammelten Daten zu verwalten.
Um fortzufahren, klicken Sie auf: Formularentwurf abschließen


Formularentwurf abschließen

Bewahren Sie die Formularentwurfsdatei an einem sicheren Ort auf. Sie benötigen die Datei, wenn Sie Änderungen am Formular vornehmen möchten.
1.
Wählen Sie „Datei“ > „Speichern“.
2.
Wählen Sie einen Speicherort für den Formularentwurf aus und geben Sie im Feld „Dateiname“ einen Namen ein.
Bevor Sie das Formular bereitstellen, sollten Sie es außerhalb von LiveCycle Designer testen. Testen Sie es zunächst selbst und geben Sie es dann an ein paar Personen weiter, um das Formular einem kontrollierten Test zu unterziehen und Rückmeldungen zu erhalten.
Um fortzufahren, klicken Sie auf: Daten in einer Tabellenkalkulation sammeln


Daten in einer Tabellenkalkulation sammeln

Sie können die Informationen aus den zugestellten Dateien mit Acrobat Professional in einer Tabellenkalkulationsdatei, z. B. Microsoft Excel, sammeln.
1.
Starten Sie Acrobat Professional und öffnen Sie das Formular, das Sie gemäß den Erläuterungen im vorherigen Abschnitt gespeichert haben.
2.
Wählen Sie „Datei“ > „Formulardaten“ > „Tabelle aus Datendateien erstellen“.
3.
Klicken Sie auf „Dateien hinzufügen“ und wählen Sie die per E-Mail gesendete XML-Datei aus.
4.
Wiederholen Sie Schritt 3, um der Liste weitere Dateien hinzuzufügen.
5.
Klicken Sie auf „Exportieren“.
6.
Wählen Sie auf Ihrem Computer einen Speicherort für die Datei und klicken Sie auf „Speichern“.
Im Dialogfeld „Export - Status“ wird „Fertig“ angezeigt, wenn Acrobat die Tabelle erstellt hat.
7.
Klicken Sie auf „Datei jetzt anzeigen“, um die Tabellenkalkulationsdatei in Ihrer Standardanwendung zu öffnen.
Nachfolgend ist ein Beispiel von Daten in einer Tabellenkalkulation abgebildet:
Die von Ihnen auf der Registerkarte „Bindung“ im Feld „Name“ eingegebenen Namen werden angezeigt. Somit ist die Datei besser lesbar.
8.
Schließen Sie die Tabellenkalkulation.
9.
Klicken Sie auf „Dialogfeld schließen“.
10.
Beenden Sie Acrobat Professional.
Um fortzufahren, klicken Sie auf: Wie geht es weiter?


Wie geht es weiter?

Sie haben soeben Ihr erstes Formular erstellt. Dieses Formular ist nur ein Beispiel für die Vielzahl von Formularen, die Sie in LiveCycle Designer erstellen können. In der Hilfe finden Sie eine Beschreibung weiterer Konzepte und Techniken zum Erstellen von Formularen.
Verwandte Themen
Bestellformular erstellen


Bestellformular erstellen

Bestellformular erstellen
Formularentwurf erstellen
Logo hinzufügen
Titel des Bestellformulars hinzufügen
Textfeld für die Bestellnummer hinzufügen
Datumsfeld für das Bestelldatum hinzufügen
Vorschau Ihrer Arbeit anzeigen
Formularentwurf speichern
Adressblock hinzufügen
Bestelldaten hinzufügen
Bestelltabelle verschieben
Größe der Bestelldatentabelle ändern
Der Kopfzeile Beschriftungen zuweisen
Zellen für die Positionsnummer und die Beschreibung als Textfelder definieren
Zellen in numerische Felder umwandeln
Felder benennen
Berechnung in der Spalte „Betrag“ durchführen
Zellen zur Bestelldatentabelle hinzufügen
Inhalt des Formulars umbenennen
Zeile für die Zwischensumme am Ende der Tabelle hinzufügen
Felder für die Steuern hinzufügen
Feld für die Versandgebühr hinzufügen
Feld für die Gesamtsumme einfügen
Verkaufs- und Lieferbedingungen hinzufügen
Unterschriftsfeldobjekt hinzufügen
Wie geht es weiter?


Bestellformular erstellen

Im Laufe eines Arbeitstags haben Sie es möglicherweise mit vielen verschiedenen Arten von Formularen zu tun, beispielsweise mit Bestellformularen, Rechnungen, Gehaltsabrechnungen und Arbeitszeitnachweisen. Es gibt verschiedene Arten von Formularen:
      •
      Formulare, die direkt von Hand oder auf elektronischem Wege ausgefüllt werden.
      •
      Formulare, die in Verbindung mit einem serverbasierten Prozess ausgefüllt werden, bei dem das Formular mit Daten zusammengeführt wird.
      •
      Formulare, die eine Kombination der beiden ersten Arten darstellen.
In diesem Lehrgang erstellen Sie ein Bestellformular, das auf elektronischem Wege ausgefüllt und dann gedruckt wird. Sie finden hier außerdem eine Beschreibung der grundlegenden Konzepte und Verfahren, die für alle Formulartypen gelten. Unabhängig davon, welche Art von Formularen Sie später erstellen, wird dieser Lehrgang eine nützliche Einführung für Sie sein.
Nach Abschluss des Lehrgangs haben Sie das folgende Formular erstellt:
Um fortzufahren, klicken Sie auf: Formularentwurf erstellen


Formularentwurf erstellen

In LiveCycle Designer gibt es verschiedene Möglichkeiten, einen neuen Formularentwurf schnell zu beginnen. Im Rahmen dieses Lehrgangs verwenden Sie den Assistenten für neue Formulare, um den Bestellformularentwurf zu erstellen. Der Assistent für neue Formulare erleichtert Ihnen die Arbeit. Er führt Sie durch verschiedene Schritte, in denen Sie angeben können, wie das Formular verteilt wird und wie das ausgefüllte Formular an Sie zurückgesendet werden soll.
Das Bestellformular soll eine einseitige PDF-Datei sein. Die Endbenutzer können das Formular elektronisch mit Adobe Reader ausfüllen, mit der in das Formular integrierten Schaltfläche „Drucken“ ausdrucken und dann manuell an Sie zurücksenden.
1.
Wählen Sie „Datei“ > „Neu“.
2.
Klicken Sie auf „Weiter“.
3.
Wählen Sie unter „Seitenformat“ die Option „US-Letter“ aus.
4.
Klicken Sie auf „Weiter“.
5.
Aktivieren Sie „Drucken-Schaltfläche hinzufügen“, und klicken Sie auf „Weiter“.
Wenn Sie diese Rücklieferungsmethode auswählen, fügt LiveCycle Designer dem neuen Formularentwurf automatisch die Schaltfläche „Drucken“ hinzu. Nach dem Ausfüllen des Formulars können die Endbenutzer auf die Schaltfläche „Drucken“ klicken, um das Formular zu drucken.
6.
Klicken Sie auf „Fertig stellen“.
Der neue Formularentwurf wird im Layout-Editor angezeigt.
Um fortzufahren, klicken Sie auf: Logo hinzufügen


Logo hinzufügen

In diesem Abschnitt fügen Sie dem Bestellformular ein Logo hinzu.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie das Objekt „Bild“ [image] oben links auf das Formular.
2.
Doppelklicken Sie auf den Platzhalter und navigieren Sie zur gewünschten Bilddatei.
Wenn die mit LiveCycle Designer gelieferten Beispieldateien installiert wurden, können Sie zum Beispiel die folgende Datei öffnen:
\Samples\Purchase Order\Interactive\Images\Purchase Order.tif.
3.
Wählen Sie in der Palette „Objekt“ in der Liste „Größe“ die Option „Originalgröße verwenden“.
Um fortzufahren, klicken Sie auf: Titel des Bestellformulars hinzufügen


Titel des Bestellformulars hinzufügen

In diesem Abschnitt fügen Sie dem Bestellformular einen Titel hinzu.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie das Objekt „Text“ [image] unter das Logo.
2.
Wählen Sie im Textobjekt den Text aus und geben Sie Bestellung ein.
3.
Markieren Sie den neuen Text im Textobjekt. Wählen Sie dann in der Palette „Schrift“ in der Liste „Größe“ den Wert „20“ und in der Liste „Stil“ die Option „Fett“ aus.
Sie können eine Standardschrift für Objekte festlegen. Wenn beispielsweise alle Textobjekte die Schriftart „Arial“ besitzen sollen, fügen Sie ein Textobjekt in das Formular ein, legen als Schrift „Arial“ fest und ziehen das Textobjekt dann in die Kategorie „Standard“ der Palette „Bibliothek“. Geben Sie im Dialogfeld „Bibliotheksobjekt hinzufügen“ den Namen Text ein und klicken Sie auf „OK“. Sie werden von LiveCycle Designer aufgefordert zu bestätigen, dass das aktuelle Textobjekt wirklich ersetzt werden soll. Klicken Sie auf „Ja“.
Um fortzufahren, klicken Sie auf: Textfeld für die Bestellnummer hinzufügen


Textfeld für die Bestellnummer hinzufügen

Als Nächstes müssen Sie ein Textfeld für die Bestellnummer hinzufügen. In diesem Formular besteht dieses Feld aus 10 Positionen (Ziffern).
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie das Objekt „Textfeld“ [image] oben rechts auf das Formular.
2.
Wählen Sie im Textfeldobjekt den Text aus und geben Sie Bestellnummer ein.
Nachdem Sie das Textfeld ausgewählt haben, können Sie für die Beschriftung und den Wert die Schriftart und -größe sowie einen Stil festlegen. Die Beschriftung (Name des Feldes) steht links neben dem Wert (in den der Endbenutzer die Daten eingibt). Verwenden Sie das Palettenmenü in der Palette „Schrift“, um die Schrift der Beschriftung und des Wertes festzulegen.
Jetzt müssen Sie die Feldlänge mit 10 Positionen definieren.
3.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und aktivieren Sie das Kontrollkästchen „Länge begrenzen“. Geben Sie im Feld „ Max. Zeichen“ den Wert 10 ein.
Um fortzufahren, klicken Sie auf: Datumsfeld für das Bestelldatum hinzufügen


Datumsfeld für das Bestelldatum hinzufügen

Sie können den Benutzern die Auswahl eines Datums für die Bestellung durch Einfügen eines Datums-/Uhrzeitfelds erleichtern. Beim Ausfüllen des Formulars in Acrobat sehen die Benutzer einen Kalender, wenn sie auf die Dropdown-Liste für das Bestelldatum klicken:
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie das Objekt „Datums-/Uhrzeitfeld“ [image] unter die Bestellnummer auf dem Formular.
2.
Wählen Sie im Datumsfeld den Text aus und geben Sie Bestelldatum ein.
Um fortzufahren, klicken Sie auf: Vorschau Ihrer Arbeit anzeigen


Vorschau Ihrer Arbeit anzeigen

Im Verlauf Ihrer Arbeit können Sie eine Vorschau des Formularentwurfs anzeigen, um zu überprüfen, wie das Formular aus Sicht der Endbenutzer aussieht. Ihr Formular sollte im Moment folgendermaßen aussehen:
1.
Klicken Sie auf die Registerkarte „PDF-Vorschau“.
Sie benötigen Adobe Reader ab Version 6.0.2, um die Registerkarte „PDF-Vorschau“ verwenden zu können.
2.
Klicken Sie auf die Registerkarte „Designansicht“, um mit der Bearbeitung des Formularentwurfs fortzufahren.
Um fortzufahren, klicken Sie auf: Formularentwurf speichern


Formularentwurf speichern

Sie sollten Ihr Formular jetzt speichern. Im Folgenden speichern Sie den Formularentwurf als PDF-Datei, damit die Endbenutzer das Formular elektronisch ausfüllen und anschließend mit Hilfe der Schaltfläche „Formular drucken“ drucken können.
1.
Wählen Sie „Datei“ > „Speichern unter“.
2.
Wählen Sie einen Speicherort für den Formularentwurf aus, und geben Sie im Feld „Dateiname“ einen Namen ein.
3.
Wählen Sie in der Liste „Dateityp“ die Option „Acrobat 7.0.5 Statische PDF-Formulardatei (*.pdf)“.
Um fortzufahren, klicken Sie auf: Adressblock hinzufügen


Adressblock hinzufügen

LiveCycle Designer enthält vordefinierte benutzerspezifische Objekte, mit denen Sie schnell und einfach Formulare erstellen können. In diesem Lehrgang verwenden Sie beispielsweise das Bibliotheksobjekt „Adressblock“, um mehrere Felder gleichzeitig einzufügen.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Eigene“ und ziehen Sie das Objekt „Adressblock“ [image] unter den Titel des Bestellformulars.
2.
Ändern Sie den Text des Feldes „Name“ in Bestellt von.
3.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie das Objekt „Textfeld“ [image] unter das Feld „Land“.
4.
Weisen Sie dem Textfeld die Beschriftung Telefon zu.
5.
Fügen Sie ein weiteres Textfeld für die Fax hinzu.
6.
Ziehen Sie noch ein Objekt des Typs „Textfeld“ unter das Feld für die Faxnummer.
7.
Weisen Sie diesem Textfeld die Beschriftung Ansprechpartner zu.
8.
Damit neben diesem Block noch ein zweiter Adressblock Platz hat, wählen Sie alle in den Schritten 1 bis 7 erstellten Felder durch Ziehen mit der Maus aus und verringern die Breite des Adressblocks mit Hilfe des Ziehpunkts am rechten Rand um etwa 1 cm.
9.
Kopieren Sie die ausgewählten Felder und fügen Sie sie neben dem Adressblock „Bestellt von“ ein.
10.
Ändern Sie den Namen des zweiten „Bestellt von“-Feldes in Liefern an.
Das Formular sollte nun wie folgt aussehen:
Sie können noch einmal eine Vorschau des Formulars auf der Registerkarte „PDF-Vorschau“ anzeigen.
Um das Erscheinungsbild des Formulars noch zu verbessern, können Sie das Aussehen der dreidimensional wirkenden Felder ändern. Wählen Sie hierfür das Objekt aus und klicken Sie dann in der Palette „Objekt“ auf die Registerkarte „Feld“. Wählen Sie in der Liste „Erscheinungsbild“ den Eintrag „Unterstrichen“.
Um fortzufahren, klicken Sie auf: Bestelldaten hinzufügen


Bestelldaten hinzufügen

Jetzt fügen Sie eine Tabelle für die Bestelldaten (Positionsnummern, Beschreibung der Artikel, Menge, Stückpreis und Betrag pro Artikel) hinzu. Mit Hilfe von Tabellen können Sie diesen Abschnitt schnell und einfach erstellen. Die Tabelle verfügt über fünf Spalten.
1.
Wählen Sie „Tabelle“ > „Tabelle einfügen“.
2.
Aktivieren Sie die Option „Tabelle mit Assistenten erstellen“ und klicken Sie auf „OK“.
Mit dem Tabellenassistenten lassen sich neue Tabellen bequem erstellen, falls Sie noch keine Erfahrung mit dem Erstellen von Tabellen in LiveCycle Designer haben.
3.
Geben Sie unter „Textkörper hat feste Größe“ als Anzahl der Spalten „5“ und als Anzahl der Textzeilen „1“ ein und klicken Sie auf „Weiter“.
4.
Aktivieren Sie die Option „Kopfzeile vorhanden“ und klicken Sie auf „Weiter“.
5.
Aktivieren Sie die Option „Keine Fußzeile“ und klicken Sie auf „Weiter“.
6.
Aktivieren Sie die Option „Textzeilen vorhanden, keine Abschnitte“ und klicken Sie auf „Weiter“.
7.
Deaktivieren Sie das Kontrollkästchen „Abwechselnde Zeilenfarben“ und klicken Sie auf „Fertig stellen“.
Um fortzufahren, klicken Sie auf: Bestelltabelle verschieben


Bestelltabelle verschieben

Die gerade erstellte Tabelle sieht wie folgt aus:
Jetzt muss die Tabelle unter den Adressblock gesetzt werden.
1.
Falls die Tabelle noch nicht ausgewählt ist, zeigen Sie mit der Maus auf die obere linke Ecke, bis der folgende Cursor angezeigt wird:
2.
Klicken Sie, um die gesamte Tabelle auszuwählen.
Sie können die Tabelle auch ganz auswählen, indem Sie erst eine Zelle auswählen und dann auf „Tabelle“ > „Auswählen“ > „Tabelle“ klicken oder indem Sie bei gedrückter Maustaste mit der Maus über die Tabelle ziehen.
3.
Zeigen Sie mit der Maus auf die obere linke Ecke der Tabelle, bis der Cursor zum Verschieben [image] eingeblendet wird.
4.
Ziehen Sie die Tabelle an die neue Position.
Um fortzufahren, klicken Sie auf: Größe der Bestelldatentabelle ändern


Größe der Bestelldatentabelle ändern

Sie können die Größe der Tabelle auf die gesamte Seitenbreite ausweiten. Standardmäßig wird die Tabelle mittig auf der Seite platziert.
1.
Wählen Sie die Tabelle aus.
2.
Zeigen Sie mit der Maus auf den mittleren Ziehpunkt am rechten Rand, bis der Cursor zum Ändern der Tabellengröße (siehe oben) angezeigt wird.
3.
Ziehen Sie, bis die Tabelle die gesamte Breite der Seite ausfüllt.
Damit alle Spalten dieselbe Breite aufweisen, klicken Sie auf „Tabelle“ > „Spalten gleichmäßig verteilen“.
Um fortzufahren, klicken Sie auf: Der Kopfzeile Beschriftungen zuweisen


Der Kopfzeile Beschriftungen zuweisen

1.
Doppelklicken Sie in die erste Tabellenzelle und geben Sie Positionsnr. ein.
2.
Wiederholen Sie diesen Schritt für alle übrigen Zellen der Kopfzeile, bis die Zeile folgendermaßen aussieht:
Sie können dieser Zeile zur Abhebung eine Füllfarbe zuweisen. Wählen Sie hierfür die Zeile aus, indem Sie mit der Maus auf den linken Rand der Zeile zeigen, bis der Cursor [image] eingeblendet wird.
Wählen Sie dann in der Palette „Rand“ unter „Hintergrundfüllung“ in der Liste „Stil“ den Eintrag „Durchgehend“. Wählen Sie abschließend eine Farbe in der Farbauswahl [image].
Das Formular sollte nun wie folgt aussehen:
Um fortzufahren, klicken Sie auf: Zellen für die Positionsnummer und die Beschreibung als Textfelder definieren


Zellen für die Positionsnummer und die Beschreibung als Textfelder definieren

Standardmäßig handelt es sich bei den Zellen von Tabellen um Textobjekte. Jetzt müssen die Zellen für die Beschreibung als Textfelder ausgewiesen werden. In Textfeldern können die Benutzer beliebigen Text eingeben, auswählen, bearbeiten, ausschneiden, kopieren, einfügen oder löschen. (Textobjekte enthalten schreibgeschützten Text, der von den Endbenutzern nicht bearbeitet werden kann.)
1.
Wählen Sie die Zelle unter der Überschrift „Positionsnr.“ aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Zelle“ und wählen Sie in der Liste „Typ“ die Option „Textfeld“.
3.
Wählen Sie in der Liste „Erscheinungsbild“ die Option „Ohne“ aus.
4.
Aktivieren Sie die Option „Mehrere Zeilen zulassen“.
5.
Wiederholen Sie die Schritte 1 bis 4 für die Zellen der Spalte „Beschreibung“.
Um fortzufahren, klicken Sie auf: Zellen in numerische Felder umwandeln


Zellen in numerische Felder umwandeln

Jetzt müssen Sie die Zellen der Spalten „Menge“, „Stückpreis“ und „Betrag“ in numerische Felder konvertieren.
1.
Wählen Sie die erste Zelle unter der Überschrift „Menge“ aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Zelle“ und wählen Sie in der Liste „Typ“ die Option „Numerisches Feld“.
3.
Wählen Sie auf der Registerkarte „Zelle“ in der Liste „Erscheinungsbild“ die Option „Ohne“.
4.
Wiederholen Sie die Schritte 1 bis 3 für die Spalten „Stückpreis“ und „Betrag“.
In den Zellen der Spalten „Stückpreis“ und „Betrag“ werden Währungsbeträge angezeigt. Um die Zahlen in diesen Zellen als Währungseinheiten zu formatieren, wählen Sie die Zellen dieser beiden Spalten durch Ziehen mit der Maus aus. Klicken Sie dann in der Palette „Objekt“ auf die Registerkarte „Zelle“ und wählen Sie in der Liste „Anzeigemuster“ die Option „$z,zzz,zz9.99“.
Um fortzufahren, klicken Sie auf: Felder benennen


Felder benennen

Damit das Formular einfacher zu lesen und zu verwenden ist und damit Berechnungen durchgeführt werden können, sollten Sie die Felder umbenennen. Für Berechnungen müssen Sie den genauen Namen des jeweiligen Feldes kennen.
LiveCycle Designer unterscheidet zwischen Groß- und Kleinschreibung.
1.
Wählen Sie die Zelle unter der Überschrift „Positionsnr.“ aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und geben Sie im Feld „Name“ Positionsnr. ein.
3.
Wiederholen Sie die Schritte 1 und 2 für die übrigen Spalten und weisen Sie ihnen folgende Namen zu:
      •
      Beschreibung
      •
      Menge
      •
      Stückpreis
      •
      Betrag
Um fortzufahren, klicken Sie auf: Berechnung in der Spalte „Betrag“ durchführen


Berechnung in der Spalte „Betrag“ durchführen

In der Spalte „Betrag“ muss die Anzahl der bestellten Artikel multipliziert mit dem Stückpreis angezeigt werden. Sie können in LiveCycle Designer mit FormCalc oder JavaScript Berechnungen durchführen. Für die vorliegende Berechnung wird FormCalc verwendet. FormCalc ist eine einfache, aber leistungsfähige Berechnungssprache, die nach dem Vorbild allgemein gebräuchlicher Tabellenkalkulations-Software entwickelt wurde. Diese Sprache soll die schnelle, effiziente Gestaltung von Formularen ohne Kenntnis konventioneller Skripterstellungstechniken oder Skriptsprachen ermöglichen. Verwenden Sie den Skript-Editor, um Berechnungen für die einzelnen Objekte im Formular einzugeben.
1.
Falls der Skript-Editor noch nicht angezeigt wird, wählen Sie „Fenster“ > „Skript-Editor“.
2.
Vergrößern Sie gegebenenfalls die Palettenleiste des Skript-Editors durch Ziehen am Ziehpunkt.
3.
Wählen Sie die Zelle unter der Überschrift „Betrag“ aus.
4.
Wählen Sie in der Liste „Anzeigen“ den Eintrag „calculate“.
5.
Wählen Sie in der Liste „Sprache“ die Option „FormCalc“ und in der Liste „Ausführen am“ die Option „Client“.
6.
Geben Sie im Skriptcode-Bereich folgende Berechnung ein:

quantity * unitPrice
7.
Klicken Sie auf „Änderungen zu Skriptquelle eingeben“ [image], um das Skript in das Formular einzufügen.
8.
Um den Schreibschutz für diese Spalte zu aktivieren, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und wählen in der Liste „Typ“ den Eintrag „Berechnet - Schreibgeschützt“.
Um fortzufahren, klicken Sie auf: Zellen zur Bestelldatentabelle hinzufügen


Zellen zur Bestelldatentabelle hinzufügen

Bei diesem Formular sind sieben Zeilen erforderlich, in die die gewünschten Artikel eingegeben werden können. Mit dem Befehl „Mehrere kopieren“ können Sie schnell mehrere Zeilen auf einmal hinzufügen.
1.
Wählen Sie die gewünschte Textzeile durch Ziehen mit der Maus aus.
2.
Wählen Sie „Bearbeiten“ > „Mehrere kopieren“.
3.
Geben Sie im Feld „Anzahl der Exemplare“ den Wert „6“ ein.
4.
Aktivieren Sie die Option „Unterhalb platzieren“.
5.
Stellen Sie sicher, dass im Bereich „Vertikaler Abstand“ die Option „Berührend“ aktiviert ist.
Das Formular sollte nun wie folgt aussehen:
Um fortzufahren, klicken Sie auf: Inhalt des Formulars umbenennen


Inhalt des Formulars umbenennen

Wenn Sie die Objekte im Formular umbenennen, können Sie sie einfacher verwalten und die verschiedenen Bereiche des Formulars besser identifizieren. Am einfachsten geschieht dies über die Palette „Hierarchie“. Bei dieser Hierarchie handelt es sich um eine grafische Darstellung des Formularinhalts.
1.
Wählen Sie „Fenster“ > „Hierarchie“.
2.
Wählen Sie das erste Objekt in der Hierarchie, Formular1, aus.
3.
Drücken Sie die Taste F2 oder klicken Sie mit der rechten Maustaste und wählen Sie „Objekt umbenennen“.
4.
Geben Sie den neuen Namen Bestellformular ein.
5.
Benennen Sie das Element (unbenannt - Teilformular) (Seite 1) in Bestellung um.
Sie können auch den übrigen Elementen im Formular neue Namen zuweisen, für den Fortgang des Lehrgangs ist dies jedoch nicht unbedingt erforderlich.
Sie können die Objekte in der Hierarchie auch verschieben, indem Sie sie auswählen und nach oben bzw. unten ziehen.
Um fortzufahren, klicken Sie auf: Zeile für die Zwischensumme am Ende der Tabelle hinzufügen


Zeile für die Zwischensumme am Ende der Tabelle hinzufügen

Zum Durchführen von Berechnungen muss FormCalc wissen, welches Objekt für die Berechnung verwendet werden soll. In diesem Schritt wird die Summe der Daten in der Spalte „Betrag“ ermittelt. Wenn Sie eine Zelle in der Spalte „Betrag“ auswählen, wird ihr interner Name im Skript-Editor angezeigt. (Sie müssen den Skript-Editor eventuell vergrößern, um den Code zu sehen.)
Dieser interne Name entspricht dem Namen des Objekts in der Hierarchie. Ganz oben steht beispielsweise „Bestellformular“, gefolgt von „Bestellung“ usw.
Alle Zeilen in der Tabelle heißen „Zeile1“, gefolgt von der standardmäßigen Instanznummer. Damit die Daten in der Spalte addiert werden können, müssen alle Zeilen denselben Namen haben.
Jetzt fügen Sie am Ende der Tabelle ein Feld für die Berechnung der Zwischensumme hinzu:
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie das Objekt „Numerisches Feld“ [image] an das Ende der Tabelle unter die Spalte „Betrag“.
2.
Wählen Sie den Text im numerischen Feldobjekt aus und geben Sie Zwischensumme ein.
3.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie in der Liste „Erscheinungsbild“ die Option „Ausgefülltes Rechteck“.
4.
Wählen Sie in der Liste „Einblenden“ des Skript-Editors den Eintrag „calculate“ aus.
5.
Wählen Sie in der Liste „Sprache“ die Option „FormCalc“ und in der Liste „Ausführen am“ die Option „Client“.
6.
Geben Sie im Skriptcode-Bereich folgende Berechnung ein:

sum(Table1.Row1[*].amount[*])
Durch den Platzhalter (*) wird LiveCycle Designer angewiesen, alle Daten in den Zeilen mit dem Namen Zeile1 und in der Spalte „Betrag“ zu sammeln.
7.
Klicken Sie auf „Änderungen zu Skriptquelle eingeben“ [image], um das Skript in das Formular einzufügen.
8.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und geben Sie in das Feld „Name“ Zwischensumme ein.
9.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie in der Liste „Anzeigemuster“ die Option „$z,zzz,zz9.99“.
10.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und wählen Sie in der Liste „Typ“ die Option „Berechnet - Schreibgeschützt“ aus.
Um fortzufahren, klicken Sie auf: Felder für die Steuern hinzufügen


Felder für die Steuern hinzufügen

Auf dem Bestellformular müssen auch die anfallenden US-Steuern berechnet werden. Hierfür erstellen Sie ein Feld für den Steuersatz und ein weiteres für den Steuerbetrag.
So fügen Sie das Feld für die US-Landessteuer hinzu
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie das Objekt „Numerisches Feld“ [image] unter das Feld „Zwischensumme“.
2.
Wählen Sie in diesem Objekt den Text aus und geben Sie beispielsweise US-Landessteuer % ein.
Sie können das Feld gegebenenfalls verkleinern.
3.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie in der Liste „Erscheinungsbild“ die Option „Ausgefülltes Rechteck“.
4.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und geben Sie in das Feld „Name“ USLandessteuerProzent ein.
5.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und geben Sie in der Liste „Anzeigemuster“ den Wert z9,99'%' ein.
6.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und geben Sie im Feld „Standardwert“ den Wert 6 ein.
So fügen Sie das Feld für die US-Landessteuer hinzu
1.
Kopieren Sie das Feld für den US-Landessteuersatz und fügen Sie das neue Feld neben diesem Feld ein.
2.
Wählen Sie den Text aus und geben Sie US-Landessteuer ein.
3.
Wählen Sie in der Liste „Einblenden“ des Skript-Editors den Eintrag „calculate“ aus.
4.
Geben Sie im Skriptcode-Bereich folgende Berechnung ein:

(total * stateTaxPercent / 100)
5.
Klicken Sie auf „Änderungen zu Skriptquelle eingeben“ [image], um das Skript in das Formular einzufügen.
6.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und geben Sie im Feld „Name“ US-Landessteuer ein.
7.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie in der Liste „Anzeigemuster“ die Option „$z,zzz,zz9.99“.
8.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und wählen Sie in der Liste „Typ“ die Option „Berechnet - Schreibgeschützt“ aus.
So fügen Sie die Felder für den US-Bundessteuersatz und die US-Bundessteuer hinzu
1.
Wiederholen Sie die Schritte zum Erstellen des Feldes für den US-Landessteuersatz.
2.
Wiederholen Sie die Schritte zum Erstellen des Feldes für den Steuerbetrag.
3.
Stellen Sie sicher, dass folgende Punkte erfüllt sind, damit die Felder für die US-Bundessteuer gelten:
      •
      Das Wort US-Landes wird durch das Wort US-Bundes ersetzt.
      •
      Der Standardwert für den US-Bundessteuersatz ist „8“.
      •
      Die Berechnung der US-Bundessteuer lautet:

(total * federalTaxPercent / 100)
Um fortzufahren, klicken Sie auf: Feld für die Versandgebühr hinzufügen


Feld für die Versandgebühr hinzufügen

Standardmäßig werden 50 Dollar Versandgebühren berechnet. Bei diesem Formular können die Benutzer die Versandgebühren jedoch ggf. ändern.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie das Objekt „Numerisches Feld“ [image] unter das Feld „US-Bundessteuer“.
2.
Wählen Sie den Text im numerischen Feldobjekt aus und geben Sie Versandkosten ein.
3.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und geben Sie im Feld „Name“ Versandkosten ein.
4.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie in der Liste „Erscheinungsbild“ die Option „Ausgefülltes Rechteck“.
5.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie in der Liste „Anzeigemuster“ die Option „$z,zzz,zz9.99“.
6.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und geben Sie im Feld „Standardwert“ den Wert 50 ein.
Um fortzufahren, klicken Sie auf: Feld für die Gesamtsumme einfügen


Feld für die Gesamtsumme einfügen

Jetzt benötigen Sie noch ein Feld für die Gesamtsumme, in dem der Gesamtbetrag für die Artikel, die Steuern und die Versandgebühren angezeigt wird.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie dann das Objekt „Numerisches Feld“ [image] unter die Tabelle.
2.
Wählen Sie in diesem Objekt den Text aus und geben Sie Gesamtsumme ein.
3.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und geben Sie im Feld „Name“ Gesamtsumme ein.
4.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie in der Liste „Erscheinungsbild“ die Option „Ausgefülltes Rechteck“.
5.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie in der Liste „Anzeigemuster“ die Option „$z,zzz,zz9.99“.
6.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und wählen Sie in der Liste „Typ“ die Option „Berechnet - Schreibgeschützt“ aus.
7.
Wählen Sie in der Liste „Einblenden“ des Skript-Editors den Eintrag „calculate“ aus.
8.
Geben Sie im Skriptcode-Bereich folgende Berechnung ein:

sum (total, stateTax, federalTax, shippingCharge)
9.
Klicken Sie auf „Änderungen zu Skriptquelle eingeben“ [image], um das Skript in das Formular einzufügen.
Um fortzufahren, klicken Sie auf: Verkaufs- und Lieferbedingungen hinzufügen


Verkaufs- und Lieferbedingungen hinzufügen

Jetzt können Sie noch die Verkaufs- und Lieferbedingungen hinzufügen, die erläutern, wie die Artikel bezahlt werden.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Registerkarte „Standard“ und ziehen Sie das Objekt „Textfeld“ [image] unter die Tabelle neben die Felder für die Berechnungen.
2.
Weisen Sie ihm die Beschriftung Verkaufs- und Lieferbedingungen zu.
Sie müssen das Feld möglicherweise vergrößern, damit die gesamte Beschriftung Platz hat. Zeigen Sie hierfür mit der Maus auf den linken Rand des Feldes. Ziehen Sie bei gedrückter Maustaste, um die Größe entsprechend anzupassen.
3.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und aktivieren Sie die Option „Mehrere Zeilen zulassen“.
4.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie in der Liste „Erscheinungsbild“ die Option „Ausgefülltes Rechteck“.
5.
Wählen Sie in der Palette „Layout“ unter „Beschriftung“ in der Liste „Position“ die Option „Oben“.
6.
Ziehen Sie mit der Maus, um das Feld zu vergrößern.
Um fortzufahren, klicken Sie auf: Unterschriftsfeldobjekt hinzufügen


Unterschriftsfeldobjekt hinzufügen

Wenn Sie möchten, dass die Anwender das Formular mit Hilfe der Unterschriftsfunktion von Adobe Acrobat unterschreiben, fügen Sie dem Formularentwurf ein Unterschriftsfeld hinzu. Weitere Informationen zu Unterschriften finden Sie im Abschnitt Dokumentunterschriftsfelder – Übersicht.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie das Objekt „Dokumentunterschriftsfeld“ [image] unter die Verkaufs- und Lieferbedingungen.
2.
Wählen Sie in diesem Objekt den Text aus und geben Sie Genehmigt von: ein.
3.
Wählen Sie in der Palette „Objekt“ in der Liste „Erscheinungsbild“ die Option „Unterstrichen“.
4.
Ziehen Sie mit der Maus, um das Feld zu vergrößern.
Das Formular sollte nun wie folgt aussehen:
Um fortzufahren, klicken Sie auf: Wie geht es weiter?


Wie geht es weiter?

Dieses Formular ist nur ein Beispiel für die Vielzahl von Formularen, die Sie in LiveCycle Designer erstellen können. In der Hilfe finden Sie eine Beschreibung weiterer Konzepte und Techniken zum Erstellen von Formularen.
Verwandte Themen
Bestellformular mit Abschnitten erstellen, die an die entsprechende Datenmenge angepasst werden


Bestellformular mit Abschnitten erstellen, die an die entsprechende Datenmenge angepasst werden

Bestellformular mit Abschnitten erstellen, die an die entsprechende Datenmenge angepasst werden
Bestellformular öffnen
Formular ansprechender gestalten
Formular organisieren
Fußzeile formatieren
Tabelle für dynamisches Wachstum einrichten
Berechnung für das Zwischensummenfeld berichtigen
Schreibschutz für Felder aktivieren
Eine Verbindung zu einer Datenquelle herstellen
Daten an Felder und Tabellenzellen binden
Datendatei festlegen
Wie geht es weiter?


Zurück Weiter

Quick Start-Lernprogramme > Bestellformular mit Abschnitten erstellen, die an die entsprechende Datenmenge angepasst werden > Bestellformular mit Abschnitten erstellen, die an die entsprechende Datenmenge angepasst werden

Bestellformular mit Abschnitten erstellen, die an die entsprechende Datenmenge angepasst werden

Im vorangegangenen Lehrgang haben Sie ein Bestellformular mit einem festen Layout erstellt, das auf elektronischem Wege ausgefüllt und dann gedruckt wird. Nun gestalten Sie das Formular-Layout flexibel, damit es sich zusätzlichen Datenmengen anpasst und alle Bestellungen eines Kunden anzeigt.
In diesem Lehrgang präsentiert der Formularentwurf Informationen aus einer Datenquelle. Das Formular ist nicht interaktiv und kann gedruckt oder elektronisch gespeichert werden.
Nach Abschluss dieses Lehrgangs haben Sie das folgende, mit Daten zusammengeführte Bestellformular erstellt:
Zur Arbeit an diesem Lehrgang benötigen Sie ein Schema und eine Datendatei. Sie können das Schema und die Datendatei verwenden, die mit LiveCycle Designer geliefert wurden, sofern Sie oder Ihr Administrator die Beispieldateien installiert haben. Das Schema und die Datendatei befinden sich standardmäßig im folgenden Ordner:
      •
      \DE\Samples\Purchase Order\Schema\Schema\Purchase Order.xsd
      •
      \DE\Samples\Purchase Order\Schema\Data\Purchase Order.xml
Um fortzufahren, klicken Sie auf: Bestellformular öffnen


Bestellformular öffnen

Zunächst müssen Sie das im vorherigen Lehrgang erstellte Bestellformular öffnen.
1.
Wählen Sie „Datei“ > „Öffnen“.
2.
Navigieren Sie zu dem im vorherigen Lehrgang gespeicherten Formular und klicken Sie auf „Öffnen“.
3.
Wählen Sie „Datei“ > „Speichern unter“ und dann unter „Dateityp“ die Option „Acrobat 7.0 (Dynamisch) PDF-Formular (*.pdf)“.
4.
Ändern Sie den Namen der Datei.
5.
Klicken Sie auf „Speichern“.
Wenn Sie beabsichtigen, überwiegend Formulare mit flexiblem Layout zu erstellen und nur wenige mit festem Layout, können Sie den Standarddateityp für neue Formulare im Dialogfeld „Extras“ > „Optionen“ (Registerkarte „Dokumentoptionen“) auf „Dynamische PDF-Formulardatei“ einstellen.
Um fortzufahren, klicken Sie auf: Formular ansprechender gestalten


Formular ansprechender gestalten

Damit das Formular in gedruckter Form noch ansprechender wirkt, können Sie zum Beispiel die Feldobjekte über der Tabelle mit einer Linie zum Eintragen der Daten anstatt als dreidimensional wirkende Felder formatieren.
1.
Wählen Sie das Feld „Bestellnummer“ aus.
2.
Klicken Sie in der Palette „Objekt“ auf das Register „Feld“ und wählen Sie anschließend in der Liste „Erscheinungsbild“ die Option „Unterstrichen“ aus.
3.
Wiederholen Sie diese beiden Schritte für die übrigen Feldobjekte oberhalb der Tabelle.
Sie können ausgewählte Objekte desselben Typs gleichzeitig ändern.
4.
Wählen Sie alle Feldobjekte oberhalb der Tabelle aus, mit Ausnahme der Drucken-Schaltfläche, des Logos und des Titels des Bestellformulars.
5.
Klicken Sie in der Palette „Absatz“ auf „Unten ausrichten“.
6.
Zeigen Sie auf der Registerkarte „PDF-Vorschau“ eine Vorschau des Formulars an.
7.
Klicken Sie auf die Registerkarte „Designansicht“, um mit der Bearbeitung des Formularentwurfs fortzufahren.
Um fortzufahren, klicken Sie auf: Formular organisieren


Formular organisieren

Um ein Formular zu erstellen, dessen Layout sich an die entsprechende Datenmenge anpasst, und das mit Daten zusammengeführt werden kann, müssen Sie die einzelnen Abschnitte in Teilformulare unterteilen. Teilformulare sind Objekte, die als Container für andere Objekte dienen, wie etwa Felder, Bausteinobjekte und andere Teilformulare. Sie helfen, Objekte relativ zueinander zu positionieren, und geben Formularentwürfen mit flexiblem Layout eine Struktur.
1.
Wählen Sie in der Palette „Hierarchie“ alle Elemente oberhalb der Tabelle aus.
2.
Wählen Sie „Einfügen“ > „Umschließen mit Teilformular“.
3.
Wählen Sie das unbenannte Teilformular aus, klicken Sie mit der rechten Maustaste darauf und wählen Sie „Objekt umbenennen“.
4.
Geben Sie Kopfzeile ein, und drücken Sie die Eingabetaste.
5.
Damit über dem Teilformular „Kopfzeile“ ein gewisser Abstand eingefügt wird, öffnen Sie die Palette „Layout“, und geben Sie unter „Größe und Position“ im Feld „Höhe“ 4,5 in ein
6.
Blenden Sie alle Elemente in der Hierarchie aus.
7.
Wiederholen Sie die Schritte 1 und 2 für alle Elemente unterhalb der Tabelle („Zwischensumme“ bis „Unterschriftsfeld“). Weisen Sie diesem neuen (unbenannten) Teilformular den Namen Fußzeile zu.
8.
Damit vor dem Teilformular „Fußzeile“ ein gewisser Abstand eingefügt wird, öffnen Sie die Palette „Layout“, und geben Sie unter „Ränder“ im Feld „Oben“ 0,25in ein.
In der Palette „Hierarchie“ sollte jetzt Folgendes angezeigt werden, wenn Sie alle Elemente unter „Bestellung“ ausblenden:
Um fortzufahren, klicken Sie auf: Fußzeile formatieren


Fußzeile formatieren

Um die Fußzeile des Formulars noch ansprechender zu gestalten, können Sie zum Beispiel die Felder unter der Tabelle mit einer Linie zum Eintragen der Daten anstatt als dreidimensional wirkende Felder formatieren. Außerdem können Sie die Beschriftungen und Werte unten und die Werte zudem noch zentriert im Feld ausrichten.
1.
Wählen Sie die Felder in der Fußzeile mit Ausnahme der allgemeinen Lieferbedingungen und des Feldes „Genehmigt von“ durch Ziehen mit der Maus aus.
Wenn Sie versuchen, die Felder durch Ziehen mit der Maus auszuwählen und der Cursor die Form des Verschieben-Zeigers [image] hat, klicken Sie an einer beliebigen Stelle am Rand des Formularentwurfs. Der Zeiger nimmt dadurch eine Pfeilform an.
2.
Klicken Sie in der Palette „Objekt“ auf das Register „Feld“ und wählen Sie anschließend in der Liste „Erscheinungsbild“ die Option „Unterstrichen“ aus.
3.
Klicken Sie in der Palette „Absatz“ auf „Unten ausrichten“.
4.
Wählen Sie im Palettenmenü für den aktuellen Bearbeitungsmodus „Wert bearbeiten“, um nur die Ausrichtung der Werte zu ändern.
5.
Klicken Sie auf „Zentrieren“.
Um fortzufahren, klicken Sie auf: Tabelle für dynamisches Wachstum einrichten


Tabelle für dynamisches Wachstum einrichten

Bei Formularen, deren Layout für das Zusammenführen mit Daten angepasst wird, ist nicht immer von Anfang an klar, wie viele Daten die Datenquelle enthält. Daher ist es unmöglich festzulegen, wie viele Zeilen eine Tabelle enthalten muss. In diesem Fall ist eine dynamische Tabelle erforderlich. Fügen Sie zu diesem Zweck nur eine Textzeile hinzu, die dann je nach Menge der Daten in der Datenquelle so oft wie nötig wiederholt wird.
1.
Wählen Sie die Zeilen unterhalb der ersten Zeile (die nicht die Kopfzeile ist) durch Ziehen mit der Maus aus.
2.
Wählen Sie „Tabelle“ > „Löschen“ > „Zeile“.
3.
Wählen Sie in der Palette „Hierarchie“ den Eintrag „Tabelle1“ aus.
4.
Wählen Sie „Einfügen“ > „Umschließen mit Teilformular“.
Hierdurch wird im Formular ein Abschnitt erstellt, der die Tabelle enthält. Sie müssen diesen Abschnitt von den übrigen Elementen im Formular trennen, damit er dynamisch an die Datenmenge angepasst werden kann.
5.
Wählen Sie in der Palette „Hierarchie“ das unbenannte Teilformular aus, klicken Sie dann in der Palette „Objekt“ auf die Registerkarte „Teilformular“, und wählen Sie im Listenfeld „Inhalt“ die Option „Textfluss“.
6.
Weisen Sie dem unbenannten Teilformular den Namen Tabelle zu.
7.
Wählen Sie in der Palette „Hierarchie“ den Eintrag „Zeile1“ aus.
8.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und aktivieren Sie die Option „Zeile für jedes Datenelement wiederholen“.
Jetzt muss für das gesamte Formular der Textfluss festgelegt werden.
9.
Wählen Sie in der Palette „Hierarchie“ das Teilformular „Bestellung“ aus.
10.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Teilformular“ und wählen Sie in der Liste „Inhalt“ die Option „Textfluss“ aus.
Wird für das gesamte Formular die Option „Textfluss“ festgelegt, werden alle Teilformulare im Formular nacheinander ohne Zwischenabstand formatiert.
Um fortzufahren, klicken Sie auf: Berechnung für das Zwischensummenfeld berichtigen


Berechnung für das Zwischensummenfeld berichtigen

Nachdem Sie jetzt den Inhalt des Formulars neu angeordnet haben, muss die Berechnung für die Zwischensumme auf das neue Teilformular „Tabelle“ verweisen.
1.
Wählen Sie das Feld „Zwischensumme“ aus.
2.
Ziehen Sie die Palettenleiste des Skript-Editors, bis in der Palette genügend Platz für mehrere Zeilen ist.
3.
Ändern Sie im Skriptcode-Bereich die Berechnung wie folgt:

sum(Table.Table1.Row1[*].amount[*])
4.
Klicken Sie auf „Änderungen zu Skriptquelle eingeben“ [image], um das Skript dem Formularentwurf hinzuzufügen.
Um fortzufahren, klicken Sie auf: Schreibschutz für Felder aktivieren


Schreibschutz für Felder aktivieren

Wenn Sie nicht wünschen, dass ein Benutzer die Felder eines druckbaren Formulars bearbeiten kann, müssen Sie den Schreibschutz für diese Felder aktivieren.
1.
Öffnen Sie in der Palette „Hierarchie“ das Teilformular „Kopfzeile“ und wählen Sie alle Textfelder aus (z. B. „Bestellnummer“, „Bestellt von“, „Bestellt von-Adresse“).
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und wählen Sie dann in der Liste „Typ“ die Option „Schreibgeschützt“.
3.
Öffnen Sie in der Palette „Hierarchie“ das Teilformular „Tabelle“ und wählen Sie die Textfelder aus („TeileNr“ und „Beschreibung“).
4.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und wählen Sie dann in der Liste „Typ“ die Option „Schreibgeschützt“.
5.
Wiederholen Sie diese Schritte für „Menge“, „Stückpreis“ und „Betrag“.
6.
Wiederholen Sie die Schritte dann für die Elemente im Teilformular „Fußzeile“ (mit Ausnahme von „Unterschriftsfeld“).
Um fortzufahren, klicken Sie auf: Eine Verbindung zu einer Datenquelle herstellen


Eine Verbindung zu einer Datenquelle herstellen

Damit Daten in Ihr Formular eingefügt werden können, muss eine Verbindung mit einer Datenquelle bestehen. Nachdem Sie die Verbindung hergestellt haben, müssen Sie die Daten an ein Feld in Ihrem Formularentwurf binden.
Wenn Sie die Felder in einem Formularentwurf an eine Datenquelle binden, erstellen Sie eine Verknüpfung zwischen dem Formularentwurf und der Datenquelle, die es Ihnen ermöglicht, die mit dem Formularentwurf verknüpften Informationen zu erfassen, darzustellen, zu verschieben, zu verarbeiten, auszugeben und zu drucken.
1.
Wählen Sie „Datei“ > „Neue Datenverbindung“.
2.
Wählen Sie „XML-Schema“ aus und klicken Sie auf „Weiter“.
3.
Wenn die mit LiveCycle Designer gelieferten Beispieldateien installiert wurden, suchen Sie das Schema „Purchase Order.xsd“ und klicken Sie auf „Öffnen“.
Die Datei befindet sich im Verzeichnis \DE\Samples\Purchase Order\Schema\Schema.
4.
Klicken Sie auf „Fertig stellen“.
Die Daten werden in der Palette „Datenansicht“ angezeigt.
In der Palette „Datenansicht“ wird eine Hierarchie der Datenquelle angezeigt. Der oberste Node in der Hierarchie stellt die Datenverbindung dar. Es wird der Name angezeigt, den Sie bei der Erstellung der Verbindung zugewiesen haben.
Um fortzufahren, klicken Sie auf: Daten an Felder und Tabellenzellen binden


Daten an Felder und Tabellenzellen binden

Nachdem Sie die Verbindung zur Datenquelle hergestellt haben, müssen Sie angeben, wo die Daten im Formularentwurf angezeigt werden sollen.
      •
      Zur Bindung einzelner Felder wie „Bestellnummer“ oder „Bestelldatum“ können Sie die Drag-and-Drop-Methode verwenden.
      •
      Zur Bindung mehrfach auftretender Objekte, wie die Zeile in der Bestellungstabelle, an mehrfach auftretende Elemente im Schema verwenden Sie das Feld „Standardbindung“ auf der Registerkarte „Bindung“ in der Palette „Objekt“. Nach der Bindung der Zeile können Sie Zellen in der Zeile an Nodes im Schema binden. Diese Bindungen beziehen sich dann auf die Zeilenbindung.
So binden Sie die Daten an Felder im Formularentwurf
1.
Wählen Sie in der Palette „Datenansicht“ das Element „poNum“ aus und ziehen Sie es auf das Feld „Bestellnummer“.
2.
Aktivieren Sie im Dialogfeld „Bindungseigenschaften“ die Option „Keine verwandten Eigenschaften aktualisieren“ und klicken Sie auf „OK“.
Durch die Bindung wird ein Formularfeld mit einem Element in der Datenquelle verknüpft. Da Sie angegeben haben, dass verwandte Eigenschaften nicht aktualisiert werden sollen, bleiben in LiveCycle Designer die dem Feldobjekt bereits zugewiesenen Formatierungen erhalten.
3.
Wiederholen Sie diese Schritte für die restlichen Elemente in der Palette „Datenansicht“ (mit Ausnahme von „partNum“, „description“, „quantity“ und „unitPrice“).
Beispielsweise sollte „companyName“ an das Feld „Bestellt von“ gebunden werden.
So binden Sie die Daten an Tabellenzellen im Formular
1.
Wählen Sie in der Palette „Hierarchie“ den Eintrag „Zeile1“ aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“.
3.
Klicken Sie auf das Dreieck neben dem Feld „Standardbindung (Öffnen, Speichern, Absenden)“, und wählen Sie eine Bindung aus. Wählen Sie beispielsweise „Datenverbindung“ > „item“ > „item“.
Im Feld „Standardbindung (Öffnen, Speichern, Absenden)“ wird die folgende Zeichenfolge angezeigt: $record.item.item[*].
Sie können diese Zeichenfolge auch im Feld „Standardbindung (Öffnen, Speichern, Absenden)“ eingeben, anstatt sie auszuwählen.
4.
Öffnen Sie die Palette „Datenansicht“.
5.
Damit die Bindung genau Ihren Vorstellungen entspricht, binden Sie jede Node mit der Drag-and-Drop-Methode an eine Zelle. Wählen Sie beispielsweise in der Palette „Datenansicht“ das Element „partNum“ aus und ziehen Sie es zu der Zelle unter der Überschrift „Teile-Nr.“.
6.
Aktivieren Sie im Dialogfeld „Bindungseigenschaften“ die Option „Keine verwandten Eigenschaften aktualisieren“ und klicken Sie auf „OK“.
7.
Wiederholen Sie diese Schritte für die restlichen Elemente in der Palette „Datenansicht“ („description“, „quantity“ und „unitPrice“).
Um fortzufahren, klicken Sie auf: Datendatei festlegen


Datendatei festlegen

Abschließend müssen Sie noch einen Verweis auf eine Datendatei erstellen, die mit dem Formular zusammengeführt werden soll.
1.
Wählen Sie „Datei“ > „Formulareigenschaften“ und klicken Sie auf die Registerkarte „Standard“.
2.
Navigieren Sie im Vorschaubereich zur gewünschten Datendatei.
Sofern Sie oder Ihr Administrator die Beispieldateien installiert haben bzw. hat, die mit LiveCycle Designer geliefert werden, suchen Sie im Pfad „\DE\Samples\Purchase Order\Schema\Data“ nach der Datei „Purchase Order.xml“.
3.
Klicken Sie auf „Öffnen“ und dann auf „OK“.
4.
Zeigen Sie auf der Registerkarte „PDF-Vorschau“ eine Vorschau des Formulars an.
Das Formular sollte nun wie dieses Beispiel aussehen.
Die mit LiveCycle Designer gelieferte Datei „Purchase Order.xml“ enthält vier Datensätze. Sie können diese XML-Datei bearbeiten, damit Sie das Layout des Formulars testen und mithilfe einer großen Datendatei feststellen können, ob das Layout sich an größere Datenmengen anpasst.
(Optional) So testen Sie, ob sich das Bestellformular an entsprechende Datenmengen anpasst:
1.
Öffnen Sie die XML-Datei. Die folgenden Zeilen werden angezeigt:

<item>
   <partNum>00300-896</partNum>
   <description>Address book</description>
   <quantity>2</quantity>
   <unitPrice>15.00</unitPrice>
</item>
2.
Unter diesen Zeilen können Sie weitere Elemente hinzufügen. Sie können beispielsweise die folgenden Zeilen hinzufügen:

<item>
   <partNum>00300-300</partNum>
   <description>Clipboard</description>
   <quantity>3</quantity>
   <unitPrice>5.00</unitPrice>
</item>
<item>
   <partNum>00300-325</partNum>
   <description>Paper Punch</description>
   <quantity>1</quantity>
   <unitPrice>8.00</unitPrice>
</item>
<item>
   <partNum>00300-350</partNum>
   <description>Ruler</description>
   <quantity>5</quantity>
   <unitPrice>1.00</unitPrice>
</item>
<item>
   <partNum>00300-400</partNum>
   <description>Scissors</description>
   <quantity>2</quantity>
   <unitPrice>2.00</unitPrice>
</item>
<item>
   <partNum>00300-425</partNum>
   <description>Tape</description>
   <quantity>2</quantity>
   <unitPrice>2.50</unitPrice>
</item>
<item>
   <partNum>00300-450</partNum>
   <description>Glue Stick</description>
   <quantity>2</quantity>
   <unitPrice>1.00</unitPrice>
</item>
<item>
   <partNum>00300-475</partNum>
   <description>Stapler</description>
   <quantity>2</quantity>
   <unitPrice>4.00</unitPrice>
</item>
<item>
   <partNum>00300-500</partNum>
   <description>Highlighters</description>
   <quantity>1</quantity>
   <unitPrice>5.00</unitPrice>
</item>
<item>
   <partNum>00300-550</partNum>
   <description>Selfstick Notes</description>
   <quantity>4</quantity>
   <unitPrice>5.00</unitPrice>
</item>
<item>
   <partNum>00300-575</partNum>
   <description>Composition Notebook</description>
   <quantity>5</quantity>
   <unitPrice>8.00</unitPrice>
</item>
3.
Speichern Sie die geänderte Datei unter einem neuen Namen.
4.
Klicken Sie im Dialogfeld „Formulareigenschaften“ auf die Registerkarte „Standard“ und navigieren Sie zu der bearbeiteten Datei.
5.
Klicken Sie auf „OK“ und zeigen Sie das Formular noch einmal auf der Registerkarte „PDF-Vorschau“ an.
Um fortzufahren, klicken Sie auf: Wie geht es weiter?


Wie geht es weiter?

Wenn Sie alle Lehrgänge absolviert haben, verfügen Sie nun über die grundlegenden Kenntnisse zum Erstellen eines Formulars. Jetzt können Sie zum Beispiel noch festlegen, dass die Kopfzeile der Tabelle auf allen nachfolgenden Seiten wiederholt werden soll, falls sich die Tabelle über mehrere Seiten erstreckt. Sie können auch eine Seitennummerierung hinzufügen. In der Hilfe finden Sie weitere Informationen, wie Sie Formulare ganz an Ihre Bedürfnisse anpassen können.


LiveCycle Designer verwenden

LiveCycle Designer verwenden

Mit Formularentwürfen arbeiten
Mit Objekten arbeiten
Objekteigenschaften
Mit Datenquellen arbeiten
Barrierefreie Formulare erstellen
Sicherheitseinstellungen
Formularerstellung mit Blick auf Leistungsoptimierung
Formulare für LiveCycle Forms erstellen
Formulare für LiveCycle Workflow erstellen
Mit der Tastatur arbeiten


Mit Formularentwürfen arbeiten

Erstellen, öffnen und speichern
Seiten, Masterseiten und Seitensätze einrichten
Die Tab-Reihenfolge festlegen
Rechtschreibung in Formularen prüfen
Formulare in der Vorschau anzeigen und testen
Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten
Dokumente importieren
Tabellen verwenden
Teilformulare verwenden
Vorlagen erstellen und verwalten


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Erstellen, öffnen und speichern

Erstellen, öffnen und speichern

Formulare erstellen
Formulare öffnen und speichern


Formulare erstellen

Grundlagen zum Erstellen von Formularen
So erstellen Sie Formularentwürfe mit dem Assistenten für neue Formulare
So erstellen Sie Formularentwürfe ohne den Assistenten für neue Formulare
So erstellen Sie Formularentwürfe anhand von Vorlagen, Mustern oder vorhandenen Formularen
So erstellen Sie Formularentwürfe durch Importieren von PDF-Dateien
So fangen Sie mit einem leeren Formular an
So fügen Sie Informationen über Formulare hinzu
So stellen Sie Benutzerberechtigungen in einem PDF-Formular ein


Grundlagen zum Erstellen von Formularen

Nachdem Sie LiveCycle Designer gestartet haben, werden Sie aufgefordert, ein neues Formular zu erstellen, ein neues Formular anhand einer Vorlage zu erstellen oder ein vorhandenes Formular zu öffnen. Nach Wunsch können Sie sich auch die Musterformulare genauer ansehen. Wenn Sie die Option zum Erstellen eines neuen Formulars bzw. eines neuen Formulars anhand einer Vorlage wählen, wird der Assistent für neue Formulare angezeigt.
Der Assistent für neue Formulare führt Sie durch verschiedene Schritte, in denen Sie auswählen können, welche Art von Formularentwurf oder Vorlage erstellt werden soll, wie das Formular ausgefüllt werden soll und wie die Informationen zurückgesendet werden sollen.
Sie können den Assistenten für neue Formulare auch deaktivieren.


So erstellen Sie Formularentwürfe mit dem Assistenten für neue Formulare

1.
Wählen Sie „Datei“ > „Neu“. Der Assistent für neue Formulare wird angezeigt.
2.
Wählen Sie im Fenster „Erste Schritte“ eine Methode zum Erstellen des neuen Formulars aus und klicken Sie auf „Weiter“.
3.
Erstellen Sie anhand der Anweisungen auf dem Bildschirm ein Formular.
4.
Geben Sie einen Namen für das Formular ein und speichern Sie es.


So erstellen Sie Formularentwürfe ohne den Assistenten für neue Formulare

1.
Wählen Sie „Datei“ > „Neu“. Der Assistent für neue Formulare wird angezeigt.
2.
Klicken Sie auf die Verknüpfung „Assistent nicht verwenden“. Das Dialogfeld „Assistent-Optionen“ wird angezeigt.
3.
Wählen Sie eine Option für die Verwendung des Assistenten für neue Formulare aus und klicken Sie auf „OK“. Das Dialogfeld „Neu“ wird angezeigt.
4.
Klicken Sie auf der Registerkarte „Leer“ auf ein Symbol, um eine Seitengröße auszuwählen. Klicken Sie dann auf „OK“. Ein unbenannter Formularentwurf wird erstellt.
Wenn Sie die ganze Seite, die tatsächliche Größe der Seite oder einen Bereich, welcher der Breite der Seite entspricht, anzeigen möchten, klicken Sie in der Werkzeugleiste auf „Tatsächliche Größe“ [image], „An Seite anpassen“ [image] oder „Fensterbreite“ [image]. Die aktuelle Zoom-Einstellung [image] wird ebenfalls in der Werkzeugleiste angezeigt.
Verwandte Themen
So speichern Sie Formularentwürfe


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Erstellen, öffnen und speichern > Formulare erstellen > So erstellen Sie Formularentwürfe anhand von Vorlagen, Mustern oder vorhandenen Formularen

So erstellen Sie Formularentwürfe anhand von Vorlagen, Mustern oder vorhandenen Formularen

1.
Öffnen Sie die Vorlage, das Muster oder das vorhandene Formular, die bzw. das als Grundlage für den Formularentwurf dienen soll.
2.
Wählen Sie „Datei“ > „Speichern unter“.
3.
Wechseln Sie zu dem Speicherort, an welchem der Formularentwurf gespeichert werden soll.
4.
Geben Sie im Feld „Dateiname“ einen Dateinamen für den Formularentwurf ein.
Wenn Sie ein Formular anhand einer Vorlage erstellen, die aus einer früheren Version von LiveCycle Designer stammt, können Sie es mit der Registerkarte „Kompatibilität“ (Dialogfeld „Formulareigenschaften“) auf Version 8 aktualisieren.
Verwandte Themen
Formulare öffnen und speichern


So erstellen Sie Formularentwürfe durch Importieren von PDF-Dateien

Sie können ein PDF-Dokument importieren und als Ausgangspunkt für einen neuen Formularentwurf verwenden. Weitere Informationen finden Sie unter So importieren Sie PDF-Dateien.
Verwandte Themen
Importieren
Hinweise zum Importieren von PDF-Dokumenten als Grafik
Dialogfeld „Importoptionen“


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Erstellen, öffnen und speichern > Formulare erstellen > So fangen Sie mit einem leeren Formular an

So fangen Sie mit einem leeren Formular an

      *
      Klicken Sie in der Werkzeugleiste auf die Schaltfläche „Neu“ [image].


So fügen Sie Informationen über Formulare hinzu

Sie können beschreibende Informationen über einen Formularentwurf oder eine Vorlage (z. B. Dateibeschreibung, Name des Autors und Dateierstellungsdetails) mit dem Formularentwurf oder mit der Vorlage speichern.
Sie können auch die Sicherheitsfunktionen für PDF-Formulare aktivieren und die Informationen so einbetten, dass sie für andere Adobe-Anwendungen verfügbar sind. Wenn Sie beispielsweise den Formularentwurf als PDF-Datei speichern, können Acrobat die Dateierstellungsdetails bereitgestellt werden.
1.
Wählen Sie „Datei“ > „Formulareigenschaften“.
2.
Geben Sie auf der Registerkarte „Info“ die Informationen ein. Eine vollständige Liste und Beschreibung der Optionen auf dieser Registerkarte finden Sie unter Registerkarte „Info“ (Dialogfeld „Formulareigenschaften“).
3.
Wenn Sie die Informationen zur Verwendung durch andere Anwendungen einbetten möchten, klicken Sie auf die Registerkarte „PDF-Schutz“, aktivieren Sie „Kennwort verwenden, um die Druck- und Bearbeitungsfunktionen des Dokuments sowie die Sicherheitseinstellungen zu begrenzen“ im Bereich „Berechtigungen“ und wählen Sie dann die erforderlichen Sicherheitseinstellungen.


So stellen Sie Benutzerberechtigungen in einem PDF-Formular ein

Sie können Benutzerberechtigungen für den Zugriff, zum Drucken und zum Bearbeiten von PDF-Formularen durch LiveCycle Designer einstellen.
1.
Wählen Sie „Datei“ > „Formulareigenschaften“.
2.
Aktivieren Sie auf der Registerkarte „PDF-Schutz“ die Option „Kennwort verwenden, um die Druck- und Bearbeitungsfunktionen des Dokuments sowie die Sicherheitseinstellungen zu begrenzen“ und wählen Sie dann die erforderlichen Sicherheitseinstellungen.
Verwandte Themen
PDF-Sicherheitsoptionen verwenden


Formulare öffnen und speichern

So öffnen Sie Formularentwürfe und andere Dateien
Dateitypen
So speichern Sie Formularentwürfe
So speichern Sie eine Kopie eines Formularentwurfs
So speichern Sie Formulare für Acrobat und Adobe Reader
So veröffentlichen Sie ein Formular in einem Repository


So öffnen Sie Formularentwürfe und andere Dateien

Neben Formularentwürfen (XDP), Vorlagen (TDS) oder nur mit LiveCycle Designer erstellten und bearbeiteten PDF-Formularen können Sie auch Dateien in verschiedenen anderen Formaten öffnen. Diese Formate werden unter In LiveCycle Designer importierbare Formularformate detailliert beschrieben.
PDF-Formulare, die in einem anderen Programm als LiveCycle Designer erstellt wurden, müssen importiert werden.
Wenn Sie eine Datei öffnen (einen Formularentwurf, eine Vorlage oder eine Datei in einem anderen Format), versucht LiveCycle Designer die Schriften in der Datei mit den auf Ihrem Computer verfügbaren Schriften abzugleichen. Wenn die Datei eine nicht verfügbare Schrift enthält, zeigt LiveCycle Designer ein Dialogfeld mit der fehlenden Schrift und einem Vorschlag für eine Ersatzschrift an. Sie können diese Ersatzschrift annehmen oder ändern. Wenn Sie die Datei später speichern, können Sie angeben, ob die Ersatzschriften mit der Datei gespeichert werden sollen.
Öffnen Sie ein Formular, das mit einer älteren Version von LiveCycle Designer erstellt wurde, können Sie dieses über die Registerkarte „Kompatibilität“ (Dialogfeld „Formulareigenschaften) auf Version 8 aktualisieren.
1.
Wählen Sie „Datei“ > „Öffnen“.
2.
Gehen Sie zu dem Speicherort, an welchem der Formularentwurf gespeichert ist, wählen Sie die Datei aus und klicken Sie auf „Öffnen“. Enthält Ihre Datei Schriften, die nicht auf Ihrem Computer verfügbar sind, wird das Dialogfeld „Fehlende Schriften“ angezeigt.
3.
Wählen Sie eine Schriftersetzungsmethode aus:
      •
      Klicken Sie auf „OK“, um die vorgeschlagenen Ersatzschriften zu akzeptieren.
      •
      Klicken Sie auf „Ersatzschrift ändern“, um die Ersatzschrift zu ändern. Wählen Sie eine Schrift und einen Schriftschnitt und klicken Sie auf „OK“. Klicken Sie im Dialogfeld „Fehlende Schriften“ auf „OK“.
Die Schriften werden nicht permanent ersetzt. LiveCycle Designer muss die nicht verfügbaren Schriften bei jedem Öffnen des Formulars neu zuordnen. Die Schriftersetzung wird permanent, wenn Sie „Datei“ > „Speichern unter“ wählen und vor dem Speichern der Datei „Nicht verfügbare Schriften dauerhaft ersetzen“ aktivieren.
Verwandte Themen
In LiveCycle Designer importierbare Formularformate
So speichern Sie Formularentwürfe
Dateitypen


Dateitypen

Jeder Dateityp ist für bestimmte Verwendungszwecke vorgesehen:
Acrobat 8 (Statisch) PDF-Formular (*.pdf)
Speichert Formulare als mit Acrobat Version 8.0 kompatible statische Dateien. Der Formularentwurf kann daher nur statische Elemente enthalten. Wenn das Formular z. B. 10 Zeilen zur Dateneingabe hat, es aber Daten für 25 Zeilen gibt, können nur 10 Zeilen ausgefüllt werden. Gleichermaßen werden 10 Zeilen angezeigt, auch wenn nur 2 Zeilen Daten enthalten. 2 Zeilen sind dann ausgefüllt und 8 Zeilen sind leer.
Acrobat 8 (Dynamisch) XML-Formular (*.pdf)
Speichert Formulare als mit Acrobat Version 8.0 kompatible dynamische Dateien. Der Formularentwurf kann dynamische Elemente enthalten. Beispielsweise kann es sich bei dem Entwurf um ein dynamisches interaktives Formular handeln, das es den Benutzern gestattet, Objektzeilen hinzuzufügen oder zu entfernen.
Acrobat 7 (Statisch) PDF-Formular (*.pdf)
Speichert Formulare als mit Acrobat Version 7.0 kompatible statische Dateien. Der Formularentwurf kann daher nur statische Elemente enthalten. Wenn das Formular z. B. 10 Zeilen zur Dateneingabe hat, es aber Daten für 25 Zeilen gibt, können nur 10 Zeilen ausgefüllt werden. Gleichermaßen werden 10 Zeilen angezeigt, auch wenn nur 2 Zeilen Daten enthalten. 2 Zeilen sind dann ausgefüllt und 8 Zeilen sind leer.
Acrobat 7 (Dynamisch) XML-Formular (*.pdf)
Speichert Formulare als mit Acrobat Version 7.0 kompatible dynamische Dateien. Der Formularentwurf kann dynamische Elemente enthalten. Beispielsweise kann es sich bei dem Entwurf um ein dynamisches interaktives Formular handeln, das es den Benutzern gestattet, Objektzeilen hinzuzufügen oder zu entfernen.
Acrobat 6 (Statisch) PDF-Formular (*.pdf)
Sie müssen den Formularentwurf in diesem Format speichern, wenn die Benutzer das Formular in Acrobat 6.0 oder Adobe Reader 6.0 ausfüllen werden. Diese Benutzer können LiveCycle Designer-Formulare, die in früheren Versionen von Acrobat oder Adobe Reader gespeichert wurden, nicht öffnen.
Adobe XML-Formular (*.xdp)
Speichert Formulare im von LiveCycle Designer erstellten XML-basierten Dateiformat. Wählen Sie diese Option, wenn Sie mit LiveCycle Forms arbeiten. Der Formularentwurf kann dynamische Elemente enthalten.
Adobe LiveCycle Designer-Vorlage (*.tds)
Speichert die Grundstruktur eines Formulars als Vorlage. Eine Vorlage kann Komponenten und verschiedene Einstellungen wie z. B. Schriften, das Seitenlayout, die Formatierung und Skripten enthalten. Sie ist ein guter Ausgangspunkt für neue Formulare.
Verwandte Themen
Unterschiede beim Ausfüllen von Formularen in Acrobat und Adobe Reader


So speichern Sie Formularentwürfe

Sie können Formularentwürfe und Vorlagen unter dem aktuellem Namen und am aktuellen Speicherort speichern oder eine Kopie unter einem anderen Namen bzw. an einem anderen Speicherort ablegen. Ein Dokument kann in mehreren Formaten gespeichert werden.
In LiveCycle Designer gespeicherte PDF-Formulare sollten nur in LiveCycle Designer bearbeitet werden.
      *
      Führen Sie einen der folgenden Schritte aus:
      •
      Wählen Sie „Datei“ > „Speichern“.
      •
      Klicken Sie in der Werkzeugleiste auf „Speichern“ [image].
Verwandte Themen
So fügen Sie Informationen über Formulare hinzu
Vorlagen und der Vorlagen-Manager


So speichern Sie eine Kopie eines Formularentwurfs

1.
Wählen Sie „Datei“ > „Speichern unter“.
2.
Wenn Sie eine Kopie des Formularentwurfs unter einem anderen Namen erstellen möchten, wechseln Sie zu dem Speicherort, an welchem der Formularentwurf gespeichert werden soll, und geben Sie im Feld „Dateiname“ einen anderen Dateinamen ein.
3.
Wenn Sie den Dateityp ändern möchten, wählen Sie in der Liste „Dateityp“ eine der Optionen.
4.
Legen Sie die Speicheroptionen fest:
      •
      Aktivieren Sie „Ein-/Ausgabehilfedaten (Tags) für Acrobat erzeugen“, um Ein-/Ausgabehilfe-Informationen in eine PDF-Formulardatei einzubetten.
      •
      Aktivieren Sie „Protokolldatei beim Speichern erstellen“, um eine Protokolldatei der gespeicherten PDF-Formulardatei zu erstellen. Die Protokolldatei wird in demselben Ordner wie das gespeicherte Formular abgelegt.
      •
      Aktivieren Sie „Nicht verfügbare Schriften dauerhaft ersetzen“, um die nicht verfügbaren Schriften in der gespeicherten Datei durch verfügbare Schriften zu ersetzen. Diese Option ist für alle Dateiformate verfügbar.
      •
      Aktivieren Sie „Schriften einbetten“, um die Formularschriften in die gespeicherte PDF-Formulardatei einzubetten.
5.
Klicken Sie auf „Speichern“.
Musterformularentwürfe und -vorlagen stehen zur Verfügung. Um sie zu verwenden, lesen Sie die entsprechenden Readme-Dateien. Die Musterformularentwürfe sind im Ordner „Samples“ des LiveCycle Designer-Installationsordners installiert und die Mustervorlagen im Ordner „Templates“ des LiveCycle Designer-Installationsordners. Vorlagen können mit Hilfe des Vorlagen-Managers angezeigt und verwaltet werden.
Verwandte Themen
In LiveCycle Designer importierbare Formularformate
So speichern Sie Formularentwürfe
Dateitypen


So speichern Sie Formulare für Acrobat und Adobe Reader

Wenn Sie Formulare für Acrobat und Adobe Reader erstellen, müssen Sie sie als PDF-Dateien speichern.
Wenn Sie auf die PDF-Datei doppelklicken, wird sie in Acrobat oder Adobe Reader geöffnet. Um die PDF-Datei in LiveCycle Designer zu öffnen, wählen Sie entweder in LiveCycle Designer „Datei“ > „Öffnen“ oder rufen Sie LiveCycle Designer aus dem Menü „Erweitert“ in Acrobat auf.
In LiveCycle Designer gespeicherte PDF-Dateien sollten nur in LiveCycle Designer bearbeitet werden.
1.
Wählen Sie „Datei“ > „Speichern“.
2.
Geben Sie im Feld „Dateiname“ den Namen für die Datei ein.
3.
Wählen Sie im Feld „Dateityp“ den entsprechenden Typ.
4.
Klicken Sie auf „OK“.
Vergewissern Sie sich, dass Ihre installierte Version von Acrobat der Version entspricht, in welcher das Formular gespeichert wurde. Anderenfalls wird ein Fehler oder ein Warnhinweis ausgegeben, wenn Sie auf die Registerkarte „PDF-Vorschau“ klicken. Wenn Sie das Formular beispielsweise im Format „Acrobat 7.0 (Dynamisch) XML-Formular“ gespeichert haben, muss Acrobat 7.0 installiert sein.
Verwandte Themen
Dateitypen


So veröffentlichen Sie ein Formular in einem Repository

Sie können eine Kopie eines Formulars und seine zugeordneten Dateien in einem gemeinsamen Ordner oder Webordner abzulegen, wo es von vielen Benutzern oder anderen Anwendungen aufgerufen werden kann. Wenn Sie ein Formular in einem Repository veröffentlichen, wirken sich Änderungen an Dateinamen, Dateitypen und Referenzen zu externen Dateien (Bilder) nur auf die veröffentlichte Kopie aus. Falls das Formular beim Veröffentlichen des Formulars und der Dateien eine Verknüpfung zu einer externen Datei enthält, wird die Liste im Formular geändert, so dass sie die neue Position der Datei anzeigt.
Sie können das Formular im PDF- oder XDP-Format veröffentlichen.
      •
      Wenn Sie das Formular im PDF-Format veröffentlichen, werden Informationen wie Bilder und Schemas in das Formular eingebettet und keine externen Dateien in den Ordner zum Veröffentlichen kopiert.
      •
      Wenn Sie ein Formular im XDP-Format veröffentlichen, werden die Verknüpfungen zu extern referenzierten Dateien in einen relativen Pfad geändert. Mit dem relativen Pfad steht Ihnen ein Speicherort für Bilder zu Verfügung, den viele Formulare referenzieren können, ohne dass mehrere Kopien der Bilder vorliegen.
Wenn sich die extern verknüpften Dateien nicht in einem Ordner unter dem gemeinsamen Ordner oder Webordner befinden, werden die Dateien in den Ordner zum Veröffentlichen kopiert und die Verknüpfungen in der XDP-Datei angepasst, so dass sie den neuen absoluten Pfad der Dateien wiedergeben.
1.
Wählen Sie „Datei“ > „In Repository veröffentlichen“.
2.
Wenn Sie den Dateityp ändern möchten, wählen Sie in der Liste „Dateityp“ eine der Optionen.
3.
Legen Sie die Speicheroptionen fest:
      •
      Aktivieren Sie „Ein-/Ausgabehilfedaten (Tags) für Acrobat erzeugen“, um Ein-/Ausgabehilfe-Informationen in eine PDF-Formulardatei einzubetten.
      •
      Aktivieren Sie „Protokolldatei beim Speichern erstellen“, um eine Protokolldatei der gespeicherten PDF-Formulardatei zu erstellen. Die Protokolldatei wird in demselben Ordner wie das gespeicherte Formular abgelegt.
      •
      Aktivieren Sie „Nicht verfügbare Schriften dauerhaft ersetzen“, um die nicht verfügbaren Schriften in der gespeicherten Datei durch verfügbare Schriften zu ersetzen. Diese Option ist für alle Dateiformate verfügbar.
      •
      Aktivieren Sie „Schriften einbetten“, um die Formularschriften in die gespeicherte PDF-Formulardatei einzubetten.
4.
Klicken Sie auf „Speichern“. Es wird ein Dialogfeld mit den Ergebnissen angezeigt.
Verwandte Themen
Dateitypen


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Seiten, Masterseiten und Seitensätze einrichten

Seiten, Masterseiten und Seitensätze einrichten

Seiten einrichten
Masterseiten einrichten
Seitensätze einrichten


Seiten einrichten

Info über Seiten
So können Sie eine Seite ein- oder ausblenden
So fügen Sie eine Seite hinzu
So löschen Sie eine Seite
So wechseln Sie zwischen mehreren Seiten
So ordnen Sie Seiten neu
So benennen Sie eine Seite um


Info über Seiten

Die Seiten stellen den Zeichenbereich dar, auf dem Sie Ihren Formularentwurf erstellen. Zum Erstellen eines Formularentwurfs ziehen Sie Objekte, wie z. B. Textfelder, von der Palette „Bibliothek“ auf die Seite. Mit der Registerkarte „Designansicht“ können Sie Seiten anzeigen, hinzufügen, löschen und bearbeiten.
Verwandte Themen
Info über Masterseiten


So können Sie eine Seite ein- oder ausblenden

Sie können die Seiten in einem Formularentwurf auf verschiedene Arten ein- oder ausblenden:
      •
      Wenn eine andere Registerkarte geöffnet ist und Sie die Registerkarte „Designansicht“ einblenden möchten, klicken Sie im Layout-Editor auf die Registerkarte „Designansicht“.
      •
      Zum Ein- oder Ausblenden der Registerkarte „Designansicht“ wählen Sie „Ansicht“ > „Designansicht“.


So fügen Sie eine Seite hinzu

Sie können eine Seite hinzufügen, indem Sie das Menü „Einfügen“ oder die Palette „Hierarchie“ verwenden.
Wenn die Palette „Hierarchie“ nicht sichtbar ist, wählen Sie „Fenster“ > „Hierarchie“.
      •
      Zum Hinzufügen einer Seite klicken Sie auf die Registerkarte „Designansicht“ und wählen Sie „Einfügen“ > „Neue Seite“.
      •
      Zum Hinzufügen einer Seite in der Palette „Hierarchie“ klicken Sie mit der rechten Maustaste auf das erforderliche Teilformular auf Seitenebene und wählen Sie die Option „Neue Seite“ aus.


So löschen Sie eine Seite

Sie können eine Seite löschen, indem Sie das Menü „Einfügen“ oder die Palette „Hierarchie“ verwenden.
Wenn die Palette „Hierarchie“ nicht sichtbar ist, wählen Sie „Fenster“ > „Hierarchie“.
      •
      Zum Löschen einer Seite klicken Sie auf eine beliebige Stelle auf der Seite und wählen Sie „Einfügen“ > „Seite löschen“.
      •
      Zum Löschen einer Seite in der Palette „Hierarchie“ klicken Sie mit der rechten Maustaste auf das Teilformular auf Seitenebene, das der Seite entspricht, und wählen Sie „Löschen“ aus.


So wechseln Sie zwischen mehreren Seiten

Wenn Ihr Formularentwurf aus mehreren Seiten besteht, können Sie problemlos mit Hilfe des Layout-Editors oder der Palette „Hierarchie“ zwischen den Seiten wechseln.
Wenn die Palette „Hierarchie“ nicht sichtbar ist, wählen Sie „Fenster“ > „Hierarchie“.
      •
      Verwenden Sie die Bildlaufleiste, um auf der Registerkarte „Designansicht“ nach oben oder nach unten zur erforderlichen Seite zu gelangen.
      •
      Klicken Sie in der Palette „Hierarchie“ auf die erforderliche Seite.


So ordnen Sie Seiten neu

Wenn Sie die Reihenfolge der Seiten ändern müssen, können Sie hierzu die Palette „Hierarchie“ verwenden.
Wenn die Palette „Hierarchie“ nicht sichtbar ist, wählen Sie „Fenster“ > „Hierarchie“.
1.
Wählen Sie in der Palette „Hierarchie“ das Teilformular aus, das der zu verschiebenden Seite entspricht.
2.
Ziehen Sie das Teilformular an eine neue Position unter dem Knoten „Formular1“.
3.
Wiederholen Sie die Schritte 1 und 2, bis sich alle Seiten in der gewünschten Reihenfolge befinden.


So benennen Sie eine Seite um

Sie können den Namen einer Seite mit Hilfe der Palette „Hierarchie“ oder der Registerkarte „Seite“ der Palette „Objekt“ ändern. Der Standardname eines Seitenknotens in der Palette „Hierarchie“ lautet „(unbenannt - Teilformular) (Seite 1)“, „(unbenannt - Teilformular) (Seite 2)“ usw.
Wenn die Palette „Hierarchie“ nicht sichtbar ist, wählen Sie „Fenster“ > „Hierarchie“.
      •
      Klicken Sie in de Palette „Hierarchie“ mit der rechten Maustaste auf den Seitenknoten und wählen Sie „Objekt umbenennen“ aus. Geben Sie einen neuen Namen für die Seite ein.
      •
      Wählen Sie die Registerkarte „Designansicht“ aus und klicken Sie auf eine beliebige Stelle auf der Seite. Klicken Sie dann auf die Palette „Objekt“ und geben Sie auf der Registerkarte „Bindung“ einen neuen Namen für die Seite ein.


Masterseiten einrichten

Info über Masterseiten
Wann eine Masterseite hinzugefügt wird
So können Sie eine Masterseite ein- oder ausblenden
So fügen Sie eine Masterseite hinzu
So löschen Sie eine Masterseite
So wechseln Sie zwischen mehreren Masterseiten
So ordnen Sie Masterseiten neu
So benennen Sie eine Masterseite um
So legen Sie die Größe einer Masterseite fest
So legen Sie die Ausrichtung einer Masterseite fest
Den Leerraum um die Kanten eines Formulars herum angeben
Kopfzeilen, Fußzeilen und andere Hintergrundelemente
Zusätzliche Masterseiten zu komplexen Formularentwürfen zuweisen
So weisen Sie einer bestimmten Seite eine Masterseite zu
Beispiel für das Zuweisen einer zweiten Masterseite zu einem Formularentwurf
Masterseiten auf Formulare mit variabler Seitenanzahl anwenden
Masterseiten mit sich wiederholenden Teilformularen verwenden
So verwenden Sie die erste Masterseite nur einmal


Info über Masterseiten

Masterseiten definieren das Layout und den Hintergrund für den Formularentwurf. Die Objekte, die Sie auf einer Masterseite einfügen, werden im gesamten Formularentwurf an derselben Stelle angezeigt. Die Registerkarte „Masterseiten“ ist standardmäßig ausgeblendet.
Ein typischer interaktiver Formularentwurf, der zwei Seiten mit unterschiedlichen Maßen umfasst, enthält mindestens zwei Masterseiten, jeweils eine für jede Seite. Wenn ein Formularentwurf mehrere Seiten mit gleichen Maßen und gleicher Ausrichtung umfasst, wird für den Formularentwurf nur eine Masterseite benötigt.
Mit der Standard-Masterseite können Sie sofort mit dem Entwerfen von Seiten beginnen. Wenn Ihr Entwurf komplexer ist (wenn Sie beispielsweise Komponenten wie Seitenkopf- und -fußzeilen erstellen), ist es am besten, mit diesen Komponenten direkt in der Masterseite zu arbeiten.
Sie können Objekte an jeder beliebigen Stelle einer Masterseite platzieren. Jede Masterseite kann ein einmaliges Design haben, das auf eine oder mehrere Seiten angewendet werden kann. Masterseiten ersparen Ihnen die Mühe, das gleiche Layout auf einzelnen Seiten für jede Seite direkt zu erstellen. Wenn auf mehreren Seiten mit dem gleichen Layout auch die gleichen Objekte benötigt werden (z. B. eine Standardfußzeile), ist es effizienter, eine Zusammenstellung dieser Objekte auf einer Masterseite einzufügen und zu verwalten als die Objekte auf jeder Seite zu duplizieren. Wenn die Objekte auf einer Masterseite eingefügt werden, zeigen alle verknüpften Seiten diese Objekte im Hintergrund an. Durch späteres Ändern der Masterseite werden alle verknüpften Seiten automatisch aktualisiert.
Wenn Sie Objekte auf den Masterseiten einfügen, möchten Sie möglicherweise auch die Größen und Positionen von Inhaltsbereichen anpassen und einseitige oder doppelseitige Funktionen (wie z. B. Kopf- und Fußzeilen) erstellen, die dann auf allen Seiten angezeigt werden.
Verwenden Sie die Registerkarte „Masterseiten“, um Masterseiten anzuzeigen, hinzuzufügen und zu löschen. Sie können auch Masterseiten umbenennen und ihre Reihenfolge ändern.
Verwandte Themen
Eigenschaften von Masterseiten auf der Registerkarte „Masterseite“
Eigenschaften von Masterseiten in der Registerkarte „Paginierung“


Wann eine Masterseite hinzugefügt wird

Normalerweise werden zusätzliche Masterseiten hinzugefügt, wenn zwei oder mehr unterschiedliche Seitengrößen, eine andere Seitenausrichtung oder andere Druckmoduseinstellungen erforderlich sind.
Wenn ein Formular ein festes Layout aufweist, müssen Sie lediglich Seiten für die einzelnen Seiten im Formular hinzufügen. Wenn das Formular Teilformulare enthält, deren Größe an die zusammengeführte Datenmenge angepasst wird, werden in LiveCycle Forms automatisch weitere Seiten hinzugefügt, wenn die zusammenzuführende Datenmenge nicht ganz auf eine einzige Seite passt.
Wenn Sie einen Formularentwurf für ein Formular mit einem festen Layout erstellen, das zusammengeführte Daten akzeptiert, müssen Sie sicherstellen, dass ausgefüllte Objekte nicht so stark erweitert werden, dass sie über den Inhaltsbereich hinausragen. Andernfalls werden möglicherweise bei der Wiedergabe des Formulars unerwünschte Seiten automatisch hinzugefügt.
Ein Formularentwurf kann mehrere Inhaltsbereiche enthalten. Beispielsweise können auf einer Masterseite zwei Inhaltsbereiche zum Erstellen eines zweispaltigen Layouts verwendet werden, und zwei Masterseiten dieses Typs (eine ungerade und eine gerade Seite) können benötigt werden, damit doppelseitige Seiten unterstützt werden.
Verwandte Themen
Standard-Teilformulare
Eigenschaften von Masterseiten auf der Registerkarte „Masterseite“
Eigenschaften von Masterseiten in der Registerkarte „Paginierung“


So können Sie eine Masterseite ein- oder ausblenden

Es gibt verschiedene Möglichkeiten, um eine Masterseite ein- oder auszublenden.
      •
      Wenn eine andere Registerkarte geöffnet ist und Sie die Registerkarte „Masterseiten“ einblenden möchten, klicken Sie im Layout-Editor auf die Registerkarte „Masterseiten“.
      •
      Zum Ein- oder Ausblenden der Registerkarte „Masterseiten“ wählen Sie „Ansicht“ > „Masterseiten“.


So fügen Sie eine Masterseite hinzu

Sie können eine Masterseite hinzufügen, indem Sie das Menü „Einfügen“ oder die Palette „Hierarchie“ verwenden.
Wenn die Palette „Hierarchie“ nicht sichtbar ist, wählen Sie „Fenster“ > „Hierarchie“.
      •
      Zum Hinzufügen einer Masterseite klicken Sie auf die Registerkarte „Masterseiten“ und wählen Sie „Einfügen“ > „Neue Masterseite“.
      •
      Zum Hinzufügen einer Masterseite klicken Sie in der Palette „Hierarchie“ mit der rechten Maustaste auf den Knoten „Masterseiten“ und wählen Sie „Neue Masterseite“ aus.


So löschen Sie eine Masterseite

Sie können eine Masterseite löschen, indem Sie das Menü „Einfügen“ oder die Palette „Hierarchie“ verwenden.
Wenn die Palette „Hierarchie“ nicht sichtbar ist, wählen Sie „Fenster“ > „Hierarchie“.
      •
      Zum Löschen einer Masterseite klicken Sie auf die Registerkarte „Masterseiten“, wählen Sie den entsprechenden Inhaltsbereich für diese Masterseite aus und klicken Sie auf „Einfügen“ > „Masterseite löschen“.
      •
      Zum Löschen einer Masterseite klicken Sie in der Palette „Hierarchie“ mit der rechten Maustaste auf die Masterseite und wählen Sie „Löschen“ aus.


So wechseln Sie zwischen mehreren Masterseiten

Wenn Ihr Formularentwurf aus mehreren Masterseiten besteht, können Sie problemlos mit Hilfe des Layout-Editors oder der Palette „Hierarchie“ zwischen den Masterseiten wechseln.
Wenn die Palette „Hierarchie“ nicht sichtbar ist, wählen Sie „Fenster“ > „Hierarchie“.
      •
      Verwenden Sie die Bildlaufleiste, um auf der Registerkarte „Masterseiten“ nach oben oder nach unten zur erforderlichen Seite zu gelangen.
      •
      Klicken Sie in der Palette „Hierarchie“ auf die erforderliche Masterseite.


So ordnen Sie Masterseiten neu

Die Reihenfolge der Masterseiten in einem Formularentwurf kann über die Palette „Hierarchie“ geändert werden.
Wenn die Palette „Hierarchie“ nicht sichtbar ist, wählen Sie „Fenster“ > „Hierarchie“.
1.
Ziehen Sie in der Palette „Hierarchie“ die Masterseite an eine neue Position unter dem Knoten „Masterseiten“.
2.
Wiederholen Sie Schritt 1, bis sich alle Masterseiten in der gewünschten Reihenfolge befinden.


So benennen Sie eine Masterseite um

Sie können den Namen einer Masterseite mit Hilfe der Palette „Hierarchie“ oder der Registerkarte „Seite“ der Palette „Objekt“ ändern.
Wenn die Palette „Hierarchie“ nicht sichtbar ist, wählen Sie „Fenster“ > „Hierarchie“.
      •
      Klicken Sie in der Palette „Hierarchie“ mit der rechten Maustaste auf die Masterseite, wählen Sie „Objekt umbenennen“ aus und geben Sie einen neuen Namen für die Masterseite ein.
      •
      Wählen Sie die Registerkarte „Masterseiten“ aus und klicken Sie auf eine beliebige Stelle auf der Masterseite. Wählen Sie dann die Palette „Objekt“ aus und geben Sie auf der Registerkarte „Masterseiten“ einen neuen Namen für die Masterseite ein.


So legen Sie die Größe einer Masterseite fest

Auf der Registerkarte „Masterseiten“ können Sie die an dem einfachen Seitenlayout eines Formulars vorgenommenen Änderungen, einschließlich der Seitengröße, anzeigen. Wenn Sie eine Masterseite in der Palette „Hierarchie“ auswählen, können Sie die Einstellungen für das einfache Seitenlayout auf der Registerkarte „Seite“ der Palette „Objekt“ ändern.
Inhaltsbereiche definieren den Abschnitt, in dem Objekte auf den Seiten eines Formulars platziert werden können. Wenn Sie ein Formular erstellen, das für fließenden Inhalt definierte Teilformulare enthält, sollten Sie am besten die Größe und Position aller Inhaltsbereiche definieren, bevor Sie weitere Objekte zur Masterseite hinzufügen.
1.
Wählen Sie in der Palette „Hierarchie“ unter dem Knoten „Masterseiten“ die Masterseite aus, deren Größe Sie verändern möchten.
2.
Wählen Sie in der Palette „Objekt“ in der Liste „Papierart“ eine Seitengröße aus.
3.
Wenn Sie den Typ „Eigene“ ausgewählt haben, geben Sie die Seitenmaße in den Feldern „Höhe“ und „Breite“ ein.


So legen Sie die Ausrichtung einer Masterseite fest

Auf der Registerkarte „Masterseiten“ können Sie die an dem einfachen Seitenlayout eines Formulars vorgenommenen Änderungen, einschließlich der Ausrichtung, anzeigen. Wenn Sie eine Masterseite in der Palette „Hierarchie“ auswählen, können Sie die Einstellungen für das einfache Seitenlayout auf der Registerkarte „Seite“ der Palette „Objekt“ ändern.
1.
Wählen Sie in der Palette „Hierarchie“ unter dem Knoten „Masterseiten“ die Masterseite aus, die Sie ausrichten möchten.
2.
Wählen Sie in der Palette „Objekt“ die Ausrichtung „Hochformat“ oder „Querformat“ aus.
Verwandte Themen
So können Sie Inhaltsbereiche kopieren, verschieben und in der Größe ändern


Den Leerraum um die Kanten eines Formulars herum angeben

In einem herkömmlich gedruckten Dokument bezieht sich der Rand auf einen Bereich um die Außenkanten der Seite herum, der nicht bedruckt wird. In interaktiven Formularen bezieht sich der Begriff Rand nur auf den Leerraumpuffer um die Innenkanten einer Objektbegrenzung herum.
Um die Größe des Leerraums um die Außenkanten eines Formulars zu vergrößern, müssen Sie die Größe des Inhaltsbereichs auf der Masterseite verringern. Standardmäßig beträgt die Begrenzung des Inhaltsbereichs 0,25 Zoll von den Kanten des Formulars. Um zusätzlichen Leerraum zum Platzieren einer Kopf- oder Fußzeile zu schaffen oder um Anpassungen zur Unterstützung von Druckbeschränkungen vorzunehmen, müssen Sie den Standard-Inhaltsbereich verkleinern.
Der durch den Inhaltsbereich gebundene Bereich bestimmt, wo Objekte auf den Seiten eines Formulars platziert werden können. Das Standard-Teilformular auf einer Seite hat die gleiche Größe wie der Standard-Inhaltsbereich auf einer Masterseite, und die Randeinstellungen des Standard-Teilformulars sind auf 0 Zoll eingestellt. Eine Änderung der Randeinstellungen des Standard-Teilformulars auf einer Seite hat auch Einfluss darauf, wo die Objekte positioniert werden. Eine Erhöhung der Randeinstellungen des Teilformulars verringert den Bereich, in dem die Objekte des Teilformulars wiedergegeben werden können.
Alle Objekte, die Sie auf einer Masterseite platzieren, werden auf jeder verknüpften Seite angezeigt, unabhängig davon, ob Sie diese Objekte innerhalb oder außerhalb des Inhaltsbereichs platzieren. Wenn Sie ein Wasserzeichen einrichten, platzieren Sie die Objekte, aus denen das Wasserzeichen besteht, innerhalb des Inhaltsbereichs.
Wenn Sie ein Formular entwerfen, das Teilformulare mit fließendem Inhalt enthält, und nicht möchten, dass die Objekte auf der Masterseite sich mit Objekten überschneiden, die auf den Seiten platziert sind, müssen Sie die Masterseitenobjekte außerhalb des Inhaltsbereichs positionieren, das heißt, irgendwo in dem Leerraum, den Sie auf der Masterseite erstellen. Wenn Sie Objekte innerhalb des Inhaltsbereichs platzieren, können andere Objekte bei der Wiedergabe des Formulars die Objekte auf den Masterseiten überlagern.
Verwandte Themen
Inhaltsbereiche – Übersicht
So können Sie Inhaltsbereiche kopieren, verschieben und in der Größe ändern
Standard-Teilformulare


Kopfzeilen, Fußzeilen und andere Hintergrundelemente

Wenn die meisten Seiten in Ihrem Formularentwurf eine bestimmte Menge standardisierten, festen Inhalts erfordern, können Sie diesen Inhalt auf Masterseiten platzieren, um einen konsistenten Hintergrund herzustellen und die Bearbeitung zu erleichtern. Beispielsweise können Sie Text, Bilder und geometrische Formen auf einer Masterseite so anordnen, dass sie auf mehreren Seiten jeweils immer an der gleichen Stelle angezeigt werden.
Wenn Sie Kopf- und Fußzeilen erstellen und andere Hintergrundelemente auf der Masterseite anordnen, befolgen Sie diese allgemeinen Anweisungen:
      •
      Wenn Sie ein Formular erstellen, das für fließenden Inhalt definierte Teilformulare enthält, sollten Sie am besten die Größe und Position aller Inhaltsbereiche definieren, bevor Sie weitere Objekte zur Masterseite hinzufügen.
      •
      Objekte können an jeder beliebigen Stelle innerhalb oder außerhalb des Inhaltsbereichs einer Masterseite platziert werden. Generell sollten Sie jedoch keine Objekte innerhalb des Inhaltsbereichs platzieren, außer wenn Sie möchten, dass andere Objekte die Objekte auf der Masterseite bei der Wiedergabe des Formulars überlagern. Wenn Sie ein Wasserzeichen einrichten, platzieren Sie dieses innerhalb des Inhaltsbereichs.
      •
      Sie werden Textobjekte für schreibgeschützten Text und Bild- oder Bildfeldobjekte benötigen, um Bilder (z. B. ein Logo) zu positionieren, und Sie können geometrische Objekte, wie z. B. Kreise, Linien oder Rechtecke hinzufügen, um das Erscheinungsbild des Formularentwurfs zu verbessern.
      •
      Alle Objekte auf einer Masterseite werden als Hintergrundobjekte auf Seiten angezeigt, wenn das Formular wiedergegeben wird.
Verwandte Themen
So können Sie Inhaltsbereiche kopieren, verschieben und in der Größe ändern


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Seiten, Masterseiten und Seitensätze einrichten > Masterseiten einrichten > Zusätzliche Masterseiten zu komplexen Formularentwürfen zuweisen

Zusätzliche Masterseiten zu komplexen Formularentwürfen zuweisen

Masterseiten liefern das zugrunde liegende Format und den Hintergrund für Seiten. Alle neuen Formularentwürfe werden mit einer Standard-Masterseite erstellt, die auf die erste Seite angewendet wird. Zusätzliche Seiten werden gemäß dem Layout der Standard-Masterseite formatiert, es sei denn, Sie erstellen eine andere zu verwendende Masterseite.
Ein Formularentwurf kann eine beliebige Anzahl von Masterseiten enthalten, von denen jede über ein einmaliges Layout verfügt. Wenn einige der Seiten andere Layouts oder Textbausteinobjekte erfordern, können Sie für jedes einmalige Layout eine Masterseite erstellen.


So weisen Sie einer bestimmten Seite eine Masterseite zu

1.
Wählen Sie das Teilformular mit Hilfe einer dieser Methoden aus:
      •
      Wählen Sie auf der Registerkarte „Designansicht“ das Standard-Teilformular auf der Seite aus.
      •
      Wählen Sie in der Palette „Hierarchie“ das Teilformular aus, das der Seite entspricht.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Paginierung“ und wählen Sie in der Liste „Platzieren“ die Option „Auf Seite > [Seite]„ aus. Dabei steht [Seite] für den Namen der zu verwendenden Masterseite.


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Seiten, Masterseiten und Seitensätze einrichten > Masterseiten einrichten > Beispiel für das Zuweisen einer zweiten Masterseite zu einem Formularentwurf

Beispiel für das Zuweisen einer zweiten Masterseite zu einem Formularentwurf

Das folgende Beispiel zeigt die Schritte für das Zuweisen einer zweiten Masterseite zu einer Seite in einem interaktiven Formularentwurf oder einem Formularentwurf mit festem Layout.
Dieser Formularentwurf enthält zwei Seiten und zwei Masterseiten. Die erste Masterseite weist die Ausrichtung „Hochformat“ und die zweite Masterseite die Ausrichtung „Querformat“ auf.
1.
Klicken Sie auf die Registerkarte „Designansicht“.
2.
Wählen Sie das Teilformular auf Seite 2 aus.
3.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Teilformular“ und wählen Sie in der Liste „Platzieren“ die Option „Auf Seite > [Seite]„ aus. Dabei steht [Seite] für den Namen der Masterseite 2.
Seite 2 übernimmt das Layout von Masterseite 2 und weist nun ein Querformat-Layout auf.


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Seiten, Masterseiten und Seitensätze einrichten > Masterseiten einrichten > Masterseiten auf Formulare mit variabler Seitenanzahl anwenden

Masterseiten auf Formulare mit variabler Seitenanzahl anwenden

Formulare, die für fließenden Inhalt definierte Teilformulare enthalten, haben eine variable Anzahl von Seiten. Wenn das Formular wiedergegeben wird, werden Objekte innerhalb von Inhaltsbereichen platziert, und wenn der Inhaltsbereich mit Daten ausgefüllt wird, erfolgt automatisch ein Seitenumbruch. In der Standardeinstellung übernehmen alle Seiten das Format der Standard-Masterseite.
Wenn mehr als eine Masterseite verfügbar ist, kann jede Masterseite die Formatierung von Seiten beeinflussen. In diesem Fall wird das Layout einer Masterseite angewendet, wenn das damit verknüpfte Teilformular wiedergegeben wird. Das heißt, wenn das Teilformular auf Seite 2 des Formulars wiedergegeben wird, wird das Format der zugeordneten Masterseite auf Seite 2 angewendet.
Sie können einschränken, wie häufig eine Masterseite angewendet wird. Beispielsweise können Sie eine Masterseite auf die erste Seite beschränken, auf der ein Teilformular wiedergegeben wird. Jede zusätzliche Seite wird dann formatiert, während das Layout der nächsten Masterseite beliebig häufig wiederholt werden kann. Die Art des Formulars sollte dafür ausschlaggebend sein, welche dieser Optionen verwendet werden.
Beispielsweise können sich auf der ersten Seite einer Zahlungsanweisung firmen- und arbeitnehmerspezifische Informationen befinden. Nachfolgende Seiten zeigen sehr wenig firmen- oder arbeitnehmerspezifische Informationen und eine größere Menge an Zeitkarteninformationen. Sie können zwei Masterseiten definieren. Auf der ersten Masterseite befinden sich zunächst das Firmenlogo und Kontaktinformationen, und zwar außerhalb des Inhaltsbereichs. Als Nächstes folgt ein kleiner Inhaltsbereich zum Empfangen von arbeitnehmerspezifischen Informationen. Der Inhaltsbereich der Masterseite ist größer und nimmt möglicherweise die gesamte Seite zur Aufnahme von Zeitkarteninformationen ein.
Um in diesem Fall Masterseiten richtig zuzuordnen, ist die Einstellung 1 für das minimale und maximale Auftreten der ersten Masterseite erforderlich, was bedeutet, dass immer genau ein Auftreten erfolgt. Für Masterseiten ist die Standardeinstellung für den minimalen Zählerwert 0 und der maximale Zählerwert ist -1. Für die zweite Masterseite kann das Layout unbegrenzt häufig auf einer Seite wiedergegeben werden.
Verwandte Themen
Info über Seiten


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Seiten, Masterseiten und Seitensätze einrichten > Masterseiten einrichten > Masterseiten mit sich wiederholenden Teilformularen verwenden

Masterseiten mit sich wiederholenden Teilformularen verwenden

Sie können allen Seiten, die in einem Formular nach der ersten Seite erscheinen, eine eigene Masterseite zuordnen, wenn Sie ein sich wiederholendes Teilformular haben, das nicht auf eine Seite passt, sondern weitere Seiten erfordert. So kann das Teilformular beispielsweise in der Mitte der ersten Seite des Formulars beginnen. Damit das Teilformular im oberen Bereich der Seiten beginnt, die nach der ersten Seite angezeigt werden, müssen Sie eine andere Masterseite erstellen.
Bei Angabe eines maximalen Zählerwertes von 1 wird die erste Masterseite nur einmal gedruckt. Sobald sie mit Daten ausgefüllt ist, legt LiveCycle Designer automatisch die zweite Masterseite ab und fährt mit der Platzierung der Überlaufdaten fort.


So verwenden Sie die erste Masterseite nur einmal

1.
Klicken Sie auf der Registerkarte „Hierarchie“ auf die erste Masterseite, Seite1.
2.
Klicken Sie auf die Palette „Objekt“ und führen Sie die folgenden Schritte aus:
      •
      Wählen Sie „Auftreten der Seite begrenzen“ aus.
      •
      Wählen Sie „Max.“ aus und geben Sie anschließend 1 im entsprechenden Feld ein.
3.
Speichern Sie den Formularentwurf.
Verwandte Themen
Wann eine Masterseite hinzugefügt wird
Info über Seiten


Seitensätze einrichten

Info über Seitensätze
So wechseln Sie zwischen mehreren Seitensätzen
So können Sie Seitensätze hinzufügen oder löschen
So ordnen Sie Seitensätze neu
So benennen Sie einen Seitensatz um


Info über Seitensätze

Mit Seitensätzen können Sie die Reihenfolge, die Druckeinstellung, das Auftreten und die Sichtbarkeit von Seiten im Formularentwurf steuern. Formularentwürfe enthalten mindestens einen Seitensatz.
Seitensätze werden am häufigsten für das Erstellen von Formularen verwendet, die Teilformulare mit fließendem Inhalt enthalten, weil Sie mit Seitensätzen die Reihenfolge, in der die Seiten des Formulars wiedergegeben werden, sowie das Auftreten angeben können. Beispielsweise möchten Sie vielleicht einen Formularentwurf erstellen, der für die Generierung eines Formulars als Druckvorstufe und als Nur-Text-Version verwendet werden kann. Ein Druckvorstufenformular wird auf Papier gedruckt, auf dem bereits Elemente gedruckt sind. Ein Nur-Text-Formular wird auf einem leeren Blatt Papier gedruckt.
Für dieses Beispiel erzeugen Sie fünf Masterseiten, die zu Seitensätzen kombiniert sind:
Masterseite1
Die Titelseite, die einmal vorkommt.
Masterseite2
Das Blatt, auf dem das Druckvorstufenformular gedruckt wird. Es enthält das Firmenlogo und Kontaktinformationen. Diese Masterseite lässt Raum für diese Informationen außerhalb des Inhaltsbereichs. Als Nächstes folgt ein kleiner Inhaltsbereich zum Empfangen von arbeitnehmerspezifischen Informationen. Er erscheint nur einmal auf dem Druckvorstufenformular.
Masterseite3
Verfügt über einen größeren Inhaltsbereich, der sich möglicherweise über die ganze Seite erstreckt, um mehr Informationen aufzunehmen. Sie wird für die zweite und alle weiteren Seiten des Druckvorstufenformulars verwendet. Sie erscheint 0 Mal bis unendlich.
Masterseite4
Zeigt zuerst das Firmenlogo und die Kontaktinformationen außerhalb des Inhaltsbereichs an. Als Nächstes folgt ein kleiner Inhaltsbereich zum Empfangen von arbeitnehmerspezifischen Informationen. Er erscheint nur einmal für die Nur-Text-Version.
Masterseite5
Verfügt über einen größeren Inhaltsbereich, der sich möglicherweise über die ganze Seite erstreckt, um mehr Informationen aufzunehmen. Sie wird für die zweite und alle weiteren Seiten des Nur-Text-Formulars verwendet. Sie erscheint 0 Mal bis unendlich.
Die Masterseiten werden zu Seitensätzen zusammengefasst (siehe Abbildung).
Das Formular wird gemäß der Seitenreihenfolge in der Hierarchie wiedergegeben:
      •
      Das erste Teilformular wird immer auf Masterseite1 wiedergegeben.
      •
      Das nächste Teilformular wird auf Masterseite2 und dann auf Masterseite3 wiedergegeben, wenn es sich um ein Druckvorstufenformular handelt, oder auf Masterseite4 und dann auf Masterseite5, wenn es sich um ein Nur-Text-Formular handelt.
Verwandte Themen
Info über Seiten
Info über die Vorschau und das Testen von Formularen
Seitensatz-Eigenschaften in der Registerkarte „Seitensatz“


So wechseln Sie zwischen mehreren Seitensätzen

      *
      Klicken Sie in der Palette „Hierarchie“ auf den Seitensatz.
Wenn die Palette „Hierarchie“ nicht sichtbar ist, wählen Sie „Fenster“ > „Hierarchie“.


So können Sie Seitensätze hinzufügen oder löschen

      •
      Zum Hinzufügen eines Seitensatzes klicken Sie in der Palette „Hierarchie“ mit der rechten Maustaste auf den Knoten „Masterseiten“ und wählen Sie „Seitensatz einfügen“ aus.
      •
      Zum Löschen eines Seitensatzes klicken Sie in der Palette „Hierarchie“ mit der rechten Maustaste auf den Seitensatz und wählen Sie „Löschen“ aus.


So ordnen Sie Seitensätze neu

1.
Ziehen Sie in der Palette „Hierarchie“ den Seitensatz an eine neue Position unter dem Knoten „Masterseiten“.
2.
Wiederholen Sie Schritt 1, bis sich alle Seitensätze in der gewünschten Reihenfolge befinden.


So benennen Sie einen Seitensatz um

1.
Klicken Sie in der Palette „Hierarchie“ mit der rechten Maustaste auf den Seitensatz und wählen Sie „Objekt umbenennen“ aus.
2.
Geben Sie einen neuen Namen für den Seitensatz ein.
Sie können den ausgewählten Seitensatz auch auf der Registerkarte „Seitensatz“ in der Palette „Objekt“ umbenennen.


Die Tab-Reihenfolge festlegen

Info über die Tab-Reihenfolge
So funktioniert die Tab-Reihenfolge
So legen Sie die Tab-Reihenfolge fest
So ändern Sie die Tab-Reihenfolge mit der Maus
So ändern Sie die Tab-Reihenfolge mit Tastenkombinationen


Info über die Tab-Reihenfolge

Viele Benutzer verwenden beim Wechseln zwischen den Feldern und Schaltflächen in einem Formular lieber die Tabulatortaste als die Maus. In LiveCycle Designer können Sie die Tab-Reihenfolge zwischen den Objekten in einem Formular festlegen.
Eine Tab-Reihenfolge ist für interaktive Formulare und Formulare mit einem festen Layout wichtig. Bei interaktiven Formulare hat die Tab-Reihenfolge Einfluss auf den Komfort des Endbenutzers beim Ausfüllen des Formulars.
Wenn Ihre Formulare für Benutzer mit Seh- oder Bewegungsbehinderungen verfügbar sein müssen, ist die Tab-Reihenfolge sowohl für interaktive als auch für nicht interaktive Formulare von Bedeutung. Diese Benutzer verwenden in der Regel nicht die Maus, um durch ein Formular zu navigieren, weshalb sie auf die Tastatur und eine gute Tab-Reihenfolge angewiesen sind, um auf alle Formularfelder zugreifen zu können.
Für barrierefreie Formulare muss eine Tab-Reihenfolge festgelegt werden, ungeachtet dessen, ob das Formular interaktiv oder zum Drucken konzipiert ist. Bildschirmlesehilfen lesen das Formular in der geografischen Reihenfolge, die in LiveCycle Designer festgelegt wird, wenn die standardmäßige Tab-Reihenfolge verwendet wird.
Verwandte Themen
So funktioniert die Tab-Reihenfolge
Tab-Reihenfolge bei barrierefreien Formularen


So funktioniert die Tab-Reihenfolge

Die standardmäßige Tab-Reihenfolge für Objekte in einem Formular ist von links nach rechts und von oben nach unten, beginnend in der linken oberen Ecke. Bei der Tab-Reihenfolge werden Teilformulare, Optionsfelder und Inhaltsbereiche berücksichtigt. Wenn beispielsweise zwei Teilformulare nebeneinander existieren und jedes Teilformular mehrere Feldobjekte enthält, führt die Tab-Reihenfolge durch die Felder des ersten Teilformulars, bevor zum nächsten Teilformular übergegangen wird.
Kreis-, Linien- und Rechteckobjekte werden in LiveCycle Designer nicht in die Tab-Reihenfolge einbezogen.
Die Tab-Reihenfolge wird auch durch die vertikale Position der Objekte auf einer Seite und auf deren Masterseite bestimmt.
Die Tab-Reihenfolge beginnt bei dem Objekt mit der kleinsten vertikalen Koordinate und endet bei dem Objekt mit der größten vertikalen Koordinate. Die Objekte können sich dabei auf der Text- oder auf der Masterseite befinden.
Bei Objekten, die selbst Objekte enthalten (z. B. Inhaltsbereiche), werden zuerst alle untergeordneten Objekte durchlaufen, bevor der Fokus zum nächsthöheren Objekt wechselt.
Die folgende Liste bietet ein Beispiel der Tab-Reihenfolge für Objekte auf Text- und Masterseiten:
      •
      Bildobjekt auf der Masterseite mit der vertikalen Koordinate 1.
      •
      Inhaltsbereichsobjekt auf der Seite mit der vertikalen Koordinate 4. Alle Objekte im Inhaltsbereich werden durchlaufen, bevor der Fokus zum Teilformular auf der Masterseite wechselt.
      •
      Teilformular auf der Masterseite mit der vertikalen Koordinate 10. Alle Objekte im Inhaltsbereich werden durchlaufen, bevor der Fokus zum Textobjekt auf der Masterseite wechselt.
      •
      Textobjekt auf der Masterseite mit der vertikalen Koordinate 12.
Da die Tab-Reihenfolge sehr wichtig ist, müssen Sie die Objekte im Formular sorgfältig relativ zueinander positionieren. Sie können z. B. ein Objekt mit Hilfe seiner Koordinaten positionieren und seine Größe anpassen und Objekte an Punkten in einem Raster ausrichten.
Sie können die standardmäßige Tab-Reihenfolge ändern, wenn Sie in Ihrem Formular eine andere Reihenfolge benötigen. Beispielsweise können Sie die Tab-Reihenfolge ändern, um sich durch Objekte in einer Spalte von oben nach unten und dann von links nach rechts zu bewegen.
In Acrobat 6.0 aktiviert ein Tabulatorschritt zu einer Gruppe von Optionsfeldern das linke obere Optionsfeld. Verwenden Sie die Tabulatortaste, um durch die Optionsfelder zu navigieren. In Acrobat 7.0 wird das ausgewählte Optionsfeld aktiviert. Verwenden Sie die Pfeiltasten, um zwischen den Optionsfeldern innerhalb einer Gruppe zu navigieren, und die Tabulatortaste, um die Gruppe zu verlassen.
Verwandte Themen
So legen Sie die Tab-Reihenfolge fest
So positionieren Sie Objekte
Die Zeichenhilfen


So legen Sie die Tab-Reihenfolge fest

Eine der Aufgaben, die Sie bei der Erstellung eines Formulars erst gegen Ende ausführen sollten, ist das Festlegen der Tab-Reihenfolge. Solange die Arbeit am Layout des Formularentwurfs noch nicht abgeschlossen ist, können sich Objekte verschieben. Daher ist es am besten zu warten, bis der Formularentwurf fertig gestellt ist, bevor Sie die Tab-Reihenfolge festlegen.
Wenn Sie die Tab-Reihenfolge für ein Formular festlegen, das als Vorlage verwendet wird, verwenden alle auf dieser Vorlage basierten Formulare dieselbe Tab-Reihenfolge.
1.
Wählen Sie „Ansicht“ > „Tab-Reihenfolge“. Auf der Seite wird die aktuelle Tab-Reihenfolge angezeigt.
Im Musterbestellformular möchten wir die Tab-Reihenfolge so ändern, dass die Informationen zur Bestelladresse in der Tab-Reihenfolge vor den Informationen zur Lieferadresse stehen.
2.
Klicken Sie auf das Bild „Finance Corporation“, um es zum ersten Objekt in der Tab-Reihenfolge zu machen. Auf dem Objekt wird „1“ angezeigt.
3.
Klicken Sie auf den Titel „Bestellung“, um ihn zum zweiten Objekt in der Tab-Reihenfolge zu machen. Auf dem Objekt wird „2“ angezeigt.
4.
Klicken Sie auf die restlichen Felder in der folgenden Reihenfolge: Bestellnummer, Bestelldatum, Bestellt von, Telefonnummer, Faxnummer, Kontaktname, Liefern an, Telefonnummer, Faxnummer, Kontaktname.
5.
Um zum normalen Entwurfsmodus zurückzukehren und die Anzeige der Tab-Reihenfolge auszuschalten, wählen Sie „Ansicht“ > „Tab-Reihenfolge“.
6.
Speichern Sie den Formularentwurf.


So ändern Sie die Tab-Reihenfolge mit der Maus

1.
Führen Sie einen der folgenden Schritte aus:
      •
      Wenn die Tab-Reihenfolge nicht im Formularentwurf anzeigt wird, wählen Sie „Ansicht“ > „Tab-Reihenfolge“.
      •
      Wenn die Tab-Reihenfolge aktuell auf dem Bildschirm angezeigt wird, wählen Sie „Ansicht“ > „Tab-Reihenfolge“ aus, um sie zu deaktivieren. Wählen Sie dann erneut „Tab-Reihenfolge“ aus.
2.
Klicken Sie auf das Feld, das die Nummer 1 sein soll. Die Tab-Reihenfolge wird so geändert, dass das aktuelle Feld zur Nummer 1 wird. Die restlichen Felder werden neu nummeriert, angefangen mit dem Feld, das ursprünglich Nummer 1 war.
3.
Um die Bearbeitung der Tab-Reihenfolge fortzusetzen, klicken Sie auf die restlichen Felder, um die gewünschte Reihenfolge herzustellen.
4.
Um zum normalen Entwurfsmodus zurückzukehren und die Anzeige der Tab-Reihenfolge auszuschalten, wählen Sie „Ansicht“ > „Tab-Reihenfolge“.


So ändern Sie die Tab-Reihenfolge mit Tastenkombinationen

      •
      Um die Position festzulegen, an der Sie mit der Bearbeitung der Tab-Reihenfolge beginnen möchten, klicken Sie bei gedrückter Steuerungstaste auf das gewünschte Feld im Formularentwurf.
      •
      Um eine neue Nummer 1 in der Tab-Reihenfolge festzulegen, klicken Sie bei gedrückter Umschalttaste auf das gewünschte Feld.
      •
      Um dieses Feld aus der Tab-Reihenfolge zu entfernen, halten Sie die Steuerungstaste und die Umschalttaste auf einem Feld gedrückt. Dadurch wird die Tab-Reihenfolge zur geografischen Reihenfolge zurückgesetzt und eine Reihenfolge wird möglicherweise in zwei aufgeteilt, falls sich das Feld in der Mitte einer vorhanden Reihenfolge befand.
      •
      Um Änderungen zu speichern und den Tab-Reihenfolge-Modus zu verlassen, drücken Sie die Eingabetaste.
      •
      Um die während der aktuellen Sitzung im Tab-Reihenfolge-Modus durchgeführten Änderungen zu verwerfen, drücken Sie die Esc-Taste. Durch diese Aktion wird auch der Tab-Reihenfolge-Modus beendet.
Verwandte Themen
Mit der Tastatur arbeiten


Rechtschreibung in Formularen prüfen

So wählen Sie die Standardsprache aus
So prüfen Sie die Rechtschreibung während der Eingabe
So prüfen Sie die Rechtschreibung in einem Formular
So fügen Sie ein Wort in allen Sprachen zum benutzerdefinierten Wörterbuch hinzu
So fügen Sie ein Wort in bestimmten Sprachen zum benutzerdefinierten Wörterbuch hinzu
So bearbeiten Sie das benutzerdefinierte Wörterbuch
Ein Wort zur Liste der ignorierten Wörter hinzufügen
So fügen Sie ein Wörterbuch hinzu
So entfernen Sie ein Wörterbuch


So wählen Sie die Standardsprache aus

Bevor Sie die Rechtschreibung in einem Formular prüfen, sollten Sie sicherstellen, dass die richtige Standardsprache im Formular ausgewählt ist. Die im Dialogfeld „Formulareigenschaften“ in der Liste „Standardsprache für Formulare“ ausgewählte Sprachoption gibt die Standardsprache an, die in LiveCycle Designer zum Prüfen der Rechtschreibung verwendet wird. Zur Information wird die aktuelle Sprache für die Rechtschreibprüfung rechts oben im Dialogfeld „Rechtschreibprüfung“ direkt unter der Titelleiste angezeigt.
Wenn Sie auf einzelne Objekte im Formular mit Hilfe der Liste „Sprache“ in der Palette „Objekt“ unterschiedliche Sprachoptionen anwenden, wird die standardmäßige Spracheinstellung für das Formular von diesen Spracheinstellungen überschrieben. D. h., wenn sich die Spracheinstellung für ein Objekt von der Spracheinstellung für das Formular unterscheidet, erkennt LiveCycle Designer die mit diesen Objekten verknüpften Wörter (Text) als Rechtschreibfehler.
Beim Anwenden unterschiedlicher Sprachoptionen auf einzelne Objekte müssen Sie beachten, dass die Objekte in Tabellen und Teilformularen automatisch dieselbe Spracheinstellung erhalten wie das Tabellen- und Teilformularobjekt.
Wenn Sie eine Sprachoption (bzw. eine Sprache) auswählen, die keine Rechtschreibprüfung unterstützt, wird eine Meldung mit der Information angezeigt, dass die Rechtschreibung bei Objekten mit dieser speziellen Spracheinstellung nicht geprüft wird.
1.
Wählen Sie „Datei“ > „Formulareigenschaften“.
2.
Klicken Sie auf die Registerkarte „Standard“ und wählen Sie in der Liste „Standardsprache für Formulare“ die Sprache aus, die bei der Rechtschreibprüfung verwendet werden soll.
3.
Klicken Sie auf „OK“.
Verwandte Themen
So prüfen Sie die Rechtschreibung während der Eingabe
So prüfen Sie die Rechtschreibung in einem Formular
Dialogfeld „Formulareigenschaften“


So prüfen Sie die Rechtschreibung während der Eingabe

Sie können LiveCycle Designer so einrichten, dass Rechtschreibfehler während der Eingabe erkannt werden, indem Sie im Dialogfeld „Optionen“ im Fenster „Rechtschreibung“ die Option „Rechtschreibung während Eingabe prüfen“ aktivieren.
Wenn die Option „Rechtschreibung während Eingabe prüfen“ aktiviert ist, wird eine rote Wellenlinie unter falsch geschriebenen Wörtern in statischen Textobjekten, Beschriftungsfeldern oder den verschiedenen Feldern in den Paletten „Objekt“ und „Ein-/Ausgabehilfe“ angezeigt, unabhängig von den ausgewählten Optionen. Mit den Optionen in der Liste „Rechtschreibprüfung“ können Sie den Texttyp angeben, für den beim Verwenden des Dialogfeldes „Rechtschreibprüfung“ die Rechtschreibung geprüft werden soll.
Beim Prüfen der Rechtschreibung in einem Formular bezieht sich LiveCycle Designer immer auf das interne und das benutzerdefinierte Wörterbuch („Mein benutzerdefiniertes Wörterbuch“). Durch Hinzufügen weiterer benutzerdefinierter Wörterbuchdateien (*.clam) können Sie die Liste der Wörter mit korrekter Rechtschreibung in LiveCycle Designer erweitern. Weitere Informationen finden Sie unter Ein Wort zur Liste der ignorierten Wörter hinzufügen.
Zum Anzeigen einer Liste der momentan verfügbaren Wörterbücher wählen Sie „Extras“ > „Optionen“ und klicken Sie auf „Rechtschreibung“. Im Fenster „Rechtschreibung“ wird eine Liste der installierten Wörterbücher angezeigt. Beachten Sie, dass „Mein benutzerdefiniertes Wörterbuch“ immer ausgewählt ist und nicht entfernt werden kann.
Berücksichtigen Sie beim Prüfen der Rechtschreibung während der Eingabe auch folgende Punkte:
      •
      Unter falsch geschriebenen Wörtern in statischen Textobjekten und Beschriftungsfeldern wird nur dann eine rote Wellenlinie angezeigt, wenn der Einfügepunkt (vertikale, blinkende Leiste für die Texteingabe) in oder direkt neben dem Text platziert wird.
      •
      Sie können die Farbe der Wellenlinie ändern, indem Sie „Extras“ > „Optionen“ > „Rechtschreibung“ > „Unterstreichungsfarbe“ auswählen.
      •
      In LiveCycle Designer werden im Kontextmenü für die einzelnen Rechtschreibfehler maximal vier alternative Rechtschreibvorschläge angezeigt. Wenn Sie mehr als vier Vorschläge anzeigen möchten, verwenden Sie das Dialogfeld „Rechtschreibprüfung“.
1.
Um LiveCycle Designer für die Erkennung von Rechtschreibfehlern während der Eingabe einzurichten, wählen Sie „Extras“ > „Optionen“ und aktivieren Sie im Fenster „Rechtschreibung“ die Option „Rechtschreibung während Eingabe prüfen“.
2.
Um einen Rechtschreibfehler während der Eingabe zu korrigieren, platzieren Sie den Einfügepunkt in oder direkt neben dem unterstrichenen Wort und klicken Sie mit der rechten Maustaste, um einen der folgenden Schritte auszuführen:
      •
      Zum Korrigieren des falsch geschriebenen Wortes wählen Sie eines der vorgeschlagenen Wörter im Kontextmenü aus. Wenn für das falsch geschriebene Wort keine Rechtschreibvorschläge vorhanden sind, wird stattdessen der Text Keine Vorschläge angezeigt.
      •
      Zum Hinzufügen des Wortes in „Mein benutzerdefiniertes Wörterbuch“ wählen Sie „Zum Wörterbuch hinzufügen“ aus. Durch diese Option wird das unterstrichene Wort in allen Sprachen zum Wörterbuch hinzugefügt. Von LiveCycle Designer wird das Wort nicht mehr als Rechtschreibfehler erkannt.
      •
      Zum Ignorieren aller Vorkommnisse des falsch geschriebenen Wortes wählen Sie „Alle ignorieren“ aus. Durch diese Option wird das Wort zur Liste der ignorierten Wörter hinzugefügt. Von LiveCycle Designer wird das Wort vorübergehend nicht als Rechtschreibfehler erkannt. Das Wort wird bei allen Rechtschreibprüfungen ignoriert, bis Sie LiveCycle Designer neu starten. Die Liste mit zu ignorierenden Wörtern wird beim Starten von LiveCycle Designer jedes Mal gelöscht.
Verwandte Themen
So wählen Sie die Standardsprache aus
So prüfen Sie die Rechtschreibung in einem Formular
So bearbeiten Sie das benutzerdefinierte Wörterbuch
Dialogfeld „Optionen“


So prüfen Sie die Rechtschreibung in einem Formular

Mit dem Dialogfeld „Rechtschreibprüfung“ können den Text in ausgewählten Objekten oder in einem gesamten Formular auf Rechtschreibfehler prüfen.
Standardmäßig prüft LiveCycle Designer die Rechtschreibung im gesamten Text, der mit den verschiedenen Objekten in einem Formular verknüpft ist, z. B. in statischem Text, Beschriftungen, QuickInfos, benutzerdefiniertem Bildschirmlesehilfen-Text und Listenfeldeinträgen. In LiveCycle Designer können Sie jedoch den geprüften Texttyp steuern, indem Sie die jeweiligen Optionen in der Liste „Rechtschreibprüfung“ auswählen, die sich im Dialogfeld „Optionen“ im Fenster „Rechtschreibung“ befindet. Wenn Sie die Optionen „Statischer Text“ und „Beschriftungen“ aktivieren, können Sie auch bestimmte statische Texte oder Beschriftungen für die Rechtschreibprüfung im Formular auswählen. Wenn die Optionen „Statischer Text“ und „Beschriftungen“ nicht aktiviert sind, wird die Rechtschreibung in markierten statischen Textobjekten oder Beschriftungsfeldern in LiveCycle Designer nicht geprüft.
Beim Prüfen der Rechtschreibung in einem Formular bezieht sich LiveCycle Designer immer auf das interne und das benutzerdefinierte Wörterbuch („Mein benutzerdefiniertes Wörterbuch“). Durch Hinzufügen weiterer benutzerdefinierter Wörterbuchdateien (*.clam) können Sie die Liste der Wörter mit korrekter Rechtschreibung in LiveCycle Designer erweitern. Weitere Informationen finden Sie unter Ein Wort zur Liste der ignorierten Wörter hinzufügen.
Zum Anzeigen einer Liste der momentan verfügbaren Wörterbücher wählen Sie „Extras“ > „Optionen“ und klicken Sie auf „Rechtschreibung“. Im Fenster „Rechtschreibung“ wird eine Liste der installierten Wörterbücher angezeigt. Beachten Sie, dass „Mein benutzerdefiniertes Wörterbuch“ immer ausgewählt ist und nicht entfernt werden kann.
1.
(Optional) Wenn Sie die Rechtschreibung in bestimmten Textobjekten oder Beschriftungsfeldern prüfen möchten, wählen Sie die erforderlichen Objekte bei gedrückter Steuerungstaste aus.
2.
Wählen Sie „Extras“ > „Rechtschreibprüfung“. Das Dialogfeld „Rechtschreibprüfung“ wird beim ersten falsch geschriebenen Wort angezeigt, das unter „Nicht im Wörterbuch“ mit roter Farbe hervorgehoben wird.
3.
Um Rechtschreibfehler zu korrigieren, führen Sie einen der folgenden Schritte aus:
      •
      Zum Korrigieren des falsch geschriebenen Wortes wählen Sie eines der Wörter in der Liste „Vorschläge“ aus und klicken Sie auf „Ändern“, um dieses Vorkommnis des falsch geschriebenen Wortes zu ersetzen, oder klicken Sie auf „Alle ändern“, um alle Vorkommnisse des falsch geschriebenen Wortes zu ersetzen. Wenn sich das betreffende Wort nicht in der Liste der vorgeschlagenen Wörter befindet, können Sie die richtige Schreibweise direkt im Dialogfeld „Rechtschreibprüfung“ eingeben und anschließend je nach Bedarf auf „Ändern“ oder auf „Alle ändern“ klicken.
      •
      Zum einmaligen Ignorieren des falsch geschriebenen Wortes klicken Sie auf „Einmal ignorieren“.
      •
      Zum Ignorieren aller Vorkommnisse des falsch geschriebenen Wortes klicken Sie auf „Alle ignorieren“. Durch diese Option wird das Wort zur Liste der ignorierten Wörter hinzugefügt. Von LiveCycle Designer wird das Wort vorübergehend nicht als Rechtschreibfehler erkannt. Das Wort wird bei allen Rechtschreibprüfungen ignoriert, bis Sie LiveCycle Designer neu starten. Die Liste mit zu ignorierenden Wörtern wird beim Starten von LiveCycle Designer jedes Mal gelöscht.
      •
      Zum Hinzufügen des Wortes in „Mein benutzerdefiniertes Wörterbuch“ klicken Sie auf „Zum Wörterbuch hinzufügen“. Durch diese Option wird das hervorgehobene Wort in allen Sprachen zu „Mein benutzerdefiniertes Wörterbuch“ hinzugefügt. Von LiveCycle Designer wird das Wort nicht mehr als Rechtschreibfehler erkannt.
Wenn Sie einen Rechtschreibfehler korrigiert haben, wird im Dialogfeld „Rechtschreibprüfung“ automatisch das nächste falsch geschriebene Wort angezeigt. Wenn die Rechtschreibprüfung abgeschlossen ist, wird in LiveCycle Designer eine entsprechende Meldung angezeigt.
Verwandte Themen
So bearbeiten Sie das benutzerdefinierte Wörterbuch
Dialogfeld „Rechtschreibprüfung“
Dialogfeld „Optionen“


So fügen Sie ein Wort in allen Sprachen zum benutzerdefinierten Wörterbuch hinzu

Wenn Sie die Rechtschreibung in einem Formular prüfen, erkennt LiveCycle Designer ein Wort möglicherweise als falsch geschrieben, obwohl das Wort eigentlich richtig geschrieben ist. So erkennt LiveCycle Designer beispielsweise generell keine firmen- oder branchenspezifische Produktterminologie und Abkürzungen. Aus diesem Grund stehen den einzelnen Benutzern in LiveCycle Designer jeweils ein benutzerdefiniertes Wörterbuch („Mein benutzerdefiniertes Wörterbuch“) zur Verfügung, in dem sie eine benutzerdefinierte Liste richtig geschriebener Wörter erstellen können. „Mein benutzerdefiniertes Wörterbuch“ wird im Dialogfeld „Optionen“ im Fenster „Rechtschreibung“ unter „Installierte Wörterbücher“ angezeigt und ist standardmäßig ausgewählt. LiveCycle Designer bezieht sich immer auf „Mein benutzerdefiniertes Wörterbuch“, wenn Sie die Rechtschreibung in einem Formular prüfen. Deshalb können Sie dieses Wörterbuch nicht löschen.
Die Wörter, die Sie zum benutzerdefinierten Wörterbuch hinzufügen, werden automatisch in allen Sprachen hinzugefügt. LiveCycle Designer betrachtet die Wörter als richtig geschrieben, unabhängig davon, welche Sprache momentan auf das Formular oder auf ein ausgewähltes Objekt angewendet wird. Wenn das Wort, das Sie zum benutzerdefinierten Wörterbuch hinzufügen möchten, allerdings nicht für alle Sprachen gilt, können Sie das Wort über das Dialogfeld „Wörterbuch bearbeiten“ für bestimmte Sprachen hinzufügen. Nachdem Sie das Wort zum benutzerdefinierten Wörterbuch hinzugefügt haben, erkennt LiveCycle Designer die Rechtschreibung des betreffenden Wortes als richtig und entfernt die rote Wellenlinie unter dem Wort.
      *
      Klicken Sie mit der rechten Maustaste auf das falsch geschriebene Wort und wählen Sie „Zum Wörterbuch hinzufügen“ aus.


So fügen Sie ein Wort in bestimmten Sprachen zum benutzerdefinierten Wörterbuch hinzu

Wenn das Wort, das Sie zum benutzerdefinierten Wörterbuch („Mein benutzerdefiniertes Wörterbuch“) hinzufügen möchten, nicht für alle Sprachen gilt, können Sie das Wort über das Dialogfeld „Wörterbuch bearbeiten“ für bestimmte Sprachen hinzufügen. Nachdem Sie das Wort zu „Mein benutzerdefiniertes Wörterbuch“ hinzugefügt haben, erkennt LiveCycle Designer die Rechtschreibung des betreffenden Wortes für die jeweilige Sprache als richtig und entfernt die rote Wellenlinie unter dem Wort.
1.
Wählen Sie „Extras“ > „Wörterbuch bearbeiten“.
2.
Wählen Sie in der Liste „Sprache“ die gewünschte Sprache aus.
3.
Geben Sie im Feld „Wort“ die richtige Schreibweise des Wortes ein, das Sie hinzufügen möchten.
4.
Klicken Sie auf „Hinzufügen“.
5.
Wiederholen Sie diese Schritte, um das Wort in einer anderen Sprache hinzuzufügen.
Verwandte Themen
So fügen Sie ein Wort in allen Sprachen zum benutzerdefinierten Wörterbuch hinzu
So bearbeiten Sie das benutzerdefinierte Wörterbuch
Dialogfeld „Wörterbuch bearbeiten“


So bearbeiten Sie das benutzerdefinierte Wörterbuch

Möglicherweise möchten Sie Ihr benutzerdefiniertes Wörterbuch („Mein benutzerdefiniertes Wörterbuch“) von Zeit zu Zeit bearbeiten oder dessen Inhalt überprüfen. Im Dialogfeld „Wörterbuch bearbeiten“ können Sie in der Liste „Sprache“ Optionen zum Anzeigen der Wörter auswählen, die mit allen Sprachen oder mit bestimmten Sprachen verknüpft sind. Außerdem können Sie die Rechtschreibung der aufgelisteten Wörter ändern und Wörter in allen oder bestimmten Sprachen hinzufügen oder entfernen.
      *
      Zum Öffnen des Dialogfeldes „Wörterbuch bearbeiten“ wählen Sie „Extras“ > „Wörterbuch bearbeiten“.
Verwandte Themen
So fügen Sie ein Wort in allen Sprachen zum benutzerdefinierten Wörterbuch hinzu
So fügen Sie ein Wort in bestimmten Sprachen zum benutzerdefinierten Wörterbuch hinzu
Dialogfeld „Optionen“
Dialogfeld „Wörterbuch bearbeiten“


Ein Wort zur Liste der ignorierten Wörter hinzufügen

Manchmal kann es vorkommen, dass LiveCycle Designer ein Wort als falsch geschrieben erkennt, obwohl es eigentlich richtig geschrieben ist. In solchen Fällen ist es jedoch nicht immer erforderlich, das Wort zu Ihrem benutzerdefinierten Wörterbuch hinzuzufügen. Alternativ können Sie eine Liste mit Wörtern erstellen, die beim Prüfen der Rechtschreibung eines Dokuments vorübergehend von LiveCycle Designer ignoriert werden. LiveCycle Designer erkennt die Rechtschreibung der ignorierten Wörter weder als richtig noch als falsch und übergeht sie bei der Durchführung einer Rechtschreibprüfung.
Sie können die Liste der ignorierten Wörter nicht anzeigen oder bearbeiten. Deshalb sollten Sie sich die hinzugefügten Wörter merken. Die Liste der ignorierten Wörter bleibt erhalten, bis Sie LiveCycle Designer schließen. Bei jedem Starten von LiveCycle Designer wird die Liste gelöscht.
Mit Hilfe der Befehle im Kontextmenü (Klicken mit der rechten Maustaste) können Sie ein Wort schnell zur Liste der ignorierten Wörter hinzufügen, während Sie Text in eines der Felder in einem Formular oder in den Paletten „Objekt“ oder „Hierarchie“ eingeben. Über die Schaltflächen im Dialogfeld „Rechtschreibprüfung“ können Sie auch ein Wort zur Liste der ignorierten Wörter hinzufügen, während Sie die Rechtschreibung in einem Formular prüfen.
So fügen Sie während der Eingabe ein Wort zur Liste der ignorierten Wörter hinzu
      •
      Klicken Sie mit der rechten Maustaste auf ein falsch geschriebenes Wort in einem beliebigen Feld in einem Formular oder in der Palette „Objekt“ oder „Hierarchie“ und wählen Sie „Alle ignorieren“ aus. Von LiveCycle Designer werden alle Instanzen des Wortes vorübergehend ignoriert, bis LiveCycle Designer neu gestartet wird.
So fügen Sie während der Rechtschreibprüfung in einem Formular ein Wort zur Liste der ignorierten Wörter hinzu
1.
Wählen Sie „Extras“ > „Rechtschreibprüfung“. Das Dialogfeld „Rechtschreibprüfung“ wird beim ersten falsch geschriebenen Wort angezeigt, das unter „Nicht im Wörterbuch“ mit roter Farbe hervorgehoben wird.
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Zum einmaligen Ignorieren des falsch geschriebenen Wortes klicken Sie auf „Einmal ignorieren“. LiveCycle Designer ignoriert das Wort und fährt mit dem nächsten falsch geschriebenen Wort fort.
      •
      Zum Ignorieren aller Vorkommnisse des falsch geschriebenen Wortes klicken Sie auf „Alle ignorieren“. LiveCycle Designer ignoriert alle Vorkommnisse des falsch geschriebenen Wortes und fährt mit dem nächsten falsch geschriebenen Wort fort. Bei allen Rechtschreibprüfungen werden alle Vorkommnisse des falsch geschriebenen Wortes ignoriert, bis Sie LiveCycle Designer neu starten. Die Liste mit zu ignorierenden Wörtern wird beim Starten von LiveCycle Designer jedes Mal gelöscht.
Verwandte Themen
So fügen Sie ein Wort in bestimmten Sprachen zum benutzerdefinierten Wörterbuch hinzu
So bearbeiten Sie das benutzerdefinierte Wörterbuch
Dialogfeld „Rechtschreibprüfung“
Dialogfeld „Wörterbuch bearbeiten“


So fügen Sie ein Wörterbuch hinzu

Wenn Sie die Liste der richtig geschriebenen Wörter erweitern möchten, auf die sich LiveCycle Designer beim Prüfen der Rechtschreibung in einem Formular bezieht, können Sie eine oder mehrere benutzerdefinierte Wörterbuchdateien (*.clam) für eine bestimmte Sprache oder für alle unterstützten Sprachen hinzufügen. Sie können beispielsweise ein benutzerdefiniertes Wörterbuch mit eindeutigen Begriffen für spezielle Branchen hinzufügen, z. B. Medizin, Recht, Technik, Versicherungen oder Finanzen.
Wenn Sie die Wörter in einer benutzerdefinierten Wörterbuchdatei nicht für alle Sprachen, sondern nur für eine bestimmte Sprache hinzufügen möchten, müssen Sie die richtigen Spracherweiterungen zum Dateinamen des benutzerdefinierten Wörterbuchs hinzufügen. D. h., wenn Sie eine benutzerdefinierte Wörterbuchdatei ausschließlich für Frankokanadisch hinzufügen möchten, müssen Sie dem Dateinamen die Endung fr_CA hinzufügen (z. B. [Dateiname]-fr_CA.clam). Wenn Sie dem Dateinamen keine Spracherweiterung hinzufügen, werden die Wörter in der Datei für alle Sprachen als richtig erachtet.
Mit den Optionen im Fenster „Rechtschreibung“ des Dialogfeldes „Optionen“ können Sie Wörterbücher hinzufügen und auswählen, welche Wörterbücher beim Durchführen von Rechtschreibprüfungen verwendet werden.
1.
Wählen Sie „Extras“ > „Optionen“.
2.
Wählen Sie links in der Liste „Rechtschreibung“ aus und klicken Sie auf „Wörterbuch hinzufügen“. Das Dialogfeld „Benutzerdefinierte Wörterbuchdatei“ wird angezeigt.
3.
Suchen Sie nach der Wörterbuchdatei, die Sie zu LiveCycle Designer hinzufügen möchten, und klicken Sie auf „Öffnen“. Das Wörterbuch wird zu der Liste der installierten Wörterbücher hinzugefügt.
Verwandte Themen
So entfernen Sie ein Wörterbuch
So bearbeiten Sie das benutzerdefinierte Wörterbuch
Dialogfeld „Optionen“
Dialogfeld „Wörterbuch bearbeiten“


So entfernen Sie ein Wörterbuch

Im Dialogfeld „Optionen“ im Fenster „Rechtschreibung“ werden in der Liste „Installierte Wörterbücher“ die Wörterbücher angezeigt, die momentan für das Prüfen der Rechtschreibung in einem Formular verfügbar sind. Sie können ein oder mehrere benutzerdefinierte Wörterbücher löschen, die Sie nicht mehr benötigen. Wenn Sie ein benutzerdefiniertes Wörterbuch löschen, wird es aus der Liste der installierten Wörterbücher entfernt. Die eigentliche Wörterbuchdatei (*.clam) wird nicht aus dem Dateisystem Ihres Computers entfernt.
„Mein benutzerdefiniertes Wörterbuch“ kann nicht entfernt werden, weil sich LiveCycle Designer bei allen Rechtschreibprüfungen für Formulare auf dieses Wörterbuch bezieht.
1.
Wählen Sie „Extras“ > „Optionen“.
2.
Wählen Sie im Fenster „Rechtschreibung“ das Wörterbuch aus, das Sie aus der Liste „Installierte Wörterbücher“ löschen möchten.
3.
Klicken Sie auf „Wörterbuch entfernen“.
Verwandte Themen
Ein Wort zur Liste der ignorierten Wörter hinzufügen
So bearbeiten Sie das benutzerdefinierte Wörterbuch
Dialogfeld „Optionen“


Formulare in der Vorschau anzeigen und testen

Info über die Vorschau und das Testen von Formularen
So können Sie Formulare auf der Registerkarte „PDF-Vorschau“ in der Vorschau anzeigen und testen
So legen Sie Vorschauoptionen für ein interaktives Formular fest
So legen Sie Vorschauoptionen für ein nicht interaktives Formular fest
So testen Sie ein Formular mit Musterdaten
So erstellen Sie Musterdaten für die Vorschau eines Formulars
So generieren Sie automatisch Musterdaten für die Vorschau eines Formulars
So testen Sie ein Formular auf Verfügbarkeit


Info über die Vorschau und das Testen von Formularen

Auf der Registerkarte „PDF-Vorschau“ können Sie einen Formularentwurf oder eine Vorlage mit Acrobat oder Adobe Reader als PDF-Formular anzeigen und testen.
Die Registerkarte „PDF-Vorschau“ wird nur angezeigt, wenn Acrobat oder Adobe Reader installiert ist. Wenn sowohl Acrobat als auch Adobe Reader installiert ist, wird Acrobat von LiveCycle Designer automatisch für eine Vorschau des Formulars gestartet. Wenn Sie in Adobe Reader eine Vorschau des Formulars anzeigen möchten, müssen Sie Adobe Reader starten, bevor Sie auf die Registerkarte „PDF-Vorschau“ klicken.
Die Vorschau verwendet das gleiche Format wie das gespeicherte Formular. LiveCycle Designer zeigt ein neues (noch nicht gespeichertes) Formular standardmäßig als statisches PDF-Formular an. Um ein noch nicht gespeichertes Formular als dynamisches PDF-Formular anzuzeigen, müssen Sie die Standardeinstellung für das XDP-Vorschauformat unter „Datei“ > „Formulareigenschaften“ auf eine der folgenden dynamischen Formularoptionen setzen.
Wenn Sie ein interaktives oder druckbares Formular entwerfen, müssen Sie zunächst den Formulartyp angeben, um die PDF-Vorschau richtig einzurichten. Legen Sie hierfür die Vorschaueinstellungen im Dialogfeld „Formulareigenschaften“ fest.
Wenn Sie Formulare für eine Verwendung mit LiveCycle Forms entwerfen, kann derselbe Formularentwurf zur Wiedergabe von PDF- oder HTML-Formularen verwendet werden. Obwohl Sie eine Vorschau des Formularentwurfs auf der Registerkarte „PDF-Vorschau“ anzeigen können, wird das HTML-Formular möglicherweise nicht wie bei der Wiedergabe mit LiveCycle Forms dargestellt. Wenn Sie ein HTML-Formular erstellen, sollten Sie das Formular mit LiveCycle Forms wiedergeben und eine Vorschau in einem Webbrowser anzeigen.
Verwandte Themen
Allgemeine Überlegungen beim Entwurf barrierefreier Formulare


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Formulare in der Vorschau anzeigen und testen > So können Sie Formulare auf der Registerkarte „PDF-Vorschau“ in der Vorschau anzeigen und testen

So können Sie Formulare auf der Registerkarte „PDF-Vorschau“ in der Vorschau anzeigen und testen

Auf der Registerkarte „PDF-Vorschau“ können Sie eine Vorschau des Formularentwurfs so anzeigen, wie er in Adobe Reader dargestellt wird. Stellen Sie vor der Vorschau des Formularentwurfs sicher, dass Sie die entsprechenden Optionen für die Vorschau des jeweiligen Formulartyps im Dialogfeld „Formulareigenschaften“ festgelegt haben.
Um die Vorschau eines Formulars auf der Registerkarte „PDF-Vorschau“ anzuzeigen, muss in Acrobat die Option „PDF in Browser anzeigen“ ausgewählt sein. Vergewissern Sie sich, dass die installierte Version von Acrobat der Version entspricht, in der das Formular gespeichert wurde. Andernfalls wird ein Fehler oder ein Warnhinweis ausgegeben, wenn Sie auf die Registerkarte „PDF-Vorschau“ klicken. Wenn Sie das Formular beispielsweise im Format „Acrobat 7.0.5 dynamische PDF-Formulardatei“ gespeichert haben, muss Acrobat 7.0.5 installiert sein.
1.
Sie können die Registerkarte „PDF-Vorschau“ auf eine der folgenden Arten anzeigen:
      •
      Wählen Sie „Ansicht“ > „PDF-Vorschau“.
      •
      Klicken Sie im Layout-Editor auf die Registerkarte „PDF-Vorschau“.
2.
Falls es sich um ein interaktives Formular handelt, können Sie durch Testen der Objekte im Formular sicherstellen, dass sie wie erwartet funktionieren.
3.
(Optional) Falls es sich um ein nicht interaktives Formular handelt, das mit Daten zusammengeführt wird, können Sie das Formular anhand einer Musterdatendatei testen, um sicherzustellen, dass die Felder ordnungsgemäß mit der Datenquelle verbunden sind.
Sie müssen die Funktionen für die Webdienste und die Datenbankverbindung mit Acrobat testen. Diese Funktionen erfordern ein PDF-Formular mit aktivierten Berechtigungen. Verwendungsrechte für ein PDF-Formular können jedoch nicht für die Vorschau in LiveCycle Designer festgelegt werden.


So legen Sie Vorschauoptionen für ein interaktives Formular fest

Wenn Sie eine Vorschau für ein interaktives Formular anzeigen möchten, müssen Sie die entsprechenden Optionen im Dialogfeld „Formulareigenschaften“ festlegen.
1.
Wählen Sie „Datei“ > „Formulareigenschaften“.
2.
Klicken Sie auf die Registerkarte „Standard“ und wählen Sie in der Liste „Vorschautyp“ die Option „Interaktives Formular“ aus.
3.
(Optional) Wenn Sie das in der Vorschau angezeigte Formular mit einer von Ihnen erstellten Datenquelle testen möchten, geben Sie im Feld „Datendatei“ den vollständigen Pfad zu einer Testdatendatei ein. Sie können auch auf die Schaltfläche „Durchsuchen“ klicken, um zur gewünschten Datei zu gelangen.
4.
(Optional) Wenn Sie das in der Vorschau angezeigte Formular mit einer automatisch generierten Datenquelle testen möchten, klicken Sie auf „Vorschaudaten erstellen“. Wenn das Formular sich wiederholende Teilformulare oder Teilformularsätze enthält, geben Sie an, wie oft das jeweilige Teilformular oder der Teilformularsatz in der Datendatei wiederholt wird. Sie können auf die Schaltfläche „Durchsuchen“ klicken, um zu dem Speicherort zu gelangen, an dem Sie die Datei speichern möchten. Geben Sie einen Namen für die Datei ein und klicken Sie dann auf „Erstellen“.
5.
Wählen Sie in der Liste „XDP-Vorschauformat“ das PDF-Vorschauformat für XDP- und TDS-Dateien aus. Bei PDF-Dateien wird das XDP-Vorschauformat allerdings ignoriert.


So legen Sie Vorschauoptionen für ein nicht interaktives Formular fest

Wenn Sie eine Vorschau für ein nicht interaktives Formular anzeigen möchten, müssen Sie die entsprechenden Optionen im Dialogfeld „Formulareigenschaften“ festlegen.
1.
Wählen Sie „Datei“ > „Formulareigenschaften“.
2.
(Optional) Wenn Sie das in der Vorschau angezeigte Formular mit einer Datenquelle testen möchten, geben Sie im Feld „Datendatei“ den vollständigen Pfad zu einer Testdatendatei ein. Sie können auch auf die Schaltfläche „Durchsuchen“ klicken, um zur gewünschten Datei zu gelangen.
3.
(Optional) Wenn Sie das in der Vorschau angezeigte Formular mit einer automatisch generierten Datenquelle testen möchten, klicken Sie auf „Vorschaudaten erstellen“. Wenn das Formular sich wiederholende Teilformulare oder Teilformularsätze enthält, geben Sie an, wie oft das jeweilige Teilformular oder der Teilformularsatz in der Datendatei wiederholt wird. Sie können auf die Schaltfläche „Durchsuchen“ klicken, um zu dem Speicherort zu gelangen, an dem Sie die Datei speichern möchten. Geben Sie einen Namen für die Datei ein und klicken Sie dann auf „Erstellen“.
4.
Wählen Sie in der Liste „XDP-Vorschauformat“ das PDF-Vorschauformat für XDP- und TDS-Dateien aus. Bei PDF-Dateien wird das XDP-Vorschauformat allerdings ignoriert.
Wenn Sie „Formular zum Drucken“ auswählen, sind alle Objekte nicht interaktiv. Das Gleiche gilt, wenn Sie beim Erstellen des Formularentwurfs im Assistenten für neue Formulare die Option „Ausfüllen und Senden/Drucken“ oder „Ausfüllen und Drucken“ aktiviert haben.


So testen Sie ein Formular mit Musterdaten

In LiveCycle Designer können Sie Ihr Formular mit XML-Musterdaten testen.
Durch Testen Ihres Formulars mit Hilfe von Musterdaten können Sie sicherstellen, dass die Daten und Felder zugeordnet werden und dass sich wiederholende Teilformulare erwartungsgemäß wiederholt werden. Sie können ein ausgeglichenes Formularlayout erstellen, das den jeweiligen Objekten genügend Platz zur Anzeige der zusammengeführten Daten bietet.
1.
Wählen Sie „Datei“ > „Formulareigenschaften“.
2.
Klicken Sie auf die Registerkarte „Standard“ und geben Sie im Feld „Datendatei“ den vollständigen Pfad zu einer Testdatendatei ein. Sie können auch auf die Schaltfläche „Durchsuchen“ klicken, um zur gewünschten Datei zu gelangen.
3.
Klicken Sie auf „OK“. Wenn Sie das nächste Mal eine Vorschau des Formulars auf der Registerkarte „PDF-Vorschau“ anzeigen, werden die Datenwerte der XML-Musterdatei in den entsprechenden Objekten dargestellt.
Eine ausführliche Beschreibung der Optionen auf der Registerkarte „Standard“ finden Sie unter Registerkarte „Standard“ (Dialogfeld „Formulareigenschaften“).
Verwandte Themen
So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei


So erstellen Sie Musterdaten für die Vorschau eines Formulars

Es wird empfohlen, das Formular regelmäßig mit Musterdaten zu testen, um sicherzustellen, dass es richtig wiedergegeben wird. Falls Ihnen keine Musterdaten vorliegen, können Sie sie erstellen.
Nachdem Sie die Musterdatendatei erstellt haben, können Sie angeben, welche Datendatei bei der Formularvorschau verwendet werden soll. Wenn Sie das nächste Mal eine Vorschau des Formulars in LiveCycle Designer anzeigen, werden die Musterdaten in den entsprechenden Objekten dargestellt.
1.
Speichern Sie den Formularentwurf als PDF-Datei.
2.
Öffnen Sie die PDF-Datei und geben Sie Werte in die zu testenden Felder ein.
3.
Wählen Sie in Acrobat „Formulare“ > „Formulardaten verwalten“ > „Daten exportieren“.
4.
Im Dialogfeld „Formulardaten exportieren“ benennen Sie die Datei und speichern Sie sie als XML-Datenpaket (*.xdp).
5.
Wählen Sie in LiveCycle Designer „Datei“ >„Formulareigenschaften“ > Registerkarte „Standard“.
6.
Klicken Sie neben dem Feld „Datendatei“ auf die Ordnerschaltfläche und suchen Sie die XDP-Datei.
7.
Wählen Sie die XDP-Datei aus und klicken Sie auf „OK“.
Verwandte Themen
So testen Sie ein Formular mit Musterdaten


So generieren Sie automatisch Musterdaten für die Vorschau eines Formulars

Statt eine Musterdatendatei zu erstellen, können Sie Musterdaten generieren, um Ihr Formular in der Vorschau anzuzeigen und zu testen. Wenn Ihr Formular sich wiederholende Teilformulare oder Teilformularsätze enthält, können Sie bei der Formularvorschau außerdem angeben, wie oft die Daten wiederholt werden.
LiveCycle Designer generiert Musterdaten, die für die entsprechenden Objekte im Formular gültig sind, mit folgenden Ausnahmen:
      •
      Die Musterdaten werden nicht gemäß einem Überprüfungsskript generiert, das unter Umständen für ein Objekt festgelegt wurde.
      •
      Durch den minimalen und maximalen Zählerwert für ein Teilformular wird die Anzahl der sich wiederholenden Teilformulare eingeschränkt, die Sie für die generierte Musterdatendatei angeben.
      •
      Der Standardwert, den Sie für einen 2D-Barcode auswählen, wird in der generierten Musterdatendatei beibehalten.
Nachdem Sie die Musterdatendatei generiert haben, können Sie die Datei gegebenenfalls bearbeiten.
Sie können festlegen, welche Datendatei bei der Formularvorschau verwendet werden soll. Wenn Sie das nächste Mal eine Vorschau des Formulars in LiveCycle Designer anzeigen, werden die Musterdaten in den entsprechenden Objekten dargestellt.
1.
Wählen Sie in LiveCycle Designer „Datei“ >„Formulareigenschaften“ > Registerkarte „Standard“.
2.
Klicken Sie auf die Registerkarte „Standard“ und wählen Sie in der Liste „Vorschautyp“ die Option „Interaktives Formular“ aus.
3.
Klicken Sie auf „Vorschaudaten erstellen“.
4.
Geben Sie im Dialogfeld „Vorschaudaten erstellen“ den vollständigen Pfad zur Testdatendatei ein, einschließlich eines Dateinamens. Sie können auf die Schaltfläche „Durchsuchen“ klicken, um zu dem Speicherort im Dialogfeld „Datendatei“ zu gelangen.
5.
Wählen Sie in der Liste „Wiederholungselemente“ die Zahl links neben einem Teilformular aus und geben Sie ein, wie oft es in der Datendatei wiederholt wird.
6.
Klicken Sie auf „Erstellen“.
Verwandte Themen
So testen Sie ein Formular mit Musterdaten


So testen Sie ein Formular auf Verfügbarkeit

Sie sollten Ihre Formulare mit verschiedenen Hilfstechnologien testen, um sicherzustellen, dass sie für Benutzer verfügbar sind.
Laden Sie Demoversionen von Bildschirmlesehilfen herunter. Da Sie als Formularverfasser mit dem Formular sehr vertraut sind, ist es für Sie eventuell schwierig zu beurteilen, ob die von der Bildschirmlesehilfe gelesenen Informationen ausreichend und verständlich sind. Lassen Sie wenn möglich jemand anders das Formular auf diese Weise testen. Zum Testen schalten Sie den Bildschirm aus und verwenden Sie nur die Bildschirmlesehilfe zum Navigieren und Ausfüllen des Formulars.
Schauen Sie im Internet nach Demo-Versionen von Bildschirmvergrößerungs-Software.
Stellen Sie sicher, dass das Formular ausschließlich mit der Tastatur ausgefüllt werden kann, und berücksichtigen Sie folgende Punkte:
      •
      Gibt es Vorgänge, die nicht ausgeführt werden können?
      •
      Sind einige Vorgänge umständlich oder schwierig auszuführen?
      •
      Sind die Tastaturfunktionen gut dokumentiert?
      •
      Haben alle Steuerelemente und Menüeinträge unterstrichene Zugriffstasten?
Beachten Sie beim Ausfüllen des Formulars folgende Punkte:
      •
      Teile des Formulars, die unsichtbar, nicht erkennbar oder schwer verwendbar sind.
      •
      Bereiche, die fortwährend in Schwarz mit weißem Hintergrund angezeigt werden.
      •
      Formularobjekte, die zu groß, zu klein oder abgeschnitten sind.
Verwandte Themen
Allgemeine Überlegungen beim Entwurf barrierefreier Formulare


Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten

Interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen
Nicht interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen
Objekte in einem Formular mit Layoutanpassungen an die Datenmenge platzieren
Formularentwürfe mit Layoutanpassungen an die Datenmenge erstellen


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen

Interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen

Info über interaktive Formulare mit Layoutanpassungen an die Datenmenge
Überlegungen zum Entwerfen interaktiver Formulare mit Layoutanpassungen an die Datenmenge
Kopf- und Fußzeilen auf der Masterseite platzieren
Objekte in Teilformulare aufnehmen und Werte für das Vorkommen festlegen
Ränder für Teilformulare anpassen
Überlaufkopfbereiche und Überlauffußbereiche in Teilformularen verwenden
Anpassbare Teilformulare erstellen
Schaltflächen zum Hinzufügen, entfernen eines Abschnitts erstellen
Schaltflächen zum Hinzufügen und Löschen erstellen
So können Sie Teilformularinstanzen mit Hilfe von Skripten hinzufügen, entfernen
So können Sie Tabellen und Tabellenzeilen mit Hilfe von Skripten hinzufügen, entfernen


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen > Info über interaktive Formulare mit Layoutanpassungen an die Datenmenge

Info über interaktive Formulare mit Layoutanpassungen an die Datenmenge

Mit LiveCycle Designer können Sie interaktive Formulare mit Teilformularen erstellen, deren Größe an die beim Wiedergeben des Formulars zusammengeführte Datenmenge angepasst wird, und die Benutzer mit Acrobat oder Adobe Reader öffnen und ausfüllen können. Bei dieser Art von Formularen wird Flexibilität mit interaktiven Formularfunktionen kombiniert, d. h., die Benutzer können die Daten direkt in erweiterbare Felder eingeben, Abschnitte hinzufügen oder entfernen und die Formulardaten elektronisch übermitteln. So können Sie beispielsweise ein interaktives Formular erstellen, in dem Benutzer Elementzeilen entfernen oder hinzufügen und Kommentare einfügen können.
Um interaktiven Formularen dynamische Funktionen hinzufügen zu können, müssen Sie mit Masterseiten, Inhaltsbereichen und Teilformularen arbeiten, um die Anordnung der Objekte im Formular in LiveCycle Designer zu steuern, wenn das Formular für das Anzeigen unterschiedlicher Datenmengen angepasst wird.
Benutzer können die Kommentarfunktionen von Acrobat beim Ausfüllen interaktiver Formulare mit Teilformularen, deren Größe an die zusammengeführte Datenmenge angepasst wird, nicht verwenden.
Unterschiede bei der Darstellung während des Entwurfs und zur Laufzeit
Beim Hinzufügen dynamischer Funktionen zu einem Formular sollten Sie sich stets bewusst sein, dass der Formularentwurf anders aussieht als das in Acrobat oder Adobe Reader angezeigte Formular.
Wenn Sie beispielsweise ein Formular in LiveCycle Designer öffnen, enthält der Formularentwurf unter Umständen nur eine Elementzeile für die Eingabe von Daten. In Acrobat oder Adobe Reader weist dieses Formular jedoch möglicherweise mehrere Elementzeilen auf. Dies geschieht, wenn Sie die Objekte in der Elementzeile in ein Teilformular aufgenommen und für das Teilformular die Optionen „Min-Zähler“ oder „Maximal“ aktiviert haben, um zu steuern, wie viele Zeilen zunächst im Formular zum Ausfüllen bereitstehen und wie viele Zeilen anschließend vom Benutzer hinzugefügt werden können.
Da sich das Layout interaktiver Formulare an die Benutzereingaben anpasst, entfällt die Notwendigkeit, die genaue Größe von Textfeldobjekten oder die genaue Anzahl von Elementzeilen von Anfang an im Formular festzulegen.
Indem Sie beispielsweise Optionen auswählen, wie „Mehrere Zeilen zulassen“, „Seitenumbrüche im Inhalt zulassen“ und „Passend erweitern“, können Sie interaktive Formulare mit einem flexiblen Layout erstellen, in denen eine unbestimmte Datenmenge ordnungsgemäß angezeigt wird.
Sie fügen einem interaktiven Formular dynamische Funktionen auf die gleiche Weise hinzu, wie Sie dynamische Funktionen zu einem Formular zur Verwendung mit LiveCycle Forms hinzufügen. Weitere Informationen zum Erstellen von Formularen mit flexiblem Layout für LiveCycle Forms finden Sie unter Info über das Erstellen von Formularentwürfen mit Layoutanpassungen an die Datenmenge.
Zum Ausfüllen interaktiver Formulare mit einem flexiblen Layout benötigen Endbenutzer Acrobat 7.0 oder Adobe Reader 7.0.
Verwandte Themen
Überlegungen zum Entwerfen interaktiver Formulare mit Layoutanpassungen an die Datenmenge
Formulare und Formularentwürfe
Info über das Erstellen von Formularentwürfen mit Layoutanpassungen an die Datenmenge


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen > Überlegungen zum Entwerfen interaktiver Formulare mit Layoutanpassungen an die Datenmenge

Überlegungen zum Entwerfen interaktiver Formulare mit Layoutanpassungen an die Datenmenge

Viele Formularverfasser beginnen mit dem Layout eines interaktiven Formularentwurfs mit festem Layout, das ein endgültiges Layout mit allen vom Benutzer benötigten Elementen enthält. Wenn der Formularentwurf Ihren Anforderungen entspricht, können Sie ihn in Teilformulare aufteilen und angeben, wie die Größe der Teilformulare an die zusammengeführte Datenmenge angepasst wird.
Beim Hinzufügen dynamischer Funktionen zu einem interaktiven Formular werden in der Regel die folgenden Vorgehensweisen angewendet:
      •
      Kopf- und Fußzeilen auf der Masterseite platzieren
      •
      Objekte in Teilformulare aufnehmen und Werte für das Vorkommen festlegen
      •
      Ränder für Teilformulare anpassen
      •
      Überlaufkopfbereiche und Überlauffußbereiche in Teilformularen verwenden
      •
      Anpassbare Teilformulare erstellen
      •
      Schaltflächen zum Hinzufügen, entfernen eines Abschnitts erstellen
      •
      Schaltflächen zum Hinzufügen und Löschen erstellen


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen > Kopf- und Fußzeilen auf der Masterseite platzieren

Kopf- und Fußzeilen auf der Masterseite platzieren

In einem interaktiven Formular mit festem Layout befindet sich der Kopf- und Fußzeilentext in der Regel auf der Seite. Wenn Sie Teilformulare hinzufügen, die für fließenden Inhalt im Formular definiert sind, befindet sich der Kopf- und Fußzeilentext normalerweise auf der Masterseite.
Da die Länge eines interaktiven Formulars, das für fließenden Inhalt definierte Teilformulare enthält, je nach Datenmenge des Formulars zunehmen kann, müssen dem Formular möglicherweise zusätzliche Seiten hinzugefügt werden, wenn der Endbenutzer mehr Daten eingibt. Indem die Kopf- und Fußzeile auf den Masterseiten platziert werden, stellen Sie sicher, dass sie auf jeder Seite angezeigt werden, und nicht nur auf der ersten Seite.
Verwandte Themen
Masterseiten einrichten


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen > Objekte in Teilformulare aufnehmen und Werte für das Vorkommen festlegen

Objekte in Teilformulare aufnehmen und Werte für das Vorkommen festlegen

Wenn Sie ein interaktives Formular mit festem Layout erstellen, müssen Sie eine ausreichende Anzahl an Elementzeilen bereitstellen, die vom Benutzer ausgefüllt werden können. Wenn Sie allerdings die Elementzeilen in Teilformulare aufnehmen, die für fließenden Inhalt definiert sind, können die Benutzer je nach Bedarf Elementzeilen hinzufügen.
Auf Grund der dynamischen Funktionen von Teilformularen müssen Sie nur eine oder zwei Elementzeilen zusammen mit einer Schaltfläche zum Hinzufügen und einer zum Löschen in das Formular einfügen. Durch Aufnehmen der Objekte in ein Teilformular können Sie bestimmen, wann, wo und wie oft ein bestimmtes Teilformular wiederholt wird. Dies geschieht über die Optionen auf den Registerkarten „Teilformular“ und „Bindung“ der Palette „Objekt“.
Das Aufnehmen von Objektgruppen in Teilformulare ist ein wesentlicher Aspekt beim Erstellen eines Formulars mit dynamischen Funktionen.
Teilformulare enthalten und steuern die Objekte, die in den Abschnitten des Formulars angeordnet sind, und erhalten so das Layout des Formulars, wenn seine Länge an die eingegebene Datenmenge angepasst wird. Durch Teilformulare werden die X- und Y-Koordinaten der einzelnen Objekte beibehalten. So wird gewährleistet, dass die Objekte als Gruppe verschoben und abgelegt werden.
Indem Sie Gruppen von Objekten in Teilformulare aufnehmen, stellen Sie sicher, dass unabhängig von der Datenmenge im Formular das Format der einzelnen Abschnitte und das Layout des gesamten Formulars einheitlich und vorhersagbar bleiben.
Beachten Sie, dass beim Öffnen des Formulars mindestens eine Elementzeile angezeigt werden muss, in die Daten eingegeben werden können. Das heißt, dass die Option „Min-Zähler“ für das Teilformular auf mindestens „1“ gesetzt werden muss. Je nach Formular kann es empfehlenswert sein, wenn beim ersten Öffnen zwei oder mehr Zeilen im PDF-Formular angezeigt werden. Dies gibt dem Formular ein ausgeglicheneres Erscheinungsbild und bietet dem Endbenutzer eine intuitivere und funktionellere Möglichkeit zum Eingeben der Daten.
Teilformulare stellen darüber hinaus die dynamischen Funktionen zur Verfügung, über die Benutzer Zeilen und Abschnitte im Formular hinzufügen oder löschen können. So können Sie beispielsweise verschiedene Schaltflächen einfügen, mit denen Benutzer Elementzeilen hinzufügen, entfernen oder Kommentare senden können.
Planen Sie, wie Sie die Objekte in Teilformulare aufnehmen möchten, um den Formularentwurf in Abschnitte zu unterteilen. Testen Sie anschließend den Formularentwurf, um sicherzustellen, dass die Teilformulare wie gewünscht verschoben und wiederholt werden und keine unerwünschten Seitenumbrüche erfolgen.
Verwandte Themen
Teilformulare – Übersicht
Teilformulare erstellen und konfigurieren
Schaltflächen zum Hinzufügen, entfernen eines Abschnitts erstellen


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen > Ränder für Teilformulare anpassen

Ränder für Teilformulare anpassen

Beim Anwenden dynamischer Funktionen auf ein interaktives Formular mit einem festen Layout ist in der Regel eine gewisse Neuformatierung notwendig. Mit Hilfe der Optionen in der Palette „Layout“ können Sie die Größe und Position sowie die Ränder und Beschriftungen von Objekten festlegen. So müssen Sie eventuell Ränder um Teilformularobjekte einfügen, um die Ausrichtung und den Randabstand (Leerraum) zwischen den Abschnitten im Formular anzupassen.
Verwandte Themen
Layout-Eigenschaften in der Palette „Layout“


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen > Überlaufkopfbereiche und Überlauffußbereiche in Teilformularen verwenden

Überlaufkopfbereiche und Überlauffußbereiche in Teilformularen verwenden

Da die Länge eines interaktiven Formulars, das für fließenden Inhalt definierte Teilformulare enthält, je nach der im Formular angezeigten Datenmenge unterschiedlich sein kann, besteht das Formular oft aus mehr als einer Seite. Daher müssen bestimmte Teilformulare (Abschnitte) des Formulars gegebenenfalls auf den nachfolgenden Seiten fortgeführt werden.
Durch die Verwendung von Überlaufkopfbereich- und Überlauffußbereich-Teilformularen können Sie verschiedene Teilformulare festlegen, die sich wiederholenden oder erweiterten Teilformularen vorausgehen bzw. diesen nachgestellt sind, wenn sich diese Teilformulare möglicherweise über mehrere Seiten erstrecken. Überlaufkopfbereiche und Überlauffußbereiche sind besondere Arten von Teilformularen, die in Formularentwürfen mit einem flexiblen Layout verwendet werden können. Wenn Sie ein Teilformular auf der Registerkarte „Paginierung“ der Palette „Objekt“ als Überlaufkopfbereich festlegen, wird das Teilformular oben auf jeder neuen Seite angezeigt.
Sie können zum Beispiel die Überschriftenzeile oben in einer Tabelle als Überlaufkopfbereich-Teilformular verwenden. Auf diese Weise wird die Überschriftenzeile oben auf jeder neuen Seite angezeigt, so dass die Informationen in den Tabellenzeilen problemlos über die Seiten hinweg zu lesen sind.
Sie können gegebenenfalls auf ähnliche Weise ein Überlauffußbereich-Teilformular zuweisen, das auf das letzte Vorkommen eines sich wiederholenden oder erweiterten Teilformulars auf einer Seite folgt, wenn dieses Formular sich möglicherweise über mehrere Seiten erstreckt.
Verwandte Themen
Teilformulare – Übersicht
Teilformulare erstellen und konfigurieren


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen > Anpassbare Teilformulare erstellen

Anpassbare Teilformulare erstellen

Je nach Verwendungszweck des Formularentwurfs können Sie dem Formular einen anpassbaren Abschnitt hinzufügen, in dem Informationen wie z. B. spezielle Wünsche oder Kommentare eingegeben werden können. In LiveCycle Designer haben Sie die Möglichkeit, Textfeldern und Teilformularen verschiedene Optionen zuzuweisen, mit deren Hilfe die Größe der Abschnitte im Formular an die eingegebene Datenmenge angepasst wird.
So verfügt ein interaktives Formular möglicherweise über einen Kommentarabschnitt, der durch Klicken auf eine Schaltfläche ein- oder ausgeblendet werden kann. Dieser Abschnitt wird mit einem Textfeld erstellt, das in einem Teilformular platziert wird. Dabei werden die folgenden Optionen ausgewählt, um eine dynamische Dateneingabe zu ermöglichen:
Textfeld: „Mehrere Zeilen zulassen“ und „Nur Text“ (Registerkarte „Feld“), „Benutzereingabe - Optional“ (Registerkarte „Wert“), „Höhe - Passend erweitern“ (Palette „Layout“)
Ermöglicht Benutzern, im Kommentar-Abschnitt eine unbegrenzte Menge Text einzugeben, da sich die Höhe des Textfeldes automatisch anpasst, so dass alle Daten angezeigt werden.
Teilformular: „Seitenumbrüche im Inhalt zulassen“ (Registerkarte „Teilformular“) und „Max.“ (Zähler) mit dem Wert „1“ (Registerkarte „Bindung“), „Autom. anpassen“ (Palette „Layout“)
Dies ermöglicht den Übergang des Kommentar-Teilformulars auf die nachfolgenden Seiten. Dabei tritt das Teilformular nur einmal im Formular auf. Das Teilformular wird so erweitert, dass alle verfügbaren Daten angezeigt werden können.
Verwandte Themen
Teilformulare – Übersicht
Teilformulare erstellen und konfigurieren
Schaltflächen zum Hinzufügen, entfernen eines Abschnitts erstellen


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen > Schaltflächen zum Hinzufügen, entfernen eines Abschnitts erstellen

Schaltflächen zum Hinzufügen, entfernen eines Abschnitts erstellen

Bei interaktiven Formularentwürfen ist es üblich, dass sich im Formular ein oder mehrere Abschnitte befinden, die erst angezeigt werden, wenn der Benutzer die Option zum Anzeigen dieser Abschnitte auswählt. LiveCycle Designer ermöglicht es Ihnen, eine Schaltfläche zusammen mit einem Skript hinzuzufügen, durch das ein bestimmter Abschnitt (Teilformular) dynamisch zum Formular hinzugefügt oder daraus entfernt wird, wenn der Benutzer auf die Schaltfläche klickt.
So können Benutzer im interaktiven Musterbestellformular beispielsweise auf die Schaltfläche „Kommentare hinzufügen“ klicken, um den Kommentarabschnitt (das Kommentar-Teilformular) aufzurufen. Die Schaltfläche verfügt über zwei verschiedene Beschriftungen, entweder zum Hinzufügen eines Kommentars oder zum Löschen eines Kommentars, die je nach aktuellem Status des Teilformulars wechseln. Bei jedem Klicken auf die Schaltfläche überprüft das Skript, ob das Kommentar-Teilformular angezeigt wird, und aktualisiert die Schaltflächenbeschriftung entsprechend.
Durch das Klicken auf die Schaltfläche wird ein Skript ausgelöst, das instanceManager verwendet (das Objekt des XML-Formularobjektmodells). Dieses Objekt verwaltet die Instanzerstellung, -entfernung und -verschiebung von Formularobjekten. Wenn der Endbenutzer das Kommentar-Teilformular löscht, entfernt das instanceManager-Objekt das Teilformular sowohl aus dem Formulardaten-DOM (Document Object Model) als auch aus dem Daten-DOM.
Beachten Sie, dass instanceManager vier Methoden verwendet: addInstance, removeInstance, moveInstance und setInstances. Die Namenskonvention von instanceManager lautet wie folgt: Teilformularname mit vorausgehendem Unterstrich (_subformname). Die Syntax für instanceManager lautet _subformname.methodname().
Im interaktiven Musterbestellformular wurde vom Verfasser das folgende JavaScript-Skript im Skript-Editor unter Verwendung der Methode setInstances eingegeben, damit das Kommentar-Teilformular hinzugefügt bzw. entfernt und die Beschriftung der Schaltfläche angepasst wird. Beachten Sie, dass _comments.count == 0 property die Anzahl der instanziierten Teilformularinstanzen zurückgibt.
// Invoke the Instance Manager to add and remove the comments subform.

if (_comments.count == 0) {// The count property specifies the current number
                                            // of instances instantiated.
    _comments.setInstances(1);												// Add the comments subform.
    this.resolveNode("caption.value.#text").value = "Clear Comments";																											// Change the button's caption.
}

else {
    _comments.setInstances(0);												// Remove the comments subform.
    this.resolveNode("caption.value.#text").value = "Add Comments";																											// Change the button's caption.
}


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen > Schaltflächen zum Hinzufügen und Löschen erstellen

Schaltflächen zum Hinzufügen und Löschen erstellen

Durch das Hinzufügen von Schaltflächen zu einem interaktiven Formular erhalten Endbenutzer die Möglichkeit, eine Aktion auszulösen, wie z. B. das Hinzufügen oder Entfernen von Teilformularen, durch die Abschnitte wie Elementzeilen in einem Bestellformular definiert werden.
Darüber hinaus können Sie eine QuickInfo zur Schaltfläche zum Löschen hinzufügen, die den Text „Element löschen“ anzeigt, wenn der Benutzer mit der Maus auf die Schaltfläche zeigt. Der Einsatz separater Schaltflächen zum Löschen ist nützlich, um den Benutzern das Löschen bestimmter Zeilen aus dem Formular zu ermöglichen.
So verfügt das interaktive Musterbestellformular beispielsweise für jedes Detail-Teilformular über eine Schaltfläche zum Hinzufügen eines Elements sowie über eine Schaltfläche zum Löschen, die durch ein „X“ markiert ist. Wenn der Benutzer auf die Schaltfläche zum Hinzufügen eines Elements klickt, wird vom Skript eine Elementzeile hinzugefügt. Wenn der Benutzer dagegen auf eine der Schaltflächen zum Löschen klickt, wird die entsprechende Elementzeile vom Skript gelöscht.
Schaltfläche „Element hinzufügen“
Mit dem folgenden JavaScript-Skript im click-Ereignis der Schaltfläche zum Hinzufügen eines Elements können Benutzer eine Elementzeile zum interaktiven Musterbestellformular hinzufügen. Durch das Skript wird das Formular ebenfalls neu berechnet, so dass das Feld mit der Gesamtsumme die neue Zeile enthält.
Da Benutzer Elementzeilen nur über die Schaltfläche „Element hinzufügen“ hinzufügen können, muss das Skript den minimalen Zählerwert (den Wert für das minimale Vorkommen) nicht überprüfen.
// Aufrufen des Instanzmanagers zum Hinzufügen einer Teilformularinstanz.
_detail.addInstance(1);

//Aufrufen der Neuberechnungsmethode zum Einschließen der Feldwerte des hinzugefügten Teilformulars in die Berechnungen..
xfa.form.recalculate(1);
Schaltfläche „Löschen“
Mit dem folgenden JavaScript-Skript im click-Ereignis der Schaltfläche zum Löschen können Benutzer die entsprechende Schaltfläche verwenden, um eine Instanz des Detail-Teilformulars des interaktiven Musterbestellformulars zu löschen. Durch das Skript wird das Formular außerdem neu berechnet, so dass das Feld für die Gesamtsumme die gelöschte Zeile nicht mehr enthält.
// Aufrufen des Instanzmanagers zum Entfernen der aktuellen Teilformularinstanz.
_detail.removeInstance(this.parent.index);

// Aufrufen der Neuberechnungsmethode zum Aktualisieren  der Formularberechnungen.
xfa.form.recalculate(1);
Da der anfängliche Mindestwert für das Vorkommen des Detail-Teilformulars 2 ist und somit automatisch zwei Elementzeilen angezeigt werden, muss dieser Mindestwert mit Hilfe des Skripts reduziert werden, damit zwei Elementzeilen gelöscht werden können. Dieses Skript wurde dem initialize-Ereignis des Detail-Teilformulars hinzugefügt.
// Zurücksetzen des Mindestwerts des Teilformulars.
this.occur.min = "0";
Da es für Benutzer möglich ist, alle Instanzen des Detail-Teilformulars zu löschen, wird durch das Skript für das calculate-Ereignis des Summenfeldes (numTotal) sichergestellt, dass sich mindestens eine Instanz des Feldes numAmount im Detail-Teilformular befindet. Wenn bei der Berechnung keine Instanzen des Feldes numAmount gefunden werden, tritt ein Fehler auf. Dieses Skript wurde dem Calculate-Ereignis des numTotal-Feldes hinzugefügt.
// Prüfen, ob mindestens eine Instanz des numAmount-Felds vorhanden ist.
if (exists(detail[0].numAmount) == 1) then
    Sum(detail[*].numAmount)
endif


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen > So können Sie Teilformularinstanzen mit Hilfe von Skripten hinzufügen, entfernen

So können Sie Teilformularinstanzen mit Hilfe von Skripten hinzufügen, entfernen

Sie können Teilformularinstanzen hinzufügen oder entfernen, indem Sie Objekten in Ihrem Formular mit Hilfe des Skript-Editors Berechnungen oder Skripte hinzufügen.
Bevor Sie damit beginnen, müssen Sie zunächst die folgenden Schritte ausführen:
      •
      Falls er nicht bereits angezeigt wird, öffnen Sie den Skript-Editor, indem Sie „Fenster“ > „Skript-Editor“ auswählen. Erweitern Sie den Skript-Editor, so dass die mehrzeilige Ansicht angezeigt wird.
      •
      Stellen Sie sicher, dass sich das Teilformular, dem Instanzen hinzugefügt werden sollen, in einem fließenden Teilformular befindet.
      •
      Legen Sie gegebenenfalls Werte für das Vorkommen des maximalen und minimalen Zählers sowie der Anfangszahl fest, indem Sie die Registerkarte „Bindung“ für das Teilformular oder folgende Skripten verwenden. Dabei steht integer für den maximalen Vorkommenswert und Subform1 für den Namen des Teilformularobjekts:
FormCalc
// Include the quotation marks (" ") surrounding the integer values
Subform1.occur.max = "integer"
Subform1.occur.min = "integer"
Subform1.occur.initial = "integer"
JavaScript
// Include the quotation marks (" ") surrounding the integer values
Subform1.occur.max = "integer";
Subform1.occur.min = "integer";
Subform1.occur.initial = "integer";
So fügen Sie einem Formular mit Hilfe von Skripten eine Teilformularinstanz hinzu
1.
Wählen Sie im Formularentwurf das Objekt aus, dem das Skript hinzugefügt werden soll, und wählen Sie in der Liste „Einblenden“ im Skript-Editor ein Ereignis aus. Wählen Sie beispielsweise das click-Ereignis einer Schaltfläche oder eines anderen interaktiven Formularobjekts.
2.
Geben Sie eines der folgenden Skripten in den Skript-Editor ein, wobei Subform1 für den Namen des Teilformulars steht, dem Instanzen hinzugefügt werden sollen, und der Wert true angibt, dass die neue Teilformularinstanz mit den Formulardaten zusammengeführt werden muss:
FormCalc
Subform1.instanceManager.addInstance(true) // Standardsyntax des Instanzmanagers
xfa.form.recalculate(true) // Aufrufen der Neuberechnungsmethode zum Einschließen der Feldwerte des hinzugefügten Teilformulars in die Berechnungen.
oder
_Subform1.addInstance(true) // Kurzform der Syntax des Instanzmanagers
xfa.form.recalculate(true) // Aufrufen der Neuberechnungsmethode zum Einschließen der Feldwerte des hinzugefügten Teilformulars in die Berechnungen.
JavaScript
Subform1.instanceManager.addInstance(true); // Standardsyntax des Instanzmanagers
xfa.form.recalculate(true) // Aufrufen der Neuberechnungsmethode zum Einschließen der Feldwerte des hinzugefügten Teilformulars in die Berechnungen.
oder
_Subform1.addInstance(true); // Kurzform der Syntax des Instanzmanagers
xfa.form.recalculate(true) // Aufrufen der Neuberechnungsmethode zum Einschließen der Feldwerte des hinzugefügten Teilformulars in die Berechnungen.
So entfernen Sie eine Teilformularinstanz aus einem Formular
1.
Wählen Sie im Formularentwurf das Objekt aus, dem das Skript hinzugefügt werden soll, und wählen Sie in der Liste „Einblenden“ im Skript-Editor ein Ereignis aus.
2.
Geben Sie eines der folgenden Skripten in den Skript-Editor ein, wobei Subform1 für den Namen des Teilformulars steht, aus dem eine Instanz entfernt werden soll, und integer die nullbasierte Indexzahl für die Instanz ist, die entfernt werden soll:
FormCalc
Subform1.instanceManager.removeInstance(integer) // Standardsyntax des Instanzmanagers
oder
_Subform1.removeInstance(integer) // Kurzform der Syntax des Instanzmanagers
JavaScript
Subform1.instanceManager.removeInstance(integer); // Standardsyntax des Instanzmanagers
oder
_Subform1.removeInstance(integer); // Kurzform der Syntax des Instanzmanagers
Verwandte Themen
Der Skript-Editor
Eigenschaften von Teilformularen: Registerkarte „Bindung“
addInstance
removeInstance
So können Sie Tabellen und Tabellenzeilen mit Hilfe von Skripten hinzufügen, entfernen


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen > So können Sie Tabellen und Tabellenzeilen mit Hilfe von Skripten hinzufügen, entfernen

So können Sie Tabellen und Tabellenzeilen mit Hilfe von Skripten hinzufügen, entfernen

Tabellen, Textzeilen, Kopf- und Fußzeilen können hinzugefügt oder entfernt werden, wenn Sie Objekten in Ihrem Formular mit Hilfe des Skript-Editors Instanzmanager-Skriptausdrücke hinzufügen.
Bevor Sie damit beginnen, müssen Sie zunächst die folgenden Schritte ausführen:
      •
      Falls er nicht bereits angezeigt wird, öffnen Sie den Skript-Editor, indem Sie „Fenster“ > „Skript-Editor“ auswählen. Erweitern Sie den Skript-Editor, so dass die mehrzeilige Ansicht angezeigt wird.
      •
      Stellen Sie sicher, dass sich die Tabelle, der Instanzen hinzugefügt werden sollen, in einem fließenden Teilformular befindet. Dadurch können neue Instanzen der Tabelle oder der Zeilen in die Tabelle eingefügt werden.
      •
      Legen Sie gegebenenfalls Werte für das Vorkommen des maximalen und minimalen Zählers sowie der Anfangszahl fest, indem Sie die Registerkarte „Bindung“ für die Tabelle oder die Tabellenzeilen oder folgende Skripten verwenden. Dabei steht integer für den maximalen Vorkommenswert und Table1 und Row1 stellen die Namen der Tabellen- und Tabellenzeilenobjekte dar:
FormCalc
// Include the quotation marks (" ") surrounding the integer values
Table1.occur.max = "integer"
Table1.occur.min = "integer"
Table1.occur.initial = "integer"
Table1.Row1.occur.max = "integer"
Table1.Row1.occur.min = "integer"
Table1.Row1.occur.initial = "integer"
JavaScript
// Include the quotation marks (" ") surrounding the integer values
Table1.occur.max = "integer";
Table1.occur.min = "integer";
Table1.occur.initial = "integer";
Table1.Row1.occur.max = "integer";
Table1.Row1.occur.min = "integer";
Table1.Row1.occur.initial = "integer";
So fügen Sie einem Formular eine Tabellen- oder Tabellenzeileninstanz hinzu
1.
Wählen Sie im Formularentwurf das Objekt aus, dem das Skript hinzugefügt werden soll, und wählen Sie in der Liste „Einblenden“ im Skript-Editor ein Ereignis aus.
2.
Geben Sie eines der folgenden Skripten in den Skript-Editor ein, wobei Table1 und Row1 jeweils für den Namen der Tabelle bzw. der Tabellenzeile steht, der Instanzen hinzugefügt werden sollen:
FormCalc
Table1.instanceManager.addInstance(true) // Standardsyntax des Instanzmanagers
Table1.Row1.instanceManager.addInstance(true) // Standardsyntax des Instanzmanagers
xfa.form.recalculate(true) // Aufrufen der Neuberechnungsmethode zum Einschließen der Feldwerte des hinzugefügten Teilformulars in die Berechnungen.
oder
Table1.addInstance(true) // Kurzform der Syntax des Instanzmanagers
Table1._Row1.addInstance(true) // Kurzform der Syntax des Instanzmanagers
xfa.form.recalculate(true) // Aufrufen der Neuberechnungsmethode zum Einschließen der Feldwerte des hinzugefügten Teilformulars in die Berechnungen.
JavaScript
Table1.instanceManager.addInstance(true); // Standardsyntax des Instanzmanagers
Table1.Row1.instanceManager.addInstance(true); // Standardsyntax des Instanzmanagers
xfa.form.recalculate(true); // Aufrufen der Neuberechnungsmethode zum Einschließen der Feldwerte des hinzugefügten Teilformulars in die Berechnungen.
oder
Table1.addInstance(true); // Kurzform der Syntax des Instanzmanagers
Table1._Row1.addInstance(true); // Kurzform der Syntax des Instanzmanagers
xfa.form.recalculate(true); // Aufrufen der Neuberechnungsmethode zum Einschließen der Feldwerte des hinzugefügten Teilformulars in die Berechnungen.
So entfernen Sie eine Tabellen- oder Tabellenzeileninstanz aus einem Formular
1.
Wählen Sie im Formularentwurf das Objekt aus, dem das Skript hinzugefügt werden soll, und wählen Sie in der Liste „Einblenden“ im Skript-Editor ein Ereignis aus.
2.
Geben Sie eines der folgenden Skripten in den Skript-Editor ein, wobei Table1 und Row1 jeweils für den Namen der Tabelle bzw. der Tabellenzeile steht, aus der Instanzen entfernt werden sollen, und integer die nullbasierte Indexzahl für die Instanz ist, die entfernt werden soll:
FormCalc
Table1.instanceManager.removeInstance(true) // Standardsyntax des Instanzmanagers
Table1.Row1.instanceManager.removeInstance(true) // Standardsyntax des Instanzmanagers
oder
Table1.removeInstance(true) // Kurzform der Syntax des Instanzmanagers
Table1._Row1.removeInstance(true) // Kurzform der Syntax des Instanzmanagers
JavaScript
Table1.instanceManager.removeInstance(true); // Standardsyntax des Instanzmanagers
Table1.Row1.instanceManager.removeInstance(true); // Standardsyntax des Instanzmanagers
oder
Table1.removeInstance(true); // Kurzform der Syntax des Instanzmanagers
Table1._Row1.removeInstance(true); // Kurzform der Syntax des Instanzmanagers
Verwandte Themen
Der Skript-Editor
Eigenschaften von Tabellen: Registerkarte „Bindung“
Eigenschaften von Textzeilen: Registerkarte „Bindung“
Eigenschaften von Kopfzeilen: Registerkarte „Bindung“
addInstance
removeInstance
So können Sie Teilformularinstanzen mit Hilfe von Skripten hinzufügen, entfernen


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Nicht interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen

Nicht interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen

Info über nicht interaktive Formulare mit Layoutanpassungen an die Datenmenge
Funktionsweise von nicht interaktiven Formularen mit Layoutanpassungen an die Datenmenge


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Nicht interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen > Info über nicht interaktive Formulare mit Layoutanpassungen an die Datenmenge

Info über nicht interaktive Formulare mit Layoutanpassungen an die Datenmenge

Nicht interaktive Formulare, die für fließenden Inhalt definierte Teilformulare enthalten, sind hilfreich, wenn Sie den Anwendern eine unbestimmte Menge an Daten präsentieren oder unterschiedliche Mengen an Informationen von Benutzern erfassen möchten. Da das Layout dieses Formulartyps automatisch an die Menge der zusammengeführten Daten angepasst wird, müssen Sie anders als bei Formularen mit einem festen Layout vorher kein festes Layout und keine feste Anzahl von Seiten festlegen.
Mit LiveCycle Designer können Sie Formulare mit Abschnitten erstellen, deren Größe an die Datenmenge zur Verwendung mit LiveCycle Forms angepasst wird. In diesem Fall wird der Formularentwurf über LiveCycle Forms mit Daten zusammengeführt. Normalerweise sind diese Formulare nicht interaktiv und sollen Benutzern Informationen aus einer Datenquelle anzeigen. Benutzer drucken das Formular aus oder speichern es elektronisch. Siehe Formulare für LiveCycle Forms entwerfen.
Verwandte Themen
Funktionsweise von nicht interaktiven Formularen mit Layoutanpassungen an die Datenmenge
Info über Teilformulare


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Nicht interaktive Formulare mit Layoutanpassungen an die Datenmenge erstellen > Funktionsweise von nicht interaktiven Formularen mit Layoutanpassungen an die Datenmenge

Funktionsweise von nicht interaktiven Formularen mit Layoutanpassungen an die Datenmenge

In einem Formularentwurf mit festem Layout wird normalerweise nur ein Teilformular (das Standard-Teilformular auf der Seite) verwendet. Dieses Teilformular wird in LiveCycle Designer standardmäßig fest verankert, d. h., der Inhalt wird fest positioniert. Wenn LiveCycle Designer Inhalt in einem Teilformular positioniert, verschiebt sich keines der verankerten Objekte im Teilformular, unabhängig von den Merkmalen und der Menge der Daten.
Wenn Sie allerdings möchten, dass die Größe bestimmter Abschnitte im Formular an die Datenmenge angepasst wird, müssen Sie im Allgemeinen mehrere Teilformulare verwenden: Das Standard-Teilformular auf der Seite, die für fließenden Inhalt definiert ist, sowie zusätzliche Teilformulare, für die Sie die Wiederholung der einzelnen Datenelemente, die passende Erweiterung oder beides festlegen. Wenn Sie ein Teilformular auf fließenden Inhalt zurücksetzen, verschieben sich die Objekte im Teilformular einschließlich der anderen Teilformulare so, dass die zusammengeführten Daten in den wiederholten und erweiterten Teilformularen dargestellt werden können.
In LiveCycle Designer können Sie die Objekte im Formular an Datenelemente in einer Datendatei binden und die Textfeld- und Teilformularobjekte im Formular so konfigurieren, dass sie entsprechend den Merkmalen und der Menge der mit dem Objekt zusammengeführten Daten angezeigt, wiederholt oder erweitert werden. Da die Objekte im Formular an die Quelldaten gebunden sind, wird das Layout des Formulars von diesen Daten bestimmt.
Beim Verfassen eines Formularentwurfs mit Abschnitten, deren Größe an die Datenmenge angepasst wird, müssen Sie wissen, welche Teilformulare nur einmal im Formular auftreten (wie z. B. der Adressblock) und welche Teilformulare entsprechend der Datenmenge wiederholt werden (wie z. B. die Elementzeile). Bei den sich wiederholenden Teilformularen wird nur eine Instanz des Teilformulars und seiner Komponenten in den Formularentwurf eingefügt. Das heißt, dass der Entwurf des Formulars nicht unbedingt dem entspricht, was die Benutzer später bei der Wiedergabe sehen.
Unten sehen Sie beispielsweise zwei Abbildungen einer nicht interaktiven Musterbestellung mit dem Formularentwurf vor und nach der Zusammenführung mit den Daten. Beachten Sie, wie die Elementzeile (Detail-Teilformular) viermal wiederholt wird entsprechend der Liste der Teile (der verfügbaren Daten).
Formular mit flexiblem Layout ohne zusammengeführte Daten
Formular mit flexiblem Layout mit zusammengeführten Daten
Verwandte Themen
Info über Teilformulare
Allgemeine Überlegungen zum Erstellen von Formularentwürfen mit anpassbarem Layout


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Objekte in einem Formular mit Layoutanpassungen an die Datenmenge platzieren

Objekte in einem Formular mit Layoutanpassungen an die Datenmenge platzieren

Info über Teilformulare und Inhaltsbereiche
In Formularen mit Layoutanpassungen an die Datenmenge mit Inhaltsbereichen arbeiten
Teilformulare in einem Formularentwurf mit Layoutanpassungen an die zusammengeführte Datenmenge verwenden


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Objekte in einem Formular mit Layoutanpassungen an die Datenmenge platzieren > Info über Teilformulare und Inhaltsbereiche

Info über Teilformulare und Inhaltsbereiche

Es gibt zwei Möglichkeiten zum Steuern, wie LiveCycle Designer Objekte in Formularen, Inhaltsbereichen und Teilformularen platziert:
      •
      Durch Inhaltsbereiche auf den Masterseiten werden die Bereiche und die Fließrichtung gesteuert, in der LiveCycle Designer Objekte auf den Seiten platziert.

      Jede Masterseite hat einen Standard-Inhaltsbereich. Dabei handelt es sich um einen Container, der steuert, wo LiveCycle Designer Objekte wie Teilformulare auf den Seiten platziert.
      •
      Mit Teilformularen wird gesteuert, wie LiveCycle Designer Objekte im Formular platziert. Durch das Aufnehmen von Objekten in Teilformulare können Sie über die verschiedenen Optionen auf den Registerkarten „Teilformular“ und „Bindung“ der Palette „Objekt“ steuern, wie oft ein Objekt wiedergegeben und wo es auf der Seite platziert wird.

      In einem Formular mit anpassparen Abschnitten enthalten Teilformulare die Objekte der einzelnen Abschnitte des Formulars. Sie erhalten zudem das Layout des Formulars, wenn sich seine Länge entsprechend der Menge der zusammengeführten Daten ändert. Teilformulare sorgen dafür, dass Objekte als eine Einheit verschoben und konsistent zueinander platziert werden. Wenn Sie Objekte in Teilformulare aufnehmen, können Sie sicher sein, dass das Format der einzelnen Abschnitte sowie das Layout des Formulars unabhängig von der Menge der mit dem Formular zusammengeführten Daten konsistent und vorhersagbar bleibt. Daher kommt dem Verwendungszweck der Teilformulare beim Entwerfen dieses Formulartyps große Bedeutung zu.


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Objekte in einem Formular mit Layoutanpassungen an die Datenmenge platzieren > In Formularen mit Layoutanpassungen an die Datenmenge mit Inhaltsbereichen arbeiten

In Formularen mit Layoutanpassungen an die Datenmenge mit Inhaltsbereichen arbeiten

Mit Inhaltsbereichen auf den Masterseiten können Sie die Bereiche und die Fließrichtung steuern, in der LiveCycle Designer die Objekte auf den Seiten platziert. Denken Sie daran, dass Sie auf den Seiten nicht mit Inhaltsbereichen arbeiten können.
Jede Masterseite hat einen Standard-Inhaltsbereich, der auf den verknüpften Seiten angezeigt wird und den Bereich skizziert, in dem Sie Objekte auf den Seiten platzieren können, vergleichbar mit den Rändern in einem Textdokument. Sie können keine Objekte auf den Seiten außerhalb des durch den Inhaltsbereich bestimmten Bereichs platzieren.
Ein Formular muss mindestens einen Inhaltsbereich aufweisen.
Der Inhaltsbereich stellt jedoch keine Begrenzung für den Bereich dar, in dem Sie Objekte auf den Masterseiten platzieren können. Textbausteinobjekte können Sie an beliebigen Stellen auf den Masterseiten platzieren, innerhalb oder außerhalb des Inhaltsbereichs. Wenn Sie Objekte, die Kopf- und Fußzeilentext, Datum und Uhrzeit oder Seitennummern enthalten sollen, außerhalb des Inhaltsbereichs platzieren, müssen Sie das Formular testen, um sicherzustellen, dass die Objekte wie erwartet dargestellt werden. Vergewissern Sie sich, dass sich die Objekte auf den Seiten bei der Wiedergabe des Formulars nicht überlagern und die Objekte auf den Masterseiten verdecken.
Beachten Sie bei Formularen mit Abschnitten, deren Größe an die Datenmenge angepasst wird, dass das Layout des Formulars letztlich von den Daten bestimmt wird. Wenn das Formular von LiveCycle Forms wiedergegeben wird, werden so viele Textseiten hinzugefügt, bis alle verfügbaren Daten zusammengeführt wurden. Wenn von LiveCycle Forms neue Seiten hinzugefügt werden, fließen die Daten innerhalb des Inhaltsbereichs auf den Masterseiten von Seite zu Seite.
Wenn jede Seite des Formulars dasselbe Layout aufweisen soll, werden Sie möglicherweise feststellen, dass hierzu lediglich der Standard-Inhaltsbereich erforderlich ist. Ist das Layout jedoch komplexer, können Sie der Standard-Masterseite auch zusätzliche Inhaltsbereiche hinzufügen. Denken Sie daran, dass Sie bei einer anderen Fließrichtung, einer anderen Seitenausrichtung oder einer doppelseitigen Darstellung zusätzliche Masterseiten einfügen und die anderen Masterseiten und Inhaltsbereiche Ihrem Entwurf entsprechend konfigurieren können.
Verwandte Themen
Inhaltsbereiche – Übersicht


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Objekte in einem Formular mit Layoutanpassungen an die Datenmenge platzieren > Teilformulare in einem Formularentwurf mit Layoutanpassungen an die zusammengeführte Datenmenge verwenden

Teilformulare in einem Formularentwurf mit Layoutanpassungen an die zusammengeführte Datenmenge verwenden

Das Hinzufügen von Abschnitten, deren Größe an die Datenmenge angepasst wird, erfolgt durch Erstellen von Teilformularen und Verschachteln dieser Teilformulare in eine Hierarchie, die in etwa der Struktur der Daten entspricht. Sie können Teilformulare in beliebiger Tiefe verschachteln. Durch die Verschachtelung können Sie den Formularentwurf so gestalten, dass er der XML-Datendatei entspricht, mit der er zusammengeführt werden soll. Wenn die XML-Datendatei beispielsweise zwei Ebenen enthält, können Sie die Teilformularhierarchie so erstellen, dass die Namen der Teilformulare den Tag-Namen in der XML-Datendatei entsprechen. Dann kann LiveCycle Designer die Daten zuordnen, ohne die Datendatei umwandeln zu müssen.
Ein Formular mit einem flexiblen Layout, wie die Musterbestellung, umfasst normalerweise mehrere verschachtelte Teilformulare, wobei in jedem Teilformular ein oder mehrere Objekte enthalten sind. Sie können beispielsweise sehen, wie die verschiedenen Objekte im Musterbestellformular in die Teilformulare „header“, „detailHeader“, „detail“ und „total“ aufgenommen wurden. Beachten Sie, wie Sie Text ausrichten und Textfeldobjekte in Zeilen und Spalten anordnen und in ein Teilformular aufnehmen können. Durch die Verwendung von Teilformularen zum Aufnehmen von Objekten wie den verschiedenen Textfeldobjekten in das Detail-Teilformular können Sie nicht nur das Layout der Objekte erhalten, sondern auch steuern, wie oft das Teilformular wiederholt wird.
Sie können jedes Teilformular so konfigurieren, dass bei der Wiedergabe des Formulars nur die Teilformulare platziert werden, die zum Darstellen der Dateninhalte erforderlich sind. So können Sie beispielsweise verschiedene Bestellungen für die einzelnen Kunden erstellen, wobei in einem Bestellformular das Detail-Teilformular zwölf Mal platziert wird, um die gekauften Artikel anzugeben, während in einem anderen Bestellformular dasselbe Teilformular fünfzig Mal über mehrere Seiten hinweg platziert wird.
Das Musterbestellformular mit Layoutanpassungen an die Datenmenge verdeutlicht, wie Sie diese Konfiguration mit Hilfe von Teilformularen erzielen können. Öffnen Sie das Formular in LiveCycle Designer und sehen Sie sich die Palette „Hierarchie“ an, um die Struktur des Teilformulars zu untersuchen. Außerdem sehen Sie in der Palette „Objekt“, wie die Teilformulare konfiguriert sind. Beachten Sie insbesondere die Teilformulare „purchaseOrder“, „detailHeader“ und „detail“ und ihre Konfiguration. Denken Sie daran, dass das übergeordnete Teilformular (puchaseOrder) den Inhaltsfluss im Formular steuert und die Größe des Formulars an die verfügbaren Daten anpasst. Das Teilformular „detailHeader“ ist mit dem minimalen Zählerwert 1 konfiguriert. Dies bedeutet, dass das Teilformular einmal von LiveCycle Forms platziert wird. Das Teilformular „detail“ ist so konfiguriert, dass es mit jedem Datenelement wiederholt wird.
Sie können mit einem Teilformular auch einen Rand um eine Gruppe von Teilformularen ziehen. Sie können beispielsweise ein oder mehrere dynamische Teilformulare erstellen, diese mit einem Teilformular umschließen und anschließend eine Umrandung für das Hüllen-Teilformular festlegen. Beim Wiedergeben des Formulars wird eine Begrenzung um alle internen Teilformulare gezogen.
Verwandte Themen
Teilformulare – Übersicht
Info über Teilformulare


Formularentwürfe mit Layoutanpassungen an die Datenmenge erstellen

Info über das Erstellen von Formularentwürfen mit Layoutanpassungen an die Datenmenge
So erstellen Sie Formularentwürfe in einem positionierten Kontext
So erstellen Sie einen Formularentwurf in einem fließenden Kontext
Allgemeine Überlegungen zum Erstellen von Formularentwürfen mit anpassbarem Layout


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Formularentwürfe mit Layoutanpassungen an die Datenmenge erstellen > Info über das Erstellen von Formularentwürfen mit Layoutanpassungen an die Datenmenge

Info über das Erstellen von Formularentwürfen mit Layoutanpassungen an die Datenmenge

Es gibt zwei grundlegende Ansätze zum Erstellen eines Formularentwurfs mit Teilformularen, deren Größe an die Datenmenge angepasst wird:
      •
      Formularentwurf in einem positionierten Kontext erstellen
      •
      Formularentwurf in einem fließenden Kontext erstellen
Beide Verfahren liefern die gleichen Ergebnisse. Sie werden jedoch feststellen, dass ein Verfahren besser zu Ihrem Entwurfsstil passt als das andere. Wenn Sie mit dem Erstellen von Formularentwürfen mit flexiblen Layouts vertraut sind, werden Sie sich den Stil angewöhnen, der am besten zu Ihrer Arbeitsweise passt.
Unabhängig vom gewählten Ansatz sollten Sie zuerst einen Formularentwurf mit einem festen Layout erstellen. Sie können das Layout des Formulars planen, einschließlich aller erforderlichen Objekte und Informationen, die den Benutzern angezeigt werden sollen. Nachdem Sie den Formularentwurf entsprechend Ihren Anforderungen erstellt haben, können Sie planen, wie die verschiedenen Objektgruppen in die Teilformulare aufgenommen werden sollen. Sie können die einzelnen Teilformulare dann so konfigurieren, dass ein flexibles Formularlayout entsteht. Sie sollten beispielsweise darüber nachdenken, welche Teilformulare mit positioniertem oder fließendem Inhalt konfiguriert werden sollen, welche Fließrichtung für die einzelnen Teilformulare am besten geeignet ist, welche Teilformulare einen Überlaufkopfbereich bzw. einen Überlauffußbereich benötigen und welche Teilformulare wiederholt werden, welche den Inhalt passend erweitern und welche den Inhalt umbrechen.


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Formularentwürfe mit Layoutanpassungen an die Datenmenge erstellen > So erstellen Sie Formularentwürfe in einem positionierten Kontext

So erstellen Sie Formularentwürfe in einem positionierten Kontext

Bei einem positionierten Kontext bauen Sie den Formularentwurf mit so vielen Masterseiten und Seiten wie nötig auf. Sobald das Objektlayout und die Formatierung abgeschlossen sind, werden den entsprechenden Teilformularen des Formularentwurfs die dynamischen Eigenschaften zugeordnet.
Wenn Sie mit dem Erstellen von Formularen mit festem Layout vertraut sind, ist das Erstellen eines Formularentwurfs in einem positionierten Kontext für Sie wahrscheinlich die einfachste Vorgehensweise. Darüber hinaus stellt dieser Ansatz die einfachste und übersichtlichste Möglichkeit dar, ein vorhandenes Formular mit festem Layout in einen Formularentwurf mit flexiblem Layout zu konvertieren.
Die folgenden Schritte beschreiben die allgemeine Vorgehensweise zum Erstellen eines Formularentwurfs in einem positionierten Kontext unter der Annahme, dass die Planungsphase abgeschlossen ist.
1.
Erstellen Sie die erforderlichen Masterseiten.
2.
Erstellen Sie auf der Seite den Formularinhalt. Wenn Sie ein Formular mit einem festen Layout konvertieren, beginnen Sie einfach damit, die Objekte im Formular in Teilformulare aufzunehmen. Wenn Sie mit einem leeren Formular beginnen, gehen Sie wie folgt vor:
      •
      Fügen Sie dem Formular Objekte hinzu und schließen Sie sie in die entsprechenden Teilformulare ein.
      •
      Wenden Sie die erforderlichen Formatierungselemente auf die Objekte an.
      •
      Schließen Sie das Layout der Objekte in ihren Teilformularen sowie der Teilformulare auf der Seite ab.
      •
      Fügen Sie nach Bedarf Skripten hinzu.
3.
Implementieren Sie die dynamischen Konzepte:
      •
      Heben Sie die Aufnahme der Standard-Teilformulare auf den einzelnen Seiten auf. Die Teilformulare werden zu untergeordneten Elementen des Stammteilformulars, das einen fließenden Inhalt hat. Von hier ab erfolgt Ihr Entwurf in einem fließenden Kontext. Sie werden feststellen, dass die Teilformulare untereinander positioniert sind, da die Fließrichtung von oben nach unten verläuft.
      •
      Wenden Sie die gewünschten Formatierungselemente auf die Teilformulare an, beispielsweise den Bindungstyp und die Begrenzungen.
      •
      Definieren Sie den Fluss. Hierzu gehört das Festlegen der Werte für das Vorkommen, das Zulassen von Seitenumbrüchen, das Definieren von Überlaufkopfbereichen und Überlauffußbereichen, das Definieren, welche Teilformulare zusammen gehören, sowie das Zuordnen von Teilformularen zu den Masterseiten und das Festlegen von Rändern.
4.
Testen Sie das Formular mit Hilfe von Musterdaten.
In den im Lieferumfang von LiveCycle Designer enthaltenen Musterformularen wird dieses Verfahren verwendet. Zur besseren Verwendung werden die Teilformulare mit dem tatsächlichen Inhalt in ein Teilformular aufgenommen, dessen Standardbindung auf „Ohne“ eingestellt ist. Wenn Sie die Teilformulare auf diese Weise konfigurieren, erhalten Sie schnell einen Einblick in die Gesamtstruktur eines Formulars, sobald es zum ersten Mal in der Hierarchieansicht angezeigt wird.
Überlegungen zum Erstellen eines Formularentwurfs mit anpassbarem Layout in einem positionierten Kontext
Wenn Sie Formulare mit flexiblem Layout in einem positionierten Kontext erstellen, sollten Sie Folgendes bedenken:
      •
      Stellen Sie den Inhalt des Formulars nur auf „Textfluss“ ein, wenn Sie mit dem Layout zufrieden sind. Wenn der Inhalt des Formulars auf „Textfluss“ eingestellt ist, kann er auch wieder auf ein positioniertes Layout zurückgesetzt werden, es können dabei jedoch Probleme mit dem Formularlayout auftreten. Wenn Sie beispielsweise die Teilformulare in einen einzigen positionierten Container aufnehmen möchten, werden die Teilformulare genau an der Stelle positioniert, an der sie in den entsprechenden Seiten waren; sie können sich dadurch überlagern. Sie können dieses Problem vermeiden, indem Sie die Teilformulare mit Hilfe der Seitengruppierung wie oben beschrieben umschließen.
      •
      Die Standardeinstellung für den minimalen und maximalen Zählerwert des Teilformulars ist standardmäßig auf 1 gesetzt; für ein dynamisches Verhalten müssen diese Werte angepasst werden.
      •
      Durch das Aufnehmen von Objekten in ein Teilformular wird der gesamte über die Objekte hinausgehende Platz gelöscht. Sie können linke und rechte Ränder hinzufügen, um das Teilformular horizontal neu auszurichten. Sie können auch die Größe des Teilformulars ändern. Dadurch werden jedoch die Objekte neu positioniert, da sie relativ zu dem übergeordneten Element positioniert sind.


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Formularentwürfe mit Layoutanpassungen an die Datenmenge erstellen > So erstellen Sie einen Formularentwurf in einem fließenden Kontext

So erstellen Sie einen Formularentwurf in einem fließenden Kontext

Mit einem fließenden Kontext bauen Sie den Formularentwurf mit so vielen Masterseiten und Teilformularen wie nötig auf. Das Konzept der Seiten wird dabei nicht berücksichtigt. Das Erstellen der Seiten erfolgt während der Verarbeitung, wenn der Formularentwurf mit den Daten zusammengeführt wird und die Menge der Daten über die aktuelle Seite hinaus fließt. Die dynamischen Eigenschaften werden angewendet, sobald das Layout und die Formatierung abgeschlossen sind.
Das Erstellen eines Formulars in einem fließenden Kontext ist häufig der beste Ansatz zum Aufbau eines Formulars, wenn Sie mit einem XML-Schema beginnen. Darüber hinaus können erfahrene Anwender diese Methode auch verwenden, weil sie beim Entwerfen des Formulars ein besseres Gefühl für das dynamische Verhalten bietet. Es dauert jedoch eine gewisse Zeit, bis man mit dem Erstellen eines Formulars in einem fließenden Kontext vertraut ist. Dies liegt vor allem an dem unerwarteten Verhalten beim Entwerfen in einem fließenden Container.
Die folgenden Schritte beschreiben die allgemeine Vorgehensweise zum Erstellen eines Formulars in einem fließenden Kontext unter der Annahme, dass die Planungsphase abgeschlossen ist.
1.
Erstellen Sie die erforderlichen Masterseiten.
2.
Erstellen Sie den Inhalt des Formulars auf die folgende Weise.
      •
      Erstellen Sie Teilformulare und ihre Inhalte. Das Standard-Teilformular der Seite wird zum ersten Teilformular im Formular. Sie sollten die Größe dieses Teilformulars entsprechend seinem Inhalt anpassen.
      •
      Zusätzliche Seiten sind nicht erforderlich. Fahren Sie mit dem Erstellen aller weiteren erforderlichen Teilformulare fort, um den Formularentwurf abzuschließen. Beim Entwerfen des Formulars werden zusätzliche Seiten angelegt, wenn das erstellte Teilformular nicht auf die aktuelle Seite passt. Dies ist nicht immer offensichtlich, da der Vorgang automatisch abläuft und die Palette „Hierarchie“ diese zusätzlichen Seiten nicht anzeigt.
      •
      Wenden Sie die erforderlichen Formatierungselemente auf die Objekte an.
      •
      Schließen Sie das Layout der Objekte in ihren Teilformularen sowie die Anordnung der Teilformulare ab.
      •
      Fügen Sie nach Bedarf Skripten hinzu.
3.
Implementieren Sie die dynamischen Konzepte.
      •
      Wenden Sie die gewünschten Formatierungselemente auf die Teilformulare an, beispielsweise den Bindungstyp und die Begrenzungen.
      •
      Definieren Sie den Fluss. Hierzu gehört das Festlegen der Werte für das Vorkommen, das Zulassen von Seitenumbrüchen, das Definieren von Überlaufkopfbereichen und Überlauffußbereichen, das Definieren, welche Teilformulare zusammen gehören, sowie das Zuordnen von Teilformularen zu den Masterseiten und das Festlegen von Rändern.
4.
Testen Sie das Formular mit Hilfe von Musterdaten.


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Mit Formularen mit Layoutanpassungen an die Datenmenge arbeiten > Formularentwürfe mit Layoutanpassungen an die Datenmenge erstellen > Allgemeine Überlegungen zum Erstellen von Formularentwürfen mit anpassbarem Layout

Allgemeine Überlegungen zum Erstellen von Formularentwürfen mit anpassbarem Layout

Unabhängig davon, ob Sie einen Formularentwurf in einem fließenden oder in einem positionierten Kontext erstellen, sollten Sie einige allgemeine Punkte berücksichtigen:
      •
      Das Festlegen der Ränder eines Teilformulars kann unerwartete Ergebnisse zur Folge haben. Da die meisten einzelnen Teilformulare einen positionierten Inhalt und damit eine feste Höhe haben, wird durch das Hinzufügen von Rändern der Inhalt des Teilformulars entsprechend versetzt, so dass die Objekte sich unter Umständen überlagern.
      •
      Zum exakten Aufnehmen des Inhalts eines Teilformulars ohne Verwendung der Option „Passend erweitern“ passen Sie die Größe des Teilformulars mit den Eigenschaften in der Palette „Layout“ an. Die mit LiveCycle Designer gelieferten Musterformulare verwenden beide Methoden.
      •
      Definieren Sie die Masterseiten in der Reihenfolge, in der sie angelegt werden sollen. Dadurch wird verhindert, dass die erste Seite leer ist, da das Layout mit dem Stammteilformular (Formular1) des ersten Seitenbereichs beginnt.
Verfasser von Formularentwürfen mit flexiblem Layout können diese Optionen in der Dropdown-Liste „Typ“ auf der Registerkarte „Wert“ der Palette „Objekt“ ignorieren. Diese Optionen gelten nicht für Formularentwürfe, deren Layout an die Datenmenge angepasst wird.


Dokumente importieren

Importieren
PDF-Dateien importieren
PDF-Dokumente als Grafik importieren
Word-Dateien importieren
Tabellenkalkulationsdaten aus Microsoft Excel importieren
InfoPath-Dateien importieren


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Dokumente importieren > Importieren

Importieren

In LiveCycle Designer importierbare Formularformate


In LiveCycle Designer importierbare Formularformate

In LiveCycle Designer können Formulare importiert werden, die in anderen Formularentwurfsanwendungen erstellt wurden. Sie haben auch die Möglichkeit, bestehende Formulare zu importieren und als Vorlage für die Erstellung neuer LiveCycle Designer-Formulare zu nutzen. In LiveCycle Designer können Dateien aus folgenden Anwendungen importiert werden.

Anwendung

Dateitypen
Adobe Acrobat
PDF
Adobe Form Designer 5.0 oder höher
XFT
Adobe Output Designer
IFD
Damit IDF-Dateien in LiveCycle Designer importiert werden können, muss auch Output Designer installiert sein. Weitere Informationen erhalten Sie über den Kunden-Support.
Microsoft InfoPath
XSN
Microsoft Word
DOC, DOT, RTF
LiveCycle Designer enthält eine Reihe von Optionen für den Umgang mit importierten Dateien und zur Erzielung bestmöglicher Ausgabeergebnisse. LiveCycle Designer übernimmt das Layout des importierten Formulars unverändert und wandelt die Elemente in LiveCycle Designer-Objekte um. Beim Import eines Formulars wandelt LiveCycle Designer dieses automatisch in das Dateiformat XDP um.
Verwandte Themen
So importieren Sie PDF-Dateien
So importieren Sie eine Microsoft Word-Datei
So importieren Sie eine Microsoft InfoPath-Datei


PDF-Dateien importieren

So importieren Sie PDF-Dateien
Ergebnisse eines PDF-Dateiimports überprüfen
Umwandlung von PDF-Objekten durch LiveCycle Designer
Hinweise zur Vermeidung von PDF-Konvertierungsproblemen
Hinweise zur Barrierefreiheit beim Import von PDF-Dateien
Hinweise zu Schriftarten beim Import von PDF-Dateien
So ersetzen Sie nicht verfügbare Schriften dauerhaft
Neue Zuordnung zur Schriftzuordnungstabelle in Designer hinzufügen
Schriftzuordnungstabelle in der Datei „ConvertPDF_FontMap.txt“
Zeichenzuordnungstabelle in der Datei „ConvertPDF_CharMap.txt“


So importieren Sie PDF-Dateien

PDF-Dateien können aus einer Vielzahl von Quellen stammen, wobei der Inhalt der PDF-Datei in jeder Entwurfsanwendung anders definiert sein kann.
Vor dem Import einer PDF-Datei in LiveCycle Designer sollten Sie die verschiedenen Optionen kennen lernen, die zur Optimierung des Importvorgangs zur Verfügung stehen.
Mit LiveCycle Designer erstellte PDF-Dateien müssen den Importvorgang nicht durchlaufen. Sie werden vielmehr direkt in LiveCycle Designer geöffnet und sollten ohne Änderungen am Design angezeigt werden.
PDF-Dateien können Sie entweder mit Hilfe des Assistenten für neue Formulare oder des Dialogfeldes „Importoptionen“ importieren. Der Assistent für neue Formulare erleichtert Ihnen die Arbeit. Er führt Sie durch verschiedene Schritte, in denen Sie angeben können, welche PDF-Datei importiert werden soll, wie Sie mit dem importierten PDF-Inhalt arbeiten möchten, und wie das ausgefüllte Formular verteilt und an Sie zurückgesendet werden soll. Im Dialogfeld „Importoptionen“ können Sie steuern, wie LiveCycle Designer den Inhalt der PDF-Datei importiert, wenn Sie ein interaktives Formular mit einem Layout erstellen, für das der Textfluss aktiviert ist. Anhand von benutzerdefinierten Optionen können Sie beispielsweise steuern, wie LiveCycle Designer den Text sowie die Absätze und Bilder im Dokument verarbeitet.
Wenn Sie den Assistenten für neue Formulare nicht zum Importieren von PDF-Dateien nutzen möchten, können Sie ihn mit Hilfe einer der folgenden Methoden deaktivieren:
      •
      Klicken Sie im Assistenten für neue Formulare auf den Link „Assistent nicht verwenden“, um das Dialogfeld „Assistent-Optionen“ anzuzeigen. Wählen Sie anschließend die gewünschte Option aus.
      •
      Wählen Sie „Extras“ > „Optionen“, um das Dialogfeld „Optionen“ anzuzeigen. Wählen Sie „Assistenten und Tipps“, und deaktivieren Sie unter „Formularassistent“ das Kontrollkästchen „Beim Importieren von Dokumenten anzeigen“. Weitere Informationen finden Sie unter Assistenten und Tipps (Dialogfeld „Optionen“).
Betrachten Sie die folgenden Szenarios, bevor Sie eine PDF-Datei importieren:
      •
      Wenn Sie ein in Adobe Acrobat oder einer anderen Anwendung als LiveCycle Designer erstelltes PDF-Dokument besitzen und den Inhalt der Datei als Hintergrundgrafik importieren möchten, wobei Sie das Original-Layout und -Erscheinungsbild des Dokuments beibehalten, wählen Sie die Option zum Erstellen eines interaktiven Formulars mit festem Layout. Sie können alle interaktiven Objekte bearbeiten und alle zusätzlichen Bibliotheksobjekte über den Grafiken platzieren.
      •
      Wenn Sie den Inhalt des PDF-Dokuments in LiveCycle Designer bearbeiten oder ändern möchten, wählen Sie die Option zum Erstellen eines interaktiven Formulars mit flexiblem Layout. Wort- und Zeilenumbrüche bleiben möglicherweise nicht erhalten.
Wenn Sie mit dem ersten Konvertierungsergebnis nicht zufrieden sind, können Sie ausprobieren, mit welchen Optionskombinationen sich das beste Ergebnis erzielen lässt.
Beim Importieren einer PDF-Datei, für die Sicherheitsrechte festgelegt sind, fordert Sie LiveCycle Designer zur Eingabe des korrekten Kennworts auf, um die Datei vor unbefugtem Zugriff zu schützen.
So importieren Sie eine PDF-Datei mit dem Assistenten für neue Formulare:
1.
Wählen Sie „Datei“ > „Neu“.
2.
Wählen Sie im Bildschirm „Erste Schritte“ des Assistenten für neue Formulare auf „PDF-Dokument importieren“, und klicken Sie auf „Weiter“.
3.
Suchen Sie im Fenster „Einrichten: PDF-Dokument importieren“ nach der zu importierenden PDF-Datei, wählen Sie die Datei aus, klicken Sie auf „Öffnen“, und klicken Sie anschließend auf „Weiter“.
4.
Wählen Sie im Fenster „Einrichten: Importoptionen“ die gewünschte Importoption aus:
      •
      Um die PDF-Datei als Hintergrundgrafik zu importieren, so dass LiveCycle Designer das Erscheinungsbild des Originaldokuments und die vorhandenen interaktiven Felder beibehält, wählen Sie die Option zum Erstellen eines interaktiven Formulars mit festem Layout.
      •
      Um die PDF-Datei zu importieren, so dass Sie die Datei in LiveCycle Designer bearbeiten können, wählen Sie die Option zum Erstellen eines interaktiven Formulars mit flexiblem Layout.
5.
Klicken Sie auf „Weiter“.
6.
[Optional] Wählen Sie im Fenster „Formularrücklieferung einrichten: Schaltflächen hinzufügen“ aus, wie das Formular verteilt und die Formulardaten zurückgeliefert werden sollen.
7.
Klicken Sie auf „Fertig stellen“.
So importieren Sie eine PDF-Datei ohne den Assistenten für neue Formulare:
1.
Wählen Sie „Datei“ > „Öffnen“.
2.
Navigieren Sie zu der zu importierenden PDF-Datei, wählen Sie die Datei aus und klicken Sie auf „Öffnen“. Das Dialogfeld „Importoptionen“ wird angezeigt. Wenn Sie im Dialogfeld „Optionen“ unter „Assistenten und Tipps“ das Kontrollkästchen „Beim Importieren von Dokumenten anzeigen“ nicht deaktiviert haben, wird der Assistent für neue Formulare weiterhin angezeigt. Klicken Sie gegebenenfalls auf „Assistent nicht verwenden“, um das Dialogfeld „Importoptionen“ anzuzeigen.
3.
Wählen Sie im Dialogfeld „Importoptionen“ die gewünschte Option für die Arbeit mit dem importierten PDF-Inhalt aus:
      •
      Um das Layout und das Erscheinungsbild des PDF-Inhalts beizubehalten, wählen Sie die Option zum Erstellen eines interaktiven Formulars mit festem Layout.
      •
      Um den Inhalt des PDF-Dokuments in LiveCycle Designer zu bearbeiten, wählen Sie die Option zum Erstellen eines interaktiven Formulars mit flexiblem Layout, und wählen Sie anschließend die gewünschten benutzerdefinierten Optionen zum Importieren der PDF-Datei.
4.
Klicken Sie auf „OK“. Wenn Sie die Option zum Anzeigen eines Übersichtsberichts aktiviert haben, werden vor dem Öffnen des Formulars eventuell aufgetretene Konvertierungsprobleme wie nicht verfügbare Schriften und nicht unterstützte Objekte in einem Dialogfeld gemeldet.
Der Temp-Ordner ist das von Windows konfigurierte temporäre Verzeichnis (normalerweise unter „Dokumente und Einstellungen\ [Benutzername]\Lokale Einstellungen\Temp“). Der Name der Protokolldatei entspricht dem der PDF-Datei mit der Dateinamenerweiterung „.log“. Wenn im Temp-Ordner bereits eine gleichnamige Datei vorhanden ist, wird sie überschrieben.
Verwandte Themen
Formulare öffnen und speichern
Dialogfeld „Importoptionen“


Ergebnisse eines PDF-Dateiimports überprüfen

Der Formularentwurf aus einer importierten PDF-Datei hängt von den unterschiedlichen Kombinationen der Optionen ab, die Sie beim Importieren ausgewählt haben. Wenn Sie mit dem ersten Konvertierungsergebnis nicht zufrieden sind, können Sie ausprobieren, mit welchen Optionskombinationen sich das beste Ergebnis erzielen lässt. Alternativ dazu können Sie die Objekte im Formularentwurf in der Feldeditor-Anzeige bearbeiten.
Die Feldeditor-Anzeige wird angezeigt, wenn Sie ein Objekt auswählen. Sie erhalten hier schnellen Zugriff auf Befehle, die häufig beim Bearbeiten von Objekten verwendet werden.
Zunächst werden Objektgrenzen im Formularentwurf angezeigt, so dass Sie sehen können, wie die PDF-Elemente, insbesondere Text, zu Objekten gruppiert wurden. Dadurch kann der Formularentwurf unruhig aussehen und schwer lesbar sein. Mit Hilfe des Befehls „Objektgrenzen“ im Menü „Ansicht“ können Sie die Objektgrenzen ausblenden, während Sie den Formularentwurf überprüfen. Die Objektgrenzen sind allerdings hilfreich, wenn Sie Änderungen an Objekten im Formularentwurf vornehmen müssen. So können Sie die Objektgrenzen als Führungslinien verwenden, wenn Objekte ohne Grenzen angepasst oder verschoben werden. Die Objektgrenzen zeigen auch an, wenn Text über zwei oder mehr Objekte im Formularentwurf getrennt ist. Über den Befehl „Ausgewählte Textobjekte zusammenführen“ im Menü „Layout“ lassen sich diese Objekte einfach zu einem Textobjekt zusammenführen.
Titel und Anweisungstext lassen sich auf mehrere Text- und Feldobjekte aufteilen. Sie können für ein Feldobjekt, das keine Beschriftung hat, eine Beschriftung erstellen, indem Sie es mit dem Befehl „Als Beschriftung zusammenführen“ im Menü „Layout“ mit einem Textobjekt zusammenführen.
Vielleicht finden Sie auch die Befehle zum Sperren im Menü „Bearbeiten“ hilfreich. Durch das Sperren von Objekten wird verhindert, dass diese Objekte im Layout-Editor ausgewählt und bearbeitet werden. Sie können beispielsweise Text sperren, damit der Text erst bearbeitet werden kann, wenn Sie auf den gewünschten Text bzw. die Beschriftung doppelklicken. Auf diese Weise kann der Text nicht so einfach verändert werden. Sie haben auch die Möglichkeit, statische Objekte wie Text, Linien, Bilder und Formen sowie Feldobjekte zu sperren.
Verwandte Themen
Umwandlung von PDF-Objekten durch LiveCycle Designer
Hinweise zur Vermeidung von PDF-Konvertierungsproblemen
Die Zeichenhilfen
So führen Sie Textobjekte zusammen
So erstellen Sie eine Beschriftung durch Zusammenführen eines Text- und eines Feldobjekts


Umwandlung von PDF-Objekten durch LiveCycle Designer

Die Umwandlung von PDF-Inhalten in das XDP-Format hängt stark von der Quelle der PDF-Datei ab. Die PDF-Spezifikation lässt beim Layout eine Vielzahl von Stilen und Strukturen zu, wobei sich einige gut für die Migration eignen. PDF wird häufig als das endgültige Layout eines Formulars verwendet. Wichtig ist daher die Darstellung des Inhalts und nicht der Inhalt selbst.
In vielen Fällen wird die PDF-Datei über Distiller® oder PDFMaker generiert. Beide Anwendungen können jedoch jeweils nur das darstellen, was ihnen zur Verfügung gestellt wird und auch nur in der Reihenfolge, in der sie es erhalten.
In der nachfolgenden Tabelle sind die zentralen Elemente einer PDF-Datei aufgeführt und es wird beschrieben, wie LiveCycle Designer diese beim Import behandelt.

Element

Konvertiert

Nicht konvertiert
Aktionen (aus einem Acrobat-Formular heraus)
LiveCycle Designer wandelt nur die folgenden Aktionen um, die einem in Acrobat erstellten Formular zugeordnet sein könnten:
•
Import von Formulardaten
•
Starten einer URL
•
Zurücksetzen eines Formulars (vollständige und teilweise Feldliste)
•
Anzeigen/Ausblenden eines Feldes
•
Übergeben eines Formulars für vollständige Feldliste
Alle weiteren Aktionen
Berechnungen
Durchschnitt
Maximum
Minimum
Summe
Bereich
Kommentare/Anmerkungen
Nicht konvertiert
Dokument
JavaScript auf Dokumenten-Ebene wird in Ereignis-Skripten umgewandelt, die auskommentiert werden. Überprüfen Sie die Skripten und aktualisieren Sie diese so, dass sie mit dem LiveCycle Designer-Modell übereinstimmen.
Seiten und Namen
Ereignisse außer JavaScript
Sicherheitsoptionen
Dokumenten-Metadaten, darunter PDF-Version, Titel, Autor, Thema, Schlüsselwörter, Ersteller, Produzent, Erstellungsdatum, Änderungsdatum.
Zugriffsinformationen von PDF-Dateien mit Tags werden beibehalten.
Tab-Reihenfolge
Felder
Datum, Text, Numerisch, Kontrollkästchen, Optionsfelder und -gruppen, Schaltfläche, Kombinationsfeld, Unterschrift (nur Identifikation), Dropdown-Liste und Listenfeld-Feldarten
Standardtext
Abmessungen
Ereignisse
Schriftname, Größe, Fett, Kursiv
JavaScript wird in Ereignis-Skripten umgewandelt, die auskommentiert werden. Überprüfen Sie die Skripten und aktualisieren Sie diese so, dass sie mit dem LiveCycle Designer-Modell übereinstimmen.
Name
Bildformatierung
Position, Ausrichtung und Sichtbarkeit
Druckbar
Attribute: Schreibgeschützt, Erforderlich, Maximale Anzahl Zeichen und Mehrfache Zeilen
RGB- und Graustufen-Farbdefinitionen für Hintergrundfarbe, Begrenzungsfarbe und Farbe. Andere Farbspezifikationen werden RGB-Werten zugeordnet.
QuickInfo wird beibehalten.
Alle in einer PDF-Datei verwendeten Schriften müssen auf Ihrem System vorhanden sein oder es müssen Schriftersetzungsregeln in der Schriftzuordnungstabelle definiert werden.
Wenn ein Kontrollkästchen ausgewählt ist, markiert LiveCycle Designer dieses mit einem Kreuz (x). Wenn in der PDF-Datei bei einem Kontrollkästchen hierfür ein anderes Zeichen verwendet wird, so wird das Zeichen in ein Kreuz umgewandelt, das möglicherweise nicht genau innerhalb des ausfüllbaren Bereichs platziert ist.
Bilder
Alle 1-Bit, 4-Bit, 8-Bit und 24-Bit
Abmessungen
Position
Vektorbild
6-Bit
32-Bit
Einige TIFF-Formate
Linien
Farbe (Kanten- und Füllfarbe)
Abmessungen
Position
Breite
Einige gepunktete und gestrichelte Stile
Stil
Rechtecke
Farbe (Kanten- und Füllfarbe)
Abmessungen
Position
Breite
Einige gepunktete und gestrichelte Linienstile
Rechtecke mit abgerundeten Ecken werden umgewandelt, wenn sie erkannt werden. Die Konvertierung hängt davon ab, wie die PDF-Datei generiert wurde.
Stil
Skripten
JavaScript auf Dokument-, Seiten- und Feldebene wird in Ereignis-Skripten umgewandelt, die auskommentiert werden. Überprüfen Sie die Skripten und aktualisieren Sie diese so, dass sie mit dem LiveCycle Designer-Modell übereinstimmen.
Text
Inhalt
Abmessungen
Schriftname, Größe, Fett, Kursiv
Verschiedene Formatierungen (Rich Text)
Position
RGB- und Graustufen-Farbdefinitionen für Hintergrundfarbe, Begrenzungsfarbe und Farbe. Andere Farbspezifikationen werden RGB-Werten zugeordnet.
Alle in einer PDF-Datei verwendeten Schriften müssen auf Ihrem System vorhanden sein oder es müssen Schriftersetzungsregeln in der Schriftzuordnungstabelle definiert werden.
Symbolzeichen werden nicht immer korrekt dargestellt. Sie können in der Zeichenzuordnungstabelle Zeichenzuordnungsregeln definieren.
LiveCycle Designer bietet keine Unterstützung für Schrift-Kerning. Bei PDF-basiertem Kerning (Unterschneidung) wird die Schriftgröße so reduziert, dass der Text denselben horizontalen Raum einnimmt.
Verwandte Themen
So importieren Sie PDF-Dateien
Hinweise zur Vermeidung von PDF-Konvertierungsproblemen
Neue Zuordnung zur Schriftzuordnungstabelle in Designer hinzufügen
Zeichenzuordnungstabelle in der Datei „ConvertPDF_CharMap.txt“


Hinweise zur Vermeidung von PDF-Konvertierungsproblemen

Einige PDF-Dateien können beim Import in LiveCycle Designer Schwierigkeiten bereiten. Konvertierungsprobleme können von der für die Erstellung der PDF-Datei benutzten Anwendung oder von Entscheidungen, die beim Verfassen des Quelldokuments getroffen wurden, abhängen. Beispielsweise haben sich die folgenden Originalquellen für PDF-Dateien als schwer in LiveCycle Designer importierbar erwiesen:
      •
      Digipath-Dateien werden in ein einziges großes Bild importiert, das nicht bearbeitet werden kann.
      •
      Microsoft Word-Dateien, wenn das Dokument nicht speziell als Formular konzipiert wurde.
Durch Beachten der folgenden Aspekte können Sie mögliche Konvertierungsprobleme vermeiden:
      •
      Wenn eine im Formular verwendete Schrift beim Import des Formulars nicht installiert ist, wird die Schrift ersetzt. Wenn eine Schrift ersetzt wird, erscheint sie nicht genau so wie im Originalformular.
      •
      Wenn Sie Acrobat zur Erstellung von PDF-Dateien verwenden, bauen Sie das Formular nicht nur aus Zeichnungsanmerkungen auf.
      •
      Wenn ein Bild in einem PDF-Formular eine große Anzahl von Linien enthält (z. B. ein Vektorbild), braucht LiveCycle Designer übermäßig viel Zeit, um die Linien beim Import zu verarbeiten. Um eine schnellere Verarbeitung zu erzielen, entfernen Sie das Bild aus der Quelldatei, die zur Erzeugung der PDF-Datei verwendet wird. Wenn erforderlich, können Sie das Bild wieder einfügen, nachdem Sie den Formularentwurf in LiveCycle Designer gespeichert haben. Wenn die Quelldatei nicht verfügbar ist, wird die Effizienz des Formulars erhöht, indem das Bild aus dem Formular in LiveCycle Designer gelöscht wird.
      •
      Wenn Konvertierungsprobleme auftreten und Sie Zugang zu den Quelldateien des Originalformulars haben, versuchen Sie, die PDF-Datei mit Distiller neu zu erstellen. Wenn die ursprüngliche PDF-Datei nicht korrekt erstellt wurde, kann eine erneute Erstellung das Problem eventuell lösen.
Verwandte Themen
So importieren Sie PDF-Dateien


Hinweise zur Barrierefreiheit beim Import von PDF-Dateien

Beim Import eines mit Tags versehenen PDF-Dokuments (barrierefreies PDF-Dokument) werden die Zugriffsinformationen der Seiteninhalte beibehalten. Darüber hinaus kann das Organisieren des Formulars durch Hinzufügen oder Ändern von Unterformularen dazu führen, dass sich die Informationen für Ein-/Ausgabehilfen ändern.
Um sicherzustellen, dass das Formular weiterhin in einer für Ihre Benutzer akzeptablen Weise funktioniert, sollten Sie das Formular gründlich testen. Beachten Sie die folgenden Bereiche und passen Sie sie ggf. an, falls sie nicht wie erwartet funktionieren:
      •
      QuickInfos
      •
      Text für angepasste Bildschirmlesehilfe
      •
      Bildschirmlesehilfen-Rangfolge
Verwandte Themen
So importieren Sie PDF-Dateien
Barrierefreie Formulare


Hinweise zu Schriftarten beim Import von PDF-Dateien

Beim Import versucht LiveCycle Designer die Schriften in der PDF-Datei mit den auf Ihrem Computer verfügbaren Schriften abzugleichen. Wenn die Datei eine nicht verfügbare Schrift enthält, zeigt LiveCycle Designer ein Dialogfeld mit der fehlenden Schrift und einem Vorschlag für eine Ersatzschrift an. Sie können diese Ersatzschrift annehmen oder ändern. Die Schriften werden nicht dauerhaft ersetzt. LiveCycle Designer muss die nicht verfügbaren Schriften bei jedem Öffnen des Formulars neu zuordnen.
Nach dem Import der PDF-Datei werden auf der Registerkarte „Warnung“ der Palette „Bericht“ alle nicht verfügbaren Schriften aufgelistet und es wird erläutert, wie diese konvertiert wurden. Wenn die Schriftzuordnungstabelle die nicht verfügbare Schrift enthält, wird auf der Registerkarte „Warnung“ darauf hingewiesen, dass die Schrift der neuen Schrift zugeordnet wurde. Wenn die nicht verfügbare Schrift in der Schriftzuordnungstabelle nicht enthalten ist, versucht LiveCycle Designer, einen passenden Ersatz auszuwählen. Auf der Registerkarte „Warnung“ wird dann darauf hingewiesen, dass die nicht verfügbare Schrift durch die neue Schrift ersetzt wurde. In diesem Fall können Sie gegebenenfalls der Schriftzuordnungstabelle einen neuen Zuordnungseintrag hinzufügen oder die Schrift permanent ersetzen.


So ersetzen Sie nicht verfügbare Schriften dauerhaft

      •
      Wählen Sie nach dem Importvorgang „Datei“ > „Speichern unter“, und aktivieren Sie das Kontrollkästchen „Nicht verfügbare Schriften dauerhaft ersetzen“, bevor Sie die Datei speichern.


Neue Zuordnung zur Schriftzuordnungstabelle in Designer hinzufügen

Dank der in der Datei „Designer.xci“ gespeicherten Schriftzuordnungstabelle kann LiveCycle Designer die Ersetzung einer vorhandenen Schrift durch eine auf dem Computer verfügbare Schrift beschleunigen. Sie enthält verschiedene Standardeinträge für die Schriftzuordnung.
Die Datei „Designer.xci“ befindet sich im Installationsverzeichnis. Beim Start von LiveCycle Designer wird die Datei „Designer.xci“ in das Benutzerverzeichnis kopiert.
Sie können die Standardeinträge für die Schriftzuordnungstabelle in der Datei „Designer.xci“ ändern.
Syntax
<equate from='input_font_*_*' to='LiveCycle Designer_font_*_*' force="0"/>
Parameter
input_font
Der Name der in der PDF-Eingabedatei verwendeten Schrift.
LiveCycle Designer_font
Der Name der auf Ihrem Computer installierten Schrift.
Sternchen (*)
Platzhalterzeichen. Die Zeichenfolge *Cour* verweist beispielsweise auf alle Schriftnamen, die die Zeichenfolge Cour enthalten.
Fragezeichen (?)
Ein Platzhalter für ein einzelnes Zeichen.
_*_*
Attribute „Fett“ und „Kursiv“. Zulässige Werte nach dem ersten Unterstrich sind: *, normal und bold. Zulässige Werte nach dem zweiten Unterstrich sind: *,normal unditalic.
force=„0“
Weist LiveCycle Designer dazu an, auf dem System nach der Schrift zu suchen und die Schrift nur dann zu ersetzen, wenn sie nicht verfügbar ist.
force=„1“
Weist LiveCycle Designer dazu an, die Schrift zuzuordnen, unabhängig davon, ob sie installiert ist oder nicht.
Beispiel
Die folgendeAnweisung weist LiveCycle Designer dazu an, die Schrift „Courier“, wenn sie nicht zur Verfügung steht, der Schrift „Courier New“ zuzuordnen.
<equate from='Courier_*_*' to='Courier New_*_*' force="0"/>
Verwandte Themen
So importieren Sie PDF-Dateien
Umwandlung von PDF-Objekten durch LiveCycle Designer
Schriftzuordnungstabelle in der Datei „ConvertPDF_FontMap.txt“
Zeichenzuordnungstabelle in der Datei „ConvertPDF_CharMap.txt“


Schriftzuordnungstabelle in der Datei „ConvertPDF_FontMap.txt“

Sie können eine Schriftzuordnungstabelle in der Datei „ConvertPDF_FontMap.txt“ anlegen.
Wenn Sie in dieser Datei eine Schriftzuordnungsregel aufnehmen, werden beim Import eines PDF-Formulars alle Vorkommen der ersetzten Schrift in die neue Schrift geändert. Dies erfolgt unabhängig von der Schriftzuordnungstabelle in der Datei „Designer.xci“ und unabhängig davon, ob die ersetzte Schrift auf Ihrem Computer zur Verfügung steht.
Die Datei „ConvertPDF_FontMap.txt“ befindet sich im Installationsverzeichnis und ist standardmäßig leer.
Syntax
input_font=LiveCycle Designer_font
input_font
Der Name der in der PDF-Eingabedatei verwendeten Schrift.
LiveCycle Designer_font
Der Name der auf Ihrem Computer installierten Schrift.
Sternchen (*)
Platzhalterzeichen. Die Zeichenfolge *Cour* verweist beispielsweise auf alle Schriftnamen, die die Zeichenfolge Cour enthalten. Durch Verwendung von Platzhalterzeichen vor und nach dem Namen der input_font (Eingabeschrift) können auch Schriftnamen im Formular mit leicht unterschiedlichen Schreibweisen erfasst werden.
Fragezeichen (?)
Ein Platzhalter für ein einzelnes Zeichen.
Beispiel
*Arial*=Arial
*Helv*=Arial
*Cour*=Courier New
*=Times New Roman
Die Verarbeitung erfolgt in derselben Reihenfolge wie in der Datei. Die letzte Zeile im Beispiel sorgt dafür, dass alle verbleibenden Schriften in die Schrift Times New Roman konvertiert werden.
Verwandte Themen
So importieren Sie PDF-Dateien
Umwandlung von PDF-Objekten durch LiveCycle Designer
Neue Zuordnung zur Schriftzuordnungstabelle in Designer hinzufügen
Zeichenzuordnungstabelle in der Datei „ConvertPDF_CharMap.txt“


Zeichenzuordnungstabelle in der Datei „ConvertPDF_CharMap.txt“

PDF-Dateien können Zeichen enthalten, die in LiveCycle Designer anders zugeordnet werden. Um die Vorgehensweise in diesen Fällen zu regeln, können Sie Zeichenzuordnungsregeln in der Zeichenzuordnungstabelle „ConvertPDF_CharMap.txt“ verwenden.
LiveCycle Designer verwendet eine Zeichenzuordnungstabelle, um PDF-Eingabesymbole mit dem nativen Zeichensatz richtig darzustellen. Die Tabelle enthält eine Reihe von Standardeinträgen.
Entspricht eine der Zeilen in der Datei „ConvertPDF_CharMap.txt“ nicht Ihrer Vorgabe, kann diese gelöscht werden. Sie können bei Bedarf auch weitere Zeilen hinzufügen.
Die Datei „ConvertPDF_CharMap.txt“ befindet sich im Installationsverzeichnis.
Syntax
input_char,input_font=LiveCycle Designer_char,LiveCycle Designer_font
input_char
Der Dezimalwert des PDF-Eingabesymbols.
input_font
Der jeweilige Schriftname in der PDF, dem das Zeichen zugeordnet sein muss. Ein Sternchen (*) steht für eine beliebige Schrift.
LiveCycle Designer_char
Steht für den UTF-8-Dezimalwert desselben Zeichens.
LiveCycle Designer_font
Steht für die gewünschte Schrift, die das Zeichen enthält. Ein Sternchen (*) weist darauf hin, dass der ursprüngliche Schriftname unverändert bleiben soll.
Beispiel
Mit der folgenden Zeile wird beispielsweise in einer PDF das doppelte Anführungszeichen („) einer beliebigen Schrift in das UTF-8-Gegenstück derselben Schrift konvertiert:
0144,*=0039,*
Verwandte Themen
So importieren Sie PDF-Dateien
Umwandlung von PDF-Objekten durch LiveCycle Designer
Neue Zuordnung zur Schriftzuordnungstabelle in Designer hinzufügen
Schriftzuordnungstabelle in der Datei „ConvertPDF_FontMap.txt“


PDF-Dokumente als Grafik importieren

Hinweise zum Importieren von PDF-Dokumenten als Grafik
So importieren Sie ein PDF-Dokument als Grafik
So ersetzen Sie PDF-Grafiken
Hinweise zum Importieren von strukturierten PDF-Dokumenten als Grafik
So fügen Sie ein field-Tag zur Dokumentstruktur hinzu
So entfernen Sie ein field-Tag aus der Dokumentstruktur
So verschieben Sie ein field-Tag in der Dokumentstruktur nach oben oder unten
So suchen Sie in der Dokumentstruktur nach Feldern ohne Tags
So zeigen Sie die content-Tags in der Dokumentstruktur an


Hinweise zum Importieren von PDF-Dokumenten als Grafik

Wenn Sie ein in Adobe Acrobat oder einer anderen Anwendung erstelltes PDF-Dokument als Grundlage für die Erstellung eines neuen PDF-Formulars in LiveCycle Designer verwenden möchten, können Sie die Option „Interaktives Formular mit fixierten Seiten erstellen“ im Assistenten für neue Formulare nutzen, um den Inhalt des PDF-Dokuments als Hintergrundgrafik für ein neues Formular zu verwenden.
Wenn das PDF-Dokument in Acrobat erstellt wurde und Formularfelder enthält, wandelt LiveCycle Designer diese Felder in die entsprechenden Bibliotheksobjekte um. Nachdem Sie ein PDF-Dokument als Grafik importiert haben, können Sie zusätzliche Bibliotheksobjekte über der Grafik platzieren, um den neuen Formularentwurf zu erweitern.
Wenn Sie die Hintergrundgrafik ändern möchten, steht Ihnen der Befehl „Grafik ersetzen“ im Menü „Bearbeiten“ zur Verfügung, um ein PDF-Ersatzdokument zu importieren. Weitere Informationen finden Sie unter So ersetzen Sie PDF-Grafiken.
Beim Importieren von PDF-Dokumenten als Grafik sollten Sie Folgendes berücksichtigen:
      •
      PDF-Dokumente lassen sich nur als Grafik importieren, wenn das jeweilige Dokument in Acrobat oder einer anderen Anwendung erstellt wurde, die über eine Funktionalität zum Generieren von PDF-Dokumenten verfügt. Wenn das PDF-Dokument mit LiveCycle Designer erstellt wurde, können Sie den Inhalt nicht als Grafik importieren. Der Inhalt kann nur in Form von bearbeitbaren Formularobjekten importiert werden.
      •
      Nachdem Sie ein PDF-Dokument als Grafik importiert haben, müssen Sie das resultierende Formular als „Acrobat 8 (Statisch) PDF-Formular“ speichern. Es kann nicht als „Acrobat (Dynamisch) PDF-Formular“ oder Adobe-XML-Formular gespeichert werden. Der Standarddateityp für neue Formulare mit PDF-Grafiken ist „Acrobat 7 (Statisch) PDF-Formular (*.pdf)“. Er lässt sich bei Bedarf im Dialogfeld „Optionen“ unter „Dokumentoptionen“ ändern.
      •
      Sie können unstrukturierte oder strukturierte PDF-Dokumente mit Tags sowie einer definierten Tab-Reihenfolge und Leserichtung für den Tastaturzugriff und Bildschirmlesehilfen importieren. Weitere Informationen finden Sie unter Hinweise zum Importieren von strukturierten PDF-Dokumenten als Grafik.
      •
      Die folgenden Bibliotheksobjekte stehen in den Gruppen „Standard“ und „Eigene“ beim Import von PDF-Dokumenten als Grafik nicht zur Verfügung: „Kreis“, „Inhaltsbereich“, „Bild“, „Linie“, „Rechteck“, „Teilformular“, „Tabelle“, „Text“, „Maskiertes Feld“, „Maskiertes Feld – teilweise“, „Blatt n von m“, Unterschrift – Drucken und unterzeichnen“ sowie „Umfrage“.
      •
      Mit Bildsymbolen beschriftete Schaltflächen im importierten PDF-Dokument werden nicht unterstützt.
      •
      Wenn Sie ein PDF-Dokument mit Hintergrundgrafiken in einer früheren Version von LiveCycle Designer als der zum Erstellen des Dokuments verwendeten Version öffnen, werden die Bilddaten im Dokument eventuell nicht ordnungsgemäß angezeigt.
      •
      JavaScript auf Dokument-, Seiten- und Feldebene (als Grafik in das PDF-Dokument importiert) wird in Ereignis-Skripten umgewandelt, die auskommentiert werden. Überprüfen Sie die Skripten und aktualisieren Sie diese so, dass sie mit dem LiveCycle Designer-Modell übereinstimmen. Sie können diese Skripten nicht mehr in Acrobat bearbeiten.
Nachdem Sie ein PDF-Dokument als Grafik importiert haben, können Sie das resultierende Dokument ebenso bearbeiten wie ein statisches PDF-Formular.
Verwandte Themen
So importieren Sie ein PDF-Dokument als Grafik


So importieren Sie ein PDF-Dokument als Grafik

Sie können den Inhalt eines PDF-Dokuments, das in Adobe Acrobat oder einer anderen Anwendung erstellt wurde, im Dialogfeld „Öffnen“ als Hintergrundgrafik für ein neues PDF-Formular importieren.
Weitere Informationen dazu, was Sie beim Importieren eines PDF-Dokuments als Grafik in LiveCycle Designer berücksichtigen sollten, finden Sie unter PDF-Dokumente als Grafik importieren.
1.
Wählen Sie „Datei“ > „Öffnen“.
2.
Wählen Sie im Dialogfeld „Öffnen“ die zu importierende PDF-Datei aus und klicken Sie auf „Öffnen“. Der Assistent für neue Formulare wird angezeigt.
3.
Im Fenster „Dokument einrichten“: Wählen Sie im Fenster „Einrichten: Importoptionen“ die Option „Interaktives Formular mit fixierten Seiten erstellen“ und klicken Sie anschließend auf „Weiter“.
4.
(Optional) Wählen Sie im Fenster „Formularrücklieferung einrichten: Schaltflächen hinzufügen“ die gewünschten Optionen aus und klicken Sie auf „Fertig stellen“.
5.
Wählen Sie „Datei“ > „Speichern“ und speichern Sie das Formular in einem der Dateiformate, die in der Liste „Dateityp“ aufgeführt sind.
Verwandte Themen
PDF-Dokumente als Grafik importieren
So ersetzen Sie PDF-Grafiken


So ersetzen Sie PDF-Grafiken

Wenn Sie die Hintergrundgrafik in einem PDF-Formular ändern möchten, steht Ihnen der Befehl „Grafik ersetzen“ im Menü „Bearbeiten“ zur Verfügung. LiveCycle Designer ersetzt die aktuelle Hintergrundgrafik durch die neue Hintergrundgrafik. Die auf der vorherigen Hintergrundgrafik platzierten Feldobjekte werden beibehalten. Alle in der PDF-Ersatzgrafik enthaltenen Adobe Acrobat-Formularfelder werden ignoriert und entfernt.
Denken Sie daran, dass sich das Ersetzen der PDF-Grafik auf die PDF-Struktur auswirkt. Weitere Informationen finden Sie unter Hinweise zum Importieren von strukturierten PDF-Dokumenten als Grafik.
Das Ersetzen von Grafiken lässt sich nicht rückgängig machen. Es wird daher empfohlen, das PDF-Formular zunächst zu speichern, bevor Sie die Grafik ersetzen.
1.
Wählen Sie „Bearbeiten“ > „Grafik ersetzen“.
2.
Wählen Sie „Datei“ > „Speichern“ und speichern Sie das Formular in einem der Dateiformate, die in der Liste „Dateityp“ aufgeführt sind.
Verwandte Themen
PDF-Dokumente als Grafik importieren
So importieren Sie ein PDF-Dokument als Grafik


Hinweise zum Importieren von strukturierten PDF-Dokumenten als Grafik

Sie können strukturierte PDF-Dokumente mit Tags und Strukturinformationen importieren, um eine definierte Tab-Reihenfolge und Leserichtung für Hilfstechnologien wie den Tastaturzugriff und Bildschirmlesehilfen bereitzustellen.
In der Palette „PDF-Struktur“ von LiveCycle Designer wird die hierarchische Struktur eines PDF-Dokuments mit Tags angezeigt. Es gibt drei Typen von Struktur-Tags:
    • <Inhalt>
Content-Tags werden auf den Inhalt des Dokuments angewendet. Sie ähneln HTML-Tags und werden als <P>, <H1>, <Sect>, <Figure> usw. angezeigt. Die Anzeige des Dokumentinhalts erfolgt unter diesen Tags. Content-Tags werden nur zu Referenzzwecken bereitgestellt. Sie können nicht in LiveCycle Designer bearbeitet werden.
    • <Formular>
Form-Tags fungieren als Container für field-Tags. Die gesamte Struktur für Bibliotheksobjekte ist in form-Tags enthalten.
    • <field>
Field-Tags entsprechen den eigentlichen Objekten im Dokument. Sie können nur unter form-Tags existieren. Jedes field-Tag kann mit einem Objekt verknüpft werden. Wenn ein field-Tag mit einem Objekt verknüpft ist, zeigt das Tag den Namen des Objekts zusammen mit einem Symbol an, das den Objekttyp im Dokument angibt. Wenn ein field-Tag nicht mit einem Objekt verknüpft ist, zeigt das Tag die Worte unlinked field an.
Wenn Sie ein strukturiertes PDF-Dokument als Grafik importieren, behält LiveCycle Designer die Struktur bei und weist etwaig enthaltenen Adobe Acrobat-Formularfeldern mit Tags, die in Bibliotheksobjekte umgewandelt werden, automatisch die richtigen form-Tags in der Dokumentstruktur zu. Eventuell müssen Sie jedoch manuell field-Tags unter den korrekten form-Tags für Felder mit Tags einfügen, die noch im Formular vorhanden sind. Sie haben außerdem die Möglichkeit, zusätzliche Bibliotheksobjekte auf der PDF-Grafik zu platzieren und field-Tags für die einzelnen Objekte zur Dokumentstruktur hinzuzufügen.
In der Palette „PDF-Struktur“ können Sie sehen, welche Objekte mit den Struktur-Tags im Formular verknüpft sind. Wenn Sie in der Palette „PDF-Struktur“ auf ein content-Tag klicken, wird das dazugehörige Formularobjekt auf der Registerkarte „Designansicht“ markiert. Beispiel: Wenn Sie in der Palette „PDF-Struktur“ auf das content-Tag <P> für einen Absatz klicken, wird der dazugehörige Inhalt (üblicherweise Text) im Formular markiert.
Nachdem Sie ein strukturiertes PDF-Dokument als Grafik importiert haben, können Sie mithilfe der Befehle im Menü der Palette „PDF-Struktur“ (und im Kontextmenü) field-Tags zur Dokumentstruktur hinzufügen und aus dieser entfernen. Außerdem können Sie in der Struktur navigieren, Felder in der Struktur nach oben und unten verschieben und die content-Tags der Struktur anzeigen.
Bedenken Sie, dass Sie in LiveCycle Designer nur die Feldstruktur bearbeiten können. Die Struktur-Tags und die Inhaltsstruktur eines Formulars können nur in Acrobat bearbeitet werden.
Auswirkungen der Ersetzung von PDF-Grafiken auf die Dokumentstruktur
Beachten Sie, dass durch das Ersetzen der Hintergrundgrafik eines strukturierten PDF-Dokuments die aktuelle Dokumentstruktur durch die Struktur der neuen Hintergrundgrafik ersetzt wird. Alle content-Tags der vorherigen Grafik werden durch die content-Tags der neuen Grafik ersetzt. Die form- und field-Tags bleiben erhalten und werden mit den neuen content-Tags zusammengeführt. Der Inhalt der Feldobjekte wird beibehalten und mit der neuen Inhaltsstruktur zusammengeführt. Sie müssen eventuell einige der form- und field-Tags verschieben, wenn sich die Tags nach dem Zusammenführen nicht am beabsichtigten Standort befinden.
Beachten Sie, dass in Acrobat zur PDF-Ersatzgrafik hinzugefügte Formularfelder in LiveCycle Designer nicht in die entsprechenden bearbeitbaren Bibliotheksobjekte umgewandelt werden.
Handelt es sich bei der PDF-Ersatzgrafik um ein unstrukturiertes Dokument, wird die Struktur der aktuellen PDF-Grafik entfernt. Das resultierende PDF-Formular besitzt keine Struktur mehr.
Verwandte Themen
So importieren Sie ein PDF-Dokument als Grafik
So ersetzen Sie PDF-Grafiken
Palette „PDF-Struktur“


So fügen Sie ein field-Tag zur Dokumentstruktur hinzu

Wählen Sie ein Feldobjekt in einem Formular aus und fügen Sie anschließend ein field-Tag unter einem ausgewählten form-Tag in der Dokumentstruktur hinzu. Unter jedem form-Tag können Sie ein field-Tag hinzufügen.
Sie können auch field-Tags erstellen, indem Sie ein Feld im Formular auf ein Struktur-Tag in der Palette „PDF-Struktur“ ziehen.
1.
Wählen Sie auf der Registerkarte „Designansicht“ das Feld im Formular aus, das Sie zur Dokumentstruktur hinzufügen möchten.
2.
Klicken Sie in der Palette „PDF-Struktur“ mit der rechten Maustaste auf das form-Tag, unter dem Sie das field-Tag hinzufügen möchten, und wählen Sie „Feld der Struktur hinzufügen“.
Verwandte Themen
Palettenmenü „PDF-Struktur“
Hinweise zum Importieren von strukturierten PDF-Dokumenten als Grafik
So ersetzen Sie PDF-Grafiken


So entfernen Sie ein field-Tag aus der Dokumentstruktur

      *
      Klicken Sie in der Palette „PDF-Struktur“ mit der rechten Maustaste auf das zu löschende field-Tag, und wählen Sie „Feld aus Struktur entfernen“.
Verwandte Themen
Palettenmenü „PDF-Struktur“
Hinweise zum Importieren von strukturierten PDF-Dokumenten als Grafik
So ersetzen Sie PDF-Grafiken


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Dokumente importieren > PDF-Dokumente als Grafik importieren > So verschieben Sie ein field-Tag in der Dokumentstruktur nach oben oder unten

So verschieben Sie ein field-Tag in der Dokumentstruktur nach oben oder unten

      *
      Klicken Sie in der Palette „PDF-Struktur“ mit der rechten Maustaste auf das zu verschiebende field-Tag und wählen Sie „Feld nach oben“ oder „Feld nach unten“.
Verwandte Themen
Palettenmenü „PDF-Struktur“
Hinweise zum Importieren von strukturierten PDF-Dokumenten als Grafik
So ersetzen Sie PDF-Grafiken


So suchen Sie in der Dokumentstruktur nach Feldern ohne Tags

      *
      Klicken Sie mit der rechten Maustaste auf die Palette „PDF-Struktur“ und wählen Sie „Felder ohne Tags suchen“.
Verwandte Themen
Palettenmenü „PDF-Struktur“
Hinweise zum Importieren von strukturierten PDF-Dokumenten als Grafik
So ersetzen Sie PDF-Grafiken


So zeigen Sie die content-Tags in der Dokumentstruktur an

      *
      Klicken Sie mit der rechten Maustaste auf die Palette „PDF-Struktur“ und wählen Sie „Inhalts-Tags anzeigen“.
Verwandte Themen
Palettenmenü „PDF-Struktur“
Hinweise zum Importieren von strukturierten PDF-Dokumenten als Grafik
So ersetzen Sie PDF-Grafiken


Word-Dateien importieren

So importieren Sie eine Microsoft Word-Datei
Umwandlung von Word-Objekten und -Einstellungen durch LiveCycle Designer
Hinweise zur Vermeidung von Word-Konvertierungsproblemen


So importieren Sie eine Microsoft Word-Datei

Sie können in LiveCycle Designer eine Microsoft Word XP- oder Microsoft Word 2003-Datei importieren. Bei der Word-Datei kann es sich um ein Dokument (DOC), eine Vorlage (DOT) oder eine RTF-Datei (RTF) handeln.
Word-Objekte (einschließlich Absätze, Tabellen, Bilder, Liniengrafiken, Formularfelder, Kopf- und Fußzeilen) werden in LiveCycle Designer-XML-Elemente umgewandelt, wobei die Rich-Text-Formatierung erhalten bleibt.
Wenn die Word-Datei eine Folge von zusammenhängenden unterstrichenen Tabulatorzeichen enthält (also der Unterstrich als Tabulatorzeichen verwendet wird), versucht LiveCycle Designer, die Informationen in ein Textfeld umzuwandeln.
LiveCycle Designer zeigt die Datei-Importoptionen bei jedem Import einer Word-Datei an.
1.
Wählen Sie „Datei“ > „Öffnen“.
2.
Wählen Sie in der Liste „Dateityp“ die Option „Microsoft Word-Dokument (DOC, DOT, RTF)“.
3.
Navigieren Sie zu der zu öffnenden Datei, wählen Sie die Datei aus und klicken Sie auf „Öffnen“.
4.
Geben Sie im Dialogfeld „Datei-Import-Optionen“ falls nötig ein Kennwort ein, um die Datei zu öffnen oder ihren Schutz aufzuheben.
5.
Zur Ersetzung fehlender Schriften und zur Unterdrückung aller Fehlermeldungen, die auf fehlende Schriften hinweisen, wählen Sie „Fehlende Schriften ignorieren“.
6.
Zur Konvertierung und Einbettung von Bildern in den Formularentwurf wählen Sie „Bilder konvertieren“.
7.
Wählen Sie eine Protokoll-Option in der Liste „Protokolldatei erstellen“ aus.
8.
Klicken Sie auf „OK“.
Da LiveCycle Designer beim Umwandeln von Daten auf die Zwischenablage von Windows zugreift, ist für andere Anwendungen kein Zugriff auf die Zwischenablage möglich, während LiveCycle Designer eine Word-Datei importiert.
Verwandte Themen
Dialogfeld „Datei-Import-Optionen“ (Microsoft InfoPath und Word)
Umwandlung von Word-Objekten und -Einstellungen durch LiveCycle Designer
Hinweise zur Vermeidung von Word-Konvertierungsproblemen


Umwandlung von Word-Objekten und -Einstellungen durch LiveCycle Designer

Beim Umwandeln einer Word-Datei in LiveCycle Designer bleibt das Layout erhalten. Unter Umständen müssen Sie jedoch anschließend die Anordnung der Objekte manuell leicht anpassen, um ein optimales Formular-Layout zu erhalten.
In dieser Tabelle sind die zentralen Objekte einer Word-Datei aufgeführt und es wird beschrieben, wie LiveCycle Designer diese beim Import behandelt.

Element

Konvertiert

Nicht konvertiert
Dateieigenschaften
Integrierte und benutzerdefinierte Eigenschaften werden in Formulareigenschaften umgewandelt.
Absätze
Inhalt (z. B. Text), einschließlich Rich-Text-Formatierung
Schrifteffekte wie Unterstreichen, Durchstreichen, Hochstellen und Tiefstellen
Auf Absätze angewendete Begrenzungen und Schattierungen
Hyperlinks
Farbige Unterstriche werden wieder zurück in schwarze Unterstriche umgewandelt.
Schrifteffekt „Großbuchstaben“
Schriftfarbe für Listennummerierung, wenn diese von der Textfarbe abweicht
Schattierung bei leeren Absätzen
Auf Text angewendete Begrenzungen
Tabellen
Tabellen werden in Unterformulare für die Positionierung von Inhalt umgewandelt. Tabellenzellen werden in untergeordnete Unterformulare umgewandelt.
Einige Begrenzungsstile werden nicht unterstützt.
Formen
Textfelder
Bilder
Linien, Rechtecke und Kreise werden über ein Raster wiedergegeben.
Auto-Formen
OLE-Objekte
Rahmen
ActiveX®-Steuerelemente werden in Bilder umgewandelt.
Pfeilspitzen werden in gerade Linien umgewandelt.
Zeichnungselemente werden in Bilder umgewandelt.
Linienneigung
Das Drehen von Zeichnungsformen wird mit Ausnahme von einem Vielfachen von 90 nicht unterstützt.
Leere Zeilen in Rahmen
ActiveX-Steuerelemente-Funktionalität
Inline-Formen
Bilder und OLE-Objekte werden wie Zeichen behandelt und so positioniert, als ob sie ein Zeichen in einer Textzeile wären.
ActiveX-Steuerelemente werden in Bilder umgewandelt.
ActiveX-Steuerelemente-Funktionalität
Formularfelder
Kontrollkästchen-Felder werden in Kontrollkästchen umgewandelt. Der Standardzustand wird unverändert übernommen.
Dropdown-Felder werden in Dropdown-Listen umgewandelt. Alle Listeneinträge werden übernommen.
Texteingabefelder werden in Textfelder umgewandelt, der Standardwert bleibt erhalten.
Hilfetext- und Statustextinhalte werden in QuickInfos umgewandelt.
Formatierung von Texteingabewerten
Web-Tool-Objekte
Kopf- und Fußzeilen
Wenn alle Kopf- und Fußzeilen gleich sind, werden diese auf der Masterseite erstellt und entsprechend den Layout-Einstellungen für die Kopf- und Fußzeile des Word-Dokuments positioniert.
Wenn unterschiedliche Kopf- und Fußzeilen vorhanden sind, werden sie auf separaten Seiten erstellt.
Eingebettete Feldcodes wie Datum und Uhrzeit
Einstellungen für „Seite einrichten“
Mit den Einstellungen für die Ränder wird das Layout des Standard-Teilformulars für die Seite angegeben.
Mehrere Seiten werden in separate Einzelseiten umgewandelt.
Die Einstellungen für das Papierformat und die Ausrichtung bestimmen die grundlegenden Seiten-Layout-Eigenschaften.
Bundsteg-Einstellungen
Skripten
Ein mit einem Formularfeld verknüpftes Skript wird im XML-Quellcode von LiveCycle Designer zu Kommentaren umgewandelt.
Seitenränder
Wenn dieses Attribut definiert ist, wird es in einen Rahmen auf der Masterseite umgewandelt.
Zeilennummern
Nicht konvertiert
Kommentare
Nicht konvertiert
Webseitenattribute
Nicht konvertiert
Verwandte Themen
So importieren Sie eine Microsoft Word-Datei
Hinweise zur Vermeidung von Word-Konvertierungsproblemen


Hinweise zur Vermeidung von Word-Konvertierungsproblemen

Microsoft Word XP oder Microsoft Word 2003 müssen auf demselben Computer installiert sein wie LiveCycle Designer.
Wenn Sie eine Word-XP-Datei importieren, die für das Senden als E-Mail-Nachricht konfiguriert ist, achten Sie darauf, dass Word XP Service Pack 1 installiert ist. Andernfalls wird es zu einem Absturz von Word XP kommen, wenn der Importvorgang abgeschlossen ist.
Um ein optimales Ergebnis zu erhalten, sollte die Eingabedatei nicht mehr als zehn Seiten enthalten.
Verwandte Themen
So importieren Sie eine Microsoft Word-Datei


Tabellenkalkulationsdaten aus Microsoft Excel importieren

So kopieren Sie Zellen aus einem Microsoft Excel-Arbeitsblatt
So erstellen Sie ein Formular aus dem Inhalt eines Microsoft Excel-Arbeitsblattes


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Dokumente importieren > Tabellenkalkulationsdaten aus Microsoft Excel importieren > So kopieren Sie Zellen aus einem Microsoft Excel-Arbeitsblatt

So kopieren Sie Zellen aus einem Microsoft Excel-Arbeitsblatt

Sie können die Zellen aus einem Microsoft Excel-Arbeitsblatt kopieren und in ein Formular einfügen. LiveCycle Designer erstellt im Formular ein Tabellenobjekt mit derselben Größe, derselben Anzahl von Zellen und demselben Inhalt wie die Auswahl im Arbeitsblatt.
LiveCycle Designer behält einige der Originalformatierungen der Arbeitsblattzellen bei, darunter Text, Schriften, Farben, Hintergrundfarben, Ausrichtung und Ränder. Wenn die im Arbeitsblatt ausgewählten Zellen Spaltenüberschriften enthalten, behält LiveCycle Designer die Formatierung als Spaltenüberschrift in einer Kopfzeile am Anfang der Tabelle bei.
Beachten Sie, dass LiveCycle Designer in dem Tabellenkalkulationsdokument enthaltene Berechnungen, Skripten, Bilder und eingebettete Objekte wie Diagramme nicht beibehält.
1.
Kopieren Sie die gewünschten Zellen des Excel-Arbeitsblattes. Lassen Sie Excel nach dem Kopiervorgang geöffnet.
2.
Fügen Sie die Zellen in LiveCycle Designer in das Formular ein.
Verwandte Themen
So erstellen Sie ein Formular aus dem Inhalt eines Microsoft Excel-Arbeitsblattes


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Dokumente importieren > Tabellenkalkulationsdaten aus Microsoft Excel importieren > So erstellen Sie ein Formular aus dem Inhalt eines Microsoft Excel-Arbeitsblattes

So erstellen Sie ein Formular aus dem Inhalt eines Microsoft Excel-Arbeitsblattes

Sie können ein Microsoft Excel-Arbeitsblatt als Grundlage für die Erstellung eines neuen PDF-Formulars verwenden, um es per E-Mail an die Empfänger zu verteilen und dieselben Daten wie im Arbeitsblatt zu erfassen.
Mit Hilfe des Assistenten für neue Formulare können Sie ein PDF-Formular mit interaktiven Textfeldern erstellen, die auf den Spaltenüberschriften in dem Excel-Arbeitsblatt basieren. Der Assistent für neue Formulare erstellt ein Textfeldobjekt für jede Spalte im Arbeitsblatt. Textfeldobjekte werden von links nach rechts auf dem Formular platziert und gegebenenfalls auf zusätzliche Zeilen umgebrochen. Die Beschriftung und der Name für die Bindung der einzelnen Textfeldobjekte entspricht dem Text der jeweiligen Spaltenüberschrift im Arbeitsblatt.
Wenn Sie eine „Per E-Mail senden“-Schaltfläche in das Formular einfügen, können die Empfänger das Formular ausfüllen und elektronisch an Sie zurücksenden. Wenn Sie im Menü „Datei“ die Option „Formular verteilen“ wählen, wird das Formular in LiveCycle Designer geschlossen. Der Acrobat-Assistent für die Verteilung von Formularen wird angezeigt, um Sie durch den Verteilungsvorgang zu führen. Nachdem Sie die ausgefüllten Formulare von den verschiedenen Empfängern erhalten haben, können Sie die gesammelten Daten in Acrobat in Datensätzen organisieren. Haben Sie mehrere Sätze von Formulardaten erhalten, können Sie die Formulardaten in einem Tabellenkalkulationsblatt neu organisieren.
Beachten Sie, dass LiveCycle Designer in dem Tabellenkalkulationsdokument enthaltene Berechnungen, Skripten, Bilder und eingebettete Objekte wie Diagramme nicht beibehält.
1.
Wählen Sie „Extras“ > „Formular aus Tabelleninhalt erstellen“.
2.
Befolgen Sie die Anweisungen des Assistenten für neue Formulare auf dem Bildschirm. Excel muss geöffnet bleiben, während Sie den Vorgang im Assistenten für neue Formulare abschließen.
Verwandte Themen
So kopieren Sie Zellen aus einem Microsoft Excel-Arbeitsblatt


InfoPath-Dateien importieren

So importieren Sie eine Microsoft InfoPath-Datei
Umwandlung von Microsoft InfoPath-Objekten mit LiveCycle Designer
Unterschiede zwischen LiveCycle Designer- und InfoPath-Objekten


So importieren Sie eine Microsoft InfoPath-Datei

In LiveCycle Designer lassen sich Microsoft InfoPath-Dateien (XSN) importieren. Beim Konvertierungsvorgang extrahiert LiveCycle Designer diese Komponenten aus der Eingabedatei und erstellt aus ihnen die folgenden LiveCycle Designer-XML-Elemente:
      •
      Eine XML-Datei mit einer Beschreibung des Paketinhalts
      •
      Eine XML-Datei mit einer Beschreibung des InfoPath-Formulars
      •
      XSL-Dateien mit einer Beschreibung jeder Ansicht
      •
      Eine Schemadatei für das InfoPath-Formular
      •
      Eine Skript-Datei, die im XML-Quellcode von LiveCycle Designer als Kommentar gespeichert wird
LiveCycle Designer zeigt die Datei-Importoptionen bei jedem Import einer InfoPath-Datei an.
1.
Wählen Sie „Datei“ > „Öffnen“.
2.
Wählen Sie in der Liste „Dateityp“ die Option „InfoPath (XSN)“.
3.
Navigieren Sie zu der zu öffnenden Datei, wählen Sie die Datei aus und klicken Sie auf „Öffnen“.
4.
Führen Sie einen der folgenden Schritte aus:
      •
      Wenn Sie nach einer Ansicht gefragt werden möchten, wählen Sie die Option „Aufforderung zur Ansichtsauswahl beim Konvertieren“. Enthält die InfoPath-Datei nur eine Ansicht, wird auch bei aktivierter Option keine Aufforderung angezeigt.
      •
      Wenn Sie den Namen der Ansicht kennen, die importiert werden soll, geben Sie den Ansichtsnamen im entsprechenden Feld ein. Um die Standardansicht umzuwandeln, lassen Sie dieses Feld leer.
5.
Führen Sie einen der folgenden Schritte aus:
      •
      Wählen Sie die Option „Druckeinstellungen importieren“, um Kopf- und Fußzeilen, Seitenausrichtung und Seitenränder des InfoPath-Formulars zu importieren.
      •
      Wenn Sie das Seitenformat des InfoPath-Formulars kennen, wählen Sie eine Option in der Liste aus, oder wählen Sie die Option „Standard“.
      •
      Wenn Sie die Seitenausrichtung des InfoPath-Formulars kennen, wählen Sie eine Option in der Liste aus.
Wenn Sie die Option „Druckeinstellungen importieren“ aktivieren, werden die Seitengröße und die Seitenausrichtung des InfoPath-Formulars übernommen, so dass Sie diese nicht mehr gesondert festlegen müssen.
6.
(Optional) Wählen Sie eine Option in der Liste „Protokolldatei erstellen“ aus.
7.
(Optional) Zur Konvertierung und Einbettung von Bildern in den Formularentwurf wählen Sie „Bilder in XDP einbetten“.
8.
Klicken Sie auf „OK“.
LiveCycle Designer verwendet Microsoft Internet Explorer 5.0 und höher, um Daten während des Imports einer InfoPath-Datei zu übertragen. Wenn Internet Explorer nicht installiert ist, können keine InfoPath-Dateien in LiveCycle Designer importiert werden.
Verwandte Themen
Microsoft InfoPath


Umwandlung von Microsoft InfoPath-Objekten mit LiveCycle Designer

Beim Umwandeln einer Microsoft InfoPath-Datei in LiveCycle Designer wird das Layout beibehalten. Unter Umständen müssen Sie jedoch anschließend die Anordnung der Objekte manuell leicht anpassen, um ein optimales Formular-Layout zu erhalten.
In der Tabelle sind die zentralen Objekte eines InfoPath-Formulars aufgeführt und es wird beschrieben, wie LiveCycle Designer diese beim Import behandelt.

Element

Konvertiert

Nicht konvertiert
Steuerelemente
Textfelder (einschließlich Rich-Text-Felder) werden in Textfelder umgewandelt.
Dropdown-Listenfelder werden in Dropdown-Listenfelder umgewandelt. Werte werden nur berücksichtigt, wenn das Steuerelement manuell ausgefüllt wurde.
Listenfelder werden in Listenfelder umgewandelt.
Datumsabfrage-Steuerelemente werden in Datums-/Uhrzeitfelder umgewandelt, es sei denn, als Datumstyp für die Datumsabfrage in InfoPath wurde Text festgelegt. In diesem Fall wird das Steuerelement in ein Textfeld umgewandelt.
Kontrollkästchen werden in Kontrollkästchen umgewandelt.
Optionsfelder werden in Optionsfelder umgewandelt.
Schaltflächen werden in Schaltflächen umgewandelt.
Gültigkeitsregeln
Bildlauf
In Rich-Text-Felder eingebettete Bilder
Eine Gruppe von Optionsfeldern darf nicht in eine einzige Optionsfeldgruppe umgewandelt werden.
Sendeaktionen für Schaltflächen werden nicht verarbeitet.
Abstandseigenschaften von Kontrollkästchen und Optionsfeldern
Anlagen
Benutzerdefinierte Steuerelemente
Ausdrucksfelder
Nicht konvertiert
Listen
Nummerierte Listen werden in Text umgewandelt.
Bei Listen mit Aufzählungszeichen wird nur Text in Text umgewandelt.
Aufzählungszeichen
Bilder
Bilder werden in Bilder umgewandelt.
Freihandzeichnungen
Schema
Wenn das InfoPath-Formular auf der Basis eines Schemas entworfen wurde, dann wird das Schema importiert und in LiveCycle Designer erfolgt automatisch eine Bindung.
Skripten
Nicht konvertiert
Bildlaufbereiche
Bildaufbereiche werden in Unterformulare umgewandelt.
Abschnitte
Abschnitte werden in Teilformulare umgewandelt.
Sich wiederholende Abschnitte werden in sich wiederholende Teilformulare in einem Formular umgewandelt. Es sind Schaltflächem zum Hinzufügen und Löschen verfügbar, damit das Exemplar eines Abschnitts beim Ausfüllen des Formulars hinzugefügt oder gelöscht werden kann.
Einbeziehungs-/Auslassungseigenschaften
Hinweistext
Es kann nur ein Exemplar eines optionalen oder wiederholenden Abschnitts konvertiert werden.
Tabellen
Tabellen werden in Tabellen umgewandelt.
Sich wiederholende Tabellen werden in sich wiederholende Tabellen in einem Formular umgewandelt. Es sind Schaltflächem zum Hinzufügen und Löschen verfügbar, damit das Exemplar eines Abschnitts beim Ausfüllen des Formulars hinzugefügt oder gelöscht werden kann.
Einige Begrenzungsstile werden nicht unterstützt.
Nur die sichtbaren Zeilen in einer wiederholten Tabelle werden umgewandelt.
Zeilen, die vertikal zusammengeführt wurden, werden in Teilformulare in einem positionierten Layout umgewandelt.
Text
Text wird in Text umgewandelt. Eine Hervorhebungsfarbe wird in eine Hintergrundfarbe umgewandelt.
Hyperlinks


Unterschiede zwischen LiveCycle Designer- und InfoPath-Objekten

LiveCycle Designer und InfoPath unterstützen nicht dieselben Funktionen und Objekt-Eigenschaften. Die größten Unterschiede sind u. a.:
      •
      Bilder können nicht in LiveCycle Designer-Textfelder platziert werden.
      •
      LiveCycle Designer unterstützt keine editierbaren fortlaufend nummerierten Listen oder Listen mit Aufzählungszeichen.
Verwandte Themen
So importieren Sie eine Microsoft InfoPath-Datei


Tabellen verwenden

Info über Tabellen
Tabellen erstellen
Auswählen, Kopieren, Verschieben und Navigieren
Einfügen und Löschen
Tabellen formatieren
Tabellen ausrichten, anpassen und anordnen
Mit Daten in Tabellen arbeiten
Tabellen mit Größenanpassung erstellen
Mit Paginierung, Kopfzeilen und Fußzeilen in Tabellen arbeiten
Mit Zellen und Zelleninhalten arbeiten
Mit Tabellenabschnitten arbeiten
In Tabellen mit Auswahlabschnitten arbeiten


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Tabellen verwenden > Info über Tabellen

Info über Tabellen

Bestandteile einer Tabelle
Tabellenarten


Bestandteile einer Tabelle

Eine Tabelle besteht aus Zeilen und Spalten mit Zellen, die Formularfelder enthalten und mit Daten zusammengeführt werden können. Die folgende Abbildung zeigt die einzelnen Bestandteile einer Tabelle:
Verwandte Themen
Tabellenarten
Info über das Erstellen von Tabellen


Tabellenarten

In Formularentwürfen von LiveCycle Designer können Sie zwei Arten von Tabellen erstellen:
      •
      Tabellen mit einer festen Anzahl von Zeilen und Spalten. Die folgende Abbildung zeigt beispielsweise eine einfache Tabelle mit vier Spalten, vier Zeilen sowie einer Kopf- und einer Fußzeile.
      •
      Tabellen mit einer festen Anzahl von Spalten, bei denen sich die Anzahl der Zeilen je nach der Menge der Daten in der Datenquelle ändert.
Interaktive Tabellen können auch durch Klicken auf eine Schaltfläche zum Hinzufügen oder Löschen von Zeilen im Formular wachsen bzw. schrumpfen.
Verwandte Themen
Bestandteile einer Tabelle
Info über das Erstellen von Tabellen


Tabellen erstellen

Info über das Erstellen von Tabellen
So erstellen Sie eine Tabelle mit dem Tabellenassistenten
So erstellen Sie eine einfache Tabelle
So erstellen Sie eine Tabelle anhand bestehender Objekte
So erstellen Sie eine verschachtelte Tabelle
So importieren Sie eine Tabelle aus Microsoft Word
So erstellen Sie eine Tabelle anhand von Teilformularen
So erstellen Sie eine verschachtelte Tabelle anhand von Teilformularen


Info über das Erstellen von Tabellen

In diesem Thema werden die verschiedenen Möglichkeiten zum Erstellen einer Tabelle zusammengefasst.

Aufgabe

Vorgehensweise
Sie möchten an einer bestimmten Stelle im Formularentwurf eine leere Tabelle mit einer festen Anzahl von Zeilen und Spalten erstellen.
Ziehen Sie das Objekt „Tabelle“ aus der Palette „Bibliothek“ an die gewünschte Stelle im Formularentwurf. Legen Sie im Dialogfeld „Tabelle einfügen“ die gewünschte Anzahl von Spalten und Textzeilen fest. Siehe So erstellen Sie eine einfache Tabelle.
Sie möchten am Ende des Formularentwurfs eine leere Tabelle mit einer festen Anzahl von Zeilen und Spalten erstellen.
Wählen Sie „Tabelle“ > „Tabelle einfügen“, „Einfache Tabelle erstellen“ aus und geben Sie die Anzahl der Spalten und der Textzeilen an. Siehe So erstellen Sie eine einfache Tabelle.
Sie möchten an einer bestimmten Stelle im Formularentwurf eine Tabelle erstellen, bei der die Anzahl der Zeilen an die angezeigte Datenmenge angepasst wird.
Wenn eine Verbindung zu einer Datenquelle besteht, ziehen Sie ein Element, das (durch ein Tabellensymbol) als sich wiederholende Datengruppe gekennzeichnet ist, aus der Palette „Datenansicht“ auf den Formularentwurf. Formatieren Sie die Tabelle. Siehe So erstellen Sie eine Tabelle aus einer Datenquelle.
Sie möchten am Ende des aktuellen Formularentwurfs eine leere Tabelle erstellen, bei der die Anzahl der Zeilen an die Datenmenge angepasst wird.
Wählen Sie „Tabelle“ > „Tabelle einfügen“ aus und aktivieren Sie die Option „Tabelle mit Assistenten erstellen“. Aktivieren Sie die Option „Textzeilen sind von Daten abhängig“ und befolgen Sie dann die Anweisungen des Assistenten. Siehe So erstellen Sie eine Tabelle mit dem Tabellenassistenten.
Sie möchten eine Tabelle anhand bestehender Objekte erstellen.
Wählen Sie die Objekte aus und klicken Sie auf „Tabelle“ > „In Tabelle konvertieren“. Siehe So erstellen Sie eine Tabelle anhand bestehender Objekte.
Sie möchten eine verschachtelte Tabelle erstellen.
Erstellen Sie die Haupttabelle und erstellen Sie dann die Tabelle, die in die Haupttabelle eingebettet werden soll. Wählen Sie die zweite Tabelle aus und ziehen Sie sie in die Zelle, in die sie eingebettet werden soll. Sie können auch die Zelle in der Haupttabelle auswählen und dann auf „Tabelle“ > „Tabelle einfügen“ klicken, um die verschachtelte Tabelle zu erstellen. Siehe So erstellen Sie eine verschachtelte Tabelle.
Sie möchten eine Tabelle aus einer anderen Anwendung importieren.
Wählen Sie „Datei“ > „Öffnen“ und navigieren Sie zu der Datei mit der Tabelle (z. B. ein Microsoft Word-Dokument). Siehe So importieren Sie eine Tabelle aus Microsoft Word.
Verwandte Themen
Info über Tabellen


So erstellen Sie eine Tabelle mit dem Tabellenassistenten

Der Tabellenassistent erleichtert Ihnen die Erstellung einer Tabelle. Sie können mit seiner Hilfe die grundlegenden Bausteine der Tabelle definieren, bevor Sie sie in das Formular einfügen. So können Sie beispielsweise im Dialogfeld „Tabellenassistent“ Textzeilen und Spalten, Kopf- und Fußzeilen sowie Abschnitte hinzufügen und den Zeilen eine Schattierung zuweisen.
Mit dem Tabellenassistenten können Sie Tabellen mit einer festen Anzahl von Zeilen und Spalten oder Tabellen mit einer festen Anzahl von Spalten erstellen, bei denen sich die Anzahl der Zeilen je nach der Menge der Daten in der Datenquelle ändert.
Im Bereich „Vorschau“ des Tabellenassistenten können Sie sehen, wie sich die Auswahl einer Option auf die Tabelle auswirkt. Nachdem Sie die Tabelle mit dem Tabellenassistenten erstellt haben, können Sie sie über die Befehle im Menü „Tabelle“ sowie die Optionen in den Paletten „Layout“, „Rand“, „Objekt“ und „Ein-/Ausgabehilfe“ noch weiter an Ihre Bedürfnisse anpassen.
Das Dialogfeld „Tabelle einfügen“ wird standardmäßig angezeigt, wenn Sie auf „Einfügen“ > „Standard“ > „Tabelle“ klicken oder das Tabellenobjekt in den Layout-Editor ziehen. Wenn Sie das Kontrollkästchen „Nicht mehr anzeigen“ im Dialogfeld „Tabelle einfügen“ aktiviert haben, können Sie diese Auswahl wieder rückgängig machen, indem Sie „Extras“ > „Optionen“ > „Assistenten und Tipps“ auswählen und dann die Option „Beim Erstellen von Tabellen anzeigen“ aktivieren.
1.
Wählen Sie „Tabelle“ > „Tabelle einfügen“ aus und aktivieren Sie die Option „Tabelle mit Assistenten erstellen“.
2.
Geben Sie im Tabellenassistenten das Textkörperlayout an und klicken Sie dann auf „Weiter“:
      •
      Um der Tabelle eine feste Anzahl von Zeilen und Spalten hinzuzufügen, aktivieren Sie die Option „Textkörper hat feste Größe“ und wählen Sie dann in den Feldern „Spaltenanzahl“ und „Textzeilenanzahl“ die gewünschten Werte aus.
      •
      Bei einer Tabelle, bei der die Anzahl der Textzeilen durch die Anzahl der Zeilen in der Datenquelle bestimmt wird, aktivieren Sie die Option „Textzeilen sind von Daten abhängig“ und wählen Sie in der Liste „Spaltenanzahl“ einen Wert aus.
3.
Geben Sie an, ob eine Kopfzeile eingefügt werden soll, und klicken Sie dann auf „Weiter“:
      •
      Wenn keine Kopfzeile erstellt werden soll, wählen Sie „Keine Kopfzeile“ aus.
      •
      Um eine Kopfzeile hinzuzufügen, wählen Sie „Kopfzeile vorhanden“ aus und wählen Sie dann ggf. „Kopfzeile auf jeder Seite wiederholen“ aus. Die Option „Kopfzeile auf jeder Seite wiederholen“ ist nur verfügbar, wenn Sie auf der Seite „Textkörperlayout“ die Option „Textzeilen sind von Daten abhängig“ ausgewählt haben.
4.
Geben Sie an, ob eine Fußzeile eingefügt werden soll, und klicken Sie dann auf „Weiter“:
      •
      Wenn keine Fußzeile erstellt werden soll, wählen Sie „Keine Fußzeile“ aus.
      •
      Um eine Fußzeile hinzuzufügen, wählen Sie „Fußzeile vorhanden“ aus und wählen Sie dann ggf. „Fußzeile auf jeder Seite wiederholen“ aus. Die Option „Fußzeile auf jeder Seite wiederholen“ ist nur verfügbar, wenn Sie auf der Seite „Textkörperlayout“ die Option „Textzeilen sind von Daten abhängig“ gewählt haben.
5.
Geben Sie die Abschnitt an, die eingefügt werden sollen, und klicken Sie dann auf „Weiter“:
      •
      Um Textzeilen ohne Abschnitte einzufügen, wählen Sie „Textzeilen vorhanden, keine Abschnitte“ aus.
      •
      Um in Abschnitte gruppierte Textzeilen einzufügen, wählen Sie „Textzeilenabschnitte vorhanden“ und führen Sie die folgenden Schritte aus:
      •
      Mit den Schaltflächen „Hinzufügen“, „Löschen“, „Nach oben“ und „Nach unten“ über dem Listenfeld „Abschnitte“ können Sie Abschnitte hinzufügen, entfernen und neu anordnen.
      •
      Zum Umbenennen eines Abschnitts in der Liste „Abschnitte“ doppelklicken Sie auf den Abschnitt und weisen ihm im Dialogfeld „Tabellenabschnitt“ einen neuen Namen zu.
      •
      Um einem Abschnitt in der Liste „Abschnitte“ bestimmte Einstellungen zuzuweisen, wählen Sie den Abschnitt aus und aktivieren unter „Abschnittsoptionen“ die gewünschten Optionen. Hinweis: Wenn Sie „Abschnitt ist optional“ auswählen, wird der Mindestwert für das Vorkommen dieses Abschnitts auf 0 gesetzt. Dies bedeutet, dass der Abschnitt nur angezeigt wird, wenn Daten vorhanden sind.
6.
Legen Sie die Zeilenschattierung fest und klicken Sie dann auf „Fertig stellen“:
      •
      Wählen Sie „Abwechselnde Zeilenfarben“ aus.
      •
      Legen Sie in der Liste „Erste“ die Anzahl der Zeilen fest, die mit der ersten Farbe unterlegt werden sollen, und wählen Sie dann eine Farbe aus.
      •
      Legen Sie in der Liste „Nächste“ die Anzahl der Zeilen fest, die mit der zweiten Farbe unterlegt werden sollen, und wählen Sie dann eine Farbe aus.
Verwandte Themen
So wiederholen Sie eine Kopf- oder Fußzeile auf Folgeseiten


So erstellen Sie eine einfache Tabelle

Sie können eine einfache Tabelle mit einer festen Anzahl von Spalten und Zeilen mit oder ohne Kopf- und Fußzeile erstellen. Die folgende Abbildung zeigt eine einfache Tabelle mit vier Spalten, vier Zeilen sowie einer Kopf- und Fußzeile.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und wählen Sie das Objekt „Tabelle“ [image] aus.
2.
Klicken Sie auf die Stelle, an der die Tabelle eingefügt werden soll.
Wenn Sie zuvor im Dialogfeld „Tabelle einfügen“ die Option „Nicht mehr anzeigen“ aktiviert haben, fügt LiveCycle Designer bei dieser Aktion die Tabelle automatisch mit der Anzahl von Spalten und Zeilen ein, die Sie beim letzten Mal im Dialogfeld „Tabelle einfügen“ ausgewählt haben.
3.
Legen Sie im Dialogfeld „Tabelle einfügen“ die gewünschte Anzahl von Spalten und Textzeilen fest.
Sie können maximal 20 Spalten und 50 Zeilen auswählen. Im Anschluss an die Tabellenerstellung ist es jedoch möglich, über die Einfügebefehle im Menü „Tabelle“ noch weitere Zeilen und Spalten hinzuzufügen.
4.
(Optional) Um eine Kopfzeile hinzuzufügen, wählen Sie „Kopfzeile in Tabelle einschließen“ aus.
5.
(Optional) Um eine Fußzeile hinzuzufügen, wählen Sie „Fußzeile in Tabelle einschließen“ aus.
6.
Klicken Sie auf „OK“.
Verwandte Themen
So wiederholen Sie eine Kopf- oder Fußzeile auf Folgeseiten


So erstellen Sie eine Tabelle anhand bestehender Objekte

Wenn Sie bereits über ein Formular verfügen, das als Tabelle formatierte Feldobjekte enthält, können Sie diese Objekte problemlos in eine Tabelle konvertieren. So enthält zum Beispiel die mit LiveCycle Designer gelieferte Vorlage „Frachtbrief“ als Tabelle formatierte Felder.
1.
Öffnen Sie ein Formular mit als Tabelle formatierten Feldern.
Erstellen Sie beispielsweise ein neues Formular auf der Grundlage der Vorlage „Frachtbrief“. Wählen Sie dazu „Datei“ > „Neu“ und die Option „Vorlage verwenden“ aus. Klicken Sie auf „Weiter“ und wählen Sie dann die Vorlage „Frachtbrief“ aus. Klicken Sie auf „Weiter“ und füllen Sie die übrigen Felder im Assistenten für neue Formulare aus.
2.
Ziehen Sie die Objekte, die in eine Tabelle konvertiert werden sollen.
Wählen Sie beispielsweise die Kopfzeile und alle Zeilen bis zu den Abschnitten „Lieferbedingungen“ und „Versicherung“ aus.
3.
Wählen Sie „Tabelle“ > „In Tabelle konvertieren“.
Sie können jede Feldgruppe in eine Tabelle konvertieren. In dieser Vorlage können Sie beispielsweise die Felder unter „Versand an“ und „Spediteur“ in eine Tabelle konvertieren.


So erstellen Sie eine verschachtelte Tabelle

Sie können innerhalb einer Tabelle eine von der Haupttabelle unabhängige Tabelle erstellen. So kann die verschachtelte Tabelle beispielsweise eine andere Anzahl von Spalten oder Zeilen als die Haupttabelle aufweisen. Die Anzahl der Verschachtelungsebenen ist unbegrenzt.
1.
Erstellen Sie eine Tabelle. Siehe So erstellen Sie eine einfache Tabelle.
2.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie das Objekt „Tabelle“ in eine Zelle der Haupttabelle.
Wenn Sie zuvor im Dialogfeld „Tabelle einfügen“ die Option „Nicht mehr anzeigen“ aktiviert haben, fügt LiveCycle Designer bei dieser Aktion die Tabelle automatisch mit der Anzahl von Spalten und Zeilen ein, die Sie beim letzten Mal im Dialogfeld „Tabelle einfügen“ ausgewählt haben.
3.
Legen Sie im Dialogfeld „Tabelle einfügen“ die gewünschte Anzahl von Spalten und Textzeilen fest.
Sie können maximal 20 Spalten und 50 Zeilen auswählen. Im Anschluss an die Tabellenerstellung ist es jedoch möglich, über die Einfügebefehle im Menü „Tabelle“ noch weitere Zeilen und Spalten hinzuzufügen.
4.
(Optional) Um eine Kopfzeile hinzuzufügen, wählen Sie „Kopfzeile in Tabelle einschließen“ aus.
5.
(Optional) Um eine Fußzeile hinzuzufügen, wählen Sie „Fußzeile in Tabelle einschließen“ aus.
6.
Klicken Sie auf „OK“.
Wenn bereits eine Tabelle vorhanden ist, können Sie auch diese Tabelle auswählen und in die gewünschte Zelle ziehen.


So importieren Sie eine Tabelle aus Microsoft Word

Sie können eine Tabelle aus Microsoft Word in LiveCycle Designer importieren.
1.
Wählen Sie in LiveCycle Designer „Datei“ > „Öffnen“.
2.
Wählen Sie in der Liste „Dateityp“ die Option „Microsoft Word-Dokument“ aus.
3.
Navigieren Sie zur Microsoft Word-Datei mit der Tabelle und klicken Sie auf „Öffnen“.
LiveCycle Designer zeigt den Assistenten für neue Formulare an. Die Option „Word-Dokument importieren“ ist bereits aktiviert.
4.
Klicken Sie auf „Weiter“ und beantworten Sie die vom Assistenten für neue Formulare eingeblendeten Fragen.
5.
Geben Sie im Dialogfeld „Datei-Import-Optionen“ die erforderlichen Informationen ein und klicken Sie auf „OK“.
Der Inhalt des Dokuments wird mit der Tabelle in LiveCycle Designer importiert.
Verwandte Themen
So wandeln Sie Zellen in einen anderen Objekttyp um


So erstellen Sie eine Tabelle anhand von Teilformularen

Eine Tabelle kann mit Hilfe von Teilformularen erstellt werden. Teilformulare können eine Vielzahl von Objekten enthalten, einschließlich Schaltflächen, Textfeldern und anderer Teilformulare. Die Fließrichtung des Teilformulars gibt an, wie die enthaltenen Objekte angeordnet werden. In der Regel werden Tabellen mit dem Objekt „Tabelle“ in der Palette „Bibliothek“ erstellt. Komplexere Tabellen mit ungleichmäßigen Spalten lassen sich mit Hilfe von Teilformularen erstellen.
1.
Beginnen Sie mit der Tabellenerstellung:
      •
      Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie das Objekt „Teilformular“ auf das Formular.
      •
      Passen Sie die Größe des Teilformulars an die gewünschte Tabellenbreite an.
      •
      Das Teilformular muss hoch genug sein, um ein oder mehrere untergeordnete Teilformulare aufnehmen zu können.
      •
      Weisen Sie dem Teilformular auf der Registerkarte „Bindung“ der Palette „Objekt“ einen Namen zu. Geben Sie beispielsweise TableParent ein.
      •
      Wählen Sie in der Palette „Ein-/Ausgabehilfe“ unter „Teilformularrolle“ den Eintrag „Tabelle“ aus.
2.
Erstellen Sie die Tabellenkopfzeile:
      •
      Ziehen Sie ein weiteres Objekt des Typs „Teilformular“ in das Teilformular „TableParent“.
      •
      Passen Sie die Breite des Kopfzeilenteilformulars an die Breite des übergeordneten Teilformulars an. Legen Sie als Höhe des Teilformulars die für die Kopfzeile erforderliche Höhe fest.
      •
      Weisen Sie dem Teilformular auf der Registerkarte „Bindung“ der Palette „Objekt“ einen Namen zu. Geben Sie beispielsweise TableHeader ein.
      •
      Wählen Sie in der Palette „Ein-/Ausgabehilfe“ unter „Teilformularrolle“ den Eintrag „Kopfzeile“ aus.
3.
Fügen Sie den Text für die Spaltenüberschriften hinzu:
      •
      Ziehen Sie ein Textobjekt in das Teilformular „TableHeader“.
      •
      Doppelklicken Sie auf den Text im Textobjekt und weisen Sie der Spalte einen Namen zu.
      •
      Wiederholen Sie diese Schritte, wenn Sie der Tabelle weitere Überschriften hinzufügen möchten.
4.
Erstellen Sie eine Textzeile, die als sich wiederholende Zeile in der Tabelle fungiert:
      •
      Ziehen Sie ein weiteres Objekt des Typs „Teilformular“ in das Teilformular „TableParent“.
      •
      Passen Sie die Breite des Textzeilenteilformulars an die Breite des übergeordneten Teilformulars an. Legen Sie als Höhe des Teilformulars die für die Textzeile erforderliche Höhe fest.
      •
      Weisen Sie dem Teilformular auf der Registerkarte „Bindung“ der Palette „Objekt“ einen Namen zu. Geben Sie beispielsweise TableBodyRow ein.
      •
      Fügen Sie dieselbe Anzahl von Feldern wie die der in Schritt 3 angelegten Überschriften hinzu, um die Datenwerte in der Tabelle anzuzeigen. Legen Sie die Größe der Felder fest.
      •
      Wählen Sie in der Palette „Layout“ in der Liste „Beschriftung“ die Einstellung „Ohne“ aus.
      •
      Wählen Sie in der Palette „Ein-/Ausgabehilfe“ unter „Teilformularrolle“ den Eintrag „Textzeile“ aus.
      •
      Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und aktivieren Sie die Option „Teilformular wiederholen für jedes Datenelement“.
5.
Wählen Sie das Teilformular „TableParent“ aus, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Teilformular“ und wählen Sie dann in der Liste „Typ“ die Option „Textfluss“ aus.
6.
(Optional) Es stehen folgende Möglichkeiten zur Verfügung, um die Tabelle noch ansprechender zu gestalten:
      •
      Fügen Sie über die Palette „Rand“ Umrandungen und Schattierungen für die Tabellenelemente hinzu.
      •
      Legen Sie für die Tabellenzeilen einen Überlaufkopfbereich und einen Überlauffußbereich fest.
So erstellen Sie eine Tabelle mit Zellen variabler Breite
1.
Erstellen Sie mindestens zwei Tabellen. Jede Tabelle sollte über eine Textzeile verfügen. Weisen Sie der ersten Tabelle eine Kopfzeile zu. Die übrigen Tabellen dürfen nur Textzeilen aufweisen.
2.
Ordnen Sie die Tabellen untereinander an.
3.
Umschließen Sie alle Tabellen mit einem übergeordneten Teilformular.
4.
Passen Sie die Breite der Zellen nach Bedarf an.
5.
Legen Sie für das übergeordnete Teilformular die Einstellung „Textfluss“ fest.
Verwandte Themen
Teilformulare – Übersicht
Info über Überlaufkopfbereiche und Überlauffußbereiche
Randeigenschaften in der Palette „Rand“
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“


So erstellen Sie eine verschachtelte Tabelle anhand von Teilformularen

Nachdem Sie eine Tabelle mithilfe von Teilformularen erstellt haben, können Sie in eine der Tabellenzellen eine weitere Tabelle einfügen. Sie können z. B. zwei unabhängige Tabellen nebeneinander (in getrennten Zellen) anzeigen oder in verschachtelte Tabellen einbauen.
Bevor Sie eine Tabelle in eine Zelle einfügen, müssen Sie die Zelle in ein Teilformular aufnehmen.
1.
Beginnen Sie mit der Erstellung der verschachtelten Tabelle:
      •
      Wählen Sie die Zelle (in der mit Teilformularen erstellten Tabelle) aus, die das eingebettete Teilformular aufnehmen soll.
      •
      Wählen Sie „Einfügen“ > „Umschließen mit Teilformular“.
      •
      Weisen Sie dem Teilformular auf der Registerkarte „Bindung“ der Palette „Objekt“ einen Namen zu. Geben Sie beispielsweise Wrapper ein.
2.
Erstellen Sie die verschachtelte Tabelle.
      •
      Klicken Sie wieder mit der rechten Maustaste auf die Zelle und wählen Sie „Umschließen mit Teilformular“ aus oder ziehen Sie das Objekt „Teilformular“ aus der Palette „Bibliothek“ in die Zelle.
      •
      Weisen Sie dem Teilformular auf der Registerkarte „Bindung“ der Palette „Objekt“ einen Namen zu. Geben Sie beispielsweise NestedTable ein.
      •
      Wählen Sie in der Palette „Ein-/Ausgabehilfe“ unter „Teilformularrolle“ den Eintrag „Tabelle“ aus.
3.
Klicken Sie mit der rechten Maustaste auf die Zelle (im Beispiel „Textfeld1“) und wählen Sie „Löschen“ aus.
4.
Erstellen Sie die Kopfzeile der verschachtelten Tabelle:
      •
      Ziehen Sie ein weiteres Objekt des Typs „Teilformular“ in das Teilformular „NestedTable“.
      •
      Legen Sie die Breite und Höhe der Kopfzeile fest.
      •
      Weisen Sie dem Teilformular auf der Registerkarte „Bindung“ der Palette „Objekt“ einen Namen zu. Geben Sie beispielsweise NestedRow1 ein.
      •
      Wählen Sie in der Palette „Ein-/Ausgabehilfe“ unter „Teilformularrolle“ den Eintrag „Kopfzeile“ aus.
Ein Teilformular, das in ein übergeordnetes Teilformular mit der Einstellung „Textfluss“ eingefügt wird, wird möglicherweise in der Palette „Hierarchie“ nicht an der richtigen Stelle angezeigt.
5.
Fügen Sie den Text für die Spaltenüberschriften hinzu:
      •
      Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie zwei Textobjekte in das Teilformular „NestedRow1“.
      •
      Wählen Sie den Text in einem der Textobjekte aus und weisen Sie ihm einen Namen zu. Geben Sie beispielsweise Description ein.
      •
      Wählen Sie den Text im zweiten Textobjekt aus und weisen Sie ihm einen Namen zu. Geben Sie beispielsweise Cost ein.
      •
      Wählen Sie die beiden Textobjekte im Teilformular „NestedRow1“ aus und klicken Sie auf „Layout“ > „Gruppieren“.
6.
Erstellen Sie eine Textzeile für die verschachtelte Tabelle:
      •
      Ziehen Sie ein weiteres Objekt des Typs „Teilformular“ in das Teilformular „NestedTable“.
      •
      Legen Sie die Breite und Höhe der Textzeile fest.
      •
      Weisen Sie dem Teilformular auf der Registerkarte „Bindung“ der Palette „Objekt“ einen Namen zu. Geben Sie beispielsweise NestedRow2 ein.
      •
      Wählen Sie in der Palette „Ein-/Ausgabehilfe“ unter „Teilformularrolle“ den Eintrag „Textzeile“ aus.
      •
      Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie drei Feldobjekte (z. B. Textfelder) in das Teilformular „NestedRow2“.
7.
Legen Sie für die Bestandteile der Tabelle die Einstellung „Textfluss“ fest:
      •
      Wählen Sie das Teilformular „NestedTable“ aus, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Teilformular“ und wählen Sie dann in der Liste „Typ“ die Option „Textfluss“ aus.
      •
      Wählen Sie das Teilformular mit dem Namen „(unbenannt - Teilformular) (Seite 1)“ aus, welches das Teilformular „NestedTable“ enthält , klicken Sie in der Palette „Objekt“ auf die Registerkarte „Teilformular“ und wählen Sie dann in der Liste „Typ“ die Option „Textfluss“ aus.
Die Palette „Hierarchie“ sieht wie die folgende Abbildung aus.
Das Formular sieht wie die folgende Abbildung auf der Registerkarte „PDF-Vorschau“ aus.
Verwandte Themen
Teilformulare – Übersicht
Info über Überlaufkopfbereiche und Überlauffußbereiche
Randeigenschaften in der Palette „Rand“
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“


Auswählen, Kopieren, Verschieben und Navigieren

So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus
So kopieren Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte
So verschieben Sie eine Tabelle
So springen Sie zu einer bestimmten Zeile
Info über das Navigieren in Tabellen in barrierefreien Formularen


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Tabellen verwenden > Auswählen, Kopieren, Verschieben und Navigieren > So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus

So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus

Es gibt verschiedene Möglichkeiten, um Zeilen, Spalten, Zellen, Abschnitte oder die gesamte Tabelle auszuwählen:
      •
      Klicken Sie auf die Tabelle und verwenden Sie die Befehle zum Auswählen im Menü „Tabelle“.
      •
      Ziehen Sie mit dem Mauszeiger, um unterschiedliche Teile der Tabelle auszuwählen.
      •
      Wählen Sie Objekte in der Palette „Hierarchie“ aus.
Sie können auch folgendermaßen vorgehen:
So wählen Sie die gesamte Tabelle aus
      *
      Klicken Sie oben links auf die Tabelle oder ziehen Sie mit der Maus über die gesamte Tabelle.
So wählen Sie die Zellen in einer Zeile aus
      *
      Zeigen Sie mit der Maus auf den linken Rand der Zeile, bis der folgende Pfeil angezeigt wird:
So wählen Sie eine Zeile aus
      *
      Zeigen Sie mit der Maus auf den linken Rand der Zeile, bis der folgende Pfeil angezeigt wird:
So wählen Sie die Zellen in einer Spalte aus
      *
      Klicken Sie am oberen Rand der Spalte.
So wählen Sie eine Zelle aus
      *
      Klicken Sie rechts unten auf die Ecke der Zelle.
Nach Auswahl einer Zelle können Sie mit den Pfeiltasten noch weitere Tabellenzellen in die Auswahl aufnehmen. Verwenden Sie bei gedrückter Umschalttaste die entsprechende Pfeiltaste, um die angrenzenden Zellen auszuwählen.
So wählen Sie mehrere Zeilen, Spalten, Zellen oder Abschnitte aus
      *
      Ziehen Sie mit dem Mauszeiger über die Zeilen, Spalten, Zellen oder Abschnitte.
Zum Auswählen mehrerer nicht aneinander angrenzender Elemente klicken Sie auf die erste auszuwählende Zeile, Spalte oder Zelle oder auf den ersten Abschnitt und klicken dann bei gedrückter Steuerungstaste auf die übrigen auszuwählenden Zeilen, Spalten, Zellen oder Abschnitte.
Zum Auswählen aneinander angrenzender Zellen klicken Sie auf die erste auszuwählende Zelle und wählen dann bei gedrückter Umschalttaste mit den Pfeiltasten die gewünschten angrenzenden Zellen aus.
Die Zeilen, Spalten, Zellen oder Abschnitte müssen sich in derselben Tabelle befinden. Eine verschachtelte Tabelle wird als eigenständige Tabelle angesehen.
So wählen Sie einen Abschnitt aus
      *
      Klicken Sie auf die rechte Klammer, durch die der Abschnitt gekennzeichnet wird.


So kopieren Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte

1.
Wählen Sie die zu kopierende Tabelle, Zeile, Spalte oder Zelle oder den zu kopierenden Abschnitt aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Ziehen Sie die Kopie bei gedrückter Steuerungstaste an die neue Position.
      •
      Wählen Sie „Bearbeiten“ > „Kopieren“ aus, klicken Sie auf die Stelle, an der das Objekt eingefügt werden soll, und wählen Sie dann „Bearbeiten“ > „Einfügen“ aus.
      •
      Wählen Sie „Bearbeiten“ > „Duplizieren“. Dieser Befehl steht für einzelne Zellen oder Zellen in Zeilen nicht zur Verfügung.
Zum Erstellen mehrerer positionierter und ausgerichteter Kopien wählen Sie im Menü „Bearbeiten“ die Option „Mehrere kopieren“. Dieser Befehl steht für einzelne Zellen oder Zellen in Zeilen nicht zur Verfügung.


So verschieben Sie eine Tabelle

1.
Wählen Sie die Tabelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Klicken Sie auf den oberen oder linken Rand der Tabelle, bis der Zeiger zum Verschieben [image] eingeblendet wird. Ziehen Sie die Tabelle an die neue Position.


So springen Sie zu einer bestimmten Zeile

Wenn Sie mit einer sehr langen Tabelle arbeiten, können Sie zu einer bestimmten Zeile (Kopf-, Text- oder Fußzeile) wechseln.
1.
Wählen Sie einen Teil der Tabelle aus und klicken Sie auf „Tabelle“ > „Gehe zu Zeile“.
2.
Wählen Sie „Kopfzeile“, „Textzeile“ oder „Fußzeile“ aus.
Sie können auch zu bestimmten Kopf- oder Fußzeilen in einem Abschnitt wechseln.
3.
Geben Sie die Nummer der Zeile ein, zu der Sie wechseln möchten, und klicken Sie auf „OK“.


Info über das Navigieren in Tabellen in barrierefreien Formularen

In barrierefreien Formularen informiert die Bildschirmlesehilfe über die Position des Cursors innerhalb einer Tabelle. Wenn sich der Benutzer zwischen den Tabellenzellen eines Formulars bewegt, informiert die Bildschirmlesehilfe über die Inhalte der Zelle. Wenn sich der Benutzer zu einer Zelle mit einer verschachtelten Tabelle bewegt, informiert die Bildschirmlesehilfe über den Inhalt der Zelle und der verschachtelten Tabelle.
Die editierbaren Felder einer verschachtelten Tabelle sind Teil der Tab-Reihenfolge innerhalb des Formulars. Daher bewegt sich der Benutzer zwischen editierbaren Feldern in einer verschachtelten Tabelle mithilfe der Pfeiltasten. Wenn der Benutzer die verschachtelte Tabelle öffnet oder diese verlässt, werden Anfang und Ende der Tabelle ausgegeben.
Wenn Sie JAWS verwenden, werden Anfang und Ende der verschachtelten Tabelle nicht im virtuellen Cursor-Modus ausgegeben.

Ergebnis

Aktion
Die Bildschirmlesehilfe gibt die aktuelle Tabellenzelle aus.
Strg+Alt+5 (Zehnertastatur)
Horizontal zwischen den Zellen wechseln
Strg+Alt+Linker oder rechter Pfeil
Vertikal zwischen den Zellen wechseln
Strg+Alt+Nach-oben- oder Nach-unten-Taste
Verwandte Themen
Tastaturbefehle anpassen
Barrierefreie Formulare
Allgemeine Überlegungen beim Entwurf barrierefreier Formulare
Unterstützung für Bildschirmlesehilfen
Entwurftipps für das Konzipieren von Formularen für Bildschirmlesehilfen


Einfügen und Löschen

So fügen Sie Zeilen, Spalten oder Abschnitte ein
So löschen Sie Tabellen, Zeilen, Spalten oder Abschnitte


So fügen Sie Zeilen, Spalten oder Abschnitte ein

1.
Wählen Sie einen Teil der Tabelle aus.
2.
Wählen Sie „Tabelle“ > „Einfügen“ und wählen Sie eine Option aus.
Wenn Sie einen Abschnitt einfügen, wird diesem Abschnitt in LiveCycle Designer standardmäßig eine Kopfzeile hinzugefügt.


So löschen Sie Tabellen, Zeilen, Spalten oder Abschnitte

So löschen Sie eine Tabelle
1.
Wählen Sie die Tabelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Wählen Sie „Tabelle“ > „Löschen“ aus und klicken Sie auf „Tabelle“.
Sofern es sich nicht um eine verschachtelte Tabelle handelt, können Sie die Tabelle auch über den Pfad „Bearbeiten“ > „Löschen“ löschen.
So löschen Sie Zeilen, Spalten oder Abschnitte
1.
Wählen Sie die Zeilen, Spalten oder Abschnitte aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Wählen Sie „Tabelle“ > „Löschen“ aus und klicken Sie dann auf „Zeile“, „Spalte“ oder „Abschnitt“.


Tabellen formatieren

So fügen Sie einen Tabellentitel hinzu
So legen Sie den Abstand um eine Tabelle herum fest
So legen Sie einen Abstand um Zellen herum fest
So legen Sie einen Abstand um Zeilen herum fest
So wenden Sie Rahmen und Schattierungen auf eine Tabelle an
So verteilen Sie Zeilen und Spalten gleichmäßig
So formatieren Sie die Ecken von Tabellen oder Zellen
So erstellen Sie ein Tabellenformat für die benutzerdefinierte Bibliothek
So zeigen Sie Beschriftungen in Zeilen an
So erstellen Sie einen Kalender mit Hilfe einer Tabelle


So fügen Sie einen Tabellentitel hinzu

1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie das Textobjekt [image] über die Tabelle.
2.
Doppelklicken Sie auf den Standardtext im Objekt und geben Sie den Titel ein.
3.
Legen Sie die Einstellungen für die Schrift fest.
Sie können auch die Zellen in der ersten Tabellenzeile zusammenführen und den Titel in die kombinierte Zelle eingeben.


So legen Sie den Abstand um eine Tabelle herum fest

Sie können mit Hilfe von Rändern einen leeren Bereich um die Tabelle herum einfügen.
1.
Wählen Sie die Tabelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Legen Sie in der Palette „Layout“ den rechten, linken, oberen und unteren Rand fest.


So legen Sie einen Abstand um Zellen herum fest

Sie können mit Hilfe von Rändern einen leeren Bereich um die Zellen herum einfügen.
1.
Wählen Sie die Zelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Legen Sie in der Palette „Layout“ den rechten, linken, oberen und unteren Rand fest.


So legen Sie einen Abstand um Zeilen herum fest

Sie können mit Hilfe von Rändern einen leeren Bereich um die Zeilen herum einfügen. In der folgenden Tabelle wurde beispielsweise ein Abstand von etwa 6 mm gewählt.
1.
Wählen Sie die Zeile aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Legen Sie in der Palette „Layout“ den rechten, linken, oberen und unteren Rand fest.


So wenden Sie Rahmen und Schattierungen auf eine Tabelle an

Durch Rahmen und Schattierungen kann die Tabelle ansprechender gestaltet werden. Sie können einer Tabelle oder einer einzelnen Zeile, Spalte oder Zelle einen Rahmen hinzufügen. Durch Schattierungen können Sie den Hintergrund einer Tabelle ausfüllen.
Es stehen schraffierte und abwechselnde Schattierungsmuster zur Verfügung. Außerdem haben Sie die Möglichkeit, die Anzahl der farbig unterlegten Zeilen und Spalten festzulegen und dem Schattierungsmuster eine Farbe zuzuweisen.
So wenden Sie Rahmen und Schattierungen auf eine Tabelle an
1.
Wählen Sie die Tabelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Um nur bestimmten Seiten einen Rahmen zuzuweisen, wählen Sie in der Palette „Rand“ in der Liste „Kanten“ die Option „Einzeln bearbeiten“ aus. Nun können Sie den Rahmen für jede Seite festlegen.
      •
      Um denselben Rahmen an allen Seiten einzufügen, wählen Sie in der Liste „Kanten“ die Option „Zusammen bearbeiten“ aus.
3.
Wählen Sie in der Liste mit den Linientypen eine Option aus und wählen Sie in der Farbauswahl eine Farbe aus.
4.
Wählen Sie zum Zuweisen einer Schattierung in der Liste „Stil“ ein Schattierungsformat und in der Farbauswahl eine Farbe aus.
So entfernen Sie Rahmen oder Schattierungen aus einer Tabelle
1.
Wählen Sie die Tabelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Wählen Sie in der Palette „Rand“ in der Liste „Kanten“ die Option „Zusammen bearbeiten“ aus.
3.
Wählen Sie in der Liste mit den Linientypen die Option „Ohne“ aus.
So wenden Sie eine schraffierte oder abwechselnde Schattierung auf Zeilen an
1.
Wählen Sie die Tabelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Zeilenschattierung“ und wählen Sie „Abwechselnde Zeilenschattierung anwenden“ aus.
3.
Legen Sie für die erste Zeile bzw. die erste Zeilengruppe eine Farbe fest.
4.
Legen Sie für die nächste Zeile bzw. Zeilengruppe eine Farbe fest.
Wenn Sie in der Palette „Rand“ für eine Zelle eine Schattierung verwenden, wird dadurch eine eventuell für die Tabelle festgelegte Zeilenschattierung überschrieben.
So entfernen Sie eine schraffierte oder abwechselnde Schattierung aus Zellen
      *
      Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Zeilenschattierung“ und heben Sie die Auswahl von „Abwechselnde Zeilenschattierung anwenden“ auf.


So verteilen Sie Zeilen und Spalten gleichmäßig

Sie können mehreren Zeilen bzw. Spalten die gleiche Größe zuweisen. Alle Zeilen werden an die Höhe der höchsten ausgewählten Zeile angepasst. Alle Spalten erhalten die gleiche Breite, basierend auf der Breite der Tabelle. Die Tabelle selbst bleibt unverändert.
1.
Wählen Sie die Zeilen bzw. Spalten aus, die die gleiche Größe erhalten sollen. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Wählen Sie „Tabelle“ > „Zeilen gleichmäßig verteilen“ oder „Spalten gleichmäßig verteilen“.
Wenn Sie zuvor den Befehl „Zellen zusammenführen“ verwendet haben, sind die ursprünglichen Spalten noch vorhanden, allerdings nicht zu sehen. (Sie können die Zellen ggf. wieder teilen.) Um Spalten mit zusammengeführten Zellen die gleiche Größe zuzuweisen, müssen Sie zunächst die verborgenen Spalten mit dem Befehl „Tabelle“ > „Löschen“ > „Spalte“ löschen.


So formatieren Sie die Ecken von Tabellen oder Zellen

Sie können einer Tabelle oder bestimmten Zellen in einer Tabelle runde oder ausgestanzte Ecken zuweisen.
So formatieren Sie die Ecken von Tabellen oder Zellen
1.
Wählen Sie die Tabelle bzw. die Zellen aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Wählen Sie in der Palette „Rand“ eine der Optionen für Ecken aus.
3.
Geben Sie im Feld „Radius“ den gewünschten Wert ein. In der obigen Abbildung wurden beispielsweise 2 mm verwendet.
So entfernen Sie den Rahmen von der gesamten Tabelle
      *
      Wählen Sie die Tabelle aus und wählen Sie in der Palette „Rand“ in der Liste mit den Linientypen die Option „Ohne“ aus.


So erstellen Sie ein Tabellenformat für die benutzerdefinierte Bibliothek

Sie können Ihre eigenen Tabellenformate erstellen, um Tabellen einheitliche Rahmen, Schattierungen, Ausrichtungen und Schriften zuzuweisen. So können Sie zum Beispiel die folgende Tabelle erstellen und dann zur Wiederverwendung auf der Registerkarte „Eigene“ in der Palette „Bibliothek“ speichern.
1.
Erstellen Sie eine Tabelle.
2.
Legen Sie das gewünschte Format für den Rahmen, die Schattierung, die Zelltypen, die Zellausrichtung und die Schrift fest.
3.
Stellen Sie sicher, dass die Kategorie „Eigene“ in der Palette „Bibliothek“ geöffnet ist.
4.
Wählen Sie die Tabelle aus und ziehen Sie sie in die Kategorie „Eigene“ der Palette „Bibliothek“.
5.
Geben Sie im Dialogfeld „Bibliotheksobjekt hinzufügen“ einen Namen für das Tabellenformat ein und klicken Sie dann auf „OK“.
Sie können auch eine Beschreibung hinzufügen und im Listenfeld „Registerkarte“ ggf. eine andere Registerkarte auswählen.


So zeigen Sie Beschriftungen in Zeilen an

Standardmäßig werden für Felder in Zellen keine Beschriftungen angezeigt. So verfügen die folgenden Objekte zwar über Beschriftungen, diese werden jedoch ausgeblendet, wenn sich das Feld in einer Zelle befindet.
      •
      Kontrollkästchen
      •
      Datums-/Uhrzeitfeld
      •
      Dezimalfeld
      •
      Dokumentunterschriftsfeld
      •
      Dropdown-Liste
      •
      Bildfeld
      •
      Listenfeld
      •
      Numerisches Feld
      •
      Kennwortfeld
      •
      Textfeld
Sie können die Beschriftung in einigen Tabellen anzeigen. Im folgenden Formular werden die Informationen in einer Tabelle dargestellt. Bei jeder Zeile unterhalb der Kopfzeile handelt es sich um eine Zelle.
1.
Wählen Sie die Zelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Wählen Sie in der Palette „Layout“ in der Liste „Position“ die gewünschte Position der Beschriftung aus.


So erstellen Sie einen Kalender mit Hilfe einer Tabelle

Sie können einen Kalender mit Hilfe einer Tabelle erstellen.
1.
Wählen Sie „Ansicht“ > „Masterseiten“.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Masterseite“ und wählen Sie die Option „Querformat“ aus.
3.
Klicken Sie auf die Registerkarte „Designansicht“.
4.
In der Palette „Bibliothek“ wählen Sie „Tabelle“ > „Tabelle einfügen“.
5.
Geben Sie im Dialogfeld „Tabelle einfügen“ für die Spalten den Wert 7 und für die Zeilen den Wert 6 ein.
6.
Wählen Sie „Kopfzeile in Tabelle einschließen“ aus und klicken Sie auf „OK“.
7.
Ziehen Sie die Tabelle an den oberen Rand der Seite.
8.
Ändern Sie die Größe der Spalten so, dass die Tabelle die gesamte Breite der Seite ausfüllt.
9.
Wählen Sie „Tabelle“ > „Spalten gleichmäßig verteilen“.
10.
Wählen Sie die letzte Zeile in der Tabelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
11.
Geben Sie in der Palette „Layout“ im Feld „Höhe“ den Wert 1.1in ein.
12.
Wählen Sie die Tabelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
13.
Wählen Sie „Tabelle“ > „Zeilen gleichmäßig verteilen“.
14.
Wählen Sie die erste Zeile in der Tabelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
15.
Wählen Sie „Tabelle“ > „Zellen zusammenführen“.
16.
Geben Sie den Monat ein und legen Sie in der Palette „Schrift“ die Schrifteigenschaften fest.
17.
Geben Sie in der zweiten Zeile die Wochentage ein und legen Sie die Schrifteigenschaften fest.
18.
Geben Sie in den übrigen Zellen die Nummern der Tage ein und legen Sie die Schrifteigenschaften fest.


Tabellen ausrichten, anpassen und anordnen

So richten Sie eine Tabelle an anderen Objekten aus
So richten Sie den Inhalt einer Zelle aus
So passen Sie die Größe eines anderen Objektes an die Tabellengröße an
So ändern Sie die Größe der gesamten Tabelle
So ändern Sie die Größe von Zeilen und Spalten
So zentrieren Sie eine Tabelle
So ordnen Sie eine Tabelle und andere Objekte an


So richten Sie eine Tabelle an anderen Objekten aus

1.
Wählen Sie die Tabelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Wählen Sie bei gedrückter Steuerungstaste das andere auszurichtende Objekt aus.
3.
Wählen Sie eine der folgenden Optionen aus.

Aufgabe

Option
Ausrichten der linken Kanten der Objekte
„Layout“ > „Ausrichten“ > „Links“
Ausrichten der rechten Kanten der Objekte
„Layout“ > „Ausrichten“ > „Rechts“
Ausrichten der oberen Kanten der Objekte
„Layout“ > „Ausrichten“ > „Oben“
Ausrichten der unteren Kanten der Objekte
„Layout“ > „Ausrichten“ > „Unten“
Ausrichten der vertikalen Mittelpunkte der Objekte
„Layout“ > „Ausrichten“ > „Vertikal zentriert“.
Ausrichten der horizontalen Mittelpunkte der Objekte
„Layout“ > „Ausrichten“ > „Horizontal zentriert“.


So richten Sie den Inhalt einer Zelle aus

Sie können die horizontale und vertikale Ausrichtung des Inhalts einer Zelle ändern.
1.
Wählen Sie die Zelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Wählen Sie in der Palette „Absatz“ eine der folgenden Ausrichtungsoptionen aus:

Aufgabe

Option
Linksbündige Ausrichtung des Zelleninhalts
„Linksbündig“
Mittige Ausrichtung des Zelleninhalts
„Zentrieren“
Rechtsbündige Ausrichtung des Zelleninhalts
„Rechtsbündig“
Inhalt gleichmäßig in der Zelle verteilen
Der Blocksatz wird auf alle Zeilen mit Ausnahme der letzten Zeile in einer mehrzeiligen Zelle angewendet. (Einzeilige Absätze können nicht im Blocksatz ausgerichtet werden.)
„Blocksatz“
Ausrichtung am oberen Rand der Zelle
„Oben ausrichten“
Ausrichtung am Mittelpunkt der Zelle
„Zentriert ausrichten“
Ausrichtung am unteren Rand der Zelle
„Unten ausrichten“


So passen Sie die Größe eines anderen Objektes an die Tabellengröße an

Sie können die Größe eines Objekts an die Größe einer Tabelle im Formular anpassen. So können Sie einem Rechteck beispielsweise die Breite der Tabelle zuweisen. Dann ist es möglich, einem Bereich des Formulars ein Teilungselement oder eine Umrandung hinzuzufügen. Die Größe anderer Objekte kann an die Größe einer Tabelle angepasst werden, Tabellen können jedoch nicht die Größe anderer Objekte übernehmen.
1.
Wählen Sie das Objekt aus, das die Größe der Tabelle annehmen soll.
2.
Wählen Sie bei gedrückter Steuerungs- oder Umschalttaste die Tabelle aus. Sie müssen die Tabelle zuletzt auswählen.
3.
Klicken Sie auf „Layout“ > „Gleiche Größe“ und wählen Sie „Breite“, „Höhe“ oder „Beide“ aus.
Das erste Objekt übernimmt die Größe des zuletzt ausgewählten Objekts.


So ändern Sie die Größe der gesamten Tabelle

Sie können die Größe einer ganzen Tabelle ändern. Die Größenänderung erfolgt immer am unteren oder rechten Rand der Tabelle. Wenn Sie die Größe der Tabelle oder der letzten Spalte außerhalb des Inhaltsbereichs ändern möchten, ändern Sie in der Palette „Layout“ die Breite.
1.
Wählen Sie die Tabelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Zeigen Sie mit der Maus auf den Rand der Tabelle, bis ein Doppelpfeil angezeigt wird.
3.
Ziehen Sie den Tabellenrand, bis die gewünschte Größe erreicht ist.


So ändern Sie die Größe von Zeilen und Spalten

Sie können die Größe von Zeilen und Spalten ändern. Die Größenänderung erfolgt immer am unteren, linken oder rechten Rand der Zeile bzw. Spalte. Wenn Sie die Größe der letzten Spalte außerhalb des Inhaltsbereichs ändern möchten, ändern Sie in der Palette „Layout“ die Breite.
1.
Zeigen Sie mit der Maus auf den Rand der Zeile oder Spalte, bis ein Doppelpfeil angezeigt wird.
2.
Ziehen Sie den Zeilen- bzw. Spaltenrand, bis die gewünschte Größe erreicht ist.


So zentrieren Sie eine Tabelle

1.
Wählen Sie die Tabelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Klicken Sie auf „Layout“ > „Auf Seite zentrieren“ und wählen Sie entweder „Horizontal“ oder „Vertikal“ aus.


So ordnen Sie eine Tabelle und andere Objekte an

Sie können steuern, wie Objekte sich überlappen, indem Sie sie vor oder hinter andere Objekte schieben. So können Sie beispielsweise ein Wasserzeichen hinter einer Tabelle anbringen.
1.
Wählen Sie die Tabelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Wählen Sie eine der folgenden Optionen:
      •
      Um die Tabelle schrittweise nach vorne zu bringen, wählen Sie „Layout“ > „Eine Ebene nach vorne“.
      •
      Um die Tabelle ganz nach vorne zu bringen, wählen Sie „Layout“ > „In den Vordergrund“.
      •
      Um die Tabelle schrittweise nach hinten zu bringen, wählen Sie „Layout“ > „Eine Ebene nach hinten“.
      •
      Um die Tabelle ganz nach hinten zu bringen, wählen Sie „Layout“ > „In den Hintergrund“.


Mit Daten in Tabellen arbeiten

So erstellen Sie eine Tabelle aus einer Datenquelle
So legen Sie für die Zeilen in einer Tabelle die Größenanpassung an die Datenmenge fest
So erstellen Sie eine Tabelle mit gruppierten Daten
So kennzeichnen Sie eine Tabelle als optional
So führen Sie Berechnungen in einer Tabelle durch


So erstellen Sie eine Tabelle aus einer Datenquelle

Bestimmte Daten einer Datenquelle können in Tabellen angezeigt werden. Wenn Sie eine Verbindung zu einer Datenquelle herstellen, werden in der Palette „Datenansicht“ alle Elemente markiert, bei denen es sich um Tabellen handeln könnte. Darüber hinaus wird angezeigt, welche Elemente zu Zeilen werden, wenn LiveCycle Designer eine sich wiederholende Datengruppe findet.
Nachdem Sie die Verbindung zur Datenquelle hergestellt haben, können Sie Elemente aus der Palette „Datenansicht“ auf den Formularentwurf ziehen und so einfach und schnell an die Datenquelle gebundene Felder erstellen. Wenn Sie ein Element aus der Palette „Datenansicht“ auf den Formularentwurf ziehen , wird in LiveCycle Designer eine Tabelle erstellt. Wenn Sie dann eine Datendatei auswählen, wird zur Laufzeit eine Tabelle wie die folgende angezeigt. Die sich wiederholende Datengruppe in der Datendatei verfügt über vier Datensätze.
1.
Stellen Sie sicher, dass eine Verbindung zu einer Datenquelle besteht. Siehe Info über das Herstellen einer Verbindung zu einer Datenquelle.
Wenn die mit LiveCycle Designer gelieferten Musterdateien installiert wurden, können Sie zum Beispiel das folgende Schema öffnen: „Purchase Order.xsd“ im Dialogfeld „Datenverbindung“.
2.
Suchen Sie in der Palette „Datenansicht“ einen Datenknoten, bei dem es sich um eine Tabelle handeln könnte. Suchen Sie zum Beispiel den folgenden item-Knoten:
3.
Wählen Sie den Knoten aus und ziehen Sie ihn auf den Formularentwurf. Auf dem Entwurf sollte nun Folgendes angezeigt werden:
In der Palette „Datenansicht“ wird angezeigt, dass der Knoten an ein Objekt gebunden ist.
4.
Zum Auswählen einer Datendatei wählen Sie „Datei“ > „Formulareigenschaften“ und klicken Sie auf die Registerkarte „Standard“. Navigieren Sie zum Speicherort der gewünschten Datendatei.
Wenn die mit LiveCycle Designer gelieferten Musterdateien installiert wurden, können Sie zum Beispiel die Datendatei „Purchase Order.xml“ öffnen.
5.
Zeigen Sie auf der Registerkarte „PDF-Vorschau“ eine Vorschau des Formulars an.
LiveCycle Designer erstellt automatisch eine Tabelle, die dynamisch mit der Menge der Daten in der Datenquelle wächst bzw. schrumpft.


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Tabellen verwenden > Mit Daten in Tabellen arbeiten > So legen Sie für die Zeilen in einer Tabelle die Größenanpassung an die Datenmenge fest

So legen Sie für die Zeilen in einer Tabelle die Größenanpassung an die Datenmenge fest

Wenn Sie bereits eine Tabelle mit einer festen Anzahl von Spalten und Zeilen erstellt haben, können Sie diese nachträglich noch in eine dynamische Tabelle konvertieren, deren Größe an die Datenmenge in der Datenquelle angepasst wird. Zum Konvertieren der Tabelle müssen Sie für das Teilformular, das die Tabelle enthält, die Einstellung „Textfluss“ festlegen und die entsprechende(n) Textzeile(n) als sich wiederholend definieren.
1.
Erstellen Sie eine Tabelle. Siehe So erstellen Sie eine einfache Tabelle.
2.
Wählen Sie die Zeilen unterhalb der ersten Zeile (die nicht die Kopfzeile ist) aus.
Bei Tabellen mit einer festen Anzahl von Spalten, bei denen sich jedoch die Anzahl der Zeilen je nach der Menge der Daten in der Datenquelle ändert, ist nur eine Zeile erforderlich. Daher müssen Sie außer der ersten Zeile in der Tabelle alle Zeilen löschen. Die Fußzeile kann bestehen bleiben.
3.
Wählen Sie „Tabelle“ > „Löschen“ > „Zeile“.
4.
Speichern Sie das Formular als „Acrobat 7.0 (Dynamisch) XML-Formular (*.pdf)“.
5.
Wählen Sie in der Palette „Hierarchie“ das Teilformular aus, das die Tabelle enthält.
6.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Teilformular“ und wählen Sie anschließend in der Liste „Inhalt“ die Option „Textfluss“ aus.
7.
Wählen Sie in der Palette „Hierarchie“ die Textzeile (z. B. „Zeile1“) aus.
8.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und aktivieren Sie die Option „Zeile für jedes Datenelement wiederholen“.
9.
Stellen Sie eine Verbindung zu einer Datenquelle her. Siehe Info über das Herstellen einer Verbindung zu einer Datenquelle.
Sie müssen eine Verbindung zu einer Datenquelle wie beispielsweise einem XML-Schema herstellen, damit Daten in der Tabelle angezeigt werden können.
10.
Wählen Sie eine Datendatei aus. Siehe So testen Sie ein Formular mit Musterdaten.
Sie müssen eine Datendatei auswählen, wenn Sie das Formular mit Daten anzeigen und testen möchten.
11.
Zeigen Sie auf der Registerkarte „PDF-Vorschau“ eine Vorschau des Formulars an.


So erstellen Sie eine Tabelle mit gruppierten Daten

Die Daten in einer Tabelle können gruppiert werden. Durch die Gruppierung werden die Daten in eine Beziehung zueinander gebracht, beispielsweise als „Land“ oder „Region“. Sie können die Gruppen verschachteln und so Beziehungen und Trends deutlich machen. Auch zusammenfassende Daten wie beispielsweise Zwischen- und Gesamtsummen lassen sich auf diese Weise besser darstellen.
Wenn Sie zum Beispiel Güter wie Monitore, Schreibtischleuchten und Telefone verkaufen, möchten Sie vielleicht wissen, in welchem Land und in welcher Region die meisten Produkte verkauft werden. Sie können die folgende Tabelle erstellen, die innerhalb der Haupttabelle eine verschachtelte Tabelle enthält, in der wiederum eine weitere Tabelle eingebettet ist:
      •
      „Land“ ist die Kopfzeile der Haupttabelle.
      •
      „Region“ ist die Kopfzeile der ersten verschachtelten Tabelle.
      •
      „Product“ und „Profit“ sind die Kopfzeile für die in die erste verschachtelte Tabelle eingebettete Tabelle.
Die mit dieser Tabelle verknüpfte XML-Musterdatei könnte die folgende Syntax aufweisen:
<form1>
 <Sales>
  <SalesData>
     <country>United States</country>
     <CountryData>
          <RegionRow>
          <region>Western</region>
     <RegionData>
     <Item>
          <product>Monitor</product>
          <profit>10</profit>
     </Item>
     <Item>
          <product>Desk Lamp</product>
          <profit>20</profit>
     </Item>
     </RegionData>
          </RegionRow>
          <RegionRow>
          <region>Central</region>
     <RegionData>
     <Item>
          <product>Monitor</product>
          <profit>30</profit>
     </Item>
     <Item>
          <product>Desk Lamp</product>
          <profit>25</profit>
     </Item>
     <Item>
          <product>Telephone</product>
          <profit>28</profit>
     </Item>
     </RegionData>
          </RegionRow>
          <RegionRow>
     <region>Atlantic</region>
     <RegionData>
     <Item>
          <product>Monitor</product>
          <profit>31</profit>
     </Item>
     <Item>
          <product>Desk Lamp</product>
          <profit>17</profit>
     </Item>
     <Item>
          <product>Telephone</product>
          <profit>22</profit>
</Item>
          </RegionData>
          </RegionRow>
     </CountryData>
  </SalesData>
 </Sales>
</form1>
Bevor Sie diese Aufgabe ausführen, müssen Sie Folgendes sicherstellen:
      •
      Stellen Sie sicher, dass eine Verbindung zu einer Datenquelle besteht. Siehe Info über das Herstellen einer Verbindung zu einer Datenquelle.
      •
      Um das Formular anhand einer Musterdatendatei zu testen, muss ein Verweis auf diese Datei vorhanden sein. Siehe So testen Sie ein Formular mit Musterdaten.
So erstellen Sie die Haupttabelle
1.
Wählen Sie „Datei“ > „Speichern unter“, geben Sie für die Datei einen Namen ein und wählen Sie „Acrobat 7.0 (Dynamisch) XML-Formular (*.pdf)“ aus. Klicken Sie auf „OK“.
2.
Wählen Sie „Tabelle“ > „Tabelle einfügen“.
3.
Legen Sie im Dialogfeld „Tabelle einfügen“ die gewünschte Anzahl von Spalten und Textzeilen fest. Verwenden Sie beispielsweise zwei Spalten und eine Zeile.
Sie können maximal 20 Spalten und 50 Zeilen auswählen. Im Anschluss an die Tabellenerstellung ist es jedoch möglich, über die Einfügebefehle im Menü „Tabelle“ noch weitere Zeilen und Spalten hinzuzufügen.
4.
(Optional) Um eine Kopfzeile einzufügen, wählen Sie „Kopfzeile in Tabelle einschließen“ aus.
5.
(Optional) Um eine Fußzeile einzufügen, wählen Sie „Fußzeile in Tabelle einschließen“ aus.
6.
Klicken Sie auf „OK“.
7.
Benennen Sie die Überschriftenzeile um. Benennen Sie beispielsweise die erste Überschrift in Country um und löschen Sie den Überschriftentext für die zweite Spalte.
8.
Passen Sie die Größe der Tabelle an.
So erstellen Sie die erste verschachtelte Tabelle
1.
Ziehen Sie das Tabellenobjekt aus der Palette „Bibliothek“ in eine Zelle der Tabelle.
2.
Weisen Sie der Kopfzeile einen anderen Text zu. Benennen Sie beispielsweise die erste Überschrift in Region um und löschen Sie den Überschriftentext für die zweite Spalte.
So erstellen Sie die zweite verschachtelte Tabelle innerhalb der ersten verschachtelten Tabelle
1.
Ziehen Sie das Tabellenobjekt aus der Palette „Bibliothek“ in eine Zelle der Tabelle, um eine weitere verschachtelte Tabelle zu erstellen. Ziehen Sie es beispielsweise in die zweite Zelle der Textzeile in der ersten verschachtelten Tabelle.
2.
Legen Sie im Dialogfeld „Tabelle einfügen“ die gewünschte Anzahl von Spalten und Textzeilen fest.
3.
(Optional) Um eine Kopfzeile einzufügen, wählen Sie „Kopfzeile in Tabelle einschließen“ aus.
4.
(Optional) Um eine Fußzeile einzufügen, wählen Sie „Fußzeile in Tabelle einschließen“ aus.
5.
Klicken Sie auf „OK“.
6.
Benennen Sie die Überschriftenzeile um. Ändern Sie die erste Überschrift beispielsweise in Product und die zweite in Profit.
Das Formular sollte nun folgendermaßen aussehen.
So zeigen Sie Daten in den Zellen an
1.
Ziehen Sie einen Datenknoten aus der Palette „Datenansicht“ in die Zelle unter der ersten Überschrift. Ziehen Sie zum Beispiel den Knoten „country“ in die Zelle unter der Überschrift „Country“.
2.
Wiederholen Sie diesen Schritt für die übrigen Zellen.
Ziehen Sie zum Beispiel den Knoten „region“ in die Zelle unter der Überschrift „Region“. Ziehen Sie den Knoten „product“ in die Zelle unter der Überschrift „Product“. Ziehen Sie den Knoten „profit“ in die Zelle unter der Überschrift „Profit“.
3.
Wählen Sie in der Palette „Hierarchie“ alle Elemente vom Typ „Zeile1“ aus und aktivieren Sie auf der Registerkarte „Bindung“ der Palette „Objekt“ die Option „Zeile für jedes Datenelement wiederholen“.
4.
Passen Sie die Namen der Tabelle, Zeile und Felder an die Namen der XML-Musterdatei an.
Wählen Sie zum Beispiel in der Palette „Hierarchie“ das Element „Tabelle1“ aus. Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und geben Sie im Feld „Standardbindung (Öffnen, Speichern, Senden)“ $record.Sales ein.
Legen Sie die übrigen Standardbindungen wie in dieser Tabelle angegeben fest.

In der Palette „Hierarchie“ auswählen

Für Standardbindung die entsprechende Zeichenfolge festlegen
Row1
SalesData
country
country
Table2
CountryData
Row1
RegionRow[*]
region
region
Table3
RegionData
Row1
Item[*]
product
product
profit
profit
5.
Wählen Sie das Teilformular aus, das die Haupttabelle enthält, und aktivieren Sie auf der Registerkarte „Teilformular“ der Palette „Objekt“ in der Liste „Inhalt“ die Option „Textfluss“.
6.
Formatieren Sie die Tabelle. Fügen Sie beispielsweise Rahmen und Schattierungen hinzu.
7.
Zeigen Sie auf der Registerkarte „PDF-Vorschau“ eine Vorschau des Formulars an.


So kennzeichnen Sie eine Tabelle als optional

Sie können eine Tabelle als optional kennzeichnen, wenn die darin enthaltenen Informationen nicht angezeigt werden sollen oder wenn für die Tabelle keine Daten verfügbar sind.
1.
Stellen Sie eine Verbindung zu einer Datenquelle her. Siehe Info über das Herstellen einer Verbindung zu einer Datenquelle.
Sie müssen eine Verbindung zu einer Datenquelle wie beispielsweise einem XML-Schema herstellen, damit Daten in der Tabelle angezeigt werden können.
2.
Wählen Sie eine Datendatei aus. Siehe So testen Sie ein Formular mit Musterdaten.
Sie müssen eine Datendatei auswählen, wenn Sie das Formular mit Daten anzeigen und testen möchten.
3.
Die Tabelle muss sich in einem Teilformular befinden, für das die Einstellung „Textfluss“ festgelegt wurde.
4.
Wählen Sie die Tabelle aus, bei der sich die Anzahl der Zeilen je nach der Menge der Daten in der Datenquelle ändert. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
Wenn Sie eine Tabelle mit einer festen Anzahl von Zeilen und Spalten auswählen und diese als optional kennzeichnen, wird die Kopfzeile für jedes Datenelement wiederholt. Zum Ändern dieser Tabelle in eine Tabelle, bei der sich die Anzahl der Zeilen je nach der Menge der Daten ändert, müssen Sie die Option „Zeile für jedes Datenelement wiederholen“ für die Kopfzeile deaktivieren und für die Textzeile aktivieren.
5.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und aktivieren Sie die Option „Tabelle für jedes Datenelement wiederholen“.
6.
Deaktivieren Sie die Option „Min-Zähler“.
7.
Zeigen Sie auf der Registerkarte „PDF-Vorschau“ eine Vorschau des Formulars an.
Wenn keine Verbindung zu einer Datenquelle besteht, sollte die Tabelle nicht angezeigt werden. Wenn Sie die Zellen der Tabelle an eine Datenquelle gebunden haben und Daten für die gebundenen Zellen vorhanden sind, sollte die Tabelle angezeigt werden.


So führen Sie Berechnungen in einer Tabelle durch

Mit der sum-Funktion von FormCalc können Sie die Summe der Werte in einer Spalte berechnen. Sie müssen die Berechnungsfunktion in die Fußzeile der Tabelle einfügen.
1.
Wählen Sie die Zelle in der Fußzeile aus, in der die Berechnung durchgeführt werden soll. Wählen Sie beispielsweise die Zelle aus, die der Summe für Quartal 1 (Q1) entspricht.
2.
Wählen Sie in der Liste „Einblenden“ des Skript-Editors den Eintrag „calculate“ aus.
3.
Wählen Sie in der Liste „Sprache“ den Eintrag „FormCalc“ aus.
4.
Wählen Sie in der Liste „Ausführen am“ den Eintrag „Client“ aus.
5.
Geben Sie im Feld „Skriptquelle“ die FormCalc-Berechnung ein.
Geben Sie beispielsweise zum Berechnen der Summe für Q1 folgenden Ausdruck ein:
6.
Klicken Sie auf „Änderungen zu Skriptquelle eingeben“, um das Skript in Ihr Formular einzufügen.
7.
Wiederholen Sie diese Schritte für die Berechnung von Q2 und Q3.
8.
Um die Gesamtsumme pro Land zu berechnen, geben Sie folgenden Ausdruck ein:

sum(Q1 + Q2 + Q3)
9.
Wiederholen Sie die Schritte für die übrigen Zeilensummen.
10.
Zur Berechnung der Summe insgesamt geben Sie folgenden Ausdruck ein:

sum(TotalQ1 + TotalQ2 + TotalQ3)
Um die Daten als „10K“ anzuzeigen, geben Sie auf der Registerkarte „Zelle“ der Palette „Objekt“ im Feld „Anzeigemuster“ den Wert z9'K' ein. Wählen Sie auf der Registerkarte „Wert“ in der Liste „Typ“ den Eintrag „Berechnet - Schreibgeschützt“ aus.


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Tabellen verwenden > Tabellen mit Größenanpassung erstellen

Tabellen mit Größenanpassung erstellen

So erstellen Sie eine Tabelle mit Größenanpassung mit Hilfe des Schaltflächenobjekts


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Tabellen verwenden > Tabellen mit Größenanpassung erstellen > So erstellen Sie eine Tabelle mit Größenanpassung mit Hilfe des Schaltflächenobjekts

So erstellen Sie eine Tabelle mit Größenanpassung mit Hilfe des Schaltflächenobjekts

Sie können eine Tabelle erstellen, der eine Zeile hinzugefügt wird, wenn ein Benutzer auf eine Schaltfläche zum Hinzufügen von Zeilen klickt. Sie können auch eine Schaltfläche zum Löschen von Zeilen einfügen. Sie müssen die Tabelle erstellen, die Schaltflächen hinzufügen und anschließend die Eigenschaften für die Größenanpassung der Tabelle festlegen.
So erstellen Sie eine Tabelle mit Größenanpassung mit Hilfe des Schaltflächenobjekts
1.
In der Palette „Bibliothek“ wählen Sie „Tabelle“ > „Tabelle einfügen“.
2.
Aktivieren Sie im Dialogfeld „Tabelle einfügen“ die Option „Tabelle mit Assistenten erstellen“ und klicken Sie auf „OK“.
3.
Wählen Sie auf der Seite „Textkörperlayout“ des Tabellenassistenten die Option „Textzeilen sind von Daten abhängig“ aus.
Dadurch wird eine Tabelle erstellt, in der je nach der an die Tabelle gesendeten Datenmenge Zeilen hinzugefügt oder daraus entfernt werden.
4.
Legen Sie die Anzahl der Spalten fest und klicken Sie auf „Weiter“.
5.
(Optional) Wählen Sie „Kopfzeile vorhanden“ aus und klicken Sie auf „Weiter“.
6.
(Optional) Wählen Sie „Fußzeile vorhanden“ aus und klicken Sie auf „Weiter“.
7.
(Optional) Wählen Sie „Textzeilen vorhanden, keine Abschnitte“ aus und klicken Sie auf „Weiter“.
8.
(Optional) Wählen Sie „Abwechselnde Zeilenfarben“ aus und klicken Sie auf „Fertig stellen“.
9.
Speichern Sie das Formular als „Acrobat 7.0 (Dynamisch) XML-Formular (*.pdf)“.
Jetzt müssen Sie die Schaltflächen zum Hinzufügen oder Löschen von Zeilen einfügen.
So fügen Sie die Schaltflächen hinzu
1.
Wählen Sie die erste Zelle der Textzeile aus und klicken Sie in der Palette „Objekt“ auf die Registerkarte „Zelle“. Wählen Sie in der Liste „Typ“ den Eintrag „Teilformular“ aus.
Die Zelle muss ein Teilformular sein, um die beiden Schaltflächen aufnehmen zu können.
Sie können auch das Objekt „Teilformular“ aus der Palette „Bibliothek“ in eine Zelle der Tabelle ziehen.
2.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie das Objekt „Schaltfläche“ in eine Zelle der Textzeile. Legen Sie es beispielsweise in der ersten Zelle der Textzeile ab.
3.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und geben Sie im Feld „Beschriftung“ den Text Add Row ein.
4.
Wiederholen Sie die Schritte 2 und 3, um eine Schaltfläche zum Löschen von Zeilen zu erstellen.
5.
Wählen Sie die Schaltfläche zum Hinzufügen von Zeilen aus und wählen Sie im Skript-Editor in der Liste „Einblenden“ den Eintrag „Click“ aus.
6.
Wählen Sie in der Liste „Sprache“ des Skript-Editors den Eintrag „JavaScript“ aus.
7.
Geben Sie folgendes Skript ein:

Table.Row1.instanceManager.addInstance(1);
Um das Skript an Ihr eigenes Formular anpassen zu können, müssen Sie die Beziehung zwischen dem Skript und der Hierarchie des Formulars kennen. In der Hierarchie des aktuellen Formulars liegen beide Schaltflächen im selben Teilformular. Deshalb müssen keine Objekte jenseits der Tabellenstufe angegeben werden.
8.
Klicken Sie auf „Änderungen zu Skriptquelle eingeben“, um das Skript in Ihr Formular einzufügen.
9.
Wählen Sie die Schaltfläche zum Löschen von Zeilen aus und wählen Sie im Skript-Editor in der Liste „Einblenden“ den Eintrag „Click“ aus.
10.
Wählen Sie in der Liste „Sprache“ des Skript-Editors den Eintrag „JavaScript“ aus.
11.
Geben Sie folgendes Skript ein:

Table.Row1.instanceManager.removeInstance(1);
Um diese Schaltflächen in einem anderen Formular wiederzuverwenden, können Sie sie zur Kategorie „Eigene“ (oder zu Ihrer eigenen Kategorie) in der Palette „Bibliothek“ hinzufügen. Hinweis: Sie müssen die Skripten für die beiden Schaltflächen unter Umständen ändern und an das andere Formular anpassen.
12.
Klicken Sie auf „Änderungen zu Skriptquelle eingeben“, um das Skript in Ihr Formular einzufügen.
13.
Zeigen Sie auf der Registerkarte „PDF-Vorschau“ eine Vorschau des Formulars an.
Sie würden beispielsweise Folgendes sehen, wenn Sie die Artikeltabelle in der Vorlage „Bestellung“ bearbeitet hätten.


Mit Paginierung, Kopfzeilen und Fußzeilen in Tabellen arbeiten

So richten Sie eine Tabelle über mehrere Seiten hinweg ein
So wiederholen Sie eine Kopf- oder Fußzeile auf Folgeseiten
So wandeln Sie eine Zeile in eine Kopf-, Fuß- oder Textzeile um
So steuern Sie Tabellen-, Kopfzeilen-, Textzeilen-, Fußzeilen- und Abschnittsumbrüche mit Hilfe von bedingten Anweisungen


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Tabellen verwenden > Mit Paginierung, Kopfzeilen und Fußzeilen in Tabellen arbeiten > So richten Sie eine Tabelle über mehrere Seiten hinweg ein

So richten Sie eine Tabelle über mehrere Seiten hinweg ein

Damit sich eine Tabelle automatisch über mehrere Seiten hinweg erstrecken kann, müssen folgende Voraussetzungen erfüllt sein:
      •
      Die Tabelle muss in einem Teilformular liegen, für das auf der Registerkarte „Teilformular“ der Palette „Objekt“ die Einstellung „Textfluss“ aktiviert wurde.
      •
      Auf der Registerkarte „Tabelle“ muss die Option „Seitenumbrüche im Inhalt zulassen“ aktiviert sein.
      •
      Die Tabelle darf sich nicht in einer Gruppe befinden.
Sie können die Tabelle nun so konfigurieren, dass die Informationen genau an der gewünschten Stelle angezeigt werden, wenn die Tabelle sich über mehrere Seiten hinweg erstreckt. Bei einer mehrseitigen Tabelle können Sie oben auf der nächsten Seite ein Tag für die Tabellenfortsetzung einfügen.
Wenn die Kopfzeile auch auf der nächsten Seite angezeigt werden soll, gehen Sie wie unter So wiederholen Sie eine Kopf- oder Fußzeile auf Folgeseiten beschrieben vor.
So richten Sie eine Masterseite mit dem Tag Tabellenfortsetzung ein
1.
Erstellen Sie eine Tabelle, deren Größe durch die Datenmenge in der Datenquelle bestimmt wird. Siehe So legen Sie für die Zeilen in einer Tabelle die Größenanpassung an die Datenmenge fest.
2.
Wählen Sie die Kopfzeile aus.
3.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Paginierung“ und wählen Sie „Kopfzeile in aufeinander folgenden Seiten“ aus.
4.
Klicken Sie (wenn nötig) auf „Ansicht“ > „Masterseiten“, um die Registerkarte „Masterseiten“ einzublenden.
5.
Klicken Sie auf die Registerkarte „Masterseiten“ und wählen Sie „Einfügen“ > „Neue Masterseite“ aus.
6.
Verkleinern Sie den Inhaltsbereich auf dieser neuen Masterseite.
7.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie das Textobjekt [image] über den Inhaltsbereich.
8.
Doppelklicken Sie auf den Standardtext im Objekt und geben Sie Fortsetzung Tabelle ein.
9.
Wählen Sie den Text aus und formatieren Sie ihn in der Palette „Schrift“ fett und kursiv.
10.
Benennen Sie in der Palette „Hierarchie“ den Inhaltsbereich „(unbenannt - Inhaltsbereich)“ auf Seite 2 in „Page2ConentArea“ um.
So legen Sie die Paginierung für die Tabelle fest
1.
Wählen Sie im Layout-Editor auf der Registerkarte „Designansicht“ die Tabelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Tabelle“ und wählen Sie (sofern noch nicht geschehen) „Seitenumbrüche im Inhalt zulassen“ aus.
3.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Paginierung“, klicken Sie neben der Liste „Überlauf“ auf den Pfeil und wählen Sie „Gehe zu Inhaltsbereich > Page2ContentArea“ aus.
So stellen Sie eine Verbindung zu einer Datenquelle her
1.
Stellen Sie sicher, dass eine Verbindung zu einer Datenquelle besteht. Siehe Info über das Herstellen einer Verbindung zu einer Datenquelle.
Wenn die mit LiveCycle Designer gelieferten Musterdateien installiert wurden, können Sie zum Beispiel das folgende Schema öffnen: „Purchase Order.xsd“ im Dialogfeld „Datenverbindung“.
2.
Suchen Sie in der Palette „Datenansicht“ den Knoten „partNum“.
3.
Ziehen Sie den Knoten in die erste Zelle unter die Überschrift „Part No“.
4.
Wiederholen Sie die Schritte 2 und 3 für die Knoten „description“, „quantity“ und „unitPrice“.
So wählen Sie eine Datendatei aus
1.
Wählen Sie „Datei“ > „Formulareigenschaften“ und klicken Sie auf die Registerkarte „Standard“.
Sie müssen eine Datendatei mit genügend Daten für mehrere Seiten auswählen.
2.
Zeigen Sie auf der Registerkarte „PDF-Vorschau“ eine Vorschau des Formulars an.


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Tabellen verwenden > Mit Paginierung, Kopfzeilen und Fußzeilen in Tabellen arbeiten > So wiederholen Sie eine Kopf- oder Fußzeile auf Folgeseiten

So wiederholen Sie eine Kopf- oder Fußzeile auf Folgeseiten

1.
Wählen Sie die Tabellenkopf- bzw. Tabellenfußzeile durch Klicken und Ziehen mit der Maus aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Paginierung“. Führen Sie einen der folgenden Schritte aus:
      •
      Wählen Sie „Kopfzeile in aufeinander folgenden Seiten“ aus.
      •
      Wählen Sie „Fußzeile in aufeinander folgenden Seiten“ aus.
Die Tabelle muss sich in einem Teilformular befinden, für das die Einstellung „Textfluss“ festgelegt wurde.


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Tabellen verwenden > Mit Paginierung, Kopfzeilen und Fußzeilen in Tabellen arbeiten > So wandeln Sie eine Zeile in eine Kopf-, Fuß- oder Textzeile um

So wandeln Sie eine Zeile in eine Kopf-, Fuß- oder Textzeile um

Nachdem Sie eine Tabelle eingefügt haben, können Sie die Zeilen in einen anderen Zeilentyp konvertieren. So können Sie beispielsweise eine Textzeile zu einer Kopfzeile machen und so eine Tabelle innerhalb der Tabelle erstellen. Sie können eine Textzeile aber auch in eine Fußzeile konvertieren und in dieser Zeile eine Übersicht anzeigen, die auf jeder Seite des Formulars erscheinen soll.
1.
Wählen Sie eine Zeile aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Zeile“ und wählen Sie in der Liste „Typ“ ein Element aus.


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Tabellen verwenden > Mit Paginierung, Kopfzeilen und Fußzeilen in Tabellen arbeiten > So steuern Sie Tabellen-, Kopfzeilen-, Textzeilen-, Fußzeilen- und Abschnittsumbrüche mit Hilfe von bedingten Anweisungen

So steuern Sie Tabellen-, Kopfzeilen-, Textzeilen-, Fußzeilen- und Abschnittsumbrüche mit Hilfe von bedingten Anweisungen

LiveCycle Designer bietet die Möglichkeit, benutzerspezifische bedingte Umbrüche für Tabellenobjekte sowie für Kopf-, Text- und Fußzeilen und für Abschnitte zu erstellen. Anders als bei der Paginierung können Sie durch bedingte Umbrüche manuell festlegen, wie die Objekte auf dem Formular umgebrochen werden. Dies geschieht mit einer Reihe von bedingten Anweisungen.
Mit Hilfe der bedingten Anweisungen können Sie die Daten eines Feldes in einer Tabelle, Kopf-, Fuß- oder Textzeile bzw. in einem Abschnitt anhand der vorherigen Instanzen dieses Feldes überprüfen. Die Tabelle, Kopf-, Fuß- oder Textzeile bzw. der Abschnitt kann dann bei einer Änderung der Daten in diesem Feld entsprechend umgebrochen werden.
So können Sie beispielsweise eine Tabelle auf einer Telefonrechnung umbrechen, wenn sich im Feld mit dem Datum der Zahlungsposten eine Änderung ergibt. Die Telefonrechnung wird dann visuell nach Datum umgebrochen, wodurch sie sich leichter lesen lässt.
Neben einer Umbruchbedingung können Sie außerdem einen Überlaufkopf- bzw. Überlauffußbereich definieren und angeben, wo auf dem Formular die nächste Instanz der Tabelle platziert werden soll.
Hierfür muss die Tabelle in einem Teilformular eingebettet sein, für das die Einstellung „Textfluss“ festgelegt wurde.
1.
Wählen Sie eine Tabelle, Kopf-, Fuß- oder Textzeile bzw. einen Abschnitt aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Paginierung“.
3.
Klicken Sie auf die Schaltfläche „Bearbeiten“ und dann auf „Hinzufügen“ [image], um einen neuen bedingten Umbruch zur Liste hinzuzufügen.
4.
Wählen Sie in der Liste „Sprache“ eine Skriptsprache aus. Die bedingte Anweisung für den bedingten Umbruch wird in dieser Sprache erstellt.
5.
Wählen Sie in der Liste „Ausführen am“ aus, wo das Skript ausgeführt werden soll.
6.
Klicken Sie auf „Beispielausdruck einfügen“ [image] und wählen Sie das Formularentwurfsobjekt in der Tabelle, Kopf-, Fuß- oder Textzeile bzw. im Abschnitt aus, das als Vergleichsfeld für den bedingten Umbruch herangezogen werden soll. Sie können auch Ihre eigene bedingte Anweisung in das Feld eingeben. Damit der bedingte Umbruch ordnungsgemäß funktioniert, müssen alle benutzerdefinierten bedingten Anweisungen entweder „true“ (wahr) oder „false“ (falsch) zurückgeben.
7.
Aktivieren Sie „Vor“ oder „Nach“, um festzulegen, an welcher Stelle die Tabelle, Kopf-, Fuß- oder Textzeile bzw. der Abschnitt umgebrochen werden soll. Wählen Sie „Vor“ aus, wenn der Umbruch unmittelbar vor der aktuellen Instanz der Tabelle, Kopf-, Fuß- oder Textzeile bzw. des Abschnitts erfolgen soll. Wählen Sie „Nach“ aus, wenn er unmittelbar danach eingefügt werden soll.
8.
Legen Sie im Feld „Bei“ fest, wo die übrigen Instanzen der umgebrochenen Tabelle, Kopf-, Fuß- oder Textzeile bzw. des Abschnitts abgelegt werden sollen.
9.
Wählen Sie in den Listenfeldern „Kopfbereich“ und „Fußbereich“ die Teilformulare für den Überlaufkopfbereich bzw. Überlauffußbereich für diesen bedingten Umbruch (sofern gewünscht) aus.
10.
Wiederholen Sie die Schritte 2 bis 9 für alle bedingten Umbrüche, die im ausgewählten Objekt eingefügt werden sollen, und klicken Sie auf „OK“, wenn Sie der Liste alle gewünschten Einträge hinzugefügt haben.
Nachdem Sie alle bedingten Umbrüche erstellt haben, sollten Sie überprüfen, in welcher Reihenfolge sie im Dialogfeld „Bedingte Umbrüche bearbeiten“ angezeigt werden. Die bedingten Umbrüche werden von LiveCycle Designer sequenziell in der im Dialogfeld „Bedingte Umbrüche bearbeiten“ angezeigten Reihenfolge von oben nach unten verarbeitet. Alle bedingten Umbrüche, für deren bedingte Anweisung „true“ (wahr) zurückgegeben wird, werden ausgeführt.
Sie können die Reihenfolge der Einträge in der Liste mithilfe der Schaltflächen „Nach oben“ [image] bzw. „Nach unten“ [image] wie gewünscht ändern.
Verwandte Themen
Dialogfeld „Bedingte Umbrüche bearbeiten“
Eigenschaften von Tabellen: „Paginierung“
Eigenschaften von Kopf- und Fußzeilen: Registerkarte „Paginierung“
Eigenschaften von Textzeilen: Registerkarte „Bindung“
Eigenschaften von Abschnitten: Registerkarte „Paginierung“


Mit Zellen und Zelleninhalten arbeiten

So löschen Sie den Inhalt einer Zelle
So können Sie Zellen zusammenführen und teilen
So richten Sie Text vertikal in Zellen aus
So wandeln Sie Zellen in einen anderen Objekttyp um


So löschen Sie den Inhalt einer Zelle

Zellen können nicht gelöscht werden. Sie können jedoch den Inhalt einer Zelle entfernen. Hierdurch wird die Zelle zu einem leeren Textobjekt.
1.
Wählen Sie die Zelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Wählen Sie „Bearbeiten“ > „Inhalt löschen“.


So können Sie Zellen zusammenführen und teilen

Sie können zwei oder mehr nebeneinander liegende Zellen in derselben Zeile zu einer einzigen Zelle zusammenführen. So können Sie beispielsweise mehrere Zellen horizontal zusammenführen und so eine Kopfzeile erzeugen, die sich über mehrere Spalten hinweg erstreckt. Die zusammengeführten Zellen müssen in derselben Zeile liegen.
Die folgenden Abbildungen zeigen eine Tabelle, bevor und nachdem Zellen in der zweiten Zeile zusammengeführt wurden.
Daten aus zwei Zellen können nicht in einer einzigen Zelle zusammengeführt werden. Dies ist nur bei Text möglich. So können Sie beispielsweise die Zellen der Kopfzeile zusammenführen, da es sich bei dem Text in den beiden Zellen um Textobjekte handelt. Wenn Sie jedoch Zellen in Textzeilen zusammenführen, deren Zellen an Elemente in einer Datenquelle gebunden sind, bleibt nur die Zelle ganz links erhalten.
Führen Sie Zellen erst ganz am Ende der Tabellenerstellung zusammen. Wenn eine Tabelle kombinierte Zellen enthält, werden neue Spalten nicht wie sonst üblich hinzugefügt bzw. gelöscht.
So führen Sie Zellen zu einer einzigen Zelle zusammen
1.
Wählen Sie die gewünschten Zellen aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Wählen Sie „Tabelle“ > „Zellen zusammenführen“.
Wenn die Zellen Textobjekte enthalten, wird der Text in LiveCycle Designer kombiniert. Falls die Zellen andere Objekte enthalten, werden die Objekte gelöscht.
Um Spalten mit zusammengeführten Zellen mit dem Befehl „Spalten gleichmäßig verteilen“ die gleiche Größe zuzuweisen, müssen Sie zunächst die verborgenen Spalten mit dem Befehl „Tabelle“ > „Löschen“ > „Spalte“ löschen.
So teilen Sie eine zusammengeführte Zelle
1.
Wählen Sie die zusammengeführte Zelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Wählen Sie „Tabelle“ > „Zelle horizontal teilen“.
Die geteilten Zellen werden zu leeren Textobjekten. Falls es sich bei den ursprünglichen Zellen um Teilformulare gehandelt hat, werden die geteilten Zellen zu leeren Teilformularen. Wenn die zusammengeführte Zelle zum Beispiel ein numerisches Feld war, werden auch alle geteilten Zellen zu numerischen Feldern.
Hinweis: Sie können auch die folgenden beiden Schaltflächen auf der Registerkarte „Zelle“ der Palette „Objekt“ verwenden:

Symbol

Befehl
Zellen zusammenführen
Zelle horizontal teilen


So richten Sie Text vertikal in Zellen aus

Sie können die Ausrichtung in Tabellenzellen so ändern, dass der Text nicht horizontal, sondern vertikal angezeigt wird.
Nur Zellen können gedreht werden. (Bei Zeilen, Spalten, Abschnitten oder einer ganzen Tabelle ist dies nicht möglich.)
1.
Wählen Sie die Zelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Klicken Sie in der Palette „Layout“ auf eine der Drehschaltflächen:
3.
Wählen Sie die gewünschte Ausrichtung aus. Der Text in der obigen Abbildung wurde beispielsweise um 90° gedreht.
4.
Wählen Sie in der Palette „Absatz“ die für die Zelle am besten geeignete Ausrichtung aus. Der vertikale Text im obigen Beispiel wurde rechts und oben ausgerichtet.
Wenn Sie ein vom Benutzer auszufüllendes Feld drehen, müssen die Benutzer die Daten in dem Drehwinkel eingeben.


So wandeln Sie Zellen in einen anderen Objekttyp um

Standardmäßig sind alle Zellen Textobjekte. Textobjekte enthalten schreibgeschützten Text, der nicht geändert werden kann. Sie können Textobjekte für folgende Zwecke nutzen:
      •
      Beschriften von Formularbereichen, z. B. der Überschriften in der Tabelle
      •
      Anweisungen zum Ausfüllen des Formulars zur Verfügung stellen
      •
      Ansprechendere Gestaltung des Formulars
Sie können die Zelle in einen anderen Objekttyp wie ein numerisches Feld oder ein Textfeld umwandeln. Auf diese Weise können Sie das gesamte Formular als Tabelle gestalten.
Eine Zelle kann auch eine Schaltfläche zum Übermitteln von Daten, zum Ausführen von Webdiensten oder Datenbankabfragen oder zum Senden von E-Mail-Nachrichten sein.
Zellen können sogar Teilformulare sein. Teilformulare sind Objekte, die als Container für andere Objekte wie Felder, Bausteinobjekte oder weitere Teilformulare dienen. Sie helfen, Objekte relativ zueinander zu positionieren, und geben Formularentwürfen eine Struktur. Zellen des Typs „Teilformular“ können mehrere Objekte aufnehmen, zum Beispiel zwei Schaltflächen.
Wenn eine Zelle in einen anderen Objekttyp umgewandelt wird, verhält sich dieses Objekt in der Zelle anders, als wenn es isoliert im Formularentwurf platziert wird. So verfügt ein Textfeldobjekt in einer Zelle beispielsweise über keine Beschriftung.
Es gibt verschiedene Möglichkeiten, eine Zelle in einen anderen Objekttyp umzuwandeln. Das Ergebnis hängt dabei davon ab, was sich bereits in der Zelle befand und in welchen Objekttyp Sie die Zelle konvertieren:
      •
      Verwenden Sie die Liste „Typ“ auf der Registerkarte „Zelle“ der Palette „Objekt“.
      •
      Ziehen Sie ein Objekt aus der Palette „Bibliothek“ in eine Zelle.
Je nach Auswahl in der Liste „Typ“ bzw. der Palette „Bibliothek“ und dem aktuellen Inhalt der Zelle wird das vorhandene Objekt durch das neue ersetzt. Wenn Sie eine Zelle in ein Teilformular umwandeln, werden alle bereits in der Zelle vorhandenen Objekte in das Teilformular aufgenommen. Wenn die Zelle beispielsweise schon ein Textfeld enthält, und Sie wählen in der Liste „Typ“ den Eintrag „Teilformular“ aus, wird das Textfeld in das Teilformular aufgenommen (d. h., es wird vom Teilformular umschlossen). Wenn die Zelle bereits ein Textfeld enthält, und Sie wählen in der Liste „Typ“ den Eintrag „Numerisches Feld“ aus, wird das Textfeld durch das numerische Feld ersetzt.
      •
      Ziehen Sie ein vorhandenes Objekt im Formularentwurf außerhalb der Tabelle in eine Zelle. Auf diese Weise bleibt das Aussehen des Objekts erhalten. Wenn Sie beispielsweise ein formatiertes Telefonnummernfeld in eine Zelle ziehen, behält das Feld sowohl seine Größe als auch seine Beschriftung.
Wenn Sie ein Teilformular, das sich außerhalb der Tabelle befindet, in eine Zelle ziehen, wird der Inhalt der Zelle durch das Teilformular ersetzt.
Wenn Sie eine Zelle in ein Textfeld umwandeln, können Sie auf der Registerkarte „Zelle“ der Palette „Objekt“ die Option „Mehrere Zeilen zulassen“ aktivieren, damit mehrere Textzeilen angezeigt werden können.
So wandeln Sie eine Zelle mithilfe der Liste „Typ“ auf der Registerkarte „Zelle“ der Palette „Objekt“ in einen anderen Objekttyp um
1.
Wählen Sie die Zelle aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Zelle“ und wählen Sie in der Liste „Typ“ einen neuen Objekttyp aus.
So wandeln Sie eine Zelle durch Ziehen eines Objekts aus der Palette „Bibliothek“ in einen anderen Objekttyp um
      *
      Ziehen Sie das Objekt aus der Palette „Bibliothek“ in die gewünschte Zelle.
So wandeln Sie eine Zelle durch Ziehen eines Objekts aus dem Formularentwurf in einen anderen Objekttyp um
      *
      Ziehen Sie das vorhandene Objekt im Formularentwurf außerhalb der Tabelle in die gewünschte Zelle.


Mit Tabellenabschnitten arbeiten

So fügen Sie einen Tabellenabschnitt ein
So gruppieren Sie Zeilen als Abschnitt
So kennzeichnen Sie einen Tabellenabschnitt als optional


So fügen Sie einen Tabellenabschnitt ein

In einem Tabellenabschnitt werden mehrere Zeilen zu einer Einheit zusammengefasst. Mit Hilfe von Abschnitten lassen sich Tabellen besser organisieren. Abschnitte können über eine eigene Kopf- und Fußzeile verfügen und so detaillierte, anhand von gemeinsamen Werten gruppierte Informationen anzeigen. Jeder Abschnitt erscheint in einer vorhersagbaren Reihenfolge auf dem Formular. Standardmäßig wird in LiveCycle Designer jedem Abschnitt eine Kopfzeile zugewiesen.
1.
Wählen Sie eine Zelle oder Zeile aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus
2.
Klicken Sie auf „Tabelle“ > „Einfügen“ und wählen Sie dann „Abschnitt oben“ bzw. „Abschnitt unten“ aus.
LiveCycle Designer fügt einen Abschnitt mit einer Kopfzeile und einer Textzeile ein.


So gruppieren Sie Zeilen als Abschnitt

Nachdem Sie eine Tabelle erstellt haben, können Sie die Zeilen als Abschnitte gruppieren. Sie können den einzelnen Abschnitten auch unterschiedliche Zeilenschattierungen zuweisen. Die folgende Tabelle wurde zum Beispiel in vier Abschnitte unterteilt:
So gruppieren Sie Zeilen als Abschnitt
1.
Wählen Sie die zu gruppierenden Zeilen aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Wählen Sie „Tabelle“ > „Als Abschnitt gruppieren“.
LiveCycle Designer zeigt rechts neben den gruppierten Zeilen eine blaue Klammer an, die den Abschnitt kennzeichnet.
So heben Sie die Gruppierung eines Abschnitts auf
      *
      Wählen Sie den Abschnitt aus und klicken Sie auf „Tabelle“ > „Abschnittsgruppierung aufheben“.
Verwandte Themen
So fügen Sie einen Tabellenabschnitt ein
So kennzeichnen Sie einen Tabellenabschnitt als optional


So kennzeichnen Sie einen Tabellenabschnitt als optional

Abschnitte als optional zu kennzeichnen ist nützlich, wenn die in einem Abschnitt enthaltenen Informationen nicht angezeigt werden sollen. In der folgenden Tabelle wurden beispielsweise die Abschnitte 1 und 3 ausgeblendet:
1.
Wählen Sie den Abschnitt aus. Siehe So wählen Sie Tabellen, Zeilen, Spalten, Zellen oder Abschnitte aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und deaktivieren Sie die Option „Abschnitt für jedes Datenelement wiederholen“.
Zum Einblenden eines verborgenen Tabellenabschnitts wählen Sie den Abschnitt aus, aktivieren Sie die Option „Abschnitt für jedes Datenelement wiederholen“, aktivieren Sie die Option „Min-Zähler“ und geben Sie im Feld 1 ein.


In Tabellen mit Auswahlabschnitten arbeiten

Info über Auswahlabschnitte in Tabellen
So erstellen Sie Auswahlabschnitte in Tabellen
So können Sie Zeilen zu Auswahlabschnitten hinzufügen und daraus entfernen
So erstellen Sie Datenbindungen und bedingte Anweisungen für Auswahlabschnitte


Info über Auswahlabschnitte in Tabellen

Bei einem Auswahlabschnitt handelt es sich um einen Abschnitt in einer Tabelle, bei dem die Anzeige bestimmter Zeilen im Abschnitt benutzerspezifisch konfiguriert werden kann.
Die benutzerspezifische Einstellung wird anhand von bedingten Anweisungen auf einzelne Zeilen im Abschnitt angewendet. So können Sie beispielsweise mithilfe eines Auswahlabschnitts festlegen, dass einzelne Instanzen einer bestimmten Zeile je nach dem Wert eines bestimmten Feldes in der Zeile mit anderen Textfarben unterlegt werden.
Verwandte Themen
Dialogfeld „Datenteilformulare bearbeiten“


So erstellen Sie Auswahlabschnitte in Tabellen

Sie können einen Auswahlabschnitt basierend auf einem bereits vorhandenen Abschnitt oder anhand einer Tabellenzeile erstellen.
So erstellen Sie einen Auswahlabschnitt basierend auf einem bereits vorhandenen Abschnitt
1.
Wählen Sie einen Tabellenabschnitt aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Abschnitt“ und wählen Sie in der Liste „Typ“ die Option „Teilformular aus Alternativen auswählen“ aus.
So erstellen Sie einen Auswahlabschnitt anhand einer Zeile
      *
      Wählen Sie eine Zeile in der Tabelle aus und klicken Sie auf „Tabelle“ > „Als Auswahlabschnitt gruppieren“.
Verwandte Themen
Dialogfeld „Datenteilformulare bearbeiten“


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Tabellen verwenden > In Tabellen mit Auswahlabschnitten arbeiten > So können Sie Zeilen zu Auswahlabschnitten hinzufügen und daraus entfernen

So können Sie Zeilen zu Auswahlabschnitten hinzufügen und daraus entfernen

Sie können im Dialogfeld „Datenteilformulare bearbeiten“ Kopf-, Fuß- und Textzeilen zu einem Auswahlabschnitt hinzufügen bzw. daraus entfernen.
Wählen Sie hierfür eine der folgenden Optionen aus:
      •
      Über das Dialogfeld „Datenteilformulare bearbeiten“
      •
      Durch manuelles Bearbeiten des Inhalts durch Ziehen der Teilformularobjekte mithilfe der Palette „Hierarchie“ in den bzw. aus dem Auswahlabschnitt
So fügen Sie einem Auswahlabschnitt eine Kopf-, Fuß- oder Textzeile hinzu
1.
Wählen Sie einen Auswahlabschnitt aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Abschnitt“ und stellen Sie sicher, dass in der Liste „Typ“ die Option „Teilformular aus Alternativen auswählen“ ausgewählt ist.
3.
Klicken Sie auf „Alternativen bearbeiten“.
4.
Klicken Sie auf die Schaltfläche „Hinzufügen“ [image], um einen neuen Eintrag zum Listenelement „Alternative Teilformulare“ hinzuzufügen. Sie können Zeilen auch mithilfe der Palette „Hierarchie“ in den Auswahl-Teilformularsatz ziehen.
Durch das Hinzufügen einer neuen Zeile wird ein Duplikat der derzeit ausgewählten Zeile hinzugefügt. Wenn keine Zeile ausgewählt ist, wird dem Auswahlabschnitt eine neue unbenannte Zeile hinzugefügt.
5.
Sie können den neuen Zeileneintrag mit den Schaltflächen „Nach oben“ [image] und „Nach unten“ [image] an die gewünschte Position verschieben. Die Reihenfolge der Einträge in der Liste „Alternative Teilformulare“ ist wichtig, da sie zur Laufzeit in dieser Reihenfolge verarbeitet werden. Der erste Eintrag, für den „true“ (wahr) zurückgegeben wird, wird auf dem Formular angezeigt.
Durch die obigen Anleitungen werden einem vorhandenen Auswahlabschnitt neue Zeilen hinzugefügt. Wenn Sie auf diese Weise Zeilen hinzufügen, wird in LiveCycle Designer zuerst ein neues Zeilenobjekt erstellt und dieses dann der Tabelle und dem Auswahlabschnitt hinzugefügt. Wenn Sie einem Auswahlabschnitt bereits vorhandene Tabellenzeilen hinzufügen möchten, ziehen Sie die gewünschten Zeilenobjekte aus der Palette „Hierarchie“ in den Auswahlabschnitt.
So entfernen Sie eine Kopf-, Fuß- oder Textzeile aus einem Auswahlabschnitt
1.
Wählen Sie einen Auswahlabschnitt aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Abschnitt“ und wählen Sie „Alternativen bearbeiten“ aus.
3.
Wählen Sie in der Liste „Alternative Teilformulare“ einen Eintrag aus und klicken Sie auf die Schaltfläche „Löschen“ [image].
Wenn Sie eine Zeile mit dem Dialogfeld „Datenteilformulare bearbeiten“ löschen, wird die Zeile vollständig aus dem Formularentwurf entfernt. Wenn Sie die Zeile nur aus dem Auswahlabschnitt, nicht jedoch aus dem Entwurf löschen möchten, müssen Sie sie in der Palette „Hierarchie“ manuell aus dem Auswahlabschnitt ziehen.
Verwandte Themen
Dialogfeld „Datenteilformulare bearbeiten“


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Tabellen verwenden > In Tabellen mit Auswahlabschnitten arbeiten > So erstellen Sie Datenbindungen und bedingte Anweisungen für Auswahlabschnitte

So erstellen Sie Datenbindungen und bedingte Anweisungen für Auswahlabschnitte

Nachdem Sie einen Auswahlabschnitt erstellt haben, können Sie für die verschiedenen Zeilen im Abschnitt Datenbindungen mit oder ohne bedingte Anweisungen definieren. Durch bedingte Anweisungen erhalten Sie eine bessere Kontrolle darüber, wann Zeilen des Auswahlabschnitts im Formular angezeigt werden, als wenn Sie nur eine Datenbindung festlegen.
Sie können allen in der Liste „Alternative Teilformulare“ des Dialogfeldes „Datenteilformulare bearbeiten“ aufgeführten Zeilen einen Datenknoten der Datenverbindung zuweisen. Wenn Sie bedingte Anweisungen verwenden, können Sie einen Ausdruck eingeben, für den zur Laufzeit entweder „true“ (wahr) oder „false“ (falsch) zurückgegeben wird. Nur der erste Eintrag in der Liste „Alternative Teilformulare“, bei dem für eine bedingte Anweisung „true“ (wahr) zurückgegeben wird, wird im Formular angezeigt.
1.
Wählen Sie einen Teilformularsatz aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Abschnitt“ und stellen Sie sicher, dass in der Liste „Typ“ die Option „Teilformular aus Alternativen auswählen“ ausgewählt ist.
3.
Klicken Sie auf „Alternativen bearbeiten“.
4.
Führen Sie einen der folgenden Schritte aus, um eine Datenbindung für eine Zeile im Auswahlabschnitt festzulegen:
      •
      Aktivieren Sie „Teilformular auswählen, dessen Name mit Datenelement oder Attribut übereinstimmt“, um den Zeilen einen Datenknoten anhand des Namens zuzuordnen. In diesem Fall müssen die Namen der zugehörigen Datenknoten mit den Namen der Zeilen im Formularentwurf übereinstimmen.
      •
      Aktivieren Sie die Option „Teilformular über Ausdruck auswählen“, um die Bindung der Zeilen im Formularentwurf an die Datenknoten der Datenverbindung manuell festzulegen.
5.
Wählen Sie in der Liste „Datenverbindung“ die gewünschte Datenquelle für die Datenbindung aus.
6.
Klicken Sie auf „Hinzufügen“ [image], um eine neue Zeile zur Tabelle hinzuzufügen, oder wählen Sie einen Eintrag in der Liste aus. Durch das Hinzufügen einer neuen Zeile wird ein Duplikat der derzeit ausgewählten Zeile hinzugefügt. Wenn keine Zeile ausgewählt ist, wird dem Auswahlabschnitt eine neue unbenannte Zeile hinzugefügt.
7.
Klicken Sie auf die Schaltfläche „Hinzufügen“, um ein neues Teilformular zum Auswahl-Teilformularsatz hinzuzufügen, oder wählen Sie einen vorhandenen Eintrag in der Liste aus. Durch das Hinzufügen eines neuen Teilformulars wird ein Duplikat des derzeit ausgewählten Teilformularobjekts hinzugefügt. Falls kein Teilformular ausgewählt ist, wird dem Auswahl-Teilformularsatz ein neues unbenanntes Teilformular hinzugefügt.
8.
Geben Sie ggf. im Feld „Name“ einen Namen für die neue Zeile ein. Wenn Sie die Bindung anhand des Namens des Datenelements oder Attributs vornehmen, muss der Name in diesem Feld genau dem Namen des zugehörigen Datenknotens entsprechen.
Wenn Sie in Schritt 4 die Option „Teilformular auswählen, dessen Name mit Datenelement oder Attribut übereinstimmt“ aktiviert haben, fahren Sie direkt mit Schritt 12 fort. Andernfalls gehen Sie zu Schritt 9 über.
9.
Klicken Sie auf den Pfeil neben dem Feld „Bindung“ und wählen Sie einen Datenknoten im Popup-Menü aus. LiveCycle Designer füllt das Feld „Bindung“ automatisch mit einem Skriptverweis auf den ausgewählten Datenknoten aus. Sie können den Verweis auch manuell in das Feld eingeben.
10.
Wählen Sie in der Liste „Sprache“ eine Skriptsprache aus.
11.
Geben Sie im Feld „Ausdruck“ das Skript für die gewünschten Aktionen oder die Verarbeitung der angegebenen Zeile und des Datenknotens ein.
12.
Wiederholen Sie die Schritte 6 bis 10 für alle weiteren Zeilen im Auswahlabschnitt und klicken Sie dann auf „OK“.
Verwandte Themen
Dialogfeld „Datenteilformulare bearbeiten“


Teilformulare verwenden

Info über Teilformulare
Teilformulare erstellen und konfigurieren
Teilformularsätze verwenden
Sich wiederholende und mehrseitige Teilformulare erstellen
Auswahl-Teilformularsätze verwenden


Info über Teilformulare

Teilformulare – Übersicht
Standard-Teilformulare
Teilformulare mit positioniertem Inhalt
Teilformulare mit fließendem Inhalt
Teilformulare mit mehreren Seiten
Teilformulare für den Überlaufkopfbereich und den Überlauffußbereich


Teilformulare – Übersicht

Bei einem Teilformular handelt es sich um einen Abschnitt im Formularentwurf, der Positionierungs-, Layout- und Geometrieverwaltungsfunktionen für Objekte zur Verfügung stellt. Die in einem Teilformular enthaltenen Objekte können in Zeilen, Spalten oder auf andere Weise symmetrisch angeordnet werden.
In einem Formularentwurf können mehrere Teilformulare verwendet werden. Teilformulare können in andere Teilformulare platziert werden. Diese Beziehung wird in der Palette „Hierarchie“ angezeigt.
Teilformulare werden verwendet, um ein Formular in verschiedene Abschnitte einzuteilen. Außerdem können Sie zum Erstellen eines Formulars verwendet werden, dessen Größe automatisch an die Datenmenge angepasst wird. Bei einem Teilformular mit anpassbarer Größe wird das Layout des Formulars je nach der Datenmenge geändert, die beim Wiedergeben des Formulars zusammengeführt wird. Beim Zusammenführen der Daten wird durch Teilformulare sichergestellt, dass Objekte und die zugehörigen Daten auf konsistente Weise relativ zueinander angeordnet werden. Mit Teilformularen können Sie die Datenhierarchie in XML-Daten angleichen.
Wenn Sie ein Formular mit einem festen Layout entwerfen, müssen Sie wahrscheinlich nicht mit mehreren Teilformularen arbeiten, weil die Objekte automatisch vom Standard-Teilformular positioniert werden.
Die Eigenschaften eines Teilformulars lassen sich in der Palette „Objekt“ auf den Registerkarten „Teilformular“ und „Bindung“ bearbeiten. Sie können die folgenden Eigenschaften festlegen:
      •
      Festlegen eines aussagekräftigen Namens für ein Teilformular (empfohlen)
      •
      Festlegen, ob beim Zusammenführen der Daten Seitenumbrüche in das Teilformular eingefügt werden sollen, so dass es sich über mehrere Seiten erstreckt, oder ob es stattdessen als Ganzes auf der nächsten Seite wiedergegeben werden soll
      •
      Festlegen, ob das Teilformular nach dem vorhergehenden Teilformular (in dem angegebenen Inhaltsbereich) oder auf einer Seite platziert werden soll, die entsprechend der angegebenen Masterseite formatiert wurde
      •
      Festlegen, ob das Teilformular in demselben Inhaltsbereich wie das vorhergehende oder das nächste Teilformular platziert werden soll
      •
      Festlegen der Fließrichtung der zusammengeführten Daten, nachdem das Teilformular platziert wurde
      •
      Definieren des Teilformulars als „Sichtbar“, „Unsichtbar“ oder „Ausgeblendet“
      •
      Festlegen einer Sprache für das Teilformular
      •
      Festlegen, ob das Teilformular seine Objekte immer dann wiederholen soll, wenn ein eindeutiges Datenelement für eines seiner Objekte zur Verfügung gestellt wird
      •
      Erstellen eines Überlaufkopfbereichs und/oder eines Überlauffußbereichs für die Teilformulare (falls erforderlich), der die Wiedergabe der Objekte wiederholen kann
      •
      Festlegen einer Bindungsmethode, um zu steuern, wie den Objekten des Teilformulars Daten zugeordnet werden
Verwandte Themen
Standard-Teilformulare
So fügen Sie ein Teilformular hinzu
So können Sie Objekte mit einem Teilformular umschließen und daraus entfernen
Eigenschaften von Teilformularen: Registerkarte „Teilformular“
Eigenschaften von Teilformularen: Registerkarte „Paginierung“
Eigenschaften von Teilformularen: Registerkarte „Bindung“


Standard-Teilformulare

Alle Formulare enthalten ein Stamm-Teilformular (Parent-Teilformular). In der Palette „Hierarchie“ wird das Stamm-Teilformular (Formular1) als Knoten der obersten Ebene mit dem Teilformular der Standardseite (Teilformular „unbenannt“) angezeigt; es erscheint als untergeordneter Knoten unterhalb des Stamm-Teilformulars.
LiveCycle Designer fügt jeder Seite automatisch ein Standard-Teilformular hinzu, das die gesamte Seite abdeckt und in Größe und Position dem Standard-Inhaltsbereich auf der Masterseite entspricht. Alle Teilformulare, die Sie später den Seiten hinzufügen, werden verschachtelt und erscheinen in der Palette „Hierarchie“ unterhalb des Teilformulars der Standardseite.
In der Palette „Hierarchie“ wird jedes Teilformular durch einen Knoten dargestellt. Die von einem Teilformular umschlossenen Objekte werden unter dem Teilformular-Knoten angezeigt. Die untergeordneten Elemente des Teilformulars übernehmen nicht die auf Teilformularebene vorgenommenen Änderungen; die Eigenschaften müssen für jedes Objekt einzeln definiert werden.
Wenn Sie sich das Musterbestellformular ansehen, wird das Stamm-Teilformular (Formular1) als Knoten der obersten Ebene mit dem Teilformular der Standardseite (purchaseOrder) angezeigt; es erscheint als untergeordnetes Element des Stamm-Teilformulars. Die weiteren Teilformulare („header“, „detailHeader“, „detail“ und „total“), die die Objekte auf der Seite enthalten, sind unterhalb des Teilformulars der Seite verschachtelt. In der Palette „Hierarchie“ wird jedes Teilformular als ein Knoten dargestellt und die von einem Teilformular umschlossenen Objekte werden unter dem jeweiligen Knoten angezeigt.
Verwandte Themen
Teilformulare – Übersicht
Eigenschaften von Teilformularen: Registerkarte „Teilformular“
Eigenschaften von Teilformularen: Registerkarte „Paginierung“
Eigenschaften von Teilformularen: Registerkarte „Bindung“
Info über das Erstellen von Formularentwürfen mit Layoutanpassungen an die Datenmenge


Teilformulare mit positioniertem Inhalt

Objekte im Teilformulars werden entsprechend ihren jeweiligen X- und Y-Koordinaten positioniert. Beim Wiedergeben des Formulars wird die Reihenfolge, in der die Teilformulare angeordnet werden, durch die Position dieser Teilformulare in der Palette „Hierarchie“ bestimmt.
Alle Teilformulare mit Ausnahme des Stamm-Teilformulars (Formular1) sind standardmäßig auf das Positionieren von Inhalt eingestellt. Wenn ein Teilformular auf das Positionieren von Inhalt eingestellt ist, kann es dennoch jede beliebige Menge von zusammengeführten Daten passend erweitern, aber keines der Objekte innerhalb des Teilformulars kann von seinem Ankerpunkt weg verschoben werden. Wenn ein Teilformular für die Positionierung von Inhalt konfiguriert ist, müssen Sie daher Ihren Formularentwurf häufig testen, um sicherzustellen, dass Objekte innerhalb des Teilformulars, die Sie als Ergebnis des Zusammenführens von Daten erwarten, nicht mit anderen Objekten im Formularentwurf in Konflikt geraten. Denken Sie daran, dass alle Objekte wie z. B. Textfeldobjekte, die sich erweitern können, eventuell andere Objekte überlagern, wenn das Formular von LiveCycle Forms wiedergegeben wird. Um dieses Problem zu umgehen, können Sie das Teilformular mit fließendem Inhalt konfigurieren und den Inhalt passend erweitern. (Siehe Teilformulare mit fließendem Inhalt.)
LiveCycle Designer stellt das Teilformular der Standardseite automatisch auf das Positionieren von Inhalt ein, um das Erstellen von interaktiven Formularen mit festem Layout zu erleichtern. Weitere Informationen finden Sie unter Standard-Teilformulare.
Wenn Sie allerdings ein Formular entwerfen, dessen Layout an die Datenmenge angepasst wird, müssen Sie das Teilformular der Standardseite wieder auf das Positionieren von Inhalt einstellen, nachdem Sie den Formularentwurf fertig gestellt haben. Am besten führen Sie diesen Schritt ganz zum Schluss aus, so dass das Teilformular sichtbar bleibt und die Objekte, die Sie im Teilformular platzieren, auf der Seite an der richtigen Position bleiben.
Zum Positionieren des Inhalts in einem Teilformular verwenden Sie die Option zum Positionieren von Inhalt in der Liste „Typ“ auf der Registerkarte „Teilformular“ . Wenn Sie die Option zum Positionieren von Inhalt auswählen, werden die X- und Y-Koordinaten der einzelnen Objekte innerhalb des Teilformulars beibehalten. Die Objekte werden an ihren X- und Y-Koordinaten relativ zur Position des Teilformulars positioniert.


Teilformulare mit fließendem Inhalt

Objekte im Teilformular werden während der Datenzusammenführung so positioniert, dass keine Objekte aufeinander abgelegt werden. Teilformulare mit fließendem Inhalt werden in aufsteigender Reihenfolge angeordnet. Sie können Teilformulare mit fließendem Inhalt verwenden, wenn die Größe des Formulars automatisch an den Inhalt angepasst werden muss.
Das Stamm-Teilformular (Formular1) ist standardmäßig auf fließenden Inhalt eingestellt. Das Stamm-Teilformular lässt den Inhalt immer entsprechend der Fließrichtungsoption fließen, die Sie dem entsprechenden Standard-Inhaltsbereich zugewiesen haben. Da das Stamm-Teilformular auf fließenden Inhalt eingestellt ist, fließen alle unter dem Stamm-Teilformular verschachtelten Teilformulare beim Zusammenführen der Daten automatisch nach Bedarf von einer Formularseite (Inhaltsbereich) zur nächsten. Bei der Wiedergabe des Formulars werden die Teilformulare unter dem Stamm-Teilformular in absteigender Folge entsprechend ihrer Position in der Objekthierarchie angeordnet.
Sie können auch jedes andere Teilformular auf fließenden Inhalt einstellen. Jedes auf fließenden Inhalt eingestellte Teilformular kann verschiedene Mengen von Daten enthalten, während die Objekte im Teilformular beim Zusammenführen der Daten gemeinsam verschoben werden, so dass keine Objekte miteinander in Konflikt geraten.
Mit der Option für fließenden Inhalt in der Liste „Typ“ auf der Registerkarte „Teilformular“ können Sie Teilformulare auf fließenden Inhalt einstellen. Wenn Sie die Option für fließenden Inhalt auswählen, werden die Objekte entsprechend der ausgewählten Option für die Fließrichtung angeordnet. Beachten Sie, dass die Liste „Fließrichtung“ und die Option „Seitenumbrüche im Inhalt zulassen“ aktiviert werden, wenn Sie in der Liste „Typ“ die Option für fließenden Inhalt auswählen.
Verwandte Themen
Teilformulare – Übersicht


Teilformulare mit mehreren Seiten

Sie können ein Teilformular zwar überall auf einer Seite platzieren, wenn jedoch eine große Menge von Daten mit dem Formular zusammengeführt wird, kann sich das Teilformular über den unteren Rand der wiedergegebenen Seite hinweg erstrecken. Um dieses Problem zu lösen, können Sie entweder die Option „Seitenumbrüche im Inhalt zulassen“ aktivieren, damit das Teilformular von LiveCycle Forms in der Mitte umgebrochen wird, oder Sie deaktivieren diese Option, um zu erzwingen, dass das gesamte Teilformular am Anfang der nächsten wiedergegebenen Seite eingefügt wird. Wenn Sie festlegen, dass das Teilformular auf der nächsten Seite erscheinen soll, stellen Sie sicher, dass alle verschachtelten Teilformulare auf derselben Seite angezeigt werden. Wenn Sie die Option „Seitenumbrüche im Inhalt zulassen“ nicht aktivieren, sollten Sie eventuell einen Überlaufkopfbereich und einen Überlauffußbereich erstellen. (Siehe Teilformulare für den Überlaufkopfbereich und den Überlauffußbereich.)
Beim Zusammenführen der Daten wird der Inhalt des Teilformulars von LiveCycle Forms nur innerhalb der Grenzen von Inhaltsbereichen positioniert. Wenn große Mengen von Daten mit den Objekten in einem Teilformular zusammengeführt werden müssen, kann sich ein Teilformular über mehrere Formularseiten hinweg erstrecken. Sobald eine Formularseite vollständig gefüllt ist, wird von LiveCycle Forms automatisch eine weitere, identische Seite wiedergegeben. Das Teilformular wird auf der neuen Seite fortgesetzt, es sei denn, Sie geben ausdrücklich an, dass die Daten in einen anderen Inhaltsbereich oder auf eine andere Masterseite fließen sollen. Falls in einem Formular mehr als ein Inhaltsbereich oder eine Masterseite vorhanden sind, können Sie festlegen, ob ein Teilformular in einem bestimmten Inhaltsbereich platziert oder entsprechend der angegebenen Masterseite positioniert werden soll.


Teilformulare für den Überlaufkopfbereich und den Überlauffußbereich

Da die Länge eines Formulars mit einem flexiblen Layout entsprechend der Menge der mit dem Formular zusammengeführten Daten variiert, sind diese Formulare häufig länger als eine Seite. Die Verwendung von Teilformularen für einen Überlaufkopfbereich bzw. einen Überlauffußbereich ist eine effiziente Möglichkeit, ein Teilformular, das sich über mehrere Seiten erstreckt, zu beginnen und zu beenden. Sie können ein beliebiges für positionierten Inhalt konfiguriertes Teilformular als Überlaufkopfbereich oder Überlauffußbereich verwenden. Im Musterbestellformular ist beispielsweise das Teilformular „detail“ für das Positionieren von Inhalt konfiguriert und wird für jedes Datenelement wiederholt. Wenn das Formular mit Daten zusammengeführt wird und auf der ersten Seite nicht genügend Platz zur Verfügung steht, um alle Instanzen des Detail-Teilformulars anzuzeigen, wird eine neue Seite hinzugefügt und die Daten fließen in den nächsten Inhaltsbereich.
Wenn sich Daten auf diese Weise über mehrere Seiten erstrecken, können Sie einen bestimmten Text wie beispielsweise „Fortsetzung von voriger Seite“ oder besondere Formatierungselemente wie Spaltenüberschriften auf die neuen Seiten mitführen. Durch Spaltenüberschriften auf jeder nachfolgenden Seite wird das Formular für die Benutzer übersichtlicher. Sie können hierfür einen Überlaufkopfbereich erstellen, der als Spaltenüberschriftszeile für jede zusätzliche Seite verwendet wird. Im Musterbestellformular wurde beispielsweise das Teilformular „detailHeader“ als Überlaufkopfbereich ausgewählt. Daher wird von LiveCycle Forms eine Kopie des Teilformulars „detailHeader“ am Anfang jeder neuen Seite vor dem ersten Vorkommen des Detail-Teilformulars eingefügt.
Ebenso können Sie bestimmte Informationen im Anschluss an das letzte Vorkommen des wiederholten Teilformulars am Ende aller Seiten mit Ausnahme der letzten einbeziehen. Sie können beispielsweise Text wie „Fortsetzung auf nächster Seite“ am Ende dieser Seiten einfügen. Hierzu erstellen Sie ein Teilformular für den Überlauffußbereich für das wiederholte Teilformular auf die gleiche Weise wie das Teilformular für den Überlaufkopfbereich.
Wenn ein Teilformular auf die nächste Seite überläuft, werden von LiveCycle Forms die folgenden Vorgänge ausgeführt:
      •
      Platzieren des Überlauffußbereichs auf der aktuellen Seite
      •
      Platzieren des Überlaufkopfbereichs auf der folgenden Seite
      •
      Fließende Darstellung des erweiterten Teilformulars und der übrigen wiederholten Objekte auf der neuen Seite


Teilformulare erstellen und konfigurieren

So fügen Sie ein Teilformular hinzu
So benennen Sie ein Teilformular
So definieren Sie ein Teilformular als sichtbar, unsichtbar oder ausgeblendet
So legen Sie ein Gebietsschema (Sprache und Land) für ein Teilformular fest
So können Sie Objekte mit einem Teilformular umschließen und daraus entfernen
So legen Sie die Inhaltsverwaltung in einem Teilformular fest
So positionieren Sie Teilformulare
So legen Sie die Art der Datenzusammenführung zwischen Teilformularen fest
So definieren Sie benutzerdefinierte Datenbindungseigenschaften für ein Teilformular


So fügen Sie ein Teilformular hinzu

Sie können ein Teilformular über das Menü oder die Palette „Bibliothek“ hinzufügen.
So fügen Sie ein Teilformular über das Menü hinzu
      *
      Zeigen Sie die Seite des Formulars an und wählen Sie „Einfügen“ > „Standard“ > „Teilformular“.
So fügen Sie ein Teilformular über die Palette „Bibliothek“ hinzu
      *
      Führen Sie einen der folgenden Schritte aus:
Klicken Sie in der Palette „Bibliothek“ auf die Registerkarte „Standard“, wählen Sie das Objekt „Teilformular“ aus und ziehen Sie es auf die Seite des Formulars.
      •
      Ziehen Sie das Objekt „Teilformular“ auf der Registerkarte „Standard“ in der Palette „Bibliothek“ auf die Seite des Formulars.
      •
      Klicken Sie in der Palette „Bibliothek“ auf die Registerkarte „Standard“ und doppelklicken Sie anschließend auf das Objekt „Teilformular“.
Verwandte Themen
Teilformulare – Übersicht
So benennen Sie ein Teilformular
Standard-Teilformulare
So können Sie Objekte mit einem Teilformular umschließen und daraus entfernen
So erstellen Sie ein Teilformular mit mehreren Seiten


So benennen Sie ein Teilformular

Wenn Sie ein Teilformular benennen oder umbenennen möchten, müssen Sie zunächst das gewünschte Teilformular auswählen.
So können Sie Teilformulare mit Hilfe der Palette „Hierarchie“ benennen oder umbenennen
1.
Klicken Sie in der Palette „Hierarchie“ mit der rechten Maustaste auf das gewünschte Teilformular und wählen Sie die Option „Objekt umbenennen“ aus.
2.
Geben Sie den neuen Namen ein und drücken Sie die Eingabetaste.
So können Sie Teilformulare mit Hilfe der Registerkarte „Bindung“ in der Palette „Objekt“ benennen oder umbenennen
1.
Wählen Sie das Teilformular aus.
2.
Geben Sie auf der Registerkarte „Bindung“ im Feld „Name“ einen neuen Namen für das Teilformular ein und drücken Sie die Eingabetaste. LiveCycle Designer legt automatisch den Wert für die Häufigkeit des Vorkommens fest.
Verwandte Themen
Teilformulare – Übersicht
Eigenschaften von Teilformularen: Registerkarte „Bindung“
So definieren Sie benutzerdefinierte Datenbindungseigenschaften für ein Teilformular


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Teilformulare verwenden > Teilformulare erstellen und konfigurieren > So definieren Sie ein Teilformular als sichtbar, unsichtbar oder ausgeblendet

So definieren Sie ein Teilformular als sichtbar, unsichtbar oder ausgeblendet

1.
Wählen Sie das Teilformular aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Teilformular“.
3.
Wählen Sie in der Liste „Präsenz“ die gewünschte Option aus:
      •
      Wenn das Objekt auf dem Bildschirm und im gedruckten Formular sichtbar sein soll und Platz im Formularlayout einnehmen soll, wählen Sie „Sichtbar“ aus.
      •
      Wenn das Objekt auf dem Bildschirm sichtbar und im gedruckten Formular nicht sichtbar sein soll und Platz im Formularlayout einnehmen soll, wählen Sie „Sichtbar (nur Bildschirm)“ aus.
      •
      Wenn das Objekt auf dem Bildschirm nicht sichtbar und im gedruckten Formular sichtbar sein soll und Platz im Formularlayout einnehmen soll, wählen Sie „Sichtbar (nur drucken)“ aus.
      •
      Wenn das Objekt auf dem Bildschirm und im gedruckten Formular nicht sichtbar sein soll und Platz im Formularlayout einnehmen soll, wählen Sie „Unsichtbar“ aus.
      •
      Wenn das Objekt auf dem Bildschirm und im gedruckten Formular nicht sichtbar sein soll und keinen Platz im Formularlayout einnehmen soll, wählen Sie „Ausgeblendet (Aus Layout ausschließen)“ aus.
Verwandte Themen
Info über das Definieren von Objekten als sichtbar, unsichtbar oder ausgeblendet
So definieren Sie ein Objekt als sichtbar, unsichtbar oder ausgeblendet


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Teilformulare verwenden > Teilformulare erstellen und konfigurieren > So legen Sie ein Gebietsschema (Sprache und Land) für ein Teilformular fest

So legen Sie ein Gebietsschema (Sprache und Land) für ein Teilformular fest

1.
Wählen Sie das Teilformular aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
3.
Wählen Sie in der Liste „Sprache“ eine der folgenden Optionen oder eine der verfügbaren Alternativen für das Gebietsschema des Teilformulars aus:
      •
      Wenn Sie die Standardsprache verwenden möchten, die im Dialogfeld „Formulareigenschaften“ auf der Registerkarte „Standard“ festgelegt ist, wählen Sie „Standardsprache“ aus.
      •
      Wenn Sie das Gebietsschema auf dem Computer des Benutzers verwenden möchten, wählen Sie „Gebietsschema des Viewers“ aus.
Zur Entwurfs- und Laufzeit werden formatierte Werte im Feld in einem Format angezeigt, das dem Gebietsschema entspricht.
Verwandte Themen
Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“
Teilformulare – Übersicht
Eigenschaften von Teilformularen: Registerkarte „Teilformular“


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Teilformulare verwenden > Teilformulare erstellen und konfigurieren > So können Sie Objekte mit einem Teilformular umschließen und daraus entfernen

So können Sie Objekte mit einem Teilformular umschließen und daraus entfernen

Objekte werden dann mit einem Teilformular umschlossen, wenn sie Teil dieses Teilformulars sind.
So fügen Sie Objekte zu einem bereits vorhandenen Teilformular hinzu
      *
      Wählen Sie die Objekte aus, die zum Teilformular hinzugefügt werden sollen, und klicken Sie auf „Einfügen“ > „Umschließen mit Teilformular“.
So entfernen Sie die Objekte aus einem Teilformular
      *
      Wählen Sie das Teilformular aus, das die Objekte enthält, die Sie wieder entfernen möchten. Klicken Sie anschließend auf „Einfügen“ > „Umschließendes Teilformular entfernen“.
Verwandte Themen
Eigenschaften von Teilformularen: Registerkarte „Teilformular“
So fügen Sie ein Teilformular hinzu


So legen Sie die Inhaltsverwaltung in einem Teilformular fest

Standardmäßig sind alle Teilformulare für das Positionieren von Inhalt definiert. Die einzige Ausnahme bildet das Stamm-Teilformular. Das Stamm-Teilformular transportiert Inhalt immer in die Richtung, die für den zugeordneten Inhaltsbereich unter „Fließrichtung“ eingestellt wurde. Da das Stamm-Teilformular Inhalt transportiert, können alle Teilformulare, die unter dem Stamm-Teilformular verschachtelt sind, automatisch von einer Formularseite oder einem Inhaltsbereich zur oder zum nächsten fließen, wenn dies bei der Datenzusammenführung erforderlich sein sollte.
Wenn ein Teilformular dagegen Inhalt positioniert, kann der Bereich, der durch das Teilformular gebunden ist, zwar vergrößert werden, um eine beliebige Menge zusammengeführter Daten aufzunehmen. In diesem Fall kann jedoch keines der Objekte in diesem Teilformular von seinen Positionspunkten verschoben werden. Wenn ein Teilformular Objekte enthält, die mit unterschiedlichen Datengrößen zusammengeführt werden, müssen Sie daher sicherstellen, dass diese Objekte nicht zu stark expandieren, damit sie den von einem anderen Objekt belegten Bereich nicht überschreiben. Bei allen Objekten, die als Reaktion auf die Datenzusammenfügung expandieren (wie z. B. Textfelder), besteht die Möglichkeit, dass sie über anderen Objekten wiedergegeben werden.
Um dieses Problem zu vermeiden, können Sie das Teilformular für fließenden Inhalt definieren. Ein Teilformular, das Inhalt transportiert, platziert die Objekte bei der Datenzusammenführung an der richtigen Stelle, so dass kein Objekt über dem anderen wiedergegeben wird.
Das Standard-Teilformular für die Seite positioniert den Inhalt, um die Erstellung von interaktiven Formularen und von Formularen mit einem festen Layout zu unterstützen. Beim Verfassen eines Formulars mit Teilformularen, deren Größe an die Datenmenge angepasst wird, müssen Sie mit Teilformularen mit positiniertem Inhalt sowie mit Teilformularen mit fließendem Inhalt arbeiten. Für das Arbeiten mit Teilformularen in dieser Art von Formularentwurf sind verschiedene Techniken verfügbar. Wofür Sie sich entscheiden, hängt von Ihrer Erfahrung mit der Erstellung von Formularentwürfen ab, deren Layout an die Datenmenge angepasst wird. Weitere Informationen finden Sie unter Info über das Erstellen von Formularentwürfen mit Layoutanpassungen an die Datenmenge.
So legen Sie fest, wie ein Teilformular Inhalt positioniert
      *
      Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Teilformular“ und wählen Sie in der Liste „Inhalt“ eine der folgenden Optionen aus:
      •
      „Position“
      •
      „Textfluss“
So legen Sie eine Fließrichtung für die Objekte in einem Teilformular mit fließendem Inhalt fest
      *
      Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Teilformular“ und wählen Sie in der Liste „Fließrichtung“ eine der folgenden Optionen aus (Objekte werden immer beginnend vom Anfang des Teilformulars platziert):
      •
      „Von oben nach unten“
      •
      „Von links nach rechts“
Die Option „Fließrichtung“ steht nur zur Verfügung, wenn in der Liste „Inhalt“ die Option „Textfluss“ ausgewählt ist.
So ändern Sie ein Teilformular mit positioniertem Inhalt in ein Teilformular mit fließendem Inhalt
1.
Wählen Sie das Teilformular aus, das Sie auf fließenden Inhalt einstellen möchten.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Teilformular“ und wählen Sie in der Liste „Inhalt“ die Option „Textfluss“ aus.
3.
Wählen Sie in der Liste „Fließrichtung“ eine der folgenden Optionen aus (Objekte werden immer beginnend vom Anfang des Teilformulars platziert):
      •
      „Von oben nach unten“
      •
      „Von links nach rechts“
Verwandte Themen
Eigenschaften von Teilformularen: Registerkarte „Teilformular“
So positionieren Sie Teilformulare
So legen Sie die Art der Datenzusammenführung zwischen Teilformularen fest


So positionieren Sie Teilformulare

So legen Sie die Position des Teilformulars fest
      *
      Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Paginierung“. Klicken Sie anschließend auf den Pfeil rechts neben dem Feld „Platzieren“ und wählen Sie eine der folgenden Präsentationsoptionen aus:
      •
      „Nach vorherigem“
      •
      „Im Inhaltsbereich > [Name_des_Inhaltsbereichs]„
      •
      „Anfang des nächsten Inhaltsbereichs“
      •
      „Anfang des Inhaltsbereichs > [Name_des_Inhaltsbereichs]„
      •
      „Auf Seite > [Name_der_Seite]„
      •
      „Anfang der nächsten Seite“
      •
      „Anfang der Seite > [Name_der_Seite]„
So bleibt das Teilformular in demselben Inhaltsbereich bzw. auf derselben Textseite wie das vorherige oder folgende Teilformular
      *
      Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Paginierung“ und wählen Sie die Option „Nicht trennen: Vorherige“ oder „Nicht trennen: Nächste“ aus.
Verwandte Themen
Eigenschaften von Teilformularen: Registerkarte „Teilformular“
So legen Sie die Inhaltsverwaltung in einem Teilformular fest
So legen Sie die Art der Datenzusammenführung zwischen Teilformularen fest


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Teilformulare verwenden > Teilformulare erstellen und konfigurieren > So legen Sie die Art der Datenzusammenführung zwischen Teilformularen fest

So legen Sie die Art der Datenzusammenführung zwischen Teilformularen fest

      *
      Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Paginierung“. Klicken Sie anschließend auf den Pfeil rechts neben dem Feld „Nach“ und wählen Sie eine der folgenden Optionen aus:
      •
      „Übergeordnet weiter füllen“
      •
      „Gehe zum nächsten Inhaltsbereich“
      •
      „Gehe zu Inhaltsbereich > [Name_des_Inhaltsbereichs]„
      •
      „Gehe zur nächsten Seite“
      •
      „Gehe zu Seite > [Name_der_Seite ]„
Verwandte Themen
Eigenschaften von Teilformularen: Registerkarte „Paginierung“
So legen Sie die Inhaltsverwaltung in einem Teilformular fest
So positionieren Sie Teilformulare


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Teilformulare verwenden > Teilformulare erstellen und konfigurieren > So definieren Sie benutzerdefinierte Datenbindungseigenschaften für ein Teilformular

So definieren Sie benutzerdefinierte Datenbindungseigenschaften für ein Teilformular

Mit den Bindungsoptionen können Sie ein Formular erstellen, das Daten für die Infrastruktur eines Unternehmens erfasst oder eine externe Datenquelle nutzt, um ein Formular zur Laufzeit auszufüllen. Die Datenbindungseigenschaften werden auf der Registerkarte „Bindung“ der Palette „Objekt“ festgelegt.
Teilformulare können Daten weder aufzeichnen noch anzeigen. Die Objekte in einem Teilformular können dagegen beides. Die Bindungseinstellungen für ein Teilformular haben direkten Einfluss darauf, wie verschachtelte Objekte Daten zugeordnet werden.
Ein Teilformular kann an eine Datengruppe und die Objekte des Teilformulars an Datenwerte innerhalb dieser Datengruppe gebunden werden. Standardmäßig beziehen sich die Bindungen der Objekte in einem Teilformular auf die Bindung des Teilformulars.
1.
Wählen Sie das Teilformular aus.
2.
Legen Sie für das Formular fest, dass beim Öffnen eine Verbindung zur Datenquelle hergestellt wird.
3.
Binden Sie das Teilformular und seine Objekte an die entsprechenden Datenknoten. Weitere Informationen zum Binden von Objekten an eine Datenquelle finden Sie unter Info über das Binden von Feldern an eine Datenquelle.
Verwandte Themen
Teilformulare – Übersicht
Eigenschaften von Teilformularen: Registerkarte „Bindung“
So benennen Sie ein Teilformular
So erstellen Sie sich wiederholende Teilformulare


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Teilformulare verwenden > Teilformularsätze verwenden

Teilformularsätze verwenden

Teilformularsätze – Übersicht
So fügen Sie einen Teilformularsatz ein


Teilformularsätze – Übersicht

Ein Teilformularsatz ist eine Gruppierung aus zwei oder mehreren sich wiederholenden oder mehrseitigen Teilformularen.
Mit Hilfe eines Teilformularsatzes können Sie die Reihenfolge steuern, in der LiveCycle Forms die Teilformulare im Satz wiedergibt, basierend auf der Reihenfolge der Teilformulare im Satz.
Im Musterbestellformular sehen Sie beispielsweise, wie die Teilformulare „detailHeader“ und „detail“ zu einem Teilformularsatz zusammengefasst werden. Der Teilformularsatz hält die beiden Teilformulare zusammen, so dass beide Teilformulare für jedes Datenelement von LiveCycle Forms wiedergegeben werden oder keines der beiden, wenn für das Teilformular „detail“ keine Daten vorliegen.
Durch Gruppieren von Teilformularen zu einem Teilformularsatz stellen Sie sicher, dass Teilformulare im Satz von LiveCycle Forms nur wiedergegeben werden, wenn die Daten zur Wiedergabe des Teilformulars vorliegen.
Sie können die Reihenfolge steuern, in der LiveCycle Forms die Teilformulare in einem Satz wiedergibt, indem Sie eine der folgenden Optionen in der Liste „Typ“ auf der Registerkarte „Teilformularsatz“ der Palette „Objekt“ auswählen:
      •
      „Alle Teilformulare in festgelegter Reihenfolge verwenden“
      Alle Teilformulare im Teilformularsatz werden im fertigen Dokument angezeigt und in der Reihenfolge, in der sie in der Palette „Hierarchie“ erscheinen.
      •
      „Teilformular aus Alternativen auswählen“
      Ein Teilformuar aus dem Satz wird im endgültigen Dokument angezeigt. Weitere Informationen finden Sie unter Info über Auswahl-Teilformularsätze.
Bei der Wiedergabe von Teilformularen sollten Sie Folgendes berücksichtigen:
      •
      Wenn Sie für ein Teilformular einen minimalen Zählerwert von „0“ festlegen, gibt LiveCycle Forms das Teilformular nicht wieder, wenn für dieses Teilformular keine Daten vorhanden sind.
      •
      Wenn Sie für ein Teilformular einen minimalen Zählerwert festlegen, der niedriger ist als die Anzahl der tatsächlichen Vorkommen in den Daten, werden die verbleibenden Datenwerte nicht angezeigt. Umgekehrt wird die angegebene Anzahl von Teilformularen von LiveCycle Forms wiedergegeben, wenn Sie für ein Teilformular einen maximalen Zählerwert festlegen, der größer ist als die Anzahl der tatsächlichen Vorkommen in den Daten. Dies bedeutet, dass einige Objekte im Teilformular ohne Daten und leer wiedergegeben werden.
      •
      Wenn Sie möchten, können Sie Teilformularsätze innerhalb anderer Teilformulare in beliebiger Tiefe verschachteln. Sie können jedoch keine einzelnen Objekte wie Linien, Kreise oder Textfeldobjekte in einem Teilformularsatz platzieren.
Verwandte Themen
So fügen Sie einen Teilformularsatz ein
Info über Auswahl-Teilformularsätze
Eigenschaften von Teilformularsätzen: Registerkarte „Teilformularsatz“
Eigenschaften von Teilformularsätzen: Registerkarte „Paginierung“
Eigenschaften von Teilformularsätzen: Registerkarte „Bindung“


So fügen Sie einen Teilformularsatz ein

Ein Teilformularsatz ist eine Gruppe von mindestens zwei Teilformularen, die zusammengefasst werden sollen. Mit Hilfe von Teilformularsätzen können Sie Teilformulare kombinieren und die Reihenfolge steuern, in der die Teilformulare von LiveCycle Forms wiedergegeben werden.
Vor dem Erstellen eines Teilformularsatzes empfiehlt es sich, die Reihenfolge zu berücksichtigen, in der das Formular von LiveCycle Forms wiedergegeben werden soll. Nur so können Sie in der Liste „Typ“ auf der Registerkarte „Teilformular“ die richtige Option auswählen.
1.
Klicken Sie mit der rechten Maustaste auf die Palette „Hierarchie“ und wählen Sie „Teilformularsatz einfügen“ aus. Der Palette „Hierarchie“ wird ein unbenanntes Teilformular hinzugefügt.
2.
Ziehen Sie in der Palette „Hierarchie“ die gewünschten Teilformulare in den Teilformularsatz.
3.
Nach Auswahl des Teilformularsatzes in der Palette „Hierarchie“ klicken Sie in der Palette „Objekt“ auf die Registerkarte „Teilformularsatz“ und wählen Sie in der Liste „Typ“ die gewünschte Option aus.
4.
Klicken Sie auf die Registerkarte „Bindung“. Optional können Sie im Feld „Name“ einen Namen für den Teilformularsatz eingeben.
5.
Wenn der Teilformularsatz entsprechend den bereitgestellten Daten wiederholt werden soll, wählen Sie die Option „Teilformular wiederh. f. jedes Datenelement“ aus und geben Sie ggf. einen minimalen und einen maximalen Zählerwert an.
6.
Zeigen Sie den Formularentwurf in der Vorschau an, um den Teilformularsatz zu testen.
Verwandte Themen
Teilformularsätze – Übersicht
Info über Auswahl-Teilformularsätze


Sich wiederholende und mehrseitige Teilformulare erstellen

So erstellen Sie sich wiederholende Teilformulare
So erstellen Sie ein Teilformular mit mehreren Seiten
Info über Überlaufkopfbereiche und Überlauffußbereiche
So können Sie Überlaufkopf- und Überlauffußbereiche erstellen und zuweisen
So steuern Sie Umbrüche in Teilformularen und Teilformularsätzen mit Hilfe von bedingten Anweisungen


So erstellen Sie sich wiederholende Teilformulare

1.
Wählen Sie das Teilformular aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Teilformular“ und wählen Sie in der Liste „Inhalt“ die Option „Textfluss“ aus.
3.
Klicken Sie auf die Registerkarte „Bindung“ und wählen Sie die Option „Teilformular wiederh. f. jedes Datenelement“ aus.
Die Option „Teilformular wiederh. f. jedes Datenelement“ steht nur zur Verfügung, wenn das übergeordnete Teilformular (wie in der Palette „Hierarchie“ angezeigt) auf fließenden Inhalt eingestellt wurde.
4.
Wenn Sie eine Mindestwiederholungszahl festlegen möchten, geben Sie die entsprechende Zahl im Feld „Min-Zähler“ ein. Wenn diese Option auf 0 gesetzt ist und zum Zeitpunkt der Datenzusammenführung keine Daten für die Objekte im Teilformular zur Verfügung stehen, wird das Teilformular bei der Wiedergabe des Formulars nicht platziert.
5.
Falls Sie die Zahl der Wiederholungen beschränken möchten, wählen Sie die Option „Maximal“ aus und geben die Anzahl der maximal möglichen Wiederholungen in das zugehörige Feld ein. Wenn Sie im Feld „Maximal“ keinen Wert eingeben, ist die Anzahl von Wiederholungen unbeschränkt.
6.
Wenn Sie unabhängig von der Datenmenge eine bestimmte Anzahl von Teilformularwiederholungen festlegen möchten, aktivieren Sie die Option „Anfangszahl“ und geben im zugehörigen Feld die gewünschte Anzahl der Wiederholungen ein. Wenn Sie diese Option aktivieren, und es stehen keine oder weniger als unter „Anfangszahl“ angegebene Daten zur Verfügung, werden leere Instanzen des Teilformulars in das Formular eingefügt.
Der Wert im Feld „Anfangszahl“ muss zwischen den Werten für „Min-Zähler“ und „Maximal“ liegen. Falls für „Min-Zähler“ kein Wert oder 0 angegeben wurde, lautet der Wert für „Anfangszahl“ 0.
Verwandte Themen
Teilformulare – Übersicht
Eigenschaften von Teilformularen: Registerkarte „Teilformular“
Eigenschaften von Teilformularen: Registerkarte „Paginierung“
Eigenschaften von Teilformularen: Registerkarte „Bindung“
Info über Überlaufkopfbereiche und Überlauffußbereiche
So können Sie Überlaufkopf- und Überlauffußbereiche erstellen und zuweisen


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Teilformulare verwenden > Sich wiederholende und mehrseitige Teilformulare erstellen > So erstellen Sie ein Teilformular mit mehreren Seiten

So erstellen Sie ein Teilformular mit mehreren Seiten

Teilformulare können an eine beliebige Stelle in einem Formularentwurf platziert werden. Wenn jedoch große Datenmengen zusammengeführt werden, ist es möglich, dass das Teilformular über den unteren Rand der wiedergegebenen Seite hinausgeht.
Zur Behebung dieses Problems können Sie entweder in der Mitte des Teilformulars einen Seitenumbruch zulassen oder festlegen, dass das gesamte wiederzugebende Teilformular am Anfang der nächsten wiedergegebenen Seite erscheinen soll. Wenn Sie festlegen, dass das Teilformular auf der nächsten Seite erscheinen soll, stellen Sie sicher, dass alle verschachtelten Teilformulare auf derselben Seite angezeigt werden.
Wenn die Daten zusammengeführt werden, wird der Inhalt eines Teilformulars nur innerhalb der Grenzen der Inhaltsbereiche platziert. In Fällen, bei denen relativ große Datenmengen mit einem der Objekte in einem Teilformular zusammengeführt werden müssen, kann sich das Teilformular über mehrere Formularseiten erstrecken.
Sobald eine Formularseite ausgefüllt ist, wird automatisch eine weitere, identische Seite angelegt. Das Teilformular wird auf der neuen Seite platziert, es sei denn, Sie geben ausdrücklich an, dass die Daten in einen anderen Inhaltsbereich oder auf eine andere Masterseite fließen sollen. Falls in einem Formular mehr als ein Inhaltsbereich oder eine Masterseite vorhanden sind, können Sie festlegen, ob ein Teilformular in einem bestimmten Inhaltsbereich platziert oder entsprechend der angegebenen Masterseite positioniert werden soll.
      *
      Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Teilformular“ und wählen Sie die Option „Seitenumbrüche im Inhalt zulassen“ aus.
Wenn diese Option deaktiviert ist, bleiben die Objekte im Teilformular auf derselben Seite zusammen.
Verwandte Themen
Teilformulare – Übersicht
Eigenschaften von Teilformularen: Registerkarte „Teilformular“
Eigenschaften von Teilformularen: Registerkarte „Paginierung“
Eigenschaften von Teilformularen: Registerkarte „Bindung“
Info über das Erstellen von Formularentwürfen mit Layoutanpassungen an die Datenmenge


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Teilformulare verwenden > Sich wiederholende und mehrseitige Teilformulare erstellen > Info über Überlaufkopfbereiche und Überlauffußbereiche

Info über Überlaufkopfbereiche und Überlauffußbereiche

Ein Überlaufkopfbereich ist ein spezielles positioniertes Teilformular, das am oberen Rand der folgenden Seite erscheint, wenn Seitenüberlauf stattfindet.
Überlaufkopfbereiche ähneln der Überschriftenzeile einer Standardtabelle. Die Überschriftenzeile erscheint am Anfang der Tabelle und enthält eine beschreibende Bezeichnung zu jeder der Tabellenspalten. Falls die Tabelle über eine Seite hinausgeht, können Sie sie so formatieren, dass die Überschriftenzeile am Anfang jeder neuen Seite wiederholt wird. Dies vereinfacht das Lesen der einzelnen Seiten, und die Informationen in der Tabelle sind für den Leser leichter zugänglich.
Ein Teilformular für einen Überlaufkopfbereich funktioniert auf ähnliche Art. Wenn Sie festlegen, dass ein bestimmtes Teilformular der Überlaufkopfbereich für ein sich wiederholendes Teilformular sein soll, dann wird dieser Überlaufkopfbereich einmal vor dem sich wiederholenden Teilformular am Anfang der aktuellen Seite und dann auf jeder nachfolgenden Seite angezeigt.
Das sich wiederholende Teilformular wird beim Zusammenführen mit Daten so oft wie nötig hinzugefügt. Ist auf der ersten Seite kein Platz mehr, wird eine neue Seite hinzugefügt. Die Daten fließen dann so lange weiter auf die nächste Seite, bis keine neuen Daten mehr vorhanden sind. Das Teilformular für den Überlaufkopfbereich wird einmal oben auf jeder Seite angezeigt.
Wie ein Teilformular für einen Überlaufkopfbereich verwendet werden kann, zeigt das Beispiel für einen Formularentwurf, dessen Layout an die Datenmenge angepasst wird und der im Lieferumfang von LiveCycle Designer enthalten ist. Das Beispiel „Purchase Order.xdp“ befindet sich im Ordner „Samples“ im Installationsverzeichnis von LiveCycle Designer. In diesem Beispiel bildet das Teilformular mit der Bezeichnung „detailHeader“ den Überlaufkopfbereich für das sich wiederholende Teilformular mit der Bezeichnung „detail“.
Ende-Kopfbereiche sind Teilformulare, die vor einem sich wiederholenden Teilformular erscheinen. Wenn Sie ein Teilformular-Geschwister direkt oberhalb eines sich wiederholenden Teilformulars definieren und es dann als Überlaufkopfbereich definieren, haben Sie es als Ende-Kopfbereich und als Überlaufkopfbereich definiert.
Ein Überlauffußbereich erscheint am unteren Rand der folgenden Seite, wenn Seitenüberlauf stattfindet. Mit einem Überlauffußbereich können Sie Informationen einfügen, die nur einmal erscheinen, nachdem alle Daten positioniert wurden.
Ende-Fußbereiche sind Teilformulare, die direkt unterhalb eines sich wiederholenden Teilformulars erscheinen. Wenn Sie ein Teilformular-Geschwister direkt unterhalb eines sich wiederholenden Teilformulars definieren und es dann als Überlauffußbereich definieren, haben Sie es als Ende-Fußbereich und als Überlauffußbereich definiert.
Verwandte Themen
Teilformulare – Übersicht
So können Sie Überlaufkopf- und Überlauffußbereiche erstellen und zuweisen
Info über das Erstellen von Formularentwürfen mit Layoutanpassungen an die Datenmenge
Überlaufkopfbereiche und Überlauffußbereiche in Teilformularen verwenden


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Teilformulare verwenden > Sich wiederholende und mehrseitige Teilformulare erstellen > So können Sie Überlaufkopf- und Überlauffußbereiche erstellen und zuweisen

So können Sie Überlaufkopf- und Überlauffußbereiche erstellen und zuweisen

Bei einem Überlaufkopfbereich oder einem Überlauffußbereich handelt es sich um ein positioniertes Teilformular, das jedem sich wiederholenden Teilformular zugewiesen werden kann. In der Regel erstellen Sie zuerst das Teilformular, das als Überlaufkopfbereich bzw. Überlauffußbereich dienen soll. Anschließend weisen Sie es dem sich wiederholenden Teilformular zu und legen die Überlaufeigenschaften fest.
Wenn der Überlaufkopfbereich auch als Ende-Kopfbereich fungiert, wird er in der Palette „Hierarchie“ direkt oberhalb des Teilformulars platziert. Wenn der Überlauffußbereich auch als Ende-Fußbereich fungiert, wird er in der Palette „Hierarchie“ direkt unterhalb des Teilformulars platziert.
So erstellen Sie ein Teilformular für einen Überlaufkopfbereich oder einen Überlauffußbereich
1.
Erstellen Sie einen Formularentwurf mit allen erforderlichen Teilformularen.
2.
Suchen Sie im Formularentwurf das Teilformular, das Sie als Überlaufkopfbereich und/oder Überlauffußbereich verwenden möchten. Wählen Sie dieses Teilformular aus und führen Sie folgende Schritte aus:
      •
      Überprüfen Sie in der Palette „Objekt“ die Einstellungen auf der Registerkarte „Teilformular“. In der Liste „Inhalt“ muss der Eintrag „Position“ angezeigt werden. Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Teilformular“ und stellen Sie sicher, dass in der Liste „Inhalt“ der Eintrag „Position“ ausgewählt ist.
      •
      Überprüfen Sie in der Palette „Objekt“ die Einstellungen auf der Registerkarte „Bindung“. Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und wählen Sie „Teilformular wiederh. f. jedes Datenelement“ aus, damit die Kopf- und Fußbereiche bei mehr als einem Überlauf angezeigt werden. Ende-Kopfbereiche und -Fußbereiche werden hierbei nicht gezählt.
So weisen Sie einem Teilformular einen Überlaufkopfbereich oder einen Überlauffußbereich zu
1.
Wählen Sie das Teilformular bzw. die Teilformulare aus, die wiederholt werden sollen.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und wählen Sie „Teilformular wiederh. f. jedes Datenelement“ aus, damit das Teilformular wiederholt wird.
3.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Paginierung“ und geben Sie im Feld „Überlauf“ einen Inhaltsbereich oder eine Seite an, in dem bzw. auf der die Überlauf-Teilformulare platziert werden sollen.
4.
Wenn Sie einen Überlaufkopfbereich angeben möchten, wählen Sie in der Liste „Überlaufkopfbereich“ das Teilformular aus, das als Überlaufkopfbereich für das aktuelle sich wiederholende Teilformular dienen soll. Sie können in der Liste „Überlaufkopfbereich“ auch „Neu“ auswählen und ein neues Teilformular für den Überlaufkopfbereich definieren.
5.
Wenn Sie einen Überlauffußbereich angeben möchten, wählen Sie in der Liste „Überlauffußbereich“ das Teilformular aus, das als Überlauffußbereich für das aktuelle sich wiederholende Teilformular dienen soll. Sie können in der Liste „Überlauffußbereich“ auch „Neu“ auswählen und ein neues Teilformular als Überlauffußbereich definieren.
Es ist nicht zwingend notwendig, einen Überlaufkopfbereich und einen Überlauffußbereich festzulegen. Ob Sie einen Überlaufkopfbereich und/oder einen Überlauffußbereich oder keinen von beiden verwenden, richtet sich allein nach den Anforderungen Ihres Formulars.
Verwandte Themen
Teilformulare – Übersicht
So erstellen Sie sich wiederholende Teilformulare
Info über Überlaufkopfbereiche und Überlauffußbereiche


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Teilformulare verwenden > Sich wiederholende und mehrseitige Teilformulare erstellen > So steuern Sie Umbrüche in Teilformularen und Teilformularsätzen mit Hilfe von bedingten Anweisungen

So steuern Sie Umbrüche in Teilformularen und Teilformularsätzen mit Hilfe von bedingten Anweisungen

In LiveCycle Designer können für sich wiederholende Teilformularobjekte benutzerspezifische bedingte Umbrüche definiert werden. Anders als bei der Paginierung bei einem Datenüberlauf bieten bedingte Umbrüche die Möglichkeit, manuell zu steuern, wie ein Teilformular auf dem Formular umgebrochen wird. Dies geschieht mit einer Reihe von bedingten Anweisungen.
Mit Hilfe bedingter Anweisungen können Sie die Daten eines Feldes in einem sich wiederholenden Teilformular anhand der vorherigen Instanzen dieses Feldes überprüfen. Das sich wiederholende Teilformular kann dann bei einer Änderung der Daten in diesem Feld entsprechend umgebrochen werden.
So können Sie beispielsweise ein sich wiederholendes Teilformular auf einer Telefonrechnung umbrechen, wenn sich im Feld mit dem Datum der Zahlungsposten eine Änderung ergibt. Die Telefonrechnung wird dann visuell nach Datum umgebrochen, wodurch sie sich leichter lesen lässt.
Neben einer Umbruchbedingung können Sie außerdem ein Teilformular für einen Überlaufkopf- bzw. Überlauffußbereich definieren und angeben, wo auf dem Formular die nächste Instanz des sich wiederholenden Teilformulars platziert werden soll.
1.
Wählen Sie ein Teilformular oder einen Teilformularsatz aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Paginierung“.
3.
Klicken Sie auf „Bearbeiten“ und dann auf „Hinzufügen“ [image], um einen neuen bedingten Umbruch zur Liste hinzuzufügen.
4.
Wählen Sie in der Liste „Sprache“ eine Skriptsprache aus. Die bedingte Anweisung für den bedingten Umbruch wird in dieser Sprache erstellt.
5.
Wählen Sie in der Liste „Ausführen am“ aus, wo das Skript ausgeführt werden soll.
6.
Klicken Sie auf „Beispielausdruck einfügen“ [image] und wählen Sie das Formularentwurfsobjekt im Teilformular, das als Vergleichsfeld für den bedingten Umbruch herangezogen werden soll. Sie können auch Ihre eigene bedingte Anweisung in das Feld eingeben. Damit der bedingte Umbruch ordnungsgemäß funktioniert, müssen alle benutzerdefinierten bedingten Anweisungen entweder true (wahr) oder false (falsch) zurückgeben. Bedingte Anweisungen, die true zurückgeben, werden ausgeführt.
7.
Geben Sie mit einer der folgenden Optionen an, wann das Teilformularobjekt umgebrochen werden soll:
      •
      Wählen Sie „Vor“ aus, wenn der Umbruch unmittelbar vor der aktuellen Instanz des Teilformulars im Formular eingefügt werden soll.
      •
      Wählen Sie „Nach“ aus, wenn der Umbruch unmittelbar nach der aktuellen Instanz des Teilformulars im Formular eingefügt werden soll.
8.
Legen Sie im Feld „Bei“ fest, wo die übrigen Instanzen des umgebrochenen Teilformulars platziert werden sollen.
9.
Wählen Sie in den Listenfeldern „Kopfbereich“ und „Fußbereich“ die Teilformulare für den Überlaufkopfbereich bzw. Überlauffußbereich für diesen bedingten Umbruch (sofern gewünscht) aus.
10.
Wiederholen Sie die Schritte 2 bis 8 für alle bedingten Umbrüche, die im ausgewählten Teilformular eingefügt werden sollen.
11.
Klicken Sie auf „OK“, wenn Sie der Liste alle gewünschten Einträge hinzugefügt haben.
Nachdem Sie alle bedingten Umbrüche erstellt haben, sollten Sie überprüfen, in welcher Reihenfolge sie im Dialogfeld „Bedingte Umbrüche bearbeiten“ angezeigt werden. Die bedingten Umbrüche werden von LiveCycle Designer sequenziell in der hier angezeigten Reihenfolge von oben nach unten verarbeitet. Alle bedingten Umbrüche, für deren bedingte Anweisung true zurückgegeben wird, werden ausgeführt.
Sie können die Reihenfolge der Einträge in der Liste mit Hilfe der Schaltflächen „Nach oben“ [image] bzw. „Nach unten“ [image] wie gewünscht ändern.
Verwandte Themen
Dialogfeld „Bedingte Umbrüche bearbeiten“
Eigenschaften von Teilformularen: Registerkarte „Paginierung“
Berechnungen und Skripten


Auswahl-Teilformularsätze verwenden

Info über Auswahl-Teilformularsätze
So erstellen Sie Auswahl-Teilformularsätze
So können Sie Teilformulare zu Auswahl-Teilformularsätzen hinzufügen und daraus entfernen
So erstellen Sie Datenbindungen und bedingte Anweisungen für Auswahl-Teilformularsätze


Info über Auswahl-Teilformularsätze

Bei einem Auswahl-Teilformularsatz handelt es sich um eine Abwandlung des Teilformularsatzobjekts, mit dem Sie die Anzeige bestimmter Teilformulare im Satz mit Hilfe von bedingten Anweisungen anpassen können. Wie Teilformularsätze werden auch Auswahl-Teilformularsätze an die Daten einer Datenverbindung gebunden. Auswahl-Teilformularsätze bieten jedoch eine bessere Kontrolle darüber, welche Teilformulare im Satz zur Laufzeit angezeigt werden. So können Sie beispielsweise mit Hilfe eines Auswahl-Teilformularsatzes festlegen, dass die Instanzen eines sich wiederholenden Teilformulars je nach dem Wert eines bestimmten Feldes im Teilformular mit anderen Textfarben angezeigt wird.
Verwandte Themen
So erstellen Sie Auswahl-Teilformularsätze
So können Sie Teilformulare zu Auswahl-Teilformularsätzen hinzufügen und daraus entfernen
So erstellen Sie Datenbindungen und bedingte Anweisungen für Auswahl-Teilformularsätze


So erstellen Sie Auswahl-Teilformularsätze

Sie können einen Auswahl-Teilformularsatz anhand eines vorhandenen Teilformularsatzes oder anhand eines vorhandenen Teilformularobjekts erstellen.
So erstellen Sie einen Auswahl-Teilformularsatz anhand eines vorhandenen Teilformularsatzes
1.
Wählen Sie einen Teilformularsatz aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Teilformularsatz“ und wählen Sie in der Liste „Typ“ die Option „Teilformular aus Alternativen auswählen“ aus.
So erstellen Sie einen Auswahl-Teilformularsatz anhand eines Teilformularobjekts
      *
      Wählen Sie ein Teilformularobjekt aus und klicken Sie auf „Einfügen“ > „In Auswahl-Teilformularsatz aufnehmen“.
Verwandte Themen
Info über Auswahl-Teilformularsätze
So können Sie Teilformulare zu Auswahl-Teilformularsätzen hinzufügen und daraus entfernen
So erstellen Sie Datenbindungen und bedingte Anweisungen für Auswahl-Teilformularsätze
Dialogfeld „Datenteilformulare bearbeiten“


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Teilformulare verwenden > Auswahl-Teilformularsätze verwenden > So können Sie Teilformulare zu Auswahl-Teilformularsätzen hinzufügen und daraus entfernen

So können Sie Teilformulare zu Auswahl-Teilformularsätzen hinzufügen und daraus entfernen

Sie können Teilformularobjekte auf eine der folgenden Arten zu einem Auswahl-Teilformularsatz hinzufügen bzw. daraus entfernen:
      •
      Über das Dialogfeld „Datenteilformulare bearbeiten“
      •
      Durch manuelles Bearbeiten des Inhalts durch Ziehen von Teilformularobjekten aus bzw. in den Auswahl-Teilformularsatz mit Hilfe der Palette „Hierarchie“
Wenn Sie ein Teilformular über das Dialogfeld „Datenteilformulare bearbeiten“ aus der Liste „Alternative Teilformulare“ löschen, wird das Teilformularobjekt vollständig aus dem Formularentwurf entfernt. Wenn Sie das Teilformularobjekt nur aus dem Auswahl-Teilformularsatz, nicht jedoch aus dem Entwurf löschen möchten, müssen Sie es mit Hilfe der Palette „Hierarchie“ manuell aus dem Auswahl-Teilformularsatz ziehen.
So fügen Sie einem Auswahl-Teilformularsatz ein Teilformular hinzu
1.
Wählen Sie einen Teilformularsatz aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Teilformularsatz“ und wählen Sie „Alternativen bearbeiten“ aus.
3.
Klicken Sie auf die Schaltfläche „Hinzufügen“ [image], um einen neuen Eintrag zum Listenelement „Alternative Teilformulare“ hinzuzufügen. Sie können auch Teilformularobjekte mit Hilfe der Palette „Hierarchie“ in den Auswahl-Teilformularsatz ziehen.
Durch das Hinzufügen eines neuen Teilformulars wird ein Duplikat des derzeit ausgewählten Teilformularobjekts hinzugefügt. Falls kein Teilformular ausgewählt ist, wird dem Auswahl-Teilformularsatz ein neues unbenanntes Teilformular hinzugefügt.
4.
Sie können das neue Teilformular mit den Schaltflächen „Nach oben“ [image] und „Nach unten“ [image] an die gewünschte Position verschieben. Die Reihenfolge der Einträge in der Liste „Alternative Teilformulare“ ist wichtig, da sie zur Laufzeit in dieser Reihenfolge verarbeitet werden. Der erste Eintrag, für den true zurückgegeben wird, wird im Formular angezeigt.
So entfernen Sie ein Teilformular aus einem Auswahl-Teilformularsatz
1.
Wählen Sie einen Teilformularsatz aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Teilformularsatz“ und wählen Sie „Alternativen bearbeiten“ aus.
3.
Wählen Sie einen Eintrag in der Liste „Alternative Teilformulare“ aus und klicken Sie auf die Schaltfläche „Löschen“ [image].
Verwandte Themen
Info über Auswahl-Teilformularsätze
So erstellen Sie Datenbindungen und bedingte Anweisungen für Auswahl-Teilformularsätze
Dialogfeld „Datenteilformulare bearbeiten“


Zurück Weiter

LiveCycle Designer verwenden > Mit Formularentwürfen arbeiten > Teilformulare verwenden > Auswahl-Teilformularsätze verwenden > So erstellen Sie Datenbindungen und bedingte Anweisungen für Auswahl-Teilformularsätze

So erstellen Sie Datenbindungen und bedingte Anweisungen für Auswahl-Teilformularsätze

Nachdem Sie einen Auswahl-Teilformularsatz erstellt haben, können Sie für die verschiedenen Teilformularobjekte im Satz Datenbindungen mit oder ohne bedingte Anweisungen erstellen. Durch bedingte Anweisungen erhalten Sie eine bessere Kontrolle darüber, wann Teilformulare des Auswahl-Teilformularsatzes im Formular angezeigt werden, als wenn Sie nur eine Datenbindung festlegen.
Sie können für alle in der Liste „Alternative Teilformulare“ des Dialogfeldes „Datenteilformulare bearbeiten“ aufgeführten Teilformularobjekte einen Datenknoten der Datenverbindung festlegen. Wenn Sie eine bedingte Anweisung verwenden, können Sie einen Ausdruck eingeben, für den zur Laufzeit entweder true (wahr) oder false (falsch) zurückgegeben wird. Nur der erste Eintrag in der Liste „Alternative Teilformulare“, bei dem für eine bedingte Anweisung true zurückgegeben wird, wird im Formular angezeigt.
Wenn Sie für einen Eintrag in der Liste „Alternative Teilformulare“ keine bedingte Anweisung festlegen, wird für diesen Eintrag der Wert true angenommen.
1.
Wählen Sie einen Teilformularsatz aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Teilformularsatz“ und stellen Sie sicher, dass in der Liste „Typ“ die Option „Teilformular aus Alternativen auswählen“ ausgewählt ist.
3.
Wählen Sie „Alternativen bearbeiten“ aus.
4.
Wählen Sie „Alternativen bearbeiten“ aus und führen Sie einen der folgenden Schritte aus, um eine Datenbindung für ein Teilformular im Teilformularsatz festzulegen:
      •
      Wählen Sie die Option „Teilformular auswählen, dessen Name mit Datenelement oder Attribut übereinstimmt“ aus, um dem Teilformular einen Datenknoten anhand des Namens zuzuordnen. In diesem Fall müssen die Namen der zugehörigen Datenknoten mit den Namen der Teilformularobjekte im Formularentwurf übereinstimmen.
      •
      Wählen Sie die Option „Teilformular über Ausdruck auswählen“ aus, um die Bindung der Teilformularobjekte im Entwurf an die Datenknoten der Datenverbindung manuell festzulegen.
5.
Wählen Sie im Listenfeld „Datenverbindung“ die gewünschte Datenquelle für die Datenbindung aus.
6.
Klicken Sie auf die Schaltfläche „Hinzufügen“ [image], um ein neues Teilformular zum Auswahl-Teilformularsatz hinzuzufügen, oder wählen Sie einen vorhandenen Eintrag in der Liste aus. Durch das Hinzufügen eines neuen Teilformulars wird ein Duplikat des derzeit ausgewählten Teilformularobjekts hinzugefügt. Falls kein Teilformular ausgewählt ist, wird dem Auswahl-Teilformularsatz ein neues unbenanntes Teilformular hinzugefügt.
7.
Geben Sie ggf. im Feld „Name“ einen Namen für das neue Teilformularobjekt ein. Wenn Sie die Bindung anhand des Namens des Datenelements oder Attributs vornehmen, muss der Name in diesem Feld genau dem Namen des zugehörigen Datenknotens entsprechen.
Wenn Sie in Schritt 4 die Option „Teilformular auswählen, dessen Name mit Datenelement oder Attribut übereinstimmt“ aktiviert haben, fahren Sie direkt mit Schritt 11 fort. Andernfalls gehen Sie zu Schritt 8 über.
8.
Klicken Sie auf den Pfeil neben dem Feld „Bindung“ und wählen Sie einen Datenknoten im Menü aus. LiveCycle Designer füllt das Feld „Bindung“ automatisch mit einem Skriptverweis auf den ausgewählten Datenknoten aus. Sie können den Verweis auch manuell in das Feld eingeben.
9.
Wählen Sie in der Liste „Sprache“ eine Skriptsprache aus.
10.
Geben Sie im Feld „Ausdruck“ das Skript für die gewünschten Aktionen oder die Verarbeitung des angegebenen Teilformularobjekts und des angegebenen Datenknotens ein.
11.
Wiederholen Sie die Schritte 6 bis 10 für alle weiteren alternativen Teilformulare.
12.
Klicken Sie auf „OK“, wenn Sie der Liste alle gewünschten Einträge hinzugefügt haben.
Verwandte Themen
Info über Auswahl-Teilformularsätze
Objekteigenschaften und -werte referenzieren
So erstellen Sie Auswahl-Teilformularsätze
Dialogfeld „Datenteilformulare bearbeiten“


Vorlagen erstellen und verwalten

Vorlagen und der Vorlagen-Manager
So erstellen Sie eine Vorlage
So fügen Sie dem Vorlagen-Manager eine Vorlage hinzu
So importieren Sie Vorlagen
So können Sie einen Formularentwurf anhand einer Vorlage erstellen und anpassen
So löschen Sie eine Vorlage aus dem Vorlagen-Manager
So benennen Sie eine Vorlage im Vorlagen-Manager um
So legen Sie im Vorlagen-Manager eine Standardvorlage fest
So stellen Sie die Standardvorlagen im Vorlagen-Manager wieder her
So fügen Sie dem Vorlagen-Manager eine Registerkarte hinzu
So löschen Sie eine Registerkarte aus dem Vorlagen-Manager
So verschieben Sie eine Vorlage im Vorlagen-Manager auf eine andere Registerkarte
So bestimmen Sie, wo die Vorlagendateien gespeichert werden:
So passen Sie die Ansicht im Vorlagen-Manager an


Vorlagen und der Vorlagen-Manager

Eine Vorlage liefert die Grundstruktur des Formularentwurfs und enthält darüber hinaus vordefinierte Dateierstellungsinformationen, die von LiveCycle Designer auf den Formularentwurf angewendet werden. Vorlagen enthalten Definitionen von Objekten, die in einem Formularentwurf verwendet werden sollen, sowie das Seitenlayout des Formularentwurfs. Eine Vorlage kann sämtliche Eigenschaften speichern, die Sie in mehr als einem Formularentwurf verwenden möchten. Dazu gehören unter anderem:
      •
      Layouts von Masterseiten, welche das Format von Seiten beeinflussen
      •
      Textbausteinobjekte, einschließlich formatierter Kopf- und Fußzeilen
      •
      Eingebettete Bilder oder Objekte, die mit häufig verwendeten Grafiken wie Logos oder Wasserzeichen verknüpft sind
      •
      Alle Textvariablen oder schwebenden Felder, die Sie als Platzhalter für Daten verwenden
      •
      Vordefinierte Formelgleichungen und Skriptfragmente
      •
      Dateieigenschaften und Dateierstellungsinformationen
      •
      Weitere Eigenschaften, die Ihre Arbeit erleichtern oder automatisieren
Das Erstellen einer Vorlage ist dem Erstellen eines Formularentwurfs sehr ähnlich. Der Unterschied besteht darin, dass das Layout, die Dateieinstellungen und die Voreinstellungen, die Sie für eine Vorlage auswählen, in der Regel für mehr als nur einen Formularentwurf benötigt werden. Sie können nach Wunsch auch Objekte hinzufügen und definieren, die in mehreren Formularentwürfen eingesetzt werden können. Wenn Sie Layouts und Eigenschaften, die in vielen Formularentwürfen häufig auftreten, in Vorlagen berücksichtigen, können Sie viel Zeit sparen, weil auf Vorlagen beruhende Formularentwürfe weniger Vorbereitung erfordern.
Der Vorlagen-Manager bietet eine Vielzahl von Mustervorlagen, die zum Lieferumfang von LiveCycle Designer gehören. Auch Vorlagen, die Sie in LiveCycle Designer erstellen und verwenden, können vom Vorlagen-Manager verwaltet werden.
Der Vorlagen-Manager ist für folgende Aufgaben vorgesehen:
      •
      Anzeigen der Vorlagen in einer Vorschau
      •
      Auswählen einer Standardvorlage zum Erstellen von Formularentwürfen
      •
      Hinzufügen, Löschen und Umbenennen von Vorlagen sowie Hinzufügen und Entfernen von Gruppen
Im Vorlagen-Manager können Sie außerdem Registerkarten hinzufügen oder löschen, Vorlagen zwischen Registerkarten verschieben und bestimmen, wo die Vorlagen von LiveCycle Designer im Dateisystem gespeichert werden. Jede Registerkarte entspricht einem Ordner im Dateisystem. Standardmäßig werden Vorlagendateien im LiveCycle Designer-Ordner „Templates“ gespeichert.
Verwandte Themen
Formulare und Formularentwürfe
So erstellen Sie Formularentwürfe anhand von Vorlagen, Mustern oder vorhandenen Formularen


So erstellen Sie eine Vorlage

Vorlagendateien (TDS) lassen sich mit dem Assistenten für neue Formulare sehr einfach erstellen. Der Assistent für neue Formulare führt Sie durch die Arbeitsschritte, die zum Erstellen einer Vorlage erforderlich sind. Dazu gehören die Vorschau und Auswahl der gewünschten Vorlage, die Eingabe der Kontaktinformationen des Unternehmens sowie das Hinzufügen einer E-Mail-Senden-Schaltfläche und einer Drucken-Schaltfläche. Wenn Sie es vorziehen, den Assistenten für neue Formulare nicht zu verwenden, können Sie über „Extras“ > „Vorlagen-Manager“ das Dialogfeld „Vorlagen-Manager“ öffnen und dort die gewünschte Vorlage direkt auswählen.
1.
Der Assistent für neue Formulare kann folgendermaßen geöffnet werden:
      •
      Wählen Sie „Datei“ > „Neu“.
      •
      Klicken Sie in der Werkzeugleiste neben der Schaltfläche „Neu“ auf den nach unten zeigenden Pfeil und wählen Sie „Neu“.
2.
Wählen Sie im Assistenten für neue Formulare die Option „Anhand einer Vorlage“ und klicken Sie auf „Weiter“.
3.
Folgen Sie den Anweisungen auf dem Bildschirm und passen Sie die Vorlage an Ihre Anforderungen an.
4.
Wählen Sie „Datei“ > „Speichern unter“.
5.
Wählen Sie in der Liste „Dateityp“ die Option „Adobe LiveCycle Designer -Vorlage (*.tds)“ aus.
6.
Klicken Sie auf „Speichern“.
Verwandte Themen
So erstellen Sie Formularentwürfe anhand von Vorlagen, Mustern oder vorhandenen Formularen


So fügen Sie dem Vorlagen-Manager eine Vorlage hinzu

1.
Wählen Sie „Extras“ > „Vorlagen-Manager“.
2.
Klicken Sie auf die Registerkarte, welcher die Vorlage hinzugefügt werden soll.
3.
Wählen Sie im Palettenmenü den Befehl „Vorlage hinzufügen“.
4.
Gehen Sie zum gewünschten Ordner, wählen Sie die hinzuzufügende Vorlagendatei (TDS) aus und klicken Sie auf „Öffnen“. Ein Kopie der Vorlagendatei wird dem Vorlagen-Manager hinzugefügt.


So importieren Sie Vorlagen

Sie können beliebige Vorlagendateien (TDS) in LiveCycle Designer importieren und diese Vorlagen dann in den Vorlagen-Manager kopieren, als Grundlage für ein neues Formular verwenden oder auch bearbeiten.
Beim Importieren einer Vorlage wird entweder dem im XML-Quellcode des Formulars angegebenen Vorgabenordner oder, wenn eine Speicherortangabe fehlt, dem Ordner „Sonstige“ automatisch eine Kopie hinzugefügt. Die importierte Vorlage wird im Vorlagen-Manager auf der entsprechenden Registerkarte aufgeführt. Wenn auf der Registerkarte bereits eine gleichnamige Vorlage vorhanden ist, werden Sie von LiveCycle Designer aufgefordert, die vorhandene Datei zu ersetzen.
1.
Die zu importierende Vorlagendatei kann folgendermaßen geöffnet werden:
      •
      Wählen Sie „Datei“ > „Öffnen“, gehen Sie zum gewünschten Ordner, wählen Sie die Vorlagendatei (TDS) aus und klicken Sie auf „Öffnen“.
      •
      Doppelklicken Sie im Windows Explorer auf die Vorlagendatei (TDS).
      •
      Ziehen Sie die Vorlagendatei (TDS) aus dem Windows Explorer in den LiveCycle Designer-Arbeitsbereich.
2.
Wählen Sie im Dialogfeld „Vorlagenoptionen“ eine der folgenden Optionen aus:
      •
      Soll die Vorlage dem Vorlagen-Manager hinzugefügt werden, aktivieren Sie „Diese Vorlage in den Vorlagen-Manager kopieren“.
      •
      Soll anhand der Vorlage ein PDF-Formular erstellt werden, aktivieren Sie „Neues Formular anhand dieser Vorlage erstellen“.
      •
      Soll die Vorlage in LiveCycle Designer geöffnet und bearbeitet werden, aktivieren Sie „Diese Vorlage bearbeiten“.
3.
Klicken Sie auf „OK“.


So können Sie einen Formularentwurf anhand einer Vorlage erstellen und anpassen

Vorlagendateien (TDS) enthalten manchmal Feldbeschriftungen, statische Textobjekte oder statische Bilder mit anpassbarem Text oder anpassbaren Bildern. Wenn Sie ein Formular anhand einer Vorlage erstellen, die Felder mit anpassbarem Text oder anpassbaren Bildern enthält, wird der Assistent für neue Formulare angezeigt, um Ihnen die Gelegenheit zu geben, die in den Feldern angezeigten Informationen an Ihre Anforderungen anzupassen. Beispielsweise enthalten die im Vorlagen-Manager verfügbaren Mustervorlagen anpassbaren Text und anpassbare Bilder, die Sie durch den Namen, die Adresse, die Telefonnummer und das Logo Ihrer Firma ersetzen können.
Die Informationen, die Sie in den einzelnen Feldern eingeben, werden gespeichert. Wenn Sie die Vorlage das nächste Mal öffnen, werden die gleichen Felder vom Assistenten für neue Formulare automatisch anhand der gespeicherten Daten ausgefüllt.
1.
Der Assistent für neue Formulare kann folgendermaßen geöffnet werden:
      •
      Wählen Sie „Datei“ > „Neu“.
      •
      Klicken Sie in der Werkzeugleiste neben der Schaltfläche „Neu“ auf den nach unten zeigenden Pfeil und wählen Sie „Neu“.
2.
Wählen Sie im Assistenten für neue Formulare die Option „Anhand einer Vorlage“ und klicken Sie auf „Weiter“.
3.
Folgen Sie den Anweisungen auf dem Bildschirm und passen Sie die neue Vorlage an Ihre Anforderungen an.
4.
Geben Sie für die Datei einen Namen ein und speichern Sie sie.


So löschen Sie eine Vorlage aus dem Vorlagen-Manager

1.
Wählen Sie „Extras“ > „Vorlagen-Manager“.
2.
Klicken Sie auf die Registerkarte, auf welcher sich die Vorlage befindet.
3.
Klicken Sie mit der rechten Maustaste auf die Vorlage und wählen Sie „Vorlage löschen“.
4.
Wenn Sie gefragt werden, ob Sie die Vorlage wirklich löschen möchten, klicken Sie auf „Ja“. Die Datei wird aus dem Dateisystem des Computers gelöscht.


So benennen Sie eine Vorlage im Vorlagen-Manager um

1.
Wählen Sie „Extras“ > „Vorlagen-Manager“.
2.
Klicken Sie auf die Registerkarte, auf welcher sich die Vorlage befindet.
3.
Klicken Sie mit der rechten Maustaste auf die Vorlage und wählen Sie „Vorlage umbenennen“.
4.
Geben Sie einen anderen Namen für die Vorlage ein und drücken Sie die Eingabetaste.


So legen Sie im Vorlagen-Manager eine Standardvorlage fest

1.
Wählen Sie „Extras“ > „Vorlagen-Manager“.
2.
Klicken Sie auf die Registerkarte, auf welcher sich die Vorlage befindet.
3.
Wählen Sie die Vorlage aus.
4.
Klicken Sie auf „Auswahl als Standard definieren“.


So stellen Sie die Standardvorlagen im Vorlagen-Manager wieder her

Sie können die im Dialogfeld „Vorlagen-Manager“ auf den beiden Registerkarten „Leer“ und „Formulare“ verfügbaren Standardvorlagen wiederherstellen.
Beim Wiederherstellen von Vorlagen werden alle in LiveCycle Designer auf den beiden Registerkarten „Leer“ und „Formulare“ ursprünglich bereitgestellten Vorlagen wiederhergestellt. LiveCycle Designer ersetzt alle fehlenden Vorlagen und überschreibt gleichnamige Vorlagen mit den Originaldateien.
1.
Wählen Sie „Extras“ > „Vorlagen-Manager“.
2.
Klicken Sie auf die Registerkarte „Leer“ oder „Formulare“.
3.
Wählen Sie im Palettenmenü den Befehl „Standardvorlagen wiederherstellen“.


So fügen Sie dem Vorlagen-Manager eine Registerkarte hinzu

Wenn Sie dem Vorlagen-Manager eine Registerkarte hinzufügen, wird von LiveCycle Designer im Ordner „Templates“ ein gleichnamiger Unterordner angelegt.
1.
Wählen Sie „Extras“ > „Vorlagen-Manager“.
2.
Wählen Sie im Palettenmenü den Befehl „Kategorie hinzufügen“.
3.
Geben Sie einen Namen für die Registerkarte ein und klicken Sie auf „OK“.


So löschen Sie eine Registerkarte aus dem Vorlagen-Manager

Wenn Sie aus dem Vorlagen-Manager eine Registerkarte löschen, wird der gleichnamige Unterordner im Ordner „Templates“ von LiveCycle Designer entfernt.
1.
Wählen Sie „Extras“ > „Vorlagen-Manager“.
2.
Klicken Sie auf die zu löschende Registerkarte.
3.
Wählen Sie im Palettenmenü den Befehl „Kategorie entfernen“.
4.
Wenn Sie gefragt werden, ob Sie die Registerkarte löschen möchten, wählen Sie eine der folgenden Vorgehensweisen:
      •
      Wenn Sie das ausgewählte Register, den zugehörigen Kategorieordner und die zugehörigen Vorlagen löschen möchten, wählen Sie „Kategorie entfernen und alle zugehörigen Vorlagen daraus entfernen“.
      •
      Wenn Sie die Vorlagen vor dem Löschen der ausgewählten Registerkarte und des zugehörigen Kategorieordners auf eine andere Registerkarte verschieben möchten, wählen Sie „Kategorie entfernen und alle zugehörigen Vorlagen verschieben in Kategorie [Registerkartenname]“. Klicken Sie dann auf die Registerkarte, auf welche die Vorlagen verschoben werden sollen.
5.
Klicken Sie auf „OK“.


So verschieben Sie eine Vorlage im Vorlagen-Manager auf eine andere Registerkarte

1.
Wählen Sie „Extras“ > „Vorlagen-Manager“.
2.
Klicken Sie auf die gewünschte Registerkarte. Klicken Sie dann mit der rechten Maustaste auf die zu verschiebende Vorlage und wählen Sie „Vorlage verschieben nach > [Registerkartenname]“.


So bestimmen Sie, wo die Vorlagendateien gespeichert werden:

1.
Wählen Sie „Extras“ > „Vorlagen-Manager“.
2.
Klicken Sie auf die gewünschte Registerkarte.
3.
Wählen Sie im Palettenmenü den Befehl „Kategorie-Eigenschaften“. Das Dialogfeld „Vorlagenkategorie-Eigenschaften“ zeigt den Speicherort der Vorlagen an, die gegenwärtig auf der ausgewählten Registerkarte aufgeführt sind.


So passen Sie die Ansicht im Vorlagen-Manager an

1.
Wählen Sie „Extras“ > „Vorlagen-Manager“.
2.
Klicken Sie auf die gewünschte Registerkarte.
3.
Wählen Sie im Palettenmenü „Ansicht“ und dann eine der folgenden Optionen:
      •
      Wählen Sie „Große Symbole“, wenn die Vorlagennamen als Symbole angezeigt werden sollen.
      •
      Wählen Sie „Liste“, wenn die Vorlagennamen in einer Liste angezeigt werden sollen.


Mit Objekten arbeiten

Info über Objekte
Objekte verwenden
Objekte hinzufügen, kopieren und löschen
Objekte auswählen, gruppieren und verschieben
Objekte ausrichten und in der Größe ändern
Objekte formatieren
Formularobjektsammlungen verwenden
Objekte als sichtbar, unsichtbar oder ausgeblendet definieren
Beschriftungen formatieren
Feldwerte formatieren
Objekte für andere Sprachen einrichten
Besondere Objekte verwenden


Info über Objekte

Was ist ein Objekt?
Objektkategorien
So ändern Sie den Objekttyp
So können Sie Objekte benennen und umbenennen
So legen Sie den Randstil fest
So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest
Objekte, die Skripten und Berechnungen unterstützen


Was ist ein Objekt?

Objekte sind die Bausteine für jedes Formular. Jedes Objekt fügt Ihrem Formular eine Funktionalität hinzu, wie z. B. ein Feld zum Eingeben von Text oder eine Schaltfläche, über die das Formular per E-Mail versendet werden kann. Beim Erstellen Ihres Formulars wählen Sie Objekte aus und fügen sie der Text- oder Masterseite des Formularentwurfs hinzu. Alle verfügbaren Objekte befinden sich in der Palette „Bibliothek“.
Die Objekte in der Palette „Bibliothek“ sind in verschiedene Kategorien unterteilt. Die Kategorie „Favoriten“ enthält die Objekte, die Sie am häufigsten verwenden. Die Kategorien „Standard“ und „Barcode“ enthalten die Hauptobjekte. Zusätzlich steht in der Kategorie „Eigene“ eine Reihe vordefinierter eigener Objekte bereit.


Objektkategorien

Die meisten dieser Objekte lassen sich in zwei Kategorien einteilen:
Textbausteinobjekte oder statische Objekte
Statische Objekte können keine Daten erfassen oder anzeigen. Sie stellen hingegen festgelegten Text oder Grafikinformationen dar. Zu diesen Objekten gehören Kreise, Linien, Rechtecke, Bilder und Text. Statische Objekte können in allen Formulartypen verwendet werden.
Feldobjekte
Feldobjekte können Daten erfassen und anzeigen. Zu diesen Objekten gehören Barcodes, Schaltflächen, Kontrollkästchen, Datums-/Uhrzeitfelder, Dropdown-Listen, Bildfelder, Listenfelder, Kennwort- und Dokumentunterschriftsfelder, Optionsfelder und Textfelder. Einige Feldobjekte, wie z. B. Textfelder, können in allen Formulartypen verwendet werden. Dabei ist es nicht relevant, ob das Formular interaktiv ist, von einem Benutzer ausgefüllt oder durch Zusammenführen mit einer Datenquelle ausgefüllt wird. Andere Objekte, wie z. B. Dropdown-Listen, sind speziell für interaktive Formulare vorgesehen.
Die folgenden Objekte stehen auf den Registerkarten „Standard“ und „Barcodes“ der Palette „Bibliothek“ zur Verfügung.

Objekt

Beschreibung

Kategorie

Verwendung

Weitere Informationen
Barcode
Ein Symbol, das einen Barcode kennzeichnet.
Statisch
Mit jedem Formulartyp kompatibel.
Barcodes – Übersicht
Bild
Ein Objekt, das ein Bild wie ein Logo oder ein Symbol anzeigt.
Statisch
Mit jedem Formulartyp kompatibel.
Bilder – Übersicht
Bildfeld
Ein Platzhalter, für den ein Bild dynamisch geladen wird, wenn das Formular dargestellt wird.
Feld
Mit jedem Formulartyp kompatibel.
Bildfelder – Übersicht
Datums-/Uhrzeitfeld
Ein Feld, in dem Datums-/Uhrzeitdaten akzeptiert und angezeigt werden und das Mustererkennung unterstützt.
Feld
Mit jedem Formulartyp kompatibel.
Datums-/Uhrzeitfelder – Übersicht
Dezimalfeld
Ein Feld, in dem Dezimaldaten akzeptiert und angezeigt werden und das Mustererkennung unterstützt.
Feld
Mit jedem Formulartyp kompatibel.
Dezimalfelder – Übersicht
Dokumentunterschriftsfeld
Ein Steuerelement, über das Benutzer dem Formular eine elektronische Unterschrift hinzufügen können.
Feld
Mit jedem Formulartyp kompatibel.
Dokumentunterschriftsfelder – Übersicht
Dropdown-Liste
Eine Liste mit mehreren Optionen, von denen eine Option ausgewählt werden kann. Es wird jeweils nur eine Option angezeigt.
Feld
Für interaktive Formulare.
Dropdown-Listen und Listenfelder – Übersicht
Drucken-Schaltfläche
Eine konfigurierte Schaltfläche, über die Benutzer das Formular drucken können.
Feld
Für interaktive Formulare.
Drucken-Schaltflächen – Übersicht
E-Mail-Senden-Schaltfläche
Eine Schaltfläche, über die Formularbenutzer Daten an eine angegebene E-Mail-Adresse zurücksenden können.
Feld
Für interaktive Formulare.
E-Mail-Senden-Schaltflächen – Übersicht
HTTP-Senden-Schaltfläche
Eine Schaltfläche, über die Formularbenutzer Daten via HTTP-Post an eine angegebene URL zurücksenden können.
Feld
Für interaktive Formulare.
HTTP-Senden-Schaltflächen – Übersicht
Inhaltsbereich
Ein Container, der sich in der Objekthierarchie auf der obersten Ebene befindet und den Bereich eines Formulars definiert, in den Objekte platziert werden können.
Statisch
Jede Masterseite definiert mindestens einen Inhaltsbereich.
Inhaltsbereiche – Übersicht
Kennwortfeld
Ein Feld, in dem alphanumerische Kennwörter akzeptiert und verdeckt eingegeben werden können.
Feld
Mit jedem Formulartyp kompatibel.
Kennwortfelder – Übersicht
Kontrollkästchen
Ein Objekt, das den Zustand aktiviert („An“) und deaktiviert („Aus“) annehmen kann.
Feld
Mit jedem Formulartyp kompatibel.
Kontrollkästchen – Übersicht
Kreis
Ein Kreis, eine Ellipse oder ein Bogen.
Statisch
Mit jedem Formulartyp kompatibel.
Kreise, Linien und Rechtecke – Übersicht
Linien
Eine durchgezogene, gestrichelte oder gepunktete Linie.
Statisch
Mit jedem Formulartyp kompatibel.
Kreise, Linien und Rechtecke – Übersicht
Listenfeld
Eine Liste mit mehreren Optionen, von denen eine Option ausgewählt werden kann. Es werden mehrere Optionen gleichzeitig angezeigt.
Feld
Für interaktive Formulare.
Dropdown-Listen und Listenfelder – Übersicht
Numerisches Feld
Ein Feld, in dem numerische Daten akzeptiert und angezeigt werden und das Mustererkennung unterstützt.
Feld
Mit jedem Formulartyp kompatibel.
Numerische Felder – Übersicht
Optionsfeld
Ein Objekt, das eine Auswahl unter einer Gruppe sich gegenseitig ausschließender Auswahlmöglichkeiten darstellt.
Feld
Mit jedem Formulartyp kompatibel.
Optionsfelder – Übersicht
Papierformular-Barcode
Ein 2D-Barcode, mit dem in einem interaktiven Formular die vom Benutzer eingegebenen Daten kodiert werden. Um den Papierformular-Barcode verwenden zu können, muss Ihr Unternehmen die LiveCycle Barcoded Forms-Lösung implementiert haben.
Feld
Für interaktive Formulare.
Papierformular-Barcodes – Übersicht
Rechteck
Ein Rechteck mit normalen, gekerbten oder abgerundeten Ecken.
Statisch
Mit jedem Formulartyp kompatibel.
Kreise, Linien und Rechtecke – Übersicht
Schaltfläche
Eine Schaltfläche zum Übergeben von Befehlen oder Client-Anforderungen.
Feld
Für interaktive Formulare.
Schaltflächen – Übersicht
Tabelle
Ein Container, der aus Zeilen und Spalten mit Zellen besteht, die Formularfelder enthalten und mit Daten zusammengeführt werden können.
Statisches Objekt oder Feldobjekt
Mit jedem Formulartyp kompatibel.
Info über Tabellen
Teilformular
Ein Container, der das Positionieren von Objekten steuert. Jede Seite ist ein Teilformular und kann weitere Teilformulare enthalten.
Statisch
Mit jedem Formulartyp kompatibel.
Teilformulare – Übersicht
Text
Schreibgeschützter Text.
Statisch
Mit jedem Formulartyp kompatibel.
Text – Übersicht
Textfeld
Ein Feld, in dem Textdaten akzeptiert und angezeigt werden und das Mustererkennung unterstützt.
Feld
Mit jedem Formulartyp kompatibel.
Textfelder – Übersicht
Zurücksetzen-Schaltfläche
Eine Schaltfläche, auf die Formularbenutzer klicken können, um den Inhalt der Formularfelder auf die Standardwerte zurückzusetzen.
Feld
Für interaktive Formulare.
Zurücksetzen-Schaltflächen – Übersicht
Verwandte Themen
Info über benutzerdefinierte Objekte
So erstellen Sie ein benutzerdefiniertes Objekt


So ändern Sie den Objekttyp

Es gibt mehrere Möglichkeiten zum Ändern des Objekttyps:
      •
      Löschen des Objekts im Formularentwurf und Ziehen des erforderlichen Objekts aus der Palette „Bibliothek“ in den Formularentwurf
      •
      Über die Liste „Typ“ auf der Registerkarte „Feld“ in der Palette „Objekt“ (für Feldobjekte, wie z. B. Textfelder, numerische Felder und Schaltflächen)
      •
      Über die Liste im Feldeditor (für Feldobjekte, wie z. B. Textfelder, numerische Felder und Schaltflächen)
      •
      Über die Liste „Typ“ auf der Registerkarte „Zeichnen“ in der Palette „Objekt“ (für statische Objekte, wie z. B. Kreise, Linien und Text)
So ändern Sie den Objekttyp über die Liste „Typ“ auf den Registerkarten der Palette „Objekt“
1.
Wählen Sie das zu ändernde Objekt aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ oder „Zeichnen“ und wählen Sie in der Liste „Typ“ einen neuen Objekttyp aus.
So ändern Sie den Objekttyp über die Liste „Typ“ im Feldeditor
1.
Wählen Sie das zu ändernde Objekt aus. Wenn der Feldeditor nicht für das Objekt angezeigt wird, wählen Sie „Ansicht“ > „Feldeditor“.
2.
Wählen Sie in der Liste „Typ“ einen neuen Objekttyp aus.


So können Sie Objekte benennen und umbenennen

Wenn Sie ein Objekt aus der Palette „Bibliothek“ in Ihren Formularentwurf ziehen, erhält es standardmäßig den Namen des Objekts gefolgt von einer Zahl, die die Anzahl der Kopien desselben Objekts im Formularentwurf angibt. Wenn Ihr Formularentwurf z. B. zwei Listenfeldobjekte enthält, erhalten diese die Standardnamen „Listenfeld1“ und „Listenfeld2“. Diese Benennung wird als Häufigkeit des Vorkommens bezeichnet.
Beim Erstellen des Formularentwurfs wird der Name des Objekts an folgenden Stellen angezeigt:
      •
      Palette „Hierarchie“
      •
      Registerkarte „Bindung“ der Palette „Objekt“
      •
      Feldeditor
      •
      Popup-QuickInfo im Formularentwurf, wenn Sie den Mauszeiger über das Objekt halten
Sie können den Namen eines Objekts mit Hilfe der Palette „Hierarchie“, der Registerkarte „Bindung“ der Palette „Objekt“ oder über den Feldeditor festlegen und ändern.
Wenn Sie Berechnungen oder Skripten zur Optimierung Ihres Formulars erstellen möchten, sollten Sie bei der Benennung der Formobjekte die Verwendung der Namen von Skripteigenschaften, -verfahren und -objekten vermeiden. Das Verwenden gleicher Namen kann dazu führen, dass Berechnungen und Skripten nicht ordnungsgemäß ausgeführt werden.
So können Sie ein Objekt über die Palette „Hierarchie“ benennen oder umbenennen
1.
Klicken Sie in der Palette „Hierarchie“ mit der rechten Maustaste auf das Objekt und wählen Sie „Objekt umbenennen“ aus.
2.
Geben Sie den neuen Namen ein und drücken Sie die Eingabetaste.
So können Sie ein Objekt über die Registerkarte „Bindung“ der Palette „Objekt“ benennen oder umbenennen
1.
Wählen Sie das Objekt aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“.
3.
Geben Sie im Feld „Name“ einen neuen Namen für das Objekt ein und drücken Sie die Eingabetaste.
So können Sie ein Objekt über den Feldeditor benennen oder umbenennen
1.
Wählen Sie das Objekt aus. Wenn der Feldeditor nicht angezeigt wird, wählen Sie „Ansicht“ > „Feldeditor“.
2.
Geben Sie im Feld „Name“ einen neuen Namen für das Objekt ein und drücken Sie die Eingabetaste.


So legen Sie den Randstil fest

      •
      Wenn Sie den Randstil für ein Objekt festlegen möchten, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie in der Liste „Erscheinungsbild“ einen Randstil für das Feld aus.
      •
      Wenn Sie eine eigene Darstellung für ein Objekt definieren möchten, wählen Sie in der Liste „Erscheinungsbild“ die Option „Benutzerdefiniert“ aus.
      •
      Wenn Sie einen Rand für das gesamte Objekt definieren möchten, verwenden Sie hierzu die Palette „Rand“.
Verwandte Themen
Randeigenschaften in der Palette „Rand“


So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest

1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
2.
Wählen Sie in der Liste „Sprache“ eine der folgenden Optionen oder eine der verfügbaren Alternativen für das Gebietsschema des Objekts aus:
      •
      Wenn Sie die Standardsprache verwenden möchten, die im Dialogfeld „Formulareigenschaften“ auf der Registerkarte „Standard“ festgelegt ist, wählen Sie „Standardsprache“ aus.
      •
      Wenn Sie das Gebietsschema auf dem Computer des Benutzers verwenden möchten, wählen Sie „Gebietsschema des Viewers“ aus.
Zur Entwurfs- und Laufzeit werden formatierte Werte im Feld in einem Format angezeigt, das dem Gebietsschema entspricht.


Objekte, die Skripten und Berechnungen unterstützen

Objekte, die Daten aufnehmen, können mit FormCalc- oder JavaScript-Ausdrücken verknüpft werden. Beispielsweise lassen sich mit Hilfe von Skripten Werte berechnen oder vom Benutzer eingegebene Daten überprüfen. In den meisten Fällen wird die Gültigkeit der Daten über die Attribute des Objekts gesteuert. Bei Objekten, die komplexe Eingabemuster (Bearbeitungsmuster) erfordern, wird die Gültigkeit über Mustereinstellungen auf der Registerkarte „Wert“ der Palette „Objekt“ gesteuert.
Mit einigen Objekten lassen sich Client-Anforderungen initiieren. So können Sie beispielsweise eine Schaltfläche einrichten, mit der eine Datenquelle zur Laufzeit abgefragt werden kann. In diesem Fall müssen Sie auch ein Skript schreiben, das dafür sorgt, dass der angeforderte Datenwert an ein angegebenes Feld des Formulars zurückgeben wird.
Sie können Skripten schreiben, die Befehle, Funktionen oder Berechnungen ausführen, wenn eines der Ereignisse eines Objekts zur Laufzeit auftritt. Ein Ereignis tritt zur Laufzeit ein, wenn der Benutzer die durch das Ereignis angegebene Aktion durchführt. Durch Definieren eines Skripts können Sie eines der vom Objekt unterstützten Verfahren aufrufen und Eigenschaften prüfen oder festlegen.
Einige Objekte, wie Kreise und Inhaltsbereiche, unterstützen keine Ereignisse. Zu Objekten, die Skripten und Berechnungen unterstützen oder Ereignisse auslösen, zählen Barcodes, Schaltflächen, Kontrollkästchen, Datums-/Uhrzeitfelder, Dropdown-Listen, Bildfelder, Listenfelder, numerische Felder, Kennwortfelder, Optionsfelder, Dokumentunterschriftsfelder, Teilformulare und Textfelder. Die unterstützten Ereignisse sind objektspezifisch und variieren je nach Objekt.
Verwandte Themen
Berechnungen und Skripten erstellen - Überblick


Objekte verwenden

Barcodes verwenden
Schaltflächen verwenden
Kontrollkästchen verwenden
Kreise, Linien und Rechtecke verwenden
Inhaltsbereiche verwenden
Datums-/Uhrzeitfelder verwenden
Dezimalfelder und numerische Felder verwenden
Dropdown-Listen und Listenfelder verwenden
Bildfelder verwenden
Bilder verwenden
Papierformular-Barcodes verwenden
Kennwortfelder verwenden
Optionsfelder verwenden
Dokumentunterschriftsfelder verwenden
Text verwenden
Textfelder verwenden
Benutzerdefinierte Objekte verwenden


Barcodes verwenden

Barcodes – Übersicht
So definieren Sie die Eigenschaften des Barcode-Feldes
So legen Sie den Standardwert für den Barcode fest
So steuern Sie die Datenzuweisung für einen Barcode
So definieren Sie benutzerdefinierte Datenbindungseigenschaften für einen Barcode


Barcodes – Übersicht

Im Geschäftsleben sind Barcodes allgegenwärtig. Sie werden vor allem zur Bestandskontrolle genutzt. Mit Barcodes können Formulare gekennzeichnet werden. Häufig werden sie jedoch auf Klebe-Etiketten gedruckt und im Lagerwesen verwendet.
LiveCycle Designer unterstützt zwei Typen von Barcodes:
    • Hardware-Barcodes
Werden nur verwendet, wenn das Formular direkt vom Server aus auf einem Drucker gedruckt wird. Da zum Drucken von Hardware-Barcodes ein Drucker benötigt wird, verwendet LiveCycle Designer einen Platzhalter für Hardware-Barcodes im Formular.
    • Software-Barcodes
Können von LiveCycle Designer gedruckt werden und sind in Acrobat und Adobe Reader sichtbar. Sie können auf jedem Allzweckdrucker gedruckt werden.
LiveCycle Designer bietet eine Reihe von Barcode-Formaten an, mit denen Sie arbeiten können. Die unterstützten Barcode-Formate werden in der Palette „Bibliothek“ in der Kategorie „Barcodes“ aufgelistet. Wenn Sie einen Barcode verwenden, für den ein bestimmter Druckertyp benötigt wird, stellt LiveCycle Designer den Barcode im Formular als schattiertes Rechteck dar.
LiveCycle Designer unterstützt auch den zweidimensionalen Papierformular-Barcode. Weitere Informationen finden Sie unter Papierformular-Barcodes – Übersicht.
Wenn Sie den Barcode in das Formular aufgenommen haben, können Sie die Eigenschaften des Objektes auf den Registerkarten „Feld“, „Wert“ und „Bindung“ der Palette „Objekt“ bearbeiten. Sie können die folgenden Eigenschaften festlegen:
      •
      Textposition
      •
      Länge der Daten
      •
      Zusätzliche Eigenschaften, die vom Barcode unterstützt werden (zum Beispiel optionale Prüfsummenfunktionen, Textpositionierung und Texteinbettung)
      •
      Darstellung des Barcodes als sichtbar, unsichtbar oder ausgeblendet
      •
      Bindungsmethode zum Speichern und Abrufen gebundener Daten
Interaktive Barcodes, die Benutzereingaben ermöglichen, werden nur bei PDF-Formularen unterstützt, die in Acrobat 7.0 oder Adobe Reader 7.0 ausgefüllt wurden.
Verwandte Themen
Unterstützte Barcode-Formate
Eigenschaften von Barcodes: Registerkarte „Feld“
Eigenschaften von Barcodes: Registerkarte „Wert“
Barcode-Eigenschaften: Registerkarte „Bindung“


So definieren Sie die Eigenschaften des Barcode-Feldes

Um die Eigenschaften eines Barcodes zu definieren, müssen Sie ihn zuerst auswählen. Die Grundeigenschaften legen Sie auf der Registerkarte „Feld“ der Palette „Objekt“ fest. Die Zahl und die Art der Barcode-Eigenschaften hängt vom jeweiligen Barcode ab.
1.
Wählen Sie den Barcode aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“. Geben Sie den Barcode-Text in das Feld „Standard“ ein.
3.
Klicken Sie auf die Registerkarte „Feld“. Wählen Sie im Feld „Position“ die Platzierung des Textes aus.
Das Format PDF 417 unterstützt keine Textpositionierung, während die Formate EAN8, EAN13 und UPC-A nur die Option „Unterhalb (eingebettet)“ unterstützen.
4.
Führen Sie in der Spalte „Wert“ mindestens einen der folgenden Schritte aus:
      •
      Geben Sie in das Feld „Datenlänge“ die Länge der Daten ein. Wenn Sie einen MSI-Barcode definieren, muss die Datenlänge einen Wert zwischen 1 und 14 aufweisen. Die Barcode-Formate MSI, UPC-E, UPC EAN2, UPC EAN5, US Postal Zip-5, US Postal DPBC und US Postal Standard besitzen feste Datenlängen, die nicht geändert werden können.
      •
      Wenn ein Prüfsummenfeld angezeigt wird, aktivieren oder deaktivieren Sie die Prüfsumme. Wenn Sie einen MSI-Barcode definieren, wählen Sie eine der verfügbaren Prüfsummenmethoden aus.
      •
      Wenn das Feld „Endezeichen“ oder „Startzeichen“ angezeigt wird, geben Sie das Endezeichen bzw. Startzeichen oder beide ein. Wenn Sie einen Codabar-Barcode definieren, sind folgende Start- und Endezeichen zulässig: A, B, C, D, a, b, c, d, *, N, T, E, n, t sowie e. Wenn Sie einen Barcode des Typs Code 49 definieren, sind die Startzeichen A, 1, 2, 3, 4 und 5 zulässig.
      •
      Wenn das Feld „Breitenverhältnis“ angezeigt wird, geben Sie einen Wert für das Breitenverhältnis ein. Bei Codabar muss als Breitenverhältnis in Code 2 von 5 (Industrial, Interleaved und Matrix) und Code 3 von 9 ein Wert zwischen 2,2 und 3,0 eingegeben werden. Bei Barcodes des Typs Code 11, Logmars, MSI oder Plessey muss der Wert zwischen 2,0 und 3,0 liegen.
Verwandte Themen
Eigenschaften von Barcodes: Registerkarte „Feld“
Gültige Textzeichen für Barcodes


So legen Sie den Standardwert für den Barcode fest

      *
      Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“. Geben Sie einen Standardwert in das Feld „Standard“ ein.
Verwandte Themen
Eigenschaften von Barcodes: Registerkarte „Feld“
Gültige Textzeichen für Barcodes


So steuern Sie die Datenzuweisung für einen Barcode

Um die Eigenschaften eines Barcodes zu definieren, müssen Sie ihn zuerst auswählen. Auf der Registerkarte „Wert“ der Palette „Objekt“ bestimmen Sie anhand von Eigenschaften, wie dem Barcode Daten zugewiesen werden.
Sie können ein Überprüfungsmuster oder eine Skriptmeldung mit einem Wert aus einer Datenquelle dynamisch ausfüllen. Dadurch können Sie sicherstellen, dass Benutzer den richtigen Wert in das Feld eingeben.
1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“. Wählen Sie in der Liste „Typ“ eine der folgenden Optionen aus:
      •
      Wenn Sie die Benutzer entscheiden lassen möchten, ob sie Daten eingeben möchten oder nicht, wählen Sie die Option „Benutzereingabe - Optional“ aus.
      •
      Wenn Sie die Benutzer zur Dateneingabe auffordern möchten und es sich bei dem Feld um ein empfohlenes Feld handeln soll, wählen Sie die Option „Benutzereingabe - Empfohlen“ aus und geben Sie im Feld „Meldung bei leerem Feld“ eine benutzerdefinierte Meldung ein.
      •
      Wenn Sie die Benutzer zur Dateneingabe auffordern möchten und es sich bei dem Feld um ein erforderliches Feld handeln soll, wählen Sie die Option „Benutzereingabe - Erforderlich“ aus und geben Sie im Feld „Meldung bei leerem Feld“ eine benutzerdefinierte Meldung ein.
      •
      Wenn es sich bei dem Feld um ein schreibgeschütztes Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der über ein angehängtes Skript berechnet und angezeigt wird, wählen Sie die Option „Berechnet - Schreibgeschützt“ aus. Die Benutzer können den berechneten Wert nicht bearbeiten.
      •
      Wenn es sich bei dem Feld um ein editierbares Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der über ein angehängtes Skript berechnet und angezeigt wird, wählen Sie die Option „Berechnet - Benutzer darf überschreiben“ aus. Die Benutzer können den berechneten Wert bearbeiten, wenn im Berechnungsskript eine Verarbeitung der Benutzereingabe vorgesehen ist. Wenn ein Benutzer den berechneten Wert bearbeiten möchte, wird eine Meldung angezeigt, die im Feld „Meldung beim Überschreiben eines Werts“ festgelegt wurde.
      •
      Wenn es sich bei dem Feld um ein schreibgeschütztes Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der zur Laufzeit zusammengeführt oder berechnet und angezeigt wird, wählen Sie die Option „Schreibgeschützt“ aus. Die Benutzer können den Wert nicht bearbeiten.
2.
Wenn der Wert empfohlen oder erforderlich ist, geben Sie in das Feld „Meldung bei leerem Wertefeld“ eine Eingabeaufforderung ein.
3.
Wenn der Wert zur Laufzeit berechnet werden soll, weisen Sie dem Objekt mit Hilfe des Skript-Editors ein Berechnungsskript zu.
4.
(Optional) Wenn ein berechneter Wert überschrieben werden darf, können Sie eine Meldung in das Feld „Meldung beim Überschreiben eines Werts“ eingeben.
Verwandte Themen
So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus
So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus
Eigenschaften von Barcodes: Registerkarte „Wert“


So definieren Sie benutzerdefinierte Datenbindungseigenschaften für einen Barcode

Mit den Bindungsoptionen können Sie ein Formular erstellen, das Daten für die Infrastruktur eines Unternehmens erfasst, und/oder eine externe Datenquelle nutzen, um ein Formular zur Laufzeit auszufüllen. Die Datenbindungseigenschaften werden auf der Registerkarte „Bindung“ der Palette „Objekt“ festgelegt.
1.
Wählen Sie den Barcode aus.
2.
Legen Sie für das Formular fest, dass beim Öffnen eine Verbindung zur Datenquelle hergestellt wird.
3.
Binden Sie den Barcode an den entsprechenden Datenknoten. Weitere Informationen zum Binden von Objekten an eine Datenquelle finden Sie unter Info über das Binden von Feldern an eine Datenquelle.
Verwandte Themen
Barcode-Eigenschaften: Registerkarte „Bindung“


Schaltflächen verwenden

Schaltflächen – Übersicht
E-Mail-Senden-Schaltflächen – Übersicht
HTTP-Senden-Schaltflächen – Übersicht
Drucken-Schaltflächen – Übersicht
Zurücksetzen-Schaltflächen – Übersicht
Info über das Senden von Daten mit Hilfe einer Schaltfläche
Info über Verarbeitungsoptionen für eine Schaltfläche
So fügen Sie eine Standardschaltfläche zum Ausführen einer Berechnung oder eines Skripts ein
So fügen Sie eine Senden-Schaltfläche zum Senden von Daten an einen Server ein
So fügen Sie eine Senden-Schaltfläche mit eingebetteter PDF-Datei ein
So fügen Sie eine Senden-Schaltfläche zum Senden eines XML-Datenstroms ein
So fügen Sie eine Senden-Schaltfläche zum Senden eines Textstroms mit Hilfe der POST-Methode ein
So fügen Sie eine Schaltfläche zum Senden einer E-Mail mit XML-Daten ein
So führen Sie eine Webdienst-Operation oder eine Datenbankabfrage mit Hilfe einer Schaltfläche aus
So hängen Sie ein Datenbankskript an eine Schaltfläche an
Mit einer Schaltfläche Felder aus einer Datenbank ausfüllen
So passen Sie die E-Mail-Senden-Schaltfläche an
So passen Sie die HTTP-Senden-Schaltfläche an


Schaltflächen – Übersicht

Sie können Schaltflächen in Ihr Formular einfügen. Solche Schaltflächen sind nützlich, wenn Sie erreichen möchten, dass die Benutzer bestimmte Aktionen ausführen, wie z. B. Daten übersenden, eine Webdienst-Operation ausführen oder eine Datenbankabfrage vornehmen. LiveCycle Designer verfügt über eine integrierte Unterstützung für Client-Server-Kommunikation und Skripten. Dadurch können in Formularen folgende Aktionen durch Schaltflächen unterstützt werden:
      •
      Durchführen von Berechnungen
      •
      Verarbeiten und Bearbeiten von Daten über ein Skript
      •
      Übergeben von Daten (einschließlich optionaler Anhänge) an einen Server
      •
      Unterschreiben von gesendeten Daten
      •
      Öffnen einer Verbindung zu einem Host
      •
      Übergeben von Clientanfragen an einen Server
      •
      Aufrufen einer Webdienst-Operation
      •
      Senden von Abfragen an eine Datenquelle
Die den Schaltflächen zugewiesenen Aktionen werden ausgelöst, sobald der Benutzer auf die Schaltfläche klickt.
Nachdem Sie eine Schaltfläche zum Formularentwurf hinzugefügt haben, können Sie den Beschriftungstext bearbeiten und die Eigenschaften des Objekts in der Palette „Objekt“ auf den Registerkarten „Feld“, „Senden“ und „Ausführen“ ändern. Sie können die folgenden Eigenschaften festlegen:
      •
      Ändern der Beschriftung für die Schaltfläche
      •
      Auswählen eines Randstils für die Schaltfläche
      •
      Festlegen des Markierungsstils für die Schaltfläche
      •
      Definieren der Schaltfläche als sichtbar, unsichtbar oder ausgeblendet
      •
      Festlegen einer Sprache für die Schaltfläche
      •
      Festlegen des Laufzeitverhaltens
LiveCycle Designer umfasst außerdem vier zusätzliche Schaltflächen, die vorkonfiguriert sind und spezielle Funktionen haben: E-Mail-Senden-Schaltfläche, HTTP-Senden-Schaltfläche, Drucken-Schaltfläche und Zurücksetzen-Schaltfläche.
Verwandte Themen
Info über Verarbeitungsoptionen für eine Schaltfläche
Beschriftungen formatieren
Digitale Unterschriften
Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“
Schrift-Eigenschaften in der Palette „Schrift“
Absatz-Eigenschaften in der Palette „Absatz“
Eigenschaften von Schaltflächen: Registerkarte „Feld“
Eigenschaften von Schaltflächen: Registerkarte „Absenden“
Eigenschaften von Schaltflächen: Registerkarte „Ausführen“


E-Mail-Senden-Schaltflächen – Übersicht

Die E-Mail-Senden-Schaltfläche ist eine Standardschaltfläche mit bestimmten bereits festgelegten Eigenschaften und einer speziellen Objektpalette. Dieses Objekt erleichtert das Erstellen von Schaltflächen, auf die Benutzer klicken können, um Formulardaten per E-Mail zu senden. Da Adobe Reader keine Änderungen an PDF-Dateien, wie zum Beispiel Dateien mit Formulardaten, speichert, ist es hilfreich, eine solche Schaltfläche in Formulare einzufügen, die Benutzer unter Umständen in Adobe Reader ausfüllen.
Die E-Mail-Senden-Schaltfläche ist eine Standardschaltfläche mit folgenden Einstellungen:
      •
      „Kontrolltyp“ ist auf „Senden“ gesetzt
      •
      „Versandformat“ ist auf „XML-Daten“ gesetzt
      •
      „Senden an URL“ ist auf das Mailto-Protokoll gesetzt, z. B. „mailto:name@adobe.com“
      •
      „Kodierung“ ist auf „UTF-8“ gesetzt
Wenn Sie den Assistenten für neue Formulare zum Erstellen eines Formulars verwenden und eine der Sendemethoden für das Zurücksenden der Daten auswählen, wird automatisch eine Schaltfläche zum Senden per E-Mail in das Formular eingefügt.
Nachdem Sie eine Schaltfläche zum Formularentwurf hinzugefügt haben, können Sie den Beschriftungstext bearbeiten und die Eigenschaften des Objekts in der Palette „Objekt“ auf der Registerkarte „Feld“ ändern. Sie können die folgenden Eigenschaften festlegen:
      •
      Ändern der Beschriftung für die Schaltfläche
      •
      Auswählen eines Randstils für die Schaltfläche
      •
      Festlegen des Markierungsstils für die Schaltfläche
      •
      Festlegen der Empfängeradresse und des Betreffs der E-Mail
      •
      Hinzufügen einer Datenunterschrift
      •
      Definieren der Schaltfläche als sichtbar, unsichtbar oder ausgeblendet
      •
      Festlegen einer Sprache für die Schaltfläche
Außerdem können Sie den Namen der Schaltfläche in der Palette „Hierarchie“ ändern und den Stil für die Beschriftung in den Paletten „Schrift“ und „Absatz“ festlegen.
Verwandte Themen
Digitale Unterschriften
So fügen Sie eine Datenunterschrift zu einer Senden-Schaltfläche hinzu
Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“
Schrift-Eigenschaften in der Palette „Schrift“
Absatz-Eigenschaften in der Palette „Absatz“
Eigenschaften der E-Mail-Senden-Schaltfläche: Registerkarte „Feld“


HTTP-Senden-Schaltflächen – Übersicht

Die HTTP-Senden-Schaltfläche ist eine Standardschaltfläche mit bestimmten bereits festgelegten Eigenschaften und einer speziellen Objektpalette. Dieses Objekt erleichtert das Erstellen von Schaltflächen, auf die Benutzer klicken können, um Formulardaten per HTTP-Post zu senden.
Die HTTP-Senden-Schaltfläche ist eine Standardschaltfläche mit folgenden Einstellungen:
      •
      „Kontrolltyp“ ist auf „Senden“ gesetzt
      •
      „Versandformat“ ist auf „URL-kodierte Daten“ gesetzt
      •
      „Senden an URL“ ist auf das HTTP-Protokoll gesetzt
Wenn Ihre Daten über das sichere HTTPS-Protokoll versandt werden müssen, können Sie stattdessen das Standard-Schaltflächenobjekt verwenden.
Nachdem Sie eine Schaltfläche zum Formularentwurf hinzugefügt haben, können Sie den Beschriftungstext bearbeiten und die Eigenschaften des Objekts in der Palette „Objekt“ auf der Registerkarte „Feld“ ändern. Sie können die folgenden Eigenschaften festlegen:
      •
      Ändern der Beschriftung für die Schaltfläche
      •
      Auswählen eines Randstils für die Schaltfläche
      •
      Festlegen des Markierungsstils für die Schaltfläche
      •
      Festlegen der URL, an die die Daten gesendet werden
      •
      Hinzufügen einer Datenunterschrift
      •
      Definieren der Schaltfläche als sichtbar, unsichtbar oder ausgeblendet
      •
      Festlegen einer Sprache für die Schaltfläche
Außerdem können Sie den Namen der Schaltfläche in der Palette „Hierarchie“ ändern und den Stil für die Beschriftung in den Paletten „Schrift“ und „Absatz“ festlegen.
Verwandte Themen
Digitale Unterschriften
So fügen Sie eine Datenunterschrift zu einer Senden-Schaltfläche hinzu
Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“
Schrift-Eigenschaften in der Palette „Schrift“
Absatz-Eigenschaften in der Palette „Absatz“
Eigenschaften der HTTP-Senden-Schaltfläche: Registerkarte „Feld“


Drucken-Schaltflächen – Übersicht

Mit der Drucken-Schaltfläche wird ein Dialogfeld geöffnet, das der Benutzer zum Drucken des Formulars verwenden kann. Die Drucken-Schaltfläche ist ein Standardschaltflächenobjekt, bei dem der Kontrolltyp auf „Normal“ gesetzt ist und dem ein Skript zugewiesen ist, das bewirkt, dass das Formular durch ein click-Ereignis der Schaltfläche gedruckt wird.
Wenn Sie den Assistenten für neue Formulare zum Erstellen eines Formulars verwenden und eine der Druckmethoden für das Zurücksenden der Daten auswählen, wird automatisch eine Drucken-Schaltfläche in das Formular eingefügt.
Verwandte Themen
Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“
Schrift-Eigenschaften in der Palette „Schrift“
Absatz-Eigenschaften in der Palette „Absatz“
Eigenschaften von Schaltflächen: Registerkarte „Feld“


Zurücksetzen-Schaltflächen – Übersicht

Durch die Zurücksetzen-Schaltfläche werden alle Felder im Formular auf ihre Standardwerte zurückgesetzt. Die Zurücksetzen-Schaltfläche ist ein Standardschaltflächenobjekt, bei dem der Kontrolltyp auf „Normal“ gesetzt ist. Außerdem ist im click-Ereignis der Schaltfläche ein Skript enthalten, mit dem die Feldwerte durch ein Klicken auf die Schaltfläche zurückgesetzt werden.
Verwandte Themen
Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“
Schrift-Eigenschaften in der Palette „Schrift“
Absatz-Eigenschaften in der Palette „Absatz“
Eigenschaften von Schaltflächen: Registerkarte „Feld“


Info über das Senden von Daten mit Hilfe einer Schaltfläche

Um die Eigenschaften einer Schaltfläche zu definieren, müssen Sie zunächst die gewünschte Schaltfläche auswählen. Die Eigenschaften für den Datenversand werden in der Palette „Objekt“ auf der Registerkarte „Senden“ festgelegt. Damit die Registerkarte „Senden“ angezeigt wird, müssen Sie auf der Registerkarte „Feld“ im Bereich „Kontrolltyp“ die Option „Senden“ auswählen.
Sie können das Format und den Typ von Daten, die gesendet werden sollen, sowie die Art der Datenkodierung festlegen. Wenn mit der Schaltfläche Daten im URL-kodierten Format gesendet werden, können Sie eine URL angeben, an die die Daten gesendet werden sollen. Wenn die Schaltfläche eine XDP-Datei sendet, können Sie Anlagen, wie z. B. Anmerkungen, PDF-Dokumente oder Dokumentunterschriften, einfügen. Sie können eine digitale Unterschrift auf die gesendeten Daten anwenden.
Verwandte Themen
Eigenschaften von Schaltflächen: Registerkarte „Absenden“
Digitale Unterschriften
So fügen Sie eine Datenunterschrift zu einer Senden-Schaltfläche hinzu


Info über Verarbeitungsoptionen für eine Schaltfläche

In der Palette „Objekt“ können Sie auf der Registerkarte „Ausführen“ eine Datenverbindung für die Schaltfläche auswählen und festlegen, ob die entsprechende Verarbeitung auf dem Client-Computer, dem Server oder beiden ausgeführt werden soll. Die Datenverbindung muss Zugriff auf die Benutzerschnittstelle eines Webdienstes oder auf einen OLEDB-Datenbank-Server haben, der entweder Daten während der Laufzeit an das Formular zurücksendet oder an anderer Stelle eine Aktion ausführt.
Nachdem Sie die Datenquelle angegeben haben (siehe Datenquellen), können Sie festlegen, welche Operation oder Abfrage ausgeführt werden soll. Wird während der Laufzeit auf die Schaltfläche geklickt, dann wird die Verarbeitung so beendet, wie durch die Operation oder Abfrage definiert ist.
Zurückgesendete Daten können mit dem Formular zusammengeführt werden, so dass nur solche Daten überschrieben werden, die bestehenden Objekten zugewiesen sind. Die Struktur des Formulars wird dabei nicht aktualisiert. Alternativ können Sie auch angeben, dass die Struktur des Formulars anhand der zurückgesendeten XML-Daten aktualisiert werden soll. In diesem Fall wird die Formularstruktur aktualisiert und die zurückgesendeten Daten werden zusammengeführt, sobald die Verarbeitung abgeschlossen ist.
Um die Verarbeitungsoptionen für eine Schaltfläche zu definieren, müssen Sie zunächst die gewünschte Schaltfläche auswählen. Die Verarbeitungsoptionen werden in der Palette „Objekt“ auf der Registerkarte „Ausführen“ festgelegt. Damit die Registerkarte „Ausführen“ angezeigt wird, müssen Sie auf der Registerkarte „Feld“ im Bereich „Kontrolltyp“ die Option „Ausführen“ auswählen.
Verwandte Themen
Eigenschaften von Schaltflächen: Registerkarte „Ausführen“


So fügen Sie eine Standardschaltfläche zum Ausführen einer Berechnung oder eines Skripts ein

1.
Fügen Sie die Schaltfläche einem Formularentwurf hinzu. Siehe So fügen Sie einem Formularentwurf Objekte hinzu.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
3.
Wählen Sie im Feld „Einblenden“ ein Ereignis aus. Wenn mit der Schaltfläche beispielsweise eine Berechnung durchgeführt werden soll, wählen Sie „Klick“ aus.
4.
Wählen Sie im Skript-Editor in der Liste „Sprache“ eine Sprache aus.
5.
Geben Sie die Berechnung oder das Skript in den Skript-Editor ein.
6.
Klicken Sie zum Hinzufügen des Skripts auf die Schaltfläche „Änderungen zu Skriptquelle eingeben“ [image].
Verwandte Themen
Eigenschaften von Schaltflächen: Registerkarte „Feld“


So fügen Sie eine Senden-Schaltfläche zum Senden von Daten an einen Server ein

1.
Fügen Sie eine Schaltfläche zum Formularentwurf hinzu. Siehe So fügen Sie einem Formularentwurf Objekte hinzu.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
3.
Wählen Sie im Bereich „Kontrolltyp“ die Option „Senden“ aus. Die Daten werden entsprechend den Einstellungen auf der Registerkarte „Senden“ gesendet.
4.
Klicken Sie auf die Registerkarte „Senden“ und geben Sie im Feld „Senden an URL“ das URL-Protokoll ein.

Aufgabe

Verwendetes URL-Protokoll

Beispiel
Senden des Pakets an eine FTP-Site
ftp
ftp://ftp.gnu.org/gnu/GPL
Senden des Pakets an einen Webserver
http
http://meinServer/cgi-bin/
Senden des Pakets an einen sicheren Webserver
https
https://meinServer/cgi-bin/
Beim Senden von Daten an eine URL ist es empfehlenswert, ein absolutes Ziel anzugeben. Relative Ziele werden relativ zur Benutzerumgebung interpretiert. Die Benutzerumgebung kann jedoch während der Laufzeit von einem Benutzer zum nächsten variieren.
5.
Wählen Sie in der Liste „Senden als“ ein Dateiformat aus.
Durch diese Formate wird die serverseitige Verarbeitung initiiert. Mit der Option „XML-Datenpaket (XDP)“ werden die Formulardaten sowie optional andere Informationen, wie der Formularentwurf, Anmerkungen und Dokumentunterschriften gesendet, die LiveCycle Forms zum anschließenden Rendering des Formulars zur Laufzeit erforderlich sind. Anhänge können nur in XDP-Dateien einbezogen werden.
6.
(Optional) Um eine Datenunterschrift auf die gesendeten Daten anzuwenden, wählen Sie auf der Registerkarte „Feld“ die Option „Sendung unterschreiben“ aus und klicken Sie dann auf „Einstellungen“, um optionale Unterschrifteneinstellungen zu konfigurieren.
7.
Wählen Sie im Bereich „Einschließen“ aus, welche Art von Anhängen einbezogen werden soll:
      •
      Wenn Sie Überprüfungskommentare, QuickInfos und andere spezielle Tags einbeziehen möchten, die zum Aufzeichnen des Bildschirmlesehilfen-Textes erforderlich sind, wählen Sie „Anmerkungen“ aus.
      •
      Wenn Sie die elektronische Unterschrift eines unterzeichneten Dokuments einbeziehen möchten, wählen Sie „Dokumentunterschriften“ aus.
      •
      Wenn Sie eine PDF-Version des Formulars beim Senden als Anhang einbeziehen möchten, wählen Sie „PDF“ aus. Andernfalls wird ein Verweis auf eine eingebettete PDF-Datei einbezogen.
      •
      Wenn Sie eine Kopie des Formularentwurfs einbeziehen möchten, wählen Sie „Vorlage“ aus.
      •
      Wenn Sie ein oder mehrere <xdp>-Elemente in die XDP-Quelldatei einbeziehen möchten, wählen Sie „Andere“ aus. Die angegebenen Elemente müssen durch Kommas getrennt werden; Leerzeichen sind optional. Beispiel: xci, xslt, sourceset.
8.
Wählen Sie in der Liste „Datenkodierung“ ein Datenkodierungs-Schema aus:
      •
      UTF-8
      •
      UTF-16
      •
      Shift_JIS
      •
      Big5
      •
      GBK
      •
      KSC_5601
Verwandte Themen
Eigenschaften von Schaltflächen: Registerkarte „Feld“
Eigenschaften von Schaltflächen: Registerkarte „Absenden“


So fügen Sie eine Senden-Schaltfläche mit eingebetteter PDF-Datei ein

1.
Fügen Sie eine Schaltfläche zum Formularentwurf hinzu. Siehe So fügen Sie einem Formularentwurf Objekte hinzu.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
3.
Wählen Sie im Bereich „Kontrolltyp“ die Option „Senden“ aus. Die Daten werden entsprechend den Einstellungen auf der Registerkarte „Senden“ gesendet.
4.
Klicken Sie auf die Registerkarte „Senden“ und geben Sie im Feld „Senden an URL“ das URL-Protokoll ein.

Aufgabe

Verwendetes URL-Protokoll

Beispiel
Senden des Pakets an eine FTP-Site
ftp
ftp://ftp.gnu.org/gnu/GPL
Senden des Pakets an einen Webserver
http
http://meinServer/cgi-bin/
Senden des Pakets an einen sicheren Webserver
https
https://meinServer/cgi-bin/
Senden des Pakets an eine E-Mail-Adresse
mailto
mailto:benutzername@domain.com
Beim Senden von Daten an eine URL ist es empfehlenswert, ein absolutes Ziel anzugeben. Relative Ziele werden relativ zur Benutzerumgebung interpretiert. Die Benutzerumgebung kann jedoch während der Laufzeit von einem Benutzer zum nächsten variieren.
5.
Wählen Sie „PDF“ in der Liste „Senden als“ aus.
6.
Durch dieses Format wird ein Paket gesendet, das eine eingebettete PDF-Datei enthält. Wählen Sie dieses Format, wenn das Formular ein Dokumentunterschriftsfeld enthält oder wenn eine Kopie des Formulars zusammen mit den Formulardaten von LiveCycle Forms gespeichert oder an einen anderen Zielservertyp gesendet werden muss. Wählen Sie diese Option nicht, wenn das Formular die serverseitige Verarbeitung initiiert, wenn LiveCycle Forms zur Wiedergabe von HTML-Formularen oder dynamischen Formularen zur Laufzeit verwendet wird, oder wenn es sich bei dem Formular um ein PDF-Formular handelt, das in Adobe Reader ohne die Verwendung von LiveCycle Reader Extensions ausgefüllt wird. (Optional) Um eine Datenunterschrift auf die gesendeten Daten anzuwenden, wählen Sie auf der Registerkarte „Feld“ die Option „Sendung unterschreiben“ aus und klicken Sie dann auf „Einstellungen“, um optionale Unterschrifteneinstellungen zu konfigurieren.
Verwandte Themen
Eigenschaften von Schaltflächen: Registerkarte „Feld“
Eigenschaften von Schaltflächen: Registerkarte „Absenden“


So fügen Sie eine Senden-Schaltfläche zum Senden eines XML-Datenstroms ein

1.
Fügen Sie eine Schaltfläche zum Formularentwurf hinzu. Siehe So fügen Sie einem Formularentwurf Objekte hinzu.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
3.
Wählen Sie im Bereich „Kontrolltyp“ die Option „Senden“ aus. Die Daten werden entsprechend den Einstellungen auf der Registerkarte „Senden“ gesendet.
4.
Klicken Sie auf die Registerkarte „Senden“ und geben Sie im Feld „Senden an URL“ das URL-Protokoll ein.

Aufgabe

Verwendetes URL-Protokoll

Beispiel
Senden des Pakets an eine FTP-Site
ftp
ftp://ftp.gnu.org/gnu/GPL
Senden des Pakets an einen Webserver
http
http://meinServer/cgi-bin/
Senden des Pakets an einen sicheren Webserver
https
https://meinServer/cgi-bin/
Senden des Pakets an eine E-Mail-Adresse
mailto
mailto:benutzername@domain.com
Beim Senden von Daten an eine URL ist es empfehlenswert, ein absolutes Ziel anzugeben. Relative Ziele werden relativ zur Benutzerumgebung interpretiert. Die Benutzerumgebung kann jedoch während der Laufzeit von einem Benutzer zum nächsten variieren.
5.
Wählen Sie „XML-Daten (XML)“ in der Liste „Senden als“ aus.
Durch dieses Format wird ein XML-Datenstrom gesendet, der die hierarchische Darstellung der Daten ermöglicht und von jedem generischen XML-Parser analysiert werden kann. Wählen Sie dieses Format, wenn der Server, der mit dem Laufzeit-Anwendungsprogramm kommuniziert, einen XML-Datenstrom empfangen muss.
6.
(Optional) Um eine Datenunterschrift auf die gesendeten Daten anzuwenden, wählen Sie auf der Registerkarte „Feld“ die Option „Sendung unterschreiben“ aus und klicken Sie dann auf „Einstellungen“, um optionale Unterschrifteneinstellungen zu konfigurieren.
7.
Wählen Sie in der Liste „Kodierung“ eines der Datenkodierungs-Schemata aus:
      •
      UTF-8
      •
      UTF-16
      •
      Shift_JIS
      •
      Big5
      •
      GBK
      •
      KSC_5601
Verwandte Themen
Eigenschaften von Schaltflächen: Registerkarte „Feld“
Eigenschaften von Schaltflächen: Registerkarte „Absenden“


So fügen Sie eine Senden-Schaltfläche zum Senden eines Textstroms mit Hilfe der POST-Methode ein

1.
Fügen Sie eine Schaltfläche zum Formularentwurf hinzu. Siehe So fügen Sie einem Formularentwurf Objekte hinzu.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
3.
Wählen Sie im Bereich „Kontrolltyp“ die Option „Senden“ aus. Die Daten werden entsprechend den Einstellungen auf der Registerkarte „Senden“ gesendet.
4.
Klicken Sie auf die Registerkarte „Senden“ und geben Sie im Feld „Senden an URL“ das URL-Protokoll ein.

Aufgabe

Verwendetes URL-Protokoll

Beispiel
Senden des Pakets an eine FTP-Site
ftp
ftp://ftp.gnu.org/gnu/GPL
Senden des Pakets an einen Webserver
http
http://meinServer/cgi-bin/
Senden des Pakets an einen sicheren Webserver
https
https://meinServer/cgi-bin/
Senden des Pakets an eine E-Mail-Adresse
mailto
mailto:benutzername@domain.com
Beim Senden von Daten an eine URL ist es empfehlenswert, ein absolutes Ziel anzugeben. Relative Ziele werden relativ zur Benutzerumgebung interpretiert. Die Benutzerumgebung kann jedoch während der Laufzeit von einem Benutzer zum nächsten variieren.
5.
Wählen Sie „URL-kodierte Daten (HTTP Post)“ in der Liste „Senden als“ aus.
Durch dieses Format wird ein Textstrom mithilfe der POST-Methode an die angegebene URL (Uniform Resource Locator) gesendet. Dieser Textstrom kann von einem FTP-Server, Mail-Server, Webserver oder einem CGI-Skript, das HTML-Formulare verarbeitet, analysiert werden. Um diese Methode verwenden zu können, müssen Benutzer das Formular in Adobe Reader 6.0 oder höher oder einem Webbrowser öffnen, es sei denn, die URL legt das Mailto-Protokoll fest.
6.
(Optional) Um eine Datenunterschrift auf die gesendeten Daten anzuwenden, wählen Sie auf der Registerkarte „Feld“ die Option „Sendung unterschreiben“ aus und klicken Sie dann auf „Einstellungen“, um optionale Unterschrifteneinstellungen zu konfigurieren.
7.
Wählen Sie in der Liste „Kodierung“ eines der Datenkodierungs-Schemata aus:
      •
      UTF-8
      •
      UTF-16
      •
      Shift_JIS
      •
      Big5
      •
      GBK
      •
      KSC_5601
Verwandte Themen
Eigenschaften von Schaltflächen: Registerkarte „Feld“
Eigenschaften von Schaltflächen: Registerkarte „Absenden“


So fügen Sie eine Schaltfläche zum Senden einer E-Mail mit XML-Daten ein

Sie können eine eigene E-Mail-Senden-Schaltfläche erstellen oder die E-Mail-Senden-Schaltfläche aus der Palette „Bibliothek“ verwenden.
1.
Fügen Sie eine Schaltfläche zum Formularentwurf hinzu. Siehe So fügen Sie einem Formularentwurf Objekte hinzu.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
3.
Wählen Sie im Bereich „Kontrolltyp“ die Option „Senden“ aus. Die Daten werden entsprechend den Einstellungen auf der Registerkarte „Senden“ gesendet.
4.
Klicken Sie auf die Registerkarte „Senden“ und geben Sie im Feld „Senden an URL“ das Mailto-Protokoll wie im folgenden Beispiel dargestellt ein:

mailto:username@domain.com
5.
Wählen Sie „XML-Daten (XML)“ in der Liste „Senden als“ aus.
Durch dieses Format wird ein XML-Datenstrom gesendet, der die hierarchische Darstellung der Daten ermöglicht und von jedem generischen XML-Parser analysiert werden kann. Wählen Sie dieses Format, wenn der Server, der mit dem Laufzeit-Anwendungsprogramm kommuniziert, einen XML-Datenstrom empfangen muss.
6.
(Optional) Um eine Datenunterschrift auf die gesendeten Daten anzuwenden, wählen Sie auf der Registerkarte „Feld“ die Option „Sendung unterschreiben“ aus und klicken Sie dann auf „Einstellungen“, um optionale Unterschrifteneinstellungen zu konfigurieren.
7.
Wählen Sie in der Liste „Kodierung“ eines der Datenkodierungs-Schemata aus:
      •
      UTF-8
      •
      UTF-16
      •
      Shift_JIS
      •
      Big5
      •
      GBK
      •
      KSC_5601
Verwandte Themen
Eigenschaften von Schaltflächen: Registerkarte „Absenden“


So führen Sie eine Webdienst-Operation oder eine Datenbankabfrage mit Hilfe einer Schaltfläche aus

Mit dem Schaltflächentyp „Ausführen“ können Sie eine Verarbeitungsanforderung für einen Webdienst ausführen. Ein Webdienst verarbeitet an ihn gesendete Operationen, um Eingangs- und Ausgangsinformationen im Formular zu definieren.
Sie fügen eine Verbindung zum Webdienst hinzu und erstellen oder binden dann Felder an die Anfrage- und Antwortdienste. Das gebundene Feld kann eine Eingangsmeldung zu dem Dienst generieren oder eine Nachricht von dem Dienst empfangen. Um die Operation zu verarbeiten, können Sie eine Schaltfläche zum Ausführen verwenden oder ein Skript schreiben. Beispielsweise können Sie einen Webdienst verwenden, um einen Zinssatz, einen Wechselkurs oder einen Aktienwert abzurufen.
1.
Fügen Sie eine Schaltfläche zum Formularentwurf hinzu. Siehe So fügen Sie einem Formularentwurf Objekte hinzu.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
3.
Wählen Sie im Bereich „Kontrolltyp“ die Option „Ausführen“ aus. Entsprechend den Einstellungen auf der Registerkarte „Ausführen“ wird eine Webdienst-Operation oder eine Datenbankabfrage ausgeführt.
4.
Klicken Sie auf die Registerkarte „Ausführen“ und wählen Sie in der Liste „Verbindung“ die Option „Neue Datenverbindung“ aus.
5.
Wählen Sie „WSDL-Datei“ aus und klicken Sie auf „Weiter“.
6.
Wenn die Datei auf Ihrem Computer gespeichert ist, klicken Sie auf „Durchsuchen“, suchen die Datei und wählen sie aus. Andernfalls geben Sie die URL der WSDL-Datei im Feld „WSDL“ ein.
7.
Klicken Sie auf „Weiter“ und wählen Sie die Operation aus, die Sie aufrufen möchten.
Das Fenster auf der rechten Seite zeigt Details für die ausgewählte Operation an. Wenn die ausgewählte Operation nicht SOAP-verschlüsselt oder nicht doc-literal ist, wird in diesem Fenster eine Warnungsmeldung angezeigt und Sie können den Vorgang nicht fortsetzen.
8.
Klicken Sie auf „Fertig stellen“.
9.
Geben Sie in der Liste „Ausführen am“ an, wo die Verarbeitung vorgenommen werden soll:
      •
      Wenn die Anforderung auf dem Client-Computer verarbeitet werden soll, wählen Sie „Client“ aus.
      •
      Wenn die Anforderung auf dem Server verarbeitet werden soll, wählen Sie „Server“ aus.
      •
      Wenn die Anforderung auf dem Client-Computer und dem Server verarbeitet werden soll, wählen Sie „Client und Server“ aus.
10.
Um die Struktur des Formulars zu aktualisieren und die zurückgesendeten Daten nach Abschluss der Verarbeitung zusammenzuführen, wählen Sie „Formulardaten erneut zusammenfügen“ aus.
Verwandte Themen
Info über Verarbeitungsoptionen für eine Schaltfläche
Eigenschaften von Schaltflächen: Registerkarte „Ausführen“


So hängen Sie ein Datenbankskript an eine Schaltfläche an

Sie können Skripten für komplexere Datenbearbeitung in einem Unternehmenssystem verwenden. In diesem Beispiel können Sie sehen, wie einige einfache Skripten zu Schaltflächenfeldern hinzugefügt werden, um einfache Datenbankoperationen durchzuführen, wie z. B. das Wechseln zum ersten, vorherigen, nächsten und letzten Datensatz, das Hinzufügen neuer Datensätze, das Aktualisieren vorhandener Datensätze und das Löschen von Datensätzen.
Dieses Beispiel basiert auf einer bestimmten Datenbank und Konfiguration, die nicht in den LiveCycle Designer-Musterdateien enthalten ist. Das Beispiel dient als Referenz für die Erstellung Ihrer eigenen Datenbankabfrageskripten.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie 8 Schaltflächenobjekte in den Formularentwurf. Wenn Sie ein Schaltflächenobjekt hinzufügen, lautet der Standardkontrolltyp „Normal“. Übernehmen Sie die Standardeinstellung.
2.
Benennen Sie die Schaltflächen folgendermaßen: „Erste“, „Vorherige“, „Nächste“, „Letzte“, „Neue Hinzufügen“, „Aktualisieren“, „Löschen“ und „Abbrechen“.
3.
Wählen Sie die erste Schaltfläche aus, in diesem Fall die Schaltfläche mit der Bezeichnung „Erste“.
4.
Wählen Sie im Skript-Editor in der Liste „Einblenden“ die Option click, in der Liste „Sprache“ die Option „JavaScript“ und in der Liste „Ausführen am“ die Option „Client“ aus.
5.
Fügen Sie im Skript-Editor folgendes JavaScript-Skript hinzu:

xfa.sourceSet.DataConnection.first();
6.
Wiederholen Sie Schritt 5 mit Hilfe folgender Skripten für alle übrigen Schaltflächen:
      •
      „Vorherige“: xfa.sourceSet.DataConnection.previous();
      •
      „Nächste“: xfa.sourceSet.DataConnection.next();
      •
      „Letzte“: xfa.sourceSet.DataConnection.last();
      •
      „Neue hinzufügen“: xfa.sourceSet.DataConnection.addNew();
      •
      „Aktualisieren“: xfa.sourceSet.DataConnection.update();
      •
      „Löschen“: xfa.sourceSet.DataConnection.delete();
      •
      „Abbrechen“: xfa.sourceSet.DataConnection.cancel();
7.
Speichern Sie den Formularentwurf.
8.
Testen Sie das Formular mit Hilfe der Registerkarte „PDF-Vorschau“. Wenn ein solches Formular in Adobe Reader ausgefüllt wird, müssen Sie mit Hilfe von LiveCycle Reader Extensions für das Formular Verwendungsrechte festlegen, damit Adobe Reader auf die Datenbank zugreifen kann.
9.
Klicken Sie auf die anderen Schaltflächen, um die mit jedem Datensatz verknüpften Daten anzuzeigen. Das Beispiel zeigt, dass die Schaltfläche „Letzte“ bewirkt, dass die ID, die Teilenummer, die Beschreibung und der Stückpreis für den letzten Datensatz in den entsprechenden Feldern angezeigt werden.
Verwandte Themen
Info über die Vorschau und das Testen von Formularen
Datenquellen
Berechnungen und Skripten in interaktiven Formularen


Mit einer Schaltfläche Felder aus einer Datenbank ausfüllen

Sie können eine Datenbank verwenden, um die Daten für Felder in Ihrem Formular bereitzustellen, einschließlich Textfelder und numerischer Felder.
In diesem Beispiel sind die Schaltfläche zum Abrufen von Datensätzen und das Listenfeld an die Datenbank (mit der Bezeichnung „Datenverbindung“) gebunden, die in der Palette „Datenansicht“ auf der linken Seite zu sehen ist. An die Schaltfläche ist außerdem ein FormCalc-Skript angehängt, um auf der Basis der im Feld „Listenfeld“ ausgewählten Teilenummer Informationen abzurufen. Die abgerufenen Datensätze werden in den Feldern „ID“, „PART_NO“, „UNITPRICE“ und „DESCRIPTION“ angezeigt.
1.
Stellen Sie eine Verbindung zur Datenbank her.
2.
Ziehen Sie aus der Palette „Datenansicht“ die Elemente „UNIT_PRICE“, „DESCRIPTION“, „PART_NO“ und „ID“ unter „Datenverbindung“ auf den Formularentwurf. Jeder Knoten, der auf den Formularentwurf gezogen wird, erstellt ein gebundenes Feld.
3.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Standard“ und ziehen Sie ein Schaltflächenobjekt auf den Formularentwurf.
4.
Geben Sie einen neuen Namen für die Schaltfläche ein. Im Beispiel wird „RETRIEVE RECORD“ verwendet.
5.
Klicken Sie auf die Schaltfläche und wählen Sie im Skript-Editor in der Liste „Einblenden“ die Option „Klick“, in der Liste „Sprache“ die Option „FormCalc“ und in der Liste „Ausführen am“ die Option „Client“ aus.
6.
Geben Sie ein FormCalc-Skript ein, das dem folgenden Beispiel ähnlich ist. Das Skript ruft die Daten in den angegebenen Datensätzen ab und druckt sie in den entsprechenden Feldern, wenn der Benutzer auf die Schaltfläche klickt.

//Ändern des Befehlstyps von TABLE in TEXT. TEXT
//entspricht der SQL-Eigenschaft
$sourceSet.DataConnection.#command.query.commandType = “text”

//Zum Festlegen des Select-Knotens. Select entspricht in diesem Fall
//einer beliebigen SQL-Eigenschaft.
$sourceSet.DataConnection.#command.query.select.nodes.item(0).value = Concat(“Select*from OfficeSupplies Where ID = “, DataListBox1.rawValue,””)

//Reopen the Data connection
$sourceSet.DataConnection.open()
7.
Speichern Sie den Formularentwurf als PDF-Datei.
8.
Testen Sie das Formular mit Hilfe der Registerkarte „PDF-Vorschau“, um zu überprüfen, ob das Skript erwartungsgemäß funktioniert.
Verwandte Themen
Info über die Vorschau und das Testen von Formularen
Datenquellen
Berechnungen und Skripten in interaktiven Formularen
So erstellen Sie ein gebundenes Feld oder Teilformular


So passen Sie die E-Mail-Senden-Schaltfläche an

Sie können die E-Mail-Adresse angeben, an die die Formulardaten gesendet werden, sowie die Betreffzeile der gesendeten E-Mail-Nachricht.
1.
Fügen Sie eine E-Mail-Senden-Schaltfläche zum Formularentwurf hinzu. Siehe So fügen Sie einem Formularentwurf Objekte hinzu.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
3.
Geben Sie die Adresse in das Feld „E-Mail-Adresse“ ein
4.
Geben Sie den Betreff in das Feld „E-Mail-Betreff“ ein.
5.
(Optional) Um eine Datenunterschrift auf die gesendeten Daten anzuwenden, wählen Sie „Sendung unterschreiben“ aus und klicken Sie dann auf „Einstellungen“, um optionale Unterschrifteneinstellungen zu konfigurieren.
Verwandte Themen
Eigenschaften der E-Mail-Senden-Schaltfläche: Registerkarte „Feld“
Digitale Unterschriften
So fügen Sie eine Datenunterschrift zu einer Senden-Schaltfläche hinzu


So passen Sie die HTTP-Senden-Schaltfläche an

1.
Fügen Sie eine HTTP-Senden-Schaltfläche zum Formularentwurf hinzu. Siehe So fügen Sie einem Formularentwurf Objekte hinzu.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und geben Sie im Feld „URL“ das URL-Protokoll ein.

Aufgabe

Verwendetes URL-Protokoll

Beispiel
Senden des Pakets an eine FTP-Site
ftp
ftp://ftp.gnu.org/gnu/GPL
Senden des Pakets an einen Webserver
http
http://meinServer/cgi-bin/
Senden des Pakets an einen sicheren Webserver
https
https://meinServer/cgi-bin/
Senden des Pakets an eine E-Mail-Adresse
mailto
mailto:benutzername@domain.com
Beim Senden von Daten an eine URL ist es empfehlenswert, ein absolutes Ziel anzugeben. Relative Ziele werden relativ zur Benutzerumgebung interpretiert. Die Benutzerumgebung kann jedoch während der Laufzeit von einem Benutzer zum nächsten variieren.
3.
(Optional) Um eine Datenunterschrift auf die gesendeten Daten anzuwenden, wählen Sie „Sendung unterschreiben“ aus und klicken Sie dann auf „Einstellungen“, um optionale Unterschrifteneinstellungen zu konfigurieren.
Verwandte Themen
Eigenschaften der HTTP-Senden-Schaltfläche: Registerkarte „Feld“
Digitale Unterschriften
So fügen Sie eine Datenunterschrift zu einer Senden-Schaltfläche hinzu


Kontrollkästchen verwenden

Kontrollkästchen – Übersicht
So legen Sie die Größe für das Kontrollkästchen fest
So legen Sie den Kontrollkästchenstil fest
So legen Sie die Statusangaben für das Kontrollkästchen fest
So definieren Sie das Verhalten des Kontrollkästchens
So legen Sie den Standardstatus für das Kontrollkästchen fest
So ändern Sie die den Statusangaben von Kontrollkästchen zugewiesenen Werte
So definieren Sie benutzerdefinierte Datenbindungseigenschaften für ein Kontrollkästchen


Kontrollkästchen – Übersicht

Fügen Sie Kontrollkästchen zum Formular hinzu, wenn Sie Benutzern die Wahl zwischen einzelnen Optionen lassen möchten, die aktiviert oder deaktiviert werden können. Der Benutzer kann den Status eines Kontrollkästchens ändern (d. h. es nach Wunsch aktivieren oder deaktivieren). Wenn das Kontrollkästchen aktiviert wurde, hat es den Status „An“. Wenn das Kontrollkästchens deaktiviert wurde, hat es den Status „Aus“. Kontrollkästchen können in jeder beliebigen Kombination aktiviert und deaktiviert werden. Außerdem können sie dazu verwendet werden, die Eigenschaften einer Auswahl festzulegen.
Nachdem Sie ein Kontrollkästchen zum Formularentwurf hinzugefügt haben, können Sie den Beschriftungstext bearbeiten und die Eigenschaften des Objekts in der Palette „Objekt“ auf den Registerkarten „Feld“, „Wert“ und „Bindung“ ändern. Sie können die folgenden Eigenschaften festlegen:
      •
      Ändern der Beschriftung für das Kontrollkästchen (Siehe So benennen Sie eine Beschriftung um)
      •
      Festlegen eines Randstils für das Kontrollkästchen (Siehe So legen Sie den Randstil fest)
      •
      Definieren des Objekts als sichtbar, unsichtbar oder ausgeblendet (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Festlegen einer Sprache für das Kontrollkästchen (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Festlegen der Größe für das Kontrollkästchen
      •
      Festlegen des Kontrollkästchenstils
      •
      Festlegen der Statusangaben für das Kontrollkästchen
      •
      Auswählen des Standardstatus des Kontrollkästchens
      •
      Eingeben der Werte für die Status „An“, „Aus“ und „Neutral“ des Kontrollkästchens
      •
      Festlegen einer Bindungsmethode zum Speichern und Abrufen gebundener Daten
Kontrollkästchen unterstützen Skripten und Berechnungen. Wenn ein Benutzer Daten bereitstellen soll, können Sie bestimmen, ob die Eingabe empfohlen oder erforderlich ist, und Sie können entsprechende Meldungen erstellen, die den Benutzer zur Dateneingabe auffordern. Alle Benutzereingaben können mit Hilfe von Skripten überprüft werden.
Sie können Kontrollkästchenobjekte an Datenelemente in einer Quelldatendatei binden, um bei der Wiedergabe des Formulars Werte für „An“ und „Aus“ aus der Quelldatei abzuleiten.
Verwandte Themen
So fügen Sie einem Formularentwurf Objekte hinzu
So können Sie Objekte benennen und umbenennen
Eigenschaften von Kontrollkästchen: Registerkarte „Feld“
Eigenschaften von Kontrollkästchen: Registerkarte „Wert“
Eigenschaften von Kontrollkästchen: Registerkarte „Bindung“
Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“


So legen Sie die Größe für das Kontrollkästchen fest

1.
Um die Größe für ein Kontrollkästchen festzulegen, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
2.
Geben Sie im Feld „Größe“ einen anderen Wert (in Punkt) ein und drücken Sie die Eingabetaste.
Je nach der eingegebenen Größe müssen Sie die Größe des Kontrollkästchens gegebenenfalls anpassen.
Verwandte Themen
Eigenschaften von Kontrollkästchen: Registerkarte „Feld“


So legen Sie den Kontrollkästchenstil fest

1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
2.
Wählen Sie in der Liste „Kontrollkästchenstil“ eine Option aus:
      •
      Um den Kontrollkästchenstil auf den Standardwert („X“) festzulegen, wählen Sie „Standard“ aus.
      •
      Um den Kontrollkästchenstil auf ein Häkchen festzulegen, wählen Sie „Häkchen“ aus.
      •
      Um den Kontrollkästchenstil auf einen Kreis festzulegen, wählen Sie „Kreis“ aus.
      •
      Um den Kontrollkästchenstil auf ein Kreuz festzulegen, wählen Sie „Kreuz“ aus.
      •
      Um den Kontrollkästchenstil auf ein Karo festzulegen, wählen Sie „Karo“ aus.
      •
      Um den Kontrollkästchenstil auf ein Quadrat festzulegen, wählen Sie „Quadrat“ aus.
      •
      Um den Kontrollkästchenstil auf einen Stern festzulegen, wählen Sie „Stern“ aus.
Verwandte Themen
Eigenschaften von Kontrollkästchen: Registerkarte „Feld“


So legen Sie die Statusangaben für das Kontrollkästchen fest

1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
2.
Wählen Sie unter „Statusangaben“ eine Option aus:
      •
      Um für das Kontrollkästchen den Status „An“ (aktiviert) oder „Aus“ (deaktiviert) festzulegen, wählen Sie „An/Aus“ aus.
      •
      Um für das Kontrollkästchen den Status „An“ (aktiviert), „Aus“ (deaktiviert) und „Neutral“ (weder aktiviert noch deaktiviert) festzulegen, wählen Sie „An/Aus/Neutral“ aus
Die Werte für die einzelnen Statusangaben müssen in der Palette „Objekt“ auf der Registerkarte „Bindung“ definiert werden. Siehe So ändern Sie die den Statusangaben von Kontrollkästchen zugewiesenen Werte.
Verwandte Themen
Eigenschaften von Kontrollkästchen: Registerkarte „Feld“
Eigenschaften von Kontrollkästchen: Registerkarte „Bindung“


So definieren Sie das Verhalten des Kontrollkästchens

1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und wählen Sie eine der folgenden Optionen aus:
      •
      Wenn Sie die Benutzer entscheiden lassen möchten, ob sie Daten eingeben möchten oder nicht, wählen Sie die Option „Benutzereingabe - Optional“ aus.
      •
      Wenn es sich bei dem Feld um ein schreibgeschütztes Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der über ein angehängtes Skript berechnet und angezeigt wird, wählen Sie die Option „Berechnet - Schreibgeschützt“ aus. Die Benutzer können den berechneten Wert nicht bearbeiten.
      •
      Wenn es sich bei dem Feld um ein editierbares Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der über ein angehängtes Skript berechnet und angezeigt wird, wählen Sie die Option „Berechnet - Benutzer darf überschreiben“ aus. Die Benutzer können den berechneten Wert bearbeiten, wenn im Berechnungsskript eine Verarbeitung der Benutzereingabe vorgesehen ist. Wenn ein Benutzer den berechneten Wert bearbeiten möchte, wird eine Meldung angezeigt, die im Feld „Meldung beim Überschreiben eines Werts“ festgelegt wurde.
      •
      Wenn es sich bei dem Feld um ein schreibgeschütztes Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der zur Laufzeit zusammengeführt oder berechnet und angezeigt wird, wählen Sie die Option „Schreibgeschützt“ aus. Die Benutzer können den Wert nicht bearbeiten.
2.
Wenn der Wert zur Laufzeit berechnet werden soll, weisen Sie dem Objekt mit Hilfe des Skript-Editors ein Berechnungsskript zu.
3.
(Optional) Wenn ein berechneter Wert überschrieben werden darf, können Sie eine Meldung in das Feld „Meldung beim Überschreiben eines Werts“ eingeben.
Sie können ein Überprüfungsmuster oder eine Skriptmeldung mit einem Wert aus einer Datenquelle dynamisch ausfüllen. Dadurch können Sie sicherstellen, dass Benutzer den richtigen Wert in das Feld eingeben.
Verwandte Themen
So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus
So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus
Eigenschaften von Kontrollkästchen: Registerkarte „Wert“


So legen Sie den Standardstatus für das Kontrollkästchen fest

1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“.
2.
Wählen Sie in der Liste „Standard“ einen Status aus:
      •
      Um den Standardstatus auf „An“ festzulegen, wählen Sie „An“ aus. Das Kontrollkästchen ist aktiviert.
      •
      Um den Standardstatus auf „Aus“ festzulegen, wählen Sie „Aus“ aus. Das Kontrollkästchen ist deaktiviert.
      •
      Um den Standardstatus auf „Neutral“ festzulegen, wählen Sie „Neutral“ aus. Das Feld wird mit grauer Füllfarbe angezeigt.
Die Liste „Standard“ steht nur zur Verfügung, wenn im Feld „Typ“ die Einstellung „Benutzereingabe“ oder „Schreibgeschützt“ ausgewählt wurde. Die Option „Neutral“ steht nur dann in der Liste „Standard“ zur Verfügung, wenn auf der Registerkarte „Feld“ im Bereich „Statusangaben“ die Option „An/Aus/Neutral“ ausgewählt wurde.
Verwandte Themen
Eigenschaften von Kontrollkästchen: Registerkarte „Wert“


So ändern Sie die den Statusangaben von Kontrollkästchen zugewiesenen Werte

Standardmäßig verwenden Kontrollkästchen Zahlen, um die Werte in den Formulardaten anzugeben. Die Standardwerte sind „1“ für „An“, „0“ für „Aus“ und „2“ für „Neutral“. Sie können diese Werte ändern, so dass sie vorhandenen Werten in einer Datenquelle entsprechen, oder aussagekräftigere Namen festlegen, die mit dem Verwendungszweck des Kontrollkästchens in der Datendatei zusammenhängen.
1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“.
2.
Geben Sie im Feld „An-Wert“ den „An“-Status des Kontrollkästchens in der Datenquelle ein.
3.
Geben Sie im Feld „Aus-Wert“ den „Aus“-Status des Kontrollkästchens in der Datenquelle ein.
4.
Wenn Sie auf der Registerkarte „Feld“ die Option „An/Aus/Neutral“ ausgewählt haben, geben Sie im Feld „Neutral-Wert“ den „Neutral“-Status des Kontrollkästchens in der Datenquelle ein.
Verwandte Themen
Datenquellen
Eigenschaften von Kontrollkästchen: Registerkarte „Bindung“


So definieren Sie benutzerdefinierte Datenbindungseigenschaften für ein Kontrollkästchen

Mit den Bindungsoptionen können Sie ein Formular erstellen, das Daten für die Infrastruktur eines Unternehmens erfasst, und/oder eine externe Datenquelle nutzen, um ein Formular zur Laufzeit auszufüllen. Die Datenbindungseigenschaften werden auf der Registerkarte „Bindung“ der Palette „Objekt“ festgelegt.
1.
Wählen Sie das Kontrollkästchen aus.
2.
Legen Sie für das Formular fest, dass beim Öffnen eine Verbindung zur Datenquelle hergestellt wird.
3.
Binden Sie das Kontrollkästchen an den entsprechenden Datenknoten. Weitere Informationen zum Binden von Objekten an eine Datenquelle finden Sie unter Info über das Binden von Feldern an eine Datenquelle.
Verwandte Themen
So ändern Sie die den Statusangaben von Kontrollkästchen zugewiesenen Werte
Datenquellen
Eigenschaften von Kontrollkästchen: Registerkarte „Bindung“


Kreise, Linien und Rechtecke verwenden

Kreise, Linien und Rechtecke – Übersicht
So ändern Sie den Linienstil
So ändern Sie die Linienstärke
So wählen Sie eine Linienfarbe aus
So legen Sie die Form des Kreises fest
So legen Sie den Start- und Endpunkt eines Bogens fest
So füllen Sie den Kreis oder das Rechteck mit Farbe oder einem Muster aus
So ändern Sie die Neigung der Linie
So ändern Sie die Ecken des Rechtecks


Kreise, Linien und Rechtecke – Übersicht

Die Zeichenobjekte in der Palette „Bibliothek“ bieten Ihnen eine Möglichkeit zur grafischen Ausgestaltung von Formularen.
      •
      Mit dem Objekt „Kreis“ können Sie auf der ganzen Seite runde, elliptische oder bogenförmige Formen zeichnen.
      •
      Mit dem Objekt „Linie“ können Sie an einer beliebigen Stelle auf der Seite durchgehende, gestrichelte oder gepunktete Linien zeichnen.
      •
      Mit dem Objekt „Rechteck“ können Sie Rechtecke mit 90°-Ecken oder mit abgerundeten Ecken zeichnen. Mit Rechtecken können Sie einen Bereich des Formulars grafisch umrahmen oder einen rechteckigen Bereich als Hintergrund für andere Objekte einfügen.
Nachdem Sie ein Zeichenobjekt zum Formularentwurf hinzugefügt haben, können Sie die Eigenschaften des Objekts in der Palette „Objekt“ auf der Registerkarte „Zeichnen“ bearbeiten. Sie können die folgenden Eigenschaften festlegen:
      •
      Ändern des Linienstils
      •
      Ändern der Linienstärke
      •
      Auswählen einer Linienfarbe
      •
      Festlegen der Form des Kreises
      •
      Festlegen des Start- und Endpunktes eines Bogens
      •
      Ausfüllen des Kreises oder Rechtecks mit Farbe oder einem Muster
      •
      Ändern der Neigung der Linie
      •
      Ändern der Ecken des Rechtecks
      •
      Definieren des Objekts als sichtbar, unsichtbar oder ausgeblendet
      •
      Definieren des Objekts als sichtbar, unsichtbar oder ausgeblendet (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
Verwandte Themen
Eigenschaften von Kreisen: Registerkarte „Zeichnen“
Eigenschaften von Linien: Registerkarte „Zeichnen“
Eigenschaften von Rechtecken: Registerkarte „Zeichnen“
Layout-Eigenschaften in der Palette „Layout“


So ändern Sie den Linienstil

1.
Wählen Sie den Kreis, die Linie oder das Rechteck aus.
2.
Wählen Sie in der Palette „Objekt“ in der Liste „Linienstil“ einen Stil aus.
Unter Umständen müssen Sie die Linienstärke einzoomen oder vergrößern, um den Stil zu erkennen.
Verwandte Themen
Eigenschaften von Kreisen: Registerkarte „Zeichnen“
Eigenschaften von Linien: Registerkarte „Zeichnen“
Eigenschaften von Rechtecken: Registerkarte „Zeichnen“


So ändern Sie die Linienstärke

1.
Wählen Sie den Kreis, die Linie oder das Rechteck aus.
2.
Geben Sie in der Palette „Objekt“ im Feld rechts neben „Linienstil“ eine neue Stärke ein.
Wenn Sie eine Zahl eingeben, durch die die Linie sehr dick wird (z. B. 1 Zoll), ist das Auswählen der Linie schwierig. Wählen Sie die Linie mit Hilfe der Palette „Hierarchie“ aus.
Verwandte Themen
Eigenschaften von Kreisen: Registerkarte „Zeichnen“
Eigenschaften von Linien: Registerkarte „Zeichnen“
Eigenschaften von Rechtecken: Registerkarte „Zeichnen“


So wählen Sie eine Linienfarbe aus

1.
Wählen Sie den Kreis, die Linie oder das Rechteck aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Schaltfläche für die Farbauswahl und wählen Sie eine Farbe aus.
Verwandte Themen
Eigenschaften von Kreisen: Registerkarte „Zeichnen“
Eigenschaften von Linien: Registerkarte „Zeichnen“
Eigenschaften von Rechtecken: Registerkarte „Zeichnen“


So legen Sie die Form des Kreises fest

1.
Wählen Sie den Kreis aus.
2.
Wählen Sie in der Palette „Objekt“ in der Liste „Erscheinungsbild“ die Form des Objekts aus.
      •
      Wenn Sie eine elliptische Form zeichnen möchten, wählen Sie „Ellipse“ aus.
      •
      Wenn Sie eine kreisförmige Form zeichnen möchten, wählen Sie „Kreis“ aus.
      •
      Wenn Sie einen Bogen zeichnen möchten, wählen Sie „Bogen“ aus.
Verwandte Themen
Eigenschaften von Kreisen: Registerkarte „Zeichnen“


So legen Sie den Start- und Endpunkt eines Bogens fest

1.
Wählen Sie den Bogen aus.
2.
In der Palette „Objekt“ geben Sie den Start- und den Endpunkt des Bogens (in Grad) in die Felder „Anfang“ und „Ende“ ein.
Verwandte Themen
Eigenschaften von Kreisen: Registerkarte „Zeichnen“


So füllen Sie den Kreis oder das Rechteck mit Farbe oder einem Muster aus

1.
Wählen Sie den Kreis oder das Rechteck aus.
2.
Wählen Sie in der Palette „Objekt“ in der Liste „Füllfarbe“ eine Option aus.
3.
Mit den nebenstehenden Schaltflächen für die Farbauswahl können Sie geeignete Füllfarben auswählen.
Verwandte Themen
Eigenschaften von Kreisen: Registerkarte „Zeichnen“
Eigenschaften von Rechtecken: Registerkarte „Zeichnen“


So ändern Sie die Neigung der Linie

Sie können die Neigung der Linie ändern. Dies ist hilfreich, wenn Sie eine krumme Linie gezeichnet haben. Mit dieser Option können Sie die Linie gerade ausrichten.
1.
Wählen Sie die Linie aus.
2.
Klicken Sie in der Palette „Objekt“ auf eine der Schaltflächen für das Erscheinungsbild [image].
Verwandte Themen
Eigenschaften von Linien: Registerkarte „Zeichnen“


So ändern Sie die Ecken des Rechtecks

1.
Wählen Sie das Rechteck aus.
2.
Klicken Sie in der Palette „Objekt“ auf eine der Schaltflächen „Ecken“.
3.
Legen Sie im Feld „Radius“ den Eckenradius fest.
Verwandte Themen
Eigenschaften von Rechtecken: Registerkarte „Zeichnen“


Inhaltsbereiche verwenden

Inhaltsbereiche – Übersicht
Datenfluss zwischen Inhaltsbereichen
So wählen Sie einen Inhaltsbereich aus
So benennen Sie einen Inhaltsbereich um
So definieren Sie die Tab- und Ausfüllreihenfolge für die Teilformulare innerhalb des Inhaltsbereichs
So können Sie Inhaltsbereiche kopieren, verschieben und in der Größe ändern
So fügen Sie Inhaltsbereiche hinzu


Inhaltsbereiche – Übersicht

Inhaltsbereiche bieten für alle Objekte in einem Formular (einschließlich der Teilformulare) eine Positionierungs- und Layoutverwaltung.
Normalerweise ist es nicht erforderlich, die Eigenschaften eines Inhaltsbereichs zu verändern. Wenn Sie jedoch ein Formular mit Teilformularen entwerfen, die für fließenden Inhalt definiert sind, sollten sie sich mit den Eigenschaften von Inhaltsbereichen vertraut machen, um das Verhalten von Teilformularen besser verstehen zu können.
Inhaltsbereiche können nicht über die Registerkarte „Designansicht“ des Layout-Editors ausgewählt oder bearbeitet werden. Wenn erforderlich, können Sie Inhaltsbereiche auf der Registerkarte „Masterseiten“ des Layout-Editors auswählen, ausschneiden, kopieren, einfügen, verschieben, löschen und verkleinern oder vergrößern. Ein Rechteck auf der Masterseite markiert den Inhaltsbereich.
Neue Formulare verfügen über einen Standard-Inhaltsbereich. Gegebenenfalls können Sie dem Formular weitere Inhaltsbereiche hinzufügen, z. B. wenn Sie ein Formular mit Teilformularen entwerfen, die für fließenden Inhalt definiert sind. Alle Inhaltsbereiche werden in der Palette „Hierarchie“ angezeigt.
Verwandte Themen
So können Sie Objekte benennen und umbenennen
Layout-Eigenschaften in der Palette „Layout“
Eigenschaften von Inhaltsbereichen: Registerkarte „Inhaltsbereich“


Datenfluss zwischen Inhaltsbereichen

Wenn mehrere Inhaltsbereiche definiert sind, können Objekte bei der Wiedergabe des Formulars zwischen den Inhaltsbereichen verschoben werden. Sie können eine Fließrichtung für die Objekte und ihre Daten festlegen. Die Fließrichtung bestimmt, in welcher Reihenfolge der Fokus bei einer Aktivierung der Objekte durch die Tabulatortaste im Formular wechselt. Er bestimmt auch, in welcher Reihenfolge den Objekten im Formular zusammengeführte Daten zugewiesen werden. Wenn Sie die Fließrichtung in einem Inhaltsbereich bestimmen, legen Sie gleichzeitig die Fließrichtung aller anderen Inhaltsbereiche im Formular fest.
Wenn ein Objekt mit zusammengeführten Daten bei der Wiedergabe des Formulars so viel Platz einnimmt, dass der Platz in einem Inhaltsbereich nicht mehr ausreicht, können die Daten in den nächsten und die folgenden Inhaltsbereiche fließen. Wenn Sie ein Formular entwerfen, können Sie einem Inhaltsbereich nur so viele Objekte hinzufügen, wie er fassen kann. Wenn der gesamte Platz im Inhaltsbereich ausgefüllt ist, erscheinen die verbleibenden Objekte im nächsten verfügbaren Inhaltsbereich. Steht kein weiterer Inhaltsbereich zur Verfügung, der die überzähligen Objekte aufnehmen könnte, werden die Daten nicht richtig wiedergegeben.
Verwandte Themen
So fügen Sie Inhaltsbereiche hinzu


So wählen Sie einen Inhaltsbereich aus

Sie können einen Inhaltsbereich über die Palette „Hierarchie“ oder die Registerkarte „Masterseiten“ des Layout-Editors auswählen.
      *
      Führen Sie zum Auswählen eines Inhaltsbereichs einen der folgenden Schritte aus:
      •
      Klicken Sie im Layout-Editor auf die Registerkarte „Masterseiten“. Klicken Sie auf das blaue Rechteck, das den Inhaltsbereich abgrenzt.
      •
      Klicken Sie in der Palette „Hierarchie“ auf den Inhaltsbereich.
Verwandte Themen
Eigenschaften von Inhaltsbereichen: Registerkarte „Inhaltsbereich“


So benennen Sie einen Inhaltsbereich um

      •
      Wenn Sie einen Inhaltsbereich über die Palette „Hierarchie“ umbenennen möchten, klicken Sie mit der rechten Maustaste auf das Objekt und wählen Sie „Objekt umbenennen“ aus. Geben Sie den neuen Namen ein und drücken Sie die Eingabetaste.
      •
      Wenn Sie einen Inhaltsbereich über die Palette „Objekt“ umbenennen möchten, wählen Sie den betreffenden Inhaltsbereich aus. Geben Sie in der Palette „Objekt“ einen neuen Namen für den Inhaltsbereich in das Feld „Name“ ein und drücken Sie die Eingabetaste. LiveCycle Designer behält die Häufigkeit des Vorkommens automatisch bei.
Verwandte Themen
Eigenschaften von Inhaltsbereichen: Registerkarte „Inhaltsbereich“


Zurück Weiter

LiveCycle Designer verwenden > Mit Objekten arbeiten > Objekte verwenden > Inhaltsbereiche verwenden > So definieren Sie die Tab- und Ausfüllreihenfolge für die Teilformulare innerhalb des Inhaltsbereichs

So definieren Sie die Tab- und Ausfüllreihenfolge für die Teilformulare innerhalb des Inhaltsbereichs

      *
      Wählen Sie in der Palette „Objekt“ eine der folgenden Optionen in der Liste „Fließrichtung“ aus:
      •
      Wenn die standardmäßige Tab- und Ausfüllreihenfolge auf der Seite von oben nach unten verlaufen soll, wählen Sie „Von oben nach unten“ aus.
      •
      Wenn die standardmäßige Tab- und Ausfüllreihenfolge oben beginnen und nach rechts verlaufen soll, bis das letzte Objekt rechts auf der Seite erreicht ist, wählen Sie „Von links nach rechts“ aus. Ist der rechte Seitenrand erreicht, setzen sich die Tab-Reihenfolge und die Fließrichtung beim nächsten unteren Objekt links auf der Seite fort.
Verwandte Themen
Eigenschaften von Inhaltsbereichen: Registerkarte „Inhaltsbereich“


So können Sie Inhaltsbereiche kopieren, verschieben und in der Größe ändern

Sie können Inhaltsbereiche mit Hilfe der Registerkarte „Masterseiten“ des Layout-Editors ausschneiden, kopieren, einfügen, löschen, verkleinern, vergrößern oder neu positionieren. Sie können nur die Inhaltsbereiche ausschneiden oder löschen, die Sie einer Masterseite hinzugefügt haben. Ein Formular muss mindestens einen Inhaltsbereich enthalten. Der Standard-Inhaltsbereich kann nicht gelöscht werden.
So können Sie einen Inhaltsbereich ausschneiden, kopieren, einfügen oder löschen
      *
      Klicken Sie im Layout-Editor auf die Registerkarte „Masterseiten“. Klicken Sie mit der rechten Maustaste auf den Inhaltsbereich und wählen Sie den entsprechenden Menübefehl aus.
So ändern Sie die Größe eines Inhaltsbereichs
      *
      Ändern Sie die Größe des Inhaltsbereiches auf der Registerkarte „Masterseiten“ mit Hilfe einer der folgenden Methoden:
      •
      Klicken Sie auf die Begrenzung des Inhaltsbereichs und ziehen Sie an den Größenziehpunkten, um die Objektgröße zu ändern.
      •
      Wählen Sie den Inhaltsbereich aus und legen Sie dann in der Palette „Layout“ die Größeneinstellungen fest.
So verschieben Sie einen Inhaltsbereich
1.
Wählen Sie im Layout-Editor auf der Registerkarte „Masterseiten“ einen Inhaltsbereich aus.
2.
Verschieben Sie den Inhaltsbereich mit einer der folgenden Methoden:
      •
      Ziehen Sie den Inhaltsbereich an eine neue Position.
      •
      Bearbeiten Sie die x- und y-Koordinaten in der Palette „Layout“.
      •
      Verschieben Sie den Inhaltsbereich mit einer Pfeiltaste in eine Richtung.
Verwandte Themen
Eigenschaften von Masterseiten auf der Registerkarte „Masterseite“


So fügen Sie Inhaltsbereiche hinzu

Sie können einen Inhaltsbereich über das Menü „Einfügen“ oder die Palette „Bibliothek“ hinzufügen. Inhaltsbereiche können nur auf Masterseiten eingefügt werden.
So fügen Sie einen Inhaltsbereich über das Menü hinzu
      *
      Rufen Sie die Masterseite des Formulars auf und wählen Sie die Optionen „Einfügen“ > „Standard“ > „Inhaltsbereich“.
So fügen Sie einen Inhaltsbereich über die Palette „Bibliothek“ hinzu
      *
      Führen Sie einen der folgenden Schritte aus:
      •
      Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“. Klicken Sie auf das Objekt „Inhaltsbereich“ und ziehen Sie es auf die Masterseite des Formulars.
      •
      Ziehen Sie ein Inhaltsbereichsobjekt aus der Kategorie „Standard“ der Palette „Bibliothek“ auf die Masterseite des Formulars.
      •
      Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“. Doppelklicken Sie auf das Objekt „Inhaltsbereich“.
Verwandte Themen
Datenfluss zwischen Inhaltsbereichen


Datums-/Uhrzeitfelder verwenden

Datums-/Uhrzeitfelder – Übersicht
So fügen Sie aktuelle Datumsfelder hinzu
So definieren Sie das Verhalten von Datums-/Uhrzeitfeldern
So definieren Sie benutzerdefinierte Datenbindungseigenschaften für Datums-/Uhrzeitfelder
So legen Sie die in Datums-/Uhrzeitfeldern angezeigten Daten fest
So legen Sie das Zeichenformat für Datums-/Uhrzeitfelder fest
So begrenzen Sie die Zahlen in Datums-/Uhrzeitfeldern


Datums-/Uhrzeitfelder – Übersicht

Wenn Sie die Möglichkeit bieten möchten, Datum und/oder Uhrzeit in einem Formular zu erfassen, müssen Sie dem Formular ein Datums-/Uhrzeitfeld hinzufügen. Der Wert in einem Datums-/Uhrzeitfeld kann mit Hilfe von vordefinierten Mustern und mit Hilfe des für das Feld angegebenen Gebietsschemas formatiert und angezeigt werden.
Sie können Ihrem Formularentwurf beispielsweise ein Datums-/Uhrzeitfeld hinzufügen, so dass Benutzer das Datum eingeben oder in einem Kalenderfenster auswählen können.
Nachdem Sie ein Datums-/Uhrzeitfeld zum Formularentwurf hinzugefügt haben, können Sie den Beschriftungstext bearbeiten und die Eigenschaften des Objekts in der Palette „Objekt“ auf den Registerkarten „Feld“, „Wert“ und „Bindung“ ändern. Sie können die folgenden Eigenschaften festlegen:
      •
      Ändern der Beschriftung für das Feld (Siehe So benennen Sie eine Beschriftung um)
      •
      Festlegen eines Randstils für das Feld (Siehe So legen Sie den Randstil fest)
      •
      Definieren des Feldes als sichtbar, unsichtbar oder ausgeblendet (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Festlegen einer Sprache für das Feld (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Festlegen des Zeichenformats für das Feld (Siehe So legen Sie das Zeichenformat für Datums-/Uhrzeitfelder fest)
      •
      Festlegen der Verwendung der horizontalen Länge des Textfeldes zur Bestimmung der maximal zulässigen Anzahl von Zeichen und Ziffern in LiveCycle Designer
      •
      Definieren des Anzeigemusters
      •
      Definieren des Bearbeitungsmusters (d. h. des Formats der Dateneingabe)
      •
      Bestimmen des anfänglich anzuzeigenden Standardwertes
      •
      Definieren einer Laufzeiteigenschaft (Sie können zum Beispiel das Datum und die Uhrzeit der Formular-Wiedergabe einfügen)
      •
      Definieren von Überprüfungsmustern
      •
      Festlegen, ob das Datum, die Uhrzeit oder beides angezeigt werden soll
      •
      Definieren von Datenbindungsmustern
      •
      Festlegen einer Bindungsmethode zum Speichern und Abrufen gebundener Daten
Datums-/Uhrzeitfelder unterstützen Skripte und Berechnungen. Wenn ein Benutzer Daten bereitstellen soll, können Sie bestimmen, ob die Eingabe empfohlen oder erforderlich ist, und Sie können entsprechende Meldungen erstellen, die den Benutzer zur Dateneingabe auffordern. Alle Benutzereingaben können mit Hilfe von Skripten überprüft werden.
Verwandte Themen
Info über Feldmuster und Wertformatierung
Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“
Datums-/Uhrzeitfelder
Eigenschaften von Datums-/Uhrzeitfeldern: Registerkarte „Feld“
Eigenschaften von Datums-/Uhrzeitfeldern: Registerkarte „Wert“
Eigenschaften von Datums-/Uhrzeitfeldern: Registerkarte „Bindung“


So fügen Sie aktuelle Datumsfelder hinzu

Mit einem Datums-/Uhrzeitfeld können Sie das aktuelle Datum automatisch anzeigen, indem Sie die Option „Laufzeiteigenschaften“ auf der Registerkarte „Wert“ in der Palette „Objekt“ verwenden.
Bei der Verwendung eines aktuellen Datumsfeldes wird das Datum aktualisiert, um das aktuelle Systemdatum jedes Mal wiederzugeben, wenn ein Benutzer das Formular öffnet.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie ein Objekt „Datums-/Uhrzeitfeld“ in den Formularentwurf.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und wählen Sie in der Liste „Typ“ die Option „Berechnet - Schreibgeschützt“ aus.
3.
Aktivieren Sie die Option „Laufzeiteigenschaften“.
4.
Zeigen Sie auf der Registerkarte „PDF-Vorschau“ eine Vorschau des Formulars an.
Verwandte Themen
Datums-/Uhrzeitfelder – Übersicht
Eigenschaften von Datums-/Uhrzeitfeldern: Registerkarte „Wert“


So definieren Sie das Verhalten von Datums-/Uhrzeitfeldern

1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“. Wählen Sie eine der folgenden Optionen aus:
      •
      Wenn Sie die Benutzer entscheiden lassen möchten, ob sie Daten eingeben möchten oder nicht, wählen Sie die Option „Benutzereingabe - Optional“ aus.
      •
      Wenn Sie die Benutzer zur Dateneingabe auffordern möchten und es sich bei dem Feld um ein empfohlenes Feld handeln soll, wählen Sie die Option „Benutzereingabe - Empfohlen“ aus und geben Sie im Feld „Meldung bei leerem Feld“ eine benutzerdefinierte Meldung ein.
      •
      Wenn Sie die Benutzer zur Dateneingabe auffordern möchten und es sich bei dem Feld um ein erforderliches Feld handeln soll, wählen Sie die Option „Benutzereingabe - Erforderlich“ aus und geben Sie im Feld „Meldung bei leerem Feld“ eine benutzerdefinierte Meldung ein.
      •
      Wenn es sich bei dem Feld um ein schreibgeschütztes Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der über ein angehängtes Skript berechnet und angezeigt wird, wählen Sie die Option „Berechnet - Schreibgeschützt“ aus. Die Benutzer können den berechneten Wert nicht bearbeiten.
      •
      Wenn es sich bei dem Feld um ein editierbares Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der über ein angehängtes Skript berechnet und angezeigt wird, wählen Sie die Option „Berechnet - Benutzer darf überschreiben“ aus. Die Benutzer können den berechneten Wert bearbeiten, wenn im Berechnungsskript eine Verarbeitung der Benutzereingabe vorgesehen ist. Wenn ein Benutzer den berechneten Wert bearbeiten möchte, wird eine Meldung angezeigt, die im Feld „Meldung beim Überschreiben eines Werts“ festgelegt wurde.
      •
      Wenn es sich bei dem Feld um ein schreibgeschütztes Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der zur Laufzeit zusammengeführt oder berechnet und angezeigt wird, wählen Sie die Option „Schreibgeschützt“ aus. Die Benutzer können den Wert nicht bearbeiten.
2.
Wenn der Wert empfohlen oder erforderlich ist, geben Sie in das Feld „Meldung bei leerem Feld“ eine Eingabeaufforderung ein.
3.
Wenn der Wert zur Laufzeit berechnet werden soll, weisen Sie dem Objekt mit Hilfe des Skript-Editors ein Berechnungsskript zu.
4.
(Optional) Wenn ein berechneter Wert überschrieben werden darf, können Sie eine Meldung in das Feld „Meldung beim Überschreiben eines Werts“ eingeben.
Sie können ein Überprüfungsmuster oder eine Skriptmeldung mit einem Wert aus einer Datenquelle dynamisch ausfüllen. Dadurch können Sie sicherstellen, dass Benutzer den richtigen Wert in das Feld eingeben.
Verwandte Themen
Datums-/Uhrzeitfelder – Übersicht
So legen Sie einen Standardwert fest
So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus
So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus
Eigenschaften von Datums-/Uhrzeitfeldern: Registerkarte „Wert“


So definieren Sie benutzerdefinierte Datenbindungseigenschaften für Datums-/Uhrzeitfelder

Mit den Bindungsoptionen können Sie ein Formular erstellen, das Daten für die Infrastruktur eines Unternehmens erfasst, und/oder eine externe Datenquelle nutzen, um ein Formular zur Laufzeit auszufüllen. Die Datenbindungseigenschaften werden auf der Registerkarte „Bindung“ der Palette „Objekt“ festgelegt.
1.
Wählen Sie das Datums-/Uhrzeitfeld aus.
2.
Legen Sie für das Formular fest, dass beim Öffnen eine Verbindung zur Datenquelle hergestellt wird.
3.
Binden Sie das Feld an den entsprechenden Datenknoten. Weitere Informationen zum Binden von Objekten an eine Datenquelle finden Sie unter Info über das Binden von Feldern an eine Datenquelle.
Verwandte Themen
Datums-/Uhrzeitfelder – Übersicht
Eigenschaften von Datums-/Uhrzeitfeldern: Registerkarte „Bindung“


So legen Sie die in Datums-/Uhrzeitfeldern angezeigten Daten fest

Sie können festlegen, ob das Datum, die Uhrzeit oder beides angezeigt werden soll.
1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“.
2.
Geben Sie in der Liste „Datenformat“ an, was im jeweiligen Feld angezeigt werden soll:
    • Datum
Legt fest, dass das Objekt ein Datum ist.
    • Uhrzeit
Legt fest, dass das Objekt eine Uhrzeit ist.
    • Datum und Uhrzeit
Legt fest, dass das Objekt ein Datum und eine Uhrzeit ist.
Verwandte Themen
Datums-/Uhrzeitfelder – Übersicht
Eigenschaften von Datums-/Uhrzeitfeldern: Registerkarte „Bindung“


So legen Sie das Zeichenformat für Datums-/Uhrzeitfelder fest

Mit dem Zeichenformat können Sie die Zahlen durch Begrenzungslinien trennen, die zu Datums-/Uhrzeitfeldern hinzugefügt werden.
1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
2.
Wählen Sie „Zeichenanzahl in Textfeld“ aus, um die einzelnen Zahlen im Datums-/Uhrzeitfeld durch Begrenzungslinien voneinander zu trennen.
3.
Geben Sie ein, wie viele Zahlen im Datums-/Uhrzeitfeld durch Begrenzungslinien getrennt werden.
Verwandte Themen
Datums-/Uhrzeitfelder – Übersicht
Eigenschaften von Datums-/Uhrzeitfeldern: Registerkarte „Feld“


So begrenzen Sie die Zahlen in Datums-/Uhrzeitfeldern

Sie können einschränken, wie viele Zahlen in Datums-/Uhrzeitfelder eingegeben werden können, indem Sie für LiveCycle Designer die Verwendung der horizontalen Länge des Datums-/Uhrzeitfeldes zur Bestimmung der zulässigen Anzahl von Zahlen festlegen.
      *
      Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie „Länge auf sichtbaren Bereich beschränken“ aus.
Verwandte Themen
Datums-/Uhrzeitfelder – Übersicht
Eigenschaften von Datums-/Uhrzeitfeldern: Registerkarte „Feld“


Dezimalfelder und numerische Felder verwenden

Dezimalfelder – Übersicht
Numerische Felder – Übersicht
So definieren Sie eine Radix-Ausrichtung (Dezimalstelle) für numerische Werte
So definieren Sie das Verhalten von Dezimalfeldern oder numerischen Feldern
So definieren Sie benutzerdefinierte Datenbindungseigenschaften für Dezimalfelder oder numerische Felder
So legen Sie das Datenformat für numerische Felder fest
So begrenzen Sie die eingegebenen Zahlen in Dezimalfeldern und numerischen Feldern
So führen Sie eine Berechnung mit Dezimalfeldern und JavaScript durch
So legen Sie das Zeichenformat für Dezimalfelder und numerische Felder fest


Dezimalfelder – Übersicht

Dezimalfelder funktionieren ähnlich wie numerische Felder. In der folgenden Tabelle werden die Unterschiede zwischen Dezimalfeldern und numerischen Feldern erläutert.

Feld

Beschreibung
Dezimalfeld
Zeigt Zahlen im Dezimalformat an.
Sie können die maximale Anzahl von Stellen vor und nach dem Komma festlegen.
Sie können ein Anzeigemuster festlegen, um den formatierten Wert mit den Stellen vor und nach dem Komma zu begrenzen.
Für ein Dezimalfeld kann kein Datenformat festgelegt werden; sein Inhalt wird immer als Dezimalwert gespeichert.
Der formatierte Wert umfasst standardmäßig zwei Stellen nach dem Dezimalzeichen.
Numerische Felder
Zeigt Zahlen als Fließkommawerte oder Ganzzahlwerte an.
Sie können die maximale Anzahl von Stellen vor und nach dem Komma nicht festlegen.
Sie können ein Datenmuster und ein Datenformat festlegen (Fließkomma oder Ganzzahl).
Der formatierte Wert hat nur zwei Ziffern nach dem Dezimalzeichen.
Verwenden Sie das Dezimalfeld in folgenden Fällen:
      •
      Wenn Sie die Anzahl von Stellen vor oder nach dem Komma festlegen möchten.
      •
      Wenn Dezimal- oder Ganzzahlwerte mit allen ursprünglich eingegebenen Stellen und ohne Rundung angezeigt werden sollen (deaktivieren Sie dazu die Option „Stellen nach dem Komma begrenzen“).
So könnte beispielsweise ein Feld mit dem Namen „Menge“ in einem wiederholten Teilformular vorhanden sein. Beim ersten Auftreten des Feldes im Teilformular hat das Feld „Menge“ den Wert 3, beim zweiten Auftreten im Teilformular dagegen den Wert 3,123:
      •
      Wenn die Option „Stellen nach dem Komma begrenzen“ auf den Höchstwert 2 eingestellt wurde, wird die erste Zahl als 3 gespeichert (weil die Nullen nach dem Komma entfernt werden) und die zweite Zahl als 3,12 (weil die Zahl gerundet wird).
      •
      Wenn die Option „Stellen nach dem Komma begrenzen“ deaktiviert ist, werden beide Zahlen exakt so gespeichert, wie sie eingegeben wurden (die erste Zahl als 3 und die zweite als 3,123).
Weitere Informationen über die Optionen für Dezimalfelder finden Sie im Abschnitt über numerische Felder. Viele der Optionen sind bei beiden Feldtypen identisch.
Zum Verwenden eines Dezimalfeldobjekts in einem interaktiven Formular benötigen Sie Adobe Reader 6.0.3 oder höher.
Verwandte Themen
Numerische Felder – Übersicht
So führen Sie eine Berechnung mit Dezimalfeldern und JavaScript durch
Numerische Muster


Numerische Felder – Übersicht

Wenn Sie die Erfassung oder Anzeige von Fließkomma- oder Ganzzahlendaten (einschließlich Währungen) unterstützen möchten, können Sie dem Formular zu diesem Zweck ein numerisches Feld hinzufügen. Der Wert in einem numerischen Feld kann mit Hilfe von vordefinierten Mustern und mit Hilfe des für das Feld angegebenen Gebietsschemas formatiert und angezeigt werden.
Nachdem Sie ein numerisches Feld zum Formularentwurf hinzugefügt haben, können Sie den Beschriftungstext bearbeiten und die Eigenschaften des Objekts in der Palette „Objekt“ auf den Registerkarten „Feld“, „Wert“ und „Bindung“ ändern. Sie können die folgenden Eigenschaften festlegen:
      •
      Ändern der Beschriftung für das Feld (Siehe So benennen Sie eine Beschriftung um)
      •
      Festlegen eines Randstils für das Feld (Siehe So legen Sie den Randstil fest)
      •
      Definieren des Feldes als sichtbar, unsichtbar oder ausgeblendet (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Festlegen einer Sprache für das Feld (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Festlegen des Zeichenformats für das Feld (Siehe So legen Sie das Zeichenformat für Dezimalfelder und numerische Felder fest)
      •
      Festlegen der Verwendung der horizontalen Länge des Textfeldes zur Bestimmung der zulässigen Anzahl von Zahlen in LiveCycle Designer
      •
      Definieren des Anzeigemusters
      •
      Definieren von Bearbeitungsmustern
      •
      Bestimmen des anzuzeigenden Ausgangswertes
      •
      Definieren von Laufzeiteigenschaften (zum Beispiel die Nummer einer wiedergegebenen Seite einfügen)
      •
      Definieren von Überprüfungsmustern
      •
      Festlegen, ob das Feld Fließkomma- oder Ganzzahlwerte unterstützt
      •
      Definieren von Datenbindungsmustern
      •
      Festlegen einer Bindungsmethode zum Speichern und Abrufen gebundener Daten
Numerische Felder unterstützen Skripten und Berechnungen. Wenn ein Benutzer Daten bereitstellen soll, können Sie bestimmen, ob die Eingabe empfohlen oder erforderlich ist, und Sie können entsprechende Meldungen erstellen, die den Benutzer zur Dateneingabe auffordern. Alle Benutzereingaben können mit Hilfe von Skripten überprüft werden.
Numerische Felder erlauben einen maximalen vom Benutzer eingegebenen oder berechneten Wert von 2.147.483.647. Dies ist die größte Zahl, die in einem Computer als eine 32-Bit-Ganzzahl eingegeben werden kann.
Verwandte Themen
Beschriftungen formatieren
Info über Feldmuster und Wertformatierung
Numerische Muster
Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“
Eigenschaften von numerischen Feldern: Registerkarte „Feld“
Eigenschaften von numerischen Feldern: Registerkarte „Wert“
Eigenschaften von numerischen Feldern: Registerkarte „Bindung“


So definieren Sie eine Radix-Ausrichtung (Dezimalstelle) für numerische Werte

1.
Wählen Sie im Menü der Palette „Absatz“ die Option „Wert bearbeiten“ aus.
2.
Klicken Sie auf „Radix-Ausrichtung“ [image].
3.
Legen Sie im Feld daneben die Entfernung zwischen dem Radix-Punkt und der rechten Kante des Füllbereichs fest.
4.
Drücken Sie die Eingabetaste.
Acrobat 6.0 und Adobe Reader 6.0 unterstützen die Einstellung der Radix-Ausrichtung nicht. Wenn Sie den Entwurf als mit Acrobat 6.0 kompatibles PDF-Formular speichern möchten, verwenden Sie nicht die Einstellung der Radix-Ausrichtung. Wenn Sie diese Einstellung verwenden, können Benutzer die Werte nicht bearbeiten.
Verwandte Themen
Absatz-Eigenschaften in der Palette „Absatz“


So definieren Sie das Verhalten von Dezimalfeldern oder numerischen Feldern

1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und wählen Sie in der Liste „Typ“ eine der folgenden Optionen aus:
      •
      Wenn Sie die Benutzer entscheiden lassen möchten, ob sie Daten eingeben möchten oder nicht, wählen Sie die Option „Benutzereingabe - Optional“ aus.
      •
      Wenn Sie die Benutzer zur Dateneingabe auffordern möchten und es sich bei dem Feld um ein empfohlenes Feld handeln soll, wählen Sie die Option „Benutzereingabe - Empfohlen“ aus und geben Sie im Feld „Meldung bei leerem Feld“ eine benutzerdefinierte Meldung ein.
      •
      Wenn Sie die Benutzer zur Dateneingabe auffordern möchten und es sich bei dem Feld um ein erforderliches Feld handeln soll, wählen Sie die Option „Benutzereingabe - Erforderlich“ aus und geben Sie im Feld „Meldung bei leerem Feld“ eine benutzerdefinierte Meldung ein.
      •
      Wenn es sich bei dem Feld um ein schreibgeschütztes Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der über ein angehängtes Skript berechnet und angezeigt wird, wählen Sie die Option „Berechnet - Schreibgeschützt“ aus. Die Benutzer können den berechneten Wert nicht bearbeiten.
      •
      Wenn es sich bei dem Feld um ein editierbares Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der über ein angehängtes Skript berechnet und angezeigt wird, wählen Sie die Option „Berechnet - Benutzer darf überschreiben“ aus. Die Benutzer können den berechneten Wert bearbeiten, wenn im Berechnungsskript eine Verarbeitung der Benutzereingabe vorgesehen ist. Wenn ein Benutzer den berechneten Wert bearbeiten möchte, wird eine Meldung angezeigt, die im Feld „Meldung beim Überschreiben eines Werts“ festgelegt wurde.
      •
      Wenn es sich bei dem Feld um ein schreibgeschütztes Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der zur Laufzeit zusammengeführt oder berechnet und angezeigt wird, wählen Sie die Option „Schreibgeschützt“ aus. Die Benutzer können den Wert nicht bearbeiten.
2.
Wenn der Wert empfohlen oder erforderlich ist, geben Sie in das Feld „Meldung bei leerem Feld“ eine Eingabeaufforderung ein.
3.
Wenn der Wert zur Laufzeit berechnet werden soll, weisen Sie dem Objekt mit Hilfe des Skript-Editors ein Berechnungsskript zu.
4.
(Optional) Wenn ein berechneter Wert überschrieben werden darf, können Sie eine Meldung in das Feld „Meldung beim Überschreiben eines Werts“ eingeben.
Verwandte Themen
So legen Sie einen Standardwert fest
So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus
So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus
Eigenschaften von numerischen Feldern: Registerkarte „Wert“


Zurück Weiter

LiveCycle Designer verwenden > Mit Objekten arbeiten > Objekte verwenden > Dezimalfelder und numerische Felder verwenden > So definieren Sie benutzerdefinierte Datenbindungseigenschaften für Dezimalfelder oder numerische Felder

So definieren Sie benutzerdefinierte Datenbindungseigenschaften für Dezimalfelder oder numerische Felder

Mit den Bindungsoptionen können Sie ein Formular erstellen, das Daten für die Infrastruktur eines Unternehmens erfasst, und/oder eine externe Datenquelle nutzen, um ein Formular zur Laufzeit auszufüllen. Die Datenbindungseigenschaften werden auf der Registerkarte „Bindung“ der Palette „Objekt“ festgelegt.
1.
Wählen Sie das Feld aus.
2.
Legen Sie für das Formular fest, dass beim Öffnen eine Verbindung zur Datenquelle hergestellt wird.
3.
Binden Sie das Feld an den entsprechenden Datenknoten. Weitere Informationen zum Binden von Objekten an eine Datenquelle finden Sie unter Info über das Binden von Feldern an eine Datenquelle.
Verwandte Themen
Eigenschaften von numerischen Feldern: Registerkarte „Bindung“


So legen Sie das Datenformat für numerische Felder fest

Mit numerischen Feldern können Daten im Fließkomma- oder Ganzzahlformat gespeichert werden. In der Standardeinstellung ist das Fließkommaformat festgelegt.
In der Standardeinstellung werden numerische Daten in einem Dezimalfeld nur mit maximal zwei Stellen nach dem Dezimalkomma gespeichert. Alle Daten nach der zweiten Dezimalstelle werden gerundet.
1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“.
2.
Wählen Sie in der Liste „Datenformat“ das geeignete Format aus:
      •
      Wenn Sie das Zahlenformat als eine aus drei Teilen bestehende Darstellung einer Zahl mit einem Dezimalzeichen festlegen möchten, wählen Sie „Gleitkommazahl“ aus.
      •
      Wenn Sie Zahlen als beliebige Abfolge aus den Ziffern 0 bis 9, möglicherweise mit einem vorangestellten Minuszeichen, festlegen möchten, wählen Sie „Ganzzahl“ aus.
Verwandte Themen
So definieren Sie benutzerdefinierte Datenbindungseigenschaften für Dezimalfelder oder numerische Felder
So legen Sie ein Datenmuster fest
Eigenschaften von numerischen Feldern: Registerkarte „Bindung“
Numerische Muster


Zurück Weiter

LiveCycle Designer verwenden > Mit Objekten arbeiten > Objekte verwenden > Dezimalfelder und numerische Felder verwenden > So begrenzen Sie die eingegebenen Zahlen in Dezimalfeldern und numerischen Feldern

So begrenzen Sie die eingegebenen Zahlen in Dezimalfeldern und numerischen Feldern

Sie können einschränken, wie viele Zahlen in Dezimalfelder und numerische Felder eingegeben werden können, indem Sie für LiveCycle Designer die Verwendung der horizontalen Länge des Dezimalfeldes oder numerischen Feldes zur Bestimmung der zulässigen Anzahl von Zahlen festlegen.
      *
      Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie „Länge auf sichtbaren Bereich beschränken“ aus.
Verwandte Themen
Dezimalfelder – Übersicht
Numerische Felder – Übersicht
Eigenschaften von numerischen Feldern: Registerkarte „Feld“
Eigenschaften von Dezimalfeldern: Registerkarte „Feld“


So führen Sie eine Berechnung mit Dezimalfeldern und JavaScript durch

Mit Hilfe von FormCalc können Sie Berechnungen mit Dezimalfeldern durchführen. Wenn die Option „Stellen nach dem Komma begrenzen“ allerdings deaktiviert ist und Sie mit Hilfe von JavaScript eine Berechnung mit Dezimalfeldern durchführen möchten, müssen Sie ein Skript verwenden. Um ein hohes Maß an Präzision zu gewährleisten, wird der Wert der Dezimalfelder von LiveCycle Designer als Zeichenfolge gespeichert. Das Skript teilt dem Dezimalfeld mit, dass es eine Zahl ist.
Angenommen, ein Formularentwurf enthält drei Dezimalfelder. Das erste Feld heißt a, das zweite b und das dritte Total. Sie möchten eine Berechnung durchführen, bei der a und b addiert werden.
1.
Falls der Skript-Editor noch nicht angezeigt wird, wählen Sie „Fenster“ > „Skript-Editor“.
2.
(Optional) Vergrößern Sie die Palettenleiste des Skript-Editors durch Ziehen am Ziehpunkt.
3.
Wählen Sie das Dezimalfeld aus, das Sie in einer Berechnung verwenden möchten.
4.
Wählen Sie in der Liste „Einblenden“ den Eintrag „calculate“, in der Liste „Sprache“ den Eintrag „JavaScript“ und in der Liste „Ausführen am“ den Eintrag „Client“ aus.
5.
Geben Sie im Feld „Skriptquelle“ folgendes Skript ein:

Total.rawValue = Number(a.rawValue) + Number (b.rawValue)
      •
      „Summe“ ist der Name des Dezimalfeldes, das Sie in einer Berechnung verwenden möchten.
      •
      a ist das erste Dezimalfeld.
      •
      b ist das zweite Dezimalfeld.
6.
Klicken Sie auf „Änderungen zu Skriptquelle eingeben“, um das Skript dem Formularentwurf hinzuzufügen.
7.
Zeigen Sie auf der Registerkarte „PDF-Vorschau“ eine Vorschau des Formulars an.


So legen Sie das Zeichenformat für Dezimalfelder und numerische Felder fest

Mit dem Zeichenformat können Sie die Zeichen und Zahlen durch Begrenzungslinien trennen, die zu Dezimalfeldern und numerischen Feldern hinzugefügt werden.
1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
2.
Wählen Sie „Zeichenanzahl in Textfeld“ aus, um die einzelnen Zahlen im Dezimalfeld oder im numerischen Feld durch Begrenzungslinien voneinander zu trennen.
3.
Geben Sie ein, wie viele Zahlen im Dezimalfeld oder im numerischen Feld durch Begrenzungslinien getrennt werden.
Verwandte Themen
Dezimalfelder – Übersicht
Numerische Felder – Übersicht
Eigenschaften von numerischen Feldern: Registerkarte „Feld“
Eigenschaften von Dezimalfeldern: Registerkarte „Feld“


Dropdown-Listen und Listenfelder verwenden

Dropdown-Listen und Listenfelder – Übersicht
So legen Sie die Liste der Optionen für Dropdown-Listen oder Listenfelder fest
So definieren Sie das Verhalten von Dropdown-Listen oder Listenfeldern
So zeigen Sie in der Dropdown-Liste oder im Listenfeld eine Standardoption an
So definieren Sie benutzerdefinierte Datenbindungseigenschaften für Dropdown-Listen oder Listenfelder
So legen Sie Listenelementwerte für Dropdown-Listen oder Listenfelder fest


Dropdown-Listen und Listenfelder – Übersicht

Dropdown-Listen und Listenfelder bieten den Benutzern die Möglichkeit, in einer Liste genau eine Option auszuwählen. Die Optionen werden in Textform dargestellt. Sie definieren die Liste der Standardoptionen.

Dropdown-Liste

Listenfeld
Nur eine Option ist sichtbar, bis der Benutzer die Liste öffnet.
Es können beliebig viele Optionen gleichzeitig angezeigt werden. Sollte der Anzeigebereich des Listenfeldes für die Anzeige der gesamten Liste zu klein sein, wird neben dem Feld eine Bildlaufleiste angezeigt.
Eigene Benutzereinträge sind zulässig.
Eigene Benutzereinträge sind nicht zulässig.
Im Gegensatz zu Kontrollkästchen und Optionsfeldern unterstützen Dropdown-Listen und Listenfelder unterschiedliche Datengrößen und eine variable Anzahl von Optionen. Wenn Sie auf den abwärts gerichteten Pfeil klicken, werden alle Optionen angezeigt. Sie wählen eine einzelne Option aus, indem Sie auf den entsprechenden Listeneintrag klicken. Wenn das Layout des Formulars keine Verwendung von Kontrollkästchen und Optionsfeldern zulässt, können Sie ein Listenfeld verwenden, um mehrere Optionen zur Auswahl anzubieten.
Nachdem Sie eine Dropdown-Liste oder ein Listenfeld zum Formularentwurf hinzugefügt haben, können Sie den Beschriftungstext bearbeiten und die Eigenschaften des Objekts in der Palette „Objekt“ auf den Registerkarten „Feld“, „Wert“ und „Bindung“ ändern. Sie können die folgenden Eigenschaften festlegen:
      •
      Ändern der Beschriftung für die Liste (Siehe So benennen Sie eine Beschriftung um)
      •
      Auswählen eines Randstils für die Liste (Siehe So legen Sie den Randstil fest)
      •
      Definieren des Bildes als sichtbar, unsichtbar oder ausgeblendet (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Festlegen einer Sprache für die Liste (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Aufnehmen von Ausgangsoptionen in die Liste und Festlegen einer Standardoption
      •
      Sortieren von Optionen in auf- oder absteigender Reihenfolge
      •
      Zulassen oder Ausschließen von Benutzereingaben (nur bei Dropdown-Listen).
      •
      Definieren des Bildes als sichtbar, unsichtbar oder ausgeblendet
      •
      Festlegen einer Sprache für die Liste
      •
      Festlegen benutzerdefinierter Datenwerte für jedes Listenelement
      •
      Festlegen einer Bindungsmethode zum Speichern und Abrufen gebundener Daten
Sie können eine Dropdown-Liste oder ein Listenfeld mit Werten aus einer Datenquelle dynamisch ausfüllen.
Verwandte Themen
Info über Objekte
So füllen Sie eine Dropdown-Liste oder ein Listenfeld dynamisch aus
Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“
Eigenschaften von Dropdown-Listen: Registerkarte „Feld“
Eigenschaften von Dropdown-Listen: Registerkarte „Wert“
Eigenschaften von Dropdown-Listen: Registerkarte „Bindung“
Eigenschaften von Listenfeldern: Registerkarte „Feld“
Eigenschaften von Listenfeldern: Registerkarte „Wert“
Eigenschaften von Listenfeldern: Registerkarte „Bindung“


So legen Sie die Liste der Optionen für Dropdown-Listen oder Listenfelder fest

Sie können der Dropdown-Liste oder dem Listenfeld über die Registerkarte „Feld“ in der Palette „Objekt“ Listenelemente hinzufügen.
Sie können eine Dropdown-Liste mit Werten aus einer Datenquelle dynamisch ausfüllen.
1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und führen Sie einen der folgenden Schritte aus:
      •
      Doppelklicken Sie unter der Spaltenüberschrift „Text“ auf das Feld „Listenelemente“.
      •
      Klicken Sie auf „Element hinzufügen“ [image].
2.
Geben Sie den Text für die erste Option ein und drücken Sie die Eingabetaste.
3.
Geben Sie den Text für die nächste Option ein und drücken Sie die Eingabetaste.
4.
Wiederholen Sie Schritt 3 für jede Option, die Sie in die Liste aufnehmen möchten.
5.
Wenn Sie ein Listenelement in der Liste neu anordnen möchten, markieren Sie es und klicken Sie auf „Nach oben“ [image] oder „Nach unten“ [image].
6.
Wenn Sie ein Listenelement aus der Liste löschen möchten, markieren Sie es und klicken Sie auf „Element löschen“ [image].
7.
Wenn Sie die Liste in aufsteigender Reihenfolge sortieren möchten, wählen Sie „Aufsteigend sortieren“ [image] aus.
8.
Wenn Sie die Liste in absteigender Reihenfolge sortieren möchten, wählen Sie „Absteigend sortieren“ [image] aus.
9.
(Nur bei Dropdown-Listen) Wenn Sie Benutzern die Möglichkeit geben möchten festzulegen, dass ein bestimmtes Element nicht in der Liste angezeigt werden soll, aktivieren Sie die Option „Benutzereingabe zulassen“.
Verwandte Themen
So füllen Sie eine Dropdown-Liste oder ein Listenfeld dynamisch aus
Eigenschaften von Dropdown-Listen: Registerkarte „Feld“
Eigenschaften von Listenfeldern: Registerkarte „Feld“


So definieren Sie das Verhalten von Dropdown-Listen oder Listenfeldern

1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“. Wählen Sie in der Liste „Typ“ eine der folgenden Optionen aus:
      •
      Wenn Sie die Benutzer entscheiden lassen möchten, ob sie Daten eingeben möchten oder nicht, wählen Sie die Option „Benutzereingabe - Optional“ aus.
      •
      Wenn Sie die Benutzer zur Dateneingabe auffordern möchten und es sich bei dem Feld um ein empfohlenes Feld handeln soll, wählen Sie die Option „Benutzereingabe - Empfohlen“ aus und geben Sie im Feld „Meldung bei leerem Feld“ eine benutzerdefinierte Meldung ein.
      •
      Wenn Sie die Benutzer zur Dateneingabe auffordern möchten und es sich bei dem Feld um ein erforderliches Feld handeln soll, wählen Sie die Option „Benutzereingabe - Erforderlich“ aus und geben Sie im Feld „Meldung bei leerem Feld“ eine benutzerdefinierte Meldung ein.
      •
      Wenn es sich bei dem Feld um ein schreibgeschütztes Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der über ein angehängtes Skript berechnet und angezeigt wird, wählen Sie die Option „Berechnet - Schreibgeschützt“ aus. Die Benutzer können den berechneten Wert nicht bearbeiten.
      •
      Wenn es sich bei dem Feld um ein editierbares Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der über ein angehängtes Skript berechnet und angezeigt wird, wählen Sie die Option „Berechnet - Benutzer darf überschreiben“ aus. Die Benutzer können den berechneten Wert bearbeiten, wenn im Berechnungsskript eine Verarbeitung der Benutzereingabe vorgesehen ist. Wenn ein Benutzer den berechneten Wert bearbeiten möchte, wird eine Meldung angezeigt, die im Feld „Meldung beim Überschreiben eines Werts“ festgelegt wurde.
      •
      Wenn es sich bei dem Feld um ein schreibgeschütztes Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der zur Laufzeit zusammengeführt oder berechnet und angezeigt wird, wählen Sie die Option „Schreibgeschützt“ aus. Die Benutzer können den Wert nicht bearbeiten.
2.
Wenn der Wert empfohlen oder erforderlich ist, geben Sie in das Feld „Meldung bei leerem Feld“ eine Eingabeaufforderung ein.
3.
Wenn der Wert zur Laufzeit berechnet werden soll, weisen Sie dem Objekt mit Hilfe des Skript-Editors ein Berechnungsskript zu.
4.
(Optional) Wenn ein berechneter Wert überschrieben werden darf, können Sie eine Meldung in das Feld „Meldung beim Überschreiben eines Werts“ eingeben.
Verwandte Themen
So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus
So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus
Eigenschaften von Dropdown-Listen: Registerkarte „Wert“
Eigenschaften von Listenfeldern: Registerkarte „Wert“


So zeigen Sie in der Dropdown-Liste oder im Listenfeld eine Standardoption an

Sie können für die Dropdown-Liste oder das Listenfeld eine Standardoption festlegen. Zunächst müssen Sie die Liste der Optionen für eine Liste angeben.
1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“.
2.
Wählen Sie die Standardoption in der Liste „Standard“ aus.
Die Liste „Standard“ steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Berechnet - Benutzer darf überschreiben“ gesetzt ist.
Die Optionen in der Liste „Standard“ entsprechen den Listenelementen auf der Registerkarte „Feld“ der Palette „Objekt“.
Verwandte Themen
So legen Sie die Liste der Optionen für Dropdown-Listen oder Listenfelder fest
Eigenschaften von Dropdown-Listen: Registerkarte „Wert“
Eigenschaften von Listenfeldern: Registerkarte „Wert“


Zurück Weiter

LiveCycle Designer verwenden > Mit Objekten arbeiten > Objekte verwenden > Dropdown-Listen und Listenfelder verwenden > So definieren Sie benutzerdefinierte Datenbindungseigenschaften für Dropdown-Listen oder Listenfelder

So definieren Sie benutzerdefinierte Datenbindungseigenschaften für Dropdown-Listen oder Listenfelder

Mit den Bindungsoptionen können Sie ein Formular erstellen, das Daten für die Infrastruktur eines Unternehmens erfasst oder eine externe Quelle nutzt, um ein Formular zur Laufzeit auszufüllen. Die Datenbindungseigenschaften werden auf der Registerkarte „Bindung“ der Palette „Objekt“ festgelegt.
1.
Wählen Sie die Dropdown-Liste oder das Listenfeld aus.
2.
Legen Sie für das Formular fest, dass beim Öffnen eine Verbindung zur Datenquelle hergestellt wird.
3.
Binden Sie die Liste an den entsprechenden Datenknoten. Weitere Informationen zum Binden von Objekten an eine Datenquelle finden Sie unter Info über das Binden von Feldern an eine Datenquelle.
Verwandte Themen
So legen Sie Listenelementwerte für Dropdown-Listen oder Listenfelder fest
Eigenschaften von Dropdown-Listen: Registerkarte „Bindung“
Eigenschaften von Listenfeldern: Registerkarte „Bindung“


So legen Sie Listenelementwerte für Dropdown-Listen oder Listenfelder fest

Jedes Element in einer Liste ist mit einem Datenwert verknüpft, der das Listenelement darstellt. Standardmäßig entsprechen die Werte dem Text für das Listenelement. Sie können diese Werte ändern, so dass sie zum Beispiel vorhandenen Werten in einer Datenquelle entsprechen.
Beim ersten Festlegen von Werten ändern sich die Werte in Ganzzahlen, wobei dem ersten Element „0“ zugewiesen wird. Wenn Sie die Option „Elementwerte festlegen“ deaktivieren, entsprechen die Werte wieder dem Listenelementtext.
Sie können ein Listenfeld mit Werten aus einer Datenquelle dynamisch ausfüllen.
1.
Wählen Sie das Dropdown-Listenobjekt oder das Listenfeldobjekt aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“.
3.
Wählen Sie „Elementwerte festlegen“ aus.
4.
Doppelklicken Sie auf den ersten Wert, den Sie ändern möchten.
5.
Geben Sie den neuen Wert ein.
6.
Drücken Sie die Eingabetaste, um den nächsten Wert zu ändern, oder doppelklicken Sie auf einen anderen Wert, um diesen zu ändern.
Verwandte Themen
Datenquellen
So definieren Sie benutzerdefinierte Datenbindungseigenschaften für Dropdown-Listen oder Listenfelder
So füllen Sie eine Dropdown-Liste oder ein Listenfeld dynamisch aus


Bildfelder verwenden

Bildfelder – Übersicht
So legen Sie eine Verknüpfung zu einem Ausgangsbild (Standardbild) fest
So betten Sie Bilddaten bei der Erstellung des Formulars ein
So legen Sie die Bildgröße fest
So definieren Sie benutzerdefinierte Datenbindungseigenschaften für ein Bildfeld


Bildfelder – Übersicht

In LiveCycle Designer stehen zwei Arten von Bildobjekten zur Verfügung.
      •
      Bei Bildobjekten können Sie schreibgeschützte Bilder zu einem Formular hinzufügen, die von den Benutzern nicht bearbeitet werden können. Durch diese Objekte können Sie das Erscheinungsbild eines Formulars verbessern. Weitere Informationen zu dieser Art von Bildobjekt finden Sie unter Bilder verwenden.
      •
      Durch die Verwendung von Bildfeldobjekten können Sie Bilder hinzufügen, die in einem interaktiven Formular geändert werden können.
Bildfelder können an eine externe Datenquelle gebunden oder mit einem Skript erstellt werden. Sie unterstützen das Zusammenführen von externen Bilddaten durch Bindung. Wenn die Datenquelle einen Wert für ein Bildfeld enthält, wird das Bild im Formular wiedergegeben. Mit dieser Funktion können Bilder dynamisch ausgewählt und geladen werden. Zum Beispiel kann ein Formular die Auswahl von Katalogelementen zulassen. Mit einem Skript kann ein Bild von jedem gewählten Element angezeigt werden. Wenn das Formular ein leeres Bildfeld enthält, legt der Pfad zum Bild fest, welches Bild im Formular angezeigt wird.
Interaktive Bilder in Bildfeldobjekten können aktualisiert werden, wenn das Formular in Acrobat 7.0 und Adobe Reader 7.0 geöffnet wird. Sie sind dagegen schreibgeschützt und können nicht aktualisiert werden, wenn das Formular in Acrobat 6.0 und Adobe Reader 6.0 geöffnet wird. Allerdings könnte ein Benutzer mit Hilfe von Skripten in einem interaktiven PDF- oder HTML-Formular, das von LiveCycle Forms erstellt wurde, dasselbe Formular erneut anfordern. Das neu erstellte Formular könnte dann mit einem anderen Bild zusammengeführt werden.
Bildfeldobjekte unterstützen die folgenden Dateiformate:
      •
      Windows Bitmap (BMP)
      •
      Joint Photographic Experts Group (JPG), verschiedene Variationen
      LiveCycle Designer unterstützt JPG-Bilder, die EXIF-Daten (Exchangeable Image File) von Digitalkameras enthalten.
      •
      Graphics Interchange Format (GIF)
      LiveCycle Designer unterstützt zwar GIF-Bilder, animierte GIF-Dateien werden jedoch nicht unterstützt. LiveCycle Designer unterstützt auch Transparenz in GIF-Dateien, so dass Bilder in Formularen überlagert werden können.
      •
      Portable Network Graphics (PNG)
      LiveCycle Designer unterstützt Transparenz in PNG-Dateien, so dass Bilder in Formularen überlagert werden können.
      •
      Tagged Image File (TIF)
      LiveCycle Designer unterstützt TIF-Bilder mit Monochrom (1 Farbkomponente mit 1 Bit Farbtiefe), Grauskalen (1 Farbkomponente mit 8 Bit Farbtiefe), RGB (3 Farbkomponenten mit 8 Bit Farbtiefe) und Palette (1 Farbkomponente mit 1, 2, 4 oder 8 Bit Farbtiefe).
Ein Ausgangsbild (Standardbild), das zur Laufzeit eingefügt werden soll, kann wahlweise durch Angabe des Dateinamens oder der URL festgelegt werden. Das Bild wird zunächst verknüpft. Es wird also getrennt vom Formular gespeichert und angezeigt, wenn das Formular geöffnet wird. Alternativ dazu können die Bilddaten bei der Erstellung des Formulars in das Formular eingebettet werden.
Die Verknüpfung mit einem Bild ist keine sichere Methode zum Schutz vertraulicher geschäftlicher Daten. Wenn die Bilddaten als sensibel betrachtet werden, sollten sie im Formular eingebettet werden. Alternativ kann eine sichere HTTPS-Verbindung zusammen mit einer URL verwendet werden. Allerdings schützt HTTPS nur die Übertragung der Bilddaten. Der Zugriff auf das Bild wird nicht geschützt, d. h., es findet keine Authentifizierung statt.
Nachdem Sie ein Bildfeld zum Formularentwurf hinzugefügt haben, können Sie die Eigenschaften des Objekts in der Palette „Objekt“ bearbeiten. Sie können die folgenden Eigenschaften festlegen:
      •
      Ändern der Beschriftung für das Feld (Siehe So benennen Sie eine Beschriftung um)
      •
      Festlegen eines Randstils für das Feld (Siehe So legen Sie den Randstil fest)
      •
      Definieren des Bildes als sichtbar, unsichtbar oder ausgeblendet (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Festlegen einer Sprache für das Feld (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Einbetten des Bildes in das Formular
      •
      Anpassen der Bildgröße
      •
      Festlegen einer Bindungsmethode zum Speichern und Abrufen gebundener Bilddaten, entweder als Ergänzung oder als Alternative zum Pfad der Ausgangsbilddatei (Standardbild).
Wenn die Bilddatei oder eine Verknüpfung zur Bilddatei in der Datendatei enthalten ist, erscheint das Bild nur bei der Darstellung des Formulars; beim Entwerfen des Formulars ist es dagegen nicht sichtbar. Wenn Sie das Formular offline verwenden möchten, wählen Sie die Option „Bilddaten einbetten“ auf der Registerkarte „Feld“ in der Palette „Objekt“ aus, so dass alle Komponenten des Formulars zur Verfügung stehen.
Verwandte Themen
Eigenschaften von Bildfeldern: Registerkarte „Feld“
Eigenschaften von Bildfeldern: Registerkarte „Bindung“


So legen Sie eine Verknüpfung zu einem Ausgangsbild (Standardbild) fest

1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Wenn Sie den Speicherort der Bilddatei kennen, geben Sie im Feld „URL“ die URL zur Bilddatei ein und drücken Sie die Eingabetaste.
      •
      Wenn Sie nach dem Speicherort der Bilddatei suchen möchten, klicken Sie rechts neben dem Feld „URL“ auf die Schaltfläche „Durchsuchen“ [image], navigieren Sie zur gewünschten Bilddatei und klicken Sie auf „Öffnen“.
Um beim Öffnen des Formulars relative Pfadnamen für das Abrufen von verknüpften Bildern zu verwenden, müssen die Bilddateien in einem Ordner gespeichert werden, der für die Benutzer zugänglich ist. Wenn LiveCycle Forms verfügbar ist, muss der Pfad relativ zu LiveCycle Forms angegeben werden.
Verwandte Themen
Eigenschaften von Bildfeldern: Registerkarte „Feld“


So betten Sie Bilddaten bei der Erstellung des Formulars ein

      *
      Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie „Bilddaten einbetten“ aus.
Wenn Sie das Bild in das Formular einbetten, wird eine Kopie des Bildes im Formular gespeichert. Wenn das Bildfeld zum dynamischen Laden von Bildern bei der Wiedergabe des Formulars verwendet wird, darf die Option „Bilddaten einbetten“ nicht ausgewählt werden.
Wenn Sie das Papierformular-Barcodeobjekt verwenden, sollten Sie die Option „Bilddaten einbetten“ nur verwenden, wenn Sie dem Barcode eine Sammlung zugeordnet haben, die keine Bildfelder enthält. Die eingebetteten Bilddaten überschreiten die Kapazität des Papierformular-Barcodeobjekts.
Verwandte Themen
Eigenschaften von Bildfeldern: Registerkarte „Feld“
So erstellen Sie eine Formularobjektsammlung


So legen Sie die Bildgröße fest

1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
2.
Wählen Sie in der Liste „Größe“ eine der folgenden Optionen aus, um die Verarbeitung des Bildes nach dem Laden festzulegen:
      •
      Wenn Sie das Bild im Objekt anpassen und dabei das Seitenverhältnis beibehalten möchten, wählen Sie „Bild proportional skalieren“ aus.
      •
      Wenn Sie die Bildgröße an die Objektmaße anpassen möchten, wählen Sie „Bild passend für Rechteck skalieren“ aus. Das Seitenverhältnis wird nicht beibehalten.
      •
      Wenn Sie die Bildgröße beibehalten möchten, wählen Sie „Originalgröße verwenden“ aus. Die Bildgröße wird nicht verändert.
Verwandte Themen
Eigenschaften von Bildfeldern: Registerkarte „Feld“


So definieren Sie benutzerdefinierte Datenbindungseigenschaften für ein Bildfeld

Mit den Bindungsoptionen können Sie ein Formular erstellen, das Daten für die Infrastruktur eines Unternehmens erfasst, und/oder eine externe Datenquelle nutzen, um ein Formular zur Laufzeit auszufüllen.
1.
Wählen Sie das Bildfeld aus.
2.
Legen Sie für das Formular fest, dass beim Öffnen eine Verbindung zur Datenquelle hergestellt wird.
3.
Binden Sie das Feld an den entsprechenden Datenknoten. Weitere Informationen zum Binden von Objekten an eine Datenquelle finden Sie unter Info über das Binden von Feldern an eine Datenquelle.
Verwandte Themen
Bildfelder – Übersicht
Eigenschaften von Bildfeldern: Registerkarte „Bindung“


Bilder verwenden

Bilder – Übersicht
So legen Sie eine Verknüpfung zu einem Bild fest
So betten Sie ein Bild in ein Formular ein
So legen Sie die Bildgröße fest


Bilder – Übersicht

Um das Erscheinungsbild eines Formulars zu verbessern, können Sie Bilder zu einem Formular hinzufügen. Sie verwenden Bildobjekte, um Logos, Symbole, Grafiken und Fotos darin einzuschließen. Ein Bildobjekt besteht aus einem grafischen Element, das Benutzer nicht bearbeiten können. Bildobjekte unterstützen die folgenden Dateiformate:
      •
      Windows Bitmap (BMP)
      •
      Encapsulated PostScript (EPS)
      •
      Joint Photographic Experts Group (JPG), verschiedene Variationen
      LiveCycle Designer unterstützt JPG-Bilder, die EXIF-Daten (Exchangeable Image File) von Digitalkameras enthalten.
      •
      Graphics Interchange Format (GIF)
      LiveCycle Designer unterstützt zwar GIF-Bilder, animierte GIF-Dateien werden jedoch nicht unterstützt. LiveCycle Designer unterstützt auch Transparenz in GIF-Dateien, so dass Bilder in Formularen überlagert werden können.
      •
      Portable Network Graphics (PNG)
      LiveCycle Designer unterstützt Transparenz in PNG-Dateien, so dass Bilder in Formularen überlagert werden können.
      •
      Tagged Image File (TIF)
      LiveCycle Designer unterstützt TIF-Bilder mit Monochrom (1 Farbkomponente mit 1 Bit Farbtiefe), Grauskalen (1 Farbkomponente mit 8 Bit Farbtiefe), RGB (3 Farbkomponenten mit 8 Bit Farbtiefe) und Palette (1 Farbkomponente mit 1, 2, 4 oder 8 Bit Farbtiefe).
Welches Bild eingefügt werden soll, können Sie entweder durch einen Dateinamen oder eine URL (Uniform Resource Locator) festlegen. Standardmäßig steht das Bild über eine Verknüpfung zur Verfügung. Das bedeutet, dass es getrennt vom Formular abgespeichert und immer dann angezeigt wird, sobald jemand das Formular aufruft. Sie können das Bild auch in das Formular einbetten.
Die Verknüpfung mit einem Bild ist keine sichere Methode zum Schutz vertraulicher geschäftlicher Daten. Wenn die Bilder als vertraulich betrachtet werden, sollten Sie sie im Formular einbetten. Alternativ kann eine sichere HTTPS-Verbindung zusammen mit einer URL verwendet werden. Allerdings schützt HTTPS nur die Übertragung der Bilddaten. Der Zugriff auf das Bild wird nicht geschützt, d. h., es findet keine Authentifizierung statt.
Nachdem Sie ein Bildobjekt zum Formularentwurf hinzugefügt haben, können Sie die Eigenschaften des Objekts in der Palette „Objekt“ bearbeiten. Folgende Eigenschaften können Sie bearbeiten:
      •
      Einbetten des Bildes in das Formular
      •
      Anpassen der Bildgröße
      •
      Definieren des Bildes als sichtbar, unsichtbar oder ausgeblendet (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
Verwandte Themen
Eigenschaften von Bildern: Registerkarte „Zeichnen“


So legen Sie eine Verknüpfung zu einem Bild fest

      *
      Führen Sie in der Palette „Objekt“ einen der folgenden Schritte aus:
      •
      Wenn Sie den Speicherort der Bilddatei kennen, geben Sie im Feld „URL“ die URL zur Bilddatei ein und drücken Sie die Eingabetaste.
      •
      Wenn Sie nach dem Speicherort der Bilddatei suchen möchten, klicken Sie rechts neben dem Feld „URL“ auf die Schaltfläche „Durchsuchen“ [image], navigieren Sie zur gewünschten Bilddatei und klicken Sie auf „Öffnen“.
Um beim Öffnen des Formulars relative Pfadnamen für das Abrufen von verknüpften Bildern zu verwenden, müssen die Bilddateien in einem Ordner gespeichert werden, der für die Benutzer zugänglich ist. Wenn LiveCycle Forms verfügbar ist, muss der Pfad relativ zu LiveCycle Forms angegeben werden.
Verwandte Themen
Eigenschaften von Bildern: Registerkarte „Zeichnen“


So betten Sie ein Bild in ein Formular ein

      *
      Wählen Sie in der Palette „Objekt“ die Option „Bilddaten einbetten“ aus.
Wenn Sie das Bild in das Formular einbetten, wird eine Kopie des Bildes im Formular gespeichert.
Verwandte Themen
Eigenschaften von Bildern: Registerkarte „Zeichnen“


So legen Sie die Bildgröße fest

1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
2.
Wählen Sie in der Liste „Größe“ eine der folgenden Optionen aus, um die Verarbeitung des Bildes nach dem Laden festzulegen:
      •
      Wenn Sie das Bild im Objekt anpassen und dabei das Seitenverhältnis beibehalten möchten, wählen Sie „Bild proportional skalieren“ aus.
      •
      Wenn Sie die Bildgröße an die Objektmaße anpassen möchten, wählen Sie „Bild passend für Rechteck skalieren“ aus. Das Seitenverhältnis wird nicht beibehalten.
      •
      Wenn Sie die Bildgröße beibehalten möchten, wählen Sie „Originalgröße verwenden“ aus. Die Bildgröße wird nicht verändert.
Verwandte Themen
Eigenschaften von Bildern: Registerkarte „Zeichnen“


Papierformular-Barcodes verwenden

Papierformular-Barcodes – Übersicht
So funktioniert der Papierformular-Barcode
So legen Sie eine eindeutige Beschriftung für den Papierformular-Barcode fest
So generieren Sie eine Beschriftung für den Papierformular-Barcode
So legen Sie die Symbole für den Papierformular-Barcode fest
So legen Sie die Scanmethode für den Papierformular-Barcode fest
So legen Sie benutzerdefinierte Dekodierungseinstellungen für einen Papierformular-Barcode fest
So steuern Sie die Datenkodierung in einem Papierformular-Barcode
So erstellen Sie ein benutzerdefiniertes Skript für die Datenkodierung in einem Papierformular-Barcode
Entwurftipps für die Verwendung von Papierformular-Barcodes


Papierformular-Barcodes – Übersicht

In einem Papierformular-Barcode werden vom Benutzer in einem interaktiven PDF-Formular eingegebene Daten elektronisch erfasst. Wenn das Formular von einem Endbenutzer mit Hilfe von Adobe Reader oder Acrobat ausgefüllt wird, wird der Barcode automatisch für die Kodierung der vom Benutzer eingegebenen Daten aktualisiert. Das ausgefüllte Formular kann dann gedruckt und per Fax, per Post oder persönlich weitergeleitet werden. Mit einem Scanner können die vom Benutzer eingegebenen Daten schließlich wieder dekodiert werden.
Das Papierformular-Barcodeobjekt kann nur verwendet werden, wenn Ihre Organisation Adobe LiveCycle Barcoded Forms implementiert hat. Weitere Informationen zu LiveCycle Barcoded Forms und zur Verteilung und Verarbeitung von Formularen mit Papierformular-Barcodes finden Sie im Handbuch 2D-Barcode-Formulare erstellen und verarbeiten.
Es folgt ein Beispiel für einen Arbeitsablauf mit der LiveCycle Barcoded Forms-Lösung. Nach dem Ausfüllen des Formulars durch den Benutzer werden die Daten automatisch im Barcode kodiert. Wenn das Formular gedruckt wurde und Ihnen eine Papierkopie zurückgegeben wurde, können die Formulardaten mit einem gewöhnlichen Barcode-Lesegerät extrahiert werden. Die Daten werden mit einer Genauigkeit von 100 % wiedergegeben und eine erneute Eingabe der Daten ist nicht erforderlich.
Wenn Sie in Formularen Papierformular-Barcodes verwenden, müssen Sie Daten nicht mehr manuell eingeben oder eine OCR-basierte Formularverarbeitung verwenden. Daten aus Fill-and-Print-Papierformularen können schnell und exakt wieder in den elektronischen Workflow integriert werden, ohne dass Daten aufgrund von Fehlern beim Scannen oder bei der erneuten manuellen Eingabe verloren gehen. Darüber hinaus können Sie von den Formularen digitale Kopien erstellen, auf denen handschriftliche Unterschriften enthalten sind.
In vielen Unternehmen werden PDF-Formulare verwendet, die elektronisch ausgefüllt werden können. Die Formulare müssen jedoch vom Benutzer unterschrieben werden, so dass die ausgefüllten Formulare gedruckt, unterschrieben und dann per Fax oder per Post zurückgesendet werden müssen. Bei Formularen mit Papierformular-Barcodes sind die elektronisch eingegebenen Daten in kodierter Form im Barcode enthalten. Nachdem also das ausgefüllte Formular zurückgesendet wird, können alle erfassten Daten mit einem Barcodeleser in eine strukturierte Datendatei gelesen werden. Lediglich die Unterschrift muss noch überprüft werden.
Das Papierformat-Barcodeobjekt kann nicht auf einem Formular verwendet werden, das als ein mit Acrobat 6.0 kompatibles PDF-Formular gespeichert wurde. Benutzer benötigen für das Ausfüllen von Formularen mit Papierformular-Barcodes entweder Acrobat 7.0 oder höher, oder Adobe Reader 7.0 oder höher für PDF417-Barcodes, und Acrobat 7.0.5 oder höher, oder Adobe Reader 7.0.5 oder höher für QR Code- und DataMatrix-Barcodes, damit die erfassten Daten kodiert werden können.
Verwandte Themen
Eigenschaften von Papierformular-Barcodes: Registerkarte „Feld“
Eigenschaften von Papierformular-Barcodes: Registerkarte „Wert“
Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“


So funktioniert der Papierformular-Barcode

Das Papierformular-Barcodeobjekt ist ein zweidimensionaler (2D) Barcode und ist mit dem Industriestandard entsprechenden Symbolen vom Typ PDF 417, QR Code (Version 2) oder DataMatrix (ECC200-Modell) verschlüsselt. Es verfügt über ein intelligentes Berechnungsskript für die Kodierung der Daten, die aus den Feldern eines Formulars erfasst werden.
Sie wählen die Formularfelder aus, die mit dem Papierformular-Barcode kodiert werden sollen. Es ist jedoch wichtig, dass Sie nur erforderliche Felder auswählen, denn die Barcodes verfügen über eine begrenzte Speicherkapazität.
Nachdem Sie einen Papierformular-Barcode zum Formularentwurf hinzugefügt haben, können Sie für ihn die gewünschten Eigenschaften festlegen. Mit Hilfe der Palette „Objekt“ können Sie die folgenden Barcode-Eigenschaften festlegen:
      •
      Barcode-Beschriftung
      •
      Im Barcode verschlüsselte Symbole
      •
      Die zur Dekodierung der Papierformular-Barcodes verwendete Scanmethode
      •
      Fehlerkorrektur-Level und die Modulbreite und -höhe des Barcodes (bei Auswahl einer benutzerdefinierten Scanmethode)
      •
      Sichtbarkeit des Objekts auf dem Formular
      •
      Die Optionen für die Datenkomprimierung
      •
      Formulardaten, die im Barcode enthalten sein sollen
      •
      Für den Papierformular-Barcode zur Kodierung der Daten und der einzuschließenden Felder verwendetes Datenformat
Sie können das fertige Formular an die jeweiligen Benutzer verteilen, die es ausfüllen, drucken und dann an Sie zurücksenden können. Mit einem Scanner können die vom Benutzer eingegebenen Daten schließlich wieder dekodiert werden. Bei PDF417-Barcodes können Formulare mithilfe von Acrobat 7.0 oder höher oder mithilfe von Adobe Reader 7.0 oder höher ausgefüllt werden. Für QR Code- und DataMatrix-Barcodes ist Acrobat 7.0.5 oder höher oder Adobe Reader 7.0.5 oder höher erforderlich.
Der Papierformular-Barcode kann nur verwendet werden, wenn Ihre Organisation LiveCycle Barcoded Forms implementiert hat.
Verwandte Themen
So fügen Sie einem Formularentwurf Objekte hinzu
So steuern Sie die Datenkodierung in einem Papierformular-Barcode
Eigenschaften von Papierformular-Barcodes: Registerkarte „Feld“
Eigenschaften von Papierformular-Barcodes: Registerkarte „Wert“
Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“


So legen Sie eine eindeutige Beschriftung für den Papierformular-Barcode fest

1.
Wählen Sie im Formularentwurf den Papierformular-Barcode aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“, deaktivieren Sie die Option „Beschriftung automatisch erstellen“ und geben Sie im Feld „Beschriftung“ eine Beschriftung ein.
Verwandte Themen
Eigenschaften von Papierformular-Barcodes: Registerkarte „Feld“


So generieren Sie eine Beschriftung für den Papierformular-Barcode

1.
Wählen Sie im Formularentwurf den Papierformular-Barcode aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie die Option „Beschriftung automatisch erstellen“ aus.
Verwandte Themen
Eigenschaften von Papierformular-Barcodes: Registerkarte „Feld“
Papierformular-Barcodes – Übersicht
Entwurftipps für die Verwendung von Papierformular-Barcodes


So legen Sie die Symbole für den Papierformular-Barcode fest

1.
Wählen Sie im Formularentwurf den Papierformular-Barcode aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie in der Liste „Symbole“ eine der folgenden Optionen aus:
      •
      PDF417
      •
      QR-Code
      •
      Datenmatrix
Endbenutzer benötigen für das Ausfüllen eines Formulars, das einen QR Code- oder einen DataMatrix-Barcode enthält, Acrobat 7.0.5 oder höher oder Adobe Reader 7.0.5 oder höher. Das Dekodieren von Code- und DataMatrix-Barcodes wird von Adobe LiveCycle Barcoded Forms 7.0, nicht jedoch von Adobe LiveCycle Barcoded Forms 7.0 Standalone (ST) unterstützt.
Verwandte Themen
Eigenschaften von Papierformular-Barcodes: Registerkarte „Feld“
Papierformular-Barcodes – Übersicht
Entwurftipps für die Verwendung von Papierformular-Barcodes


So legen Sie die Scanmethode für den Papierformular-Barcode fest

1.
Wählen Sie im Formularentwurf den Papierformular-Barcode aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie in der Liste „Scanmethode“ eine der folgenden Optionen aus:
      •
      Handscanner
      •
      Faxserver
      •
      Dokument-Scanner
      •
      Benutzerdefiniert
3.
Wenn Sie die Option „Benutzerdefiniert“ auswählen, können Sie auch benutzerdefinierte Dekodierungseinstellungen festlegen.
Verwandte Themen
Eigenschaften von Papierformular-Barcodes: Registerkarte „Feld“
Papierformular-Barcodes – Übersicht
Entwurftipps für die Verwendung von Papierformular-Barcodes


Zurück Weiter

LiveCycle Designer verwenden > Mit Objekten arbeiten > Objekte verwenden > Papierformular-Barcodes verwenden > So legen Sie benutzerdefinierte Dekodierungseinstellungen für einen Papierformular-Barcode fest

So legen Sie benutzerdefinierte Dekodierungseinstellungen für einen Papierformular-Barcode fest

1.
Wählen Sie im Formularentwurf den Papierformular-Barcode aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie in der Liste „Scanmethode“ die Option „Benutzerdefiniert“ aus.
3.
Wählen Sie zum Ändern der Dekodierungseigenschaften den gewünschten Wert in der Liste „Wert“ neben der entsprechenden Eigenschaft aus.
Wenn der Barcode später mit einem Handscanner für Barcodes dekodiert wird, sollten Sie keine Barcodes mit einer Breite von mehr als 10 cm erstellen. Hohe und schmale Barcodes werden in der Regel besser mit Hand-Scannern eingelesen.
Verwandte Themen
Eigenschaften von Papierformular-Barcodes: Registerkarte „Feld“
Papierformular-Barcodes – Übersicht
Entwurftipps für die Verwendung von Papierformular-Barcodes


So steuern Sie die Datenkodierung in einem Papierformular-Barcode

Beim Verwenden eines Papierformular-Barcodeobjekts in einem Formularentwurf müssen Sie angeben, welches Format bei der Datenkodierung verwendet werden soll und welche Daten kodiert werden sollen. Sie können folgende Datenformate festlegen:
      •
      XML
      •
      Tabulatorgetrennt
Beide Optionen enthalten für das Papierformular-Barcodeobjekt ein Skript mit der Anweisung, welcher Datentyp bei der Datenkodierung verwendet werden soll. Der Barcode kann alle Felder im Formular kodieren, nur die Daten aus den Feldern des Teilformulars, welches das übergeordnete Element des Papierformular-Barcodeobjekts ist, oder nur Felder, die Sie festlegen und in einer Sammlung speichern.
Zur Datenkodierung können Sie ein eigenes benutzerdefiniertes Skript verwenden. Weitere Informationen finden Sie unter So erstellen Sie ein benutzerdefiniertes Skript für die Datenkodierung in einem Papierformular-Barcode.
Die Datenabrufmethode für den Papierformular-Barcode können Sie über die Optionen der Registerkarte „Wert“ in der Palette „Objekt“ festlegen. Sie können ferner angeben, ob die Daten vor dem Verschlüsseln komprimiert werden sollen.
So erstellen Sie automatisch ein Skript zur Kodierung von Barcode-Daten:
1.
Wählen Sie im Formularentwurf den Papierformular-Barcode.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und wählen Sie „Automatische Skripterstellung“ aus.
3.
Wählen Sie in der Liste „Format“ eine der folgenden Optionen aus:
      •
      XML
      •
      Tabulatorgetrennt. (Optional) Wählen Sie „Feldnamen einschließen“ und „Beschriftung einschließen“ aus.
4.
Wählen Sie in der Liste „Anwenden auf“ eine der folgenden Optionen aus:
      •
      Gesamte Formulardaten
      •
      Teilformulardaten
      •
      Sammlungsdaten. Wählen Sie die Sammlung unter „Sammlung“ aus.
So komprimieren Sie die Daten vor der Kodierung
1.
Wählen Sie im Formularentwurf den Papierformular-Barcode.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und wählen Sie den Befehl „Daten vor der Kodierung komprimieren“ aus.
Verwandte Themen
So erstellen Sie ein benutzerdefiniertes Skript für die Datenkodierung in einem Papierformular-Barcode
Entwurftipps für die Verwendung von Papierformular-Barcodes
Info über Formularobjektsammlungen
Eigenschaften von Papierformular-Barcodes: Registerkarte „Wert“
Teilformulare – Übersicht
Berechnungen und Skripten


Zurück Weiter

LiveCycle Designer verwenden > Mit Objekten arbeiten > Objekte verwenden > Papierformular-Barcodes verwenden > So erstellen Sie ein benutzerdefiniertes Skript für die Datenkodierung in einem Papierformular-Barcode

So erstellen Sie ein benutzerdefiniertes Skript für die Datenkodierung in einem Papierformular-Barcode

Wenn Sie für das Kodieren von Daten bestimmte Behörden- oder sonstige Vorgaben berücksichtigen müssen, entsprechen die voreingestellten Optionen für die Datenkodierung möglicherweise nicht Ihren Anforderungen. Wenn Sie die Option „Benutzerdefiniert“ auswählen, können Sie Ihr eigenes Skript für die Datenkodierung verwenden. Ein einfaches Skript wie in diesem Beispiel ist hierbei ausreichend:
this.rawValue=NumericField1.rawValue
Sie können aber auch ein komplexes Skript verwenden, in dem auf der Grundlage bestimmter Bedingungen festgelegt wird, welche Felder kodiert werden.
1.
Wählen Sie im Formularentwurf das Papierformular-Barcodeobjekt aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und deaktivieren Sie „Automatische Skripterstellung“.
3.
Im Skript-Editor können Sie das benutzerdefinierte Beispielskript bearbeiten oder ein eigenes Skript schreiben.
Der folgende Beispielcode stellt das zum Abrufen der Feldwerte eines Formulars erforderliche JavaScript-Skript dar. Formatieren Sie eine Zeichenfolge für einen kommagetrennten Wert (CSV-Wert) mit Formularfeldern und aktualisieren Sie einen Papierformular-Barcode für ein interaktives PDF-Formular. Das Formular enthält Felder mit den Namen accountNum, formerFirstName, formerMiddleInitial, formerLastName, newFirstName, newMiddleInitial und newLastName.
// Mit dieser Funktion wird der Barcode bei Änderung
// an einem Formularfeld aktualisiert.
function depends(node)
{
for (var i = 0; i < node.nodes.length; ++i)
{
var child = node.nodes.item(i);
if (child.isContainer)
depends(child);
}
}
// Return a field surrounded by quotes and followed with a separator
function fmtField(fieldName, separator)
{
   var str = "\"" + fieldName.rawValue + "\"" + separator;
   return str;
}
// Erzwingen eine Aktualisierung aller Felder im Formular im Datensatz
depends(xfa.form);
// Erstellen einer im Barcode verschlüsselten CSV-Zeichenfolge
var comma = ",";
var newLine = "\n";
var s = fmtField(accountNum, comma);
s += fmtField(formerFirstName, comma)
s += fmtField(formerMiddleInitial, comma);
s += fmtField(formerLastName, comma);
s += fmtField(newFirstName, comma)
s += fmtField(newMiddleInitial, comma);
s += fmtField(newLastName, newLine);
// Zuweisen der Zeichenfolge zum Barcode zur Verschlüsselung
this.rawValue = s;
Verwandte Themen
So steuern Sie die Datenkodierung in einem Papierformular-Barcode
Eigenschaften von Papierformular-Barcodes: Registerkarte „Wert“
Berechnungen und Skripten.


Entwurftipps für die Verwendung von Papierformular-Barcodes

Bei der Erstellung eines Papierformular-Barcodes kommt es vor allem darauf an, diesen so zu entwerfen, dass Informationen effektiv darin kodiert und problemlos wieder in verständliche Informationen dekodiert werden können. Im Folgenden finden Sie einige Besonderheiten, die Sie beim Entwurf von Barcodes beachten sollten, so dass diese leicht zu verwenden und dekodierbar sind.

Entwurftipps für Barcodes

Details
Entwerfen Sie einen Barcode, der für den jeweiligen Verwendungszweck geeignet ist.
Überlegen Sie vorab, auf welche Art der Benutzer das Formular an Sie oder an das Unternehmen, in dem das Formular verarbeitet wird, weiterleitet. Entwerfen Sie einen Barcode, der durch Druck-, Versenden-, Fax- und Scanvorgänge nicht beeinflusst wird.
Entscheiden Sie, an welcher Stelle Sie den Barcode auf dem Formularentwurf platzieren möchten.
Sie können den Papierformular-Barcode an einer beliebigen Stelle auf dem Formularentwurf platzieren. Platzieren Sie den Barcode immer an einer gut sichtbaren Stelle, an der er problemlos gescannt werden kann. Lassen Sie einen Abstand von mindestens 1,3 cm zwischen Barcode und Papierrand, so dass der Barcode auf jeden Fall im Druckbereich liegt.
Wählen Sie die Größe des Barcodes entsprechend der zu erfassenden Datenmenge.
Die Datenmenge, die in einen Papierformular-Barcode kodiert werden kann, ist begrenzt und hängt unter anderem von der Größe des Barcodes ab. Wenn der Barcode für die vom Benutzer eingegebenen Daten zu klein gewählt wurde, wird an der rechten oberen Ecke des Barcodes eine rote Markierung mit einer Nachricht angezeigt, dass der zu kodierende Datensatz für den Barcode zu groß ist. Führen Sie in diesem Fall einen der folgenden Schritte aus:
•
Passen Sie die Größe des Barcodes an die jeweilige Datenmenge an.
•
Verkleinern Sie den Datensatz, indem Sie die Standarddatengröße für einige Formularobjekte, wie z. B. für Textfelder, ändern. Die Standardlängenbegrenzung beträgt für Textfelder beispielsweise 255 Zeichen. Bei Textfeldern für Vornamen, Nachnamen oder auch Vor- und Nachnamen könnte die Längenbegrenzung jedoch auf 20 oder 50 Zeichen reduziert werden. Das Problem der Barcodegröße wäre dadurch möglicherweise bereits behoben.
•
Durch die Verwendung von erweiterten Zeichen sowie von Groß- und Kleinbuchstaben wird die Datengröße erhöht. Schreiben Sie ein Skript, mit dessen Hilfe nur alphanumerische Zeichen und Großbuchstaben verwendet werden können.
•
Wenn in den Daten Feldnamen enthalten sind, verwenden Sie kürzere Objektnamen.
•
Teilen Sie das Formular in Teilformulare auf und ordnen Sie dann bestimmte Felder einem Teilformular oder anderen Feldern in einem anderen Teilformular zu. Fügen Sie für jedes Teilformular einen Papierformular-Barcode hinzu. Dadurch können Sie große Datenmengen auf verschiedene Barcodes aufteilen, wodurch mehr Daten kodiert werden können.
Betten Sie keine Daten für Bildfelder ein.
Papierformular-Barcodes können nicht so viele Daten speichern, dass Daten für Bilder eingebettet werden können. Wenn sich auf dem Formular ein Bildfeldobjekt befindet, wählen Sie entweder für das Bildfeldobjekt die Option „Bilddaten einbetten“ nicht aus oder schließen Sie das Objekt aus den Barcodedaten aus. Wenn das Bildfeld in den Barcodedaten enthalten ist, zeigt der Barcode eine Warnung an, dass die Datenlänge nicht berechnet werden kann.
Testen Sie das Formular, bevor Sie es verteilen
Testen Sie das fertige Formular unbedingt sowohl in Adobe Reader als auch in Acrobat, da die meisten Benutzer dieser Arten von Formularen nur über Adobe Reader verfügen.
Stellen Sie sicher, dass die Benutzer die Formulare elektronisch ausfüllen
Erklären Sie Ihren Benutzern, dass die Formulare elektronisch ausgefüllt werden müssen. Wenn das Formular ausgedruckt und dann ausgefüllt wird, kann der Papierformular-Barcode keine der vom Benutzer eingegebenen Daten kodieren.
Verwandte Themen
Papierformular-Barcodes – Übersicht
So funktioniert der Papierformular-Barcode
Info über Formularobjektsammlungen


Kennwortfelder verwenden

Kennwortfelder – Übersicht
So legen Sie das Zeichen für die Kennwortanzeige fest
So definieren Sie das Verhalten des Feldes
So definieren Sie benutzerdefinierte Datenbindungseigenschaften für ein Kennwortfeld
So begrenzen Sie die Anzahl der in Kennwortfeldern eingegebenen Zeichen


Kennwortfelder – Übersicht

Wenn Sie den Zugriff auf bestimmte Formulare mit Hilfe eines Kennwortes steuern möchten, können Sie ein Kennwortfeld in das betreffende Formular einfügen. Sobald ein Benutzer in das Kennwortfeld schreibt, werden die eingegebenen Buchstaben oder Zahlen verschlüsselt angezeigt. Das Zeichen für die verschlüsselte („maskierte“) Anzeige des Kennwortes können Sie auswählen. Bei Bedarf können Sie ein bestimmtes Eingabemuster definieren, das der Benutzer einhalten muss, damit er Zugriff auf das Formular erhält.
Nachdem Sie ein Kennwortfeld zum Formularentwurf hinzugefügt haben, können Sie den Beschriftungstext bearbeiten und die Eigenschaften des Objekts in der Palette „Objekt“ auf den Registerkarten „Feld“, „Wert“ und „Bindung“ ändern. Sie können die folgenden Eigenschaften festlegen:
      •
      Ändern der Beschriftung für das Feld (Siehe So benennen Sie eine Beschriftung um)
      •
      Festlegen eines Randstils für das Feld (Siehe So legen Sie den Randstil fest)
      •
      Definieren des Feldes als sichtbar, unsichtbar oder ausgeblendet (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Festlegen einer Sprache für die Liste (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Festlegen der Verwendung der horizontalen Länge des Textfeldes zur Bestimmung der im Kennwortfeld zulässigen Anzahl von Zeichen in LiveCycle Designer
      •
      Auswählen des Zeichens für die Kennwortanzeige
      •
      Definieren von Bearbeitungsmustern
      •
      Definieren von Überprüfungsmustern
      •
      Definieren von Datenbindungsmustern
      •
      Festlegen einer Bindungsmethode zum Speichern und Abrufen gebundener Daten
In einem Formular kann ein Kennwortfeld enthalten sein, ohne dass der Benutzer gezwungen ist, ein Kennwort anzugeben. Sie können definieren, ob das Kennwort optional, empfohlen oder erforderlich ist, und Sie können Meldungen einrichten, die den Benutzern entsprechende Hinweise geben. Alle Benutzereingaben können mit Hilfe von Skripten überprüft werden.
Verwandte Themen
Beschriftungen formatieren
Feldwerte formatieren
Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“
Kennwortmuster
Eigenschaften von Kennwortfeldern: Registerkarte „Feld“
Eigenschaften von Kennwortfeldern: Registerkarte „Wert“
Eigenschaften von Kennwortfeldern: Registerkarte „Bindung“


So legen Sie das Zeichen für die Kennwortanzeige fest

1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
2.
Geben Sie im Feld „Zeichen für Kennwortanzeige“ das Zeichen ein, das zum Ausblenden des Kennwortes verwendet werden soll, falls das Kennwort während der Laufzeit angezeigt wird.


So definieren Sie das Verhalten des Feldes

1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und wählen Sie in der Liste „Typ“ eine der folgenden Optionen aus:
      •
      Wenn Sie die Benutzer entscheiden lassen möchten, ob sie Daten eingeben möchten oder nicht, wählen Sie die Option „Benutzereingabe - Optional“ aus.
      •
      Wenn Sie die Benutzer zur Dateneingabe auffordern möchten und es sich bei dem Feld um ein empfohlenes Feld handeln soll, wählen Sie die Option „Benutzereingabe - Empfohlen“ aus und geben Sie im Feld „Meldung bei leerem Feld“ eine benutzerdefinierte Meldung ein.
      •
      Wenn Sie die Benutzer zur Dateneingabe auffordern möchten und es sich bei dem Feld um ein erforderliches Feld handeln soll, wählen Sie die Option „Benutzereingabe - Erforderlich“ aus und geben Sie im Feld „Meldung bei leerem Feld“ eine benutzerdefinierte Meldung ein.
2.
Wenn der Wert empfohlen oder erforderlich ist, geben Sie in das Feld „Meldung bei leerem Feld“ eine Eingabeaufforderung ein.
Verwandte Themen
Eigenschaften von Kennwortfeldern: Registerkarte „Wert“
So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus
So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus


So definieren Sie benutzerdefinierte Datenbindungseigenschaften für ein Kennwortfeld

Mit den Bindungsoptionen können Sie ein Formular erstellen, das Daten für die Infrastruktur eines Unternehmens erfasst, und/oder eine externe Datenquelle nutzen, um ein Formular zur Laufzeit auszufüllen. Die Datenbindungseigenschaften werden auf der Registerkarte „Bindung“ der Palette „Objekt“ festgelegt.
1.
Wählen Sie das Kennwortfeld aus.
2.
Legen Sie für das Formular fest, dass beim Öffnen eine Verbindung zur Datenquelle hergestellt wird.
3.
Binden Sie das Feld an den entsprechenden Datenknoten. Weitere Informationen zum Binden von Objekten an eine Datenquelle finden Sie unter Info über das Binden von Feldern an eine Datenquelle.
Verwandte Themen
Eigenschaften von Kennwortfeldern: Registerkarte „Bindung“


So begrenzen Sie die Anzahl der in Kennwortfeldern eingegebenen Zeichen

Sie können Sie Anzahl der in Kennwortfeldern eingegebenen Zeichen begrenzen, indem Sie für LiveCycle Designer die Verwendung der horizontalen Länge des Dezimalfeldes oder numerischen Feldes festlegen, um die zulässige Anzahl von Zeichen zu bestimmen.
      *
      Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie „Länge auf sichtbaren Bereich beschränken“ aus.
Verwandte Themen
Kennwortfelder – Übersicht
Eigenschaften von Kennwortfeldern: Registerkarte „Feld“


Optionsfelder verwenden

Optionsfelder – Übersicht
So legen Sie die Größe für ein Optionsfeld fest
So legen Sie den Stil für ein Optionsfeld fest
So weisen Sie Optionsfeldern „An“-Werte zu
So definieren Sie benutzerdefinierte Datenbindungseigenschaften für Optionsfelder
So erstellen Sie eine neue Ausschlussgruppe
So verschieben Sie ein Optionsfeld in eine andere Ausschlussgruppe
So verschieben Sie eine Ausschlussgruppe
So führen Sie Ausschlussgruppen zusammen
So definieren Sie das Verhalten der Ausschlussgruppe
So legen Sie die Standardauswahl für die Ausschlussgruppe fest


Optionsfelder – Übersicht

Optionsfelder bieten die Möglichkeit, einem Benutzer mehrere einander ausschließende Möglichkeiten zur Auswahl zu stellen. Die Benutzer können jedes Optionsfeld einer Gruppe beliebig aktivieren oder deaktivieren. Wenn ein Optionsfeld ausgewählt wird, ist sein Status „An“ und der zugehörige Wert wird registriert. Wird die Auswahl des Optionsfeldes aufgehoben, ist sein Status „Aus“ und der zugehörige Wert wird nicht registriert. Nur ein Optionsfeld in einer Gruppe kann den Status „An“ aufweisen.
Sie können ein Optionsfeld wie ein Kontrollkästchen anzeigen lassen, indem Sie die Erscheinungsmerkmale auf der Registerkarte „Feld“ der Palette „Objekt“ einstellen. Zuvor sollten Sie jedoch die Erwartungen der Benutzer im Hinblick auf das Verhalten von Kontrollkästchen berücksichtigen. Erwarten die Benutzer Kontrollkästchen, die mehrfache Auswahlmöglichkeiten bieten? Wenn dies der Fall ist, sollten Sie den Standard beibehalten und keine Optionsfeldfunktionalität auf Kontrollkästchenbilder anwenden.
Nachdem Sie ein Optionsfeld zum Formularentwurf hinzugefügt haben, können Sie den Beschriftungstext bearbeiten und die Eigenschaften des Objekts in der Palette „Objekt“ auf den Registerkarten „Feld“, „Wert“ und „Bindung“ ändern. Sie können die folgenden Eigenschaften festlegen:
      •
      Ändern der Beschriftung für das Optionsfeld (Siehe So benennen Sie eine Beschriftung um)
      •
      Auswählen eines Randstils für das Optionsfeld (Siehe So legen Sie den Randstil fest)
      •
      Definieren des Optionsfeldes als sichtbar, unsichtbar oder ausgeblendet (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Festlegen einer Sprache für das Optionsfeld (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Zuweisen eines Wertes zum „An“-Status jedes Optionsfeldes in der Ausschlussgruppe
      •
      Festlegen des Stils für das Optionsfeld
      •
      Festlegen einer Standardauswahl für die Gruppe
      •
      Festlegen einer Bindungsmethode zum Speichern und Abrufen gebundener Daten
Optionsfelder unterstützen Skripten und Berechnungen. Wenn ein Benutzer Daten bereitstellen soll, können Sie bestimmen, ob die Eingabe empfohlen oder erforderlich ist, und Sie können entsprechende Meldungen erstellen, die den Benutzer zur Dateneingabe auffordern. Die Benutzereingaben können mit Hilfe von Skripten überprüft werden.
Bei einer Ausschlussgruppe handelt es sich um eine Gruppe von Optionsfeldern. Innerhalb dieser Ausschlussgruppe kann immer nur ein Optionsfeld ausgewählt sein.
Sie können mit einer Ausschlussgruppe wie mit einem einzelnen Objekt arbeiten. Einige Optionen in der Palette „Objekt“ gelten für alle Optionsfelder einer Ausschlussgruppe. Sie können die Optionsfelder zwischen Ausschlussgruppen verschieben und neue Ausschlussgruppen erstellen. Wenn mehrere Optionsfelder zu derselben Ausschlussgruppe gehören, können Sie einige Objekte auf einfache Weise zu einer anderen Ausschlussgruppe zusammenfassen.
Wenn Sie dem Formular ein neues Optionsfeld hinzufügen und das letzte hinzugefügte Objekt auch ein Optionsfeld war, wird das neue Feld automatisch derselben Ausschlussgruppe zugeordnet. Wenn das letzte hinzugefügte Objekt kein Optionsfeld war, wird eine neue Ausschlussgruppe für das Optionsfeld erstellt.
Die Ausschlussgruppen ändern automatisch ihre Größe, so dass sie alle Optionsfelder in der Gruppe enthalten. Wenn Sie ein Optionsfeld in einen leeren Seitenbereich ziehen, vergrößert sich die Ausschlussgruppe, so dass sie das Optionsfeld umfasst. Wenn Sie die Größe der Ausschlussgruppe manuell ändern, wird auch die Größe aller enthaltenen Optionsfelder entsprechend angepasst.
Verwandte Themen
Beschriftungen formatieren
So machen Sie Optionsfelder barrierefrei
Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“
Eigenschaften von Optionsfeldern: Registerkarte „Feld“
Eigenschaften von Optionsfeldern: Registerkarte „Wert“
Eigenschaften von Optionsfeldern: Registerkarte „Bindung“


So legen Sie die Größe für ein Optionsfeld fest

1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
2.
Geben Sie im Feld „Größe“ einen anderen Wert (in Punkt) ein und drücken Sie die Eingabetaste.
Je nach der eingegebenen Größe müssen Sie die Größe des Optionsfeldes gegebenenfalls anpassen.
Verwandte Themen
Eigenschaften von Optionsfeldern: Registerkarte „Feld“


So legen Sie den Stil für ein Optionsfeld fest

1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
2.
Wählen Sie in der Liste „Schaltflächenstil“ eine Option aus:
      •
      Um den Schaltflächenstil auf den Standardwert (ausgefüllter Kreis) festzulegen, wählen Sie „Standard“ aus.
      •
      Um den Schaltflächenstil auf ein Häkchen festzulegen, wählen Sie „Häkchen“ aus.
      •
      Um den Schaltflächenstil auf einen Kreis festzulegen, wählen Sie „Kreis“ aus.
      •
      Um den Schaltflächenstil auf ein Kreuz festzulegen, wählen Sie „Kreuz“ aus.
      •
      Um den Schaltflächenstil auf ein Karo festzulegen, wählen Sie „Karo“ aus.
      •
      Um den Schaltflächenstil auf ein Quadrat festzulegen, wählen Sie „Quadrat“ aus.
      •
      Um den Schaltflächenstil auf einen Stern festzulegen, wählen Sie „Stern“ aus.
Verwandte Themen
Eigenschaften von Optionsfeldern: Registerkarte „Feld“


So weisen Sie Optionsfeldern „An“-Werte zu

Jedes Optionsfeld in einer Ausschlussgruppe ist mit einem „An“-Wert verknüpft, der das ausgewählte Optionsfeld in den Formulardaten repräsentiert. Sie können diese Werte ändern, so dass sie zum Beispiel vorhandenen Werten in einer Datenquelle entsprechen.
Die Standardwerte beim Festlegen von „An“-Werten sind fortlaufende Ganzzahlen, wobei dem ersten Optionsfeld in der Ausschlussgruppe, das dem Formular hinzugefügt wird, „1“ zugewiesen ist. Wenn Sie die Option „Elementwerte festlegen“ deaktivieren, entsprechen die „An“-Werte dem Beschriftungstext des Optionsfeldes.
1.
Wählen Sie die Ausschlussgruppe oder eines der Optionsfelder innerhalb der Gruppe aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und wählen Sie „Elementwerte festlegen“ aus.
3.
Doppelklicken Sie auf den ersten „An“-Wert, den Sie ändern möchten.
4.
Geben Sie den neuen „An“-Wert ein.
5.
Drücken Sie die Eingabetaste, um den nächsten „An“-Wert zu ändern, oder doppelklicken Sie auf einen anderen „An“-Wert, um diesen zu ändern.
Verwandte Themen
Datenquellen
So definieren Sie benutzerdefinierte Datenbindungseigenschaften für Optionsfelder
Eigenschaften von Optionsfeldern: Registerkarte „Bindung“


So definieren Sie benutzerdefinierte Datenbindungseigenschaften für Optionsfelder

Mit den Bindungsoptionen können Sie ein Formular erstellen, das Daten für die Infrastruktur eines Unternehmens erfasst, und/oder eine externe Datenquelle nutzen, um ein Formular zur Laufzeit auszufüllen. Wählen Sie auf der Registerkarte „Bindung“ der Palette „Objekt“ die Datenbindungseigenschaften für die Optionsfelder aus.
1.
Wählen Sie die Gruppe aus.
2.
Legen Sie für das Formular fest, dass beim Öffnen eine Verbindung zur Datenquelle hergestellt wird.
3.
Binden Sie die Ausschlussgruppe an den entsprechenden Datenknoten. Weitere Informationen zum Binden von Objekten an eine Datenquelle finden Sie unter Info über das Binden von Feldern an eine Datenquelle.
Verwandte Themen
Eigenschaften von Optionsfeldern: Registerkarte „Bindung“
So weisen Sie Optionsfeldern „An“-Werte zu


So erstellen Sie eine neue Ausschlussgruppe

1.
Wählen Sie die Optionsfelder, die Sie einer separaten Ausschlussgruppe zuordnen möchten, im Layout-Editor oder in der Palette „Hierarchie“ aus.
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Klicken Sie im Layout-Editor mit der rechten Maustaste auf eines der ausgewählten Objekte und wählen Sie „Umbruch in neuer Optionsfeldgruppe“ aus.
      •
      Klicken Sie in der Palette „Hierarchie“ mit der rechten Maustaste auf eines der ausgewählten Objekte und wählen Sie „Umbruch in neuer Optionsfeldgruppe“ aus.
Fügen Sie, sobald Sie eine Gruppe von Optionsfeldern hinzugefügt haben, ein anderes Objekt zur Seite hinzu. (Fügen Sie beispielsweise ein Textobjekt hinzu.) Jetzt werden alle neuen Optionsfelder, die Sie zum Formularentwurf hinzufügen, in einer neuen Ausschlussgruppe erfasst.


So verschieben Sie ein Optionsfeld in eine andere Ausschlussgruppe

1.
Wählen Sie das Optionsfeld, das Sie in eine andere Ausschlussgruppe verschieben möchten, im Layout-Editor oder in der Palette „Hierarchie“ aus.
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Um das Optionsfeld auf dem Formular zu verschieben, ziehen Sie das Objekt im Layout Editor auf eine Position innerhalb einer anderen Ausschlussgruppe.
      •
      Um Ausschlussgruppen ohne ein Verschieben des Feldes auf der Seite zu ändern, ziehen Sie das Optionsfeld in der Palette „Hierarchie“ in eine andere Ausschlussgruppe.


So verschieben Sie eine Ausschlussgruppe

1.
Wählen Sie die Ausschlussgruppe durch Klicken auf den zugehörigen Rand aus.
2.
Ziehen Sie die Gruppe an eine neue Position auf der Seite. Alle Optionsfelder in der Gruppe werden zusammen verschoben.


So führen Sie Ausschlussgruppen zusammen

1.
Wählen Sie die Ausschlussgruppen durch Klicken auf den zugehörigen Rand aus.
2.
Wählen Sie „Layout“ > „Optionsfeldgruppen zusammenführen“.
Verwandte Themen
Optionsfelder – Übersicht


So definieren Sie das Verhalten der Ausschlussgruppe

1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und wählen Sie in der Liste „Typ“ eine der folgenden Optionen aus:
      •
      Wenn Sie die Benutzer entscheiden lassen möchten, ob sie Daten eingeben möchten oder nicht, wählen Sie die Option „Benutzereingabe - Optional“ aus.
      •
      Wenn Sie die Benutzer zur Dateneingabe auffordern möchten und es sich bei dem Feld um ein empfohlenes Feld handeln soll, wählen Sie die Option „Benutzereingabe - Empfohlen“ aus und geben Sie im Feld „Meldung bei leerem Feld“ eine benutzerdefinierte Meldung ein.
      •
      Wenn Sie die Benutzer zur Dateneingabe auffordern möchten und es sich bei dem Feld um ein erforderliches Feld handeln soll, wählen Sie die Option „Benutzereingabe - Erforderlich“ aus und geben Sie im Feld „Meldung bei leerem Feld“ eine benutzerdefinierte Meldung ein.
      •
      Wenn es sich bei dem Feld um ein schreibgeschütztes Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der über ein angehängtes Skript berechnet und angezeigt wird, wählen Sie die Option „Berechnet - Schreibgeschützt“ aus. Die Benutzer können den berechneten Wert nicht bearbeiten.
      •
      Wenn es sich bei dem Feld um ein editierbares Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der über ein angehängtes Skript berechnet und angezeigt wird, wählen Sie die Option „Berechnet - Benutzer darf überschreiben“ aus. Die Benutzer können den berechneten Wert bearbeiten, wenn im Berechnungsskript eine Verarbeitung der Benutzereingabe vorgesehen ist. Wenn ein Benutzer den berechneten Wert bearbeiten möchte, wird eine Meldung angezeigt, die im Feld „Meldung beim Überschreiben eines Werts“ festgelegt wurde.
      •
      Wenn es sich bei dem Feld um ein schreibgeschütztes Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der zur Laufzeit zusammengeführt oder berechnet und angezeigt wird, wählen Sie die Option „Schreibgeschützt“ aus. Die Benutzer können den Wert nicht bearbeiten.
2.
Wenn der Wert empfohlen oder erforderlich ist, geben Sie in das Feld „Meldung bei leerem Feld“ eine Eingabeaufforderung ein.
3.
Wenn der Wert zur Laufzeit berechnet werden soll, weisen Sie dem Objekt mit Hilfe des Skript-Editors ein Berechnungsskript zu.
4.
(Optional) Wenn ein berechneter Wert überschrieben werden darf, können Sie eine Meldung in das Feld „Meldung beim Überschreiben eines Werts“ eingeben.
Verwandte Themen
Eigenschaften von Optionsfeldern: Registerkarte „Wert“


So legen Sie die Standardauswahl für die Ausschlussgruppe fest

1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“.
2.
Wählen Sie in der Liste „Standard“ den Wert aus, der das Optionsfeld identifiziert, das den Status „An“ haben soll.
Die Liste „Standard“ steht nur zur Verfügung, wenn im Feld „Typ“ die Einstellung „Benutzereingabe“ oder „Schreibgeschützt“ ausgewählt wurde. Der Wert für den „An“-Status des Optionsfeldes kann auf der Registerkarte „Bindung“ geändert werden.
Verwandte Themen
Eigenschaften von Optionsfeldern: Registerkarte „Wert“


Zurück Weiter

LiveCycle Designer verwenden > Mit Objekten arbeiten > Objekte verwenden > Dokumentunterschriftsfelder verwenden

Dokumentunterschriftsfelder verwenden

Dokumentunterschriftsfelder – Übersicht


Dokumentunterschriftsfelder – Übersicht

Wenn Sie die Identität eines Benutzers und den Inhalt des Dokuments authentifizieren möchten, fügen Sie dem Formular ein Dokumentunterschriftsfeld hinzu. Eine digitale Unterschrift speichert Informationen zum Unterzeichner sowie zum Status des Dokuments zu dem Zeitpunkt, zu dem es unterschrieben wird. Adobe-Dokumentunterschriften unterstützen den Public Key Cryptography Standard (PKCS) #7 und verwenden die Hashalgorithmen RSA MD5, RSA SHA-1 oder DSA SHA-1.
Sie können angeben, ob sich eine Dokumentunterschrift auf ein ganzes Formular oder auf eine Sammlung von Objekten in einem Formular bezieht. Wenn sich die Dokumentunterschrift auf eine Sammlung von Objekten beziehen soll, muss der Unterzeichner Acrobat oder Adobe Reader Version 8.0 oder höher verwenden.
Wenn sich die Unterschrift auf eine Sammlung von Objekten bezieht, sind die Felder gesperrt und können nach dem Unterschreiben des Dokuments nicht mehr geändert werden. Die Sperre wird vererbt. Wenn beispielsweise ein Teilformular gesperrt ist, wird die Sperre an alle Objekte im Teilformular vererbt.
Um das Formular zu unterzeichnen, muss der Benutzer nur auf das Dokumentunterschriftsfeld klicken. Weitere Informationen zum Unterschreiben von PDF-Formularen in Acrobat finden Sie in der Acrobat-Hilfe.
Allerdings erzeugt das Dokumentunterschriftsfeld die digitale Unterschrift nicht direkt. Es ruft mithilfe von Skripten den Unterschriften-Handler eines Drittanbieters auf, der die erforderliche Funktionalität für die digitale Unterschrift zur Verfügung stellt. Ohne einen geeigneten Unterschriften-Handler können Benutzer keine Formulare unterzeichnen.
Bei Bedarf können Sie das Dokumentunterschriftsfeld in der Palette „Hierarchie“ umbenennen, nachdem Sie es zum Formularentwurf hinzugefügt haben.
Nach dem Hinzufügen eines Dokumentunterschriftsfeldes zum Formularentwurf können Sie die Eigenschaften der Unterschrift auf der Registerkarte „Dokumentunterschrift“ der Palette „Objekt“ definieren. Sie können festlegen, ob sich die Unterschrift auf das ganze Formular oder auf eine Sammlung von Feldobjekten bezieht, und Sie können Standardeigenschaften für Unterschriften festlegen.
Sie können den Beschriftungstext bearbeiten und die Objekteigenschaften in der Registerkarte „Feld“ der Palette „Objekt“ ändern. Sie können die folgenden Eigenschaften festlegen:
      •
      Ändern der Beschriftung für das Feld (Siehe So benennen Sie eine Beschriftung um)
      •
      Festlegen eines Randstils für das Feld (Siehe So legen Sie den Randstil fest)
      •
      Definieren des Feldes als sichtbar, unsichtbar oder ausgeblendet (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Festlegen einer Sprache für das Feld (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
Verwandte Themen
Beschriftungen formatieren
Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“
Dokumentunterschriftsfelder
Digitale Unterschriften


Text verwenden

Text – Übersicht
So geben Sie Zeichen in ein Textobjekt ein
So fügen Sie ein schwebendes Textfeld in ein Textobjekt ein
So fügen Sie den Wert einer Laufzeiteigenschaft in ein Textobjekt ein
So führen Sie Textobjekte zusammen
So erstellen Sie eine Beschriftung durch Zusammenführen eines Text- und eines Feldobjekts
So fügen Sie sprachspezifische Zahlen in Text oder Beschriftungen ein


Text – Übersicht

Textobjekte enthalten schreibgeschützten Text, der nicht geändert werden kann. Sie können Textobjekte für folgende Zwecke nutzen:
      •
      Beschriften eines Formularbereichs
      •
      Anweisungen zum Ausfüllen des Formulars zur Verfügung stellen
      •
      Hinzufügen einer Kopf- und Fußzeile
Wenn Sie ein Textobjekt zum Formularentwurf hinzugefügt haben, können Sie folgende Eigenschaften definieren:
      •
      Definieren des Textes als sichtbar, unsichtbar oder ausgeblendet (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Festlegen einer Sprache für den Text (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Eingeben von Text und Festlegen eines Stils
      •
      Bearbeiten der Eigenschaften der Schriftart oder bestimmter Teile des Textes
Außerdem können Sie Platzhalter, wie z. B. schwebende Textfelder, und die Werte von Laufzeiteigenschaften, wie z. B. Anzahl der Seiten, aktuelle Seite sowie aktuelles Datum/Uhrzeit, in Textobjekte einfügen.
Beachten Sie, dass beim Textobjekt standardmäßig beide Optionen von „Passend erweitern“ ausgewählt sind, so dass die Größe des Objekts in der Entwurfsphase automatisch angepasst wird, um den von Ihnen eingegebenen Text und die von Ihnen geänderten Eigenschaftseinstellungen, wie z. B. Ränder, Begrenzungen, Schrifttyp und -größe unterzubringen.
Verwandte Themen
Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“
Schrift-Eigenschaften in der Palette „Schrift“
Absatz-Eigenschaften in der Palette „Absatz“
Eigenschaften von Text: Registerkarte „Zeichnen“


So geben Sie Zeichen in ein Textobjekt ein

Sie können Zeichen in das Objekt eingeben, nachdem Sie es zum Formular hinzugefügt haben.
Die Option „Objekte mit fester Größe beim Bearbeiten automatisch einpassen“ im Bereich „Arbeitsbereich“ im Dialogfeld „Extras“ > „Optionen“ ist standardmäßig aktiviert. Mit dieser Option werd die Breite und die Höhe von Textobjekten beim Eingeben von Zeichen angepasst. Damit nur entweder die Breite oder die Höhe eines Textobjekts angepasst wird, deaktivieren Sie die Option „Objekte mit fester Größe beim Bearbeiten automatisch einpassen“ und aktivieren Sie dann die entsprechende Option „Passend erweitern“ in der Palette „Layout“.
1.
Wählen Sie „Bearbeiten“ aus und stellen Sie sicher, dass die Befehle „Text sperren“ und „Statische Objekte sperren“ nicht ausgewählt sind.
2.
Doppelklicken Sie auf das Textobjekt und geben Sie die gewünschten Zeichen ein.
Verwandte Themen
So können Sie Objekte passend erweitern
Layout-Eigenschaften in der Palette „Layout“


So fügen Sie ein schwebendes Textfeld in ein Textobjekt ein

Sie können ein schwebendes Textfeld in ein Textobjekt einfügen. Schwebende Textfelder unterstützen das Zusammenführen verschiedener Textwerte innerhalb der Textobjekte. So können Sie beispielsweise ein schwebendes Textfeld einbetten, um in der Anrede eines Formularbriefes den Namen eines Kunden zu implementieren.
Ein schwebendes Textfeld hat keine Objektbeschreibung und kann so bearbeitet werden, als wäre es ein einzelnes Textzeichen. Die Eigenschaften des schwebenden Textfeldes müssen gesondert und zusätzlich zu den Eigenschaften des Textobjekts definiert werden.
1.
Platzieren Sie den Cursor an der Stelle im Textobjekt, an der das schwebende Textfeld eingefügt werden soll.
2.
Wählen Sie „Einfügen“ > „Feld in Fließtext“.
3.
Wählen Sie das gewünschte schwebende Textfeld aus und bearbeiten Sie die zugehörigen Eigenschaften.
Verwandte Themen
Textfelder – Übersicht


So fügen Sie den Wert einer Laufzeiteigenschaft in ein Textobjekt ein

Sie können die Werte von Laufzeiteigenschaften in ein Textobjekt einfügen. Beim Anzeigen des Formulars wird der aktuelle Wert automatisch eingefügt.
Der eingefügte Wert kann eine andere Schrift, Schriftgröße und einen anderen Schriftstil aufweisen als das Textobjekt.
1.
Platzieren Sie den Cursor an der Stelle im Textobjekt, an der der Wert der Laufzeiteigenschaft eingefügt werden soll.
2.
Wählen Sie „Einfügen“ > [Wert der Laufzeiteigenschaft].
      •
      Wenn Sie die aktuelle Seitenzahl des fertigen Formulars einfügen möchten, wählen Sie „Aktuelle Seitenzahl“ aus.
      •
      Wenn Sie die Gesamtanzahl der Seiten einfügen möchten, aus denen das fertige Formular besteht, wählen Sie „Anzahl der Seiten“ aus.
      •
      Wenn Sie das aktuelle Datum und/oder die aktuelle Uhrzeit einfügen möchten, wählen Sie „Aktuelles Datum/Uhrzeit“ aus.
      •
      Wenn Sie den Wert der Spracheinstellung für die Anwendung einfügen möchten, die das Formular verarbeitet, wählen Sie „Gebietsschema für Viewer“ aus.
      •
      Wenn Sie den Namen der Anwendung einfügen möchten, die das Formular verarbeitet, wählen Sie „Name des Anzeigeprogramms“ aus.
      •
      Wenn Sie die Versionsnummer der Anwendung einfügen möchten, die das Formular verarbeitet, wählen Sie „Version des Anzeigeprogramms“ aus.
3.
Wählen Sie den Wert der Laufzeiteigenschaft aus und bearbeiten Sie die zugehörigen Eigenschaften.
Verwandte Themen
Datums-/Uhrzeitfelder – Übersicht
Numerische Felder – Übersicht
Textfelder – Übersicht
Schrift-Eigenschaften in der Palette „Schrift“
Absatz-Eigenschaften in der Palette „Absatz“


So führen Sie Textobjekte zusammen

Wenn Sie eine PDF-Datei in LiveCycle Designer importieren, werden der Titel und der Anweisungstext je nach gewählten Importoptionen unter Umständen auf mehrere Textobjekte aufgeteilt. Dieser Vorgang führt zu einer erschwerten Bearbeitung des Textes, da sich einzelne Wörter oder Buchstaben unter Umständen in separaten Textobjekten befinden. Wenn Sie den Text bearbeiten möchten, können Sie die Textobjekte zusammenführen, um die Aktualisierung des Textes zu vereinfachen.
1.
Wählen Sie die Textobjekte aus, die Sie zusammenführen möchten.
Wenn Sie zusätzlich ein Objekt eines anderen Typs auswählen, wird dieses nicht in das zusammengeführte Objekt einbezogen.
2.
Wählen Sie „Layout“ > „Ausgewählte Textobjekte zusammenführen“.
Alle ausgewählten Textobjekte werden zu einem Textobjekt zusammengefasst.
Verwandte Themen
So erstellen Sie eine Beschriftung durch Zusammenführen eines Text- und eines Feldobjekts


So erstellen Sie eine Beschriftung durch Zusammenführen eines Text- und eines Feldobjekts

Sie können für ein Feldobjekt, das keine Beschriftung hat, eine Beschriftung erstellen, indem Sie es mit einem Textobjekt zusammenführen.
Sie können z. B. ein Textobjekt mit einem Textfeld zusammenführen, für das als Beschriftung „Ohne“ festgelegt wurde, und so ein einziges Feld erstellen. Der Text aus dem Textobjekt wird als Beschriftung für das Textfeld verwendet.
Bevor Sie diese Aufgabe ausführen, müssen Sie Folgendes sicherstellen:
      •
      Stellen Sie sicher, dass ein Textobjekt vorhanden ist.
      •
      Stellen Sie sicher, dass ein Feldobjekt vorhanden ist, für das in der Palette „Layout“ die Beschriftungsoption „Ohne“ festgelegt wurde bzw. dessen Beschriftung leer ist.
Das Feldobjekt kann eines der folgenden Objekte sein:
      •
      Kontrollkästchen
      •
      Datums-/Uhrzeitfeld
      •
      Dezimalfeld
      •
      Dokumentunterschriftsfeld
      •
      Dropdown-Liste
      •
      Bildfeld
      •
      Listenfeld
      •
      Numerisches Feld
      •
      Kennwortfeld
      •
      Optionsfeld
      •
      Textfeld
Sie können nur ein Textobjekt mit einem Feldobjekt zusammenführen.
1.
Wählen Sie das Textobjekt aus, das als Beschriftung für das Feldobjekt verwendet werden soll.
2.
Klicken Sie bei gedrückter Steuerungs- oder Umschalttaste, um das Feldobjekt auszuwählen, das mit dem Textobjekt zusammengeführt werden soll.
Für das Feldobjekt muss in der Palette „Layout“ die Beschriftungsoption „Ohne“ festgelegt sein bzw. die Beschriftung muss leer sein.
3.
Wählen Sie „Layout“ > „Als Beschriftung zusammenführen“.
Als Beschriftung für das neue Objekt wird der Text des Textobjekts verwendet. Die Größe und Position des neuen Objekts entsprechen der Gesamtumrandung der zusammengeführten Objekte.
Nach der Zusammenführung der Objekte müssen Sie u. U. die Schrift für die Beschriftung und den Wert bearbeiten.
Verwandte Themen
So führen Sie Textobjekte zusammen
Beschriftungen formatieren
So positionieren Sie eine Beschriftung


So fügen Sie sprachspezifische Zahlen in Text oder Beschriftungen ein

In den meisten Regionen der Welt wird das so genannte römische Zahlensystem (1, 2, 3 ...) verwendet. Das arabische Zahlensystem ist jedoch anders. Es leitet sich aus indischen Zahlen ab.
Arabische Buchstaben werden zwar von rechts nach links geschrieben, arabische Zahlen jedoch von links nach rechts. Dieses Zahlensystem wird häufig als indisch-arabisches Zahlensystem bezeichnet.
Sofern das gewählte Gebietsschema – z. B. Arabisch (Ägypten) – dies zulässt, können Sie auch sprachspezifische Zahlen in Text oder in Beschriftungen einfügen. Die folgenden Gebietsschemata unterstützen diese Funktion:
      •
      Arabisch (alle außer Algerien, Marokko und Tunesien)
      •
      Thailändisch (Thailand, traditionell)
Die in diesem Hilfethema beschriebenen Funktionen sind nur verfügbar, wenn die Unterstützung für die entsprechenden Sprachen in den Microsoft Office-Spracheinstellungen aktiviert wurde.
1.
Wählen Sie den Text aus.
2.
Klicken Sie mit der rechten Maustaste und stellen Sie sicher, dass der sprachspezifische Befehl „Ziffern verwenden“ aktiviert ist.
Wenn dieses Menüelement nicht vorhanden ist, müssen Sie überprüfen, ob das für dieses Objekt festgelegte Gebietsschema diese Funktion unterstützt.
3.
Geben Sie die Zahlen ein.
Unten sehen Sie ein Beispiel für eine Beschriftung, die drei Arten sprachspezifischer Zahlen aufweist.
LiveCycle Forms 7.1 bietet keine Unterstützung für Formularentwürfe mit arabischen, hebräischen, thailändischen und vietnamesischen Schriftzeichen.


Textfelder verwenden

Textfelder – Übersicht
So können Sie mehrere Textzeilen in Textfeldern zulassen
So begrenzen Sie die Anzahl der Zeichen in Textfeldern
So lassen Sie die Eingabe von RTF-Text im Feld zu
So definieren Sie das Verhalten des Feldes
So definieren Sie benutzerdefinierte Datenbindungseigenschaften für Textfelder
So legen Sie das Datenformat für Textfelder fest
So legen Sie das Zeichenformat für Textfelder fest


Textfelder – Übersicht

Wenn Sie den Benutzern die Eingabe von Textdaten ermöglichen möchten, fügen Sie dem Formular Textfelder hinzu. In Textfeldern können die Benutzer beliebigen Text eingeben, auswählen, bearbeiten, ausschneiden, kopieren, einfügen oder löschen.
Textfelder können mehrere Zeilen Text enthalten und Text umbrechen und unterstützen erweiterte Formatierungsfunktionen. Zum Beispiel können verschiedene Textblöcke in unterschiedlichen Schriften und Schriftfarben angezeigt werden. Text kann als einfacher Text oder im XHTML-Format gespeichert und abgerufen werden. Die Daten in einem Textfeld können mit Hilfe von vordefinierten Mustern formatiert und angezeigt werden.
Nachdem Sie ein Textfeld zum Formularentwurf hinzugefügt haben, können Sie den Beschriftungstext bearbeiten und die Eigenschaften des Objekts in der Palette „Objekt“ auf den Registerkarten „Feld“, „Wert“ und „Bindung“ ändern. Sie können die folgenden Eigenschaften festlegen:
      •
      Ändern der Beschriftung für das Feld (Siehe So benennen Sie eine Beschriftung um)
      •
      Festlegen eines Randstils für das Feld (Siehe So legen Sie den Randstil fest)
      •
      Definieren des Feldes als sichtbar, unsichtbar oder ausgeblendet (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Festlegen einer Sprache für das Feld (Siehe So legen Sie ein Gebietsschema (Sprache und Land) für ein Objekt fest)
      •
      Festlegen des Zeichenformats für das Feld (Siehe So legen Sie das Zeichenformat für Textfelder fest)
      •
      Zulassen oder Ausschließen mehrerer Textzeilen
      •
      Zulassen oder Ausschließen der Eingabe von Text im Rich-Text-Format
      •
      Begrenzen der Anzahl der Zeichen im Feld
      •
      Definieren des Anzeigemusters
      •
      Definieren von Bearbeitungsmustern
      •
      Bestimmen des anzuzeigenden Ausgangswertes
      •
      Definieren von Laufzeiteigenschaften (z. B. Einfügen der Seitenzahl)
      •
      Definieren von Überprüfungsmustern
      •
      Bestimmen, ob das Feld einfachen Text oder XHTML unterstützt
      •
      Definieren von Datenbindungsmustern
      •
      Festlegen einer Bindungsmethode zum Speichern und Abrufen gebundener Daten
Textfelder unterstützen Skripten und Berechnungen. Wenn ein Benutzer Daten bereitstellen soll, können Sie bestimmen, ob die Eingabe empfohlen oder erforderlich ist, und Sie können entsprechende Meldungen erstellen, die den Benutzer zur Dateneingabe auffordern. Alle Benutzereingaben können mit Hilfe von Skripten überprüft werden.
Verwandte Themen
Beschriftungen formatieren
So sperren Sie Objekte
Info über Feldmuster und Wertformatierung
Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“
Textfeldmuster
Eigenschaften von Textfeldern: Registerkarte „Feld“
Eigenschaften von Textfeldern: Registerkarte „Wert“
Eigenschaften von Textfeldern: Registerkarte „Bindung“


So können Sie mehrere Textzeilen in Textfeldern zulassen

      *
      Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie „Mehrere Zeilen zulassen“ aus.
Verwandte Themen
Eigenschaften von Textfeldern: Registerkarte „Feld“


So begrenzen Sie die Anzahl der Zeichen in Textfeldern

Sie haben zwei Möglichkeiten, um die Anzahl der Zeichen in Textfeldern zu begrenzen:
      •
      Sie können die maximal zulässige Anzahl von Zeichen festlegen.
      •
      Sie können für LiveCycle Designer die Verwendung der horizontalen Länge des Textfeldes zur Bestimmung der zulässigen Anzahl von Zeichen festlegen.
So legen Sie die Anzahl von Zeichen in Textfeldern fest
1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
2.
Aktivieren Sie die Option „Länge begrenzen“ und geben Sie im Feld „Max. Zeichen“ die maximale Anzahl der Zeichen ein, die Benutzer in das Textfeld eingeben dürfen.
So begrenzen Sie die Anzahl der Zeichen auf die Breite von Textfeldern
      *
      Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie „Länge auf sichtbaren Bereich beschränken“ aus.
Verwandte Themen
Eigenschaften von Textfeldern: Registerkarte „Feld“


So lassen Sie die Eingabe von RTF-Text im Feld zu

Standardmäßig ist ein Textfeld so eingestellt, dass normaler Text angezeigt und erfasst wird. Wenn der mit dem Textfeld verknüpfte Datenwert formatiert ist, wird die Formatierung ignoriert und der Datenwert als einfacher Text dargestellt. Sie können das Textfeld so einstellen, dass die RTF-Formatierung der Daten erhalten bleibt.
1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und wählen Sie in der Liste „Feldformat“ die Option „Rich Text“ aus.
2.
Wählen Sie auf der Registerkarte „Bindung“ in der Liste „Datenformat“ die Option „XHTML“ aus.
Verwandte Themen
Eigenschaften von Textfeldern: Registerkarte „Feld“


So definieren Sie das Verhalten des Feldes

1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und wählen Sie in der Liste „Typ“ eine der folgenden Optionen aus:
      •
      Wenn Sie die Benutzer entscheiden lassen möchten, ob sie Daten eingeben möchten oder nicht, wählen Sie die Option „Benutzereingabe - Optional“ aus.
      •
      Wenn Sie die Benutzer zur Dateneingabe auffordern möchten und es sich bei dem Feld um ein empfohlenes Feld handeln soll, wählen Sie die Option „Benutzereingabe - Empfohlen“ aus und geben Sie im Feld „Meldung bei leerem Feld“ eine benutzerdefinierte Meldung ein.
      •
      Wenn Sie die Benutzer zur Dateneingabe auffordern möchten und es sich bei dem Feld um ein erforderliches Feld handeln soll, wählen Sie die Option „Benutzereingabe - Erforderlich“ aus und geben Sie im Feld „Meldung bei leerem Feld“ eine benutzerdefinierte Meldung ein.
      •
      Wenn es sich bei dem Feld um ein schreibgeschütztes Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der über ein angehängtes Skript berechnet und angezeigt wird, wählen Sie die Option „Berechnet - Schreibgeschützt“ aus. Die Benutzer können den berechneten Wert nicht bearbeiten.
      •
      Wenn es sich bei dem Feld um ein editierbares Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der über ein angehängtes Skript berechnet und angezeigt wird, wählen Sie die Option „Berechnet - Benutzer darf überschreiben“ aus. Die Benutzer können den berechneten Wert bearbeiten, wenn im Berechnungsskript eine Verarbeitung der Benutzereingabe vorgesehen ist. Wenn ein Benutzer den berechneten Wert bearbeiten möchte, wird eine Meldung angezeigt, die im Feld „Meldung beim Überschreiben eines Werts“ festgelegt wurde.
      •
      Wenn es sich bei dem Feld um ein schreibgeschütztes Feld handeln soll und Sie darin einen Datenwert anzeigen möchten, der zur Laufzeit zusammengeführt oder berechnet und angezeigt wird, wählen Sie die Option „Schreibgeschützt“ aus. Die Benutzer können den Wert nicht bearbeiten.
2.
Wenn der Wert empfohlen oder erforderlich ist, geben Sie in das Feld „Meldung bei leerem Feld“ eine Eingabeaufforderung ein.
3.
Wenn der Wert zur Laufzeit berechnet werden soll, weisen Sie dem Objekt mit Hilfe des Skript-Editors ein Berechnungsskript zu.
4.
(Optional) Wenn ein berechneter Wert überschrieben werden darf, können Sie eine Meldung in das Feld „Meldung beim Überschreiben eines Werts“ eingeben.
Verwandte Themen
So legen Sie einen Standardwert fest
So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus
So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus
Eigenschaften von Textfeldern: Registerkarte „Wert“


So definieren Sie benutzerdefinierte Datenbindungseigenschaften für Textfelder

Mit den Bindungsoptionen können Sie ein Formular erstellen, das Daten für die Infrastruktur eines Unternehmens erfasst, und/oder eine externe Datenquelle nutzen, um ein Formular zur Laufzeit auszufüllen. Die Datenbindungseigenschaften werden auf der Registerkarte „Bindung“ der Palette „Objekt“ festgelegt.
1.
Wählen Sie das Textfeld aus.
2.
Legen Sie für das Formular fest, dass beim Öffnen eine Verbindung zur Datenquelle hergestellt wird.
3.
Binden Sie das Feld an den entsprechenden Datenknoten. Weitere Informationen zum Binden von Objekten an eine Datenquelle finden Sie unter Info über das Binden von Feldern an eine Datenquelle.
Verwandte Themen
Eigenschaften von Textfeldern: Registerkarte „Bindung“


So legen Sie das Datenformat für Textfelder fest

In Textfeldern können Daten nur als normaler Text oder als Text mit XHTML-Textformatierungsinformationen als Teil des Wertes gespeichert werden. Die Standardeinstellung ist normaler Text. Wenn Sie das Datenformat in „XHTML“ ändern, wird die Option „Rich Text“ in der Liste „Feldformat“ auf der Registerkarte „Feld“ der Palette „Objekt“ automatisch aktiviert.
1.
Wählen Sie das Textfeldobjekt aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“.
3.
Wählen Sie in der Datenformatliste das geeignete Format aus.
Verwandte Themen
So definieren Sie benutzerdefinierte Datenbindungseigenschaften für Textfelder
Eigenschaften von Textfeldern: Registerkarte „Bindung“


So legen Sie das Zeichenformat für Textfelder fest

Mit dem Zeichenformat können Sie die Zeichen und Zahlen, die zu Textfeldern hinzugefügt werden, durch Begrenzungslinien trennen.
1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
2.
Wählen Sie „Zeichenanzahl in Textfeld“ aus, um die einzelnen Zeichen im Textfeld durch Begrenzungslinien voneinander zu trennen.
3.
Geben Sie die Anzahl von Zeichen ein, die im Textfeld durch Begrenzungslinien voneinander getrennt werden.
Verwandte Themen
Textfelder – Übersicht
Eigenschaften von Textfeldern: Registerkarte „Feld“


Zurück Weiter

LiveCycle Designer verwenden > Mit Objekten arbeiten > Objekte verwenden > Benutzerdefinierte Objekte verwenden

Benutzerdefinierte Objekte verwenden

Info über benutzerdefinierte Objekte
So erstellen Sie ein benutzerdefiniertes Objekt


Info über benutzerdefinierte Objekte

Zusätzlich zu den Objekten in der Kategorie „Standard“ der Palette „Bibliothek“ enthält LiveCycle Designer einige vordefinierte eigene Objekte, die die benötigte Funktionalität bieten, auf die Formularverfasser bei einer Formularlösung häufig zurückgreifen. Diese benutzerdefinierten Objekte verfügen über Eigenschaften und Skripten, die an Ihre Anforderungen angepasst werden können.
Die folgenden vordefinierten benutzerdefinierten Objekte befinden sich in der Kategorie „Eigene“ der Palette „Bibliothek“.

Objekt

Beschreibung
Adobe Workflow Server-Felder
Ein Block von Objekten, der für Workflow Server-Formulare eingerichtet wurde. Er beinhaltet eine Senden-Schaltfläche, eine Dropdown-Liste für Aktionen sowie andere unsichtbare Felder. Letztere dienen dem Transport von Daten für den Workflow Server, damit die Formulardaten ordnungsgemäß elektronisch weitergeleitet werden können.
Adressblock
Akzeptiert Adressen und zeigt sie im Format des US Postal Service an. Der Adressblock ist eine Gruppe von Textfeldern, in denen Benutzer ihren Namen, Adresse, Stadt, Staat, Postleitzahl und Land eingeben können.
Mit jedem Formulartyp kompatibel.
Aktuelles Datum
Ein Datum-/Uhrzeitfeld mit einem Skript, welches das aktuelle Datum entsprechend dem Systemgebietsschema des Betrachters darstellt.
Mit jedem Formulartyp kompatibel.
Blatt n von m
Zeigt ein Textobjekt an, das den Wert des aktuellen Blatt Papiers innerhalb des für ein Formular erforderlichen Blattbereichs angibt.
Beispiel: Blatt 1 von 5
Für jeden Formulartyp.
Daten-Dropdown-Liste
Eine Dropdown-Liste mit einem Skript, das die Liste aus einer OLEDB-Datenquelle ausfüllt.
Für interaktive Formulare.
Datenlistenfeld
Ein Listenfeld mit einem Skript, das die Liste aus einer OLEDB-Datenquelle ausfüllt.
Für interaktive Formulare.
E-Mail-Adresse
Ein Textfeld, das eine E-Mail-Adresse erfasst und überprüft.
Für interaktive Formulare.
Länder
Zeigt eine Dropdown-Liste an, die mit Ländernamen gefüllt ist. Sie können jedes Land hinzufügen, verschieben oder aus der Liste löschen.
Für interaktive Formulare.
Name
Eine Gruppe von Textobjekten, die Namensinformationen akzeptiert und darstellt. Endbenutzer können ihren Nachnamen, ihren Vornamen und ihre Initialen eingeben.
Für jeden Formulartyp.
Seite n von m
Ein Textfeld mit einem Skript, das die aktuelle Seite und die Gesamtzahl der Seiten eines Formulars zur Laufzeit darstellt.
Beispiel: Seite 1 von 30
Für jeden Formulartyp.
Seiten-Navigation
Eine Gruppe von Schaltflächen mit Skripten, um zur ersten, letzen, vorherigen oder nächsten Seite zu blättern.
Für interaktive Formulare.
Sozialversicherungsnummer in den USA
Ein Textfeld, in dem der Benutzer eine Sozialversicherungsnummer für die USA eingeben kann.
Für interaktive Formulare.
Telefonnummer - International
Ein Textfeld, das eine Texteingabe als internationale Telefonnummer formatiert.
Für interaktive Formulare.
Telefonnummer - Nordamerika
Ein Textfeld, das eine Texteingabe als nordamerikanische Telefonnummer formatiert.
Für interaktive Formulare.
Umfrage-Frage
Ein statisches Textobjekt für eine Umfrage sowie eine Gruppe von Optionsfeldern, um die Antwort auszuwählen.
Für interaktive Formulare.
Unterschrift - Drucken und Unterzeichnen
Zeigt einen Leerraum auf einem gedruckten Formular an. An dieser Stelle kann ein Benutzer unterschreiben.
Für Druckformulare.
US-Staaten
Zeigt eine Dropdown-Liste an, die mit Namen von US-Bundesstaaten ausgefüllt ist. Sie können jeden Staat hinzufügen, verschieben oder aus der Liste löschen.
Für interaktive Formulare.
Die meisten benutzerdefinierten Objekte können direkt verwendet werden und bedürfen nur kleiner Änderungen. So können Sie Ihren Bedürfnissen entsprechend Beschriftungen ändern, Zahlen formatieren oder die Schrift ändern. Ziehen Sie einfach das benutzerdefinierte Objekt in den Formularentwurf und nehmen Sie die Änderungen vor. Wenn Sie ein benutzerdefiniertes Objekt in den Formularentwurf ziehen, wird es auch in der Palette „Hierarchie“ angezeigt. Bei benutzerdefinierten Objekten, die aus mehreren Standardobjekten bestehen, die auf eine bestimmte Art formatiert und gruppiert sind (z. B. das Objekt „Adressblock“), werden die einzelnen Textfeldobjekte (Name, Adresse, Ort, Staat, Postleitzahl und Land) in der Palette „Hierarchie“ angezeigt.
Die beiden Objekte „Daten-Dropdown-Liste“ und „Datenlistenfeld“ bestehen aus einem einzigen Objekt, dem ein benutzerdefiniertes Skript zugeordnet ist. Dieses Skript können Sie zum Ausfüllen von zwei Datenspalten von einer OLEDB-Datenverbindung verwenden. Wenn Sie das Objekt im Formularentwurf platzieren, wird das Skript im Skript-Editor angezeigt. Das Skript enthält Kommentare, denen Sie entnehmen können, welche Änderungen vorgenommen werden müssen, damit das Skript mit Ihrer jeweiligen Laufzeitumgebung kompatibel ist. Weitere Informationen finden Sie unter So füllen Sie eine Dropdown-Liste oder ein Listenfeld über eine OLEDB-Datenverbindung dynamisch aus.
Das Objekt „Adobe Workflow Server-Felder“ ist ausschließlich für die Verwendung mit Workflow Server vorgesehen.
Verwandte Themen
So erstellen Sie ein benutzerdefiniertes Objekt
So fügen Sie einem Formularentwurf Objekte hinzu


So erstellen Sie ein benutzerdefiniertes Objekt

Mit LiveCycle Designer können Sie Ihre eigenen benutzerdefinierten Objekte erstellen, die Sie speichern und stets wieder verwenden können. Beim Erstellen eines benutzerdefinierten Objekts fügen Sie dem Formularentwurf ein oder mehrere Objekte aus der Registerkarte „Standard“ hinzu und legen anschließend die Eigenschaften der Objekte entsprechend Ihren Bedürfnissen fest.
Sie können das Objekt in der Kategorie „Eigene“ der Palette „Bibliothek“ speichern oder eine eigene Kategorie in der Palette „Bibliothek“ erstellen und das Objekt dort speichern. Es empfiehlt sich, eigene Bibliothekskategorien zum Organisieren der von Ihnen erstellten Objekte zu erstellen und sie von den vordefinierten eigenen Objekten, die in LiveCycle Designer enthalten sind, getrennt zu verwalten. Informationen über das Erstellen eigener Kategorien finden Sie unter So fügen Sie der Palette „Bibliothek“ eine Kategorie hinzu.
1.
Ziehen Sie in der Palette „Bibliothek“ das Objekt, das Sie anpassen möchten, in den Formularentwurf.
2.
Definieren Sie die Eigenschaften des Objekts.
3.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Eigene“.
4.
Ziehen Sie das Objekt in die Kategorie „Eigene“ der Palette „Bibliothek“.
5.
Geben Sie im Dialogfeld „Bibliotheksobjekt hinzufügen“ einen Namen und eine Beschreibung für das benutzerdefinierte Objekt ein. Klicken Sie anschließend auf „OK“.
Mehrere Objekte können zusammen als ein einzelnes benutzerdefiniertes Objekt gespeichert werden. Wenn Sie mehrere Objekte zusammen in die Registerkarte „Eigene“ ziehen, wird darin ein einzelnes Objekt erstellt.
Verwandte Themen
Palette „Bibliothek“
Palette „Bibliothek“ verwalten
Objekte, die Skripten und Berechnungen unterstützen
Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“
Schrift-Eigenschaften in der Palette „Schrift“
Absatz-Eigenschaften in der Palette „Absatz“


Objekte hinzufügen, kopieren und löschen

So fügen Sie einem Formularentwurf Objekte hinzu
So können Sie Objekte ausschneiden, kopieren und einfügen
So duplizieren Sie Objekte
So löschen Sie Objekte


So fügen Sie einem Formularentwurf Objekte hinzu

Es gibt mehrere Möglichkeiten, um einem Formularentwurf Objekte hinzuzufügen. Nach dem Hinzufügen eines Objekts können Sie die Eigenschaften für das Objekt definieren.
So fügen Sie ein Objekt über das Menü „Einfügen“ hinzu
      *
      Führen Sie einen der folgenden Schritte aus:
      •
      Wählen Sie „Einfügen“ > „Favoriten“ > [Objekt].
      •
      Wählen Sie „Einfügen“ > „Standard“ > [Objekt].
      •
      Wählen Sie „Einfügen“ > „Barcodes“ > [Objekt].
      •
      Wählen Sie „Einfügen“ > „Eigene“ > [Objekt].
So fügen Sie ein Objekt aus der Palette „Bibliothek“ hinzu
      *
      Führen Sie einen der folgenden Schritte aus:
      •
      Ziehen Sie das Objekt in den Formularentwurf.
      •
      Doppelklicken Sie auf das Objekt.
      •
      Klicken Sie auf das Objekt und ziehen Sie es in den gewünschten Formularentwurf.
So fügen Sie mehrere Objekte des gleichen Typs hinzu
      *
      Führen Sie einen der folgenden Schritte aus:
      •
      Klicken Sie in der Palette „Bibliothek“ auf das Objekt und wählen Sie „Ansicht“ > „Zeichenwerkzeug beibehalten“. Sie können den Befehl „Zeichenwerkzeug beibehalten“ für ein beliebiges Objekt verwenden. Wenn Sie diese Funktion deaktivieren möchten, wählen Sie erneut „Ansicht“ > „Zeichenwerkzeug beibehalten“ oder drücken Sie die Esc-Taste.
      •
      Klicken Sie in der Symbolleiste „Extras“ auf die Schaltfläche „Felder zeichnen“ und wählen Sie anschließend das Objekt in der Dropdown-Liste aus. Die Schaltfläche „Felder zeichnen“ ist nur für die Objekte in der Dropdown-Liste verfügbar. Wenn Sie diese Funktion deaktivieren möchten, klicken Sie in der Symbolleiste „Extras“ auf die Schaltfläche „Auswahl-Werkzeug“ oder „Hand-Werkzeug“.
Wenn diese Befehle ausgewählt sind, können Sie so viele Kopien eines Objekts wie notwendig zeichnen, ohne dieses jedes Mal von neuem in der Palette „Bibliothek“ auswählen zu müssen.


So können Sie Objekte ausschneiden, kopieren und einfügen

Sie können Objekte über das Menü oder über Tastaturbefehle ausschneiden, kopieren und einfügen.
So können Sie ein Objekt ausschneiden und einfügen
1.
Ein oder mehrere Objekte auswählen
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Zum Ausschneiden eines Objekts wählen Sie „Bearbeiten“ > „Ausschneiden“.
      •
      Zum Kopieren eines Objekts wählen Sie „Bearbeiten“ > „Kopieren“.
3.
Wählen Sie „Bearbeiten“ > „Einfügen“.
Wenn sich der Zeiger auf einer Seite befindet, wird das Objekt unterhalb des Zeigers eingefügt. Andernfalls wird das Objekt in der linken oberen Ecke des aktiven Inhaltsbereichs eingefügt.
So kopieren Sie eine Gruppe von Objekten
1.
Wählen Sie in der Palette „Hierarchie“ den gewünschten Gruppenknoten aus.
2.
Wählen Sie „Bearbeiten“ > „Kopieren“.
So erstellen Sie mehrere Kopien von einem oder mehreren Objekten
1.
Wählen Sie ein oder mehrere Objekte im Formularentwurf oder in der Palette „Hierarchie“ aus.
2.
Wählen Sie „Bearbeiten“ > „Mehrere kopieren“.
3.
Geben Sie in das Feld „Anzahl der Exemplare“ eine Anzahl ein. Sie können so viele Kopien anfertigen, wie in den aktiven Inhaltsbereich passen.
4.
Wählen Sie Optionen für „Vertikale Platzierung“ und „Horizontale Platzierung“ aus.
5.
Wenn Sie den vertikalen Abstand zwischen dem kopierten und dem ursprünglichen Objekt vergrößern möchten, wählen Sie im Bereich „Vertikaler Abstand“ die Option „Verschiebung um“ aus und geben Sie in das Feld daneben den Abstand ein.
6.
Wenn Sie den horizontalen Abstand zwischen dem kopierten und dem ursprünglichen Objekt vergrößern möchten, wählen Sie im Bereich „Horizontaler Abstand“ die Option „Verschiebung um“ aus und geben Sie in das Feld daneben den Abstand ein.
7.
Klicken Sie auf „OK“. Die Kopien werden der Seite hinzugefügt, und alle Objekte, sowohl Original als auch Kopie, sind ausgewählt.
Verwandte Themen
So duplizieren Sie Objekte
So löschen Sie Objekte


So duplizieren Sie Objekte

Das Duplizieren eines Objekts entspricht dem Kopieren und Einfügen eines Objekts. Standardmäßig wird das Duplikat direkt unterhalb und rechts vom Original platziert. Wenn Sie das Duplikat an eine neue Position ziehen und es dann duplizieren, hat dies zur Folge, dass das nächste und alle folgenden Duplikate im selben Abstand zum letzten Duplikat und in derselben Richtung verlaufend platziert werden. Sie können so viele Duplikate anfertigen, wie in den aktiven Inhaltsbereich passen.
So duplizieren Sie Objekte
1.
Ein oder mehrere Objekte auswählen
2.
Wählen Sie „Bearbeiten“ > „Duplizieren“.
So duplizieren Sie ein Objekt durch Ziehen
1.
Ziehen Sie das Objekt an die Stelle, an der Sie das Duplikat platzieren möchten.
2.
Drücken Sie die Steuerungstaste und lassen Sie die Maustaste los.
Verwandte Themen
So können Sie Objekte ausschneiden, kopieren und einfügen
So löschen Sie Objekte


So löschen Sie Objekte

Sie können jedes ausgewählte Objekt löschen.
1.
Ein oder mehrere Objekte auswählen
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Wählen Sie „Bearbeiten“ > „Löschen“.
      •
      Drücken Sie die Entf-Taste.
Verwandte Themen
So können Sie Objekte ausschneiden, kopieren und einfügen


Objekte auswählen, gruppieren und verschieben

So wählen Sie Objekte aus
So wählen Sie Objekte über die Palette „Hierarchie“ aus
So können Sie Gruppierungen für Objekte erstellen und wieder aufheben
So verschieben Sie Objekte
So ordnen Sie Objekte an
So sperren Sie Objekte


So wählen Sie Objekte aus

Ein Objekt kann mit den üblichen Maus- und Tastatureingabeverfahren ausgewählt werden:
      •
      Wenn Sie ein einzelnes Objekt auswählen möchten, klicken Sie in der Werkzeugleiste auf die Schaltfläche „Auswahl-Werkzeug“ [image] und klicken Sie anschließend auf das Objekt.
      •
      Wenn Sie mehrere Objekte auswählen möchten, klicken Sie bei gedrückter Steuerungstaste auf die auszuwählenden Objekte oder markieren Sie die gewünschten Objekte mit der Lasso-Funktion (indem Sie die Maustaste über die Objekte ziehen).
      •
      Wenn Sie alle Objekte auswählen möchten, klicken Sie auf „Bearbeiten“ > „Alles auswählen“.
      •
      Wenn Sie alle statischen Objekte auswählen möchten, klicken Sie auf „Bearbeiten“ > „Alle statischen Objekte auswählen“.
      •
      Wenn Sie alle Felder auswählen möchten, klicken Sie auf „Bearbeiten“ > „Alle Felder auswählen“.
Verwandte Themen
Tasten zum Auswählen von Text


So wählen Sie Objekte über die Palette „Hierarchie“ aus

Die Palette „Hierarchie“ unterstützt Sie bei der Auswahl und Bearbeitung von Objekten.
Wenn Sie ein Objekt in der Palette „Hierarchie“ auswählen, wird das Objekt auch gleichzeitig im Formular ausgewählt. Wenn Sie in der Palette „Hierarchie“ eine Auswahl vornehmen, werden alle Tasteneingaben (z. B. F2 oder Umschalttaste+Klicken) so lange an die Palette „Hierarchie“ geleitet, bis Sie wieder im Formular arbeiten.
      •
      Wenn Sie die Palette „Hierarchie“ anzeigen möchten, klicken Sie auf „Fenster“ > „Hierarchie“.
      •
      Wenn Sie ein einzelnes Objekt in der Palette „Hierarchie“ auswählen möchten, klicken Sie auf das Objekt.
      •
      Wenn Sie mehrere benachbarte Objekte in der Palette „Hierarchie“ auswählen möchten, klicken Sie auf das erste Objekt und klicken Sie anschließend bei gedrückter Umschalttaste auf das letzte Objekt.
      •
      Wenn Sie mehrere nicht benachbarte Objekte in der Palette „Hierarchie“ auswählen möchten, klicken Sie bei gedrückter Steuerungstaste auf die einzelnen Objekte.
      •
      Wenn Sie eine Gruppe von Objekten in der Palette „Hierarchie“ auswählen möchten, klicken Sie auf den Gruppenknoten.


So können Sie Gruppierungen für Objekte erstellen und wieder aufheben

Um Objekte zu gruppieren bzw. die Gruppierung wieder aufzuheben, können Sie das Menü „Layout“, die Palette „Hierarchie“ oder die Symbolleiste „Layout“ verwenden:
      •
      Wenn Sie Objekte gruppieren möchten, wählen Sie im Formularentwurf oder in der Palette „Hierarchie“ die zu gruppierenden Objekte aus und wählen Sie anschließend „Layout“ > „Gruppieren“ oder klicken Sie auf „Gruppieren“ [image].
      •
      Wenn Sie die Gruppierung von Objekten aufheben möchten, wählen Sie im Formularentwurf oder in der Palette „Hierarchie“ die gewünschten Objekte aus und wählen Sie anschließend „Layout“ > „Gruppierung aufheben“ oder klicken Sie auf „Gruppierung aufheben“ [image].
      •
      Wenn Sie einer Gruppe mit Hilfe der Maus ein neues Objekt hinzufügen möchten, ziehen Sie das Objekt im Formularentwurf in die Gruppe.
      •
      Wenn Sie einer Gruppe über die Palette „Hierarchie“ ein neues Objekt hinzufügen möchten, ziehen Sie das Objekt in einen vorhandenen Gruppenknoten.
Verwandte Themen
Tasten zum Bearbeiten von Objekten


So verschieben Sie Objekte

Objekte können durch Ziehen mit der Maus, mit Hilfe der Pfeiltasten auf der Tastatur oder durch Eingeben der genauen Werte in der Palette „Layout“ verschoben werden.
So verschieben oder duplizieren Sie Objekte durch Einfügen
1.
Ein oder mehrere Objekte auswählen
2.
Wählen Sie zum Verschieben der Auswahl „Bearbeiten“ > „Ausschneiden“ oder zum Duplizieren der Auswahl auf „Bearbeiten“ > „Kopieren“.
3.
(Optional) Wenn Sie ein Objekt in eine andere Datei einfügen möchten, öffnen Sie die betreffende Datei.
4.
Wählen Sie „Bearbeiten“ > „Einfügen“, um das Objekt im aktiven Fenster einzufügen.
So verschieben Sie ein Objekt durch Ziehen
1.
Ein oder mehrere Objekte auswählen
2.
Ziehen Sie das Objekt an eine neue Position.
So verschieben Sie ein Objekt mit Hilfe der Pfeiltasten
1.
Ein oder mehrere Objekte auswählen
2.
Drücken Sie die Pfeiltaste für die Richtung, in die Sie das Objekt verschieben möchten. Der Standardabstand ist 1 Punkt (1/72-tel Zoll oder 0,3528 Millimeter).
3.
Wenn Sie das Objekt um jeweils 10 Punkte verschieben möchten, drücken Sie Umschalttaste und die Pfeiltaste gleichzeitig.
So verschieben Sie Objekte mit Hilfe der X- und Y-Koordinaten in der Palette „Layout“
1.
Ein oder mehrere Objekte auswählen
2.
Geben Sie in der Palette „Layout“ neue Werte in das Feld „X“ und/oder „Y“ ein.


So ordnen Sie Objekte an

In LiveCycle Designer werden gezeichnete Objekte nacheinander angeordnet, beginnend mit dem ersten gezeichneten Objekt. Durch die Anordnung der Objekte wird bestimmt, wie sie angezeigt werden, wenn sie sich überlagern. Die Anordnungsreihenfolge von Objekten in Ihrem Formularentwurf kann jederzeit mit Hilfe der Anordnungsbefehle im Menü „Layout“ geändert werden.
1.
Wählen Sie das Objekt aus.
2.
Verwenden Sie eine der folgenden Methoden:
      •
      Um das Objekt weiter nach vorne zu bringen, wählen Sie „Layout“ > „Nach vorne“ oder klicken Sie auf „Eine Ebene nach vorne“ [image].
      •
      Um das Objekt nach vorne zu bringen, wählen Sie „Layout“ > „In den Vordergrund“ oder klicken Sie auf „In den Vordergrund“ [image].
      •
      Um ein Objekt weiter nach hinten zu stellen, wählen Sie „Layout“ > „Eine Ebene nach hinten“ oder klicken Sie auf „Eine Ebene nach hinten“ [image].
      •
      Um ein Objekt nach hinten zu stellen, wählen Sie „Layout“ > „In den Hintergrund“ oder klicken Sie auf „In den Hintergrund“ [image].
Verwandte Themen
Layout-Eigenschaften in der Palette „Layout“


So sperren Sie Objekte

Wenn Objekte gesperrt sind, können sie im Layout-Editor weder ausgewählt noch bearbeitet werden. Sie können folgende Bestandteile Ihres Formularentwurfs sperren:
    • Text
Hierzu gehört statischer Text oder Text in den Beschriftungen von Objekten. Wenn Sie „Text sperren“ auswählen, müssen Sie auf den jeweiligen Text oder die Beschriftung doppelklicken, um sie bearbeiten zu können. Auf diese Weise kann der Text nicht so einfach verändert werden. Ist „Text sperren“ nicht aktiviert, können Sie den Text durch einfaches Klicken auf die Beschriftung oder auf das Textobjekt bearbeiten. Der Befehl „Text sperren“ ist vor allem dann nützlich, wenn Sie Objekte auswählen und verschieben möchten, ohne Änderungen am Text vorzunehmen. Sie können das Objekt mit einem einfachen Mausklick auswählen. Um Änderungen vornehmen zu können, müssen Sie auf die Beschriftung oder den Text jedoch doppelklicken.
    • Statische Objekte
Hierzu gehören statischer Text, Kreise, Linien und Rechtecke.
    • Feldobjekte
Hierzu gehören Schaltflächen, Kontrollkästchen, Datums-/Uhrzeitfelder, Dezimalfelder, Dokumentunterschriftsfelder, Dropdown-Listen, Bildfelder, Listenfelder, numerische Felder, Papierformular-Barcodes, Kennwortfelder, Optionsfelder und Textfelder.
Sie können die Objekte in der Palette „Hierarchie“ auswählen und die zugehörigen Eigenschaften bearbeiten.
Nach dem Sperren von statischen Objekten und Feldobjekten müssen Sie diese entsperren, um neue statische Objekte und Feldobjekte hinzufügen zu können.
Die Befehle zum Sperren sind dann hilfreich, wenn Sie die Formatierung bestimmter Objekte im Formularentwurf abgeschlossen haben und mit anderen Objekttypen weiterarbeiten möchten. Ihr Formular enthält beispielsweise viele Textfeldobjekte sowie Textobjekte mit Anweisungen zum Ausfüllen des Formulars. Sie haben alle statischen Textobjekte positioniert und formatiert und müssen auf Textfeldobjekte eine andere Schrift anwenden. Dazu sperren Sie einfach die Textobjekte und verwenden dann die Option „Bearbeiten“ > „Alle Felder auswählen“, um alle Textfeldobjekte gleichzeitig auszuwählen und die Schrift zu ändern.
      •
      Wenn Sie Text sperren möchten, wählen Sie „Bearbeiten“ > „Text sperren“. Wenn Sie Text entsperren möchten, wählen Sie „Bearbeiten“ > „Text sperren“.
      •
      Wenn Sie statische Objekte sperren möchten, wählen Sie „Bearbeiten“ > „Statische Objekte sperren“. Wenn Sie statische Objekte entsperren möchten, wählen Sie „Bearbeiten“ > „Statische Objekte sperren“.
      •
      Wenn Sie Felder sperren möchten, wählen Sie „Bearbeiten“ > „Felder sperren“. Wenn Sie Felder entsperren möchten, wählen Sie „Bearbeiten“ > „Felder sperren“.


Objekte ausrichten und in der Größe ändern

So richten Sie Objekte zueinander aus
So richten Sie Objekte an einem Raster aus
So zentrieren Sie Objekte auf der Seite
So drehen Sie Objekte
So verteilen Sie Objekte
So ändern Sie die Größe von Objekten
So passen Sie die Größe von Objekten an
So können Sie Objekte passend erweitern
So positionieren Sie Objekte


So richten Sie Objekte zueinander aus

Wenn Sie Objekte zueinander ausrichten, bestimmt das zuletzt ausgewählte Objekt den Ausrichtungspunkt. Wenn Sie beispielsweise bei gedrückter Umschalttaste auf mehrere linksbündig auszurichtende Objekte klicken, dann werden die Objekte an der linken Seite des zuletzt ausgewählten Objekts ausgerichtet. In einer Gruppe von ausgewählten Objekten verfügt das zuletzt ausgewählte Objekt über Ziehpunkte zur Größenänderung.
So richten Sie die Kanten der Objekte aus
1.
Wählen Sie die Objekte aus, die Sie ausrichten möchten.
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Um die linken Kanten der Objekte auszurichten, wählen Sie „Layout“ > „Ausrichten“ > „Links“ oder klicken Sie auf „Linksbündig“ [image].
      •
      Um die rechten Kanten der Objekte auszurichten, wählen Sie „Layout“ > „Ausrichten“ > „Rechts“ oder klicken Sie auf „Rechtsbündig“ [image].
      •
      Um die oberen Kanten der Objekte auszurichten, wählen Sie „Layout“ > „Ausrichten“ > „Oben“ oder klicken Sie auf „Oben ausrichten“ [image].
      •
      Um die unteren Kanten der Objekte auszurichten, wählen Sie „Layout“ > „Ausrichten“ > „Unten“ oder klicken Sie auf „Unten ausrichten“ [image].
So richten Sie den vertikalen Mittelpunkt der Objekte aus
1.
Wählen Sie die Objekte aus, die Sie ausrichten möchten.
2.
Wählen Sie „Layout“ > „Ausrichten“ > „Vertikal zentriert“ oder klicken Sie auf „Vertikal zentriert“ [image].
So richten Sie den horizontalen Mittelpunkt der Objekte aus
1.
Wählen Sie die Objekte aus, die Sie ausrichten möchten.
2.
Wählen Sie „Layout“ > „Ausrichten“ > „Horizontal zentriert“ oder klicken Sie auf „Horizontal zentriert“ [image].
Verwandte Themen
So richten Sie Objekte an einem Raster aus
So zentrieren Sie Objekte auf der Seite
So verteilen Sie Objekte
Tasten zum Bearbeiten von Objekten


So richten Sie Objekte an einem Raster aus

Sie können Objekte am nächstliegenden Rastersegment ausrichten. Die Rastereinstellungen können in der Palette „Zeichenhilfen“ angepasst werden.
1.
Wählen Sie die Objekte aus, die Sie ausrichten möchten.
2.
Wählen Sie „Layout“ > „Ausrichten“ > „Am Raster“.
Verwandte Themen
So richten Sie Objekte zueinander aus
So zentrieren Sie Objekte auf der Seite
So verteilen Sie Objekte
Tasten zum Bearbeiten von Objekten
Palette „Zeichenhilfen“


So zentrieren Sie Objekte auf der Seite

Sie können ein Objekt im horizontalen oder vertikalen Mittelpunkt der Seite positionieren. Der Mittelpunkt wird auf der Basis der definierten Seitengröße bestimmt.
1.
Wählen Sie die Objekte aus, die Sie zentrieren möchten.
2.
Wählen Sie „Layout“ > „Auf Seite zentrieren“ > „Horizontal“ oder „Layout“ > „Auf Seite zentrieren“ > „Vertikal“.
Verwandte Themen
So richten Sie Objekte zueinander aus
So richten Sie Objekte an einem Raster aus
So verteilen Sie Objekte


So drehen Sie Objekte

Sie können ein Objekt in Schritten von 90°, 180° oder 270° um seinen Verankerungspunkt drehen. Der Verankerungspunkt wird durch die X- und Y-Koordinaten eines Objekts definiert und bildet den Drehpunkt für das Objekt.
1.
Wählen Sie das Objekt aus.
2.
Wählen Sie in der Palette „Layout“ die Position des Verankerungspunktes aus der Verankerungsliste. Die Position wird relativ zum Objektumfang bestimmt.
3.
Klicken Sie auf eine der Schaltflächen zum Drehen [image].
Verwandte Themen
Layout-Eigenschaften in der Palette „Layout“


So verteilen Sie Objekte

Beim Verteilen von Objekten werden diese gleichmäßig innerhalb des durch die aktuelle Auswahl markierten Bereichs angeordnet. Die ausgewählten Objekte können gleichmäßig über den gesamten Bereich oder nach unten sowie in Zeilen und Spalten angeordnet werden. Wenn Sie Objekte im aktuellen Auswahlbereich verteilen, werden diese in gleichmäßigem Abstand zwischen den ganz links und den ganz rechts liegenden Kanten der Objekte im Auswahlbereich angeordnet.
Wenn Sie mehrere Objekte in Zeilen und Spalten verteilen, bestimmen die Objekte, die den Außenkanten des Auswahlbereichs am nächsten liegen, die Positionen der ganz links und ganz rechts angeordneten Spalten sowie der ganz oben und ganz unten angeordneten Zeilen.
Bei komplexen Layouts behalten Sie möglicherweise besser die Übersicht, wenn Sie jeweils nur eine Zeile oder Spalte verteilen, als alle Objekte gleichzeitig in Zeilen und Spalten zu verteilen. Für ein optimales Ergebnis können Sie versuchen, zuerst die ganz links angeordnete Spalte und dann die ganz oben angeordnete Zeile zu verteilen. Wählen Sie anschließend jede Zeile aus und richten Sie diese an der ganz links angeordneten Spalte aus.
1.
Wählen Sie die Objekte aus, die Sie verteilen möchten.
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Um die Objekte über den gesamten aktuellen Auswahlbereich hinweg gleichmäßig zu verteilen, wählen Sie „Layout“ > „Verteilen“ > „Quer“ oder klicken Sie auf „Gleichmäßig horizontal verteilen“ [image].
      •
      Um die Objekte im aktuellen Auswahlbereich gleichmäßig nach unten zu verteilen, wählen Sie „Layout“ > „Verteilen“ > „Nach unten“ oder klicken Sie auf „Gleichmäßig vertikal verteilen“ [image].
      •
      Um die Objekte in Zeilen und Spalten zu verteilen, wählen Sie „Layout“ > „Verteilen“ > „In Zeilen und Spalten“ oder klicken Sie auf „Gleichmäßig in Zeilen und Spalten verteilen“ [image].
Verwandte Themen
So richten Sie Objekte zueinander aus
So richten Sie Objekte an einem Raster aus
So zentrieren Sie Objekte auf der Seite
Tasten zum Bearbeiten von Objekten


So ändern Sie die Größe von Objekten

Die Größe eines Objekts oder einer Gruppe von Objekten können Sie mit der Maus ändern. Wenn Sie die Größe mehrerer Objekte gleichzeitig ändern, wird die Größe der Objekte proportional geändert. Sie weisen mehreren Objekten unterschiedliche Größen zu, indem Sie sie einzeln auswählen und ihre Größe ändern.
Die Größe eines Objekts können Sie auch ändern, indem Sie in der Palette „Layout“ andere Einstellungen verwenden.
Damit die Größe eines Bildfeldes geändert werden kann, muss die zugehörige Option „Größe“ (auf der Registerkarte „Feld“ der Palette „Objekt“) auf eine andere Option als „Bildgröße verwenden“ gesetzt sein.
1.
Wählen Sie die Objekte aus, deren Größe Sie ändern möchten.
2.
Positionieren Sie den Zeiger über einen der Auswahlpunkte. Wenn der Zeiger als Doppelpfeil dargestellt wird, führen Sie einen der folgenden Schritte aus:
      •
      Um das Objekt zu vergrößern, ziehen Sie den Auswahlpunkt vom ausgewählten Objekt weg.
      •
      Um das Objekt zu verkleinern, ziehen Sie den Auswahlpunkt in Richtung Mitte des ausgewählten Objekts.
Während des Ziehens des Auswahlpunkts wird in der Statusleiste die Größe des Objekts angezeigt.
Verwandte Themen
So passen Sie die Größe von Objekten an
Layout-Eigenschaften in der Palette „Layout“


So passen Sie die Größe von Objekten an

Sie können zwei oder mehrere Objekte mit der gleichen Breite, Höhe oder mit beidem versehen. Die Abmessungen des zuletzt ausgewählten Objekts bestimmen, welche Breite bzw. Höhe verwendet wird. Wenn Sie beispielsweise bei gedrückter Umschalttaste auf mehrere Objekte klicken, die mit der gleichen Breite versehen werden sollen, wird die Größe der Objekte an die Breite des zuletzt ausgewählten Objekts angepasst. In einer Gruppe von ausgewählten Objekten befinden sich am letzten Objekt Ziehpunkte zur Größenänderung.
Damit die Größe eines Bildfeldes geändert werden kann, muss die zugehörige Option „Größe“ (auf der Registerkarte „Feld“ der Palette „Objekt“) auf eine andere Option als „Bildgröße verwenden“ gesetzt sein.
1.
Wählen Sie die Objekte aus, die Sie mit der gleichen Größe versehen möchten.
2.
Wählen Sie „Layout“ > „Gleiche Größe“ > [Abmessung].
Verwandte Themen
So richten Sie Objekte zueinander aus
So ändern Sie die Größe von Objekten


So können Sie Objekte passend erweitern

Beim Zusammenführen von Daten können sich Höhe und Breite von Objekten ausgehend vom Verankerungspunkt ausdehnen. Da jede Objektausdehnung vom Verankerungspunkt weg erfolgt, kann dieser die Richtung beschränken, in der das Objekt wächst. Wenn Sie zum Beispiel den Verankerungspunkt „Oben Mitte“ wählen, kann sich das Objekt nach links, rechts und unten ausdehnen.
Die Option „Passend erweitern“ sollte für mit Acrobat 6 kompatible Formulare nicht aktiviert werden. Benutzer können die Daten in erweiterbaren Feldern in mit Acrobat 6 kompatiblen Formularen nicht bearbeiten. Wählen Sie Position und Größe der Felder stattdessen so, dass auch umfangreiche Benutzereingaben Platz finden.
1.
Wählen Sie das Objekt aus.
2.
Wählen Sie in der Palette „Layout“ die Option „Passend erweitern“ für die Breite und/oder die Höhe aus.
Verwandte Themen
Layout-Eigenschaften in der Palette „Layout“


So positionieren Sie Objekte

Mit Hilfe der X- und Y-Koordinaten in der Palette „Layout“ können Sie die genaue Position eines Objekts angeben. Die X-Koordinate bestimmt die horizontale Position des Objekts in Bezug auf den linken Seitenrand. Die Y-Koordinate bestimmt die vertikale Position des Objekts in Bezug auf den oberen Seitenrand. Zur Gesamtgröße eines Objekts gehören auch die Beschriftung (soweit vorhanden) und der zugehörige Füllbereich.
1.
Wählen Sie das Objekt aus.
2.
Wählen Sie im Menü der Palette „Layout“ eine der folgenden Optionen aus:
      •
      „Absolute Koordinaten“
      •
      „Relative Koordinaten“
3.
Legen Sie in der Palette „Layout“ die X- und Y-Koordinaten für das Objekt fest.
Verwandte Themen
Layout-Eigenschaften in der Palette „Layout“


Objekte formatieren

So legen Sie einen Randabstand um ein Objekt herum fest
So legen Sie einen Rand um ein Objekt herum fest
So legen Sie einen Rand um den Füllbereich herum fest
So ändern Sie die Standardformatierung für neue Objekte
Texte und Absätze formatieren


So legen Sie einen Randabstand um ein Objekt herum fest

Alle Objekte sind in einem Randabstand oder einem Rand mit festgelegter Stärke eingefasst.
1.
Wählen Sie das Objekt aus.
2.
Legen Sie in der Palette „Layout“ den rechten, linken, oberen und unteren Rand fest.
Verwandte Themen
Layout-Eigenschaften in der Palette „Layout“


So legen Sie einen Rand um ein Objekt herum fest

Damit Sie die Randeigenschaften für ein Objekt festlegen können, das Ränder unterstützt, müssen Sie das Objekt zuerst auswählen. Die Eigenschaften, die Sie in der Palette „Rand“ festlegen, gelten für das ganze Objekt.
1.
Wählen Sie das Objekt aus.
2.
Wählen Sie in der Palette „Rand“ in der Liste „Kanten“ eine Bearbeitungsoption aus.
      •
      Wenn Sie jeder Kante einzeln einen Rand zuweisen möchten, wählen Sie „Einzeln bearbeiten“ aus. Diese Option wirkt sich nicht auf dreidimensionale Ränder aus.
      •
      Wenn Sie allen Kanten denselben Rand zuweisen möchten, wählen Sie „Zusammen bearbeiten“ aus.
3.
Wählen Sie in der Liste „Kanten“ Stil, Breite und Farbe für die Ränder aus.
4.
Wenn die Ecken der Ränder abgerundet sein sollen, klicken Sie auf eine Ecken-Schaltfläche und legen Sie im Feld „Radius“ den Radius der Ecke fest (wahlweise in Zoll, Zentimetern oder Punkten).
5.
Wenn Sie das Objekt mit Farbe oder einem Muster ausfüllen möchten, wählen Sie eine Option in der Liste „Stil“ aus und wählen Sie mit den nebenstehenden Schaltflächen für die Farbauswahl die gewünschten Füllfarben aus.
Verwandte Themen
Randeigenschaften in der Palette „Rand“
So legen Sie einen Rand um den Füllbereich herum fest


So legen Sie einen Rand um den Füllbereich herum fest

Sie können auch die Randeigenschaften für die Füllbereiche eines Objekts festlegen. Sie können zum Beispiel bei einem Textfeld einen bestimmten Randtyp und eine Füllung für das Gesamtobjekt und einen anderen Randtyp und eine andere Füllung für den Wertebereich festlegen, in dem Daten angezeigt werden. Die folgenden Objekte verfügen über Füllbereiche:
      •
      Befehlsschaltflächen
      •
      Kontrollkästchen
      •
      Dokumentunterschriftsfelder
      •
      Dropdown-Listen
      •
      Listenfelder
      •
      Numerische Felder
      •
      Kennwortfelder
      •
      Optionsfelder
      •
      Textfelder
1.
Wählen Sie das Objekt aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“. Wählen Sie in der Liste „Erscheinungsbild“ die Option „Benutzerdefiniert“ aus.
3.
Wählen Sie einen Stil für den Rand des Füllbereichs aus. Es stehen dieselben Optionen zur Verfügung wie in der Palette „Rand“.
4.
Soweit für das Objekt zutreffend, geben Sie für den Rand eine Breite ein und wählen Sie eine Randfarbe aus.
5.
Wenn die Ecken der Ränder abgerundet sein sollen, klicken Sie auf eine Ecken-Schaltfläche und legen Sie im Feld „Radius“ den Radius der Ecke fest (wahlweise in Zoll, Zentimetern oder Punkten).
6.
Wenn Sie den Füllbereich mit Farbe oder einem Muster ausfüllen möchten, wählen Sie eine Option in der Liste „Stil“ aus und wählen Sie mit den nebenstehenden Schaltflächen für die Farbauswahl die gewünschten Füllfarben aus.
Verwandte Themen
So legen Sie einen Rand um ein Objekt herum fest
Randeigenschaften in der Palette „Rand“


So ändern Sie die Standardformatierung für neue Objekte

Sie können die Standardformatierung für neue Objekte festlegen und in der Palette „Bibliothek“ speichern. Sie können beispielsweise die Standardschrift für alle neuen Textobjekte in „Times New Roman“ ändern.
1.
Fügen Sie ein Objekt ein.
2.
Nehmen Sie die Änderungen am Objekt vor. Fügen Sie beispielsweise einen Rand hinzu, verwenden Sie eine andere Schrift oder ändern Sie die Textgröße.
3.
Ziehen Sie das Objekt in eine Kategorie der Palette „Bibliothek“.
4.
Geben Sie im Dialogfeld „Bibliotheksobjekt hinzufügen“ einen Namen für das Objekt ein und klicken Sie auf „OK“.
Falls auf dieser Registerkarte bereits ein Objekt mit diesem Namen vorhanden ist, müssen Sie in LiveCycle Designer bestätigen, dass Sie das vorhandene Objekt ersetzen möchten.
Verwandte Themen
Schrift-Eigenschaften in der Palette „Schrift“
Absatz-Eigenschaften in der Palette „Absatz“
Randeigenschaften in der Palette „Rand“


Texte und Absätze formatieren

Info über das Formatieren von Texten
So verwenden Sie eine andere Schrift
So ändern Sie die Textgröße
So verschieben Sie den Text nach oben oder nach unten
So können Sie einen Text fett, kursiv, unterstrichen oder durchgestrichen formatieren
So ändern Sie die Textfarbe
Info über das Formatieren von Abschnitten
So richten Sie Absätze aus
So ändern Sie den Einzug für einen Absatz
So ändern Sie den Abstand von Absätzen


Info über das Formatieren von Texten

Sie können für Textobjekte, Objektbeschriftungen und Datenwerte Schrifteigenschaften festlegen.
Die Palette „Schrift“ enthält alle verfügbaren Schrifteigenschaften. Sie können folgende Schrifteigenschaften in der Palette „Schrift“ definieren:
      •
      Schrifttyp
      •
      Schriftgröße und -stil
      •
      Grundlinienverschiebung bzw. Verschiebung der Zeichen nach oben oder unten
Häufig verwendete Schriftformatierungseigenschaften wie Schrifttyp, -größe und -stil lassen sich schnell über die Werkzeugleiste „Schrift“ festlegen.
Wenn Sie Objekte erstellen, die Text in Sprachen darstellen können, die nicht-lateinische Schriften verwenden, müssen Sie über die Registerkarte „Feld“ der Palette „Objekt“ eine Schrift auswählen, die den gesamten Zeichenumfang der jeweiligen Sprache und das entsprechende Gebietsschema unterstützt.
Verwandte Themen
Schrift-Eigenschaften in der Palette „Schrift“


So verwenden Sie eine andere Schrift

1.
Wählen Sie den zu ändernden Text oder das Objekt aus.
Wenn der Befehl „Bearbeiten“ > „Text sperren“ aktiviert ist, doppelklicken Sie auf den Text.
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Wenn Sie die Beschriftung und den Datenwert bearbeiten möchten, klicken Sie in der Palette „Schrift“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Beschriftung und Wert bearbeiten“ aus.
      •
      Wenn Sie nur die Beschriftung bearbeiten möchten, klicken Sie in der Palette „Schrift“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Beschriftung bearbeiten“ aus.
      •
      Wenn Sie nur den Datenwert bearbeiten möchten, klicken Sie in der Palette „Schrift“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Wert bearbeiten“ aus.
3.
Wählen Sie in der Palette „Schrift“ in der Liste „Schrift“ einen Schriftnamen aus.
Verwandte Themen
Schrift-Eigenschaften in der Palette „Schrift“


So ändern Sie die Textgröße

1.
Wählen Sie den zu ändernden Text oder das Objekt aus.
Wenn der Befehl „Bearbeiten“ > „Text sperren“ aktiviert ist, doppelklicken Sie auf den Text.
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Wenn Sie die Beschriftung und den Datenwert bearbeiten möchten, klicken Sie in der Palette „Schrift“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Beschriftung und Wert bearbeiten“ aus.
      •
      Wenn Sie nur die Beschriftung bearbeiten möchten, klicken Sie in der Palette „Schrift“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Beschriftung bearbeiten“ aus.
      •
      Wenn Sie nur den Datenwert bearbeiten möchten, klicken Sie in der Palette „Schrift“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Wert bearbeiten“ aus.
3.
In der Palette „Schrift“ im Feld „Schriftgrad“ können Sie eine Punktgröße eingeben oder auswählen.
Verwandte Themen
Schrift-Eigenschaften in der Palette „Schrift“


So verschieben Sie den Text nach oben oder nach unten

1.
Wählen Sie den zu ändernden Text oder das Objekt aus.
Wenn der Befehl „Bearbeiten“ > „Text sperren“ aktiviert ist, doppelklicken Sie auf den Text.
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Wenn Sie die Beschriftung und den Datenwert bearbeiten möchten, klicken Sie in der Palette „Schrift“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Beschriftung und Wert bearbeiten“ aus.
      •
      Wenn Sie nur die Beschriftung bearbeiten möchten, klicken Sie in der Palette „Schrift“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Beschriftung bearbeiten“ aus.
      •
      Wenn Sie nur den Datenwert bearbeiten möchten, klicken Sie in der Palette „Schrift“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Wert bearbeiten“ aus.
3.
Geben Sie in der Palette „Schrift“ im Feld „Grundlinienverschiebung“ die anzuwendende Verschiebung ein.
Verwandte Themen
Schrift-Eigenschaften in der Palette „Schrift“


So können Sie einen Text fett, kursiv, unterstrichen oder durchgestrichen formatieren

1.
Wählen Sie den zu ändernden Text oder das Objekt aus.
Wenn der Befehl „Bearbeiten“ > „Text sperren“ aktiviert ist, doppelklicken Sie auf den Text.
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Wenn Sie die Beschriftung und den Datenwert bearbeiten möchten, klicken Sie in der Palette „Schrift“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Beschriftung und Wert bearbeiten“ aus.
      •
      Wenn Sie nur die Beschriftung bearbeiten möchten, klicken Sie in der Palette „Schrift“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Beschriftung bearbeiten“ aus.
      •
      Wenn Sie nur den Datenwert bearbeiten möchten, klicken Sie in der Palette „Schrift“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Wert bearbeiten“ aus.
3.
Führen Sie in der Palette „Schrift“ einen der folgenden Schritte aus:
      •
      Wenn Sie den Text fett formatieren möchten, klicken Sie auf „Fett“.
      •
      Wenn Sie den Text kursiv formatieren möchten, klicken Sie auf „Kursiv“.
      •
      Wenn Sie den Text unterstreichen möchten, klicken Sie auf „Unterstrichen“.
      •
      Wenn Sie den Text durchstreichen möchten, klicken Sie auf „Durchgestrichen“.
Verwandte Themen
Schrift-Eigenschaften in der Palette „Schrift“


So ändern Sie die Textfarbe

1.
Wählen Sie den zu ändernden Text oder das Objekt aus.
Wenn der Befehl „Bearbeiten“ > „Text sperren“ aktiviert ist, doppelklicken Sie auf den Text.
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Wenn Sie die Beschriftung und den Datenwert bearbeiten möchten, klicken Sie in der Palette „Schrift“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Beschriftung und Wert bearbeiten“ aus.
      •
      Wenn Sie nur die Beschriftung bearbeiten möchten, klicken Sie in der Palette „Schrift“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Beschriftung bearbeiten“ aus.
      •
      Wenn Sie nur den Datenwert bearbeiten möchten, klicken Sie in der Palette „Schrift“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Wert bearbeiten“ aus.
3.
Klicken Sie in der Palette „Schrift“ auf die Schaltfläche für die Farbauswahl und wählen Sie die gewünschte Farbe aus.
Verwandte Themen
Schrift-Eigenschaften in der Palette „Schrift“


Info über das Formatieren von Abschnitten

Sie können für Textobjekte, Objektbeschriftungen und Datenwerte Absatzeigenschaften festlegen. Um diese Eigenschaften zu definieren, müssen Sie zuerst das Objekt auswählen.
Die Palette „Absatz“ enthält alle in LiveCycle Designer verfügbaren Absatzeigenschaften. In der Palette „Absatz“ können Sie die folgenden Absatzeigenschaften definieren:
      •
      Ausrichtung und Streubreite
      •
      Einzug
      •
      Zeilenabstand
Die am häufigsten verwendeten Formatierungsbefehle lassen sich einfach über die Werkzeugleiste „Absatz“ aufrufen.
Verwandte Themen
Absatz-Eigenschaften in der Palette „Absatz“


So richten Sie Absätze aus

1.
Wählen Sie den zu ändernden Text oder das Objekt aus.
Wenn der Befehl „Bearbeiten“ > „Text sperren“ aktiviert ist, doppelklicken Sie auf den Text.
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Wenn Sie die Beschriftung und den Datenwert bearbeiten möchten, klicken Sie in der Palette „Absatz“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Beschriftung und Wert bearbeiten“ aus.
      •
      Wenn Sie nur die Beschriftung bearbeiten möchten, klicken Sie in der Palette „Absatz“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Beschriftung bearbeiten“ aus.
      •
      Wenn Sie nur den Datenwert bearbeiten möchten, klicken Sie in der Palette „Absatz“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Wert bearbeiten“ aus.
3.
Führen Sie einen der folgenden Schritte aus:
      •
      Wenn Sie den Text linksbündig oder rechtsbündig ausrichten möchten, klicken Sie in der Palette „Absatz“ auf „Linksbündig“ oder auf „Rechtsbündig“.
      •
      Wenn Sie den Text zentrieren möchten, klicken Sie in der Palette „Absatz“ auf „Zentrieren“.
      •
      Wenn Sie den Text als Blocksatz formatieren möchten, klicken Sie in der Palette „Absatz“ auf „Blocksatz“.
      •
      Wenn Sie den Text über dem Bereich ausrichten möchten, der für die Beschriftung und den Wert vorgesehen ist, klicken Sie in der Palette „Absatz“ auf „Oben ausrichten“.
      •
      Wenn Sie den Text in der Mitte des Bereichs ausrichten möchten, der für die Beschriftung und den Wert vorgesehen ist, klicken Sie in der Palette „Absatz“ auf „Zentriert ausrichten“.
      •
      Wenn Sie den Text unter dem Bereich ausrichten möchten, der für die Beschriftung und den Wert vorgesehen ist, klicken Sie in der Palette „Absatz“ auf „Unten ausrichten“.
Verwandte Themen
Absatz-Eigenschaften in der Palette „Absatz“


So ändern Sie den Einzug für einen Absatz

1.
Wählen Sie den zu ändernden Text oder das Objekt aus.
Wenn der Befehl „Bearbeiten“ > „Text sperren“ aktiviert ist, doppelklicken Sie auf den Text.
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Wenn Sie die Beschriftung und den Datenwert bearbeiten möchten, klicken Sie in der Palette „Absatz“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Beschriftung und Wert bearbeiten“ aus.
      •
      Wenn Sie nur die Beschriftung bearbeiten möchten, klicken Sie in der Palette „Absatz“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Beschriftung bearbeiten“ aus.
      •
      Wenn Sie nur den Datenwert bearbeiten möchten, klicken Sie in der Palette „Absatz“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Wert bearbeiten“ aus.
3.
Führen Sie einen der folgenden Schritte aus:
      •
      Wenn Sie den linken Texteinzug vergrößern oder verkleinern möchten, geben Sie in der Palette „Absatz“ unter „Einzüge“ den gewünschten Einzug im Feld „Links“ ein.
      •
      Wenn Sie den rechten Texteinzug ändern möchten, geben Sie in der Palette „Absatz“ unter „Einzüge“ den gewünschten Einzug im Feld „Rechts“ ein.
      •
      Wenn Sie einen Erstzeileneinzug erstellen möchten, wählen Sie in der Palette „Absatz“ in der Liste „Erste“ die Option „Erste Zeile“ aus. Geben Sie im Feld „Um“ das Maß für den Einzug an.
      •
      Wenn Sie einen hängenden Einzug erstellen möchten, wählen Sie in der Palette „Absatz“ in der Liste „Erste“ die Option „Hängend“ aus. Geben Sie im Feld „Um“ das Maß für den Einzug an.
Verwandte Themen
Absatz-Eigenschaften in der Palette „Absatz“


So ändern Sie den Abstand von Absätzen

1.
Wählen Sie den zu ändernden Text oder das Objekt aus.
Wenn der Befehl „Bearbeiten“ > „Text sperren“ aktiviert ist, doppelklicken Sie auf den Text.
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Wenn Sie die Beschriftung und den Datenwert bearbeiten möchten, klicken Sie in der Palette „Absatz“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Beschriftung und Wert bearbeiten“ aus.
      •
      Wenn Sie nur die Beschriftung bearbeiten möchten, klicken Sie in der Palette „Absatz“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Beschriftung bearbeiten“ aus.
      •
      Wenn Sie nur den Datenwert bearbeiten möchten, klicken Sie in der Palette „Absatz“ auf das Palettenmenü für den aktuellen Bearbeitungsmodus und wählen Sie „Wert bearbeiten“ aus.
3.
Führen Sie einen der folgenden Schritte aus:
      •
      Wenn Sie den Abstand vor und nach Text ändern möchten, geben Sie in der Palette „Absatz“ unter „Abstand“ den gewünschten Abstand im Feld „Über“ oder „Unter“ ein.
      •
      Wenn Sie den Abstand zwischen Zeilen festlegen möchten, wählen Sie in der Palette „Absatz“ in der Liste „Zeilenabstand“ eine Option aus.
Verwandte Themen
Absatz-Eigenschaften in der Palette „Absatz“


Zurück Weiter

LiveCycle Designer verwenden > Mit Objekten arbeiten > Formularobjektsammlungen verwenden

Formularobjektsammlungen verwenden

Info über Formularobjektsammlungen


Info über Formularobjektsammlungen

So erstellen Sie eine Formularobjektsammlung
So kopieren Sie eine Formularobjektsammlung
So benennen Sie eine Formularobjektsammlung um
So ändern Sie eine Formularobjektsammlung
So löschen Sie eine Formularobjektsammlung
Sie können nur die erforderlichen Objekte zum Verwenden durch ein Dokumentunterschriftsfeld oder zur Kodierung in einem Papierformular-Barcode auswählen und sie als Sammlung speichern.
Eine Sammlung wird entweder auf Dokumentunterschriftsfelder oder auf Papierformular-Barcodes angewendet, nicht jedoch auf beides, da die Objekte unterschiedlich dargestellt werden. Die Sammlungen, die für Dokumentunterschriftsfelder verfügbar sind, werden in der Palette „Objekt“ auf der Registerkarte „Dokumentunterschrift“ angezeigt. Die Sammlungen, die für Papierformular-Barcodes verfügbar sind, werden in der Palette „Objekt“ auf der Registerkarte „Wert“ angezeigt.
Verwandte Themen
Digitale Unterschriften


So erstellen Sie eine Formularobjektsammlung

Sie können eine Sammlung für Dokumentunterschriftsfelder oder für Papierformular-Barcodes erstellen. Sie können eine oder mehrere Sammlungen erstellen und die gewünschte Sammlung für ein bestimmtes Dokumentunterschriftsfeld oder für einen bestimmten Papierformular-Barcode auswählen.
1.
Wählen Sie „Datei“ > „Formularobjektsammlungen“.
2.
Klicken Sie auf „Neu“ und geben Sie im entsprechenden Feld einen Namen für die Sammlung ein.
3.
Klicken Sie auf „Ändern“ und wählen Sie in der Liste „Sammlungstyp“ die gewünschte Option aus. In der Liste werden die verfügbaren Objekte für den ausgewählten Sammlungstyp angezeigt.
4.
Wählen Sie die Objekte aus, die in die Sammlung eingefügt werden sollen. Um für den Sammlungstyp nicht unterstützte Objekte auszublenden, wählen Sie die Option „Nicht unterstützte Knoten ausblenden“ aus.
5.
Klicken Sie auf „OK“.
Verwandte Themen
So fügen Sie ein Dokumentunterschriftsfeld hinzu
Eigenschaften von Dokumentunterschriftsfeldern: Registerkarte „Dokumentunterschrift“
Entwurftipps für die Verwendung von Papierformular-Barcodes
Eigenschaften von Papierformular-Barcodes: Registerkarte „Wert“
Dialogfeld „Sammlungseditor“
Dialogfeld „Sammlungsliste“


So kopieren Sie eine Formularobjektsammlung

1.
Wählen Sie „Datei“ > „Formularobjektsammlungen“ aus.
2.
Wählen Sie in der Liste eine Sammlung aus und klicken Sie auf „Duplizieren“.
3.
Doppelklicken Sie auf die Sammlung und geben Sie einen Namen ein.
4.
Zum Festlegen der Position der Sammlung klicken Sie auf „Nach oben“ oder „Nach unten“.
Verwandte Themen
So fügen Sie ein Dokumentunterschriftsfeld hinzu
Eigenschaften von Dokumentunterschriftsfeldern: Registerkarte „Dokumentunterschrift“
Entwurftipps für die Verwendung von Papierformular-Barcodes
Eigenschaften von Papierformular-Barcodes: Registerkarte „Wert“
Dialogfeld „Sammlungseditor“
Dialogfeld „Sammlungsliste“


So benennen Sie eine Formularobjektsammlung um

1.
Wählen Sie „Datei“ > „Formularobjektsammlungen“ aus.
2.
Doppelklicken Sie auf die Sammlung in der Liste und geben Sie den neuen Namen ein.
Verwandte Themen
So fügen Sie ein Dokumentunterschriftsfeld hinzu
Eigenschaften von Dokumentunterschriftsfeldern: Registerkarte „Dokumentunterschrift“
Entwurftipps für die Verwendung von Papierformular-Barcodes
Eigenschaften von Papierformular-Barcodes: Registerkarte „Wert“
Dialogfeld „Sammlungseditor“
Dialogfeld „Sammlungsliste“


So ändern Sie eine Formularobjektsammlung

1.
Wählen Sie eine der folgenden Optionen:
      •
      Wählen Sie „Datei“ > „Formularobjektsammlungen“ aus und fahren Sie mit Schritt 3 fort.
      •
      Wählen Sie auf der Seite ein Dokumentunterschriftsfeld oder Papierformular-Barcodeobjekt aus.
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Um die Sammlung für einen Papierformular-Barcode zu ändern, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“.
      •
      Um die Sammlung für ein Dokumentunterschriftsfeld zu ändern, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Dokumentunterschrift“.
3.
Wählen Sie in der Liste „Sammlung“ die Option „Sammlung - Neu/verwalten“ aus.
4.
Wählen Sie die Sammlung aus, die Sie ändern möchten, und klicken Sie auf „Ändern“.
5.
Wählen Sie in der Liste „Sammlungstyp“ die gewünschte Option aus.
6.
Wählen Sie die Objekte aus, die aus der Sammlung entfernt oder in diese eingefügt werden sollen. Um für den Sammlungstyp nicht unterstützte Objekte auszublenden, wählen Sie die Option „Nicht unterstützte Knoten ausblenden“ aus.
7.
Klicken Sie auf „OK“.
8.
Zum Festlegen der Position der Sammlung klicken Sie auf „Nach oben“ oder „Nach unten“.
Verwandte Themen
So fügen Sie ein Dokumentunterschriftsfeld hinzu
Eigenschaften von Dokumentunterschriftsfeldern: Registerkarte „Dokumentunterschrift“
Entwurftipps für die Verwendung von Papierformular-Barcodes
Eigenschaften von Papierformular-Barcodes: Registerkarte „Wert“
Dialogfeld „Sammlungseditor“
Dialogfeld „Sammlungsliste“


So löschen Sie eine Formularobjektsammlung

1.
Wählen Sie „Datei“ > „Formularobjektsammlungen“ aus.
2.
Wählen Sie in der Liste eine Sammlung aus, klicken Sie auf „Löschen“ und klicken Sie dann auf „Ja“.
Verwandte Themen
So fügen Sie ein Dokumentunterschriftsfeld hinzu
Eigenschaften von Dokumentunterschriftsfeldern: Registerkarte „Dokumentunterschrift“
Entwurftipps für die Verwendung von Papierformular-Barcodes
Eigenschaften von Papierformular-Barcodes: Registerkarte „Wert“
Dialogfeld „Sammlungseditor“
Dialogfeld „Sammlungsliste“


Objekte als sichtbar, unsichtbar oder ausgeblendet definieren

Info über das Definieren von Objekten als sichtbar, unsichtbar oder ausgeblendet
So definieren Sie ein Objekt als sichtbar, unsichtbar oder ausgeblendet


Info über das Definieren von Objekten als sichtbar, unsichtbar oder ausgeblendet

Je nach Verwendungszweck des Formulars können Sie steuern, welche Objekte in einem PDF-Formular angezeigt werden, wenn Benutzer das Formular in Acrobat oder Adobe Reader anzeigen bzw. wenn Benutzer das Formular drucken. Mit den verschiedenen Optionen in der Liste „Präsenz“ der Palette „Objekt“ können Sie bestimmte Objekte in einem PDF-Formular selektiv als sichtbar, unsichtbar oder ausgeblendet definieren, wenn das Formular auf dem Bildschirm angezeigt oder gedruckt wird.
Beim Anwenden der Präsenzoptionen auf Objekte müssen Sie folgende Punkte berücksichtigen:
      •
      Die Optionen „Unsichtbar“ und „Ausgeblendet“ sind für Gruppen, Inhaltsbereiche, Masterseiten, Seitensätze und Teilformularsätze nicht verfügbar.
      •
      Die auf Containerobjekte, wie z. B. Inhaltsbereiche und Teilformulare, angewandten Präsenzoptionen überschreiben die Präsenzoptionen der jeweils enthaltenen Objekte. Wenn Sie beispielsweise die Option „Sichtbar (nur drucken)“ auf einen Teilformularsatz anwenden, werden das Teilformular und die erfassten Objekte nicht auf dem Bildschirm, sondern nur im gedruckten Formular angezeigt, unabhängig von der Präsenzeinstellung der einzelnen Objekte.
      •
      Wenn Sie ein Formular drucken möchten, wenden Sie die Option „Sichtbar (nur Bildschirm)“ nicht auf Inhaltsbereichsobjekte im Formular an. Wenn Sie diese Option anwenden, wird der Inhaltsbereich auf dem Bildschirm angezeigt. Er wird allerdings nicht im gedruckten Formular angezeigt oder wiedergegeben, so dass das Formular nicht ordnungsgemäß gedruckt wird. In der rechten oberen Ecke der Masterseite wird ein Warnsymbol angezeigt, wenn ein Inhaltsbereich oder ein Masterseitenobjekt in der Bildschirm- oder in der Druckansicht fehlt.
      •
      Wenn Sie die Option „Sichtbar (nur drucken)“ auf ein Objekt anwenden, wird das Objekt auf den Registerkarten „Designansicht“ und „Masterseite“ angezeigt, jedoch nicht auf der Registerkarte „PDF-Vorschau“.
In der folgenden Liste werden einige Verwendungsmöglichkeiten für die Präsenzoptionen beschrieben:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. Wenn das Formular beispielsweise auf dem Bildschirm genauso dargestellt werden soll wie im Ausdruck, können Sie die Option „Sichtbar“ auf alle Objekte im Formular anwenden. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. Wenn ein Benutzer beispielsweise ein Formular ausfüllt, online sendet und anschießend druckt, können Sie die Option „Sichtbar (nur Bildschirm)“ auf die Schaltflächen „Drucken“ und „Senden“ anwenden, so dass die Schaltflächen auf dem Bildschirm sichtbar und im gedruckten Formular unsichtbar sind.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. Wenn das gedruckte Formular beispielsweise einen bestimmten Anweisungstext enthalten soll, der auf dem Bildschirm nicht unbedingt angezeigt werden muss (z. B. Anweisungen zum Versand), können Sie die Option „Sichtbar (nur drucken)“ auf Textfeldobjekte anwenden, in denen die Anweisungen enthalten sind, so dass der Text im gedruckten Formular sichtbar und auf dem Bildschirm unsichtbar ist.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. Wenn ein Bereich in einem Formular unsichtbar bleiben soll, bis ein Benutzer eine bestimmte Option auswählt (z. B. der Abschnitt mit den Zahlungsinformationen in einer Rechnung), können Sie die Option „Unsichtbar“ auf die Textfeldobjekte anwenden, die zur Erfassung von Kreditkarteninformationen verwendet werden, so dass sie unsichtbar bleiben, bis der Benutzer ein Optionsfeld zur Angabe des Kreditkartentyps aktiviert.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein. Wenn ein Abschnitt in einem Formular beispielsweise ausgeblendet werden soll, bis ein Benutzer eine bestimmte Option auswählt, und das Formular im Layout keinen Platz einnehmen soll, solange der Abschnitt ausgeblendet ist, können Sie die Option „Ausgeblendet (Aus Layout ausschließen)“ auf das Teilformular mit den verschiedenen Objekten im Abschnitt anwenden, so dass das Formularlayout je nach Bedarf angepasst werden kann.


So definieren Sie ein Objekt als sichtbar, unsichtbar oder ausgeblendet

Je nach ausgewähltem Objekt wird die Liste „Präsenz“ auf einer anderen Registerkarte angezeigt.
1.
Wählen Sie das Objekt aus.
2.
Klicken Sie in der Palette „Objekt“ auf die entsprechende Registerkarte.
3.
Wählen Sie in der Liste „Präsenz“ eine der folgenden Optionen aus:
      •
      Wenn das Objekt auf dem Bildschirm und im gedruckten Formular sichtbar sein soll und Platz im Formularlayout einnehmen soll, wählen Sie „Sichtbar“ aus.
      •
      Wenn das Objekt auf dem Bildschirm sichtbar und im gedruckten Formular nicht sichtbar sein soll und Platz im Formularlayout einnehmen soll, wählen Sie „Sichtbar (nur Bildschirm)“ aus.
      •
      Wenn das Objekt auf dem Bildschirm nicht sichtbar und im gedruckten Formular sichtbar sein soll und Platz im Formularlayout einnehmen soll, wählen Sie „Sichtbar (nur drucken)“ aus.
      •
      Wenn das Objekt auf dem Bildschirm und im gedruckten Formular nicht sichtbar sein soll und Platz im Formularlayout einnehmen soll, wählen Sie „Unsichtbar“ aus.
      •
      Wenn das Objekt auf dem Bildschirm und im gedruckten Formular nicht sichtbar sein soll und keinen Platz im Formularlayout einnehmen soll, wählen Sie „Ausgeblendet (Aus Layout ausschließen)“ aus.


Beschriftungen formatieren

Info über Beschriftungen
So benennen Sie eine Beschriftung um
So positionieren Sie eine Beschriftung
So legen Sie die Größe des Randabstands für eine Beschriftung fest
So stellen Sie den Beschriftungsbereich auf automatische Anpassung ein
So blenden Sie eine Beschriftung aus


Info über Beschriftungen

Beschriftungen werden von einer Reihe von Standardfeldobjekten in der Palette „Bibliothek“ unterstützt. Beschriftungen enthalten Textinformationen für Benutzer, die das endgültige Formular anzeigen.
Wenn Sie ein Objekt hinzufügen, das Beschriftungen unterstützt, verwendet LiveCycle Designer für diese Beschriftung einen Standardnamen. Der Standardname ist der Name des Objekts. Wenn Sie dem Formularentwurf also z. B. ein Listenfeld hinzufügen, wird als Standardbeschriftung „Listenfeld“ verwendet.
Beim Erstellen des Formularentwurfs wird die Beschriftung des Objekts an zwei Stellen angezeigt: Im Formularentwurf über dem Objekt (Standardposition) oder auf der Registerkarte „Feld“ der Palette „Objekt“.
Sie können den Beschriftungstext mit Hilfe der Registerkarte „Feld“ der Palette „Objekt“ oder durch Bearbeiten des Beschriftungstextes direkt auf der Seite ändern. Wenn der Text bei der Eingabe umgebrochen wird, können Sie die Objektgröße ändern, so dass der Text richtig angezeigt wird. Wenn am Objekt ein weißes Kreuz in einem roten Feld [image] angezeigt wird, müssen Sie entweder die Objektgröße oder den Beschriftungsabstand anpassen. Bei einem Abstandswert von 0 wird der Beschriftungsbereich automatisch an die Größe der Beschriftung angepasst. Die Beschriftung ist geschützt und kann von den Benutzern beim Ausfüllen des Formulars nicht geändert werden.
Verwenden Sie den Befehl „Text sperren“, um zu vermeiden, dass Beschriftungen geändert werden, wenn Sie Feldobjekte neu anordnen. Mit Hilfe dieses Befehls lassen sich Feldobjekte problemlos verschieben. Die Bearbeitung der zugehörigen Beschriftung ist jedoch nicht ohne weiteres möglich.
Beschriftungen können nicht ausgewählt oder bearbeitet werden, wenn ein Feldobjekt gesperrt ist. Siehe So sperren Sie Objekte.
Verwandte Themen
Texte und Absätze formatieren
So erstellen Sie eine Beschriftung durch Zusammenführen eines Text- und eines Feldobjekts
So fügen Sie sprachspezifische Zahlen in Text oder Beschriftungen ein
Schrift-Eigenschaften in der Palette „Schrift“
Absatz-Eigenschaften in der Palette „Absatz“
Layout-Eigenschaften in der Palette „Layout“


So benennen Sie eine Beschriftung um

1.
Wählen Sie das Objekt aus.
2.
Führen Sie einen der folgenden Schritte aus:
      •
      Wenn Sie die Beschriftung im Layout-Editor ändern möchten, markieren Sie den Beschriftungstext und geben Sie eine neue Beschriftung ein. Wenn der Befehl „Bearbeiten“ > „Text sperren“ aktiviert ist, doppelklicken Sie auf den Text.
      •
      Wenn Sie die Beschriftung mit Hilfe der Palette „Objekt“ ändern möchten, klicken Sie auf die Registerkarte „Feld“ und geben Sie im Feld „Beschriftung“ eine neue Beschriftung ein.
Sie können eine Beschriftung mit einem Wert aus einer Datenquelle dynamisch ausfüllen.
Verwandte Themen
So sperren Sie Objekte
So füllen Sie eine Beschriftung dynamisch aus


So positionieren Sie eine Beschriftung

Die Position von Beschriftungen wird relativ zum Füllbereich des jeweiligen Objekts festgelegt.
1.
Ein oder mehrere Objekte auswählen
2.
Wählen Sie in der Palette „Layout“ in der Liste „Position“ die gewünschte Position der Beschriftung aus.


So legen Sie die Größe des Randabstands für eine Beschriftung fest

Sie können die Größe des Randabstands zwischen der Beschriftung und dem Füllbereich einstellen.
1.
Ein oder mehrere Objekte auswählen
2.
Geben Sie in der Palette „Layout“ einen neuen Wert im Feld „Abstand“ ein.
Wenn Sie einen Randabstand eingeben, bevor Sie die Position der Beschriftung bestimmt haben, stellt LiveCycle Designer den Randabstand automatisch ein.


So stellen Sie den Beschriftungsbereich auf automatische Anpassung ein

1.
Wählen Sie ein oder mehrere Objekte aus.
2.
Geben Sie in der Palette „Layout“ im Feld „Abstand“ den Wert 0 ein. Durch diesen Wert wird der Beschriftungsbereich automatisch an die Größe der Beschriftung angepasst.
Verwandte Themen
Layout-Eigenschaften in der Palette „Layout“


So blenden Sie eine Beschriftung aus

1.
Wählen Sie ein oder mehrere Objekte aus.
2.
Wählen Sie in der Palette „Layout“ in der Liste „Position“ die Einstellung „Ohne“ aus.
Verwandte Themen
Layout-Eigenschaften in der Palette „Layout“


Feldwerte formatieren

Info über Feldmuster und Wertformatierung
Anwendungszwecke für Muster
Standards für die Wertformatierung
So legen Sie einen Standardwert fest
So legen Sie ein Anzeigemuster fest
So fordern Sie Benutzer zur Dateneingabe auf
So legen Sie ein Bearbeitungsmuster fest
So überprüfen Sie Benutzereingaben
So legen Sie ein Datenmuster fest
Einfache Muster
Gebietsschemata
Epoche
Datumsformate
Uhrzeitformate
Datums- und Uhrzeitmuster
Komplexe Feldmuster


Info über Feldmuster und Wertformatierung

Je nach den Anforderungen Ihrer speziellen Situation können Sie eines oder mehrere der folgenden Muster festlegen, um zu steuern, wie Feldwerte wie Textfelder, numerische Felder und Datums-/Uhrzeitfelder zur Laufzeit formatiert werden:
      •
      Ein Anzeigemuster, das die Art und Weise beschreibt, in der Daten im Formular angezeigt werden. Wenn Sie einen Standard-Anfangswert festlegen, wird er dem Anzeigemuster entsprechend formatiert. Das Anzeigemuster ist auch für die Formatierung der Benutzereingabe und aller gebundenen Werte verantwortlich, die zur Laufzeit ermittelt werden.
      •
      Ein Bearbeitungsmuster, das die Syntax für die Dateneingabe in ein Datums-/Uhrzeitfeld, numerisches Feld, Textfeld oder Kennwortfeld zur Laufzeit beschreibt
      •
      Ein Überprüfungsmuster, das zur Überprüfung der Benutzereingabe während der Laufzeit dient
      •
      Ein Datenmuster, das die Syntax gebundener oder gespeicherter Daten beschreibt
Die richtige Wahl der Formatierungsoptionen hängt vom Zweck des Formulars ab. Wenn Sie zum Beispiel ein interaktives Formular entwerfen, sollten Sie für jedes Feld ein Bearbeitungsmuster definieren, um die Benutzereingabe zu bearbeiten, und ein Überprüfungsmuster, um die Eingabe zu überprüfen. Ein Datenmuster wäre in diesem Fall nicht erforderlich, soweit die Felder nicht an eine Datenquelle gebunden sind.
Verwandte Themen
Anwendungszwecke für Muster
So legen Sie einen Standardwert fest
So legen Sie ein Anzeigemuster fest
So fordern Sie Benutzer zur Dateneingabe auf
So legen Sie ein Bearbeitungsmuster fest
So überprüfen Sie Benutzereingaben
So legen Sie ein Datenmuster fest


Anwendungszwecke für Muster

Mit Mustern können Sie die Verarbeitung von Feldwerten zur Laufzeit steuern. Zum Beispiel können Benutzer Buchstaben und Ziffern in ein Textfeld eingeben, wobei die Eingabe noch vor der Anzeige des betreffenden Wertes nach einem definierten Muster mit bestimmten Trenn-, Leer- oder Dezimalzeichen formatiert wird.
Benutzereingaben erfassen und anzeigen
Wenn Sie ein Formular zur Erfassung von Daten erstellen, können Sie festlegen, wie die Daten formatiert werden. In einem Anzeigemuster können Sie festlegen, wie die Daten angezeigt werden. Wenn Sie kein Anzeigemuster festlegen, werden die Daten nach LiveCycle Designer-Standard angezeigt.
Wenn Benutzer Daten eingeben sollen, die nicht dem LiveCycle Designer-Standard entsprechen, müssen Sie ein Bearbeitungsmuster festlegen. Das Bearbeitungsmuster beschreibt die Syntax der Benutzereingabe. Wenn ein Muster vorhanden ist, konvertiert die Laufzeitanwendung die Benutzereingabe in einen Rohwert und formatiert dann den Wert entsprechend dem Anzeigemuster.
Wenn Sie ein interaktives Formular erstellen, müssen Sie eine Plausibilitätsprüfung der Benutzereingabe durchführen. Sie können eine eigene Meldung definieren, mit der die Benutzer zur Eingabe richtiger Werte aufgefordert werden. Wenn Sie keine eigene Meldung für die Laufzeitanwendung festlegen, wird vom System automatisch eine Meldung generiert.
Die Benutzereingabe kann mit FormCalc-Formeln und JavaScript-Skripten verarbeitet werden. (Ein Skript kann zum Beispiel den Rohwert eines Feldes anfordern.) Da Formeln und Skripten sowohl Rohwerte als auch formatierte Werte verarbeiten, muss die gesamte Eingabe überprüft werden.
Gebundene Daten abfragen und anzeigen
Wenn gebundene Daten mit einem Formular zusammengeführt werden, können Sie festlegen, ob die Daten mit einem Anzeigemuster für die Anzeige formatiert werden. Wenn Sie kein Anzeigemuster festlegen, werden die Daten nach LiveCycle Designer-Standard angezeigt.
Wenn die Daten dem LiveCycle Designer-Standard nicht entsprechen, müssen Sie ein Datenmuster festlegen. Das Datenmuster beschreibt die Syntax der gebundenen Daten. Anhand des Musters konvertiert die Laufzeitanwendung die abgerufenen Daten in Rohwerte und formatiert sie dann für die Anzeige.
Verwandte Themen
Info über Feldmuster und Wertformatierung
Standards für die Wertformatierung


Standards für die Wertformatierung

Standardwerte müssen abhängig vom Feldtyp den folgenden Regeln entsprechen.

Feld

Regel
Datums-/Uhrzeitfeld
Ein standardmäßiger Datums-/Uhrzeitwert muss dem Kurzformat für das Gebietsschema entsprechen, das für das Datums-/Uhrzeitfeld definiert wurde. In LiveCycle Designer wird der Standardwert jedoch automatisch im mittleren Gebietsschemaformat angezeigt, sowohl beim Entwerfen also auch zur Laufzeit.
Angenommen, Sie erstellen ein Formular mit dem Gebietsschema Deutsch (Deutschland) für ein Datums-/Uhrzeitfeld. Sie geben als Datum den Standardwert im Kurzformat DD.MM.YY ein. Wenn Sie dann den Fokus auf ein anderes Feld verschieben, wird der angegebene Wert im Feld auf der Seite im mittleren Format DD.MM.YYYY angezeigt. Der formatierte Werte wird auch bei der Anzeige des Formulars auf der Registerkarte „PDF-Vorschau“ im mittleren Format angezeigt.
Zur Laufzeit müssen Benutzer beim Ausfüllen standardmäßig als Wert des Datums-/Uhrzeitfeldes das kurze Format des Gebietsschemas verwenden, das für das Feld festgelegt wurde. Wenn Sie auf der Registerkarte „Feld“ ein Bearbeitungsmuster festlegen, überschreibt dieses Muster das Kurzformat. Benutzer müssen Daten dann dem Bearbeitungsmuster entsprechend eingeben.
Numerisches Feld oder Dezimalfeld
Für numerische Standardwerte sind beliebige Ganz- oder Dezimalzahlen mit genau einem Dezimalzeichen zulässig. Als Dezimalzeichen kann entweder ein Punkt (.) oder ein Komma (,) verwendet werden, abhängig vom ausgewählten Gebietsschema. Tausender-Trennzeichen (oder Gruppierungssymbole) und Währungssymbole sind als Bestandteil des Standardwertes nicht zulässig.
Wenn z. B. für ein numerisches Feld das Gebietsschema Englisch (USA) festgelegt wird und Sie den Standardwert $1.234,56 festlegen, sind sowohl das Währungssymbol „$“ (Dollarzeichen) als auch der Tausender-Separator „,“ (Komma) nicht gültig.
Textfeld
Ein Standardtextwert kann aus einer beliebigen alphanumerischen Zeichenfolge bestehen und Leerzeichen enthalten. Dies gilt auch für Kennwörter.
Nur die in der Tabelle aufgeführten Felder haben Standardwerte, die der gebietsschemaspezifischen Formatierung entsprechen müssen.
Verwandte Themen
Info über Feldmuster und Wertformatierung
Einfache Muster
Komplexe Feldmuster
Datumsformate
Uhrzeitformate


So legen Sie einen Standardwert fest

Datums-/Uhrzeitfelder, numerische Felder und Textfelder können mit einem (Standard-)Ausgangswert angezeigt werden, wenn das Formular geöffnet wird. Der Wert kann aufgrund einer Laufzeiteigenschaft ermittelt werden. Sie können den Wert jedoch in LiveCycle Designer auch individuell festlegen. Der Wert kann auch mit Hilfe einer Bindung aus einer externen Datenquelle abgerufen werden. Zur Laufzeit formatiert LiveCycle Designer Standardfeldwerte entsprechend dem Gebietsschema, das für jedes Feld festgelegt wurde.
1.
Wählen Sie ein Datums-/Uhrzeitfeld, Dezimalfeld, numerisches Feld oder Textfeld aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“. Wählen Sie in der Liste „Sprache“ ein Gebietsschema aus.
3.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“. Geben Sie den Wert in das Feld „Standard“ ein.
Der Standardwert muss im dem Gebietsschema entsprechenden Format angegeben werden.
Wenn die Daten gebunden sind und ein Datenmuster festgelegt wurde, muss der Wert mit dem auf der Registerkarte „Bindung“ festgelegten Datenmuster übereinstimmen.
Verwandte Themen
Info über Feldmuster und Wertformatierung
Standards für die Wertformatierung
So legen Sie ein Datenmuster fest
Einfache Muster


So legen Sie ein Anzeigemuster fest

Zur Laufzeit werden in LiveCycle Designer Datums- und Uhrzeitfeldwerte sowie numerische Feldwerte im dem Gebietsschema entsprechenden Format angezeigt. Wenn Sie einen Feldwert in einem anderen Format als dem Standardformat anzeigen möchten, können Sie das benutzerdefinierte Muster auf der Registerkarte „Feld“ angeben.
Dropdown-Listen unterstützen Benutzereingaben, lassen jedoch kein Anzeigemuster für benutzerdefinierte Einträge zu. Sie können bei Bedarf ein Skript zur Formatierung der Benutzereingabe erstellen.
Das Anzeigemuster beschreibt, wie Daten im Formular angezeigt werden. Entsprechend werden alle Standardwerte, benutzerseitig eingegebenen Werte und die aus einer Datenbank abgerufenen Werte in das beschriebene Format konvertiert.
Datumsangaben vor dem 1. Januar 1900 werden vom Anzeigemuster nicht formatiert.
1.
Wählen Sie das Datums-/Uhrzeitfeld, numerische Feld oder Textfeld aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“. Wählen Sie in der Liste „Anzeigemuster“ eines der vordefinierten Anzeigemuster aus oder geben Sie ein eigenes Muster ein.
Verwandte Themen
Info über Feldmuster und Wertformatierung
Standards für die Wertformatierung
Einfache Muster


So fordern Sie Benutzer zur Dateneingabe auf

Eingabeaufforderungen eignen sich dann, wenn Benutzer Daten eingeben oder eine Option auswählen sollen. Sie können eine Meldung ausgeben, mit der Sie den Benutzer auffordern, einen Wert in eines der folgenden Felder einzugeben: in ein Datums-/Uhrzeitfeld, ein numerisches Feld oder ein Kennwortfeld. Ebenso kann der Benutzer aufgefordert werden, eine Auswahl aus einer Dropdown-Liste, einem Listenfeld oder einer Optionsfeldgruppe zu treffen.
Wenn Sie eine Meldung für ein Objekt definieren, wird diese in den folgenden Situationen angezeigt:
      •
      Der Benutzer verlässt ein Datums-/Uhrzeitfeld, numerisches Feld, Textfeld, Kennwortfeld oder eine Dropdown-Liste zur Laufzeit, ohne einen Datenwert einzugeben.
      •
      Der Benutzer versucht, Daten mit einer Senden-Schaltfläche zu versenden, obwohl noch kein Wert eingegeben wurde.
Benutzer können ein PDF-Formular nicht absenden, das Leerwerte enthält, wenn die fehlenden Werte erforderlich sind. Sie können jedoch ein PDF-Formular speichern und schließen, ohne die empfohlenen oder erforderlichen Werte anzugeben. In diesem Fall erscheint keine Aufforderung zur Dateneingabe.
1.
Wählen Sie das Feld, die Dropdown-Liste, das Listenfeld oder die Optionsfeldergruppe aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“. Wählen Sie in der Liste „Typ“ eine der folgenden Optionen aus:
      •
      „Benutzereingabe - Empfohlen“
      •
      „Benutzereingabe - Erforderlich“
3.
Geben Sie in das Feld „Meldung bei leerem Feld“ die Benutzereingabe ein. Die Benutzereingabe muss gegebenenfalls dem erforderlichen Eingabeformat entsprechen. Wenn Sie zum Beispiel ein Bearbeitungsmuster definiert haben, muss die Benutzereingabe dem Bearbeitungsmuster entsprechen.
Verwandte Themen
So legen Sie ein Bearbeitungsmuster fest
So überprüfen Sie Benutzereingaben


So legen Sie ein Bearbeitungsmuster fest

Zur Laufzeit werden in LiveCycle Designer Datums- und Uhrzeitfeldwerte sowie numerische Feldwerte im dem Gebietsschema entsprechenden Format angezeigt. Wenn Sie beim Ausfüllen von Formularen zulassen möchten, das Feldwerte in einem anderen Format als dem Standardformat des Gebietsschemas bearbeitet werden, können Sie das Bearbeitungsmuster auf der Registerkarte „Feld“ angeben. Entspricht die Benutzereingabe dem Bearbeitungsmuster nicht, werden die Daten nicht akzeptiert und die Formatierung des Feldwertes wird nicht durchgeführt.
Das Bearbeitungsmuster kann vom Anzeigemuster abweichen. Wenn es für die Benutzer zum Beispiel einfacher ist, kurze Datumsangaben einzugeben und lange Datumsangaben zu lesen, können Sie für das Bearbeitungsmuster des Datums-/Uhrzeitfeldes ein kurzes Datumsformat und für das Anzeigemuster ein langes Datumsformat festlegen. Wenn Anzeige- und Bearbeitungsmuster unterschiedlich sind, wird der Wert entsprechend dem Anzeigemuster formatiert, sobald der Benutzer das Feld verlässt.
1.
Wählen Sie das Datums-/Uhrzeitfeld, numerische Feld, Textfeld oder Kennwortfeld aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“. Geben Sie in der Liste „Bearbeitungsmuster“ ein eigenes Muster ein oder wählen Sie ein vorher eingegebenes Muster in der Liste aus.
Verwandte Themen
Info über Feldmuster und Wertformatierung
Standards für die Wertformatierung
So legen Sie ein Anzeigemuster fest
Einfache Muster


So überprüfen Sie Benutzereingaben

Für die einzelnen Felder sind drei unterschiedliche Überprüfungen möglich. Diese Überprüfungen werden in der folgenden Reihenfolge durchgeführt:
      •
      Testen des Feldes auf Null-Inhalt
      •
      Überprüfen des Formats des Feldwertes anhand eines bestimmten Feldmusters (Weitere Informationen zu Feldmustern finden Sie unter Einfache Muster)
      •
      Aufrufen eines Überprüfungsskripts
Sie können ein Überprüfungsmuster definieren, mit dem Sie die Benutzereingabe für Datums-/Uhrzeitfelder, numerische Felder, Textfelder und Kennwortfelder überprüfen. Standardmäßig werden Leereingaben nicht akzeptiert, wenn ein Wert erforderlich ist. Die Rohwerte werden direkt mit dem Überprüfungsmuster verglichen. Entsprechen sie dem Muster, werden sie für die Anzeige formatiert.
Wenn der eingegebene Wert dem Überprüfungsmuster nicht entspricht, wird ein Programmierfehler oder eine Warnmeldung angezeigt. Die Fehler- oder Warnmeldung wird von Acrobat, Adobe Reader oder LiveCycle Forms erfasst und dann automatisch an den Benutzer weitergegeben. Wenn kein Bearbeitungsmuster festgelegt wurde und die Benutzereingabe dem LiveCycle Designer-Standard nicht entspricht, schlägt die Überprüfung fehl.
Eine Überprüfungsmeldung zeigt an, ob Objekte, die Werte erfordern, Null-Werte enthalten, und der Benutzer versucht, Daten an LiveCycle Forms. zu senden.
Benutzer können ein PDF-Formular speichern und schließen, ohne die erforderlichen Werte bereitzustellen. In diesem Fall wird keine Überprüfung durchgeführt.
Sie können die Standard-Fehlermeldung bzw. -Warnmeldung durch eigene Überprüfungsmustermeldungen ersetzen..
Zur Überprüfung der Benutzereingabe können Sie auch ein Überprüfungsskript einsetzen, und zwar entweder zusätzlich zum Muster, oder dann, wenn ein Überprüfungsmuster nicht unterstützt wird (zum Beispiel bei Optionsfeldergruppen und Kontrollkästchen). Durch die Überprüfung der Eingabe mit einem Skript wird sichergestellt, dass die Daten für Ihre Anwendung verwertet werden können. Eigene Meldungen und Laufzeitfehler-/Warnmeldungen werden hierbei ebenfalls unterstützt.
Sie können ein Überprüfungsmuster mit einem Wert aus einer Datenquelle dynamisch ausfüllen. Dadurch können Sie sicherstellen, dass Benutzer den richtigen Wert in das Feld eingeben.
So legen Sie ein Überprüfungsmuster und eine eigene Meldung fest
1.
Wählen Sie das Datums-/Uhrzeitfeld, numerische Feld, Textfeld, Kennwortfeld, Listenfeld oder die Dropdown-Liste aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“. Wählen Sie in der Liste „Überprüfungsmuster“ eines der vordefinierten Überprüfungsmuster aus oder geben Sie ein eigenes Muster ein.
Bei Datums-/Uhrzeitfeldern, numerischen Feldern, Textfeldern und Kennwortfeldern muss das Überprüfungsmuster mit der Syntax der eingegebenen Werte übereinstimmen. Wenn zum Beispiel ein Bearbeitungsmuster festgelegt wurde, muss das Überprüfungsmuster dem Bearbeitungsmuster entsprechen.
3.
Geben Sie im Feld „Überprüfungsmuster-Meldung“ eine Meldung ein, mit der die Benutzer zur Eingabe des richtigen Wertes aufgefordert werden. Die Meldung sollte das erforderliche Eingabeformat angeben. Wenn Sie einen Zeilenumbruch in der Meldung einfügen möchten, drücken Sie die Steuerungs- und die Eingabetaste gleichzeitig.
4.
Wenn an Stelle der Warnmeldung eine Programmierfehlermeldung erscheinen soll, wählen Sie die Option „Fehler“ aus.
So zeigen Sie eine Meldung an, wenn ein angehängtes Skript eine unzulässige Eingabe feststellt
1.
Wählen Sie das Datums-/Uhrzeitfeld, numerische Feld, Textfeld, Kennwortfeld, Listenfeld, Kontrollkästchen, die Dropdown-Liste oder die Optionsfeldergruppe aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“. Geben Sie in das Feld „Überprüfungsskript-Meldung“ die Meldung ein.
3.
Wenn an Stelle der Warnmeldung eine Programmierfehlermeldung erscheinen soll, wählen Sie die Option „Fehler“ aus.
Verwandte Themen
Info über Feldmuster und Wertformatierung
Standards für die Wertformatierung
So legen Sie ein Bearbeitungsmuster fest
Berechnungen und Skripten
So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus


So legen Sie ein Datenmuster fest

Mit den Datenbindungsoptionen können Sie ein Formular erstellen, das Daten für die Infrastruktur eines Unternehmens erfasst und/oder eine externe Quelle nutzt, um ein Formular zur Laufzeit auszufüllen. Zum Beispiel können Acrobat und Adobe Reader anhand der entsprechenden Bindungsinformationen (siehe Info über das Binden von Feldern an eine Datenquelle) und des Zugriffs auf die Datenquelle (siehe Datenquellen) Daten aus einer OLEDB-Datenbank importieren und anzeigen, wenn das Formular geöffnet wird. Objekte können auch an ein XML-Schema, eine XML-Datei oder eine WSDL-Datenquelle gebunden werden.
Acrobat, Adobe Reader und LiveCycle Forms interpretieren die Datenbindungseigenschaften, um die erfassten Daten zu speichern und die abgerufenen Daten zu verarbeiten. Die Daten eines Objekts werden standardmäßig gespeichert und gemäß den entsprechenden Adobe-Regeln zusammengeführt. Wenn ein Formular in Acrobat oder Adobe Reader geöffnet oder durch LiveCycle Forms wiedergegeben wird, werden die Feldwerte aus der Datenquelle ausgefüllt. Alle benutzerseitigen Änderungen eines Feldwertes werden an die zugehörige Datenquelle übermittelt, wenn das Formular in Acrobat oder Adobe Reader gespeichert wird oder die Daten an LiveCycle Forms gesendet werden.
Wenn die Daten nicht an eine Datenquelle gebunden sind (beispielsweise wenn die Formulardaten per E-Mail zurückgesendet werden), legt das Datenmuster das Format fest, in dem die Daten gespeichert werden. Wenn Sie kein Datenmuster erstellen, werden die Daten im kanonischen Format gespeichert. Wenn ein Formular von Benutzern in verschiedenen Sprachen ausgefüllt werden kann oder wenn die Daten in mehreren Sprachen zurückgegeben werden können, hilft das kanonische Datenformat dabei, dass alle Benutzer die Daten auf die gleiche Weise interpretieren.
Sie können Datenmuster für Datums-/Uhrzeitfelder, numerische Felder, Textfelder und Kennwortfelder festlegen. Wenn das Datenmuster verhindert, dass Acrobat, Adobe Reader oder LiveCycle Forms einen abgerufenen Wert analysieren, wird der Wert im Formular unverändert angezeigt, also nicht für die Anzeige formatiert.
1.
Wählen Sie das Datums-/Uhrzeitfeld, numerische Feld, Textfeld oder Kennwortfeld aus.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“. Wählen Sie in der Liste „Datenmuster“ eines der vordefinierten Datenbindungsmuster aus oder geben Sie ein eigenes Muster ein.
Verwandte Themen
Info über Feldmuster und Wertformatierung
Standards für die Wertformatierung


Einfache Muster

Mit einfachen Mustern können Sie die Werte von Datums-/Uhrzeitfeldern, numerischen Feldern, Textfeldern und Kennwortfeldern formatieren. Diese folgen jeweils eigenen Regeln zur gültigen Formatierung von Mustern. Für Muster kann nur ein begrenzter Zeichensatz verwendet werden. Die Syntax gültiger Muster ist unterschiedlich, je nachdem, ob es sich um Datums-/Uhrzeitfelder, numerische Felder, Textfelder oder Kennwortfelder handelt.
Klicken Sie auf einen der folgenden Abschnitte, um mehr über gültige Zeichen in einem Muster zu erfahren und Beispiele gültiger Muster abzurufen. Weitere Informationen zu komplexen Mustern für Datums-/Uhrzeitfelder, numerische Felder oder Textfelder finden Sie unter Komplexe Feldmuster.
Verwandte Themen
Standards für die Wertformatierung
Datums- und Uhrzeitmuster
Numerische Muster
Textfeldmuster
Kennwortmuster


Gebietsschemata

Ein Gebietsschema ist ein Standardbegriff, der bei der Entwicklung internationaler Standards zur Identifizierung einer bestimmten Nationalität (Sprache und/oder Land) dient. In FormCalc legt ein Gebietsschema die für ein bestimmtes Land oder für eine bestimmte Region gültigen Datums-, Uhrzeit-, Zahlen- und Währungsformate fest, um zu gewährleisten, dass die Endbenutzer die gewohnten Formate verwenden können.
Jedes Gebietsschema besteht aus einer eindeutigen Zeichenfolge, der Gebietsschema-Kennung. Der Inhalt dieser Zeichenfolgen wird von der Internationalen Standardisierungsorganisation (ISO) Internet Engineering Task Force (IETF) kontrolliert, die eine Arbeitsgruppe der Internet Society ist (www.isoc.org).
Gebietsschema-Kennungen bestehen aus einem Sprachenteil, einem Länderteil oder beidem. Die folgende Tabelle enthält die gültigen Gebietsschemata für diese Version von LiveCycle Designer:

Sprache

Land

ISO-Code
Arabisch
Vereinigte Arabische Emirate
ar_AE
Arabisch
Bahrain
ar_BH
Arabisch
Algerien
ar_DZ
Arabisch
Ägypten
ar_EG
Arabisch
Irak
ar_IQ
Arabisch
Jordanien
ar_JO
Arabisch
Kuwait
ar_KW
Arabisch
Libanon
ar_LB
Arabisch
Libyen
ar_LY
Arabisch
Marokko
ar_MA
Arabisch
Oman
ar_OM
Arabisch
Katar
ar_QA
Arabisch
Saudi-Arabien
ar_SA
Arabisch
Sudan
ar_SD
Arabisch
Syrien
ar_SY
Arabisch
Tunesien
ar_TN
Arabisch
Jemen
ar_YE
Bulgarisch
Bulgarien
bg_BG
Chinesisch
Hongkong
zh_HK
Chinesisch
Volksrepublik China (vereinfacht)
zh_CN
Chinesisch
Taiwan (traditionell)
zh_TW
Dänisch
Dänemark
da_DK
Deutsch
Österreich
de_AT
Deutsch
Deutschland
de_DE
Deutsch
Luxemburg
de_LU
Deutsch
Schweiz
de_CH
Englisch
Australien
en_AU
Englisch
Kanada
en_CA
Englisch
Indien
en_IN
Englisch
Irland
en_IE
Englisch
Neuseeland
en_NZ
Englisch
Südafrika
en_ZA
Englisch
Großbritannien
en_GB
Englisch
Großbritannien (Europa)
en_GB_EURO
Englisch
Vereinigte Staaten von Amerika
en_US
Estnisch
Estland
et_EE
Finnisch
Finnland
fi_FI
Flämisch
Belgien
nl_BE
Französisch
Belgien
fr_BE
Französisch
Kanada
fr_CA
Französisch
Frankreich
fr_FR
Französisch
Luxemburg
fr_LU
Französisch
Schweiz
fr_CH
Griechisch
Griechenland
el_GR
Hebräisch
Israel
he_IL
Indonesisch
Indonesien
id_ID
Italienisch
Italien
it_IT
Italienisch
Schweiz
it_CH
Japanisch
Japan
ja_JP
Koreanisch
Republik Korea
ko_KR
Koreanisch
Korea (Hanja-Zeichen)
ko_KR_HANI
Kroatisch
Kroatien
hr_HR
Lettisch
Lettland
lv_LV
Litauisch
Litauen
lt_LT
Malaiisch
Malaysia
ms_MY
Niederländisch
Niederlande
nl_NL
Norwegisch (Bokmal)
Norwegen
nb_NO
Norwegisch (Nynorsk)
Norwegen
nn_NO
Polnisch
Polen
pl_PL
Portugiesisch
Brasilien
pt_BR
Portugiesisch
Portugal
pt_PT
Rumänisch
Rumänien
ro_RO
Russisch
Russland
ru_RU
Schwedisch
Schweden
sv_SE
Serbokroatisch
Bosnien und Herzegowina
sh_BA
Serbokroatisch
Kroatien
sh_HR
Serbokroatisch
Serbien und Montenegro
sh_CS
Slowakisch
Slowakei
sk_SK
Slowenisch
Slowenien
sl_SI
Spanisch
Ecuador
es_EC
Spanisch
El Salvador
es_SV
Spanisch
Guatemala
es_GT
Spanisch
Honduras
es_HN
Spanisch
Nicaragua
es_NI
Spanisch
Panama
es_PA
Spanisch
Paraguay
es_PY
Spanisch
Puerto Rico
es_PR
Spanisch
Uruguay
es_UY
Spanisch
Argentinien
es_AR
Spanisch
Bolivien
es_BO
Spanisch
Chile
es_CL
Spanisch
Kolumbien
es_CO
Spanisch
Costa Rica
es_CR
Spanisch
Dominikanische Republik
es_DO
Spanisch
Mexiko
es_MX
Spanisch
Peru
es_PE
Spanisch
Spanien
es_ES
Spanisch
Venezuela
es_VE
Thailändisch
Thailand
th_TH
Thailändisch
Thailand, traditionell
th_TH_TH
Tschechisch
Tschechische Republik
cs_CAZ
Türkisch
Türkei
tr_TR
Ukrainisch
Ukraine
uk_UA
Ungarisch
Ungarn
hu_HU
Vietnamesisch
Vietnam
vi_VN
In der Regel sind beide Elemente eines Gebietsschemas von Bedeutung. Beispielsweise werden die Namen der Wochentage und Monate in Englisch für Kanada und Großbritannien identisch formatiert, Datumsangaben aber unterschiedlich. Daher ist die Angabe der Sprache Englisch als Gebietsschema nicht ausreichend. Die Angabe nur des Landes als Gebietsschema ist ebenfalls unzureichend. So gibt es für Kanada unterschiedliche Datumsformate für Englisch und Französisch.
Grundsätzlich wird jede Anwendung in einer Umgebung eingesetzt, in der ein Gebietsschema vorhanden ist. Dieses Gebietsschema wird als Umgebungsgebietsschema bezeichnet. Unter bestimmten Umständen wird eine Anwendung auf einem System oder in einer Umgebung ausgeführt, in der kein Gebietsschema vorhanden ist. In diesen seltenen Fällen wird das Umgebungsgebietsschema auf den Standardwert Englisch, USA gesetzt (en_US). Dieses Gebietsschema wird als Standardgebietsschema bezeichnet.
Verwandte Themen
Epoche
Datumsformate
Uhrzeitformate
Datums- und Uhrzeitmuster


Epoche

Sowohl den Datums- als auch den Uhrzeitwerten ist ein Ursprung oder eine Epoche zugeordnet, d. h. ein Zeitpunkt, an dem die Zeitrechnung begonnen wurde. Alle Datums- und Uhrzeitwerte, die vor dieser Epoche liegen, sind ungültig.
Die Werteinheit für Datumsfunktionen ist die seit Beginn der Epoche verstrichene Anzahl von Tagen. Die Werteinheit für Uhrzeitfunktionen ist die seit Beginn der Epoche verstrichene Anzahl von Millisekunden.
In LiveCycle Designer ist der erste Tag der Epoche für die Datumsfunktionen der 1. Januar 1900 und die erste Millisekunde der Epoche für die Uhrzeitfunktionen ist Mitternacht, 00:00:00, Greenwich Mean Time (GMT). Aus dieser Definition folgt, dass für Benutzer in Zeitzonen östlich der Greenwich Mean Time eventuell negative Uhrzeitwerte zurückgegeben werden.
Verwandte Themen
Gebietsschemata
Datumsformate
Uhrzeitformate
Datums- und Uhrzeitmuster


Datumsformate

Ein Datumsformat gibt in Kurzform an, wie das Datum dargestellt wird. Es besteht aus mehreren Interpunktionszeichen und Symbolen, die das Format angeben, in dem das Datum dargestellt werden soll. Die folgende Tabelle zeigt einige Beispiele für Datumsformate:

Datumsformat

Beispiel
MM/DD/YY
11/11/78
DD/MM/YY
25/07/85
MMMM DD, YYYY
März 10, 1964
Das Datumsformat wird von einem ISO-Standard bestimmt. Jedes Land bzw. jede Region legt ihr eigenes Datumsformat fest. Dabei stehen eine kurze, eine mittlere, eine lange und eine vollständige Formatkategorie zur Auswahl. In der folgenden Tabelle sind Beispiele zu den unterschiedlichen Datumsformaten in verschiedenen Gebietsschemata für die einzelnen Kategorien aufgeführt.

Gebietsschema-Kennung und Beschreibung

Datumsformat (Kategorie)

Beispiel
en_GB
Englisch (Großbritannien)
DD/MM/YY(kurz)
08/18/92
08/04/05
fr_CA
Französisch (Kanada)
YY-MM-DD (mittel)
92-08-18
de_DE
Deutsch (Deutschland)
D. MMMM YYYY (lang)
17. Juni 1989
fr_FR
Französisch (Frankreich)
EEEE, 'le' T MMMM YYYY (vollständig)
Lundi, le 29 Octobre, 1990
Verwandte Themen
Gebietsschemata
Epoche
Uhrzeitformate
Datums- und Uhrzeitmuster


Uhrzeitformate

Ein Zeitformat gibt in Kurzform an, wie die Uhrzeit formatiert wird. Es besteht aus Interpunktionszeichen, Literalen und Mustersymbolen. Die folgende Tabelle zeigt einige Beispiele für Uhrzeitformate:

Uhrzeitformat

Beispiel
h:MM A
19:15 Uhr
HH:MM:SS
21:35:26
HH:MM:SS 'o''clock' A Z
14:20:10 o’clock PM EDT
Uhrzeitformate werden von einer ISO-Norm bestimmt. Jedes Land legt die Form seiner Uhrzeitformate in einer Standard- sowie einer kurzen, mittleren, langen und vollständigen Variante fest. Im Gebietsschema wird das Format der Uhrzeiten festgelegt, die den Standards des betreffenden Landes entsprechen.
In der folgenden Tabelle sind einige Beispiele für die unterschiedlichen Datumsformate in verschiedenen Gebietsschemata für die einzelnen Kategorien aufgeführt.

Gebietsschema-Kennung und Beschreibung

Uhrzeitformat (Kategorie)

Beispiel
en_GB
Englisch (Großbritannien)
HH:MM (kurz)
14:13
fr_CA
Französisch (Kanada)
HH:MM:SS (mittel)
12:15:50
de_DE
Deutsch (Deutschland)
HH:MM:SS z (lang)
14:13:13 -0400
fr_FR
Französisch (Frankreich)
HH ‘h‘ MM Z (vollständig)
14 h 13 GMT-04:00
Verwandte Themen
Gebietsschemata
Epoche
Datumsformate
Datums- und Uhrzeitmuster


Datums- und Uhrzeitmuster

Die folgenden Symbole müssen verwendet werden, um Datums- und Uhrzeitmuster für Datums-/Uhrzeitfelder zu erstellen. Bestimmte Datumssymbole werden nur in den Gebietsschemata für Chinesisch, Japanisch und Koreanisch verwendet. Diese Symbole werden unten auch angegeben.
Komma (,), Bindestrich (-), Doppelpunkt (:), Schrägstrich (/), Punkt (.) und Leerzeichen ( ) werden als Literalwerte behandelt und können an einer beliebigen Stelle in einem Muster vorkommen. Wenn eine Wortfolge in ein Muster aufgenommen werden soll, schließen Sie sie in einfache Anführungszeichen (') ein. Beispielsweise kann 'Your payment is due no later than' MM-DD-YY als Anzeigemuster festgelegt werden.

Datumssymbol

Beschreibung

Formatierter Wert für das Gebietsschema Englisch (USA). Dabei lautet der dem Gebietsschema entsprechende Eingabewert 1/1/08 (dies bedeutet „January 1, 2008“).

D
1- oder 2-stelliger (1-31) Tag des Monats
1

DD
Mit 0 aufgefüllter 2-stelliger (01-31) Tag des Monats
01

J
1-, 2- oder 3-stelliger (1-366) Tag des Jahres
1

JJJ
Mit 0 aufgefüllter dreistelliger (001-366) Tag des Jahres
001

M
Ein- oder zweistelliger (1-12) Monat des Jahres
1

MM
Mit 0 aufgefüllter zweistelliger (01-12) Monat des Jahres
01

MMM
Abgekürzter Monatsname
Jan

MMMM
Vollständiger Monatsname
Januar

E
Einstelliger (1-7) Tag der Woche: 1=Sonntag
3 (weil der 1. Januar 2008 auf einen Dienstag fällt)

EEE
Abgekürzter Wochentag
Tue (weil der 1. Januar 2008 auf einen Dienstag [engl. „Tuesday“] fällt)

EEEE
Vollständiger Wochentag
Tuesday (weil der 1. Januar 2008 auf einen Dienstag [engl. „Tuesday“] fällt)

YY
Zweistellige Jahreszahl, wobei Zahlen unter 30 als Jahresangaben nach dem Jahr 2000 und Zahlen ab 30 als Jahresangaben vor dem Jahr 2000 zu verstehen sind. Beispiele: 00=2000, 29=2029, 30=1930 und 99=1999
08

YYYY
Vierstellige Jahreszahl
2008

G
Epochenname (v. Chr. oder n. Chr.)
AD (engl. für „n. Chr.“)

w
Einstellige (0-5) Wochennummer des Monats: Woche 1 ist die früheste auf einen Samstag endende Sequenz von vier aufeinander folgenden Tagen
1

WW
Zweistellige (01-53) Woche des Jahres gemäß ISO-8601: Woche 1 ist die Woche, die den 4. Januar enthält
01
Es sind verschiedene weitere Datumsmuster für die Darstellung von Daten in den Gebietsschemata für Chinesisch, Japanisch und Koreanisch verfügbar.
Japanische Epochen können anhand verschiedener Symbole dargestellt werden. Die letzten vier Epochensymbole sind alternative Symbole für die Darstellung japanischer Ären.

Datensymbol (Chinesisch, Japanisch, Koreanisch)

Beschreibung

DDD
Der ideografisch-numerisch festgelegte Tag des Monats im Gebietsschema.

DDDD
Der nach der Zehnerregel ideografisch-numerisch festgelegte Tag des Monats im Gebietsschema.

YYY
Das ideografisch-numerisch festgelegte Jahr im Gebietsschema.

YYYYY
Das nach der Zehnerregel ideografisch-numerisch festgelegte Jahr im Gebietsschema.

g
Der alternative Epochenname des Gebietsschemas. Für die gegenwärtige japanische Epoche Heisei zeigt dieses Muster das ASCII-Zeichen H (U+48) an.

gg
Der alternative Epochenname des Gebietsschemas. Für die gegenwärtige japanische Epoche zeigt dieses Muster das Kanji an, das dem Unicode-Symbol (U+5E73) entspricht.

ggg
Der alternative Epochenname des Gebietsschemas. Für die gegenwärtige japanische Epoche zeigt dieses Muster die Kanjis an, die den Unicode-Symbolen (U+5E73 U+6210) entsprechen.

 g
Der alternative Epochenname des Gebietsschemas. Für die gegenwärtige japanische Epoche zeigt dieses Muster das ASCII-Zeichen H (U+FF28) in voller Breite an.

 g g
Der alternative Epochenname des Gebietsschemas. Für die gegenwärtige japanische Epoche zeigt dieses Muster das Kanji an, das dem Unicode-Symbol (U+337B) entspricht.

Zeitsymbol

Beschreibung

Dem Gebietsschema entsprechender Eingabewert

Formatierter Wert für das Gebietsschema Englisch (USA)

h
Ein- oder zweistellige (1-12) Stunde im 12-Stunden-System (AM/PM)
12:08 AM oder 2:08 PM
12 oder 2

hh
Mit 0 aufgefüllte zweistellige (01-12) Stunde im 12-Stunden-System (AM/PM)
12:08 AM oder 2:08 PM
12 oder 02

k
Ein- oder zweistellige (0-11) Stunde im 12-Stunden-System (AM/PM)
12:08 AM oder 2:08 PM
0 oder 2

kk
Zweistellige (00-11) Stunde im 12-Stunden-System (AM/PM)
12:08 AM oder 2:08 PM
00 oder 02

H
Ein- oder zweistellige (0-23) Stunde des Tages
12:08 AM oder 2:08 PM
0 oder 14

HH
Mit 0 aufgefüllte zweistellige (00-23) Stunde des Tages
12:08 AM oder 2:08 PM
00 oder 14

K
Ein- oder zweistellige (1-24) Stunde des Tages
12:08 AM oder 2:08 PM
24 oder 14

KK
Mit 0 aufgefüllte zweistellige (01-24) Stunde des Tages
12:08 AM oder 2:08 PM
24 oder 14

M
Ein- oder zweistellige (0-59) Minute der Stunde
Sie müssen dieses Symbol zusammen mit einem Stundensymbol verwenden.
2:08 PM
8

MM
Mit 0 aufgefüllte zweistellige (00-59) Minute der Stunde
Sie müssen dieses Symbol zusammen mit einem Stundensymbol verwenden.
2:08 PM
08

S
Ein- oder zweistellige (0-59) Sekunde der Minute
Sie müssen dieses Symbol zusammen mit einem Stunden- und Minutensymbol verwenden.
2:08:09 PM
9

SS
Mit 0 aufgefüllte zweistellige (00-59) Sekunde der Minute
Sie müssen dieses Symbol zusammen mit einem Stunden- und Minutensymbol verwenden.
2:08:09 PM
09

FFF
Dreistellige (000-999) Tausendstelsekunde
Sie müssen dieses Symbol zusammen mit einem Stunden-, Minuten- und Sekundensymbol verwenden.
2:08:09 PM
09

A
Der Zeitraum von Mitternacht bis Mittag (AM) bzw. von Mittag bis Mitternacht (PM)
2:08:09 PM
PM

z
Zeitzonenformat nach ISO-8601 (z. B. Z, +0500, -0030, -01, +0100)
Sie müssen dieses Symbol zusammen mit einem Stundensymbol verwenden.
2:08:09 PM
-0400

zz
Alternatives ISO-8601 Zeitzonenformat (z. B. Z, +05:00, -00:30, -01, +01:00)
Sie müssen dieses Symbol zusammen mit einem Stundensymbol verwenden.
2:08:09 PM
-04:00

Z
Abgekürzter Zeitzonenname (z. B. GMT, GMT+05:00, GMT-00:30, EST, PDT)
Sie müssen dieses Symbol zusammen mit einem Stundensymbol verwenden.
2:08:09 PM
EDT
Reservierte Symbole
Die folgenden Symbole haben spezielle Bedeutungen und können nicht als Literalzeichen im Text verwendet werden.
?
Das Symbol entspricht einem beliebigen Zeichen. Wenn es für die Anzeige zusammengeführt wird, wandelt es sich zu einem Leerzeichen.

*
Das Symbol steht beim Senden für 0 oder für UNICODE-Leerzeichen. Wenn es für die Anzeige zusammengeführt wird, wandelt es sich zu einem Leerzeichen.

+
Das Symbol steht beim Senden für ein oder mehrere UNICODE-Leerzeichen. Wenn es für die Anzeige zusammengeführt wird, wandelt es sich zu einem Leerzeichen.
Verwandte Themen
Info über Feldmuster und Wertformatierung
Komplexe Feldmuster
Datumsformate
Uhrzeitformate
Beispiele für Datums-/Uhrzeitmuster


Komplexe Feldmuster

Zusätzlich zu einfachen Mustern für Datums-/Uhrzeitfelder, numerische Felder und Textfelder können Sie ein sprachenspezifisches Muster festlegen oder variable Muster verarbeiten.
Sprachenmuster
Wenn Sie eine bestimmte Sprache unabhängig von der einem Objekt bereits zugewiesenen Sprache für ein Muster festlegen möchten, können Sie ein Sprachenmuster definieren. Die Syntax eines Sprachenmusters ist folgendermaßen definiert:
category_name(locale_name){pattern}
Hierbei gilt:
      •
      category_name kann vom Typ date, time, num oder text sein.
      •
      locale_name wird durch einen Sprach- und/oder Ländercode gekennzeichnet, wie in RFC 1766 (Tags for the Identification of Languages – Tags zur Kennzeichnung von Sprachen, 1995) angegeben.
      •
      pattern ist das einfache Muster zur Verarbeitung von Werten.
Wenn Sie zum Beispiel für ein Datums-/Uhrzeitfeld zwingend vorgeben möchten, ein Datum entsprechend dem Ländercode für Frankreich anzuzeigen, müssten Sie das Muster folgendermaßen definieren:
date(fr_FR){DD MMMM, YYYY}
Variable Muster
Wenn Benutzereingaben oder gebundene Daten in mehreren Formaten vorliegen (beispielsweise für eine Telefonnummer mit oder ohne Vorwahl), können Sie ein Muster definieren, das diese Unterschiede berücksichtigt. Zur Definition mehrerer zulässiger Muster gilt die folgende Syntax:
category_name{pattern}|category_name{pattern}|category_name{pattern}
Hierbei werden die einzelnen Muster durch einen senkrechten Strich (|) getrennt. Sie können beliebig viele Muster angeben. Das folgende Beispiel lässt zwei verschiedene Textmuster zu:
text{999*9999}|text{999*999*9999}
Verwandte Themen
Einfache Muster


Objekte für andere Sprachen einrichten

So richten Sie Objekte für Arabisch und Hebräisch ein
So richten Sie Objekte für Thailändisch und Vietnamesisch ein
So richten Sie ein Datumsfeld für andere Sprachen ein


So richten Sie Objekte für Arabisch und Hebräisch ein

Objekte – die Bausteine von Formularen – haben je nach der Sprache, für die ein Formular entworfen wird, ein unterschiedliches Aussehen.
So steht bei einer Dropdown-Liste in einem deutschen Formular die Beschriftung in der Regel links, während sich der Pfeil auf der rechten Seite befindet. In arabischen und hebräischen Formularen ist dies jedoch in der Regel genau umgekehrt, da es sich um von rechts nach links gelesene Sprachen handelt.
Um ein Objekt für Arabisch oder Hebräisch einzurichten, müssen Sie folgende Schritte ausführen:
      •
      Als Gebietsschema Arabisch oder Hebräisch festlegen
      •
      Die Beschriftung auf der rechten Seite positionieren (außer bei Kontrollkästchen und Optionsfeldern, bei denen die Beschriftung links platziert werden muss)
      •
      Die Beschriftung und den Wert rechtsbündig ausrichten
      •
      Eine von diesen Sprachen unterstützte Schrift auswählen
Arabisch und Hebräisch muss bei folgenden Objekten gesondert eingerichtet werden:
      •
      Kontrollkästchen
      •
      Datums-/Uhrzeitfelder
      •
      Dezimalfelder
      •
      Dokumentunterschriftsfelder
      •
      Dropdown-Listen
      •
      Listenfelder
      •
      Numerische Felder
      •
      Kennwortfelder
      •
      Optionsfelder
      •
      Textfelder
Die in diesem Hilfethema beschriebenen Funktionen sind nur verfügbar, wenn die Unterstützung für die entsprechenden Sprachen in den Microsoft Office-Spracheinstellungen aktiviert wurde.
LiveCycle Forms 7.1 bietet keine Unterstützung für Formularentwürfe mit arabischen, hebräischen, thailändischen und vietnamesischen Schriftzeichen.
1.
Fügen Sie das Objekt hinzu.
Ziehen Sie beispielsweise das Objekt „Dropdown-Liste“ aus der Palette „Bibliothek“ auf den Formularentwurf.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
3.
Wählen Sie im Feld „Sprache“ eine Sprache und ein Land aus.
Wählen Sie beispielsweise „Arabisch (Bahrain)“ aus.
4.
Wählen Sie das Objekt aus.
5.
Wählen Sie in der Palette „Schrift“ eine Schrift aus, von der das Gebietsschema unterstützt wird.
So unterstützt Adobe Arabic beispielsweise Arabisch und Adobe Hebrew Hebräisch. Falls die erforderlichen Schriften noch nicht auf dem System installiert sind, können Sie sie aus dem Internet herunterladen.
6.
Wählen Sie das Objekt aus.
7.
Klicken Sie in der Palette „Absatz“ auf „Rechtsbündig“, um die Beschriftung und den Wert rechtsbündig auszurichten.
8.
Wählen Sie in der Palette „Layout“ in der Liste „Position“ die gewünschte Position für die Beschriftung aus.

Objekt

Position
Kontrollkästchen
Links
Datums-/Uhrzeitfelder
Rechts
Dezimalfelder
Rechts
Dokumentunterschriftsfelder
Rechts
Dropdown-Listen
Rechts
Listenfelder
Rechts
Numerische Felder
Rechts
Kennwortfelder
Rechts
Optionsfelder
Links
Textfelder
Rechts
9.
Zeigen Sie eine Vorschau des Objekts auf der Registerkarte „PDF-Vorschau“ an, um sicherzustellen, dass es wie erwartet aussieht.


So richten Sie Objekte für Thailändisch und Vietnamesisch ein

Um ein Objekt für Thailändisch oder Vietnamesisch einzurichten, müssen Sie folgende Schritte ausführen:
      •
      Als Gebietsschema Thailändisch oder Vietnamesisch festlegen
      •
      Eine von diesen Sprachen unterstützte Schrift auswählen
Die in diesem Hilfethema beschriebenen Funktionen sind nur verfügbar, wenn die Unterstützung für die entsprechenden Sprachen in den Microsoft Office-Spracheinstellungen aktiviert wurde.
LiveCycle Forms 7.1 bietet keine Unterstützung für Formularentwürfe mit arabischen, hebräischen, thailändischen und vietnamesischen Schriftzeichen.
1.
Fügen Sie das Objekt hinzu.
Ziehen Sie beispielsweise das Objekt „Dropdown-Liste“ aus der Palette „Bibliothek“ auf den Formularentwurf.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“.
3.
Wählen Sie im Feld „Sprache“ eine Sprache und ein Land aus.
Wählen Sie beispielsweise „Thailändisch (Thailand, traditionell)“ aus.
4.
Wählen Sie das Objekt aus.
5.
Wählen Sie in der Palette „Schrift“ eine Schrift aus, von der das Gebietsschema unterstützt wird.
Adobe Thai unterstützt beispielsweise Thailändisch, und Myriad® Pro and Minion® Pro unterstützen Vietnamesisch. Falls die erforderlichen Schriften noch nicht auf dem System installiert sind, können Sie sie aus dem Internet herunterladen.
6.
Zeigen Sie eine Vorschau des Objekts auf der Registerkarte „PDF-Vorschau“ an, um sicherzustellen, dass es wie erwartet aussieht.


So richten Sie ein Datumsfeld für andere Sprachen ein

1.
Vergewissern Sie sich, dass die Regional- und Sprachoptionen in der Systemsteuerung von Microsoft Windows® auf die richtige Sprache eingestellt sind.
2.
Ziehen Sie in LiveCycle Designer aus der Palette „Bibliothek“ das Objekt „Datums-/Uhrzeitfeld“ auf den Formularentwurf.
3.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und geben Sie im Feld „Anzeigemuster“ den Text DD/MM/gYY ein.
Für Daten in Thailändisch verwenden Sie beispielsweise Folgendes:
      •
      g zeigt die buddhistische Zeitrechnung an
      •
      gg zeigt die Abkürzung der buddhistischen Zeitrechnung in Thailändisch an
      •
      ggg zeigt den vollständigen Namen der buddhistischen Zeitrechnung in Thailändisch an
4.
Auf der Registerkarte „PDF-Vorschau“ sehen das Datums-/Uhrzeitfeld und der Kalender folgendermaßen aus:
Und so sieht der Kalender aus, wenn Sie das Gebietsschema und die Sprache für die anderen drei Sprachen auswählen:


Besondere Objekte verwenden

Info über besondere Objekte
So definieren Sie ein globales Feld
So fügen Sie ein schwebendes Feld ein
So fügen Sie Laufzeiteigenschaften ein
So fügen Sie einem Formular Variablen hinzu


Info über besondere Objekte

Außer den Standard- und benutzerdefinierten Objekten in der Palette „Bibliothek“ gibt es in LiveCycle Designer eine Reihe von Objekten und/oder Eigenschaften, die ein Formular zur Laufzeit mit einer besonderen Funktionalität versehen. Zu diesen Objekten und Eigenschaften gehören:
      •
      Globale Felder
      •
      Felder in Fließtext/schwebende Felder
      •
      Laufzeiteigenschaften
      •
      Variablen
Verwandte Themen
So definieren Sie ein globales Feld
So fügen Sie ein schwebendes Feld ein
So fügen Sie Laufzeiteigenschaften ein
So fügen Sie einem Formular Variablen hinzu


So definieren Sie ein globales Feld

Globale Felder enthalten Informationen, die in Ihrem Formular an mehreren Stellen angezeigt werden. Eine Rechnung enthält beispielsweise eine Rechnungsnummer, die auf dem Formular mehrfach angegeben wird. Im Formularentwurf können Sie die Rechnungsnummer als globales Feld definieren und nach Bedarf verwenden.
Globale Felder eignen sich vor allem dann, wenn Informationen an mehreren Stellen angezeigt werden. Mit globalen Feldern sinkt nicht nur die zu sendende Datenmenge, sondern es wird zugleich sichergestellt, dass an den wichtigen Stellen des Formulars genau dieselben Daten enthalten sind.
Anhand der Bindungseigenschaft „Global“ können Sie denselben Wert allen gleichnamigen Objekten im Formular zuweisen.
Wenn Sie die globale Einstellung auf ein Objekt anwenden, werden alle Objekte mit dem gleichen Namen zur Laufzeit an die gleichen Daten gebunden. Da globale Objekte gleichen Namens mit dem gleichen Datenwert verknüpft werden, werden die in einem globalen Objekt angezeigten Daten automatisch in allen anderen globalen Objekten gleichen Namens angezeigt. Es kann nicht mehrere identisch benannte Objekte in einem Formular geben, wenn für einige, aber nicht alle Objekte „Global“ festgelegt ist.
Sie können die globale Bindungseinstellung auf die folgenden Objekte anwenden:
      •
      Kontrollkästchen
      •
      Datums-/Uhrzeitfelder
      •
      Dropdown-Listen
      •
      Bildfelder
      •
      Listenfelder
      •
      Numerische Felder
      •
      Kennwortfelder
      •
      Optionsfelder
      •
      Textfelder
Wenn Sie die Eigenschaftseinstellung „Global“ einem Objekt zuweisen, wendet LiveCycle Designer den globalen Wert automatisch auf alle anderen gleichnamigen Objekte im Formular an. Wenn Sie hingegen die globale Einstellung aus einem Objekt entfernen, entfernt LiveCycle Designer den Wert von allen anderen Objekten mit dem gleichen Namen und der gleichen Einstellung.
Wenn Sie die globale Bindung auf ein Objekt anwenden, können Sie keine Laufzeiteigenschaften, wie z. B. aktuelle Seite, Anzahl der Seiten und aktuelles Datum/aktuelle Uhrzeit zu diesem Objekt hinzufügen.
1.
Fügen Sie dem Formularentwurf die erforderlichen Objekte hinzu.
2.
Weisen Sie jedem Objekt denselben Namen zu.
3.
Wählen Sie eines der gleichnamigen Objekte aus.
4.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und wählen Sie in der Liste „Standardbindung“ die Option „Global“ aus. In LiveCycle Designer wird eine Meldung angezeigt, in der bestätigt wird, dass die globale Bindung auf alle Objekte angewendet wird, die den gleichen Namen haben wie das ausgewählte Objekt.
Verwandte Themen
Datenquellen
So können Sie Objekte benennen und umbenennen


So fügen Sie ein schwebendes Feld ein

Sie können ein schwebendes Feld in ein Textobjekt einfügen, um verschiedene Arten von Informationen anzuzeigen.
Schwebende Felder sind Objekte, die das Zusammenführen von Text, numerischen Werten, Laufzeiteigenschaften und Skripten in einem Textobjekt bei der Darstellung des Formulars unterstützen. Sie können schwebende Felder nur in Textobjekte einfügen.
Schwebende Felder sind standardmäßig Textfeldobjekte, jedoch können Sie den Objekttyp in der Liste „Typ“ auf der Registerkarte „Feld“ der Palette „Objekt“ ändern.
Sie können schwebende Felder an eine Datenquelle binden, um einen bestimmten Text oder numerische Werte anzuzeigen. Sie können beispielsweise ein schwebendes Feld einfügen, um individuelle Kundennamen in die Begrüßungsformel eines Formularbriefs einzubinden. Das schwebende Feld erscheint als Textfeldobjekt, wie das folgende Beispiel zeigt.
(Sehr geehrte/r Frau/Herr {Textfeld})
Sie müssen die Eigenschaften des schwebenden Feldobjekts unabhängig von der Einstellung des Textobjekts vornehmen. Standardmäßig sind schwebende Feldobjekte in der Liste „Präsenz“ auf „Ausgeblendet (Aus Layout ausschließen)“ eingestellt.
1.
Klicken Sie in das Textobjekt, in das Sie das schwebende Textfeldobjekt platzieren möchten.
2.
Positionieren Sie Ihren Cursor auf die Zeile, in die LiveCycle Designer das schwebende Textfeldobjekt einfügen soll.
3.
Wählen Sie „Einfügen“ > „Feld in Fließtext“.
4.
Um die Eigenschaften des schwebenden Feldes einzustellen, klicken Sie auf die Markierung „Feld in Fließtext“ im Objekt „Text“ und wählen Sie dann die Optionen nach Bedarf aus. Es ist zu empfehlen, das schwebende Textfeldobjekt umzubenennen und die nötige Bindung festzulegen.
Verwandte Themen
So fügen Sie Laufzeiteigenschaften ein


So fügen Sie Laufzeiteigenschaften ein

Mit Hilfe von Laufzeiteigenschaften können Sie in einem Formularentwurf bestimmte Arten von Informationen zur Laufzeit anzeigen. Zu den Informationen, die Sie anzeigen können, gehören die aktuelle Seite, die Anzahl der Seiten, das aktuelle Datum/die aktuelle Uhrzeit, das Gebietsschema, der Name und die Version des Anzeigeprogramms.
Laufzeiteigenschaften können in die folgenden Objekte eingefügt werden:
      •
      Numerisches Feld
      •
      Text
      •
      Textfeld
Verwenden Sie die Befehle im Menü „Einfügen“, um Laufzeiteigenschaften zu einem Textobjekt hinzuzufügen. Alternativ können Sie auch die Liste „Typ“ verwenden, um einem Textfeldobjekt oder einem numerischen Feldobjekt Laufzeiteigenschaften hinzuzufügen.
In beiden Fällen fügt LiveCycle Designer ein schwebendes Feld sowie ein Berechnungsskript hinzu, das den beabsichtigten Wert und einen Standardwert auf der Basis der Eigenschaft für das ausgewählte Objekt erzeugt. LiveCycle Designer benennt auch das schwebende Feld gemäß der von Ihnen ausgewählten Laufzeiteigenschaft.
Wenn Sie die Laufzeiteigenschaft der aktuellen Seite zu einem Objekt hinzufügen, wenden Sie nicht die Option der globalen Bindung an, da LiveCycle Designer in diesem Fall auf jeder Seite die gleiche Seitennummer statt einmaliger Werte anwendet.
So fügen Sie einem Textobjekt eine Laufzeiteigenschaft hinzu
1.
Klicken Sie auf das Textfeld.
2.
Wählen Sie „Einfügen“ und wählen Sie die Laufzeiteigenschaft aus, die Sie hinzufügen möchten.
So fügen Sie einem Textfeld oder einem numerischen Feldobjekt eine Laufzeiteigenschaft hinzu
1.
Klicken Sie auf das Textfeld bzw. das numerische Feld.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und wählen Sie in der Liste „Typ“ die Option „Berechnet - Schreibgeschützt“ aus. Die Option „Laufzeiteigenschaften“ wird angezeigt.
3.
Wählen Sie „Laufzeiteigenschaften“ und wählen Sie dann in der Liste darunter die Laufzeiteigenschaft aus, die Sie einfügen möchten.
Verwandte Themen
Numerische Felder – Übersicht
Text – Übersicht
Textfelder – Übersicht


So fügen Sie einem Formular Variablen hinzu

Mit Hilfe von Variablen können Sie variierenden Text oder variierende Werte einfügen. Eine Variable ist ein Segment aus Text oder Werten, das LiveCycle Designer mit Hilfe von Skripten automatisch aktualisieren oder (nach Bedarf) ändern kann.
Das Variablenelement kann eine beliebige Anzahl bzw. jede Art von getrennten Datenelementen aufnehmen. Da alle Datenelemente mit ihrem eigenen Namensattribut individuell benannt sind, können sie anhand von Skripten einzeln angesteuert werden.
Sie können Textvariablen definieren und diese dann in Objektbeschreibungen oder andere Arten von Text einfügen. Beispielsweise können Sie Variablen auf Produktterminologie anwenden, die sich in einigen Punkten ändern kann. Wenn die Variable (der Ausdruck) geändert werden muss, können Sie das entsprechende Formular öffnen und den Variablenwert aktualisieren; LiveCycle Designer aktualisiert dann automatisch alle Vorkommen des Ausdrucks.
Um eine Variable zu erstellen, müssen Sie die Variable benennen und den Wert angeben, den LiveCycle Designer verwenden soll. Beispielsweise können Sie eine Variable mit dem Namen „ProductName“ erstellen, die den aktuellen Produktnamen enthält, der bei Bedarf aktualisiert werden kann.
Variablenwerte werden zusammen mit dem Formular gespeichert.
Verwandte Themen
Variablen
Registerkarte „Variablen“ (Dialogfeld „Formulareigenschaften“)


Objekteigenschaften

Layout-Eigenschaften in der Palette „Layout“
Randeigenschaften in der Palette „Rand“
Schrift-Eigenschaften in der Palette „Schrift“
Absatz-Eigenschaften in der Palette „Absatz“
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“
Eigenschaften von Masterseiten auf der Registerkarte „Masterseite“
Eigenschaften von Masterseiten in der Registerkarte „Paginierung“
Seitensatz-Eigenschaften in der Registerkarte „Seitensatz“
Eigenschaften in der Palette „Objekt“


Layout-Eigenschaften in der Palette „Layout“

Mit Hilfe der Palette „Layout“ können Sie bestimmte Eigenschaften des ausgewählten Objekts festlegen, wie seine Größe und Position, die Ränder und die Position der Beschriftungen. Sie können für jedes Objekt auf der Seite Layout-Eigenschaften festlegen.
X und Y
Legt die horizontale und vertikale Position des Objekt-Verankerungspunktes fest. Wenn im Listenfeld „Position“ nicht die Einstellung „Oben links“ gewählt ist, werden die Optionen „X“ und „Y“ durch „Pos. X“ und „Pos. Y“ ersetzt. Siehe So positionieren Sie Objekte.
Breite, Höhe und Passend erweitern/Autom. anpassen
Legt die Mindestgesamthöhe und -breite des Objekts fest und ermöglicht bei Bedarf eine Vergrößerung in der entsprechenden Richtung. Siehe So positionieren Sie Objekte und So können Sie Objekte passend erweitern.
Die Optionen für „Autom. anpassen“ werden nur bei Text- und Teilformularobjekten angezeigt. Wenn diese Option ausgewählt ist, wird die Größe des Objekts in LiveCycle Designer an den eingeschlossenen Inhalt angepasst.
Position
Legt den Verankerungspunkt des Objektes fest. Siehe So drehen Sie Objekte.
Drehen
Dreht das Objekt um seinen Verankerungspunkt. Siehe So drehen Sie Objekte.
Ränder
Legt die Größe des Randabstands links, rechts, über und unter dem Objekt fest. Siehe So legen Sie einen Randabstand um ein Objekt herum fest.
Beschriftung
Legt die Position einer Beschriftung fest. Siehe So positionieren Sie eine Beschriftung.
Abstand
Legt die Größe des Bereiches fest, der für eine Beschriftung reserviert wird. Siehe So positionieren Sie eine Beschriftung.
Bei einem Abstandswert von 0 wird der Beschriftungsbereich automatisch angepasst. Die Größe des Objekts orientiert sich an der Beschriftung.
Verwandte Themen
Objekte ausrichten und in der Größe ändern


Randeigenschaften in der Palette „Rand“

Mit der Palette „Rand“ können Sie die Randeigenschaften für Objekte bearbeiten, die einen Rand besitzen. Sie können die Ränder einzeln oder zusammen bearbeiten.
Kanten
Legt die Randeigenschaften für alle oder einzelne Kanten fest:
    • Einzeln bearbeiten
Wendet den Rand jeder Kante einzeln an. Diese Option wirkt sich nicht auf dreidimensionale Ränder aus.
    • Zusammen bearbeiten
Wendet denselben Rand auf alle Kanten an.
    • Seite
Legt den Stil und die Breite der Ränder fest.
    • Farbauswahl
Legt die Linienfarbe fest.
Ecken
Weist den Randecken einen Stil zu.
Radius
Legt den Radius von abgerundeten Ecken fest.
Stil
Legt die Farbe oder das Muster der Hintergrundfüllung fest:
    • Farbauswahl
Legt die Farben der Hintergrundfüllung fest.
Verwandte Themen
So legen Sie einen Rand um ein Objekt herum fest


Schrift-Eigenschaften in der Palette „Schrift“

In der Palette „Schrift“ können Sie die Schriftfamilie, die Schriftgröße und den Textstil im ausgewählten Objekt ändern.
Schrift
Legt die Schrift fest
Größe
Legt die Schriftgröße fest
Grundlinienverschiebung
Legt den Abstand der Zeichen zur Grundlinie fest.
Stil
Legt den Schriftstil fest.
Verwandte Themen
Info über das Formatieren von Texten


Absatz-Eigenschaften in der Palette „Absatz“

Mit der Palette „Absatz“ können Sie Ausrichtung, Einzüge und Zeilenabstand des ausgewählten Textes ändern.
Ausrichten
Legt die horizontale Ausrichtung mit den folgenden Optionen fest:
    • Linksbündig
Richtet die Beschriftung oder den Wert linksbündig aus.
    • Zentrieren
Richtet die Beschriftung oder den Wert zentriert aus.
    • Rechtsbündig
Richtet die Beschriftung oder den Wert rechtsbündig aus.
    • Blocksatz
Richtet die Beschriftung oder den Wert im Blocksatz aus. Der Blocksatz wird auf alle Zeilen mit Ausnahme der letzten Zeile in einer mehrzeiligen Beschriftung bzw. einem mehrzeiligen Wert angewendet. (Einzeilige Absätze können nicht im Blocksatz ausgerichtet werden.)
Radix-Ausrichtung
Legt die Radix-Ausrichtung für numerische Felder fest (Dezimalpunkt). Diese Option wird in der Palette „Absatz“ nur angezeigt, wenn ein numerisches Feldobjekt ausgewählt ist.
Numerische Felder mit definierter Radix-Ausrichtung werden in PDF-Formularen für Acrobat 6.0 und Adobe Reader6.0 nicht unterstützt.
Vertikale Ausrichtung
Legt die vertikale Ausrichtung mit den folgenden Optionen fest:
    • Oben ausrichten
Die Ausrichtung erfolgt oben in dem Bereich, der für die Beschriftung und den Wert reserviert ist.
    • Zentriert ausrichten
Die Ausrichtung erfolgt in der Mitte des Bereiches, der für die Beschriftung und den Wert reserviert ist.
    • Unten ausrichten
Die Ausrichtung erfolgt unten in dem Bereich, der für die Beschriftung und den Wert reserviert ist.
Einzüge
Legt linke und rechte Einzüge fest.
Erste
Legt den Einzug für die erste Zeile fest:
    • Ohne
Legt für alle Zeilen denselben Einzug fest.
    • Erste Zeile
Rückt nur die erste Zeile ein.
    • Hängend
Rückt alle Zeilen außer der ersten ein.
Um
Legt den Einzug für die erste Zeile oder den hängenden Einzug fest.
Abstand
Legt den Abstand oberhalb und unterhalb des Absatzes fest:
    • Über
Legt die Größe des vertikalen Abstandes oberhalb des Absatzes fest. Dieser Wert wird zu dem Wert im Feld „Unter“ addiert.
    • Unter
Legt die Größe des vertikalen Abstandes unterhalb des Absatzes fest. Dieser Wert wird zu dem Wert im Feld „Über“ addiert.
Zeilenabstand
Legt den Zeilenabstand zwischen den Zeilen fest:
    • Einfach
Legt als Zeilenhöhe die Höhe des höchsten Zeichens in der Zeile fest.
    • 1,5 Zeilen
Legt als Zeilenhöhe die 1,5fache Höhe des höchsten Zeichens in der Zeile fest.
    • Doppelt
Legt als Zeilenhöhe die doppelte Höhe des höchsten Zeichens in der Zeile fest.
    • Genau
Legt als Zeilenhöhe den Wert im Feld „Maß“ fest.
Verwandte Themen
Info über das Formatieren von Abschnitten


Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“

LiveCycle Designer bietet eine Reihe von Optionen zur Unterstützung von Bildschirmlesehilfen. Für jedes Objekt in einem Formular können Sie eine oder mehrere Einstellungen für den Text der Bildschirmlesehilfe angeben:
      •
      Der Text für angepasste Bildschirmlesehilfen wird in der Palette „Ein-/Ausgabehilfe“ definiert.
      •
      QuickInfos für Objekte werden in der Palette „Ein-/Ausgabehilfe“ definiert.
      •
      Beschriftungen für Felder
      •
      Namen von Objekten (wie im Feld „Name“ der Registerkarte „Bindung“ angegeben).
Die Einstellungen bestimmen, welche Informationen von Bildschirmlesehilfen als Objekte in PDF-Formularen gelesen werden. Pro Objekt wird nur eine einzige Einstellung je Sprache ausgegeben.
Wenn das Formular als PDF mit Tags gespeichert wird, sucht LiveCycle Designer im Formular nach diesen Einstellungen. Die Standardsuchreihenfolge ist: Eigener Text, QuickInfo, Beschriftung und Name. Diese Standardreihenfolge können Sie über die Option „Bildschirmlesehilfen-Rangfolge“ in der Palette „Ein-/Ausgabehilfe“ außer Kraft setzen.
Eine QuickInfo und angepassten Text für Bildschirmlesehilfen können Sie mit Werten aus einer Datenquelle dynamisch ausfüllen.
QuickInfos werden angezeigt, wenn der Benutzer den Mauszeiger über das Objekt bewegt. Die Einstellung in der Palette „Ein-/Ausgabehilfe“ haben keinen Einfluss auf das Objekt, wenn das Formular als PDF-Formular wiedergegeben wird.
Teilformularrolle
Legt fest, wie Bildschirmlesehilfen das Teilformular, die Tabelle oder die ausgewählte Zeile in einer Tabelle interpretieren:
    • Tabelle
Weist dem ausgewählten Teilformular die Rolle einer Tabelle zu. Wenn der Benutzer zu diesem Teilformular navigiert, erkennen die meisten Bildschirmlesehilfen das Teilformular als Tabelle und geben die Anzahl der Zeilen und Spalten an.
    • Kopfzeile
Weist der ausgewählten Teilformular- oder Tabellenzelle die Kopfzeilenrolle zu. Beim Lesen des Inhalts einer Textzeilenzelle wird von den meisten Bildschirmlesehilfen zunächst der Inhalt der zugehörigen Kopfzeilenzelle gelesen.
    • Textzeile
Weist der ausgewählten Teilformular- oder Tabellenzelle die Textzeilenrolle zu. Enthält eine Zelle ein Teilformular, lesen Bildschirmlesehilfen normalerweise den Inhalt der zugehörigen Zelle in der Kopfzeile und anschließend die Felder im Teilformular.
    • Fußzeile
Weist der ausgewählten Teilformular- oder Tabellenzelle die Fußzeilenrolle zu.
    • Liste
Weist dem ausgewählten Teilformular die Rolle einer Liste zu.
    • Listenelement
Weist dem ausgewählten Teilformular die Rolle eines Listenelementes zu. Die Rolle eines Listenelementes kann nur einem Teilformular zugewiesen werden, das in einem Teilformular mit der Rolle „Liste“ enthalten ist. Sie können eine Tabelle oder Tabellenzeile nicht als Liste oder Listenelement definieren. Ein Listenelement kann jedoch eine Tabelle enthalten.
    • Überschrift
Weist dem ausgewählten statischen Textobjekt die Rolle einer Überschrift zu.
    • (ohne)
Gibt eine Zeile an, die Informationen über die Tabelle oder ihren Inhalt enthält. Die Zeile wird nicht als Teil der Tabelle angesehen, ihr Inhalt wird jedoch von der Bildschirmlesehilfe gelesen.
QuickInfo
Definiert eine QuickInfo für das Objekt. QuickInfos werden angezeigt, wenn der Benutzer den Mauszeiger über das Objekt bewegt. Eine Bildschirmlesehilfe liest den in diesem Feld eingegebenen Text.
Sie können einem Objekt nicht sowohl eine QuickInfo als auch einen Text für eine angepasste Bildschirmlesehilfe zuweisen. Sie müssen sich für eine der Optionen entscheiden. Möchten Sie eine eigene QuickInfo verwenden, geben Sie den Text ein, und wählen Sie in der Liste „Bildschirmlesehilfen-Rangfolge“ die Option „QuickInfo“ aus bzw. geben Sie keinen Text für angepasste Bildschirmlesehilfe ein.
„QuickInfo“ ist bei den meisten Objekten eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren.
Bildschirmlesehilfen-Rangfolge
Gibt an, welche Einstellung die Bildschirmlesehilfe lesen soll. Pro Objekt wird nur eine einzige Einstellung je Sprache ausgegeben:
    • Eigener Text
Liest den im Feld „Text für angepasste Bildschirmlesehilfe“ angegebenen Text. Dies ist die Standardeinstellung.
    • QuickInfo
Liest den im Feld „QuickInfo“ angegebenen Text.
    • Beschriftung
Liest die für das Objekt angegebene Beschriftung. Die Position der Beschriftung relativ zum Objekt wirkt sich nicht auf die Reihenfolge aus, in der die Beschriftung von der Bildschirmlesehilfe gelesen wird. Wird kein Text im Feld „QuickInfo“ oder „Text für angepasste Bildschirmlesehilfe“ angegeben, liest die Bildschirmlesehilfe standardmäßig die Beschriftung.
    • Name
Liest den Namen des Objekts, der in der Palette „Objekt“ auf der Registerkarte „Bindung“ im Feld „Name“ angegeben ist.
    • Ohne
Deaktiviert eine eigene QuickInfo oder eigenen Text für die angepasste Bildschirmlesehilfe für das Feld.
Text für angepasste Bildschirmlesehilfe
Definiert angepassten Text für das ausgewählte Objekt. Die Bildschirmlesehilfe liest den in diesem Feld eingegebenen Text.
Sie können einem Objekt nicht sowohl eine QuickInfo als auch einen Text für eine angepasste Bildschirmlesehilfe zuweisen. Sie müssen sich für eine der Optionen entscheiden. Soll der Text für die angepasste Bildschirmlesehilfe sowohl als QuickInfo als auch als Bildschirmlesehilfen-Text verwendet werden, geben Sie den Text ein, und wählen Sie in der Liste „Bildschirmlesehilfen-Rangfolge“ die Option „Eigener Text“ aus.
„Text für angepasste Bildschirmlesehilfe“ ist bei den meisten Objekten eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren.
Verwandte Themen
Barrierefreie Formulare
So füllen Sie eine QuickInfo dynamisch aus
So füllen Sie Bildschirmlesehilfen-Text dynamisch aus


Eigenschaften von Masterseiten auf der Registerkarte „Masterseite“

Verwenden Sie die Registerkarte „Masterseite“ der Palette „Objekt“, um den Seitennamen und verschiedene Layoutoptionen für jede Masterseite einzustellen. Wählen Sie auf der Registerkarte „Masterseite“ die Masterseite, mit der Sie in der Palette „Hierarchie“ arbeiten möchten.
Name
Legt den Namen der Masterseite fest.
Papierart, Höhe und Breite
Legt die Größe der Masterseite fest. Die tatsächlichen Maße werden in den Feldern „Höhe“ und „Breite“ angezeigt und können verändert werden, wenn die Option „Papiertyp“ auf „Eigene“ eingestellt ist.
Ausrichtung
Legt die Ausrichtung der Masterseite fest:
    • Hochformat
Die Seitenhöhe ist gleich der oder größer als die Seitenbreite.
    • Querformat
Die Seitenbreite ist gleich der oder größer als die Seitenhöhe.
Auftreten der Seite begrenzen, Min-Zähler und Maximal
Wählen Sie diese Option nur für die Erstellung von Formularen, deren Layout an die entsprechende Datenmenge angepasst wird. Dies aktiviert bzw. deaktiviert die wiederholte Wiedergabe von Seiten, die auf der ausgewählten Masterseite basieren. Wenn die Option ausgewählt wird, können Sie im Feld „Min-Zähler“ eine Mindestanzahl von Wiederholungen und im Feld „Maximal“ eine Höchstanzahl von Wiederholungen eingeben.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
Verwandte Themen
Eigenschaften von Masterseiten in der Registerkarte „Paginierung“
Masterseiten einrichten


Eigenschaften von Masterseiten in der Registerkarte „Paginierung“

Wenn Sie eine Masterseite auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Paginierung“ verschiedene Paginierungsoptionen zur Verfügung.
Seite in Nummerierung einbeziehen
Legt fest, ob Seiten, die gemäß der ausgewählten Masterseite wiedergegeben wurden, bei der Zählung der Gesamtseitenzahl berücksichtigt werden sollen. Standardmäßig ist diese Option ausgewählt, so dass alle Seiten gezählt werden.
Erste Dokumentseite
Legt die Seitennumerierung für Seiten fest, die gemäß der ausgewählten Masterseite wiedergegeben wurden.
    • Nummerierung von vorigem Dokument fortsetzen
Die Nummerierung wird vom letzten von LiveCycle Forms verarbeiteten Dokument ausgehend fortgesetzt.
    • Beginnen bei
Die Nummerierung beginnt bei dem angegebenen Wert.
Verwandte Themen
Eigenschaften von Masterseiten auf der Registerkarte „Masterseite“
Masterseiten einrichten


Seitensatz-Eigenschaften in der Registerkarte „Seitensatz“

Verwenden Sie die Registerkarte „Seitensatz“ der Palette „Objekt“, um den Seitennamen und verschiedene Layoutoptionen für jede Masterseite einzustellen. Um die Registerkarte „Seitensatz“ anzuzeigen, wählen Sie in der Palette „Hierarchie“ den Seitensatz, mit dem Sie arbeiten möchten.
Sie können diese Optionen für jeden Seitensatz individuell einstellen.
Name
Legt den Namen des Seitensatzes fest.
Auftreten des Seitensatzes begrenzen, Min-Zähler und Maximal
Wählen Sie diese Option nur zum Erstellen interaktiver Formulare. Sie aktiviert bzw. deaktiviert die wiederholte Wiedergabe von Seiten, die im ausgewählten Seitensatz auf Masterseiten basieren. Wenn die Option ausgewählt wird, können Sie im Feld „Min-Zähler“ eine Mindestanzahl von Wiederholungen und im Feld „Maximal“ eine Höchstanzahl von Wiederholungen eingeben.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
Verwandte Themen
Seitensätze einrichten


Eigenschaften in der Palette „Objekt“

Barcodes
Schaltflächen
Kontrollkästchen
Kreise
Inhaltsbereiche
Datums-/Uhrzeitfelder
Dezimalfelder
Dokumentunterschriftsfelder
Dropdown-Listen
E-Mail-Senden-Schaltfläche
HTTP-Senden-Schaltfläche
Bildfelder
Bilder
Linien
Listenfelder
Numerische Felder
Papierformular-Barcodes
Kennwortfelder
Optionsfelder
Rechtecke
Teilformulare
Teilformularsätze
Tabellen
Text
Textfelder


Barcodes

Eigenschaften von Barcodes: Registerkarte „Feld“
Eigenschaften von Barcodes: Registerkarte „Wert“
Barcode-Eigenschaften: Registerkarte „Bindung“
Unterstützte Barcode-Formate
Gültige Textzeichen für Barcodes


Eigenschaften von Barcodes: Registerkarte „Feld“

Wenn Sie einen Barcode auswählen, zeigt die Registerkarte „Feld“ in der Palette „Objekt“ eine Reihe von Optionen zur Formatierung von Barcodes an.
Position
Legt die Position des Barcode-Textes fest.
Eigenschaft/Wert
Legt die Barcode-spezifischen Eigenschaften fest.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Verwandte Themen
Barcodes – Übersicht


Eigenschaften von Barcodes: Registerkarte „Wert“

Wenn Sie einen Barcode erzeugen, steht Ihnen auf der Registerkarte „Wert“ eine Reihe von Optionen zur Verfügung, die Sie auf das Objekt anwenden können.
Typ
Ermöglicht Berechnungen und Eingabeaufforderungen zur Laufzeit:
    • Benutzereingabe - Optional
Der Benutzer kann selbst entscheiden, ob er Daten eingeben möchte.
    • Benutzereingabe - Empfohlen
Wenn der Benutzer keine Daten eingibt, wird eine eigene Meldung angezeigt (soweit sie im Feld „Meldung bei leerem Feld“ eingetragen worden ist).
    • Benutzereingabe - Erforderlich
Wenn der Benutzer keine Daten eingibt, wird eine eigene Meldung angezeigt (soweit sie im Feld „Meldung bei leerem Feld“ eingetragen worden ist).
    • Berechnet - Schreibgeschützt
Ein Datenwert wird über ein angehängtes Skript berechnet und angezeigt. Die Benutzer können den berechneten Wert nicht bearbeiten.
    • Berechnet - Benutzer darf überschreiben
Ein Datenwert wird über ein angehängtes Skript berechnet und angezeigt. Die Benutzer können den berechneten Wert bearbeiten, wenn im Berechnungsskript eine Verarbeitung der Benutzereingabe vorgesehen ist. Wenn ein Benutzer den berechneten Wert bearbeiten möchte, wird eine Meldung angezeigt, die im Feld „Meldung beim Überschreiben eines Werts“ festgelegt wurde.
    • Schreibgeschützt
Ein Datenwert wird zur Laufzeit zusammengeführt oder berechnet und angezeigt. Die Benutzer können den Wert nicht bearbeiten.
Standardwert
Legt einen Ausgangswert für den Barcode fest. Die Länge des eingegebenen Wertes kann die Anzeigebreite einiger Barcodes beeinflussen.
Diese Option steht nur dann zur Verfügung, wenn die Option „Typ“ auf „Benutzereingabe - Optional“, „Benutzereingabe - Empfohlen“, „Benutzereingabe - Erforderlich“ oder „Schreibgeschützt“ gesetzt ist.
Meldung bei leerem Feld
Legt eine Meldung fest, mit der die Benutzer zur Eingabe eines empfohlenen oder erforderlichen Wertes aufgefordert werden. Siehe So fordern Sie Benutzer zur Dateneingabe auf.
Diese Option ist nur dann verfügbar, wenn die Option „Typ“ auf „Benutzereingabe - Empfohlen“ oder „Benutzereingabe - Erforderlich“ gesetzt ist.
Überprüfungsmuster
Legt ein Überprüfungsmuster für die Benutzereingabe fest. Das Muster muss mit der Syntax der Benutzereingabe übereinstimmen. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist.
Überprüfungsmuster-Meldung und Fehler
Legt eine eigene Meldung fest, die angezeigt wird, wenn ein Rohwert nicht dem Überprüfungsmuster entspricht. Standardmäßig wird in einem solchen Fall zur Laufzeit ein Programmierfehler generiert. Wenn stattdessen eine Warnmeldung generiert werden soll, deaktivieren Sie die Option „Fehler“. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist. „Überprüfungsmuster-Meldung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus.
Überprüfungsskript-Meldung und Fehler
Legt eine Meldung fest, die angezeigt wird, wenn ein angehängtes Überprüfungsskript einen inakzeptablen Wert ermittelt. Standardmäßig wird in einem solchen Fall zur Laufzeit ein Programmierfehler generiert. Wenn stattdessen eine Warnmeldung generiert werden soll, deaktivieren Sie die Option „Fehler“. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist. „Überprüfungsskript-Meldung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus.
Meldung beim Überschreiben eines Werts
Legt eine eigene Meldung fest, die den Benutzer darauf hinweist, dass er dabei ist, den Wert eines berechneten Feldes zu ändern. Die Meldung erscheint, wenn ein Benutzer den berechneten Wert ändert.
Diese Option steht nur zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Benutzer darf überschreiben“ gesetzt ist.
Verwandte Themen
Barcodes – Übersicht
So steuern Sie die Datenzuweisung für einen Barcode
So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus
So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus


Barcode-Eigenschaften: Registerkarte „Bindung“

Auf der Registerkarte „Bindung“ werden verschiedene Optionen für die Bindung von Barcodes angezeigt. Die Optionen, die sich nicht direkt auf die Erstellung einer Datenverbindung beziehen, gelten für die an eine Datenquelle gebundenen und die in einer Datei gespeicherten Daten, wenn das Objekt an keine Datenquelle gebunden ist.
Name
Legt den Namen des Barcodes fest. Siehe So können Sie Objekte benennen und umbenennen.
Standardbindung
Legt die Standardmethode zum Binden von Daten fest:
    • Normal
Aktiviert die Optionen zum Zusammenführen und Speichern von Daten. Die Datenwerte werden den Adobe-Regeln zur Datenzusammenführung entsprechend zusammengeführt und gespeichert.
    • Global
Verbindet einen einzelnen Datenwert mit allen gleichnamigen Objekten (siehe So definieren Sie ein globales Feld).
    • Neue Datenverbindung
Startet den Assistenten „Neue Datenverbindung“. Weitere Informationen dazu, wie Sie eine Verbindung mit Hilfe des Assistenten definieren, finden Sie unter So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei oder So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank.
    • Ohne
Deaktiviert die Datenbindung. Da das Objekt keine zusammengeführten Daten erfasst oder anzeigt, bleiben alle Informationen, die zum Objekt gehören, beim Speichern oder Absenden der Formulardaten unberücksichtigt.
Import/Export-Bindungen
Legt eine Import/Export-Bindung für eine WSDL-Datenverbindung fest. Siehe So erstellen Sie eine Datenverbindung zu einer WSDL-Datei.
Verwandte Themen
Datenquellen
Barcodes – Übersicht
So definieren Sie benutzerdefinierte Datenbindungseigenschaften für einen Barcode


Unterstützte Barcode-Formate

Die folgenden Barcode-Formate werden unterstützt:
AUS Post Custom2
Format „AUSPOST Custom 2“
AUS Post Custom3
Format „AUSPOST Custom 3“
AUS Post Reply Paid
Format „AUSPOST Reply Paid“
AUS Post Standard
Format „AUSPOST Standard“
Codabar
Codabar-Format, kompatibel mit USD-4, NW-7 und 2-of-7 Code
Code 11
Format „Code 11“ (Hardware-gestützt)
Code 128SSCC
Format „UCC/EAN 128 SSCC“ (Serial Shipping Container Code)
Code 128
Format „Code128“
Code 128A
Format „Code128, Set A“
Code 128B
Format „Code128, Set B“
Code 128C
Format „Code128, Set C“
Code 2 of 5 Industrial
Format „2 of 5, Industrial“
Code 2 of 5 Interleaved
Format „2 of 5, Interleaved“, kompatibel mit Code 25, I2of5, ITF und I25
Code 2 of 5 Matrix
Format „2 of 5 Matrix“
Code 3 of 9 - 3
Format „3 of 9“
Code 93
Format „Code 93“ (Hardware-gestützt)
Code 49
Format „Code 49“ (Hardware-gestützt)
Code QR
Format „Quick Response (QR) 2-D Code“ (Hardware-gestützt)
EAN13
Format „EAN13“
EAN8
Format „EAN8“
Logmars
Format „Logmars“ (Hardware-gestützt)
MSI
MSI-Format (Hardware-gestützt)
PDF 417
Zweidimensionales Format, das bis zu 1 800 ASCII-Zeichen unterstützt
Plessey
Format „Plessey“ (Hardware-gestützt)
UK Post RM4SCC
Format „UK/Royal Mail RM4SCC“
UPC-A
Format „UPC-A“
UPC-E
Format „UPC-E“ (Hardware-gestützt)
UPC EAN2
Format „UPC EAN2“ (Hardware-gestützt)
UPC EAN5
Format „UPC EAN5“ (Hardware-gestützt)
US Postal Zip-5
5-stelliges Format des US Post-Dienstes (ZIP)
US Postal DPBC
Format „Delivery Point ZIP +6“
US Postal Standard
US Postal Standard, Standardformat des US-Postdienstes
Zusätzliche hardwarespezifische Barcode-Formate können in den Standardsatz der unterstützten Barcode-Formate aufgenommen werden.
Verwandte Themen
Barcodes – Übersicht


Gültige Textzeichen für Barcodes

In dieser Tabelle werden die Zeichen aufgeführt, die Sie für Barcodetext verwenden können.

Barcode

Gültige Zeichen
AUS Post Custom2
AUS Post Custom3
AUS Post Reply Paid
AUS Post Standard
Code 2 of 5 Industrial
Code 2 of 5 Interleaved
Code 2 of 5 Matrix
EAN13
EAN8
MSI
UPC-A
UPC-E
UPC-EAN2
UPC-EAN5
US Postal Zip-5
US Postal DPBC
US Postal Standard
0 1 2 3 4 5 6 7 8 9
Codabar
0 1 2 3 4 5 6 7 8 9
- $ : / . +
Code 11
0 1 2 3 4 5 6 7 8 9
-
Code 128SSCC
Code 128
Code 128A
Code 128B
Code 128C
0 1 2 3 4 5 6 7 8 9
! # & ' < > `
$ % ( ) * + , - . / : ; ? @ # = [ ] \ ^ _ { } | ~ Leerzeichen
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
a b c d e f g h i j k l m n o p q r s t u v w x y z
Code 3 of 9
0 1 2 3 4 5 6 7 8 9
- . $ / + % * Leerzeichen
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Code 49
0 1 2 3 4 5 6 7 8 9
< > - . $ / + % : ; ? =
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Code 93
0 1 2 3 4 5 6 7 8 9
& ' - . $ ( ) / + % , Leerzeichen
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Logmars
0 1 2 3 4 5 6 7 8 9
- . $ / + % Leerzeichen
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
PDF 417
Keine Beschränkungen
Plessey
0 1 2 3 4 5 6 7 8 9
A B C D E F
UK Post RM4SCC
0 1 2 3 4 5 6 7 8 9
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Verwandte Themen
Barcodes – Übersicht


Schaltflächen

Eigenschaften von Schaltflächen: Registerkarte „Feld“
Eigenschaften von Drucken-Schaltflächen: Registerkarte „Feld“
Eigenschaften von Zurücksetzen-Schaltflächen: Registerkarte „Feld“
Eigenschaften von Schaltflächen: Registerkarte „Absenden“
Eigenschaften von Schaltflächen: Registerkarte „Ausführen“


Eigenschaften von Schaltflächen: Registerkarte „Feld“

Wenn Sie eine Schaltfläche auswählen, zeigt die Registerkarte „Feld“ in der Palette „Objekt“ eine Reihe von Optionen zur Formatierung von Schaltflächen an.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Beschriftung
Legt eine Beschriftung für das Objekt fest.
„Beschriftung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Beschriftung dynamisch aus.
Erscheinungsbild
Legt den Begrenzungsstil fest:
    • Keine Begrenzung
Entfernt die Linie, die die Schaltfläche umrahmt.
    • Durchgehende Begrenzung
Erzeugt eine breite Linie, die die Schaltfläche umrahmt.
    • Angehobene Begrenzung
Erzeugt einen Schatten um die Schaltfläche, der die Schaltfläche dreidimensional wirken lässt.
    • Benutzerdefiniert
Zeigt das Dialogfeld „Angepasstes Erscheinungsbild“ an. Wählen Sie diese Option, wenn Sie das Erscheinungsbild der Schaltfläche selbst festlegen möchten.
Hervorhebung
Legt die Schaltflächen-Hervorhebung fest, die beim Klicken auf die Schaltfläche angezeigt wird:
    • Ohne
Entfernt die Schaltflächen-Hervorhebung.
    • Invertiert
Invertiert die Schaltflächen-Hervorhebung, wenn auf die Schaltfläche geklickt wird.
    • Schaltfläche
Erzeugt an den Rändern der Schaltfläche eine Schattierung, um die Schaltfläche vertieft darzustellen.
    • Kontur
Erzeugt eine Linie, die die Schaltfläche umrahmt, wenn auf die Schaltfläche geklickt wird.
Text bei Rollover
Legt einen Text bei Rollover fest, wenn „Schaltfläche“ als Schaltflächen-Hervorhebung eingestellt ist. Dieser Text wird angezeigt, wenn der Mauszeiger über die Schaltfläche bewegt wird.
Text bei Aktivierung
Legt einen Text bei Aktivierung fest, wenn „Schaltfläche“ als Schaltflächen-Hervorhebung eingestellt ist. Dieser Text wird beim Klicken auf die Schaltfläche angezeigt.
Kontrolltyp
Legt fest, welche Aktion ausgeführt wird, wenn der Benutzer auf die Schaltfläche klickt. Diese Optionen werden nicht für die Drucken- und Zurücksetzen-Schaltfläche angezeigt.
    • Normal
Das angefügte Skript oder die Berechnung wird ausgeführt. Das Skript oder die Berechnung wird vom Benutzer angegeben.
    • Absenden
Die Daten werden entsprechend den Einstellungen auf der Registerkarte „Absenden“ gesendet. Siehe Eigenschaften von Schaltflächen: Registerkarte „Absenden“.
    • Ausführen
Entsprechend den Einstellungen auf der Registerkarte „Ausführen“ wird eine Webdienst-Operation oder eine Datenbankabfrage ausgeführt. Siehe Eigenschaften von Schaltflächen: Registerkarte „Ausführen“.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Schaltflächen – Übersicht


Eigenschaften von Drucken-Schaltflächen: Registerkarte „Feld“

Wenn Sie eine Schaltfläche auswählen, zeigt die Registerkarte „Feld“ in der Palette „Objekt“ eine Reihe von Optionen zur Formatierung von Schaltflächen an.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Beschriftung
Legt eine Beschriftung für das Objekt fest.
„Beschriftung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Beschriftung dynamisch aus.
Erscheinungsbild
Legt den Begrenzungsstil fest:
    • Keine Begrenzung
Entfernt die Linie, die die Schaltfläche umrahmt.
    • Durchgehende Begrenzung
Erzeugt eine breite Linie, die die Schaltfläche umrahmt.
    • Angehobene Begrenzung
Erzeugt einen Schatten um die Schaltfläche, der die Schaltfläche dreidimensional wirken lässt.
    • Benutzerdefiniert
Zeigt das Dialogfeld „Angepasstes Erscheinungsbild“ an. Wählen Sie diese Option, wenn Sie das Erscheinungsbild der Schaltfläche selbst festlegen möchten.
Hervorhebung
Legt die Schaltflächen-Hervorhebung fest, die beim Klicken auf die Schaltfläche angezeigt wird:
    • Ohne
Entfernt die Schaltflächen-Hervorhebung.
    • Invertiert
Invertiert die Schaltflächen-Hervorhebung, wenn auf die Schaltfläche geklickt wird.
    • Schaltfläche
Erzeugt an den Rändern der Schaltfläche eine Schattierung, um die Schaltfläche vertieft darzustellen.
    • Kontur
Erzeugt eine Linie, die die Schaltfläche umrahmt, wenn auf die Schaltfläche geklickt wird.
Text bei Rollover
Legt einen Text bei Rollover fest, wenn „Schaltfläche“ als Schaltflächen-Hervorhebung eingestellt ist. Dieser Text wird angezeigt, wenn der Mauszeiger über die Schaltfläche bewegt wird.
Text bei Aktivierung
Legt einen Text bei Aktivierung fest, wenn „Schaltfläche“ als Schaltflächen-Hervorhebung eingestellt ist. Dieser Text wird beim Klicken auf die Schaltfläche angezeigt.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Schaltflächen – Übersicht


Eigenschaften von Zurücksetzen-Schaltflächen: Registerkarte „Feld“

Wenn Sie eine Schaltfläche auswählen, zeigt die Registerkarte „Feld“ in der Palette „Objekt“ eine Reihe von Optionen zur Formatierung von Schaltflächen an.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Beschriftung
Legt eine Beschriftung für das Objekt fest.
„Beschriftung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Beschriftung dynamisch aus.
Erscheinungsbild
Legt den Begrenzungsstil fest:
    • Keine Begrenzung
Entfernt die Linie, die die Schaltfläche umrahmt.
    • Durchgehende Begrenzung
Erzeugt eine breite Linie, die die Schaltfläche umrahmt.
    • Angehobene Begrenzung
Erzeugt einen Schatten um die Schaltfläche, der die Schaltfläche dreidimensional wirken lässt.
    • Benutzerdefiniert
Zeigt das Dialogfeld „Angepasstes Erscheinungsbild“ an. Wählen Sie diese Option, wenn Sie das Erscheinungsbild der Schaltfläche selbst festlegen möchten.
Hervorhebung
Legt die Schaltflächen-Hervorhebung fest, die beim Klicken auf die Schaltfläche angezeigt wird:
    • Ohne
Entfernt die Schaltflächen-Hervorhebung.
    • Invertiert
Invertiert die Schaltflächen-Hervorhebung, wenn auf die Schaltfläche geklickt wird.
    • Schaltfläche
Erzeugt an den Rändern der Schaltfläche eine Schattierung, um die Schaltfläche vertieft darzustellen.
    • Kontur
Erzeugt eine Linie, die die Schaltfläche umrahmt, wenn auf die Schaltfläche geklickt wird.
Text bei Rollover
Legt einen Text bei Rollover fest, wenn „Schaltfläche“ als Schaltflächen-Hervorhebung eingestellt ist. Dieser Text wird angezeigt, wenn der Mauszeiger über die Schaltfläche bewegt wird.
Text bei Aktivierung
Legt einen Text bei Aktivierung fest, wenn „Schaltfläche“ als Schaltflächen-Hervorhebung eingestellt ist. Dieser Text wird beim Klicken auf die Schaltfläche angezeigt.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Schaltflächen – Übersicht


Eigenschaften von Schaltflächen: Registerkarte „Absenden“

Wenn Sie eine Schaltfläche erzeugen und unter „Kontrolltyp“ die Option „Absenden“ wählen, erscheint in der Palette „Objekt“ die Registerkarte „Absenden“. Sie enthält verschiedene Optionen zum Formatieren von Schaltflächen für das Senden von Daten.
Absenden an URL
Legt die Adresse eines Webservers fest. Sie können das ftp-, http-, https- oder mailto-Protokoll angeben.
Senden als
Legt das Format der Daten fest, die übergeben werden sollen.
    • XML-Datenpaket (XDP)
Übergibt ein Paket in dem von LiveCycle Designer erzeugten Dateiformat. Wählen Sie dieses Format, wenn mit dem Formular z. B. eine Server-seitige Verarbeitung ausgelöst wird. Verwenden Sie dieses Format auch, um den Formularentwurf, die Formulardaten, Anmerkungen und alle anderen, für LiveCycle Forms relevanten Daten zu übergeben und das Formular zur Laufzeit zu implementieren.
    • PDF
Übergibt ein Paket, das eine eingebettete PDF-Datei enthält. Wählen Sie dieses Format, wenn das Formular ein Dokumentunterschriftsfeld enthält oder wenn eine Kopie des Formulars zusammen mit den Formulardaten von LiveCycle Forms gespeichert oder an eine andere Art von Ziel-Server gesendet werden muss. Wählen Sie diese Option nicht, wenn das Formular die Verarbeitung auf der Server-Seite auslöst, wenn LiveCycle Forms verwendet wird, um HTML-Formulare oder Formulare mit flexiblem Layout zur Laufzeit wiederzugeben, oder wenn es sich bei dem Formular um ein PDF-Formular handelt, das in Adobe Reader ohne die Verwendung von LiveCycle Reader Extensions ausgefüllt wird.
    • XML-Daten (XML)
Übergibt einen XML-Datenstrom, der die hierarchische Darstellung der Daten ermöglicht und von jedem generischen XML-Parser analysiert werden kann. Wählen Sie dieses Format, wenn der Server, der mit dem Laufzeit-Anwendungsprogramm kommuniziert, einen XML-Datenstrom empfangen muss.
    • URL-kodierte Daten (HTTP Post)
Übergibt mit Hilfe der POST-Methode einen Textstrom an den angegebenen URL (Uniform Resource Locator). Dieser Textstrom kann von einem FTP-Server, Mail-Server, Webserver oder einem CGI-Skript, das HTML-Formulare verarbeitet, analysiert werden. Um diese Methode verwenden zu können, müssen Benutzer das Formular in Adobe Reader 6.0 oder höher oder in einem Web-Browser öffnen, es sei denn, die URL legt das mailto-Protokoll fest.
Sendung unterschreiben
Wendet eine Datenunterschrift auf die gesendeten Daten an. Wenn der Benutzer beim Ausfüllen auf diese Schaltfläche klickt, wird eine digitale Unterschrift für die gesendeten Daten und Anhänge erstellt. Datenunterschriften sichern die unterschriebenen Daten und gewährleisten deren Integrität bei der Übertragung. Datenunterschriften können auf die Formulardaten oder auf die gesamte Sendung einschließlich der Anhänge angewendet werden. Klicken Sie auf die Schaltfläche „Einstellungen“, um optionale Sicherheitseinstellungen für die Datenunterschrift, wie etwa den Unterschriften-Handler, Unterschriftszertifikate und Zertifikataussteller, zu definieren.
Einschließen
Legt die Elemente fest, die als Anhänge einbezogen werden sollen. Anhänge können nur mit XDP-Dateien einbezogen werden.
    • Anmerkungen
Bezieht Überprüfungskommentare, QuickInfos und andere spezielle Tags ein, die zum Aufzeichnen des Textes für die Bildschirmlesehilfe erforderlich sind.
    • Digitale Unterschrift
Bezieht die digitalen Unterschriften eines unterschriebenen Dokuments ein.
    • PDF
Wenn diese Option ausgewählt ist, wird eine PDF-Version des Formulars als Anhang gesendet. Ist sie nicht ausgewählt, wird ein Verweis auf eine eingebettete PDF-Datei eingefügt.
    • Vorlage
Bezieht eine Kopie des Formularentwurfs ohne zusammengeführte Daten ein.
    • Andere
Bezieht ein oder mehrere <xdp>-Elemente in die XDP-Quelldatei ein. Die angegebenen Elemente müssen durch Kommas getrennt werden; Leerzeichen sind optional. Beispiel: xci, xslt, sourceset
Datenoptionen
Legt das Kodierungsformat für Datenübertragungen fest.
    • UTF-8
Unicode Transformation Format 8.
    • UTF-16
Unicode Transformation Format 16.
    • Shift_JIS
Japanisch.
    • Big5
Chinesisch (traditionell).
    • GBK
Chinesisch (vereinfacht) (GB 13000.1-93) (in Erweiterung von GB 2312-80)
    • KSC_5601
Koreanisch.
Verwandte Themen
Schaltflächen – Übersicht
Info über das Senden von Daten mit Hilfe einer Schaltfläche


Eigenschaften von Schaltflächen: Registerkarte „Ausführen“

Wenn Sie eine Schaltfläche erzeugen und unter „Kontrolltyp“ die Option „Ausführen“ wählen, erscheint in der Palette „Objekt“ die Registerkarte „Ausführen“. Sie enthält verschiedene Optionen zum Formatieren von Schaltflächen mit einer Datenverbindung.
Verbindung
Legt die Verbindung fest. Siehe So erstellen Sie eine Datenverbindung zu einer WSDL-Datei.
Verbindungsdaten
Zeigt Informationen zur Verbindung an sowie den Namen der Operation oder der auszuführenden Abfrage.
Ausführen am
Legt den Ort der Ausführung fest.
    • Client
Die Anforderung wird auf dem Client-Computer verarbeitet.
    • Server
Die Anforderung wird auf dem Server verarbeitet.
    • Client und Server
Die Anforderung wird auf dem Client-Computer und dem Server verarbeitet.
Formulardaten erneut zusammenfügen
Aktiviert oder deaktiviert die Aktualisierung der Formularstruktur nach Abschluss der Bearbeitung.
Verwandte Themen
Schaltflächen – Übersicht
Info über Verarbeitungsoptionen für eine Schaltfläche
Festlegen, wo eine Berechnung oder ein Skript ausgeführt werden soll


Kontrollkästchen

Eigenschaften von Kontrollkästchen: Registerkarte „Feld“
Eigenschaften von Kontrollkästchen: Registerkarte „Wert“
Eigenschaften von Kontrollkästchen: Registerkarte „Bindung“


Eigenschaften von Kontrollkästchen: Registerkarte „Feld“

Wenn Sie ein Kontrollkästchen auswählen, zeigt die Registerkarte „Feld“ in der Palette „Objekt“ eine Reihe von Optionen zur Formatierung von Kontrollkästchen an.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Beschriftung
Legt eine Beschriftung für das Objekt fest.
„Beschriftung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Beschriftung dynamisch aus.
Erscheinungsbild
Legt den Randstil für den Füllbereich des Kontrollkästchens fest:
    • Ohne
Das Kästchen erhält keine Begrenzung.
    • Ausgefülltes Quadrat
Verwendet ein ausgefülltes Quadrat zur Darstellung des Kontrollkästchens.
    • Versenktes Quadrat
Erzeugt eine quadratische Schattierung, so dass das Kontrollkästchen dreidimensional wirkt.
    • Ausgefüllter Kreis
Verwendet einen ausgefüllten Kreis zur Darstellung des Kontrollkästchens.
    • Versenkter Kreis
Erzeugt eine kreisförmige Schattierung, so dass das Kontrollkästchen dreidimensional wirkt.
    • Benutzerdefiniert
Zeigt das Dialogfeld „Angepasstes Erscheinungsbild“ an. Wählen Sie diese Option, wenn Sie ein eigenes Design für den Füllbereich entwerfen möchten.
Statusangaben
Legt die Anzahl der unterstützten Statusangaben fest:
    • An/Aus
Das Kontrollkästchen kann den Status „An“ (aktiviert) oder „Aus“ (deaktiviert) haben.
    • An/Aus/Neutral
Das Kontrollkästchen kann den Status „An“ (aktiviert), „Aus“ (deaktiviert) und „Neutral“ (weder aktiviert noch deaktiviert) haben.
Die Werte für die einzelnen Statusangaben müssen in der Palette „Objekt“ auf der Registerkarte „Bindung“ definiert werden.
Größe
Legt die Größe des Kontrollkästchens fest.
Kontrollkästchenstil
Legt den Stil für die Aktivierung des Kontrollkästchens fest:
    • Standard
Verwendet ein X als Kontrollkästchenstil.
    • Häkchen
Verwendet ein Häkchen als Kontrollkästchenstil.
    • Kreis
Verwendet einen Kreis als Kontrollkästchenstil.
    • Kreuz
Verwendet ein Kreuz als Kontrollkästchenstil.
    • Karo
Verwendet ein Karo als Kontrollkästchenstil.
    • Quadrat
Verwendet ein Quadrat als Kontrollkästchenstil.
    • Stern
Verwendet einen Stern als Kontrollkästchenstil.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Kontrollkästchen – Übersicht


Eigenschaften von Kontrollkästchen: Registerkarte „Wert“

Wenn Sie ein Kontrollkästchen erzeugen, steht Ihnen auf der Registerkarte „Wert“ eine Reihe von Optionen zur Verfügung, die Sie auf das Objekt anwenden können.
Typ
Ermöglicht Berechnungen und Eingabeaufforderungen zur Laufzeit.
    • Benutzereingabe
Der Benutzer kann selbst entscheiden, ob er Daten eingeben möchte.
    • Berechnet - Schreibgeschützt
Ein Datenwert wird über ein angefügtes Skript berechnet und zur Laufzeit angezeigt. Die Benutzer können den berechneten Wert nicht bearbeiten.
    • Berechnet - Benutzer darf überschreiben
Ein Datenwert wird über ein angehängtes Skript berechnet und angezeigt. Die Benutzer können den berechneten Wert bearbeiten, wenn im Berechnungsskript eine Verarbeitung der Benutzereingabe vorgesehen ist. Wenn ein Benutzer den berechneten Wert bearbeiten möchte, wird eine Meldung angezeigt, die im Feld „Meldung beim Überschreiben eines Werts“ festgelegt wurde.
    • Schreibgeschützt
Ein Datenwert wird zur Laufzeit zusammengeführt oder berechnet und angezeigt. Die Benutzer können den Wert nicht bearbeiten.
Standard
Legt den anfänglichen Status des Kontrollkästchens fest.
    • Ein
Das Kontrollkästchen hat standardmäßig den Status „Ein“. Das Kontrollkästchen ist aktiviert.
    • Aus
Das Kontrollkästchen hat standardmäßig den Status „Aus“. Das Kontrollkästchen ist deaktiviert.
    • Neutral
Das Kontrollkästchen hat standardmäßig den Status „Neutral“. Das Feld wird mit grauer Füllfarbe angezeigt.
Die Liste „Standardwert“ steht nur zur Verfügung, wenn im Feld „Typ“ die Einstellung „Benutzereingabe“ oder „Schreibgeschützt“ ausgewählt wurde. Die Option „Neutral“ steht nur dann in der Liste „Standardwert“ zur Verfügung, wenn auf der Registerkarte „Feld“ im Bereich „Statusangaben“ die Option „An/Aus/Neutral“ ausgewählt wurde.
Überprüfungsskript-Meldung und Fehler
Legt eine Meldung fest, die angezeigt wird, wenn ein angehängtes Überprüfungsskript einen inakzeptablen Wert ermittelt. Standardmäßig wird in einem solchen Fall zur Laufzeit ein Programmierfehler generiert. Wenn stattdessen eine Warnmeldung generiert werden soll, deaktivieren Sie die Option „Fehler“. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist. „Überprüfungsskript-Meldung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus.
Meldung beim Überschreiben eines Werts
Legt eine eigene Meldung fest, die den Benutzer darauf hinweist, dass er dabei ist, den Wert eines berechneten Feldes zu ändern. Die Meldung erscheint, wenn ein Benutzer den berechneten Wert ändert.
Diese Option steht nur zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Benutzer darf überschreiben“ gesetzt ist.
Verwandte Themen
Kontrollkästchen – Übersicht


Eigenschaften von Kontrollkästchen: Registerkarte „Bindung“

Wenn Sie ein Kontrollkästchen erzeugen, stehen Ihnen auf der Registerkarte „Bindung“ verschiedene Optionen zur Datenbindung zur Verfügung, die Sie auf das Objekt anwenden können. Die Optionen, die sich nicht direkt auf die Erstellung einer Datenverbindung beziehen, gelten für die an eine Datenquelle gebundenen und die in einer Datei gespeicherten Daten, wenn das Objekt an keine Datenquelle gebunden ist.
Name
Legt den Namen des Kontrollkästchens fest. Siehe So können Sie Objekte benennen und umbenennen.
Standardbindung
Legt die Standardmethode zum Binden von Daten fest:
    • Normal
Aktiviert die Optionen zum Zusammenführen und Speichern von Daten. Die Datenwerte werden den Adobe-Regeln zur Datenzusammenführung entsprechend zusammengeführt und gespeichert.
    • Global
Verbindet einen einzelnen Datenwert mit allen gleichnamigen Objekten (siehe So definieren Sie ein globales Feld).
    • Neue Datenverbindung
Startet den Assistenten „Neue Datenverbindung“. Weitere Informationen dazu, wie Sie eine Verbindung mit Hilfe des Assistenten definieren, finden Sie unter So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei oder So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank.
    • Ohne
Deaktiviert die Datenbindung. Da das Objekt keine zusammengeführten Daten erfasst oder anzeigt, bleiben alle Informationen, die zum Objekt gehören, beim Speichern oder Absenden der Formulardaten unberücksichtigt.
An-Wert
Legt den Wert des An-Status des Kontrollkästchens in der Datenquelle fest. Siehe So ändern Sie die den Statusangaben von Kontrollkästchen zugewiesenen Werte.
Aus-Wert
Legt den Wert des Aus-Status des Kontrollkästchens in der Datenquelle fest.
Neutral-Wert
Legt den Wert des Neutral-Status des Kontrollkästchens in der Datenquelle fest.
Import/Export-Bindungen
Legt eine Import/Export-Bindung für eine WSDL-Datenverbindung fest. Siehe So erstellen Sie eine Datenverbindung zu einer WSDL-Datei.
Verwandte Themen
Datenquellen


Zurück Weiter

LiveCycle Designer verwenden > Objekteigenschaften > Eigenschaften in der Palette „Objekt“ > Kreise

Kreise

Eigenschaften von Kreisen: Registerkarte „Zeichnen“


Eigenschaften von Kreisen: Registerkarte „Zeichnen“

Wenn Sie einen Kreis erstellen, enthält die Registerkarte „Zeichnen“ in der Palette „Objekt“ spezielle Optionen zur Formatierung von Kreisen.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Erscheinungsbild
Legt die Form des Objektes fest.
    • Ellipse
Zeichnet eine elliptische Form.
    • Kreis
Zeichnet eine kreisförmige Form.
    • Bogen
Zeichnet einen Bogen.
Anfang
Legt den Startpunkt eines Bogens fest.
Ende
Legt den Endpunkt eines Bogens fest.
Linienstil
Legt den Stil und die Stärke der Linie fest.
Color Picker
Sets the line color.
Füllfarbe
Legt einen Füllstil fest.
Farbauswahl
Legt die Füllfarben fest.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Verwandte Themen
Kreise, Linien und Rechtecke – Übersicht


Zurück Weiter

LiveCycle Designer verwenden > Objekteigenschaften > Eigenschaften in der Palette „Objekt“ > Inhaltsbereiche

Inhaltsbereiche

Eigenschaften von Inhaltsbereichen: Registerkarte „Inhaltsbereich“


Eigenschaften von Inhaltsbereichen: Registerkarte „Inhaltsbereich“

Wenn ein Inhaltsbereich ausgewählt ist, werden auf der Registerkarte „Inhaltsbereich“ zwei Optionen angezeigt.
Name
Legt den Namen des Inhaltsbereiches fest.
Fließrichtung
Legt die Fließrichtung für Teilformulare innerhalb des Inhaltsbereiches fest.
    • Von oben nach unten
Legt fest, dass die Tab- und Ausfüllreihenfolge auf der Seite von oben nach unten verläuft.
    • Von links nach rechts
Legt fest, dass die Tab- und Ausfüllreihenfolge oben beginnt und nach rechts verläuft, bis das letzte Objekt rechts auf der Seite erreicht ist. Ist der rechte Seitenrand erreicht, setzen sich die Tab-Reihenfolge und die Fließrichtung beim nächsten unteren Objekt links auf der Seite fort.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
Verwandte Themen
Inhaltsbereiche – Übersicht
Datenfluss zwischen Inhaltsbereichen


Datums-/Uhrzeitfelder

Eigenschaften von Datums-/Uhrzeitfeldern: Registerkarte „Feld“
Eigenschaften von Datums-/Uhrzeitfeldern: Registerkarte „Wert“
Eigenschaften von Datums-/Uhrzeitfeldern: Registerkarte „Bindung“
Beispiele für Datums-/Uhrzeitmuster


Eigenschaften von Datums-/Uhrzeitfeldern: Registerkarte „Feld“

Wenn Sie ein Datums-/Uhrzeitfeld auswählen, steht auf der Registerkarte „Feld“ eine Reihe von Optionen zur Formatierung von Datums-/Uhrzeitfeldern zur Verfügung.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Beschriftung
Legt eine Beschriftung für das Objekt fest.
„Beschriftung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Beschriftung dynamisch aus.
Erscheinungsbild
Legt einen Stil für die Begrenzung des Füllbereiches fest:
    • Ohne
Das Feld wird ohne Begrenzung angezeigt.
    • Unterstrichen
Das Feld wird unterstrichen.
    • Ausgefülltes Rechteck
Das Feld wird in einem ausgefüllten Rechteck angezeigt.
    • Versenktes Rechteck
Erzeugt einen Schatten um das Feld, der das Feld dreidimensional wirken lässt.
    • Benutzerdefiniert
Zeigt das Dialogfeld „Angepasstes Erscheinungsbild“ an. Wählen Sie diese Option, wenn Sie ein eigenes Design für den Füllbereich entwerfen möchten.
Länge auf sichtbaren Bereich beschränken
Legt die maximal zulässige Anzahl von Zeichen und Zahlen im Feld entsprechend der horizontalen Länge des Datums-/Uhrzeitfeldes fest.
Zeichenanzahl in Textfeld _ Zeichen
Aktiviert Begrenzungslinien im Feld.
Anzeigemuster
Legt das Muster für die Anzeige von formatierten Werten im Formular fest. Das Muster muss mit dem auf der Registerkarte „Bindung“ ausgewählten Datenformat kompatibel sein. Wenn also für das Datenformat „Datum“ festgelegt ist, muss das Muster einen Datumswert darstellen.
Zur Entwurfs- und Laufzeit werden formatierte Werte im Feld in einem Format angezeigt, das dem Gebietsschema entspricht.
Bearbeitungsmuster
Legt das Muster für die Syntax der Benutzereingabe fest. Das Muster muss mit dem auf der Registerkarte „Bindung“ ausgewählten Datenformat kompatibel sein. Wenn also für das Datenformat „Datum“ festgelegt ist, muss das Muster einen Datumswert darstellen. Entspricht die Benutzereingabe dem Bearbeitungsmuster nicht, werden die Daten nicht akzeptiert, und der Feldwert wird nicht formatiert.
Zur Entwurfs- und Laufzeit werden formatierte Werte im Feld in einem Format angezeigt, das dem Gebietsschema entspricht.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Datums-/Uhrzeitfelder – Übersicht
So legen Sie ein Anzeigemuster fest
So legen Sie ein Bearbeitungsmuster fest
Datums- und Uhrzeitmuster


Eigenschaften von Datums-/Uhrzeitfeldern: Registerkarte „Wert“

Wenn Sie ein Datums-/Uhrzeitfeld erzeugen, steht Ihnen auf der Registerkarte „Wert“ eine Reihe von Optionen zur Verfügung, die Sie auf das Objekt anwenden können.
Typ
Ermöglicht Berechnungen und Eingabeaufforderungen zur Laufzeit:
    • Benutzereingabe - Optional
Der Benutzer kann selbst entscheiden, ob er Daten eingeben möchte.
    • Benutzereingabe - Empfohlen
Wenn der Benutzer keine Daten eingibt, wird eine eigene Meldung angezeigt (soweit sie im Feld „Meldung bei leerem Feld“ eingetragen worden ist).
    • Benutzereingabe - Erforderlich
Wenn der Benutzer keine Daten eingibt, wird eine eigene Meldung angezeigt (soweit sie im Feld „Meldung bei leerem Feld“ eingetragen worden ist).
    • Berechnet - Schreibgeschützt
Ein Datenwert wird über ein angehängtes Skript berechnet und angezeigt. Die Benutzer können den berechneten Wert nicht bearbeiten.
    • Berechnet - Benutzer darf überschreiben
Ein Datenwert wird über ein angehängtes Skript berechnet und angezeigt. Die Benutzer können den berechneten Wert bearbeiten, wenn im Berechnungsskript eine Verarbeitung der Benutzereingabe vorgesehen ist. Wenn ein Benutzer den berechneten Wert bearbeiten möchte, wird eine Meldung angezeigt, die im Feld „Meldung beim Überschreiben eines Werts“ festgelegt wurde.
    • Schreibgeschützt
Ein Datenwert wird zur Laufzeit zusammengeführt oder berechnet und angezeigt. Die Benutzer können den Wert nicht bearbeiten.
Standardwert
Legt einen Ausgangswert für das Feld fest. Der Wert wird entsprechend der Einstellung der Option „Anzeigemuster“ auf der Registerkarte „Feld“ formatiert. Er muss allerdings dem kurzen Datums- oder Uhrzeitformat des Gebietsschemas entsprechen, das für das Feld gilt. Weitere Informationen zu kurzen Datums- und Uhrzeitformaten finden Sie unter Datumsformate und Uhrzeitformate. Wenn die Daten gebunden sind und ein Datenmuster festgelegt wurde, muss der Wert mit dem auf der Registerkarte „Bindung“ festgelegten Datenmuster übereinstimmen. Siehe So legen Sie einen Standardwert fest.
Diese Option steht nur dann zur Verfügung, wenn die Option „Typ“ auf „Benutzereingabe - Optional“, „Benutzereingabe - Empfohlen“, „Benutzereingabe - Erforderlich“ oder „Schreibgeschützt“ gesetzt ist.
Meldung bei leerem Feld
Legt eine Meldung fest, mit der die Benutzer zur Eingabe eines empfohlenen oder erforderlichen Wertes aufgefordert werden. Siehe So fordern Sie Benutzer zur Dateneingabe auf.
Diese Option ist nur dann verfügbar, wenn die Option „Typ“ auf „Benutzereingabe - Empfohlen“ oder „Benutzereingabe - Erforderlich“ gesetzt ist.
Überprüfungsmuster
Legt ein Überprüfungsmuster für die Benutzereingabe fest. Das Muster muss der Syntax der Benutzereingabe entsprechen und mit dem auf der Registerkarte „Bindung“ ausgewählten Datenformat kompatibel sein. Wenn also für das Datenformat „Datum“ festgelegt ist, muss das Muster einen Datumswert darstellen. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist.
Überprüfungsmuster-Meldung und Fehler
Legt eine eigene Meldung fest, die angezeigt wird, wenn ein Rohwert nicht dem Überprüfungsmuster entspricht. Standardmäßig wird in einem solchen Fall zur Laufzeit ein Programmierfehler generiert. Wenn stattdessen eine Warnmeldung generiert werden soll, deaktivieren Sie die Option „Fehler“. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist. „Überprüfungsmuster-Meldung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus.
Überprüfungsskript-Meldung und Fehler
Legt eine Meldung fest, die angezeigt wird, wenn ein angehängtes Überprüfungsskript einen inakzeptablen Wert ermittelt. Standardmäßig wird in einem solchen Fall zur Laufzeit ein Programmierfehler generiert. Wenn stattdessen eine Warnmeldung generiert werden soll, deaktivieren Sie die Option „Fehler“. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist. „Überprüfungsskript-Meldung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus.
Berechnungsskript
Der Wert wird durch ein Skript berechnet, das für das calculate-Ereignis des Objekts geschrieben wurde.
Diese Option steht nur zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ gesetzt ist.
Laufzeiteigenschaften
Legt die folgenden Laufzeiteigenschaften für das Objekt fest. Wenn Sie eine Laufzeiteigenschaft auswählen, wird der eigentliche Wert, der der Option entspricht, bei der Wiedergabe des Formulars dynamisch eingefügt.
    • Aktuelles Datum/Uhrzeit
Zeigt das aktuelle Datum und die Uhrzeit im Datums-/Uhrzeitfeld an.
Diese Option steht nur zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ gesetzt ist.
Meldung beim Überschreiben eines Werts
Legt eine eigene Meldung fest, die den Benutzer darauf hinweist, dass er dabei ist, den Wert eines berechneten Feldes zu ändern. Die Meldung erscheint, wenn ein Benutzer den berechneten Wert ändert.
Diese Option steht nur zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Benutzer darf überschreiben“ gesetzt ist.
Verwandte Themen
Datums-/Uhrzeitfelder – Übersicht


Eigenschaften von Datums-/Uhrzeitfeldern: Registerkarte „Bindung“

Wenn Sie ein Datums-/Uhrzeitfeld erstellen, enthält die Registerkarte „Bindung“ Optionen, die Sie auf das Feld anwenden können. Die Optionen, die sich nicht direkt auf die Erstellung einer Datenverbindung beziehen, gelten für die an eine Datenquelle gebundenen und die in einer Datei gespeicherten Daten, wenn das Objekt an keine Datenquelle gebunden ist.
Name
Legt den Namen des Datums-/Uhrzeitfeldes fest. Siehe So können Sie Objekte benennen und umbenennen.
Standardbindung
Legt die Standardmethode zum Binden von Daten fest:
    • Normal
Aktiviert die Optionen zum Zusammenführen und Speichern von Daten. Die Datenwerte werden den Adobe-Regeln zur Datenzusammenführung entsprechend zusammengeführt und gespeichert.
    • Global
Verbindet einen einzelnen Datenwert mit allen gleichnamigen Objekten (siehe So definieren Sie ein globales Feld).
    • Neue Datenverbindung
Startet den Assistenten „Neue Datenverbindung“. Weitere Informationen dazu, wie Sie eine Verbindung mit Hilfe des Assistenten definieren, finden Sie unter So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei oder So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank.
    • Ohne
Deaktiviert die Datenbindung. Da das Objekt keine zusammengeführten Daten erfasst oder anzeigt, bleiben alle Informationen, die zum Objekt gehören, beim Speichern oder Absenden der Formulardaten unberücksichtigt.
Datenmuster
Legt ein Muster für das Speichern und Abrufen gebundener Daten oder für das Speichern von Daten fest, wenn das Formular nicht an eine Datenquelle gebunden ist. Siehe So legen Sie ein Datenmuster fest.
Datenformat
Legt den Inhalt des Feldes fest.
    • Datum
Legt fest, dass das Objekt ein Datum ist.
    • Uhrzeit
Legt fest, dass das Objekt eine Uhrzeit ist.
    • Datum und Uhrzeit
Legt fest, dass das Objekt ein Datum und eine Uhrzeit ist.
Import/Export-Bindungen
Legt eine Import/Export-Bindung für eine WSDL-Datenverbindung fest. Siehe So erstellen Sie eine Datenverbindung zu einer WSDL-Datei.
Verwandte Themen
Datenquellen
Datums-/Uhrzeitfelder – Übersicht
So legen Sie die in Datums-/Uhrzeitfeldern angezeigten Daten fest
Datums- und Uhrzeitmuster


Beispiele für Datums-/Uhrzeitmuster

Formatierte Werte können angezeigt oder verarbeitet werden. Rohwerte entsprechen den LiveCycle Designer-Standards.
Vordefinierte Muster
Die folgende Tabelle gibt die vordefinierten Datums- und Uhrzeitmuster an, die Sie in der Palette „Objekt“ auf der Registerkarte „Feld“ unter „Anzeigemuster“ auswählen können. Sie enthält außerdem einige Beispiele dafür, wie verschiedene Standardeingabewerte nach der Formatierung anhand des angegebenen Gebietsschemas aussehen. Allen Beispielen liegt das englische Gebietsschema (USA) zugrunde.

Vordefiniertes Muster

Eingabewert (im kurzen Format, d. h. M/D/YY beim Datum und h:MM A bei der Uhrzeit)

Formatierter Wert
YYYY-MM-DD
8/23/08
2008-08-23
EEEE, MMMM D, YYYY
8/23/08
Saturday, August 23, 2008
HH:MM:SS
17.02 Uhr
17:02:00
Datum{YYYY-MM-DD} Uhrzeit{HH:MM:SS}
8/23/08 17.02 Uhr
2008-08-23 17:02:00
Wenn Sie wissen möchten, wie das standardmäßige Kurzformat für das Datum und die Uhrzeit lautet, wählen Sie „Ansicht“ > „XML-Quelle“, und suchen Sie folgende Zeilen:
<datePatterns>
   <datePattern name="full">EEEE, MMMM D, YYYY</datePattern>
   <datePattern name="long">MMMM D, YYYY</datePattern>
   <datePattern name="med">MMM D, YYYY</datePattern>
   <datePattern name="short">M/D/YY</datePattern>
</datePatterns>
<timePatterns>
   <timePattern name="full">h:MM:SS A Z</timePattern>
   <timePattern name="long">h:MM:SS A Z</timePattern>
   <timePattern name="med">h:MM:SS A</timePattern>
   <timePattern name="short">h:MM A</timePattern>
</timePatterns>
Eigene Muster
In der folgenden Tabelle werden einige eigene Anzeigemuster aufgeführt, die Sie zur Formatierung von Standardeingabewerten anhand des angegebenen Gebietsschemas definieren können. Allen Beispielen liegt das englische Gebietsschema (USA) zugrunde.

Eigenes Muster

Eingabewert (im kurzen Format, d. h. M/T/JJ beim Datum und h:MM A bei der Uhrzeit)

Formatierter Wert
MMMM DD, YYYYJ
8/23/08
August 23, 2008
EEEE, 'den' D'.' MMMM, YYYY
8/23/08
Samstag, den 23. August, 2008
HH:MM
17.02 Uhr
17:02
h:MM:SS 'Uhr' A Z
17.02 Uhr
17:02:00 Uhr EDT
HH:MM:SS Z
17.02 Uhr
17:02:00 EDT


Zurück Weiter

LiveCycle Designer verwenden > Objekteigenschaften > Eigenschaften in der Palette „Objekt“ > Dezimalfelder

Dezimalfelder

Eigenschaften von Dezimalfeldern: Registerkarte „Feld“


Eigenschaften von Dezimalfeldern: Registerkarte „Feld“

Wenn Sie ein Dezimalfeld auswählen, werden in der Palette „Objekt“ auf der Registerkarte „Feld“ eine Reihe von Optionen für Dezimalfelder angezeigt. Nur zwei der Optionen sind ausschließlich für Dezimalfelder verfügbar; alle anderen werden auch für numerische Felder angezeigt.
Stellen vor dem Komma begrenzen und Maximal
Legt fest, wie viele Stellen maximal vor dem Dezimalzeichen stehen können. Bei einer Überschreitung des Höchstwerts wird eine Null angezeigt.
Standardwert: Unbeschränkt
Höchstwert: 15 (einschließlich Stellen nach dem Komma)
Stellen nach dem Komma begrenzen und Maximal
Legt fest, wie viele Stellen maximal nach dem Dezimalzeichen stehen können. Bei einer Überschreitung des Höchstwerts wird die Zahl gerundet. Wenn Sie die Option „Stellen nach dem Komma begrenzen“ deaktivieren, werden Dezimalwerte exakt so angezeigt, wie sie eingegeben wurden.
Standardwert: 2
Höchstwert: 15 (einschließlich Stellen vor dem Komma)
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Verwandte Themen
Dezimalfelder – Übersicht
Numerische Felder – Übersicht
Eigenschaften von numerischen Feldern: Registerkarte „Feld“
Eigenschaften von numerischen Feldern: Registerkarte „Wert“
Eigenschaften von numerischen Feldern: Registerkarte „Bindung“


Dokumentunterschriftsfelder

Eigenschaften von Dokumentunterschriftsfeldern: Registerkarte „Feld“
Eigenschaften von Dokumentunterschriftsfeldern: Registerkarte „Dokumentunterschrift“


Eigenschaften von Dokumentunterschriftsfeldern: Registerkarte „Feld“

Wenn Sie ein Dokumentunterschriftsfeld auswählen, zeigt die Registerkarte „Feld“ in der Palette „Objekt“ eine Reihe von Optionen zur Formatierung von Dokumentunterschriftsfeldern an.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Beschriftung
Legt eine Beschriftung für das Objekt fest.
„Beschriftung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Beschriftung dynamisch aus.
Erscheinungsbild
Legt einen Stil für die Begrenzung des Füllbereiches fest:
    • Ohne
Das Feld wird ohne Begrenzung angezeigt.
    • Unterstrichen
Das Feld wird unterstrichen.
    • Ausgefülltes Rechteck
Das Feld wird in einem ausgefüllten Rechteck angezeigt.
    • Versenktes Rechteck
Erzeugt einen Schatten um das Feld, der das Feld dreidimensional wirken lässt.
    • Benutzerdefiniert
Zeigt das Dialogfeld „Angepasstes Erscheinungsbild“ an. Wählen Sie diese Option, wenn Sie ein eigenes Design für den Füllbereich entwerfen möchten.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Dokumentunterschriftsfelder – Übersicht
Digitale Unterschriften


Zurück Weiter

LiveCycle Designer verwenden > Objekteigenschaften > Eigenschaften in der Palette „Objekt“ > Dokumentunterschriftsfelder > Eigenschaften von Dokumentunterschriftsfeldern: Registerkarte „Dokumentunterschrift“

Eigenschaften von Dokumentunterschriftsfeldern: Registerkarte „Dokumentunterschrift“

Wenn Sie ein Dokumentunterschriftsfeld auswählen, zeigt die Registerkarte „Dokumentunterschrift“ in der Palette „Objekt“ eine Reihe von Optionen zur Konfiguration von Dokumentunterschriftsfeldern an. Wenn die Dokumentunterschrift auf eine Sammlung von Objekten angewendet wird, sind folgende Objekttypen zulässig: Schaltflächen, Kontrollkästchen, Datums-/Uhrzeitfelder, Dezimalfelder, Dropdown-Listen, Bildfelder, Listenfelder, numerische Felder, Papierformular-Barcodes, Kennwortfelder, Optionsfelder, andere Dokumentunterschriftsfelder und Textfelder.
Klicken Sie auf die Schaltfläche „Einstellungen“, um optionale Sicherheitseinstellungen für die Datenunterschrift, wie etwa den Unterschriften-Handler, Unterschriftszertifikate und Zertifikataussteller, zu definieren.
Felder nach dem Unterschreiben sperren
Gibt an, für welche Formularobjekte die Dokumentunterschrift gilt. Sie können ein Dokumentunterschriftsfeld auf ein gesamtes Formular oder auf eine Sammlung von Objekten in einem Formular anwenden. Wenn Sie diese Option nicht auswählen, gilt die Dokumentunterschrift standardmäßig für das gesamte Formular. Wählen Sie diese Option aus, dann gilt die Unterschrift für die ausgewählten Objekte. Nachdem der Ausfüller des Formulars das Formular unterschrieben hat, werden die unterschriebenen Felder gesperrt. Sie können die zu unterschreibende Objektsammlung in der Dropdown-Liste auswählen.
    • Alle Felder im Dokument
Sperrt alle Felder im Dokument.
    • Alle Felder in der Sammlung
Sperrt alle Felder in der ausgewählten Sammlung.
    • Alle Felder außerhalb der Sammlung
Sperrt alle Felder, die nicht in der Sammlung enthalten sind.
    • Sammlung - Neu/verwalten
Zeigt das Dialogfeld „Sammlungsliste“ an, in dem Sie eine Sammlung von Feldern für die Dokumentunterschrift erstellen oder ändern können.
Verwandte Themen
Dokumentunterschriftsfelder – Übersicht
Digitale Unterschriften
Info über Formularobjektsammlungen


Dropdown-Listen

Eigenschaften von Dropdown-Listen: Registerkarte „Feld“
Eigenschaften von Dropdown-Listen: Registerkarte „Wert“
Eigenschaften von Dropdown-Listen: Registerkarte „Bindung“


Eigenschaften von Dropdown-Listen: Registerkarte „Feld“

Wenn Sie eine Dropdown-Liste auswählen, steht auf der Registerkarte „Feld“ eine Reihe von Optionen zur Formatierung bereit.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Beschriftung
Legt eine Beschriftung für das Objekt fest.
„Beschriftung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Beschriftung dynamisch aus.
Erscheinungsbild
Legt einen Stil für die Begrenzung des Füllbereiches fest:
    • Ohne
Das Feld wird ohne Begrenzung angezeigt.
    • Unterstrichen
Das Feld wird unterstrichen.
    • Ausgefülltes Rechteck
Das Feld wird in einem ausgefüllten Rechteck angezeigt.
    • Versenktes Rechteck
Erzeugt einen Schatten um das Feld, der das Feld dreidimensional wirken lässt.
    • Benutzerdefiniert
Zeigt das Dialogfeld „Angepasstes Erscheinungsbild“ an. Wählen Sie diese Option, wenn Sie ein eigenes Design für den Füllbereich entwerfen möchten.
Listenelemente
Legt die Listeneinträge und ihre Reihenfolge fest. Mit Hilfe der Schaltflächen können Sie die Listenelemente nach oben oder unten verschieben und in auf- oder absteigender Reihenfolge sortieren.
„Listenelemente“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren.
Benutzereingabe zulassen
Aktiviert oder deaktiviert benutzerseitige Eingaben. Benutzereingaben müssen dem LiveCycle Designer-Standard entsprechen. Siehe Standards für die Wertformatierung.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Dropdown-Listen und Listenfelder – Übersicht


Eigenschaften von Dropdown-Listen: Registerkarte „Wert“

Wenn Sie eine Dropdown-Liste erzeugen, steht Ihnen auf der Registerkarte „Wert“ eine Reihe von Optionen zur Verfügung, die Sie auf das Objekt anwenden können.
Typ
Ermöglicht Berechnungen und Eingabeaufforderungen zur Laufzeit:
    • Benutzereingabe - Optional
Der Benutzer kann selbst entscheiden, ob er Daten eingeben möchte.
    • Benutzereingabe - Empfohlen
Wenn der Benutzer keine Daten eingibt, wird eine eigene Meldung angezeigt (soweit sie im Feld „Meldung bei leerem Feld“ eingetragen worden ist).
    • Benutzereingabe - Erforderlich
Wenn der Benutzer keine Daten eingibt, wird eine eigene Meldung angezeigt (soweit sie im Feld „Meldung bei leerem Feld“ eingetragen worden ist).
    • Berechnet - Schreibgeschützt
Ein Datenwert wird über ein angehängtes Skript berechnet und angezeigt. Die Benutzer können den berechneten Wert nicht bearbeiten.
    • Berechnet - Benutzer darf überschreiben
Ein Datenwert wird über ein angehängtes Skript berechnet und angezeigt. Die Benutzer können den berechneten Wert bearbeiten, wenn im Berechnungsskript eine Verarbeitung der Benutzereingabe vorgesehen ist. Wenn ein Benutzer den berechneten Wert bearbeiten möchte, wird eine Meldung angezeigt, die im Feld „Meldung beim Überschreiben eines Werts“ festgelegt wurde.
    • Schreibgeschützt
Ein Datenwert wird zur Laufzeit zusammengeführt oder berechnet und angezeigt. Die Benutzer können den Wert nicht bearbeiten.
Standardwert
Legt die Standardauswahl fest. Wenn auf der Registerkarte „Feld“ die Option „Benutzereintrag zulassen“ aktiviert wurde, können Sie als Standardwert auch einen Wert eingeben, der sich nicht in der Liste befindet.
Diese Option steht nur dann zur Verfügung, wenn die Option „Typ“ auf „Benutzereingabe - Optional“, „Benutzereingabe - Empfohlen“, „Benutzereingabe - Erforderlich“ oder „Schreibgeschützt“ gesetzt ist.
Meldung bei leerem Feld
Legt eine Meldung fest, mit der die Benutzer zur Eingabe eines empfohlenen oder erforderlichen Wertes aufgefordert werden. Siehe So fordern Sie Benutzer zur Dateneingabe auf.
Diese Option ist nur dann verfügbar, wenn die Option „Typ“ auf „Benutzereingabe - Empfohlen“ oder „Benutzereingabe - Erforderlich“ gesetzt ist.
Überprüfungsmuster
Legt ein Überprüfungsmuster für die Benutzereingabe fest. Das Muster muss mit der Syntax der Benutzereingabe übereinstimmen. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist.
Überprüfungsmuster-Meldung und Fehler
Legt eine eigene Meldung fest, die angezeigt wird, wenn ein Rohwert nicht dem Überprüfungsmuster entspricht. Standardmäßig wird in einem solchen Fall zur Laufzeit ein Programmierfehler generiert. Wenn stattdessen eine Warnmeldung generiert werden soll, deaktivieren Sie die Option „Fehler“. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist. „Überprüfungsmuster-Meldung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus.
Überprüfungsskript-Meldung und Fehler
Legt eine Meldung fest, die angezeigt wird, wenn ein angehängtes Überprüfungsskript einen inakzeptablen Wert ermittelt. Standardmäßig wird in einem solchen Fall zur Laufzeit ein Programmierfehler generiert. Wenn stattdessen eine Warnmeldung generiert werden soll, deaktivieren Sie die Option „Fehler“. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist. „Überprüfungsskript-Meldung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus.
Meldung beim Überschreiben eines Werts
Legt eine eigene Meldung fest, die den Benutzer darauf hinweist, dass er dabei ist, den Wert eines berechneten Feldes zu ändern. Die Meldung erscheint, wenn ein Benutzer den berechneten Wert ändert.
Diese Option steht nur zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Benutzer darf überschreiben“ gesetzt ist.
Verwandte Themen
Dropdown-Listen und Listenfelder – Übersicht


Eigenschaften von Dropdown-Listen: Registerkarte „Bindung“

Wenn Sie eine Dropdown-Liste erstellen, enthält die Registerkarte „Bindung“ Optionen, die Sie auf die Liste anwenden können. Die Optionen, die sich nicht direkt auf die Erstellung einer Datenverbindung beziehen, gelten für die an eine Datenquelle gebundenen und die in einer Datei gespeicherten Daten, wenn das Objekt an keine Datenquelle gebunden ist.
Name
Legt den Namen des Listenfeldes fest. Siehe So können Sie Objekte benennen und umbenennen.
Standardbindung
Legt die Standardmethode zum Binden von Daten fest:
    • Normal
Aktiviert die Optionen zum Zusammenführen und Speichern von Daten. Die Datenwerte werden den Adobe-Regeln zur Datenzusammenführung entsprechend zusammengeführt und gespeichert.
    • Global
Verbindet einen einzelnen Datenwert mit allen gleichnamigen Objekten (siehe So definieren Sie ein globales Feld).
    • Neue Datenverbindung
Startet den Assistenten „Neue Datenverbindung“. Weitere Informationen dazu, wie Sie eine Verbindung mit Hilfe des Assistenten definieren, finden Sie unter So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei oder So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank.
    • Ohne
Deaktiviert die Datenbindung. Da das Objekt keine zusammengeführten Daten erfasst oder anzeigt, bleiben alle Informationen, die zum Objekt gehören, beim Speichern oder Absenden der Formulardaten unberücksichtigt.
Elementwerte
Ermöglicht Ihnen das Festlegen benutzerdefinierter Datenwerte für jedes Listenelement. Wenn diese Option nicht ausgewählt ist, entsprechen die Datenwerte dem Text der Listenelemente. Wenn diese Option ausgewählt ist, sind die Standardwerte fortlaufende Ganzzahlen, wobei dem ersten Listenelement „0“ zugewiesen ist. Siehe So legen Sie Listenelementwerte für Dropdown-Listen oder Listenfelder fest.
„Elementwerte“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren.
Nach oben, Nach unten, Aufsteigend sortieren, Absteigend sortieren
Ändert die Reihenfolge der Elemente in der Liste (wenn die Daten beispielsweise in einer Reihenfolge gespeichert werden sollen, die von der Optionsanzeige in der Dropdown-Liste abweicht). Sie können Listenelemente mit Hilfe der entsprechenden Schaltflächen nach oben oder unten verschieben und in auf- oder absteigender Reihenfolge sortieren.
Import/Export-Bindungen
Legt eine Import/Export-Bindung für eine WSDL-Datenverbindung fest. Siehe So erstellen Sie eine Datenverbindung zu einer WSDL-Datei.
Verwandte Themen
Datenquellen


Zurück Weiter

LiveCycle Designer verwenden > Objekteigenschaften > Eigenschaften in der Palette „Objekt“ > E-Mail-Senden-Schaltfläche

E-Mail-Senden-Schaltfläche

Eigenschaften der E-Mail-Senden-Schaltfläche: Registerkarte „Feld“


Eigenschaften der E-Mail-Senden-Schaltfläche: Registerkarte „Feld“

Wenn Sie eine E-Mail-Senden-Schaltfläche auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Feld“ verschiedene Optionen zum Formatieren zur Verfügung.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Beschriftung
Legt eine Beschriftung für das Objekt fest.
„Beschriftung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Beschriftung dynamisch aus.
Erscheinungsbild
Legt den Begrenzungsstil fest:
    • Keine Begrenzung
Entfernt die Linie, die die Schaltfläche umrahmt.
    • Durchgehende Begrenzung
Erzeugt eine breite Linie, die die Schaltfläche umrahmt.
    • Angehobene Begrenzung
Erzeugt einen Schatten um die Schaltfläche, der die Schaltfläche dreidimensional wirken lässt.
    • Benutzerdefiniert
Zeigt das Dialogfeld „Angepasstes Erscheinungsbild“ an. Wählen Sie diese Option, wenn Sie das Erscheinungsbild der Schaltfläche selbst festlegen möchten.
Hervorhebung
Legt die Schaltflächen-Hervorhebung fest, die beim Klicken auf die Schaltfläche angezeigt wird:
    • Ohne
Entfernt die Schaltflächen-Hervorhebung.
    • Invertiert
Invertiert die Schaltflächen-Hervorhebung, wenn auf die Schaltfläche geklickt wird.
    • Schaltfläche
Erzeugt an den Rändern der Schaltfläche eine Schattierung, um die Schaltfläche vertieft darzustellen.
    • Kontur
Erzeugt eine Linie, die die Schaltfläche umrahmt, wenn auf die Schaltfläche geklickt wird.
Text bei Rollover
Legt einen Text bei Rollover fest, wenn „Schaltfläche“ als Schaltflächen-Hervorhebung eingestellt ist. Dieser Text wird angezeigt, wenn der Mauszeiger über die Schaltfläche bewegt wird.
Text bei Aktivierung
Legt einen Text bei Aktivierung fest, wenn „Schaltfläche“ als Schaltflächen-Hervorhebung eingestellt ist. Dieser Text wird beim Klicken auf die Schaltfläche angezeigt.
E-Mail-Adresse
Legt die Empfänger der E-Mail und der angehängten Formulardaten fest.
E-Mail-Betreff
Legt die Betreffzeile für die E-Mail fest.
Sendung unterschreiben
Wendet eine Datenunterschrift auf die gesendeten Daten an. Wenn der Benutzer beim Ausfüllen auf diese Schaltfläche klickt, wird eine digitale Unterschrift für die gesendeten Daten und Anhänge erstellt. Datenunterschriften sichern die unterschriebenen Daten und gewährleisten deren Integrität bei der Übertragung. Datenunterschriften können auf die Formulardaten oder auf die gesamte Sendung einschließlich der Anhänge angewendet werden. Klicken Sie auf die Schaltfläche „Einstellungen“, um optionale Sicherheitseinstellungen für die Datenunterschrift, wie etwa den Unterschriften-Handler, Unterschriftszertifikate und Zertifikataussteller, zu definieren.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
E-Mail-Senden-Schaltflächen – Übersicht


Zurück Weiter

LiveCycle Designer verwenden > Objekteigenschaften > Eigenschaften in der Palette „Objekt“ > HTTP-Senden-Schaltfläche

HTTP-Senden-Schaltfläche

Eigenschaften der HTTP-Senden-Schaltfläche: Registerkarte „Feld“


Eigenschaften der HTTP-Senden-Schaltfläche: Registerkarte „Feld“

Wenn Sie eine HTTP-Mail-Senden-Schaltfläche auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Feld“ verschiedene Optionen zum Formatieren zur Verfügung.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Beschriftung
Legt eine Beschriftung für das Objekt fest.
„Beschriftung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Beschriftung dynamisch aus.
Erscheinungsbild
Legt den Begrenzungsstil fest:
    • Keine Begrenzung
Entfernt die Linie, die die Schaltfläche umrahmt.
    • Durchgehende Begrenzung
Erzeugt eine breite Linie, die die Schaltfläche umrahmt.
    • Angehobene Begrenzung
Erzeugt einen Schatten um die Schaltfläche, der die Schaltfläche dreidimensional wirken lässt.
    • Benutzerdefiniert
Zeigt das Dialogfeld „Angepasstes Erscheinungsbild“ an. Wählen Sie diese Option, wenn Sie das Erscheinungsbild der Schaltfläche selbst festlegen möchten.
Hervorhebung
Legt die Schaltflächen-Hervorhebung fest, die beim Klicken auf die Schaltfläche angezeigt wird:
    • Ohne
Entfernt die Schaltflächen-Hervorhebung.
    • Invertiert
Invertiert die Schaltflächen-Hervorhebung, wenn auf die Schaltfläche geklickt wird.
    • Schaltfläche
Erzeugt an den Rändern der Schaltfläche eine Schattierung, um die Schaltfläche vertieft darzustellen.
    • Kontur
Erzeugt eine Linie, die die Schaltfläche umrahmt, wenn auf die Schaltfläche geklickt wird.
Text bei Rollover
Legt einen Text bei Rollover fest, wenn „Schaltfläche“ als Schaltflächen-Hervorhebung eingestellt ist. Dieser Text wird angezeigt, wenn der Mauszeiger über die Schaltfläche bewegt wird.
Text bei Aktivierung
Legt einen Text bei Aktivierung fest, wenn „Schaltfläche“ als Schaltflächen-Hervorhebung eingestellt ist. Dieser Text wird beim Klicken auf die Schaltfläche angezeigt.
URL
Die URL, an die das Formular gesendet wird.
Sendung unterschreiben
Wendet eine Datenunterschrift auf die gesendeten Daten an. Wenn der Benutzer beim Ausfüllen auf diese Schaltfläche klickt, wird eine digitale Unterschrift für die gesendeten Daten und Anhänge erstellt. Datenunterschriften sichern die unterschriebenen Daten und gewährleisten deren Integrität bei der Übertragung. Datenunterschriften können auf die Formulardaten oder auf die gesamte Sendung einschließlich der Anhänge angewendet werden. Klicken Sie auf die Schaltfläche „Einstellungen“, um optionale Sicherheitseinstellungen für die Datenunterschrift, wie etwa den Unterschriften-Handler, Unterschriftszertifikate und Zertifikataussteller, zu definieren.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
HTTP-Senden-Schaltflächen – Übersicht


Zurück Weiter

LiveCycle Designer verwenden > Objekteigenschaften > Eigenschaften in der Palette „Objekt“ > Bildfelder

Bildfelder

Eigenschaften von Bildfeldern: Registerkarte „Feld“
Eigenschaften von Bildfeldern: Registerkarte „Bindung“


Eigenschaften von Bildfeldern: Registerkarte „Feld“

Wenn Sie ein Bildfeld auswählen, ist auf der Registerkarte „Feld“ eine Reihe von Optionen zur Formatierung von Bildfeldern verfügbar.
Type
Sets the type of object. Objects are the building blocks of every form.
Beschriftung
Legt eine Beschriftung für das Objekt fest.
„Beschriftung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Beschriftung dynamisch aus.
URL
Gibt den Speicherort der Quelldatei des Bildes an. Wenn Sie relative Pfadnamen zu verknüpften Bildern festlegen möchten, die beim Öffnen des Formulars abgerufen werden, müssen sich die Bilddateien in einem Ordner befinden, auf den die Benutzer zugreifen können. Wenn LiveCycle Forms verfügbar ist, muss der Pfad relativ zu LiveCycle Forms angegeben werden.
Bilddaten einbetten
Wenn diese Option ausgewählt ist, wird eine Kopie der Bilddaten im Formular gespeichert. Ist die Option deaktiviert, werden die Bilddaten getrennt vom Formular gespeichert. Das Bild wird abgerufen, wenn das Formular geöffnet wird.
Wenn das Bildfeld zum dynamischen Laden von Bildern bei der Wiedergabe des Formulars verwendet wird, darf die Option „Bilddaten einbetten“ nicht ausgewählt werden.
Größe
Aktiviert bzw. deaktiviert die Größenbearbeitung von Bildern, wenn das Bild geladen wird.
    • Bild proportional skalieren
Passt das Bild im Objekt an und bewahrt dabei das Seitenverhältnis.
    • Bild passend für Rechteck skalieren
Passt die Bildgröße an die Objektmaße an. Das Seitenverhältnis wird nicht beibehalten.
    • Originalgröße verwenden
Die Bildgröße wird nicht verändert. Die Objektgröße wird an die tatsächliche Bildgröße angepasst.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Bildfelder – Übersicht


Eigenschaften von Bildfeldern: Registerkarte „Bindung“

Wenn Sie ein Bildfeld erstellen, enthält die Registerkarte „Bindung“ Bindungsoptionen, die Sie auf das Objekt anwenden können. Die Optionen, die sich nicht direkt auf die Erstellung einer Datenverbindung beziehen, gelten für die an eine Datenquelle gebundenen und die in einer Datei gespeicherten Daten, wenn das Objekt an keine Datenquelle gebunden ist.
Name
Legt den Namen des Bildfeldes fest. Siehe So können Sie Objekte benennen und umbenennen.
Standardbindung
Legt die Standardmethode zum Binden von Daten fest:
    • Normal
Aktiviert die Optionen zum Zusammenführen und Speichern von Daten. Die Datenwerte werden den Adobe-Regeln zur Datenzusammenführung entsprechend zusammengeführt und gespeichert.
    • Global
Verbindet einen einzelnen Datenwert mit allen gleichnamigen Objekten (siehe So definieren Sie ein globales Feld).
    • Neue Datenverbindung
Startet den Assistenten „Neue Datenverbindung“. Weitere Informationen dazu, wie Sie eine Verbindung mit Hilfe des Assistenten definieren, finden Sie unter So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei oder So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank.
    • Ohne
Deaktiviert die Datenbindung. Da das Objekt keine zusammengeführten Daten erfasst oder anzeigt, bleiben alle Informationen, die zum Objekt gehören, beim Speichern oder Absenden der Formulardaten unberücksichtigt.
Import/Export-Bindungen
Legt eine Import/Export-Bindung für eine WSDL-Datenverbindung fest. Siehe So erstellen Sie eine Datenverbindung zu einer WSDL-Datei.
Verwandte Themen
Datenquellen


Zurück Weiter

LiveCycle Designer verwenden > Objekteigenschaften > Eigenschaften in der Palette „Objekt“ > Bilder

Bilder

Eigenschaften von Bildern: Registerkarte „Zeichnen“


Eigenschaften von Bildern: Registerkarte „Zeichnen“

Wenn Sie ein Bildobjekt erzeugen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Zeichnen“ verschiedene Optionen zum Formatieren zur Verfügung.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
URL
Gibt den Speicherort der Quelldatei des Bildes an. Wenn Sie relative Pfadnamen zu verknüpften Bildern festlegen möchten, die beim Öffnen des Formulars abgerufen werden, müssen sich die Bilddateien in einem Ordner befinden, auf den die Benutzer zugreifen können. Wenn LiveCycle Forms verfügbar ist, muss der Pfad relativ zu LiveCycle Forms angegeben werden.
Bilddaten einbetten
Wenn diese Option ausgewählt ist, wird eine Kopie der Bilddaten im Formular gespeichert. Ist die Option deaktiviert, werden die Bilddaten getrennt vom Formular gespeichert. Das Bild wird abgerufen, wenn das Formular geöffnet wird.
Größe
Aktiviert bzw. deaktiviert die Größenbearbeitung von Bildern, wenn das Bild geladen wird:
    • Bild proportional skalieren
Passt das Bild im Objekt an und bewahrt dabei das Seitenverhältnis.
    • Bild passend für Rechteck skalieren
Passt die Bildgröße an die Objektmaße an. Das Seitenverhältnis wird nicht beibehalten.
    • Originalgröße verwenden
Die Bildgröße wird nicht verändert. Die Objektgröße wird an die tatsächliche Bildgröße angepasst.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Verwandte Themen
Bilder – Übersicht


Zurück Weiter

LiveCycle Designer verwenden > Objekteigenschaften > Eigenschaften in der Palette „Objekt“ > Linien

Linien

Eigenschaften von Linien: Registerkarte „Zeichnen“


Eigenschaften von Linien: Registerkarte „Zeichnen“

Wenn Sie eine Linie zeichnen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Zeichnen“ verschiedene Optionen zum Formatieren von Linien zur Verfügung.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Erscheinungsbild
Legt die Neigung der Linie fest.
Linienstil
Legt den Stil und die Stärke der Linie fest.
Farbauswahl
Legt die Linienfarbe fest.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Verwandte Themen
Kreise, Linien und Rechtecke – Übersicht


Listenfelder

Eigenschaften von Listenfeldern: Registerkarte „Feld“
Eigenschaften von Listenfeldern: Registerkarte „Wert“
Eigenschaften von Listenfeldern: Registerkarte „Bindung“


Eigenschaften von Listenfeldern: Registerkarte „Feld“

Wenn Sie ein Listenfeld auswählen, steht Ihnen auf der Registerkarte „Feld“ eine Reihe von Optionen zum Formatieren von Listenfeldern zur Verfügung.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Beschriftung
Legt eine Beschriftung für das Objekt fest.
„Beschriftung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Beschriftung dynamisch aus.
Erscheinungsbild
Legt einen Stil für die Begrenzung des Füllbereiches fest:
    • Ohne
Das Feld wird ohne Begrenzung angezeigt.
    • Unterstrichen
Das Feld wird unterstrichen.
    • Ausgefülltes Rechteck
Das Feld wird in einem ausgefüllten Rechteck angezeigt.
    • Versenktes Rechteck
Erzeugt einen Schatten um das Feld, der das Feld dreidimensional wirken lässt.
    • Benutzerdefiniert
Zeigt das Dialogfeld „Angepasstes Erscheinungsbild“ an. Wählen Sie diese Option, wenn Sie ein eigenes Design für den Füllbereich entwerfen möchten.
Listenelemente
Legt die Listeneinträge und ihre Reihenfolge fest. Mit Hilfe der Schaltflächen können Sie die Listenelemente nach oben oder unten verschieben und in auf- oder absteigender Reihenfolge sortieren.
„Listenelemente“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Dropdown-Listen und Listenfelder – Übersicht


Eigenschaften von Listenfeldern: Registerkarte „Wert“

Wenn Sie ein Listenfeld erzeugen, steht Ihnen auf der Registerkarte „Wert“ eine Reihe von Optionen zur Verfügung, die Sie auf das Objekt anwenden können.
Typ
Ermöglicht Berechnungen und Eingabeaufforderungen zur Laufzeit:
    • Benutzereingabe - Optional
Der Benutzer kann selbst entscheiden, ob er Daten eingeben möchte.
    • Benutzereingabe - Empfohlen
Wenn der Benutzer keine Daten eingibt, wird eine eigene Meldung angezeigt (soweit sie im Feld „Meldung bei leerem Feld“ eingetragen worden ist).
    • Benutzereingabe - Erforderlich
Wenn der Benutzer keine Daten eingibt, wird eine eigene Meldung angezeigt (soweit sie im Feld „Meldung bei leerem Feld“ eingetragen worden ist).
    • Berechnet - Schreibgeschützt
Ein Datenwert wird über ein angehängtes Skript berechnet und angezeigt. Die Benutzer können den berechneten Wert nicht bearbeiten.
    • Berechnet - Benutzer darf überschreiben
Ein Datenwert wird über ein angehängtes Skript berechnet und angezeigt. Die Benutzer können den berechneten Wert bearbeiten, wenn im Berechnungsskript eine Verarbeitung der Benutzereingabe vorgesehen ist. Wenn ein Benutzer den berechneten Wert bearbeiten möchte, wird eine Meldung angezeigt, die im Feld „Meldung beim Überschreiben eines Werts“ festgelegt wurde.
    • Schreibgeschützt
Ein Datenwert wird zur Laufzeit zusammengeführt oder berechnet und angezeigt. Die Benutzer können den Wert nicht bearbeiten.
Standardwert
Legt eine Standardauswahl fest.
Diese Option steht nur dann zur Verfügung, wenn die Option „Typ“ auf „Benutzereingabe - Optional“, „Benutzereingabe - Empfohlen“, „Benutzereingabe - Erforderlich“ oder „Schreibgeschützt“ gesetzt ist.
Meldung bei leerem Feld
Legt eine Meldung fest, mit der die Benutzer zur Eingabe eines empfohlenen oder erforderlichen Wertes aufgefordert werden. Siehe So fordern Sie Benutzer zur Dateneingabe auf.
Diese Option ist nur dann verfügbar, wenn die Option „Typ“ auf „Benutzereingabe - Empfohlen“ oder „Benutzereingabe - Erforderlich“ gesetzt ist.
Überprüfungsmuster
Legt ein Überprüfungsmuster für die Benutzereingabe fest. Das Muster muss mit der Syntax der Benutzereingabe übereinstimmen. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist.
Überprüfungsmuster-Meldung und Fehler
Legt eine eigene Meldung fest, die angezeigt wird, wenn ein Rohwert nicht dem Überprüfungsmuster entspricht. Standardmäßig wird in einem solchen Fall zur Laufzeit ein Programmierfehler generiert. Wenn stattdessen eine Warnmeldung generiert werden soll, deaktivieren Sie die Option „Fehler“. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist. „Überprüfungsmuster-Meldung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus.
Überprüfungsskript-Meldung und Fehler
Legt eine Meldung fest, die angezeigt wird, wenn ein angehängtes Überprüfungsskript einen inakzeptablen Wert ermittelt. Standardmäßig wird in einem solchen Fall zur Laufzeit ein Programmierfehler generiert. Wenn stattdessen eine Warnmeldung generiert werden soll, deaktivieren Sie die Option „Fehler“. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist. „Überprüfungsskript-Meldung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus.
Meldung beim Überschreiben eines Werts
Legt eine eigene Meldung fest, die den Benutzer darauf hinweist, dass er dabei ist, den Wert eines berechneten Feldes zu ändern. Die Meldung erscheint, wenn ein Benutzer den berechneten Wert ändert.
Diese Option steht nur zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Benutzer darf überschreiben“ gesetzt ist.
Verwandte Themen
Dropdown-Listen und Listenfelder – Übersicht


Eigenschaften von Listenfeldern: Registerkarte „Bindung“

Wenn Sie ein Listenfeld erzeugen, stehen Ihnen auf der Registerkarte „Bindung“ Optionen zur Datenbindung zur Verfügung, die Sie auf das Listenfeld anwenden können. Die Optionen, die sich nicht direkt auf die Erstellung einer Datenverbindung beziehen, gelten für die an eine Datenquelle gebundenen und die in einer Datei gespeicherten Daten, wenn das Objekt an keine Datenquelle gebunden ist.
Name
Legt den Namen des Listenfeldes fest. Siehe So können Sie Objekte benennen und umbenennen.
Standardbindung
Legt die Standardmethode zum Binden von Daten fest:
    • Normal
Aktiviert die Optionen zum Zusammenführen und Speichern von Daten. Die Datenwerte werden den Adobe-Regeln zur Datenzusammenführung entsprechend zusammengeführt und gespeichert.
    • Global
Verbindet einen einzelnen Datenwert mit allen gleichnamigen Objekten (siehe So definieren Sie ein globales Feld).
    • Neue Datenverbindung
Startet den Assistenten „Neue Datenverbindung“. Weitere Informationen dazu, wie Sie eine Verbindung mit Hilfe des Assistenten definieren, finden Sie unter So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei oder So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank.
    • Ohne
Deaktiviert die Datenbindung. Da das Objekt keine zusammengeführten Daten erfasst oder anzeigt, bleiben alle Informationen, die zum Objekt gehören, beim Speichern oder Absenden der Formulardaten unberücksichtigt.
Elementwerte
Ermöglicht Ihnen das Festlegen benutzerdefinierter Datenwerte für jedes Listenelement. Wenn diese Option nicht ausgewählt ist, entsprechen die Datenwerte dem Text der Listenelemente. Wenn diese Option ausgewählt ist, sind die Standardwerte fortlaufende Ganzzahlen, wobei dem ersten Listenelement „0“ zugewiesen ist. Siehe So legen Sie Listenelementwerte für Dropdown-Listen oder Listenfelder fest.
„Elementwerte“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren.
Nach oben, Nach unten, Aufsteigend sortieren, Absteigend sortieren
Ändert die Reihenfolge der Elemente in der Liste (wenn die Daten beispielsweise in einer Reihenfolge gespeichert werden sollen, die von der Optionsanzeige in der Dropdown-Liste abweicht). Sie können Listenelemente mit Hilfe der entsprechenden Schaltflächen nach oben oder unten verschieben und in auf- oder absteigender Reihenfolge sortieren.
Import/Export-Bindungen
Legt eine Import/Export-Bindung für eine WSDL-Datenverbindung fest. Siehe So erstellen Sie eine Datenverbindung zu einer WSDL-Datei.
Verwandte Themen
Datenquellen


Numerische Felder

Eigenschaften von numerischen Feldern: Registerkarte „Feld“
Eigenschaften von numerischen Feldern: Registerkarte „Wert“
Eigenschaften von numerischen Feldern: Registerkarte „Bindung“
Numerische Muster
Beispiele für numerische Muster


Eigenschaften von numerischen Feldern: Registerkarte „Feld“

Wenn Sie ein numerisches Feld auswählen, zeigt die Registerkarte „Feld“ in der Palette „Objekt“ eine Reihe von Optionen zur Formatierung von Feldern an.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Beschriftung
Legt eine Beschriftung für das Objekt fest.
„Beschriftung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Beschriftung dynamisch aus.
Erscheinungsbild
Legt einen Stil für die Begrenzung des Füllbereiches fest:
    • Ohne
Das Feld wird ohne Begrenzung angezeigt.
    • Unterstrichen
Das Feld wird unterstrichen.
    • Ausgefülltes Rechteck
Das Feld wird in einem ausgefüllten Rechteck angezeigt.
    • Versenktes Rechteck
Erzeugt einen Schatten um das Feld, der das Feld dreidimensional wirken lässt.
    • Benutzerdefiniert
Zeigt das Dialogfeld „Angepasstes Erscheinungsbild“ an. Wählen Sie diese Option, wenn Sie ein eigenes Design für den Füllbereich entwerfen möchten.
Länge auf sichtbaren Bereich beschränken
Legt die maximal zulässige Anzahl von Zahlen im Feld entsprechend der horizontalen Länge des Textfeldes fest.
Zeichenanzahl in Textfeld _ Zeichen
Aktiviert Begrenzungslinien im Feld.
Anzeigemuster
Legt das Muster für die Anzeige von formatierten Werten im Formular fest. Siehe So legen Sie ein Anzeigemuster fest.
Zur Entwurfs- und Laufzeit werden formatierte Werte im Feld in einem Format angezeigt, das dem Gebietsschema entspricht.
Bearbeitungsmuster
Legt das Muster für die Syntax der Benutzereingabe fest. Entspricht die Benutzereingabe dem Bearbeitungsmuster nicht, werden die Daten nicht akzeptiert, und der Feldwert wird nicht formatiert. Siehe So legen Sie ein Bearbeitungsmuster fest.
Zur Entwurfs- und Laufzeit werden formatierte Werte im Feld in einem Format angezeigt, das dem Gebietsschema entspricht.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Numerische Felder – Übersicht
Dezimalfelder – Übersicht


Eigenschaften von numerischen Feldern: Registerkarte „Wert“

Wenn Sie ein numerisches Feld erzeugen, steht Ihnen auf der Registerkarte „Wert“ eine Reihe von Optionen zur Verfügung, die Sie auf das Objekt anwenden können.
Typ
Ermöglicht Berechnungen und Eingabeaufforderungen zur Laufzeit:
    • Benutzereingabe - Optional
Der Benutzer kann selbst entscheiden, ob er Daten eingeben möchte.
    • Benutzereingabe - Empfohlen
Wenn der Benutzer keine Daten eingibt, wird eine eigene Meldung angezeigt (soweit sie im Feld „Meldung bei leerem Feld“ eingetragen worden ist).
    • Benutzereingabe - Erforderlich
Wenn der Benutzer keine Daten eingibt, wird eine eigene Meldung angezeigt (soweit sie im Feld „Meldung bei leerem Feld“ eingetragen worden ist).
    • Berechnet - Schreibgeschützt
Ein Datenwert wird über ein angehängtes Skript berechnet und angezeigt. Die Benutzer können den berechneten Wert nicht bearbeiten.
    • Berechnet - Benutzer darf überschreiben
Ein Datenwert wird über ein angehängtes Skript berechnet und angezeigt. Die Benutzer können den berechneten Wert bearbeiten, wenn im Berechnungsskript eine Verarbeitung der Benutzereingabe vorgesehen ist. Wenn ein Benutzer den berechneten Wert bearbeiten möchte, wird eine Meldung angezeigt, die im Feld „Meldung beim Überschreiben eines Werts“ festgelegt wurde.
    • Schreibgeschützt
Ein Datenwert wird zur Laufzeit zusammengeführt oder berechnet und angezeigt. Die Benutzer können den Wert nicht bearbeiten.
Standardwert
Legt einen Ausgangswert für das Feld fest. Der Wert wird entsprechend der Einstellung der Option „Anzeigemuster“ auf der Registerkarte „Feld“ formatiert. Er muss allerdings dem Gebietsschema entsprechen, das für das Feld gilt. Wenn die Daten gebunden sind und ein Datenmuster festgelegt wurde, muss der Wert mit dem auf der Registerkarte „Bindung“ festgelegten Datenmuster übereinstimmen. Siehe So legen Sie einen Standardwert fest.
Diese Option steht nur dann zur Verfügung, wenn die Option „Typ“ auf „Benutzereingabe - Optional“, „Benutzereingabe - Empfohlen“, „Benutzereingabe - Erforderlich“ oder „Schreibgeschützt“ gesetzt ist.
Meldung bei leerem Feld
Legt eine Meldung fest, mit der die Benutzer zur Eingabe eines empfohlenen oder erforderlichen Wertes aufgefordert werden. Siehe So fordern Sie Benutzer zur Dateneingabe auf.
Diese Option ist nur dann verfügbar, wenn die Option „Typ“ auf „Benutzereingabe - Empfohlen“ oder „Benutzereingabe - Erforderlich“ gesetzt ist.
Überprüfungsmuster
Legt ein Überprüfungsmuster für die Benutzereingabe fest. Das Muster muss mit der Syntax der Benutzereingabe übereinstimmen. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist.
Überprüfungsmuster-Meldung und Fehler
Legt eine eigene Meldung fest, die angezeigt wird, wenn ein Rohwert nicht dem Überprüfungsmuster entspricht. Standardmäßig wird in einem solchen Fall zur Laufzeit ein Programmierfehler generiert. Wenn stattdessen eine Warnmeldung generiert werden soll, deaktivieren Sie die Option „Fehler“. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist. „Überprüfungsmuster-Meldung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus.
Überprüfungsskript-Meldung und Fehler
Legt eine Meldung fest, die angezeigt wird, wenn ein angehängtes Überprüfungsskript einen inakzeptablen Wert ermittelt. Standardmäßig wird in einem solchen Fall zur Laufzeit ein Programmierfehler generiert. Wenn stattdessen eine Warnmeldung generiert werden soll, deaktivieren Sie die Option „Fehler“. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist. „Überprüfungsskript-Meldung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus.
Berechnungsskript
Der Wert wird durch ein Skript berechnet, das für das calculate-Ereignis des Objekts geschrieben wurde.
Diese Option steht nur zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ gesetzt ist.
Laufzeiteigenschaften
Legt eine der folgenden Laufzeiteigenschaften für das Objekt fest. Wenn Sie eine Laufzeiteigenschaft auswählen, wird der eigentliche Wert, der der Option entspricht, bei der Wiedergabe des Formulars dynamisch eingefügt.
    • Aktuelle Seitenzahl
Zeigt die Nummer der aktuellen Seite im numerischen Feld an.
    • Anzahl der Seiten
Fügt die Gesamtanzahl der Seiten des fertigen Formulars ein.
    • Aktuelle Blattnummer
Fügt die Nummer des aktuellen Blattes in das numerische Feld ein.
    • Blattanzahl
Fügt die Gesamtanzahl der Blätter ein, aus denen das Formular besteht.
Diese Option steht nur zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ gesetzt ist.
Meldung beim Überschreiben eines Werts
Legt eine eigene Meldung fest, die den Benutzer darauf hinweist, dass er dabei ist, den Wert eines berechneten Feldes zu ändern. Die Meldung erscheint, wenn ein Benutzer den berechneten Wert ändert.
Diese Option steht nur zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Benutzer darf überschreiben“ gesetzt ist.
Verwandte Themen
Numerische Felder – Übersicht
Dezimalfelder – Übersicht


Eigenschaften von numerischen Feldern: Registerkarte „Bindung“

Wenn Sie ein numerisches Feld erzeugen, stehen Ihnen auf der Registerkarte „Bindung“ verschiedene Optionen zur Datenbindung zur Verfügung, die Sie auf das Objekt anwenden können. Die Optionen, die sich nicht direkt auf die Erstellung einer Datenverbindung beziehen, gelten für die an eine Datenquelle gebundenen und die in einer Datei gespeicherten Daten, wenn das Objekt an keine Datenquelle gebunden ist.
Name
Legt den Namen des numerischen Feldes fest. Siehe So können Sie Objekte benennen und umbenennen.
Standardbindung
Legt die Standardmethode zum Binden von Daten fest:
    • Normal
Aktiviert die Optionen zum Zusammenführen und Speichern von Daten. Die Datenwerte werden den Adobe-Regeln zur Datenzusammenführung entsprechend zusammengeführt und gespeichert.
    • Global
Verbindet einen einzelnen Datenwert mit allen gleichnamigen Objekten (siehe So definieren Sie ein globales Feld).
    • Neue Datenverbindung
Startet den Assistenten „Neue Datenverbindung“. Weitere Informationen dazu, wie Sie eine Verbindung mit Hilfe des Assistenten definieren, finden Sie unter So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei oder So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank.
    • Ohne
Deaktiviert die Datenbindung. Da das Objekt keine zusammengeführten Daten erfasst oder anzeigt, bleiben alle Informationen, die zum Objekt gehören, beim Speichern oder Absenden der Formulardaten unberücksichtigt.
Datenmuster
Legt ein Muster für das Speichern und Abrufen gebundener Daten oder für das Speichern von Daten fest, wenn das Formular nicht an eine Datenquelle gebunden ist. Siehe So legen Sie ein Datenmuster fest.
Datenformat
Legt das Format der Daten fest. Siehe So legen Sie ein Datenmuster fest:
    • Fließkomma
Eine aus drei Teilen bestehende Darstellung einer Zahl, die ein Dezimalzeichen enthält. Die Darstellung der Zahl setzt sich aus einem Zeichen, einer Zahl und einem Dezimalzeichen zusammen. In einigen Gebietsschemata ist das Dezimalzeichen ein Punkt (also 4.23423412, 1234.1234234 und 4.00). und in anderen ist es ein Komma. Beispielsweise wird im Gebietsschema „Deutsch (Deutschland)“ ein Dezimalkomma verwendet (also 1234,1234).
    • Ganzzahl
Eine beliebige Sequenz aus den Ziffern 0 bis 9, möglicherweise mit einem vorangestellten Minuszeichen. Beispielsweise kann die Zahl eine Null oder eine positive (z. B. 1, 2, 3) bzw. negative Ganzzahl (z. B. -1, -2, -3) sein.
Import/Export-Bindungen
Legt eine Import/Export-Bindung für eine WSDL-Datenverbindung fest. Siehe So erstellen Sie eine Datenverbindung zu einer WSDL-Datei.
Verwandte Themen
Datenquellen


Numerische Muster

Es müssen spezifische Symbole verwendet werden, um numerische Muster für numerische Felder zu erzeugen. Sie können diese Symbole auch verwenden, um numerische Muster für Dezimalfelder zu erzeugen.
Bindestrich (-), Doppelpunkt (:), Schrägstrich (/) und Leerzeichen ( ) werden als Literalwerte behandelt und können an jeder beliebigen Stelle im Muster eingefügt werden. Wenn eine Wortfolge in ein Muster aufgenommen werden soll, schließen Sie sie in einfache Anführungszeichen (') ein. Beispielsweise kann 'Your balance is' z,zz9.99 als Anzeigemuster angegeben werden.
Verwenden Sie die folgenden Mustersymbole zum Erstellen von Mustern. Durch das Muster wird festgelegt, in welchem Format Benutzer Daten eingeben oder formatieren können. Die formatierten Ergebnisse sind in der Spalte „Beispiel“ durch doppelte Anführungszeichen begrenzt, so dass Sie genau ablesen können, an welcher Stelle im Ergebnis Leerzeichen erscheinen. Die Anführungszeichen gehören nicht zum Ergebnis. Allen Beispielen liegt das englische Gebietsschema (USA) zugrunde.

Numerisches Symbol

Beschreibung

Beispiel

8
Single digit or the zero digit if the input is a zero digit or empty. When following the decimal radix, indicates the same number of digits as contained in the data value, up to the maximum number of digits indicated by the pattern.
The 8 symbol is used in decimal fields.
Display Pattern: zzz,zz9.888
Input Value: 123456.1236 or 1234
Formatted Value: “123,456.124” or “1,234”

9
Eine einstellige Zahl oder die Zahl Null, wenn die Eingabe leer ist. Zeigt nach der Dezimalwurzel die exakte Zahl der Stellen an, die im Datenwert enthalten ist.
Anzeigemuster: zzz,zz9.999
Eingabewert: 123456,1236 oder 1234
Formatierter Wert: „123,456.124“ oder „1,234.000“

z
Eine einstellige Zahl oder keine Ausgabe, wenn die Eingabe eine führende Null ist; keine Ausgabe, wenn die Eingabe leer ist.
Anzeigemuster: $zzz9
Eingabewert: 123
Formatierter Wert: „$123“

Z
Eine einstellige Zahl oder ein Leerzeichen, wenn die Eingabe eine führende Null ist; ein Leerzeichen, wenn die Eingabe leer ist
Anzeigemuster: $ZZZ9
Eingabewert: 123
Formatierter Wert: „$ 123“

s
Ein Minuszeichen (-) bei einer negativen Zahl (bei einer positiven Zahl ist kein Symbol erforderlich)
Anzeigemuster: $szzz9
Eingabewert: 123 oder -123
Formatierter Wert: „$123“ oder „$-123“

S
Ein Minuszeichen (-) bei einer negativen Zahl, ein Leerzeichen bei einer positiven Zahl
Anzeigemuster: $Szzz9
Eingabewert: 123 oder -123
Formatierter Wert: „$ 123“ oder „$-123“

E
Exponentialsymbol (E+3 bedeutet, dass der Exponent den Wert 3 hat; bei E-2 ist der Exponentenwert -2).
Das Exponentialsymbol (E) kann nur nach einer 9, einem z oder Z verwendet werden.
Anzeigemuster: 99.999E
Eingabewert: 12345 oder 0,12345
Formatierter Wert: „12.345E+3“ oder „12.345E-2“

$
Währungssymbol, das der aktuellen Spracheinstellung für das Objekt entspricht
Anzeigemuster: $zzz9
Eingabewert: 123
Formatierter Wert: „$123“
cr
Kreditsymbol (Credit, CR) bei einer negativen Zahl (bei einer positiven Zahl ist kein Symbol erforderlich)
Anzeigemuster: cr$zzz9
Eingabewert: 123 oder -123
Formatierter Wert: „$123“ oder „CR$123“

CR
Kreditsymbol (Credit, CR) bei einer negativen Zahl, mehrere Leerzeichen bei einer positiven Zahl
Anzeigemuster: CR$zzz9
Eingabewert: 123 oder -123
Formatierter Wert: „$123“ oder „CR$123“

db
Debitsymbol (DB) bei einer negativen Zahl (bei einer positiven Zahl ist kein Symbol erforderlich)
Anzeigemuster: db$zzz9
Eingabewert: 123 oder -123
Formatierter Wert: „$123“ oder „DB$123“

DB
Debitsymbol (DB) bei einer negativen Zahl, mehrere Leerzeichen bei einer positiven Zahl
Anzeigemuster: DB$zzz9
Eingabewert: 123 oder -123
Formatierter Wert: „$123“ oder „DB$123“

( )
Linkes und rechtes Klammernsymbol zur Kennzeichnung einer negativen Zahl. Ist die Zahl eine positive Zahl, werden die Klammernsymbole zu Leerzeichen.
Das linke und rechte Klammernsymbol können nur eine 8, 9, ein z oder ein Z einschließen.
Anzeigemuster: ($zzz9)
Eingabewert: 123 oder -123
Formatierter Wert: „ $123 „ oder „($123)“

.
Dezimalwurzel, die der aktuellen Spracheinstellung für das Objekt entspricht
Anzeigemuster: zzz9.99
Eingabewert: 123.45
Formatierter Wert für das Gebietsschema „Deutsch (Deutschland)“: „123,45“ „123,45“

v
Implizierte Dezimalwurzel, die der aktuellen Spracheinstellung für das Objekt entspricht (die Dezimalwurzel wird gezogen, bevor das Ergebnis geschrieben wird)
Anzeigemuster: zzz9v99
Eingabewert: 123.45
Formatierter Wert: „12345“

,
Gruppierungssymbol, das der aktuellen Spracheinstellung für das Objekt entspricht
Anzeigemuster: z,zz9.99
Eingabewert: 1234.56
Formatierter Wert für das Gebietsschema „Deutsch (Deutschland)“: „123,45“ „1.234,56“

%
Prozentsymbol, das der aktuellen Spracheinstellung für das Objekt entspricht
Anzeigemuster: z9.99%
Eingabewert: 0.123
Formatierter Wert: „12.30%“
Reservierte Symbole
Die folgenden Symbole haben spezielle Bedeutungen und können nicht als Literalzeichen im Text verwendet werden.
?
Das Symbol entspricht einem beliebigen Zeichen. Wenn es für die Anzeige zusammengeführt wird, wandelt es sich zu einem Leerzeichen.

*
Das Symbol steht beim Absenden für 0 oder für UNICODE-Leerzeichen. Wenn es für die Anzeige zusammengeführt wird, wandelt es sich zu einem Leerzeichen.

+
Das Symbol steht beim Absenden für ein oder mehrere UNICODE-Leerzeichen. Wenn es für die Anzeige zusammengeführt wird, wandelt es sich zu einem Leerzeichen.
Verwandte Themen
Info über Feldmuster und Wertformatierung
So legen Sie ein Datenmuster fest
So legen Sie ein Bearbeitungsmuster fest
Beispiele für numerische Muster


Beispiele für numerische Muster

Die folgende Tabelle zeigt einige Beispiele für Anzeigemuster und die Ergebnisse der Formatierung einiger Beispieleingabewerte (vom Benutzer eingegeben oder verbunden) mit Hilfe des Anzeigemusters. Die formatierten Ergebnisse sind durch doppelte Anführungszeichen begrenzt, so dass Sie genau ablesen können, an welcher Stelle im Ergebnis Leerzeichen erscheinen. Die Anführungszeichen gehören nicht zum Ergebnis. Allen Beispielen liegt das englische Gebietsschema (USA) zugrunde.
.

Muster

Eingabewert

Formatierter Wert
zzz,zz9.888
The 8 symbol is used in decimal fields.
123456.1236
12345.6
1234
“123,456.124”
“12,345.6”
“1234”
zzz,zz9.99
123456.1236
123456.4
123456
„123,456.12“
„123,456.40“
„123,456.00“
$Z,ZZ9.99
123.4
„ 123.40“
$z,zz9.99CR
1234
-1234
„$1,234.00“
„$1,234.00CR“
$z,zz9.99DB
123
-123
„$ 123.00“
„$ 123.00DB“
($z,zz9.99)
1234
-1234
„ $1,234.56 „
„($1,234.00)“
zzz9
12.0
„12“
Szzz,zz9.99
1234.56
-1234.56
„1,234.56“
„-1,234.56“
$9,999.99
123.4
„$0,123.40“
$Z,999.99
123.4
„$ 123.40“
99999
1234
„01234“
S999v99
-1.23
„-00123“
S999V99
-1.23
123
„-001.23“
„ 123.00“
SZZ9.99
12.3
-12.3
„ 12.30“
„- 12.30“
szz9.99
12.3
-12.3
„12.3“
„-12.3“
99.999E
12345
0.12345
„12.345E+3“
„12.345E-2“
Die nachstehende Tabelle zeigt das Ergebnis einer Konvertierung von Beispielwerten (Benutzereingaben oder gebundene Werte) in Rohwerte durch ein Bearbeitungs- oder Datenmuster.

Eigenes Muster

Eingabewert

Rohwert
99V99
1050
3125
10.50
31.25
99.999E
12.345E3
12.345E-2
12345
0.12345
z999
150
0150
150
150
z,zz9.99
10.50
3,125.00
10.50
3125.00
$z,zz9.99DB
$1,234.00
$1,234.00DB
1234.00
-1234.00


Papierformular-Barcodes

Eigenschaften von Papierformular-Barcodes: Registerkarte „Feld“
Eigenschaften von Papierformular-Barcodes: Registerkarte „Wert“


Eigenschaften von Papierformular-Barcodes: Registerkarte „Feld“

Wenn Sie beim Formularentwurf ein Papierformular-Barcodeobjekt auswählen, enthält die Registerkarte „Feld“ in der Palette „Objekt“ Optionen zur Formatierung von Papierformular-Barcodes.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Bezeichnung
Eine benutzerdefinierte oder automatisch erzeugte Beschreibung, die unter dem Barcode angezeigt wird. Sinnvoll zur Unterscheidung von Barcodes in verschiedenen Versionen von Formularen mit Barcodes.
Beschriftung automatisch erstellen
Bei Aktivierung dieser Option wird die Barcode-Beschriftung automatisch erstellt. Deaktivieren Sie die Option, um eine benutzerdefinierte Beschriftung festzulegen.
Symbole
Legt die Symbole für den Barcode fest:
      •
      PDF417
      •
      QR-Code
      •
      Datenmatrix
Endbenutzer benötigen für das Ausfüllen von Formularen mit einem QR Code- oder Datenmatrix-Barcode entweder Acrobat 7.0.5 oder höher bzw. Adobe Reader 7.0.5 oder höher. Die Dekodierung von QR Code- und Datenmatrix-Barcodes wird von Adobe LiveCycle Barcoded Forms 7.0 unterstützt. Adobe LiveCycle Barcoded Forms 7.0 Standalone (ST) bietet für diese Barcodes jedoch keine Unterstützung.
Scanmethode
Dadurch werden die Bedingungen festgelegt, die für die Dekodierung der im Papierformular-Barcode enthaltenen Informationen gelten, nachdem der Barcode auf ein Formular gedruckt wurde. Mit der Dekodierbedingung wird die horizontale und vertikale Größe der Datenzelle sowie das Fehlerkorrektur-Level des Barcodes bestimmt. In LiveCycle Designer stehen die folgenden voreingestellten und benutzerdefinierbaren Optionen zur Verfügung:
    • Dokument-Scanner (Standard)
Wenn Sie diese Option auswählen, werden die für die Einstellungen „Fehlerkorrektur-Level“, „Modulhöhe/-breite“ und „Modulbreite“ geeigneten Werte für das Scannen von Papierformular-Barcodes mit einem 300 dpi-Scanner ausgewählt.
In LiveCycle Designer werden die folgenden Werte festgelegt:
      •
      Fehlerkorrektur-Level: 5
      •
      Modulhöhe/-breite: 2 (PDF417), 1 (QR Code und Datenmatrix)
      •
      Modulbreite: 0.0133 in
    • Handscanner
Wenn Sie diese Option auswählen, werden die für die Einstellungen „Fehlerkorrektur-Level“, „Modulhöhe/-breite“ und „Modulbreite“ geeigneten Werte für das Scannen von Papierformular-Barcodes mit einem Handscanner ausgewählt.
In LiveCycle Designer werden die folgenden Werte festgelegt:
      •
      Fehlerkorrektur-Level: 5
      •
      Modulhöhe/-breite: 3 (PDF417), 1 (QR Code und Datenmatrix)
      •
      Modulbreite: 0.0133 in
    • Faxserver
Wenn Sie diese Option auswählen, werden die für die Einstellungen „Fehlerkorrektur-Level“, „Modulhöhe/-breite“ und „Modulbreite“ geeigneten Werte für das Scannen von Papierformular-Barcodes ausgewählt, die auf mit einem Faxgerät empfangenen Formularen gedruckt wurden.
In LiveCycle Designer werden die folgenden Werte festgelegt:
      •
      Fehlerkorrektur-Level: 6
      •
      Modulhöhe/-breite: 2 (PDF417), 1 (QR Code und Datenmatrix)
      •
      Modulbreite: 0.0133 in
    • Benutzerdefiniert
Wenn Sie diese Option auswählen, wird die Liste zur Auswahl der Eigenschaftswerte aktiviert, und Sie können für die Einstellungen „Fehlerkorrektur-Level“, „Modulhöhe/-breite“ und „Modulbreite“ Werte aus den folgenden Bereichen auswählen:
      •
      Fehlerkorrektur-Level: 1 - 8
      •
      Modulhöhe/-breite: 1-4 (Ganzzahlen für PDF417), 1 (QR Code und Datenmatrix)
      •
      Modulbreite: 0.0133 – 0.04 in
Wenn die Option „Benutzerdefiniert“ ausgewählt ist, bleibt die Eigenschaftenliste unabhängig von den für die Einstellungen „Fehlerkorrektur-Level“, „Modulhöhe/-breite“ und „Modulbreite“ ausgewählten Eigenschaftswerten aktiviert, und zwar selbst dann, wenn diese den Werten für eine voreingestellte Bedingung entsprechen.
Die Einstellung „Fehlerkorrektur-Level“ ist für Datenmatrix-Barcodes deaktiviert.
Eigenschaft/Wert
Wenn die Option „Benutzerdefiniert“ ausgewählt ist, müssen Sie die Eigenschaftswerte für das Fehlerkorrektur-Level, das Verhältnis von Modulhöhe und -breite sowie die Modulbreite festlegen:
    • Fehlerkorrektur-Level
Legt die Datenredundanzebene fest, die dem Barcode hinzugefügt wird, um mögliche Scanfehler auszugleichen. Als Wert können Ebenen zwischen 1 und 8 ausgewählt werden. Wenn Sie eine höhere Ebene auswählen, werden die Redundanz sowie die Qualität des Barcodes verbessert. Durch die Auswahl einer höheren Ebene erhöht sich jedoch auch die Größe des Barcodes. Einem stabileren Barcode können Fehler wie Kugelschreibermarkierungen oder Knicke im Dokument weniger anhaben, da redundante Informationen in den Barcode eingeschlossen werden. LiveCycle Designer legt anhand des von Ihnen gewählten Scanners automatisch ein Fehlerkorrektur-Level fest.
Bei einem Fehlerkorrektur-Level von 5 erhalten Sie in der Regel eine gute Leistung bei einer kompakten Größe des Barcodes. Wenn Sie über keine speziellen Kenntnisse der Barcode-Dekodierung verfügen, sollten Sie immer einen Fehlerkorrektur-Level von mindestens 5 auswählen.
Die Einstellung „Fehlerkorrektur-Level“ ist für Datenmatrix-Barcodes deaktiviert.
    • Modulhöhe/-breite
Legt die Höhe des Barcodes durch das Verhältnis von Modulhöhe und -breite fest. Akzeptable Ebenen für „Wert“ sind Ganzzahlen von 1 bis 4 (PDF417), 1 (QR Code und Datenmatrix).
    • Modulbreite
Legt die Breite des kleinsten Strichs des Barcodes fest. Die Größen aller anderen Striche des Barcodes sind Vielfache dieser Abmessung. Als Wert können Ebenen zwischen 0.0133 und 0.04 Zoll ausgewählt werden.
Der Wert für die Modulbreite wird mit einer Genauigkeit von 1/300stel gerundet, wenn der Barcode in Acrobat oder Adobe Reader wiedergegeben wird. Wählen Sie nur dann eine benutzerdefinierte Modulbreite, wenn Sie über spezielle Kenntnisse der Barcode-Dekodierung verfügen.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Verwandte Themen
Papierformular-Barcodes – Übersicht


Eigenschaften von Papierformular-Barcodes: Registerkarte „Wert“

Wenn Sie beim Formularentwurf ein Papierformular-Barcodeobjekt auswählen, enthält die Registerkarte „Wert“ in der Palette „Objekt“ Optionen zur Formatierung von Papierformular-Barcodes.
Daten vor der Kodierung komprimieren
Dadurch wird angezeigt, ob Daten vor der Kodierung durch das Papierformular-Barcodeobjekt komprimiert werden. Als Standardeinstellung ist festgelegt, dass Daten nicht komprimiert werden.
Für die Komprimierung der Daten wird das Flate-Verfahren verwendet. Wenn diese Option ausgewählt ist, wird die Komprimierung bei der Zeichnung des Barcodes in Acrobat oder Adobe Reader durchgeführt.
Komprimierte Daten benötigen weniger Speicher im Barcode, so dass mehr Formulardaten gespeichert werden können.
Normalerweise ist eine Datenkomprimierung vorzuziehen, es sei denn, für die Dekodierung der Daten werden ein Handscanner oder eigene Dekodierungslösungen verwendet, die keine Dekomprimierungssoftware enthalten. Weitere Informationen zur Datenkomprimierung finden Sie in der Acrobat-Hilfe.
Automatische Skripte
Legt fest, ob die Barcode-Daten automatisch oder über ein benutzerdefiniertes Skript abgerufen werden.
Format
Legt das Format der Barcode-Daten fest, die automatisch über ein Skript abgerufen werden. Wenn eine Option ausgewählt ist, wird das mit der Option verknüpfte Skript im Skript-Editor angezeigt. Vordefinierte Skripten können gegebenenfalls auch bearbeitet werden. Wählen Sie eines der folgenden Formate aus:
    • XML
Der Barcodewert beruht auf einem Skript, das die Daten aus allen Formularfeldern im XML-Format kodiert.
    • Tabulatorgetrennt
Der Barcodewert beruht auf einem Skript, das die Daten aus allen Formularfeldern in einem tabulatorgetrennten Format kodiert (eine flache ASCII-Darstellung von durch Tabulatorzeichen getrennten Feldwerten). Die folgenden Optionen stehen zur Auswahl:
Feldnamen einschließen
Trennt die Feldnamen durch Tabstopps und kodiert sie als erste Linie des Barcode-Inhalts. Die Werte werden darunter kodiert.
Beschriftung einschließen
Kodiert die Beschriftung (wie auf der Registerkarte „Feld“ angezeigt) als erstes tabulatorgetrenntes Feld im Barcode-Inhalt.
Anwenden auf
Legt fest, auf welche Elemente das ausgewählte Format angewendet wird. Wählen Sie eine Option in der Liste aus:
    • Gesamte Formulardaten
Kodiert die Daten aus allen Formularfeldern im ausgewählten Format.
    • Teilformulardaten
Kodiert alle Daten aller Felder im Teilformular, in dem das Papierformular-Barcodeobjekt ein untergeordnetes Objekt darstellt, im ausgewählten Format.
    • Sammlungsdaten
Kodiert die Daten aus allen Formularfeldern im ausgewählten Format.
Sammlung
Legt die Sammlung zur Kodierung der Daten fest. Wählen Sie eine Option in der Liste aus:
    • Sammlungsname
Der Name der von Ihnen erstellten Sammlung.
    • Sammlung - Neu/verwalten
Sammlungen in der Sammlungsliste können erstellt, gelöscht, dupliziert oder umbenannt werden.
Ändern
Zeigt die ausgewählten Felder für die aktuelle Sammlung an. Sie können die Felder in der Sammlung in diesem Fenster auch bearbeiten und die Sammlung umbenennen.
Verwandte Themen
Papierformular-Barcodes – Übersicht
So steuern Sie die Datenkodierung in einem Papierformular-Barcode
Entwurftipps für die Verwendung von Papierformular-Barcodes


Kennwortfelder

Eigenschaften von Kennwortfeldern: Registerkarte „Feld“
Eigenschaften von Kennwortfeldern: Registerkarte „Wert“
Eigenschaften von Kennwortfeldern: Registerkarte „Bindung“
Kennwortmuster
Beispiele für Kennwortmuster


Eigenschaften von Kennwortfeldern: Registerkarte „Feld“

Wenn Sie ein Kennwortfeld auswählen, zeigt die Registerkarte „Feld“ in der Palette „Objekt“ eine Reihe von Optionen zur Formatierung von Kennwortfeldern an.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Beschriftung
Legt eine Beschriftung für das Objekt fest.
„Beschriftung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Beschriftung dynamisch aus.
Erscheinungsbild
Legt einen Stil für die Begrenzung des Füllbereiches fest:
    • Ohne
Das Feld wird ohne Begrenzung angezeigt.
    • Unterstrichen
Das Feld wird unterstrichen.
    • Ausgefülltes Rechteck
Das Feld wird in einem ausgefüllten Rechteck angezeigt.
    • Versenktes Rechteck
Erzeugt einen Schatten um das Feld, der das Feld dreidimensional wirken lässt.
    • Benutzerdefiniert
Zeigt das Dialogfeld „Angepasstes Erscheinungsbild“ an. Wählen Sie diese Option, wenn Sie ein eigenes Design für den Füllbereich entwerfen möchten.
Zeichen für Kennwortanzeige
Legt das Zeichen für die Anzeige fest.
Länge auf sichtbaren Bereich beschränken
Legt die maximal zulässige Anzahl von Zeichen im Feld entsprechend der horizontalen Länge des Kennwortfeldes fest.
Bearbeitungsmuster
Wenn die Benutzereingabe nicht dem LiveCycle Designer-Standard entsprechen wird, bestimmen Sie damit die Syntax der Benutzereingabe. Siehe So legen Sie ein Bearbeitungsmuster fest.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Kennwortfelder – Übersicht


Eigenschaften von Kennwortfeldern: Registerkarte „Wert“

Wenn Sie ein Kennwortfeld erzeugen, steht Ihnen auf der Registerkarte „Wert“ eine Reihe von Optionen zur Verfügung, die Sie auf das Objekt anwenden können.
Typ
Legt die Anforderungen für die Benutzereingabe fest.
    • Benutzereingabe - Optional
Der Benutzer kann selbst entscheiden, ob er ein Kennwort eingeben möchte.
    • Benutzereingabe - Empfohlen
Gibt der Benutzer kein Kennwort ein, wird eine benutzerdefinierte Meldung angezeigt (sofern eine solche im Feld „Meldung bei leerem Feld“ eingetragen wurde).
    • Benutzereingabe - Erforderlich
Gibt der Benutzer kein Kennwort ein, wird eine benutzerdefinierte Meldung angezeigt (sofern eine solche im Feld „Meldung bei leerem Feld“ eingetragen wurde).
Meldung bei leerem Feld
Legt eine Meldung fest, mit der die Benutzer zur Eingabe eines empfohlenen oder erforderlichen Wertes aufgefordert werden. Siehe So fordern Sie Benutzer zur Dateneingabe auf.
Diese Option ist nur dann verfügbar, wenn die Option „Typ“ auf „Benutzereingabe - Empfohlen“ oder „Benutzereingabe - Erforderlich“ gesetzt ist.
Überprüfungsmuster
Legt ein Überprüfungsmuster für die Benutzereingabe fest. Das Muster muss mit der Syntax der Benutzereingabe übereinstimmen. Siehe So überprüfen Sie Benutzereingaben.
Überprüfungsmuster-Meldung und Fehler
Legt eine eigene Meldung fest, die angezeigt wird, wenn ein Rohwert nicht dem Überprüfungsmuster entspricht. Standardmäßig wird in einem solchen Fall zur Laufzeit ein Programmierfehler generiert. Wenn stattdessen eine Warnmeldung generiert werden soll, deaktivieren Sie die Option „Fehler“. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist. „Überprüfungsmuster-Meldung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus.
Überprüfungsskript-Meldung und Fehler
Legt eine Meldung fest, die angezeigt wird, wenn ein angehängtes Überprüfungsskript einen inakzeptablen Wert ermittelt. Standardmäßig wird in einem solchen Fall zur Laufzeit ein Programmierfehler generiert. Wenn stattdessen eine Warnmeldung generiert werden soll, deaktivieren Sie die Option „Fehler“. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist. „Überprüfungsskript-Meldung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus.
Verwandte Themen
Kennwortfelder – Übersicht


Eigenschaften von Kennwortfeldern: Registerkarte „Bindung“

Wenn Sie ein Kennwortfeld erzeugen, stehen Ihnen auf der Registerkarte „Bindung“ verschiedene Optionen zur Datenbindung zur Verfügung, die Sie auf das Objekt anwenden können. Die Optionen, die sich nicht direkt auf die Erstellung einer Datenverbindung beziehen, gelten für die an eine Datenquelle gebundenen und die in einer Datei gespeicherten Daten, wenn das Objekt an keine Datenquelle gebunden ist.
Name
Legt den Namen des Feldes fest. Siehe So können Sie Objekte benennen und umbenennen.
Standardbindung
Legt die Standardmethode zum Binden von Daten fest:
    • Normal
Aktiviert die Optionen zum Zusammenführen und Speichern von Daten. Die Datenwerte werden den Adobe-Regeln zur Datenzusammenführung entsprechend zusammengeführt und gespeichert.
    • Global
Verbindet einen einzelnen Datenwert mit allen gleichnamigen Objekten (siehe So definieren Sie ein globales Feld).
    • Neue Datenverbindung
Startet den Assistenten „Neue Datenverbindung“. Weitere Informationen dazu, wie Sie eine Verbindung mit Hilfe des Assistenten definieren, finden Sie unter So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei oder So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank.
    • Ohne
Deaktiviert die Datenbindung. Da das Objekt keine zusammengeführten Daten erfasst oder anzeigt, bleiben alle Informationen, die zum Objekt gehören, beim Speichern oder Absenden der Formulardaten unberücksichtigt.
Datenmuster
Legt ein Muster für das Speichern und Abrufen gebundener Daten oder für das Speichern von Daten fest, wenn das Formular nicht an eine Datenquelle gebunden ist. Siehe So legen Sie ein Datenmuster fest.
Import/Export-Bindungen
Legt eine Import/Export-Bindung für eine WSDL-Datenverbindung fest. Siehe So erstellen Sie eine Datenverbindung zu einer WSDL-Datei.
Verwandte Themen
Datenquellen


Kennwortmuster

Bei Bedarf können Sie Kennwortmuster für Felder festlegen. Beachten Sie jedoch, dass Kennwörter durch die Definition eines speziellen Musters eine geringere Sicherheitsstufe aufweisen, da sich dabei die möglichen Zeichenkombinationen, die für das Kennwort verwendet werden können, reduzieren. Verwenden Sie beim Definieren eines Musters die folgenden Zeichen.
Komma (,), Bindestrich (-), Doppelpunkt (:), Schrägstrich (/), Punkt (.) und Leerzeichen ( ) werden als Literalwerte behandelt und können an einer beliebigen Stelle in einem Muster vorkommen.

Kennwortsymbole

Beschreibung

A
Einzelner Buchstabe

X
Einzelnes Zeichen

O
Einzelnes alphanumerisches Zeichen

0
Einzelnes alphanumerisches Zeichen

9
Einzelne Ziffer
Die Symbole O (Großbuchstabe o) und 0 (Null) werden absichtlich als Synonyme verwendet, da es andernfalls beim Lesen und Schreiben dieser beiden Zeichen sehr häufig zu Verwechslungen und Missverständnissen kommt.
Reservierte Symbole
Die folgenden Symbole haben eine besondere Bedeutung und können daher nicht in einem Kennwort verwendet werden.
?
Das Symbol entspricht einem beliebigen Zeichen. Wenn es für die Anzeige zusammengeführt wird, wandelt es sich zu einem Leerzeichen.

*
Das Symbol steht beim Absenden für 0 oder für UNICODE-Leerzeichen. Wenn es für die Anzeige zusammengeführt wird, wandelt es sich zu einem Leerzeichen.

+
Das Symbol steht beim Absenden für ein oder mehrere UNICODE-Leerzeichen. Wenn es für die Anzeige zusammengeführt wird, wandelt es sich zu einem Leerzeichen.
Verwandte Themen
Info über Feldmuster und Wertformatierung
Beispiele für Kennwortmuster


Beispiele für Kennwortmuster

Die nachfolgende Tabelle enthält einige Beispiele für Bearbeitungsmuster, die Sie selbst definieren können, um von Benutzern eingegebene Kennwörter zu verarbeiten.

Eigenes Muster

Eingabewert
AAA999
MAB123
XXX-9
MA2-4
99999
12345
9009AA9
1M23BE4
1m23be4
1MA3BE4


Optionsfelder

Eigenschaften von Optionsfeldern: Registerkarte „Feld“
Eigenschaften von Optionsfeldern: Registerkarte „Wert“
Eigenschaften von Optionsfeldern: Registerkarte „Bindung“


Eigenschaften von Optionsfeldern: Registerkarte „Feld“

Wenn Sie ein Optionsfeld oder eine Ausschlussgruppe auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Feld“ verschiedene Optionen zum Formatieren von Optionsfeldern zur Verfügung.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Erscheinungsbild
Legt einen Begrenzungsstil für das Optionsfeld fest.
Bei Auswahl nur eines Optionsfeldes stehen folgende Optionen zur Verfügung:
    • Ohne
Das Feld wird ohne Begrenzung angezeigt.
    • Ausgefülltes Quadrat
Verwendet ein ausgefülltes Quadrat zur Darstellung des Feldes.
    • Versenktes Quadrat
Erzeugt eine quadratische Schattierung, so dass das Feld dreidimensional wirkt.
    • Ausgefüllter Kreis
Verwendet einen ausgefüllten Kreis zur Darstellung des Feldes.
    • Versenkter Kreis
Erzeugt eine kreisförmige Schattierung, so dass das Feld dreidimensional wirkt.
    • Benutzerdefiniert
Zeigt das Dialogfeld „Angepasstes Erscheinungsbild“ an. Wählen Sie diese Option, wenn Sie ein eigenes Design für den Füllbereich entwerfen möchten.
Bei Auswahl der Ausschlussgruppe stehen folgende Optionen zur Verfügung:
    • Keine Begrenzung
Die Ausschlussgruppe wird ohne Begrenzung angezeigt.
    • Durchgehende Begrenzung
Erzeugt eine breite Linie, die die Gruppe umrahmt.
    • Angehobene Begrenzung
Erzeugt eine Schattierung um die Gruppe, so dass sie dreidimensional wirkt.
    • Benutzerdefiniert
Zeigt das Dialogfeld „Angepasstes Erscheinungsbild“ an. Wählen Sie diese Option, wenn Sie das Erscheinungsbild der Gruppe selbst festlegen möchten.
Größe
Legt die Größe des Optionsfeldes fest.
Schaltflächenstil
Legt den Stil des Optionsfeldes fest:
    • Standard
Verwendet einen ausgefüllten Kreis als Schaltflächenstil.
    • Häkchen
Verwendet ein Häkchen als Schaltflächenstil.
    • Kreis
Verwendet einen Kreis als Schaltflächenstil.
    • Kreuz
Verwendet einen Kreuz als Schaltflächenstil.
    • Karo
Verwendet einen Karo als Schaltflächenstil.
    • Quadrat
Verwendet einen Quadrat als Schaltflächenstil.
    • Stern
Verwendet einen Stern als Schaltflächenstil.
Element
Führt alle Optionsfelder in der aktuellen Ausschlussgruppe auf. Sie können auf ein Optionsfeld doppelklicken, um die Beschriftung zu ändern.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Optionsfelder – Übersicht


Eigenschaften von Optionsfeldern: Registerkarte „Wert“

Wenn Sie eine Ausschlussgruppe mit Optionsfeldern erzeugen, stehen Ihnen auf der Registerkarte „Wert“ verschiedene Optionen zur Verfügung, die Sie auf die Gruppe anwenden können.
Typ
Ermöglicht Berechnungen und Eingabeaufforderungen zur Laufzeit:
    • Benutzereingabe - Optional
Der Benutzer kann selbst entscheiden, ob er Daten eingeben möchte.
    • Benutzereingabe - Empfohlen
Wenn der Benutzer keine Daten eingibt, wird eine eigene Meldung angezeigt (soweit sie im Feld „Meldung bei leerem Feld“ eingetragen worden ist).
    • Benutzereingabe - Erforderlich
Wenn der Benutzer keine Daten eingibt, wird eine eigene Meldung angezeigt (soweit sie im Feld „Meldung bei leerem Feld“ eingetragen worden ist).
    • Berechnet - Schreibgeschützt
Ein Datenwert wird über ein angehängtes Skript berechnet und angezeigt. Die Benutzer können den berechneten Wert nicht bearbeiten.
    • Berechnet - Benutzer darf überschreiben
Ein Datenwert wird über ein angehängtes Skript berechnet und angezeigt. Die Benutzer können den berechneten Wert bearbeiten, wenn im Berechnungsskript eine Verarbeitung der Benutzereingabe vorgesehen ist. Wenn ein Benutzer den berechneten Wert bearbeiten möchte, wird eine Meldung angezeigt, die im Feld „Meldung beim Überschreiben eines Werts“ festgelegt wurde.
    • Schreibgeschützt
Ein Datenwert wird zur Laufzeit zusammengeführt oder berechnet und angezeigt. Die Benutzer können den Wert nicht bearbeiten.
Standardwert
Legt eine Standardauswahl fest.
Diese Option steht nur dann zur Verfügung, wenn die Option „Typ“ auf „Benutzereingabe - Optional“, „Benutzereingabe - Empfohlen“, „Benutzereingabe - Erforderlich“ oder „Schreibgeschützt“ gesetzt ist.
Meldung bei leerem Feld
Legt eine Meldung fest, mit der die Benutzer zur Eingabe eines empfohlenen oder erforderlichen Wertes aufgefordert werden. Siehe So fordern Sie Benutzer zur Dateneingabe auf.
Diese Option ist nur dann verfügbar, wenn die Option „Typ“ auf „Benutzereingabe - Empfohlen“ oder „Benutzereingabe - Erforderlich“ gesetzt ist.
Überprüfungsskript-Meldung und Fehler
Legt eine Meldung fest, die angezeigt wird, wenn ein angehängtes Überprüfungsskript einen inakzeptablen Wert ermittelt. Standardmäßig wird in einem solchen Fall zur Laufzeit ein Programmierfehler generiert. Wenn stattdessen eine Warnmeldung generiert werden soll, deaktivieren Sie die Option „Fehler“. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist. „Überprüfungsskript-Meldung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus.
Meldung beim Überschreiben eines Werts
Legt eine eigene Meldung fest, die den Benutzer darauf hinweist, dass er dabei ist, den Wert eines berechneten Feldes zu ändern. Die Meldung erscheint, wenn ein Benutzer den berechneten Wert ändert.
Diese Option steht nur zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Benutzer darf überschreiben“ gesetzt ist.
Verwandte Themen
Optionsfelder – Übersicht


Eigenschaften von Optionsfeldern: Registerkarte „Bindung“

Wenn Sie eine Ausschlussgruppe mit Optionsfeldern erzeugen, stehen Ihnen auf der Registerkarte „Bindung“ verschiedene Datenbindungsoptionen zur Verfügung, die Sie auf die Gruppe anwenden können. Die Optionen, die sich nicht direkt auf die Erstellung einer Datenverbindung beziehen, gelten für die an eine Datenquelle gebundenen und die in einer Datei gespeicherten Daten, wenn das Objekt an keine Datenquelle gebunden ist.
Name
Legt den Namen der Ausschlussgruppe fest.
Standardbindung
Legt die Standardmethode zum Binden von Daten fest:
    • Normal
Aktiviert die Optionen zum Zusammenführen und Speichern von Daten. Die Datenwerte werden den Adobe-Regeln zur Datenzusammenführung entsprechend zusammengeführt und gespeichert.
    • Global
Verbindet einen einzelnen Datenwert mit allen gleichnamigen Objekten (siehe So definieren Sie ein globales Feld).
    • Neue Datenverbindung
Startet den Assistenten „Neue Datenverbindung“. Weitere Informationen dazu, wie Sie eine Verbindung mit Hilfe des Assistenten definieren, finden Sie unter So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei oder So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank.
    • Ohne
Deaktiviert die Datenbindung. Da das Objekt keine zusammengeführten Daten erfasst oder anzeigt, bleiben alle Informationen, die zum Objekt gehören, beim Speichern oder Absenden der Formulardaten unberücksichtigt.
Elementwerte
Ermöglicht Ihnen das Festlegen benutzerdefinierter An-Werte für jedes Optionsfeld in der Gruppe. Jeder Wert, den Sie für ein Optionsfeld einer Gruppe festlegen, muss im Vergleich zu den Werten der übrigen Optionsfelder eindeutig sein.
Wenn diese Option nicht ausgewählt ist, entsprechen die An-Werte der Beschriftung für das Optionsfeld. Wenn diese Option ausgewählt ist, sind die Standardwerte fortlaufende Ganzzahlen, die beim ersten Optionsfeld in der Gruppe mit „1“ beginnen. Siehe So weisen Sie Optionsfeldern „An“-Werte zu.
Import/Export-Bindungen
Legt eine Import/Export-Bindung für eine WSDL-Datenverbindung fest. Siehe So erstellen Sie eine Datenverbindung zu einer WSDL-Datei.
Verwandte Themen
Datenquellen


Zurück Weiter

LiveCycle Designer verwenden > Objekteigenschaften > Eigenschaften in der Palette „Objekt“ > Rechtecke

Rechtecke

Eigenschaften von Rechtecken: Registerkarte „Zeichnen“


Eigenschaften von Rechtecken: Registerkarte „Zeichnen“

Wenn Sie ein Rechteck erzeugen, stehen Ihnen auf der Registerkarte „Zeichnen“ in der Palette „Objekt“ verschiedene Optionen zum Formatieren zur Verfügung.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Linienstil
Legt den Stil und die Stärke der Linie fest.
Farbauswahl
Legt die Linienfarbe fest.
Ecken
Legt den Stil für die Ecken fest.
Radius
Legt den Radius von abgerundeten Ecken fest.
Füllfarbe
Legt einen Füllstil fest.
Farbauswahl
Legt die Füllfarben fest.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Verwandte Themen
Kreise, Linien und Rechtecke – Übersicht


Teilformulare

Eigenschaften von Teilformularen: Registerkarte „Teilformular“
Eigenschaften von Teilformularen: Registerkarte „Paginierung“
Eigenschaften von Teilformularen: Registerkarte „Bindung“


Eigenschaften von Teilformularen: Registerkarte „Teilformular“

Wenn Sie ein Teilformular auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Teilformular“ verschiedene Formatierungsoptionen zur Verfügung.
Inhalt
Legt fest, ob der Inhalt des Teilformulars positioniert werden soll oder fließend sein soll.
    • Position
Positioniert die Objekte des Teilformulars entsprechend ihren jeweiligen X- und Y-Koordinaten.
    • Textfluss
Positioniert die Objekte des Teilformulars während der Datenzusammenführung, so dass keine Objekte aufeinander abgelegt werden.
Fließrichtung
Legt eine Fließrichtung für Objekte fest:
    • Von oben nach unten
Legt die Objekte untereinander ab.
    • Von links nach rechts
Legt die Objekte von links nach rechts ab. Wenn die Objekte an der rechten Kante des Teilformulars umgebrochen werden, stellt diese Option sicher, dass sie dann eine Position weiter unten ebenfalls wieder von links nach rechts abgelegt werden.
Diese Option ist nur verfügbar, wenn in der Liste „Inhalt“ die Option „Textfluss“ ausgewählt wurde.
Seitenumbrüche im Inhalt zulassen
Aktiviert oder deaktiviert Seitenumbrüche in der Mitte eines Teilformulars.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Teilformulare – Übersicht
So erstellen Sie ein Teilformular mit mehreren Seiten


Eigenschaften von Teilformularen: Registerkarte „Paginierung“

Wenn Sie ein Teilformular auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Paginierung“ verschiedene Paginierungsoptionen zur Verfügung.
Platzierung
Legt fest, wo das Teilformular platziert werden soll.
    • Nach vorherigem
Platziert das Teilformular nach dem vorherigen Objekt im übergeordneten Teilformular.
    • In Inhaltsbereich > [Name_des_Inhaltsbereichs]
Platziert das Teilformular im angegebenen Inhaltsbereich.
    • Anfang des nächsten Inhaltsbereichs
Platziert das Teilformular am Anfang des nächsten Inhaltsbereichs.
    • Anfang des Inhaltsbereichs > [Name_des _Inhaltsbereichs]
Platziert das Teilformular am Anfang des angegebenen Inhaltsbereichs.
    • Auf Seite > [Name_der_Seite]
Platziert das Teilformular auf der angegebenen Seite (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
    • Anfang der nächsten Seite
Platziert das Teilformular am Anfang der nächsten Seite (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
    • Anfang der Seite > [Name_der_Seite]
Platziert das Teilformular am Anfang der Seite, sobald die angegebene Seite wiedergegeben wird (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
Nicht trennen: Vorherige
Hält das Teilformular im gleichen Inhaltsbereich wie das vorherige Teilformular.
Nicht trennen: Nächste
Hält das Teilformular im gleichen Inhaltsbereich wie das folgende Teilformular.
Nach
Legt fest, welcher Bereich gefüllt werden soll, nachdem das Teilformular platziert wurde.
    • Übergeordnet weiter füllen
Setzt das Zusammenführen von Daten für alle Objekte fort, die im übergeordneten Teilformular zum Füllen verblieben sind.
    • Gehe zum nächsten Inhaltsbereich
Startet das Füllen des nächsten Inhaltsbereichs.
    • Gehe zum Inhaltsbereich > [Name_des_Inhaltsbereichs]
Startet das Füllen des angegebenen Inhaltsbereichs.
    • Gehe zur nächsten Seite
Startet das Füllen der nächsten Seite.
    • Gehe zu Seite > [Name_der_Seite]
Startet das Füllen der angegebenen Seite.
Bedingte Umbrüche
Legt die Anzahl der bedingten Umbrüche fest, die für das Teilformular definiert wurden.
Überlauf
Legt einen Überlauf für ein Teilformular fest, das mehrere Seiten umfasst.
    • Ohne
Startet das Füllen der nächsten Seite (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch eingefügt wird).
    • Gehe zum Inhaltsbereich > [Name_des_Inhaltsbereichs]
Startet das Füllen des angegebenen Inhaltsbereichs.
    • Gehe zu Seite > [Name_der_Seite]
Startet das Füllen der angegebenen Seite.
Überlaufkopfbereich
Gibt einen Überlaufkopfbereich für ein Teilformular an, in das Seitenumbrüche eingefügt werden müssen.
    • [Name_des_Teilformulars]
Verwendet dieses bestehende Teilformular als Überlaufkopfbereich.
    • Ohne
Es wird kein Überlaufkopfbereich bei der Paginierung des Teilformulars verwendet.
    • Neu
Erstellt ein neues Überlaufkopfbereich-Teilformular in LiveCycle Designer und legt es bei der Paginierung dieses Teilformulars als Überlaufkopfbereich fest.
Überlauffußbereich
Gibt einen Überlauffußbereich für ein Teilformular an, in das Seitenumbrüche eingefügt werden müssen.
    • [Name_des_Teilformulars]
Verwendet dieses bestehende Teilformular als Überlauffußbereich.
    • Ohne
Es wird kein Überlauffußbereich bei der Paginierung des Teilformulars verwendet.
    • Neu
Erstellt ein neues Überlauffußbereich-Teilformular in LiveCycle Designer und legt es bei der Paginierung dieses Teilformulars als Überlauffußbereich fest.
Verwandte Themen
Teilformulare – Übersicht
Eigenschaften von Teilformularen: Registerkarte „Teilformular“
Eigenschaften von Teilformularen: Registerkarte „Bindung“


Eigenschaften von Teilformularen: Registerkarte „Bindung“

Wenn Sie ein Teilformular auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Bindung“ verschiedene Datenbindungsoptionen zur Verfügung. Die Optionen, die sich nicht direkt auf die Erstellung einer Datenverbindung beziehen, gelten für die an eine Datenquelle gebundenen und die in einer Datei gespeicherten Daten, wenn das Objekt an keine Datenquelle gebunden ist.
Name
Legt den Namen des Teilformulars fest. Standardmäßig haben Teilformulare keinen Namen. Siehe So benennen Sie ein Teilformular.
Standardbindung
Legt die Standardmethode zum Binden von Daten fest.
    • Normal
Aktiviert die Optionen zum Zusammenführen und Speichern von Daten. Die Datenwerte werden den Adobe-Regeln zur Datenzusammenführung entsprechend zusammengeführt und gespeichert.
    • Neue Datenverbindung
Startet den Assistenten „Neue Datenverbindung“. Weitere Informationen dazu, wie Sie eine Verbindung mit Hilfe des Assistenten definieren, finden Sie unter So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei oder So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank.
    • Ohne
Deaktiviert die Datenbindung. Das Teilformular wird nicht in die Operationen zur Datenzusammenfügung einbezogen. Trotzdem können die Objekte des Teilformulars (einschließlich verschachtelter Teilformulare) weiterhin Daten aufzeichnen oder anzeigen.
Anfangszahl
Legt die Anzahl der Exemplare des momentan ausgewählten Objekts fest, die zunächst im Formular angezeigt werden sollen, unabhängig von der Datenmenge aus einer beliebigen Datenverbindung. Der von Ihnen angegebene Wert muss gleich oder größer als der Wert für „Min-Zähler“ und kleiner oder gleich dem Wert für „Maximal“ sein.
Verwandte Themen
Datenquellen


Teilformularsätze

Eigenschaften von Teilformularsätzen: Registerkarte „Teilformularsatz“
Eigenschaften von Teilformularsätzen: Registerkarte „Paginierung“
Eigenschaften von Teilformularsätzen: Registerkarte „Bindung“


Eigenschaften von Teilformularsätzen: Registerkarte „Teilformularsatz“

Wenn Sie einen Teilformularsatz auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Teilformularsatz“ verschiedene Formatierungsoptionen zur Verfügung.
„Alternativen bearbeiten“ ist nur verfügbar, wenn die Option „Teilformular aus Alternativen auswählen“ im Listenfeld „Typ“ ausgewählt wurde.
Typ
Legt die Reihenfolge fest, in der Teilformulare im Teilformularsatz in einem Formular wiedergegeben werden.
    • Alle Teilformulare in festgelegter Reihenfolge verwenden
Alle Teilformulare im Teilformularsatz werden in der Reihenfolge wiedergegeben, in der sie im Formularentwurf auftreten.
    • Teilformular aus Alternativen auswählen
Nur eines der Teilformulare aus dem Teilformularsatz wird den Bedingungen entsprechend wiedergegeben, die vom Formularautor festgelegt wurden.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
Verwandte Themen
Teilformularsätze – Übersicht
Eigenschaften von Teilformularsätzen: Registerkarte „Paginierung“
Eigenschaften von Teilformularsätzen: Registerkarte „Bindung“
Dialogfeld „Datenteilformulare bearbeiten“


Eigenschaften von Teilformularsätzen: Registerkarte „Paginierung“

Wenn Sie einen Teilformularsatz auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Paginierung“ verschiedene Paginierungsoptionen zur Verfügung.
Platzierung
Legt fest, wo der Teilformularsatz platziert werden soll.
    • Nach vorherigem
Platziert den Teilformularsatz nach dem vorherigen Objekt im übergeordneten Teilformular.
    • In Inhaltsbereich > [Name_des_Inhaltsbereichs]
Platziert den Teilformularsatz im angegebenen Inhaltsbereich.
    • Anfang des nächsten Inhaltsbereichs
Platziert den Teilformularsatz am Anfang des nächsten Inhaltsbereichs.
    • Anfang des Inhaltsbereichs > [Name_des _Inhaltsbereichs]
Platziert den Teilformularsatz am Anfang des angegebenen Inhaltsbereichs.
    • Auf Seite > [Name_der_Seite]
Platziert den Teilformularsatz auf der angegebenen Seite (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
    • Anfang der nächsten Seite
Platziert den Teilformularsatz am Anfang der nächsten Seite (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
    • Anfang der Seite > [Name_der_Seite]
Platziert den Teilformularsatz am Anfang der Seite, sobald die angegebene Seite wiedergegeben wird (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
    • Auf ungerader Seite
Platziert den Teilformularsatz auf Seiten, die als ungerade Seiten zum Drucken eingerichtet sind.
    • Anfang der nächsten ungeraden Seite
Platziert den Teilformularsatz am Anfang der ungeraden Seite, sobald die angegebene Seite wiedergegeben wird (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
    • Auf gerader Seite
Platziert den Teilformularsatz auf Seiten, die als gerade Seiten zum Drucken eingerichtet sind.
    • Anfang der nächsten geraden Seite
Platziert den Teilformularsatz am Anfang der nächsten geraden Seite, sobald die angegebene Seite wiedergegeben wird (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
Nach
Legt fest, welcher Bereich gefüllt werden soll, nachdem der Teilformularsatz platziert wurde.
    • Übergeordnet weiter füllen
Setzt das Zusammenführen von Daten für alle Objekte fort, die im übergeordneten Teilformular zum Füllen verblieben sind.
    • Gehe zum nächsten Inhaltsbereich
Startet das Füllen des nächsten Inhaltsbereichs.
    • Gehe zum Inhaltsbereich > [Name_des_Inhaltsbereichs]
Startet das Füllen des angegebenen Inhaltsbereichs.
    • Gehe zur nächsten Seite
Startet das Füllen der nächsten Seite.
    • Gehe zu Seite > [Name_der_Seite]
Startet das Füllen der angegebenen Seite.
Bedingte Umbrüche
Legt die Anzahl der bedingten Umbrüche fest, die für den Teilformularsatz definiert wurden.
Überlauf
Legt einen Überlauf für einen Teilformularsatz fest, der mehrere Seiten umfasst.
    • Ohne
Startet das Füllen der nächsten Seite (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch eingefügt wird).
    • Gehe zum Inhaltsbereich > [Name_des_Inhaltsbereichs]
Startet das Füllen des angegebenen Inhaltsbereichs.
    • Gehe zu Seite > [Name_der_Seite]
Startet das Füllen der angegebenen Seite.
Überlaufkopfbereich
Gibt einen Überlaufkopfbereich für einen Teilformularsatz an, in den Seitenumbrüche eingefügt werden müssen.
    • Ohne
Es wird kein Überlaufkopfbereich bei der Paginierung des Teilformularsatzes verwendet.
    • [Name_des_Teilformulars]
Verwendet diesen bestehenden Teilformularsatz als Überlaufkopfbereich.
    • Neu
Erstellt einen neuen Überlaufkopfbereich-Teilformularsatz und legt ihn bei der Paginierung dieses Teilformulars als Überlaufkopfbereich fest.
Überlauffußbereich
Gibt einen Überlauffußbereich für einen Teilformularsatz an, in den Seitenumbrüche eingefügt werden müssen.
    • Ohne
Es wird kein Überlauffußbereich bei der Paginierung des Teilformularsatzes verwendet.
    • [Name_des_Teilformulars]
Verwendet diesen bestehenden Teilformularsatz als Überlauffußbereich.
    • Neu
Erstellt ein neues Überlauffußbereich-Teilformular und legt es als den Überlauffußbereich bei der Paginierung dieses Teilformulars fest.
Verwandte Themen
Teilformularsätze – Übersicht
Eigenschaften von Teilformularsätzen: Registerkarte „Teilformularsatz“
Eigenschaften von Teilformularsätzen: Registerkarte „Bindung“


Eigenschaften von Teilformularsätzen: Registerkarte „Bindung“

Wenn Sie einen Teilformularsatz auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Bindung“ verschiedene Datenbindungsoptionen zur Verfügung.
Name
Legt den Namen des Teilformularsatzes fest. Standardmäßig haben Teilformularsätze keinen Namen.
Teilformular wiederholen für jedes Datenelement
Aktiviert oder deaktiviert die Teilformular-Wiederholung.
Min-Zähler
Legt die Mindestanzahl der Exemplare des momentan ausgewählten Objekts fest, die im Formular angezeigt werden sollen.
Max
Legt die maximale Anzahl der Exemplare des momentan ausgewählten Objekts fest, die im Formular angezeigt werden sollen.
Anfangszahl
Legt die Anzahl der Exemplare des momentan ausgewählten Objekts fest, die zunächst im Formular angezeigt werden sollen, unabhängig von der Datenmenge aus einer beliebigen Datenverbindung. Der von Ihnen angegebene Wert muss gleich oder größer als der Wert für „Min-Zähler“ und kleiner oder gleich dem Wert für „Maximal“ sein.
Verwandte Themen
Teilformularsätze – Übersicht


Tabellen

Eigenschaften von Tabellen: Registerkarte „Tabelle“
Eigenschaften von Tabellen: Registerkarte „Zeilenschattierung“
Eigenschaften von Tabellen: „Paginierung“
Eigenschaften von Tabellen: Registerkarte „Bindung“
Eigenschaften von Kopfzeilen: Registerkarte „Zeile“
Eigenschaften von Fußzeilen: Registerkarte „Zeile“
Eigenschaften von Kopf- und Fußzeilen: Registerkarte „Paginierung“
Eigenschaften von Kopfzeilen: Registerkarte „Bindung“
Eigenschaften von Fußzeilen: Registerkarte „Bindung“
Eigenschaften von Textzeilen: Registerkarte „Zeile“
Eigenschaften von Textzeilen: Registerkarte „Paginierung“
Eigenschaften von Textzeilen: Registerkarte „Bindung“
Eigenschaften von Abschnitten: Registerkarte „Abschnitt“
Eigenschaften von Abschnitten: Registerkarte „Zeilenschattierung“
Eigenschaften von Abschnitten: Registerkarte „Paginierung“
Eigenschaften von Abschnitten: Registerkarte „Bindung“
Eigenschaften von Zellen: Registerkarte „Zelle“
Eigenschaften von Zellen: Registerkarte „Wert“
Eigenschaften von Zellen: Registerkarte „Bindung“


Eigenschaften von Tabellen: Registerkarte „Tabelle“

Wenn Sie eine Tabelle auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Tabelle“ verschiedene Formatierungsoptionen zur Verfügung.
Textzeilen
Zeigt die Anzahl der Textzeilen.
Kopfzeilen
Zeigt die Anzahl der Kopfzeilen.
Spalten
Zeigt die Anzahl der Spalten.
Fußzeilen
Zeigt die Anzahl der Fußzeilen.
Seitenumbrüche im Inhalt zulassen
Aktiviert oder deaktiviert Seitenumbrüche in der Mitte einer Tabelle.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Info über Tabellen
Eigenschaften von Tabellen: Registerkarte „Zeilenschattierung“
Eigenschaften von Tabellen: „Paginierung“
Eigenschaften von Tabellen: Registerkarte „Bindung“


Eigenschaften von Tabellen: Registerkarte „Zeilenschattierung“

Wenn Sie eine Tabelle auswählen, zeigt die Registerkarte „Zeilenschattierung“ der Palette „Objekt“ Optionen zum Anwenden von Schattierungsfarben auf Zeilen im Wechsel an.
Abwechselnde Zeilenschattierung
Aktiviert bzw. deaktiviert die Schattierung von Textzeilen in einer Tabelle.
Bei Tabellen mit bei der Formularwiedergabe zusammengeführten Daten, wird die Schattierung nur auf Textzeilen mit zusammengeführten Daten angewendet. Auf Textzeilen, die nicht Teil der Datenzusammenführung sind, wird keine Schattierung angewendet. Alle Zeilen mit Schattierung müssen einen Namen haben. Siehe Eigenschaften von Textzeilen: Registerkarte „Bindung“.
ErsteLegt die Anzahl der Textzeilen fest, auf die die erste Schattierungsfarbe angewendet wird, angefangen bei der ersten Textzeile.
Farbauswahl
Legt die erste Füllfarbe für die Schattierung fest.
Nächste
Legt die Anzahl der Textzeilen fest, auf die die zweite Schattierungsfarbe angewendet wird. Dies sind jeweils die Zeilen nach den Textzeilen mit der ersten Schattierungsfarbe.
Farbauswahl
Legt die zweite Füllfarbe für die Schattierung fest.
Verwandte Themen
Info über Tabellen
So wenden Sie Rahmen und Schattierungen auf eine Tabelle an
Eigenschaften von Tabellen: Registerkarte „Tabelle“
Eigenschaften von Tabellen: „Paginierung“
Eigenschaften von Tabellen: Registerkarte „Bindung“


Eigenschaften von Tabellen: „Paginierung“

Wenn Sie eine Tabelle auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Paginierung“ verschiedene Paginierungsoptionen zur Verfügung.
Platzierung
Legt fest, wo die Tabelle platziert werden soll.
    • Nach vorherigem
Platziert die Tabelle nach dem vorherigen Objekt im übergeordneten Teilformular.
    • In Inhaltsbereich > [Name_des_Inhaltsbereichs]
Platziert die Tabelle im angegebenen Inhaltsbereich.
    • Anfang des nächsten Inhaltsbereichs
Platziert die Tabelle am Anfang des nächsten Inhaltsbereichs.
    • Anfang des Inhaltsbereichs > [Name_des _Inhaltsbereichs]
Platziert die Tabelle am Anfang des angegebenen Inhaltsbereichs.
    • Auf Seite > [Name_der_Seite]
Platziert die Tabelle auf der angegebenen Seite (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
    • Anfang der nächsten Seite
Platziert die Tabelle am Anfang der nächsten Seite (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
    • Anfang der Seite > [Name_der_Seite]
Platziert die Tabelle am Anfang der Seite, sobald die angegebene Seite wiedergegeben wird (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
Nicht trennen: Vorherige
Hält die Tabelle im gleichen Inhaltsbereich wie die vorherige Tabelle.
Nicht trennen: Nächste
Hält die Tabelle im gleichen Inhaltsbereich wie die nächste Tabelle.
Nach
Legt fest, welcher Bereich gefüllt werden soll, nachdem die Tabelle platziert wurde.
    • Übergeordnet weiter füllen
Setzt das Zusammenführen von Daten für alle Objekte fort, die im übergeordneten Teilformular zum Füllen verblieben sind.
    • Gehe zum nächsten Inhaltsbereich
Startet das Füllen des nächsten Inhaltsbereichs.
    • Gehe zum Inhaltsbereich > [Name_des_Inhaltsbereichs]
Startet das Füllen des angegebenen Inhaltsbereichs.
    • Gehe zur nächsten Seite
Startet das Füllen der nächsten Seite.
    • Gehe zu Seite > [Name_der_Seite]
Startet das Füllen der angegebenen Seite.
Bedingte Umbrüche
Legt die Anzahl der bedingten Umbrüche fest, die für die Tabelle definiert wurden. Siehe So steuern Sie Tabellen-, Kopfzeilen-, Textzeilen-, Fußzeilen- und Abschnittsumbrüche mit Hilfe von bedingten Anweisungen.
Überlauf
Legt einen Überlauf für eine Tabelle fest, die mehrere Seiten umfasst. Siehe So richten Sie eine Tabelle über mehrere Seiten hinweg ein.
    • Ohne
Startet das Füllen der nächsten Seite (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch eingefügt wird).
    • Gehe zum Inhaltsbereich > [Name_des_Inhaltsbereichs]
Startet das Füllen des angegebenen Inhaltsbereichs.
    • Gehe zu Seite > [Name_der_Seite]
Startet das Füllen der angegebenen Seite.
Verwandte Themen
Info über Tabellen
So richten Sie eine Tabelle über mehrere Seiten hinweg ein
Eigenschaften von Tabellen: Registerkarte „Tabelle“
Eigenschaften von Tabellen: Registerkarte „Zeilenschattierung“
Eigenschaften von Tabellen: Registerkarte „Bindung“


Eigenschaften von Tabellen: Registerkarte „Bindung“

Wenn Sie eine Tabelle auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Bindung“ verschiedene Datenbindungsoptionen zur Verfügung. Die Optionen, die sich nicht direkt auf die Erstellung einer Datenverbindung beziehen, gelten für die an eine Datenquelle gebundenen und die in einer Datei gespeicherten Daten, wenn das Objekt an keine Datenquelle gebunden ist.
Name
Legt den Namen der Tabelle fest. Wenn bestehende Tabellen im Formular denselben Namen verwenden, zeigt die Zahl neben dem Namen das Exemplar für die aktuelle Tabelle an. Siehe So können Sie Objekte benennen und umbenennen.
Standardbindung
Legt die Standardmethode zum Binden von Daten fest:
    • Normal
Aktiviert die Optionen zum Zusammenführen und Speichern von Daten. Die Datenwerte werden den Adobe-Regeln zur Datenzusammenführung entsprechend zusammengeführt und gespeichert.
    • Global
Verbindet einen einzelnen Datenwert mit allen gleichnamigen Objekten (siehe So definieren Sie ein globales Feld).
    • Neue Datenverbindung
Startet den Assistenten „Neue Datenverbindung“. Weitere Informationen dazu, wie Sie eine Verbindung mit Hilfe des Assistenten definieren, finden Sie unter So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei oder So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank.
    • Ohne
Deaktiviert die Datenbindung. Da das Objekt keine zusammengeführten Daten erfasst oder anzeigt, bleiben alle Informationen, die zum Objekt gehören, beim Speichern oder Absenden der Formulardaten unberücksichtigt.
Import/Export-Bindungen
Legt eine Import/Export-Bindung für eine WSDL-Datenverbindung fest. Siehe So erstellen Sie eine Datenverbindung zu einer WSDL-Datei.
Tabelle für jedes Datenelement wiederholen
Aktiviert bzw. deaktiviert die Tabellenwiederholung.
Min-Zähler
Legt die Mindestanzahl der Exemplare des momentan ausgewählten Objekts fest, die im Formular angezeigt werden sollen.
Max
Legt die maximale Anzahl der Exemplare des momentan ausgewählten Objekts fest, die im Formular angezeigt werden sollen.
Anfangszahl
Legt die Anzahl der Exemplare des momentan ausgewählten Objekts fest, die zunächst im Formular angezeigt werden sollen, unabhängig von der Datenmenge aus einer beliebigen Datenverbindung. Der von Ihnen angegebene Wert muss gleich oder größer als der Wert für „Min-Zähler“ und kleiner oder gleich dem Wert für „Maximal“ sein.
Verwandte Themen
Info über Tabellen
Eigenschaften von Tabellen: Registerkarte „Tabelle“
Eigenschaften von Tabellen: Registerkarte „Zeilenschattierung“
Eigenschaften von Tabellen: „Paginierung“


Eigenschaften von Kopfzeilen: Registerkarte „Zeile“

Wenn Sie eine Kopf- oder Fußzeile auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Zeile“ verschiedene Formatierungsoptionen zur Verfügung.
Typ
Legt den Typ für den Zeileninhalt fest:
    • Textzeile
Die Zeile enthält Tabelleninhalt.
    • Kopfzeile
Die Zeile enthält Kopfzeileninformationen. Dies ist in der Regel die erste Zeile, die in einer Tabelle angelegt wird. Eine Kopfzeile kann z. B. Informationen über den Inhalt jeder Tabellenspalte enthalten.
    • Fußzeile
Die Zeile enthält Fußzeileninformationen. Dies ist in der Regel die letzte Zeile, die in einer Tabelle angelegt wird. In einer Tabelle, die beispielsweise numerische Daten enthält, kann eine Fußzeile den Gesamtwert jeder Spalte angeben.
Seitenumbrüche im Inhalt zulassen
Aktiviert oder deaktiviert Seitenumbrüche in der Mitte einer Zeile.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Info über Tabellen
So wandeln Sie eine Zeile in eine Kopf-, Fuß- oder Textzeile um
Eigenschaften von Kopf- und Fußzeilen: Registerkarte „Paginierung“
Eigenschaften von Kopfzeilen: Registerkarte „Bindung“


Eigenschaften von Fußzeilen: Registerkarte „Zeile“

Wenn Sie eine Kopf- oder Fußzeile auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Zeile“ verschiedene Formatierungsoptionen zur Verfügung.
Typ
Legt den Typ für den Zeileninhalt fest:
    • Textzeile
Die Zeile enthält Tabelleninhalt.
    • Kopfzeile
Die Zeile enthält Kopfzeileninformationen. Dies ist in der Regel die erste Zeile, die in einer Tabelle angelegt wird. Eine Kopfzeile kann z. B. Informationen über den Inhalt jeder Tabellenspalte enthalten.
    • Fußzeile
Die Zeile enthält Fußzeileninformationen. Dies ist in der Regel die letzte Zeile, die in einer Tabelle angelegt wird. In einer Tabelle, die beispielsweise numerische Daten enthält, kann eine Fußzeile den Gesamtwert jeder Spalte angeben.
Seitenumbrüche im Inhalt zulassen
Aktiviert oder deaktiviert Seitenumbrüche in der Mitte einer Zeile.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Info über Tabellen
So wandeln Sie eine Zeile in eine Kopf-, Fuß- oder Textzeile um
Eigenschaften von Kopf- und Fußzeilen: Registerkarte „Paginierung“
Eigenschaften von Kopfzeilen: Registerkarte „Bindung“


Eigenschaften von Kopf- und Fußzeilen: Registerkarte „Paginierung“

Wenn Sie eine Kopf- oder Fußzeile auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Paginierung“ verschiedene Formatierungsoptionen zur Verfügung.
Platzierung
Legt fest, wo die Kopf- oder Fußzeile abgelegt werden soll.
    • Nach vorherigem
Legt die Zeile nach der vorherigen Zeile ab.
    • In Inhaltsbereich > [Name_des_Inhaltsbereichs]
Platziert die Zeile im angegebenen Inhaltsbereich.
    • Anfang des nächsten Inhaltsbereichs
Platziert die Zeile am Anfang des nächsten Inhaltsbereichs.
    • Anfang des Inhaltsbereichs > [Name_des _Inhaltsbereichs]
Platziert die Zeile am Anfang des angegebenen Inhaltsbereichs.
    • Auf Seite > [Name_der_Seite]
Platziert die Zeile auf der angegebenen Seite (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
    • Anfang der nächsten Seite
Platziert die Zeile am Anfang der nächsten Seite (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
    • Anfang der Seite > [Name_der_Seite]
Platziert die Zeile am Anfang der Seite, sobald die angegebene Seite wiedergegeben wird (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
Nicht trennen: Vorherige
Hält die Zeile im gleichen Inhaltsbereich wie die vorherige Zeile.
Nicht trennen: Nächste
Hält die Zeile im gleichen Inhaltsbereich wie die nächste Zeile.
Nach
Legt fest, welcher Bereich gefüllt werden soll, nachdem die Zeile platziert wurde.
    • Übergeordnet weiter füllen
Setzt das Zusammenführen von Daten für alle Objekte fort, die in der übergeordneten Tabelle zum Füllen verblieben sind.
    • Gehe zum nächsten Inhaltsbereich
Startet das Füllen des nächsten Inhaltsbereichs.
    • Gehe zum Inhaltsbereich > [Name_des_Inhaltsbereichs]
Startet das Füllen des angegebenen Inhaltsbereichs.
    • Gehe zur nächsten Seite
Startet das Füllen der nächsten Seite.
    • Gehe zu Seite > [Name_der_Seite]
Startet das Füllen der angegebenen Seite.
Bedingte Umbrüche
Legt die Anzahl der bedingten Umbrüche fest, die für die Kopf- bzw. Fußzeile definiert wurden. Siehe So steuern Sie Tabellen-, Kopfzeilen-, Textzeilen-, Fußzeilen- und Abschnittsumbrüche mit Hilfe von bedingten Anweisungen.
Kopfzeile in Tabelle einschließen
Legt für eine Kopfzeile fest, dass die Zeile an ihrer aktuellen Position in der Tabelle angezeigt wird.
Kopfzeile in aufeinander folgenden Seiten einschließen
Legt für eine Kopfzeile in Tabellen, die mehrere Seiten umfassen, fest, dass die Zeile als erste Zeile in der Tabelle auf jeder Seite eingefügt wird.
Fußzeile in aufeinander folgenden Seiten einschließen
Legt für eine Fußzeile in Tabellen, die mehrere Seiten umfassen, fest, dass die Zeile als letzte Zeile in der Tabelle auf jeder Seite eingefügt wird.
Fußzeile in Tabelle einschließen
Legt für eine Fußzeile fest, dass die Zeile an ihrer aktuellen Position in der Tabelle angezeigt wird.
Verwandte Themen
Info über Tabellen
So wiederholen Sie eine Kopf- oder Fußzeile auf Folgeseiten
Eigenschaften von Kopfzeilen: Registerkarte „Zeile“
Eigenschaften von Kopfzeilen: Registerkarte „Bindung“
Eigenschaften von Textzeilen: Registerkarte „Paginierung“


Eigenschaften von Kopfzeilen: Registerkarte „Bindung“

Wenn Sie eine Kopf- oder Fußzeile auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Bindung“ verschiedene Formatierungsoptionen zur Verfügung. Die Optionen, die sich nicht direkt auf die Erstellung einer Datenverbindung beziehen, gelten für die an eine Datenquelle gebundenen und die in einer Datei gespeicherten Daten, wenn das Objekt an keine Datenquelle gebunden ist.
Name
Legt den Namen der Zeile fest. Wenn bestehende Zeilen in der Tabelle denselben Namen verwenden, zeigt die Zahl neben dem Namen das Exemplar für die aktuelle Zeile an. Siehe So können Sie Objekte benennen und umbenennen.
Standardbindung
Legt die Standardmethode zum Binden von Daten fest:
    • Normal
Aktiviert die Optionen zum Zusammenführen und Speichern von Daten. Die Datenwerte werden den Adobe-Regeln zur Datenzusammenführung entsprechend zusammengeführt und gespeichert.
    • Global
Verbindet einen einzelnen Datenwert mit allen gleichnamigen Objekten (siehe So definieren Sie ein globales Feld).
    • Neue Datenverbindung
Startet den Assistenten „Neue Datenverbindung“. Weitere Informationen dazu, wie Sie eine Verbindung mit Hilfe des Assistenten definieren, finden Sie unter So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei oder So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank.
    • Ohne
Deaktiviert die Datenbindung. Da das Objekt keine zusammengeführten Daten erfasst oder anzeigt, bleiben alle Informationen, die zum Objekt gehören, beim Speichern oder Absenden der Formulardaten unberücksichtigt.
Import/Export-Bindungen
Legt eine Import/Export-Bindung für eine WSDL-Datenverbindung fest. Siehe So erstellen Sie eine Datenverbindung zu einer WSDL-Datei.
Zeile für jedes Datenelement wiederholen, Min-Zähler, Maximal und Anfangszahl
Aktiviert bzw. deaktiviert die Zeilenwiederholung. Siehe So legen Sie für die Zeilen in einer Tabelle die Größenanpassung an die Datenmenge fest.
Verwandte Themen
Info über Tabellen
Eigenschaften von Kopfzeilen: Registerkarte „Zeile“
Eigenschaften von Kopf- und Fußzeilen: Registerkarte „Paginierung“
Eigenschaften von Textzeilen: Registerkarte „Bindung“


Eigenschaften von Fußzeilen: Registerkarte „Bindung“

Wenn Sie eine Kopf- oder Fußzeile auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Bindung“ verschiedene Formatierungsoptionen zur Verfügung. Die Optionen, die sich nicht direkt auf die Erstellung einer Datenverbindung beziehen, gelten für die an eine Datenquelle gebundenen und die in einer Datei gespeicherten Daten, wenn das Objekt an keine Datenquelle gebunden ist.
Name
Legt den Namen der Zeile fest. Wenn bestehende Zeilen in der Tabelle denselben Namen verwenden, zeigt die Zahl neben dem Namen das Exemplar für die aktuelle Zeile an. Siehe So können Sie Objekte benennen und umbenennen.
Standardbindung
Legt die Standardmethode zum Binden von Daten fest:
    • Normal
Aktiviert die Optionen zum Zusammenführen und Speichern von Daten. Die Datenwerte werden den Adobe-Regeln zur Datenzusammenführung entsprechend zusammengeführt und gespeichert.
    • Global
Verbindet einen einzelnen Datenwert mit allen gleichnamigen Objekten (siehe So definieren Sie ein globales Feld).
    • Neue Datenverbindung
Startet den Assistenten „Neue Datenverbindung“. Weitere Informationen dazu, wie Sie eine Verbindung mit Hilfe des Assistenten definieren, finden Sie unter So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei oder So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank.
    • Ohne
Deaktiviert die Datenbindung. Da das Objekt keine zusammengeführten Daten erfasst oder anzeigt, bleiben alle Informationen, die zum Objekt gehören, beim Speichern oder Absenden der Formulardaten unberücksichtigt.
Import/Export-Bindungen
Legt eine Import/Export-Bindung für eine WSDL-Datenverbindung fest. Siehe So erstellen Sie eine Datenverbindung zu einer WSDL-Datei.
Zeile für jedes Datenelement wiederholen, Min-Zähler, Maximal und Anfangszahl
Aktiviert bzw. deaktiviert die Zeilenwiederholung. Siehe So legen Sie für die Zeilen in einer Tabelle die Größenanpassung an die Datenmenge fest.
Verwandte Themen
Info über Tabellen
Eigenschaften von Kopfzeilen: Registerkarte „Zeile“
Eigenschaften von Kopf- und Fußzeilen: Registerkarte „Paginierung“
Eigenschaften von Textzeilen: Registerkarte „Bindung“


Eigenschaften von Textzeilen: Registerkarte „Zeile“

Wenn Sie eine Textzeile auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Zeile“ verschiedene Formatierungsoptionen zur Verfügung.
Typ
Legt den Typ für den Zeileninhalt fest:
    • Textzeile
Die Zeile enthält Tabelleninhalt.
    • Kopfzeile
Die Zeile enthält Kopfzeileninformationen. Dies ist in der Regel die erste Zeile, die in einer Tabelle angelegt wird. Eine Kopfzeile kann z. B. Informationen über den Inhalt jeder Tabellenspalte enthalten.
    • Fußzeile
Die Zeile enthält Fußzeileninformationen. Dies ist in der Regel die letzte Zeile, die in einer Tabelle angelegt wird. In einer Tabelle, die beispielsweise numerische Daten enthält, kann eine Fußzeile den Gesamtwert jeder Spalte angeben.
Siehe Eigenschaften von Kopfzeilen: Registerkarte „Zeile“.
Seitenumbrüche im Inhalt zulassen
Aktiviert oder deaktiviert Seitenumbrüche in der Mitte einer Zeile.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Info über Tabellen
So wandeln Sie eine Zeile in eine Kopf-, Fuß- oder Textzeile um
Eigenschaften von Textzeilen: Registerkarte „Paginierung“
Eigenschaften von Textzeilen: Registerkarte „Bindung“


Eigenschaften von Textzeilen: Registerkarte „Paginierung“

Wenn Sie eine Textzeile auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Paginierung“ verschiedene Paginierungsoptionen zur Verfügung.
Die Einschließen-Optionen sind nur verfügbar, wenn eine Kopf- oder Fußzeile ausgewählt ist. Siehe Eigenschaften von Kopf- und Fußzeilen: Registerkarte „Paginierung“.
Platzierung
Legt fest, wo die Zeile platziert werden soll.
    • Nach vorherigem
Legt die Zeile nach der vorherigen Zeile ab.
    • In Inhaltsbereich > [Name_des_Inhaltsbereichs]
Platziert die Zeile im angegebenen Inhaltsbereich.
    • Anfang des nächsten Inhaltsbereichs
Platziert die Zeile am Anfang des nächsten Inhaltsbereichs.
    • Anfang des Inhaltsbereichs > [Name_des _Inhaltsbereichs]
Platziert die Zeile am Anfang des angegebenen Inhaltsbereichs.
    • Auf Seite > [Name_der_Seite]
Platziert die Zeile auf der angegebenen Seite (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
    • Anfang der nächsten Seite
Platziert die Zeile am Anfang der nächsten Seite (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
    • Anfang der Seite > [Name_der_Seite]
Platziert die Zeile am Anfang der Seite, sobald die angegebene Seite wiedergegeben wird (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
Nicht trennen: Vorherige
Hält die Zeile im gleichen Inhaltsbereich wie die vorherige Zeile.
Nicht trennen: Nächste
Hält die Zeile im gleichen Inhaltsbereich wie die nächste Zeile.
Nach
Legt fest, welcher Bereich gefüllt werden soll, nachdem die Zeile platziert wurde.
    • Übergeordnet weiter füllen
Setzt das Zusammenführen von Daten für alle Objekte fort, die in der übergeordneten Tabelle zum Füllen verblieben sind.
    • Gehe zum nächsten Inhaltsbereich
Startet das Füllen des nächsten Inhaltsbereichs.
    • Gehe zum Inhaltsbereich > [Name_des_Inhaltsbereichs]
Startet das Füllen des angegebenen Inhaltsbereichs.
    • Gehe zur nächsten Seite
Startet das Füllen der nächsten Seite.
    • Gehe zu Seite > [Name_der_Seite]
Startet das Füllen der angegebenen Seite.
Bedingte Umbrüche
Legt die Anzahl der bedingten Umbrüche fest, die für die Zelle definiert wurden. Siehe So steuern Sie Tabellen-, Kopfzeilen-, Textzeilen-, Fußzeilen- und Abschnittsumbrüche mit Hilfe von bedingten Anweisungen.
Verwandte Themen
Info über Tabellen
Eigenschaften von Textzeilen: Registerkarte „Zeile“
Eigenschaften von Textzeilen: Registerkarte „Bindung“


Eigenschaften von Textzeilen: Registerkarte „Bindung“

Wenn Sie eine Textzeile auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Bindung“ verschiedene Datenbindungsoptionen zur Verfügung. Die Optionen, die sich nicht direkt auf die Erstellung einer Datenverbindung beziehen, gelten für die an eine Datenquelle gebundenen und die in einer Datei gespeicherten Daten, wenn das Objekt an keine Datenquelle gebunden ist.
Name
Legt den Namen der Zeile fest. Standardmäßig haben Textzeilen keinen Namen. Wenn bestehende Zeilen im Formular denselben Namen verwenden, zeigt die Zahl neben dem Namen das Exemplar für die aktuelle Zeile an. Siehe So können Sie Objekte benennen und umbenennen.
Standardbindung
Legt die Standardmethode zum Binden von Daten fest:
    • Normal
Aktiviert die Optionen zum Zusammenführen und Speichern von Daten. Die Datenwerte werden den Adobe-Regeln zur Datenzusammenführung entsprechend zusammengeführt und gespeichert.
    • Global
Verbindet einen einzelnen Datenwert mit allen gleichnamigen Objekten (siehe So definieren Sie ein globales Feld).
    • Neue Datenverbindung
Startet den Assistenten „Neue Datenverbindung“. Weitere Informationen dazu, wie Sie eine Verbindung mit Hilfe des Assistenten definieren, finden Sie unter So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei oder So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank.
    • Ohne
Deaktiviert die Datenbindung. Da das Objekt keine zusammengeführten Daten erfasst oder anzeigt, bleiben alle Informationen, die zum Objekt gehören, beim Speichern oder Absenden der Formulardaten unberücksichtigt.
Import/Export-Bindungen
Legt eine Import/Export-Bindung für eine WSDL-Datenverbindung fest. Siehe So erstellen Sie eine Datenverbindung zu einer WSDL-Datei.
Zeile für jedes Datenelement wiederholen, Min-Zähler, Maximal und Anfangszahl
Aktiviert bzw. deaktiviert die Zeilenwiederholung. Siehe So legen Sie für die Zeilen in einer Tabelle die Größenanpassung an die Datenmenge fest.
Verwandte Themen
Info über Tabellen
Eigenschaften von Textzeilen: Registerkarte „Zeile“
Eigenschaften von Textzeilen: Registerkarte „Paginierung“
Eigenschaften von Kopfzeilen: Registerkarte „Bindung“


Eigenschaften von Abschnitten: Registerkarte „Abschnitt“

Wenn Sie einen Abschnitt auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Abschnitt“ verschiedene Formatierungsoptionen zur Verfügung.
Typ
Legt die Abschnitte fest, die beim Wiedergeben des Formulars basierend auf dem Abschnittsinhalt angezeigt werden.
    • Alle Teilformulare in festgelegter Reihenfolge verwenden
Alle Zeilen im Abschnitt werden beim Wiedergeben des Formulars einbezogen.
    • Teilformular aus Alternativen auswählen
Eine von zwei möglichen Zeilen wird bei der Wiedergabe des Formulars einbezogen. Die eingeschlossene Zeile wird basierend auf den zusammengeführten Daten bestimmt. Bei Zeilen mit einer Zelle, die einen berechneten Wert anzeigt, können Sie z. B. festlegen, dass eine Zeile angezeigt wird, wenn der Wert größer oder gleich Null ist, und dass eine andere Zeile angezeigt wird, wenn der Wert kleiner als Null ist.
Verwandte Themen
Info über Tabellen
So gruppieren Sie Zeilen als Abschnitt
So erstellen Sie Auswahlabschnitte in Tabellen
Eigenschaften von Abschnitten: Registerkarte „Zeilenschattierung“
Eigenschaften von Abschnitten: Registerkarte „Paginierung“
Eigenschaften von Abschnitten: Registerkarte „Bindung“


Eigenschaften von Abschnitten: Registerkarte „Zeilenschattierung“

Wenn Sie einen Abschnitt auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Zeilenschattierung“ Optionen zum Anwenden von abwechselnden Schattierungsfarben auf Zeilen im Abschnitt zur Verfügung.
Abwechselnde Zeilenschattierung
Aktiviert bzw. deaktiviert die Textzeilenschattierung in einem Abschnitt.
Bei Abschnitten mit bei der Formularwiedergabe zusammengeführten Daten, wird die Schattierung nur auf Textzeilen mit zusammengeführten Daten angewendet. Auf Textzeilen, die nicht Teil der Datenzusammenführung sind, wird keine Schattierung angewendet. Alle Zeilen mit Schattierung müssen einen Namen haben. Siehe Eigenschaften von Textzeilen: Registerkarte „Bindung“.
Erste
Legt die Anzahl der Textzeilen fest, auf die die erste Schattierungsfarbe angewendet wird, angefangen bei der ersten Textzeile im Abschnitt.
Farbauswahl
Legt die erste Füllfarbe für die Schattierung fest.
Nächste
Legt die Anzahl der Textzeilen im Abschnitt fest, auf die die zweite Schattierungsfarbe angewendet wird. Dies sind jeweils die Zeilen nach den Textzeilen mit der ersten Schattierungsfarbe.
Farbauswahl
Legt die zweite Füllfarbe für die Schattierung fest.
Verwandte Themen
Info über Tabellen
Eigenschaften von Abschnitten: Registerkarte „Abschnitt“
Eigenschaften von Abschnitten: Registerkarte „Paginierung“
Eigenschaften von Abschnitten: Registerkarte „Bindung“


Eigenschaften von Abschnitten: Registerkarte „Paginierung“

Wenn Sie einen Abschnitt auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Paginierung“ verschiedene Paginierungsoptionen zur Verfügung.
Platzierung
Legt fest, wo der Abschnitt platziert werden soll.
    • Nach vorherigem
Legt den Abschnitt nach dem vorherigen Abschnitt ab.
    • In Inhaltsbereich > [Name_des_Inhaltsbereichs]
Platziert den Abschnitt im angegebenen Inhaltsbereich.
    • Anfang des nächsten Inhaltsbereichs
Platziert den Abschnitt am Anfang des nächsten Inhaltsbereichs.
    • Anfang des Inhaltsbereichs > [Name_des _Inhaltsbereichs]
Platziert den Abschnitt am Anfang des angegebenen Inhaltsbereichs.
    • Auf Seite > [Name_der_Seite]
Platziert den Abschnitt auf der angegebenen Seite (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
    • Anfang der nächsten Seite
Platziert den Abschnitt am Anfang der nächsten Seite (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
    • Anfang der Seite > [Name_der_Seite]
Platziert den Abschnitt am Anfang der Seite, sobald die angegebene Seite wiedergegeben wird (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
Nach
Legt fest, welcher Bereich gefüllt werden soll, nachdem der Abschnitt platziert wurde.
    • Übergeordnet weiter füllen
Setzt das Zusammenführen von Daten für alle Objekte fort, die in der übergeordneten Tabelle zum Füllen verblieben sind.
    • Gehe zum nächsten Inhaltsbereich
Startet das Füllen des nächsten Inhaltsbereichs.
    • Gehe zum Inhaltsbereich > [Name_des_Inhaltsbereichs]
Startet das Füllen des angegebenen Inhaltsbereichs.
    • Gehe zur nächsten Seite
Startet das Füllen der nächsten Seite.
    • Gehe zu Seite > [Name_der_Seite]
Startet das Füllen der angegebenen Seite.
Bedingte Umbrüche
Legt die Anzahl der bedingten Umbrüche fest, die für den Abschnitt definiert wurden. Siehe So steuern Sie Tabellen-, Kopfzeilen-, Textzeilen-, Fußzeilen- und Abschnittsumbrüche mit Hilfe von bedingten Anweisungen.
Überlauf
Legt einen Überlauf für einen Abschnitt fest, der mehrere Seiten umfasst. Siehe So richten Sie eine Tabelle über mehrere Seiten hinweg ein.
    • Ohne
Startet das Füllen der nächsten Seite (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch eingefügt wird).
    • Gehe zum Inhaltsbereich > [Name_des_Inhaltsbereichs]
Startet das Füllen des angegebenen Inhaltsbereichs.
    • Gehe zu Seite > [Name_der_Seite]
Startet das Füllen der angegebenen Seite.
Verwandte Themen
Info über Tabellen
Eigenschaften von Abschnitten: Registerkarte „Abschnitt“
Eigenschaften von Abschnitten: Registerkarte „Zeilenschattierung“
Eigenschaften von Abschnitten: Registerkarte „Bindung“


Eigenschaften von Abschnitten: Registerkarte „Bindung“

Wenn Sie einen Abschnitt auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Bindung“ verschiedene Datenbindungsoptionen zur Verfügung. Die Optionen, die sich nicht direkt auf die Erstellung einer Datenverbindung beziehen, gelten für die an eine Datenquelle gebundenen und die in einer Datei gespeicherten Daten, wenn das Objekt an keine Datenquelle gebunden ist.
Name
Legt den Namen des Abschnitts fest. Wenn bestehende Abschnitte in der Tabelle denselben Namen verwenden, zeigt die Zahl neben dem Namen die Instanz für den aktuellen Abschnitt an. Standardmäßig haben Abschnitte keinen Namen. Siehe So können Sie Objekte benennen und umbenennen.
Abschnitt für jedes Datenelement wiederholen, Min-Zähler, Maximal und Anfangszahl
Aktiviert bzw. deaktiviert die Abschnittswiederholung. Siehe So kennzeichnen Sie einen Tabellenabschnitt als optional.
Verwandte Themen
Info über Tabellen
Eigenschaften von Abschnitten: Registerkarte „Abschnitt“
Eigenschaften von Abschnitten: Registerkarte „Zeilenschattierung“
Eigenschaften von Abschnitten: Registerkarte „Paginierung“


Eigenschaften von Zellen: Registerkarte „Zelle“

Wenn Sie eine Zelle auswählen, stehen Ihnen in der Palette „Objekt“ auf der Registerkarte „Zelle“ Formatierungsoptionen zur Verfügung.
Standardmäßig enthalten Zellen statischen Text. Die Registerkarte „Zelle“ enthält Formatierungsoptionen für das Textobjekt. Wenn Sie den Inhalt einer Zelle ändern, zeigt die Registerkarte „Zelle“ die Formatierungsoptionen für den entsprechenden Objekttyp an. Wenn Sie z. B. den Zelleninhalt in ein Textfeld ändern, zeigt die Registerkarte „Zelle“ die Formatierungsoptionen für ein Textfeldobjekt an.
Sie können den Zellentyp in einen beliebigen Standardobjekttyp ändern. Die Formatierungsoptionen auf der Registerkarte „Zelle“ entsprechen den Formatierungsoptionen, die verfügbar sind, wenn Sie das Objekt direkt in das Formular einfügen. Die Optionen auf der Registerkarte „Zelle“ für den Zellentyp „Textfeld“ entsprechen beispielsweise den Optionen der Registerkarte „Feld“ für ein Textfeldobjekt. Ebenso zeigt die Registerkarte „Zelle“ für den Zellentyp „Kreis“ dieselben Optionen an wie die Registerkarte „Zeichnen“ für ein Kreisobjekt.
Außer den Formatierungsoptionen für den Objekttyp enthält die Registerkarte „Zelle“ die folgenden Optionen:
    • Zellen zusammenführen
Führt zwei oder mehrere nebeneinander liegende, ausgewählte Zellen zusammen.
    • Zelle horizontal teilen
Teilt die Zelle bei Auswahl einer zusammengeführten Zelle basierend auf den ursprünglichen Positionen.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
Unsichtbar
      •
      Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
Verwandte Themen
Info über Tabellen
So wandeln Sie Zellen in einen anderen Objekttyp um
So können Sie Zellen zusammenführen und teilen
Eigenschaften von Zellen: Registerkarte „Wert“
Eigenschaften von Zellen: Registerkarte „Bindung“


Eigenschaften von Zellen: Registerkarte „Wert“

Wenn Sie eine Zelle auswählen, für die ein Objekttyp mit Wertoptionen (z. B. ein Textfeld oder numerisches Feld) festgelegt wurde, zeigt die Registerkarte „Wert“ der Palette „Objekt“ eine Reihe von Optionen an. Die auf der Registerkarte „Wert“ angezeigten Optionen sind vom auswählten Zellentyp abhängig. Wenn Sie z. B. eine Textfeldzelle auswählen, zeigt die Registerkarte „Wert“ die Optionen für ein Textfeldobjekt an.
Die Optionen auf der Registerkarte „Wert“ entsprechen den Optionen, die verfügbar sind, wenn Sie das Objekt direkt in das Formular einfügen.
Verwandte Themen
Info über Tabellen
Eigenschaften von Zellen: Registerkarte „Zelle“
Eigenschaften von Zellen: Registerkarte „Bindung“


Eigenschaften von Zellen: Registerkarte „Bindung“

Wenn Sie eine Zelle mit einem Objekt mit Bindungsoptionen (z. B. ein Textfeld oder Teilformular) auswählen, zeigt die Registerkarte „Bindung“ der Palette „Objekt“ eine Reihe von Datenbindungsoptionen an. Die auf der Registerkarte „Bindung“ angezeigten Optionen sind vom auswählten Zellentyp abhängig.
Wenn Sie z. B. eine Textfeldzelle auswählen, zeigt die Registerkarte „Bindung“ die Optionen für ein Textfeldobjekt an. Die Optionen, die sich nicht direkt auf die Erstellung einer Datenverbindung beziehen, gelten für die an eine Datenquelle gebundenen und die in einer Datei gespeicherten Daten, wenn das Objekt an keine Datenquelle gebunden ist.
Die Optionen auf der Registerkarte „Bindung“ entsprechen den Optionen, die verfügbar sind, wenn Sie das Objekt direkt in das Formular einfügen.
Verwandte Themen
Info über Tabellen
Eigenschaften von Zellen: Registerkarte „Zelle“
Eigenschaften von Zellen: Registerkarte „Wert“


Zurück Weiter

LiveCycle Designer verwenden > Objekteigenschaften > Eigenschaften in der Palette „Objekt“ > Text

Text

Eigenschaften von Text: Registerkarte „Zeichnen“


Eigenschaften von Text: Registerkarte „Zeichnen“

Wenn Sie ein Textobjekt erzeugen, stehen Ihnen auf der Registerkarte „Zeichnen“ der Palette „Objekt“ verschiedene Optionen zum Formatieren zur Verfügung.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Text – Übersicht


Textfelder

Eigenschaften von Textfeldern: Registerkarte „Feld“
Eigenschaften von Textfeldern: Registerkarte „Wert“
Eigenschaften von Textfeldern: Registerkarte „Bindung“
Textfeldmuster
Beispiele für Textmuster


Eigenschaften von Textfeldern: Registerkarte „Feld“

Wenn Sie ein Textfeld auswählen, zeigt die Registerkarte „Feld“ in der Palette „Objekt“ eine Reihe von Optionen zur Formatierung von Feldern an.
Typ
Legt den Objekttyp fest. Objekte sind die Bausteine für jedes Formular.
Beschriftung
Legt eine Beschriftung für das Objekt fest.
„Beschriftung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Beschriftung dynamisch aus.
Erscheinungsbild
Legt einen Stil für die Begrenzung des Füllbereiches fest:
    • Ohne
Das Feld wird ohne Begrenzung angezeigt.
    • Unterstrichen
Das Feld wird unterstrichen.
    • Ausgefülltes Rechteck
Das Feld wird in einem ausgefüllten Rechteck angezeigt.
    • Versenktes Rechteck
Erzeugt einen Schatten um das Feld, der das Feld dreidimensional wirken lässt.
    • Benutzerdefiniert
Zeigt das Dialogfeld „Angepasstes Erscheinungsbild“ an. Wählen Sie diese Option, wenn Sie ein eigenes Design für den Füllbereich entwerfen möchten.
Mehrere Zeilen zulassen
Bestimmt, ob mehrere Textzeilen zugelassen werden.
Feldformat
Legt fest, ob der Feldwert im Text- oder RTF-Format (Rich Text Format) formatiert wird.
    • Nur Text
Legt das Nur Text-Format fest.
    • Rich Text
Legt das Rich Text-Format fest. Wenn Sie das Feld auf die Anzeige von Rich Text-Formatierung einstellen und wollen, dass die Daten mit Rich Text-Formatierung gespeichert werden, müssen Sie auch die Option „Datenformat“ auf der Registerkarte „Bindung“ auf XHTML einstellen.
Länge begrenzen und Max. Zeichen
Begrenzt die Feldlänge auf die angegebene maximale Anzahl von Zeichen.
Länge auf sichtbaren Bereich beschränken
Legt die maximal zulässige Anzahl von Zeichen im Feld entsprechend der horizontalen Länge des Textfeldes fest.
Zeichenanzahl in Textfeld _ Zeichen
Aktiviert Begrenzungslinien im Feld.
Anzeigemuster
Legt das Muster für die Anzeige von formatierten Werten im Formular fest. Siehe So legen Sie ein Anzeigemuster fest.
Zur Entwurfs- und Laufzeit werden formatierte Werte im Feld in einem Format angezeigt, das dem Gebietsschema entspricht.
Bearbeitungsmuster
Legt das Muster für die Syntax der Benutzereingabe fest. Entspricht die Benutzereingabe dem Bearbeitungsmuster nicht, werden die Daten nicht akzeptiert, und der Feldwert wird nicht formatiert. Siehe So legen Sie ein Bearbeitungsmuster fest.
Zur Entwurfs- und Laufzeit werden formatierte Werte im Feld in einem Format angezeigt, das dem Gebietsschema entspricht.
Präsenz
Steuert, ob ein Objekt in einem PDF-Formular angezeigt wird, wenn der Benutzer das Formular in Acrobat oder Adobe Reader anzeigt oder wenn der Benutzer das Formular druckt:
    • Sichtbar
Das Objekt ist auf dem Bildschirm sowie im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein. „Sichtbar“ ist die standardmäßige Präsenzeinstellung für alle Objekte.
    • Sichtbar (nur Bildschirm)
Das Objekt ist nicht im gedruckten Formular, sondern nur auf dem Bildschirm sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Sichtbar (nur drucken)
Das Objekt ist nicht auf dem Bildschirm, sondern nur im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Unsichtbar
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt einen bestimmten Platz im Formularlayout ein.
    • Ausgeblendet (Aus Layout ausschließen)
Das Objekt ist weder auf dem Bildschirm noch im gedruckten Formular sichtbar und nimmt keinen Platz im Formularlayout ein.
Sprache
Gibt die Daten entsprechend dem festgelegten Gebietsschema für die Sprache und das Land wieder. Wählen Sie eine Sprache für das entsprechende Land in der Liste aus, oder geben Sie eine der beiden folgenden Optionen an:
    • Standardsprache
Verwendet die auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ angegebene Standardsprache.
    • Gebietsschema des Viewers
Verwendet das auf dem Computer des Benutzers festgelegte Gebietsschema.
Die Gebietsschemata in der Liste sind zunächst nach Sprache und dann nach Land geordnet.
Verwandte Themen
Textfelder – Übersicht


Eigenschaften von Textfeldern: Registerkarte „Wert“

Wenn Sie ein Textfeld erzeugen, steht Ihnen auf der Registerkarte „Wert“ eine Reihe von Optionen zur Verfügung, die Sie auf das Objekt anwenden können.
Typ
Ermöglicht Berechnungen und Eingabeaufforderungen zur Laufzeit:
    • Benutzereingabe - Optional
Der Benutzer kann selbst entscheiden, ob er Daten eingeben möchte.
    • Benutzereingabe - Empfohlen
Wenn der Benutzer keine Daten eingibt, wird eine eigene Meldung angezeigt (soweit sie im Feld „Meldung bei leerem Feld“ eingetragen worden ist).
    • Benutzereingabe - Erforderlich
Wenn der Benutzer keine Daten eingibt, wird eine eigene Meldung angezeigt (soweit sie im Feld „Meldung bei leerem Feld“ eingetragen worden ist).
    • Berechnet - Schreibgeschützt
Ein Datenwert wird über ein angehängtes Skript berechnet und angezeigt. Die Benutzer können den berechneten Wert nicht bearbeiten.
    • Berechnet - Benutzer darf überschreiben
Ein Datenwert wird über ein angehängtes Skript berechnet und angezeigt. Die Benutzer können den berechneten Wert bearbeiten, wenn im Berechnungsskript eine Verarbeitung der Benutzereingabe vorgesehen ist. Wenn ein Benutzer den berechneten Wert bearbeiten möchte, wird eine Meldung angezeigt, die im Feld „Meldung beim Überschreiben eines Werts“ festgelegt wurde.
    • Schreibgeschützt
Ein Datenwert wird zur Laufzeit zusammengeführt oder berechnet und angezeigt. Die Benutzer können den Wert nicht bearbeiten.
Standardwert
Legt einen Ausgangswert für das Feld fest. Der Wert wird entsprechend der Einstellung der Option „Anzeigemuster“ auf der Registerkarte „Feld“ formatiert. Er muss allerdings dem Gebietsschema entsprechen, das für das Feld gilt. Wenn die Daten gebunden sind und ein Datenmuster festgelegt wurde, muss der Wert mit dem auf der Registerkarte „Bindung“ festgelegten Datenmuster übereinstimmen. Siehe So legen Sie einen Standardwert fest.
Diese Option steht nur dann zur Verfügung, wenn die Option „Typ“ auf „Benutzereingabe - Optional“, „Benutzereingabe - Empfohlen“, „Benutzereingabe - Erforderlich“ oder „Schreibgeschützt“ gesetzt ist.
Meldung bei leerem Feld
Legt eine Meldung fest, mit der die Benutzer zur Eingabe eines empfohlenen oder erforderlichen Wertes aufgefordert werden. Siehe So fordern Sie Benutzer zur Dateneingabe auf.
Diese Option ist nur dann verfügbar, wenn die Option „Typ“ auf „Benutzereingabe - Empfohlen“ oder „Benutzereingabe - Erforderlich“ gesetzt ist.
Überprüfungsmuster
Legt ein Überprüfungsmuster für die Benutzereingabe fest. Das Muster muss mit der Syntax der Benutzereingabe übereinstimmen. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist.
Überprüfungsmuster-Meldung und Fehler
Legt eine eigene Meldung fest, die angezeigt wird, wenn ein Rohwert nicht dem Überprüfungsmuster entspricht. Standardmäßig wird in einem solchen Fall zur Laufzeit ein Programmierfehler generiert. Wenn stattdessen eine Warnmeldung generiert werden soll, deaktivieren Sie die Option „Fehler“. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist. „Überprüfungsmuster-Meldung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus.
Überprüfungsskript-Meldung und Fehler
Legt eine Meldung fest, die angezeigt wird, wenn ein angehängtes Überprüfungsskript einen inakzeptablen Wert ermittelt. Standardmäßig wird in einem solchen Fall zur Laufzeit ein Programmierfehler generiert. Wenn stattdessen eine Warnmeldung generiert werden soll, deaktivieren Sie die Option „Fehler“. Siehe So überprüfen Sie Benutzereingaben.
Diese Option steht nicht zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ oder „Schreibgeschützt“ gesetzt ist. „Überprüfungsskript-Meldung“ ist eine dynamische Eigenschaft. Dynamische Eigenschaften sind durch aktive Beschriftungen mit einer grünen Unterstreichung gekennzeichnet. Durch Klicken auf die Unterstreichung können Sie die Eigenschaft dynamisch an eine Datenquelle binden. Über den Befehl „Dynamische Eigenschaften anzeigen“ im Menü der Palette „Objekt“ lassen sich aktive Beschriftungen aktivieren bzw. deaktivieren. Siehe So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus.
Berechnungsskript
Der Wert wird durch ein Skript berechnet, das für das calculate-Ereignis des Objekts geschrieben wurde.
Diese Option steht nur zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ gesetzt ist.
Laufzeiteigenschaften
Legt eine der folgenden Laufzeiteigenschaften für das Objekt fest. Wenn Sie eine Laufzeiteigenschaft auswählen, wird der eigentliche Wert der Option bei der Anzeige des Formulars dynamisch eingefügt:
    • Aktuelle Seitenzahl
Fügt die aktuelle Seitenzahl des fertigen Formulars ein.
    • Anzahl der Seiten
Fügt die Gesamtanzahl der Seiten des fertigen Formulars ein.
    • Gebietsschema für Viewer
Fügt die Gebietsschema-Kennung des Gebietsschemas für die Anwendung ein, in der das Formular verarbeitet wird. Die Gebietsschema-Kennung für „Englisch (USA)“ ist beispielsweise „en_US“. en gibt dabei die Sprache an und US das Land.
    • Name des Anzeigeprogramms
Fügt den Namen der Anwendung ein, in der das Formular verarbeitet wird.
    • Version des Anzeigeprogramms
Fügt die Versionsnummer der Anwendung ein, in der das Formular verarbeitet wird.
    • Aktuelle Blattnummer
Fügt die Nummer des aktuellen Blattes in das numerische Feld ein.
    • Blattanzahl
Fügt die Gesamtanzahl der Blätter ein, aus denen das Formular besteht.
Diese Option steht nur zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Schreibgeschützt“ gesetzt ist.
Meldung beim Überschreiben eines Werts
Legt eine eigene Meldung fest, die den Benutzer darauf hinweist, dass er dabei ist, den Wert eines berechneten Feldes zu ändern. Die Meldung erscheint, wenn ein Benutzer den berechneten Wert ändert.
Diese Option steht nur zur Verfügung, wenn die Option „Typ“ auf „Berechnet - Benutzer darf überschreiben“ gesetzt ist.
Verwandte Themen
Textfelder – Übersicht


Eigenschaften von Textfeldern: Registerkarte „Bindung“

Wenn Sie ein Textfeld erstellen, zeigt die Registerkarte „Bindung“ Bindungsoptionen an, die Sie auf das Objekt anwenden können. Die Optionen, die sich nicht direkt auf die Erstellung einer Datenverbindung beziehen, gelten für die an eine Datenquelle gebundenen und die in einer Datei gespeicherten Daten, wenn das Objekt an keine Datenquelle gebunden ist.
Name
Legt den Namen des Textfeldes fest. Siehe So können Sie Objekte benennen und umbenennen.
Standardbindung
Legt die Standardmethode zum Binden von Daten fest:
    • Normal
Aktiviert die Optionen zum Zusammenführen und Speichern von Daten. Die Datenwerte werden den Adobe-Regeln zur Datenzusammenführung entsprechend zusammengeführt und gespeichert.
    • Global
Verbindet einen einzelnen Datenwert mit allen gleichnamigen Objekten (siehe So definieren Sie ein globales Feld).
    • Neue Datenverbindung
Startet den Assistenten „Neue Datenverbindung“. Weitere Informationen dazu, wie Sie eine Verbindung mit Hilfe des Assistenten definieren, finden Sie unter So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei oder So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank.
    • Ohne
Deaktiviert die Datenbindung. Da das Objekt keine zusammengeführten Daten erfasst oder anzeigt, bleiben alle Informationen, die zum Objekt gehören, beim Speichern oder Absenden der Formulardaten unberücksichtigt.
Datenmuster
Legt ein Muster für das Speichern und Abrufen gebundener Daten oder für das Speichern von Daten fest, wenn das Formular nicht an eine Datenquelle gebunden ist. Siehe So legen Sie ein Datenmuster fest.
Datenformat
Legt das Format der gespeicherten Daten fest. Siehe So legen Sie das Datenformat für Textfelder fest.
    • Normaler Text
UTF-8 kodierter Text mit Unterstützung für erweiterte Zeichen. Der Feldwert umfasst nur die Daten.
    • XHTML
Extensible HyperText Markup Language (XHTML), Version 1.0. Der in der Datenquelle oder Datendatei gespeicherte Feldwert umfasst XHTML-Formatierungsinformationen für den Text.
Import/Export-Bindungen
Legt eine Import/Export-Bindung für eine WSDL-Datenverbindung fest. Siehe So erstellen Sie eine Datenverbindung zu einer WSDL-Datei.
Verwandte Themen
Datenquellen
Textfelder – Übersicht
Textfeldmuster


Textfeldmuster

Zur Erstellung von Textmustern für Textfelder müssen die folgenden Symbole verwendet werden.
Komma (,), Bindestrich (-), Doppelpunkt (:), Schrägstrich (/), Punkt (.) und Leerzeichen ( ) werden als Literalwerte behandelt und können an einer beliebigen Stelle in einem Muster vorkommen. Wenn eine Wortfolge in ein Muster aufgenommen werden soll, schließen Sie sie in einfache Anführungszeichen (') ein. Beispielsweise kann'Your phone number is ('999')' 999-9999als Anzeigemuster angegeben werden.

Textsymbol

Beschreibung

Beispiel

A
Einzelner Buchstabe
Anzeigemuster: A9A 9A9
Eingabewert: K1S5K2
Formatierter Wert: K1S 5K2

X
Einzelnes Zeichen
Anzeigemuster: XXX XXX
Eingabewert: !1$5&2
Formatierter Wert: !1$ 5&2

O
Einzelnes alphanumerisches Zeichen
Anzeigemuster: OO OO OO
Eingabewert: 123ABC
Formatierter Wert: 12 3A BC

0
Einzelnes alphanumerisches Zeichen
Anzeigemuster: 00 00 00
Eingabewert: 123ABC
Formatierter Wert: 12 3A BC

9
Einzelne Ziffer
Anzeigemuster: 999-9999
Eingabewert: 9407000
Formatierter Wert: 940-7000
Die Zeichen O (großes „o“) und 0 (Null) wurden absichtlich gleichbedeutend definiert, da die beiden Zeichen oft verwechselt werden.
Reservierte Symbole
Die folgenden Symbole haben spezielle Bedeutungen und können nicht als Literalzeichen im Text verwendet werden.
?
Das Symbol entspricht einem beliebigen Zeichen. Wenn es für die Anzeige zusammengeführt wird, wandelt es sich zu einem Leerzeichen.

*
Das Symbol steht beim Absenden für 0 oder für UNICODE-Leerzeichen. Wenn es für die Anzeige zusammengeführt wird, wandelt es sich zu einem Leerzeichen.

+
Das Symbol steht beim Absenden für ein oder mehrere UNICODE-Leerzeichen. Wenn es für die Anzeige zusammengeführt wird, wandelt es sich zu einem Leerzeichen.
Verwandte Themen
Info über Feldmuster und Wertformatierung
Komplexe Feldmuster
Beispiele für Textmuster


Beispiele für Textmuster

Vordefinierte Muster
Die folgende Tabelle gibt die vordefinierten Textmuster an, die Sie in der Palette „Objekt“ auf der Registerkarte „Feld“ im Listenfeld „Anzeigemuster“ auswählen können, sowie das Ergebnis einer Formatierung von einigen Beispiel-Eingabewerten (Benutzereingaben oder gebundene Daten) mit dem Anzeigemuster.

Vordefiniertes Muster

Eingabewert

Formatierter Wert
A9A 9A9
K1S5K2
K1S 5K2
AA9A 9A9
KB1C3R2
KB1C 3R2
99999
12345
12345
'('999')' 999-9999
6135551212
(613) 555-1212
999-9999
5551212
555-1212
Text{999-9999}|Text{999-999-9999}
5551212
6135551212
555-1212
613-555-1212
Eigene Muster
Die folgende Tabelle zeigt einige selbst erstellte Anzeigemuster, die Sie für die Formatierung von Eingabewerten (Benutzereingaben oder gebundene Daten) verwenden können.

Eigenes Muster

Eingabewert

Formatierter Wert
'+1 ('999') '999-9999
6135551212
+1 (613) 555-1212
999.999.9999
6135551212
613.555.1212
Im nächsten Beispiel ist für eine Seriennummer die folgende Eingabe erforderlich: drei Buchstaben des Alphabets, danach vier Ziffern, danach ein einzelnes Zeichen beliebigen Typs. Ein gültiges Textmuster ist zum Beispiel:
AAA-9999-X
Die nachstehende Tabelle zeigt das Ergebnis einer Konvertierung von Beispielwerten (Benutzereingaben oder gebundene Werte) in Rohwerte durch ein Bearbeitungs- oder Datenmuster.

Eigenes Muster

Eingabewert

Rohwert
AAA-9999-X
ABC-1234-5
ABC-1234-D
123-4567-8
ABC12345
ABC1234D
„„
Im letzten Beispiel ergibt sich als Rohwert eine Leerzeichenfolge, da der Eingabewert 123-4567-8 nicht dem Muster entspricht.


Mit Datenquellen arbeiten

Datenquellen
Eine Verbindung zu einer Datenquelle herstellen
Felder an eine Datenquelle binden
Feldtypen
Formularobjekteigenschaften aus einer Datenquelle dynamisch ausfüllen


Zurück Weiter

LiveCycle Designer verwenden > Mit Datenquellen arbeiten > Datenquellen

Datenquellen

Mit Datenquellen arbeiten
Mit Datenverbindungen arbeiten


Mit Datenquellen arbeiten

Sie können Formularentwürfe erstellen, die über einfache Datenerfassung hinausgehen. Unter Verwendung von LiveCycle Designer können Sie Ihre Formularentwürfe in Unternehmensdatenbanken oder Webdienste integrieren, um Datenerfassungslösungen zu erstellen und zu verwalten, die von Daten von Firmendatenquellen gelesen, anhand dieser überprüft und zu diesen hinzugefügt werden. Dazu verbinden Sie Ihren Formularentwurf mit einer oder mehreren Datenquellen und binden die Daten an ein oder mehrere Felder in Ihrem Formularentwurf.
Sie können Felder mit diesen Datenquellen verbinden und an diese binden:
XML-Schema
XML-Schemas geben an, wie die Elemente in einem XML-Dokument formell beschrieben werden. Durch Verbindung mit einem XML-Schema können Sie die im Schema definierten Elemente und Attribute an die Felder im Formularentwurf binden. Sie können auch das XML-Daten-Stammelement auswählen, um es für die Verbindung zu verwenden.
OLEDB-Datenbanken
OLEDB ist ein Microsoft-Integrationsstandard, der auf niedriger Ebene eine Anwendungsprogramm-Schnittstelle (API) für Daten einer ganzen Organisation bietet. Durch Verbinden mit einer OLEDB-Datenbank können Sie Formularentwürfe erstellen, die als ein Dateneingabe- bzw. Erfassungswerkzeug für Firmendatenbankserver dienen. Sie können auch eine Datenbank verwenden, um zur Laufzeit Inhalt für Teile eines Formulars bereitzustellen.
XML-Musterdaten
Durch Verbinden mit einer XML-Datei können Sie Felder an die in der XML-Datei definierten Elemente und Attribute binden. Dies ist hilfreich, wenn Sie zwar kein XML-Schema, jedoch eine XML-Datei haben, die Sie als ein Muster verwenden können.
WSDL-Dateien (Web Service Definition Language)
In WSDL-Dateien werden Webdienste mit Hilfe von XML beschrieben. Durch Verbinden mit einer WSDL-Datei können Sie Felder im Formularentwurf an einen oder mehrere Webdienste binden.
Verwandte Themen
Palette „Datenansicht“
Info über das Herstellen einer Verbindung zu einer Datenquelle
Info über das Binden von Feldern an eine Datenquelle
Info über dynamische Eigenschaften


Mit Datenverbindungen arbeiten

Beim Erstellen interaktiver Formularentwürfe können Sie externe Datenquellen (Datenbanken, XML-Datendateien, XML-Schemas und Webdienste) verwenden, um Feldwerte zu definieren, Felder in einem Formular auszufüllen oder die in ein Formular eingegebenen Daten zu sammeln. Mit dem Datenverbindungswerkzeug von LiveCycle Designer können Sie Verbindungen zu Datenquellen definieren. Sie können dann Felder anbinden, die diese Arten von Daten von der Datenquelle akzeptieren. Wenn ein Feld die Verwendung von Skripten unterstützt, können Sie FormCalc- oder JavaScript-Lösungen schreiben, um Geschäftslogik auszudrücken und Berechnungen und Überprüfungen zu erstellen. Zusätzlich können Sie auch beim Herstellen einer Verbindung zu einer Datenbank von folgenden beiden benutzerdefinierten Objekten profitieren: von der Daten-Dropdown-Liste und dem Datenlistenfeld. Diese beiden Objekte finden Sie in der Palette „Bibliothek“ unter der Kategorie „Eigene“.
Welche Arten von Daten Sie wählen, richtet sich nach dem Formular und der geplanten Verteilung. Sie können eine oder mehrere Datenquellen verbinden und die Daten an ein oder mehrere Felder in Ihrem Formularentwurf binden.

Typ

Beschreibung
OLEDB-Datenbanken
Sie können eine oder mehrere Datenbanken mit einem Formular verbinden, um Daten zwischen dem Formular und der Datenbank auszutauschen. Sie können Felder mit Daten aus einer Datenbank füllen oder Daten, die im Formular erfasst wurden, in die Datenbank integrieren. Ein Datenaustausch ist für interaktive Formulare in Acrobat unter Verwendung clientseitiger Bindungen möglich. Weitere Informationen finden Sie unter So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank.
XML-Schema
Ein XML-Schema gibt an, wie Elemente in einem XML-Dokument formal zu beschreiben sind. Sie können ein XML-Schema mit einem Formular verbinden und spezielle Elemente und Attribute, die im Schema definiert sind, an Felder im Formular binden. Sie können dies verwenden, um Daten in und von Formularfeldern in einem Format zuzuordnen, das dem Schema entspricht. Weitere Informationen finden Sie unter So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei.
XML-Datendateien
Wenn Sie kein XML-Schema haben, können Sie eine XML-Datendatei mit einem Formular verbinden und Elemente und Attribute in der Datei an Felder im Formular binden. Die im Formular erfassten Daten entsprechen der XML-Datendatei. Sie können die Datendatei für die Zuordnung von Daten im erforderlichen Format in Formularfelder bzw. aus Formularfeldern verwenden. Weitere Informationen finden Sie unter So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei.
Webdienste (WSDL)
Webdienste bieten Funktionen und Daten für andere Anwendungen über das Internet unter Verwendung von Standards wie z. B. SOAP über HTTP. Der Webdienst kann einen Befehl empfangen und verarbeiten und die Ergebnisse in Ihr Formular zurückgeben. Sie können einen oder mehrere Webdienste in einem Formular verbinden. Weitere Informationen finden Sie unter So erstellen Sie eine Datenverbindung zu einer WSDL-Datei.
LiveCycle Designer bietet integrierte Werkzeuge für das Erstellen, Binden, Importieren und Exportieren von bzw. in Datenquellen. Formularverfasser, die weniger Erfahrung im Umgang mit Datenquellen haben, sollten allerdings bei der Implementierung der Datenverbindungen auf die Hilfe und Unterstützung von Datenbankadministratoren und anderem technischen Personal zurückgreifen.
Berücksichtigen Sie bei der Planung zur Einrichtung und Ausführung des für Ihr Formular benötigten Datenaustauschs folgende Punkte:
      •
      Ermitteln Sie die Datenquellen, die für die Erfassung der von Benutzern eingegebenen Daten sowie für den Import von Daten in Ihre Formularfelder verwendet werden.
      •
      Entscheiden Sie, ob Sie Feldbindung an ein XML-Schema oder eine Datendatei verwenden möchten, um die Struktur der Daten festzulegen.
      •
      Sammeln Sie Datenzuordnungsinformationen, einschließlich des Datentyps und der von der vorhandenen Datenquelle verwendeten Struktur.
In Acrobat ist es auf Grund der Sicherheitsanforderungen nicht möglich, eine ODBC-Verbindungszeichenfolge mit der Syntax Driver=; festzulegen. Daher benötigt das Clientsystem einen für die ODBC-Verbindung konfigurierten DSN. Wenn Sie externe Datenquellen in einem Formular verwenden, das auch in Adobe Reader verfügbar sein soll, müssen Sie außerdem mit Hilfe von LiveCycle Reader Extensions Verwendungsrechte für das Formular festlegen.
Verwandte Themen
Datenquellen
Info über das Herstellen einer Verbindung zu einer Datenquelle


Eine Verbindung zu einer Datenquelle herstellen

Info über das Herstellen einer Verbindung zu einer Datenquelle
So arbeiten Sie mit der Palette „Datenansicht“
So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei
So erstellen Sie eine Datenverbindung zu einer XML-Datendatei
So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank
So erstellen Sie eine Datenverbindung zu einer WSDL-Datei
So führen Sie die Verbindung zum Webdienst aus
So löschen Sie eine Datenverbindung
So ändern Sie eine Datenverbindung


Info über das Herstellen einer Verbindung zu einer Datenquelle

Das Verbinden eines Formularentwurfs mit einer Datenquelle ist der erste Schritt zur Bindung von Daten an Felder im Formularentwurf. Nachdem Sie eine oder mehrere Datenquellenverbindungen in einem Formularentwurf erstellt haben, wird in der Palette „Datenansicht“ eine Hierarchieansicht von jeder Datenquelle angezeigt. Die oberen Knoten in der Hierarchie stellen jede Datenverbindung dar und zeigen den Namen an, den Sie bei der Erstellung der Verbindung zuordnet haben.
Nachdem Sie die Datenverbindung erstellt haben, müssen Sie die Daten an die Felder im Formularentwurf binden.
Verwandte Themen
Felder an eine Datenquelle binden


So arbeiten Sie mit der Palette „Datenansicht“

      •
      Zum Anzeigen der Knotendetails wählen Sie im Palettenmenü die Option „Informationen einblenden“.
      •
      Zum Erweitern eines Knotens klicken Sie auf das Pluszeichen (+).
      •
      Zum Reduzieren eines Knotens klicken Sie auf das Minuszeichen (-).
      •
      Zum Anzeigen der Datenbeschreibung des Knotens (bis maximal 25 Zeichen) wählen Sie im Palettenmenü die Option „Datenbeschreibungen anzeigen“. Falls keine Beschriftung für den Knoten verfügbar ist, wird der Datenname angezeigt. Sie müssen mit einer Datenquelle verbunden sein, die Daten beschreibt.
      •
      Zum Anzeigen des Datennamens und der Beschreibung des Knotens wählen Sie im Palettenmenü die Option „Beides anzeigen“. Sie müssen mit einer Datenquelle verbunden sein, die Daten beschreibt.
Verwandte Themen
Palettenmenü „Datenansicht“
Info über das Binden von Feldern an eine Datenquelle


So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei

Sie können eine XML-Schemadefinition in einen Formularentwurf importieren und dann die Objekte im Formularentwurf an die Elemente und Attribute in der XML-Schemadefinition binden.
Wenn Sie ein XML-Schema importieren, das ein Schemaelement des Typs <xs:include> oder <xs:import> enthält, muss das Elementattribut „schemaLocation“ auf eine Datei im lokalen Dateisystem verweisen.
1.
Führen Sie einen der folgenden Schritte aus:
      •
      Wählen Sie „Datei“ > „Neue Datenverbindung“.
      •
      Wählen Sie ein Objekt auf der Seite aus, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und wählen Sie im Menü „Standardbindung“ die Option „Neue Datenverbindung“.
2.
Tragen Sie im Feld „Name der neuen Verbindung“ einen Namen für die Verbindung ein.
Der Name muss aus einem Wort bestehen und darf aus maximal 127 Zeichen bestehen. Das erste Zeichen eines benutzerdefinierten Namens muss ein Buchstabe oder ein Unterstrich (_) sein. Die restlichen Zeichen können Buchstaben, Ziffern, Bindestriche (-), Unterstriche (_) oder Punkte (.) sein.
3.
Wählen Sie „XML-Schema“ aus und klicken Sie auf „Weiter“.
4.
Führen Sie einen der folgenden Schritte aus:
      •
      Klicken Sie auf „Durchsuchen“ [image], suchen Sie die XML-Schema-Datei und wählen Sie diese aus.
      •
      Geben oder fügen Sie das URL-Verzeichnis der XML-Schemadatei in das Feld „XML-Schemadatei auswählen“ ein.
5.
Legen Sie eine oder mehrere der folgenden Optionen fest:
      •
      Wählen Sie im Menü „XML-Daten-Stammelementname verwenden“ das Stammdatenelement, das verwendet wird, um das Stammteilformular des Formularentwurfs zu benennen. Dieses Menü enthält globale Elementdeklarationen im XML-Schema.
      •
      (Optional) Wählen Sie „XML-Schema einbetten“ aus, um das XML-Schema als ein Paket in der XDP-Datei einzubetten.
      •
      (Optional) Wählen Sie „Eingangsdaten umformen“ aus und klicken Sie auf „Durchsuchen“ [image], um die XSLT-Datei zu suchen und auszuwählen, die verwendet wird, um Eingangsdaten für den Formularentwurf umzuformen.
      •
      (Optional) Wählen Sie „Ausgangsdaten umformen“ aus und klicken Sie auf „Durchsuchen“ [image], um die XSLT-Datei zu suchen und auszuwählen, die verwendet wird, um Ausgangsdaten für den Formularentwurf umzuformen.
6.
Klicken Sie auf „Fertig stellen“. Die Daten werden in der Palette „Datenansicht“ angezeigt.
Das at-Symbol (@) vor name in der Palette „Datenansicht“ zeigt an, dass dieser Knoten ein Attribut eines Optionsknotens ist, und #data zeigt den tatsächlichen Wert des Optionsknotens an.
Verwandte Themen
Info über das Binden von Feldern an eine Datenquelle
So erstellen Sie ein gebundenes Feld oder Teilformular


So erstellen Sie eine Datenverbindung zu einer XML-Datendatei

Wenn Sie kein XML-Schema haben, können Sie eine Datenverbindung zu einer XML-Datei erstellen, um diese als Beispiel für Ihre Daten zu verwenden.
1.
Führen Sie einen der folgenden Schritte aus:
      •
      Wählen Sie „Datei“ > „Neue Datenverbindung“.
      •
      Markieren Sie auf der Seite ein Objekt. Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und wählen Sie im Menü „Standardbindung“ die Option „Neue Datenverbindung“.
2.
Tragen Sie im Feld „Name der neuen Verbindung“ einen Namen für die Verbindung ein.
Der Name muss aus einem Wort bestehen und darf aus maximal 127 Zeichen bestehen. Das erste Zeichen eines benutzerdefinierten Namens muss ein Buchstabe oder Unterstrich (_) sein. Die restlichen Zeichen können Buchstaben, Ziffern, Bindestriche (-), Unterstriche (_) oder Punkte (.) sein.
3.
Wählen Sie „Muster-XML-Daten“ und klicken Sie auf „Weiter“.
4.
Klicken Sie auf „Durchsuchen“ [image], suchen Sie die XML-Datei und wählen Sie diese aus.
5.
Wählen Sie mindestens eine der folgenden Optionen aus:
      •
      (Optional) Wählen Sie „Eingangsdaten umformen“ aus und klicken Sie dann auf „Durchsuchen“ [image], um die XSLT-Datei zu suchen und auszuwählen, die verwendet wird, um Eingangsdaten für den Formularentwurf umzuformen.
      •
      (Optional) Wählen Sie „Ausgangsdaten umformen“ aus und klicken Sie dann auf „Durchsuchen“ [image], um die XSLT-Datei zu suchen und auszuwählen, die verwendet wird, um Ausgangsdaten für den Formularentwurf umzuformen.
6.
Klicken Sie auf „Fertig stellen“. Die Daten werden in der Palette „Datenansicht“ angezeigt.
Verwandte Themen
Info über das Binden von Feldern an eine Datenquelle
So erstellen Sie ein gebundenes Feld oder Teilformular


So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank

Vielleicht möchten Sie, dass Ihr Formular Zugriff auf Informationen in einer Datenbank hat. Beispielsweise können Sie Daten abrufen, um ein Formular auf der Basis eines Wertes aufzufüllen, wie z. B. eine Arbeitnehmer-ID, die der Benutzer beim Ausfüllen des Formulars eingibt. Wenn der Benutzer die ID-Nummer eingibt, löst diese eine Datenbankabfrage aus, um den entsprechenden Datensatz abzurufen und im Formular anzuzeigen.
Um Daten aus einer Datenbank anzuzeigen, einzufügen, zu aktualisieren oder zu löschen, stellen Sie eine Verbindung zu der Datenbank her und binden dann die Felder auf dem Formular an die entsprechenden Spalten in der Datenbanktabelle.
Sie können auch Skripten verwenden, um Datensätze einzufügen, zu aktualisieren und zu löschen, oder zur Durchführung der Nächster-/Voriger-Navigation für Datensätze in der Datenbank.
Wann eine Datenbank statt beispielsweise einer XML-Datendatei zu verwenden ist, bestimmt der Anwendungsentwickler. Sie können über mehrere für ein Formular konfigurierte Datenverbindungen verfügen (eine zu einer Datenbank, eine zu einer XML-Datei) und einzelne Felder an eine der Datenverbindungen binden.
OLEDB ist die einzige Datenbankverbindung, auf die Sie von LiveCycle Designer zugreifen können. Durch die Verwendung von „Microsoft OLEDB Provider for ODBC Drivers“ können Sie auf Datenbanken zugreifen, die anhand des ODBC-Datenquellennamens (DSN) erkannt werden. Sie können auch andere OLE-Treiber als „Microsoft OLEDB Provider for ODBC“ verwenden. Allerdings muss das Formular dann in Acrobat zertifiziert sein, bevor es zur Laufzeit funktioniert.
In Acrobat können Sie aus Sicherheitsgründen keine ODBC-Verbindungszeichenfolge unter Verwendung der Syntax Driver=; festlegen. Daher benötigt der Client-Computer eine konfigurierte DSN für ODBC-Verbindungen.
Wenn Sie externe Datenquellen in einem Formularentwurf verwenden, den Sie für die Verwendung mit Adobe Reader verfügbar machen möchten, müssen Sie mit LiveCycle Reader Extensions Verwendungsrechte für das Formular einrichten.
1.
Führen Sie einen der folgenden Schritte aus:
      •
      Wählen Sie „Datei“ > „Neue Datenverbindung“.
      •
      Markieren Sie auf der Seite ein Objekt. Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und wählen Sie im Menü „Standardbindung“ die Option „Neue Datenverbindung“.
2.
Tragen Sie im Feld „Name der neuen Verbindung“ einen Namen für die Verbindung ein.
Der Name muss aus einem Wort bestehen und darf aus maximal 127 Zeichen bestehen. Das erste Zeichen eines benutzerdefinierten Namens muss ein Buchstabe oder Unterstrich (_) sein. Die restlichen Zeichen können Buchstaben, Ziffern, Bindestriche (-), Unterstriche (_) oder Punkte (.) sein.
3.
Wählen Sie „OLEDB-Datenbank“ aus und klicken Sie auf „Weiter“.
4.
Richten Sie im Dialogfeld „OLEDB“ Ihre Datenbank-Verbindungszeichenfolge ein. Hilfe zu dieser Einrichtung finden Sie in der Dokumentation des Datenbankherstellers.
5.
Wählen Sie eine der folgenden Optionen aus und klicken Sie auf „Weiter“:
      •
      Wählen Sie die Option „Tabelle“ aus und wählen Sie dann eine Tabelle als Datensatzquelle aus. In der Liste sind alle Tabellen aufgeführt, die in der durch die Verbindungszeichenfolge identifizierten Datenbank zur Verfügung stehen.
      •
      Wählen Sie die Option „Gespeicherte Prozedur“ aus und wählen Sie dann die Datensatzquelle in der Liste aus. Die Liste wird mit allen in der Datenbank gespeicherten Prozeduren ausgefüllt.
      •
      Wählen Sie die Option „SQL-Abfrage“ aus und geben Sie die SQL-Abfragezeichenfolge ein.
6.
Geben Sie Ihren Benutzernamen und Ihr Kennwort in den entsprechenden Feldern ein und legen Sie die ADO-Datensatz-Optionen fest.
7.
Klicken Sie auf „Weiter“. LiveCycle Designer überprüft, ob die Verbindung zur Datenbank erfolgreich ist und fordert Sie zur Eingabe Ihrer Anmeldeinformationen auf, falls erforderlich.
8.
Klicken Sie auf „Fertig stellen“. Die Daten werden in der Palette „Datenansicht“ angezeigt.
Verwandte Themen
So bestimmt LiveCycle Designer den Feldtyp bei der Bindung von Daten


So erstellen Sie eine Datenverbindung zu einer WSDL-Datei

Ein Webdienst, wie in einem WSDL-Dokument (Web Service Definition Language) definiert, stellt eine Anzahl von Operationen dar. WSDL kann für jede Operation eine Eingangsmeldung, eine Ausgangsmeldung oder beides definieren. Eingangsmeldungen werden an den Server gesendet. Der Server kann dann mit einer Ausgangsmeldung antworten. Sie können Felder in einem Formularentwurf erstellen und an einen oder mehrere Webdienste binden.
Die WSDL-Datenverbindung unterscheidet sich von anderen Datenverbindungstypen. Eine Webdienst-Operation ähnelt einem Funktionsaufruf mit Eingangs- und/oder Ausgangsparametern. Ein bestimmtes Feld oder bestimmte Felder können die Quelle einer Eingangsmeldung und der Zielort der Ausgangsmeldung sein.
Unter Verwendung von LiveCycle Designer und einer WSDL-Datenverbindung können Sie folgende Aktionen ausführen:
      •
      Eine oder mehrere Operationen innerhalb eines oder mehrerer Webdienste binden.
      •
      Felder, Teilformulare sowie Ausschlussgruppen, die von der Ausführung einer Webdienst-Operation ausgeschlossen sind, an das Klick-Ereignis einer Schaltfläche anhängen.
      •
      Eine Webdienst-Operation von jedem Ereignis über ein Skript ausführen.
      •
      Skriptzugriff auf alle zurückgegebenen Elemente eines Webdienst ermöglichen, unabhängig davon, ob diese Elemente an Felder gebunden sind.
      •
      Die Kommunikation im Stil von SOAP 1.1 (SOAP-Bindungen und ein HTTP-Transport) verwenden.
      •
      Daten mit einem Webdienst unter Verwendung des Austauschformats „doc/literal“ austauschen.
      •
      Client-basierte Skripten mit Hilfe des Acrobat SOAP JavaScript-Objekts (das „RPC/encoded“ unterstützt) schreiben.
Folgende Funktionen werden nicht unterstützt:
      •
      Einige XML-Schemafunktionen
      •
      Protokolle wie beispielsweise SMTP, FTP usw. als das zugrunde liegende Transportprotokoll für SOAP
      •
      Elemente des Erweiterbarkeitstyps
      •
      Webdienst-Suchen mit Hilfe von UDDI
      •
      Remoteprozeduraufruf (RPC) verschlüsselter SOAP-Meldungen
      •
      Verwendung von HTTP POST- und GET WSDL-Bindungen
1.
Wählen Sie „Datei“ > „Neue Datenverbindung“.
2.
Tragen Sie im Feld „Name der neuen Verbindung“ einen Namen für die Verbindung ein.
Der Name muss aus einem Wort bestehen und darf aus maximal 127 Zeichen bestehen. Das erste Zeichen eines benutzerdefinierten Namens muss ein Buchstabe oder Unterstrich (_) sein. Die restlichen Zeichen können Buchstaben, Ziffern, Bindestriche (-), Unterstriche (_) oder Punkte (.) sein.
3.
Wählen Sie „WSDL-Datei“ aus und klicken Sie auf „Weiter“.
4.
Wenn die Datei auf Ihrem Computer gespeichert ist, klicken Sie auf „Durchsuchen“ [image], suchen die Datei und wählen sie aus. Andernfalls geben Sie die URL der WSDL-Datei im Feld „WSDL“ ein.
5.
Klicken Sie auf „Weiter“ und wählen Sie die Operation aus, die Sie aufrufen möchten.
Das Fenster auf der rechten Seite zeigt Details für die ausgewählte Operation an. Wenn die ausgewählte Operation nicht SOAP-verschlüsselt oder nicht doc-literal ist, wird in diesem Fenster eine Warnungsmeldung angezeigt und Sie können den Vorgang nicht fortsetzen.
6.
Klicken Sie auf „Fertig stellen“.
Verwandte Themen
So führen Sie die Verbindung zum Webdienst aus


So führen Sie die Verbindung zum Webdienst aus

Sie können die Verbindung zum Webdienst auf verschiedene Arten ausführen.
So führen Sie die Verbindung zum Webdienst über eine Schaltfläche aus
Für WSDL-Datenverbindungen enthält die Palette „Datenansicht“ einen Knoten, der eine Schaltfläche darstellt.
      *
      Ziehen Sie den Knoten, der eine Schaltfläche darstellt, auf den Formularentwurf. Mit dieser Schaltfläche wird die Verbindung aktiviert.
So führen Sie die Verbindung zum Webdienst über ein anderes Ereignis aus
Sie können die Verbindung zum Webdienst statt von einer Schaltfläche auch von einem anderen Ereignis ausführen. Beispielsweise können Sie einen Wert auf der Basis des Wertes in einer Liste, die ein Benutzer wählt, an den Service weiterreichen.
      *
      Geben Sie in das Ereignis, mit dem Sie den Webdienst auslösen möchten, folgendes Skript ein:
In JavaScript: xfa.connectionSet.MyWSDLDataConnection.execute(0);
In FormCalc: $connectionSet.MyWSDLDataConnection.execute(0)
In beiden Fällen ist der weitergegebene Parameter ein boolescher Wert. Wenn die Ergebnisse vom Webdienst zurückgegeben werden, zeigt dieser Wert an, ob die gesamte Daten-DOM mit dem Formular zusammengeführt werden sollte, oder ob die zurückgegebenen Werte die Werte im aktuellen Exemplar des Formulars ersetzen. Null (0) zeigt an, dass die Daten nicht neu zusammengeführt werden. Das heißt, es werden keine neuen Felder oder Teilformulare als Ergebnis dieser Ausführung direkt hinzugefügt oder gelöscht. Eins (1) zeigt an, dass alle Daten im Daten-DOM neu zusammengeführt werden.
So zeigen Sie die Verbindungsinformationen einer Schaltfläche an
1.
Markieren Sie auf der Seite eine Schaltfläche.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Ausführen“ und lesen Sie die Verbindungsinformationen unter „Verbindungsdaten“.


So löschen Sie eine Datenverbindung

Sie können eine Datenverbindung aus dem Formularentwurf löschen.
1.
Wählen Sie in der Palette „Datenansicht“ die zu löschende Datenverbindung aus.
2.
Wählen Sie im Palettenmenü die Option „Datenverbindung löschen“.
3.
Wählen Sie eine der folgenden Optionen:
      •
      Um mit der Datenbankverbindung auch die Bindungen zu löschen, wählen Sie die Option „Bindungen für gelöschte Datenverbindung entfernen“ aus.
      •
      Deaktivieren Sie die Option „Bindungen für gelöschte Datenverbindung entfernen“, um die Datenbankverbindung zu löschen, gleichzeitig aber die Datenbindungen zu erhalten. Die Bindungen sind Referenzen zu den Daten des Formularentwurfs und sind selbst bei Inaktivität der Datenverbindung noch gültig, sofern die Daten unverändert bleiben.
4.
Klicken Sie auf „Löschen“.


So ändern Sie eine Datenverbindung

Sie können die meisten Datenverbindungseigenschaften ändern, außer dem Datenbeschreibungstyp.
1.
Wählen Sie in der Palette „Datenansicht“ die zu ändernde Datenverbindung aus.
2.
Wählen Sie im Palettenmenü die Option „Verbindungseigenschaften“.
3.
Nehmen Sie die erforderlichen Änderungen vor. Klicken Sie auf „Weiter“, um durch die einzelnen Dialogfelder zu navigieren.
4.
Klicken Sie auf „Fertig stellen“.


Felder an eine Datenquelle binden

Info über das Binden von Feldern an eine Datenquelle
So erstellen Sie ein gebundenes Feld oder Teilformular
So binden Sie einen Knoten an ein vorhandenes Feld
So generieren Sie gebundene Felder in einem Teilformular
Identische Daten an mehreren Positionen anzeigen
So binden Sie mehrere Felder an einen Knoten
So verwenden Sie ein Skript zum Anzeigen von Daten in einem anderen Feld als dem, in das sie eingegeben wurden
So legen Sie Feldgenerierungsoptionen fest
So entfernen Sie eine Bindung
So aktualisieren Sie Datenverbindungen
So zeigen Sie eine Liste gebundener Felder an


Info über das Binden von Feldern an eine Datenquelle

Wenn Sie die Felder in einem Formularentwurf an eine Datenquelle binden, erstellen Sie eine Verknüpfung zwischen dem Formularentwurf und der Datenquelle, die es Ihnen ermöglicht, die mit dem Formularentwurf verknüpften Informationen zu erfassen, darzustellen, zu verschieben, zu verarbeiten, auszugeben und zu drucken.
Sind einige Formularfelder an eine Datenquelle gebunden, gehen Daten nicht gebundener Felder beim Speichern des Formulars in Acrobat verloren. Sollen einige Felder an eine Datenquelle gebunden werden, muss dies für alle zu speichernden Felder vorgenommen werden.
LiveCycle Designer ermöglicht es Ihnen, eine Client-basierte oder Server-basierte Bindung zu verwenden. Durch Client-basierte Bindung können Sie Daten unmittelbar ändern. Server-basierte Bindung erfordert, dass Sie Daten an den Server zurückgeben, um Änderungen an ihnen durchzuführen.
Für die Durchführung Client-basierter Bindung muss Acrobat oder Adobe Reader (mit einem Formular mit Verwendungsrechten) installiert sein. Für Server-seitige Datenbankbindung benötigen Sie LiveCycle Forms auf einem Microsoft-Server.
Sie können ein gebundenes Feld oder Teilformular auf eine der folgenden Arten erstellen:
Neue Formularobjekte aus der Palette „Datenansicht“ erstellen
Sie können einen Knoten oder einen Knoten mit untergeordneten Knoten aus der Palette „Datenansicht“ auf die Seite ziehen und automatisch ein gebundenes Feld oder mehrere Felder oder Teilformulare erstellen. Das Formularfeld oder das Teilformular und seine abhängigen Elemente werden an die Datenquelle gebunden. Zusätzlich werden Formularfeldeigenschaften automatisch gemäß den Eigenschaften der Dateibindung eingestellt. So entsprechen zum Beispiel Typ, Name und Objektbeschreibung sämtlich denen des Bindungsobjekts.
Knoten aus der Palette „Datenansicht“ mit einem vorhandenen Formularfeld verknüpfen
Sie können einen Knoten aus der Palette „Datenansicht“ auf ein vorhandenes Feld auf der Seite ziehen und so die beiden Elemente verbinden. Sie können auch die Feldeigenschaften des Formulars aktualisieren und so an die des Bindungsobjekts anpassen. Die Eigenschaften, die aktualisiert werden können, hängen von der Kombination von Formularobjekttyp und Bindungstyp ab. Weitere Informationen zu den Eigenschaften, die aktualisiert werden können, finden Sie unter Dialogfeld „Bindungseigenschaften“.
Bindungsknoten mit Hilfe der Registerkarte „Bindung“ in der Palette „Objekt“ festlegen
Wählen Sie auf der Seite ein Objekt und dann den Knoten aus, an den das Objekt der Palette „Objekt“ auf der Registerkarte „Bindung“ gebunden werden soll. Die Formularfeldeigenschaften können so aktualisiert werden, als ob Sie einen Knoten aus der Palette „Datenansicht“ auf ein vorhandenes Formularfeld ziehen würden. Weitere Informationen zu den Eigenschaften, die aktualisiert werden können, finden Sie unter Dialogfeld „Bindungseigenschaften“.
Mit LiveCycle Designer gebundene Felder in einem Teilformular automatisch generieren
Sie können neue gebundene Felder in einem Teilformular aus der Palette „Datenansicht“ generieren.
Verwandte Themen
So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank
So erstellen Sie eine Datenverbindung zu einer WSDL-Datei


So erstellen Sie ein gebundenes Feld oder Teilformular

1.
Wählen Sie eine der folgenden Methoden:
      •
      Um gebundene Felder aus allen Knoten in der Palette „Datenansicht“ zu erstellen, ziehen Sie den oberen Knoten einer Datenverbindung auf die Seite. LiveCycle Designer erstellt Teilformulare und Objekte, die an alle Knoten in der Hierarchie gebunden sind.
      •
      Um ein gebundenes Feld zu erstellen, ziehen Sie einen Knoten auf die Seite.
      •
      Um ein gebundenes Teilformular zu erstellen, ziehen Sie den Knoten mit untergeordneten Knoten auf die Seite.
2.
Positionieren Sie die Objekte und Teilformulare auf der Seite nach Ihren Anforderungen.
Verwandte Themen
So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank
So erstellen Sie eine Datenverbindung zu einer WSDL-Datei


So binden Sie einen Knoten an ein vorhandenes Feld

Sie können mit Hilfe der Palette „Datenansicht“ oder „Objekt“ einen Knoten an ein vorhandenes Feld binden.
So binden Sie mit der Palette „Datenansicht“ einen Knoten an ein vorhandenes Feld
1.
Wählen Sie in der Palette „Datenansicht“ den betreffenden Knoten aus und ziehen Sie ihn in das Feld auf der Seite.
2.
Im Dialogfeld „Bindungseigenschaften“ wählen Sie eine der folgenden Optionen aus:
      •
      Alle verwandten Eigenschaften aktualisieren
      •
      Nur folgende Eigenschaften aktualisieren
      •
      Keine verwandten Eigenschaften aktualisieren
3.
Klicken Sie auf „OK“. Ob Sie die Objekteigenschaften aktualisieren oder nicht: Das Formularobjekt ist jetzt an die Datenquelle gebunden.
So binden Sie mit der Palette „Objekt“ einen Knoten an ein vorhandenes Feld
1.
Wählen Sie auf der Seite das Objekt aus, das Sie an einen Knoten binden möchten.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und wählen Sie im Menü „Standardbindung“ den Knoten.
3.
Im Dialogfeld „Bindungseigenschaften“ wählen Sie eine der folgenden Optionen aus:
      •
      Alle verwandten Eigenschaften aktualisieren
      •
      Nur folgende Eigenschaften aktualisieren
      •
      Keine verwandten Eigenschaften aktualisieren
4.
Klicken Sie auf „OK“. Ob Sie die Objekteigenschaften aktualisieren oder nicht: Das Formularobjekt ist jetzt an die Datenquelle gebunden.
Verwandte Themen
So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank
So erstellen Sie eine Datenverbindung zu einer WSDL-Datei


So generieren Sie gebundene Felder in einem Teilformular

1.
Wählen Sie das Teilformular aus, in dem Sie die gebundenen Felder generieren möchten.
2.
Wählen Sie in der Palette „Datenansicht“ den Knoten aus, dessen Leaf-Knoten im Teilformular erstellt werden sollen.
3.
Wählen Sie im Palettenmenü „Felder generieren“. Die neuen Felder, die dem Knoten entsprechen, werden im Teilformular erstellt.
Verwandte Themen
So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank
So erstellen Sie eine Datenverbindung zu einer WSDL-Datei


Identische Daten an mehreren Positionen anzeigen

Mit den folgenden Methoden können Sie dieselben Daten an mehreren Positionen anzeigen:
      •
      Setzen Sie mehrere Felder auf die Einstellung für globale Felder, um dieselben interaktiv eingegebenen Daten anzuzeigen.
      •
      Binden Sie mehrere Felder an einen Knoten, um dieselben Daten aus einer Datenquelle in den Feldern anzuzeigen.
      •
      Verwenden Sie ein Skript zum Anzeigen von Daten in einem anderen Feld als dem, in das sie eingegeben wurden.
In der folgenden Tabelle werden globale Felder, die Bindung mehrerer Felder an einen Knoten und die Verwendung eines Skripts zum Anzeigen von Daten in einem anderen Feld als dem, in das sie eingegeben wurden, verglichen.

Vergleich

Globale Felder

Bindung

Skript
Ergebnis
LiveCycle Designer Derselbe Wert wird in allen Feldern mit demselben Namen angezeigt.
LiveCycle Designer Derselbe Wert wird in allen Feldern mit derselben Bindung angezeigt.
LiveCycle Designer Die in ein Feld eingegebenen Daten werden in einem anderen Feld angezeigt.
Name der Felder
Die Namen müssen identisch sein.
Die Namen müssen nicht identisch sein.
Die Namen müssen nicht identisch sein.
Laufzeiteigenschaften (z. B. aktuelle Seite, Seitenzahl und aktuelle Datums- und Zeitangaben)
Dem Feld können keine Laufzeiteigenschaften hinzugefügt werden.
Dem Feld können keine Laufzeiteigenschaften hinzugefügt werden.
Dem Feld können Laufzeiteigenschaften hinzugefügt werden.
Entfernung
Wenn Sie die globale Einstellung aus einem Feld entfernen, entfernt LiveCycle Designer diese Einstellung aus allen Feldern mit demselben Namen.
Wenn Sie eine Bindung aus einem Feld entfernen, behalten die anderen Felder die Bindung bei.
Nicht zutreffend
Bezug zu Knoten
Globale Felder können sich auf Knoten außerhalb des aktuellen Datensatzes beziehen.
Explizite Daten beziehen sich auf Knoten innerhalb des aktuellen Datensatzes.
Nicht zutreffend
Anwendungsbeispiel
Verwenden Sie diese Methode bei sich wiederholenden Formularinformationen, wie z. B. Kundenname oder -adresse. Benutzer geben die Informationen ein Mal ein und die Daten werden automatisch in die als globale Felder definierten Felder eingetragen.
Verwenden Sie diese Methode, wenn Sie einen Dateneintrag aus einer Datenquelle in mehreren Feldern anzeigen möchten.
Verwenden Sie diese Methode zum Kopieren eines Kontaktnamens auf Seite 1 und zum Anzeigen in einem Formularbrief auf Seite 2.
Dieses Diagramm zeigt an, wie sich das Definieren mehrerer Felder als globale Felder auswirkt. Name und Adresse werden auf Seite 2 ausgefüllt, nachdem der Benutzer diese Daten auf Seite 1 eingegeben hat.
Dieses Diagramm zeigt an, wie sich das Binden mehrerer Felder an einen Knoten auswirkt. Name und Adresse werden von der Datenquelle aus eingefügt.
Dieses Diagramm zeigt an, wie sich die Verwendung eines Skripts zum Anzeigen von Daten in einem anderen Feld als dem, in das sie eingegeben wurden, auswirkt. Der Kontaktname im Formularbrief ist identisch mit dem auf Seite 1 im Namensfeld eingegebenen Namen.
Verwandte Themen
So definieren Sie ein globales Feld
So binden Sie mehrere Felder an einen Knoten


So binden Sie mehrere Felder an einen Knoten

Mit den folgenden Methoden können Sie mehrere Felder an einen Knoten binden:
      •
      Weisen Sie bestehenden Formularfeldern in der Palette „Datenansicht“ durch Ziehen und Übergeben einen Knoten zu.
      •
      Geben Sie den Bindungsknoten auf der Registerkarte „Bindung“ der Palette „Objekt“ für bestehende Formularfelder an.
Sie sollten nur einen einzigen Dateneintrag an mehrere Felder binden. Binden Sie keine sich wiederholenden Daten an mehrere Felder.
1.
Wählen Sie in der Palette „Datenansicht“ den betreffenden Knoten aus und ziehen Sie ihn in das Feld auf der Seite.
2.
Im Dialogfeld „Bindungseigenschaften“ wählen Sie eine der folgenden Optionen aus:
      •
      Alle verwandten Eigenschaften aktualisieren
      •
      „Nur folgende Eigenschaften aktualisieren“ bei anschließender Auswahl der gewünschten Optionen
      •
      Keine verwandten Eigenschaften aktualisieren
3.
Klicken Sie auf „OK“. Ob Sie die Objekteigenschaften aktualisieren oder nicht: Das Formularobjekt ist jetzt an die Datenquelle gebunden.
4.
Wählen Sie den Knoten aus Schritt 1 aus und wiederholen Sie die Schritte 2 und 3 für weitere Felder, die Sie an denselben Knoten binden möchten.
Verwandte Themen
So definieren Sie ein globales Feld


Zurück Weiter

LiveCycle Designer verwenden > Mit Datenquellen arbeiten > Felder an eine Datenquelle binden > So verwenden Sie ein Skript zum Anzeigen von Daten in einem anderen Feld als dem, in das sie eingegeben wurden

So verwenden Sie ein Skript zum Anzeigen von Daten in einem anderen Feld als dem, in das sie eingegeben wurden

Verwenden Sie ein Skript zum Anzeigen von Daten in einem anderen Feld als dem, in das sie eingegeben wurden. Sie können dieses Skript auf bestimmte feldorientierte Ereignisse anwenden, die infolge von Benutzeraktionen ausgelöst werden.
So kann ein Benutzer in einem interaktiven Formular zur Eingabe des Abteilungsnamens aufgefordert werden. Der Abteilungsname soll dann auf den nachfolgenden Formularseiten erscheinen (bei einem mehrseitigen interaktiven Formular). Das Feld für den Abteilungsnamen ist an ein Datenfeld gebunden, in dem der Abteilungsname gespeichert wird. Zum Anzeigen des Abteilungsnamens auf anderen Seiten muss der Inhalt des Eingabefeldes auf den anderen Seiten erscheinen. Diese Felder bedürfen keiner Bearbeitung und können somit Teil eines anderen Feldes (z. B. eines schwebenden Feldes) sein. Verwenden Sie in diesem Fall ein Skript zum Kopieren des Abteilungsnamens in die anderen Felder.
1.
Wählen Sie das erste Feld aus.
2.
Falls der Skript-Editor noch nicht angezeigt wird, wählen Sie „Fenster“ > „Skript-Editor“.
3.
(Optional) Klicken Sie auf die Erweitern-Schaltfläche der Palette, bis diese die gewünschte Größe hat.
4.
Wählen Sie in der Liste „Einblenden“ ein feldorientiertes Ereignis aus.
Sie können in der Liste „Einblenden“ beispielsweise den Eintrag „Exit“ auswählen.
5.
Wählen Sie in der Liste „Sprache“ die Option „JavaScript“ und in der Liste „Ausführen am“ die Option „Client“ aus.
6.
Geben Sie im Feld „Skriptquelle“ das Skript ein:
Sie können beispielsweise folgendes Skript verwenden:
ContactName.rawValue = this.rawValue;
„ContactName“ (Kontaktname) ist der Name des zweiten Feldes auf der Registerkarte „Bindung“ der Palette „Objekt“.
7.
Klicken Sie auf „Änderungen zu Skriptquelle eingeben“, um das Skript in Ihr Formular einzufügen.
8.
Wählen Sie das zweite Feld aus.
9.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und wählen Sie dann in der Liste „Typ“ die Option „Berechnet - Schreibgeschützt“ aus.
Verwandte Themen
So binden Sie mehrere Felder an einen Knoten
So definieren Sie ein globales Feld
Berechnungen und Skripten


So legen Sie Feldgenerierungsoptionen fest

Sie können folgende Optionen festlegen, die beim Generieren eines Feldes oder einer Gruppe von Feldern angewendet werden:
      •
      Überprüfungsskripten für neue Felder generieren. Die generierten Überprüfungsskripten sind JavaScript-Skripten auf dem Feld. Beispielsweise kann ein Überprüfungsskript überprüfen, ob ein Feldwert zu der Liste der zulässigen Werte gehört.
      •
      Beschreibungsinformationen generieren.
      •
      Tabellenerstellung zulassen. Bestimmte Daten aus einer Datenquelle können in Tabellen angezeigt werden. Wenn Sie eine Verbindung zu einer Datenquelle herstellen, werden in der Palette „Datenansicht“ alle Elemente markiert, bei denen es sich um Tabellen handeln könnte. Darüber hinaus wird angezeigt, welche Elemente zu Zeilen werden, wenn LiveCycle Designer eine sich wiederholende Datengruppe findet.
1.
Wählen Sie im Palettenmenü „Datenansicht“ den Befehl „Optionen“.
2.
Deaktivieren Sie eine der folgenden Optionen:
      •
      Deaktivieren Sie die Option „Überprüfungsskripte generieren“, um die Generierung von Überprüfungsskripten zu deaktivieren.
      •
      Deaktivieren Sie die Option „Beschreibende Informationen generieren“, um Beschreibungsinformationen zu deaktivieren.
      •
      Tabellenerstellung zulassen
3.
Klicken Sie auf „OK“.
Verwandte Themen
So bestimmt LiveCycle Designer den Feldtyp bei der Bindung von Daten


So entfernen Sie eine Bindung

Sie können Bindungen aus Feldern und Teilformularen entfernen.
1.
Wählen Sie ein oder mehrere Objekte aus, von denen Sie die Bindung entfernen möchten.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Bindung“ und wählen Sie im Menü „Standardbindung“ die Option „Ohne“. Da das Objekt keine Daten erfassen oder anzeigen wird, werden keine mit dem Objekt verknüpften Informationen beim Speichern der Formulardaten als Ausgabe geschrieben.
Wenn Sie eine Bindung von einem Teilformular deaktivieren, wird das Teilformular nicht in Operationen zum Zusammenführen von Daten einbezogen, jedoch können seine Objekte (einschließlich aller verschachtelter Teilformulare) weiterhin Daten erfassen oder anzeigen.
Verwandte Themen
So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank
So erstellen Sie eine Datenverbindung zu einer WSDL-Datei


So aktualisieren Sie Datenverbindungen

Sie können alle Datenverbindungen im Formularentwurf aktualisieren. Dieser Befehl ist hilfreich, wenn Sie Ihre Dateien geändert haben und den Formularentwurf aktualisieren möchten.
      *
      Wählen Sie im Palettenmenü „Datenansicht“ den Befehl „Datenansicht aktualisieren“.
Verwandte Themen
So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank
So erstellen Sie eine Datenverbindung zu einer WSDL-Datei


So zeigen Sie eine Liste gebundener Felder an

Sie können eine Liste der folgenden Feldtypen generieren:
      •
      Felder, die eine normale Datenbindung haben.
      •
      Felder mit Datenbindung durch Referenz.
      •
      Felder mit einer globalen Bindung.
      •
      Felder ohne Datenbindung.
      •
      Ungebundener Datenverbindungsknoten
1.
Klicken Sie in der Palette „Bericht“ auf die Registerkarte „Bindungen“.
2.
Wählen Sie die entsprechende Option aus und führen Sie einen Menübefehl aus dem Menü „Bindungen“ aus:
      •
      Um eine Liste von Feldern mit normaler Datenbindung anzuzeigen, wählen Sie die Option „Felder mit normaler Datenbindung“ aus.
      •
      Um eine Liste von Feldern mit Datenbindung durch Referenz anzuzeigen, wählen Sie „Felder mit Datenbindung durch Referenz“ aus.
      •
      Um eine Liste von Feldern mit globaler Datenbindung anzuzeigen, wählen Sie die Option „Felder mit globaler Datenbindung“ aus.
      •
      Um eine Liste von Feldern ohne Datenbindung anzuzeigen, wählen Sie die Option „Felder ohne Datenbindung“ aus.
      •
      Um eine Liste von ungebundenen Feldern anzuzeigen, wählen Sie die Option „Ungebundene Datenverbindungsknoten“ aus.
Verwandte Themen
So bestimmt LiveCycle Designer den Feldtyp bei der Bindung von Daten


Feldtypen

So bestimmt LiveCycle Designer den Feldtyp bei der Bindung von Daten
Einfache Typen
Komplexe Typen
Rich-Text-Objekte
Bilder
Standardwerte/feste Werte
Anmerkungsinformationen
Namespaces
Überprüfung


So bestimmt LiveCycle Designer den Feldtyp bei der Bindung von Daten

Nachdem Sie eine Datenverbindung erstellt haben, können Sie Teilformulare und Felder erstellen, die allen oder einigen Daten entsprechen. Häufig existieren überflüssige Daten, die Sie nicht benötigen; aus diesem Grund ist die selektive Erstellung von Teilformularen und Feldern der automatischen Erstellung möglicherweise vorzuziehen. Ein weiterer Ansatz besteht darin, zuerst den Formularentwurf zu erstellen und dann mit Hilfe der Palette „Datenansicht“ spezielle Felder im Formularentwurf an spezielle Datenknoten in der Hierarchie zu binden.
LiveCycle Designer bestimmt, welche Felder zu erstellen sind, wenn Sie spezielle Felder aus einem XML-Schema, einer XML-Datei oder einer WSDL-Datei binden, oder wenn Sie von der Palette „Datenansicht“ auf der Basis von Elementtypen und Elementattributen Felder generieren. Beispielsweise wird dem statischen Bildobjekt im Formularentwurf ein Bild zugeordnet.
Wenn Sie einen Knoten aus der Palette „Datenansicht“ auf die Seite ziehen, um ein Feld oder Teilformular zu erstellen, wird der Name eines XML-Schema-Elements oder -Attributs als Name des generierten Feldes oder Teilformulars verwendet. Der Element- oder Attributname wird auch als anfängliche Beschriftung für das Feld verwendet. Der Bindungswert für das Feld wird verwendet, um das Feld an den Datenknoten zu binden, der durch die Element- oder Attributdeklaration im Schema beschrieben wird.
Unter „Verwandte Themen“ finden Sie Themen mit weiteren Informationen über die Art, wie LiveCycle Designer bestimmt, welches Feld zu erstellen ist, wenn Sie Felder aus einem XML-Schema, einer XML-Datei oder einer WSDL-Datei binden.
Verwandte Themen
So erstellen Sie ein gebundenes Feld oder Teilformular
So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank
So erstellen Sie eine Datenverbindung zu einer WSDL-Datei


Einfache Typen

XML-Schema-Elementdeklarationen können von einem einfachen oder von einem komplexen Typ sein. Elemente ohne Elementinhalt und ohne Attribute werden im XML-Schema mit einem einfachen Typ deklariert. Attributdeklarationen können von einem einfachen Typ sein. Im Allgemeinen werden Elemente mit einfachen Typen und Attributen Feldern in LiveCycle Designer zugeordnet. Der Typ des Feldes wird anhand des einfachen Typwertes ermittelt.
Eingebaute einfache Typen
Das XML-Schema definiert eine Anzahl eingebauter einfacher Typen.
Die folgenden Typen werden jedem Textfeldobjekt mit Nur-Text-Inhalt zugeordnet:
Zeichenfolge | normalizedString
token | Name
NCName | QName
language |
Die folgenden Typen werden dem numerischen Feldobjekt zugeordnet:
float | double
decimal | integer
long | int
short | byte
positiveInteger | nonPositiveInteger
negativeInteger | nonNegativeInteger
unsignedLong | unsignedInt
unsignedShort | unsignedByte
Die Datums- und Zeitzuordnungen werden in der folgenden Tabelle aufgelistet:

Datum und Uhrzeit

Objekttyp
Dauer
Textbearbeitungsfeld
dateTime
Datums-/Uhrzeitfeld. Der Kontrolltyp ist Datum und Zeit.
Datum
Datums-/Uhrzeitfeld. Der Kontrolltyp ist Datum.
Uhrzeit
Datums-/Uhrzeitfeld. Der Kontrolltyp ist Zeit.
gYear
Textfeld mit Picture-Klausel.
gYearMonth
Textfeld mit Picture-Klausel.
gMonth
Textfeld mit Picture-Klausel.
gMonthDay
Textfeld mit Picture-Klausel.
gDay
Textfeld mit Picture-Klausel.
Folgende Legacy-Typen werden dem Textfeldobjekt zugeordnet:
ID | IDREF
IDREFS | ENTITY
ENTITIES | NMTOKEN
NMTOKENS | NOTATION
Weitere Typen werden in der folgenden Tabelle zugeordnet:

Andere

Objekttyp
Boolescher Wert
Kontrollkästchen
hexBinary
Statisches Bild
base64Binary
Statisches Bild
anyURI
Textfeld
Beschränkte einfache Typen
Neue einfache Typen können von anderen einfachen Typen, die XML-Schema-Beschränkungen verwenden, abgeleitet werden. Dieser Abschnitt beschreibt, wie diese Beschränkungen Formularentwürfen zugeordnet werden können.
Aufzählungs-Facetten
Ein XML-Schema jedes Basistyps, das einen oder mehrere aufgezählte Werte deklariert, generiert eher ein Dropdown-Listenobjekt als das Standardfeld für den Basistyp der Deklaration, wie im folgenden Beispiel erläutert.
<xsd:element name=”Colors”>
    <xsd:complexType>
        <xsd:simpleContent>
            <xsd:extension base=”xsd:string”>
                <xsd:enumeration value=”red”/>
                <xsd:enumeration value=”green”/>
                <xsd:enumeration value=”blue”/>
            </xsd:extension>
        </xsd:simpleContent>
    </xsd:complexType>
<xsd:element>
Die aufgezählten Werte werden als Elemente für die Dropdown-Liste gespeichert.
Grenzen-, Längen- und Genauigkeitsfacetten
Wann immer es möglich ist, werden die Beschränkungsfacetten, die die Grenzen (minInclusive, minExclusive, maxInclusive und maxExclusive), die Länge (length, minLength und maxLength) und die Genauigkeit (totalDigits und fractionDigits) steuern, den Eigenschaften generierter Objekte zugeordnet. Andernfalls werden sie zum Generieren von Überprüfungsskripten verwendet. Hier sind zwei Beispiele:
      •
      Die Facette maxLength wird zum Festlegen der maxChars-Eigenschaften des Textwertes verwendet:

<field><value><text maxChars=”100”/></value></field>
      •
      Die Facette fractionDigits wird zum Festlegen der fracDigits-Eigenschaft des Dezimalwertes verwendet:

<field><value><decimal fracDigits=”3”/></value></field>
Listen- und Union-Typen
Listentypen ermöglichen die Definition von Typen, deren Werte aus durch Leerzeichen getrennte Listen mit einfachen Werten bestehen. Elemente und Attribute, die über Listentypen verfügen, werden Textfeldobjekten zugeordnet.
Union-Typen sind Typen, für die die Menge an zulässigen Werten aus einer Vereinigung aus zwei oder mehreren anderen Mengen von Werten bestehen. Die verschiedenen Mengen sind nicht notwendigerweise vom gleichen Basistyp. Im Allgemeinen werden Union-Typen Textfeldobjekten zugeordnet. Wenn jedoch alle Mengen in der Vereinigung vom gleichen Typ sind, erfolgt die Zuordnung genau wie für jeden anderen Typ, der einen dieser Mengen verwendet (das heißt, eine Vereinigung von zwei Mengen mit aufgezählten Werten generiert eine Dropdown-Liste mit allen Werten aus der Vereinigung).


Komplexe Typen

XML-Schema-Elementdeklarationen können von einem einfachen oder von einem komplexen Typ sein. Attributdeklarationen können von einem einfachen Typ sein. Im Allgemeinen werden Elemente mit einfachen Typen und Attributen Feldern in LiveCycle Designer zugeordnet. Elemente mit komplexen Typen enthalten andere Elemente und Attribute oder nur Attribute und werden normalerweise Teilformularen zugeordnet.
Komplexe Typen werden zum Definieren aller anderen Elemente verwendet. Komplexe Typen können Elementinhalt, einfachen Inhalt, gemischten Inhalt und leeren Inhalt definieren.
Jedes Element eines komplexen Typs kann Attribute deklarieren.
Ein Teilformular aus Elementinhalt in einer Datenquelle generieren
Ein Element, das nur Elementinhalt und optional Attribute besitzt, generiert ein Teilformular, wenn es in das Formulardesign gezogen wird.
Dieses Teilformular enthält Objekte für jedes Attribut, das für das Element und für die Objekte und Teilformulare für jedes Child-Element deklariert wurde.
Einfacher Inhalt
Einfacher Inhalt ist vorhanden, wenn deklariert wird, dass ein Element einfachen Inhalt (Textdaten) enthält und auch Attribute deklarieren kann. Wenn das Element keine Attribute deklariert, ist die Zuordnung gleich der für einfache Elemente.
Wenn Attribute deklariert werden, werden die Elemente einem Teilformular zugeordnet, das den Elementnamen trägt. Dieses Teilformular enthält dann ein Feld, das an das Element gebunden ist, sowie zusätzliche Felder für jedes Attribut. Der Name des an das Element gebundenen Feldes ist dann der Name des Elements mit der angehängten Zeichenfolge “_data” . Ein Beispiel dafür ist ein Element (zum Beispiel <phone>) mit numerischem Inhalt und einem Attribut mit dem Namen type:
<phone type=”work”>5554567</phone>
Dadurch wird ein Teilformular mit dem Namen phone generiert, das Objekte mit den Namen type und phone_data enthält. Das Objekt type wird an $data...phone.type gebunden, das Feld phone_data wird an $data...phone gebunden.
Gemischter Inhalt
Gemischter Inhalt liegt vor, wenn deklariert wird, dass ein Element eine Mischung aus Child-Elementen und Textinhalt enthält.
Leerer Inhalt
Komplexe Typen mit leerem Inhalt werden wie einfacher Inhalt behandelt, wobei das Objekt, das erstellt und an das Element gebunden wird, keinen Inhalt enthalten darf.
Vorkommen
XML-Schema-Attribute für Vorkommen (minOccurs und maxOccurs) in Elementdeklarationen, die Teilformulare generieren, werden den Wiederholungseigenschaften für das Teilformular zugeordnet.
Inhaltsmodelle
Wenn das Inhaltsmodell für die Child-Elemente eines Elements etwas anderes ist als eine Abfolge, versuchen die Zuordnungen mit Hilfe von subformSets die Auswahl und alle Gruppen nachzubilden.


Rich-Text-Objekte

Eine Elementdeklaration, die Inhalt aus einem XHTML-Schema definiert, wird eher einem Rich-Text-Feldobjekt als einem Nur-Text-Feldobjekt zugeordnet. Das heißt, das Objekt <field>, das im Formularentwurf erstellt wird, hat <value><exData contentType=”text/html”/></value>.
Es gibt drei Situationen, in denen ein Element als ein Element mit Rich-Text-Inhalt identifiziert wird:
      •
      Das Schema importiert das XHTML-Schema und deklariert ein Element, das ein einzelnes Child-Element enthält, das das xhtml-<body> -Element ist, wie im folgenden Beispiel gezeigt:

    <xsd:schema xmlns:xsd=”http://www.w3.ord/2001/XMLSchema”
            xmlns:xhtml=”http://www.w3.ord/1999/xhtml”>
    <xsd:import namespace=”http://www.w3.org/1999/xhtml”/>
    <xsd:element name=”RichTextField”>
        <xsd:complexType>
            <xsd:sequence>
                <xsd:element ref=”xhtml:body”/>
            </xsd:sequence>
        </xsd:complexType>
    </xsd:element>
      •
      Ein Schemadokument deklariert ein Element vom Typ „String“ mit einem Standardwert oder einem festen Wert, der mit folgendem Inhalt beginnt:

<body xmlns=”http://www.w3.org/1999/xhtml” ...
In diesem Fall wird ein Rich-Text-Objekt erstellt, bei dem der Wert auf den Standardwert oder den festen Wert eingestellt ist.
      •
      Eine Elementdeklaration umfasst ein Attribut von „xfa:contentType“ mit einem festen Wert von text/html, wie im folgenden Beispiel gezeigt:

    <xsd:schema xmlns:xsd=”http://www.w3.ord/2001/XMLSchema”
                    xmlns:xfa=”http://www.adobe.com/2003/xfa”>
    <xsd:import namespace=”http://www.adobe.com/2003/xfa”/>
    <xsd:element name=”RichTextField”>
        <xsd:complexType>
            <xsd:simpleContent>
                <xsd:extension base=”xsd:string”>
                    <xsd:attribute ref=”xfa:contentType" fixed="text/html”/>
                </xsd:extension>
            </xsd:simpleContent>
        </xsd:complexType>
    </xsd:element>
In diesem Beispiel wird das Attribut „xfa:contentType“ nicht zum Generieren eines Feldes verwendet wie im Fall des allgemeinen Attributs. Statt dessen wird es als eine Anweisung interpretiert, dass das generierte Feld ein Rich-Textfeld sein sollte. Hinsichtlich des Namespace-Bezeichners hat der Formularentwurf xmlns=”http://www.xfa.org/schema/xfa-template/2.1/ und die XDP-Datei hat xmlns:xdp=”http://ns.adobe.com/xdp/.


Bilder

Ein Bild wird dem statischen Objekt „Bildfeld“ im Formularentwurf zugeordnet. Die Attribute sind folgende:
xfa:contentType
xfa:href
xfa:transferEncoding
Dies ist ein Beispiel einer solchen Deklaration:
<xsd:schema xmlns:xsd=”http://www.w3.org/2001/XMLSchema”
        xmlns:xfa=”http://www.adobe.com/2003/xfa”>
<xsd:import namespace=”http//www.adobe.com/2003/xfa”>
<xsd:element name=”ImageField”>
    <xsd:complexType>
        <xsd:extension base=”xsd:hexBinary”>
            <xsd:attribute ref=”xfa:contentType” fixed=”image/jpg”/>
            <xsd:attribute ref=”xfa:transferEncoding” fixed=”base64”/>
        </xsd:extension>
    </xsd:simpleContent>
    </xsd:complexType>
</xsd:element>
In diesem Fall werden die Attribute nicht zum Generieren von Feldern im Formularentwurf verwendet. Sie werden verwendet, um zu erkennen, dass ein Element einem Bildfeld entspricht, und alle Standardwerte oder festen Werte für die Attribute werden auf dem generierten <image> -Element festgelegt.


Standardwerte/feste Werte

Attribut- und Elementdeklarationen von einem einfachen oder einem komplexen Typ und mit einfachem Inhalt können einen festen Wert oder einen Standardwert für das Element oder Attribut festlegen.
Jede Element- oder Attributdeklaration, die einen festen Wert oder einen Standardwert festlegt, generiert ein Feld, wobei der Anfangswert dieses Feldes auf den in der Deklaration angegebenen festen Wert oder Standardwert eingestellt wird.


Anmerkungsinformationen

Alle Anmerkungsinformationen, die im XML-Schema als ein Child-Element eines <xsd:element> oder <xsd:attribute> auftreten, werden dem Feld zugeordnet, das von der jeweiligen Element- oder Attributdeklaration als <desc>-Inhalt generiert wird.


Namespaces

Wenn „targetNamespace“ im XML-Schema definiert ist, werden diese Informationen beibehalten und zum Identifizieren von Datenelementen verwendet. Die Namespace- und die Namespace-Präfix-Information erscheinen nicht in der Palette „Datenansicht“ oder in den von der Datenverbindung generierten Objekten oder Teilformularen. Dennoch wird die Namespace-Information durch die vom Schema generierte dataDescription aufbewahrt, die für die Zuordnung zwischen dem Formularentwurf und den vom XML-Schema beschriebenen Daten verwendet wird.


Überprüfung

Wenn das XML-Schema Informationen über die zulässigen Werte eines Elements oder Attributs (und daher des entsprechenden Feldes in der Vorlage) liefert, umfasst das generierte Feld ein JavaScript-Überprüfungsskript, das überprüft, ob es sich bei dem Wert um einen durch die Schemadeklaration zugelassenen Wert handelt. Solche Informationen können durch den Datentyp des Elements oder Attributs sowie durch die auf den Basistyp angewendeten Beschränkungsfacetten bereitgestellt werden. Betrachten Sie folgendes Beispiel:
<xsd:element name=”Number”>
    <xsd:simpleType>
        <xsd:restriction base=”xsd:integer”>
            <xsd:minInclusive value=”4”/>
            <xsd:maxInclusive value=”9”/>
        </xsd:restriction>
    </xsd:simpleType>
</xsd:element>
Die Zuordnung resultiert in einem numerischen Feld mit dem Namen „Zahl“, das ein Überprüfungsskript enthält, welches überprüft, ob ein Wert eine Ganzzahl zwischen 4 und 9 ist.
Viele der durch das XML-Schema gelieferten Beschränkungsfacetten liefern Informationen, die zum Generieren eines Überprüfungsskripts verwendet werden können. Diese Informationen werden zum Generieren von Überprüfungsskripten verwendet, wenn die Informationen nicht direkt einer Eigenschaft zugeordnet werden können; zum Beispiel die Zuordnung der Facette „maxLength“ eines Zeichenfolgetyps zu <text maxChars=„„>.
Numerische Typenskripten
Alle numerischen Typen im XML-Schema werden einem einzigen numerischen Feld zugeordnet. Jedoch werden die durch einen numerischen Typ des XML-Schemas zusätzlich auferlegten Beschränkungen durch das Generieren von Überprüfungsskripten beibehalten, um sicherzustellen, dass sich ein Zahlenwert im zulässigen Bereich für den ursprünglichen XML-Schematyp befindet. Ein „unsigned byte“-Typ im XML-Schema generiert ein numerisches Feld mit einem Skript, um zu überprüfen, ob der Wert ein Byte-Wert ohne Vorzeichen ist; das generierte Skript wird also wie folgt lauten:
this.rawValue >= 0 && this.rawValue <= 255;
Skripten zum Überprüfen des angemessenen Bereichs werden für folgende Werte generiert:
integer | positive integer
negative integer | non-positive integer
non-negative integer | long, int
short | byte
unsigned long | unsigned int
unsigned short | unsigned byte-Datentypen
Einschluss-/Ausschluss-Skripten
Wenn ein numerischer Typ Min- oder Max-Einschluss- und/oder -Ausschlusswerte festlegt, wird ein Skript generiert, das überprüft, ob der eingegebene Wert innerhalb des durch diese Beschränkungsfacetten definierten Bereichs liegt. Für ein Feld, das bereits über ein Skript zur Überprüfung des numerischen Bereichs verfügt, wie in Numerische Typenskripten definiert, überprüft das Skript den Bereich gemäß dem am meisten beschränkenden Datentypbereich oder gemäß dem Einschluss-/Ausschlussbereich.
length-, minLength- und maxLength-Skripten
Ein String-Typ des XML-Schemas kann eine length-Beschränkungsfacette oder eine minLength- und/oder eine maxLength-Beschränkungsfacette festlegen. Wenn der Schemaknoten einem Textfeld zugeordnet wird, werden die für length- und minLength-Beschränkungsfacetten festgelegten Werte zum Generieren eines Überprüfungsskripts verwendet, das überprüft, ob die Textfeldlänge der durch length oder zumindest durch minLength festgelegte Wert ist.
Beachten Sie, dass jeder maxLength-Facettenwert für das Textfeld als maxChars zugeordnet wird.
Wenn ein String-Datentyp einer Popup-Liste zugeordnet wird (wegen der aufgezählten Werte) und length- oder min/maxLength-Werte im Überprüfungsskript dazu führen, dass der in der Liste ausgewählte Wert eine Länge besitzt, die gemäß den Facetten length, minLength und maxLength gültig ist.
totalDigits/fractionDigits-Skripten
Die Facette totalDigits legt die maximale Anzahl von Ziffern fest, die für einen Dezimal- oder jeden Ganzzahltyp verwendet werden kann (das heißt für die Datentypen „decimal“, „integer“, „positive integer“, „negative integer“, „non-positive integer“, „non-negative integer“, „long, int“, „short“, „byte“, „unsigned long“, „unsigned int“, „unsigned short“ und „unsigned byte“). Die fractionDigits-Facette ist nur für den Datentyp „decimal“ anwendbar und legt die maximal verwendbare Anzahl von Bruchziffern fest.
Wenn totalDigits oder fractionDigits für ein Element oder Attribut festgelegt werden, das einem numerischen Feld zugeordnet wird, wird ein Überprüfungsskript generiert, um zu überprüfen, ob die Gesamtanzahl der Ziffern und/oder die Gesamtanzahl der Bruchziffern gemäß den Beschränkungsfacetten zulässig ist.


Formularobjekteigenschaften aus einer Datenquelle dynamisch ausfüllen

Info über dynamische Eigenschaften
So legen Sie dynamische Eigenschaften fest
So füllen Sie eine Dropdown-Liste oder ein Listenfeld dynamisch aus
So füllen Sie eine Dropdown-Liste oder ein Listenfeld über eine OLEDB-Datenverbindung dynamisch aus
So füllen Sie eine Beschriftung dynamisch aus
So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus
So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus
So füllen Sie eine QuickInfo dynamisch aus
So füllen Sie Bildschirmlesehilfen-Text dynamisch aus
So füllen Sie nach dem Ausfüllen des ersten Feldes ein zweites Feld dynamisch aus
So bearbeiten Sie die dynamische Datenbindung
So füllen Sie Formularobjekteigenschaften durch Ziehen und Übergeben dynamisch aus
So entfernen Sie die dynamische Datenbindung


Info über dynamische Eigenschaften

Dynamische Eigenschaften sind Formularobjekteigenschaften, denen Werte aus einer Datenquelle zugewiesen sind und die zur Laufzeit aktualisiert werden. So ist es beispielsweise möglich, eine Dropdown-Liste mit einer in der Datenquelle gespeicherten Liste mit Ländernamen auszufüllen.
Die folgenden Eigenschaften von Formularobjekten sind dynamisch; sie können an Werte aus einer Datenquelle gebunden werden:
      •
      Listenelemente in einer Dropdown-Liste oder einem Listenfeld
      •
      Beschriftung
      •
      Überprüfungsmuster-Meldung
      •
      Überprüfungsskript-Meldung
      •
      QuickInfo
      •
      Bildschirmlesehilfen-Text
Durch dynamische Eigenschaften erhalten Sie die Möglichkeit, die Eigenschaften der Formularobjekte außerhalb des Formularentwurfs zu ändern und auf eine Datenquelle zurückzugreifen. Dies kann bei der Entwicklung und Wartung sehr nützlich sein.
Darüber hinaus kann eine Datenquelle für verschiedene Formularentwürfe verwendet werden. So ist es zum Beispiel möglich, eine lange Liste mit Ländernamen in einer Datendatei zu speichern und diese dann mit einer Vielzahl von Formularen zu verknüpfen. Sie können mit vielfältigen Datenquellen arbeiten, von einfachen XML-Dateien bis hin zu komplexen Datenbanken.
Um zu erkennen, für welche Formularobjekteigenschaften dynamische Eigenschaften festgelegt werden können, gibt es in LiveCycle Designer aktive Beschriftungen. Aktive Beschriftungen können im Dialogfeld unter „Extras“ > „Optionen“ > „Datenbindung“ aktiviert und deaktiviert werden. Auch die Option „Dynamische Eigenschaften anzeigen“ befindet sich in diesem Dialogfeld. Als Beispiel sehen Sie hier die aktive Beschriftung für eine Dropdown-Liste jeweils vor und nach der dynamischen Bindung an eine Datenquelle.
In der Palette „Datenansicht“ zeigt das Symbol [image] an, dass der Knoten dynamisch an ein Objekt gebunden ist.
Wenn ein Knoten sowohl an eine dynamische Eigenschaft als auch an ein Feld gebunden ist, wird das Standardsymbol [image] angezeigt.
Wenn Sie Formularobjekteigenschaften aus einer Datenquelle dynamisch ausfüllen möchten, müssen Sie zunächst die Formularobjekteigenschaften an die Datendatei binden, indem Sie einen Verweis auf die Datendatei mit den gewünschten Daten erstellen.
Sie können die Formularobjekteigenschaften manuell an die Datendatei binden, wenn Sie die erwartete Datendateistruktur kennen. Sie benötigen dann keine Datenverbindung.
In der folgenden Tabelle sind die Objekte mit den zugehörigen aktiven Beschriftungen aufgeführt.

Aktive Beschriftung/Objekt

Listenelemente

Elementwerte festlegen

Beschriftung

Überprüfungsmuster-Meldung

Überprüfungsskript-Meldung

QuickInfo

Benutzerdef. Bildschirmlesehilfe-Text
Barcodes
J
J
J
J
Schaltfläche
J
J
J
Kontrollkästchen
J
J
J
J
Datums-/Uhrzeitfeld
J
J
J
J
J
Dezimalfeld
J
J
J
J
J
Dokumentunterschriftsfeld
J
J
J
Dropdown-Liste
J
J
J
J
J
J
J
E-Mail-Senden-Schaltfläche
J
J
J
HTTP-Senden-Schaltfläche
J
J
J
Bild
J
J
Bildfeld
J
J
J
Listenfeld
J
J
J
J
J
J
J
Numerisches Feld
J
J
J
J
J
Kennwortfeld
J
J
J
J
J
Drucken-Schaltfläche
J
J
J
Optionsfeld
J
J
J
Text
J
J
Textfeld
J
J
J
J
J
Verwandte Themen
So legen Sie dynamische Eigenschaften fest


So legen Sie dynamische Eigenschaften fest

Damit Sie erkennen können, welche Formularobjekteigenschaften dynamisch sind, müssen Sie zunächst aktive Beschriftungen aktivieren.
Aktive Beschriftungen zeigen an, welche Eigenschaften dynamisch sein können. Aktive Beschriftungen werden grün und unterstrichen dargestellt. Indem Sie auf eine Eigenschaft klicken, können Sie sie dynamisch an eine Datenquelle binden. Sie können die Standardfarbe für aktive Beschriftungen festlegen.
Als Beispiel sehen Sie hier die aktive Beschriftung für eine Dropdown-Liste.
Dynamische Eigenschaften sind standardmäßig deaktiviert.
So aktivieren und deaktivieren Sie aktive Beschriftungen
      *
      Führen Sie einen der folgenden Schritte aus:
      •
      Wählen Sie im Menü der Palette „Objekt“ die Option „Dynamische Eigenschaften anzeigen“.
      •
      Wählen Sie „Extras“ > „Optionen“ und wählen Sie links im Fenster den Eintrag „Datenbindung“ aus. Aktivieren Sie die Option „Dynamische Eigenschaften anzeigen“ und klicken Sie auf „OK“.
Wenn Sie aktive Beschriftungen deaktivieren, bleiben alle Formularobjekteigenschaften, die bereits dynamisch an eine Datenquelle gebunden sind, gebunden und aktiv.
So legen Sie die Standardfarbe für aktive Beschriftungen fest
1.
Wählen Sie „Extras“ > „Optionen“ und wählen Sie links im Fenster den Eintrag „Datenbindung“ aus.
2.
Aktivieren Sie die Option „Benutzerdefinierte Beschriftungsfarbe verwenden“.
3.
Wählen Sie mit der Farbauswahl eine Farbe aus.
4.
Klicken Sie auf „OK“.
Verwandte Themen
Info über dynamische Eigenschaften


So füllen Sie eine Dropdown-Liste oder ein Listenfeld dynamisch aus

Sie können eine Dropdown-Liste oder ein Listenfeld mit Werten aus einer Datenquelle dynamisch ausfüllen.
Wenn Sie einen vordefinierten, unveränderlichen Satz möglicher Werte haben, können Sie eine Dropdown-Liste oder ein Listenfeld im Verlauf des Formularentwurfs ausfüllen. Siehe So legen Sie die Liste der Optionen für Dropdown-Listen oder Listenfelder fest. Mit einem Satz veränderlicher Werte in einer Datenquelle können Sie eine Dropdown-Liste oder ein Listenfeld während der Laufzeit dynamisch ausfüllen. Wenn Sie eine lange Liste mit Werten haben, profitieren Sie beim Speichern der Liste in einer Datenquelle von mehr Flexibilität für Ihr Formular.
Sie können beispielsweise eine Dropdown-Liste mit den Namen von Ländern aus der Liste in einer Datenquelle ausfüllen. Ein anderes Beispiel: Sie können ein Listenfeld mit französischen Produktnamen ausfüllen, aber die deutschen Datenwerte an die Datenquelle übermitteln.
Das Schema, zu dem Sie eine Verbindung herstellen, könnte beispielsweise die folgende Definition für eine Liste enthalten:
<form>
   <lists>
      <item uiname="item1" token="value1"/>
      <item uiname="item2" token="value2"/>
   </lists>
</form>
Die Datendatei, zu der Sie einen Verweis erstellen, könnte die folgende Definition für eine Liste enthalten:
<form>
   <lists>
      <item uiname="MasterCard" token="MC"/>
      <item uiname="Visa" token="VS"/>
      <item uiname="Eurocard" token="EC"/>
      <item uiname="Special Card" token="SC"/>
   </lists>
</form>
Wenn Sie in diesem Beispiel die Datendatei mit dem Formularentwurf zusammenführen, sehen Sie MasterCard als eine der Optionen in der Liste. Bei Übermittlung des Formulars wird jedoch das Token MC an die Datenquelle gesendet.
Wenn Sie mit einer OLEDB-Datenverbindung arbeiten, können Sie das Daten-Dropdown-Listenobjekt oder das Datenlistenfeldobjekt von der Kategorie „Eigene“ der Palette „Bibliothek“ verwenden, um eine Dropdown-Liste oder ein Listenfeld mit Daten aus einer Tabellenspalte auszufüllen. Siehe So füllen Sie eine Dropdown-Liste oder ein Listenfeld über eine OLEDB-Datenverbindung dynamisch aus.
Bevor Sie diese Aufgabe ausführen, müssen Sie Folgendes sicherstellen:
      •
      Vergewissern Sie sich, dass aktive Beschriftungen aktiviert sind. Siehe So legen Sie dynamische Eigenschaften fest.
      •
      Vergewissern Sie sich, dass eine Verbindung zu der Datenquelle besteht, an deren Daten Formularobjekteigenschaften gebunden werden. Siehe Info über das Herstellen einer Verbindung zu einer Datenquelle.
      •
      Vergewissern Sie sich, dass ein Verweis auf eine Datendatei mit definierten Daten für die Formularobjekteigenschaft vorhanden ist, um das Formular mit einer Beispieldatendatei zu testen. Siehe So testen Sie ein Formular mit Musterdaten.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie eine Dropdown-Liste oder ein Listenfeld auf den Formularentwurf.
Fügen Sie beispielsweise eine Dropdown-Liste ein.
2.
(Optional) Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und geben Sie im Feld „Beschriftung“ eine Beschriftung für das Objekt ein.
Geben Sie beispielsweise Credit Card ein.
3.
Führen Sie einen der folgenden Schritte aus:
      •
      Klicken Sie in der Palette „Objekt“ auf der Registerkarte „Feld“ auf die aktive Beschriftung „Listenelemente“.
      •
      Klicken Sie in der Palette „Objekt“ auf der Registerkarte „Bindung“ auf die aktive Beschriftung „Elementwerte festlegen“.
Um die Arbeit zu vereinfachen, wird sowohl mit der aktiven Beschriftung „Listenelemente“ als auch mit der aktiven Beschriftung „Elementwerte festlegen“ dasselbe Dialogfeld „Dynamische Eigenschaften“ aufgerufen.
4.
Wählen Sie die Datenverbindung aus.
Falls noch keine Verbindung zu einer Datenquelle besteht, wird in diesem Listenfeld lediglich der Eintrag „Standarddatenbindung“ angezeigt.
5.
Klicken Sie auf das Dreieck neben dem Feld „Elemente“ und wählen Sie eine Bindung aus.
Die ausgewählte Bindung sollte ein sich wiederholender Datenwert oder eine sich wiederholende Gruppe sein, damit die Dropdown-Liste bzw. das Listenfeld nicht nur ein Element enthält.
Wählen Sie beispielsweise „lists“ > „item“ aus.
Im Feld „Elemente“ wird die folgende Zeichenfolge angezeigt:
$record.lists.item[*]
Sie können diese Zeichenfolge alternativ auch direkt in das Feld „Elemente“ eingeben.
Bei OLEDB-Datenverbindungen steht das Feld „Elemente“ nicht zur Verfügung. Verwenden Sie die Felder „Elementtext“ und „Elementwert“, um die Datenbasisspalten zum Ausfüllen der Liste auszuwählen.
6.
Damit zur Laufzeit eine benutzerfreundliche Beschriftung angezeigt wird, klicken Sie auf das Dreieck neben dem Feld „Elementtext“ und wählen Sie eine Bindung aus.
Wählen Sie beispielsweise „@uiname“ aus, wenn „MasterCard“ angezeigt werden soll.
Die Datendatei, zu der Sie einen Verweis erstellen, könnte einen sich wiederholenden Datenwert enthalten:
<form>
   <pymt>
      <cc type="MC">MasterCard</cc>
      <cc type="VS">Visa</cc>
   </pymt>
</form>
Wenn Sie „#data“ auswählen, wird in der Dropdown-Liste MasterCard angezeigt.
7.
(Optional) Wenn Sie in der Datenquelle einen anderen Wert als die Bezeichnung „Elementtext“ speichern möchten, klicken Sie auf das Dreieck neben dem Feld „Elementwert“ und wählen Sie eine Bindung aus.
Wählen Sie beispielsweise „@token“ aus, wenn in der Datendatei „MC“ gespeichert werden soll.
Die Datendatei, zu der Sie einen Verweis erstellen, könnte einen sich wiederholenden Datenwert enthalten:
<form>
   <pymt>
      <cc type="MC">MasterCard</cc>
      <cc type="VS">Visa</cc>
   </pymt>
</form>
Wenn Sie „#data“ auswählen, wird in der Dropdown-Liste MC angezeigt.
8.
Klicken Sie auf „OK“.
Wenn eine Bindung festgelegt ist, wird ein kleines Verknüpfungssymbol mit der aktiven Beschriftung angezeigt.
9.
Zeigen Sie auf der Registerkarte „PDF-Vorschau“ eine Vorschau des Formulars an.
Verwandte Themen
Info über dynamische Eigenschaften
So legen Sie dynamische Eigenschaften fest


Zurück Weiter

LiveCycle Designer verwenden > Mit Datenquellen arbeiten > Formularobjekteigenschaften aus einer Datenquelle dynamisch ausfüllen > So füllen Sie eine Dropdown-Liste oder ein Listenfeld über eine OLEDB-Datenverbindung dynamisch aus

So füllen Sie eine Dropdown-Liste oder ein Listenfeld über eine OLEDB-Datenverbindung dynamisch aus

In der Kategorie „Eigene“ der Palette „Bibliothek“ stehen zwei benutzerdefinierte Objekte zur Verfügung, die Sie zum Ausfüllen von zwei Spalten mit Daten von einer OLEDB-Datenverbindung verwenden können. Sowohl das Daten-Dropdown-Listenobjekt als auch das Datenlistenfeldobjekt füllen zwei Spalten mit Daten aus einer OLEDB-Datenverbindung aus.
Dies ist eine skriptbasierte Alternative. Mit dynamischen Eigenschaften können Sie dasselbe Ziel erreichen. Siehe So füllen Sie eine Dropdown-Liste oder ein Listenfeld dynamisch aus.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Eigene“ und ziehen Sie das entsprechende Listenobjekt auf die Seite:
      •
      Um eine Dropdown-Liste zu erstellen, ziehen Sie das Daten-Dropdown-Listenobjekt.
      •
      Um ein Listenfeld zu erstellen, ziehen Sie das Datenlistenfeldobjekt.
2.
Wählen Sie das Objekt aus.
3.
Wählen Sie „Fenster“ > „Skript-Editor“.
4.
Ersetzen Sie in sDataConnectionName = “<value>” den Wert („value“) durch den Namen der Datenverbindung.
5.
Ersetzen Sie in sColHiddenValue = “<value>” den Wert („value“) durch den Namen des verborgenen Werts.
6.
Ersetzen Sie in sColDisplayText = “<value>” den Wert („value“) durch den Namen der Anzeigetextspalte.
Verwandte Themen
Info über dynamische Eigenschaften
So legen Sie dynamische Eigenschaften fest
So erstellen Sie ein gebundenes Feld oder Teilformular
So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank
So erstellen Sie eine Datenverbindung zu einer WSDL-Datei


So füllen Sie eine Beschriftung dynamisch aus

Sie können eine Beschriftung mit Werten aus einer Datenquelle dynamisch ausfüllen.
Sie haben beispielsweise die Möglichkeit, eine Beschriftung mit einem Produktnamen in französischer Sprache auszufüllen. Das Schema, zu dem Sie eine Verbindung herstellen, könnte die folgende Definition für eine Beschriftung enthalten:
<form>
   <caption product=”ProductName1”></caption>
</form>
Die Datendatei, zu der Sie einen Verweis erstellen, könnte die folgende Definition für eine Beschriftung enthalten:
<form>
   <caption product=”Schreibtischlampe”></caption>
</form>
Wenn Sie die Datendatei mit dem Formularentwurf zusammenführen, wird für das Produkt die Beschriftung Schreibtischlampe angezeigt.
Eine weitere Möglichkeit wäre die Bereitstellung des Produktnamens in einer anderen Sprache. Die Datendatei, zu der Sie einen Verweis erstellen, könnte die folgende Definition für eine Beschriftung enthalten:
<form>
   <caption product=”Lampe de Bureau”></caption>
</form>
Wenn Sie die Datendatei mit dem Formularentwurf zusammenführen, wird für das Produkt die Beschriftung Lampe de Bureau angezeigt.
Wenn Sie in Ihrer Datendatei Nicht-ASCII-Zeichen (wie Akzentzeichen oder die deutschen Umlaute) verwenden möchten, achten Sie darauf, dass die Datei entsprechend kodiert ist und die Kodierung in der XML-Verarbeitungsanweisung richtig identifiziert wird. Beispiel:
<?xml version="1.0" encoding="UTF-8"?>
Bevor Sie diese Aufgabe ausführen, müssen Sie Folgendes sicherstellen:
      •
      Vergewissern Sie sich, dass aktive Beschriftungen aktiviert sind. Siehe So legen Sie dynamische Eigenschaften fest.
      •
      Vergewissern Sie sich, dass eine Verbindung zu der Datenquelle besteht, an deren Daten Formularobjekteigenschaften gebunden werden. Siehe Info über das Herstellen einer Verbindung zu einer Datenquelle.
      •
      Vergewissern Sie sich, dass ein Verweis auf eine Datendatei mit definierten Daten für die Formularobjekteigenschaft vorhanden ist, um das Formular mit einer Beispieldatendatei zu testen. Siehe So testen Sie ein Formular mit Musterdaten.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie ein Objekt auf den Formularentwurf.
Fügen Sie beispielsweise ein Textfeldobjekt ein.
2.
(Optional) Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und geben Sie im Feld „Beschriftung“ eine Beschriftung für das Objekt ein.
Geben Sie beispielsweise Product ein.
3.
Klicken Sie auf die aktive Beschriftung „Beschriftung“.
4.
Wählen Sie die Datenverbindung aus.
Falls noch keine Verbindung zu einer Datenquelle besteht, wird in diesem Listenfeld lediglich der Eintrag „Standarddatenbindung“ angezeigt.
5.
Klicken Sie auf das Dreieck neben dem Feld „Bindung“ und wählen Sie eine Bindung aus.
Wählen Sie beispielsweise „caption“ > „@product“ aus.
6.
Klicken Sie auf „OK“.
7.
Zeigen Sie auf der Registerkarte „PDF-Vorschau“ eine Vorschau des Formulars an.
Verwandte Themen
Info über dynamische Eigenschaften
So legen Sie dynamische Eigenschaften fest


So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus

Sie können die Überprüfungsmuster-Meldung auch dynamisch mit einem Wert aus einer Datenquelle ausfüllen. Dadurch können Sie sicherstellen, dass Benutzer den richtigen Wert in das Feld eingeben.
Sie können beispielsweise eine eigene Fehlermeldung anzeigen, wenn Benutzer das falsche Muster in ein Feld einfügen.
Das Schema, zu dem Sie eine Verbindung herstellen, könnte die folgende Definition für ein Überprüfungsmuster enthalten:
<form>
   <validationPattern dp_patternMessage="message1"/>
</form>
Die Datendatei, zu der Sie einen Verweis erstellen, könnte die folgende Definition für ein Überprüfungsmuster enthalten:
<form>
   <validationPattern dp_patternMessage="DP-Muster - Mellung: Das Muster für die Bestellnummer lautet: A9A9A9"/>
</form>
Wenn Sie die Datendatei mit dem Formularentwurf zusammenführen und in das Feld für die Bestellnummer eine Nummer eingeben, die nicht dem erwarteten Muster entspricht, wird ein Dialogfeld mit einer Fehlermeldung angezeigt.
Eine weitere Möglichkeit wäre die Einrichtung eigener Fehlermeldungen für Muster in einer anderen Sprache. Die Datendatei, zu der Sie einen Verweis erstellen, könnte die folgende Definition für die Musterüberprüfung enthalten:
<form>
   <validationPattern dp_patternMessage="Le numéro de commande doit suivre le modèle suivant : A9A9A9"/>
</form>
Wenn Sie die Datendatei mit dem Formularentwurf zusammenführen und in das Feld für die Bestellnummer eine Nummer eingeben, die nicht dem erwarteten Muster entspricht, wird ein Dialogfeld mit einer Fehlermeldung in französischer Sprache angezeigt.
Wenn Sie in Ihrer Datendatei Nicht-ASCII-Zeichen (wie Akzentzeichen oder die deutschen Umlaute) verwenden möchten, achten Sie darauf, dass die Datei entsprechend kodiert ist und die Kodierung in der XML-Verarbeitungsanweisung richtig identifiziert wird. Beispiel:
<?xml version="1.0" encoding="UTF-8"?>
Bevor Sie diese Aufgabe ausführen, müssen Sie Folgendes sicherstellen:
      •
      Vergewissern Sie sich, dass aktive Beschriftungen aktiviert sind. Siehe So legen Sie dynamische Eigenschaften fest.
      •
      Vergewissern Sie sich, dass eine Verbindung zu der Datenquelle besteht, an deren Daten Formularobjekteigenschaften gebunden werden. Siehe Info über das Herstellen einer Verbindung zu einer Datenquelle.
      •
      Vergewissern Sie sich, dass ein Verweis auf eine Datendatei mit definierten Daten für die Formularobjekteigenschaft vorhanden ist, um das Formular mit einer Beispieldatendatei zu testen. Siehe So testen Sie ein Formular mit Musterdaten.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie ein Objekt auf den Formularentwurf.
Fügen Sie beispielsweise ein Textfeldobjekt ein.
2.
(Optional) Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und geben Sie im Feld „Beschriftung“ eine Beschriftung für das Objekt ein.
Geben Sie beispielsweise Order Number ein.
3.
Klicken Sie auf die Registerkarte „Wert“ und geben Sie im Feld „Überprüfungsmuster“ ein Muster ein.
Geben Sie beispielsweise A9A9A9 ein.
4.
Klicken Sie auf die aktive Beschriftung „Überprüfungsmuster-Meldung“.
5.
Wählen Sie die Datenverbindung aus.
Falls noch keine Verbindung zu einer Datenquelle besteht, wird in diesem Listenfeld lediglich der Eintrag „Standarddatenbindung“ angezeigt.
6.
Klicken Sie auf das Dreieck neben dem Feld „Bindung“ und wählen Sie eine Bindung aus.
Wählen Sie beispielsweise „validation“ > „@dp_patternMessage“ aus.
Im Feld „Bindung“ wird die folgende Zeichenfolge angezeigt:
$record.validation.dp_patternMessage
Sie können diese Zeichenfolge alternativ auch direkt in das Feld „Elemente“ eingeben.
7.
Klicken Sie auf „OK“.
8.
Zeigen Sie die Fehlermeldung auf der Registerkarte „PDF-Vorschau“ an.
Geben Sie dazu auf der Registerkarte „PDF-Vorschau“ beispielsweise eine Bestellnummer ein, die nicht dem Muster entspricht.
Verwandte Themen
Info über dynamische Eigenschaften
So legen Sie dynamische Eigenschaften fest


So füllen Sie eine Überprüfungsskript-Meldung dynamisch aus

Sie können die Überprüfungsskript-Meldung auch dynamisch mit einem Wert aus einer Datenquelle ausfüllen. Dadurch können Sie sicherstellen, dass Benutzer den richtigen Wert in das Feld eingeben.
Sie können beispielsweise eine eigene Fehlermeldung anzeigen, wenn Benutzer etwas in ein Feld eingeben, das nicht mit dem zugehörigen Skript übereinstimmt. So kann an ein numerisches Feld, etwa mit der Bezeichnung „Menge“, ein Skript angehängt sein, in dem festgelegt ist, dass die Zahl in diesem Feld nicht größer als sein darf als 100. Gibt der Benutzer eine Zahl über 100 ein, wird eine eigene Fehlermeldung angezeigt.
Das Schema, zu dem Sie eine Verbindung herstellen, könnte die folgende Definition für ein Überprüfungsskript enthalten:
<form>
   <validationScript dp_scriptMessage="message1"/>
</form>
Die Datendatei, zu der Sie einen Verweis erstellen, könnte die folgende Definition für die Skriptüberprüfung enthalten:
<form>
   <validationScript dp_scriptMessage="DP-Sriptmeldung - Die Menge muss kleiner oder gleich 100 sein."/>
</form>
Wenn Sie die Datendatei mit dem Formularentwurf zusammenführen und in das Feld für die Menge eine Zahl eingeben, die größer ist als 100, wird ein Dialogfeld mit einer Fehlermeldung angezeigt.
Eine weitere Möglichkeit wäre die Einrichtung eigener Fehlermeldungen zu einem Skript in einer anderen Sprache. Die Datendatei, zu der Sie einen Verweis erstellen, könnte die folgende Definition für die Skriptüberprüfung enthalten:
<form>
   <validationScript dp_scriptMessage="Entrez un nombre inférieur ou égal à 100."/>
</form>
Wenn Sie die Datendatei mit dem Formularentwurf zusammenführen und in das Feld für die Menge eine Zahl eingeben, die größer ist als 100, wird ein Dialogfeld mit einer Fehlermeldung in französischer Sprache angezeigt.
Wenn Sie in Ihrer Datendatei Nicht-ASCII-Zeichen (wie Akzentzeichen oder die deutschen Umlaute) verwenden möchten, achten Sie darauf, dass die Datei entsprechend kodiert ist und die Kodierung in der XML-Verarbeitungsanweisung richtig identifiziert wird. Beispiel:
<?xml version="1.0" encoding="UTF-8"?>
Bevor Sie diese Aufgabe ausführen, müssen Sie Folgendes sicherstellen:
      •
      Vergewissern Sie sich, dass aktive Beschriftungen aktiviert sind. Siehe So legen Sie dynamische Eigenschaften fest.
      •
      Vergewissern Sie sich, dass eine Verbindung zu der Datenquelle besteht, an deren Daten Formularobjekteigenschaften gebunden werden. Siehe Info über das Herstellen einer Verbindung zu einer Datenquelle.
      •
      Vergewissern Sie sich, dass ein Verweis auf eine Datendatei mit definierten Daten für die Formularobjekteigenschaft vorhanden ist, um das Formular mit einer Beispieldatendatei zu testen. Siehe So testen Sie ein Formular mit Musterdaten.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie ein Objekt auf den Formularentwurf.
Fügen Sie beispielsweise ein Objekt „Numerisches Feld“ ein.
2.
(Optional) Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und geben Sie im Feld „Beschriftung“ eine Beschriftung für das Objekt ein.
Geben Sie beispielsweise Menge ein.
3.
Wählen Sie in der Liste „Einblenden“ des Skript-Editors den Eintrag „validate“ aus.
4.
Wählen Sie in der Liste „Sprache“ des Skript-Editors eine Sprache aus.
Sie können in der Liste „Sprache“ beispielsweise den Eintrag „JavaScript“ auswählen.
5.
Geben Sie ein Skript für das Objekt ein.
Geben Sie für das Feld „Menge“ beispielsweise dieses Skript ein:
this.rawValue <= 100
6.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und anschließend auf die aktive Beschriftung „Überprüfungsskript-Meldung“.
7.
Wählen Sie die Datenverbindung aus.
Falls noch keine Verbindung zu einer Datenquelle besteht, wird in diesem Listenfeld lediglich der Eintrag „Standarddatenbindung“ angezeigt.
8.
Klicken Sie auf das Dreieck neben dem Feld „Bindung“ und wählen Sie eine Bindung aus.
Wählen Sie beispielsweise „validation“ > „@dp_scriptMessage“ aus.
Im Feld „Bindung“ wird die folgende Zeichenfolge angezeigt:
$record.validation.dp_scriptMessage
Sie können diese Zeichenfolge alternativ auch direkt in das Feld „Elemente“ eingeben.
9.
Klicken Sie auf „OK“.
10.
Zeigen Sie die Fehlermeldung auf der Registerkarte „PDF-Vorschau“ an.
Geben Sie dazu auf der Registerkarte „PDF-Vorschau“ beispielsweise eine Menge ein, die größer ist als 100.
Verwandte Themen
Info über dynamische Eigenschaften
So legen Sie dynamische Eigenschaften fest


So füllen Sie eine QuickInfo dynamisch aus

Sie können eine QuickInfo mit einem Wert aus einer Datenquelle dynamisch ausfüllen. Sie haben beispielsweise die Möglichkeit, eine eigene QuickInfo für ein Objekt in französischer Sprache anzuzeigen.
Das Schema, zu dem Sie eine Verbindung herstellen, könnte die folgende Definition für eine QuickInfo enthalten:
<form>
   <tooltip dp_tt="tooltip1"/>
</form>
Die Datendatei, zu der Sie einen Verweis erstellen, könnte die folgende Definition für eine QuickInfo enthalten:
<form>
   <tooltip dp_tt="Quantité - Entrez un nombre inférieur ou égal à 100."/>
</form>
Wenn Sie die Datendatei mit dem Formularentwurf zusammenführen und den Zeiger über dem Feld für die Menge positionieren, wird die folgende QuickInfo angezeigt:
Bevor Sie diese Aufgabe ausführen, müssen Sie Folgendes sicherstellen:
      •
      Vergewissern Sie sich, dass aktive Beschriftungen aktiviert sind. Siehe So legen Sie dynamische Eigenschaften fest.
      •
      Vergewissern Sie sich, dass eine Verbindung zu der Datenquelle besteht, an deren Daten Formularobjekteigenschaften gebunden werden. Siehe Info über das Herstellen einer Verbindung zu einer Datenquelle.
      •
      Vergewissern Sie sich, dass ein Verweis auf eine Datendatei mit definierten Daten für die Formularobjekteigenschaft vorhanden ist, um das Formular mit einer Beispieldatendatei zu testen. Siehe So testen Sie ein Formular mit Musterdaten.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie ein Objekt auf den Formularentwurf.
Fügen Sie beispielsweise ein Textfeldobjekt ein.
2.
(Optional) Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und geben Sie im Feld „Beschriftung“ eine Beschriftung für das Objekt ein.
Geben Sie beispielsweise Quantité ein.
3.
Klicken Sie in der Palette „/Ein-/Ausgabehilfe“ auf die aktive Beschriftung „QuickInfo“.
4.
Wählen Sie die Datenverbindung aus.
Falls noch keine Verbindung zu einer Datenquelle besteht, wird in diesem Listenfeld lediglich der Eintrag „Standarddatenbindung“ angezeigt.
5.
Klicken Sie auf das Dreieck neben dem Feld „Bindung“ und wählen Sie eine Bindung aus.
Wählen Sie beispielsweise „tooltip“ > „@dp_tt“ aus.
Im Feld „Bindung“ wird die folgende Zeichenfolge angezeigt:
$record.tooltip.dp_tt
Sie können diese Zeichenfolge alternativ auch direkt in das Feld „Elemente“ eingeben.
6.
Klicken Sie auf „OK“.
7.
Zeigen Sie auf der Registerkarte „PDF-Vorschau“ eine Vorschau des Formulars an.
Positionieren Sie auf der Registerkarte „PDF-Vorschau“ beispielsweise den Zeiger über dem Feld für die Menge, um die eigene QuickInfo zu sehen.
Verwandte Themen
Info über dynamische Eigenschaften
So legen Sie dynamische Eigenschaften fest


So füllen Sie Bildschirmlesehilfen-Text dynamisch aus

Sie können Bildschirmlesehilfen-Text mit Zeichenfolgen aus einer Datenquelle dynamisch ausfüllen. Sie haben beispielsweise die Möglichkeit, benutzerdefinierten Bildschirmlesehilfen-Text für ein Objekt in französischer Sprache auszugeben.
Das Schema, zu dem Sie eine Verbindung herstellen, könnte die folgende Definition für benutzerdefinierten Bildschirmlesehilfen-Text enthalten:
<form>
   <csr dp_csr="csr1"/>
</form>
Die Datendatei, zu der Sie einen Verweis erstellen, könnte die folgende Definition für benutzerdefinierten Bildschirmlesehilfen-Text enthalten:
<form>
   <csr dp_csr="The 7-digit customer identification field."/>
</form>
Wenn Sie die Datendatei mit dem Formularentwurf zusammenführen und die Bildschirmlesehilfe starten, wird zunächst die Art des Feldes vorgelesen und anschließend der Text „The 7-digit customer identification field“ (Feld für die siebenstellige Kundenkennung).
Bevor Sie diese Aufgabe ausführen, müssen Sie Folgendes sicherstellen:
      •
      Vergewissern Sie sich, dass aktive Beschriftungen aktiviert sind. Siehe So legen Sie dynamische Eigenschaften fest.
      •
      Vergewissern Sie sich, dass eine Verbindung zu der Datenquelle besteht, an deren Daten Formularobjekteigenschaften gebunden werden. Siehe Info über das Herstellen einer Verbindung zu einer Datenquelle.
      •
      Vergewissern Sie sich, dass ein Verweis auf eine Datendatei mit definierten Daten für die Formularobjekteigenschaft vorhanden ist, um das Formular mit einer Beispieldatendatei zu testen. Siehe So testen Sie ein Formular mit Musterdaten.
      •
      Vergewissern Sie sich, dass in Adobe Acrobat im Dialogfeld „Grundeinstellungen“ (aufzurufen über das Menü „Bearbeiten“) unter „Lesen“ die Option „Formularfelder lesen“ aktiviert wurde.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie ein Objekt auf den Formularentwurf.
Fügen Sie beispielsweise ein Objekt „Numerisches Feld“ ein.
2.
(Optional) Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und geben Sie im Feld „Beschriftung“ eine Beschriftung für das Objekt ein.
Geben Sie beispielsweise Kunden-ID ein.
3.
Klicken Sie in der Palette „Ein-/Ausgabehilfe“ auf die aktive Beschriftung „Benutzerdef. Bildschirmlesehilfen-Text“.
4.
Wählen Sie die Datenverbindung aus.
Falls noch keine Verbindung zu einer Datenquelle besteht, wird in diesem Listenfeld lediglich der Eintrag „Standarddatenbindung“ angezeigt.
5.
Klicken Sie auf das Dreieck neben dem Feld „Bindung“ und wählen Sie eine Bindung aus.
Wählen Sie beispielsweise „csr“ > „@dp_csr“ aus.
Im Feld „Bindung“ wird die folgende Zeichenfolge angezeigt:
$record.csr.dp_csr
Sie können diese Zeichenfolge alternativ auch direkt in das Feld „Elemente“ eingeben.
6.
Klicken Sie auf „OK“.
7.
Zeigen Sie auf der Registerkarte „PDF-Vorschau“ eine Vorschau des Formulars an.
Versuchen Sie zum Beispiel, auf der Registerkarte „PDF-Vorschau“ Daten in das Feld „Kunden-ID“ einzugeben, um den benutzerdefinierten Bildschirmlesehilfen-Text zu hören.
Verwandte Themen
Info über dynamische Eigenschaften
So legen Sie dynamische Eigenschaften fest


Zurück Weiter

LiveCycle Designer verwenden > Mit Datenquellen arbeiten > Formularobjekteigenschaften aus einer Datenquelle dynamisch ausfüllen > So füllen Sie nach dem Ausfüllen des ersten Feldes ein zweites Feld dynamisch aus

So füllen Sie nach dem Ausfüllen des ersten Feldes ein zweites Feld dynamisch aus

Sie können mit Hilfe von Skripten ein zweites Feld dynamisch ausfüllen, wenn das erste Feld bereits ausgefüllt ist. Sie können beispielsweise eine Dropdown-Liste mit den Namen verschiedener Länder einrichten. Nachdem ein Benutzer ein Land ausgewählt hat, zeigt die zweite Liste die Staaten, Bezirke oder Ähnliches für das entsprechende Land.
In der zugehörigen XML-Datei könnte Folgendes definiert sein:
<MyData>
   <country/>
   <countries>
      <item uiname="United States" token="US"/>
      <item uiname="Vietnam" token="SRV"/>
   </countries>
   <state/>
   <US>
      <item>California</item>
      <item>New York</item>
      <item>Texas</item>
   </US>
   <SRV>
      <item>An Giang</item>
      <item>Bac Giang</item>
      <item>Bac Kan</item>
   </SRV>
</MyData>
Wenn Sie in der ersten Dropdown-Liste beispielsweise „Vietnam“ auswählen, werden in der Liste „Staaten/Bezirke“ nur die Staaten angezeigt, die zu Vietnam gehören.
Bevor Sie diese Aufgabe ausführen, müssen Sie Folgendes sicherstellen:
      •
      Vergewissern Sie sich, dass aktive Beschriftungen aktiviert sind. (Siehe So legen Sie dynamische Eigenschaften fest)
      •
      Vergewissern Sie sich, dass eine Verbindung zu der Datenquelle besteht, an deren Daten Formularobjekteigenschaften gebunden werden. Siehe Info über das Herstellen einer Verbindung zu einer Datenquelle.
      •
      Vergewissern Sie sich, dass ein Verweis auf eine Datendatei mit definierten Daten für die Formularobjekteigenschaft vorhanden ist, um das Formular mit einer Beispieldatendatei zu testen. Siehe So testen Sie ein Formular mit Musterdaten.
So richten Sie das erste Feld ein
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie eine Dropdown-Liste oder ein Listenfeld auf den Formularentwurf.
Fügen Sie beispielsweise eine Dropdown-Liste ein.
2.
(Optional) Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und geben Sie im Feld „Beschriftung“ eine Beschriftung für das Objekt ein.
Geben Sie beispielsweise Country ein.
3.
Führen Sie einen der folgenden Schritte aus:
      •
      Klicken Sie in der Palette „Objekt“ auf der Registerkarte „Feld“ auf die aktive Beschriftung „Listenelemente“.
      •
      Klicken Sie in der Palette „Objekt“ auf der Registerkarte „Bindung“ auf die aktive Beschriftung „Elementwerte festlegen“.
4.
Wählen Sie die Datenverbindung aus.
Falls noch keine Verbindung zu einer Datenquelle besteht, wird in diesem Listenfeld lediglich der Eintrag „Standarddatenbindung“ angezeigt.
5.
Klicken Sie auf das Dreieck neben dem Feld „Elemente“ und wählen Sie eine Bindung aus.
Die ausgewählte Bindung sollte ein sich wiederholender Datenwert oder eine sich wiederholende Gruppe sein, damit die Dropdown-Liste bzw. das Listenfeld nicht nur ein Element enthält.
Wählen Sie beispielsweise „countries“ > „item“ aus.
Im Feld „Elemente“ wird die folgende Zeichenfolge angezeigt:
$record.countries.item[*]
Sie können diese Zeichenfolge alternativ auch direkt in das Feld „Elemente“ eingeben.
Bei OLEDB-Datenverbindungen steht das Feld „Elemente“ nicht zur Verfügung. Verwenden Sie die Felder „Elementtext“ und „Elementwert“, um die Datenbasisspalten zum Ausfüllen der Liste auszuwählen.
6.
Damit zur Laufzeit eine benutzerfreundliche Beschriftung angezeigt wird, klicken Sie auf das Dreieck neben dem Feld „Elementtext“ und wählen Sie eine Bindung aus.
Wählen Sie beispielsweise „@uiname“ aus, wenn United States angezeigt werden soll.
7.
(Optional) Wenn Sie in der Datenquelle einen anderen Wert als die Bezeichnung „Elementtext“ speichern möchten, klicken Sie auf das Dreieck neben dem Feld „Elementwert“ und wählen Sie eine Bindung aus.
Wählen Sie beispielsweise „@token“ aus, wenn US in der Datendatei gespeichert werden soll.
8.
Klicken Sie auf „OK“.
Wenn eine Bindung festgelegt ist, wird ein kleines Verknüpfungssymbol mit der aktiven Beschriftung angezeigt.
So erstellen Sie ein Skript zum dynamischen Ausfüllen eines zweiten Feldes nach dem ersten Feld
1.
Wählen Sie bei aktivierter Dropdown-Liste in der Liste „Einblenden“ des Skript-Editors den Eintrag „change“ aus.
2.
Wählen Sie in der Liste „Sprache“ den Eintrag „JavaScript“ aus.
3.
Geben Sie folgendes Skript ein:

var tempString = "xfa.record." + this.boundItem(xfa.event.newText);
var oItems = xfa.resolveNode(tempString);
var nItemsLength = oItems.nodes.length;

DropDownList2.clearItems();

for (var nItemCount = 0; nItemCount < nItemsLength; nItemCount++) {
   DropDownList2.addItem(oItems.nodes.item(nItemCount).value);
}

Skript

Beschreibung

tempString
Gibt die Zeichenfolge für „xfa.record“ an. Wird beispielsweise „United States“ ausgewählt, wird „xfa.record“ zu „xfa.record.US“.

this.boundItem
Eine Listenobjektmethode, die den benutzerfreundlichen Namen in die Wert- oder Token-Zeichenfolge übersetzt. Wird beispielsweise United States ausgewählt, so wird US übermittelt.

xfa.event.newText
Gibt den neuen Textinhalt des Change-Ereignisses für die Liste zurück. Wird beispielsweise United States ausgewählt, so wird United States übermittelt.

var nItemsLength = oItems.nodes.length;
Fragt die Anzahl der Child-Elemente von <US> (oder <SRV>) ab, also die Anzahl der untergeordneten Elemente (<item>-Children).

DropDownList2.clearItems();
Entfernt alle vorhandenen Elemente aus der zweiten Dropdown-Liste.

for (var nItemCount = 0; nItemCount < nItemsLength; nItemCount++)
Fragt jedes <item>-Child von <US> (bzw. <SRV>) ab.

DropDownList2.addItem(oItems.nodes.item(nItemCount).value);
Ruft den Textwert des <item>-Childs ab, wie angezeigt durch den nItemCount-Index, und fügt diesen Wert als neues Element in die zweite Dropdown-Liste ein.
4.
Klicken Sie auf „Änderungen zu Skriptquelle eingeben“, um das Skript in Ihr Formular einzufügen.
So richten Sie das zweite Feld ein
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie eine Dropdown-Liste oder ein Listenfeld auf den Formularentwurf.
Fügen Sie beispielsweise eine Dropdown-Liste ein.
2.
(Optional) Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“ und geben Sie im Feld „Beschriftung“ eine Beschriftung für das Objekt ein.
Geben Sie beispielsweise Staat/Bundesl. ein.
3.
Binden Sie das Feld an die Datenquelle.
Binden Sie beispielsweise den Knoten „state“ an die Dropdown-Liste „Staaten/Bezirke“.
4.
Zeigen Sie auf der Registerkarte „PDF-Vorschau“ eine Vorschau des Formulars an.
Verwandte Themen
Info über dynamische Eigenschaften
So legen Sie dynamische Eigenschaften fest


So bearbeiten Sie die dynamische Datenbindung

1.
Wählen Sie das Objekt aus, das eine dynamische Datenbindung aufweist.
Für jede gebundene dynamische Eigenschaft wird an der aktiven Beschriftung ein kleines Verknüpfungssymbol angezeigt. Beispiel:
2.
Suchen Sie die aktive Beschriftung der dynamischen Eigenschaft, deren Datenbindung Sie bearbeiten möchten.
3.
Führen Sie einen der folgenden Schritte aus:
      •
      Klicken Sie auf die aktive Beschriftung.
      •
      Klicken Sie mit der rechten Maustaste auf die aktive Beschriftung und wählen Sie den Befehl „[Eigenschaft] Bindungen bearbeiten“ aus.
4.
Nehmen Sie die gewünschten Änderungen vor und klicken Sie dann auf „OK“.
Verwandte Themen
Info über dynamische Eigenschaften
So legen Sie dynamische Eigenschaften fest


Zurück Weiter

LiveCycle Designer verwenden > Mit Datenquellen arbeiten > Formularobjekteigenschaften aus einer Datenquelle dynamisch ausfüllen > So füllen Sie Formularobjekteigenschaften durch Ziehen und Übergeben dynamisch aus

So füllen Sie Formularobjekteigenschaften durch Ziehen und Übergeben dynamisch aus

Durch Ziehen und Übergeben können Sie schnell dynamische Datenbindungen für Formularobjekteigenschaften einrichten.
Ziehen und Übergeben kann nicht bei Listenelementen in einem Listenfeld oder einer Dropdown-Liste verwendet werden.
Bevor Sie diese Aufgabe ausführen, müssen Sie Folgendes sicherstellen:
      •
      Vergewissern Sie sich, dass aktive Beschriftungen aktiviert sind. Siehe So legen Sie dynamische Eigenschaften fest.
      •
      Vergewissern Sie sich, dass eine Verbindung zu der Datenquelle besteht, an deren Daten Formularobjekteigenschaften gebunden werden. Siehe Info über das Herstellen einer Verbindung zu einer Datenquelle.
      •
      Vergewissern Sie sich, dass ein Verweis auf eine Datendatei mit definierten Daten für die Formularobjekteigenschaft vorhanden ist, um das Formular mit einer Beispieldatendatei zu testen. Siehe So testen Sie ein Formular mit Musterdaten.
1.
Suchen Sie die aktive Beschriftung, für die Sie die dynamische Datenbindung einrichten möchten.
2.
Wählen Sie in der Palette „Datenansicht“ den Knoten aus, den Sie verknüpfen möchten.
3.
Klicken Sie auf den Knoten und ziehen Sie ihn auf die aktive Beschriftung.
Für jede gebundene dynamische Eigenschaft wird an der aktiven Beschriftung ein kleines Verknüpfungssymbol angezeigt. Beispiel:
Wenn für die Eigenschaft bereits eine Datenbindung für dieselbe Datenverbindung eingerichtet war, wird diese Datenbindung ersetzt.
Verwandte Themen
Info über dynamische Eigenschaften
So legen Sie dynamische Eigenschaften fest


So entfernen Sie die dynamische Datenbindung

1.
Wählen Sie das Objekt aus, das eine dynamische Datenbindung aufweist.
Für jede gebundene dynamische Eigenschaft wird an der aktiven Beschriftung ein kleines Verknüpfungssymbol angezeigt. Beispiel:
2.
Suchen Sie die aktive Beschriftung, für die Sie die dynamische Datenbindung entfernen möchten.
3.
Klicken Sie mit der rechten Maustaste auf die aktive Beschriftung und wählen Sie den Befehl „[Eigenschaft] Bindungen löschen“ aus.
Eine weitere Möglichkeit, die dynamische Datenbindung zu entfernen, ist das Auswählen von <Ohne> in der Liste im Dialogfeld „Dynamische Eigenschaften“. Wenn Sie die Option „Bindungen für gelöschte Datenverbindung löschen“ aktivieren, werden beim Löschen einer Datenverbindung sowohl Standarddatenbindungen als auch dynamische Datenbindungen gelöscht.
Verwandte Themen
Info über dynamische Eigenschaften
So legen Sie dynamische Eigenschaften fest


Barrierefreie Formulare erstellen

Barrierefreie Formulare
Barrierefreier Formulare entwerfen
Objekte barrierefrei machen


Barrierefreie Formulare

Ein barrierefreies Formular ist ein Formular, das für eine Vielzahl von Menschen nutzbar ist, so auch von Benutzern mit Behinderungen, die hierdurch in ihrer Arbeit mit dem Formular auf dem Computerbildschirm beeinträchtigt sind. Der Benutzer des Formulars könnte z. B. sehbehindert oder in seiner Mobilität eingeschränkt sein.
LiveCycle Designer bietet eine Reihe von Features und Funktionen, die Benutzern mit unterschiedlichen Behinderungen die Nutzung der Formulare erleichtert und Formularautoren dabei hilft, PDF-Formulare zu erstellen, die für behinderte Menschen zugänglicher sind.
LiveCycle Designer unterstützt die Erstellung barrierefreier HTML-Dateien (AHTML) mit LiveCycle Forms und getaggten PDF-Formularen. Getaggte PDF-Formulare beinhalten eine vollständige logische Struktur sowie weitere Informationen über den Inhalt eines Dokuments, welche die Zugreifbarkeit deutlich verbessern.
Beim Anlegen barrierefreier Formulare sollten Sie berücksichtigen, ob das Formular von den Endbenutzern interaktiv ausgefüllt wird oder ob diese das Formular lediglich anzeigen und drucken werden.
Sie können auch vorhandene barrierefreie PDF-Dateien als Grundlage für Ihr Formular verwenden. Weitere Informationen finden Sie unter Hinweise zur Barrierefreiheit beim Import von PDF-Dateien.
Verwandte Themen
Allgemeine Überlegungen beim Entwurf barrierefreier Formulare
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“


Barrierefreier Formulare entwerfen

Allgemeine Überlegungen beim Entwurf barrierefreier Formulare
Formulare für Benutzer mit Sehbehinderungen oder anderen körperlichen Einschränkungen
Formulare für Benutzer mit eingeschränkter Beweglichkeit
Tab-Reihenfolge bei barrierefreien Formularen
Farbe in barrierefreien Formularen
Unterstützung für Bildschirmlesehilfen
Entwurftipps für das Konzipieren von Formularen für Bildschirmlesehilfen
So erstellen Sie PDF-Formulare mit Ein-/Ausgabehilfe-Tags
Entwurftipps für das Erstellen barrierefreier PDF-Formulare
Verfahren zum Testen der Barrierefreiheit von Formularen


Allgemeine Überlegungen beim Entwurf barrierefreier Formulare

Wenn Sie Formulare für eine große Anzahl von Personen entwerfen, sollten Sie in Betracht ziehen, dass einige Benutzer Behinderungen haben könnten, die sie bei der Arbeit mit den Formularen beeinträchtigen. Einige Benutzer könnten sehbehindert, in ihrer Beweglichkeit eingeschränkt oder in anderer Form behindert sein. Vielleicht möchten Sie, um den Anforderungen aller Benutzer gerecht zu werden, einige praktische Designfunktionen in Ihre Formulare einfügen und die Formulare unter Verwendung einiger Hilfstechnologien testen.
Hier einige Tipps zum Entwerfen barrierefreier Formulare:
      •
      Ein Formular ist nicht barrierefrei, wenn es nicht einfach zu verwenden ist. Sie sollten versuchen, Formulare zu konzipieren, die einfach und gut nutzbar sind. Ein einfach gehaltenes Layout, das Steuerelemente und Felder mit klaren, aussagekräftigen Beschriftungen und QuickInfos umfasst, erleichtert allen Benutzern das Ausfüllen des Formulars.
      •
      Durch übersichtlich und logisch aufgebaute Formulare, die über klare und einfache Anleitungen verfügen, helfen Sie allen Benutzern, Formulare so leicht wie möglich auszufüllen. Navigationsfunktionen, wie die Tab-Reihenfolge und Tastaturbefehle, sollten die logische Anordnung der Objekte im Formular unterstützen. Die Beschriftung eines Feldes sollte sich auf derselben Zeile befinden wie der ausfüllbare Bereich für dieses Feld. Platzieren Sie Beschriftungen immer konsistent auf dieselbe Seite eines Feldes.
      •
      Benutzer arbeiten besser mit Formularen, bei denen das Risiko Fehler zu machen möglichst gering ist. Klare und knappe Fehlermeldungen helfen den Benutzern, gemachte Fehler zu beheben.
      •
      Wählen Sie Objekte, welche die Handhabung des Formulars vereinfachen. Mit Tabellen beispielsweise lassen sich bei richtiger Verwendung tabellarische Informationen effizient gliedern und darstellen. Vermeiden Sie übermäßig komplexe Tabellen, wie Tabellen, die verschachtelte Tabellen und Abschnitte enthalten.
      •
      Benutzer sollten das Formular vollständig über Tastatureingaben oder ein ähnliches Eingabegerät allein ausfüllen können. Benutzer mit eingeschränkter Mobilität bzw. Sehfähigkeit haben möglicherweise keine andere Wahl, als die Tastatur zu nutzen. Und viele Benutzer, die eine Maus verwenden könnten, ziehen es vor, Eingaben per Tastatur vorzunehmen. Indem Sie mehrere Eingabeverfahren ermöglichen, erstellen Sie Formulare, die nicht nur barrierefrei sind, sondern auch den Vorlieben aller Benutzer entgegenkommen.
      •
      Konzipieren Sie Ihre Formulare so, dass sie auf die gewohnte Weise mit anderen Anwendungen und Systemstandards zusammenarbeiten. Sie könnten beispielsweise die Standardeinstellungen der Windows-Systemsteuerung für Farben und das Standardtastaturverhalten unterstützen.
      •
      Ein gut konzipiertes Formular sollte mit verschiedenen Hilfstechnologien kompatibel sein. Sie sollten sich mit der Funktionsweise dieser Technologien vertraut machen und Designverfahren sowie Benutzerschnittstellenelemente verwenden, die mit einer Vielzahl der Hilfstechnologien kompatibel sind.
      •
      Farben können das Benutzererlebnis mit Ihrem Formular deutlich positiver gestalten, vorausgesetzt diese werden sinnvoll eingesetzt. Farben können bestimmte Teile Ihres Formulars hervorheben und verdeutlichen, allerdings sollten nicht die Farben allein Träger der Information werden. Viele Farben können Augenschmerzen verursachen. Bei Verwendung zu vieler Farben kann der im Vordergrund stehende Text undeutlich werden. Es werden kontrastreiche Farben empfohlen, wie die Standardeinstellungen von Schwarz auf einem weißen Hintergrund.
      •
      Bilder können vor allem Benutzern mit bestimmten Behinderungen beim Verständnis helfen. Viele Bildschirmlesehilfen können jedoch keine Grafiken lesen, was sich u. U. für sehbehinderte Benutzer negativ auswirken kann. Wenn Sie Bilder verwenden möchten, sollten Sie Textbeschreibungen einfügen, welche das Objekt und seinen Zweck im Formular erklären.
      •
      Beachten Sie, dass clientseitige Skripten zu Konflikten mit Bildschirmlesehilfen und Tastaturen führen können, wenn das Skript den Fokus der Client-Anwendung ändert. So kann beispielsweise die Verwendung von „Change“- und „MouseEnter“-Ereignissen in Dropdown-Listen oder Listenfeldern ungewollte Aktionen auslösen. Clientseitige Skripten sollten so geschrieben werden, dass Konflikte mit Bildschirmlesehilfen und Tastaturen vermieden werden. Ebenso sollten Skriptereignisse vermieden werden, die optische Effekte erzeugen, wie blinkender Text, da diese die Lesbarkeit für Benutzer einschränken könnten.
      •
      Optionsfelder werden häufig falsch interpretiert oder sind für behinderte Benutzer in HTML-Formularen nur schwer zugänglich, da sie von Webbrowsern und Bildschirmlesehilfen unterschiedlich gehandhabt werden. Vermeiden Sie Optionsfelder in HTML-Formularen und verwenden Sie stattdessen möglichst Listenfelder.
Verwandte Themen
Entwurftipps für das Konzipieren von Formularen für Bildschirmlesehilfen
Entwurftipps für das Erstellen barrierefreier PDF-Formulare
Einfache Tabellen barrierefrei machen
Komplexe Tabellen barrierefrei machen
Bilder barrierefrei machen
Skripten barrierefrei machen


Formulare für Benutzer mit Sehbehinderungen oder anderen körperlichen Einschränkungen

Benutzer mit einer Sehbehinderung oder anderen körperlichen Einschränkungen verwenden in der Regel eine Hilfstechnologie namens Screenreader (Bildschirmlesehilfe), welche den Benutzer durch Sprachausgabe unterstützt. Eine Bildschirmlesehilfe kann dem Benutzer die Informationen vorlesen, die sich unterhalb des Cursors auf dem Bildschirm befinden. Die Bildschirmlesehilfe ist auch in der Lage, QuickInfos zu lesen. Daher sollten Sie diese auf jeden Fall in Ihrem Entwurf vorsehen.
Außer QuickInfos können Sie Überschriften, Objektnamen oder benutzerdefinierten Bildschirmlesehilfen-Text verwenden, um die einzelnen Felder eindeutig zu identifizieren. Sie können auch Textobjekte verwenden, um anzugeben, welche Art von Eingabe erforderlich ist. Sie sollten explizit angeben, welche Felder ausgefüllt werden müssen. Beispielsweise könnte der QuickInfo-Text die Wörter „Erforderliche Eingabe“ enthalten.
Um sicherzustellen, dass eine Bildschirmlesehilfe mit einem PDF-Formular funktioniert, müssen Sie für jedes Objekt eine gesprochene Information hinterlegen und ein getaggtes PDF-Formular erzeugen. Wenn Sie von demselben Formularentwurf ein HTML-Formular erstellen, können Bildschirmlesehilfen die QuickInfos von AHTML-Konvertierungen lesen und als Sprechtext wiedergeben.
Beachten Sie folgende Design-Überlegungen, um Benutzer mit Sehbehinderungen oder anderen körperlichen Einschränkungen zu unterstützen:
      •
      Benutzer mit Sehbehinderungen oder anderen körperlichen Einschränkungen können die Maus nicht für die Interaktion mit dem Computer verwenden. Jede Funktion muss über Tastatureingaben aufgerufen werden können. In den meisten Formularen wird der Cursor gewöhnlich mit der Tabulatortaste und mit Umschalt+Tabulator vorwärts und zurück bewegt. Stellen Sie sicher, dass Sie eine logische Tab-Reihenfolge definieren, die alle Felder und Schaltflächen umfasst.
      •
      Viele Formulare beinhalten Informationen mit zusätzlichen allgemeinen Anweisungen für den Benutzer zum Ausfüllen des Formulars. Verwenden Sie QuickInfos, damit dem Benutzer alle wichtigen Informationen zum richtigen Zeitpunkt zur Verfügung stehen. Informieren Sie den Benutzer beispielsweise durch eine Ansage, wenn er zur Ausführung einer Funktion eine bestimmte Taste drücken muss (z. B. das Drücken der Leertaste zur Auswahl einer Schaltfläche oder die Verwendung von Pfeiltasten zur Auswahl von Elementen in einem Listenfeld).
      •
      Verwenden Sie eine ausreichende Menge an Sprachausgabe-Informationen, damit der Benutzer weiß, welche Eingaben erwartet und wie die Felder korrekt ausgefüllt werden. Vermeiden Sie es jedoch, die Benutzer mit redundanten Informationen zu überhäufen.
      •
      Fügen Sie Navigationsschaltflächen am Anfang und am Ende Ihres Formulars ein. Am Anfang Ihres Formulars könnten Sie z. B. folgende Schaltflächen einfügen: „Datendatei öffnen“, „Vorherige Seite“ oder „Nächste Seite“. Am Formularende könnten z. B. folgende Schaltflächen verwendet werden: „Daten speichern“, „Daten per E-Mail senden“, „Zum Anfang“ oder „Drucken“.
      •
      „Intelligente Felder“ könnten auf effektive Weise das Ausfüllen eines Formulars erleichtern. So könnte z. B. ein Formular für die Reisekostenabrechnung über mehrere Zeilen und Spalten von Feldern verfügen. Das letzte Feld in jeder Reihe könnte überprüfen, ob irgendwelche Daten in dieser Reihe eingegeben wurden. Falls die Zeile leer ist, könnte das Drücken der Tabulatortaste den Sprung in den nächsten Abschnitt des Formulars bewirken, anstatt weiterhin durch eine Reihe von Feldern zu springen, die nicht ausgefüllt werden müssen.
      •
      Benutzer mit einer Sehbehinderung oder Farbenblindheit könnten Schwierigkeiten beim Erkennen des Cursors haben. Verwenden Sie entsprechende Farben, um Objekte mit dem vom Benutzer ausgewählten Farbschema darzustellen.
      •
      Sehbehinderte Benutzer greifen normalerweise auf Hilfstechnologien wie Vergrößerungsprogramme zurück. Diese Produkte vergrößern den Cursor. Testen Sie Ihre Formulare mit einer Vielzahl gängiger Vergrößerungsprogramme, um sicherzustellen, dass sie den Anforderungen an barrierefreie Formulare genügen.


Formulare für Benutzer mit eingeschränkter Beweglichkeit

Für Benutzer mit eingeschränkter Beweglichkeit oder Motorik kann das Ausfüllen eines Formulars sehr beschwerlich sein. Wenn ein Benutzer keine Maus bedienen kann, muss jede Funktion innerhalb eines Formulars mit der Tastatur aufrufbar sein.
Benutzer mit eingeschränkter Beweglichkeit bzw. Motorik können auf eine Vielzahl von Hilfstechnologien zugreifen. Die Bandbreite reicht von speziellen Tastaturen über Spracheingabe-Anwendungen, mit deren Hilfe der Benutzer das Formular über ein Mikrofon ausfüllt, bis hin zu ausgereiften Technologien, die es ermöglichen, einen Computer über den Atem oder per Augenbewegungen zu bedienen.
Testen Sie Ihre Formulare mit einer Vielzahl dieser Hilfstechnologien, um sicherzustellen, dass sie den Anforderungen an barrierefreie Formulare genügen.


Tab-Reihenfolge bei barrierefreien Formularen

Wenn Ihr Formular die Standard-Tab-Reihenfolge verwendet, gilt die geografische Reihenfolge, d. h. von links nach rechts und von oben nach unten. Bei der Tab-Reihenfolge werden Teilformulare, Optionsfelder und Inhaltsbereiche berücksichtigt. Die Tab-Reihenfolge wird auch durch die vertikale Position der Objekte auf einer Seite und auf deren Masterseite bestimmt.
Die Einhaltung einer schlüssigen Tab-Reihenfolge ist ein wichtiger Aspekt beim Entwerfen von Formularen, die für Benutzer mit eingeschränkter Sehfähigkeit bzw. Behinderungen zugänglich sein sollen. Diese Benutzer verwenden beim Navigieren durch ein Formular in der Regel keine Maus, sondern sind auf die Tastatur angewiesen. Eine logische Tab-Reihenfolge stellt sicher, dass sie Zugriff auf alle Felder im Formular haben und auf eine sinnvolle und effiziente Weise durch das Formular navigieren können.
Die Tab-Reihenfolge bestimmt außerdem die Lesereihenfolge, in welcher die Bildschirmlesehilfe Formularobjekte liest. Die Lesereihenfolge beruht auf der logischen PDF-Struktur, die beim Speichern des Formulars als PDF mit Tags erstellt wird.
LiveCycle Designer schließt alle statischen Objekte und Feldobjekte in die logische Struktur ein. Stellen Sie sicher, dass alle Text- und Bildobjekte logisch in der Tab-Reihenfolge platziert sind, so dass Text innerhalb eines Textobjekts und alle QuickInfos oder benutzerdefinierter Bildschirmlesehilfen-Text für Bilder zum richtigen Zeitpunkt vorgelesen werden.
Da die Tab-Reihenfolge sehr wichtig ist, müssen Sie die Objekte im Formular sorgfältig relativ zueinander positionieren. Sie können z. B. ein Objekt mit Hilfe seiner Koordinaten positionieren und seine Größe anpassen und Objekte an Punkten in einem Raster ausrichten.
Wenn Sie ein großes interaktives PDF-Formular ohne Struktur erstellen, kann es vorkommen, dass für die Benutzer das Springen von einem Feld zum anderen mit niedriger Geschwindigkeit erfolgt. Dieses Problem können Sie vermeiden, indem Sie das Formular ohne Tags speichern. Wenn Ihr Formular jedoch barrierefrei sein muss, müssen Sie es als PDF mit Tags speichern. Um dieses Problem zu umgehen, können Sie Abschnitte des Formulars in unbenannte Teilformulare aufnehmen. Dadurch wird dem Formular die erforderliche Struktur hinzugefügt.
Verwandte Themen
Info über die Tab-Reihenfolge
So funktioniert die Tab-Reihenfolge
So legen Sie die Tab-Reihenfolge fest
So positionieren Sie Objekte
Die Zeichenhilfen


Farbe in barrierefreien Formularen

Farben können das Benutzererlebnis mit Ihrem Formular deutlich positiver gestalten, wenn diese sinnvoll eingesetzt werden. Viele Farben können Augenschmerzen verursachen. Bei Verwendung zu vieler Farben kann der im Vordergrund stehende Text undeutlich werden.
Beim Entwerfen von barrierefreien Formularen sind ein paar zusätzliche Richtlinien für die Verwendung von Farbe zu beachten. Farben können bestimmte Teile Ihres Formulars hervorheben und verdeutlichen, allerdings sollten nicht die Farben allein Träger der Information werden.
Ein rotes Sternchen bedeutet beispielsweise oft, dass ein Textfeld vom Benutzer ausgefüllt werden muss. Da sehbehinderte Benutzer die Farbe Rot u. U. nur schlecht erkennen können, ist es besser, für Textfelder in barrierefreien Formularen den Typ „Benutzereingabe - Erforderlich“ festzulegen und durch eine Meldung anzugeben, dass das Feld ausgefüllt werden muss.
Viele sehbehinderte Benutzer sind auf einen hohen Kontrast zwischen Text und Hintergrund angewiesen, um das Formular lesen zu können. Es wird dringend empfohlen, die standardmäßigen Schrift- und Hintergrundfarben zu verwenden. Schwarz auf einem weißen Hintergrund bildet einen starken Kontrast, welcher die Lesbarkeit des Formulars verbessert. Wenn Sie diese Standardfarben dennoch ändern müssen, sollten Sie eine entsprechende kontrastreiche Farbkombination wählen.
Ihr Formularentwurf sollte mit anderen Anwendungen und Systemstandards normal zu verwenden sein. Dazu gehört auch die Unterstützung von standardmäßigen Windows-Systemsteuerungseinstellungen für Farben. Benutzer mit einer Sehbehinderung oder Farbenblindheit könnten Schwierigkeiten beim Erkennen des Cursors haben. Durch Verwenden der Standardeinstellungen für Farbe lässt sich dieses Problem vermeiden.
Beim Entwerfen Ihres Formulars sollten Sie dieses häufig mit einem Farbschema testen, das viele sehbehinderte Benutzer beim Ausfüllen verwenden. Dadurch können Sie Probleme frühzeitig erkennen und beheben.
Verwandte Themen
Schrift-Eigenschaften in der Palette „Schrift“
Absatz-Eigenschaften in der Palette „Absatz“
Randeigenschaften in der Palette „Rand“
Verfahren zum Testen der Barrierefreiheit von Formularen


Unterstützung für Bildschirmlesehilfen

Um auf gesprochene Informationen über ein Formular Zugriff zu haben, benötigen sehbehinderte Benutzer eine Bildschirmlesehilfe. Bildschirmlesehilfen lesen Informationen über den Bereich des Formulars vor, auf den der Cursor zeigt. Als Verfasser des Formulars müssen Sie den Text für die Bildschirmlesehilfe bereitstellen. Wenn das Formular als PDF gespeichert wird, müssen Sie auch ein PDF-Formular mit Tags generieren.
LiveCycle Designer unterstützt die mit Microsoft Active Accessibility (MSAA) kompatible Bildschirmlesehilfe JAWS für Windows von Freedom Scientific.
Verwandte Themen
Entwurftipps für das Konzipieren von Formularen für Bildschirmlesehilfen
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“


Entwurftipps für das Konzipieren von Formularen für Bildschirmlesehilfen

Um ein barrierefreies Formular bereitstellen zu können, müssen Sie wissen, wie Bildschirmlesehilfen funktionieren. Sie müssen ebenfalls wissen, wie Sie mit der Palette „Ein-/Ausgabehilfe“ von LiveCycle Designer festlegen, welche Informationen die Bildschirmlesehilfe für die Objekte im Formular vorliest. Beachten Sie bei der Implementierung von barrierefreien Formularen, die Bildschirmlesehilfen unterstützen, die folgenden Aspekte:
      •
      Informieren Sie die Benutzer darüber, welches Formular geöffnet ist und wie es ausgefüllt werden muss. Beim Öffnen eines Formulars liest die Bildschirmlesehilfe in der Regel eine gesamte Seite, einschließlich Text- und Bildobjekte. Wenn der Benutzer beginnt, sich durch das Formular zu bewegen, liest die Bildschirmlesehilfe den Text für jedes Objekt vor, das aktiv wird.
      •
      Legen Sie eine logische Tab-Reihenfolge fest, welche den gesamten Text, alle Felder, Schaltflächen und Bilder einschließt, um sehbehinderten Benutzern die Navigation zu erleichtern. Es ist wichtig, die Tab-Reihenfolge konsequent umzusetzen, da PDF-Tags für Bildschirmlesehilfen standardmäßig von oben nach unten und von links nach rechts angeordnet sind.
      •
      Informieren Sie den Benutzer durch eine Ansage, wenn er zur Ausführung einer Funktion eine bestimmte Taste drücken muss. Dies kann das Drücken der Leertaste zur Auswahl einer Schaltfläche oder die Verwendung von Pfeiltasten zur Auswahl von Elementen in einem Listenfeld bedeuten.
      •
      Die Namen von Schaltflächen und Feldern sowie ihr Zweck sollte angesagt werden, sobald sie mit der Tabulatortaste angesprungen wurden. Ziehen Sie die folgenden Möglichkeiten in Betracht:
      •
      Ansage des Status von Kontrollkästchen und Optionsfeldern.
      •
      Bei Listenfeldern und Dropdown-Listen: Ansage des in der Liste ausgewählten Standardelements. Lassen Sie den Benutzer außerdem wissen, dass er sich mit den Pfeiltasten nach oben und nach unten durch die Listenelemente bewegen kann. Zur Auswahl des Elements in der Liste muss die Tabulator- oder Eingabetaste gedrückt werden. Mit Hilfe von Skripten können Sie definieren, dass das Ereignis „Change“ des Objekts ansagt, welches Element in der Liste ausgewählt ist.
Verwandte Themen
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“
So legen Sie einen benutzerdefinierten Bildschirmlesehilfen-Text für ein Objekt fest
So legen Sie eine eigene QuickInfo für ein Objekt fest
So legen Sie eine andere Suchreihenfolge für Bildschirmlesehilfen-Text fest
So deaktivieren Sie den Bildschirmlesehilfen-Text für ein Objekt


So erstellen Sie PDF-Formulare mit Ein-/Ausgabehilfe-Tags

Zusätzlich zur Angabe eines Textes für Bildschirmlesehilfen müssen Sie ein PDF-Formular mit Tags erstellen, damit die Bildschirmlesehilfe den Text lesen kann. Dazu generieren Sie Ein-/Ausgabehilfe-Tags, wenn Sie den Formularentwurf als PDF-Datei speichern.
In LiveCycle Designer werden PDF-Formulare standardmäßig mit Tags erstellt.
1.
Wählen Sie „Datei“ > „Speichern“.
2.
Wählen Sie in der Liste „Dateityp“ eine der Optionen namens „Acrobat PDF-Formular (*.pdf)“ aus.
3.
Achten Sie darauf, dass im Abschnitt „Speicheroptionen“ die Option „Ein-/Ausgabehilfedaten (Tags) für Acrobat erzeugen“ aktiviert ist.
Verwandte Themen
Tab-Reihenfolge bei barrierefreien Formularen
Entwurftipps für das Erstellen barrierefreier PDF-Formulare


Entwurftipps für das Erstellen barrierefreier PDF-Formulare

Diese Tipps erleichtern das Erstellen barrierefreier Formulare für Acrobat und Adobe Reader:
      •
      Kreis-, Linien- und Rechteckobjekte werden in PDF-Formularen nicht mit Tags versehen. Diese Objekte enthalten keine nützlichen Informationen für Benutzer mit verminderter Sehfähigkeit oder Behinderungen. Die Informationen für diese Objekte werden von Bildschirmlesehilfen nicht gelesen.
      •
      Stellen Sie die Option „Bildschirmlesehilfen-Rangfolge“ für Feldobjekte nicht auf „Ohne“ ein. Ansonsten gibt die Bildschirmlesehilfe in Acrobat die Meldung aus, dass die MSAA-Dateneingabeaufforderung nicht verfügbar ist, wenn der Benutzer in das Feld springt, auch wenn das Feld schreibgeschützt ist.
      •
      Teilformulare eignen sich zum Anordnen verwandter Objekte und sorgen für eine logische Tab-Struktur. Die standardmäßige Tab-Reihenfolge ist die geografische Reihenfolge von links nach rechts und von oben nach unten. Wenn zwei Teilformulare nebeneinander liegen und jedes Teilformular eine Anzahl von Feldobjekten enthält, führt die Tab-Reihenfolge durch die Felder des ersten Teilformulars, bevor zum nächsten Teilformular übergegangen wird.
      •
      Wenn mit der Tabulatortaste in ein Optionsfeld gesprungen wird, gibt die Bildschirmlesehilfe zuerst den Text für das Gruppenobjekt aus, welches das Optionsfeld enthält, und anschließend den An-Wert für das Optionsfeld. Sie sollten für jede Optionsfeld-Ausschlussgruppe benutzerdefinierten Bildschirmlesehilfen-Text festlegen und sicherstellen, dass der An-Wert des Optionsfelds der Beschriftung entspricht oder sinnvollen Text enthält.
      •
      Bilder können vor allem Benutzern mit bestimmten Behinderungen beim Verständnis helfen. Viele Bildschirmlesehilfen können jedoch keine Grafiken lesen, was sich u. U. für sehbehinderte Benutzer negativ auswirken kann. Wenn Sie Bilder verwenden möchten, sollten Sie Textbeschreibungen einfügen, welche das Objekt und seinen Zweck im Formular erklären.
      •
      Die Tab-Reihenfolge von Objekten auf Seiten und deren Masterseiten wird von den vertikalen Koordinaten der Objekte bestimmt. Testen Sie Ihre Formulare, um sicherzustellen, dass die Bildschirmlesehilfe Objekte in der gewünschten Reihenfolge liest.
      •
      Beachten Sie, dass clientseitige Skripten zu Konflikten mit Bildschirmlesehilfen und Tastaturen führen können, wenn das Skript den Fokus der Client-Anwendung ändert. So kann beispielsweise die Verwendung von „Change“- und „MouseEnter“-Ereignissen in Dropdown-Listen oder Listenfeldern ungewollte Aktionen auslösen. Clientseitige Skripten sollten so geschrieben werden, dass Konflikte mit Bildschirmlesehilfen und Tastaturen vermieden werden. Ebenso sollten Skriptereignisse vermieden werden, die optische Effekte erzeugen, wie blinkender Text, da diese die Lesbarkeit für Benutzer einschränken könnten.
      •
      Enthält Ihr Formular viele Objekte, ist das Navigieren mit der Tabulatortaste in Acrobat 6.0 eventuell langsam. Wenn Sie ein Acrobat 6.0-kompatibles Formular erstellen, sollten Sie um kleinere Gruppen von Formularobjekten unbenannte Teilformulare hinzufügen; der logischen Struktur werden dadurch Ebenen hinzugefügt und das Problem wird behoben.
      •
      Verfasser und Benutzer von Formularen sollten sich mit den Problemen vertraut machen, die zwischen Acrobat und Bildschirmlesehilfen auftreten können.
      •
      Bildschirmlesehilfen lesen beim Tippen in ein Feld jede Tasteneingabe, einschließlich der von Kennwortfeldern, vor.
      •
      Bei jedem Öffnen eines Meldungsfelds, z. B. um einen Überprüfungsfehler auszugeben, verliert das Formular den Fokus. Durch erneutes Drücken der Tabulatortaste gelangt der Benutzer wieder zum ersten Feld der Tab-Reihenfolge zurück.
      •
      Die Bildschirmlesehilfe liest den gesamten Text in der für das Dokument festgelegten Standardsprache.
Verwandte Themen
Entwurftipps für das Konzipieren von Formularen für Bildschirmlesehilfen
So erstellen Sie PDF-Formulare mit Ein-/Ausgabehilfe-Tags
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“
So deaktivieren Sie den Bildschirmlesehilfen-Text für ein Objekt


Verfahren zum Testen der Barrierefreiheit von Formularen

Sie sollten Ihre Formulare mit verschiedenen Hilfstechnologien testen, um sicherzustellen, dass sie einer Vielzahl von Benutzern zugänglich sind. Anhand der folgenden Verfahren können Sie Ihre Formulare einfach und kostengünstig testen:
      •
      Stellen Sie sicher, dass das Formular allein über Tastatureingaben ausgefüllt werden kann. Achten Sie darauf, das gesamte Formular auszufüllen und alle Felder und Schaltflächen zu testen. Während Sie das Formular ausfüllen, prüfen Sie anhand Ihrer Antworten auf folgende Fragen, ob Verbesserungen notwendig sind:
      •
      Gibt es Vorgänge, die nicht ausgeführt werden können?
      •
      Sind einige Vorgänge umständlich oder schwierig auszuführen?
      •
      Sind die Tastaturfunktionen gut dokumentiert?
      •
      Haben alle Steuerelemente und Menüeinträge unterstrichene Zugriffstasten?
      •
      Demoversionen von Bildschirmlesehilfen können aus dem Internet heruntergeladen werden. Zum Testen schalten Sie den Bildschirm aus und verwenden Sie nur die Bildschirmlesehilfe zum Navigieren und Ausfüllen des Formulars. Da Sie als Formularverfasser mit dem Formular sehr vertraut sind, ist es für Sie eventuell schwierig zu beurteilen, ob die von der Bildschirmlesehilfe gelesenen Informationen ausreichend und verständlich sind. Lassen Sie wenn möglich jemand anders das Formular auf diese Weise testen.
      •
      Demoversionen von Software zur Vergrößerung von Bildschirmausschnitten können zu Testzwecken aus dem Internet heruntergeladen werden.
      •
      Spracheingabe-Software kann gegen ein geringes Entgelt in Computer-Fachgeschäften erworben werden. Testen Sie das Formular, indem Sie es nur über Spracheingabe ausfüllen.
      •
      Viele sehbehinderte Benutzer sind auf einen hohen Kontrast zwischen Text und Hintergrund angewiesen, um das Formular lesen zu können. Microsoft Windows hat ein Farbschema mit hohem Kontrast, dessen Anzeige der entspricht, die viele sehbehinderte Benutzer zum Ausfüllen Ihres Formulars verwenden. Um für Ihre Anzeige einen Modus mit hohem Kontrast einzustellen, aktivieren Sie in der Systemsteuerung von Windows die entsprechende Funktion in den Eingabehilfe-Optionen. Während Sie das Formular in diesem Modus ausfüllen, prüfen Sie anhand Ihrer Antworten auf folgende Fragen, ob Verbesserungen notwendig sind:
      •
      Werden Teile des Formulars unsichtbar oder sind sie unkenntlich bzw. nur schwer nutzbar?
      •
      Werden Bereiche weiterhin schwarz auf weißem Hintergrund dargestellt?
      •
      Haben Elemente die falsche Größe oder sind sie abgeschnitten?


Objekte barrierefrei machen

So legen Sie einen benutzerdefinierten Bildschirmlesehilfen-Text für ein Objekt fest
So legen Sie eine eigene QuickInfo für ein Objekt fest
So legen Sie eine andere Suchreihenfolge für Bildschirmlesehilfen-Text fest
So deaktivieren Sie den Bildschirmlesehilfen-Text für ein Objekt
Einfache Tabellen barrierefrei machen
Komplexe Tabellen barrierefrei machen
So machen Sie Optionsfelder barrierefrei
Listen barrierefrei machen
Bilder barrierefrei machen
Skripten barrierefrei machen
Abschnitte in Formularen überspringen


So legen Sie einen benutzerdefinierten Bildschirmlesehilfen-Text für ein Objekt fest

Einen benutzerdefinierten Bildschirmlesehilfen-Text für ein Objekt definieren Sie über die Palette „Ein-/Ausgabehilfe“.
Vergewissern Sie sich, dass in Acrobat im Dialogfeld „Grundeinstellungen“ (aufzurufen über das Menü „Bearbeiten“) unter „Lesen“ die Option „Formularfelder lesen“ aktiviert wurde.
1.
Wählen Sie das Objekt im Formularentwurf aus.
2.
Klicken Sie auf die Registerkarte der Palette „Ein-/Ausgabehilfe“ und geben Sie im Feld „Benutzerdef. Bildschirmlesehilfen-Text“ den gewünschten Text ein.
Verwandte Themen
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“
So legen Sie eine eigene QuickInfo für ein Objekt fest


So legen Sie eine eigene QuickInfo für ein Objekt fest

Eine eigene QuickInfo für ein Objekt definieren Sie über die Palette „Ein-/Ausgabehilfe“. Bei den meisten Objekten werden QuickInfos angezeigt, wenn der Benutzer den Mauszeiger über das Objekt bewegt. QuickInfos werden für einige schreibgeschützte Objekte, wie Papierformular-Barcodeobjekte, nur dann angezeigt, wenn eine Bildschirmlesehilfe verwendet wird.
Sie können einem Objekt nicht sowohl eine eigene QuickInfo als auch einen benutzerdefinierten Bildschirmlesehilfen-Text zuweisen. Sie müssen sich für eine der Optionen entscheiden. Möchten Sie eine eigene QuickInfo verwenden, geben Sie den Text ein und wählen in der Liste „Bildschirmlesehilfen-Rangfolge“ die Option „QuickInfo“ aus bzw. geben keinen benutzerdefinierten Bildschirmlesehilfen-Text ein. Soll der benutzerdefinierte Bildschirmlesehilfen-Text sowohl als QuickInfo als auch als Bildschirmlesehilfen-Text verwendet werden, geben Sie den Text ein und wählen in der Liste „Bildschirmlesehilfen-Rangfolge“ die Option „Eigener Text“ aus.
Wurde im Feld „QuickInfo“ oder im Feld „Benutzerdef. Bildschirmlesehilfen-Text“ nichts angegeben, verwendet die Bildschirmlesehilfe die Beschriftung für die QuickInfo und die Sprachausgabe.
1.
Wählen Sie das Objekt im Formularentwurf aus.
2.
Klicken Sie auf die Registerkarte der Palette „Ein-/Ausgabehilfe“ und geben Sie in das Feld „QuickInfo“ den gewünschten Text ein.
3.
Wenn für dieses Objekt auch ein benutzerdefinierter Bildschirmlesehilfen-Text definiert ist, die Bildschirmlesehilfe aber die QuickInfo anstelle des Bildschirmlesehilfen-Textes lesen soll, wählen Sie in der Liste „Bildschirmlesehilfen-Rangfolge“ die Option „QuickInfo“.
Verwandte Themen
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“
So legen Sie einen benutzerdefinierten Bildschirmlesehilfen-Text für ein Objekt fest
So legen Sie eine andere Suchreihenfolge für Bildschirmlesehilfen-Text fest


So legen Sie eine andere Suchreihenfolge für Bildschirmlesehilfen-Text fest

Standardmäßig durchsucht die Bildschirmlesehilfe die Formulareinstellungen für Bildschirmlesehilfen-Text in folgender Reihenfolge: Eigener Text, QuickInfo, Beschriftung und Name. Dieses Standardverhalten können Sie über die Option „Bildschirmlesehilfen-Rangfolge“ ändern.
1.
Wählen Sie das Objekt im Formularentwurf aus.
2.
Klicken Sie auf die Registerkarte der Palette „Ein-/Ausgabehilfe“.
3.
Wählen Sie in der Liste „Bildschirmlesehilfen-Rangfolge“ die gewünschte Option.
Wenn Sie beispielsweise möchten, dass die Bildschirmlesehilfe nicht die Beschriftung, sondern den Namen liest, wählen Sie „Name“. Dadurch wird die Suchreihenfolge folgendermaßen geändert: Name, Eigener Text, QuickInfo und Beschriftung.
Verwandte Themen
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“
So legen Sie eine eigene QuickInfo für ein Objekt fest
So deaktivieren Sie den Bildschirmlesehilfen-Text für ein Objekt


So deaktivieren Sie den Bildschirmlesehilfen-Text für ein Objekt

In bestimmten Fällen soll die Bildschirmlesehilfe möglicherweise für ein Objekt keinen Text (auch nicht den Objekttyp) lesen. Über die Palette „Ein-/Ausgabehilfe“ können Sie Text für eine Bildschirmlesehilfe für jedes einzelne Objekt deaktivieren.
Vergewissern Sie sich, dass in Acrobat im Dialogfeld „Grundeinstellungen“ (aufzurufen über das Menü „Bearbeiten“) unter „Lesen“ die Option „Formularfelder lesen“ aktiviert wurde.
1.
Wählen Sie das Objekt im Formularentwurf aus.
2.
Klicken Sie auf die Registerkarte der Palette „Ein-/Ausgabehilfe“.
3.
Wählen Sie in der Liste „Bildschirmlesehilfen-Rangfolge“ die Option „Ohne“.
Verwandte Themen
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“
So legen Sie eine andere Suchreihenfolge für Bildschirmlesehilfen-Text fest


Einfache Tabellen barrierefrei machen

Mit Tabellen lässt sich Inhalt effizient in barrierefreien Formularen anordnen und darstellen. Bei richtiger Verwendung geben die Zeilen und Spalten einer Tabelle dem Formularinhalt eine vorhersehbare, konsistente Struktur.
Wenn ein Benutzer z. B. zu einer Textzelle in einer Zeile navigiert, bestimmt die Bildschirmlesehilfe die Zellenposition und liest dann den Inhalt der Zelle. Die Zellenposition wird von der Bildschirmlesehilfe mit Hilfe einer Kombination aus Zeilen- und Spaltenüberschriften oder Zeilen- und Spaltennummern bestimmt.
Außer der Positionsbestimmung der Zelle kann eine Bildschirmlesehilfe auch Überschrifteninformationen angeben, z. B. den Inhalt der obersten Zelle in der Spalte. Da Bildschirmlesehilfen Informationen liefern, mit deren Hilfe der Benutzer sich im Inhalt der Tabelle orientiert, wirkt sich das Layout unmittelbar auf die Lesbarkeit der Tabelle aus.
Tabellen mit einem einfachen Layout sind empfehlenswert. Einfache Tabellen enthalten eine Kopfzeile und daran anschließend Textzeilen.
Beim Erstellen von einfachen Tabellen für Benutzer mit Seh- und Bewegungseinschränkungen sollten Sie die folgenden Hinweise berücksichtigen:
      •
      Die Tab-Reihenfolge für eine Tabelle ist die geografische Reihenfolge, die auch für das Formular selbst gilt. Der Tabelleninhalt sollte so angeordnet sein, dass er beim Lesen der Tabelle von links nach rechts und von oben nach unten problemlos erfasst werden kann.
      •
      Die meisten Bildschirmlesehilfen interpretieren die erste Zeile in einer Tabelle als Kopfzeile. Beim Lesen des Inhalts einer Textzeilenzelle mit einer Bildschirmlesehilfe wird zunächst der Inhalt der zugehörigen Kopfzeilenzelle gelesen. Jede Kopfzeilenzelle sollte daher eine aussagekräftige Beschreibung des Spalteninhalts enthalten.
      •
      Vermeiden Sie Zellen, die zwei oder mehrere Spalten umfassen, sowie verschachtelte Tabellen oder Tabellenabschnitte. Diese Funktionen werden von Bildschirmlesehilfen oft nicht einwandfrei interpretiert und daher ignoriert. Wenn z. B. eine Zelle in einer Textzeile zwei Spalten umfasst, können Bildschirmlesehilfen den korrekten Zelleninhalt in der Kopfzeile möglicherweise beim Lesen der nächsten Zelle in der Zeile nicht referenzieren.
Verwandte Themen
Komplexe Tabellen barrierefrei machen
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“


Komplexe Tabellen barrierefrei machen

Beim Erstellen von Tabellen für Benutzer mit Seh- und Bewegungseinschränkungen sollte auf ein einfaches Tabellenlayout geachtet werden, mit einer Kopfzeile und anschließenden Textzeilen. Es kann aber auch vorkommen, dass sich bestimmte Inhalte am besten im Tabellenformat anstatt in anderen Präsentationsformaten darstellen lassen und dass hierfür ein komplexeres Layout erforderlich ist. Unter Umständen sind mehrere Spalten umfassende Zellen oder mehrere Kopfzeilen nötig, um den Inhalt optimal zu vermitteln.
Komplexe Tabellen können Sie mit Hilfe des Tabellenobjekts oder durch Kombinieren von Teilformularobjekten erstellen. Das Tabellenobjekt enthält Funktionen zur Unterstützung des Designprozesses, z. B. Optionen zum Einfügen und Ändern der Größe von Spalten und Zeilen.
Abhängig von Ihrer Design-Erfahrung und Ihren Präferenzen können Sie zum Erstellen komplexer Tabellen Teilformularobjekte kombinieren. Sie können z. B. ein Teilformular mit zwei Zeilen erstellen und dieses Teilformular als Kopfzeile für die Tabelle festlegen und dann ein anderes Teilformular für die Tabellentextzeilen definieren.
Bei der Tabellenerstellung mit Teilformularobjekten anstelle von Tabellenobjekten sind ein paar zusätzliche Schritte erforderlich:
      •
      Weisen Sie jedem Teilformular den Typ „Position“ zu. Siehe Eigenschaften von Teilformularen: Registerkarte „Teilformular“.
      •
      Legen Sie in der Palette „Ein-/Ausgabehilfe“ für jedes Teilformular der Tabelle eine geeignete Teilformularrolle fest. Weisen Sie z. B. dem Teilformular, das als Tabellenüberschrift dienen soll, die Rolle „Kopfzeile“ zu. Siehe Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“.
      •
      Weisen Sie Zeilen, die Informationen über die Tabelle oder deren Inhalt enthalten, aber nicht als Teil der Tabelle anzusehen sind, die Teilformularrolle „Ohne“ zu. Der Zeileninhalt wird von der Bildschirmlesehilfe gelesen.
Die von der Bildschirmlesehilfe unterstützten Funktionen wirken sich auf den Lesevorgang bei einer komplexen Tabelle aus. Nehmen wir an, eine Tabelle enthält eine Kopfzeile und einen Abschnitt mit einer Kopfzeile. Wenn der Benutzer zu einer Textzeilenzelle im Tabellenabschnitt navigiert, wird der Text von der Bildschirmlesehilfe in der folgenden Reihenfolge gelesen:
      •
      Inhalt der entsprechenden Zelle in der Kopfzeile der Tabelle
      •
      Inhalt der entsprechenden Zelle in der Kopfzeile des Abschnitts
      •
      Inhalt der ausgewählten Zelle
Einige Bildschirmlesehilfen lesen u. U. nicht die Zellen in beiden Kopfzeilen.
Verwandte Themen
Einfache Tabellen barrierefrei machen


So machen Sie Optionsfelder barrierefrei

Beim Springen in eine Ausschlussgruppe liest die Bildschirmlesehilfe zunächst den Text für die Ausschlussgruppe und dann die Beschriftung für das aktive Optionsfeld.
Wenn ein sehbehinderter Benutzer mit der Tabulatortaste ein Optionsfeld ansteuert, muss die Bildschirmlesehilfe zwei Dinge lesen:
      •
      Eine allgemeine Beschreibung des Zwecks der Optionsfeldgruppe
      •
      Eine sinnvolle Beschreibung des Zwecks jedes Optionsfelds
Angenommen, ein Formular enthält eine Gruppe von Optionsfeldern für die Zahlung. Für die Ausschlussgruppe als Ganzes soll der Sprechtext „Select the method of payment“ (Zahlungsmethode auswählen) wiedergegeben werden. Für die einzelnen Schaltflächen sind Textwerte für „Cash“ (Bar), „Credit Card“ (Kreditkarte) und „Check“ (Scheck) erforderlich. Wenn der Benutzer mit der Tabulatortaste die Ausschlussgruppe und das erste Optionsfeld („Cash“) ansteuert, soll die Bildschirmlesehilfe den Objekttyp angeben und dann „Select the method of payment. Cash“ (Zahlungsmethode auswählen. Bar) vorlesen. Danach soll sie den Status angeben (aktiviert oder deaktiviert).
LiveCycle Designer enthält Optionen, mit denen Sprechtext für Bildschirmlesehilfen festgelegt werden kann. Benutzerdefinierten Bildschirmlesehilfen-Text und QuickInfos definieren Sie über die Palette „Ein-/Ausgabehilfe“. Darüber hinaus können Sie Beschriftungen und Objektnamen verwenden, die auf der Registerkarte „Bindung“ unter „Name“ angegeben wurden. In den meisten Fällen dürften die Beschriftungen der Optionsfelder auch für die Bildschirmlesehilfe brauchbaren Text enthalten.
So erstellen Sie mit den Schaltflächenbeschriftungen barrierefreie Optionsfelder
1.
Wählen Sie in der Palette „Hierarchie“ die gewünschte Ausschlussgruppe aus.
2.
Klicken Sie auf die Registerkarte der Palette „Ein-/Ausgabehilfe“ und geben Sie im Feld „Benutzerdef. Bildschirmlesehilfen-Text“ den Sprechtext für die Gruppe ein. Geben Sie beispielsweise Select a method of payment (Zahlungsmethode auswählen) ein.
3.
Wenn die Beschriftungen für die einzelnen Optionsfelder auch als Sprechtext brauchbar sind, aktivieren Sie in der Palette „Objekt“ die Registerkarte „Bindung“ und deaktivieren Sie das Kontrollkästchen „Elementwerte“.
So erstellen Sie mit einem festgelegten Elementwert barrierefreie Optionsfelder
1.
Wählen Sie in der Palette „Hierarchie“ die gewünschte Ausschlussgruppe aus.
2.
Klicken Sie auf die Registerkarte der Palette „Ein-/Ausgabehilfe“ und geben Sie im Feld „Benutzerdef. Bildschirmlesehilfen-Text“ den Sprechtext für die Gruppe ein. Geben Sie beispielsweise Select a method of payment (Zahlungsmethode auswählen) ein.
3.
Wählen Sie in der Palette „Hierarchie“ das erste Optionsfeld in der Gruppe aus.
4.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“. Doppelklicken Sie im Bereich „Element“ auf das Element und geben Sie einen sinnvollen Text für das ausgewählte Optionsfeld ein. Geben Sie beispielsweise Cash (Bar) ein.
5.
Wiederholen Sie die Schritte 3 und 4 für jedes Optionsfeld in der Ausschlussgruppe.
Verwandte Themen
Optionsfelder – Übersicht
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“
So legen Sie einen benutzerdefinierten Bildschirmlesehilfen-Text für ein Objekt fest


Listen barrierefrei machen

Wenn der Formularentwurf Listen enthält, die durch Verschachteln von Teilformularen im Formularentwurf entstanden sind, können Sie jedem Teilformular der Liste mit der Palette „Ein-/Ausgabehilfe“ eine entsprechende Teilformularrolle zuweisen. Die Bildschirmlesehilfe kann dann die Liste, die Anzahl der Listenelemente, die Verschachtelungsstufe und das Listenende ansagen.
Beispielsweise können Sie die Rolle „Liste“ dem obersten Teilformular zuweisen und die Rolle „Listenelement“ den verschachtelten Teilformularen, aus denen sich die Listenelemente zusammensetzen.
Verwandte Themen
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“
So legen Sie einen benutzerdefinierten Bildschirmlesehilfen-Text für ein Objekt fest


Bilder barrierefrei machen

Bilder können das Verständnis von Benutzern mit bestimmten Behinderungen verbessern. Viele Bildschirmlesehilfen können jedoch keine Grafiken lesen. Bilder können sich auf die Lesbarkeit Ihres Formulars durch Benutzer mit Sehbehinderungen negativ auswirken.
Wenn Sie Bilder verwenden möchten, sollten Sie für alle Bilder und Bildfeldobjekte Textbeschreibungen einfügen. Wenn ein Benutzer zu einem solchen Objekt navigiert, gibt die Bildschirmlesehilfe den Text wieder. Stellen Sie sicher, dass der Text das Objekt und seinen Zweck im Formular beschreibt.
Textbeschreibungen können Sie in Form von QuickInfos oder benutzerdefiniertem Bildschirmlesehilfen-Text über die Palette „Ein-/Ausgabehilfe“ hinzufügen. Sie können aber auch Textfelder, Beschriftungen oder Objektnamen verwenden, die auf der Registerkarte „Bindung“ unter „Name“ definiert werden.
Die Zugänglichkeit von Bildern in Ihren Formularen lässt sich jedoch nicht nur durch Textbeschreibungen für Bilder verbessern. Berücksichtigen Sie auch die folgenden allgemeinen Richtlinien:
      •
      Bilder sollten den Formularinhalt unterstützen und keine unnötigen Details enthalten.
      •
      Zur optimalen Lesbarkeit von farbigen Bildern sollten Sie kontrastreiche Farben verwenden.
      •
      Stellen Sie sicher, dass die Bildgröße nicht zu klein ist und das Bild problemlos gelesen werden kann.
Verwandte Themen
Bilder – Übersicht
Bildfelder – Übersicht
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“
Farbe in barrierefreien Formularen


Skripten barrierefrei machen

Bei der Gestaltung von Formularen kann der Entwickler Skripten verwenden, um den Gebrauchswert für den Benutzer zu erhöhen. Sie können die meisten Formularfelder und -objekte durch Skripten ergänzen. Beispielsweise haben Sie die Möglichkeit, einfache Skripten zu erstellen, um die Werte in einem interaktiven Formular in Abhängigkeit von den Benutzereingaben dynamisch zu aktualisieren.
Bei der Gestaltung von Skripten zur besseren Zugreifbarkeit sollten Sie die folgenden allgemeinen Richtlinien beachten:
      •
      Der Formularinhalt sollte keine optischen Störungen enthalten. Vermeiden Sie beispielsweise Funktionen, wodurch der Inhalt flackert, blinkt oder sich bewegt.
      •
      Stellen Sie sicher, dass Popup-Fenster nur bei vom Benutzer ausgelösten Aktionen angezeigt werden. Ebenso sollte der aktuelle Fokus des Formulars sich nur ändern und Inhalt nur dann erneut angezeigt werden, wenn dies vom Benutzer initiiert wurde. Mit dem Fokus des Formulars ist die aktuelle Ansicht des Benutzers gemeint. Wenn der Benutzer z. B. Felder in der unteren Hälfte des Formulars ausfüllt, darf der Fokus sich nicht in die obere linke Ecke des Formulars verschieben, wenn der Benutzer diese Positionsänderung nicht selbst ausführt.
      •
      Benutzer mit Behinderungen benötigen u. U. mehr Zeit zum Ausfüllen von Feldern. Legen Sie keine zeitliche Begrenzung für das Ausfüllen von Eingabefeldern fest.
      •
      Beachten Sie, dass clientseitige Skripten zu Konflikten mit Bildschirmlesehilfen und Tastaturen führen können, wenn das Skript den Fokus der Client-Anwendung ändert. So kann beispielsweise die Verwendung von „Change“- und „MouseEnter“-Ereignissen in Dropdown-Listen oder Listenfeldern ungewollte Aktionen auslösen. Clientseitige Skripten sollten so geschrieben werden, dass Konflikte mit Bildschirmlesehilfen und Tastaturen vermieden werden.
Verwandte Themen
Berechnungen und Skripten


Abschnitte in Formularen überspringen

Sie können den Benutzern die Möglichkeit geben, mit der Bildschirmlesehilfe bestimmte Abschnitte eines Formulars zu überspringen. Dazu platzieren Sie am Anfang verschiedener Formularabschnitte statische Textobjekte. Anschließend weisen Sie jedem der statischen Textobjekte über die Palette „Ein-/Ausgabehilfe“ die Teilformularrolle „Überschrift“ zu.
Wenn ein Benutzer in der Bildschirmlesehilfe JAWS die Taste „H“ drückt, springt die Bildschirmlesehilfe vom aktuellen Objekt zum nächsten statischen Textobjekt, dem im Formular die Rolle „Überschrift“ zugewiesen wurde.
Verwandte Themen
Eigenschaften von Ein-/Ausgabehilfen in der Palette „Ein-/Ausgabehilfe“
So legen Sie einen benutzerdefinierten Bildschirmlesehilfen-Text für ein Objekt fest


Sicherheitseinstellungen

Sichere Formulare
Digitale Unterschriften verwenden
Kennwortfelder verwenden
PDF-Sicherheitsoptionen verwenden


Sichere Formulare

Ein sehr wichtiger Aspekt bei der Erstellung interaktiver PDF-Formulare ist, sicherzustellen, dass die Formulare und die erfassten Daten sicher und geschützt sind. Folgende Funktionen und Merkmale in LiveCycle Designer bieten Sicherheitsoptionen für Ihre Formulare:
      •
      Mit den PDF-Sicherheitseinstellungen können Sie die Zugriffsmöglichkeiten der Benutzer auf PDF-Formulare steuern. Im Dialogfeld „Formulareigenschaften“ können Sie ein Kennwort festlegen, das die Benutzer eingeben müssen, um das Formular zu öffnen und auszufüllen. Sie können auch die verschiedenen Zugriffsebenen des Formulars beschränken. Beispielsweise können Sie es den Benutzern gestatten, Felder auszufüllen und eine Unterschrift zu leisten, es ihnen aber gleichzeitig verwehren, dem Formular Kommentare oder Seiten hinzuzufügen.
      •
      Mit Hilfe von digitalen Unterschriften können Sie den Unterzeichner authentifizieren und gewährleisten, dass das Formular nach dem Unterschreiben nicht mehr geändert werden kann. Um ein Feld für eine digitale Unterschrift zu einem Formularentwurf hinzuzufügen, können Sie ein Dokumentunterschriftsfeld oder eine mit einer Senden-Schaltfläche verknüpfte Datenunterschrift verwenden. Ein Dokumentunterschriftsfeld schützt das Erscheinungsbild der Formularobjekte und der darin enthaltenen Werte Datenunterschriften stellen die Integrität der Formulardaten sicher.
      •
      Mit Kennwortfeldern können Sie den Zugriff auf ein Formular steuern. Sie können die Zeichenmaskierung als eine Option für das Feld festlegen, so dass die Daten nicht auf dem Bildschirm angezeigt werden. Sie können definieren, ob das Kennwort optional, empfohlen oder erforderlich ist, und Sie können Meldungen einrichten, die den Benutzern entsprechende Hinweise geben. Alle Benutzereingaben können mit Hilfe von Skripten überprüft werden. Sie können Kennwortfelder auch an Datenquellen binden.
Verwandte Themen
PDF-Sicherheitsoptionen verwenden


Digitale Unterschriften verwenden

Digitale Unterschriften
So fügen Sie ein Dokumentunterschriftsfeld hinzu
So testen Sie ein Dokumentunterschriftsfeld
So fügen Sie eine Datenunterschrift zu einer Senden-Schaltfläche hinzu


Digitale Unterschriften

Sie können die Integrität von Formularen dadurch schützen, dass die Benutzer Formulare mit Hilfe von Zertifikaten digital unterschreiben. Sobald das Formular unterschrieben ist, kann der unterschriebene Teil nicht ohne Außerkraftsetzung der Unterschrift geändert werden. Die digitale Unterschrift ruft den Unterschriften-Handler eines Drittanbieters auf, der die erforderliche Funktionalität für digitale Unterschriften bereitstellt.
Die Prüfung der Unterschrift gewährleistet, dass die Daten nach dem Versand nicht manipuliert wurden. Wenn der Benutzer ein Formular unterschreibt, wird eine Meldungszusammenfassung der zu unterschreibenden Daten erstellt. Im Rahmen einer Berechnung wird der private Schlüssel des Benutzers mit den angegebenen Formulardaten kombiniert und mit ihnen verschlüsselt. Die Ausgabe ist eine digitale Unterschrift. Die digitale Unterschrift enthält die unterschriebenen Daten und die Zertifikatinformationen der Person, die das Formular unterschrieben hat.
Bei der Überprüfung der Unterschrift wird der öffentliche Schlüssel des jeweiligen Benutzers verwendet, um die unterschriebenen Daten zu entschlüsseln und den Digest-Wert abzurufen. Der neue Digest-Wert für das empfangene Dokument wird mit demselben Algorithmus berechnet, der für den Unterschriftsprozess verwendet wurde. Stimmen die beiden Digest-Werte nicht überein, steht fest, dass die Daten manipuliert wurden, da das Formular unterschrieben wurde und die Prüfung fehlschlägt.
Digitale Unterschriften binden auch Zertifikate an die unterschriebenen Daten. Das zur Unterschrift gehörende Zertifikat kann authentifiziert werden, um die Identität desjenigen zu bestätigen, der die Daten unterschrieben hat.
Der Benutzer muss über ein digitales Zertifikat eines entsprechenden Zertifikatausstellers verfügen, um das Formular zu unterschreiben. Adobe-Unterschriften unterstützen den Public Key Cryptography Standard (PKCS) #7 und verwenden die Hash-Algorithmen RSA MD5, RSA SHA-1 oder DSA SHA-1.
LiveCycle Designer stellt die beiden folgenden Typen von digitalen Unterschriften bereit.
Dokumentunterschriften
Dokumentunterschriften schützen das Erscheinungsbild von Formularobjekten und den darin enthaltenen Werten. Um eine Dokumentunterschrift zu erstellen, fügen Sie ein Dokumentunterschriftsfeld zum Formularentwurf hinzu. Sie können festlegen, ob ein Dokumentunterschriftsfeld auf ein gesamtes Formular oder auf eine Sammlung von Objekten in einem Formular angewendet wird. Standardmäßig wird es auf ein gesamtes Formular angewendet. Wenn die Dokumentunterschrift auf eine Sammlung von Formularobjekten angewendet werden soll, muss der Aussteller der Unterschrift Acrobat oder Adobe Reader 8.0 oder höher verwenden.
Wenn die Dokumentunterschrift auf eine Sammlung von Objekten angewendet wird, werden statische Objekte wie Kreise und Rechtecke ignoriert. Die Anwendung erfolgt nur für Schaltflächen, Kontrollkästchen, Datums-/Uhrzeitfelder, Dezimalfelder, Dropdown-Listen, Bildfelder, Listenfelder, numerische Felder, Papierformular-Barcodes, Kennwortfelder, Optionsfelder, andere Dokumentunterschriftsfelder und Textfelder.
Um das Formular zu unterschreiben, muss der Benutzer nur auf das Dokumentunterschriftsfeld klicken. Wenn die Dokumentunterschrift auf eine Sammlung von Formularobjekten angewendet wird, werden die in der Dokumentunterschrift angegebenen Objekte gesperrt und als schreibgeschützt markiert. Durch das Sperren der Objekte wird verhindert, dass die Formularempfänger die Objektwerte nach dem Unterschreiben des Dokuments ändern.
Datenunterschriften
Datenunterschriften sichern die Formulardaten und gewährleisten deren Integrität bei der Übertragung. Um eine Datenunterschrift zu erstellen, fügen Sie eine Senden-Schaltfläche, eine E-Mail-Senden-Schaltfläche oder eine HTTP-Senden-Schaltfläche hinzu, und wählen Sie in der Palette „Objekt“ die Option „Sendung unterschreiben“. Der Unterzeichner muss Acrobat oder Adobe Reader 8.0 verwenden, damit die Daten unterschrieben werden können.
Datenunterschriften können nur auf die Formulardaten oder auch auf die gesamte Sendung, einschließlich von Anlagen wie Anmerkungen, Dokumentunterschriften oder PDF-Dokumenten, angewendet werden.
Um die Formulardaten zu unterschreiben, klickt der Benutzer auf die Senden-Schaltfläche. Wenn der Benutzer auf die Schaltfläche klickt, muss er sein Unterschriftszertifikat angeben, damit seine digitale Unterschrift vor dem Senden auf die Formulardaten angewendet wird.
Verwandte Themen
Dokumentunterschriftsfelder – Übersicht
Schaltflächen – Übersicht
Info über das Senden von Daten mit Hilfe einer Schaltfläche


So fügen Sie ein Dokumentunterschriftsfeld hinzu

LiveCycle Designer bietet ein integriertes Dokumentunterschriftsfeld, das Sie zu einem Formular hinzufügen können, um Benutzern die Möglichkeit zu geben, die von ihnen eingegebenen Daten zu unterschreiben. Die Dokumentunterschrift wird standardmäßig auf alle Objekte im Formular angewendet. Wenn die Dokumentunterschrift auf eine Sammlung von Objekten im Formular angewendet werden soll, müssen Sie die Sammlung zunächst erstellen und anschließend auf der Registerkarte „Dokumentunterschrift“ der Palette „Objekt“ angeben.
Wird die Dokumentunterschrift auf eine Sammlung von Objekten angewendet, dann werden durch das Unterschreiben des Dokuments auch die Felder in der Sammlung gesperrt. Wenn Sie mehr als ein Dokumentunterschriftsfeld hinzufügen, um verschiedene Abschnitte des Formulars zu schützen, wird die erste Objektsammlung nach dem Unterschreiben des ersten Unterschriftsfeldes gesperrt. Es können dann nur noch die verbleibenden Felder im Formular ausgefüllt werden.
Wird eine Dokumentunterschrift auf eine Sammlung von Objekten angewendet, schützt sie auch die in den Objekten enthaltenen Werte. Die Dokumentunterschrift kann auch das Erscheinungsbild der Objekte in der Sammlung schützen, so dass das ursprüngliche Erscheinungsbild der Objekte beim Öffnen des Formulars wiederhergestellt wird. Die Fähigkeit zum Schützen des Erscheinungsbildes der Objekte ist von der Option „Beim Speichern Skriptänderungen an Formular beibehalten“ auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ abhängig. Ist diese Option auf die Standardeinstellung „Automatisch“ eingestellt, wird das Erscheinungsbild der Objekte automatisch geschützt. Ist die Option auf „Manuell“ eingestellt, müssen Sie ein Skript erstellen, um das Erscheinungsbild der Objekte wiederherzustellen.
Dokumentunterschriftsfelder dürfen nicht wiederholbar sein. Sie sollten nicht in ein wiederholbares Teilformularobjekt eingefügt werden. Ein Formular mit wiederholbaren Dokumentunterschriftsfeldern ist nicht gültig und verursacht Probleme in Acrobat. Das Unterschriftsfeld wird hier unter Umständen nicht angezeigt.
Wenn die Dokumentunterschrift auf eine Sammlung von Objekten angewendet wird, dürfen die Objekte der Sammlung nicht wiederholbar sein, da sich die Anzahl der Objekte ändern kann und somit die Dokumentunterschrift ungültig werden lässt. Sie können die wiederholbaren Objekte entweder aus der Sammlung entfernen oder stattdessen eine Datenunterschrift verwenden.
Um das Formular zu unterschreiben, muss der Benutzer nur auf das Dokumentunterschriftsfeld klicken. Der Unterzeichner muss Acrobat oder Adobe Reader 8.0 oder höher verwenden, damit eine Sammlung von Formularobjekten unterschrieben werden kann.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie das Dokumentunterschriftsfeld auf den Formularentwurf.
2.
(Optional) Um die Dokumentunterschrift auf eine Sammlung von Feldern im Formular anzuwenden, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Dokumentunterschrift“, und wählen Sie „Felder nach dem Unterschreiben sperren“.
3.
(Optional) Erstellen Sie die Sammlung und wählen Sie sie aus:
      •
      Wählen Sie „Sammlung - Neu/verwalten“.
      •
      Klicken Sie im Dialogfeld „Sammlungsliste“ auf „Neu“, geben Sie einen Namen für die Sammlung ein, drücken Sie die Eingabetaste, und klicken Sie auf „Ändern“.
      •
      Wählen Sie im Dialogfeld „Sammlungseditor“ die Objekte aus, die Sie in die Sammlung einschließen möchten, und klicken Sie auf „OK“.
      •
      Klicken Sie im Dialogfeld „Sammlungsliste“ auf „Schließen“.
      •
      Wählen Sie die Sammlung in der Liste aus.
4.
(Optional) Wenden Sie die Unterschrift auf die Felder in und außerhalb der Sammlung an:
      •
      Um die Unterschrift auf die Felder in der Sammlung anzuwenden, wählen Sie „Alle Felder in der Sammlung“.
      •
      Um die Unterschrift auf die Felder außerhalb der Sammlung anzuwenden, wählen Sie „Alle Felder außerhalb der Sammlung“.
5.
(Optional) Klicken Sie auf „Einstellungen“, um optionale Sicherheitseinstellungen wie einen Unterschriften-Handler oder eine Zertifikatssperrliste zu definieren.
6.
Verwenden Sie die Paletten, um das Erscheinungsbild des Dokumentunterschriftsfeldes anzupassen.
7.
Speichern Sie den Formularentwurf.
Verwandte Themen
Dokumentunterschriftsfelder – Übersicht
Eigenschaften von Dokumentunterschriftsfeldern: Registerkarte „Dokumentunterschrift“
Info über Formularobjektsammlungen
Dialogfeld „Sammlungseditor“
Dialogfeld „Sammlungsliste“


So testen Sie ein Dokumentunterschriftsfeld

Verwenden Sie die Registerkarte „PDF-Vorschau“, um zu überprüfen, ob sich das Dokumentunterschriftsfeld erwartungsgemäß verhält. Stellen Sie vor dem Testen des Formularentwurfs sicher, dass Sie die Standardoptionen für die Vorschau eines interaktiven Formulars im Dialogfeld „Formulareigenschaften“ aktiviert haben.
Der Unterzeichner muss Acrobat oder Adobe Reader 8.0 oder höher verwenden, damit eine Sammlung von Formularobjekten unterschrieben werden kann.
1.
Klicken Sie auf die Registerkarte „PDF-Vorschau“, um den Formularentwurf als interaktives PDF-Formular anzuzeigen.
2.
Klicken Sie in das Dokumentunterschriftsfeld.
3.
Klicken Sie im Warndialogfeld auf „Unterzeichnung fortsetzen“.
4.
Wählen Sie im Dialogfeld „Datenaustauschdatei“ eine digitale Unterschrift oder klicken Sie auf „Digitale ID hinzufügen“, um eine neue ID zu erstellen.
Verwandte Themen
Dokumentunterschriftsfelder – Übersicht
Info über die Vorschau und das Testen von Formularen


So fügen Sie eine Datenunterschrift zu einer Senden-Schaltfläche hinzu

Sie können eine Senden-Schaltfläche so konfigurieren, dass eine Datenunterschrift erstellt wird, bevor die Daten übertragen werden, damit die Benutzer die Formulardaten beim Senden des Formulars unterschreiben können. Datenunterschriften gewährleisten die Datenintegrität und authentifizieren den Unterzeichner bei der Übertragung. Sie können Datenunterschriften beispielsweise verwenden, um die Formulardaten bei automatischen Transaktionen zu schützen.
Der Unterzeichner muss Acrobat oder Adobe Reader 8.0 verwenden, damit die Daten unterschrieben werden können.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“, und ziehen Sie eine Schaltfläche, E-Mail-Senden-Schaltfläche oder HTTP-Senden-Schaltfläche auf den Formularentwurf.
2.
Verknüpfen Sie in der Palette „Objekt“ eine Datenunterschrift mit der Schaltfläche:
      •
      Wenn Sie eine Standardschaltfläche verwenden, wählen Sie auf der Registerkarte „Feld“ den Kontrolltyp „Absenden“ aus, und wählen Sie anschließend auf der Registerkarte „Absenden“ die Option „Sendung unterschreiben“.
      •
      Wenn Sie eine E-Mail- oder HTTP-Senden-Schaltfläche verwenden, wählen Sie auf der Registerkarte „Feld“ die Option „Sendung unterschreiben“.
3.
(Optional) Klicken Sie auf „Einstellungen“, um optionale Sicherheitseinstellungen zu definieren (z. B., ob die Unterschrift nur auf die Daten oder auf die gesamte Sendung angewendet werden soll).
4.
Verwenden Sie die Paletten, um das Erscheinungsbild der Senden-Schaltfläche anzupassen.
5.
Speichern Sie den Formularentwurf.
Verwandte Themen
E-Mail-Senden-Schaltflächen – Übersicht
HTTP-Senden-Schaltflächen – Übersicht
Info über das Senden von Daten mit Hilfe einer Schaltfläche


Kennwortfelder verwenden

Kennwortfelder in interaktiven Formularen
Kennwortfeld in einem interaktiven Formular hinzufügen
Zeichen für die Kennwortanzeige ändern
Eingabeformat und Überprüfungsmeldung festlegen


Kennwortfelder in interaktiven Formularen

Sie können den Zugriff auf ein Formular mit Hilfe eines Kennwortfelds und eines Skripts steuern. Das Kennwortfeld bietet mehrere Optionen:
      •
      Eine Zeichenmaskierungsoption, mit der Sie ein Zeichen festlegen können, das die von dem Benutzer eingegebenen Daten verdeckt. Das Kennwort selbst wird im Kennwortfeld nicht angezeigt.
      •
      Ein Bearbeitungsmuster, um sicherzustellen, dass der Benutzer das Kennwort in einem gültigen Format eingibt.
      •
      Ein Überprüfungsmuster und eine Überprüfungsmeldung, um den Benutzer zu einer erneuten Eingabe des Kennworts aufzufordern, wenn das Format kein gültiges Muster ist.
      •
      Eine Einstellung, die das Kennwortfeld als erforderlich, empfohlen oder optional angibt und eine Meldung zur Aufforderung von Benutzern enthält, einen empfohlenen oder erforderlichen Wert einzugeben.
Die Erfassung von Informationen und die Anzeige von Zeichen im Feld dienen nur visuellen Zwecken. Es wird nicht versucht, den Wert des Feldes vor den Programmierschnittstellen oder bei der Übergabe von Daten zu verbergen. Wenn Sie Ihre Informationen sichern möchten, müssen Sie eine sichere Verknüpfung verwenden (wie z. B. SSL), um die Daten für die Übertragung zu verschlüsseln.
Verwandte Themen
Kennwortfelder – Übersicht


Kennwortfeld in einem interaktiven Formular hinzufügen

Sie können Kennwortfelder zu interaktiven Formularen hinzufügen.
1.
Klicken Sie in der Palette „Bibliothek“ auf die Kategorie „Standard“ und ziehen Sie das Objekt „Kennwortfeld“ auf den Formularentwurf.
2.
Legen Sie mit Hilfe der Paletten „Layout“, „Schrift“, „Absatz“ und „Rand“ die gewünschten Eigenschaften für das Kennwortfeld fest.
3.
Fügen Sie ein Bearbeitungsmuster hinzu, wenn Sie sicherstellen möchten, dass der Benutzer das Kennwort in einem speziellen Format eingibt.
4.
Fügen Sie ein Überprüfungsmuster mit einer Meldung hinzu, wenn Sie die von dem Benutzer eingegebenen Daten überprüfen und eine Meldung anzeigen möchten, falls diese Daten nicht korrekt sind. Das Überprüfungsmuster muss mit dem Bearbeitungsmuster identisch sein.
5.
(Optional) Ändern Sie das Standard-Maskierungszeichen.
6.
Fügen Sie Bindungsinformationen nach Bedarf hinzu.
7.
Speichern und testen Sie den Formularentwurf.
Verwandte Themen
Kennwortfelder – Übersicht


Zeichen für die Kennwortanzeige ändern

Das Zeichen für Kennwortanzeige, das standardmäßig angezeigt wird, wenn ein Benutzer ein Kennwort eingibt, ist das Sternchensymbol (*). Sie können dieses Symbol in der Option „Zeichen für Kennwortanzeige“ auf der Registerkarte „Feld“ der Palette „Objekt“ ändern.
      *
      Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“, wählen Sie unter „Zeichen für Kennwortanzeige“ das Standardsymbol (*) aus, und geben Sie ein Ersetzungszeichen ein (z. B. #).
Verwandte Themen
Kennwortfelder – Übersicht


Eingabeformat und Überprüfungsmeldung festlegen

Sie können ein Bearbeitungsmuster festlegen, um sicherzustellen, dass der Benutzer das Kennwort in einem gültigen Format eingibt. Sie können auch ein Überprüfungsmuster und eine Meldung einfügen, um den Benutzer zur erneuten Eingabe des Kennworts aufzufordern, wenn das Format kein gültiges Muster ist. Die von Ihnen festgelegten Bearbeitungs- und Überprüfungsmuster müssen identisch sein. Wenn ein Benutzer ein neues Kennwort eingibt, wird es mit dem Überprüfungsmuster verglichen. Wenn das Muster nicht übereinstimmt, werden die Änderungen nicht akzeptiert.
Sie können ein Überprüfungsmuster auch dynamisch mit einem Wert aus einer Datenquelle füllen. Dadurch können Sie sicherstellen, dass Benutzer den richtigen Wert in das Feld eingeben.
1.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“, und geben Sie im Feld „Bearbeitungsmuster“ ein gültiges Bearbeitungsmuster ein.
Dieses Muster beschreibt die Art, wie ein Benutzer das Kennwort eingeben muss. Dieses Muster wird im Formular nicht visuell dargestellt. Das Formular akzeptiert die Daten nur, wenn der Benutzer sie im richtigen Format eingibt.
Um die Werteigenschaften eines Kennwortfelds zu definieren, müssen Sie zuerst das Kennwortfeld im Formularentwurf auswählen. Die Werteigenschaften können auf der Registerkarte „Wert“ der Palette „Objekt“ bearbeitet werden.
Wird ein Wert empfohlen, dann wird die Meldung ein Mal angezeigt. Wenn ein Wert erforderlich ist, wird die Meldung wiederholt angezeigt, bis der Benutzer einen Wert eingibt.
2.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Wert“ und gehen Sie folgendermaßen vor:
      •
      Wählen Sie in der Liste „Überprüfungsmuster“ ein Überprüfungsmuster oder geben Sie ein benutzerdefiniertes Muster ein. Die Einstellung des Überprüfungsmusters muss mit der Einstellung der Bearbeitungsmusteroption auf der Registerkarte „Feld“ übereinstimmen.
      •
      Geben Sie im Feld „Überprüfungsmuster-Meldung“ eine Meldung ein, die Benutzer auffordert, den richtigen Wert einzugeben.
3.
Um eine Fehlermeldung zur Laufzeit zu generieren, aktivieren Sie die Option „Fehler“.
Verwandte Themen
Kennwortmuster
Kennwortfelder – Übersicht
So füllen Sie eine Überprüfungsmuster-Meldung dynamisch aus


PDF-Sicherheitsoptionen verwenden

PDF-Sicherheitsoptionen
Kennwort zum Öffnen eines PDF-Formulars festlegen
Drucken in einem PDF-Formular beschränken
Bearbeiten in einem PDF-Formular beschränken
Textzugriff für Bildschirmlesehilfen in sicheren Formularen aktivieren


PDF-Sicherheitsoptionen

Wenn Sie interaktive PDF-Formulare veröffentlichen, bietet es sich an, einige der Funktionen einzuschränken, die in PDF-Formularen normalerweise verfügbar sind. Beispielsweise können Sie in einem PDF-Formular normalerweise Kommentare hinzufügen, Seiten einfügen und löschen, das Formular unterschreiben, Text kopieren und Kopien des Formulars speichern.
Über das Menü „Datei“ können Sie das Dialogfeld „Formulareigenschaften“ aufrufen und dann mit Hilfe der PDF-Sicherheitsoptionen auf der Registerkarte „PDF-Schutz“ den Zugriff auf bestimmte Funktionen einschränken. Folgende Optionen können Sie deaktivieren:
      •
      Drucken von Formularen
      •
      Öffnen von Formularen ohne Kennworteingabe
      •
      Einfügen, Extrahieren oder Drehen von Seiten
      •
      Hinzufügen von Kommentaren
      •
      Hinzufügen von Unterschriften
      •
      Kopieren von Text und Bildern
      •
      Normaltext-Metadaten
Wenn Sie den Zugriff auf PDF-Formularfunktionen beschränken, sollten Sie bedenken, dass Sie damit möglicherweise auch die Fähigkeit von Bildschirmlesehilfen beeinträchtigen, die mit Tags versehenen PDF-Elemente in der Datei zu lesen. Eine Bildschirmlesehilfe ist eine softwarebasierte Technologie, die es Benutzern mit Seh- oder anderen Behinderungen ermöglicht, mit Computersoftware zu arbeiten. Damit das Formular für diese Benutzer verfügbar ist, sollten Sie den Textzugriff für Bildschirmlesehilfen aktivieren.
Verwandte Themen
PDF-Sicherheitsoptionen verwenden


Kennwort zum Öffnen eines PDF-Formulars festlegen

Sie können ein Kennwort festlegen, das ein Benutzer eingeben muss, um ein PDF-Formular zu öffnen. Dieses Verfahren umfasst zwei Schritte: Zuerst geben Sie an, dass ein Kennwort erforderlich ist; dann geben Sie das Kennwort ein, das der Benutzer eingeben muss, wenn er das Formular öffnet.
1.
Wählen Sie „Datei“ > „Formulareigenschaften“.
2.
Klicken Sie auf die Registerkarte „PDF-Schutz“.
3.
Aktivieren Sie die Option „Kennwort zum Öffnen des Dokuments erforderlich“, und klicken Sie auf „OK“.
4.
Speichern Sie das Formular als Adobe PDF-Formular (*.pdf).
5.
Gehen Sie im Dialogfeld „Kennwort zum Öffnen des Dokuments festlegen“ folgendermaßen vor:
      •
      Geben Sie im Feld „Kennwort zum Öffnen des Dokuments“ ein Kennwort ein.
      •
      Geben Sie das Kennwort im Feld „Bestätigen“ erneut ein.
      •
      Klicken Sie auf „OK“.
6.
Schließen Sie den Formularentwurf.
Verwandte Themen
PDF-Sicherheitsoptionen verwenden


Drucken in einem PDF-Formular beschränken

Sie können verhindern, dass Benutzer ein PDF-Formular ausdrucken. Sie können festlegen, ob das Formular gedruckt werden kann und ob es mit minimaler Auflösung oder mit hoher Auflösung gedruckt werden kann.
1.
Wählen Sie „Datei“ > „Formulareigenschaften“.
2.
Klicken Sie auf die Registerkarte „PDF-Schutz“.
3.
Wählen Sie im Bereich „Berechtigungen“ die Option „Kennwort verwenden, um die Druck- und Bearbeitungsfunktionen des Dokuments sowie die Sicherheitseinstellungen zu begrenzen“.
4.
Wählen Sie in der Liste „Zulässiges Drucken“ eine der folgenden Möglichkeiten:
      •
      Nicht zulässig
      •
      Geringe Auflösung (150 dpi)
      •
      Hohe Auflösung
Verwandte Themen
PDF-Sicherheitsoptionen verwenden


Bearbeiten in einem PDF-Formular beschränken

Sie können bestimmte Bearbeitungsfunktionen für PDF-Formulare deaktivieren:
      •
      Einfügen, Extrahieren und Drehen von Seiten
      •
      Hinzufügen von Kommentaren
      •
      Hinzufügen von Unterschriften
      •
      Kopieren von Text und Bildern
      •
      Aktivieren von Normaltext-Metadaten
1.
Wählen Sie „Datei“ > „Formulareigenschaften“.
2.
Klicken Sie auf die Registerkarte „PDF-Schutz“.
3.
Wählen Sie im Bereich „Berechtigungen“ die Option „Kennwort verwenden, um die Druck- und Bearbeitungsfunktionen des Dokuments sowie die Sicherheitseinstellungen zu begrenzen“.
4.
Wählen Sie in der Liste „Zulässiges Drucken“ eine der folgenden Möglichkeiten:
      •
      Seiten einfügen, löschen und drehen
      •
      Formularfelder ausfüllen und unterschreiben
      •
      Formularfelder kommentieren, ausfüllen und unterschreiben
      •
      Alles außer Seiten extrahieren
5.
Wählen Sie eine oder beide der folgenden Optionen aus:
      •
      Kopieren von Text, Bildern und anderem Inhalt zulassen
      •
      Normaltext-Metadaten aktivieren
Verwandte Themen
PDF-Sicherheitsoptionen verwenden


Textzugriff für Bildschirmlesehilfen in sicheren Formularen aktivieren

Wenn Sie Optionen zur Beschränkung des Zugriffs auf PDF-Funktionen einstellen möchten, sollten Sie beachten, dass diese Optionen auch die Fähigkeit von Bildschirmlesehilfen zum Lesen von getaggtem PDF-Material in Ihrem Formular beeinträchtigen können.
Um sicherzustellen, dass Ihre Formulare weiterhin für Bildschirmlesehilfen barrierefrei bleiben, müssen Sie sich vergewissern, dass die Option „Textzugriff für Bildschirmlesehilfen“ aktiviert ist.
1.
Wählen Sie „Datei“ > „Formulareigenschaften“.
2.
Klicken Sie auf die Registerkarte „PDF-Schutz“, und führen Sie im Bereich „Berechtigungen“ die folgenden Schritte aus:
      •
      Wählen Sie „Kennwort verwenden, um die Druck- und Bearbeitungsfunktionen des Dokuments sowie die Sicherheitseinstellungen zu begrenzen“.
      •
      Wählen Sie „Textzugriff für Bildschirmlesehilfen für Sehbehinderte aktivieren“.
Verwandte Themen
PDF-Sicherheitsoptionen verwenden


Formularerstellung mit Blick auf Leistungsoptimierung

Leistung
Allgemeine Überlegungen zum Entwerfen mit Blick auf die Leistung
Objekte verwenden
Daten mit Blick auf Leistungsoptimierung strukturieren
Schriftauswahl mit Blick auf die Leistung
Leistungsaspekte beim Importieren von Formularen
Leistungsaspekte bei barrierefreien Formularen
Leistungsaspekte bei Skripten
Leistungsaspekte bei Ausdrücken im XML-Formularobjektmodell
Warn- und Fehlermeldungen behandeln mit Blick auf Leistungsoptimierung


Leistung

Die Leistung beim Wiedergeben (Rendern) und Verwenden von Formularen wird von vielen Faktoren beeinflusst, unter anderem von der Art des Formulars. Nicht interaktive Formulare können schneller wiedergegeben werden als interaktive Formulare.
Weitere Faktoren, die sich auf die Leistung auswirken, sind etwa die im Formular verwendeten Schriften sowie die Anzahl, Art und Komplexität von Objekten. Bei Formularen, die an Datenquellen gebunden sind, beeinflusst auch die Struktur der Daten die Leistung.
LiveCycle Designer bietet zahlreiche Optionen zum Entwerfen von Formularen. Häufig können Sie mit verschiedenen Designoptionen dieselben Ergebnisse erzielen. Sie sollten daher während des Entwerfens die Auswirkungen der einzelnen Optionen auf die Leistung beachten.
Verwandte Themen
Allgemeine Überlegungen zum Entwerfen mit Blick auf die Leistung


Allgemeine Überlegungen zum Entwerfen mit Blick auf die Leistung

Zahlreiche Faktoren wirken sich auf die Leistung aus, einer der wichtigsten ist jedoch die Dateigröße. Zur Leistungsoptimierung sollten Formulare in möglichst kleinen Dateien umgesetzt sein.
Die Dateigröße von Formularen beeinflusst die Leistung, wenn der Server Formulare wiedergibt (rendert), wenn Formulare über langsame Kommunikationskanäle übertragen werden oder wenn Formulare im Rahmen von Nearlinespeicherlösungen gespeichert oder abgerufen werden.
Beachten Sie diese allgemeinen Tipps, um die Dateigröße von Formularen zu verkürzen:
      •
      Vermeiden Sie – insbesondere bei Feldobjekten – den Einsatz von Schriften, die eingebettet werden müssen. Eingebettete Schriften können nicht in Untergruppen eingefügt werden.
      •
      Verwenden Sie statt verknüpfter Bilder eingebettete Bilder. In der Standardeinstellung werden Bilder verknüpft.
      •
      Verwenden Sie bei Farben Palette-Bilder oder Monochrom-Bilder. Vermeiden Sie den Einsatz von Formaten mit 24-Bit-Farben.
      •
      Beachten Sie, dass die Erstellung von barrierefreien Formularen die Leistung beeinträchtigt.
      •
      Verwenden Sie in Formularen immer möglichst wenige und möglichst einfache Objekte.
Beachten Sie diese allgemeinen Tipps, um bei interaktiven Formularen die Leistung zu verbessern:
      •
      Wählen Sie bei Formularen, die Daten an LiveCycle Forms senden, das XML-Daten-Format. Für andere Formate, wie etwa PDF, ist mehr Bandbreite und Verarbeitungszeit erforderlich. Siehe Info über das Senden von Daten mit Hilfe einer Schaltfläche.
      •
      Aktivieren Sie die Formular-Zwischenspeicherung, um die Leistung beim Wiedergeben eines Formulars zu erhöhen. Beim Zwischenspeichern von Formularen werden die Daten mit einer vorgenerierten Präsentation zusammengeführt. Damit LiveCycle Forms Formulare mit festem Layout zwischenspeichert, müssen Sie die Option zur Formular-Zwischenspeicherung in LiveCycle Designer für jedes erstellte Formular auswählen. Siehe Formular-Zwischenspeicherung.
Beachten Sie diese allgemeinen Tipps, um bei nicht interaktiven Formularen die Leistung zu verbessern:
      •
      Vermeiden Sie Überprüfungsmuster und andere interaktive Formularmerkmale wie Dateneingabeprüfungen und Bearbeitungsmasken.
Derartige Merkmale bewirken, dass LiveCycle Forms interaktive Formulare wiedergibt. Im Allgemeinen sind die Dateigrößen bei nicht interaktiven Formularen kleiner. Daher können diese Formulare schneller wiedergegeben werden als interaktive Formulare.
Wenn das Formular gedruckt werden soll, bieten interaktive Merkmale keinen zusätzlichen Nutzen. LiveCycle Designer kann bei Formularen, die an XML-Schemas gebunden sind, beispielsweise für bestimmte Objekte Überprüfungsskripten generieren. Bei interaktiven Formularen sorgen diese Überprüfungsskripten dafür, dass die eingegebenen Daten der Spezifikation für das betreffende Schema entsprechen. Mit einem Überprüfungsskript kann beispielsweise geprüft werden, ob es sich bei einem angegebenen Wert für ein numerisches Objekt um eine Ganzzahl zwischen 4 und 9 handelt. Bei nicht interaktiven Formularen sind keine Benutzereingaben möglich. Daher werden die Überprüfungsskripten nicht verwendet. Wenn Sie die Generierung dieser Skripten deaktivieren, wird die Leistung verbessert, da die Verarbeitung der Skriptausführung entfällt. Siehe So legen Sie Feldgenerierungsoptionen fest.
      •
      Sammeln Sie Formulare für die Stapelverarbeitung.
Wenn mehrere Exemplare eines Formulars wiedergegeben werden, beispielsweise Rechnungen für unterschiedliche Kunden, sammeln Sie die Daten für alle Exemplare in einer einzigen Datendatei und geben Sie die einzelnen Formulare aus dieser Datei wieder. Dieser Ansatz ist effizienter als die Einzelverarbeitung von Formularen. Bei der Stapelverarbeitung unterschiedlicher Formulare sollten Sie die Formulare vor der Wiedergabe jedoch gruppieren. Wenn beispielsweise Rechnungen und Ladelisten gleichzeitig ausgeführt werden, gruppieren Sie zunächst alle Rechnungen und führen Sie sie aus, dann alle Ladelisten.
Verwandte Themen
Leistung
Leistung im Zusammenhang mit Bildern optimieren
Bilder – Übersicht
Leistungsaspekte bei barrierefreien Formularen
Tipps zum Verringern der Anzahl von Objekten
Tipps zum Verringern der Komplexität von Objekten


Objekte verwenden

Leistung im Zusammenhang mit Bildern optimieren
Leistung im Zusammenhang mit Optionsauswahlen optimieren
Leistung im Zusammenhang mit Teilformularen optimieren
Leistung im Zusammenhang mit Textfeldern optimieren
Leistung bei Objekten auf Masterseiten und auf Seiten
Tipps zum Verringern der Anzahl von Objekten
Tipps zum Verringern der Komplexität von Objekten


Leistung im Zusammenhang mit Bildern optimieren

Für Bilder ist bei der Wiedergabe (beim Rendern) des Formulars zusätzliche Verarbeitungszeit erforderlich. Wenn Sie Bilder einsetzen möchten, wählen Sie zur Minimierung der Dateigröße kompakte Dateiformate und die kleinstmöglichen Bildmaße. Bringen Sie Bilder auf die gewünschte Größe, bevor Sie sie in das Formular einfügen. Wenn Bilder einmal in das Formular eingefügt wurden, sollten Sie ihre Größe nicht mehr ändern.
Achten Sie darauf, dass Ecken rechtwinklig sind und Linien exakt horizontal bzw. vertikal verlaufen, damit die Leistung bei der Wiedergabe des Formulars optimiert wird. Linien, die exakt horizontal oder vertikal erscheinen, weisen manchmal eine leichte Neigung auf.
In der Palette „Layout“ können Sie die Neigung horizontaler und vertikaler Linien überprüfen. Die Option „Höhe“ steht für die Neigung einer horizontalen Linie, die Option „Breite“ für die Neigung einer vertikalen Linie. Im folgenden Beispiel ist eine vertikale Linie geringfügig um etwa 0,5 Millimeter geneigt. Mit einer Breite von 0 Millimeter wird die Linie exakt vertikal.
Verwandte Themen
Allgemeine Überlegungen zum Entwerfen mit Blick auf die Leistung
Leistung im Zusammenhang mit Optionsauswahlen optimieren


Leistung im Zusammenhang mit Optionsauswahlen optimieren

Bei einigen Objekten stehen unterschiedliche, einander ausschließende Optionen zur Auswahl: Kontrollkästchen sowie Listen- und Optionsfelder. Listenfelder und Kontrollkästchen werden schneller wiedergegeben als Optionsfelder.
Verwandte Themen
Leistung im Zusammenhang mit Bildern optimieren
Leistung im Zusammenhang mit Teilformularen optimieren


Leistung im Zusammenhang mit Teilformularen optimieren

In LiveCycle Designer gibt es einerseits Textbausteinobjekte (statische Objekte) wie Text, Linien und Bilder, andererseits Objekte mit variablem Inhalt wie Text- und Bildfelder.
Interaktive Formulare können beispielsweise statische Textbezeichnungen enthalten, die dem Benutzer Informationen bieten, und Textfeldobjekte, die Informationen vom Benutzer erfassen.
Ein Teilformular ist ein Objekt mit Inhalt. Teilformulare sind häufig nach den Strukturen der jeweils daran gebundenen Daten gruppiert. Durch die Möglichkeit, sich wiederholende, optionale und bedingte Datengruppen an Teilformulare zu binden und dadurch einen Skripteinsatz überflüssig zu machen, wird das Risiko von Designfehlern verringert.
Sie können beispielsweise ein Teilformular erstellen, das Objekte für sich wiederholende Datengruppen enthält. Bei der Wiedergabe des Formulars werden von LiveCycle Forms so viele Exemplare des Teilformulars erstellt, wie es für die Darstellung aller Datengruppen notwendig ist.
Beachten Sie beim Einsatz von Teilformularen die folgenden Hinweise zur Leistungsoptimierung:
      •
      Wiederholte und verschachtelte Teilformulare beanspruchen bei der Formularwiedergabe zusätzliche Verarbeitungsleistung. Vermeiden Sie den Einsatz, sofern alternative Optionen nicht noch stärkere Leistungseinbußen bewirken. Ein wiederholtes Teilformular kann unter Umständen beispielsweise mehrere wiederholte Objekte ersetzen.
      •
      Wenn in Teilformularen Seitenumbrüche zugelassen sind, ist zusätzliche Verarbeitungsleistung erforderlich, selbst wenn von LiveCycle Forms keine Seitenumbrüche angewendet werden. Position, Größe oder Inhalt eines Teilformulars kann beispielsweise einem Seitenumbruch vorbeugen. Zur Leistungsoptimierung sollten Sie Seitenumbrüche in Teilformularen deaktivieren. In der Standardeinstellung sind Seitenumbrüche zugelassen.
Teilformulare sind außerdem sinnvoll, um Objekte zu gruppieren und zu strukturieren, ohne das Teilformular an ein Datenelement zu binden. Ändern Sie den Datenbindungstyp des Teilformulars vom Standardwert „Normal“ zu „Ohne“, damit von LiveCycle Forms beim Zusammenfügen von Daten nicht nach einem Datenelement für das Teilformular gesucht wird.
Verwandte Themen
Eigenschaften von Teilformularen: Registerkarte „Teilformular“
Leistung im Zusammenhang mit Optionsauswahlen optimieren
Leistung im Zusammenhang mit Textfeldern optimieren


Leistung im Zusammenhang mit Textfeldern optimieren

In der Standardeinstellung werden Einträge in Textfeldobjekten als Normaltext formatiert. Sie können diese Option ändern, um Rich-Text-Formatierung zu ermöglichen.
Bei Normaltexteinträgen werden jedoch die beim Entwerfen des Formulars verwendeten Einstellungen für Schriftart, Schriftschnitt und Schriftgröße auch auf Benutzereingaben angewendet. Das Formular kann effizienter wiedergegeben werden, wenn die Texteigenschaften aus der Formularentwurfsphase zum Einsatz kommen.
Bei Rich-Text-Einträgen können Benutzer Schriftschnitt und -größe für in das Objekt eingegebenen Text individuell anpassen. Rich-Text-Einträge sind möglicherweise in einigen Situationen sinnvoll, etwa bei Informationen in längeren Textpassagen, doch die zusätzlichen Attribute beeinträchtigen die Leistung.
Verwandte Themen
Eigenschaften von Textfeldern: Registerkarte „Feld“
Leistung im Zusammenhang mit Teilformularen optimieren
Leistung bei Objekten auf Masterseiten und auf Seiten


Leistung bei Objekten auf Masterseiten und auf Seiten

Für Objekte auf Masterseiten ist beim Wiedergeben des Formulars durch LiveCycle Forms zusätzliche Verarbeitungszeit erforderlich. Platzieren Sie Objekte möglichst auf Seiten.
Verwandte Themen
Leistung im Zusammenhang mit Textfeldern optimieren
Tipps zum Verringern der Anzahl von Objekten


Tipps zum Verringern der Anzahl von Objekten

Die Dateigröße eines Formulars wird durch die Anzahl von Objekten im Formular beeinflusst. Beachten Sie diese allgemeinen Tipps, um die Anzahl von Objekten in Formularen möglichst gering zu halten:
      •
      Verwenden Sie beim Erstellen eines Feldes ein Rechteckobjekt, statt vier einzelne Linien zu verbinden.
      •
      Verwenden Sie beim Erstellen eines Randes für ein Feld- oder Teilformularobjekt die Randattribute des Objekts, statt ein separates Feld anzulegen.
      •
      Verwenden Sie beim Erstellen von Hintergründen für Objekte eine Hintergrundfüllung, statt ein separates schattiertes Feldobjekt anzulegen.
      •
      Verwenden Sie für Beschriftungen die Beschriftungseigenschaft des Objekts, statt ein separates statisches Textobjekt einzusetzen.
      •
      Kombinieren Sie mehrere statische Textobjekte zu einem einzigen Textobjekt. Diese Vorgehensweise ist besonders sinnvoll, nachdem Formulare in LiveCycle Designer importiert wurden.
Verwandte Themen
Leistungsaspekte beim Importieren von Formularen
Leistung bei Objekten auf Masterseiten und auf Seiten
Tipps zum Verringern der Komplexität von Objekten
Info über Beschriftungen
So führen Sie Textobjekte zusammen
Randeigenschaften in der Palette „Rand“


Tipps zum Verringern der Komplexität von Objekten

Die Dateigröße eines Formulars wird durch die Komplexität der Objekte im Formular beeinflusst. Einfache Objekte können effizienter verarbeitet werden als komplexe Objekte. Beachten Sie diese allgemeinen Tipps, um die Komplexität von Objekten möglichst gering zu halten:
      •
      Verwenden Sie möglichst wenige unterschiedliche Schriftarten, Schriftschnitte und Schriftgrößen, um zwischengespeicherte Schriftinformationen optimal zu nutzen.
      •
      Verwenden Sie an Stelle von dynamischen Objekten, die größer und kleiner werden können, feste Objekte, sofern möglich.
      •
      Vermeiden Sie es, Objekte übereinander anzuordnen, insbesondere in mehr als drei Ebenen.
Verwandte Themen
Leistung im Zusammenhang mit Textfeldern optimieren
Schriftauswahl mit Blick auf die Leistung
Tipps zum Verringern der Anzahl von Objekten
Datenbindungsoptionen mit Blick auf Leistungsoptimierung


Daten mit Blick auf Leistungsoptimierung strukturieren

Datenbindungsoptionen mit Blick auf Leistungsoptimierung
Analysieren der Datenstruktur mit Blick auf Leistungsoptimierung


Datenbindungsoptionen mit Blick auf Leistungsoptimierung

Bei Formularen, die an Datenquellen gebunden sind, können Sie ein Datenelement mit einem Formularobjekt verknüpfen, etwa einem Feld oder einem Teilformular. Diese Verknüpfung wird als Datenbindung bezeichnet. Sie können Objekte wählen, die je nach Menge der angezeigten Daten schrumpfen bzw. wachsen.
Sie können bei der Formularwiedergabe mit vielen unterschiedlichen Datenbindungsdefinitionen dieselben Ergebnisse erzielen. Die Verarbeitung der Datenbindung in LiveCycle Forms wird jedoch effizienter, wenn die Beziehung zwischen dem Formularobjekt und dem zugehörigen Datenelement möglichst klar und offensichtlich ist.
Im folgenden Diagramm sehen Sie ein Beispiel für eine Feldbindung, bei dem zwei Feldobjekte im Formular an Datenelemente gebunden sind. Die Bindung ist nicht eindeutig, weil mehrere Exemplare der Feldobjekte und der zugehörigen Daten vorhanden sind. Beim Wiedergeben (Rendern) des Formulars ist mehr Verarbeitungsleistung erforderlich, um das n-te Vorkommen jedes Objekts mit dem n-ten Vorkommen der entsprechenden Daten abzugleichen.
Das folgende Diagramm zeigt den Einsatz einer Teilformularbindung zur Objektgruppierung. Die Verarbeitung bei der Formularwiedergabe soll dadurch vereinfacht werden. Das Teilformular ist an die sich wiederholende Gruppe in den Daten gebunden, wodurch die mehrdeutige Bindung eliminiert wird. Die Bindung wird für die erste Gruppe ausgewertet; bei den dann folgenden Wiederholungen ist keine erneute Auswertung erforderlich.
Sie können Teilformulare einsetzen, um Objekte zu gruppieren und zu strukturieren, ohne das Teilformular an ein Datenelement zu binden. Ändern Sie den Datenbindungstyp des Teilformulars vom Standardwert „Normal“ zu „Ohne“, damit von LiveCycle Forms beim Zusammenfügen von Daten nicht nach einem Datenelement für das Teilformular gesucht wird.
Verwandte Themen
Datenquellen
Eigenschaften von Teilformularen: Registerkarte „Bindung“
Tipps zum Verringern der Komplexität von Objekten
Analysieren der Datenstruktur mit Blick auf Leistungsoptimierung


Zurück Weiter

LiveCycle Designer verwenden > Formularerstellung mit Blick auf Leistungsoptimierung > Daten mit Blick auf Leistungsoptimierung strukturieren > Analysieren der Datenstruktur mit Blick auf Leistungsoptimierung

Analysieren der Datenstruktur mit Blick auf Leistungsoptimierung

Am Beispiel des selektiven Anzeigens eines Feldes lässt sich zeigen, wie die Datenstruktur die Leistung beeinflusst.
Angenommen, eine Meldung soll nur dann angezeigt werden, wenn der Wert des Datenelements „amountOwed“ (zu zahlender Betrag) größer als null ist. Eine Möglichkeit ist der Einsatz eines Skripts, um den Wert von „amountOwed“ zu untersuchen und je nach Wert des Datenelements die Anzeigeeigenschaft des Meldungsfeldes zu ändern.
Alternativ können die Daten an ein Teilformular gebunden werden. Das Binden von Daten an ein Teilformular ist effizienter als das Binden von Daten an ein Feld, beide Methoden führen jedoch zum selben Ergebnis. Im Beispiel fügen wir das Statuselement in die Datenstruktur ein und binden dieses Element an ein Teilformular. Das Teilformular enthält das Feld mit der Meldung und das Feld amountOwed . Ist der Zähler-Mindestwert für den Teilformularsatz auf null eingestellt, wird die Meldung nur angezeigt, wenn das Status-Element vorhanden ist.
Im Datenkontext sollte die Entscheidung über das Einfügen des Statusknotens in die Datendatei zum Zeitpunkt der Generierung getroffen werden, wenn der Wert größer als 0 ist. Dieses Verfahren verschiebt im Datenkontextentwurf die Logik zum Feststellen, ob ein Teilformular erforderlich ist.
Verwandte Themen
Datenbindungsoptionen mit Blick auf Leistungsoptimierung
Schriftauswahl mit Blick auf die Leistung


Schriftauswahl mit Blick auf die Leistung

Je kleiner die Dateigröße eines Formulars ist, desto schneller kann das Formular wiedergegeben (gerendert) werden. Sie können die Dateigröße minimieren, indem Sie möglichst wenige unterschiedliche Schriften einsetzen und keine Schriften verwenden, die eingebettet werden müssen.
Die folgenden Schriften, die in Adobe Reader immer verfügbar sind, werden niemals eingebettet:
      •
      Adobe Pi Std, Adobe Sans MM, Adobe Serif MM
      •
      Courier Std, Courier Std Bold, Courier Std Bold Oblique, Courier Std Oblique
      •
      Minion Pro Bold, Minion Pro Bold It, Minion Pro It, Minion Pro Regular
      •
      Myriad Pro Bold, Myriad Pro Bold It, Myriad Pro It, Myriad Pro Regular
      •
      Symbol (Type 1)
Palette „Schrift“
Analysieren der Datenstruktur mit Blick auf Leistungsoptimierung
Leistungsaspekte beim Importieren von Formularen


Leistungsaspekte beim Importieren von Formularen

Sie können vorhandene Formulare in LiveCycle Designer importieren. Während des Importvorgangs werden unter Umständen unnötige Objekte erstellt.
Wenn ein PDF-Formular importiert wird, kann beispielsweise für jede Zeile oder jedes Wort im Originalformular ein statisches Textobjekt erstellt werden. Mit zunehmender Anzahl und Komplexität von Objekten erhöht sich die Dateigröße des Formulars, so dass die Leistung bei der Wiedergabe (beim Rendern) des Formulars sinkt.
LiveCycle Designer bietet Optionen, mit denen sich die Anzahl der erstellten unnötigen Objekte verringern lässt. Beim Importieren des Formulars können Sie „Bearbeitbarkeit erhalten“ oder „Erscheinungsbild beibehalten“ wählen.
Je nach Option ergeben sich Unterschiede bei der Anzahl und der Komplexität der Objekte im entstehenden Formular. Eventuell ist es hilfreich, das Formular zweimal zu importieren, einmal mit der Option „Bearbeitbarkeit erhalten“ und einmal mit der Option „Erscheinungsbild beibehalten“. Das endgültige Formular können Sie dann durch Kombinieren der jeweils am besten geeigneten Elemente aus den beiden entstandenen Formularen zusammenstellen.
Nach dem Importieren des Formulars können Sie die Anzahl der Objekte im Formular verringern, indem Sie zusammengehörige Textobjekte kombinieren. Sie können beispielsweise jedes einzelne Textobjekt in einem Satz auswählen und zu einem einzigen Textobjekt bündeln.
Verwandte Themen
So importieren Sie PDF-Dateien
So führen Sie Textobjekte zusammen
Tipps zum Verringern der Anzahl von Objekten
Tipps zum Verringern der Komplexität von Objekten
Schriftauswahl mit Blick auf die Leistung
Leistungsaspekte bei barrierefreien Formularen


Leistungsaspekte bei barrierefreien Formularen

Beim Entwerfen barrierefreier Formulare können Sie Text definieren, der von Bildschirmlesehilfen gelesen wird. Sie müssen ein PDF-Formular mit Tags erstellen, damit die Bildschirmlesehilfe den Text lesen kann. Dazu generieren Sie Tags für zugreifbare Dokumente, wenn Sie den Formularentwurf als PDF-Datei speichern.
In LiveCycle Designer wird standardmäßig ein PDF-Formular mit Tags erstellt.
Die zwecks Ausgabehilfe eingefügten Tags erhöhen die Dateigröße, so dass die Leistung herabgesetzt wird. Um die Auswirkungen auf die Leistung bei barrierefreien Formularen auszugleichen, sollten Sie Designelemente mit Bedacht auswählen.
Für einander ausschließende Optionen sind etwa Listenfelder oder Kontrollkästchen zu empfehlen. Diese Objekte können schneller wiedergegeben werden als Optionsfelder.
Verwandte Themen
So erstellen Sie PDF-Formulare mit Ein-/Ausgabehilfe-Tags
Leistungsaspekte beim Importieren von Formularen
Leistungsaspekte bei Skripten


Leistungsaspekte bei Skripten

Skripten erhöhen im Allgemeinen die erforderliche Verarbeitungsleistung für das Wiedergeben (Rendern) von Formularen. Untersuchen Sie vor der Verwendung von Skripten, ob es eine Alternative gibt, die zu weniger Leistungseinbußen führt. Beispielsweise haben Zeichenmasken häufig bessere Leistungseigenschaften als Skripten, die zu den gleichen Ergebnissen führen.
Für Berechnungen und Überprüfungen in Formularen können Sie JavaScript oder FormCalc verwenden. Wenn möglich, sollten Sie keine Überprüfungsskripten einsetzen. Diese Skripten beeinträchtigen die Leistung, weil sie viel Verarbeitungszeit beanspruchen.
Wenn Sie sich für den Einsatz von Skripten entscheiden, ist FormCalc unter Leistungsgesichtspunkten besser als JavaScript, und zwar aus folgenden Gründen:
      •
      FormCalc führt einfache Berechnungen und Überprüfungen schneller aus.
      •
      FormCalc interpretiert die Syntax des XML-Formularobjektmodells (XML Form Object Model) direkt; Referenz-Syntax-Ausdrücke können daher effizienter ausgewertet werden.
Sie können die Skriptsprache im Skript-Editor auswählen.
Verwandte Themen
Berechnungen und Skripten
Grundlagen zu FormCalc
Grundlagen zu JavaScript
Grundlagen zum Referenzieren von Objekten in Berechnungen und Skripten
Leistungsaspekte bei barrierefreien Formularen
Leistungsaspekte bei Ausdrücken im XML-Formularobjektmodell


Leistungsaspekte bei Ausdrücken im XML-Formularobjektmodell

Das Adobe XML-Formularobjektmodell basiert auf einem Ansatz für die Formulargestaltung, bei dem unterschieden wird zwischen Formularlayout, Formularentwurf und Formulardaten.
In einem Formularentwurf verknüpfen Referenz-Syntax-Ausdrücke Objekte mit Werten, Objekten und Eigenschaften innerhalb der Baumstruktur eines Document Object Model (DOM). Referenz-Syntax-Ausdrücke werden normalerweise bei Überprüfungen, Berechnungen oder anderen Geschäftsregeln in Formularlogik geschrieben.
Beachten Sie die folgenden Tipps, um die für das Auflösen von Referenz-Syntax-Ausdrücken erforderliche Verarbeitungszeit zu verkürzen:
      •
      Ausdrücke sollten so einfach wie möglich sein.
      •
      In Ausdrücken sollten keine doppelten Punkte („..“) verwendet werden.
Nach der Auswertung der Referenz-Syntax in einem Skript sollten Sie das Ergebnis in einer Objektvariablen speichern. Wenn die Referenz-Syntax erneut verwendet wird, kann dieses Ergebnis abgerufen werden. Es ist effizienter, ein Ergebnis wiederzuverwenden, als den Ausdruck neu auszuwerten.
Im folgenden Beispiel wird einmal die Methode resolveNode eingesetzt. Die entstehende Objektreferenz wird gespeichert und zur Bearbeitung verschiedener zugehöriger Objekte wiederverwendet. Dieses Skript kann effizienter verarbeitet werden als ein Skript, in dem für jedes Objekt ein Referenz-Syntax-Ausdruck verwendet wird und jedes Mal die Methode resolveNode zum Einsatz kommt.
var oSubform = xfa.resolveNode("xfa.form.form1.Subform1");

if (oSubform.all.length< 3) {

   Subform.SubformUpButton1.presence = „invisible“;
   Subform.SubformLabel1.presence = „invisible“;

   Subform.SubformUpButton2.presence = „invisible“;
   Subform.SubformLabel2.presence = „invisible“;

}
Verwandte Themen
Berechnungen und Skripten
Grundlagen zu JavaScript
Grundlagen zum Referenzieren von Objekten in Berechnungen und Skripten
Leistungsaspekte bei Skripten
Warn- und Fehlermeldungen behandeln mit Blick auf Leistungsoptimierung


Warn- und Fehlermeldungen behandeln mit Blick auf Leistungsoptimierung

Das Generieren von Warn- und Fehlermeldungen beeinträchtigt die Leistung. Versuchen Sie, möglichst viele dieser Meldungen durch Beheben der Fehlerursache zu behandeln.
Wenn Sie beispielsweise Meldungen über Schriftersetzungen erhalten, sollten Sie dafür sorgen, dass die benötigten Schriften zur Verfügung stehen. Einige Meldungen werden auch dann generiert, wenn die Formulare fehlerfrei sind; diese Meldungen lassen sich unter Umständen nicht vermeiden.
Von LiveCycle Designer generierte Meldungen werden in der Palette „Bericht“ auf der Registerkarte „Warnungen“ angezeigt.
Sie können in der Palette „Bericht“ von LiveCycle Designer prüfen, ob Meldungen vorliegen. Die Meldungen werden außerdem in den Protokolldateien von LiveCycle Forms aufgeführt.
Sie sollten immer beide Arten der generierten Meldungen überprüfen. Auch wenn LiveCycle Designer keine Meldungen ausgibt, können sich Probleme ergeben, weil die LiveCycle Forms-Umgebung möglicherweise große Unterschiede zu Ihrer Desktop-Umgebung aufweist.
Die folgende Liste zeigt einige Beispiele für häufig vorkommende Meldungen, die bei der Wiedergabe (beim Rendern) des Formulars durch LiveCycle Forms generiert werden:
      •
      „Schrift ZaDb wurde nicht gefunden, ersetzt durch Myriad Pro.“
Im Formular wird eine Schrift verwendet, die für LiveCycle Forms nicht zur Verfügung steht. Eine verfügbare Schrift wurde als Ersatz verwendet. Wenn das Formular mit der Ersatzschrift korrekt angezeigt wird, können Sie die Fehlermeldung ausschalten, indem Sie die Formularobjekte ändern und die Ersatzschrift dafür verwenden. Eine weitere Reaktionsmöglichkeit auf diese Fehlermeldung ist das Installieren der fehlenden Schrift für LiveCycle Forms.
      •
      „Skript fehlgeschlagen (Sprache ist JavaScript; Kontext ist ...“
Das Skript kann aufgrund von Skriptfehlern nicht ausgeführt werden. Wenn das Skript keine Ergebnisse im Formular erzeugt, wird dieser Fehler beim Testen des Formulars möglicherweise nicht erkannt. Das Generieren der Fehlermeldung setzt jedoch die Leistung herab.
Das folgende Beispiel zeigt einen Skriptfehler:
script = function testFractionDigits(maxDigits)
{
   index = this.rawValue.lastIndexOf(„.“);
   if (index >= 0)
   return (((this.rawValue.length1)index) <= maxDigits);
   return true;
}
In diesem Beispiel ist index eine nicht definierte Variable. Zum Beheben des Fehlers muss var vor dem ersten Vorkommen von index eingefügt werden.
      •
      „In Feldern verwendete Schrift darf keine Untergruppe sein. Schrift ArialMT ist keine Untergruppe, wird eingebettet.“
Eine Schrift kann nicht in Untergruppen eingefügt werden. Dieser Fehler lässt sich beheben, indem die Schrifteinbettung in Untergruppen durch Einsatz einer Standardschrift ausgeschaltet wird. Durch diese Änderung verringert sich auch die Größe der entstehenden Datei.
      •
      „Bildfeld Attribut ‚access‘ muss explizit auf 'nonInteractive' gesetzt werden. Feld wird als Textbaustein gezeichnet.“
Ein Bildfeldobjekt wird in Formularen von Acrobat Professional 6.0, Acrobat Standard 6.0 und Adobe Reader 6.0 als nicht interaktiv wiedergegeben. Sie können diesen Fehler beheben, indem Sie das Objekt in ein statisches Bildobjekt konvertieren.
      •
      „Ungültiges Layout-Attribut in Teilformular AccountDetails. Standardwert wird verwendet.“
Ein Teilformular hat ein Zeilenlayout, das in einer übergeordneten Tabelle verschachtelt sein sollte, jedoch nicht in einer Tabelle eingeschlossen ist. Dieser Fehler kann behoben werden durch Verschieben des Teilformulars in eine Tabelle oder durch Ändern des Teilformulartyps in „Inhalt positionieren“ oder „Fließender Inhalt“.
Verwandte Themen
Leistungsaspekte bei Ausdrücken im XML-Formularobjektmodell


Formulare für LiveCycle Forms erstellen

LiveCycle Forms
Grundlagen zum Entwerfen von Formularen LiveCycle Forms
Formulare in LiveCycle Forms implementieren
Formularentwürfe zum Erstellen von HTML-Formularen optimieren
Intelligente Formulare verarbeiten


LiveCycle Forms

Was ist LiveCycle Forms?
Die Rolle der LiveCycle Forms
Vorgehensweise von LiveCycle Formsbeim Verarbeiten erfasster Daten
Vorgehensweise von LiveCycle Forms bei der Formularwiedergabe
Vorgehensweise von LiveCycle Forms beim Ausfüllen von Formularen im Voraus


Was ist LiveCycle Forms?

LiveCycle Forms ist eine intelligente Lösung für das Erfassen und Zusammenführen von Daten, die es Organisationen ermöglicht, Formulare ins Internet zu stellen. Mit LiveCycle Forms können Sie Daten erfassen, Formulare im Voraus ausfüllen und Formulare innerhalb und außerhalb Ihrer Organisation auf automatischem Wege verteilen.
LiveCycle Forms bieten diese grundlegenden Dienste:
      •
      Es werden HTML-Formulare an Webbrowser auf Benutzerdesktops, ohne Herunterladevorgänge oder Plug-ins geliefert.
      •
      Es werden PDF-Formulare, die Benutzer online oder offline ausfüllen, drucken und/oder lokal speichern können, geliefert.
      •
      Es wird Server-seitig Intelligenz in Formularen ausgeführt, und es werden Skripten verarbeitet, deren Ausführung auf dem Computer des Benutzers erfolgt, wenn die Client-Anwendung das Skript nicht ausführen kann.
      •
      Es werden ggf. Geschäftsregeln für Felddaten erzwungen.
Verwandte Themen
Die Rolle der LiveCycle Forms


Die Rolle der LiveCycle Forms

Wenn LiveCycle Forms ein Teil der Laufzeitumgebung ist, sind Softwareentwickler gewöhnlich für die Erstellung einer benutzerdefinierten Anwendung und die Integration mit LiveCycle Forms sowie für die Unternehmensinfrastruktur verantwortlich. LiveCycle Forms ist nur eine Komponente der Laufzeitumgebung.
Die benutzerdefinierte Anwendung enthält in der Regel eine Benutzerschnittstelle und bietet Zugriff auf LiveCycle Forms. Die Unternehmensinfrastruktur kann ein zentrales Repository mit Unternehmensdaten enthalten, durch das von LiveCycle Forms auf Daten zugegriffen wird.
Hier sind einige Beispiele für die Verwendung von LiveCycle Forms:
      •
      Formulare können zur Erstellung von Rechnungen für die Verteilung über viele Kanäle verwendet werden. Benutzer greifen auf Formulare zu und aktualisieren die Informationen durch LiveCycle Forms.
      •
      Formulare können mit Daten aus einer Datenbank zusammengeführt werden, um benutzerspezifische Telefonrechnungen zu erstellen. Die Daten werden von LiveCycle Forms aus der Datenbank angefordert und die Informationen dynamisch zusammengeführt.
      •
      Benutzer können Teile eines vorausgefüllten Formulars anzeigen und optional online ausfüllen, bevor das Formular an einen Händler für weitere Eingaben übergeben wird. Wenn das aktualisierte Formular gespeichert wird und die Daten erfasst werden, bindet LiveCycle Forms die Daten auf eine Art, die mit dem proprietären XML-Schema des Händlers kompatibel ist.
Verbesserte Datenerfassung, Übergabe- und Bindungsoptionen werden von LiveCycle Forms unterstützt und das Zusammenführen von Daten wird durchgeführt. Wenn Daten erfasst sind, akzeptiert und überprüft LiveCycle Forms diese. Wenn ein Formular angefordert wird, führt LiveCycle Forms den Formularentwurf mit Daten zusammen und erteilt Zugriff auf das zusammengeführte Formular im PDF- oder HTML-Format. Falls es erforderlich ist, ein Formular wiederzugeben, das auf Textfluss eingestellte Teilformularsätze enthält, übernimmt LiveCycle Forms das Einbinden von Objekten, die unterschiedliche Mengen von Daten annehmen, und die mit dem Text wiedergegeben werden.
LiveCycle Forms ist kompatibel mit LiveCycle Reader Extensions. Nach dem Speichern einer LiveCycle Designer-XDP-Datei durchLiveCycle Forms können Verwendungsrechte auf dynamisch zusammengeführte PDF-Formulare programmatisch angewendet werden, statt durch LiveCycle Reader Extensions.
Wenn ein Benutzer ein Formular über Adobe Reader anfordert, überprüft LiveCycle Forms die Verwendungsrechte des Benutzers, um zu bestimmen, ob das angeforderte Formular heruntergeladen werden kann. Wenn die erforderlichen Verwendungsrechte gegeben sind, wird eine XML-Verwendungsrechtedatei erstellt und mit dem Formular auf LiveCycle Reader Extensions heruntergeladen.
LiveCycle Reader Extensions überprüft ein Adobe-Zertifikat, um die Benutzeranmeldeinformationen zu bestätigen, bevor Funktionen in PDF-Dokumenten aktiviert werden, die andernfalls über Adobe Reader nicht verfügbar wären.
Weitere Informationen zu LiveCycle Forms finden Sie in der nachfolgenden Auflistung der entsprechenden Dokumentation.

Gewünschte Informationen

Referenz
Funktionen, Arbeitsumgebungen und Integration mit anderen Adobe-Produkten
Übersicht
Neues in der aktuellen Version von LiveCycle Forms
Neuheiten
Dokumentation von LiveCycle Forms
Dokumentation
Installation, Konfiguration und Verwaltung von LiveCycle Forms in der Entwicklung und einer Laufzeitumgebung
LiveCycle Forms installieren und konfigurieren
Verwenden der im Umfang der LiveCycle Forms-Installation enthaltenen Beispieldateien
Readme-Datei für Beispieldateien
Die Architektur von LiveCycle Forms und Verwenden der APIs zum Erstellen von LiveCycle Forms-Anwendungen
Developing Custom Applications
LiveCycle Forms APIs, einschließlich einzelner Beschreibungen und Erläuterungen
XML Form Module API Reference undAdobe LiveCycle Forms API Reference.
Unterstützung welcher LiveCycle Designer-Eigenschaften von einzelnen Webbrowsern für die Formularwiedergabe im HTML-Format
Transformation Reference
Verwandte Themen
Vorgehensweise von LiveCycle Formsbeim Verarbeiten erfasster Daten
Vorgehensweise von LiveCycle Forms bei der Formularwiedergabe
Vorgehensweise von LiveCycle Forms beim Ausfüllen von Formularen im Voraus


Vorgehensweise von LiveCycle Formsbeim Verarbeiten erfasster Daten

Sie können interaktive Formulare zum Erfassen von Daten verwenden, die von Benutzern eingegeben wurden. Wenn Benutzer mit Acrobat oder Adobe Reader arbeiten, können die eingegebenen Daten direkt im PDF-Formular gespeichert werden. Alternativ können Sie, wenn Sie im Formular eine Schaltfläche zum Senden bereitstellen, Benutzern das Hochladen der eingegebenen Daten zu LiveCycle Forms ermöglichen.
Wenn der Benutzer zur Laufzeit auf eine Schaltfläche zum Senden klickt, werden die Daten an LiveCycle Forms gesendet. Wenn LiveCycle Forms hierfür eingerichtet ist, und vorausgesetzt, dass kein Überprüfungsfehler auftritt, können die Daten mit dem Formular zusammengeführt und an den Benutzer zurückgegeben werden. Alternativ kann LiveCycle Forms dazu eingerichtet werden, die Daten an eine benutzerdefinierte Anwendung zur weiteren Verarbeitung weiterzuleiten.
Gute Kenntnisse über das Definieren der Eigenschaften einer Schaltfläche zum Senden sind unerlässlich, um die Anforderungen der benutzerdefinierten Anwendung zu erfüllen, weil die Daten in mehreren Formaten an LiveCycle Forms übergeben werden können.
Verwandte Themen
Schaltflächen – Übersicht
Info über das Senden von Daten mit Hilfe einer Schaltfläche
So überprüfen Sie Benutzereingaben


Vorgehensweise von LiveCycle Forms bei der Formularwiedergabe

LiveCycle Designer ermöglicht Ihnen die Erstellung von interaktiven, statischen oder dynamischen Formularentwürfen, die vonLiveCycle Forms in PDF-Formularen oder HTML-Formularen wiedergegeben werden.
Sie können PDF-Formulare direkt in LiveCycle Designer speichern und dann über E-Mail oder über einen Standard-Netzwerkserver an Benutzer verteilen. Wenn Sie jedoch LiveCycle Forms verwenden, speichern Sie Ihre Formularentwürfe wahrscheinlich im XDP-Format und stellen sie für LiveCycle Forms zur Verfügung.
Wenn Formularentwürfe in LiveCycle Forms implementiert werden, können wiedergegebene Formulare über eine Web-basierte Benutzerschnittstelle direkt an Benutzer verteilt werden. Wenn ein Benutzer ein Formular anfordert, wendet LiveCycle Forms eine entsprechende Konvertierung Ihres Formularentwurfs an, um das Formular wiederzugeben.
Wenn der Benutzer beispielsweise ein interaktives PDF-Formular anfordert, verwendet LiveCycle Forms die PDFForm-Konvertierung, um das Formular wiederzugeben.
Verwandte Themen
Formularkonvertierungen
Formularentwürfe, die LiveCycle Forms unterstützt
Speicherung von Formularentwürfen im XDP- oder PDF-Format?


Vorgehensweise von LiveCycle Forms beim Ausfüllen von Formularen im Voraus

LiveCycle Forms kann ein Formular mit Daten von einer externen Datenquelle im Voraus ausfüllen, während das Formular wiedergegeben wird.
Für einige einfache Anwendungen können Sie möglicherweise durch Einrichtung von Datenbindung in LiveCycle Designer Formulare erstellen, die mit externen Daten funktionieren, ohne ein Skript schreiben zu müssen. Bindung kann gewöhnlich alleine verwendet werden, um Daten von einer WSDL-Datenquelle oder einer OLEDB-Datenbank zu erhalten.
LiveCycle Forms bietet Unterstützung für einfache Datenbindung. Die einfache Bindung ermöglicht es Ihnen, einen einzelnen Wert an ein Feld zu binden.
Verwandte Themen
Info über das Binden von Feldern an eine Datenquelle
Zusammenführen von Daten testen
Formularfelder im Voraus mit Daten füllen


Grundlagen zum Entwerfen von Formularen LiveCycle Forms

Formulare für LiveCycle Forms entwerfen
Formularentwürfe, die LiveCycle Forms unterstützt
Welche Formularentwürfe sind für LiveCycle Forms geeignet?
Format für die Datenübergabe festlegen
Formularkonvertierungen
Zusammenführen von Daten testen
Leistungsfähigkeit für LiveCycle Forms optimieren und verbessern


Formulare für LiveCycle Forms entwerfen

Formularentwürfe für LiveCycle Forms werden nach dem gleichen Verfahren erstellt wie alle anderen Formularentwürfe. Wenn Sie jedoch einen Formularentwurf für LiveCycle Forms erstellen, kann dieser Formularentwurf für die Wiedergabe von PDF- oder HTML-Formularen verwendet werden.
LiveCycle Forms ermöglicht es Ihnen, PDF- und HTML-Formulare im Internet oder in einem Intranet zu veröffentlichen. Wenn LiveCycle Forms ein HTML-Formular wiedergibt, wird das Formular in der Regel in einem Webbrowser geöffnet. Wenn LiveCycle Forms ein PDF-Formular wiedergibt, kann das Formular direkt in Acrobat oder Adobe Reader geöffnet werden, je nach den Einstellungen von Acrobat oder Adobe Reader auf dem Benutzercomputer.
Wenn Sie Formulare in einer Webumgebung verteilen, müssen Sie die Einschränkungen der Umgebung berücksichtigen. Beispielsweise werden einige der Funktionen, die Sie Formularentwürfen mit Hilfe von LiveCycle Designer zuordnen können, in einer Webumgebung nicht unterstützt, und unterschiedliche Webbrowser zeigen die gleichen Objekte unterschiedlich an.
Darüber hinaus werden einige Formularfähigkeiten von Webbrowsern oder der HTML-Technologie nicht direkt unterstützt. Der Gesamtumfang der Formularfähigkeiten steht nur zur Verfügung, wenn ein PDF-Formular mit Acrobat oder Adobe Reader geöffnet wird.
LiveCycle Forms 7.1 bietet keine Unterstützung für Tabellen in Formularentwürfen, die als HTML-Formulare wiedergegeben werden. LiveCycle Forms 7.1 bietet keine Unterstützung für Formularentwürfe mit arabischen, hebräischen, thailändischen und vietnamesischen Schriftzeichen.
Verwandte Themen
Was ist LiveCycle Forms?
Formularentwürfe, die LiveCycle Forms unterstützt
Welche Formularentwürfe sind für LiveCycle Forms geeignet?


Formularentwürfe, die LiveCycle Forms unterstützt

LiveCycle Forms gibt vier grundlegende Formulartypen wieder:
      •
      Interaktive Formulare mit festem Layout
      •
      Nicht interaktive Formulare mit festem Layout
      •
      Interaktive Formulare, deren Layout an die entsprechende Datenmenge angepasst wird
      •
      Nicht interaktive Formulare, deren Layout an die entsprechende Datenmenge angepasst wird
Nachdem Sie einen Formularentwurf an LiveCycle Forms übergeben haben, kann LiveCycle Forms das Formular als PDF- oder HTML-Dokument entweder mit zusammengeführten Daten oder ohne zusammengeführte Daten wiedergeben.
Die folgende Tabelle enthält eine kurze Beschreibung der Formulartypen, die Sie mit LiveCycle Designer erstellen können. Weitere Informationen zu Formulartypen finden Sie unter Ansätze zum Erstellen von Formularentwürfen.

Interaktiv

Nicht interaktiv
Festes Layout
Ein interaktives Formular hat ein festes Layout und umfasst mindestens ein paar Felder, die vom Benutzer manuell ausgefüllt werden müssen. Layout und Paginierung ändern sich nicht, unabhängig von der Datenmenge, die in den Formularfeldern platziert wird.
Ein nicht interaktives Formular hat ein festes Layout, enthält aber keine Felder, in die der Ausfüller Daten eingeben muss. Sie können nicht interaktive Formulare im Voraus mit Daten füllen. Layout und Paginierung des Formulars ändern sich jedoch nicht.
Flexibles Layout
Ein interaktives Formular, dessen Layout an die entsprechende Datenmenge angepasst wird, kann im Voraus mit Daten gefüllt werden (optional). Es muss jedoch mindestens ein paar Felder oder andere Funktionen enthalten, die vom Formularausfüller manuell bedient werden.
Ein nicht interaktives Formular, dessen Layout an die entsprechende Datenmenge angepasst wird, kann im Voraus mit Daten gefüllt werden (optional). Es enthält keine Felder oder andere Funktionen, die vom Formularausfüller manuell bedient werden.
Benutzer können in alle Formulartypen zur Laufzeit Formulardaten importieren.
Verwandte Themen
Info über das Erstellen von Formularentwürfen mit Layoutanpassungen an die Datenmenge
Ansätze zum Erstellen von Formularentwürfen
HTML-Formulare


Welche Formularentwürfe sind für LiveCycle Forms geeignet?

Es ist wichtig zu wissen, dass PDF- und HTML-Formulare, die vom gleichen Formularentwurf wiedergegeben werden, einige Unterschiede im Verhalten aufweisen.
Da PDF-Formulare mit Acrobat oder Adobe Reader angezeigt werden können, unterstützt das Formular den gesamten Umfang an Objekteigenschaften, die Sie im Formularentwurf definieren. Wenn Sie HTML-Formulare auf der Basis des gleichen Formularentwurfs verteilen, bieten einige Client-Anwendungen (z. B. Webbrowser) für einzelne Objekteigenschaften nicht das gleiche Unterstützungsniveau.
Wenn darüber hinaus ein HTML-Formular wiedergegeben wird, sind Seitengrößen (die für den Seitenumbruch von PDF-Formularen benötigt werden) bedeutungslos. Da sich ein Formular mit flexiblem Layout auf einer unbegrenzt langen HTML-Seite ausweiten kann, ist es wichtig, auf der Masterseite Fußzeilen zu vermeiden. Eine Fußzeile unter dem Inhaltsbereich auf einer Masterseite könnte HTML-Inhalt überschreiben, der über das hinausfließt, was sonst (in einem PDF-Formular) eine Seitenbegrenzung wäre.
LiveCycle Forms 7.1 bietet keine Unterstützung für Tabellen in Formularentwürfen, die als HTML-Formulare wiedergegeben werden. LiveCycle Forms 7.1 bietet keine Unterstützung für Formularentwürfe mit arabischen, hebräischen, thailändischen und vietnamesischen Schriftzeichen.
Um einen einzelnen Formularentwurf zu erstellen, der diesen Einschränkungen gerecht wird, befolgen Sie diese Verfahrensweise:
1.
Informationen über das Verhalten von Objekten in einer bestimmten Client-Anwendung finden Sie in der Transformation Reference.
2.
Wenn Sie ein Formular mit festem Layout entwerfen und das Formular im HTML-Format wiedergeben möchten, müssen Sie die Konvertierungs-Zwischenspeicherung aktivieren.
3.
Versuchen Sie bei der Erstellung des Formularentwurfs alle in den Client-Anwendungen bestehenden Einschränkungen zu umgehen, indem Sie nach Möglichkeiten suchen, das Formular einzusetzen, ohne auf nicht unterstützte Objekteigenschaften angewiesen zu sein.
4.
Verwenden Sie ein Layout, das sowohl für PDF-Formulare als auch für HTML-Formulare funktioniert.
5.
Lesen Sie den Abschnitt über die Erstellung von barrierefreien Formularen, und verwenden Sie die Richtlinien zur Integration von Ein- und Ausgabehilfen in Ihren Formularentwurf.
6.
Fragen Sie Ihren Formularentwickler, wo Skripten standardmäßig ausgeführt werden sollen. Standardmäßig werden Skripten auf dem Client ausgeführt. Wenn Skripten, die Sie in ein Formular einbeziehen, auf dem Server oder auf dem Client und dem Server ausgeführt werden sollen, müssen Sie möglicherweise die Standardeinstellung deaktivieren.
7.
Zeigen Sie das Formular regelmäßig mit LiveCycle Designer (für PDF-Formular) oder mit der Client-Anwendung (für HTML-Formulare) in der Vorschau an, um Probleme bereits am Anfang des Entwurfsprozesses zu beseitigen.
8.
Wenn LiveCycle Forms Formulare mit Daten zusammenführt, verwenden Sie Testdaten, um Ihre Formularentwürfe gründlich zu überprüfen, bevor Sie abgeschlossene Versionen für LiveCycle Forms verfügbar machen.
Verwandte Themen
Formularkonvertierungen
Formular-Zwischenspeicherung
Schritte zum Verfassen eines Formularentwurfs
Barrierefreie Formulare
Client- und Server-seitige Verarbeitung
So können Sie Formulare auf der Registerkarte „PDF-Vorschau“ in der Vorschau anzeigen und testen
Vorschau eines HTML-Formulars
Format für die Datenübergabe festlegen
Zusammenführen von Daten testen
Speicherung von Formularentwürfen im XDP- oder PDF-Format?
Kopieren von Formularentwürfen in das lokale Netzwerk


Format für die Datenübergabe festlegen

Beim Erstellen eines Formulars können Sie das Format festlegen, in dem die Übergabe der Daten erfolgen soll. Es gibt zwei Möglichkeiten, das Datenübergabeformat in LiveCycle Designer festzulegen:
      •
      Platzieren Sie ein Schaltflächenobjekt im Formular, definieren Sie es als Senden-Schaltfläche und wählen Sie das Format für die Datenübergabe aus.
      •
      Platzieren Sie eine HTTP-Senden-Schaltfläche oder eine E-Mail-Senden-Schaltfläche im Formular.
Nach dem Hinzufügen eines Schaltflächenobjekts zum Formularentwurf können Sie auf der Registerkarte „Absenden“ der Palette „Objekt“ ein Format für die Datenübergabe festlegen. HTTP-Senden-Schaltflächen und E-Mail-Senden-Schaltflächen sind vorkonfiguriert und verwenden daher bestimmte Formate zur Datenübergabe. Weitere Informationen zu Datenübergabeformaten finden Sie unter Info über das Senden von Daten mit Hilfe einer Schaltfläche.
Unterstützte Funktionalität und Funktionen
LiveCycle Designer unterstützt vier Datenübergabeformate:
    • XML-Datenpaket (XDP)
XML-Daten und PDF-Dateien, die extrahiert und als separater Inhalt gespeichert wurden. Wenn Benutzer das Formular abrufen, erhalten sie die PDF-Datei.
    • PDF
XML-Daten werden aus der PDF-Datei extrahiert und separat gespeichert.
    • XML-Daten (XML)
Daten werden in einer separaten XML-Datei gespeichert. Daten werden bei Bedarf mit dem Formular zusammengeführt.
    • URL-kodierte Daten (HTTP Post)
Die Daten werden wie XML-Daten verarbeitet. Dieses Format ist das einzige Datenübergabeformat für HTML-Formulare.
In der folgenden Tabelle sind die Funktionen zusammengefasst, die von den Datenübergabeformaten auf der Registerkarte „Absenden“ der Palette „Objekt“ unterstützt werden.

Funktion/
Funktionalität

XML-Datenpaket (XDP)

PDF

XML-Daten

URL-kodierte Daten
(HTTP Post)
Anmerkungen
Unterstützt
Wenn Anmerkungen im XML-Datenpaket eingeschlossen werden sollen, müssen Sie für das Senden-Schaltflächenobjekt auf der Registerkarte „Absenden“ das Kontrollkästchen „PDF“ aktivieren.
Nicht unterstützt
Nicht unterstützt
Nicht unterstützt
Digitale Unterschriften
Unterstützt
Wenn digitale Unterschriften im XML-Datenpaket eingeschlossen werden sollen, müssen Sie für das Senden-Schaltflächenobjekt auf der Registerkarte „Absenden“ das Kontrollkästchen „PDF“ aktivieren.
Nicht unterstützt
Nicht unterstützt
Nicht unterstützt
PDF
Unterstützt
Nicht unterstützt
Nicht unterstützt
Nicht unterstützt
Vorlage
Unterstützt
Nicht unterstützt
Nicht unterstützt
Nicht unterstützt
Verwandte Themen
Info über das Senden von Daten mit Hilfe einer Schaltfläche
Eigenschaften von Schaltflächen: Registerkarte „Absenden“
Zusammenführen von Daten testen
Grundlagen zum Optimieren und Verbessern der Leistungsfähigkeit


Formularkonvertierungen

LiveCycle Forms gibt Formulare in zahlreichen Formaten durch Konvertierungen wieder, die Formulare an die Fähigkeiten von Client-Anwendungen (z. B. Acrobat, Adobe Reader, verschiedene Webbrowser oder eine Bildschirmlesehilfe) anpassen.
LiveCycle Forms unterstützt jeden HTML-Client, der die CSS2-Spezifikation befolgt. Da Browser hinsichtlich ihrer Unterstützung von CSS2 sehr unterschiedlich sind und ältere Browser keine Unterstützung bieten, erfordern mehrere Browser und generische Benutzeragenten eine spezielle Konvertierung. Die Konvertierungen, die LiveCycle Forms für Client-Anwendungen liefert, werden in der Tabelle beschrieben.

Konvertierung

Ziel-Client-Anwendung
HTML4
Netscape Navigator 4.7.x
PDF
Erstellt nicht interaktive PDF-Formulare mit festem Layout, die mit Acrobat oder Adobe Reader gedruckt und gespeichert werden können.
PDFForm
Erstellt interaktive und barrierefreie PDF-Formulare für Acrobat oder Adobe Reader.
PDFMerge
Führt Daten in einem Formularentwurf zusammen (Vorabausfüllen), der in LiveCycle Designer als PDF-Formular gespeichert wurde. Wenn keine Server-seitigen Berechnungen erforderlich sind, ist dies die schnellste Art der Konvertierung.
AHTML
Bildschirmlesehilfen und Microsoft Internet Explorer 5.x oder höher.
MSDHTML
Microsoft Internet Explorer 5.x oder höher. Verwendet VML für Vektorgrafiken.
CSS2HTML
Netscape Navigator 6.2 oder höher, Opera 7 und Internet Explorer 5.x oder höher. Mit Ausnahme von Rechtecken und Linien werden Vektorgrafiken nicht unterstützt.
Außer einem Dokumentunterschriftsfeld kann jede Objektart in ein HTML-Formular eingefügt werden. Jedoch werden, je nach den Beschränkungen der Client-Anwendung, nicht alle Objekteigenschaften unterstützt.
Eine Liste aller Objekte und unterstützten Eigenschaften für jeden Konvertierungstyp finden Sie in der Transformation Reference auf der Support-Website von LiveCycle Designer.
Wenn Sie die HTML4-Konvertierung zur Unterstützung von Netscape 4.7.x gewählt haben, wird jedes JavaScript, das zur Ausführung auf dem Client vorgesehen ist, stattdessen automatisch auf dem Server ausgeführt.
Verwandte Themen
Welche Formularentwürfe sind für LiveCycle Forms geeignet?


Zusammenführen von Daten testen

Bei der Einrichtung von Formularen zur Unterstützung von zusammengeführten Daten müssen Sie die Anforderungen des Formulars für das Zusammenführen von Daten hinsichtlich der Eingabedaten analysieren. Der Formularentwurf sollte auf der Basis der Struktur der Eingabedaten erstellt werden.
Es wird empfohlen, die Eingabedaten zu überprüfen und die Vorbereitung einer Musterdatendatei für Testzwecke zu erwägen. Sie können diese Musterdatendatei auch automatisch von LiveCycle Designer erstellen lassen. Die Datei kann dem Formularverfasser bereitgestellt werden.
Beispieldaten können verwendet werden, um das Verhalten eines Formulars zu ermitteln, und sollten nicht als Ersatz für eine gründliche Überprüfung betrachtet werden. Um die besten Ergebnisse zu erzielen, sollte der Formularentwurf mit systemgenerierten Daten getestet werden. Sie können die Beispieldaten wie in der folgenden Liste generieren, um zu ermitteln, ob das Layout, die Formatierung, der Inhalt und das Verhalten eines Formulars den Erwartungen entspricht:
      •
      Um zu überprüfen, ob die Datenformatierung (z. B. Schriftart, Schriftgröße und Absatzausrichtung) korrekt ist, generieren Sie Daten für jedes Feld im Formular. Mit den Daten kann auch jeder berechnete Feldwert überprüft werden.
      •
      Um zu prüfen, ob Feldobjekte ausreichend groß sind, um alle Datenwerte aufzunehmen, generieren Sie Daten, die die maximal zulässige Zeichenanzahl pro Feld erreichen.
      •
      Um den Vorgang der Einstellung von „Mehrfache Zeilen zulassen“ und „Passend erweitern“ zu überprüfen, generieren Sie mehrere Zeilen mit Daten.
      •
      Wenn Ihr Formularentwurf Teilformulare enthält, die sich wiederholen, generieren Sie sich wiederholende Datengruppen, um die Wiedergabe dieser Teilformulare in der von Ihnen erstellten Musterdatendatei zu testen. Wenn Sie eine automatisch generierte Musterdatendatei verwenden, können Sie festlegen, wie oft sich eine Datengruppe wiederholen soll.
      •
      Wenn Ihr Formularentwurf Überlaufkopfbereiche oder Überlauffußbereiche enthält, generieren Sie die Daten, die nötig sind, um jeden Überlaufkopf- oder -fußbereich und die Einstellungen für deren Auftreten zu testen. Sie sollten genügend sich wiederholende Datengruppen generieren, die über drei Seiten fließen. Hierdurch wird auch die Überprüfung der Seitennummerierung ermöglicht. Verwenden Sie Beispieldaten (fügen Sie jeweils eine sich wiederholende Datengruppe hinzu), um zu überprüfen, wie ein sich wiederholendes Teilformular aussieht, wenn es auf die nächste Seite fließt.
      •
      Um die Datenmustereinstellung für gebundene Daten zu testen, stellen Sie sicher, dass alle Datenwerte vom System im gleichen Format generiert werden, insbesondere wenn die Syntax der Quelldaten nicht den LiveCycle Designer-Standardeinstellungen entspricht.
      •
      Generieren Sie genügend Daten, um das Layout jeder Masterseite im wiedergegebenen Formular einzusetzen.
Die folgenden Richtlinien helfen Ihnen bei der Erstellung einer einfachen Testdatei, die repräsentative Eingabedaten enthält:
      •
      Die Eingabedatendatei muss eine gültige XML-Datei sein. Beispielsweise könnte eine einfache Datei Elemente in diesem Format besitzen:

        <root_node>
            <first_node>value</first_node>
            <second_node>value</second_node>
            ...
            <last_node>value</last_node>
        </root_node>
      •
      Vergleichen Sie den Fluss der Eingabedaten mit dem physischen Layout des Formulars. Wenn Sie die implizite Bindung verwenden, müssen die Namen der Daten-Nodes mit den entsprechenden Containern und Feldern im Formular übereinstimmen und in der gleichen Reihenfolge wie die Ausfüllreihenfolge im Formular wiedergegeben werden.
      •
      Wenn die Eingabedatendatei über mehr Verschachtelungsniveaus verfügt als die Elemente in der Palette „Hierarchie“, müssen Datenbindungen für alle verschachtelten Objekte explizit auf der Registerkarte „Bindung“ in der Palette „Objekt“ eingestellt werden.
      •
      Suchen Sie in der Eingabedatendatei nach Daten, die wiederholt werden, jedoch nicht Bestandteil jedes Datensatzes sind. Diese Informationen können möglicherweise auf Masterseiten als Textbausteinobjekte oder in Teilformularen, die nur Daten für einmalige Datensätze wiederholen, gehandhabt werden.
Um den Testvorgang zu beginnen, können Sie angeben, welche Eingabedatendatei in eine LiveCycle Designer-Vorschau (siehe Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“) geladen werden soll. Falls nötig, können Sie die Objekte im Formularentwurf neu anordnen, so dass sie mit der Reihenfolge und der Verschachtelung der Datennodes in der Eingabedatendatei übereinstimmen.
Um einen Formularentwurf zur Anpassung an die Eingabedaten weiter zu verfeinern, können Sie die Informationen in diese Komponenten aufteilen und entsprechend platzieren:
      •
      Objekte, aus denen eine Formularkopfzeile besteht, sollten auf einer Masterseite platziert werden.
      •
      Formularinhalt, einschließlich Überlaufkopfbereiche, sich wiederholende Zeilen (Teilformulare) und Überlauffußbereiche sollten auf Seiten platziert werden.
      •
      Für interaktive und statische PDF-Formulare können Objekte, aus denen eine Formularfußzeile besteht, auf einer Masterseite platziert werden. Für HTML-Formulare sollten Fußzeilen vermieden werden.
Achten Sie darauf, dass die Daten keine hexadezimalen Werte zwischen 0x00 und 0x20 enthalten. Ausnahmen sind Wagenrücklauf, Zeilenvorschub und horizontaler Tabulator. Diese Werte sind ungültige XML-Zeichen, die von LiveCycle Forms nicht erkannt werden.
Verwandte Themen
Datenquellen
Info über interaktive Formulare
Ansätze zum Erstellen von Formularentwürfen
Info über das Erstellen von Formularentwürfen mit Layoutanpassungen an die Datenmenge
So können Sie Formulare auf der Registerkarte „PDF-Vorschau“ in der Vorschau anzeigen und testen
Vorschau eines HTML-Formulars


Leistungsfähigkeit für LiveCycle Forms optimieren und verbessern

Grundlagen zum Optimieren und Verbessern der Leistungsfähigkeit
Formular-Zwischenspeicherung
So aktivieren Sie die Formular-Zwischenspeicherung für Formulare mit festem Layout
Formularentwürfe mit flexiblem Layout auf dem Client wiedergeben
Formularfelder im Voraus mit Daten füllen


Zurück Weiter

LiveCycle Designer verwenden > Formulare für LiveCycle Forms erstellen > Grundlagen zum Entwerfen von Formularen LiveCycle Forms > Leistungsfähigkeit für LiveCycle Forms optimieren und verbessern > Grundlagen zum Optimieren und Verbessern der Leistungsfähigkeit

Grundlagen zum Optimieren und Verbessern der Leistungsfähigkeit

In LiveCycle Designer können Sie die Leistungsfähigkeit Ihrer Formulare auf vielfältige Weise verbessern, wenn Sie LiveCycle Forms verwenden. Mit Hilfe dieser Verbesserungen können Sie zeitsparende Funktionen konfigurieren, z. B. schnellere Formularwiedergabezeiten, Formularwiedergabe auf dem Client zur Serverentlastung und Vorausfüllen von Formularen mit bekannten Daten zur Entlastung der Formularausfüller.
Verwandte Themen
Formular-Zwischenspeicherung
Formularentwürfe mit flexiblem Layout auf dem Client wiedergeben
Formularfelder im Voraus mit Daten füllen


Zurück Weiter

LiveCycle Designer verwenden > Formulare für LiveCycle Forms erstellen > Grundlagen zum Entwerfen von Formularen LiveCycle Forms > Leistungsfähigkeit für LiveCycle Forms optimieren und verbessern > Formular-Zwischenspeicherung

Formular-Zwischenspeicherung

Das Zwischenspeichern von Formularen ist eine effektive Möglichkeit, die Leistung bei der Wiedergabe eines Formulars zu erhöhen. Beim Zwischenspeichern von Formularen werden die Daten mit einer vorgenerierten Präsentation zusammengeführt. Mit LiveCycle Forms können Sie Formulare zwischenspeichern, um die Wiedergabeleistung zu erhöhen.
Berücksichtigen Sie jedoch die folgenden beim Aktivieren der Zwischenspeicherung geltenden Einschränkungen:
      •
      Wenn das Formular mit Acrobat oder Adobe Reader 6.0.2 ausgefüllt werden kann, können nur Formulare mit festem Layout zwischengespeichert werden. Die Zwischenspeicherung von Formularen mit flexiblem Layout wird nur von Acrobat und Adobe Reader 7.0 oder höher unterstützt.
      •
      Die gesamte Skripterstellung auf der Server-Seite zum Formular-Layout wird ignoriert. Sie können beispielsweise keine Skripterstellung zu Faktoren wie Füllfarbe, Schriftfarbe, Begrenzungsbreite oder Begrenzungsfarbe verwenden.
      •
      Skripterstellung auf der Server-Seite zum Ändern der Seiteninhalte, der Anzahl der Felder, der Position der Felder oder ihrem Erscheinungsbild wird ignoriert.
      •
      Bei der Verwendung von PDF- oder PDFForm-Konvertierungen können Sie das Layout des Formulars nicht mit Hilfe von Skripterstellung auf der Client-Seite ändern. Sie können jedoch mit Hilfe von HTML-Konvertierungen eine Skripterstellung auf der Client-Seite verwenden, um das Erscheinungsbild des Formulars zu ändern, auch wenn die Zwischenspeicherung von Formularen aktiviert ist.
      •
      Vor der Zwischenspeicherung werden dem Formular Nutzungsrechte zugewiesen, um die Wiedergabeleistung weiter zu verbessern.
      •
      Für die Zwischenspeicherung müssen alle Formulare eindeutig identifiziert werden. LiveCycle DesignerWenn Sie ein neues Formular mit einem vorhanden Formular als Ausgangspunkt erstellen wollen, verwenden Sie zum Kopieren des Formulars nicht den Kopierbefehl des Betriebssystems. Verwenden Sie stattdessen den Befehl „Datei“> „Speichern unter“ in LiveCycle Designer zum Erstellen des neuen Formulars.
      •
      Wenn Sie ein vorhandenes Formular in LiveCycle Designer öffnen und die Änderungen speichern, wird die Zwischenspeicherung automatisch aktualisiert.
Damit LiveCycle Forms Formulare mit festem Layout zwischenspeichert, müssen Sie die Option zur Formular-Zwischenspeicherung in LiveCycle Designer für jedes erstellte Formular auswählen.


Zurück Weiter

LiveCycle Designer verwenden > Formulare für LiveCycle Forms erstellen > Grundlagen zum Entwerfen von Formularen LiveCycle Forms > Leistungsfähigkeit für LiveCycle Forms optimieren und verbessern > So aktivieren Sie die Formular-Zwischenspeicherung für Formulare mit festem Layout

So aktivieren Sie die Formular-Zwischenspeicherung für Formulare mit festem Layout

1.
Wählen Sie „Datei“ > „Formulareigenschaften“.
2.
Klicken Sie auf die Registerkarte „Standard“, und aktivieren Sie das Kontrollkästchen „Formularwiedergabe über Cache auf Server zulassen“.
3.
Klicken Sie auf „OK“.
Verwandte Themen
Zusammenführen von Daten testen
Formularkonvertierungen


Zurück Weiter

LiveCycle Designer verwenden > Formulare für LiveCycle Forms erstellen > Grundlagen zum Entwerfen von Formularen LiveCycle Forms > Leistungsfähigkeit für LiveCycle Forms optimieren und verbessern > Formularentwürfe mit flexiblem Layout auf dem Client wiedergeben

Formularentwürfe mit flexiblem Layout auf dem Client wiedergeben

Wenn die Formularausfüller Acrobat 7.0 oder höher oder Adobe Reader 7.0 oder höher verwenden, können Sie wählen, ob Ihre Formulare auf dem Client anstatt auf dem Server wiedergegeben werden sollen.
Beim Wiedergeben von interaktiven oder nicht interaktiven Formularen mit flexiblem Layout über Acrobat oder Adobe Reader auf dem Client wird eine bessere Leistung erzielt als bei der Wiedergabe auf dem Server. Der Grund dafür ist, dass die Client-Anwendungen Acrobat- und Adobe Reader den Wiedergabevorgang anstelle des Servers durchführen. Es können sogar Formulare mit flexiblem Layout auf dem Client wiedergegeben werden, bei denen Daten zusammengeführt werden.
Darüber hinaus wird bei der Client-seitigen Wiedergabe die Übermittlung des PDF-Inhalts optimiert, und die Fähigkeit von LiveCycle Forms zur Verarbeitung der Netzlast wird verbessert.
Zum Wiedergeben eines Formulars auf dem Client muss LiveCycle Forms für die Wiedergabe von Formularen auf dem Client eingestellt und ein Seed-PDF erstellt werden.
Die Seed-PDF-Datei ist ein Container, mit dem Sie dem Acrobat- oder Adobe Reader-Client eine XDP-Datei (als Teil des Datenstroms) liefern können. Sie dient als Ausgangswert, von dem aus eine dynamisch wiedergegebene PDF-Datei angezeigt wird, und kann eingebettete Schriften enthalten, die von der XPD-Datei benötigt werden. Mit Hilfe der Seed-PDF-Datei können Acrobat und Adobe Reader die XDP-Datei öffnen und das PDF-Dokument auf dem Client wiedergeben.
Weitere Informationen zu LiveCycle Forms und zur Wiedergabe von Formularen auf dem Client finden Sie im Handbuch Developing Custom Applications, das mit LiveCycle Forms geliefert wird.
Verwandte Themen
Info über das Erstellen von Formularentwürfen mit Layoutanpassungen an die Datenmenge
Ansätze zum Erstellen von Formularentwürfen


Zurück Weiter

LiveCycle Designer verwenden > Formulare für LiveCycle Forms erstellen > Grundlagen zum Entwerfen von Formularen LiveCycle Forms > Leistungsfähigkeit für LiveCycle Forms optimieren und verbessern > Formularfelder im Voraus mit Daten füllen

Formularfelder im Voraus mit Daten füllen

Mit Hilfe der LiveCycle Forms-Modul-API können alle Formulartypen im Voraus mit Daten gefüllt werden. Sie können ein Formular vor der Wiedergabe im Voraus mit Daten füllen, oder Sie können einen Formularentwurf mit Daten füllen, der von LiveCycle Designer als PDF-Formular gespeichert wurde. Die Daten können aus verschiedenen Quellen stammen, z. B. aus einer Datenbank, einem anderen Formular oder einer anderen Anwendung.
Das Füllen eines Formulars im Voraus hat eine Reihe von Vorteilen:
      •
      Der Benutzer kann benutzerdefinierte Daten in einem Formular anzeigen.
      •
      Der manuelle Eingabeaufwand für den Benutzer beim Ausfüllen eines Formulars verringert sich.
      •
      Die Datenintegrität wird sichergestellt, da die Platzierung der Daten gesteuert wird.
Das Ausfüllen von Formularen im Voraus ist schneller und sicherer, wenn das Vorausfüllen bei der Wiedergabe auf einem Server anstatt auf dem Client erfolgt.
XML-Datenquellen für die Datenzusammenführung überprüfen
Beim Vorausfüllen von Formularen mit Daten muss sichergestellt werden, dass entweder die Struktur der Daten der Struktur des Formularentwurfs entspricht, oder dass der Formularentwurf mit der Struktur der Daten übereinstimmt.
Das bedeutet also, dass für jedes Formularfeld, das im Voraus ausgefüllt werden soll, in der Datenquelle ein XML-Element vorhanden sein muss. Unstimmigkeiten zwischen der Struktur Ihres Formulars und der Datenquelle können zu einer fehlerhaften Ausgabe führen. Der XML-Elementname muss mit einem Formularfeldnamen übereinstimmen. XML-Elemente, die nicht mit Formularfeldern übereinstimmen, werden ignoriert.
Mit den folgenden beiden Datenquellen kann ein LiveCycle Designer-Formular vorausgefüllt werden:
      •
      Eine XDP-Datenquelle, die im XML-Format vorliegt und der XML-Formulararchitektursyntax entspricht
      •
      Eine beliebige XML-Datenquelle, die Name/Wert-Paare enthält, die den Formularfeldnamen entsprechen
Mit einer XML-Datenquelle können Formulare im Voraus ausgefüllt werden. Eine XML-Datenquelle, mit der ein Formular mit flexiblem Layout vorausgefüllt wird, enthält jedoch sich wiederholende XML-Elemente, die zum Vorausfüllen von Teilformularen verwendet werden, die im Formular selbst mehrfach vorkommen.
Weitere Informationen zum Vorausfüllen finden Sie im Handbuch Developing Custom Applications, das mit LiveCycle Forms geliefert wird.
Verwandte Themen
Info über das Binden von Feldern an eine Datenquelle
Zusammenführen von Daten testen
Info über das Erstellen von Formularentwürfen mit Layoutanpassungen an die Datenmenge


Formulare in LiveCycle Forms implementieren

Voraussetzungen für die Implementierung von Formularentwürfen in LiveCycle Forms
Speicherung von Formularentwürfen im XDP- oder PDF-Format?
Kopieren von Formularentwürfen in das lokale Netzwerk


Voraussetzungen für die Implementierung von Formularentwürfen in LiveCycle Forms

Die Implementierung von Formularentwürfen erfordert es, Formularentwürfe für LiveCycle Forms verfügbar zu machen. Bevor Sie Formularentwürfe in LiveCycle Forms implementieren, müssen noch einige vorbereitende Schritte abgeschlossen werden:
      •
      Der Entwickler der benutzerdefinierten Anwendung muss die Anforderungen für die Anwendung definieren. Das Dateiformat Ihres Formularentwurfs (XDP oder PDF) hängt von diesen Anforderungen ab.
      •
      Konvertierungsoptionen müssen in der LiveCycle Forms-API definiert werden, damit die erforderlichen Konvertierungen unterstützt werden. Der Entwickler der benutzerdefinierten Anwendung stellt die Optionen auf der Basis Ihrer Eingaben ein.
      •
      Wenn Sie ein Unterschriftobjekt in einem PDF-Formularentwurf verwenden, muss der Entwickler der benutzerdefinierten Anwendung eine Lösung eines Drittanbieters integrieren, damit digitale Unterschriften unterstützt werden.
Verwandte Themen
Speicherung von Formularentwürfen im XDP- oder PDF-Format?
Kopieren von Formularentwürfen in das lokale Netzwerk


Speicherung von Formularentwürfen im XDP- oder PDF-Format?

LiveCycle Forms akzeptiert Formularentwürfe in den folgenden Formaten:
      •
      XDP
      •
      PDF
XDP ist das von LiveCycle Designer erstellte Dateiformat. Wählen Sie dieses Format, um den Formularentwurf, alle Formulardaten, Anmerkungen, Ein-/Ausgabehilfe-Tags und alle anderen relevanten Informationen zu übergeben, die benötigt werden, damit LiveCycle Forms das Formular nachfolgend zur Laufzeit wiedergibt. Sie müssen dieses Format auswählen, wenn dieses Formular Server-seitige Verarbeitung initiiert.
Speichern Sie das Formular im PDF-Format, wenn es immer in Acrobat oder Adobe Reader geöffnet werden soll.
Wählen Sie PDF, wenn das Formular ein Dokumentunterschriftsfeld enthält, oder wenn erwartet wird, dass Benutzer Daten direkt im PDF-Formular zur Laufzeit speichern. Wenn das wiedergegebene Formular ein festes Layout besitzt, und Sie erwarten, dass das Formular häufig angefordert wird, kann die Bereitstellung des Formularentwurfs für LiveCycle Forms im PDF-Format die LiveCycle Forms-Laufzeitleistung verbessern.
Wählen Sie das PDF-Format nicht:
      •
      wenn das Formular die Server-seitige Verarbeitung initiiert
      •
      wenn LiveCycle Forms für die Wiedergabe von HTML-Formularen oder Formularen mit flexiblem Layout verwendet wird
Verwandte Themen
Voraussetzungen für die Implementierung von Formularentwürfen in LiveCycle Forms
Kopieren von Formularentwürfen in das lokale Netzwerk


Kopieren von Formularentwürfen in das lokale Netzwerk

Um Formularentwürfe für LiveCycle Forms bereitzustellen, benötigen Sie Schreibzugriff auf den Speicherort, von dem von LiveCycle Forms Dateien zur Laufzeit abgerufen werden. Der Entwickler der benutzerdefinierten Anwendung kann über den Speicherort Auskunft geben, und Ihr Netzwerkadministrator kann die erforderlichen Berechtigungen einrichten.
Fertige Formularentwürfe werden im lokalen Dateisystem gespeichert, damit der Entwickler auf die benutzerdefinierte Anwendung zugreifen kann. Sie müssen alle anderen Dateien einbeziehen, die für die Unterstützung des Formularentwurfs benötigt werden (z. B. Bilder).
Wenn Ihre Zugriffsberechtigungen eingerichtet sind, können Sie die Formularentwürfe mit Hilfe des Veröffentlichungsbefehls von LiveCycle Designer an diesem Speicherort veröffentlichen (wählen Sie „Datei“ > „In Repository veröffentlichen“).
Verwandte Themen
Voraussetzungen für die Implementierung von Formularentwürfen in LiveCycle Forms
Speicherung von Formularentwürfen im XDP- oder PDF-Format?


Formularentwürfe zum Erstellen von HTML-Formularen optimieren

HTML-Formulare
Teilformulare für die Erstellung von HTML-Seiten verwenden
Überlegungen zum Layout für HTML-Formulare
Bildrichtlinien für die Erstellung von HTML-Formularen
Webbrowser-Beschränkungen umgehen
So aktivieren Sie die Konvertierungs-Zwischenspeicherung für Formulare mit festem Layout
Vorschau eines HTML-Formulars


HTML-Formulare

LiveCycle Forms kann sowohl HTML-Formulare als auch PDF-Formulare wiedergeben. Um HTML-Formulare zu verteilen, müssen Sie Ihre Formularentwürfe als XDP-Dateien speichern und die XDP-Dateien und alle anderen ergänzenden Dateien, wie z. B. Bilder, in LiveCycle Forms implementieren.
Sie können interaktive Formulare im HTML-Format wiedergeben lassen. Da HTML-Formulare in einer Client-Anwendung, wie z. B. einem Webbrowser angezeigt werden, unterliegen sie den Beschränkungen der Client-Anwendungsumgebung.
Beispielsweise können Sie in Ihren Formularentwürfen JavaScript einbeziehen und so einrichten, dass das JavaScript zur Laufzeit als Teil des HTML-Formulars zur Client-Anwendung heruntergeladen wird. Im Browser muss jedoch JavaScript-aktiviert sein, damit das Skript ausgeführt werden kann.
LiveCycle Forms 7.2 bietet keine Unterstützung für Tabellen in Formularentwürfen, die als HTML-Formulare wiedergegeben werden.
Verwandte Themen
Info über interaktive Formulare
Formularentwürfe, die LiveCycle Forms unterstützt
Info über das Erstellen von Formularentwürfen mit Layoutanpassungen an die Datenmenge


Teilformulare für die Erstellung von HTML-Seiten verwenden

Wenn ein Formularentwurf Teilformulare enthält, die erweitert werden, ist es schwierig, genau zu wissen, wie viele Seiten im resultierenden Formular zur Laufzeit wiedergegeben werden. Die Seitengrößeneinstellung wird für den Seitenumbruch von PDF-Formularen verwendet, doch bei der Wiedergabe eines HTML-Formulars wird sie ignoriert, da HTML-Seiten beliebig lang sein können.
Um das Konzept eines mehrseitigen HTML-Formulars zu implementieren, können Sie Ihrem Formularentwurf ein Teilformular auf Seitenniveau hinzufügen. Sie benötigen für jede Seite, die im Formular wiedergegeben werden soll, eines dieser Teilformulare. Für Formulare, deren Layout sich an die entsprechende Datenmenge anpasst, sollte jedes Teilformular mit fließendem Inhalt innerhalb eines der Teilformulare auf Seitenniveau geschachtelt sein. Wenn das Formular danach wiedergegeben wird, werden alle Inhalte, die zum gleichen Teilformular auf Seitenniveau gehören, auf der gleichen HTML-Seite angezeigt.
Um das Konzept eines mehrseitigen HTML-Formulars zu implementieren, müssen Sie in jedem Teilformular auf Seitenniveau eine oder mehrere Schaltflächen einfügen, damit die Benutzer von einer Seite zur nächsten wechseln können. Ihr Formularentwickler muss ein Skript schreiben, um die Verarbeitung zu steuern, wenn ein Benutzer auf eine dieser Schaltflächen klickt.
Betrachten Sie zum Beispiel den Formularentwurf der folgenden Abbildung. Der Formularentwurf enthält drei Teilformulare: „Subform_Page0“, „Subform_Page1“ und „Subform_LastPage“. Wenn LiveCycle Forms ein HTML-Formular auf der Basis dieses Formularentwurfs wiedergibt, wird automatisch von jedem Teilformular auf Seitenniveau eine HTML-Seite erstellt.
Wenn LiveCycle Forms das HTML-Formular zur Laufzeit wiedergibt, wird das erste Teilformular auf Seitenniveau auf der ersten Seite angezeigt. Für den Zweck dieses Beispiels kann die erste Seite ähnlich wie die hier gezeigte Seite aussehen. Beachten Sie, dass die Schaltfläche „Nächste Seite“ eingefügt werden muss, um Benutzern den Wechsel zur nächsten Seite des Formulars zu ermöglichen.
Vorausgesetzt, dass mindestens ein Eintrag zum Zusammenführen mit „Expanding_subform“ zur Laufzeit verfügbar ist, kann die zweite Seite ähnlich aussehen wie die folgende Beispielseite. Wieder wird eine „Nächste Seite“-Schaltfläche benötigt, damit die Benutzer zur nächsten Seite des Formulars wechseln können. Sie sollten Ihrem Formular außerdem eine „Vorherige Seite“-Schaltfläche hinzufügen.
Das dritte Teilformular auf Seitenniveau, „Subform_LastPage“, wird auf der letzten Seite des wiedergegebenen Formulars angezeigt. In diesem Beispiel wird den Benutzern auf der letzten Seite für das Ausfüllen des Formulars gedankt, und eine Schaltfläche für die Übergabe der eingegebenen Daten an LiveCycle Forms wird angezeigt.
Weitere Informationen über das Schreiben eines Skripts, das Benutzern den Wechsel zwischen HTML-Seiten ermöglicht, finden Sie unter Skripten für die Handhabung von HTML-Seiten schreiben.
Verwandte Themen
Überlegungen zum Layout für HTML-Formulare
Bildrichtlinien für die Erstellung von HTML-Formularen
Webbrowser-Beschränkungen umgehen


Überlegungen zum Layout für HTML-Formulare

Die folgenden Informationen sollen Ihnen bei der Erstellung von HTML-Formularen helfen, die visuell ansprechend und leicht lesbar sind:
      •
      Verwenden Sie keine Begrenzungseigenschaften eines Objekts, um Linien, Felder und Raster auf Ihr Formular zu zeichnen. In einigen Browsern werden die Ränder vielleicht anders dargestellt als in einer LiveCycle Designer-Vorschau. Die Objekte erscheinen eventuell übereinander oder schieben andere Objekte von ihren vorgesehenen Positionen.
      •
      Wenn Benutzer Microsoft Internet Explorer verwenden, können Sie den Hintergrund des Formulars anhand von Linien, Rechtecken und Kreisen gestalten. Alle anderen Webbrowser unterstützen nur vertikale und horizontale Linien, d. h. Rechtecke und Kreise im Formularentwurf werden zur Laufzeit nicht angezeigt.
      •
      Verwenden Benutzer Opera-Browser, erstellen Sie Felder, die etwas größer sind, als Sie es möchten. Felder haben in Opera immer einen vertieften inneren Rand. Die von Ihnen ausgewählten Begrenzungsattribute werden außerhalb dieses Randes gelegt. Da der vertiefte Rand im Feld Raum einnimmt, wird der ausfüllbare Bereich verringert.
      •
      Erstellen Sie statischen Text etwas größer als erforderlich zu sein scheint, um den Text unterzubringen. LiveCycle Designer und Acrobat verwenden unter Umständen andere Kerning-Einstellungen als ein bestimmter Webbrowser, und einige Textstellen werden möglicherweise nicht korrekt angezeigt.
      •
      LiveCycle Forms 7.2 bietet keine Unterstützung für Tabellen in Formularentwürfen, die als HTML-Formulare wiedergegeben werden.
      •
      LiveCycle Forms 7.2 bietet keine Unterstützung für Formularentwürfe mit arabischen, hebräischen, thailändischen und vietnamesischen Schriftzeichen.
Verwandte Themen
Bildrichtlinien für die Erstellung von HTML-Formularen
Webbrowser-Beschränkungen umgehen


Bildrichtlinien für die Erstellung von HTML-Formularen

Bei der Auswahl von Bildern für Ihre Formularentwürfe können Sie jede Bilddatei (außer animierte GIF-Dateien) einfügen, die den Beschränkungen des Webbrowsers unterliegen, mit denen Benutzer HTML-Formulare anzeigen.
Betten Sie keine Bilder im Formular ein. LiveCycle Forms unterstützt keine eingebetteten Bilder. Verwenden Sie stattdessen relative Pfadnamen, um Bilddateien einzufügen.
Beispielsweise kann der Pfad relativ zum Formular-Stammverzeichnis von LiveCycle Forms sein, das standardmäßig der als „Formular-Repository“ vorgesehene Ordner ist. Der Bilderordner im folgenden Pfad befindet sich auf der gleichen Ebene wie der Formularordner:
../images/graphic.jpg
Verwandte Themen
Überlegungen zum Layout für HTML-Formulare
Webbrowser-Beschränkungen umgehen


Webbrowser-Beschränkungen umgehen

Wenn Sie damit rechnen, dass einige der Benutzer Browser mit begrenzten Fähigkeiten verwenden, sollten Sie vom kleinsten gemeinsamen Nenner ausgehen und Ihre Formulare entsprechend erstellen. Wenn Ihre Organisation jedoch Browser verwendet, die XHTML unterstützen, stehen Ihnen mehr Optionen für die Erstellung Ihres Formularentwurfs zur Verfügung.
Berücksichtigen Sie bei der Erstellung von Formularen, die in unterschiedlichen Browsern angezeigt werden, folgende Punkte:
      •
      Geben Sie eine Seitengröße ein, um sicherzustellen, dass die HTML4-Konvertierung (für Netscape Navigator 4.7.x) alle statischen Objekte ordnungsgemäß anzeigt. Andernfalls wird für die Felder nur bei Wiedergabe des Formulars genügend Platz reserviert.
      •
      Lassen Sie oben und links auf dem Formular einen mindestens 1/4-Zoll breiten Rand. Alles was oberhalb und links dieses Randes liegt, ist nicht sichtbar.
      •
      Objekte oder Teile von Objekten, die auf negativen Rasterkoordinaten gezeichnet wurden, werden nicht angezeigt. Wenn Sie z. B. ein Objekt von der vertikalen Rasterkoordinate -0,50 aus zeichnen, wird der Teil des Objekts, der zwischen -0,50 und der inneren Kante eines 1/4-Zoll-Randes liegt, nicht angezeigt.
      •
      Lassen Sie um Felder herum genügend Platz, um visuelle Einbußen in einem Low-end-Browser zu kompensieren. Beispielsweise werden in einigen Browsern die Kontrollkästchen und Optionsfelder größer angezeigt, als sie konzipiert wurden.
      •
      Bei der Verwendung eines Low-end-Browsers zum Anzeigen des Formulars kann jede Linksausrichtung von Daten verloren gehen, insbesondere, wenn Benutzer die mit ihren Browsern verknüpften Standardschriftarten ändern.
Verwandte Themen
Überlegungen zum Layout für HTML-Formulare
Bildrichtlinien für die Erstellung von HTML-Formularen


Zurück Weiter

LiveCycle Designer verwenden > Formulare für LiveCycle Forms erstellen > Formularentwürfe zum Erstellen von HTML-Formularen optimieren > So aktivieren Sie die Konvertierungs-Zwischenspeicherung für Formulare mit festem Layout

So aktivieren Sie die Konvertierungs-Zwischenspeicherung für Formulare mit festem Layout

LiveCycle Forms verwendet Konvertierungs-Zwischenspeicherung, um die Leistung zu verbessern. Damit LiveCycle Forms Formulare mit festem Layout zur Laufzeit richtig zwischenspeichert, müssen Sie jedes Mal die Eigenschaft für die Formular-Zwischenspeicherung aktivieren, wenn Sie ein solches Formular erstellen.
1.
Wählen Sie „Datei“ > „Formulareigenschaften“.
2.
Klicken Sie auf die Registerkarte „Standard“, und aktivieren Sie das Kontrollkästchen „Formularwiedergabe über Cache auf Server zulassen“.
3.
Klicken Sie auf „OK“.
Verwandte Themen
Formularkonvertierungen


Vorschau eines HTML-Formulars

Um die Funktion Ihres Formularentwurfs mit LiveCycle Forms zu testen und Befehlsschaltflächen in einem Formularentwurf korrekt einzurichten, muss Ihnen die URL bekannt sein, die mit den Anfragen an LiveCycle Forms verknüpft ist. Der Entwickler der benutzerdefinierten Anwendung kennt die URL.
Um ein HTML-Formular in der Vorschau anzuzeigen, müssen Sie den Formularentwurf für LiveCycle Forms verfügbar machen, damit dieser den Formularentwurf speichern kann. Danach können Sie das Formular über die URL anfordern, die mit LiveCycle Forms verknüpft ist. Verwenden Sie einen Webbrowser oder eine der Ziel-Client-Anwendungen (wie z. B. eine Bildschirmlesehilfe), um das Formular zu öffnen.
LiveCycle Forms 7.2 bietet keine Unterstützung für Tabellen in Formularentwürfen, die als HTML-Formulare wiedergegeben werden. LiveCycle Forms 7.2 bietet auch keine Unterstützung für Formularentwürfe mit arabischen, hebräischen, thailändischen und vietnamesischen Schriftzeichen.
Verwandte Themen
Voraussetzungen für die Implementierung von Formularentwürfen in LiveCycle Forms
Kopieren von Formularentwürfen in das lokale Netzwerk


Intelligente Formulare verarbeiten

Wo Berechnungen und Skripten ausgeführt werden
Client- und Server-seitige Verarbeitung
Ereignisse, die Sie in einem Skript oder einer Berechnung referenzieren können
Übersicht der unterstützten Eigenschaften, Methoden und Ereignisse
Von HTML-Clients unterstützte Ausdrücke
Skripten für die Handhabung von HTML-Seiten schreiben


Wo Berechnungen und Skripten ausgeführt werden

Sie können Berechnungen und Skripten in einen Formularentwurf einbetten, um Berechnungen, Methoden oder Operationen auszuführen, wenn Objektereignisse zur Laufzeit auftreten. Beispielsweise tritt ein Ereignis zur Laufzeit ein, wenn der Benutzer die durch das Ereignis angegebene Aktion durchführt. Durch Definieren eines Skripts können Sie eines der vom Objekt unterstützten Verfahren aufrufen und Eigenschaften prüfen oder festlegen.
In LiveCycle Designer sind Skripten und Berechnungen standardmäßig für eine Ausführung auf dem Client-Gerät vorgesehen. Der Standard-Verarbeitungsort wird auf der Registerkarte „Standard“ des Dialogfeldes „Formulareigenschaften“ definiert (wählen Sie „Datei“ > „Formulareigenschaften“). Um den Standard-Verarbeitungsort zu ändern, können Sie explizit einen anderen Verarbeitungsort angeben, indem Sie die Option „Ausführen am“ im Skript-Editor verwenden, wenn Sie ein Skript oder eine Berechnung an ein Objekt anhängen.
Wenn Sie LiveCycle Forms verwenden, kann die Verarbeitung auf dem Client, dem Server oder auf beiden stattfinden. Wenn Sie angeben, dass ein Skript/eine Berechnung auf dem Client und auf dem Server ausgeführt werden soll, kann es vorkommen, dass sowohl der Client als auch der Server versuchen, das Skript/die Berechnung auszuführen. Von LiveCycle Forms wird versucht, das Skript/die Berechnung immer dann auszuführen, wenn der Client nicht dazu in der Lage ist. Wenn Skripten/Berechnungen für eine Ausführung auf dem Server vorgesehen sind, werden von LiveCycle Forms die Skripten und/oder Berechnungen ausgeführt, die Ergebnisse im Formular zusammengeführt und beide an den Client zurückgegeben.
Client-seitige Skripten und Berechnungen werden auf dem Client-Gerät ausgeführt. Beim Erstellen von PDF-Formularen für Acrobat oder Adobe Reader muss die gesamte Verarbeitung auf dem Client erfolgen. Wenn jedoch der Client das Skript oder die Berechnung nicht ausführen kann, versucht LiveCycle Forms das Skript oder die Berechnung auszuführen.
Um ein Client-seitiges Skript in einem HTML-Formular erfolgreich auszufüllen, müssen bestimmte Bedingungen erfüllt werden:
      •
      Die Client-Anwendung muss Microsoft Internet Explorer 5.x, Netscape 6.0 oder höher oder Opera 5 oder höher sein.
      •
      JavaScript kann nur zum Schreiben von Skripten verwendet werden. (Sie können keine FormCalc-Berechnungen in den Formularentwurf einbeziehen.)
      •
      JavaScript muss in der Client-Anwendung aktiviert sein.
LiveCycle Forms 7.1 bietet keine Unterstützung für Tabellen in Formularentwürfen, die als HTML-Formulare wiedergegeben werden.
Verwandte Themen
Client- und Server-seitige Verarbeitung
Ereignisse, die Sie in einem Skript oder einer Berechnung referenzieren können
Von HTML-Clients unterstützte Ausdrücke
Skripten für die Handhabung von HTML-Seiten schreiben
FormCalc


Client- und Server-seitige Verarbeitung

Die Verarbeitung kann auf dem Client, Server oder auf beiden ausgeführt werden. Skripten und Berechnungen verhalten sich bei Ausführung auf dem Client anders als auf dem Server.
Client-seitige Verarbeitung
Wenn die Verarbeitung dazu eingestellt ist, zur Laufzeit auf dem Client stattzufinden, werden alle Skripten/Berechnungen auf dem Computer des Benutzers in Echtzeit ausgeführt. Der Code und die deklarierten Variablen werden fast zeitgleich mit dem Öffnen des Formulars verfügbar. Diese Informationen bleiben verfügbar, und der Zustand der Daten wird beibehalten, bis eine der folgenden Situationen auftritt:
      •
      Ein anderes Skript wird ausgeführt.
      •
      Ein anderes Skript entfernt das verknüpfte Objekt.
      •
      Das Formular wird geschlossen.
Server-seitige Verarbeitung
LiveCycle Forms kann alle Skripten/Berechnungen verwalten, die die Client-Anwendung nicht verwalten kann. Um beispielsweise ein Formular im Voraus aufzufüllen, müssen Sie möglicherweise ein Skript verwenden, um eine Verbindung zu einer Datenbank oder einem Webdienst aufzubauen, die bzw. der auf dem Client möglicherweise nicht verfügbar ist. Wenn von LiveCycle Forms ein Skript oder eine Berechnung ausgeführt wird, erfolgt die Ausführung, während das Formular wiedergegeben wird. Kein Code oder keine Variable bleibt nach Abschluss der Verarbeitung verfügbar. Das heißt, wenn Sie Variablen zu einem Skript oder einer Berechnung hinzufügen, bleiben diese nur während der Dauer der Verarbeitung gültig.
Wenn Sie die HTML4-Konvertierung zur Unterstützung von Netscape Navigator 4.7.x gewählt haben, wird jedes JavaScript, das zur Ausführung auf dem Client konzipiert ist, stattdessen automatisch auf dem Server ausgeführt.
LiveCycle Forms 7.1 bietet keine Unterstützung für Tabellen in Formularentwürfen, die als HTML-Formulare wiedergegeben werden.
Verwandte Themen
Wo Berechnungen und Skripten ausgeführt werden
FormCalc


Ereignisse, die Sie in einem Skript oder einer Berechnung referenzieren können

Server-seitige Skripten
Acrobat und Adobe Reader erkennen alle von LiveCycle Designer unterstützten Ereignisse. Die Client-Anwendung sendet durch den Benutzer initiierte Ereignisse an LiveCycle Forms zur Server-seitigen Verarbeitung. Keine anderen Ereignistypen lösen Server-seitige Verarbeitung aus. Von LiveCycle Forms wird jedes Mal Server-seitige Verarbeitung ausgeführt, wenn ein Formular wiedergegeben, vom Client initiierte Serverereignisse ausgeführt oder übergebene Daten verarbeitet werden.
Wenn Sie angeben, dass ein Skript oder eine Berechnung auf dem Server ausgeführt werden soll, bewirken folgende durch den Benutzer initiierte Ereignisse, dass Acrobat oder Adobe Reader das Ereignis zur Verarbeitung an LiveCycle Forms sendet:
      •
      exit
      •
      mouseEnter
      •
      mouseExit
      •
      change
      •
      mouseUp
      •
      mouseDown
      •
      click
Während der Ereignisverarbeitung werden von LiveCycle Forms alle Skripten /Berechnungen, die für eine Ausführung auf dem Server vorgesehen sind, verarbeitet und die Ergebnisse erneut im Formular zusammengeführt, bevor dies zur Client-Anwendung zurückgegeben wird.
Wenn eines dieser Ereignisse in einem Server-seitigen Skript/einer Server-seitigen Berechnung referenziert wird, werden sie von Acrobat oder Adobe Reader ignoriert:
      •
      initialize
      •
      calculate
      •
      validate
      •
      docReady
      •
      docClose
Die folgende Tabelle identifiziert die Ereignisse, die Sie nur in Server-seitigen Skripten/Berechnungen referenzieren können. Diese Ereignisse werden von HTML-Client-Anwendungen nicht erkannt.

Ereignis

Weitere Informationen finden Sie unter
form:ready
form:ready-Ereignis
layout:ready
layout:ready-Ereignis
Ist ein Skript für eine Ausführung auf dem Server vorgesehen, dann ist das click-Ereignis (einer normalen Schaltfläche) das einzige Ereignis, das bewirkt, dass ein HTML-Client Server-seitige Verarbeitung initiiert. Während der Verarbeitung setzt LiveCycle Forms die Ergebnisse erneut in das HTML-Formular zusammen, bevor es zur Client-Anwendung zurückgegeben wird. Alle anderen Ereignisse werden vom HTML-Client ignoriert und nur ausgeführt, wenn LiveCycle Forms Server-seitige Verarbeitung durchführt.
Client-seitige Skripten
Für Client-seitige Skripterstellung und Client-seitige Berechnungen unterstützen Acrobat und Adobe Reader alle Ereignisse, die Sie in LiveCycle Designer definieren können.
Jedoch werden nicht alle dieser Ereignisse von HTML-Clients erkannt. Wenn Sie einen einzelnen Formularentwurf verwenden, um sowohl PDF- als auch HTML-Formulare zu erstellen, sollten Ihre Client-seitigen Skripten nur einen Teil der unterstützten Ereignisse referenzieren.
Wenn ein Client-seitiges Skript ein Ereignis referenziert, das vom HTML-Client nicht erkannt wird, stoppt das Skript die Ausführung an dem Punkt, an dem das nicht erkannte Ereignis referenziert wird.
Verwenden Sie die folgenden Ereignisse, um Client-seitige Skripten von HTML-Formularen auszuführen.
]

Ereignis

Weitere Informationen finden Sie unter
initialize
initialize-Ereignis
enter
enter-Ereignis
exit
exit-Ereignis
calculate
calculate-Ereignis
Nur in HTML-Formularen werden Aktivitäten ausgeführt, die durch Berechnungsereignisse ausgelöst werden, wenn der Cursor ein Feld verlässt. Die Verarbeitung wird nicht gestartet, wenn ein Benutzer einen Feldwert ändert, jedoch können Sie, falls erforderlich, die Verarbeitung zu diesem Zeitpunkt explizit aufrufen und die execCalculate()-Methode verwenden.
validate
validate-Ereignis
change
change-Ereignis
In PDF- und HTML-Formularen wird dieses Ereignis nur für Dropdown-Listen und Listenfelder unterstützt.
mouseUp
mouseUp-Ereignis
mouseDown
mouseDown-Ereignis
click
click-Ereignis
Das click-Ereignis kann in PDF- oder HTML-Formularen nicht für Schaltflächen zum Senden verwendet werden. Verwenden Sie statt dessen das Ereignis „preSubmit“.
preSubmit
preSubmit-Ereignis
In PDF- und HTML-Formularen wird dieses Ereignis nur für Schaltflächen zum Senden unterstützt. Wenn Sie das „preSubmit“-Ereignis verwenden, um ein Client-seitiges Skript auszuführen, erfolgt die Verarbeitung vor Übergabe der Daten. Wenn das Ereignis ein Skript auf dem Server ausführt, erfolgt die Verarbeitung, während die Daten übergeben werden.
Verwandte Themen
Übersicht der unterstützten Eigenschaften, Methoden und Ereignisse
Wo Berechnungen und Skripten ausgeführt werden
Berechnungen und Skripten


Übersicht der unterstützten Eigenschaften, Methoden und Ereignisse

Mit Ausnahme einiger Host-Objekt-Methoden, unterstützen Acrobat und Adobe Reader alle Eigenschaften, Methoden und Ereignisse. HTML-Clients erkennen eine begrenzte Anzahl dieser Eigenschaften, Methoden und Ereignisse.
Wenn Sie einen einzelnen Formularentwurf verwenden, um sowohl PDF-Formulare als auch HTML-Formulare zu erstellen, werden Ihre Skripten möglicherweise einen Teil der unterstützten Eigenschaften, Methoden und Ereignisse referenzieren.
LiveCycle Forms 7.1 bietet keine Unterstützung für Tabellen in Formularentwürfen, die als HTML-Formulare wiedergegeben werden.
Die folgenden Tabellen fassen zusammen, welche Client-Anwendungen die verschiedenen Eigenschaften, Methoden und Ereignisse erkennen, die Sie in Client- und/oder Server-seitigen Skripten referenzieren können.

Host-Objekt

Acrobat / Adobe Reader

HTML-Client

Eigenschaften
currentPage (schreibgeschützt)
Ja
Ja
numPages (schreibgeschützt)
Ja
Ja
name (schreibgeschützt)
Ja
Ja
validationsEnabled
Ja
Ja
calculationsEnabled
Ja
Ja

Methoden
pageUp
Ja
Nur Client und Server.
pageDown
Ja
Nur Client und Server.
exportData
Ja
Nein
importData
Ja
Nein
gotoURL
Nur Client.
Nur Client.
messageBox
Nur Client.
Nur Client.
resetData
Ja
Ja
setFocus
Nur Client.
Nur Client.

Ereignisse
docReady
Ja
Nur Server.
docClose
Ja
Nur Server.
postPrint
Ja
Nein
postSave
Ja
Nein
prePrint
Ja
Nein
preSave
Ja
Nein

Formularobjekt

Acrobat / Adobe Reader

HTML-Client

Methoden
resolveNodes
Ja
Ja
resolveNode
Ja
Ja
execCalculate
Ja
Ja
execValidate
Ja
Ja
execInitialize
Ja
Ja

Teilformularobjekt

Acrobat / Adobe Reader

HTML-Client

Eigenschaften
name (schreibgeschützt)
Ja
Ja
index (schreibgeschützt)
Ja
Ja
x
Ja
Ja
y
Ja
Ja
w
Ja
Ja
h
Ja
Ja
validationMessage
Ja
Ja

Methoden
resolveNodes
Ja
Ja
resolveNode
Ja
Ja
execCalculate
Ja
Ja
execValidate
Ja
Ja
execInitialize
Ja
Ja

Ereignisse
enter
Ja
Ja
exit
Ja
Ja
initialize
Ja
Ja
validate
Ja
Ja
calculate
Ja
Ja

Feldobjekte

Acrobat / Adobe Reader

HTML-Client

Eigenschaften
name (schreibgeschützt)
Ja
Ja
index (schreibgeschützt)
Ja
Ja
rawValue
Ja
Ja
formattedValue
Siehe Hinweis 1.
Ja
x
Ja
Ja
y
Ja
Ja
w
Ja
Ja
h
Ja
Ja
presence
Ja
Ja
mandatory
Ja
Ja
fontColor
Ja
Ja
fillColor
Ja
Ja
borderColor
Ja
Ja
borderWidth
Ja
Ja
validationMessage
Ja
Ja

Methoden
execCalculate
Ja
Ja
execInitialize
Ja
Ja
execValidate
Ja
Ja
addItem
Ja, nur für Dropdown-Listen und Listenfelder.
Ja, nur für Dropdown-Listen und Listenfelder.
clearItems
Ja, nur für Dropdown-Listen und Listenfelder.
Ja, nur für Dropdown-Listen und Listenfelder.
resolveNodes
Ja
Ja
resolveNode
Ja
Ja

Ereignisse
exit
Ja
Ja
enter
Ja
Ja
calculate
Ja
Ja
validate
Ja
Ja
initialize
Ja
Ja
click
Ja, aber nicht für Senden-Schaltflächen. Siehe Hinweis 2.
Ja, aber nicht für Senden-Schaltflächen. Siehe Hinweis 2.
change
Ja
Ja, nur für Dropdown-Listen und Listenfelder.
mouseUp
Ja
Ja
mouseDown
Ja
Ja
preSubmit
Ja
Ja, nur für Senden-Schaltflächen.
Hinweis 1: Für Listenfelder gibt „formattedValue“ nicht den Anzeigetext zurück.
Hinweis 2: Das „click“-Ereignis wird für Senden-Schaltflächen in PDF- oder HTML-Formularen nicht unterstützt. Verwenden Sie stattdessen „preSubmit“.

ScriptObject-Objekt

Acrobat / Adobe Reader

HTML-Client
Siehe Hinweis 3.
Ja
Ja
Hinweis 3: Das ScriptObject-Objekt kann mit jedem anderen Skript erstellt und verwendet werden. Siehe So erstellen Sie ein Skriptobjekt.

Ereignisobjekt

Acrobat / Adobe Reader

HTML-Client

Eigenschaften
prevText
Ja
Nein
prevContentType
Ja
Nein
newText
Ja
Nein
newContentType
Ja
Nein
fullText
Ja
Nein
commitKey
Ja
Nein
keyDown
Ja
Nein
modifier
Ja
Nein
name
Ja
Nein
selEnd
Ja
Nein
selStart
Ja
Nein
shift
Ja
Nein
target
Ja
Nein
change
Ja
Nein


Von HTML-Clients unterstützte Ausdrücke

Eine vereinfachte Teilmenge von Ausdrücken der Referenz-Syntax wird von HTML-Clients unterstützt:
      •
      Symbol-Tastaturbefehle (z. B. $form, $data und $host) werden nicht unterstützt.
      •
      Die Syntax der Auslassungspunkte (...) wird nicht unterstützt.
      •
      Beim Schreiben eines Client-seitigen Skripts für HTML-Formulare müssen Sie den JavaScript-Ausdruck „resolveNode“ verwenden, um Nodes in der Hierarchie zu suchen. Das Skript kann nicht die Hierarchie unter Verwendung der Objektschreibweise durchlaufen. Beispielsweise wird der folgende Ausdruck nicht unterstützt:

xfa.form.subform1.TextEdit1
Der folgende Ausdruck wird unterstützt:
xfa.form.resolveNode("subform1.TextEdit1")
Unqualifizierte Feldreferenzen können verwendet werden, um nebengeordnete Felder in der Hierarchie zu suchen.
Wenn Sie die HTML4-Konvertierung zur Unterstützung von Netscape Navigator 4.7.x gewählt haben, wird jedes JavaScript, das zur Ausführung auf dem Client konzipiert ist, stattdessen automatisch auf dem Server ausgeführt.
LiveCycle Forms 7.1 bietet keine Unterstützung für Tabellen in Formularentwürfen, die als HTML-Formulare wiedergegeben werden.


Skripten für die Handhabung von HTML-Seiten schreiben

Wenn für die Wiedergabe von PDF- und HTML-Formularen der gleiche Formularentwurf verwendet wird, erfolgt der Seitenumbruch des PDF-Formulars aufgrund der Seitengrößeneinstellung. Diese wird bei der Wiedergabe des HTML-Formulars jedoch ignoriert. Um die Unterschiede zwischen PDF- und HTML-Seiten auszugleichen, können Formularverfasser optional Unterformulare auf Seitenniveau zum Einrichten künstlicher HTML-Seiten verwenden. Wenn HTML-Seiten auf diese Art eingerichtet werden, wird JavaScript benötigt, um Benutzern zur Laufzeit das Wechseln zwischen HTML-Seiten zu ermöglichen.
LiveCycle Forms 7.1 bietet keine Unterstützung für Tabellen in Formularentwürfen, die als HTML-Formulare wiedergegeben werden.
Sie können die pageUp()- und die pageDown()-Methode verwenden, um Benutzern das Wechseln zwischen HTML-Seiten mit Hilfe einer normalen Befehlsschaltfläche zu ermöglichen, die die Verarbeitung auslöst, wenn sich das click-Ereignis der Schaltfläche ereignet. Sowohl für PDF- als auch für HTML-Formulare muss die Verarbeitung auf dem Client und Server ausgeführt werden.
Die pageUp()- und pageDown()-Methoden operieren auf dem Seitenniveau der Unterformulare. Nehmen Sie beispielsweise an, dass der Formularverfasser folgende Struktur im Formularentwurf eingerichtet hat:
Wenn der Benutzer die HTML-Seite anzeigt, die „Subform_Page0“ entspricht, bewirkt der Aufruf von „xfa.host.pageDown()“, dass „Subform_Page1“ im Browser angezeigt wird. Ähnlich bewirkt der Aufruf von „xfa.host.pageUp()“ während „Subform_Page1“ angezeigt wird, dass die Anzeige von „Subform_Page0“ im Browser erfolgt. Seitenzahlen werden den folgenden Eigenschaften zugeordnet, um diese HTML-Seiten zu bearbeiten:
xfa.host.currentPage = 0 	//moves to the first page
xfa.host.currentPage = 1 	//moves to the second page
xfa.host.currentPage = 2 	//moves to the third page
xfa.host.currentPage = xfa.host.numPages -1 	//moves to the last page
Während Benutzer zwischen HTML-Seiten wechseln, bleibt der Zustand der Daten erhalten, doch der Darstellungszustand eines Objekts (z. B. die Hintergrundfarbe eines Feldes) kann sich von Seite zu Seite ändern. Sie können Darstellungseinstellungen zwischen Seiten mit Hilfe ausgeblendeter Felder beibehalten, die Zustandswerte für verschiedene Einstellungen und Befehlsschaltflächen enthalten, die Benutzern das Zurück- und Vorwärtsblättern in einem Formular ermöglichen. Ihr Skript aktualisiert die Darstellungszustände von Feldern auf der Basis von Werten in ausgeblendeten Feldern. Wenn ein Benutzer auf eine der Befehlsschaltflächen klickt, kann das calculate-Ereignis für die Schaltfläche zum Ausführen des Skripts verwendet werden.
Beispielsweise behält das folgende JavaScript auf der Basis eines Wertes des Feldes „hiddenField“ die Füllfarbe bei. Das Skript wird ausgelöst, wenn sich das calculate-Ereignis ereignet.
If (hiddenField.rawValue == 1)
this.fillColor = “255,0,0”
else
this.fillColor = “0,255,0”
Bei der Ausführung von Skripten in einem HTML-Formular auf dem Client-Gerät, können Sie nur gegen das aktuelle Unterformular/die aktuelle HTML-Seite ein Skript einsetzen.
Verwandte Themen
pageDown
pageUp
currentPage


Formulare für LiveCycle Workflow erstellen

Adobe LiveCycle Workflow
So erstellen Sie ein Formular für LiveCycle Workflow
Für LiveCycle Workflow erforderliche Objekte


Adobe LiveCycle Workflow

Mit Adobe® LiveCycle™ Workflow können Sie automatisierte Geschäftsprozesse entwerfen, implementieren und verwalten, die Systeme und Menschen miteinander verbinden. LiveCycle Workflow bietet mehrere Werkzeuge, mit deren Hilfe Sie die angestrebte Automatisierung von Geschäftsprozessen umsetzen können:
LiveCycle Workflow Designer
Eine Desktop-Anwendung, mit der Sie die elektronischen Definitionen der Geschäftsprozesse erstellen und auf dem Server implementieren können.
LiveCycle Workflow Server
Eine Server-Anwendung, die die elektronischen Definitionen der Geschäftsprozesse ausführt und die Prozessaktivitäten koordiniert.
LiveCycle-Verwaltung
Eine webbasierte Anwendung, mit der Sie die Benutzerauthentifizierung und -autorisierung für alle LiveCycle-Produkte konfigurieren, die Laufzeit-Eigenschaften von LiveCycle Workflow Server definieren und den Prozessablauf während der Prozessausführung verwalten können.
LiveCycle Workflow Business Activity Monitor
Ein Satz webbasierter Anwendungen, mit denen Sie die Datenanzeige erstellen und anzeigen können, die auf Echtzeitdaten aus automatisierten Geschäftsprozessen basiert.
Weitere Informationen zu diesen Werkzeugen finden Sie unter LiveCycle Workflow - Übersicht.
Verwandte Themen
So erstellen Sie ein Formular für LiveCycle Workflow
Für LiveCycle Workflow erforderliche Objekte


So erstellen Sie ein Formular für LiveCycle Workflow

Mit Adobe LiveCycle Designer können Sie Formulare für LiveCycle Workflow erstellen. Für LiveCycle Workflow entworfene Formulare müssen bestimmte Objekte enthalten. Um Ihnen die Arbeit zu erleichtern, haben wir ein einzelnes benutzerdefiniertes Objekt erstellt, das die Verarbeitung des Formulars mit LiveCycle Workflow Server ermöglicht. Mit Hilfe dieses Objekts („Adobe LiveCycle Workflow-Felder“) können Sie einem Formular rasch die erforderlichen Objekte hinzufügen. Das Objekt befindet sich in der Kategorie „Eigene“ der Palette „Bibliothek“.
Das benutzerdefinierte Objekt fügt erforderliche Objekte wie z. B. eine Senden-Schaltfläche, ein Popup-Menü mit Aktionen sowie eine Reihe von verborgenen Feldern hinzu. Diese Felder dienen zum Transport der Daten, die erforderlich sind, damit LiveCyle Workflow Server die Formulardaten korrekt weiterleiten kann. Das benutzerdefinierte Objekt erspart Ihnen den Aufwand zur Erstellung all dieser Objekte und stellt sicher, dass diese Objekte jedes Mal richtig erstellt werden.
LiveCycle Designer-Formulare können sowohl in einer Messaging- (E-Mail-) als auch in einer Webumgebung eingesetzt werden. Sie können Formulare entwickeln, die in nur einer der Umgebungen funktionieren oder in beiden Umgebungen gleichzeitig.
Im Hinblick auf die Messaging-Unterstützung betten Sie das Formular in eine Webseite ein und aktivieren Sie es mit einem Webbrowser.
1.
Erstellen Sie das Formular.
2.
Fügen Sie Ihrem Formular das Objekt „Adobe LiveCycle Workflow-Felder“ hinzu.
Wenn Sie ein mehrseitiges Formular erstellen, müssen Sie das Objekt „Adobe LiveCycle Workflow-Felder“ auf der ersten Seite platzieren.
3.
Wählen Sie „Datei“ > „Speichern“.
Verwandte Themen
Adobe LiveCycle Workflow
Für LiveCycle Workflow erforderliche Objekte


Für LiveCycle Workflow erforderliche Objekte

In Formularen, die mit LiveCycle Workflow verwendet werden sollen, sind die folgenden Objekte erforderlich. Das benutzerdefinierte Bibliotheksobjekt „Adobe LiveCycle Workflow-Felder“ enthält Objekte, die nur für die Verwendung mit Form Manager, Objekte, die nur für E-Mail, und Objekte, die für beides erforderlich sind.
Das Popup-Menü „AWS_ACTION“ und die Senden-Schaltfläche sind sichtbar, wenn ein Benutzer ein Formular ausfüllt. Die übrigen Objekte sind nicht sichtbar.

Feldname

Typ

Beschreibung
AWS_SUBMIT
Schaltfläche
Sendet das Formular an LiveCycle Workflow Server.
Wenn Sie Formulare und Formulardaten in ein PDF-Dokument konvertieren und den Verweis in einer Dokumentvariablen speichern möchten, müssen Sie die Senden-Schaltfläche so konfigurieren, dass sie das Senden-Format „PDF“ verwendet.
Klicken Sie in der Palette „Objekt“ auf die Registerkarte „Feld“. Klicken Sie auf die Registerkarte „Senden“ und wählen Sie im Menü „Versandformat“ die Option „PDF“ aus.
AWS_ACTION
Popup-Menü
Führt die Optionen auf, die zum Fertigstellen des Arbeitsschritts verfügbar sind. Wenn Sie keine Optionen zur Auswahl stellen möchten, können Sie dieses Feld weglassen.
AWS_ASSIGNED_ID
Textfeld (unsichtbar)
Ein unsichtbares Textfeld, in dem der Name des Teilnehmers gespeichert wird, der das Formular sendet.
AWS_STATUS
Textfeld (unsichtbar)
Ein unsichtbares Textfeld, das automatisch mit Workflow-Daten gefüllt wird.
AWS_TASKID
Textfeld (unsichtbar)
Ein unsichtbares Textfeld, das automatisch mit Workflow-Daten gefüllt wird.
Diese Feld enthält die Identität der mit dem Formular verknüpften Aufgabe.
AWS_MAILTO
Textfeld (unsichtbar)
Ein unsichtbares Feld, das die von LiveCycle Workflow Server verwendete E-Mail-Adresse enthält.
Sie müssen in diesem Feld einen Wert eingeben, wenn Sie möchten, dass ein Benutzer durch Senden des Formulars per E-Mail an LiveCycle Workflow Server Prozesse initiieren kann.
AWS_CHOICE
Textfeld (unsichtbar)
Ein unsichtbares Textfeld, das automatisch mit Workflow-Daten gefüllt wird.
AWS_PROCESSTYPE
Textfeld (unsichtbar)
Ein unsichtbares Textfeld, das den mit dem Formular verknüpften Prozesstyp enthält.
Sie müssen in diesem Feld nur dann einen Wert eingeben, wenn Sie möchten, dass der Benutzer durch Senden des Formulars per E-Mail an LiveCycle Workflow Server Prozesse initiieren kann.
Wenn das Feld „AWS_TASKID“ leer ist, ruft LiveCycle Workflow Server den im Feld „AWS_PROCESSTYPE“ angegebenen Prozesstyp auf.
FSSUBMIT_
Textfeld (unsichtbar)
Eine unsichtbare Schaltfläche, die automatisch mit Informationen zum Senden des Formulars an LiveCycle Forms gefüllt wird.
Die Workflow-Felder dürfen nicht gruppiert werden. Wenn die Felder gruppiert sind, funktioniert das Formular nicht mit LiveCycle Workflow.
Weitere Informationen finden Sie im LiveCycle Workflow-Handbuch Workflows erstellen.
Verwandte Themen
Adobe LiveCycle Workflow
So erstellen Sie ein Formular für LiveCycle Workflow


Mit der Tastatur arbeiten

Standardtastaturbefehle
Tastaturbefehle anpassen


Standardtastaturbefehle

Tastaturbefehle für häufig verwendete Aktionen
Tasten zum Rückgängigmachen und Wiederherstellen einer Aktion
Tasten zum Löschen von Text
Tasten zum Auswählen von Text
Tasten zum Kopieren und Verschieben von Text
Tasten zum Anwenden von Zeichenformaten auf den ausgewählten Text
Tasten zum Einstellen des Zeilenabstands
Tasten zum Ausrichten von Absätzen
Tasten zum Steuern der Fenster
Tasten zum Navigieren im Formularentwurf
Tasten zum Steuern der Menüs
Tasten für den Skript-Editor und für die Registerkarte „XML-Quelle“
Tasten zum Bearbeiten von Objekten
Tasten zum Ändern der Tab-Reihenfolge
Tasten zum Auswählen und Navigieren in Tabellen
Tasten zum Navigieren in der LiveCycle Designer-Hilfe


Tastaturbefehle für häufig verwendete Aktionen

Ergebnis

Aktion
Aktivieren oder deaktivieren des Menüleistenmodus
Alt oder F10
Abbrechen der aktuellen Aufgabe oder Schließen eines offenen Menüs oder eines Dialogfeldes
Esc-Taste
Anzeigen des Kontextmenüs für das ausgewählte Element
Umschalt+F10
Verschieben des Cursors an den Anfang des Textes in der aktivierten Zeile
Pos1
Verschieben des Cursors an das Ende des Textes in der aktivierten Zeile.
Ende
Verschieben des Cursors an das Ende des Textes
Strg+Ende
Verschieben des Cursors an den Anfang des Textes
Strg+Pos1
Öffnen des Fensters für die LiveCycle Designer-Hilfe.
F1
Auswählen (wie Klicken mit der primären Maustaste)
Leertaste
In der Standardeinstellung wird der Assistent für neue Formulare geöffnet. Das Dialogfeld „Neu“ wird geöffnet, wenn Sie die Option „Beim Erstellen neuer Dokumente anzeigen“ im Fenster zu Assistenten und Tipps zu Formularen im Dialogfeld „Optionen“ deaktiviert haben.
Strg+N


Tasten zum Rückgängigmachen und Wiederherstellen einer Aktion

Ergebnis

Aktion
Wiederherstellen der rückgängig gemachten Aktion
Strg+Umschalt+Z oder Strg+Y
Rückgängig machen der letzten Aktion
Strg+Z oder Alt+Rücktaste


Tasten zum Löschen von Text

Ergebnis

Aktion
Ausschneiden des ausgewählten Textes und Senden an die Zwischenablage
Strg+X oder Umschalt+Entf
Löschen eines Zeichens links
Rücktaste
Löschen eines Zeichens rechts oder Löschen des ausgewählten Textes, ohne ihn in die Zwischenablage zu kopieren
Löschen
Löschen eines Wortes links
Strg+Rücktaste
Löschen eines Wortes rechts
Strg+Entf


Tasten zum Auswählen von Text

Ergebnis

Aktion
Bearbeitungsmodus beenden
F2
Auswahl ab der Cursorposition bis zum Anfang des Absatzes.
Strg+Umschalt+Aufwärtspfeil
Auswahl ab der Cursorposition bis zum Ende des Absatzes.
Strg+Umschalt+Abwärtspfeil
Auswählen oder Aufheben der Auswahl ab der Cursorposition bis zum Ende des Wortes.
Strg+Umschalt+Rechtspfeil
Auswählen oder Aufheben der Auswahl ab der Cursorposition bis zum Anfang der aktuellen Zeile.
Umschalt+Pos1
Auswählen oder Aufheben der Auswahl ab der Cursorposition bis zum Anfang des Wortes.
Strg+Umschalt+Linkspfeil
Auswählen oder Aufheben der Auswahl ab der Cursorposition bis zum Ende der aktuellen Zeile.
Umschalt+Ende
Auswählen oder Aufheben der Auswahl ab der Cursorposition bis zur gleichen Position in der nächsten Zeile. Wenn der Cursor sich in der letzten Zeile befindet, endet die Auswahl am Ende der aktuellen Zeile.
Umschalt+Abwärtspfeil
Auswählen oder Aufheben der Auswahl ab der Cursorposition bis zur gleichen Position in der vorigen Zeile. Wenn sich der Cursor in der ersten Zeile befindet, endet die Auswahl am Anfang der aktuellen Zeile.
Umschalt+Aufwärtspfeil
Auswählen oder Aufheben der Auswahl eines Zeichens links.
Umschalt+Linkspfeil
Auswählen oder Aufheben der Auswahl eines Zeichens rechts.
Umschalt+Rechtspfeil
Auswählen oder Aufheben der Auswahl eines Bildschirms bis zur gleichen Position auf dem nächsten Bildschirm.
Umschalt+Bild-ab-Taste
Auswählen oder Aufheben der Auswahl eines Bildschirms bis zur gleichen Position auf dem vorherigen Bildschirm.
Umschalt+Bild-auf-Taste
Auswählen oder Aufheben der Auswahl bis zum Anfang des Objekttextes (oben, linke Textposition des Objekts).
Strg+Umschalt+Pos1
Auswählen oder Aufheben der Auswahl bis zum Ende des Objekttextes (unten, rechte Textposition des Objekts).
Strg+Umschalt+Ende
Wählt den gesamten Text in einem Textfeld oder im Skript-Editor aus.
Wählt alle Objekte auf einer Seite aus.
Strg+A


Tasten zum Kopieren und Verschieben von Text

Ergebnis

Aktion
Kopieren des ausgewählten Textes in die Zwischenablage
Strg+C oder Strg+Einfg
Ausschneiden des ausgewählten Textes und Senden an die Zwischenablage
Strg+X
Löschen eines Zeichens rechts oder Löschen des ausgewählten Textes, ohne ihn in die Zwischenablage zu kopieren
Löschen
Löschen eines Wortes rechts
Strg+Entf
Einfügen des Inhalts der Zwischenablage am Einfügepunkt
Strg+V oder Umschalt+Einfg


Tasten zum Anwenden von Zeichenformaten auf den ausgewählten Text

Ergebnis

Aktion
Anwenden der Formatierung „Fett“ (die Schrift muss die Darstellung „Fett“ unterstützen)
Strg+B
Anwenden der Formatierung „Kursiv“ (die Schrift muss die Darstellung „Kursiv“ unterstützen)
Strg+I
Anwenden der Unterstreichung
Strg+U


Tasten zum Einstellen des Zeilenabstands

Ergebnis

Aktion
Eineinhalbzeiliger Abstand
Strg+Umschalt+5
Doppelzeiliger Abstand
Strg+Umschalt+2
Einzeiliger Abstand
Strg+Umschalt+1


Tasten zum Ausrichten von Absätzen

Ergebnis

Aktion
Absatz zentrieren
Strg+E
Hängende Einrückung reduzieren
Strg+Umschalt+T
Hängende Einrückung erhöhen
Strg+T
Absatzeinrückung links erhöhen
Strg+M
Absatz ausrichten
Strg+J
Absatz linksbündig ausrichten
Strg+L
Absatzeinrückung links entfernen
Strg+Umschalt+M
Absatzformatierung auf den Standard vor der Eingabe von Änderungen zurücksetzen
Strg+Q
Absatz rechtsbündig ausrichten
Strg+R


Tasten zum Steuern der Fenster

Ergebnis

Aktion
Anzeigen des aktiven Palettenmenüs
F6
Anzeigen der Registerkarte „PDF-Vorschau“
F5
Wechsel zum nächsten geöffneten Dokument
Strg+F6
Wechsel zum nächsten Teilfenster bzw. zur nächsten Palette
Strg+Tab
Wechsel zur nächsten Registerkarte innerhalb der aktuellen Palette
Strg+,
Wechsel zum vorherigen geöffneten Dokument
Strg+Umschalt+F6
Wechsel zum vorigen Teilfenster bzw. zur vorigen Palette
Strg+Umschalt+Tab
Wechsel zur vorherigen Registerkarte innerhalb der aktuellen Palette
Strg+.
Erstellen eines neuen Formularentwurfs
Strg+N
Öffnen des Dialogfeldes „Öffnen“
Strg+O
Öffnen des Dialogfeldes „Drucken“
Strg+P
Beenden von LiveCycle Designer
Alt+F4
Speichern einer Kopie des Inhalts des aktiven Formularentwurfs in einer neuen Datei
Strg+Umschalt+S
Speichern des Formularentwurfs, das momentan den Eingabefokus hat
Strg+S
Ein- oder Ausschalten der Anzeige des Rasters
Strg+’
Ein- oder Ausschalten der Ausrichtung am Raster
Strg+Umschalt+'


Tasten zum Navigieren im Formularentwurf

Ergebnis

Aktion
Wechsel zur ersten Seite
Strg+Pos1
Wechsel zur letzten Seite
Strg+Ende
Wechsel zur nächsten Seite
Bild-ab-Taste
Wechsel zur vorigen Seite
Bild-auf-Taste
Wechsel zwischen der Formularentwurf- und der ersten aktiven Palette
F6
Wechsel zur nächsten Eigenschaftenseite in der Palette
Strg+.
Wechsel zur vorherigen Eigenschaftenseite in der Palette
Strg+,
Vergrößern
Strg+=
Verkleinern
Strg+-
Zoom auf tatsächliche Größe
Strg+1
Zoom passend zur Seitenbreite
Strg+2
Zoom passend zur Seite
Strg+0


Tasten zum Steuern der Menüs

Ergebnis

Aktion
Aktivieren der Menüleiste und Aufruf des Menümodus
F10 oder Alt
Aktivieren der Menüleiste und Öffnen des entsprechenden Menüs für die Zugriffstaste
Alt+[Zugriffstasten im Menü oder im ausgewählten Dialogfeld]
Anzeigen des Kontextmenüs für das ausgewählte Element
Umschalt+F10
Anzeigen des Kontextmenüs für das aktive Child-Fenster
Alt+Bindestrich (-)
Anzeigen des Kontextmenüs für das aktive Fenster
Alt+Leertaste
Führt im Menümodus (Alt+) den entsprechenden Befehl aus
Zugriffstaste
Wechselt im Menümodus (Alt+) ein Element nach oben oder wechselt zum Ende des Menüs, wenn der Fokus sich am oberen Rand des Menüs befindet.
Nach-oben-Taste
Öffnet im Menümodus (Alt+) das Menüelement, wechselt ein Element nach unten oder wechselt zum Anfang des Menüs, wenn der Fokus sich am unteren Rand des Menüs befindet.
Nach-unten-Taste
Öffnet im Menümodus (Alt+) das nächste Menü auf der linken Seite oder schließt ein Untermenü.
Nach-links-Taste
Öffnet im Menümodus (Alt+) das nächste Menü auf der rechten Seite oder öffnet ein Untermenü.
Nach-rechts-Taste


Tasten für den Skript-Editor und für die Registerkarte „XML-Quelle“

Ergebnis

Aktion
Weitersuchen
F3
Vorige suchen
Umschalt+F3
Abgekürzte Referenz-Syntax für ein Objekt auf dem Formular einfügen
Bei gedrückter Taste „Strg+“ auf das Objekt klicken, von dem Sie die Referenz erhalten möchten (während der Skript-Editor aktiv ist).
Öffnen des Dialogfeldes „Suchen“
Strg+F
Öffnen der Funktionenliste „FormCalc“ im Feld „Skriptquelle“ des Skript-Editors
F10
Anzeigen des Dialogfeldes „Gehe zu Zeile“
Strg+G
Öffnen des Dialogfeldes „Ersetzen“
Strg+H
Ein-/Ausschalten der Anzeige des Skript-Editors
Strg+Umschalt+F5


Tasten zum Bearbeiten von Objekten

Ergebnis

Aktion
Unten ausrichten
Strg+Abwärtspfeil
Ausrichten horizontal zentriert
Alt+Strg+Rechtspfeil
Linksbündig
Strg+Linkspfeil
Rechtsbündig
Strg+Rechtspfeil
Am Raster ausrichten
Alt+Strg+Linkspfeil
Oben ausrichten
Strg+Aufwärtspfeil
Ausrichten vertikal zentriert
Alt+Strg+Aufwärtspfeil
Duplizieren des angegebenen Objekts
Strg+D
Fügen Sie ein Objekt ein.
„Alt+I“, Auswählen eines Objekts und anschließend Eingabetaste
Zeichenwerkzeug beibehalten
Strg+K
Um 10 Einheiten nach unten verschieben
Umschalt+Abwärtspfeil
Um eine Einheit nach unten verschieben
Nach-unten-Taste
Um 10 Einheiten nach links verschieben
Umschalt+Linkspfeil
Um eine Einheit nach links verschieben
Nach-links-Taste
Um 10 Einheiten nach rechts verschieben
Umschalt+Rechtspfeil
Um eine Einheit nach rechts verschieben
Nach-rechts-Taste
Um 10 Einheiten nach oben verschieben
Umschalt+Aufwärtspfeil
Um eine Einheit nach oben verschieben
Nach-oben-Taste
Umbenennen eines Objekts mit Hilfe der Palette „Hierarchie“
Strg+F2
Umbenennen des ausgewählten Objekts
F2
Auswählen eines Objekts mit Hilfe der Palette „Hierarchie“
Nach-oben- oder Nach-unten-Taste
Auswählen mehrerer nebeneinander liegender Objekte in der Palette „Hierarchie“
Umschalt+Aufwärtspfeil oder Umschalt+Abwärtspfeil
Auswählen mehrerer nicht nebeneinander liegender Objekte in der Palette „Hierarchie“
Strgl+Aufwärtspfeil oder Strg+Abwärtspfeil, anschließend Leertaste
Ein-/Ausschalten der Anzeige der Palette „Ein-/Ausgabehilfe“
Umschalt+F6
Ein-/Ausschalten der Anzeige der Palette „Rand“
Umschalt+F8
Ein-/Ausschalten der Anzeige der Palette „Schrift“
Umschalt+F4
Ein-/Ausschalten der Anzeige der Palette „Hierarchie“
Umschalt+F11
Ein-/Ausschalten der Anzeige der Palette „Layout“
Umschalt+F9
Ein-/Ausschalten der Anzeige der Palette „Bibliothek“
Umschalt+F12
Ein-/Ausschalten der Anzeige der Palette „Objekt“
Umschalt+F7
Ein-/Ausschalten der Anzeige der Palette „Absatz“
Umschalt+F5
Ein-/Ausschalten der Anzeige des Skript-Editors
Strg+Umschalt+F5


Tasten zum Ändern der Tab-Reihenfolge

Zum Ändern der Tab-Reihenfolge mit der Tastatur müssen Sie zusammen mit der Tastatur ein Zeigegerät verwenden.

Ergebnis

Aktion
Löschen der in der aktuellen Sitzung vorgenommenen Änderungen und Beenden des Modus „Tab-Reihenfolge“.
Esc-Taste
Speichern der Änderungen und Beenden des Modus „Tab-Reihenfolge“
Eingabe
Angeben einer neuen Nummer 1 in der Tab-Reihenfolge
Halten Sie die Umschalttaste gedrückt und klicken Sie auf das Feld.


Tasten zum Auswählen und Navigieren in Tabellen

Ergebnis

Aktion
Erweitern der Auswahl bis zum Anfang der Zeile
Umschalt+Pos1
Erweitern der Auswahl bis zum Anfang der Tabelle
Strg+Umschalt+Pos1
Erweitern der Auswahl bis zum Ende der Zeile
Umschalt+Ende
Erweitern der Auswahl bis zum Ende der Tabelle
Strg+Umschalt+Ende
Erweitern der Auswahl
Umschalt+Nach-links, Nach-rechts, Nach-oben bzw. Nach-unten
Zwischen Zellen wechseln
Nach-links, Nach-rechts, Nach-oben bzw. Nach-unten
Auswählen aller Zellen in einer Spalte
Strg+Leertaste
Auswählen aller Zellen in einer Zeile
Umschalt+Leertaste
Auswählen aller Zellen in der Tabelle
Strg+Umschalt+Leertaste
Nur Auswahl der aktiven Zelle bei mehreren ausgewählten Zellen
Umschalt+Rücktaste
Auswählen der ersten Zelle in der Zeile
Pos1
Auswählen der ersten Zelle in der Tabelle
Strg+Pos1
Auswählen der letzten Zelle in der Zeile
Ende
Auswählen der letzten Zelle in der Tabelle
Strg+Ende
Aktivieren bzw. Deaktivieren des Textbearbeitungsmodus in der aktiven Zelle
F2


Tasten zum Navigieren in der LiveCycle Designer-Hilfe

Ergebnis

Aktion
Help-Viewer schließen
Alt+F4
LiveCycle Designer-Hilfe anzeigen
F1
Registerkarte „Inhalt“ anzeigen
Alt+C
Registerkarte „Index“ anzeigen
Alt+N
Menü „Optionen“ anzeigen. Die Befehle für alle Schaltflächen der Help-Viewer-Symbolleiste sind im Menü „Optionen“ verfügbar.
Alt+O
Registerkarte „Erweiterte Suche“ anzeigen
Alt+S
Ausgewähltes Thema anzeigen
Eingabetaste oder Alt+D
Ein Buch öffnen und schließen
Pluszeichen und Minuszeichen oder Linkspfeil und Rechtspfeil
Ein Schlüsselwort in der Liste auswählen
Aufwärtspfeil und Abwärtspfeil
Auswahl eines Themas in der Liste der Suchergebnisse
Alt+T, gefolgt von Aufwärtspfeil und Abwärtspfeil
Ein Thema auswählen
Abwärtspfeil und Aufwärtspfeil
Suche beginnen
Alt+L


Tastaturbefehle anpassen

So erstellen Sie einen benutzerdefinierten Tastaturbefehlssatz
So weisen Sie einem Befehl einen Tastaturbefehl zu
So entfernen Sie einen Tastaturbefehl für einen Befehl
So überprüfen Sie die aktuellen Tastaturbefehle für einen Befehl


So erstellen Sie einen benutzerdefinierten Tastaturbefehlssatz

Bei einem Tastaturbefehlssatz handelt es sich um eine benannte Sammlung von Tastaturbefehlen. Sie können je nach Ihren Bedürfnissen und den Bedürfnissen der anderen Benutzer beliebig viele Tastaturbefehlssätze definieren.
Wenn zum Beispiel verschiedene Benutzer zu verschiedenen Zeiten auf demselben Computer mit LiveCycle Designer arbeiten, kann jeder Anwender seinen eigenen Tastaturbefehlssatz erstellen. So können alle Benutzer ihre eigenen Tastaturbefehle verwenden und verwalten, ohne dabei den Standardsatz ändern zu müssen.
Der Standardsatz selbst kann nicht direkt geändert, ersetzt oder gelöscht werden. Das heißt, dass in LiveCycle Designer bei jeder Änderung des Standardsatzes (oder eines vorhandenen benutzerspezifischen Satzes) eine weitere Instanz dieses Satzes mit dem Wort „(Geändert)“ hinter dem Satznamen zur Liste „Satz“ hinzugefügt wird. Sie können dem geänderten Satz dann einen neuen Namen zuweisen.
1.
Wählen Sie „Extras“ > „Tastaturbefehle“.
2.
Wählen Sie in der Liste „Satz“ den Tastaturbefehlssatz, der geändert werden soll. Verwenden Sie den Standardsatz oder einen bereits vorhandenen benutzerspezifischen Satz.
3.
Klicken Sie auf „Speichern unter“.
4.
(Optional) Geben Sie im Feld „Name“ einen Namen für den Satz ein. Wenn Sie keinen Namen eingeben, wird der Name des vorhandenen Satzes weiterhin mit dem Zusatz „(Geändert)“ angezeigt.
5.
Klicken Sie auf „OK“.


So weisen Sie einem Befehl einen Tastaturbefehl zu

Sie können einen Tastaturbefehl einem Befehl zuweisen. Sie können einen oder mehrere Tastaturbefehle demselben Befehl zuweisen. Um überflüssige Doppelzuweisungen zu vermeiden, sollten Sie jedoch jedem Befehl möglichst nur einen Tastaturbefehl zuordnen.
Wenn der gewünschte Tastaturbefehl bereits vergeben ist, werden Sie von LiveCycle Designer aufgefordert, die Zuweisung für den anderen Befehl aufzuheben und den Tastaturbefehl dem derzeit ausgewählten Befehl zuzuweisen.
Nachdem Sie einem Befehl einen neuen bzw. einen zusätzlichen Tastaturbefehl zugewiesen haben, wird vor dem Namen des Befehls in der Liste „Befehle“ ein Sternchen (*) angezeigt. Dieses weist darauf hin, dass die Tastaturbefehle für diesen Befehl geändert wurden.
Wenn Sie einem Befehl einen Tastaturbefehl zuweisen, ändern Sie damit den Tastaturbefehlssatz für diesen Befehl, d. h. entweder den Standardsatz oder einen vorhandenen benutzerdefinierten Satz. Daher wird in LiveCycle Designer der Liste „Satz“ eine weitere Instanz dieses Tastaturbefehlssatzes mit dem Zusatz „(Geändert)“ hinzugefügt. Dieser Zusatz weist darauf hin, dass Änderungen an diesem Satz vorgenommen wurden. Um die neuen Zuweisungen zu speichern, müssen Sie den zugehörigen Tastaturbefehlssatz speichern.
Wenn Sie die Änderungen an dem Satz nicht speichern, bleiben diese in LiveCycle Designer nur so lange aktiv, bis Sie in der Liste „Satz“ einen neuen Satz auswählen. Sobald Sie einen neuen Tastaturbefehlssatz auswählen, werden Sie von LiveCycle Designer aufgefordert, die zuvor vorgenommenen Änderungen zu speichern.
1.
Wählen Sie „Extras“ > „Tastaturbefehle“.
2.
Wählen Sie in der Liste „Satz“ den Tastaturbefehlssatz, in dem der Tastaturbefehl gespeichert werden soll.
3.
Wählen Sie in der Liste „Produktbereich“ den Eintrag „(Alle Befehle)“ oder wählen Sie ein bestimmtes Menü, das den gewünschten Befehl enthält.
4.
Wählen Sie in der Liste „Befehle“ den gewünschten Befehl. Bereits definierte Tastaturbefehle werden in der Liste „Aktuelle Tastaturbefehle“ aufgeführt.
5.
(Optional) Wählen Sie in der Liste „Aktuelle Tastaturbefehle“ die Tastaturbefehle, die gelöscht werden sollen, und klicken Sie auf „Entfernen“.
6.
Geben Sie im Feld „Neuer Tastaturbefehl“ die gewünschte Tastenkombination ein und klicken Sie auf „Zuweisen“.
7.
Klicken Sie auf „Speichern unter“, um die Änderungen an dem Tastaturbefehlssatz zu speichern.
8.
(Optional) Geben Sie im Feld „Name“ einen Namen für den neuen Satz ein. Wenn Sie keinen Namen eingeben, wird der Name des vorhandenen Satzes weiterhin mit dem Zusatz „(Geändert)“ angezeigt.
9.
Klicken Sie auf „OK“.


So entfernen Sie einen Tastaturbefehl für einen Befehl

Sie können bei allen Befehlen die zugewiesenen Tastaturbefehle (einschließlich des Standardtastaturbefehls) wieder entfernen.
So können Sie beispielsweise nicht verwendete Tastaturbefehle löschen oder einen vorhandenen Tastaturbefehl durch eine Tastenkombination, die Sie bevorzugen, ersetzen.
Wenn Sie einen Tastaturbefehl löschen, wird vor dem Namen des Befehls in der Liste „Befehle“ ein Sternchen (*) angezeigt. Dieses weist darauf hin, dass die Tastaturbefehle für diesen Befehl geändert wurden.
Wenn Sie einen Tastaturbefehl für einen Befehl entfernen, ändern Sie damit den Tastaturbefehlssatz für diesen Befehl, d. h. entweder den Standardsatz oder einen vorhandenen benutzerdefinierten Satz. Daher wird in LiveCycle Designer der Liste „Satz“ eine weitere Instanz dieses Tastaturbefehlssatzes mit dem Zusatz „(Geändert)“ hinzugefügt. Dieser Zusatz weist darauf hin, dass Änderungen an diesem Satz vorgenommen wurden. Um die Änderungen zu speichern, müssen Sie den zugehörigen Tastaturbefehlssatz speichern.
Wenn Sie die Änderungen an dem Satz nicht speichern, bleiben diese in LiveCycle Designer nur so lange aktiv, bis Sie in der Liste „Satz“ einen neuen Satz auswählen. Sobald Sie einen neuen Tastaturbefehlssatz auswählen, werden Sie von LiveCycle Designer aufgefordert, die zuvor vorgenommenen Änderungen zu speichern.
1.
Wählen Sie „Extras“ > „Tastaturbefehle“.
2.
Wählen Sie in der Liste „Satz“ den Satz mit dem zu löschenden Tastaturbefehl.
3.
Wählen Sie in der Liste „Produktbereich“ den Eintrag „(Alle Befehle)“ oder wählen Sie ein bestimmtes Menü, das den gewünschten Befehl enthält.
4.
Wählen Sie in der Liste „Befehle“ den gewünschten Befehl. Bereits definierte Tastaturbefehle werden in der Liste „Aktuelle Tastaturbefehle“ aufgeführt.
5.
Wählen Sie in der Liste „Aktuelle Tastaturbefehle“ den zu löschenden Tastaturbefehl und klicken Sie auf „Entfernen“.
6.
(Optional) Um den Tastaturbefehlssatz umzubenennen, klicken Sie auf „Speichern unter“. Geben Sie im Feld „Name“ den neuen Namen für den Satz ein.
7.
Klicken Sie auf „OK“.


So überprüfen Sie die aktuellen Tastaturbefehle für einen Befehl

1.
Wählen Sie „Extras“ > und anschließend „Tastaturbefehle“.
2.
Wählen Sie in der Liste „Satz“ den Tastaturbefehlssatz mit den zu überprüfenden Tastaturbefehlen.
3.
Wählen Sie in der Liste „Produktbereich“ den Eintrag „(Alle Befehle)“ oder wählen Sie ein bestimmtes Menü, das den gewünschten Befehl enthält.
4.
Wählen Sie in der Liste „Befehle“ den gewünschten Befehl. Alle bereits für einen Befehl definierten Tastaturbefehle werden in der Liste „Aktuelle Tastaturbefehle“ aufgeführt.


Skripterstellung

Skripterstellung

Skripterstellung mit LiveCycle Designer
Skript-Referenz
FormCalc-Benutzerreferenz


Skripterstellung mit LiveCycle Designer

Berechnungen und Skripten
Objekte, die Berechnungen und Skripten unterstützen
LiveCycle Designer-Arbeitsbereich zur Skripterstellung konfigurieren
Berechnungen und Skripten erstellen
Ereignisse
Skriptsprachen
Objekte in Berechnungen und Skripten referenzieren
Variablen
Debugging von Berechnungen und Skripten
Mit Host-Anwendungen arbeiten
Das Ereignismodell
JavaScript-Funktionen erstellen und wiederverwenden
Von der Skripterstellung in Acrobat zur Skripterstellung in LiveCycle Designer wechseln
Beispiele für gängige Aufgaben bei der Skripterstellung


Berechnungen und Skripten

Bei der Gestaltung von Formularen kann der Entwickler Berechnungen und Skripten verwenden, um den Gebrauchswert für den Benutzer zu erhöhen. Sie können die meisten Formularfelder und -objekte durch Berechnungen und Skripten ergänzen. Beispielsweise haben Sie die Möglichkeit, einfache Berechnungen zu erstellen, um die Werte in einem interaktiven Formular in Abhängigkeit von den Benutzereingaben dynamisch zu aktualisieren. Auf einem anspruchsvolleren Niveau können Sie dann eigene Funktionen erstellen, die auf Ihre individuellen Anforderungen hinsichtlich der Verarbeitung benutzerdefinierter Formulare zugeschnitten sind.
LiveCycle Designer unterstützt zwei Skriptsprachen, die jeweils auf die Anforderungen einer bestimmten Gruppe von Formularentwicklern abgestimmt sind. FormCalc ist eine unkomplizierte, einfach anzuwendende Berechnungssprache, deren Funktionalität sich an gebräuchlicher Tabellenkalkulations-Software orientiert. Diese Skriptsprache enthält eine Vielzahl integrierter Funktionen, mit deren Hilfe Sie Formularentwürfe im Handumdrehen erstellen können. JavaScript ist eine leistungsfähige Skriptsprache, die viel Flexibilität bei der Erstellung von Skripten bietet, wobei Sie bereits vorhandene Kenntnisse über diese Sprache nutzen können.
Beachten Sie, dass es Ihnen völlig freigestellt ist, ob Sie in einem Formular Skripterstellung verwenden. Sie können sich zwar für die Vorteile der Skripterstellung entscheiden, um den Gebrauchswert des Formulars für den Benutzer zu erhöhen, viele der leistungsstarken Funktionen stehen in LiveCycle Designer aber auch ohne die Anwendung von Skripten zur Verfügung. Durch Skripterstellung können Sie jedoch fast alle Aspekte der Formulargestaltung steuern.
Verwandte Themen
Grundlagen zu FormCalc
Grundlagen zu JavaScript
Grundlagen zur Objekt-Scripting-Referenz


Objekte, die Berechnungen und Skripten unterstützen

Sie können Berechnungen und Skripten erstellen, die sich auf alle Formularentwurfsobjekte auswirken. Allerdings können Berechnungen und Skripten nur den Formularereignissen eines bestimmten Objekts hinzugefügt werden. Nicht alle Formularentwurfsobjekte unterstützen Ereignisse; um diese Objekte zu ändern, müssen Sie daher die Berechnung bzw. das Skript einem unterstützten Ereignis eines anderen Formularentwurfsobjekts hinzufügen. Die folgende Tabelle gibt Ihnen einen Überblick über die Skriptunterstützung der Objekte, die in der Kategorie „Standard“ der Palette „Bibliothek“ zur Verfügung stehen.

Objekte, die Berechnungen und Skripten unterstützen

Objekte, die keine Berechnungen und Skripten unterstützen
Barcodes
Kreis
Bildfeld
Datums-/Uhrzeitfeld
Rechteck
Dezimalfeld
Bild
Dokumentunterschriftsfeld
Tabelle (nur Abschnitte)
Dropdown-Liste
Text
Drucken-Schaltfläche
E-Mail-Senden-Schaltfläche
HTTP-Senden-Schaltfläche
Kennwortfeld
Kontrollkästchen
Linie
Listenfeld
Numerisches Feld
Optionsfeld
Papierformular-Barcode
Schaltfläche
Inhaltsbereich
Tabelle (einschließlich Textzeilen, Kopf- und Fußzeilen)
Teilformular
Textfeld
Zurücksetzen-Schaltfläche
Verwandte Themen
Grundlagen zur Objekt-Scripting-Referenz


LiveCycle Designer-Arbeitsbereich zur Skripterstellung konfigurieren

Der Skript-Editor
So zeigen Sie den Skript-Editor an
So wechseln Sie von der einzeiligen zur mehrzeiligen Ansicht
So legen Sie die Standard-Skriptsprache fest
So legen Sie die Standardanwendung für die Verarbeitung fest
So zeigen Sie arabische, hebräische, thailändische und vietnamesische Zeichen an
Berechnungen und Skripten mit dem Arbeitsbereich debuggen


Der Skript-Editor

Der Skript-Editor ist die Komponente in LiveCycle Designer, in der Sie die Berechnungen und Skripten für ein bestimmtes Formular erstellen, modifizieren und anzeigen.
Der Skript-Editor bietet eine einzeilige und eine mehrzeilige Ansicht. Sie können zwischen diesen beiden Ansichten jederzeit bei Bedarf hin und her wechseln. Die einzeilige Ansicht soll dafür sorgen, dass möglichst viel Platz für den Layout-Editor und andere Paletten zur Verfügung steht, wogegen die mehrzeilige Ansicht möglichst viel Platz für die Skripterstellung bereitstellen soll.
Anzeigen
Listet alle Ereignisse des Formularentwurfs auf, die benutzerdefinierte Skripterstellung unterstützen. Alle Ereignisse, die für ein bestimmtes Objekt nicht gültig sind, werden ausgegraut dargestellt. Enthält ein Ereignis eine Berechnung oder ein Skript, steht neben dem Namen dieses Ereignisses ein Sternchen (*).
Ereignisse für untergeordnete Objekte anzeigen
Zeigt das Ereignis an, das gegenwärtig unter „Anzeigen“ für das aktuelle Objekt und alle untergeordneten Objekte ausgewählt ist.
Funktionen
Zeigt eine Liste der verfügbaren integrierten Funktionen an.
Um eine Funktion in das Skript-Bearbeitungsfeld einzufügen, wählen Sie eine Funktion in der Liste aus und drücken die Eingabetaste.
Änderungen zu Skriptquelle eingeben
Speichert das Skript im Formularentwurf. Klicken Sie auf diese Schaltfläche, wenn die Erstellung eines Skriptes abgeschlossen ist. Wenn Sie Ihr Skript nicht auf diese Weise speichern, wird es eventuell nicht korrekt ausgeführt oder es kann verloren gehen.
Änderungen zu Skriptquelle abbrechen
Macht alle Änderungen rückgängig, die Sie an einer bestimmten Berechnung oder einem Skript vorgenommen haben. Dies gilt nur für die momentane Bearbeitungssitzung und hat nicht die Funktionalität einer mehrstufigen Rückgängig-Funktion.
Sprache
Legt fest, welche Skriptsprache Sie für die aktuelle Berechnung bzw. das aktuelle Skript verwenden möchten. Die folgenden Optionen stehen zur Auswahl:
      •
      FormCalc ist eine native Adobe-Berechnungssprache, die für kürzere Skripten ideal geeignet ist.
      •
      JavaScript ist eine leistungsstarke, flexible Skriptsprache für komplexere Skripten.
Ausführen am
Gibt an, wo die Berechnung bzw. das Skript ausgeführt werden soll. Es stehen drei Optionen zur Auswahl:
    • Client
Berechnungen und Skripten werden ausgeführt, während die Client-Anwendung (z. B. Acrobat, Adobe Reader oder ein Webbrowser) das Formular verarbeitet.
    • Server
      •
      Berechnungen und Skripten werden ausgeführt, während die Serveranwendung (z. B. LiveCycle Forms) das Formular verarbeitet.
    • Client und Server
      •
      Berechnungen und Skripten werden ausgeführt, während die Serveranwendung (z. B. LiveCycle Forms) das Formular verarbeitet, es sei denn, die HTML-Client-Anwendung unterstützt clientseitige Skripterstellung.


Zurück Weiter

Skripterstellung > Skripterstellung mit LiveCycle Designer > LiveCycle Designer-Arbeitsbereich zur Skripterstellung konfigurieren > So zeigen Sie den Skript-Editor an

So zeigen Sie den Skript-Editor an

      *
      Wählen Sie „Fenster“ > „Skript-Editor“.


So wechseln Sie von der einzeiligen zur mehrzeiligen Ansicht

      *
      Ziehen Sie die Palettenleiste des Skript-Editors, bis die Palette die erforderliche Größe hat.
Die mehrzeilige Ansicht erweitert die Liste „Anzeigen“ um die Optionen „Alle Ereignisse“ und „Ereignisse mit Skripten“. Die Option „Alle Ereignisse“ zeigt alle Ereignisse für ein bestimmtes Formularentwurfsobjekt an, und zwar auch dann, wenn die Ereignisse keine Berechnungen oder Skripten enthalten. Die Option „Ereignisse mit Skripten“ zeigt nur diejenigen Ereignisse eines bestimmten Objekts an, die Berechnungen oder Skripten enthalten.


So legen Sie die Standard-Skriptsprache fest

1.
Wählen Sie „Datei“ > „Formulareigenschaften“.
2.
Klicken Sie auf die Registerkarte „Standard“.
3.
Wählen Sie in der Liste „Standardsprache“ die standardmäßige Sprache für die Skripterstellung aus.


So legen Sie die Standardanwendung für die Verarbeitung fest

1.
Wählen Sie „Datei“ > „Formulareigenschaften“.
2.
Klicken Sie auf die Registerkarte „Standard“.
3.
Wählen Sie aus der Liste „Standardausführung am“ die gewünschte Standardanwendung für die Verarbeitung.
Verwandte Themen
Berechnungen und Skripten erstellen - Überblick
Festlegen, wo eine Berechnung oder ein Skript ausgeführt werden soll
Grundlagen zu Ereignissen


Zurück Weiter

Skripterstellung > Skripterstellung mit LiveCycle Designer > LiveCycle Designer-Arbeitsbereich zur Skripterstellung konfigurieren > So zeigen Sie arabische, hebräische, thailändische und vietnamesische Zeichen an

So zeigen Sie arabische, hebräische, thailändische und vietnamesische Zeichen an

Zum Anzeigen von Zeichen in Arabisch, Hebräisch, Thai oder Vietnamesisch im Skript-Editor oder auf der Registerkarte „XML-Quelle“ müssen Sie die Schrifteinstellungen ändern, die LiveCycle Designer auf diesen Registerkarten verwendet. Andernfalls werden an Stelle der landesspezifischen Zeichen in LiveCycle Designer nur kleine Kästchen angezeigt.
LiveCycle Forms 7.1 bietet keine Unterstützung für Formularentwürfe mit arabischen, hebräischen, thailändischen und vietnamesischen Schriftzeichen.
1.
Wählen Sie „Extras“ > „Optionen“ und dann links im Fenster den Eintrag „Arbeitsbereich“.
2.
Wählen Sie eine der folgenden Optionen aus:
      •
      "„FormCalc-Syntaxformatierung“, um die Schrift im Skript-Editor festzulegen, wenn FormCalc verwendet wird
      •
      "JavaScript-Syntaxformatierung", um die Schrift im Skript-Editor festzulegen, wenn JavaScript verwendet wird
      •
      "Syntaxformatierung der XML-Quelle", um die Schrift auf der Registerkarte „XML-Quelle“ festzulegen
3.
Wählen Sie unter „Schrift“ eine Schrift aus, die Ihre Sprache unterstützt. Adobe Arabic unterstützt beispielsweise Arabisch, Adobe Hebrew unterstützt Hebräisch, Adobe Thai unterstützt Thai und Myriad Pro und Minion Pro unterstützen Vietnamesisch. Falls die erforderlichen Schriften noch nicht auf dem System installiert sind, können Sie sie aus dem Internet herunterladen.
4.
Klicken Sie auf „OK“.
5.
Klicken Sie auf „OK“, um das Dialogfeld „Optionen“ zu schließen.


Berechnungen und Skripten mit dem Arbeitsbereich debuggen

Zum Debugging von Berechnungen und Skripten stehen im LiveCycle Designer-Arbeitsbereich verschiedene Möglichkeiten zur Auswahl.
Die folgende Tabelle zeigt, wo Sie nützliche Debugging-Informationen in den verschiedenen LiveCycle Designer-Paletten und -Registerkarten finden und wie Sie diese nutzen können.

Arbeitsbereich

Zweck
Registerkarte „Warnungen“ der Palette „Bericht“
Bei Skriptfehlern oder anderen unerwarteten Formularproblemen sollten Formularentwickler zunächst die Registerkarte „Warnungen“ überprüfen. Die Registerkarte „Warnungen“ dient als Protokoll für die von LiveCycle Designer gemeldeten Probleme und wird bei der Vorschau des Formularentwurfs auf der Registerkarte „PDF-Vorschau“ aktualisiert.
Registerkarte „Bindungen“ der Palette „Bericht“
Wenn ein Formularentwurf Felder enthält, die an eine Datenquelle gebunden sind, können Sie mit Hilfe der Registerkarte „Bindungen“ abhängig von der definierten Datenbindung Felderlisten anzeigen. Auf diese Weise können Sie z. B. nur Felder mit globaler Datenbindung oder nur Felder ohne definierte Datenbindung anzeigen. Dies ist vor allem bei Formularen mit einer großen Anzahl von Feldern mit Datenbindungen nützlich.
Hierarchie, Palette
Mit der Palette „Hierarchie“ können Sie die Position eines Formularobjekts für eine Referenz-Syntax ermitteln. Bei der Palette „Hierarchie“ handelt es sich um eine grafische Darstellung der Struktur eines Formulars. Sie zeigt die Inhalte der Registerkarten „Masterseiten“ und „Designansicht“ an.
In der Palette „Hierarchie“ werden auch referenzierte Objekte unter dem Knoten „Referenzierte Objekte“ angezeigt. Ein referenziertes Objekt ist ein Objekt, das nur bei Bedarf einem Formular hinzugefügt wird. Teilformulare für den Überlaufkopfbereich und den Überlauffußbereich sind Beispiele für referenzierte Objekte. Immer, wenn Daten über mehrere Seiten oder Inhaltsbereiche fließen, werden die Teilformulare für den Überlaufkopfbereich und den Überlauffußbereich an den entsprechenden Stellen in das Formular eingefügt.
Registerkarte „Bindung“ der Palette „Objekt“
Für jedes LiveCycle Designer-Objekt, das an eine Datenquelle gebunden werden kann, gibt es in der Palette „Objekt“ eine Registerkarte „Bindung“. Wenn Sie ein Objekt in Ihrem Formularentwurf an einen bestimmten Datenknoten aus Ihrer Datenverbindung binden, wird in der Liste „Standardbindung (Öffnen, Speichern, Absenden)“ eine gültige FormCalc Referenz-Syntax für den Zugriff auf diesen Datenknoten angezeigt. Der FormCalc Referenz-Syntax lässt sich auch zum Testen in anderen Berechnungen oder Skripten verwenden.
Registerkarte „XML-Quelle“
Die Registerkarte „XML-Quelle“ enthält den XML-Code des Formularentwurfs. Der XML-Quellcode definiert alle Aspekte des Formulars. Auf der Registerkarte „XML-Quelle“ können Sie sich die XML Form Object Model-Struktur eines Formularentwurfs sowie die Beziehungen zwischen Objekten und Eigenschaften genauer ansehen. In der XML-Quelle entsprechen die XML-Elementnamen den Objektnamen im XML Form Object Model und die Attribute entsprechen Eigenschaften.
Wenn Sie in der Palette „Hierarchie“ ein Objekt auswählen und dann auf die Registerkarte „XML-Quelle“ klicken, wird die erste Zeile des entsprechenden Elements hervorgehoben. Der in LiveCycle Designer in der Palette „Hierarchie“ angegebene Objektname wird in der XML-Quelle zum Wert des Attributs name.
In dem über „Extras“ > „Optionen“ aufgerufenen Dialogfeld stehen verschiedene Optionen zur Anzeige der Quelle auf der Registerkarte „XML-Quelle“ zur Auswahl. Dazu gehören beispielsweise das Ein- oder Ausblenden der Zeilennummern und die Einstellung der Syntaxfarbe.
Es ist nicht empfehlenswert, den XML-Quellcode direkt zu bearbeiten.
Zum Debugging von Berechnungen und Skripten kann es außerdem hilfreich sein, die Standardoptionen für den Skript-Editor zu ändern. Diese Optionen finden Sie im Dialogfeld „Optionen“ im Bereich „Arbeitsbereich“. Wählen Sie „Extras“ > „Optionen“ und anschließend links in der Liste den Eintrag „Arbeitsbereich“.
Verwandte Themen
Berechnungen und Skripten testen und debuggen
Grundlagen zum Debugging von Berechnungen und Skripten
Der Arbeitsbereich
Palette „Hierarchie“
Palette „Bericht“
Palette „Objekt“


Berechnungen und Skripten erstellen

Berechnungen und Skripten erstellen - Überblick
Namenskonventionen für Formularentwurfsobjekte und Variablen
Skriptsprache wählen
So erstellen Sie eine Berechnung oder ein Skript
So suchen Sie nach Text oder anderen Objekten
So ersetzen Sie Text oder andere Objekte
So erstellen Sie Berechnungen und Skripten mit dem Anweisungsende
So fügen Sie eine Objektreferenz-Syntax automatisch ein
Festlegen, wann eine Berechnung oder ein Skript ausgeführt werden soll
So zeigen Sie Skriptereignisse und Skripten an
Festlegen, wo eine Berechnung oder ein Skript ausgeführt werden soll
Berechnungen und Skripten testen und debuggen


Berechnungen und Skripten erstellen - Überblick

LiveCycle Designer bietet für die Erstellung von Berechnungen und Skripten eine Vielzahl von Funktionen, mit deren Hilfe sich zahlreiche Aufgaben ausführen lassen. Beispielsweise können Sie einfache Skripten erstellen, mit denen das Aussehen eines Formularobjekts (z. B. die Farbe des Objektrahmens oder der Schriftgrad) je nach der Eingabe des Benutzers beim Ausfüllen zur Laufzeit geändert wird. Komplexere Formulare können mit Hilfe von Skripten zur Laufzeit Datenquellverbindungen vornehmen und Daten bearbeiten.
Für die Erstellung von Berechnungen und Skripten in LiveCycle Designer gibt es einen allgemeinen Prozess, der jedes Mal ausgeführt werden muss, wenn Sie eine Berechnung oder ein Skript an ein Objekt anhängen. Nicht alle Teile dieses Prozesses sind jedes Mal erforderlich, wenn Sie eine Berechnung oder ein Skript erstellen. Dennoch ist es empfehlenswert, diesen Prozess umzusetzen, um potenzielle Fehler und unerwartete Ergebnisse zu vermeiden.
Beim Erstellen einer Berechnung oder eines Skripts müssen generell die folgenden Schritte ausgeführt werden:
      •
      Wählen Sie das Objekt aus, an das Sie eine Berechnung oder ein Skript anhängen möchten. Sie können zwar Berechnungen und Skripte erstellen, mit denen fast jedes Objekt im Formularentwurf bearbeitet werden kann, aber nur Feldobjekte unterstützen Formularereignisse. Wenn Sie also ein Objekt mit einer Berechnung oder einem Skript bearbeiten möchten, müssen Sie die Berechnung bzw. das Skript auf einem Feldobjekt im Formularentwurf platzieren.
      •
      Sie müssen sämtliche Berechnungen und Skripten, die Sie in LiveCycle Designer erstellen, jeweils einem spezifischen Formularereignis zuweisen. Die Berechnung bzw. das Skript, die bzw. das einem Ereignis zugeordnet ist, wird jedes Mal ausgelöst, wenn das Formularereignis eintritt. Beispielsweise werden Berechnungen oder Skripten, die an das Ereignis click einer Schaltfläche angehängt wurden, jedes Mal initiiert, wenn der Benutzer beim Ausfüllen des Formulars auf diese Schaltfläche klickt.
      •
      Wählen Sie die gewünschte Skriptsprache. Je nach dem Formular, das Sie erstellen möchten, bietet es sich an, nur FormCalc, nur JavaScript oder eine Mischung aus beiden Sprachen einzusetzen.
      •
      Geben Sie an, wo die Berechnung oder das Skript ausgeführt wird. Zur Auswahl stehen die Client-Anwendung wie Acrobat oder Adobe Reader sowie der Server über LiveCycle Forms.
      •
      Unterziehen Sie die Berechnung oder das Skript entweder auf der Registerkarte „PDF-Vorschau“ oder in Ihrer Produktionsumgebung einem gründlichen Test.
Verwandte Themen
So erstellen Sie eine Berechnung oder ein Skript
So suchen Sie nach Text oder anderen Objekten
So ersetzen Sie Text oder andere Objekte
So erstellen Sie Berechnungen und Skripten mit dem Anweisungsende
Festlegen, wann eine Berechnung oder ein Skript ausgeführt werden soll
So zeigen Sie Skriptereignisse und Skripten an
Festlegen, wo eine Berechnung oder ein Skript ausgeführt werden soll
Berechnungen und Skripten testen und debuggen
Objekte, die Berechnungen und Skripten unterstützen


Namenskonventionen für Formularentwurfsobjekte und Variablen

Wenn Sie Berechnungen oder Skripten erstellen, um ein Formular anspruchsvoller zu gestalten, müssen Sie die im Formular verwendeten Namen für das Formularentwurfsobjekt und die Variablen sorgfältig auswählen. Die Namen von XML Form Object Model-Eigenschaften, -Methoden und -Objekten sollten nach Möglichkeit nicht für Formularentwurfsobjekte und Variablen verwendet werden. Andernfalls werden Berechnungen und Skripten möglicherweise nicht ordnungsgemäß ausgeführt.
Weitere Informationen zu den Namen der Eigenschaften, Methoden und Objekte des XML Form Object Model finden Sie unter Skript-Referenz.
Verwandte Themen
Variablen benennen
Berechnungen und Skripten erstellen - Überblick
Objekte, die Berechnungen und Skripten unterstützen


Skriptsprache wählen

LiveCycle Designer unterstützt die Skripterstellung sowohl mit FormCalc als auch mit JavaScript. Jede Skriptsprache bietet ihre eigenen Vorteile, die Sie kennen sollten, bevor Sie mit der Erstellung von Skripten für Ihr Formular beginnen.
FormCalc ist eine Berechnungssprache mit einer umfangreichen Palette von integrierten Funktionen zur Vereinfachung der gebräuchlichsten Formularfunktionen. Beispielsweise können Sie mit den Finanzfunktionen von FormCalc anhand des Kreditbetrags, des Zinssatzes und der Anzahl der Zahlungsperioden die Höhe der pro Periode fälligen Zahlungsbeträge berechnen.
JavaScript ist eine leistungsstärkere und vielseitigere Skriptsprache, die Ihnen mehr Flexibilität bietet und die Möglichkeit eröffnet, Ihre bereits vorhandenen Skripterstellungskenntnisse zu nutzen. Beispielsweise können Sie vorhandene JavaScript-Funktionen in LiveCycle Designer wiederverwerten und sich so die Arbeit bei der Skripterstellung etwas erleichtern.
LiveCycle Designer unterstützt JavaScript Version 1.6 und älter.
In der folgenden Tabelle sind einige der Hauptunterschiede zwischen FormCalc und JavaScript zusammengestellt.

FormCalc

JavaScript
Native Adobe-Berechnungssprache, die in LiveCycle Designer und LiveCycle Forms gültig ist
Standard-Skriptsprache, kommt in zahlreichen verbreiteten Software-Anwendungen zum Einsatz
Kürzere Skripten (üblicherweise nur eine Zeile)
Möglichkeit, bei Bedarf längere Skripten mit Schleifenlogik zu verwenden
Enthält eine Vielzahl von nützlichen integrierten Funktionen, durch die für allgemeine Aufgaben beim Formularentwurf weniger Skripterstellungsaufwand erforderlich ist
Bietet Zugriff auf das Acrobat-Objektmodell und die JavaScript-Funktionalität von Acrobat
Unterstützung für internationale Datums-, Uhrzeit-, Währungs- und Zahlenformate
Debugging mit dem JavaScript-Debugger in Acrobat möglich
Integrierte URL-Funktionen für Post, Put und Get ermöglichen webgestützte Interaktion
Erstellung benutzerdefinierter Funktionen für Ihre spezifischen Anforderungen
Auf allen von LiveCycle Designer und LiveCycle Forms unterstützten Plattformen kompatibel
Auf allen von LiveCycle Designer und LiveCycle Forms unterstützten Plattformen kompatibel
Verwandte Themen
Grundlagen zu FormCalc
Grundlagen zu JavaScript
Unterschiede zwischen FormCalc- und JavaScript-Funktionen
JavaScript-Funktionen erstellen und wiederverwenden


So erstellen Sie eine Berechnung oder ein Skript

1.
Wählen Sie im Formularentwurf ein Objekt aus, das Ereignisse unterstützt.
2.
Wählen Sie im Skript-Editor aus der Liste „Anzeigen“ eines der Ereignisse, die für das betreffende Objekt gültig sind. Das gewählte Ereignis bestimmt, wann das Skript ausgeführt wird. Wenn Sie eine Berechnung oder ein Skript erstellen, die/das sich auf ein Objekt auswirkt, das keine Ereignisse unterstützt, müssen Sie Ihre Berechnung bzw. Ihr Skript einem Formularentwurfsobjekt hinzufügen, das Formularereignisse unterstützt.
3.
Wählen Sie in der Liste „Sprache“ eine Skriptsprache.
4.
Wählen Sie in der Liste „Ausführen am“, wo das Skript ausgeführt werden soll.
Zur Auswahl stehen die clientbasierte Anwendung (z. B. Acrobat oder ein Webbrowser) und der serverbasierte Prozess (z. B. LiveCycle Forms). Wenn „Client“ festgelegt wurde, wird die Verarbeitung von Berechnungen und Skripten erst nach der Wiedergabe des Formulars ausgelöst. Wenn „Server“ festgelegt wurde, erfolgt die Verarbeitung von Berechnungen und Skripten bereits während des Wiedergabevorgangs.
Wenn Sie in der Liste „Ausführen auf“ die Option „Client und Server“ wählen, wird das Skript entweder in der Client- oder in der Serveranwendung ausgeführt; dies ist davon abhängig, welche Anwendung zur Verarbeitung des Formulars verwendet wird.
5.
Geben Sie in das Feld „Skriptquelle“ eine FormCalc-Berechnung bzw. ein JavaScript-Skript ein. Mit Hilfe der Anweisungsende-Funktionalität von LiveCycle Designer können Sie Referenz-Syntaxen für eine Berechnung oder ein Skript erstellen.
6.
Klicken Sie auf „Änderungen zu Skriptquelle eingeben“ [image], um das Skript in das Formular einzufügen.
7.
Nach Fertigstellung des Formularentwurfs sollten Sie Ihre Berechnungen und Skripten vor dem eigentlichen Einsatz prüfen.
Verwandte Themen
Grundlagen zu FormCalc
Grundlagen zu JavaScript
Grundlagen zu Ereignissen
So erstellen Sie Berechnungen und Skripten mit dem Anweisungsende
Festlegen, wann eine Berechnung oder ein Skript ausgeführt werden soll
So zeigen Sie Skriptereignisse und Skripten an
Festlegen, wo eine Berechnung oder ein Skript ausgeführt werden soll
Berechnungen und Skripten testen und debuggen


So suchen Sie nach Text oder anderen Objekten

Auf der Registerkarte „XML-Quelle“ oder im Skript-Editor können Sie schnell nach jedem Vorkommen eines Wortes oder Ausdrucks suchen.
1.
Wählen Sie auf der Registerkarte „XML-Quelle“ oder im Skript-Editor den Befehl „Bearbeiten“ > „Suchen“ oder klicken Sie mit der rechten Maustaste, um das Kontextmenü aufzurufen.
2.
Geben Sie im Feld „Suchen nach“ den zu suchenden Text ein.
3.
Wählen Sie nach Wunsch andere Optionen aus.
4.
Klicken Sie auf „Weitersuchen“.
Zum Abbrechen eines laufenden Suchvorgangs drücken Sie die Esc-Taste oder klicken auf die Schaltfläche „Abbrechen“.
Verwandte Themen
Berechnungen und Skripten erstellen - Überblick
So erstellen Sie eine Berechnung oder ein Skript
So ersetzen Sie Text oder andere Objekte
So erstellen Sie Berechnungen und Skripten mit dem Anweisungsende
Festlegen, wann eine Berechnung oder ein Skript ausgeführt werden soll
So zeigen Sie Skriptereignisse und Skripten an
Festlegen, wo eine Berechnung oder ein Skript ausgeführt werden soll
Berechnungen und Skripten testen und debuggen


So ersetzen Sie Text oder andere Objekte

1.
Text kann automatisch ersetzt werden. Sie können z. B. Corp. durch Corporation ersetzen.
2.
Wählen Sie auf der Registerkarte „XML-Quelle“ oder im Skript-Editor „Bearbeiten“ > „Ersetzen“.
3.
Geben Sie im Feld „Suchen nach“ den zu suchenden Text ein.
4.
Geben Sie im Feld „Ersetzen durch“ den Ersatztext ein.
5.
Wählen Sie nach Wunsch andere Optionen aus.
6.
Klicken Sie auf „Weitersuchen“, „Ersetzen“ oder „Alle ersetzen“.
Zum Abbrechen eines laufenden Suchvorgangs drücken Sie die Esc-Taste oder klicken auf die Schaltfläche „Abbrechen“.
Von der direkten Bearbeitung des XML-Quellcodes auf der Registerkarte „XML-Quelle“ wird abgeraten, es sei denn, Sie sind mit der Adobe XML-Formulararchitektur vertraut. Weitere Informationen zur XML-Formulararchitektur finden Sie unter www.adobe.com/devnet/livecycle/.
Verwandte Themen
Berechnungen und Skripten erstellen - Überblick
So suchen Sie nach Text oder anderen Objekten


So erstellen Sie Berechnungen und Skripten mit dem Anweisungsende

Die Anweisungsende-Funktion im Skript-Editor gibt Ihnen die Möglichkeit, Ihre Berechnungen und Skripten interaktiv zu erstellen.
Wenn Sie eine Berechnung oder ein Skript erstellen, zeigt die Anweisungsende-Funktion jedes Mal, wenn Sie einen Punkt (.) unmittelbar hinter dem Namen eines Formularobjekts oder einer Formulareigenschaft eingeben, eine Liste der verfügbaren Methoden und Eigenschaften an. Wenn die Anweisungsende-Liste nicht erscheint, überprüfen Sie, dass Sie den Namen des Objekts oder der Eigenschaft korrekt eingegeben haben.
1.
Geben Sie den Namen eines Formularentwurfsobjekts oder einer Eigenschaft bzw. einen gültigen FormCalc-Kurzbefehl ein und gleich darauf einen Punkt.
2.
Wählen Sie die Methode oder Eigenschaft aus, die Sie für das Formularentwurfsobjekt anwenden möchten, und fahren Sie dann mit dem Erstellen des Skripts fort. Um die Anweisungsende-Liste zu schließen, ohne eine Funktion auszuwählen, drücken Sie die Esc-Taste.
Die Liste der verfügbaren Eigenschaften des XML Form Object Model ändert sich in Abhängigkeit von dem Formularentwurfsobjekt bzw. der Eigenschaft unmittelbar vor dem Punkt.
Verwandte Themen
Grundlagen zur Objekt-Scripting-Referenz
Objekteigenschaften und -werte referenzieren


So fügen Sie eine Objektreferenz-Syntax automatisch ein

Anstatt eine Objektreferenz-Syntax manuell mit der Anweisungsende-Liste zu erstellen, können Sie mit der Funktion zum Einfügen einer Objektreferenz-Syntax Ihren Berechnungen oder Skripten auch automatisch eine Referenz-Syntax hinzufügen. Diese Funktion gibt für das Objekt, das Sie im Skript-Editor im Feld „Skriptquelle“ ausgewählt haben, eine abgekürzte Referenz-Syntax ein. Berechnungen und Skripten lassen sich auf diese Weise schneller erstellen und es ist gewährleistet, dass die Referenz-Syntax fehlerfrei ist.
1.
Achten Sie darauf, dass das Feld „Skriptquelle“ im Skript-Editor den Fokus hat.
2.
Klicken Sie im Formular bei gedrückter Strg-Taste auf das zu referenzierende Objekt. Der Cursor nimmt die Form [image] an, um Ihnen die Objektauswahl zu erleichtern.
Verwandte Themen
Grundlagen zum Referenzieren von Objekten in Berechnungen und Skripten
Der Skript-Editor


Festlegen, wann eine Berechnung oder ein Skript ausgeführt werden soll

Beim Erstellen von Berechnungen und Skripten müssen Sie jeden Eintrag einem bestimmten Formularereignis zuweisen. Jedes Formularereignis stellt eine Änderung des Formularstatus dar, die zu einem bestimmten Zeitpunkt eintritt. Der Formularstatus kann sich während der Formularwiedergabe auf dem Server durch LiveCycle Forms, während der Formularwiedergabe auf dem Client durch Acrobat oder Adobe Reader sowie während des Ausfüllens des Formulars durch einen Benutzer ändern. Wenn eine Änderung des Formularstatus eintritt, werden alle mit dem Ereignis verbundenen Berechnungen oder Skripten automatisch verarbeitet.
Das Ereignis, das Sie beim Erstellen einer Berechnung oder eines Skriptes verwenden, bestimmt in gewissem Maß, was Sie bei der Berechnung oder im Skript berücksichtigen müssen. Beispielsweise kann die auf einem Formular verfügbare Datenmenge und -art je nach dem gewählten Zeitpunkt des Ereignisses anders ausfallen. Die Ergebnisse einer Berechnung oder eines Skriptes, die bzw. das den Wert eines Feldes abruft, fallen daher möglicherweise unterschiedlich aus, je nachdem, ob sie bzw. es ausgeführt wird, bevor oder nachdem ein Benutzer beim Ausfüllen des Formulars bestimmte Aktionen ausführt.
Je nach dem erstellten Formulartyp treten einige Ereignisse möglicherweise niemals ein. Angenommen, ein Formular enthält ein festes Layout und keine interaktiven Objekte. In diesem Fall treten interaktive Ereignisse, die mit Benutzeraktionen verknüpft sind, wahrscheinlich nie ein und die mit diesen Ereignissen verbundenen Skripten werden folglich nicht ausgeführt.
LiveCycle Designer unterstützt eine Vielzahl von Formularereignissen. Zahlreiche gängige Berechnungs- und Skriptaufgaben lassen sich aber auch mit Hilfe einiger weniger Ereignisse durchführen, die bei wichtigen Änderungen des Formularstatus auftreten. Dazu gehören unter anderem:
    • change
      •
      Wird ausgelöst, wenn ein Benutzer beim Ausfüllen einen Feldwert ändert.
    • click
      •
      Wird ausgelöst, wenn ein Benutzer beim Ausfüllen auf ein Feld oder eine Schaltfläche klickt.
    • docReady
      •
      Wird sofort nach dem Öffnen des Formulars in Acrobat oder Adobe Reader ausgelöst sowie unmittelbar bevor der Benutzer mit Formularobjekten arbeiten kann.
    • enter
      •
      Wird ausgelöst, wenn ein Benutzer beim Ausfüllen den Fokus auf ein bestimmtes Feld oder eine Schaltfläche verlagert.
    • exit
      •
      Wird ausgelöst, wenn ein Benutzer beim Ausfüllen den Fokus von einem bestimmten Feld oder von einer bestimmten Schaltfläche auf ein anderes Objekt verlagert.
Verwandte Themen
So zeigen Sie Skriptereignisse und Skripten an
Der Skript-Editor
Grundlagen zu Ereignissen
Festlegen, wo eine Berechnung oder ein Skript ausgeführt werden soll


So zeigen Sie Skriptereignisse und Skripten an

Im Skript-Editor gibt es verschiedene Möglichkeiten zur Anzeige der Skriptereignisse für Objekte in einem Formular. Welche Möglichkeiten verfügbar sind, hängt von der Art der ausgewählten Objekte und der Anzahl der anzuzeigenden Ereignisse ab.
Führen Sie zuerst die folgenden Schritte durch:
      •
      Wenn der Skript-Editor nicht auf dem Bildschirm angezeigt wird, wählen Sie „Fenster“ > „Skript-Editor“.
      •
      Wenn der Skript-Editor zum Anzeigen von mehr als einer Zeile eines Skripts nicht ausreicht, ziehen Sie die untere Linie des Skript-Editors nach unten, um das Anzeigefenster zu vergrößern.
So zeigen Sie im Skript-Editor ein Skriptereignis für ein einzelnes Objekt an
1.
Wählen Sie im Formular ein Objekt aus.
2.
Wählen Sie in der Liste „Anzeigen“ ein gültiges Skriptereignis aus.
Das Ereignis wird im Skript-Bearbeitungsfeld des Skript-Editors angezeigt. Bestimmte Ereignisse sind nur für bestimmte Objekte vorgesehen. Wenn Sie ein Skriptereignis auswählen, werden im Skript-Bearbeitungsfeld des Skript-Editors nur die gültigen Instanzen des Ereignisses aufgeführt. Angenommen, Sie wählen ein Teilformular aus, das eine Dropdown-Liste enthält, und dann das Ereignis preOpen. Im Skript-Editor wird lediglich ein Eintrag für die Dropdown-Liste angezeigt. Dies liegt daran, dass das Ereignis preOpen nur für Dropdown-Listen gilt. Wenn Sie hingegen das Ereignis enter auswählen, werden zwei Einträge angezeigt, d. h. ein Eintrag für die Dropdown-Liste und ein zweiter Eintrag für das Teilformular.
In der Liste „Anzeigen“ steht hinter den Namen von Ereignissen, die Skripten enthalten, jeweils ein Sternchen (*). Wenn ein Ereignis ein Skript enthält und Sie dieses Ereignis in der Liste „Anzeigen“ auswählen, wird die Quelle im Skript-Bearbeitungsfeld des Skript-Editors angezeigt.
So zeigen Sie im Skript-Editor ein Skriptereignis für ein Container-Objekt und dessen untergeordnete Objekte an
1.
Ändern Sie bei Bedarf die Größe des Skript-Editors, damit mehrere Skriptzeilen angezeigt werden können, und vergewissern Sie sich, dass die Option „Ereignisse für untergeordnete Objekte anzeigen“ [image] aktiviert ist.
2.
Wählen Sie ein Container-Objekt, wie z. B. ein Teilformular, aus.
3.
Wählen Sie in der Liste „Anzeigen“ ein gültiges Skriptereignis aus.
Die Ereignisse werden im Skript-Bearbeitungsfeld des Skript-Editors jeweils durch die Referenz-Syntax der einzelnen Ereignisse getrennt angezeigt. Bestimmte Ereignisse sind nur für bestimmte Objekttypen vorgesehen. Wenn Sie ein Skriptereignis auswählen, werden im Skript-Bearbeitungsfeld des Skript-Editors nur die gültigen Instanzen des Ereignisses aufgeführt. Angenommen, Sie wählen ein Teilformular aus, das eine Dropdown-Liste enthält, und dann das Ereignis preOpen. Im Skript-Editor wird lediglich ein Eintrag für die Dropdown-Liste angezeigt. Dies liegt daran, dass das Ereignis preOpen nur für Dropdown-Listen gilt. Wenn Sie hingegen das Ereignis enter auswählen, werden zwei Einträge angezeigt, d. h. ein Eintrag für die Dropdown-Liste und ein zweiter Eintrag für das Teilformular.
In der Liste „Anzeigen“ steht hinter den Namen von Ereignissen, die Skripten enthalten, jeweils ein Sternchen (*). Wenn ein Ereignis ein Skript enthält und Sie dieses Ereignis in der Liste „Anzeigen“ auswählen, wird die Quelle im Skript-Bearbeitungsfeld des Skript-Editors angezeigt.
So zeigen Sie im Skript-Editor alle Skriptereignisse für ein einzelnes Objekt an
1.
Wählen Sie im Formular ein Objekt aus.
2.
Wählen Sie in der Liste „Anzeigen“ die Option „Alle Ereignisse“ aus.
Die Ereignisse werden im Skript-Bearbeitungsfeld des Skript-Editors jeweils durch die Referenz-Syntax der einzelnen Ereignisse getrennt angezeigt.
So zeigen Sie im Skript-Editor alle Skriptereignisse für ein Container-Objekt und dessen untergeordnete Objekte an
1.
Ändern Sie bei Bedarf die Größe des Skript-Editors, damit mehrere Skriptzeilen angezeigt werden können, und vergewissern Sie sich, dass die Option „Ereignisse für untergeordnete Objekte anzeigen“ [image] aktiviert ist.
2.
Wählen Sie ein Container-Objekt, wie z. B. ein Teilformular, aus.
3.
Wählen Sie in der Liste „Anzeigen“ die Option „Alle Ereignisse“ aus.
Die Ereignisse werden im Skript-Bearbeitungsfeld des Skript-Editors jeweils durch die Referenz-Syntax der einzelnen Ereignisse getrennt angezeigt.
So zeigen Sie im Skript-Editor alle Skripten für ein einzelnes Objekt an
1.
Wählen Sie ein Objekt, an das Skripten angehängt sind.
2.
Wählen Sie in der Liste „Anzeigen“ die Option „Ereignisse mit Skripten“ aus.
Die Skripten werden im Skript-Bearbeitungsfeld des Skript-Editors jeweils durch die Referenz-Syntax der einzelnen Ereignisse getrennt angezeigt.
So zeigen Sie im Skript-Editor alle Skripten für ein Container-Objekt und dessen untergeordnete Objekte an
1.
Ändern Sie bei Bedarf die Größe des Skript-Editors, damit mehrere Skriptzeilen angezeigt werden können, und vergewissern Sie sich, dass die Option „Ereignisse für untergeordnete Objekte anzeigen“ [image] aktiviert ist.
2.
Wählen Sie ein Container-Objekt, wie z. B. ein Teilformular, aus. Alle Ereignisse für das Container-Objekt und dessen untergeordnete Objekte werden im Skript-Editor angezeigt.
3.
Wählen Sie in der Liste „Anzeigen“ die Option „Alle Ereignisse“ aus.
Die Skripten werden im Skript-Bearbeitungsfeld des Skript-Editors jeweils durch die Referenz-Syntax der einzelnen Ereignisse getrennt angezeigt.
Verwandte Themen
Info über die Vorschau und das Testen von Formularen


Festlegen, wo eine Berechnung oder ein Skript ausgeführt werden soll

Für jede in LiveCycle Designer erstellte Berechnung und jedes Skript müssen Sie angeben, wo die Berechnung bzw. das Skript ausgeführt werden soll.
Sofern Sie keine serverbasierte Verarbeitung wie LiveCycle Forms verwenden, müssen Sie sicherstellen, dass alle Ihre Berechnungen und Skripten für die Ausführung auf der Client-Anwendung (z. B. Acrobat oder ein Webbrowser) ausgelegt sind.
Wenn Sie die serverbasierte Verarbeitung verwenden, können Sie wählen, ob Berechnungen in der Client-Anwendung oder auf dem Server ausgeführt werden sollen. Wenn Sie sich entscheiden, Berechnungen und Skripten auf dem Server ausführen zu lassen, legen Sie damit fest, dass die Skripten zu einem bestimmten Zeitpunkt während des Formularwiedergabeprozesses ausgeführt werden.
Wenn Sie in der Liste „Ausführen am“ die Option „Client und Server“ wählen, steht die Berechnung bzw. das Skript sowohl client- als auch serverbasierten Anwendungen zur Verfügung. Diese Option ist beispielsweise dann sinnvoll, wenn Sie nicht wissen, ob den Benutzern, die Ihr Formular nutzen möchten, Client- oder Serveranwendungen zur Verfügung stehen. Die Option ist auch dann von Nutzen, wenn sich bestimmte Formularobjekte gegenüber einer Client-Anwendung und einer serverbasierten Anwendung unterschiedlich verhalten.
Verwandte Themen
Der Skript-Editor
Grundlagen zu Ereignissen
Festlegen, wann eine Berechnung oder ein Skript ausgeführt werden soll
So zeigen Sie Skriptereignisse und Skripten an


Berechnungen und Skripten testen und debuggen

Wenn Sie Berechnungen oder Skripten erstellt und Ihr Formular getestet haben, können Skriptfehler oder andere unerwartete Feldwerte aufgrund von Skriptfehlern auftreten.
In LiveCycle Designer gibt es drei grundlegende Methoden zum Testen und Debugging Ihrer Berechnungen und Skripten:
      •
      Mit Hilfe der Paletten im Arbeitsbereich von LiveCycle Designer. Weitere Informationen finden Sie unter Berechnungen und Skripten mit dem Arbeitsbereich debuggen.
      •
      Testen Ihrer Skripten mit Hilfe von JavaScript-Debugger (nur für JavaScript). Weitere Informationen zur Verwendung des Debuggers finden Sie unter So aktivieren Sie den JavaScript-Debugger für LiveCycle Designer.
      •
      Verwenden der Hostmodell- und Ereignismodell-Eigenschaften und -Methoden zur Behebung der Fehler im Formular.
Mit Hilfe der Hostmodell- und Ereignismodell-Funktionalität können Sie entweder mit der Host-Anwendung oder mit den verschiedenen Formularereignissen arbeiten. Diese Modelle können hilfreiche Informationen zum Debugging von Berechnungen und Skripten zurückgeben.
Das folgende Skript gibt z. B. zur Laufzeit eine Meldung zurück, die den Namen des Ereignisses angibt, auf welchem das Skript platziert wurde. Das bedeutet, dass ein bestimmtes Ereignis ausgelöst wurde.
    xfa.host.messageBox(xfa.event.name)  // FormCalc
    xfa.host.messageBox(xfa.event.name); // JavaScript
Ein weiteres Beispiel für den Einsatz der Hostmodell- und Ereignismodell-Methoden ist das Abrufen des Wertes eines Feldes in einem interaktiven Formular, bevor es vom Benutzer manuell bearbeitet wird. Dadurch lässt sich feststellen, wie die Objekte in Ihrem Formularentwurf auf die vom Benutzer eingegebenen Daten reagieren.
    xfa.host.messageBox(xfa.event.prevText)  // FormCalc
    xfa.host.messageBox(xfa.event.prevText); // JavaScript
Verwandte Themen
Berechnungen und Skripten mit dem Arbeitsbereich debuggen
Grundlagen zum Arbeiten mit Host-Anwendungen
Grundlagen zum Ereignismodell


Ereignisse

Grundlagen zu Ereignissen
Ereignistypen
Prozessereignisse
Interaktive Ereignisse
Anwendungsereignisse
Ereignisliste


Grundlagen zu Ereignissen

Alle Berechnungen und Skripten, die einem Formularobjekt hinzugefügt werden, sind jeweils einem bestimmten Ereignis zugeordnet. Unter einem Ereignis versteht man ein bestimmtes Vorkommnis oder eine Aktion, das bzw. die den Zustand eines Formulars ändern kann. Wenn eine Änderung des Zustands eintritt, wird automatisch eine mit dem Ereignis verbundene Berechnung oder ein Skript aufgerufen. Ereignisse können zu beliebigen Zeitpunkten auftreten – vom Beginn des Formularwiedergabeprozesses, wenn Daten mit einem Formularentwurf zusammengeführt werden, bis hin zum Ausfüllen des Formulars, wenn ein Benutzer die Formularobjekte in einer Client-Anwendung verwendet. Durch die Verknüpfung von Berechnungen und Skripten mit bestimmten Ereignissen können Sie präzise steuern, wie Formularobjekte und -daten dargestellt werden und wie die Objekte und Daten auf die Benutzerinteraktionen beim Ausfüllen des Formulars reagieren.
Eine einzelne Zustandsänderung oder Aktion beim Ausfüllen des Formulars kann mehrere Ereignisse auslösen. Wenn beispielsweise mit der Tabulatortaste vom aktuellen Feld zum nächsten Feld gewechselt wird, löst dies sowohl das exit-Ereignis für das aktuelle Feld als auch das enter-Ereignis für das nächste Feld aus. Wenn sich das aktuelle und das nächste Feld in unterschiedlichen Teilformularen befinden, werden insgesamt vier Ereignisse ausgelöst: je ein exit-Ereignis für das aktuelle Feld und Teilformular sowie je ein enter-Ereignis für das nächste Feld und Teilformular. In der Regel gilt für alle Kategorien der Formularereignisse eine vorhersehbare Reihenfolge.
Verwandte Themen
Ereignistypen
Prozessereignisse
Interaktive Ereignisse
Anwendungsereignisse


Ereignistypen

Die Formularereignisse werden in vier Kategorien unterteilt:
Prozessereignisse
Dieser Ereignistyp wird durch einen internen Prozess bzw. eine interne Aktion im Zusammenhang mit Objekten in einem Formular automatisch ausgelöst. Angenommen, ein Benutzer klickt beim Ausfüllen des Formulars auf eine Schaltfläche, durch die dem Formular eine neue Seite hinzugefügt wird. In diesem Fall werden die Prozessereignisse initialize, calculate, validate und layout:ready automatisch für die neue Seite initiiert.
Interaktive Ereignisse
Dieser Ereignistyp wird direkt durch Aktionen beim Ausfüllen des Formulars ausgelöst. Wenn ein Benutzer z. B. den Zeiger über ein Feld in einem Formular bewegt, wird durch diese Aktion das Ereignis mouseEnter initiiert.
Anwendungsereignisse
Dieser Ereignistyp wird durch die Aktionen ausgelöst, die eine Client-Anwendung oder eine Serveranwendung ausführt. Beispielsweise können Sie mit Hilfe des Ereignisses prePrint eine Berechnung oder ein Skript erstellen, die bzw. das unmittelbar vor dem Drucken des Formulars eine Aufgabe ausführt.
Verwandte Themen
Grundlagen zu Ereignissen
Prozessereignisse
Interaktive Ereignisse
Anwendungsereignisse


Prozessereignisse

Prozessereignisse werden durch einen internen Prozess bzw. eine interne Aktion im Zusammenhang mit einem Formular oder Objekten in einem Formular automatisch ausgelöst. Sie werden unmittelbar nach bedeutsamen Formularänderungen initiiert, z. B. nach dem Zusammenführen eines Formularentwurfs mit Daten oder nach dem Abschluss der Formularpaginierung. Prozessereignisse werden außerdem unmittelbar nach dem Initiieren interaktiver Ereignisse ausgelöst. Beispielsweise wird direkt nach dem Initiieren eines beliebigen interaktiven Ereignisses das Ereignis calculate ausgelöst und anschließend das Ereignis validate.
Die folgenden Prozessereignisse sind im Skript-Editor unter „Anzeigen“ verfügbar:
      •
      calculate
      •
      form:ready
      •
      indexChange
      •
      initialize
      •
      layout:ready
      •
      validate
Prozessereignisse können auf Grund von Abhängigkeiten viele Male initiiert werden. Unter Abhängigkeiten versteht man Aktionen, die einem einzelnen Ereignis zugeordnet sind, das letztlich ein oder mehrere zusätzliche Ereignisse auslöst. Angenommen, ein Benutzer klickt beim Ausfüllen eines Formulars auf eine Schaltfläche, um einen zuvor ausgeblendeten Bereich des Formulars einzublenden. Durch Klicken auf die Schaltfläche wird nicht nur eine Reihe interaktiver und Prozessereignisse für die Schaltfläche selbst ausgelöst, sondern auch eine Reihe von Prozessereignissen für das neue Teilformular.
In der folgenden Abbildung wird die normale Ereignisabfolge bis zum Öffnen eines PDF-Formulars in Acrobat oder Adobe Reader veranschaulicht.
Nach dem Öffnen des Formulars in Acrobat oder Adobe Reader werden diese Prozessereignisse unter Umständen auf Grund von Formularänderungen erneut ausgelöst. Beispielsweise werden die Ereignisse calculate, validate und layout:ready für ein Objekt unmittelbar nach dem Initiieren beliebiger interaktiver Ereignisse ausgelöst. Die mit den Prozessereignissen verknüpften Berechnungen und Skripten werden daher mehrmals ausgeführt.
Verwandte Themen
Grundlagen zu Ereignissen
Interaktive Ereignisse
Anwendungsereignisse
calculate-Ereignis
docReady-Ereignis
form:ready-Ereignis
indexChange-Ereignis
initialize-Ereignis
layout:ready-Ereignis
validate-Ereignis
Festlegen, wann eine Berechnung oder ein Skript ausgeführt werden soll


Interaktive Ereignisse

Interaktive Ereignisse werden direkt durch Benutzeraktionen beim Ausfüllen des Formulars ausgelöst. Daher sind sie für eine Vielzahl von Berechnungs- und Skriptaufgaben nützlich. Beispielsweise können Sie dem Ereignis mouseEnter für ein Textfeld ein Skript hinzufügen, welches die Umrandungsfarbe des Feldes in Blau ändert, und dem Ereignis mouseExit ein Skript, welches die Originalfarbe der Umrandung wiederherstellt. Durch diese Aktion wird das Feld visuell hervorgehoben, wenn ein Benutzer beim Ausfüllen des Formulars den Zeiger über das Feld bewegt. Interaktive Ereignisse sind auch nützlich, wenn Formulardaten in Abhängigkeit von einer Benutzerauswahl geändert werden sollen. Beispielsweise können Sie dem Ereignis change für eine Dropdown-Liste ein Skript hinzufügen, welches die Datenwerte in mehreren Feldern je nach dem Wert aktualisiert, welchen der Benutzer beim Ausfüllen des Formulars in der Dropdown-Liste auswählt.
Die folgenden interaktiven Ereignisse sind im Skript-Editor unter „Anzeigen“ verfügbar:
      •
      change
      •
      click
      •
      enter
      •
      exit
      •
      mouseDown
      •
      mouseEnter
      •
      mouseExit
      •
      mouseUp
      •
      preOpen
In der folgenden Abbildung wird die normale Ereignisabfolge beim Ausfüllen von Formularen veranschaulicht, wenn der Benutzer mit der Maus ein Objekt auswählt und dessen Wert ändert.
Die Abbildung veranschaulicht eine normale Ereignisabfolge; diese Abfolge kann aber von bestimmten Aktionen des Formularbenutzers und von bestimmten Formularobjekten geändert werden. Wenn ein Benutzer beim Ausfüllen des Formulars beispielsweise in einer Dropdown-Liste einen Wert auswählt, tritt das mouseExit-Ereignis nach dem click-Ereignis auf, aber vor dem Ereignis change oder full. Wenn ein Benutzer ein Feld auswählt, die Maustaste drückt und dann das Feld verlässt, ohne die Maustaste loszulassen, findet das mouseUp-Ereignis nicht zu dem in der Abbildung beschriebenen Zeitpunkt statt.
In der folgenden Abbildung wird die normale Ereignisabfolge beim Ausfüllen von Formularen veranschaulicht, wenn der Benutzer über die Tastatur ein Objekt auswählt und dessen Wert ändert.
Verwandte Themen
change-Ereignis
click-Ereignis
enter-Ereignis
exit-Ereignis
full-Ereignis
mouseDown-Ereignis
mouseEnter-Ereignis
mouseExit-Ereignis
mouseUp-Ereignis
preOpen-Ereignis


Anwendungsereignisse

Anwendungsereignisse werden durch Aktionen ausgelöst, die eine Client-Anwendung oder eine Serveranwendung als Reaktion auf eine Benutzeraktion beim Ausfüllen des Formulars oder infolge eines automatisierten Prozesses ausführt. Wenn ein Benutzer das Formular z. B. in Acrobat oder Adobe Reader speichert, wird unmittelbar vor dem Speichern-Vorgang das Ereignis preSave ausgelöst. Anschließend werden die Ereignisse calculate, validate und layout:ready in dieser Reihenfolge für alle Objekte im Formular initiiert. Die gleiche Ereignisabfolge wird initiiert, wenn das Formular ein Skript enthält, welches das Formular programmatisch speichert.
Die folgenden Anwendungsereignisse sind im Skript-Editor unter „Anzeigen“ verfügbar:
      •
      docClose
      •
      docReady
      •
      postPrint
      •
      postSave
      •
      prePrint
      •
      preSave
      •
      preSubmit
Anwendungsereignisse kommen in normalen Ereignisabfolgen nicht vor. Sie sind vielmehr Einzelereignisse im Zusammenhang mit Aktionen, welche die Client- oder Serveranwendung ausführt.
Verwandte Themen
docClose-Ereignis
postPrint-Ereignis
postSave-Ereignis
prePrint-Ereignis
preSave-Ereignis
preSubmit-Ereignis


Ereignisliste

calculate-Ereignis
change-Ereignis
click-Ereignis
docClose-Ereignis
docReady-Ereignis
enter-Ereignis
exit-Ereignis
form:ready-Ereignis
full-Ereignis
indexChange-Ereignis
initialize-Ereignis
layout:ready-Ereignis
mouseDown-Ereignis
mouseEnter-Ereignis
mouseExit-Ereignis
mouseUp-Ereignis
postPrint-Ereignis
postSave-Ereignis
preOpen-Ereignis
prePrint-Ereignis
preSave-Ereignis
preSubmit-Ereignis
validate-Ereignis


calculate-Ereignis

Beschreibung
Wird unter den folgenden Umständen initiiert:
      •
      Wenn der Formularentwurf und die Daten zum fertigen Formular zusammengeführt werden.
      •
      Wenn sich einer der Werte ändert, von denen die Berechnung abhängig ist, z. B. der Wert eines bestimmten Feldes, es sei denn, der berechnete Wert wurde beim Ausfüllen des Formulars manuell vom Benutzer überschrieben. Als Ergebnis zeigt das Objekt den Rückgabewert des Ereignisses an. Die Eigenschaften für manuell überschriebene Felder befinden sich auf der Registerkarte „Wert“ der Palette „Objekt“.
      •
      Wenn ein Feld den Fokus verliert, z. B. wenn ein Benutzer klickt oder die Tabulatortaste drückt, um ein Feld zu verlassen.
Bei Verwendung des Ereignisses calculate zur Durchführung von Berechnungen oder Skripten ist Folgendes zu beachten:
      •
      Berechnungen und Skripten für das Ereignis calculate dürfen keine Änderungen an der Formularstruktur vornehmen; davon ausgenommen sind die Formularfeld- und Datenwerte.
      •
      Vom Ereignis calculate eingefügte Inhalte müssen den zugehörigen Validierungen für das Objekt entsprechen; anderenfalls werden Validierungsfehler gemeldet.
      •
      Berechnungen und Skripten dürfen keine Endlosschleifen enthalten, weil diese dazu führen, dass das Formular den Wert kontinuierlich aktualisiert. Beispielsweise könnte ein Skript, welches den Wert eines Feldes im Rahmen eines Schleifenausdrucks inkrementiert (z. B. eine Schleife des Typs while oder for ), eine Endlosschleife schaffen.
Typ
Prozessereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
4
Beispiel
Das Ereignis calculate eignet sich zur Aktualisierung von Zahlenwerten in Feldern, weil es unmittelbar nach den meisten anderen Ereignissen initiiert wird. Beispielsweise könnten Sie in einem Bestellformular mit dem Ereignis calculate für ein Feld den Prozentwert der Umsatzsteuer anhand der Bestellkosten errechnen. Die Berechnung wird jedes Mal ausgeführt, wenn die Werte in den Formularfeldern geändert werden. Auf diese Weise wird gewährleistet, dass der für die Umsatzsteuer angezeigte Wert immer korrekt ist.
Da das Ereignis calculate aber viele Male initiiert werden kann, müssen Sie sicherstellen, dass die Berechnung oder das Skript, die bzw. das Sie dem Ereignis hinzufügen, nicht zu einer unnötigen Inkrementierung von Datenwerten führt. Wenn z. B. im Rahmen der Umsatzsteuerberechnung der Wert der Umsatzsteuer den Gesamtkosten bei jeder Initiierung des Ereignisses calculate hinzugefügt wird, fällt der resultierende Gesamtkostenwert im Formular möglicherweise zu hoch aus.
Verwandte Themen
Grundlagen zu Ereignissen
Prozessereignisse


change-Ereignis

Beschreibung
Wird ausgelöst, wenn ein Benutzer beim Ausfüllen des Formulars den Inhalt eines Feldes durch eine der folgenden Aktionen ändert:
      •
      Tasteneingabe, während das Feld den Tastaturfokus besitzt
      •
      Dateneingabe in das Feld
      •
      Auswahl aus einem Listenfeld oder einer Dropdown-Liste
      •
      Aktivieren oder Deaktivieren eines Kontrollkästchens
      •
      Änderung der Einstellungen einer Optionsfeldgruppe
Dieses Ereignis wird nicht ausgelöst, wenn die Objektwerte durch Berechnungen oder Skripten bzw. durch die Zusammenführung des Formularentwurfs mit Daten geändert werden.
Typ
Interaktives Ereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
4
(Nur für Dropdown-Listen)
Beispiel
Dieses Ereignis eignet sich für Berechnungen oder Skripten, die ausgelöst werden müssen, wenn ein Benutzer beim Ausfüllen des Formulars den Wert eines Feldes ändert. Beispielsweise können Sie das Ereignis change für eine Dropdown-Liste verwenden, damit in einer Tabelle bestimmte Zeilen hervorgehoben werden. Jedes Mal, wenn der Benutzer einen Wert in der Dropdown-Liste auswählt, wird dann die entsprechende Tabellenzeile hervorgehoben.
Verwandte Themen
Grundlagen zu Ereignissen
Interaktive Ereignisse


click-Ereignis

Beschreibung
Wird initiiert, wenn innerhalb des Bereichs ein Mausklick erfolgt. Wenn ein click-Ereignis für ein Text- oder numerisches Feld ausgelöst wird, werden Berechnungen oder Skripten sofort ausgeführt. Der Wert des Feldes wird aber erst dann aufgrund von Berechnungen und Skripten geändert, wenn das Feld den Fokus verliert.
Sie können keine Berechnung und kein Skript auf das click-Ereignis einer Senden-Schaltfläche platzieren, weil die Berechnung oder das Skript die Übergabeaktion außer Kraft setzt. Platzieren Sie Berechnungen und Skripten stattdessen auf das preSubmit-Ereignis für eine Senden-Schaltfläche.
Typ
Interaktives Ereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
4
Beispiel
Dieses Ereignis eignet sich für die Ausführung einer Aktion, nachdem ein Benutzer im Formular auf eine Schaltfläche geklickt oder ein Optionsfeld bzw. ein Kontrollkästchen aktiviert hat. Beispielsweise können Sie mit dem Ereignis click für ein Kontrollkästchen ein Formularfeld ein- und ausblenden.
Verwandte Themen
Grundlagen zu Ereignissen
Interaktive Ereignisse
preSubmit-Ereignis


docClose-Ereignis

Beschreibung
Wird ganz am Ende der Verarbeitung eines Formulars ausgeführt, sofern sämtliche Formularüberprüfungen fehlerfrei durchgeführt wurden.
Typ
Anwendungsereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
8
Beispiel
Dieses Ereignis wird erst spät ausgelöst und führt keine Änderungen am gespeicherten Formular durch. Es soll vielmehr die Möglichkeit bieten, einen Beenden-Status oder eine Fertig-Meldung zu erzeugen. Beispielsweise können Sie mit dem Ereignis docClose eine Meldung mit dem Hinweis einblenden, dass das Formular fertig ausgefüllt ist.
Verwandte Themen
Grundlagen zu Ereignissen
Anwendungsereignisse
Prozessereignisse


docReady-Ereignis

Beschreibung
Wird unmittelbar nach dem Öffnen des Formulars in Acrobat oder Adobe Reader ausgelöst.
Typ
Anwendungsereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
8
Beispiel
Dies ist das erste Ereignis, das nach dem Öffnen eines Formulars in Acrobat oder Adobe Reader ausgelöst wird. Dieses Ereignis sollte für alle Berechnungs- oder Skriptaufgaben verwendet werden, für welche das vollständige Formular gebraucht wird oder die nur einmal beim ersten Öffnen des Formulars ausgeführt werden sollen. Beispielsweise können Sie mit dem Ereignis docReady die Version von Acrobat oder Adobe Reader prüfen und eine Meldung einblenden, wenn vor dem Ausfüllen des Formulars eine Anwendungsaktualisierung erforderlich ist.
Verwandte Themen
Grundlagen zu Ereignissen
Anwendungsereignisse


enter-Ereignis

Beschreibung
Wird ausgelöst, wenn ein Feld oder Teilformular den Tastaturfokus erhält, und zwar unabhängig davon, ob dies durch eine Benutzeraktion verursacht wird (Wechsel in ein Feld per Tabulatortaste oder Mausklick) oder durch ein Skript, welches den Fokus programmatisch setzt.
Typ
Interaktives Ereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
4
Beispiel
Mit diesem Ereignis können Sie Hilfetext oder andere Meldungen bereitstellen, welche dem Benutzer das Ausfüllen des aktuellen Feldes oder Teilformulars erleichtern. Angenommen, in ein Feld muss ein Wert in einem bestimmten Format eingegeben werden oder beim Ausfüllen eines Feldes sind spezifische Anweisungen zu beachten. In diesem Fall können Sie mit diesem Ereignis eine Meldung einblenden, welche den Benutzer über die besonderen Anforderungen informiert.
Verwandte Themen
Grundlagen zu Ereignissen
Interaktive Ereignisse


exit-Ereignis

Beschreibung
Wird ausgelöst, wenn das Feld oder Teilformular den Tastaturfokus verliert, und zwar unabhängig davon, ob dies durch eine Benutzeraktion verursacht wird (Wechsel in ein anderes Feld per Tabulatortaste oder Mausklick außerhalb des Feldes) oder durch ein Skript, welches den Fokus programmatisch entfernt.
Typ
Interaktives Ereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
4
Beispiel
Dieses Ereignis eignet sich zur Überprüfung von Felddaten, wenn der Benutzer den Fokus von einem Feld entfernt. Angenommen, in ein Feld muss ein Wert eingegeben werden. In diesem Fall können Sie mit diesem Ereignis eine Meldung bereitstellen, welche den Benutzer darauf aufmerksam macht, dass das Formular nur gesendet werden kann, wenn in dieses Feld Daten eingegeben wurden.
Verwandte Themen
Grundlagen zu Ereignissen
Interaktive Ereignisse


form:ready-Ereignis

Beschreibung
Wird ausgelöst, nachdem Formularentwurf und Daten zusammengeführt wurden, das fertige Formular gespeichert wurde und die Ereignisse initialize, calculate und validate abgeschlossen sind.
Typ
Prozessereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
8
Beispiel
Dieses Ereignis eignet sich zur Ausführung von Aufgaben, nachdem Formularentwurf und Daten zusammengeführt wurden, aber bevor das Layout fertig ist. Beispielsweise können Sie mit diesem Ereignis die Anordnung oder Platzierung von Teilformularen im Formular anpassen, bevor das Formular paginiert und wiedergegeben wird.
Verwandte Themen
Grundlagen zu Ereignissen
Prozessereignisse


full-Ereignis

Beschreibung
Wird ausgelöst, wenn beim Ausfüllen von Formularen mehr als die maximal zulässige Menge an Inhalt in ein Feld eingegeben wird. Angenommen, die Eigenschaft „Länge begrenzen“ für ein Feld wurde auf 5 eingestellt und ein Benutzer versucht, die Zeichenfolge abcdef einzugeben. In diesem Fall wird das Ereignis full initiiert, sobald der Benutzer den Buchstaben f eingibt.
Die Eigenschaft „Länge begrenzen“ für ein Feld befindet sich auf der Registerkarte „Feld“ der Palette „Objekt“.
Typ
Interaktives Ereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
8
Beispiel
Verwenden Sie dieses Ereignis, um einen Benutzer darauf hinzuweisen, dass die maximal zulässige Datenmenge in ein Feld eingegeben wurde. Beispielsweise können Sie eine Meldung mit dem Hinweis einblenden, dass das Feld voll ist, und Möglichkeiten zur Problemlösung vorschlagen.
Verwandte Themen
Grundlagen zu Ereignissen
Interaktive Ereignisse
Eigenschaften von Textfeldern: Registerkarte „Feld“


indexChange-Ereignis

Beschreibung
Wird ausgelöst, nachdem ein Teilformular durch Zusammenführen neuer Daten mit dem Formular oder mit Hilfe von Skripten eingefügt, verschoben oder aus dem Formular entfernt wurde.
Dieses Ereignis wird nur von den Teilformularinstanzen empfangen, die vom Instanzmanager verwaltet werden; bei Teilformularsätzen wird es ignoriert.
Typ
Prozessereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
8
Beispiel
Mit diesem Ereignis können Sie anhand des Instanzwerts eines bestimmten Objekts Eigenschaften festlegen. Beispielsweise lässt sich damit die abwechselnde Zeilenschattierung in einer Tabelle steuern.
Verwandte Themen
Grundlagen zu Ereignissen
Prozessereignisse


initialize-Ereignis

Beschreibung
Wird für alle Objekte initiiert, nachdem der Formularentwurf mit Daten zusammengeführt wurde.
Typ
Prozessereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
4
Beispiel
Mit diesem Ereignis können Sie beim Erstellen eines Objekts Aktionen ausführen, die entweder durch eine Benutzeraktion beim Ausfüllen des Formulars oder im Rahmen des Formularerstellungsprozesses verursacht werden. Beispielsweise können Sie die Einstellungen für neue Instanzen eines Teilformularobjekts steuern, welche der Benutzer dem Formular durch Klicken auf eine Schaltfläche hinzufügt.
Verwandte Themen
Grundlagen zu Ereignissen
Prozessereignisse


layout:ready-Ereignis

Beschreibung
Wird initiiert, wenn Formularentwurf und Daten zusammengeführt wurden, das Formular vorhanden ist und das Layout des Formulars angewendet wurde. Zu diesem Zeitpunkt wurde das fertige Formular noch nicht wiedergegeben; eine Berechnung oder ein Skript, die bzw. das bei diesem Ereignis ausgeführt werden soll, könnte das Layout vor der Wiedergabe also modifizieren. Dieses Ereignis tritt auch nach der Formularwiedergabe auf, wenn eine Berechnung oder ein Skript die Daten ändert bzw. eine Änderung des Formulars in Acrobat oder Adobe Reader bewirkt.
Typ
Prozessereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
8
Beispiel
Mit diesem Ereignis können Sie unmittelbar nach der Festlegung des Formularlayouts bestimmte Aufgaben ausführen. Beispielsweise können Sie die Anzahl der Seiten bestimmen, welche das Formular enthält.
Verwandte Themen
Grundlagen zu Ereignissen
Prozessereignisse


mouseDown-Ereignis

Beschreibung
Wird initiiert, wenn ein Benutzer beim Ausfüllen des Formulars die Maustaste drückt, während sich der Zeiger in einem Feld befindet.
Wenn ein mouseDown-Ereignis für ein Text- oder numerisches Feld ausgelöst wird, werden Berechnungen oder Skripten sofort ausgeführt. Der Wert des Feldes wird aber erst dann aufgrund von Berechnungen und Skripten geändert, wenn das Feld den Fokus verliert. Wenn ein mouseDown-Ereignis für ein Dokumentunterschriftsfeld initiiert wird, wird das Ereignis vor Beginn des Unterschriftsprozesses ausgelöst.
Typ
Interaktives Ereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
4
Beispiel
Dieses Ereignis eignet sich für die Ausführung einer Aktion, nachdem ein Benutzer im Formular auf eine Schaltfläche geklickt oder ein Optionsfeld bzw. ein Kontrollkästchen aktiviert hat. Beispielsweise können Sie mit dem Ereignis mouseDown für ein Kontrollkästchen ein Formularfeld ein- und ausblenden. Dieses Ereignis ist von der Konzeption her mit dem Ereignis click vergleichbar und erfüllt einen ähnlichen Zweck.
Verwandte Themen
Grundlagen zu Ereignissen
Interaktive Ereignisse
click-Ereignis


mouseEnter-Ereignis

Beschreibung
Dieses Ereignis wird ausgelöst, wenn der Benutzer beim Ausfüllen des Formulars den Mauszeiger in den Feldbereich bewegt; dabei muss nicht notwendigerweise die Maustaste gedrückt werden. Es wird nicht ausgelöst, wenn der Mauszeiger aus einem anderen Grund in das Feld gelangt, z. B. weil ein darüber liegendes Fenster geschlossen wurde.
Typ
Interaktives Ereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
8
Beispiel
Sie können dieses Ereignis mit dem Ereignis mouseExit kombinieren, um dem Benutzer beim Ausfüllen des Formulars visuelles Feedback zu liefern. Beispielsweise können Sie mit diesem Ereignis die Rahmen- oder Hintergrundfarbe eines Objekts ändern, damit der Benutzer beim Ausfüllen visuell erkennen kann, dass er sich zurzeit in einem bestimmten Feld befindet.
Verwandte Themen
Grundlagen zu Ereignissen
Interaktive Ereignisse


mouseExit-Ereignis

Beschreibung
Dieses Ereignis wird ausgelöst, wenn der Benutzer beim Ausfüllen des Formulars den Mauszeiger aus dem Feld herausbewegt, auch wenn er dabei die Maustaste gedrückt hält. Es wird nicht ausgelöst, wenn der Mauszeiger aus einem anderen Grund aus dem Feld bewegt wird, z. B. weil ein darüber liegendes Fenster geöffnet wurde.
Typ
Interaktives Ereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
8
Beispiel
Sie können dieses Ereignis mit dem Ereignis mouseEnter kombinieren, um dem Benutzer beim Ausfüllen des Formulars visuelles Feedback zu liefern. Beispielsweise können Sie mit diesem Ereignis die Rahmen- oder Hintergrundfarbe eines Objekts auf die ursprüngliche Einstellung zurücksetzen, damit der Benutzer beim Ausfüllen visuell erkennen kann, dass er sich nicht mehr in einem bestimmten Feld befindet.
Verwandte Themen
Grundlagen zu Ereignissen
Interaktive Ereignisse


mouseUp-Ereignis

Beschreibung
Wird initiiert, wenn ein Benutzer beim Ausfüllen des Formulars die Maustaste loslässt, während sich der Zeiger in einem Feld befindet.
Wenn ein mouseUp-Ereignis für ein Text- oder numerisches Feld eintritt, werden Berechnungen oder Skripten sofort ausgeführt. Der Wert des Feldes wird aber erst dann aufgrund von Berechnungen und Skripten geändert, wenn das Feld den Fokus verliert.
Typ
Interaktives Ereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
4
Beispiel
Dieses Ereignis eignet sich für die Ausführung von Aktionen, nachdem ein Benutzer im Formular auf eine Schaltfläche geklickt oder ein Optionsfeld bzw. ein Kontrollkästchen aktiviert hat. Beispielsweise können Sie mit dem Ereignis mouseUp für ein Kontrollkästchen ein Formularfeld ein- und ausblenden. Dieses Ereignis ist von der Konzeption her mit dem Ereignis click vergleichbar und erfüllt einen ähnlichen Zweck.
Verwandte Themen
Grundlagen zu Ereignissen
Interaktive Ereignisse


postPrint-Ereignis

Beschreibung
Wird sofort initiiert, sobald das wiedergegebene Formular zum Drucker, Spooler oder Ausgabeziel gesendet wurde.
Typ
Anwendungsereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
8
Beispiel
Mit diesem Ereignis können Sie Meldungen für den Benutzer anzeigen, nachdem das Formular gedruckt wurde. Beispielsweise können Sie ein Skript für das Ereignis postPrint erstellen, um Benutzer daran zu erinnern, wie sie das Formular manuell einreichen können.
Verwandte Themen
Grundlagen zu Ereignissen
Anwendungsereignisse


postSave-Ereignis

Beschreibung
Wird sofort ausgeführt, nachdem ein Benutzer ein Formular im PDF- oder XDP-Format gespeichert hat. Dieses Ereignis wird nicht ausgeführt, wenn Sie eine Teilmenge des Formulars (z. B. nur Formulardaten) in das XDP-Format exportieren.
Typ
Anwendungsereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
8
Beispiel
Mit diesem Ereignis können Sie Meldungen für den Benutzer anzeigen, nachdem die Formulardaten gespeichert wurden. Beispielsweise können Sie ein Skript für das Ereignis postSave erstellen, um Benutzer daran zu erinnern, wie viel Zeit ihnen noch zum Ausfüllen und Einreichen des Formulars verbleibt.
Verwandte Themen
Grundlagen zu Ereignissen
Anwendungsereignisse


preOpen-Ereignis

Beschreibung
Wird ausgeführt, wenn ein Benutzer beim Ausfüllen des Formulars eine Aktion ausführt, mit welcher die Dropdown-Liste angezeigt wird. Dies geschieht beispielsweise, wenn der Benutzer auf das Pfeilsymbol neben der Dropdown-Liste klickt oder wenn er mit der Tabulatortaste zur Dropdown-Liste wechselt und anschließend das Pfeilsymbol verwendet. Das Ereignis wird ausgelöst, bevor der Inhalt der Dropdown-Liste angezeigt wird.
Dieses Ereignis ist nur für Dropdown-Listenobjekte vorgesehen.
Typ
Interaktives Ereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
8
Beispiel
Mit diesem Ereignis können Sie das Laden großer Mengen von Listenelementen steuern. Beispielsweise können Sie eine feste Anzahl von Datensätzen aus einer Datenquelle in eine Dropdown-Liste laden. Dadurch wird die Reaktionsgeschwindigkeit des Formulars beim Ausfüllen verbessert.
Verwandte Themen
Grundlagen zu Ereignissen
Interaktive Ereignisse


prePrint-Ereignis

Beschreibung
Wird unmittelbar vor Beginn der Wiedergabe eines Formulars zum Drucken ausgelöst.
Typ
Anwendungsereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
4
Beispiel
Mit diesem Ereignis können Sie die Präsenz eines Objekts verändern, um zu verhindern, dass es gedruckt wird. Beispielsweise können Sie Texte oder Anweisungen ausblenden, die lediglich beim Ausfüllen des Formulars sichtbar sein sollen.
Verwandte Themen
Grundlagen zu Ereignissen
Anwendungsereignisse


preSave-Ereignis

Beschreibung
Wird unmittelbar vor dem Speichern von Formulardaten im PDF- oder XDP-Format ausgelöst. Dieses Ereignis wird nicht ausgelöst, wenn Sie die Formulardaten oder eine andere Teilmenge des Formulars in das XDP-Format exportieren.
Typ
Anwendungsereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
4
Beispiel
Mit diesem Ereignis können Sie Formulardaten unmittelbar vor dem Speichern der Daten ändern. Beispielsweise können Sie ein Skript für das Ereignis preSave erstellen, welches die Daten überprüft und den Benutzer bei Bedarf über eine Meldung daran erinnert, dass bestimmte erforderliche Felder noch leer sind.
Verwandte Themen
Grundlagen zu Ereignissen
Anwendungsereignisse


preSubmit-Ereignis

Beschreibung
Wird ausgelöst, wenn ein Formular über das HTTP-Protokoll Daten an den Host übergibt. Zu diesem Zeitpunkt sind die Daten bereits in einem Datensatz angeordnet, wurden aber noch nicht an den Host gesendet. Diesem Ereignis zugeordnete Berechnungen und Skripten können die Daten vor der Übergabe des Formulars prüfen und verändern. Wenn die Berechnung oder das Skript für die Ausführung auf dem Server konfiguriert ist, sendet das Formular die Daten mit dem Hinweis zum Server, dass er die Berechnung oder das Skript ausführen soll, bevor eine weitere Verarbeitung der Daten erfolgt.
Dieses Ereignis unterscheidet nicht zwischen Übergaben, die durch Instanzen angeklickter Schaltflächen ausgelöst werden oder die für unterschiedliche URLs vorgesehen sind. Wenn ein Skript Unterscheidungen dieser Art benötigt, muss es entsprechenden Code enthalten, damit ermittelt werden kann, auf welche Schaltfläche geklickt wurde. Das Ereignis preSubmit ist von der Konzeption her mit dem Ereignis preSave vergleichbar und erfüllt einen ähnlichen Zweck.
Typ
Anwendungsereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
4
(Nur für Senden-Schaltflächen)
Beispiel
Mit diesem Ereignis können Sie Formulardaten unmittelbar vor dem Senden der Daten ändern. Beispielsweise können Sie ein Skript für das Ereignis preSubmit erstellen, welches die Datenmenge prüft und den Benutzer über eine Meldung informiert, wie lange die Datenübergabe ungefähr dauern wird.
Verwandte Themen
Grundlagen zu Ereignissen
Anwendungsereignisse
preSave-Ereignis


validate-Ereignis

Beschreibung
Wird initiiert, wenn Formularentwurf und Daten zum Formular zusammengeführt werden und wenn ein Feld den Fokus verliert, z. B. wenn ein Benutzer klickt oder die Tabulatortaste drückt, um ein Feld zu verlassen. Dieses Ereignis wird jedes Mal ausgelöst, wenn sich der Wert eines Feldes ändert. Mit Berechnungen und Skripten, die auf dem Ereignis validate platziert werden, lassen sich Überprüfungen durchführen, die spezifischeren Charakter haben als die über die Registerkarte „Wert“ der Palette „Objekt“ verfügbaren Überprüfungen.
Berechnungen und Skripten für das Ereignis validate müssen true (bei erfolgreicher Validierung) oder false (bei nicht erfolgreicher Validierung) in einem der Skriptsprache entsprechenden Format zurückgeben. Darüber hinaus dürfen sie nicht die Gesamtformularstruktur von Formularwerten beeinträchtigen. Außerdem dürfen Berechnungen und Skripten nicht versuchen, dem Formularbenutzer Rückmeldungen zu liefern, da der Benutzer das Formular möglicherweise nicht in einer Client-Anwendung wie Acrobat verwendet.
Da Überprüfungen am Inhalt des Formulars vorgenommen werden, kann damit die durch Feldmuster vorgegebene Formatierung der Darstellung nicht überprüft werden.
Typ
Prozessereignis
Unterstützung

Client-Anwendung

Verfügbarkeit
Acrobat und Adobe Reader
4
HTML-Browser
4
Beispiel
Mit diesem Ereignis können Sie Objektwerte überprüfen. Es eignet sich insbesondere für Situationen, in denen Objektdaten mit bestimmten Regeln übereinstimmen müssen. Beispielsweise können Sie ein Skript für das Ereignis validate erstellen, um sich zu vergewissern, dass das Feld für die Gesamtkosten in einem Bestellformular keinen negativen Wert enthält.
Verwandte Themen
Grundlagen zu Ereignissen
Prozessereignisse


Skriptsprachen

Unterschiede zwischen FormCalc- und JavaScript-Funktionen
FormCalc verwenden
JavaScript verwenden


Unterschiede zwischen FormCalc- und JavaScript-Funktionen

FormCalc und JavaScript richten sich an zwei unterschiedliche Benutzergruppen, es besteht aber eine gewisse Überschneidung zwischen den jeweiligen integrierten Funktionen. In der folgenden Tabelle sind alle verfügbaren FormCalc-Funktionen zusammengestellt; dabei ist jeweils angegeben, ob JavaScript eine vergleichbare Funktion enthält.

FormCalc-Funktion

Beschreibung

JavaScript-
Entsprechung vorhanden

Abs(n1)
Gibt den Betragswert eines Zahlenwerts oder Ausdrucks zurück.
Ja

Apr(n1, n2, n3)
Gibt die jährliche Gesamtbelastung für einen Kredit zurück.
Nein

At(s1, s2)
Findet die Anfangs-Zeichenposition einer Zeichenfolge innerhalb einer anderen Zeichenfolge.
Ja

Avg(n1 [, n2... ] )
Wertet einen Satz von Zahlenwerten und/oder Ausdrücken aus und gibt den Mittelwert der von null verschiedenen Elemente innerhalb dieses Satzes zurück.
Nein

Ceil(n1)
Gibt die ganze Zahl zurück, die größer oder gleich einer angegebenen Zahl ist.
Ja

Choose(n1, s1 [, s2... ] )
Wählt einen Wert aus einem gegebenen Satz von Parametern.
Nein

Concat(s1 [, s2... ] )
Gibt die Verkettung von zwei oder mehr Zeichenfolgen zurück.
Ja

Count(n1 [, n2...])
Wertet einen Satz von Werten und/oder Ausdrücken aus und gibt die Anzahl der von null verschiedenen Elemente innerhalb dieses Satzes zurück.
Nein

CTerm(n1, n2, n3)
Gibt die Anzahl der Perioden zurück, die erforderlich sind, damit eine Anlage mit einer festen Verzinsung mit Zinseszins auf einen Endwert anwächst.
Nein

Date()
Gibt das aktuelle Systemdatum als Anzahl von Tagen seit Beginn der Epoche zurück.
Ja

Date2Num(d1 [, f1 [, k1 ] ] )
Gibt für eine angegebene Datums-Zeichenfolge die Anzahl der Tage seit Beginn der Epoche zurück.
Nein

DateFmt([ n1 [, k1 ] ] )
Gibt für einen angegebenen Datumsformat-Stil eine Datumsformat-Zeichenfolge zurück.
Nein

Decode(s1 [, s2 ] )
Gibt die dekodierte Version einer angegebenen Zeichenfolge zurück.
Zum Teil unterstützt
JavaScript unterstützt nur URL-kodierte Werte ohne Escape-Zeichen.

Encode(s1 [, s2 ] )
Gibt die kodierte Version einer angegebenen Zeichenfolge zurück.
Zum Teil unterstützt
JavaScript unterstützt nur URL-kodierte Werte ohne Escape-Zeichen.

Eval()
Gibt den Wert einer angegebenen Formularberechnung zurück.
Ja

Exists(v1)
Bestimmt, ob der angegebene Parameter eine gültige Referenz-Syntax zu einem vorhandenen Objekt ist.
Nein

Floor(n1)
Gibt die größte Ganzzahl zurück, die kleiner oder gleich dem angegebenen Wert ist.
Ja

Format(s1, s2)
Formatiert die angegebenen Daten gemäß der angegebenen Musterformat-Zeichenfolge.
Nein

FV(n1, n2, n3)
Gibt den Endwert von Anlagebeträgen zurück, die regelmäßig und in gleich bleibender Höhe bei einem konstanten Zinssatz eingezahlt werden.
Nein

Get(s1)
Lädt den Inhalt der angegebenen URL herunter.
Nein

HasValue(v1)
Ermittelt, ob der angegebene Parameter eine gültige Referenz-Syntax mit einem von null verschiedenen, nicht leeren oder vom Leerzeichen verschiedenen Wert ist.
Nein

IPmt(n1, n2, n3, n4, n5)
Gibt den Zinsbetrag zurück, der in einer bestimmten Zeitspanne für einen Kredit gezahlt wurde.
Nein

IsoDate2Num(d1)
Gibt für eine angegebene gültige Datums-Zeichenfolge die Anzahl der Tage seit Beginn der Epoche zurück.
Nein

IsoTime2Num(d1)
Gibt für eine angegebene gültige Uhrzeit-Zeichenfolge die Anzahl der Millisekunden seit Beginn der Epoche zurück.
Nein

Left(s1, n1)
Extrahiert eine angegebene Anzahl von Zeichen aus einer Zeichenfolge, beginnend beim ersten Zeichen auf der linken Seite.
Ja

Len(s1)
Gibt die Anzahl der Zeichen in einer angegebenen Zeichenfolge zurück.
Ja

LocalDateFmt( [ n1 [, k1 ] ] )
Gibt eine lokalisierte Datumsformat-Zeichenfolge mit dem angegebenen Datumsformat-Stil zurück.
Nein

LocalTimeFmt( [ n1 [, k1 ] ] )
Gibt eine lokalisierte Uhrzeitformat-Zeichenfolge mit dem angegebenen Uhrzeitformat-Stil zurück.
Nein

Lower(s1 [, k1 ] )
Wandelt alle Großbuchstaben in einer angegebenen Zeichenfolge in Kleinbuchstaben um.
Nein

Ltrim(s1)
Gibt eine Zeichenfolge zurück, bei der alle Leerraum-Zeichen am Anfang entfernt wurden.
Nein

Max(n1 [, n2... ] )
Gibt den Maximalwert der von null verschiedenen Elemente im angegebenen Satz von Zahlen zurück.
Nein

Min(n1 [, n2... ] )
Gibt den Minimalwert der von null verschiedenen Elemente im angegebenen Satz von Zahlen zurück.
Nein

Mod(n1, n2)
Gibt den Modulus der Division einer Zahl durch eine andere zurück.
Nein

NPV(n1, n2 [, ... ] )
Gibt den Kapitalwert einer Anlage auf der Grundlage eines Diskontsatzes und einer Folge von zukünftigen periodischen Cashflows zurück.
Nein

Num2Date(n1[, f1 [, k1 ] ] )
Gibt für eine angegebene Anzahl von Tagen seit Beginn der Epoche eine Datums-Zeichenfolge zurück.
Nein

Num2GMTime(n1 [,f1 [, k1 ] ] )
Gibt für eine angegebene Anzahl von Millisekunden seit Beginn der Epoche eine GMT-Uhrzeit-Zeichenfolge zurück.
Nein

Num2Time(n1 [,f1 [, k1 ] ] )
Gibt für eine angegebene Anzahl von Millisekunden seit Beginn der Epoche eine Uhrzeit-Zeichenfolge zurück.
Nein

Oneof(s1, s2 [, s3... ] )
Gibt TRUE (1) zurück, wenn sich ein Wert in einem angegebenen Satz befindet, bzw. FALSE (0), wenn dies nicht der Fall ist.
Ja

Parse(s1, s2)
Analysiert die angegebenen Daten gemäß dem angegebenen Musterformat.
Nein

Pmt(n1, n2, n3)
Gibt die Höhe des Rückzahlungsbetrags für einen Kredit bei konstanten Zahlungsbeträgen und konstantem Zinssatz zurück.
Nein

Post(s1, s2 [, s3 [, s4 [, s5 ] ] ] )
Sendet die angegebenen Daten an die genannte URL.
Nein

PPmt(n1, n2, n3, n4, n5)
Gibt den Tilgungsbetrag zurück, der in einer bestimmten Zeitspanne für einen Kredit gezahlt wurde.
Nein

Put(s1, s2 [, s3 ] )
Lädt die angegebenen Daten zu der genannten URL hoch.
Nein

PV(n1, n2, n3)
Gibt den Gegenwartswert einer Anlage mit regelmäßigen konstanten Einzahlungen und konstantem Zinssatz zurück.
Nein

Rate(n1, n2, n3)
Gibt den Zinssatz pro Verzinsungsperiode zurück, der benötigt wird, damit eine Anlage mit Zinseszins in einem gegebenen Zeitraum von einem gegebenen Gegenwartswert auf einen Endwert anwächst.
Nein

Ref()
Gibt eine Referenz auf ein vorhandenes Objekt zurück.
Ja

Replace(s1, s2 [, s3 ] )
Ersetzt innerhalb einer angegebenen Zeichenfolge alle Fundstellen einer Zeichenfolge durch eine andere.
Ja

Right(s1, n1)
Extrahiert mehrere Zeichen aus einer angegebenen Zeichenfolge, beginnend beim letzten Zeichen auf der rechten Seite.
Ja

Round(n1 [, n2 ] )
Wertet einen angegebenen Zahlenwert oder Ausdruck aus und gibt eine auf die angegebene Anzahl von Dezimalstellen gerundete Zahl zurück.
Ja

Rtrim(s1)
Gibt eine Zeichenfolge zurück, bei der alle Leerraum-Zeichen am Ende entfernt wurden.
Nein

Space(n1)
Gibt eine Zeichenfolge zurück, die aus einer angegebenen Anzahl von Leerzeichen besteht.
Nein

Str(n1 [, n2 [, n3 ] ] )
Wandelt eine Zahl in eine Zeichenfolge um. FormCalc formatiert das Ergebnis auf die angegebene Breite und rundet auf die angegebene Zahl von Dezimalstellen.
Nein

Stuff(s1, n1, n2 [, s2 ] )
Fügt eine Zeichenfolge in eine andere Zeichenfolge ein.
Nein

Substr(s1, n1, n2)
Extrahiert einen Abschnitt aus einer angegebenen Zeichenfolge.
Ja

Sum(n1 [, n2... ] )
Gibt die Summe der von null verschiedenen Elemente eines gegebenen Satzes von Zahlen zurück.
Nein

Term(n1, n2, n3)
Gibt die Anzahl der Perioden zurück, die erforderlich sind, um mit konstanten periodischen Einzahlungen auf ein verzinstes Konto einen angegebenen Endwert zu erzielen.
Nein

Time()
Gibt die aktuelle Systemuhrzeit als Anzahl von Millisekunden seit Beginn der Epoche zurück.
Ja

Time2Num(d1 [, f1 [, k1 ] ] )
Gibt für eine angegebene Uhrzeit-Zeichenfolge die Anzahl der Millisekunden seit Beginn der Epoche zurück.
Nein

TimeFmt([n1 [, k1 ] ] )
Gibt ein Uhrzeitformat in einem angegebenen Uhrzeitformat-Stil zurück.
Nein

UnitType(s1)
Gibt die Einheit einer Maßangabe zurück. Eine Maßangabe ist eine Zeichenfolge, die aus einer Zahl und einer nachfolgenden Einheitenbezeichnung besteht.
Nein

UnitValue(s1 [, s2 ] )
Gibt den Zahlenwert einer Messung mit ihrer zugeordneten Maßangabe nach einer optionalen Einheitenumwandlung zurück.
Nein

Upper(s1 [, k1 ] )
Wandelt alle Kleinbuchstaben in einer angegebenen Zeichenfolge in Großbuchstaben um.
Nein

Uuid(n1)
Gibt eine UUID-Zeichenfolge (Universally Unique Identifier) zurück, die als Kennzeichnungsmethode verwendet werden soll.

Within(s1, s2, s3)
Gibt TRUE (1) zurück, wenn der geprüfte Wert innerhalb eines angegebenen Bereichs liegt, bzw. FALSE (0), wenn dies nicht der Fall ist.
Ja

WordNum(n1 [, n2 [, k1 ] ] )
Gibt die englischsprachige Textentsprechung einer angegebenen Zahl zurück.
Nein
Verwandte Themen
Grundlagen zu FormCalc
Einführung in FormCalc


FormCalc verwenden

Grundlagen zu FormCalc
Integrierte Funktionen verwenden
So fügen Sie einem Objekt eine FormCalc-Funktion hinzu
Integrierte Funktionssyntax
Basisberechnungen erstellen


Grundlagen zu FormCalc

FormCalc ist eine einfache, aber leistungsfähige Berechnungssprache, die nach dem Vorbild allgemein gebräuchlicher Tabellenkalkulations-Software entwickelt wurde. Diese Sprache soll die schnelle, effiziente Gestaltung von Formularen ohne Kenntnis konventioneller Skripterstellungstechniken oder Skriptsprachen ermöglichen. Benutzer, die FormCalc noch nicht kennen, können mit Hilfe von wenigen integrierten Funktionen in kurzer Zeit Formulare erstellen, welche den Endbenutzern zeitaufwendige Berechnungen, Kontrollen und andere Überprüfungsmaßnahmen abnehmen. Sie haben also die Möglichkeit, für den Formularentwurf einen Satz Grundregeln aufzustellen, anhand dessen das resultierende Formular auf die Daten reagieren kann, mit denen es in Berührung kommt.
Bei LiveCycle Designer ist FormCalc die Standard-Skriptsprache, die überall zum Einsatz kommt, wo Skripten erstellt werden; alternativ wird JavaScript eingesetzt. Informationen zur Festlegung der Standard-Skriptsprache finden Sie unter Der Skript-Editor.
Wenn Sie Formulare für die Nutzung in einem serverbasierten Prozess erstellen (z. B. mit LiveCycle Forms) und vorhaben, diese Formulare in HTML wiederzugeben, sollten Sie Ihre Berechnungen und Skripten in JavaScript entwickeln. FormCalc-Berechnungen sind in HTML-Browsern nicht gültig und werden vor der Wiedergabe in HTML aus dem Formular entfernt.
FormCalc behandelt jede neue Zeile im Skript-Editor als neu auszuwertenden Ausdruck.
Verwandte Themen
Grundlagen zu FormCalc
Grundlagen zu JavaScript


Integrierte Funktionen verwenden

Die integrierten Funktionen, aus denen sich FormCalc zusammensetzt, decken eine umfangreiche Palette von Bereichen ab: Mathematik, Datum und Uhrzeit, Zeichenfolgen, Finanzen, Logik und Internet. Diese Bereiche entsprechen den Funktionalitätsarten, die in Formularen üblicherweise genutzt werden. Die Funktionen sollen eine schnelle und einfache Bearbeitung von Formulardaten auf zweckmäßige Weise ermöglichen.
Auf der elementarsten Ebene kann eine Berechnung aus einer einzelnen FormCalc-Funktion bestehen. Diese einzelne FormCalc-Funktion kann aber weitere FormCalc-Funktionen als Parameter nutzen.
Verwandte Themen
Einführung in FormCalc


So fügen Sie einem Objekt eine FormCalc-Funktion hinzu

Mit Ausnahme des Skriptobjekts können Sie jedem Formularentwurfsobjekt, das Berechnungen und Skripten zulässt, eine FormCalc-Funktion hinzufügen.
1.
Achten Sie darauf, dass im LiveCycle Designer-Arbeitsbereich die mehrzeilige Version des Skript-Editors angezeigt wird.
2.
Wählen Sie ein Feld in Ihrem Formular aus.
3.
Wählen Sie in der Liste „Anzeigen“ das Ereignis „calculate“.
4.
Klicken Sie auf „Funktionen“ [image] oder drücken Sie die F10-Taste, um eine Liste der FormCalc-Funktionen einzublenden.
5.
Wählen Sie die gewünschte Funktion und drücken Sie die Eingabetaste.
6.
Ersetzen Sie die Standardnotation der Funktionssyntax durch Ihre eigenen Werte.
7.
Klicken Sie auf „Änderungen zu Skriptquelle eingeben“ [image], um die FormCalc-Berechnungen in Ihr Formular einzufügen.


Integrierte Funktionssyntax

Jede FormCalc-Funktion verwendet eine bestimmte Syntax-Notation, die Sie einhalten müssen, damit die Funktion richtig ausgeführt wird. In der folgenden Tabelle werden die Elemente der Syntax-Notation in sehr allgemeiner Form beschrieben.

Syntax-Notation

Ersetzungswerte

d
Eine gültige Datums-Zeichenfolge (Beispiel: 03/15/1996)

f
Eine gültige Datumsformat-Zeichenfolge (Beispiel: MM/DD/YYYY)

k
Eine gültige Gebietsschema-Kennung (Beispiel: fr_FR)

n
Ein gültiger Zahlenwert. Beachten Sie, dass der Bereich der gültigen Werte je nach Funktion unterschiedlich ist.

s
Eine gültige Maßeinheit (Beispiel: „in“ für „inches“ [Zoll]).

v
Eine gültige Referenz-Syntax.

n1, n2, n3
Alle Werte sind obligatorisch.

[ [ n [, k ] ] ]
Keiner der Werte ist obligatorisch, Sie können aber fakultativ entweder nur n oder sowohl n als auch k angeben.

n1 [, n2 ... ]
n1 ist obligatorisch, Sie können aber fakultativ beliebig viele weitere Werte angeben.

d [, f [, k ] ]
d ist obligatorisch, Sie können aber fakultativ entweder f oder sowohl f als auch k angeben.


Basisberechnungen erstellen

Grundlagen zu Basisberechnungen
Einfache Ausdrücke sind die elementarsten Elemente in der Skripterstellung. Diese Ausdrücke verwenden keine integrierten Funktionen von FormCalc und sind niemals länger als eine Zeile. Sie müssen einfache Ausdrücke dem calculate-Ereignis eines bestimmten Feldes oder Objekts hinzufügen, damit der Wert des Ausdrucks auf dem Formular ausgegeben wird.
Beispiele für Basisberechnungen
Die folgenden Beispiele zeigen einfache Ausdrücke:
2
"abc"
2 - 3 * 10 / 2 + 7
Jeder einfache Ausdruck wird zu einem einzelnen Wert ausgewertet. Dabei gilt die konventionelle Reihenfolge der Operationen, auch wenn diese Reihenfolge aus der Syntax der Ausdrücke nicht immer offensichtlich ist. Beispielsweise liefern die folgenden Gruppen von Ausdrücken jeweils das gleiche Ergebnis:

Ausdruck

Entspricht

Ergebnis

"abc"

"abc"

abc

2 - 3 * 10 / 2 + 7

2 - (3 * 10 / 2) + 7

-6

(10 + 2) * (5 + 4)

(10 + 2) * (5 + 4)

108

0 and 1 or 2 > 1

(0 and 1) or (2 >1)
1 (TRUE)

2 < 3 not 1 == 1

(2 < 3) not (1 == 1)
0 (FALSE)
Alle oben aufgeführten Beispiele sind gültige einfache Ausdrücke, die Sie in ein Formularfeld oder Objekt einfügen können, das Berechnungen und Skripten akzeptiert. Angenommen, Sie erstellen in LiveCycle Designer ein neues Formular mit einem einzelnen numerischen Feld und fügen dem calculate-Ereignis im Skript-Editor die folgende Berechnung hinzu:
Wenn Sie anschließend die Registerkarte „PDF-Vorschau“ wählen, um sich das ausgefüllte Formular anzusehen, erscheint in dem Textfeld der Wert des einfachen Ausdrucks.
Falls der Wert in der PDF-Vorschau nicht angezeigt wird, vergewissern Sie sich, dass der einfache Ausdruck im calculate-Ereignis des Formularentwurfsobjekts erscheint. Außerdem sollten Sie überprüfen, ob Sie LiveCycle Designer und Acrobat richtig installiert haben.


JavaScript verwenden

Grundlagen zu JavaScript
Skripten mit JavaScript erstellen
So fügen Sie einem Objekt ein JavaScript-Skript hinzu


Grundlagen zu JavaScript

Um Formulardesignern mehr Flexibilität und Skripterstellungsmöglichkeiten bieten zu können, unterstützt LiveCycle Designer die Verwendung von JavaScript (Version 1.6 oder früher) in allen Situationen, in denen Skripterstellung möglich ist.
Formulardesigner, die mit JavaScript vertraut sind, können ihr vorhandenes Wissen direkt auf LiveCycle Designer übertragen. LiveCycle Designer stellt zahlreiche Eigenschaften und Methoden zur Verfügung, die JavaScript so erweitern, dass Sie damit auf Feld- und Objektwerte zugreifen können. Diese Eigenschaften und Methoden ermöglichen Ihnen in Verbindung mit der Referenz-Syntax von LiveCycle Designer eine einfache Manipulation von Formularwerten und -daten.
Im Skript-Editor gibt es für Skripten, die mit JavaScript erstellt wurden, keine Möglichkeit zur Überprüfung der Syntax auf Fehler.
Verwandte Themen
Skripten mit JavaScript erstellen


Skripten mit JavaScript erstellen

Die Skripterstellung in LiveCycle Designer mit JavaScript ist der JavaScript-Erstellung in anderen Anwendungen sehr ähnlich. Sie können Ihre Vorkenntnisse von JavaScript-Konzepten anwenden, JavaScript-Funktionen mit dem LiveCycle Designer-Skriptobjekt wiederverwerten und die JavaScript-Sprachfunktionalität nutzen.
Dabei ist zu beachten, dass sich JavaScript-Vorkenntnisse zwar übertragen lassen, Sie jedoch auch wissen müssen, wie in LiveCycle Designer eine Referenz-Syntax aufgebaut wird, damit Sie JavaScript in Ihren Formularentwürfen effektiv anwenden können. Insbesondere müssen Sie wissen, wie Sie die Referenz-Syntax korrekt einsetzen, um im Formularentwurf auf Objekte zuzugreifen.
In der folgenden Tabelle werden die Hauptkonzepte zum Entwickeln von Skripten in JavaScript für LiveCycle Designer erklärt. Darüber hinaus erfahren Sie, wo Sie weitere Informationen zu jedem Konzept in der <Italic>LiveCycle Designer-Hilfe finden können.

Hauptkonzept

Weitere Informationsquellen
Erstellen von Referenzen zu Objekteigenschaften und -werten, einschließlich der Verwendung der Methode resolveNode
Objekteigenschaften und -werte referenzieren
resolveNode
So erstellen Sie Berechnungen und Skripten mit dem Anweisungsende
Verwenden der Host- und Ereignismodelle zum Testen und Debugging von Formularen
Berechnungen und Skripten testen und debuggen
Objekteigenschaften und -werte referenzieren
Verwenden des Skriptobjekts zur Wiederverwendung existierender JavaScript-Funktionen
Das Skriptobjekt
Zusätzlich zu den Informationen in der <Italic>LiveCycle Designer-Hilfe finden Sie umfangreiche Ressourcen und Dokumente zur Skripterstellung im LiveCycle Developer Center. Sie finden das Developer Center unter www.adobe.com/devnet/livecycle/.
Verwandte Themen
Grundlagen zu JavaScript


So fügen Sie einem Objekt ein JavaScript-Skript hinzu

Sie können jedem Formularentwurfsobjekt, das Berechnungen und Skripten zulässt, ein JavaScript-Skript hinzufügen. Dies gilt auch für das Skriptobjekt.
1.
Achten Sie darauf, dass im LiveCycle Designer-Arbeitsbereich die mehrzeilige Version des Skript-Editors angezeigt wird.
2.
Wählen Sie ein Feld in Ihrem Formular aus.
3.
Wählen Sie in der Liste „Anzeigen“ ein gültiges Ereignis.
4.
Klicken Sie auf „Funktionen“ [image] oder drücken Sie die F10-Taste, um eine Liste der JavaScript-Funktionen einzublenden. Wählen Sie die gewünschte Funktion und drücken Sie die Eingabetaste. Ersetzen Sie die Standardnotation der Funktionssyntax durch Ihre eigenen Werte. Alternativ können Sie im Skript-Editor im Feld „Skriptquelle“ ein Skript manuell eingeben.
5.
Klicken Sie auf „Änderungen zu Skriptquelle eingeben“ [image], um das JavaScript-Skript in Ihr Formular einzufügen.
Verwandte Themen
Grundlagen zu JavaScript


Objekte in Berechnungen und Skripten referenzieren

Grundlagen zum Referenzieren von Objekten in Berechnungen und Skripten
Objekteigenschaften und -werte referenzieren
Unbenannte und wiederholte Objekte referenzieren
Aktuelles Objekt referenzieren
Referenz-Syntax-Kurzbefehle für FormCalc


Grundlagen zum Referenzieren von Objekten in Berechnungen und Skripten

FormCalc-Berechnungen und JavaScript-Skripten unterliegen bei der Strukturierung von Code zwar jeweils spezifischen Regeln, aber wenn es um den Zugriff auf Formularobjekteigenschaften und -werte geht, stützen sie sich auf die gleiche Referenz-Syntax. Das XML Form Object Model bietet über eine Namenskonvention, bei der alle Objekte, Eigenschaften und Methoden jeweils durch ein Punktzeichen (.) voneinander getrennt sind, eine strukturierte Möglichkeit, auf Objekteigenschaften und -werte zuzugreifen.
Jede Referenz-Syntax weist in der Regel eine in drei Abschnitte unterteilte Struktur auf:
      •
      Der erste Abschnitt enthält die Namen der Objekte in der Formularhierarchie und dient zur Navigation zu einem bestimmten Feld oder Objekt. Mit den beiden Paletten „Hierarchie“ und „Datenansicht“ können Sie die Position eines Objekts im Verhältnis zu anderen Objekten im Formular und in zugehörigen Daten ermitteln.
      •
      Der zweite Abschnitt ist der Name des Objekts, das Sie referenzieren möchten.
      •
      Der dritte Abschnitt ist der Name der Eigenschaft oder Methode, auf die Sie zugreifen möchten. Dieser Abschnitt enthält möglicherweise auch Objekte des XML Form Object Model, die in der Struktur vor der Eigenschaft oder Methode auftreten, aber in der Palette „Hierarchie“ nicht als Objekte aufgeführt werden.
In der folgenden Abbildung sehen Sie die Referenz-Syntax für den Zugriff auf den Wert eines Textfelds in einem Formularentwurf. Dabei gelten die folgenden Konventionen für die Objektbenennung:
Das Teilformularobjekt, welches die erste Seite eines neuen Formulars darstellt, ist standardmäßig unbenannt. In der obigen Referenz-Syntax wird das unbenannte Teilformular als #subform bezeichnet.
Die Notationsstruktur der Referenz-Syntax hängt immer von der spezifischen Situation ab. Beispielsweise ist eine vollständig qualifizierte Referenz-Syntax für alle Situationen geeignet. In einigen Fällen können Sie die Syntax aber durch eine verkürzte Referenz-Syntax oder einen Referenz-Syntax-Kurzbefehl etwas übersichtlicher gestalten.
Verwandte Themen
Objekteigenschaften und -werte referenzieren
Unbenannte und wiederholte Objekte referenzieren
Aktuelles Objekt referenzieren
Referenz-Syntax-Kurzbefehle für FormCalc


Objekteigenschaften und -werte referenzieren

Für die Referenz-Syntax, über die Sie auf Objekteigenschaften und -werte zugreifen bzw. diese ändern, stehen zwei Varianten zur Auswahl:
Vollständig qualifiziert
Die Referenz-Syntax enthält die gesamte Objekthierarchie, angefangen mit dem Stammknoten xfa. Die vollständig qualifizierte Syntax greift präzise auf die Eigenschaft oder den Wert eines Objekts zu, unabhängig davon, wo sich die Berechnung oder das Skript befindet, die bzw. das die Referenz-Syntax enthält.
Abgekürzt
Die Referenz-Syntax ist entweder wegen der relativen Position der Berechnung oder des Skripts, die bzw. das die Referenz-Syntax und die Objektsyntaxreferenzen enthält, abgekürzt, oder weil Kurzbefehle verwendet werden. Eine abgekürzte Referenz-Syntax lässt sich zwar schneller erstellen, sie hat aber auch den Nachteil, dass sie nur so lange funktioniert, wie die Position der Objekte im Verhältnis zueinander unverändert bleibt.
In der folgenden Abbildung wird die Hierarchie eines Musterbestellformulars dargestellt.
Die Abbildung zeigt eine vollständig qualifizierte Referenz-Syntax für FormCalc und JavaScript, die zum Zugriff auf den Wert des Feldes txtCondition dient. Diese Referenz-Syntax könnte als Teil einer Berechnung oder eines Skriptes für ein beliebiges Objekt des Formulars eingesetzt werden.
Obwohl die Referenz-Syntax sowohl von FormCalc als auch von JavaScript verwendet wird, müssen Sie die für die beiden Skriptsprachen geltenden Konventionen beachten. Beispielsweise kann die im obigen Beispiel angegebene Referenz-Syntax ohne Änderungen in FormCalc eingesetzt werden; für JavaScript müssten Sie aber ein Semikolon (;) am Ende einfügen.
Wenn sich zwei Objekte in demselben Container befinden, z. B. in einem Teilformular, haben sie denselben Kontext. Wenn Objekte in demselben Kontext vorkommen, können Sie eine abgekürzte Referenz-Syntax verwenden, die sich nur aus dem Namen des Objekts gefolgt von der Eigenschaft oder Methode, auf die Sie zugreifen möchten, zusammensetzt. Beim obigen Beispiel würde die folgende abgekürzte Referenz-Syntax auf den Wert des Feldes txtCondition in allen Feldern des Teilformulars total zugreifen:
    txtCondition.rawValue
Wenn sich zwei Objekte in unterschiedlichen Containern befinden, haben sie nicht denselben Kontext. In diesem Fall können Sie zwar ein abgekürzte Referenz-Syntax verwenden, aber die Syntax muss mit dem Namen des obersten Container-Objekts beginnen, welches die beiden Objekte nicht gemein haben. Bei der obigen Hierarchie würde die folgende abgekürzte Referenz-Syntax auf den Wert des Feldes address vom Feld txtCondition aus zugreifen:
    header.address.rawValue
Auf Grund der Struktur des XML Form Object Model treten einige Objekteigenschaften und -methoden bei untergeordneten Objekten der Objekte im Formular auf. Diese untergeordneten Objekte existieren nur als Teil des XML Form Object Model und kommen nicht in den beiden Paletten „Hierarchie“ und „Datenansicht“ vor. Wenn Sie auf diese Eigenschaften und Methoden zugreifen möchten, müssen Sie die untergeordneten Objekte in die Referenz-Syntax einschließen. Beispielsweise wird über die folgende Referenz-Syntax die QuickInfo für das Feld txtCondition festgelegt:
    txtCondition.assist.toolTip.value = "Verkaufsbedingungen."  // FormCalc
    txtCondition.assist.toolTip.value = "Verkaufsbedingungen."; // JavaScript
Weitere Informationen zu den Objekten und zur Objektstruktur des XML Form Object Model finden Sie unter Skript-Referenz.
Verwandte Themen
Grundlagen zum Referenzieren von Objekten in Berechnungen und Skripten
Unbenannte und wiederholte Objekte referenzieren
Aktuelles Objekt referenzieren
Referenz-Syntax-Kurzbefehle für FormCalc


Unbenannte und wiederholte Objekte referenzieren

In LiveCycle Designer können Sie sowohl unbenannte Objekte als auch mehrere gleichnamige Objekte erstellen. Ferner können Sie Berechnungen und Skripten erstellen, die mit Hilfe des Nummernzeichens (#) auf Eigenschaften und Werte unbenannter Objekte zugreifen bzw. diese ändern oder die mit Hilfe der eckigen Klammer ([ ]) auf Vorkommenswerte von Objekten zugreifen. Das Nummernzeichen (#) und die eckige Klammer ([ ]) werden von FormCalc korrekt ausgewertet. JavaScript ist hierzu nicht in der Lage. Wenn Sie mit JavaScript auf den Wert eines Textfelds in einer Situation zugreifen möchten, in welcher das Nummernzeichen (#) oder die eckige Klammer ([ ]) auftritt, müssen Sie die Methode resolveNode mit einer vollständig qualifizierten oder einer abgekürzten Referenz-Syntax kombinieren.
Wenn Sie beispielsweise ein neues, leeres Formular erstellen, ist der Name des Teilformulars, welches die Seite des Formulars darstellt, standardmäßig ein unbenanntes Teilformular mit dem Vorkommenswert 0. In der folgenden Abbildung sehen Sie die Formularhierarchie bei einem neuen Formular mit standardmäßiger Objektbenennung.
Das unbenannte Teilformular, welches die erste Seite des Formulars darstellt, hat die Vorkommensnummer 0. In dieser Situation greifen die beiden folgenden Referenz-Syntaxen auf den Wert des Textfelds zu, das in der Formularhierarchie über einem neuen Formular liegt und für das standardmäßige Namenskonventionen gelten:
    xfa.form.form1.#subform.TextField1.rawValue
    xfa.form.form1.#subform[0].TextField1.rawValue
Wenn für ein Objekt kein Vorkommenswert angegeben wurde, greift die Referenz-Syntax standardmäßig auf das erste Vorkommen dieses Objekts zu.
FormCalc erkennt die oben angegebene vollständig qualifizierte Referenz-Syntax und wertet sie korrekt aus. Wenn Sie mit JavaScript auf denselben Wert zugreifen möchten, müssen Sie eine der folgenden Varianten der Skriptmethode resolveNode verwenden:
    xfa.resolveNode("xfa.form.form1.#subform.TextField1").rawValue;
    xfa.resolveNode("xfa.form.form1.#subform[0].TextField1").rawValue;
Wenn Sie einem Formular eine neue Seite hinzufügen, ist das Teilformular, welches die neue Seite darstellt, standardmäßig unbenannt. Der Vorkommenswert des neuen Teilformulars wird allerdings auf 1 eingestellt. Sie können das neue unbenannte Teilformular mit einer ähnlichen Referenz-Syntax wie der obigen angeben:
    xfa.form.form1.#subform[1].TextField1.rawValue // FormCalc
    xfa.resolveNode("xfa.form.form1.#subform[1].TextField1").rawValue; // JavaScript
Zu den im Skript-Editor verfügbaren Anweisungsende-Optionen gehören unbenannte Objekte am Anfang der Liste. Objekte mit mehreren Vorkommenswerten werden in der Liste nur einmal aufgeführt. Der Listeneintrag bezieht sich auf das erste Vorkommen des Objekts. Wenn Sie anstelle des ersten Vorkommenswerts einen anderen Vorkommenswert abrufen möchten, müssen Sie diesen Wert manuell der Referenz-Syntax hinzufügen.
Mit der Methode resolveNode können Sie Objekte innerhalb anderer Referenz-Syntax-Anweisungen referenzieren. Dadurch kann der Skripterstellungsaufwand, der zum Referenzieren eines bestimmten Objekts, einer bestimmten Eigenschaft oder einer bestimmten Methode erforderlich ist, erheblich reduziert werden. Beispielsweise ließe sich die Referenz-Syntax, die auf ein Textfeld auf der zweiten Formularseite verweist, auf die folgende Anweisung kürzen:
    xfa.form.form1.resolveNode("#subform[1].TextField1").rawValue; // JavaScript
Weitere Informationen zur Methode resolveNode finden Sie unter resolveNode.
Verwandte Themen
Grundlagen zum Referenzieren von Objekten in Berechnungen und Skripten
Objekteigenschaften und -werte referenzieren
Aktuelles Objekt referenzieren
Referenz-Syntax-Kurzbefehle für FormCalc


Aktuelles Objekt referenzieren

Wenn Sie die Eigenschaften oder Werte des aktuellen Objekts mit Hilfe von Berechnungen oder Skripten ändern möchten, die an das Objekt selbst angehängt sind, bieten sowohl FormCalc als auch JavaScript eindeutige Kurzbefehle, mit denen sich der Umfang der Referenz-Syntax verringern lässt. In FormCalc wird das aktuelle Objekt mit dem Dollarzeichen ($) bezeichnet. JavaScript verwendet hierzu das Schlüsselwort this.
Beispielsweise gibt die folgende Referenz-Syntax den Wert des aktuellen Objekts zurück:
    $ // FormCalc
    this.rawValue // JavaScript
Mit dem Dollarzeichen ($) und dem Schlüsselwort this können Sie den Namen des aktuellen Objekts beim Zugriff auf Objekteigenschaften in Berechnungen und Skripten ersetzen. Beispielsweise wird über die folgende Referenz-Syntax die mit dem aktuellen Objekt verbundene QuickInfo ersetzt:
    $.assist.toolTip.value = "QuickInfo-Text"     // FormCalc
    this.assist.toolTip.value = "QuickInfo-Text"; // JavaScript
Verwandte Themen
Grundlagen zum Referenzieren von Objekten in Berechnungen und Skripten
Objekteigenschaften und -werte referenzieren
Unbenannte und wiederholte Objekte referenzieren
Referenz-Syntax-Kurzbefehle für FormCalc


Referenz-Syntax-Kurzbefehle für FormCalc

Mit Hilfe einer Reihe von Kurzbefehlen lassen sich Referenzen in FormCalc bequemer erstellen, wodurch der Zugriff auf Objekteigenschaften und -werte erleichtert wird. Die folgende Tabelle bietet einen Überblick über die für FormCalc verfügbaren Referenz-Syntax-Kurzbefehle.

Notation

Beschreibung
$
Bezeichnet das aktuelle Feld oder Objekt. Beispiel:
    $ = "Tony Blue"
Das obige Beispiel setzt den Wert des aktuellen Feldes oder Objekts auf Tony Blue.
$data
Bezeichnet den Stammknoten des Datenmodells xfa.datasets.data. Beispiel:
    $data.purchaseOrder.total
entspricht
    xfa.datasets.data.purchaseOrder.total
$event
Bezeichnet das aktuelle Formularobjekt-Ereignis. Beispiel:
    $event.name
entspricht
    xfa.event.name
Weitere Informationen finden Sie unter Grundlagen zum Ereignismodell.
$form
Bezeichnet den Stammknoten des Formularmodells xfa.form. Beispiel:
    $form.purchaseOrder.tax
entspricht
    xfa.form.purchaseOrder.tax
$host
Bezeichnet das Host-Objekt. Beispiel:
    $host.messageBox("Hello world")
entspricht
    xfa.host.messageBox("Hello world")
Weitere Informationen finden Sie unter Grundlagen zum Arbeiten mit Host-Anwendungen.
$layout
Bezeichnet den Stammknoten des Layoutmodells xfa.layout. Beispiel:
    $layout.ready
entspricht
    xfa.layout.ready
$record
Bezeichnet den aktuellen Datensatz aus einer Zusammenstellung von Daten, z. B. aus einer XML-Datei. Beispiel:
    $record.header.txtOrderedByCity
referenziert den Knoten txtOrderedByCity im Knoten header der aktuellen XML-Daten.
$template
Bezeichnet den Stammknoten des Vorlagenmodells xfa.template. Beispiel:
    $template.purchaseOrder.item
entspricht
    xfa.template.purchaseOrder.item
!
Bezeichnet den Stammknoten des Datenmodells xfa.datasets. Beispiel:
    !data
entspricht
    xfa.datasets.data
*
Wählt alle Formularobjekte innerhalb eines gegebenen Containers, z. B. in einem Teilformular, unabhängig von ihrem Namen bzw. alle Objekte mit einem ähnlichen Namen aus.
Beispielsweise wählt der folgende Ausdruck alle Objekte namens item in einem Formular aus:
    xfa.form.form1.item[*]
..
Sie können an jeder Stelle in Ihrer Referenz-Syntax zwei Punkte einsetzen, um nach Objekten zu suchen, die Teil eines Unter-Containers des aktuellen Container-Objekts (z. B. eines Teilformulars) sind. Beispielsweise bedeutet der Ausdruck Subform_Page..Subform2: Knoten Subform_Page lokalisieren (wie üblich) und einen Subform_Page untergeordneten Knoten namens Subform2 suchen.
Aus dem obigen Beispiel-Baumdiagramm ergibt sich:
    Subform_Page..TextField2
entspricht
    Subform_Page.Subform1[0].Subform3.TextField2[0]
da sich TextField2[0] im ersten Subform1-Knoten befindet, auf den FormCalc bei der Suche stößt. Ein zweites Beispiel:
    Subform_Page..Subform3[*]
gibt alle vier Instanzen des Objekts TextField2 zurück.
#
Das Nummernzeichen (#) dient zur Bezeichnung eines der folgenden Elemente in einer Referenz-Syntax:
      •
      Ein unbenanntes Objekt. Beispielsweise greift die folgende Referenz-Syntax auf ein unbenanntes Teilformular zu:

        xfa.form.form1.#subform
      •
      Geben Sie in einer Referenz-Syntax eine Eigenschaft an, wenn eine Eigenschaft und ein Objekt den gleichen Namen tragen. Beispielsweise greift die folgende Referenz-Syntax auf die Eigenschaft name eines Teilformulars zu, wenn das Teilformular auch ein Feld namens name hat:

        xfa.form.form1.#subform.#name
[ ]
Die eckige Klammer ([ ]) gibt den Vorkommenswert eines Objekts an. Um eine Referenz mit einem solchen Wert zu erstellen, setzen Sie eckige Klammern ([ ]) hinter einen Objektnamen und fügen Sie zwischen den eckigen Klammern einen der folgenden Werte ein:
      •
      [ n ], wobei n eine absolute Vorkommens-Indexnummer ist (der Index beginnt bei 0). Wenn eine Vorkommensnummer außerhalb des zulässigen Bereichs liegt, wird ein Fehler zurückgegeben. Beispiel:

        xfa.form.form1.#subform.Quantity[3]
        refers to the fourth occurrence of the Quantity object.
      •
      [ +/- n ], wobei n ein Vorkommen relativ zum Vorkommen des Objekts angibt, von welchem die Referenz ausgeht. Positive Werte liefern höhere Vorkommensnummern und negative Werte liefern niedrigere. Beispiel:

         xfa.form.form1.#subform.Quantity[+2]

      Diese Referenz liefert das Vorkommen von Quantity, dessen Vorkommensnummer um 2 höher ist als die Vorkommensnummer des Containers, von welchem die Referenz ausgeht. Stünde diese Referenz beispielsweise mit dem Objekt Quantity[2] in Verbindung, so wäre sie gleichbedeutend mit:

         xfa.template.Quantity[4]

      Wenn die berechnete Indexnummer außerhalb des zulässigen Bereichs liegt, gibt die Referenz einen Fehler zurück.

      Die häufigste Anwendung dieser Syntax ist die Ansteuerung des vorigen oder nächsten Vorkommens eines bestimmten Objekts. Beispielsweise könnte man bei jedem Vorkommen des Objekts Quantity (außer beim ersten) mit Quantity[-1] den Wert des vorigen Quantity-Objekts abrufen.
      •
      [*] gibt mehrere Vorkommen eines Objekts an. Das erste benannte Objekt wird gefunden und die mit dem ersten Objekt verwandten Objekte desselben Namens werden zurückgegeben. Beachten Sie, dass bei dieser Notation eine Zusammenstellung von mehreren Objekten zurückgegeben wird. Beispiel:

         xfa.form.form1.#subform.Quantity[*]

      Dieser Ausdruck bezieht sich auf alle Objekte mit dem Namen Quantity, welche mit dem ersten von der Referenz gefundenen Vorkommen von Quantity verwandt sind.
In sprachspezifischen Formularen für Arabisch, Hebräisch, Thailändisch und Vietnamesisch befindet sich die Referenz-Syntax grundsätzlich rechts (auch bei Sprachen, die von rechts nach links geschrieben werden).
LiveCycle Forms 7.1 bietet keine Unterstützung für Formularentwürfe mit arabischen, hebräischen, thailändischen und vietnamesischen Schriftzeichen.
[ ]
(Fortsetzung)
In dem gezeigten Baumdiagramm geben diese Ausdrücke jeweils die folgenden Objekte zurück:
      •
      Subform_Page.Subform1[*] gibt beide Subform1-Objekte zurück.
      •
      Subform_Page.Subform1.Subform3.TextField2[*] gibt die beiden TextField2-Objekte zurück. Subform_Page.Subform1 wird zum ersten Subform1-Objekt auf der linken Seite aufgelöst und TextField2[*] wird relativ zum Objekt Subform3 ausgewertet.
      •
      Subform_Page.Subform1[*].TextField1 gibt beide TextField1-Instanzen zurück. Subform_Page.Subform1[*] wird zu den beiden Subform1-Objekten aufgelöst und TextField1 wird relativ zu den Subform1-Objekten ausgewertet.
      •
      Subform_Page.Subform1[*].Subform3.TextField2[1] gibt das zweite und vierte TextField2-Objekt von links zurück. Subform_Page.Subform1[*] wird zu den beiden Subform1-Objekten aufgelöst und TextField2[1] wird relativ zu den Subform3-Objekten ausgewertet.
      •
      Subform_Page.Subform1[*].Subform3[*] gibt beide Instanzen des Subform3-Objekts zurück.
      •
      Subform_Page.* gibt beide Subform1-Objekte und das Subform2-Objekt zurück.
      •
      Subform_Page.Subform2.* gibt die beiden Instanzen des NumericField2-Objekts zurück.
Grundlagen zum Referenzieren von Objekten in Berechnungen und Skripten
Objekteigenschaften und -werte referenzieren
Unbenannte und wiederholte Objekte referenzieren
Aktuelles Objekt referenzieren


Variablen

Grundlagen zu Variablen
Variablen benennen
So definieren Sie Textvariablen
So zeigen Sie die Definition einer Textvariablen an
So löschen Sie Textvariablen
Variablen in Berechnungen und Skripten verwenden


Grundlagen zu Variablen

Sie können in LiveCycle Designer Textvariablen definieren, um spezifische Informationen an einer zentralen, zugänglichen Position zu speichern. Eine Variable dient üblicherweise als Platzhalter für Text, den Sie zu einem späteren Zeitpunkt eventuell ändern müssen. Beispielsweise kann in einer Variablen der Titel eines Meldungsdialogfelds gespeichert werden. Wenn der Text geändert werden muss, müssen Sie lediglich das betreffende Formular bzw. die Vorlage öffnen und den Text mit Hilfe der Variablendefinition einmal aktualisieren. LiveCycle Designer fügt den neuen Text automatisch an allen Stellen ein, an denen die eingefügte Variable steht.
Sie können Variablen ohne Eingabe von Skript-Code erstellen, anzeigen und löschen. Sie müssen allerdings Skript-Code eingeben, um auf die von Variablen gespeicherten Werte zuzugreifen und diese zu bearbeiten oder um die Werte auf Objekte in Ihrem Formular anzuwenden.
Die Werte von Formularvariablen werden jedes Mal zurückgesetzt, wenn Sie ein Formular öffnen.
Bevor Sie eine Variable erstellen, legen Sie den Namen der Variablen fest sowie den Text, den sie enthalten soll. Variablendefinitionen werden mit dem Formular bzw. mit der Vorlage gespeichert.
Verwandte Themen
Variablen benennen
So definieren Sie Textvariablen
So zeigen Sie die Definition einer Textvariablen an
So löschen Sie Textvariablen
Variablen in Berechnungen und Skripten verwenden


Variablen benennen

Zur Laufzeit treten Namenskonflikte auf, wenn die Namen von Variablen mit den Namen von Eigenschaften oder Methoden des XML Form Object Model bzw. mit Feldnamen des Formularentwurfs identisch sind. Diese Konflikte können dazu führen, dass Skripten unerwartete Werte zurückgeben. Daher ist es wichtig, jeder Variablen einen eindeutigen Namen zuzuweisen. Dazu einige Beispiele:
      •
      Verwenden Sie die Variablennamen fieldWidth und fieldHeight anstelle von x und y.
      •
      Verwenden Sie als Name für ein Formularentwurfsobjekt statt name die Bezeichnung clientName.
Bei Variablennamen ist die korrekte Groß-/Kleinschreibung wichtig; sie sollten außerdem keine Leerzeichen enthalten.
Verwandte Themen
Grundlagen zu Variablen
So definieren Sie Textvariablen
So zeigen Sie die Definition einer Textvariablen an
So löschen Sie Textvariablen
Variablen in Berechnungen und Skripten verwenden


So definieren Sie Textvariablen

1.
Wählen Sie „Datei“ > „Formulareigenschaften“.
2.
Klicken Sie auf der Registerkarte „Variablen“ auf „Neu (Einfügen)“ [image].
3.
Geben Sie in der Liste „Variablen“ einen eindeutigen Namen für die Variable ein und drücken Sie die Eingabetaste. Bei Variablennamen ist die korrekte Groß-/Kleinschreibung wichtig; sie sollten außerdem keine Leerzeichen enthalten.
4.
Klicken Sie einmal in das Feld auf der rechten Seite und geben Sie den Text ein, den Sie der Variablen zuweisen möchten.
Die Variable erscheint in der Palette „Hierarchie“ auf der Formularebene.
Verwandte Themen
Grundlagen zu Variablen
Variablen benennen
So zeigen Sie die Definition einer Textvariablen an
So löschen Sie Textvariablen
Variablen in Berechnungen und Skripten verwenden


So zeigen Sie die Definition einer Textvariablen an

1.
Wählen Sie „Datei“ > „Formulareigenschaften“.
2.
Klicken Sie auf die Registerkarte „Variablen“ und wählen Sie die Variable in der Variablenliste aus. Der zugehörige Text wird in dem Feld auf der rechten Seite angezeigt.
Verwandte Themen
Grundlagen zu Variablen
Variablen benennen
So definieren Sie Textvariablen
So löschen Sie Textvariablen
Variablen in Berechnungen und Skripten verwenden


So löschen Sie Textvariablen

1.
Wählen Sie „Datei“ > „Formulareigenschaften“.
2.
Wählen Sie auf der Registerkarte „Variablen“ die Variable und klicken Sie auf „Löschen (Entf)“ [image].
Verwandte Themen
Grundlagen zu Variablen
Variablen benennen
So definieren Sie Textvariablen
So zeigen Sie die Definition einer Textvariablen an
Variablen in Berechnungen und Skripten verwenden


Variablen in Berechnungen und Skripten verwenden

Nachdem Sie Formularvariablen erstellt haben, genügt es, den Variablennamen in Ihren Berechnungen und Skripten zu referenzieren, um den Wert der Variablen zu erhalten.
Bei der Benennung von Variablen sollten Sie Namen vermeiden, die mit den Namen von Eigenschaften, Methoden oder Objekten des XML Form Object Model identisch sind. Informationen zu den Eigenschaften, Methoden und Objekten des XML Form Object Model finden Sie unter Skript-Referenz.
Erstellen Sie beispielsweise die folgenden Definitionen für Formularvariablen.

Variablenname

Wert
firstName
Tony
lastName
Blue
age
32
In FormCalc können Sie auf die Variablenwerte auf die gleiche Weise zugreifen wie auf Feld- und Objektwerte. In diesem Beispiel werden die Werte drei getrennten Feldern zugewiesen.
TextField1 = firstName
TextField2 = lastName
NumericField1 = age
Sie können Variablen auf die gleiche Weise auch in FormCalc-Funktionen verwenden, wie dieses Beispiel zeigt.
Concat( "Dear ", firstName, lastName )
In JavaScript referenzieren Sie Variablenwerte mit der Eigenschaft .value und nicht mit der Eigenschaft .rawValue, die für Feld- und Objektwerte vorgesehen ist. Dazu ein Beispiel:
TextField1.rawValue = firstName.value;
Verwandte Themen
Grundlagen zu Variablen
Variablen benennen
So definieren Sie Textvariablen
So zeigen Sie die Definition einer Textvariablen an
So löschen Sie Textvariablen


Debugging von Berechnungen und Skripten

Grundlagen zum Debugging von Berechnungen und Skripten
Debugging-Feedback mit der messageBox-Methode bereitstellen
So aktivieren Sie den JavaScript-Debugger für LiveCycle Designer
So verhindern Sie, dass der JavaScript-Debugger in LiveCycle Designer ausgeblendet wird
Skripten in der JavaScript-Konsole ausführen


Grundlagen zum Debugging von Berechnungen und Skripten

In LiveCycle Designer steht in Abhängigkeit von der gewählten Skriptsprache eine Reihe von Funktionen und Techniken zum Debugging von Berechnungen und Skripten zur Verfügung.
Sowohl für FormCalc als auch für JavaScript bietet LiveCycle Designer verschiedene Möglichkeiten zum Debugging und zur Überprüfung von Skripten.
      •
      Auf der Registerkarte „Warnungen“ der Palette „Bericht“ können Sie alle von LiveCycle Designer ausgegebenen Fehler oder Meldungen anzeigen. Diese Registerkarte dient als eine Art Protokoll für die von LiveCycle Designer gemeldeten Aktionen. Sie wird aktualisiert, wenn Sie auf der Registerkarte „PDF-Vorschau“ eine Vorschau eines Formularentwurfs anzeigen. Weitere Informationen zum Debugging von Skripten mit der Registerkarte „Warnungen“ und dem LiveCycle Designer-Arbeitsbereich finden Sie unter Berechnungen und Skripten mit dem Arbeitsbereich debuggen.
      •
      Mit der Methode messageBox des XML Form Object Model können Sie die aus einem interaktiven Formular stammenden Informationen zur Laufzeit in einem Dialogfeld ausgeben. Weitere Informationen zur Verwendung der Methode messageBox finden Sie unter messageBox.
      •
      Bei bestimmten Debugging-Arten ist es möglicherweise angebracht, Informationen wie Feldwerte oder Meldungen in einem Textfeld des Formularentwurfs auszugeben. Beispielsweise können Sie neue Meldungen oder Werte an den Wert eines Textfelds anhängen und so ein Protokoll erstellen, das Sie bei der Problemlösung zu Rate ziehen können.
Wenn Sie mit Acrobat Professional arbeiten, können Sie Ihre Formularskripten mit dem JavaScript-Debugger von Acrobat testen. Der JavaScript-Debugger enthält die JavaScript-Konsole, mit der Sie auf der Registerkarte „PDF-Vorschau“ Teile des JavaScript-Codes testen können. Die JavaScript-Konsole bietet eine interaktive und bequeme Schnittstelle, mit der Sie Teile des JavaScript-Codes testen und mit anderen Objekteigenschaften und -methoden experimentieren können. Dank dieser interaktiven Funktionalität verhält sich die JavaScript-Konsole wie ein Editor, welcher die Ausführung einzelner Code-Zeilen oder Code-Blöcke unterstützt.
Weitere Informationen über die JavaScript-Konsole und den JavaScript-Debugger finden Sie in Developing Acrobat Applications Using JavaScript unter partners.adobe.com/public/developer/acrobat/devcenter.html (nur in Englisch).
Verwandte Themen
Debugging-Feedback mit der messageBox-Methode bereitstellen
So aktivieren Sie den JavaScript-Debugger für LiveCycle Designer
So verhindern Sie, dass der JavaScript-Debugger in LiveCycle Designer ausgeblendet wird
Skripten in der JavaScript-Konsole ausführen
Palette „Bericht“
FormCalc-Benutzerreferenz
Skript-Referenz


Debugging-Feedback mit der messageBox-Methode bereitstellen

Mit der Methode messageBox des XML Form Object Model können Sie bei jedem Formulartyp zur Laufzeit Meldungen oder Feldwerte anzeigen lassen. Wenn die Methode messageBox initiiert wird, zeigt sie in der Client-Anwendung in einem neuen Dialogfeld einen Zeichenfolgenwert an. Bei diesem Zeichenfolgenwert kann es sich um eine Textmeldung handeln, die Sie zu Debugging-Zwecken erstellen, oder um den Zeichenfolgenwert von Feldern oder Ausdrücken.
Angenommen, ein einfacher Formularentwurf enthält ein einzelnes numerisches Feld (NumericField1) und eine Schaltfläche (Button1). In diesem Fall geben die folgende FormCalc-Berechnung und das folgende JavaScript-Skript jeweils eine Meldung aus, die sich aus Text und dem im numerischen Feld gegenwärtig angezeigten Wert zusammensetzt. Wenn Sie nun die Berechnung oder das Skript dem Ereignis click des Schaltflächenobjekts hinzufügen, wird der Wert des numerischen Feldes durch Klicken auf die Schaltfläche interaktiv in einem neuen Dialogfeld angezeigt.
FormCalc
    xfa.host.messageBox(Concat("The value of NumericField1 is: ",
        NumericField1), „Debugging“, 3)
JavaScript
    xfa.host.messageBox("The value of NumericField1 is: " +
        NumericField1.rawValue, „Debugging“, 3);
Die Methode messageBox gibt im Meldungsdialogfeld einen Ganzzahlwert für die Schaltfläche zurück, auf welche der Benutzer beim Ausfüllen des Formulars klickt. Wenn Sie die Methode messageBox an das Ereignis calculate eines Feldobjekts anhängen und die Methode messagebox die letzte Skriptzeile ist, gibt das Feld den Rückgabewert der Methode messageBox zur Laufzeit zurück.
Wenn Sie beispielsweise ein Meldungsfeld während eines calculate-Ereignisses zurückgeben möchten, ist die Methode alert des JavaScript-Objektmodells von Acrobat empfehlenswert. Das folgende Skript gibt zum Beispiel den Wert eines Textfelds zurück:
    var oField = xfa.resolveNode("TextField1").rawValue;
    app.alert(oField);
Weitere Informationen zur Methode alert und zum JavaScript-Objektmodell von Acrobat finden Sie in Developing Acrobat Applications Using JavaScript unter partners.adobe.com/public/developer/acrobat/devcenter.html (nur in English).
Verwandte Themen
Grundlagen zum Debugging von Berechnungen und Skripten
So aktivieren Sie den JavaScript-Debugger für LiveCycle Designer
So verhindern Sie, dass der JavaScript-Debugger in LiveCycle Designer ausgeblendet wird
Skripten in der JavaScript-Konsole ausführen
Berechnungen und Skripten mit dem Arbeitsbereich debuggen


So aktivieren Sie den JavaScript-Debugger für LiveCycle Designer

Wenn Sie den JavaScript-Debugger für LiveCycle Designer aktivieren und Code von der JavaScript-Konsole ausführen möchten, müssen Sie in Acrobat Professional JavaScript und den JavaScript-Debugger aktivieren. Um auf die JavaScript-Konsole zuzugreifen, muss der JavaScript-Debugger aktiviert sein, da es sich beim Konsolenfenster um eine Komponente der JavaScript-Debugger-Schnittstelle handelt.
Wenn Sie LiveCycle Reader Extensions installiert haben, können Sie den JavaScript-Debugger in Adobe Reader aktivieren. Zum Aktivieren des JavaScript-Debuggers in Adobe Reader muss die Datei „debugger.js“ geöffnet und in der Microsoft Windows-Registrierung bearbeitet werden. Weitere Informationen zum Aktivieren des JavaScript-Debuggers in Adobe Reader finden Sie in Developing Acrobat Applications Using JavaScript unter partners.adobe.com/public/developer/acrobat/devcenter.html (nur in English).
1.
Starten Sie LiveCycle Designer.
2.
Starten Sie Acrobat Professional.
3.
Wählen Sie in Acrobat Professional den Befehl „Bearbeiten“ > „Grundeinstellungen“.
4.
Wählen Sie aus der linken Liste „JavaScript“.
5.
Sofern nicht bereits aktiviert, wählen Sie „Acrobat JavaScript aktivieren“.
6.
Aktivieren Sie unter „JavaScript-Debugger“ die Option „JavaScript-Debugger nach dem Neustart von Acrobat aktivieren“.
7.
Wählen Sie „Interaktive Konsole aktivieren“. Mit dieser Option können Sie den in der JavaScript-Konsole geschriebenen Code auswerten.
8.
Wählen Sie „Konsole bei Fehlern und Meldungen anzeigen“. Mit dieser Option wird sichergestellt, dass die JavaScript-Konsole bei Falscheingaben hilfreiche Informationen anzeigt.
9.
Klicken Sie auf „OK“, um das Dialogfeld „Grundeinstellungen“ zu schließen.
10.
Beenden Sie Acrobat Professional.
11.
Klicken Sie in LiveCycle Designer auf die Registerkarte „PDF-Vorschau“.
12.
Drücken Sie die Tasten Strg+J, um den JavaScript-Debugger zu öffnen.
Verwandte Themen
Grundlagen zum Debugging von Berechnungen und Skripten
Debugging-Feedback mit der messageBox-Methode bereitstellen
So verhindern Sie, dass der JavaScript-Debugger in LiveCycle Designer ausgeblendet wird
Skripten in der JavaScript-Konsole ausführen
Berechnungen und Skripten mit dem Arbeitsbereich debuggen


So verhindern Sie, dass der JavaScript-Debugger in LiveCycle Designer ausgeblendet wird

Wenn der JavaScript-Debugger von Acrobat aus aktiviert wurde und ausgeblendet wird, wenn Sie in LiveCycle Designer auf Komponenten klicken, müssen Sie den Acrobat.exe-Prozess im Microsoft Windows Task-Manager beenden. Der Acrobat.exe-Prozess wird auch nach Beendigung von Acrobat weiter ausgeführt, damit Acrobat bei einem Neustart schneller angezeigt werden kann. Wird der Acrobat.exe-Prozess beendet, wird auch die Verknüpfung zwischen dem JavaScript-Debugger und der Acrobat Professional-Sitzung beendet. Der JavaScript-Debugger kann dann in LiveCycle Designer eingesetzt werden.
1.
Klicken Sie im Windows Task-Manager auf die Registerkarte „Prozesse“.
2.
Klicken Sie in der Spalte „Abbildname“ mit der rechten Maustaste auf Acrobat.exe und wählen Sie die Option „Prozess beenden“ aus.
Verwandte Themen
Grundlagen zum Debugging von Berechnungen und Skripten
Debugging-Feedback mit der messageBox-Methode bereitstellen
So aktivieren Sie den JavaScript-Debugger für LiveCycle Designer
Skripten in der JavaScript-Konsole ausführen
Berechnungen und Skripten mit dem Arbeitsbereich debuggen


Skripten in der JavaScript-Konsole ausführen

Mit der JavaScript-Konsole von Acrobat können Sie einzelne oder mehrere Code-Zeilen auswerten.
Für die Auswertung von JavaScript-Code mit der interaktiven JavaScript-Konsole stehen drei Möglichkeiten zur Auswahl:
      •
      Wenn Sie einen Teil einer Code-Zeile auswerten möchten, heben Sie diesen Teil im Konsolenfenster hervor. Drücken Sie dann entweder auf der Zehnertastatur die Eingabetaste oder auf der normalen Tastatur die Tasten Strg+Eingabe.
      •
      Wenn Sie eine einzelne Code-Zeile auswerten möchten, stellen Sie sicher, dass sich der Cursor in der richtigen Zeile im Konsolenfenster befindet. Drücken Sie dann entweder auf der Zehnertastatur die Eingabetaste oder auf der normalen Tastatur die Tasten Strg+Eingabe.
      •
      Wenn Sie mehrere Code-Zeilen auswerten möchten, heben Sie diese Zeilen im Konsolenfenster hervor. Drücken Sie dann entweder auf der Zehnertastatur die Eingabetaste oder auf der normalen Tastatur die Tasten Strg+Eingabe.
In allen Fällen wird im Konsolenfenster das Ergebnis des zuletzt ausgewerteten JavaScript-Skriptes angezeigt.
Nach der Auswertung eines JavaScript-Skriptes zeigt das Konsolenfenster undefined an. Dies ist der Rückgabewert der Anweisung. Beachten Sie, dass das Ergebnis einer Anweisung nicht dem Wert eines Ausdrucks innerhalb der Anweisung entspricht. Der Rückgabewert undefined bedeutet nicht, dass der Wert des Skriptes nicht definiert („undefined“) ist, sondern dass der Rückgabewert der JavaScript-Anweisung nicht definiert ist.
Klicken Sie rechts unten in der Konsole auf „Löschen“ (Papierkorbsymbol), um alle im Konsolenfenster angezeigten Inhalte zu löschen.
Verwandte Themen
Grundlagen zum Debugging von Berechnungen und Skripten
Debugging-Feedback mit der messageBox-Methode bereitstellen
So aktivieren Sie den JavaScript-Debugger für LiveCycle Designer
So verhindern Sie, dass der JavaScript-Debugger in LiveCycle Designer ausgeblendet wird
Berechnungen und Skripten mit dem Arbeitsbereich debuggen


Mit Host-Anwendungen arbeiten

Grundlagen zum Arbeiten mit Host-Anwendungen
Die Funktionalität des Host-Skriptmodells im Vergleich


Grundlagen zum Arbeiten mit Host-Anwendungen

Unter einer Host-Anwendung versteht man die Anwendung, in der ein Formular zu einem bestimmten Zeitpunkt vorhanden ist. Wenn Sie beispielsweise ein Formular mit LiveCycle Forms im HTML-Format wiedergeben, ist LiveCycle Forms in der Phase vor dem Wiedergabeprozess die Host-Anwendung. Sobald Sie ein Formular wiedergeben und in einer Client-Anwendung wie Acrobat, Adobe Reader oder einem HTML-Browser anzeigen, wird die Client-Anwendung zur Host-Anwendung.
In LiveCycle Designer steht ein Skriptmodell mit Eigenschaften und Methoden zur Verfügung, die eine direkte Verbindung zur Host-Anwendung herstellen. Beispielsweise können Sie mit den Eigenschaften und Methoden des Host-Skriptmodells in Acrobat oder Adobe Reader Navigationsaktionen für PDF-Seiten bereitstellen sowie mit der Methode importData Daten in ein Formular laden.
Sie können die Host-Skriptmodellsyntax bei jedem gültigen Skriptereignis für Formularentwurfsobjekte mit der folgenden Syntax in FormCalc und JavaScript referenzieren:
    xfa.host.property_or_method
Eigenschaften und Methoden des Host-Skriptmodells
Mit Hilfe der Eigenschaften und Methoden des Host-Skriptmodells können Sie Informationen abrufen und Aktionen ausführen, die normalerweise über Berechnungen und Skripten nicht zugänglich sind. Sie können etwa den Namen der Host-Anwendung abrufen (z. B. Acrobat) oder bei einem interaktiven Formular von der aktuellen Seite aus weiterblättern. In der folgenden Tabelle werden die für das Host-Skriptmodell verfügbaren Eigenschaften und Methoden aufgeführt.
Weitere Informationen zu den Eigenschaften und Methoden des Host-Skriptmodells finden Sie im LiveCycle Developer Center unter www.adobe.com/devnet/livecycle/.

Eigenschaften

Methoden
appType
calculationsEnabled
currentPage
language
name
numPages
platform
title
validationsEnabled
variation
version
beep
exportData
gotoURL
importData
messageBox
pageDown
pageUp
print
resetData
response
setFocus
Verwandte Themen
Die Funktionalität des Host-Skriptmodells im Vergleich
Grundlagen zum Referenzieren von Objekten in Berechnungen und Skripten


Die Funktionalität des Host-Skriptmodells im Vergleich

In der folgenden Tabelle werden die Eigenschaften und Methoden des Host-Skriptmodells von LiveCycle Designer aufgeführt und den entsprechenden Ausdrücken im JavaScript-Objektmodell von Acrobat gegenübergestellt.

Eigenschaften und Methoden des Host-Skriptmodells

Entsprechungen im JavaScript-Objektmodell

xfa.host.appType
app.viewerType
xfa.host.beep( [ INTEGER param ] )
app.beep([ nType ])
xfa.host.currentPage
doc.pageNum
xfa.host.exportData([ STRING param1 [,
    BOOLEAN param2 ] ])
doc.exportXFAData(cPath [, bXDP ])
xfa.host.gotoURL( STRING param1 [,
    BOOLEAN param2 ] )
doc.getURL(cURL, [ bAppend ])
xfa.host.importData( [ STRING param ] )
doc.importXFAData(cPath)
xfa.host.language
app.language
xfa.host.messageBox(STRING param1 [,
    STRING param2 [, INTEGER param3 [,
    INTEGER param4 ] ] ])
doc.alert(cMsg [, nIcon [, nType [,
    cTitle ] ] ])
xfa.host.name
none
xfa.host.numPages
doc.numPages
xfa.host.pageDown()
doc.pageNum++
xfa.host.pageUp()
doc.pageNum--
xfa.host.platform
app.platform
xfa.host.print(BOOLEAN param1, INTEGER
    param2, INTEGER param3, BOOLEAN
    param4, BOOLEAN param5, BOOLEAN
    param6, BOOLEAN param7, BOOLEAN
    param8)
doc.print([ bUI [, nStart [, nEnd [,
    bSilent [, bShrinkToFit [,
    bPrintAsImage [, bReverse [,
    bAnnotations ] ] ] ] ] ] ] ])
xfa.host.resetData( [ STRING param ] )
doc.resetForm([ aFields ])
xfa.host.response( STRING param1 [,
    STRING param2 [, STRING param3 [,
    BOOLEAN param4] ] ])
app.response(cQuestion [, cTitle [,
    cDefault [, bPassword ] ] ])
xfa.host.setFocus( STRING param )
field.setFocus()
xfa.host.title
doc.title
xfa.host.variation
app.viewerVariation
xfa.host.version
app.viewerVersion
Verwandte Themen
Grundlagen zum Arbeiten mit Host-Anwendungen


Das Ereignismodell

Grundlagen zum Ereignismodell
Eigenschaften und Methoden des Ereignismodells


Grundlagen zum Ereignismodell

Im Ereignismodell werden Eigenschaften von Objektereignissen gespeichert. Diese Eigenschaften sind dann nützlich, wenn Sie auf Werte zugreifen möchten, die außerhalb des Gültigkeitsbereichs der Ereignisse liegen, die im Skript-Editor in der Liste „Anzeigen“ aufgeführt sind.
Das Ereignismodell steuert die Änderungen in einem Formular, die vor, während und nach Aktionen ausgeführt werden. Zu diesen Aktionen zählen dynamische Formularereignisse, wie z. B. der Zeitpunkt, zu welchem die Daten und der Formularentwurf zusammengeführt werden, jedoch bevor eine Paginierung angewendet wird, sowie interaktive Formularereignisse, wie z. B. wenn ein Benutzer den Wert eines Feldes aktualisiert.
Verwandte Themen
Eigenschaften und Methoden des Ereignismodells


Eigenschaften und Methoden des Ereignismodells

Mit Hilfe der Eigenschaften und Methoden des Ereignismodells können Sie Informationen abrufen und Aktionen ausführen, die normalerweise nicht über Berechnungen und Skripten zugänglich sind. Beispielsweise können Sie den vollständigen Wert eines Feldes abrufen, bei dem andernfalls ein Teil der Daten wegfallen würde, da sie zu lang oder auf andere Weise ungültig sind. Dies ist dann von Nutzen, wenn Sie eine umfassende Fehlerprüfung durchführen müssen.

Eigenschaften

Methoden
change
className
commitKey
fullText
keyDown
modifier
name
newContentType
newText
prevContentType
prevText
reenter
selEnd
selStart
shift
soapFaultCode
soapFaultString
target
emit
reset
Verwandte Themen
Grundlagen zum Ereignismodell


JavaScript-Funktionen erstellen und wiederverwenden

Das Skriptobjekt
So erstellen Sie ein Skriptobjekt
So fügen Sie einem Skriptobjekt Skripten hinzu:
So referenzieren Sie JavaScript-Funktionen in einem Skriptobjekt


Das Skriptobjekt

Das Skriptobjekt ist ein Objekt, in dem Sie JavaScript-Funktionen und -Werte getrennt von konkreten Formularobjekten speichern können. Üblicherweise verwenden Sie das Skriptobjekt zur Erstellung von benutzerdefinierten Funktionen und Methoden, die Sie als Teil von JavaScript-Skripten an mehreren Stellen in Ihrem Formular verwenden möchten. Dadurch wird der Arbeitsaufwand, der bei der Skripterstellung für sich wiederholende Aktionen normalerweise anfällt, erheblich reduziert.
Das Skriptobjekt unterstützt nur Skripten, die in JavaScript geschrieben wurden. Hinsichtlich der Stellen, an welchen die Skripten ausgeführt werden, gibt es jedoch keine Einschränkungen. Es muss lediglich gewährleistet sein, dass die Skriptsprache für das Ereignis, welches das Skriptobjekt auslöst, auf JavaScript eingestellt ist. Acrobat und LiveCycle Forms verarbeiten die Skripterstellung eines Skriptobjekts auf die gleiche Weise, es gibt jedoch auch Unterschiede. Nur Skripten, die für die Ausführung auf dem Client konfiguriert sind, können Skriptobjekte nutzen, die für die Ausführung auf dem Client konfiguriert sind, und umgekehrt.
Verwandte Themen
So erstellen Sie ein Skriptobjekt
So fügen Sie einem Skriptobjekt Skripten hinzu:
So referenzieren Sie JavaScript-Funktionen in einem Skriptobjekt


So erstellen Sie ein Skriptobjekt

Die Erstellung eines Skriptobjekts erfolgt in zwei Phasen. Die erste Phase besteht darin, das Objekt selbst dem Formularentwurf hinzuzufügen; die zweite Phase ist die eigentliche Erstellung des Skripts, das Sie im Skriptobjekt speichern möchten.
1.
Erstellen Sie ein neues Formular oder öffnen Sie ein vorhandenes.
2.
Klicken Sie in der Palette „Hierarchie“ mit der rechten Maustaste entweder auf ein Objekt auf Formularebene oder auf ein Objekt auf Teilformularebene und wählen Sie „Skriptobjekt einfügen“.
3.
(Optional) Klicken Sie mit der rechten Maustaste auf das Skriptobjekt und wählen Sie „Objekt umbenennen“.
Verwandte Themen
Das Skriptobjekt
So fügen Sie einem Skriptobjekt Skripten hinzu:
So referenzieren Sie JavaScript-Funktionen in einem Skriptobjekt


So fügen Sie einem Skriptobjekt Skripten hinzu:

Nachdem Sie Ihr Formular mit einem Skriptobjekt versehen haben, können Sie mit dem Skript-Editor Skripten hinzufügen.
1.
Wählen Sie das Skriptobjekt in der Palette „Hierarchie“ aus.
Der Skript-Editor wird angezeigt. Die Liste „Anzeigen“ enthält den Wert „Skriptobjekt“ und die Liste „Sprache“ den Wert „JavaScript“. Sie können keinen dieser Werte ändern.
2.
Geben Sie im Feld „Skriptquelle“ Ihr Skript ein.
3.
Wenn Sie fertig sind, klicken Sie auf „Änderungen zu Skriptquelle eingeben“ [image], um Ihrem Formular das Skript hinzuzufügen.
Beispiel
Erstellen Sie ein Skriptobjekt namens feedback, welches die folgende Funktion enthält:
function emptyCheck(oField) {

    if ((oField.rawValue == null) || (oField.rawValue == "")) {
        xfa.host.messageBox("Sie müssen einen Wert in das Feld eingeben.", "Fehlermeldung", 3);
    }
}
Verwandte Themen
Das Skriptobjekt
So erstellen Sie ein Skriptobjekt
So referenzieren Sie JavaScript-Funktionen in einem Skriptobjekt


So referenzieren Sie JavaScript-Funktionen in einem Skriptobjekt

Nachdem Sie einem Skriptobjekt Skripten hinzugefügt haben, können Sie das Skriptobjekt von jedem Ereignis aus referenzieren, das JavaScript-Skripten unterstützt.
1.
Wählen Sie ein Objekt im Formular und anschließend unter „Anzeigen“ ein Ereignis aus.
2.
Erstellen Sie eine Referenz zum Skriptobjekt und zu beliebigen Funktionen im Skriptobjekt. In der folgenden generischen Syntax wird davon ausgegangen, dass sich das Objekt, von dem aus das Skriptobjekt referenziert wird, in der Formularhierarchie auf derselben Ebene wie das Skriptobjekt befindet bzw. dass sich das Skriptobjekt in der Formularhierarchie auf der obersten Ebene befindet.

        script_object.function_name(parameter1, ...);
3.
Wenden Sie das neue Skript auf das Formularobjekt an und testen Sie es, indem Sie auf der Registerkarte „PDF-Vorschau“ eine Vorschau des Formulars anzeigen.
Ähnlich wie beim Referenzieren anderer Objekte auf einem Formular müssen Sie beim Referenzieren des Skriptobjekts eine gültige Syntax angeben, die auch die Position des Objekts innerhalb der Formularhierarchie beinhaltet. Weitere Informationen zum Referenzieren von Objekten bei der Skripterstellung finden Sie unter Objekteigenschaften und -werte referenzieren.
Beispiel
Platzieren Sie im Skriptobjektbeispiel aus So fügen Sie einem Skriptobjekt Skripten hinzu: das folgende JavaScript-Skript auf dem Ereignis exit für ein Textfeld. Testen Sie das Formular mit der Registerkarte „PDF-Vorschau“.
    feedback.emptyCheck(this);
Verwandte Themen
Das Skriptobjekt
So erstellen Sie ein Skriptobjekt
So fügen Sie einem Skriptobjekt Skripten hinzu:


Von der Skripterstellung in Acrobat zur Skripterstellung in LiveCycle Designer wechseln

Grundlagen zum Wechseln von der Skripterstellung in Acrobat zur Skripterstellung in LiveCycle Designer
Acrobat-Formulare mit Skripten konvertieren
JavaScript-Objekte aus Acrobat in LiveCycle Designer verwenden
In LiveCycle Designer unterstützte JavaScript-Objekte aus Acrobat


Zurück Weiter

Skripterstellung > Skripterstellung mit LiveCycle Designer > Von der Skripterstellung in Acrobat zur Skripterstellung in LiveCycle Designer wechseln > Grundlagen zum Wechseln von der Skripterstellung in Acrobat zur Skripterstellung in LiveCycle Designer

Grundlagen zum Wechseln von der Skripterstellung in Acrobat zur Skripterstellung in LiveCycle Designer

In LiveCycle Designer steht eine breite Palette von Funktionen zur Skripterstellung zur Auswahl. Dazu gehört auch die Unterstützung der gängigsten JavaScript-Objekte aus Acrobat. Wenn Sie ein Acrobat-Formular in LiveCycle Designer konvertieren, funktionieren die meisten JavaScript-Skripten weiterhin in der gewohnten Weise, ohne dass Änderungen erforderlich sind. Einige JavaScript-Skripten müssen jedoch manuell aus Acrobat konvertiert werden, um zu gewährleisten, dass die Funktionalität des Acrobat-Formulars erhalten bleibt.
Beim Konvertieren von Skripten in einem Acrobat-Formular ist zu beachten, dass es zwischen der Skripterstellung in LiveCycle Designer und der Skripterstellung in Acrobat einige Unterschiede gibt:
    • LiveCycle Designer-Arbeitsbereich
Sie können im LiveCycle Designer-Arbeitsbereich die Eigenschaften und Verhaltensweisen von Formularobjekten ändern, ohne Skripten zu erstellen.
    • Skriptsprachen
LiveCycle Designer unterstützt neben JavaScript auch FormCalc, eine einfache Berechnungssprache. Mit den in FormCalc integrierten Funktionen können zahlreiche nützliche Vorgänge ausgeführt werden, für die anderenfalls ein erheblicher Skripterstellungsaufwand anfallen würde.
    • Referenzieren von Objekten, Eigenschaften und Methoden
LiveCycle Designer sind hochgradig strukturiert. Daher müssen Sie, wenn Sie bestimmte Objekte, Eigenschaften oder Methoden referenzieren möchten, die entsprechende Referenz-Syntax in Ihr Skript einbauen. Die Anweisungsende-Optionen im Skript-Editor erleichtern die Erstellung der Referenz-Syntax.
JavaScript-Objekte, -Eigenschaften und -Methoden aus Acrobat können in LiveCycle Designer weiter verwendet werden. Allerdings sollten Sie JavaScript aus Acrobat nur für Aufgaben einsetzen, welche mit der Anwendung in Zusammenhang stehen, in der sich das Formular befindet, und welche sich nicht in LiveCycle Designer reproduzieren lassen. Beispielsweise können Sie JavaScript aus Acrobat verwenden, um Anhänge, Lesezeichen oder Anmerkungen hinzuzufügen, ein Formular zu durchsuchen, die Rechtschreibung in einem Formular zu prüfen, Berichte zu erstellen oder Metadaten abzurufen bzw. zu bearbeiten. JavaScript aus Acrobat ist für Vorgänge wie das Festlegen von Feldwerten, das Hinzufügen neuer Felder zu einem Formular sowie das Löschen von Seiten aus einem Formular ungeeignet.
Es ist nicht möglich, einem LiveCycle Designer-Formular mit Acrobat JavaScript-Skripten hinzuzufügen; dies gilt auch für Acrobat-Formulare, die mit LiveCycle Designer konvertiert wurden. Bei der Anzeige eines LiveCycle Designer-Formulars in Acrobat sind keine JavaScript-Werkzeuge verfügbar.
Weitere Informationen zum Konvertieren von Acrobat-Skripten in LiveCycle Designer finden Sie im Artikel Converting Acrobat JavaScript for Use in LiveCycle Designer Forms im LiveCycle Developer Center unter www.adobe.com/devnet/livecycle/.
Verwandte Themen
Acrobat-Formulare mit Skripten konvertieren


Acrobat-Formulare mit Skripten konvertieren

Einer der ersten Schritte bei der Konvertierung eines Formulars aus Acrobat in LiveCycle Designer besteht darin festzustellen, welcher Teil der Acrobat-Skripten von LiveCycle Designer unterstützt wird und welcher Teil konvertiert werden muss.
In der Regel sollten Sie alle Acrobat-Skripten in entsprechende LiveCycle Designer-Skripten konvertieren. In LiveCycle Designer werden der Entwurf und die Implementierung von Formularlösungen durch die hochgradige Strukturierung der LiveCycle Designer-Formulare sowie durch nützliche formularspezifische Funktionen beschleunigt und erleichtert.
Zu den Acrobat-Skripten, die Sie beibehalten sollten, gehören die Skripten, die für die Umgebung und die Peripherievorgänge des Formulars zuständig sind. Dazu gehören das Hinzufügen von Anhängen oder Multimedia, die Durchführung von Suchvorgängen, die Berichterstellung sowie der Umgang mit Dokument-Metadaten.
Weitere Informationen zum Konvertieren von Acrobat-Skripten in LiveCycle Designer finden Sie im Artikel Converting Acrobat JavaScript for Use in LiveCycle Designer Forms im LiveCycle Designer Developer Center unter www.adobe.com/devnet/livecycle/.
Verwandte Themen
Grundlagen zum Wechseln von der Skripterstellung in Acrobat zur Skripterstellung in LiveCycle Designer
JavaScript-Objekte aus Acrobat in LiveCycle Designer verwenden
In LiveCycle Designer unterstützte JavaScript-Objekte aus Acrobat


Zurück Weiter

Skripterstellung > Skripterstellung mit LiveCycle Designer > Von der Skripterstellung in Acrobat zur Skripterstellung in LiveCycle Designer wechseln > JavaScript-Objekte aus Acrobat in LiveCycle Designer verwenden

JavaScript-Objekte aus Acrobat in LiveCycle Designer verwenden

Sie haben in LiveCycle Designer die Möglichkeit, mit Hilfe der Acrobat-Skriptsyntax Skripten für bestimmte JavaScript-Objekte in Acrobat zu erstellen. Sie können daher die Eigenschaften und Methoden dieser Objekte in Ihren Formularen verwenden. Wenn Sie beispielsweise eine Meldung für Benutzer anzeigen möchten, können Sie dem Ereignis eines Formularentwurfsobjekts in LiveCycle Designer das folgende Skript hinzufügen:
app.alert("Acrobat-Warnmeldung.");
Sie können auch veranlassen, dass das Formular per E-Mail versendet wird, indem Sie dem Ereignis click einer Schaltfläche das folgende Skript hinzufügen:
var myDoc = event.target;
myDoc.mailDoc(true);
In LiveCycle Designer müssen Sie dafür sorgen, dass die Skriptsprache für das Ereignis auf JavaScript eingestellt ist, damit das Skript zur Laufzeit korrekt ausgeführt wird.
Sie können auch Verweise auf die JavaScript-Objekte in Acrobat in die Referenz-Syntax einbauen. Beispielsweise ruft das folgende Skript den Unterschriftsstatus eines Dokumentunterschriftsfelds ab und führt eine vom Status abhängige Aktion aus:
        // Fahren Sie fort, wenn das aktuelle Feld nicht unterschrieben ist.
        var oState = event.target.getField("form1[0].#subform[0].SignatureField1[0]").signatureValidate(); //Get the field's signed state.

if (oState == 0) {
...
}
In diesem Beispiel wird für den Verweis auf den Text eine vollständig qualifizierte Referenz-Syntax verwendet. Weitere Informationen zum Referenzieren von Formularentwurfsobjekten finden Sie unter Objekteigenschaften und -werte referenzieren.
Bei der Arbeit mit JavaScript aus Acrobat in LiveCycle Designer sind die folgenden Punkte zu beachten:
      •
      Greifen Sie in LiveCycle Designer über event.target auf das JavaScript-Objekt Doc aus Acrobat zu. In Acrobat wird mit dem Objekt this das Objekt Doc referenziert; in LiveCycle Designer jedoch bezieht sich das Objekt this auf das Formularentwurfsobjekt, an welches das Skript angehängt ist.
      •
      Im Skript-Editor stehen keine Anweisungsende-Optionen für JavaScript-Objekte aus Acrobat zur Verfügung. Weitere Informationen finden Sie in JavaScript for Acrobat API Reference im Acrobat Developer Center unter partners.adobe.com/public/developer/acrobat/devcenter.html.
Weitere Informationen zum Konvertieren von Acrobat-Skripten in LiveCycle Designer finden Sie im Artikel Converting Acrobat JavaScript for Use in LiveCycle Designer Forms im LiveCycle Developer Center unter www.adobe.com/devnet/livecycle/.
Verwandte Themen
Grundlagen zum Wechseln von der Skripterstellung in Acrobat zur Skripterstellung in LiveCycle Designer
Acrobat-Formulare mit Skripten konvertieren


Zurück Weiter

Skripterstellung > Skripterstellung mit LiveCycle Designer > Von der Skripterstellung in Acrobat zur Skripterstellung in LiveCycle Designer wechseln > In LiveCycle Designer unterstützte JavaScript-Objekte aus Acrobat

In LiveCycle Designer unterstützte JavaScript-Objekte aus Acrobat

In der folgenden Tabelle finden Sie eine Übersicht über die Verfügbarkeit der am häufigsten verwendeten Acrobat-Objekte, -Eigenschaften und -Methoden in LiveCycle Designer und deren Entsprechungen in LiveCycle Designer. Einige gängige Acrobat-Objekte, -Eigenschaften und -Methoden fehlen in dieser Liste. Beispielsweise sind keine Multimedia-Objekte aufgeführt, weil sie in Formularen nur sehr selten vorkommen.
In den Fällen, in denen keine entsprechende LiveCycle Designer-Funktionalität aufgeführt ist, gibt es keine LiveCycle Designer-Eigenschaft oder -Methode, mit welcher das Acrobat-Verhalten reproduziert werden kann. Sie können aber trotzdem eigene Funktionen oder Skripten erstellen, welche die Acrobat-Funktionalität reproduzieren.

JavaScript in Acrobat

LiveCycle
Designer-
Unterstützung

JaveScript-Entsprechung in LiveCycle Designer

Kommentare
Annot-Objekteigenschaften und -methoden
Alle Eigenschaften und Methoden
Ja
Keine
Nur Formulare mit festem Layout unterstützen die Anmerkungsebene.
app Objekteigenschaften

calculate
Nein
Keine
LiveCycle Designer enthält die Methode execCalculate, welche das Ereignis calculate initiiert.

language
Ja

xfa.host.language
Siehe die Eigenschaft language.

monitors
Ja
Keine

platform
Ja

xfa.host.platform
Siehe die Eigenschaft platform.

plugins
Ja
Keine

toolbar
Ja
Keine

viewerType
Ja

xfa.host.appType
Siehe die Eigenschaft appType.

viewerVariation
Ja

xfa.host.variation
Siehe die Eigenschaft variation.

viewerVersion
Ja

xfa.host.version
Siehe die Eigenschaft version.
app-Objektmethoden

addMenuItem
Ja
Keine

addSubMenu
Ja
Keine

addToolButton
Ja
Keine

alert
Ja

xfa.host.messageBox()
Siehe die Methode messageBox.

beep
Ja

xfa.host.beep()
Siehe die Methode beep.

browseForDoc
Ja
Keine

clearInterval
Ja
Keine

clearTimeOut
Ja
Keine

execDialog
Ja
Keine

execMenuItem
Ja
Keine
Führt den angegebenen Menübefehl aus. Verwenden Sie diese Methode in LiveCycle Designer für Datei-Menübefehle.

getNthPluginName
Ja
Keine

getPath
Ja
Keine

goBack
Ja
Keine

goForward
Ja
Keine

hideMenuItem
Ja
Keine

hideToolbarButton
Ja
Keine

launchURL
Ja
Keine
LiveCycle Designer enthält die Methode gotoURL, die eine angegebene URL in die Client-Anwendung wie z. B. Acrobat oder Adobe Reader lädt.

listMenuItems
Ja
Keine

listToolbarButtons
Ja
Keine

mailGetAddrs
Ja
Keine

mailMsg
Ja
Keine

newDoc
Ja
Keine
Diese Methode kann nur während Stapelverarbeitungs-, Konsolen- oder Menüereignissen ausgeführt werden.

newFDF
Nein
Keine

openDoc
Ja
Keine

openFDF
Nein
Keine

popUpMenuEx
Ja
Keine

popUpMenu
Ja
Keine

removeToolButton
Ja
Keine

response
Ja

xfa.host.response()
Siehe die Methode response.

setInterval
Ja
Keine

setTimeOut
Ja
Keine

trustedFunction
Ja
Keine

trustPropagatorFunction
Ja
Keine
Diese Methode ist nur während der Stapelverarbeitungs-, Konsolen- und Anwendungsinitialisierung verfügbar.
Lesezeichen - Objekteigenschaften und -methoden
Alle Eigenschaften und Methoden
Ja
Keine
doc Objekteigenschaften

author
Ja
Keine

baseURL
Ja
Keine

bookmarkRoot
Ja
Keine

calculate
Nein
Keine

dataObjects
Ja
Keine

delay
Nein
Keine

dirty
Ja
Keine
Dieses JavaScript-Skript von LiveCycle Designer speichert eine Kopie eines Formulars und testet, ob sich das Formular geändert hat.
var sOrigXML = xfa.data.saveXML;
if (sOrigXML != xfa.data.saveXML)
{...}

disclosed
Ja
Keine

documentFileName
Ja
Keine

dynamicXFAForm
Ja
Keine

external
Ja
Keine

filesize
Ja
Keine

hidden
Ja
Keine

icons
Ja
Keine

keywords
Ja
Keine

layout
Ja
Keine

media
Ja
Keine

metadata
Ja

xfa.form.desc
Siehe das Objekt desc.

modDate
Ja
Keine

mouseX
mouseY
Ja
Keine

noautocomplete
Ja
Keine

nocache
Ja
Keine

numFields
Ja

xfa.layout.pageContent()
Die Methode pageContent gibt eine Liste sämtlicher Objekte zurück, die einem bestimmten Typ angehören. Allerdings müssen Sie die Methode für Textseiten und Masterseiten ausführen, damit das gesamte Formular durchsucht wird.

numPages
Ja

xfa.host.numPages
oder
xfa.layout.absPageCount()
xfa.layout.pageCount()
Die Eigenschaft numPages gibt die Seitenanzahl des im Client wiedergegebenen Formulars zurück. Siehe auch die Methoden absPageCount und pageCount.

pageNum
Ja

xfa.host.currentPage
Siehe die Eigenschaft currentPage.

pageNum--
Ja

xfa.host.currentPage--
oder
xfa.host.pageUp()
Siehe die Eigenschaft currentPage oder die Methode pageUp.

pageNum++
Ja

xfa.host.currentPage++
oder
xfa.host.pageDown()
Siehe die Eigenschaft currentPage oder die Methode pageDown.

path
Ja
Keine

securityHandler
Ja
Keine

templates
Nein
Keine
Verwenden Sie Teilformularobjekte in LiveCycle Designer; verwenden Sie Eigenschaften und Methoden, um Teilformularinstanzen hinzuzufügen, zu entfernen, zu verschieben und einzurichten.
Weitere Informationen finden Sie unter So können Sie Teilformularinstanzen mit Hilfe von Skripten hinzufügen, entfernen.

title
Ja

xfa.host.title
Siehe die Eigenschaft title.
doc-Objektmethoden

addAnnot
Ja
Keine

addField
Nein
Keine
Sie müssen Formulare mit festem Layout in LiveCycle Designer verwenden und dann Felder mit Hilfe der Eigenschaft presence ein- und ausblenden.

addIcon
Ja
Keine

addLink
Nein
Keine

addRecipientListCryptFilter
Ja
Keine

addScript
Ja
Keine

addThumbnails
Nein
Keine

addWatermarkFromFile
Ja
Keine

addWatermarkFromText
Ja
Keine

addWeblinks
Ja
Keine

appRightsSign
Ja
Keine

appRightsValidate
Ja
Keine

bringToFront
Ja
Keine

calculateNow
Nein

xfa.form.recalculate(1);
oder
execCalculate()
Die Methode recalculate bewirkt, dass ein spezifischer Satz Skripten bei calculate-Ereignissen initiiert wird. Boolescher Wert gibt an, ob True (Standard) - alle Berechnungsskripten werden initiiert; oder False - nur anstehende Berechnungsskripten werden initiiert.
LiveCycle Designer Das Objekt calculate steuert, ob ein Benutzer beim Ausfüllen den berechneten Wert eines Feldes überschreiben darf.
Alternativ können Sie für jedes Objekt, für das Sie eine Neuberechnung erzwingen möchten, die Methode execCalculate verwenden.

closeDoc
Ja
Keine

createDataObject
Ja
Keine

createTemplate
Nein
Keine
Bei LiveCycle Designer-Formularen gibt es keine Entsprechung für Acrobat-Vorlagen. In LiveCycle Designer müssen Sie Teilformularobjekte verwenden.

deletePages
Nein
Keine
In LiveCycle Designer können Sie mit dem Objekt instanceManager das Teilformularobjekt entfernen, das eine Seite im Formular darstellt.
Weitere Informationen finden Sie unter So können Sie Teilformularinstanzen mit Hilfe von Skripten hinzufügen, entfernen.

embedDocAsDataObject
Ja
Keine

encryptForRecipients
Ja
Keine

encryptUsingPolicy
Ja
Keine

exportAsText
Ja
Keine
Diese Methode ist nur in der JavaScript-Konsole des JavaScript-Debuggers in Acrobat bzw. während der Stapelverarbeitung verfügbar.

exportAsFDF
Nein

xfa.host.exportData()
Die Methode exportData exportiert anstelle einer FDF-Datei eine XML- oder XDP-Datei.

exportAsXFDF
Nein

xfa.host.exportData()
Die Methode exportData exportiert anstelle einer FDF-Datei eine XML- oder XDP-Datei.

exportDataObject
Ja
Keine

exportXFAData
Nein

xfa.host.exportData()
Die Methode exportData exportiert anstelle einer FDF-Datei eine XML- oder XDP-Datei.

extractPages
Nein
Keine

flattenPages
Ja
Keine

getAnnot
Ja
Keine

getAnnots
Ja
Keine

getDataObjectContents
Ja
Keine

getField("FieldName")
Ja

xfa.resolveNode
("FieldName")
Die Methode resolveNode greift auf das angegebene Objekt in der XML-Quelle des Formulars zu.

getLegalWarnings
Ja
Keine

getLinks
Nein
Keine

getNthFieldName
Ja
Sie müssen alle Objekte mit einem ähnlichen Klassennamen durchlaufen, bis das n-te (nth) Vorkommen erreicht ist.
Siehe die Eigenschaft className.

getNthTemplate
Nein
Keine

getOCGs
Ja
Keine

getOCGOrder
Ja
Keine

getPageBox
Ja
Keine

getPageLabel
Ja
Keine

getPageNthWord
Ja
Keine

getPageNthWordQuads
Ja
Keine

getPageNumWords
Ja
Keine

getPageRotation
Ja
Keine

getPrintParams
Ja
Keine

getTemplate
Nein
Keine

getURL
Ja

xfa.host.gotoURL(
„http://www.adobe.com“);
Siehe die Methode gotoURL.

gotoNamedDest
Nein
Keine

importAnFDF
Nein
Keine

importAnXFDF
Ja
Keine

importDataObject
Ja
Keine

importIcon
Ja
Keine

importTextData
Ja
Keine

importXFAData
Nein

xfa.host.importData
(„filename.xdp“);
Siehe die Methode importData.

insertPages
Nein
Keine

mailDoc
Ja
Keine

mailForm
Nein
Keine

movePage
Nein
Keine

newPage
Nein
Keine

openDataObject
Ja
Keine

print
Ja

xfa.host.print();
Siehe die Methode print.

removeDataObject
Ja
Keine

removeField
Nein
Keine

removeIcon
Ja
Keine

removeLinks
Nein
Keine

removeScript
Ja
Keine

removeTemplate
Nein
Keine

removeThumbnails
Nein
Keine

removeWeblinks
Ja
Keine

replacePages
Nein
Keine
resetForm
Nein

xfa.host.resetData()
oder
xfa.event.reset()
Die Methode resetData setzt alle Feldwerte in einem Formular auf die Standardwerte zurück. Die Methode reset setzt alle Eigenschaften im Ereignismodell zurück.
saveAs
Ja
Keine
In LiveCycle Designer muss die Datei auf Anwendungsebene gespeichert werden. Die folgenden Skripten sind Beispiele für die Speicherung auf Anwendungsebene:
app.executeMenuItem
("SaveAs");
oder
var myDoc = event.target; myDoc.saveAs();

spawnPageFromTemplate
Nein
Keine

setAction
Nein
Keine

setPageLabel
Ja
Keine

setPageRotation
Nein
Keine

setPageTabOrder
Nein
Keine
Wählen Sie in LiveCycle Designer „Ansicht“ > „Tab-Reihenfolge“, um die Tab-Reihenfolge festzulegen.

setScript
Nein
Keine

submitForm
Ja
Verwenden Sie eines der Senden-Schaltfläche-Objekte in LiveCycle Designer.
event Objekteigenschaften

change
Ja

xfa.event.change
Siehe die Eigenschaft change.

targetName
Ja

xfa.event.target
Siehe die Eigenschaft target.
field Objekteigenschaften

comb
Nein
Keine

charLimit
Nein

this.value.#text.maxChars
Bei Formularen mit festem Layout kann die maximale Zeichenanzahl im LiveCycle Designer-Arbeitsbereich festgelegt werden. Sie können Felder in Formularen einstellen, deren Layout an die Datenmenge angepasst wird.
Weitere Informationen finden Sie unter maxChars.

display = display.noView
Nein
In the prePrint event:
this.presence =
"visible"
In the postPrint event:
this.presence =
invisible"
Die Eigenschaft presence kann auch im LiveCycle Designer-Arbeitsbereich festgelegt werden.

display = display.noPrint
Nein
In the prePrint event:
this.presence = "invisible"
In the postPrint event:
this.presence =
"visible"
Die Eigenschaft presence kann auch im LiveCycle Designer-Arbeitsbereich festgelegt werden.

defaultValue
Nein
Keine
Legen Sie den Standard-Feldwert im LiveCycle Designer-Arbeitsbereich fest.

exportValues
Nein
Keine
Legen Sie den Exportwert im LiveCycle Designer-Arbeitsbereich fest.

fillColor
Nein

xfa.form.Form1.
NumericField1.fillColor
Siehe die Eigenschaft fillColor.

hidden
Nein

this.presence = "invisible" this.
presence = „visible“
Die Eigenschaft presence kann auch im LiveCycle Designer-Arbeitsbereich festgelegt werden.

multiline
Nein

this.ui.textEdit.multiLine
= „1“;
Siehe die Eigenschaft multiLine.

password
Nein
Keine
LiveCycle Designer enthält ein Kennwortfeld, das Sie für Kennwörter in Formularen verwenden können.

page
Nein
Keine
Bei LiveCycle Designer-Formularen nicht zutreffend.

print
Nein

this.relevant = "-print";
Siehe die Eigenschaft relevant.

radiosInUnison
Nein
Keine
Gruppierte Optionsfelder in LiveCycle Designer schließen sich standardmäßig gegenseitig aus.

rect
Ja
Sie können die Höhe und Breite eines LiveCycle Designer-Formularfeldds mit Hilfe der folgenden Referenz-Syntax abrufen:
this.h;
this.w;
Alternativ können Sie die x- und y-Koordinaten eines Objekts mit der folgenden Referenz-Syntax abrufen:
this.x;
this.y;
Siehe die Eigenschaften h, w, x und y.

required
Nein

this.mandatory = "error";
oder
this.validate.nullTest = "error";
Siehe die Eigenschaften mandatory und nullTest.

textColor
Nein

this.fontColor
Siehe die Eigenschaft fontColor.

textSize
Nein

this.font.size
Siehe die Eigenschaft size.

textFont
Nein

this.font.typeface
Siehe die Eigenschaft typeface.

value
Nein

this.rawValue
Siehe die Eigenschaft rawValue.
LiveCycle Designer-Felder haben eine Eigenschaft namens value, die nicht der Eigenschaft value in Acrobat entspricht.
field-Objektmethoden

clearItems
Nein

DropDownList1.clearItems();
Die Methode clearItems gilt nur für Dropdown-Listen- und Listenfeldobjekte in LiveCycle Designer.

deleteItemAt
Nein
Keine

getItemAt
Nein
Keine

insertItemAt
Nein

DropDownList1.addItem(
.....)
Siehe die Methode addItem.

isBoxChecked
Nein

if(CheckBox1.rawValue
== 1)....
Siehe die Eigenschaft rawValue.

isDefaultChecked
Nein
Keine

setAction
Nein
Keine
Bei LiveCycle Designer-Formularen nicht zutreffend.

setFocus
Ja

xfa.host.setFocus
("TextField1")
Die Methode setFocus setzt voraus, dass das angegebene Objekt einen eindeutigen Namen hat und nicht mit anderen Formularobjekten verwechselt werden kann.

setItems
Nein
Keine

setLock
Ja
Keine

signatureGetModifications
Ja
Keine

signatureGetSeedValue
Ja
Keine

signatureInfo
Ja
Keine

signatureSetSeedValue
Ja
Keine

signatureSign
Ja
Keine

signatureValidate
Ja
Keine
search-Objektmethode

search.query("<your text>");
Ja
Keine
Mit der Kurzbefehlsyntax (..) von FormCalc können Sie das XML Form Object Model nach Objekten durchsuchen.
Weitere Informationen finden Sie unter Referenz-Syntax-Kurzbefehle für FormCalc.
SOAP-Objektmethode
Alle Eigenschaften und Methoden
Ja
Keine
Verwandte Themen
Grundlagen zum Ereignismodell


Beispiele für gängige Aufgaben bei der Skripterstellung

Beispiele zur Skripterstellung
Hintergrundfarben von Feldern, Füllbereichen und Teilformularen ändern
Objekte ein- und ausblenden
Visuelle Eigenschaften von Objekten im Client ändern
Aktuellen oder vorherigen Wert einer Dropdown-Liste abrufen
Höhe eines Feldes zur Laufzeit anpassen
Felder zur Laufzeit als „Erforderlich“ festlegen
Feldsummen berechnen
Felder als Reaktion auf Benutzeraktionen hervorheben
Die Werte des aktuellen Teilformulars zurücksetzen
Präsenz von Formularentwurfsobjekten ändern
Teilformulare mit Hilfe der Eigenschaften des Instanzmanagers steuern
Teilformulare mit Hilfe der Methoden des Instanzmanagers steuern
Teilformulare mit Hilfe des Instanzmanagers zur Laufzeit steuern


Beispiele zur Skripterstellung

Die Beispiele zur Skripterstellung veranschaulichen schnelle und einfache Techniken, die Sie auf Ihre eigenen Projekte übertragen können.
Weitere Beispiele und Anregungen finden Sie im LiveCycle Developer Center unter www.adobe.com/devnet/livecycle.


Hintergrundfarben von Feldern, Füllbereichen und Teilformularen ändern

Dieses Beispiel zeigt, wie Sie die Hintergrundfarbe von Teilformularen, Feldern und Füllbereichen in einem Formular als Reaktion auf Benutzeraktionen zur Laufzeit ändern.
In diesem Beispiel ändert sich die Hintergrundfarbe eines bestimmten Objekts, wenn der Benutzer auf eine Schaltfläche klickt.
Um die Hintergrundfarbe von Objekten zur Laufzeit zu ändern, müssen Sie Ihr Formular im Format „Acrobat (Dynamisch) XML-Formular“ speichern.
Dieses und andere Beispiele zur Skripterstellung finden Sie im LiveCycle Developer Center unter www.adobe.com/devnet/livecycle.
Skripten für die Hintergrundfarben von Teilformularen und Textfeldern
Die Hintergrundfarben von Teilformularen und Textfeldern werden mit der Methode fillColor eingestellt. Beispielsweise stellt die folgende Zeile das Skript für das Teilformular dar:
    Subform1.fillColor = "17,136,255";
Die folgenden Zeilen bilden das Skript für die Hintergrundfarbe der Textfelder:
    Subform1.Name.fillColor = "102,179,255";
    Subform1.Address.fillColor = "102,179,255";
    Subform1.City.fillColor = "102,179,255";
    Subform1.State.fillColor = "102,179,255";
    Subform1.ZipCode.fillColor = "102,179,255";
    Subform1.Country.fillColor = "102,179,255";
Skripten für die Hintergrundfarbe von Füllbereichen
Beim Festlegen der Hintergrundfarbe oder des Füllbereichs für die einzelnen Textfelder müssen die Skripten auf Eigenschaften zugreifen, die einen Referenz-Syntax-Ausdruck mit dem Nummernzeichen (#) erfordern. Da JavaScript das Nummernzeichen (#) in Referenz-Syntax-Ausdrücken aber nicht richtig interpretiert, verwendet das Skript zur Auflösung des Ausdrucks die Methode resolveNode.
    xfa.resolveNode("Subform1.Name.ui.#textEdit.border.fill.color").value = "153,204,255";
    xfa.resolveNode("Subform1.Address.ui.#textEdit.border.fill.color").value = "153,204,255";
    xfa.resolveNode("Subform1.City.ui.#textEdit.border.fill.color").value = "153,204,255";
    xfa.resolveNode("Subform1.State.ui.#textEdit.border.fill.color").value = "153,204,255";
    xfa.resolveNode("Subform1.ZipCode.ui.#textEdit.border.fill.color").value = "153,204,255";
    xfa.resolveNode("Subform1.Country.ui.#textEdit.border.fill.color").value = "153,204,255";
Skripten für die Schaltfläche „Alles löschen“
Im Skript für die Schaltfläche „Alles löschen“ werden der Formularentwurf und die Formulardaten mit Hilfe der Methode remerge erneut zusammengeführt. In diesem Beispiel stellt die Methode die Felder, Füllbereiche und Teilformulare in ihrem Originalzustand wieder her.
    xfa.form.remerge();


Objekte ein- und ausblenden

Dieses Beispiel zeigt, wie Sie Schaltflächen beim Drucken eines Formulars ausblenden und wie Sie Objekte durch Ändern der Präsenzwerte zur Laufzeit ein- und ausblenden.
In diesem Beispiel sind alle Formularobjekte im Formular sichtbar.
Der Formularbenutzer kann mit den Dropdown-Listen im Bereich „Präsenzwerte“ Objekte ein- oder ausblenden. In der folgenden Abbildung ist das Feld „Adresse“ ausgeblendet und das Formularlayout entsprechend angepasst. Die Schaltfläche „Formular drucken“ ist ebenfalls nicht sichtbar.
Um Objekte zur Laufzeit ein- und auszublenden, müssen Sie Ihr Formular im Format „Acrobat (Dynamisch) XML-Formular“ speichern.
Dieses und andere Beispiele zur Skripterstellung finden Sie im LiveCycle Developer Center unter www.adobe.com/devnet/livecycle.
Skripten für die Präsenzwerte der Teilformulare
Das Skript für die Präsenzwerte der Teilformulare enthält eine switch-Anweisung zur Steuerung der drei Präsenzoptionen, die ein Formularbenutzer dem Teilformularobjekt zuweisen kann:
switch(xfa.event.newText) {
    case 'Invisible':
        Subform1.presence = "invisible";
        break;
    case 'Hidden (Exclude from Layout)':
        Subform1.presence = "hidden";
        break;
    default:
        Subform1.presence = "visible";
        break;
}
Skripten für die Präsenzwerte der Textfelder
Für das Skript für die Präsenzwerte der Textfelder sind zwei Variablen erforderlich. Die erste Variable speichert die in Subform1 enthaltene Anzahl von Objekten:
    var nSubLength = Subform1.nodes.length;
Die zweite Variable speichert den Namen des Textfelds, welches der Formularbenutzer in der Dropdown-Liste „Textfelder“ auswählt:
    var sSelectField = fieldList.rawValue;
Im folgenden Skript werden mit der Methode replace alle Leerzeichen aus dem in der Variablen sSelectField gespeicherten Namen des Feldes entfernt. Dies bewirkt, dass der Wert der Dropdown-Liste nun mit dem Namen des Objekts in der Palette „Hierarchie“ übereinstimmt:
    sSelectField = sSelectField.replace(' ', '');
In diesem Skript werden sämtliche Objekte in Subform1 mit Hilfe einer For-Schleife nacheinander durchlaufen:
    for (var nCount = 0; nCount < nSubLength; nCount++) {
Wenn das aktuelle Objekt in Subform1 dem Typ field angehört und denselben Namen wie das Objekt hat, welches der Formularbenutzer ausgewählt hat, wird Folgendes ausgeführt:
if ((Subform1.nodes.item(nCount).className == "field") & (Subform1.nodes.item(nCount).name == sSelectField)) {
Das folgende Skript enthält eine switch-Anweisung zur Steuerung der drei Präsenzoptionen, die ein Formularbenutzer den Textfeldobjekten zuweisen kann:
        switch(xfa.event.newText) {
            case 'Invisible':
                Subform1.nodes.item(nCount).presence = "invisible";
                break;
            case 'Hidden (Exclude from Layout)':
                Subform1.nodes.item(nCount).presence = "hidden";
                break;
            default:
                Subform1.nodes.item(nCount).presence = "visible";
                break;
        }
    }
}
Skripten für die Präsenzwerte der Schaltflächen
Für das Skript für die Präsenzwerte der Schaltflächen sind zwei Variablen erforderlich. Diese Variable speichert die in Subform1 enthaltene Anzahl von Objekten:
    var nSubLength = Subform1.nodes.length;
Diese Variable speichert den Namen der Schaltfläche, welche der Formularbenutzer in der Dropdown-Liste „Schaltflächen“ auswählt:
    var sSelectButton = buttonList.rawValue;
Im folgenden Skript werden mit der Methode replace alle Leerzeichen aus dem in der Variablen sSelectField gespeicherten Namen der Schaltfläche entfernt. Dies bewirkt, dass der Wert der Dropdown-Liste mit dem Namen des Objekts in der Palette „Hierarchie“ übereinstimmt:
    sSelectButton = sSelecButton.replace(/\s/g, '');
In diesem Skript werden sämtliche Objekte in Subform1 mit Hilfe einer For-Schleife nacheinander durchlaufen:
    for (var nCount = 0; nCount < nSubLength; nCount++) {
Wenn das aktuelle Objekt in Subform1 dem Typ field angehört und denselben Namen wie das Objekt hat, welches der Formularbenutzer ausgewählt hat, wird Folgendes ausgeführt:
    if ((Subform1.nodes.item(nCount).className == "field") &
    Subform1.nodes.item(nCount).name == sSelectButton)) {
Dieses Skript enthält eine switch-Anweisung zur Steuerung der fünf Präsenzoptionen, die ein Formularbenutzer den Schaltflächenobjekten zuweisen kann.
Die relevante Eigenschaft gibt jeweils an, ob ein Objekt beim Drucken des Formulars sichtbar sein soll.
        switch(xfa.event.newText) {
            case 'Invisible':
                Subform1.nodes.item(nCount).presence = "invisible";
                break;
            case 'Hidden (Exclude from Layout)':
                Subform1.nodes.item(nCount).presence = "hidden";
                break;
            case 'Visible (but Don\'t Print)':
                Subform1.nodes.item(nCount).presence = "visible";
                Subform1.nodes.item(nCount).relevant = "-print";
                break;
            case 'Invisible (but Print Anyway)':
                Subform1.nodes.item(nCount).presence = "invisible";
                Subform1.nodes.item(nCount).relevant = "+print";
                break;
            default:
                Subform1.nodes.item(nCount).presence = "visible";
                break;
        }
    }
}
Skripten für die Zurücksetzung der Dropdown-Listen
Sämtliche Dropdown-Listen können mit der Methode resetData auf ihre Standardwerte zurückgesetzt werden:
    xfa.host.resetData();
Führen Sie den Formularentwurf und die Formulardaten mit der Methode remerge erneut zusammen. In diesem Beispiel stellt die Methode die Objekte im Bereich „Formularobjekte“ in ihrem Originalzustand wieder her.
    xfa.form.remerge();


Visuelle Eigenschaften von Objekten im Client ändern

Dieses Beispiel zeigt, wie Sie die visuellen Eigenschaften eines Objekts (in diesem Fall ein Textfeld) ändern. Wenn ein Benutzer beispielsweise das Kontrollkästchen „Feldbreite vergrößern“ aktiviert, wird der Füllbereich des Textfelds auf vier Zoll erweitert.
Um die visuellen Eigenschaften von Objekten im Client zu ändern, müssen Sie Ihr Formular im Format „Acrobat (Dynamisch) XML-Formular“ speichern.
In diesem Beispiel haben die Kontrollkästchen keine eindeutigen Objektnamen. LiveCycle Designer weist daher einen Instanzwert zu, damit ein Objekt referenziert werden kann. Das Skript für Kontrollkästchen enthält eine if-else-Anweisung, um eine Aktivierung und Deaktivierung zu ermöglichen.
Dieses und andere Beispiele zur Skripterstellung finden Sie im LiveCycle Developer Center unter www.adobe.com/devnet/livecycle.
Skripten für das Kontrollkästchen „Feld verschieben“
Wenn das Kontrollkästchen aktiviert wird, wird das Feld den x- und y-Einstellungen entsprechend verschoben. Wenn das Kontrollkästchen deaktiviert wird, wird das Feld an seine ursprüngliche Position zurückgesetzt.
if (CheckBox1.rawValue == true) {
    TextField.x = "3.0in";
    TextField.y = "3.5in";
}
else {
    TextField.x = "1in";
    TextField.y = "3in";
}
Skripten für das Kontrollkästchen „Feldbreite vergrößern“
Wenn das Kontrollkästchen aktiviert wird, wird die Feldbreite auf 4 Zoll erhöht. Wenn das Kontrollkästchen deaktiviert wird, wird die Feldbreite auf 2,5 Zoll verringert.
if (CheckBox2.rawValue == true)
    TextField.w = "4in";
else
    TextField.w = "2.5in";
Skripten für das Kontrollkästchen „Feldhöhe vergrößern“
Wenn das Kontrollkästchen aktiviert wird, wird die Feldhöhe auf 1,5 Zoll gesteigert. Wenn das Kontrollkästchen deaktiviert wird, wird die Feldhöhe auf 0,5 Zoll verringert.
if (CheckBox3.rawValue == true)
    TextField.h = "1.5in";
else
    TextField.h = "0.5in";
Skripten für das Kontrollkästchen „Objektrandfarbe ändern“
Wenn das Kontrollkästchen aktiviert wird, wird dem Feldrand die Farbe Rot zugewiesen. Wenn das Kontrollkästchen deaktiviert wird, wird dem Feldrand die Farbe Weiß zugewiesen.
if (CheckBox4.rawValue == true)
    TextField.border.edge.color.value = "255,0,0";
else
    TextField.border.edge.color.value = "255,255,255";
Skripten für das Kontrollkästchen „Füllfarbe des ausfüllbaren Bereichs ändern“
Wenn das Kontrollkästchen aktiviert wird, wird dem Füllbereich des Textfelds die Farbe Grün zugewiesen. Wenn das Kontrollkästchen deaktiviert wird, wird dem Füllbereich des Textfelds die Farbe Weiß zugewiesen.
if (CheckBox5.rawValue == true) {
    xfa.resolveNode("TextField.ui.#textEdit.border.fill.color").value = "0,255,0";
}
else {
    xfa.resolveNode("TextField.ui.#textEdit.border.fill.color").value = "255,255,255";
}
Skripten für das Kontrollkästchen „Passend auf Breite des Werts erweitern“
Wenn das Kontrollkästchen aktiviert wird, wird der Füllbereich des Textfelds an den Wert angepasst. Wenn das Kontrollkästchen deaktiviert wird, wird der Füllbereich des Textfelds nicht an den Wert angepasst.
if (CheckBox6.rawValue == true)
    TextField.minW = "0.25in";
else
    TextField.maxW = "2.5in";
Skripten für das Kontrollkästchen „Feld ausblenden“
Wenn das Kontrollkästchen aktiviert wird, wird das Feld ausgeblendet. Wenn das Kontrollkästchen deaktiviert wird, ist das Feld sichtbar.
if (CheckBox7.rawValue == true)
    TextField.presence = "hidden";
else
    TextField.presence = "visible";
Skripten für das Kontrollkästchen „Schrift des Werts ändern“
Wenn das Kontrollkästchen aktiviert wird, wird dem Wert die Schrift Courier New zugewiesen. Wenn das Kontrollkästchen deaktiviert wird, wird dem Wert die Schrift Myriad Pro zugewiesen.
if (CheckBox8.rawValue == true)
    TextField.font.typeface = "Courier New";
else
    TextField.font.typeface = "Myriad Pro";
Skripten für das Kontrollkästchen „Schriftgröße ändern“
Wenn das Kontrollkästchen aktiviert wird, wird die Schriftgröße auf 14 Pt eingestellt. Wenn das Kontrollkästchen deaktiviert wird, wird die Schriftgröße auf 10 Pt eingestellt.
if (CheckBox9.rawValue == true)
    TextField.font.size = "14pt";
else
    TextField.font.size = "10pt";
Skripten für das Kontrollkästchen „Textfeldwert vertikal ausrichten“
Wenn das Kontrollkästchen aktiviert wird, wird der Textfeldwert an der oberen Kante ausgerichtet. Wenn das Kontrollkästchen deaktiviert wird, wird der Textfeldwert an der Mitte ausgerichtet.
if (CheckBox10.rawValue == true)
    TextField.para.vAlign = "top";
else
    TextField.para.vAlign = "middle";
Skripten für das Kontrollkästchen „Textfeldwert horizontal ausrichten“ erstellen
Wenn das Kontrollkästchen aktiviert wird, wird der Textfeldwert an der Mitte ausgerichtet. Wenn das Kontrollkästchen deaktiviert wird, wird der Textfeldwert an der linken Kante ausgerichtet.
if (CheckBox11.rawValue == true)
    TextField.para.hAlign = "center";
else
    TextField.para.hAlign = "left";
Skripten für das Kontrollkästchen „Vorgegebenen Wert anzeigen“
Wenn das Kontrollkästchen aktiviert wird, wird im Textfeld ein durch ein Skript definierter Wert angezeigt. Wenn das Kontrollkästchen deaktiviert wird, wird im Textfeld der (ebenfalls durch ein Skript definierte) Standardwert angezeigt.
if (CheckBox12.rawValue == true)
    TextField.rawValue = "This is a value set using a script.";
else
    TextField.rawValue = "This is a default value.";
Skripten für das Kontrollkästchen „Beschriftungstext ändern“
Wenn das Kontrollkästchen aktiviert wird, wird der durch ein Skript definierte, alternative Beschriftungstext angezeigt. Wenn das Kontrollkästchen deaktiviert wird, wird die (ebenfalls durch ein Skript definierte) Standardbeschriftung angezeigt.
if (CheckBox13.rawValue == true)
    xfa.resolveNode("TextField.caption.value.#text").value = "Alternate Caption:";
else
    xfa.resolveNode("TextField.caption.value.#text").value = "Caption:";
Skripten für das Kontrollkästchen „Feldrand von 3D in ausgefülltes Rechteck ändern“
Wenn das Kontrollkästchen aktiviert wird, wird der Feldrand in ein ausgefülltes Rechteck geändert. Wenn das Kontrollkästchen deaktiviert wird, wird dem Feldrand ein 3D-Stil zugewiesen.
if (CheckBox14.rawValue == true)
    xfa.resolveNode("TextField.ui.#textEdit.border.edge").stroke = "solid";
else
    xfa.resolveNode("TextField.ui.#textEdit.border.edge").stroke = "lowered";
Skripten für die Schaltfläche „Alle Kontrollkästchen deaktivieren“
Mit der Methode resetData können Sie sämtliche Kontrollkästchen auf ihren Standardwert (Aus) zurücksetzen.
    xfa.host.resetData();
Führen Sie den Formularentwurf und die Formulardaten mit der Methode remerge erneut zusammen. In diesem Fall stellt die Methode das Textfeld in seinem Originalzustand wieder her.
    xfa.form.remerge();


Aktuellen oder vorherigen Wert einer Dropdown-Liste abrufen

Dieses Beispiel zeigt, wie Sie den aktuellen Wert einer Dropdown-Liste abrufen und welche Möglichkeiten Sie haben, auf den vorherigen Wert einer Dropdown-Liste in einem Formular zuzugreifen. Abgesehen von den eigentlichen Skripten, durch welche die aktuellen und vorherigen Werte festgelegt werden, ist auch wichtig, dass sich die Skripten im Ereignis change für die Dropdown-Liste befinden.
Im folgenden Beispiel wird, wenn ein Formularbenutzer in der Dropdown-Liste einen Wert auswählt, der ausgewählte Wert im Feld „Aktueller Wert“ angezeigt. Wenn der Formularbenutzer dann einen anderen Wert in der Dropdown-Liste auswählt, wird dieser neue Wert in der Liste „Aktueller Wert“ angezeigt und der vorherige Wert im Feld „Vorheriger Wert 1“.
Die verschiedenen Methoden zum Abrufen des vorherigen Wertes einer Dropdown-Liste beruhen jeweils auf einem anderen Skript. Das Textfeld „Vorheriger Wert 1“ wird durch eine direkte Referenz zur Eigenschaft rawValue der Dropdown-Liste ausgefüllt, das Textfeld „Vorheriger Wert 2“ hingegen mit Hilfe der Eigenschaft prevText. Damit Sie konsistente Ergebnisse erzielen, sollten Sie auf den vorherigen Wert über die Eigenschaft prevText zugreifen.
Dieses und andere Beispiele zur Skripterstellung finden Sie im LiveCycle Developer Center unter www.adobe.com/devnet/livecycle.
Skripten zum Ausfüllen des Textfelds „Aktueller Wert“
Wenn Sie das Textfeld „Aktueller Wert“ ausfüllen möchten, verwenden Sie die Eigenschaft newText:
    CurrentValue.rawValue = xfa.event.newText;
Skripten zum Ausfüllen des Textfelds „Vorheriger Wert 1“
Wenn Sie das Textfeld „Vorheriger Wert 1“ ausfüllen möchten, referenzieren Sie die Eigenschaft rawValue der Dropdown-Liste:
    PreviousValue1.rawValue = DropDownList.rawValue;
Skripten zum Ausfüllen des Textfelds „Vorheriger Wert 2“
Wenn Sie das Textfeld „Vorheriger Wert 2“ ausfüllen möchten, verwenden Sie die Eigenschaft prevText:
    PreviousValue2.rawValue = xfa.event.prevText;


Höhe eines Feldes zur Laufzeit anpassen

Dieses Beispiel zeigt, wie Sie ein Feld erweitern, um es an die Höhe des Inhalts in einem anderen Feld anzupassen.
In diesem Beispiel wird, wenn der Formularbenutzer in TextField1 mehrere Zeilen eingibt und dann auf die Schaltfläche „Erweitern“ klickt, die Höhe von TextField2 vergrößert und somit an die Höhe von TextField1 angepasst.
Dieses und andere Beispiele zur Skripterstellung finden Sie im LiveCycle Developer Center unter www.adobe.com/devnet/livecycle.
Skripten für die Schaltfläche „Erweitern“
Das folgende Skript wurde für die Schaltfläche „Erweitern“ erstellt:
    var newHeight = xfa.layout.h(TextField1, "in");
    TextField2.h = newHeight + "in";


Felder zur Laufzeit als „Erforderlich“ festlegen

Dieses Beispiel zeigt, wie Sie ein Feld zur Laufzeit als „Erforderlich“ festlegen.
In diesem Beispiel wird, wenn auf die Schaltfläche „Als 'Erforderlich' festlegen“ geklickt wurde und ein Formularbenutzer versucht, ein Formular zu senden, ohne vorher das Feld „TextField1“ auszufüllen, eine entsprechende Fehlermeldung eingeblendet.
Dieses und andere Beispiele zur Skripterstellung finden Sie im LiveCycle Developer Center unter www.adobe.com/devnet/livecycle.
Skripten für die Schaltfläche „Als 'Erforderlich' festlegen“
Das folgende Skript wurde für die Schaltfläche „Als 'Erforderlich' festlegen“ erstellt:
    TextField1.validate.nullTest = "error";
Alternativ können Sie auch eines der beiden folgenden Skripten verwenden:
TextField1.mandatory = "error"
TextField1.mandatoryMessage = "this field is mandatory!"


Feldsummen berechnen

Dieses Beispiel zeigt, wie Sie die Summen von Feldern berechnen, die sich auf unterschiedlichen Ebenen der Formularhierarchie befinden, wenn der Formularbenutzer das Formular in einer Client-Anwendung wie Acrobat Professional, Adobe Reader oder einem HTML-Client öffnet.
Dieses und andere Beispiele zur Skripterstellung finden Sie im LiveCycle Developer Center unter www.adobe.com/devnet/livecycle.
Skripten zur Berechnung der Summe sich wiederholender Felder in einem Formular
Zur Berechnung der Summe sich wiederholender Felder in einem Formular fügen Sie dem Feld „Summe“ ein calculate-Ereignis hinzu:
var fields = xfa.resolveNodes("NumericField1[*]");

var total = 0;
for (var i=0; i <= fields.length-1; i++) {
    total = total + fields.item(i).rawValue;
}

this.rawValue = total;
Skripten zur Berechnung der Summe sich wiederholender Felder
Zur Berechnung der Summe sich wiederholender Felder fügen Sie dem Feld „Summe“ ebenfalls ein calculate-Ereignis hinzu:
var fields = xfa.resolveNodes("detail[*].NumericField1");

var total = 0;
for (var i=0; i <= fields.length-1; i++) {
    total = total + fields.item(i).rawValue;
}

this.rawValue = total;
Skripten zur Berechnung der Summe der Felder auf der Seite
Zur Berechnung der Summe der Felder auf der Seite fügen Sie dem Feld „Summe“ ein calculate-Ereignis hinzu:
var fields = xfa.layout.pageContent(0 , "field", 0);

var total = 0;
for (var i=0; i <= fields.length-1; i++) {
    if (fields.item(i).name == "NumericField1") {
           total = total + fields.item(i).rawValue;
       }
}

this.rawValue = total;


Felder als Reaktion auf Benutzeraktionen hervorheben

Dieses Beispiel zeigt, wie Sie das aktuelle Feld hervorheben, das ein Formularbenutzer gerade bearbeitet, wie Sie die Felder hervorheben, die Formularbenutzer ausfüllen müssen und wie Sie den Formularbenutzern Feedback in Form von Meldungsfeldern liefern.
In diesem Beispiel erscheint rechts neben den erforderlichen Feldern ein Sternchen (*). Wenn ein Feld ausgewählt wird, wird dem Feldrand die Farbe Blau zugewiesen. Wenn ein Formularbenutzer auf die Schaltfläche „Daten überprüfen“ klickt, aber nicht alle erforderlichen Felder ausgefüllt hat, wird eine Meldung angezeigt und das Feld rot markiert. Wenn alle erforderlichen Felder ausgefüllt wurden und der Formularbenutzer auf die Schaltfläche „Daten überprüfen“ klickt, wird eine Bestätigungsmeldung eingeblendet.
Dieses und andere Beispiele zur Skripterstellung finden Sie im LiveCycle Developer Center unter www.adobe.com/devnet/livecycle.
Skripten zum Kennzeichnen eines ausgewählten Feldes mit einem blauen Rand
Zum Kennzeichnen des ausgewählten Feldes durch einen blauen Rand fügen Sie allen Textfeldern die folgenden Skripten hinzu:
Fügen Sie dem Feld „Name“ beispielsweise ein enter-Ereignis hinzu:
    Name.border.edge.color.value = "0,0,255";
Fügen Sie dem Feld „Name“ beispielsweise ein exit-Ereignis hinzu:
    Name.border.edge.color.value = "255,255,255";
Fügen Sie dem Feld „Name“ beispielsweise ein mouseEnter-Ereignis hinzu:
    Name.border.edge.color.value = "0,0,255";
Fügen Sie dem Feld „Name“ beispielsweise ein mouseExit-Ereignis hinzu:
    Name.border.edge.color.value = "255,255,255";
Skripten für die Schaltfläche „Daten überprüfen“
Das folgende Skript, das speziell für die Schaltfläche „Daten überprüfen“ konzipiert wurde, stellt anhand einiger Überprüfungsschritte fest, ob die erforderlichen Felder Daten enthalten. Dabei wird jedes Feld einzeln überprüft und festgestellt, ob der Feldwert nicht null oder eine leere Zeichenfolge ist. Ist der Feldwert null oder eine leere Zeichenfolge, wird ein Hinweis eingeblendet, welcher den Benutzer daran erinnert, dass dieses Feld ausgefüllt werden muss. Gleichzeitig wird die Hintergrundfarbe des Füllbereichs in Rot geändert.
Verwenden Sie diese Variable, um anzugeben, ob ein Feld keine Daten enthält:
var iVar = 0;

if ((Name.rawValue == null) || (Name.rawValue == "")) {
    app.alert("Please enter a value in the Name field.");
Dieses Skript ändert die Farbe des Füllbereichs des Textfelds:
    xfa.resolveNode("Name.ui.#textEdit.border.edge").stroke = "solid";
    xfa.resolveNode("Name.ui.#textEdit.border.fill.color").value = "255,100,50";

    // Set the variable to indicate that this field does not contain data.
    iVar = 1;
}
else {
    // Reset the fillable area of the text field.
    xfa.resolveNode("Name.ui.#textEdit.border.edge").stroke = "lowered";
    xfa.resolveNode("Name.ui.#textEdit.border.fill.color").value = "255,255,255";
}

if ((Address.rawValue == null) || (Address.rawValue == "")) {
    app.alert("Please enter a value in the Address field.");
Dieses Skript ändert die Farbe des Füllbereichs des Textfelds:
    xfa.resolveNode("Address.ui.#textEdit.border.edge").stroke = "solid";
    xfa.resolveNode("Address.ui.#textEdit.border.fill.color").value = "255,100,50";
Dieses Skript stellt die Variable ein, die angibt, dass dieses Feld keine Daten enthält:
    iVar = 1;
}
else {
Dieses Skript setzt den Füllbereich des Textfelds zurück:
    xfa.resolveNode("Address.ui.#textEdit.border.edge").stroke = "lowered";
    xfa.resolveNode("Address.ui.#textEdit.border.fill.color").value = "255,255,255";
}

if ((City.rawValue == null) || (City.rawValue == "")) {
    app.alert("Please enter a value in the City field.");

Dieses Skript ändert die Farbe des Füllbereichs des Textfelds:
    xfa.resolveNode("City.ui.#textEdit.border.edge").stroke = "solid";
    xfa.resolveNode("City.ui.#textEdit.border.fill.color").value = "255,100,50";
Dieses Skript stellt die Variable ein, die angibt, dass dieses Feld keine Daten enthält:
    iVar = 1;
}
else {
Dieses Skript setzt den Füllbereich des Textfelds zurück:
    xfa.resolveNode("City.ui.#textEdit.border.edge").stroke = "lowered";
    xfa.resolveNode("City.ui.#textEdit.border.fill.color").value = "255,255,255";
}

if ((State.rawValue == null) || (State.rawValue == "")) {
    app.alert("Please enter a value in the State field.");
Dieses Skript ändert die Farbe des Füllbereichs des Textfelds:
    xfa.resolveNode("State.ui.#textEdit.border.edge").stroke = "solid";
    xfa.resolveNode("State.ui.#textEdit.border.fill.color").value = "255,100,50";
Dieses Skript stellt die Variable ein, die angibt, dass dieses Feld keine Daten enthält:
    iVar = 1;
}
else {
Dieses Skript setzt den Füllbereich des Textfelds zurück:
    xfa.resolveNode("State.ui.#textEdit.border.edge").stroke = "lowered";
    xfa.resolveNode("State.ui.#textEdit.border.fill.color").value = "255,255,255";
}

if ((ZipCode.rawValue == null) || (ZipCode.rawValue == "")) {
    app.alert("Please enter a value in the Zip Code field.");

Dieses Skript ändert die Farbe des Füllbereichs des Textfelds:
    xfa.resolveNode("ZipCode.ui.#textEdit.border.edge").stroke = "solid";
    xfa.resolveNode("ZipCode.ui.#textEdit.border.fill.color").value = "255,100,50";
Dieses Skript stellt die Variable ein, die angibt, dass dieses Feld keine Daten enthält:
    iVar = 1;
}
else {
Dieses Skript setzt den Füllbereich des Textfelds zurück:
    xfa.resolveNode("ZipCode.ui.#textEdit.border.edge").stroke = "lowered";
    xfa.resolveNode("ZipCode.ui.#textEdit.border.fill.color").value = "255,255,255";
}

if ((Country.rawValue == null) || (Country.rawValue == "")) {
    app.alert("Please enter a value in the Country field.");
Dieses Skript ändert die Farbe des Füllbereichs des Textfelds:
    xfa.resolveNode("Country.ui.#textEdit.border.edge").stroke = "solid";
    xfa.resolveNode("Country.ui.#textEdit.border.fill.color").value = "255,100,50";

Dieses Skript stellt die Variable ein, die angibt, dass dieses Feld keine Daten enthält:
    iVar = 1;
}
else {
Dieses Skript setzt den Füllbereich des Textfelds zurück:
    xfa.resolveNode("Country.ui.#textEdit.border.edge").stroke = "lowered";
    xfa.resolveNode("Country.ui.#textEdit.border.fill.color").value = "255,255,255";
}
Wenn alle erforderlichen Felder Daten enthalten, wird die Variable iVar auf 0 gesetzt und eine Bestätigungsmeldung angezeigt:
    if (iVar == 0) {
        app.alert("Thank you for inputting your information.");
    }


Die Werte des aktuellen Teilformulars zurücksetzen

Dieses Beispiel zeigt, wie Sie die Werte eines bestimmten Satzes von Feldern zurücksetzen, nicht aber die Werte des gesamten Formulars. Dazu setzen Sie nur die Felder im erforderlichen Teilformularobjekt zurück.
In diesem Beispiel kann der Formularbenutzer die Feldwerte durch Klicken auf die Schaltfläche „Löschen“ zurücksetzen.
Dieses und andere Beispiele zur Skripterstellung finden Sie im LiveCycle Developer Center unter www.adobe.com/devnet/livecycle.
Skripten für die Werte in der linken Spalte
Geben Sie dieses Skript für die Werte ein, die in der linken Spalte angezeigt werden:
    this.rawValue = this.parent.index + 1;
Um die Standardwerte wiederherzustellen, fügen Sie der Schaltfläche „Löschen“ ein click-Ereignis hinzu. Sie benötigen einen dynamischen Referenz-Syntax-Ausdruck, weil es sich hier um ein sich wiederholendes Teilformular handelt, was im Referenz-Syntax-Ausdruck berücksichtigt werden muss. In diesem Fall ist es einfacher, die resetData-Parameter einzeln zu erstellen.
    var f1 = this.parent.somExpression + ".TextField2" + ",";
    var f2 = f1 + this.parent.somExpression + ".DropDownList1" + ",";
    var f3 = f2 + this.parent.somExpression + ".NumericField1";

    // ...and pass the variable as a parameter.
    xfa.host.resetData(f3);


Präsenz von Formularentwurfsobjekten ändern

LiveCycle Designer bietet auf verschiedenen Registerkarten der Palette „Objekt“ die folgenden Präsenzeinstellungen für die Objekte in einem Formular. Die Einstellungen „Unsichtbar“ und „Ausgeblendet (Aus Layout ausschließen)“ sind nicht für Gruppen, Inhaltsbereiche, Masterseiten, Seitensätze und Objekte von Teilformularsätzen verfügbar.
Um die Präsenzeinstellung eines Objekts mit Hilfe von Skripten zu ändern, müssen Sie den Wert zweier zugrunde liegender XML Form Object Model-Eigenschaften ändern: presence und relevant.
In der folgenden Tabelle finden Sie eine Übersicht über die Präsenzeinstellungen und die zugehörige Referenz-Syntax.

Präsenzeinstellung

Referenz-Syntax
Sichtbar
FormCalc
ObjectName.presence = "visible"
JavaScript
ObjectName.presence = "visible";
Sichtbar (nur Bildschirm)
FormCalc
ObjectName.presence = "visible"
ObjectName.relevant = „-print“
JavaScript
ObjectName.presence = "visible";
ObjectName.relevant = „-print“;
Sichtbar (nur drucken)
FormCalc
ObjectName.presence = "visible"
ObjectName.relevant = „+print“
JavaScript
ObjectName.presence = "visible";
ObjectName.relevant = „+print“;
Unsichtbar
FormCalc
ObjectName.presence = "invisible"
JavaScript
ObjectName.presence = "invisible";
Ausgeblendet (Aus Layout ausschließen)
FormCalc
ObjectName.presence = "hidden"
JavaScript
ObjectName.presence = "hidden";
Verwandte Themen
So ändern Sie die Standardformatierung für neue Objekte


Teilformulare mit Hilfe der Eigenschaften des Instanzmanagers steuern

Dieses Beispiel zeigt, wie Sie mit den Eigenschaften des Instanzmanagers (der zum XML Form Object Model gehört) zur Laufzeit Informationen über Teilformulare abrufen.
Im folgenden Formular nutzen die vier Schaltflächen die Skripteigenschaften des Instanzmanangers und liefern Informationen über Subform1. Wenn ein Formularbenutzer beispielsweise auf die Schaltfläche „Max“ klickt, wird eine Meldung eingeblendet, welche die maximal zulässige Anzahl unterstützter Subform1-Instanzen angibt.
Skripten zur Ausgabe des Wertes der Eigenschaft „count“ im Meldungsfeld
Dieses Skript verwendet die Methode messageBox, um den Wert der Eigenschaft count auszugeben:
    xfa.host.messageBox("The current number of Subform1 instances on the
    form is:" „+ properties.Subform1.instanceManager.count, „Instance Manager
    Properties“,3);
Sie können dieses Skript auch mit der Unterstrich-Notation (_) schreiben, um die Eigenschaft count des Instanzmanagers zu referenzieren, wie in diesem Beispiel:
    xfa.host.messageBox("The current number of Subform1 instances on the form
    is: " + properties._Subform1.count, "Instance Manager Properties", 3);
Die Unterstrich-Notation (_) ist besonders wichtig, wenn das Formular zurzeit keine Teilformularinstanzen enthält.
Skripten zur Ausgabe des Wertes der Eigenschaft „max“ im Meldungsfeld
Dieses Skript verwendet die Methode messageBox, um den Wert der Eigenschaft max auszugeben:
    xfa.host.messageBox("The maximum number of instances allowed for Subform1
    is: " + properties.Subform1.instanceManager.max, „Instance Manager
    Properties", 3);
Sie können dieses Skript auch mit der Unterstrich-Notation (_) schreiben, um die Eigenschaft max des Instanzmanagers zu referenzieren, wie in diesem Beispiel:
    xfa.host.messageBox("The maximum number of instances allowed for Subform1
    is: " + properties._Subform1.max, „Instance Manager Properties", 3);
Skripten zur Ausgabe des Wertes der Eigenschaft „min“ im Meldungsfeld
Dieses Skript verwendet die Methode messageBox, um den Wert der Eigenschaft min auszugeben:
    xfa.host.messageBox("The minimum number of instances allowed for Subform1
    is: " + properties.Subform1.instanceManager.min, „Instance Manager
    Properties", 3);
Sie können dieses Skript auch mit der Unterstrich-Notation (_) schreiben, um die Eigenschaft min des Instanzmanagers zu referenzieren, wie in diesem Beispiel:
    xfa.host.messageBox("The minimum number of instances allowed for Subform1
    is: " + properties._Subform1.min, „Instance Manager Properties", 3);
Skripten zur Ausgabe des Namens der Teilformulareigenschaft im Meldungsfeld
Das folgende Skript verwendet die Methode messageBox, um den Namen der Eigenschaft subform auszugeben:
    xfa.host.messageBox("The name of the subform using the instance manager name
    property is: " + properties.Subform1.instanceManager.name +
    ".\n\nNote: This value is different than the value returned by the name
    property for the Subform1 object." , „Instance Manager Properties", 3);
Sie können dieses Skript auch mit der Unterstrich-Notation (_) schreiben, um die Eigenschaft „name“ des Instanzmanagers zu referenzieren, wie in diesem Beispiel:
    xfa.host.messageBox("The name of the subform using the instance manager name
    property is: " + properties._Subform1.name +
    ".\n\nNote: This value is different than the value returned by the name
    property for the Subform1 object." , „Instance Manager Properties", 3);


Teilformulare mit Hilfe der Methoden des Instanzmanagers steuern

Dieses Beispiel demonstriert, wie Sie mit den Methoden des Instanzmanagers (der zum XML Form Object Model gehört) zur Laufzeit Vorgänge für Teilformularobjekte durchführen. Beispielsweise können Sie Instanzen eines bestimmten Teilformulars, einer Tabelle oder einer Tabellenzeile hinzufügen oder entfernen.
Im folgenden Formular verwendet der Formularbenutzer die vier Schaltflächen, um die verschiedenen Skriptmethoden des Instanzmanagers zu einzusetzen. Wenn der Formularbenutzer beispielsweise auf die Schaltfläche „Hinzufügen“ klickt, wird dem Formular eine neue Subform2-Instanz hinzugefügt.
Die Schaltfläche „Verschieben“ ordnet die ersten beiden Subform2-Instanzen neu an und die Schaltfläche „Festlegen“ zeigt die Höchstanzahl der Subform2-Instanzen an. In beiden Fällen müssen Sie möglicherweise Teilformulare hinzufügen oder entfernen oder die Daten in den Textfeldern ändern, um die auf die Subform2-Instanzen angewendeten Änderungen sehen zu können.
Skripten zum Feststellen, ob einem Formular die Höchstanzahl von Teilformularen hinzugefügt wurde
Das folgende Skript ermittelt, ob die maximal unterstützte Anzahl von Subform2-Instanzen bereits im Formular vorhanden ist. Falls ja, wird eine entsprechende Meldung eingeblendet. Falls nein, wird dem Formular eine neue Subform2-Instanz hinzugefügt.
    if (methods.Subform2.instanceManager.count ==
    methods.Subform2.instanceManager.max) {
    xfa.host.messageBox("You have reached the maximum number of items allowed.",
    "Instance Manager Methods", 1);
}
    else {
    methods.Subform2.instanceManager.addInstance(1);
    xfa.form.recalculate(1);
}
Sie können dieses Skript auch mit der Unterstrich-Notation (_) schreiben, um die Eigenschaften und Methoden des Instanzmanagers zu referenzieren, wie in diesem Beispiel:
    if (methods._Subform2.count == methods._Subform1.max) {
         xfa.host.messageBox("You have reached the maximum number of items
        allowed.", „Instance Manager Methods“, 1);
}
    else {
        methods._Subform2.addInstance(1);
        xfa.form.recalculate(1);
}
Skripten zum Feststellen, ob aus dem Formular weitere Teilformulare entfernt werden können
Das folgende Skript ermittelt, ob das Formular Subform2-Instanzen enthält. Falls nein, wird eine entsprechende Meldung eingeblendet. Falls ja, wird die erste Instanz aus dem Formular entfernt.
    if (methods.Subform2.instanceManager.count == 0) {
        xfa.host.messageBox("There are no subform instances to remove.",
        "Instance Manager Methods", 1);
    }
    else {
        methods.Subform2.instanceManager.removeInstance(0);
        xfa.form.recalculate(1);
    }
Sie können dieses Skript auch mit der Unterstrich-Notation (_) schreiben, um die Eigenschaften und Methoden des Instanzmanagers zu referenzieren, wie in diesem Beispiel:
    if (methods._Subform2.count == 0) {
        xfa.host.messageBox("There are no subform instances to remove.",
        "Instance Manager Methods", 1);
    }
    else {
        methods._Subform2.removeInstance(0);
        xfa.form.recalculate(1);
    }
Skripten zum Festlegen, dass im Formular vier Teilformularinstanzen erscheinen sollen
Das folgende Skript bewirkt, dass im Formular vier Subform2-Instanzen erscheinen, unabhängig davon, wie viele Instanzen zurzeit vorhanden sind:
    methods.Subform2.instanceManager.setInstances(4);
Sie können dieses Skript auch mit der Unterstrich-Notation (_) schreiben, um die Eigenschaften und Methoden des Instanzmanagers zu referenzieren, wie in diesem Beispiel:
    methods._Subform2.setInstances(4);
Skripten zum Vertauschen des ersten und zweiten Teilformulars im Formular
Das folgende Skript weist die erste und zweite Subform2-Instanz an, auf dem Formular die Position zu tauschen.
    methods.Subform2.instanceManager.moveInstance(0,1);
Sie können dieses Skript auch mit der Unterstrich-Notation (_) schreiben, um die Eigenschaften und Methoden des Instanzmanagers zu referenzieren, wie in diesem Beispiel:
    methods._Subform2.moveInstance(0,1);


Teilformulare mit Hilfe des Instanzmanagers zur Laufzeit steuern

Dieses Beispiel zeigt, wie Sie mit den Eigenschaften und Methoden des Instanzmanagers zur Laufzeit Informationen über Teilformulare abrufen und Vorgänge für Teilformularobjekte durchführen.
In diesem Beispiel verwendet der Formularbenutzer die Schaltflächen, um mit Hilfe von Subform3-Instanzen verschiedene Aktionen auszuführen. Wenn ein Formularbenutzer beispielsweise auf die Schaltfläche „Instanz unten einfügen“ klickt, wird unterhalb der aktuellen Instanz eine neue Subform3-Instanz eingefügt.
Möglicherweise ist es erforderlich, Teilformulare hinzuzufügen oder zu entfernen oder die Daten im Textfeld ändern, um die auf die Subform3-Instanzen angewendeten Änderungen sehen zu können.
Skripten für die Schaltfläche „Neues Teilformular hinzufügen“
Das folgende Skript ermittelt, ob die maximal unterstützte Anzahl von Subform3-Instanzen bereits im Formular vorhanden ist. Falls ja, wird eine entsprechende Meldung eingeblendet. Falls nein, wird dem Formular eine neue Subform3-Instanz hinzugefügt.
    if (advanced.Subform3.instanceManager.count ==
        advanced.Subform3.instanceManager.max) {
        xfa.host.messageBox("You have reached the maximum number of items
        allowed.","Combining Instance Manager Concepts", 1);
}
    else {
        advanced.Subform3.instanceManager.addInstance(1);
        xfa.form.recalculate(1);
}
Sie können dieses Skript auch mit der Unterstrich-Notation (_) schreiben, um die Eigenschaften und Methoden des Instanzmanagers zu referenzieren, wie in diesem Beispiel:
    if (advanced._Subform3.count == advanced._Subform3.max) {
        xfa.host.messageBox("You have reached the maximum number of items
        allowed.", „Combining Instance Manager Concepts“, 1);
    }
    else {
        advanced._Subform3.addInstance(1);
        xfa.form.recalculate(1);
    }
Skripten für die Schaltfläche „Teilformular entfernen“
Das folgende Skript ermittelt, ob das Formular Subform3-Instanzen enthält. Falls nein, wird eine entsprechende Meldung eingeblendet. Falls ja, wird die erste Instanz aus dem Formular enthält.
    if (advanced.Subform3.instanceManager.count == 0) {
        xfa.host.messageBox("There are no subform instances to remove.",
        "Combining Instance Manager Concepts", 1);
    }
    else {
        advanced.Subform3.instanceManager.removeInstance(0);
    }
Sie können dieses Skript auch mit der Unterstrich-Notation (_) schreiben, um die Eigenschaften und Methoden des Instanzmanagers zu referenzieren, wie in diesem Beispiel:
    if (advanced._Subform3.count == 0) {
        xfa.host.messageBox("There are no subform instances to remove.",
        "Combining Instance Manager Concepts", 1);
    }
    else {
        advanced._Subform3.removeInstance(0);
    }
Skripten für die Schaltfläche „Instanz unten einfügen“
Die folgende if-else-Anweisung verhindert die Fortsetzung des Skriptes, falls das Formular zurzeit die maximal zulässige Anzahl von Subform3-Instanzen enthält:
    if (Subform3.instanceManager.count < Subform3.instanceManager.occur.max) {
//oNewInstance stores an instance of Subform3 created by the addInstance() method.
    var oNewInstance = Subform3.instanceManager.addInstance(1);
//nIndexFrom and nIndexTo store the before and after index values to use with the moveInstance() method.
    var nIndexFrom = oNewInstance.index;
    var nIndexTo = Subform3.index + 1;
In diesem Fall wird, wenn das Skript den Wert für nIndexFrom referenziert, dem Formular an der von der Methode moveInstance angegebenen Stelle eine neue Instanz von Subform3 hinzugefügt:
        Subform3.instanceManager.moveInstance(nIndexFrom, nIndexTo);
    }
    else {
        xfa.host.messageBox("You have reached the maximum number of items
        allowed.", „Combining Instance Manager Concepts", 1);
    }
Sie können dieses Skript auch mit der Unterstrich-Notation (_) schreiben, um die Eigenschaften und Methoden des Instanzmanagers zu referenzieren, wie in diesem Beispiel:
    if (_Subform3.count < _Subform3.occur.max) {
    var oNewInstance = _Subform3.addInstance(1);
    var nIndexFrom = oNewInstance.index;
    var nIndexTo = Subform3.index + 1;
    _Subform3.moveInstance(nIndexFrom, nIndexTo);
    }
    else {
    xfa.host.messageBox("You have reached the maximum number of items allowed.", 		"Combining Instance Manager Concepts", 1);
    }
Skripten für die Schaltfläche „Diese Instanz löschen“
Die folgende if-else-Anweisung verhindert die Fortsetzung des Skriptes, falls das Formular zurzeit die mindestens erforderliche Anzahl von Subform3-Instanzen enthält:
    if (Subform3.instanceManager.count > Subform3.instanceManager.occur.min) {
Dieses Skript entfernt mit Hilfe der Methode removeInstance eine Instanz von Subform3.
Dieses Skript gibt mit dem Wert parent.parent.index an, welche Subform3-Instanz entfernt werden muss. Die parent-Referenz bezeichnet den Container des Objekts, welches die Referenz verwendet. In diesem Fall würde die Referenz parent.index das unbenannte Teilformular bezeichnen, welches die Schaltflächen „Instanz unten einfügen“, „Diese Instanz löschen“, „Eine Zeile nach oben“ und „Eine Zeile nach unten“ enthält.
        Subform3.instanceManager.removeInstance(parent.parent.index);
    }
    else {
        xfa.host.messageBox("You have reached the minimum number of items
        allowed.", „Combining Instance Manager Concepts", 1);
    }
Sie können dieses Skript auch mit der Unterstrich-Notation (_) schreiben, um die Eigenschaften und Methoden des Instanzmanagers zu referenzieren, wie in diesem Beispiel:
    if (_Subform3.count > _Subform3.occur.min) {
    Subform3.removeInstance(Subform3.index);
    }
    else {
    xfa.host.messageBox("You have reached the minimum number of items allowed.",
    "Combining Instance Manager Concepts", 1);
    }
Skripten für die Schaltfläche „Eine Zeile nach oben“
Die folgende if-else-Anweisung verhindert die Fortsetzung des Skriptes, falls die Instanz von Subform3 als erste Instanz in der Liste aufgeführt wird:
    if (Subform3.index != 0) {
//nIndexFrom and nIndexTo store the before and after index values to use with the moveInstance method.
        var nIndexFrom = Subform3.index;
        var nIndexTo = Subform3.index - 1;
        Subform3.instanceManager.moveInstance(nIndexFrom, nIndexTo);
    }
    else {
        xfa.host.messageBox("The current item cannot be moved because it is the
        first instance in the list.", „Combining Instance Manager Concepts“, 1);
    }
Sie können dieses Skript auch mit der Unterstrich-Notation (_) schreiben, um die Eigenschaften und Methoden des Instanzmanagers zu referenzieren, wie in diesem Beispiel:
    if (Subform3.index != 0) {
        var nIndexFrom = Subform3.index;
    var nIndexTo = Subform3.index - 1;
    Subform3.moveInstance(nIndexFrom, nIndexTo);
    }
    else {
    xfa.host.messageBox("The current item can't be moved since it already is the 	first instance in the list.", "Combining Instance Manager Concepts", 1);
    }
Skripten für die Schaltfläche „Eine Zeile nach unten“
Diese Variable speichert den Indexwert der Subform3-Instanz:
var nIndex = Subform3.index;
Die folgende if-else-Anweisung verhindert die Fortsetzung des Skriptes, falls die Instanz von Subform3 als letzte Instanz in der Liste aufgeführt wird:
if ((nIndex + 1) < Subform3.instanceManager.count) {
// nIndexFrom and nIndexTo store the before and after index values to use with the moveInstance() method.
    var nIndexFrom = nIndex;
    var nIndexTo = nIndex + 1;

    Subform3.instanceManager.moveInstance(nIndexFrom, nIndexTo);
    }
    else {
    xfa.host.messageBox("The current item cannot be moved because it is the last
    instance in the list.", „Combining Instance Manager Concepts“, 1);
    }
Sie können dieses Skript auch mit der Unterstrich-Notation (_) schreiben, um die Eigenschaften und Methoden des Instanzmanagers zu referenzieren, wie in diesem Beispiel:
    var nIndex = Subform3.index;
    if ((nIndex + 1) < Subform3.instanceManager.count) {
    var nIndexFrom = nIndex;
    var nIndexTo = nIndex + 1;
    _Subform3.moveInstance(nIndexFrom, nIndexTo);
    }
    else {
    xfa.host.messageBox("The current item can't be moved since it already is the
    last instance in the list.", „Combining Instance Manager Concepts“, 1);
    }


Skript-Referenz

Grundlagen zur Objekt-Scripting-Referenz
Klassenhierarchie des XML-Formularobjektmodells
Objekte
Skripteigenschaften
Skriptmethoden


Grundlagen zur Objekt-Scripting-Referenz

Dieser Abschnitt beschreibt die Objekte, Eigenschaften und Methoden, die Sie in der Skriptumgebung von LiveCycle Designer verwenden können.
Jeder Host, wie z. B. Acrobat und Adobe Reader, ist für die Implementierung der verfügbaren Methoden verantwortlich. Einige Methoden, wie z. B. die beep-Methode, ergeben auf einem Server keinen Sinn. Der Server implementiert diese Methoden nicht und kann stattdessen eine Fehlermeldung ausgeben, wenn ein Benutzer versucht, die Methode aufzurufen.
Weitere Informationen zur Skriptumgebung von LiveCycle Designer finden Sie in der Dokumentation Adobe XML Form Object Model Reference, die auf der Website von Adobe LiveCycle Designer Developer Center verfügbar ist: http://partners.adobe.com/public/developer/livecycle/designer/devcenter.html.


Klassenhierarchie des XML-Formularobjektmodells

object-Klasse
treeList-Klasse
tree-Klasse
node-Klasse
content-Klasse
model-Klasse
textNode-Klasse
Das XML-Formularobjektmodell (XML Form Object Model) setzt sich aus neun Modellen zusammen, die jeweils aus einem Satz von Objekten bestehen. Jedes Objekt ist von einer Gruppe von Klassen abgeleitet, die allgemeine Eigenschaften und Methoden definieren. Ein Objekt übernimmt diese allgemeinen Eigenschaften und Methoden, kann jedoch auch Eigenschaften und Methoden hinzufügen, die nur für dieses Objekt verfügbar sind, relativ zu anderen von derselben Klasse abgeleiteteten Objekten.
Die Klassenhierarchie, aus der sich die Objekte des XML-Formularobjektmodells ableiten, ist folgendermaßen strukturiert.
object |  |  |
 | treeList |  |
 | tree |  |
 |  | node |
 |  |  | content
 |  |  | model
 |  |  | textNode
Wie bei herkömmlichen Klassenstrukturen übernimmt jede Klasse Eigenschaften und Methoden von der zugehörigen übergeordneten Klasse. Objekte übernehmen dagegen Eigenschaften und Methoden von der übergeordneten Klasse, von der sie abgeleitet werden.
Jedes Modell verwendet eine Hierarchie von Objekten. Objekte übernehmen keine Eigenschaften und Methoden von anderen Objekten, sondern übernehmen diese stattdessen direkt von der Klassenhierarchie. Die Hierarchie von Objekten in einem Modell stellt die XML-Struktur dieses Modells dar.


object-Klasse

Die object-Klasse ist die Basisklasse, von der alle anderen Klassen, Objekte und Modelle entweder direkt oder indirekt abgeleitet werden.
Klassenhierarchie

Übergeordnete Klasse

Aktuelle Klasse

Untergeordnete Klasse
Keine

object
tree
treeList
Eigenschaften

Name

Beschreibung

Typ

Zugriff
className
Legt den Namen der Klasse dieses Objekts fest.
Zeichenfolge
Get
Methoden
Keine


treeList-Klasse

Die treeList-Klasse stellt eine Liste von Struktur-Nodes dar.
Klassenhierarchie

Übergeordnete Klasse

Aktuelle Klasse

Untergeordnete Klasse
object
treeList
Keine
Eigenschaften

Name

Beschreibung

Typ

Zugriff
length
Gibt die Anzahl der Objekte in der Liste an.
Ganzzahl
Lesen
Methoden

Name

Beschreibung

Rückgabe
append
Fügt am Ende der Node-Liste eine Node an.
Leer
insert
Fügt eine Node vor einer angegebenen Node in der Node-Liste ein.
Leer
item
Beschreibt einen Null-basierten Index zur Sammlung.
Objekt
namedItem
Ruft das erste untergeordnete Element dieser Node mit dem angegebenen Namen ab.
Objekt
remove
Entfernt eine Node aus der Node-Liste.
Leer


tree-Klasse

Die tree-Klasse stellt die Struktur dar, von der die node-Klasse abgeleitet wird.
Klassenhierarchie

Übergeordnete Klasse

Aktuelle Klasse

Untergeordnete Klasse
object
tree
node
Eigenschaften

Name

Beschreibung

Typ

Zugriff
all
Gibt eine Sammlung von Nodes mit ähnlichen Namen im Bereich zurück.
Objekt
Lesen
classAll
Gibt eine Sammlung von Nodes der gleichen Klasse im Bereich zurück.
Objekt
Lesen
classIndex
Gibt die Position dieses Objekts in der zugehörigen Sammlung der Objekte mit ähnlichen Klassen im Bereich zurück.
Ganzzahl
Lesen
index
Gibt die Position dieser Node in der zugehörigen Sammlung der Nodes mit ähnlichen Namen im Bereich zurück.
Ganzzahl
Lesen
name
Gibt einen Bezeichner an, mit dem dieses Objekt oder Ereignis in Skriptausdrücken angegeben werden kann.
Zeichenfolge
Lesen/Schreiben
nodes
Gibt eine Liste aller untergeordneten Objekte des aktuellen Objekts zurück.
Objekt
Lesen
parent
Gibt das übergeordnete Objekt des aktuellen Objekts zurück.
Objekt
Lesen
somExpression
Liest den Ausdruck der Referenz-Syntax für diese Node.
Zeichenfolge
Lesen
Methoden

Name

Beschreibung

Rückgabe
resolveNode
Wertet den angegebenen Ausdruck der Referenz-Syntax aus, angefangen mit dem aktuellen Objekt des XML-Formularobjektmodells, und gibt den Wert des im Ausdruck der Referenz-Syntax angegebenen Objekts zurück.
Objekt
resolveNodes
Wertet den angegebenen Ausdruck der Referenz-Syntax aus, angefangen mit dem aktuellen Objekt des XML-Formularobjektmodells, und gibt den Wert des bzw. der im Ausdruck der Referenz-Syntax angegebenen Objekts bzw. Objekte zurück.
Objekt


node-Klasse

Die node-Klasse stellt den primären Datentyp für Objekte des XML-Formularobjektmodells dar.
Klassenhierarchie

Übergeordnete Klasse

Aktuelle Klasse

Untergeordnete Klassen
tree

node
content
model
textNode
Eigenschaften

Name

Beschreibung

Typ

Zugriff
id
Gibt einen allgemeinen benutzerdefinierten XML-ID-Typ an.
Zeichenfolge
Lesen/Schreiben
isContainer
Gibt an, ob dieses Objekt ein container-Objekt ist.
Boolescher Wert
Lesen
isNull
Gibt an, ob der aktuelle Datenwert der Nullwert ist.
Boolescher Wert
Lesen
model
Gibt das Modell für das aktuelle Objekt an.
Objekt
Lesen
ns
Gibt den Namespace für das Objekt zurück.
Zeichenfolge
Lesen
oneOfChild
Ruft das untergeordnete Objekt ab oder legt es fest, wenn ein übergeordnetes Objekt nur ein bestimmtes untergeordnetes Objekt haben kann.
Objekt
Lesen/Schreiben
Methoden

Name

Beschreibung

Rückgabe
applyXSL
Wendet eine XSL-Transformation auf die XML-Darstellung der aktuellen Node an. Diese Methode entspricht dem Aufruf von saveXML und der Transformation des Ergebnisses mit dem angegebenen XSL-Dokument.
Zeichenfolge
assignNode
Wertet den Ausdruck der Referenz-Syntax mit Hilfe des aktuellen Kontexts aus und legt den Wert der gefundenen Node fest. Wenn die Node nicht vorhanden ist, kann sie erstellt werden.
Objekt
clone
Erstellt eine Kopie eines Objekts.
Objekt
getAttribute
Ruft den Wert einer angegebenen Eigenschaft ab.
Zeichenfolge
getElement
Gibt eine angegebene Objekteigenschaft zurück.
Objekt
isPropertySpecified
Überprüft, ob eine bestimmte Eigenschaft für diese Node definiert wurde.
Boolescher Wert
loadXML
Lädt ein angegebenes XML-Dokument und fügt es an das aktuelle Objekt an.
Leer
saveFilteredXML
Speichert die aktuelle Node in einer Zeichenfolge, bezieht jedoch nur eine Untergruppe der untergeordneten Nodes ein.
Zeichenfolge
saveXML
Speichert die aktuelle Node in einer Zeichenfolge.
Zeichenfolge
setAttribute
Legt den Wert einer angegebenen Eigenschaft fest.
Leer
setElement
Legt ein angegebenes Objekt als aktuelles Objekt fest.
Leer


content-Klasse

Die content-Klasse stellt Inhaltsobjekte für das Formular- und das Vorlagenmodell bereit. Formularentwürfe und ausgefüllte Formulare setzen sich aus Objekten zusammen, die Inhalt wie etwa Bilder und Text darstellen.
Klassenhierarchie

Übergeordnete Klasse

Aktuelle Klasse

Untergeordnete Klasse
node

content
Keine
Eigenschaften
Keine
Methoden
Keine


model-Klasse

Die model-Klasse ist die Basisklasse für die Stammobjekte der einzelnen Modelle.
Klassenhierarchie

Übergeordnete Klasse

Aktuelle Klasse

Untergeordnete Klasse
node

model
Keine
Eigenschaften

Name

Beschreibung

Typ

Zugriff
aliasNode
Gibt das Objekt an, das durch den Alias für dieses Modell dargestellt wird.
Objekt
Lesen/Schreiben
context
Gibt das aktuelle Objekt an, bei dem es sich um das Startobjekt für die Methoden resolveNode und resolveNodes handelt.
Objekt
Lesen/Schreiben
Methoden

Name

Beschreibung

Rückgabe
clearErrorList
Entfernt alle Elemente aus dem aktuellen Fehlerprotokoll.
Leer
createNode
Erstellt eine neue Node auf Basis eines gültigen Klassennamens.
Objekt
isCompatibleNS
Stellt fest, ob ein angegebener Namespace in der Funktion dem Namespace dieses Modells entspricht, d. h. mit diesem kompatibel ist. Diese Methode stellt fest, ob die beiden Namespaces einander entsprechen, auch wenn die Zeichenfolgen, mit denen sie dargestellt werden, nicht identisch sind.
Boolescher Wert


textNode-Klasse

Die textNode-Klasse stellt Objekte dar, die Textdaten direkt speichern, statt das von der node-Klasse abgeleitete #text-Objekt zu verwenden.
Klassenhierarchie

Übergeordnete Klasse

Aktuelle Klasse

Untergeordnete Klasse
node

textNode
Keine
Eigenschaften

Name

Beschreibung

Typ

Zugriff
{default}
Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Zeichenfolge
Lesen/Schreiben
value
Gibt den Wert des aktuellen Objekts an.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


Objekte

arc
area
assist
barcode
bind
bindItems
bookend
boolean
border
break
breakAfter
breakBefore
button
calculate
caption
certificate
certificates
checkButton
choiceList
color
comb
command
connect
connectionSet
connectString
contentArea
corner
dataGroup
dataModel
dataValue
dataWindow
date
dateTime
dateTimeEdit
decimal
defaultUi
delete
desc
digestMethod
digestMethod
draw
dSigData
edge
encoding
encodings
event
eventPseudoModel
exclGroup
exData
execute
exObject
extras
field
fill
filter
float
font
form
format
handler
hostPseudoModel
image
imageEdit
insert
instanceManager
integer
issuers
items
keep
keyUsage
layoutPseudoModel
line
linear
manifest
map
margin
mdp
medium
message
numericEdit
occur
oid
oids
operation
overflow
packet
pageArea
pageSet
para
password
passwordEdit
pattern
picture
proto
query
radial
reason
reasons
recordSet
rectangle
ref
rootElement
script
select
setProperty
signature
signatureProperties
signaturePseudoModel
signData
signedState
signing
soapAction
soapAddress
solid
source
sourceSet
speak
stipple
subform
subformSet
subjectDN
subjectDNs
submit
template
text
textEdit
time
timeStamp
toolTip
traversal
traverse
ui
update
uri
user
validate
value
variables
wsdlAddress
wsdlConnection
xfa
xmlConnection
xsdConnection


arc

Das arc-Objekt beschreibt einen Bogen oder eine Ellipse.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
value

arc
edge
fill
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
circular
Ermöglicht die Umwandlung eines Bogens in einen Kreis.
Zeichenfolge
Lesen/Schreiben
hand
Beschreibt die Ausrichtung einer Linie oder Kante.
Zeichenfolge
Lesen/Schreiben
startAngle
Legt den Winkel fest, an dem die Wiedergabe des Bogenanfangs erfolgen soll.
Zeichenfolge
Lesen/Schreiben
sweepAngle
Gibt die Länge des Bogens als Winkel an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


area

Das area-Objekt stellt die Gruppierung anderer Containerobjekte in einem Formular dar.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
area
pageArea
proto
subform

area
desc
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
colSpan
Gibt bei der Verwendung in einem Teilformular mit einer Layoutzeile die Anzahl der Spalten an, die dieses Objekt umfasst.
Zeichenfolge
Lesen/Schreiben
relevant
Steuert, ob ein Formularobjekt beim Drucken des Formulars einbezogen wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
x
Gibt die X-Koordinate des Container-Verankerungspunkts im Verhältnis zur oberen, linken Ecke des übergeordneten Containers bei der Platzierung in einem positionierten Layout an.
Zeichenfolge
Lesen/Schreiben
y
Gibt die Y-Koordinate eines Container-Verankerungspunkts im Verhältnis zur oberen, linken Ecke des übergeordneten Containers bei der Platzierung in einem positionierten Layout an.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


assist

Das assist-Objekt stellt zusätzliche Informationen zu einem Container für Benutzer von interaktiven Formularanwendungen bereit.
Mit diesem Objekt kann die QuickInfo und das Verhalten für eine gesprochene Eingabeaufforderung angegeben werden.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
draw
exclGroup
field
proto

assist
speak
toolTip
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
role
Gibt die Rolle des übergeordneten Containers an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


barcode

Das barcode-Objekt stellt die Informationen bereit, die zum Anzeigen eines Barcodes erforderlich sind. Zu diesen Informationen zählen der Barcode-Typ sowie eine Reihe von Optionen, die von Barcode-Typ zu Barcode-Typ unterschiedlich sind.
LiveCycle Designer unterstützt zwei Typen von Barcodes: Hardware- und Software-Barcodes. Es ist jedoch keine XFA-Anwendung zur Unterstützung bestimmter Barcodesätze erforderlich. Hardware-Barcodes werden von speziellen Druckern dargestellt. Welche Barcodes unterstützt werden, hängt vom Anzeigegerät ab, da einige Drucker über eine integrierte Unterstützung für bestimmte Barcodes verfügen. Software-Barcodes werden Strich für Strich von der eigentlichen XFA-Anwendung gezeichnet. Bei der Anzeige auf einem Bildschirm, auf den Barcodeleser nicht zugreifen können, kehrt eine XFA-Anwendung möglicherweise auch zur Anzeige von Platzhaltern anstelle eines exakten Barcodes zurück.
Für jeden Barcode-Typ gibt es in der Regel zwei verschiedene Spezifikationen: eine für den eigentlichen Barcode und eine für die Anordnung des Barcodes im Verhältnis zur physikalischen Seite sowie zur Druckumgebung. Der Verfasser des Formularentwurfs ist dafür verantwortlich, dass der Barcode richtig auf der Seite platziert wird. Die XFA-Anwendung ist für die ordnungsgemäße Wiedergabe des Barcodes mit Hilfe der Benutzerdaten verantwortlich. Die Benutzerdaten müssen mit dem Barcode kompatibel sein, d. h., sie müssen mit dem zulässigen Zeichensatz und der zulässigen Zeichenfolgenlänge übereinstimmen.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
ui

barcode
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
charEncoding
Gibt die Zeichencodierung des in einem Barcode kodierten Wertes an.
Zeichenfolge
Lesen/Schreiben
checksum
Gibt einen Algorithmus für die in den Barcode einzufügende Prüfsumme an.
Zeichenfolge
Lesen/Schreiben
dataColumnCount
Gibt eine optionale Anzahl an Datenspalten an, die für unterstützte Barcodes kodiert werden. Diese Eigenschaft bezieht sich nur auf zweidimensionale Barcodes.
Zeichenfolge
Lesen/Schreiben
dataLength
Gibt die maximale Anzahl Zeichen für diese Barcodeinstanz an. Diese Eigenschaft bezieht sich nur auf eindimensionale Barcodes.
Zeichenfolge
Lesen/Schreiben
dataPrep
Definiert die Vorverarbeitung für die Daten, die in den Barcode geschrieben werden.
Zeichenfolge
Lesen/Schreiben
dataRowCount
Gibt eine optionale Anzahl an Datenzeilen an, die für unterstützte Barcodes kodiert werden. Diese Eigenschaft bezieht sich nur auf 2D-Barcodes.
Zeichenfolge
Lesen/Schreiben
endChar
Gibt ein optionales Endsteuerzeichen an, das an die Barcodedaten angehängt wird.
Zeichenfolge
Lesen/Schreiben
errorCorrectionLevel
Gibt ein optionales Fehlerkorrektur-Level an, das auf unterstützte Barcodes angewendet werden soll. Diese Eigenschaft bezieht sich nur auf 2D-Barcodes.
Zeichenfolge
Lesen/Schreiben
moduleHeight
Bestimmt die Höhe einer Gruppe von Balken, mit denen ein Zeichen von bereitgestelltem Text kodiert wird.
Zeichenfolge
Lesen/Schreiben
moduleWidth
Gibt die unterschiedlichen Aspekte eines Barcodes abhängig von der Klasse der verwendeten Barcodes an.
Zeichenfolge
Lesen/Schreiben
printCheckDigit
Gibt an, ob die Prüfziffern in Klartext gedruckt werden.
Zeichenfolge
Lesen/Schreiben
rowColumnRatio
Ein optionales Verhältnis zwischen Zeilen und Spalten für unterstützte 2D-Barcodes.
Zeichenfolge
Lesen/Schreiben
startChar
Gibt ein optionales Startsteuerzeichen an, das am Anfang der Barcodedaten eingefügt wird.
Zeichenfolge
Lesen/Schreiben
textLocation
Gibt die Position eines dem Barcode zugehörigen Textes an.
Zeichenfolge
Lesen/Schreiben
truncate
Schneidet die rechte Kante des Barcodes für unterstützte Formate ab.
Zeichenfolge
Lesen/Schreiben
type
Gibt das von einem Objekt verwendete Muster an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
wideNarrowRatio
Gibt das Verhältnis der breiten und schmalen Balken in unterstützten Barcodes an.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


bind

Das bind-Objekt bestimmt das Verhalten des zugehörigen übergeordneten Objekts bei Zusammenführungsvorgängen.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
command
exclGroup
field
proto
subform

bind
picture
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
contentType
Gibt den Inhaltstyp im referenzierten Dokument an, ausgedrückt als MIME-Typ.
Zeichenfolge
Lesen/Schreiben
match
Steuert die Rolle, die das Einschließen eines Objekts in einer Datenbindungsoperation (Zusammenführungsoperation) spielt.
Zeichenfolge
Lesen/Schreiben
ref
Gibt einen Ausdruck der Referenz-Syntax an, der die Node im Datenmodell definiert, an die der einschließende Container gebunden wird.
Zeichenfolge
Lesen/Schreiben
transferEncoding
Gibt die Kodierung von binärem Inhalt im referenzierten Dokument an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


bindItems

Das bindItems -Objekt gibt einen Satz von Daten-Nodes zum Binden an.
Die Anwendung des bindItems -Objekts ist ein Bindungsvorgang. Die Verknüpfungen zwischen den Listenelementen und den referenzierten Daten sind aktiv. Eine Änderung an den Daten führt zu einer sofortigen Aktualisierung der Listenelemente.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
field
proto

bindItems
ref
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
connection
Gibt den Namen des zugeordneten Verbindungssteuerelements in der Verbindungsgruppe an.
Zeichenfolge
Lesen/Schreiben
labelRef
Löst einen Datenwert für alle durch das ref -Objekt angegebenen Daten-Nodes in der Gruppe auf.
Zeichenfolge
Lesen/Schreiben
valueRef
Löst einen Datenwert für alle durch das ref -Objekt angegebenen Daten-Nodes in der Gruppe auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


bookend

Das bookend-Objekt speichert Eigenschaften, über die optionale Teilformulare angegeben werden, die den Inhalt des übergeordneten Teilformulars beenden.
Die leader-Eigenschaft gibt ein optionales Objekt vom Typ subform oder subformSet an, das als erstes, vor dem Inhalt des übergeordneten Containers angeordnet wird. Die trailer-Eigenschaft gibt ein optionales Objekt vom Typ subform oder subformSet an, das als letztes, nach dem Inhalt des übergeordneten Containers angeordnet wird. Auf diese Weise beenden diese Eigenschaften den Inhalt des übergeordneten Containers. Dies gilt unabhängig davon, wie viele Objekte vom Typ contentArea oder pageArea der übergeordnete Container umfasst.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
subform
subformSet

bookend
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
leader
Gibt zum Platzieren im oberen Bereich eines Inhalts- oder Seitenbereichs das subform -Objekt oder das subformSet -Objekt an.
Zeichenfolge
Lesen/Schreiben
trailer
Gibt das subform - bzw. subformSet -Objekt an, das im unteren Bereich eines Inhalts- oder Seitenbereichs platziert werden soll.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


boolean

Das boolean-Objekt beschreibt eine Dateninhaltseinheit, die einen logischen booleschen Wert darstellt.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
desc
exObject
extras
items
proto
value
variables
boolean
Keine
Übergeordnete Klasse
content-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
{default}
Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Boolescher Wert
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
value
Gibt den Wert des aktuellen Objekts an.
Boolescher Wert
Lesen/Schreiben
Methoden
Keine


border

Das border-Objekt beschreibt die Begrenzung, die ein Objekt umgibt.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
checkButton
choiceList
dateTimeEdit
draw
exclGroup
field
imageEdit
numericEdit
passwordEdit
proto
signature
subform
textEdit

border
corner
edge
extras
fill
margin
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
break
Beschreibt die Einschränkungen beim Wechseln auf eine neue Seite oder einen neuen Inhaltsbereich nach der Wiedergabe eines Objekts.
Zeichenfolge
Lesen/Schreiben
hand
Beschreibt die Ausrichtung einer Linie oder Kante.
Zeichenfolge
Lesen/Schreiben
presence
Gibt an, ob ein Objekt sichtbar ist.
Zeichenfolge
Lesen/Schreiben
relevant
Steuert, ob ein Formularobjekt beim Drucken des Formulars einbezogen wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


break

Das break-Objekt beschreibt die Einschränkungen zum Wechseln auf eine neue Seite oder einen neuen Inhaltsbereich vor oder nach der Wiedergabe eines Objekts.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
subform
subformSet
break
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
after
Gibt die Einschränkungen zum Wechseln auf eine neue Seite oder einen neuen Inhaltsbereich nach der Wiedergabe des Teilformulars an.
Zeichenfolge
Lesen/Schreiben
afterTarget
Gibt die explizite Zielseite oder den Inhaltsbereich für die after-Eigenschaft an.
Zeichenfolge
Lesen/Schreiben
before
Gibt die Einschränkungen zum Wechseln auf eine neue Seite oder in einen neuen Inhaltsbereich vor der Wiedergabe des Teilformulars an.
Zeichenfolge
Lesen/Schreiben
beforeTarget
Gibt die explizite Zielseite oder den Inhaltsbereich für die before-Eigenschaft an.
Zeichenfolge
Lesen/Schreiben
bookendLeader
Gibt ein Teilformular an, das in den aktuellen Inhaltsbereich oder in die aktuelle Seite vor anderen Inhalten eingefügt wird.
Zeichenfolge
Lesen/Schreiben
bookendTrailer
Gibt ein Teilformular an, das in den aktuellen Inhaltsbereich oder in die aktuelle Seite nach anderen Inhalten eingefügt wird.
Zeichenfolge
Lesen/Schreiben
overflowLeader
Gibt das Teilformular an, das oben im Inhaltsbereich oder auf der Seite platziert werden soll, wenn es als Ergebnis eines Überlaufs eingegeben wird.
Zeichenfolge
Lesen/Schreiben
overflowTarget
Gibt den eindeutigen Inhaltsbereich an, der als Übergangsziel dient, wenn der aktuelle Inhalts- oder Seitenbereich überläuft.
Zeichenfolge
Lesen/Schreiben
overflowTrailer
Gibt das Teilformular an, das beim Überlaufen unten im Inhaltsbereich oder unten auf der Seite platziert werden soll.
Zeichenfolge
Lesen/Schreiben
startNew
Legt fest, ob ein neuer Inhaltsbereich oder eine neue Seite begonnen werden soll, selbst wenn der aktuelle Inhaltsbereich bzw. die aktuelle Seite den erforderlichen Namen besitzt.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


breakAfter

Das breakAfter-Objekt beschreibt die bedingten Einschränkungen zum Wechseln auf eine neue Seite oder einen neuen Inhaltsbereich nach dem Ablegen des übergeordneten Containers. Das breakAfter-Objekt wird nach dem Anordnen des übergeordneten Teilformulars aufgerufen. Die Kopf- und Fußbereiche werden vor und nach einem vom breakAfter-Objekt angeforderten Sprung abgelegt.
Ein optionales, mit dem breakAfter-Objekt verknüpftes script-Objekt bestimmt, ob es beachtet wird. Dieses script-Objekt besitzt standardmäßig den Wert „True“. Dies bedeutet, dass breakAfter-Objekte ohne script-Objekt immer aufgerufen werden.
Das breakAfter-Objekt entspricht in der Funktion der veralteten Syntax von break.after und afterTarget.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
subform
subformSet

breakAfter
script
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
leader
Gibt zum Platzieren im oberen Bereich eines Inhalts- oder Seitenbereichs das subform -Objekt oder das subformSet -Objekt an.
Zeichenfolge
Lesen/Schreiben
startNew
Legt fest, ob ein neuer Inhaltsbereich oder eine neue Seite begonnen werden soll, selbst wenn der aktuelle Inhaltsbereich bzw. die aktuelle Seite den erforderlichen Namen besitzt.
Zeichenfolge
Lesen/Schreiben
target
Gibt das Objekt an, auf welches das Ereignis wirkt.
Zeichenfolge
Lesen/Schreiben
targetType
Gibt die Einschränkungen zum Wechseln auf eine neue Seite oder in einen neuen Inhaltsbereich vor dem Erstellen des Layouts für das übergeordnete Teilformular an.
Zeichenfolge
Lesen/Schreiben
trailer
Gibt das subform - bzw. subformSet -Objekt an, das im unteren Bereich eines Inhalts- oder Seitenbereichs platziert werden soll.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


breakBefore

Das breakBefore-Objekt beschreibt die bedingten Einschränkungen zum Wechseln auf eine neue Seite oder in einen neuen Inhaltsbereich vor dem Ablegen des übergeordneten Containers. Das breakBefore-Objekt wird vor dem Anordnen des übergeordneten Teilformulars aufgerufen. Die Kopf- und Fußbereiche werden vor und nach einem vom breakBefore-Objekt angeforderten Sprung abgelegt.
Ein optionales, mit dem breakBefore-Objekt verknüpftes script-Objekt bestimmt, ob es beachtet wird. Dieses script-Objekt besitzt standardmäßig den Wert „True“. Dies bedeutet, dass breakBefore-Objekte ohne script-Objekt immer aufgerufen werden.
Das breakBefore-Objekt entspricht in der Funktion der veralteten Syntax von break.before und beforeTarget.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
subform
subformSet

breakBefore
script
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
leader
Gibt zum Platzieren im oberen Bereich eines Inhalts- oder Seitenbereichs das subform -Objekt oder das subformSet -Objekt an.
Zeichenfolge
Lesen/Schreiben
startNew
Legt fest, ob ein neuer Inhaltsbereich oder eine neue Seite begonnen werden soll, selbst wenn der aktuelle Inhaltsbereich bzw. die aktuelle Seite den erforderlichen Namen besitzt.
Zeichenfolge
Lesen/Schreiben
target
Gibt das Objekt an, auf welches das Ereignis wirkt.
Zeichenfolge
Lesen/Schreiben
targetType
Gibt die Einschränkungen zum Wechseln auf eine neue Seite oder in einen neuen Inhaltsbereich vor dem Erstellen des Layouts für das übergeordnete Teilformular an.
Zeichenfolge
Lesen/Schreiben
trailer
Gibt das subform - bzw. subformSet -Objekt an, das im unteren Bereich eines Inhalts- oder Seitenbereichs platziert werden soll.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


button

Das button-Objekt beschreibt ein Schaltflächen-Steuerelement.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
ui

button
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
highlight
Gibt das visuelle Erscheinungsbild einer Schaltfläche bei Aktivierung durch einen Benutzer an. Alle Werte unterstützen zwei Zustände (nicht aktiviert und aktiviert), mit Ausnahme von push , der drei Zustände unterstützt (nicht aktiviert, aktiviert und Mauskontakt).
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


calculate

Das calculate-Objekt legt die Berechnung des Werts eines Feldes fest.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
exclGroup
field
proto
subform

calculate
extras
message
script
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
override
Bestimmt, ob der berechnete Wert vom Benutzer in einem interaktiven Kontext überschrieben werden kann, oder ob der Wert in jedem Kontext deaktiviert ist.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


caption

Das caption-Objekt beschreibt eine beschreibende Bezeichnung, die mit einem Formularentwurfsobjekt verknüpft ist.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
draw
exclGroup
field
proto
caption
extras
font
margin
para
value
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
placement
Definiert die Platzierung der Beschriftung.
Zeichenfolge
Lesen/Schreiben
presence
Gibt an, ob ein Objekt sichtbar ist.
Zeichenfolge
Lesen/Schreiben
reserve
Eine Maßeinheit, welche die Höhe oder Breite der Beschriftung angibt.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


certificate

Das certificate-Objekt speichert ein Zertifikat.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
issuers
proto
signing

certificate
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


certificates

Das certificates-Objekt speichert eine Sammlung mit Zertifkatsfiltern.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
filter
proto

certificates
issuers
keyUsage
oids
signing
subjectDNs
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
credentialServerPolicy
Gibt an, ob das Prüfen des Zertifikatstatus beim Unterschreiben einer digitalen Unterschrift erforderlich ist. Der Zertifikatstatus kann anhand einer Zertifikatssperrliste oder einer OCSP-Antwort (Online Certificate Status Protocol, OCSP) geprüft werden.
Zeichenfolge
Lesen/Schreiben
url
Gibt die URL für dieses Objekt an.
Zeichenfolge
Lesen/Schreiben
urlPolicy
(urlPolicy) Gibt den Typ der URL an, die vom Zertifikatobjekt dargestellt wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


checkButton

Das checkButton-Objekt, das ein Kontrollkästchen- oder ein Optionsfeld-Steuerelement beschreibt.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
ui

checkButton
border
extras
margin
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
allowNeutral
Gibt an, ob das Kontrollkästchen oder das Optionsfeld einen weiteren dritten Zustand unterstützen kann, der einen neutralen Wert darstellt.
Zeichenfolge
Lesen/Schreiben
mark
Gibt die beim Ausfüllen eines Kontrollkästchenobjekts zu verwendende Form an.
Zeichenfolge
Lesen/Schreiben
shape
Gibt an, ob das Kontrollkästchen oder Optionsfeld mit einer quadratischen oder runden Kontur dargestellt wird.
Zeichenfolge
Lesen/Schreiben
size
Eine Maßeinheit, welche die Größe des Kontrollkästchens bzw. des Optionsfelds angibt. Bei einem Kontrollkästchen stellt sie die Höhe und Breite und bei einem Optionsfeld den Durchmesser dar.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


choiceList

Das choiceList-Objekt, das eine Liste mit Optionen beschreibt. Die Liste mit Optionen wird durch ein oder mehrere nebengeordnete Objekte festgelegt.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
ui

choiceList
border
extras
margin
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
commitOn
Gibt an, wann die Auswahl eines Benutzers auf das Datenmodell übertragen wird.
Zeichenfolge
Lesen/Schreiben
open
Legt fest, wann die Auswahlliste von interaktiven Anwendungen angezeigt wird.
Zeichenfolge
Lesen/Schreiben
textEntry
Bestimmt, ob ein Benutzer einen Wert in eine Dropdown-Liste eingeben kann.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


color

Das color-Objekt beschreibt eine eindeutige Farbe in einem Formular.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
corner
edge
fill
linear
pattern
proto
radial
stipple
color
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
cSpace
Gibt den Farbraum an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
value
Gibt den Wert des aktuellen Objekts an.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


comb

Das comb-Objekt beschreibt ein Kombinationsfeld, wobei die einzelnen Buchstaben des Feldes durch eine schwarze vertikale Linie voneinander getrennt sind, die von der oberen bis zur unteren Kante des Feldes reicht.
Es können nur einzeilige Kombinationsfelder erstellt werden. Wenn ein textEdit-Objekt ein mehrzeiliges Feld oder ein Rich-Text-Feld darstellt, wird das Vorhandensein eines untergeordneten Kombinationsfeldobjekts als Fehler betrachtet und eine Warnung generiert. Die maxChars-Eigenschaft des textEdit-Objekts bestimmt die Anzahl der zu erstellenden Kombinationsfelder.
Das comb-Objekt ist nur für dynamische oder interaktive PDF-Formulare verfügbar. Statische PDF-Formulare und alle anderen Ausgabeformate ignorieren dieses Objekt.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
textEdit (textEdit.comb ist für die zukünftige Verwendung reserviert)

comb
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
numberOfCells
Gibt die Anzahl der Zellen an, die für ein Kombinationsfeld gezeichnet wird. Diese ist von der Anzahl der Zeichen im Wert des Feldes nicht betroffen.
Ganzzahl
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


command

Das command-Objekt gibt einen einzelnen Befehl an, der für die Datenquelle ausgeführt wird.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
source

command
delete
insert
query
update
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
timeout
Gibt die Anzahl der Sekunden für den Versuch einer Abfrage an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


connect

Das connect-Objekt beschreibt die Beziehung zwischen dem Objekt, in dem es enthalten ist, und einer Verbindung mit einem Webdienst, Schema oder einer Datenbeschreibung. Verbindungen sind außerhalb des Formularentwurfs in einem eigenen Paket mit einem eigenen Schema definiert.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
exclGroup
field
proto
source
subform

connect
connectString
password
picture
user
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
connection
Gibt den Namen des zugeordneten Verbindungssteuerelements in der Verbindungsgruppe an.
Zeichenfolge
Lesen/Schreiben
delayedOpen
Gibt die Anzahl der Sekunden an, um die das Öffnen der Datenquelle nach dem Herstellen einer Verbindung verzögert wird.
Zeichenfolge
Lesen/Schreiben
ref
Gibt einen Ausdruck der Referenz-Syntax an, der die Node im Datenmodell definiert, an die der einschließende Container gebunden wird.
Zeichenfolge
Lesen/Schreiben
timeout
Gibt die Anzahl der Sekunden für den Versuch einer Abfrage an.
Zeichenfolge
Lesen/Schreiben
usage
Gibt den Kontext an, in dem die Verbindung verwendet wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


connectionSet

Das connectionSet-Objekt ist das Stammobjekt des connectionSet-Modells.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
Keine

connectionSet
wsdlConnection
xsdConnection
Übergeordnete Klasse
model-Klasse
Eigenschaften
Keine
Methoden
Keine


connectString

Das connectString-Objekt gibt die Verbindungszeichenfolge für die Verbindung mit der Datenbank an.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
connect

connectString
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


contentArea

Das contentArea-Objekt beschreibt einen Bereich in einem Seitenbereich, der Inhalte empfangen kann.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
pageArea
proto

contentArea
desc
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
h
Eine Maßeinheit für die Höhe des Layouts.
Zeichenfolge
Lesen/Schreiben
relevant
Steuert, ob ein Formularobjekt beim Drucken des Formulars einbezogen wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
w
Eine Maßeinheit für die Breite des Layouts.
Zeichenfolge
Lesen/Schreiben
x
Gibt die X-Koordinate des Container-Verankerungspunkts im Verhältnis zur oberen, linken Ecke des übergeordneten Containers bei der Platzierung in einem positionierten Layout an.
Zeichenfolge
Lesen/Schreiben
y
Gibt die Y-Koordinate eines Container-Verankerungspunkts im Verhältnis zur oberen, linken Ecke des übergeordneten Containers bei der Platzierung in einem positionierten Layout an.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


corner

Das corner-Objekt beschreibt das Erscheinungsbild eines Vertex zwischen zwei Kanten.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
border
proto
rectangle

corner
color
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
inverted
Gibt an, ob die Ecke konvex (verbindet die Kanten tangential) oder invertiert und damit konkav (verbindet die Kanten im rechten Winkel) dargestellt wird.
Zeichenfolge
Lesen/Schreiben
join
Gibt die Form der Ecke an.
Zeichenfolge
Lesen/Schreiben
presence
Gibt an, ob ein Objekt sichtbar ist.
Zeichenfolge
Lesen/Schreiben
radius
Gibt den Radius der Ecke an.
Zeichenfolge
Lesen/Schreiben
stroke
Gibt das Erscheinungsbild einer Linie an.
Zeichenfolge
Lesen/Schreiben
thickness
Gibt die Stärke oder Breite der Linie an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


dataGroup

Das dataGroup-Objekt ist das übergeordnete Element einer Liste mit XML-Daten-Nodes in einer XML-Datendatei. Die im dataGroup-Objekt enthaltenen Nodes sind entweder tatsächliche Datenwerte oder andere XML-Datenobjekte, wie z. B. dataGroup-Objekte. Teilformulare, wie Sie in XML-Datendateien vorkommen, sind ein Beispiel für Datengruppen.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
dataGroup

dataGroup
dataGroup
dataValue
Übergeordnete Klasse
node-Klasse
Eigenschaften
Keine
Methoden
Keine


dataModel

Das dataModel-Objekt ist das Stammobjekt des Datenmodells.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
Keine

dataModel
dataWindow
Übergeordnete Klasse
model-Klasse
Eigenschaften
Keine
Methoden
Keine


dataValue

Das dataValue-Objekt stellt ein Containerobjekt dar, das einen oder mehrere Werte speichert. Ein dataValue-Objekt ist beispielsweise ein Feld in einem Formular.
Ein dataValue-Objekt kann weitere untergeordnete dataValue-Objekte enthalten, die weitere Daten speichern. Dies ist üblicherweise nicht der Fall.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
dataGroup

dataValue
dataValue
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
{default}
Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Variabel
Lesen/Schreiben
contains
Bestimmt, ob ein Datenwert in den Wert des übergeordneten Objekts oder als Eigenschaft des übergeordneten Objekts eingefügt werden muss.
Zeichenfolge
Lesen/Schreiben
contentType
Gibt den Inhaltstyp im referenzierten Dokument an, ausgedrückt als MIME-Typ.
Zeichenfolge
Lesen/Schreiben
isNull
Gibt an, ob der aktuelle Datenwert der Nullwert ist.
Boolescher Wert
Lesen/Schreiben
value
Gibt den Wert des aktuellen Objekts an.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


dataWindow

Das dataWindow-Objekt stellt den Datensatzbereich aus der Datenquelle dar, die derzeit im Datenmodell geladen ist.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
dataModel

dataWindow
dataGroup
dataValue
Übergeordnete Klasse
object-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
currentRecordNumber
Gibt die aktuelle Datensatznummer im Bereich der Datensätze zurück, die im aktuellen dataWindow-Objekt enthalten sind.
Ganzzahl
Lesen
isDefined
Gibt an, ob derzeit ein gültiges Datenfenster definiert ist.
Boolescher Wert
Lesen
recordsAfter
Gibt die Anzahl der Datensätze im Datenfenster nach dem aktuellen Datensatz zurück.
Ganzzahl
Lesen
recordsBefore
Gibt die Anzahl der Datensätze im Datenfenster vor dem aktuellen Datensatz zurück.
Ganzzahl
Lesen
Methoden

Name

Beschreibung

Rückgabe
gotoRecord
Verschiebt den aktuellen Datensatz des Datenfensters in einen bestimmten Datensatz innerhalb des Datensatzbereichs in den Daten.
Leer
isRecordGroup
Gibt an, ob ein bestimmtes dataGroup-Objekt auch ein einzelner Datensatz ist.
Boolescher Wert
moveCurrentRecord
Verschiebt den aktuellen Datensatz an eine andere Position im Datensatzbereich.
Leer
record
Gibt einen Datensatz an einer Position relativ zum aktuellen Datensatz zurück.
Objekt


date

Das date-Objekt beschreibt ein Kalenderdatum.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
desc
exObject
extras
items
proto
value
variables
date
Keine
Übergeordnete Klasse
content-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
{default}
Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
value
Gibt den Wert des aktuellen Objekts an.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


dateTime

Das dateTime-Objekt stellt einen Datums- und Uhrzeitwert dar.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
desc
exObject
extras
items
proto
value
variables
dateTime
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
{default}
Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
value
Gibt den Wert des aktuellen Objekts an.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


dateTimeEdit

Das dateTimeEdit-Objekt beschreibt ein Steuerelement zur Unterstützung bei der Auswahl von Datum und Uhrzeit.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
ui

dateTimeEdit
border
comb
extras
margin
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
hScrollPolicy
Gibt an, ob in einem Feld der horizontale Bildlauf verfügbar ist.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


decimal

Das decimal-Objekt stellt eine Zahl mit einer festen Anzahl von Ziffern nach dem Dezimaltrennzeichen dar.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
desc
exObject
extras
items
proto
value
variables
decimal
Keine
Übergeordnete Klasse
content-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
{default}
Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Double
Lesen/Schreiben
fracDigits
Gibt die maximale Anzahl der Stellen nach dem Dezimalzeichen zur Erfassung und Speicherung an.
Zeichenfolge
Lesen/Schreiben
leadDigits
Gibt die maximale Anzahl der Stellen vor dem Dezimalzeichen zur Erfassung und Speicherung an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
value
Gibt den Wert des aktuellen Objekts an.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


defaultUi

Das defaultUi-Objekt legt die Darstellung von Objekten fest, deren Erscheinungsbild auf die Anwendung übertragen wird.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
ui

defaultUi
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


delete

Das delete-Objekt gibt den Vorgang zum Löschen des aktuellen Datensatzes aus der Datenquelle an.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
command

delete
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


desc

Das desc-Objekt beschreibt lesbare Metadaten.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
area
contentArea
draw
exclGroup
field
pageArea
proto
subform
subformSet
desc
boolean
date
dateTime
decimal
exData
float
image
integer
text
time
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


digestMethod

Das digestMethod-Objekt listet ein Array akzeptabler Digest-Algorithmen für die Erstellung von Unterschriften auf. Gültige Werte für PDF 1.7 sind SHA1, SHA256, SHA384, SHA512 und RIPEMD160.
Dieses Objekt findet nur Anwendung, wenn die digitale Referenz, die die Unterschrift erstellt, öffentliche/private RSA-Schlüssel enthält. Enthält sie öffentliche/private DSA-Schlüssel, ist der Digest-Algorithm immer SHA1 und dieses Objekt wird ignoriert. Der Standardwert (falls nicht angegeben) ist implementierungsspezifisch.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
digestMethod

digestMethod
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


digestMethod

Das digestMethods-Objekt enthält eine Liste akzeptabler digestMethod-Objektwerte. Wenn die Referenz öffentliche/private RSA-Schlüssel enthält, sind SHA1, SHA256, SHA384, SHA512 und RIPEMD160 gültige Werte. Enthält die Referenz öffentliche/private DSA-Schlüssel, ist nur der Wert SHA1 gültig.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
filter

digestMethods
digestMethod
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
type
Gibt das von einem Objekt verwendete Muster an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


draw

Das draw-Objekt enthält nicht interaktiven Formularentwurfsinhalt. In LiveCycle Designer beschreibt das Zeichenobjekt beispielsweise den statischen Text sowie statische Bild-, Kreis-, Linien- und Rechteckobjekte.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
area
pageArea
proto
subform
draw
assist
border
caption
desc
extras
font
margin
para
setProperty
traversal
ui
value
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
{default}
Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Zeichenfolge
Lesen/Schreiben
anchorType
Gibt die Position des Verankerungspunkts des Containers an, wenn er anhand eines positionierten Layouts platziert wird.
Zeichenfolge
Lesen/Schreiben
colSpan
Gibt bei der Verwendung in einem Teilformular mit einer Layoutzeile die Anzahl der Spalten an, die dieses Objekt umfasst.
Zeichenfolge
Lesen/Schreiben
h
Eine Maßeinheit für die Höhe des Layouts.
Zeichenfolge
Lesen/Schreiben
hAlign
Gibt die horizontale Textausrichtung an.
Zeichenfolge
Lesen/Schreiben
locale
Gibt die für den Inhalt des Objekts zu verwendende Sprache und Währung sowie das zu verwendende Uhrzeit-/Datumsformat an.
Zeichenfolge
Lesen/Schreiben
maxH
Gibt die maximale Höhe für Layoutzwecke an.
Zeichenfolge
Lesen/Schreiben
maxW
Gibt die maximale Breite für Layoutzwecke an.
Zeichenfolge
Lesen/Schreiben
minH
Gibt die minimale Höhe für Layoutzwecke an.
Zeichenfolge
Lesen/Schreiben
minW
Gibt die minimale Breite für Layoutzwecke an.
Zeichenfolge
Lesen/Schreiben
presence
Gibt an, ob ein Objekt sichtbar ist.
Zeichenfolge
Lesen/Schreiben
rawValue
Gibt den unformatierten Wert des aktuellen Objekts an.
Zeichenfolge
Lesen/Schreiben
relevant
Steuert, ob ein Formularobjekt beim Drucken des Formulars einbezogen wird.
Zeichenfolge
Lesen/Schreiben
rotate
Dreht das Objekt um den angegebenen Winkel um seinen Verankerungspunkt.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
vAlign
Gibt die vertikale Textausrichtung an.
Zeichenfolge
Lesen/Schreiben
w
Eine Maßeinheit für die Breite des Layouts.
Zeichenfolge
Lesen/Schreiben
x
Gibt die X-Koordinate des Container-Verankerungspunkts im Verhältnis zur oberen, linken Ecke des übergeordneten Containers bei der Platzierung in einem positionierten Layout an.
Zeichenfolge
Lesen/Schreiben
y
Gibt die Y-Koordinate eines Container-Verankerungspunkts im Verhältnis zur oberen, linken Ecke des übergeordneten Containers bei der Platzierung in einem positionierten Layout an.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


dSigData

Das dSigData-Objekt beschreibt eine Einheit von digitalen XML-Unterschriftsdaten.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
TBD

dSigData
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften
Keine
Methoden
Keine


edge

Das edge-Objekt beschreibt einen Bogen, eine Linie oder eine Seite eines Rahmens oder Rechtecks.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
arc
border
line
proto
rectangle
edge
color
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
cap
Gibt den wiedergegebenen Abschluss der Linie an.
Zeichenfolge
Lesen/Schreiben
presence
Gibt an, ob ein Objekt sichtbar ist.
Zeichenfolge
Lesen/Schreiben
stroke
Gibt das Erscheinungsbild einer Linie an.
Zeichenfolge
Lesen/Schreiben
thickness
Gibt die Stärke oder Breite der Linie an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


encoding

Das encoding-Objekt entspricht dem PDFL subFilters-Element. Die gültigen Werte für Adobe sind: adbe.x509.rsa_sha1, adbe.pkcs7.detached und adbe.pkcs7.sha1. Andere Sicherheits-Handler definieren eventuell eigene Werte.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
encodings

encoding
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


encodings

Das encodings-Objekt enthält eine Liste akzeptabler encoding-Objektwerte.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
filter
submit

encodings
encoding
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
type
Gibt das von einem Objekt verwendete Muster an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


event

Das event-Objekt sorgt dafür, dass beim Auftreten eines bestimmten Ereignisses ein Skript ausgeführt wird oder Daten gesendet werden.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
exclGroup
field
proto
subform
event
extras
execute
script
submit
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
activity
Gibt den Namen des Ereignisses an.
Zeichenfolge
Lesen/Schreiben
ref
Gibt einen Ausdruck der Referenz-Syntax an, der die Node im Datenmodell definiert, an die der einschließende Container gebunden wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


eventPseudoModel

Das eventPseudoModel-Objekt ist das Stammobjekt des Ereignismodells.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
Keine

eventPseudoModel
Keine
Übergeordnete Klasse
object-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
change
Gibt den Wert an, den ein Benutzer unmittelbar nach dem Ausführen der Aktion in einem Feld eingibt oder einfügt.
Zeichenfolge
Lesen/Schreiben
commitKey
Beschreibt, wie der aktuelle Wert eines Formularfelds vom Benutzer festgelegt wurde.
Ganzzahl
Lesen/Schreiben
fullText
Stellt den vollständigen (nicht abgeschnittenen) Wert dar, den ein Benutzer in ein Formularfeld einfügt.
Zeichenfolge
Lesen/Schreiben
keyDown
Stellt fest, ob ein Benutzer die Auswahl durch Drücken einer Pfeiltaste trifft. Diese Eigenschaft ist nur für Listenfelder und Dropdown-Listen verfügbar.
Boolescher Wert
Lesen/Schreiben
modifier
Stellt fest, ob bei Ausführung eines bestimmten Ereignisses die Zusatztaste (beispielsweise STRG unter Windows) gedrückt wird.
Boolescher Wert
Lesen/Schreiben
newContentType
Gibt den Inhaltstyp der newText-Eigenschaft an.
Zeichenfolge
Lesen/Schreiben
newText
Gibt den Inhalt des Feldes nach einer Änderung aufgrund von Benutzeraktionen an.
Zeichenfolge
Lesen/Schreiben
prevContentType
Gibt den Inhaltstyp des für die prevText-Eigenschaft angegebenen Werts an.
Zeichenfolge
Lesen/Schreiben
prevText
Gibt den Inhalt des Feldes vor einer Änderung aufgrund von Benutzeraktionen an.
Zeichenfolge
Lesen/Schreiben
reenter
Gibt an, ob das enter -Ereignis zum ersten Mal auftritt. Das enter -Ereignis tritt bei jedem Klick in ein Feld auf.
Boolescher Wert
Lesen/Schreiben
selEnd
Gibt die Indexposition des letzten Zeichens in der Textauswahl an, die während eines Änderungsereignisses in der prevText-Eigenschaft gespeichert wurde.
Ganzzahl
Lesen/Schreiben
selStart
Gibt die Indexposition des ersten Zeichens in der Textauswahl an, die während eines Änderungsereignisses in der prevText-Eigenschaft gespeichert wurde.
Ganzzahl
Lesen/Schreiben
shift
Gibt an, ob während eines bestimmten Ereignisses die Umschalttaste gedrückt gehalten wird.
Boolescher Wert
Lesen/Schreiben
soapFaultCode
Gibt einen Fehlercode an, der auftritt, wenn ein Benutzer versucht, eine Webdienst-Verbindung auszuführen.
Zeichenfolge
Lesen/Schreiben
soapFaultString
Gibt die beschreibende Meldung an, die einem bestimmten Fehlercode für eine Webdienst-Verbindung entspricht.
Zeichenfolge
Lesen/Schreiben
target
Gibt das Objekt an, auf welches das Ereignis wirkt.
Zeichenfolge
Lesen/Schreiben
Methoden

Name

Beschreibung

Rückgabe
emit
Benachrichtigt den Ereignis-Manager über das Eintreten eines Ereignisses.
Leer
reset
Setzt alle Eigenschaften innerhalb des XML-Formularereignismodells zurück.
Leer


exclGroup

Das exclGroup-Objekt beschreibt eine Beziehung des gegenseitigen Ausschlusses zwischen einer Gruppe von Containern.
Eine Ausschlussgruppe wird verwendet, um Optionsfelder gegenseitig auszuschließen. Wenn ein Benutzer ein Element der Gruppe aktiviert, werden die anderen Elemente automatisch deaktiviert. Wenn die Gruppe beispielsweise aus Optionsfeldern besteht, werden die anderen Felder beim Klicken auf ein Feld deaktiviert.
Jedes Element der Ausschlussgruppe ist mit einem on-Wert und einem off-Wert verknüpft. Wenn ein Element aktiviert wird, nimmt es den on-Wert an. Wenn es deaktiviert wird, nimmt es den off-Wert an. Der on-Wert der Elemente einer bestimmten Ausschlussgruppe muss eindeutig sein.
Wenn ein Element der Ausschlussgruppe im Formular ausgewählt wird, muss für den Wert der anderen Elemente der zugehörige on- bzw. off-Wert gesetzt werden. Entsprechend werden die anderen Elemente deaktiviert, wenn einem Element der Ausschlussgruppe der on-Wert zugeordnet wird.
Alternativ kann auch der Ausschlussgruppe selbst ein Wert zugeordnet werden. In diesem Fall werden die einzelnen Elemente nur aktiviert, wenn der Wert mit dem on-Wert für dieses Element übereinstimmt.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
area
pageArea
proto
subform
exclGroup
assist
bind
border
calculate
caption
connect
desc
event
extras
field
margin
para
setProperty
traversal
validate
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
{default}
Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Zeichenfolge
Lesen/Schreiben
access
Steuert den Benutzerzugriff auf den Inhalt eines Containers.
Zeichenfolge
Lesen/Schreiben
accessKey
Gibt eine Zugriffstaste an, die von einer interaktiven Anwendung zum Verschieben des Eingabefokus auf ein bestimmtes Feldelement verwendet wird.
Zeichenfolge
Lesen/Schreiben
anchorType
Gibt die Position des Verankerungspunkts des Containers an, wenn er anhand eines positionierten Layouts platziert wird.
Zeichenfolge
Lesen/Schreiben
borderColor
Gibt den Farbwert für die Begrenzung dieses Feldes an.
Zeichenfolge
Lesen/Schreiben
borderWidth
Gibt die Breite der Begrenzung für dieses Feld an.
Zeichenfolge
Lesen/Schreiben
colSpan
Gibt bei der Verwendung in einem Teilformular mit einer Layoutzeile die Anzahl der Spalten an, die dieses Objekt umfasst.
Zeichenfolge
Lesen/Schreiben
fillColor
Der Wert für die Hintergrundfarbe für dieses Feld.
Zeichenfolge
Lesen/Schreiben
h
Eine Maßeinheit für die Höhe des Layouts.
Zeichenfolge
Lesen/Schreiben
hAlign
Gibt die horizontale Textausrichtung an.
Zeichenfolge
Lesen/Schreiben
layout
Gibt die von diesem Objekt zu verwendende Layoutstrategie an.
Zeichenfolge
Lesen/Schreiben
mandatory
Gibt den nullTest-Wert für das Feld an.
Zeichenfolge
Lesen/Schreiben
mandatoryMessage
Gibt die obligatorische Meldungszeichenfolge für dieses Feld an.
Zeichenfolge
Lesen/Schreiben
maxH
Gibt die maximale Höhe für Layoutzwecke an.
Zeichenfolge
Lesen/Schreiben
maxW
Gibt die maximale Breite für Layoutzwecke an.
Zeichenfolge
Lesen/Schreiben
minH
Gibt die minimale Höhe für Layoutzwecke an.
Zeichenfolge
Lesen/Schreiben
minW
Gibt die minimale Breite für Layoutzwecke an.
Zeichenfolge
Lesen/Schreiben
presence
Gibt an, ob ein Objekt sichtbar ist.
Zeichenfolge
Lesen/Schreiben
rawValue
Gibt den unformatierten Wert des aktuellen Objekts an.
Zeichenfolge
Lesen/Schreiben
relevant
Steuert, ob ein Formularobjekt beim Drucken des Formulars einbezogen wird.
Zeichenfolge
Lesen/Schreiben
transient
Gibt an, ob die verarbeitende Anwendung den Wert der Ausschlussgruppe als Teil eines Formularsende- oder -speichervorgangs speichern muss.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
validationMessage
Gibt die Zeichenfolge für die Überprüfungsmeldung dieses Feldes an.
Zeichenfolge
Lesen/Schreiben
vAlign
Gibt die vertikale Textausrichtung an.
Zeichenfolge
Lesen/Schreiben
w
Eine Maßeinheit für die Breite des Layouts.
Zeichenfolge
Lesen/Schreiben
x
Gibt die X-Koordinate des Container-Verankerungspunkts im Verhältnis zur oberen, linken Ecke des übergeordneten Containers bei der Platzierung in einem positionierten Layout an.
Zeichenfolge
Lesen/Schreiben
y
Gibt die Y-Koordinate eines Container-Verankerungspunkts im Verhältnis zur oberen, linken Ecke des übergeordneten Containers bei der Platzierung in einem positionierten Layout an.
Zeichenfolge
Lesen/Schreiben
Methoden

Name

Beschreibung

Rückgabe
execCalculate
Führt das Berechnungsskript des Feldes aus.
Leer
execEvent
Führt das Ereignisskript des Objekts aus.
Leer
execInitialize
Führt das Initialisierungsskript des Feldes aus.
Leer
execValidate
Führt das Überprüfungsskript des Feldes aus.
Leer
selectedMember
Gibt das ausgewählte Element einer Ausschlussgruppe zurück.
Objekt


exData

Das exData-Objekt beschreibt einen fremden Datentyp.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
desc
exObject
extras
items
proto
value
variables
exData
Keine
Übergeordnete Klasse
content-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
{default}
Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Zeichenfolge
Lesen/Schreiben
contentType
Gibt den Inhaltstyp im referenzierten Dokument an, ausgedrückt als MIME-Typ.
Zeichenfolge
Lesen/Schreiben
href
Gibt einen Verweis auf eine externe Datei oder Ressource an.
Zeichenfolge
Lesen/Schreiben
maxLength
Gibt die maximal zulässige Länge des Inhalts (einschließlich) oder -1 an, um festzulegen, dass keine maximale Länge angewendet wird.
Zeichenfolge
Lesen/Schreiben
transferEncoding
Gibt die Kodierung von binärem Inhalt im referenzierten Dokument an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


execute

Das execute-Objekt bestimmt, an welcher Stelle ein Ereignis verarbeitet wird.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
event
proto

execute
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
connection
Gibt den Namen des zugeordneten Verbindungssteuerelements in der Verbindungsgruppe an.
Zeichenfolge
Lesen/Schreiben
executeType
Gibt an, ob neue Daten in das bestehende Formular importiert oder neue Daten mit dem ursprünglichen Formularentwurf zusammengeführt werden sollen, um ein neues Formular zu erstellen.
Zeichenfolge
Lesen/Schreiben
runAt
Gibt an, welche Anwendung das Skript ausführen kann.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


exObject

Das exObject-Objekt beschreibt ein einzelnes Programm oder ein von der Implementierung abhängiges fremdes Objekt.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
area
exObject
proto
subform
ui
exObject
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
archive
Gibt den URI-Speicherort für eine Archivdatei an, die möglicherweise Programmcode für das exObject -Objekt enthält.
Zeichenfolge
Lesen/Schreiben
classId
Gibt einen URI-Namen oder einen Speicherort für den Programmcode an, der durch das Objekt dargestellt wird.
Zeichenfolge
Lesen/Schreiben
codeBase
Gibt einen URI-Speicherort an, der für die Auflösung einer relativen classId-Eigenschaft verwendet werden kann.
Zeichenfolge
Lesen/Schreiben
codeType
Gibt einen Bezeichner an, der einem MIME-Typ entspricht, der den durch das Objekt dargestellten Programmcode angibt.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


extras

Das extras-Objekt dient als Einfassung um eine oder mehrere Gruppen von benutzerdefinierten Eigenschaften. Der Inhalt dieses Objekts kann von benutzerdefinierten Anwendungen verwendet werden.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
area
barcode
border
break
button
calculate
caption
checkButton
choiceList
color
contentArea
corner
dateTimeEdit
defaultUi
draw
edge
event
exclGroup
exObject
extras
field
fill
font
format
imageEdit
keep
linear
margin
numericEdit
occur
pageArea
pageSet
passwordEdit
pattern
proto
radial
signature
solid
stipple
subform
subformSet
template
textEdit
traversal
traverse
ui
validate

extras
boolean
date
dateTime
decimal
exData
extras
float
image
integer
text
time
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
type
Gibt das von einem Objekt verwendete Muster an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


field

Das field-Objekt beschreibt einen einzelnen interaktiven Container, der Dateninhalte erfassen und darstellen kann.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
area
exclGroup
pageArea
proto
subform
field
assist
bind
bindItems
border
calculate
caption
connect
desc
event
extras
font
format
items
margin
para
setProperty
traversal
ui
validate
value
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
{default}
Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Variabel
Lesen/Schreiben
access
Steuert den Benutzerzugriff auf den Inhalt eines Containers.
Zeichenfolge
Lesen/Schreiben
accessKey
Gibt eine Zugriffstaste an, die von einer interaktiven Anwendung zum Verschieben des Eingabefokus auf ein bestimmtes Feldelement verwendet wird.
Zeichenfolge
Lesen/Schreiben
anchorType
Gibt die Position des Verankerungspunkts des Containers an, wenn er anhand eines positionierten Layouts platziert wird.
Zeichenfolge
Lesen/Schreiben
borderColor
Gibt den Farbwert für die Begrenzung dieses Feldes an.
Zeichenfolge
Lesen/Schreiben
borderWidth
Gibt die Breite der Begrenzung für dieses Feld an.
Zeichenfolge
Lesen/Schreiben
colSpan
Gibt bei der Verwendung in einem Teilformular mit einer Layoutzeile die Anzahl der Spalten an, die dieses Objekt umfasst.
Zeichenfolge
Lesen/Schreiben
fillColor
Der Wert für die Hintergrundfarbe für dieses Feld.
Zeichenfolge
Lesen/Schreiben
fontColor
Der Wert für die Vordergrundfarbe für das Feld.
Zeichenfolge
Lesen/Schreiben
formatMessage
Gibt die Zeichenfolge der Meldung zur Formatprüfung für dieses Feld an.
Zeichenfolge
Lesen/Schreiben
formattedValue
Gibt den formatierten Wert für das Feld an.
Zeichenfolge
Lesen/Schreiben
h
Eine Maßeinheit für die Höhe des Layouts.
Zeichenfolge
Lesen/Schreiben
hAlign
Gibt die horizontale Textausrichtung an.
Zeichenfolge
Lesen/Schreiben
locale
Gibt die für den Inhalt des Objekts zu verwendende Sprache und Währung sowie das zu verwendende Uhrzeit-/Datumsformat an.
Zeichenfolge
Lesen/Schreiben
mandatory
Gibt den nullTest-Wert für das Feld an.
Zeichenfolge
Lesen/Schreiben
mandatoryMessage
Gibt die obligatorische Meldungszeichenfolge für dieses Feld an.
Zeichenfolge
Lesen/Schreiben
maxH
Gibt die maximale Höhe für Layoutzwecke an.
Zeichenfolge
Lesen/Schreiben
maxW
Gibt die maximale Breite für Layoutzwecke an.
Zeichenfolge
Lesen/Schreiben
minH
Gibt die minimale Höhe für Layoutzwecke an.
Zeichenfolge
Lesen/Schreiben
minW
Gibt die minimale Breite für Layoutzwecke an.
Zeichenfolge
Lesen/Schreiben
parentSubform
Gibt das übergeordnete Teilformular (Seite) für dieses Feld an.
Objekt
Lesen
presence
Gibt an, ob ein Objekt sichtbar ist.
Zeichenfolge
Lesen/Schreiben
rawValue
Gibt den unformatierten Wert des aktuellen Objekts an.
Variabel
Lesen/Schreiben
relevant
Steuert, ob ein Formularobjekt beim Drucken des Formulars einbezogen wird.
Zeichenfolge
Lesen/Schreiben
rotate
Dreht das Objekt um den angegebenen Winkel um seinen Verankerungspunkt.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
validationMessage
Gibt die Zeichenfolge für die Überprüfungsmeldung dieses Feldes an.
Zeichenfolge
Lesen/Schreiben
vAlign
Gibt die vertikale Textausrichtung an.
Zeichenfolge
Lesen/Schreiben
w
Eine Maßeinheit für die Breite des Layouts.
Zeichenfolge
Lesen/Schreiben
x
Gibt die X-Koordinate des Container-Verankerungspunkts im Verhältnis zur oberen, linken Ecke des übergeordneten Containers bei der Platzierung in einem positionierten Layout an.
Zeichenfolge
Lesen/Schreiben
y
Gibt die Y-Koordinate eines Container-Verankerungspunkts im Verhältnis zur oberen, linken Ecke des übergeordneten Containers bei der Platzierung in einem positionierten Layout an.
Zeichenfolge
Lesen/Schreiben
Methoden

Name

Beschreibung

Rückgabe
addItem
Fügt dem aktuellen Formularfeld neue Elemente hinzu. Mit dieser Methode werden einer Dropdown-Liste beispielsweise neue Elemente hinzugefügt.
Leer
boundItem
Ruft den Bindewert eines bestimmten Anzeigeelements aus einer Dropdown-Liste oder einem Listenfeld ab.
Zeichenfolge
clearItems
Entfernt alle Elemente aus dem Feld. Es werden beispielsweise alle Elemente in der Dropdown-Liste oder im Listenfeld entfernt.
Leer
execCalculate
Führt das Berechnungsskript des Feldes aus.
Leer
execEvent
Führt das Ereignisskript des Objekts aus.
Leer
execInitialize
Führt das Initialisierungsskript des Feldes aus.
Leer
execValidate
Führt das Überprüfungsskript des Feldes aus.
Leer


fill

Das fill-Objekt wendet eine Farbe und optional wiedergegebene Entwürfe für den von einem Objekt eingeschlossenen Bereich an.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
arc
border
font
proto
rectangle
fill
color
extras
linear
pattern
radial
solid
stipple
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
presence
Gibt an, ob ein Objekt sichtbar ist.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


filter

Das filter-Objekt beschreibt die Kriterien zum Filtern unterschriebener Zertifikate. Mit den unterschriebenen Zertifikaten werden Datenunterschriften erstellt, die den XML-Signaturstandards des W3C-Consortiums entsprechen.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
signature
signData
filter
certificates
digestMethod
encodings
handler
mdp
reasons
timeStamp
Die untergeordneten Objekte mdp, reasons und timestamp sind nur gültig, wenn signature das übergeordnete Objekt ist. Wenn das übergeordnete Objekt signData ist, ignoriert LiveCycle Designer diese untergeordneten Objekte und generiert die Objekte nicht.
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
addRevocationInfo
Gibt an, ob der Zertifikatstatus beim Unterschreiben einer digitalen Unterschrift geprüft wird. Der Zertifikatstatus kann anhand einer Zertifikatssperrliste oder einer OCSP-Antwort (Online Certificate Status Protocol, OCSP) geprüft werden.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


float

Das float-Objekt beschreibt einen Fließkommawert.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
desc
exObject
extras
items
proto
value
variables
float
Keine
Übergeordnete Klasse
content-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
{default}
Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Double
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
value
Gibt den Wert des aktuellen Objekts an.
Double
Lesen/Schreiben
Methoden
Keine


font

Das font-Objekt beschreibt eine in einem Formular verwendete Schrift.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
caption
draw
field
proto
font
extras
fill
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
baselineShift
Gibt entweder eine positive Maßeinheit an, um die eine Schrift von der Grundlinie aus nach oben versetzt wird, oder eine negative Maßeinheit, um die eine Schrift von der Grundlinie aus nach unten versetzt wird.
Zeichenfolge
Lesen/Schreiben
lineThrough
Gibt die Aktivierung einer einzelnen oder doppelten Linie an, die durch den Text verläuft (auch als Durchstreichung bezeichnet).
Zeichenfolge
Lesen/Schreiben
lineThroughPeriod
Steuert das Erscheinungsbild der Linie, die durch den Text verläuft (auch als Durchstreichung bezeichnet).
Zeichenfolge
Lesen/Schreiben
overline
Gibt die Art der Überstreichung und ihre Aktivierung an.
Zeichenfolge
Lesen/Schreiben
overlinePeriod
Bestimmt das Erscheinungsbild der Überstreichung.
Zeichenfolge
Lesen/Schreiben
posture
Gibt an, ob die Schrift kursiv ist.
Zeichenfolge
Lesen/Schreiben
size
Eine Maßeinheit, welche die Größe des Kontrollkästchens bzw. des Optionsfelds angibt. Bei einem Kontrollkästchen stellt sie die Höhe und Breite und bei einem Optionsfeld den Durchmesser dar.
Zeichenfolge
Lesen/Schreiben
typeface
Gibt den Namen der Schrift an.
Zeichenfolge
Lesen/Schreiben
underline
Gibt die Art der Unterstreichung und ihre Aktivierung an.
Zeichenfolge
Lesen/Schreiben
underlinePeriod
Bestimmt das Erscheinungsbild der Unterstreichung.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
weight
Steuert die Schriftbreite.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


form

Das form-Objekt ist das Stammobjekt für das Formularmodell.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
Keine

form
desc
extras
Übergeordnete Klasse
model-Klasse
Eigenschaften
Keine
Methoden

Name

Beschreibung

Rückgabe
execCalculate
Führt das Berechnungsskript des Feldes aus.
Leer
execInitialize
Führt das Initialisierungsskript des Feldes aus.
Leer
execValidate
Führt das Überprüfungsskript des Feldes aus.
Leer
formNodes
Gibt eine Liste mit allen Formularmodellobjekten zurück, die an ein bestimmtes Datenobjekt gebunden sind.
Objekt
recalculate
Erzwingt die Ausführung eines angegebenen Satzes von Skripten, die mit Berechnungsereignissen verknüpft sind. Bei den spezifischen Ereignissen kann es sich um anstehende Berechnungsereignisse oder um alle Berechnungsereignisse handeln.
Leer
remerge
Erzwingt das erneute Zusammenführen von Datenmodell und Vorlagenmodell zur Neuerstellung des Formularmodells. Nach dem erneuten Zusammenführen müssen evtl. vorgenommene Layoutmodell-Verarbeitungen für das fertig gestellte Formular wiederholt werden.
Leer


format

Das format-Objekt schließt Eingabe- und Ausgabeformatierungsinformationen wie z. B. die picture-Klausel ein.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
field
proto

format
extras
picture
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


handler

Das handler-Objekt legt fest, welcher Unterschriften-Handler für einen Datenunterschriftvorgang gemäß den XML-Signaturstandards des W3C-Consortiums verwendet wird.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
filter
proto
handler
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
type
Gibt das von einem Objekt verwendete Muster an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
version
Gibt die Versionsnummer der aktuellen Anwendung an.
Zeichenfolge
Lesen
Methoden
Keine


hostPseudoModel

Das hostPseudoModel-Objekt ist das Stammobjekt des Hostmodells. Verwenden Sie die Hosteigenschaften und -methoden zur Laufzeit.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
Keine

hostPseudoModel
Keine
Übergeordnete Klasse
object-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
appType
Gibt den Namen der Client-Anwendung an, in der sich ein Formular gerade befindet.
Zeichenfolge
Lesen/Schreiben
calculationsEnabled
Gibt an, ob Berechnungsskripten ausgeführt werden.
Boolescher Wert
Lesen/Schreiben
currentPage
Legt die derzeit aktive Seite eines Dokuments zur Laufzeit fest.
Ganzzahl
Lesen/Schreiben
language
Gibt die Sprache der ausgeführten Host-Anwendung zurück.
Zeichenfolge
Lesen
numPages
Gibt die Anzahl der Seiten im aktuellen Dokument zurück.
Ganzzahl
Lesen
platform
Gibt die Plattform des Rechners zurück, auf dem das Skript ausgeführt wird.
Zeichenfolge
Lesen
title
Legt den Titel des Dokuments fest und ruft ihn ab. Nur für Client-Anwendungen verfügbar.
Zeichenfolge
Lesen/Schreiben
validationsEnabled
Gibt an, ob die Überprüfungsskripten ausgeführt werden.
Boolescher Wert
Lesen
variation
Gibt die Verpackung der Anwendung an, die das Skript ausführt.
Zeichenfolge
Lesen
version
Gibt die Versionsnummer der aktuellen Anwendung an.
Zeichenfolge
Lesen
Methoden

Name

Beschreibung

Rückgabe
beep
Lässt das System einen Klang abspielen. Nur für Client-Anwendungen verfügbar.
Leer
exportData
Exportiert die Daten aus dem aktuellen Formular im XDP- oder XML-Format in eine Datei.
Leer
gotoURL
Ruft die angegebene URL ab. Nur für Client-Anwendungen verfügbar.
Leer
importData
Importiert Daten aus einer angegebenen Datei in das aktuelle Formular.
Leer
messageBox
Zeigt ein Dialogfeld an. Nur für Client-Anwendungen verfügbar.
Ganzzahl
openList
Öffnet die durch den usdruck der Referenz-Syntax angegebene Dropdown-Liste. Nur für Client-Anwendungen verfügbar.
Leer
pageDown
Wechselt zur nächsten Seite eines Formulars. Verwenden Sie die pageDown-Methode zur Laufzeit.
Leer
pageUp
Wechselt zur vorherigen Seite eines Formulars. Verwenden Sie die pageUp-Methode zur Laufzeit.
Leer
print
Druckt eine bestimmte Anzahl von Seiten aus einem Dokument. Nur für Client-Anwendungen verfügbar.
Leer
resetData
Setzt die Felder in einem Dokument auf ihre Standardwerte zurück.
Leer
response
Zeigt ein Dialogfeld an, das eine Frage sowie ein Eingabefeld enthält, in dem der Benutzer die Frage beantworten kann. Der Rückgabewert ist eine Zeichenfolge, die die Antwort des Benutzers enthält. Wenn der Anwender im Dialogfeld auf die Schaltfläche „Abbrechen“ klickt, ist die Antwort der Null-Wert.
Zeichenfolge
setFocus
Stellt den Tastaturfokus auf das vom Ausdruck der Referenz-Syntax angegebene Feld ein. Nur für Client-Anwendungen verfügbar.
Leer


image

Das image-Objekt beschreibt ein Bild in einem Formular.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
desc
exObject
extras
items
proto
value
variables
image
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
{default}
Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Zeichenfolge
Lesen
aspect
Gibt an, wie das Bild auf dem nominalen Inhaltsbereich des Bild-Containers abzubilden ist.
Zeichenfolge
Lesen/Schreiben
contentType
Gibt den Inhaltstyp im referenzierten Dokument an, ausgedrückt als MIME-Typ.
Zeichenfolge
Lesen/Schreiben
href
Gibt einen Verweis auf eine externe Datei oder Ressource an.
Zeichenfolge
Lesen/Schreiben
transferEncoding
Gibt die Kodierung von binärem Inhalt im referenzierten Dokument an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
value
Gibt den Wert des aktuellen Objekts an.
Zeichenfolge
Lesen
Methoden
Keine


imageEdit

Das imageEdit-Objekt schließt Steuerelemente zum Bearbeiten von Bildinhalten ein.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
ui

imageEdit
border
extras
margin
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
data
Gibt an, ob das in Widget bereitgestellte Bild als Verweis dargestellt oder eingebettet werden soll.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


insert

Das insert-Objekt gibt den Vorgang zum Einfügen des aktuellen Datensatzes aus der Datenquelle an.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
command

insert
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


instanceManager

Das instanceManager-Objekt verwaltet das Erstellen, Entfernen und Verschieben einer Instanz von Formularmodellobjekten.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
subform

instanceManager
occur
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
count
Gibt die aktuelle Anzahl der Teilformular-Instanzen in einem Formular an.
Zeichenfolge
Lesen/Schreiben
max
Gibt die maximale Anzahl Exemplare für den einschließenden Container oder -1 an, um für Vorkommnisse keine obere Begrenzung festzulegen.
Zeichenfolge
Lesen/Schreiben
min
Gibt die Mindestanzahl der Exemplare für den einschließenden Container an.
Zeichenfolge
Lesen/Schreiben
Methoden

Name

Beschreibung

Rückgabe
addInstance
Fügt dem Formularmodell eine neue Instanz eines Teilformulars oder Teilformularsatzes hinzu.
Objekt
insertInstance
Fügt eine neue Instanz eines Teilformulars oder Teilformularsatzes in ein Formular ein.
Objekt
moveInstance
Verschiebt ein subform -Objekt in einer Gruppe von Teilformular-Instanzen.
Leer
removeInstance
Entfernt ein angegebenes Teilformular oder einen Teilformularsatz aus dem Formularmodell.
Leer
setInstance
Fügt angegebene Teilformulare oder Teilformularsätze aus dem Formularmodell hinzu oder entfernt diese.
Leer


integer

Das integer-Objekt beschreibt einen Ganzzahlwert.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
desc
exObject
extras
items
proto
value
variables
integer
Keine
Übergeordnete Klasse
content-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
{default}
Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Ganzzahl
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
value
Gibt den Wert des aktuellen Objekts an.
Ganzzahl
Lesen/Schreiben
Methoden
Keine


issuers

Das issuers-Objekt beschreibt eine Gruppe von Ausstellerzertifikaten, die für das Unterschreiben von Daten gemäß den XML-Signaturstandards des W3C-Consortiums zulässig sind.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
certificates
proto
issuers
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
type
Gibt das von einem Objekt verwendete Muster an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


items

Das items-Objekt stellt eine Spalte mit Optionen für ein Listenfeld oder ein Kontrollkästchen bereit.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
field
proto

items
boolean
date
dateTime
decimal
exData
float
image
integer
text
time
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
presence
Gibt an, ob ein Objekt sichtbar ist.
Zeichenfolge
Lesen/Schreiben
ref
Gibt einen Ausdruck der Referenz-Syntax an, der die Node im Datenmodell definiert, an die der einschließende Container gebunden wird.
Zeichenfolge
Lesen/Schreiben
save
Bestimmt, ob die Werte in einer bestimmten Spalte sowohl angezeigte als auch gebundene Werte darstellen, oder ob die Daten in der Spalte nur gebundene Daten darstellen.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


keep

Das keep-Objekt beschreibt die Einschränkungen, die für das Speichern von Teilformularen in einem Seiten- oder Inhaltsbereich gelten.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
subform

keep
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
intact
Gibt die Einschränkungen beim Erhalten eines Teilformulars im Inhaltsbereich oder in einer Seite an.
Zeichenfolge
Lesen/Schreiben
next
Gibt die Einschränkungen für die gemeinsame Wiedergabe eines Teilformulars mit dem folgenden Teilformular in einem Inhaltsbereich oder auf einer Seite an.
Zeichenfolge
Lesen/Schreiben
previous
Gibt die Einschränkungen für die gemeinsame Wiedergabe eines Teilformulars mit dem vorherigen Teilformular in einem Inhaltsbereich oder auf einer Seite an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


keyUsage

Das keyUsage-Objekt beschreibt die Einstellungen für die Schlüsselverwendung, die für das Unterschriftszertifikat erforderlich sind. Es wird mit einem Zeichen erstellt, mit dem die einzelnen Schlüsselverwendungstypen dargestellt werden. Das ersten neun Zeichen (von links nach rechts) stellen den erforderlichen Wert für diese Eigenschaften dar: digitalSignature, nonRepudiation, keyEncipherment, dataEncipherment, keyAgreement, keyCertSign, crlSign, encipherOnly, decipherOnly. Alle weiteren Zeichen werden ignoriert.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
certificates

keyUsage
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
crlSign
Gibt eine akzeptable Schlüsselverwendungserweiterung an, die im Unterschriftszertifikat vorhanden sein muss.
Zeichenfolge
Lesen/Schreiben
dataEncipherment
Gibt eine akzeptable Schlüsselverwendungserweiterung an, die im Unterschriftszertifikat vorhanden sein muss.
Zeichenfolge
Lesen/Schreiben
decipherOnly
Gibt eine akzeptable Schlüsselverwendungserweiterung an, die im Unterschriftszertifikat vorhanden sein muss.
Zeichenfolge
Lesen/Schreiben
digitalSignature
Gibt eine akzeptable Schlüsselverwendungserweiterung an, die im Unterschriftszertifikat vorhanden sein muss.
Zeichenfolge
Lesen/Schreiben
encipherOnly
Gibt eine akzeptable Schlüsselverwendungserweiterung an, die im Unterschriftszertifikat vorhanden sein muss.
Zeichenfolge
Lesen/Schreiben
keyAgreement
Gibt eine akzeptable Schlüsselverwendungserweiterung an, die im Unterschriftszertifikat vorhanden sein muss.
Zeichenfolge
Lesen/Schreiben
keyCertSign
Gibt eine akzeptable Schlüsselverwendungserweiterung an, die im Unterschriftszertifikat vorhanden sein muss.
Zeichenfolge
Lesen/Schreiben
keyEncipherment
Gibt eine akzeptable Schlüsselverwendungserweiterung an, die im Unterschriftszertifikat vorhanden sein muss.
Zeichenfolge
Lesen/Schreiben
nonRepudiation
Gibt eine akzeptable Schlüsselverwendungserweiterung an, die im Unterschriftszertifikat vorhanden sein muss.
Zeichenfolge
Lesen/Schreiben
type
Gibt das von einem Objekt verwendete Muster an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


layoutPseudoModel

Mit dem layoutPseudoModel-Objekt werden Parameter abgefragt, die erst nach dem Erstellen des Layouts für das Formular bekannt sind, wie z. B. auf welcher Seite sich ein Formularentwurfsobjekt befindet, die Gesamtzahl der Seiten, die Anzahl der Seiten, die ein Objekt umfasst, oder die Ausrichtung des Formularentwurfsobjekts.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
Keine

layoutPseudoModel
Keine
Übergeordnete Klasse
object-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
ready
Gibt an, ob der Formularlayout-Prozess abgeschlossen ist und Skripterstellungsaufgaben beginnen können.
Boolescher Wert
Lesen
Methoden

Name

Beschreibung

Rückgabe
absPage
Stellt fest, auf welcher Seite des Formulars ein bestimmtes Formularentwurfsobjekt zuerst vorkommt.
Ganzzahl
absPageCount
Stellt die Seitenzahl des aktuellen Formulars fest.
Ganzzahl
absPageSpan
Stellt fest, wie viele Formularseiten ein bestimmtes Formularentwurfsobjekt umfasst.
Ganzzahl
h
Bestimmt die Höhe eines angegebenen Formularentwurfsobjekts.
Double
Seite
Bestimmt die Seitenzahl, die ein angegebenes Formularentwurfsobjekt enthält. Bei einem Objekt, das auf mehreren Seiten vorkommt, gibt diese Methode die erste Seite zurück, auf der das Objekt auftritt.
Ganzzahl
pageContent
Ruft Formularentwurfsobjekttypen von einer angegebenen Seite eines Formulars ab.
Objekt
pageCount
Stellt fest, wie viele Seiten das aktuelle Formular hat.
Ganzzahl
pageSpan
Stellt fest, wie viele logische Seiten ein bestimmtes Formularentwurfsobjekt umfasst.
Ganzzahl
relayout
Wendet die Layoutoptionen erneut auf das aktuelle Formular an.
Leer
relayoutPageArea
Ersetzt das Layout des PageArea-Objektinhalts durch ein neues Layout.
Leer
w
Bestimmt die Breite eines angegebenen Formularentwurfsobjekts.
Double
x
Bestimmt die X-Koordinate eines angegebenen Formularentwurfsobjekts.
Double
y
Bestimmt die Y-Koordinate eines angegebenen Formularentwurfsobjekts.
Double


line

Das line-Objekt beschreibt eine wiedergegebene Zeile in einem Formular.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
value

line
edge
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
hand
Beschreibt die Ausrichtung einer Linie oder Kante.
Zeichenfolge
Lesen/Schreiben
slope
Gibt die Ausrichtung der Linie an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


linear

Das linear-Objekt beschreibt einen linearen Farbverlauf in einem Formular.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
fill
proto

linear
color
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
type
Gibt das von einem Objekt verwendete Muster an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


manifest

Das manifest-Objekt enthält eine Liste mit Verweisen auf alle Nodes einer Dokumentunterschrift.
Ist das manifest-Objekt ein untergeordnetes Objekt des signature-Objekts, kann die Dokumentunterschrift statt des gesamten Formulars auch eine Sammlung von Nodes schützen.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
signature
signData
manifest
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
{default}
Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Boolescher Wert
Lesen/Schreiben
action
Gibt die von einer Dokumentunterschrift geschützten Formular-Nodes an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden

Name

Beschreibung

Rückgabe
evaluate
Ruft die Liste der Objekte ab, auf die im Manifest verwiesen wird.
Objekt


map

Das map-Objekt gibt Datenzuordnungen aus den Spaltennamen einer Datenquelle an.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
query

map
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
bind
Gibt den Namen einer eindeutigen Bindungs-ID an, wobei Spalten aus der durch die from-Eigenschaft angegebene Datenquelle gebunden sind.
Zeichenfolge
Lesen/Schreiben
from
Gibt den ursprünglichen Spaltennamen in der Datenquelle an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


margin

Das margin-Objekt gibt Werte für die Ränder eines Formularentwurfsobjekts an.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
border
caption
checkButton
choiceList
dateTimeEdit
draw
exclGroup
field
imageEdit
numericEdit
passwordEdit
proto
signature
subform
textEdit
margin
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
bottomInset
Eine Maßeinheit, die angibt, wie groß die untere Vertiefung sein soll.
Zeichenfolge
Lesen/Schreiben
leftInset
Gibt die Größe der linken Vertiefung an.
Zeichenfolge
Lesen/Schreiben
rightInset
Gibt die Größe der rechten Vertiefung an.
Zeichenfolge
Lesen/Schreiben
topInset
Eine Maßeinheit, die angibt, wie groß die obere Vertiefung sein soll.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


mdp

Das mdp-Objekt bietet Unterstützung für digitale MDP+-Unterschriften (Modify Detection Prevention Plus, MDP+). Acrobat 8.0 und höher unterstützen digitale MDP+-Unterschriften für XFA-basierte Formulare.
In LiveCycle Designer werden MDP+-Unterschriften mit einem Dokumentunterschriftsfeld implementiert. Mit Hilfe von Dokumentunterschriftsfeldern können Sie eine Sammlung von Formularobjekten angeben, die durch die Dokumentunterschrift geschützt werden. Durch Dokumentunterschriften lässt sich das Formular bzw. ein Teil des Formulars vor Änderungen schützen.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
filter

mpd
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
permissions
Gibt die Zugriffsberechtigungen an, die für ein Formular mit Verfasserunterschrift gewährt werden.
Zeichenfolge
Lesen/Schreiben
signatureType
Gibt an, wie ein Formular mit Dokumentunterschrift als zertifiziertes PDF-Dokument gespeichert wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


medium

Das medium-Objekt beschreibt ein physikalisches Medium, das wiedergegeben werden soll.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
pageArea
medium
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
imagingBBox
Gibt einen Bereich im Medium an, das zur Wiedergabe mit vier kommagetrennten Maßeinheiten verfügbar ist und die Maßeinheiten für x, y, Breite und Höhe darstellt.
Zeichenfolge
Lesen/Schreiben
long
Gibt die Länge der langen Kante des Mediums an. Die durch die long -Eigenschaft angegebene Länge muss größer sein als die durch die short-Eigenschaft angegebene Länge.
Zeichenfolge
Lesen/Schreiben
orientation
Gibt die Ausrichtung des Mediums an.
Zeichenfolge
Lesen/Schreiben
short
Gibt die Länge der kurzen Kante des medium -Objekts an.
Zeichenfolge
Lesen/Schreiben
stock
Gibt den Namen einer Standardpapiergröße an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


message

Das message-Objekt speichert ein oder mehrere Teilobjekte, die Überprüfungsfehlermeldungen enthalten.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
calculate
proto
validate

message
text
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


numericEdit

Das numericEdit-Objekt beschreibt ein Steuerelement zum Bearbeiten von numerischen Inhalten.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
ui

numericEdit
border
comb
extras
margin
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
hScrollPolicy
Gibt an, ob in einem Feld der horizontale Bildlauf verfügbar ist.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


occur

Das occur-Objekt beschreibt die Einschränkungen in Bezug auf die Anzahl der zulässigen Instanzen für den zugehörigen einschließenden Container.
Ändern Sie das occur-Objekt im template:ready-Ereignis. Auf das template:ready-Ereignis kann über die Benutzeroberfläche nicht zugegriffen werden. Das occur-Objekt kann beim form:ready-Ereignis nicht geändert werden, da dieses Ereignis zu spät in der Formularverarbeitung auftritt.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
pageArea
pageSet
proto
subform
subformSet

occur
extras
script (occur.script ist für die zukünftige Verwendung reserviert)
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
initial
Gibt die Anfangsanzahl der Exemplare für den einschließenden Container an.
Zeichenfolge
Lesen/Schreiben
max
Gibt die maximale Anzahl Exemplare für den einschließenden Container oder -1 an, um für Vorkommnisse keine obere Begrenzung festzulegen.
Zeichenfolge
Lesen/Schreiben
min
Gibt die Mindestanzahl der Exemplare für den einschließenden Container an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


oid

Das oid-Objekt beschreibt eine Objektkennung (OID, Object Identifier) der Zertifikatsrichtlinien, die im unterschreibenden Zertifikat vorhanden sein muss.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
oids
proto
oid
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


oids

Das oids-Objekt beschreibt eine Gruppe mit Objektkennungen (OIDs, Object Identifiers), die für das Unterschreiben von Daten gemäß den XML-Signaturstandards des W3C-Consortiums gelten.
Dieses Objekt kann nur angewendet werden, wenn ein nicht leeres, nebengeordnetes issuers-Objekt vorhanden ist.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
certificates
proto
oid s
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
type
Gibt das von einem Objekt verwendete Muster an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


operation

Das operation-Objekt stellt einen bestimmten Vorgang dar, der von einer bestimmten WSDL-Adresse bereitgestellt wird. Jede Operation stellt eine Datenverbindung dar.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
wsdlConnection

operation
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
input
Gibt eine Eingabemeldung an, die mit einem bestimmten WSDL-Verbindungsvorgang verknüpft ist.
Zeichenfolge
Lesen/Schreiben
output
Gibt die Ausgabemeldung an, die mit einem bestimmten WSDL-Verbindungsvorgang verknüpft ist.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


overflow

Das overflow-Objekt speichert Eigenschaften, die verwendet werden, wenn ein übergeordnetes subform auf den aktuellen contentArea überläuft.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
subform
subformSet

overflow
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
leader
Gibt zum Platzieren im oberen Bereich eines Inhalts- oder Seitenbereichs das subform -Objekt oder das subformSet -Objekt an.
Zeichenfolge
Lesen/Schreiben
target
Gibt das Objekt an, auf welches das Ereignis wirkt.
Zeichenfolge
Lesen/Schreiben
trailer
Gibt das subform - bzw. subformSet -Objekt an, das im unteren Bereich eines Inhalts- oder Seitenbereichs platziert werden soll.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


packet

Das packet-Objekt speichert nicht erkannte Objekte, d. h. Objekte, die keinem der anderen XML-Formularobjektmodelle entsprechen. Dieses Objekt stellt eine Möglichkeit zum Kopieren, Verschieben oder Abrufen der Informationen in diesen nicht erkannten Objekten bereit.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
dataGroup

packet
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
content
Gibt den Inhalt des Objekts an.
Zeichenfolge
Lesen/Schreiben
Methoden

Name

Beschreibung

Rückgabe
getAttribute
Ruft den Wert einer angegebenen Eigenschaft ab.
Zeichenfolge
removeAttribute
Entfernt die angegebene Eigenschaft.
Leer
setAttribute
Legt den Wert einer angegebenen Eigenschaft fest.
Leer


pageArea

Das pageArea-Objekt beschreibt eine Wiedergabeoberfläche.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
pageSet
proto

pageArea
area
contentArea
desc
draw
exclGroup
extras
field
medium
occur
subform
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
blank (veraltet)
Gibt an, ob der Seitenbereich leer sein soll, was eine besonderen Behandlung durch das Ausgabegerät zur Folge hat.
Zeichenfolge
Lesen/Schreiben
blankOrNotBlank
Gibt an, ob der Seitenbereich leer sein soll, was eine besonderen Behandlung durch das Ausgabegerät zur Folge hat.
Zeichenfolge
Lesen/Schreiben
initialNumber
Stellt dem ersten Seitenexemplar in einer Folge die erste Seitennummer bereit, sofern sich die Eigenschaft in einem Bereich mit nummerierten Seiten befindet.
Zeichenfolge
Lesen/Schreiben
numbered
Gibt an, ob der Seitenbereich als nummerierter Seitenbereich betrachtet wird.
Zeichenfolge
Lesen/Schreiben
oddOrEven
Gibt an, ob die Seite bei der Paginierung in einem Seitensatz gerade oder ungerade ist.
Zeichenfolge
Lesen/Schreiben
pagePosition
Gibt die Position einer Seite innerhalb eines Seitensatzes an.
Zeichenfolge
Lesen/Schreiben
relevant
Steuert, ob ein Formularobjekt beim Drucken des Formulars einbezogen wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


pageSet

Das pageSet-Objekt beschreibt eine Gruppe verwandter Seitenbereichsobjekte.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
pageSet
proto
subform

pageSet
extras
occur
pageArea
pageSet
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
relation
Gibt die Beziehung zwischen den Elementen einer Gruppe an.
Zeichenfolge
Lesen/Schreiben
relevant
Steuert, ob ein Formularobjekt beim Drucken des Formulars einbezogen wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


para

Das para-Objekt gibt die Standardeigenschaften für Absätze und Ausrichtung an, die auf den Inhalt eines einschließenden Containers anzuwenden sind.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
caption
draw
exclGroup
field
proto
subform
para
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
hAlign
Gibt die horizontale Textausrichtung an.
Zeichenfolge
Lesen/Schreiben
lineHeight
Gibt die Zeilenhöhe an, die auf den Absatzinhalt angewendet werden soll.
Zeichenfolge
Lesen/Schreiben
marginLeft
Gibt an, wie groß der linke Einzug des Absatzes sein soll.
Zeichenfolge
Lesen/Schreiben
marginRight
Gibt an, wie groß der rechte Einzug des Absatzes sein soll.
Zeichenfolge
Lesen/Schreiben
preserve
Gibt Einschränkungen der Absatzkontrolle zum Überlaufverhalten des Inhalts im einschließenden Container an.
Zeichenfolge
Lesen/Schreiben
radixOffset
Gibt einen Versatzwert für den Verankerungspunkt des Absatzes an.
Zeichenfolge
Lesen/Schreiben
spaceAbove
Gibt den vertikalen Abstand an, der zusätzlich zum maximalen Zeilenabstand der ersten Zeile im Absatz vorgesehen werden soll.
Zeichenfolge
Lesen/Schreiben
spaceBelow
Gibt den vertikalen Abstand an, der zusätzlich zum maximalen Zeilenabstand der ersten Zeile im Absatz vorgesehen werden soll.
Zeichenfolge
Lesen/Schreiben
tabDefault
Gibt den Abstand zwischen Standardtabstopps an.
Zeichenfolge
Lesen/Schreiben
tabStops
Gibt eine durch Leerzeichen getrennte Liste mit Tabstopp-Positionen an.
Zeichenfolge
Lesen/Schreiben
textIndent
Gibt die horizontale Position der ersten Zeile im Verhältnis zu den anderen Zeilen in einem Absatz an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
vAlign
Gibt die vertikale Textausrichtung an.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


password

Das password-Objekt gibt das Kennwort für die Datenquelle an (sofern für eine Verbindung erforderlich).
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
connect

password
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


passwordEdit

Das passwordEdit-Objekt beschreibt ein Steuerelement zum Bearbeiten von Kennwortinhalten. Auf der Benutzeroberfläche ist die visuelle Darstellung des Inhalts in der Regel ausgeblendet.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
ui

passwordEdit
border
extras
margin
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
hScrollPolicy
Gibt an, ob in einem Feld der horizontale Bildlauf verfügbar ist.
Zeichenfolge
Lesen/Schreiben
passwordChar
Gibt das Zeichen an, das im Formular für jedes Zeichen eines vom Benutzer eingegebenen Kennworts anzeigt wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


pattern

Das pattern-Objekt beschreibt ein Füllmuster für ein Formularentwurfsobjekt.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
fill
proto

pattern
color
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
type
Gibt das von einem Objekt verwendete Muster an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


picture

Das picture-Objekt beschreibt Informationen zur Eingabemaske und zur Ausgabeformatierung.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
bind
connect
format
proto
ui
validate
picture
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
{default}
Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
value
Gibt den Wert des aktuellen Objekts an.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


proto

Das proto-Objekt beschreibt eine Gruppe von wiederverwendbaren Objektdefinitionen.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
subform

proto
arc
area
assist
barcode
bind
bindItems
boolean
border
break
breakAfter
breakBefore
button
calculate
caption
checkButton
choiceList
color
connect
contentArea
corner
date
dateTime
dateTimeEdit
decimal
defaultUi
desc
draw
edge
event
exclGroup
exData
execute
exObject
extras
field
fill
float
font
format
image
imageEdit
integer
items
keep
line
linear
margin
medium
message
numericEdit
occur
pageArea
pageSet
para
passwordEdit
pattern
picture
radial
rectangle
script
setProperty
signature
signedState
solid
speak
stipple
subform
subformSet
submit
template
text
textEdit
time
toolTip
traversal
traverse
ui
validate
value
variables
Übergeordnete Klasse
node-Klasse
Eigenschaften
Keine
Methoden
Keine


query

Das query-Objekt stellt eine spezielle Abfrage einer bestimmten Datenquelle dar.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
command

query
recordSet
select
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
commandType
Gibt den Befehlstyp an, der von einer Datenabfrage verwendet wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


radial

Das radial-Objekt beschreibt einen radialen Farbverlauf.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
fill
proto

radial
color
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
type
Gibt das von einem Objekt verwendete Muster an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


reason

Das reason-Objekt enthält einen akzeptablen Grund für das Unterschreiben von Daten gemäß den XML-Signaturstandards des W3C-Consortiums.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
reasons
reason
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


reasons

Das reasons-Objekt enthält akzeptable Gründe für das Unterschreiben von Daten gemäß den XML-Signaturstandards des W3C-Consortiums.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
filter
proto
reasons
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
type
Gibt das von einem Objekt verwendete Muster an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


recordSet

Das recordSet-Objekt enthält eine Reihe von Datensätzen, die auf einer bestimmten Abfrage der Datenquelle basieren. Diese Datensätze können angezeigt, neu angeordnet, hinzugefügt und entfernt werden.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
query

recordSet
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
bofAction
Gibt die Aktion an, die ausgeführt wird, wenn der aktuelle Datensatz der erste Datensatz in der Datensatzgruppe ist.
Zeichenfolge
Lesen/Schreiben
cursorLocation
Gibt den Speicherort der Cursorbibliothek an, die mit der Datensatzgruppe verwendet wird.
Zeichenfolge
Lesen/Schreiben
cursorType
Gibt den Typ des Cursors an, der beim Öffnen der Datensatzgruppe verwendet wird.
Zeichenfolge
Lesen/Schreiben
eofAction
Gibt die Aktion an, die durchgeführt wird, wenn der aktuelle Datensatz der letzte Datensatz in der Datensatzgruppe ist.
Zeichenfolge
Lesen/Schreiben
lockType
Gibt den Typ der Sperrfunktion an, die für die Datenquelle verwendet werden soll.
Zeichenfolge
Lesen/Schreiben
max
Gibt die maximale Anzahl Exemplare für den einschließenden Container oder -1 an, um für Vorkommnisse keine obere Begrenzung festzulegen.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


rectangle

Das rectangle-Objekt beschreibt ein wiedergegebenes Rechteck.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
value

rectangle
corner
edge
fill
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
hand
Beschreibt die Ausrichtung einer Linie oder Kante.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


ref

Das ref-Objekt enthält einen Ausdruck der Referenz-Syntax, der eine Node angibt, die in einer digitalen XML-Unterschrift enthalten sein muss.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
bindItems
manifest
proto
setProperty
ref
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


rootElement

Das rootElement-Objekt bestimmt das XML-Element in einer XML-Schemadatenverbindung für die Verwendung als Stamm einer Datendatei, die im Formular verwendet wird.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
xsdConnection

rootElement
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


script

Das script-Objekt enthält ein in FormCalc oder JavaScript geschriebenes Skript.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
breakAfter
breakBefore
calculate
event
occur (occur.script ist für die zukünftige Verwendung reserviert)
proto
traverse
validate
variables
script
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
{default}
Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Zeichenfolge
Lesen/Schreiben
binding
Gibt den Typ der Anwendung an, an die das Skript weitergeleitet wird.
Zeichenfolge
Lesen/Schreiben
contentType
Gibt den Inhaltstyp im referenzierten Dokument an, ausgedrückt als MIME-Typ.
Zeichenfolge
Lesen/Schreiben
runAt
Gibt an, welche Anwendung das Skript ausführen kann.
Zeichenfolge
Lesen/Schreiben
stateless
Bestimmt, ob die Variablen eines Skripts zwischen zwei Aufrufen bestehen bleiben.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
value
Gibt den Wert des aktuellen Objekts an.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


select

Das select-Objekt enthält die Abfrageinformationen zur select-Anweisung für die Verwendung mit der aktuellen Datenquelle.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
query

select
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


setProperty

Das setProperty -Objekt bearbeitet eine Eigenschaft des ihm übergeordneten Objekts. Ein übergeordnetes Objekt kann beliebig viele setProperty -Objekte enthalten.
Bei der target-Eigenschaft handelt es sich um einen Ausdruck der Referenz-Syntax, der eine Eigenschaft des übergeordneten Objekts beschreibt. Diese Eigenschaft gibt die Node an, für die der Wert auf den vom ref-Objekt und der connection-Eigenschaft angegebenen Wert festgelegt werden muss. Das Ziel, das beispielsweise das toolTip-Objekt für ein Feld setzt, ist access.toolTip.
Innerhalb des übergeordneten Containers gibt es keine Einschränkungen hinsichtlich der Ziele für die Eigenschaften des setProperty-Objekts. Das setProperty-Objekt kann jedoch nicht auf die Eigenschaften geschachtelter Container verweisen.
Die Anwendung des setProperty-Objekts ist ein Vorlagenvorgang. Beim Erstellen des Formulars aufgrund einer Zusammenführung wird der Verweis aufgelöst und der Datenwert auf die target-Eigenschaft angewendet. Zwischen der Daten-Node und der Eigenschaft gibt es keine permanente Verknüpfung. Nachfolgende Änderungen an den Daten werden nur an die Zieleigenschaft übertragen, wenn eine weitere Zusammenführung erfolgt.
Die Verwendung des setProperty-Objekts für bindungsbezogene Eigenschaften, wie z. B. das bind-Objekt oder #name, ist nicht sinnvoll, da die setProperty-Anwendung nach der Zusammenführung auftritt.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
draw
exclGroup
field
proto
subform
setProperty
ref
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
connection
Gibt den Namen des zugeordneten Verbindungssteuerelements in der Verbindungsgruppe an.
Zeichenfolge
Lesen/Schreiben
target
Gibt das Objekt an, auf welches das Ereignis wirkt.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


signature

Das signature-Objekt bestimmt, welche anderen Objekte durch eine Unterschrift unterschrieben werden.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
ui

signature
border
extras
filter
manifest
margin
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
type (signature.type is reserved for future use)
(type)Specifies the pattern used by an object.
String
Read /Write
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


signatureProperties

Das signatureProperties-Objekt speichert die Eigenschaften einer XML-Datensignatur. Objekte, die in dieses Objekt eingefügt werden, werden als XMP-Daten in die XML-Unterschrift eingefügt.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
signData

signtureProperties
signedState
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


signaturePseudoModel

Das signaturePseudoModel-Objekt ist das Stammobjekt des Unterschriftsmodells.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
Keine

signaturePseudoModel
Keine
Übergeordnete Klasse
object-Klasse
Methoden

Name

Beschreibung

Rückgabe
clear
Entfernt eine vorhandene Unterschrift.
Boolescher Wert
enumerate
Führt alle im Dokument gefundenen XML-Unterschriften auf.
Objekt
sign
Unterschreibt eine bestimmte Node-Liste und platziert die Unterschrift am Zielort.
Boolescher Wert
verify
Überprüft die Gültigkeit einer Unterschrift.
Ganzzahl


signData

Das signData-Objekt steuert das Erstellen einer Datenunterschrift gemäß den XML-Signaturstandards des W3C-Consortiums.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
event
proto
submit

signData
filter
manifest
ref
signatureProperties
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
operation
Bestimmt, wann eine Verknüpfung verwendet wurde.
Zeichenfolge
Lesen/Schreiben
ref
Gibt einen Ausdruck der Referenz-Syntax an, der die Node im Datenmodell definiert, an die der einschließende Container gebunden wird.
Zeichenfolge
Lesen/Schreiben
target
Gibt das Objekt an, auf welches das Ereignis wirkt.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


Zurück Weiter

Skripterstellung > Skript-Referenz > Objekte > signedState

signedState

Für die zukünftige Verwendung reserviert.


signing

Das signing-Objekt beschreibt eine Sammlung von Unterschriftszertifikaten, die für die Datenunterschrift gemäß den XML-Signaturstandards des W3C-Consortiums zulässig sind.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
certificates
proto
signing
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
type
Gibt das von einem Objekt verwendete Muster an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


soapAction

Das soapAction-Objekt enthält eine vollständig qualifizierte SOAP-Aktion.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
wsdlConnection

soapAction
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


soapAddress

Das soapAddress-Objekt speichert die vollständig qualifizierte Position des SOAP-Endpunkts. Diese Position muss im Standardformat gemäß RFC 2396 angegeben sein.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
wsdlConnection

soapAddress
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


solid

Das solid-Objekt beschreibt einen durchgehenden Füllstil eines Formularentwurfsobjekts.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
fill
proto

solid
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


source

Das source-Objekt stellt eine externe Datenquelle dar.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
sourceSet

source
connect
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
db
Gibt den Namen einer vom Anbieter bereitgestellten Datenbank an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden

Name

Beschreibung

Rückgabe
addNew
Fügt der Datensatzgruppe einen neuen Datensatz hinzu.
Leer
cancel
Storniert vor dem Aufruf der update-Methode alle Änderungen, die an der derzeitigen oder neuen Zeile eines Datensatzobjekts oder an der Feldsammlung eines Datensatzobjekts vorgenommen wurden.
Leer
cancelBatch
Bricht eine anstehende Batch-Aktualisierung ab.
Leer
close
Schließt eine Verbindung mit einer Datenquelle.
Leer
delete
Löscht den aktuellen Datensatz aus der Datensatzgruppe.
Leer
first
Wechselt zum ersten Datensatz in der Datensatzgruppe und füllt das Datenmodell mit den Daten aus dem Datensatz.
Leer
hasDataChanged
Stellt fest, ob die aktuellen Datensatzdaten verändert wurden. Hierbei handelt es sich um einen Test des aktiven Datensatzes vor dem Festschreiben. Bei diesem Test werden die aktuellen Datensatzdaten mit den Datensatzdaten aus der aktuellen Datenquelle verglichen. Wenn die Daten geändert wurden, gibt diese Methode den Wert True zurück.
Boolescher Wert
isBOF
Stellt fest, ob sich die aktuelle Position am Anfang des Datensatzes befindet.
Boolescher Wert
isEOF
Stellt fest, ob sich die aktuelle Position am Ende des Datensatzes befindet.
Boolescher Wert
last
Wechselt zum letzen Datensatz in der Datensatzgruppe und füllt das Datenmodell mit den Daten aus dem Datensatz.
Leer
next
Wechselt zum nächsten Datensatz in der Datensatzgruppe und füllt das Datenmodell mit den Daten aus dem Datensatz.
Leer
open
Stellt eine Verbindung mit der Datenquelle her und füllt das Datenmodell mit den Ergebnissen des aktuellen Datensatzes.
Leer
previous
Wechselt zum vorherigen Datensatz in der Datensatzgruppe und füllt das Datenmodell mit den Daten aus dem Datensatz.
Leer
requery
Aktualisiert die aktuelle Datenbindung durch erneutes Ausführen der Abfrage, auf der die Objektdaten basieren. Das Aufrufen dieser Methode entspricht dem Aufrufen der Methoden close und open nacheinander.
Leer
resync
Aktualisiert die aktuelle Datensatzgruppe oder Datenverbindung.
Leer
update
Aktualisiert den aktuellen Datensatz in der Datensatzgruppe.
Leer
updateBatch
Schreibt alle anstehenden Batch-Aktualisierungen in die Datenquelle.
Leer


sourceSet

Das sourceSet-Objekt ist das Stammobjekt des sourceSet-Modells.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
Keine

sourceSet
source
Übergeordnete Klasse
model-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


speak

Die speak-Eigenschaft gibt eine akustische Meldung wieder, die den Inhalt eines Containerobjekts, wie z. B. eines Feldes oder eines Teilformulars, beschreibt. Dieses Objekt wird von nicht interaktiven Formularanwendungen ignoriert.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
assist
proto

speak
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
disable
Deaktiviert die akustische Meldung.
Zeichenfolge
Lesen/Schreiben
priority
Ändert den Suchpfad von Text, für den eine Sprachausgabe erfolgen soll. Das in dieser Eigenschaft angegebene Objekt wird an den Anfang des Suchpfads verschoben. Die anderen Objekte behalten ihre relative Position in der Reihenfolge bei.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


stipple

Das stipple-Objekt beschreibt einen Tupfeneffekt für ein Formularobjekt.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
fill
proto

stipple
color
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
rate
Gibt den Prozentsatz für die Tupfenfarbe an, die über eine Hintergrundfarbfläche verteilt wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


subform

Das subform-Objekt beschreibt ein Teilformular, das andere Container einschließen kann.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte

area
proto
subform
subformSet
subform
assist
bind
bookend
border
break
breakAfter
breakBefore
calculate
desc
extras
instanceManager
keep
margin
occur
overflow
pageSet
para
setProperty
subform
subformSet
traversal
validate
variables
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
allowMacro
Gibt an, ob die verarbeitende Anwendung die Ausgabe durch Generieren eines Druckermakros für den gesamten draw-Inhalt des Teilformulars optimieren darf.
Zeichenfolge
Lesen/Schreiben
anchorType
Gibt die Position des Verankerungspunkts des Containers an, wenn er anhand eines positionierten Layouts platziert wird.
Zeichenfolge
Lesen/Schreiben
colSpan
Gibt bei der Verwendung in einem Teilformular mit einer Layoutzeile die Anzahl der Spalten an, die dieses Objekt umfasst.
Zeichenfolge
Lesen/Schreiben
columnWidths
Gibt die Breite für Spalten einer Tabelle an.
Zeichenfolge
Lesen/Schreiben
h
Eine Maßeinheit für die Höhe des Layouts.
Zeichenfolge
Lesen/Schreiben
hAlign
Gibt die horizontale Textausrichtung an.
Zeichenfolge
Lesen/Schreiben
layout
Gibt die von diesem Objekt zu verwendende Layoutstrategie an.
Zeichenfolge
Lesen/Schreiben
locale
Gibt die für den Inhalt des Objekts zu verwendende Sprache und Währung sowie das zu verwendende Uhrzeit-/Datumsformat an.
Zeichenfolge
Lesen/Schreiben
maxH
Gibt die maximale Höhe für Layoutzwecke an.
Zeichenfolge
Lesen/Schreiben
maxW
Gibt die maximale Breite für Layoutzwecke an.
Zeichenfolge
Lesen/Schreiben
minH
Gibt die minimale Höhe für Layoutzwecke an.
Zeichenfolge
Lesen/Schreiben
minW
Gibt die minimale Breite für Layoutzwecke an.
Zeichenfolge
Lesen/Schreiben
presence
Gibt an, ob ein Objekt sichtbar ist.
Zeichenfolge
Lesen/Schreiben
relevant
Steuert, ob ein Formularobjekt beim Drucken des Formulars einbezogen wird.
Zeichenfolge
Lesen/Schreiben
restoreState
Stellt die Formular-Nodes eines Formulars mit ihrem ursprünglichen Zustand wieder her und setzt die visuellen Eigenschaften von Feldern, wie etwa Änderungen an Begrenzungsfarben, zurück.
Zeichenfolge
Lesen/Schreiben
scope
Bestimmt die Teilnahme des Teilformulars an der Datenbindung sowie an Ausdrücken der Referenz-Syntax.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
validationMessage
Gibt die Zeichenfolge für die Überprüfungsmeldung dieses Feldes an.
Zeichenfolge
Lesen/Schreiben
vAlign
Gibt die vertikale Textausrichtung an.
Zeichenfolge
Lesen/Schreiben
w
Eine Maßeinheit für die Breite des Layouts.
Zeichenfolge
Lesen/Schreiben
x
Gibt die X-Koordinate des Container-Verankerungspunkts im Verhältnis zur oberen, linken Ecke des übergeordneten Containers bei der Platzierung in einem positionierten Layout an.
Zeichenfolge
Lesen/Schreiben
y
Gibt die Y-Koordinate eines Container-Verankerungspunkts im Verhältnis zur oberen, linken Ecke des übergeordneten Containers bei der Platzierung in einem positionierten Layout an.
Zeichenfolge
Lesen/Schreiben
Methoden

Name

Beschreibung

Rückgabe
execCalculate
Führt das Berechnungsskript des Feldes aus.
Leer
execEvent
Führt das Ereignisskript des Objekts aus.
Leer
execInitialize
Führt das Initialisierungsskript des Feldes aus.
Leer
execValidate
Führt das Überprüfungsskript des Feldes aus.
Leer


subformSet

Das subformSet-Objekt beschreibt eine Gruppe verwandter Teilformularobjekte.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
area
proto
subform
subformSet
subformSet
bookend
break
breakAfter
breakBefore
desc
extras
instanceManager
occur
overflow
subform
subformSet
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
relation
Gibt die Beziehung zwischen den Elementen einer Gruppe an.
Zeichenfolge
Lesen/Schreiben
relevant
Steuert, ob ein Formularobjekt beim Drucken des Formulars einbezogen wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


subjectDN

Das subnectDN-Objekt beschreibt die Attribute für den charakteristischen Namen, der im Unterschriftszertifikat vorhanden sein muss, damit das Zertifikat akzeptabel für das Unterschreiben ist. Es handelt sich hierbei um ein Array von Wörterbüchern, von denen jedes Schlüssel/Wert-Paare enthält, die den charakteristischen Namen angeben. Das Zertifikat muss alle im Wörterbuch angegebenen Attribute beinhalten. Es kann jedoch auch zusätzliche Attribute enthalten. Der Schlüssel kann eine beliebige rechtliche Attributkennung sein.
Weitere Informationen zu den verschiedenen Attributen für charakteristische Namen und den Attributtypen finden Sie im RFC-Dokument 3280.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
subjectDNs

subjectDN
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
delimiter
Trennt die Attribute in der Zeichenfolge für den charakteristischen Namen.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


subjectDNs

Das subjectDNs-Objekt beschreibt die Sammlung der Schlüssel/Wert-Paare, die zum Angeben des charakteristischen Namens verwendet werden.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
certificates

subjectDNs
subjectDN
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
type
Gibt das von einem Objekt verwendete Muster an.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


submit

Das submit-Objekt beschreibt, wie Daten an einen Host gesendet werden.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
event
proto

submit
signData
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
embedPDF
Bestimmt, ob eine PDF-Datei als Teil der Daten eingefügt wird.
Zeichenfolge
Lesen/Schreiben
format
Bestimmt das Format, in dem die Daten übergeben werden.
Zeichenfolge
Lesen/Schreiben
target
Gibt das Objekt an, auf welches das Ereignis wirkt.
Zeichenfolge
Lesen/Schreiben
textEncoding
Gibt die Kodierung des im Dokument enthaltenen Textes an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
xdpContent
Steuert, welche Untermenge von Daten übergeben wird. Diese Eigenschaft wird nur berücksichtigt, wenn für die format-Eigenschaft xdp verwendet wird.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


template

Das template-Objekt beschreibt eine Vorlage. Für jede Vorlage sowie für alle anderen Objekte, die dem template-Objekt untergeordnet sind, gibt es ein Objekt dieser Art.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto

template
extras
Übergeordnete Klasse
model-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
baseProfile
Zeichenfolge
Lesen/Schreiben
Methoden

Name

Beschreibung

Rückgabe
createNode
Erstellt eine neue Node auf Basis eines gültigen Klassennamens.
Objekt
execCalculate
Führt das Berechnungsskript des Feldes aus.
Leer
execInitialize
Führt das Initialisierungsskript des Feldes aus.
Leer
execValidate
Führt das Überprüfungsskript des Feldes aus.
Leer
formNodes
Gibt eine Liste mit allen Formularmodellobjekten zurück, die an ein bestimmtes Datenobjekt gebunden sind.
Objekt
recalculate
Erzwingt die Ausführung eines angegebenen Satzes von Skripten, die mit Berechnungsereignissen verknüpft sind. Bei den spezifischen Ereignissen kann es sich um anstehende Berechnungsereignisse oder um alle Berechnungsereignisse handeln.
Leer
remerge
Erzwingt das erneute Zusammenführen von Datenmodell und Vorlagenmodell zur Neuerstellung des Formularmodells. Nach dem erneuten Zusammenführen müssen evtl. vorgenommene Layoutmodell-Verarbeitungen für das fertig gestellte Formular wiederholt werden.
Leer


text

Das text-Objekt beschreibt eine Dateninhaltseinheit, die einen Nur-Text-Wert darstellt.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
desc
exObject
extras
items
message
proto
value
variables
text
Keine
Übergeordnete Klasse
content-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
{default}
Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Zeichenfolge
Lesen/Schreiben
maxChars
Gibt die maximale Anzahl Zeichen an, die dieser Textwert umfassen kann.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
value
Gibt den Wert des aktuellen Objekts an.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


textEdit

Das textEdit-Objekt schließt Steuerelemente zum Bearbeiten von Textinhalten ein.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
ui

textEdit
border
comb (textEdit.comb ist für die zukünftige Verwendung reserviert)
extras
margin
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
allowRichText
Gibt an, ob der Text Formatierung enthalten darf (auch als Rich-Text bekannt).
Zeichenfolge
Lesen/Schreiben
hScrollPolicy
Gibt an, ob in einem Feld der horizontale Bildlauf verfügbar ist.
Zeichenfolge
Lesen/Schreiben
multiLine
Gibt an, ob der Text mehrzeilig sein kann.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
vScollPolicy
Gibt an, ob in einem Feld der vertikale Bildlauf verfügbar ist.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


time

Das time-Objekt beschreibt eine Dateneinheit, die einen Zeitwert darstellt.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
desc
exObject
extras
items
proto
value
variables
time
Keine
Übergeordnete Klasse
content-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
{default}
Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
value
Gibt den Wert des aktuellen Objekts an.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


timeStamp

Das timeStamp-Objekt fügt einen Zeitstempel an eine Dokumentunterschrift an. Der Zeitstempel gibt das Datum und die Uhrzeit an, an dem bzw. zu der das Dokument unterschrieben wurde und lässt keinen Zweifel am Unterschriftszeitpunkt.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
filter

timestamp
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
server
Gibt die URL für einen Zeitstempel-Server an.
Zeichenfolge
Lesen/Schreiben
type
Gibt das von einem Objekt verwendete Muster an.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


toolTip

Das toolTip-Objekt stellt Text für eine QuickInfo in einem Formular bereit. Dieses Objekt wird von nicht interaktiven Formularanwendungen ignoriert.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
assist
proto

tooltip
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


traversal

Das traversal-Objekt verknüpft die eigenen Container mit anderen Objekten in Folge.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
draw
exclGroup
field
proto
subform
traversal
extras
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


traverse

Das traverse-Objekt deklariert eine Verknüpfung vom eigenen Container mit einem anderen Objekt in einer unidirektionalen Kette von Verknüpfungen.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
traversal

traverse
extras
script
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
operation
Bestimmt, wann eine Verknüpfung verwendet wurde.
Zeichenfolge
Lesen/Schreiben
ref
Gibt einen Ausdruck der Referenz-Syntax an, der die Node im Datenmodell definiert, an die der einschließende Container gebunden wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


ui

Das ui-Objekt umfasst die Beschreibung der Benutzeroberfläche eines Formularobjekts.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
draw
field
proto

ui
extras
imageEdit
picture
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


update

Das update-Objekt gibt den Vorgang zum Aktualisieren des aktuellen Datensatzes aus der Datenquelle an.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
command
source

update
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


uri

Das uri-Objekt speichert einen vollständig qualifizierten URI für ein bestimmtes xmlConnection- oder xsdConnection-Objekt.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
xmlConnection
xsdConnection

uri
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


user

Das user-Objekt gibt die Benutzer-ID für die Datenquelle an (sofern diese für eine Verbindung erforderlich ist).
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
connect

user
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


validate

Das validate-Objekt steuert die Überprüfung von Daten, die von Benutzern in einem Formular eingegeben werden.
Das validate-Objekt kann während der Lebensdauer eines Formulars mehrmals aktiviert werden.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
exclGroup
field
proto
subform
validate
extras
message
picture
script
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
formatTest
Steuert die Überprüfung auf Übereinstimmung mit der „display picture“-Klausel.
Zeichenfolge
Lesen/Schreiben
nullTest
Bestimmt, ob ein Feld in einem Formular obligatorisch ist, oder ob es leer gelassen werden kann.
Zeichenfolge
Lesen/Schreiben
scriptTest
Steuert die Überprüfung durch das Skript.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


value

Das value-Objekt schließt eine Dateninhaltseinheit ein.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
caption
draw
field
proto

value
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
override
Bestimmt, ob der berechnete Wert vom Benutzer in einem interaktiven Kontext überschrieben werden kann, oder ob der Wert in jedem Kontext deaktiviert ist.
Zeichenfolge
Lesen/Schreiben
relevant
Steuert, ob ein Formularobjekt beim Drucken des Formulars einbezogen wird.
Zeichenfolge
Lesen/Schreiben
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


variables

Das variables-Objekt wird zum Speichern von Dokumentvariablen verwendet.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
proto
subform

variables
Keine
Übergeordnete Klasse
node-Klasse
Eigenschaften
(

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


wsdlAddress

Das wsdlAddress-Objekt enthält die ursprüngliche URL der im wsdlConnection-Objekt referenzierten WSDL.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
wsdlConnection

wsdlAddress
Keine
Übergeordnete Klasse
textNode-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
use
Ruft einen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
usehref
Ruft einen externen Prototyp auf.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


wsdlConnection

Das wsdlConnection-Objekt gibt eine eindeutige WSDL-Webdienstverbindung an.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
connectionSet

wsdlConnection
operation
soapAction
soapAddress
wsdlAddress
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
dataDescription
Gibt den Namen der Beschreibung der Datenverbindung an, die mit einem bestimmten Typ von Webdienstverbindung verwendet wird.
Zeichenfolge
Lesen/Schreiben
Methoden

Name

Beschreibung

Rückgabe
execute
Führt eine Verbindung aus.
Boolescher Wert


xfa

Das xfa-Objekt ist die Stamm-Node des XFA-Modells.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
Keine

xfa
packet
Übergeordnete Klasse
model-Klasse
Eigenschaften
Keine
Methoden
Keine


xmlConnection

Das xmlConnection-Objekt wird zum Speichern einer XML-Musterdatenverbindung verwendet.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
connectionSet

xmlConnection
uri
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
dataDescription
Gibt den Namen der Beschreibung der Datenverbindung an, die mit einem bestimmten Typ von Webdienstverbindung verwendet wird.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


xsdConnection

Das xsdConnection-Objekt speichert einen Eintrag für eine XML-Schemadatenverbindung.
Hierarchie der Objekte

Übergeordnete Objekte

Aktuelles Objekt

Untergeordnete Objekte
connectionSet

xsdConnection
rootElement
uri
Übergeordnete Klasse
node-Klasse
Eigenschaften

Name

Beschreibung

Typ

Zugriff
dataDescription
Gibt den Namen der Beschreibung der Datenverbindung an, die mit einem bestimmten Typ von Webdienstverbindung verwendet wird.
Zeichenfolge
Lesen/Schreiben
Methoden
Keine


Skripteigenschaften

#text
{default}
access
accessKey
action
activity
addRevocationInfo
after
afterTarget
aliasNode
all
allowMacro
allowNeutral
allowRichText
anchorType
appType
archive
aspect
baselineShift
before
beforeTarget
bind
binding
blank (veraltet)
blankOrNotBlank
bofAction
bookendLeader
bookendTrailer
borderColor
borderWidth
bottomInset
break
calculationsEnabled
cap
change
charEncoding
checksum
circular
classAll
classId
classIndex
className
codeBase
codeType
colSpan
columnWidths
commandType
commitKey
commitOn
connection
contains
content
contentType
context
count
credentialServerPolicy
crlSign
cSpace
currentPage
currentRecordNumber
cursorLocation
cursorType
data
dataColumnCount
dataDescription
dataEncipherment
dataLength
dataPrep
dataRowCount
db
decipherOnly
delayedOpen
delimiter
digitalSignature
disable
embedPDF
encipherOnly
endChar
eofAction
errorCorrectionLevel
executeType
fillColor
fontColor
format
formatMessage
formattedValue
formatTest
fracDigits
from
fullText
h
hAlign
hand
highlight
href
hScrollPolicy
id
imagingBBox
index
initial
initialNumber
input
intact
inverted
isContainer
isDefined
isNull
join
keyAgreement
keyCertSign
keyDown
keyEncipherment
labelRef
language
layout
leadDigits
leader
leftInset
length
lineHeight
lineThrough
lineThroughPeriod
locale
lockType
long
mandatory
mandatoryMessage
marginLeft
marginRight
mark
match
max
maxChars
maxH
maxLength
maxW
min
minH
minW
model
modifier
moduleHeight
moduleWidth
multiLine
name
newContentType
newText
next
nodes
nonRepudiation
ns
nullTest
numbered
numberOfCells
numPages
oddOrEven
oneOfChild
open
operation
orientation
output
overflowLeader
overflowTarget
overflowTrailer
overline
overlinePeriod
override
pagePosition
parent
parentSubform
passwordChar
permissions
picture
placement
platform
posture
presence
preserve
prevContentType
previous
prevText
printCheckDigit
priority
radius
radixOffset
rate
rawValue
ready
recordsAfter
recordsBefore
reenter
ref
relation
relevant
reserve
restoreState
rightInset
role
rotate
rowColumnRatio
runAt
save
scope
scriptTest
selEnd
selStart
server
shape
shift
short
signatureType
size
slope
soapFaultCode
soapFaultString
somExpression
spaceAbove
spaceBelow
startAngle
startChar
startNew
stateless
stock
stroke
sweepAngle
tabDefault
tabStops
target
targetType
textEncoding
textEntry
textIndent
textLocation
thickness
this
timeout
timeStamp
title
topInset
trailer
transferEncoding
transient
truncate
type
typeface
underline
underlinePeriod
url
urlPolicy
usage
use
usehref
uuid
validationMessage
validationsEnabled
vAlign
value
valueRef
variation
version
vScollPolicy
w
weight
wideNarrowRatio
x
xdpContent
y
Dieser Abschnitt enthält eine alphabetische Liste aller Eigenschaften, die in dieser Skripterstellungsumgebung unterstützt werden.
Sofern nichts anderes angegeben ist, besitzen alle Eigenschaften Lese-/Schreibzugriff.


#text

Eine Textzeichenfolge.
Syntax
Reference_Syntax.#text.value = "text"
Werte

Typ

Werte
Zeichenfolge
      •
      Eine beliebige gültige Zeichenfolge.
Beispiele
JavaScript
TextField1.caption.value.#text = "This is a caption.";
FormCalc
TextField1.caption.value.#text = "This is a caption."


{default}

Stellt den eigentlichen Wert dar, der von einem Objekt gespeichert wird.
Typ und mögliche Werte können je nach Objekt unterschiedlich sein.
Syntax
Reference_Syntax = "value"
Werte

Typ

Werte
Variabel
Werte sind je nach Objekt unterschiedlich.
Gilt für

Modell

Objekt
Datenmodell
dataValue
Formularmodell
boolean
date
dateTime
decimal
draw
exclGroup
exData
field
float
image
integer
picture
text
time
sourceSet-Modell
boolean
integer
text
Gilt auch für Objekte, die von der textNode-Klasse abgeleitet sind.


access

Steuert den Benutzerzugriff auf den Inhalt eines Containers.
Syntax
Reference_Syntax.access = "open | protected | readOnly"
Werte

Typ

Werte
Zeichenfolge
      •
      open (Standardwert)
Ermöglicht es, den Inhalt eines Containers zu aktualisieren und den Container uneingeschränkt zu öffnen bzw. zu schließen. In interaktiven Formularen können Sie den Inhalt eines Containers ändern und mit der Tabulatortaste oder auf andere Weise navigieren. Der Container erstellt Ereignisse.
      •
      protected
Die verarbeitende Anwendung lässt keine direkten Änderungen am Inhalt des Containers durch den Benutzer zu. Indirekte Änderungen (z. B. Berechnungen) sind möglich. Der Container nimmt nicht an der Tab-Reihenfolge teil, allerdings kann eine Anwendung die Auswahl von Text zulassen, wenn dieser in die Zwischenablage kopiert wird. Geschützte Container generieren keine Ereignisse.
      •
      readOnly
Die Anwendung lässt keine direkten Änderungen am Container-Inhalt durch den Benutzer zu. Indirekte Änderungen (z. B. Berechnungen) sind jedoch möglich. Der Container nimmt an der Tab-Reihenfolge teil und erlaubt Benutzern das Anzeigen des Inhalts. Der Benutzer kann den Container-Inhalt auswählen, um ihn in die Zwischenablage zu kopieren. Der Container generiert eine Untergruppe von Ereignissen (diejenigen, die nicht mit direkten Inhaltsänderungen durch den Benutzer in Zusammenhang stehen).
Gilt für

Modell

Objekt
Formularmodell
exclGroup
field
Beispiele
JavaScript
TextField1.access = "readOnly";
FormCalc
TextField1.access = "readOnly"


accessKey

Gibt eine Zugriffstaste an, die von einer interaktiven Anwendung zum Verschieben des Eingabefokus auf ein bestimmtes Feldelement verwendet wird.
Syntax
Reference_Syntax.accessKey = "character"
Werte

Typ

Werte
Zeichenfolge
Der Wert dieses Attributs ist ein einzelnes Zeichen. Wenn der Benutzer gleichzeitig die plattformspezifische Zusatztaste und die Taste des einzelnen Zeichens drückt, wechselt der Fokus des Formulars zu diesem Feld. Bei Windows-Systemen ist die Zusatztaste die ALT-Taste und bei Mac OS-Systemen ist es die Wahltaste.
Wenn der Formularverfasser beispielsweise die accessKey-Eigenschaft eines Feldes auf f setzt und ein Windows-Benutzer die Tastenkombination ALT+F drückt, wechselt der Fokus zu diesem Feld.
Wenn Formularentwickler Formulare mit Zugriffstasten entwerfen, müssen sie die Benutzer auf die Verfügbarkeit der Tastenkombinationen hinweisen.
Gilt für

Modell

Objekt
Formularmodell
exclGroup
field
Beispiele
JavaScript
TextField1.accessKey = "f";
FormCalc
TextField1.accessKey = „f“


action

Gibt die von einer Dokumentunterschrift geschützten Formular-Nodes an.
Syntax
Reference_Syntax.action = "include | exclude | all"
Werte

Typ

Werte
Zeichenfolge
•
include (Standardwert)
Die Dokumentunterschrift schützt alle ausfüllbaren Formular-Nodes in der angegebenen Sammlung. Diese Option erfordert mindestens ein gültiges, untergeordnetes ref-Objekt, dessen Textwert ein Ausdruck der Referenz-Syntax ist, der die von der Dokumentunterschrift geschützten Nodes angibt.
      •
      exclude
Die Dokumentunterschrift schützt alle ausfüllbaren Formular-Nodes, die nicht in der angegebenen Sammlung enthalten sind. Diese Option erfordert mindestens ein gültiges, untergeordnetes ref-Objekt, dessen Textwert ein Ausdruck der Referenz-Syntax ist, der die von der Dokumentunterschrift geschützten Nodes angibt.
      •
      all
Die Dokumentunterschrift schützt alle ausfüllbaren Formular-Nodes.
Gilt für

Modell

Objekt
Formularmodell
manifest


activity

Gibt den Namen des Ereignisses an.
Die zugehörige ref-Eigenschaft muss ein Objekt angeben, welches das genannte Ereignis generieren kann.
Syntax
Reference_Syntax.activity = "change | click | docClose | docReady | enter | exit | full | initialize | mouseDown | mouseEnter | mouseExit | mouseUp | postExecute | postPrint | postSave | preExecute | prePrint | preSave | preSubmit | ready"
Werte

Typ

Wert
Zeichenfolge
      •
      change
Tritt auf, wenn der Benutzer den Feldwert ändert. Beispiele:
      •
      Mit jeder Tastenbetätigung
      •
      Beim Einfügen von Text
      •
      Beim Auswählen einer neuen Option
      •
      Beim Klicken auf ein Kontrollkästchen
      •
      click (Standardwert)
Tritt auf, wenn der Benutzer in das Feld klickt. Bei den meisten Systemen ist das click-Ereignis als Drücken und Loslassen der Maustaste definiert, wobei der Zeiger nicht über einen sehr geringen Schwellenwert hinaus bewegt werden darf.
      •
      docClose
Wird ganz am Ende der Verarbeitung eines Formulars ausgeführt, und zwar dann (und nur dann), wenn alle Formularüberprüfungen ohne Fehler durchgeführt wurden. Dieses Ereignis erfolgt zu spät, um eine Änderung an einem gespeicherten Dokument zu bewirken. Es soll vielmehr die Möglichkeit bieten, einen Ende-Status oder eine Abschlussmeldung zu erzeugen.
      •
      docReady
Wird vor der Wiedergabe des Dokuments, aber nach der Datenbindung der Daten ausgeführt.
      •
      enter
Tritt beim Feld auf, wenn der Tastaturfokus auf das Feld wechselt. Tritt bei einem Teilformular oder einer Ausschlussgruppe auf, wenn der Tastaturfokus auf ein Feld im Teilformular oder in der Ausschlussgruppe wechselt, d. h., der Tastaturfokus wechselt von außerhalb des Objekts in das Objekt.
      •
      enter
Tritt beim Feld auf, wenn der Tastaturfokus auf das Feld wechselt. Tritt bei einem Teilformular oder einer Ausschlussgruppe auf, wenn der Tastaturfokus auf ein Feld im Teilformular oder in der Ausschlussgruppe wechselt, d. h., der Tastaturfokus wechselt von außerhalb des Objekts in das Objekt.
      •
      exit
Tritt beim Feld auf, wenn das Feld den Tastaturfokus verliert. Tritt bei einem Teilformular oder einer Ausschlussgruppe auf, wenn alle Felder im Teilformular oder in der Ausschlussgruppe den Tastaturfokus verlieren, d. h., der Tastaturfokus wechselt von innerhalb des Objekts nach außerhalb des Objekts.
      •
      full
Wird ausgelöst, wenn beim Ausfüllen von Formularen mehr als die maximal zulässige Menge an Inhalt in ein Feld eingegeben wird.
      •
      initialize
Wird nach dem Abschluss der Datenbindung ausgeführt. Für jede Instanz des Teilformulars im Formularmodell wird ein gesondertes Ereignis erzeugt.
      •
      mouseDown
Tritt auf, wenn der Benutzer die Maustaste im Feld drückt, jedoch bevor er die Taste loslässt.
      •
      mouseEnter
Tritt auf, wenn der Benutzer den Zeiger über das Feld zieht, jedoch nicht notwendigerweise die Taste drückt.
      •
      mouseExit
Tritt auf, wenn der Benutzer den Zeiger aus dem Feld zieht, jedoch nicht notwendigerweise die Taste drückt.
      •
      mouseUp
Tritt auf, wenn der Benutzer die Maustaste im Feld loslässt.
      •
      postExecute
Tritt auf, wenn Daten über WSDL an einen Webdienst gesendet werden, direkt nach dem Empfang der Antwort auf die Anfrage. Die empfangenen Daten werden in ein connectionData-Objekt unterhalb von $datasets eingefügt. Ein durch dieses Ereignis ausgelöstes Skript kann die empfangenen Daten überprüfen und verarbeiten. Nach der Ausführung dieses Ereignisses werden die empfangenen Daten gelöscht.
      •
      postPrint
Tritt direkt nach dem Senden des wiedergegebenen Formulars an den Drucker, den Spooler oder das Ausgabeziel auf.
      •
      postSave
Tritt direkt nach der Ausgabe des Formulars im PDF- oder XDP-Format auf. Tritt nicht auf, wenn das Datenmodell oder eine andere Untergruppe des Formulars in XDP exportiert wird.
      •
      preExecute
Tritt auf, wenn eine Abfrage über WSDL an einen Webdienst gesendet wird. Ein durch dieses Ereignis ausgelöstes Skript kann die Daten vor dem Senden der Abfrage überprüfen und ändern. Wenn das Skript für die Ausführung nur auf dem Server gekennzeichnet ist, werden die Daten mit dem Hinweis an den Server gesendet, dass der Server vor dem Verarbeiten der restlichen Daten das zugehörige Skript ausführen soll.
      •
      preSave
Tritt direkt vor der Ausgabe des Formulars im PDF- oder XDP-Format auf. Tritt nicht auf, wenn das Datenmodell oder eine andere Untergruppe des Formulars in XDP exportiert wird. XSLT-Nachverarbeitung tritt nach diesem Ereignis auf (sofern aktiviert).
      •
      preSubmit
Tritt auf, wenn Daten über das HTTP-Protokoll an den Host gesendet werden. Ein durch dieses Ereignis ausgelöstes Skript kann die Daten vor dem Senden überprüfen und ändern. Wenn das Skript für die Ausführung auf dem Server gekennzeichnet ist, werden die Daten mit dem Hinweis an den Server gesendet, dass der Server vor dem Verarbeiten der restlichen Daten das zugehörige Skript ausführen soll.
      •
      ready
Tritt auf, wenn das Modell vollständig geladen ist.
Gilt für

Modell

Objekt
Formularmodell
event
Beispiele
JavaScript
TextField1.event.activity = "mouseEnter";
FormCalc
TextField1.event.activity = „mouseEnter“


addRevocationInfo

Gibt an, ob der Zertifikatstatus beim Unterschreiben einer digitalen Unterschrift geprüft wird. Der Zertifikatstatus kann anhand einer Zertifikatssperrliste oder einer OCSP-Antwort (Online Certificate Status Protocol, OCSP) geprüft werden.
Der Unterzeichner muss Zugriff auf das Internet haben, um die Zertifikatsperrliste oder die OCSP-Antwort vom entsprechenden Server abrufen zu können.
Die addRevocationInfoEigenschaft besitzt keinen Standardwert. Acrobat kann die Eigenschaft daher übergehen, wenn kein Wert angegeben ist.
Syntax
Reference_Syntax.addRevocationInfo = "required | optional | none"
Werte

Typ

Werte
Zeichenfolge
•
Required
Die Prüfung des Zertifikatstatus ist erforderlich.
•
Optional
Die Prüfung des Zertifikatstatus ist optional.
•
None
Es ist keine Zertifikatsperrliste oder OCSP-Antwort in der digitalen Unterschrift enthalten.
Gilt für

Modell

Objekt
Formularmodell
filter


after

Gibt die Einschränkungen zum Wechseln auf eine neue Seite oder einen neuen Inhaltsbereich nach der Wiedergabe des Teilformulars an.
Syntax
Reference_Syntax.after = "auto | contentArea | pageArea | pageEven | pageFront | pageOdd"
Werte

Typ

Werte
Zeichenfolge
Das im Folgenden beschriebene Verhalten kann durch Angeben einer Zielseite oder eines Inhaltsbereichs mit Hilfe der afterTarget-Eigenschaft weiter optimiert werden.
      •
      auto (Standardwert)
Die Entscheidung über einen Übergang zu einer neuen Seite oder einem Inhaltsbereich wird auf die Verarbeitungsanwendung übertragen. Es wird kein Übergang zu einer neuen Seite oder einem Inhaltsbereich erzwungen.
      •
      contentArea
Bei der Wiedergabe erfolgt der Übergang zum nächsten verfügbaren Inhaltsbereich.
      •
      pageArea
Bei der Wiedergabe erfolgt der Übergang zu einer neuen Seite.
      •
      pageBack
Ist die Duplexfunktion aktiv, erfolgt bei der Wiedergabe der Übergang zur nächsten verfügbaren Rückseite, so dass u. U. eine dazwischen liegende Seitenfläche gedruckt wird. Ist der Duplexfunktion nicht aktiv, erfolgt der Übergang der Wiedergabe zu einer neuen Seite.
      •
      pageEven
Bei der Wiedergabe erfolgt der Übergang zur nächsten verfügbaren geraden Seite, wodurch dazwischen liegende nummerierte und/oder nicht nummerierte Seiten u. U. gedruckt werden. Dieses Verhalten macht keine Aktivierung der Duplexfunktion erforderlich.
      •
      pageFront
Bei aktivierter Duplexfunktion erfolgt bei der Wiedergabe der Übergang zur nächsten verfügbaren Vorderseite, so dass u. U. eine dazwischen liegende Seitenfläche gedruckt wird. Ist der Duplexfunktion nicht aktiv, erfolgt der Übergang der Wiedergabe zu einer neuen Seite.
      •
      pageOdd
Bei der Wiedergabe erfolgt der Übergang zur nächsten verfügbaren ungeraden Seite, wodurch dazwischen liegende nummerierte und/oder nicht nummerierte Seiten u. U. gedruckt werden. Dieses Verhalten macht keine Aktivierung der Duplexfunktion erforderlich.
Gilt für

Modell

Objekt
Formularmodell
break
Beispiele
JavaScript
Subform1.break.after = "pageOdd";
FormCalc
Subform1.break.after = „pageOdd“


afterTarget

Gibt die explizite Zielseite oder den Inhaltsbereich für die after-Eigenschaft an.
Syntax
Reference_Syntax.afterTarget = "auto | contentArea | pageArea | pageEven | pageFront | pageOdd"
Werte

Typ

Werte
Zeichenfolge
Der Wert dieser Eigenschaft muss mit dem Wert der after-Eigenschaft kompatibel sein. Es wird beispielsweise ein Fehler ausgegeben, wenn die after-Eigenschaft auf einen Seitenbereich und die afterTarget-Eigenschaft auf einen Inhaltsbereich verweist oder umgekehrt.
Gilt für

Modell

Objekt
Formularmodell
break
Beispiele
JavaScript
Subform1.break.afterTarget = "pageEven";
FormCalc
Subform1.break.afterTarget = „pageEven“


aliasNode

Gibt das Objekt an, das durch den Alias für dieses Modell dargestellt wird.
Syntax
Reference_Syntax.aliasNode = "object"
Werte

Typ

Werte
Objekt
Das Objekt im Modell, auf das die Referenz-Syntax für dieses Modell verweist. Beim Formularmodell ist die Alias-Node das form-Objekt.
Weitere Informationen zu Ausdrücken der Referenz-Syntax finden Sie unter Grundlagen zum Referenzieren von Objekten in Berechnungen und Skripten.
Gilt für
model-Klasse
Beispiele
JavaScript
xfa.aliasNode = "form";
FormCalc
xfa.aliasNode = „form“


all

Gibt eine Sammlung von Nodes mit ähnlichen Namen im Bereich zurück.
Wenn die Node keinen Namen hat, wird eine Sammlung von benannten Nodes der gleichen Klasse zurückgegeben.
Syntax
Reference_Syntax.all = "object(s)"
Werte

Typ

Werte
Objekt
Ein Objekt oder eine Sammlung von Objekten.
Gilt für
tree-Klasse
Beispiele
JavaScript
Subform1.all;
FormCalc
Subform1.all


allowMacro

Gibt an, ob die verarbeitende Anwendung die Ausgabe durch Generieren eines Druckermakros für den gesamten draw-Inhalt des Teilformulars optimieren darf.
Syntax
Reference_Syntax.allowMacro = "1 | 0"
Werte

Typ

Werte
Zeichenfolge
      •
      1 (Standardwert)
Die verarbeitende Anwendung darf für dieses Teilformular ein Druckermakro verwenden.
      •
      0
Die verarbeitende Anwendung darf für dieses Teilformular kein Druckermakro verwenden.
Gilt für

Modell

Objekt
Formularmodell
subform
Beispiele
JavaScript
Subform1.allowMacro = "0";
FormCalc
Subform1.allowMacro = "0"


allowNeutral

Gibt an, ob das Kontrollkästchen oder das Optionsfeld einen weiteren dritten Zustand unterstützen kann, der einen neutralen Wert darstellt.
Syntax
Reference_Syntax.allowNeutral = "0 | 1"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
Das Kontrollkästchen oder Optionsfeld unterstützt zwei Zustände, „wahr“ und „falsch“.
      •
      1
Das Kontrollkästchen oder Optionsfeld unterstützt drei Zustände. Dies sind die Zustände wahr, falsch oder neutral.
Gilt für

Modell

Objekt
Formularmodell
checkButton
Beispiele
JavaScript
CheckBox1.resolveNode(„ui.#checkButton“).allowNeutral = „1“;
FormCalc
CheckBox1.ui.#checkButton.allowNeutral = "1"


allowRichText

Gibt an, ob der Text Formatierung enthalten darf (auch als Rich-Text bekannt).
Die allowRichText-Eigenschaft leitet lediglich Stilinformationen an die Anwendungsschnittstelle weiter. Die Einstellung dieser Eigenschaft bedeutet für den Benutzer keinerlei Einschränkung bezüglich der Eingabe von Nur-Text-Markup, das Stilinformationen umfasst. Ein Benutzer könnte beispielsweise ohne Berücksichtigung der Einstellung für diese Eigenschaft Folgendes eingeben:
        <b>hello</b>
Syntax
Reference_Syntax.allowRichText = "0 | 1"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
Textstile sind nicht zulässig. Dies ist der Standardwert, wenn das textEdit-Objekt kein exData-Objekt enthält.
      •
      1
Textstile sind zulässig. Dies ist der Standardwert, wenn das textEdit-Objekt kein exData-Objekt enthält.
Gilt für

Modell

Objekt
Formularmodell
textEdit
Beispiele
JavaScript
TextField1.resolveNode(„ui.#textEdit“).allowRichText = „1“;
FormCalc
TextField1.ui.#textEdit.allowRichText = "1"


anchorType

Gibt die Position des Verankerungspunkts des Containers an, wenn er anhand eines positionierten Layouts platziert wird.
Syntax
Reference_Syntax.anchorType = "topLeft | topCenter | topRight | middleLeft | middleCenter | middleRight | bottomLeft | bottomCenter | bottomRight"
Werte

Typ

Werte
Zeichenfolge
      •
      topLeft (Standardwert)
Linke obere Ecke des Containers.
      •
      topCenter
Mitte des oberen Container-Randes.
      •
      topRight
Rechte obere Ecke des Containers.
      •
      middleLeft
Mitte des linken Container-Randes.
      •
      middleCenter
Container-Mitte.
      •
      middleRight
Mitte des rechten Container-Randes.
      •
      bottomLeft
Linke untere Ecke des Containers.
      •
      bottomCenter
Mitte des unteren Container-Randes.
      •
      bottomRight
Rechte untere Ecke des Containers.
Gilt für

Modell

Objekt
Formularmodell
draw
exclGroup
field
subform
Beispiele
JavaScript
TextField1.anchorType = „bottomRight“;
FormCalc
TextField1.anchorType = "bottomRight"


appType

Gibt den Namen der Client-Anwendung an, in der sich ein Formular gerade befindet.
The Die appType-Eigenschaft ruft die viewerType-Eigenschaft vom Acrobat JavaScript-Objektmodell ab und gibt den entsprechenden Wert für die Client-Anwendung zurück, in der sich das Formular befindet. Beispiel: Im Kontext eines PDF-Formulars, das in Adobe Reader angezeigt wird, gibt diese Eigenschaft Reader zurück.
Weitere Informationen zur viewerType-Eigenschaft und zu den zurückgegebenen Werten finden Sie in der Acrobat JavaScript Scripting Reference, die Sie auf der Acrobat Family Developer Center-Website finden: www.adobe.com/devnet/livecycle.
Syntax
Reference_Syntax.appType
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die den Namen der aktuellen Client-Host-Anwendung angibt.
Gilt für

Modell

Objekt
Formularmodell
draw
exclGroup
field
subform
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.appType;
FormCalc
xfa.host.appType


archive

Gibt den URI-Speicherort für eine Archivdatei an, die möglicherweise Programmcode für das exObject-Objekt enthält.
Syntax
Reference_Syntax.archive = "URI"
Werte

Typ

Werte
Zeichenfolge
Ein vollständig qualifizierter URI-Wert.
Gilt für

Modell

Objekt
Formularmodell
exObject


aspect

Gibt an, wie das Bild auf dem nominalen Inhaltsbereich des Bild-Containers abzubilden ist.
Syntax
Reference_Syntax.aspect = "fit | none | actual | width | height"
Werte

Typ

Werte
Zeichenfolge
      •
      fit (Standardwert)
Die Anwendung skaliert das Bild proportional zur maximalen Größe des Container-Inhaltsbereichs.
      •
      none
Die Anwendung skaliert das Bild so, dass es der Größe des gesamten Container-Inhaltsbereichs entspricht. Dies kann dazu führen, dass verschiedene Skalierungswerte auf die X- und Y-Koordinaten des Bilds angewendet werden.
      •
      actual
Das Bild wird mit den im Bildinhalt gespeicherten Abmessungen wiedergegeben. Die Größe des Containerbereichs beeinflusst die Änderung der Bildgröße nicht.
      •
      width
Die Anwendung skaliert das Bild proportional zur maximalen Breite des Containerinhaltsbereichs. Das Bild kann länger oder kürzer sein als der Inhaltsbereich.
      •
      height
Die Anwendung skaliert das Bild proportional zur maximalen Höhe des Containerinhaltsbereichs. Das Bild kann breiter oder schmaler sein als der Inhaltsbereich.
Gilt für

Modell

Objekt
Formularmodell
image
Beispiele
JavaScript
ImageField1.resolveNode("value.#image").aspect = "actual";
FormCalc
ImageField1.value.#image.aspect = "actual"


baselineShift

Gibt entweder eine positive Maßeinheit an, um die eine Schrift von der Grundlinie aus nach oben versetzt wird, oder eine negative Maßeinheit, um die eine Schrift von der Grundlinie aus nach unten versetzt wird.
Syntax
Reference_Syntax.baselineShift = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
font
Beispiele
JavaScript
TextField1.font.baselineShift = "-5pt";
FormCalc
TextField1.font.baselineShift = "-5pt"


before

Gibt die Einschränkungen zum Wechseln auf eine neue Seite oder in einen neuen Inhaltsbereich vor der Wiedergabe des Teilformulars an.
Syntax
Reference_Syntax.before = "auto | contentArea | pageArea | pageBack | pageEven | pageFront | pageOdd"
Werte

Typ

Werte
Zeichenfolge
Das im Folgenden beschriebene Verhalten kann durch Angeben einer Zielseite oder eines Inhaltsbereichs mit Hilfe der beforeTarget-Eigenschaft weiter optimiert werden. Die startNew-Eigenschaft ändert auch einige der folgenden Verhaltensweisen:
      •
      auto (Standardwert)
Die Entscheidung über einen Übergang zu einer neuen Seite oder einem neuen Inhaltsbereich wird auf die verarbeitende Anwendung übertragen. Es wird kein Übergang zu einer neuen Seite oder einem neuen Inhaltsbereich erzwungen.
      •
      contentArea
Bei der Wiedergabe erfolgt der Übergang zum nächsten verfügbaren Inhaltsbereich. Siehe auch startNew-Eigenschaft.
      •
      pageArea
Bei der Wiedergabe erfolgt der Übergang zu einer neuen Seite. Siehe auch startNew-Eigenschaft.
      •
      pageBack
Bei aktivierter Duplexfunktion erfolgt bei der Wiedergabe der Übergang zur nächsten verfügbaren Rückseite, so dass u. U. eine dazwischen liegende Seitenfläche gedruckt wird. Ist die Duplexfunktion nicht aktiv, erfolgt der Übergang zur Wiedergabe einer neuen Seite. pageBack ist im Gegensatz zu pageEven von der Seitennummerierung nicht betroffen.
      •
      pageEven
Bei der Wiedergabe erfolgt der Übergang zur nächsten verfügbaren geraden Seite, wodurch dazwischen liegende nummerierte oder nicht nummerierte Seiten u. U. gedruckt werden. Dieses Verhalten macht keine Aktivierung der Duplexfunktion erforderlich.
      •
      pageFront
Bei aktivierter Duplexfunktion erfolgt bei der Wiedergabe der Übergang zur nächsten verfügbaren Vorderseite, so dass u. U. eine dazwischen liegende Seitenfläche gedruckt wird. Ist der Duplexfunktion nicht aktiv, erfolgt der Übergang der Wiedergabe zu einer neuen Seite. pageFront ist im Gegensatz zu pageOdd von der Seitennummerierung nicht betroffen.
      •
      pageOdd
Bei der Wiedergabe erfolgt der Übergang zur nächsten verfügbaren ungeraden Seite, wodurch dazwischen liegende nummerierte oder nicht nummerierte Seiten u. U. gedruckt werden. Dieses Verhalten macht keine Aktivierung der Duplexfunktion erforderlich.
Gilt für

Modell

Objekt
Formularmodell
break
Beispiele
JavaScript
Subform1.break.before = "contentArea";
FormCalc
Subform1.break.before = "contentArea"


beforeTarget

Gibt die explizite Zielseite oder den Inhaltsbereich für die before-Eigenschaft an.
Syntax
Reference_Syntax.beforeTarget = "auto | contentArea | pageArea | pageEven | pageFront | pageOdd"
Werte

Typ

Werte
Zeichenfolge
Der Wert der beforeTarget-Eigenschaft muss mit dem Wert der before-Eigenschaft kompatibel sein. Es wird beispielsweise ein Fehler ausgegeben, wenn die before-Eigenschaft den Wert pageArea aufweist und die beforeTarget-Eigenschaft auf einen Inhaltsbereich verweist oder umgekehrt.
Gilt für

Modell

Objekt
Formularmodell
break
Beispiele
JavaScript
Subform1.break.beforeTarget = "#contentArea_ID";
FormCalc
Subform1.break.beforeTarget = "#contentArea_ID"


bind

Gibt den Namen einer eindeutigen Bindungs-ID an, wobei Spalten aus der durch die from-Eigenschaft angegebene Datenquelle gebunden sind.
Syntax
Reference_Syntax.bind = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die eine Bindungs-ID darstellt.
Gilt für

Modell

Objekt
sourceSet-Modell
map


binding

Gibt den Typ der Anwendung an, an die das Skript weitergeleitet wird.
Syntax
Reference_Syntax.binding = "XFA | Application_type"
Werte

Typ

Werte
Zeichenfolge
      •
      XFA (Standardwert)
Das Skript muss durch die Standardanwendung angewendet werden.
      •
      Alle sonstigen gültigen Anwendungstypen.
Alle Werte außer XFA geben an, dass das Skript von Standardanwendungen ignoriert werden kann.
Gilt für

Modell

Objekt
Formularmodell
script
Beispiele
JavaScript
TextField1.resolveNode("#event.#script").binding = "XFA";
FormCalc
TextField1.#event.#script.binding = "XFA"


blank (veraltet)

Gibt an, ob der Seitenbereich leer sein soll, was eine besonderen Behandlung durch das Ausgabegerät zur Folge hat.
Syntax
Reference_Syntax.blank = "0 | 1"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
Der Seitenbereich sollte nicht leer sein. Etwaiger Inhalt wird wiedergegeben.
      •
      1
Der Seitenbereich soll leer sein und wird vom Ausgabegerät auf besondere Weise behandelt.
Ein Drucker kann dem Benutzer beispielsweise den Ausdruck nach Seiten berechnen. Der Benutzer möchte bei einem Duplexauftrag nicht für leere Rückseiten bezahlen. Mit Hilfe dieser Eigenschaft können die leeren Rückseiten des Dokuments als leer gekennzeichnet werden, so dass die verarbeitende Anwendung keine Inhalte auf der Rückseite wiedergeben muss und der Drucker möglicherweise spezielle Anweisungen erhält, um sicherzustellen, dass dem Benutzer die leere Rückseite nicht berechnet wird.
Gilt für

Modell

Objekt
Formularmodell
pageArea
Beispiele
Der Ausdruck der Referenz-Syntax ist variabel, je nachdem, von welchem Objekt er aufgerufen wird.
JavaScript
xfa.form.form1.pageSet.Page1.blank;
FormCalc
xfa.form.form1.pageSet.Page1.blank


blankOrNotBlank

Gibt an, ob der Seitenbereich leer sein soll, was eine besonderen Behandlung durch das Ausgabegerät zur Folge hat.
Syntax
Reference_Syntax.blankOrNotBlank = "any | blank | notBlank"
Werte

Typ

Werte
Zeichenfolge
      •
      any (Standardwert)
Sucht nach leeren oder nicht leeren Seiten.
      •
      blank
Sucht nach Seiten, die von einem Umbruch auf gerade Seite auf einer geraden Seite oder von einem Umbruch auf ungerade Seite auf einer ungeraden Seite eingefügt wurden.
      •
      notBlank
Sucht nach allen Seiten, die eingefügt wurden, um Inhalt aufzunehmen oder den Mindestwert für das Vorkommen zu erfüllen.
Gilt für

Modell

Objekt
Formularmodell
pageArea
Beispiele
Der Ausdruck der Referenz-Syntax ist variabel, je nachdem, von welchem Objekt er aufgerufen wird.
JavaScript
xfa.form.form1.pageSet.Page1.blankOrNotBlank = "notBlank";
FormCalc
xfa.form.form1.pageSet.Page1.blankOrNotBlank = "notBlank"


bofAction

Gibt die Aktion an, die ausgeführt wird, wenn der aktuelle Datensatz der erste Datensatz in der Datensatzgruppe ist.
Syntax
Reference_Syntax.bofAction = "moveLast | stayEOF"
Werte

Typ

Werte
Zeichenfolge
      •
      moveLast (Standardwert)
Verschiebt die aktuelle Datensatzposition an eine Stelle nach dem letzten Datensatz.
      •
      stayEOF
Der aktuelle Datensatz ist immer der letzte Datensatz in der Datensatzgruppe.
Gilt für

Modell

Objekt
sourceSet-Modell
recordSet


bookendLeader

Gibt ein Teilformular an, das in den aktuellen Inhaltsbereich oder in die aktuelle Seite vor anderen Inhalten eingefügt wird.
Wenn sowohl die Eigenschaft bookendLeader als auch die Eigenschaft bookendTrailer angegeben ist, umschließen die beiden Teilformulare den Inhalt wie Buchstützen.
Syntax
Reference_Syntax.bookendLeader = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die den Namen oder vollständig qualifizierten Ausdruck der Referenz-Syntax eines Teilformulars darstellt.
Gilt für

Modell

Objekt
Formularmodell
break
Beispiele
JavaScript
Subform1.break.bookendLeader = "xfa.form.form1.Subform2";
FormCalc
Subform1.break.bookendLeader = "xfa.form.form1.Subform2"


bookendTrailer

Gibt ein Teilformular an, das in den aktuellen Inhaltsbereich oder in die aktuelle Seite nach anderen Inhalten eingefügt wird.
Wenn sowohl die Eigenschaft bookendLeader als auch die Eigenschaft bookendTrailer angegeben ist, umschließen die beiden Teilformulare den Inhalt wie Buchstützen.
Syntax
Reference_Syntax.bookendTrailer = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die den Namen oder vollständig qualifizierten Ausdruck der Referenz-Syntax eines Teilformulars darstellt.
Gilt für

Modell

Objekt
Formularmodell
break
Beispiele
JavaScript
Subform1.break.bookendTrailer = „xfa.form.form1.Subform2“;
FormCalc
Subform1.break.bookendTrailer = "xfa.form.form1.Subform2"


borderColor

Gibt den Farbwert für die Begrenzung dieses Feldes an.
Bevor die Farbe mit Hilfe eines Skripts geändert werden kann, muss eine Begrenzung definiert werden.
Syntax
Reference_Syntax.borderColor = " [0-255], [0-255], [0-255]"
Werte

Typ

Werte
Zeichenfolge
Für den Farbraum SRGB sind die Komponentenwerte r,g,b erforderlich. Dabei steht r für den roten Komponentenwert, g für den grünen Komponentenwert und b für den blauen Komponentenwert. Jeder Komponentenwert muss innerhalb des Wertebereichs von 0 bis 255 (einschließlich) liegen. Der Wert 255 stellt die maximale Anzeigeintensität dar. Mit 255,0,0 wird beispielsweise die Farbe Rot angegeben.
Die Standardeinstellung hängt davon ab, in welchem Kontext die Farbe verwendet wird. Die Standardfarbe wird von dem Objekt bestimmt, das das Farbobjekt umschließt.
Gilt für

Modell

Objekt
Formularmodell
exclGroup
field
Beispiele
JavaScript
TextField1.borderColor = "125,154,125";
FormCalc
TextField1.borderColor = "125,154,125"


borderWidth

Gibt die Breite der Begrenzung für dieses Feld an.
Syntax
Reference_Syntax.borderWidth = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
exclGroup
field
Beispiele
JavaScript
TextField1.borderWidth = "0.05in";
FormCalc
TextField1.borderWidth = "0.05in"


bottomInset

Eine Maßeinheit, die angibt, wie groß die untere Vertiefung sein soll.
Syntax
Reference_Syntax.bottomInset = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
margin
Beispiele
JavaScript
Subform1.margin.bottomInset = "1in";
FormCalc
Subform1.margin.bottomInset ="1in"


break

Beschreibt die Einschränkungen beim Wechseln auf eine neue Seite oder einen neuen Inhaltsbereich nach der Wiedergabe eines Objekts.
Syntax
Reference_Syntax.break = "close | open"
Werte

Typ

Werte
Zeichenfolge
      •
      close (Standardwert)
      •
      open
Gilt für

Modell

Objekt
Formularmodell
border
Beispiele
JavaScript
Subform1.border.break = "open";
FormCalc
Subform1.border.break = "open"


calculationsEnabled

Gibt an, ob Berechnungsskripten ausgeführt werden.
Syntax
Reference_Syntax.calculationsEnabled= "0 | 1"
Werte

Typ

Werte
Boolescher Wert
      •
      1 (Standardwert)
Die Berechnungsskripten werden ausgeführt.
      •
      0
Die Berechnungsskripten werden nicht ausgeführt.
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.calculationsEnabled = "1";
FormCalc
xfa.host.calculationsEnabled = "1"


cap

Gibt den wiedergegebenen Abschluss der Linie an.
Linien, die einen eingeschlossenen Bereich bilden, haben keinen wiedergegebenen Abschluss. Insbesondere alle Rechtecke und Rahmenkanten sowie alle 360-Grad-Bogenkanten weisen keinen Abschluss auf. Bögen mit Bogenwinkeln unter 360° sowie Linien haben an beiden Endpunkten einen Abschluss.
Syntax
Reference_Syntax.cap = "square | butt | round"
Werte

Typ

Werte
Zeichenfolge
      •
      square (Standardwert)
Die Linie wird abgeschlossen, indem das Ende der Kante vollständig über den Endpunkt der Kante hinaus mit dem Abstand der halben Kantenstärke wiedergegeben wird.
      •
      butt
Die Linie wird abgeschlossen, indem das Ende der Kante vollständig über den Endpunkt wiedergegeben wird.
      •
      round
Die Linie wird abgeschlossen, indem das Ende der Kante mit einem Halbkreis am Endpunkt der Kante wiedergegeben wird, wobei der Radius des Halbkreises der halben Stärke der Kante entspricht.
Gilt für

Modell

Objekt
Formularmodell
edge
Beispiele
JavaScript
Line1.resolveNode("value.#line.edge").cap = "round";
FormCalc
Line1.value.#line.edge.cap = "round"


change

Gibt den Wert an, den ein Benutzer unmittelbar nach dem Ausführen der Aktion in einem Feld eingibt oder einfügt.
Syntax
Reference_Syntax.change
Werte

Typ

Werte
Zeichenfolge
Eine beliebige gültige Zeichenfolge für ein bestimmtes Formularfeld.
Gilt für

Modell

Objekt
Ereignismodell
eventPseudoModel
Beispiele
JavaScript
xfa.event.change;
FormCalc
xfa.event.change


charEncoding

Gibt die Zeichencodierung des in einem Barcode kodierten Wertes an.
Der Wert des Barcodefelds wird nach dem angegebenen Zeichencode in eine Bytefolge serialisiert. Anschließend wird er komprimiert, wenn die dataPrep-Eigenschaft es erfordert, und verschlüsselt, sofern das encrypt -Objekt vorhanden ist. Abschließend wird er gemäß der Symbole kodiert.
Beim Wert dieser Eigenschaft wird die Groß-/Kleinschreibung nicht unterschieden. Er muss einem der folgenden Werte entsprechen.
Syntax
Reference_Syntax.charEncoding = "UTF-8 | none | ISO-8859-1 | ISO-8859-2 | SO-8859-7 | SHift-JIS | KSC-5601 | Big-Five | GB-2312 | UTF-16 | UCS-2 | fontSpecific"
Werte

Typ

Werte
Zeichenfolge
      •
      UTF-8 (Standardwert)
Die Zeichenkodierung erfolgt in Übereinstimmung mit den von Unicode definierten Unicode-Codepunkten und der UTF-8-Serialisierung gemäß ISO/IEC 10646.
      •
      none
Es ist keine spezielle Kodierung angegeben. Die Zeichen werden mit Hilfe der betriebssystemspezifischen Kodierung verschlüsselt.
      •
      ISO-8859-1
Die Zeichenkodierung erfolgt mittels ISO-8859-1, auch als Latin-1 bekannt.
      •
      ISO-8859-2
Die Zeichenkodierung erfolgt mittels ISO-8859-2.
      •
      SO-8859-7
Die Zeichenkodierung erfolgt mittels ISO-8859-7.
      •
      Shift-JIS
Die Zeichenkodierung erfolgt mittels JIS X 0208 (als Shift-JIS bekannt).
      •
      KSC-5601
Die Zeichenkodierung erfolgt mittels des Code for Information Interchange (Hangul und Hanja).
      •
      Big-Five
Die Zeichenkodierung erfolgt mittels Traditionellem Chinesisch (Big-Five). Für Big-Five gibt es keinen offiziellen Standard, entsprechend gibt es mehrere Varianten. Das Adobe-Formularobjektmodell verwendet die Variante, die von Microsoft als Code implementiert wird.
      •
      GB-2312
Die Zeichenkodierung erfolgt mittels Vereinfachtem Chinesisch.
      •
      UTF-16
Die Zeichenkodierung erfolgt in Übereinstimmung mit den von Unicode definierten Unicode-Codepunkten und der UTF-16-Serialisierung gemäß ISO/IEC 10646.
      •
      UCS-2
Die Zeichenkodierung erfolgt in Übereinstimmung mit den von Unicode definierten Unicode-Codepunkten und der UCS-2-Serialisierung gemäß ISO/IEC 10646.
      •
      fontSpecific
Die Zeichenkodierung erfolgt schriftspezifisch. Jedes Zeichen wird durch ein 8-Bit Byte dargestellt.
Gilt für

Modell

Objekt
Formularmodell
barcode
Beispiele
JavaScript
Code11BarCode1.resolveNode(„ui.#barcode“).charEncoding = „UCS-2“;
FormCalc
Code11BarCode1.ui.#barcode.charEncoding = "UCS-2"


checksum

Gibt einen Algorithmus für die in den Barcode einzufügende Prüfsumme an.
Die Berechnung der Prüfsummen basiert auf den Barcodedaten.
Das Vorlagenmodell ermöglicht die Auswahl einer der unten aufgeführten Möglichkeiten. Manche Barcodeformate erfordern jedoch eine bestimmte Prüfsumme oder lassen überhaupt keine Prüfsumme zu. Bei Barcodes dieser Art wird die checksum-Eigenschaft ignoriert. Einige der übrigen Barcodeformate unterstützen nur eine begrenzte Teilmenge dieser Auswahlmöglichkeiten. Bei diesen Barcodes gibt das Vorlagenmodell keine nicht unterstützte Auswahl an.
Syntax
Reference_Syntax.checksum = "none | auto | 1mod10 | 2mod10 | 1mod10_1mod11"
Werte

Typ

Werte
Zeichenfolge
      •
      none (Standardwert)
Keine Prüfsumme einfügen.
      •
      auto
Standardprüfsumme für das Barcodeformat einfügen.
      •
      1mod10
Eine 1 modulo 10-Prüfsumme einfügen.
      •
      2mod10
Eine 2 modulo 10-Prüfsumme einfügen.
      •
      1mod10_1mod11
Eine 1 modulo 10-Prüfsumme gefolgt von einer 1 modulo 11-Prüfsumme einfügen.
1 modulo 10, 2 modulo 10 und 1 modulo 11 sind Barcodestandards. Weitere Informationen zu diesen Barcodes finden Sie in der Dokumentation zu diesen Standards.
Gilt für

Modell

Objekt
Formularmodell
barcode
Beispiele
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").checksum  = "2mod10";
FormCalc
Code11BarCode1.ui.#barcode.checksum  = "2mod10"


circular

Ermöglicht die Umwandlung eines Bogens in einen Kreis.
Syntax
Reference_Syntax.circular = "0 | 1"
Werte

Typ

Werte
Boolescher Wert
      •
      0 (Standardwert)
Den Bogen nicht in einen Kreis umwandeln.
      •
      1
Den Bogen in einen Kreis umwandeln.
Sie können einen Bogen auch dann in einen Kreis umwandeln, wenn der Inhaltsbereich, in dem sich der Bogen befindet, nicht quadratisch ist. Wenn erforderlich, wird die Größe des Kreises an die des Inhaltsbereichs angepasst.
Gilt für

Modell

Objekt
Formularmodell
arc
Beispiele
JavaScript
Circle1.resolveNode("value.#arc").circular = "1";
FormCalc
Circle1.value.#arc.circular = 1


classAll

Gibt eine Sammlung von Nodes der gleichen Klasse im Bereich zurück.
Diese Eigenschaft ist schreibgeschützt.
Syntax
Reference_Syntax.classAll = "objects"
Werte

Typ

Werte
Objekt
Eine Gruppe von Objekten, die von derselben Klasse wie das aktuelle Objekt abgeleitet wurden und sich im selben Bereich befinden.
Gilt für
tree-Klasse
Beispiele
JavaScript
Subform1.classAll;
FormCalc
Subform1.classAll


classId

Gibt einen URI-Namen oder einen Speicherort für den Programmcode an, der durch das Objekt dargestellt wird.
Syntax
Reference_Syntax.classId = "URI"
Werte

Typ

Werte
Zeichenfolge
Ein vollständig qualifizierter URI-Wert.
Gilt für

Modell

Objekt
Formularmodell
exObject


classIndex

Gibt die Position dieses Objekts in der zugehörigen Sammlung der Objekte mit ähnlichen Klassen im Bereich zurück.
Diese Eigenschaft ist schreibgeschützt.
Syntax
Reference_Syntax.classIndex = "integer"
Werte

Typ

Werte
Ganzzahl
Eine Ganzzahl, welche die Null-basierte Indexposition des aktuellen Objekts im Verhältnis zu der Gruppe von Objekten im selben Bereich darstellt, die von derselben Klasse abgeleitet werden.
Gilt für
tree-Klasse
Beispiele
JavaScript
Subform1.classIndex;
FormCalc
Subform1.classIndex


className

Legt den Namen der Klasse dieses Objekts fest.
Diese Eigenschaft ist schreibgeschützt.
Syntax
Reference_Syntax.className = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die den Klassennamen des entsprechenden Objekts darstellt.
Gilt für
object-Klasse
Beispiele
JavaScript
Subform1.className;
FormCalc
Subform1.className


codeBase

Gibt einen URI-Speicherort an, der für die Auflösung einer relativen classId-Eigenschaft verwendet werden kann.
Syntax
Reference_Syntax.codeBase = "URI"
Werte

Typ

Werte
Zeichenfolge
Ein vollständig qualifizierter URI-Wert.
Gilt für

Modell

Objekt
Formularmodell
exObject


codeType

Gibt einen Bezeichner an, der einem MIME-Typ entspricht, der den durch das Objekt dargestellten Programmcode angibt.
Syntax
Reference_Syntax.codeType = "MIME-type"
Werte

Typ

Werte
Zeichenfolge
Ein gültiger MIME-Bezeichner. Beispiel:application/java
Gilt für

Modell

Objekt
Formularmodell
exObject


colSpan

Gibt bei der Verwendung in einem Teilformular mit einer Layoutzeile die Anzahl der Spalten an, die dieses Objekt umfasst.
Syntax
Reference_Syntax.colSpan = "1 | integer"
Werte

Typ

Werte
Zeichenfolge
      •
      1 (Standardwert)
      •
      Jeder gültige Ganzzahlwert.
Gilt für

Modell

Objekt
Formularmodell
area
draw
exclGroup
field
subform
Beispiele
JavaScript
StaticText1.colSpan = "1";
FormCalc
StaticText1.colSpan = "1"


columnWidths

Gibt die Breite für Spalten einer Tabelle an.
Die columnWidth-Eigenschaft wird ignoriert, außer die layout-Eigenschaft ist auf table gesetzt.
Syntax
Reference_Syntax.columnWidth = "measurement | -1 [, [, measurement | -1 ] ]"
Werte

Typ

Werte
Zeichenfolge
Der Wert dieser Eigenschaft ist eine Gruppe mit durch Leerzeichen getrennten Token. Jedes Token muss eine gültige Maßeinheit oder -1 aufweisen. Bei Vorhandensein einer Maßeinheit wird für die entsprechende Spalte diese Breite festgelegt. Wenn das Token -1 aufweist, übernimmt die entsprechende Spalte die Breite des breitesten Inhalts für diese Spalte über alle Zeilen der Tabelle hinweg.
Gilt für

Modell

Objekt
Formularmodell
subform
Beispiele
JavaScript
Subform1.columnWidths = ".5in 1.5in";
FormCalc
Subform1.columnWidths = ".5in 1.5in"


commandType

Gibt den Befehlstyp an, der von einer Datenabfrage verwendet wird.
Syntax
Reference_Syntax.commandType = "unknown | text | table | storedProc"
Werte

Typ

Werte
Zeichenfolge
      •
      unknown (Standardwert)
      •
      text
Eine explizite SQL-Abfragezeichenfolge, die in der Datenbank nicht unter einem Namen gespeichert wird.
      •
      table
Eine in der Datenbank gespeicherte Tabelle.
      •
      storedProc
Eine Abfrage, wie z. B. eine SQL-Abfrage, die zum Abfragen mindestens einer Tabelle in der Datenbank erstellt und dann als benannte Abfrage in der Datenbank gespeichert wird.
Gilt für

Modell

Objekt
sourceSet-Modell
query
Beispiele
In diesen Beispielen stellt Titles den Namen der Datenverbindung dar.
JavaScript
xfa.sourceSet.Titles.nodes.item(1).query.setAttribute("text", "commandType");
FormCalc
xfa.sourceSet.Titles.nodes.item(1).query.setAttribute("text", "commandType")


commitKey

Beschreibt, wie der aktuelle Wert eines Formularfelds vom Benutzer festgelegt wurde.
Syntax
Reference_Syntax.commitKey = "0 | 1 | 2 | 3"
Werte

Typ

Werte
Ganzzahl
      •
      0 (Standardwert)
Der Wert wurde nicht festgelegt (beispielsweise, wenn der Anwender die ESC-Taste drückt, bevor das Formularfeld den Fokus verliert).
      •
      1
Der Wert wird festgelegt, wenn der Benutzer mit der linken Maustaste auf eine Stelle außerhalb des Feldes klickt.
      •
      2
Der Wert wird festgelegt, wenn der Benutzer die Eingabetaste drückt.
      •
      3
Der Wert wird festgelegt, wenn der Benutzer mit der Tabulatortaste zu einem neuen Feld wechselt.
Gilt für

Modell

Objekt
Ereignismodell
eventPseudoModel
Beispiele
JavaScript
xfa.event.commitKey = "2";
FormCalc
xfa.event.commitKey = "2"


commitOn

Gibt an, wann die Auswahl eines Benutzers auf das Datenmodell übertragen wird.
Syntax
Reference_Syntax.commitOn = "select | exit"
Werte

Typ

Werte
Zeichenfolge
      •
      select
Wenn ein Benutzer einen Auswahllisteneintrag mit der Tastatur oder der Maus auswählt, werden die ausgewählten Daten in das Datenmodell geschrieben.
Es kann vor allem bei Formularen, die nicht interaktive XFA-Funktionen wie Acrobat-Kommentare oder Hypertext-Verknüpfungen enthalten, wichtig sein, dass Daten aus einer Auswahlliste sofort nach der Auswahl übergeben werden. Benutzer, die solche Formulare ausfüllen, könnten irrtümlicherweise meinen, dass das Auswählen eines Elements aus einer Auswahlliste und das anschließende Klicken auf eine nicht interaktive XFA-Funktion dem Beenden der Auswahlliste entspricht. Tatsächlich bleibt der Fokus jedoch auf der Auswahlliste.
      •
      exit
Die ausgewählten Daten werden erst in das Datenmodell geschrieben, wenn das Feld den Fokus verliert. Diese Einstellung ist für Auswahllisten empfehlenswert, die mehrere Auswahlen unterstützen (open=„multiSelect“).
Gilt für

Modell

Objekt
Formularmodell
choiceList
Beispiele
JavaScript
DropDownList1.resolveNode("ui.#choiceList").commitOn = "exit";
FormCalc
DropDownList1.ui.#choiceList.commitOn = "exit"


connection

Gibt den Namen des zugeordneten Verbindungssteuerelements in der Verbindungsgruppe an.
Die durch diese Eigenschaft benannte Verbindung muss auf einen Webdienst verweisen.
Syntax
Reference_Syntax.connection = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die den Namen des zugeordneten connection-Objekts in der Verbindungsgruppe darstellt. Wenn diese Eigenschaft fehlt oder leer ist, wird für den Verbindungsnamen standardmäßig der Name des Teilformulars verwendet, das die Verbindung enthält.
Gilt für

Modell

Objekt
Formularmodell
bindItems
connect
execute
setProperty
sourceSet-Modell
connect
Beispiele
JavaScript
TextField1.resolveNode("#connect").connection = "DataConnection";
FormCalc
TextField1.#connect.connection = "DataConnection"


contains

Bestimmt, ob ein Datenwert in den Wert des übergeordneten Objekts oder als Eigenschaft des übergeordneten Objekts eingefügt werden muss.
Syntax
Reference_Syntax.contains = "data | metaData"
Werte

Typ

Werte
Zeichenfolge
      •
      data (Standardwert)
Der Wert wird in den Wert des übergeordneten Objekts eingefügt.
      •
      metaData
Der Wert ist eine Eigenschaft des übergeordneten Objekts.
Gilt für

Modell

Objekt
Datenmodell
dataValue


content

Gibt den Inhalt des Objekts an.
Syntax
Reference_Syntax.content = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die den Inhalt des Objekts darstellt. Bei Paketen mit XML-Inhalt muss damit eine leere Zeichenfolge zurückgegeben werden.
Gilt für

Modell

Objekt
XFA-Modell
packet
Beispiele
JavaScript
xfa.packet.content = "";
FormCalc
xfa.packet.content = ""


contentType

Gibt den Inhaltstyp im referenzierten Dokument an, ausgedrückt als MIME-Typ.
Syntax
Reference_Syntax.contentType = "text/plain | application/x-formcalc | Mime-type"
Werte

Typ

Werte
Zeichenfolge
Die folgenden Werte sind für Dokumente mit Text zulässig:
      •
      text/plain (Standardwert)
Nicht formatierter Text. Die Anwendung akzeptiert Inhalte, die den Anforderungen des MIME-Typs nicht exakt entsprechen.
      •
      application/x-formcalc
Ein FormCalc-Skript.
      •
      Ein gültiger MIME-Typ.
Unterstützung von anderen Texttypen, wie z. B. text/html, sowie von Skripttypen, wie z. B. application/x-ecmascript, ist durch die Implementierung definiert.
Wenn es sich bei dem referenzierten Dokument um ein Bild handelt, muss für diese Eigenschaft ein geeigneter MIME-Typ bereitgestellt werden, um der Anwendung mitzuteilen, dass der Inhalt ein Bild ist. Die Anwendung kann jedoch den bereitgestellten Wert überschreiben, wenn bei der Überprüfung der Bilddaten festgestellt wird, dass die Bilddaten einen anderen Typ aufweisen. Welche Bildtypen unterstützt werden, wird durch die Implementierung definiert.
Gilt für

Modell

Objekt
Datenmodell
dataValue
Formularmodell
exData
image
script
sourceSet-Modell
bind
Beispiele
JavaScript
ImageField1.resolveNode("value.#image").contentType = "application/x-formcalc";
FormCalc
ImageField1.value.#image.contentType = "application/x-formcalc"


context

Gibt das aktuelle Objekt an, bei dem es sich um das Startobjekt für die Methoden resolveNode und resolveNodes handelt.
Syntax
Reference_Syntax.content = "object"
Werte

Typ

Werte
Objekt
Das aktuelle Objekt.
Gilt für
model-Klasse


count

Gibt die aktuelle Anzahl der Teilformular-Instanzen in einem Formular an.
Syntax
Reference_Syntax.count = "integer"
Werte

Typ

Werte
Ganzzahl
      •
      integer
Ein Ganzzahlwert größer oder gleich Null, der die Anzahl der Teilformular-Instanzen im Formular angibt.
Gilt für

Modell

Objekt
Formularmodell
instanceManager
Beispiele
JavaScript
Subform1.instanceManager.count;
FormCalc
Subform1.instanceManager.count


credentialServerPolicy

Gibt an, ob das Prüfen des Zertifikatstatus beim Unterschreiben einer digitalen Unterschrift erforderlich ist. Der Zertifikatstatus kann anhand einer Zertifikatssperrliste oder einer OCSP-Antwort (Online Certificate Status Protocol, OCSP) geprüft werden.
Syntax
Reference_Syntax.credentialServerPolicy = "Optional | Required"
Werte

Typ

Werte
Zeichenfolge
•
Optional (Standardwert)
Das Einschließen der Zertifikatssperrliste oder OCSP-Antwort beim Unterschreiben ist optional.
•
Required
Das Einschließen der Zertifikatssperrliste oder OCSP-Antwort beim Unterschreiben ist erforderlich.
Gilt für

Modell

Objekt
Formularmodell
certificates


crlSign

Gibt eine akzeptable Schlüsselverwendungserweiterung an, die im Unterschriftszertifikat vorhanden sein muss.
Syntax
Reference_Syntax.crlSign = "Yes | No | empty_string"
Werte

Typ

Werte
Zeichenfolge
•
Yes (Standardwert)
Der Wert muss im Zertifikat eingestellt sein, damit er akzeptabel ist.
•
No
Der Wert muss nicht im Zertifikat eingestellt sein, damit er akzeptabel ist.
•
""
Ist kein Wert angegeben oder ist eine leere Zeichenfolge angegeben, wird das Attribut des Zertifikats ignoriert.
Gilt für

Modell

Objekt
Formularmodell
keyUsage


cSpace

Gibt den Farbraum an.
Der Standardfarbraum (der derzeit einzige zulässige Farbraum) ist der Farbraum SRGB.
Syntax
Reference_Syntax.cSpace = "SRGB"
Werte

Typ

Werte
Zeichenfolge
SRBG (Standardwert)
Dies ist der einzige unterstützte Wert.
Gilt für

Modell

Objekt
Formularmodell
color
Beispiele
JavaScript
TextField1.border.edge.color.cSpace = "SRGB";
FormCalc
TextField1.border.edge.color.cSpace = "SRGB"


currentPage

Legt die derzeit aktive Seite eines Dokuments zur Laufzeit fest.
Seitenzahlen sind 0-basiert; das heißt, die erste Seite eines Dokuments gibt den Wert 0 zurück.
Die Eigenschaft currentPage ist verfügbar, wenn layout:ready auf einem Client ausgeführt wird. Sie ist jedoch nicht verfügbar, wenn layout:ready auf dem Server ausgeführt wird, da die Eigenschaft nur in Verbindung mit dem Formularlayout ausgeführt wird.
Syntax
Reference_Syntax.currentPage = "integer"
Werte

Typ

Werte
Ganzzahl
Eine gültige Ganzzahl, die eine bestimmte Seite des Dokuments darstellt.
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.currentPage = "2";
FormCalc
xfa.host.currentPage = "2"


currentRecordNumber

Gibt die aktuelle Datensatznummer im Bereich der Datensätze zurück, die im aktuellen dataWindow-Objekt enthalten sind.
Syntax
Reference_Syntax.currentRecordNumber = "integer"
Werte

Typ

Werte
Ganzzahl
Jeder gültige Ganzzahlwert.
Gilt für

Modell

Objekt
Datenmodell
dataWindow
Beispiele
JavaScript
xfa.dataWindow.currentRecordNumber = "2"; // The third record
FormCalc
xfa.dataWindow.currentRecordNumber = "2" // The third record


cursorLocation

Gibt den Speicherort der Cursorbibliothek an, die mit der Datensatzgruppe verwendet wird.
Syntax
Reference_Syntax.cursorLocation = "client | server"
Werte

Typ

Werte
Zeichenfolge
      •
      client (Standardwert)
Die Cursorbibliothek befindet sich auf dem Clientcomputer.
      •
      server
Die Cursorbibliothek befindet sich auf dem Servercomputer.
Gilt für

Modell

Objekt
sourceSet-Modell
recordSet


cursorType

Gibt den Typ des Cursors an, der beim Öffnen der Datensatzgruppe verwendet wird.
Syntax
Reference_Syntax.cursorType = "forwardOnly | keyset | dynamic | static | unspecified"
Werte

Typ

Werte
Zeichenfolge
      •
      forwardOnly (Standardwert)
Identisch mit einem statischen Cursor, mit der Ausnahme, dass ein Bildlauf nur nach vorn durchgeführt werden kann. Auf diese Weise wird die Leistung verbessert, wenn nur ein Durchgang durch eine Datensatzgruppe erforderlich ist.
      •
      keyset
Ähnlich wie ein dynamischer Cursor, mit der Ausnahme, dass von anderen Benutzern hinzugefügte Datensätze nicht angezeigt werden. Datenänderungen durch andere Benutzer werden angezeigt.
      •
      dynamic
Hinzufügungs-, Änderungs- und Löschvorgänge von anderen Benutzern werden angezeigt. Alle Arten der Bewegung durch die Datensatzgruppe sind zulässig, außer bei Lesezeichen, wenn diese vom Anbieter nicht unterstützt werden.
      •
      static
Eine statische Kopie einer Datensatzgruppe zum Suchen von Daten oder Generieren von Berichten. Hinzufügungs-, Änderungs- oder Löschvorgänge durch andere Benutzer werden nicht angezeigt.
      •
      unspecified
Der Cursortyp ist nicht angegeben.
Gilt für

Modell

Objekt
sourceSet-Modell
recordSet


data

Gibt an, ob das in Widget bereitgestellte Bild als Verweis dargestellt oder eingebettet werden soll.
Die data-Eigenschaft wirkt sich auf das Verhalten des Objekts beim Ausfüllen des Formulars aus.
Syntax
Reference_Syntax.data = "link | embed"
Werte

Typ

Werte
Zeichenfolge
      •
      link
Das Bild wird als URI-Verweis dargestellt. Wenn der Benutzer in Widget einen URI bereitstellt, wird das href-Attribut des image-Objekts des Containers mit dem neuen URI aktualisiert. Wenn das image-Objekt zuvor mit einem eingebetteten Bild geladen wurde, wird dieses Bild aus dem Objekt entfernt.
      •
      embed
Das Bild wird in das image-Objekt des Containers eingebettet. Wenn der Benutzer in Widget einen URI bereitstellt, wird das durch den URI referenzierte Bild als Inhalt des image-Objekts eingebettet.
Gilt für

Modell

Objekt
Formularmodell
imageEdit
Beispiele
JavaScript
TextField1.resolveNode("ui.#imageEdit").data = "embed";
FormCalc
TextField1.ui.#textEdit.data = "embed"


dataColumnCount

Gibt eine optionale Anzahl an Datenspalten an, die für unterstützte Barcodes kodiert werden. Diese Eigenschaft bezieht sich nur auf zweidimensionale Barcodes.
Der Formularentwurf muss diese Eigenschaft zusammen mit der dataRowCount-Eigenschaft bereitstellen, um einen festen Zeilen- und Spaltenbarcode anzugeben. Andernfalls muss der Parser die Zeilen- und Spaltenzahl mit Hilfe der rowColumnRatio-Eigenschaft bestimmen. Die Vorlage darf die dataColumnCount-Eigenschaft nur bereitstellen, wenn die dataRowCount-Eigenschaft ebenfalls bereitgestellt wird. Wenn diese Eigenschaften verwendet werden, ist die Größe des Barcodes fest. Wenn die bereitgestellten Daten den Barcode nicht füllen, wird er mit Füllzeichen aufgefüllt.
Syntax
Reference_Syntax.dataColumnCount = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, welche die Anzahl der zu kodierenden Datenspalten darstellt.
Gilt für

Modell

Objekt
Formularmodell
barcode
Beispiele
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").dataColumnCount = "3";
FormCalc
Code11BarCode1.ui.#barcode.dataColumnCount = "3"


dataDescription

Gibt den Namen der Beschreibung der Datenverbindung an, die mit einem bestimmten Typ von Webdienstverbindung verwendet wird.
Syntax
Reference_Syntax.dataDescription = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die den Namen einer Datenbeschreibung darstellt, die beim Exportieren von Daten verwendet wird.
Gilt für

Modell

Objekt
connectionSet-Modell


dataEncipherment

Gibt eine akzeptable Schlüsselverwendungserweiterung an, die im Unterschriftszertifikat vorhanden sein muss.
Syntax
Reference_Syntax.dataEncipherment = "Yes | No | empty_string"
Werte

Typ

Werte
Zeichenfolge
•
Yes (Standardwert)
Der Wert muss im Zertifikat eingestellt sein, damit er akzeptabel ist.
•
No
Der Wert muss nicht im Zertifikat eingestellt sein, damit er akzeptabel ist.
•
""
Ist kein Wert angegeben oder ist eine leere Zeichenfolge angegeben, wird das Attribut des Zertifikats ignoriert.
Gilt für

Modell

Objekt
Formularmodell
keyUsage


dataLength

Gibt die maximale Anzahl Zeichen für diese Barcodeinstanz an. Diese Eigenschaft bezieht sich nur auf eindimensionale Barcodes.
Wenn bei Software-Barcodes die moduleWidth-Eigenschaft nicht angegeben ist, muss der Formularentwurf die dataLength-Eigenschaft bereitstellen. Bei Hardware-Barcodes wird diese Eigenschaft ignoriert.
Die angezeigten Daten werden nicht geprüft. Bei Software-Barcodes erlaubt die Anwendung das Überlaufen der Daten über den zugewiesenen Feldbereich hinaus. Bei Hardware-Barcodes hängt das Ergebnis eines Überlaufs vom Drucker ab.
Es gibt keine entsprechende Mindestlängeneinschränkung. Einige Barcodeformate haben eine feste Anzahl Symbole und müssen mit Füllzeichen ausgefüllt werden. Bei anderen ist die Anzahl Symbole variabel. Sie müssen nach dem letzten Symbol enden.
Syntax
Reference_Syntax.dataLength = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, welche die maximale Anzahl Zeichen für diese Barcodeinstanz darstellt. Jeder Barcodetyp verfügt über seinen eigenen Längen-Standardwert.
Gilt für

Modell

Objekt
Formularmodell
barcode
Beispiele
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").dataLength = "10";
FormCalc
Code11BarCode1.ui.#barcode.dataLength = "10"


dataPrep

Definiert die Vorverarbeitung für die Daten, die in den Barcode geschrieben werden.
Die Daten in den Objektmodellen sind davon nicht betroffen. Die Eigenschaft hat auch keinen Einfluss darauf, was der Benutzer sieht, wenn das Feld in interaktiven Kontexten den Fokus hat.
Nur bei 2D-Barcodes empfehlenswert.
Syntax
Reference_Syntax.dataPrep = "none | flateCompress"
Werte

Typ

Werte
Zeichenfolge
      •
      none (Standardwert)
Verwendet die bereitgestellten Daten.
      •
      flateCompress
Schreibt eine Kopfzeile, die aus einem Byte mit dem Dezimalwert 257 besteht, gefolgt von einem weiteren Byte mit dem Dezimalwert 1. Anschließend werden die Daten komprimiert mit dem Flate-Algorithmus geschrieben, wie von der Internet Engineering Task Force (IETF) in RFC1951 definiert. Es wird kein Predictor-Algorithmus verwendet.
Legen Sie für diese Option keinen Typ fest, der keine beliebigen Binärdaten verschlüsseln kann.
Gilt für

Modell

Objekt
Formularmodell
barcode
Beispiele
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").dataPrep = "flateCompress";
FormCalc
Code11BarCode1.ui.#barcode.dataPrep = "flateCompress"


dataRowCount

Gibt eine optionale Anzahl an Datenzeilen an, die für unterstützte Barcodes kodiert werden. Diese Eigenschaft bezieht sich nur auf 2D-Barcodes.
Der Formularentwurf kann diese Eigenschaft zusammen mit der dataColumnCount-Eigenschaft bereitstellen, um einen Barcode mit festen Zeilen und Spalten anzugeben. Andernfalls können die rowColumnRatio-Eigenschaft und die tatsächliche Länge der eingefügten Daten die Zeilen- und Spaltenzahl bestimmen. Die dataRowCount-Eigenschaft darf nur vorhanden sein, wenn die dataColumnCount-Eigenschaft ebenfalls vorhanden ist. Wenn diese Eigenschaften verwendet werden, ist die Größe des Barcodes fest. Wenn die bereitgestellten Daten den Barcode nicht füllen, werden die restlichen Zellen mit Füllzeichen aufgefüllt.
Syntax
Reference_Syntax.dataRowCount = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, welche die Anzahl der zu kodierenden Datenzeilen darstellt.
Gilt für

Modell

Objekt
Formularmodell
barcode
Beispiele
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").dataRowCount = "2";
FormCalc
Code11BarCode1.ui.#barcode.dataRowCount = "2"


db

Gibt den Namen einer vom Anbieter bereitgestellten Datenbank an.
Syntax
Reference_Syntax.db = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die den Datenbanknamen darstellt.
Gilt für

Modell

Objekt
sourceSet-Modell
source


decipherOnly

Gibt eine akzeptable Schlüsselverwendungserweiterung an, die im Unterschriftszertifikat vorhanden sein muss.
Syntax
Reference_Syntax.decipherOnly = "Yes | No | empty_string"
Werte

Typ

Werte
Zeichenfolge
•
Yes (Standardwert)
Der Wert muss im Zertifikat eingestellt sein, damit er akzeptabel ist.
•
No
Der Wert muss nicht im Zertifikat eingestellt sein, damit er akzeptabel ist.
•
""
Ist kein Wert angegeben oder ist eine leere Zeichenfolge angegeben, wird das Attribut des Zertifikats ignoriert.
Gilt für

Modell

Objekt
Formularmodell
keyUsage


delayedOpen

Gibt die Anzahl der Sekunden an, um die das Öffnen der Datenquelle nach dem Herstellen einer Verbindung verzögert wird.
Syntax
Reference_Syntax.delayedOpen = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, welche die Anzahl der Sekunden darstellt.
Gilt für

Modell

Objekt
sourceSet-Modell
command
Beispiele
In diesen Beispielen stellt Titles den Namen der Datenverbindung dar.
JavaScript
xfa.sourceSet.Titles.connect.delayedOpen = "5";
FormCalc
xfa.sourceSet.Titles.connect.delayedOpen = "5"


delimiter

Trennt die Attribute in der Zeichenfolge für den charakteristischen Namen.
Syntax
Reference_Syntax.delimiter = ", | string"
Werte

Typ

Werte
Zeichenfolge
•
, (Standardwert)
•
Eine gültige Zeichenfolge, die die Attribute in der Zeichenfolge für den charakteristischen Namen trennt.


digitalSignature

Gibt eine akzeptable Schlüsselverwendungserweiterung an, die im Unterschriftszertifikat vorhanden sein muss.
Syntax
Reference_Syntax.digitalSignature = "Yes | No | empty_string"
Werte

Typ

Werte
Zeichenfolge
•
Yes (Standardwert)
Der Wert muss im Zertifikat eingestellt sein, damit er akzeptabel ist.
•
No
Der Wert muss nicht im Zertifikat eingestellt sein, damit er akzeptabel ist.
•
""
Ist kein Wert angegeben oder ist eine leere Zeichenfolge angegeben, wird das Attribut des Zertifikats ignoriert.
Gilt für

Modell

Objekt
Formularmodell
keyUsage


disable

Deaktiviert die akustische Meldung.
Syntax
Reference_Syntax.disable = "1 | 0"
Werte

Typ

Werte
Zeichenfolge
      •
      1 (Standardwert)
Wenn das Feld nicht ausgeblendet oder unsichtbar ist, wird eine akustische Meldung generiert.
      •
      0
Es wird keine akustische Meldung generiert.
Gilt für

Modell

Objekt
Formularmodell
speak
Beispiele
JavaScript
TextField1.assist.speak.disable = "0";
FormCalc
TextField1.assist.speak.disable = "0"


embedPDF

Bestimmt, ob eine PDF-Datei als Teil der Daten eingefügt wird.
Syntax
Reference_Syntax.embedPDF = "0 | 1"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
Die PDF-Datei wird als Teil der Daten gesendet.
      •
      1
Die PDF-Datei wird nicht als Teil der Daten gesendet. Stattdessen wird ein URI gesendet.
Gilt für

Modell

Objekt
Formularmodell
submit
Beispiele
JavaScript
Button1.resolveNode("#event.#submit").embedPDF = "1";
FormCalc
Button1.#event.#submit.embedPDF = "1"


encipherOnly

Gibt eine akzeptable Schlüsselverwendungserweiterung an, die im Unterschriftszertifikat vorhanden sein muss.
Syntax
Reference_Syntax.encipherOnly = "Yes | No | empty_string"
Werte

Typ

Werte
Zeichenfolge
•
Yes (Standardwert)
Der Wert muss im Zertifikat eingestellt sein, damit er akzeptabel ist.
•
No
Der Wert muss nicht im Zertifikat eingestellt sein, damit er akzeptabel ist.
•
""
Ist kein Wert angegeben oder ist eine leere Zeichenfolge angegeben, wird das Attribut des Zertifikats ignoriert.
Gilt für

Modell

Objekt
Formularmodell
keyUsage


endChar

Gibt ein optionales Endsteuerzeichen an, das an die Barcodedaten angehängt wird.
Die Eigenschaft endChar wird vom Parser ignoriert, wenn das Barcodemuster das angegebene Steuerzeichen nicht unterstützt.
Syntax
Reference_Syntax.endChar = "character"
Werte

Typ

Werte
Zeichenfolge
Ein gültiges Steuerzeichen.
Gilt für

Modell

Objekt
Formularmodell
barcode
Beispiele
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").endChar = "*";
FormCalc
Code11BarCode1.ui.#barcode.endChar = "*"


eofAction

Gibt die Aktion an, die durchgeführt wird, wenn der aktuelle Datensatz der letzte Datensatz in der Datensatzgruppe ist.
Syntax
Reference_Syntax.eofAction = "moveLast | stayEOF | addNew"
Werte

Typ

Werte
Zeichenfolge
      •
      moveLast (Standardwert)
Verschiebt die aktuelle Datensatzposition an eine Stelle nach dem letzten Datensatz.
      •
      stayEOF
Der aktuelle Datensatz ist immer der letzte Datensatz in der Datensatzgruppe.
      •
      addNew
Fügt der Datensatzgruppe einen neuen Datensatz hinzu.
Gilt für

Modell

Objekt
sourceSet-Modell
recordSet


errorCorrectionLevel

Gibt ein optionales Fehlerkorrektur-Level an, das auf unterstützte Barcodes angewendet werden soll. Diese Eigenschaft bezieht sich nur auf 2D-Barcodes.
Bei Barcodes, die diese Eigenschaft akzeptieren, ignoriert der Parser die checksum-Eigenschaft.
Syntax
Reference_Syntax.errorCorrectionLevel = "0 | integer"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
      •
      Für PDF417 sind die gültigen Werte Ganzzahlen von 0 bis einschließlich 8.
Gilt für

Modell

Objekt
Formularmodell
barcode
Beispiele
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").errorCorrectionLevel = "5";
FormCalc
Code11BarCode1.ui.#barcode.errorCorrectionLevel = "5"


executeType

Gibt an, ob neue Daten in das bestehende Formular importiert oder neue Daten mit dem ursprünglichen Formularentwurf zusammengeführt werden sollen, um ein neues Formular zu erstellen.
Syntax
Reference_Syntax.executeType = "import | remerge"
Werte

Typ

Werte
Zeichenfolge
      •
      import (Standardwert)
Importiert Daten in das aktuelle Formular, ohne diese Daten mit dem Formularentwurf zusammenzuführen.
      •
      remerge
Führt die Daten im Datensatz „connectionData“ mit dem Formularentwurf zusammen. Während des Zusammenführens werden in Abhängigkeit von den Daten, die vom Webdienst zurückgegeben werden, dynamische Teilformulare erstellt, wenn dies notwendig ist.
Gilt für

Modell

Objekt
Formularmodell
execute
Beispiele
JavaScript
Button1.resolveNode("#event.#execute").executeType = "remerge";
FormCalc
Button1.#event.#execute.executeType = "remerge"


fillColor

Der Wert für die Hintergrundfarbe für dieses Feld.
Bevor Sie die Farbe ändern können, müssen Sie eine Füllfarbe definieren.
Syntax
Reference_Syntax.fillColor = "[0-255], [0-255], [0-255]"
Werte

Typ

Werte
Zeichenfolge
Für den Farbraum SRGB sind die Komponentenwerte r,g,b erforderlich. Dabei steht r für den roten Komponentenwert, g für den grünen Komponentenwert und b für den blauen Komponentenwert. Jeder Komponentenwert muss innerhalb des Wertebereichs von 0 bis 255 (einschließlich) liegen. Der Wert 255 stellt die maximale Anzeigeintensität dar. Mit 255,0,0 wird beispielsweise die Farbe Rot angegeben.
Die Standardeinstellung hängt davon ab, in welchem Kontext die Farbe verwendet wird. Die Standardfarbe wird von dem Objekt bestimmt, das das Farbobjekt umschließt.
Gilt für

Modell

Objekt
Formularmodell
exclGroup
field
Beispiele
JavaScript
TextField1.fillColor = "150,130,33";
FormCalc
TextField1.fillColor = "150,130,33"


fontColor

Der Wert für die Vordergrundfarbe für das Feld.
Syntax
Reference_Syntax.fontColor = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, welche die Schriftfarbe darstellt.
Gilt für

Modell

Objekt
Formularmodell
field
Beispiele
JavaScript
TextField1.fontColor = "150,130,33";
FormCalc
TextField1.fontColor = "150,130,33"


format

Bestimmt das Format, in dem die Daten übergeben werden.
Syntax
Reference_Syntax.format = "xdp | formdata | pdf | xml"
Werte

Typ

Werte
Zeichenfolge
      •
      xdp (Standardwert)
Die Daten werden im XDP-Format gepackt.
      •
      formdata
Die Daten werden im URL-kodierten Format wie unter „Uniform Resource Locators (URL)“ beschrieben gepackt.
      •
      pdf
Die Daten werden wie in den Adobe PDF-Spezifikationen beschrieben als PDF gepackt.
Gilt für

Modell

Objekt
Formularmodell
submit
Beispiele
JavaScript
Button1.resolveNode("#event.#submit").format = "pdf"
FormCalc
Button1.#event.#submit.format = "pdf"


formatMessage

Gibt die Zeichenfolge der Meldung zur Formatprüfung für dieses Feld an.
Syntax
Reference_Syntax.formatMessage = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, welche die Meldung zur Formatprüfung darstellt.
Gilt für

Modell

Objekt
Formularmodell
field
Beispiele
JavaScript
TextField1.formatMessage = "Please use the format: LASTNAME, FIRSTNAME";
FormCalc
TextField1.formatMessage = "Please use the format: LASTNAME, FIRSTNAME"


formattedValue

Gibt den formatierten Wert für das Feld an.
Syntax
Reference_Syntax.formattedValue = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die den Wert des Feldes mit Formatierung einschließlich Bildformaten und Symbolen angibt.
Gilt für

Modell

Objekt
Formularmodell
field
Beispiele
JavaScript
TextField2.rawValue = TextField1.formattedValue;
FormCalc
TextField2 = TextField1.formattedValue


formatTest

Steuert die Überprüfung auf Übereinstimmung mit der „display picture“-Klausel.
Die formatTest-Eigenschaft kann für Überprüfungen verwendet werden.
Syntax
Reference_Syntax.formatTest = "warning | disabled | error"
Werte

Typ

Werte
Zeichenfolge
      •
      disabled
Keinen Test ausführen. Das Formularobjekt darf einen Wert haben, welcher der picture-Klausel nicht entspricht. Selbst wenn das Feld einen nicht konformen Wert enthält, wird das Formular dadurch nicht ungültig.
      •
      error
Eine Meldung wird ausgegeben, und es werden keine Daten akzeptiert, die nicht mit der picture-Klausel übereinstimmen. Das Formularobjekt muss einer picture-Klausel entsprechen.
      •
      warning (Standardwert)
Wenn die Daten nicht mit der picture-Klausel übereinstimmen, wird eine Meldung ausgegeben. Der Benutzer darf jedoch zum nächsten Feld wechseln. Die Meldung muss den Benutzer darüber informieren, dass das Formularobjekt einen Wert haben sollte, welcher der picture-Klausel entspricht. Es müssen zwei Möglichkeiten zur Verfügung stehen:
      •
      dismiss: Der Benutzer nimmt die Meldung zur Kenntnis und möchte zum Formular zurückkehren, um diese Einschränkung zu erfüllen.
      •
      override:Der Benutzer nimmt die Meldung zur Kenntnis, entscheidet jedoch, gegen diese Einschränkung zu verstoßen.
Gilt für

Modell

Objekt
Formularmodell
validate
Beispiele
Überprüfungsmuster festlegen, wenn dieses noch nicht definiert wurde.
JavaScript
TextField1.validate.picture.value = "A9A 9A9";
TextField1.validate.formatTest = "error";
FormCalc
TextField1.validate.picture = "A9A 9A9"
TextField1.validate.formatTest = "error"


fracDigits

Gibt die maximale Anzahl der Stellen nach dem Dezimalzeichen zur Erfassung und Speicherung an.
Syntax
Reference_Syntax.fracDigits = "2 | integer"
Werte

Typ

Werte
Zeichenfolge
      •
      2 (Standardwert)
      •
      Eine Zeichenfolge, die einen beliebigen gültigen Ganzzahlwert darstellt.
Beispiele
Für den numerischen Felddatentyp sollte das Dezimalformat festgelegt werden.
JavaScript
NumericField1.resolveNode("value.#decimal").fracDigits = "3";
FormCalc
NumericField1.value.#decimal.fracDigits = "3"


from

Gibt den ursprünglichen Spaltennamen in der Datenquelle an.
Syntax
Reference_Syntax.from = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die den Namen der Spalte in der Datenquelle darstellt, aus der Daten zugeordnet werden.
Gilt für

Modell

Objekt
sourceSet-Modell
map


fullText

Stellt den vollständigen (nicht abgeschnittenen) Wert dar, den ein Benutzer in ein Formularfeld einfügt.
In Felder eingefügter Text kann abgeschnitten werden, wenn er über den zulässigen Inhaltsbereich hinausgeht. Die Eigenschaft fullText speichert den nicht abgeschnittenen Wert zur Verwendung für Skriptoperationen.
Der Wert von newContentType bestimmt den Inhaltstyp dieser Eigenschaft.
Syntax
Reference_Syntax.fullText = "string"
Werte

Typ

Werte
Zeichenfolge
Eine beliebige gültige Zeichenfolge.
Gilt für

Modell

Objekt
Ereignismodell
eventPseudoModel
Beispiele
JavaScript
xfa.event.fullText;
FormCalc
xfa.event.fullText


h

Eine Maßeinheit für die Höhe des Layouts.
Wenn die Höhe in Form einer Maßeinheit angegeben wird, überschreibt dieser Wert jeden durch die Eigenschaften minH und maxH zugelassenen Wachstumsbereich. Erfolgt keine Angabe der Eigenschaft oder wird eine leere Zeichenfolge angegeben, wird der Wachstumsbereich durch die Eigenschaften minH und maxH vorgegeben.
Syntax
Reference_Syntax.h = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
contentArea
draw
exclGroup
field
subform
Beispiele
JavaScript
TextField1.h = "2in";
FormCalc
TextField1.h = "2in"


hAlign

Gibt die horizontale Textausrichtung an.
Syntax
Reference_Syntax.hAlign = "left | center | right | justifyAll | justify | radix"
Werte

Typ

Werte
Zeichenfolge
      •
      left (Standardwert)
Am linken Rand des verfügbaren Bereichs ausrichten.
      •
      center
Horizontal innerhalb des verfügbaren Bereichs zentrieren.
      •
      right
Am rechten Rand des verfügbaren Bereichs ausrichten.
      •
      justifyAll
Alle Zeilen im Blocksatz ausrichten, damit der gesamte verfügbare Bereich gefüllt wird.
      •
      justify
Die letzte Zeile links ausrichten und den Rest im Blocksatz ausrichten.
Gilt für

Modell

Objekt
Formularmodell
draw
exclGroup
field
para
subform
Beispiele
JavaScript
TextField1.para.hAlign = "right";
FormCalc
TextField1.para.hAlign = "right"


hand

Beschreibt die Ausrichtung einer Linie oder Kante.
Syntax
Reference_Syntax.hand = "even | left | right"
Werte

Typ

Werte
Zeichenfolge
      •
      even (Standardwert)
Zentriert die angezeigte Linie auf dem zugrunde liegenden Vektor oder Bogen.
      •
      left
Positioniert die angezeigte Linie beim Verfolgen der Linie vom Anfangs- bis zum Endpunkt direkt links neben dem zugrunde liegenden Vektor oder Bogen.
      •
      right
Positioniert die angezeigte Linie beim Verfolgen der Linie vom Anfangs- bis zum Endpunkt direkt rechts neben dem zugrunde liegenden Vektor oder Bogen.
Gilt für

Modell

Objekt
Formularmodell
arc
border
line
rectangle
Beispiele
JavaScript
Line1.resolveNode("value.#line").hand = "left";
FormCalc
Line1.value.#line.hand = "left"


highlight

Gibt das visuelle Erscheinungsbild einer Schaltfläche bei Aktivierung durch einen Benutzer an. Alle Werte unterstützen zwei Zustände (nicht aktiviert und aktiviert), mit Ausnahme von push, der drei Zustände unterstützt (nicht aktiviert, aktiviert und Mauskontakt).
Syntax
Reference_Syntax.highlight="none | inverted | push | outline"
Werte

Typ

Werte
Zeichenfolge
      •
      push (Standardwert)
      •
      none
      •
      inverted
      •
      outline
Auf den highlight-Modus „push“ eingestellte Schaltflächen können den verschiedenen Schaltflächenzuständen unterschiedliche Beschriftungen zuweisen (aktiviert und Mauskontakt).
Gilt für

Modell

Objekt
Formularmodell
button
Beispiele
JavaScript
Button1.resolveNode("ui.#button").highlight = "push";
FormCalc
Button1.ui.#button.highlight = "push"


href

Gibt einen Verweis auf eine externe Datei oder Ressource an.
Die transferEncoding-Eigenschaft gilt für externe Bilder nicht.
Syntax
Reference_Syntax.href = "URL"
Werte

Typ

Werte
Zeichenfolge
Eine gültige HTML-Referenz. Beispiel:
      •
      http://www.adobe.com/data
      •
      ftp://255.255.0.0/dataFiles
Gilt für

Modell

Objekt
Formularmodell
exData
image
Beispiele
JavaScript
ImageField1.resolveNode("value.#image").href = "E:\dev\Logos\adobe.jpg";
FormCalc
ImageField1.value.#image.href = "E:\dev\Logos\adobe.jpg"


hScrollPolicy

Gibt an, ob in einem Feld der horizontale Bildlauf verfügbar ist.
Diese Eigenschaft findet keine Anwendung für Textfelder, die sich erweitern können, um Daten oder Text aufzunehmen.
Syntax
Reference_Syntax.hScrollPolicy = "auto | on | off"
Werte

Typ

Werte
Zeichenfolge
      •
      auto (Standardwert)
Einzeilige Felder bieten einen horizontalen Bildlauf und mehrzeilige Felder einen vertikalen Bildlauf (bei Bedarf wird eine vertikale Bildlaufleiste angezeigt).
      •
      on
Vertikale und/oder horizontale Bildlaufleisten werden unabhängig davon angezeigt, ob der Text bzw. die Daten über die Grenzen des Feldes fließt bzw. fließen.
      •
      off
Beschränkt die Eingabe von Zeichen im Feld durch den Benutzer auf die Anzahl von Zeichen, die physisch in die Feldbreite passt. Beachten Sie, dass diese Einschränkung nicht für Daten im Feld gilt.
Gilt für

Modell

Objekt
Formularmodell
dateTimeEdit
Beispiele
JavaScript
TextField1.resolveNode("ui.#textEdit").hScrollPolicy = "off";
FormCalc
TextField1.ui.#textEdit.hScrollPolicy = "off"


id

Gibt einen allgemeinen benutzerdefinierten XML-ID-Typ an.
Syntax
Reference_Syntax.id = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die eine benutzerdefinierte XML-Kennung darstellt.
Gilt für
node-Klasse
Beispiele
In diesen Beispielen ist CurrentPageNumber ein schwebendes Feld. Hierbei handelt es sich um einen Objekttyp mit einer Kennung.


imagingBBox

Gibt einen Bereich im Medium an, das zur Wiedergabe mit vier kommagetrennten Maßeinheiten verfügbar ist und die Maßeinheiten für x, y, Breite und Höhe darstellt.
Syntax
Reference_Syntax.bind = "none | x, y, width, height"
Werte

Typ

Werte
Zeichenfolge
      •
      none (Standardwert)
Der gesamte Bereich des Papiers steht für die Wiedergabe zur Verfügung.
      •
      x, y, width, height
Der Inhalt des Teilformulars ist für die Bearbeitung durch den Benutzer nicht verfügbar. Ein Benutzeragent muss das Teilformular als Pass-Through-Container in aufeinanderfolgenden Vorgängen behandeln. Sie benötigen keine Erlaubnis, um den Inhalt des Teilformulars zu bearbeiten. Der Inhalt des Teilformulars kann weiterhin (beispielsweise mit Skriptvorgängen und Berechnungen) direkt bearbeitet werden.
Gilt für

Modell

Objekt
Formularmodell
medium
Beispiele
JavaScript
xfa.form.form1.pageSet.Page1.medium = "100, 100, 50, 50";
FormCalc
xfa.form.form1.pageSet.Page1.medium = "100, 100, 50, 50"


index

Gibt die Position dieser Node in der zugehörigen Sammlung der Nodes mit ähnlichen Namen im Bereich zurück.
Wenn die Node keinen Namen hat, wird die Position in der zugehörigen Sammlung von benannten Nodes der gleichen Klasse zurückgegeben.
Syntax
Reference_Syntax.index = "integer"
Werte

Typ

Werte
Ganzzahl
Eine Ganzzahl, welche die Null-basierte Indexposition des aktuellen Objekts relativ zu Objekten mit demselben Namen im selben Bereich darstellt.
Gilt für
tree-Klasse
Beispiele
JavaScript
Subform1.parent.index;
FormCalc
Subform1.parent.index


initial

Gibt die Anfangsanzahl der Exemplare für den einschließenden Container an.
Syntax
Reference_Syntax.initial = "1 | string"
Werte

Typ

Werte
Zeichenfolge
      •
      1 (Standardwert)
      •
      Eine gültige Zeichenfolge, die eine beliebige gültige Ganzzahl darstellt.
Gilt für

Modell

Objekt
Formularmodell
occur
Beispiele
Das Ändern des occur-Objekts im form:ready-Ereignis ist in diesem Formularstadium zu spät. Es muss im template:ready-Ereignis bearbeitet werden. Auf das template:ready-Ereignis kann über die Benutzeroberfläche nicht zugegriffen werden.
JavaScript
Subform1.occur.initial = "3";
FormCalc
Subform1.occur.initial = "3"


initialNumber

Stellt dem ersten Seitenexemplar in einer Folge die erste Seitennummer bereit, sofern sich die Eigenschaft in einem Bereich mit nummerierten Seiten befindet.
Syntax
Reference_Syntax.initialNumber = "1 | string"
Werte

Typ

Werte
Zeichenfolge
      •
      1 (Standardwert)
      •
      Eine gültige Zeichenfolge, die eine beliebige Ganzzahl darstellt.
Gilt für

Modell

Objekt
Formularmodell
pageArea
Beispiele
JavaScript
xfa.form.form1.pageSet.Page1.initialNumber = "4";
FormCalc
xfa.form.form1.pageSet.Page1.initialNumber = "4"


input

Gibt eine Eingabemeldung an, die mit einem bestimmten WSDL-Verbindungsvorgang verknüpft ist.
Syntax
Reference_Syntax.input = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die eine Eingabemeldung darstellt.
Gilt für

Modell

Objekt
connectionSet-Modell
operation


intact

Gibt die Einschränkungen beim Erhalten eines Teilformulars im Inhaltsbereich oder in einer Seite an.
Syntax
Reference_Syntax.intact = "none | contentArea | pageArea"
Werte

Typ

Werte
Zeichenfolge
      •
      none (Standardwert)
Die Entscheidung, ob ein Teilformular in einem Inhaltsbereich oder in einer Seite erhaltend wiedergegeben wird, wird auf die verarbeitende Anwendung übertragen. Ein Teilformular kann über einen Inhaltsbereich oder eine Seite aufgeteilt werden. Dies ist der Standardwert, wenn das Layout des übergeordneten Containers tb, lr-tb oder table ist.
      •
      contentArea
Es wird angefordert, dass das Teilformular in einem Inhaltsbereich erhaltend wiedergegeben wird. Dies ist der Standardwert, wenn das Layout des übergeordneten Containers position oder row ist.
      •
      pageArea
Es wird angefordert, dass das Teilformular in einer Seite erhaltend wiedergegeben wird.
Für diese Eigenschaft gibt es keinen Standardwert. Bei diesem Wert muss stattdessen die Groß-/Kleinschreibung beachtet werden. Wenn das Layout des übergeordneten Containers tb, lr-tb oder table ist, lautet der Standardwert none. Wenn das Layout des übergeordneten Containers position oder row ist, lautet der Standardwert contentArea. Der Standardwert wird zum Zeitpunkt des API-Aufrufs zum Abrufen des Werts oder zu dem Zeitpunkt berechnet, zu dem der Layoutvorgang aufgerufen wird.
Gilt für

Modell

Objekt
Formularmodell
keep
Beispiele
JavaScript
Subform1.keep.intact = "pageArea";
FormCalc
Subform1.keep.intact = "pageArea"


inverted

Gibt an, ob die Ecke konvex (verbindet die Kanten tangential) oder invertiert und damit konkav (verbindet die Kanten im rechten Winkel) dargestellt wird.
Syntax
Reference_Syntax.inverted = "0 | 1"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
Die Ecke wird konvex dargestellt.
      •
      1
Die Ecke wird konkav dargestellt.
Gilt für

Modell

Objekt
Formularmodell
corner
Beispiele
JavaScript
TextField1.border.corner.inverted = "1";
FormCalc
TextField1.border.corner.inverted = "1"


isContainer

Gibt an, ob dieses Objekt ein container-Objekt ist.
Diese Eigenschaft ist schreibgeschützt.
Syntax
Reference_Syntax.isContainer = "True | False"
Werte

Typ

Werte
Boolescher Wert
      •
      True (Standardwert)
Das Objekt ist ein Objekt des Typs „container“.
      •
      False
Das Objekt ist kein Objekt des Typs „container“.
Gilt für
node-Klasse
Beispiele
JavaScript
TextField1.isContainer;
FormCalc
TextField1.isContainer


isDefined

Gibt an, ob derzeit ein gültiges Datenfenster definiert ist.
Ein Datenfenster ist gültig, wenn der aktuelle Datensatzindex auf einen Datensatz in den Daten verweist. Ein Datenfenster ist nicht definiert, wenn keine Datensätze vorhanden sind, oder wenn der aktuelle Datensatzindex über das Ende des Datensatzbereichs hinausreicht.
Diese Eigenschaft ist schreibgeschützt.
Syntax
Reference_Syntax.isDefined = "True | False"
Werte

Typ

Werte
Boolescher Wert
      •
      True (Standardwert)
Das aktuelle Datenfenster ist definiert.
      •
      False
Das aktuelle Datenfenster ist nicht definiert.
Gilt für

Modell

Objekt
Datenmodell
dataWindow
Beispiele
JavaScript
xfa.dataWindow.isDefined;
FormCalc
$dataWindow.isDefined


isNull

Gibt an, ob der aktuelle Datenwert der Nullwert ist.
Syntax
Reference_Syntax.isNull = "True | False"
Werte

Typ

Werte
Boolescher Wert
      •
      True (Standardwert)
Der aktuelle Datenwert ist der Nullwert.
      •
      False
Das aktuelle Datenfenster entspricht nicht dem Nullwert.
Gilt für
node-Klasse

Modell

Objekt
Datenmodell
dataValue
Beispiele
JavaScript
TextField1.isNull = "False";
FormCalc
TextField1.isNull = "False"


join

Gibt die Form der Ecke an.
Syntax
Reference_Syntax.join = "square | round"
Werte

Typ

Werte
Zeichenfolge
      •
      square (Standardwert)
Die Ecke hat zwischen den aufeinander treffenden Kanten die Form eines rechten Winkels.
      •
      round
Die Ecke hat zwischen den aufeinander treffenden Kanten die Form einer runden Kurve.
Gilt für

Modell

Objekt
Formularmodell
corner
Beispiele
JavaScript
TextField1.border.corner.join = "round";
FormCalc
TextField1.border.corner.join = "round"


keyAgreement

Gibt eine akzeptable Schlüsselverwendungserweiterung an, die im Unterschriftszertifikat vorhanden sein muss.
Syntax
Reference_Syntax.keyAgreement = "Yes | No | empty_string"
Werte

Typ

Werte
Zeichenfolge
•
Yes (Standardwert)
Der Wert muss im Zertifikat eingestellt sein, damit er akzeptabel ist.
•
No
Der Wert muss nicht im Zertifikat eingestellt sein, damit er akzeptabel ist.
•
""
Ist kein Wert angegeben oder ist eine leere Zeichenfolge angegeben, wird das Attribut des Zertifikats ignoriert.
Gilt für

Modell

Objekt
Formularmodell
keyUsage


keyCertSign

Gibt eine akzeptable Schlüsselverwendungserweiterung an, die im Unterschriftszertifikat vorhanden sein muss.
Syntax
Reference_Syntax.keyCertSign = "Yes | No | empty_string"
Werte

Typ

Werte
Zeichenfolge
•
Yes (Standardwert)
Der Wert muss im Zertifikat eingestellt sein, damit er akzeptabel ist.
•
No
Der Wert muss nicht im Zertifikat eingestellt sein, damit er akzeptabel ist.
•
""
Ist kein Wert angegeben oder ist eine leere Zeichenfolge angegeben, wird das Attribut des Zertifikats ignoriert.
Gilt für

Modell

Objekt
Formularmodell
keyUsage


keyDown

Stellt fest, ob ein Benutzer die Auswahl durch Drücken einer Pfeiltaste trifft. Diese Eigenschaft ist nur für Listenfelder und Dropdown-Listen verfügbar.
Syntax
Reference_Syntax.keyDown = "True | False"
Werte

Typ

Werte
Zeichenfolge
      •
      True (Standardwert)
Die Auswahl wurde mit der Pfeiltaste vorgenommen.
      •
      False
Die Auswahl wurde nicht mit der Pfeiltaste vorgenommen.
Gilt für

Modell

Objekt
Ereignismodell
eventPseudoModel
Beispiele
JavaScript
xfa.event.keyDown;
FormCalc
xfa.event.keyDown


keyEncipherment

Gibt eine akzeptable Schlüsselverwendungserweiterung an, die im Unterschriftszertifikat vorhanden sein muss.
Syntax
Reference_Syntax.keyEnciphement = "Yes | No | empty_string"
Werte

Typ

Werte
Zeichenfolge
•
Yes (Standardwert)
Der Wert muss im Zertifikat eingestellt sein, damit er akzeptabel ist.
•
No
Der Wert muss nicht im Zertifikat eingestellt sein, damit er akzeptabel ist.
•
""
Ist kein Wert angegeben oder ist eine leere Zeichenfolge angegeben, wird das Attribut des Zertifikats ignoriert.
Gilt für

Modell

Objekt
Formularmodell
keyUsage


labelRef

Löst einen Datenwert für alle durch das ref-Objekt angegebenen Daten-Nodes in der Gruppe auf.
Mit den Datenwerten werden anschließend die Beschriftungselemente, wie z. B. <items save='0'>, gefüllt.
Die labelRef-Eigenschaft ist ein relativer Ausdruck der Referenz-Syntax.
Die labelRef-Eigenschaft ist optional. Möglicherweise möchten Sie eine Liste definieren, für die nur eine Gruppe von Werten ohne Beschriftung verwendet wird. In diesem Fall verwendet das wiedergegebene Objekt Beschriftungen, bei denen als Standardwert der aktuelle Wert verwendet wird.
Syntax
Reference_Syntax.labelRef = "string"
Werte

Typ

Werte
Zeichenfolge
Eine Zeichenfolge, die einen Datenwert für jede Daten-Node im Satz darstellt.
Gilt für

Modell

Objekt
Formularmodell
bindItems


language

Gibt die Sprache der ausgeführten Host-Anwendung zurück.
Syntax
Reference_Syntax.language
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die das Sprachschema des Host-Computers angibt.
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.language;
FormCalc
xfa.host.language


layout

Gibt die von diesem Objekt zu verwendende Layoutstrategie an.
Syntax
Reference_Syntax.layout = "position | lr-tb | rl-tb | row | table | tb"
Werte

Typ

Werte
Zeichenfolge
      •
      position (Standardwert)
Der Inhalt des Steuerelements wird gemäß den in den content-Objekten ausgedrückten Speicherortinformationen positioniert.
      •
      lr-tb
Der Inhalt des Objekts fließt von links nach rechts und von oben nach unten.
      •
      rl-tb
Für die zukünftige Verwendung reserviert. Der Inhalt des Objekts fließt von rechts nach links und von oben nach unten.
      •
      row
Hierbei handelt es sich um ein inneres Objekt einer Tabelle, das mindestens eine Zeile darstellt. Die in diesem Objekt enthaltenen Objekte sind Zellen der Tabelle. Deren height- und width-Eigenschaften werden (sofern vorhanden) ignoriert. Die Zellen werden von rechts nach links angeordnet und jeweils an die Höhe der Zeile und die Breite einer oder mehrerer benachbarter Spalten angepasst.
      •
      table
Hierbei handelt es sich um das äußere Objekt einer Tabelle. Bei allen zugehörigen untergeordneten Teilformularen oder Ausschlussgruppen muss für die entsprechende layout-Eigenschaft „row“ festgelegt werden. Die Zeilen der Tabelle werden von oben nach unten angeordnet.
      •
      tb
Der Inhalt des Objekts fließt von oben nach unten.
Gilt für

Modell

Objekt
Formularmodell
exclGroup
subform
Beispiele
JavaScript
Subform1.layout = "tb";
FormCalc
Subform1.layout = "tb"


leadDigits

Gibt die maximale Anzahl der Stellen vor dem Dezimalzeichen zur Erfassung und Speicherung an.
Syntax
Reference_Syntax.leadDigits = "0 | integer"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
      •
      Eine gültige Zeichenfolge, die einen beliebigen Ganzzahlwert darstellt.
Gilt für

Modell

Objekt
Formularmodell
decimal
Beispiele
Für diese Beispiele sollte für den numerischen Felddatentyp das Dezimalformat festgelegt werden.
JavaScript
NumericField1.resolveNode("value.#decimal").leadDigits = "2";
FormCalc
NumericField1.value.#decimal.leadDigits = "2"


leader

Gibt zum Platzieren im oberen Bereich eines Inhalts- oder Seitenbereichs das subform-Objekt oder das subformSet-Objekt an.
Die leader-Eigenschaft ersetzt die nicht weiter unterstützten Eigenschaften overflowLeader und bookendLeader.
Syntax
Reference_Syntax.leader = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, welche die ID oder den vollständig qualifizierten Ausdruck der Referenz-Syntax eines Teilformulars oder eines Teilformularsatzes darstellt. Der Standardwert ist eine leere Zeichenfolge.
Gilt für

Modell

Objekt
Formularmodell
bookend
breakAfter
breakBefore
overflow
Beispiele
JavaScript
Subform1.leader = "xfa.form.form1.Subform2";
FormCalc
Subform1.leader = "xfa.form.form1.Subform2"


leftInset

Gibt die Größe der linken Vertiefung an.
Syntax
Reference_Syntax.leftInset = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
margin
Beispiele
JavaScript
Subform1.margin.leftInset = "0.25in";
FormCalc
Subform1.margin.leftInset = "0.25in"


length

Gibt die Anzahl der Objekte in der Liste an.
Diese Eigenschaft ist schreibgeschützt.
Syntax
Reference_Syntax.length
Werte

Typ

Werte
Ganzzahl
Eine gültige Zeichenfolge, welche die Anzahl von Objekten darstellt.
Gilt für
treeList-Klasse
Beispiele
JavaScript
// Display the number of child nodes under root node.
xfa.host.messageBox("Number of nodes under rootNode after appending clone: " + xfa.record.nodes.length);
FormCalc
// Display the number of child nodes under root node.
xfa.host.messageBox("Number of nodes under rootNode after appending clone: " + xfa.record.nodes.length)


lineHeight

Gibt die Zeilenhöhe an, die auf den Absatzinhalt angewendet werden soll.
Wird kein oder ein leerer Wert angegeben, dann bestimmt die Schriftgröße die Zeilenhöhe.
Syntax
Reference_Syntax.lineHeight = "0pt | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0pt (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
para
Beispiele
JavaScript
TextField1.para.lineHeight = "20pt";
FormCalc
TextField1.para.lineHeight = "20pt"


lineThrough

Gibt die Aktivierung einer einzelnen oder doppelten Linie an, die durch den Text verläuft (auch als Durchstreichung bezeichnet).
Syntax
Reference_Syntax.lineThrough = "0 | 1 | 2"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
Die Schrift wird ohne eine durch den Text verlaufende Linie wiedergegeben.
      •
      1
Die Schrift wird mit einer einzelnen durch den Text verlaufenden Linie wiedergegeben.
      •
      2
Die Schrift wird mit einer doppelten durch den Text verlaufenden Linie wiedergegeben.
Gilt für

Modell

Objekt
Formularmodell
font
Beispiele
JavaScript
TextField1.font.lineThrough = "2";
FormCalc
TextField1.font.lineThrough = "2"


lineThroughPeriod

Steuert das Erscheinungsbild der Linie, die durch den Text verläuft (auch als Durchstreichung bezeichnet).
Syntax
Reference_Syntax.lineThroughPeriod = "all | word"
Werte

Typ

Werte
Zeichenfolge
      •
      all (Standardwert)
Die wiedergegebene Linie erstreckt sich über Wortumbrüche hinweg.
      •
      word
Die wiedergegebene Linie wird an den Wortumbrüchen unterbrochen.
Gilt für

Modell

Objekt
Formularmodell
font
Beispiele
JavaScript
TextField1.font.lineThroughPeriod = "word";
FormCalc
TextField1.font.lineThroughPeriod = "word"


locale

Gibt die für den Inhalt des Objekts zu verwendende Sprache und Währung sowie das zu verwendende Uhrzeit-/Datumsformat an.
Die locale-Eigenschaft wirkt sich auf die Darstellung von Daten aus, die von picture-Klauseln formatiert, geprüft oder normalisiert wurden. Wenn diese Eigenschaft fehlt oder leer ist, wird standardmäßig das Gebietsschema des übergeordneten Objekts übernommen. Wenn das äußerste Teilformular kein Gebietsschema vorgibt, wird standardmäßig das betriebssystemspezifische Gebietsschema übernommen. Wenn das Betriebssystem kein Gebietsschema bereitstellt, wird en_US verwendet.
Syntax
Reference_Syntax.locale = "ambient | locale"
Werte

Typ

Werte
Zeichenfolge
      •
      ambient (Standardwert)
Die Anwendung verwendet ihr spezifisches Gebietsschema.
      •
      Ein gültiger Name für ein Gebietsschema, z. B. en_US. Eine vollständige Liste mit gültigen Werten für Gebietsschemata finden Sie in den Spezifikationen IETF RFC 1766 und ISO 639/ISO 3166.
Gilt für

Modell

Objekt
Formularmodell
draw
field
subform
Beispiele
JavaScript
TextField1.locale = "en_US";
FormCalc
TextField1.locale = "en_US"


lockType

Gibt den Typ der Sperrfunktion an, die für die Datenquelle verwendet werden soll.
Syntax
Reference_Syntax.lockType = "unspecified | readOnly | pessimistic | optimistic | batchOptimistic"
Werte

Typ

Werte
Zeichenfolge
      •
      unspecified (Standardwert)
Gibt keinen Sperrtyp an.
      •
      readOnly
Gibt schreibgeschützte Datensätze an. Daten können nicht geändert werden.
      •
      pessimistic
Die Datensätze werden in der Datenquelle sofort nach dem Bearbeiten gesperrt.
      •
      optimistic
Die Datensätze werden nur gesperrt, wenn eine vom Benutzer initiierte Aktualisierung durchgeführt wird.
      •
      batchOptimistic
Gibt optimistische Batch-Aktualisierungen an. Erforderlich für den Batch-Aktualisierungsmodus.
Gilt für

Modell

Objekt
sourceSet-Modell
recordSet
Beispiele
In diesen Beispielen stellt Titles den Namen der Datenverbindung dar.
JavaScript
xfa.sourceSet.Titles.nodes.item(1).query.recordSet.lockType = "optimistic";
FormCalc
xfa.sourceSet.Titles.nodes.item(1).query.recordSet.lockType = "optimistic"


long

Gibt die Länge der langen Kante des Mediums an. Die durch die long-Eigenschaft angegebene Länge muss größer sein als die durch die short-Eigenschaft angegebene Länge.
Syntax
Reference_Syntax.long = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
medium
Beispiele
JavaScript
xfa.form.form1.pageSet.Page1.medium.long = "4in";
FormCalc
xfa.form.form1.pageSet.Page1.medium.long = "4in"


mandatory

Gibt den nullTest-Wert für das Feld an.
Syntax
Reference_Syntax.mandatory = "string"
Werte

Typ

Werte
Zeichenfolge
Eine Zeichenfolge, die den Null-Test-Wert darstellt.
Gilt für

Modell

Objekt
Formularmodell
exclGroup
field
Beispiele
JavaScript
Textfield1.mandatory = "error";
FormCalc
TextField1.mandatory = "error"


mandatoryMessage

Gibt die obligatorische Meldungszeichenfolge für dieses Feld an.
Syntax
Reference_Syntax.mandatoryMessage = "string"
Werte

Typ

Werte
Zeichenfolge
Eine Zeichenfolge, welche die obligatorische Meldung darstellt.
Gilt für

Modell

Objekt
Formularmodell
exclGroup
field
Beispiele
JavaScript
Textfield1.mandatoryMessage = "This field is required.";
FormCalc
TextField1.mandatoryMessage = "This field is required."


marginLeft

Gibt an, wie groß der linke Einzug des Absatzes sein soll.
Syntax
Reference_Syntax.marginLeft = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
para
Beispiele
JavaScript
TextField1.para.marginLeft = "0.5in";
FormCalc
TextField1.para.marginLeft = "0.5in"


marginRight

Gibt an, wie groß der rechte Einzug des Absatzes sein soll.
Syntax
Reference_Syntax.marginRight = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
para
Beispiele
JavaScript
TextField1.para.marginRight = "0.5in";
FormCalc
TextField1.para.marginRight = "0.5in"


mark

Gibt die beim Ausfüllen eines Kontrollkästchenobjekts zu verwendende Form an.
Syntax
Reference_Syntax.mark = "default | check | circle | cross | diamond | square | star"
Werte

Typ

Werte
Zeichenfolge
      •
      default (Standardwert)
Der Standardstil hängt von der Form des Kontrollkästchenobjekts ab. Ein ausgefülltes Rechteck bei rechteckigen Kontrollkästchen und ein ausgefüllter Kreis bei runden Kontrollkästchen. Die neuen Kontrollkästchenstile sind Schrift-basierte Symbole.
      •
      check
      •
      circle
      •
      cross
      •
      diamond
      •
      square
      •
      star
Gilt für

Modell

Objekt
Formularmodell
checkButton
Beispiele
JavaScript
CheckBox1.resolveNode("ui.#checkButton").mark = "diamond";
FormCalc
CheckBox1.ui.#checkButton.mark = "diamond"


match

Steuert die Rolle, die das Einschließen eines Objekts in einer Datenbindungsoperation (Zusammenführungsoperation) spielt.
Syntax
Reference_Syntax.mark = "once | none | global | dataref"
Werte

Typ

Werte
Zeichenfolge
      •
      once (Standardwert)
Die Bindung der Node, die das umschließende Objekt darstellt, mit einer Node im Datenmodell erfolgt gemäß den Standard-Abgleichungsregeln.
      •
      none
Die Node, die das umschließende Objekt darstellt, ist temporär. Sie wird mit keiner der Nodes im Datenmodell gebunden.
      •
      global
Das Container-Feld ist global. Wenn die normalen Abgleichungsregeln keine Übereinstimmung liefern, sucht der Datenbindungsprozess außerhalb des aktuellen Datensatzes nach an das Feld zu bindenden Daten.
      •
      dataRef
Das Container-Feld wird an die Node im Datenmodell gebunden, die von der zugehörigen ref-Eigenschaft angegeben wird.
Gilt für

Modell

Objekt
Formularmodell
bind
sourceSet-Modell
bind
Beispiele
Sie müssen die Eigenschaft „global“ vor der Zusammenführung für das Feld festlegen.
JavaScript
TextField1.bind.match = "global";
FormCalc
TextField1.bind.match = "global"


max

Gibt die maximale Anzahl Exemplare für den einschließenden Container oder -1 an, um für Vorkommnisse keine obere Begrenzung festzulegen.
Der Standardwert der max-Eigenschaft ist der Wert der min-Eigenschaft. Ist keine min-Eigenschaft vorhanden, ist der Standardwert 1.
Syntax
Reference_Syntax.max = "1 | -1 | integer"
Werte

Typ

Werte
Zeichenfolge
      •
      1 (Standardwert)
      •
      -1
Keine obere Begrenzung.
      •
      Jede gültige Ganzzahl.
Gilt für

Modell

Objekt
Formularmodell
instanceManager
occur
sourceSet-Modell
recordSet
Beispiele
JavaScript
Subform1.occur.max = "3";
FormCalc
Subform1.occur.max = "3"


maxChars

Gibt die maximale Anzahl Zeichen an, die dieser Textwert umfassen kann.
Syntax
Reference_Syntax.maxChars = "0 | integer"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
      •
      Jeder gültige Ganzzahlwert.
Wenn Sie für diese Eigenschaft entweder gar keinen Wert oder eine leere Zeichenfolge angeben, gibt es keine Vorgabe für die maximale Anzahl der Zeichen.


maxH

Gibt die maximale Höhe für Layoutzwecke an.
Wenn Sie keinen Wert für diese Eigenschaft angeben, dann besteht keine Obergrenze. Wenn Sie für die h-Eigenschaft einen Wert angeben, kann der Container nicht in vertikaler Richtung vergrößert werden und diese Eigenschaft wird ignoriert.
Syntax
Reference_Syntax.maxH = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Beispiele
JavaScript
TextField1.maxH = "3in";
FormCalc
TextField1.maxH = "3in"


maxLength

Gibt die maximal zulässige Länge des Inhalts (einschließlich) oder -1 an, um festzulegen, dass keine maximale Länge angewendet wird.
Die Interpretation dieser Eigenschaft wird durch den Inhaltstyp bestimmt. In diesem Fall gibt diese Eigenschaft die maximal zulässige Länge des Inhalts (einschließlich) in Zeichen an. Wenn der Inhaltstyp beispielsweise text/plain ist, stellt diese Eigenschaft die maximale Anzahl an Zeichen (einschließlich) für den Nur-Text-Inhalt dar. Wenn der Inhaltstyp text/html ist, stellt diese Eigenschaft die maximale Anzahl an Zeichen (einschließlich) für den Inhalt ohne Markierung und bedeutungslose Leerzeichen dar.
Syntax
Reference_Syntax.maxLength = "-1 | integer"
Werte

Typ

Werte
Zeichenfolge
      •
      -1 (Standardwert)
      •
      Jeder gültige Ganzzahlwert.
Gilt für

Modell

Objekt
Formularmodell
exData


maxW

Gibt die maximale Breite für Layoutzwecke an.
Wenn Sie keinen Wert für diese Eigenschaft angeben, gibt es keine Vorgabe für die maximale Breite. Wenn Sie für die w-Eigenschaft einen Wert angeben, kann der Container nicht in horizontaler Richtung vergrößert werden und diese Eigenschaft wird ignoriert.
Syntax
Reference_Syntax.maxW = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
draw
exclGroup
field
subform
Beispiele
JavaScript
TextField1.maxW = "3in";
FormCalc
TextField1.maxW = "3in"


min

Gibt die Mindestanzahl der Exemplare für den einschließenden Container an.
Syntax
Reference_Syntax.min = "1 | integer"
Werte

Typ

Werte
Zeichenfolge
      •
      1 (Standardwert)
      •
      Jede gültige Ganzzahl.
Gilt für

Modell

Objekt
Formularmodell
instanceManager
occur
Beispiele
JavaScript
Subform1.occur.min = "0";
FormCalc
Subform1.occur.min = "0"


minH

Gibt die minimale Höhe für Layoutzwecke an.
Wenn Sie für die h-Eigenschaft einen Wert angeben, kann der Container nicht in vertikaler Richtung vergrößert werden und diese Eigenschaft wird ignoriert.
Syntax
Reference_Syntax.minH = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
draw
exclGroup
field
subform
Beispiele
JavaScript
TextField1.minH = "0.5in";
FormCalc
TextField1.minH = "0.5in"


minW

Gibt die minimale Breite für Layoutzwecke an.
Wenn Sie für die w-Eigenschaft einen Wert angeben, kann der Container nicht in horizontaler Richtung vergrößert werden und diese Eigenschaft wird ignoriert.
Syntax
Reference_Syntax.minW = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Beispiele
JavaScript
TextField1.minW = "0.5in";
FormCalc
TextField1.minW = "0.5in"


model

Gibt das Modell für das aktuelle Objekt an.
Diese Eigenschaft ist schreibgeschützt.
Syntax
Reference_Syntax.model
Werte

Typ

Werte
Objekt
Das Stammobjekt für das jeweilige XML-Formularobjektmodell, wie z. B. connectionSet oder dataModel.
Gilt für
node-Klasse
Beispiele
JavaScript
xfa.model.name;
FormCalc
xfa.model.name


modifier

Stellt fest, ob bei Ausführung eines bestimmten Ereignisses die Zusatztaste (beispielsweise STRG unter Windows) gedrückt wird.
Syntax
Reference_Syntax.modifier
Werte

Typ

Werte
Boolescher Wert
      •
      True (Standardwert)
Die Zusatztaste wird während der Ereignisausführung gedrückt gehalten.
      •
      False
Die Zusatztaste wird während der Ereignisausführung nicht gedrückt gehalten.
Gilt für

Modell

Objekt
Ereignismodell
eventPseudoModel
Beispiele
JavaScript
xfa.event.modifier;
FormCalc
xfa.event.modifier


moduleHeight

Bestimmt die Höhe einer Gruppe von Balken, mit denen ein Zeichen von bereitgestelltem Text kodiert wird.
Der zulässige Höhenbereich ist je nach Barcodemuster unterschiedlich. Der Formularentwurf darf keine Höhe außerhalb des zulässigen Bereichs angeben.
Syntax
Reference_Syntax.moduleHeight = "5mm | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      5mm (Standardwert für 2D-Barcodes)
      •
      Jede gültige Maßeinheit.
Wenn diese Eigenschaft nicht angegeben ist, hängt das Standardverhalten vom Typ des Barcodes ab. Bei eindimensionalen Barcodes wird die Höhe an das einschließende Feld, beschränkt durch den zulässigen Höhenbereich, angepasst. Der Standardwert von 2D-Barcodes ist eine Modulhöhe von 5mm.
Gilt für

Modell

Objekt
Formularmodell
barcode
Beispiele
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").moduleHeight = "5mm";
FormCalc
Code11BarCode1.ui.#barcode.moduleHeight = "5mm"


moduleWidth

Gibt die unterschiedlichen Aspekte eines Barcodes abhängig von der Klasse der verwendeten Barcodes an.
Bei eindimensionalen Software-Barcodes legt der Parser für die Breite der schmalen Balken den Wert dieser Eigenschaft fest. Die Breite der breiten Balken wird von der der schmalen Balken abgeleitet. Der zulässige Breitenbereich ist je nach Barcodeformat unterschiedlich. Der Formularentwurf darf keinen Wert außerhalb des zulässigen Bereichs angeben. Wenn die moduleWidth-Eigenschaft angegeben ist, wird die dataLength-Eigenschaft ignoriert. Umgekehrt gibt es für die moduleWidth-Eigenschaft keinen Standardwert. Wenn also die dataLength-Eigenschaft nicht angegeben ist, muss die moduleWidth-Eigenschaft angegeben werden.
Bei 2D-Hardware-Barcodes hat die moduleWidth-Eigenschaft je nach Drucker und Barcode entweder keine Auswirkung oder dieselbe Auswirkung wie bei Software-Barcodes. Der zulässige Bereich für den Wert ist je nach Drucker und Barcode unterschiedlich.
Bei 2D-Barcodes bestimmt der Wert dieser Eigenschaft die Modulbreite. Bei einem Modul handelt es sich um eine Gruppe von Balken, mit denen ein Symbol kodiert wird. In der Regel entspricht ein Symbol einem Zeichen bereitgestellter Daten. Der zulässige Breitenbereich ist je nach Barcodeformat unterschiedlich. Der Formularentwurf darf keinen Wert außerhalb des zulässigen Bereichs angeben.
Syntax
Reference_Syntax.moduleWidth = "0.25mm | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0.25mm (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
barcode
Beispiele
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").moduleWidth = "25mm";
FormCalc
Code11BarCode1.ui.#barcode.moduleHeight = "25mm"


multiLine

Gibt an, ob der Text mehrzeilig sein kann.
Die multiLine -Eigenschaft ist bei Clients wie HTML-Browsern nützlich, die über zwei Arten von Texteditierschnittstellen verfügen.
Syntax
Reference_Syntax.multiLine = "1 | 0"
Werte

Typ

Werte
Zeichenfolge
      •
      1 (Standardwert)
Der Text kann mehrzeilig sein.
      •
      0
Der Text ist auf eine Zeile begrenzt.
Beispiele
JavaScript
TextField1.resolveNode("ui.#textEdit").multiLine = "0";
FormCalc
TextField1.ui.#textEdit.multiLine = "0"


name

Gibt einen Bezeichner an, mit dem dieses Objekt oder Ereignis in Skriptausdrücken angegeben werden kann.
Diese Eigenschaft gibt z. B. den Namen der Host-Anwendung an, und gibt in einem interaktiven PDF-Formular Acrobat zurück.
Syntax
Reference_Syntax.name
Werte

Typ

Werte
Zeichenfolge
Eine bis zu 255 Zeichen lange Zeichenfolge.
Gilt für
tree-Klasse
Beispiele
JavaScript
xfa.host.name;
FormCalc
xfa.host.name


newContentType

Gibt den Inhaltstyp der newText-Eigenschaft an.
Ist beispielsweise newContentType='text/html', dann enthält „newText“ ein XHTML-Fragment.
Syntax
Reference_Syntax.newContentType = "allowRichText | plainTextOnly"
Werte

Typ

Werte
Zeichenfolge
      •
      allowRichText (Standardwert)
Das Feld unterstützt das Rich-Text-Format.
      •
      plainTextOnly
Das Feld unterstützt das Rich-Text-Format nicht. Selbst wenn Markierungen in den Daten vorhanden sind, sollten sie durchgereicht statt interpretiert werden. Es gibt jedoch keine Garantie dafür, dass die Markierungen bei der weiteren Verarbeitung berücksichtigt werden.
Gilt für

Modell

Objekt
Ereignismodell
eventPseudoModel
Beispiele
JavaScript
xfa.event.newContentType = "plainTextOnly";
FormCalc
xfa.event.newContentType = "plainTextOnly"


newText

Gibt den Inhalt des Feldes nach einer Änderung aufgrund von Benutzeraktionen an.
Syntax
Reference_Syntax.newtext = "string"
Werte

Typ

Werte
Zeichenfolge
Eine bis zu 255 Zeichen lange Zeichenfolge.
Gilt für

Modell

Objekt
Ereignismodell
eventPseudoModel
Beispiele
JavaScript
TextField2.rawValue = xfa.event.newTextl;
FormCalc
TextField2 = xfa.event.newText


next

Gibt die Einschränkungen für die gemeinsame Wiedergabe eines Teilformulars mit dem folgenden Teilformular in einem Inhaltsbereich oder auf einer Seite an.
Syntax
Reference_Syntax.next = "none | contentArea | pageArea"
Werte

Typ

Werte
Zeichenfolge
      •
      none (Standardwert)
Die Entscheidung, ob ein Teilformular und das folgende Teilformular in demselben Inhaltsbereich oder auf derselben Seite wiedergegeben werden, wird auf die Verarbeitungsanwendung übertragen. Es werden keine speziellen Einschränkungen erzwungen.
      •
      contentArea
Das Teilformular soll in demselben Inhaltsbereich wie das folgende Teilformular wiedergegeben werden.
      •
      pageArea
Das Teilformular soll auf derselben Seite wie das folgende Teilformular wiedergegeben werden.
Gilt für

Modell

Objekt
Formularmodell
keep
Beispiele
JavaScript
Subform1.keep.next = "contentArea";
FormCalc
Subform1.keep.next = "contentArea"


nodes

Gibt eine Liste aller untergeordneten Objekte des aktuellen Objekts zurück.
Diese Eigenschaft ist schreibgeschützt.
Syntax
Reference_Syntax.nodes
Werte

Typ

Werte
Objekt
Eine Liste mit Objekten des XML-Formularobjektmodells.
Gilt für
tree-Klasse
Beispiele
JavaScript
Subform1.nodes; // Single line example

// This example displays the names of the children of Subform1
var oNodes = this.nodes;
var nodesLength = oNodes.length;

for (var i = 0; i < nodesLength; i++) {
    xfa.host.messageBox(oNodes.item(i).name)
}
FormCalc
Subform1.nodes // Single line example

// This example displays the names of the children of Subform1
var oNodes = Subform1.nodes
var nodesLength = oNodes.length;

for (var i = 0; i < nodesLength; i++) {
    xfa.host.messageBox(oNodes.item(i).name)
}


nonRepudiation

Gibt eine akzeptable Schlüsselverwendungserweiterung an, die im Unterschriftszertifikat vorhanden sein muss.
Syntax
Reference_Syntax.nonRepudiation = "Yes | No | empty_string"
Werte

Typ

Werte
Zeichenfolge
•
Yes (Standardwert)
Der Wert muss im Zertifikat eingestellt sein, damit er akzeptabel ist.
•
No
Der Wert muss nicht im Zertifikat eingestellt sein, damit er akzeptabel ist.
•
""
Ist kein Wert angegeben oder ist eine leere Zeichenfolge angegeben, wird das Attribut des Zertifikats ignoriert.
Gilt für

Modell

Objekt
Formularmodell
keyUsage


ns

Gibt den Namespace für das Objekt zurück.
Wenn es sich bei dem Objekt um den Stamm eines Modells handelt, gibt diese Eigenschaft den Namespace für das Modell zurück.
Diese Eigenschaft ist schreibgeschützt.
Syntax
Reference_Syntax.ns
Werte

Typ

Werte
Objekt
Eine gültige Zeichenfolge, die den Namespace des aktuellen Objekts oder den Namespace des aktuellen Modells darstellt, wenn es sich bei dem derzeit ausgewählten Objekt um das Stammobjekt handelt.
Gilt für
node-Klasse


nullTest

Bestimmt, ob ein Feld in einem Formular obligatorisch ist, oder ob es leer gelassen werden kann.
Die nullTest-Eigenschaft kann für Überprüfungen verwendet werden.
Syntax
Reference_Syntax.nullTest = "disabled | error | warning"
Werte

Typ

Werte
Zeichenfolge
      •
      disabled (Standardwert)
Diesen Test nicht ausführen (Standardwert). Das Formularobjekt darf den Wert Null aufweisen. Das Feld kann ohne Wert bleiben. Dies hat keine negativen Auswirkungen auf die Gültigkeit des Formulars. Dieser Wert deaktiviert die Überprüfung.
      •
      error
Eine Fehlermeldung ausgeben und die Annahme eines leeren Feldes verweigern. Das Formularobjekt muss einen Wert ungleich Null aufweisen.
      •
      warning
Wenn das Feld leer ist, wird eine Warnmeldung ausgegeben. Der Benutzer darf jedoch zum nächsten Feld wechseln. Die Meldung muss den Benutzer darüber informieren, dass das Formularobjekt einen Wert aufweisen sollte. Es müssen zwei Möglichkeiten angeboten werden:
      •
      dismiss: Der Benutzer nimmt die Empfehlung zur Kenntnis, kehrt zum Formular zurück und erfüllt die Einschränkung.
      •
      override: Der Benutzer nimmt die Empfehlung zur Kenntnis, entscheidet jedoch, gegen diese Einschränkung zu verstoßen.
Gilt für

Modell

Objekt
Formularmodell
validate
Beispiele
JavaScript
TextField1.validate.nullTest = "error";
FormCalc
TextField1.validate.nullTest = "error"


numbered

Gibt an, ob der Seitenbereich als nummerierter Seitenbereich betrachtet wird.
Nummerierte Seitenbereiche tragen zur normalen Erhöhung der Seitenzahlen bei, während nicht nummerierte Seiten die Seitenzahlen nicht verändern.
Syntax
Reference_Syntax.numbered = "auto | none"
Werte

Typ

Werte
Zeichenfolge
      •
      auto (Standardwert)
Der Seitenbereich stellt einen nummerierten Seitenbereich dar. Daher trägt die Instanziierung des Seitenbereichs zur Erhöhung der aktuellen Seitenbereichszahl bei.
      •
      none
Der Seitenbereich trägt nicht zur Erhöhung der aktuellen Seitenbereichszahl bei.
Gilt für

Modell

Objekt
Formularmodell
pageArea
Beispiele
JavaScript
xfa.form.form1.pageSet.Page1.numbered = "none";
FormCalc
xfa.form.form1.pageSet.Page1.numbered = "none"


numberOfCells

Gibt die Anzahl der Zellen an, die für ein Kombinationsfeld gezeichnet wird. Diese ist von der Anzahl der Zeichen im Wert des Feldes nicht betroffen.
Syntax
Reference_Syntax.numberOfCells = "0 | integer"
Werte

Typ

Werte
Ganzzahl
      •
      0 (Standardwert)
Für das Kombinationsfeld wird eine Zelle gezeichnet. Wenn die maxChars-Eigenschaft eingestellt ist, entspricht die Anzahl der Zellen der Wert von maxChars.
      •
      integer
Eine gültige Ganzzahl, die die Gesamtanzahl der für das Kombinationsfeld gezeichneten Zellen darstellt.
Gilt für

Modell

Objekt
Formularmodell
comb
Beispiele
JavaScript
TextField1.resolveNode("ui.#textEdit.comb").numberOfCells = "6";
FormCalc
TextField1.ui.#textEdit.comb.numberOfCells = "6"


numPages

Gibt die Anzahl der Seiten im aktuellen Dokument zurück.
Syntax
Reference_Syntax.numPages
Werte

Typ

Werte
Ganzzahl
Eine gültige Ganzzahl, welche die Gesamtzahl der Seiten angibt.
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.numPages;
FormCalc
xfa.host.numPages


oddOrEven

Gibt an, ob die Seite bei der Paginierung in einem Seitensatz gerade oder ungerade ist.
Syntax
Reference_Syntax.oddOrEven = "any | odd | even"
Werte

Typ

Werte
Zeichenfolge
      •
      any (Standardwert)
Sucht eine beliebige Seite in einem Dokument.
      •
      odd
Sucht die erste Seite in einem Dokument und alle weiteren geraden Seiten danach, unabhängig von der Seitennummerierung.
      •
      even
Sucht die zweite Seite in einem Dokument und alle weiteren ungeraden Seiten danach, unabhängig von der Seitennummerierung.
Gilt für

Modell

Objekt
Formularmodell
pageArea
Beispiele
Der Ausdruck der Referenz-Syntax ist variabel, je nachdem, von welchem Objekt er aufgerufen wird.
JavaScript
xfa.form.form1.pageSet.Page1.oddOrEven = "even";
FormCalc
xfa.form.form1.pageSet.Page1.oddOrEven = "even"


oneOfChild

Ruft das untergeordnete Objekt ab oder legt es fest, wenn ein übergeordnetes Objekt nur ein bestimmtes untergeordnetes Objekt haben kann.
Syntax
Reference_Syntax.oneOfChild = "object"
Werte

Typ

Werte
Objekt
Das untergeordnete Objekt.
Gilt für
node-Klasse
Beispiele
JavaScript
TextField1.value.oneOfChild;
FormCalc
TextField1.value.oneOfChild


open

Legt fest, wann die Auswahlliste von interaktiven Anwendungen angezeigt wird.
Syntax
Reference_Syntax.open = "userControl | onEntry | always | multiSelect"
Werte

Typ

Werte
Zeichenfolge
      •
      userControl (Standardwert)
Die Liste wird geöffnet, wenn der Benutzer auf eine Schaltfläche klickt oder eine andere entsprechende Aktion ausführt Die Liste wird ausgeblendet, wenn der Cursor die Liste verlässt oder ein anderes entsprechendes Ereignis auf der Benutzeroberfläche auftritt.
      •
      onEntry
Die Liste wird beim Eintritt des Cursors in das Feld geöffnet. Beim Verlassen des Feldes wird sie wieder ausgeblendet.
      •
      always
Die Liste wird immer angezeigt, wenn das Feld sichtbar ist.
      •
      multiSelect
Der Benutzer kann mehrere Einträge in der Liste durch Drücken der Umschalttaste und gleichzeitiges Klicken auf die Einträge auswählen. Die Auswahlliste wird angezeigt, wenn das Feld sichtbar ist.
Gilt für

Modell

Objekt
Formularmodell
choiceList
Beispiele
JavaScript
DropDownList1.resolveNode("ui.#choiceList").open = "always";
FormCalc
DropDownList1.ui.#choiceList.open = "always"


operation

Bestimmt, wann eine Verknüpfung verwendet wurde.
Syntax
Reference_Syntax.operation = "next | back | down | first | left | right | up"
Werte

Typ

Werte
Zeichenfolge
      •
      next (Standardwert)
Wird verwendet, wenn der Benutzer die Tabulatortaste drückt oder das letzte Zeichen in ein Feld mit fester Breite eingibt. Dieselbe Kette mit „next“-Verknüpfungen wird beim Lesen des Formulars auch von der Bildschirmlesehilfe durchsucht. Der Standardwert ist die Richtung von links nach rechts und von oben nach unten.
Zur Unterstützung der Bildschirmlesehilfe kann die Kette mit „next“-Verknüpfungen Textbausteinobjekte enthalten. Objekte dieser Art können keinen Eingabefokus akzeptieren. Daher wird beim Verschieben des Fokus auf das nächste Formularobjekt die Tabulatortaste so lange gedrückt, bis ein Objekt erreicht wird, das den Eingabefokus akzeptiert. Der Formularverfasser muss sicherstellen, dass der Formularentwurf keine Endlosschleife aufweist.
      •
      back
Wird verwendet, wenn der Benutzer die Tastenkombination aus Umschalt- und Tabulatortaste drückt. Der Standardwert ist die Richtung von rechts nach links und von unten nach oben.
      •
      down
Ziel, wenn der Benutzer die Nach-unten-Taste drückt. Der Standardwert ist die Richtung von oben nach unten.
      •
      first
Diese Eigenschaft wird nur verwendet, wenn es sich beim Container um ein Teilformular oder einen Teilformularsatz handelt. Die Verknüpfung verweist auf das Objekt, das den Fokus erhält, wenn der Container eingegeben wird. Genau genommen übergibt der Container den Fokus mit Hilfe dieser Verknüpfung. Der Standardwert ist der erste Container, der diesem Container untergeordnet ist, in der Reihenfolge von oben nach unten und von links nach rechts.
      •
      left
Ziel, wenn der Benutzer die Nach-links-Taste drückt. Der Standardwert ist die Richtung von rechts nach links.
      •
      right
Ziel, wenn der Benutzer die Nach-rechts-Taste drückt. Der Standardwert ist die Richtung von links nach rechts.
      •
      up
Ziel, wenn der Benutzer die Nach-oben-Taste drückt. Der Standardwert ist die Richtung von unten nach oben.
Gilt für

Modell

Objekt
connectionSet-Modell
wsdlConnection
Formularmodell


orientation

Gibt die Ausrichtung des Mediums an.
Syntax
Reference_Syntax.orientation = "portrait | landscape"
Werte

Typ

Werte
Zeichenfolge
      •
      portrait (Standardwert)
Die Ausrichtung des Mediums verschiebt die kurze Kante nach oben.
      •
      landscape
Die Ausrichtung des Mediums verschiebt die lange Kante nach oben.
Gilt für

Modell

Objekt
Formularmodell
medium
Beispiele
JavaScript
xfa.form.form1.pageSet.Page1.medium.orientation = "landscape";
FormCalc
xfa.form.form1.pageSet.Page1.medium.orientation = "landscape"


output

Gibt die Ausgabemeldung an, die mit einem bestimmten WSDL-Verbindungsvorgang verknüpft ist.
Syntax
Reference_Syntax.output = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, welche die Ausgabemeldung darstellt.
Gilt für

Modell

Objekt
connectionSet-Modell
operation
Beispiele
JavaScript
xfa.connectionSet.DataConnection.operation.output = "Connection successful.";
FormCalc
xfa.connectionSet.DataConnection.operation.output = "Connection successful."


overflowLeader

Gibt das Teilformular an, das oben im Inhaltsbereich oder auf der Seite platziert werden soll, wenn es als Ergebnis eines Überlaufs eingegeben wird.
Syntax
Reference_Syntax.overflowLeader = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die den Namen oder vollständig qualifizierten Ausdruck der Referenz-Syntax eines Teilformulars darstellt.
Gilt für

Modell

Objekt
Formularmodell
break
Beispiele
JavaScript
Subform1.break.overflowLeader = "Subform2";
FormCalc
Subform1.break.overflowLeader = "Subform2"


overflowTarget

Gibt den eindeutigen Inhaltsbereich an, der als Übergangsziel dient, wenn der aktuelle Inhalts- oder Seitenbereich überläuft.
Syntax
Reference_Syntax.overflowTarget = "string"
Werte

Typ

Werte
Zeichenfolge
Der Name oder vollständig qualifizierte Ausdruck der Referenz-Syntax eines Inhaltsbereichs.
Gilt für

Modell

Objekt
Formularmodell
break
Beispiele
JavaScript
Subform1.break.overflowTarget = "xfa.form.form1.pageSet.Page1.Content_Main";
FormCalc
Subform1.break.overflowTarget = "xfa.form.form1.pageSet.Page1.Content_Main"


overflowTrailer

Gibt das Teilformular an, das beim Überlaufen unten im Inhaltsbereich oder unten auf der Seite platziert werden soll.
Der vertikale Bereich, der für den Überlauffußbereich benötigt wird, muss reserviert werden.
Syntax
Reference_Syntax.overflowTrailer = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die den Namen oder vollständig qualifizierten Ausdruck der Referenz-Syntax eines Teilformulars darstellt.
Gilt für

Modell

Objekt
Formularmodell
break
Beispiele
JavaScript
Subform1.break.overflowTrailer = "Subform2";
FormCalc
Subform1.break.overflowTrailer = "Subform2"


overline

Gibt die Art der Überstreichung und ihre Aktivierung an.
Syntax
Reference_Syntax.overline = "0 | 1 | 2"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
Die Schrift wird ohne Überstreichung wiedergegeben.
      •
      1
Die Schrift wird mit einer einfachen Überstreichung wiedergegeben.
      •
      2
Die Schrift wird mit einer doppelten Überstreichung wiedergegeben.
Gilt für

Modell

Objekt
Formularmodell
font
Beispiele
JavaScript
TextField1.font.overline = "0";
FormCalc
TextField1.font.overline = "0"


overlinePeriod

Bestimmt das Erscheinungsbild der Überstreichung.
Syntax
Reference_Syntax.overlinePeriod = "all | word"
Werte

Typ

Werte
Zeichenfolge
      •
      all (Standardwert)
Die wiedergegebene Zeile erstreckt sich über Wortumbrüche hinweg.
      •
      word
Die wiedergegebene Zeile wird bei Wortumbrüchen unterbrochen.
Gilt für

Modell

Objekt
Formularmodell
font
Beispiele
JavaScript
TextField1.font.overlinePeriod = "all";
FormCalc
TextField1.font.overlinePeriod = "all"


override

Bestimmt, ob der berechnete Wert vom Benutzer in einem interaktiven Kontext überschrieben werden kann, oder ob der Wert in jedem Kontext deaktiviert ist.
Wenn kein zugehöriges calculate-Objekt vorhanden ist, hat diese Eigenschaft keine Auswirkungen, und der Benutzer kann in das Feld einen Wert eingeben.
Syntax
Reference_Syntax.override = "error | ignore | disabled | warning"
Werte

Typ

Werte
Zeichenfolge
      •
      error
Die Berechnung ist aktiviert und der Benutzer kann den berechneten Wert nicht überschreiben. Wenn der Benutzer versucht, den berechneten Wert zu überschreiben, zeigt die verarbeitende Anwendung eine Fehlermeldung an. Um Fehlermeldungen zu vermeiden, können Formularentwickler diese Felder mit Schreibschutz definieren.
Hierbei handelt es sich um den Standardwert für die Außerkraftsetzung, wenn das calculate-Objekt im Containerobjekt enthalten ist.
      •
      ignore
Der berechnete Wert wird als Standardwert bereitgestellt. Wenn der Benutzer den Wert überschreibt, lässt die verarbeitende Anwendung das Überschreiben zu, ohne dem Benutzer eine Warnmeldung anzuzeigen.
Hierbei handelt es sich um den Standardwert für die Außerkraftsetzung, wenn das calculate-Objekt nicht im Containerobjekt enthalten ist.
      •
      disabled
Die Berechnung ist deaktiviert. In einem interaktiven Kontext kann der Benutzer Daten in das Feld eingeben. Die Auswirkung dieses Überschreibungswerts ist von der Benutzeraktion unabhängig. Der disabled-Wert lässt zu, dass ein Ereignisskript ein calculate-Objekt dynamisch aktiviert oder deaktiviert.
      •
      warning
Die Berechnung ist aktiviert und der berechnete Wert wird über Benutzereingabewerte empfohlen. Wenn der Benutzer den berechneten Wert überschreibt, zeigt die verarbeitende Anwendung eine Warnmeldung an. Die Meldung informiert den Benutzer darüber, dass das Formularobjekt einen berechneten Wert verwenden muss und bietet dem Benutzer zwei Möglichkeiten an:
      •
      Dismiss gibt an, dass der Benutzer den berechneten Wert verwenden möchte.
      •
      Override gibt an, dass der Benutzer die Meldung zur Kenntnis nimmt, den berechneten Wert jedoch außer Kraft setzen möchte.
Die Anwendung gibt keine Warnungen oder Eingabeaufforderungen nach der Fokusübernahme durch dasselbe Objekt aus.
Gilt für

Modell

Objekt
Formularmodell
calculate
value
Beispiele
JavaScript
TextField1.calculate.override = "disabled";
FormCalc
TextField1.calculate.override = "disabled"


pagePosition

Gibt die Position einer Seite innerhalb eines Seitensatzes an.
Syntax
Reference_Syntax.pagePosition = "any | first | last | rest | only"
Werte

Typ

Werte
Zeichenfolge
      •
      any (Standardwert)
Sucht nach einer beliebigen Seite in einem Satz aufeinanderfolgender Seiten.
      •
      first
Sucht die erste Seite in einem Satz aufeinanderfolgender Seiten.
      •
      last
Sucht die letzte Seite in einem Satz aufeinanderfolgender Seiten.
      •
      rest
Sucht eine beliebige Seite, die weder die erste noch die letzte Seite ist, in einem Satz aufeinanderfolgender Seiten.
      •
      only
Sucht eine einzelne Seitenfolge.
Gilt für

Modell

Objekt
Formularmodell
pageArea
Beispiele
Der Ausdruck der Referenz-Syntax ist variabel, je nachdem, von welchem Objekt er aufgerufen wird.
JavaScript
xfa.form.form1.pageSet.Page1.pagePosition = "only";
FormCalc
xfa.form.form1.pageSet.Page1.pagePosition = "only"


parent

Gibt das übergeordnete Objekt des aktuellen Objekts zurück.
Diese Eigenschaft ist schreibgeschützt.
Syntax
Reference_Syntax.parent
Werte

Typ

Werte
Objekt
Ein Objekt des XML-Formularobjektmodells.
Gilt für
tree-Klasse
Beispiele
JavaScript
TextField1.parent;
FormCalc
TextField1.parent


parentSubform

Gibt das übergeordnete Teilformular (Seite) für dieses Feld an.
Syntax
Reference_Syntax.parentSubform = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die den Namen oder den vollständig qualifizierten Ausdruck der Referenz-Syntax des übergeordneten Teilformularobjekts darstellt.
Gilt für

Modell

Objekt
Formularmodell
field
Beispiele
JavaScript
TextField1.parentSubform;
FormCalc
TextField1.parentSubform


passwordChar

Gibt das Zeichen an, das im Formular für jedes Zeichen eines vom Benutzer eingegebenen Kennworts anzeigt wird.
Syntax
Reference_Syntax.passwordChar = "* | character"
Werte

Typ

Werte
Zeichenfolge
      •
      „*„ (Sternchen) (Standardwert)
      •
      Jedes zulässige Einzelzeichen.
Gilt für

Modell

Objekt
Formularmodell
passwordEdit
Beispiele
JavaScript
PasswordField1.resolveNode("ui.#passwordEdit").passwordChar = "*";
FormCalc
PasswordField1.ui.#passwordEdit.passwordChar = "*"


permissions

Gibt die Zugriffsberechtigungen an, die für ein Formular mit Verfasserunterschrift gewährt werden.
Weitere Informationen zu Verfasserunterschriften finden Sie unter signatureType.
Syntax
Reference_Syntax.permissions = "1 | 2 | 3"
Werte

Typ

Werte
Zeichenfolge
•
1
Es sind keine Änderungen am Dokument zulässig. Änderungen am Dokument machen die Unterschrift ungültig.
•
2 (Standardwert)
Zulässige Änderungen sind das Ausfüllen von Formularen, das Instanziieren von Seitenvorlagen und das Unterschreiben. Andere Änderungen machen die Unterschrift ungültig.
•
3
Zulässige Änderungen sind die von „2“ erlaubten Änderungen sowie das Erstellen, Löschen und Bearbeiten von Anmerkungen. Andere Änderungen machen die Unterschrift ungültig.
Gilt für

Modell

Objekt
Formularmodell
mdp


picture

Ein Wiedergabeelement, das die Eingabe- und Ausgabeformatierungsinformationen beschreibt.
Syntax
Reference_Syntax.picture = "string"
Werte

Typ

Werte
Zeichenfolge
Jede Zeichenfolge, die einem gültigen Bilddatenformat entspricht.
Verwandte Themen
Datums- und Uhrzeitmuster


placement

Definiert die Platzierung der Beschriftung.
Syntax
Reference_Syntax.placement = "left | right | top | bottom | inline"
Werte

Typ

Werte
Zeichenfolge
      •
      left (Standardwert)
Platziert die Beschriftung links neben dem Inhalt.
      •
      right
Platziert die Beschriftung rechts neben dem Inhalt.
      •
      top
Platziert die Beschriftung oberhalb des Inhalts.
      •
      bottom
Platziert die Beschriftung unterhalb des Inhalts.
      •
      inline
Platziert die Beschriftung auf gleicher Höhe direkt vor dem Inhalt.
Gilt für

Modell

Objekt
Formularmodell
caption
Beispiele
JavaScript
TextField1.caption.placement = "left";
FormCalc
TextField1.caption.placement = "left"


platform

Gibt die Plattform des Rechners zurück, auf dem das Skript ausgeführt wird.
Diese Eigenschaft ist schreibgeschützt.
Syntax
Reference_Syntax.platform
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die das Betriebssystem darstellt. Bei einem PDF-Formular in Acrobat gibt diese Eigenschaft beispielsweise Folgendes zurück: WIN, MAC oder UNIX.
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.platform;
FormCalc
xfa.host.platform


posture

Gibt an, ob die Schrift kursiv ist.
Syntax
Reference_Syntax.posture = "normal | italic"
Werte

Typ

Werte
Zeichenfolge
      •
      normal (Standardwert)
Die Schrift ist nicht kursiv.
      •
      italic
Die Schrift ist kursiv.
Gilt für

Modell

Objekt
Formularmodell
font
Beispiele
JavaScript
TextField1.font.posture = "italic";
FormCalc
TextField1.font.posture = "italic"


presence

Gibt an, ob ein Objekt sichtbar ist.
Syntax
Reference_Syntax.presence = "visible | invisible | hidden"
Werte

Typ

Werte
Zeichenfolge
      •
      visible (Standardwert)
Das Objekt ist sichtbar.
      •
      invisible
Das Objekt ist transparent. Das Objekt nimmt auch dann Platz ein, wenn es unsichtbar ist.
      •
      hidden
Das Objekt ist ausgeblendet. Das Objekt wird nicht im Formular angezeigt und nimmt im Formularlayout auch keinen Platz ein.
Gilt für

Modell

Objekt
Formularmodell
border
caption
corner
draw
edge
exclGroup
field
fill
items
subform
Beispiele
JavaScript
TextField1.presence = "hidden";
FormCalc
TextField1.presence = "hidden"


preserve

Gibt Einschränkungen der Absatzkontrolle zum Überlaufverhalten des Inhalts im einschließenden Container an.
Syntax
Reference_Syntax.preserve = "0 | integer | all"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
Der Inhalt wird über eine Überlaufgrenze umgebrochen.
      •
      integer
Ein Ganzzahlwert größer als Null gibt die Mindestmenge des Inhalts an, der über eine Überlaufgrenze reichen muss. Wenn beispielsweise der Ganzzahlwert 2 angegeben wird, wird eine einzelne Inhaltszeile nicht über eine Überlaufgrenze umgebrochen, sondern es werden mindestens zwei Inhaltszeilen über die Überlaufgrenze hinausreichen.
      •
      all
Die einzelnen Absätze des Inhalts müssen erhalten bleiben. Sie können daher nicht über eine Überlaufgrenze umgebrochen werden.
Gilt für

Modell

Objekt
Formularmodell
para
Beispiele
JavaScript
TextField1.para.preserve = "all";
FormCalc
TextField1.para.preserve = "all"


prevContentType

Gibt den Inhaltstyp des für die prevText-Eigenschaft angegebenen Werts an.
Beispielsweise, wenn prevContentType='text/html', prevText ein XHTML-Fragment enthält.
Syntax
Reference_Syntax.prevContentType = "allowRichText | plainTextOnly"
Werte

Typ

Werte
Zeichenfolge
      •
      allowRichText (Standardwert)
Das Feld unterstützt das Rich-Text-Format.
      •
      plainTextOnly
Das Feld unterstützt das Rich-Text-Format nicht.
Gilt für

Modell

Objekt
Ereignismodell
eventPseudoModel
Beispiele
JavaScript
xfa.event.prevContentType = "plainTextOnly";
FormCalc
xfa.event.prevContentType = "plainTextOnly"


previous

Gibt die Einschränkungen für die gemeinsame Wiedergabe eines Teilformulars mit dem vorherigen Teilformular in einem Inhaltsbereich oder auf einer Seite an.
Syntax
Reference_Syntax.previous = "none | contentArea | pageArea"
Werte

Typ

Werte
Zeichenfolge
      •
      none (Standardwert)
Die Entscheidung, ob ein Teilformular und das vorherige Teilformular in demselben Inhaltsbereich oder auf derselben Seite wiedergegeben werden, wird auf die Verarbeitungsanwendung übertragen. Es werden keine speziellen Einschränkungen erzwungen.
      •
      contentArea
Das Teilformular soll in demselben Inhaltsbereich wie das vorherige Teilformular wiedergegeben werden.
      •
      pageArea
Das Teilformular soll auf derselben Seite wie das vorherige Teilformular wiedergegeben werden.
Gilt für

Modell

Objekt
Formularmodell
keep
Beispiele
JavaScript
Subform1.keep.previous = "contentArea";
FormCalc
Subform1.keep.previous = "contentArea"


prevText

Gibt den Inhalt des Feldes vor einer Änderung aufgrund von Benutzeraktionen an.
Der prevText-Wert kann ähnlich wie bei einer Rückgängig-Funktion wieder aufgerufen werden.
Syntax
Reference_Syntax.prevText
Werte

Typ

Werte
Zeichenfolge
Eine bis zu 255 Zeichen lange Zeichenfolge.
Gilt für

Modell

Objekt
Ereignismodell
eventPseudoModel
Beispiele
JavaScript
xfa.event.prevText;
FormCalc
xfa.event.prevText


printCheckDigit

Gibt an, ob die Prüfziffern in Klartext gedruckt werden.
Der Parser ignoriert diese Eigenschaft, wenn die checksum-Eigenschaft den Wert 0 aufweist, oder wenn die checksum-Eigenschaft den Wert 1 aufweist und das Standardverhalten vorsieht, dass der Barcodetyp keine Prüfsumme enthält.
Syntax
Reference_Syntax.printCheckDigit = "0 | 1"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
Die Prüfziffern werden nicht in Klartext, sondern nur im Barcode gedruckt.
      •
      1
Die Prüfziffer an das Ende des Klartexts anfügen.
Gilt für

Modell

Objekt
Formularmodell
barcode
Beispiele
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").printCheckDigit = "1";
FormCalc
Code11BarCode1.ui.#barcode.printCheckDigit = "1"


priority

Ändert den Suchpfad von Text, für den eine Sprachausgabe erfolgen soll. Das in dieser Eigenschaft angegebene Objekt wird an den Anfang des Suchpfads verschoben. Die anderen Objekte behalten ihre relative Position in der Reihenfolge bei.
Syntax
Reference_Syntax.priority = "custom | caption | name | tooltip"
Werte

Typ

Werte
Zeichenfolge
      •
      custom (Standardwert)
Die Suchreihenfolge lautet speak, tooltip, caption, Name des Containers.
      •
      caption
Die Suchreihenfolge lautet caption, speak, tooltip, Name des Containers.
      •
      name
Die Suchreihenfolge lautet Name des Containers, speak, tooltip, caption.
      •
      tooltip
Die Suchreihenfolge lautet tooltip, speak, caption, Name des Containers.
Gilt für

Modell

Objekt
Formularmodell
speak
Beispiele
JavaScript
TextField1.assist.speak.priority = "tooltip";
FormCalc
TextField1.assist.speak.priority = "tooltip"


radius

Gibt den Radius der Ecke an.
Die radius-Eigenschaft beeinflusst generell das Erscheinungsbild von gerundeten Ecken, bestimmt aber auch die Tiefe einer invertierten, quadratischen Ecke. Jede Kante wird unabhängig von den Werten der Eigenschaften „inverted“ und „join“ durch den Eckenradius von ihren Endpunkten getrennt. In der Regel hat dies keine weiteren Auswirkungen, da die Ecke an den Kantenschnittpunkten eine sichtbare Verbindung zu den Kanten erhält. Ist jedoch für die Ecke die „presence“-Eigenschaft mit dem Wert „invisible“ (nicht sichtbar) vorgegeben, dann sind die Kantenschnitte zu sehen, auch wenn die Ecke quadratisch und nicht invertiert ist.
Syntax
Reference_Syntax.radius = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
corner
Beispiele
JavaScript
TextField1.border.corner.radius = "0.5in";
FormCalc
TextField1.border.corner.radius = "0.5in"


radixOffset

Gibt einen Versatzwert für den Verankerungspunkt des Absatzes an.
Syntax
Reference_Syntax.radixOffset = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
para
Beispiele
JavaScript
NumericField1.para.radixOffset = "0in";
FormCalc
NumericField1.para.radixOffset = "0in"


rate

Gibt den Prozentsatz für die Tupfenfarbe an, die über eine Hintergrundfarbfläche verteilt wird.
Die Hintergrundfarbe wird im „stipple“-Objekt nicht angegeben.
Syntax
Reference_Syntax.rate = "50 | integer"
Werte

Typ

Werte
Zeichenfolge
      •
      50 (Standardwert)
      •
      Ein beliebiger Ganzzahlwert zwischen 0 und 100. Dabei gibt 0 an, dass keine sichtbaren Tupfen über die Hintergrundfarbe verteilt werden, und 100 gibt an, dass die Hintergrundfarbe durch vollständiges Füllen des Bereichs mit der Tupfenfarbe vollständig verdeckt wird.
Eine Tupfenrate zwischen 0 und 100 gibt eine unterschiedliche Mischung von Hintergrundfarbe und einer überlagernden Tupfenfarbe an. Eine Tupfenrate von 50 gibt beispielsweise eine Mischung aus Hintergrundfarbe und Tupfenfarbe zu gleichen Teilen an.
Gilt für

Modell

Objekt
Formularmodell
stipple
Beispiele
JavaScript
TextField1.border.fill.stipple.rate = "75";
FormCalc
TextField1.border.fill.stipple.rate = "75"


rawValue

Gibt den unformatierten Wert des aktuellen Objekts an.
Diese Eigenschaft kann beispielsweise den Wert eines Feldes zurückgeben oder festlegen.
Syntax
Reference_Syntax.rawValue = "value"
Werte

Typ

Werte
Variabel
Die Werte unterscheiden sich abhängig vom referenzierenden Objekt. Beispielsweise gibt diese Eigenschaft bei Objekten, die einen Farbwert erfordern, eine Liste mit kommagetrennten Werten für jede Farbkomponente des Farbraums im Formular r,g,b an.
Alternativ dazu ist die rawValue-Eigenschaft eines field-Objekts eine Zeichenfolge, die den tatsächlichen, im Feld angezeigten Wert oder den Bindewert des Feldes darstellt.
Beispiele
JavaScript
TextField1.rawValue = "Hello";
FormCalc
TextField1.rawValue = "Hello"


ready

Gibt an, ob der Formularlayout-Prozess abgeschlossen ist und Skripterstellungsaufgaben beginnen können.
Diese Eigenschaft ist schreibgeschützt.
Syntax
Reference_Syntax.ready = "True | False"
Werte

Typ

Werte
Boolescher Wert
      •
      True (Standardwert)
Der Layout-Prozess ist abgeschlossen.
      •
      False
Der Layout-Prozess ist nicht abgeschlossen.
Gilt für

Modell

Objekt
Layoutmodell
layoutPseudoModel
Beispiele
JavaScript
xfa.layout.ready;
FormCalc
xfa.layout.ready


recordsAfter

Gibt die Anzahl der Datensätze im Datenfenster nach dem aktuellen Datensatz zurück.
Diese Eigenschaft ist schreibgeschützt.
Syntax
Reference_Syntax.recordsAfter
Werte

Typ

Werte
Ganzzahl
Ein gültiger Ganzzahlwert zwischen 0 und dem Indexwert des letzten Datensatzes in den Quelldaten.
Gilt für

Modell

Objekt
Datenmodell
dataWindow
Beispiele
JavaScript
xfa.dataWindow.recordsAfter;
FormCalc
xfa.dataWindow.recordsAfter


recordsBefore

Gibt die Anzahl der Datensätze im Datenfenster vor dem aktuellen Datensatz zurück.
Diese Eigenschaft ist schreibgeschützt.
Syntax
Reference_Syntax.recordsBefore
Werte

Typ

Werte
Ganzzahl
Ein gültiger Ganzzahlwert zwischen 0 und dem Indexwert des ersten Datensatzes in den Quelldaten.
Gilt für

Modell

Objekt
Datenmodell
dataWindow
Beispiele
JavaScript
xfa.dataWindow.recordsBefore;
FormCalc
xfa.dataWindow.recordsBefore


reenter

Gibt an, ob das enter-Ereignis zum ersten Mal auftritt. Das enter-Ereignis tritt bei jedem Klick in ein Feld auf.
Klickt ein Benutzer erstmals in ein Feld, wird ein enter-Ereignis mit der reenter-Eigenschaft gesendet, die auf den Wert false eingestellt ist. Klickt ein Benutzer erneut in das Feld oder drückt die Eingabetaste, wird ein weiteres enter-Ereignis gesendet, für das die Eigenschaft reenter mit dem Wert true (wahr) versehen ist.
Syntax
Reference_Syntax.reenter = "0 | 1"
Werte

Typ

Werte
Boolescher Wert
      •
      True
Das Eingabeereignis ist bereits eingetreten.
      •
      False
Das Eingabeereignis tritt zum ersten Mal ein.
Gilt für

Modell

Objekt
Ereignismodell
eventPseudoModel
Beispiele
JavaScript
xfa.event.reenter = "False";
FormCalc
xfa.event.reenter = "False"


ref

Gibt einen Ausdruck der Referenz-Syntax an, der die Node im Datenmodell definiert, an die der einschließende Container gebunden wird.
Syntax
Reference_Syntax.ref = "string"
Werte

Typ

Werte
Zeichenfolge
Ein gültiger Verweis der Referenz-Syntax.
Gilt für

Modell

Objekt
Formularmodell
bind
bindItems
connect
event
items
signData
traverse
sourceSet-Modell


relation

Gibt die Beziehung zwischen den Elementen einer Gruppe an.
Syntax
Reference_Syntax.relation = "ordered | unordered | choice"
Werte

Typ

Werte
Zeichenfolge
      •
      ordered (Standardwert)
Instanziiert die Mitglieder in der Reihenfolge, in der sie im Formularentwurf deklariert sind. Dadurch wird der Inhalt möglicherweise neu angeordnet, damit er der Dokumentanordnung des Formularentwurfs entspricht.
      •
      unordered
Instanziiert die Mitglieder in der Datenreihenfolge, unabhängig von der Reihenfolge ihrer Deklaration. Dadurch wird die Gruppe unter Umständen neu geordnet, damit sie der Reihenfolge des Inhalts entspricht.
      •
      choice
Die Mitglieder schließen sich gegenseitig aus; es kann nur eines der Mitglieder instanziiert werden. Die Entscheidung, welches der Mitglieder eingerichtet wird, hängt von den Daten ab.
Gilt für

Modell

Objekt
Formularmodell
subformSet
Beispiele
JavaScript
xfa.form.form1.resolveNode("#subformSet").relation = "unordered";
FormCalc
xfa.form.form1.#subformSet.relation = "unordered"


relevant

Steuert, ob ein Formularobjekt beim Drucken des Formulars einbezogen wird.
Syntax
Reference_Syntax.relevant = "+print | -print"
Werte

Typ

Werte
Zeichenfolge
      •
      +print | print (Standard bei sichtbaren Objekten)
Erzwingt das Einbeziehen eines Objekts beim Drucken des Formulars, unabhängig von der Einstellung der presence-Eigenschaft des Objekts.
      •
      -print (Standardeinstellung bei nicht sichtbaren oder ausgeblendeten Objekten)
Erzwingt das Ausschließen eines Objekts beim Drucken des Formulars, unabhängig von der Einstellung der presence-Eigenschaft des Objekts.
Gilt für

Modell

Objekt
Formularmodell
area
border
contentArea
draw
exclGroup
field
pageArea
pageSet
subform
subformSet
value
Beispiele
JavaScript
Button1.relevant = "-print";
FormCalc
Button1.relevant = "-print"


reserve

Eine Maßeinheit, welche die Höhe oder Breite der Beschriftung angibt.
Die Wirkung dieser Eigenschaft hängt von der placement-Eigenschaft ab. Wenn die Beschriftung auf der linken oder rechten Seite angeordnet wird, gibt die reserve-Eigenschaft an, wie hoch der Beschriftungsbereich ist. Wenn die Beschriftung oben oder unten angeordnet wird, gibt die reserve-Eigenschaft die Breite an. Wenn die Beschriftung auf gleicher Höhe angeordnet wird, wird die reserve-Eigenschaft ignoriert.
Bei einem Abstandswert von 0 wird der Beschriftungsbereich automatisch angepasst. Die Größe des Objekts orientiert sich an der Beschriftung.
Syntax
Reference_Syntax.reserve = "measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
caption
Beispiele
JavaScript
TextField1.caption.reserve = "1.5in";
FormCalc
TextField1.caption.reserve = "1.5in"


restoreState

Stellt die Formular-Nodes eines Formulars mit ihrem ursprünglichen Zustand wieder her und setzt die visuellen Eigenschaften von Feldern, wie etwa Änderungen an Begrenzungsfarben, zurück.
Syntax
Reference_Syntax.restoreState = "none | manual | auto"
Werte

Typ

Werte
Zeichenfolge
      •
      none (Standardwert)
Die Zustand- und Wiederherstellungsinformationen werden nicht gespeichert.
      •
      manual
Bestimmte Eigenschaften werden gespeichert und mit Hilfe von Skriptobjekten wiederhergestellt.
      •
      auto
Das Formular automatisch speichern und mit seinem ursprünglichen Zustand wiederherstellen.
Die Einstellung „auto“ kann nicht für zertifizierte Dokumente verwendet werden.
Gilt für

Modell

Objekt
Formularmodell
subform
Beispiele
JavaScript
Subform1.restoreState = "auto";
FormCalc
Subform1.restoreState = "auto"


rightInset

Gibt die Größe der rechten Vertiefung an.
Syntax
Reference_Syntax.rightInset = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
margin
Beispiele
JavaScript
Subform1.margin.rightInset = "0.25in";
FormCalc
Subform1.margin.rightInset = "0.25in"


role

Gibt die Rolle des übergeordneten Containers an.
Syntax
Reference_Syntax.role = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, welche die Rolle des übergeordneten Containers angibt. Sie kann von sprachaktivierten XFA-Verarbeitungsanwendungen verwendet werden, um Informationen zu liefern. Es können z. B. Werte aus HTML-Code zugewiesen werden, wie TH (Tabellenüberschrift) und TR (Tabellenzeile).
Gilt für

Modell

Objekt
Formularmodell
assist
Beispiele
JavaScript
TextField1.assist.role = "TH";
FormCalc
TextField1.assist.role = "TH"


rotate

Dreht das Objekt um den angegebenen Winkel um seinen Verankerungspunkt.
Der Winkel entspricht der Einheit Grad gegen den Uhrzeigersinn zur Standardposition. Der Wert muss ein nicht negatives Vielfaches von 90 sein.
Die Drehrichtung entspricht der Richtung für positive Winkel in PostScript, PDF und PCL, ist aber der in SVG entgegengesetzt.
Syntax
Reference_Syntax.rotate = "0 | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
      •
      Jede gültige Winkelmaßeinheit.
Gilt für

Modell

Objekt
Formularmodell
draw
field
Beispiele
JavaScript
TextField1.rotate = "90";
FormCalc
TextField1.rotate = "90"


rowColumnRatio

Ein optionales Verhältnis zwischen Zeilen und Spalten für unterstützte 2D-Barcodes.
Der Parser ignoriert diese Eigenschaft, wenn die Eigenschaften dataRowCount und dataColumnCount angegeben sind.
Ist die rowColumnRatio-Eigenschaft angegeben, wird die Größe des Barcodes an die Anzahl der Zeilen angepasst, die zum Aufnehmen der bereitgestellten Daten erforderlich sind. Wird die letzte Zeile nicht mit den bereitgestellten Daten gefüllt, wird sie mit Füllzeichen aufgefüllt.
Syntax
Reference_Syntax.rowColumnRatio = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die das Verhältnis zwischen Zeilen und Spalten darstellt.
Gilt für

Modell

Objekt
Formularmodell
barcode


runAt

Gibt an, welche Anwendung das Skript ausführen kann.
Diese Einstellung wird auch dann angewendet, wenn das Skript von einem anderen Skript aufgerufen wird.
Syntax
Reference_Syntax.runAt = "client | server | both"
Werte

Typ

Werte
Zeichenfolge
      •
      client (Standardwert)
Das Skript ist nur auf dem Client ausführbar.
      •
      server
Das Skript ist nur auf dem Server ausführbar.
      •
      both
Das Skript ist auf dem Server und auf dem Client ausführbar.
Gilt für

Modell

Objekt
Formularmodell
execute
script
Beispiele
JavaScript
NumericField1.calculate.script.runAt = "both";
FormCalc
NumericField1.calculate.script.runAt = "both"


save

Bestimmt, ob die Werte in einer bestimmten Spalte sowohl angezeigte als auch gebundene Werte darstellen, oder ob die Daten in der Spalte nur gebundene Daten darstellen.
Syntax
Reference_Syntax.save = "0 | 1"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
Bei den von diesem Objekt bereitgestellten Werten handelt es sich nur um Anzeigewerte.
      •
      1
Die von diesem Objekt bereitgestellten Werte können in das Feld eingegeben werden.
Mindestens eine Spalte muss den Wert 1 aufweisen. Wenn mehrere Spalten den Wert 1 aufweisen, speichert der Parser die erste Spalte mit dem Wert 1.
Gilt für

Modell

Objekt
Formularmodell
items
Beispiele
JavaScript
DropDownList1.resolveNode("#items").save = "1";
FormCalc
DropDownList1.#items.save = "1"


scope

Bestimmt die Teilnahme des Teilformulars an der Datenbindung sowie an Ausdrücken der Referenz-Syntax.
Ein benanntes Teilformular nimmt an der Datenbindung teil und kann mit einem Ausdruck der Referenz-Syntax referenziert werden. Mit Hilfe dieser Eigenschaft kann einem Teilformular ein Name zugewiesen werden, wobei das Teilformular für die Datenbindung sowie für Ausdrücke der Referenz-Syntax transparent bleibt.
Syntax
Reference_Syntax.scope = "name | none"
Werte

Typ

Werte
Zeichenfolge
      •
      name (Standardwert)
Wenn das Teilformular einen Namen besitzt, nimmt es an der Datenbindung sowie an Ausdrücken der Referenz-Syntax teil. Andernfalls erfolgt keine Teilnahme.
      •
      none
Das Teilformular nimmt auch dann nicht an der Datenbindung oder an Ausdrücken der Referenz-Syntax teil, wenn es einen Namen besitzt.
Gilt für

Modell

Objekt
Formularmodell
subform
Beispiele
JavaScript
Subform1.scope = "none";
FormCalc
Subform1.scope = "none"


scriptTest

Steuert die Überprüfung durch das Skript.
Skripten, die Teil einer Überprüfung sind, dürfen keine Annahmen darüber anstellen, wie die verarbeitende Anwendung die Überprüfungsergebnisse möglicherweise verwendet oder wann das validate-Objekt aufgerufen wird. Das Skript darf dem Benutzer kein Feedback geben oder den Status des Formulars in irgendeiner Weise ändern.
Syntax
Reference_Syntax.scriptTest = "error | disabled | warning"
Werte
Gilt für

Typ

Werte
Zeichenfolge
      •
      disabled
Diesen Test nicht ausführen. Das Formularobjekt darf einen Wert haben, welcher dem Skript nicht entspricht. Selbst wenn das Feld einen nicht konformen Wert enthält, wirkt sich dies nicht negativ auf die Gültigkeit des Formulars aus. Dieser Wert deaktiviert die Überprüfung.
      •
      error (Standardwert)
Eine Meldung wird ausgegeben und die Annahme von Daten verweigert, die das Skript als fehlerhaft meldet. Das Formularobjekt muss einen Wert haben, welcher dem Skript entspricht.
      •
      warning
Wenn das Skript die Daten als fehlerhaft meldet, wird eine Meldung ausgegeben. Der Benutzer darf jedoch zum nächsten Feld wechseln. Die Meldung muss den Benutzer darüber informieren, dass das Formularobjekt einen Wert haben muss, der den Einschränkungen des Skripts entspricht. Es müssen zwei Möglichkeiten angeboten werden:
      •
      dismiss: Der Benutzer nimmt die Empfehlung zur Kenntnis, kehrt zum Formular zurück und erfüllt die Einschränkung.
      •
      override: Der Benutzer nimmt die Empfehlung zur Kenntnis, entscheidet jedoch, gegen diese Einschränkung zu verstoßen.

Modell

Objekt
Formularmodell
validate
Beispiele
JavaScript
NumericField1.validate.scriptTest = "disabled";
FormCalc
NumericField1.validate.scriptTest = "disabled"


selEnd

Gibt die Indexposition des letzten Zeichens in der Textauswahl an, die während eines Änderungsereignisses in der prevText-Eigenschaft gespeichert wurde.
Syntax
Reference_Syntax.selEnd
Werte

Typ

Werte
Ganzzahl
Eine gültige Ganzzahl, die den Null-basierten Indexwert des letzten Zeichens der Textauswahl bezeichnet.
Ist kein Text ausgewählt, wird diese Eigenschaft auf die Position des Textcursors zum Zeitpunkt der Änderung eingestellt. Wenn der Wert dieser Eigenschaft verändert wird, werden andere Zeichen durch den Wert der Änderung ersetzt und der Textcursor wird neu positioniert.
Gilt für

Modell

Objekt
Ereignismodell
eventPseudoModel
Beispiele
JavaScript
xfa.event.selEnd;
FormCalc
xfa.event.selEnd


selStart

Gibt die Indexposition des ersten Zeichens in der Textauswahl an, die während eines Änderungsereignisses in der prevText-Eigenschaft gespeichert wurde.
Syntax
Reference_Syntax.selStart
Werte

Typ

Werte
Ganzzahl
Eine gültige Ganzzahl, die den Null-basierten Indexwert des ersten Zeichens der Textauswahl bezeichnet.
Ist kein Text ausgewählt, wird diese Eigenschaft auf die Position des Textcursors zum Zeitpunkt der Änderung eingestellt. Wenn der Wert dieser Eigenschaft verändert wird, werden andere Zeichen durch den Wert der Änderung ersetzt und der Textcursor wird neu positioniert.
Gilt für

Modell

Objekt
Ereignismodell
eventPseudoModel
Beispiele
JavaScript
xfa.event.selStart;
FormCalc
xfa.event.selStart


server

Gibt die URL für einen Zeitstempel-Server an.
Syntax
Reference_Syntax.server = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die die URL für den Zeitstempel-Server darstellt.
Gilt für

Modell

Objekt
Formularmodell
timeStamp


shape

Gibt an, ob das Kontrollkästchen oder Optionsfeld mit einer quadratischen oder runden Kontur dargestellt wird.
Syntax
Reference_Syntax.shape = "square | round"
Werte

Typ

Werte
Zeichenfolge
      •
      square (Standardwert)
Die Schaltfläche wird mit einer quadratischen Kontur dargestellt.
      •
      round
Die Schaltfläche wird mit einer kreisförmigen Kontur dargestellt.
Gilt für

Modell

Objekt
Formularmodell
checkButton
Beispiele
JavaScript
CheckButton1.resolveNode("ui.#checkButton").shape = "square";
FormCalc
CheckButton.ui.#checkButton.shape = "square"


shift

Gibt an, ob während eines bestimmten Ereignisses die Umschalttaste gedrückt gehalten wird.
Syntax
Reference_Syntax.shift
Werte

Typ

Werte
Boolescher Wert
      •
      True (Standardwert)
Die Umschalttaste wird während der Ereignisausführung gedrückt gehalten.
      •
      False
Die Umschalttaste wird während der Ereignisausführung nicht gedrückt gehalten.
Gilt für

Modell

Objekt
Ereignismodell
eventPseudoModel
Beispiele
JavaScript
xfa.event.shift;
FormCalc
xfa.event.shift


short

Gibt die Länge der kurzen Kante des medium-Objekts an.
Die durch die short-Eigenschaft angegebene Länge muss kleiner sein als die durch die long-Eigenschaft angegebene Länge.
Syntax
Reference_Syntax.short = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
medium
Beispiele
JavaScript
xfa.form.form1.pageSet.Page1.medium.short;
FormCalc
xfa.form.form1.pageSet.Page1.medium.short


signatureType

Gibt an, wie ein Formular mit Dokumentunterschrift als zertifiziertes PDF-Dokument gespeichert wird.
Syntax
Reference_Syntax.signatureType = "filler | author"
Werte

Typ

Werte
Zeichenfolge
      •
      filler (Standardwert)
Speichert das Formular als zertifiziertes PDF-Dokument.
      •
      author
Dokumente mit Verfasserunterschriften werden als zertifizierte Dokumente bezeichnet. Nachdem das Formular als PDF-Dokument gespeichert und in Acrobat geöffnet wurde, kann der Benutzer auf das Dokumentunterschriftsfeld klicken, um das gesamte Dokument zu zertifizieren.
Gilt für

Modell

Objekt
Formularmodell
mdp


size

Eine Maßeinheit, welche die Größe des Kontrollkästchens bzw. des Optionsfelds angibt. Bei einem Kontrollkästchen stellt sie die Höhe und Breite und bei einem Optionsfeld den Durchmesser dar.
Syntax
Reference_Syntax.size = "10pt | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      10pt (Standardwert)
      •
      Jede gültige Maßeinheit.
Die Werte für diese Eigenschaft hängen vom referenzierenden Objekt ab:
      •
      Beim font-Objekt gibt diese Eigenschaft die Größe der Schrift an.
      •
      Für das checkButton-Objekt gibt diese Eigenschaft die Höhe bzw. die Breite eines Kontrollkästchens oder den Durchmesser eines Optionsfeldes an.
Gilt für

Modell

Objekt
Formularmodell
checkButton
font
Beispiele
JavaScript
CheckBox1.resolveNode("ui.#checkButton").size = "20pt";
FormCalc
CheckBox1.ui.#checkButton.size = "20pt"


slope

Gibt die Ausrichtung der Linie an.
Syntax
Reference_Syntax.slope = "\ | /"
Werte

Typ

Werte
Zeichenfolge
      •
      \ (umgekehrter Schrägstrich) (Standardeinstellung)
Die Linie erstreckt sich von oben links nach unten rechts.
      •
      / (Schrägstrich)
Die Linie erstreckt sich von unten links nach oben rechts.
Gilt für

Modell

Objekt
Formularmodell
line
Beispiele
JavaScript
Line1.resolveNode("value.#line").slope = "/";
FormCalc
Line1.value.#line.slope = "/"


soapFaultCode

Gibt einen Fehlercode an, der auftritt, wenn ein Benutzer versucht, eine Webdienst-Verbindung auszuführen.
Syntax
Reference_Syntax.soapFaultCode = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die den SOAP-Fehlercode darstellt.
Gilt für

Modell

Objekt
Ereignismodell
eventPseudoModel


soapFaultString

Gibt die beschreibende Meldung an, die einem bestimmten Fehlercode für eine Webdienst-Verbindung entspricht.
Syntax
Reference_Syntax.size = "10pt | measurement"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, welche die SOAP-Fehlercode-Meldung darstellt.
Gilt für

Modell

Objekt
Ereignismodell
eventPseudoModel


somExpression

Liest den Ausdruck der Referenz-Syntax für diese Node.
Syntax
Reference_Syntax.somExpression
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die einen vollständig qualifizierten Ausdruck der Referenz-Syntax darstellt.
Gilt für
tree-Klasse
Beispiele
JavaScript
TextField1.somExpression;
FormCalc
TextField1.somExpression


spaceAbove

Gibt den vertikalen Abstand an, der zusätzlich zum maximalen Zeilenabstand der ersten Zeile im Absatz vorgesehen werden soll.
Syntax
Reference_Syntax.spaceAbove = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
para
Beispiele
JavaScript
TextField1.para.spaceAbove = "2pt";
FormCalc
TextField1.para.spaceAbove = "2pt"


spaceBelow

Gibt den vertikalen Abstand an, der zusätzlich zum maximalen Zeilenabstand der ersten Zeile im Absatz vorgesehen werden soll.
Syntax
Reference_Syntax.spaceAbove = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
para
Beispiele
JavaScript
TextField1.para.spaceBelow = "2pt";
FormCalc
TextField1.para.spaceBelow = "2pt"


startAngle

Legt den Winkel fest, an dem die Wiedergabe des Bogenanfangs erfolgen soll.
Syntax
Reference_Syntax.startAngle = "0 | angle"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
      •
      Ein Wert größer als 0 und kleiner gleich 360.
Gilt für

Modell

Objekt
Formularmodell
arc
Beispiele
JavaScript
Circle1.resolveNode("value.#arc").startAngle = "12";
FormCalc
Circle1.value.#arc.startAngle = "12"


startChar

Gibt ein optionales Startsteuerzeichen an, das am Anfang der Barcodedaten eingefügt wird.
Die starChar-Eigenschaft wird vom Parser ignoriert, wenn das Barcodemuster das angegebene Startsteuerzeichen nicht unterstützt.
Syntax
Reference_Syntax.startChar = "character"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die ein Steuerzeichen darstellt.
Gilt für

Modell

Objekt
Formularmodell
barcode
Beispiele
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").startChar = "*";
FormCalc
Code11BarCode1.ui.#barcode.startChar = "*"


startNew

Legt fest, ob ein neuer Inhaltsbereich oder eine neue Seite begonnen werden soll, selbst wenn der aktuelle Inhaltsbereich bzw. die aktuelle Seite den erforderlichen Namen besitzt.
Diese Eigenschaft ist nur wirksam, wenn die before-Eigenschaft den Wert contentArea oder den Wert pageArea aufweist.
Syntax
Reference_Syntax.startNew = "0 | 1"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
Beginnt keinen neuen Inhaltsbereich bzw. Seitenbereich, wenn der aktuelle Bereich den angegebenen Namen besitzt.
      •
      1
Beginnt einen neuen Inhalts- oder Seitenbereich.
Der Name des Inhaltsbereichs bzw. der Seite wird von der zugehörigen beforeTarget-Eigenschaft bereitgestellt.
Gilt für

Modell

Objekt
Formularmodell
break
breakAfter
breakBefore
Beispiele
JavaScript
Subform1.break.startNew = "1";
FormCalc
Subform1.break.startNew = "1"


stateless

Bestimmt, ob die Variablen eines Skripts zwischen zwei Aufrufen bestehen bleiben.
Syntax
Reference_Syntax.stateless = "0 | 1"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
Die Variablen des Skripts bleiben bestehen (statusbehaftet).
      •
      1
Die Variablen des Skripts bleiben nicht bestehen (nicht statusbehaftet).
Gilt für

Modell

Objekt
Formularmodell
script
Beispiele
JavaScript
TextField1.resolveNode("#event.#script").stateless = "1";
FormCalc
TextField1.#event.#script.stateless = "1"


stock

Gibt den Namen einer Standardpapiergröße an.
Syntax
Reference_Syntax.stock = "letter | paper_size"
Werte

Typ

Werte
Zeichenfolge
      •
      letter (Standardwert)
      •
      Ein gültiger Wert für eine Papiergröße.
Gilt für

Modell

Objekt
Formularmodell
medium
Beispiele
JavaScript
xfa.form.form1.pageSet.Page1.medium.stock = "A4";
FormCalc
xfa.form.form1.pageSet.Page1.medium.stock = "A4"


stroke

Gibt das Erscheinungsbild einer Linie an.
Syntax
Reference_Syntax.stroke = "solid | dashed | dotted | dashDot | dashDotDot | lowered | raised | etched | embossed"
Werte

Typ

Werte
Zeichenfolge
      •
      solid (Standardwert)
Durchgezogen.
      •
      dashed
Eine gestrichelte Linie.
      •
      dotted
Eine gepunktete Linie.
      •
      dashDot
Eine Strichpunktlinie.
      •
      dashDotDot
Eine Strichpunktlinie bestehend aus einer Abfolge von rechteckigen kurzen Strichen und jeweils zwei runden Punkten.
      •
      lowered
Die Linie umschließt einen tiefergestellten Bereich.
      •
      raised
Die Linie umschließt einen höhergestellten Bereich.
      •
      etched
Entspricht einer in der Zeichenfläche vertieften Linie.
      •
      embossed
Entspricht einer in der Zeichenfläche erhöhten Linie.
Gilt für

Modell

Objekt
Formularmodell
corner
edge
Beispiele
JavaScript
Line1.resolveNode("value.#line.edge").stroke = "etched";
FormCalc
Line1.value.#line.edge.stroke = "etched"


sweepAngle

Gibt die Länge des Bogens als Winkel an.
Syntax
Reference_Syntax.sweepAngle = "360 |angle"
Werte

Typ

Werte
Zeichenfolge
      •
      360 (Standardwert)
      •
      Ein Wert kleiner als 360 und größer gleich 0.
Gilt für

Modell

Objekt
Formularmodell
arc
Beispiele
JavaScript
Circle1.resolveNode("value.#arc").sweepAngle = "45";
FormCalc
Circle1.value.#arc.sweepAngle = "45"


tabDefault

Gibt den Abstand zwischen Standardtabstopps an.
Standardmäßig sind keine Standardtabstopps definiert.
Syntax
Reference_Syntax.tabDefault = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die den Abstand zwischen den Standardtabstopps darstellt.
Gilt für

Modell

Objekt
Formularmodell
para
Beispiele
JavaScript
TextField1.para.tabDefault = "3in";
FormCalc
TextField1.para.tabDefault = "3in"


tabStops

Gibt eine durch Leerzeichen getrennte Liste mit Tabstopp-Positionen an.
Im Bereich zwischen dem linken Rand und dem Tabstopp ganz rechts in der Liste ersetzen diese Tabstopp-Positionen die durch die tabDefault-Eigenschaft angegebenen Standardtabstopps. Die Standardtabstopps werden nach rechts in diesem Bereich fortgesetzt.
Jeder Eintrag in der Liste der Tabstopps besteht aus einem Schlüsselwort, das die Ausrichtung am Tabstopp, ein Leerzeichen sowie den Abstand des Tabstopps vom linken Rand angibt.
Syntax
Reference_Syntax.tabStops = "center | left | right | decimal"
Werte

Typ

Werte
Zeichenfolge
Die Tabstoppausrichtung weist einen der folgenden Werte auf:
      •
      center
Gibt ein zentriertes Tabstoppzeichen an.
      •
      left
Gibt ein links ausgerichtetes Tabstoppzeichen an.
      •
      right
Gibt ein rechts ausgerichtetes Tabstoppzeichen an.
      •
      decimal
Gibt ein Tabstoppzeichen an, das den Inhalt um einen Radixpunkt anordnet.
Gilt für

Modell

Objekt
Formularmodell
para
Beispiele
JavaScript
TextField1.para.tabStops = "decimal";
FormCalc
TextField1.para.tabStops = "decimal"


target

Gibt das Objekt an, auf welches das Ereignis wirkt.
Syntax
Reference_Syntax.target = "URL"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die den Namen eines Formularentwurfsobjekts, eines Ausdrucks der Referenz-Syntax oder einer URL für Datensendungen angibt.
Gilt für

Modell

Objekt
Ereignismodell
eventPseudoModel
Formularmodell
breakAfter
breakBefore
overflow
setProperty
signData
submit
Beispiele
JavaScript
xfa.event.target;
FormCalc
xfa.event.target


targetType

Gibt die Einschränkungen zum Wechseln auf eine neue Seite oder in einen neuen Inhaltsbereich vor dem Erstellen des Layouts für das übergeordnete Teilformular an.
Die targetType-Eigenschaft ersetzt die nicht weiter unterstützte break.before-Eigenschaft.
Syntax
Reference_Syntax.targetType = "auto | contentArea | pageArea"
Werte

Typ

Werte
Zeichenfolge
Die startNew-Eigenschaft ändert auch einige der folgenden Verhaltensweisen.
      •
      auto (Standardwert)
Die Entscheidung über einen Übergang zu einer neuen Seite oder einem neuen Inhaltsbereich wird auf die verarbeitende Anwendung übertragen. Es wird kein Übergang zu einer neuen Seite oder einem neuen Inhaltsbereich erzwungen.
      •
      contentArea
Bei der Wiedergabe erfolgt der Übergang zum nächsten verfügbaren Inhaltsbereich. Siehe auch startNew-Eigenschaft.
      •
      pageArea
Bei der Wiedergabe erfolgt der Übergang zu einer neuen Seite. Siehe auch startNew-Eigenschaft.
Gilt für

Modell

Objekt
Formularmodell
breakAfter
breakBefore
Beispiele
JavaScript
Subform1.breakBefore.targetType = "pageArea";
FormCalc
Subform1.breakBefore.targetType = "pageArea"


textEncoding

Gibt die Kodierung des im Dokument enthaltenen Textes an.
Syntax
Reference_Syntax.textEncoding = "UTF-8 | UTF-16 | Shift-JIS | Big-Five | GB-2312"
Werte
Beim Wert dieser Eigenschaft wird die Groß-/Kleinschreibung nicht unterschieden. Er muss einem der folgenden Werte entsprechen.

Typ

Werte
Zeichenfolge
      •
      none (Standardwert)
Es ist keine spezielle Kodierung angegeben. Die Zeichen werden mit Hilfe der betriebssystemspezifischen Kodierung verschlüsselt.
      •
      ISO-8859-1
Die Zeichenkodierung erfolgt mittels ISO-8859-1, auch als Latin-1 bekannt.
      •
      ISO-8859-2
Die Zeichenkodierung erfolgt mittels ISO-8859-2.
      •
      SO-8859-7
Die Zeichenkodierung erfolgt mittels ISO-8859-7.
      •
      Shift-JIS
Die Zeichenkodierung erfolgt mittels JIS X 0208 (als Shift-JIS bekannt).
      •
      KSC-5601
Die Zeichenkodierung erfolgt mittels des Code for Information Interchange (Hangul und Hanja).
      •
      Big-Five
Die Zeichenkodierung erfolgt mittels Traditionellem Chinesisch (Big-Five). Für Big-Five gibt es keinen offiziellen Standard, entsprechend gibt es mehrere Varianten. Das Adobe-Formularobjektmodell verwendet die Variante, die von Microsoft als Code implementiert wird.
      •
      GB-2312
Die Zeichenkodierung erfolgt mittels Vereinfachtem Chinesisch.
      •
      UTF-8
Die Zeichenkodierung erfolgt in Übereinstimmung mit den von Unicode definierten Unicode-Codepunkten und der UTF-8-Serialisierung gemäß ISO/IEC 10646.
      •
      UTF-16
Die Zeichenkodierung erfolgt in Übereinstimmung mit den von Unicode definierten Unicode-Codepunkten und der UTF-16-Serialisierung gemäß ISO/IEC 10646.
      •
      UCS-2
Die Zeichenkodierung erfolgt in Übereinstimmung mit den von Unicode definierten Unicode-Codepunkten und der UCS-2-Serialisierung gemäß ISO/IEC 10646.
      •
      fontSpecific
Die Zeichenkodierung erfolgt schriftspezifisch. Jedes Zeichen wird durch ein 8-Bit Byte dargestellt.
Gilt für

Modell

Objekt
Formularmodell
submit
Beispiele
JavaScript
Button1.event.submit.textEncoding = "UCS-2";
FormCalc
Button1.event.submit.textEncoding = "UCS-2"


textEntry

Bestimmt, ob ein Benutzer einen Wert in eine Dropdown-Liste eingeben kann.
Syntax
Reference_Syntax.textEntry = "0 | 1"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
Der Benutzer kann keine Eingabe im aktuellen Feld machen. Der Wert wird durch Auswahl eines Wertes in der Dropdown-Liste festgelegt.
      •
      1
Der Benutzer kann einen Wert in einer Dropdown-Liste eingeben oder in der Dropdown-Liste auswählen. Somit wird der Feldwert durch die Eingabe des Benutzers bestimmt. Wenn für die open-Eigenschaft der Wert multiSelect festgelegt ist, kann der Benutzer keine Werte in das Feld eingeben.
Gilt für

Modell

Objekt
Formularmodell
choiceList
Beispiele
JavaScript
DropDownList1.resolveNode("ui.#choiceList").textEntry = "1";
FormCalc
DropDownList1.ui.#choiceList.textEntry = "1"


textIndent

Gibt die horizontale Position der ersten Zeile im Verhältnis zu den anderen Zeilen in einem Absatz an.
Ein negativer Wert bewirkt einen hängenden Einzug, ein positiver Wert dagegen einen Erstzeileneinzug.
Syntax
Reference_Syntax.textIndent = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
para
Beispiele
JavaScript
TextField1.para.textIndent = "3in";
FormCalc
TextField1.para.textIndent = "3in"


textLocation

Gibt die Position eines dem Barcode zugehörigen Textes an.
Der für eingebetteten Text verfügbare Bereich (sofern vorhanden) wird vom Barcodeformat bestimmt. Bei den meisten Barcodeformaten ist dies ein einzelner, zusammenhängender Bereich. Bei EAN-Barcodes ist er in vier Bereiche aufgeteilt, welche die Eigenschaften typeface und size vom einschließenden Feld übernehmen. Der Formularentwurf muss die Eigenschaftentypeface und size für das Feld festlegen, das in den vorgegebenen Bereich ohne Überlappung von Balken eingepasst werden soll. Die typeface-Eigenschaft sollte nicht proportional sein.
Syntax
Reference_Syntax.textLocation = "below | none | above | aboveEmbedded | belowEmbedded"
Werte

Typ

Werte
Zeichenfolge
      •
      below (Standardwert)
Der Text wird unterhalb des Barcodes positioniert.
      •
      above
Der Text wird oberhalb des Barcodes positioniert.
      •
      belowEmbedded
Der Text wird teilweise am unteren Rand des Barcodes eingebettet und auf den unteren Rand der Striche ausgerichtet.
      •
      aboveEmbedded
Der Text wird teilweise am oberen Rand des Barcodes eingebettet und auf den oberen Rand der Striche ausgerichtet.
      •
      none
Es wird kein Text angezeigt.
Gilt für

Modell

Objekt
Formularmodell
barcode
Beispiele
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").textLocation = "aboveEmbedded";
FormCalc
Code11BarCode1.ui.#barcode.textLocation = "aboveEmbedded"


thickness

Gibt die Stärke oder Breite der Linie an.
Syntax
Reference_Syntax.thickness = "0.5pt | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0.5pt (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
corner
edge
Beispiele
JavaScript
TextField1.border.edge.thickness = "0.2in";
FormCalc
TextField1.border.edge.thickness = "0.2in"


this

Ruft die aktuelle Node ab. Hierbei handelt es sich um die Anfangs-Node für die Methoden resolveNode und resolveNodes.
Diese Eigenschaft ist schreibgeschützt.
Syntax
this
Werte

Typ

Werte
Objekt
Das aktuelle Objekt.
Gilt für

Modell

Objekt
XFA-Modell
xfa
Beispiele
JavaScript
this
FormCalc
this


timeout

Gibt die Anzahl der Sekunden für den Versuch einer Abfrage an.
Syntax
Reference_Syntax.timeout = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, welche die Anzahl der Sekunden vor dem Ablauf des Zeitlimits für die Abfrage darstellt.
Gilt für

Modell

Objekt
sourceSet-Modell
command
connect
Beispiele
In diesen Beispielen stellt Titles den Namen der Datenverbindung dar.
JavaScript
xfa.sourceSet.Titles.connect.timeout = "10";
FormCalc
xfa.sourceSet.Titles.connect.timeout = "10"


timeStamp

Gibt den Datums-/Uhrzeitstempel für diese Node an.
Syntax
Reference_Syntax.timeStamp = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die ein Datum und eine Uhrzeit darstellt.
Gilt für

Modell

Objekt
XFA-Modell
xfa


title

Legt den Titel des Dokuments fest und ruft ihn ab. Nur für Client-Anwendungen verfügbar.
Syntax
Reference_Syntax.title
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die den Titel des aktuellen Formulars angibt.
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.title;
FormCalc
xfa.host.title


topInset

Eine Maßeinheit, die angibt, wie groß die obere Vertiefung sein soll.
Syntax
Reference_Syntax.topInset = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
margin
Beispiele
JavaScript
Subform1.margin.topInset "1in";
FormCalc
Subform1.margin.topInset "1in"


trailer

Gibt das subform- bzw. subformSet-Objekt an, das im unteren Bereich eines Inhalts- oder Seitenbereichs platziert werden soll.
Die „trailer“-Eigenschaft ersetzt die nicht weiter unterstützten Eigenschaften overflowTrailer und bookendTrailer.
Syntax
Reference_Syntax.trailer = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, welche die ID oder den vollständig qualifizierten Ausdruck der Referenz-Syntax eines Teilformulars oder eines Teilformularsatzes darstellt. Der Standardwert ist eine leere Zeichenfolge.
Gilt für

Modell

Objekt
Formularmodell
bookend
breakAfter
breakBefore
overflow
Beispiele
JavaScript
Subform1.breakBefore.trailer = "Subform2";
FormCalc
Subform1.breakBefore.trailer = "Subform2"


transferEncoding

Gibt die Kodierung von binärem Inhalt im referenzierten Dokument an.
Syntax
Reference_Syntax.transferEncoding = "none | base64"
Werte

Typ

Werte
Zeichenfolge
      •
      none (Standardwert)
Das referenzierte Dokument wird nicht kodiert. Wird das referenzierte Dokument über einen URI angegeben, erfolgt die Übertragung als Datenstrom. Wenn das referenzierte Dokument die „inline“-Eigenschaft aufweist, muss es den Einschränkungen für den PCDATA-Datentyp entsprechen.
      •
      base64
Der binäre Inhalt wird gemäß dem Kodierungsstandard für base64-Übertragungen kodiert.
Gilt für

Modell

Objekt
Formularmodell
exData
image
sourceSet-Modell
bind


transient

Gibt an, ob die verarbeitende Anwendung den Wert der Ausschlussgruppe als Teil eines Formularsende- oder -speichervorgangs speichern muss.
Syntax
Reference_Syntax.transient = "0 | 1"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
Der Wert der Ausschlussgruppe muss gespeichert werden.
      •
      1
Die Ausschlussgruppe muss nicht gespeichert werden.
Gilt für

Modell

Objekt
Formularmodell
exclGroup


truncate

Schneidet die rechte Kante des Barcodes für unterstützte Formate ab.
Es werden nur Barcodes vom Typ PDF417 abgeschnitten. Der Parser ignoriert diese Eigenschaft für Barcodeformate, für die diese Eigenschaft nicht gilt.
Syntax
Reference_Syntax.truncate = "0 | 1"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
Schließt das rechte Synchronisierungszeichen ein.
      •
      1
Schließt das rechte Synchronisierungszeichen nicht ein.
Gilt für

Modell

Objekt
Formularmodell
barcode
Beispiele
JavaScript
Code11BarCode1.resolveNode("ui.#barcode").truncate = "1";
FormCalc
Code11BarCode1.ui.#barcode.truncate = "1"


type

Gibt das von einem Objekt verwendete Muster an.
Gibt die Richtung des Farbverlaufs an.
Syntax
Reference_Syntax.type = "toRight | toLeft | toTop | toBottom"
Werte

Typ

Werte
Zeichenfolge
Die Werte für diese Eigenschaft hängen vom referenzierenden Objekt ab.
Für das barcode-Objekt gilt:
Eine Zeichenfolge, die das Barcodemuster angibt.
Diese Eigenschaft muss angegeben werden. Die Gruppe unterstützter Werte für diese Eigenschaft bezieht sich nur auf das Anzeigegerät.
Die folgenden Werte wurden für diese Eigenschaft definiert, um bestimmte Barcodetypen anzugeben:
•
codabar
Codabar-Barcode, wie in ANSI/AIM BC3-1995, USS Codabar definiert.
•
code2Of5Industrial
Code 2 of 5 Industrial; kein offizieller Standard.
•
code2Of5Interleaved
Code 2 of 5 Interleaved, wie in ANSI/AIM BC2-1995, USS Interleaved 2-of-5 definiert.
•
code2Of5Matrix
Code 2 of 5 Matrix; kein offizieller Standard.
•
code2Of5Standard
Code 2 of 5 Standard; kein offizieller Standard.
•
code3Of9
Code 39 (auch als Code 3 of 9 bezeichnet), wie in ANSI/AIM BC1-1995, USS Code 39 definiert.
•
code3Of9extended
Code 39 extended; kein offizieller Standard.
•
code11
Code 11 (USD-8); kein offizieller Standard.
•
code49
Code 49, wie in ANSI/AIM BC6-1995, USS Code 49 definiert.
•
code93
Code 93, wie in ANSI/AIM BC5-1995, USS Code 93 definiert.
•
code128
Code 128, wie in ANSI/AIM BC4-1995, Code 128 definiert.
•
code128A
Code 128 A, wie in ANSI/AIM BC4-1995, ISS Code 128 definiert.
•
code128B
Code 128 B, wie in ANSI/AIM BC4-1995, ISS Code 128 definiert.
•
code128C
Code 128 C, wie in ANSI/AIM BC4-1995, ISS Code 128 definiert.
•
code128SSCC
Code 128 Serial Shipping Container Code, wie in ANSI/AIM BC4-1995, ISS Code 128 definiert.
•
ean8
EAN-8, wie in ISO/EEC 15420 definiert.
•
ean8add2
EAN-8 with 2-digit Addendum, wie in ISO/EEC 15420 definiert.
•
ean8add5
EAN-8 with 5-digit Addendum, wie in ISO/EEC 15420 definiert.
•
ean13
EAN-13, wie in ISO/EEC 15420 definiert.
•
postAUSStandard
Australian Postal Standard, wie in Customer Barcoding Technical Specifications definiert.
•
postUKRM4SCC
United Kingdom RM4SCC (Royal Mail 4-State Customer Code), wie in the How to Use Mailsort Guide definiert.
•
postUSDPBC
United States Postal Service Delivery Point, wie in DMM C840 Barcoding Standards for Letters and Flats definiert.
•
postUSStandard
United States Postal Service POSTNET (Zip+4), wie in DMM C840 Barcoding Standards for Letters and Flats definiert.
•
postUSZip
United States Postal Service POSTNET (5 digit Zip), wie in DMM C840 Barcoding Standards for Letters and Flats definiert.
•
qr
QR Code, wie in ISS - QR Code definiert.
•
telepen
Telepen, wie in USS Telepen definiert.
•
ucc128
UCC/EAN 128, wie in International Symbology Specification - Code 128 (1999) definiert.
•
ucc128random
UCC/EAN 128 Random Weight, wie in International Symbology Specification - Code 128 (1999) definiert.
•
ucc128sscc
UCC/EAN 128 Serial Shipping Container Code (SSCC), wie in International Symbology Specification - Code 128 (1999) definiert.
•
upcA
UPC-A, wie in ISO/EEC 15420 definiert.
•
upcAadd2
UPC-A with 2-digit Addendum, wie in ISO/EEC 15420 definiert.
•
upcAadd5
UPC-A with 5-digit Addendum, wie in ISO/EEC 15420 definiert.
•
upcApwcd
UPC-A with Price/Weight customer data, wie in ISO/EEC 15420 definiert.
•
upcE
UPC-E, wie in ISO/EEC 15420 definiert.
•
upcEadd2
UPC-E with 2-digit Addendum, wie in ISO/EEC 15420 definiert.
•
upcEadd5
UPC-E with 5-digit Addendum, wie in ISO/EEC 15420 definiert.
•
upcean2
UPC/EAN with 2-digit Addendum, wie in ISO/EEC 15420 definiert.
•
upcean5
UPC/EAN with 5-digit Addendum, wie in ISO/EEC 15420 definiert.
Für Objekte des Typs digestMethods, encodings, subjectDNSs und timeStamp gilt:
Gibt an, ob die Unterschriftsoptionen auf die Filtereinstellungen beschränkt sind.
•
optional (Standardwert)
Die Unterschriftsoptionen sind nicht auf die Filtereinstellungen beschränkt.
•
required
Die Unterschriftsoptionen sind auf die Filtereinstellungen beschränkt.
Für das linear-Objekt gilt:
Gibt die Richtung des Farbverlaufs an.
•
toRight (Standardwert)
Die Farbe geht von der Anfangsfarbe auf der linken Seite des Objekts nach rechts verlaufend in die Endfarbe über.
•
toLeft
Die Farbe geht von der Anfangsfarbe auf der rechten Seite des Objekts nach links verlaufend in die Endfarbe über.
•
toTop
Die Farbe geht von der Anfangsfarbe am unteren Ende des Objekts zum oberen Ende hin verlaufend in die Endfarbe über.
•
toBottom
Die Farbe geht von der Anfangsfarbe am oberen Ende des Objekts zum unteren Ende hin verlaufend in die Endfarbe über.
Für das radial-Objekt gilt:
Gibt die Richtung des Farbverlaufs an.
•
toEdge (Standardwert)
Die Farbe geht von der Anfangsfarbe in der Mitte des Objekts nach außen verlaufend in die Endfarbe über.
•
toCenter
Die Farbe geht von der Anfangsfarbe an der Außenkante des Objekts in die Mitte verlaufend in die Endfarbe über.
Gilt für

Modell

Objekt
Formularmodell
barcode
handler
issuers
linear
oids
pattern
radial
reasons
signing
timeStamp
sourceSet-Modell
extras


typeface

Gibt den Namen der Schrift an.
Syntax
Reference_Syntax.typeface = "Courier | typeface"
Werte

Typ

Werte
Zeichenfolge
      •
      Courier (Standardwert)
      •
      Jeder gültige Schriftname.
Gilt für

Modell

Objekt
Formularmodell
font
Beispiele
JavaScript
TextField1.font.typeface = "Myriad Pro";
FormCalc
TextField1.font.typeface = "Myriad Pro"


underline

Gibt die Art der Unterstreichung und ihre Aktivierung an.
Syntax
Reference_Syntax.underline = "0 | 1 | 2"
Werte

Typ

Werte
Zeichenfolge
      •
      0 (Standardwert)
Die Schrift wird ohne Unterstriche wiedergegeben.
      •
      1
Die Schrift wird mit einfachen Unterstrichen wiedergegeben.
      •
      2
Die Schrift wird mit doppelten Unterstrichen wiedergegeben.
Gilt für

Modell

Objekt
Formularmodell
font
Beispiele
JavaScript
TextField1.font.underline = "2";
FormCalc
TextField1.font.underline = "2"


underlinePeriod

Bestimmt das Erscheinungsbild der Unterstreichung.
Syntax
Reference_Syntax.underlinePeriod = "all | word"
Werte

Typ

Werte
Zeichenfolge
      •
      all (Standardwert)
Die wiedergegebene Linie erstreckt sich über Wortumbrüche hinweg.
      •
      word
Die wiedergegebene Linie wird an den Wortumbrüchen unterbrochen.
Gilt für

Modell

Objekt
Formularmodell
font
Beispiele
JavaScript
TextField1.font.underlinePeriod = "word";
FormCalc
TextField1.font.underlinePeriod = "word"


url

Gibt die URL für dieses Objekt an.
Syntax
Reference_Syntax.url = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die eine URL für diese Node darstellt.
Gilt für

Modell

Objekt
Formularmodell
certificates


urlPolicy

(urlPolicy) Gibt den Typ der URL an, die vom Zertifikatobjekt dargestellt wird.
Die Eigenschaft entspricht dem urlType-Attribute für PDF-Dokumente. Ihre Werte werden als Browser- oder ASSP-Zeichenfolge bzw. als die Zeichenfolge kodiert, die der Benutzer für den urlType-Schlüssel eingegeben hat.
Syntax
Reference_Syntax.urlPolicy = "enrollmentServer | roamingCredentialServer | string"
Werte

Typ

Werte
Zeichenfolge
•
enrollmentServer
Die URL referenziert einen Webserver, auf dem sich der Unterzeichner für ein digitales Zertifikat registrieren kann.
•
roamingCredentialServer
Die URL referenziert einen Webdienst, der die digitale Referenz speichert, die ein Unterzeichner zum Unterschreiben eines Dokuments oder von Daten verwendet.
•
Eine gültige Zeichenfolge, die die Verwendung dieser Eigenschaft mit eindeutigen Werten erweitert.
Gilt für

Modell

Objekt
Formularmodell
certificates


usage

Gibt den Kontext an, in dem die Verbindung verwendet wird.
Syntax
Reference_Syntax.usage = "exportAndImport | exportOnly | importOnly"
Werte

Typ

Werte
Zeichenfolge
      •
      exportAndImport (Standardwert)
Wird sowohl während des Imports als auch während des Exports verwendet.
      •
      exportOnly
Wird während des Exports verwendet und während des Imports ignoriert.
      •
      importOnly
Wird während des Imports verwendet und während des Exports ignoriert.
Gilt für

Modell

Objekt
Formularmodell
connect
Beispiele
JavaScript
TextField1.connect.usage = "importOnly";
FormCalc
TextField1.connect.usage = "importOnly"


use

Ruft einen Prototyp auf.
Syntax
Reference_Syntax.use = "string"
Werte

Typ

Werte
Zeichenfolge
Der Wert dieser Eigenschaft ist ein „#“-Zeichen gefolgt von der Kennung des Prototyps.
Gilt für

Modell

Objekt
connectionSet-Modell
operation
rootElement
soapAction
soapAddress
uri
wsdlAddress
Formularmodell
arc
area
assist
barcode
bookend
boolean
border
break
breakAfter
breakBefore
button
calculate
caption
certificate
certificates
checkButton
choiceList
color
comb
connect
contentArea
corner
date
dateTime
dateTimeEdit
decimal
defaultUi
desc
draw
edge
event
exclGroup
exData
execute
exObject
extras
field
fill
filter
float
font
format
handler
image
integer
issuers
items
keep
line
linear
manifest
margin
medium
message
numericEdit
occur
oid
oids
overflow
pageArea
pageSet
para
passwordEdit
pattern
picture
radial
reason
reasons
rectangle
ref
script
signature
signatureProperties
signData
signing
solid
stipple
subform
subformSet
submit
text
textEdit
time
traversal
traverse
ui
validate
value
variables
sourceSet-Modell
boolean
command
connect
connectString
delete
extras
insert
integer
map
password
query
recordSet
select
source
sourceSet
text
update
user


usehref

Ruft einen externen Prototyp auf.
Die usehref-Eigenschaft kann nicht auf PDF-Dateien angewendet werden, selbst wenn die PDF-Dateien Objekte des XML-Formularobjektmodells enthalten.
Wenn ein Objekt sowohl eine use- als auch eine usehref-Eigenschaft enthält, hat die usehref-Eigenschaft Vorrang vor der use-Eigenschaft. Dadurch kann bei der Wiedergabe von Formularentwürfen auf älteren Systemen ein anderer Prototyp verwendet werden. Auf älteren Systemen wird die usehref-Eigenschaft ignoriert.
Um Sicherheitsprobleme zu vermeiden, geben Sie für die URI von usehref HTTPS an oder stellen Sie sicher, dass alle Prototypverweise hinter einer Firewall erfolgen.
Syntax
Reference_Syntax.usehref = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die einen externen Prototyp darstellt. Der Wert dieser Eigenschaft enthält ein „#“-Zeichen sowie die Kennung des Prototyps:
    usehref="URL#XML_ID"
    usehref="URL#ref(reference_syntax)"
Gilt für

Modell

Objekt

connectionSet-Modell
operation
rootElement
soapAction
soapAddress
uri
wsdlAddress
Formularmodell
arc
area
assist
barcode
bookend
boolean
border
break
breakAfter
breakBefore
button
calculate
caption
certificate
certificates
checkButton
choiceList
color
comb
connect
contentArea
corner
date
dateTime
dateTimeEdit
decimal
defaultUi
desc
draw
edge
event
exclGroup
exData
execute
exObject
extras
field
fill
filter
float
font
format
handler
image
imageEdit
instanceManager
integer
issuers
items
keep
line
linear
manifest
margin
medium
message
numericEdit
occur
oid
oids
overflow
pageArea
pageSet
para
passwordEdit
pattern
picture
radial
reason
reasons
rectangle
ref
script
signature
signatureProperties
signData
signedState
signing
solid
stipple
subform
subformSet
submit
text
textEdit
time
traversal
traverse
ui
validate
value
variables
sourceSet-Modell
bind
boolean
command
connect
connectString
delete
extras
insert
integer
map
password
query
recordSet
select
source
sourceSet
text
update
user


uuid

Gibt die UUID (Universally Unique Identifier) für dieses Objekt an.
Syntax
Reference_Syntax.uuid = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die die UUID (Universally Unique Identifier) für diese Node darstellt.
Gilt für

Modell

Objekt
XFA-Modell
xfa


validationMessage

Gibt die Zeichenfolge für die Überprüfungsmeldung dieses Feldes an.
Syntax
Reference_Syntax.validationMessage = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die eine Überprüfungsmeldung zum Anzeigen für den Benutzer darstellt.
Gilt für

Modell

Objekt
Formularmodell
exclGroup
field
Beispiele
JavaScript
NumericField1.validationMessage = "This is the validation message."
FormCalc
NumericField1.validationMessage = "This is the validation message."


validationsEnabled

Gibt an, ob die Überprüfungsskripten ausgeführt werden.
Syntax
Reference_Syntax.validationsEnabled = "0 | 1"
Werte

Typ

Werte
Boolescher Wert
      •
      0 (Standardwert)
Überprüfungsskripten sind deaktiviert.
      •
      1
Überprüfungsskripten sind aktiviert.
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.validationsEnabled = "1";
FormCalc
xfa.host.validationsEnabled = "1"


vAlign

Gibt die vertikale Textausrichtung an.
Syntax
Reference_Syntax.vAlign = "top | middle | bottom"
Werte

Typ

Werte
Zeichenfolge
      •
      top (Standardwert)
Auf den oberen Rand des verfügbaren Bereichs ausrichten.
      •
      middle
Vertikal innerhalb des verfügbaren Bereichs zentrieren.
      •
      bottom
Auf den unteren Rand des verfügbaren Bereichs ausrichten.
Gilt für

Modell

Objekt
Formularmodell
draw
exclGroup
field
para
subform
Beispiele
JavaScript
TextField1.vAlign = "top";
FormCalc
TextField1.vAlign = "top"


value

Gibt den Wert des aktuellen Objekts an.
Gibt für jede Farbkomponente des Farbspektrums eine durch Kommata getrennte Werteliste an.
Syntax
Reference_Syntax.value = "various"
Werte

Typ

Werte
Variabel
Die Werte unterscheiden sich abhängig vom referenzierenden Objekt.
Beispielsweise ist die value-Eigenschaft eines field-Objekts eine Zeichenfolge, die den tatsächlichen, im Feld angezeigten Wert oder den Bindewert des Feldes darstellt.
Alternativ dazu gibt diese Eigenschaft bei Objekten, die einen Farbwert erfordern, eine Liste mit kommagetrennten Werten für jede Farbkomponente des Farbraums an. Für den Farbraum SRGB sind die Komponentenwerte r,g,b erforderlich. Dabei steht r für den roten Komponentenwert, g für den grünen Komponentenwert und b für den blauen Komponentenwert. Jeder Komponentenwert muss innerhalb des Wertebereichs von 0 bis 255 (einschließlich) liegen. Der Wert 255 stellt die maximale Anzeigeintensität dar. Mit 255,0,0 wird beispielsweise die Farbe Rot angegeben.
Die Standardeinstellung hängt davon ab, in welchem Kontext die Farbe verwendet wird. Die Standardfarbe wird von dem Objekt bestimmt, das das Farbobjekt umschließt.
Gilt für

Modell

Objekt
Datenmodell
dataValue
Formularmodell
boolean
color
date
dateTime
decimal
float
image
integer
picture
script
text
time
sourceSet-Modell
boolean
integer
text
Gilt auch für Objekte, die von der textNode-Klasse abgeleitet sind.
Beispiele
JavaScript
// Use the value property to set and get the document variable’s value.
TextField1.rawValue = docVar.value;
FormCalc
// Use the value property to set and get the document variable’s value.
TextField1 = docVar.value


valueRef

Löst einen Datenwert für alle durch das ref-Objekt angegebenen Daten-Nodes in der Gruppe auf.
Mit den Datenwerten werden anschließend die Wertelemente, wie z. B. <items save='1'>, gefüllt.
Die valueRef-Eigenschaft ist ein relativer Ausdruck der Referenz-Syntax.
Diese Eigenschaft ist schreibgeschützt.
Syntax
Reference_Syntax.valueRef = "string"
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, die einen Datenwert für alle Daten-Nodes in der Gruppe darstellt.
Gilt für

Modell

Objekt
Formularmodell
bindItems


variation

Gibt die Verpackung der Anwendung an, die das Skript ausführt.
Nur für Client-Anwendungen verfügbar.
Diese Eigenschaft ist schreibgeschützt.
Syntax
Reference_Syntax.variation
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, welche die Verpackung der Anwendung angibt. Bei einem PDF-Formular in Acrobat gibt diese Eigenschaft beispielsweise Folgendes zurück: Reader, Fill-in, Business Tools oder Full.
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.variation;
FormCalc
xfa.host.variation


version

Gibt die Versionsnummer der aktuellen Anwendung an.
Diese Eigenschaft ist schreibgeschützt.
Syntax
Reference_Syntax.version
Werte

Typ

Werte
Zeichenfolge
Eine gültige Zeichenfolge, welche die Verpackung der Anwendung angibt. Beispiel: In Acrobat 6.0.1 gibt diese Eigenschaft 6.0.1 zurück.
Gilt für

Modell

Objekt
Formularmodell
handler
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.version;
FormCalc
xfa.host.version


vScollPolicy

Gibt an, ob in einem Feld der vertikale Bildlauf verfügbar ist.
Diese Eigenschaft findet keine Anwendung für Textfelder, die sich erweitern können, um Daten oder Text aufzunehmen.
Syntax
Reference_Syntax.hScrollPolicy = "auto | on | off"
Werte

Typ

Werte
Zeichenfolge
      •
      auto (Standardwert)
Einzeilige Felder bieten einen horizontalen Bildlauf und mehrzeilige Felder einen vertikalen Bildlauf (bei Bedarf wird eine vertikale Bildlaufleiste angezeigt).
      •
      on
Vertikale und/oder horizontale Bildlaufleisten werden unabhängig davon angezeigt, ob der Text bzw. die Daten über die Grenzen des Feldes fließt bzw. fließen.
      •
      off
Beschränkt die Eingabe von Zeichen im Feld durch den Benutzer auf die Anzahl von Zeichen, die physisch in die Feldbreite passt. Beachten Sie, dass diese Einschränkung nicht für Daten im Feld gilt.
Gilt für

Modell

Objekt
Formularmodell
textEdit
Beispiele
JavaScript
TextField1.resolveNode("ui.#textEdit").vScrollPolicy = "off";
FormCalc
TextField1.ui.#textEdit.vScrollPolicy = "off"


w

Eine Maßeinheit für die Breite des Layouts.
Wenn Sie eine Breite angeben, überschreibt dieser Wert alle durch die Eigenschaften minW und maxW erlaubten Wachstumsbereiche. Wird diese Eigenschaft nicht definiert oder erfolgt die Angabe einer leeren Zeichenfolge, wird die Breite des Objekts durch die Eigenschaften minW und maxW definiert.
Syntax
Reference_Syntax.w = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
contentArea
draw
exclGroup
field
subform
Beispiele
JavaScript
TextField1.w = "3in";
FormCalc
TextField1.w = "3in"


weight

Steuert die Schriftbreite.
Syntax
Reference_Syntax.weight = "bold | normal"
Werte

Typ

Werte
Zeichenfolge
      •
      bold (Standardwert)
Die Schrift wird fett formatiert wiedergegeben.
      •
      normal
Die Schrift wird mit der Standardschriftbreite dargestellt.
Gilt für

Modell

Objekt
Formularmodell
font
Beispiele
JavaScript
TextField1.font.weight = "normal";
FormCalc
TextField1.font.weight = "normal"


wideNarrowRatio

Gibt das Verhältnis der breiten und schmalen Balken in unterstützten Barcodes an.
Der zulässige Bereich für das Verhältnis ist je nach Barcodeformat (bei Hardware-Barcodes je nach Ausgabegerät) unterschiedlich. Die Vorlage darf keinen Wert außerhalb des zulässigen Bereichs angeben. Der Parser ignoriert diese Eigenschaft für Barcodeformate, die kein variables Verhältnis von breiten und schmalen Balkenbreiten zulassen.
Syntax
Reference_Syntax.wideNarrowRatio = "3:1 | wide[:narrow]"
Werte

Typ

Werte
Zeichenfolge
      •
      3:1 (Standardwert)
Ein beliebiges Verhältnis, das die folgende Syntax verwendet:
      •
      wide[:narrow]
Dabei ist wide eine positive Zahl, die den Zähler des Quotienten darstellt, und narrow eine optional positive Zahl, die den Nenner des Quotienten darstellt.
Wenn narrow nicht angegeben wird, wird der Standardwert 1 verwendet.
Gilt für

Modell

Objekt
Formularmodell
barcode
Beispiele
JavaScript
Barcode1.resolveNode("ui.#barcode").wideNarrowRatio = "5:1";
FormCalc
Barcode1.ui.#barcode.wideNarrowRatio = "5:1"


x

Gibt die X-Koordinate des Container-Verankerungspunkts im Verhältnis zur oberen, linken Ecke des übergeordneten Containers bei der Platzierung in einem positionierten Layout an.
Container mit fließendem Inhalt verwenden keine X-Koordinaten.
Syntax
Reference_Syntax.x = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
area
contentArea
draw
exclGroup
field
subform
Beispiele
JavaScript
TextField1.x = "5in";
FormCalc
TextField.x = "5in"


xdpContent

Steuert, welche Untermenge von Daten übergeben wird. Diese Eigenschaft wird nur berücksichtigt, wenn für die format-Eigenschaft xdp verwendet wird.
Syntax
Reference_Syntax.xdpContent = "string"
Werte

Typ

Werte
Zeichenfolge
      •
      datasets pdf xfdf (Standardwert)
Übergibt Objekte mit den Tags „datasets“, „pdf“ und „xfdf“ an den Host.
      •
      tag1 tag2 ... tagN
Übergibt Objekte mit Tags, die den angegebenen Tags entsprechen.
      •
      * (Sternchen)
Übergibt alle Datenobjekte an den Host.
Gilt für

Modell

Objekt
Formularmodell
submit
Beispiele
JavaScript
Button1.resolveNode("#event.#submit").xdpContent = "*"
FormCalc
Button1.#event.#submit.xdpContent = "*"


y

Gibt die Y-Koordinate eines Container-Verankerungspunkts im Verhältnis zur oberen, linken Ecke des übergeordneten Containers bei der Platzierung in einem positionierten Layout an.
Container mit fließendem Inhalt verwenden keine Y-Koordinaten.
Syntax
Reference_Syntax.y = "0in | measurement"
Werte

Typ

Werte
Zeichenfolge
      •
      0in (Standardwert)
      •
      Jede gültige Maßeinheit.
Gilt für

Modell

Objekt
Formularmodell
area
contentArea
draw
exclGroup
field
subform
Beispiele
JavaScript
TextField1.y = "5in";
FormCalc
TextField.y = "5in"


Skriptmethoden

absPage
absPageCount
absPageSpan
addInstance
addItem
addNew
append
applyXSL
assignNode
beep
boundItem
cancel
cancelBatch
clear
clearErrorList
clearItems
clone
close
createNode
delete
emit
enumerate
evaluate
execCalculate
execEvent
execInitialize
execute
execValidate
exportData
first
formNodes
getAttribute
getElement
gotoRecord
gotoURL
h
hasDataChanged
importData
insert
insertInstance
isBOF
isCompatibleNS
isEOF
isPropertySpecified
isRecordGroup
item
last
loadXML
messageBox
moveCurrentRecord
moveInstance
namedItem
next
open
openList
Seite
pageContent
pageCount
pageDown
pageSpan
pageUp
previous
print
recalculate
record
relayout
relayoutPageArea
remerge
remove
removeAttribute
removeInstance
requery
reset
resetData
resolveNode
resolveNodes
response
resync
saveFilteredXML
saveXML
selectedMember
setAttribute
setElement
setFocus
setInstance
sign
update
updateBatch
verify
w
x
y
Dieser Abschnitt enthält eine alphabetische Liste aller Methoden, die in dieser Skripterstellungsumgebung unterstützt werden.
Die einzelnen Hosts, wie z. B. Acrobat und Adobe Reader sind für die Implementierung der verfügbaren Methoden verantwortlich. Einige Methoden sind für einen Server nicht sinnvoll, wie z. B. die beep-Methode. Der Server implementiert diese Methoden nicht und kann stattdessen eine Fehlermeldung ausgeben, wenn ein Benutzer versucht, die Methode aufzurufen.


absPage

Stellt fest, auf welcher Seite des Formulars ein bestimmtes Formularentwurfsobjekt zuerst vorkommt.
Syntax
Reference_Syntax.absPage( OBJECT param )
Parameter
param
Der vollständig qualifizierte Ausdruck der Referenz-Syntax eines der folgenden Formularentwurfsobjekte: field, draw, subform, area, pageArea, contentArea.
Rückgabe
Eine Ganzzahl, welche die Seite des Formulars darstellt (Null-basiert). Diese Methode gibt -1 zurück, wenn das in param angegebene Objekt im Formular nicht gefunden werden kann.
Gilt für

Modell

Objekt
Layoutmodell
layoutPseudoModel
Beispiele
JavaScript
TextField2.rawValue = xfa.layout.absPage(this);
FormCalc
TextField2 = xfa.layout.absPage($)


absPageCount

Stellt die Seitenzahl des aktuellen Formulars fest.
Syntax
Reference_Syntax.absPageCount()
Parameter
Keine
Rückgabe
Eine Ganzzahl, welche die Anzahl der Seiten im aktuellen Formular darstellt.
Gilt für

Modell

Objekt
Layoutmodell
layoutPseudoModel
Beispiele
JavaScript
TextField2.rawValue = xfa.layout.absPageCount();
FormCalc
TextField2 = xfa.layout.absPageCount()


absPageSpan

Stellt fest, wie viele Formularseiten ein bestimmtes Formularentwurfsobjekt umfasst.
Syntax
Reference_Syntax.absPageSpan( OBJECT param )
Parameter
param
Der vollständig qualifizierte Ausdruck der Referenz-Syntax eines der folgenden Formularentwurfsobjekte: field, draw, subform, area, pageArea, contentArea.
Rückgabe
Eine Ganzzahl, welche die Anzahl der Seiten darstellt, die das angegebene Formularentwurfsobjekt umfasst. Diese Methode gibt -1 zurück, wenn das in param angegebene Objekt im Formular nicht gefunden werden kann.
Gilt für

Modell

Objekt
Layoutmodell
layoutPseudoModel
Beispiele
JavaScript
xfa.layout.absPageSpan(Subform1);
FormCalc
xfa.layout.absPageSpan(Subform1)


addInstance

Fügt dem Formularmodell eine neue Instanz eines Teilformulars oder Teilformularsatzes hinzu.
Syntax
Reference_Syntax.addInstance( BOOLEAN param )
Parameter
param (Optional)
Gibt an, ob das neue Teilformular bzw. der Teilformularsatz über einen entsprechenden Datenwert im Datenmodell verfügt.
      •
      True (Standardwert)
Führt das neue Teilformular bzw. den Teilformularsatz und das Datenmodell zusammen.
      •
      False
Kein Zusammenführungsvorgang
Rückgabe
Das neue Formularobjekt oder Null, wenn kein Objekt hinzugefügt wurde.
Gilt für

Modell

Objekt
Formularmodell
instanceManager
Beispiele
JavaScript
Subform1.instanceManager.addInstance(1);
FormCalc
Subform1.instanceManager.addInstance(1)


addItem

Fügt dem aktuellen Formularfeld neue Elemente hinzu. Mit dieser Methode werden einer Dropdown-Liste beispielsweise neue Elemente hinzugefügt.
Syntax
Reference_Syntax.addItem( STRING param1 [, STRING param2 ] )
Parameter
param1 | Eine gültige Zeichenfolge, die den in diesem Feld anzuzeigenden Wert darstellt.
param2 (Optional) | Eine gültige Zeichenfolge, die den Bindewert des neuen Elements darstellt. Falls leer, ist der Standardwert eine leere Zeichenfolge.
Rückgabe
Leer
Gilt für

Modell

Objekt
Formularmodell
field
Beispiele
JavaScript
DropDownList1.addItem("Human Resources");
FormCalc
DropDownList1.addItem("Human Resources")


addNew

Fügt der Datensatzgruppe einen neuen Datensatz hinzu.
Syntax
Reference_Syntax.addNew()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
sourceSet-Modell
source
Beispiele
JavaScript
xfa.sourceSet.dataConnectionName.addNew();
FormCalc
xfa.sourceSet.dataConnectionName.addNew();


append

Fügt am Ende der Node-Liste eine Node an.
Syntax
Reference_Syntax.append( OBJECT param )
Parameter
param
Ein gültiger Ausdruck der Referenz-Syntax, der die anzufügende Node darstellt.
Rückgabe
Leer
Gilt für
treeList-Klasse
Beispiele
JavaScript
// Append a data group node to another data model node.
xfa.record.nodes.append(oGroupNode);
FormCalc
// Append a data group node to another data model node.
xfa.record.nodes.append(oGroupNode)


applyXSL

Wendet eine XSL-Transformation auf die XML-Darstellung der aktuellen Node an. Diese Methode entspricht dem Aufruf von saveXML und der Transformation des Ergebnisses mit dem angegebenen XSL-Dokument.
Syntax
Reference_Syntax.applyXSL( STRING param )
Parameter
param
Eine gültige Zeichenfolge, welche die anzuwendende Eingabe für die XSL-Transformation darstellt.
Rückgabe
Eine gültige Zeichenfolge, die das Ergebnis der XSL-Transformation darstellt.
Gilt für
node-Klasse


assignNode

Wertet den Ausdruck der Referenz-Syntax mit Hilfe des aktuellen Kontexts aus und legt den Wert der gefundenen Node fest. Wenn die Node nicht vorhanden ist, kann sie erstellt werden.
Syntax
Reference_Syntax.assignNode( STRING param1 [, STRING param2 [, INTEGER param3 ] ] )
Parameter
param1
Eine gültige Zeichenfolge, die einen Ausdruck der Referenz-Syntax darstellt, der auf eine bestimmte Node verweist.
param2 (Optional)
Eine gültige Zeichenfolge, die den Wert darstellt, der der Node zuzuordnen ist.
param3 (Optional)
Ein Ganzzahlwert, der die Aktion darstellt, die beim Erstellen neuer Nodes durchgeführt wird. Folgende Parameterwerte sind gültig:
      •
      0
Wenn die Node vorhanden ist, wird der Wert aktualisiert. Ist die Node nicht vorhanden, wird sie erstellt.
      •
      1
Wenn die Node vorhanden ist, wird ein Fehler ausgegeben. Ist die Node nicht vorhanden, wird sie erstellt.
      •
      2
Wenn die Node vorhanden ist, wird keine Aktion durchgeführt. Ist die Node nicht vorhanden, wird sie erstellt.
      •
      3
Es wird immer eine neue Node erstellt.
Rückgabe
Ein Objekt, das der angegebenen Node entspricht.
Gilt für
node-Klasse


beep

Lässt das System einen Klang abspielen. Nur für Client-Anwendungen verfügbar.
Syntax
Reference_Syntax.beep( [ INTEGER param ] )
Parameter
param (Optional)
Der Systemcode für den entsprechenden Klang.
      •
      0 (Fehler)
      •
      1 (Warnung)
      •
      2 (Frage)
      •
      3 (Status)
      •
      4 (Standard - Die Zeichenfolge, die den Anzeigewert darstellt.)
Rückgabe
Leer
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.beep("2");
FormCalc
xfa.host.beep("2")


boundItem

Ruft den Bindewert eines bestimmten Anzeigeelements aus einer Dropdown-Liste oder einem Listenfeld ab.
Syntax
Reference_Syntax.boundItem( STRING param )
Parameter
param
Eine gültige Zeichenfolge, die den Anzeigewert darstellt, der im Listenfeld oder in der Dropdown-Liste angezeigt wird.
Rückgabe
Eine gültige Zeichenfolge, die den Bindewert eines angegebenen Anzeigewerts darstellt.
Gilt für

Modell

Objekt
Formularmodell
field
Beispiele
JavaScript
DropDownList1.boundItem("Text");
FormCalc
DropDownList1.boundItem("Text")


cancel

Storniert vor dem Aufruf der update-Methode alle Änderungen, die an der derzeitigen oder neuen Zeile eines Datensatzobjekts oder an der Feldsammlung eines Datensatzobjekts vorgenommen wurden.
Syntax
Reference_Syntax.cancel()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
sourceSet-Modell
source
Beispiele
JavaScript
xfa.sourceSet.dataConnectionName.cancel();
FormCalc
xfa.sourceSet.dataConnectionName.cancel()


cancelBatch

Bricht eine anstehende Batch-Aktualisierung ab.
Syntax
Reference_Syntax.cancelBatch()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
sourceSet-Modell
source


clear

Entfernt eine vorhandene Unterschrift.
Syntax
Reference_Syntax.clear( OBJECT param1 [, BOOLEAN param2 ] )
Parameter
param1
input
Eine gültige XML-Unterschrifts-Node.
param2 (Optional)
input (Optional)
      •
      True (Standardwert)
Gibt an, dass für diesen Vorgang ein Dialogfeld verwendet wird.
      •
      False
Gibt an, dass für diesen Vorgang kein Dialogfeld verwendet wird.
Rückgabe
True, wenn die Unterschrift erfolgreich entfernt wurde, und False, wenn die Unterschrift nicht erfolgreich entfernt wurde.
Gilt für

Modell

Objekt
Unterschriftsmodell
signaturePseudoModel


clearErrorList

Entfernt alle Elemente aus dem aktuellen Fehlerprotokoll.
Syntax
Reference_Syntax.clearErrorList()
Parameter
Keine
Rückgabe
Leer
Gilt für
model-Klasse


clearItems

Entfernt alle Elemente aus dem Feld. Es werden beispielsweise alle Elemente in der Dropdown-Liste oder im Listenfeld entfernt.
Syntax
Reference_Syntax.clearItems()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
Formularmodell
field
Beispiele
JavaScript
DropDownList1.clearItems();
FormCalc
DropDownList1.clearItems()


clone

Erstellt eine Kopie eines Objekts.
Syntax
Reference_Syntax.clone( BOOLEAN param )
Parameter
param
Ein boolescher Wert, der angibt, ob rekursiv geklont werden soll.
      •
      True (Standardwert)
Das Objekt rekursiv klonen.
      •
      False
Das Objekt nicht rekursiv klonen.
Rückgabe
Die duplizierte Kopie des Objekts.
Gilt für
node-Klasse
Beispiele
JavaScript
xfa.record.NewGroupNode.clone(1);
FormCalc
xfa.record.NewGroupNode.clone(1)


close

Schließt eine Verbindung mit einer Datenquelle.
Syntax
Reference_Syntax.close()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
sourceSet-Modell
source
Beispiele
JavaScript
xfa.sourceSet.nodes.item(nIndex).close();
FormCalc
xfa.sourceSet.nodes.item(nIndex).close()


createNode

Erstellt eine neue Node auf Basis eines gültigen Klassennamens.
Syntax
Reference_Syntax.createNode( STRING param1 [, STRING param2 [, STRING param3 ] ] )
Parameter
param1 | Eine gültige Zeichenfolge, die den Klassennamen des zu erstellenden Objekts darstellt.
param2 (Optional) | Eine gültige Zeichenfolge, die den Namen darstellt, der der Node zuzuordnen ist. Ist diese Zeichenfolge leer, dann ist der Standardwert dieses Parameters eine leere Zeichenfolge.
param3 (Optional) | Eine gültige Zeichenfolge, die den XML-Namespace darstellt, in dem sich die erstellte Node befindet. Ist diese Zeichenfolge leer, dann ist der Standardwert dieses Parameters eine leere Zeichenfolge.
Rückgabe
Ein Objekt, das eine gültige Node darstellt.
Gilt für
model-Klasse
Beispiele
JavaScript
// Create a node of type dataGroup.
var oGroupNode = xfa.datasets.createNode("dataGroup", "NewGroupNode");
FormCalc
// Create a node of type dataGroup.
var oGroupNode = xfa.datasets.createNode("dataGroup", "NewGroupNode")


delete

Löscht den aktuellen Datensatz aus der Datensatzgruppe.
Syntax
Reference_Syntax.delete()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
sourceSet-Modell
source
Beispiele
JavaScript
xfa.sourceSet.dataConnectionName.delete();
FormCalc
xfa.sourceSet.dataConnectionName.delete()


emit

Benachrichtigt den Ereignis-Manager über das Eintreten eines Ereignisses.
Syntax
Reference_Syntax.emit()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
Ereignismodell
eventPseudoModel
Beispiele
JavaScript
xfa.event.emit();
FormCalc
xfa.event.emit()


enumerate

Führt alle im Dokument gefundenen XML-Unterschriften auf.
Syntax
Reference_Syntax.enumerate()
Parameter
Keine
Rückgabe
Ein Objekt, das eine XFA-Node-Liste aller XML-Unterschrifts-Nodes darstellt.
Gilt für

Modell

Objekt
Unterschriftsmodell
signaturePseudoModel


evaluate

Ruft die Liste der Objekte ab, auf die im Manifest verwiesen wird.
Syntax
Reference_Syntax.evaluate()
Parameter
Keine
Rückgabe
Ein Objekt, das eine Liste mit Objekten darstellt.
Gilt für

Modell

Objekt
Formularmodell
manifest


execCalculate

Führt das Berechnungsskript des Feldes aus.
Syntax
Reference_Syntax.execCalculate()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
Formularmodell
exclGroup
field
form
subform
Beispiele
JavaScript
TextField1.execCalculate();
FormCalc
TextField1.execCalculate()


execEvent

Führt das Ereignisskript des Objekts aus.
Syntax
Reference_Syntax.execEvent( STRING param )
Parameter
param
Eine gültige Zeichenfolge, die den Namen des auszuführenden Ereignisses darstellt.
Rückgabe
Leer
Gilt für

Modell

Objekt
Formularmodell
exclGroup
field
subform
Beispiele
JavaScript
Button1.execEvent("click");
FormCalc
Button1.execEvent("click")


execInitialize

Führt das Initialisierungsskript des Feldes aus.
Syntax
Reference_Syntax.execInitialize()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
Formularmodell
exclGroup
field
form
subform
Beispiele
JavaScript
Subform1.execInitialize();
FormCalc
Subform1.execInitialize()


execute

Führt eine Verbindung aus.
Syntax
Reference_Syntax.execute( BOOLEAN param )
Parameter
param
      •
      True (Standardwert)
Erzwingt das erneute Zusammenführen des Formularentwurfs und der importierten WSDL-Daten.
      •
      False
Importiert die WSDL-Daten in das aktuelle Formular, ohne sie mit dem Formularentwurf zusammenzuführen.
Rückgabe
True, wenn die Verbindung erfolgreich ausgeführt wurde, und False, wenn sie nicht erfolgreich ausgeführt wurde.
Gilt für

Modell

Objekt
connectionSet-Modell
wsdlConnection


execValidate

Führt das Überprüfungsskript des Feldes aus.
Syntax
Reference_Syntax.execValidate()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
Formularmodell
field
form
subform
Beispiele
JavaScript
NumericField1.execValidate();
FormCalc
NumericField1.execValidate()


exportData

Exportiert die Daten aus dem aktuellen Formular im XDP- oder XML-Format in eine Datei.
Aus Sicherheitsgründen wird beim Angeben des ersten Parameters die exportData-Methode nur bei zertifizierten Dokumenten ausgeführt. Geben Sie den ersten Parameter nicht an, ist kein zertifiziertes Dokument erforderlich und der Benutzer wird zur Angabe eines Speicherorts und Dateinamens aufgefordert.
Syntax
Reference_Syntax.exportData( [ STRING param1 [, BOOLEAN param2 ] ])
Parameter
param1 (Optional)
Gibt die Position und den Dateinamen der Datei an, in die die Daten exportiert werden. Wenn Sie diesen Parameter weglassen, wird ein Dialogfeld geöffnet, in dem der Anwender die Datei manuell wählen kann.
Dieser Parameter ist nur bei zertifizierten Dokumenten gültig, wenn der Anwender hinreichende Berechtigungen besitzt.
param2 (Optional)
Gibt das Exportformat für die Daten an.
      •
      True (Standardwert)
Export in das XDP-Format.
      •
      False
Export als reine XML-Daten.
Um den Exporttyp zu ändern, ohne einen Dateinamen festzulegen, müssen Sie als ersten Parameter eine leere Zeichenfolge angeben. Beispiel:
xfa.host.exportData("",0)
Rückgabe
Leer
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.exportData("filename.xdp");
FormCalc
xfa.host.exportData("filename.xdp")


first

Wechselt zum ersten Datensatz in der Datensatzgruppe und füllt das Datenmodell mit den Daten aus dem Datensatz.
Die Datenverbindungsmethode xfa.sourceSet.DataConnection.first sucht eine Tabelle und aktualisiert sie, wenn sich die Daten geändert haben. Sie verwendet die hasDataChanged-Methode, um zu ermitteln, ob sich die Daten geändert haben.
Syntax
Reference_Syntax.first()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
sourceSet-Modell
source
Beispiele
JavaScript
xfa.sourceSet.dataConnectionName.first();
FormCalc
xfa.sourceSet.dataConnectionName.first()


formNodes

Gibt eine Liste mit allen Formularmodellobjekten zurück, die an ein bestimmtes Datenobjekt gebunden sind.
Syntax
Reference_Syntax.formNodes( OBJECT param )
Parameter
param
Ein gültiger Ausdruck der Referenz-Syntax, der ein Datenmodellobjekt darstellt.
Rückgabe
Ein Objekt, das die Liste aller Formularmodellobjekte darstellt, die eine Beziehung mit dem angegebenen Datenobjekt aufweisen.
Gilt für

Modell

Objekt
Formularmodell
form


getAttribute

Ruft den Wert einer angegebenen Eigenschaft ab.
Syntax
Reference_Syntax.getAttribute( STRING param )
Parameter
param
Eine gültige Zeichenfolge, die den Namen der abzurufenden Eigenschaft darstellt.
Rückgabe
Eine gültige Zeichenfolge, die den Wert der Eigenschaft darstellt.
Gilt für

Modell

Objekt
XFA-Modell
packet
Gilt auch für die node-Klasse.
Beispiele
JavaScript
var sBOFBackup = oDB.nodes.item(nIndex).query.recordSet.getAttribute("bofAction");
FormCalc
var sBOFBackup = oDB.nodes.item(nIndex).query.recordSet.getAttribute("bofAction")


getElement

Gibt eine angegebene Objekteigenschaft zurück.
Syntax
Reference_Syntax.getElement( STRING param1 [, INTEGER param2 ] )
Parameter
param1 | Eine gültige Zeichenfolge, die den Namen des abzurufenden Objekts darstellt.
param2 (Optional) | Ein Ganzzahlwert, der die Instanz des abzurufenden Objekts darstellt.
Rückgabe
Das angegebene Objekt.
Gilt für
node-Klasse


gotoRecord

Verschiebt den aktuellen Datensatz des Datenfensters in einen bestimmten Datensatz innerhalb des Datensatzbereichs in den Daten.
Syntax
Reference_Syntax.gotoRecord( INTEGER param )
Parameter
param
Ein gültiger Ganzzahlwert, der den angegebenen Datensatz im Bereich der Datensätze darstellt.
Rückgabe
Leer
Gilt für

Modell

Objekt
Datenmodell
dataWindow
Beispiele
JavaScript
xfa.dataWindow.gotoRecord(2);
FormCalc
xfa.dataWindow.gotoRecord(2)


gotoURL

Ruft die angegebene URL ab. Nur für Client-Anwendungen verfügbar.
Syntax
Reference_Syntax.gotoURL( STRING param1 [, BOOLEAN param2 ] )
Parameter
param1
Eine gültige Zeichenfolge, die eine vollständig qualifizierte oder eine relative URL darstellt. Am Ende der URL kann eine Abfragezeichenfolge eingefügt werden.
Wenn das Formular in einem Browser angezeigt wird oder Acrobat Capture® nicht verfügbar ist, ruft das Weblink-Zusatzmodul die gewünschte URL ab. Wenn das Formular in Acrobat ausgeführt wird, erfolgt das Abrufen der URL des aktuellen Dokuments von der Basis-URL des Dokuments, von der URL der Seite 0 (wenn das Dokument mit Web Capture heruntergeladen wurde) oder vom Dateisystem.
param2 (Optional)
      •
      True (Standardwert)
Hängt die Seiten an das aktuelle Dokument an.
      •
      False
Die Kennzeichnung ist „False“, wenn das Dokument im Webbrowser ausgeführt wird, das Acrobat Capture-Zusatzmodul nicht verfügbar ist oder die URL vom Typ „file:///“ ist.
Rückgabe
Leer
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.gotoURL("http://www.adobe.com");
FormCalc
xfa.host.gotoURL("http://www.adobe.com")


h

Bestimmt die Höhe eines angegebenen Formularentwurfsobjekts.
Syntax
Reference_Syntax.h( OBJECT param1 [, STRING param2 [, INTEGER param3 ] ] )
Parameter
param1 | Der vollständig qualifizierte Ausdruck der Referenz-Syntax eines der folgenden Container-Formularentwurfsobjekte: field, draw, subform, area, pageArea, contentArea.
param2 (Optional) | Eine Zeichenfolge, die den Einheitentyp des Rückgabewerts darstellt. Wenn nichts eingegeben wird, besteht der Standardeinheitentyp aus Punkten.
param3 (Optional) | Eine Ganzzahl, die den Versatz des Werts für die Höhe eines Formularentwurfsobjekts, beginnend mit der ersten Seite, auf der das Objekt auftritt, darstellt. Wenn nichts eingegeben wird, ist der Standardwert 0.
Rückgabe
Die Höhe des Formularentwurfsobjekts.
Gilt für

Modell

Objekt
Layoutmodell
layoutPseudoModel
Beispiele
JavaScript
xfa.layout.h(TextField1,"in");
FormCalc
xfa.layout.h(TextField1,"in")


hasDataChanged

Stellt fest, ob die aktuellen Datensatzdaten verändert wurden. Hierbei handelt es sich um einen Test des aktiven Datensatzes vor dem Festschreiben. Bei diesem Test werden die aktuellen Datensatzdaten mit den Datensatzdaten aus der aktuellen Datenquelle verglichen. Wenn die Daten geändert wurden, gibt diese Methode den Wert True zurück.
Die Datenverbindungsmethoden xfa.sourceSet.DataConnection.first, xfa.sourceSet.DataConnection.next, xfa.sourceSet.DataConnection.previous und xfa.sourceSet.DataConnection.last führen eine implizite Aktualisierung durch, wenn die Daten geändert wurden.
Syntax
Reference_Syntax.hasDataChanged()
Parameter
Keine
Rückgabe
True, wenn die Daten geändert wurden, und False, wenn die Daten nicht geändert wurden.
Gilt für

Modell

Objekt
sourceSet-Modell
source


importData

Importiert Daten aus einer angegebenen Datei in das aktuelle Formular.
Aus Sicherheitsgründen wird die importData-Methode beim Angeben des Parameters nur bei zertifizierten Dokumenten ausgeführt. Geben Sie den Parameter nicht an, ist kein zertifiziertes Dokument erforderlich und der Benutzer wird zur Angabe eines Speicherorts und Dateinamens aufgefordert.
Syntax
Reference_Syntax.importData( [ STRING param ] )
Parameter
param (Optional)
Eine gültige Zeichenfolge, die den Speicherort und Namen der Datei darstellt, aus der die Daten importiert werden. Wenn Sie diesen Parameter weglassen, wird ein Dialogfeld geöffnet, in dem der Anwender die Datei manuell wählen kann.
Dieser Parameter ist nur bei zertifizierten Dokumenten gültig, wenn der Anwender hinreichende Berechtigungen besitzt.
Rückgabe
Leer
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.importData("filename.xdp");
FormCalc
xfa.host.importData("filename.xdp")


insert

Fügt eine Node vor einer angegebenen Node in der Node-Liste ein.
Syntax
Reference_Syntax.insert( OBJECT param1, OBJECT param2 )
Parameter
param1 | Ein gültiger Ausdruck der Referenz-Syntax, der die einzufügende Node darstellt.
param2 | Ein gültiger Ausdruck der Referenz-Syntax, der die zuvor einzufügende Node darstellt.
Rückgabe
Leer
Gilt für
treeList-Klasse
Beispiele
JavaScript
xfa.datasets.connectionData.DataConnection.nodes.insert(oHeader,oFirst);
FormCalc
xfa.datasets.connectionData.DataConnection.nodes.insert(oHeader,oFirst)


insertInstance

Fügt eine neue Instanz eines Teilformulars oder Teilformularsatzes in ein Formular ein.
Syntax
Reference_Syntax.insertInstance( INTEGER param1 [, BOOLEAN param2 ] )
Parameter
param1
Ein Ganzzahlwert, der die Null-basierte Indexposition für das Einfügen der Instanz in einen Satz von Instanzen angibt.
param2
(optional)
Ein boolescher Wert, der angibt, ob Daten mit der neuen Teilformular-Instanz zusammengeführt werden sollen.
      •
      True
Führt die neue Teilformular-Instanz mit den verfügbaren Daten zusammen.
      •
      False
Die neue Teilformular-Instanz wird nicht mit Daten zusammengeführt.
Rückgabe
Ein Objekt, das die neue Instanz des Teilformulars oder des Teilformularsatzes darstellt.
Gilt für

Modell

Objekt
sourceSet-Modell
source
Beispiele
JavaScript
Subform1.instanceManager.insertInstance(3, false);
FormCalc
Subform1.instanceManager.insertInstance(3, false)


isBOF

Stellt fest, ob sich die aktuelle Position am Anfang des Datensatzes befindet.
Die bofAction-Eigenschaft muss auf stayBOF eingestellt sein.
Syntax
Reference_Syntax.isBOF()
Parameter
Keine
Rückgabe
True, wenn sich die aktuelle Position am Anfang des Datensatzes befindet, und False, wenn sie sich nicht am Anfang des Datensatzes befindet.
Gilt für

Modell

Objekt
sourceSet-Modell
source
Beispiele
JavaScript
xfa.sourceSet.nodes.item(nIndex).isBOF();
FormCalc
xfa.sourceSet.nodes.item(nIndex).isBOF()


isCompatibleNS

Stellt fest, ob ein angegebener Namespace in der Funktion dem Namespace dieses Modells entspricht, d. h. mit diesem kompatibel ist. Diese Methode stellt fest, ob die beiden Namespaces einander entsprechen, auch wenn die Zeichenfolgen, mit denen sie dargestellt werden, nicht identisch sind.
Syntax
Reference_Syntax.isCompatibleNS( STRING param )
Parameter
param
Eine gültige Zeichenfolge, die den zu vergleichenden Namespace darstellt.
Rückgabe
True, wenn die Namespaces einander entsprechen, und False, wenn sie nicht kompatibel sind.
Gilt für
model-Klasse


isEOF

Stellt fest, ob sich die aktuelle Position am Ende des Datensatzes befindet.
Die eofAction-Eigenschaft muss auf stayEOF eingestellt sein.
Syntax
Reference_Syntax.isEOF()
Parameter
Keine
Rückgabe
True, wenn sich die aktuelle Position am Ende des Datensatzes befindet, und False, wenn sie sich nicht am Ende des Datensatzes befindet.
Gilt für

Modell

Objekt
sourceSet-Modell
source
Beispiele
JavaScript
xfa.sourceSet.nodes.item(nIndex).isEOF();
FormCalc
xfa.sourceSet.nodes.item(nIndex).isEOF()


isPropertySpecified

Überprüft, ob eine bestimmte Eigenschaft für diese Node definiert wurde.
Syntax
Reference_Syntax.isPropertySpecified( STRING param1 [, BOOLEAN param2 [, INTEGER param3 ] ] )
Parameter
param1
Eine gültige Zeichenfolge, die den Namen nach der zu suchenden Objekteigenschaft darstellt.
param2 (Optional)
Ein boolescher Wert, der angibt, ob die Vererbung von übergeordneten Klassen berücksichtigt werden soll.
      •
      True (Standardwert)
Legt fest, ob diese Eigenschaft von einer übergeordneten Klasse vererbt wird.
      •
      False
Legt fest, ob diese Eigenschaft unabhängig von der Vererbung für das aktuelle Objekt definiert wird.
param3 (Optional)
Ein Ganzzahlwert, der festlegt, welches Vorkommen der Eigenschaft überprüft wird. Dieser Parameter ist nur für die Eigenschaften gültig, die mehrere Instanzen besitzen können.
Rückgabe
True, wenn die Eigenschaft festgelegt ist, und False, wenn sie nicht festgelegt ist.
Gilt für
node-Klasse
Beispiele
JavaScript
TextField1.isPropertySpecified("ui");
FormCalc
TextField1.isPropertySpecified("ui")


isRecordGroup

Gibt an, ob ein bestimmtes dataGroup-Objekt auch ein einzelner Datensatz ist.
Syntax
Reference_Syntax.isRecordGroup( OBJECT param )
Parameter
param
Ein gültiges dataGroup-Objekt aus der aktuellen Datenquelle.
Rückgabe
True, wenn die angegebene Datengruppe auch ein einzelner Datensatz ist, und False, wenn dies nicht der Fall ist.
Gilt für

Modell

Objekt
Datenmodell
dataWindow
Beispiele
JavaScript
xfa.dataWindow.isRecordGroup(xfa.datasets.data.dataNodeName);
FormCalc
xfa.dataWindow.isRecordGroup(xfa.datasets.data.dataNodeName)


item

Beschreibt einen Null-basierten Index zur Sammlung.
Syntax
Reference_Syntax.item( INTEGER param )
Parameter
param
Ein Null-basierter Index zur Sammlung.
Rückgabe
Ein Objekt, das eine XFA-Struktur darstellt.
Gilt für
treeList-Klasse


last

Wechselt zum letzen Datensatz in der Datensatzgruppe und füllt das Datenmodell mit den Daten aus dem Datensatz.
Die Datenverbindungsmethode xfa.sourceSet.DataConnection.last sucht eine Tabelle und aktualisiert sie, wenn sich die Daten geändert haben. Sie verwendet die hasDataChanged-Methode, um zu ermitteln, ob sich die Daten geändert haben.
Syntax
Reference_Syntax.last()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
sourceSet-Modell
source
Beispiele
JavaScript
xfa.sourceSet.dataConnectionName.last();
FormCalc
xfa.sourceSet.dataConnectionName.last()


loadXML

Lädt ein angegebenes XML-Dokument und fügt es an das aktuelle Objekt an.
Syntax
Reference_Syntax.EMPTY loadXML( STRING param1 [, BOOLEAN param2 [, BOOLEAN param3 ] ] )
Parameter
param1
Eine gültige Zeichenfolge, die den Namen des XML-Dokuments darstellt.
param2 (Optional)
Ein boolescher Wert, der angibt, ob die Stamm-Node im XML-Dokument ignoriert werden soll.
      •
      True (Standardwert)
Ignoriert die Stamm-Node des XML-Dokuments und fügt die restlichen XML-Nodes direkt an das aktuelle Objekt des XML-Formularobjektmodells an.
      •
      False
Fügt die Stamm-Node des XML-Dokuments direkt an das aktuelle Objekt des XML-Formularobjektmodells an.
param3 (Optional)
Ein boolescher Wert, der angibt, ob die Daten aus dem XML-Dokument die Informationen für das aktuelle Objekt des XML-Formularobjektmodells überschreiben sollen.
      •
      True
Ersetzt den Inhalt des aktuellen Objekt des XML-Formularobjektmodells durch die XML-Dokumentdaten.
      •
      False (Standardwert)
Fügt die XML-Dokumentdaten an das aktuelle Objekt des XML-Formularobjektmodells an.
Rückgabe
Leer
Gilt für
node-Klasse
Beispiele
JavaScript
xfa.datasets.data.loadXML(xmlData,0,1);
FormCalc
xfa.datasets.data.loadXML(xmlData,0,1)


messageBox

Zeigt ein Dialogfeld an. Nur für Client-Anwendungen verfügbar.
Syntax
Reference_Syntax.messageBox( STRING param1 [, STRING param2 [, INTEGER param3 [, INTEGER param4 ] ] ] )
Parameter
param1
Eine gültige Zeichenfolge, welche die anzuzeigende Meldung darstellt.
param2 (Optional)
Eine gültige Zeichenfolge, die den Titel darstellt, der in der Titelleiste des Dialogfelds angezeigt werden soll.
param3 (Optional)
Eine Ganzzahl, die das Symbol darstellt, das im Dialogfeld angezeigt werden soll.
      •
      0 (Fehler) - Dies ist die Standardeinstellung.
      •
      1 (Warnung)
      •
      2 (Frage)
      •
      3 (Status)
param4 (Optional)
Eine Ganzzahl, welche die anzuzeigenden Schaltflächen darstellt.
      •
      0 (OK) - Dies ist die Standardeinstellung.
      •
      1 (OK, Abbrechen)
      •
      2 (Ja, Nein)
      •
      3 (Ja, Nein, Abbrechen)
Rückgabe
Eine gültige Ganzzahl, die den Wert der Schaltfläche darstellt, die vom Benutzer aktiviert wird:
      •
      1 (OK)
      •
      2 (Abbrechen)
      •
      3 (Nein)
      •
      4 (Ja)
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.messageBox("This is a message", 3, 1);
FormCalc
xfa.host.messageBox("This is a message", 3, 1)


moveCurrentRecord

Verschiebt den aktuellen Datensatz an eine andere Position im Datensatzbereich.
Syntax
Reference_Syntax.moveCurrentRecord( INTEGER param )
Parameter
param
Eine gültige Ganzzahl, welche die Anzahl der Datensätze darstellt, die den aktuellen Datensatz und den gewünschten Zieldatensatz voneinander trennen. Eine positive Ganzzahl gibt einen Datensatz zwischen dem aktuellen Datensatz und dem Ende des Datensatzbereichs an, ein negativer Wert einen Datensatz zwischen dem aktuellen Datensatz und dem Anfang des Bereichs.
Rückgabe
Leer
Gilt für

Modell

Objekt
Datenmodell
dataWindow
Beispiele
JavaScript
xfa.dataWindow.moveCurrentRecord(1);
FormCalc
xfa.dataWindow.moveCurrentRecord(1)


moveInstance

Verschiebt ein subform-Objekt in einer Gruppe von Teilformular-Instanzen.
Die entsprechende Datenmodellinformationen für das Teilformular werden innerhalb des Datenmodells ebenfalls neu positioniert.
Syntax
Reference_Syntax.moveInstance( INTEGER param1, INTEGER param2 )
Parameter
param1 | Eine gültige Ganzzahl, welche die Null-basierte Indexposition des zu verschiebenden Formularmodellobjekts darstellt.
param2 | Eine gültige Ganzzahl, die die Null-basierte Position des untergeordneten Objekts innerhalb der Gruppe der Instanzen angibt.
Rückgabe
Leer
Gilt für

Modell

Objekt
Formularmodell
instanceManager
Beispiele
JavaScript
Subform1.instanceManager.moveInstance(0,6);
FormCalc
Subform1.instanceManager.moveInstance(0,6)


namedItem

Ruft das erste untergeordnete Element dieser Node mit dem angegebenen Namen ab.
Syntax
Reference_Syntax.namedItem( STRING param )
Parameter
param
Eine gültige Zeichenfolge, die den Namen dieser Node darstellt.
Rückgabe
Ein Objekt, welches das erste untergeordnete Element dieser Node mit dem angegebenen Namen darstellt.
Gilt für
treeList-Klasse


next

Wechselt zum nächsten Datensatz in der Datensatzgruppe und füllt das Datenmodell mit den Daten aus dem Datensatz.
Die Datenverbindungsmethode xfa.sourceSet.DataConnection.next sucht eine Tabelle und aktualisiert sie, wenn sich die Daten geändert haben. Sie verwendet die hasDataChanged-Methode, um zu ermitteln, ob sich die Daten geändert haben.
Syntax
Reference_Syntax.next()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
sourceSet-Modell
source
Beispiele
JavaScript
xfa.sourceSet.dataConnectionName.next();
FormCalc
xfa.sourceSet.dataConnectionName.next()


open

Stellt eine Verbindung mit der Datenquelle her und füllt das Datenmodell mit den Ergebnissen des aktuellen Datensatzes.
Syntax
Reference_Syntax.open()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
sourceSet-Modell
source
Beispiele
JavaScript
xfa.sourceSet.nodes.item(nIndex).open();
FormCalc
xfa.sourceSet.nodes.item(nIndex).open()


openList

Öffnet die durch den usdruck der Referenz-Syntax angegebene Dropdown-Liste. Nur für Client-Anwendungen verfügbar.
Syntax
Reference_Syntax.openList( STRING param )
Parameter
param
Ein vollständig qualifizierter Ausdruck der Referenz-Syntax, der eine Dropdown-Liste angibt.
Rückgabe
Leer
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel


Seite

Bestimmt die Seitenzahl, die ein angegebenes Formularentwurfsobjekt enthält. Bei einem Objekt, das auf mehreren Seiten vorkommt, gibt diese Methode die erste Seite zurück, auf der das Objekt auftritt.
Syntax
Reference_Syntax.page( OBJECT param )
Parameter
param
Der vollständig qualifizierte Ausdruck der Referenz-Syntax eines der folgenden Container-Formularentwurfsobjekte: field, draw, subform, area, pageArea, contentArea.
Rückgabe
Eine Ganzzahl, welche die Anzahl der Seiten darstellt, die das angegebene Formularentwurfsobjekt enthalten. Diese Methode gibt 0 zurück, wenn das in param angegebene Objekt im Formular nicht gefunden werden kann.
Gilt für

Modell

Objekt
Layoutmodell
layoutPseudoModel
Beispiele
JavaScript
xfa.layout.page(this);
FormCalc
xfa.layout.page($)


pageContent

Ruft Formularentwurfsobjekttypen von einer angegebenen Seite eines Formulars ab.
Syntax
Reference_Syntax.pageContent( INTEGER param1 [, STRING param2 [, BOOLEAN param3 ] ] )
Parameter
param1
Eine Ganzzahl, die die gewünschte Seitenzahl darstellt. Dieser Wert ist Null-basiert.
param2 (Optional)
Gibt die folgenden Containertypen zurück:
      •
      field
Gibt die folgenden Formularentwurfsobjekte zurück: Schaltfläche, Kontrollkästchen, Datums-/Uhrzeitfeld, Dropdown-Liste, Dokumentunterschriftsfeld, Bildfeld, Listenfeld, Numerisches Feld, Kennwortfeld, Optionsfeld und Textfeld.
      •
      draw
Gibt die folgenden Formularentwurfsobjekte zurück: Kreis, Linie, Rechteck, statisches Bild und statischer Text.
      •
      subform
Gibt alle subform-Formularentwurfsobjekte zurück.
      •
      area
Gibt alle area-Formularobjekte zurück.
      •
      pageArea
Gibt alle pageArea-Formularentwurfsobjekte zurück.
      •
      contentArea
Gibt alle contentArea-Formularentwurfsobjekte.
      •
      empty (Standardwert)
Gibt alle Container zurück.
param3 (Optional)
      •
      True (Standardwert)
Gibt nur pageArea-Inhalts-Nodes zurück.
      •
      False
Gibt alle Nicht-pageArea-Inhalts-Nodes zurück.
Rückgabe
Eine Sammlung mit Formularentwurfsobjekten aus der angegebenen Seitenzahl.
Gilt für

Modell

Objekt
Layoutmodell
layoutPseudoModel
Beispiele
JavaScript
// Get the fields in a document
var oFields = xfa.layout.pageContent(i, "field");
FormCalc
// Get the fields in a document
var oFields = xfa.layout.pageContent(i, "field")


pageCount

Stellt fest, wie viele Seiten das aktuelle Formular hat.
Syntax
Reference_Syntax.pageCount()
Parameter
Keine
Rückgabe
Eine Ganzzahl, welche die Gesamtseitenzahl des Formulars darstellt.
Gilt für

Modell

Objekt
Layoutmodell
layoutPseudoModel
Beispiele
JavaScript
xfa.layout.pageCount();
FormCalc
xfa.layout.pageCount()


pageDown

Wechselt zur nächsten Seite eines Formulars. Verwenden Sie die pageDown-Methode zur Laufzeit.
Syntax
Reference_Syntax.pageDown()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.pageDown();
FormCalc
xfa.host.pageDown()


pageSpan

Stellt fest, wie viele logische Seiten ein bestimmtes Formularentwurfsobjekt umfasst.
Syntax
Reference_Syntax.pageSpan( OBJECT param )
Parameter
param
Der vollständig qualifizierte Ausdruck der Referenz-Syntax eines der folgenden Container-Formularentwurfsobjekte: field, draw, subform, area, pageArea, contentArea.
Rückgabe
Eine Ganzzahl, welche die Gesamtseitenzahl des Formulars darstellt.
Gilt für

Modell

Objekt
Layoutmodell
layoutPseudoModel
Beispiele
JavaScript
xfa.layout.pageSpan(this);
FormCalc
xfa.layout.pageSpan($)


pageUp

Wechselt zur vorherigen Seite eines Formulars. Verwenden Sie die pageUp-Methode zur Laufzeit.
Syntax
Reference_Syntax.pageUp()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.pageUp();
FormCalc
xfa.host.pageUp()


previous

Wechselt zum vorherigen Datensatz in der Datensatzgruppe und füllt das Datenmodell mit den Daten aus dem Datensatz.
Die Datenverbindungsmethode xfa.sourceSet.DataConnection.previous sucht eine Tabelle und aktualisiert sie, wenn sich die Daten geändert haben. Sie verwendet die hasDataChanged-Methode, um zu ermitteln, ob sich die Daten geändert haben.
Syntax
Reference_Syntax.previous()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
sourceSet-Modell
source
Beispiele
JavaScript
xfa.sourceSet.dataConnectionName.previous();
FormCalc
xfa.sourceSet.dataConnectionName.previous()


print

Druckt eine bestimmte Anzahl von Seiten aus einem Dokument. Nur für Client-Anwendungen verfügbar.
Syntax
Reference_Syntax.print( BOOLEAN param1, INTEGER param2, INTEGER param3, BOOLEAN param4, BOOLEAN param5, BOOLEAN param6, BOOLEAN param7, BOOLEAN param8 )
Parameter
param1
      •
      True (Standardwert)
Zeigt ein Drucken-Dialogfeld an und fordert den Benutzer zum Drucken von Einrichtungsinformationen und Bestätigen der Aktion auf.
      •
      False
Zeigt kein Drucken-Dialogfeld an. Der Druckvorgang wird fortgesetzt, ohne dass der Benutzer nach Informationen oder einer Bestätigung gefragt wird.
param2
Eine gültige Zeichenfolge, welche die erste Seitenzahl des zu druckenden Bereichs darstellt. Seitenzahlen sind Null-basiert; das heißt, Seite 1 wird mit dem Wert 0 bezeichnet.
Die Startseite wird ebenfalls gedruckt.
param3
Eine gültige Zeichenfolge, welche die letzte Seitenzahl des zu druckenden Bereichs darstellt. Seitenzahlen sind Null-basiert; das heißt, Seite 1 wird mit dem Wert 0 bezeichnet.
Die Endseite wird ebenfalls gedruckt.
param4
      •
      True (Standardwert)
Während des Druckvorgangs wird kein Abbrechen-Dialogfeld angezeigt.
      •
      False
Zeigt ein Abbrechen-Dialogfeld zum Anhalten des Druckvorgangs an.
param5
      •
      True (Standardwert)
Verkleinert die Seite (bei Bedarf) auf die Größe des Bildbereichs der gedruckten Seite.
      •
      False
Verkleinert die Seite nicht auf die Größe des Bildbereichs der gedruckten Seite.
param6
      •
      True (Standardwert)
Druckt jede Seite als Bild.
      •
      False
Druckt jede Seite als Textseite.
param7
      •
      True (Standardwert)
Druckt die Seiten in umgekehrter Reihenfolge.
      •
      False
Druckt die Seiten in Reihenfolge.
param8
      •
      True (Standardwert)
Druckt alle Anmerkungen.
      •
      False
Druckt keine Anmerkungen.
Rückgabe
Leer
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.print(1, "0", "0", 0, 1, 0, 0, 0);
FormCalc
xfa.host.print(1, "0", "0", 0, 1, 0, 0, 0)


recalculate

Erzwingt die Ausführung eines angegebenen Satzes von Skripten, die mit Berechnungsereignissen verknüpft sind. Bei den spezifischen Ereignissen kann es sich um anstehende Berechnungsereignisse oder um alle Berechnungsereignisse handeln.
Syntax
Reference_Syntax.recalculate( BOOLEAN param )
Parameter
param
Ein boolescher Wert, der angibt, welche Berechnungsskripten ausgeführt werden müssen.
      •
      True (Standardwert)
Alle Berechnungsskripten werden erneut ausgeführt.
      •
      False
Nur ausstehende Berechnungsskripten dürfen ausgeführt werden.
Rückgabe
Leer
Gilt für

Modell

Objekt
Formularmodell
form
template
Beispiele
JavaScript
xfa.form.recalculate(1);
FormCalc
xfa.form.recalculate(1)


record

Gibt einen Datensatz an einer Position relativ zum aktuellen Datensatz zurück.
Syntax
Reference_Syntax.record( INTEGER param )
Parameter
param
Eine gültige Ganzzahl, welche die Anzahl der Datensätze darstellt, die den aktuellen Datensatz und den gewünschten Zieldatensatz voneinander trennen. Eine positive Ganzzahl gibt einen Datensatz zwischen dem aktuellen Datensatz und dem Ende des Datensatzbereichs an, ein negativer Wert einen Datensatz zwischen dem aktuellen Datensatz und dem Anfang des Bereichs.
Rückgabe
Objekt
Gilt für

Modell

Objekt
Datenmodell
dataWindow
Beispiele
JavaScript
xfa.dataWindow.record(0).dataNodeName.value;
FormCalc
xfa.dataWindow.record(0).dataNodeName.value


relayout

Wendet die Layoutoptionen erneut auf das aktuelle Formular an.
Syntax
Reference_Syntax.relayout()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
Layoutmodell
layoutPseudoModel
Beispiele
JavaScript
xfa.layout.relayout();
FormCalc
xfa.layout.relayout()


relayoutPageArea

Ersetzt das Layout des PageArea-Objektinhalts durch ein neues Layout.
Syntax
Reference_Syntax.relayoutPageArea( [ INTEGER param ] )
Parameter
param (Optional)
Die Seitenzahl der zu ersetzenden Seite. Seitenzahlwerte sind Null-basiert.
Rückgabe
Leer
Gilt für

Modell

Objekt
Layoutmodell
layoutPseudoModel
Beispiele
JavaScript
xfa.layout.relayoutPageArea(0);
FormCalc
xfa.layout.relayoutPageArea(0)


remerge

Erzwingt das erneute Zusammenführen von Datenmodell und Vorlagenmodell zur Neuerstellung des Formularmodells. Nach dem erneuten Zusammenführen müssen evtl. vorgenommene Layoutmodell-Verarbeitungen für das fertig gestellte Formular wiederholt werden.
Syntax
Reference_Syntax.remerge()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
Formularmodell
form
Beispiele
JavaScript
xfa.form.remerge();
FormCalc
xfa.form.remerge()


remove

Entfernt eine Node aus der Node-Liste.
Syntax
Reference_Syntax.remove( OBJECT param )
Parameter
param
Ein gültiger Ausdruck der Referenz-Syntax, der die zu entfernende Node darstellt.
Rückgabe
Leer
Gilt für
treeList-Klasse
Beispiele
JavaScript
xfa.record.nodes.remove(oNode);
FormCalc
xfa.record.nodes.remove(oNode)


removeAttribute

Entfernt die angegebene Eigenschaft.
Syntax
Reference_Syntax.removeAttribute( STRING param )
Parameter
param
Eine gültige Zeichenfolge, die den Namen der zu entfernenden Eigenschaft darstellt.
Rückgabe
Leer
Gilt für

Modell

Objekt
XFA-Modell
packet


removeInstance

Entfernt ein angegebenes Teilformular oder einen Teilformularsatz aus dem Formularmodell.
Beim Entfernen einer Teilformular-Instanz sollten Sie Vorkommnis-Verletzungen vermeiden. Sie können keine Teilformular-Instanz löschen, wenn die Mindestanzahl der Instanzen erreicht wurde. Wenn ein Teilformular die Mindestanzahl der Instanzen erreicht, zeigt der JavaScript Debugger eine Fehlermeldung an:
The element [min] has violated its allowable number of occurrences.
Wenn der Endbenutzer alle Instanzen eines Teilformulars löschen darf, muss die Mindestanzahl von Instanzen zunächst auf 0 gesetzt werden, bevor eine Instanz entfernt werden kann. Anderenfalls verhindert das Skript jeglichen Löschversuch einer Teilformular-Instanz unter der Mindestanzahl.
Syntax
Reference_Syntax.removeInstance( INTEGER param )
Parameter
param
Eine gültige Ganzzahl, welche die Null-basierte Indexposition im zu entfernenden Formularmodell des Teilformulars oder des Teilformularsatzes darstellt.
Rückgabe
Leer
Gilt für

Modell

Objekt
Formularmodell
instanceManager
Beispiele
JavaScript
Subform2.instanceManager.removeInstance(3);
FormCalc
Subform2.instanceManager.removeInstance(3)


requery

Aktualisiert die aktuelle Datenbindung durch erneutes Ausführen der Abfrage, auf der die Objektdaten basieren. Das Aufrufen dieser Methode entspricht dem Aufrufen der Methoden close und open nacheinander.
Syntax
Reference_Syntax.requery()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
sourceSet-Modell
source


reset

Setzt alle Eigenschaften innerhalb des XML-Formularereignismodells zurück.
Syntax
Reference_Syntax.reset()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
Ereignismodell
eventPseudoModel
Beispiele
JavaScript
xfa.event.reset();
FormCalc
xfa.event.reset()


resetData

Setzt die Felder in einem Dokument auf ihre Standardwerte zurück.
Syntax
Reference_Syntax.resetData([ STRING param ])
Parameter
param
(Optional)
Eine gültige Zeichenfolge, die die Namen oder entsprechenden Ausdrücke der Referenz-Syntax der zurückzusetzenden Felder auflistet. Die Listeneinträge sind durch Kommazeichen („,“) getrennt. Wenn diese Liste nicht vorhanden oder leer ist, werden alle Felder im Formular auf ihre Standardwerte zurückgesetzt.
Rückgabe
Leer
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.resetData("xfa.form.form1.TextField1,xfa.form.form1.TextField2");
FormCalc
xfa.host.resetData("xfa.form.form1.TextField1,xfa.form.form1.TextField2")


resolveNode

Wertet den angegebenen Ausdruck der Referenz-Syntax aus, angefangen mit dem aktuellen Objekt des XML-Formularobjektmodells, und gibt den Wert des im Ausdruck der Referenz-Syntax angegebenen Objekts zurück.
Die Suche nach einem Objekt beginnt an einer anderen Stelle in der Formularhierarchie, abhängig davon, wie auf die resolveNode-Eigenschaft zugegriffen wurde:
      •
      this.resolveNode(): Die Suche beginnt beim aktuellen Objekt und setzt sich nach oben in der Formularhierarchie fort.
      •
      xfa.resolveNode(): Die Suche beginnt oben in der Formularhierarchie und setzt sich nach unten fort.
Die Suche könnte zu unerwarteten Ergebnissen führen, wenn das Formular mehrere Objekte desselben Namens enthält. Es wird der Wert des ersten gefundenen Objekts zurückgegeben.
Syntax
Reference_Syntax.resolveNode( STRING param )
Parameter
param
Eine gültige Zeichenfolge, die einen Ausdruck der Referenz-Syntax darstellt, der als ein bestimmtes Objekt eines XML-Formularobjektmodells ausgewertet wird.
Rückgabe
Ein einzelnes Objekt, das dem Ausdruck der Referenz-Syntax entspricht, sofern vorhanden. Existiert ein solches Objekt nicht, gibt die Methode null zurück.
Gilt für
tree-Klasse
Beispiele
JavaScript
xfa.resolveNode("#subform").x = "2in";

TextField1.resolveNode("ui.#textEdit").border.edge.stroke = "lowered";


resolveNodes

Wertet den angegebenen Ausdruck der Referenz-Syntax aus, angefangen mit dem aktuellen Objekt des XML-Formularobjektmodells, und gibt den Wert des bzw. der im Ausdruck der Referenz-Syntax angegebenen Objekts bzw. Objekte zurück.
Die Suche nach einem Objekt beginnt an einer anderen Stelle in der Formularhierarchie, abhängig davon, wie auf die resolveNode-Eigenschaft zugegriffen wurde:
      •
      this.resolveNodes(): Die Suche beginnt beim aktuellen Objekt und setzt sich nach oben in der Formularhierarchie fort.
      •
      xfa.resolveNodes(): Die Suche beginnt oben in der Formularhierarchie und setzt sich nach unten fort.
Die Suche könnte zu unerwarteten Ergebnissen führen, wenn das Formular mehrere Objekte desselben Namens enthält. Es wird der Wert des ersten gefundenen Objekts zurückgegeben.
Syntax
Reference_Syntax.resolveNodes( STRING param )
Parameter
param
Eine gültige Zeichenfolge, die einen Ausdruck der Referenz-Syntax darstellt, der als mindestens ein bestimmtes Objekt eines XML-Formularobjektmodells ausgewertet wird.
Rückgabe
Mindestens ein Objekt, das dem Ausdruck der Referenz-Syntax entspricht, sofern Objekte dieser Art vorhanden sind. Existieren solche Objekte nicht, gibt die Methode null zurück.
Gilt für
tree-Klasse
Beispiele
JavaScript
xfa.resolveNodes("Subform1[*]");
FormCalc
xfa.resolveNodes("Subform1[*]")


response

Zeigt ein Dialogfeld an, das eine Frage sowie ein Eingabefeld enthält, in dem der Benutzer die Frage beantworten kann. Der Rückgabewert ist eine Zeichenfolge, die die Antwort des Benutzers enthält. Wenn der Anwender im Dialogfeld auf die Schaltfläche „Abbrechen“ klickt, ist die Antwort der Null-Wert.
Syntax
Reference_Syntax.response(STRING param1 [, STRING param2 [, STRING param3 [, BOOLEAN param4 ] ] ])
Parameter
param1
Eine gültige Zeichenfolge, die eine Frage für den Benutzer darstellt.
param2 (Optional)
Eine gültige Zeichenfolge, die den Titel darstellt, der in der Titelleiste des Dialogfelds angezeigt wird.
param3 (Optional)
Eine gültige Zeichenfolge, die den Standardwert für die Antwort auf die Frage darstellt.
param4 (Optional)
      •
      True (Standardwert)
Verbirgt die Antwort des Benutzers durch ein Sternchen (*).
      •
      False
Verbirgt die Antwort des Benutzers nicht.
Rückgabe
Eine Zeichenfolge, welche die Antwort des Benutzers darstellt. Wenn der Benutzer im Dialogfeld auf die Abbrechen-Schaltfläche klickt, ist die Antwort das Null-Objekt.
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.response("Question", "Title", "Default Value");
FormCalc
xfa.host.response("Question", "Title", "Default Value")


resync

Aktualisiert die aktuelle Datensatzgruppe oder Datenverbindung.
Syntax
Reference_Syntax.resync()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
sourceSet-Modell
source


saveFilteredXML

Speichert die aktuelle Node in einer Zeichenfolge, bezieht jedoch nur eine Untergruppe der untergeordneten Nodes ein.
Syntax
Reference_Syntax.saveFilteredXML( OBJECT param1 [, STRING param2 ] )
Parameter
param1 | Ein manifest-Objekt, das die in die Zeichenfolge einzubeziehenden Nodes beschreibt.
param2 (Optional) | Eine gültige Zeichenfolge, die darstellt, wie die sich ergebende XML-Zeichenfolge gedruckt wird. Verwenden Sie beispielsweise die Zeichenfolge pretty, um einen PrettyPrint-Ausdruck der resultierenden XML-Zeichenfolge zu drucken.
Rückgabe
Eine gültige Zeichenfolge, die das XML-Fragment darstellt, das nur die angegebene Untergruppe der aktuellen Node enthält.
Gilt für
node-Klasse


saveXML

Speichert die aktuelle Node in einer Zeichenfolge.
Syntax
Reference_Syntax.saveXML()
Parameter
Keine
Rückgabe
Eine gültige Zeichenfolge, die das XML-Fragment des aktuellen Objekts darstellt.
Gilt für
node-Klasse
Beispiele
JavaScript
xfa.data.saveXML();
FormCalc
xfa.data.saveXML()


selectedMember

Gibt das ausgewählte Element einer Ausschlussgruppe zurück.
Syntax
Reference_Syntax.selectedMember( [ STRING param ] )
Parameter
param (Optional)
Eine gültige Zeichenfolge, die den Namen des Ausschlussgruppenelements darstellt, vorausgesetzt, das Ausschlussgruppenelement befindet sich im selben Bereich wie das verweisende Objekt. Andernfalls eine gültige Zeichenfolge, die den Ausdruck der Referenz-Syntax des auszuwählenden Ausschlussgruppenelements darstellt.
Rückgabe
Das Objekt, welches das ausgewählte Element der Ausschlussgruppe darstellt. In LiveCycle Designer gibt diese Methode beispielsweise das aktivierte Optionsfeld zurück.
Gilt für

Modell

Objekt
Formularmodell
exclGroup


setAttribute

Legt den Wert einer angegebenen Eigenschaft fest.
Syntax
Reference_Syntax.setAttribute( STRING param1, STRING param2 )
Parameter
param1 | Eine gültige Zeichenfolge, die den neuen Wert der Eigenschaft darstellt.
param2 | Eine gültige Zeichenfolge, die den Namen der Eigenschaft darstellt.
Rückgabe
Leer
Gilt für

Modell

Objekt
XFA-Modell
packet
Gilt auch für die node-Klasse.


setElement

Legt ein angegebenes Objekt als aktuelles Objekt fest.
Syntax
Reference_Syntax.setElement( OBJECT param1 [, STRING param2 ] )
Parameter
param1 | Ein Objekt, das ein neues Objekt darstellt.
param2 (Optional) | Eine gültige Zeichenfolge, die den Namen des zu ersetzenden Objekts darstellt.
Rückgabe
Leer
Gilt für
node-Klasse


setFocus

Stellt den Tastaturfokus auf das vom Ausdruck der Referenz-Syntax angegebene Feld ein. Nur für Client-Anwendungen verfügbar.
Sie können setFocus nicht mit den Ereignissen form:ready, layout:ready oder initialize verwenden.
Syntax
Reference_Syntax.setFocus( STRING param )
Parameter
param
Eine gültige Zeichenfolge, die einen vollständig qualifizierten Ausdruck der Referenz-Syntax für das Feld darstellt, das den Fokus erhalten soll.
Rückgabe
Leer
Gilt für

Modell

Objekt
Hostmodell
hostPseudoModel
Beispiele
JavaScript
xfa.host.setFocus("xfa.form.form1.TextField1");
FormCalc
xfa.host.setFocus("xfa.form.form1.TextField1")


setInstance

Fügt angegebene Teilformulare oder Teilformularsätze aus dem Formularmodell hinzu oder entfernt diese.
Syntax
Reference_Syntax.setInstance( INTEGER param )
Parameter
param
Eine gültige Ganzzahl, welche die gewünschte Anzahl von Instanzen eines bestimmten Teilformulars oder Teilfomularsatzes im Formularmodell darstellt.
Rückgabe
Leer
Gilt für

Modell

Objekt
Formularmodell
instanceManager
Beispiele
JavaScript
Subform1.instanceManager.setInstances(5);
FormCalc
Subform1.instanceManager.setInstances(5)


sign

Unterschreibt eine bestimmte Node-Liste und platziert die Unterschrift am Zielort.
Syntax
Reference_Syntax.sign( OBJECT param1, STRING param2, STRING param3 [, STRING param4 [, BOOLEAN param5 [, OBJECT param6 [, OBJECT param7 ] ] ] ] )
Parameter
param1
input
Eine gültige XFA-Node-Liste aller zu unterschreibenden Nodes.
param2
input
Eine gültige Zeichenfolge, die einen Ausdruck der Referenz-Syntax für die übergeordnete Node der Unterschrifts-Node darstellt.
param3
input
Eine gültige Zeichenfolge, die einen XML-Kennzeichnungswert für die Unterschrift darstellt.
param4 (Optional)
input (Optional)
Eine gültige Zeichenfolge, die das Verhalten der unterschriebenen Daten-Nodes angibt.
Folgende Werte sind möglich:
      •
      open (Standardwert)
Die Daten-Nodes sind für die Bearbeitung offen und können zur Laufzeit geändert werden.
      •
      locked
Die Daten-Node ist gesperrt und kann zur Laufzeit nicht geändert werden.
param5 (Optional)
input (Optional)
      •
      True (Standardwert)
Gibt an, dass für diesen Vorgang ein Dialogfeld verwendet wird.
      •
      False
Gibt an, dass für diesen Vorgang kein Dialogfeld verwendet wird.
param6 (Optional)
input (Optional)
Stellt das SecurityHandler-Objekt dar, das zum Unterschreiben verwendet wird. Sicherheitsobjekte können in der Regel erst zum Unterschreiben verwendet werden, nachdem sie initialisiert wurden.
param7 (Optional)
output (Optional)
Stellt ein SignatureInfo-Ausgabeobjekt dar, das die nicht schreibgeschützten Eigenschaften der Unterschrift enthält.
Rückgabe
True , wenn die Unterschrift erfolgreich angewendet wurde, und False, wenn die Unterschriftsoption abgebrochen wurde. Wenn beim Unterschriftsvorgang ein Fehler auftritt, wird ein Ausnahmefehler zurückgegeben.
Gilt für

Modell

Objekt
Unterschriftsmodell
signaturePseudoModel


update

Aktualisiert den aktuellen Datensatz in der Datensatzgruppe.
Syntax
Reference_Syntax.update()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
sourceSet-Modell
source
Beispiele
JavaScript
xfa.sourceSet.dataConnectionName.update();
FormCalc
xfa.sourceSet.dataConnectionName.update()


updateBatch

Schreibt alle anstehenden Batch-Aktualisierungen in die Datenquelle.
Syntax
Reference_Syntax.updateBatch()
Parameter
Keine
Rückgabe
Leer
Gilt für

Modell

Objekt
sourceSet-Modell
source


verify

Überprüft die Gültigkeit einer Unterschrift.
Syntax
Reference_Syntax.verify( OBJECT param1 [, BOOLEAN param2 [, OBJECT param3 [, OBJECT param4 ] ] ] )
Parameter
param1
input
Eine gültige XML-Unterschrifts-Node.
param2 (Optional)
input (Optional)
      •
      True (Standardwert)
Gibt an, dass für diesen Vorgang ein Dialogfeld verwendet wird.
      •
      False
Gibt an, dass für diesen Vorgang kein Dialogfeld verwendet wird.
param3 (Optional)
input (Optional)
Das SecurityHandler-Objekt, das zum Unterschreiben verwendet wird. Sicherheitsobjekte können in der Regel erst zum Unterschreiben verwendet werden, nachdem sie initialisiert wurden.
param4 (Optional)
output (Optional)
Ein SignatureInfo-Ausgabeobjekt, das die nicht schreibgeschützten Eigenschaften der Unterschrift enthält.
Rückgabe
Eine Ganzzahl, welche die Gültigkeit der Unterschrift darstellt. In der folgenden Tabelle sind die Gültigkeitswerte beschrieben:

Wert

Beschreibung
-1
Keine Unterschrifts-Node.
0
Unterschrift ist leer.
1
Unbekannter Status.
2
Unterschrift ist ungültig.
3
Unterschrift ist gültig, die Identität des Unterzeichners konnte jedoch nicht geprüft werden.
4
Unterschrift und Identität des Unterzeichners sind gültig.
Gilt für

Modell

Objekt
Unterschriftsmodell
signaturePseudoModel


w

Bestimmt die Breite eines angegebenen Formularentwurfsobjekts.
Syntax
Reference_Syntax.w( OBJECT param1 [, STRING param2 [, INTEGER param3 ] ] )
Parameter
param1 | Der vollständig qualifizierte Ausdruck der Referenz-Syntax eines der folgenden Container-Formularentwurfsobjekte: field, draw, subform, area, pageArea, contentArea.
param2 (Optional) | Eine Zeichenfolge, die den Einheitentyp des Rückgabewerts darstellt. Wenn nichts eingegeben wird, besteht der Standardeinheitentyp aus Punkten.
param3 (Optional) | Eine Ganzzahl, welche die Zahl darstellt, bei der die Breite des Objekts, beginnend mit der ersten Seite, auf der das Objekt auftritt, angepasst wird. Wenn nichts eingegeben wird, ist der Standardwert 0.
Rückgabe
Die Breite des Formularentwurfsobjekts als Double.
Gilt für

Modell

Objekt
Layoutmodell
layoutPseudoModel
Beispiele
JavaScript
xfa.layout.w(TextField1,"in");
FormCalc
xfa.layout.w(TextField1,"in")


x

Bestimmt die X-Koordinate eines angegebenen Formularentwurfsobjekts.
Syntax
Reference_Syntax.x( OBJECT param1 [, STRING param2 [, INTEGER param3 ] ] )
Parameter
param1 | Der vollständig qualifizierte Ausdruck der Referenz-Syntax eines der folgenden Container-Formularentwurfsobjekte: field, draw, subform, area, pageArea, contentArea.
param2 (Optional) | Eine Zeichenfolge, die den Einheitentyp des Rückgabewerts darstellt. Wenn nichts eingegeben wird, besteht der Standardeinheitentyp aus Punkten.
param3 (Optional) | Eine Ganzzahl, welche die Anzahl von Seiten darstellt, um welche die X-Koordinate des Objekts, beginnend mit der ersten Seite, auf der das Objekt auftritt, versetzt wird. Wenn nichts eingegeben wird, ist der Standardwert 0.
Rückgabe
Die X-Koordinate des Formularentwurfsobjekts als Double.
Gilt für

Modell

Objekt
Layoutmodell
layoutPseudoModel
Beispiele
JavaScript
xfa.layout.x(TextField1,"in");
FormCalc
xfa.layout.x(TextField1,"in")


y

Bestimmt die Y-Koordinate eines angegebenen Formularentwurfsobjekts.
Syntax
Reference_Syntax.y( OBJECT param1 [, STRING param2 [, INTEGER param3 ] ] )
Parameter
param1 | Der vollständig qualifizierte Ausdruck der Referenz-Syntax eines der folgenden Container-Formularentwurfsobjekte: field, draw, subform, area, pageArea, contentArea.
param2 (Optional) | Eine Zeichenfolge, die den Einheitentyp des Rückgabewerts darstellt. Wenn nichts eingegeben wird, besteht der Standardeinheitentyp aus Punkten.
param3 (Optional) | Eine Ganzzahl, welche die Anzahl von Seiten darstellt, um welche die Y-Koordinate des Objekts, beginnend mit der ersten Seite, auf der das Objekt auftritt, versetzt wird. Wenn nichts eingegeben wird, ist der Standardwert 0.
Rückgabe
Die Y-Koordinate des Formularentwurfsobjekts als Double.
Gilt für

Modell

Objekt
Layoutmodell
layoutPseudoModel
Beispiele
JavaScript
xfa.layout.y(TextField1,"in");
FormCalc
xfa.layout.y(TextField1,"in")


FormCalc-Benutzerreferenz

Einführung in FormCalc
Sprachreferenz
Arithmetik-Funktionen
Datums- und Uhrzeitfunktionen
Finanzfunktionen
Logikfunktionen
Sonstige Funktionen
Zeichenfolgen-Funktionen
URL-Funktionen


Einführung in FormCalc

FormCalc
Skripterstellung in LiveCycle Designer
Alphabetische Liste der Funktionen


FormCalc

FormCalc ist eine einfache, aber leistungsfähige Berechnungssprache, die nach dem Vorbild allgemein gebräuchlicher Tabellenkalkulations-Software entwickelt wurde. Diese Sprache soll die schnelle, effiziente Gestaltung von Formularen ohne Kenntnis konventioneller Skripterstellungstechniken oder Skriptsprachen ermöglichen. Benutzer, die FormCalc noch nicht kennen, können mit Hilfe von wenigen integrierten Funktionen in kurzer Zeit Formulare erstellen, welche den Endbenutzern zeitaufwendige Berechnungen, Kontrollen und andere Überprüfungsmaßnahmen abnehmen. Auf diese Weise kann der Entwickler sein Formular bei der Gestaltung mit einer elementaren Intelligenz versehen, mit welcher das so entstehende interaktive Formular auf die eingegebenen Daten reagiert.
Die integrierten Funktionen, aus denen sich FormCalc zusammensetzt, decken eine umfangreiche Palette von Bereichen ab: Mathematik, Datum und Uhrzeit, Zeichenfolgen, Finanzen, Logik und Internet. Diese Bereiche entsprechen den Datentypen, die in Formularen typischerweise verwendet werden. Die Funktionen sollen eine schnelle und einfache Handhabung der Daten auf zweckmäßige Weise ermöglichen.


Skripterstellung in LiveCycle Designer

Bei LiveCycle Designer ist FormCalc die Standard-Skriptsprache, die überall zum Einsatz kommt, wo Skripten erstellt werden; alternativ wird JavaScript™ eingesetzt. Skripterstellung erfolgt bei den verschiedenen Ereignissen, die Formularobjekte betreffen. Sie können eine Mischung aus FormCalc und JavaScript bei interaktiven Formularen verwenden. Wenn Sie aber einen serverbasierten Prozess wie LiveCycle Forms verwenden, um Formulare für die Anzeige in einem Internet-Browser zu erstellen, werden FormCalc-Skripten zu bestimmten Formularobjekt-Ereignissen nicht im HTML-Formular wiedergegeben. Hierdurch soll verhindert werden, dass im Internet-Browser Fehler auftreten, wenn Benutzer mit dem fertigen Formular arbeiten.


Alphabetische Liste der Funktionen

Die folgende Tabelle enthält alle verfügbaren FormCalc-Funktionen, liefert eine Beschreibung für jede Funktion und gibt den Kategorietyp an, zu welchem die jeweilige Funktion gehört.

Funktion

Beschreibung

Typ
Abs
Gibt den Betragswert eines Zahlenwerts oder Ausdrucks zurück.
Arithmetik
Apr
Gibt die jährliche Gesamtbelastung für einen Kredit zurück.
Finanz
At
Findet die Anfangs-Zeichenposition einer Zeichenfolge innerhalb einer anderen Zeichenfolge.
Zeichenfolge
Avg
Wertet einen Satz von Zahlenwerten und/oder Ausdrücken aus und gibt den Mittelwert der von null verschiedenen Elemente innerhalb dieses Satzes zurück.
Arithmetik
Ceil
Gibt die ganze Zahl zurück, die größer oder gleich einer angegebenen Zahl ist.
Arithmetik
Choose
Wählt einen Wert aus einem gegebenen Satz von Parametern.
Logisch
Concat
Gibt die Verkettung von zwei oder mehr Zeichenfolgen zurück.
Zeichenfolge
Count
Wertet einen Satz von Werten und/oder Ausdrücken aus und gibt die Anzahl der von null verschiedenen Elemente innerhalb dieses Satzes zurück.
Arithmetik
CTerm
Gibt die Anzahl der Perioden zurück, die erforderlich sind, damit eine Anlage mit einer festen Verzinsung mit Zinseszins auf einen Endwert anwächst.
Finanz
Date
Gibt das aktuelle Systemdatum als Anzahl von Tagen seit Beginn der Epoche zurück.
Datum und Uhrzeit
Date2Num
Gibt für eine angegebene Datums-Zeichenfolge die Anzahl von Tagen seit Beginn der Epoche zurück.
Datum und Uhrzeit
DateFmt
Gibt für einen angegebenen Datumsformat-Stil eine Datumsformat-Zeichenfolge zurück.
Datum und Uhrzeit
Decode
Gibt die dekodierte Version einer angegebenen Zeichenfolge zurück.
Zeichenfolge
Encode
Gibt die kodierte Version einer angegebenen Zeichenfolge zurück.
Zeichenfolge
Eval
Gibt den Wert einer angegebenen Formularberechnung zurück.
Sonstiges
Exists
Bestimmt, ob der angegebene Parameter ein Akzessor zu einem vorhandenen Objekt ist.
Logisch
Floor
Gibt die größte Ganzzahl zurück, die kleiner oder gleich dem angegebenen Wert ist.
Arithmetik
Format
Formatiert die angegebenen Daten gemäß der angegebenen Musterformat-Zeichenfolge.
Zeichenfolge
FV
Gibt den Endwert von Anlagebeträgen zurück, die regelmäßig und in gleich bleibender Höhe bei einem konstanten Zinssatz eingezahlt werden.
Finanz
Get
Lädt den Inhalt der angegebenen URL herunter.
URL
HasValue
Ermittelt, ob der angegebene Parameter ein Akzessor mit einem von null verschiedenen, nicht leeren, vom Leerzeichen verschiedenen Wert ist.
Logisch
IPmt
Gibt den Zinsbetrag zurück, der in einer bestimmten Zeitspanne für einen Kredit gezahlt wurde.
Finanz
IsoDate2Num
Gibt für eine angegebene gültige Datums-Zeichenfolge die Anzahl der Tage seit Beginn der Epoche zurück.
Datum und Uhrzeit
IsoTime2Num
Gibt für eine angegebene gültige Uhrzeit-Zeichenfolge die Anzahl der Millisekunden seit Beginn der Epoche zurück.
Datum und Uhrzeit
Left
Extrahiert eine angegebene Anzahl von Zeichen aus einer Zeichenfolge, beginnend beim ersten Zeichen auf der linken Seite.
Zeichenfolge
Len
Gibt die Anzahl der Zeichen in einer angegebenen Zeichenfolge zurück.
Zeichenfolge
LocalDateFmt
Gibt eine lokalisierte Datumsformat-Zeichenfolge mit dem angegebenen Datumsformat-Stil zurück.
Datum und Uhrzeit
LocalTimeFmt
Gibt eine lokalisierte Uhrzeitformat-Zeichenfolge mit dem angegebenen Uhrzeitformat-Stil zurück.
Datum und Uhrzeit
Lower
Wandelt alle Großbuchstaben in einer angegebenen Zeichenfolge in Kleinbuchstaben um.
Zeichenfolge
Ltrim
Gibt eine Zeichenfolge zurück, bei der alle Leerraum-Zeichen am Anfang entfernt wurden.
Zeichenfolge
Max
Gibt den Maximalwert der von null verschiedenen Elemente im angegebenen Satz von Zahlen zurück.
Arithmetik
Min
Gibt den Minimalwert der von null verschiedenen Elemente im angegebenen Satz von Zahlen zurück.
Arithmetik
Mod
Gibt den Modulus der Division einer Zahl durch eine andere zurück.
Arithmetik
NPV
Gibt den Netto-Barwert einer Anlage auf der Grundlage eines Diskontsatzes und einer Folge von zukünftigen periodischen Cashflows zurück.
Finanz
Null
Gibt den Null-Wert zurück. („Null-Wert“ ist gleichbedeutend mit „kein Wert“.)
Sonstiges
Num2Date
Gibt für eine angegebene Anzahl von Tagen seit Beginn der Epoche eine Datums-Zeichenfolge zurück.
Datum und Uhrzeit
Num2GMTime
Gibt für eine angegebene Anzahl von Millisekunden seit Beginn der Epoche eine GMT-Uhrzeit-Zeichenfolge zurück.
Datum und Uhrzeit
Num2Time
Gibt für eine angegebene Anzahl von Millisekunden seit Beginn der Epoche eine Uhrzeit-Zeichenfolge zurück.
Datum und Uhrzeit
Oneof
Gibt TRUE (1) zurück, wenn sich ein Wert in einem angegebenen Set befindet, bzw. FALSE (0), wenn dies nicht der Fall ist.
Logisch
Parse
Analysiert die angegebenen Daten gemäß dem angegebenen Musterformat.
Zeichenfolge
Pmt
Gibt die Höhe des Rückzahlungsbetrags für einen Kredit bei konstanten Zahlungsbeträgen und konstantem Zinssatz zurück.
Finanz
Post
Sendet die angegebenen Daten an die genannte URL.
URL
PPmt
Gibt den Tilgungsbetrag zurück, der in einer bestimmten Zeitspanne für einen Kredit gezahlt wurde.
Finanz
Put
Lädt die angegebenen Daten zu der genannten URL hoch.
URL
PV
Gibt den Gegenwartswert einer Anlage mit regelmäßigen konstanten Einzahlungen und konstantem Zinssatz zurück.
Finanz
Rate
Gibt den Zinssatz pro Verzinsungsperiode zurück, der benötigt wird, damit eine Anlage mit Zinseszins in einem gegebenen Zeitraum von einem gegebenen Gegenwartswert auf einen Endwert anwächst.
Finanz
Ref
Gibt eine Referenz auf ein vorhandenes Objekt zurück.
Sonstiges
Replace
Ersetzt innerhalb einer angegebenen Zeichenfolge alle Fundstellen einer Zeichenfolge durch eine andere.
Zeichenfolge
Right
Extrahiert mehrere Zeichen aus einer angegebenen Zeichenfolge, beginnend beim letzten Zeichen auf der rechten Seite.
Zeichenfolge
Round
Wertet einen angegebenen Zahlenwert oder Ausdruck aus und gibt eine auf die angegebene Anzahl von Dezimalstellen gerundete Zahl zurück.
Arithmetik
Rtrim
Gibt eine Zeichenfolge zurück, bei der alle Leerraum-Zeichen am Ende entfernt wurden.
Zeichenfolge
Space
Gibt eine Zeichenfolge zurück, die aus einer angegebenen Anzahl von Leerzeichen besteht.
Zeichenfolge
Str
Wandelt eine Zahl in eine Zeichenfolge um. FormCalc formatiert das Ergebnis auf die angegebene Breite und rundet auf die angegebene Zahl von Dezimalstellen.
Zeichenfolge
Stuff
Fügt eine Zeichenfolge in eine andere Zeichenfolge ein.
Zeichenfolge
Substr
Extrahiert einen Abschnitt aus einer angegebenen Zeichenfolge.
Zeichenfolge
Sum
Gibt die Summe der von null verschiedenen Elemente eines gegebenen Satzes von Zahlen zurück.
Arithmetik
Term
Gibt die Anzahl der Perioden zurück, die erforderlich sind, um mit konstanten periodischen Einzahlungen auf ein verzinstes Konto einen angegebenen Endwert zu erzielen.
Finanz
Time
Gibt die aktuelle Systemuhrzeit als Anzahl von Millisekunden seit Beginn der Epoche zurück.
Datum und Uhrzeit
Time2Num
Gibt für eine angegebene Uhrzeit-Zeichenfolge die Anzahl der Millisekunden seit Beginn der Epoche zurück.
Datum und Uhrzeit
TimeFmt
Gibt ein Uhrzeitformat in einem angegebenen Uhrzeitformat-Stil zurück.
Datum und Uhrzeit
UnitType
Gibt die Einheit einer Maßangabe zurück. Eine Maßangabe ist eine Zeichenfolge, die aus einer Zahl und einer nachfolgenden Einheitenbezeichnung besteht.
Sonstiges
UnitValue
Gibt den Zahlenwert einer Messung mit ihrer zugeordneten Maßangabe nach einer optionalen Einheitenumwandlung zurück.
Sonstiges
Upper
Wandelt alle Kleinbuchstaben in einer angegebenen Zeichenfolge in Großbuchstaben um.
Zeichenfolge
Uuid
Gibt eine UUID-Zeichenfolge (Universally Unique Identifier) zurück, die als Kennzeichnungsmethode verwendet werden soll.
Zeichenfolge
Within
Gibt TRUE (1) zurück, wenn der geprüfte Wert innerhalb eines angegebenen Bereichs liegt, bzw. FALSE (0), wenn dies nicht der Fall ist.
Logisch
WordNum
Gibt die englischsprachige Textentsprechung einer angegebenen Zahl zurück.
Zeichenfolge


Zurück Weiter

Skripterstellung > FormCalc-Benutzerreferenz > Sprachreferenz

Sprachreferenz

Bausteine
Ausdrücke


Bausteine

Grundlagen zu Bausteinen
Literale
Operatoren
Kommentare
Schlüsselwörter
Bezeichner
Zeilenende-Zeichen
Leerraum


Grundlagen zu Bausteinen

Die FormCalc-Sprache besteht aus einzelnen Bausteinen, die FormCalc-Ausdrücke bilden. Jeder FormCalc-Ausdruck ist eine Folge bestimmter Kombinationen dieser Komponenten.
      •
      Literale
      •
      Operatoren
      •
      Kommentare
      •
      Schlüsselwörter
      •
      Bezeichner
      •
      Zeilenende-Zeichen
      •
      Leerraum


Literale

Grundlagen zu Literalen
Literale sind konstante Werte, die als Grundlage für alle Werte dienen, die zur Verarbeitung an FormCalc übergeben werden. Es gibt zwei allgemeine Typen von Literalen: Zahlen und Zeichenfolgen.
Zahlenliterale
Ein Zahlenliteral ist eine hauptsächlich aus Ziffern bestehende Folge, die sich aus einem oder mehreren der folgenden Zeichen zusammensetzt: Ganzzahl, Dezimalpunkt, Bruchanteil, Exponentenzeichen („e“ oder „E“) sowie ein optionaler vorzeichenbehafteter Exponentenwert. Die folgenden Beispiele zeigen einige Literalzahlen:
      •
      -12
      •
      1.5362
      •
      0.875
      •
      5.56e-2
      •
      1.234E10
Entweder der Ganzzahl- oder der Bruchanteil einer Literalzahl kann weggelassen werden, aber nicht beide gleichzeitig. Außerdem kann im Bruchanteil entweder der Dezimalpunkt oder der Exponentenwert weggelassen werden, aber nicht beide gleichzeitig.
Alle Zahlenliterale werden intern gemäß einem Standard des Institute of Electrical and Electronics Engineers (IEEE) in 64 Bit lange Binärwerte umgewandelt. Da die IEEE-Werte aber nur eine endliche Zahlenmenge darstellen können, lassen sich bestimmte Werte in dieser Form nicht als binärer Bruch darstellen, ähnlich wie sich bestimmte Werte (z. B. 1/3) als Dezimalbruch nicht exakt darstellen lassen (ein völlig genauer Dezimalwert müsste unendlich viele Dezimalstellen haben).
Die Werte ohne äquivalente binäre Bruchdarstellung sind in der Regel Zahlenliterale mit mehr als 16 signifikanten Ziffern vor dem Exponenten. FormCalc rundet diese Werte auf den nächsten nach dem IEEE-Standard darstellbaren 64-Bit-Wert. Beispielsweise wird der Wert
    123456789.012345678
auf den (nächsten) Wert gerundet:
    123456789.01234567
In einem zweiten Beispiel wird dagegen das Zahlenliteral
    99999999999999999
auf den (nächsten) Wert gerundet:
    100000000000000000
Dieses Verhalten kann in manchen Fällen zu unerwarteten Ergebnissen führen. FormCalc enthält die Funktion Round, welche die übergebene Zahl auf eine angegebene Zahl von Dezimalstellen gerundet zurückgibt. Wenn die übergebene Zahl genau in der Mitte zwischen zwei darstellbaren Zahlen liegt, wird „von 0 weg“ gerundet; das heißt, eine positive Zahl wird nach oben gerundet, eine negative nach unten. Dazu zwei Beispiele:
    Round(0.124, 2)
liefert 0.12
und
    Round(.125, 2)
liefert 0.13.
Folglich würde man erwarten, dass
    Round(0.045, 2)
0.05 liefert.
Die IEEE-Norm 754 schreibt aber vor, dass das Zahlenliteral 0.045 als 0.0449999999999999 anzunähern ist. Dieser Näherungswert liegt näher bei 0.04 als bei 0.05. Daher liefert
    Round(0.045, 2)
das Ergebnis 0.04.
Dies entspricht ebenfalls der IEEE-Norm 754.
64-Bit-Werte gemäß der IEEE-Norm unterstützen auch Darstellungen wie NaN (Not a Number – keine Zahl), +Inf (positiv unendlich) und -Inf (negativ unendlich). In FormCalc werden diese Werte jedoch nicht unterstützt, und Ausdrücke, die zu NaN, +Inf oder -Inf ausgewertet werden, führen zu einem Ausnahmefehler, der dann auch auf den Rest des Ausdrucks übertragen wird.
Zeichenfolgenliterale
Ein Zeichenfolgenliteral ist eine in Anführungszeichen eingeschlossene Folge von beliebigen Unicode-Zeichen. Beispiel:
    "The cat jumped over the fence."
    "Number 15, Main street, California, U.S.A"
Das Zeichenfolgenliteral "" steht für eine leere Folge von Textzeichen, die als „leere Zeichenfolge“ bezeichnet wird.
Wenn Sie innerhalb eines Zeichenfolgenliterals Anführungszeichen verwenden möchten, müssen Sie vor jedes Anführungszeichen einen umgekehrten Schrägstrich (\) setzen. Beispiel:
    "The message reads: ""Warning: Insufficient Memory"""
Zu jedem Unicode-Zeichen gibt es eine äquivalente, 6 Zeichen lange Escape-Sequenz, die aus \u und vier nachfolgenden Hexadezimalziffern besteht. In einem Zeichenfolgenliteral lässt sich jedes Zeichen, einschließlich der Steuerzeichen, mit einer entsprechenden Unicode-Escape-Sequenz darstellen. Beispiel:
    "\u0047\u006f\u0066\u0069\u0073\u0068\u0021"
    "\u000d" (carriage return)
    "\u000a" (newline character)


Operatoren

Zu FormCalc gehört eine Reihe von Operatoren: unär, multiplikativ, additiv, relational, Gleichheit, logisch und der Zuweisungsoperator.
Zu mehreren FormCalc-Operatoren gibt es ein äquivalentes mnemonisches Operator-Schlüsselwort. Diese Schlüsselwort-Operatoren sind immer dann nützlich, wenn FormCalc-Ausdrücke in HTML- und XML-Quelltext eingebettet sind, wo die Symbole „Kleiner als“ (<) und „Größer als“ (>) sowie das Et-Zeichen (&) eine vordefinierte Bedeutung haben und daher vermieden werden müssen. In der folgenden Tabelle sind alle FormCalc-Operatoren aufgeführt. Neben der symbolischen ist gegebenenfalls auch die mnemonische Darstellungsform angegeben.

Operator-Typ

Darstellung
Addition
+
Division
/
Gleichheit
== eq
<> ne
Logisches UND
& and
Logisches ODER
| or
Multiplikation
*
Relational
< lt (less than - kleiner als)
> gt (greater than - größer als)
<= le (less than or equal to - kleiner oder gleich)
>= ge (greater than or equal to - größer oder gleich)
Subtraktion
-
Unär
-
+
not


Kommentare

Kommentare sind Code-Abschnitte, die von FormCalc nicht ausgeführt werden. Kommentare enthalten in der Regel Informationen oder Anleitungen, in denen die Verwendung eines bestimmten Code-Abschnitts erläutert wird. Alle in Kommentaren gespeicherten Informationen werden von FormCalc während der Laufzeit ignoriert.
Kommentare werden entweder durch ein Semikolon (;) oder zwei Schrägstriche (//) gekennzeichnet. In FormCalc erstreckt sich ein Kommentar von seinem Anfang bis zum nächsten Zeilenende-Zeichen.

Zeichenname

Darstellung
Kommentar
;
//
Beispiel:
    // This is a type of comment
    First_Name="Tony"
    Initial="C" ;This is another type of comment
    Last_Name="Blue"
Alle FormCalc-Berechnungen für ein Ereignis kommentieren
Wenn sämtliche FormCalc-Berechnungen für ein bestimmtes Ereignis kommentiert sind, wird ein Fehler ausgegeben, wenn Sie sich Ihr Formular über die Registerkarte „PDF-Vorschau“ ansehen oder die fertige PDF-Datei anzeigen. Bei jeder FormCalc-Berechnung muss ein Wert ausgegeben werden. Kommentare werden von FormCalc nicht als Werte akzeptiert.
Gehen Sie folgendermaßen vor, um diese Fehlerausgabe bei kommentiertem FormCalc-Code zu umgehen:
      •
      Entfernen Sie den kommentierten Code aus dem Ereignis.
      •
      Fügen Sie einen Ausdruck hinzu, der einen Wert für den FormCalc-Code des Ereignisses ausgibt.
Verwenden Sie einen der folgenden Ausdrücke, damit der Wert des Ausdrucks keine unerwünschten Ergebnisse in Ihrem Formular ausgibt:
      •
      Einen einfachen, aus einem Zeichen bestehenden Ausdruck, wie im folgenden Beispiel:

        // First_Name="Tony"
        // Initial="C"
        // Last_Name="Blue"
        //
        // The simple expression below sets the value of the event to zero.
        0
      •
      Einen Zuweisungsausdruck, welcher den Wert des Objekts erhält. Verwenden Sie diesen Ausdruckstyp, wenn sich Ihr kommentierter FormCalc-Code im berechneten Ereignis befindet, damit der eigentliche Objektwert nicht verändert wird (siehe folgendes Beispiel):

        // First_Name="Tony"
        // Initial="C"
        // Last_Name="Blue"
        //
        // The assignment expression below sets the value of the current
        // field equal to itself.
        $.rawValue = $.rawValue


Schlüsselwörter

Schlüsselwörter in FormCalc sind reservierte Wörter, bei denen die Groß-/Kleinschreibung nicht beachtet wird. Diese Schlüsselwörter werden als Teile von Ausdrücken, spezielle Zahlenliterale und Operatoren verwendet.
Die folgende Tabelle zeigt die FormCalc-Schlüsselwörter. Verwenden Sie keines dieser Wörter für die Benennung von Formularobjekten.
and | endif | in | step
break | endwhile | infinity | then
continue | eq | le | this
do | exit | lt | throw
downto | for | nan | upto
else | foreach | ne | var
elseif | func | not | while
end | ge | null |
endfor | gt | or |
endfunc | if | return |


Bezeichner

Ein Bezeichner ist eine Zeichenkette beliebiger Länge, welche den Namen einer Funktion oder Methode angibt. Jeder Bezeichner muss mit einem der folgenden Zeichen beginnen:
      •
      Einem beliebigen alphabetischen Zeichen (gemäß den Unicode-Buchstabenklassifikationen)
      •
      Unterstrich (_)
      •
      Dollarzeichen ($)
      •
      Ausrufezeichen (!)
In FormCalc ist die Groß-/Kleinschreibung der Bezeichner relevant; das heißt, Bezeichner, deren Namen sich nur durch die Groß-/Kleinschreibung von Buchstaben unterscheiden, gelten als verschieden.

Zeichenname

Darstellung
Bezeichner
A..Z,a..z
$
!
_
Gültige Bezeichner sind beispielsweise:
    GetAddr
    $primary
    _item
    !dbresult


Zeilenende-Zeichen

Zeilenende-Zeichen werden für die Trennung von Zeilen und die Verbesserung der Lesbarkeit verwendet.
In der folgenden Tabelle sind alle in FormCalc gültigen Zeilenende-Zeichen aufgeführt:

Zeichenname

Unicode-Zeichen
Wagenrücklauf
#xD
U+000D
Zeilenvorschub
#xA
&#x000D;
&#D;


Leerraum

Leerraum-Zeichen trennen verschiedene Objekte und mathematische Operationen voneinander. Diese Zeichen dienen ausschließlich zur Verbesserung der Lesbarkeit und werden in FormCalc während der Verarbeitung nicht beachtet.

Zeichenname

Unicode-Zeichen
Formularvorschub
#xC
Horizontaler Tabulator
#x9
Leertaste
#x20
Vertikaler Tabulator
#xB


Ausdrücke

Grundlagen zu Ausdrücken
Einfach
Zuweisung
Logisches ODER
Logisches UND
Unär
Gleichheit und Ungleichheit
Relational
if-Ausdrücke
while-Ausdrücke
for-Ausdrücke
foreach-Ausdrücke
break-Ausdrücke
continue-Ausdrücke


Grundlagen zu Ausdrücken

Die Literale, Operatoren, Kommentare, Schlüsselwörter, Bezeichner, Zeilenende-Zeichen und Leerräume bilden gemeinsam eine Liste von Ausdrücken, auch wenn die Liste nur einen einzelnen Ausdruck enthält. Allgemein wird jeder Ausdruck in der Liste zu einem Wert aufgelöst; der Wert der gesamten Liste ist der Wert des letzten Ausdrucks in der Liste.
Betrachten Sie zum Beispiel das folgende Szenario mit zwei Feldern auf einem Formularentwurf:

Feldname

Berechnungen

Rückgabe

Field1

5 + Abs(Price)
„Hello World“
10 * 3 + 5 * 4

50

Field2

10 * 3 + 5 * 4

50
Sowohl Field1 als auch Field2 haben nach der Auswertung ihrer jeweiligen Ausdrucksliste den Wert 50.
FormCalc unterteilt die verschiedenen Arten von Ausdrücken, aus denen eine Ausdrucksliste besteht, in die folgenden Kategorien:
      •
      Einfach
      •
      Zuweisung
      •
      Logisches ODER
      •
      Logisches UND
      •
      Unär
      •
      Gleichheit und Ungleichheit
      •
      Relational
      •
      if-Ausdrücke
      •
      while-Ausdrücke
      •
      for-Ausdrücke
      •
      foreach-Ausdrücke
      •
      break-Ausdrücke
      •
      continue-Ausdrücke


Einfach

Einfache Ausdrücke
In ihrer elementarsten Form sind FormCalc-Ausdrücke Gruppen von Operatoren, Schlüsselwörtern und Literalen, die logisch miteinander verknüpft sind. In den folgenden Fällen zum Beispiel handelt es sich jeweils um einfache Ausdrücke:
    2
    "abc"
    2 - 3 * 10 / 2 + 7
Jeder FormCalc-Ausdruck wird zu einem einzelnen Wert aufgelöst. Dabei gilt die konventionelle Reihenfolge der Operationen, auch wenn diese Reihenfolge aus der Syntax der Ausdrücke nicht immer offensichtlich ist. Wenn beispielsweise die folgenden Ausdrücke auf Objekte in einem Formularentwurf angewandt werden, sehen die Ergebnisse wie folgt aus:

Ausdruck

Entspricht

Rückgabe

"abc"

"abc"

abc

2 - 3 * 10 / 2 + 7

2 - (3 * (10 / 2)) + 7

-6

10 * 3 + 5 * 4

(10 * 3) + (5 * 4)

50

0 and 1 or 2 > 1

(0 and 1) or (2 >1)
1 (TRUE)

2 < 3 not 1 == 1

(2 < 3) not (1 == 1)
0 (FALSE)
Wie aus der obigen Tabelle hervorgeht, besitzen alle FormCalc-Operatoren innerhalb von Ausdrücken eine bestimmte Priorität. Die folgende Tabelle zeigt die Hierarchie der Operatoren im Überblick:

Priorität

Operator
Höchste
=
(Unär) - , + , not
* , /
+ , -
< , <= , > , >= , lt , le , gt , ge
== , <> , eq , ne
& , and
Niedrigste
| , or
Umwandlung von Operanden
Falls ein oder mehrere Operanden in einer bestimmten Operation nicht dem erwarteten Typ für die betreffende Operation entsprechen, wandelt FormCalc die Operanden in den benötigten Typ um. Wie diese Umwandlung erfolgt, hängt davon ab, welchen Operandentyp die Operation benötigt.
Numerische Operationen
Bei der Ausführung von numerischen Operationen, an denen nicht-numerische Operanden beteiligt sind, werden die nicht-numerischen Operanden zunächst in ihre numerische Entsprechung umgewandelt. Wenn sich der nicht-numerische Operand nicht erfolgreich in einen Zahlenwert konvertieren lässt, ist sein Wert 0. Wenn nullwertige Operanden in Zahlen umgewandelt werden, ist ihr Wert stets 0.
Die folgende Tabelle liefert einige Beispiele für die Anpassung von nicht-numerischen Operanden.

Ausdruck

Entspricht

Rückgabe

(5 - "abc") * 3

(5 - 0) * 3

15

"100" / 10e1

100 / 10e1

1

5 + null + 3

5 + 0 + 3

8
Boolesche Operationen
Bei der Ausführung von booleschen Operationen, an denen nicht-boolesche Operanden beteiligt sind, werden die nicht-booleschen Operanden zunächst in ihre booleschen Entsprechungen umgewandelt. Wenn sich der nicht-boolesche Operand nicht erfolgreich in einen von 0 verschiedenen Wert umwandeln lässt, hat er den Wert TRUE (1); andernfalls hat er den Wert FALSE (0). Wenn nullwertige Operanden in einen booleschen Wert umgewandelt werden, ist dieser Wert stets FALSE (0). Beispielsweise wird der Ausdruck
    "abc" | 2
als 1 ausgewertet. Das heißt, false | true = true. Hingegen wird
    if ("abc") then
    10
    else
    20
    endif
als 20 ausgewertet.
Zeichenfolgenoperationen
Wenn Zeichenfolgenoperationen bei Operanden ausgeführt werden, die keine Zeichenfolgen sind, werden diese Operanden zunächst in Zeichenfolgen umgewandelt. Dabei wird jeweils der Wert des Operanden als Zeichenfolge verwendet. Wenn nullwertige Operanden in Zeichenfolgen umgewandelt werden, entspricht ihr Wert stets der leeren Zeichenfolge. Beispielsweise wird der Ausdruck
    concat("The total is ", 2, " dollars and ", 57, " cents.")
als "The total is 2 dollars and 57 cents." ausgewertet.
Wenn während der Auswertung eines Ausdrucks ein Zwischenschritt das Ergebnis NaN, +Inf oder -Inf liefert, erzeugt FormCalc einen Ausnahmefehler und überträgt diesen Fehler auf den Rest des Ausdrucks. Dadurch liefert dieser Ausdruck stets den Wert 0, z. B.:
    3 / 0 + 1
wird als 0 ausgewertet.


Zuweisung

Ein Zuweisungsausdruck setzt die von einer gegebenen Referenz-Syntax bezeichnete Eigenschaft als Wert eines einfachen Ausdrucks fest. Beispiel:
    $template.purchase_order.name.first = "Tony"
Hierdurch wird der Wert des Formularentwurfsobjekts „first“ auf Tony gesetzt.
Weitere Informationen zur Verwendung der Referenz-Syntax finden Sie unter Grundlagen zum Referenzieren von Objekten in Berechnungen und Skripten.


Logisches ODER

Ein logischer ODER-Ausdruck gibt TRUE (1) zurück, wenn mindestens einer der Operanden TRUE (1) ist, oder FALSE (0), wenn beide Operanden FALSE (0) sind. Wenn beide Operanden null sind, liefert der Ausdruck das Ergebnis null.

Ausdruck

Zeichendarstellung
Logisches ODER
|
or
Die folgenden Beispiele verdeutlichen die Verwendung des logischen ODER-Ausdrucks:

Ausdruck

Rückgabe

1 or 0
1 (TRUE)

0 | 0
0 (FALSE)

0 or 1 | 0 or 0
1 (TRUE)


Logisches UND

Ein logischer UND-Ausdruck gibt TRUE (1) zurück, wenn beide Operanden TRUE (1) sind, oder FALSE, wenn mindestens einer der Operanden FALSE (0) ist. Wenn beide Operanden null sind, liefert der Ausdruck das Ergebnis null.

Ausdruck

Zeichendarstellung
Logisches UND
&
and
Die folgenden Beispiele verdeutlichen die Verwendung des logischen UND-Ausdrucks:

Ausdruck

Rückgabe

1 and 0
0 (FALSE)

0 & 0
1 (TRUE)

0 and 1 & 0 and 0
0 (FALSE)


Unär

Unäre Ausdrücke liefern je nach verwendetem unärem Operator unterschiedliche Ergebnisse.

Ausdruck

Zeichendarstellung

Rückgabe
Unär
-
Die arithmetische Negierung des Operanden bzw. null, wenn der Operand null ist.
+
Der arithmetische Wert des Operanden (unverändert) bzw. null, wenn der Operand null ist.
not
Die logische Negierung des Operanden.
Die arithmetische Negierung eines Null-Operanden liefert das Ergebnis null, die logische Negierung eines Null-Operanden dagegen liefert das boolesche Ergebnis TRUE. Dem entspricht die folgende, aus der Alltagserfahrung stammende Aussage: Wenn „null“ „nichts“ heißt, muss „nicht nichts“ gleichbedeutend mit „etwas“ sein.
Die folgenden Beispiele verdeutlichen die Verwendung unärer Ausdrücke:

Ausdruck

Rückgabe

-(17)

-17

-(-17)

17

+(17)

17

+(-17)

-17

not("true")
1 (TRUE)

not(1)
0 (FALSE)


Gleichheit und Ungleichheit

Gleichheits- und Ungleichheits-Ausdrücke liefern das Ergebnis eines Vergleichs der Operanden auf Gleichheit zurück.

Ausdruck

Zeichendarstellung

Rückgabe
Gleichheit
== eq
TRUE (1), wenn die beiden Operanden beim Vergleich identisch sind, bzw. FALSE (0), wenn sie beim Vergleich nicht identisch sind.
Ungleichheit
<> ne
TRUE (1), wenn die beiden Operanden beim Vergleich nicht identisch sind, bzw. FALSE (0), wenn sie beim Vergleich identisch sind.
Außerdem gelten für die Verwendung der Gleichheitsoperatoren die folgenden Spezialfälle:
      •
      Wenn einer der Operanden null ist, wird ein Null-Vergleich durchgeführt. Nullwertige Operanden werden beim Vergleich als identisch gewertet, wenn beide Operanden null sind, und als verschieden, wenn einer der Operanden nicht null ist.
      •
      Wenn beide Operanden Referenzen sind, werden die beiden Operanden als identisch gewertet, wenn sie sich beide auf das gleiche Objekt beziehen, und als verschieden, wenn sie sich nicht auf das gleiche Objekt beziehen.
      •
      Wenn beide Operanden Zeichenfolgen sind, wird ein lexikografischer Zeichenfolgenvergleich der Operanden unter Berücksichtigung des Gebietsschemas durchgeführt. Andernfalls werden die Operanden, sofern nicht beide Operanden null sind, in Zahlenwerte umgewandelt und ein numerischer Vergleich wird durchgeführt.
Die folgenden Beispiele verdeutlichen die Verwendung der Gleichheits- und Ungleichheits-Ausdrücke:

Ausdruck

Rückgabe

3 == 3
1 (TRUE)

3 <> 4
1 (TRUE)

"abc" eq "def"
0 (FALSE)

"def" ne "abc"
1 (TRUE)

5 + 5 == 10
1 (TRUE)

5 + 5 <> "10"
0 (FALSE)


Relational

Ein relationaler Ausdruck gibt das boolesche Ergebnis eines relationalen Vergleichs der Operanden zurück.

Ausdruck

Zeichendarstellung

Rückgabe
Relational
< lt
TRUE (1), wenn der erste Operand kleiner als der zweite Operand ist, und FALSE (0), wenn der erste Operand größer als der zweite Operand ist.
> gt
TRUE (1), wenn der erste Operand größer als der zweite Operand ist, und FALSE (0), wenn der erste Operand kleiner als der zweite Operand ist.
<= le
TRUE (1), wenn der erste Operand kleiner als der zweite Operand oder gleich groß ist, und FALSE (0), wenn der erste Operand größer als der zweite Operand ist.
>= ge
TRUE (1), wenn der erste Operand größer als der zweite Operand oder gleich groß ist, und FALSE (0), wenn der erste Operand kleiner als der zweite Operand ist.
Außerdem gelten für die Verwendung der relationalen Operatoren die folgenden Spezialfälle:
      •
      Wenn einer der Operanden null ist, wird ein Null-Vergleich durchgeführt. Nullwertige Operanden werden beim Vergleich als identisch bewertet, wenn beide Operanden null sind und der relationale Operator „kleiner gleich“ oder „größer gleich“ verwendet wird; andernfalls werden sie als verschieden bewertet.
      •
      Wenn beide Operanden Zeichenfolgen sind, wird ein lexikografischer Zeichenfolgenvergleich der Operanden unter Berücksichtigung des Gebietsschemas durchgeführt. Andernfalls werden die Operanden, sofern nicht beide Operanden null sind, in Zahlenwerte umgewandelt und ein numerischer Vergleich wird durchgeführt.
Die folgenden Beispiele verdeutlichen die Verwendung relationaler Ausdrücke:

Ausdruck

Rückgabe

3 < 3
0 (FALSE)

3 > 4
0 (FALSE)

"abc" <= "def"
1 (TRUE)

"def" > "abc"
1 (TRUE)

12 >= 12
1 (TRUE)

"true" < "false"
0 (FALSE)


if-Ausdrücke

Ein if-Ausdruck ist eine bedingte Anweisung, die prüft, ob ein gegebener einfacher Ausdruck wahr ist, und anschließend das Ergebnis einer Liste von Ausdrücken zurückgibt, die diesem Wahrheitswert entsprechen. Wenn der erste einfache Ausdruck als FALSE (0) ausgewertet wird, prüft FormCalc für alle vorhandenen elseif- und else-Bedingungen, ob diese wahr sind, und gibt gegebenenfalls das Ergebnis ihrer Ausdruckslisten zurück.

Ausdruck

Syntax

Rückgabe
if

if ( simple expression ) then
    list of expressions
elseif ( simple expression ) then
    list of expressions
else
    list of expressions
endif
Das Ergebnis der Liste von Ausdrücken, welche den gültigen Bedingungen (sofern vorhanden) im if-Ausdruck zugeordnet ist.
Sie müssen keine elseif(...)- oder else-Anweisungen als Teil des if-Ausdrucks verwenden; das Ende des Ausdrucks muss aber mit endif gekennzeichnet werden.
Die folgenden Beispiele verdeutlichen die Verwendung des if-Ausdrucks:

Ausdruck

Rückgabe

if ( 1 < 2 ) then
 1
endif

1

if ( "abc" > "def") then
 1 and 0
else
 0
endif

0

if ( Field1 < Field2 ) then
 Field3 = 0
elseif ( Field1 > Field2 ) then
 Field3 = 40
elseif ( Field1 = Field2 ) then
 Field3 = 10
endif
Je nach den Werten von Field1 und Field2 unterschiedlich. Beispiel: Wenn Field1 den Wert 20 und Field2 den Wert 10 hat, setzt dieser Ausdruck Field3 auf den Wert 40.


while-Ausdrücke

Ein while-Ausdruck ist eine iterative Anweisung oder Schleife, die einen gegebenen einfachen Ausdruck prüft. Wenn das Ergebnis der Prüfung TRUE (1) ist, prüft FormCalc wiederholt die do-Bedingung und gibt die Ergebnisse der Ausdruckslisten zurück. Wenn das Ergebnis FALSE (0) ist, wird die Kontrolle an die nächste Anweisung übergeben.
Ein while-Ausdruck ist besonders dann geeignet, wenn bedingte Wiederholungen benötigt werden. Im Gegensatz hierzu sind for-Ausdrücke besser für Situationen geeignet, in denen nicht bedingte Wiederholungen benötigt werden.

Ausdruck

Syntax

Rückgabe
while

while ( simple expression ) do
    expression list
endwhile
Das Ergebnis der Liste von Ausdrücken, welche der do-Bedingung zugeordnet sind.
Im folgenden Beispiel werden die Werte der Elemente einer Dropdown-Liste aus einer XML-Datei hinzugefügt, indem die addItem-Methode für alle XML-Elemente verwendet wird, die in list1 aufgelistet und ungleich 3 sind.
    var List = ref(xfa.record.lists.list1)
    var i = 0
    while ( List.nodes.item(i+1).value ne "3")do
    $.addItem (List.nodes.item(i).value,List.nodes.item(i+1).value)
    i = i + 2
    endwhile


for-Ausdrücke

Ein for-Ausdruck ist eine bedingte iterative Anweisung oder Schleife.
Ein for-Ausdruck ist besonders in Schleifenlogiksituationen geeignet, in denen nicht bedingte Wiederholungen benötigt werden. Im Gegensatz hierzu sind while-Ausdrücke besser für Situationen geeignet, in denen bedingte Wiederholungen benötigt werden.
Der Wert des for-Ausdrucks ist der Wert der letzten Auswertungsliste, die ausgewertet wurde, oder FALSE (0).
Die for-Bedingung initialisiert eine FormCalc-Variable, welche die Schleifenlogikaktion steuert.
In der upto-Variante iteriert der Wert der Schleifenvariablen vom start-Ausdruck zum end-Ausdruck in step-Ausdrucksinkrementen. Wenn Sie den step-Ausdruck weglassen, ist das step-Inkrement standardmäßig 1.
In der downto-Variante iteriert der Wert der Schleifenvariablen vom start-Ausdruck zum end-Ausdruck in step-Ausdrucksdekrementen. Wen der step-Ausdruck weggelassen wird, ist das step-Dekrement standardmäßig -1.
Die Iterationen der Schleife werden vom Wert des end-Ausdrucks gesteuert. Vor jeder Iteration wird der end-Ausdruck ausgewertet und mit der Schleifenvariablen verglichen. Wenn das Ergebnis TRUE (1) ist, wird die Ausdrucksliste ausgewertet. Nach jeder Auswertung wird der step-Ausdruck ausgewertet und der Schleifenvariablen hinzugefügt.
Vor jeder Iteration wird der end-Ausdruck ausgewertet und mit der Schleifenvariablen verglichen. Außerdem wird nach jeder Auswertung der do-Bedingung der step-Ausdruck ausgewertet und der Schleifenvariablen hinzugefügt.
Eine for-Schleife endet, wenn der start-Ausdruck den end-Ausdruck überschritten hat. Der start-Ausdruck kann den end-Ausdruck entweder aufwärts überschreiten, wenn Sie upto verwenden, oder abwärts, wenn Sie downto verwenden.

Ausdruck

Syntax

Rückgabe
for

for variable = start expression
    (upto | downto ) end expression
        (step step expression ) do
    expression list
endfor
Die start-, end- und step-Ausdrücke müssen alle einfache Ausdrücke sein.
Das Ergebnis der Liste von Ausdrücken, welche der do-Bedingung zugeordnet sind.
Im folgenden Beispiel werden die Werte der Elemente einer Dropdown-Liste aus einer XML-Datei hinzugefügt, indem die addItem-Methode für alle XML-Elemente verwendet wird, die in list1 aufgelistet sind.
    var List = ref(xfa.record.lists.list1)
    for i=0 upto List.nodes.length - 1 step 2 do
    $.addItem (List.nodes.item(i).value,"")
    endfor


foreach-Ausdrücke

Ein foreach-Ausdruck iteriert über die Liste der Ausdrücke für jeden Wert in seiner Liste von Argumenten.
Der Wert des foreach-Ausdrucks ist der Wert der letzten Ausdrucksliste, die ausgewertet wurde, oder null (0), wenn die Schleife nicht in Gang gesetzt wurde.
Die in-Bedingung, die nur einmal ausgeführt wird (nachdem die Schleifenvariable deklariert wurde), steuert die Iteration der Schleife. Vor jeder Iteration werden der Schleifenvariablen aufeinander folgende Werte aus der Liste der Argumente zugewiesen. Die Liste der Argumente kann nicht leer sein.

Ausdruck

Syntax

Rückgabe
foreach

foreach variable in( argument list )do
    expression list
endfor
Verwenden Sie ein Komma (,), um einfache Ausdrücke in der Liste der Argumente voneinander zu trennen.
Der Wert der letzten Ausdrucksliste, die ausgewertet wurde, oder null (0), wenn die Schleife nicht in Gang gesetzt wurde.
Im folgenden Beispiel werden der foreach-Dropdown-Liste nur die Werte der XML-Elemente „display“ hinzugefügt.
    foreach Item in (xfa.record.lists.list1.display[*]) do
    $.addItem(Item,"")
    endfor


break-Ausdrücke

Ein break-Ausdruck löst das unmittelbare Verlassen der innersten umschließenden while-, for- oder foreach-Ausdrucksschleife aus. Die Steuerung wird an den Ausdruck übergeben, welcher der beendeten Schleife folgt.
Der Wert des break-Ausdrucks ist immer der Wert null (0).

Ausdruck

Syntax

Rückgabe
break

break
Übergibt die Steuerung an den Ausdruck, welcher der beendeten Schleife folgt.
Im folgenden Beispiel wird eine if-Bedingung in der while-Schleife platziert, um zu prüfen, ob der aktuelle Wert gleich „Display data for 2“ ist. Falls TRUE, wird der break-Ausdruck ausgeführt und verhindert, dass die Schleife fortgesetzt wird.
    var List = ref(xfa.record.lists.list1)
    var i=0
    while (List.nodes.item(i+1).value ne "3") do
    $.addItem(List.nodes.item(i).value,List.nodes.item(i+1).value)
    i = i + 2
    if (List.nodes.item(i) eq "Display data for 2" then
    break
    endif
    endwhile


continue-Ausdrücke

Ein continue-Ausdruck löst die nächste Iteration der innersten umschließenden while-, for- oder foreach-Schleife aus.
Der Wert des continue-Ausdrucks ist immer der Wert null (0).

Ausdruck

Syntax

Rückgabe
continue

continue
Wenn dieser Ausdruck in einem while-Ausdruck verwendet wird, wird die Steuerung an die while-Bedingung übergeben. Wenn dieser Ausdruck in einem for-Ausdruck verwendet wird, wird die Steuerung an den step-Ausdruck übergeben.
Das Ziel des folgenden Beispiels ist es, die Dropdown-Liste mit Werten aus der XML-Datei zu füllen. Wenn der Wert des aktuellen XML-Elements „Display data for 3“ ist, wird die while-Schleife über den break-Ausdruck beendet. Wenn der Wert des aktuellen XML-Elements „Display data for 2“ ist, fügt das Skript der Variablen i (dem Zähler) „2“ hinzu und die Schleife beginnt sofort ihren nächsten Zyklus. Die letzten beiden Zeilen werden ignoriert, wenn der Wert des aktuellen XML-Elements „Display data for 2“ ist.
    var List = ref(xfa.record.lists.list1)
    var i = 0
    while (List.nodes.item(i+1).value ne "5") do
    if (List.nodes.item(i) eq "Display data for 3") then
    break
    endif
    if (List.nodes.item(i) eq "Display data for 2" then
    i=i+2
    continue
    endif
    $.addItem(List.nodes.item(i).value,List.nodes.item(i+1).value)
    i=i+2
    endwhile
Mit Hilfe einer Reihe von Kurzbefehlen lassen sich Referenzen in FormCalc bequemer erstellen, wodurch der Zugriff auf Objekteigenschaften und -werte erleichtert wird. Die folgende Tabelle bietet einen Überblick über die für FormCalc verfügbaren Referenz-Syntax-Kurzbefehle.

Notation

Beschreibung
$
Bezeichnet das aktuelle Feld oder Objekt. Beispiel:
    $ = "Tony Blue"
Das obige Beispiel setzt den Wert des aktuellen Feldes oder Objekts auf Tony Blue.
$data
Bezeichnet den Stammknoten des Datenmodells xfa.datasets.data. Beispiel:
    $data.purchaseOrder.total
entspricht
    xfa.datasets.data.purchaseOrder.total
$event
Bezeichnet das aktuelle Formularobjekt-Ereignis. Beispiel:
    $event.name
entspricht
    xfa.event.name
Weitere Informationen finden Sie unter Grundlagen zum Ereignismodell.
$form
Bezeichnet den Stammknoten des Formularmodells xfa.form. Beispiel:
    $form.purchaseOrder.tax
entspricht
    xfa.form.purchaseOrder.tax
$host
Bezeichnet das Host-Objekt. Beispiel:
    $host.messageBox("Hello world")
entspricht
    xfa.host.messageBox("Hello world")
Weitere Informationen finden Sie unter Grundlagen zum Arbeiten mit Host-Anwendungen.
$layout
Bezeichnet den Stammknoten des Layoutmodells xfa.layout. Beispiel:
    $layout.ready
entspricht
    xfa.layout.ready
$record
Bezeichnet den aktuellen Datensatz aus einer Zusammenstellung von Daten, z. B. aus einer XML-Datei. Beispiel:
    $record.header.txtOrderedByCity
referenziert den Knoten txtOrderedByCity im Knoten header der aktuellen XML-Daten.
$template
Bezeichnet den Stammknoten des Vorlagenmodells xfa.template. Beispiel:
    $template.purchaseOrder.item
entspricht
    xfa.template.purchaseOrder.item
!
Bezeichnet den Stammknoten des Datenmodells xfa.datasets. Beispiel:
    !data
entspricht
    xfa.datasets.data
*
Wählt alle Formularobjekte innerhalb eines gegebenen Containers, z. B. in einem Teilformular, unabhängig von ihrem Namen bzw. alle Objekte mit einem ähnlichen Namen aus.
Beispielsweise wählt der folgende Ausdruck alle Objekte namens item in einem Formular aus:
    xfa.form.form1.item[*]
..
Sie können an jeder Stelle in Ihrer Referenz-Syntax zwei Punkte einsetzen, um nach Objekten zu suchen, die Teil eines Unter-Containers des aktuellen Container-Objekts (z. B. eines Teilformulars) sind. Beispielsweise bedeutet der Ausdruck Subform_Page..Subform2: Knoten Subform_Page lokalisieren (wie üblich) und einen Subform_Page untergeordneten Knoten namens Subform2 suchen.
Aus dem obigen Beispiel-Baumdiagramm ergibt sich:
    Subform_Page..TextField2
entspricht
    Subform_Page.Subform1[0].Subform3.TextField2[0]
da sich TextField2[0] im ersten Subform1-Knoten befindet, auf den FormCalc bei der Suche stößt. Ein zweites Beispiel:
    Subform_Page..Subform3[*]
gibt alle vier Instanzen des Objekts TextField2 zurück.
#
Das Nummernzeichen (#) dient zur Bezeichnung eines der folgenden Elemente in einer Referenz-Syntax:
      •
      Ein unbenanntes Objekt. Beispielsweise greift die folgende Referenz-Syntax auf ein unbenanntes Teilformular zu:

        xfa.form.form1.#subform
      •
      Geben Sie in einer Referenz-Syntax eine Eigenschaft an, wenn eine Eigenschaft und ein Objekt den gleichen Namen tragen. Beispielsweise greift die folgende Referenz-Syntax auf die Eigenschaft name eines Teilformulars zu, wenn das Teilformular auch ein Feld namens name hat:

        xfa.form.form1.#subform.#name
[ ]
Die eckige Klammer ([ ]) gibt den Vorkommenswert eines Objekts an. Um eine Referenz mit einem solchen Wert zu erstellen, setzen Sie eckige Klammern ([ ]) hinter einen Objektnamen und fügen Sie zwischen den eckigen Klammern einen der folgenden Werte ein:
      •
      [ n ], wobei n eine absolute Vorkommens-Indexnummer ist (der Index beginnt bei 0). Wenn eine Vorkommensnummer außerhalb des zulässigen Bereichs liegt, wird ein Fehler zurückgegeben. Beispiel:

        xfa.form.form1.#subform.Quantity[3]
        refers to the fourth occurrence of the Quantity object.
      •
      [ +/- n ], wobei n ein Vorkommen relativ zum Vorkommen des Objekts angibt, von welchem die Referenz ausgeht. Positive Werte liefern höhere Vorkommensnummern und negative Werte liefern niedrigere. Beispiel:

         xfa.form.form1.#subform.Quantity[+2]

      Diese Referenz liefert das Vorkommen von Quantity, dessen Vorkommensnummer um 2 höher ist als die Vorkommensnummer des Containers, von welchem die Referenz ausgeht. Stünde diese Referenz beispielsweise mit dem Objekt Quantity[2] in Verbindung, so wäre sie gleichbedeutend mit:

         xfa.template.Quantity[4]

      Wenn die berechnete Indexnummer außerhalb des zulässigen Bereichs liegt, gibt die Referenz einen Fehler zurück.

      Die häufigste Anwendung dieser Syntax ist die Ansteuerung des vorigen oder nächsten Vorkommens eines bestimmten Objekts. Beispielsweise könnte man bei jedem Vorkommen des Objekts Quantity (außer beim ersten) mit Quantity[-1] den Wert des vorigen Quantity-Objekts abrufen.
      •
      [*] gibt mehrere Vorkommen eines Objekts an. Das erste benannte Objekt wird gefunden und die mit dem ersten Objekt verwandten Objekte desselben Namens werden zurückgegeben. Beachten Sie, dass bei dieser Notation eine Zusammenstellung von mehreren Objekten zurückgegeben wird. Beispiel:

         xfa.form.form1.#subform.Quantity[*]

      Dieser Ausdruck bezieht sich auf alle Objekte mit dem Namen Quantity, welche mit dem ersten von der Referenz gefundenen Vorkommen von Quantity verwandt sind.
In sprachspezifischen Formularen für Arabisch, Hebräisch, Thailändisch und Vietnamesisch befindet sich die Referenz-Syntax grundsätzlich rechts (auch bei Sprachen, die von rechts nach links geschrieben werden).
LiveCycle Forms 7.1 bietet keine Unterstützung für Formularentwürfe mit arabischen, hebräischen, thailändischen und vietnamesischen Schriftzeichen.
[ ]
(Fortsetzung)
In dem gezeigten Baumdiagramm geben diese Ausdrücke jeweils die folgenden Objekte zurück:
      •
      Subform_Page.Subform1[*] gibt beide Subform1-Objekte zurück.
      •
      Subform_Page.Subform1.Subform3.TextField2[*] gibt die beiden TextField2-Objekte zurück. Subform_Page.Subform1 wird zum ersten Subform1-Objekt auf der linken Seite aufgelöst und TextField2[*] wird relativ zum Objekt Subform3 ausgewertet.
      •
      Subform_Page.Subform1[*].TextField1 gibt beide TextField1-Instanzen zurück. Subform_Page.Subform1[*] wird zu den beiden Subform1-Objekten aufgelöst und TextField1 wird relativ zu den Subform1-Objekten ausgewertet.
      •
      Subform_Page.Subform1[*].Subform3.TextField2[1] gibt das zweite und vierte TextField2-Objekt von links zurück. Subform_Page.Subform1[*] wird zu den beiden Subform1-Objekten aufgelöst und TextField2[1] wird relativ zu den Subform3-Objekten ausgewertet.
      •
      Subform_Page.Subform1[*].Subform3[*] gibt beide Instanzen des Subform3-Objekts zurück.
      •
      Subform_Page.* gibt beide Subform1-Objekte und das Subform2-Objekt zurück.
      •
      Subform_Page.Subform2.* gibt die beiden Instanzen des NumericField2-Objekts zurück.


Arithmetik-Funktionen

Grundlagen zu Arithmetik-Funktionen
Abs
Avg
Ceil
Count
Floor
Max
Min
Mod
Round
Sum


Grundlagen zu Arithmetik-Funktionen

Diese Funktionen führen verschiedene mathematische Operationen aus.
Funktionen
      •
      Abs
      •
      Avg
      •
      Ceil
      •
      Count
      •
      Floor
      •
      Max
      •
      Min
      •
      Mod
      •
      Round
      •
      Sum


Abs

Gibt den Betragswert eines Zahlenwerts oder Ausdrucks zurück bzw. liefert das Ergebnis null, wenn der Wert oder Ausdruck null ist.
Syntax
Abs(n1)
Parameter

Parameter

Beschreibung

n1
Ein auszuwertender Zahlenwert oder Ausdruck.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Abs:

Ausdruck

Rückgabe

Abs(1.03)

1.03

Abs(-1.03)

1.03

Abs(0)

0


Avg

Wertet einen Satz von Zahlenwerten und/oder Ausdrücken aus und gibt den Mittelwert der von null verschiedenen Elemente innerhalb dieses Satzes zurück.
Syntax
Avg(n1 [, n2 ...])
Parameter

Parameter

Beschreibung

n1
Der erste Zahlenwert oder Ausdruck des Satzes.
n2 (optional)
Weitere Zahlenwerte oder Ausdrücke.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Avg:

Ausdruck

Rückgabe

Avg(0, 32, 16)

16

Avg(2.5, 17, null)

9.75

Avg(Price[0], Price[1], Price[2], Price[3])
Der Mittelwert der vier ersten von null verschiedenen Vorkommen von Price.

Avg(Quantity[*])
Der Mittelwert aller von null verschiedenen Vorkommen von Quantity.


Ceil

Gibt die ganze Zahl zurück, die unmittelbar größer oder gleich einer gegebenen Zahl ist, oder liefert das Ergebnis null, wenn der Parameter null ist.
Syntax
Ceil(n)
Parameter

Parameter

Beschreibung

n
Ein beliebiger Zahlenwert oder Ausdruck.
Die Funktion gibt 0 zurück, wenn n kein Zahlenwert oder Ausdruck ist.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Ceil:

Ausdruck

Rückgabe

Ceil(2.5875)

3

Ceil(-5.9)

-5

Ceil("abc")

0

Ceil(A)
100, wenn der Wert von A 99.999 beträgt.


Count

Wertet einen Satz von Werten und/oder Ausdrücken aus und gibt die Anzahl der von null verschiedenen Elemente innerhalb dieses Satzes zurück.
Syntax
Count(n1 [, n2 ...])
Parameter

Parameter

Beschreibung

n1
Ein Zahlenwert oder Ausdruck.
n2 (optional)
Weitere Zahlenwerte und/oder Ausdrücke.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Count:

Ausdruck

Rückgabe

Count("Tony", "Blue", 41)

3

Count(Customers[*])
Die Anzahl der von null verschiedenen Vorkommen von Customers.

Count(Coverage[2], "Home", "Auto")
3, sofern das dritte Vorkommen von Coverage von null verschieden ist.


Floor

Gibt die größte Ganzzahl zurück, die kleiner oder gleich dem angegebenen Wert ist.
Syntax
Floor(n)
Parameter

Parameter

Beschreibung

n
Ein beliebiger Zahlenwert oder Ausdruck.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Floor:

Ausdruck

Rückgabe

Floor(21.3409873)

21

Floor(5.999965342)

5

Floor(3.2 * 15)

48


Max

Gibt den Maximalwert der von null verschiedenen Elemente im angegebenen Satz von Zahlen zurück.
Syntax
Max(n1 [, n2 ...])
Parameter

Parameter

Beschreibung

n1
Ein Zahlenwert oder Ausdruck.
n2 (optional)
Weitere Zahlenwerte und/oder Ausdrücke.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Max:

Ausdruck

Rückgabe

Max(234, 15, 107)

234

Max("abc", 15, "Tony Blue")

15

Max("abc")

0

Max(Field1[*], Field2[0])
Hier werden die von null verschiedenen Vorkommen von Field1 sowie das erste Vorkommen von Field2 ausgewertet und der höchste Wert wird zurückgegeben.

Max(Min(Field1[*], Field2[0]), Field3, Field4)
Hier werden die von null verschiedenen Vorkommen von Field1 sowie das erste Vorkommen von Field2 ausgewertet und der niedrigste Wert wird zurückgegeben. Das Endergebnis ist der aus dem Vergleich dieses Wertes mit den Werten für Field3 und Field4 ermittelte Höchstwert.
Siehe auch Min.


Min

Gibt den Minimalwert der von null verschiedenen Elemente im angegebenen Satz von Zahlen zurück.
Syntax
Min(n1 [, n2 ...])
Parameter

Parameter

Beschreibung

n1
Ein Zahlenwert oder Ausdruck.
n2 (optional)
Weitere Zahlenwerte und/oder Ausdrücke.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Min:

Ausdruck

Rückgabe

Min(234, 15, 107)

15

Min("abc", 15, "Tony Blue")

15

Min("abc")

0

Min(Field1[*], Field2[0])
Hier werden die von null verschiedenen Vorkommen von Sales_July sowie das erste Vorkommen von Sales_August ausgewertet und der niedrigste Wert wird zurückgegeben.

Min(Max(Field1[*], Field2[0]), Field3, Field4)
Hier werden die von null verschiedenen Vorkommen von Field1 sowie das erste Vorkommen von Field2 ausgewertet und der höchste Wert wird zurückgegeben. Das Endergebnis ist der aus dem Vergleich dieses Wertes mit den Werten für Field3 und Field4 ermittelte Höchstwert.
Siehe auch Max.


Mod

Gibt den Modulus der Division einer Zahl durch eine andere zurück. Der Modulus ist der Rest, der sich bei der Division des Dividenden durch den Divisor ergibt. Das Vorzeichen des Rests entspricht stets dem Vorzeichen des Dividenden.
Syntax
Mod(n1, n2)
Parameter

Parameter

Beschreibung

n1
Der Dividend, ein Zahlenwert oder Ausdruck.

n2
Der Divisor, ein Zahlenwert oder Ausdruck.
Wenn n1 und/oder n2 keine Zahlenwerte oder Ausdrücke sind, gibt die Funktion den Wert 0 zurück.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Mod:

Ausdruck

Rückgabe

Mod(64, -3)

1

Mod(-13,3)

-1

Mod("abc", 2)

0

Mod(X[0], Y[9])
Das erste Vorkommen von X wird als Dividend verwendet und das zehnte Vorkommen von Y als Divisor.

Mod(Round(Value[4], 2), Max(Value[*]))
Das fünfte Vorkommen von Value, auf zwei Dezimalstellen gerundet, wird als Dividend verwendet und das größte aller von null verschiedenen Vorkommen von Value wird als Divisor verwendet.
Siehe auch Max und Round.


Round

Wertet einen angegebenen Zahlenwert oder Ausdruck aus und gibt eine auf die angegebene Anzahl von Dezimalstellen gerundete Zahl zurück.
Syntax
Round(n1 [, n2])
Parameter

Parameter

Beschreibung

n1
Ein auszuwertender Zahlenwert oder Ausdruck.
n2 (optional)
Die Anzahl von Dezimalstellen (maximal 12), mit der n1 auszuwerten ist.
Wenn Sie keinen Wert für n2 angeben oder wenn n2 ungültig ist, geht die Funktion davon aus, dass die Anzahl der Dezimalstellen 0 ist.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Round:

Ausdruck

Rückgabe

Round(12.389764537, 4)

12.3898

Round(20/3, 2)

6.67

Round(8.9897, "abc")

9

Round(FV(400, 0.10/12, 30*12), 2)
904195.17. Hier wird der mit der Funktion FV ausgewertete Wert übernommen und auf zwei Dezimalstellen gerundet.
Siehe auch FV.

Round(Total_Price, 2)
Rundet den Wert von Total_Price auf zwei Dezimalstellen ab.


Sum

Gibt die Summe der von null verschiedenen Elemente eines gegebenen Satzes von Zahlen zurück.
Syntax
Sum(n1 [, n2 ...])
Parameter

Parameter

Beschreibung

n1
Ein Zahlenwert oder Ausdruck.
n2 (optional)
Weitere Zahlenwerte und/oder Ausdrücke.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Sum:

Ausdruck

Rückgabe

Sum(2, 4, 6, 8)

20

Sum(-2, 4, -6, 8)

4

Sum(4, 16, "abc", 19)

39

Sum(Amount[2], Amount[5])
Summiert das dritte und sechste Vorkommen von Amount.

Sum(Round(20/3, 2), Max(Amount[*]), Min(Amount[*]))
Summiert den Wert von 20/3, auf zwei Dezimalstellen gerundet, sowie das größte und das kleinste der von null verschiedenen Vorkommen von Amount.
Siehe auch Max, Min und Round.


Datums- und Uhrzeitfunktionen

Grundlagen zu Datums- und Uhrzeitfunktionen
Date
Date2Num
DateFmt
IsoDate2Num
IsoTime2Num
LocalDateFmt
LocalTimeFmt
Num2Date
Num2GMTime
Num2Time
Time
Time2Num
TimeFmt


Grundlagen zu Datums- und Uhrzeitfunktionen

Die Funktionen in diesem Kapitel dienen speziell zur Erstellung und Bearbeitung von Datums- und Uhrzeitwerten.
Funktionen
      •
      Date
      •
      Date2Num
      •
      DateFmt
      •
      IsoDate2Num
      •
      IsoTime2Num
      •
      LocalDateFmt
      •
      LocalTimeFmt
      •
      Num2Date
      •
      Num2GMTime
      •
      Num2Time
      •
      Time
      •
      Time2Num
      •
      TimeFmt
Ein Gebietsschema ist ein Standardbegriff, der bei der Entwicklung internationaler Standards zur Identifizierung einer bestimmten Nationalität (Sprache und/oder Land) dient. In FormCalc legt ein Gebietsschema die für ein bestimmtes Land oder für eine bestimmte Region gültigen Datums-, Uhrzeit-, Zahlen- und Währungsformate fest, um zu gewährleisten, dass die Endbenutzer die gewohnten Formate verwenden können.
Jedes Gebietsschema besteht aus einer eindeutigen Zeichenfolge, der Gebietsschema-Kennung. Der Inhalt dieser Zeichenfolgen wird von der Internationalen Standardisierungsorganisation (ISO) Internet Engineering Task Force (IETF) kontrolliert, die eine Arbeitsgruppe der Internet Society ist (www.isoc.org).
Gebietsschema-Kennungen bestehen aus einem Sprachenteil, einem Länderteil oder beidem. Die folgende Tabelle enthält die gültigen Gebietsschemata für diese Version von LiveCycle Designer:

Sprache

Land

ISO-Code
Arabisch
Vereinigte Arabische Emirate
ar_AE
Arabisch
Bahrain
ar_BH
Arabisch
Algerien
ar_DZ
Arabisch
Ägypten
ar_EG
Arabisch
Irak
ar_IQ
Arabisch
Jordanien
ar_JO
Arabisch
Kuwait
ar_KW
Arabisch
Libanon
ar_LB
Arabisch
Libyen
ar_LY
Arabisch
Marokko
ar_MA
Arabisch
Oman
ar_OM
Arabisch
Katar
ar_QA
Arabisch
Saudi-Arabien
ar_SA
Arabisch
Sudan
ar_SD
Arabisch
Syrien
ar_SY
Arabisch
Tunesien
ar_TN
Arabisch
Jemen
ar_YE
Bulgarisch
Bulgarien
bg_BG
Chinesisch
Hongkong
zh_HK
Chinesisch
Volksrepublik China (vereinfacht)
zh_CN
Chinesisch
Taiwan (traditionell)
zh_TW
Dänisch
Dänemark
da_DK
Deutsch
Österreich
de_AT
Deutsch
Deutschland
de_DE
Deutsch
Luxemburg
de_LU
Deutsch
Schweiz
de_CH
Englisch
Australien
en_AU
Englisch
Kanada
en_CA
Englisch
Indien
en_IN
Englisch
Irland
en_IE
Englisch
Neuseeland
en_NZ
Englisch
Südafrika
en_ZA
Englisch
Großbritannien
en_GB
Englisch
Großbritannien (Europa)
en_GB_EURO
Englisch
Vereinigte Staaten von Amerika
en_US
Estnisch
Estland
et_EE
Finnisch
Finnland
fi_FI
Flämisch
Belgien
nl_BE
Französisch
Belgien
fr_BE
Französisch
Kanada
fr_CA
Französisch
Frankreich
fr_FR
Französisch
Luxemburg
fr_LU
Französisch
Schweiz
fr_CH
Griechisch
Griechenland
el_GR
Hebräisch
Israel
he_IL
Indonesisch
Indonesien
id_ID
Italienisch
Italien
it_IT
Italienisch
Schweiz
it_CH
Japanisch
Japan
ja_JP
Koreanisch
Republik Korea
ko_KR
Koreanisch
Korea (Hanja-Zeichen)
ko_KR_HANI
Kroatisch
Kroatien
hr_HR
Lettisch
Lettland
lv_LV
Litauisch
Litauen
lt_LT
Malaiisch
Malaysia
ms_MY
Niederländisch
Niederlande
nl_NL
Norwegisch (Bokmal)
Norwegen
nb_NO
Norwegisch (Nynorsk)
Norwegen
nn_NO
Polnisch
Polen
pl_PL
Portugiesisch
Brasilien
pt_BR
Portugiesisch
Portugal
pt_PT
Rumänisch
Rumänien
ro_RO
Russisch
Russland
ru_RU
Schwedisch
Schweden
sv_SE
Serbokroatisch
Bosnien und Herzegowina
sh_BA
Serbokroatisch
Kroatien
sh_HR
Serbokroatisch
Serbien und Montenegro
sh_CS
Slowakisch
Slowakei
sk_SK
Slowenisch
Slowenien
sl_SI
Spanisch
Ecuador
es_EC
Spanisch
El Salvador
es_SV
Spanisch
Guatemala
es_GT
Spanisch
Honduras
es_HN
Spanisch
Nicaragua
es_NI
Spanisch
Panama
es_PA
Spanisch
Paraguay
es_PY
Spanisch
Puerto Rico
es_PR
Spanisch
Uruguay
es_UY
Spanisch
Argentinien
es_AR
Spanisch
Bolivien
es_BO
Spanisch
Chile
es_CL
Spanisch
Kolumbien
es_CO
Spanisch
Costa Rica
es_CR
Spanisch
Dominikanische Republik
es_DO
Spanisch
Mexiko
es_MX
Spanisch
Peru
es_PE
Spanisch
Spanien
es_ES
Spanisch
Venezuela
es_VE
Thailändisch
Thailand
th_TH
Thailändisch
Thailand, traditionell
th_TH_TH
Tschechisch
Tschechische Republik
cs_CAZ
Türkisch
Türkei
tr_TR
Ukrainisch
Ukraine
uk_UA
Ungarisch
Ungarn
hu_HU
Vietnamesisch
Vietnam
vi_VN
In der Regel sind beide Elemente eines Gebietsschemas von Bedeutung. Beispielsweise werden die Namen der Wochentage und Monate in Englisch für Kanada und Großbritannien identisch formatiert, Datumsangaben aber unterschiedlich. Daher ist die Angabe der Sprache Englisch als Gebietsschema nicht ausreichend. Die Angabe nur des Landes als Gebietsschema ist ebenfalls unzureichend. So gibt es für Kanada unterschiedliche Datumsformate für Englisch und Französisch.
Grundsätzlich wird jede Anwendung in einer Umgebung eingesetzt, in der ein Gebietsschema vorhanden ist. Dieses Gebietsschema wird als Umgebungsgebietsschema bezeichnet. Unter bestimmten Umständen wird eine Anwendung auf einem System oder in einer Umgebung ausgeführt, in der kein Gebietsschema vorhanden ist. In diesen seltenen Fällen wird das Umgebungsgebietsschema auf den Standardwert Englisch, USA gesetzt (en_US). Dieses Gebietsschema wird als Standardgebietsschema bezeichnet.
Sowohl den Datums- als auch den Uhrzeitwerten ist ein Ursprung oder eine Epoche zugeordnet, d. h. ein Zeitpunkt, an dem die Zeitrechnung begonnen wurde. Alle Datums- und Uhrzeitwerte, die vor dieser Epoche liegen, sind ungültig.
Die Werteinheit für Datumsfunktionen ist die seit Beginn der Epoche verstrichene Anzahl von Tagen. Die Werteinheit für Uhrzeitfunktionen ist die seit Beginn der Epoche verstrichene Anzahl von Millisekunden.
In LiveCycle Designer ist der erste Tag der Epoche für die Datumsfunktionen der 1. Januar 1900 und die erste Millisekunde der Epoche für die Uhrzeitfunktionen ist Mitternacht, 00:00:00, Greenwich Mean Time (GMT). Aus dieser Definition folgt, dass für Benutzer in Zeitzonen östlich der Greenwich Mean Time eventuell negative Uhrzeitwerte zurückgegeben werden.
Ein Datumsformat gibt in Kurzform an, wie das Datum dargestellt wird. Es besteht aus mehreren Interpunktionszeichen und Symbolen, die das Format angeben, in dem das Datum dargestellt werden soll. Die folgende Tabelle zeigt einige Beispiele für Datumsformate:

Datumsformat

Beispiel
MM/DD/YY
11/11/78
DD/MM/YY
25/07/85
MMMM DD, YYYY
März 10, 1964
Das Datumsformat wird von einem ISO-Standard bestimmt. Jedes Land bzw. jede Region legt ihr eigenes Datumsformat fest. Dabei stehen eine kurze, eine mittlere, eine lange und eine vollständige Formatkategorie zur Auswahl. In der folgenden Tabelle sind Beispiele zu den unterschiedlichen Datumsformaten in verschiedenen Gebietsschemata für die einzelnen Kategorien aufgeführt.

Gebietsschema-Kennung und Beschreibung

Datumsformat (Kategorie)

Beispiel
en_GB
Englisch (Großbritannien)
DD/MM/YY (kurz)
08/18/92
08/04/05
fr_CA
Französisch (Kanada)
YY-MM-DD (mittel)
92-08-18
de_DE
Deutsch (Deutschland)
D. MMMM YYYY (lang)
17. Juni 1989
fr_FR
Französisch (Frankreich)
EEEE, 'le' D MMMM YYYY (vollständig)
Lundi, le 29 Octobre, 1990
Ein Zeitformat gibt in Kurzform an, wie die Uhrzeit formatiert wird. Es besteht aus Interpunktionszeichen, Literalen und Mustersymbolen. Die folgende Tabelle zeigt einige Beispiele für Uhrzeitformate:

Uhrzeitformat

Beispiel
h:MM A
19:15 Uhr
HH:MM:SS
21:35:26
HH:MM:SS 'o''clock' A Z
14:20:10 o’clock PM EDT
Uhrzeitformate werden von einer ISO-Norm bestimmt. Jedes Land legt die Form seiner Uhrzeitformate in einer Standard- sowie einer kurzen, mittleren, langen und vollständigen Variante fest. Im Gebietsschema wird das Format der Uhrzeiten festgelegt, die den Standards des betreffenden Landes entsprechen.
In der folgenden Tabelle sind einige Beispiele für die unterschiedlichen Datumsformate in verschiedenen Gebietsschemata für die einzelnen Kategorien aufgeführt.

Gebietsschema-Kennung und Beschreibung

Uhrzeitformat (Kategorie)

Beispiel
en_GB
Englisch (Großbritannien)
HH:MM (kurz)
14:13
fr_CA
Französisch (Kanada)
HH:MM:SS (mittel)
12:15:50
de_DE
Deutsch (Deutschland)
HH:MM:SS z (lang)
14:13:13 -0400
fr_FR
Französisch (Frankreich)
HH ‘h‘ MM Z (vollständig)
14 h 13 GMT-04:00
Die folgenden Symbole müssen verwendet werden, um Datums- und Uhrzeitmuster für Datums-/Uhrzeitfelder zu erstellen. Bestimmte Datumssymbole werden nur in den Gebietsschemata für Chinesisch, Japanisch und Koreanisch verwendet. Diese Symbole werden unten auch angegeben.
Komma (,), Bindestrich (-), Doppelpunkt (:), Schrägstrich (/), Punkt (.) und Leerzeichen ( ) werden als Literalwerte behandelt und können an einer beliebigen Stelle in einem Muster vorkommen. Wenn eine Wortfolge in ein Muster aufgenommen werden soll, schließen Sie sie in einfache Anführungszeichen (') ein. Beispielsweise kann 'Your payment is due no later than' MM-DD-YY als Anzeigemuster festgelegt werden.

Datumssymbol

Beschreibung

Formatierter Wert für das Gebietsschema Englisch (USA). Dabei lautet der dem Gebietsschema entsprechende Eingabewert 1/1/08 (dies bedeutet „January 1, 2008“).

D
1- oder 2-stelliger (1-31) Tag des Monats
1

DD
Mit 0 aufgefüllter 2-stelliger (01-31) Tag des Monats
01

J
1-, 2- oder 3-stelliger (1-366) Tag des Jahres
1

JJJ
Mit 0 aufgefüllter dreistelliger (001-366) Tag des Jahres
001

M
Ein- oder zweistelliger (1-12) Monat des Jahres
1

MM
Mit 0 aufgefüllter zweistelliger (01-12) Monat des Jahres
01

MMM
Abgekürzter Monatsname
Jan

MMMM
Vollständiger Monatsname
Januar

E
Einstelliger (1-7) Tag der Woche: 1=Sonntag
3 (weil der 1. Januar 2008 auf einen Dienstag fällt)

EEE
Abgekürzter Wochentag
Tue (weil der 1. Januar 2008 auf einen Dienstag [engl. „Tuesday“] fällt)

EEEE
Vollständiger Wochentag
Tuesday (weil der 1. Januar 2008 auf einen Dienstag [engl. „Tuesday“] fällt)

YY
Zweistellige Jahreszahl, wobei Zahlen unter 30 als Jahresangaben nach dem Jahr 2000 und Zahlen ab 30 als Jahresangaben vor dem Jahr 2000 zu verstehen sind. Beispiele: 00=2000, 29=2029, 30=1930 und 99=1999
08

YYYY
Vierstellige Jahreszahl
2008

G
Epochenname (v. Chr. oder n. Chr.)
AD (engl. für „n. Chr.“)

w
Einstellige (0-5) Wochennummer des Monats: Woche 1 ist die früheste auf einen Samstag endende Sequenz von vier aufeinander folgenden Tagen
1

WW
Zweistellige (01-53) Woche des Jahres gemäß ISO-8601: Woche 1 ist die Woche, die den 4. Januar enthält
01
Es sind verschiedene weitere Datumsmuster für die Darstellung von Daten in den Gebietsschemata für Chinesisch, Japanisch und Koreanisch verfügbar.
Japanische Epochen können anhand verschiedener Symbole dargestellt werden. Die letzten vier Epochensymbole sind alternative Symbole für die Darstellung japanischer Ären.

Datensymbol (Chinesisch, Japanisch, Koreanisch)

Beschreibung

DDD
Der ideografisch-numerisch festgelegte Tag des Monats im Gebietsschema.

DDDD
Der nach der Zehnerregel ideografisch-numerisch festgelegte Tag des Monats im Gebietsschema.

YYY
Das ideografisch-numerisch festgelegte Jahr im Gebietsschema.

YYYYY
Das nach der Zehnerregel ideografisch-numerisch festgelegte Jahr im Gebietsschema.

g
Der alternative Epochenname des Gebietsschemas. Für die gegenwärtige japanische Epoche Heisei zeigt dieses Muster das ASCII-Zeichen H (U+48) an.

gg
Der alternative Epochenname des Gebietsschemas. Für die gegenwärtige japanische Epoche zeigt dieses Muster das Kanji an, das dem Unicode-Symbol (U+5E73) entspricht.

ggg
Der alternative Epochenname des Gebietsschemas. Für die gegenwärtige japanische Epoche zeigt dieses Muster die Kanjis an, die den Unicode-Symbolen (U+5E73 U+6210) entsprechen.

 g
Der alternative Epochenname des Gebietsschemas. Für die gegenwärtige japanische Epoche zeigt dieses Muster das ASCII-Zeichen H (U+FF28) in voller Breite an.

 g g
Der alternative Epochenname des Gebietsschemas. Für die gegenwärtige japanische Epoche zeigt dieses Muster das Kanji an, das dem Unicode-Symbol (U+337B) entspricht.

Zeitsymbol

Beschreibung

Dem Gebietsschema entsprechender Eingabewert

Formatierter Wert für das Gebietsschema Englisch (USA)

h
Ein- oder zweistellige (1-12) Stunde im 12-Stunden-System (AM/PM)
12:08 AM oder 2:08 PM
12 oder 2

hh
Mit 0 aufgefüllte zweistellige (01-12) Stunde im 12-Stunden-System (AM/PM)
12:08 AM oder 2:08 PM
12 oder 02

k
Ein- oder zweistellige (0-11) Stunde im 12-Stunden-System (AM/PM)
12:08 AM oder 2:08 PM
0 oder 2

kk
Zweistellige (00-11) Stunde im 12-Stunden-System (AM/PM)
12:08 AM oder 2:08 PM
00 oder 02

H
Ein- oder zweistellige (0-23) Stunde des Tages
12:08 AM oder 2:08 PM
0 oder 14

HH
Mit 0 aufgefüllte zweistellige (00-23) Stunde des Tages
12:08 AM oder 2:08 PM
00 oder 14

K
Ein- oder zweistellige (1-24) Stunde des Tages
12:08 AM oder 2:08 PM
24 oder 14

KK
Mit 0 aufgefüllte zweistellige (01-24) Stunde des Tages
12:08 AM oder 2:08 PM
24 oder 14

M
Ein- oder zweistellige (0-59) Minute der Stunde
Sie müssen dieses Symbol zusammen mit einem Stundensymbol verwenden.
2:08 PM
8

MM
Mit 0 aufgefüllte zweistellige (00-59) Minute der Stunde
Sie müssen dieses Symbol zusammen mit einem Stundensymbol verwenden.
2:08 PM
08

S
Ein- oder zweistellige (0-59) Sekunde der Minute
Sie müssen dieses Symbol zusammen mit einem Stunden- und Minutensymbol verwenden.
2:08:09 PM
9

SS
Mit 0 aufgefüllte zweistellige (00-59) Sekunde der Minute
Sie müssen dieses Symbol zusammen mit einem Stunden- und Minutensymbol verwenden.
2:08:09 PM
09

FFF
Dreistellige (000-999) Tausendstelsekunde
Sie müssen dieses Symbol zusammen mit einem Stunden-, Minuten- und Sekundensymbol verwenden.
2:08:09 PM
09

A
Der Zeitraum von Mitternacht bis Mittag (AM) bzw. von Mittag bis Mitternacht (PM)
2:08:09 PM
PM

z
Zeitzonenformat nach ISO-8601 (z. B. Z, +0500, -0030, -01, +0100)
Sie müssen dieses Symbol zusammen mit einem Stundensymbol verwenden.
2:08:09 PM
-0400

zz
Alternatives ISO-8601 Zeitzonenformat (z. B. Z, +05:00, -00:30, -01, +01:00)
Sie müssen dieses Symbol zusammen mit einem Stundensymbol verwenden.
2:08:09 PM
-04:00

Z
Abgekürzter Zeitzonenname (z. B. GMT, GMT+05:00, GMT-00:30, EST, PDT)
Sie müssen dieses Symbol zusammen mit einem Stundensymbol verwenden.
2:08:09 PM
EDT
Reservierte Symbole
Die folgenden Symbole haben spezielle Bedeutungen und können nicht als Literalzeichen im Text verwendet werden.
?
Das Symbol entspricht einem beliebigen Zeichen. Wenn es für die Anzeige zusammengeführt wird, wandelt es sich zu einem Leerzeichen.

*
Das Symbol steht beim Senden für 0 oder für UNICODE-Leerzeichen. Wenn es für die Anzeige zusammengeführt wird, wandelt es sich zu einem Leerzeichen.

+
Das Symbol steht beim Senden für ein oder mehrere UNICODE-Leerzeichen. Wenn es für die Anzeige zusammengeführt wird, wandelt es sich zu einem Leerzeichen.


Date

Gibt das aktuelle Systemdatum als Anzahl von Tagen seit Beginn der Epoche zurück.
Syntax
Date()
Parameter
Keine
Beispiele
Die folgende Tabelle zeigt ein Beispiel für die Verwendung der Funktion Date:

Ausdruck

Rückgabe

Date()
37875 (die Anzahl der Tage vom Beginn der Epoche bis zum 12. September 2003)


Date2Num

Gibt für eine angegebene Datums-Zeichenfolge die Anzahl von Tagen seit Beginn der Epoche zurück.
Syntax
Date2Num(d [, f [, k ]])
Parameter

Parameter

Beschreibung

d
Eine Datums-Zeichenfolge in dem von f gelieferten Format, die auch dem von k angegebenen Gebietsschema entspricht.
f (optional)
Eine Datumsformat-Zeichenfolge. Wenn f nicht angegeben ist, wird das Standard-Datumsformat MMM D, YYYY verwendet.
k (optional)
Eine Zeichenfolge für die Gebietsschema-Kennung, welche den Benennungsstandards für Gebietsschemata entspricht. Wenn k nicht angegeben (oder ungültig) ist, wird das Umgebungsgebietsschema verwendet.
Die Funktion gibt den Wert 0 zurück, wenn mindestens eine der folgenden Bedingungen erfüllt ist:
      •
      Das Format des angegebenen Datums entspricht nicht dem in der Funktion angegebenen Format.
      •
      Das in der Funktion angegebene Gebietsschema oder Datumsformat ist ungültig.
Es sind nicht genügend Informationen angegeben, um einen eindeutigen Tag seit Beginn der Epoche zu bestimmen (das heißt, die Datumsangaben fehlen oder sind unvollständig).
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Date2Num:

Ausdruck

Rückgabe

Date2Num("Mar 15, 1996")

35138

Date2Num("1/1/1900", "D/M/YYYY")

1

Date2Num("03/15/96", "MM/DD/YY")

35138

Date2Num("Aug 1,1996", "MMM D, YYYY")

35277

Date2Num("96-08-20", "YY-MM-DD", "fr_FR")

35296

Date2Num("1/3/00", "D/M/YY") - Date2Num("1/2/00", "D/M/YY")

29


DateFmt

Gibt für einen angegebenen Datumsformat-Stil eine Datumsformat-Zeichenfolge zurück.
Syntax
DateFmt([n [, k ]])
Parameter

Parameter

Beschreibung
n (optional)
Eine Ganzzahl, welche den durch das Gebietsschema festgelegten Datumsformat-Stil angibt wie folgt:
      •
      1 (Kurzer Formatstil)
      •
      2 (Mittlerer Formatstil)
      •
      3 (Langer Formatstil)
      •
      4 (Vollständiger Formatstil)
Wenn n nicht angegeben (oder ungültig) ist, wird der Standardstilwert 0 verwendet.
k (optional)
Eine Zeichenfolge für die Gebietsschema-Kennung, welche den Benennungsstandards für Gebietsschemata entspricht. Wenn k nicht angegeben (oder ungültig) ist, wird das Umgebungsgebietsschema verwendet.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion DateFmt:

Ausdruck

Rückgabe

DateFmt(1)
M/D/YY (bei Gebietsschema en_US)

DateFmt(2, "fr_CA")

YY-MM-DD

DateFmt(3, "de_DE")

D. MMMM YYYY

DateFmt(4, "fr_FR")

EEEE D' MMMM YYYY


IsoDate2Num

Gibt für eine angegebene gültige Datums-Zeichenfolge die Anzahl der Tage seit Beginn der Epoche zurück.
Syntax
IsoDate2Num(d)
Parameter

Parameter

Beschreibung

d
Eine gültige Datums-Zeichenfolge.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion IsoDate2Num:

Ausdruck

Rückgabe

IsoDate2Num("1900")

1

IsoDate2Num("1900-01")

1

IsoDate2Num("1900-01-01")

1

IsoDate2Num("19960315T20:20:20")

35138

IsoDate2Num("2000-03-01") - IsoDate2Num("20000201")

29


IsoTime2Num

Gibt für eine angegebene gültige Uhrzeit-Zeichenfolge die Anzahl der Millisekunden seit Beginn der Epoche zurück.
Syntax
IsoTime2Num(d)
Parameter

Parameter

Beschreibung

d
Eine gültige Uhrzeit-Zeichenfolge.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion IsoTime2Num:

Ausdruck

Rückgabe

IsoTime2Num("00:00:00Z")
1, für einen Benutzer in der nordamerikanischen Zeitzone Eastern Time (ET).

IsoTime2Num("13")
64800001, für einen Benutzer in Boston, USA.

IsoTime2Num("13:13:13")
76393001, für einen Benutzer in Kalifornien.

IsoTime2Num("19111111T131313+01")
43993001, für einen Benutzer in der nordamerikanischen Zeitzone Eastern Time (ET).


LocalDateFmt

Gibt eine lokalisierte Datumsformat-Zeichenfolge mit dem angegebenen Datumsformat-Stil zurück.
Syntax
LocalDateFmt([n [, k ]])
Parameter

Parameter

Beschreibung
n (optional)
Eine Ganzzahl, welche den durch das Gebietsschema festgelegten Datumsformat-Stil angibt wie folgt:
      •
      1 (Kurzer Formatstil)
      •
      2 (Mittlerer Formatstil)
      •
      3 (Langer Formatstil)
      •
      4 (Vollständiger Formatstil)
Wenn n nicht angegeben (oder ungültig) ist, wird der Standardstilwert 0 verwendet.
k (optional)
Eine Zeichenfolge für die Gebietsschema-Kennung, welche den Benennungsstandards für Gebietsschemata entspricht. Wenn k nicht angegeben (oder ungültig) ist, wird das Umgebungsgebietsschema verwendet.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Funktion LocalDateFmt:

Ausdruck

Rückgabe

LocalDateFmt(1, "de_DE")

tt.MM.uu

LocalDateFmt(2, "fr_CA")

aa-MM-jj

LocalDateFmt(3, "de_CH")

t. MMMM jjjj

LocalDateFmt(4, "fr_FR")

EEEE j MMMM aaaa


LocalTimeFmt

Gibt eine lokalisierte Uhrzeitformat-Zeichenfolge mit dem angegebenen Uhrzeitformat-Stil zurück.
Syntax
LocalTimeFmt([n [, k ]])
Parameter

Parameter

Beschreibung
n (optional)
Eine Ganzzahl, welche den durch das Gebietsschema festgelegten Uhrzeitformat-Stil angibt wie folgt:
      •
      1 (Kurzer Formatstil)
      •
      2 (Mittlerer Formatstil)
      •
      3 (Langer Formatstil)
      •
      4 (Vollständiger Formatstil)
Wenn n nicht angegeben (oder ungültig) ist, wird der Standardstilwert 0 verwendet.
k (optional)
Eine Zeichenfolge für die Gebietsschema-Kennung, welche den Benennungsstandards für Gebietsschemata entspricht. Wenn k nicht angegeben (oder ungültig) ist, wird das Umgebungsgebietsschema verwendet.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion LocalTimeFmt:

Ausdruck

Rückgabe

LocalTimeFmt(1, "de_DE")

HH:mm

LocalTimeFmt(2, "fr_CA")

HH:mm:ss

LocalTimeFmt(3, "de_CH")

HH:mm:ss z

LocalTimeFmt(4, "fr_FR")

HH' h 'mm z


Num2Date

Gibt für eine angegebene Anzahl von Tagen seit Beginn der Epoche eine Datums-Zeichenfolge zurück.
Syntax
Num2Date(n [,f [, k ]])
Parameter

Parameter

Beschreibung

n
Eine Ganzzahl, welche die Anzahl von Tagen angibt.
Wenn n ungültig ist, gibt die Funktion einen Fehler zurück.
f (optional)
Eine Datumsformat-Zeichenfolge. Wenn Sie keinen Wert für f angeben, verwendet die Funktion das Standard-Datumsformat MMM D, YYYY.
k (optional)
Eine Zeichenfolge für die Gebietsschema-Kennung, welche den Benennungsstandards für Gebietsschemata entspricht. Wenn Sie keinen Wert für k angeben oder wenn k ungültig ist, verwendet die Funktion das Umgebungsgebietsschema.
Die Funktion gibt den Wert 0 zurück, wenn mindestens eine der folgenden Bedingungen erfüllt ist:
      •
      Das Format des angegebenen Datums entspricht nicht dem in der Funktion angegebenen Format.
      •
      Das in der Funktion angegebene Gebietsschema oder Datumsformat ist ungültig.
Es sind nicht genügend Informationen vorhanden, um einen eindeutigen Tag seit Beginn der Epoche zu bestimmen (das heißt, die Datumsangaben fehlen oder sind unvollständig).
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Num2Date:

Ausdruck

Rückgabe

Num2Date(1, "DD/MM/YYYY")

01/01/1900

Num2Date(35139, "DD-MMM-YYYY", "de_DE")

16-Mrz-1996

Num2Date(Date2Num("Mar 15, 2000") - Date2Num("98-03-15", "YY-MM-DD", "fr_CA"))

Jan 1, 1902


Num2GMTime

Gibt für eine angegebene Anzahl von Millisekunden seit Beginn der Epoche eine GMT-Uhrzeit-Zeichenfolge zurück.
Syntax
Num2GMTime(n [,f [, k ]])
Parameter

Parameter

Beschreibung

n
Eine Ganzzahl, die eine Anzahl von Millisekunden angibt.
Wenn n ungültig ist, gibt die Funktion einen Fehler zurück.
f (optional)
Eine Uhrzeitformat-Zeichenfolge. Wenn Sie keinen Wert für f angeben, verwendet die Funktion das Standard-Uhrzeitformat H:MM:SS A.
k (optional)
Eine Zeichenfolge für die Gebietsschema-Kennung, welche den Benennungsstandards für Gebietsschemata entspricht. Wenn Sie keinen Wert für k angeben oder wenn k ungültig ist, verwendet die Funktion das Umgebungsgebietsschema.
Die Funktion gibt den Wert 0 zurück, wenn mindestens eine der folgenden Bedingungen erfüllt ist:
      •
      Das Format der angegebenen Uhrzeit entspricht nicht dem in der Funktion angegebenen Format.
      •
      Das in der Funktion angegebene Gebietsschema oder Uhrzeitformat ist ungültig.
Es sind nicht genügend Informationen vorhanden, um eine eindeutige Uhrzeit seit Beginn der Epoche zu bestimmen (das heißt, die Zeitangaben fehlen oder sind unvollständig).
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Num2GMTime:

Ausdruck

Rückgabe

Num2GMTime(1, "HH:MM:SS")

00:00:00

Num2GMTime(65593001, "HH:MM:SS Z")

18:13:13 GMT

Num2GMTime(43993001, TimeFmt(4, "de_DE"), "de_DE")

12.13 Uhr GMT


Num2Time

Gibt für eine angegebene Anzahl von Millisekunden seit Beginn der Epoche eine Uhrzeit-Zeichenfolge zurück.
Syntax
Num2Time(n [,f [, k ]])
Parameter

Parameter

Beschreibung

n
Eine Ganzzahl, die eine Anzahl von Millisekunden angibt.
Wenn n ungültig ist, gibt die Funktion einen Fehler zurück.
f (optional)
Eine Uhrzeitformat-Zeichenfolge. Wenn Sie keinen Wert für f angeben, verwendet die Funktion das Standard-Uhrzeitformat H:MM:SS A.
k (optional)
Eine Zeichenfolge für die Gebietsschema-Kennung, welche den Benennungsstandards für Gebietsschemata entspricht. Wenn Sie keinen Wert für k angeben oder wenn k ungültig ist, verwendet die Funktion das Umgebungsgebietsschema.
Die Funktion gibt den Wert 0 zurück, wenn mindestens eine der folgenden Bedingungen erfüllt ist:
      •
      Das Format der angegebenen Uhrzeit entspricht nicht dem in der Funktion angegebenen Format.
      •
      Das in der Funktion angegebene Gebietsschema oder Uhrzeitformat ist ungültig.
Es sind nicht genügend Informationen vorhanden, um eine eindeutige Uhrzeit seit Beginn der Epoche zu bestimmen (das heißt, die Zeitangaben fehlen oder sind unvollständig).
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Num2Time:

Ausdruck

Rückgabe

Num2Time(1, "HH:MM:SS")
00:00:00 in Greenwich und 09:00:00 in Tokio.

Num2Time(65593001, "HH:MM:SS Z")
13:13:13 EST in Boston.

Num2Time(65593001, "HH:MM:SS Z", "de_DE")
13:13:13 GMT-05:00 für einen deutschschweizerischen Benutzer in Boston.

Num2Time(43993001, TimeFmt(4, "de_DE"), "de_DE")
13.13 Uhr GMT+01:00 für einen Benutzer in Zürich.

Num2Time(43993001, "HH:MM:SSzz")
13:13+01:00 für einen Benutzer in Zürich.


Time

Gibt die aktuelle Systemuhrzeit als Anzahl von Millisekunden seit Beginn der Epoche zurück.
Syntax
Time()
Parameter
Keine
Beispiele
Die folgende Tabelle zeigt ein Beispiel für die Verwendung der Funktion Time:

Ausdruck

Rückgabe

Time()
71533235 um genau 3:52:15 PM am 15. September 2003 für einen Benutzer in der Zeitzone Eastern Time (ET).


Time2Num

Gibt für eine angegebene Uhrzeit-Zeichenfolge die Anzahl der Millisekunden seit Beginn der Epoche zurück.
Syntax
Time2Num(d [, f [, k ]])
Parameter

Parameter

Beschreibung

d
Eine Datums-Zeichenfolge in dem von f gelieferten Format, die auch dem von k angegebenen Gebietsschema entspricht.
f (optional)
Eine Uhrzeitformat-Zeichenfolge. Wenn Sie keinen Wert für f angeben, verwendet die Funktion das Standard-Uhrzeitformat H:MM:SS A.
k (optional)
Eine Zeichenfolge für die Gebietsschema-Kennung, welche den Benennungsstandards für Gebietsschemata entspricht. Wenn Sie keinen Wert für k angeben oder wenn k ungültig ist, verwendet die Funktion das Umgebungsgebietsschema.
Die Funktion gibt den Wert 0 zurück, wenn mindestens eine der folgenden Bedingungen erfüllt ist:
      •
      Das Format der angegebenen Uhrzeit entspricht nicht dem in der Funktion angegebenen Format.
      •
      Das in der Funktion angegebene Gebietsschema oder Uhrzeitformat ist ungültig.
Es sind nicht genügend Informationen vorhanden, um eine eindeutige Uhrzeit seit Beginn der Epoche zu bestimmen (das heißt, die Zeitangaben fehlen oder sind unvollständig).
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Time2Num:

Ausdruck

Rückgabe

Time2Num("00:00:00 GMT", "HH:MM:SS Z")

1

Time2Num("1:13:13 PM")
76393001 für einen Benutzer in Kalifornien während der Winterzeit (Pacific Standard Time) und 76033001, wenn für denselben Benutzer die Sommerzeit (Pacific Daylight Savings Time) gilt.

Time2Num("13:13:13", "HH:MM:SS") - Time2Num("13:13:13 GMT", "HH:MM:SS Z")) / (60 * 60 * 1000)
8 für einen Benutzer in Vancouver und 5 für einen Benutzer in Ottawa während der Winterzeit. Während der Sommerzeit werden die Werte 7 bzw. 4 zurückgegeben.

Time2Num("13:13:13 GMT", "HH:MM:SS Z", "fr_FR")

47593001


TimeFmt

Gibt ein Uhrzeitformat in einem angegebenen Uhrzeitformat-Stil zurück.
Syntax
TimeFmt([n [, k ]])
Parameter

Parameter

Beschreibung
n (optional)
Eine Ganzzahl, welche den durch das Gebietsschema festgelegten Uhrzeitformat-Stil angibt wie folgt:
      •
      1 (Kurzer Formatstil)
      •
      2 (Mittlerer Formatstil)
      •
      3 (Langer Formatstil)
      •
      4 (Vollständiger Formatstil)
Wenn Sie keinen Wert für n angeben oder wenn n ungültig ist, verwendet die Funktion den Standardstilwert.
k (optional)
Eine Zeichenfolge für die Gebietsschema-Kennung, welche den Benennungsstandards für Gebietsschemata entspricht. Wenn k nicht angegeben (oder ungültig) ist, wird das Umgebungsgebietsschema verwendet.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion TimeFmt:

Ausdruck

Rückgabe

TimeFmt(1)

h:MM A (if en_US locale is set)

TimeFmt(2, "fr_CA")

HH:MM:SS

TimeFmt(3, "fr_FR")

HH:MM:SS Z

TimeFmt(4, "de_DE")

H.MM' Uhr 'Z


Finanzfunktionen

Grundlagen zu Finanzfunktionen
Apr
CTerm
FV
IPmt
NPV
Pmt
PPmt
PV
Rate
Term


Grundlagen zu Finanzfunktionen

Diese Funktionen führen eine Vielzahl von Zins-, Kapital- und Auswertungsberechnungen für den Finanzsektor durch.
Funktionen
      •
      Apr
      •
      CTerm
      •
      FV
      •
      IPmt
      •
      NPV
      •
      Pmt
      •
      PPmt
      •
      PV
      •
      Rate
      •
      Term


Apr

Gibt die jährliche Gesamtbelastung für einen Kredit zurück.
Die Methoden für die Zinsberechnung sind von Land zu Land unterschiedlich. Diese Funktion berechnet einen Zinssatz anhand der in den USA üblichen Standards.
Syntax
Apr(n1, n2, n3)
Parameter

Parameter

Beschreibung

n1
Ein Zahlenwert oder Ausdruck, welcher den Kapitalbetrag des Kredits angibt.

n2
Ein Zahlenwert oder Ausdruck, welcher den Betrag pro Zahlung für den Kredit angibt.

n3
Ein Zahlenwert oder Ausdruck, welcher die Anzahl der Zahlungsperioden während der Laufzeit des Kredits angibt.
Wenn ein Parameter null ist, gibt die Funktion null zurück. Wenn ein Parameter negativ oder 0 ist, gibt die Funktion einen Fehler zurück.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Apr:

Ausdruck

Rückgabe

Apr(35000, 269.50, 360)
0.08515404566 für einen Kredit in Höhe von 35.000 $, der 30 Jahre lang in Monatsraten von 269,50 $ zurückgezahlt wird.

Apr(210000 * 0.75, 850 + 110, 25 * 26)

0.07161332404

Apr(-20000, 250, 120)
Fehler

Apr(P_Value, Payment, Time)
In diesem Beispiel werden Variablen statt konkreter Zahlenwerte oder Ausdrücke verwendet.


CTerm

Gibt die Anzahl der Perioden zurück, die erforderlich sind, damit eine Anlage mit einer festen Verzinsung mit Zinseszins auf einen Endwert anwächst.
Die Methoden für die Zinsberechnung sind von Land zu Land unterschiedlich. Diese Funktion berechnet einen Zinssatz anhand der in den USA üblichen Standards.
Syntax
CTerm(n1, n2, n3)
Parameter

Parameter

Beschreibung

n1
Ein Zahlenwert oder Ausdruck, welcher den Zinssatz pro Periode angibt.

n2
Ein Zahlenwert oder Ausdruck, welcher den Endwert der Anlage angibt.

n3
Ein Zahlenwert oder Ausdruck, welcher die Höhe des Anfangskapitals angibt.
Wenn ein Parameter null ist, gibt die Funktion null zurück. Wenn ein Parameter negativ oder 0 ist, gibt die Funktion einen Fehler zurück.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion CTerm:

Ausdruck

Rückgabe

CTerm(0.02, 1000, 100)

116.2767474515

CTerm(0.10, 500000, 12000)

39.13224648502

CTerm(0.0275 + 0.0025, 1000000, 55000 * 0.10)

176.02226044975

CTerm(Int_Rate, Target_Amount, P_Value)
In diesem Beispiel werden Variablen statt konkreter Zahlenwerte oder Ausdrücke verwendet.


FV

Gibt den Endwert von Anlagebeträgen zurück, die regelmäßig und in gleich bleibender Höhe bei einem konstanten Zinssatz eingezahlt werden.
Die Methoden für die Zinsberechnung sind von Land zu Land unterschiedlich. Diese Funktion berechnet einen Zinssatz anhand der in den USA üblichen Standards.
Syntax
FV(n1, n2, n3)
Parameter

Parameter

Beschreibung

n1
Ein Zahlenwert oder Ausdruck, welcher den Betrag pro Einzahlung angibt.

n2
Ein Zahlenwert oder Ausdruck, welcher die Zinsen pro Anlageperiode angibt.

n3
Ein Zahlenwert oder Ausdruck, welcher die Gesamtzahl der Einzahlungsperioden angibt.
Die Funktion gibt einen Fehler zurück, wenn eine der folgenden Bedingungen erfüllt ist:
      •
      n1 oder n3 ist negativ oder 0.
      •
      n2 ist negativ.
Wenn einer der Parameter null ist, gibt die Funktion null zurück.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Funktion FV:

Ausdruck

Rückgabe

FV(400, 0.10 / 12, 30 * 12)
904195.16991842445. Dies ist der Wert einer Anlage mit monatlichen Einzahlungen von 400 $ und einer jährlichen Verzinsung von 10 % nach 30 Jahren.

FV(1000, 0.075 / 4, 10 * 4)
58791.96145535981. Dies ist der Wert einer Anlage mit monatlichen Einzahlungen von 1.000 $ und einer vierteljährlichen Verzinsung von 7,5 % nach 10 Jahren.

FV(Payment[0], Int_Rate / 4, Time)
In diesem Beispiel werden Variablen statt konkreter Zahlenwerte oder Ausdrücke verwendet.


IPmt

Gibt den Zinsbetrag zurück, der in einer bestimmten Zeitspanne für einen Kredit gezahlt wurde.
Die Methoden für die Zinsberechnung sind von Land zu Land unterschiedlich. Diese Funktion berechnet einen Zinssatz anhand der in den USA üblichen Standards.
Syntax
IPmt(n1, n2, n3, n4, n5)
Parameter

Parameter

Beschreibung

n1
Ein Zahlenwert oder Ausdruck, welcher den Kapitalbetrag des Kredits angibt.

n2
Ein Zahlenwert oder Ausdruck, welcher den Jahreszinssatz der Anlage angibt.

n3
Ein Zahlenwert oder Ausdruck, welcher die Höhe der monatlichen Zahlungen angibt.

n4
Ein Zahlenwert oder Ausdruck, welcher den ersten Monat angibt, in dem eine Zahlung erfolgt.

n5
Ein Zahlenwert oder Ausdruck, der angibt, für wie viele Monate die Berechnung durchgeführt werden soll.
Die Funktion gibt einen Fehler zurück, wenn eine der folgenden Bedingungen erfüllt ist:
      •
      n1, n2 oder n3 ist negativ oder 0.
      •
      n4 oder n5 ist negativ.
Wenn ein Parameter null ist, gibt die Funktion null zurück. Wenn der Zahlungsbetrag (n3) kleiner ist als die monatliche Zinsbelastung, gibt die Funktion 0 zurück.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion IPmt:

Ausdruck

Rückgabe

IPmt(30000, 0.085, 295.50, 7, 3)
624.8839283142. Dies ist der Zinsbetrag, der für einen Kredit in Höhe von 30.000 $ bei einem Zinssatz von 8,5 % in den drei Monaten zwischen dem siebten und zehnten Monat der Kreditlaufzeit gezahlt wurde.

IPmt(160000, 0.0475, 980, 24, 12)
7103.80833569485. Die Höhe der im dritten Jahr der Kreditlaufzeit gezahlten Zinsen.

IPmt(15000, 0.065, 65.50, 15, 1)
0, weil die Höhe der monatlichen Zahlungen geringer ist als die für den Kredit während des Monats anfallenden Zinsen.


NPV

Gibt den Kapitalwert einer Anlage auf der Grundlage eines Diskontsatzes und einer Folge von zukünftigen periodischen Cashflows zurück.
Die Methoden für die Zinsberechnung sind von Land zu Land unterschiedlich. Diese Funktion berechnet einen Zinssatz anhand der in den USA üblichen Standards.
Syntax
NPV(n1, n2 [, ...])
Parameter

Parameter

Beschreibung

n1
Ein Zahlenwert oder Ausdruck, welcher den Diskontsatz während einer einzelnen Periode angibt.

n2
Ein Zahlenwert oder Ausdruck, welcher den Wert eines Cashflows angibt, der am Ende einer Periode erfolgen muss. Es ist wichtig, dass die in n2 und dahinter angegebenen Werte in der richtigen Reihenfolge aufgeführt sind.
Die Funktion gibt einen Fehler zurück, wenn n1 negativ oder 0 ist. Wenn einer der Parameter null ist, gibt die Funktion null zurück.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion NPV:

Ausdruck

Rückgabe

NPV(0.065, 5000)
4694.83568075117; dies ist der Netto-Barwert einer Anlage mit einer jährlichen Verzinsung von 6,5 %, der Einkünfte von 5.000 $ zufließen werden.

NPV(0.10, 500, 1500, 4000, 10000)
11529.60863329007; dies ist der Kapitalwert einer Anlage mit einer jährlichen Verzinsung von 10 %, der in den nächsten vier Jahren Einkünfte von jeweils 500 $, 1.500 $, 4.000 $ und 10.000 $ zufließen werden.

NPV(0.0275 / 12, 50, 60, 40, 100, 25)
273.14193838457; dies ist der Kapitalwert einer Anlage mit einer jährlichen Verzinsung von 2,75 %, der in den nächsten fünf Monaten Einkünfte von jeweils 50 $, 60 $, 40 $, 100 $ und 25 $ zufließen werden.


Pmt

Gibt die Höhe des Rückzahlungsbetrags für einen Kredit bei konstanten Zahlungsbeträgen und konstantem Zinssatz zurück.
Die Methoden für die Zinsberechnung sind von Land zu Land unterschiedlich. Diese Funktion berechnet einen Zinssatz anhand der in den USA üblichen Standards.
Syntax
Pmt(n1, n2, n3)
Parameter

Parameter

Beschreibung

n1
Ein Zahlenwert oder Ausdruck, welcher den Kapitalbetrag des Kredits angibt.

n2
Ein Zahlenwert oder Ausdruck, welcher den Zinssatz pro Verzinsungsperiode der Anlage angibt.

n3
Ein Zahlenwert oder Ausdruck, welcher die Gesamtzahl der Einzahlungsperioden angibt.
Die Funktion gibt einen Fehler zurück, wenn einer der Parameter negativ oder 0 ist. Wenn einer der Parameter null ist, gibt die Funktion null zurück.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Pmt:

Ausdruck

Rückgabe

Pmt(150000, 0.0475 / 12, 25 * 12)
855.17604207164; dies ist der monatliche Zahlungsbetrag bei einer Kreditsumme von 150.000 $, die bei einer jährlichen Verzinsung von 4,75 % 25 Jahre lang zurückzuzahlen ist.

Pmt(25000, 0.085, 12)
3403.82145169876; dies ist der jährliche Zahlungsbetrag bei einer Kreditsumme von 25.000 $, die bei einer jährlichen Verzinsung von 8,5 % 12 Jahre lang zurückzuzahlen ist.


PPmt

Gibt den Tilgungsbetrag zurück, der in einer bestimmten Zeitspanne für einen Kredit gezahlt wurde.
Die Methoden für die Zinsberechnung sind von Land zu Land unterschiedlich. Diese Funktion berechnet einen Zinssatz anhand der in den USA üblichen Standards.
Syntax
PPmt(n1, n2, n3, n4, n5)
Parameter

Parameter

Beschreibung

n1
Ein Zahlenwert oder Ausdruck, welcher den Kapitalbetrag des Kredits angibt.

n2
Ein Zahlenwert oder Ausdruck, welcher den jährlichen Zinssatz angibt.

n3
Ein Zahlenwert oder Ausdruck, welcher die Höhe der monatlichen Zahlungen angibt.

n4
Ein Zahlenwert oder Ausdruck, welcher den ersten Monat angibt, in dem eine Zahlung erfolgt.

n5
Ein Zahlenwert oder Ausdruck, der angibt, für wie viele Monate die Berechnung durchgeführt werden soll.
Die Funktion gibt einen Fehler zurück, wenn eine der folgenden Bedingungen erfüllt ist:
      •
      n1, n2 oder n3 ist negativ oder 0.
      •
      n4 oder n5 ist negativ.
Wenn ein Parameter null ist, gibt die Funktion null zurück. Wenn der Zahlungsbetrag (n3) kleiner ist als die monatliche Zinsbelastung, gibt die Funktion 0 zurück.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion PPmt:

Ausdruck

Rückgabe

PPmt(30000, 0.085, 295.50, 7, 3)
261.6160716858, der Tilgungsbetrag, der für einen Kredit in Höhe von 30.000 $ bei einem Zinssatz von 8,5 % in den drei Monaten zwischen dem siebten und zehnten Monat der Kreditlaufzeit gezahlt wurde.

PPmt(160000, 0.0475, 980, 24, 12)
4656.19166430515, die Höhe des im dritten Jahr der Kreditlaufzeit getilgten Kreditbetrags.

PPmt(15000, 0.065, 65.50, 15, 1)
0, weil die monatliche Zahlung kleiner ist als die während des Monats anfallenden Zinsen, daher wird nichts vom Kapitalbetrag getilgt.


PV

Gibt den Gegenwartswert einer Anlage mit regelmäßigen konstanten Einzahlungen und konstantem Zinssatz zurück.
Die Methoden für die Zinsberechnung sind von Land zu Land unterschiedlich. Diese Funktion berechnet einen Zinssatz anhand der in den USA üblichen Standards.
Syntax
PV(n1, n2, n3)
Parameter

Parameter

Beschreibung

n1
Ein Zahlenwert oder Ausdruck, welcher den Betrag pro Einzahlung angibt.

n2
Ein Zahlenwert oder Ausdruck, welcher die Zinsen pro Anlageperiode angibt.

n3
Ein Zahlenwert oder Ausdruck, welcher die Gesamtzahl der Einzahlungsperioden angibt.
Die Funktion gibt einen Fehler zurück, wenn n1 oder n3 negativ oder 0 ist. Wenn einer der Parameter null ist, gibt die Funktion null zurück.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion PV:

Ausdruck

Rückgabe

PV(400, 0.10 / 12, 30 * 12)
45580.32799074439. Dies ist der Wert einer Anlage mit monatlichen Einzahlungen von 400 $ und einer jährlichen Verzinsung von 10 % nach 30 Jahren.

PV(1000, 0.075 / 4, 10 * 4)
58791.96145535981. Dies ist der Wert einer Anlage mit monatlichen Einzahlungen von 1.000 $ und einer vierteljährlichen Verzinsung von 7,5 % nach zehn Jahren.

PV(Payment[0], Int_Rate / 4, Time)
In diesem Beispiel werden Variablen statt konkreter Zahlenwerte oder Ausdrücke verwendet.


Rate

Gibt den Zinssatz pro Verzinsungsperiode zurück, der benötigt wird, damit eine Anlage mit Zinseszins in einem gegebenen Zeitraum von einem gegebenen Gegenwartswert auf einen Endwert anwächst.
Die Methoden für die Zinsberechnung sind von Land zu Land unterschiedlich. Diese Funktion berechnet einen Zinssatz anhand der in den USA üblichen Standards.
Syntax
Rate(n1, n2, n3)
Parameter

Parameter

Beschreibung

n1
Ein Zahlenwert oder Ausdruck, welcher den Endwert der Anlage angibt.

n2
Ein Zahlenwert oder Ausdruck, welcher den Gegenwartswert der Anlage angibt.

n3
Ein Zahlenwert oder Ausdruck, welcher die Gesamtzahl der Anlageperioden angibt.
Die Funktion gibt einen Fehler zurück, wenn einer der Parameter negativ oder 0 ist. Wenn einer der Parameter null ist, gibt die Funktion null zurück.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Rate:

Ausdruck

Rückgabe

Rate(12000, 8000, 5)
0.0844717712 (oder 8,45 %); dies ist der Zinssatz, der pro Periode benötigt wird, damit ein Gegenwartswert von 8.000 $ in fünf Perioden auf 12.000 $ anwächst.

Rate(10000, 0.25 * 5000, 4 * 12)
0.04427378243 (oder 4,43 %); dies ist der Zinssatz, der pro Monat benötigt wird, damit der Gegenwartswert in vier Jahren auf 10.000 $ anwächst.

Rate(Target_Value, Pres_Value[*], Term * 12)
In diesem Beispiel werden Variablen statt konkreter Zahlenwerte oder Ausdrücke verwendet.


Term

Gibt die Anzahl der Perioden zurück, die erforderlich sind, um mit konstanten periodischen Einzahlungen auf ein verzinstes Konto einen angegebenen Endwert zu erzielen.
Die Methoden für die Zinsberechnung sind von Land zu Land unterschiedlich. Diese Funktion berechnet einen Zinssatz anhand der in den USA üblichen Standards.
Syntax
Term(n1, n2, n3)
Parameter

Parameter

Beschreibung

n1
Ein Zahlenwert oder Ausdruck, welcher die Höhe der Zahlung am Ende jeder Periode angibt.

n2
Ein Zahlenwert oder Ausdruck, welcher den Zinssatz pro Verzinsungsperiode der Anlage angibt.

n3
Ein Zahlenwert oder Ausdruck, welcher den Endwert der Anlage angibt.
Die Funktion gibt einen Fehler zurück, wenn einer der Parameter negativ oder 0 ist. Wenn einer der Parameter null ist, gibt die Funktion null zurück.
FormCalc folgt bei der Handhabung von numerischen Fließkommawerten dem internationalen Standard IEEE-754. Weitere Informationen finden Sie unter Zahlenliterale.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Term:

Ausdruck

Rückgabe

Term(475, .05, 1500)
3.00477517728 (oder ungefähr 3); dies ist die Anzahl der Perioden, die benötigt werden, um Einzahlungen in Höhe von 475 $ bei einem Zinssatz von 5 % pro Periode auf 1.500 $ anwachsen zu lassen.

Term(2500, 0.0275 + 0.0025, 5000)
1.97128786369; dies ist die Anzahl der Perioden, die benötigt werden, um Einzahlungen in Höhe von 2.500 $ bei einem Zinssatz von 3 % pro Periode auf 5.000 $ anwachsen zu lassen.

Rate(Inv_Value[0], Int_Rate + 0.0050, Target_Value)
In diesem Beispiel werden Variablen statt konkreter Zahlenwerte oder Ausdrücke verwendet. In diesem Fall wird das erste Vorkommen der Variablen Inv_Value als Einzahlungsbetrag verwendet. Die Variable Int_Rate wird um einen halben Prozentpunkt erhöht und als Zinssatz eingesetzt und die Variable Target_Value ist der Endwert der Anlage.


Zurück Weiter

Skripterstellung > FormCalc-Benutzerreferenz > Logikfunktionen

Logikfunktionen

Grundlagen zu Logikfunktionen
Choose
Exists
HasValue
Oneof
Within


Grundlagen zu Logikfunktionen

Diese Funktionen eignen sich zum Testen und/oder Analysieren von Informationen, um ein wahres (TRUE) oder falsches (FALSE) Ergebnis zu erhalten.
Funktionen
      •
      Choose
      •
      Exists
      •
      HasValue
      •
      Oneof
      •
      Within


Choose

Wählt einen Wert aus einem gegebenen Satz von Parametern.
Syntax
Choose(n, s1 [, s2 ...])
Parameter

Parameter

Beschreibung

n
Die Position des auszuwählenden Wertes innerhalb des Satzes. Wenn dieser Wert keine Ganzzahl ist, rundet die Funktion n auf den nächsten ganzzahligen Wert ab.
Die Funktion gibt eine leere Zeichenfolge zurück, wenn eine der folgenden Bedingungen erfüllt ist:
      •
      n ist kleiner als 1.
      •
      n ist größer als die Zahl der Elemente im Satz.
Wenn n null ist, gibt die Funktion null zurück.

s1
Der erste Wert in dem Wertesatz.
s2 (optional)
Weitere Werte im Satz.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Choose:

Ausdruck

Rückgabe

Choose(3, "Taxes", "Price", "Person", "Teller")

Person

Choose(2, 10, 9, 8, 7, 6, 5, 4, 3, 2, 1)

9

Choose(Item_Num[0], Items[*])
Gibt den Wert innerhalb des Satzes Items zurück, welcher sich an der durch das erste Vorkommen von Item_Num bestimmten Position befindet.

Choose(20/3, "A", "B", "C", "D", "E", "F", "G", "H")

F


Exists

Bestimmt, ob der angegebene Parameter eine Referenz-Syntax zu einem vorhandenen Objekt ist.
Syntax
Exists(v)
Parameter

Parameter

Beschreibung

v
Ein gültiger Referenz-Syntaxausdruck.
Wenn v keine Referenz-Syntax ist, gibt die Funktion FALSE (0) zurück.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Exists:

Ausdruck

Rückgabe

Exists(Item)
TRUE (1), wenn das Objekt Item existiert, andernfalls FALSE (0).

Exists("hello world")
FALSE (0). Die Zeichenfolge ist keine Referenz-Syntax.

Exists(Invoice.Border.Edge[1].Color)
TRUE (1), wenn das Objekt Invoice existiert und die Eigenschaft Border aufweist, die wiederum mindestens eine Eigenschaft Edge hat, die wiederum die Eigenschaft Color besitzt. Andernfalls gibt die Funktion FALSE (0) zurück.


HasValue

Ermittelt, ob der angegebene Parameter eine Referenz-Syntax mit einem von null verschiedenen, nicht leeren oder vom Leerzeichen verschiedenen Wert ist.
Syntax
HasValue(v)
Parameter

Parameter

Beschreibung

v
Ein gültiger Referenz-Syntaxausdruck.
Wenn v keine Referenz-Syntax ist, gibt die Funktion FALSE (0) zurück.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion HasValue:

Ausdruck

Rückgabe

HasValue(2)
TRUE (1)

HasValue(" ")
FALSE (0)

HasValue(Amount[*])
Fehler

HasValue(Amount[0])
Wertet das erste Vorkommen von Amount aus und gibt TRUE (1) zurück, wenn dieser Wert weder null, noch leer, noch das Leerzeichen ist.


Oneof

Bestimmt, ob der angegebene Wert zu einem Satz gehört.
Syntax
Oneof(s1, s2 [, s3 ...])
Parameter

Parameter

Beschreibung

s1
Die Position des auszuwählenden Wertes innerhalb des Satzes. Wenn dieser Wert keine Ganzzahl ist, rundet die Funktion s1 auf den nächsten ganzzahligen Wert ab.

s2
Der erste Wert in dem Wertesatz.
s3 (optional)
Weitere Werte im Satz.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Oneof:

Ausdruck

Rückgabe

Oneof(3, 10, 9, 8, 7, 6, 5, 4, 3, 2, 1)
TRUE (1)

Oneof("John", "Bill", "Gary", "Joan", "John", "Lisa")
TRUE (1)

Oneof(3, 1, 25)
FALSE (0)

Oneof("loan", Fields[*])
Prüft, ob eines der Vorkommen von Fields den Wert loan besitzt.


Within

Bestimmt, ob der angegebene Wert innerhalb eines angegebenen Bereichs liegt.
Syntax
Within(s1, s2, s3)
Parameter

Parameter

Beschreibung

s1
Der zu prüfende Wert.
Wenn s1 eine Zahl ist, wird eine numerische Sortierreihenfolge verwendet.
Wenn s1 keine Zahl ist, wird beim Sortierungsvergleich die für das aktuelle Gebietsschema angegebene Sortierreihenfolge verwendet. Weitere Informationen finden Sie unter Gebietsschemata.
Wenn s1 null ist, gibt die Funktion null zurück.

s2
Die untere Grenze des Prüfbereichs.

s3
Die obere Grenze des Prüfbereichs.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Within:

Ausdruck

Rückgabe

Within("C", "A", "D")
TRUE (1)

Within(1.5, 0, 2)
TRUE (1)

Within(-1, 0, 2)
FALSE (0)

Within($, 1, 10)
TRUE (1), wenn der aktuelle Wert zwischen 1 und 10 liegt.


Sonstige Funktionen

Grundlagen zu sonstigen Funktionen
Eval
Null
Ref
UnitType
UnitValue


Grundlagen zu sonstigen Funktionen

Die Funktionen in diesem Kapitel lassen sich in keine bestimmte Funktionskategorie einordnen, können sich aber in zahlreichen Anwendungsbereichen als nützlich erweisen.
Funktionen
      •
      Eval
      •
      Null
      •
      Ref
      •
      UnitType
      •
      UnitValue


Eval

Gibt den Wert einer angegebenen Formularberechnung zurück.
Syntax
Eval(s)
Parameter

Parameter

Beschreibung

s
Eine gültige Zeichenfolge, die einen Ausdruck oder eine Liste von Ausdrücken darstellt.
Die Funktion Eval kann keine benutzerdefinierten Variablen und Funktionen referenzieren. Beispiel:
var s = "var t = concat(s, ""hello"")"
eval(s)
In diesem Fall erkennt die Funktion Eval s nicht und gibt daher einen Fehler zurück. Nachfolgende Funktionen, welche die Variable s referenzieren, schlagen ebenfalls fehl.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Eval:

Ausdruck

Rückgabe

eval("10*3+5*4")

50

eval("hello")

error


Null

Gibt den Null-Wert zurück. („Null-Wert“ ist gleichbedeutend mit „kein Wert“.)
Definition
Null()
Parameter
Keine
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Null:

Ausdruck

Rückgabe

Null()

null
Null() + 5

5

Quantity = Null()
Weist dem Objekt Quantity null zu.

Concat("ABC", Null(), "DEF")

ABCDEF
Siehe auch Concat.


Ref

Gibt eine Referenz auf ein vorhandenes Objekt zurück.
Definition
Ref(v)
Parameter

Parameter

Beschreibung

v
Eine gültige Zeichenfolge, die eine Referenz-Syntax, Eigenschaft, Methode oder Funktion darstellt.
Wenn der angegebene Parameter den Null-Wert hat, gibt die Funktion die Null-Referenz zurück. Für alle anderen angegebenen Parameter erzeugt die Funktion einen Ausnahmefehler.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Ref:

Ausdrücke

Rückgabe

Ref("10*3+5*4")

10*3+5*4

Ref("hello")

hello


UnitType

Gibt die Einheit einer Maßangabe zurück. Eine Maßangabe ist eine Zeichenfolge, die aus einer Zahl und einer nachfolgenden Einheitenbezeichnung besteht.
Syntax
UnitType(s)
Parameter

Parameter

Beschreibung

s
Eine gültige Zeichenfolge (Maßangabe), die aus einem Zahlenwert und einer gültigen Maßeinheit besteht. Die folgenden Maßeinheiten werden erkannt:
      •
      in, Inch
      •
      mm, Millimeter
      •
      cm, Zentimeter
      •
      pt, Pica, Punkt
      •
      mp, Millipunkt
Wen s ungültig ist, gibt die Funktion in zurück.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion UnitType:

Ausdruck

Ergebnisse

UnitType("36 in")

in

UnitType("2.54centimeters")

cm

UnitType("picas")

pt

UnitType("2.cm")

cm

UnitType("2.zero cm")

in

UnitType("kilometers")

in

UnitType(Size[0])
Gibt die Maßeinheit im ersten Vorkommen von Size zurück.


UnitValue

Gibt den Zahlenwert einer Messung mit ihrer zugeordneten Maßangabe nach einer optionalen Einheitenumwandlung zurück. Eine Maßangabe ist eine Zeichenfolge, die aus einer Zahl und einer nachfolgenden gültigen Maßeinheit besteht.
Syntax
UnitValue(s1 [, s2 ])
Parameter

Parameter

Beschreibung

s1
Eine gültige Zeichenfolge (Maßangabe), die aus einem Zahlenwert und einer gültigen Maßeinheit besteht. Die folgenden Maßeinheiten werden erkannt:
      •
      in, Inch
      •
      mm, Millimeter
      •
      cm, Zentimeter
      •
      pt, Pica, Punkt
      •
      mp, Millipunkt
s2 (optional)
Eine Zeichenfolge, die eine gültige Maßeinheit enthält. Die Funktion wandelt die in s1 angegebene Maßangabe in diese neue Maßeinheit um.
Wenn Sie für s2 keinen Wert angeben, verwendet die Funktion die in s1 angegebene Maßeinheit. Wenn s2 ungültig ist, wandelt die Funktion s1 in Zoll (Inch) um.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion UnitValue:

Ausdruck

Rückgabe

UnitValue("2in")

2

UnitValue("2in", "cm")

5.08

UnitValue("6", "pt")

432

UnitValue("A", "cm")

0

UnitValue(Size[2], "mp")
Gibt den Messwert des dritten Vorkommens von Size in Millipunkt umgerechnet zurück.

UnitValue("5.08cm", "kilograms")

2


Zeichenfolgen-Funktionen

Grundlagen zu Zeichenfolgen-Funktionen
At
Concat
Decode
Encode
Format
Left
Len
Lower
Ltrim
Parse
Replace
Right
Rtrim
Space
Str
Stuff
Substr
Upper
Uuid
WordNum


Grundlagen zu Zeichenfolgen-Funktionen

Die Funktionen in diesem Kapitel dienen zur Bearbeitung, Auswertung und Erstellung von Zeichenfolgenwerten.
Funktionen
      •
      At
      •
      Concat
      •
      Decode
      •
      Encode
      •
      Format
      •
      Left
      •
      Len
      •
      Lower
      •
      Ltrim
      •
      Parse
      •
      Replace
      •
      Right
      •
      Rtrim
      •
      Space
      •
      Str
      •
      Stuff
      •
      Substr
      •
      Upper
      •
      Uuid
      •
      WordNum


At

Findet die Anfangs-Zeichenposition einer Zeichenfolge innerhalb einer anderen Zeichenfolge.
Syntax
At(s1, s2)
Parameter

Parameter

Beschreibung

s1
Die Quell-Zeichenfolge.

s2
Die Such-Zeichenfolge.
Wenn s2 kein Bestandteil von s1 ist, gibt die Funktion 0 zurück.
Wen s2 leer ist, gibt die Funktion 1 zurück.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion At:

Ausdruck

Rückgabe

At("ABCDEFGH", "AB")

1

At("ABCDEFGH", "F")

6

At(23412931298471, 29)
5, das erste Vorkommen von 29 in der Quell-Zeichenfolge.

At(Ltrim(Cust_Info[0]), "555")
Die Position der Zeichenfolge 555 innerhalb des ersten Vorkommens von Cust_Info.
Siehe auch Ltrim.


Concat

Gibt die Verkettung von zwei oder mehr Zeichenfolgen zurück.
Syntax
Concat(s1 [, s2 ...])
Parameter

Parameter

Beschreibung

s1
Die erste Zeichenfolge in dem Satz.
s2 (optional)
Weitere Zeichenfolgen, die an den Satz angehängt werden sollen.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Concat:

Ausdruck

Rückgabe

Concat("ABC", "DEF")

ABCDEF

Concat("Tony", Space(1), "Blue")

Tony Blue
Siehe auch Space.
Concat("You owe ", WordNum(1154.67, 2), ".")

You owe One Thousand One Hundred Fifty-four Dollars And Sixty-seven Cents.
Siehe auch WordNum.


Decode

Gibt die dekodierte Version einer angegebenen Zeichenfolge zurück.
Syntax
Decode(s1 [, s2 ])
Parameter

Parameter

Beschreibung

s1
Die zu dekodierende Zeichenfolge.
s2 (optional)
Eine Zeichenfolge, die die Art der durchzuführenden Dekodierung angibt. Die folgenden Zeichenfolgen sind gültige Dekodierungs-Zeichenfolgen:
      •
      url (URL-Dekodierung)
      •
      html (HTML-Dekodierung)
      •
      xml (XML-Dekodierung)
Wenn Sie keinen Wert für s2 angeben, führt die Funktion eine URL-Dekodierung durch.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Decode:

Ausdruck

Rückgabe

Decode("&AElig;&Aacute;&Acirc;&Aacute;
&Acirc;", „html“)

ÆÁÂÁÂ

Decode("~!@#$%^&amp;*()_+|`{&quot;}[]
&lt;&gt;?,./;&apos;:", „xml“)

~!@#$%^&*()_+|`{""}[]<>?,./;':


Encode

Gibt die kodierte Version einer angegebenen Zeichenfolge zurück.
Syntax
Encode(s1 [, s2 ])
Parameter

Parameter

Beschreibung

s1
Die zu kodierende Zeichenfolge.
s2 (optional)
Eine Zeichenfolge, welche die Art der durchzuführenden Kodierung angibt. Die folgenden Zeichenfolgen sind gültige Kodierungs-Zeichenfolgen:
      •
      url (URL-Kodierung)
      •
      html (HTML-Kodierung)
      •
      xml (XML-Kodierung)
Wenn Sie keinen Wert für s2 angeben, führt die Funktion eine URL-Kodierung durch.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Encode:

Ausdruck

Rückgabe

Encode("""hello, world!""", "url")

%22hello,%20world!%22

Encode("ÁÂÃÄÅÆ", "html")

&#xc1;&#Xc2;&#Xc3;&#xc4;&#xc5;&#xc6;


Format

Formatiert die angegebenen Daten gemäß der angegebenen Musterformat-Zeichenfolge.
Syntax
Format(s1, s2 [, s3 ...])
Parameter

Parameter

Beschreibung

s1
Die Musterformat-Zeichenfolge, die ein an das Gebietsschema angepasstes Datums- oder Uhrzeitformat sein kann. Siehe Gebietsschemata.
s2
Die zu formatierenden Quelldaten.
Bei Musterformaten für Datumsangaben müssen die Quelldaten entweder eine ISO-konforme Datum-Uhrzeit-Zeichenfolge oder eine ISO-konforme Datums-Zeichenfolge in einem der beiden folgenden Formate sein:
      •
      YYYY[MM[DD]]
      •
      YYYY[-MM[-DD]]
Bei Musterformaten für Uhrzeitangaben müssen die Quelldaten entweder eine ISO-konforme Datum-Uhrzeit-Zeichenfolge oder eine ISO-konforme Uhrzeit-Zeichenfolge in einem der folgenden Formate sein:
      •
      HH[MM[SS[.FFF][z]]]
      •
      HH[MM[SS[.FFF][+HH[MM]]]]
      •
      HH[MM[SS[.FFF][-HH[MM]]]]
      •
      HH[:MM[:SS[.FFF][z]
      •
      HH[:MM[:SS[.FFF][-HH[:MM]]]]
      •
      HH[:MM[:SS[.FFF][+HH[:MM]]]]
Bei Datum-Uhrzeit-Musterformaten müssen die Quelldaten eine ISO-konforme Datum-Uhrzeit-Zeichenfolge sein.
Bei numerischen Musterformaten müssen die Quelldaten numerisch sein.
Bei Text-Musterformaten muss es sich bei den Quelldaten um Text handeln.
Bei zusammengesetzten Musterformaten muss die Anzahl der Quelldaten-Argumente mit der Anzahl der Unterelemente im Muster übereinstimmen.
s3 (optional)
Zusätzliche zu formatierende Quelldaten.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Format:

Ausdruck

Rückgabe

Format("MMM D, YYYY", "20020901")

Sep 1, 2002

Format("$9,999,999.99", 1234567.89)
$1,234,567.89 in den USA und 1 234 567,89 Euro in Frankreich.


Left

Extrahiert eine angegebene Anzahl von Zeichen aus einer Zeichenfolge, beginnend beim ersten Zeichen auf der linken Seite.
Syntax
Left(s, n)
Parameter

Parameter

Beschreibung

s
Die Zeichenfolge, aus der extrahiert werden soll.

n
Die Anzahl der zu extrahierenden Zeichen.
Wenn die Anzahl der zu extrahierenden Zeichen größer als die Länge der Zeichenfolge ist, gibt die Funktion die komplette Zeichenfolge zurück.
Wenn die Anzahl der zu extrahierenden Zeichen 0 oder kleiner ist, gibt die Funktion die leere Zeichenfolge zurück.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Left:

Ausdruck

Rückgabe

Left("ABCDEFGH", 3)

ABC

Left("Tony Blue", 5)

"Tony "

Left(Telephone[0], 3)
Die ersten drei Zeichen des ersten Vorkommens von Telephone.

Left(Rtrim(Last_Name), 3)
Die drei ersten Zeichen von Last_Name.
Siehe auch Rtrim.


Len

Gibt die Anzahl der Zeichen in einer angegebenen Zeichenfolge zurück.
Syntax
Len(s)
Parameter

Parameter

Beschreibung

s
Die zu untersuchende Zeichenfolge.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Len:

Ausdruck

Rückgabe

Len("ABDCEFGH")

8

Len(4)

1

Len(Str(4.532, 6, 4))

6
Siehe auch Str.

Len(Amount[*])
Die Anzahl der Zeichen im ersten Vorkommen von Amount.


Lower

Wandelt alle Großbuchstaben in einer angegebenen Zeichenfolge in Kleinbuchstaben um.
Syntax
Lower(s, [, k ])
Parameter

Parameter

Beschreibung

s
Die umzuwandelnde Zeichenfolge.
k (optional)
Eine Zeichenfolge, die ein gültiges Gebietsschema angibt. Wenn Sie keinen Wert für k angeben, verwendet die Funktion das Umgebungsgebietsschema.
Siehe auch Gebietsschemata.
Diese Funktion wandelt nur die Unicode-Zeichen von U+41 bis U+5A (im ASCII-Zeichensatz) sowie die Zeichen von U+FF21 bis U+FF3A (im vollbreiten Zeichensatz) um.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Lower:

Ausdruck

Rückgabe

Lower("ABC")

abc

Lower("21 Main St.")

21 main st.

Lower(15)

15

Lower(Address[0])
In diesem Beispiel wird das erste Vorkommen von Address vollständig in Kleinbuchstaben umgewandelt.


Ltrim

Gibt eine Zeichenfolge zurück, bei der alle Leerraum-Zeichen am Anfang entfernt wurden.
Zu den Leerraum-Zeichen gehören ASCII-Leerzeichen, horizontaler Tabulator, Zeilenvorschub, vertikaler Tabulator, Formularvorschub, Wagenrücklauf sowie die Unicode-Leerzeichen (Unicode-Kategorie Zs).
Syntax
Ltrim(s)
Parameter

Parameter

Beschreibung

s
Die zu verkürzende Zeichenfolge.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Ltrim:

Ausdruck

Rückgabe

Ltrim("          ABCD")

"ABCD"

Ltrim(Rtrim("          Tony Blue          "))

"Tony Blue"
Siehe auch Rtrim.

Ltrim(Address[0])
Entfernt ggf. den Leerraum am Anfang des ersten Vorkommens von Address.


Parse

Analysiert die angegebenen Daten gemäß dem angegebenen Musterformat.
Wenn die Daten erfolgreich analysiert wurden, liefert die Funktion einen der folgenden Werte:
      •
      Datums-Musterformat: Eine ISO-konforme Datums-Zeichenfolge der Form YYYY-MM-DD.
      •
      Uhrzeit-Musterformat: Eine ISO-konforme Uhrzeit-Zeichenfolge der Form HH:MM:SS.
      •
      Datum-Uhrzeit-Musterformat: Eine ISO-konforme Datum-Uhrzeit-Zeichenfolge der Form YYYY-MM-DDTHH:MM:SS.
      •
      Numerisches Musterformat: Eine Zahl.
      •
      Text-Muster: Text.
Syntax
Parse(s1, s2 )
Parameter

Parameter

Beschreibung

s1
Eine gültige Datum- oder Uhrzeit-Musterformat-Zeichenfolge.
Weitere Informationen zu Datums- und Uhrzeitformaten finden Sie unter Grundlagen zu Datums- und Uhrzeitfunktionen.

s2
Die zu analysierenden Zeichenfolgen-Daten.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Parse:

Ausdruck

Rückgabe

Parse("MMM D, YYYY", "Sep 1, 2002")

2002-09-01

Parse("$9,999,999.99", "$1,234,567.89")
1234567.89 in den USA


Replace

Ersetzt innerhalb einer angegebenen Zeichenfolge alle Fundstellen einer Zeichenfolge durch eine andere.
Syntax
Replace(s1, s2 [, s3 ])
Parameter

Parameter

Beschreibung

s1
Eine Quell-Zeichenfolge.

s2
Die zu ersetzende Zeichenfolge.
s3 (optional)
Die Ersatz-Zeichenfolge.
Wenn Sie keinen Wert für s3 angeben oder wenn s3 null ist, verwendet die Funktion eine leere Zeichenfolge.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Replace:

Ausdruck

Rückgabe

Replace("Tony Blue", "Tony", "Chris")

Chris Blue

Replace("ABCDEFGH", "D")

ABCEFGH

Replace("ABCDEFGH", "d")

ABCDEFGH

Replace(Comments[0], "recieve", "receive")
Berichtigt die Schreibung des Wortes receive im ersten Vorkommen von Comments.


Right

Extrahiert mehrere Zeichen aus einer angegebenen Zeichenfolge, beginnend beim letzten Zeichen auf der rechten Seite.
Syntax
Right(s, n )
Parameter

Parameter

Beschreibung

s
Die zu extrahierende Zeichenfolge.

n
Die Anzahl der zu extrahierenden Zeichen.
Wenn n größer als die Länge der Zeichenfolge ist, gibt die Funktion die gesamte Zeichenfolge zurück.
Wenn n gleich oder kleiner 0 ist, gibt die Funktion eine leere Zeichenfolge zurück.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Right:

Ausdruck

Rückgabe

Right("ABCDEFGH", 3)

FGH

Right("Tony Blue", 5)

" Blue"

Right(Telephone[0], 7)
Die letzten sieben Zeichen des ersten Vorkommens von Telephone.

Right(Rtrim(CreditCard_Num), 4)
Die letzten vier Zeichen von CreditCard_Num.
Siehe auch Rtrim.


Rtrim

Gibt eine Zeichenfolge zurück, bei der alle Leerraum-Zeichen am Ende entfernt wurden.
Zu den Leerraum-Zeichen gehören ASCII-Leerzeichen, horizontaler Tabulator, Zeilenvorschub, vertikaler Tabulator, Formularvorschub, Wagenrücklauf sowie die Unicode-Leerzeichen (Unicode-Kategorie Zs).
Syntax
Rtrim(s )
Parameter

Parameter

Beschreibung

s
Die zu verkürzende Zeichenfolge.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Rtrim:

Ausdruck

Rückgabe

Rtrim("ABCD          ")

"ABCD"

Rtrim("Tony Blue           ")

"Tony Blue"

Rtrim(Address[0])
Entfernt ggf. den Leerraum am Ende des ersten Vorkommens von Address.


Space

Gibt eine Zeichenfolge zurück, die aus einer angegebenen Anzahl von Leerzeichen besteht.
Syntax
Space(n )
Parameter

Parameter

Beschreibung

n
Die Anzahl der Leerzeichen.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Space:

Ausdruck

Rückgabe

Space(5)

"     "

Space(Max(Amount[*]))
Eine Zeichenfolge, die so viele Leerzeichen enthält, wie es dem größten Vorkommen von Amount entspricht.
Siehe auch Max.

Concat("Tony", Space(1), "Blue")

Tony Blue


Str

Wandelt eine Zahl in eine Zeichenfolge um. FormCalc formatiert das Ergebnis auf die angegebene Breite und rundet auf die angegebene Zahl von Dezimalstellen.
Syntax
Str(n1 [, n2 [, n3 ]])
Parameter

Parameter

Beschreibung

n1
Die umzuwandelnde Zahl.
n2 (optional)
Die maximale Breite der Zeichenfolge. Wenn Sie keinen Wert für n2 angeben, verwendet die Funktion den Wert 10 als Standardbreite.
Wenn die resultierende Zeichenfolge länger als n2 ist, gibt die Funktion eine aus dem Zeichen * (Stern) bestehende Zeichenfolge mit der in n2 angegebenen Breite zurück.
n3 (optional)
Die Anzahl der Ziffern, die hinter dem Dezimalpunkt angezeigt werden sollen. Wenn Sie keinen Wert für n3 angeben, verwendet die Funktion die Standardgenauigkeit 0.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Str:

Ausdruck

Rückgabe

Str(2.456)

"         2"

Str(4.532, 6, 4)

4.5320

Str(234.458, 4)

" 234"

Str(31.2345, 4, 2)

****

Str(Max(Amount[*]), 6, 2)
Wandelt das größte Vorkommen von Amount in eine sechs Zeichen lange Zeichenfolge mit zwei Dezimalstellen um.
Siehe auch Max.


Stuff

Fügt eine Zeichenfolge in eine andere Zeichenfolge ein.
Syntax
Stuff(s1, n1, n2 [, s2 ])
Parameter

Parameter

Beschreibung

s1
Die Quell-Zeichenfolge.

n1
Die Position in s1, an welcher die neue Zeichenfolge s2 eingefügt werden soll.
Wenn n1 kleiner als 1 ist, geht die Funktion von der ersten Zeichenposition aus. Wenn n1 größer als die Länge von s1 ist, geht die Funktion von der letzten Zeichenposition aus.

n2
Die Anzahl der Zeichen, die aus der Zeichenfolge s1 gelöscht werden sollen, beginnend an der Zeichenposition n1.
Wenn n2 kleiner oder gleich 0 ist, geht die Funktion von 0 Zeichen aus.
s2 (optional)
Die Zeichenfolge, die in s1 eingefügt werden soll.
Wenn Sie keinen Wert für s2 angeben, verwendet die Funktion die leere Zeichenfolge.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Stuff:

Ausdruck

Rückgabe

Stuff("TonyBlue", 5, 0, " ")

Tony Blue

Stuff("ABCDEFGH", 4, 2)

ABCFGH

Stuff(Address[0], Len(Address[0]), 0, "Street")
Hiermit wird das Wort Street am Ende des ersten Vorkommens von Address hinzugefügt.
Siehe auch Len.

Stuff("members-list@myweb.com", 0, 0, "cc:"

cc:members-list@myweb.com


Substr

Extrahiert einen Abschnitt aus einer angegebenen Zeichenfolge.
Syntax
Substr(s1, n1, n2 )
Parameter

Parameter

Beschreibung

s1
Die Quell-Zeichenfolge.

n1
Die Position in der Zeichenfolge s1, an welcher die Extraktion beginnen soll.
Wenn n1 kleiner als 1 ist, geht die Funktion von der ersten Zeichenposition aus. Wenn n1 größer als die Länge von s1 ist, geht die Funktion von der letzten Zeichenposition aus.

n2
Die Anzahl der zu extrahierenden Zeichen.
Wenn n2 kleiner oder gleich 0 ist, gibt FormCalc eine leere Zeichenfolge zurück. Wenn n1 + n2 größer als die Länge von s1 ist, gibt die Funktion die Unterzeichenfolge von der Position von n1 bis zum Ende von s1 zurück.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Substr:

Ausdruck

Rückgabe

Substr("ABCDEFG", 3, 4)

CDEF

Substr(3214, 2, 1)

2

Substr(Last_Name[0], 1, 3)
Liefert die drei ersten Zeichen aus dem ersten Vorkommen von Last_Name.

Substr("ABCDEFG", 5, 0)

""

Substr("21 Waterloo St.", 4, 5)

Water


Upper

Wandelt alle Kleinbuchstaben in einer angegebenen Zeichenfolge in Großbuchstaben um.
Syntax
Upper(s [, k ])
Parameter

Parameter

Beschreibung

s
Die umzuwandelnde Zeichenfolge.
k (optional)
Eine Zeichenfolge, die ein gültiges Gebietsschema angibt. Wenn Sie keinen Wert für k angeben, wird das Umgebungsgebietsschema verwendet.
Siehe auch Gebietsschemata.
Diese Funktion wandelt nur die Unicode-Zeichen von U+61 bis U+7A (im ASCII-Zeichensatz) sowie die Zeichen von U+FF41 bis U+FF5A (im vollbreiten Zeichensatz) um.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Upper:

Ausdruck

Rückgabe

Upper("abc")

ABC

Upper("21 Main St.")

21 MAIN ST.

Upper(15)

15

Upper(Address[0])
In diesem Beispiel wird das erste Vorkommen von Address vollständig in Großbuchstaben umgewandelt.


Uuid

Gibt eine UUID-Zeichenfolge (Universally Unique Identifier) zurück, die als Kennzeichnungsmethode verwendet werden soll.
Syntax
Uuid([n ])
Parameter

Parameter

Beschreibung

n
Eine Zahl, welche das Format der UUID-Zeichenfolge angibt. Gültige Zahlenwerte sind:
      •
      0 (Standardwert): UUID-Zeichenfolge enthält nur hexadezimale Oktett-Ziffern.
      •
      1: UUID-Zeichenfolge enthält an festgelegten Positionen Bindestriche zur Gliederung der hexadezimalen Oktettfolgen.
Wenn Sie keinen Wert für n angeben, verwendet die Funktion den Standardwert.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Funktion Uuid:

Ausdruck

Rückgabe

Uuid()
Ein Wert wie z. B. 3c3400001037be8996c400a0c9c86dd5
Uuid(0)
Ein Wert wie z. B. 3c3400001037be8996c400a0c9c86dd5
Uuid(1)
Ein Wert wie z. B. 1a3ac000-3dde-f352-96c4-00a0c9c86dd5
Uuid(7)
Ein Wert wie z. B. 1a3ac000-3dde-f352-96c4-00a0c9c86dd5


WordNum

Gibt die englischsprachige Textentsprechung einer angegebenen Zahl zurück.
Syntax
WordNum(n1 [, n2 [, k ]])
Parameter

Parameter

Beschreibung

n1
Die umzuwandelnde Zahl.
Wenn eine der folgenden Aussagen wahr ist, gibt die Funktion als Hinweis auf einen Fehler das Zeichen * (Stern) zurück:
      •
      n1 ist keine Zahl.
      •
      Der ganzzahlige Wert von n1 ist negativ.
      •
      Der ganzzahlige Wert von n1 ist größer als 922.337.203.685.477.550.
n2 (optional)
Eine Zahl zur Angabe der Formatierungsoption. Gültige Zahlenwerte sind:
      •
      0 (Standardwert): Die Zahl wird in einen Text umgewandelt, welcher die einfache Zahl darstellt.
      •
      1: Die Zahl wird in einen Text umgewandelt, welcher den Geldwert ohne Stellen nach dem Komma darstellt.
      •
      2: Die Zahl wird in einen Text umgewandelt, welcher den Geldwert mit Stellen nach dem Komma darstellt.
Wenn Sie keinen Wert für n2 angeben, verwendet die Funktion den Standardwert (0).
k (optional)
Eine Zeichenfolge, die ein gültiges Gebietsschema angibt. Wenn Sie keinen Wert für k angeben, verwendet die Funktion das Umgebungsgebietsschema.
Siehe auch Gebietsschemata.
In dieser Version ist es nicht möglich, für diese Funktion eine andere Gebietsschema-Kennung als Englisch anzugeben.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion WordNum:

Ausdruck

Rückgabe

WordNum(123.45)

One Hundred and Twenty-three Dollars

WordNum(123.45, 1)

One Hundred and Twenty-three Dollars

WordNum(1154.67, 2)

One Thousand One Hundred Fifty-four Dollars And Sixty-seven Cents

WordNum(43, 2)

Forty-three Dollars And Zero Cents

WordNum(Amount[0], 2)
Dieses Beispiel verwendet das erste Vorkommen von Amount als umzuwandelnde Zahl.


Zurück Weiter

Skripterstellung > FormCalc-Benutzerreferenz > URL-Funktionen

URL-Funktionen

Grundlagen zu URL-Funktionen
Get
Post
Put


Grundlagen zu URL-Funktionen

Diese Funktionen dienen zum Austausch von Informationen (Senden und Empfangen), einschließlich Inhaltstypen und Kodierungsdaten, mit beliebigen erreichbaren URL-Adressen.
Funktionen
      •
      Get
      •
      Post
      •
      Put


Get

Lädt den Inhalt der angegebenen URL herunter.
Die Funktion Get wird nur ausgeführt, wenn ein Formular zertifiziert ist. Adobe Acrobat® und Adobe Reader® können erst nach dem Initiieren des Ereignisses initialize prüfen, ob das Formular zertifiziert ist. Soll die Funktion Get vor der Formularwiedergabe bei zertifizierten Formularen eingesetzt werden, verwenden Sie das Ereignis docReady.
Syntax
Get(s)
Parameter

Parameter

Beschreibung

s
Die URL, von der Daten heruntergeladen werden sollen.
Wenn die Funktion von der angegebenen URL keine Daten herunterladen kann, gibt sie einen Fehler zurück.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Get:

Ausdruck

Rückgabe

Get("http://www.myweb.com/data/mydata.xml")
XML-Daten, welche der angegebenen Datei entnommen wurden.

Get("ftp://ftp.gnu.org/gnu/GPL")
Der Inhalt der GNU Public License.

Get("http://intranet?sql=SELECT+*+FROM+
projects+FOR+XML+AUTO,+ELEMENTS")
Das Ergebnis einer SQL-Abfrage der angegebenen Website.


Post

Sendet die angegebenen Daten an die genannte URL.
Die Funktion Post wird nur ausgeführt, wenn ein Formular zertifiziert ist. Acrobat und Adobe Reader können erst nach dem Initiieren des Ereignisses initialize prüfen, ob das Formular zertifiziert ist. Soll die Funktion Post vor der Formularwiedergabe bei zertifizierten Formularen eingesetzt werden, verwenden Sie das Ereignis docReady.
Syntax
Post(s1, s2 [, s3 [, s4 [, s5 ]]])
Parameter

Parameter

Beschreibung

s1
Die URL, an die Daten gesendet werden sollen.

s2
Die zu sendenden Daten.
Wenn die Funktion die Daten nicht senden kann, gibt sie einen Fehler zurück.
s3 (optional)
Eine Zeichenfolge, welche den Inhaltstyp der zu sendenden Daten enthält. Folgende Inhaltstypen sind zulässig:
      •
      application/octet-stream (Standardwert)
      •
      text/html
      •
      text/xml
      •
      text/plain
      •
      multipart/form-data
      •
      application/x-www-form-urlencoded
      •
      Alle sonstigen gültigen MIME-Typen
Wenn Sie für s3 keinen Wert angeben, setzt die Funktion den Inhaltstyp auf den Standardwert. Die Anwendung gewährleistet, dass bei den zu sendenden Daten das richtige Format für den angegebenen Inhaltstyp verwendet wird.
s4 (optional)
Eine Zeichenfolge mit dem Namen der für die Kodierung der Daten verwendeten Codepage. Folgende Codepage-Namen sind gültig:
      •
      UTF-8 (Standardwert)
      •
      UTF-16
      •
      ISO-8859-1
      •
      Jede von der Internet Assigned Numbers Authority (IANA) aufgeführte Zeichenkodierung
Wenn Sie für s4 keinen Wert angeben, setzt die Funktion die Codepage auf den Standardwert. Die Anwendung gewährleistet, dass die Kodierung der zu sendenden Daten der angegebenen Codepage entspricht.
s5 (optional)
Eine Zeichenfolge, die zusätzliche, beim Senden der Daten einzuschließende HTTP- Header enthält.
Wenn Sie für s5 keinen Wert angeben, fügt die Funktion beim Senden keinen zusätzlichen HTTP-Header ein.
Wenn Daten an SOAP-Server gesendet werden, ist in der Regel eine SOAPAction- Kopfzeile erforderlich.
Beispiele
Die folgende Tabelle zeigt Beispiele für die Verwendung der Funktion Post:

Ausdruck

Rückgabe

Post("http://tools_build/scripts/jfecho.cgi",
"user=joe&passwd=xxxxx&date=27/08/2002",
"application/x-www-form-urlencoded")
Sendet URL-kodierte Anmeldedaten an einen Server und gibt die Bestätigungsseite dieses Servers zurück.

Post("http://www.nanonull.com/TimeService/
TimeService.asmx/getLocalTime", "<?xml version='1.0'
encoding='UTF-8'?><soap:Envelope><soap:Body>
<getLocalTime/></soap:Body>
</soap:Envelope>", "text/xml", "utf-8",
"http://www.Nanonull.com/TimeService/getLocalTime")
Sendet eine SOAP-Anforderung der Ortszeit an einen Server und erwartet die Rückgabe einer XML-Antwort.


Put

Lädt die angegebenen Daten zu der genannten URL hoch.
Die Funktion Put wird nur ausgeführt, wenn ein Formular zertifiziert ist. Acrobat und Adobe Reader können erst nach dem Initiieren des Ereignisses initialize prüfen, ob das Formular zertifiziert ist. Soll die Funktion Put vor der Formularwiedergabe bei zertifizierten Formularen eingesetzt werden, verwenden Sie das Ereignis docReady.
Syntax
Put(s1, s2 [, s3 ])
Parameter

Parameter

Beschreibung

s1
Die URL, zu der Daten hochgeladen werden sollen.

s2
Die hochzuladenden Daten.
Wenn die Funktion die Daten nicht hochladen kann, gibt sie einen Fehler zurück.
s3 (optional)
Eine Zeichenfolge mit dem Namen der für die Kodierung der Daten verwendeten Codepage. Folgende Codepage-Namen sind gültig:
      •
      UTF-8 (Standardwert)
      •
      UTF-16
      •
      ISO8859-1
      •
      Jede von der Internet Assigned Numbers Authority (IANA) aufgeführte Zeichenkodierung
Wenn Sie für s3 keinen Wert angeben, setzt die Funktion die Codepage auf den Standardwert. Die Anwendung gewährleistet, dass die Kodierung der hochzuladenden Daten der angegebenen Codepage entspricht.
Beispiele
Die folgende Tabelle zeigt ein Beispiel für die Verwendung der Funktion Put:

Ausdruck

Rückgabe

Put("ftp://www.example.com/pub/fubu.xml",
"<?xml version='1.0'
encoding='UTF-8'?><msg>hello world!</msg>")
Nichts, wenn der FTP-Server dem Benutzer die Genehmigung erteilt hat, XML-Daten in die Datei pub/fubu.xml hochzuladen. Andernfalls gibt diese Funktion einen Fehler zurück.


Menü, Befehl, Werkzeugleiste und Dialogfeld Referenz

Menü, Befehl, Werkzeugleiste und Dialogfeld Referenz

Menüs und Befehle
Werkzeugleisten
Dialogfeld-Referenz


Menüs und Befehle

Grundlagen zu Menüs und Befehlen
So öffnen Sie ein Menü mit der Tastatur
So zeigen Sie ein Kontextmenü an
Menü „Datei“
Menü „Bearbeiten“
Menü „Ansicht“
Menü „Einfügen“
Menü „Tabelle“
Menü „Layout“
Menü „Extras“
Menü „Fenster“
Menü „Hilfe“
Menü „Vorlagen-Manager“
Menü „Feldeditor“
Palettenmenü „Hierarchie“
Palettenmenü „Datenansicht“
Palettenmenü „PDF-Struktur“
Palettenmenü „Bibliothek“
Menü „Favoriten“
Menü „Standard“
Menü „Eigene“
Menü „Barcode“
Palettenmenü „Layout“
Palettenmenü „Rand“
Palettenmenü „Objekt“
Palettenmenü „Ein-/Ausgabehilfe“
Palettenmenü „Schrift“
Palettenmenü „Absatz“
Palettenmenü „Zeichenhilfen“
Palettenmenü „Info“
Palettenmenü „Bericht“
Palettenmenü „Verfahren“


Grundlagen zu Menüs und Befehlen

In einem Menü wird eine Liste von Befehlen angezeigt. Neben einigen dieser Befehle finden Sie Symbole, so dass Sie den Befehl problemlos dem Symbol in der Symbolleiste zuordnen können. Anderen Befehlen sind Hotkeys (an dem Unterstrich zu erkennen) und Tastaturbefehle zugeordnet, so dass Sie allgemeine Aufgaben sehr schnell ausführen können.
Zusätzlich zu den Menüs am oberen Rand des Fensters LiveCycle Designer und in vielen Paletten zeigen Kontextmenüs Befehle an, die für die aktive Palette oder Seite relevant sind.


So öffnen Sie ein Menü mit der Tastatur

      *
      Um ein Menü mit der Tastatur zu öffnen, drücken Sie die Taste Alt + [Hotkey] und wählen Sie anschließend einen Menübefehl durch Drücken des entsprechenden Hotkeys aus. Zum Öffnen des Menüs „Bearbeiten“ und Auswählen des Ausschneiden-Befehls drücken Sie Alt+B und dann die Taste U. Sie können auch den Tastaturbefehl Strg+X für den Befehl „Ausschneiden“ verwenden.


So zeigen Sie ein Kontextmenü an

1.
Positionieren Sie den Zeiger über der Palette bzw. über der Seite.
2.
Klicken Sie mit der rechten Maustaste. Das Kontextmenü erscheint an der Stelle, an der Sie geklickt haben.


Menü „Datei“

Das Menü „Datei“ enthält Befehle zur Durchführung der primären Operationen in LiveCycle Designer.
Neu
Erstellt einen neuen Formularentwurf. Klicken Sie auf die Listenschaltfläche „Neu“ [image], um schnell eine Vorlage für den neuen Formularentwurf auszuwählen.
Öffnen
Öffnet einen vorhandenen Formularentwurf.
Schließen
Schließt den aktiven Formularentwurf. Sie werden aufgefordert, Ihre Änderungen zu speichern.
Speichern
Speichert den Inhalt des aktiven Formularentwurfs.
Speichern unter
Speichert den Inhalt des aktiven Formularentwurfs in einem der folgenden Dateiformate: Acrobat 8 (Statisch) PDF-Formular (.pdf), Acrobat 8 (Dynamisch) XML-Formular (.pdf), Acrobat 7 (Statisch) PDF-Formular (.pdf), Acrobat 7 (Dynamisch) XML-Formular (.pdf), Acrobat 6 (Statisch) PDF-Formular (.pdf), Adobe XML-Formular (.xdp) oder Adobe LiveCycle Designer Vorlage (.tds).
In Repository veröffentlichen
Speichert den Formularentwurf und seine zugeordneten Dateien in einem gemeinsamen oder Webordner, wo es von vielen Benutzern oder anderen Anwendungen aufgerufen werden kann.
Formular verteilen
Schließt das Formular in LiveCycle Designer. Anschließend wird der Acrobat-Assistent zum Verteilen angezeigt, um Sie durch den Verteilungsprozess zu führen.
Neue Datenverbindung
Richtet eine Datenverbindung ein; dadurch wird eine Beschreibung der Verbindung zwischen der Datenquelle und dem Formularentwurf bereitgestellt.
Formularobjektsammlungen
Erstellt, löscht, dupliziert und ändert Sammlungen für Dokumentunterschriftsfelder und Papierformular-Barcodes und benennt sie um.
Formulareigenschaften
Zeigt die Eigenschaften für den aktiven Formularentwurf an.
Drucken
Druckt den Inhalt der aktiven Registerkarte „Designansicht“ oder „Masterseiten“ im Layout-Editor.
Liste „Letzte Datei“
Listet die zuletzt geöffneten Formularentwurf-Fenster auf.
Beenden
Schließt LiveCycle Designer. Sie werden aufgefordert, Ihre Änderungen zu speichern.


Menü „Bearbeiten“

Das Menü „Bearbeiten“ enthält Befehle zum Bearbeiten eines Formularentwurfs.
Rückgängig
Macht bis zu 10 vorangegangene Aktionen rückgängig.
Wiederholen
Wendet bis zu 10 rückgängig gemachte Aktionen eine nach der anderen wieder an.
Ausschneiden
Löscht die aktuelle Auswahl und verschiebt eine Kopie davon in die Zwischenablage.
Kopieren
Fügt eine Kopie der aktuellen Auswahl in die Zwischenablage ein.
Einfügen
Kopiert den Inhalt der Zwischenablage in die Seite.
Löschen
Löscht die aktuelle Auswahl, ohne eine Kopie in die Zwischenablage zu platzieren.
Duplizieren
Dupliziert die aktuelle Auswahl, ohne eine Kopie in die Zwischenablage zu platzieren.
Mehrere kopieren
Erstellt eine angegebene Anzahl von Kopien der ausgewählten Objekte.
Alles auswählen
Wählt alle Objekte, Gruppen und Teilformulare der obersten Ebene auf der aktuellen Registerkarte „Layout Editor“ aus. Wählt außerdem den Inhalt des Skript-Editors aus.
Alle statischen Objekte auswählen
Wählt alle statischen Objekte aus, einschließlich statischem Text, Kreisen, Linien und Rechtecken.
Alle Felder auswählen
Wählt alle Felder aus, einschließlich Schaltflächen, Kontrollkästchen, Datums-/Uhrzeitfelder, Dezimalfelder, Dokumentunterschriftsfelder, Dropdown-Listen, Bildfelder, Listenfelder, numerischer Felder, Papierformular-Barcodes, Kennwortfelder, Optionsfelder und Textfelder.
Suchen
Sucht jedes Auftreten eines bestimmten Worts oder einer Zeichenfolge auf der Registerkarte „XML-Quelle“ oder im Skript-Editor.
Weitersuchen
Sucht das nächste Auftreten des angegebenen Worts bzw. der Zeichenfolge auf der Registerkarte „XML-Quelle“ oder im Skript-Editor.
Vorherige suchen
Sucht rückwärts nach dem angegebenen Wort bzw. der Zeichenfolge auf der Registerkarte „XML-Quelle“ oder im Skript-Editor.
Ersetzen
Sucht und ersetzt Text auf der Registerkarte „XML-Quelle“ oder im Skript-Editor.
Gehe zu Zeile
Wechselt auf der Registerkarte „XML-Quelle“ oder im Skript-Editor zur angegebenen Zeilennummer.
Text sperren
Ist diese Option aktiviert, wählen Sie durch einfaches Klicken ein Objekt aus und bearbeiten Sie mit einem Doppelklick Beschriftungen. Ist sie deaktiviert, können Sie durch einfaches Klicken ein Objekt auswählen und direkt die Beschriftung wählen.
Statische Objekte sperren
Ist diese Option aktiviert, können statische Objekte wie Text, Linien, Bilder und Formen nicht ausgewählt oder geändert werden.
Felder sperren
Ist diese Option aktiviert, können keine Feldobjekte ausgewählt oder geändert werden.
Grafik ersetzen
Ersetzt die Hintergrundgrafik in einem PDF-Dokument durch ein anderes PDF-Dokument, das Sie auswählen. Dieser Befehl ist nicht verfügbar, wenn ein PDF-Dokument keine Hintergrundgrafik enthält.


Menü „Ansicht“

Das Menü „Ansicht“ enthält Befehle, die Ihren Arbeitsbereich verändern.
Lineale
Zeigt die Lineale an oder blendet sie aus.
Führungslinien
Zeigt die Führungslinien an oder blendet sie aus.
Raster
Zeigt das Raster an oder blendet es aus.
An Raster ausrichten
Richtet das Objekt am nächsten Rasterpunkt aus.
Zeichenwerkzeug beibehalten
Bei Auswahl dieser Schaltfläche können Sie so viele Kopien eines Objekts wie nötig zeichnen, ohne das Objekt jedes Mal wieder in der Palette „Bibliothek“ auswählen zu müssen. Um diese Funktion zu deaktivieren, klicken Sie erneut auf „Zeichenwerkzeug beibehalten“.
Objektgrenzen
Zeigt die Begrenzungen um Objekte auf der Seite an oder blendet sie aus.
Feldeditor
Zeigt den Feldeditor um das ausgewählte Objekt auf der Seite an oder blendet ihn aus. Der Feldeditor vereinfacht den Zugriff auf allgemeine Eigenschaften.
Designansicht
Zeigt die Registerkarte „Designansicht“ an.
Masterseiten
Zeigt die Registerkarte „Masterseiten“ an.
XML-Quelle
Zeigt die Registerkarte „XML-Quelle“ an.
PDF-Vorschau
Zeigt die Registerkarte „PDF-Vorschau“ an.
Zoom
Vergrößert zur Anzeige von Details bzw. verkleinert zur Anzeige eines größeren Bereichs.
Tatsächliche Größe
Bringt die Seite auf die tatsächliche Größe (100%).
An Größe anpassen
Passt die Größe der Seite entsprechend dem Layout-Editor an.
Fensterbreite
Passt die Größe der Seite entsprechend der Breite des Layout-Editors an.
Zoom-Bereich
Vergrößert den ausgewählten Bereich auf der Seite.
Tab-Reihenfolge
Ermöglicht Ihnen die Auswahl der Tab-Reihenfolge zwischen Objekten im Formularentwurf.


Menü „Einfügen“

Das Menü „Einfügen“ enthält Befehle zum Hinzufügen von Objekten zum Formularentwurf.
Feld in Fließtext
Fügt ein schwebendes Feld in den Formularentwurf ein.
Aktuelle Seitenzahl
Fügt die aktuelle Seitenzahl des fertigen Formulars ein.
Anzahl der Seiten
Fügt die Gesamtanzahl der Seiten des fertigen Formulars ein.
Aktuelles Datum/Uhrzeit
Fügt das aktuelle Datum und die aktuelle Uhrzeit ein.
Gebietsschema des Anzeigeprogramms
Fügt den Wert der Spracheinstellung (Gebietsschema) für die Anwendung ein, in der das Formular verarbeitet wird.
Name des Anzeigeprogramms
Fügt den Namen der Anwendung ein, in der das Formular verarbeitet wird.
Version des Anzeigeprogramms
Fügt die Versionsnummer der Anwendung ein, in der das Formular verarbeitet wird.
Favoriten > [Objekt]
Listet die Zeichnungsobjekte auf, die Sie dem Formular hinzufügen können. Die Objekte in diesem Befehl entsprechen den Objekten in der Kategorie „Favoriten“ der Palette „Bibliothek“.
Standard > [Objekt]
Listet die Zeichnungsobjekte auf, die Sie dem Formular hinzufügen können. Die Objekte in diesem Befehl entsprechen den Objekten in der Kategorie „Standard“ der Palette „Bibliothek“.
Barcodes > [Objekt]
Listet die Barcodeobjekte auf, die Sie dem Formular hinzufügen können. Die Objekte in diesem Befehl entsprechen den Objekten in der Kategorie „Barcodes“ der Palette „Bibliothek“.
Eigene > [Objekt]
Listet die benutzerdefinierten Zeichnungsobjekte auf, die Sie dem Formular hinzufügen können. Die Objekte in diesem Befehl entsprechen den Objekten in der Kategorie „Eigene“ der Palette „Bibliothek“.
[Palette „Bibliothek“] > [Objekt]
Listet weitere Kategorien auf, die Sie der Palette „Bibliothek“ hinzufügen können. Die Objekte in diesem Befehl entsprechen den Objekten in den zusätzlichen Kategorien der Palette „Bibliothek“.
Umschließen mit Teilformular
Erstellt ein neues Teilformular mit den ausgewählten Objekten.
Umschließendes Teilformular entfernen
Das Teilformular wird entfernt; seine Objekte bleiben im Formularentwurf.
In Teilformularsatz aufnehmen
Erstellt ein neues Teilformular, durch das zwei oder mehr Teilformulare zu einer Gruppe (Einheit) zusammengefasst werden.
In Auswahl-Teilformularsatz aufnehmen
Erstellt ein neues Teilformular, durch das zwei oder mehr Teilformulare zu einer Gruppe (Einheit) zusammengefasst werden. Nur eines der Teilformulare im Satz erscheint im fertigen Formular, wobei die Auswahl anhand benutzerdefinierter Bedingungen erfolgt.
Aufnahme in Teilformularsatz aufheben
Hebt die Gruppierung zweier oder mehrerer Teilformulare zu einer Einheit auf.
Neue Seite
Fügt hinter der letzten Seite eine neue Seite im Formularentwurf ein. Diese Befehl wird nur angezeigt, wenn die Registerkarte „Designansicht“ aktiviert ist.
Seite löschen
Löscht die aktuelle Seite. Diese Befehl wird nur angezeigt, wenn die Registerkarte „Designansicht“ aktiviert ist.
Neue Masterseite
Fügt hinter der letzten Masterseite eine neue Masterseite im Formularentwurf ein. Diese Befehl wird nur angezeigt, wenn die Registerkarte „Masterseiten“ aktiviert ist.
Masterseite löschen
Löscht die aktuelle Masterseite Diese Befehl wird nur angezeigt, wenn die Registerkarte „Masterseiten“ aktiviert ist.


Menü „Tabelle“

Das Menü „Tabelle“ enthält Befehle für die Arbeit mit Tabellen.
Tabelle einfügen
Öffnet das Dialogfeld „Tabelle einfügen“.
Einfügen > Spalte links
Fügt links neben der äußersten linken ausgewählten Spalte eine oder mehrere Spalten ein. Dabei entspricht die Anzahl der eingefügten Spalten derjenigen der ausgewählten Spalten.
Einfügen > Spalte rechts
Fügt rechts neben der äußersten rechten ausgewählten Spalte eine oder mehrere Spalten ein. Dabei entspricht die Anzahl der eingefügten Spalten derjenigen der ausgewählten Spalten.
Einfügen > Zeile oben
Fügt oberhalb der ausgewählten Zellen oder Zeilen eine oder mehrere Zeilen ein. Dabei entspricht die Anzahl der eingefügten Zeilen derjenigen der ausgewählten Zeilen.
Einfügen > Zeile unten
Fügt unterhalb der ausgewählten Zellen oder Zeilen eine oder mehrere Zeilen ein. Dabei entspricht die Anzahl der eingefügten Zeilen derjenigen der ausgewählten Zeilen.
Einfügen > Abschnitt oben
Fügt oberhalb der ausgewählten Zellen, Zeilen oder Abschnitte einen Abschnitt ein.
Einfügen > Abschnitt unten
Fügt unterhalb der ausgewählten Zellen, Zeilen oder Abschnitte einen Abschnitt ein.
Löschen > Zeile
Löscht alle Zeilen mit ausgewählten Zellen.
Löschen > Spalte
Löscht alle Spalten mit ausgewählten Zellen.
Löschen > Abschnitt
Löscht alle Abschnitte mit ausgewählten Zellen.
Löschen > Tabelle
Löscht alle Tabellen mit ausgewählten Zellen.
Auswählen > Zelle
Wählt im Textbearbeitungsmodus die Zelle mit dem Cursor aus.
Auswählen > Zeilenzellen
Wählt alle Zellen in allen Zeilen mit mindestens einer ausgewählten Zelle aus. Es werden nur die Zellen (Textobjekte), nicht jedoch die Zeile selbst ausgewählt.
Auswählen > Spaltenzellen
Wählt alle Zellen in allen Spalten mit mindestens einer ausgewählten Zelle aus.
Auswählen > Zeile
Wählt alle Zeilen mit mindestens einer ausgewählten Zelle aus.
Auswählen > Abschnitt
Wählt alle Abschnitte mit mindestens einer ausgewählten Zelle oder Zeile aus.
Auswählen > Tabelle
Wählt alle Tabellen mit mindestens einer ausgewählten Zelle oder Zeile bzw. einem ausgewählten Abschnitt aus.
Zellen zusammenführen
Fügt zwei oder mehr nebeneinander liegende Zellen in derselben Zeile zu einer einzigen Zelle zusammen.
Zelle horizontal teilen
Teilt zwei oder mehr zusammengeführte Zellen in einer Zeile in separate Zellen.
Zeilen gleichmäßig verteilen
Verteilt die ausgewählten Zeilen gleichmäßig in einem oder mehreren Abschnitten bzw. in einer oder mehreren Tabellen. Alle Zeilen werden an die Höhe der höchsten ausgewählten Zeile angepasst.
Spalten gleichmäßig verteilen
Verteilt die ausgewählten Spalten gleichmäßig in einem oder mehreren Abschnitten bzw. in einer oder mehreren Tabellen. Die Gesamtbreite aller ausgewählten Spalten wird gleichmäßig auf alle ausgewählten Spalten aufgeteilt, so dass alle Spalten dieselbe Breite aufweisen. Die Tabellenbreite bleibt unverändert.
Als Abschnitt gruppieren
Fasst die ausgewählten Zeilen oder Abschnitte zu einem Abschnitt zusammen.
Als Auswahlabschnitt gruppieren
Erstellt einen Auswahlabschnitt mit einer Tabellenzeile. LiveCycle Designer nimmt die Zeile in einen Abschnitt auf, legt als Bedingung für den Zeilensatz „Teilformular aus Alternativen auswählen“ fest, überträgt die Instanzenbeschränkung der Zeile auf den Tabellenabschnitt und legt für den Mindest- und Maximalzählerwert der Zeile „1“ fest. Dieser Befehl ist verfügbar, wenn eine Tabellenzeile ausgewählt ist.
Abschnittsgruppierung aufheben
Hebt die Gruppierung der ausgewählten Zeilen oder Abschnitte auf und wandelt sie wieder in separate Zeilen und Abschnitte um.
In Tabelle konvertieren
Wandelt ein oder mehrere ausgewählte Objekte in eine Tabelle um.
Gehe zu Zeile
Öffnet das Dialogfeld „Gehe zu Zeile“.


Menü „Layout“

Das Menü „Layout“ enthält Befehle zum Anordnen von Objekten in einem Formularentwurf.
Ausrichten > Links
Richtet die linken Ränder der ausgewählten Objekte entsprechend der Position des Objekts aus, das zuletzt ausgewählt wurde.
Ausrichten > Rechts
Richtet die rechten Ränder der ausgewählten Objekte entsprechend der Position des Objekts aus, das zuletzt ausgewählt wurde.
Ausrichten > Oben
Richtet die oberen Ränder der ausgewählten Objekte entsprechend der Position des Objekts aus, das zuletzt ausgewählt wurde.
Ausrichten > Unten
Richtet die unteren Ränder der ausgewählten Objekte entsprechend der Position des Objekts aus, das zuletzt ausgewählt wurde.
Ausrichten > Vertikal zentriert
Richtet die vertikalen Mittelpunkte der ausgewählten Objekte aus.
Ausrichten > Horizontal zentriert
Richtet die horizontalen Mittelpunkte der ausgewählten Objekte aus.
Ausrichten > Am Raster
Richtet die ausgewählten Objekte am nächstgelegenen Rasterpunkt aus.
Verteilen > Quer
Verteilt die ausgewählten Objekte gleichmäßig horizontal.
Verteilen > Nach unten
Verteilt die ausgewählten Objekte gleichmäßig vertikal.
Verteilen > In Zeilen und Spalten
Richtet die ausgewählten Objekte aus und verteilt sie gleichmäßig in Zeilen und Spalten.
Auf Seite zentrieren > Horizontal
Zentriert die ausgewählten Objekte horizontal im Formularentwurf.
Auf Seite zentrieren > Vertikal
Zentriert die ausgewählten Objekte vertikal im Formularentwurf.
Gleiche Größe > Breite
Ändert die Größe der ausgewählten Objekte entsprechend der Breite des innerhalb der Auswahl zuletzt ausgewählten Objekts.
Gleiche Größe > Höhe
Ändert die Größe der ausgewählten Objekte entsprechend der Höhe des innerhalb der Auswahl zuletzt ausgewählten Objekts.
Gleiche Größe > Beide
Ändert die Größe der ausgewählten Objekte entsprechend der Breite und Höhe des innerhalb der Auswahl zuletzt ausgewählten Objekts.
Gruppieren
Verbindet die ausgewählten Objekte, so dass sie als eine Einheit verwendet werden. Eine Gruppe von Objekten kann eine beliebige Anzahl von Objekten enthalten und beliebig tief verschachtelt werden.
Gruppierung aufheben
Bricht ein gruppiertes Objekt in mehrere separate Einheiten auf.
Ausgewählte Textobjekte zusammenführen
Führt den Inhalt mehrerer Textobjekte in einem einzigen Objekt zusammen. Die Größe und Position des neuen Objekts entsprechen der Gesamtumrandung der zusammengeführten Objekte.
Als Beschriftung zusammenführen
Führt den Inhalt eines Textobjekts und eines Textfeldes, bei dem für die Position der Beschriftung „Ohne“ festgelegt wurde, in einem einzigen Objekt zusammen. Als Beschriftung für das neue Objekt wird der Text des Textobjekts verwendet. Die Größe und Position des neuen Objekts entsprechen der Gesamtumrandung der zusammengeführten Objekte.
In neue Optionsfeldgruppe aufnehmen
Nimmt die ausgewählten Optionsfelder in eine einzige Gruppe auf.
Optionsfeldgruppen zusammenführen
Führt die ausgewählten Optionsfeldgruppen (oder mindestens eine Optionsfeldgruppe und mindestens ein ausgewähltes Optionsfeld) in einer einzelnen Optionsfeldgruppe zusammen.
In den Vordergrund
Verschiebt die ausgewählten Objekte in den Vordergrund.
Eine Ebene nach vorne
Verschiebt ausgewählte Objekte relativ zu anderen Objekten, die vor den ausgewählten Objekten liegen, weiter nach vorne.
Eine Ebene nach hinten
Verschiebt ausgewählte Objekte relativ zu anderen Objekten, die hinter den ausgewählten Objekten liegen, weiter nach hinten.
In den Hintergrund
Verschiebt die ausgewählten Objekte in den Hintergrund.


Menü „Extras“

Das Menü „Extras“ enthält Befehle zum Angeben von Optionen.
Rechtschreibprüfung
Öffnet das Dialogfeld „Rechtschreibprüfung“, in dem Sie einzelne oder alle falsch geschriebenen Wörter in ausgewählten Objekten oder im ganzen Formular korrigieren, Wörter zu „Mein benutzerdefiniertes Wörterbuch“ hinzufügen, eine Liste zu ignorierender Wörter erstellen und das Fenster „Rechtschreibung“ im Dialogfeld „Optionen“ öffnen können.
Wörterbuch bearbeiten
Öffnet das Dialogfeld „Wörterbuch bearbeiten“, in dem Sie die Wortliste, die in „Mein benutzerdefiniertes Wörterbuch“ unter den einzelnen oder unter allen Sprachen verfügbar ist, anzeigen, die Rechtschreibung eines aufgelisteten Worts ändern sowie Wörter in einzelnen Sprachen oder in allen Sprachen hinzufügen bzw. Wörter aus einzelnen Sprachen oder allen Sprachen löschen können.
Vorlagen-Manager
Öffnet das Dialogfeld „Vorlagen-Manager“, in dem Sie Vorlagen verwalten und Standardvorlagen festlegen können.
Tastaturbefehle
Öffnet das Dialogfeld „Tastaturbefehle“, in dem Sie Tastaturbefehle anpassen können.
Werkzeugleisten anpassen
Passt das Erscheinungsbild der Werkzeugleisten an.
Optionen
Öffnet das Dialogfeld „Optionen“, in dem Sie Optionen zum Dokument, zum Arbeitsbereich, zur Rechtschreibung, zu Assistenten und Tipps, zu bidirektionalem Text, zu Datenbindung, zu Sprachen und zu internationalen Maßeinheiten festlegen können.
Formular aus Tabelleninhalt erstellen
Öffnet den Assistenten für neue Formulare, in dem Sie ein PDF-Formular mit interaktiven Formfeldern basierend auf den Spaltenüberschriften in einer Microsoft Excel-Tabelle erstellen können.


Menü „Fenster“

Das Menü „Fenster“ enthält Befehle zum Einblenden oder Ausblenden von Formularentwurf-Fenstern und Paletten in LiveCycle Designer.
Ausrichten > Neues Fenster
Öffnet ein neues Fenster des aktiven Formularentwurfs.
Ausrichten > Überlappend
Zeigt die geöffneten Formularentwurf-Fenster in überlappender Anordnung an.
Ausrichten > Nebeneinander
Zeigt alle geöffneten Formularentwurf-Fenster an.
Ausrichten > Symbole anordnen
Ordnet minimierte Fenster am unteren Rand des LiveCycle Designer-Fensters an.
Arbeitsbereich > Obere Paletten
Zeigt die am oberen Rand des LiveCycle Designer-Fensters angedockten Paletten an oder blendet sie aus.
Arbeitsbereich > Untere Paletten
Zeigt die am unteren Rand des LiveCycle Designer-Fensters angedockten Paletten an oder blendet sie aus.
Arbeitsbereich > Linke Paletten
Zeigt die am linken Rand des LiveCycle Designer-Fensters angedockten Paletten an oder blendet sie aus.
Arbeitsbereich > Rechte Paletten
Zeigt die am rechten Rand des LiveCycle Designer-Fensters angedockten Paletten an oder blendet sie aus.
Arbeitsbereich > Schwebende Paletten
Blendet schwebende Paletten ein oder aus.
Arbeitsbereich > Palettenpositionen zurücksetzen
Setzt die Paletten auf ihre Standardpositionen zurück.
Werkzeugleisten
Blendet die Werkzeugleisten (Symbolleisten) ein oder aus.
Skript-Editor
Blendet den Skript-Editor ein oder aus.
Statusleiste
Zeigt die Statusleiste an oder blendet sie aus.
Hierarchie
Blendet die Palette „Hierarchie“ ein oder aus.
PDF-Struktur
Blendet die Palette „PDF-Struktur“ ein oder aus.
Datenansicht
Blendet die Palette „Datenansicht“ ein oder aus.
Bibliothek
Blendet die Palette „Bibliothek“ ein oder aus.
Layout
Blendet die Palette „Layout“ ein oder aus.
Rand
Blendet die Palette „Rand“ ein oder aus.
Objekt
Blendet die Palette „Objekt“ ein oder aus.
Ein-/Ausgabehilfe
Blendet die Palette „Ein-/Ausgabehilfe“ ein oder aus.
Schrift
Blendet die Palette „Schrift“ ein oder aus.
Absatz
Blendet die Palette „Absatz“ ein oder aus.
Zeichenhilfen
Blendet die Palette „Zeichenhilfen“ ein oder aus.
Info
Blendet die Palette „Info“ ein oder aus.
Bericht
Blendet die Palette „Bericht“ ein oder aus.
Verfahren
Blendet die Palette „Verfahren“ ein oder aus.


Menü „Hilfe“

Das Hilfemenü enthält Befehle zum Aufrufen von Hilfeinformationen und liefert Versionsinformationen zu LiveCycle Designer.
Adobe LiveCycle Designer-Hilfe
Zeigt die Hilfethemen zu LiveCycle Designer an.
Verfahren
Blendet die Palette „Verfahren“ ein oder aus.
Erste Schritte
Zeigt die Lernprogramme an, die Ihnen beim Erstellen grundlegender Formulare behilflich sein sollen.
Skriptreferenz
Zeigt die Skriptreferenz an. Die Skriptreferenz beschreibt die Objekte, Eigenschaften und Methoden, die Sie in der Skriptumgebung von LiveCycle Designer verwenden können.
Willkommen
Blendet den Begrüßungsbildschirm ein bzw. aus.
Über LiveCycle Designer 8.0
Zeigt die Version von LiveCycle Designer sowie Copyright-Informationen an.


Menü „Vorlagen-Manager“

Das in den Dialogfeldern „Neu“ und „Vorlagen-Manager“ angezeigte Menü enthält Befehle zur Verwaltung von Formularvorlagen.
Hilfe
Öffnet die LiveCycle Designer-Hilfe und zeigt eine Beschreibung des Dialogfeldes an.
Anzeigen > Große Symbole
Zeigt die Objekte als große Symbole an.
Anzeigen > Liste
Zeigt die Objekte nach Namen in alphabetischer Reihenfolge an.
Vorlage hinzufügen
Öffnet das Dialogfeld „Vorlagendatei hinzufügen“, in dem Sie eine Vorlage suchen können, die Sie zum Dialogfeld hinzufügen möchten.
Vorlage löschen
Entfernt die ausgewählte Vorlage aus dem Dialogfeld.
Vorlage umbenennen
Benennt die Vorlage im Dialogfeld um.
Vorlage verschieben nach > [Registerkarte]
Verschiebt die Vorlage auf eine andere Registerkarte im Dialogfeld.
Kategorie hinzufügen
Fügt dem Dialogfeld eine Registerkarte hinzu.
Kategorie entfernen
Entfernt die ausgewählte Registerkarte aus dem Dialogfeld. Es können nicht alle Registerkarten entfernt werden.
Kategorie-Eigenschaften
Zeigt Registerkarteneigenschaften an, die geändert werden können.
Standardvorlagen wiederherstellen
Stellt die Standardvorlagen mit ihren ursprünglichen Einstellungen wieder her.


Menü „Feldeditor“

Das Menü „Feldeditor“ wird im Feldeditor angezeigt und enthält Befehle zum Verwalten ausgewählter Objekteigenschaften.
Ausschneiden
Löscht die aktuelle Auswahl und verschiebt eine Kopie davon in die Zwischenablage.
Kopieren
Fügt eine Kopie der aktuellen Auswahl in die Zwischenablage ein.
Einfügen
Kopiert den Inhalt der Zwischenablage in die Seite.
Löschen
Löscht die aktuelle Auswahl, ohne eine Kopie in die Zwischenablage zu platzieren.
Objekt umbenennen Benennt das ausgewählte Objekt um.
Objekttyp ändern > Textfeld
Legt den Objekttyp auf „Textfeld“ fest.
Objekttyp ändern > Numerisches Feld
Legt den Objekttyp auf „Numerisches Feld“ fest.
Objekttyp ändern > Schaltfläche
Legt den Objekttyp auf „Schaltfläche“ fest.
Objekttyp ändern > Listenfeld
Legt den Objekttyp auf „Listenfeld“ fest.
Objekttyp ändern > Dropdown-Liste
Legt den Objekttyp auf „Dropdown-Liste“ fest.
Objekttyp ändern > Optionsfeld
Legt den Objekttyp auf „Optionsfeld“ fest.
Objekttyp ändern > Bildfeld
Legt den Objekttyp auf „Bildfeld“ fest.
Objekttyp ändern > Rechteck
Legt den Objekttyp auf „Rechteck“ fest.
Objekttyp ändern > Kreis
Legt den Objekttyp auf „Kreis“ fest.
Objekttyp ändern > Linie
Legt den Objekttyp auf „Linie“ fest.
Objekttyp ändern > Bild
Legt den Objekttyp auf „Bild“ fest.
Objekttyp ändern > Text
Legt den Objekttyp auf „Text“ fest.
Umschließen mit Teilformular
Erstellt ein neues Teilformular mit den ausgewählten Objekten.
Umschließendes Teilformular entfernen
Das Teilformular wird entfernt; seine Objekte bleiben im Formularentwurf.
Zusammenführen
Führt den Inhalt mehrerer Textobjekte in einem Objekt zusammen. Die Größe und Position des neuen Objekts entsprechen der Gesamtumrandung der zusammengeführten Objekte.
In den Vordergrund
Verschiebt die ausgewählten Objekte in den Vordergrund.
Eine Ebene nach vorne
Verschiebt ausgewählte Objekte relativ zu anderen Objekten, die vor den ausgewählten Objekten liegen, weiter nach vorne.
Eine Ebene nach hinten
Verschiebt ausgewählte Objekte relativ zu anderen Objekten, die hinter den ausgewählten Objekten liegen, weiter nach hinten.
In den Hintergrund
Verschiebt die ausgewählten Objekte in den Hintergrund.
Paletten > Layout
Blendet die Palette „Layout“ ein oder aus.
Paletten > Rand
Blendet die Palette „Rand“ ein oder aus.
Paletten > Objekt
Blendet die Palette „Objekt“ ein oder aus.
Paletten > Schrift
Blendet die Palette „Schrift“ ein oder aus.
Paletten > Absatz
Blendet die Palette „Absatz“ ein oder aus.
Paletten > Ein-/Ausgabehilfe
Blendet die Palette „Ein-/Ausgabehilfe“ ein oder aus.
Zu Bibliothek hinzufügen
Fügt das Objekt zur Palette „Bibliothek“ hinzu.
Text bearbeiten
Wendet Änderungen an, die Sie in der Objektbeschreibung vornehmen.


Palettenmenü „Hierarchie“

Das Palettenmenü „Hierarchie“ zeigt Befehle zum Arbeiten mit der Palette „Hierarchie“ an. Sie können dieses Menü durch Klicken auf die Palettenmenüschaltfläche aufrufen. Das Kontextmenü wird auch eingeblendet, wenn Sie in der Palette „Hierarchie“ mit der rechten Maustaste klicken.
Hilfe
Öffnet die LiveCycle Designer-Hilfe und zeigt eine Beschreibung der Palette „Hierarchie“ an.
Palette ausblenden
Blendet die Palette aus.
Objekt umbenennen
Benennt das ausgewählte Objekt in der Palette „Hierarchie“ um.
Löschen
Löscht die aktuelle Auswahl, ohne eine Kopie in die Zwischenablage zu platzieren.
Umschließen mit Teilformular
Erstellt ein neues Teilformular mit den ausgewählten Objekten.
Umschließendes Teilformular entfernen
Das Teilformular wird entfernt; seine Objekte bleiben im Formularentwurf.
Teilformular einfügen
Fügt im Formularentwurf ein Teilformular ein.
In Teilformularsatz aufnehmen
Erstellt ein neues Teilformular, durch das zwei oder mehr Teilformulare zu einer Gruppe (Einheit) zusammengefasst werden.
In Auswahl-Teilformularsatz aufnehmen
Erstellt ein neues Teilformular, durch das zwei oder mehr Teilformulare zu einer Gruppe (Einheit) zusammengefasst werden. Nur eines der Teilformulare im Satz erscheint im fertigen Formular, wobei die Auswahl anhand benutzerdefinierter Bedingungen erfolgt.
Aufnahme in Teilformularsatz aufheben
Hebt die Gruppierung zweier oder mehrerer Teilformulare zu einer Einheit auf.
Teilformularsatz einfügen
Fügt im Formularentwurf einen Teilformularsatz ein.
Ausgewählte Textobjekte zusammenführen
Führt den Inhalt mehrerer Textobjekte in einem Objekt zusammen. Die Größe und Position des neuen Objekts entsprechen der Gesamtumrandung der zusammengeführten Objekte.
Als Beschriftung zusammenführen
Führt den Inhalt eines Textobjekts und eines Textfeldes, bei dem für die Position der Beschriftung „Ohne“ festgelegt wurde, in einem einzigen Objekt zusammen. Als Beschriftung für das neue Objekt wird der Text des Textobjekts verwendet. Die Größe und Position des neuen Objekts entsprechen der Gesamtumrandung der zusammengeführten Objekte.
In neue Optionsfeldgruppe aufnehmen
Nimmt die ausgewählten Optionsfelder in eine einzige Gruppe auf.
Optionsfeldgruppen zusammenführen
Führt die ausgewählten Optionsfeldgruppen (oder mindestens eine Optionsfeldgruppe und mindestens ein ausgewähltes Optionsfeld) in einer Einheit zusammen.
Skriptobjekt einfügen
Fügt ein Skript als Child-Element des ausgewählten Objekts ein. Das Skriptobjekt ist ein Objekt, das Sie zum Speichern des Skript-Codes und der Werte getrennt von einem bestimmten Formularobjekt verwenden können. Normalerweise verwenden Sie das Skriptobjekt zum Erstellen eigener Funktionen und Methoden, die Sie als Teil von Skripten an vielen Stellen in Ihrem Formular einsetzen möchten.
Neue Seite
Fügt hinter der letzten Seite eine neue Seite im Formularentwurf ein. Dieser Befehl ist nur verfügbar, wenn Sie in der Palette „Hierarchie“ eine Textseite ausgewählt haben.
Neue Masterseite
Fügt hinter der letzten Masterseite eine neue Masterseite im Formularentwurf ein. Dieser Befehl ist nur verfügbar, wenn Sie in der Palette „Hierarchie“ eine Masterseite ausgewählt haben.
Seitensatz einfügen
Fügt einen Seitensatz zur Steuerung der Reihenfolge und des Auftretens der Seiten im Formularentwurf hinzu.
Namen anzeigen
Zeigt den Namen des Objekts an. Dies ist die Standardeinstellung.
Beschriftungen anzeigen
Zeigt die Beschriftung des Objekts mit maximal 25 Zeichen an. Falls keine Beschriftung verfügbar ist, wird „(keine Beschriftung)“ angezeigt.
Beides anzeigen
Zeigt den Namen und die Beschriftung des Objekts an.


Palettenmenü „Datenansicht“

Das Palettenmenü „Datenansicht“ zeigt Befehle zum Arbeiten mit der Palette „Datenansicht“ an. Sie können dieses Menü durch Klicken auf die Palettenmenüschaltfläche aufrufen. Das Kontextmenü wird auch eingeblendet, wenn Sie in der Palette „Datenansicht“ mit der rechten Maustaste klicken.
Hilfe
Öffnet die LiveCycle Designer-Hilfe und zeigt eine Beschreibung der Palette „Datenansicht“ an.
Palette ausblenden
Blendet die Palette aus.
Neue Datenverbindung
Richtet eine Datenverbindung ein; dadurch wird eine Beschreibung der Verbindung zwischen der Datenquelle und dem Formularentwurf bereitgestellt.
Datenverbindung löschen
Entfernt die ausgewählte Datenverbindung aus dem Formularentwurf.
Verbindungseigenschaften
Zeigt Eigenschaften der aktuellen Datenverbindung an; einige dieser Eigenschaften können geändert werden.
Felder generieren
Erstellt neue Felder, Teilformulare und Teilformularsätze im Formularentwurf, die der durch die Datenverbindung dargestellten Datenhierarchie entsprechen.
Optionen
Zeigt die Optionen an, die beim Generieren eines Feldes oder einer Gruppe von Feldern mit dem Befehl „Felder generieren“ angewendet werden.
Datennamen anzeigen
Zeigt den Datennamen des Objekts an. Dies ist die Standardeinstellung.
Datenbeschreibungen anzeigen
Zeigt die Datenbeschreibung des Objekts mit maximal 25 Zeichen an. Falls keine Beschreibung für das Objekt verfügbar ist, wird der Datenname angezeigt.
Beides anzeigen
Zeigt den Datennamen und die Beschreibung des Objekts an.
Informationen einblenden
Blendet die Eigenschaften des in der Datenansicht ausgewählten Knotens ein bzw. aus.
Datenansicht aktualisieren
Aktualisiert alle Datenverbindungen in der aktuellen Vorlage.


Palettenmenü „PDF-Struktur“

Das Palettenmenü „PDF-Struktur“ zeigt Befehle zum Arbeiten mit der Palette „PDF-Struktur“ an. Sie können dieses Menü durch Klicken auf die Palettenmenüschaltfläche aufrufen. Das Kontextmenü wird auch eingeblendet, wenn Sie in der Palette „PDF-Struktur“ mit der rechten Maustaste klicken.
Hilfe
Öffnet die LiveCycle Designer-Hilfe und zeigt eine Beschreibung der Palette „PDF-Struktur“ an.
Palette ausblenden
Blendet die Palette aus, die Sie im Menü „Fenster“ wieder anzeigen können.
Feld der Struktur hinzufügen
Erstellt ein neues Feldstrukturelement im ausgewählten Feldobjekt auf der Registerkarte „Designansicht“. Jedes einzelne Feld kann nur über ein Strukturelement in der Strukturansicht verfügen.
Feld aus Struktur entfernen
Entfernt das ausgewählte Feldstrukturelement.
Voriges Tag
Wechselt vom ausgewählten Struktur-Tag zum vorherigen Struktur-Tag.
Nächstes Tag
Wechselt vom ausgewählten Struktur-Tag zum nächsten Struktur-Tag.
Feld nach oben
Schiebt das ausgewählte Feld unter dem aktuellen Struktur-Tag eine Position nach oben. Wenn es sich beim ausgewählten Feld um das erste Feld unter dem Tag handelt, wird es zum vorherigen Struktur-Tag geschoben.
Feld nach unten
Schiebt das ausgewählte Feld unter dem aktuellen Struktur-Tag eine Position nach unten. Wenn es sich beim ausgewählten Feld um das letzte Feld unter dem Tag handelt, wird es zum nächsten Struktur-Tag geschoben.
Felder ohne Tags suchen
Sucht und identifiziert Felder, die über keine Struktur verfügen.
Kontext-Tags anzeigen
Wechselt die Anzeige von Kontext-Tags.


Palettenmenü „Bibliothek“

Das Palettenmenü „Bibliothek“ zeigt Befehle zum Arbeiten mit der Palette „Bibliothek“ an. Sie können dieses Menü durch Klicken auf die Palettenmenüschaltfläche aufrufen.
Hilfe
Öffnet die LiveCycle Designer-Hilfe und zeigt eine Beschreibung der Palette „Bibliothek“ an.
Palette ausblenden
Blendet die Palette aus.
Alle ausblenden
Blendet die Objekte in der Liste der Palette „Bibliothek“ aus.
Alle einblenden
Blendet die Objekte in der Liste der Palette „Bibliothek“ ein.
Objektvorschau anzeigen
Blendet das Vorschaufenster mit dem ausgewählten Objekt ein bzw. aus.
Zoom-Vorschau > [%]
Zeigt die Zoom-Stufe des Vorschau-Teilfensters an.
Gruppe hinzufügen
Fügt der Palette „Bibliothek“ eine neue Kategorie hinzu, in der Sie Objekte erstellen und speichern können.
Gemeinsame Bibliotheksposition
Zeigt die Position der gemeinsamen Bibliothek an.
Standardobjekte für alle Kategorien wiederherstellen
Sofern dies zulässig ist, stellt diese Funktion alle Objekte wieder her, die bei der Installation in der Palette „Bibliothek“ vorhanden waren.


Menü „Favoriten“

Das Menü „Favoriten“ zeigt Befehle zum Arbeiten mit den Objekten des Menüs „Favoriten“ in der Palette „Bibliothek“ an. Sie können dieses Menü durch Klicken auf die Menüschaltfläche aufrufen.
Anzeigen > Große Symbole
Zeigt die Objekte als große Symbole an.
Anzeigen > Kleine Symbole
Zeigt die Objekte als kleine Symbole an.
Anzeigen > Sortierte Liste
Zeigt die Objekte nach Namen in alphabetischer Reihenfolge an.
Objekt verschieben nach > [Registerkarte]
Verschiebt das ausgewählte Objekt in die ausgewählte Liste der Palette „Bibliothek“.
Objekt aus Bibliothek entfernen
Entfernt das ausgewählte Objekt aus der Palette „Bibliothek“.
Objektinfo
Zeigt Informationen zum Objekt an. Sofern das Ändern des Objekts zulässig ist, können Sie mit diesem Befehl die Objektinformationen ändern.
Gruppe entfernen
Entfernt die ausgewählte Kategorie und ihre Objekte aus der Palette „Bibliothek“.
Gruppeneigenschaften
Zeigt die Eigenschaften der ausgewählten Kategorie in der Palette „Bibliothek“ an. Sie können die Eigenschaften einer gemeinsamen Bibliothek nicht ändern.
Standardobjekte wiederherstellen
Sofern dies zulässig ist, stellt diese Funktion die Objekte wieder her, die bei der Installation in der Kategorie „Favoriten“ vorhanden waren, und fügt sie der aktuellen Liste hinzu.


Menü „Standard“

Das Menü „Standard“ zeigt Befehle zum Arbeiten mit den Objekten des Menüs „Standard“ in der Palette „Bibliothek“ an. Sie können dieses Menü durch Klicken auf die Menüschaltfläche aufrufen.
Anzeigen > Große Symbole
Zeigt die Objekte als große Symbole an.
Anzeigen > Kleine Symbole
Zeigt die Objekte als kleine Symbole an.
Anzeigen > Sortierte Liste
Zeigt die Objekte nach Namen in alphabetischer Reihenfolge an.
Objekt verschieben nach > [Registerkarte]
Verschiebt das ausgewählte Objekt in die ausgewählte Liste der Palette „Bibliothek“.
Objekt aus Bibliothek entfernen
Entfernt das ausgewählte Objekt aus der Palette „Bibliothek“.
Objektinfo
Zeigt Informationen zum Objekt an. Sofern das Ändern des Objekts zulässig ist, können Sie mit diesem Befehl die Objektinformationen ändern.
Gruppe entfernen
Entfernt die ausgewählte Kategorie und ihre Objekte aus der Palette „Bibliothek“.
Gruppeneigenschaften
Zeigt die Eigenschaften der ausgewählten Kategorie in der Palette „Bibliothek“ an. Sie können die Eigenschaften einer gemeinsamen Bibliothek nicht ändern.
Standardobjekte wiederherstellen
Sofern dies zulässig ist, stellt diese Funktion die Objekte wieder her, die bei der Installation in der Kategorie „Standard“ vorhanden waren, und fügt sie der aktuellen Liste hinzu.


Menü „Eigene“

Das Menü „Standard“ zeigt Befehle zum Arbeiten mit den Objekten des Menüs „Eigene“ in der Palette „Bibliothek“ an. Sie können dieses Menü durch Klicken auf die Menüschaltfläche aufrufen.
Anzeigen > Große Symbole
Zeigt die Objekte als große Symbole an.
Anzeigen > Kleine Symbole
Zeigt die Objekte als kleine Symbole an.
Anzeigen > Sortierte Liste
Zeigt die Objekte nach Namen in alphabetischer Reihenfolge an.
Objekt verschieben nach > [Registerkarte]
Verschiebt das ausgewählte Objekt in die ausgewählte Liste der Palette „Bibliothek“.
Objekt aus Bibliothek entfernen
Entfernt das ausgewählte Objekt aus der Palette „Bibliothek“.
Objektinfo
Zeigt Informationen zum Objekt an. Sofern das Ändern des Objekts zulässig ist, können Sie mit diesem Befehl die Objektinformationen ändern.
Gruppe entfernen
Entfernt die ausgewählte Kategorie und ihre Objekte aus der Palette „Bibliothek“.
Gruppeneigenschaften
Zeigt die Eigenschaften der ausgewählten Kategorie in der Palette „Bibliothek“ an. Sie können die Eigenschaften einer gemeinsamen Bibliothek nicht ändern.
Standardobjekte wiederherstellen
Sofern dies zulässig ist, stellt diese Funktion die Objekte wieder her, die bei der Installation in der Kategorie „Eigene“ vorhanden waren, und fügt sie der aktuellen Liste hinzu.


Menü „Barcode“

Das Menü „Barcode“ zeigt Befehle zum Arbeiten mit den Objekten des Menüs „Barcode“ in der Palette „Bibliothek“ an. Sie können dieses Menü durch Klicken auf die Menüschaltfläche aufrufen.
Anzeigen > Große Symbole
Zeigt die Objekte als große Symbole an.
Anzeigen > Kleine Symbole
Zeigt die Objekte als kleine Symbole an.
Anzeigen > Sortierte Liste
Zeigt die Objekte nach Namen in alphabetischer Reihenfolge an.
Objekt verschieben nach > [Registerkarte]
Verschiebt das ausgewählte Objekt in die ausgewählte Liste der Palette „Bibliothek“.
Objekt aus Bibliothek entfernen
Entfernt das ausgewählte Objekt aus der Palette „Bibliothek“.
Objektinfo
Zeigt Informationen zum Objekt an. Sofern das Ändern des Objekts zulässig ist, können Sie mit diesem Befehl die Objektinformationen ändern.
Gruppe entfernen
Entfernt die ausgewählte Kategorie und ihre Objekte aus der Palette „Bibliothek“.
Gruppeneigenschaften
Zeigt die Eigenschaften der ausgewählten Kategorie in der Palette „Bibliothek“ an. Sie können die Eigenschaften einer gemeinsamen Bibliothek nicht ändern.
Standardobjekte wiederherstellen
Sofern dies zulässig ist, stellt diese Funktion die Objekte wieder her, die bei der Installation in der Kategorie „Barcode“ vorhanden waren, und fügt sie der aktuellen Liste hinzu.


Palettenmenü „Layout“

Das Palettenmenü „Layout“ zeigt Befehle zum Arbeiten mit der Palette „Layout“ an. Sie können dieses Menü durch Klicken auf die Palettenmenüschaltfläche aufrufen.
Hilfe
Öffnet die LiveCycle Designer-Hilfe und zeigt eine Beschreibung der Palette „Layout“ an.
Palette ausblenden
Blendet die Palette aus.
Absolute Koordinaten
Zeigt die X- und Y-Koordinaten relativ zur linken oberen Ecke der Seite an. Absolute Koordinaten sind besonders bei statischen Formularen hilfreich.
Relative Koordinaten
Zeigt die X- und Y-Koordinaten relativ zu den Parent-Objekten an. Relative Koordinaten sind in Formularen, deren Layout sich der Datenmenge anpasst, sehr nützlich.


Palettenmenü „Rand“

Das Palettenmenü „Rand“ zeigt Befehle zum Arbeiten mit der Palette „Rand“ an. Sie können dieses Menü durch Klicken auf die Palettenmenüschaltfläche aufrufen.
Hilfe
Öffnet die LiveCycle Designer-Hilfe und zeigt eine Beschreibung der Palette „Rand“ an.
Palette ausblenden
Blendet die Palette aus.


Palettenmenü „Objekt“

Das Palettenmenü „Objekt“ zeigt Befehle zum Arbeiten mit der Palette „Objekt“ an. Sie können dieses Menü durch Klicken auf die Palettenmenüschaltfläche aufrufen.
Hilfe
Öffnet die LiveCycle Designer-Hilfe und zeigt eine Beschreibung der Palette „Objekt“ an.
Palette ausblenden
Blendet die Palette aus.
Dynamische Eigenschaften anzeigen
Blendet die aktiven Beschriftungen für dynamische Eigenschaften ein bzw. aus. Aktive Beschriftungen zeigen an, welche Eigenschaften dynamisch sein können. Sie werden grün und unterstrichen dargestellt. Wenn Sie auf eine solche Eigenschaft klicken, können Sie sie dynamisch an eine Datenquelle binden.


Palettenmenü „Ein-/Ausgabehilfe“

Das Palettenmenü „Ein-/Ausgabehilfe“ zeigt Befehle zum Arbeiten mit der Palette „Ein-/Ausgabehilfe“ an. Sie können dieses Menü durch Klicken auf die Palettenmenüschaltfläche aufrufen.
Hilfe
Öffnet die LiveCycle Designer-Hilfe und zeigt eine Beschreibung der Palette „Ein-/Ausgabehilfe“ an.
Palette ausblenden
Blendet die Palette aus.
Dynamische Eigenschaften anzeigen
Blendet die aktiven Beschriftungen für dynamische Eigenschaften ein bzw. aus. Aktive Beschriftungen zeigen an, welche Eigenschaften dynamisch sein können. Sie werden grün und unterstrichen dargestellt. Wenn Sie auf eine solche Eigenschaft klicken, können Sie sie dynamisch an eine Datenquelle binden.


Palettenmenü „Schrift“

Das Palettenmenü „Schrift“ zeigt Befehle zum Arbeiten mit der Palette „Schrift“ an. Sie können dieses Menü durch Klicken auf die Palettenmenüschaltfläche aufrufen.
Hilfe
Öffnet die LiveCycle Designer-Hilfe und zeigt eine Beschreibung der Palette „Schrift“ an.
Palette ausblenden
Blendet die Palette aus.
Schriftnamen im eigenen Schriftstil anzeigen
Zeigt die Schriftnamen in der Schrift selbst an.
Palettenmenü für den aktuellen Bearbeitungsmodus
Das Palettenmenü für den aktuellen Bearbeitungsmodus zeigt Befehle zum Arbeiten mit der Palette „Schrift“ an. Sie können dieses Menü durch Klicken auf die Palettenmenüschaltfläche aufrufen.
Das Palettenmenü für den aktuellen Bearbeitungsmodus ist nur verfügbar, wenn das gesamte Objekt ausgewählt und die Option „Bearbeiten“ > „Text sperren“ nicht aktiviert ist.
Beschriftung und Wert bearbeiten
Wendet Änderungen, die Sie in der Palette „Schrift“ vornehmen, auf die Beschriftung und den Wert an.
Beschriftung bearbeiten
Wendet Änderungen, die Sie in der Palette „Schrift“ vornehmen, auf die Beschriftung an.
Wert bearbeiten
Wendet Änderungen, die Sie in der Palette „Schrift“ vornehmen, auf den Wert an.


Palettenmenü „Absatz“

Das Palettenmenü „Absatz“ zeigt Befehle zum Arbeiten mit der Palette „Absatz“ an. Sie können dieses Menü durch Klicken auf die Palettenmenüschaltfläche aufrufen.
Hilfe
Öffnet die LiveCycle Designer-Hilfe und zeigt eine Beschreibung der Palette „Absatz“ an.
Palette ausblenden
Blendet die Palette aus.
Palettenmenü für den aktuellen Bearbeitungsmodus
Das Palettenmenü für den aktuellen Bearbeitungsmodus zeigt Befehle zum Arbeiten mit der Palette „Absatz“ an. Sie können dieses Menü durch Klicken auf die Palettenmenüschaltfläche aufrufen.
Das Palettenmenü für den aktuellen Bearbeitungsmodus ist nur verfügbar, wenn das gesamte Objekt ausgewählt und die Option „Bearbeiten“ > „Text sperren“ nicht aktiviert ist.
Beschriftung und Wert bearbeiten
Wendet Änderungen, die Sie in der Palette „Schrift“ vornehmen, auf die Beschriftung und den Wert an.
Beschriftung bearbeiten
Wendet Änderungen, die Sie in der Palette „Schrift“ vornehmen, auf die Beschriftung an.
Wert bearbeiten
Wendet Änderungen, die Sie in der Palette „Schrift“ vornehmen, auf den Wert an.


Palettenmenü „Zeichenhilfen“

Das Palettenmenü „Zeichenhilfen“ zeigt Befehle zum Arbeiten mit der Palette „Zeichenhilfen“ an. Sie können dieses Menü durch Klicken auf die Palettenmenüschaltfläche aufrufen.
Hilfe
Öffnet die LiveCycle Designer-Hilfe und zeigt eine Beschreibung der Palette „Zeichenhilfen“ an.
Palette ausblenden
Blendet die Palette aus.
Zoll/Zentimeter/Millimeter/Punkt (mit Dezimalstellen)
Zeigt einen Wert als n Zoll oder n cm an.
Zeilen pro Zoll/Zentimeter/Millimeter/Punkt
Zeigt einen Wert als n/Zoll oder n/cm an.
Führungslinien-Sets > [Führungslinie]
Fügt horizontale und vertikale Führungslinien hinzu.


Palettenmenü „Info“

Das Palettenmenü „Info“ zeigt Befehle zum Arbeiten mit der Palette „Info“ an. Sie können dieses Menü durch Klicken auf die Palettenmenüschaltfläche aufrufen.
Hilfe
Öffnet die LiveCycle Designer-Hilfe und zeigt eine Beschreibung der Palette „Info“ an.
Palette ausblenden
Blendet die Palette aus.


Palettenmenü „Bericht“

Das Palettenmenü „Bericht“ zeigt Befehle zum Arbeiten mit der Palette „Bericht“ an. Sie können dieses Menü durch Klicken auf die Palettenmenüschaltfläche aufrufen.
Hilfe
Öffnet die LiveCycle Designer-Hilfe und zeigt eine Beschreibung der Palette „Bericht“ an.
Palette ausblenden
Blendet die Palette aus.
Warnungen löschen
Löscht die Registerkarte „Warnungen“.


Palettenmenü „Verfahren“

Das Palettenmenü „Verfahren“ zeigt Befehle zum Arbeiten mit der Palette „Verfahren“ an. Sie können dieses Menü durch Klicken auf die Palettenmenüschaltfläche aufrufen.
Hilfe
Öffnet die LiveCycle Designer-Hilfe und zeigt eine Beschreibung der Palette „Verfahren“ an.
Palette ausblenden
Blendet die Palette aus.


Werkzeugleisten

Informationen zu Werkzeugleisten
Werkzeugleiste „Standard“
Schaltfläche „Textformatierung“
Werkzeugleiste „Layout“
Werkzeugleiste „Tabelle“
Werkzeugleiste „Extras“


Informationen zu Werkzeugleisten

Werkzeugleisten enthalten Schaltflächen für häufig verwendete Befehle. Die folgenden Werkzeugleisten (Symbolleisten) werden mit LiveCycle Designer installiert:
      •
      Standard
      •
      Textformatierung
      •
      Layout
      •
      Tabelle
      •
      Extras
Sie können die Werkzeugleisten ändern oder neue Werkzeugleisten entsprechend Ihren Anforderungen erstellen.
Verwandte Themen
Werkzeugleisten anpassen
Werkzeugleiste „Standard“
Schaltfläche „Textformatierung“
Werkzeugleiste „Layout“
Werkzeugleiste „Tabelle“
Werkzeugleiste „Extras“


Werkzeugleiste „Standard“

Die Werkzeugleiste „Standard“ bietet schnellen Zugriff auf häufig verwendete Befehle in LiveCycle Designer.
Neu
Öffnet einen neuen Formularentwurf.
Öffnen
Öffnet einen vorhandenen Formularentwurf.
Speichern
Speichert den Inhalt des aktiven Formularentwurfs.
Drucken
Druckt den Inhalt der aktiven Registerkarte „Designansicht“ oder „Masterseiten“ im Layout-Editor.
Rückgängig
Macht bis zu 10 vorangegangene Aktionen rückgängig.
Wiederholen
Wendet bis zu 10 rückgängig gemachte Aktionen eine nach der anderen wieder an.
Suchen
Sucht jedes Auftreten eines bestimmten Worts oder einer Zeichenfolge auf der Registerkarte „XML-Quelle“ oder im Skript-Editor.
Raster einblenden
Blendet das Raster ein oder aus.
Am Raster ausrichten
Aktiviert oder deaktiviert die Option „Am Raster ausrichten“ Wenn die Option aktiviert ist, wird das gezeichnete bzw. gezogene Objekt am nächsten Rasterpunkt ausgerichtet.
Zeichenwerkzeug beibehalten
Bei Auswahl dieser Schaltfläche können Sie so viele Kopien eines Objekts wie nötig zeichnen, ohne das Objekt jedes Mal wieder in der Palette „Bibliothek“ auswählen zu müssen. Um diese Funktion zu deaktivieren, klicken Sie erneut auf „Zeichenwerkzeug beibehalten“.
Tatsächliche Größe
Bringt die Seite auf die tatsächliche Größe (100%).
An Seite anpassen
Passt die Größe der Seite entsprechend dem Layout-Editor an.
Fensterbreite
Passt die Größe der Seite entsprechend der Breite des Layout-Editors an.
Verkleinern
Verkleinert, damit ein größerer Bereich angezeigt werden kann.
Zoom
Vergrößert zur Anzeige von Details bzw. verkleinert zur Anzeige eines größeren Bereichs.
Vergrößern
Vergrößert, um Details anzuzeigen.
Palette „Verfahren“
Blendet die Palette „Verfahren“ ein oder aus.
Rechtschreibprüfung
Prüft die Rechtschreibung des gesamten aktuellen Dokuments oder eines Teils des aktuellen Dokuments.


Schaltfläche „Textformatierung“

Die Schaltfläche „Textformatierung“ bietet schnellen Zugriff auf allgemeine Befehle zur Text- und Absatzformatierung.
Schrift
Zeigt den Schriftnamen für den ausgewählten Text an.
Schriftgrad
Zeigt die Schriftgröße für den ausgewählten Text an.
Fett
Wendet die Formatierung „Fett“ auf den ausgewählten Text an bzw. entfernt sie.
Kursiv
Wendet die Formatierung „Kursiv“ auf den ausgewählten Text an bzw. entfernt sie.
Unterstreichen
Wendet die Formatierung „Unterstreichen“ auf den ausgewählten Text an bzw. entfernt sie.
Linksbündig
Richtet Text linksbündig aus.
Zentrieren
Richtet Text zentriert aus.
Rechtsbündig
Richtet Text rechtsbündig aus.
Blocksatz
Richtet den Text im Blocksatz aus.


Werkzeugleiste „Layout“

Die Werkzeugleiste „Layout“ bietet schnellen Zugriff auf allgemeine Befehle zur Layout-Formatierung.
Linksbündig
Richtet die linken Ränder der ausgewählten Objekte aus.
Rechtsbündig
Richtet die rechten Ränder der ausgewählten Objekte aus.
Oben ausrichten
Richtet die oberen Ränder der ausgewählten Objekte aus.
Unten ausrichten
Richtet die unteren Ränder der ausgewählten Objekte aus.
Vertikal zentriert
Richtet die vertikalen Mittelpunkte der ausgewählten Objekte aus.
Horizontal zentriert
Richtet die horizontalen Mittelpunkte der ausgewählten Objekte aus.
Gleichmäßig horizontal verteilen
Verteilt die ausgewählten Objekte gleichmäßig horizontal.
Gleichmäßig vertikal verteilen
Verteilt die ausgewählten Objekte gleichmäßig vertikal.
In Zeilen und Spalten gleichmäßig verteilen
Richtet die ausgewählten Objekte aus und verteilt sie gleichmäßig in Zeilen und Spalten.
In den Vordergrund
Verschiebt die ausgewählten Objekte in den Vordergrund.
In den Hintergrund
Verschiebt die ausgewählten Objekte in den Hintergrund.
Eine Ebene nach vorne
Verschiebt ausgewählte Objekte relativ zu anderen Objekten, die vor den ausgewählten Objekten liegen, weiter nach vorne.
Eine Ebene nach hinten
Verschiebt ausgewählte Objekte relativ zu anderen Objekten, die hinter den ausgewählten Objekten liegen, weiter nach hinten.
Gruppieren
Verbindet mehrere ausgewählte Objekte, so dass sie als eine Einheit verwendet werden. Eine Gruppe von Objekten kann eine beliebige Anzahl von Objekten enthalten und beliebig tief verschachtelt werden.
Gruppierung aufheben
Bricht ein gruppiertes Objekt in mehrere separate Einheiten auf.
Zusammenführen
Wenn zwei oder mehr Textobjekte ausgewählt sind, werden die Objekte in ein einziges Objekt zusammengeführt. Wenn ein oder mehr Optionsfelder ausgewählt sind, wird eine neue Ausschlussgruppe mit den ausgewählten Optionsfeldern erstellt.


Werkzeugleiste „Tabelle“

Die Werkzeugleiste „Tabelle“ bietet schnellen Zugriff auf häufig verwendete Tabellenbefehle.
Tabelle einfügen
Öffnet das Dialogfeld „Tabelle einfügen“.
Zeile unten einfügen
Fügt unterhalb der ausgewählten Zellen oder Zeilen eine oder mehrere Zeilen ein. Dabei entspricht die Anzahl der eingefügten Zeilen derjenigen der ausgewählten Zeilen.
Spalte rechts einfügen
Fügt rechts neben der äußersten rechten ausgewählten Spalte eine oder mehrere Spalten ein. Dabei entspricht die Anzahl der eingefügten Spalten derjenigen der ausgewählten Spalten.
Zellen zusammenführen
Fügt zwei oder mehr nebeneinander liegende Zellen in derselben Zeile zu einer einzigen Zelle zusammen.
Zelle horizontal teilen
Teilt zwei oder mehr zusammengeführte Zellen in einer Zeile in separate Zellen.
Zeile löschen
Löscht alle Zeilen mit ausgewählten Zellen.
Spalte löschen
Löscht alle Spalten mit ausgewählten Zellen.
In Tabelle konvertieren
Wandelt ein oder mehrere ausgewählte Objekte in eine Tabelle um.


Werkzeugleiste „Extras“

Die Werkzeugleiste „Extras“ bietet schnellen Zugriff auf allgemeine Werkzeuge.
Auswahl-Werkzeug
Wählt das Objekt aus.
Hand-Werkzeug
Verschiebt die Seite, damit Sie alle Bereiche anzeigen können. Eine LiveCycle Designer-Seite mit dem Hand-Werkzeug zu verschieben ist vergleichbar mit dem Verschieben eines echten Blatt Papiers auf dem Schreibtisch.
Felder zeichnen
Ändert den Objekttyp.
Zoom-Werkzeug
Vergrößert, um Details anzuzeigen.
Tab-Reihenfolge
Zeigt die aktuelle Tab-Reihenfolge an.


Dialogfeld-Referenz

Dialogfeld „Bindungseigenschaften“
Dialogfeld „Rechtschreibprüfung“
Dialogfeld „Sammlungseditor“
Dialogfeld „Sammlungsliste“
Dialogfeld „Verbindungseigenschaften“
Dialogfeld „Anpassen“
Dialogfeld „Datenanzeigeoptionen“
Dialogfeld „Dokumentunterschrifts-Einstellungen“
Dialogfeld „Dynamische Eigenschaften“
Dialogfeld „Bedingte Umbrüche bearbeiten“
Dialogfeld „Datenteilformulare bearbeiten“
Dialogfeld „Wörterbuch bearbeiten“
Dialogfeld „Datei-Import-Optionen“ (Microsoft InfoPath und Word)
Dialogfeld „Formulareigenschaften“
Dialogfeld „Importoptionen“
Dialogfeld „Tabelle einfügen“
Dialogfeld „Tastaturbefehle“
Dialogfeld „Fehlende Schriften“
Dialogfeld „Schriftersetzungen ändern“
Dialogfeld „Neue Datenverbindung“
Dialogfeld „Neu“
Dialogfeld „Öffnen“
Dialogfeld „Optionen“
Dialogfeld „Drucken“
Dialogfeld „In Repository veröffentlichen“
Dialogfeld „Speichern unter“
Dialogfeld „Daten unterschreiben und Einstellungen senden“
Dialogfeld „Ersatzschrift festlegen“
Dialogfeld „Syntaxformatierung“
Dialogfeld „Tabellenassistent“
Dialogfeld „Vorlagen-Manager“
Dialogfeld „Vorlagenoptionen“


Dialogfeld „Bindungseigenschaften“

Verwenden Sie dieses Dialogfeld zur Änderung der Objekteigenschaften eines Formulars, wenn Sie eine Datenverbindung einem vorhandenen Feld im Formularentwurf zuordnen. Sie können eine Datenverbindung einem Formularobjekt zuordnen, indem Sie einen Knoten von der Palette „Datenansicht“ auf das Objekt ziehen oder indem Sie die Registerkarte „Bindung“ in der Palette „Objekt“ verwenden. Siehe So erstellen Sie ein gebundenes Feld oder Teilformular.
Dieses Dialogfeld wird nur für Formularobjekte angezeigt, die Datenbindung unterstützen. Beachten Sie, dass dieses Dialogfeld bei der Einstellung der Bindung von Optionsfeldobjekten nicht angezeigt wird.
Ziehen Sie zum Anzeigen dieses Dialogfeldes oder wenn Sie mit Hilfe der Registerkarte „Bindung“ in der Palette „Objekt“ den Verbindungsknoten angeben einen Knoten aus der Palette „Datenansicht“ in ein bereits auf dem Formularentwurf vorhandenes Feld.
Alle verwandten Eigenschaften aktualisieren
Passt alle möglichen Eigenschaften des Formularobjekts an die Eigenschaften des Bindungsobjekts an.
Wenn der Formularobjekttyp sich vom Bindungstyp unterscheidet und Sie „Alle verwandten Eigenschaften aktualisieren“ wählen, wird der Formularobjekttyp an den Bindungstyp angepasst. Wenn zum Beispiel das Formularobjekt ein Textfeld und das Bindungsobjekt ein numerisches Feld ist, ändert die Auswahl von „Alle verwandten Eigenschaften aktualisieren“ das Formularobjekt in ein numerisches Feld. Um zu kontrollieren, ob der Objekttyp geändert wird, verwenden Sie die Option „Nur folgende Eigenschaften aktualisieren“.
Nur folgende Eigenschaften aktualisieren
Zeigt eine Liste aller möglichen Eigenschaften des Formularobjekts an, die durch die Eigenschaften eines Bindungsobjekts aktualisiert werden können. Sie können die Funktionen, die Sie aktualisieren wollen, auswählen. Die Annahme aller Optionen führt zum gleichen Ergebnis wie „Alle verwandten Eigenschaften aktualisieren“.
Die Liste der angezeigten Eigenschaften variiert je nach der Kombination von Formularobjekttyp und Bindung. Wenn Formularobjekt und Bindungsobjekt identisch sind, kann die folgende Liste aktualisierbarer Eigenschaften angezeigt werden:
      •
      Name
      •
      Beschriftung
      •
      Beschreibende Informationen
      •
      Vorkommen
      •
      Überprüfungsskripten
Die Eigenschaften „Name“ und „Beschriftung“ werden immer angezeigt. Die anderen Eigenschaften variieren, je nachdem, was für das Formularobjekt und für die Bindung sinnvoll ist. Wenn zum Beispiel die Bindung über Informationen zu Überprüfungsskripten verfügt, wird die Option „Überprüfungsskripten“ angezeigt.
Je nach Kombination von Formularobjekt und Bindung zeigt LiveCycle Designer auch auf den Typ des Objekts bezogene Optionen an. Die folgende Liste vom Typ abhängiger Optionen kann als Liste aktualisierbarer Eigenschaften angezeigt werden:
      •
      Datenmuster (nur bei Textfeldern und Datums-/Uhrzeitfeldern)
      •
      Standardwert (alle Felder mit Ausnahme von Bildfeldern)
      •
      Bild-URL (nur Bildfelder)
      •
      Listenelemente (nur Dropdown-Listen)
      •
      Max. Zeichen (nur Textfelder)
Wenn der Formularobjekttyp und der Bindungsobjekttyp identisch sind, zeigt LiveCycle Designer die vom Typ abhängigen Eigenschaften zusammen mit den übrigen oben genannten Eigenschaften an. Falls der Formularobjekttyp und der Bindungsobjekttyp jedoch verschieden sind, zeigt LiveCycle Designer die Option „Typ“ gefolgt von den typabhängigen Eigenschaften an. In diesem Fall muss die Option „Typ“ ausgewählt werden, um die vom Typ abhängigen Eigenschaften zu aktualisieren. Wenn Sie die Option „Typ“ nicht auswählen, wird keine der vom Typ abhängigen Eigenschaften aktualisiert.
Wenn Sie den Formularobjekttyp nicht ändern wollen, deaktivieren Sie die Option „Typ“.
Keine verwandten Eigenschaften aktualisieren
Es werden keine weiteren Eigenschaften des Objekts, außer der Bindung selbst, geändert.
Nicht mehr anzeigen
Bei Auswahl dieser Option wird das Dialogfeld „Bindungseigenschaften“ nicht mehr angezeigt, wenn Sie einen Knoten aus der Palette „Datenansicht“ in den Layout-Editor ziehen.
Keine der Objekteigenschaften wird aktualisiert und den Eigenschaften des Datenelements in der Datenquelle angepasst.
Um die Deaktivierung des Dialogfeldes wieder aufzuheben, klicken Sie mit der rechten Maustaste auf die Palette „Datenansicht“, wählen den Eintrag „Optionen“ aus und aktivieren dann das Kontrollkästchen „Dialogfeld „Bindungseigenschaften“ anzeigen“.
Verwandte Themen
Info über das Binden von Feldern an eine Datenquelle


Dialogfeld „Rechtschreibprüfung“

Verwenden Sie dieses Dialogfeld, um einzelne oder alle falsch geschriebenen Wörter in ausgewählten Objekten oder im ganzen Formular zu korrigieren, Wörter zu Ihrem benutzerdefinierten Wörterbuch hinzuzufügen, eine Liste zu ignorierender Wörter zu erstellen und das Fenster „Rechtschreibung“ im Dialogfeld „Optionen“ zu öffnen.
Standardmäßig überprüft LiveCycle Designer die Rechtschreibung im gesamten Text, der mit den verschiedenen Objekten in einem Formular verknüpft ist , wie z. B. statischem Text, Kopfzeilen, QuickInfo, Texten aus benutzerdefinierten Bildschirmlesehilfen und Listenfeldeinträgen. Um den Texttyp zu kontrollieren, den LiveCycle Designer prüft, können Sie Optionen in der Liste „Rechtschreibprüfung“ im Fenster „Rechtschreibung“ im Dialogfeld „Optionen“ auswählen. Weitere Informationen finden Sie unter Rechtschreibung (Dialogfeld „Optionen“).
Um dieses Dialogfeld anzuzeigen, wählen Sie unter „Extras“ die Option „Rechtschreibprüfung“ aus.
Nicht im Wörterbuch
Zeigt falsch geschriebene Wörter im Kontext an. Wenn beispielsweise der Text für eine QuickInfo ein falsch geschriebenes Wort enthält, wird der gesamte Text der QuickInfo angezeigt und das falsch geschriebene Wort markiert (fett und rot). Sie können Korrekturen direkt in dieses Feld eingeben. Wenn Sie den Text in diesem Feld korrigieren, wird die fette, rote Markierung von dem falsch geschriebenen Wort entfernt und die Schaltflächen „Einmal ignorieren“, „Alle ignorieren“, „Zum Wörterbuch hinzufügen“, „Alle ändern“ und „Rückgängig“ sind nicht verfügbar.
Gefunden in
Zeigt die Referenz-Syntax an, die das Objekt beschreibt, an dem Sie die Rechtschreibprüfung durchführen.
Vorschläge
Eine Liste mit Rechtschreibvorschlägen für das markierte Wort.
Einmal ignorieren
Ignoriert dieses falsch geschriebene Wort. LiveCycle Designer markiert jedes nachfolgende der auf die gleiche Weise falsch geschriebenen Wörter.
Alle ignorieren
Ignoriert alle auf dieselbe Weise falsch geschriebenen Wörter. Fügt das Wort zur Liste mit den zu ignorierenden Wörtern hinzu, damit LiveCycle Designer das Wort vorübergehend nicht als falsch geschrieben erkennt. Alle Rechtschreibprüfungen werden das Wort ignorieren, bis Sie LiveCycle Designer erneut starten. Die Liste mit zu ignorierenden Wörtern wird beim Starten von LiveCycle Designer jedes Mal gelöscht.
Zum Wörterbuch hinzufügen
Fügt das markierte Wort zu allen Sprachen unter „Mein benutzerdefiniertes Wörterbuch“ hinzu. LiveCycle Designer erkennt das Wort dann nicht mehr als falsch geschrieben.
Ändern
Ersetzt das falsch geschriebene (markierte) Wort durch das Wort, das in der Liste der Korrekturvorschläge ausgewählt oder im Feld „Nicht im Wörterbuch“ eingegeben ist.
Alle ändern
Ersetzt alle falsch geschriebenen (markierten) Wörter durch das Wort, das in der Liste der Korrekturvorschläge ausgewählt ist.
Rückgängig:
Macht vorangegangene Änderungen rückgängig.
Optionen
Öffnet das Fenster „Rechtschreibung“ im Dialogfeld „Optionen“. Alle Änderungen, die Sie im Fenster „Rechtschreibung“ vornehmen, werden umgehend übernommen und bei der laufenden Rechtschreibprüfung angewandt. Wenn Sie beispielsweise das Kontrollkästchen „QuickInfo“ in der Liste „Rechtschreibprüfung“ löschen, überprüft LiveCycle Designer keinen QuickInfo-Text.
Schließen
Schließt das Dialogfeld „Rechtschreibprüfung“.


Dialogfeld „Sammlungseditor“

Verwenden Sie dieses Dialogfeld, um die Objekte für die Sammlung der Dokumentunterschriftsfelder oder Papierformular-Barcodes auszuwählen.
Klicken Sie zum Anzeigen dieses Dialogfeldes (bei ausgewähltem Objekt „Papierformular-Barcode“) in der Palette „Objekt“ auf der Registerkarte „Wert“ auf die Schaltfläche „Ändern“.
Name
Zeigt den Namen der ausgewählten Sammlung an.
Sammlungstyp
Gibt den Typ der Sammlung an, die Sie bearbeiten. Die beiden verfügbaren Sammlungstypen sind „Dokumentunterschrift“ und „Papierformular-Barcode“.
Die Liste zeigt die Objekte in einer hierarchischen Struktur an. Sie können die Objekte in die Sammlung aufnehmen oder davon ausschließen.
Nicht unterstützte Nodes ausblenden
Blendet die Objekte aus, die für die ausgewählte Sammlung nicht unterstützt werden. Durch Ausblenden der nicht unterstützten Nodes finden Sie die Objekte leichter, die Sie in die Sammlung aufnehmen möchten.
Verwandte Themen
So fügen Sie ein Dokumentunterschriftsfeld hinzu
Eigenschaften von Dokumentunterschriftsfeldern: Registerkarte „Dokumentunterschrift“
Eigenschaften von Barcodes: Registerkarte „Feld“
So steuern Sie die Datenzuweisung für einen Barcode
Info über Formularobjektsammlungen


Dialogfeld „Sammlungsliste“

Verwenden Sie dieses Dialogfeld, um Sammlungen von Objekten für Dokumentunterschriftsfelder und Papierformular-Barcodes zu erstellen, zu duplizieren, zu löschen, zu verwalten und zu ändern.
Klicken Sie zum Anzeigen dieses Dialogfeldes auf „Datei“ > „Formularobjektsammlungen“.
Sammlungen
Zeigt eine Liste der Sammlungen für Dokumentunterschriftsfelder und Papierformular-Barcodes an. Eine Sammlung gilt entweder für Dokumentunterschriftsfelder oder für Papierformular-Barcodes und nicht für beides, weil diese beiden Typen unterschiedliche Arten von Objekten verwenden. Die Sammlungen, die für Dokumentunterschriftsfelder verfügbar sind, werden in der Palette „Objekt“ auf der Registerkarte „Dokumentunterschrift“ angezeigt. Die Sammlungen, die für Papierformular-Barcodes verfügbar sind, werden in der Palette „Objekt“ auf der Registerkarte „Wert“ angezeigt.
Neu
Erstellt eine neue Sammlung und fügt sie am Ende der Sammlungsliste ein.
Duplizieren
Erstellt eine Kopie der ausgewählten Sammlung in der Sammlungsliste.
Nach oben
Verschiebt die ausgewählte Sammlung in der Sammlungsliste nach oben.
Nach unten
Verschiebt die ausgewählte Sammlung in der Sammlungsliste nach unten.
Ändern
Öffnet das Dialogfeld „Sammlungseditor“, in dem Sie die Liste der in der Sammlung enthaltenen Objekte ändern können.
Verwandte Themen
So fügen Sie ein Dokumentunterschriftsfeld hinzu
Eigenschaften von Dokumentunterschriftsfeldern: Registerkarte „Dokumentunterschrift“
Eigenschaften von Barcodes: Registerkarte „Feld“
So steuern Sie die Datenzuweisung für einen Barcode
Info über Formularobjektsammlungen


Dialogfeld „Verbindungseigenschaften“

Verwenden Sie dieses Dialogfeld, um den Namen der ausgewählten Datenverbindung zu ändern.
Um dieses Dialogfeld anzuzeigen, wählen Sie eine Datenverbindung und klicken dann auf „Verbindungseigenschaften“ im Palettenmenü „Datenansicht“.
Verbindungsname
Zeigt den Verbindungsnamen der Datenquelle an. Sie können in diesem Feld den Namen der Datenverbindung ändern.
Verwandte Themen
Datenquellen
So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei
So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank
So erstellen Sie eine Datenverbindung zu einer WSDL-Datei


Dialogfeld „Anpassen“

Registerkarte „Befehle“ (Dialogfeld „Anpassen“)
Registerkarte „Werkzeugleisten“ (Dialogfeld „Anpassen“)


Registerkarte „Befehle“ (Dialogfeld „Anpassen“)

Verwenden Sie dieses Dialogfeld, um ein Menü oder eine Schaltfläche zu einer Symbolleiste (Werkzeugleiste) hinzuzufügen.
Um dieses Dialogfeld anzuzeigen, klicken Sie auf „Extras“ > „Werkzeugleisten anpassen“ und dann auf „Befehl“.
Kategorien
Zeigt eine Liste der Kategorien an, aus denen Sie Schaltflächen für eine Symbolleiste auswählen.
Schaltflächen
Zeigt die Schaltflächen an, die Sie für eine Symbolleiste auswählen können. Sie können diese Schaltflächen auf vorhandene Werkzeugleisten ziehen.
Verwandte Themen
Werkzeugleisten anpassen


Registerkarte „Werkzeugleisten“ (Dialogfeld „Anpassen“)

Verwenden Sie dieses Dialogfeld, um die in LiveCycle Designer angezeigten Werkzeugleisten (Symbolleisten) an Ihre Bedürfnisse anzupassen.
Um dieses Dialogfeld anzuzeigen, klicken Sie auf „Extras“ > „Werkzeugleisten anpassen“ und anschließend auf „Werkzeugleisten“.
Werkzeugleisten
Führt die in LiveCycle Designer verfügbaren Werkzeugleisten (Symbolleisten) auf.
QuickInfo anzeigen
Zeigt eine QuickInfo an, wenn Sie mit der Maus auf ein Symbol in der Symbolleiste zeigen.
3D-Darstellung
Ändert das Erscheinungsbild der Werkzeugleisten.
Große Schaltflächen
Zeigt große Schaltflächen in der Werkzeugleiste an.
Neu
Erzeugt eine neue benutzerdefinierte Werkzeugleiste.
Zurück
Setzt die Werkzeugleisten auf ihren Standardstatus zurück.
Verwandte Themen
Werkzeugleisten anpassen


Dialogfeld „Datenanzeigeoptionen“

Verwenden Sie dieses Dialogfeld, um die Optionen, die beim Erstellen eines Feldes oder einer Gruppe von Feldern mit dem Befehl „Felder generieren“ verwendet werden, festzulegen.
Wählen Sie zum Anzeigen dieses Dialogfeldes im Menü der Palette „Datenansicht“ den Eintrag „Optionen“.
Überprüfungsskripts generieren
Erstellt Überprüfungsskripten für neue Felder. Die generierten Überprüfungsskripten sind JavaScript-Skripten auf dem Feld. Beispielsweise kann ein Überprüfungsskript überprüfen, ob ein Feldwert zu der Liste der zulässigen Werte gehört.
Beschreibende Informationen generieren
Erzeugt beschreibende Informationen.
Tabellenerstellung zulassen
Es wird eine Tabelle erstellt, wenn Sie einen Tabellenknoten aus der Palette „Datenansicht“ in den Layout-Editor ziehen. Wenn Sie diese Option deaktivieren, werden in LiveCycle Designer verschachtelte, nicht fest positionierte und positionierte Teilformulare erstellt.
Immer Kopfzeile für Tabellen erstellen
Jede Tabelle wird mit Kopfzeile erstellt.
Dialogfeld „Bindungseigenschaften“ anzeigen
Bei Auswahl dieser Option wird das Dialogfeld „Bindungseigenschaften“ angezeigt, wenn Sie einen Knoten aus der Palette „Datenansicht“ in den Layout-Editor ziehen.
Wenn Sie diese Option deaktivieren, werden keine Objekteigenschaften aktualisiert und den Eigenschaften des Datenelements in der Datenquelle angepasst, wenn Sie einen Knoten aus der Palette „Datenansicht“ in den Layout-Editor ziehen.
Verwandte Themen
So legen Sie Feldgenerierungsoptionen fest


Dialogfeld „Dokumentunterschrifts-Einstellungen“

Registerkarte „Aussteller und Richtlinien“ (Dialogfeld „Dokumentunterschrifts-Einstellungen“/„Daten unterschreiben und Einstellungen senden“)
Registerkarte „Roaming-ID“ (Dialogfeld „Dokumentunterschrifts-Einstellungen“/„Daten unterschreiben und Einstellungen senden“)
Registerkarte „Unterschriften-Handler“ (Dialogfeld „Dokumentunterschrifts-Einstellungen“/„Daten unterschreiben und Einstellungen senden“)
Registerkarte „Info zur Unterschrift“ (Dialogfeld „Dokumentunterschrifts-Einstellungen“/„Daten unterschreiben und Einstellungen senden“)
Registerkarte „Unterschriftsrzertifikate“ (Dialogfeld „Dokumentunterschrifts-Einstellungen“/„Daten unterschreiben und Einstellungen senden“)
Registerkarte „Gründe für Unterschrift“ (Dialogfeld „Dokumentunterschrifts-Einstellungen“)


Zurück Weiter

Menü, Befehl, Werkzeugleiste und Dialogfeld Referenz > Dialogfeld-Referenz > Dialogfeld „Dokumentunterschrifts-Einstellungen“ > Registerkarte „Aussteller und Richtlinien“ (Dialogfeld „Dokumentunterschrifts-Einstellungen“/„Daten unterschreiben und Einstellungen senden“)

Registerkarte „Aussteller und Richtlinien“ (Dialogfeld „Dokumentunterschrifts-Einstellungen“/„Daten unterschreiben und Einstellungen senden“)

Auf dieser Registerkarte können Sie die Zertifikataussteller, einen Zertifikatregistrierungsserver und Zertifikatsrichtlinien angeben.
Führen Sie zum Anzeigen dieser Registerkarte einen der folgenden Schritte aus:
      •
      Wählen Sie ein Dokumentunterschriftsfeld aus, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Dokumentunterschrift“, klicken Sie auf „Einstellungen“ und anschließend auf die Registerkarte „Aussteller und Richtlinien“.
      •
      Wählen Sie eine Senden-Schaltfläche aus, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Senden“, stellen Sie sicher, dass die Option „Sendung unterschreiben“ ausgewählt ist, klicken Sie auf „Einstellungen“ und anschließend auf die Registerkarte „Aussteller und Richtlinien“.
      •
      Wählen Sie eine E-Mail- oder HTTP-Senden-Schaltfläche aus, stellen Sie sicher, dass in der Palette „Objekt“ die Option „Sendung unterschreiben“ ausgewählt ist, klicken Sie auf „Einstellungen“ und anschließend auf die Registerkarte „Aussteller und Richtlinien“.
Zertifikataussteller
Zeigt eine Liste der Zertifikate an, die die Aussteller identifizieren, die Signaturzertifikate für Unterzeichner zur Verfügung stellen:
    • Hinzufügen
Öffnet das Dialogfeld „Zertifikat des Ausstellers auswählen“, in dem Sie nach Zertifikaten des Ausstellers suchen und diese hinzufügen können. Zertifikatdateien haben Dateinamenerweiterungen, wie z. B. .p7c, .p7b oder .cer.
    • Entfernen
Entfernt die ausgewählten Zertifikate aus der Liste.
    • Detail
Öffnet die Zertifikatanzeige, in der Sie die Details zum ausgewählten Zertifikat anzeigen können. Die angezeigten Details sind je nach Betriebssystem und installierten Zertifizierungsstellen-Zertifikaten unterschiedlich.
    • Unterzeichnung auf Zertifikate von den festgelegten Ausstellern begrenzen
Acrobat weist die Unterschrift zurück, wenn der Unterzeichner kein Zertifikat von einem festgelegten Aussteller besitzt.
URL für Zertifikatregistrierungsserver
Gibt die URL für eine Webseite an, auf der sich Personen für ein Zertifikat registrieren können. Diese Webseite wird angezeigt, wenn für einen Unterzeichner kein Signaturzertifikat verfügbar ist.
Zertifikatregistrierung auf angegebenen URL-Server beschränken
Zwingt den Unterzeichner dazu, ein Signaturzertifikat vom angegebenen Registrierungsserver zu erwerben.
Objektkennungen
Zeigt eine Liste der mit den Zertifikatsrichtlinien verknüpften Objektkennungen (OID, Object Identifier) an, die die Zertifikate beschränken, die zum Unterschreiben der Dokumente oder Daten verwendet werden können.
Hinzufügen
Fügt eine Objektkennung hinzu.
Löschen
Löscht die ausgewählte Objektkennung.
Unterzeichnung auf Zertifikate begrenzen, die den angegebenen Richtlinien entsprechen
Acrobat weist die Unterschrift zurück, wenn das Signaturzertifikat nicht den angegebenen Richtlinien entspricht.
Verwandte Themen
Dokumentunterschriftsfelder verwenden
E-Mail-Senden-Schaltflächen – Übersicht
HTTP-Senden-Schaltflächen – Übersicht
Info über das Senden von Daten mit Hilfe einer Schaltfläche
So fügen Sie ein Dokumentunterschriftsfeld hinzu
So fügen Sie eine Datenunterschrift zu einer Senden-Schaltfläche hinzu


Zurück Weiter

Menü, Befehl, Werkzeugleiste und Dialogfeld Referenz > Dialogfeld-Referenz > Dialogfeld „Dokumentunterschrifts-Einstellungen“ > Registerkarte „Roaming-ID“ (Dialogfeld „Dokumentunterschrifts-Einstellungen“/„Daten unterschreiben und Einstellungen senden“)

Registerkarte „Roaming-ID“ (Dialogfeld „Dokumentunterschrifts-Einstellungen“/„Daten unterschreiben und Einstellungen senden“)

Auf dieser Registerkarte können Sie einen Webserver angeben, auf dem die digitalen Unterzeichnungsberechtigungen gespeichert sind, die zum Unterschreiben der Dokumente oder Daten verwendet werden.
Führen Sie zum Anzeigen dieser Registerkarte einen der folgenden Schritte aus:
      •
      Wählen Sie ein Dokumentunterschriftsfeld aus, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Dokumentunterschrift“, klicken Sie auf „Einstellungen“ und anschließend auf die Registerkarte „Roaming-ID“.
      •
      Wählen Sie eine Senden-Schaltfläche aus, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Senden“, stellen Sie sicher, dass die Option „Sendung unterschreiben“ ausgewählt ist, klicken Sie auf „Einstellungen“ und anschließend auf die Registerkarte „Roaming-ID“.
      •
      Wählen Sie eine E-Mail- oder HTTP-Senden-Schaltfläche aus, stellen Sie sicher, dass in der Palette „Objekt“ die Option „Sendung unterschreiben“ ausgewählt ist, klicken Sie auf „Einstellungen“ und anschließend auf die Registerkarte „Roaming-ID“.
URL des Unterschriftservers
Verweist auf einen Webdienst, auf dem die digitalen Unterzeichnungsberechtigungen gespeichert sind, die ein Unterzeichner zum Unterschreiben von Dokumenten oder Daten verwendet.
Unterzeichnung auf angegebenen URL-Server beschränken
Zwingt Acrobat dazu, auf dem angegebenen Server nach den Unterzeichnungsberechtigungen zu suchen. Wenn diese Option nicht aktiviert ist, wird der Server nur vorgeschlagen. Daher kann Acrobat auf anderen Webdiensten nach den Unterzeichnungsberechtigungen suchen.
Verwandte Themen
Dokumentunterschriftsfelder verwenden
E-Mail-Senden-Schaltflächen – Übersicht
HTTP-Senden-Schaltflächen – Übersicht
Info über das Senden von Daten mit Hilfe einer Schaltfläche
So fügen Sie ein Dokumentunterschriftsfeld hinzu
So fügen Sie eine Datenunterschrift zu einer Senden-Schaltfläche hinzu


Zurück Weiter

Menü, Befehl, Werkzeugleiste und Dialogfeld Referenz > Dialogfeld-Referenz > Dialogfeld „Dokumentunterschrifts-Einstellungen“ > Registerkarte „Unterschriften-Handler“ (Dialogfeld „Dokumentunterschrifts-Einstellungen“/„Daten unterschreiben und Einstellungen senden“)

Registerkarte „Unterschriften-Handler“ (Dialogfeld „Dokumentunterschrifts-Einstellungen“/„Daten unterschreiben und Einstellungen senden“)

Auf dieser Registerkarte können Sie einen optionalen Unterschriften-Handler für eine Dokumentunterschrift oder eine Datenunterschrift definieren, die mit einer Senden-Schaltfläche verknüpft ist. Ein Unterschriften-Handler ist ein Software-Modul, das den Verschlüsselungsvorgang mit öffentlichem Schlüssel implementiert und den Zugriff auf verschlüsselte Dokumente oder Daten steuert. Zu den Sicherheits-Handlern, die eine Verschlüsselung mit öffentlichem Schlüssel unterstützten, gehören beispielsweise Adobe.PPKLite, Adobe.PubSec und Entrust.PPKEF.
Führen Sie zum Anzeigen dieser Registerkarte einen der folgenden Schritte aus:
      •
      Wählen Sie ein Dokumentunterschriftsfeld aus, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Dokumentunterschrift“, klicken Sie auf „Einstellungen“ und anschließend auf die Registerkarte „Unterschriften-Handler“.
      •
      Wählen Sie eine Senden-Schaltfläche aus, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Senden“, stellen Sie sicher, dass die Option „Sendung unterschreiben“ ausgewählt ist, klicken Sie auf „Einstellungen“ und anschließend auf die Registerkarte „Unterschriften-Handler“.
      •
      Wählen Sie eine E-Mail- oder HTTP-Senden-Schaltfläche aus, stellen Sie sicher, dass in der Palette „Objekt“ die Option „Sendung unterschreiben“ ausgewählt ist, klicken Sie auf „Einstellungen“ und anschließend auf die Registerkarte „Unterschriften-Handler“.
Name
Zeigt eine Liste der Namen von Sicherheits-Handlern an. Sie können einen Namen in das Feld eingeben, wenn der von Ihnen gewünschte Sicherheits-Handler nicht in der Liste enthalten ist.
Version
Gibt die Mindestversionsnummer für den Sicherheits-Handler an. Statt eine Version auszuwählen, können Sie auch eine Zahl in das Feld eingeben. Wenn Sie AdobePPKLite als Unterschriften-Handler auswählen, ist die Version je nach der Version von Acrobat oder Adobe Reader, die zum Unterschreiben des Dokuments verwendet wird, auf 0, 1 und 2 begrenzt.

Acrobat- und Adobe Reader-Version

AdobePPKLite-Version
4.x und 5.x
0
6.x und 7.x
1
8.x
2
Unterzeichner muss den festgelegten Unterschriften-Handler verwenden
Zwingt Acrobat dazu, den angegebenen Sicherheits-Handler zum Erstellen und Überprüfen der digitalen Unterschrift zu verwenden. Wenn diese Option nicht aktiviert ist, wird der Sicherheits-Handler nur vorgeschlagen. Daher kann Acrobat den bevorzugten Sicherheits-Handler verwenden.
Verwandte Themen
Dokumentunterschriftsfelder verwenden
E-Mail-Senden-Schaltflächen – Übersicht
HTTP-Senden-Schaltflächen – Übersicht
Info über das Senden von Daten mit Hilfe einer Schaltfläche
So fügen Sie ein Dokumentunterschriftsfeld hinzu
So fügen Sie eine Datenunterschrift zu einer Senden-Schaltfläche hinzu


Zurück Weiter

Menü, Befehl, Werkzeugleiste und Dialogfeld Referenz > Dialogfeld-Referenz > Dialogfeld „Dokumentunterschrifts-Einstellungen“ > Registerkarte „Info zur Unterschrift“ (Dialogfeld „Dokumentunterschrifts-Einstellungen“/„Daten unterschreiben und Einstellungen senden“)

Registerkarte „Info zur Unterschrift“ (Dialogfeld „Dokumentunterschrifts-Einstellungen“/„Daten unterschreiben und Einstellungen senden“)

Auf dieser Registerkarte können Sie eine Zertifikatssperrliste (Certificate Revocation List, CRL) oder eine OCSP-Antwort (Online Certificate Status Protocol) festlegen und einen Zeitstempelserver angeben.
Führen Sie zum Anzeigen dieser Registerkarte einen der folgenden Schritte aus:
      •
      Wählen Sie ein Dokumentunterschriftsfeld aus, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Dokumentunterschrift“, klicken Sie auf „Einstellungen“ und anschließend auf die Registerkarte „Info zur Unterschrift“.
      •
      Wählen Sie eine Senden-Schaltfläche aus, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Senden“, stellen Sie sicher, dass die Option „Sendung unterschreiben“ ausgewählt ist, klicken Sie auf „Einstellungen“ und anschließend auf die Registerkarte „Info zur Unterschrift“.
      •
      Wählen Sie eine E-Mail- oder HTTP-Senden-Schaltfläche aus, stellen Sie sicher, dass in der Palette „Objekt“ die Option „Sendung unterschreiben“ ausgewählt ist, klicken Sie auf „Einstellungen“ und anschließend auf die Registerkarte „Info zur Unterschrift“.
Zertifikatssperrliste oder OCSP-Antwort beim Unterschreiben einschließen
Schließt die Zertifikatssperrliste oder die OCSP-Antwort in die Unterschrift ein, wenn das Dokument oder die Daten unterschrieben werden. Der Unterzeichner muss über einen Internetzugang verfügen, um die Zertifikatssperrliste oder die OCSP-Antwort vom jeweiligen Server abzurufen.
    • Erforderlich
Das Einschließen der Zertifikatssperrliste oder OCSP-Antwort ist erforderlich.
    • Optional
Das Einschließen der Zertifikatssperrliste oder OCSP-Antwort ist optional.
URL des Zeitstempelservers
Diese Option wird nur für Dokumentunterschriftsfelder angezeigt. Gibt die URL für den Zeitstempelserver an. Zeitstempel geben das Datum und die Uhrzeit der Unterzeichnung eines Dokuments oder von Daten an. Durch die Verwendung eines externen Servers zum Hinzufügen eines Zeitstempels zu einer digitalen Unterschrift bleiben keine Zweifel hinsichtlich des Zeitpunkts der Dokument- oder Datenunterzeichnung.
Unterzeichner muss den festgelegten Zeitstempel-Server verwenden
Diese Option wird nur für Dokumentunterschriftsfelder angezeigt. Zwingt Acrobat dazu, beim Unterschreiben des Dokuments oder der Daten einen Zeitstempel zu einer digitalen Unterschrift hinzuzufügen.
Verwandte Themen
Dokumentunterschriftsfelder verwenden
E-Mail-Senden-Schaltflächen – Übersicht
HTTP-Senden-Schaltflächen – Übersicht
Info über das Senden von Daten mit Hilfe einer Schaltfläche
So fügen Sie ein Dokumentunterschriftsfeld hinzu
So fügen Sie eine Datenunterschrift zu einer Senden-Schaltfläche hinzu


Zurück Weiter

Menü, Befehl, Werkzeugleiste und Dialogfeld Referenz > Dialogfeld-Referenz > Dialogfeld „Dokumentunterschrifts-Einstellungen“ > Registerkarte „Unterschriftsrzertifikate“ (Dialogfeld „Dokumentunterschrifts-Einstellungen“/„Daten unterschreiben und Einstellungen senden“)

Registerkarte „Unterschriftsrzertifikate“ (Dialogfeld „Dokumentunterschrifts-Einstellungen“/„Daten unterschreiben und Einstellungen senden“)

Auf dieser Registerkarte können Sie Zertifikate angeben, die die Aussteller identifizieren, die das Dokument oder die Daten unterschreiben können.
Führen Sie zum Anzeigen dieser Registerkarte einen der folgenden Schritte aus:
      •
      Wählen Sie ein Dokumentunterschriftsfeld aus, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Dokumentunterschrift“, klicken Sie auf „Einstellungen“ und anschließend auf die Registerkarte „Unterschriftszertifikate“.
      •
      Wählen Sie eine Senden-Schaltfläche aus, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Senden“, stellen Sie sicher, dass die Option „Sendung unterschreiben“ ausgewählt ist, klicken Sie auf „Einstellungen“ und anschließend auf die Registerkarte „Unterschriftszertifikate“.
      •
      Wählen Sie eine E-Mail- oder HTTP-Senden-Schaltfläche aus, stellen Sie sicher, dass in der Palette „Objekt“ die Option „Sendung unterschreiben“ ausgewählt ist, klicken Sie auf „Einstellungen“ und anschließend auf die Registerkarte „Unterschriftszertifikate“.
Hinzufügen
Öffnet das Dialogfeld „Benutzerzertifikat auswählen“, in dem Sie nach Unterschriftszertifikaten suchen und diese hinzufügen können. Zertifikatdateien haben Dateinamenerweiterungen, wie z. B. .p7c, .p7b oder .cer.
Entfernen
Entfernt die ausgewählten Zertifikate aus der Liste.
Detail
Öffnet die Zertifikatanzeige, in der Sie die Details zum ausgewählten Zertifikat anzeigen können. Die angezeigten Details sind je nach Betriebssystem und installierten Zertifizierungsstellen-Zertifikaten unterschiedlich.
Unterzeichnung auf Personenkreise mit den angegebenen Zertifikaten begrenzen
Ermöglicht nur den Unterzeichnern, die von den aufgelisteten Zertifikaten identifiziert werden, das Unterschreiben des Dokuments oder der Daten.
Verwandte Themen
Dokumentunterschriftsfelder verwenden
E-Mail-Senden-Schaltflächen – Übersicht
HTTP-Senden-Schaltflächen – Übersicht
Info über das Senden von Daten mit Hilfe einer Schaltfläche
So fügen Sie ein Dokumentunterschriftsfeld hinzu
So fügen Sie eine Datenunterschrift zu einer Senden-Schaltfläche hinzu


Zurück Weiter

Menü, Befehl, Werkzeugleiste und Dialogfeld Referenz > Dialogfeld-Referenz > Dialogfeld „Dokumentunterschrifts-Einstellungen“ > Registerkarte „Gründe für Unterschrift“ (Dialogfeld „Dokumentunterschrifts-Einstellungen“)

Registerkarte „Gründe für Unterschrift“ (Dialogfeld „Dokumentunterschrifts-Einstellungen“)

Auf dieser Registerkarte können Sie Gründe für die Dokumentunterschriften angeben.
Zum Anzeigen dieser Registerkarte wählen Sie ein Dokumentunterschriftsfeld aus, klicken in der Palette „Objekt“ auf die Registerkarte „Dokumentunterschrift“, klicken auf „Einstellungen“ und anschließend auf die Registerkarte „Gründe für Unterschrift“.
Gründe für Unterschrift angeben
Die angegebenen Gründe ersetzen die Standardgründe von Acrobat. Der Unterzeichner kann beim Unterschreiben eines Formulars einen der Gründe auswählen.
    • Hinzufügen
Fügt einen Grund für die Unterschrift zur Liste hinzu.
    • Löschen
Entfernt die ausgewählten Gründe für die Unterschrift aus der Liste.
    • Nach oben
Verschiebt den ausgewählten Grund in der Liste nach oben.
    • Nach unten
Verschiebt den ausgewählten Grund in der Liste nach unten.
    • Aufsteigend sortieren
Sortiert die Liste von oben nach unten in alphabetischer Reihenfolge.
    • Absteigend sortieren
Sortiert die Liste von unten nach oben in alphabetischer Reihenfolge.
Unterzeichner muss in dieser Liste einen Grund auswählen
Zwingt den Unterzeichner dazu, beim Unterschreiben des Formulars einen Grund in der Liste auszuwählen. Wenn Sie eine Liste mit Gründen erstellen, die nicht als erforderlich markiert ist, sind die Gründe unter Umständen nicht für den Benutzer sichtbar, wenn er Acrobat oder Adobe Reader 8.0 oder höher verwendet.
Verwandte Themen
Dokumentunterschriftsfelder verwenden
So fügen Sie ein Dokumentunterschriftsfeld hinzu


Dialogfeld „Dynamische Eigenschaften“

Verwenden Sie dieses Dialogfeld, um die Eigenschaften von dynamischen Formularobjekten an Werte einer Datenquelle zu binden. Auf diese Weise ist es möglich, Formularobjekteigenschaften wie die Elemente einer Dropdown-Liste oder eines Listenfeldes dynamisch mit Werten der Datenquelle zu füllen.
Um dieses Dialogfeld anzuzeigen, müssen Sie die Option „Dynamische Eigenschaften anzeigen“ aktivieren, eine Formularobjekteigenschaft mit einer dynamischen Datenbindung auswählen und dann auf eine der folgenden dynamischen Beschriftungen klicken:
      •
      „Listenelemente“ und „Elementwerte festlegen“ bei Dropdown-Listen und Listenfeldern
      •
      Beschriftung
      •
      Überprüfungsmuster-Meldung
      •
      Überprüfungsskript-Meldung
      •
      QuickInfo
      •
      Benutzerdef. Bildschirmlesehilfen-Text
Datenverbindung
Gibt die Datenverbindung an, die für die dynamische Datenbindung verwendet werden soll. Falls noch keine Verbindung zu einer Datenquelle besteht, wird in diesem Listenfeld lediglich der Eintrag „ Standarddatenbindung „ angezeigt.
Wie bei der normalen Bindung können Sie eine oder mehrere WSDL-Verbindungsbindungen angeben.
Elemente
Gibt den Satz von Knoten an, der zum Füllen der Dropdown-Listen bzw. der Listenfelder verwendet wird.
Sie können „<Ohne>„ wählen, um die Bindung für die ausgewählte Eigenschaft aufzuheben. Alternativ können Sie auch direkt eine Zeichenfolge in das Feld eingeben.
Diese Option ist verfügbar, wenn Sie auf die dynamische Beschriftung „Listenelemente“ oder „Elementwerte festlegen“ für Dropdown-Listen oder Listenfelder klicken. Bei OLEDB-Datenverbindungen steht das Feld „Elemente“ nicht zur Verfügung. Verwenden Sie die Felder „Elementtext“ und „Elementwert“, um die Datenbasisspalten zum Füllen der Liste auszuwählen.
Elementtext
Gibt die zur Laufzeit angezeigte benutzerfreundliche Beschriftung an. Die hier verfügbaren Bindungen werden durch den im Feld „Elemente“ ausgewählten Satz von Knoten bestimmt.
Sie können „<Ohne>„ wählen, um die Bindung für die ausgewählte Eigenschaft aufzuheben. Alternativ können Sie auch direkt eine Zeichenfolge in das Feld eingeben.
Diese Option ist verfügbar, wenn Sie auf die dynamische Beschriftung „Listenelemente“ oder „Elementwerte festlegen“ für Dropdown-Listen oder Listenfelder klicken.
Elementwert
Gibt den an die Datenquelle gesendeten Datenwert an. Die hier verfügbaren Bindungen werden durch den im Feld „Elemente“ ausgewählten Satz von Knoten bestimmt. Die Angabe in diesem Feld ist optional. Wenn Sie das Feld leer lassen, wird der Objekttext an die Datenquelle gesendet.
Sie können „<Ohne>„ wählen, um die Bindung für die ausgewählte Eigenschaft aufzuheben. Alternativ können Sie auch direkt eine Zeichenfolge in das Feld eingeben.
Diese Option ist verfügbar, wenn Sie auf die dynamische Beschriftung „Listenelemente“ oder „Elementwerte festlegen“ für Dropdown-Listen oder Listenfelder klicken.
Bindung
Legt die Bindung für die ausgewählte Eigenschaft fest. Die verfügbaren Bindungen werden durch die ausgewählte Datenverbindung vorgegeben.
Sie können „<Ohne>„ wählen, um die Bindung für die ausgewählte Eigenschaft aufzuheben. Alternativ können Sie auch direkt eine Zeichenfolge in das Feld eingeben.
Diese Option ist verfügbar, wenn Sie auf die dynamischen Beschriftungen „Beschriftung“, „Überprüfungsmuster-Meldung“, „Überprüfungsskript-Meldung“, „QuickInfo“ und „Benutzerdef. Bildschirmlesehilfen-Text“ klicken.
Verwandte Themen
Info über dynamische Eigenschaften


Dialogfeld „Bedingte Umbrüche bearbeiten“

Verwenden Sie dieses Dialogfeld, um Anweisungen für bedingte Umbrüche für Teilformulare, Teilformularsätze, Tabellen, Kopfzeilen, Textzeilen und Abschnitte zu erstellen. Bedingte Umbrüche sind flexibler als herkömmliche Umbrüche und ermöglichen den mehrfachen Umbruch eines einzelnen Objekts.
Führen Sie zum Anzeigen dieses Dialogfeldes einen der folgenden Schritte aus:
      •
      Wählen Sie ein Teilformularobjekt aus und klicken Sie auf der Registerkarte „Paginierung“ in der Palette „Objekt“ auf „Bearbeiten“. Hinweis: Das ausgewählte Teilformular muss sich im Formularentwurf in einem nicht fest positionierten Teilformular (d. h. in einem Teilformular mit der Einstellung „Textfluss“) befinden.
      •
      Wählen Sie einen Teilformularsatz aus und klicken Sie auf der Registerkarte „Paginierung“ in der Palette „Objekt“ auf „Bearbeiten“.
      •
      Wählen Sie eine Tabelle aus und klicken Sie auf der Registerkarte „Paginierung“ in der Palette „Objekt“ auf „Bearbeiten“. Hinweis: Die ausgewählte Tabelle muss sich im Formularentwurf in einem nicht fest positionierten Teilformular (d. h. in einem Teilformular mit der Einstellung „Textfluss“) befinden.
      •
      Wählen Sie eine Tabellenkopfzeile aus und klicken Sie auf der Registerkarte „Paginierung“ in der Palette „Objekt“ auf „Bearbeiten“. Hinweis: Die zur Kopfzeile gehörige Tabelle muss sich im Formularentwurf in einem nicht fest positionierten Teilformular (d. h. in einem Teilformular mit der Einstellung „Textfluss“) befinden.
      •
      Wählen Sie eine Tabellentextzeile aus und klicken Sie auf der Registerkarte „Paginierung“ in der Palette „Objekt“ auf „Bearbeiten“. Hinweis: Die zur Textzeile gehörige Tabelle muss sich im Formularentwurf in einem nicht fest positionierten Teilformular (d. h. in einem Teilformular mit der Einstellung „Textfluss“) befinden.
      •
      Wählen Sie eine Tabellenfußzeile aus und klicken Sie auf der Registerkarte „Paginierung“ in der Palette „Objekt“ auf „Bearbeiten“. Hinweis: Die zur Fußzeile gehörige Tabelle muss sich im Formularentwurf in einem nicht fest positionierten Teilformular (d. h. in einem Teilformular mit der Einstellung „Textfluss“) befinden.
      •
      Wählen Sie einen Tabellenabschnitt aus und klicken Sie auf der Registerkarte „Paginierung“ in der Palette „Objekt“ auf „Bearbeiten“. Hinweis: Der ausgewählte Tabellenabschnitt muss sich im Formularentwurf in einem nicht fest positionierten Teilformular (d. h. in einem Teilformular mit der Einstellung „Textfluss“) befinden.
Hinzufügen
Fügt eine neue Umbruchbedingung für das aktuelle Objekt hinzu. Falls derzeit ein bedingter Umbruch ausgewählt ist, wird der neue Eintrag vor dem ausgewählten Eintrag angelegt.
Löschen
Entfernt die derzeit ausgewählte Umbruchbedingung für das Objekt.
Nach oben
Verschiebt den derzeit ausgewählten bedingten Umbruch in der Liste nach oben.
Nach unten
Verschiebt den derzeit ausgewählten bedingten Umbruch in der Liste nach unten.
Wenn
Gibt einen Ausdruck an, durch den festgelegt wird, wann der bedingte Umbruch eingefügt werden soll.
Verwenden Sie die Schaltfläche „Beispielausdruck einfügen“ [image], um ein gültiges Objekt als Umbruchbedingung auszuwählen. LiveCycle Designer fügt einen Beispielausdruck ein, durch den ein bedingter Umbruch erzwungen wird, wenn für ihn der Wert „true“ (wahr) zurückgegeben wird.
Die Schaltfläche „Beispielausdruck einfügen“ ist nur verfügbar, wenn der Formularentwurf gültige Objekte enthält.
Sprache
Legt fest, welche Skriptsprache Sie für die aktuelle Berechnung bzw. das aktuelle Skript verwenden möchten. Dabei gibt es zwei Möglichkeiten:
    • FormCalc
Eine von Adobe entwickelte Berechnungssprache, die für kürzere Skripten geeignet ist.
    • JavaScript
Eine leistungsstarke, flexible Skriptsprache für komplexere Skripten.
Ausführen am
Gibt an, wo die Berechnung bzw. das Skript ausgeführt werden soll. Drei Optionen stehen zur Verfügung:
    • Client
Berechnungen und Skripten werden ausgeführt, während die Clientanwendung (z. B. Acrobat oder der Webbrowser) das Formular verarbeitet.
    • Server
Berechnungen und Skripten werden ausgeführt, während die Server-Anwendung (z. B. LiveCycle Forms) das Formular verarbeitet.
    • Client und Server
Berechnungen und Skripten werden ausgeführt, während das Formular entweder von der Client- oder von der Serveranwendung verarbeitet wird, je nachdem, welche Anwendung das Formular verarbeitet.
Umbruch
Legt fest, wo der bedingte Umbruch eingefügt werden soll:
    • Vor
Unmittelbar vor dem aktuellen Teilformular, Teilformularsatz oder Abschnitt bzw. der aktuellen Tabelle, Kopfzeile, Fußzeile oder Textzeile.
    • Nach
Unmittelbar nach dem aktuellen Teilformular, Teilformularsatz oder Abschnitt bzw. der aktuellen Tabelle, Kopfzeile, Fußzeile oder Textzeile.
An
Legt fest, wo die übrigen Felder und Daten des umbrochenen Teilformulars nach dem bedingten Umbruch abgelegt werden:
    • Inhaltsbereich > [Name_des _Inhaltsbereichs]
Die Fortsetzung erfolgt im angegebenen Inhaltsbereich.
    • Anfang des nächsten Inhaltsbereichs
Die Fortsetzung erfolgt am Anfang des nächsten Inhaltsbereichs.
    • Anfang des Inhaltsbereichs > [Name_des _Inhaltsbereichs]
Die Fortsetzung erfolgt am Anfang des angegebenen Inhaltsbereichs.
    • Seite > [Name_der_Seite]
Die Fortsetzung erfolgt auf der angegebenen Seite (fügt einen Seitenumbruch ein, falls es sich hierbei nicht um die aktuelle Seite handelt).
    • Anfang der nächsten Seite
Die Fortsetzung erfolgt am Anfang der nächsten Seite (fügt einen Seitenumbruch ein).
    • Anfang der Seite > [Name_der_Seite]
Die Fortsetzung erfolgt am Anfang der Seite, sobald die angegebene Seite wiedergegeben wird (fügt einen Seitenumbruch ein, wenn dieser nicht automatisch vorgenommen wird).
    • Kein Umbruch, nur Kopf- und Fußbereich
Legen Sie das Objekt nach dem vorherigen Teilformular oder Teilformularsatz bzw. der Tabelle, Kopfzeile, Fußzeile oder Textzeile ab. Ein Wechsel in einen neuen Inhaltsbereich sollte nur erfolgen, wenn das Teilformular, der Teilformularsatz oder Abschnitt bzw. die Tabelle, Kopf-, Fuß- oder Textzeile nicht in den aktuellen Inhaltsbereich passt.
Fußbereich
Definiert einen Teilformularfußbereich zur Verwendung für den bedingten Umbruch.
    • [Name_des_Teilformulars/der_Tabelle]
Verwendet das vorhandene Teilformular, den vorhandenen Teilformularsatz oder die vorhandene Tabelle bzw. Kopf- oder Textzeile als Überlauffußbereich.
    • Ohne
Es wird kein Überlauffußbereich verwendet.
Kopfbereich
Definiert einen Teilformularkopfbereich zur Verwendung für den bedingten Umbruch.
    • [Name_des_Teilformulars/der_Tabelle]
Verwendet das vorhandene Teilformular, den vorhandenen Teilformularsatz oder die vorhandene Tabelle bzw. Kopf- oder Textzeile als Überlaufkopfbereich.
    • Ohne
Es wird kein Überlaufkopfbereich verwendet.
Verwandte Themen
Teilformulare – Übersicht
Teilformularsätze – Übersicht
Info über Tabellen
So erstellen Sie sich wiederholende Teilformulare
So steuern Sie Umbrüche in Teilformularen und Teilformularsätzen mit Hilfe von bedingten Anweisungen


Dialogfeld „Datenteilformulare bearbeiten“

Verwenden Sie dieses Dialogfeld, um die Anzeige von Teilformularen in einem Auswahl-Teilformularsatz bzw. von Zeilen in einem Auswahlabschnitt zu steuern.
Führen Sie zum Anzeigen dieses Dialogfeldes einen der folgenden Schritte aus:
      •
      Wählen Sie einen Auswahl-Teilformularsatz aus und klicken Sie auf der Registerkarte „Teilformularsatz“ der Palette „Objekt“ auf „Alternativen bearbeiten“.
      •
      Wählen Sie einen Auswahlabschnitt aus und klicken Sie auf der Registerkarte „Abschnitt“ der Palette „Objekt“ auf „Alternativen bearbeiten“.
Teilformular auswählen, dessen Name mit Datenelement oder Attribut übereinstimmt
Ordnet ein einzelnes Teilformular des Auswahl-Teilformularsatzes bzw. eine Zeile des Auswahlabschnitts einem gleichnamigen Datenknoten der Datenverbindung zu. Im Formularlayout wird dann nur das Teilformular bzw. die Zeile angezeigt, deren Name dem Datenknoten entspricht.
Teilformular über Ausdruck auswählen
Ordnet ein einzelnes Teilformular des Auswahl-Teilformularsatzes bzw. eine Zeile des Auswahlabschnitts einem benutzerdefinierten Datenknoten in der Datenverbindung zu. Sie können dann mit Hilfe von relationalen Skriptausdrücken (z. B. für Gleichheit oder Ungleichheit) im Feld „Ausdruck“ die Bedingungen festlegen, die erfüllt sein müssen, damit das benannte Teilformular bzw. die benannte Zeile im Formularlayout angezeigt wird. Der erste Eintrag in der Liste „Alternative Teilformulare“, bei dem für einen Wert „true“ (wahr) zurückgegeben wird, wird im Formular angezeigt.
Datenverbindung
Gibt den Namen der aktuellen Datenverbindung an:
    • Standarddatenbindung
Für den Formularentwurf ist derzeit keine Datenverbindung festgelegt.
    • [Name_der_Datenverbindung]
Der Name der derzeit für den Formularentwurf festgelegten Datenverbindung.
Hinzufügen
Fügt dem Auswahl-Teilformularsatz ein neues Teilformular bzw. dem Auswahlabschnitt eine neue Zeile hinzu. Hierdurch wird ein Duplikat des derzeit in der Liste „Alternative Teilformulare“ ausgewählten Teilformularobjekts hinzugefügt. Falls kein Teilformular oder keine Zeile ausgewählt ist, wird dem Auswahl-Teilformularsatz bzw. dem Auswahlabschnitt ein neues unbenanntes Teilformular hinzugefügt.
Entfernen
Löscht das derzeit ausgewählte Teilformular bzw. die derzeit ausgewählte Zeile aus dem Auswahl-Teilformularsatz bzw. dem Auswahlabschnitt.
Nach oben
Verschiebt den derzeit ausgewählten Eintrag zum alternativen Teilformular in der Liste nach oben.
Nach unten
Verschiebt den derzeit ausgewählten Eintrag zum alternativen Teilformular in der Liste nach unten.
Name
Gibt den Namen des Teilformularobjekts im Auswahl-Teilformularsatz bzw. den Namen der Zeile im Auswahlabschnitt an.
Bindung
Zeigt alle für die aktuelle Datenverbindung verfügbaren Datenbindungen an:
    • [Name_des_Datenknotens]
Bindet das Teilformular bzw. die Zeile innerhalb der Datenverbindung an diesen Datenknoten.
    • <Ohne>
Deaktiviert die Datenbindung und verwendet einen benutzerdefinierten Datenknoten der Datenverbindung. Das Teilformular bzw. die Zeile wird trotzdem an einen gleichnamigen Datenknoten in der Datenverbindung gebunden, sofern dieser existiert.
Sie können allerdings auch direkt eine benutzerdefinierte Bindung eingeben.
Ausdruck
Gibt einen relationalen Skriptausdruck (z. B. für Gleichheit oder Ungleichheit) an, durch den die Bedingungen festgelegt werden, die erfüllt sein müssen, damit das benannte Teilformular bzw. die benannte Zeile im Formularlayout angezeigt wird.
Wenn kein Ausdruck angegeben wird, wird für den bedingten Umbruch der Wert „true“ (wahr) angenommen.
Sprache
Legt fest, welche Skriptsprache Sie für die aktuelle Berechnung bzw. das aktuelle Skript verwenden möchten. Dabei gibt es zwei Möglichkeiten:
    • FormCalc
Eine von Adobe entwickelte Berechnungssprache, die für kürzere Skripten geeignet ist.
    • JavaScript
Eine leistungsstarke, flexible Skriptsprache für komplexere Skripten.
Verwandte Themen
Teilformulare – Übersicht
Teilformularsätze – Übersicht
Info über Tabellen
Eigenschaften von Abschnitten: Registerkarte „Abschnitt“


Dialogfeld „Wörterbuch bearbeiten“

Verwenden Sie dieses Dialogfeld, um eine Liste der Wörter anzuzeigen, die in Ihrem benutzerdefinierten Wörterbuch („Mein benutzerdefiniertes Wörterbuch“) unter einzelnen oder allen Sprachen verfügbar sind. Mit Hilfe des Dialogfeldes können Sie die Rechtschreibung der aufgelisteten Wörter ändern, Wörter zu einzelnen Sprachen oder zu allen Sprachen hinzufügen sowie Wörter in einzelnen oder in allen Sprachen löschen.
Um dieses Dialogfeld anzuzeigen, wählen Sie „Extras“ > „Wörterbuch bearbeiten“.
Sprache
Listet die verfügbaren Sprachen auf, die Sie auswählen können. Die Liste der Wörter zu der jeweiligen Sprache werden angezeigt, wenn die Sprache ausgewählt ist.
Wort
Das aus der Liste ausgewählte Wort wird in diesem Feld angezeigt. Hier können Sie die Rechtschreibung korrigieren oder ändern. Sie können auch neue Wörter eingeben und zu „Mein benutzerdefiniertes Wörterbuch“ hinzufügen.
Hinzufügen
Fügt das neue Wort, das im Feld „Wort“ eingegeben ist, zu „Mein benutzerdefiniertes Wörterbuch“ hinzu.
Löschen
Löscht das ausgewählte Wort aus der Liste zu der ausgewählten Sprache.
Fertig
Schließt das Dialogfeld „Wörterbuch bearbeiten“.


Dialogfeld „Datei-Import-Optionen“ (Microsoft InfoPath und Word)

Über dieses Dialogfeld können Sie Dateien von Microsoft InfoPath und Microsoft Word-Dokument importieren.
Microsoft InfoPath
Verwenden Sie dieses Dialogfeld, um Optionen für den Import von Microsoft® InfoPath-Dateien festzulegen.
Um dieses Dialogfeld anzuzeigen, wählen Sie „Datei“ > „Öffnen“ und öffnen Sie anschließend die gewünschte InfoPath-Datei.
Aufforderung zur Ansichtsauswahl beim Konvertieren
Fordert Sie zur Auswahl einer Ansicht auf. Enthält die InfoPath-Datei nur eine Ansicht, wird auch bei aktivierter Option keine Aufforderung angezeigt.
Ansicht
Gibt den Namen der zu konvertierenden Ansicht an. Um die Standardansicht umzuwandeln, lassen Sie dieses Feld leer. Wenn die Option „Aufforderung zur Ansichtsauswahl beim Konvertieren“ aktiviert ist, wird diese Option ignoriert.
Druckeinstellungen importieren
Importiert die Kopf- und Fußzeilen, die Seitenausrichtung und die Seitenränder des InfoPath-Formulars. Wenn Sie die Option „Druckeinstellungen importieren“ aktivieren, werden die Seitengröße und die Seitenausrichtung des InfoPath-Formulars übernommen, so dass Sie diese nicht mehr gesondert festlegen müssen.
Seitengröße
Legt eine Seitengröße für das zu konvertierende Formular fest. Wählen Sie zum Konvertieren der Standardgröße die Option „Standard“.
Ausrichtung
Legt die Seitenausrichtung des konvertierten Formulars fest.
Protokolldatei generieren
Wenn eine andere Option als „Nicht protokollieren“ ausgewählt wird, erstellt LiveCycle Designer eine Protokolldatei (*.log) unter dem von Ihnen angegebenen Namen und an dem von Ihnen festgelegten Standort. Die Protokolldatei zeichnet Informationen über den Umwandlungsvorgang auf und kann in einem beliebigen ASCII-Texteditor angezeigt werden.
Bilder in XDP einbetten
Bei Auswahl dieser Option werden Bilder in der InfoPath-Datei umgewandelt und in das umgewandelte Formular eingebettet. Wenn Sie diese Option deaktiviert lassen, wandelt LiveCycle Designer die Bilder nicht um, sondern setzt stattdessen Platzhalter ein.
Verwandte Themen
So importieren Sie eine Microsoft InfoPath-Datei
Umwandlung von Microsoft InfoPath-Objekten mit LiveCycle Designer
Microsoft Word-Dokument
Verwenden Sie dieses Dialogfeld, um Optionen für den Import von Microsoft Word-Dateien festzulegen.
Um dieses Dialogfeld anzuzeigen, wählen Sie unter „Datei“ die Option „Öffnen“ und anschließend die gewünschte Word-Datei aus.
Kennwort zum Öffnen der Datei
Wenn für die Word-Datei ein Kennwort eingegeben werden muss, bevor das Dokument geöffnet werden kann, dann geben Sie das Kennwort in dieses Feld ein.
Kennwort zum Freigeben der Datei
Wenn die Word-Datei geschützt ist (Benutzer können Daten nur in bestimmte Bereiche eingeben) und die Eingabe eines Kennworts notwendig ist, um den Schutz aufzuheben, dann geben Sie das Kennwort in dieses Feld ein.
Fehlende Schriften ignorieren
LiveCycle Designer erkennt, ob die Word-Datei Schriften enthält, die auf Ihrem Computer nicht zur Verfügung stehen. Sie können dann entweder die fehlenden Schriften installieren oder in Word entsprechende Schriftersetzungsregeln einrichten. Wenn diese Option ausgewählt ist, ersetzt LiveCycle Designer die fehlenden Schriften durch eine verfügbare Schrift und alle Schriftersetzungsmeldungen werden unterdrückt.
Bilder konvertieren
Bei Auswahl dieser Option werden Bilder umgewandelt und in das umgewandelte Formular eingebettet. Wenn Sie diese Option deaktiviert lassen, wandelt LiveCycle Designer die Bilder nicht um, sondern setzt stattdessen Platzhalter ein.
Flow-Layout beibehalten (Objekte und Text werden nicht fest positioniert.)
Bei Auswahl dieser Option wird das Layout in LiveCycle Designer nicht verankert.
Protokolldatei generieren
Wenn eine andere Option als „Nicht protokollieren“ ausgewählt ist, erstellt LiveCycle Designer eine Protokolldatei (*.log) an dem von Ihnen angegebenen Ort. Die Protokolldatei zeichnet Informationen über den Umwandlungsvorgang auf und kann in einem beliebigen ASCII-Texteditor angezeigt werden. Der Name der Protokolldatei beinhaltet den Namen der Formulardatei.
Verwandte Themen
So importieren Sie eine Microsoft Word-Datei
Umwandlung von Word-Objekten und -Einstellungen durch LiveCycle Designer
Hinweise zur Vermeidung von Word-Konvertierungsproblemen


Dialogfeld „Formulareigenschaften“

Registerkarte „Kompatibilität“ (Dialogfeld „Formulareigenschaften“)
Registerkarte „Standard“ (Dialogfeld „Formulareigenschaften“)
Registerkarte „Info“ (Dialogfeld „Formulareigenschaften“)
Registerkarte „PDF-Schutz“ (Dialogfeld „Formulareigenschaften“)
Registerkarte „Leistung“ (Dialogfeld „Formulareigenschaften“)
Registerkarte „Variablen“ (Dialogfeld „Formulareigenschaften“)


Registerkarte „Kompatibilität“ (Dialogfeld „Formulareigenschaften“)

Verwenden Sie dieses Dialogfeld, um Formulare, die mit LiveCycle Designer Version 6 erstellt wurden, auf Version 7 zu aktualisieren. Dadurch wird Text verschoben, der möglicherweise anschließend wieder manuell angepasst werden muss. Ferner wird die Skriptverarbeitung bezüglich enter- und exit-Ereignissen für Dropdown-Listenfelder beeinflusst. Wird das ältere Formular zumeist mit Acrobat 7.0 oder Adobe Reader 7.0 oder höher angezeigt, sollte es unter Verwendung der Registerkarte „Kompatibilität“ auf Version 7 aktualisiert werden.
Um dieses Dialogfeld anzuzeigen, wählen Sie unter „Datei“ die Option „Formulareigenschaften“ aus und klicken Sie auf „Kompatibilität“. Wurde das Formular mit Version 6 erstellt, werden Schaltflächen angezeigt, die Sie zum Aktualisieren auf Version 7 verwenden können.
Textformatierung zurücksetzen oder aktualisieren
Formulare einer älteren Version von LiveCycle Designer verfügen über andere Textformatierungsregeln.
Zum Verwenden der aktuellen Textformatierungsregeln klicken Sie auf „Textformatierung aktualisieren“. Durch Aktualisieren der älteren Formulare verschieben sich Textteile, die möglicherweise manuell ausgerichtet werden müssen.
Zum Verwenden der Formatierungsregeln von Version 6 klicken Sie auf „Textformatierung zurücksetzen“.
Ereignismodell aktualisieren oder zurücksetzen
Bei Formularen einer älteren Version von LiveCycle Designer unterscheidet sich die Verarbeitung von „enter“-Ereignissen im Formular. Klickt ein Benutzer in Version 7 zum ersten Mal in ein Feld, wird ein „enter“-Ereignis gesendet, für das die Eigenschaft „reenter“ mit dem Wert „false“ (falsch) versehen ist. Klickt ein Benutzer erneut in das Feld oder drückt die Eingabetaste, wird ein weiteres „enter“-Ereignis gesendet, für das die Eigenschaft „reenter“ mit dem Wert „true“ (wahr) versehen ist.
Zum Verwenden der aktuellen Ereignisverarbeitung klicken Sie auf „Ereignismodell aktualisieren“. Soll das „enter“-Ereignis bei jedem Klicken auf eine Dropdown-Liste ausgelöst werden, aktualisieren Sie das Ereignismodell.
Zum Verwenden der Ereignisverarbeitung aus Version 6 klicken Sie auf „Ereignismodell zurücksetzen“. Möchten Sie in einem Formular, das mit Version 6 von LiveCycle Designer erstellt wurde, Daten von einem Server nur beim ersten „enter“-Ereignis herunterladen, sollten Sie das alte Ereignismodell beibehalten oder das Modell zurücksetzen.


Registerkarte „Standard“ (Dialogfeld „Formulareigenschaften“)

Verwenden Sie dieses Dialogfeld, um eine Reihe von Standardeinstellungen festzulegen, die dann in LiveCycle Designer für jeden Formularentwurf verwendet werden. Falls nötig, können Sie diese Einstellungen für einzelne Entwürfe außer Kraft setzen.
Um dieses Dialogfeld anzuzeigen, wählen Sie unter „Datei“ die Option „Formulareigenschaften“ aus und klicken Sie auf „Standard“.
Standardsprache für Formulare
Legt die Standardsprache für den Formularentwurf sowie das Format von Datum, Uhrzeit und numerischen Werten sowie die Währung für ein bestimmtes Land fest. Legt auch die Sprache fest, die von der Funktion „Rechtschreibprüfung“ verwendet wird.
Standardsprache
Legt die Standard-Skriptsprache, die beim Erstellen eines Formularentwurfs verwendet werden soll, fest. Sie können zwischen JavaScript und FormCalc wählen.
Standardausführung am
Legt fest, wann die Skripten in der Vorlage ausgeführt werden. Die folgenden Optionen stehen zur Auswahl:
    • Client
Gibt an, dass Skripten auf dem Client ausgeführt werden sollen. Dies ist die Standardeinstellung.
    • Server
Gibt an, dass Skripten auf dem Server ausgeführt werden sollen. Das Ergebnis wird anschließend an den Browser zurückgegeben.
    • Client und Server
Gibt an, dass Skripten auf dem Client und auf dem Server ausgeführt werden können.
Vorschautyp
Legt fest, welche Art von Formular auf der Registerkarte „PDF-Vorschau“ angezeigt wird:
    • Interaktives Formular
Wählen Sie diese Option zum Anzeigen eines Formulars, das Felder zum interaktiven Erfassen von Daten enthält. Wenn Sie den Formularentwurf als Vorschau anzeigen, wird das Formular als interaktive PDF-Datei angezeigt.
Vorschaudaten erstellen
Wählen Sie diese Option aus, um Formulardaten als Muster zu erstellen. Wenn Sie den Formularentwurf als Vorschau anzeigen, wird er mit den Musterdaten zusammengeführt. Sie können auch angeben, wie oft ein wiederholtes Teilformular in der Vorschau des Formularentwurfs wiederholt werden soll.
Datendatei
Legt die Datendatei fest, die bei der Vorschau eines mit Daten zusammenzuführenden Formularentwurfs verwendet werden soll. Die Datendatei muss das XML-Standardformat aufweisen. Sie können den Pfad zu der Datendatei im Feld „Datendatei“ eingeben oder zu der Datei blättern.
XDP-Vorschauformat
Legt das PDF-Vorschauformat für XDP- und TDS-Dateien fest. Das hier festgelegte Vorschauformat für XDP-Dateien wird auch zur Vorschau noch nicht gespeicherter Dateien verwendet, wenn für die Option „Standarddateityp für neue Formulare“ (unter „Extras“ > „Optionen“) der Eintrag „Adobe XML-Formulardatei (XDP)“ ausgewählt wurde. Bei PDF-Dateien wird das XDP-Vorschauformat allerdings ignoriert. Sie können aus den folgenden Optionen auswählen:
    • Acrobat 8 (Statisch) PDF-Formular
Legt „Acrobat 8.0 (Statisch)“ als Standardvorschauformat fest. Der Formularentwurf kann daher nur statische Elemente enthalten. Falls Ihr Formularentwurf dynamische Elemente enthält, sind diese im Formular nicht verfügbar. Wenn beispielsweise ein Formular eine Tabelle enthält, deren Spaltenanzahl sich nicht verändert, jedoch je nach Informationsmenge in der Datenquelle die Anzahl an Zeilen in der Tabelle sich verändert, wird nur eine Zeile mit Daten auf der Registerkarte „PDF-Vorschau“ angezeigt.
    • Acrobat 8 (Dynamisch) XML-Formular
Legt „Acrobat 8.0 (Dynamisch)“ als Standardvorschauformat fest. Der Formularentwurf kann dynamische Elemente enthalten. Wenn beispielsweise ein Formular eine Tabelle enthält, deren Spaltenanzahl sich nicht verändert, jedoch je nach Informationsmenge in der Datenquelle die Anzahl an Zeilen in der Tabelle sich verändert, werden alle Zeilen mit Daten auf der Registerkarte „PDF-Vorschau“ angezeigt.
    • Acrobat 7 (Statisch) PDF-Formular
Legt eine mit Acrobat Version 7.0 kompatible statische PDF-Datei als Standardvorschauformat fest. Der Formularentwurf kann daher nur statische Elemente enthalten. Wenn das Formular z. B. 10 Zeilen zur Dateneingabe hat, es aber Daten für 25 Zeilen gibt, können nur 10 Zeilen ausgefüllt werden. Gleichermaßen werden 10 Zeilen angezeigt, auch wenn nur 2 Zeilen Daten enthalten. 2 Zeilen sind dann ausgefüllt, und 8 Zeilen sind leer.
    • Acrobat 7 (Dynamisch) XML-Formular
Legt eine mit Acrobat Version 7.0 kompatible dynamische PDF-Datei als Standardvorschauformat fest. Der Formularentwurf kann dynamische Elemente enthalten. Beispielsweise kann es sich bei dem Formularentwurf um ein interaktives Formular handeln, das es den Anwendern gestattet, Elementzeilen hinzuzufügen oder zu entfernen.
    • Mit Acrobat Version 6 kompatible (statische) PDF-Datei
Legt eine mit Acrobat Version 6 kompatible (statische) PDF-Datei als Standardvorschauformat fest. Vewenden Sie diese Option, wenn die potenziellen Formularempfänger nur über Acrobat 6.0 verfügen. Der Formularentwurf kann nur statische Elemente enthalten. Ferner können keine Papierformular-Barcodes hinzugefügt werden.
Standardwiedergabe überschreiben
Aktivieren Sie diese Option, um LiveCycle Forms anzuweisen, wie ein XDP-Formular wiedergegeben werden soll.
PDF-Wiedergabeformat
Wenn „Standardwiedergabe überschreiben“ aktiviert ist, gibt diese Option an, in welchem PDF-Format LiveCycle Forms Version 7.1 ein XDP-Formular wiedergeben soll, sofern LiveCycle Forms Version 7.1 auf die Standardoption eingestellt ist. Weitere Informationen finden Sie im LiveCycle Forms-Dokument Entwickeln benutzerdefinierter Anwendungen. Sie können aus den folgenden Optionen auswählen: „Acrobat 8 (Statisch) PDF-Formular“, „Acrobat 8 (Dynamisch) XML-Formular“, „Acrobat 7 (Statisch) PDF-Formular“, „Acrobat 7 (Dynamisch) XML-Formular“ oder „Acrobat 6 (Statisch) PDF-Formular“.
Verwandte Themen
So können Sie Formulare auf der Registerkarte „PDF-Vorschau“ in der Vorschau anzeigen und testen
So legen Sie Vorschauoptionen für ein interaktives Formular fest


Registerkarte „Info“ (Dialogfeld „Formulareigenschaften“)

Verwenden Sie dieses Dialogfeld, um allgemeine Informationen zum Formularentwurf aufzuzeichnen und anzuzeigen. So wird beispielsweise im Feld „Datei“ der Dateiname des Formularentwurfs und der Pfad zu seinem Speicherort angezeigt.
Wenn Sie mit einem PDF-Dokument arbeiten, das PDF-Grafiken enthält, werden die Informationen auf der Registerkarte „Info“ schreibgeschützt dargestellt und können nur in Adobe Acrobat bearbeitet werden.
Um dieses Dialogfeld anzuzeigen, wählen Sie unter „Datei“ die Option „Formulareigenschaften“ aus und klicken Sie auf „Info“.
Datei
Zeigt den Dateinamen und den Pfad zum Speicherort der Datei an. Der Name wird beim Erstellen des Formularentwurfs erzeugt.
Titel
Gibt den Namen des Formularentwurfs an.
Beschreibung
Enthält eine Beschreibung des Formularentwurfs.
Autor
Zeigt den Verfasser des Formularentwurfs an.
Kontakt
Enthält zusätzliche Kontaktinformationen.
Abteilung
Gibt die Abteilung innerhalb der Organisation an, der der Formularentwurf gehört.
Erstellt am
Zeigt an, wann der Formularentwurf erstellt wurde.
Version
Zeigt die aktuelle Version des Formularentwurfs an.
Versionsdatum
Zeigt das Datum der aktuellen Version des Formularentwurfs an.
Verwandte Themen
So fügen Sie Informationen über Formulare hinzu


Registerkarte „PDF-Schutz“ (Dialogfeld „Formulareigenschaften“)

Verwenden Sie dieses Dialogfeld, um den Zugriff auf das PDF-Formular einzuschränken. Dazu geben Sie Kennwörter an und schränken bestimmte Funktionen wie die Druckausgabe oder die Bearbeitung des PDF-Formulars ein.
Zum Anzeigen dieses Dialogfeldes wählen Sie „Datei“ > „Formulareigenschaften“, und klicken Sie dann auf „PDF-Schutz“.
Kennwort zum Öffnen des Dokuments erforderlich
Gibt an, dass das PDF-Formular den Benutzer auffordert, zum Öffnen des Formulars ein Kennwort einzugeben. Sie werden beim Speichern des Formularentwurfs im PDF-Format aufgefordert, das Kennwort festzulegen.
Kennwörter löschen
Entfernt die zum Öffnen, Drucken und Bearbeiten des PDF-Formulars erforderlichen Kennwörter. Sie werden beim Speichern des Formularentwurfs im PDF-Format aufgefordert, das Kennwort festzulegen.
Kennwort verwenden, um das Drucken und Bearbeiten des Dokuments bzw. seiner Sicherheitseinstellungen einzuschränken
Gibt an, dass der Endbenutzer das richtige Kennwort eingeben muss, um das PDF-Formular zu drucken oder zu bearbeiten. Sie werden beim Speichern des Formularentwurfs im PDF-Format aufgefordert, das Kennwort festzulegen.
Zulässiges Drucken
Gibt an, ob der Benutzer das Formular drucken kann. Wenn Sie das Drucken zulassen möchten, wählen Sie die Druckauflösung in der Liste aus. Die Optionen umfassen:
      •
      Geringe Auflösung (150 dpi)
      •
      Hohe Auflösung
Zulässige Änderungen
Gibt an, ob der Benutzer Änderungen an dem PDF-Formular vornehmen kann. Wenn Sie Änderungen zulassen möchten, wählen Sie den Typ der Änderung aus, die der Benutzer vornehmen darf. Die Optionen umfassen:
      •
      Einfügen, Löschen und Drehen von Seiten
      •
      Formularfelder ausfüllen und unterschreiben
      •
      Kommentieren, Ausfüllen von Formularfeldern und unterschreiben
      •
      Alle außer Entnehmen von Seiten
Kopieren von Text, Bildern und anderen Inhalten zulassen
Gibt an, dass der Benutzer Text, Bilder und andere Inhalte kopieren darf.
Textzugriff für Bildschirmlesehilfen für Sehbehinderte aktivieren
Gibt an, dass der Benutzer das Dokument mit einer Bildschirmlesehilfe aufrufen kann.
Nur-Text-Metadaten aktivieren
Gibt an, dass die auf der Registerkarte „Info“ eingegebenen Informationen zusammen mit dem PDF-Formular gespeichert werden.
Verwandte Themen
Sichere Formulare
PDF-Sicherheitsoptionen


Registerkarte „Leistung“ (Dialogfeld „Formulareigenschaften“)

Verwenden Sie dieses Dialogfeld, um die Server- und Druckeinstellungen für die Zwischenspeicherung (Cache-Speicherung) des Formularentwurfs festzulegen. Durch die Optionen für die Druck-Zwischenspeicherung kann die serverseitige Verarbeitung und die Leistung der angegebenen Druckausgabe verbessert werden. Die Aktivierung dieser Einstellungen kann jedoch auch zu einer größeren Entwurfsdatei führen und so die Leistung des Client beeinträchtigen. Bei gleichzeitiger Auswahl mehrerer Druckoptionen steigt die Dateigröße des Formularentwurfs auf jeden Fall beträchtlich an.
Um dieses Dialogfeld anzuzeigen, wählen Sie unter „Datei“ die Option „Formulareigenschaften“ aus und klicken Sie auf „Leistung“.
Zwischenspeichern der Formularwiedergabe auf Server zulassen
Das gesamte statische PDF-Formular wird auf dem Server zwischengespeichert und für spätere Formularwiedergaben verwendet. Wählen Sie diese Option nur für Formulare mit festem Layout aus.
Serverseitige Datenbindung und/oder Skripterstellung für Formular erforderlich
Weist den Server an, den Formularentwurf mit Daten zusammenzuführen. Aktivieren Sie diese Option nur, wenn der Formularentwurf über eine Datenbank- oder Webdienst-Bindung bzw. über ein serverseitiges Skript verfügt.
Falls der Entwurf keine serverseitigen Datenbindungen oder Skripten aufweist, lassen Sie diese Option deaktiviert, da sie sonst zu einem Leistungsabfall führt.
PostScript-Ausgabe in Formular zwischenspeichern
Bettet eine PostScript®-Kopie des Formularentwurfs im Formularentwurf ein. Die Einbettung der Kopie erfolgt beim Speichern des Entwurfs.
Schwarzweiß-PCL-Ausgabe in Formular zwischenspeichern
Bettet eine Kopie des Formularentwurfs im Schwarzweiß-PCL-Format im Formularentwurf ein. Die Einbettung der Kopie erfolgt beim Speichern des Entwurfs.
Farb-PCL-Ausgabe in Formular zwischenspeichern
Bettet eine Kopie des Formularentwurfs im Farb-PCL-Format im Formularentwurf ein. Die Einbettung der Kopie erfolgt beim Speichern des Entwurfs.
Zebra Label-Druckerausgabe (200 dpi) in Formular zwischenspeichern
Bettet eine Kopie des Formularentwurfs im Zebra-Format mit 200 dpi im Formularentwurf ein. Die Einbettung der Kopie erfolgt beim Speichern des Entwurfs.
Zebra Label-Druckerausgabe (300 dpi) in Formular zwischenspeichern
Bettet eine Kopie des Formularentwurfs im Zebra-Format mit 300 dpi im Formularentwurf ein. Die Einbettung der Kopie erfolgt beim Speichern des Entwurfs.


Registerkarte „Variablen“ (Dialogfeld „Formulareigenschaften“)

Verwenden Sie dieses Dialogfeld, um Variablen im Formularentwurf festzulegen. Die Variablen werden mit dem aktuellen Formularentwurf gespeichert.
Um dieses Dialogfeld anzuzeigen, wählen Sie unter „Datei“ die Option „Formulareigenschaften“ aus und klicken Sie auf „Variablen“.
Variablen
Zeigt alle Variablen im aktuellen Formularentwurf an.
Hinzufügen
Klicken Sie auf diese Schaltfläche, um eine neue Variable zu definieren. Sie müssen einen Namen in der Variablenliste und einen Variablenwert im großen Bearbeitungsfeld auf der rechten Seite eingeben.
Jede Variable in einem Formularentwurf muss einen eindeutigen Namen haben. Bei Variablennamen wird nicht zwischen Groß- und Kleinbuchstaben unterschieden.
Der Variablenname darf keine Leerzeichen enthalten. Sobald Sie die Leertaste drücken, wird der Cursor automatisch von LiveCycle Designer in das große Bearbeitungsfeld auf der rechten Seite verschoben.
Wenn eine Variable keinen Wert hat, wird sie von LiveCycle Designer nur während der aktuellen Sitzung im Formularentwurf gespeichert.
Löschen
Klicken Sie auf diese Schaltfläche, um die momentan in der Variablenliste ausgewählte Variable zu löschen.
Verwandte Themen
Variablen


Dialogfeld „Importoptionen“

Verwenden Sie dieses Dialogfeld, um Importeinstellungen für PDF-Dateien festzulegen, die nicht mit LiveCycle Designer erstellt wurden.
Um dieses Dialogfeld anzuzeigen, wählen Sie unter „Datei“ die Option „Öffnen“ und dann eine PDF-Datei aus. Klicken Sie anschließend auf „Öffnen“ und auf den Link „Assistent nicht verwenden“, wenn der Assistent für neue Formulare angezeigt wird.
Interaktives Formular mit fixierten Seiten erstellen
Erhält das Erscheinungsbild von PDF-Dokumenten, die mit Acrobat und anderen Anwendungen erstellt wurden und die im Dialogfeld „Öffnen“ verfügbar sind. Konvertiert Acrobat-Formularfelder in entsprechende LiveCycle Designer-Bibliotheksobjekte. Wenn Sie den Inhalt eines PDF-Dokuments als Grafik importiert haben, können Sie zusätzliche Bibliotheksobjekte wie gewünscht zu den Grafiken hinzufügen. Verwenden Sie diese Option, wenn Sie über ein PDF-Dokument verfügen, das mit Acrobat oder einer anderen Anwendung erstellt wurde und das Sie als Basis (Hintergrund) beim Erstellen eines interaktiven Formulars mit fixierten Seiten mit LiveCycle Designer verwenden möchten.
Interaktives Formular mit flexiblem Layout erstellen
Importiert PDF-Dokumente, damit deren Inhalte in LiveCycle Designer bearbeitet werden können. Alle Dateianhänge und Anmerkungen werden entfernt. Hält den Text in weniger Objekten zusammen. Verwenden Sie diese Option, wenn Sie ein interaktives Formular mit flexiblem Layout erstellen, umfangreiche Textänderungen an dem importierten PDF-Formular vornehmen oder LiveCycle Designer zum kontinuierlichen Aktualisieren des Formulars verwenden möchten. Diese Option unterstützt außerdem Wortumbrüche; Zeilenumbrüche jedoch bleiben möglicherweise nicht erhalten. Zur Wiederherstellen des Erscheinungsbilds des Originaldokuments werden möglicherweise einige TouchUp-Textwerkzeuge benötigt.
Bearbeitungsoptionen
Beinhaltet Optionen für den Import von Text:
    • Inhalt platzieren in
Legt fest, wo der Inhalt im Formularentwurf eingefügt wird: auf einer Seite oder auf einer Masterseite.
    • Text verbinden als
Gibt an, wie der Text in Objekte konvertiert werden soll.
    • Toleranz beim Verbinden von Text
Eine hohe Toleranzeinstellung bietet eine höhere Anzahl von Variationen und verbindet mehrere Textteile in einem Objekt. Bei einer hohen Einstellung können Textteile kombiniert werden, die eigentlich getrennte Objekte sein sollten. Bei einer niedrigen Einstellung wird mehr Text als einzelne Objekte beibehalten.
    • Toleranz beim Verbinden von Zeilen
Eine hohe Toleranzeinstellung bietet eine höhere Anzahl von Variationen und verbindet mehrere Textzeilen in einem Objekt. Bei einer hohen Einstellung können Textzeilen kombiniert werden, die eigentlich getrennte Objekte sein sollten. Bei einer niedrigen Einstellung wird mehr Text als einzelne Textzeilen beibehalten.
    • Toleranz beim Verbinden von Absätzen
Eine hohe Toleranzeinstellung bietet eine höhere Anzahl von Variationen und verbindet mehrere Absätze miteinander. Bei einer hohen Einstellung können Absätze kombiniert werden, die eigentlich getrennt sein sollten. Bei einer niedrigen Einstellung werden mehr Absätze als einzelne Objekte beibehalten. Bei einer niedrigen Einstellung wird unter Umständen Text, der in einem Absatz stehen sollte, nicht zusammengefügt.
Bilder einbetten
Wandelt die Bilder in der PDF-Datei um und bettet sie in das konvertierte Formular ein. Sie können eines der unterstützten Formate auswählen. Wenn Sie diese Option deaktiviert lassen, wandelt LiveCycle Designer die Bilder nicht um, sondern setzt stattdessen Platzhalter ein.
Format
Listet die Grafiken auf, die Sie auswählen können.
Protokolldatei im Temp-Ordner erstellen
Erstellt eine Protokolldatei (*.log) mit dem Namen der PDF-Datei und der Erweiterung „.log“. Die Protokolldatei wird im von Windows konfigurierten Temp-Ordner (temporäres Verzeichnis) (normalerweise unter \Dokumente und Einstellungen\[Benutzername]\Lokale Einstellungen\Temp) abgelegt. Wenn im Temp-Ordner bereits eine gleichnamige Datei vorhanden ist, wird sie überschrieben. In der Protokolldatei werden Informationen über den Umwandlungsvorgang aufgezeichnet und können in einem beliebigen ASCII-Texteditor angezeigt werden.
Übersichtsbericht anzeigen, wenn Konvertierungsprobleme auftreten
Bei Auftreten von Problemen bei der Umwandlung wird ein Dialogfeld mit den entsprechenden Informationen angezeigt, bevor der Umwandlungsvorgang abgeschlossen wird. Der Vorgang kann bei Bedarf abgebrochen werden.
Optionen für Seitenbereich
Beinhaltet Optionen für die Angabe der Anzahl der zu importierenden Seiten.
Alle
Importiert alle Seiten im PDF-Dokument.
Seiten
Importiert einzelne Seiten oder einen Bereich von Seiten. Geben Sie beispielsweise 2,3,6 für einzelne Seiten oder 2-5 für einen Seitenbereich ein. Es ist auch möglich, gleichzeitig Einzelseiten und Seitenbereiche anzugeben: 1,3,6-9.
Verwandte Themen
So importieren Sie PDF-Dateien
Umwandlung von PDF-Objekten durch LiveCycle Designer
Hinweise zur Vermeidung von PDF-Konvertierungsproblemen
PDF-Dokumente als Grafik importieren


Dialogfeld „Tabelle einfügen“

Verwenden Sie dieses Dialogfeld, um eine einfache Tabelle zu erstellen. Sie haben zudem die Möglichkeit, auf den Tabellenassistenten zuzugreifen.
Wählen Sie zum Anzeigen dieses Dialogfeldes „Einfügen“ > „Standard“ > „Tabelle“ aus, oder ziehen Sie das Standardobjekt „Tabelle“ aus der Kategorie „Standard“ in der Palette „Bibliothek“ in den Layout-Editor. Sie können das Dialogfeld „Tabelle einfügen“ auch durch Klicken auf „Tabelle“ > „Tabelle einfügen“ öffnen.
Einfache Tabelle erstellen
Erstellt anhand der ausgewählten Optionen eine einfache Tabelle.
Spalten
Fügt die angegebene Anzahl von Spalten zur Tabelle hinzu.
Textzeilen
Fügt die angegebene Anzahl von Textzeilen zur Tabelle hinzu.
Kopfzeile in Tabelle einschließen
Fügt der Tabelle eine Kopfzeile hinzu.
Fußzeile in Tabelle einschließen
Fügt der Tabelle eine Fußzeile hinzu.
Tabelle mit Assistenten erstellen
Öffnet den Tabellenassistenten, mit dem Sie eine einfache Tabelle oder eine Tabelle, die mit der Anzahl der Datenzeilen wächst, erstellen können.
Nicht mehr anzeigen
Bei Auswahl dieser Option wird das Dialogfeld „Tabelle einfügen“ nicht mehr angezeigt, wenn Sie „Einfügen“ > „Standard“ > „Tabelle“ wählen oder das Tabellenobjekt in den Layout-Editor ziehen. Um diese Auswahl zu revidieren, wählen Sie „Extras“ > „Optionen“ > „Assistenten und Tipps“ > „Beim Erstellen von Tabellen anzeigen“.
Verwandte Themen
Textkörperlayout (Dialogfeld „Tabellenassistent“)
So erstellen Sie eine Tabelle mit dem Tabellenassistenten
So erstellen Sie eine einfache Tabelle


Dialogfeld „Tastaturbefehle“

Verwenden Sie dieses Dialogfeld, um für die Befehle in LiveCycle Designer Tastaturbefehle zu erstellen und zu verwalten.
Klicken Sie zum Anzeigen dieses Dialogfeldes auf „Extras“ > „Tastaturbefehle“.
Satz
Enthält den Standard- und alle benutzerdefinierten Tastaturbefehlssätze, die verwendet, geändert, gespeichert und gelöscht werden können. Nach jeder Änderung am ausgewählten Satz wird das Wort „(Geändert)“ hinter dem Satznamen angefügt.
Speichern unter
Öffnet das Dialogfeld „Speichern unter“, in dem Sie einen Namen eingeben und den Tastaturbefehlssatz speichern können. Sie können einen beliebigen Namen verwenden. Der Standardsatz kann jedoch nicht ersetzt werden.
Löschen
Löscht den ausgewählten Tastaturbefehlssatz. Der Standardsatz kann nicht gelöscht werden.
Produktbereich
Enthält die Produktbereiche (einschließlich der Menüs und Paletten), für die benutzerdefinierte Tastaturbefehle erstellt werden können.
Befehle
Zeigt alle Befehle an, wenn unter „Produktbereich“ die Option „(Alle Befehle)“ ausgewählt ist, bzw. nur die zugehörigen Befehle, wenn ein bestimmtes Menü bzw. eine bestimmte Palette ausgewählt wurde. Die Befehle sind bestimmten Produktbereichen wie „Datei“, „Bearbeiten“, „Ansicht“ oder „Paletten“ zugeordnet.
Aktuelle Tastaturbefehle
Zeigt die dem in der Liste „Befehle“ ausgewählten Befehl zugewiesenen Tastaturbefehle an.
Entfernen
Löscht den ausgewählten Tastaturbefehl aus der Liste „Aktuelle Tastaturbefehle“. Wenn dem ausgewählten Befehl kein Tastaturbefehl zugewiesen ist, ist diese Schaltfläche deaktiviert.
Neuer Tastaturbefehl
In diesem Feld geben Sie den gewünschten neuen Tastaturbefehl für den ausgewählten Befehl ein.
Zuweisen
Weist dem ausgewählten Befehl den neuen Tastaturbefehl zu.
Beschreibung
Enthält eine kurze Beschreibung des ausgewählten Befehls.
Verwandte Themen
Tastaturbefehle anpassen


Dialogfeld „Fehlende Schriften“

Verwenden Sie dieses Dialogfeld, um eine Ersatzschrift für die Schriften auszuwählen, die nicht auf Ihrem Computer verfügbar sind. Nachdem Sie die Ersatzschriften ausgewählt oder die Standardeinstellung übernommen haben, wird das Dokument mit diesen Schriften angezeigt.
Das Dialogfeld wird eingeblendet, wenn Sie ein Formular mit Schriften öffnen, die nicht auf Ihrem Computer installiert sind.
Schriftersetzung
Jede fehlende Schrift wird angezeigt.
Ersatzschrift ändern
Wenn Sie die Standardschrift nicht annehmen möchten, klicken Sie auf diese Schaltfläche, um eine andere Schrift zu wählen.


Dialogfeld „Schriftersetzungen ändern“

Verwenden Sie dieses Dialogfeld, um die vorgeschlagene Schriftersetzung zu akzeptieren bzw. zu ändern. Es wird die fehlende Schrift und die vorgeschlagene Ersatzschrift angezeigt.
Um dieses Dialogfeld anzuzeigen, klicken Sie auf „Extras“ > „Optionen“. Wählen Sie links im Fenster den Eintrag „Dokumentoptionen“ aus und klicken Sie dann auf „Schriftersetzungen ändern“.
Schriftersetzung
Es wird jede fehlende Schrift angezeigt und daneben die vorgeschlagene Ersatzschrift.
Ersatzschrift ändern
Wenn Sie die vorgeschlagene Ersatzschrift nicht annehmen möchten, klicken Sie auf diese Schaltfläche, um eine andere Schrift zu wählen.


Dialogfeld „Neue Datenverbindung“

Neue Datenverbindung
ADO-Eigenschaften (Dialogfeld „Neue Datenverbindung“)
OLEDB-Verbindung (Dialogfeld „Neue Datenverbindung“/„Verbindungseigenschaften“)
Muster-XML-Daten (Dialogfeld „Neue Datenverbindung“/„Verbindungseigenschaften“)
WSDL (Dialogfeld „Neue Datenverbindung“)
Wählen Sie eine Operation (Dialogfeld „Neue Datenverbindung“, WSDL)
XML-Schema (Dialogfeld „Neue Datenverbindung“/„Verbindungseigenschaften“)


Neue Datenverbindung

Verwenden Sie dieses Dialogfeld, um eine Verbindung zwischen einer Datenquelle und einem Formularentwurf zu definieren.
Um dieses Dialogfeld anzuzeigen, wählen Sie unter „Datei“ die Option „Neue Datenverbindung“ aus.
Name der neuen Verbindung
Der Name, den Sie der Datenverbindung zuweisen.
Datenbeschreibung abrufen von
Die Liste der verfügbaren Datenquellen, aus der Sie auswählen können.
Verwandte Themen
Datenquellen
So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei
So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank
So erstellen Sie eine Datenverbindung zu einer WSDL-Datei


ADO-Eigenschaften (Dialogfeld „Neue Datenverbindung“)

Verwenden Sie dieses Dialogfeld, um die Eigenschaften für die Festlegung der Merkmale der Datenbankverbindung anzugeben.
Benutzer
Gibt den zur Authentifizierung beim Verbinden mit der Datenbank verwendeten Benutzer an.
Kennwort
Gibt das zur Authentifizierung beim Verbinden mit der Datenbank verwendete Kennwort an.
Verbindungs-Timeout
Gibt an, wie lange versucht wird, eine Verbindung herzustellen, bevor der Versuch abgebrochen und eine Fehlermeldung ausgegeben wird.
Abfrage-Timeout
Gibt an, wie lange auf die Ergebnisse einer SQL-Anfrage von der Datenbank gewartet wird, bevor der Versuch abgebrochen und eine Fehlermeldung ausgegeben wird.
Verzögertes Öffnen
Ist diese Option aktiviert, stellt LiveCycle Designer beim Laden des Formulars nicht automatisch eine Verbindung zur Datenquelle her. Wählen Sie diese Option, wenn das Formular die Eingabe des Benutzers erfordert, bevor der Versuch einer Verbindungsherstellung unternommen wird. Dies ist z. B. der Fall, wenn die Eingabe einer Benutzer-ID und eines Kennworts erforderlich ist.
Cursortyp
Zeigt den Typ des Cursors an, der beim Öffnen eines Datensatzgruppenobjekts verwendet wird
Cursorposition
Zeigt die Cursorposition an. Sie können eine client- oder serverseitige Position wählen.
Sperrtyp
Gibt den Sperrtyp an, der beim Öffnen eines Formulars verwendet wird.
BOF-Aktion
Gibt an, welche Aktion ausgeführt wird, wenn zu einem Datensatz verschoben wird, der sich unterhalb des ersten Datensatzes (Dateianfang, BOF) der Datenquelle befindet. Beispiel: ungültigen Datensatz beibehalten, zum letzten gültigen Datensatz zurückgehen oder umbrechen.
EOF-Aktion
Gibt an, welche Aktion ausgeführt wird, wenn zu einem Datensatz verschoben wird, der sich unterhalb des letzten Datensatzes (Dateiende, EOF) der Datenquelle befindet. Beispiel: ungültigen Datensatz beibehalten, zum letzten gültigen Datensatz zurückgehen oder umbrechen.
Verwandte Themen
Datenquellen
So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank


OLEDB-Verbindung (Dialogfeld „Neue Datenverbindung“/„Verbindungseigenschaften“)

Verwenden Sie dieses Dialogfeld, um eine Beschreibung für die Datenverbindung zwischen OLEDB und einem Formularentwurf zur Verfügung zu stellen.
Um dieses Dialogfeld anzuzeigen, wählen Sie unter „Datei“ die Option „Neue Datenverbindung“ aus. Wählen Sie „OLEDB“ aus und klicken Sie auf „Weiter“.
Verbindungszeichenfolge
Der Name der Verbindungszeichenfolge.
Tabelle
Gibt die Tabelle an.
Gespeicherte Prozedur
Gibt die gespeicherte Prozedur an.
SQL-Abfrage
Gibt die SQL-Abfrage an.
Verwandte Themen
Datenquellen
So erstellen Sie eine Datenverbindung zu einer OLE-Datenbank


Muster-XML-Daten (Dialogfeld „Neue Datenverbindung“/„Verbindungseigenschaften“)

Verwenden Sie dieses Dialogfeld, um eine Beschreibung für die Datenverbindung zwischen den Muster-XML-Daten und einem Formularentwurf zur Verfügung zu stellen.
Um dieses Dialogfeld anzuzeigen, wählen Sie unter „Datei“ die Option „Neue Datenverbindung“ aus. Wählen Sie „Muster-XML-Daten“ und klicken Sie auf „Weiter“.
Muster-XML-Datendatei auswählen
Gibt die Position und den Namen der XML-Datei an.
Eingangsdaten umformen
Formt Eingangsdaten anhand der von Ihnen angegebenen XSLT-Datei um.
XSLT-Datei
Die XSLT-Datei, die zur Umformung (Transformation) der Eingangsdaten verwendet wird.
Ausgangsdaten umformen
Formt Ausgangsdaten anhand der von Ihnen angegebenen XSLT-Datei um.
XSLT-Datei
Die XSLT-Datei, die zur Umformung (Transformation) der ausgehenden Daten verwendet wird.
Verwandte Themen
Datenquellen
So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei


WSDL (Dialogfeld „Neue Datenverbindung“)

Verwenden Sie dieses Dialogfeld, um eine Beschreibung für die Datenverbindung zwischen der Web Service Description Language (WSDL) und einem Formularentwurf anzugeben.
Um dieses Dialogfeld anzuzeigen, wählen Sie unter „Datei“ die Option „Neue Datenverbindung“ aus. Wählen Sie „WSDL-Datei“ aus und klicken Sie auf „Weiter“.
WSDL-Datei
Gibt die Position und den Namen der WSDL-Datei an.
Verwandte Themen
Datenquellen
So erstellen Sie eine Datenverbindung zu einer WSDL-Datei


Wählen Sie eine Operation (Dialogfeld „Neue Datenverbindung“, WSDL)

Verwenden Sie dieses Dialogfeld, um den WSDL-Vorgang auszuwählen.
Wählen Sie eine Operation
Wählen Sie die im Formularentwurf zu verwendende Operation aus.
Verwandte Themen
Datenquellen
So erstellen Sie eine Datenverbindung zu einer WSDL-Datei


XML-Schema (Dialogfeld „Neue Datenverbindung“/„Verbindungseigenschaften“)

Verwenden Sie dieses Dialogfeld, um eine Beschreibung für die Datenverbindung zwischen einem XML-Schema und einem Formularentwurf anzugeben.
Um dieses Dialogfeld anzuzeigen, wählen Sie unter „Datei“ die Option „Neue Datenverbindung“ aus.
XML-Schemadatei auswählen
Gibt die Position und den Namen der XML-Schemadatei an.
XML-Daten-Stammelementname verw.
Gibt das Daten-Stammelement an, das in der Palette „Datenansicht“ angezeigt werden soll.
XML-Schema einbetten
Bettet das XML-Schema im Formularentwurf ein.
Eingangsdaten umformen
Formt Eingangsdaten anhand der von Ihnen angegebenen XSLT-Datei um.
XSLT-Datei
Die XSLT-Datei, die zur Umformung (Transformation) der Eingangsdaten verwendet wird.
Ausgangsdaten umformen
Formt Ausgangsdaten anhand der von Ihnen angegebenen XSLT-Datei um.
XSLT-Datei
Die XSLT-Datei, die zur Umformung (Transformation) der ausgehenden Daten verwendet wird.
Verwandte Themen
Datenquellen
So erstellen Sie eine Datenverbindung zu einem XML-Schema und einer XML-Datendatei


Dialogfeld „Neu“

Verwenden Sie dieses Dialogfeld, um ein neues Formular zu erstellen, ein neues Formular aus einer Vorlage zu erstellen oder ein vorhandenes Musterformular zu öffnen. Sie können auch die Muster-Formularvorlagen ansehen.
Um dieses Dialogfeld anzuzeigen, während der Assistent für neue Formulare deaktiviert ist, wählen Sie „Datei“ > „Neu“. Alternativ können Sie auch im Begrüßungsbildschirm auf „Neues Formular“ klicken oder die Option zum Erstellen eines neuen Formulars anhand einer Vorlage auswählen.
Registerkarte „Standard“
Zeigt die verfügbaren Papierformate für das neue Formular an.
Registerkarte „Muster“
Zeigt verfügbare Muster-Formularentwürfe an.
Registerkarte „Eigene“
Zeigt verfügbare benutzerdefinierte Formularentwürfe an.
Auswahl als Standard definieren
Stellt die Standardgröße für neue Formularentwürfe ein.
Erstellen
Gibt an, ob ein neues Formular oder eine neue Vorlage erstellt wird.
Verwandte Themen
So erstellen Sie Formularentwürfe ohne den Assistenten für neue Formulare


Dialogfeld „Öffnen“

Verwenden Sie dieses Dialogfeld, um einen vorhandenen Formularentwurf oder eine Vorlage zu öffnen. Sie können Dokumente in verschiedenen Formaten öffnen. Nach dem Öffnen in LiveCycle Designer werden die Dokumente in das Dateiformat XDP umgewandelt.
Zum Anzeigen dieses Dialogfeldes wählen Sie „Datei“ > „Öffnen“.
Suchen in
Gibt die Stelle an, an der Sie eine Datei oder einen Ordner speichern möchten.
Dateiname
Zeigt den Dateinamen an. Der Name wird beim Erstellen der Vorlage erzeugt.
Dateityp
Listet die verfügbaren Dateitypen auf, die Sie öffnen können.
Verwandte Themen
So öffnen Sie Formularentwürfe und andere Dateien


Dialogfeld „Optionen“

Bidirektionaler Text (Dialogfeld „Optionen“)
Datenbindung (Dialogfeld „Optionen“)
Dokumentoptionen (Dialogfeld „Optionen“)
Assistenten und Tipps (Dialogfeld „Optionen“)
Arbeitsbereich (Dialogfeld „Optionen“)
Rechtschreibung (Dialogfeld „Optionen“)
International (Dialogfeld „Optionen“)


Bidirektionaler Text (Dialogfeld „Optionen“)

Verwenden Sie dieses Dialogfeld, um während des Entwurfs logische oder visuelle Cursorbewegung festzulegen. Die Standardeinstellung lautet „Logisch“. Klicken Sie zum Öffnen dieses Dialogfeldes auf „Extras“ > „Optionen“ und wählen Sie dann links im Fenster den Eintrag „Bidirektionaler Text“ aus.
Logisch
Verschiebt die Einfügemarke im bidirektionalen Text entsprechend der Richtung des jeweiligen Textes. Wenn Sie beispielsweise mit den Pfeiltasten durch einen arabischen Text blättern, der auch deutsche Zahlen enthält, wird der Cursor im arabischen Teil mit dem Nach-rechts-Pfeil von rechts nach links, im deutschen Teil jedoch von links nach rechts verschoben. Die Option „Logisch“ gilt für Dialogfelder, Paletten, den Skripteditor und die XML-Quelle.
Visuell
Die Einfügemarke wird im bidirektionalen Text zum visuell am nächsten gelegenen Zeichen verschoben. Wenn Sie beispielsweise mit den Pfeiltasten durch arabischen Text blättern, der auch deutsche Zahlen enthält, wird der Cursor unabhängig von der Textrichtung mit dem Nach-links-Pfeil von rechts nach links verschoben. Die Option „Visuell“ ändert die Cursorbewegung nur in der Designansicht und auf den Masterseiten. Sie gilt nicht für Dialogfelder, Paletten, den Skripteditor und die XML-Quelle.
Verwandte Themen
So richten Sie Objekte für Arabisch und Hebräisch ein
So richten Sie Objekte für Thailändisch und Vietnamesisch ein


Datenbindung (Dialogfeld „Optionen“)

Verwenden Sie dieses Dialogfeld, um aktive Beschriftungen ein- bzw. auszuschalten, die Standardfarbe für die aktiven Beschriftungen festzulegen sowie die Standardbindung für neue Teilformulare anzugeben.
Um dieses Dialogfeld anzuzeigen, wählen Sie „Extras“ > „Optionen“ und klicken dann links im Fenster auf „Datenbindung“.
Dynamische Eigenschaften anzeigen
Blendet die aktiven Beschriftungen für dynamische Eigenschaften ein bzw. aus. Aktive Beschriftungen zeigen an, welche Eigenschaften dynamisch sein können. Sie werden grün und unterstrichen dargestellt. Wenn Sie auf eine solche Eigenschaft klicken, können Sie sie dynamisch an eine Datenquelle binden.
Benutzerdefinierte Beschriftungsfarbe verwenden
Ermöglicht die Auswahl einer Standardfarbe für aktive Beschriftungen.
Benutzerdefinierte Beschriftungsfarbe
Öffnet die Farbpalette, in der Sie die gewünschte Farbe für die aktiven Beschriftungen auswählen können.
Standardbindung für neue Teilformulare
Legt die Standardbindung für neue Teilformulare fest.
    • Normal
Legt die Optionen zum Zusammenführen von Daten und zum Speichern fest. Die Datenwerte werden den Adobe-Regeln zur Datenzusammenführung entsprechend zusammengeführt und gespeichert.
    • Ohne
Deaktiviert die Optionen zum Zusammenführen und Speichern von Daten für neue Teilformulare. Bei Auswahl dieser Option wird bei neuen Teilformularen standardmäßig keine Datenzusammenführung vorgenommen.
Verwandte Themen
So legen Sie dynamische Eigenschaften fest


Dokumentoptionen (Dialogfeld „Optionen“)

Verwenden Sie dieses Dialogfeld, um den Standarddateityp für neue Formulare, die Einstellung für die Liste der zuletzt verwendeten Dateien, die Komprimierungs- und Sicherungsoptionen, die Optionen für den Bilddatei-Browser und die Optionen für die Schriftersetzung festzulegen.
Klicken Sie zum Anzeigen dieses Dialogfeldes auf „Extras“ > „Optionen“ und wählen Sie dann links im Fenster den Eintrag „Dokumentoptionen“ aus.
Standarddateityp für neue Formulare
Legt den Standarddateityp für neue Formulare fest. Diese Einstellung wirkt sich auf das Dialogfeld „Speichern unter“ und auf das auf der Registerkarte „PDF-Vorschau“ verwendete Dateiformat aus, falls das Formular bisher noch nicht gespeichert wurde.
    • Acrobat 8 (Statisch) PDF-Formular
Neue Formulare werden standardmäßig als mit Acrobat Version 8.0 kompatible statische Formulare erstellt. Der Formularentwurf kann daher nur statische Elemente enthalten. Wenn das Formular z. B. 10 Zeilen zur Dateneingabe hat, es aber Daten für 25 Zeilen gibt, können nur 10 Zeilen ausgefüllt werden. Gleichermaßen werden 10 Zeilen angezeigt, auch wenn nur 2 Zeilen Daten enthalten. 2 Zeilen sind dann ausgefüllt, und 8 Zeilen sind leer.
    • Acrobat 8 (Dynamisch) XML-Formular
Neue Formulare werden standardmäßig als mit Acrobat Version 8.0 kompatible dynamische Formulare erstellt. Der Formularentwurf kann dynamische Elemente enthalten. Beispielsweise kann es sich bei dem Formularentwurf um ein interaktives Formular handeln, das es den Anwendern gestattet, Elementzeilen hinzuzufügen oder zu entfernen.
    • Acrobat 7 (Statisch) PDF-Formular
Neue Formulare werden standardmäßig als mit Acrobat Version 7.0 kompatible statische Formulare erstellt. Der Formularentwurf kann daher nur statische Elemente enthalten. Wenn das Formular z. B. 10 Zeilen zur Dateneingabe hat, es aber Daten für 25 Zeilen gibt, können nur 10 Zeilen ausgefüllt werden. Gleichermaßen werden 10 Zeilen angezeigt, auch wenn nur 2 Zeilen Daten enthalten. 2 Zeilen sind dann ausgefüllt, und 8 Zeilen sind leer.
    • Acrobat 7 (Dynamisch) XML-Formular
Neue Formulare werden standardmäßig als mit Acrobat Version 7.0 kompatible dynamische Formulare erstellt. Der Formularentwurf kann dynamische Elemente enthalten. Beispielsweise kann es sich bei dem Formularentwurf um ein interaktives Formular handeln, das es den Anwendern gestattet, Elementzeilen hinzuzufügen oder zu entfernen.
    • Acrobat 6 (Statisch) PDF-Formular
Neue Formulare werden standardmäßig als mit Acrobat Version 6 kompatible (statische) PDF-Dokumente erstellt. Vewenden Sie diese Option, wenn die potenziellen Formularempfänger nur über Acrobat 6.0 verfügen. Der Formularentwurf kann nur statische Elemente enthalten. Ferner können keine Papierformular-Barcodes hinzugefügt werden.
    • Adobe XML-Formulardatei (XDP)
Neue Formulare werden standardmäßig als mit LiveCycle Designer erstellte Dateien im XML-Format erstellt. Verwenden Sie diese Option, wenn Sie mit LiveCycle Forms arbeiten. Der Formularentwurf kann dynamische Elemente enthalten. Mit der Einstellung „XDP-Vorschauformat“ auf der Registerkarte „Standard“ (im Dialogfeld „Formulareigenschaften“) wird das für die PDF-Vorschau dieses Dateityps verwendete Format bestimmt.
Liste zuletzt verwendeter Dateien
Bestimmt die Anzahl der in der Liste der zuletzt verwendeten Dateien angezeigten Dokumente. Geben Sie einen Wert ein. Die Höchstanzahl ist 10.
PDF-Dateien komprimiert speichern
Komprimiert PDF-Dateien beim Speichern.
Beim Speichern Sicherungskopie erstellen
Erstellt beim Speichern des Formularentwurfs eine Sicherungsdatei. Die Sicherungskopie wird im selben Ordner wie der Formularentwurf abgelegt. An den Dateinamen wird die Sequenz „_BAK“ vor der Erweiterung angehängt. Durch die Sicherungskopie bleibt beim erneuten Speichern die vorherige Version der Datei erhalten, falls Sie diese noch einmal benötigen.
Standard-Dateibrowser anzeigen
Legt fest, welcher Browser standardmäßig verwendet wird. Sie können eine externe COM-Komponente (wie zum Beispiel einen Dateibrowser) laden, die ein besonderes Repository durchsucht. Falls eine solche Komponente auf dem Computer registriert ist, wird sie von LiveCycle Designer erkannt und in dieser Liste aufgeführt.
Schriftersetzungen ändern
Legt Ersatzschriften für Dokumente fest, deren Schriften auf dem Computer fehlen.
Dialogfeld „Fehlende Schriften“ nur anzeigen, wenn keine Ersatzschrift festgelegt ist
Ruft das Dialogfeld „Fehlende Schriften“ auf, wenn für mindestens eine Schrift keine Ersatzschrift festgelegt wurde.
Verwandte Themen
Ansätze zum Erstellen von Formularentwürfen


Assistenten und Tipps (Dialogfeld „Optionen“)

Verwenden Sie dieses Dialogfeld, um Tipps in Dialogfeldern, Warnmeldungen und den Willkommensbildschirm zu aktivieren bzw. zu deaktivieren.
Um dieses Dialogfeld anzuzeigen, wählen Sie unter „Extras“ die Option „Optionen“ und anschließend in der Liste auf der linken Seite „Assistenten und Tipps“ aus.
Alle Tipp-Dialogfelder zurücksetzen
Zeigt Dialogfelder mit Tipps an. Diese Dialogfelder bieten weitere Informationen zu der gerade in LiveCycle Designer durchgeführten Aktion. Falls Sie in einem Tipp das Kontrollkästchen „Diesen Tipp nicht mehr anzeigen“ aktiviert haben und diese Einstellung rückgängig machen möchten, klicken Sie auf „Alle Tipp-Dialogfelder zurücksetzen“.
Alle Warndialogfelder zurücksetzen
Zeigt Warndialogfelder an, wenn ein Fehler auftritt.
Willkommensbildschirm anzeigen
Zeigt beim Starten von LiveCycle Designer das Begrüßungsfenster an.
Warnungsmarken vor Ort anzeigen
Zeigt Warnungsmarken wie ein gelbes Dreieck oder ein weißes Kreuz in einem roten Kreis an, wenn bei einem Objekt ein Problem vorliegt.
Wenn Wertebereich zu klein ist
Zeigt eine Warnungsmarke [image] an, wenn der längste für das Feld zulässige Wert nicht ganz im Wertebereich angezeigt werden kann. Wenn das Feld beispielsweise 7 mal 1,5 cm groß ist bei einer Feldlänge von maximal 50 Zeichen, dann passen zur Laufzeit unter Umständen nicht alle Zeichen in den Wertebereich. Sie müssen dann die Breite des Wertebereichs an den Feldwert anpassen.
LiveCycle Designer überprüft das Feld, um festzustellen, ob der Wertebereich groß genug ist, um den Wert zur Laufzeit anzuzeigen. Unter folgenden Umständen wird eine Warnungsmarke von LiveCycle Designer ausgegeben:
      •
      Wenn für das Feld eine Schrift mit fester Breite bzw. eine nicht proportionale Schrift (wie Courier oder LetterGothic) verwendet wird. Bei proportionalen Schriften (wie Times New Roman) kann das Feld in LiveCycle Designer nicht ausgewertet werden, da viele i-Zeichen beispielsweise in den Platz für ein W passen. Bei Schriften mit fester Breite kann die Größe des Wertebereichs besser von LiveCycle Designer eingeschätzt werden.
Stellen Sie daher sicher, dass die Schrift von LiveCycle Designer als Schrift mit fester Breite oder als nicht proportionale Schrift erkannt wird. Sie können dies beispielsweise mit einem bewusst zu klein festgelegten Feld testen.
      •
      Wenn für das Feld auf der Palette „Layout“ in den Feldern „Breite“ und „Höhe“ Werte für eine feste Abmessung eingegeben wurden.
      •
      Wenn die Länge des Feldes durch eine bestimmte Anzahl von Zeichen oder Ziffern begrenzt ist. Eine solche Begrenzung kann auf der Registerkarte „Feld“ der Palette „Objekt“ festgelegt werden.
      •
      Für das Feld wurde weder ein Daten- noch ein Anzeigemuster definiert.
Falls es sich bei dem Feld um eine Tabellenzelle handelt, wird keine Warnungsmarke angezeigt.
Beim Erstellen neuer Dokumente anzeigen
Zeigt den Assistenten für neue Formulare an, wenn ein neuer Formularentwurf erstellt wird.
Beim Importieren von Dokumenten anzeigen
Zeigt den Assistenten für neue Formulare an, wenn eine Datei importiert wird.
Beim Importieren von PDF-Dokumenten aus Adobe anzeigen
Zeigt den Assistenten für neue Formulare an, wenn eine PDF-Datei aus Acrobat heraus geöffnet wird. Diese Option wird ignoriert, wenn Sie die PDF-Datei direkt in LiveCycle Designer öffnen.
Beim Erstellen von Tabellen anzeigen
Öffnet das Dialogfeld „Tabelle einfügen“, wenn Sie eine neue Tabelle mit dem Tabellenobjekt in der Palette „Bibliothek“ erstellen. Über dieses Dialogfeld können Sie den Tabellenassistenten aufrufen.


Arbeitsbereich (Dialogfeld „Optionen“)

Verwenden Sie dieses Dialogfeld, um QuickInfos für Objekte zu aktivieren bzw. zu deaktivieren, Optionen für den Skript-Editor festzulegen und Ansichtseinstellungen für die Quelle zu definieren.
Wenn Sie dieses Dialogfeld anzeigen möchten, wählen Sie „Extras“ > „Optionen“ und dann auf der linken Seite den Eintrag „Arbeitsbereich“ aus.
QuickInfos zu Position und Größe beim Bearbeiten anzeigen
Zeigt QuickInfos zu Position und Größe an.
QuickInfos zu Objektnamen beim Zeigen einblenden
Blendet die QuickInfo für ein Objekt ein, wenn Sie mit der Maus darauf zeigen.
Objekte mit fester Größe beim Bearbeiten automatisch einpassen
Passt Textobjekte mit einer festgelegten Höhe und Breite an die Textmenge an, wenn die Optionen für „Passend erweitern“ deaktiviert sind.
FormCalc-Syntaxformatierung
Zeigt die Einstellungen für Schrift und Farbe der FormCalc-Syntax im Script-Editor an.
JavaScript-Syntaxformatierung
Zeigt die Einstellungen für Schrift und Farbe der JavaScript-Syntax im Script-Editor an.
Anweisungsende-Optionen anzeigen
Zeigt die Optionen zum Abschluss von Anweisungen im Skript-Editor an.
Zeilennummern anzeigen
Zeigt die Zeilennummer im Skript-Editor an.
Syntaxformatierung der XML-Quelle
Zeigt die Einstellungen für Schrift und Farbe für die XML-Syntax in der XML-Ausgangsseite an.
Zeilennummern anzeigen
Zeigt die Zeilennummer in der XML-Ausgangsseite an.
LiveCycle Designer 8.0 als Standard festlegen
Legt LiveCycle Designer 8.0 als die Standardversion fest. Die Standardversion ist die registrierte Version von LiveCycle Designer. Wenn eine ältere Version auf Ihrem System installiert ist und Sie diese starten, wird die ältere Version automatisch registriert und wird zur Standardversion.
LiveCycle Designer prüft beim Start, ob er als Standard-Designer festgelegt wurde
Überprüft beim Starten der Anwendung, ob LiveCycle Designer 8.0 die Standardversion ist. Wenn diese Version nicht die Standardversion ist, können Sie sie als Standard festlegen.
Verwandte Themen
Der Skript-Editor
QuickInfo anpassen
Dialogfeld „Syntaxformatierung“


Rechtschreibung (Dialogfeld „Optionen“)

Verwenden Sie dieses Dialogfeld, um verschiedene Optionen auszuwählen: Rechtschreibprüfung während der Eingabe, Steuerung des Texttyps, den LiveCycle Designer auf Rechtschreibfehler untersucht, Hinzufügen und Entfernen von benutzerdefinierten Wörterbüchern und Öffnen des Dialogfeldes „Wörterbuch bearbeiten“, um Ihr benutzerdefiniertes Wörterbuch zu bearbeiten.
Um dieses Dialogfeld anzuzeigen, wählen Sie unter „Extras“ den Eintrag > „Optionen“ und anschließend in der Liste auf der linken Seite „Rechtschreibung“ aus.
Rechtschreibung während Eingabe prüfen
Aktiviert die Rechtschreibprüfung während der Eingabe. Wenn diese Option ausgewählt ist, wird unter falsch geschriebenen Wörtern in LiveCycle Designer eine geschlängelte, farbige Linie angezeigt.
Unterstreichungsfarbe
Öffnet eine Farbpalette, in der der Benutzer eine andere Farbe für die Unterstreichung falsch geschriebener Wörter auswählen kann. Die Standardfarbe ist rot.
Rechtschreibprüfung
Listet die Texttypen in einem Formular auf, von dem LiveCycle Designer eine Rechtschreibprüfung durchführen kann, wenn Sie das Dialogfeld „Rechtschreibprüfung“ verwenden. Alle Optionen sind standardmäßig ausgewählt.
Installierte Wörterbücher
Listet die Wörterbücher auf, die für die Rechtschreibprüfung zur Verfügung stehen. LiveCycle Designer verwendet bei der Rechtschreibprüfung eines Formulars die ausgewählten Wörterbücher. Das erste Wörterbuch in der Liste ist immer das benutzerdefinierte Wörterbuch des aktuellen Benutzers („Mein benutzerdefiniertes Wörterbuch“). Dieses Wörterbuch ist immer für die Verwendung ausgewählt und kann nicht aus der Liste entfernt werden.
Wörterbuch hinzufügen
Öffnet das Dialogfeld „Benutzerdefinierte Wörterbuchdatei“, aus der Sie die benutzerdefinierten Wörterbuchdateien (*.clam) auswählen können, die Sie zur Wörterbuchliste hinzufügen möchten.
Wörterbuch entfernen
Entfernt das ausgewählte Wörterbuch aus der Liste der installierten Wörterbücher. Die Option löscht jedoch nicht die Wörterbuchdatei (*.clam) aus dem Dateisystem Ihres Computers.
Benutzerdefiniertes Wörterbuch bearbeiten
Öffnet das Dialogfeld „Wörterbuch bearbeiten“, in dem Sie die Wortliste, die in „Mein benutzerdefiniertes Wörterbuch“ unter den einzelnen oder unter allen Sprachen verfügbar ist, anzeigen, die Rechtschreibung eines aufgelisteten Worts ändern sowie Wörter in einzelnen Sprachen oder in allen Sprachen hinzufügen bzw. Wörter aus einzelnen Sprachen oder allen Sprachen löschen können. Sie können den Inhalt der anderen installierten Wörterbücher nicht bearbeiten.


International (Dialogfeld „Optionen“)

Verwenden Sie dieses Dialogfeld, um die Sprache für die Anwendung auszuwählen. Sie müssen LiveCycle Designer erneut starten, damit die Änderung der Sprache übernommen wird.
Um dieses Dialogfeld anzuzeigen, wählen Sie unter „Extras“ die Option „Optionen“ und anschließend „International“ in der Liste auf der linken Seite aus.
Sprache
Listet die für die Anwendung verfügbaren Sprachen auf.
Zeigt Maßeinheiten im Standardgebietsschema der Anwendung an.
Zeigt Maßeinheiten gemäß dem Gebietsschema der Anwendung an.


Dialogfeld „Drucken“

Verwenden Sie das Dialogfeld „Drucken“, um die Optionen für Ihren Drucker einzustellen.
Die Optionen im Dialogfeld „Drucken“ hängen von dem an Ihren Computer angeschlossenen Drucker ab. Weitere Informationen zu den Druckoptionen finden Sie in der Druckerdokumentation.


Dialogfeld „In Repository veröffentlichen“

Verwenden Sie dieses Dialogfeld, um einen Formularentwurf und die ihm zugeordneten Dateien in einem gemeinsamen oder in einem Webordner abzulegen, wo er von vielen Benutzern oder anderen Anwendungen aufgerufen werden kann. Falls das Formular beim Veröffentlichen des Formularentwurfs und der Dateien einen Link zu einer externen Datei enthält, wird die Liste im Formularentwurf geändert, so dass sie die neue Position der Datei anzeigt.
Zum Anzeigen dieses Dialogfeldes wählen Sie „Datei“ > „In Repository veröffentlichen“.
Speichern in
Gibt die Position an, an der das Formular veröffentlicht werden soll.
Dateiname
Zeigt den Dateinamen an.
Dateityp
Führt die Dateitypen auf, die Sie veröffentlichen können.
    • Acrobat 8 (Statisch) PDF-Formular (*.pdf)
Veröffentlicht Formulare als mit Acrobat Version 8.0 kompatible statische Dateien. Der Formularentwurf kann daher nur statische Elemente enthalten. Wenn das Formular z. B. 10 Zeilen zur Dateneingabe hat, es aber Daten für 25 Zeilen gibt, können nur 10 Zeilen ausgefüllt werden. Gleichermaßen werden 10 Zeilen angezeigt, auch wenn nur 2 Zeilen Daten enthalten. 2 Zeilen sind dann ausgefüllt, und 8 Zeilen sind leer.
    • Acrobat 8 (Dynamisch) XML-Formular (*.pdf)
Veröffentlicht Formulare als mit Acrobat Version 8.0 kompatible dynamische Dateien. Der Formularentwurf kann dynamische Elemente enthalten. Beispielsweise kann es sich bei dem Formularentwurf um ein interaktives Formular handeln, das es den Anwendern gestattet, Elementzeilen hinzuzufügen oder zu entfernen.
    • Acrobat 7 (Statisch) PDF-Formular (*.pdf)
Veröffentlicht Formulare als mit Acrobat Version 7.0 kompatible statische Dateien. Der Formularentwurf kann daher nur statische Elemente enthalten. Wenn das Formular z. B. 10 Zeilen zur Dateneingabe hat, es aber Daten für 25 Zeilen gibt, können nur 10 Zeilen ausgefüllt werden. Gleichermaßen werden 10 Zeilen angezeigt, auch wenn nur 2 Zeilen Daten enthalten. 2 Zeilen sind dann ausgefüllt, und 8 Zeilen sind leer.
    • Acrobat 7 (Dynamisch) XML-Formular (*.pdf)
Veröffentlicht Formulare als mit Acrobat Version 7.0 kompatible dynamische Dateien. Der Formularentwurf kann dynamische Elemente enthalten. Beispielsweise kann es sich bei dem Formularentwurf um ein interaktives Formular handeln, das es den Anwendern gestattet, Elementzeilen hinzuzufügen oder zu entfernen.
    • Acrobat 6 (Statisch) PDF-Formular (*.pdf)
Veröffentlicht Formulare als mit Acrobat Version 6 kompatible (statische) PDF-Dateien. Vewenden Sie diese Option, wenn die potenziellen Formularempfänger nur über Acrobat 6.0 verfügen. Der Formularentwurf kann nur statische Elemente enthalten. Ferner können keine Papierformular-Barcodes hinzugefügt werden.
    • Adobe XML-Formular (*.xdp)
Veröffentlicht Formulare im von LiveCycle Designer erstellten XML-basierten Dateiformat. Verwenden Sie diese Option, wenn Sie mit LiveCycle Forms arbeiten. Der Formularentwurf kann dynamische Elemente enthalten.
Eingabehilfedaten (Tags) für Acrobat erzeugen
Umfasst die Informations-Tags für Eingabehilfen in der PDF-Datei.
Protokolldatei beim Speichern erstellen
Erstellt eine Protokolldatei im gleichen Ordner, in dem sich die PDF-Datei befindet. Diese Option steht nur beim Veröffentlichen im PDF-Format zur Verfügung.
Nicht verfügbare Schriften dauerhaft ersetzen
Ersetzt nicht verfügbare Schriften durch verfügbare Schriften. Diese Option steht nur beim Veröffentlichen im PDF-Format zur Verfügung.
Schriften einbetten
Bettet die Formularschriften in den gespeicherten Formularentwurf ein. Diese Option steht nur beim Veröffentlichen im PDF-Format zur Verfügung.
Verwandte Themen
So veröffentlichen Sie ein Formular in einem Repository


Dialogfeld „Speichern unter“

Verwenden Sie dieses Dialogfeld, um einen Formularentwurf oder eine Vorlage unter dem aktuellem Namen und am aktuellen Speicherort zu speichern bzw. um eine Kopie unter einem anderen Namen oder an einem anderen Speicherort zu speichern.
Zum Anzeigen dieses Dialogfeldes wählen Sie „Datei“ > „Speichern unter“.
Speichern in
Gibt die Stelle an, an der Sie eine Datei oder einen Ordner speichern möchten.
Dateiname
Zeigt den Dateinamen an. Der Name wird beim Erstellen des Formularentwurfs erzeugt.
Dateityp
Listet die verfügbaren Dateitypen auf, die Sie speichern können.
    • Acrobat 8 (Statisch) PDF-Formular (*.pdf)
Speichert Formulare als mit Acrobat Version 8.0 kompatible statische Dateien. Der Formularentwurf kann daher nur statische Elemente enthalten. Wenn das Formular z. B. 10 Zeilen zur Dateneingabe hat, es aber Daten für 25 Zeilen gibt, können nur 10 Zeilen ausgefüllt werden. Gleichermaßen werden 10 Zeilen angezeigt, auch wenn nur 2 Zeilen Daten enthalten. 2 Zeilen sind dann ausgefüllt, und 8 Zeilen sind leer.
    • Acrobat 8 (Dynamisch) XML-Formular (*.pdf)
Speichert Formulare als mit Acrobat Version 8.0 kompatible dynamische Dateien. Der Formularentwurf kann dynamische Elemente enthalten. Beispielsweise kann es sich bei dem Formularentwurf um ein interaktives Formular handeln, das es den Anwendern gestattet, Elementzeilen hinzuzufügen oder zu entfernen.
    • Acrobat 7 (Statisch) PDF-Formular (*.pdf)
Speichert Formulare als mit Acrobat Version 7.0 kompatible statische Dateien. Der Formularentwurf kann daher nur statische Elemente enthalten. Wenn das Formular z. B. 10 Zeilen zur Dateneingabe hat, es aber Daten für 25 Zeilen gibt, können nur 10 Zeilen ausgefüllt werden. Gleichermaßen werden 10 Zeilen angezeigt, auch wenn nur 2 Zeilen Daten enthalten. 2 Zeilen sind dann ausgefüllt, und 8 Zeilen sind leer.
    • Acrobat 7 (Dynamisch) XML-Formular (*.pdf)
Speichert Formulare als mit Acrobat Version 7.0 kompatible dynamische Dateien. Der Formularentwurf kann dynamische Elemente enthalten. Beispielsweise kann es sich bei dem Formularentwurf um ein interaktives Formular handeln, das es den Anwendern gestattet, Elementzeilen hinzuzufügen oder zu entfernen.
    • Acrobat 6 (Statisch) PDF-Formular (*.pdf)
Speichert Formulare als mit Acrobat Version 6 kompatible (statische) PDF-Dateien. Vewenden Sie diese Option, wenn die potenziellen Formularempfänger nur über Acrobat 6.0 verfügen. Der Formularentwurf kann nur statische Elemente enthalten. Ferner können keine Papierformular-Barcodes hinzugefügt werden.
    • Adobe XML-Formular (*.xdp)
Speichert Formulare im von LiveCycle Designer erstellen XML-basierten Dateiformat. Verwenden Sie diese Option, wenn Sie mit LiveCycle Forms arbeiten. Der Formularentwurf kann dynamische Elemente enthalten.
    • Adobe LiveCycle Designer Vorlage (*.tds)
Speichert die Grundstruktur eines Formulars als Vorlage. Eine Vorlage kann Komponenten und verschiedene Einstellungen wie z. B. Schriften, das Seitenlayout, die Formatierung und Skripten enthalten. Sie ist ein guter Ausgangspunkt für neue Formulare.
Eingabehilfedaten (Tags) für Acrobat erzeugen
Bettet die Informationen zu Eingabehilfen innerhalb der gespeicherten PDF-Datei ein. Diese Option steht nur beim Veröffentlichen im PDF-Format zur Verfügung.
Protokolldatei beim Speichern erstellen
Erstellt eine Protokolldatei der gespeicherten Datei. Die Protokolldatei wird in demselben Ordner wie das gespeicherte Formular abgelegt. Diese Option steht nur beim Veröffentlichen im PDF-Format zur Verfügung.
Nicht verfügbare Schriften dauerhaft ersetzen
Ersetzt nicht verfügbare Schriften durch verfügbare Schriften.
Schriften einbetten
Bettet die Formularschriften in den gespeicherten Formularentwurf ein. Diese Option steht nur beim Veröffentlichen im PDF-Format zur Verfügung.
Verwandte Themen
So speichern Sie Formularentwürfe
So speichern Sie eine Kopie eines Formularentwurfs


Dialogfeld „Daten unterschreiben und Einstellungen senden“

Registerkarte „Daten unterschreiben“ (Dialogfeld „Daten unterschreiben und Einstellungen senden“)
Dieses Dialogfeld enthält die gleichen Registerkarten wie das Dialogfeld „Dokumentunterschrifts-Einstellungen“, mit der Ausnahme, dass es die Registerkarte „Daten unterschreiben“ statt der Registerkarte „Gründe für Unterschrift“ enthält.
Weitere Informationen zu den Registerkarten in diesem Dialogfeld finden Sie unter Dialogfeld „Dokumentunterschrifts-Einstellungen“.


Zurück Weiter

Menü, Befehl, Werkzeugleiste und Dialogfeld Referenz > Dialogfeld-Referenz > Dialogfeld „Daten unterschreiben und Einstellungen senden“ > Registerkarte „Daten unterschreiben“ (Dialogfeld „Daten unterschreiben und Einstellungen senden“)

Registerkarte „Daten unterschreiben“ (Dialogfeld „Daten unterschreiben und Einstellungen senden“)

Auf dieser Registerkarte können Sie die Daten auswählen, die in einer Datenunterschrift enthalten sind, die mit einer Senden-Schaltfläche verknüpft ist. Die Unterschrift kann entweder den Standarddatensatz oder alle Daten enthalten.
Führen Sie zum Anzeigen dieser Registerkarte einen der folgenden Schritte aus:
      •
      Wählen Sie eine Senden-Schaltfläche aus, klicken Sie in der Palette „Objekt“ auf die Registerkarte „Senden“, stellen Sie sicher, dass die Option „Sendung unterschreiben“ ausgewählt ist, klicken Sie auf „Einstellungen“ und anschließend auf die Registerkarte „Daten unterschreiben“.
      •
      Wählen Sie eine E-Mail- oder HTTP-Senden-Schaltfläche aus, stellen Sie sicher, dass in der Palette „Objekt“ die Option „Sendung unterschreiben“ ausgewählt ist, klicken Sie auf „Einstellungen“ und anschließend auf die Registerkarte „Daten unterschreiben“.
Nur Daten unterschreiben
Erstellt eine Unterschrift, die nur die Formulardaten in der Sendung umfasst. Diese Option ist die Standardeinstellung.
Gesamte Sendung unterschreiben
Erstellt eine Unterschrift, die die Formulardaten und die enthaltenen Anhänge umfasst, wie z. B. den Formularentwurf, die Dokumentunterschrift oder Anmerkungen.
Verwandte Themen
E-Mail-Senden-Schaltflächen – Übersicht
HTTP-Senden-Schaltflächen – Übersicht
Info über das Senden von Daten mit Hilfe einer Schaltfläche
So fügen Sie eine Datenunterschrift zu einer Senden-Schaltfläche hinzu


Dialogfeld „Ersatzschrift festlegen“

Verwenden Sie dieses Dialogfeld zur Auswahl einer Ersatzschrift für die fehlende Schrift.
Um dieses Dialogfeld anzuzeigen, klicken Sie auf „Extras“ > „Optionen“. Wählen Sie links im Fenster den Eintrag „Dokumentoptionen“ aus und klicken Sie dann auf „Schriftersetzungen ändern“. Klicken Sie auf „Ersatzschrift ändern“.
Fehlende Schrift
Der Name der Schrift, die nicht auf Ihrem Computer installiert ist.
Verfügbare Schriften
Eine Liste der Schriften, aus denen Sie eine Ersatzschrift wählen können.
Schriftschnitt
Die verfügbaren Schriftschnitte für die ausgewählte Ersatzschrift.


Dialogfeld „Syntaxformatierung“

Verwenden Sie das jeweilige Dialogfeld für die Syntaxformatierung, um die Schrift- und Farbeinstellungen für die FormCalc-, JavaScript- und die XML-Quellcode-Syntax festzulegen.
Um arabische, hebräische, thailändische oder vietnamesische Zeichen im Skript-Editor oder auf der Registerkarte „XML-Quelle“ anzeigen zu können, müssen sie die von LiveCycle Designer im Skript-Editor und im XML-Quellcode verwendeten Schrifteinstellungen anpassen. Andernfalls werden an Stelle der landesspezifischen Zeichen in LiveCycle Designer nur kleine Kästchen angezeigt. Wählen Sie beispielsweise für Arabisch die Schrift „Adobe Arabic“, für Hebräisch „Adobe Hebrew“, für Thai „Adobe Thai“ und für Vietnamesisch „Myriad Pro“ oder „Minion Pro“ aus.
Um dieses Dialogfeld anzuzeigen, klicken Sie auf „Extras“ > „Optionen“. Wählen Sie links im Fenster den Eintrag „Arbeitsbereich“ aus und klicken Sie dann auf eine der Schaltflächen für die Syntaxformatierung.
Schrift
Legt die Schrift fest.
Format
Legt die Schriftgröße fest.
Farbeinstellungen
Legt die Kategorie fest, die Sie ändern möchten.
Benutzerdefinierte Textfarbe verwenden
Legt die Farbe für die Zeichen fest.
Benutzerdefinierte Hintergrundfarbe verwenden
Legt die Hintergrundfarbe fest.
Beispiel
Zeigt ein Beispiel zu Ihren Einstellungen an.
Standard wiederherstellen
Setzt die Schrift- und Farbeinstellungen auf die Standardeinstellungen zurück.
Verwandte Themen
Der Skript-Editor
So zeigen Sie arabische, hebräische, thailändische und vietnamesische Zeichen an


Dialogfeld „Tabellenassistent“

Textkörperlayout (Dialogfeld „Tabellenassistent“)
Fußzeile (Dialogfeld „Tabellenassistent“)
Kopfzeile (Dialogfeld „Tabellenassistent“)
Zeilenschattierung (Dialogfeld „Tabellenassistent“)
Abschnitte (Dialogfeld „Tabellenassistent“)


Textkörperlayout (Dialogfeld „Tabellenassistent“)

Verwenden Sie dieses Dialogfeld, um entweder eine Tabelle mit einer festen Anzahl von Textzeilen und Spalten oder eine Tabelle mit einer dynamischen Anzahl von Textzeilen und einer festen Anzahl von Spalten zu erstellen.
Klicken Sie zum Anzeigen dieses Dialogfeldes auf „Einfügen“ > „Standard“ > „Tabelle“ > „Tabelle mit Assistenten erstellen“ > „OK“.
Textkörper hat feste Größe
Erstellt eine Tabelle mit der ausgewählten (festen) Anzahl von Textzeilen und Spalten.
Spaltenanzahl
Fügt die angegebene Anzahl von Spalten (maximal 20) hinzu.
Textzeilenanzahl
Fügt die angegebene Anzahl von Textzeilen (maximal 50) hinzu.
Textzeilen sind von Daten abhängig
Erstellt eine Tabelle, bei der die Anzahl der Zeilen durch die Anzahl der Zeilen in der Datenquelle bestimmt wird.
Verwandte Themen
So erstellen Sie eine Tabelle mit dem Tabellenassistenten


Fußzeile (Dialogfeld „Tabellenassistent“)

Verwenden Sie dieses Dialogfeld, um zu bestimmen, ob die Tabelle mit oder ohne Fußzeile erstellt werden soll. Darüber hinaus können Sie festlegen, dass die Fußzeile auf jeder Seite wiederholt wird.
Klicken Sie zum Anzeigen dieses Dialogfeldes auf „Einfügen“ > „Standard“ > „Tabelle“ > „Tabelle mit Assistenten erstellen“ > „Fußzeile“.
Keine Fußzeile
Die Tabelle wird ohne Fußzeile erstellt.
Fußzeile vorhanden
Die Tabelle wird mit Fußzeile erstellt.
Fußzeile auf jeder Seite wiederholen
Die Fußzeile wird auf allen Seiten angezeigt. Diese Option ist nur verfügbar, wenn für das übergeordnete Teilformular auf der Registerkarte „Teilformular“ der Palette „Objekt“ die Einstellung „Textfluss“ festgelegt wurde.
Verwandte Themen
So erstellen Sie eine Tabelle mit dem Tabellenassistenten


Kopfzeile (Dialogfeld „Tabellenassistent“)

Verwenden Sie dieses Dialogfeld, um zu bestimmen, ob die Tabelle mit oder ohne Kopfzeile erstellt werden soll. Darüber hinaus können Sie festlegen, dass die Kopfzeile auf jeder Seite wiederholt wird.
Klicken Sie zum Anzeigen dieses Dialogfeldes auf „Einfügen“ > „Standard“ > „Tabelle“ > „Tabelle mit Assistenten erstellen“ > „Kopfzeile“.
Keine Kopfzeile
Die Tabelle wird ohne Kopfzeile erstellt.
Kopfzeile vorhanden
Die Tabelle wird mit Kopfzeile erstellt.
Kopfzeile auf jeder Seite wiederholen
Die Kopfzeile wird auf allen Seiten angezeigt. Diese Option ist nur verfügbar, wenn für das übergeordnete Teilformular auf der Registerkarte „Teilformular“ der Palette „Objekt“ die Einstellung „Textfluss“ festgelegt wurde.
Verwandte Themen
So erstellen Sie eine Tabelle mit dem Tabellenassistenten


Zeilenschattierung (Dialogfeld „Tabellenassistent“)

Verwenden Sie dieses Dialogfeld, um den Zeilen abwechselnde Farben zuzuweisen.
Klicken Sie zum Anzeigen dieses Dialogfeldes auf „Einfügen“ > „Standard“ > „Tabelle“ > „Tabelle mit Assistenten erstellen“ > „Zeilenschattierung“.
Abwechselnde Zeilenfarben
Weist den Textzeilen unter Verwendung der angegebenen Anzahl von Zeilen und der ausgewählten Farben abwechselnde Zeilenfarben zu.
Erste
Legt die Anzahl von Zeilen fest, denen die erste Farbe zugewiesen wird.
Farbauswahl
Ruft die Farbpalette zur Auswahl der Farbe für die erste(n) Zeile(n) auf.
Weiter
Legt die Anzahl von Zeilen fest, denen die zweite Farbe zugewiesen wird.
Farbauswahl
Ruft die Farbpalette zur Auswahl der Farbe für die zweite(n) Zeile(n) auf.
Verwandte Themen
So erstellen Sie eine Tabelle mit dem Tabellenassistenten


Abschnitte (Dialogfeld „Tabellenassistent“)

Verwenden Sie dieses Dialogfeld, um in der Tabelle Abschnitte hinzuzufügen, zu löschen, zu benennen und zu sortieren (Gruppieren von Zeilen als Einheit).
Klicken Sie zum Anzeigen dieses Dialogfeldes auf „Einfügen“ > „Standard“ > „Tabelle“ > „Tabelle mit Assistenten erstellen“ > „Abschnitte“.
Textzeilen vorhanden, keine Abschnitte
Erstellt eine Tabelle mit der auf der Seite „Textkörperlayout“ festgelegten Anzahl von Textzeilen, aber ohne Abschnitte.
Textzeilenabschnitte vorhanden
Erstellt eine Tabelle mit der auf der Seite „Textkörperlayout“ festgelegten Anzahl von Textzeilen und den in der Liste „Abschnitte“ angegebenen Abschnitten.
Abschnitte
Führt die im Tabellenlayout enthaltenen Abschnitte auf. „Abschnitt 1“ ist ein Platzhalter für den Abschnittsnamen. Sie können durch Doppelklicken auf den Namen einen neuen Namen zuweisen.
Hinzufügen
Fügt einen Abschnitt hinzu und öffnet das Dialogfeld „Tabellenabschnitt“, in dem Sie dem Abschnitt einen Namen zuweisen können.
Löschen
Löscht den ausgewählten Abschnitt.
Nach-oben-Taste
Verschiebt den ausgewählten Abschnitt nach oben.
Nach-unten-Taste
Verschiebt den ausgewählten Abschnitt nach unten.
Abschnitt hat Kopfzeile
Fügt dem ausgewählten Abschnitt eine Kopfzeile hinzu.
Abschnitt hat Fußzeile
Fügt dem ausgewählten Abschnitt eine Fußzeile hinzu.
Abschnitt ist optional
Der ausgewählte Abschnitt wird nur angezeigt, wenn für diesen Abschnitt Daten vorhanden sind.
Verwandte Themen
So erstellen Sie eine Tabelle mit dem Tabellenassistenten


Dialogfeld „Vorlagen-Manager“

Verwenden Sie den Vorlagen-Manager für die Vorschau von Vorlagen und die Auswahl einer Standardvorlage zum Erstellen von Formularentwürfen. Die Standardvorlage wird angezeigt, wenn der Vorlagen-Manager geöffnet wird.
Um dieses Dialogfeld anzuzeigen, klicken Sie auf „Extras“ > „Vorlagen-Manager“.
Registerkarte „Leer“
Zeigt die verfügbaren Papierformate für den neuen Formularentwurf an.
Registerkarte „Formulare“
Zeigt verfügbare Muster-Formularentwürfe an.
Registerkarte „Sonstige“
Zeigt verfügbare benutzerdefinierte Formularentwürfe an.
Auswahl als Standard definieren
Legt die Standardwerte fest, die beim nächsten Erstellen eines Formularentwurfs verwendet werden sollen.
Verwandte Themen
Vorlagen und der Vorlagen-Manager
So fügen Sie dem Vorlagen-Manager eine Vorlage hinzu
So fügen Sie dem Vorlagen-Manager eine Registerkarte hinzu


Dialogfeld „Vorlagenoptionen“

Verwenden Sie dieses Dialogfeld, um anzugeben, wie LiveCycle Designer die importierte Vorlage verarbeiten soll.
Um dieses Dialogfeld anzuzeigen, öffnen Sie eine Vorlagendatei (TDS), die noch nicht zum Vorlagen-Manager hinzugefügt wurde.
Diese Vorlage in den Vorlagen-Manager kopieren.
Fügt die Vorlagendatei zum Vorlagen-Manager hinzu.
Neues Formular anhand dieser Vorlage erstellen.
Erstellt ein unbenanntes PDF-Formular anhand der Vorlage; Sie können dieses Formular benennen und speichern. Wenn die Vorlage Platzhalter enthält, wird der Assistent für neue Formulare geöffnet, mit dessen Hilfe Sie die Platzhalterdaten ändern können, die in den verschiedenen Feldern angezeigt werden.
Diese Vorlage bearbeiten
Öffnet die Vorlagendatei zum Bearbeiten.


Musterformulare

Musterformulare

Die Musterformulare
Muster-Mahnbrief
E-Ticket-Muster
Muster-Zuschussantrag
Musterbestellungen
Skripterstellungsmuster
Teilformularsatz-Muster
Muster-Steuerbeleg


Die Musterformulare

In LiveCycle Designer steht eine Reihe vollständiger Musterformulare zur Auswahl. Für jedes dieser Formulare werden ein Formularentwurf, Musterdaten und/oder ein Schema sowie die Endversion des Formulars bereitgestellt. Die Musterformulare veranschaulichen sowohl einfache als auch anspruchsvollere Techniken zum Entwerfen von Formularen. Sie werden im LiveCycle Designer-Installationsordner im Ordner „DE\Samples“ installiert.
In der folgenden Tabelle werden alle Musterformulare und deren Speicherorte im LiveCycle Designer-Installationsordner aufgeführt.

Formularmuster

Speicherort

Mahnbrief

Der Muster-Mahnbrief zeigt das Verhalten eines dynamischen PDF-Formulars.
\DE\Samples\Dunning Notice

E-Ticket

Das E-Ticket-Muster zeigt das Verhalten eines dynamischen PDF-Formulars. In der Hilfe werden die nummerierten Notizen erläutert, welche in der Musterdatei „E-Ticket.pdf“ angezeigt werden.
\DE\Samples\E-Ticket

Zuschussantrag

Der Muster-Zuschussantrag zeigt das Verhalten eines interaktiven PDF-Formulars.
\DE\Samples\Grant Application

Bestellung

Die vier Musterbestellungen zeigen das Verhalten von dynamischen, interaktiven und dynamisch-interaktiven PDF-Formularen.
\DE\Samples\Purchase Order

Skripterstellung

Das Skripterstellungsmuster ermöglicht es Ihnen, Erfahrungen mit den Sprachen FormCalc und JavaScript zu sammeln. Sie können ein Skript in ein Feld eingeben und durch Klicken auf eine Schaltfläche ausführen.
\DE\Samples\Scripting

Teilformularsatz

Das Teilformularsatz-Muster zeigt das Verhalten eines dynamischen PDF-Formulars. Das Muster besteht aus vier Teilmustern, welche das Instanziierungsverhalten des Teilformularsatz-Objekts bei variierenden Beziehungen des Teilformulartyps und der Vorkommenswerte veranschaulichen.
\DE\Samples\SubformSet

Steuerbeleg

Der Muster-Steuerbeleg zeigt das Verhalten eines dynamischen PDF-Formulars.
\DE\Samples\Tax Receipt


Muster-Mahnbrief

Grundlagen zum Muster-Mahnbrief
So arbeiten Sie mit dem Muster-Mahnbrief
Grundlagen zum Mahnbriefformular


Grundlagen zum Muster-Mahnbrief

Der Muster-Mahnbrief zeigt das Verhalten eines dynamischen PDF-Formulars.
Es stehen drei Mahnstufen zur Verfügung. Die für die einzelnen Stufen jeweils vorgesehenen Informationen sollen zusammen mit einer Liste der unbezahlten Dokumente ausgedruckt werden.
Zum Muster gehören die folgenden Dateien:
Formular | Dunning Notice.xdp | LiveCycle Designer-Formulardatei im Ordner „Forms“
Daten | Dunning Notice Level1.xml Dunning Notice Level2.xml Dunning Notice Level3.xml | XML-Datendateien im Ordner „Data“. Die Datendatei für den Mahnbrief der Stufe 3 enthält genügend Rechnungen für einen Überlauf auf eine zweite Seite.
Bild | Dunning Notice.tif | Bilddatei im Ordner „Images“
Ausgabe | Dunning Notice Level1.pdf Dunning Notice Level2.pdf Dunning Notice Level3.pdf | Wiedergegebene Formulare nach der Zusammenführung mit Daten im Ordner „Outputs“


So arbeiten Sie mit dem Muster-Mahnbrief

1.
Öffnen Sie „\DE\Samples\Dunning Notice\Forms\Dunning Notice.xdp“ in LiveCycle Designer.
2.
Um die Vorschauoptionen festzulegen, wählen Sie „Datei“ > „Formulareigenschaften“. Klicken Sie auf die Registerkarte „Standard“ und gehen Sie folgendermaßen vor:
      •
      Wählen Sie unter „Vorschautyp“ die Option „Formular zum Drucken“ aus.
      •
      Wechseln Sie unter „Datendatei“ zum Ordner „Data“ und wählen Sie eine der Musterdatendateien, z. B „Dunning Notice Level1.xml“.
      •
      Klicken Sie auf „OK“.
3.
Für die Vorschau des Formulars klicken Sie auf die Registerkarte „PDF-Vorschau“.
Die PDF-Musterdateien im Ordner „Outputs“ zeigen das wiedergegebene Formular jeweils nach der Zusammenführung mit den drei Datensätzen. Vergleichen Sie diese Dateien mit den Ergebnissen des in der Vorschau angezeigten Formulars.


Grundlagen zum Mahnbriefformular

Mit dem Formular werden verschiedene Funktionen demonstriert.
Hierarchische Struktur des Formulars
Das Mahnbriefformular basiert auf der Datenstruktur, um den impliziten Datenbindungsprozess zu nutzen.
Masterseite
Es sind zwei Masterseiten erforderlich. Auf der ersten werden das Firmenlogo, der Formulartitel und statischer Text angezeigt. Diese Seite wird zuerst gedruckt und hat den Maximalwert 1. Die Option „Maximal“ befindet sich auf der Registerkarte „Bindung“ der Palette „Objekt“. Die zweite Masterseite wird für alle folgenden Seiten verwendet. Derselbe statische Text sowie die Seitennummer werden angezeigt.
Seitennummerierung
Die Seitennummern sind berechnete Werte, die man durch Einfügen von Laufzeiteigenschaften in ein Textobjekt erhält.
Textfluss
Wenn Daten mit dem Formular zusammengeführt werden, werden die Teilformulare untereinander platziert, indem die Option „Inhalt“ des dem Teilformular übergeordneten Formulars (dunningNotice) auf „Textfluss“ eingestellt wird. Die Option „Inhalt“ befindet sich auf der Registerkarte „Teilformular“ der Palette „Objekt“. Für die ebenfalls auf der Registerkarte „Teilformular“ enthaltene Option „Fließrichtung“ ist „Von oben nach unten“ ausgewählt. Die auf der Palette „Layout“ angegebenen Ränder fügen den zwischen zwei Teilformularen erforderlichen zusätzlichen Platz hinzu.
Die Teilformulare „header“, „level1“, „level2“, „level3“ und „closing“ haben ebenfalls Inhalte, für welche die Option „Textfluss“ aktiviert wurde. Die Feldränder liefern den zwischen zwei Objekten zusätzlich erforderlichen Platz.
Teilformularvorkommen
Das Formular enthält eine Reihe von Teilformularen, deren Zusammenspiel ein sauberes Platzieren der Daten ermöglicht. Die Teilformulare selbst sind eine Kombination aus wiederholten und nicht wiederholten Teilformularen. Der Wert „Min-Zähler“ ist für alle Teilformulare mit Ausnahme von „detailHeader“ und „closing“ auf 0 einstellt. Damit wird angegeben, dass nur das erforderliche Teilformular gedruckt wird. Der Wert „Maximal“ ist für die nicht wiederholten Teilformulare auf 1 gesetzt. Bei den wiederholten Teilformularen gibt es keinen maximalen Vorkommenswert, da die Anzahl je nach Datensatz variiert. Der Wert „Min-Zähler“ des Teilformulars „closing“ ist auf 1 gesetzt, da zur Instanziierung des Teilformulars keine Daten verfügbar sind.
Detail-Kopfzeile
Die Detail-Kopfzeile zeigt die Spaltenüberschriften an und sollte vor der ersten Detailzeile ausgedruckt werden. Diese Informationen sollen am Seitenanfang wiederholt werden, wenn die Detailzeilen nicht mehr auf die aktuelle Seite passen und auf eine neue Seite fließen. Durch Einstellen des Werts „Min-Zähler“ für das Teilformular „detailHeader“ auf 1 lässt sich gewährleisten, dass die Kopfzeile immer mindestens einmal gedruckt wird.
Überlaufkopfbereich
Das Teilformular „detailHeader“ ist mit dem Teilformular des Dokuments als dessen Überlaufkopfbereich verknüpft. Dadurch wird das Überlaufkopfbereich-Teilformular des Dokument-Teilformulars jedes Mal gedruckt, wenn das Dokument-Teilformular auf eine neue Seite fließt. Da keine Felder im Teilformular „detailHeader“ vorhanden sind, ist für die Option „Standardbindung“ auf der Registerkarte „Bindung“ der Palette „Objekt“ die Option „Ohne“ ausgewählt.
Globale Felder
Der Währungswert ist in der Datendatei einmal angegeben. Durch Auswahl der Option „Global“ für die Standardbindung des Währungsfelds und durch Verwendung dieses Feldes an mehreren Stellen wird der Wert bei jedem Auftreten des Feldes repliziert.
Bildfeld
Da das Firmenlogo variieren kann, ist die Logodatei in die Datendatei eingebettet. Ein Bildfeldobjekt wird zum Anzeigen des Bildes verwendet.
Maximale Anzahl von Zeichen für die einzelnen Felder
Der Wert „Max. Zeichen“ für die einzelnen Felder wurde den Datenspezifikationen entsprechend festgelegt. Die Option „Max. Zeichen“ befindet sich auf der Registerkarte „Feld“ der Palette „Objekt“.
Erweiterbare Felder und Verankerungsposition
Damit Datenwerte verschiedener Länge aufgenommen werden können, wurde die Option „Passend erweitern“ auf der Palette „Layout“ für die Felder „billToAddress“, „salutation“ und „closing“ aktiviert. Die Verankerungsposition dieser Felder ist so definiert, dass eine Felderweiterung in die richtige Richtung gewährleistet ist.
Variablen
Der Abschluss der einzelnen Absätze ist identisch. Zur einfacheren Wartung wurde der zugehörige Wert als Variable definiert und dieser Wert wird mit Hilfe eines Skriptes referenziert und angezeigt. Da der Wert des Feldes berechnet wird, ist die Standardbindung auf „Ohne“ gesetzt.
Skripterstellung
Die Adresswerte sollten als ein Block dargestellt werden. Ein JavaScript wird verwendet, um die Datenwerte zu verketten. Da der Wert des Feldes „billToAddress „ berechnet wird, ist die Standardbindung auf „Ohne“ gesetzt.
Mehrzeiliges Feld
Für das Feld „billToAddress“ ist die Eigenschaft „Mehrere Zeilen zulassen“ auf der Registerkarte „Feld“ der Palette „Objekt“ aktiviert, damit der berechnete Wert auf mehrere Zeilen verteilt gedruckt werden kann.
Schwebende Felder
Das Teilformular „level3“ enthält sowohl Text als auch Felder. Die Verwendung schwebender Felder ermöglicht einen natürlichen Informationsfluss. Ein Anzeigemuster kann direkt im Feld angegeben und im Absatz angezeigt werden. Die Option „Anzeigemuster“ befindet sich auf der Registerkarte „Feld“ der Palette „Objekt“. Ein schwebendes Feld ist ein in das Textobjekt eingefügtes ausgeblendetes Feld. Die Referenz zum schwebenden Feld wird durch den in Klammern angegebenen Feldnamen angegeben, z. B. {Feldname}
Bildmuster
Einige Wert können durch Anwendung eines Anzeigemusters leichter gelesen werden. Beispielsweise ist der Wert für das Fälligkeitsdatum im Teilformular „level3“ mit einem Datumsformat mittlerer Länge formatiert. Ein Datenmuster ist ebenfalls erforderlich, weil der Datenwert nicht in einem kanonischen Format bereitgestellt wird. Der Wert „Datenmuster“ wird auf der Registerkarte „Bindung“ der Palette „Objekt“ festgelegt.


E-Ticket-Muster

Grundlagen zum E-Ticket-Muster
So arbeiten Sie mit dem E-Ticket-Muster
Grundlagen zur E-Ticket-Ausgabe


Grundlagen zum E-Ticket-Muster

Das E-Ticket-Muster zeigt und erläutert das Verhalten eines dynamischen PDF-Formulars. Das Musterformular enthält nummerierte Notizen in Form von schwarzen Kreisen mit weißen Ziffern. Sämtliche Notizen werden unter Grundlagen zur E-Ticket-Ausgabe näher erläutert.
Dieses Formular dient zum Drucken eines individuellen Reisepakets, das sich aus einem Fluglinien-Reiseplan, einer Zollerklärung, einer medizinischen Erklärung, den Transfers, den Hotelinformationen und den Bordkarten zusammensetzt. Die einzelnen Abschnitte des Pakets sollen mit unterschiedlichen Papierausrichtungen gedruckt werden.
Zum Muster gehören die folgenden Dateien:
Formular | E-Ticket.xdp | LiveCycle Designer-Formulardatei im Ordner „Forms“
Daten | E-Ticket.xml | XML-Datendatei im Ordner „Data“
Bild | E-Ticket.tif | Bilddatei im Ordner „Images“
Ausgabe | E-Ticket.pdf | Wiedergegebenes Formular nach der Zusammenführung mit Daten im Ordner „Outputs“


So arbeiten Sie mit dem E-Ticket-Muster

1.
Öffnen Sie „\DE\Samples\E-Ticket\Forms\E-Ticket.xdp“ in LiveCycle Designer.
2.
Um die Vorschauoptionen festzulegen, wählen Sie „Datei“ > „Formulareigenschaften“. Klicken Sie auf die Registerkarte „Standard“ und gehen Sie folgendermaßen vor:
      •
      Wählen Sie unter „Vorschautyp“ die Option „Formular zum Drucken“ aus.
      •
      Wechseln Sie unter „Datendatei“ zum Ordner „Data“ und wählen Sie die Musterdatendatei „E-Ticket.xml“.
      •
      Klicken Sie auf „OK“.
3.
Für die Vorschau des Formulars klicken Sie auf die Registerkarte „PDF-Vorschau“.
Die PDF-Musterdatei im Ordner „Outputs“ zeigt das wiedergegebene Formular nach der Zusammenführung mit den Daten. Vergleichen Sie diese Datei mit den Ergebnissen des in der Vorschau angezeigten Formulars.


Grundlagen zur E-Ticket-Ausgabe

Die folgenden nummerierten Notizen entsprechen den nummerierten Kreissymbolen in der Musterformulardatei.
1.
Das Deckblatt des Pakets sollte einmal im Hochformat ausgedruckt werden.
      •
      Das Teilformular „coverPage“ wird durch die Existenz der Datengruppe „coverPage“ aufgerufen.
      •
      Das Teilformular „coverPage“ wird auf der hochformatigen Masterseite platziert, da es den ersten im Seitensatz definierten Seitenbereich darstellt.
      •
      Das Teilformular „coverPage“ hat einen Min-Zählerwert von 0 und einen Maximalwert von 1. Diese beiden Optionen befinden sich auf der Registerkarte „Bindung“ der Palette „Objekt“.
      •
      Die Bilddatei ist mit dem Formular verknüpft. Die Verknüpfung wird als URL eines Bildobjekts bereitgestellt.
      •
      Im Abschnitt „Inhalt dieses Reisepakets“ wird der Feldbeschriftungstext bei Bedarf mit Hilfe eines JavaScript-Skriptes in den Plural gesetzt.
Die Datenwerte, die an verschiedenen Stellen im Reisepaket gedruckt werden müssen, wurden als globale Felder erstellt; dies gilt z. B. für die Felder „lastName“, „firstName“ und „initial“.
2.
Die Kopfzeileninformationen des Fluglinien-Reiseplans sollten vor der Auflistung der Flugrouten im Querformat gedruckt werden.
      •
      Damit das Teilformular „flightHeader“ aufgerufen wird, müssen das Teilformular und der Teilformularsatz vorhanden sein und für den Teilformularsatz muss ein bestimmter Beziehungstyp gelten.
      •
      Der Teilformularsatz „itinerary“ wird nur instanziiert, wenn ein Teilformular „flight“ instanziiert wird. Dies lässt sich durch Einstellen des Min-Zählerwerts für den Teilformularsatz auf 0 gewährleisten. Sobald der Teilformularsatz instanziiert ist, wird das Teilformular „flightHeader“ aufgerufen, da es den Min-Zählerwert 1 hat. Dies liegt daran, dass der Wert „Typ“ des Teilformularsatzes auf der Registerkarte „Teilformularsatz“ der Palette „Objekt“ auf „Alle Teilformulare in festgelegter Reihenfolge verwenden“ eingestellt ist.
      •
      Das Teilformular „flightHeader“ ist der querformatigen Masterseite zugeordnet. Das Teilformular „flightHeader“ wird auf der Seite „landscape“ platziert.
      •
      Das Teilformular „flightHeader“ ist mit dem Teilformular „flight“ als dessen Überlaufkopfbereich verknüpft. Das Teilformular „flightHeader“ sollte am Anfang jeder Seite im Abschnitt des Fluglinien-Reiseplans gedruckt werden. Für das Feld „Standardbindung“ auf der Registerkarte „Bindung“ der Palette „Objekt“ wurde die Option „Global“ ausgewählt, da die Informationen wiederholt benötigt werden.
3.
Die Flüge gelten speziell für das Reisepaket und können je nach Reiseplan variieren.
      •
      Das Teilformular „flight“ wird durch die Existenz der Datengruppe „flight“ aufgerufen. Der Min-Zählerwert für das Teilformular „flight“ ist 0 und der Maximalwert ist unbegrenzt. Dies bedeutet, dass das Teilformular nur instanziiert wird, wenn Daten dafür vorhanden sind, und es wird so oft wiederholt, wie dies zum Drucken der vorhandenen Daten erforderlich ist. Der Maximalwert ist unbegrenzt, wenn die Option „Teilformular wiederholen für jedes Datenelement“ aktiviert und die Option „Maximal“ deaktiviert ist. Die Option „Teilformular wiederholen für jedes Datenelement“ befindet sich auf der Registerkarte „Bindung“ der Palette „Objekt“.
      •
      Das Teilformular „flight“ wird nach dem vorherigen Teilformular platziert.
4.
Für jede Familie ist eine separate Zollerklärung erforderlich. Die Erklärung sollte im Hochformat gedruckt werden.
      •
      Das Teilformular „customs“ wird durch die Existenz der Datengruppe „customs“ aufgerufen.
      •
      Das Teilformular „customs“ hat einen Min-Zählerwert von 0 und einen Maximalwert von 1.
      •
      Das Teilformular „customs“ ist der hochformatigen Masterseite zugeordnet. Das Teilformular „customs“ wird am Anfang der Seite „portrait“ platziert, was eine neue Seite erzwingt.
5.
Pro Seite sollte eine einzelne medizinische Erklärung im Hochformat gedruckt werden.
      •
      Das Teilformular „medical“ wird durch die Existenz der Datengruppe „medical“ aufgerufen.
      •
      Der Min-Zählerwert für das Teilformular „medical“ ist 0 und der Maximalwert ist unbegrenzt.
      •
      Das Teilformular „medical“ ist der hochformatigen Masterseite zugeordnet. Es wird am Anfang der Seite „portrait“ platziert, was eine neue Seite erzwingt.
      •
      Die Informationen zur Privatadresse des Passagiers werden über ein JavaScript-Skript verkettet. Für das Feld „homeAddress“ ist die Option „Mehrere Zeilen zulassen“ aktiviert, damit der Informationsblock korrekt angezeigt wird. Die Option „Mehrere Zeilen zulassen“ befindet sich auf der Registerkarte „Feld“ der Palette „Objekt“.
6.
Die Kopfzeileninformationen zur Hotelunterbringung sollten vor der Liste der Hotels im Querformat gedruckt werden.
      •
      Damit das Teilformular „hotelHeader“ aufgerufen wird, müssen das Teilformular und der Teilformularsatz vorhanden sein und für den Teilformularsatz muss ein bestimmter Beziehungstyp gelten.
      •
      Der Teilformularsatz „accommodation“ wird nur instanziiert, wenn ein Teilformular „hotel“ instanziiert wird. Dies lässt sich durch Einstellen des Min-Zählerwerts für den Teilformularsatz auf 0 gewährleisten. Sobald der Teilformularsatz instanziiert ist, wird das Teilformular „hotelHeader“ aufgerufen, da es den Min-Zählerwert 1 hat. Dies liegt daran, dass der Wert „Typ“ des Teilformularsatzes auf „Alle Teilformulare in festgelegter Reihenfolge verwenden“ eingestellt ist.
      •
      Das Teilformular „hotelHeader“ ist der hochformatigen Masterseite zugeordnet. Das Teilformular „hotelHeader“ wird auf der Seite „landscape“ platziert.
      •
      Das Teilformular „hotelHeader“ ist mit dem Teilformular „hotel“ als dessen Überlaufkopfbereich verknüpft. Das Teilformular „hotelHeader“ sollte am Anfang jeder Seite im Abschnitt der Hotelunterbringung gedruckt werden. Die Felder sind auf „Global“ eingestellt, weil die Informationen wiederholt benötigt werden.
      •
      Die Datenwerte für „lastName“ und „firstName“ werden mit Hilfe eines JavaScript-Skriptes miteinander verkettet.
      •
      Die Gästeadresswerte sollten als ein Block dargestellt werden. Die Datenwerte werden mit Hilfe eines JavaScript-Skriptes verkettet.
7.
Die Hotelliste gilt speziell für das Reisepaket und kann je nach Reiseplan variieren.
      •
      Das Teilformular „hotel“ wird durch die Existenz der Datengruppe „hotel“ aufgerufen. Der Min-Zählerwert für das Teilformular „hotel“ ist 0 und der Maximalwert ist unbegrenzt. Dies bedeutet, dass das Teilformular nur instanziiert wird, wenn Daten dafür vorhanden sind, und es wird so oft wiederholt, wie dies zum Drucken der vorhandenen Daten erforderlich ist.
      •
      Das Teilformular „hotel“ wird nach dem vorherigen Teilformular platziert.
      •
      Die Zimmertypwerte sollten als ein Block dargestellt werden. Die Datenwerte werden mit Hilfe eines JavaScript-Skriptes verkettet. Da der Wert des Feldes „roomName“ berechnet wird, ist die Standardbindung auf „Ohne“ gesetzt.
8.
Pro Seite sollte eine einzelne Bordkarte im Querformat gedruckt werden.
      •
      Das Teilformular „boarding“ wird durch die Existenz der Datengruppe „boarding“ aufgerufen.
      •
      Der Min-Zählerwert für das Teilformular „boarding“ ist 0 und der Maximalwert ist unbegrenzt. Dies bedeutet, dass das Teilformular nur instanziiert wird, wenn Daten dafür vorhanden sind, und es wird so oft wiederholt, wie dies zum Drucken der vorhandenen Daten erforderlich ist.
      •
      Das Teilformular „boarding“ ist der querformatigen Masterseite zugeordnet. Das Teilformular „boarding“ wird am Anfang der Seite „landscape“ platziert, was eine neue Seite erzwingt.


Muster-Zuschussantrag

Grundlagen zum Muster-Zuschussantrag
So arbeiten Sie mit dem Muster-Zuschussantrag
Grundlagen zum Zuschussantragsformular


Grundlagen zum Muster-Zuschussantrag

Das Muster-Zuschussantrag zeigt das Verhalten eines interaktiven PDF-Formulars. Informationen über die Erstellung und Verwendung interaktiver Formulare finden Sie in der LiveCycle Designer-Hilfe.
Das Muster enthält einen Zuschussantrag, der ausgefüllt und an die Einrichtung oder Stiftung zurückgereicht werden muss, welche das Formular herausgegeben hat.
Zum Muster gehört die folgende Datei:
Formular
Grant Application.pdf
Sowohl der Formularentwurf als auch das auszufüllende Formular befinden sich im Ordner „Forms“.


So arbeiten Sie mit dem Muster-Zuschussantrag

1.
Öffnen Sie das Formular „\DE\Samples\Grant Application\Forms\Grant Application.pdf“ in Acrobat oder Adobe Reader.
2.
Klicken Sie in das Feld „Projekttitel“ und füllen Sie das Formular aus.


Grundlagen zum Zuschussantragsformular

Mit dem Formular werden verschiedene Funktionen demonstriert.
Seitennummerierung
Die Seitennummern sind berechnete Werte, die man durch Einfügen von Laufzeiteigenschaften in ein Textobjekt erhält.
Maximale Anzahl von Zeichen für die einzelnen Felder
Die Option „Max. Zeichen“ auf der Registerkarte „Feld“ der Palette „Objekt“ wird für die einzelnen Felder entsprechend den Datenspezifikationen angegeben.
Mehrzeiliges Feld
Für das Feld „description“ ist die Eigenschaft „Mehrere Zeilen zulassen“ auf der Registerkarte „Feld“ der Palette „Objekt“ aktiviert, damit Benutzer mehrere Textzeilen eingeben kann.
Musterformate
Der Benutzer muss einige Werte in einem bestimmten Format eingeben. Eine Überprüfungsmeldung, die auf der Registerkarte „Wert“ der Palette „Objekt“ festgelegt wird, fordert den Benutzer bei Bedarf auf, Werte im richtigen Format einzugeben. Beispielsweise prüft ein Skript den vom Benutzer eingegebenen Wert des Feldes „BudgetDirectCosts“.
Eigene Bibliotheksobjekte
Mit dem eigenen Bibliotheksobjekt „US-Staaten“ wurden die beiden Dropdown-Listen „State“ und „OrgState“ erstellt.
Tab-Reihenfolge
Die standardmäßige Tab-Reihenfolge wurde geändert, um einen Spaltenfluss zu ermöglichen. Die Tab-Reihenfolge wird angezeigt, wenn Sie im Menü „Ansicht“ die Option „Tab-Reihenfolge“ auswählen.


Musterbestellungen

Grundlagen zu den Musterbestellungen
So arbeiten Sie mit den Musterbestellungen


Grundlagen zu den Musterbestellungen

Die vier Musterbestellungen zeigen das Verhalten von dynamischen, interaktiven und dynamisch-interaktiven PDF-Formularen.
Zu den Mustern gehören die folgenden Dateien:
Dynamische Bestellung
Formular | Purchase Order.xdp | LiveCycle Designer-Formulardatei im Ordner „Forms“
Daten | Purchase Order.xml | XML-Datendatei im Ordner „Data“
Bild | Purchase Order.tif | Bilddatei im Ordner „Images“
Ausgabe | Purchase Order.pdf | Wiedergegebenes Formular nach der Zusammenführung mit Daten im Ordner „Outputs“
Dynamisch-interaktive Bestellung
Formular | Purchase Order.pdf | Sowohl der Formularentwurf als auch das auszufüllende Formular im Ordner „Forms“
Bild | Purchase Order.tif | Bilddatei im Ordner „Images“
Interaktive Bestellung
Formular | Purchase Order.pdf | Sowohl der Formularentwurf als auch das auszufüllende Formular im Ordner „Forms“
Bild | Purchase Order.tif | Bilddatei im Ordner „Images“
Schema-Bestellung
r
Formular | Purchase Order.xdp | LiveCycle Designer-Formulardatei im Ordner „Forms“
Daten | Purchase Order.xml | XML-Datendatei im Ordner „Data“
Schema | Purchase Order.xsd | Schemadatei im Ordner „Schema“
Bild | Purchase Order.tif | Bilddatei im Ordner „Images“
Ausgabe | Purchase Order.pdf | Wiedergegebenes Formular nach der Zusammenführung mit Daten im Ordner „Outputs“


So arbeiten Sie mit den Musterbestellungen

Dynamische und Schema-Bestellung
1.
Öffnen Sie das gewünschte Formular in LiveCycle Designer:
      •
      \DE\Samples\Purchase Order\Dynamic\Forms\Purchase Order.xdp
      •
      \DE\Samples\Purchase Order\Schema\Forms\Purchase Order.xdp
2.
Um die Vorschauoptionen festzulegen, wählen Sie „Datei“ > „Formulareigenschaften“. Klicken Sie auf die Registerkarte „Standard“ und gehen Sie folgendermaßen vor:
      •
      Wählen Sie unter „Vorschautyp“ die Option „Formular zum Drucken“ aus.
      •
      Wechseln Sie unter „Datendatei“ zum Ordner „Data“ und wählen Sie die Musterdatendatei „Purchase Order.xml“.
      •
      Klicken Sie auf „OK“.
3.
Für die Vorschau des Formulars klicken Sie auf das Register „PDF-Vorschau“.
Die PDF-Musterdatei im Ordner „Outputs“ zeigt das wiedergegebene Formular nach der Zusammenführung mit den Daten. Vergleichen Sie diese Datei mit den Ergebnissen des in der Vorschau angezeigten Formulars.
Interaktive und dynamisch-interaktive Bestellung
1.
Öffnen Sie das gewünschte Formular in Acrobat oder Adobe Reader:
      •
      \DE\Samples\Purchase Order\Interactive\Forms\Purchase Order.xdp
      •
      \DE\Samples\Purchase Order\Dynamic Interactive\Forms\Purchase Order.xdp
2.
Klicken Sie in das Feld „Bestellnummer“ und füllen Sie das Formular aus.
Die PDF-Musterdatei im Ordner „Outputs“ zeigt das wiedergegebene Formular nach der Zusammenführung mit den Daten. Vergleichen Sie diese Datei mit den Ergebnissen des in der Vorschau angezeigten Formulars.


Skripterstellungsmuster

Grundlagen zum Skripterstellungsmuster
So arbeiten Sie mit dem Skripterstellungsmuster


Grundlagen zum Skripterstellungsmuster

Das Skripterstellungsmuster ermöglicht es Ihnen, Erfahrungen mit den Sprachen FormCalc und JavaScript zu sammeln. Sie können ein Skript in ein Feld eingeben und durch Klicken auf eine Schaltfläche ausführen. Das Muster umfasst eine Vielzahl von Feldtypen, welche von dem Skript verwendet werden können.
Zum Muster gehört die folgende Datei:
Formular
Scripting.pdf
Sowohl der Formularentwurf als auch das auszufüllende Formular im Ordner „Forms“


So arbeiten Sie mit dem Skripterstellungsmuster

1.
Öffnen Sie das Formular „\DE\Samples\Scripting\Forms\Scripting.pdf“ in Acrobat oder Adobe Reader.
2.
Geben Sie im Feld „Hier Skript eingeben“ ein Skript ein.
3.
Geben Sie die vom Skript erwarteten Daten ein.
4.
Klicken Sie auf die entsprechende Schaltfläche, um das Skript auszuführen. Die Ausgabe wird im Feld „Ergebnis“ angezeigt. Falls gewünscht, können Sie die Ergebnisse einem anderen Feld zuweisen.
5.
Nachdem das Skript ausgeführt wurde, klicken Sie auf „Felderinhalt löschen“, um die Feldinhalte zu entfernen und das Skript entweder erneut auszuführen oder zu ändern.
Wenn Sie ein einfaches Skript ausprobieren möchten, verwenden Sie eines der folgenden Beispiele:
JavaScript
if (NF1.rawValue < NF2.rawValue)
    NF3.rawValue = 0
else
    NF3.rawValue = NF1.rawValue - NF2.rawValue
FormCalc
if (NF1 < NF2) then
    NF3 = 0
else
    NF3 = NF1 - NF2
endif
Beide Skripten verwenden die numerischen Felder NF1, NF2 und NF3. Der Benutzer kann in die Felder NF1 und NF2 Zahlen eingeben; das Skript subtrahiert die Zahlen (NF1-NF2) und zeigt die Differenz im Feld NF3 an. Falls das Ergebnis negativ ist, wird der Wert für NF3 auf 0 gesetzt.


Teilformularsatz-Muster

Grundlagen zum Teilformularsatz-Muster
So arbeiten Sie mit dem Teilformularsatz-Muster
Grundlagen zur Teilformularsatz-Ausgabe


Grundlagen zum Teilformularsatz-Muster

Das Teilformularsatz-Muster zeigt das Verhalten eines dynamischen PDF-Formulars. Das Muster besteht aus vier Teilmustern, welche das Instanziierungsverhalten des Teilformularsatz-Objekts bei variierenden Beziehungen des Teilformulartyps und der Vorkommenswerte veranschaulichen. Das Musterformular enthält nummerierte Notizen in Form von schwarzen Kreisen mit weißen Ziffern. Sämtliche Notizen werden unter Grundlagen zur Teilformularsatz-Ausgabe näher erläutert.
Zum Muster gehören die folgenden Dateien:
Formular | SubformSet1.xdp SubformSet2.xdp SubformSet3.xdp SubformSet4.xdp | LiveCycle Designer-Formulardatei im Ordner „Forms“
Daten | DataA.xml DataB.xml | XML-Datendateien im Ordner „Data“
Ausgabe | SubformSet1 DataA.pdf SubformSet1 DataB.pdf SubformSet2 DataA.pdf SubformSet2 DataB.pdf SubformSet3 DataA.pdf SubformSet3 DataB.pdf SubformSet4 DataA.pdf SubformSet4 DataB.pdf | Wiedergegebene Formulare nach der Zusammenführung mit Daten im Ordner „Outputs“


So arbeiten Sie mit dem Teilformularsatz-Muster

1.
Öffnen Sie eines der Formulare im Ordner „\DE\Samples\SubformSet\Forms“ in LiveCycle Designer.
2.
Um die Vorschauoptionen festzulegen, wählen Sie „Datei“ > „Formulareigenschaften“. Klicken Sie auf die Registerkarte „Standard“ und gehen Sie folgendermaßen vor:
      •
      Wählen Sie unter „Vorschautyp“ die Option „Formular zum Drucken“ aus.
      •
      Wechseln Sie unter „Datendatei“ zum Ordner „Data“ und wählen Sie eine der Musterdatendateien, z. B. DataA.xml.
      •
      Klicken Sie auf „OK“.
3.
Für die Vorschau des Formulars klicken Sie auf die Registerkarte „PDF-Vorschau“.
Die PDF-Musterdateien im Ordner „Outputs“ zeigen die wiedergegebenen Formulare jeweils nach der Zusammenführung mit den beiden Datensätzen. Vergleichen Sie diese Dateien mit den Ergebnissen des in der Vorschau angezeigten Formulars.


Grundlagen zur Teilformularsatz-Ausgabe

Die folgenden nummerierten Kommentare entsprechen den nummerierten schwarzen Kreissymbolen im Teilformularsatz-Muster.
Daten
Es stehen zwei Musterdatendateien für dieses Muster zur Verfügung. Dieser Abschnitt enthält den Namen und den Inhalt der mit dem Formular zusammengeführten Datendatei. Diese Informationen können mit den in Abschnitt 3, „Beziehung der Teilformulare“, angezeigten Daten verglichen werden.
Teilformular-Vorkommen
Jedes Formular enthält drei Teilformulare. Dieser Abschnitt enthält den Min-Zähler- und Maximalwert für das Vorkommen der Teilformulare. Die Werte für das Vorkommen werden auf der Registerkarte „Bindung“ der Palette „Objekt“ angegeben.
Teilformularspezifikationen pro Formular

TeilformularA

TeilformularB

TeilformularC
SubformSet1.xdp
Min-Zähler = 0 Maximal =−1*
Min-Zähler = 0 Maximal =−1*
Min-Zähler = 0 Maximal =−1*
SubformSet2.xdp
Min-Zähler = 0 Maximal = 1
Min-Zähler = 0 Maximal = 1
Min-Zähler = 0 Maximal = 1
SubformSet3.xdp
Min-Zähler = 1 Maximal = 1
Min-Zähler = 1 Maximal = 1
Min-Zähler = 1 Maximal = 1
SubformSet4.xdp
Min-Zähler = 2 Maximal = 2
Min-Zähler = 1 Maximal = 1
Min-Zähler = 3 Maximal = 3
* Der Maximalwert ist unbegrenzt, wenn die Option „Teilformular wiederholen für jedes Datenelement“ auf der Registerkarte „Bindung“ der Palette „Objekt“ aktiviert und die Option „Maximal“ deaktiviert ist.
Beziehung der Teilformulare
Der dritte Abschnitt enthält drei Spalten zum Vergleich der Teilformulare innerhalb verschiedener Beziehungstypen:

Spalte

Typ

Kommentare
1
Alle Teilformulare in festgelegter Reihenfolge verwenden
Die Teilformulare werden in der Reihenfolge instanziiert, in der sie im Formular deklariert werden. Das bedeutet, dass der Inhalt unter Umständen neu geordnet werden muss, um die Formularreihenfolge zu erfüllen.
2
Teilformular aus Alternativen verwenden
Die Teilformulare schließen sich gegenseitig aus; es kann nur eines der Teilformulare instanziiert werden. Die Entscheidung, welches der Teilformulare instanziiert wird, hängt von den Daten ab.


Muster-Steuerbeleg

Grundlagen zum Muster-Steuerbeleg
So arbeiten Sie mit dem Muster-Steuerbeleg
Grundlagen zum Steuerbeleg-Formular


Grundlagen zum Muster-Steuerbeleg

Der Muster-Steuerbeleg zeigt das Verhalten eines dynamischen PDF-Formulars.
Mit diesem Formular werden drei Kopien eines Steuerbelegs auf einer Seite gedruckt, und zwar die Kopie für die Stiftung, die Kopie für die Sektion und die Kopie für Steuerzwecke.
Zum Muster gehören die folgenden Dateien:
Formular | Tax Receipt.xdp | LiveCycle Designer-Formulardatei im Ordner „Forms“
Daten | Tax Receipt.xml | XML-Datendatei im Ordner „Data“
Bild | Signature.tif Tax Receipt.tif | Bilddateien im Ordner „Images“
Ausgabe | Tax Receipt.pdf | Wiedergegebenes Formular nach der Zusammenführung mit Daten im Ordner „Outputs“


So arbeiten Sie mit dem Muster-Steuerbeleg

1.
Öffnen Sie das Formular „Tax Receipt.xdp“ in LiveCycle Designer.
2.
Um die Vorschauoptionen festzulegen, wählen Sie „Datei“ > „Formulareigenschaften“. Klicken Sie auf die Registerkarte „Standard“ und gehen Sie folgendermaßen vor:
      •
      Wählen Sie unter „Vorschautyp“ die Option „Formular zum Drucken“ aus.
      •
      Wechseln Sie unter „Datendatei“ zum Ordner „Data“ und wählen Sie die Musterdatei „Tax Receipt.xml“.
      •
      Klicken Sie auf „OK“.
3.
Für die Vorschau des Formulars klicken Sie auf die Registerkarte „PDF-Vorschau“.
Die PDF-Musterdatei im Ordner „Outputs“ zeigt das wiedergegebene Formular nach der Zusammenführung mit den Daten. Vergleichen Sie diese Datei mit den Ergebnissen des in der Vorschau angezeigten Formulars.


Grundlagen zum Steuerbeleg-Formular

Mit dem Formular werden verschiedene Funktionen demonstriert.
Hierarchische Struktur des Formulars
Das Steuerbeleg-Formular basiert auf der Datenstruktur, um den impliziten Datenbindungsprozess zu nutzen.
Masterseite
Da der Fußzeilentext am unteren Rand jeder Seite angezeigt werden soll, wurde er auf der Masterseite definiert.
Textfluss
Die Instanzen des Teilformulars „receipt „ werden untereinander platziert; dies ist deshalb möglich, weil die Option „Inhalt“ des Teilformulars „taxReceipt“ auf „Textfluss“ eingestellt wurde. Die Option „Inhalt“ befindet sich auf der Registerkarte „Teilformular“ der Palette „Objekt“. Für die ebenfalls auf der Registerkarte „Teilformular“ enthaltene Option „Fließrichtung“ ist „Von oben nach unten“ ausgewählt. Die Ränder der Teilformulare werden auf der Palette „Layout“ festgelegt und fügen den zwischen zwei Teilformularen erforderlichen zusätzlichen Platz hinzu.
Teilformularvorkommen
Das Teilformular „receipt“ enthält die Informationen des Steuerbelegs einschließlich der Felder und statischen Elemente. Da der Beleg dreimal auf einer Seite gedruckt werden soll, wurde der Maximalwert für das Teilformular „receipt“ auf 3 festgesetzt. Dieser Wert wird auf der Registerkarte „Bindung“ der Palette „Objekt“ festgelegt.
Globale Felder
Der Angaben zum Spendengeber werden in der Datendatei einmal bereitgestellt. Durch die Definition der Spendengeberfelder als globale Felder können diese Werte auf jeder Kopie des Steuerbelegs gedruckt werden.
Bildfeld
Da die Unterschrift des Schatzmeisters variieren kann, ist die Verknüpfung zum Unterschriftbild in der Datendatei enthalten. Ein Bildfeld wird zum Anzeigen des Unterschriftbildes verwendet.
Maximale Anzahl von Zeichen für die einzelnen Felder
Die Option „Max. Zeichen“ wird auf der Registerkarte „Feld“ der Palette „Objekt“ für die einzelnen Felder entsprechend den Datenspezifikationen angegeben.
Erweiterbare Felder und Verankerungsposition
Damit Datenwerte verschiedener Länge aufgenommen werden können, wurde die Option „Passend erweitern“ auf der Palette „Layout“ für die Felder „receiptSerial“ und „copyLabel“ aktiviert. Die Verankerungsposition dieser Felder ist so definiert, dass eine Felderweiterung in die richtige Richtung gewährleistet ist.
Skripterstellung
Die Adresswerte sollten als ein Block dargestellt werden. Die Datenwerte werden mit Hilfe eines JavaScript-Skriptes verkettet. Da der Wert des Felds „donorAddress“ berechnet wird, ist die Standardbindung auf „Ohne“ gesetzt. Die Standardbindung wird auf der Registerkarte „Bindung“ der Palette „Objekt“ festgelegt.
Mehrzeiliges Feld
Für das Feld „donorAddress „ ist die Eigenschaft „Mehrere Zeilen zulassen“ auf der Registerkarte „Feld“ der Palette „Objekt“ aktiviert, damit es auf mehrere Zeilen verteilt gedruckt werden kann.
Musterformate
Einige Wert sind durch Anwendung eines Anzeigemusters einfacher zu lesen. Diese Option befindet sich auf der Registerkarte „Feld“ der Palette „Objekt“. Beispielsweise ist der Datumswert mit einem langen Datumsformat formatiert.


Glossar

Glossar

Dieses Glossar enthält spezifische Terminologiedefinitionen zur Dokumentation von Adobe Document Services. Diese Begriffe haben eventuell in einem anderen Kontext eine andere Bedeutung. In dieser Dokumentation gilt die eingeschränkte Bedeutung.
A B C D E F G H I J K L M N O P Q R S T U V W X YZ
A
Acrobat-Formular
Ein in Acrobat erstelltes PDF-Dokument mit einem oder mehreren Formularfeldern. Acrobat-Formulare können auch über nicht formularbezogene Inhalte verfügen.
Adobe Document Services
Adobe Document Services erweitern die Kernsysteme eines Unternehmens und gewährleisten, dass geschäftskritische Daten über das gesamte Unternehmen hinweg erfasst und bereitgestellt werden. Die Adobe Document Services-Lösung setzt sich aus LiveCycle Designer, LiveCycle Forms, LiveCycle Reader Extensions, LiveCycle Form Manager und Document Security Server zusammen.
Adobe-zertifiziertes Dokument
Ein Dokument, das mit einem speziellen Adobe-Wurzelzertifikat unterzeichnet wurde. Das Adobe-Wurzelzertifikat ist auf ein Hardware-Sicherheitsmodul verteilt. Ein Adobe-zertifiziertes Dokument bietet eine hohe Garantie hinsichtlich der Echtheit und der Unveränderlichkeit des Dokuments. Siehe auch Zertifikat.
Anwendung
Eine Reihe zusammengehöriger und in der Regel voneinander abhängiger Dateien, die eine eigenständige Anwendung bilden, die von LiveCycle Forms ausgeführt werden kann. Anwendungen können Dateien wie Formularentwürfe, JavaServer-Seiten, HTML-Seiten, Servlets und Bilder enthalten.
Arbeitsablauf
Ein Prozess, der die automatische Weiterleitung von Formulardaten in einer vordefinierten Sequenz zwischen Abteilungen, Personen und Systemen ermöglicht.
Zurück zum Anfang
B
Barrierefreie Formulare
Formulare, die Benutzer mit Behinderungen, insbesondere Sehbehinderungen, mit Hilfe von Bildschirmlesehilfen und anderen Hilfstechnologien ausfüllen können.
Baustein
Statische oder feste Objekte, die Text oder Grafiken enthalten. Textbausteine bilden die sichtbaren Komponenten eines Formularentwurfs. Im Gegensatz zu Datenfeldern ändern sich die Informationen in den Textbausteinen niemals.
Berechtigungen
Sicherheitseinstellungen, die Benutzer am Öffnen, Bearbeiten oder Drucken eines PDF-Dokuments hindern. Die Berechtigungen können nicht geändert werden, es sei denn, der Benutzer hat das Berechtigungskennwort. Berechtigungen lassen sich in LiveCycle Designer, Acrobat oder LiveCycle Forms einrichten.
Berechtigungsaktiviertes Dokument
Ein PDF-Dokument mit Sicherheitserweiterungen, die Benutzern von Adobe Reader die Möglichkeit geben, Formulare mit Daten zu speichern, Kommentare hinzuzufügen und Dokumente zu unterschreiben.
Zurück zum Anfang
C
Client
Das anfordernde Programm oder eine Person in einer Client/Server-Beziehung. Ein Webbrowser ist ein Beispiel für eine Client-Anwendung.
Credential
Ein privater Schlüssel zur Einrichtung einer Identität bei Verschlüsselungs- und Signaturvorgängen.
Zurück zum Anfang
D
Datenbindung
Das Verknüpfen eines Objekts mit dem entsprechenden Feld innerhalb einer Datendatei oder
Datenbank.
Zurück zum Anfang
E
Eingeschränktes Dokument
Ein PDF-Dokument mit Kennwort-Sicherheitsbeschränkungen, die verhindern, dass das Dokument geöffnet, gedruckt, gespeichert oder bearbeitet werden kann.
F
Festes Layout
Ein Formular, dessen Layout beim Ausfüllen mit Daten genau so bleibt, wie es entworfen wurde. Das Layout ändert sich durch die Menge der Daten nicht.
FormCalc
Eine Berechnungssprache ähnlich der in allgemeinen Tabellenkalkulationsprogrammen. FormCalc ermöglicht einen Formularentwurf ohne Vorkenntnisse über herkömmliche Skripttechniken oder Programmiersprachen.
Formular
Ein elektronisches Dokument, das Daten erfasst und weiterleitet. Eine Person kann einem interaktiven Formular Daten hinzufügen oder ein Serverprozess kann einen Formularentwurf mit Daten zusammenführen.
Formularentwickler
LiveCycle Designer-Benutzer, die komplexe formularorientierte Anwendungen zur Verwendung in verschiedenen Umgebungen entwickeln können. Siehe auch Formularverfasser.
Formularentwurf
Die Version eines von einem Verfasser oder Entwickler in LiveCycle Designer entwickelten Formulars zur Entwicklungszeit.
Formularobjekt
Ein Formularelement wie beispielsweise eine Schaltfläche oder ein Textfeld, das Sie in einem Formular platzieren können. Ein Objekt verfügt über seine eigenen Eigenschaften und Ereignisse.
Formularverfasser
Benutzer von LiveCycle Designer, die ausfüllbare Formulare für die Nutzung in Acrobat oder Adobe Reader und einfache nicht interaktive Formulare für den Einsatz mit LiveCycle Forms erstellen können. Siehe auch Formularentwickler.
Zurück zum Anfang
G
Getaggtes PDF-Formular
Ein Formular, das eine logische Struktur und einen Satz definierter Beziehungen und Abhängigkeiten zwischen den verschiedenen Elementen sowie zusätzliche Informationen enthält, die einen erneuten Textfluss ermöglichen.
Zurück zum Anfang
I
Interaktives Formular
Ein Formular, mit dem der Endbenutzer eine Interaktion durchführen und das er elektronisch ausfüllen kann.
Zurück zum Anfang
K
Kanonisches Format
Eine Standardmethode zum Schreiben von Formeln. Die zwei Formeln 9 + x und x + 9 beispielsweise sind zwar identisch, die zweite Schreibweise wird jedoch als kanonische, also als Normalform bezeichnet, da dies die Normalform mit x als höchster Potenz ist. Im Allgemeinen gibt es festgelegte Regeln zum Bestimmen, ob eine Formel kanonisch dargestellt wird. Kanonische Formeln sind besser zu Vergleichszwecken geeignet.
In der folgenden Tabelle sind verschiedene Feldtypen mit ihrer kanonischen Schreibweise dargestellt. Die Werte in den eckigen Klammern sind hierbei optional. Währungs- und Gruppierungssymbole können nicht im kanonischen Format dargestellt werden.

Feldtyp

Beschreibung

Kanonisches Format

Beispiel
Datumsfelder
Eine Datumszeichenfolge im Format ISO-8601/XFA
YYYY[-MM[-DD]]
YYYY[MM[DD]]
2005-07-04
20050704
Datums-/Uhrzeitfelder
Eine Datums- und Uhrzeitzeichenfolge ist die gültige Verkettung der Datumszeichenfolge ISO-8601/XFA mit der Uhrzeitzeichenfolge ISO-8601/XFA unter Verwendung des Buchstaben „T“ als Trennzeichen zwischen beiden Zeichenfolgen.
2004-07-04T10:11:12+05:00
20040704T101112
Numerische Felder
Eine ASCII-Ziffernfolge bestehend aus einer Ganzzahl, einem Dezimaltrennzeichen, einem Bruchanteil, gegebenenfalls einem Exponentenzeichen („e“ oder „E“) sowie einem optionalen vorzeichenbehafteten Exponentenwert
12
1.234
.12
1e-2
1.2E3
Textfelder
Eine Unicode-Zeichenfolge ohne Leerzeichen
A1B2C3
Anzeigemuster: A9A 9A9
Formatierter Wert: A1B 2C3
Zeitfelder
Eine Uhrzeitzeichenfolge im Format ISO-8601/XFA
HH[:MM[:SS[.FFF][Z]]]
HH[:MM[:SS[.FFF][+HH[:MM]]]]
HH[:MM[:SS[.FFF][-HH[:MM]]]]
HH[MM[SS[.FFF][Z]]]
HH[MM[SS[.FFF][+HH[MM]]]]
HH[MM[SS[.FFF][-HH[MM]]]]
10:11:12.123+05:00
101112+0500
10:11:12Z
10:11
10
Zurück zum Anfang
L
Laufzeit
Zeit, in welcher eine Anwendung oder ein Serverprozess einen Formularentwurf aufruft, gegebenenfalls mit Daten zusammenführt und ihn dem Benutzer zur Ansicht oder Bearbeitung anzeigt.
LiveCycle Form Manager-Repository
Ein Repository, auf das autorisierte Benutzer und Anwendungen zugreifen können, um Formulare und zugehörige Anwendungsdateien zu speichern und abzurufen.
Zurück zum Anfang
P
PDF-Formular
Ein Formular, das von Benutzern in Acrobat und Adobe Reader geöffnet werden kann. PDF-Formulare sind entweder interaktiv oder nicht interaktiv.
S
Sicherheits-Handler
Ein Software-Modul, das verschiedene Aspekte des Verschlüsselungsprozesses implementiert und den Zugriff auf den Inhalt der verschlüsselten Dokumente steuert. Es enthält die gesamte Sicherheitslogik (z. B. wie Unterschriften erstellt und überprüft werden).
Statisches Formular
Siehe Festes Layout.
Zurück zum Anfang
T
Teilformular
Ein Abschnitt eines Formularentwurfs zum Erstellen eines Formulars mit flexiblem Layout. Ein Teilformular kann Text, Grafik oder Felder enthalten.
Textbausteinobjekt
Ein statisches Objekt in einem Formular, beispielsweise Text, eine Linie, ein Kreis oder ein Rechteck.
Zurück zum Anfang
V
Vertrauenswürdige Identitäten
Vom dazugehörigen Zertifikat erkannte Identitäten. Nur die angegebenen vertrauenswürdigen Identitäten können ein Formular digital unterschreiben.
Verwendungsrechte
Berechtigungen, die die Funktionalität von Adobe Reader erweitern und Benutzern die Möglichkeit geben, Formulare mit Daten zu speichern, Kommentare hinzuzufügen und Dokumente zu unterschreiben.
Vorausgefülltes Formular
Ein Formular, das dem Benutzer so angezeigt wird, dass einige oder alle Felder bereits automatisch mit Daten aufgefüllt sind.
Zurück zum Anfang
W
Wiedergabe
Eine Aktion, bei der von LiveCycle Forms ein Formularentwurf abgerufen, gegebenenfalls mit Daten zusammengeführt und im PDF- oder HTML-Format in einem Browser angezeigt wird.
Zurück zum Anfang
X
XML-Formular
Ein Formular auf der Basis der XML-Formulararchitektur. XML-Formulare werden in LiveCycle Designer erstellt und können die Dateinamenerweiterungen „.xdp“ oder „.pdf“ haben.
XML-Formulararchitektur
Bildet die Basistechnologie zur Adobe XML-Formularlösung. Sie ermöglicht die Erstellung robuster und flexibler formularorientierter Anwendungen zur Verwendung auf dem Client oder dem Server.
Zurück zum Anfang
Z
Zertifikat
Ein öffentlicher Schlüssel, der zu einem privaten Schlüssel (Credential) passt und bei Verschlüsselungs- und Unterschriftsvorgängen verwendet wird. Siehe auch Adobe-zertifiziertes Dokument.
Zurück zum Anfang


Copyright- und Marken-Hinweise

Copyright- und Marken-Hinweise

© 2006 Adobe Systems Incorporated. Alle Rechte vorbehalten.
Adobe® LiveCycle® Designer 8.0-Hilfe für Microsoft® Windows®
Oktober 2006
Wenn dieses Handbuch mit Software vertrieben wird, zu der eine Endbenutzervereinbarung gehört, unterliegen dieses Handbuch und die darin beschriebene Software einem Lizenzvertrag und dürfen nur in Übereinstimmung mit den Vertragsbestimmungen verwendet oder vervielfältigt werden. Kein Teil dieses Handbuchs darf, sofern nicht per Lizenzvertrag ausdrücklich erlaubt, ohne die vorherige schriftliche Genehmigung von Adobe Systems Incorporated reproduziert, in Datenbanken gespeichert oder in irgendeiner Form – elektronisch, fotomechanisch, auf Tonträgern oder auf irgendeine andere Weise – übertragen werden. Beachten Sie, dass der Inhalt dieses Handbuchs urheberrechtlich geschützt ist, auch wenn es nicht mit der Software geliefert wird, die eine Endbenutzerlizenzvereinbarung enthält.
Der Inhalt dieses Handbuchs dient ausschließlich Informationszwecken, kann ohne Vorankündigung geändert werden und ist nicht als Verpflichtung von Adobe Systems Incorporated anzusehen. Adobe Systems Incorporated übernimmt keine Haftung für Fehler oder Ungenauigkeiten, die in den in diesem Handbuch enthaltenen Informationen auftreten können.
Beachten Sie, dass die Grafiken oder Abbildungen, die Sie eventuell in Ihrem Projekt verwenden möchten, urheberrechtlich geschützt sein können. Das Einfügen solchen Materials in Ihre neue Arbeit kann eine Urheberrechtsverletzung darstellen. Holen Sie vorher die Erlaubnis vom Inhaber der Urheberrechte ein.
Verweise auf Firmennamen und Firmenlogos in Mustermaterialien oder Musterformularen, die in dieser Software enthalten sind, dienen ausschließlich Demonstrationszwecken und verweisen nicht auf tatsächlich bestehende Organisationen.
Adobe, das Adobe-Logo, Acrobat, Distiller, LiveCycle, Minion, Myriad, PostScript und Reader sind Marken oder eingetragene Marken von Adobe Systems Incorporated in den USA und/oder anderen Ländern.
Microsoft, Windows und ActiveX sind entweder eingetragene Marken oder Marken der Microsoft Corporation in den USA und/oder anderen Ländern.
SVG ist eine Marke des World Wide Web Consortium; Marken von W3C sind eingetragen und werden von den Hauptinstitutionen MIT, INRIA und Keio beansprucht.
Alle anderen Marken sind Eigentum ihrer jeweiligen Inhaber.
Dieses Produkt umfasst von der Apache Software Foundation (http://www.apache.org/) entwickelte Software.
Adobe Systems Incorporated, 345 Park Avenue, San Jose, California 95110, USA.
Hinweis für Endbenutzer in US-Behörden. Software und Dokumentation sind „Commercial Items“ (kommerzielle Güter) gemäß Definition aus 48 C.F.R. §2.101. Sie bestehen aus „Commercial Computer Software“ (kommerzieller Computersoftware) und „Commercial Computer Software Documentation“ (kommerzieller Computersoftwaredokumentation) im Sinne von 48 C.F.R. §12.212 oder 48 C.F.R. §227.7202, falls anwendbar. In Übereinstimmung mit 48 C.F.R. §12.212 oder 48 C.F.R. §§227.7202-1 bis 227.7202-4 werden „Commercial Computer Software“ und „Commercial Computer Software Documentation“ für Benutzer in US-Regierungsbehörden (a) lediglich als „Commercial Items“ und (b) nur mit den Rechten lizenziert, die allen anderen Benutzern gemäß den dokumentierten Geschäftsbedingungen eingeräumt werden. Nicht veröffentlichte Rechte sind unter den Urheberrechtsgesetzen der USA vorbehalten. Adobe Systems Incorporated, 345 Park Avenue, San Jose, CA 95110-2704, USA. Für Benutzer aus US-Regierungsbehörden hält Adobe alle anwendbaren Gleichberechtigungsgesetze, ggf. auch die Bestimmungen von Executive Order 11246 und Zusätze, Abschnitt 402 des Vietnam Era Veterans Readjustment Assistance Act von 1974 (38 USC 4212) und Abschnitt 503 des Rehabilitation Act von 1973 und Zusätze sowie die Bestimmungen von 41 C.F.R., Teile 60-1 bis 60-60, 60-250 und 60-741, ein. Die Antidiskriminierungsklausel und Bestimmungen aus dem vorangehenden Satz werden durch Verweis berücksichtigt.