はじめに

XFX 1 は、現在、DirectX 互換のその他のアプリケーションを使用しているユーザーに対して Sound Forge ユーザーに人気の高品質エフェクトを使用できる環境を提供するために開発されました。

XFX 1 には、シンプル ディレイ、マルチタップ ディレイ、コーラス、リバーブ、ピッチ シフト、および時間圧縮/展開という個別の 6 種類のプラグインがあります。


XFX 1 の使用

XFX 1 は、あらゆる Microsoft DirectX 対応ホスト アプリケーションで使用できます。プラグインの品質と機能はどのホスト アプリケーションでも変わりませんが、エフェクトのプレビュー方法は異なります。プレビュー方法については、使用しているホスト アプリケーションのマニュアルを参照してください。

DirectX の実装はホスト アプリケーションによって異なります。そのため、リアルタイム プレビューに関する問題が発生することがあります。

使用するエフェクトを選択してください。

シンプル ディレイ

マルチタップ ディレイ

コーラス

リバーブ

ピッチ シフト

時間圧縮/展開


シンプル ディレイ

シンプル ディレイ エフェクトを使用すると、かすかな環境音や、スラップバック エコーなど、さまざまなエフェクトを作成できます。

  1. [シンプル ディレイ] ダイアログ ボックスを開きます。

  2. [名前] ドロップダウン リストからプリセット値を選択するか、次の手順に従ってコントロールを調整します。

  3. a. ドライ アウト フェーダーをドラッグして、出力にミキシングする未処理信号のレベルを設定します。

  4. b. ディレイ アウト フェーダーをドラッグして、出力にミキシングするディレイ信号のレベルを設定します。

  5. c. ディレイ時間を設定します。

  • ディレイ時間スライダをドラッグして、ドライ信号とディレイ信号の間隔を設定します。

— または —

  • ホスト アプリケーションがテンポベースのエフェクトをサポートしている場合は、[テンポ同期のディレイ] チェック ボックスをオンにし、[ディレイ時間 (テンポ)] コントロールを使用して、楽曲時間におけるディレイ時間を設定します。

ヒント:

  • ディレイ時間が非常に短い場合 (約 3 ミリ秒) は、 コムフィルタ エフェクトが生成されます。

  • 中程度の場合 (約 25 ミリ秒) は、ダブリング エフェクトが生成され、サウンドが重厚になります。

  • 長い場合 (約 65 ミリ秒) は、密度の高いミックスでリバーブの代わりに使用できます。

  1. d. 徐々にフェード アウトする複数のエコーを作成する場合は、[マルチ ディレイ (フィードバック)] チェック ボックスをオンにして、ディケイ時間を設定します。

  2. ディケイ時間スライダをドラッグして、徐々にフェード アウトする複数のエコーを作成します。

    ディケイ時間スライダを使用して、複数のディレイがほとんど聞こえなくなるまでの時間を指定します。

— または —

  • ホスト アプリケーションがテンポベースのエフェクトをサポートしている場合は、[テンポ同期のフィードバック] チェック ボックスをオンにし、[ディケイ時間 (テンポ)] コントロールを使用して、楽曲時間におけるディケイ時間を設定します。


マルチタップ ディレイ

  1. [マルチタップ ディレイ] ダイアログ ボックスを開きます。

  2. [名前] ドロップダウン リストからプリセット値を選択するか、次の手順に従ってコントロールを調整します。

a. 入力ゲイン フェーダーをドラッグして、信号を処理する前に適用するゲインを設定します。

b. ドライ アウト フェーダーをドラッグして、出力にミックスする未処理信号のレベルを設定します。

c. ウェット アウト フェーダーをドラッグして、出力にミックスする処理済み信号のレベルを設定します。

d. 必要に応じてタップを調整します。

e. モジュレーションを調整します。

f. フィードバック スライダをドラッグして、追加のエコーを作成します。フィードバックの割合を 100% より大きい値に設定すると、エコーが繰り返されるにつれて音が次第に大きくなります。

g. 高周波音をフィルタリングする場合は、[ローパス開始周波数] チェック ボックスをオンにして、スライダをドラッグします。

[マルチタップ ディレイ] ウィンドウは、各タップを個別に調整できるように設定されています。使用するタップの数を選択するには、タップ数スライダをドラッグするか、スライダの右にある矢印ボタンをクリックします。

特定のタップの調整

  1. 調整するタップに対応する [現在のタップ] ラジオ ボタンをクリックします。

  2. タップ ゲイン フェーダーをドラッグして、オリジナルの信号およびその他のタップと対比したタップの音量を指定します。

[タップ ゲイン] に負の値を指定すると、タップは残りの信号のフェーズから 180 度外れることになります。

  3. ディレイ スライダをドラッグ (または編集ボックスに値を入力) して、ドライ信号とディレイ信号との間隔を設定します。

音は約 1 フィート/ミリ秒の速さで移動するため、特定のルーム サイズをシミュレートするには、室内のすべての壁からの反響が一致するようにディレイを設定します。大きいルームの場合は、音が反響面に到達するまでに時間がかかります。したがって、エコーの間隔を長く設定すると、広い空間にいるような感覚を作り出すことができます。

  4. パン スライダをドラッグして、現在のタップを左右にパンします。スライダをダブルクリックすると、タップは中間の位置に戻ります。

パン スライダはステレオ ファイルを操作している場合にのみ使用できます。

エコーグラムの使用

エコーグラムは、現在の設定で指定された一定時間における音響の振幅 (インパルス応答) を表します。縦の線はそれぞれオリジナル サウンドのエコーを表します。線の長さは振幅度 (オリジナル サウンドに対比した割合) に対応しており、左端からの横方向の長さはオリジナル サウンド以降の経過時間を表します。赤い線は現在選択されているタップ、黒い線はアクティブな別のタップ、青い線はフィードバックによるエコーを表します。

グラフの解像度スライダをドラッグして、グラフの表示間隔を指定します。

上のグラフ例には、8 つのタップが表示されています。各タップのゲインは前のタップより小さく、3番目のタップは [現在のタップ] ラジオ ボタンがオンになっているため、強調表示されています。

マルチタップ ディレイ内のすべてのタップを変調すると、幅広いコーラスやその他のエフェクトを作成できます。

モジュレーション レート スライダをドラッグして、ディレイ時間の変調速度を制御します。速度を遅くすると変化はわずかになり、速度を速くするとエフェクトはより強調されます。

モジュレーション深度スライダをドラッグして、ディレイ時間の変調範囲を制御します。

ローパス フィルタを適用すると、高周波数のコンテンツをカスタマイズして、別の周波数曲線を作成できます。

高周波音をフィルタリングする場合は、[ローパス開始周波数] チェック ボックスをオンにして、スライダをドラッグします。スライダを左に動かすと高周波音がさらにフィルタリングされ、右に動かすと残される高周波音が多くなります。つまり、より明るいサウンドになるか、よりミュートされたサウンドになります。

マルチタップ ディレイ

マルチタップ ディレイでは、複数の独立したディレイを使用することで、複雑なディレイ パターンを作成できます。各ディレイ タップには、独自のディレイ時間、振幅、およびステレオ パン コントロールがあります。

複雑なリズム ディレイから擬似リバーブに至るまで、マルチタップ ディレイ エフェクトを使用したさまざまなエフェクトを作成できます。

実行する操作を選択してください。

マルチタップ ディレイの適用

タップの調整

ディレイ時間の変調

ローパス フィルタの適用


コーラス

  1. [コーラス] ダイアログ ボックスを開きます。

  2. [名前] ドロップダウン リストからプリセット値を選択するか、次の手順に従ってコントロールを調整します。

a. 入力ゲイン フェーダーをドラッグして、信号を処理する前に適用するゲインを設定します。

b. ドライ アウト フェーダーをドラッグして、出力にミックスする未処理信号のレベルを設定します。

c. コーラス アウト フェーダーをドラッグして、出力にミックスする処理済み信号のレベルを設定します。

d. モジュレーション レートを設定して、ディレイ時間の変調速度を指定します。

  • モジュレーション レート スライダをドラッグして、ディレイ時間の変調速度を指定します。わずかな変調を適用するには 0.3～1 Hz の値にします。高い値にすると、より強烈な効果を得ることができます。

— または —

  • ホスト アプリケーションがテンポベースのエフェクトをサポートしている場合は、[テンポの同期] チェック ボックスをオンにし、[モジュレーション期間] コントロールを使用して、楽曲時間におけるモジュレーションの長さを設定します。

[モジュレーション深度] 設定の値を上げないと、モジュレーションは聞こえません。

e. モジュレーション深度 スライダをドラッグして、ディレイ時間を初期設定からどの程度変調するかを指定します。設定値を高くすると、非同調エフェクトが作成されます。低い設定値は、豊かな音色のギター エフェクトおよびストリング エフェクトを作成する場合に適しています。

f. コーラス アウトのディレイ スライダをドラッグして、モジュレーションの中間点になるディレイ時間を選択します。

コーラス エフェクトは、通常、ソース素材の種類により 25～50 ミリ秒のディレイ時間で作成されます。ディレイ時間が短いとフランジ エフェクトが作成され、ディレイ時間が長いとダブリング エフェクトまたはスラップバック ディレイ エフェクトが作成されます。

コーラス サイズ スライダをドラッグして、選択した素材をコーラス アルゴリズムで何回処理するかを指定します。

[コーラス サイズ] 設定に大きな値を指定すると、エフェクトに深みが加わり、[フィードバック] 設定のエフェクトが強調されます。

フィードバック スライダをドラッグして、再処理が必要な処理済み信号の割合を指定します。

フィードバック値を大きくすると、コーラス エフェクトに厚みを与えることができます。フィードバックの設定値を大きくすることによって、ディレイが信号に追加されます。その結果は、コーラスの周囲がわずかに大きくなったり、独立した劇的なエコーが追加されるなど、さまざまです。

処理済み信号のフェーズを未処理信号にミックスする前に反転する場合は、[コーラス フェーズの反転] チェック ボックスをオンにします。

フィードバック信号のフェーズをコーラス信号に追加する前に反転する場合は、[フィードバック フェーズの反転] チェック ボックスをオンにします。

サウンド データを反転すると、ベースライン付近の波形の極性が逆になります。波形を反転してもファイルのサウンドは変わりません。ただし、別のサウンド ファイルをミックスすると、フェーズがキャンセルされ、「こもった」感じのサウンドが生成されます。ファイルの 1 つを反転することで、フェーズがキャンセルされないようにすることができます。

次の例では、赤い線はベースラインを表し、下の波形は上の波形を反転したイメージです。

[高周波数を減衰する] チェック ボックスをオンにし、スライダをドラッグして、ローパス フィルタを選択範囲に適用します。スライダで指定した周波数より上の周波音はフィルタリングされます。

この機能を使用すると、広範な非コーラス エフェクトを作成できます。[モジュレーション深度] の値が大きいとビブラート エフェクトが生成され、[コーラス アウト ディレイ] の値が小さいとフランジが生成されます。

コーラス

コーラス エフェクトは、同じノートを演奏する同じ楽器のさまざまなサウンドをシミュレートします。コーラス エフェクトを追加するには、非常に短いディレイを追加してディレイ時間を変調します。

コーラス設定は弦楽器に対して非常に効果があります。また、ボーカルやその他の楽器に対する特殊エフェクトとしても使用できます。

実行する操作を選択してください。

シンプル コーラスの適用

コーラス サイズを大きくする

フィードバックの追加

コーラス/フィードバック信号のフェーズの反転

高周波数の減衰


リバーブ

  1. [リバーブ] ダイアログ ボックスを開きます。

  2. [名前] ドロップダウン リストからプリセット値を選択するか、次の手順に従ってコントロールを調整します。

a. ドロップダウン リストから残響モードを選択します。

これらのモードは、[リバーブ] ダイアログ ボックスで選択可能なリバーブ シミュレーションの基本的な種類を表します。これらのモードによって、リバーブの長さではなく、リバーブを構成するエコーの拡散や反響パターンなどのパラメータが決定されます。

b. ドライ アウト フェーダーをドラッグして、出力にミックスする未処理信号のレベルを設定します。

c. リバーブ アウト フェーダーをドラッグして、出力にミックスする処理済み信号のレベルを設定します。

d. ドロップダウン リストから初期反射スタイルを選択し、初期出力 スライダをドラッグして、出力にミックスする初期反射音を調整します。

初期反射音とは、空間で音が発生したときに最初に聞こえる反射音のことです。このような反射音が人間の耳に届くまでに反射する回数は、通常 1 回です。人間の耳はこの最初の反射音を利用して、空間の大きさを判断します。

e. ディケイ時間スライダをドラッグして、リバーブの長さを指定します。ディケイ時間とは、リバーブが初期レベルより -60 dB より下にディケイするまでにかかる時間のことです。通常、3 秒を超えるリバーブは非常に長いと言えます。一般に狭い室内でのディケイ時間は 1 秒未満です。

f. プリディレイ スライダをドラッグして、初期サウンドからリバーブが開始されるまでの時間を指定します。プリディレイは、人間の耳が空間の大きさを感知するためのパラメータでもあります。通常、空間が大きい場合はプリディレイ時間を長くします。

ドライ アウト、リバーブ アウト、および初期出力の各フェーダーを調整することによって、サウンドを形成し、作成した空間にいるリスナーの近くまたは遠くに音源を配置することができます。ドライ信号のバランスを高くすると、音源が近くなります。リバーブのバランスを高くすると、音源は空間内で遠くに配置されます。

リバーブを使用すると、音が空間内で反響するため、高周波音と低周波音は失われる傾向があります。信号にハイパス フィルタとローパス フィルタを適用すれば、空間内で失われるこれらの周波音をシミュレートできます。

低周波音をフィルタリングする場合は、 [バス周波数を減衰する] チェック ボックスをオンにして、スライダをドラッグします。指定した周波数より低い音は減衰されます。

高周波音をフィルタリングする場合は、 [高周波数を減衰する] チェック ボックスをオンにして、スライダをドラッグします。指定した周波数より高い音は減衰されます。

薄暗い室内の場合は通常、4000 Hz を超える高周波音は減衰されます。室内が明るいほど、減衰の対象となる周波数は高くなります。

リバーブ

リバーブを使用すると、クローズマイキング テクニックで失われる空間を再現することができます。また、通常は聞こえない空間に音源を配置して、エフェクトを作成する場合にも使用できます。

実行する操作を選択してください。

シンプル リバーブの適用

音源とリバーブ信号の配置の調整

ハイパス フィルタとローパス フィルタの適用


ピッチ シフト

  1. [ピッチ シフト] ダイアログ ボックスを開きます。

  2. [名前] ドロップダウン リストからプリセット値を選択するか、次の手順に従ってコントロールを調整します。

a. ピッチ シフトする半音 スライダをドラッグ (または編集ボックスに値を入力) して、選択範囲のピッチを調整します。

[長さの維持] チェック ボックスがオンの場合、このスライダで調整できるのは -12～12 の範囲の半音に限られます。

b. ピッチ シフトするセント数 スライダをドラッグ (または編集ボックスに値を入力) して、選択範囲のピッチを調整します。

半音は 100 セントから構成され、1 オクターブは 12 の半音から構成されます。ボーカル トラックをチューニングする場合は、セント スライダを使用してピッチを調整するのが一般的です。

c. 精度スライダをドラッグして、ピッチ シフト アルゴリズムを正確に設定します。 [精度] の設定値を高く すると、処理が遅くなります。

コンピュータでピッチ シフトのプレビューに問題がある場合は、[精度] の設定値を低くしてみてください。使用する設定を選択したら、処理の精度を元の高い設定に戻します。

信号のピッチを上げたときのエイリアシング ディストーションを最小限にするには、[ピッチ シフト中にアンチエイリアス フィルタを適用] チェック ボックスをオンにします。

ピッチ シフトを上げると、サンプリング周波数の 1/2 高い周波音 (ナイキスト周波数) が生成されます。アンチ エイリアス フィルタはこれらの周波音を取り除くため、潜在的なエイリアシング ディストーションが削除されます。

ピッチ シフトを下げる場合は、このチェック ボックスは使用できません。

[長さの維持] チェック ボックスをオンにして、ドロップダウン リストからモードを選択します。

ピッチ シフトには 19 種類のモードがあり、各モードはそれぞれ特定の素材の品質を最高に保つように設計されています。たとえば、ドラムに最適なモードは弦楽器には適しません。

ピッチの変更で使用する半音が 12 を超えると、[長さの維持] コントロールは使用できません。

ピッチ シフト

ピッチ シフト エフェクトは、信号の長さを変えずに音のピッチを変更します。このエフェクトを使用すると、調子の外れたノートを直したり、曲のキーを変えることができます。

実行する操作を選択してください。

長さを維持せずにピッチを変更

処理中にアンチ エイリアス フィルタを適用

長さを変えずにピッチを変更


タイム ストレッチ

  1. [タイム ストレッチ] ダイアログ ボックスを開きます。

  2. [名前] ドロップダウン リストからプリセット値を選択するか、次の手順に従ってコントロールを調整します。

a. ドロップダウン リストからモードを選択します。

タイム ストレッチには 19 種類のモードがあり、各モードはそれぞれ特定の素材の品質を最高に保つように設計されています。たとえば、ドラムに最適なモードは弦楽器には適しません。

最適な比率は 75～115% です。この範囲外の値を指定すると、エコー、フランジ、欠落などの劣化が生じます。また、増分を小さくして (105% など) 処理を複数回実行すると、大幅に時間を変えて一度に処理した場合とは違った効果が得られます。

b. 最終割合スライダをドラッグして、選択範囲の長さを変更します。

[入力形式] ドロップダウン リストの設定に応じて、 最終割合スライダは、最終割合、 最終時間、または 最終テンポとして表示される場合があります。

タイム ストレッチ機能を使用すると、オリジナルの割合、時間、テンポの 3 種類の方法でサウンドの長さを変更できます。[入力形式] ドロップダウン リストから設定を選択して、時間形式を変更します。

DirectX では処理中のデータの合計の長さをプラグインに通知しないため、時間またはテンポ設定を使用する場合は、事前にプラグインに通知する必要があります。たとえば、32 秒のサウンド ファイルを 30 秒にする必要がある場合は、最初に [入力形式] ドロップダウン メニューから [時間] を選択して、[初期時間] ボックスに「00:00:32」と入力する必要があります。次に、最終時間スライダをドラッグして、サウンドの長さを変更します。[最終時間] ボックスに 00:00:30 と表示されるまで、スライダをドラッグします。

タイム ストレッチ

タイム ストレッチ エフェクトを使用すると、ピッチを変えずに信号の長さを変更できます。

実行する操作を選択してください。

サウンドの長さの変更

時間形式の変更


トラブルシューティング

ここでは、XFX 1 のパフォーマンスに関する一般的な問題の解決方法について説明します。

項目をクリックすると詳細情報を表示します。

リアルタイム プレビュー時にスタッターが発生する

Sound Forge で選択した素材の処理中にグリッチが発生する


リアルタイム プレビュー時にスタッターが発生する

XFX プラグインのリアルタイム プレビュー時に問題が発生した場合は、次のいずれかの手順に従ってください。

DirectX のバッファ サイズを大きくする

Sound Forge で、XFX プラグイン ウィンドウのタイトル バーを右クリックして、ショートカット メニューから [プレビュー設定] を選択します。[処理バッファ数/秒] の値を小さくするか、[合計再生バッファ数] の値を大きくして (またはその両方)、ギャップを小さくします。ただし、この設定によりコントロールの応答は鈍くなります。数秒でプレビュー時の音が変わります。

高速浮動小数点演算に対応した高速プロセッサを使用する

Sound Forge でプラグインを使用している場合は、各プラグイン ウィンドウの下部に CPU 使用率メーターが表示されます。

このメーターを参照すれば、コンピュータがリアルタイム プレビューをどのように処理しているかの概要を把握することができます。使用率が 100% を超えると、スタッターの問題が発生しやすくなります。


Sound Forge で選択した素材の処理中にグリッチが発生する

選択した素材と選択していない素材の間のトランジションでグリッチが生じる場合は、クロスフェード エッジ機能を有効にしてください (Sound Forge 4.0d 以上)。この機能は、ファイルの中間にあるオーディオの微小な部分をピッチ シフトまたは時間圧縮する場合に特に便利です。

  1. XFX プラグイン ウィンドウのタイトル バーを右クリックして、ショートカット メニューから [設定のプレビュー] を選択します。

  2. [クロスフェード エッジ] チェック ボックスをオンにして、クロスフェード時間を指定します。

[クロスフェード エッジ] の設定はプラグインに依存します。つまり、各プラグインで独自の設定が維持されます。


ようこそ

Sony Pictures Digital Web サイトの XFX 1 ページにアクセス

Copyright ©2005.Madison Media Software, Inc. (Sony Corporation of America の子会社)
 | All Rights Reserved
 | 改訂日:2005 年 7 月 1 日