Introduction

XFX 1 a été développé pour offrir aux utilisateurs d'autres applications compatibles avec DirectX, la possibilité d'utiliser des effets haute qualité dont les utilisateurs de Sound Forge sont devenus friands.

XFX 1 contient six modules discrets : Retard simple, Retard complexe, Effet Chorus, Réverbération, Ajustement de la hauteur du son et Étirement de la durée.


Utilisation de XFX 1

Vous pouvez utiliser XFX 1 dans n'importe quelle application hôte compatible avec Microsoft DirectX. La qualité et les fonctionnalités des modules externes sont identiques quelle que soit l'application hôte. Toutefois, la méthode de prévisualisation des effets varie. Pour connaître les méthodes de prévisualisation disponibles, consultez la documentation de votre application hôte.

Certaines implémentations de DirectX varient selon les applications hôtes. Ceci peut causer des problèmes lors de la prévisualisation en temps réel.

Quel effet voulez-vous utiliser ?

Retard simple

Retard complexe

Effet Chorus

Réverbération

Ajustement de la hauteur du son

Étirement de la durée


Retard simple

L'effet Retard simple vous permet de créer une ambiance subtile, des échos de retour de claquement et d'autres effets intéressants.

  1. Ouvrez la boîte de dialogue Retard simple.

  2. Choisissez une valeur dans la liste déroulante Nom ou ajustez les commandes au besoin :

  3. a. Déplacez le fondu Sortie sèche pour définir le niveau du signal non traité qui sera mélangé dans la sortie.

  4. b. Déplacez le fondu Retard de sortie pour définir le niveau du signal non traité qui sera mélangé dans la sortie.

  5. c. Définissez la durée du retard :

  • Déplacez le curseur Durée du retard pour définir l'interface entre le signal sec et le signal retardé.

—ou—

  • Si votre application hôte prend en charge les effets basés sur le tempo, activez la case à cocher Retard de synchronisation de tempo et utilisez les commandes Durée du retard (Tempo) pour définir la longueur du retard en temps musical.

Conseils :

  • Un retard très court (environ 3 millisecondes) produit un effet de filtre combiné.

  • Un retard moyen (environ 25 millisecondes) produit un effet de doublage qui amplifie un son.

  • Un retard plus important (environ 65 millisecondes) peut se substituer à une réverbération dans les mixages denses.

  1. d. Si vous souhaitez créer plusieurs échos disparaissant en fondu, activez la case à cocher Retards multiples (commentaires) et définissez la longueur de l'affaiblissement :

  2. Déplacez le curseur Durée d'affaiblissement pour créer plusieurs échos disparaissant graduellement en fondu.

    Ce curseur     détermine le temps nécessaire à plusieurs retards pour devenir pratiquement inaudibles.

—ou—

  • Si votre application hôte prend en charge les effets basés sur le tempo, activez la case à cocher Retour de la synchronisation de tempo et utilisez les commandes Durée de l'affaiblissement (Tempo) pour définir la longueur du retard en temps musical.


Retard complexe

  1. Ouvrez la boîte de dialogue Retard complexe.

  2. Choisissez une valeur dans la liste déroulante Nom ou ajustez les commandes au besoin :

a. Déplacez le fondu Gain en entrée pour définir le gain appliqué au signal avant le traitement.

b. Déplacez le fondu Sortie sèche pour définir le niveau du signal non traité qui sera mélangé dans la sortie.

c. Déplacez le fondu Sortie modérée pour définir le volume de signal traité qui sera mélangé dans la sortie.

d. Ajustez les commandes au besoin.

e. Réglez la modulation.

f. Déplacez le curseur Feedback pour créer des échos supplémentaires. Les pourcentages de feedback supérieurs à 100 % créent des échos répétés qui s'amplifient avec le temps.

g. Activez la case à cocher Fréq. de départ passe-bas et déplacez le curseur si vous souhaitez filtrer les hautes fréquences.

La fenêtre Retard complexe permet de régler chaque tap séparément. Pour choisir le nombre de taps à utiliser, déplacez le curseur Nombre de taps ou cliquez sur les boutons fléchés à droite du curseur.

Pour régler un tap

  1. En regard de Tap actuel, sélectionnez la case d'option correspondant au tap que vous souhaitez régler.

  2. Déplacez le fondu Gain de tap pour indiquer le volume sonore du tap par rapport au signal original et aux autres taps.

Un paramètre Gain de tap négatif signifie que le tap est déphasé de 180 degrés par rapport au reste du signal.

  3. Déplacez le curseur Retard (ou saisissez une valeur dans la zone d'édition) pour définir l'interface entre le signal sec et le signal retardé.

Le son voyageant à environ 31 cm par milliseconde, vous pouvez simuler une pièce d'un volume donné en définissant des retards correspondant aux réflexions sur les parois de la pièce. Dans une grande pièce, le son doit se déplacer davantage pour atteindre les parois. Par conséquent, en décalant les échos, vous créez l'impression d'un espace plus volumineux.

  4. Déplacez le curseur Panoramique pour diriger le tap actuel vers la gauche ou vers la droite. Cliquez deux fois sur le curseur pour le ramener au milieu.

Le curseur Panoramique n'est disponible que si vous manipulez un fichier stéréo.

Pour utiliser l'échogramme

L'échogramme représente l'amplitude des réflexions sonores en fonction du temps (réponse aux impulsions), telles qu'elles sont déterminées par les paramètres configurés. Chaque ligne verticale représente un écho du son initial. La longueur de chaque ligne indique son amplitude (en pourcentage du son initial), tandis que sa distance horizontale par rapport au bord gauche indique le temps écoulé après le son initial. La ligne rouge signale le tap sélectionné. Les lignes noires sont les autres taps actifs. Les lignes bleues sont des échos du signal de feedback.

Déplacez le curseur Résolution graphique pour définir l'intervalle affiché dans le graphique.

Cet exemple de graphique contient huit taps. Le gain de chaque tap est inférieur au tap précédent. Le troisième tap apparaît en surbrillance car il est sélectionné dans les cases d'option Tap actuel.

Vous pouvez moduler tous les taps du Retard complexe pour créer un effet de chorus riche ou d'autres effets.

Déplacez le curseur Vitesse du modulateur pour déterminer la rapidité de modulation des retards. Une valeur plus faible crée des changements subtils. Au contraire, une valeur supérieure crée des effets plus intenses.

Déplacez le curseur Profondeur du modulateur pour contrôler la plage de modulation des retards.

Vous pouvez appliquer un filtre passe-bas pour personnaliser les hautes fréquences et créer différents contours de fréquences.

Activez la case à cocher Fréq. de départ passe-bas et déplacez le curseur pour filtrer les hautes fréquences. Déplacez-le vers la gauche pour filtrer davantage les hautes fréquences ou vers la droite pour les conserver. Vous obtenez un son plus clair ou plus ténu.

Retard complexe

L'effet Retard complexe vous permet de créer des motifs de retard complexe grâce à plusieurs retards discrets. Chaque tap a sa propre durée, sa propre amplitude et ses propres commandes de panoramique stéréo.

Avec l'effet Retard complexe, vous pouvez créer toute une gamme d'effets, depuis des retards rythmiques complexes jusqu'à des pseudo-réverbérations.

Que voulez-vous faire ?

Appliquer un retard complexe

Ajuster les taps

Moduler les temps de retard

Appliquer un filtre passe-bas


Effet Chorus

  1. Ouvrez la boîte de dialogue Effet Chorus.

  2. Choisissez une valeur dans la liste déroulante Nom ou ajustez les commandes au besoin :

a. Déplacez le fondu Gain en entrée pour définir le gain appliqué au signal avant le traitement.

b. Déplacez le fondu Sortie sèche pour définir le niveau du signal non traité qui sera mélangé dans la sortie.

c. Déplacez le fondu Sortie chorus pour définir le volume de signal traité qui sera mélangé dans la sortie.

d. Définissez le taux de modulation pour déterminer la rapidité de modulation du retard :

  • Déplacez le curseur Taux de modulation pour déterminer la rapidité de modulation du retard. Choisissez une valeur comprise entre 0,3 et 1 Hz pour obtenir une modulation subtile. Une valeur plus élevée produit un effet plus intense.

—ou—

  • Si votre application hôte prend en charge les effets basés sur le tempo, activez la case à cocher Synchroniser tempo et utilisez les commandes Période de modulation pour définir la longueur de la modulation en durée musicale.

La modulation ne sera audible que si vous augmentez la valeur du paramètre Profondeur de modulation.

e. Déplacez le curseur Profondeur de modulation pour déterminer l'amplitude de la modulation du retard hors du paramètre initial. Une valeur supérieure crée des effets de désaccord. Une valeur inférieure est recommandé pour créer des effets de corde et de guitare vivants.

f. Déplacez le curseur Retard de sortie chorus pour sélectionner le retard qui sera le point central de la modulation.

En général, les effets Chorus sont créés avec des retards compris entre 25 et 50 millisecondes, selon le support source. Des retards plus courts créent un effet de flanger, tandis que des retards plus importants créent un effet de doublage ou de retardement de retour de claquement.

Déplacez le curseur Taille de chorus pour spécifier le nombre de traitements de la sélection avec l'algorithme de chorus.

Une valeur supérieure dans Taille de chorus ajoute de la profondeur à l'effet et amplifie les effets du paramètre Feedback.

Déplacez le curseur Feedback pour spécifier le pourcentage du signal traité dont vous souhaitez renouveler le traitement.

L'augmentation du feedback permet également d'épaissir l'effet Chorus. Si vous augmentez la valeur du paramètre Feedback, vous ajoutez des retards supplémentaires au signal. Le résultat peut aller d'une augmentation subtile de l'ampleur du chorus à l'apparition d'échos discrets nets.

Activez la case à cocher Inverser la phase de chorus si vous souhaitez inverser la phase du signal traité avant de le mélanger au signal non traité.

Activez la case à cocher Inverser la phase de lecture si vous souhaitez inverser la phase du signal de feedback avant de le mélanger au signal modifié par le chorus.

L'inversion des données de son entraîne celle de la polarité d'une forme d'onde par rapport à sa ligne de base. L'inversion d'une forme d'onde ne modifie pas le son d'un fichier. Toutefois, lorsque vous mélangez plusieurs fichiers son, un phénomène d'annulation de phase peut apparaître et produire un son « vide ». L'inversion de l'un des fichiers permet d'empêcher cette annulation de phase.

Dans l'exemple ci-dessous, la ligne rouge représente la ligne de base, tandis que la forme d'onde inférieure correspond à l'image inversée de la forme d'onde supérieure :

Activez la case à cocher Atténuer hautes fréquences sup. à et déplacez le curseur pour appliquer un filtre passe-bas à votre sélection. Les fréquences supérieures à celle indiquée par le curseur sont filtrées.

Cette fonction permet de créer un large éventail d'effets qui ne sont pas des effets Chorus : si la valeur du paramètre Profondeur de modulation est élevée, un effet de vibrato apparaît. Si la valeur du paramètre Retard de sortie chorus est faible, un effet de flanger apparaît.

Effet Chorus

L'effet Chorus simule le son de plusieurs instruments identiques jouant les mêmes notes. Pour créer un effet Chorus, le système ajoute des retards très faibles qu'il module.

Très efficace sur les instruments à cordes, le chorus crée un effet particulier sur les voix et les autres instruments.

Que voulez-vous faire ?

Appliquer un chorus simple

Augmenter la taille du chorus

Ajouter un feedback

Inverser la phase du chorus ou du signal de feedback

Atténuer les hautes fréquences


Réverbération

  1. Ouvrez la boîte de dialogue Réverbération.

  2. Choisissez une valeur dans la liste déroulante Nom ou ajustez les commandes au besoin :

a. Choisissez un Mode Réverbération dans la liste déroulante.

Ces modes sont des types de simulation de réverbération qui sont disponibles dans la boîte de dialogue Réverbération. Au lieu de déterminer la longueur de la réverbération, ils déterminent des paramètres comme la diffusion et les motifs de réflexion des échos qui constituent une réverbération.

b. Déplacez le fondu Sortie sèche pour définir le niveau du signal non traité qui sera mélangé dans la sortie.

c. Déplacez le fondu Sortie Réverb pour définir le niveau du signal traité qui sera mélangé dans la sortie.

d. Choisissez une option dans la liste déroulante Style de reflet préliminaire et déplacez le curseur Sortie préliminaire pour ajuster les réflexions précoces mélangées dans la sortie.

Les réflexions précoces sont les premières réflexions que vous entendez lorsqu'un son est émis dans un espace. En général, elles n'ont rebondi qu'une fois lorsqu'elles atteignent vos oreilles. L'oreille humaine s'appuie sur ces premières réflexions pour évaluer la taille d'un espace.

e. Déplacez le curseur Durée d'affaiblissement pour indiquer la longueur de la réverbération. La durée d'affaiblissement est le temps nécessaire à la réverbération pour s'affaiblir à -60 dB sous son niveau initial. En général, une réverbération de plus de trois secondes est considérée comme très longue. Pour une petite pièce, la durée d'affaiblissement est inférieure à une seconde.

f. Déplacez le curseur Pré-retard pour indiquer le temps entre le son initial et le début de la réverbération. Le pré-retard est un autre paramètre qui permet à l'oreille humaine d'évaluer le volume d'un espace. Une durée de Pré-retard longue révèle généralement un espace important.

Vous pouvez régler les fondus Sortie sèche, Sortie Réverb et Sortie préliminaire pour sculpter le son et le rapprocher ou l'éloigner de la personne qui l'écoute dans l'espace que vous avez créé. Une balance supérieure du signal sec rapproche la source. Une balance supérieure de la réverbération éloigne la source dans l'espace.

La réverbération tend à perdre les hautes fréquences et les basses fréquences après plusieurs réflexions dans un espace. Pour simuler cette perte des fréquences, vous pouvez appliquer des filtres passe-haut et passe-bas.

Activez la case à cocher Atténuer les basses fréquences inf. à et déplacez le curseur pour filtrer les basses fréquences. Les sons dont la fréquence est inférieure à la fréquence spécifiée sont atténués.

Activez la case à cocher Atténuer les hautes fréquences sup. à et déplacez le curseur pour filtrer les hautes fréquences. Les sons dont la fréquence est supérieure à la fréquence spécifiée sont atténués.

En général, les espaces sombres atténuent les hautes fréquences proches de 4000 Hz et au-delà. Dans les espaces lumineux, l'atténuation concerne des fréquences encore supérieures.

Réverbération

L'effet Réverbération vous permet de recréer l'espace. En général, les techniques de prise de son rapprochée ne conservent pas ces données spatiales. L'effet Réverbération permet également de créer des effets en plaçant des sons dans des espaces où ils ne seraient jamais audibles.

Que voulez-vous faire ?

Appliquer une réverbération simple

Ajuster la position de la source et des signaux de réverbération

Appliquer des filtres passe-haut et passe-bas


Ajustement de la hauteur du son

  1. Ouvrez la boîte de dialogue Ajustement de la hauteur du son.

  2. Choisissez une valeur dans la liste déroulante Nom ou ajustez les commandes au besoin :

a. Déplacez le curseur Ajuster la hauteur du son de (ou saisissez une valeur dans la zone d'édition) pour ajuster la hauteur du son de la sélection.

Lorsque la case à cocher Maintenir la durée est activée, ce curseur est limité à la plage comprise entre -12 et 12 demi-tons.

b. Déplacez le curseur Ajuster hauteur du son de xx centièmes (ou saisissez une valeur dans la zone d'édition) pour ajuster la hauteur du son de la sélection.

Un demi-ton contient 100 centièmes et un octave contient 12 demi-tons. Si vous mettez au point une piste vocale, il est fort probable que vous deviez ajuster le curseur Centièmes pour obtenir la hauteur de son souhaitée.

c. Déplacez le curseur Exactitude pour définir la précision de l'algorithme d'ajustement de la hauteur du son. Plus la précision est élevée, plus le traitement est lent.

Si votre ordinateur peine à prévisualiser l'ajustement de la hauteur du son en temps réel, saisissez une valeur plus faible dans le champ Exactitude. Après avoir choisi les paramètres que vous souhaitez utiliser, restaurez la valeur d'exactitude la plus élevée possible pour le traitement.

Activez la case à cocher Appliquer filtre anti-alias pend. l'ajustement de hauteur son pour minimiser la distorsion dite d'aliasing lors de l'augmentation de la hauteur du son d'un signal.

Lorsque vous augmentez la hauteur d'un son, vous risquez de voir apparaître des fréquences supérieures à la moitié de la fréquence d'échantillonnage (appelée fréquence de Nyquist). Le filtre anti-alias supprime ces fréquences et donc toute distorsion de type aliasing.

Cette case à cocher n'est pas disponible lorsque vous réduisez la hauteur du son.

Activez la case à cocher Maintenir la durée et choisissez un Mode dans la liste déroulante.

L'effet Ajustement de la hauteur du son propose 19 modes conçus pour optimiser la qualité de différents types de support. Par exemple, un mode adapté aux percussions n'est pas forcément idéal pour les cordes.

Les commandes Maintenir la durée ne sont pas disponibles lorsque vous modifiez la hauteur du son de plus de 12 demi-tons.

Ajustement de la hauteur du son

L'effet Ajustement de la hauteur du son modifie la hauteur d'un son sans changer la durée d'un signal. Utilisez cet effet pour corriger les notes désaccordées et modifier la clé d'une chanson.

Que voulez-vous faire ?

Changer la hauteur du son sans conserver la durée

Appliquer un filtre anti-alias pendant le traitement

Maintenir la durée pendant l'ajustement de la hauteur du son


Étirement de la durée

  1. Ouvrez la boîte de dialogue Étirement de la durée.

  2. Choisissez une valeur dans la liste déroulante Nom ou ajustez les commandes au besoin :

a. Choisissez un Mode dans la liste déroulante.

L'effet Étirement de la durée propose 19 modes conçus pour optimiser la qualité de différents types de support. Par exemple, un mode adapté aux percussions n'est pas forcément idéal pour les cordes.

Vous devriez obtenir d'excellents résultats pour des ratios compris entre 75 et 115 %. Au-delà, vous entendrez des artefacts comme des échos, des flangers ou des blancs. De plus, l'exécution du processus plusieurs fois avec de petits incréments (comme 105 %) crée des effets différents de ceux obtenus lorsque vous appliquez un traitement global avec un changement temporel important.

b. Déplacez le curseur Pourcentage final pour modifier la longueur de la sélection.

Le curseur Pourcentage final peut s'afficher sous la forme Pourcentage final, Durée finale ou Tempo final, selon l'option choisie dans la liste déroulante Format d'entrée.

La fonction Étirement de la durée vous permet de modifier la longueur de vos sons de trois manières : pourcentage de l'original, temps ou tempo. Choisissez une option dans la liste déroulante Format d'entrée pour modifier le format temporel.

DirectX ne permettant pas à un module externe de connaître la longueur totale des données qu'il traite, vous devez au préalable indiquer au module si vous utilisez les paramètres Temps ou Tempo. Par exemple, si votre fichier son dure 32 secondes et que vous devez le raccourcir de 2 secondes, vous devez tout d'abord sélectionner Temps dans la liste déroulante Format d'entrée et saisir 00:00:32 dans le champ Durée initiale. Désormais, lorsque vous déplacez le curseur Durée finale, vous modifiez le son avec la durée comme référence. Déplacez le curseur jusqu'à ce que le champ Durée finale affiche 00:00:30.

Étirement de la durée

L'effet Étirement de la durée vous permet de modifier la longueur d'un signal sans en altérer le timbre.

Que voulez-vous faire ?

Modifier la longueur d'un son

Modifier le format temporel


Dépannage

Cette section contient des solutions à des problèmes de performance concernant XFX 1.

Sur quel sujet souhaitez-vous plus d'informations ?

Bégaiement pendant une prévisualisation en temps réel

Défauts de traitement des sélections dans Sound Forge


Bégaiement pendant une prévisualisation en temps réel

Si vous rencontrez des problèmes lors de la prévisualisation de modules XFX en temps réel, essayez les opérations suivantes :

Augmentez la taille de la mémoire tampon de DirectX

Dans Sound Forge, cliquez avec le bouton droit sur la barre de titre d'une fenêtre du module XFX et sélectionnez Configuration de prévisualisation dans le menu contextuel. Diminuez la valeur du paramètre Tampons à traiter par seconde et/ou augmentez la valeur du paramètre Volume total des tampons de lecture pour réduire les blancs. L'inconvénient réside dans le fait que les commandes sont alors moins réactives. Vous devez patienter environ une seconde avant d'entendre les modifications dans la prévisualisation.

Utilisez un processeur plus rapide avec arithmétique en virgule flottante

Lorsque vous utilisez les modules dans Sound Forge, un indicateur d'utilisation de l'UC apparaît en bas de chaque fenêtre de module.

Cet indicateur vous signale le taux d'utilisation de l'ordinateur lors de la prévisualisation en temps réel. Si ce taux excède 100 %, vous risquez de rencontrer des problèmes de bégaiement.


Défauts de traitement des sélections dans Sound Forge

Si vous constatez de petits défauts dans les transitions entre un support sélectionné et un support non sélectionné, essayez d'activer la fonction Bords de fondu enchaîné (Sound Forge version 4.0d ou ultérieure). Cette fonction est particulièrement utile pour ajuster la hauteur du son ou compresser la durée d'une petite séquence audio située au milieu d'un fichier.

  1. Cliquez avec le bouton droit sur la barre de titre d'une fenêtre du module XFX et sélectionnez Configuration de prévisualisation dans le menu contextuel.

  2. Activez la case à cocher Bords de fondu enchaîné et spécifiez une durée de fondu enchaîné.

Le paramètre Bords de fondu enchaîné est propre au module dans lequel il est défini. Cela signifie que chaque module gère son paramètre.


Bienvenue

Visitez la page XFX 1 du site Web de Sony Pictures Digital

Copyright ©2006. Madison Media Software, Inc., filiale de Sony Corporation of America
 | Tous droits réservés
 | Révisé le 01.07.05