アセンブリ キャッシュ ビューア

.NET Framework 開発者ガイド
アセンブリ キャッシュ ビューア
DropDown image

アセンブリ キャッシュ ビューアは Windows のシェル拡張機能であり、この機能により、Windows エクスプローラでグローバル アセンブリ キャッシュの内容を表示および操作できます。

アセンブリ キャッシュ ビューアの使用

アセンブリ キャッシュ ビューアでは、次の処理を実行できます。

  • キャッシュの内容の表示

  • ダウンロードに関するキャッシュ サイズ制限の表示と変更

  • 個別のアセンブリのプロパティの表示

  • キャッシュへのアセンブリの追加

  • キャッシュからのアセンブリの削除

  • ヘルプ情報の表示

アセンブリ キャッシュの内容を表示するには

  • Windows エクスプローラで、Windows ディレクトリのサブディレクトリ \assembly, (<System Drive>:\<Windows Folder>\assembly) に移動します。グローバル アセンブリ キャッシュの内容が表示されます。

    Shfusion.dll によって、表示される assembly フォルダの内容は通常の Windows フォルダの内容と異なります。グローバル アセンブリ キャッシュにインストールされているアセンブリの名前と、それぞれのアセンブリの型、バージョン、カルチャ、公開キー トークンなどの詳細が表示されます。

    Shfusion.dll は、%windir%\Microsoft.NET\Framework\vx.x.xxxx フォルダにあります。vx.x.xxxx は、インストールされている .NET Framework のうち、最も高いバージョン番号です。たとえば、バージョン v1.1.4322 と v1.0.5000 がインストールされている場合は、v1.1.4322 が使用されます。

次のスクリーンショットは、ビューア内に表示されるアセンブリ キャッシュの内容を示しています。

グローバル アセンブリ キャッシュの内容

ダウンロードに関するキャッシュ サイズ制限を表示および変更するには

  • [ツール] メニュー (Windows NT の場合) または [表示] メニュー (Windows 98 の場合) の [キャッシュ設定] を選択します。または、ツール バーの [キャッシュ設定] アイコンも使用できます。

    上記の操作により、[キャッシュ プロパティ] ダイアログ ボックスが表示されます。このダイアログ ボックスは、従来のドライブのプロパティ ダイアログ ボックスと似ていますが、使用済みのキャッシュ容量がメガバイト単位で表示される点が異なります。

次のスクリーンショットは、[キャッシュ プロパティ] ダイアログ ボックスを示しています。

[キャッシュ プロパティ] ダイアログ ボックス

アセンブリのプロパティを表示するには

  • ビューア内でアセンブリ名を右クリックし、ショートカット メニューの [プロパティ] を選択します。

    アセンブリの名前、バージョン、カルチャ、公開キー、アセンブリが属するコードベース、アセンブリの最終変更日を示す [プロパティ] ウィンドウが表示されます。アセンブリのプロパティは、[ファイル] メニューからも表示できます。

次のスクリーンショットは、アセンブリ System.Data に関する [プロパティ] ウィンドウを示しています。

アセンブリの [プロパティ] ウィンドウ

アセンブリをキャッシュに追加するには

  • Windows エクスプローラを使用して、マニフェストを含むファイルをアセンブリ キャッシュのディレクトリへドラッグします。キャッシュに追加できるのは厳密な名前を持つアセンブリだけです。

.NET Framework SDK をお持ちの場合は、グローバル アセンブリ キャッシュ ツール (Gacutil.exe) を使用してアセンブリをキャッシュに追加することもできます。

アセンブリをキャッシュから削除するには

  • ビューア内でアセンブリ名を右クリックし、ショートカット メニューの [削除] を選択します。

アセンブリを削除するには、[ファイル] メニューから操作するか、.NET Framework SDK をお持ちの場合は Gacutil.exe を使用できます。

ビューアに関するヘルプを表示するには

  • F1 キーを使用するか、[ヘルプ] メニューの [ヘルプ トピック] を選択します。

このトピックについてのご提案や障害報告をお送りいただく場合は、こちらを参照してください。


shfusionhxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}
DropDown image

shfusionhxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

全文検索とインデックス デバッグ トピック グラフィック
このトピックについてのご提案や障害報告をお送りいただく場合は、こちらを参照してください。